%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Getting started

Glossary Item Box

This section will help you get started with Barcode4NET toolkit. It includes information on installing and configuring Barcode4NET toolkit, features and barcode symbologies included in the toolkit. It also presents information on licensing and deployment of Barcode4NET assemblies.

  • Installation
    Shows information on installing and configuring Barcode4NET toolkit to work with Visual Studio .Net 2003, Visual Studio .Net 2005 and SQL Reporting Services 2005.
  • What's included in the installation kit
    Shows the content of the installation kit at file level.
  • Features
    Shows the features matrix supported by Barcode4NET toolkit.
  • Barcode symbologies
    Shows the list of barcode symbologies that are supported by Barcode4NET toolkit.
  • Available editions
    Shows the complete list of Barcode4NET toolkit editions.
  • Licensing
    Shows the license agreement for Barcode4NET toolkit.
  • Deployment
    Provides information on how to deploy Barcode4NET assemblies with your applications.

© O2 Solutions. All Rights Reserved.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Installation

Glossary Item Box

This section describes the installation steps that need to be performed in order to have a fully working Barcode4NET installation on your computer. Some of the steps are automatic, but other need to be performed manually. The steps need to be performed in the order they are presented, but optional steps that do not apply to the edition you purchased may be skipped.

  1. Install Barcode4NET on your computer
    Shows the steps to perform for running the setup kit and installing the Barcode4NET toolkit on computer's disk.
  2. Add Barcode4NET to Visual Studio toolbox
    Shows how to install Barcode4NET components into Visual Studio toolbox.
  3. Add Barcode4NET to DataSources designer
    Shows how to install Barcode4NET components in order to be available at design time in DataSources designer.
  4. Configure Barcode4NET for SQL Server Reporting Services 2005
    Shows how to configure SQL Server Reporting Services 2005 to display Barcode4NET barcodes at design time and at runtime.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Installing Barcode4NET on your computer

Glossary Item Box

After downloading Barcode4NET toolkit from our website, run the setup package to install Barcode4NET files on your computer's disk. The setup process is very easy, just click Next in the setup dialogs and the toolkit will be installed on your computer's disk. By default the Barcode4NET toolkit is installed in <Program Files> folder, but this can be changed during the setup.

When the setup process has finished, perform the next steps in order to have a fully working Barcode4NET installation on your computer.

  1. Add Barcode4NET to Visual Studio toolbox
    Shows how to install Barcode4NET components into Visual Studio toolbox.
  2. Add Barcode4NET to DataSources designer
    Shows how to install Barcode4NET Windows Forms components in order to be available at design time in DataSources designer.
  3. Configure Barcode4NET for MSSQL Reporting Services 2005
    Shows how to configure MS SQL Reporting Services 2005 to display Barcode4NET barcodes at design time and at runtime.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Adding Barcode4NET to Visual Studio toolbox

Glossary Item Box

This section shows how to install the Barcode4NET controls into Visual Studio toolbox. Depending on the edition you purchased, you have to perform one or more of the steps below.

  1. Add Barcode4NET Windows Forms controls to Visual Studio toolbox.
    Shows how to install Barcode4NET Windows Forms controls into Visual Studio toolbox. Applies to Windows Forms & Mobile Devices or .Net editions.
  2. Add Barcode4NET Mobile Devices controls to Visual Studio toolbox.
    Shows how to install Barcode4NET Mobile Devices controls into Visual Studio toolbox. Applies to Windows Forms & Mobile Devices or .Net editions.
  3. Add Barcode4NET ASP.NET server controls to Visual Studio toolbox.
    Shows how to install Barcode4NET ASP.NET server controls into Visual Studio toolbox. Applies to ASP.NET & Reporting Services or .Net editions.
  4. Add Barcode4NET Reporting Services controls to Visual Studio toolbox.
    Shows how to install Barcode4NET Reporting Services controls into Visual Studio toolbox. Applies to ASP.NET & Reporting Services or .Net editions.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Adding Barcode4NET Windows Forms controls to Visual Studio toolbox

Glossary Item Box

Skip this section if you purchased ASP.NET & Reporting Services edition.

After Barcode4NET toolkit has been installed on your computer's disk, the Barcode4NET assemblies are located in the \bin folder of the installation location.

The \bin folder contains 2 folders, one for each supported .Net Framework. Net 1.1 folder contains the assemblies for .Net 1.1 and Visual Studio .Net 2003 and Net 2.0 folder contains the assemblies for .Net 2.0 and Visual Studio .Net 2005. The screenshots below show Visual Studio .Net 2005, but the process is the same for Visual Studio .Net 2003.
  1. Start Visual Studio .Net 2005 (or 2003) and create a new Windows Forms application. Make sure that the application form is in design mode and the components toolbox is displayed. Right click on the toolbox and select Add tab from the menu.

    Enlarge Click to enlarge
  2. Type "Barcode4NET" as tab name and press Enter.

    Enlarge Click to enlarge
  3. Right click on Barcode4NET tab, select Choose items from the menu and Choose toolbox items dialog will be displayed. Make sure .NET Framework Components tab is selected.

    Enlarge Click to enlarge
    Select BarcodeView and BarcodeTextBox controls in the list. If they are not displayed in the list, click Browse button and locate Barcode4NET.Windows.dll assembly on your computer's disk.
    If you are adding Barcode4NET to Visual Studio .Net 2003 toolbox, then locate the Barcode4NET Windows assembly in bin\net 1.1\ folder of the installation location. If you are adding Barcode4NET to Visual Studio .Net 2005 toolbox, then locate the Barcode4NET Windows assembly in bin\net 2.0\ folder of the installation location.
    Click OK.
  4. BarcodeView and BarcodeTextBox controls are now available in the toolbox.

    Enlarge Click to enlarge


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Adding Barcode4NET Mobile Devices controls to Visual Studio toolbox

Glossary Item Box

Skip this section if you purchased the ASP.NET & Reporting Services edition.

After Barcode4NET toolkit has been installed on your computer's disk, the Barcode4NET assemblies are located in the \bin folder of the installation location.

The \bin folder contains 2 folders, one for each supported .Net Framework. Net 1.1 folder contains the assemblies for .Net 1.1 and Visual Studio .Net 2003 and Net 2.0 folder contains the assemblies for .Net 2.0 and Visual Studio .Net 2005. The screenshots below show Visual Studio .Net 2005, but the process is the same for Visual Studio .Net 2003.
  1. Start Visual Studio .Net 2005 (or 2003) and create a new Windows Forms application. Make sure that the application form is in design mode and the components toolbox is displayed. Right click on the toolbox and select Add tab from the menu.

    Enlarge Click to enlarge
  2. Type "Barcode4NET" as tab name and press Enter.

    Enlarge Click to enlarge
  3. Right click on Barcode4NET tab, select Choose items from the menu and Choose toolbox items dialog will be displayed. Make sure .NET Framework Components tab is selected.

    Enlarge Click to enlarge
    Select BarcodeView control (located in Barcode4NET.Windows.CF assembly) in the list. If it is not displayed in the list, click Browse button and locate Barcode4NET.Windows.CF.dll assembly on your computer's disk if you are using Visual Studio .Net 2005, or locate Barcode4NET.Windows.Design.CF.dll if you are using Visual Studio .Net 2003.
    If you are adding Barcode4NET to Visual Studio .Net 2003 toolbox, then locate the Barcode4NET Windows assembly in bin\net 1.1\ folder of the installation location. If you are adding Barcode4NET to Visual Studio .Net 2005 toolbox, then locate the Barcode4NET Windows assembly in bin\net 2.0\ folder of the installation location.
    Click OK.
  4. BarcodeView control is now available in the toolbox.

    Enlarge Click to enlarge


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Adding Barcode4NET ASP.NET controls to Visual Studio toolbox

Glossary Item Box

Skip this section if you purchased Windows Forms & Mobile Devices edition.

After Barcode4NET toolkit has been installed on your computer's disk, the Barcode4NET assemblies are located in the \bin folder of the installation location.

The \bin folder contains 2 folders, one for each supported .Net Framework. Net 1.1 folder contains the assemblies for .Net 1.1 and Visual Studio .Net 2003 and Net 2.0 folder contains the assemblies for .Net 2.0 and Visual Studio .Net 2005. The screenshots below show Visual Studio .Net 2005, but the process is the same for Visual Studio .Net 2003.
  1. Start Visual Studio .Net 2005 (or 2003) and create a new Web application or web site. Make sure that the application form is in design mode and the components toolbox is displayed. Right click on the toolbox and select Add tab from the menu.

    Enlarge Click to enlarge
  2. Type "Barcode4NET" as tab name and press Enter.

     Enlarge Click to enlarge
  3. Right click on Barcode4NET tab, select Choose items from the menu and Choose toolbox items dialog will be displayed. Make sure .NET Framework Components tab is selected.

     Enlarge Click to enlarge
    Select BarcodeView control in the list. If it is not displayed in the list, click Browse button and locate Barcode4NET.Web.dll assembly on your computer's disk.
    If you are adding Barcode4NET to Visual Studio .Net 2003 toolbox, then locate the Barcode4NET Windows assembly in bin\net 1.1\ folder of the installation location. If you are adding Barcode4NET to Visual Studio .Net 2005 toolbox, then locate the Barcode4NET Windows assembly in bin\net 2.0\ folder of the installation location.
    Click OK.
  4. BarcodeView control is now available in the toolbox.

    Enlarge Click to enlarge


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Adding Barcode4NET Reporting Services controls to Visual Studio toolbox

Glossary Item Box

Skip this section if you purchased the Windows Forms & Mobile Devices edition.
Before adding the Barcode4NET Reporting Services design time controls to Visual Studio toolbox, you need to configure MS SQL Reporting Services 2005 to work with Barcode4NET.

After Barcode4NET toolkit has been installed on your computer's disk, the Barcode4NET assemblies are located in the \bin folder of the installation location.

The \bin folder contains 2 folders, one for each supported .Net Framework. Net 1.1 folder contains the assemblies for .Net 1.1 and Visual Studio .Net 2003 and Net 2.0 folder contains the assemblies for .Net 2.0 and Visual Studio .Net 2005. Design time support for MS SQL Reporting Services 2005 is available only using Visual Studio .Net 2005.
  1. Start Visual Studio .Net 2005 and create a new Report Server project.

    Enlarge Click to enlarge
  2. Make sure that the report is in design mode and the components toolbox is displayed. Right click on Report Items tab and select Choose items from the menu.

    Enlarge Click to enlarge
  3. When Choose toolbox items dialog is displayed, make sure .NET Framework Components tab is selected.

    Enlarge Click to enlarge
    Select Barcode control in the list. If it is not displayed in the list, click Browse button and locate Barcode4NET.RS.Design.dll assembly on your computer's disk.
    The Barcode4NET Reporting Services design time assembly is located in <VSNet2005InstallPath>\Common7\IDE\PrivateAssemblies\ folder, where <VSNet2005InstallPath> is the location where Visual Studio .Net 2005 is installed.
    IMPORTANT: In order for Barcode4NET to work correctly in Report Designer, the Barcode4NET Reporting Services design time assembly must be added to toolbox from <VSNet2005InstallPath>\Common7\IDE\PrivateAssemblies\ folder and NOT from <Barcode4NETInstallPath>\Bin\Net 2.0\ folder.
    Click OK.
  4. Barcode control is now available in the toolbox.

    Enlarge Click to enlarge


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Adding Barcode4NET to Data Sources designer

Glossary Item Box

This section applies to any of the Windows Forms & Mobile Devices or .Net editions.

After Barcode4NET toolkit has been installed on your computer's disk, the Barcode4NET assemblies are located in the \bin folder of the installation location.

The \bin folder contains 2 folders, one for each supported .Net Framework. Net 1.1 folder contains the assemblies for .Net 1.1 and Visual Studio .Net 2003 and Net 2.0 folder contains the assemblies for .Net 2.0 and Visual Studio .Net 2005. Support for DataSources designer is available only in Visual Studio .Net 2005.
  1. Start Visual Studio .Net 2005 and create a new Windows Forms application.

    Enlarge Click to enlarge
  2. Display the Data Sources window if it is not visible.

    Enlarge Click to enlarge
  3. Click on Add new Data Source to add a new data source to the project.

     Enlarge Click to enlarge
    This sample project used vEmployee view available in AdventureWorks sample database that came with MS SQL Server 2005.
  4. Select any string field, click on the drop down arrow and then select Customize....

    Enlarge Click to enlarge
  5. In Options dialog make sure that Data UI Customization is selected and String is selected in Data type combobox. Select BarcodeView and BarcodeTextBox controls in Associated controls listbox.

    Enlarge Click to enlarge
    Click OK.
  6. BarcodeView and BarcodeTextBox controls can now be associated with any string field.

    Enlarge Click to enlarge


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Configuring SQL Reporting Services to work with Barcode4NET

Glossary Item Box

In order for SQL Reporting Services to display barcodes created with Barcode4NET, several configuration files need to be updated and Barcode4NET assemblies need to be copied to several locations. SQL Reporting Services 2000 requires 2 configuration files to be updated, while SQL Reporting Services 2005 requires 4 configuration files to be updated. The list below shows the configuration files that need to be updated, along with the changes that need to be performed, for each SQL Reporting Services version.

  • SQL Reporting Services 2000

- rssrvpolicy.config - Add the following inside the innermost <CodeGroup> element:

<CodeGroup class="UnionCodeGroup" version="2" PermissionSetName="FullTrust" Name="Barcode4NET" Description="This code group grants FullTrust to Barcode4NET.dll assembly.">
<IMembershipCondition class="StrongNameMembershipCondition" version="2" PublicKeyBlob="00240000048000009400000006020000002400005253413100040000010001003fae1daf0d6dcc969069ced0ebc2d71fabda6a00d750fe1e0447e52e3b899a64355e28d01598d62cf569d888472ab48e4929360b19c774ec0002af83d3352b1ad9c4d36da271e83c0c0d9dcbb22e0bc39a2929446518e66d65d19105203628f47e293ded809198d35068344a8919905aa5f1b82816a7b8b879ee895869aaa2ac" />
</CodeGroup>
This file is located in <SqlReportingServices2000InstallPath>\MSSQL\Reporting Services\ReportServer\rssrvpolicy.config, usually C:\Program Files\Microsoft SQL Server\MSSQL\Reporting Services\ReportServer\rssrvpolicy.config.

- rspreviewpolicy.config - Add the following inside the innermost <CodeGroup> element:
<CodeGroup class="UnionCodeGroup" version="2" PermissionSetName="FullTrust" Name="Barcode4NET" Description="This code group grants FullTrust to Barcode4NET.dll assembly.">
<IMembershipCondition class="StrongNameMembershipCondition" version="2" PublicKeyBlob="00240000048000009400000006020000002400005253413100040000010001003fae1daf0d6dcc969069ced0ebc2d71fabda6a00d750fe1e0447e52e3b899a64355e28d01598d62cf569d888472ab48e4929360b19c774ec0002af83d3352b1ad9c4d36da271e83c0c0d9dcbb22e0bc39a2929446518e66d65d19105203628f47e293ded809198d35068344a8919905aa5f1b82816a7b8b879ee895869aaa2ac" />
</CodeGroup>
This file is located in <SqlReportingServices2000InstallPath>\80\Tools\Report Designer\rspreviewpolicy.config, usually C:\Program Files\Microsoft SQL Server\80\Tools\Report Designer\rspreviewpolicy.config.

  • SQL Reporting Services 2005

- rssrvpolicy.config - Add the following inside the innermost <CodeGroup> element:

<CodeGroup class="UnionCodeGroup" version="2" PermissionSetName="FullTrust" Name="Barcode4NET" Description="This code group grants FullTrust to Barcode4NET.RS.dll assembly.">
<IMembershipCondition class="StrongNameMembershipCondition" version="2" PublicKeyBlob="0024000004800000940000000602000000240000525341310004000001000100e3b54f9ca0f68f94a88fc162a5e0f7e7b01088eb03b98a3bc9f3a071d6592dd9414258dd116b2511b2bc5527368e8f957915a3c268ff4ee82dee57f7a03c92171de7a75c3f2df8a1bc65acc046fa886b5659edf2c52d1b1d2bbdd43f01207ddd57cecdbbceb0e208a6a789c004a248572565fbad80a99a4976523168d74d519d" />
</CodeGroup>
This file is located in <SqlReportingServices2005InstallPath>\MSSQL.3\Reporting Services\ReportServer\rssrvpolicy.config, usually C:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer\rssrvpolicy.config.

- rsreportserver.config - Add the following to inside the <Extensions> element:

<ReportItems>
<ReportItem Name="Barcode4NET" Type="O2S.Barcode4NET.ReportingServices.BarcodeItem, Barcode4NET.RS" />
</ReportItems>

If the <ReportItems> element already exists, then add only the <ReportItem> element inside it.
This file is located in <SqlReportingServices2005InstallPath>\MSSQL.3\Reporting Services\ReportServer\rsreportserver.config, usually C:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer\rsreportserver.config.

- rspreviewpolicy.config - Add the following inside the innermost <CodeGroup> element:
<CodeGroup class="UnionCodeGroup" version="2" PermissionSetName="FullTrust" Name="Barcode4NET" Description="This code group grants FullTrust to Barcode4NET.RS.dll assembly.">
<IMembershipCondition class="StrongNameMembershipCondition" version="2" PublicKeyBlob="0024000004800000940000000602000000240000525341310004000001000100e3b54f9ca0f68f94a88fc162a5e0f7e7b01088eb03b98a3bc9f3a071d6592dd9414258dd116b2511b2bc5527368e8f957915a3c268ff4ee82dee57f7a03c92171de7a75c3f2df8a1bc65acc046fa886b5659edf2c52d1b1d2bbdd43f01207ddd57cecdbbceb0e208a6a789c004a248572565fbad80a99a4976523168d74d519d" />
</CodeGroup>

This file is located in <VisualStudioNet2005InstallPath>\Common7\IDE\PrivateAssemblies\rspreviewpolicy.config, usually C:\Program Files\Visual Studio .Net 2005\Common7\IDE\PrivateAssemblies\rspreviewpolicy.config.

- rsreportdesigner.config - Add the following inside the <Extensions> element:
<ReportItems>
<ReportItem Name="Barcode4NET" Type="O2S.Barcode4NET.ReportingServices.BarcodeItem, Barcode4NET.RS" />
</ReportItems>
<ReportItemDesigner>
<ReportItem Name="Barcode4NET" Type="O2S.Barcode4NET.ReportingServices.Design.BarcodeDesigner, Barcode4NET.RS.Design" />
</ReportItemDesigner>
If the <ReportItems> element already exists, then add only the <ReportItem> element inside it. If the <ReportItemDesigner> element already exists, then add only the <ReportItem> element inside it.
This file is located in <VisualStudioNet2005InstallPath>\Common7\IDE\PrivateAssemblies\rsreportdesigner.config, usually C:\Program Files\Visual Studio .Net 2005\Common7\IDE\PrivateAssemblies\rsreportdesigner.config.

Sample configuration files

Barcode4NET toolkit includes sample configuration files that already include the Barcode4NET related settings. These files are located in <Barcode4NETInstallPath>\Samples\Reporting Services\Configuration. These sample files are provided just as helper files to see exactly where the Barcode4NET settings have to be inserted into real configuration files, and they should not be used to overwrite the real SQL Reporting Services configuration files.

SQL Reporting Services configuration utility

Barcode4NET toolkit includes a configuration application, Barcode4NET.RSConfig.exe (located in Bin\ folder) that performs automatically all the configurations above.

Enlarge Click to enlarge

Each field corresponds to one of the files above. Fill in the actual path for each configuration file and then press Add Barcode4NET to Reporting Services config files button to configure SQL Reporting Services. If you want to remove Barcode4NET from sQL Reporting Services configuration files, fill in the actual path for each configuration file and then press Remove Barcode4NET from Reporting Services config files. After each operation the application displays a log of all performed changes.

Barcode4NET assemblies and SQL Reporting Services

The following files need to be copied in several locations in order for SQL Reporting Services to use them:

  • SQL Reporting Services 2000

Bin\Net 1.1\Barcode4NET.dll needs to be copied to <SqlReportingServices2000InstallPath>\MSSQL\Reporting Services\ReportServer\Bin\. It also has to be registered in GAC.

  • SQL Reporting Services 2005

Bin\Net 2.0\Barcode4NET.dll needs to be copied to <SqlReportingServices2005InstallPath>\MSSQL.3\Reporting Services\ReportServer\Bin\.
Bin\Net 2.0\Barcode4NET.RS.dll needs to be copied to <SqlReportingServices2005InstallPath>\MSSQL.3\Reporting Services\ReportServer\Bin\.
Bin\Net 2.0\Barcode4NET.dll needs to be copied to <VisualStudioNet2005InstallPath>\Common7\IDE\PrivateAssemblies\.
Bin\Net 2.0\Barcode4NET.RS.dll needs to be copied to <VisualStudioNet2005InstallPath>\Common7\IDE\PrivateAssemblies\.
Bin\Net 2.0\Barcode4NET.RS.Design.dll needs to be copied to <VisualStudioNet2005InstallPath>\Common7\IDE\PrivateAssemblies\.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
What's included in the installation kit

Glossary Item Box

After installing Barcode4NET toolkit, the following files and folders will be present on your computer's disk:

Bin\net 1.1\ - Barcode4NET assemblies for .Net Framework 1.1
Bin\net 1.1\barcode4net.dll - Barcode4NET class library with support for 1D and 2D barcodes.
Bin\net 1.1\barcode4net.windows.dll - BarcodeView and BarcodeTextBox Windows Forms controls.
Bin\net 1.1\barcode4net.cf.dll - Barcode4NET class library with support for 1D and 2D barcodes for .Net Compact Framework.
Bin\net 1.1\barcode4net.windows.cf.dll - BarcodeView Mobile Device runtime control for .Net Compact Framework.
Bin\net 1.1\barcode4net.windows.design.cf.dll - BarcodeView Mobile Device design-time control for .Net Compact Framework.
Bin\net 1.1\barcode4net.web.dll - BarcodeView ASP.NET server control.
Bin\net 2.0\ - Barcode4NET assemblies for .Net Framework 2.0
Bin\net 2.0\barcode4net.dll - Barcode4NET class library with support for 1D and 2D barcodes.
Bin\net 2.0\barcode4net.windows.dll - BarcodeView and BarcodeTextBox Windows Forms controls.
Bin\net 2.0\barcode4net.cf.dll - Barcode4NET class library with support for 1D and 2D barcodes for .Net Compact Framework.
Bin\net 2.0\barcode4net.windows.cf.dll - BarcodeView Mobile Device control for .Net Compact Framework.
Bin\net 2.0\barcode4net.web.dll - BarcodeView ASP.NET server control.
Bin\net 2.0\barcode4net.rs.dll - BarcodeView Reporting Services runtime control.
Bin\net 2.0\barcode4net.rs.design.dll - BarcodeView Reporting Services design time control.

Help - Barcode4NET help files

Samples\Windows Forms - Windows Forms samples
Samples\ASP.NET - ASP.NET samples
Samples\Mobile Devices - Mobile Devices samples


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Features

Glossary Item Box

Barcode4NET is a .NET toolkit for adding barcode display and print support in .NET applications. It includes several controls and class libraries targeted for all Microsoft .NET platforms: desktop, web, mobile devices and Reporting Services. Design time support is provided for all these platforms. The toolkit supports a wide range for both 1D and 2D barcode symbologies, it includes our own developed barcode rendering engine and it does not rely on any barcode fonts for rendering the barcodes. The barcodes can be exported in several raster and vector image formats, for later use in other applications.

The main features of Barcode4NET toolkit are outlined below.

 | Platforms
 | Windows Forms & Mobile devices | ASP.NET & Reporting Services | .NET
Barcode features
1D symbologies | Yes | Yes | Yes
2D symbologies | Yes | Yes | Yes
Export barcodes as raster images (Bmp, Gif, Jpeg, Png, Tiff)1 | Yes | Yes | Yes
Export barcodes as vector images (Emf, Eps, Pdf, Ps, Svg)2 | Yes | Yes | Yes
Rotate barcodes with 0, 90, 180 and 270 degrees | Yes | Yes | Yes
Automatic data validation | Yes | Yes | Yes
Automatic checksum calculation | Yes | Yes | Yes
Design time support
Visual Studio .NET 2003 WinForms & WebForms designer | Yes | Yes | Yes
Visual Studio .NET 2005 WinForms & WebForms designer | Yes | Yes | Yes
Visual Studio .NET 2005 Data binding designer | Yes |  | Yes
Visual Studio .NET 2005 Report designer |  | Yes | Yes
SQL Server 2005 Business Intelligence Development Studio Report Designer |  | Yes | Yes
Intellisense support in source code view | Yes | Yes | Yes
Intellisense support in HTML code view |  | Yes | Yes
Package content
BarcodeView WinForms control | Yes |  | Yes
BarcodeView WinForms control for .NetCF | Yes |  | Yes
BarcodeTextBox WinForms control | Yes |  | Yes
BarcodeView ASP.NET control |  | Yes | Yes
BarcodeView Reporting Services control |  | Yes | Yes
Barcode class library licensed for WinForms and console applications, windows services and local reports | Yes |  | Yes
Barcode class library licensed for ASP.NET applications and web services, SQL Reporting Services 2000 & 2005 |  | Yes | Yes
Integrated help system | Yes | Yes | Yes
Strong named assemblies for .Net 1.1 and .Net 2.0 | Yes | Yes | Yes
Licensing
Per developer licensing | Yes | Yes | Yes
Royalty free distribution | Yes | Yes | Yes
1 not supported on .Net Compact Framework versions. 2 only Eps, Pdf, Ps, Svg supported on .Net Compact Framework versions.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Barcode symbologies

Glossary Item Box

Barcode4NET supports both 1D and 2D barcode symbologies. 1D symbologies are also called linear or unidimensional symbologies and 2D symbologies are also called bidimensional symbologies.
The following barcode symbologies are supported by Barcode4NET toolkit:

1D Symbologies
Codabar | Codabar
 | Also known as: USD-4 | NW-7 | Code 2 of 7
 | Codabar symbology was developer by Pitney Bowes, Inc in 1972. It is a discrete and self-checking symbology that supports 16 different characters for encoding. Because it is a self-checking symbology, it does not have a checksum character. EnableCheckSum and DisplayCheckSum properties have no effect on this symbology. Codabar symbology uses start and stop characters to mark the beginning and the end of the barcode. The start/stop characters are not returned by barcode reader when the barcode is scanned. Codabar symbology is used by U.S. blood banks, photo labs, and on FedEx airbills.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9 - $ : / . +
 | Required data length: Variable.
Code 11 | Code 11
 | Also known as: USD-8
 | Code 11 is a high density numeric only symbology. The symbology is discrete and is able to encode the numbers 0 through 9, the dash symbol (-) and start/stop characters. Code 11 symbology uses start and stop characters to mark the beginning and the end of the barcode. The start/stop characters are not returned by barcode reader when the barcode is scanned. This symbology is not very secure, printing defects can convert one character into another valid character. Because of this, Code 11 supports one or two check characters, depending on data length. If data length is less than 10, only one check character is used, otherwise two check characters are used. Barcode4NET automatically computes the check characters if EnableCheckSum property is true. Code 11 symbology is used primarily in labeling telecommunications equipment.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9 -
 | Required data length: Variable.
Code 128A | Code 128A
 | Code 128A is a high density alphanumeric symbology that uses codeset A of Code 128. The symbology is self-checking and also requires check digit (EnableCheckSum property is true by default and the check character is computed automatically) for greater security. Code 128A symbology is used primarily in applications where large amounts of data must be encoded in a small space.
 | Allowed characters: NUL (0x00) SOH (0x01) STX (0x02) ETX (0x03) EOT (0x04) ENQ (0x05) ACK (0x06) BEL (0x07) BS (0x08) HT (0x09) LF (0x0A) VT (0x0B) FF (0x0C) CR (0x0D) SO (0x0E) SI (0x0F) DLE (0x10) DC1 (0x11) DC2 (0x12) DC3 (0x13) DC4 (0x14) NAK (0x15) SYN (0x16) ETB (0x17) CAN (0x18) EM (0x19) SUB (0x1A) ESC (0x1B) FS (0x1C) GS (0x1D) RS (0x1E) US (0x1F) SPACE (0x20) ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _
 | Required data length: Variable.
Code 128B | Code 128B
 | Code 128B is a high density alphanumeric symbology that uses codeset B of Code 128. The symbology is self-checking and also requires check digit (EnableCheckSum property is true by default and the check character is computed automatically) for greater security. Code 128B symbology is used primarily in applications where large amounts of data must be encoded in a small space.
 | Allowed characters: SPACE (0x20) ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _ ` a b c d e f g h i j k l m n o p q r s t u v w x y z { | } ~ DEL (\x7F)
 | Required data length: Variable.
Code 128C | Code 128C
 | Code 128C is a high density numberic only symbology that uses codeset C of Code 128. The symbology is self-checking and also requires check digit (EnableCheckSum property is true by default and the check character is computed automatically) for greater security. Code 128C symbology is used primarily in applications where large amounts of numeric data must be encoded in a small space, because each pair of digits is encoded as a single barcode symbol.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
Code 2 of 5 | Code 2 of 5
 | Also known as: Standard 2 of 5 | Industrial 2 of 5
 | Code 2 of 5 is a low density numeric only symbology. It has been in use since 1960. This symbology may include an optional check character. Barcode4NET automatically computes the check character if EnableCheckSum property is true. A newer version of this symbology is Code 2 of 5 Interleaved which achieves a higher density. Code 2 of 5 is used for sequentially numbering airline tickets, for photofinishing and warehouse sorting industries.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
Code 2 of 5 Interleaved | Code 2 of 5 Interleaved
 | Also known as: Interleaved 2 of 5
 | Code 2 of 5 Interleaved is a high density numeric only symbology and it is a newer version of Code 2 of 5. This symbology may include an optional check character. Barcode4NET automatically computes the check character if EnableCheckSum property is true. Code 2 of 5 is used in distribution and warehouse industry.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
Code 39 | Code 39
 | Also known as: USD-3 | Code 3 of 9 | LOGMARS
 | Code 39 is the first developed barcode symbology. It is self checking and may include an optional check character. Barcode4NET automatically computes the check character if EnableCheckSum property is true. Code 39 is used by the United States Department of Defense, by the Health Industry Bar Code Council (HIBCC) and also in non-retail environments.
 | Allowed characters: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
 | Required data length: Variable.
Code 39 Extended | Code 39 Extended
 | Also known as: USD-3 | Code 3 of 9 | LOGMARS
 | Code 39 Extended is based on Code 39 and supports all 128 ASCII characters.
 | Allowed characters: All 128 ASCII characters.
 | Required data length: Variable.
Code 93 | Code 93
 | Also known as: USS-93
 | Code 93 symbology was designed to improve and complement the Code 39 symbology. It supports 47 different characters to encode. Two check characters are required (EnableCheckSum property is true by default) and they are computed automatically.
 | Allowed characters: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
 | Required data length: Variable.
Code 93 Extended | Code 93 Extended
 | Also known as: USS-93
 | Code 93 Extended is based on Code 93 and supports all 128 ASCII characters.
 | Allowed characters: All 128 ASCII characters.
 | Required data length: Variable.
COOP 2 of 5 | COOP 2 of 5
 | Also known as: COOP 25
 | COOP 2 of 5 is a numeric only symbology. It is self checking and it may include an optional check character. Barcode4NET automatically computes the check character if EnableCheckSum property is true. COOP 2 of 5 is used for management of physical distribution.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
EAN-13 | EAN-13
 | EAN-13 is a numeric only symbology based on UPC-A standard (it is a super set of UPC-A). It is self checking and it requires a check character. Barcode4NET automatically computes the check character regardless of EnableCheckSum property and the check character is always displayed regardless of DisplayCheckSum property. EAN-13 barcodes allow a secondary barcode, called supplement, to be added to main barcode. Barcode4NET supports both 2 and 5 digits supplement. EAN-13 was implemented by the International Article Numbering Association (EAN) in Europe and it uses 2 digits for the number system code.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 12 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
EAN-8 | EAN-8
 | EAN-8 is a numeric only symbology, the "short" version of EAN-13 designed for small packages. It is self checking and it requires a check character. Barcode4NET automatically computes the check character regardless of EnableCheckSum property and the check character is always displayed regardless of DisplayCheckSum property. EAN-8 barcodes allow a secondary barcode, called supplement, to be added to main barcode. Barcode4NET supports both 2 and 5 digits supplement.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 7 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
IATA 2 of 5 | IATA 2 of 5
 | IATA 2 of 5 is a numeric only symbology. It is self checking and a check character is always required. Barcode4NET automatically computes the check character if EnableCheckSum property is true (this is default). IATA 2 of 5 is used by IATA (International Air Transport Association) for the management of air cargo.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: 16 digits.
ISBN | ISBN
 | ISBN (International Standard Book Numbering) is a EAN-13 symbology that uses the number system 978. ISBN barcodes allow a secondary barcode, called supplement, to be added to main barcode. Barcode4NET supports both 2 and 5 digits supplement. This symbology is used for labeling books.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 9 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
ISMN | ISMN
 | ISMN (International Standard Music Number) is a EAN-13 symbology that uses the number system 979. ISMN barcodes allow a secondary barcode, called supplement, to be added to main barcode. Barcode4NET supports both 2 and 5 digits supplement. This symbology is used for labeling music casettes and CDs.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 9 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
ISSN | ISSN
 | ISSN (International Standard Serial Number for Periodicals) is a EAN-13 symbology that uses the number system 977. ISSN barcodes allow a secondary barcode, called supplement, to be added to main barcode. Barcode4NET supports both 2 and 5 digits supplement. This symbology is used for labeling periodicals and newspapers.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 9 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
JAN-13 | JAN-13
 | JAN-13 is a EAN-13 symbology that uses the number system 49. JAN-13 barcodes allow a secondary barcode, called supplement, to be added to main barcode. Barcode4NET supports both 2 and 5 digits supplement. This symbology is used in Japan in retail applications.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 10 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
Matrix 2 of 5 | Matrix 2 of 5
 | Matrix 2 of 5 is a numeric only symbology. It is self checking and an optional check character may be included. Barcode4NET automatically computes the check character if EnableCheckSum property is true.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
MSI/Plessey | MSI/Plessey
 | Also known as: Modified Plessey
 | MSI/Plessey is a numeric only symbology. It was developed by MSI Data Corporation, based on the original Plessey Code. It is not self checking but an optional check character may be included. Barcode4NET automatically computes the check character if EnableCheckSum property is true. This symbology is used primarily to mark retail shelves for inventory control.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
Planet | Planet
 | Planet is a height modulated numeric only symbology, it is the inverse of PostNet symbology. A check character is required and it is computed automatically regardless of EnableCheckSum property. This symbology is used in combination with PostNet by USPS to track customer's piece of mail.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: 11 or 13 digits.
Postnet | Postnet
 | Postnet is a height modulated numeric only symbology. It was created by USPS to allow faster sorting and routing of mail. A check character is required and it is computed automatically regardless of EnableCheckSum property. Postnet barcodes can encode 5 digits (ZIP code), 9 digits (ZIP+4) or 11 digits (full delivery point). This symbology is used by USPS to allow faster sorting and routing of mail.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: 5, 9 or 11 digits.
RM4SCC | RM4SCC
 | RM4SCC (Royal Mail 4-state Customer Code) is a height modulated symbology. A check character is required and it is computed automatically regardless of EnableCheckSum property. This symbology is used by UK Royal Mail to allow faster sorting and routing of mail.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
 | Required data length: Variable.
SCC-14 | SCC-14
 | SCC-14 (Shipping Container Code 14) is a numeric only symbology based on Code 128C. It is in fact a Code 128C barcode with a fixed data format. A check character is required and it is computed automatically regardless of EnableCheckSum property. SCC-14 is part of the larger UCC/EAN-128 specification with application identifier 01, and it is a shorter version of SSCC-18 symbology. Shipping Container Code is used to identify individual shipping containers. This is used, generally, to establish a number that is unique worldwide to track a specific container.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: 13 digits.
SSCC-18 | SSCC-18
 | SSCC-18 (Serial Shipping Container Code 18) is a numeric only symbology based on Code 128C. It is in fact a Code 128C barcode with a fixed data format. A check character is required and it is computed automatically regardless of EnableCheckSum property. SCC-18 is part of the larger UCC/EAN-128 specification with application identifier 00. Serial Shipping Container Code is used to identify individual shipping containers. This is used, generally, to establish a number that is unique worldwide to track a specific container.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: 17 digits.
UPC-A | UPC-A
 | UPC-A is a numeric only symbology. It is self checking and it requires a check character. Barcode4NET automatically computes the check character regardless of EnableCheckSum property and the check character is always displayed regardless of DisplayCheckSum property. UPC-A barcodes allow a secondary barcode, called supplement, to be added to main barcode. Barcode4NET supports both 2 and 5 digits supplement. UPC-A is widely used in United States in retail.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 11 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
UPC-E | UPC-E
 | UPC-E is a numeric only symbology, a shorter version of UPC-A symbology. It is self checking and it requires a check character. Barcode4NET automatically computes the check character regardless of EnableCheckSum property and the check character is always displayed regardless of DisplayCheckSum property. UPC-E barcodes allow a secondary barcode, called supplement, to be added to main barcode. Barcode4NET supports both 2 and 5 digits supplement. UPC-E is widely used in United States in retail and it is used instead of UPC-A for products with very small packaging.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 7 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
2D Symbologies
CODABLOCK F | CODABLOCK F
 | CODABLOCK F is is multirow symbology, a 2D version of Code 128. It was created at ICS Identcode-Systeme, being invented by Heinrich Oehlmann.
 | Allowed characters: All 256 ISO 8859-1 characters.
 | Required data length: Variable, up to 2725 characters.
Code 16K | Code 16K
 | Code 16K is is multirow symbology based on Code 128. It was created by Ted Williams in 1989.
 | Allowed characters: All 256 ISO 8859-1 characters.
 | Required data length: Variable, up to 77 ASCII characters or 154 numeric characters.
DataMatrix | DataMatrix
 | DataMatrix is a 2D matrix symbology made up of square modules arranged within a perimeter finder pattern. A limited set of symbol sizes, both square and rectangular, is available, together with a fixed level of error correction for each symbol size. Barcode4NET uses ECC200 version of DataMatrix symbology.
 | Allowed characters: All 256 ISO 8859-1 characters.
 | Required data length: Variable, up to 1556 bytes or 2335 alphanumeric characters or 3116 numeric characters.
MicroPDF417 | MicroPDF417
 | MicroPDF417 is a multi-row symbology, derived from and closely based on PDF417. MicroPDF417 is designed for applications with a need for improved area efficiency but without the requirement for PDF417's maximum data capacity. A limited set of symbol sizes is available, together with a fixed level of error correction for each symbol size.
 | Allowed characters: All 256 ISO 8859-1 characters.
 | Required data length: Variable, up to 150 bytes or 250 alphanumeric characters or 366 numeric characters.
PDF417 | PDF417
 | PDF417 is a multi-row, variable-length symbology that offers high data capacity and error correction capabilities. Up to 2700 characters can be encoded depending on the selected data compaction mode. Barcode4NET supports all 3 data compaction modes: Text, Byte and Numeric.
 | Allowed characters: All 256 ISO 8859-1 characters.
 | Required data length: Variable, up to 1108 bytes or 1850 alphanumeric characters or 2710 numeric characters.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Available editions

Glossary Item Box

Barcode4NET toolkit has 3 editions, designed to fit every need and budget. Here it is the complete list along with the content included in each edition.

Barcode4NET for Windows Forms & Mobile Devices

  • 28 1D & 5 2D barcode symbologies
  • BarcodeView WinForms control
  • BarcodeView WinForms control for .NetCF
  • BarcodeTextBox WinForms control
  • Barcode class library licensed for WinForms and console applications, windows services and WinForms local reports
  • Integrated help system
  • Strong named assemblies for .Net 1.1 and .Net 2.0
  • Per developer licensing with royalty free distribution
  • Price starts at US$499/license

Barcode4NET for ASP.NET & Reporting Services

  • 28 1D & 5 2D barcode symbologies
  • BarcodeView ASP.NET control
  • BarcodeView Reporting Services control
  • Barcode class library licensed for ASP.NET applications and web services, SQL Reporting Services 2000 & 2005
  • Integrated help system
  • Strong named assemblies for .Net 1.1 and .Net 2.0
  • Per developer licensing with royalty free distribution
  • Price starts at US$499/license

Barcode4NET for .NET

  • 28 1D & 5 2D barcode symbologies
  • BarcodeView WinForms control
  • BarcodeView WinForms control for .NetCF
  • BarcodeTextBox WinForms control
  • BarcodeView ASP.NET control
  • BarcodeView Reporting Services control
  • Barcode class library licensed for WinForms and console applications, windows services and local reports
  • Barcode class library licensed for ASP.NET applications and web services, SQL Reporting Services 2000 & 2005
  • Integrated help system
  • Strong named assemblies for .Net 1.1 and .Net 2.0
  • Per developer licensing with royalty free distribution
  • Price starts at US$799/license


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Licensing

Glossary Item Box

The Barcode4NET toolkit is licensed per developer. One license can be used on multiple computers as long as it is used by the same developer, and it can not be used concurrently or shared by other developers.
Any Barcode4NET license lets you distribute the runtime components with your application inside your organization on unlimited number of desktop computers and servers.
If you want to distribute Barcode4NET runtime components with your application to your customers, you need to purchase a Client Redistribution License. A single client redistribution license allows you to distribute Barcode4NET with your applications to an unlimited number of customers.
This license does NOT ALLOW you to distribute the Barcode4NET library for use in development. This requires an OEM distribution license. If you want to do so, please contact us.

LICENSE AGREEMENT

VERY IMPORTANT - READ CAREFULLY:

This O2 Solutions Software License Agreement (hereinafter, this "LICENSE") is a legal agreement between you (either an individual or a single entity) and O2 Solutions, SRL. ("O2 Solutions"), for the software containing this LICENSE which has been obtained through O2 Solutions or its authorized distributor.

  1. OWNERSHIP; LICENSE GRANT
    This is a license agreement and NOT an agreement for sale. O2 Solutions continues to own the copy of the SOFTWARE contained on the disk and all other copies that you are authorized by this LICENSE to make. Your rights to the SOFTWARE are specified in this LICENSE, and O2 Solutions retains all rights not expressly granted to you in this LICENSE. O2 Solutions hereby grants to you, and you accept, a non-exclusive, non-transferable license to use, copy and modify the SOFTWARE only as authorized below.
  2. PERMITTED USES. This LICENSE grants you the following rights:
    A. The SOFTWARE is licensed per individual developer. You may make copies on more than one computer, as long as the use of the SOFTWARE is by the same developer.
    B. Solely with respect to electronic documents included with the SOFTWARE, you may make a copy for each developer for which the Software has been licensed as described in Section 2.A, above; provided, that such copies shall be used only by such developer for internal purposes and are not to be republished or distributed to any other third party.
    C. You may use the evaluation versions of the SOFTWARE for the limited purposes of demonstrations, trials and design time evaluations.
  3. PROHIBITED USES. You may not, without the prior written permission of O2 Solutions:
    A. Disassemble, decompile or "unlock", decode or otherwise reverse translate or engineer, or attempt in any manner to reconstruct or discover any source code or underlying algorithms of SOFTWARE provided in object code form only.
    B. Use, copy, modify, or merge copies of the SOFTWARE and any accompanying documents except as permitted in this LICENSE.
    C. Transfer, rent, lease, or sublicense the SOFTWARE.
  4. REDISTRIBUTABLE COMPONENTS
    A.     The files barcode4net.dll, barcode4net.windows.dll, barcode4net.web.dll, barcode4net.cf.dll, barcode4net.windows.cf.dll, barcode4net.rs.dll are considered as REDISTRIBUTABLE DLLs.
    B. In addition to the license and rights granted in Sections I and II, O2 Solutions grants you a nonexclusive, royalty-free right to reproduce and distribute the object code version of the SOFTWARE designated in the SOFTWARE as (i) those portions of the SOFTWARE which are identified in the documentation as REDISTRIBUTABLE DLLs ("DLLs"); provided: you distribute the REDISTRIBUTABLES in object code form only in conjunction with and as part of your software application product which adds significant and primary functionality; you do not use O2 Solutions' name, logo or trademarks to market your software application product; you include a valid copyright notice on your SOFTWARE; and
    C. In addition to the other requirements set forth in this Section 4, you hereby agree to indemnify, hold harmless, and defend O2 Solutions from and against any and all liabilities, damages, losses, costs and expenses (including attorneys' fees) arising from or related to any claim, action, proceeding or allegation that arise or result from the use and distribution of any of your software application product(s) or components.
  5. COPYRIGHT
    All title and copyrights in and to the SOFTWARE are owned by O2 Solutions. The SOFTWARE is protected by United States copyright laws and international treaty provisions. All rights are reserved worldwide. You must treat the SOFTWARE like any other copyrighted material, except that you may, in addition to the copies permitted in this LICENSE, make one copy of the SOFTWARE solely for backup or archival purposes. No part of the accompanying printed materials may be reproduced, transmitted, transcribed, stored in any retrieval system, or translated into any language by any means without the express prior written permission of O2 Solutions.
  6. TERMINATION
    This LICENSE and your right to use the SOFTWARE will terminate immediately without notice from O2 Solutions if you fail to comply with the terms and conditions of this LICENSE. Upon termination, you agree to destroy the SOFTWARE, including all accompanying documents and copies. This is in addition to and not in lieu of any criminal, civil or other remedies available to O2 Solutions.
  7. LIMITED WARRANTY
    A.     O2 Solutions does not warranty that the SOFTWARE will be error-free. Except with respect to REDISTRIBUTABLES, which are provided "AS IS," without warranty of any kind, O2 Solutions warrants that the SOFTWARE will perform substantially in accordance with the accompanying electronic documentation for a period of thirty (30) days from the date of receipt.
    B. O2 Solutions' entire liability, in contract tort or otherwise, and your exclusive remedy under the performance warranty set forth in Section 7.A, shall be, at O2 Solutions' option, either (a) return of the purchase price paid, or (b) repair or replacement of the defective SOFTWARE. This limited warranty is void if failure of the SOFTWARE has resulted from accident, abuse, or misapplication. Any replacement SOFTWARE will be warranted for the remainder of the original thirty (30) day period.
    C. EXCEPT AS EXPRESSLY SET FORTH IN THIS SECTION 7, O2 SOLUTIONS DISCLAIMS ALL OTHER WARRANTIES, EITHER EXPRESS OR IMPLIED, WHETHER ARISING BY STATUTE OR OTHERWISE IN LAW OR FROM A COURSE OF DEALING OR USAGE OR TRADE, INCLUDING, BUT NOT LIMITED TO, ANY IMPLIED WARRANTIES OF ACCURACY, COMPLETENESS, PERFORMANCE, CURRENCY, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE WITH REGARD TO THE SOFTWARE.
  8. LIMITATION OF LIABILITIES
    O2 Solutions' liability, whether in contract, or otherwise, arising out of Licensee's use of, or in connection with, the SOFTWARE, or otherwise under this Agreement, shall not exceed the amount of the license fee paid by you to O2 Solutions. IN NO EVENT SHALL O2 SOLUTIONS BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR CONSEQUENTIAL DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS
    OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE, EVEN IF O2 SOLUTIONS HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
License activation

Glossary Item Box

After you purchase any of Barcode4NET toolkit editions, you will receive a serial number for unlocking the evaluation version. The serial number works only with the edition you purchased, for example a serial number for Windows Forms edition does not work with ASP.NET edition.

NOTE: The serial numbers are case sensitive.

Unlocking the Barcode4NET class library

The Barcode class has a property called SerialNumber. Set this property to the serial number you received and the TRIAL tag will be removed from the barcode images.

Unlocking the BarcodeView and BarcodeTextBox Windows Forms controls

Both BarcodeView and BarcodeTextBox Windows Forms controls have a property called SerialNumber. Set this property to the serial number you received and the TRIAL tag will be removed from the control.

Unlocking the BarcodeView ASP.NET control

The BarcodeView ASP.NET control has a property called SerialNumber. Set this property to the serial number you received and the TRIAL tag will be removed from the control. The BarcodeView ASP.NET control can also load the serial number from application's web.config file. The following key needs to be added to application's web.config file, in <appSettings> section:
<add key="Barcode4NET.1.0" value="your-serial-number" />
At runtime, the BarcodeView control looks for "Barcode4NET.1.0" key in application's web.config file and if it finds it, it loads the key,

Unlocking the BarcodeView SSRS 2005 control

The BarcodeView SSRS2005 control has a property called SerialNumber. Set this property to the serial number you received and the TRIAL tag will be removed from the control.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Deployment

Glossary Item Box

All the assemblies included in Barcode4NET toolkit can be used the XCOPY deployment, no additional configurations are needed, except for deploying the assembly for MS SQL Reporting Services, when the Reporting Services needs to be configured to work with Barcode4NET.

All the assemblies are strong named so they can be deployed to Global Assembly Cache (GAC) if needed.

Deploying Barcode4NET with desktop applications

By desktop applications we mean Windows Forms applications, Console applications and Windows services.

The following assemblies are required to be deployed with your application: barcode4net.dll and barcode4net.windows.dll.

The assemblies can be deployed in the same folder with your application's executable or they can be deployed to GAC.
Deploying Barcode4NET with Mobile Devices applications
The following assemblies are required to be deployed with your application: barcode4net.cf.dll and barcode4net.windows.cf.dll.
The assemblies can be deployed in the same folder with your application's executable.
Deploying Barcode4NET with ASP.NET applications
The following assemblies are required to be deployed with your web application: barcode4net.dll and barcode4net.web.dll.
The assemblies can be deployed in the bin/ folder of your web application or they can be deployed to GAC.
Deploying Barcode4NET with SQL Reporting Services 2005 reports
The following assemblies are required to be deployed with your reports: barcode4net.dll and barcode4net.rs.dll.
The assemblies need to be deployed to bin/ folder of your Reporting Services server, usually <SqlReportingServices2005InstallPath>\MSSQL.3\Reporting Services\ReportServer\Bin\ (where <SqlReportingServices2005InstallPath> is the location where MS SQL Reporting Services 2005 have been installed).
After coying the Barcode4NET assemblies to bin/ folder, the following configuration files need to be updated (they are located in <SqlReportingServices2005InstallPath>\MSSQL.3\Reporting Services\ReportServer\):
IMPORTANT: Backup rsreportserver.config and rssrvpolicy.config files before making any changes!
  • rsreportserver.config - add the following line to <ReportItems> section:
    <ReportItem Name="Barcode" Type="O2S.Barcode4NET.ReportingServices.BarcodeItem, Barcode4NET.RS" />
    If the <ReportItems> section does not exist, create it inside <Extensions> section.
    Here it is how to rsreportserver.config file should look after the changes (the fragment below is the end of the config file, the green section is the Barcode4NET configuration the others are existing tags):
    <ReportItems>
    <ReportItem Name="Barcode4NET" Type="O2S.Barcode4NET.ReportingServices.BarcodeItem, Barcode4NET.RS" />
    </ReportItems>
     </Extensions>
    </Configuration>
  • rssrvpolicy.config - add the following <CodeGroup> section (replace <RS2005InstallPath> with actual installation path):
    <CodeGroup class="UnionCodeGroup" version="2" PermissionSetName="FullTrust" Name="Barcode4NET" Description="This code group grants FullTrust to Barcode4NET.RS.dll assembly.">
    <IMembershipCondition class="StrongNameMembershipCondition" version="2" PublicKeyBlob="0024000004800000940000000602000000240000525341310004000001000100e3b54f9ca0f68f94a88fc162a5e0f7e7b01088eb03b98a3bc9f3a071d6592dd9414258dd116b2511b2bc5527368e8f957915a3c268ff4ee82dee57f7a03c92171de7a75c3f2df8a1bc65acc046fa886b5659edf2c52d1b1d2bbdd43f01207ddd57cecdbbceb0e208a6a789c004a248572565fbad80a99a4976523168d74d519d" />
    </CodeGroup>
    Here it is how to rssrvpolicy.config file should look after the changes (the fragment below is the end of the config file, the green section is the Barcode4NET configuration the others are existing tags):
    <CodeGroup class="UnionCodeGroup" version="1" PermissionSetName="FullTrust">
    <IMembershipCondition class="UrlMembershipCondition" version="1" Url="$CodeGen$/*" />
    </CodeGroup>
    <CodeGroup class="UnionCodeGroup" version="1" PermissionSetName="FullTrust" Name="SharePoint_Server_Strong_Name" Description="This code group grants SharePoint Server code full trust. ">
    <IMembershipCondition class="StrongNameMembershipCondition" version="1" PublicKeyBlob="0024000004800000940000000602000000240000525341310004000001000100AFD4A0E7724151D5DD52CB23A30DED7C0091CC01CFE94B2BCD85B3F4EEE3C4D8F6417BFF763763A996D6B2DFC1E7C29BCFB8299779DF8785CDE2C168CEEE480E570725F2468E782A9C2401302CF6DC17E119118ED2011937BAE9698357AD21E8B6DFB40475D16E87EB03C744A5D32899A0DBC596A6B2CFA1E509BE5FBD09FACF" />
    </CodeGroup>
     <CodeGroup class="UnionCodeGroup" version="2" PermissionSetName="FullTrust" Name="Barcode4NET" Description="This code group grants FullTrust to Barcode4NET.RS.dll assembly.">
    <IMembershipCondition class="StrongNameMembershipCondition" version="2" PublicKeyBlob="0024000004800000940000000602000000240000525341310004000001000100e3b54f9ca0f68f94a88fc162a5e0f7e7b01088eb03b98a3bc9f3a071d6592dd9414258dd116b2511b2bc5527368e8f957915a3c268ff4ee82dee57f7a03c92171de7a75c3f2df8a1bc65acc046fa886b5659edf2c52d1b1d2bbdd43f01207ddd57cecdbbceb0e208a6a789c004a248572565fbad80a99a4976523168d74d519d" />
    </CodeGroup>
     </CodeGroup>
    </CodeGroup>
    </PolicyLevel>
    </policy>
    </security>
    </mscorlib>
    </configuration>

The install kit includes sample SQL Reporting Services configuration files that show where to add the Barcode4NET related sections. These sample files are located in Samples\Reporting Services\Configuration\2005 folder of the installation location.

Deploying Barcode4NET with SQL Reporting Services 2000 reports
The following assembly is required to be deployed with your reports: barcode4net.dll. This assembly also has to be registered in GAC on the server where it is deployed.
The assembly needs to be deployed to bin/ folder of your Reporting Services server, usually <SqlReportingServices2000InstallPath>\MSSQL\Reporting Services\ReportServer\Bin\ (where <SqlReportingServices2000InstallPath> is the location where SQL Reporting Services 2000 have been installed).
After coying the Barcode4NET assembly to bin/ folder, the following configuration file needs to be updated (it is located in <SqlReportingServices2000InstallPath>\MSSQL\Reporting Services\ReportServer\):
IMPORTANT: Backup rssrvpolicy.config files before making any changes!
  • rssrvpolicy.config - add the following <CodeGroup> section (replace <RS2005InstallPath> with actual installation path):
    <CodeGroup class="UnionCodeGroup" version="2" PermissionSetName="FullTrust" Name="Barcode4NET" Description="This code group grants FullTrust to Barcode4NET.dll assembly.">
    <IMembershipCondition class="StrongNameMembershipCondition" version="2" PublicKeyBlob="00240000048000009400000006020000002400005253413100040000010001003fae1daf0d6dcc969069ced0ebc2d71fabda6a00d750fe1e0447e52e3b899a64355e28d01598d62cf569d888472ab48e4929360b19c774ec0002af83d3352b1ad9c4d36da271e83c0c0d9dcbb22e0bc39a2929446518e66d65d19105203628f47e293ded809198d35068344a8919905aa5f1b82816a7b8b879ee895869aaa2ac" />
    </CodeGroup>
    Here it is how to rssrvpolicy.config file should look after the changes (the fragment below is the end of the config file, the green section is the Barcode4NET configuration the others are existing tags):
    <CodeGroup class="UnionCodeGroup" version="1" PermissionSetName="FullTrust">
    <IMembershipCondition class="UrlMembershipCondition" version="1" Url="$CodeGen$/*" />
    </CodeGroup>
    <CodeGroup class="UnionCodeGroup" version="1" PermissionSetName="FullTrust" Name="SharePoint_Server_Strong_Name" Description="This code group grants SharePoint Server code full trust. ">
    <IMembershipCondition class="StrongNameMembershipCondition" version="1" PublicKeyBlob="0024000004800000940000000602000000240000525341310004000001000100AFD4A0E7724151D5DD52CB23A30DED7C0091CC01CFE94B2BCD85B3F4EEE3C4D8F6417BFF763763A996D6B2DFC1E7C29BCFB8299779DF8785CDE2C168CEEE480E570725F2468E782A9C2401302CF6DC17E119118ED2011937BAE9698357AD21E8B6DFB40475D16E87EB03C744A5D32899A0DBC596A6B2CFA1E509BE5FBD09FACF" />
    </CodeGroup>
     <CodeGroup class="UnionCodeGroup" version="2" PermissionSetName="FullTrust" Name="Barcode4NET" Description="This code group grants FullTrust to Barcode4NET.dll assembly.">
    <IMembershipCondition class="StrongNameMembershipCondition" version="2" PublicKeyBlob="00240000048000009400000006020000002400005253413100040000010001003fae1daf0d6dcc969069ced0ebc2d71fabda6a00d750fe1e0447e52e3b899a64355e28d01598d62cf569d888472ab48e4929360b19c774ec0002af83d3352b1ad9c4d36da271e83c0c0d9dcbb22e0bc39a2929446518e66d65d19105203628f47e293ded809198d35068344a8919905aa5f1b82816a7b8b879ee895869aaa2ac" />
    </CodeGroup>
     </CodeGroup>
    </CodeGroup>
    </PolicyLevel>
    </policy>
    </security>
    </mscorlib>
    </configuration>

The install kit includes sample SQL Reporting Services configuration files that show where to add the Barcode4NET related sections. These sample files are located in Samples\Reporting Services\Configuration\2000 folder of the installation location.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
My first barcode

Glossary Item Box

This section presents simple samples that illustrate the basic things you need to do when working with Barcode4NET.

Adding barcodes support to Console applications
This sample shows how to work with barcodes in Console applications.

Adding barcodes support to Windows Forms applications
This sample shows how to use BarcodeView and BarcodeTextBox controls in Windows Forms applications.

Adding barcodes support to Mobile Devices applications
This sample shows how to use BarcodeView control in Mobile Devices applications.

Adding barcodes support to ASP.NET applications
This sample shows how to use BarcodeView control in ASP.NET applications.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Console application version

Glossary Item Box

You can skip this sample if you purchased the ASP.NET & Reporting Services edition.

Because Console applications do not have a graphic window to display their output, this sample shows how to export barcodes as images. These images can be later used by other applications to display and print the barcodes.

The sample below uses Visual Studio .Net 2005, but the steps are same for Visual Studio .Net 2003.

  1. Start Visual Studio .Net 2005 (or 2003) and create a new Console application.

    Enlarge Click to enlarge
  2. Add a reference to barcode4net.dll to your application and then type the following code at the top of your file:
    C#:
    using O2S.Barcode4NET;
    VB.NET:
    Imports O2S.Barcode4NET
    Type the following code inside the Main method:
    C#:
    Code39Barcode c39 = new Code39Barcode("0123456789");
    c39.Save("c39.gif", BarcodeImageFormat.Gif, 300);
    VB.NET:
    Dim c39 as New Code39Barcode("0123456789")
    c39.Save("c39.gif", BarcodeImageFormat.Gif, 300)

    Enlarge Click to enlarge
  3. Compile and run the application.
  4. The barcode image is now on disk as a gif image.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Windows Forms version

Glossary Item Box

You can skip this sample if you purchased the ASP.NET & Reporting Services edition.

This sample shows how to display a barcode using BarcodeView control.

The sample below uses Visual Studio .Net 2005, but the steps are same for Visual Studio .Net 2003.

  1. Start Visual Studio .Net 2005 (or 2003) and create a new Windows application. Make sure the application form is in design mode.

    Enlarge Click to enlarge
  2. Select BarcodeView control in the toolbox and drag it on the form.

    Enlarge Click to enlarge
  3. Using the properties grid, set the Symbology property to Code39, Data property to 1234567890 and TextColor property to Blue.

    Enlarge Click to enlarge
  4. Compile the application and run it.

    Enlarge Click to enlarge
  5. The barcode is displayed on application's form.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Mobile Devices version

Glossary Item Box

You can skip this sample if you purchased the ASP.NET & Reporting Services edition.

This sample shows how to display a barcode using BarcodeView control in a Mobile Devices application.

The sample below uses Visual Studio .Net 2005, but the steps are same for Visual Studio .Net 2003.

  1. Start Visual Studio .Net 2005 (or 2003) and create a new Smart Device application. Make sure the application form is in design mode.

    Enlarge Click to enlarge
  2. Select BarcodeView control in the toolbox and drag it on the form.

    Enlarge Click to enlarge
  3. Using the properties grid, set the Symbology property to Code39, Data property to 12345, TextColor property to Blue and BarColor property to Red.

    Enlarge Click to enlarge
  4. Compile the application and run it. The barcode is displayed on application's form.

    Enlarge Click to enlarge


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
ASP.NET version

Glossary Item Box

You can skip this sample if you purchased the Windows Forms & Mobile Devices edition.

This sample shows how to display a barcode using BarcodeView server control in an ASP.NET application.

The sample below uses Visual Studio .Net 2005, but the steps are same for Visual Studio .Net 2003.

  1. Start Visual Studio .Net 2005 (or 2003) and create a new Web application (web site). Make sure the application form is in design mode.

    Enlarge Click to enlarge
  2. Select BarcodeView control in the toolbox and drag it on the form.

    Enlarge Click to enlarge
  3. Using the properties grid, set the Symbology property to Code39, Data property to 1234567890, TextColor property to Blue and ImageStreamingMode property to HttpHandler.

    Enlarge Click to enlarge
  4. Add the following lines to application's web.config file:
    <httpHandlers>
    <add verb="GET" path="barcodeservice.axd" type="O2S.Barcode4NET.WebControls.BarcodeService, Barcode4NET.Web" />
    </httpHandlers>

    Enlarge Click to enlarge
  5. Compile the application and run it.

    Enlarge Click to enlarge
  6. The barcode is displayed on application's page.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Tutorials

Glossary Item Box

This section shows how Barcode4NET toolkit can be used in more complex scenarios. These tutorials assume that you are familiar with XML, datasets, Crystal Reports and Visual Studio 2005 local reports.

Barcode4NET and Crystal Reports
This tutorial presents how to display barcodes using Barcode4NET toolkit in reports created with Crystal Reports.

Barcode4NET and SQL Server Reporting Services 2000
This tutorial presents how to display barcodes using Barcode4NET toolkit in reports created with SQL Server Reporting Services 2000.

Barcode4NET and Windows Forms local reports
This tutorial presents how to display barcodes using Barcode4NET toolkit in Windows Forms local reports created with Visual Studio 2005.

Barcode4NET and ASP.NET local reports
This tutorial presents how to display barcodes using Barcode4NET toolkit in ASP.NET local reports created with Visual Studio 2005.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Barcode4NET and Crystal Reports

Glossary Item Box

This tutorial presents how to display barcodes, created with Barcode4NET, in Crystal Reports.

Requirements
Before starting to work on this tutorial, make sure the following items are available:
  • Barcode4NET toolkit, any of Windows Forms & Mobile Devices or .Net editions.
  • Visual Studio .Net 2003 or Visual Studio .Net 2005
  • MS SQL 2000 + Northwind database (other data sources can work as well).
Building the Vendors report
Please follow the steps in the sequence they are presented in order for this tutorial to work. The tutorial uses Visual Studio .Net 2003 but the steps are the same for Visual Studio .Net 2005.
  1. Start Visual Studio .Net 2003 and create a new Windows Forms application. Add a reference to barcode4net.dll.

    Enlarge Click to enlarge
  2. Using the Project menu (Project > Add new item...), add a new XML schema to the application. Name the schema Customers.xsd.
    In order to add barcodes to Crystal Reports you will need a XML schema for the data that will be displayed in the report. The XML schema is used only during the design of the report and it is used to design the report and define the fields that will be displayed.

    Enlarge Click to enlarge
  3. Make sure the XML schema is in design mode. Select the Element object in the toolbox and drag it on the schema. Name the element "Customer".

    Enlarge Click to enlarge
  4. Add the following fields to the Customer element:
    CompanyName - string
    Address - string
    City - string
    PostalCode - string
    Country - string
    CustomerIDBarcode - base64Binary

    Enlarge Click to enlarge
    Save the XML Schema.
  5. Using the Project menu (Project > Add new item...), add a blank Crystal Report to the application. Name the report CustomersReport.rpt.

    Enlarge Click to enlarge
  6. Make sure the report is in design mode. Right click on Database Fields item on the left and select Add/Remove Database... from the context menu.

    Enlarge Click to enlarge
  7. Expand More Data Sources item and select ADO.NET (XML).

    Enlarge Click to enlarge
  8. Expand the ADO.NET (XML) node and type the path to Customers.xsd file in XML File Path field and then click Finish.

    Enlarge Click to enlarge
  9. Select Customer table in Available Data Sources list and move it to Selected Tables list by clicking the > button.

    Enlarge Click to enlarge
    Click OK to save the selection.
  10. Make sure the report is displayed in design mode. Expand the Database fields item on the left and drag the fields in the Details section of the report.

    Enlarge Click to enlarge
  11. Right click on CustomerIDBarcode field and select Format from the context menu. In Format Editor window select Can grow option.

    Enlarge Click to enlarge
  12. Display the application's main form in design mode. Select the CrystalReportViewer component in the toolbox and drag it on the form.

    Enlarge Click to enlarge
  13. Open the application's main form source code file and import/use the following namespaces:
    C#:
    using System.Data.SqlClient;
    using O2S.Barcode4NET;
    VB.NET:
    Imports System.Data
    Imports System.Data.SqlClient
    Imports O2S.Barcode4NET
    Type the following code in the Form load event handler:
    C#:
    // Create a Sql connection to the database storing the data for the report
     SqlConnection connection =
    new SqlConnection("Data Source=(local);Initial Catalog=Northwind;Integrated Security=True");
    connection.Open();

    // The fields in the query string must match the fields in the Customer.xsd
     string queryString =
    "SELECT CustomerID, CompanyName, Address, City, PostalCode, Country FROM Customers";
    SqlDataAdapter adapter     = new SqlDataAdapter(queryString, connection);

    // Fill the dataset with data.
     DataSet customers = new DataSet();
    adapter.Fill(customers,     "Customers");

    // Create a new column in the dataset that will store the barcode
    // The column name must match the CustomerIDBarcode column in Customers.xsd
     DataColumn dc = new DataColumn("CustomerIDBarcode", typeof(byte[]));

    //Add the CustomerIDBarcode column to the DataTable
     customers.Tables[0].Columns.Add(dc);

    //Create a Code39 barcode object to fill the CustomerIDBarcode column
     Code39Barcode c39 = new Code39Barcode();
    c39.DimensionUnit     = XYDimensionUnit.Pixel;
    c39.XDimension     = 1;
    c39.YDimension     = 40;

    // Fill each row with the barcode image
     foreach (DataRow dr in customers.Tables[0].Rows)
    {
    c39.Data     = (string)dr["CustomerID"];
    dr[    "CustomerIDBarcode"] = c39.GetImageData(BarcodeImageFormat.Png, 0);
    }

    // Create the report and attach the data source
     CustomersReport customersReport = new CustomersReport();
    customersReport.SetDataSource(customers.Tables[    0]);

    // Display the report in the viewer
     crystalReportViewer1.ReportSource = customersReport;
    VB.NET:
    ' Create a Sql connection to the database storing the data for the report
     Dim connection As New SqlConnection("Data Source=(local);Initial Catalog=Northwind;Integrated Security=True")
    connection.Open()

    ' The fields in the query string must match the fields in the Customer.xsd
     Dim queryString As String = "SELECT CustomerID, CompanyName, Address, City, PostalCode, Country FROM Customers"
    Dim adapter As New SqlDataAdapter(queryString, connection)

    ' Fill the dataset with data.
     Dim customers As New DataSet
    adapter.Fill(customers,     "Customers")

    ' Create a new column in the dataset that will store the barcode
     ' The column name must match the CustomerIDBarcode column in Customers.xsd
     Dim dc = New DataColumn("CustomerIDBarcode", GetType(Byte()))

    ' Add the CustomerIDBarcode column to the DataTable
     customers.Tables(0).Columns.Add(dc)

    ' Create a Code39 barcode object to fill the CustomerIDBarcode column
     Dim c39 As New Code39Barcode
    c39.DimensionUnit     = XYDimensionUnit.Pixel
    c39.XDimension     = 1
    c39.YDimension     = 40

    ' Fill each row with the barcode image
     Dim dr As DataRow
    For Each dr In customers.Tables(0).Rows
    c39.Data     = CType(dr("CustomerID"), String)
    dr(    "CustomerIDBarcode") = c39.GetImageData(BarcodeImageFormat.Png, 0)
    Next

    ' Create the report and attach the data source
     Dim customersReport As New CustomersReport
    customersReport.SetDataSource(customers.Tables(    0))

    ' Display the report in the viewer
     crystalReportViewer1.ReportSource = customersReport

    Enlarge Click to enlarge
  14. Compile the application and run it.

    Enlarge Click to enlarge


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Barcode4NET and SQL Server Reporting Services 2000

Glossary Item Box

This tutorial presents how to display barcodes, created with Barcode4NET, in SQL Server Reporting Services 2000 reports.

Requirements
Before starting to work on this tutorial, make sure the following items are available:
  • Barcode4NET toolkit, any of ASP.NET & Reporting Services or .Net editions.
  • Visual Studio .Net 2003
  • MS SQL 2000 + AdventureWorks database (other data sources can work as well).
  • MS SQL Reporting Services 2000
Building the Employees report
Please follow the steps in the sequence they are presented in order for this tutorial to work.
  1. Start Visual Studio .Net 2003 and create a new report project.

    Enlarge Click to enlarge
  2. In Solution Explorer right click on Reports folder and add a new report using the Report Wizard.
    This tutorial uses the Northwind database that comes with MS SQL 2000. The report data source uses the Customers table that already exist in the database.
    Type the following code for the query string and then click Next:
    SELECT CustomerID, CompanyName, Address, City, PostalCode, Country FROM Customers

    Enlarge Click to enlarge
  3. Select all the fields to be displayed in the details section of the report and then click Next.

    Enlarge Click to enlarge
  4. In the last step of the Report Wizard set the report name to CustomersReport and click Finish to create the report.

    Enlarge Click to enlarge
  5. Make sure the report is opened in design mode. Using the Report menu, display the report properties (Report > Report properties...) and select the References tab. In the References list, click on the first empty line and type this:
    Barcode4NET, Version=1.0.0.0, Culture=neutral, PublicKeyToken=fdeffed0f6085085
    IMPORTANT: Make sure that Barcod4NET.dll assembly (located in Bin\Net 1.1) is registered in Global Assembly Cache. If it is not registered, use the gacutil.exe utility to register the assembly in GAC.

    Enlarge Click to enlarge
  6. Select the Code tab and type the following function:
    Public Function GetBarcodeImage(ByVal data As String) As Byte()
    'Create the barcode
    Dim c39 As New O2S.Barcode4NET.Code39Barcode(data)
    'Set the barcode size
    c39.DimensionUnit = O2S.Barcode4NET.XYDimensionUnit.Pixel
    c39.XDimension = 1
    c39.YDimension = 30
    'Get the barcode image as a gif image
    Return c39.GetImageData(O2S.Barcode4NET.BarcodeImageFormat.Gif, 0)
    End Function
    This tutorial uses a Code 39 (Code 3 of 9) barcode, but ANY barcode symbology that is supported by Barcode4NET toolkit can be used.

    Enlarge Click to enlarge
    Click OK to save the changes made to report properties.
  7. Select the Image object in the toolbox and drag it in the Customer ID column.

    Enlarge Click to enlarge
  8. Select the Image object in Customer ID column and set its properties:
    MIMEType = image/gif (the image format here must match the first parameter of GetImageData method in the code at Step 5)
    Source = Database
    Value = =Code.GetBarcodeImage(Fields!NationalIDNumber.Value) (the = sign must appear in front of Code keyword).
    Sizing = AutoSize

    Enlarge Click to enlarge
  9. Display the report in preview mode (click on Preview tab) to check that everything is ok.

    Enlarge Click to enlarge
  10. Configure the SQL Reporting Services 2000 security policy to allow Barcode4NET to run in the report context. Add the following lines to rssrvpolicy.config file (usually located in C:\Program Files\Microsoft SQL Server\MSSQL\Reporting Services\ReportServer):
    <CodeGroup class="UnionCodeGroup" version="2" PermissionSetName="FullTrust" Name="Barcode4NETLibrary" Description="This code group grants FullTrust to Barcode4NET assembly.">
    <IMembershipCondition class="StrongNameMembershipCondition" version="2" PublicKeyBlob="00240000048000009400000006020000002400005253413100040000010001003fae1daf0d6dcc969069ced0ebc2d71fabda6a00d750fe1e0447e52e3b899a64355e28d01598d62cf569d888472ab48e4929360b19c774ec0002af83d3352b1ad9c4d36da271e83c0c0d9dcbb22e0bc39a2929446518e66d65d19105203628f47e293ded809198d35068344a8919905aa5f1b82816a7b8b879ee895869aaa2ac" />
    </CodeGroup>
    IMPORTANT: Backup the rssrvpolicy.config file before making any changes.

    Enlarge Click to enlarge
    The installation kit contains sample SQL Reporting Services 2000 configuration files that show where the <CodeGroup> has to be added. The sample configuration files are located in <Barcode4NETInstallPath>\Samples\Reporting Services\Configuration\2000\.
  11. Compile the report and deploy it to your SQL Reporting Services 2000 server.

    Enlarge Click to enlarge
  12. The report can be exported as PDF (or other supported formats) and the barcodes are preserved.
    CustomersReport exported as a PDF document.

    Enlarge Click to enlarge


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Barcode4NET and Windows Forms local reports

Glossary Item Box

This tutorial presents how to display barcodes, created with Barcode4NET, in Windows Forms local reports.

Local reports, also known as RDLC reports (Report Definition Language Client-side processing), are a new type of reports that have been introduced in Visual Studio .Net 2005. They use the same definition language like the SQL Reporting Services reports, but they do not need the SQL Reporting Services complex infrastructure in order to run. The ReportViewer control take care of processing and displaying these reports.
Requirements
Before starting to work on this tutorial, make sure the following items are available:
  • Barcode4NET toolkit, any of Windows Forms & Mobile Devices or .Net editions.
  • Visual Studio .Net 2005
  • MS SQL 2005 + AdventureWorks database (other data sources can work as well).
Building the Vendors report
Please follow the steps in the sequence they are presented in order for this tutorial to work.
  1. Start Visual Studio .Net 2005. Create a new Windows Forms application. Using the Data menu, add a new Data Source to the project.
    This tutorial uses the AdventureWorks database that comes with MS SQL 2005. The Data Source that has been added to the project uses the Purchasing.vVendor view that already exists in the database. After adding the data source, the Visual Studio window should look like in the screenshot below.

    Enlarge Click to enlarge
  2. Using the Project menu (Project > Add new item...), add a new Report to the application. Name the report VendorReport.rdlc.

    Enlarge Click to enlarge
  3. Make sure the report is opened in design mode. Using the Report menu, display the report properties (Report > Report properties...) and select the References tab. In the References list, click on the first empty line and type this:
    Barcode4NET, Version=1.0.0.0, Culture=neutral, PublicKeyToken=fdeffed0f6085085
    IMPORTANT: Make sure that Barcod4NET.dll assembly (located in Bin\Net 2.0) is registered in Global Assembly Cache. If it is not registered, use the gacutil.exe utility to register the assembly in GAC.

    Enlarge Click to enlarge
  4. Select the Code tab and type the following function:
    Public Function GetBarcodeImage(ByVal data As String) As Byte()
    'Create the barcode
    Dim c39 As New O2S.Barcode4NET.Code39Barcode(data)
    'Set the barcode size
    c39.DimensionUnit = O2S.Barcode4NET.XYDimensionUnit.Pixel
    c39.XDimension = 1
    c39.YDimension = 30
    'Get the barcode image as a gif image
    Return c39.GetImageData(O2S.Barcode4NET.BarcodeImageFormat.Gif, 0)
    End Function
    This tutorial uses a Code 39 (Code 3 of 9) barcode, but ANY barcode symbology that is supported by Barcode4NET toolkit can be used.

    Enlarge Click to enlarge
    Click OK to save the changes made to report properties.
  5. With the report opened in design mode, select the Table object in the toolbox and drag it on the report. Right click on the gray header and insert a new column. You should have now 4 columns. In the header row type Vendor name in the 1st column, First name in the 2nd column, Last name in the 3rd column and Phone in the 4th column.

    Enlarge Click to enlarge
  6. Make sure the Data Sources window is visible (main menu: Data > Show Data Sources...) and vVendor view is expanded (like in Step 1 screenshot). Click on Name field and drag it on the details row in the 1st column. Click on First name field and drag it on the details row in the 2nd column. Click on Last name field and drag it on the details row in the 3nd column. Display the toolbox again, select the Image object and drag it on the details row in the 4th column.

    Enlarge Click to enlarge
  7. Select the Image object in Phone column and set its properties:
    MIMEType = image/gif (the image format here must match the first parameter of GetImageData method in the code at Step 4)
    Source = Database
    Value = =Code.GetBarcodeImage(Fields!Phone.Value) (the = sign must appear in front of Code keyword).
    Sizing = AutoSize

    Enlarge Click to enlarge
  8. Display the application's main form in design mode. Select the ReportViewer control in the toolbox and drag it on the form. Select VendorReport to be displayed in the control.

    Enlarge Click to enlarge
  9. Add the following code line at the beginning of Form1_Load method:
    C#:
    reportViewer1.LocalReport.AddTrustedCodeModuleInCurrentAppDomain("Barcode4NET, Version=1.0.0.0, Culture=neutral, PublicKeyToken=fdeffed0f6085085");
    VB.NET:
    reportViewer1.LocalReport.AddTrustedCodeModuleInCurrentAppDomain("Barcode4NET, Version=1.0.0.0, Culture=neutral, PublicKeyToken=fdeffed0f6085085")

    Enlarge Click to enlarge
  10. Compile the application and run it.

    Enlarge Click to enlarge
  11. The report can be exported as PDF and Excel files and the barcodes are preserved.
    VendorReport exported as a PDF document.
    VendorReport exported as PDF document
    Enlarge Click to enlarge
    VendorReport exported as an Excel document
    VendorReport exported as an Excel document
    Enlarge Click to enlarge


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Barcode4NET and ASP.NET local reports

Glossary Item Box

This tutorial presents how to display barcodes, created with Barcode4NET, in ASP.NET local reports.

Local reports, also known as RDLC reports (Report Definition Language Client-side processing), are a new type of reports that have been introduced in Visual Studio .Net 2005. They use the same definition language like the SQL Reporting Services reports, but they do not need the SQL Reporting Services complex infrastructure in order to run. The ReportViewer control take care of processing and displaying these reports.
Requirements
Before starting to work on this tutorial, make sure the following items are available:
  • Barcode4NET toolkit, any of ASP.NET & Reporting Services or .Net editions.
  • Visual Studio .Net 2005
  • MS SQL 2005 + AdventureWorks database (other data sources can work as well).
Building the Employees report
Please follow the steps in the sequence they are presented in order for this tutorial to work.
  1. Start Visual Studio .Net 2005 and create a new website.

    Enlarge Click to enlarge
  2. Using the Website menu (Website > Add new item...), add a new Report to the application. Name the report EmployeesReport.rdlc.

    Enlarge Click to enlarge
  3. Add a new Data Source to the project and type the following code for reading the data from the database:
    SELECT
    Person.Contact.FirstName,
    Person.Contact.LastName,
    Person.Contact.EmailAddress,
    HumanResources.Employee.NationalIDNumber
    FROM
    Person.Contact INNER JOIN
    HumanResources.Employee ON
    Person.Contact.ContactID = HumanResources.Employee.ContactID
    This tutorial uses the AdventureWorks database that comes with MS SQL 2005. The Data Source that has been added to the project uses the Person.Contact and HumanResources.Employee tables that already exist in the database.

    Enlarge Click to enlarge
  4. Make sure the report is opened in design mode. Using the Report menu, display the report properties (Report > Report properties...) and select the References tab. In the References list, click on the first empty line and type this:
    Barcode4NET, Version=1.0.0.0, Culture=neutral, PublicKeyToken=fdeffed0f6085085
    IMPORTANT: Make sure that Barcod4NET.dll assembly (located in Bin\Net 2.0) is registered in Global Assembly Cache. If it is not registered, use the gacutil.exe utility to register the assembly in GAC.

    Enlarge Click to enlarge
  5. Select the Code tab and type the following function:
    Public Function GetBarcodeImage(ByVal data As String) As Byte()
    'Create the barcode
    Dim c39 As New O2S.Barcode4NET.Code39Barcode(data)
    'Set the barcode size
    c39.DimensionUnit = O2S.Barcode4NET.XYDimensionUnit.Pixel
    c39.XDimension = 1
    c39.YDimension = 30
    'Get the barcode image as a gif image
    Return c39.GetImageData(O2S.Barcode4NET.BarcodeImageFormat.Gif, 0)
    End Function
    This tutorial uses a Code 39 (Code 3 of 9) barcode, but ANY barcode symbology that is supported by Barcode4NET toolkit can be used.

    Enlarge Click to enlarge
    Click OK to save the changes made to report properties.
  6. With the report opened in design mode, select the Table object in the toolbox and drag it on the report. Right click on the gray header and insert a new column. You should have now 4 columns. In the header row type First name in the 1st column, Last name in the 2nd column, EMail in the 3rd column and IDNumber in the 4th column.

    Enlarge Click to enlarge
  7. Make sure the Data Sources window is visible and DataTable1 is expanded (like in Step 3 screenshot). Click on FirstName field and drag it on the details row in the 1st column. Click on LastName field and drag it on the details row in the 2nd column. Click on EMailAddress field and drag it on the details row in the 3nd column. Display the toolbox again, select the Image object and drag it on the details row in the 4th column.

    Enlarge Click to enlarge
  8. Select the Image object in IDNumber column and set its properties:
    MIMEType = image/gif (the image format here must match the first parameter of GetImageData method in the code at Step 5)
    Source = Database
    Value = =Code.GetBarcodeImage(Fields!NationalIDNumber.Value) (the = sign must appear in front of Code keyword).
    Sizing = AutoSize

    Enlarge Click to enlarge
  9. Display the application's default.aspx page in design mode. Select the ReportViewer control in the toolbox and drag it on the form. Select EmployeesReport to be displayed in the control.

    Enlarge Click to enlarge
  10. Add the following code line at the beginning of Form1_Load method:
    C#:
    reportViewer1.LocalReport.AddTrustedCodeModuleInCurrentAppDomain("Barcode4NET, Version=1.0.0.0, Culture=neutral, PublicKeyToken=fdeffed0f6085085");
    VB.NET:
    reportViewer1.LocalReport.AddTrustedCodeModuleInCurrentAppDomain("Barcode4NET, Version=1.0.0.0, Culture=neutral, PublicKeyToken=fdeffed0f6085085")

    Enlarge Click to enlarge
  11. Compile the website and run it.

    Enlarge Click to enlarge
  12. The report can be exported as PDF and Excel files and the barcodes are preserved.
    EmployeesReport exported as a PDF document.

    Enlarge Click to enlarge
    EmployeesReport exported as an Excel document

    Enlarge Click to enlarge


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Class Reference

Glossary Item Box

This section presents the complete class reference for all controls, classes and enumerations included in Barcode4NET toolkit.

Barcode4NET assembly
Class reference for Barcode4NET class library for standard Microsoft .NET Framework.

Barcode4NET.Windows assembly
Class reference for BarcodeView and BarcodeTextBox Windows Forms controls for standard Microsoft .NET Framework.

Barcode4NET.Web assembly
Class reference for BarcodeView ASP.NET server control for standard Microsoft .NET Framework.

Barcode4NET.CF assembly
Class reference for Barcode4NET class library for Microsoft .NET Compact Framework.

Barcode4NET.Windows.CF assembly
Class reference for BarcodeView Windows Forms control for Microsoft .NET Compact Framework.

Barcode4NET.RS.Design assembly
Class reference for BarcodeView design time control for Sql Server Reporting Services 2005.


$$INTRODUCTION$$ - %%projecttitle%%

Barcode4NET Send comments on this topic.
Introduction
Welcome to Barcode4NET class library online help.


%%phrase%%

Barcode4NET Send comments on this topic.
Barcode4NET Assembly
The Barcode4NET assembly includes the Barcode4NET class library.

Namespaces

Namespace | Description
Internal |
O2S.Barcode4NET | Root namespace for all barcodes included in Barcode4NET toolkit.
O2S.Barcode4NET.Licensing |
Xheo.Licensing |


$$GETTING_STARTED$$ - %%projecttitle%%

Barcode4NET Send comments on this topic.
Getting Started
This online help will help you get started with Barcode4NET class library. It includes detailed information about all classes included in Barcode4NET class library.


%%ItemTitle%%

Barcode4NET Send comments on this topic.
Internal Namespace (Barcode4NET)
See Also Inheritance Hierarchy

Classes

Class | Description
BigInteger | Implements an large integer of arbitrary length.
CommonRegexes | Declares static versions of some common regular expressions.

See Also

Reference

Barcode4NET Assembly


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Class
See Also Members
[image]
Internal Namespace : BigInteger Class

Implements an large integer of arbitrary length.

Syntax

Visual Basic (Declaration)
Private Class BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
C#
private class BigInteger
Managed Extensions for C++
private __gc class BigInteger
C++/CLI
private ref class BigInteger

Inheritance Hierarchy

System.Object
Internal.BigInteger

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Members
Internal Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
BigInteger Class Members
See Also Properties Methods
[image]
Internal Namespace : BigInteger Class

The following tables list the members exposed by BigInteger.

Public Constructors

 | Name | Description
Public Constructor | BigInteger Constructor | Overloaded. Initializes a new instance of the BigInteger class.
Top

Public Properties

 | Name | Description
Public Property | Bits | Gets the position of the most significant bit in the value.
Top

Public Methods

 | Name | Description
Public Method | Abs | Returns the absolute value of the BigInteger.
Public Method | Equals | Overridden. Overrides the equals comparison.
Public Method | Gcd | Returns the GCD(this, bi)
Public Method | GenerateCoPrime | Generates a random number with the specified number of bits such that Gcd(number, this) = 1
static (Shared in Visual Basic) | GeneratePseudoPrime | Makes a pseudoprime number that requires at least the given number of bits.
Public Method | GenerateRandomBits | Fills the BigInteger with random bits.
Public Method | GetBytes | Returns the value of the BigInteger as a byte array. The lowest index contains the MSB.
Public Method | GetHashCode | Overridden. Gets the hash code for the value.
Public Method | IntValue | Returns the lowest 4 bytes of the BigInteger as an int.
Public Method | IsProbablePrime | Determines whether a number is probably prime, using the Rabin-Miller's test. Before applying the test, the number is tested for divisibility by primes < 2000
Public Method | LongValue | Returns the lowest 8 bytes of the BigInteger as a long.
Public Method | ModInverse | Returns the modulo inverse of this. Throws ArithmeticException if the inverse does not exist. (i.e. Gcd(this, modulus) != 1)
Public Method | ModPow | Modulo Exponentiation. ( this ^ exp ) % n.
Public Method | Sqrt | Returns a value that is equivalent to the integer square root of the BigInteger.
Public Method | ToString | Overloaded. Overridden. Returns a string representation of the value.
Public Method | ULongValue | Returns the lowest 8 bytes of the BigInteger as a long.
Top

Public Operators

Public Operator Addition | Adds two BigInteger values together.
Public Operator And | Bitwise AND operator.
Public Operator Or | Bitwise OR operator.
Public Operator Decrement | Decrements the BigInteger value by one.
Public Operator Division | Division operator.
Public Operator Equality | Equality operator.
Public Operator Exclusive Or | Bitwise XOR operator.
Public Operator Greater Than | Greater than operator.
Public Operator Greater Than or Equal | Greater than or equal operator.
Public Operator Implicit Type Conversion | Overloaded.
Public Operator Increment | Increments the BigInteger value by 1.
Public Operator Inequality | Inequality operator.
Public Operator Left-shift | Shifts the bits to the left.
Public Operator Less Than | Less than operator.
Public Operator Less Than or Equal | Less than or equal operator.
Public Operator Modulus | Modulus operator.
Public Operator Multiplication | Multiplies two BigInteger values.
Public Operator Bitwise Complement | Implements a 1's compliment.
Public Operator Right-shift | Shifts the bits to the right.
Public Operator Subtraction | Subtracts one BigInteger from another.
Public Operator Unary Negation | Implements a 2's compliment (negative).
Top

See Also

Reference

BigInteger Class
Internal Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Constructor
See Also
[image]
Internal Namespace > BigInteger Class : BigInteger Constructor

Initializes a new instance of the BigInteger class.

Overload List

Overload | Description
BigInteger Constructor() | Initializes a new instance of the BigInteger class.
BigInteger Constructor(BigInteger) | Initializes a new instance of the BigInteger class from an existing instance.
BigInteger Constructor(Byte[]) | Initializes a new instance of the BigInteger class from an array of existing bytes.
BigInteger Constructor(Byte[],Int32) | Initializes a new instance of the BigInteger class from an array of existing bytes.
BigInteger Constructor(Int64) | Initializes a new instance of the BigInteger class from a Int64 value.
BigInteger Constructor(String,Int32) | Initializes a new instance of the BigInteger class from a string representation in the given radix.
BigInteger Constructor(UInt64) | Initializes a new instance of the BigInteger class from a UInt64 value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Constructor()
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor()

Initializes a new instance of the BigInteger class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BigInteger()
C#
public BigInteger()
Managed Extensions for C++
public: BigInteger();
C++/CLI
public:
BigInteger();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Constructor(BigInteger)
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(BigInteger)

bi
The BigInteger to initialize from.
Initializes a new instance of the BigInteger class from an existing instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bi As BigInteger _
)
Visual Basic (Usage) Copy Code
Dim bi As BigInteger

Dim instance As BigInteger(bi)
C#
public BigInteger(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger(
   BigInteger* bi
)
C++/CLI
public:
BigInteger(
   BigInteger^ bi
)

Parameters

bi
The BigInteger to initialize from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Constructor(Byte[])
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Byte[])

inData
The values to initialize from.
Initializes a new instance of the BigInteger class from an array of existing bytes.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As Byte _
)
Visual Basic (Usage) Copy Code
Dim inData() As Byte

Dim instance As BigInteger(inData)
C#
public BigInteger(
   byte[] inData
)
Managed Extensions for C++
public: BigInteger(
   byte[] inData
)
C++/CLI
public:
BigInteger(
   array<byte> inData
)

Parameters

inData
The values to initialize from.

Remarks

The lowest index of the input byte array (i.e [0]) should contain the most significant byte of the number, and the highest index should contain the least significant byte.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Constructor(Byte[],Int32)
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Byte[],Int32)

inData
The values to initialize from.
inLen
The length of the initialization array to use.
Initializes a new instance of the BigInteger class from an array of existing bytes.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As Byte, _
   ByVal inLen As Integer _
)
Visual Basic (Usage) Copy Code
Dim inData() As Byte
Dim inLen As Integer

Dim instance As BigInteger(inData, inLen)
C#
public BigInteger(
   byte[] inData,
   int inLen
)
Managed Extensions for C++
public: BigInteger(
   byte[] inData,
   int inLen
)
C++/CLI
public:
BigInteger(
   array<byte> inData,
   int inLen
)

Parameters

inData
The values to initialize from.
inLen
The length of the initialization array to use.

Remarks

The lowest index of the input byte array (i.e [0]) should contain the most significant byte of the number, and the highest index should contain the least significant byte.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Constructor(Int64)
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Int64)

value
The value to initialize with.
Initializes a new instance of the BigInteger class from a Int64 value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim value As Long

Dim instance As BigInteger(value)
C#
public BigInteger(
   long value
)
Managed Extensions for C++
public: BigInteger(
   long value
)
C++/CLI
public:
BigInteger(
   long value
)

Parameters

value
The value to initialize with.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Constructor(String,Int32)
See Also Example
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(String,Int32)

value
The string value to initialize from.
radix
The radix (or base) the value is offered as.
Initializes a new instance of the BigInteger class from a string representation in the given radix.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal radix As Integer _
)
Visual Basic (Usage) Copy Code
Dim value As String
Dim radix As Integer

Dim instance As BigInteger(value, radix)
C#
public BigInteger(
   string value,
   int radix
)
Managed Extensions for C++
public: BigInteger(
   string* value,
   int radix
)
C++/CLI
public:
BigInteger(
   String^ value,
   int radix
)

Parameters

value
The string value to initialize from.
radix
The radix (or base) the value is offered as.

Example

Example in Base 10

Example in Base 16 (HEX)

C# Copy Code
BigInteger a = new BigInteger( "1234", 10 );
            BigInteger b = new BigInteger( "-1234", 10 )
C# Copy Code
BigInteger a = new BigInteger( "1D4F", 16 );
            BigInteger b = new BigInteger( "-1D4F", 10 )

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Constructor(UInt64)
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(UInt64)

value
The value to initialize with.
Initializes a new instance of the BigInteger class from a UInt64 value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As ULong _
)
Visual Basic (Usage) Copy Code
Dim value As ULong

Dim instance As BigInteger(value)
C#
public BigInteger(
   ulong value
)
Managed Extensions for C++
public: BigInteger(
   ulong value
)
C++/CLI
public:
BigInteger(
   ulong value
)

Parameters

value
The value to initialize with.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
BigInteger Class Methods
See Also
[image]
Internal Namespace : BigInteger Class

For a list of all members of this type, see BigInteger members.

Public Methods

 | Name | Description
Public Method | Abs | Returns the absolute value of the BigInteger.
Public Method | Equals | Overridden. Overrides the equals comparison.
Public Method | Gcd | Returns the GCD(this, bi)
Public Method | GenerateCoPrime | Generates a random number with the specified number of bits such that Gcd(number, this) = 1
static (Shared in Visual Basic) | GeneratePseudoPrime | Makes a pseudoprime number that requires at least the given number of bits.
Public Method | GenerateRandomBits | Fills the BigInteger with random bits.
Public Method | GetBytes | Returns the value of the BigInteger as a byte array. The lowest index contains the MSB.
Public Method | GetHashCode | Overridden. Gets the hash code for the value.
Public Method | IntValue | Returns the lowest 4 bytes of the BigInteger as an int.
Public Method | IsProbablePrime | Determines whether a number is probably prime, using the Rabin-Miller's test. Before applying the test, the number is tested for divisibility by primes < 2000
Public Method | LongValue | Returns the lowest 8 bytes of the BigInteger as a long.
Public Method | ModInverse | Returns the modulo inverse of this. Throws ArithmeticException if the inverse does not exist. (i.e. Gcd(this, modulus) != 1)
Public Method | ModPow | Modulo Exponentiation. ( this ^ exp ) % n.
Public Method | Sqrt | Returns a value that is equivalent to the integer square root of the BigInteger.
Public Method | ToString | Overloaded. Overridden. Returns a string representation of the value.
Public Method | ULongValue | Returns the lowest 8 bytes of the BigInteger as a long.
Top

See Also

Reference

BigInteger Class
Internal Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Abs Method
See Also
[image]
Internal Namespace > BigInteger Class : Abs Method

Returns the absolute value of the BigInteger.

Syntax

Visual Basic (Declaration)
Public Function Abs() As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As BigInteger

value = instance.Abs()
C#
public BigInteger Abs()
Managed Extensions for C++
public: BigInteger* Abs();
C++/CLI
public:
BigInteger^ Abs();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Equals Method
See Also
[image]
Internal Namespace > BigInteger Class : Equals Method

o
Overrides the equals comparison.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal o As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim o As Object
Dim value As Boolean

value = instance.Equals(o)
C#
public override bool Equals(
   object o
)
Managed Extensions for C++
public: bool Equals(
   Object* o
) override
C++/CLI
public:
bool Equals(
   Object^ o
) override

Parameters

o

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Gcd Method
See Also
[image]
Internal Namespace > BigInteger Class : Gcd Method

bi
Returns the GCD(this, bi)

Syntax

Visual Basic (Declaration)
Public Function Gcd( _
   ByVal bi As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bi As BigInteger
Dim value As BigInteger

value = instance.Gcd(bi)
C#
public BigInteger Gcd(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger* Gcd(
   BigInteger* bi
)
C++/CLI
public:
BigInteger^ Gcd(
   BigInteger^ bi
)

Parameters

bi

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GenerateCoPrime Method
See Also
[image]
Internal Namespace > BigInteger Class : GenerateCoPrime Method

bits
Bits to use.
rand
Random number generator.
Generates a random number with the specified number of bits such that Gcd(number, this) = 1

Syntax

Visual Basic (Declaration)
Public Function GenerateCoPrime( _
   ByVal bits As Integer, _
   ByVal rand As Random _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bits As Integer
Dim rand As Random
Dim value As BigInteger

value = instance.GenerateCoPrime(bits, rand)
C#
public BigInteger GenerateCoPrime(
   int bits,
   Random rand
)
Managed Extensions for C++
public: BigInteger* GenerateCoPrime(
   int bits,
   Random* rand
)
C++/CLI
public:
BigInteger^ GenerateCoPrime(
   int bits,
   Random^ rand
)

Parameters

bits
Bits to use.
rand
Random number generator.

Return Value

Returns the co prime.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GeneratePseudoPrime Method
See Also
[image]
Internal Namespace > BigInteger Class : GeneratePseudoPrime Method

bits
The number of bits to use.
confidence
The amount of confidence required...a lower value is more confident.
rand
The random number generator.
Makes a pseudoprime number that requires at least the given number of bits.

Syntax

Visual Basic (Declaration)
Public Shared Function GeneratePseudoPrime( _
   ByVal bits As Integer, _
   ByVal confidence As Integer, _
   ByVal rand As Random _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim bits As Integer
Dim confidence As Integer
Dim rand As Random
Dim value As BigInteger

value = BigInteger.GeneratePseudoPrime(bits, confidence, rand)
C#
public static BigInteger GeneratePseudoPrime(
   int bits,
   int confidence,
   Random rand
)
Managed Extensions for C++
public: static BigInteger* GeneratePseudoPrime(
   int bits,
   int confidence,
   Random* rand
)
C++/CLI
public:
static BigInteger^ GeneratePseudoPrime(
   int bits,
   int confidence,
   Random^ rand
)

Parameters

bits
The number of bits to use.
confidence
The amount of confidence required...a lower value is more confident.
rand
The random number generator.

Return Value

Returns a pseudo prime number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GenerateRandomBits Method
See Also
[image]
Internal Namespace > BigInteger Class : GenerateRandomBits Method

bits
The minimum number of bits.
rand
The random number generator.
Fills the BigInteger with random bits.

Syntax

Visual Basic (Declaration)
Public Sub GenerateRandomBits( _
   ByVal bits As Integer, _
   ByVal rand As Random _
)
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bits As Integer
Dim rand As Random

instance.GenerateRandomBits(bits, rand)
C#
public void GenerateRandomBits(
   int bits,
   Random rand
)
Managed Extensions for C++
public: void GenerateRandomBits(
   int bits,
   Random* rand
)
C++/CLI
public:
void GenerateRandomBits(
   int bits,
   Random^ rand
)

Parameters

bits
The minimum number of bits.
rand
The random number generator.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetBytes Method
See Also
[image]
Internal Namespace > BigInteger Class : GetBytes Method

Returns the value of the BigInteger as a byte array. The lowest index contains the MSB.

Syntax

Visual Basic (Declaration)
Public Function GetBytes() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value() As Byte

value = instance.GetBytes()
C#
public byte[] GetBytes()
Managed Extensions for C++
public: byte[] GetBytes();
C++/CLI
public:
array<byte> GetBytes();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetHashCode Method
See Also
[image]
Internal Namespace > BigInteger Class : GetHashCode Method

Gets the hash code for the value.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IntValue Method
See Also
[image]
Internal Namespace > BigInteger Class : IntValue Method

Returns the lowest 4 bytes of the BigInteger as an int.

Syntax

Visual Basic (Declaration)
Public Function IntValue() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.IntValue()
C#
public int IntValue()
Managed Extensions for C++
public: int IntValue();
C++/CLI
public:
int IntValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsProbablePrime Method
See Also
[image]
Internal Namespace > BigInteger Class : IsProbablePrime Method

confidence
Amount of confidence allowed.
Determines whether a number is probably prime, using the Rabin-Miller's test. Before applying the test, the number is tested for divisibility by primes < 2000

Syntax

Visual Basic (Declaration)
Public Function IsProbablePrime( _
   ByVal confidence As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim confidence As Integer
Dim value As Boolean

value = instance.IsProbablePrime(confidence)
C#
public bool IsProbablePrime(
   int confidence
)
Managed Extensions for C++
public: bool IsProbablePrime(
   int confidence
)
C++/CLI
public:
bool IsProbablePrime(
   int confidence
)

Parameters

confidence
Amount of confidence allowed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LongValue Method
See Also
[image]
Internal Namespace > BigInteger Class : LongValue Method

Returns the lowest 8 bytes of the BigInteger as a long.

Syntax

Visual Basic (Declaration)
Public Function LongValue() As Long
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Long

value = instance.LongValue()
C#
public long LongValue()
Managed Extensions for C++
public: long LongValue();
C++/CLI
public:
long LongValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ModInverse Method
See Also
[image]
Internal Namespace > BigInteger Class : ModInverse Method

modulus
Returns the modulo inverse of this. Throws ArithmeticException if the inverse does not exist. (i.e. Gcd(this, modulus) != 1)

Syntax

Visual Basic (Declaration)
Public Function ModInverse( _
   ByVal modulus As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim modulus As BigInteger
Dim value As BigInteger

value = instance.ModInverse(modulus)
C#
public BigInteger ModInverse(
   BigInteger modulus
)
Managed Extensions for C++
public: BigInteger* ModInverse(
   BigInteger* modulus
)
C++/CLI
public:
BigInteger^ ModInverse(
   BigInteger^ modulus
)

Parameters

modulus

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ModPow Method
See Also
[image]
Internal Namespace > BigInteger Class : ModPow Method

exp
Exponent.
n
Modulus.
Modulo Exponentiation. ( this ^ exp ) % n.

Syntax

Visual Basic (Declaration)
Public Function ModPow( _
   ByVal exp As BigInteger, _
   ByVal n As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim exp As BigInteger
Dim n As BigInteger
Dim value As BigInteger

value = instance.ModPow(exp, n)
C#
public BigInteger ModPow(
   BigInteger exp,
   BigInteger n
)
Managed Extensions for C++
public: BigInteger* ModPow(
   BigInteger* exp,
   BigInteger* n
)
C++/CLI
public:
BigInteger^ ModPow(
   BigInteger^ exp,
   BigInteger^ n
)

Parameters

exp
Exponent.
n
Modulus.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Sqrt Method
See Also
[image]
Internal Namespace > BigInteger Class : Sqrt Method

Returns a value that is equivalent to the integer square root of the BigInteger.

Syntax

Visual Basic (Declaration)
Public Function Sqrt() As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As BigInteger

value = instance.Sqrt()
C#
public BigInteger Sqrt()
Managed Extensions for C++
public: BigInteger* Sqrt();
C++/CLI
public:
BigInteger^ Sqrt();

Remarks

The integer square root of "this" is defined as the largest integer n such that (n * n) <= this

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ToString Method
See Also
[image]
Internal Namespace > BigInteger Class : ToString Method

Returns a string representation of the value.

Overload List

Overload | Description
ToString() | Returns a string representation of the value.
ToString(Int32) | Returns a string representing the BigInteger in sign-and-magnitude format in the specified radix.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ToString() Method
See Also
[image]
Internal Namespace > BigInteger Class > ToString Method : ToString() Method

Returns a string representation of the value.

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ToString(Int32) Method
See Also
[image]
Internal Namespace > BigInteger Class > ToString Method : ToString(Int32) Method

radix
The radix (or base) of the value to output. Valid values are from 2 to 36.
Returns a string representing the BigInteger in sign-and-magnitude format in the specified radix.

Syntax

Visual Basic (Declaration)
Overloads Public Function ToString( _
   ByVal radix As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim radix As Integer
Dim value As String

value = instance.ToString(radix)
C#
public string ToString(
   int radix
)
Managed Extensions for C++
public: string* ToString(
   int radix
)
C++/CLI
public:
String^ ToString(
   int radix
)

Parameters

radix
The radix (or base) of the value to output. Valid values are from 2 to 36.

Return Value

Returns the formatted string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ULongValue Method
See Also
[image]
Internal Namespace > BigInteger Class : ULongValue Method

Returns the lowest 8 bytes of the BigInteger as a long.

Syntax

Visual Basic (Declaration)
Public Function ULongValue() As ULong
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As ULong

value = instance.ULongValue()
C#
public ulong ULongValue()
Managed Extensions for C++
public: ulong ULongValue();
C++/CLI
public:
ulong ULongValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
BigInteger Class Properties
See Also
[image]
Internal Namespace : BigInteger Class

For a list of all members of this type, see BigInteger members.

Public Properties

 | Name | Description
Public Property | Bits | Gets the position of the most significant bit in the value.
Top

See Also

Reference

BigInteger Class
Internal Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Bits Property
See Also
[image]
Internal Namespace > BigInteger Class : Bits Property

Gets the position of the most significant bit in the value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bits As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.Bits
C#
public int Bits {get;}
Managed Extensions for C++
public: __property int get_Bits();
C++/CLI
public:
property int Bits {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Addition Operator
See Also
[image]
Internal Namespace > BigInteger Class : Addition Operator

bi1
BigInteger 1.
bi2
BigInteger 2.
Adds two BigInteger values together.

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator +(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Addition(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator +(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
BigInteger 1.
bi2
BigInteger 2.

Return Value

Returns the sum of the two values.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
And Operator
See Also
[image]
Internal Namespace > BigInteger Class : And Operator

bi1
bi2
Bitwise AND operator.

Syntax

Visual Basic (Declaration)
Public Operator And( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator &(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_BitwiseAnd(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator &(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Or Operator
See Also
[image]
Internal Namespace > BigInteger Class : Or Operator

bi1
bi2
Bitwise OR operator.

Syntax

Visual Basic (Declaration)
Public Operator Or( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator |(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_BitwiseOr(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator |(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Decrement Operator
See Also
[image]
Internal Namespace > BigInteger Class : Decrement Operator

bi1
Decrements the BigInteger value by one.

Syntax

Visual Basic (Declaration)
This operator type is not supported by Visual Basic
C#
public BigInteger operator --(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_Decrement(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator --(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Division Operator
See Also
[image]
Internal Namespace > BigInteger Class : Division Operator

bi1
bi2
Division operator.

Syntax

Visual Basic (Declaration)
Public Operator /( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator /(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Division(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator /(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Equality Operator
See Also
[image]
Internal Namespace > BigInteger Class : Equality Operator

bi1
bi2
Equality operator.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator ==(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_Equality(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator ==(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Exclusive Or Operator
See Also
[image]
Internal Namespace > BigInteger Class : Exclusive Or Operator

bi1
bi2
Bitwise XOR operator.

Syntax

Visual Basic (Declaration)
Public Operator Xor( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator ^(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_ExclusiveOr(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator ^(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Greater Than Operator
See Also
[image]
Internal Namespace > BigInteger Class : Greater Than Operator

bi1
bi2
Greater than operator.

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator >(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_GreaterThan(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator >(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Greater Than or Equal Operator
See Also
[image]
Internal Namespace > BigInteger Class : Greater Than or Equal Operator

bi1
bi2
Greater than or equal operator.

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator >=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_GreaterThanOrEqual(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator >=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Implicit Type Conversion Operator
See Also
[image]
Internal Namespace > BigInteger Class : Implicit Type Conversion Operator

Overload List

Overload | Description
Implicit Type Conversion(Int32) |
Implicit Type Conversion(Int64) |
Implicit Type Conversion(UInt32) |
Implicit Type Conversion(UInt64) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Increment Operator
See Also
[image]
Internal Namespace > BigInteger Class : Increment Operator

bi1
Increments the BigInteger value by 1.

Syntax

Visual Basic (Declaration)
This operator type is not supported by Visual Basic
C#
public BigInteger operator ++(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_Increment(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator ++(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Inequality Operator
See Also
[image]
Internal Namespace > BigInteger Class : Inequality Operator

bi1
bi2
Inequality operator.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator !=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_Inequality(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator !=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Left-shift Operator
See Also
[image]
Internal Namespace > BigInteger Class : Left-shift Operator

bi1
shiftVal
Shifts the bits to the left.

Syntax

Visual Basic (Declaration)
Public Operator <<( _
   ByVal bi1 As BigInteger, _
   ByVal shiftVal As Integer _
) As BigInteger
C#
public BigInteger operator <<(
   BigInteger bi1,
   int shiftVal
)
Managed Extensions for C++
public: BigInteger* op_LeftShift(
   BigInteger* bi1,
   int shiftVal
)
C++/CLI
public:
BigInteger^ operator <<(
   BigInteger^ bi1,
   int shiftVal
)

Parameters

bi1
shiftVal

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Less Than Operator
See Also
[image]
Internal Namespace > BigInteger Class : Less Than Operator

bi1
bi2
Less than operator.

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator <(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_LessThan(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator <(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Less Than or Equal Operator
See Also
[image]
Internal Namespace > BigInteger Class : Less Than or Equal Operator

bi1
bi2
Less than or equal operator.

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator <=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_LessThanOrEqual(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator <=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Modulus Operator
See Also
[image]
Internal Namespace > BigInteger Class : Modulus Operator

bi1
bi2
Modulus operator.

Syntax

Visual Basic (Declaration)
Public Operator Mod( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator %(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Modulus(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator %(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Multiplication Operator
See Also
[image]
Internal Namespace > BigInteger Class : Multiplication Operator

bi1
bi2
Multiplies two BigInteger values.

Syntax

Visual Basic (Declaration)
Public Operator *( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator *(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Multiply(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator *(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Bitwise Complement Operator
See Also
[image]
Internal Namespace > BigInteger Class : Bitwise Complement Operator

bi1
Implements a 1's compliment.

Syntax

Visual Basic (Declaration)
Public Operator Not( _
   ByVal bi1 As BigInteger _
) As BigInteger
C#
public BigInteger operator ~(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_OnesComplement(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator ~(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Right-shift Operator
See Also
[image]
Internal Namespace > BigInteger Class : Right-shift Operator

bi1
shiftVal
Shifts the bits to the right.

Syntax

Visual Basic (Declaration)
Public Operator >>( _
   ByVal bi1 As BigInteger, _
   ByVal shiftVal As Integer _
) As BigInteger
C#
public BigInteger operator >>(
   BigInteger bi1,
   int shiftVal
)
Managed Extensions for C++
public: BigInteger* op_RightShift(
   BigInteger* bi1,
   int shiftVal
)
C++/CLI
public:
BigInteger^ operator >>(
   BigInteger^ bi1,
   int shiftVal
)

Parameters

bi1
shiftVal

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Subtraction Operator
See Also
[image]
Internal Namespace > BigInteger Class : Subtraction Operator

bi1
bi2
Subtracts one BigInteger from another.

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator -(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Subtraction(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator -(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Unary Negation Operator
See Also
[image]
Internal Namespace > BigInteger Class : Unary Negation Operator

bi1
Implements a 2's compliment (negative).

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal bi1 As BigInteger _
) As BigInteger
C#
public BigInteger operator -(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_UnaryNegation(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator -(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
CommonRegexes Class
See Also Members
[image]
Internal Namespace : CommonRegexes Class

Declares static versions of some common regular expressions.

Syntax

Visual Basic (Declaration)
Private NotInheritable Class CommonRegexes
Visual Basic (Usage) Copy Code
Dim instance As CommonRegexes
C#
private sealed class CommonRegexes
Managed Extensions for C++
private __gc __sealed class CommonRegexes
C++/CLI
private ref class CommonRegexes sealed

Inheritance Hierarchy

System.Object
Internal.CommonRegexes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Members
Internal Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
CommonRegexes Class Members
See Also Fields
[image]
Internal Namespace : CommonRegexes Class

The following tables list the members exposed by CommonRegexes.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DomainName | Pattern for matching against any valid domain name.
static (Shared in Visual Basic) | Email | Pattern for matching against any valid email address.
static (Shared in Visual Basic) | FileName | Pattern for matching a Windows file path.
static (Shared in Visual Basic) | FilePath | Pattern for matching a Windows file path.
static (Shared in Visual Basic) | FullyQualifiedUrl | Pattern for matching against any valid URL.
static (Shared in Visual Basic) | FullyQualifiedUrlFolder | Pattern for matching a fully qualified URL that has no file name.
static (Shared in Visual Basic) | IpAddress | Pattern for matching against any valid IP address.
static (Shared in Visual Basic) | Url | Pattern for matching against any valid URL.
static (Shared in Visual Basic) | UrlFolder | Pattern for matching against any valid URL that has no file name.
static (Shared in Visual Basic) | UsEin | Pattern for a US employer identification number.
static (Shared in Visual Basic) | UsPhone | Pattern for a US 10-digit phone number.
static (Shared in Visual Basic) | UsSsn | Pattern for a US social security number.
static (Shared in Visual Basic) | UsSsnOrEin | Pattern for a US social security number or an employer identification number.
static (Shared in Visual Basic) | UsZip | Pattern for a US 5-digit zip code with an optional 4 digit exchange.
static (Shared in Visual Basic) | UsZip5 | Pattern for a US 5-digit zip code.
static (Shared in Visual Basic) | UsZip5Plus4 | Pattern for a US 5-digit zip code plus 4 digit exchange.
Top

See Also

Reference

CommonRegexes Class
Internal Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET Send comments on this topic.
CommonRegexes Class Fields
See Also
[image]
Internal Namespace : CommonRegexes Class

For a list of all members of this type, see CommonRegexes members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DomainName | Pattern for matching against any valid domain name.
static (Shared in Visual Basic) | Email | Pattern for matching against any valid email address.
static (Shared in Visual Basic) | FileName | Pattern for matching a Windows file path.
static (Shared in Visual Basic) | FilePath | Pattern for matching a Windows file path.
static (Shared in Visual Basic) | FullyQualifiedUrl | Pattern for matching against any valid URL.
static (Shared in Visual Basic) | FullyQualifiedUrlFolder | Pattern for matching a fully qualified URL that has no file name.
static (Shared in Visual Basic) | IpAddress | Pattern for matching against any valid IP address.
static (Shared in Visual Basic) | Url | Pattern for matching against any valid URL.
static (Shared in Visual Basic) | UrlFolder | Pattern for matching against any valid URL that has no file name.
static (Shared in Visual Basic) | UsEin | Pattern for a US employer identification number.
static (Shared in Visual Basic) | UsPhone | Pattern for a US 10-digit phone number.
static (Shared in Visual Basic) | UsSsn | Pattern for a US social security number.
static (Shared in Visual Basic) | UsSsnOrEin | Pattern for a US social security number or an employer identification number.
static (Shared in Visual Basic) | UsZip | Pattern for a US 5-digit zip code with an optional 4 digit exchange.
static (Shared in Visual Basic) | UsZip5 | Pattern for a US 5-digit zip code.
static (Shared in Visual Basic) | UsZip5Plus4 | Pattern for a US 5-digit zip code plus 4 digit exchange.
Top

See Also

Reference

CommonRegexes Class
Internal Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
DomainName Field
See Also
[image]
Internal Namespace > CommonRegexes Class : DomainName Field

Pattern for matching against any valid domain name.

Syntax

Visual Basic (Declaration)
Public Shared DomainName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.DomainName

CommonRegexes.DomainName = value
C#
public static string DomainName
Managed Extensions for C++
public: static string* DomainName
C++/CLI
public:
static String^ DomainName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Email Field
See Also
[image]
Internal Namespace > CommonRegexes Class : Email Field

Pattern for matching against any valid email address.

Syntax

Visual Basic (Declaration)
Public Shared Email As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.Email

CommonRegexes.Email = value
C#
public static string Email
Managed Extensions for C++
public: static string* Email
C++/CLI
public:
static String^ Email

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
FileName Field
See Also
[image]
Internal Namespace > CommonRegexes Class : FileName Field

Pattern for matching a Windows file path.

Syntax

Visual Basic (Declaration)
Public Shared FileName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.FileName

CommonRegexes.FileName = value
C#
public static string FileName
Managed Extensions for C++
public: static string* FileName
C++/CLI
public:
static String^ FileName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
FilePath Field
See Also
[image]
Internal Namespace > CommonRegexes Class : FilePath Field

Pattern for matching a Windows file path.

Syntax

Visual Basic (Declaration)
Public Shared FilePath As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.FilePath

CommonRegexes.FilePath = value
C#
public static string FilePath
Managed Extensions for C++
public: static string* FilePath
C++/CLI
public:
static String^ FilePath

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
FullyQualifiedUrl Field
See Also
[image]
Internal Namespace > CommonRegexes Class : FullyQualifiedUrl Field

Pattern for matching against any valid URL.

Syntax

Visual Basic (Declaration)
Public Shared FullyQualifiedUrl As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.FullyQualifiedUrl

CommonRegexes.FullyQualifiedUrl = value
C#
public static string FullyQualifiedUrl
Managed Extensions for C++
public: static string* FullyQualifiedUrl
C++/CLI
public:
static String^ FullyQualifiedUrl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
FullyQualifiedUrlFolder Field
See Also
[image]
Internal Namespace > CommonRegexes Class : FullyQualifiedUrlFolder Field

Pattern for matching a fully qualified URL that has no file name.

Syntax

Visual Basic (Declaration)
Public Shared FullyQualifiedUrlFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.FullyQualifiedUrlFolder

CommonRegexes.FullyQualifiedUrlFolder = value
C#
public static string FullyQualifiedUrlFolder
Managed Extensions for C++
public: static string* FullyQualifiedUrlFolder
C++/CLI
public:
static String^ FullyQualifiedUrlFolder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IpAddress Field
See Also
[image]
Internal Namespace > CommonRegexes Class : IpAddress Field

Pattern for matching against any valid IP address.

Syntax

Visual Basic (Declaration)
Public Shared IpAddress As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.IpAddress

CommonRegexes.IpAddress = value
C#
public static string IpAddress
Managed Extensions for C++
public: static string* IpAddress
C++/CLI
public:
static String^ IpAddress

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Url Field
See Also
[image]
Internal Namespace > CommonRegexes Class : Url Field

Pattern for matching against any valid URL.

Syntax

Visual Basic (Declaration)
Public Shared Url As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.Url

CommonRegexes.Url = value
C#
public static string Url
Managed Extensions for C++
public: static string* Url
C++/CLI
public:
static String^ Url

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UrlFolder Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UrlFolder Field

Pattern for matching against any valid URL that has no file name.

Syntax

Visual Basic (Declaration)
Public Shared UrlFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UrlFolder

CommonRegexes.UrlFolder = value
C#
public static string UrlFolder
Managed Extensions for C++
public: static string* UrlFolder
C++/CLI
public:
static String^ UrlFolder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UsEin Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsEin Field

Pattern for a US employer identification number.

Syntax

Visual Basic (Declaration)
Public Shared UsEin As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsEin

CommonRegexes.UsEin = value
C#
public static string UsEin
Managed Extensions for C++
public: static string* UsEin
C++/CLI
public:
static String^ UsEin

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UsPhone Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsPhone Field

Pattern for a US 10-digit phone number.

Syntax

Visual Basic (Declaration)
Public Shared UsPhone As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsPhone

CommonRegexes.UsPhone = value
C#
public static string UsPhone
Managed Extensions for C++
public: static string* UsPhone
C++/CLI
public:
static String^ UsPhone

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UsSsn Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsSsn Field

Pattern for a US social security number.

Syntax

Visual Basic (Declaration)
Public Shared UsSsn As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsSsn

CommonRegexes.UsSsn = value
C#
public static string UsSsn
Managed Extensions for C++
public: static string* UsSsn
C++/CLI
public:
static String^ UsSsn

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UsSsnOrEin Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsSsnOrEin Field

Pattern for a US social security number or an employer identification number.

Syntax

Visual Basic (Declaration)
Public Shared UsSsnOrEin As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsSsnOrEin

CommonRegexes.UsSsnOrEin = value
C#
public static string UsSsnOrEin
Managed Extensions for C++
public: static string* UsSsnOrEin
C++/CLI
public:
static String^ UsSsnOrEin

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UsZip Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsZip Field

Pattern for a US 5-digit zip code with an optional 4 digit exchange.

Syntax

Visual Basic (Declaration)
Public Shared UsZip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsZip

CommonRegexes.UsZip = value
C#
public static string UsZip
Managed Extensions for C++
public: static string* UsZip
C++/CLI
public:
static String^ UsZip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UsZip5 Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsZip5 Field

Pattern for a US 5-digit zip code.

Syntax

Visual Basic (Declaration)
Public Shared UsZip5 As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsZip5

CommonRegexes.UsZip5 = value
C#
public static string UsZip5
Managed Extensions for C++
public: static string* UsZip5
C++/CLI
public:
static String^ UsZip5

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UsZip5Plus4 Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsZip5Plus4 Field

Pattern for a US 5-digit zip code plus 4 digit exchange.

Syntax

Visual Basic (Declaration)
Public Shared UsZip5Plus4 As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsZip5Plus4

CommonRegexes.UsZip5Plus4 = value
C#
public static string UsZip5Plus4
Managed Extensions for C++
public: static string* UsZip5Plus4
C++/CLI
public:
static String^ UsZip5Plus4

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%ItemTitle%%

Barcode4NET Send comments on this topic.
O2S.Barcode4NET Namespace (Barcode4NET)
See Also Inheritance Hierarchy
Root namespace for all barcodes included in Barcode4NET toolkit.

Classes

Class | Description
Barcode | Defines the base class for all barcode types.
BarcodeEncodingException | Defines an exception that is thrown when the barcode data can not be encoded according to barcode's rules.
BasePDF417Barcode | Defines the base class for all PDF 417 barcodes.
BidimensionalBarcode | Defines the base class for all bidimensional barcodes.
CodabarBarcode | Defines a Codabar barcode.
CodablockFBarcode | Defines a CODABLOCK F barcode.
Code11Barcode | Defines a Code 11 barcode.
Code128ABarcode | Defines a Code 128 barcode.
Code128Barcode | Defines the base class for all Code 128 barcodes.
Code128BBarcode | Defines a Code 128 barcode.
Code128CBarcode | Defines a Code 128 barcode.
Code16KBarcode | Defines a Code 16K barcode.
Code25Barcode | Defines a Code 2 of 5 barcode.
Code25InterleavedBarcode | Defines an Interleaved 2 of 5 barcode.
Code39Barcode | Defines a Code 39 barcode.
Code39ExtendedBarcode | Defines an extended Code 39 barcode.
Code93Barcode | Defines a Code 93 barcode.
Code93ExtendedBarcode | Defines an extended Code 93 barcode.
COOP25Barcode | Defines a COOP 2 of 5 barcode.
DataMatrixBarcode | Defines a DataMatrix barcode.
EAN13Barcode | Defines the class for EAN-13 barcodes.
EAN8Barcode | Defines the class for EAN-8 barcodes.
EANBarcode | Defines the base class for EAN based barcodes.
HeightModulatedBarcode | Defines the base class for all height modulated barcodes.
IATA25Barcode | Defines a IATA 2 of 5 barcode.
ISBNBarcode | Defines the class for ISBN barcodes.
ISMNBarcode | Defines the class for ISMN barcodes.
ISSNBarcode | Defines the class for ISSN barcodes.
JAN13Barcode | Defines the class for JAN13 barcodes.
Matrix25Barcode | Defines a Matrix 2 of 5 barcode.
MicroPDF417Barcode | Defines a Micro PDF 417 barcode.
MSIPlesseyBarcode | Defines a MSI/Plessey barcode.
PDF417Barcode | Defines a PDF 417 barcode.
PlanetBarcode | Defines a Planet barcode.
PostnetBarcode | Defines a Postnet barcode.
RM4SCCBarcode | Defines a RM4SCC barcode.
SCC14Barcode | Defines a SCC-14 barcode.
SSCC18Barcode | Defines a SSCC-18 barcode.
UnidimensionalBarcode | Defines the base class for 1D barcodes.
UPCABarcode | Defines the class for UPC-A barcodes.
UPCEBarcode | Defines the class for UPC-E barcodes.

Enumerations

Enumeration | Description
BarcodeImageFormat | Specifies the available file formats for saving a barcode image.
BarcodeRotation | Specifies the available rotation angles of the barcode image.
BarcodeSymbology | Specifies the available barcode symbologies.
BarcodeTextLocation | Specifies the available locations for displaying text on a linear barcode.
DataMatrixEncoding | Specifies the available encoding modes for a DataMatrix barcode.
DataMatrixSymbolSize | Specifies the available sizes for a DataMatrix symbol.
MicroPDF417SymbolSize | Specifies the available sizes for a Micro PDF417 symbol.
PDF417DataCompactionMode | Specifies the available data compaction modes for a PDF417 barcode.
PDF417ErrorCorrectionLevel | Specifies the available error correction levels for a PDF417 barcode.
XYDimensionUnit | Specifies the unit of measure for the barcode's XDimension and YDimension properties.

See Also

Reference

Barcode4NET Assembly


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Barcode Class

Defines the base class for all barcode types.

Syntax

Visual Basic (Declaration)
Public MustInherit Class Barcode
Visual Basic (Usage) Copy Code
Dim instance As Barcode
C#
public abstract class Barcode
Managed Extensions for C++
public __gc abstract class Barcode
C++/CLI
public ref class Barcode abstract

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.BidimensionalBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Barcode Class

The following tables list the members exposed by Barcode.

Public Constructors

 | Name | Description
Public Constructor | Barcode Constructor | Initializes a new Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode.
Public Property | BarColor | Gets or sets the color of the bars.
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode.
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties.
Public Property | Font | Gets or sets the font used to display the barcode text.
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode.
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode.
Public Property | Rotation | Gets or sets the rotation angle of the barcode image.
Public Property | SerialNumber | Gets or sets the serial number.
Public Property | TextColor | Gets or sets the color of the barcode text.
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode.
Public Property | XDimension | Gets or sets the width of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface.
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution.
Public Method | GetImageData | Gets the barcode image as a byte array.
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution.
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode.
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format.
Top

See Also

Reference

Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : Barcode Constructor

Initializes a new Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Barcode()
C#
public Barcode()
Managed Extensions for C++
public: Barcode();
C++/CLI
public:
Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Barcode Class

For a list of all members of this type, see Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface.
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution.
Public Method | GetImageData | Gets the barcode image as a byte array.
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution.
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode.
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format.
Top

See Also

Reference

Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Draw Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : Draw Method

Draws the barcode on a graphics surface.

Overload List

Overload | Description
Draw(Graphics) | Draws the barcode on a graphics surface.
Draw(Graphics,Int32,Int32) | Draws the barcode on a graphics surface.
Draw(Graphics,Single,Single) | Draws the barcode on a graphics surface.
Draw(Graphics,Single,Single,Single,Single) | Draws the barcode on a graphics surface.

Exceptions

Exception | Description
BarcodeEncodingException | Thrown when the barcode can not encode the given data.

Remarks

This method draws the barcode on a graphics surface. The top left corner of the barcode is drawn at (0, 0).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Draw(Graphics) Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class > Draw Method : Draw(Graphics) Method

g
The Graphics surface to draw the barcode on.
Draws the barcode on a graphics surface.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Draw( _
   ByVal g As Graphics _
)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim g As Graphics

instance.Draw(g)
C#
public void Draw(
   Graphics g
)
Managed Extensions for C++
public: void Draw(
   Graphics g
)
C++/CLI
public:
void Draw(
   Graphics g
)

Parameters

g
The Graphics surface to draw the barcode on.

Exceptions

Exception | Description
BarcodeEncodingException | Thrown when the barcode can not encode the given data.

Remarks

This method draws the barcode on a graphics surface. The top left corner of the barcode is drawn at (0, 0).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Draw(Graphics,Int32,Int32) Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class > Draw Method : Draw(Graphics,Int32,Int32) Method

g
The Graphics surface to draw the barcode on.
x
The X coordinate of the top left corner of the barcode.
y
The Y coordinate of the top left corner of the barcode.
Draws the barcode on a graphics surface.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Draw( _
   ByVal g As Graphics, _
   ByVal x As Integer, _
   ByVal y As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim g As Graphics
Dim x As Integer
Dim y As Integer

instance.Draw(g, x, y)
C#
public void Draw(
   Graphics g,
   int x,
   int y
)
Managed Extensions for C++
public: void Draw(
   Graphics g,
   int x,
   int y
)
C++/CLI
public:
void Draw(
   Graphics g,
   int x,
   int y
)

Parameters

g
The Graphics surface to draw the barcode on.
x
The X coordinate of the top left corner of the barcode.
y
The Y coordinate of the top left corner of the barcode.

Exceptions

Exception | Description
BarcodeEncodingException | Thrown when the barcode can not encode the given data.

Remarks

This method draws the barcode on a graphics surface. The top left corner of the barcode is drawn at (x, y).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Draw(Graphics,Single,Single) Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class > Draw Method : Draw(Graphics,Single,Single) Method

g
The Graphics surface to draw the barcode on.
x
The X coordinate of the top left corner of the barcode.
y
The Y coordinate of the top left corner of the barcode.
Draws the barcode on a graphics surface.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Draw( _
   ByVal g As Graphics, _
   ByVal x As Single, _
   ByVal y As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim g As Graphics
Dim x As Single
Dim y As Single

instance.Draw(g, x, y)
C#
public void Draw(
   Graphics g,
   float x,
   float y
)
Managed Extensions for C++
public: void Draw(
   Graphics g,
   float x,
   float y
)
C++/CLI
public:
void Draw(
   Graphics g,
   float x,
   float y
)

Parameters

g
The Graphics surface to draw the barcode on.
x
The X coordinate of the top left corner of the barcode.
y
The Y coordinate of the top left corner of the barcode.

Exceptions

Exception | Description
BarcodeEncodingException | Thrown when the barcode can not encode the given data.

Remarks

This method draws the barcode on a graphics surface. The top left corner of the barcode is drawn at (x, y).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Draw(Graphics,Single,Single,Single,Single) Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class > Draw Method : Draw(Graphics,Single,Single,Single,Single) Method

g
The Graphics surface to draw the barcode on.
x
The X coordinate of the top left corner of the barcode.
y
The Y coordinate of the top left corner of the barcode.
scaleX
Scale factor in the x direction.
scaleY
Scale factor in the y direction.
Draws the barcode on a graphics surface.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Draw( _
   ByVal g As Graphics, _
   ByVal x As Single, _
   ByVal y As Single, _
   ByVal scaleX As Single, _
   ByVal scaleY As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim g As Graphics
Dim x As Single
Dim y As Single
Dim scaleX As Single
Dim scaleY As Single

instance.Draw(g, x, y, scaleX, scaleY)
C#
public void Draw(
   Graphics g,
   float x,
   float y,
   float scaleX,
   float scaleY
)
Managed Extensions for C++
public: void Draw(
   Graphics g,
   float x,
   float y,
   float scaleX,
   float scaleY
)
C++/CLI
public:
void Draw(
   Graphics g,
   float x,
   float y,
   float scaleX,
   float scaleY
)

Parameters

g
The Graphics surface to draw the barcode on.
x
The X coordinate of the top left corner of the barcode.
y
The Y coordinate of the top left corner of the barcode.
scaleX
Scale factor in the x direction.
scaleY
Scale factor in the y direction.

Exceptions

Exception | Description
BarcodeEncodingException | Thrown when the barcode can not encode the given data.

Remarks

This method draws the barcode on a graphics surface. The top left corner of the barcode is drawn at (x, y).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetImage Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : GetImage Method

Gets the image of the barcode at the specified resolution.

Overload List

Overload | Description
GetImage(Single) | Gets the image of the barcode at the specified resolution.
GetImage(Single,Single) | Gets the image of the barcode at the specified horizontal and vertical resolutions.

Remarks

If the DimensionUnit property is Pixel, then the resolution has no effect because all the dimensions are already measured in pixels.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetImage(Single) Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class > GetImage Method : GetImage(Single) Method

dpi
The resolution of the barcode image.
Gets the image of the barcode at the specified resolution.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetImage( _
   ByVal dpi As Single _
) As Bitmap
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim dpi As Single
Dim value As Bitmap

value = instance.GetImage(dpi)
C#
public Bitmap GetImage(
   float dpi
)
Managed Extensions for C++
public: Bitmap GetImage(
   float dpi
)
C++/CLI
public:
Bitmap GetImage(
   float dpi
)

Parameters

dpi
The resolution of the barcode image.

Return Value

A Bitmap object with the barcode image or null (Nothing in VB.NET) if the data can not be encoded as barcode.

Remarks

If the DimensionUnit property is Pixel, then the resolution has no effect because all the dimensions are already measured in pixels.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetImage(Single,Single) Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class > GetImage Method : GetImage(Single,Single) Method

dpiX
The horizontal resolution of the barcode image.
dpiY
The vertical resolution of the barcode image.
Gets the image of the barcode at the specified horizontal and vertical resolutions.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetImage( _
   ByVal dpiX As Single, _
   ByVal dpiY As Single _
) As Bitmap
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim dpiX As Single
Dim dpiY As Single
Dim value As Bitmap

value = instance.GetImage(dpiX, dpiY)
C#
public Bitmap GetImage(
   float dpiX,
   float dpiY
)
Managed Extensions for C++
public: Bitmap GetImage(
   float dpiX,
   float dpiY
)
C++/CLI
public:
Bitmap GetImage(
   float dpiX,
   float dpiY
)

Parameters

dpiX
The horizontal resolution of the barcode image.
dpiY
The vertical resolution of the barcode image.

Return Value

A Bitmap object with the barcode image or null (Nothing in VB.NET) if the data can not be encoded as barcode.

Remarks

If the DimensionUnit property is Pixel, then the resolution has no effect because all the dimensions are already measured in pixels.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetImageData Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : GetImageData Method

barcodeImageFormat
The format of the barcode image to return.
dpi
The dpi of the barcode image.
Gets the barcode image as a byte array.

Syntax

Visual Basic (Declaration)
Public Function GetImageData( _
   ByVal barcodeImageFormat As BarcodeImageFormat, _
   ByVal dpi As Single _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim barcodeImageFormat As BarcodeImageFormat
Dim dpi As Single
Dim value() As Byte

value = instance.GetImageData(barcodeImageFormat, dpi)
C#
public byte[] GetImageData(
   BarcodeImageFormat barcodeImageFormat,
   float dpi
)
Managed Extensions for C++
public: byte[] GetImageData(
   BarcodeImageFormat barcodeImageFormat,
   float dpi
)
C++/CLI
public:
array<byte> GetImageData(
   BarcodeImageFormat barcodeImageFormat,
   float dpi
)

Parameters

barcodeImageFormat
The format of the barcode image to return.
dpi
The dpi of the barcode image.

Return Value

A byte array with the actual barcode image.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when dpi is 0 and DimensionUnit is different from Pixel.

Remarks

The dpi parameter has effect only on raster image formats (Bmp, Gif, Jpeg, Png, Tiff) and only if DimensionUnit is not Pixel.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetSize Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : GetSize Method

Gets the size of the barcode image at the specified resolution.

Overload List

Overload | Description
GetSize(Single) | Gets the size of the barcode image at the specified resolution.
GetSize(Single,Single) | Gets the size of the barcode image at the specified horizontal and vertical resolutions.

Remarks

If either the Width or the Height properties of the returned structure are -1, then the data can not be encoded as a barcode and an exception will be thrown when drawing the barcode.
If the DimensionUnit property is Pixel, then the resolution has no effect because all the dimensions are already measured in pixels.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetSize(Single) Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class > GetSize Method : GetSize(Single) Method

dpi
The resolution of the barcode image.
Gets the size of the barcode image at the specified resolution.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetSize( _
   ByVal dpi As Single _
) As SizeF
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim dpi As Single
Dim value As SizeF

value = instance.GetSize(dpi)
C#
public SizeF GetSize(
   float dpi
)
Managed Extensions for C++
public: SizeF GetSize(
   float dpi
)
C++/CLI
public:
SizeF GetSize(
   float dpi
)

Parameters

dpi
The resolution of the barcode image.

Return Value

A SizeF structure with the size of the barcode image.

Remarks

If either the Width or the Height properties of the returned structure are -1, then the data can not be encoded as a barcode and an exception will be thrown when drawing the barcode.
If the DimensionUnit property is Pixel, then the resolution has no effect because all the dimensions are already measured in pixels.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetSize(Single,Single) Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class > GetSize Method : GetSize(Single,Single) Method

dpiX
The horizontal resolution of the barcode image.
dpiY
The vertical resolution of the barcode image.
Gets the size of the barcode image at the specified horizontal and vertical resolutions.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetSize( _
   ByVal dpiX As Single, _
   ByVal dpiY As Single _
) As SizeF
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim dpiX As Single
Dim dpiY As Single
Dim value As SizeF

value = instance.GetSize(dpiX, dpiY)
C#
public SizeF GetSize(
   float dpiX,
   float dpiY
)
Managed Extensions for C++
public: SizeF GetSize(
   float dpiX,
   float dpiY
)
C++/CLI
public:
SizeF GetSize(
   float dpiX,
   float dpiY
)

Parameters

dpiX
The horizontal resolution of the barcode image.
dpiY
The vertical resolution of the barcode image.

Return Value

A SizeF structure with the size of the barcode image.

Remarks

If either the Width or the Height properties of the returned structure are -1, then the data can not be encoded as a barcode and an exception will be thrown when drawing the barcode.
If the DimensionUnit property is Pixel, then the resolution has no effect because all the dimensions are already measured in pixels.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsValidCharacterCode Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : IsValidCharacterCode Method

characterCode
The character code to test.
Gets whether the given character code can be encoded by the barcode.

Syntax

Visual Basic (Declaration)
Public Overridable Function IsValidCharacterCode( _
   ByVal characterCode As Byte _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim characterCode As Byte
Dim value As Boolean

value = instance.IsValidCharacterCode(characterCode)
C#
public virtual bool IsValidCharacterCode(
   byte characterCode
)
Managed Extensions for C++
public: virtual bool IsValidCharacterCode(
   byte characterCode
)
C++/CLI
public:
virtual bool IsValidCharacterCode(
   byte characterCode
)

Parameters

characterCode
The character code to test.

Return Value

True if the character code can be encoded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Save Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : Save Method

Saves this Barcode object to the specified file in the specified format.

Overload List

Overload | Description
Save(String,BarcodeImageFormat,Single) | Saves this Barcode object to the specified file in the specified format.
Save(Stream,BarcodeImageFormat,Single) | Saves this Barcode object to the specified stream in the specified format.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when dpi is 0 and DimensionUnit is different from Pixel.

Remarks

The dpi parameter has effect only on raster image formats (Bmp, Gif, Jpeg, Png, Tiff) and only if DimensionUnit is not Pixel.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Save(String,BarcodeImageFormat,Single) Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class > Save Method : Save(String,BarcodeImageFormat,Single) Method

fileName
A string that contains the name of the file to which to save this Barcode object.
barcodeImageFormat
The format of barcode image file.
dpi
The resolution for barcode image.
Saves this Barcode object to the specified file in the specified format.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal fileName As String, _
   ByVal barcodeImageFormat As BarcodeImageFormat, _
   ByVal dpi As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim fileName As String
Dim barcodeImageFormat As BarcodeImageFormat
Dim dpi As Single

instance.Save(fileName, barcodeImageFormat, dpi)
C#
public void Save(
   string fileName,
   BarcodeImageFormat barcodeImageFormat,
   float dpi
)
Managed Extensions for C++
public: void Save(
   string* fileName,
   BarcodeImageFormat barcodeImageFormat,
   float dpi
)
C++/CLI
public:
void Save(
   String^ fileName,
   BarcodeImageFormat barcodeImageFormat,
   float dpi
)

Parameters

fileName
A string that contains the name of the file to which to save this Barcode object.
barcodeImageFormat
The format of barcode image file.
dpi
The resolution for barcode image.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when dpi is 0 and DimensionUnit is different from Pixel.

Remarks

The dpi parameter has effect only on raster image formats (Bmp, Gif, Jpeg, Png, Tiff) and only if DimensionUnit is not Pixel.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Save(Stream,BarcodeImageFormat,Single) Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class > Save Method : Save(Stream,BarcodeImageFormat,Single) Method

stream
The Stream where the Barcode object will be saved.
barcodeImageFormat
The format of barcode image file.
dpi
The resolution for barcode image.
Saves this Barcode object to the specified stream in the specified format.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream, _
   ByVal barcodeImageFormat As BarcodeImageFormat, _
   ByVal dpi As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim stream As Stream
Dim barcodeImageFormat As BarcodeImageFormat
Dim dpi As Single

instance.Save(stream, barcodeImageFormat, dpi)
C#
public void Save(
   Stream stream,
   BarcodeImageFormat barcodeImageFormat,
   float dpi
)
Managed Extensions for C++
public: void Save(
   Stream* stream,
   BarcodeImageFormat barcodeImageFormat,
   float dpi
)
C++/CLI
public:
void Save(
   Stream^ stream,
   BarcodeImageFormat barcodeImageFormat,
   float dpi
)

Parameters

stream
The Stream where the Barcode object will be saved.
barcodeImageFormat
The format of barcode image file.
dpi
The resolution for barcode image.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when dpi is 0 and DimensionUnit is different from Pixel.

Remarks

The dpi parameter has effect only on raster image formats (Bmp, Gif, Jpeg, Png, Tiff) and only if DimensionUnit is not Pixel.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Barcode Class

For a list of all members of this type, see Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode.
Public Property | BarColor | Gets or sets the color of the bars.
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode.
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties.
Public Property | Font | Gets or sets the font used to display the barcode text.
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode.
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode.
Public Property | Rotation | Gets or sets the rotation angle of the barcode image.
Public Property | SerialNumber | Gets or sets the serial number.
Public Property | TextColor | Gets or sets the color of the barcode text.
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode.
Public Property | XDimension | Gets or sets the width of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

See Also

Reference

Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BackColor Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : BackColor Property

Gets or sets the background color of the barcode.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
public Color BackColor {get; set;}
Managed Extensions for C++
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
C++/CLI
public:
property Color BackColor {
   Color get();
   void set (Color value);
}

Return Value

A Color object specifying the background color of barcode.

Remarks

If this property is Empty, then the barcode's background will be transparent. Default barcode background color is white.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BarColor Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : BarColor Property

Gets or sets the color of the bars.

Syntax

Visual Basic (Declaration)
Public Property BarColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Color

instance.BarColor = value

value = instance.BarColor
C#
public Color BarColor {get; set;}
Managed Extensions for C++
public: __property Color get_BarColor();
public: __property void set_BarColor(
   Color value
);
C++/CLI
public:
property Color BarColor {
   Color get();
   void set (Color value);
}

Return Value

A Color object specifying the color of the bars.

Remarks

If this property is Empty, then no bars are shown. Default bars color is black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BottomQuietZone Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : BottomQuietZone Property

Gets or sets the bottom quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property BottomQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Single

instance.BottomQuietZone = value

value = instance.BottomQuietZone
C#
public float BottomQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_BottomQuietZone();
public: __property void set_BottomQuietZone(
   float value
);
C++/CLI
public:
property float BottomQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of bottom quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the bottom quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Data Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : Data Property

Gets or sets the string to be encoded as barcode.

Syntax

Visual Basic (Declaration)
Public Property Data As String
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As String

instance.Data = value

value = instance.Data
C#
public string Data {get; set;}
Managed Extensions for C++
public: __property string* get_Data();
public: __property void set_Data(
   string* value
);
C++/CLI
public:
property String^ Data {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the value to be encoded as barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length (applies to some barcodes only).

Remarks

The characters allowed to be encoded are defined by each barcode type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
DimensionUnit Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : DimensionUnit Property

Gets or sets the measure unit for the XDimension and YDimension properties.

Syntax

Visual Basic (Declaration)
Public Property DimensionUnit As XYDimensionUnit
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As XYDimensionUnit

instance.DimensionUnit = value

value = instance.DimensionUnit
C#
public XYDimensionUnit DimensionUnit {get; set;}
Managed Extensions for C++
public: __property XYDimensionUnit get_DimensionUnit();
public: __property void set_DimensionUnit(
   XYDimensionUnit value
);
C++/CLI
public:
property XYDimensionUnit DimensionUnit {
   XYDimensionUnit get();
   void set (XYDimensionUnit value);
}

Return Value

A XYDimensionUnit enumeration member specifying the measure unit for the XDimension and YDimension properties.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Font Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : Font Property

Gets or sets the font used to display the barcode text.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Font

instance.Font = value

value = instance.Font
C#
public Font Font {get; set;}
Managed Extensions for C++
public: __property Font get_Font();
public: __property void set_Font(
   Font value
);
C++/CLI
public:
property Font Font {
   Font get();
   void set (Font value);
}

Return Value

A Font object used to display the barcode text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LeftQuietZone Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : LeftQuietZone Property

Gets or sets the left quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property LeftQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Single

instance.LeftQuietZone = value

value = instance.LeftQuietZone
C#
public float LeftQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_LeftQuietZone();
public: __property void set_LeftQuietZone(
   float value
);
C++/CLI
public:
property float LeftQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of left quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the left quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
RightQuietZone Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : RightQuietZone Property

Gets or sets the right quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property RightQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Single

instance.RightQuietZone = value

value = instance.RightQuietZone
C#
public float RightQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_RightQuietZone();
public: __property void set_RightQuietZone(
   float value
);
C++/CLI
public:
property float RightQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of right quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the right quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Rotation Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : Rotation Property

Gets or sets the rotation angle of the barcode image.

Syntax

Visual Basic (Declaration)
Public Property Rotation As BarcodeRotation
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As BarcodeRotation

instance.Rotation = value

value = instance.Rotation
C#
public BarcodeRotation Rotation {get; set;}
Managed Extensions for C++
public: __property BarcodeRotation get_Rotation();
public: __property void set_Rotation(
   BarcodeRotation value
);
C++/CLI
public:
property BarcodeRotation Rotation {
   BarcodeRotation get();
   void set (BarcodeRotation value);
}

Return Value

A BarcodeRotation enumeration member specifying the rotation angle of the barcode image.

Remarks

The barcode image is rotated counterclockwise around the top left corner.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SerialNumber Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : SerialNumber Property

Gets or sets the serial number.

Syntax

Visual Basic (Declaration)
Public Property SerialNumber As String
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As String

instance.SerialNumber = value

value = instance.SerialNumber
C#
public string SerialNumber {get; set;}
Managed Extensions for C++
public: __property string* get_SerialNumber();
public: __property void set_SerialNumber(
   string* value
);
C++/CLI
public:
property String^ SerialNumber {
   String^ get();
   void set (String^ value);
}

Return Value

The Barcode4NET serial number.

Remarks

The serial number unlocks the Barcode4NET library and removes the TRIAL watermark from the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
TextColor Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : TextColor Property

Gets or sets the color of the barcode text.

Syntax

Visual Basic (Declaration)
Public Property TextColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Color

instance.TextColor = value

value = instance.TextColor
C#
public Color TextColor {get; set;}
Managed Extensions for C++
public: __property Color get_TextColor();
public: __property void set_TextColor(
   Color value
);
C++/CLI
public:
property Color TextColor {
   Color get();
   void set (Color value);
}

Return Value

A Color object specifying the text color.

Remarks

If this property is Empty, then no text is shown. Default text color is black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
TopQuietZone Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : TopQuietZone Property

Gets or sets the top quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property TopQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Single

instance.TopQuietZone = value

value = instance.TopQuietZone
C#
public float TopQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_TopQuietZone();
public: __property void set_TopQuietZone(
   float value
);
C++/CLI
public:
property float TopQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of top quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the top quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
XDimension Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : XDimension Property

Gets or sets the width of a narrow bar.

Syntax

Visual Basic (Declaration)
Public Property XDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Single

instance.XDimension = value

value = instance.XDimension
C#
public float XDimension {get; set;}
Managed Extensions for C++
public: __property float get_XDimension();
public: __property void set_XDimension(
   float value
);
C++/CLI
public:
property float XDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of a narrow bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.
The recommended width of a narrow bar is 12 mills. Depending on the barcode printer resolution and quality of barcode scanner, the XDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower XDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
YDimension Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : YDimension Property

Gets or sets the height of a bar.

Syntax

Visual Basic (Declaration)
Public Overridable Property YDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Single

instance.YDimension = value

value = instance.YDimension
C#
public virtual float YDimension {get; set;}
Managed Extensions for C++
public: __property virtual float get_YDimension();
public: __property virtual void set_YDimension(
   float value
);
C++/CLI
public:
virtual property float YDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BarcodeEncodingException Class
See Also Members
[image]
O2S.Barcode4NET Namespace : BarcodeEncodingException Class

Defines an exception that is thrown when the barcode data can not be encoded according to barcode's rules.

Syntax

Visual Basic (Declaration)
Public Class BarcodeEncodingException
   Inherits ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As BarcodeEncodingException
C#
public class BarcodeEncodingException : ApplicationException
Managed Extensions for C++
public __gc class BarcodeEncodingException : public ApplicationException
C++/CLI
public ref class BarcodeEncodingException : public ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Barcode4NET.BarcodeEncodingException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeEncodingException Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
BarcodeEncodingException Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : BarcodeEncodingException Class

The following tables list the members exposed by BarcodeEncodingException.

Public Constructors

 | Name | Description
Public Constructor | BarcodeEncodingException Constructor | Initializes a new BarcodeEncodingException object with the specified message.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

BarcodeEncodingException Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BarcodeEncodingException Constructor
See Also
[image]
O2S.Barcode4NET Namespace > BarcodeEncodingException Class : BarcodeEncodingException Constructor

message
The exception message.
Initializes a new BarcodeEncodingException object with the specified message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As BarcodeEncodingException(message)
C#
public BarcodeEncodingException(
   string message
)
Managed Extensions for C++
public: BarcodeEncodingException(
   string* message
)
C++/CLI
public:
BarcodeEncodingException(
   String^ message
)

Parameters

message
The exception message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeEncodingException Class
BarcodeEncodingException Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BasePDF417Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : BasePDF417Barcode Class

Defines the base class for all PDF 417 barcodes.

Syntax

Visual Basic (Declaration)
Public MustInherit Class BasePDF417Barcode
   Inherits BidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As BasePDF417Barcode
C#
public abstract class BasePDF417Barcode : BidimensionalBarcode
Managed Extensions for C++
public __gc abstract class BasePDF417Barcode : public BidimensionalBarcode
C++/CLI
public ref class BasePDF417Barcode abstract : public BidimensionalBarcode

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.BasePDF417Barcode
O2S.Barcode4NET.PDF417Barcode
O2S.Barcode4NET.PDF417Barcode
O2S.Barcode4NET.MicroPDF417Barcode
O2S.Barcode4NET.MicroPDF417Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BasePDF417Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
BasePDF417Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : BasePDF417Barcode Class

The following tables list the members exposed by BasePDF417Barcode.

Public Constructors

 | Name | Description
Public Constructor | BasePDF417Barcode Constructor | Initializes a new PDF417Barcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built.
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Overridden. Gets whether the given character code can be encoded by the barcode.
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

BasePDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BasePDF417Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > BasePDF417Barcode Class : BasePDF417Barcode Constructor

Initializes a new PDF417Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BasePDF417Barcode()
C#
public BasePDF417Barcode()
Managed Extensions for C++
public: BasePDF417Barcode();
C++/CLI
public:
BasePDF417Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BasePDF417Barcode Class
BasePDF417Barcode Members


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
BasePDF417Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : BasePDF417Barcode Class

For a list of all members of this type, see BasePDF417Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Overridden. Gets whether the given character code can be encoded by the barcode.
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

BasePDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsValidCharacterCode Method
See Also
[image]
O2S.Barcode4NET Namespace > BasePDF417Barcode Class : IsValidCharacterCode Method

characterCode
The character code to test.
Gets whether the given character code can be encoded by the barcode.

Syntax

Visual Basic (Declaration)
Overrides Public Function IsValidCharacterCode( _
   ByVal characterCode As Byte _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasePDF417Barcode
Dim characterCode As Byte
Dim value As Boolean

value = instance.IsValidCharacterCode(characterCode)
C#
public override bool IsValidCharacterCode(
   byte characterCode
)
Managed Extensions for C++
public: bool IsValidCharacterCode(
   byte characterCode
) override
C++/CLI
public:
bool IsValidCharacterCode(
   byte characterCode
) override

Parameters

characterCode
The character code to test.

Return Value

True if the character code can be encoded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BasePDF417Barcode Class
BasePDF417Barcode Members


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
BasePDF417Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : BasePDF417Barcode Class

For a list of all members of this type, see BasePDF417Barcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built.
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

BasePDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
CompactionMode Property
See Also
[image]
O2S.Barcode4NET Namespace > BasePDF417Barcode Class : CompactionMode Property

Gets or sets the data compaction mode for this barcode.

Syntax

Visual Basic (Declaration)
Public Property CompactionMode As PDF417DataCompactionMode
Visual Basic (Usage) Copy Code
Dim instance As BasePDF417Barcode
Dim value As PDF417DataCompactionMode

instance.CompactionMode = value

value = instance.CompactionMode
C#
public PDF417DataCompactionMode CompactionMode {get; set;}
Managed Extensions for C++
public: __property PDF417DataCompactionMode get_CompactionMode();
public: __property void set_CompactionMode(
   PDF417DataCompactionMode value
);
C++/CLI
public:
property PDF417DataCompactionMode CompactionMode {
   PDF417DataCompactionMode get();
   void set (PDF417DataCompactionMode value);
}

Return Value

A PDF417DataCompactionMode enumeration member specifying the data compaction mode used in this barcode.

Remarks

The Text compaction mode provides a 2:1 compaction ratio when using only ASCII characters from 0x20 to 0x7F. The Numeric compaction mode provides a 2.93:1 compaction ratio when using only digits (0x30 to 0x39). Byte compaction mode provides a 1.2:1 compaction ratio when using any 8bit character.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BasePDF417Barcode Class
BasePDF417Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsValid Property
See Also
[image]
O2S.Barcode4NET Namespace > BasePDF417Barcode Class : IsValid Property

Gets a value indicating whether a valid barcode can be built.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsValid As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasePDF417Barcode
Dim value As Boolean

value = instance.IsValid
C#
public bool IsValid {get;}
Managed Extensions for C++
public: __property bool get_IsValid();
C++/CLI
public:
property bool IsValid {
   bool get();
}

Return Value

True if the barcode can be built, false otherwise.

Remarks

The following items are considered when building the barcode: barcode data, rows, columns and error correction level.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BasePDF417Barcode Class
BasePDF417Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BidimensionalBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : BidimensionalBarcode Class

Defines the base class for all bidimensional barcodes.

Syntax

Visual Basic (Declaration)
Public MustInherit Class BidimensionalBarcode
   Inherits Barcode
Visual Basic (Usage) Copy Code
Dim instance As BidimensionalBarcode
C#
public abstract class BidimensionalBarcode : Barcode
Managed Extensions for C++
public __gc abstract class BidimensionalBarcode : public Barcode
C++/CLI
public ref class BidimensionalBarcode abstract : public Barcode

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.DataMatrixBarcode
O2S.Barcode4NET.DataMatrixBarcode
O2S.Barcode4NET.Code16KBarcode
O2S.Barcode4NET.Code16KBarcode
O2S.Barcode4NET.CodablockFBarcode
O2S.Barcode4NET.CodablockFBarcode
O2S.Barcode4NET.BasePDF417Barcode
O2S.Barcode4NET.BasePDF417Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BidimensionalBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
BidimensionalBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : BidimensionalBarcode Class

The following tables list the members exposed by BidimensionalBarcode.

Public Constructors

 | Name | Description
Public Constructor | BidimensionalBarcode Constructor | Initializes a new BidimensionalBarcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

BidimensionalBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BidimensionalBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > BidimensionalBarcode Class : BidimensionalBarcode Constructor

Initializes a new BidimensionalBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BidimensionalBarcode()
C#
public BidimensionalBarcode()
Managed Extensions for C++
public: BidimensionalBarcode();
C++/CLI
public:
BidimensionalBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BidimensionalBarcode Class
BidimensionalBarcode Members


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
BidimensionalBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : BidimensionalBarcode Class

For a list of all members of this type, see BidimensionalBarcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

BidimensionalBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
AlternateData Property
See Also Example
[image]
O2S.Barcode4NET Namespace > BidimensionalBarcode Class : AlternateData Property

Gets or sets the alternate data to encode as a barcode.

Syntax

Visual Basic (Declaration)
Public Property AlternateData As Byte()
Visual Basic (Usage) Copy Code
Dim instance As BidimensionalBarcode
Dim value() As Byte

instance.AlternateData = value

value = instance.AlternateData
C#
public byte[] AlternateData {get; set;}
Managed Extensions for C++
public: __property byte[] get_AlternateData();
public: __property void set_AlternateData(
   byte[] value
);
C++/CLI
public:
property array<byte> AlternateData {
   array<byte> get();
   void set (bytearray<value> value);
}

Return Value

A byte array specifying the data to be encoded as a barcode.

Example

The following line of code shows how to encode a Unicode string:
C# Copy Code
...<br/>
barcode.AlternateData = Encoding.Unicode.GetBytes("my unicode string");
...<br/>

Remarks

Barcodes were designed to work with 8bit characters. Because .NET strings are Unicode, when they are converted to 8bit characters (using ISO 8859-1 encoding) the Unicode characters are removed. This property allows you to specify directly the byte array to encode.
If both Data and AlternateData properties are specified, the AlternateData property is used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BidimensionalBarcode Class
BidimensionalBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
CodabarBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : CodabarBarcode Class

Defines a Codabar barcode.

Syntax

Visual Basic (Declaration)
Public Class CodabarBarcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As CodabarBarcode
C#
public class CodabarBarcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc class CodabarBarcode : public UnidimensionalBarcode
C++/CLI
public ref class CodabarBarcode : public UnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Codabar barcode: 0 1 2 3 4 5 6 7 8 9 - $ : / . +

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.CodabarBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodabarBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
CodabarBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : CodabarBarcode Class

The following tables list the members exposed by CodabarBarcode.

Public Constructors

 | Name | Description
Public Constructor | CodabarBarcode Constructor | Overloaded. Initializes a new CodabarBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

CodabarBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
CodabarBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > CodabarBarcode Class : CodabarBarcode Constructor

Initializes a new CodabarBarcode object.

Overload List

Overload | Description
CodabarBarcode Constructor() | Initializes a new CodabarBarcode object.
CodabarBarcode Constructor(String) | Initializes a new CodabarBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodabarBarcode Class
CodabarBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
CodabarBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > CodabarBarcode Class > CodabarBarcode Constructor : CodabarBarcode Constructor()

Initializes a new CodabarBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CodabarBarcode()
C#
public CodabarBarcode()
Managed Extensions for C++
public: CodabarBarcode();
C++/CLI
public:
CodabarBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodabarBarcode Class
CodabarBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
CodabarBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > CodabarBarcode Class > CodabarBarcode Constructor : CodabarBarcode Constructor(String)

data
The data to be encoded.
Initializes a new CodabarBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As CodabarBarcode(data)
C#
public CodabarBarcode(
   string data
)
Managed Extensions for C++
public: CodabarBarcode(
   string* data
)
C++/CLI
public:
CodabarBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodabarBarcode Class
CodabarBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
CodablockFBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : CodablockFBarcode Class

Defines a CODABLOCK F barcode.

Syntax

Visual Basic (Declaration)
Public Class CodablockFBarcode
   Inherits BidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As CodablockFBarcode
C#
public class CodablockFBarcode : BidimensionalBarcode
Managed Extensions for C++
public __gc class CodablockFBarcode : public BidimensionalBarcode
C++/CLI
public ref class CodablockFBarcode : public BidimensionalBarcode

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.CodablockFBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodablockFBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
CodablockFBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : CodablockFBarcode Class

The following tables list the members exposed by CodablockFBarcode.

Public Constructors

 | Name | Description
Public Constructor | CodablockFBarcode Constructor | Initializes a new CodablockFBarcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Overridden. Gets or sets the height of a barcode row.
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

CodablockFBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
CodablockFBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > CodablockFBarcode Class : CodablockFBarcode Constructor

Initializes a new CodablockFBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CodablockFBarcode()
C#
public CodablockFBarcode()
Managed Extensions for C++
public: CodablockFBarcode();
C++/CLI
public:
CodablockFBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodablockFBarcode Class
CodablockFBarcode Members


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
CodablockFBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : CodablockFBarcode Class

For a list of all members of this type, see CodablockFBarcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Overridden. Gets or sets the height of a barcode row.
Top

See Also

Reference

CodablockFBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Columns Property
See Also
[image]
O2S.Barcode4NET Namespace > CodablockFBarcode Class : Columns Property

Gets or sets the number of columns in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As CodablockFBarcode
Dim value As Integer

instance.Columns = value

value = instance.Columns
C#
public int Columns {get; set;}
Managed Extensions for C++
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
C++/CLI
public:
property int Columns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 7 or greater than 65.

Remarks

The minimum number of columns in a CODABLOCK F barcode is 7 and the maximum number of columns is 65. This property includes the character subset selector, row indicator and row check columns.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodablockFBarcode Class
CodablockFBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Rows Property
See Also
[image]
O2S.Barcode4NET Namespace > CodablockFBarcode Class : Rows Property

Gets or sets the number of rows in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As CodablockFBarcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
public int Rows {get; set;}
Managed Extensions for C++
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
C++/CLI
public:
property int Rows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2, or greater than 44.

Remarks

The minimum number of rows in a CODABLOCK F barcode is 2 and the maximum number of rows is 44.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodablockFBarcode Class
CodablockFBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
YDimension Property
See Also
[image]
O2S.Barcode4NET Namespace > CodablockFBarcode Class : YDimension Property

Gets or sets the height of a barcode row.

Syntax

Visual Basic (Declaration)
Overrides Public Property YDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As CodablockFBarcode
Dim value As Single

instance.YDimension = value

value = instance.YDimension
C#
public override float YDimension {get; set;}
Managed Extensions for C++
public: __property float get_YDimension()override ;
public: __property void set_YDimension(
   float value
)override ;
C++/CLI
public:
property float YDimension override {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a barcode row.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The row height is specified using the "mills" measure unit. A mill is 1/1000th of an inch.
The minimum YDimension should be either 8*XDimension or 0.55*Columns+3, whichever is greater. If this property is 0, the row height will be computed automatically.
Depending on the barcode printer resolution and quality of barcode scanner, the YDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower YDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodablockFBarcode Class
CodablockFBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code11Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code11Barcode Class

Defines a Code 11 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code11Barcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As Code11Barcode
C#
public class Code11Barcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc class Code11Barcode : public UnidimensionalBarcode
C++/CLI
public ref class Code11Barcode : public UnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Code 11 barcode: 0 1 2 3 4 5 6 7 8 9 -

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code11Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code11Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
Code11Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code11Barcode Class

The following tables list the members exposed by Code11Barcode.

Public Constructors

 | Name | Description
Public Constructor | Code11Barcode Constructor | Overloaded. Initializes a new Code11Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code11Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code11Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code11Barcode Class : Code11Barcode Constructor

Initializes a new Code11Barcode object.

Overload List

Overload | Description
Code11Barcode Constructor() | Initializes a new Code11Barcode object.
Code11Barcode Constructor(String) | Initializes a new Code11Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code11Barcode Class
Code11Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code11Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code11Barcode Class > Code11Barcode Constructor : Code11Barcode Constructor()

Initializes a new Code11Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code11Barcode()
C#
public Code11Barcode()
Managed Extensions for C++
public: Code11Barcode();
C++/CLI
public:
Code11Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code11Barcode Class
Code11Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code11Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code11Barcode Class > Code11Barcode Constructor : Code11Barcode Constructor(String)

data
The data to be encoded.
Initializes a new Code11Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code11Barcode(data)
C#
public Code11Barcode(
   string data
)
Managed Extensions for C++
public: Code11Barcode(
   string* data
)
C++/CLI
public:
Code11Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code11Barcode Class
Code11Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code128ABarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code128ABarcode Class

Defines a Code 128 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code128ABarcode
   Inherits Code128Barcode
Visual Basic (Usage) Copy Code
Dim instance As Code128ABarcode
C#
public class Code128ABarcode : Code128Barcode
Managed Extensions for C++
public __gc class Code128ABarcode : public Code128Barcode
C++/CLI
public ref class Code128ABarcode : public Code128Barcode

Remarks

This class defines a Code 128 barcode using the A character set. Only the following symbols are allowed in a Code 128 A barcode: NUL (\x00) SOH (\x01) STX (\x02) ETX (\x03) EOT (\x04) ENQ (\x05) ACK (\x06) BEL (\x07) BS (\x08) HT (\x09) LF (\x0A) VT (\x0B) FF (\x0C) CR (\x0D) SO (\x0E) SI (\x0F) DLE (\x10) DC1 (\x11) DC2 (\x12) DC3 (\x13) DC4 (\x14) NAK (\x15) SYN (\x16) ETB (\x17) CAN (\x18) EM (\x19) SUB (\x1A) ESC (\x1B) FS (\x1C) GS (\x1D) RS (\x1E) US (\x1F) SPACE ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _ FNC1 (\xF0) FNC2 (\xF1) FNC3 (\xF2) FNC4 (\xF3) SHIFT (\xF4).

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code128ABarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128ABarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
Code128ABarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code128ABarcode Class

The following tables list the members exposed by Code128ABarcode.

Public Constructors

 | Name | Description
Public Constructor | Code128ABarcode Constructor | Overloaded. Initializes a new Code128ABarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code128ABarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code128ABarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code128ABarcode Class : Code128ABarcode Constructor

Initializes a new Code128ABarcode object.

Overload List

Overload | Description
Code128ABarcode Constructor() | Initializes a new Code128ABarcode object.
Code128ABarcode Constructor(String) | Initializes a new Code128ABarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128ABarcode Class
Code128ABarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code128ABarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code128ABarcode Class > Code128ABarcode Constructor : Code128ABarcode Constructor()

Initializes a new Code128ABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code128ABarcode()
C#
public Code128ABarcode()
Managed Extensions for C++
public: Code128ABarcode();
C++/CLI
public:
Code128ABarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128ABarcode Class
Code128ABarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code128ABarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code128ABarcode Class > Code128ABarcode Constructor : Code128ABarcode Constructor(String)

data
The data to be encoded.
Initializes a new Code128ABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code128ABarcode(data)
C#
public Code128ABarcode(
   string data
)
Managed Extensions for C++
public: Code128ABarcode(
   string* data
)
C++/CLI
public:
Code128ABarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128ABarcode Class
Code128ABarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code128Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code128Barcode Class

Defines the base class for all Code 128 barcodes.

Syntax

Visual Basic (Declaration)
Public MustInherit Class Code128Barcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As Code128Barcode
C#
public abstract class Code128Barcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc abstract class Code128Barcode : public UnidimensionalBarcode
C++/CLI
public ref class Code128Barcode abstract : public UnidimensionalBarcode

Remarks

Code 128 allows to encode 102 symbols, grouped in 3 sets of symbols, A, B and C. Each symbol set is represented by its own barcode class: Code128ABarcode, Code128BBarcode and Code128CBarcode.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code128CBarcode
O2S.Barcode4NET.Code128CBarcode
O2S.Barcode4NET.Code128BBarcode
O2S.Barcode4NET.Code128BBarcode
O2S.Barcode4NET.Code128ABarcode
O2S.Barcode4NET.Code128ABarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
Code128Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code128Barcode Class

The following tables list the members exposed by Code128Barcode.

Public Constructors

 | Name | Description
Public Constructor | Code128Barcode Constructor | Overloaded. Initializes a new Code128Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code128Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code128Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code128Barcode Class : Code128Barcode Constructor

Initializes a new Code128Barcode object.

Overload List

Overload | Description
Code128Barcode Constructor() | Initializes a new Code128Barcode object.
Code128Barcode Constructor(String) | Initializes a new Code128Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128Barcode Class
Code128Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code128Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code128Barcode Class > Code128Barcode Constructor : Code128Barcode Constructor()

Initializes a new Code128Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code128Barcode()
C#
public Code128Barcode()
Managed Extensions for C++
public: Code128Barcode();
C++/CLI
public:
Code128Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128Barcode Class
Code128Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code128Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code128Barcode Class > Code128Barcode Constructor : Code128Barcode Constructor(String)

data
The data to be encoded.
Initializes a new Code128Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code128Barcode(data)
C#
public Code128Barcode(
   string data
)
Managed Extensions for C++
public: Code128Barcode(
   string* data
)
C++/CLI
public:
Code128Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128Barcode Class
Code128Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code128BBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code128BBarcode Class

Defines a Code 128 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code128BBarcode
   Inherits Code128Barcode
Visual Basic (Usage) Copy Code
Dim instance As Code128BBarcode
C#
public class Code128BBarcode : Code128Barcode
Managed Extensions for C++
public __gc class Code128BBarcode : public Code128Barcode
C++/CLI
public ref class Code128BBarcode : public Code128Barcode

Remarks

This class defines a Code 128 barcode using the B character set. Only the following symbols are allowed in a Code 128 B barcode: SPACE ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _ ` a b c d e f g h i j k l m n o p q r s t u v w x y z { | } ~ DEL (\x7F) FNC1 (\xF0) FNC2 (\xF1) FNC3 (\xF2) FNC4 (\xF3) SHIFT (\xF4).

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code128BBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128BBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
Code128BBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code128BBarcode Class

The following tables list the members exposed by Code128BBarcode.

Public Constructors

 | Name | Description
Public Constructor | Code128BBarcode Constructor | Overloaded. Initializes a new Code128BBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code128BBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code128BBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code128BBarcode Class : Code128BBarcode Constructor

Initializes a new Code128BBarcode object.

Overload List

Overload | Description
Code128BBarcode Constructor() | Initializes a new Code128BBarcode object.
Code128BBarcode Constructor(String) | Initializes a new Code128BBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128BBarcode Class
Code128BBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code128BBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code128BBarcode Class > Code128BBarcode Constructor : Code128BBarcode Constructor()

Initializes a new Code128BBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code128BBarcode()
C#
public Code128BBarcode()
Managed Extensions for C++
public: Code128BBarcode();
C++/CLI
public:
Code128BBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128BBarcode Class
Code128BBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code128BBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code128BBarcode Class > Code128BBarcode Constructor : Code128BBarcode Constructor(String)

data
The data to be encoded.
Initializes a new Code128BBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code128BBarcode(data)
C#
public Code128BBarcode(
   string data
)
Managed Extensions for C++
public: Code128BBarcode(
   string* data
)
C++/CLI
public:
Code128BBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128BBarcode Class
Code128BBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code128CBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code128CBarcode Class

Defines a Code 128 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code128CBarcode
   Inherits Code128Barcode
Visual Basic (Usage) Copy Code
Dim instance As Code128CBarcode
C#
public class Code128CBarcode : Code128Barcode
Managed Extensions for C++
public __gc class Code128CBarcode : public Code128Barcode
C++/CLI
public ref class Code128CBarcode : public Code128Barcode

Remarks

This class defines a Code 128 barcode using the C character set. Only the following symbols are allowed in a Code 128 C barcode: 0 1 2 3 4 5 6 7 8 9 FNC1 (\xF0).
Code 128 C encodes only numeric symbols at float density, each pair of digits is encoded using a single symbol.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code128CBarcode
O2S.Barcode4NET.SSCC18Barcode
O2S.Barcode4NET.SSCC18Barcode
O2S.Barcode4NET.SCC14Barcode
O2S.Barcode4NET.SCC14Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128CBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
Code128CBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code128CBarcode Class

The following tables list the members exposed by Code128CBarcode.

Public Constructors

 | Name | Description
Public Constructor | Code128CBarcode Constructor | Overloaded. Initializes a new Code128CBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code128CBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code128CBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code128CBarcode Class : Code128CBarcode Constructor

Initializes a new Code128CBarcode object.

Overload List

Overload | Description
Code128CBarcode Constructor() | Initializes a new Code128CBarcode object.
Code128CBarcode Constructor(String) | Initializes a new Code128CBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128CBarcode Class
Code128CBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code128CBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code128CBarcode Class > Code128CBarcode Constructor : Code128CBarcode Constructor()

Initializes a new Code128CBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code128CBarcode()
C#
public Code128CBarcode()
Managed Extensions for C++
public: Code128CBarcode();
C++/CLI
public:
Code128CBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128CBarcode Class
Code128CBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code128CBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code128CBarcode Class > Code128CBarcode Constructor : Code128CBarcode Constructor(String)

data
The data to be encoded.
Initializes a new Code128CBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code128CBarcode(data)
C#
public Code128CBarcode(
   string data
)
Managed Extensions for C++
public: Code128CBarcode(
   string* data
)
C++/CLI
public:
Code128CBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128CBarcode Class
Code128CBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code16KBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code16KBarcode Class

Defines a Code 16K barcode.

Syntax

Visual Basic (Declaration)
Public Class Code16KBarcode
   Inherits BidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As Code16KBarcode
C#
public class Code16KBarcode : BidimensionalBarcode
Managed Extensions for C++
public __gc class Code16KBarcode : public BidimensionalBarcode
C++/CLI
public ref class Code16KBarcode : public BidimensionalBarcode

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.Code16KBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code16KBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
Code16KBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code16KBarcode Class

The following tables list the members exposed by Code16KBarcode.

Public Constructors

 | Name | Description
Public Constructor | Code16KBarcode Constructor | Initializes a new Code16KBarcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Columns | Gets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Overridden. Gets or sets the height of a barcode row.
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code16KBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code16KBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code16KBarcode Class : Code16KBarcode Constructor

Initializes a new Code16KBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code16KBarcode()
C#
public Code16KBarcode()
Managed Extensions for C++
public: Code16KBarcode();
C++/CLI
public:
Code16KBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code16KBarcode Class
Code16KBarcode Members


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
Code16KBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code16KBarcode Class

For a list of all members of this type, see Code16KBarcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Columns | Gets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Overridden. Gets or sets the height of a barcode row.
Top

See Also

Reference

Code16KBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Columns Property
See Also
[image]
O2S.Barcode4NET Namespace > Code16KBarcode Class : Columns Property

Gets the number of columns in this barcode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As Code16KBarcode
Dim value As Integer

value = instance.Columns
C#
public int Columns {get;}
Managed Extensions for C++
public: __property int get_Columns();
C++/CLI
public:
property int Columns {
   int get();
}

Return Value

An integer value specifying the number of columns used by this barcode.

Remarks

A Code 16K barcode has always 5 columns.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code16KBarcode Class
Code16KBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Rows Property
See Also
[image]
O2S.Barcode4NET Namespace > Code16KBarcode Class : Rows Property

Gets or sets the number of rows in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As Code16KBarcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
public int Rows {get; set;}
Managed Extensions for C++
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
C++/CLI
public:
property int Rows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2 but not 0, or greater than 16.

Remarks

The minimum number of rows in a Code 16K barcode is 2 and the maximum number of rows is 16. If this property is 0, the number of rows is calculated automatically to accomodate the barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code16KBarcode Class
Code16KBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
YDimension Property
See Also
[image]
O2S.Barcode4NET Namespace > Code16KBarcode Class : YDimension Property

Gets or sets the height of a barcode row.

Syntax

Visual Basic (Declaration)
Overrides Public Property YDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As Code16KBarcode
Dim value As Single

instance.YDimension = value

value = instance.YDimension
C#
public override float YDimension {get; set;}
Managed Extensions for C++
public: __property float get_YDimension()override ;
public: __property void set_YDimension(
   float value
)override ;
C++/CLI
public:
property float YDimension override {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a barcode row.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The row height is specified using the "mills" measure unit. A mill is 1/1000th of an inch.
A minimum YDimension of 8*XDimension is recommended for ease of scanning. If this property is 0, the row height will be computed automatically.
Depending on the barcode printer resolution and quality of barcode scanner, the YDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower YDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code16KBarcode Class
Code16KBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code25Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code25Barcode Class

Defines a Code 2 of 5 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code25Barcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As Code25Barcode
C#
public class Code25Barcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc class Code25Barcode : public UnidimensionalBarcode
C++/CLI
public ref class Code25Barcode : public UnidimensionalBarcode

Remarks

Code 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Code 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code25Barcode
O2S.Barcode4NET.Matrix25Barcode
O2S.Barcode4NET.Matrix25Barcode
O2S.Barcode4NET.IATA25Barcode
O2S.Barcode4NET.IATA25Barcode
O2S.Barcode4NET.COOP25Barcode
O2S.Barcode4NET.COOP25Barcode
O2S.Barcode4NET.Code25InterleavedBarcode
O2S.Barcode4NET.Code25InterleavedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
Code25Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code25Barcode Class

The following tables list the members exposed by Code25Barcode.

Public Constructors

 | Name | Description
Public Constructor | Code25Barcode Constructor | Overloaded. Initializes a new Code25Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code25Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code25Barcode Class : Code25Barcode Constructor

Initializes a new Code25Barcode object.

Overload List

Overload | Description
Code25Barcode Constructor() | Initializes a new Code25Barcode object.
Code25Barcode Constructor(String) | Initializes a new Code25Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25Barcode Class
Code25Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code25Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code25Barcode Class > Code25Barcode Constructor : Code25Barcode Constructor()

Initializes a new Code25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code25Barcode()
C#
public Code25Barcode()
Managed Extensions for C++
public: Code25Barcode();
C++/CLI
public:
Code25Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25Barcode Class
Code25Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code25Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code25Barcode Class > Code25Barcode Constructor : Code25Barcode Constructor(String)

data
The data to be encoded.
Initializes a new Code25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code25Barcode(data)
C#
public Code25Barcode(
   string data
)
Managed Extensions for C++
public: Code25Barcode(
   string* data
)
C++/CLI
public:
Code25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25Barcode Class
Code25Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code25InterleavedBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code25InterleavedBarcode Class

Defines an Interleaved 2 of 5 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code25InterleavedBarcode
   Inherits Code25Barcode
Visual Basic (Usage) Copy Code
Dim instance As Code25InterleavedBarcode
C#
public class Code25InterleavedBarcode : Code25Barcode
Managed Extensions for C++
public __gc class Code25InterleavedBarcode : public Code25Barcode
C++/CLI
public ref class Code25InterleavedBarcode : public Code25Barcode

Remarks

Interleaved 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Interleaved 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code25Barcode
O2S.Barcode4NET.Code25InterleavedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25InterleavedBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
Code25InterleavedBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code25InterleavedBarcode Class

The following tables list the members exposed by Code25InterleavedBarcode.

Public Constructors

 | Name | Description
Public Constructor | Code25InterleavedBarcode Constructor | Overloaded. Initializes a new Code25InterleavedBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code25InterleavedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code25InterleavedBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code25InterleavedBarcode Class : Code25InterleavedBarcode Constructor

Initializes a new Code25InterleavedBarcode object.

Overload List

Overload | Description
Code25InterleavedBarcode Constructor() | Initializes a new Code25InterleavedBarcode object.
Code25InterleavedBarcode Constructor(String) | Initializes a new Code25InterleavedBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25InterleavedBarcode Class
Code25InterleavedBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code25InterleavedBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code25InterleavedBarcode Class > Code25InterleavedBarcode Constructor : Code25InterleavedBarcode Constructor()

Initializes a new Code25InterleavedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code25InterleavedBarcode()
C#
public Code25InterleavedBarcode()
Managed Extensions for C++
public: Code25InterleavedBarcode();
C++/CLI
public:
Code25InterleavedBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25InterleavedBarcode Class
Code25InterleavedBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code25InterleavedBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code25InterleavedBarcode Class > Code25InterleavedBarcode Constructor : Code25InterleavedBarcode Constructor(String)

data
The data to be encoded.
Initializes a new Code25InterleavedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code25InterleavedBarcode(data)
C#
public Code25InterleavedBarcode(
   string data
)
Managed Extensions for C++
public: Code25InterleavedBarcode(
   string* data
)
C++/CLI
public:
Code25InterleavedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25InterleavedBarcode Class
Code25InterleavedBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code39Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code39Barcode Class

Defines a Code 39 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code39Barcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As Code39Barcode
C#
public class Code39Barcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc class Code39Barcode : public UnidimensionalBarcode
C++/CLI
public ref class Code39Barcode : public UnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Code 39 barcode: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
All alphabetic characters are uppercase. If lowercase characters are required, then a Code 39 Extended barcode must be used.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code39Barcode
O2S.Barcode4NET.Code39ExtendedBarcode
O2S.Barcode4NET.Code39ExtendedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
Code39Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code39Barcode Class

The following tables list the members exposed by Code39Barcode.

Public Constructors

 | Name | Description
Public Constructor | Code39Barcode Constructor | Overloaded. Initializes a new Code39Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code39Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code39Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code39Barcode Class : Code39Barcode Constructor

Initializes a new Code39Barcode object.

Overload List

Overload | Description
Code39Barcode Constructor() | Initializes a new Code39Barcode object.
Code39Barcode Constructor(String) | Initializes a new Code39Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39Barcode Class
Code39Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code39Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code39Barcode Class > Code39Barcode Constructor : Code39Barcode Constructor()

Initializes a new Code39Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code39Barcode()
C#
public Code39Barcode()
Managed Extensions for C++
public: Code39Barcode();
C++/CLI
public:
Code39Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39Barcode Class
Code39Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code39Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code39Barcode Class > Code39Barcode Constructor : Code39Barcode Constructor(String)

data
The data to be encoded.
Initializes a new Code39Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code39Barcode(data)
C#
public Code39Barcode(
   string data
)
Managed Extensions for C++
public: Code39Barcode(
   string* data
)
C++/CLI
public:
Code39Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39Barcode Class
Code39Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
Code39Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code39Barcode Class

For a list of all members of this type, see Code39Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code39Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
WideToNarrowRatio Property
See Also
[image]
O2S.Barcode4NET Namespace > Code39Barcode Class : WideToNarrowRatio Property

Gets or sets the ratio between wide bars and narrow bars.

Syntax

Visual Basic (Declaration)
Public Property WideToNarrowRatio As Single
Visual Basic (Usage) Copy Code
Dim instance As Code39Barcode
Dim value As Single

instance.WideToNarrowRatio = value

value = instance.WideToNarrowRatio
C#
public float WideToNarrowRatio {get; set;}
Managed Extensions for C++
public: __property float get_WideToNarrowRatio();
public: __property void set_WideToNarrowRatio(
   float value
);
C++/CLI
public:
property float WideToNarrowRatio {
   float get();
   void set (float value);
}

Return Value

A float value specifying the ratio between wide bars and narrow bars.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39Barcode Class
Code39Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code39ExtendedBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code39ExtendedBarcode Class

Defines an extended Code 39 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code39ExtendedBarcode
   Inherits Code39Barcode
Visual Basic (Usage) Copy Code
Dim instance As Code39ExtendedBarcode
C#
public class Code39ExtendedBarcode : Code39Barcode
Managed Extensions for C++
public __gc class Code39ExtendedBarcode : public Code39Barcode
C++/CLI
public ref class Code39ExtendedBarcode : public Code39Barcode

Remarks

All 128 ASCII characters can be encoded in an extended Code 39 barcode.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code39Barcode
O2S.Barcode4NET.Code39ExtendedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39ExtendedBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
Code39ExtendedBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code39ExtendedBarcode Class

The following tables list the members exposed by Code39ExtendedBarcode.

Public Constructors

 | Name | Description
Public Constructor | Code39ExtendedBarcode Constructor | Overloaded. Initializes a new Code39ExtendedBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from Code39Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code39ExtendedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code39ExtendedBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code39ExtendedBarcode Class : Code39ExtendedBarcode Constructor

Initializes a new Code39ExtendedBarcode object.

Overload List

Overload | Description
Code39ExtendedBarcode Constructor() | Initializes a new Code39ExtendedBarcode object.
Code39ExtendedBarcode Constructor(String) | Initializes a new Code39ExtendedBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39ExtendedBarcode Class
Code39ExtendedBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code39ExtendedBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code39ExtendedBarcode Class > Code39ExtendedBarcode Constructor : Code39ExtendedBarcode Constructor()

Initializes a new Code39ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code39ExtendedBarcode()
C#
public Code39ExtendedBarcode()
Managed Extensions for C++
public: Code39ExtendedBarcode();
C++/CLI
public:
Code39ExtendedBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39ExtendedBarcode Class
Code39ExtendedBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code39ExtendedBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code39ExtendedBarcode Class > Code39ExtendedBarcode Constructor : Code39ExtendedBarcode Constructor(String)

data
The data to be encoded.
Initializes a new Code39ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code39ExtendedBarcode(data)
C#
public Code39ExtendedBarcode(
   string data
)
Managed Extensions for C++
public: Code39ExtendedBarcode(
   string* data
)
C++/CLI
public:
Code39ExtendedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39ExtendedBarcode Class
Code39ExtendedBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code93Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code93Barcode Class

Defines a Code 93 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code93Barcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As Code93Barcode
C#
public class Code93Barcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc class Code93Barcode : public UnidimensionalBarcode
C++/CLI
public ref class Code93Barcode : public UnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Code 93 barcode: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
All alphabetic characters are uppercase. If lowercase characters are required, then a Code 93 Extended barcode must be used.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code93Barcode
O2S.Barcode4NET.Code93ExtendedBarcode
O2S.Barcode4NET.Code93ExtendedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
Code93Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code93Barcode Class

The following tables list the members exposed by Code93Barcode.

Public Constructors

 | Name | Description
Public Constructor | Code93Barcode Constructor | Overloaded. Initializes a new Code93Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code93Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code93Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code93Barcode Class : Code93Barcode Constructor

Initializes a new Code93Barcode object.

Overload List

Overload | Description
Code93Barcode Constructor() | Initializes a new Code93Barcode object.
Code93Barcode Constructor(String) | Initializes a new Code93Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93Barcode Class
Code93Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code93Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code93Barcode Class > Code93Barcode Constructor : Code93Barcode Constructor()

Initializes a new Code93Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code93Barcode()
C#
public Code93Barcode()
Managed Extensions for C++
public: Code93Barcode();
C++/CLI
public:
Code93Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93Barcode Class
Code93Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code93Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code93Barcode Class > Code93Barcode Constructor : Code93Barcode Constructor(String)

data
The data to be encoded.
Initializes a new Code93Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code93Barcode(data)
C#
public Code93Barcode(
   string data
)
Managed Extensions for C++
public: Code93Barcode(
   string* data
)
C++/CLI
public:
Code93Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93Barcode Class
Code93Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code93ExtendedBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code93ExtendedBarcode Class

Defines an extended Code 93 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code93ExtendedBarcode
   Inherits Code93Barcode
Visual Basic (Usage) Copy Code
Dim instance As Code93ExtendedBarcode
C#
public class Code93ExtendedBarcode : Code93Barcode
Managed Extensions for C++
public __gc class Code93ExtendedBarcode : public Code93Barcode
C++/CLI
public ref class Code93ExtendedBarcode : public Code93Barcode

Remarks

All 128 ASCII characters can be encoded in an extended Code 93 barcode.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code93Barcode
O2S.Barcode4NET.Code93ExtendedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93ExtendedBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
Code93ExtendedBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code93ExtendedBarcode Class

The following tables list the members exposed by Code93ExtendedBarcode.

Public Constructors

 | Name | Description
Public Constructor | Code93ExtendedBarcode Constructor | Overloaded. Initializes a new Code93ExtendedBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code93ExtendedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code93ExtendedBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code93ExtendedBarcode Class : Code93ExtendedBarcode Constructor

Initializes a new Code93ExtendedBarcode object.

Overload List

Overload | Description
Code93ExtendedBarcode Constructor() | Initializes a new Code93ExtendedBarcode object.
Code93ExtendedBarcode Constructor(String) | Initializes a new Code93ExtendedBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93ExtendedBarcode Class
Code93ExtendedBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code93ExtendedBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code93ExtendedBarcode Class > Code93ExtendedBarcode Constructor : Code93ExtendedBarcode Constructor()

Initializes a new Code93ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code93ExtendedBarcode()
C#
public Code93ExtendedBarcode()
Managed Extensions for C++
public: Code93ExtendedBarcode();
C++/CLI
public:
Code93ExtendedBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93ExtendedBarcode Class
Code93ExtendedBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Code93ExtendedBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code93ExtendedBarcode Class > Code93ExtendedBarcode Constructor : Code93ExtendedBarcode Constructor(String)

data
The data to be encoded.
Initializes a new Code93ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code93ExtendedBarcode(data)
C#
public Code93ExtendedBarcode(
   string data
)
Managed Extensions for C++
public: Code93ExtendedBarcode(
   string* data
)
C++/CLI
public:
Code93ExtendedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93ExtendedBarcode Class
Code93ExtendedBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
COOP25Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : COOP25Barcode Class

Defines a COOP 2 of 5 barcode.

Syntax

Visual Basic (Declaration)
Public Class COOP25Barcode
   Inherits Code25Barcode
Visual Basic (Usage) Copy Code
Dim instance As COOP25Barcode
C#
public class COOP25Barcode : Code25Barcode
Managed Extensions for C++
public __gc class COOP25Barcode : public Code25Barcode
C++/CLI
public ref class COOP25Barcode : public Code25Barcode

Remarks

COOP 2 of 5 is a numeric symbology. Only the following symbols are allowed in a COOP 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code25Barcode
O2S.Barcode4NET.COOP25Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

COOP25Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
COOP25Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : COOP25Barcode Class

The following tables list the members exposed by COOP25Barcode.

Public Constructors

 | Name | Description
Public Constructor | COOP25Barcode Constructor | Overloaded. Initializes a new COOP25Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

COOP25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
COOP25Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > COOP25Barcode Class : COOP25Barcode Constructor

Initializes a new COOP25Barcode object.

Overload List

Overload | Description
COOP25Barcode Constructor() | Initializes a new COOP25Barcode object.
COOP25Barcode Constructor(String) | Initializes a new COOP25Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

COOP25Barcode Class
COOP25Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
COOP25Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > COOP25Barcode Class > COOP25Barcode Constructor : COOP25Barcode Constructor()

Initializes a new COOP25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As COOP25Barcode()
C#
public COOP25Barcode()
Managed Extensions for C++
public: COOP25Barcode();
C++/CLI
public:
COOP25Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

COOP25Barcode Class
COOP25Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
COOP25Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > COOP25Barcode Class > COOP25Barcode Constructor : COOP25Barcode Constructor(String)

data
The data to be encoded.
Initializes a new COOP25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As COOP25Barcode(data)
C#
public COOP25Barcode(
   string data
)
Managed Extensions for C++
public: COOP25Barcode(
   string* data
)
C++/CLI
public:
COOP25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

COOP25Barcode Class
COOP25Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
DataMatrixBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : DataMatrixBarcode Class

Defines a DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Class DataMatrixBarcode
   Inherits BidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixBarcode
C#
public class DataMatrixBarcode : BidimensionalBarcode
Managed Extensions for C++
public __gc class DataMatrixBarcode : public BidimensionalBarcode
C++/CLI
public ref class DataMatrixBarcode : public BidimensionalBarcode

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.DataMatrixBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataMatrixBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
DataMatrixBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : DataMatrixBarcode Class

The following tables list the members exposed by DataMatrixBarcode.

Public Constructors

 | Name | Description
Public Constructor | DataMatrixBarcode Constructor | Initializes a new DataMatrixBarcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Encoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | SymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Overridden. Gets whether the given character code can be encoded by the barcode.
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

DataMatrixBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
DataMatrixBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > DataMatrixBarcode Class : DataMatrixBarcode Constructor

Initializes a new DataMatrixBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixBarcode()
C#
public DataMatrixBarcode()
Managed Extensions for C++
public: DataMatrixBarcode();
C++/CLI
public:
DataMatrixBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataMatrixBarcode Class
DataMatrixBarcode Members


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
DataMatrixBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : DataMatrixBarcode Class

For a list of all members of this type, see DataMatrixBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Overridden. Gets whether the given character code can be encoded by the barcode.
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

DataMatrixBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsValidCharacterCode Method
See Also
[image]
O2S.Barcode4NET Namespace > DataMatrixBarcode Class : IsValidCharacterCode Method

characterCode
The character code to test.
Gets whether the given character code can be encoded by the barcode.

Syntax

Visual Basic (Declaration)
Overrides Public Function IsValidCharacterCode( _
   ByVal characterCode As Byte _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixBarcode
Dim characterCode As Byte
Dim value As Boolean

value = instance.IsValidCharacterCode(characterCode)
C#
public override bool IsValidCharacterCode(
   byte characterCode
)
Managed Extensions for C++
public: bool IsValidCharacterCode(
   byte characterCode
) override
C++/CLI
public:
bool IsValidCharacterCode(
   byte characterCode
) override

Parameters

characterCode
The character code to test.

Return Value

True if the character code can be encoded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataMatrixBarcode Class
DataMatrixBarcode Members


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
DataMatrixBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : DataMatrixBarcode Class

For a list of all members of this type, see DataMatrixBarcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Encoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | SymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

DataMatrixBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Encoding Property
See Also
[image]
O2S.Barcode4NET Namespace > DataMatrixBarcode Class : Encoding Property

Gets or sets the encoding of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property Encoding As DataMatrixEncoding
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixBarcode
Dim value As DataMatrixEncoding

instance.Encoding = value

value = instance.Encoding
C#
public DataMatrixEncoding Encoding {get; set;}
Managed Extensions for C++
public: __property DataMatrixEncoding get_Encoding();
public: __property void set_Encoding(
   DataMatrixEncoding value
);
C++/CLI
public:
property DataMatrixEncoding Encoding {
   DataMatrixEncoding get();
   void set (DataMatrixEncoding value);
}

Return Value

A DataMatrixEncoding enumeration member specifying the data encoding for this DataMatrix barcode.

Remarks

If the data to encode contains only numbers (ASCII characters from 0x30 to 0x39), then Numeric provides the best encoding. If the data to encode contains only base ASCII characters (0x00 to 0x7F), then both ASCII and Base256 encoding provide the same performance, but if the data to encode contains more than 3 extended ASCII characters (0x80 to 0xFF) then the Base256 encoding is the best option.
If the selected encoding is Auto, then the library will select the encoding that will generate the smallest encoded data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataMatrixBarcode Class
DataMatrixBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SymbolSize Property
See Also
[image]
O2S.Barcode4NET Namespace > DataMatrixBarcode Class : SymbolSize Property

Gets or sets the symbol size of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property SymbolSize As DataMatrixSymbolSize
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixBarcode
Dim value As DataMatrixSymbolSize

instance.SymbolSize = value

value = instance.SymbolSize
C#
public DataMatrixSymbolSize SymbolSize {get; set;}
Managed Extensions for C++
public: __property DataMatrixSymbolSize get_SymbolSize();
public: __property void set_SymbolSize(
   DataMatrixSymbolSize value
);
C++/CLI
public:
property DataMatrixSymbolSize SymbolSize {
   DataMatrixSymbolSize get();
   void set (DataMatrixSymbolSize value);
}

Return Value

A DataMatrixSymbolSize enumeration member specifying the size of symbol used to represent this DataMatrix barcode.

Remarks

If the SymbolSize is Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataMatrixBarcode Class
DataMatrixBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
EAN13Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : EAN13Barcode Class

Defines the class for EAN-13 barcodes.

Syntax

Visual Basic (Declaration)
Public Class EAN13Barcode
   Inherits EANBarcode
Visual Basic (Usage) Copy Code
Dim instance As EAN13Barcode
C#
public class EAN13Barcode : EANBarcode
Managed Extensions for C++
public __gc class EAN13Barcode : public EANBarcode
C++/CLI
public ref class EAN13Barcode : public EANBarcode

Remarks

EAN-13 symbology is a numeric symbology. Only the following symbols are allowed in an EAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-13 barcode must always have 12 characters length. The 13th character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.EAN13Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN13Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
EAN13Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : EAN13Barcode Class

The following tables list the members exposed by EAN13Barcode.

Public Constructors

 | Name | Description
Public Constructor | EAN13Barcode Constructor | Overloaded. Initializes a new EAN13Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

EAN13Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
EAN13Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > EAN13Barcode Class : EAN13Barcode Constructor

Initializes a new EAN13Barcode object.

Overload List

Overload | Description
EAN13Barcode Constructor() | Initializes a new EAN13Barcode object.
EAN13Barcode Constructor(String) | Initializes a new EAN13Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN13Barcode Class
EAN13Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
EAN13Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > EAN13Barcode Class > EAN13Barcode Constructor : EAN13Barcode Constructor()

Initializes a new EAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EAN13Barcode()
C#
public EAN13Barcode()
Managed Extensions for C++
public: EAN13Barcode();
C++/CLI
public:
EAN13Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN13Barcode Class
EAN13Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
EAN13Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > EAN13Barcode Class > EAN13Barcode Constructor : EAN13Barcode Constructor(String)

data
The data to be encoded.
Initializes a new EAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As EAN13Barcode(data)
C#
public EAN13Barcode(
   string data
)
Managed Extensions for C++
public: EAN13Barcode(
   string* data
)
C++/CLI
public:
EAN13Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN13Barcode Class
EAN13Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
EAN8Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : EAN8Barcode Class

Defines the class for EAN-8 barcodes.

Syntax

Visual Basic (Declaration)
Public Class EAN8Barcode
   Inherits EANBarcode
Visual Basic (Usage) Copy Code
Dim instance As EAN8Barcode
C#
public class EAN8Barcode : EANBarcode
Managed Extensions for C++
public __gc class EAN8Barcode : public EANBarcode
C++/CLI
public ref class EAN8Barcode : public EANBarcode

Remarks

EAN-8 symbology is a numeric symbology. Only the following symbols are allowed in an EAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-8 barcode must always have 7 characters length. The 8th character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.EAN8Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN8Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
EAN8Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : EAN8Barcode Class

The following tables list the members exposed by EAN8Barcode.

Public Constructors

 | Name | Description
Public Constructor | EAN8Barcode Constructor | Overloaded. Initializes a new EAN8Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

EAN8Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
EAN8Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > EAN8Barcode Class : EAN8Barcode Constructor

Initializes a new EAN8Barcode object.

Overload List

Overload | Description
EAN8Barcode Constructor() | Initializes a new EAN8Barcode object.
EAN8Barcode Constructor(String) | Initializes a new EAN8Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN8Barcode Class
EAN8Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
EAN8Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > EAN8Barcode Class > EAN8Barcode Constructor : EAN8Barcode Constructor()

Initializes a new EAN8Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EAN8Barcode()
C#
public EAN8Barcode()
Managed Extensions for C++
public: EAN8Barcode();
C++/CLI
public:
EAN8Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN8Barcode Class
EAN8Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
EAN8Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > EAN8Barcode Class > EAN8Barcode Constructor : EAN8Barcode Constructor(String)

data
The data to be encoded.
Initializes a new EAN8Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As EAN8Barcode(data)
C#
public EAN8Barcode(
   string data
)
Managed Extensions for C++
public: EAN8Barcode(
   string* data
)
C++/CLI
public:
EAN8Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN8Barcode Class
EAN8Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
EANBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : EANBarcode Class

Defines the base class for EAN based barcodes.

Syntax

Visual Basic (Declaration)
Public MustInherit Class EANBarcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As EANBarcode
C#
public abstract class EANBarcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc abstract class EANBarcode : public UnidimensionalBarcode
C++/CLI
public ref class EANBarcode abstract : public UnidimensionalBarcode

Remarks

An EAN based symbology is a numeric symbology. Only the following symbols are allowed in an EAN based barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-13 barcode must always has 12 characters length. The 13th character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.UPCEBarcode
O2S.Barcode4NET.UPCEBarcode
O2S.Barcode4NET.UPCABarcode
O2S.Barcode4NET.UPCABarcode
O2S.Barcode4NET.JAN13Barcode
O2S.Barcode4NET.JAN13Barcode
O2S.Barcode4NET.ISSNBarcode
O2S.Barcode4NET.ISSNBarcode
O2S.Barcode4NET.ISMNBarcode
O2S.Barcode4NET.ISMNBarcode
O2S.Barcode4NET.ISBNBarcode
O2S.Barcode4NET.ISBNBarcode
O2S.Barcode4NET.EAN8Barcode
O2S.Barcode4NET.EAN8Barcode
O2S.Barcode4NET.EAN13Barcode
O2S.Barcode4NET.EAN13Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EANBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
EANBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : EANBarcode Class

The following tables list the members exposed by EANBarcode.

Public Constructors

 | Name | Description
Public Constructor | EANBarcode Constructor | Overloaded. Initializes a new EANBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data.
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text.
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

EANBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
EANBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > EANBarcode Class : EANBarcode Constructor

Initializes a new EANBarcode object.

Overload List

Overload | Description
EANBarcode Constructor() | Initializes a new EANBarcode object.
EANBarcode Constructor(String) | Initializes a new EANBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EANBarcode Class
EANBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
EANBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > EANBarcode Class > EANBarcode Constructor : EANBarcode Constructor()

Initializes a new EANBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EANBarcode()
C#
public EANBarcode()
Managed Extensions for C++
public: EANBarcode();
C++/CLI
public:
EANBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EANBarcode Class
EANBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
EANBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > EANBarcode Class > EANBarcode Constructor : EANBarcode Constructor(String)

data
The data to be encoded.
Initializes a new EANBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As EANBarcode(data)
C#
public EANBarcode(
   string data
)
Managed Extensions for C++
public: EANBarcode(
   string* data
)
C++/CLI
public:
EANBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EANBarcode Class
EANBarcode Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
EANBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : EANBarcode Class

For a list of all members of this type, see EANBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data.
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text.
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

EANBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Supplement Property
See Also
[image]
O2S.Barcode4NET Namespace > EANBarcode Class : Supplement Property

Gets or sets the supplement for barcode data.

Syntax

Visual Basic (Declaration)
Public Property Supplement As String
Visual Basic (Usage) Copy Code
Dim instance As EANBarcode
Dim value As String

instance.Supplement = value

value = instance.Supplement
C#
public string Supplement {get; set;}
Managed Extensions for C++
public: __property string* get_Supplement();
public: __property void set_Supplement(
   string* value
);
C++/CLI
public:
property String^ Supplement {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying a 2 or 5 digit supplemental barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in supplement data or the supplement does not have the required length (2 or 5 digits).

Remarks

This supplement is optional. If it exists, it can be only 2 or 5 digits.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EANBarcode Class
EANBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SupplementDisplayLocation Property
See Also
[image]
O2S.Barcode4NET Namespace > EANBarcode Class : SupplementDisplayLocation Property

Gets or sets the location of the supplement text.

Syntax

Visual Basic (Declaration)
Public Property SupplementDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As EANBarcode
Dim value As BarcodeTextLocation

instance.SupplementDisplayLocation = value

value = instance.SupplementDisplayLocation
C#
public BarcodeTextLocation SupplementDisplayLocation {get; set;}
Managed Extensions for C++
public: __property BarcodeTextLocation get_SupplementDisplayLocation();
public: __property void set_SupplementDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation SupplementDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location where the supplement text is displayed.

Remarks

The embedding options are ignored for supplement text. AboveEmbedded has the same effect like Above, and BelowEmbedded has the same effect like Below.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EANBarcode Class
EANBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SupplementYDimension Property
See Also
[image]
O2S.Barcode4NET Namespace > EANBarcode Class : SupplementYDimension Property

Gets or sets the height of a bar in the supplement barcode.

Syntax

Visual Basic (Declaration)
Public Property SupplementYDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As EANBarcode
Dim value As Single

instance.SupplementYDimension = value

value = instance.SupplementYDimension
C#
public float SupplementYDimension {get; set;}
Managed Extensions for C++
public: __property float get_SupplementYDimension();
public: __property void set_SupplementYDimension(
   float value
);
C++/CLI
public:
property float SupplementYDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a bar in the supplement barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by XYDimensionUnit property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EANBarcode Class
EANBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
HeightModulatedBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : HeightModulatedBarcode Class

Defines the base class for all height modulated barcodes.

Syntax

Visual Basic (Declaration)
Public MustInherit Class HeightModulatedBarcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As HeightModulatedBarcode
C#
public abstract class HeightModulatedBarcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc abstract class HeightModulatedBarcode : public UnidimensionalBarcode
C++/CLI
public ref class HeightModulatedBarcode abstract : public UnidimensionalBarcode

Remarks

Height modulated barcodes encode the information in the height of the bars, not and in the width of the bars and spaces.
Usually height modulated barcodes are used for encoding postal information, such as ZIP/Postal codes or delivery points.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.HeightModulatedBarcode
O2S.Barcode4NET.RM4SCCBarcode
O2S.Barcode4NET.RM4SCCBarcode
O2S.Barcode4NET.PostnetBarcode
O2S.Barcode4NET.PostnetBarcode
O2S.Barcode4NET.PlanetBarcode
O2S.Barcode4NET.PlanetBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

HeightModulatedBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
HeightModulatedBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : HeightModulatedBarcode Class

The following tables list the members exposed by HeightModulatedBarcode.

Public Constructors

 | Name | Description
Public Constructor | HeightModulatedBarcode Constructor | Overloaded. Initializes a new HeightModulatedBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

HeightModulatedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
HeightModulatedBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > HeightModulatedBarcode Class : HeightModulatedBarcode Constructor

Initializes a new HeightModulatedBarcode object.

Overload List

Overload | Description
HeightModulatedBarcode Constructor() | Initializes a new HeightModulatedBarcode object.
HeightModulatedBarcode Constructor(String) | Initializes a new HeightModulatedBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

HeightModulatedBarcode Class
HeightModulatedBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
HeightModulatedBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > HeightModulatedBarcode Class > HeightModulatedBarcode Constructor : HeightModulatedBarcode Constructor()

Initializes a new HeightModulatedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As HeightModulatedBarcode()
C#
public HeightModulatedBarcode()
Managed Extensions for C++
public: HeightModulatedBarcode();
C++/CLI
public:
HeightModulatedBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

HeightModulatedBarcode Class
HeightModulatedBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
HeightModulatedBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > HeightModulatedBarcode Class > HeightModulatedBarcode Constructor : HeightModulatedBarcode Constructor(String)

data
The data to be encoded.
Initializes a new HeightModulatedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As HeightModulatedBarcode(data)
C#
public HeightModulatedBarcode(
   string data
)
Managed Extensions for C++
public: HeightModulatedBarcode(
   string* data
)
C++/CLI
public:
HeightModulatedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

HeightModulatedBarcode Class
HeightModulatedBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IATA25Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : IATA25Barcode Class

Defines a IATA 2 of 5 barcode.

Syntax

Visual Basic (Declaration)
Public Class IATA25Barcode
   Inherits Code25Barcode
Visual Basic (Usage) Copy Code
Dim instance As IATA25Barcode
C#
public class IATA25Barcode : Code25Barcode
Managed Extensions for C++
public __gc class IATA25Barcode : public Code25Barcode
C++/CLI
public ref class IATA25Barcode : public Code25Barcode

Remarks

IATA 2 of 5 is a numeric symbology. Only the following symbols are allowed in a IATA 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9. The required data length is 16 digits (the 17th digit is the check digit and it is computed automatically).
IATA (International Air Transport Assosiation) uses this for the management of air cargo.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code25Barcode
O2S.Barcode4NET.IATA25Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IATA25Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
IATA25Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : IATA25Barcode Class

The following tables list the members exposed by IATA25Barcode.

Public Constructors

 | Name | Description
Public Constructor | IATA25Barcode Constructor | Overloaded. Initializes a new IATA25Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

IATA25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IATA25Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > IATA25Barcode Class : IATA25Barcode Constructor

Initializes a new IATA25Barcode object.

Overload List

Overload | Description
IATA25Barcode Constructor() | Initializes a new IATA25Barcode object.
IATA25Barcode Constructor(String) | Initializes a new IATA25Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IATA25Barcode Class
IATA25Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IATA25Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > IATA25Barcode Class > IATA25Barcode Constructor : IATA25Barcode Constructor()

Initializes a new IATA25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As IATA25Barcode()
C#
public IATA25Barcode()
Managed Extensions for C++
public: IATA25Barcode();
C++/CLI
public:
IATA25Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IATA25Barcode Class
IATA25Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IATA25Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > IATA25Barcode Class > IATA25Barcode Constructor : IATA25Barcode Constructor(String)

data
The data to be encoded.
Initializes a new IATA25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As IATA25Barcode(data)
C#
public IATA25Barcode(
   string data
)
Managed Extensions for C++
public: IATA25Barcode(
   string* data
)
C++/CLI
public:
IATA25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IATA25Barcode Class
IATA25Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ISBNBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : ISBNBarcode Class

Defines the class for ISBN barcodes.

Syntax

Visual Basic (Declaration)
Public Class ISBNBarcode
   Inherits EANBarcode
Visual Basic (Usage) Copy Code
Dim instance As ISBNBarcode
C#
public class ISBNBarcode : EANBarcode
Managed Extensions for C++
public __gc class ISBNBarcode : public EANBarcode
C++/CLI
public ref class ISBNBarcode : public EANBarcode

Remarks

ISBN symbology is a numeric symbology. Only the following symbols are allowed in an ISBN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISBN barcode (International Standard Book Numbering) is in fact an EAN-13 barcode having the 978 number system. The data for an ISBN barcode must always have 9 characters length. The number system is always 978 and the last character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.ISBNBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISBNBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
ISBNBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : ISBNBarcode Class

The following tables list the members exposed by ISBNBarcode.

Public Constructors

 | Name | Description
Public Constructor | ISBNBarcode Constructor | Overloaded. Initializes a new ISBNBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

ISBNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ISBNBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > ISBNBarcode Class : ISBNBarcode Constructor

Initializes a new ISBNBarcode object.

Overload List

Overload | Description
ISBNBarcode Constructor() | Initializes a new ISBNBarcode object.
ISBNBarcode Constructor(String) | Initializes a new ISBNBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISBNBarcode Class
ISBNBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ISBNBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > ISBNBarcode Class > ISBNBarcode Constructor : ISBNBarcode Constructor()

Initializes a new ISBNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ISBNBarcode()
C#
public ISBNBarcode()
Managed Extensions for C++
public: ISBNBarcode();
C++/CLI
public:
ISBNBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISBNBarcode Class
ISBNBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ISBNBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > ISBNBarcode Class > ISBNBarcode Constructor : ISBNBarcode Constructor(String)

data
The data to be encoded.
Initializes a new ISBNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As ISBNBarcode(data)
C#
public ISBNBarcode(
   string data
)
Managed Extensions for C++
public: ISBNBarcode(
   string* data
)
C++/CLI
public:
ISBNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISBNBarcode Class
ISBNBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ISMNBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : ISMNBarcode Class

Defines the class for ISMN barcodes.

Syntax

Visual Basic (Declaration)
Public Class ISMNBarcode
   Inherits EANBarcode
Visual Basic (Usage) Copy Code
Dim instance As ISMNBarcode
C#
public class ISMNBarcode : EANBarcode
Managed Extensions for C++
public __gc class ISMNBarcode : public EANBarcode
C++/CLI
public ref class ISMNBarcode : public EANBarcode

Remarks

ISMN symbology is a numeric symbology. Only the following symbols are allowed in an ISMN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISMN barcode (International Standard Music Number) is in fact an EAN-13 barcode having the 979 number system. The data for an ISMN barcode must always have 9 characters length. The number system is always 979 and the last character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.ISMNBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISMNBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
ISMNBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : ISMNBarcode Class

The following tables list the members exposed by ISMNBarcode.

Public Constructors

 | Name | Description
Public Constructor | ISMNBarcode Constructor | Overloaded. Initializes a new ISMNBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

ISMNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ISMNBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > ISMNBarcode Class : ISMNBarcode Constructor

Initializes a new ISMNBarcode object.

Overload List

Overload | Description
ISMNBarcode Constructor() | Initializes a new ISMNBarcode object.
ISMNBarcode Constructor(String) | Initializes a new ISMNBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISMNBarcode Class
ISMNBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ISMNBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > ISMNBarcode Class > ISMNBarcode Constructor : ISMNBarcode Constructor()

Initializes a new ISMNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ISMNBarcode()
C#
public ISMNBarcode()
Managed Extensions for C++
public: ISMNBarcode();
C++/CLI
public:
ISMNBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISMNBarcode Class
ISMNBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ISMNBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > ISMNBarcode Class > ISMNBarcode Constructor : ISMNBarcode Constructor(String)

data
The data to be encoded.
Initializes a new ISMNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As ISMNBarcode(data)
C#
public ISMNBarcode(
   string data
)
Managed Extensions for C++
public: ISMNBarcode(
   string* data
)
C++/CLI
public:
ISMNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISMNBarcode Class
ISMNBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ISSNBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : ISSNBarcode Class

Defines the class for ISSN barcodes.

Syntax

Visual Basic (Declaration)
Public Class ISSNBarcode
   Inherits EANBarcode
Visual Basic (Usage) Copy Code
Dim instance As ISSNBarcode
C#
public class ISSNBarcode : EANBarcode
Managed Extensions for C++
public __gc class ISSNBarcode : public EANBarcode
C++/CLI
public ref class ISSNBarcode : public EANBarcode

Remarks

ISSN symbology is a numeric symbology. Only the following symbols are allowed in an ISSN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISSN barcode (International Standard Serial Number for Periodicals) is in fact an EAN-13 barcode having the 977 number system. The data for an ISSN barcode must always have 9 characters length. The number system is always 977 and the last character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.ISSNBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISSNBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
ISSNBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : ISSNBarcode Class

The following tables list the members exposed by ISSNBarcode.

Public Constructors

 | Name | Description
Public Constructor | ISSNBarcode Constructor | Overloaded. Initializes a new ISSNBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

ISSNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ISSNBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > ISSNBarcode Class : ISSNBarcode Constructor

Initializes a new ISSNBarcode object.

Overload List

Overload | Description
ISSNBarcode Constructor() | Initializes a new ISSNBarcode object.
ISSNBarcode Constructor(String) | Initializes a new ISSNBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISSNBarcode Class
ISSNBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ISSNBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > ISSNBarcode Class > ISSNBarcode Constructor : ISSNBarcode Constructor()

Initializes a new ISSNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ISSNBarcode()
C#
public ISSNBarcode()
Managed Extensions for C++
public: ISSNBarcode();
C++/CLI
public:
ISSNBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISSNBarcode Class
ISSNBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ISSNBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > ISSNBarcode Class > ISSNBarcode Constructor : ISSNBarcode Constructor(String)

data
The data to be encoded.
Initializes a new ISSNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As ISSNBarcode(data)
C#
public ISSNBarcode(
   string data
)
Managed Extensions for C++
public: ISSNBarcode(
   string* data
)
C++/CLI
public:
ISSNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISSNBarcode Class
ISSNBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
JAN13Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : JAN13Barcode Class

Defines the class for JAN13 barcodes.

Syntax

Visual Basic (Declaration)
Public Class JAN13Barcode
   Inherits EANBarcode
Visual Basic (Usage) Copy Code
Dim instance As JAN13Barcode
C#
public class JAN13Barcode : EANBarcode
Managed Extensions for C++
public __gc class JAN13Barcode : public EANBarcode
C++/CLI
public ref class JAN13Barcode : public EANBarcode

Remarks

JAN-13 symbology is a numeric symbology. Only the following symbols are allowed in an JAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. An JAN-13 barcode (Japanese Article Numbering) is in fact an EAN-13 barcode having the 49 number system. The data for an JAN-13 barcode must always have 10 characters length. The number system is always 49 and the last character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.JAN13Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

JAN13Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
JAN13Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : JAN13Barcode Class

The following tables list the members exposed by JAN13Barcode.

Public Constructors

 | Name | Description
Public Constructor | JAN13Barcode Constructor | Overloaded. Initializes a new JAN13Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

JAN13Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
JAN13Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > JAN13Barcode Class : JAN13Barcode Constructor

Initializes a new JAN13Barcode object.

Overload List

Overload | Description
JAN13Barcode Constructor() | Initializes a new JAN13Barcode object.
JAN13Barcode Constructor(String) | Initializes a new JAN13Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

JAN13Barcode Class
JAN13Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
JAN13Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > JAN13Barcode Class > JAN13Barcode Constructor : JAN13Barcode Constructor()

Initializes a new JAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As JAN13Barcode()
C#
public JAN13Barcode()
Managed Extensions for C++
public: JAN13Barcode();
C++/CLI
public:
JAN13Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

JAN13Barcode Class
JAN13Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
JAN13Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > JAN13Barcode Class > JAN13Barcode Constructor : JAN13Barcode Constructor(String)

data
The data to be encoded.
Initializes a new JAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As JAN13Barcode(data)
C#
public JAN13Barcode(
   string data
)
Managed Extensions for C++
public: JAN13Barcode(
   string* data
)
C++/CLI
public:
JAN13Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

JAN13Barcode Class
JAN13Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Matrix25Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Matrix25Barcode Class

Defines a Matrix 2 of 5 barcode.

Syntax

Visual Basic (Declaration)
Public Class Matrix25Barcode
   Inherits Code25Barcode
Visual Basic (Usage) Copy Code
Dim instance As Matrix25Barcode
C#
public class Matrix25Barcode : Code25Barcode
Managed Extensions for C++
public __gc class Matrix25Barcode : public Code25Barcode
C++/CLI
public ref class Matrix25Barcode : public Code25Barcode

Remarks

Matrix 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Matrix 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code25Barcode
O2S.Barcode4NET.Matrix25Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Matrix25Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
Matrix25Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Matrix25Barcode Class

The following tables list the members exposed by Matrix25Barcode.

Public Constructors

 | Name | Description
Public Constructor | Matrix25Barcode Constructor | Overloaded. Initializes a new Matrix25Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Matrix25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Matrix25Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Matrix25Barcode Class : Matrix25Barcode Constructor

Initializes a new Matrix25Barcode object.

Overload List

Overload | Description
Matrix25Barcode Constructor() | Initializes a new Matrix25Barcode object.
Matrix25Barcode Constructor(String) | Initializes a new Matrix25Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Matrix25Barcode Class
Matrix25Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Matrix25Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Matrix25Barcode Class > Matrix25Barcode Constructor : Matrix25Barcode Constructor()

Initializes a new Matrix25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Matrix25Barcode()
C#
public Matrix25Barcode()
Managed Extensions for C++
public: Matrix25Barcode();
C++/CLI
public:
Matrix25Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Matrix25Barcode Class
Matrix25Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Matrix25Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Matrix25Barcode Class > Matrix25Barcode Constructor : Matrix25Barcode Constructor(String)

data
The data to be encoded.
Initializes a new Matrix25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Matrix25Barcode(data)
C#
public Matrix25Barcode(
   string data
)
Managed Extensions for C++
public: Matrix25Barcode(
   string* data
)
C++/CLI
public:
Matrix25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Matrix25Barcode Class
Matrix25Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MicroPDF417Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : MicroPDF417Barcode Class

Defines a Micro PDF 417 barcode.

Syntax

Visual Basic (Declaration)
Public Class MicroPDF417Barcode
   Inherits BasePDF417Barcode
Visual Basic (Usage) Copy Code
Dim instance As MicroPDF417Barcode
C#
public class MicroPDF417Barcode : BasePDF417Barcode
Managed Extensions for C++
public __gc class MicroPDF417Barcode : public BasePDF417Barcode
C++/CLI
public ref class MicroPDF417Barcode : public BasePDF417Barcode

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.BasePDF417Barcode
O2S.Barcode4NET.MicroPDF417Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MicroPDF417Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
MicroPDF417Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : MicroPDF417Barcode Class

The following tables list the members exposed by MicroPDF417Barcode.

Public Constructors

 | Name | Description
Public Constructor | MicroPDF417Barcode Constructor | Initializes a new MicroPDF417Barcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from BasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from BasePDF417Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from BasePDF417Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

MicroPDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MicroPDF417Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > MicroPDF417Barcode Class : MicroPDF417Barcode Constructor

Initializes a new MicroPDF417Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MicroPDF417Barcode()
C#
public MicroPDF417Barcode()
Managed Extensions for C++
public: MicroPDF417Barcode();
C++/CLI
public:
MicroPDF417Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MicroPDF417Barcode Class
MicroPDF417Barcode Members


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
MicroPDF417Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : MicroPDF417Barcode Class

For a list of all members of this type, see MicroPDF417Barcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from BasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from BasePDF417Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

MicroPDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SymbolSize Property
See Also
[image]
O2S.Barcode4NET Namespace > MicroPDF417Barcode Class : SymbolSize Property

Gets or sets the symbol size of this Micro PDF 417 barcode.

Syntax

Visual Basic (Declaration)
Public Property SymbolSize As MicroPDF417SymbolSize
Visual Basic (Usage) Copy Code
Dim instance As MicroPDF417Barcode
Dim value As MicroPDF417SymbolSize

instance.SymbolSize = value

value = instance.SymbolSize
C#
public MicroPDF417SymbolSize SymbolSize {get; set;}
Managed Extensions for C++
public: __property MicroPDF417SymbolSize get_SymbolSize();
public: __property void set_SymbolSize(
   MicroPDF417SymbolSize value
);
C++/CLI
public:
property MicroPDF417SymbolSize SymbolSize {
   MicroPDF417SymbolSize get();
   void set (MicroPDF417SymbolSize value);
}

Return Value

A MicroPDF417SymbolSize enumeration member specifying the size of symbol used to represent this Micro PDF 417 barcode.

Remarks

If the SymbolSize is Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MicroPDF417Barcode Class
MicroPDF417Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MSIPlesseyBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : MSIPlesseyBarcode Class

Defines a MSI/Plessey barcode.

Syntax

Visual Basic (Declaration)
Public Class MSIPlesseyBarcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As MSIPlesseyBarcode
C#
public class MSIPlesseyBarcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc class MSIPlesseyBarcode : public UnidimensionalBarcode
C++/CLI
public ref class MSIPlesseyBarcode : public UnidimensionalBarcode

Remarks

MSI/Plessey is a numeric symbology. Only the following symbols are allowed in a MSI/Plessey barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.MSIPlesseyBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MSIPlesseyBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
MSIPlesseyBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : MSIPlesseyBarcode Class

The following tables list the members exposed by MSIPlesseyBarcode.

Public Constructors

 | Name | Description
Public Constructor | MSIPlesseyBarcode Constructor | Overloaded. Initializes a new MSIPlesseyBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

MSIPlesseyBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MSIPlesseyBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > MSIPlesseyBarcode Class : MSIPlesseyBarcode Constructor

Initializes a new MSIPlesseyBarcode object.

Overload List

Overload | Description
MSIPlesseyBarcode Constructor() | Initializes a new MSIPlesseyBarcode object.
MSIPlesseyBarcode Constructor(String) | Initializes a new MSIPlesseyBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MSIPlesseyBarcode Class
MSIPlesseyBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MSIPlesseyBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > MSIPlesseyBarcode Class > MSIPlesseyBarcode Constructor : MSIPlesseyBarcode Constructor()

Initializes a new MSIPlesseyBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MSIPlesseyBarcode()
C#
public MSIPlesseyBarcode()
Managed Extensions for C++
public: MSIPlesseyBarcode();
C++/CLI
public:
MSIPlesseyBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MSIPlesseyBarcode Class
MSIPlesseyBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MSIPlesseyBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > MSIPlesseyBarcode Class > MSIPlesseyBarcode Constructor : MSIPlesseyBarcode Constructor(String)

data
The data to be encoded.
Initializes a new MSIPlesseyBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As MSIPlesseyBarcode(data)
C#
public MSIPlesseyBarcode(
   string data
)
Managed Extensions for C++
public: MSIPlesseyBarcode(
   string* data
)
C++/CLI
public:
MSIPlesseyBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MSIPlesseyBarcode Class
MSIPlesseyBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
PDF417Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : PDF417Barcode Class

Defines a PDF 417 barcode.

Syntax

Visual Basic (Declaration)
Public Class PDF417Barcode
   Inherits BasePDF417Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
C#
public class PDF417Barcode : BasePDF417Barcode
Managed Extensions for C++
public __gc class PDF417Barcode : public BasePDF417Barcode
C++/CLI
public ref class PDF417Barcode : public BasePDF417Barcode

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.BasePDF417Barcode
O2S.Barcode4NET.PDF417Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
PDF417Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : PDF417Barcode Class

The following tables list the members exposed by PDF417Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDF417Barcode Constructor | Initializes a new PDF417Barcode object.
Top

Public Properties

 | Name | Description
Public Property | ActualColumns | Returns the actual number of columns used by this barcode.
Public Property | ActualRows | Returns the actual number of rows used by this barcode.
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from BasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | ErrorCorrectionLevel | Gets or sets the level of error correction used by this barcode.
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from BasePDF417Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from BasePDF417Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

PDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
PDF417Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > PDF417Barcode Class : PDF417Barcode Constructor

Initializes a new PDF417Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode()
C#
public PDF417Barcode()
Managed Extensions for C++
public: PDF417Barcode();
C++/CLI
public:
PDF417Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
PDF417Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : PDF417Barcode Class

For a list of all members of this type, see PDF417Barcode members.

Public Properties

 | Name | Description
Public Property | ActualColumns | Returns the actual number of columns used by this barcode.
Public Property | ActualRows | Returns the actual number of rows used by this barcode.
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from BasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | ErrorCorrectionLevel | Gets or sets the level of error correction used by this barcode.
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from BasePDF417Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

PDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ActualColumns Property
See Also
[image]
O2S.Barcode4NET Namespace > PDF417Barcode Class : ActualColumns Property

Returns the actual number of columns used by this barcode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActualColumns As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As Integer

value = instance.ActualColumns
C#
public int ActualColumns {get;}
Managed Extensions for C++
public: __property int get_ActualColumns();
C++/CLI
public:
property int ActualColumns {
   int get();
}

Return Value

An integer value specifying the actual number of columns used by this barcode.

Remarks

This value is computed automatically by the library when Columns property is 0. When Columns property is not 0, this property matches the Columns property.
This property returns -1 if a valid number of columns can not be computed for the following combination: barcode data, rows and error correction level.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ActualRows Property
See Also
[image]
O2S.Barcode4NET Namespace > PDF417Barcode Class : ActualRows Property

Returns the actual number of rows used by this barcode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActualRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As Integer

value = instance.ActualRows
C#
public int ActualRows {get;}
Managed Extensions for C++
public: __property int get_ActualRows();
C++/CLI
public:
property int ActualRows {
   int get();
}

Return Value

An integer value specifying the actual number of rows used by this barcode.

Remarks

This value is computed automatically by the library when Rows property is 0. When Rows property is not 0, this property matches the Rows property.
This property returns -1 if a valid number of rows can not be computed for the following combination: barcode data, columns and error correction level.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Columns Property
See Also
[image]
O2S.Barcode4NET Namespace > PDF417Barcode Class : Columns Property

Gets or sets the number of columns in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As Integer

instance.Columns = value

value = instance.Columns
C#
public int Columns {get; set;}
Managed Extensions for C++
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
C++/CLI
public:
property int Columns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 1 or greater than 30 - OR - Throws when value is 0 and Rows is also 0.

Remarks

The minimum number of columns in a PDF 417 barcode is 1 and the maximum number of columns is 30. If this property is 0, the library will compute automatically the number of required columns to encode the barcode data. When this property is 0, the Rows property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ErrorCorrectionLevel Property
See Also
[image]
O2S.Barcode4NET Namespace > PDF417Barcode Class : ErrorCorrectionLevel Property

Gets or sets the level of error correction used by this barcode.

Syntax

Visual Basic (Declaration)
Public Property ErrorCorrectionLevel As PDF417ErrorCorrectionLevel
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As PDF417ErrorCorrectionLevel

instance.ErrorCorrectionLevel = value

value = instance.ErrorCorrectionLevel
C#
public PDF417ErrorCorrectionLevel ErrorCorrectionLevel {get; set;}
Managed Extensions for C++
public: __property PDF417ErrorCorrectionLevel get_ErrorCorrectionLevel();
public: __property void set_ErrorCorrectionLevel(
   PDF417ErrorCorrectionLevel value
);
C++/CLI
public:
property PDF417ErrorCorrectionLevel ErrorCorrectionLevel {
   PDF417ErrorCorrectionLevel get();
   void set (PDF417ErrorCorrectionLevel value);
}

Return Value

A PDF417ErrorCorrectionLevel enumeration member specifying the level or error correction used by this barcode.

Remarks

The lowest error correction level is 0 and the greatest error correction level is 8. Each level generates a specific number of error correction codewords.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Rows Property
See Also
[image]
O2S.Barcode4NET Namespace > PDF417Barcode Class : Rows Property

Gets or sets the number of rows in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
public int Rows {get; set;}
Managed Extensions for C++
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
C++/CLI
public:
property int Rows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 3, but not 0, or greater than 90 - OR - Throws when value is 0 and Columns is also 0.

Remarks

The minimum number of rows in a PDF 417 barcode is 3 and the maximum number of rows is 90. If this property is 0, the library will compute automatically the number of required rows to encode the barcode data. When this property is 0, the Columns property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
PlanetBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : PlanetBarcode Class

Defines a Planet barcode.

Syntax

Visual Basic (Declaration)
Public Class PlanetBarcode
   Inherits HeightModulatedBarcode
Visual Basic (Usage) Copy Code
Dim instance As PlanetBarcode
C#
public class PlanetBarcode : HeightModulatedBarcode
Managed Extensions for C++
public __gc class PlanetBarcode : public HeightModulatedBarcode
C++/CLI
public ref class PlanetBarcode : public HeightModulatedBarcode

Remarks

The Planet barcode was developed by the United States Postal Service (USPS).
Only the following symbols are allowed in a Planet barcode: 0 1 2 3 4 5 6 7 8 9
The information is encoded in the height of the barcodes, not in their width.
The required data length for a Planet barcode is either 11 or 13 digits.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.HeightModulatedBarcode
O2S.Barcode4NET.PlanetBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PlanetBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
PlanetBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : PlanetBarcode Class

The following tables list the members exposed by PlanetBarcode.

Public Constructors

 | Name | Description
Public Constructor | PlanetBarcode Constructor | Overloaded. Initializes a new PlanetBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

PlanetBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
PlanetBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > PlanetBarcode Class : PlanetBarcode Constructor

Initializes a new PlanetBarcode object.

Overload List

Overload | Description
PlanetBarcode Constructor() | Initializes a new PlanetBarcode object.
PlanetBarcode Constructor(String) | Initializes a new PlanetBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PlanetBarcode Class
PlanetBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
PlanetBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > PlanetBarcode Class > PlanetBarcode Constructor : PlanetBarcode Constructor()

Initializes a new PlanetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PlanetBarcode()
C#
public PlanetBarcode()
Managed Extensions for C++
public: PlanetBarcode();
C++/CLI
public:
PlanetBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PlanetBarcode Class
PlanetBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
PlanetBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > PlanetBarcode Class > PlanetBarcode Constructor : PlanetBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PlanetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PlanetBarcode(data)
C#
public PlanetBarcode(
   string data
)
Managed Extensions for C++
public: PlanetBarcode(
   string* data
)
C++/CLI
public:
PlanetBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PlanetBarcode Class
PlanetBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
PostnetBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : PostnetBarcode Class

Defines a Postnet barcode.

Syntax

Visual Basic (Declaration)
Public Class PostnetBarcode
   Inherits HeightModulatedBarcode
Visual Basic (Usage) Copy Code
Dim instance As PostnetBarcode
C#
public class PostnetBarcode : HeightModulatedBarcode
Managed Extensions for C++
public __gc class PostnetBarcode : public HeightModulatedBarcode
C++/CLI
public ref class PostnetBarcode : public HeightModulatedBarcode

Remarks

Postnet was developed by the United States Postal Service (USPS) to allow faster sorting and routing of mail.
Only the following symbols are allowed in a Planet barcode: 0 1 2 3 4 5 6 7 8 9
The information is encoded in the height of the barcodes, not in their width.
The required length for a Postnet barcode is 5 (ZIP), 9 (ZI+4) or 11 (full delivery point) digits.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.HeightModulatedBarcode
O2S.Barcode4NET.PostnetBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostnetBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
PostnetBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : PostnetBarcode Class

The following tables list the members exposed by PostnetBarcode.

Public Constructors

 | Name | Description
Public Constructor | PostnetBarcode Constructor | Overloaded. Initializes a new PostnetBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

PostnetBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
PostnetBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > PostnetBarcode Class : PostnetBarcode Constructor

Initializes a new PostnetBarcode object.

Overload List

Overload | Description
PostnetBarcode Constructor() | Initializes a new PostnetBarcode object.
PostnetBarcode Constructor(String) | Initializes a new PostnetBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostnetBarcode Class
PostnetBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
PostnetBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > PostnetBarcode Class > PostnetBarcode Constructor : PostnetBarcode Constructor()

Initializes a new PostnetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PostnetBarcode()
C#
public PostnetBarcode()
Managed Extensions for C++
public: PostnetBarcode();
C++/CLI
public:
PostnetBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostnetBarcode Class
PostnetBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
PostnetBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > PostnetBarcode Class > PostnetBarcode Constructor : PostnetBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PostnetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PostnetBarcode(data)
C#
public PostnetBarcode(
   string data
)
Managed Extensions for C++
public: PostnetBarcode(
   string* data
)
C++/CLI
public:
PostnetBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostnetBarcode Class
PostnetBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
RM4SCCBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : RM4SCCBarcode Class

Defines a RM4SCC barcode.

Syntax

Visual Basic (Declaration)
Public Class RM4SCCBarcode
   Inherits HeightModulatedBarcode
Visual Basic (Usage) Copy Code
Dim instance As RM4SCCBarcode
C#
public class RM4SCCBarcode : HeightModulatedBarcode
Managed Extensions for C++
public __gc class RM4SCCBarcode : public HeightModulatedBarcode
C++/CLI
public ref class RM4SCCBarcode : public HeightModulatedBarcode

Remarks

The Royal Mail 4-state Customer Code (RM4SCC) is a height-modulated barcode symbology for use in automated mail sortation process.
Only the following symbols are allowed in a RM4SCC barcode: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z.
The information is encoded in the height of the barcodes, not in their width.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.HeightModulatedBarcode
O2S.Barcode4NET.RM4SCCBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RM4SCCBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
RM4SCCBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : RM4SCCBarcode Class

The following tables list the members exposed by RM4SCCBarcode.

Public Constructors

 | Name | Description
Public Constructor | RM4SCCBarcode Constructor | Overloaded. Initializes a new RM4SCCBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

RM4SCCBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
RM4SCCBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > RM4SCCBarcode Class : RM4SCCBarcode Constructor

Initializes a new RM4SCCBarcode object.

Overload List

Overload | Description
RM4SCCBarcode Constructor() | Initializes a new RM4SCCBarcode object.
RM4SCCBarcode Constructor(String) | Initializes a new RM4SCCBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RM4SCCBarcode Class
RM4SCCBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
RM4SCCBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > RM4SCCBarcode Class > RM4SCCBarcode Constructor : RM4SCCBarcode Constructor()

Initializes a new RM4SCCBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RM4SCCBarcode()
C#
public RM4SCCBarcode()
Managed Extensions for C++
public: RM4SCCBarcode();
C++/CLI
public:
RM4SCCBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RM4SCCBarcode Class
RM4SCCBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
RM4SCCBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > RM4SCCBarcode Class > RM4SCCBarcode Constructor : RM4SCCBarcode Constructor(String)

data
The data to be encoded.
Initializes a new RM4SCCBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As RM4SCCBarcode(data)
C#
public RM4SCCBarcode(
   string data
)
Managed Extensions for C++
public: RM4SCCBarcode(
   string* data
)
C++/CLI
public:
RM4SCCBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RM4SCCBarcode Class
RM4SCCBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SCC14Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : SCC14Barcode Class

Defines a SCC-14 barcode.

Syntax

Visual Basic (Declaration)
Public Class SCC14Barcode
   Inherits Code128CBarcode
Visual Basic (Usage) Copy Code
Dim instance As SCC14Barcode
C#
public class SCC14Barcode : Code128CBarcode
Managed Extensions for C++
public __gc class SCC14Barcode : public Code128CBarcode
C++/CLI
public ref class SCC14Barcode : public Code128CBarcode

Remarks

This class defines a SCC-14 (Shipping Container Code) barcode. Only the following symbols are allowed in a SCC-14 barcode: 0 1 2 3 4 5 6 7 8 9.
A SCC-14 barcode is a special Code 128C barcode using a predefined format with a fixed length. The barcode length is 14 digits. 13 digits are provided by the user, the 14th digit is the check digit and it is calculated automatically by the library.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code128CBarcode
O2S.Barcode4NET.SCC14Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SCC14Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
SCC14Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : SCC14Barcode Class

The following tables list the members exposed by SCC14Barcode.

Public Constructors

 | Name | Description
Public Constructor | SCC14Barcode Constructor | Overloaded. Initializes a new SCC14Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

SCC14Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SCC14Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > SCC14Barcode Class : SCC14Barcode Constructor

Initializes a new SCC14Barcode object.

Overload List

Overload | Description
SCC14Barcode Constructor() | Initializes a new SCC14Barcode object.
SCC14Barcode Constructor(String) | Initializes a new SCC14Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SCC14Barcode Class
SCC14Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SCC14Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > SCC14Barcode Class > SCC14Barcode Constructor : SCC14Barcode Constructor()

Initializes a new SCC14Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SCC14Barcode()
C#
public SCC14Barcode()
Managed Extensions for C++
public: SCC14Barcode();
C++/CLI
public:
SCC14Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SCC14Barcode Class
SCC14Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SCC14Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > SCC14Barcode Class > SCC14Barcode Constructor : SCC14Barcode Constructor(String)

data
The data to be encoded.
Initializes a new SCC14Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As SCC14Barcode(data)
C#
public SCC14Barcode(
   string data
)
Managed Extensions for C++
public: SCC14Barcode(
   string* data
)
C++/CLI
public:
SCC14Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SCC14Barcode Class
SCC14Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SSCC18Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : SSCC18Barcode Class

Defines a SSCC-18 barcode.

Syntax

Visual Basic (Declaration)
Public Class SSCC18Barcode
   Inherits Code128CBarcode
Visual Basic (Usage) Copy Code
Dim instance As SSCC18Barcode
C#
public class SSCC18Barcode : Code128CBarcode
Managed Extensions for C++
public __gc class SSCC18Barcode : public Code128CBarcode
C++/CLI
public ref class SSCC18Barcode : public Code128CBarcode

Remarks

This class defines a SSCC-18 (Serial Shipping Container Code) barcode. Only the following symbols are allowed in a SSCC-18 barcode: 0 1 2 3 4 5 6 7 8 9.
A SSCC-18 barcode is a special Code 128C barcode using a predefined format with a fixed length. The barcode length is 18 digits. 17 digits are provided by the user, the 18th digit is the check digit and it is calculated automatically by the library.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code128CBarcode
O2S.Barcode4NET.SSCC18Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SSCC18Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
SSCC18Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : SSCC18Barcode Class

The following tables list the members exposed by SSCC18Barcode.

Public Constructors

 | Name | Description
Public Constructor | SSCC18Barcode Constructor | Overloaded. Initializes a new SSCC18Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

SSCC18Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SSCC18Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > SSCC18Barcode Class : SSCC18Barcode Constructor

Initializes a new SSCC18Barcode object.

Overload List

Overload | Description
SSCC18Barcode Constructor() | Initializes a new SSCC18Barcode object.
SSCC18Barcode Constructor(String) | Initializes a new SSCC18Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SSCC18Barcode Class
SSCC18Barcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SSCC18Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > SSCC18Barcode Class > SSCC18Barcode Constructor : SSCC18Barcode Constructor()

Initializes a new SSCC18Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SSCC18Barcode()
C#
public SSCC18Barcode()
Managed Extensions for C++
public: SSCC18Barcode();
C++/CLI
public:
SSCC18Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SSCC18Barcode Class
SSCC18Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SSCC18Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > SSCC18Barcode Class > SSCC18Barcode Constructor : SSCC18Barcode Constructor(String)

data
The data to be encoded.
Initializes a new SSCC18Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As SSCC18Barcode(data)
C#
public SSCC18Barcode(
   string data
)
Managed Extensions for C++
public: SSCC18Barcode(
   string* data
)
C++/CLI
public:
SSCC18Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SSCC18Barcode Class
SSCC18Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UnidimensionalBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : UnidimensionalBarcode Class

Defines the base class for 1D barcodes.

Syntax

Visual Basic (Declaration)
Public MustInherit Class UnidimensionalBarcode
   Inherits Barcode
Visual Basic (Usage) Copy Code
Dim instance As UnidimensionalBarcode
C#
public abstract class UnidimensionalBarcode : Barcode
Managed Extensions for C++
public __gc abstract class UnidimensionalBarcode : public Barcode
C++/CLI
public ref class UnidimensionalBarcode abstract : public Barcode

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.MSIPlesseyBarcode
O2S.Barcode4NET.MSIPlesseyBarcode
O2S.Barcode4NET.HeightModulatedBarcode
O2S.Barcode4NET.HeightModulatedBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.Code93Barcode
O2S.Barcode4NET.Code93Barcode
O2S.Barcode4NET.Code39Barcode
O2S.Barcode4NET.Code39Barcode
O2S.Barcode4NET.Code25Barcode
O2S.Barcode4NET.Code25Barcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code11Barcode
O2S.Barcode4NET.Code11Barcode
O2S.Barcode4NET.CodabarBarcode
O2S.Barcode4NET.CodabarBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnidimensionalBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
UnidimensionalBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : UnidimensionalBarcode Class

The following tables list the members exposed by UnidimensionalBarcode.

Public Constructors

 | Name | Description
Public Constructor | UnidimensionalBarcode Constructor | Overloaded. Initializes a new UnidimensionalBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Overridden. Gets whether the given character code can be encoded by the barcode.
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

UnidimensionalBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UnidimensionalBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > UnidimensionalBarcode Class : UnidimensionalBarcode Constructor

Initializes a new UnidimensionalBarcode object.

Overload List

Overload | Description
UnidimensionalBarcode Constructor() | Initializes a new UnidimensionalBarcode object.
UnidimensionalBarcode Constructor(String) | Initializes a new UnidimensionalBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnidimensionalBarcode Class
UnidimensionalBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UnidimensionalBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > UnidimensionalBarcode Class > UnidimensionalBarcode Constructor : UnidimensionalBarcode Constructor()

Initializes a new UnidimensionalBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UnidimensionalBarcode()
C#
public UnidimensionalBarcode()
Managed Extensions for C++
public: UnidimensionalBarcode();
C++/CLI
public:
UnidimensionalBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnidimensionalBarcode Class
UnidimensionalBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UnidimensionalBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > UnidimensionalBarcode Class > UnidimensionalBarcode Constructor : UnidimensionalBarcode Constructor(String)

data
The data to be encoded.
Initializes a new UnidimensionalBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As UnidimensionalBarcode(data)
C#
public UnidimensionalBarcode(
   string data
)
Managed Extensions for C++
public: UnidimensionalBarcode(
   string* data
)
C++/CLI
public:
UnidimensionalBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length (applies to some barcodes only).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnidimensionalBarcode Class
UnidimensionalBarcode Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
UnidimensionalBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : UnidimensionalBarcode Class

For a list of all members of this type, see UnidimensionalBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Overridden. Gets whether the given character code can be encoded by the barcode.
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

UnidimensionalBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsValidCharacterCode Method
See Also
[image]
O2S.Barcode4NET Namespace > UnidimensionalBarcode Class : IsValidCharacterCode Method

characterCode
The character code to test.
Gets whether the given character code can be encoded by the barcode.

Syntax

Visual Basic (Declaration)
Overrides Public Function IsValidCharacterCode( _
   ByVal characterCode As Byte _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UnidimensionalBarcode
Dim characterCode As Byte
Dim value As Boolean

value = instance.IsValidCharacterCode(characterCode)
C#
public override bool IsValidCharacterCode(
   byte characterCode
)
Managed Extensions for C++
public: bool IsValidCharacterCode(
   byte characterCode
) override
C++/CLI
public:
bool IsValidCharacterCode(
   byte characterCode
) override

Parameters

characterCode
The character code to test.

Return Value

True if the character code can be encoded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnidimensionalBarcode Class
UnidimensionalBarcode Members


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
UnidimensionalBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : UnidimensionalBarcode Class

For a list of all members of this type, see UnidimensionalBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

UnidimensionalBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
DataDisplayLocation Property
See Also
[image]
O2S.Barcode4NET Namespace > UnidimensionalBarcode Class : DataDisplayLocation Property

Gets or sets the location of the barcode data.

Syntax

Visual Basic (Declaration)
Public Property DataDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As UnidimensionalBarcode
Dim value As BarcodeTextLocation

instance.DataDisplayLocation = value

value = instance.DataDisplayLocation
C#
public BarcodeTextLocation DataDisplayLocation {get; set;}
Managed Extensions for C++
public: __property BarcodeTextLocation get_DataDisplayLocation();
public: __property void set_DataDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation DataDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location of the barcode data when it is displayed on the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnidimensionalBarcode Class
UnidimensionalBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
DisplayCheckSum Property
See Also
[image]
O2S.Barcode4NET Namespace > UnidimensionalBarcode Class : DisplayCheckSum Property

Gets or sets whether the check characters should be displayed in barcode text.

Syntax

Visual Basic (Declaration)
Public Property DisplayCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UnidimensionalBarcode
Dim value As Boolean

instance.DisplayCheckSum = value

value = instance.DisplayCheckSum
C#
public bool DisplayCheckSum {get; set;}
Managed Extensions for C++
public: __property bool get_DisplayCheckSum();
public: __property void set_DisplayCheckSum(
   bool value
);
C++/CLI
public:
property bool DisplayCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if the check characters should be displayed. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnidimensionalBarcode Class
UnidimensionalBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
EnableCheckSum Property
See Also
[image]
O2S.Barcode4NET Namespace > UnidimensionalBarcode Class : EnableCheckSum Property

Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.

Syntax

Visual Basic (Declaration)
Public Property EnableCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UnidimensionalBarcode
Dim value As Boolean

instance.EnableCheckSum = value

value = instance.EnableCheckSum
C#
public bool EnableCheckSum {get; set;}
Managed Extensions for C++
public: __property bool get_EnableCheckSum();
public: __property void set_EnableCheckSum(
   bool value
);
C++/CLI
public:
property bool EnableCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if a checksum symbol should be appended automatically to the barcode, false otherwise.

Remarks

Not all barcodes support checksum symbols. This property is ignored for those that do not support them.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnidimensionalBarcode Class
UnidimensionalBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UPCABarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : UPCABarcode Class

Defines the class for UPC-A barcodes.

Syntax

Visual Basic (Declaration)
Public Class UPCABarcode
   Inherits EANBarcode
Visual Basic (Usage) Copy Code
Dim instance As UPCABarcode
C#
public class UPCABarcode : EANBarcode
Managed Extensions for C++
public __gc class UPCABarcode : public EANBarcode
C++/CLI
public ref class UPCABarcode : public EANBarcode

Remarks

UPC-A symbology is a numeric symbology. Only the following symbols are allowed in an UPC-A barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an UPC-A barcode must always have 11 characters length. The first digit is the number system, usually 0, and the last digit is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.UPCABarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCABarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
UPCABarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : UPCABarcode Class

The following tables list the members exposed by UPCABarcode.

Public Constructors

 | Name | Description
Public Constructor | UPCABarcode Constructor | Overloaded. Initializes a new UPCABarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

UPCABarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UPCABarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > UPCABarcode Class : UPCABarcode Constructor

Initializes a new UPCABarcode object.

Overload List

Overload | Description
UPCABarcode Constructor() | Initializes a new UPCABarcode object.
UPCABarcode Constructor(String) | Initializes a new UPCABarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCABarcode Class
UPCABarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UPCABarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > UPCABarcode Class > UPCABarcode Constructor : UPCABarcode Constructor()

Initializes a new UPCABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UPCABarcode()
C#
public UPCABarcode()
Managed Extensions for C++
public: UPCABarcode();
C++/CLI
public:
UPCABarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCABarcode Class
UPCABarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UPCABarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > UPCABarcode Class > UPCABarcode Constructor : UPCABarcode Constructor(String)

data
The data to be encoded.
Initializes a new UPCABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As UPCABarcode(data)
C#
public UPCABarcode(
   string data
)
Managed Extensions for C++
public: UPCABarcode(
   string* data
)
C++/CLI
public:
UPCABarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCABarcode Class
UPCABarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UPCEBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : UPCEBarcode Class

Defines the class for UPC-E barcodes.

Syntax

Visual Basic (Declaration)
Public Class UPCEBarcode
   Inherits EANBarcode
Visual Basic (Usage) Copy Code
Dim instance As UPCEBarcode
C#
public class UPCEBarcode : EANBarcode
Managed Extensions for C++
public __gc class UPCEBarcode : public EANBarcode
C++/CLI
public ref class UPCEBarcode : public EANBarcode

Remarks

UPC-E symbology is a numeric symbology. Only the following symbols are allowed in an UPC-E barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an UPC-E barcode must always have 7 digits length. The first digit is the number system, usually 0, and the last digit is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.UPCEBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCEBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
UPCEBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : UPCEBarcode Class

The following tables list the members exposed by UPCEBarcode.

Public Constructors

 | Name | Description
Public Constructor | UPCEBarcode Constructor | Overloaded. Initializes a new UPCEBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

UPCEBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UPCEBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > UPCEBarcode Class : UPCEBarcode Constructor

Initializes a new UPCEBarcode object.

Overload List

Overload | Description
UPCEBarcode Constructor() | Initializes a new UPCEBarcode object.
UPCEBarcode Constructor(String) | Initializes a new UPCEBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCEBarcode Class
UPCEBarcode Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UPCEBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > UPCEBarcode Class > UPCEBarcode Constructor : UPCEBarcode Constructor()

Initializes a new UPCEBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UPCEBarcode()
C#
public UPCEBarcode()
Managed Extensions for C++
public: UPCEBarcode();
C++/CLI
public:
UPCEBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCEBarcode Class
UPCEBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UPCEBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > UPCEBarcode Class > UPCEBarcode Constructor : UPCEBarcode Constructor(String)

data
The data to be encoded.
Initializes a new UPCEBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As UPCEBarcode(data)
C#
public UPCEBarcode(
   string data
)
Managed Extensions for C++
public: UPCEBarcode(
   string* data
)
C++/CLI
public:
UPCEBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCEBarcode Class
UPCEBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BarcodeImageFormat Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : BarcodeImageFormat Enumeration

Specifies the available file formats for saving a barcode image.

Syntax

Visual Basic (Declaration)
Public Enum BarcodeImageFormat
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BarcodeImageFormat
C#
public enum BarcodeImageFormat : Enum
Managed Extensions for C++
__value public enum BarcodeImageFormat : public Enum
C++/CLI
public enum class BarcodeImageFormat : public Enum

Members

Member | Description
Bmp | Bitmap file format.
Emf | EMF (Enhanced Windows Metafile) file format.
Eps | EPS (Encapsulated PostScript) file format.
Gif | GIF (Graphics Interchange Format) file format.
Jpeg | JPEG (Joint Photographic Experts Group) file format.
Pdf | PDF (Portable Document Format) file format.
Png | PNG (Portable Network Graphics) file format.
Ps | PS (PostScript) file format.
Svg | SVG (Scalable Vector Graphics) file format.
Tiff | TIFF (Tag Image File Format) file format.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.BarcodeImageFormat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BarcodeRotation Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : BarcodeRotation Enumeration

Specifies the available rotation angles of the barcode image.

Syntax

Visual Basic (Declaration)
Public Enum BarcodeRotation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BarcodeRotation
C#
public enum BarcodeRotation : Enum
Managed Extensions for C++
__value public enum BarcodeRotation : public Enum
C++/CLI
public enum class BarcodeRotation : public Enum

Members

Member | Description
NoRotation | The barcode image is not rotated.
Rotation90Degrees | The barcode image is rotated with 90 degrees counterclockwise.
Rotation180Degrees | The barcode image is rotated with 180 degrees counterclockwise.
Rotation270Degrees | The barcode image is rotated with 270 degrees counterclockwise.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.BarcodeRotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BarcodeSymbology Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : BarcodeSymbology Enumeration

Specifies the available barcode symbologies.

Syntax

Visual Basic (Declaration)
Public Enum BarcodeSymbology
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BarcodeSymbology
C#
public enum BarcodeSymbology : Enum
Managed Extensions for C++
__value public enum BarcodeSymbology : public Enum
C++/CLI
public enum class BarcodeSymbology : public Enum

Members

Member | Description
Codabar | Codabar barcode.
Code11 | Code 11 barcode.
Code128A | Code 128A barcode.
Code128B | Code 128B barcode.
Code128C | Code 128C barcode.
Code25 | Industrial 2 of 5 barcode.
Code25Interleaved | Interleaved 2 of 5 barcode.
Code39 | Code 3 of 9 barcode.
Code39Extended | Code 3 of 9 extended barcode.
Code93 | Code 93 barcode.
Code93Extended | Code 93 extended barcode.
Coop25 | COOP 2 of 5 barcode.
Ean13 | EAN13 barcode.
Ean8 | EAN8 barcode.
Iata25 | IATA 2 of 5 barcode.
Isbn | ISBN (International Standard Book Numbering) barcode.
Ismn | ISMN (International Standard Music Number) barcode.
Issn | ISSN (International Standard Serial Number for Periodicals) barcode.
Jan13 | JAN13 barcode.
Matrix25 | Matrix 2 of 5 barcode.
MsiPlessey | MSI Plessey barcode.
Planet | Planet barcode.
PostNet | PostNet barcode.
Rm4Scc | RM4SCC (Royal Mail 4-state Customer Code) barcode.
Scc14 | SCC-14 (Shipping Container Code) barcode
Sscc18 | SSCC-18 (Serial Shipping Container Code) barcode.
UpcA | UPC-A barcode.
UpcE | UPC-E barcode.
CodablockF | CodablockF barcode.
Code16K | Code16K barcode.
DataMatrix | DataMatrix barcode.
MicroPdf417 | Micro PDF417 barcode.
Pdf417 | PDF417 (Portable Data Format) barcode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.BarcodeSymbology

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BarcodeTextLocation Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : BarcodeTextLocation Enumeration

Specifies the available locations for displaying text on a linear barcode.

Syntax

Visual Basic (Declaration)
Public Enum BarcodeTextLocation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextLocation
C#
public enum BarcodeTextLocation : Enum
Managed Extensions for C++
__value public enum BarcodeTextLocation : public Enum
C++/CLI
public enum class BarcodeTextLocation : public Enum

Members

Member | Description
None | Barcode text is not displayed.
Above | Barcode text is placed above the bar code.
AboveEmbedded | Barcode text is partially embedded at the top of the bar code. The top of the text is aligned with the top of the bars.
Below | Barcode text is placed below the bar code.
BelowEmbedded | Barcode text is partially embedded in the bottom of the bar code. The baseline of the text is aligned with the bottom of the bars.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.BarcodeTextLocation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
DataMatrixEncoding Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : DataMatrixEncoding Enumeration

Specifies the available encoding modes for a DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Enum DataMatrixEncoding
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixEncoding
C#
public enum DataMatrixEncoding : Enum
Managed Extensions for C++
__value public enum DataMatrixEncoding : public Enum
C++/CLI
public enum class DataMatrixEncoding : public Enum

Members

Member | Description
Auto | The encoding is determined automatically based on the data to encode.
ASCII | The data to encode contains ASCII characters only (0x00 - 0x7F). Extended ASCII characters (0x80 - 0xFF) are also supported.
Base256 | The data to encode is a binary stream.
Numeric | The data to encode contains only numbers (ASCII characters 0x30 - 0x39)

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.DataMatrixEncoding

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
DataMatrixSymbolSize Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : DataMatrixSymbolSize Enumeration

Specifies the available sizes for a DataMatrix symbol.

Syntax

Visual Basic (Declaration)
Public Enum DataMatrixSymbolSize
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixSymbolSize
C#
public enum DataMatrixSymbolSize : Enum
Managed Extensions for C++
__value public enum DataMatrixSymbolSize : public Enum
C++/CLI
public enum class DataMatrixSymbolSize : public Enum

Members

Member | Description
Auto | The smallest symbol size is calculated based on available data.
Size10x10 | Square DataMatrix symbol with 10 rows and 10 columns.
Size12x12 | Square DataMatrix symbol with 12 rows and 12 columns.
Size14x14 | Square DataMatrix symbol with 14 rows and 14 columns.
Size16x16 | Square DataMatrix symbol with 16 rows and 16 columns.
Size18x18 | Square DataMatrix symbol with 18 rows and 18 columns.
Size20x20 | Square DataMatrix symbol with 20 rows and 20 columns.
Size22x22 | Square DataMatrix symbol with 22 rows and 22 columns.
Size24x24 | Square DataMatrix symbol with 24 rows and 24 columns.
Size26x26 | Square DataMatrix symbol with 26 rows and 26 columns.
Size32x32 | Square DataMatrix symbol with 32 rows and 32 columns.
Size36x36 | Square DataMatrix symbol with 36 rows and 36 columns.
Size40x40 | Square DataMatrix symbol with 40 rows and 40 columns.
Size44x44 | Square DataMatrix symbol with 44 rows and 44 columns.
Size48x48 | Square DataMatrix symbol with 48 rows and 48 columns.
Size52x52 | Square DataMatrix symbol with 52 rows and 52 columns.
Size64x64 | Square DataMatrix symbol with 64 rows and 64 columns.
Size72x72 | Square DataMatrix symbol with 72 rows and 72 columns.
Size80x80 | Square DataMatrix symbol with 80 rows and 80 columns.
Size88x88 | Square DataMatrix symbol with 88 rows and 88 columns.
Size96x96 | Square DataMatrix symbol with 96 rows and 96 columns.
Size104x104 | Square DataMatrix symbol with 104 rows and 104 columns.
Size120x120 | Square DataMatrix symbol with 120 rows and 120 columns.
Size132x132 | Square DataMatrix symbol with 132 rows and 132 columns.
Size144x144 | Square DataMatrix symbol with 144 rows and 144 columns.
Size8x18 | Rectangular DataMatrix symbol with 8 rows and 18 columns.
Size8x32 | Rectangular DataMatrix symbol with 8 rows and 32 columns.
Size12x26 | Rectangular DataMatrix symbol with 12 rows and 26 columns.
Size12x36 | Rectangular DataMatrix symbol with 12 rows and 36 columns.
Size16x36 | Rectangular DataMatrix symbol with 16 rows and 36 columns.
Size16x48 | Rectangular DataMatrix symbol with 16 rows and 48 columns.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.DataMatrixSymbolSize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MicroPDF417SymbolSize Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : MicroPDF417SymbolSize Enumeration

Specifies the available sizes for a Micro PDF417 symbol.

Syntax

Visual Basic (Declaration)
Public Enum MicroPDF417SymbolSize
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MicroPDF417SymbolSize
C#
public enum MicroPDF417SymbolSize : Enum
Managed Extensions for C++
__value public enum MicroPDF417SymbolSize : public Enum
C++/CLI
public enum class MicroPDF417SymbolSize : public Enum

Members

Member | Description
Auto | The smallest symbol size is calculated based on available data.
Size11x1 | Micro PDF417 symbol with 11 rows and 1 column.
Size14x1 | Micro PDF417 symbol with 14 rows and 1 column.
Size17x1 | Micro PDF417 symbol with 17 rows and 1 column.
Size20x1 | Micro PDF417 symbol with 20 rows and 1 column.
Size24x1 | Micro PDF417 symbol with 24 rows and 1 column.
Size28x1 | Micro PDF417 symbol with 28 rows and 1 column.
Size8x2 | Micro PDF417 symbol with 8 rows and 2 columns.
Size11x2 | Micro PDF417 symbol with 11 rows and 2 columns.
Size14x2 | Micro PDF417 symbol with 14 rows and 2 columns.
Size17x2 | Micro PDF417 symbol with 17 rows and 2 columns.
Size20x2 | Micro PDF417 symbol with 20 rows and 2 columns.
Size23x2 | Micro PDF417 symbol with 23 rows and 2 columns.
Size26x2 | Micro PDF417 symbol with 26 rows and 2 columns.
Size6x3 | Micro PDF417 symbol with 6 rows and 3 columns.
Size8x3 | Micro PDF417 symbol with 8 rows and 3 columns.
Size10x3 | Micro PDF417 symbol with 10 rows and 3 columns.
Size12x3 | Micro PDF417 symbol with 12 rows and 3 columns.
Size15x3 | Micro PDF417 symbol with 15 rows and 3 columns.
Size20x3 | Micro PDF417 symbol with 20 rows and 3 columns.
Size26x3 | Micro PDF417 symbol with 26 rows and 3 columns.
Size32x3 | Micro PDF417 symbol with 32 rows and 3 columns.
Size38x3 | Micro PDF417 symbol with 38 rows and 3 columns.
Size44x3 | Micro PDF417 symbol with 44 rows and 3 columns.
Size4x4 | Micro PDF417 symbol with 4 rows and 4 columns.
Size6x4 | Micro PDF417 symbol with 6 rows and 4 columns.
Size8x4 | Micro PDF417 symbol with 8 rows and 4 columns.
Size10x4 | Micro PDF417 symbol with 10 rows and 4 columns.
Size12x4 | Micro PDF417 symbol with 12 rows and 4 columns.
Size15x4 | Micro PDF417 symbol with 15 rows and 4 columns.
Size20x4 | Micro PDF417 symbol with 20 rows and 4 columns.
Size26x4 | Micro PDF417 symbol with 26 rows and 4 columns.
Size32x4 | Micro PDF417 symbol with 32 rows and 4 columns.
Size38x4 | Micro PDF417 symbol with 38 rows and 4 columns.
Size44x4 | Micro PDF417 symbol with 44 rows and 4 columns.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.MicroPDF417SymbolSize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
PDF417DataCompactionMode Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : PDF417DataCompactionMode Enumeration

Specifies the available data compaction modes for a PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Enum PDF417DataCompactionMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF417DataCompactionMode
C#
public enum PDF417DataCompactionMode : Enum
Managed Extensions for C++
__value public enum PDF417DataCompactionMode : public Enum
C++/CLI
public enum class PDF417DataCompactionMode : public Enum

Members

Member | Description
Text | Text compaction mode.
Numeric | Numeric compaction mode.
Byte | Binary compaction mode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.PDF417DataCompactionMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
PDF417ErrorCorrectionLevel Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : PDF417ErrorCorrectionLevel Enumeration

Specifies the available error correction levels for a PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Enum PDF417ErrorCorrectionLevel
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF417ErrorCorrectionLevel
C#
public enum PDF417ErrorCorrectionLevel : Enum
Managed Extensions for C++
__value public enum PDF417ErrorCorrectionLevel : public Enum
C++/CLI
public enum class PDF417ErrorCorrectionLevel : public Enum

Members

Member | Description
Level0 | Level 0 - 2 error correction codewords.
Level1 | Level 1 - 4 error correction codewords.
Level2 | Level 2 - 8 error correction codewords.
Level3 | Level 3 - 16 error correction codewords.
Level4 | Level 4 - 32 error correction codewords.
Level5 | Level 5 - 64 error correction codewords.
Level6 | Level 6 - 128 error correction codewords.
Level7 | Level 7 - 256 error correction codewords.
Level8 | Level 8 - 512 error correction codewords.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.PDF417ErrorCorrectionLevel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
XYDimensionUnit Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : XYDimensionUnit Enumeration

Specifies the unit of measure for the barcode's XDimension and YDimension properties.

Syntax

Visual Basic (Declaration)
Public Enum XYDimensionUnit
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XYDimensionUnit
C#
public enum XYDimensionUnit : Enum
Managed Extensions for C++
__value public enum XYDimensionUnit : public Enum
C++/CLI
public enum class XYDimensionUnit : public Enum

Members

Member | Description
Inch | Specifies the inch as the unit of measure.
Mil | Specifies the mil (1/1000 inch) as the unit of measure.
Millimeter | Specifies the millimeter as the unit of measure.
Pixel | Specifies the pixel as the unit of measure.
Point | Specifies a printer's point (1/72 inch) as the unit of measure.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.XYDimensionUnit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%ItemTitle%%

Barcode4NET Send comments on this topic.
O2S.Barcode4NET.Licensing Namespace (Barcode4NET)
See Also Inheritance Hierarchy

Classes

Class | Description
LicenseValidator | Defines a validator for license serial numbers.

See Also

Reference

Barcode4NET Assembly


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LicenseValidator Class
See Also Members
[image]
O2S.Barcode4NET.Licensing Namespace : LicenseValidator Class

Defines a validator for license serial numbers.

Syntax

Visual Basic (Declaration)
Private Class LicenseValidator
Visual Basic (Usage) Copy Code
Dim instance As LicenseValidator
C#
private class LicenseValidator
Managed Extensions for C++
private __gc class LicenseValidator
C++/CLI
private ref class LicenseValidator

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Licensing.LicenseValidator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValidator Members
O2S.Barcode4NET.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
LicenseValidator Class Members
See Also Methods
[image]
O2S.Barcode4NET.Licensing Namespace : LicenseValidator Class

The following tables list the members exposed by LicenseValidator.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetSerialNumber | Reads the serial number from the registry to give a default value to SerialNumber property.
static (Shared in Visual Basic) | ValidateSerialNumber | Validates a serial number based on a license file and a public key.
Top

See Also

Reference

LicenseValidator Class
O2S.Barcode4NET.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
LicenseValidator Class Methods
See Also
[image]
O2S.Barcode4NET.Licensing Namespace : LicenseValidator Class

For a list of all members of this type, see LicenseValidator members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetSerialNumber | Reads the serial number from the registry to give a default value to SerialNumber property.
static (Shared in Visual Basic) | ValidateSerialNumber | Validates a serial number based on a license file and a public key.
Top

See Also

Reference

LicenseValidator Class
O2S.Barcode4NET.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetSerialNumber Method
See Also
[image]
O2S.Barcode4NET.Licensing Namespace > LicenseValidator Class : GetSerialNumber Method

edition
The edition to lookup the serial number for.
version
Version to lookup the serial number for.
Reads the serial number from the registry to give a default value to SerialNumber property.

Syntax

Visual Basic (Declaration)
Public Shared Function GetSerialNumber( _
   ByVal edition As String, _
   ByVal version As String _
) As String
Visual Basic (Usage) Copy Code
Dim edition As String
Dim version As String
Dim value As String

value = LicenseValidator.GetSerialNumber(edition, version)
C#
public static string GetSerialNumber(
   string edition,
   string version
)
Managed Extensions for C++
public: static string* GetSerialNumber(
   string* edition,
   string* version
)
C++/CLI
public:
static String^ GetSerialNumber(
   String^ edition,
   String^ version
)

Parameters

edition
The edition to lookup the serial number for.
version
Version to lookup the serial number for.

Return Value

Serial number if exists, empty string otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValidator Class
LicenseValidator Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ValidateSerialNumber Method
See Also
[image]
O2S.Barcode4NET.Licensing Namespace > LicenseValidator Class : ValidateSerialNumber Method

serialNumber
Serial number to validate.
licenseResourceName
License file the serial number is validated against.
publicKeyResourceName
The public key for validating the serial number.
Validates a serial number based on a license file and a public key.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateSerialNumber( _
   ByVal serialNumber As String, _
   ByVal licenseResourceName As String, _
   ByVal publicKeyResourceName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim serialNumber As String
Dim licenseResourceName As String
Dim publicKeyResourceName As String
Dim value As Boolean

value = LicenseValidator.ValidateSerialNumber(serialNumber, licenseResourceName, publicKeyResourceName)
C#
public static bool ValidateSerialNumber(
   string serialNumber,
   string licenseResourceName,
   string publicKeyResourceName
)
Managed Extensions for C++
public: static bool ValidateSerialNumber(
   string* serialNumber,
   string* licenseResourceName,
   string* publicKeyResourceName
)
C++/CLI
public:
static bool ValidateSerialNumber(
   String^ serialNumber,
   String^ licenseResourceName,
   String^ publicKeyResourceName
)

Parameters

serialNumber
Serial number to validate.
licenseResourceName
License file the serial number is validated against.
publicKeyResourceName
The public key for validating the serial number.

Return Value

True if the serial number is valid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValidator Class
LicenseValidator Members


%%ItemTitle%%

Barcode4NET Send comments on this topic.
Xheo.Licensing Namespace (Barcode4NET)
See Also Inheritance Hierarchy

Classes

Class | Description
BigInteger | Implements an large integer of arbitrary length.
ContainerLimit | Serves as a base class for limits that contain other limits.
ExtendedLicense | Primary class for the XHEO|Licensing framework.
ExtendedLicenseException | Represents an exception in a Xheo assembly with a localized FriendlyMessage and DetailedMessage.
ExtendedLicensePack | Represents a collection of licenses stored in a single .LIC file.
LicenseSigningKey | Implements a key pair for signing licenses.
LicenseValuesCollection | Maintains a collection of name value pairs. The collection can be serialized and marked as read only.
Limit | Base class for all license limitations.
LimitCollection | Services as a collection of limits.
MachineProfile | Manages a machine profile used by the license activation system. Profiles represent a collection of generally non volitale system properties that can collectively be used to identify certain machines.
MachineProfile.Constants | A class to contain the constants required for the IP_ADAPTER_INFO struct
MachineProfile.GetAdapterInfo | Uses the windows API to retrieve information about the IP configuration of the local machine
StateEntry |
TransientReadOnlyCollection | Implements a transient read only collection. Values can be added, removed and changed until the SetReadOnly method is called thus forcing the collection to a read only state.

Structures

Structure | Description
LicenseSigningKey.KeyRecord |
MachineProfile._MEMORYSTATUS | Summary of _MEMORYSTATUS
MachineProfile._MEMORYSTATUSEX | Summary of _MEMORYSTATUSEX
MachineProfile.IP_ADAPTERINFO_STRUCTURE | declare the IP_ADAPTERINFO_STRUCTURE structure
MachineProfile.IP_ADDR_STRING | declare the IP_ADDR_STRING structure
MachineProfile.TGuid | Summary of TGuid

Enumerations

Enumeration | Description
PeekResult | Possible results from the Peek method.
SerialNumberSizes | Possible key sizes for use when generating serial numbers. More bits makes it more difficult to crack but also increase the size of the serial number.

See Also

Reference

Barcode4NET Assembly


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Class
See Also Members
[image]
Xheo.Licensing Namespace : BigInteger Class

Implements an large integer of arbitrary length.

Syntax

Visual Basic (Declaration)
Private Class BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
C#
private class BigInteger
Managed Extensions for C++
private __gc class BigInteger
C++/CLI
private ref class BigInteger

Inheritance Hierarchy

System.Object
Xheo.Licensing.BigInteger

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
BigInteger Class Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : BigInteger Class

The following tables list the members exposed by BigInteger.

Public Constructors

 | Name | Description
Public Constructor | BigInteger Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | dataLength |
static (Shared in Visual Basic) | primesBelow2000 |
Top

Public Methods

 | Name | Description
Public Method | abs |
Public Method | bitCount |
Public Method | Equals | Overridden.
Public Method | FermatLittleTest |
Public Method | gcd |
static (Shared in Visual Basic) | genPseudoPrime |
Public Method | genRandomBits |
Public Method | getBit |
Public Method | getBytes |
Public Method | GetHashCode | Overridden.
Public Method | IntValue |
Public Method | isProbablePrime | Overloaded.
static (Shared in Visual Basic) | Jacobi |
Public Method | LongValue |
static (Shared in Visual Basic) | LucasSequence |
Public Method | LucasStrongTest |
Public Method | min |
Public Method | modInverse |
Public Method | modPow |
Public Method | RabinMillerTest |
Public Method | setBit |
Public Method | sqrt |
Public Method | ToHexString |
Public Method | ToString | Overloaded. Overridden.
Public Method | ULongValue |
Public Method | unsetBit |
Top

Public Operators

Public Operator Addition |
Public Operator And |
Public Operator Or |
Public Operator Decrement |
Public Operator Division |
Public Operator Equality |
Public Operator Exclusive Or |
Public Operator Greater Than |
Public Operator Greater Than or Equal |
Public Operator Implicit Type Conversion | Overloaded.
Public Operator Increment |
Public Operator Inequality |
Public Operator Left-shift |
Public Operator Less Than |
Public Operator Less Than or Equal |
Public Operator Modulus |
Public Operator Multiplication |
Public Operator Bitwise Complement |
Public Operator Right-shift |
Public Operator Subtraction |
Public Operator Unary Negation |
Top

See Also

Reference

BigInteger Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Constructor
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : BigInteger Constructor

Overload List

Overload | Description
BigInteger Constructor() |
BigInteger Constructor(BigInteger) |
BigInteger Constructor(Byte[]) |
BigInteger Constructor(Byte[],Int32) |
BigInteger Constructor(Int64) |
BigInteger Constructor(String,Int32) |
BigInteger Constructor(UInt32[]) |
BigInteger Constructor(UInt64) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Constructor()
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BigInteger()
C#
public BigInteger()
Managed Extensions for C++
public: BigInteger();
C++/CLI
public:
BigInteger();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Constructor(BigInteger)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(BigInteger)

bi

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bi As BigInteger _
)
Visual Basic (Usage) Copy Code
Dim bi As BigInteger

Dim instance As BigInteger(bi)
C#
public BigInteger(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger(
   BigInteger* bi
)
C++/CLI
public:
BigInteger(
   BigInteger^ bi
)

Parameters

bi

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Constructor(Byte[])
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Byte[])

inData

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As Byte _
)
Visual Basic (Usage) Copy Code
Dim inData() As Byte

Dim instance As BigInteger(inData)
C#
public BigInteger(
   byte[] inData
)
Managed Extensions for C++
public: BigInteger(
   byte[] inData
)
C++/CLI
public:
BigInteger(
   array<byte> inData
)

Parameters

inData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Constructor(Byte[],Int32)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Byte[],Int32)

inData
inLen

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As Byte, _
   ByVal inLen As Integer _
)
Visual Basic (Usage) Copy Code
Dim inData() As Byte
Dim inLen As Integer

Dim instance As BigInteger(inData, inLen)
C#
public BigInteger(
   byte[] inData,
   int inLen
)
Managed Extensions for C++
public: BigInteger(
   byte[] inData,
   int inLen
)
C++/CLI
public:
BigInteger(
   array<byte> inData,
   int inLen
)

Parameters

inData
inLen

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Constructor(Int64)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Int64)

value

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim value As Long

Dim instance As BigInteger(value)
C#
public BigInteger(
   long value
)
Managed Extensions for C++
public: BigInteger(
   long value
)
C++/CLI
public:
BigInteger(
   long value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Constructor(String,Int32)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(String,Int32)

value
radix

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal radix As Integer _
)
Visual Basic (Usage) Copy Code
Dim value As String
Dim radix As Integer

Dim instance As BigInteger(value, radix)
C#
public BigInteger(
   string value,
   int radix
)
Managed Extensions for C++
public: BigInteger(
   string* value,
   int radix
)
C++/CLI
public:
BigInteger(
   String^ value,
   int radix
)

Parameters

value
radix

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Constructor(UInt32[])
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(UInt32[])

inData

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As UInteger _
)
Visual Basic (Usage) Copy Code
Dim inData() As UInteger

Dim instance As BigInteger(inData)
C#
public BigInteger(
   uint[] inData
)
Managed Extensions for C++
public: BigInteger(
   uint[] inData
)
C++/CLI
public:
BigInteger(
   array<uint> inData
)

Parameters

inData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
BigInteger Constructor(UInt64)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(UInt64)

value

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As ULong _
)
Visual Basic (Usage) Copy Code
Dim value As ULong

Dim instance As BigInteger(value)
C#
public BigInteger(
   ulong value
)
Managed Extensions for C++
public: BigInteger(
   ulong value
)
C++/CLI
public:
BigInteger(
   ulong value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
BigInteger Class Methods
See Also
[image]
Xheo.Licensing Namespace : BigInteger Class

For a list of all members of this type, see BigInteger members.

Public Methods

 | Name | Description
Public Method | abs |
Public Method | bitCount |
Public Method | Equals | Overridden.
Public Method | FermatLittleTest |
Public Method | gcd |
static (Shared in Visual Basic) | genPseudoPrime |
Public Method | genRandomBits |
Public Method | getBit |
Public Method | getBytes |
Public Method | GetHashCode | Overridden.
Public Method | IntValue |
Public Method | isProbablePrime | Overloaded.
static (Shared in Visual Basic) | Jacobi |
Public Method | LongValue |
static (Shared in Visual Basic) | LucasSequence |
Public Method | LucasStrongTest |
Public Method | min |
Public Method | modInverse |
Public Method | modPow |
Public Method | RabinMillerTest |
Public Method | setBit |
Public Method | sqrt |
Public Method | ToHexString |
Public Method | ToString | Overloaded. Overridden.
Public Method | ULongValue |
Public Method | unsetBit |
Top

See Also

Reference

BigInteger Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
abs Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : abs Method

Syntax

Visual Basic (Declaration)
Public Function abs() As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As BigInteger

value = instance.abs()
C#
public BigInteger abs()
Managed Extensions for C++
public: BigInteger* abs();
C++/CLI
public:
BigInteger^ abs();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
bitCount Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : bitCount Method

Syntax

Visual Basic (Declaration)
Public Function bitCount() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.bitCount()
C#
public int bitCount()
Managed Extensions for C++
public: int bitCount();
C++/CLI
public:
int bitCount();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Equals Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Equals Method

o

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal o As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim o As Object
Dim value As Boolean

value = instance.Equals(o)
C#
public override bool Equals(
   object o
)
Managed Extensions for C++
public: bool Equals(
   Object* o
) override
C++/CLI
public:
bool Equals(
   Object^ o
) override

Parameters

o

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
FermatLittleTest Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : FermatLittleTest Method

confidence

Syntax

Visual Basic (Declaration)
Public Function FermatLittleTest( _
   ByVal confidence As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim confidence As Integer
Dim value As Boolean

value = instance.FermatLittleTest(confidence)
C#
public bool FermatLittleTest(
   int confidence
)
Managed Extensions for C++
public: bool FermatLittleTest(
   int confidence
)
C++/CLI
public:
bool FermatLittleTest(
   int confidence
)

Parameters

confidence

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
gcd Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : gcd Method

bi

Syntax

Visual Basic (Declaration)
Public Function gcd( _
   ByVal bi As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bi As BigInteger
Dim value As BigInteger

value = instance.gcd(bi)
C#
public BigInteger gcd(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger* gcd(
   BigInteger* bi
)
C++/CLI
public:
BigInteger^ gcd(
   BigInteger^ bi
)

Parameters

bi

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
genPseudoPrime Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : genPseudoPrime Method

bits
confidence
rand

Syntax

Visual Basic (Declaration)
Public Shared Function genPseudoPrime( _
   ByVal bits As Integer, _
   ByVal confidence As Integer, _
   ByVal rand As RandomNumberGenerator _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim bits As Integer
Dim confidence As Integer
Dim rand As RandomNumberGenerator
Dim value As BigInteger

value = BigInteger.genPseudoPrime(bits, confidence, rand)
C#
public static BigInteger genPseudoPrime(
   int bits,
   int confidence,
   RandomNumberGenerator rand
)
Managed Extensions for C++
public: static BigInteger* genPseudoPrime(
   int bits,
   int confidence,
   RandomNumberGenerator* rand
)
C++/CLI
public:
static BigInteger^ genPseudoPrime(
   int bits,
   int confidence,
   RandomNumberGenerator^ rand
)

Parameters

bits
confidence
rand

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
genRandomBits Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : genRandomBits Method

bits
rand

Syntax

Visual Basic (Declaration)
Public Sub genRandomBits( _
   ByVal bits As Integer, _
   ByVal rand As RandomNumberGenerator _
)
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bits As Integer
Dim rand As RandomNumberGenerator

instance.genRandomBits(bits, rand)
C#
public void genRandomBits(
   int bits,
   RandomNumberGenerator rand
)
Managed Extensions for C++
public: void genRandomBits(
   int bits,
   RandomNumberGenerator* rand
)
C++/CLI
public:
void genRandomBits(
   int bits,
   RandomNumberGenerator^ rand
)

Parameters

bits
rand

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
getBit Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : getBit Method

bitNum

Syntax

Visual Basic (Declaration)
Public Function getBit( _
   ByVal bitNum As UInteger _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bitNum As UInteger
Dim value As Boolean

value = instance.getBit(bitNum)
C#
public bool getBit(
   uint bitNum
)
Managed Extensions for C++
public: bool getBit(
   uint bitNum
)
C++/CLI
public:
bool getBit(
   uint bitNum
)

Parameters

bitNum

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
getBytes Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : getBytes Method

Syntax

Visual Basic (Declaration)
Public Function getBytes() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value() As Byte

value = instance.getBytes()
C#
public byte[] getBytes()
Managed Extensions for C++
public: byte[] getBytes();
C++/CLI
public:
array<byte> getBytes();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetHashCode Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : GetHashCode Method

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IntValue Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : IntValue Method

Syntax

Visual Basic (Declaration)
Public Function IntValue() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.IntValue()
C#
public int IntValue()
Managed Extensions for C++
public: int IntValue();
C++/CLI
public:
int IntValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
isProbablePrime Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : isProbablePrime Method

Overload List

Overload | Description
isProbablePrime(Int32) |
isProbablePrime() |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
isProbablePrime(Int32) Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > isProbablePrime Method : isProbablePrime(Int32) Method

confidence

Syntax

Visual Basic (Declaration)
Overloads Public Function isProbablePrime( _
   ByVal confidence As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim confidence As Integer
Dim value As Boolean

value = instance.isProbablePrime(confidence)
C#
public bool isProbablePrime(
   int confidence
)
Managed Extensions for C++
public: bool isProbablePrime(
   int confidence
)
C++/CLI
public:
bool isProbablePrime(
   int confidence
)

Parameters

confidence

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
isProbablePrime() Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > isProbablePrime Method : isProbablePrime() Method

Syntax

Visual Basic (Declaration)
Overloads Public Function isProbablePrime() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Boolean

value = instance.isProbablePrime()
C#
public bool isProbablePrime()
Managed Extensions for C++
public: bool isProbablePrime();
C++/CLI
public:
bool isProbablePrime();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Jacobi Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Jacobi Method

a
b

Syntax

Visual Basic (Declaration)
Public Shared Function Jacobi( _
   ByVal a As BigInteger, _
   ByVal b As BigInteger _
) As Integer
Visual Basic (Usage) Copy Code
Dim a As BigInteger
Dim b As BigInteger
Dim value As Integer

value = BigInteger.Jacobi(a, b)
C#
public static int Jacobi(
   BigInteger a,
   BigInteger b
)
Managed Extensions for C++
public: static int Jacobi(
   BigInteger* a,
   BigInteger* b
)
C++/CLI
public:
static int Jacobi(
   BigInteger^ a,
   BigInteger^ b
)

Parameters

a
b

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LongValue Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : LongValue Method

Syntax

Visual Basic (Declaration)
Public Function LongValue() As Long
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Long

value = instance.LongValue()
C#
public long LongValue()
Managed Extensions for C++
public: long LongValue();
C++/CLI
public:
long LongValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LucasSequence Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : LucasSequence Method

P
Q
k
n

Syntax

Visual Basic (Declaration)
Public Shared Function LucasSequence( _
   ByVal P As BigInteger, _
   ByVal Q As BigInteger, _
   ByVal k As BigInteger, _
   ByVal n As BigInteger _
) As BigInteger()
Visual Basic (Usage) Copy Code
Dim P As BigInteger
Dim Q As BigInteger
Dim k As BigInteger
Dim n As BigInteger
Dim value() As BigInteger

value = BigInteger.LucasSequence(P, Q, k, n)
C#
public static BigInteger[] LucasSequence(
   BigInteger P,
   BigInteger Q,
   BigInteger k,
   BigInteger n
)
Managed Extensions for C++
public: static BigInteger*[] LucasSequence(
   BigInteger* P,
   BigInteger* Q,
   BigInteger* k,
   BigInteger* n
)
C++/CLI
public:
static array<BigInteger^> LucasSequence(
   BigInteger^ P,
   BigInteger^ Q,
   BigInteger^ k,
   BigInteger^ n
)

Parameters

P
Q
k
n

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LucasStrongTest Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : LucasStrongTest Method

Syntax

Visual Basic (Declaration)
Public Function LucasStrongTest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Boolean

value = instance.LucasStrongTest()
C#
public bool LucasStrongTest()
Managed Extensions for C++
public: bool LucasStrongTest();
C++/CLI
public:
bool LucasStrongTest();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
min Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : min Method

bi

Syntax

Visual Basic (Declaration)
Public Function min( _
   ByVal bi As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bi As BigInteger
Dim value As BigInteger

value = instance.min(bi)
C#
public BigInteger min(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger* min(
   BigInteger* bi
)
C++/CLI
public:
BigInteger^ min(
   BigInteger^ bi
)

Parameters

bi

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
modInverse Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : modInverse Method

modulus

Syntax

Visual Basic (Declaration)
Public Function modInverse( _
   ByVal modulus As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim modulus As BigInteger
Dim value As BigInteger

value = instance.modInverse(modulus)
C#
public BigInteger modInverse(
   BigInteger modulus
)
Managed Extensions for C++
public: BigInteger* modInverse(
   BigInteger* modulus
)
C++/CLI
public:
BigInteger^ modInverse(
   BigInteger^ modulus
)

Parameters

modulus

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
modPow Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : modPow Method

exp
n

Syntax

Visual Basic (Declaration)
Public Function modPow( _
   ByVal exp As BigInteger, _
   ByVal n As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim exp As BigInteger
Dim n As BigInteger
Dim value As BigInteger

value = instance.modPow(exp, n)
C#
public BigInteger modPow(
   BigInteger exp,
   BigInteger n
)
Managed Extensions for C++
public: BigInteger* modPow(
   BigInteger* exp,
   BigInteger* n
)
C++/CLI
public:
BigInteger^ modPow(
   BigInteger^ exp,
   BigInteger^ n
)

Parameters

exp
n

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
RabinMillerTest Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : RabinMillerTest Method

confidence

Syntax

Visual Basic (Declaration)
Public Function RabinMillerTest( _
   ByVal confidence As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim confidence As Integer
Dim value As Boolean

value = instance.RabinMillerTest(confidence)
C#
public bool RabinMillerTest(
   int confidence
)
Managed Extensions for C++
public: bool RabinMillerTest(
   int confidence
)
C++/CLI
public:
bool RabinMillerTest(
   int confidence
)

Parameters

confidence

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
setBit Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : setBit Method

bitNum

Syntax

Visual Basic (Declaration)
Public Sub setBit( _
   ByVal bitNum As UInteger _
)
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bitNum As UInteger

instance.setBit(bitNum)
C#
public void setBit(
   uint bitNum
)
Managed Extensions for C++
public: void setBit(
   uint bitNum
)
C++/CLI
public:
void setBit(
   uint bitNum
)

Parameters

bitNum

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
sqrt Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : sqrt Method

Syntax

Visual Basic (Declaration)
Public Function sqrt() As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As BigInteger

value = instance.sqrt()
C#
public BigInteger sqrt()
Managed Extensions for C++
public: BigInteger* sqrt();
C++/CLI
public:
BigInteger^ sqrt();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ToHexString Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : ToHexString Method

Syntax

Visual Basic (Declaration)
Public Function ToHexString() As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As String

value = instance.ToHexString()
C#
public string ToHexString()
Managed Extensions for C++
public: string* ToHexString();
C++/CLI
public:
String^ ToHexString();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ToString Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : ToString Method

Overload List

Overload | Description
ToString() |
ToString(Int32) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ToString() Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > ToString Method : ToString() Method

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ToString(Int32) Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > ToString Method : ToString(Int32) Method

radix

Syntax

Visual Basic (Declaration)
Overloads Public Function ToString( _
   ByVal radix As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim radix As Integer
Dim value As String

value = instance.ToString(radix)
C#
public string ToString(
   int radix
)
Managed Extensions for C++
public: string* ToString(
   int radix
)
C++/CLI
public:
String^ ToString(
   int radix
)

Parameters

radix

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ULongValue Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : ULongValue Method

Syntax

Visual Basic (Declaration)
Public Function ULongValue() As ULong
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As ULong

value = instance.ULongValue()
C#
public ulong ULongValue()
Managed Extensions for C++
public: ulong ULongValue();
C++/CLI
public:
ulong ULongValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
unsetBit Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : unsetBit Method

bitNum

Syntax

Visual Basic (Declaration)
Public Sub unsetBit( _
   ByVal bitNum As UInteger _
)
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bitNum As UInteger

instance.unsetBit(bitNum)
C#
public void unsetBit(
   uint bitNum
)
Managed Extensions for C++
public: void unsetBit(
   uint bitNum
)
C++/CLI
public:
void unsetBit(
   uint bitNum
)

Parameters

bitNum

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%% $$Fields$$

Barcode4NET Send comments on this topic.
BigInteger Class Fields
See Also
[image]
Xheo.Licensing Namespace : BigInteger Class

For a list of all members of this type, see BigInteger members.

Public Fields

 | Name | Description
Public Field | dataLength |
static (Shared in Visual Basic) | primesBelow2000 |
Top

See Also

Reference

BigInteger Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
dataLength Field
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : dataLength Field

Syntax

Visual Basic (Declaration)
Public dataLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.dataLength

instance.dataLength = value
C#
public int dataLength
Managed Extensions for C++
public: int dataLength
C++/CLI
public:
int dataLength

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
primesBelow2000 Field
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : primesBelow2000 Field

Syntax

Visual Basic (Declaration)
Public Shared primesBelow2000 As Integer()
Visual Basic (Usage) Copy Code
Dim value() As Integer

value = BigInteger.primesBelow2000

BigInteger.primesBelow2000 = value
C#
public static int[] primesBelow2000
Managed Extensions for C++
public: static int[] primesBelow2000
C++/CLI
public:
static array<int> primesBelow2000

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Addition Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Addition Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator +(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Addition(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator +(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
And Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : And Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator And( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator &(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_BitwiseAnd(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator &(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Or Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Or Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator Or( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator |(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_BitwiseOr(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator |(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Decrement Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Decrement Operator

bi1

Syntax

Visual Basic (Declaration)
This operator type is not supported by Visual Basic
C#
public BigInteger operator --(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_Decrement(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator --(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Division Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Division Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator /( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator /(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Division(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator /(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Equality Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Equality Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator ==(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_Equality(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator ==(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Exclusive Or Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Exclusive Or Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator Xor( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator ^(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_ExclusiveOr(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator ^(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Greater Than Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Greater Than Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator >(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_GreaterThan(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator >(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Greater Than or Equal Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Greater Than or Equal Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator >=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_GreaterThanOrEqual(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator >=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Implicit Type Conversion Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Implicit Type Conversion Operator

Overload List

Overload | Description
Implicit Type Conversion(Int32) |
Implicit Type Conversion(Int64) |
Implicit Type Conversion(UInt32) |
Implicit Type Conversion(UInt64) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Increment Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Increment Operator

bi1

Syntax

Visual Basic (Declaration)
This operator type is not supported by Visual Basic
C#
public BigInteger operator ++(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_Increment(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator ++(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Inequality Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Inequality Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator !=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_Inequality(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator !=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Left-shift Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Left-shift Operator

bi1
shiftVal

Syntax

Visual Basic (Declaration)
Public Operator <<( _
   ByVal bi1 As BigInteger, _
   ByVal shiftVal As Integer _
) As BigInteger
C#
public BigInteger operator <<(
   BigInteger bi1,
   int shiftVal
)
Managed Extensions for C++
public: BigInteger* op_LeftShift(
   BigInteger* bi1,
   int shiftVal
)
C++/CLI
public:
BigInteger^ operator <<(
   BigInteger^ bi1,
   int shiftVal
)

Parameters

bi1
shiftVal

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Less Than Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Less Than Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator <(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_LessThan(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator <(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Less Than or Equal Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Less Than or Equal Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator <=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_LessThanOrEqual(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator <=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Modulus Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Modulus Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator Mod( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator %(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Modulus(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator %(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Multiplication Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Multiplication Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator *( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator *(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Multiply(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator *(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Bitwise Complement Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Bitwise Complement Operator

bi1

Syntax

Visual Basic (Declaration)
Public Operator Not( _
   ByVal bi1 As BigInteger _
) As BigInteger
C#
public BigInteger operator ~(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_OnesComplement(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator ~(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Right-shift Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Right-shift Operator

bi1
shiftVal

Syntax

Visual Basic (Declaration)
Public Operator >>( _
   ByVal bi1 As BigInteger, _
   ByVal shiftVal As Integer _
) As BigInteger
C#
public BigInteger operator >>(
   BigInteger bi1,
   int shiftVal
)
Managed Extensions for C++
public: BigInteger* op_RightShift(
   BigInteger* bi1,
   int shiftVal
)
C++/CLI
public:
BigInteger^ operator >>(
   BigInteger^ bi1,
   int shiftVal
)

Parameters

bi1
shiftVal

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Subtraction Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Subtraction Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator -(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Subtraction(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator -(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Unary Negation Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Unary Negation Operator

bi1

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal bi1 As BigInteger _
) As BigInteger
C#
public BigInteger operator -(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_UnaryNegation(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator -(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ContainerLimit Class
See Also Members
[image]
Xheo.Licensing Namespace : ContainerLimit Class

Serves as a base class for limits that contain other limits.

Object Model

Syntax

Visual Basic (Declaration)
Private MustInherit Class ContainerLimit
   Inherits Limit
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
C#
private abstract class ContainerLimit : Limit
Managed Extensions for C++
private __gc abstract class ContainerLimit : public Limit
C++/CLI
private ref class ContainerLimit abstract : public Limit

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Xheo.Licensing.Limit
Xheo.Licensing.ContainerLimit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
ContainerLimit Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : ContainerLimit Class

The following tables list the members exposed by ContainerLimit.

Public Properties

 | Name | Description
Public Property | Description | Gets the description of the limit. (Inherited from Limit)
Public Property | IsGui | Overridden. Gets a value that indicates if the limit may use a GUI interface.
Public Property | IsRemote | Overridden. Gets a value that indicates if the limit may use remote resources.
Public Property | IsTimeSensitive | Overridden. Determines if any contained limits are time sensitive.
Public Property | License | Gets or sets a reference to the ExtendedLicense that contains this Limit. (Inherited from Limit)
Public Property | Limits | Gets the collection of child limits.
Public Property | Name | Gets the display name of the limit. (Inherited from Limit)
Public Property | QualifiedTypeName | Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type. (Inherited from Limit)
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases any managed or unmanged resources. (Inherited from Limit)
Public Method | GetDetailsDescription | Gets a description of the details of the limit. (Inherited from Limit)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Granted | Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created. (Inherited from Limit)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | LoadFromXml | Overridden. Loads the contents of a Limit from an XmlNode.
Public Method | Peek | Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user. (Inherited from Limit)
Public Method | SaveToXml | Overridden. Saves the contents of the Limit as an XmlNode.
Public Method | Validate | Validates that the license being granted is within the limits enforced by this object. (Inherited from Limit)
Top

See Also

Reference

ContainerLimit Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
ContainerLimit Class Methods
See Also
[image]
Xheo.Licensing Namespace : ContainerLimit Class

For a list of all members of this type, see ContainerLimit members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases any managed or unmanged resources. (Inherited from Limit)
Public Method | GetDetailsDescription | Gets a description of the details of the limit. (Inherited from Limit)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Granted | Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created. (Inherited from Limit)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | LoadFromXml | Overridden. Loads the contents of a Limit from an XmlNode.
Public Method | Peek | Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user. (Inherited from Limit)
Public Method | SaveToXml | Overridden. Saves the contents of the Limit as an XmlNode.
Public Method | Validate | Validates that the license being granted is within the limits enforced by this object. (Inherited from Limit)
Top

See Also

Reference

ContainerLimit Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : LoadFromXml Method

node
The XmlNode to load from.
Loads the contents of a Limit from an XmlNode.

Syntax

Visual Basic (Declaration)
Overrides Public Function LoadFromXml( _
   ByVal node As XmlNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim node As XmlNode
Dim value As Boolean

value = instance.LoadFromXml(node)
C#
public override bool LoadFromXml(
   XmlNode node
)
Managed Extensions for C++
public: bool LoadFromXml(
   XmlNode node
) override
C++/CLI
public:
bool LoadFromXml(
   XmlNode node
) override

Parameters

node
The XmlNode to load from.

Return Value

Returns true if the load was successful, otherwise false.
Returns true if the load was successful, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : SaveToXml Method

parent
The parent node to save to.
Saves the contents of the Limit as an XmlNode.

Syntax

Visual Basic (Declaration)
Overrides Public Function SaveToXml( _
   ByVal parent As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim parent As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parent)
C#
public override XmlNode SaveToXml(
   XmlNode parent
)
Managed Extensions for C++
public: XmlNode SaveToXml(
   XmlNode parent
) override
C++/CLI
public:
XmlNode SaveToXml(
   XmlNode parent
) override

Parameters

parent
The parent node to save to.

Return Value

Returns the saved XmlNode.
Returns the saved XmlNode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
ContainerLimit Class Properties
See Also
[image]
Xheo.Licensing Namespace : ContainerLimit Class

For a list of all members of this type, see ContainerLimit members.

Public Properties

 | Name | Description
Public Property | Description | Gets the description of the limit. (Inherited from Limit)
Public Property | IsGui | Overridden. Gets a value that indicates if the limit may use a GUI interface.
Public Property | IsRemote | Overridden. Gets a value that indicates if the limit may use remote resources.
Public Property | IsTimeSensitive | Overridden. Determines if any contained limits are time sensitive.
Public Property | License | Gets or sets a reference to the ExtendedLicense that contains this Limit. (Inherited from Limit)
Public Property | Limits | Gets the collection of child limits.
Public Property | Name | Gets the display name of the limit. (Inherited from Limit)
Public Property | QualifiedTypeName | Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type. (Inherited from Limit)
Top

See Also

Reference

ContainerLimit Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsGui Property
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : IsGui Property

Gets a value that indicates if the limit may use a GUI interface.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property IsGui As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim value As Boolean

value = instance.IsGui
C#
public override bool IsGui {get;}
Managed Extensions for C++
public: __property bool get_IsGui()override ;
C++/CLI
public:
property bool IsGui override {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsRemote Property
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : IsRemote Property

Gets a value that indicates if the limit may use remote resources.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property IsRemote As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim value As Boolean

value = instance.IsRemote
C#
public override bool IsRemote {get;}
Managed Extensions for C++
public: __property bool get_IsRemote()override ;
C++/CLI
public:
property bool IsRemote override {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsTimeSensitive Property
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : IsTimeSensitive Property

Determines if any contained limits are time sensitive.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property IsTimeSensitive As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim value As Boolean

value = instance.IsTimeSensitive
C#
public override bool IsTimeSensitive {get;}
Managed Extensions for C++
public: __property bool get_IsTimeSensitive()override ;
C++/CLI
public:
property bool IsTimeSensitive override {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Limits Property
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : Limits Property

Gets the collection of child limits.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Limits As LimitCollection
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim value As LimitCollection

value = instance.Limits
C#
public LimitCollection Limits {get;}
Managed Extensions for C++
public: __property LimitCollection* get_Limits();
C++/CLI
public:
property LimitCollection^ Limits {
   LimitCollection^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ExtendedLicense Class
See Also Members
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

Primary class for the XHEO|Licensing framework.

Object Model

Syntax

Visual Basic (Declaration)
Private NotInheritable Class ExtendedLicense
   Inherits License
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
C#
private sealed class ExtendedLicense : License
Managed Extensions for C++
private __gc __sealed class ExtendedLicense : public License
C++/CLI
private ref class ExtendedLicense sealed : public License

Remarks

Each Type in an assembly can be protected by XHEO|Licensing. The environment that the Type is allowed to run in, is defined by a collection of Limit instances defined for the license. For instance the license may limit a component for use on a computer with a specific IP address. These limits are implemented and enforced by subclasses of the Limit class.

To ensure that the license files have not been altered since they were issued, each ExtendedLicense is signed with a LicenseSigningKey. The signing key uses a public key encryption method (See Cryptography) with the public key embedded in the assembly that the component is implemented in. The private key remains secured with the original developers ensuring that only they can grant valid licenses.

Inheritance Hierarchy

System.Object
System.ComponentModel.License
Xheo.Licensing.ExtendedLicense

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Members
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
ExtendedLicense Class Members
See Also Fields Properties Methods
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

The following tables list the members exposed by ExtendedLicense.

Public Constructors

 | Name | Description
Public Constructor | ExtendedLicense Constructor | Overloaded. Initializes a new instance of the ExtendedLicense class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ConfigSection | The configuration section where XHEO|Licensing settings are stored in the application's configuration file.
static (Shared in Visual Basic) | CurrentVersion | The current license scheme file version.
Top

Public Properties

 | Name | Description
Public Property | AbsoluteOrganization | Gets or sets the name of the organization that the license is issued to.
Public Property | AbsoluteSerialNumber | Gets or sets the serial number for the license.
Public Property | AbsoluteUser | Gets or sets the name of the user that the license is issued to.
Public Property | AcceptedSerialNumberSizes | Gets or sets the serial number sizes that can be used to unlock the license. If a valid serial number of a different size is used, license validation will fail.
Public Property | AssemblyName | Gets or sets the name of the assembly used to sign the license originally. The value of this property is for reference only and has no impact on the validation of a license.
Public Property | Components | Gets the collection of component names that the license applies to.
static (Shared in Visual Basic) | ConnectionString | Gets the default database connection string for licensing components.
static (Shared in Visual Basic) | EmulateVersion | Gets a value that determines the release version that XHEO|Licensing should emulate.
Public Property | Expires | Gets or sets the expiration date for the license.
static (Shared in Visual Basic) | IisIsAvailable | Gets a value that indicates if IIS is installed and available on the machine. If false then HttpContext should not be checked because it will throw an exception.
Public Property | InvalidReason | Gets or sets the reason the license was not valid. If Validate returns true this is an empty string.
Public Property | IsEmbedded | Gets or sets a value that indicates if the license was loaded from an embedded resource rather then an external .LIC file.
Public Property | IsReadOnly | Gets a value that indicates if the current license is read only.
Public Property | IssuerUrl | Gets or sets the URL to the company that issued the license.
static (Shared in Visual Basic) | IsTerminalServices | Gets a value that indicates if the current session is running under terminal services.
Public Property | IsTimeSensitive | Gets a value that indicates if the license contians time sensitive data and the clock should be protected.
static (Shared in Visual Basic) | IsWebRequest | Gets a value indicating if a web request/HttpContext is currently available.
static (Shared in Visual Basic) | KeyFolder | Gets the folder where the license keys are located as defined in the application's config file.
Public Property | LicensedType | Gets the Type the license was/will be granted to.
static (Shared in Visual Basic) | LicenseFolders | Gets a collection of folders where the licenses are located as defined in the application's config file.
Public Property | LicenseKey | Overridden. Overrides LicenseKey.
Public Property | LicensePack | Gets the ExtendedLicensePack that owns the license.
Public Property | MaximumSerialNumberSeed | Gets or sets the maximum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.
Public Property | MetaValues | Gets a collection of arbitrary values to store with the license. These values are not protected and may be changed without affecting the validity of the license. Use for storing volitle information and other unsecured information.
Public Property | MinimumSerialNumberSeed | Gets or sets the minimum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.
Public Property | Organization | Gets or sets the name of the organization that the license is issued to.
Public Property | PersistantState | Gets a reference to per-license specific state that works independent of any underlying state schemes. This is used to safely track values that should be kept in memory even when a license is reloaded from disk.
Public Property | PublicKey | Gets a reference to the LicenseSigningKey being used to validate the license.
Public Property | SerialNumber | Gets or sets the value of the absolute serial number.
static (Shared in Visual Basic) | SharedFolder | Gets or sets the path to the shared license folder.
Public Property | Signature | Gets or sets the signature used to validate the license data.
Public Property | SurrogateLicensePack | Gets or sets a surrogate license pack to use if validation of this license fails.
Public Property | Tag | Gets or sets an arbitrary piece of data to track with the license. This is a "cheap" way of extending the license scheme by allowing you to store any kind of additional data that can be saved as a string to the license.
static (Shared in Visual Basic) | TemplateFolder | Gets the folder where the license templates are located as defined in the application's config file.
Public Property | Type | Gets or sets an application/product specific description of the type of license. For examples "designer", "single user", "non-profit", etc. This can often be used a reference to the primary key in a database, such as a SKU, for the product that the license represents.
Public Property | UnlockBySerial | Gets or sets a value that indicates if the user must provide a valid serial number to fully unlock the license.
Public Property | UnlockedLicense | Gets or sets the ExtendedLicense that was unlocked by the registration process.
Public Property | User | Gets or sets the value of the user as it should appear on screen.
Public Property | Values | Gets a collection of arbitrary values to store with the license.
Public Property | Version | Gets or sets the version of the licensing scheme used.
Public Property | XmlString | Gets or sets the contents of the license as an XML string fragment.
Top

Public Methods

 | Name | Description
Public Method | ComponentsFromString | Fills the components collection from a comma separated list.
Public Method | ComponentsToString | Gets the components collection as a comma separated list.
Public Method | Dispose | Releases any managed or unmanaged resources.
static (Shared in Visual Basic) | FromXml | Overloaded. Creates a new ExtendedLicense from an XML fragment.
Public Method | FromXmlString | Loads the contents of the license from an XML string.
static (Shared in Visual Basic) | GetFullPath | Utility function that gets the full path of a folder relative to the "application root" of the current application.
Public Method | GetShortAssemblyName | Gets the short name of the assembly. If the AssemblyName property contains version and key information, only the assembly name is returned.
Public Method | GetSigningKey | Overloaded. Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.
Public Method | GetValue | Gets the first value from the Values collection with the given key and if not found returns the default value instead.
Public Method | LoadFromXml | Loads the contents of a license from an XmlNode.
Public Method | SaveToXml | Saves the contents of the ExtendedLicense to the given XmlNode.
Public Method | ToXmlString | Saves the contents of the license to an XML string.
Top

See Also

Reference

ExtendedLicense Class
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ExtendedLicense Constructor
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ExtendedLicense Constructor

Initializes a new instance of the ExtendedLicense class.

Overload List

Overload | Description
ExtendedLicense Constructor() | Initializes a new instance of the ExtendedLicense class.
ExtendedLicense Constructor(XmlNode) | Initializes a new instance of the ExtendedLicense class with the values of the given XmlNode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ExtendedLicense Constructor()
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > ExtendedLicense Constructor : ExtendedLicense Constructor()

Initializes a new instance of the ExtendedLicense class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense()
C#
public ExtendedLicense()
Managed Extensions for C++
public: ExtendedLicense();
C++/CLI
public:
ExtendedLicense();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ExtendedLicense Constructor(XmlNode)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > ExtendedLicense Constructor : ExtendedLicense Constructor(XmlNode)

node
The XmlNode of the ExtendedLicensePack to load the license properties from.
Initializes a new instance of the ExtendedLicense class with the values of the given XmlNode.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal node As XmlNode _
)
Visual Basic (Usage) Copy Code
Dim node As XmlNode

Dim instance As ExtendedLicense(node)
C#
public ExtendedLicense(
   XmlNode node
)
Managed Extensions for C++
public: ExtendedLicense(
   XmlNode node
)
C++/CLI
public:
ExtendedLicense(
   XmlNode node
)

Parameters

node
The XmlNode of the ExtendedLicensePack to load the license properties from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
ExtendedLicense Class Methods
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

For a list of all members of this type, see ExtendedLicense members.

Public Methods

 | Name | Description
Public Method | ComponentsFromString | Fills the components collection from a comma separated list.
Public Method | ComponentsToString | Gets the components collection as a comma separated list.
Public Method | Dispose | Releases any managed or unmanaged resources.
static (Shared in Visual Basic) | FromXml | Overloaded. Creates a new ExtendedLicense from an XML fragment.
Public Method | FromXmlString | Loads the contents of the license from an XML string.
static (Shared in Visual Basic) | GetFullPath | Utility function that gets the full path of a folder relative to the "application root" of the current application.
Public Method | GetShortAssemblyName | Gets the short name of the assembly. If the AssemblyName property contains version and key information, only the assembly name is returned.
Public Method | GetSigningKey | Overloaded. Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.
Public Method | GetValue | Gets the first value from the Values collection with the given key and if not found returns the default value instead.
Public Method | LoadFromXml | Loads the contents of a license from an XmlNode.
Public Method | SaveToXml | Saves the contents of the ExtendedLicense to the given XmlNode.
Public Method | ToXmlString | Saves the contents of the license to an XML string.
Top

See Also

Reference

ExtendedLicense Class
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ComponentsFromString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ComponentsFromString Method

components
Comma separated list of components.
Fills the components collection from a comma separated list.

Syntax

Visual Basic (Declaration)
Public Sub ComponentsFromString( _
   ByVal components As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim components As String

instance.ComponentsFromString(components)
C#
public void ComponentsFromString(
   string components
)
Managed Extensions for C++
public: void ComponentsFromString(
   string* components
)
C++/CLI
public:
void ComponentsFromString(
   String^ components
)

Parameters

components
Comma separated list of components.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ComponentsToString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ComponentsToString Method

Gets the components collection as a comma separated list.

Syntax

Visual Basic (Declaration)
Public Function ComponentsToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

value = instance.ComponentsToString()
C#
public string ComponentsToString()
Managed Extensions for C++
public: string* ComponentsToString();
C++/CLI
public:
String^ ComponentsToString();

Return Value

Returns the list of components.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Dispose Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Dispose Method

Releases any managed or unmanaged resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
FromXml Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : FromXml Method

Creates a new ExtendedLicense from an XML fragment.

Overload List

Overload | Description
FromXml(String) | Creates a new ExtendedLicense from an XML fragment.
FromXml(XmlNode) | Creates a new ExtendedLicense from an XML fragment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
FromXml(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > FromXml Method : FromXml(String) Method

xml
The xml to create the license from.
Creates a new ExtendedLicense from an XML fragment.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromXml( _
   ByVal xml As String _
) As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim xml As String
Dim value As ExtendedLicense

value = ExtendedLicense.FromXml(xml)
C#
public static ExtendedLicense FromXml(
   string xml
)
Managed Extensions for C++
public: static ExtendedLicense* FromXml(
   string* xml
)
C++/CLI
public:
static ExtendedLicense^ FromXml(
   String^ xml
)

Parameters

xml
The xml to create the license from.

Return Value

Returns the newly created extended license.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
FromXml(XmlNode) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > FromXml Method : FromXml(XmlNode) Method

xml
The xml to create the license from.
Creates a new ExtendedLicense from an XML fragment.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromXml( _
   ByVal xml As XmlNode _
) As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim xml As XmlNode
Dim value As ExtendedLicense

value = ExtendedLicense.FromXml(xml)
C#
public static ExtendedLicense FromXml(
   XmlNode xml
)
Managed Extensions for C++
public: static ExtendedLicense* FromXml(
   XmlNode xml
)
C++/CLI
public:
static ExtendedLicense^ FromXml(
   XmlNode xml
)

Parameters

xml
The xml to create the license from.

Return Value

Returns the newly created extended license.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : FromXmlString Method

xml
The XML string to load from.
Loads the contents of the license from an XML string.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
The XML string to load from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetFullPath Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : GetFullPath Method

path
The path to resolve to a complete path.
Utility function that gets the full path of a folder relative to the "application root" of the current application.

Syntax

Visual Basic (Declaration)
Public Shared Function GetFullPath( _
   ByVal path As String _
) As String
Visual Basic (Usage) Copy Code
Dim path As String
Dim value As String

value = ExtendedLicense.GetFullPath(path)
C#
public static string GetFullPath(
   string path
)
Managed Extensions for C++
public: static string* GetFullPath(
   string* path
)
C++/CLI
public:
static String^ GetFullPath(
   String^ path
)

Parameters

path
The path to resolve to a complete path.

Remarks

For console and forms applications the base folder is the folder of the entry executable. For Web sites the base folder is the root of the site...rather than the \bin folder.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetShortAssemblyName Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : GetShortAssemblyName Method

Gets the short name of the assembly. If the AssemblyName property contains version and key information, only the assembly name is returned.

Syntax

Visual Basic (Declaration)
Public Function GetShortAssemblyName() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

value = instance.GetShortAssemblyName()
C#
public string GetShortAssemblyName()
Managed Extensions for C++
public: string* GetShortAssemblyName();
C++/CLI
public:
String^ GetShortAssemblyName();

Return Value

Returns the short version of the AssemblyName if set, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetSigningKey Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : GetSigningKey Method

Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.

Overload List

Overload | Description
GetSigningKey(String) | Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.
GetSigningKey() | Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetSigningKey(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > GetSigningKey Method : GetSigningKey(String) Method

folder
The folder to look for keys. If null KeyFolder is used.
Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetSigningKey( _
   ByVal folder As String _
) As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim folder As String
Dim value As LicenseSigningKey

value = instance.GetSigningKey(folder)
C#
public LicenseSigningKey GetSigningKey(
   string folder
)
Managed Extensions for C++
public: LicenseSigningKey* GetSigningKey(
   string* folder
)
C++/CLI
public:
LicenseSigningKey^ GetSigningKey(
   String^ folder
)

Parameters

folder
The folder to look for keys. If null KeyFolder is used.

Return Value

Returns the key needed to sign the license if found, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetSigningKey() Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > GetSigningKey Method : GetSigningKey() Method

Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetSigningKey() As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As LicenseSigningKey

value = instance.GetSigningKey()
C#
public LicenseSigningKey GetSigningKey()
Managed Extensions for C++
public: LicenseSigningKey* GetSigningKey();
C++/CLI
public:
LicenseSigningKey^ GetSigningKey();

Return Value

Returns the key needed to sign the license if found, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetValue Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : GetValue Method

key
The key of the value to return.
defaultValue
The default value if not found.
Gets the first value from the Values collection with the given key and if not found returns the default value instead.

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal key As String, _
   ByVal defaultValue As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim key As String
Dim defaultValue As String
Dim value As String

value = instance.GetValue(key, defaultValue)
C#
public string GetValue(
   string key,
   string defaultValue
)
Managed Extensions for C++
public: string* GetValue(
   string* key,
   string* defaultValue
)
C++/CLI
public:
String^ GetValue(
   String^ key,
   String^ defaultValue
)

Parameters

key
The key of the value to return.
defaultValue
The default value if not found.

Return Value

Returns the first value with the given key if found, otherwise the default value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LoadFromXml Method

node
An XmlNode containing the license data.
Loads the contents of a license from an XmlNode.

Syntax

Visual Basic (Declaration)
Public Function LoadFromXml( _
   ByVal node As XmlNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim node As XmlNode
Dim value As Boolean

value = instance.LoadFromXml(node)
C#
public bool LoadFromXml(
   XmlNode node
)
Managed Extensions for C++
public: bool LoadFromXml(
   XmlNode node
)
C++/CLI
public:
bool LoadFromXml(
   XmlNode node
)

Parameters

node
An XmlNode containing the license data.

Return Value

Returns true if the load was successful, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : SaveToXml Method

parent
The parent XmlNode.
Saves the contents of the ExtendedLicense to the given XmlNode.

Syntax

Visual Basic (Declaration)
Public Function SaveToXml( _
   ByVal parent As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim parent As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parent)
C#
public XmlNode SaveToXml(
   XmlNode parent
)
Managed Extensions for C++
public: XmlNode SaveToXml(
   XmlNode parent
)
C++/CLI
public:
XmlNode SaveToXml(
   XmlNode parent
)

Parameters

parent
The parent XmlNode.

Return Value

Returns the root node of the saved license.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ToXmlString Method

Saves the contents of the license to an XML string.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

value = instance.ToXmlString()
C#
public string ToXmlString()
Managed Extensions for C++
public: string* ToXmlString();
C++/CLI
public:
String^ ToXmlString();

Return Value

The saved XML.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
ExtendedLicense Class Properties
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

For a list of all members of this type, see ExtendedLicense members.

Public Properties

 | Name | Description
Public Property | AbsoluteOrganization | Gets or sets the name of the organization that the license is issued to.
Public Property | AbsoluteSerialNumber | Gets or sets the serial number for the license.
Public Property | AbsoluteUser | Gets or sets the name of the user that the license is issued to.
Public Property | AcceptedSerialNumberSizes | Gets or sets the serial number sizes that can be used to unlock the license. If a valid serial number of a different size is used, license validation will fail.
Public Property | AssemblyName | Gets or sets the name of the assembly used to sign the license originally. The value of this property is for reference only and has no impact on the validation of a license.
Public Property | Components | Gets the collection of component names that the license applies to.
static (Shared in Visual Basic) | ConnectionString | Gets the default database connection string for licensing components.
static (Shared in Visual Basic) | EmulateVersion | Gets a value that determines the release version that XHEO|Licensing should emulate.
Public Property | Expires | Gets or sets the expiration date for the license.
static (Shared in Visual Basic) | IisIsAvailable | Gets a value that indicates if IIS is installed and available on the machine. If false then HttpContext should not be checked because it will throw an exception.
Public Property | InvalidReason | Gets or sets the reason the license was not valid. If Validate returns true this is an empty string.
Public Property | IsEmbedded | Gets or sets a value that indicates if the license was loaded from an embedded resource rather then an external .LIC file.
Public Property | IsReadOnly | Gets a value that indicates if the current license is read only.
Public Property | IssuerUrl | Gets or sets the URL to the company that issued the license.
static (Shared in Visual Basic) | IsTerminalServices | Gets a value that indicates if the current session is running under terminal services.
Public Property | IsTimeSensitive | Gets a value that indicates if the license contians time sensitive data and the clock should be protected.
static (Shared in Visual Basic) | IsWebRequest | Gets a value indicating if a web request/HttpContext is currently available.
static (Shared in Visual Basic) | KeyFolder | Gets the folder where the license keys are located as defined in the application's config file.
Public Property | LicensedType | Gets the Type the license was/will be granted to.
static (Shared in Visual Basic) | LicenseFolders | Gets a collection of folders where the licenses are located as defined in the application's config file.
Public Property | LicenseKey | Overridden. Overrides LicenseKey.
Public Property | LicensePack | Gets the ExtendedLicensePack that owns the license.
Public Property | MaximumSerialNumberSeed | Gets or sets the maximum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.
Public Property | MetaValues | Gets a collection of arbitrary values to store with the license. These values are not protected and may be changed without affecting the validity of the license. Use for storing volitle information and other unsecured information.
Public Property | MinimumSerialNumberSeed | Gets or sets the minimum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.
Public Property | Organization | Gets or sets the name of the organization that the license is issued to.
Public Property | PersistantState | Gets a reference to per-license specific state that works independent of any underlying state schemes. This is used to safely track values that should be kept in memory even when a license is reloaded from disk.
Public Property | PublicKey | Gets a reference to the LicenseSigningKey being used to validate the license.
Public Property | SerialNumber | Gets or sets the value of the absolute serial number.
static (Shared in Visual Basic) | SharedFolder | Gets or sets the path to the shared license folder.
Public Property | Signature | Gets or sets the signature used to validate the license data.
Public Property | SurrogateLicensePack | Gets or sets a surrogate license pack to use if validation of this license fails.
Public Property | Tag | Gets or sets an arbitrary piece of data to track with the license. This is a "cheap" way of extending the license scheme by allowing you to store any kind of additional data that can be saved as a string to the license.
static (Shared in Visual Basic) | TemplateFolder | Gets the folder where the license templates are located as defined in the application's config file.
Public Property | Type | Gets or sets an application/product specific description of the type of license. For examples "designer", "single user", "non-profit", etc. This can often be used a reference to the primary key in a database, such as a SKU, for the product that the license represents.
Public Property | UnlockBySerial | Gets or sets a value that indicates if the user must provide a valid serial number to fully unlock the license.
Public Property | UnlockedLicense | Gets or sets the ExtendedLicense that was unlocked by the registration process.
Public Property | User | Gets or sets the value of the user as it should appear on screen.
Public Property | Values | Gets a collection of arbitrary values to store with the license.
Public Property | Version | Gets or sets the version of the licensing scheme used.
Public Property | XmlString | Gets or sets the contents of the license as an XML string fragment.
Top

See Also

Reference

ExtendedLicense Class
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
AbsoluteOrganization Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AbsoluteOrganization Property

Gets or sets the name of the organization that the license is issued to.

Syntax

Visual Basic (Declaration)
Public Property AbsoluteOrganization As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.AbsoluteOrganization = value

value = instance.AbsoluteOrganization
C#
public string AbsoluteOrganization {get; set;}
Managed Extensions for C++
public: __property string* get_AbsoluteOrganization();
public: __property void set_AbsoluteOrganization(
   string* value
);
C++/CLI
public:
property String^ AbsoluteOrganization {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
AbsoluteSerialNumber Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AbsoluteSerialNumber Property

Gets or sets the serial number for the license.

Syntax

Visual Basic (Declaration)
Public Property AbsoluteSerialNumber As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.AbsoluteSerialNumber = value

value = instance.AbsoluteSerialNumber
C#
public string AbsoluteSerialNumber {get; set;}
Managed Extensions for C++
public: __property string* get_AbsoluteSerialNumber();
public: __property void set_AbsoluteSerialNumber(
   string* value
);
C++/CLI
public:
property String^ AbsoluteSerialNumber {
   String^ get();
   void set (String^ value);
}

Remarks

Generally the value of the serial number property is completely arbitrary and can contain any value. However the values should be treated as a primary key that uniquely identifies the license. Generally this is used to reference licenses in a back-end system and to uniquely identify the license.

By default a random GUID is generated for the serial number. You can later change it to any desired value.

(Version 1.2+) When using Unlock by Serial to unlock licenses, the Absolute Serial Number is used to match user's serial numbers to licenses.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
AbsoluteUser Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AbsoluteUser Property

Gets or sets the name of the user that the license is issued to.

Syntax

Visual Basic (Declaration)
Public Property AbsoluteUser As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.AbsoluteUser = value

value = instance.AbsoluteUser
C#
public string AbsoluteUser {get; set;}
Managed Extensions for C++
public: __property string* get_AbsoluteUser();
public: __property void set_AbsoluteUser(
   string* value
);
C++/CLI
public:
property String^ AbsoluteUser {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
AcceptedSerialNumberSizes Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AcceptedSerialNumberSizes Property

Gets or sets the serial number sizes that can be used to unlock the license. If a valid serial number of a different size is used, license validation will fail.

Syntax

Visual Basic (Declaration)
Public Property AcceptedSerialNumberSizes As SerialNumberSizes
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As SerialNumberSizes

instance.AcceptedSerialNumberSizes = value

value = instance.AcceptedSerialNumberSizes
C#
public SerialNumberSizes AcceptedSerialNumberSizes {get; set;}
Managed Extensions for C++
public: __property SerialNumberSizes get_AcceptedSerialNumberSizes();
public: __property void set_AcceptedSerialNumberSizes(
   SerialNumberSizes value
);
C++/CLI
public:
property SerialNumberSizes AcceptedSerialNumberSizes {
   SerialNumberSizes get();
   void set (SerialNumberSizes value);
}

Remarks

It is recommended that you only allow the largest size you will reasonably expect to issue to your customers. A malicious user needs only to crack the smallest acceptable size to gain access to the license. The Recommended sizes are Medium (for regular serial numbers) and Huge (for activation keys).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
AssemblyName Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AssemblyName Property

Gets or sets the name of the assembly used to sign the license originally. The value of this property is for reference only and has no impact on the validation of a license.

Syntax

Visual Basic (Declaration)
Public Property AssemblyName As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.AssemblyName = value

value = instance.AssemblyName
C#
public string AssemblyName {get; set;}
Managed Extensions for C++
public: __property string* get_AssemblyName();
public: __property void set_AssemblyName(
   string* value
);
C++/CLI
public:
property String^ AssemblyName {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Components Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Components Property

Gets the collection of component names that the license applies to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As StringCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As StringCollection

value = instance.Components
C#
public StringCollection Components {get;}
Managed Extensions for C++
public: __property StringCollection get_Components();
C++/CLI
public:
property StringCollection Components {
   StringCollection get();
}

Remarks

Each component name in the collection should be the FullName of the Type including the namespace. When the license is read only then a copy of the collection is returned and any changes to the collection are lost.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ConnectionString Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ConnectionString Property

Gets the default database connection string for licensing components.

Syntax

Visual Basic (Declaration)
Public Shared Property ConnectionString As String
Visual Basic (Usage) Copy Code
Dim value As String

ExtendedLicense.ConnectionString = value

value = ExtendedLicense.ConnectionString
C#
public static string ConnectionString {get; set;}
Managed Extensions for C++
public: __property static string* get_ConnectionString();
public: __property static void set_ConnectionString(
   string* value
);
C++/CLI
public:
static property String^ ConnectionString {
   String^ get();
   void set (String^ value);
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.ConnectionString" value="server=localhost;catalog=Northwind" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="ConnectionString" value="server=localhost;catalog=Northwind" />
    </Licensing>
</Xheo>
</configuration>

Remarks

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.ConnectionString and set it to the path where keys are stored on your machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
EmulateVersion Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : EmulateVersion Property

Gets a value that determines the release version that XHEO|Licensing should emulate.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property EmulateVersion As Version
Visual Basic (Usage) Copy Code
Dim value As Version

value = ExtendedLicense.EmulateVersion
C#
public static Version EmulateVersion {get;}
Managed Extensions for C++
public: __property static Version* get_EmulateVersion();
C++/CLI
public:
static property Version^ EmulateVersion {
   Version^ get();
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.EmulateVersion" value="1.1" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="EmulateVersion" value="1.1" />
    </Licensing>
</Xheo>
</configuration>

Remarks

Use this value when migrating a solution from an earlier version to a newer one so that licenses generated with the new assembly will use the previous version until you have fully upgraded all dependent assemblies.

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.EmulateVersion and set it to either true or false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Expires Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Expires Property

Gets or sets the expiration date for the license.

Syntax

Visual Basic (Declaration)
Public Property Expires As Date
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Date

instance.Expires = value

value = instance.Expires
C#
public DateTime Expires {get; set;}
Managed Extensions for C++
public: __property DateTime get_Expires();
public: __property void set_Expires(
   DateTime value
);
C++/CLI
public:
property DateTime Expires {
   DateTime get();
   void set (DateTime value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IisIsAvailable Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IisIsAvailable Property

Gets a value that indicates if IIS is installed and available on the machine. If false then HttpContext should not be checked because it will throw an exception.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IisIsAvailable As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = ExtendedLicense.IisIsAvailable
C#
public static bool IisIsAvailable {get;}
Managed Extensions for C++
public: __property static bool get_IisIsAvailable();
C++/CLI
public:
static property bool IisIsAvailable {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
InvalidReason Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : InvalidReason Property

Gets or sets the reason the license was not valid. If Validate returns true this is an empty string.

Syntax

Visual Basic (Declaration)
Public Property InvalidReason As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.InvalidReason = value

value = instance.InvalidReason
C#
public string InvalidReason {get; set;}
Managed Extensions for C++
public: __property string* get_InvalidReason();
public: __property void set_InvalidReason(
   string* value
);
C++/CLI
public:
property String^ InvalidReason {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsEmbedded Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsEmbedded Property

Gets or sets a value that indicates if the license was loaded from an embedded resource rather then an external .LIC file.

Syntax

Visual Basic (Declaration)
Public Property IsEmbedded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Boolean

instance.IsEmbedded = value

value = instance.IsEmbedded
C#
public bool IsEmbedded {get; set;}
Managed Extensions for C++
public: __property bool get_IsEmbedded();
public: __property void set_IsEmbedded(
   bool value
);
C++/CLI
public:
property bool IsEmbedded {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsReadOnly Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsReadOnly Property

Gets a value that indicates if the current license is read only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IssuerUrl Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IssuerUrl Property

Gets or sets the URL to the company that issued the license.

Syntax

Visual Basic (Declaration)
Public Property IssuerUrl As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.IssuerUrl = value

value = instance.IssuerUrl
C#
public string IssuerUrl {get; set;}
Managed Extensions for C++
public: __property string* get_IssuerUrl();
public: __property void set_IssuerUrl(
   string* value
);
C++/CLI
public:
property String^ IssuerUrl {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsTerminalServices Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsTerminalServices Property

Gets a value that indicates if the current session is running under terminal services.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IsTerminalServices As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = ExtendedLicense.IsTerminalServices
C#
public static bool IsTerminalServices {get;}
Managed Extensions for C++
public: __property static bool get_IsTerminalServices();
C++/CLI
public:
static property bool IsTerminalServices {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsTimeSensitive Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsTimeSensitive Property

Gets a value that indicates if the license contians time sensitive data and the clock should be protected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsTimeSensitive As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Boolean

value = instance.IsTimeSensitive
C#
public bool IsTimeSensitive {get;}
Managed Extensions for C++
public: __property bool get_IsTimeSensitive();
C++/CLI
public:
property bool IsTimeSensitive {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsWebRequest Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsWebRequest Property

Gets a value indicating if a web request/HttpContext is currently available.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IsWebRequest As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = ExtendedLicense.IsWebRequest
C#
public static bool IsWebRequest {get;}
Managed Extensions for C++
public: __property static bool get_IsWebRequest();
C++/CLI
public:
static property bool IsWebRequest {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
KeyFolder Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : KeyFolder Property

Gets the folder where the license keys are located as defined in the application's config file.

Syntax

Visual Basic (Declaration)
Public Shared Property KeyFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

ExtendedLicense.KeyFolder = value

value = ExtendedLicense.KeyFolder
C#
public static string KeyFolder {get; set;}
Managed Extensions for C++
public: __property static string* get_KeyFolder();
public: __property static void set_KeyFolder(
   string* value
);
C++/CLI
public:
static property String^ KeyFolder {
   String^ get();
   void set (String^ value);
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.KeyFolder" value="X:\Keys" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="KeyFolder" value="D:\aaa" />
    </Licensing>
</Xheo>
</configuration>

Remarks

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.KeyFolder and set it to the path where keys are stored on your machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LicensedType Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LicensedType Property

Gets the Type the license was/will be granted to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LicensedType As Type
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Type

value = instance.LicensedType
C#
public Type LicensedType {get;}
Managed Extensions for C++
public: __property Type* get_LicensedType();
C++/CLI
public:
property Type^ LicensedType {
   Type^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LicenseFolders Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LicenseFolders Property

Gets a collection of folders where the licenses are located as defined in the application's config file.

Syntax

Visual Basic (Declaration)
Public Shared Property LicenseFolders As String()
Visual Basic (Usage) Copy Code
Dim value() As String

ExtendedLicense.LicenseFolders = value

value = ExtendedLicense.LicenseFolders
C#
public static string[] LicenseFolders {get; set;}
Managed Extensions for C++
public: __property static string*[] get_LicenseFolders();
public: __property static void set_LicenseFolders(
   string*[] value
);
C++/CLI
public:
static property array<String^> LicenseFolders {
   array<String^> get();
   void set (String^array<value> value);
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.LicenseFolder" value="X:\Folder1" />
    <add key="Xheo.Licensing.LicenseFolder" value="X:\Folder2" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="Xheo.Licensing.Configuration.NameValueSectionHandler, System, Version=1.1.0.0, Culture=neutral, PublicKeyToken=798276055709c98a" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="LicenseFolder" value="D:\aaa" />
        <add key="LicenseFolder" value="C:\other" />
    </Licensing>
</Xheo>
</configuration>

Remarks

Use this setting when you install XHEO|Licensing or licensed components into the GAC, or when using a shared install in a hosting environment.

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.LicenseFolders and set it to the path where keys are stored on your machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LicenseKey Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LicenseKey Property

Overrides LicenseKey.

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable ReadOnly Property LicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

value = instance.LicenseKey
C#
public override string LicenseKey {get;}
Managed Extensions for C++
public: __property string* get_LicenseKey()override ;
C++/CLI
public:
property String^ LicenseKey override {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LicensePack Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LicensePack Property

Gets the ExtendedLicensePack that owns the license.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LicensePack As ExtendedLicensePack
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As ExtendedLicensePack

value = instance.LicensePack
C#
public ExtendedLicensePack LicensePack {get;}
Managed Extensions for C++
public: __property ExtendedLicensePack* get_LicensePack();
C++/CLI
public:
property ExtendedLicensePack^ LicensePack {
   ExtendedLicensePack^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MaximumSerialNumberSeed Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : MaximumSerialNumberSeed Property

Gets or sets the maximum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.

Syntax

Visual Basic (Declaration)
Public Property MaximumSerialNumberSeed As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Integer

instance.MaximumSerialNumberSeed = value

value = instance.MaximumSerialNumberSeed
C#
public int MaximumSerialNumberSeed {get; set;}
Managed Extensions for C++
public: __property int get_MaximumSerialNumberSeed();
public: __property void set_MaximumSerialNumberSeed(
   int value
);
C++/CLI
public:
property int MaximumSerialNumberSeed {
   int get();
   void set (int value);
}

Remarks

Use MinimumSerialNumberSeed and MaximumSerialNumberSeed to partition serial numbers to various resellers or vendors. You can then use this to determine which vendor sold your product in case of support requests.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MetaValues Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : MetaValues Property

Gets a collection of arbitrary values to store with the license. These values are not protected and may be changed without affecting the validity of the license. Use for storing volitle information and other unsecured information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetaValues As LicenseValuesCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As LicenseValuesCollection

value = instance.MetaValues
C#
public LicenseValuesCollection MetaValues {get;}
Managed Extensions for C++
public: __property LicenseValuesCollection* get_MetaValues();
C++/CLI
public:
property LicenseValuesCollection^ MetaValues {
   LicenseValuesCollection^ get();
}

Remarks

The MetaValues collection will be persisted with a license. However any changes to the meta values collection after the license is signed will not affect the validity of the signature. Use this to track volitle information that need not be secured and is safe for the user to change.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MinimumSerialNumberSeed Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : MinimumSerialNumberSeed Property

Gets or sets the minimum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.

Syntax

Visual Basic (Declaration)
Public Property MinimumSerialNumberSeed As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Integer

instance.MinimumSerialNumberSeed = value

value = instance.MinimumSerialNumberSeed
C#
public int MinimumSerialNumberSeed {get; set;}
Managed Extensions for C++
public: __property int get_MinimumSerialNumberSeed();
public: __property void set_MinimumSerialNumberSeed(
   int value
);
C++/CLI
public:
property int MinimumSerialNumberSeed {
   int get();
   void set (int value);
}

Remarks

Use MinimumSerialNumberSeed and MaximumSerialNumberSeed to partition serial numbers to various resellers or vendors. You can then use this to determine which vendor sold your product in case of support requests.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Organization Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Organization Property

Gets or sets the name of the organization that the license is issued to.

Syntax

Visual Basic (Declaration)
Public Property Organization As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.Organization = value

value = instance.Organization
C#
public string Organization {get; set;}
Managed Extensions for C++
public: __property string* get_Organization();
public: __property void set_Organization(
   string* value
);
C++/CLI
public:
property String^ Organization {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
PersistantState Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : PersistantState Property

Gets a reference to per-license specific state that works independent of any underlying state schemes. This is used to safely track values that should be kept in memory even when a license is reloaded from disk.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PersistantState As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Hashtable

value = instance.PersistantState
C#
public Hashtable PersistantState {get;}
Managed Extensions for C++
public: __property Hashtable* get_PersistantState();
C++/CLI
public:
property Hashtable^ PersistantState {
   Hashtable^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
PublicKey Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : PublicKey Property

Gets a reference to the LicenseSigningKey being used to validate the license.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PublicKey As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As LicenseSigningKey

value = instance.PublicKey
C#
public LicenseSigningKey PublicKey {get;}
Managed Extensions for C++
public: __property LicenseSigningKey* get_PublicKey();
C++/CLI
public:
property LicenseSigningKey^ PublicKey {
   LicenseSigningKey^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SerialNumber Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : SerialNumber Property

Gets or sets the value of the absolute serial number.

Syntax

Visual Basic (Declaration)
Public Property SerialNumber As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.SerialNumber = value

value = instance.SerialNumber
C#
public string SerialNumber {get; set;}
Managed Extensions for C++
public: __property string* get_SerialNumber();
public: __property void set_SerialNumber(
   string* value
);
C++/CLI
public:
property String^ SerialNumber {
   String^ get();
   void set (String^ value);
}

Remarks

The absolute serial number is used in unlocking a license by serial number. The absolute serial number must begin with the SerialNumber for the license.
Warning This value is unprotected and can be changed by the client. Do not assume the value is valid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SharedFolder Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : SharedFolder Property

Gets or sets the path to the shared license folder.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SharedFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

value = ExtendedLicense.SharedFolder
C#
public static string SharedFolder {get;}
Managed Extensions for C++
public: __property static string* get_SharedFolder();
C++/CLI
public:
static property String^ SharedFolder {
   String^ get();
}

Remarks

The shared license folder is a location on the client machine where all XHEO|Licensing protected applications can look for licenses. This helps with shared hosting environments and large applications that may include multiple assemblies, some in the GAC. Rather then having .LIC files spread over the machine they can be located into a single location.

This is a machine wide setting. The value of this property should be considered configured by the machine's administrator. You should not change it as it will effect all installed applications protected with XHEO|Licensing.

The folder location by default is [Common Files]\Xheo\SharedLicenses. This can be configured per machine or per user in the registry at HKLM or HKLU\Software\Xheo\Licensing\SharedLicenseFolder.

See LicenseFolders for settings you can apply to the application's config or machine.config file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
LicenseFolders Property


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Signature Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Signature Property

Gets or sets the signature used to validate the license data.

Syntax

Visual Basic (Declaration)
Public Property Signature As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.Signature = value

value = instance.Signature
C#
public string Signature {get; set;}
Managed Extensions for C++
public: __property string* get_Signature();
public: __property void set_Signature(
   string* value
);
C++/CLI
public:
property String^ Signature {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SurrogateLicensePack Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : SurrogateLicensePack Property

Gets or sets a surrogate license pack to use if validation of this license fails.

Syntax

Visual Basic (Declaration)
Public Property SurrogateLicensePack As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.SurrogateLicensePack = value

value = instance.SurrogateLicensePack
C#
public string SurrogateLicensePack {get; set;}
Managed Extensions for C++
public: __property string* get_SurrogateLicensePack();
public: __property void set_SurrogateLicensePack(
   string* value
);
C++/CLI
public:
property String^ SurrogateLicensePack {
   String^ get();
   void set (String^ value);
}

Remarks

For limits that alter the current license, or download new licenses you can set this property so that the new or altered license pack is used instead. When Validate is called on the current license, this is initially set to null. If Validate returns false, and this is not null then the license pack indicated in this property, if it contains a license, is used instead. If a surrogate license pack also defines a surrogate license, it will not be checked, the license provider only checks one level deep.

Generally you shouldn't set this to a license pack containing license with with a Trial limit or GUI limit because it will interfere with the optimal license selection of the license provider.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Tag Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Tag Property

Gets or sets an arbitrary piece of data to track with the license. This is a "cheap" way of extending the license scheme by allowing you to store any kind of additional data that can be saved as a string to the license.

Syntax

Visual Basic (Declaration)
Public Property Tag As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.Tag = value

value = instance.Tag
C#
public string Tag {get; set;}
Managed Extensions for C++
public: __property string* get_Tag();
public: __property void set_Tag(
   string* value
);
C++/CLI
public:
property String^ Tag {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
TemplateFolder Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : TemplateFolder Property

Gets the folder where the license templates are located as defined in the application's config file.

Syntax

Visual Basic (Declaration)
Public Shared Property TemplateFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

ExtendedLicense.TemplateFolder = value

value = ExtendedLicense.TemplateFolder
C#
public static string TemplateFolder {get; set;}
Managed Extensions for C++
public: __property static string* get_TemplateFolder();
public: __property static void set_TemplateFolder(
   string* value
);
C++/CLI
public:
static property String^ TemplateFolder {
   String^ get();
   void set (String^ value);
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.TemplateFolder" value="X:\Templates" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="TemplateFolder" value="D:\aaa\Templates" />
    </Licensing>
</Xheo>
</configuration>

Remarks

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.TemplateFolder and set it to the path where keys are stored on your machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Type Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Type Property

Gets or sets an application/product specific description of the type of license. For examples "designer", "single user", "non-profit", etc. This can often be used a reference to the primary key in a database, such as a SKU, for the product that the license represents.

Syntax

Visual Basic (Declaration)
Public Property Type As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.Type = value

value = instance.Type
C#
public string Type {get; set;}
Managed Extensions for C++
public: __property string* get_Type();
public: __property void set_Type(
   string* value
);
C++/CLI
public:
property String^ Type {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UnlockBySerial Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : UnlockBySerial Property

Gets or sets a value that indicates if the user must provide a valid serial number to fully unlock the license.

Syntax

Visual Basic (Declaration)
Public Property UnlockBySerial As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Boolean

instance.UnlockBySerial = value

value = instance.UnlockBySerial
C#
public bool UnlockBySerial {get; set;}
Managed Extensions for C++
public: __property bool get_UnlockBySerial();
public: __property void set_UnlockBySerial(
   bool value
);
C++/CLI
public:
property bool UnlockBySerial {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UnlockedLicense Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : UnlockedLicense Property

Gets or sets the ExtendedLicense that was unlocked by the registration process.

Syntax

Visual Basic (Declaration)
Public Property UnlockedLicense As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As ExtendedLicense

instance.UnlockedLicense = value

value = instance.UnlockedLicense
C#
public ExtendedLicense UnlockedLicense {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_UnlockedLicense();
public: __property void set_UnlockedLicense(
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ UnlockedLicense {
   ExtendedLicense^ get();
   void set (ExtendedLicense^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
User Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : User Property

Gets or sets the value of the user as it should appear on screen.

Syntax

Visual Basic (Declaration)
Public Property User As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.User = value

value = instance.User
C#
public string User {get; set;}
Managed Extensions for C++
public: __property string* get_User();
public: __property void set_User(
   string* value
);
C++/CLI
public:
property String^ User {
   String^ get();
   void set (String^ value);
}

Remarks

Warning This value is unprotected and can be changed by the client. Do not assume the value is valid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Values Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Values Property

Gets a collection of arbitrary values to store with the license.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As LicenseValuesCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As LicenseValuesCollection

value = instance.Values
C#
public LicenseValuesCollection Values {get;}
Managed Extensions for C++
public: __property LicenseValuesCollection* get_Values();
C++/CLI
public:
property LicenseValuesCollection^ Values {
   LicenseValuesCollection^ get();
}

Remarks

You can use this to store values for runtime adjustments such as maximum values, names, etc. The values are also signed so adjustments to the values after the license has been signed will invalidate the license. Non primitive values must be marked as Serializable.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Version Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Version Property

Gets or sets the version of the licensing scheme used.

Syntax

Visual Basic (Declaration)
Public Property Version As Version
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Version

instance.Version = value

value = instance.Version
C#
public Version Version {get; set;}
Managed Extensions for C++
public: __property Version* get_Version();
public: __property void set_Version(
   Version* value
);
C++/CLI
public:
property Version^ Version {
   Version^ get();
   void set (Version^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
XmlString Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : XmlString Property

Gets or sets the contents of the license as an XML string fragment.

Syntax

Visual Basic (Declaration)
Public Property XmlString As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.XmlString = value

value = instance.XmlString
C#
public string XmlString {get; set;}
Managed Extensions for C++
public: __property string* get_XmlString();
public: __property void set_XmlString(
   string* value
);
C++/CLI
public:
property String^ XmlString {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%% $$Fields$$

Barcode4NET Send comments on this topic.
ExtendedLicense Class Fields
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

For a list of all members of this type, see ExtendedLicense members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ConfigSection | The configuration section where XHEO|Licensing settings are stored in the application's configuration file.
static (Shared in Visual Basic) | CurrentVersion | The current license scheme file version.
Top

See Also

Reference

ExtendedLicense Class
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ConfigSection Field
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ConfigSection Field

The configuration section where XHEO|Licensing settings are stored in the application's configuration file.

Syntax

Visual Basic (Declaration)
Public Shared ConfigSection As String
Visual Basic (Usage) Copy Code
Dim value As String

value = ExtendedLicense.ConfigSection

ExtendedLicense.ConfigSection = value
C#
public static string ConfigSection
Managed Extensions for C++
public: static string* ConfigSection
C++/CLI
public:
static String^ ConfigSection

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.TemplateFolder" value="X:\Keys" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="TemplateFolder" value="D:\aaa" />
    </Licensing>
</Xheo>
</configuration>

Remarks

All of XHEO|Licensing's configuration settings can be set from the application or machine's configuration file. You can use the shared <appSettings> section or the custom section to set settings.

Most configuration options can be set in the configuration file via code by setting the public static property to the desired value. For example to save the location of the KeyFolder simply set KeyFolder to the desired value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
CurrentVersion Field
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : CurrentVersion Field

The current license scheme file version.

Syntax

Visual Basic (Declaration)
Public Shared CurrentVersion As Version
Visual Basic (Usage) Copy Code
Dim value As Version

value = ExtendedLicense.CurrentVersion

ExtendedLicense.CurrentVersion = value
C#
public static Version CurrentVersion
Managed Extensions for C++
public: static Version* CurrentVersion
C++/CLI
public:
static Version^ CurrentVersion

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ExtendedLicenseException Class
See Also Members
[image]
Xheo.Licensing Namespace : ExtendedLicenseException Class

Represents an exception in a Xheo assembly with a localized FriendlyMessage and DetailedMessage.

Syntax

Visual Basic (Declaration)
Private Class ExtendedLicenseException
   Inherits ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException
C#
private class ExtendedLicenseException : ApplicationException
Managed Extensions for C++
private __gc class ExtendedLicenseException : public ApplicationException
C++/CLI
private ref class ExtendedLicenseException : public ApplicationException

Remarks

The Message is used to communicate a simple description of what went wrong and should be written to the non-developer audience. The DetailedMessage should be used to communicate additional technical details and how the problem might be fixed.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Xheo.Licensing.ExtendedLicenseException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
ExtendedLicenseException Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : ExtendedLicenseException Class

The following tables list the members exposed by ExtendedLicenseException.

Public Constructors

 | Name | Description
Public Constructor | ExtendedLicenseException Constructor | Overloaded. Initializes a new instance of the ExtendedLicenseException class.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | DetailedMessage | Gets or sets the detailed message.
Public Property | FriendlyMessage | Gets or sets the friendly message.
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Overridden. Gets a description of the exception.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ExtendedLicenseException Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ExtendedLicenseException Constructor
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class : ExtendedLicenseException Constructor

Initializes a new instance of the ExtendedLicenseException class.

Overload List

Overload | Description
ExtendedLicenseException Constructor() | Initializes a new instance of the ExtendedLicenseException class.
ExtendedLicenseException Constructor(String) | Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.
ExtendedLicenseException Constructor(String,Exception) | Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.
ExtendedLicenseException Constructor(String,Exception,Object[]) | Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.
ExtendedLicenseException Constructor(String,Object[]) | Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ExtendedLicenseException Constructor()
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor()

Initializes a new instance of the ExtendedLicenseException class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException()
C#
public ExtendedLicenseException()
Managed Extensions for C++
public: ExtendedLicenseException();
C++/CLI
public:
ExtendedLicenseException();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ExtendedLicenseException Constructor(String)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor(String)

resourceName
The name of the resource to use for the message.
Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceName As String _
)
Visual Basic (Usage) Copy Code
Dim resourceName As String

Dim instance As ExtendedLicenseException(resourceName)
C#
public ExtendedLicenseException(
   string resourceName
)
Managed Extensions for C++
public: ExtendedLicenseException(
   string* resourceName
)
C++/CLI
public:
ExtendedLicenseException(
   String^ resourceName
)

Parameters

resourceName
The name of the resource to use for the message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ExtendedLicenseException Constructor(String,Exception)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor(String,Exception)

resourceName
The name of the resource to use for the message.
innerException
A reference to any inner exception.
Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceName As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim resourceName As String
Dim innerException As Exception

Dim instance As ExtendedLicenseException(resourceName, innerException)
C#
public ExtendedLicenseException(
   string resourceName,
   Exception innerException
)
Managed Extensions for C++
public: ExtendedLicenseException(
   string* resourceName,
   Exception* innerException
)
C++/CLI
public:
ExtendedLicenseException(
   String^ resourceName,
   Exception^ innerException
)

Parameters

resourceName
The name of the resource to use for the message.
innerException
A reference to any inner exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ExtendedLicenseException Constructor(String,Exception,Object[])
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor(String,Exception,Object[])

resourceName
The name of the resource to use for the message.
innerException
A reference to any inner exception.
args
Variable list of arguments to pass to String.Format.
Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceName As String, _
   ByVal innerException As Exception, _
   ByVal ParamArray args() As Object _
)
Visual Basic (Usage) Copy Code
Dim resourceName As String
Dim innerException As Exception
Dim args() As Object

Dim instance As ExtendedLicenseException(resourceName, innerException, args)
C#
public ExtendedLicenseException(
   string resourceName,
   Exception innerException,
   params object[] args
)
Managed Extensions for C++
public: ExtendedLicenseException(
   string* resourceName,
   Exception* innerException,
   params Object*[] args
)
C++/CLI
public:
ExtendedLicenseException(
   String^ resourceName,
   Exception^ innerException,
   ... array<Object^> args
)

Parameters

resourceName
The name of the resource to use for the message.
innerException
A reference to any inner exception.
args
Variable list of arguments to pass to String.Format.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ExtendedLicenseException Constructor(String,Object[])
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor(String,Object[])

resourceName
The name of the resource to use for the message.
args
Variable list of arguments to pass to String.Format.
Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceName As String, _
   ByVal ParamArray args() As Object _
)
Visual Basic (Usage) Copy Code
Dim resourceName As String
Dim args() As Object

Dim instance As ExtendedLicenseException(resourceName, args)
C#
public ExtendedLicenseException(
   string resourceName,
   params object[] args
)
Managed Extensions for C++
public: ExtendedLicenseException(
   string* resourceName,
   params Object*[] args
)
C++/CLI
public:
ExtendedLicenseException(
   String^ resourceName,
   ... array<Object^> args
)

Parameters

resourceName
The name of the resource to use for the message.
args
Variable list of arguments to pass to String.Format.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
ExtendedLicenseException Class Properties
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicenseException Class

For a list of all members of this type, see ExtendedLicenseException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | DetailedMessage | Gets or sets the detailed message.
Public Property | FriendlyMessage | Gets or sets the friendly message.
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Overridden. Gets a description of the exception.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ExtendedLicenseException Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
DetailedMessage Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class : DetailedMessage Property

Gets or sets the detailed message.

Syntax

Visual Basic (Declaration)
Public Property DetailedMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException
Dim value As String

instance.DetailedMessage = value

value = instance.DetailedMessage
C#
public string DetailedMessage {get; set;}
Managed Extensions for C++
public: __property string* get_DetailedMessage();
public: __property void set_DetailedMessage(
   string* value
);
C++/CLI
public:
property String^ DetailedMessage {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
FriendlyMessage Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class : FriendlyMessage Property

Gets or sets the friendly message.

Syntax

Visual Basic (Declaration)
Public Property FriendlyMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException
Dim value As String

instance.FriendlyMessage = value

value = instance.FriendlyMessage
C#
public string FriendlyMessage {get; set;}
Managed Extensions for C++
public: __property string* get_FriendlyMessage();
public: __property void set_FriendlyMessage(
   string* value
);
C++/CLI
public:
property String^ FriendlyMessage {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Message Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class : Message Property

Gets a description of the exception.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property Message As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException
Dim value As String

value = instance.Message
C#
public override string Message {get;}
Managed Extensions for C++
public: __property string* get_Message()override ;
C++/CLI
public:
property String^ Message override {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ExtendedLicensePack Class
See Also Members
[image]
Xheo.Licensing Namespace : ExtendedLicensePack Class

Represents a collection of licenses stored in a single .LIC file.

Object Model

Syntax

Visual Basic (Declaration)
Private Class ExtendedLicensePack
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
C#
private class ExtendedLicensePack : CollectionBase
Managed Extensions for C++
private __gc class ExtendedLicensePack : public CollectionBase
C++/CLI
private ref class ExtendedLicensePack : public CollectionBase

Remarks

Each license pack can serialize to and from an XML license file. Each license within the pack is signed, but the pack itself is not. Licenses can be added or removed without affecting the validity of the pack.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Xheo.Licensing.ExtendedLicensePack

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
ExtendedLicensePack Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : ExtendedLicensePack Class

The following tables list the members exposed by ExtendedLicensePack.

Public Constructors

 | Name | Description
Public Constructor | ExtendedLicensePack Constructor | Overloaded. Initializes a new instance of the ExtendedLicensePack class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsEmbedded | Gets a value that indicates if the pack was loaded directly from an assembly.
Public Property | Item | Overloaded. Gets or sets the ExtendedLicense at the given index.
Public Property | Location | Gets the path to the file where the license pack was originally loaded from. If not loaded from a file, returns null.
Public Property | MetaValues | Gets a collection of arbitrary values to store with the license pack. These values are not protected and may be changed without affecting the validity of the contained licenses. Use for storing volitle information and other unsecured information.
Public Property | SaveToShared | Gets or sets a value that indicates if changes to the license pack when validating should be saved to the shared licenses folder.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the given ExtendedLicense to the collection.
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Clones the license pack in memory.
Public Method | Contains | Determines if the pack contains the given license.
Public Method | CopyTo | Copies the collection of ExtendedLicense objects into the array at the given index.
Public Method | Dispose | Disposes of any managed/unmanged resources.
Public Method | FromXmlString | Loads the contents of the xml string into the license pack.
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetLicensesForComponent | Gets a subset of the current license pack filtered by the given component.
Public Method | IndexOf | Overloaded. Gets the index of the ExtendedLicense with the given serial number.
Public Method | Insert | Inserts the license at the given index.
Public Method | Load | Overloaded. Loads the contents of the license pack from a file.
Public Method | Remove | Overloaded. Removes the given ExtendedLicense from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Save | Overloaded. Saves the contents of the license pack to a stream.
Public Method | ToFormattedXmlString | Gets the contents of the license pack as an friendly XML string.
Public Method | ToXmlString | Gets the contents of the license pack as an XML string.
Public Method | WriteToResponse | Overloaded. Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.
Top

See Also

Reference

ExtendedLicensePack Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ExtendedLicensePack Constructor
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : ExtendedLicensePack Constructor

Initializes a new instance of the ExtendedLicensePack class.

Overload List

Overload | Description
ExtendedLicensePack Constructor() | Initializes a new instance of the ExtendedLicensePack class.
ExtendedLicensePack Constructor(String) | Initializes a new instance of the ExtendedLicensePack class from the given file.
ExtendedLicensePack Constructor(String,Boolean) | Initializes a new instance of the ExtendedLicensePack class from the given file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ExtendedLicensePack Constructor()
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > ExtendedLicensePack Constructor : ExtendedLicensePack Constructor()

Initializes a new instance of the ExtendedLicensePack class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack()
C#
public ExtendedLicensePack()
Managed Extensions for C++
public: ExtendedLicensePack();
C++/CLI
public:
ExtendedLicensePack();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ExtendedLicensePack Constructor(String)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > ExtendedLicensePack Constructor : ExtendedLicensePack Constructor(String)

filename
Path to the file that contains the license pack.
Initializes a new instance of the ExtendedLicensePack class from the given file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim filename As String

Dim instance As ExtendedLicensePack(filename)
C#
public ExtendedLicensePack(
   string filename
)
Managed Extensions for C++
public: ExtendedLicensePack(
   string* filename
)
C++/CLI
public:
ExtendedLicensePack(
   String^ filename
)

Parameters

filename
Path to the file that contains the license pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ExtendedLicensePack Constructor(String,Boolean)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > ExtendedLicensePack Constructor : ExtendedLicensePack Constructor(String,Boolean)

filename
Path to the file that contains the license pack.
tryIsolatedStorage
When true attempts to load a mirrored version of the license from Isolated Storage first.
Initializes a new instance of the ExtendedLicensePack class from the given file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String, _
   ByVal tryIsolatedStorage As Boolean _
)
Visual Basic (Usage) Copy Code
Dim filename As String
Dim tryIsolatedStorage As Boolean

Dim instance As ExtendedLicensePack(filename, tryIsolatedStorage)
C#
public ExtendedLicensePack(
   string filename,
   bool tryIsolatedStorage
)
Managed Extensions for C++
public: ExtendedLicensePack(
   string* filename,
   bool tryIsolatedStorage
)
C++/CLI
public:
ExtendedLicensePack(
   String^ filename,
   bool tryIsolatedStorage
)

Parameters

filename
Path to the file that contains the license pack.
tryIsolatedStorage
When true attempts to load a mirrored version of the license from Isolated Storage first.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
ExtendedLicensePack Class Methods
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicensePack Class

For a list of all members of this type, see ExtendedLicensePack members.

Public Methods

 | Name | Description
Public Method | Add | Adds the given ExtendedLicense to the collection.
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Clones the license pack in memory.
Public Method | Contains | Determines if the pack contains the given license.
Public Method | CopyTo | Copies the collection of ExtendedLicense objects into the array at the given index.
Public Method | Dispose | Disposes of any managed/unmanged resources.
Public Method | FromXmlString | Loads the contents of the xml string into the license pack.
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetLicensesForComponent | Gets a subset of the current license pack filtered by the given component.
Public Method | IndexOf | Overloaded. Gets the index of the ExtendedLicense with the given serial number.
Public Method | Insert | Inserts the license at the given index.
Public Method | Load | Overloaded. Loads the contents of the license pack from a file.
Public Method | Remove | Overloaded. Removes the given ExtendedLicense from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Save | Overloaded. Saves the contents of the license pack to a stream.
Public Method | ToFormattedXmlString | Gets the contents of the license pack as an friendly XML string.
Public Method | ToXmlString | Gets the contents of the license pack as an XML string.
Public Method | WriteToResponse | Overloaded. Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.
Top

See Also

Reference

ExtendedLicensePack Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Add Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Add Method

license
The ExtendedLicense to add.
Adds the given ExtendedLicense to the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim license As ExtendedLicense

instance.Add(license)
C#
public void Add(
   ExtendedLicense license
)
Managed Extensions for C++
public: void Add(
   ExtendedLicense* license
)
C++/CLI
public:
void Add(
   ExtendedLicense^ license
)

Parameters

license
The ExtendedLicense to add.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Clone Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Clone Method

Clones the license pack in memory.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As Object

value = instance.Clone()
C#
public object Clone()
Managed Extensions for C++
public: Object* Clone();
C++/CLI
public:
Object^ Clone();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Contains Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Contains Method

license
The license to look for.
Determines if the pack contains the given license.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal license As ExtendedLicense _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim license As ExtendedLicense
Dim value As Boolean

value = instance.Contains(license)
C#
public bool Contains(
   ExtendedLicense license
)
Managed Extensions for C++
public: bool Contains(
   ExtendedLicense* license
)
C++/CLI
public:
bool Contains(
   ExtendedLicense^ license
)

Parameters

license
The license to look for.

Return Value

Returns true if the license is found, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
CopyTo Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : CopyTo Method

array
The array to copy to.
index
The index in the array to start copying.
Copies the collection of ExtendedLicense objects into the array at the given index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ExtendedLicense, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim array() As ExtendedLicense
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ExtendedLicense[] array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   ExtendedLicense*[] array,
   int index
)
C++/CLI
public:
void CopyTo(
   array<ExtendedLicense^> array,
   int index
)

Parameters

array
The array to copy to.
index
The index in the array to start copying.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Dispose Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Dispose Method

Disposes of any managed/unmanged resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : FromXmlString Method

xml
A string containing the XML for the license pack.
Loads the contents of the xml string into the license pack.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
A string containing the XML for the license pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetLicensesForComponent Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : GetLicensesForComponent Method

component
Name of the component to get licenses for.
Gets a subset of the current license pack filtered by the given component.

Syntax

Visual Basic (Declaration)
Public Function GetLicensesForComponent( _
   ByVal component As String _
) As ICollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim component As String
Dim value As ICollection

value = instance.GetLicensesForComponent(component)
C#
public ICollection GetLicensesForComponent(
   string component
)
Managed Extensions for C++
public: ICollection* GetLicensesForComponent(
   string* component
)
C++/CLI
public:
ICollection^ GetLicensesForComponent(
   String^ component
)

Parameters

component
Name of the component to get licenses for.

Return Value

Returns a new collection with the requested licenses.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IndexOf Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : IndexOf Method

Gets the index of the ExtendedLicense with the given serial number.

Overload List

Overload | Description
IndexOf(String) | Gets the index of the ExtendedLicense with the given serial number.
IndexOf(ExtendedLicense) | Gets the index of the license in the pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IndexOf(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > IndexOf Method : IndexOf(String) Method

serialNumber
The serial number to look for.
Gets the index of the ExtendedLicense with the given serial number.

Syntax

Visual Basic (Declaration)
Overloads Public Function IndexOf( _
   ByVal serialNumber As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim serialNumber As String
Dim value As Integer

value = instance.IndexOf(serialNumber)
C#
public int IndexOf(
   string serialNumber
)
Managed Extensions for C++
public: int IndexOf(
   string* serialNumber
)
C++/CLI
public:
int IndexOf(
   String^ serialNumber
)

Parameters

serialNumber
The serial number to look for.

Return Value

Returns the index of the license if found, otherwise -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IndexOf(ExtendedLicense) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > IndexOf Method : IndexOf(ExtendedLicense) Method

license
The license to look for.
Gets the index of the license in the pack.

Syntax

Visual Basic (Declaration)
Overloads Public Function IndexOf( _
   ByVal license As ExtendedLicense _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim license As ExtendedLicense
Dim value As Integer

value = instance.IndexOf(license)
C#
public int IndexOf(
   ExtendedLicense license
)
Managed Extensions for C++
public: int IndexOf(
   ExtendedLicense* license
)
C++/CLI
public:
int IndexOf(
   ExtendedLicense^ license
)

Parameters

license
The license to look for.

Return Value

Returns the index of the license if found, otherwise -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Insert Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Insert Method

index
The index in the collection to insert the license.
license
The license to be inserted.
Inserts the license at the given index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim index As Integer
Dim license As ExtendedLicense

instance.Insert(index, license)
C#
public void Insert(
   int index,
   ExtendedLicense license
)
Managed Extensions for C++
public: void Insert(
   int index,
   ExtendedLicense* license
)
C++/CLI
public:
void Insert(
   int index,
   ExtendedLicense^ license
)

Parameters

index
The index in the collection to insert the license.
license
The license to be inserted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Load Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Load Method

Loads the contents of the license pack from a file.

Overload List

Overload | Description
Load(String,Boolean) | Loads the contents of the license pack from a file.
Load(String) | Loads the contents of the license pack from a file.
Load(Stream) | Loads the contents of the license pack from a file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Load(String,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Load Method : Load(String,Boolean) Method

filename
Path to the file where the licenses were saved.
tryIsolatedStorage
When true attempts to load a mirrored version of the license from Isolated Storage first.
Loads the contents of the license pack from a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal filename As String, _
   ByVal tryIsolatedStorage As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String
Dim tryIsolatedStorage As Boolean

instance.Load(filename, tryIsolatedStorage)
C#
public void Load(
   string filename,
   bool tryIsolatedStorage
)
Managed Extensions for C++
public: void Load(
   string* filename,
   bool tryIsolatedStorage
)
C++/CLI
public:
void Load(
   String^ filename,
   bool tryIsolatedStorage
)

Parameters

filename
Path to the file where the licenses were saved.
tryIsolatedStorage
When true attempts to load a mirrored version of the license from Isolated Storage first.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Load(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Load Method : Load(String) Method

filename
Path to the file where the licenses were saved.
Loads the contents of the license pack from a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String

instance.Load(filename)
C#
public void Load(
   string filename
)
Managed Extensions for C++
public: void Load(
   string* filename
)
C++/CLI
public:
void Load(
   String^ filename
)

Parameters

filename
Path to the file where the licenses were saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Load(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Load Method : Load(Stream) Method

stream
The stream to load from.
Loads the contents of the license pack from a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim stream As Stream

instance.Load(stream)
C#
public void Load(
   Stream stream
)
Managed Extensions for C++
public: void Load(
   Stream* stream
)
C++/CLI
public:
void Load(
   Stream^ stream
)

Parameters

stream
The stream to load from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Remove Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Remove Method

Removes the given ExtendedLicense from the collection.

Overload List

Overload | Description
Remove(ExtendedLicense) | Removes the given ExtendedLicense from the collection.
Remove(String) | Removes the license with the given serial number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Remove(ExtendedLicense) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Remove Method : Remove(ExtendedLicense) Method

license
The ExtendedLicense to remove.
Removes the given ExtendedLicense from the collection.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim license As ExtendedLicense

instance.Remove(license)
C#
public void Remove(
   ExtendedLicense license
)
Managed Extensions for C++
public: void Remove(
   ExtendedLicense* license
)
C++/CLI
public:
void Remove(
   ExtendedLicense^ license
)

Parameters

license
The ExtendedLicense to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Remove(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Remove Method : Remove(String) Method

serialNumber
The serial numbef of the license to remove.
Removes the license with the given serial number.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal serialNumber As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim serialNumber As String

instance.Remove(serialNumber)
C#
public void Remove(
   string serialNumber
)
Managed Extensions for C++
public: void Remove(
   string* serialNumber
)
C++/CLI
public:
void Remove(
   String^ serialNumber
)

Parameters

serialNumber
The serial numbef of the license to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Save Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Save Method

Saves the contents of the license pack to a stream.

Overload List

Overload | Description
Save(Stream) | Saves the contents of the license pack to a stream.
Save(String) | Saves the contents of the license pack to a file.
Save() | Saves the contents of the license pack to the file that it was originally loaded from.
Save(String,Boolean) | Saves the contents of the license pack to a file.
Save(Boolean) | Saves the contents of the license pack to the file that it was originally loaded from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Save(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save(Stream) Method

stream
The Stream to write the contents of the license pack to.
Saves the contents of the license pack to a stream.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim stream As Stream

instance.Save(stream)
C#
public void Save(
   Stream stream
)
Managed Extensions for C++
public: void Save(
   Stream* stream
)
C++/CLI
public:
void Save(
   Stream^ stream
)

Parameters

stream
The Stream to write the contents of the license pack to.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Save(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save(String) Method

filename
Path to the file where the licenses should be saved.
Saves the contents of the license pack to a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String

instance.Save(filename)
C#
public void Save(
   string filename
)
Managed Extensions for C++
public: void Save(
   string* filename
)
C++/CLI
public:
void Save(
   String^ filename
)

Parameters

filename
Path to the file where the licenses should be saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Save() Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save() Method

Saves the contents of the license pack to the file that it was originally loaded from.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack

instance.Save()
C#
public void Save()
Managed Extensions for C++
public: void Save();
C++/CLI
public:
void Save();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Save(String,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save(String,Boolean) Method

filename
Path to the file where the licenses should be saved.
useIsolatedOnFail
If the save fails because of a permission exception, attempt to save to the isolated storage location instead.
Saves the contents of the license pack to a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal filename As String, _
   ByVal useIsolatedOnFail As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String
Dim useIsolatedOnFail As Boolean

instance.Save(filename, useIsolatedOnFail)
C#
public void Save(
   string filename,
   bool useIsolatedOnFail
)
Managed Extensions for C++
public: void Save(
   string* filename,
   bool useIsolatedOnFail
)
C++/CLI
public:
void Save(
   String^ filename,
   bool useIsolatedOnFail
)

Parameters

filename
Path to the file where the licenses should be saved.
useIsolatedOnFail
If the save fails because of a permission exception, attempt to save to the isolated storage location instead.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Save(Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save(Boolean) Method

useIsolatedOnFail
If the save fails because of a permission exception, attempt to save to the isolated storage location instead.
Saves the contents of the license pack to the file that it was originally loaded from.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal useIsolatedOnFail As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim useIsolatedOnFail As Boolean

instance.Save(useIsolatedOnFail)
C#
public void Save(
   bool useIsolatedOnFail
)
Managed Extensions for C++
public: void Save(
   bool useIsolatedOnFail
)
C++/CLI
public:
void Save(
   bool useIsolatedOnFail
)

Parameters

useIsolatedOnFail
If the save fails because of a permission exception, attempt to save to the isolated storage location instead.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ToFormattedXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : ToFormattedXmlString Method

Gets the contents of the license pack as an friendly XML string.

Syntax

Visual Basic (Declaration)
Public Function ToFormattedXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As String

value = instance.ToFormattedXmlString()
C#
public string ToFormattedXmlString()
Managed Extensions for C++
public: string* ToFormattedXmlString();
C++/CLI
public:
String^ ToFormattedXmlString();

Return Value

An XML string representation of the license pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : ToXmlString Method

Gets the contents of the license pack as an XML string.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As String

value = instance.ToXmlString()
C#
public string ToXmlString()
Managed Extensions for C++
public: string* ToXmlString();
C++/CLI
public:
String^ ToXmlString();

Return Value

An XML string representation of the license pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
WriteToResponse Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : WriteToResponse Method

Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.

Overload List

Overload | Description
WriteToResponse(String,Boolean) | Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.
WriteToResponse(String) | Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.
WriteToResponse() | Writes the license pack to the response stream for download.

Remarks

Use this method to provide license downloads on your website. You should be careful to not write any additional content to the response stream, or call Response.End() after this method.

NOTE: The response must be buffered for this method to work. In general buffering is on by default in ASP.NET applications.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
WriteToResponse(String,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > WriteToResponse Method : WriteToResponse(String,Boolean) Method

filename
Suggested file name.
direct
Indicates that the file should be written directly to the response and not saved as a new file. When false the user is prompted to open or save the file on their computer.
Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.

Syntax

Visual Basic (Declaration)
Overloads Public Sub WriteToResponse( _
   ByVal filename As String, _
   ByVal direct As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String
Dim direct As Boolean

instance.WriteToResponse(filename, direct)
C#
public void WriteToResponse(
   string filename,
   bool direct
)
Managed Extensions for C++
public: void WriteToResponse(
   string* filename,
   bool direct
)
C++/CLI
public:
void WriteToResponse(
   String^ filename,
   bool direct
)

Parameters

filename
Suggested file name.
direct
Indicates that the file should be written directly to the response and not saved as a new file. When false the user is prompted to open or save the file on their computer.

Remarks

Use this method to provide license downloads on your website. You should be careful to not write any additional content to the response stream, or call Response.End() after this method.

NOTE: The response must be buffered for this method to work. In general buffering is on by default in ASP.NET applications.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
WriteToResponse(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > WriteToResponse Method : WriteToResponse(String) Method

filename
Suggested file name.
Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.

Syntax

Visual Basic (Declaration)
Overloads Public Sub WriteToResponse( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String

instance.WriteToResponse(filename)
C#
public void WriteToResponse(
   string filename
)
Managed Extensions for C++
public: void WriteToResponse(
   string* filename
)
C++/CLI
public:
void WriteToResponse(
   String^ filename
)

Parameters

filename
Suggested file name.

Remarks

Use this method to provide license downloads on your website. You should be careful to not write any additional content to the response stream, or call Response.End() after this method.

NOTE: The response must be buffered for this method to work. In general buffering is on by default in ASP.NET applications.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
WriteToResponse() Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > WriteToResponse Method : WriteToResponse() Method

Writes the license pack to the response stream for download.

Syntax

Visual Basic (Declaration)
Overloads Public Sub WriteToResponse()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack

instance.WriteToResponse()
C#
public void WriteToResponse()
Managed Extensions for C++
public: void WriteToResponse();
C++/CLI
public:
void WriteToResponse();

Remarks

Use this method to provide license downloads on your website.

NOTE: The response must be buffered for this method to work. In general buffering is on by default in ASP.NET applications.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
ExtendedLicensePack Class Properties
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicensePack Class

For a list of all members of this type, see ExtendedLicensePack members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsEmbedded | Gets a value that indicates if the pack was loaded directly from an assembly.
Public Property | Item | Overloaded. Gets or sets the ExtendedLicense at the given index.
Public Property | Location | Gets the path to the file where the license pack was originally loaded from. If not loaded from a file, returns null.
Public Property | MetaValues | Gets a collection of arbitrary values to store with the license pack. These values are not protected and may be changed without affecting the validity of the contained licenses. Use for storing volitle information and other unsecured information.
Public Property | SaveToShared | Gets or sets a value that indicates if changes to the license pack when validating should be saved to the shared licenses folder.
Top

See Also

Reference

ExtendedLicensePack Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsEmbedded Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : IsEmbedded Property

Gets a value that indicates if the pack was loaded directly from an assembly.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmbedded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As Boolean

value = instance.IsEmbedded
C#
public bool IsEmbedded {get;}
Managed Extensions for C++
public: __property bool get_IsEmbedded();
C++/CLI
public:
property bool IsEmbedded {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Item Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Item Property

Gets or sets the ExtendedLicense at the given index.

Overload List

Overload | Description
Item(Int32) | Gets or sets the ExtendedLicense at the given index.
Item(String) | Gets or sets the ExtendedLicense with the given serial number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Item(Int32) Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Item Property : Item(Int32) Property

index
Gets or sets the ExtendedLicense at the given index.

Syntax

Visual Basic (Declaration)
Overloads Public Property Item( _
   ByVal index As Integer _
) As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim index As Integer
Dim value As ExtendedLicense

instance.Item(index) = value

value = instance.Item(index)
C#
public ExtendedLicense Item(
   int index
) {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ Item {
   ExtendedLicense^ get(int index);
   void set (int index, ExtendedLicense^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Item(String) Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Item Property : Item(String) Property

serialNumber
Gets or sets the ExtendedLicense with the given serial number.

Syntax

Visual Basic (Declaration)
Overloads Public Property Item( _
   ByVal serialNumber As String _
) As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim serialNumber As String
Dim value As ExtendedLicense

instance.Item(serialNumber) = value

value = instance.Item(serialNumber)
C#
public ExtendedLicense Item(
   string serialNumber
) {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_Item(
   string* serialNumber
);
public: __property void set_Item(
   string* serialNumber,
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ Item {
   ExtendedLicense^ get(String^ serialNumber);
   void set (String^ serialNumber, ExtendedLicense^ value);
}

Parameters

serialNumber

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Location Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Location Property

Gets the path to the file where the license pack was originally loaded from. If not loaded from a file, returns null.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As String

value = instance.Location
C#
public string Location {get;}
Managed Extensions for C++
public: __property string* get_Location();
C++/CLI
public:
property String^ Location {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MetaValues Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : MetaValues Property

Gets a collection of arbitrary values to store with the license pack. These values are not protected and may be changed without affecting the validity of the contained licenses. Use for storing volitle information and other unsecured information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetaValues As LicenseValuesCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As LicenseValuesCollection

value = instance.MetaValues
C#
public LicenseValuesCollection MetaValues {get;}
Managed Extensions for C++
public: __property LicenseValuesCollection* get_MetaValues();
C++/CLI
public:
property LicenseValuesCollection^ MetaValues {
   LicenseValuesCollection^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SaveToShared Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : SaveToShared Property

Gets or sets a value that indicates if changes to the license pack when validating should be saved to the shared licenses folder.

Syntax

Visual Basic (Declaration)
Public Property SaveToShared As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As Boolean

instance.SaveToShared = value

value = instance.SaveToShared
C#
public bool SaveToShared {get; set;}
Managed Extensions for C++
public: __property bool get_SaveToShared();
public: __property void set_SaveToShared(
   bool value
);
C++/CLI
public:
property bool SaveToShared {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LicenseSigningKey Class
See Also Members
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

Implements a key pair for signing licenses.

Syntax

Visual Basic (Declaration)
Private NotInheritable Class LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
C#
private sealed class LicenseSigningKey
Managed Extensions for C++
private __gc __sealed class LicenseSigningKey
C++/CLI
private ref class LicenseSigningKey sealed

Remarks

See ExtendedLicense for details on how this class works with others in the library to enforce component licenses.

Inheritance Hierarchy

System.Object
Xheo.Licensing.LicenseSigningKey

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
LicenseSigningKey Class Members
See Also Fields Properties Methods
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

The following tables list the members exposed by LicenseSigningKey.

Public Constructors

 | Name | Description
Public Constructor | LicenseSigningKey Constructor | Overloaded. Initializes a new instance of the LicenseSigningKey class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CurrentVersion | The current version of the LicenseSigningKey class.
Top

Public Properties

 | Name | Description
Public Property | IsGlobalKey | Gets a value that indicates if the keys are the global keys used during the trial.
Public Property | Location | Gets the location where the keys were loaded from.
Public Property | Version | Gets or sets the version of the signing key.
Top

Public Methods

 | Name | Description
Public Method | Decrypt | Decrypts the data using the key. Use Encrypt to encrypt values.
Public Method | DecryptString | Decrypts the data using the key. Use EncryptString to encrypt values.
Public Method | Dispose | Implements Dispose.
Public Method | Encrypt | Encrypts the data using the key. Use Decrypt to retrieve the encrypted value.
Public Method | EncryptString | Encrypts the data using the key. Use DecryptString to retrieve the encrypted value.
Public Method | Export | Overloaded. Saves the public key contents of the LicenseSigningKey to a file with the given file name.
Public Method | FromXmlString | Initializes the contents of the LicenseSigningKey from the XML string.
static (Shared in Visual Basic) | GetPublicKey | Gets the runtime.lic embedded in the assembly hosting the given type.
Public Method | GetSerialNumberSeed | Gets the original unmasked serial number seed (Int32 value) from the encoded value.
static (Shared in Visual Basic) | GetSigningKey | Overloaded. Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.
Public Method | Load | Overloaded. Loads the LicenseSigningKey with the contents of the given file.
Public Method | MakeSerialNumber | Overloaded. Makes an encoded serial number for the given license.
Public Method | Save | Overloaded. Saves the contents of the LicenseSigningKey to a file with the given file name.
Public Method | SignData |
Public Method | SignLicense | Signs the ExtendedLicense and sets the LicenseKey property
Public Method | SignResponse | Signs a response so that the originator of the message can be validated.
Public Method | ToXmlString | Gets the LicenseSigningKey as an XML strign.
Public Method | UpgradeVersion | Upgrades the keys to the format used by the specified version.
Public Method | ValidateLicense | Validates that the contents of the license has not been changed since it was signed.
Public Method | ValidateResponse | Validates a response signature.
Public Method | ValidateSerialNumber | Overloaded. Validates that a serial number was signed with the license key and falls within a given range of valid numbers.
Public Method | VerifyData |
Top

See Also

Reference

LicenseSigningKey Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LicenseSigningKey Constructor
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : LicenseSigningKey Constructor

Initializes a new instance of the LicenseSigningKey class.

Overload List

Overload | Description
LicenseSigningKey Constructor() | Initializes a new instance of the LicenseSigningKey class.
LicenseSigningKey Constructor(Stream) | Initializes a new instance of the LicenseSigningKey class with the key from the given Stream object.
LicenseSigningKey Constructor(String) | Initializes a new instance of the LicenseSigningKey class with the key from the given file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LicenseSigningKey Constructor()
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > LicenseSigningKey Constructor : LicenseSigningKey Constructor()

Initializes a new instance of the LicenseSigningKey class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey()
C#
public LicenseSigningKey()
Managed Extensions for C++
public: LicenseSigningKey();
C++/CLI
public:
LicenseSigningKey();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LicenseSigningKey Constructor(Stream)
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > LicenseSigningKey Constructor : LicenseSigningKey Constructor(Stream)

stream
The Stream object that contains the data.
Initializes a new instance of the LicenseSigningKey class with the key from the given Stream object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As LicenseSigningKey(stream)
C#
public LicenseSigningKey(
   Stream stream
)
Managed Extensions for C++
public: LicenseSigningKey(
   Stream* stream
)
C++/CLI
public:
LicenseSigningKey(
   Stream^ stream
)

Parameters

stream
The Stream object that contains the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LicenseSigningKey Constructor(String)
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > LicenseSigningKey Constructor : LicenseSigningKey Constructor(String)

filename
Path to the file where the LicenseSigningKey is saved.
Initializes a new instance of the LicenseSigningKey class with the key from the given file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim filename As String

Dim instance As LicenseSigningKey(filename)
C#
public LicenseSigningKey(
   string filename
)
Managed Extensions for C++
public: LicenseSigningKey(
   string* filename
)
C++/CLI
public:
LicenseSigningKey(
   String^ filename
)

Parameters

filename
Path to the file where the LicenseSigningKey is saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
LicenseSigningKey Class Methods
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

For a list of all members of this type, see LicenseSigningKey members.

Public Methods

 | Name | Description
Public Method | Decrypt | Decrypts the data using the key. Use Encrypt to encrypt values.
Public Method | DecryptString | Decrypts the data using the key. Use EncryptString to encrypt values.
Public Method | Dispose | Implements Dispose.
Public Method | Encrypt | Encrypts the data using the key. Use Decrypt to retrieve the encrypted value.
Public Method | EncryptString | Encrypts the data using the key. Use DecryptString to retrieve the encrypted value.
Public Method | Export | Overloaded. Saves the public key contents of the LicenseSigningKey to a file with the given file name.
Public Method | FromXmlString | Initializes the contents of the LicenseSigningKey from the XML string.
static (Shared in Visual Basic) | GetPublicKey | Gets the runtime.lic embedded in the assembly hosting the given type.
Public Method | GetSerialNumberSeed | Gets the original unmasked serial number seed (Int32 value) from the encoded value.
static (Shared in Visual Basic) | GetSigningKey | Overloaded. Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.
Public Method | Load | Overloaded. Loads the LicenseSigningKey with the contents of the given file.
Public Method | MakeSerialNumber | Overloaded. Makes an encoded serial number for the given license.
Public Method | Save | Overloaded. Saves the contents of the LicenseSigningKey to a file with the given file name.
Public Method | SignData |
Public Method | SignLicense | Signs the ExtendedLicense and sets the LicenseKey property
Public Method | SignResponse | Signs a response so that the originator of the message can be validated.
Public Method | ToXmlString | Gets the LicenseSigningKey as an XML strign.
Public Method | UpgradeVersion | Upgrades the keys to the format used by the specified version.
Public Method | ValidateLicense | Validates that the contents of the license has not been changed since it was signed.
Public Method | ValidateResponse | Validates a response signature.
Public Method | ValidateSerialNumber | Overloaded. Validates that a serial number was signed with the license key and falls within a given range of valid numbers.
Public Method | VerifyData |
Top

See Also

Reference

LicenseSigningKey Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Decrypt Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Decrypt Method

data
Data previously encrypted with Encrypt.
Decrypts the data using the key. Use Encrypt to encrypt values.

Syntax

Visual Basic (Declaration)
Public Function Decrypt( _
   ByVal data() As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim value() As Byte

value = instance.Decrypt(data)
C#
public byte[] Decrypt(
   byte[] data
)
Managed Extensions for C++
public: byte[] Decrypt(
   byte[] data
)
C++/CLI
public:
array<byte> Decrypt(
   array<byte> data
)

Parameters

data
Data previously encrypted with Encrypt.

Return Value

Returns the original value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
DecryptString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : DecryptString Method

data
Data previously encrypted with EncryptString.
Decrypts the data using the key. Use EncryptString to encrypt values.

Syntax

Visual Basic (Declaration)
Public Function DecryptString( _
   ByVal data() As Byte _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim value As String

value = instance.DecryptString(data)
C#
public string DecryptString(
   byte[] data
)
Managed Extensions for C++
public: string* DecryptString(
   byte[] data
)
C++/CLI
public:
String^ DecryptString(
   array<byte> data
)

Parameters

data
Data previously encrypted with EncryptString.

Return Value

Returns the original value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Dispose Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Dispose Method

Implements Dispose.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Encrypt Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Encrypt Method

data
The data to encrypt.
Encrypts the data using the key. Use Decrypt to retrieve the encrypted value.

Syntax

Visual Basic (Declaration)
Public Function Encrypt( _
   ByVal data() As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim value() As Byte

value = instance.Encrypt(data)
C#
public byte[] Encrypt(
   byte[] data
)
Managed Extensions for C++
public: byte[] Encrypt(
   byte[] data
)
C++/CLI
public:
array<byte> Encrypt(
   array<byte> data
)

Parameters

data
The data to encrypt.

Return Value

Returns the encrypted version of the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
EncryptString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : EncryptString Method

data
The data to encrypt.
Encrypts the data using the key. Use DecryptString to retrieve the encrypted value.

Syntax

Visual Basic (Declaration)
Public Function EncryptString( _
   ByVal data As String _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data As String
Dim value() As Byte

value = instance.EncryptString(data)
C#
public byte[] EncryptString(
   string data
)
Managed Extensions for C++
public: byte[] EncryptString(
   string* data
)
C++/CLI
public:
array<byte> EncryptString(
   String^ data
)

Parameters

data
The data to encrypt.

Return Value

Returns the encrypted version of the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Export Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Export Method

Saves the public key contents of the LicenseSigningKey to a file with the given file name.

Overload List

Overload | Description
Export(String) | Saves the public key contents of the LicenseSigningKey to a file with the given file name.
Export(Stream) | Saves the contents of the LicenseSigningKey to a Stream object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Export(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Export Method : Export(String) Method

filename
Path to the file where the LicenseSigningKey should be saved.
Saves the public key contents of the LicenseSigningKey to a file with the given file name.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Export( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim filename As String

instance.Export(filename)
C#
public void Export(
   string filename
)
Managed Extensions for C++
public: void Export(
   string* filename
)
C++/CLI
public:
void Export(
   String^ filename
)

Parameters

filename
Path to the file where the LicenseSigningKey should be saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Export(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Export Method : Export(Stream) Method

stream
The Stream object to receive the data.
Saves the contents of the LicenseSigningKey to a Stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Export( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim stream As Stream

instance.Export(stream)
C#
public void Export(
   Stream stream
)
Managed Extensions for C++
public: void Export(
   Stream* stream
)
C++/CLI
public:
void Export(
   Stream^ stream
)

Parameters

stream
The Stream object to receive the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : FromXmlString Method

xml
A string containing an XML representaion of the key.
Initializes the contents of the LicenseSigningKey from the XML string.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
A string containing an XML representaion of the key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetPublicKey Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : GetPublicKey Method

type
The reference type to use for obtaining the assembly.
Gets the runtime.lic embedded in the assembly hosting the given type.

Syntax

Visual Basic (Declaration)
Public Shared Function GetPublicKey( _
   ByVal type As Type _
) As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim type As Type
Dim value As LicenseSigningKey

value = LicenseSigningKey.GetPublicKey(type)
C#
public static LicenseSigningKey GetPublicKey(
   Type type
)
Managed Extensions for C++
public: static LicenseSigningKey* GetPublicKey(
   Type* type
)
C++/CLI
public:
static LicenseSigningKey^ GetPublicKey(
   Type^ type
)

Parameters

type
The reference type to use for obtaining the assembly.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetSerialNumberSeed Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : GetSerialNumberSeed Method

license
The license the serial number was generated for.
serialNumber
The masked serial number created by MakeSerialNumber.
Gets the original unmasked serial number seed (Int32 value) from the encoded value.

Syntax

Visual Basic (Declaration)
Public Function GetSerialNumberSeed( _
   ByVal license As ExtendedLicense, _
   ByVal serialNumber As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim serialNumber As String
Dim value As Integer

value = instance.GetSerialNumberSeed(license, serialNumber)
C#
public int GetSerialNumberSeed(
   ExtendedLicense license,
   string serialNumber
)
Managed Extensions for C++
public: int GetSerialNumberSeed(
   ExtendedLicense* license,
   string* serialNumber
)
C++/CLI
public:
int GetSerialNumberSeed(
   ExtendedLicense^ license,
   String^ serialNumber
)

Parameters

license
The license the serial number was generated for.
serialNumber
The masked serial number created by MakeSerialNumber.

Return Value

Returns the original Int32 seed value for the masked serial number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetSigningKey Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : GetSigningKey Method

Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.

Overload List

Overload | Description
GetSigningKey(String,String) | Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.
GetSigningKey(String) | Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetSigningKey(String,String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > GetSigningKey Method : GetSigningKey(String,String) Method

name
Name of the keys.
folder
Path to the folder where the keys are located.
Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function GetSigningKey( _
   ByVal name As String, _
   ByVal folder As String _
) As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim name As String
Dim folder As String
Dim value As LicenseSigningKey

value = LicenseSigningKey.GetSigningKey(name, folder)
C#
public static LicenseSigningKey GetSigningKey(
   string name,
   string folder
)
Managed Extensions for C++
public: static LicenseSigningKey* GetSigningKey(
   string* name,
   string* folder
)
C++/CLI
public:
static LicenseSigningKey^ GetSigningKey(
   String^ name,
   String^ folder
)

Parameters

name
Name of the keys.
folder
Path to the folder where the keys are located.

Return Value

Returns the signing key if found, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetSigningKey(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > GetSigningKey Method : GetSigningKey(String) Method

name
Name of the keys.
Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function GetSigningKey( _
   ByVal name As String _
) As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim name As String
Dim value As LicenseSigningKey

value = LicenseSigningKey.GetSigningKey(name)
C#
public static LicenseSigningKey GetSigningKey(
   string name
)
Managed Extensions for C++
public: static LicenseSigningKey* GetSigningKey(
   string* name
)
C++/CLI
public:
static LicenseSigningKey^ GetSigningKey(
   String^ name
)

Parameters

name
Name of the keys.

Return Value

Returns the signing key if found, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Load Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Load Method

Loads the LicenseSigningKey with the contents of the given file.

Overload List

Overload | Description
Load(String) | Loads the LicenseSigningKey with the contents of the given file.
Load(Stream) | Loads the LicenseSigningKey from a Stream object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Load(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Load Method : Load(String) Method

filename
Path to the file where the LicenseSigningKey is saved.
Loads the LicenseSigningKey with the contents of the given file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim filename As String

instance.Load(filename)
C#
public void Load(
   string filename
)
Managed Extensions for C++
public: void Load(
   string* filename
)
C++/CLI
public:
void Load(
   String^ filename
)

Parameters

filename
Path to the file where the LicenseSigningKey is saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Load(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Load Method : Load(Stream) Method

stream
The Stream object that contains the data.
Loads the LicenseSigningKey from a Stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim stream As Stream

instance.Load(stream)
C#
public void Load(
   Stream stream
)
Managed Extensions for C++
public: void Load(
   Stream* stream
)
C++/CLI
public:
void Load(
   Stream^ stream
)

Parameters

stream
The Stream object that contains the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MakeSerialNumber Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : MakeSerialNumber Method

Makes an encoded serial number for the given license.

Overload List

Overload | Description
MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32[],Int32) | Makes an encoded serial number for the given license.
MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32) | Makes an encoded serial number for the given license.
MakeSerialNumber(String,SerialNumberSizes,Int32[],Int32) | Makes an encoded serial number for the given license.
MakeSerialNumber(String,SerialNumberSizes,Int32) | Makes an encoded serial number for the given license.

Exceptions

Exception | Description
ExtendedLicenseException | Thrown when the license keys have not been upgraded to at least version 2.0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32[],Int32) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > MakeSerialNumber Method : MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32[],Int32) Method

license
The license to generate a serial number for.
size
The key size to use when encrypting the serial number.
groupSizes
Defines the group sizes used to split the serial number into smaller chunks. A null value will use the default sizes for the given key size.
seed
The serial number value to encode.
Makes an encoded serial number for the given license.

Syntax

Visual Basic (Declaration)
Overloads Public Function MakeSerialNumber( _
   ByVal license As ExtendedLicense, _
   ByVal size As SerialNumberSizes, _
   ByVal groupSizes() As Integer, _
   ByVal seed As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim size As SerialNumberSizes
Dim groupSizes() As Integer
Dim seed As Integer
Dim value As String

value = instance.MakeSerialNumber(license, size, groupSizes, seed)
C#
public string MakeSerialNumber(
   ExtendedLicense license,
   SerialNumberSizes size,
   int[] groupSizes,
   int seed
)
Managed Extensions for C++
public: string* MakeSerialNumber(
   ExtendedLicense* license,
   SerialNumberSizes size,
   int[] groupSizes,
   int seed
)
C++/CLI
public:
String^ MakeSerialNumber(
   ExtendedLicense^ license,
   SerialNumberSizes size,
   array<int> groupSizes,
   int seed
)

Parameters

license
The license to generate a serial number for.
size
The key size to use when encrypting the serial number.
groupSizes
Defines the group sizes used to split the serial number into smaller chunks. A null value will use the default sizes for the given key size.
seed
The serial number value to encode.

Return Value

Returns a new serial number encrypted with the key.

Exceptions

Exception | Description
ExtendedLicenseException | Thrown when the license keys have not been upgraded to at least version 2.0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > MakeSerialNumber Method : MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32) Method

license
The license to generate a serial number for.
size
The key size to use when encrypting the serial number.
seed
The serial number value to encode.
Makes an encoded serial number for the given license.

Syntax

Visual Basic (Declaration)
Overloads Public Function MakeSerialNumber( _
   ByVal license As ExtendedLicense, _
   ByVal size As SerialNumberSizes, _
   ByVal seed As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim size As SerialNumberSizes
Dim seed As Integer
Dim value As String

value = instance.MakeSerialNumber(license, size, seed)
C#
public string MakeSerialNumber(
   ExtendedLicense license,
   SerialNumberSizes size,
   int seed
)
Managed Extensions for C++
public: string* MakeSerialNumber(
   ExtendedLicense* license,
   SerialNumberSizes size,
   int seed
)
C++/CLI
public:
String^ MakeSerialNumber(
   ExtendedLicense^ license,
   SerialNumberSizes size,
   int seed
)

Parameters

license
The license to generate a serial number for.
size
The key size to use when encrypting the serial number.
seed
The serial number value to encode.

Return Value

Returns a new serial number encrypted with the key.

Exceptions

Exception | Description
ExtendedLicenseException | Thrown when the license keys have not been upgraded to at least version 2.0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MakeSerialNumber(String,SerialNumberSizes,Int32[],Int32) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > MakeSerialNumber Method : MakeSerialNumber(String,SerialNumberSizes,Int32[],Int32) Method

prefix
The prefix to add to the serial number. It must match the AbsoluteSerialNumber of the license it will be assigned to.
size
The key size to use when encrypting the serial number.
groupSizes
Defines the group sizes used to split the serial number into smaller chunks. A null value will use the default sizes for the given key size.
seed
The serial number value to encode.
Makes an encoded serial number for the given license.

Syntax

Visual Basic (Declaration)
Overloads Public Function MakeSerialNumber( _
   ByVal prefix As String, _
   ByVal size As SerialNumberSizes, _
   ByVal groupSizes() As Integer, _
   ByVal seed As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim prefix As String
Dim size As SerialNumberSizes
Dim groupSizes() As Integer
Dim seed As Integer
Dim value As String

value = instance.MakeSerialNumber(prefix, size, groupSizes, seed)
C#
public string MakeSerialNumber(
   string prefix,
   SerialNumberSizes size,
   int[] groupSizes,
   int seed
)
Managed Extensions for C++
public: string* MakeSerialNumber(
   string* prefix,
   SerialNumberSizes size,
   int[] groupSizes,
   int seed
)
C++/CLI
public:
String^ MakeSerialNumber(
   String^ prefix,
   SerialNumberSizes size,
   array<int> groupSizes,
   int seed
)

Parameters

prefix
The prefix to add to the serial number. It must match the AbsoluteSerialNumber of the license it will be assigned to.
size
The key size to use when encrypting the serial number.
groupSizes
Defines the group sizes used to split the serial number into smaller chunks. A null value will use the default sizes for the given key size.
seed
The serial number value to encode.

Return Value

Returns a new serial number encrypted with the key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MakeSerialNumber(String,SerialNumberSizes,Int32) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > MakeSerialNumber Method : MakeSerialNumber(String,SerialNumberSizes,Int32) Method

prefix
The prefix to add to the serial number. It must match the AbsoluteSerialNumber of the license it will be assigned to.
size
The key size to use when encrypting the serial number.
seed
The serial number value to encode.
Makes an encoded serial number for the given license.

Syntax

Visual Basic (Declaration)
Overloads Public Function MakeSerialNumber( _
   ByVal prefix As String, _
   ByVal size As SerialNumberSizes, _
   ByVal seed As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim prefix As String
Dim size As SerialNumberSizes
Dim seed As Integer
Dim value As String

value = instance.MakeSerialNumber(prefix, size, seed)
C#
public string MakeSerialNumber(
   string prefix,
   SerialNumberSizes size,
   int seed
)
Managed Extensions for C++
public: string* MakeSerialNumber(
   string* prefix,
   SerialNumberSizes size,
   int seed
)
C++/CLI
public:
String^ MakeSerialNumber(
   String^ prefix,
   SerialNumberSizes size,
   int seed
)

Parameters

prefix
The prefix to add to the serial number. It must match the AbsoluteSerialNumber of the license it will be assigned to.
size
The key size to use when encrypting the serial number.
seed
The serial number value to encode.

Return Value

Returns a new serial number encrypted with the key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Save Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Save Method

Saves the contents of the LicenseSigningKey to a file with the given file name.

Overload List

Overload | Description
Save(String,Boolean) | Saves the contents of the LicenseSigningKey to a file with the given file name.
Save(String) | Saves the contents of the LicenseSigningKey to a file with the given file name.
Save(Stream,Boolean) | Saves the contents of the LicenseSigningKey to a Stream object.
Save(Stream) | Saves the contents of the LicenseSigningKey to a Stream object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Save(String,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Save Method : Save(String,Boolean) Method

filename
Path to the file where the LicenseSigningKey should be saved.
includePrivateData
Indicates if the private portion of the key should be included.
Saves the contents of the LicenseSigningKey to a file with the given file name.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal filename As String, _
   ByVal includePrivateData As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim filename As String
Dim includePrivateData As Boolean

instance.Save(filename, includePrivateData)
C#
public void Save(
   string filename,
   bool includePrivateData
)
Managed Extensions for C++
public: void Save(
   string* filename,
   bool includePrivateData
)
C++/CLI
public:
void Save(
   String^ filename,
   bool includePrivateData
)

Parameters

filename
Path to the file where the LicenseSigningKey should be saved.
includePrivateData
Indicates if the private portion of the key should be included.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Save(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Save Method : Save(String) Method

filename
Path to the file where the LicenseSigningKey should be saved.
Saves the contents of the LicenseSigningKey to a file with the given file name.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim filename As String

instance.Save(filename)
C#
public void Save(
   string filename
)
Managed Extensions for C++
public: void Save(
   string* filename
)
C++/CLI
public:
void Save(
   String^ filename
)

Parameters

filename
Path to the file where the LicenseSigningKey should be saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Save(Stream,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Save Method : Save(Stream,Boolean) Method

stream
The Stream object to receive the data.
includePrivateData
Indicates if the private portion of the key should be included.
Saves the contents of the LicenseSigningKey to a Stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream, _
   ByVal includePrivateData As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim stream As Stream
Dim includePrivateData As Boolean

instance.Save(stream, includePrivateData)
C#
public void Save(
   Stream stream,
   bool includePrivateData
)
Managed Extensions for C++
public: void Save(
   Stream* stream,
   bool includePrivateData
)
C++/CLI
public:
void Save(
   Stream^ stream,
   bool includePrivateData
)

Parameters

stream
The Stream object to receive the data.
includePrivateData
Indicates if the private portion of the key should be included.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Save(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Save Method : Save(Stream) Method

stream
The Stream object to receive the data.
Saves the contents of the LicenseSigningKey to a Stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim stream As Stream

instance.Save(stream)
C#
public void Save(
   Stream stream
)
Managed Extensions for C++
public: void Save(
   Stream* stream
)
C++/CLI
public:
void Save(
   Stream^ stream
)

Parameters

stream
The Stream object to receive the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SignData Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : SignData Method

data

Syntax

Visual Basic (Declaration)
Public Function SignData( _
   ByVal data() As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim value() As Byte

value = instance.SignData(data)
C#
public byte[] SignData(
   byte[] data
)
Managed Extensions for C++
public: byte[] SignData(
   byte[] data
)
C++/CLI
public:
array<byte> SignData(
   array<byte> data
)

Parameters

data

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SignLicense Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : SignLicense Method

license
Signs the ExtendedLicense and sets the LicenseKey property

Syntax

Visual Basic (Declaration)
Public Sub SignLicense( _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense

instance.SignLicense(license)
C#
public void SignLicense(
   ExtendedLicense license
)
Managed Extensions for C++
public: void SignLicense(
   ExtendedLicense* license
)
C++/CLI
public:
void SignLicense(
   ExtendedLicense^ license
)

Parameters

license

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SignResponse Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : SignResponse Method

response
The response to sign.
Signs a response so that the originator of the message can be validated.

Syntax

Visual Basic (Declaration)
Public Function SignResponse( _
   ByVal response As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim response As String
Dim value As String

value = instance.SignResponse(response)
C#
public string SignResponse(
   string response
)
Managed Extensions for C++
public: string* SignResponse(
   string* response
)
C++/CLI
public:
String^ SignResponse(
   String^ response
)

Parameters

response
The response to sign.

Return Value

Returns a signature for the response.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : ToXmlString Method

includePrivateData
Indicates if the private data shouls be included.
Gets the LicenseSigningKey as an XML strign.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString( _
   ByVal includePrivateData As Boolean _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim includePrivateData As Boolean
Dim value As String

value = instance.ToXmlString(includePrivateData)
C#
public string ToXmlString(
   bool includePrivateData
)
Managed Extensions for C++
public: string* ToXmlString(
   bool includePrivateData
)
C++/CLI
public:
String^ ToXmlString(
   bool includePrivateData
)

Parameters

includePrivateData
Indicates if the private data shouls be included.

Return Value

Returns an XML string representation of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UpgradeVersion Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : UpgradeVersion Method

version
The version to upgrade to.
Upgrades the keys to the format used by the specified version.

Syntax

Visual Basic (Declaration)
Public Sub UpgradeVersion( _
   ByVal version As Version _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim version As Version

instance.UpgradeVersion(version)
C#
public void UpgradeVersion(
   Version version
)
Managed Extensions for C++
public: void UpgradeVersion(
   Version* version
)
C++/CLI
public:
void UpgradeVersion(
   Version^ version
)

Parameters

version
The version to upgrade to.

Remarks

The changes should be saved over the existing keys and the public key re-exported after the upgrade.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ValidateLicense Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : ValidateLicense Method

license
The license to validate.
Validates that the contents of the license has not been changed since it was signed.

Syntax

Visual Basic (Declaration)
Public Function ValidateLicense( _
   ByVal license As ExtendedLicense _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim value As Boolean

value = instance.ValidateLicense(license)
C#
public bool ValidateLicense(
   ExtendedLicense license
)
Managed Extensions for C++
public: bool ValidateLicense(
   ExtendedLicense* license
)
C++/CLI
public:
bool ValidateLicense(
   ExtendedLicense^ license
)

Parameters

license
The license to validate.

Return Value

Returns true if the contents of the license have not been changed, otherwise false.

Remarks

You must use the same LicenseSigningKey to validate the license as you did to sign it. You can use either the full public/private key or just the public key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ValidateResponse Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : ValidateResponse Method

response
The original response.
signature
The signature generated from SignResponse.
Validates a response signature.

Syntax

Visual Basic (Declaration)
Public Function ValidateResponse( _
   ByVal response As String, _
   ByVal signature As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim response As String
Dim signature As String
Dim value As Boolean

value = instance.ValidateResponse(response, signature)
C#
public bool ValidateResponse(
   string response,
   string signature
)
Managed Extensions for C++
public: bool ValidateResponse(
   string* response,
   string* signature
)
C++/CLI
public:
bool ValidateResponse(
   String^ response,
   String^ signature
)

Parameters

response
The original response.
signature
The signature generated from SignResponse.

Return Value

Returns true if the signature and response match.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ValidateSerialNumber Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : ValidateSerialNumber Method

Validates that a serial number was signed with the license key and falls within a given range of valid numbers.

Overload List

Overload | Description
ValidateSerialNumber(ExtendedLicense,String) | Validates that a serial number was signed with the license key and falls within a given range of valid numbers.
ValidateSerialNumber(String,String,Int32,Int32,SerialNumberSizes) | Validates that a serial number was signed with the license key and falls within a given range of valid numbers.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ValidateSerialNumber(ExtendedLicense,String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > ValidateSerialNumber Method : ValidateSerialNumber(ExtendedLicense,String) Method

license
The license the seral number is checked against.
serialNumber
The serial number to check.
Validates that a serial number was signed with the license key and falls within a given range of valid numbers.

Syntax

Visual Basic (Declaration)
Overloads Public Function ValidateSerialNumber( _
   ByVal license As ExtendedLicense, _
   ByVal serialNumber As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim serialNumber As String
Dim value As Boolean

value = instance.ValidateSerialNumber(license, serialNumber)
C#
public bool ValidateSerialNumber(
   ExtendedLicense license,
   string serialNumber
)
Managed Extensions for C++
public: bool ValidateSerialNumber(
   ExtendedLicense* license,
   string* serialNumber
)
C++/CLI
public:
bool ValidateSerialNumber(
   ExtendedLicense^ license,
   String^ serialNumber
)

Parameters

license
The license the seral number is checked against.
serialNumber
The serial number to check.

Return Value

Returns true of the serial number is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ValidateSerialNumber(String,String,Int32,Int32,SerialNumberSizes) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > ValidateSerialNumber Method : ValidateSerialNumber(String,String,Int32,Int32,SerialNumberSizes) Method

prefix
The serial number prefix required.
serialNumber
The serial number to check.
minAcceptedSeed
The minimum acceptable seed value.
maxAcceptedSeed
The maximim acceptable seed value.
acceptedSizes
The accepted serial number sizes.
Validates that a serial number was signed with the license key and falls within a given range of valid numbers.

Syntax

Visual Basic (Declaration)
Overloads Public Function ValidateSerialNumber( _
   ByVal prefix As String, _
   ByVal serialNumber As String, _
   ByVal minAcceptedSeed As Integer, _
   ByVal maxAcceptedSeed As Integer, _
   ByVal acceptedSizes As SerialNumberSizes _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim prefix As String
Dim serialNumber As String
Dim minAcceptedSeed As Integer
Dim maxAcceptedSeed As Integer
Dim acceptedSizes As SerialNumberSizes
Dim value As Boolean

value = instance.ValidateSerialNumber(prefix, serialNumber, minAcceptedSeed, maxAcceptedSeed, acceptedSizes)
C#
public bool ValidateSerialNumber(
   string prefix,
   string serialNumber,
   int minAcceptedSeed,
   int maxAcceptedSeed,
   SerialNumberSizes acceptedSizes
)
Managed Extensions for C++
public: bool ValidateSerialNumber(
   string* prefix,
   string* serialNumber,
   int minAcceptedSeed,
   int maxAcceptedSeed,
   SerialNumberSizes acceptedSizes
)
C++/CLI
public:
bool ValidateSerialNumber(
   String^ prefix,
   String^ serialNumber,
   int minAcceptedSeed,
   int maxAcceptedSeed,
   SerialNumberSizes acceptedSizes
)

Parameters

prefix
The serial number prefix required.
serialNumber
The serial number to check.
minAcceptedSeed
The minimum acceptable seed value.
maxAcceptedSeed
The maximim acceptable seed value.
acceptedSizes
The accepted serial number sizes.

Return Value

Returns true of the serial number is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
VerifyData Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : VerifyData Method

data
signature

Syntax

Visual Basic (Declaration)
Public Function VerifyData( _
   ByVal data() As Byte, _
   ByVal signature() As Byte _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim signature() As Byte
Dim value As Boolean

value = instance.VerifyData(data, signature)
C#
public bool VerifyData(
   byte[] data,
   byte[] signature
)
Managed Extensions for C++
public: bool VerifyData(
   byte[] data,
   byte[] signature
)
C++/CLI
public:
bool VerifyData(
   array<byte> data,
   array<byte> signature
)

Parameters

data
signature

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
LicenseSigningKey Class Properties
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

For a list of all members of this type, see LicenseSigningKey members.

Public Properties

 | Name | Description
Public Property | IsGlobalKey | Gets a value that indicates if the keys are the global keys used during the trial.
Public Property | Location | Gets the location where the keys were loaded from.
Public Property | Version | Gets or sets the version of the signing key.
Top

See Also

Reference

LicenseSigningKey Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsGlobalKey Property
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : IsGlobalKey Property

Gets a value that indicates if the keys are the global keys used during the trial.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsGlobalKey As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim value As Boolean

value = instance.IsGlobalKey
C#
public bool IsGlobalKey {get;}
Managed Extensions for C++
public: __property bool get_IsGlobalKey();
C++/CLI
public:
property bool IsGlobalKey {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Location Property
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Location Property

Gets the location where the keys were loaded from.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim value As String

value = instance.Location
C#
public string Location {get;}
Managed Extensions for C++
public: __property string* get_Location();
C++/CLI
public:
property String^ Location {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Version Property
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Version Property

Gets or sets the version of the signing key.

Syntax

Visual Basic (Declaration)
Public Property Version As Version
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim value As Version

instance.Version = value

value = instance.Version
C#
public Version Version {get; set;}
Managed Extensions for C++
public: __property Version* get_Version();
public: __property void set_Version(
   Version* value
);
C++/CLI
public:
property Version^ Version {
   Version^ get();
   void set (Version^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%% $$Fields$$

Barcode4NET Send comments on this topic.
LicenseSigningKey Class Fields
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

For a list of all members of this type, see LicenseSigningKey members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CurrentVersion | The current version of the LicenseSigningKey class.
Top

See Also

Reference

LicenseSigningKey Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
CurrentVersion Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : CurrentVersion Field

The current version of the LicenseSigningKey class.

Syntax

Visual Basic (Declaration)
Public Shared CurrentVersion As Version
Visual Basic (Usage) Copy Code
Dim value As Version

value = LicenseSigningKey.CurrentVersion

LicenseSigningKey.CurrentVersion = value
C#
public static Version CurrentVersion
Managed Extensions for C++
public: static Version* CurrentVersion
C++/CLI
public:
static Version^ CurrentVersion

Remarks

Later versions may introduce a new signing/file scheme. To maintain backwards compatability the keys are versioned.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LicenseValuesCollection Class
See Also Members
[image]
Xheo.Licensing Namespace : LicenseValuesCollection Class

Maintains a collection of name value pairs. The collection can be serialized and marked as read only.

Syntax

Visual Basic (Declaration)
Private Class LicenseValuesCollection
   Inherits NameValueCollection
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
C#
private class LicenseValuesCollection : NameValueCollection
Managed Extensions for C++
private __gc class LicenseValuesCollection : public NameValueCollection
C++/CLI
private ref class LicenseValuesCollection : public NameValueCollection

Inheritance Hierarchy

System.Object
System.Collections.Specialized.NameObjectCollectionBase
System.Collections.Specialized.NameValueCollection
Xheo.Licensing.LicenseValuesCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
LicenseValuesCollection Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : LicenseValuesCollection Class

The following tables list the members exposed by LicenseValuesCollection.

Public Constructors

 | Name | Description
Public Constructor | LicenseValuesCollection Constructor | Initializes a new instance of the LicenseValuesCollection class.
Top

Public Properties

 | Name | Description
Public Property | AllKeys | Gets all the keys in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Property | Count | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Property | Item | Overloaded. Gets or sets the entry with the specified key in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Property | Keys | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Included for serialization compatability, do not use.
Public Method | Clear | Invalidates the cached arrays and removes all entries from the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | CopyTo | Copies the entire NameValueCollection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | FromXmlString | Loads the values from an XML string.
Public Method | Get | Overloaded. Gets the values associated with the specified key from the NameValueCollection combined into one comma-separated list. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | GetEnumerator | Returns an enumerator that iterates through the NameObjectCollectionBase. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetKey | Gets the key at the specified index of the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetValues | Overloaded. Gets the values associated with the specified key from the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | HasKeys | Gets a value indicating whether the NameValueCollection contains keys that are not null. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | LoadFromXml | Loades the contents of the collection from the XmlNode.
Public Method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | Remove | Removes the entries with the specified key from the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | SaveToXml | Saves the contents of the collection to the parent XmlNode.
Public Method | Set | Sets the value of an entry in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | ToXmlString | Converts the collection to an XML string representation.
Top

See Also

Reference

LicenseValuesCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LicenseValuesCollection Constructor
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : LicenseValuesCollection Constructor

Initializes a new instance of the LicenseValuesCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection()
C#
public LicenseValuesCollection()
Managed Extensions for C++
public: LicenseValuesCollection();
C++/CLI
public:
LicenseValuesCollection();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
LicenseValuesCollection Class Methods
See Also
[image]
Xheo.Licensing Namespace : LicenseValuesCollection Class

For a list of all members of this type, see LicenseValuesCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Included for serialization compatability, do not use.
Public Method | Clear | Invalidates the cached arrays and removes all entries from the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | CopyTo | Copies the entire NameValueCollection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | FromXmlString | Loads the values from an XML string.
Public Method | Get | Overloaded. Gets the values associated with the specified key from the NameValueCollection combined into one comma-separated list. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | GetEnumerator | Returns an enumerator that iterates through the NameObjectCollectionBase. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetKey | Gets the key at the specified index of the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetValues | Overloaded. Gets the values associated with the specified key from the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | HasKeys | Gets a value indicating whether the NameValueCollection contains keys that are not null. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | LoadFromXml | Loades the contents of the collection from the XmlNode.
Public Method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | Remove | Removes the entries with the specified key from the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | SaveToXml | Saves the contents of the collection to the parent XmlNode.
Public Method | Set | Sets the value of an entry in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | ToXmlString | Converts the collection to an XML string representation.
Top

See Also

Reference

LicenseValuesCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Add Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : Add Method

Included for serialization compatability, do not use.

Overload List

Overload | Description
Add(String) | Included for serialization compatability, do not use.
Add(NameValueCollection) | Copies the entries in the specified NameValueCollection to the current NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Add(String,String) | Adds an entry with the specified name and value to the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Add(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class > Add Method : Add(String) Method

value
Included for serialization compatability, do not use.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim value As String

instance.Add(value)
C#
public void Add(
   string value
)
Managed Extensions for C++
public: void Add(
   string* value
)
C++/CLI
public:
void Add(
   String^ value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : FromXmlString Method

xml
The XML document string containing the values collection.
Loads the values from an XML string.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
The XML document string containing the values collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : LoadFromXml Method

parentNode
The root XmlNode containing the collection.
Loades the contents of the collection from the XmlNode.

Syntax

Visual Basic (Declaration)
Public Sub LoadFromXml( _
   ByVal parentNode As XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim parentNode As XmlNode

instance.LoadFromXml(parentNode)
C#
public void LoadFromXml(
   XmlNode parentNode
)
Managed Extensions for C++
public: void LoadFromXml(
   XmlNode parentNode
)
C++/CLI
public:
void LoadFromXml(
   XmlNode parentNode
)

Parameters

parentNode
The root XmlNode containing the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : SaveToXml Method

parentNode
The XmlNode to save the collection to.
Saves the contents of the collection to the parent XmlNode.

Syntax

Visual Basic (Declaration)
Public Function SaveToXml( _
   ByVal parentNode As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim parentNode As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parentNode)
C#
public XmlNode SaveToXml(
   XmlNode parentNode
)
Managed Extensions for C++
public: XmlNode SaveToXml(
   XmlNode parentNode
)
C++/CLI
public:
XmlNode SaveToXml(
   XmlNode parentNode
)

Parameters

parentNode
The XmlNode to save the collection to.

Return Value

Returns the root node of the saved collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : ToXmlString Method

Converts the collection to an XML string representation.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim value As String

value = instance.ToXmlString()
C#
public string ToXmlString()
Managed Extensions for C++
public: string* ToXmlString();
C++/CLI
public:
String^ ToXmlString();

Return Value

Returns the collection as an XML document string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Limit Class
See Also Members
[image]
Xheo.Licensing Namespace : Limit Class

Base class for all license limitations.

Object Model

Syntax

Visual Basic (Declaration)
Private MustInherit Class Limit
   Inherits MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As Limit
C#
private abstract class Limit : MarshalByRefObject
Managed Extensions for C++
private __gc abstract class Limit : public MarshalByRefObject
C++/CLI
private ref class Limit abstract : public MarshalByRefObject

Remarks

Limits are used by the XHEO|Licensing framework to restrict a Component, Class or Control to a specific set of runtime or designtime conditions. The library contains over 15 built in limits that you can use to control the use of your protected Type.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Xheo.Licensing.Limit
Xheo.Licensing.ContainerLimit
Xheo.Licensing.ContainerLimit
Xheo.Licensing.ContainerLimit
Xheo.Licensing.ContainerLimit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
Limit Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : Limit Class

The following tables list the members exposed by Limit.

Public Properties

 | Name | Description
Public Property | Description | Gets the description of the limit.
Public Property | IsGui | Gets a value that indicates if this Limit uses a GUI to interact with the user.
Public Property | IsRemote | Gets a value that indicates if this Limit uses remote processes (such as WebServices) for enforcement.
Public Property | IsTimeSensitive | Gets a value that indicates if the limit is time sensitive and the clock should be protected.
Public Property | License | Gets or sets a reference to the ExtendedLicense that contains this Limit.
Public Property | Name | Gets the display name of the limit.
Public Property | QualifiedTypeName | Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type.
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases any managed or unmangaged resources used by the limit.
static (Shared in Visual Basic) | GetBitmapResource | Gets an Image for the requested resource. Resources can be defined as assembly resources or as remote resources. If the name is prefixed with http then it is assumed to be a remote resource and a WebRequest is made to retrieve the bitmap, otherwise it is assumed to be embedded in the assembly.
Public Method | GetDetailsDescription | Gets a description of the details of the limit.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | GetLimitFromName | Gets a Limit object based on the given name.
static (Shared in Visual Basic) | GetPrivateRegistryKey | Gets a private registry key where values for the license can be stored for the given type.
Public Method | Granted | Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | LoadFromXml | Loads the contents of a Limit from an XmlNode.
static (Shared in Visual Basic) | MaskValue | Performs a simple value obfuscation to make editing client side values more difficult. This is by no means secure.
static (Shared in Visual Basic) | OpenOrCreateRegistryKey | Opens or creates a registry key.
static (Shared in Visual Basic) | ParseIPAddress | Parses an IPAddress to it's actual long value.
Public Method | Peek | Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user.
Public Method | SaveToXml | Saves the contents of the Limit as an XmlNode.
static (Shared in Visual Basic) | SelectCulture | Selects the given culture for the current thread, and returns the previous culture.
static (Shared in Visual Basic) | SelectWebCulture | Selects the culture of the current web request into the current thread, and returns the previous culture.
static (Shared in Visual Basic) | UnmaskValue | Reverses the simple value obfuscation performed by MaskValue.
Public Method | Validate | Validates that the license being granted is within the limits enforced by this object.
static (Shared in Visual Basic) | ValidateDomainName | Validates the format of a domain name.
static (Shared in Visual Basic) | ValidateEmail | Validates if the email is correctly formatted.
static (Shared in Visual Basic) | ValidateIPAddress | Validates the format of an IP address.
static (Shared in Visual Basic) | ValidateUrl | Validates the url is correctly formatted.
Top

See Also

Reference

Limit Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
Limit Class Methods
See Also
[image]
Xheo.Licensing Namespace : Limit Class

For a list of all members of this type, see Limit members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases any managed or unmangaged resources used by the limit.
static (Shared in Visual Basic) | GetBitmapResource | Gets an Image for the requested resource. Resources can be defined as assembly resources or as remote resources. If the name is prefixed with http then it is assumed to be a remote resource and a WebRequest is made to retrieve the bitmap, otherwise it is assumed to be embedded in the assembly.
Public Method | GetDetailsDescription | Gets a description of the details of the limit.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | GetLimitFromName | Gets a Limit object based on the given name.
static (Shared in Visual Basic) | GetPrivateRegistryKey | Gets a private registry key where values for the license can be stored for the given type.
Public Method | Granted | Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | LoadFromXml | Loads the contents of a Limit from an XmlNode.
static (Shared in Visual Basic) | MaskValue | Performs a simple value obfuscation to make editing client side values more difficult. This is by no means secure.
static (Shared in Visual Basic) | OpenOrCreateRegistryKey | Opens or creates a registry key.
static (Shared in Visual Basic) | ParseIPAddress | Parses an IPAddress to it's actual long value.
Public Method | Peek | Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user.
Public Method | SaveToXml | Saves the contents of the Limit as an XmlNode.
static (Shared in Visual Basic) | SelectCulture | Selects the given culture for the current thread, and returns the previous culture.
static (Shared in Visual Basic) | SelectWebCulture | Selects the culture of the current web request into the current thread, and returns the previous culture.
static (Shared in Visual Basic) | UnmaskValue | Reverses the simple value obfuscation performed by MaskValue.
Public Method | Validate | Validates that the license being granted is within the limits enforced by this object.
static (Shared in Visual Basic) | ValidateDomainName | Validates the format of a domain name.
static (Shared in Visual Basic) | ValidateEmail | Validates if the email is correctly formatted.
static (Shared in Visual Basic) | ValidateIPAddress | Validates the format of an IP address.
static (Shared in Visual Basic) | ValidateUrl | Validates the url is correctly formatted.
Top

See Also

Reference

Limit Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Dispose Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Dispose Method

Releases any managed or unmangaged resources used by the limit.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As Limit

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetBitmapResource Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : GetBitmapResource Method

bitmapResource
Name of the resource to retrieve, prefix with http to get a remote resource.
limit
The limit requesting the resource.
parameters
Collection of additional parameters to append to the URL for remote images. Parameters should be in the format "key=value".
Gets an Image for the requested resource. Resources can be defined as assembly resources or as remote resources. If the name is prefixed with http then it is assumed to be a remote resource and a WebRequest is made to retrieve the bitmap, otherwise it is assumed to be embedded in the assembly.

Syntax

Visual Basic (Declaration)
Public Shared Function GetBitmapResource( _
   ByVal bitmapResource As String, _
   ByVal limit As Limit, _
   ByVal ParamArray parameters() As String _
) As Bitmap
Visual Basic (Usage) Copy Code
Dim bitmapResource As String
Dim limit As Limit
Dim parameters() As String
Dim value As Bitmap

value = Limit.GetBitmapResource(bitmapResource, limit, parameters)
C#
public static Bitmap GetBitmapResource(
   string bitmapResource,
   Limit limit,
   params string[] parameters
)
Managed Extensions for C++
public: static Bitmap GetBitmapResource(
   string* bitmapResource,
   Limit* limit,
   params string*[] parameters
)
C++/CLI
public:
static Bitmap GetBitmapResource(
   String^ bitmapResource,
   Limit^ limit,
   ... array<String^> parameters
)

Parameters

bitmapResource
Name of the resource to retrieve, prefix with http to get a remote resource.
limit
The limit requesting the resource.
parameters
Collection of additional parameters to append to the URL for remote images. Parameters should be in the format "key=value".

Return Value

Returns the resource if found, otherwise null.

Remarks

For remote resources the serial number, expiration date, and optional parameters of the License will be appended to the request QueryString. You can use this to provide alternate images based on the conditions of the license.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetDetailsDescription Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : GetDetailsDescription Method

Gets a description of the details of the limit.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetDetailsDescription() As String
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As String

value = instance.GetDetailsDescription()
C#
public virtual string GetDetailsDescription()
Managed Extensions for C++
public: virtual string* GetDetailsDescription();
C++/CLI
public:
virtual String^ GetDetailsDescription();

Return Value

Returns the description.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetLimitFromName Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : GetLimitFromName Method

name
The name of the limit type to retrieve.
Gets a Limit object based on the given name.

Syntax

Visual Basic (Declaration)
Public Shared Function GetLimitFromName( _
   ByVal name As String _
) As Limit
Visual Basic (Usage) Copy Code
Dim name As String
Dim value As Limit

value = Limit.GetLimitFromName(name)
C#
public static Limit GetLimitFromName(
   string name
)
Managed Extensions for C++
public: static Limit* GetLimitFromName(
   string* name
)
C++/CLI
public:
static Limit^ GetLimitFromName(
   String^ name
)

Parameters

name
The name of the limit type to retrieve.

Return Value

Returns a new Limit object of the given type if available, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetPrivateRegistryKey Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : GetPrivateRegistryKey Method

key
A unique key to identify this registry section.
mustExist
Indicates if the key must already exist.
created
Accepts a value that indicates if the key was created.
Gets a private registry key where values for the license can be stored for the given type.

Syntax

Visual Basic (Declaration)
Public Shared Function GetPrivateRegistryKey( _
   ByVal key As String, _
   ByVal mustExist As Boolean, _
   ByRef created As Boolean _
) As RegistryKey
Visual Basic (Usage) Copy Code
Dim key As String
Dim mustExist As Boolean
Dim created As Boolean
Dim value As RegistryKey

value = Limit.GetPrivateRegistryKey(key, mustExist, created)
C#
public static RegistryKey GetPrivateRegistryKey(
   string key,
   bool mustExist,
   out bool created
)
Managed Extensions for C++
public: static RegistryKey* GetPrivateRegistryKey(
   string* key,
   bool mustExist,
   [PARAMFLAG::Out] bool created
)
C++/CLI
public:
static RegistryKey^ GetPrivateRegistryKey(
   String^ key,
   bool mustExist,
   [PARAMFLAG::Out] bool created
)

Parameters

key
A unique key to identify this registry section.
mustExist
Indicates if the key must already exist.
created
Accepts a value that indicates if the key was created.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Granted Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Granted Method

context
The LicenseContext used to determine the environment and settings of the licensing.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Granted( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim context As LicenseContext
Dim type As Type
Dim instance As Object

instance.Granted(context, type, instance)
C#
public virtual void Granted(
   LicenseContext context,
   Type type,
   object instance
)
Managed Extensions for C++
public: virtual void Granted(
   LicenseContext context,
   Type* type,
   Object* instance
)
C++/CLI
public:
virtual void Granted(
   LicenseContext context,
   Type^ type,
   Object^ instance
)

Parameters

context
The LicenseContext used to determine the environment and settings of the licensing.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.

Remarks

Checks in this method should be very fast because they are called every time a licensed object is created. The default implementation does nothing.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : LoadFromXml Method

node
The XmlNode to load from.
Loads the contents of a Limit from an XmlNode.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride Function LoadFromXml( _
   ByVal node As XmlNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim node As XmlNode
Dim value As Boolean

value = instance.LoadFromXml(node)
C#
public virtual abstract bool LoadFromXml(
   XmlNode node
)
Managed Extensions for C++
public: virtual abstract bool LoadFromXml(
   XmlNode node
)
C++/CLI
public:
virtual abstract bool LoadFromXml(
   XmlNode node
)

Parameters

node
The XmlNode to load from.

Return Value

Returns true if the load was successful, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MaskValue Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : MaskValue Method

source
The original value.
Performs a simple value obfuscation to make editing client side values more difficult. This is by no means secure.

Syntax

Visual Basic (Declaration)
Public Shared Function MaskValue( _
   ByVal source As String _
) As String
Visual Basic (Usage) Copy Code
Dim source As String
Dim value As String

value = Limit.MaskValue(source)
C#
public static string MaskValue(
   string source
)
Managed Extensions for C++
public: static string* MaskValue(
   string* source
)
C++/CLI
public:
static String^ MaskValue(
   String^ source
)

Parameters

source
The original value.

Return Value

Returns the masked version of the value. Call UnmaskValue to obtain the original value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
OpenOrCreateRegistryKey Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : OpenOrCreateRegistryKey Method

key
The parent key to open from.
subkey
The path of the sub key to open. Sub key should be separated by \ characters.
Opens or creates a registry key.

Syntax

Visual Basic (Declaration)
Public Shared Function OpenOrCreateRegistryKey( _
   ByVal key As RegistryKey, _
   ByVal subkey As String _
) As RegistryKey
Visual Basic (Usage) Copy Code
Dim key As RegistryKey
Dim subkey As String
Dim value As RegistryKey

value = Limit.OpenOrCreateRegistryKey(key, subkey)
C#
public static RegistryKey OpenOrCreateRegistryKey(
   RegistryKey key,
   string subkey
)
Managed Extensions for C++
public: static RegistryKey* OpenOrCreateRegistryKey(
   RegistryKey* key,
   string* subkey
)
C++/CLI
public:
static RegistryKey^ OpenOrCreateRegistryKey(
   RegistryKey^ key,
   String^ subkey
)

Parameters

key
The parent key to open from.
subkey
The path of the sub key to open. Sub key should be separated by \ characters.

Return Value

Returns the opened or created registry key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ParseIPAddress Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ParseIPAddress Method

address
IPAddress to parse.
Parses an IPAddress to it's actual long value.

Syntax

Visual Basic (Declaration)
Public Shared Function ParseIPAddress( _
   ByVal address As IPAddress _
) As Long
Visual Basic (Usage) Copy Code
Dim address As IPAddress
Dim value As Long

value = Limit.ParseIPAddress(address)
C#
public static long ParseIPAddress(
   IPAddress address
)
Managed Extensions for C++
public: static long ParseIPAddress(
   IPAddress address
)
C++/CLI
public:
static long ParseIPAddress(
   IPAddress address
)

Parameters

address
IPAddress to parse.

Return Value

Returns the actual address of the IPAddress.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Peek Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Peek Method

context
The LicenseContext used to determine the environment and settings of the licensing.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user.

Syntax

Visual Basic (Declaration)
Public Overridable Function Peek( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object _
) As PeekResult
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim context As LicenseContext
Dim type As Type
Dim instance As Object
Dim value As PeekResult

value = instance.Peek(context, type, instance)
C#
public virtual PeekResult Peek(
   LicenseContext context,
   Type type,
   object instance
)
Managed Extensions for C++
public: virtual PeekResult Peek(
   LicenseContext context,
   Type* type,
   Object* instance
)
C++/CLI
public:
virtual PeekResult Peek(
   LicenseContext context,
   Type^ type,
   Object^ instance
)

Parameters

context
The LicenseContext used to determine the environment and settings of the licensing.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : SaveToXml Method

parent
The parent XmlNode to add child nodes to.
Saves the contents of the Limit as an XmlNode.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride Function SaveToXml( _
   ByVal parent As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim parent As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parent)
C#
public virtual abstract XmlNode SaveToXml(
   XmlNode parent
)
Managed Extensions for C++
public: virtual abstract XmlNode SaveToXml(
   XmlNode parent
)
C++/CLI
public:
virtual abstract XmlNode SaveToXml(
   XmlNode parent
)

Parameters

parent
The parent XmlNode to add child nodes to.

Return Value

Returns the saved XML node.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SelectCulture Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : SelectCulture Method

culture
The culture to select.
Selects the given culture for the current thread, and returns the previous culture.

Syntax

Visual Basic (Declaration)
Public Shared Function SelectCulture( _
   ByVal culture As CultureInfo _
) As CultureInfo
Visual Basic (Usage) Copy Code
Dim culture As CultureInfo
Dim value As CultureInfo

value = Limit.SelectCulture(culture)
C#
public static CultureInfo SelectCulture(
   CultureInfo culture
)
Managed Extensions for C++
public: static CultureInfo* SelectCulture(
   CultureInfo* culture
)
C++/CLI
public:
static CultureInfo^ SelectCulture(
   CultureInfo^ culture
)

Parameters

culture
The culture to select.

Return Value

Returns the previous culture.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SelectWebCulture Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : SelectWebCulture Method

Selects the culture of the current web request into the current thread, and returns the previous culture.

Syntax

Visual Basic (Declaration)
Public Shared Function SelectWebCulture() As CultureInfo
Visual Basic (Usage) Copy Code
Dim value As CultureInfo

value = Limit.SelectWebCulture()
C#
public static CultureInfo SelectWebCulture()
Managed Extensions for C++
public: static CultureInfo* SelectWebCulture();
C++/CLI
public:
static CultureInfo^ SelectWebCulture();

Return Value

Returns the previous culture.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
UnmaskValue Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : UnmaskValue Method

source
The original value.
Reverses the simple value obfuscation performed by MaskValue.

Syntax

Visual Basic (Declaration)
Public Shared Function UnmaskValue( _
   ByVal source As String _
) As String
Visual Basic (Usage) Copy Code
Dim source As String
Dim value As String

value = Limit.UnmaskValue(source)
C#
public static string UnmaskValue(
   string source
)
Managed Extensions for C++
public: static string* UnmaskValue(
   string* source
)
C++/CLI
public:
static String^ UnmaskValue(
   String^ source
)

Parameters

source
The original value.

Return Value

Returns the masked version of the value. Call UnmaskValue to obtain the original value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Validate Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Validate Method

context
The LicenseContext passed to GetLicense.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
Validates that the license being granted is within the limits enforced by this object.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride Function Validate( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim context As LicenseContext
Dim type As Type
Dim instance As Object
Dim value As Boolean

value = instance.Validate(context, type, instance)
C#
public virtual abstract bool Validate(
   LicenseContext context,
   Type type,
   object instance
)
Managed Extensions for C++
public: virtual abstract bool Validate(
   LicenseContext context,
   Type* type,
   Object* instance
)
C++/CLI
public:
virtual abstract bool Validate(
   LicenseContext context,
   Type^ type,
   Object^ instance
)

Parameters

context
The LicenseContext passed to GetLicense.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.

Return Value

Returns true if the limits are valid, otherwise false.

Remarks

If validation fails, limits should set their parent License's InvalidReason to a string explaining why it could not be validated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ValidateDomainName Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ValidateDomainName Method

domainName
The domain name to validate.
Validates the format of a domain name.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateDomainName( _
   ByVal domainName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim domainName As String
Dim value As Boolean

value = Limit.ValidateDomainName(domainName)
C#
public static bool ValidateDomainName(
   string domainName
)
Managed Extensions for C++
public: static bool ValidateDomainName(
   string* domainName
)
C++/CLI
public:
static bool ValidateDomainName(
   String^ domainName
)

Parameters

domainName
The domain name to validate.

Return Value

Returns true if the format of the domain name is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ValidateEmail Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ValidateEmail Method

email
The email address to validate.
Validates if the email is correctly formatted.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateEmail( _
   ByVal email As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim email As String
Dim value As Boolean

value = Limit.ValidateEmail(email)
C#
public static bool ValidateEmail(
   string email
)
Managed Extensions for C++
public: static bool ValidateEmail(
   string* email
)
C++/CLI
public:
static bool ValidateEmail(
   String^ email
)

Parameters

email
The email address to validate.

Return Value

Returns true if the email is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ValidateIPAddress Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ValidateIPAddress Method

address
The IP Address to validate.
Validates the format of an IP address.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateIPAddress( _
   ByVal address As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim address As String
Dim value As Boolean

value = Limit.ValidateIPAddress(address)
C#
public static bool ValidateIPAddress(
   string address
)
Managed Extensions for C++
public: static bool ValidateIPAddress(
   string* address
)
C++/CLI
public:
static bool ValidateIPAddress(
   String^ address
)

Parameters

address
The IP Address to validate.

Return Value

Returns true if the format of the address is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ValidateUrl Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ValidateUrl Method

url
The url to validate.
fullyQualified
Indicates if the url must be fully qualified. Containing a host and optional protocol.
Validates the url is correctly formatted.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateUrl( _
   ByVal url As String, _
   ByVal fullyQualified As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim url As String
Dim fullyQualified As Boolean
Dim value As Boolean

value = Limit.ValidateUrl(url, fullyQualified)
C#
public static bool ValidateUrl(
   string url,
   bool fullyQualified
)
Managed Extensions for C++
public: static bool ValidateUrl(
   string* url,
   bool fullyQualified
)
C++/CLI
public:
static bool ValidateUrl(
   String^ url,
   bool fullyQualified
)

Parameters

url
The url to validate.
fullyQualified
Indicates if the url must be fully qualified. Containing a host and optional protocol.

Return Value

Returns true if the url is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
Limit Class Properties
See Also
[image]
Xheo.Licensing Namespace : Limit Class

For a list of all members of this type, see Limit members.

Public Properties

 | Name | Description
Public Property | Description | Gets the description of the limit.
Public Property | IsGui | Gets a value that indicates if this Limit uses a GUI to interact with the user.
Public Property | IsRemote | Gets a value that indicates if this Limit uses remote processes (such as WebServices) for enforcement.
Public Property | IsTimeSensitive | Gets a value that indicates if the limit is time sensitive and the clock should be protected.
Public Property | License | Gets or sets a reference to the ExtendedLicense that contains this Limit.
Public Property | Name | Gets the display name of the limit.
Public Property | QualifiedTypeName | Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type.
Top

See Also

Reference

Limit Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Description Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Description Property

Gets the description of the limit.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride ReadOnly Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As String

value = instance.Description
C#
public virtual abstract string Description {get;}
Managed Extensions for C++
public: __property virtual abstract string* get_Description();
C++/CLI
public:
virtual abstract property String^ Description {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsGui Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : IsGui Property

Gets a value that indicates if this Limit uses a GUI to interact with the user.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsGui As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As Boolean

value = instance.IsGui
C#
public virtual bool IsGui {get;}
Managed Extensions for C++
public: __property virtual bool get_IsGui();
C++/CLI
public:
virtual property bool IsGui {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsRemote Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : IsRemote Property

Gets a value that indicates if this Limit uses remote processes (such as WebServices) for enforcement.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsRemote As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As Boolean

value = instance.IsRemote
C#
public virtual bool IsRemote {get;}
Managed Extensions for C++
public: __property virtual bool get_IsRemote();
C++/CLI
public:
virtual property bool IsRemote {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsTimeSensitive Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : IsTimeSensitive Property

Gets a value that indicates if the limit is time sensitive and the clock should be protected.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsTimeSensitive As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As Boolean

value = instance.IsTimeSensitive
C#
public virtual bool IsTimeSensitive {get;}
Managed Extensions for C++
public: __property virtual bool get_IsTimeSensitive();
C++/CLI
public:
virtual property bool IsTimeSensitive {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
License Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : License Property

Gets or sets a reference to the ExtendedLicense that contains this Limit.

Syntax

Visual Basic (Declaration)
Public Property License As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As ExtendedLicense

instance.License = value

value = instance.License
C#
public ExtendedLicense License {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_License();
public: __property void set_License(
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ License {
   ExtendedLicense^ get();
   void set (ExtendedLicense^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Name Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Name Property

Gets the display name of the limit.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As String

value = instance.Name
C#
public virtual abstract string Name {get;}
Managed Extensions for C++
public: __property virtual abstract string* get_Name();
C++/CLI
public:
virtual abstract property String^ Name {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
QualifiedTypeName Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : QualifiedTypeName Property

Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property QualifiedTypeName As String
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As String

value = instance.QualifiedTypeName
C#
public virtual string QualifiedTypeName {get;}
Managed Extensions for C++
public: __property virtual string* get_QualifiedTypeName();
C++/CLI
public:
virtual property String^ QualifiedTypeName {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LimitCollection Class
See Also Members
[image]
Xheo.Licensing Namespace : LimitCollection Class

Services as a collection of limits.

Object Model

Syntax

Visual Basic (Declaration)
Private Class LimitCollection
   Inherits TransientReadOnlyCollection
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
C#
private class LimitCollection : TransientReadOnlyCollection
Managed Extensions for C++
private __gc class LimitCollection : public TransientReadOnlyCollection
C++/CLI
private ref class LimitCollection : public TransientReadOnlyCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Xheo.Licensing.TransientReadOnlyCollection
Xheo.Licensing.LimitCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
LimitCollection Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : LimitCollection Class

The following tables list the members exposed by LimitCollection.

Public Constructors

 | Name | Description
Public Constructor | LimitCollection Constructor | Overloaded. Initializes a new instance of the LimitCollection class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating if the collection is read only. (Inherited from TransientReadOnlyCollection)
Public Property | Item | Gets or sets a limit at the given index.
Public Property | License | Gets or sets a reference to the containing license.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a new limit to the collection.
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines if the collection contains the given Limit.
Public Method | CopyTo | Copies the collection to an array.
Public Method | FromXmlString | Loads the contents of the limit collection from an XML string.
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetPrioritizedOrder | Gets the limits in order of priority.
Public Method | Granted | Called every time the limit is granted.
Public Method | IndexOf | Gets the index of the given limit.
Public Method | Insert | Inserts the limit at the given index.
Public Method | LoadFromXml | Loads the contents of a LimitCollection from an XmlNode.
Public Method | Remove | Removes the given index from the list.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | SaveToXml | Saves the contents of the LimitCollection to the given XmlNode.
Public Method | SetReadOnly | Sets the collection to a read only state. This cannot be reversed. (Inherited from TransientReadOnlyCollection)
Public Method | ToXmlString | Saves the contents of the limit collection to an XML string.
Public Method | Validate | Ensures that all the Limits in the collection are valid for the given type and context.
Top

See Also

Reference

LimitCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LimitCollection Constructor
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : LimitCollection Constructor

Initializes a new instance of the LimitCollection class.

Overload List

Overload | Description
LimitCollection Constructor() | Included for COM compliance, do not use.
LimitCollection Constructor(ExtendedLicense) | Initializes a new instance of the LimitCollection class.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LimitCollection Constructor()
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class > LimitCollection Constructor : LimitCollection Constructor()

Included for COM compliance, do not use.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection()
C#
public LimitCollection()
Managed Extensions for C++
public: LimitCollection();
C++/CLI
public:
LimitCollection();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LimitCollection Constructor(ExtendedLicense)
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class > LimitCollection Constructor : LimitCollection Constructor(ExtendedLicense)

license
Reference to the containing ExtendedLicense.
Initializes a new instance of the LimitCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim license As ExtendedLicense

Dim instance As LimitCollection(license)
C#
public LimitCollection(
   ExtendedLicense license
)
Managed Extensions for C++
public: LimitCollection(
   ExtendedLicense* license
)
C++/CLI
public:
LimitCollection(
   ExtendedLicense^ license
)

Parameters

license
Reference to the containing ExtendedLicense.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
LimitCollection Class Methods
See Also
[image]
Xheo.Licensing Namespace : LimitCollection Class

For a list of all members of this type, see LimitCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a new limit to the collection.
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines if the collection contains the given Limit.
Public Method | CopyTo | Copies the collection to an array.
Public Method | FromXmlString | Loads the contents of the limit collection from an XML string.
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetPrioritizedOrder | Gets the limits in order of priority.
Public Method | Granted | Called every time the limit is granted.
Public Method | IndexOf | Gets the index of the given limit.
Public Method | Insert | Inserts the limit at the given index.
Public Method | LoadFromXml | Loads the contents of a LimitCollection from an XmlNode.
Public Method | Remove | Removes the given index from the list.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | SaveToXml | Saves the contents of the LimitCollection to the given XmlNode.
Public Method | SetReadOnly | Sets the collection to a read only state. This cannot be reversed. (Inherited from TransientReadOnlyCollection)
Public Method | ToXmlString | Saves the contents of the limit collection to an XML string.
Public Method | Validate | Ensures that all the Limits in the collection are valid for the given type and context.
Top

See Also

Reference

LimitCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Add Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Add Method

limit
The limit to add.
Adds a new limit to the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal limit As Limit _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim limit As Limit

instance.Add(limit)
C#
public void Add(
   Limit limit
)
Managed Extensions for C++
public: void Add(
   Limit* limit
)
C++/CLI
public:
void Add(
   Limit^ limit
)

Parameters

limit
The limit to add.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Contains Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Contains Method

limit
The Limit to look for.
Determines if the collection contains the given Limit.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal limit As Limit _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim limit As Limit
Dim value As Boolean

value = instance.Contains(limit)
C#
public bool Contains(
   Limit limit
)
Managed Extensions for C++
public: bool Contains(
   Limit* limit
)
C++/CLI
public:
bool Contains(
   Limit^ limit
)

Parameters

limit
The Limit to look for.

Return Value

Returns true if the Limit is found, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
CopyTo Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : CopyTo Method

array
The array to copy to.
index
The index in the array to begin copying.
Copies the collection to an array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As Limit, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim array() As Limit
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   Limit[] array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   Limit*[] array,
   int index
)
C++/CLI
public:
void CopyTo(
   array<Limit^> array,
   int index
)

Parameters

array
The array to copy to.
index
The index in the array to begin copying.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : FromXmlString Method

xml
The XML string to load from.
Loads the contents of the limit collection from an XML string.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
The XML string to load from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetPrioritizedOrder Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : GetPrioritizedOrder Method

includeRemote
Indicates if remote limits should be included.
Gets the limits in order of priority.

Syntax

Visual Basic (Declaration)
Public Function GetPrioritizedOrder( _
   ByVal includeRemote As Boolean _
) As LimitCollection
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim includeRemote As Boolean
Dim value As LimitCollection

value = instance.GetPrioritizedOrder(includeRemote)
C#
public LimitCollection GetPrioritizedOrder(
   bool includeRemote
)
Managed Extensions for C++
public: LimitCollection* GetPrioritizedOrder(
   bool includeRemote
)
C++/CLI
public:
LimitCollection^ GetPrioritizedOrder(
   bool includeRemote
)

Parameters

includeRemote
Indicates if remote limits should be included.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Granted Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Granted Method

context
type
instance
Called every time the limit is granted.

Syntax

Visual Basic (Declaration)
Public Sub Granted( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim context As LicenseContext
Dim type As Type
Dim instance As Object

instance.Granted(context, type, instance)
C#
public void Granted(
   LicenseContext context,
   Type type,
   object instance
)
Managed Extensions for C++
public: void Granted(
   LicenseContext context,
   Type* type,
   Object* instance
)
C++/CLI
public:
void Granted(
   LicenseContext context,
   Type^ type,
   Object^ instance
)

Parameters

context
type
instance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IndexOf Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : IndexOf Method

limit
The limit to look for.
Gets the index of the given limit.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal limit As Limit _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim limit As Limit
Dim value As Integer

value = instance.IndexOf(limit)
C#
public int IndexOf(
   Limit limit
)
Managed Extensions for C++
public: int IndexOf(
   Limit* limit
)
C++/CLI
public:
int IndexOf(
   Limit^ limit
)

Parameters

limit
The limit to look for.

Return Value

Returns the index of the given limit if found, otherwise -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Insert Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Insert Method

index
The index where to insert the limit.
limit
The limit to insert.
Inserts the limit at the given index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal limit As Limit _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim index As Integer
Dim limit As Limit

instance.Insert(index, limit)
C#
public void Insert(
   int index,
   Limit limit
)
Managed Extensions for C++
public: void Insert(
   int index,
   Limit* limit
)
C++/CLI
public:
void Insert(
   int index,
   Limit^ limit
)

Parameters

index
The index where to insert the limit.
limit
The limit to insert.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : LoadFromXml Method

node
Loads the contents of a LimitCollection from an XmlNode.

Syntax

Visual Basic (Declaration)
Public Function LoadFromXml( _
   ByVal node As XmlNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim node As XmlNode
Dim value As Boolean

value = instance.LoadFromXml(node)
C#
public bool LoadFromXml(
   XmlNode node
)
Managed Extensions for C++
public: bool LoadFromXml(
   XmlNode node
)
C++/CLI
public:
bool LoadFromXml(
   XmlNode node
)

Parameters

node

Return Value

Returns true if the load was successful, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Remove Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Remove Method

limit
The limit to remove.
Removes the given index from the list.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal limit As Limit _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim limit As Limit

instance.Remove(limit)
C#
public void Remove(
   Limit limit
)
Managed Extensions for C++
public: void Remove(
   Limit* limit
)
C++/CLI
public:
void Remove(
   Limit^ limit
)

Parameters

limit
The limit to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : SaveToXml Method

parent
The parent XmlNode.
Saves the contents of the LimitCollection to the given XmlNode.

Syntax

Visual Basic (Declaration)
Public Function SaveToXml( _
   ByVal parent As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim parent As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parent)
C#
public XmlNode SaveToXml(
   XmlNode parent
)
Managed Extensions for C++
public: XmlNode SaveToXml(
   XmlNode parent
)
C++/CLI
public:
XmlNode SaveToXml(
   XmlNode parent
)

Parameters

parent
The parent XmlNode.

Return Value

Returns the root node of the saved limits.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : ToXmlString Method

Saves the contents of the limit collection to an XML string.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim value As String

value = instance.ToXmlString()
C#
public string ToXmlString()
Managed Extensions for C++
public: string* ToXmlString();
C++/CLI
public:
String^ ToXmlString();

Return Value

The saved XML.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Validate Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Validate Method

context
The LicenseContext passed to GetLicense.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
includeRemote
Indicates if limits that have IsRemote set to true should be included in the validation.
Ensures that all the Limits in the collection are valid for the given type and context.

Syntax

Visual Basic (Declaration)
Public Overridable Function Validate( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object, _
   ByVal includeRemote As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim context As LicenseContext
Dim type As Type
Dim instance As Object
Dim includeRemote As Boolean
Dim value As Boolean

value = instance.Validate(context, type, instance, includeRemote)
C#
public virtual bool Validate(
   LicenseContext context,
   Type type,
   object instance,
   bool includeRemote
)
Managed Extensions for C++
public: virtual bool Validate(
   LicenseContext context,
   Type* type,
   Object* instance,
   bool includeRemote
)
C++/CLI
public:
virtual bool Validate(
   LicenseContext context,
   Type^ type,
   Object^ instance,
   bool includeRemote
)

Parameters

context
The LicenseContext passed to GetLicense.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
includeRemote
Indicates if limits that have IsRemote set to true should be included in the validation.

Return Value

Returns true if the limits are valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
LimitCollection Class Properties
See Also
[image]
Xheo.Licensing Namespace : LimitCollection Class

For a list of all members of this type, see LimitCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating if the collection is read only. (Inherited from TransientReadOnlyCollection)
Public Property | Item | Gets or sets a limit at the given index.
Public Property | License | Gets or sets a reference to the containing license.
Top

See Also

Reference

LimitCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Item Property
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Item Property

index
Gets or sets a limit at the given index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Limit
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim index As Integer
Dim value As Limit

instance.Item(index) = value

value = instance.Item(index)
C#
public Limit this[
   int index
]; {get; set;}
Managed Extensions for C++
public: __property Limit* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   Limit* value
);
C++/CLI
public:
property Limit^ default [int] {
   Limit^ get(int index);
   void set (int index, Limit^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
License Property
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : License Property

Gets or sets a reference to the containing license.

Syntax

Visual Basic (Declaration)
Public Property License As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim value As ExtendedLicense

instance.License = value

value = instance.License
C#
public ExtendedLicense License {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_License();
public: __property void set_License(
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ License {
   ExtendedLicense^ get();
   void set (ExtendedLicense^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MachineProfile Class
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile Class

Manages a machine profile used by the license activation system. Profiles represent a collection of generally non volitale system properties that can collectively be used to identify certain machines.

Syntax

Visual Basic (Declaration)
Private NotInheritable Class MachineProfile
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
C#
private sealed class MachineProfile
Managed Extensions for C++
private __gc __sealed class MachineProfile
C++/CLI
private ref class MachineProfile sealed

Inheritance Hierarchy

System.Object
Xheo.Licensing.MachineProfile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
MachineProfile Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : MachineProfile Class

The following tables list the members exposed by MachineProfile.

Public Constructors

 | Name | Description
Public Constructor | MachineProfile Constructor | Initializes a new instance of the MachineProfile class.
Top

Public Properties

 | Name | Description
Public Property | Hash | Gets the comparable hash for the MachineProfile.
static (Shared in Visual Basic) | Profile | Gets the profile of the current machine.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CompareHash | Compares two machine profile hashes and determines the amount of difference.
Public Method | CompareTo | Determines if the MachineProfile is comparatively similar to the given hash.
Public Method | GetComparableHash | Overloaded. Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.
static (Shared in Visual Basic) | GetDifferences | Gets the name of the hardware types that are different between the two hashes.
Top

See Also

Reference

MachineProfile Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MachineProfile Constructor
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : MachineProfile Constructor

Initializes a new instance of the MachineProfile class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile()
C#
public MachineProfile()
Managed Extensions for C++
public: MachineProfile();
C++/CLI
public:
MachineProfile();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
MachineProfile Class Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile Class

For a list of all members of this type, see MachineProfile members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CompareHash | Compares two machine profile hashes and determines the amount of difference.
Public Method | CompareTo | Determines if the MachineProfile is comparatively similar to the given hash.
Public Method | GetComparableHash | Overloaded. Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.
static (Shared in Visual Basic) | GetDifferences | Gets the name of the hardware types that are different between the two hashes.
Top

See Also

Reference

MachineProfile Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
CompareHash Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : CompareHash Method

hash
The of the machine to compare.
comparedHash
The hashed value of another machine profile to compare to.
Compares two machine profile hashes and determines the amount of difference.

Syntax

Visual Basic (Declaration)
Public Shared Function CompareHash( _
   ByVal hash As String, _
   ByVal comparedHash As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim hash As String
Dim comparedHash As String
Dim value As Integer

value = MachineProfile.CompareHash(hash, comparedHash)
C#
public static int CompareHash(
   string hash,
   string comparedHash
)
Managed Extensions for C++
public: static int CompareHash(
   string* hash,
   string* comparedHash
)
C++/CLI
public:
static int CompareHash(
   String^ hash,
   String^ comparedHash
)

Parameters

hash
The of the machine to compare.
comparedHash
The hashed value of another machine profile to compare to.

Return Value

Returns the difference rating from 0 (same) to 10 (very different).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
CompareTo Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : CompareTo Method

profileHash
The hash to compare to.
tolerance
The tolerance level.
Determines if the MachineProfile is comparatively similar to the given hash.

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal profileHash As String, _
   ByVal tolerance As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
Dim profileHash As String
Dim tolerance As Integer
Dim value As Boolean

value = instance.CompareTo(profileHash, tolerance)
C#
public bool CompareTo(
   string profileHash,
   int tolerance
)
Managed Extensions for C++
public: bool CompareTo(
   string* profileHash,
   int tolerance
)
C++/CLI
public:
bool CompareTo(
   String^ profileHash,
   int tolerance
)

Parameters

profileHash
The hash to compare to.
tolerance
The tolerance level.

Return Value

Returns true if the current machine profile is within the tolerance level of the given profile hash.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetComparableHash Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : GetComparableHash Method

Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.

Overload List

Overload | Description
GetComparableHash(Version) | Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.
GetComparableHash() | Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetComparableHash(Version) Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class > GetComparableHash Method : GetComparableHash(Version) Method

version
The hash version to generate. Use to create backwards compatible hash codes.
Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetComparableHash( _
   ByVal version As Version _
) As String
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
Dim version As Version
Dim value As String

value = instance.GetComparableHash(version)
C#
public string GetComparableHash(
   Version version
)
Managed Extensions for C++
public: string* GetComparableHash(
   Version* version
)
C++/CLI
public:
String^ GetComparableHash(
   Version^ version
)

Parameters

version
The hash version to generate. Use to create backwards compatible hash codes.

Return Value

Returns a comparable has for the current machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetComparableHash() Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class > GetComparableHash Method : GetComparableHash() Method

Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetComparableHash() As String
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
Dim value As String

value = instance.GetComparableHash()
C#
public string GetComparableHash()
Managed Extensions for C++
public: string* GetComparableHash();
C++/CLI
public:
String^ GetComparableHash();

Return Value

Returns a comparable has for the current machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetDifferences Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : GetDifferences Method

hash
The of the machine to compare.
comparedHash
The hashed value of another machine profile to compare to.
Gets the name of the hardware types that are different between the two hashes.

Syntax

Visual Basic (Declaration)
Public Shared Function GetDifferences( _
   ByVal hash As String, _
   ByVal comparedHash As String _
) As String()
Visual Basic (Usage) Copy Code
Dim hash As String
Dim comparedHash As String
Dim value() As String

value = MachineProfile.GetDifferences(hash, comparedHash)
C#
public static string[] GetDifferences(
   string hash,
   string comparedHash
)
Managed Extensions for C++
public: static string*[] GetDifferences(
   string* hash,
   string* comparedHash
)
C++/CLI
public:
static array<String^> GetDifferences(
   String^ hash,
   String^ comparedHash
)

Parameters

hash
The of the machine to compare.
comparedHash
The hashed value of another machine profile to compare to.

Return Value

Returns the collection of hardware changes detected between the two hashes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
MachineProfile Class Properties
See Also
[image]
Xheo.Licensing Namespace : MachineProfile Class

For a list of all members of this type, see MachineProfile members.

Public Properties

 | Name | Description
Public Property | Hash | Gets the comparable hash for the MachineProfile.
static (Shared in Visual Basic) | Profile | Gets the profile of the current machine.
Top

See Also

Reference

MachineProfile Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Hash Property
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : Hash Property

Gets the comparable hash for the MachineProfile.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hash As String
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
Dim value As String

value = instance.Hash
C#
public string Hash {get;}
Managed Extensions for C++
public: __property string* get_Hash();
C++/CLI
public:
property String^ Hash {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Profile Property
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : Profile Property

Gets the profile of the current machine.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Profile As MachineProfile
Visual Basic (Usage) Copy Code
Dim value As MachineProfile

value = MachineProfile.Profile
C#
public static MachineProfile Profile {get;}
Managed Extensions for C++
public: __property static MachineProfile* get_Profile();
C++/CLI
public:
static property MachineProfile^ Profile {
   MachineProfile^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MachineProfile.Constants Class
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.Constants Class

A class to contain the constants required for the IP_ADAPTER_INFO struct

Syntax

Visual Basic (Declaration)
Private Class MachineProfile.Constants
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.Constants
C#
private class MachineProfile.Constants
Managed Extensions for C++
private __gc class MachineProfile.Constants
C++/CLI
private ref class MachineProfile.Constants

Inheritance Hierarchy

System.Object
Xheo.Licensing.MachineProfile.Constants

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
MachineProfile.Constants Class Members
See Also Fields
[image]
Xheo.Licensing Namespace : MachineProfile.Constants Class

The following tables list the members exposed by MachineProfile.Constants.

Public Constructors

 | Name | Description
Public Constructor | MachineProfile.Constants Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MAX_ADAPTER_ADDRESS_LENGTH | The maximum length for the physical address of the adapter
static (Shared in Visual Basic) | MAX_ADAPTER_DESCRIPTION_LENGTH | The maximum length of the description of an adapter
static (Shared in Visual Basic) | MAX_ADAPTER_NAME_LENGTH | The maximum length of an adapter name
Top

See Also

Reference

MachineProfile.Constants Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MachineProfile.Constants Constructor
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.Constants Class : MachineProfile.Constants Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.Constants()
C#
public MachineProfile.Constants()
Managed Extensions for C++
public: MachineProfile.Constants();
C++/CLI
public:
MachineProfile.Constants();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Class
MachineProfile.Constants Members


%%PageItemTitle%% $$Fields$$

Barcode4NET Send comments on this topic.
MachineProfile.Constants Class Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.Constants Class

For a list of all members of this type, see MachineProfile.Constants members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MAX_ADAPTER_ADDRESS_LENGTH | The maximum length for the physical address of the adapter
static (Shared in Visual Basic) | MAX_ADAPTER_DESCRIPTION_LENGTH | The maximum length of the description of an adapter
static (Shared in Visual Basic) | MAX_ADAPTER_NAME_LENGTH | The maximum length of an adapter name
Top

See Also

Reference

MachineProfile.Constants Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MAX_ADAPTER_ADDRESS_LENGTH Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.Constants Class : MAX_ADAPTER_ADDRESS_LENGTH Field

The maximum length for the physical address of the adapter

Syntax

Visual Basic (Declaration)
Public Shared MAX_ADAPTER_ADDRESS_LENGTH As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = MachineProfile.Constants.MAX_ADAPTER_ADDRESS_LENGTH

MachineProfile.Constants.MAX_ADAPTER_ADDRESS_LENGTH = value
C#
public static int MAX_ADAPTER_ADDRESS_LENGTH
Managed Extensions for C++
public: static int MAX_ADAPTER_ADDRESS_LENGTH
C++/CLI
public:
static int MAX_ADAPTER_ADDRESS_LENGTH

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Class
MachineProfile.Constants Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MAX_ADAPTER_DESCRIPTION_LENGTH Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.Constants Class : MAX_ADAPTER_DESCRIPTION_LENGTH Field

The maximum length of the description of an adapter

Syntax

Visual Basic (Declaration)
Public Shared MAX_ADAPTER_DESCRIPTION_LENGTH As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = MachineProfile.Constants.MAX_ADAPTER_DESCRIPTION_LENGTH

MachineProfile.Constants.MAX_ADAPTER_DESCRIPTION_LENGTH = value
C#
public static int MAX_ADAPTER_DESCRIPTION_LENGTH
Managed Extensions for C++
public: static int MAX_ADAPTER_DESCRIPTION_LENGTH
C++/CLI
public:
static int MAX_ADAPTER_DESCRIPTION_LENGTH

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Class
MachineProfile.Constants Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MAX_ADAPTER_NAME_LENGTH Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.Constants Class : MAX_ADAPTER_NAME_LENGTH Field

The maximum length of an adapter name

Syntax

Visual Basic (Declaration)
Public Shared MAX_ADAPTER_NAME_LENGTH As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = MachineProfile.Constants.MAX_ADAPTER_NAME_LENGTH

MachineProfile.Constants.MAX_ADAPTER_NAME_LENGTH = value
C#
public static int MAX_ADAPTER_NAME_LENGTH
Managed Extensions for C++
public: static int MAX_ADAPTER_NAME_LENGTH
C++/CLI
public:
static int MAX_ADAPTER_NAME_LENGTH

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Class
MachineProfile.Constants Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MachineProfile.GetAdapterInfo Class
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.GetAdapterInfo Class

Uses the windows API to retrieve information about the IP configuration of the local machine

Syntax

Visual Basic (Declaration)
Private Class MachineProfile.GetAdapterInfo
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.GetAdapterInfo
C#
private class MachineProfile.GetAdapterInfo
Managed Extensions for C++
private __gc class MachineProfile.GetAdapterInfo
C++/CLI
private ref class MachineProfile.GetAdapterInfo

Inheritance Hierarchy

System.Object
Xheo.Licensing.MachineProfile.GetAdapterInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.GetAdapterInfo Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
MachineProfile.GetAdapterInfo Class Members
See Also Methods
[image]
Xheo.Licensing Namespace : MachineProfile.GetAdapterInfo Class

The following tables list the members exposed by MachineProfile.GetAdapterInfo.

Public Constructors

 | Name | Description
Public Constructor | MachineProfile.GetAdapterInfo Constructor | Constructor for the GetAdapterInfo Class
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetAdapters | Gets details of all the adapters on the local machine
static (Shared in Visual Basic) | GetFirstAdapter | Gets the details of the first available adapter on the local machine
Top

See Also

Reference

MachineProfile.GetAdapterInfo Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MachineProfile.GetAdapterInfo Constructor
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.GetAdapterInfo Class : MachineProfile.GetAdapterInfo Constructor

Constructor for the GetAdapterInfo Class

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.GetAdapterInfo()
C#
public MachineProfile.GetAdapterInfo()
Managed Extensions for C++
public: MachineProfile.GetAdapterInfo();
C++/CLI
public:
MachineProfile.GetAdapterInfo();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.GetAdapterInfo Class
MachineProfile.GetAdapterInfo Members


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
MachineProfile.GetAdapterInfo Class Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.GetAdapterInfo Class

For a list of all members of this type, see MachineProfile.GetAdapterInfo members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetAdapters | Gets details of all the adapters on the local machine
static (Shared in Visual Basic) | GetFirstAdapter | Gets the details of the first available adapter on the local machine
Top

See Also

Reference

MachineProfile.GetAdapterInfo Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetAdapters Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.GetAdapterInfo Class : GetAdapters Method

Gets details of all the adapters on the local machine

Syntax

Visual Basic (Declaration)
Public Shared Function GetAdapters() As ArrayList
Visual Basic (Usage) Copy Code
Dim value As ArrayList

value = MachineProfile.GetAdapterInfo.GetAdapters()
C#
public static ArrayList GetAdapters()
Managed Extensions for C++
public: static ArrayList* GetAdapters();
C++/CLI
public:
static ArrayList^ GetAdapters();

Return Value

The return object is a System.Collections.ArrayList of IPConfig.IP_ADAPTERINFO_STRUCTURE structs containing data about the Adapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.GetAdapterInfo Class
MachineProfile.GetAdapterInfo Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GetFirstAdapter Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.GetAdapterInfo Class : GetFirstAdapter Method

Gets the details of the first available adapter on the local machine

Syntax

Visual Basic (Declaration)
Public Shared Function GetFirstAdapter() As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Visual Basic (Usage) Copy Code
Dim value As MachineProfile.IP_ADAPTERINFO_STRUCTURE

value = MachineProfile.GetAdapterInfo.GetFirstAdapter()
C#
public static MachineProfile.IP_ADAPTERINFO_STRUCTURE GetFirstAdapter()
Managed Extensions for C++
public: static MachineProfile.IP_ADAPTERINFO_STRUCTURE GetFirstAdapter();
C++/CLI
public:
static MachineProfile.IP_ADAPTERINFO_STRUCTURE GetFirstAdapter();

Return Value

The return value is an struct of type IP_ADAPTERINFO_STRUCTURE containing data about the Adapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.GetAdapterInfo Class
MachineProfile.GetAdapterInfo Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
StateEntry Class
See Also Members
[image]
Xheo.Licensing Namespace : StateEntry Class

Syntax

Visual Basic (Declaration)
Private Class StateEntry
Visual Basic (Usage) Copy Code
Dim instance As StateEntry
C#
private class StateEntry
Managed Extensions for C++
private __gc class StateEntry
C++/CLI
private ref class StateEntry

Inheritance Hierarchy

System.Object
Xheo.Licensing.StateEntry

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateEntry Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
StateEntry Class Members
See Also Fields
[image]
Xheo.Licensing Namespace : StateEntry Class

The following tables list the members exposed by StateEntry.

Public Constructors

 | Name | Description
Public Constructor | StateEntry Constructor |
Top

Public Fields

 | Name | Description
Public Field | LastUsed |
Public Field | SessionState |
Top

See Also

Reference

StateEntry Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
StateEntry Constructor
See Also
[image]
Xheo.Licensing Namespace > StateEntry Class : StateEntry Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StateEntry()
C#
public StateEntry()
Managed Extensions for C++
public: StateEntry();
C++/CLI
public:
StateEntry();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateEntry Class
StateEntry Members


%%PageItemTitle%% $$Fields$$

Barcode4NET Send comments on this topic.
StateEntry Class Fields
See Also
[image]
Xheo.Licensing Namespace : StateEntry Class

For a list of all members of this type, see StateEntry members.

Public Fields

 | Name | Description
Public Field | LastUsed |
Public Field | SessionState |
Top

See Also

Reference

StateEntry Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LastUsed Field
See Also
[image]
Xheo.Licensing Namespace > StateEntry Class : LastUsed Field

Syntax

Visual Basic (Declaration)
Public LastUsed As Date
Visual Basic (Usage) Copy Code
Dim instance As StateEntry
Dim value As Date

value = instance.LastUsed

instance.LastUsed = value
C#
public DateTime LastUsed
Managed Extensions for C++
public: DateTime LastUsed
C++/CLI
public:
DateTime LastUsed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateEntry Class
StateEntry Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SessionState Field
See Also
[image]
Xheo.Licensing Namespace > StateEntry Class : SessionState Field

Syntax

Visual Basic (Declaration)
Public SessionState As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As StateEntry
Dim value As Hashtable

value = instance.SessionState

instance.SessionState = value
C#
public Hashtable SessionState
Managed Extensions for C++
public: Hashtable* SessionState
C++/CLI
public:
Hashtable^ SessionState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateEntry Class
StateEntry Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
TransientReadOnlyCollection Class
See Also Members
[image]
Xheo.Licensing Namespace : TransientReadOnlyCollection Class

Implements a transient read only collection. Values can be added, removed and changed until the SetReadOnly method is called thus forcing the collection to a read only state.

Syntax

Visual Basic (Declaration)
Private MustInherit Class TransientReadOnlyCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As TransientReadOnlyCollection
C#
private abstract class TransientReadOnlyCollection : CollectionBase
Managed Extensions for C++
private __gc abstract class TransientReadOnlyCollection : public CollectionBase
C++/CLI
private ref class TransientReadOnlyCollection abstract : public CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Xheo.Licensing.TransientReadOnlyCollection
Xheo.Licensing.LimitCollection
Xheo.Licensing.LimitCollection
Xheo.Licensing.LimitCollection
Xheo.Licensing.LimitCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TransientReadOnlyCollection Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
TransientReadOnlyCollection Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : TransientReadOnlyCollection Class

The following tables list the members exposed by TransientReadOnlyCollection.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating if the collection is read only.
Top

Public Methods

 | Name | Description
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | SetReadOnly | Sets the collection to a read only state. This cannot be reversed.
Top

See Also

Reference

TransientReadOnlyCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
TransientReadOnlyCollection Class Methods
See Also
[image]
Xheo.Licensing Namespace : TransientReadOnlyCollection Class

For a list of all members of this type, see TransientReadOnlyCollection members.

Public Methods

 | Name | Description
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | SetReadOnly | Sets the collection to a read only state. This cannot be reversed.
Top

See Also

Reference

TransientReadOnlyCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SetReadOnly Method
See Also
[image]
Xheo.Licensing Namespace > TransientReadOnlyCollection Class : SetReadOnly Method

Sets the collection to a read only state. This cannot be reversed.

Syntax

Visual Basic (Declaration)
Public Sub SetReadOnly()
Visual Basic (Usage) Copy Code
Dim instance As TransientReadOnlyCollection

instance.SetReadOnly()
C#
public void SetReadOnly()
Managed Extensions for C++
public: void SetReadOnly();
C++/CLI
public:
void SetReadOnly();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TransientReadOnlyCollection Class
TransientReadOnlyCollection Members


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
TransientReadOnlyCollection Class Properties
See Also
[image]
Xheo.Licensing Namespace : TransientReadOnlyCollection Class

For a list of all members of this type, see TransientReadOnlyCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating if the collection is read only.
Top

See Also

Reference

TransientReadOnlyCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IsReadOnly Property
See Also
[image]
Xheo.Licensing Namespace > TransientReadOnlyCollection Class : IsReadOnly Property

Gets a value indicating if the collection is read only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TransientReadOnlyCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TransientReadOnlyCollection Class
TransientReadOnlyCollection Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
PeekResult Enumeration
See Also
[image]
Xheo.Licensing Namespace : PeekResult Enumeration

Possible results from the Peek method.

Syntax

Visual Basic (Declaration)
Private Enum PeekResult
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PeekResult
C#
private enum PeekResult : Enum
Managed Extensions for C++
__value private enum PeekResult : public Enum
C++/CLI
private enum class PeekResult : public Enum

Members

Member | Description
Unknown | Unkonwn status.
Valid | The limit is valid in it's current state and Validate will return true without any user interaction.
Invalid | The limit is invalid. Calling Validate may require user interaction.
NeedsUser | The limit may be valid but will require user interaction to ensure.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xheo.Licensing.PeekResult

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SerialNumberSizes Enumeration
See Also
[image]
Xheo.Licensing Namespace : SerialNumberSizes Enumeration

Possible key sizes for use when generating serial numbers. More bits makes it more difficult to crack but also increase the size of the serial number.

Syntax

Visual Basic (Declaration)
Private Enum SerialNumberSizes
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As SerialNumberSizes
C#
private enum SerialNumberSizes : Enum
Managed Extensions for C++
__value private enum SerialNumberSizes : public Enum
C++/CLI
private enum class SerialNumberSizes : public Enum

Members

Member | Description
None | Indicates that no serial number sizes are valid.
Small | Uses a key of 64 bits in length. Generates a serial number ~13 characters in length. Recommended group size = 4.
Medium | Uses a key of 96 bits in length. Generates a serial number ~20 characters in length. Recommended group size = 5.
Large | Uses a key of 128 bits in length. Generates a serial number ~25 characters in length. Recommended group size = 5.
Huge | Uses a key of 320 bits in length. Generates a serial number ~64 characters in length. Recommended group size = 8.
All | Allow any of the stored serial number sizes.
MediumAndBigger | Allow the medium and bigger sizes.
LargeAndBigger | Allow the large and bigger sizes.
Recommended | Recommended sizes for licenses.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xheo.Licensing.SerialNumberSizes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LicenseSigningKey.KeyRecord Structure
See Also Members
[image]
Xheo.Licensing Namespace : LicenseSigningKey.KeyRecord Structure

Object Model

Syntax

Visual Basic (Declaration)
Private Structure LicenseSigningKey.KeyRecord
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
C#
private struct LicenseSigningKey.KeyRecord : ValueType
Managed Extensions for C++
private __value struct LicenseSigningKey.KeyRecord : public ValueType
C++/CLI
private value class LicenseSigningKey.KeyRecord : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.LicenseSigningKey.KeyRecord

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
LicenseSigningKey.KeyRecord Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : LicenseSigningKey.KeyRecord Structure

The following tables list the members exposed by LicenseSigningKey.KeyRecord.

Public Constructors

 | Name | Description
Public Constructor | LicenseSigningKey.KeyRecord Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Bits |
Public Field | d |
Public Field | e |
Public Field | n |
Public Field | p |
Public Field | q |
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Public Method | VerifyKey |
Top

See Also

Reference

LicenseSigningKey.KeyRecord Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LicenseSigningKey.KeyRecord Constructor
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : LicenseSigningKey.KeyRecord Constructor

Overload List

Overload | Description
LicenseSigningKey.KeyRecord Constructor(BigInteger,BigInteger,BigInteger,BigInteger,BigInteger,Int32) |
LicenseSigningKey.KeyRecord Constructor(Int32) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LicenseSigningKey.KeyRecord Constructor(BigInteger,BigInteger,BigInteger,BigInteger,BigInteger,Int32)
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure > LicenseSigningKey.KeyRecord Constructor : LicenseSigningKey.KeyRecord Constructor(BigInteger,BigInteger,BigInteger,BigInteger,BigInteger,Int32)

p
q
e
n
d
bits

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal p As BigInteger, _
   ByVal q As BigInteger, _
   ByVal e As BigInteger, _
   ByVal n As BigInteger, _
   ByVal d As BigInteger, _
   ByVal bits As Integer _
)
Visual Basic (Usage) Copy Code
Dim p As BigInteger
Dim q As BigInteger
Dim e As BigInteger
Dim n As BigInteger
Dim d As BigInteger
Dim bits As Integer

Dim instance As LicenseSigningKey.KeyRecord(p, q, e, n, d, bits)
C#
public LicenseSigningKey.KeyRecord(
   BigInteger p,
   BigInteger q,
   BigInteger e,
   BigInteger n,
   BigInteger d,
   int bits
)
Managed Extensions for C++
public: LicenseSigningKey.KeyRecord(
   BigInteger* p,
   BigInteger* q,
   BigInteger* e,
   BigInteger* n,
   BigInteger* d,
   int bits
)
C++/CLI
public:
LicenseSigningKey.KeyRecord(
   BigInteger^ p,
   BigInteger^ q,
   BigInteger^ e,
   BigInteger^ n,
   BigInteger^ d,
   int bits
)

Parameters

p
q
e
n
d
bits

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LicenseSigningKey.KeyRecord Constructor(Int32)
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure > LicenseSigningKey.KeyRecord Constructor : LicenseSigningKey.KeyRecord Constructor(Int32)

bits

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bits As Integer _
)
Visual Basic (Usage) Copy Code
Dim bits As Integer

Dim instance As LicenseSigningKey.KeyRecord(bits)
C#
public LicenseSigningKey.KeyRecord(
   int bits
)
Managed Extensions for C++
public: LicenseSigningKey.KeyRecord(
   int bits
)
C++/CLI
public:
LicenseSigningKey.KeyRecord(
   int bits
)

Parameters

bits

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
LicenseSigningKey.KeyRecord Structure Methods
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey.KeyRecord Structure

For a list of all members of this type, see LicenseSigningKey.KeyRecord members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Public Method | VerifyKey |
Top

See Also

Reference

LicenseSigningKey.KeyRecord Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
VerifyKey Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : VerifyKey Method

Syntax

Visual Basic (Declaration)
Public Function VerifyKey() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As Boolean

value = instance.VerifyKey()
C#
public bool VerifyKey()
Managed Extensions for C++
public: bool VerifyKey();
C++/CLI
public:
bool VerifyKey();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%% $$Fields$$

Barcode4NET Send comments on this topic.
LicenseSigningKey.KeyRecord Structure Fields
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey.KeyRecord Structure

For a list of all members of this type, see LicenseSigningKey.KeyRecord members.

Public Fields

 | Name | Description
Public Field | Bits |
Public Field | d |
Public Field | e |
Public Field | n |
Public Field | p |
Public Field | q |
Top

See Also

Reference

LicenseSigningKey.KeyRecord Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Bits Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : Bits Field

Syntax

Visual Basic (Declaration)
Public Bits As Integer
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As Integer

value = instance.Bits

instance.Bits = value
C#
public int Bits
Managed Extensions for C++
public: int Bits
C++/CLI
public:
int Bits

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
d Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : d Field

Syntax

Visual Basic (Declaration)
Public d As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.d

instance.d = value
C#
public BigInteger d
Managed Extensions for C++
public: BigInteger* d
C++/CLI
public:
BigInteger^ d

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
e Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : e Field

Syntax

Visual Basic (Declaration)
Public e As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.e

instance.e = value
C#
public BigInteger e
Managed Extensions for C++
public: BigInteger* e
C++/CLI
public:
BigInteger^ e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
n Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : n Field

Syntax

Visual Basic (Declaration)
Public n As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.n

instance.n = value
C#
public BigInteger n
Managed Extensions for C++
public: BigInteger* n
C++/CLI
public:
BigInteger^ n

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
p Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : p Field

Syntax

Visual Basic (Declaration)
Public p As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.p

instance.p = value
C#
public BigInteger p
Managed Extensions for C++
public: BigInteger* p
C++/CLI
public:
BigInteger^ p

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
q Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : q Field

Syntax

Visual Basic (Declaration)
Public q As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.q

instance.q = value
C#
public BigInteger q
Managed Extensions for C++
public: BigInteger* q
C++/CLI
public:
BigInteger^ q

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MachineProfile._MEMORYSTATUS Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUS Structure

Summary of _MEMORYSTATUS

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile._MEMORYSTATUS
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
C#
private struct MachineProfile._MEMORYSTATUS : ValueType
Managed Extensions for C++
private __value struct MachineProfile._MEMORYSTATUS : public ValueType
C++/CLI
private value class MachineProfile._MEMORYSTATUS : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile._MEMORYSTATUS

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
MachineProfile._MEMORYSTATUS Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUS Structure

The following tables list the members exposed by MachineProfile._MEMORYSTATUS.

Public Fields

 | Name | Description
Public Field | dwAvailPageFile |
Public Field | dwAvailPhys |
Public Field | dwAvailVirtual |
Public Field | dwLength |
Public Field | dwMemoryLoad |
Public Field | dwTotalPageFile |
Public Field | dwTotalPhys |
Public Field | dwTotalVirtual |
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET Send comments on this topic.
MachineProfile._MEMORYSTATUS Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUS Structure

For a list of all members of this type, see MachineProfile._MEMORYSTATUS members.

Public Fields

 | Name | Description
Public Field | dwAvailPageFile |
Public Field | dwAvailPhys |
Public Field | dwAvailVirtual |
Public Field | dwLength |
Public Field | dwMemoryLoad |
Public Field | dwTotalPageFile |
Public Field | dwTotalPhys |
Public Field | dwTotalVirtual |
Top

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
dwAvailPageFile Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwAvailPageFile Field

Syntax

Visual Basic (Declaration)
Public dwAvailPageFile As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwAvailPageFile

instance.dwAvailPageFile = value
C#
public uint dwAvailPageFile
Managed Extensions for C++
public: uint dwAvailPageFile
C++/CLI
public:
uint dwAvailPageFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
dwAvailPhys Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwAvailPhys Field

Syntax

Visual Basic (Declaration)
Public dwAvailPhys As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwAvailPhys

instance.dwAvailPhys = value
C#
public uint dwAvailPhys
Managed Extensions for C++
public: uint dwAvailPhys
C++/CLI
public:
uint dwAvailPhys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
dwAvailVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwAvailVirtual Field

Syntax

Visual Basic (Declaration)
Public dwAvailVirtual As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwAvailVirtual

instance.dwAvailVirtual = value
C#
public uint dwAvailVirtual
Managed Extensions for C++
public: uint dwAvailVirtual
C++/CLI
public:
uint dwAvailVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
dwLength Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwLength Field

Syntax

Visual Basic (Declaration)
Public dwLength As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwLength

instance.dwLength = value
C#
public uint dwLength
Managed Extensions for C++
public: uint dwLength
C++/CLI
public:
uint dwLength

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
dwMemoryLoad Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwMemoryLoad Field

Syntax

Visual Basic (Declaration)
Public dwMemoryLoad As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwMemoryLoad

instance.dwMemoryLoad = value
C#
public uint dwMemoryLoad
Managed Extensions for C++
public: uint dwMemoryLoad
C++/CLI
public:
uint dwMemoryLoad

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
dwTotalPageFile Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwTotalPageFile Field

Syntax

Visual Basic (Declaration)
Public dwTotalPageFile As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwTotalPageFile

instance.dwTotalPageFile = value
C#
public uint dwTotalPageFile
Managed Extensions for C++
public: uint dwTotalPageFile
C++/CLI
public:
uint dwTotalPageFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
dwTotalPhys Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwTotalPhys Field

Syntax

Visual Basic (Declaration)
Public dwTotalPhys As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwTotalPhys

instance.dwTotalPhys = value
C#
public uint dwTotalPhys
Managed Extensions for C++
public: uint dwTotalPhys
C++/CLI
public:
uint dwTotalPhys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
dwTotalVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwTotalVirtual Field

Syntax

Visual Basic (Declaration)
Public dwTotalVirtual As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwTotalVirtual

instance.dwTotalVirtual = value
C#
public uint dwTotalVirtual
Managed Extensions for C++
public: uint dwTotalVirtual
C++/CLI
public:
uint dwTotalVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MachineProfile._MEMORYSTATUSEX Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUSEX Structure

Summary of _MEMORYSTATUSEX

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile._MEMORYSTATUSEX
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
C#
private struct MachineProfile._MEMORYSTATUSEX : ValueType
Managed Extensions for C++
private __value struct MachineProfile._MEMORYSTATUSEX : public ValueType
C++/CLI
private value class MachineProfile._MEMORYSTATUSEX : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile._MEMORYSTATUSEX

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
MachineProfile._MEMORYSTATUSEX Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUSEX Structure

The following tables list the members exposed by MachineProfile._MEMORYSTATUSEX.

Public Fields

 | Name | Description
Public Field | dwLength |
Public Field | dwMemoryLoad |
Public Field | ullAvailExtendedVirtual |
Public Field | ullAvailPageFile |
Public Field | ullAvailPhys |
Public Field | ullAvailVirtual |
Public Field | ullTotalPageFile |
Public Field | ullTotalPhys |
Public Field | ullTotalVirtual |
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET Send comments on this topic.
MachineProfile._MEMORYSTATUSEX Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUSEX Structure

For a list of all members of this type, see MachineProfile._MEMORYSTATUSEX members.

Public Fields

 | Name | Description
Public Field | dwLength |
Public Field | dwMemoryLoad |
Public Field | ullAvailExtendedVirtual |
Public Field | ullAvailPageFile |
Public Field | ullAvailPhys |
Public Field | ullAvailVirtual |
Public Field | ullTotalPageFile |
Public Field | ullTotalPhys |
Public Field | ullTotalVirtual |
Top

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
dwLength Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : dwLength Field

Syntax

Visual Basic (Declaration)
Public dwLength As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As UInteger

value = instance.dwLength

instance.dwLength = value
C#
public uint dwLength
Managed Extensions for C++
public: uint dwLength
C++/CLI
public:
uint dwLength

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
dwMemoryLoad Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : dwMemoryLoad Field

Syntax

Visual Basic (Declaration)
Public dwMemoryLoad As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As UInteger

value = instance.dwMemoryLoad

instance.dwMemoryLoad = value
C#
public uint dwMemoryLoad
Managed Extensions for C++
public: uint dwMemoryLoad
C++/CLI
public:
uint dwMemoryLoad

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ullAvailExtendedVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullAvailExtendedVirtual Field

Syntax

Visual Basic (Declaration)
Public ullAvailExtendedVirtual As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullAvailExtendedVirtual

instance.ullAvailExtendedVirtual = value
C#
public ulong ullAvailExtendedVirtual
Managed Extensions for C++
public: ulong ullAvailExtendedVirtual
C++/CLI
public:
ulong ullAvailExtendedVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ullAvailPageFile Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullAvailPageFile Field

Syntax

Visual Basic (Declaration)
Public ullAvailPageFile As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullAvailPageFile

instance.ullAvailPageFile = value
C#
public ulong ullAvailPageFile
Managed Extensions for C++
public: ulong ullAvailPageFile
C++/CLI
public:
ulong ullAvailPageFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ullAvailPhys Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullAvailPhys Field

Syntax

Visual Basic (Declaration)
Public ullAvailPhys As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullAvailPhys

instance.ullAvailPhys = value
C#
public ulong ullAvailPhys
Managed Extensions for C++
public: ulong ullAvailPhys
C++/CLI
public:
ulong ullAvailPhys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ullAvailVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullAvailVirtual Field

Syntax

Visual Basic (Declaration)
Public ullAvailVirtual As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullAvailVirtual

instance.ullAvailVirtual = value
C#
public ulong ullAvailVirtual
Managed Extensions for C++
public: ulong ullAvailVirtual
C++/CLI
public:
ulong ullAvailVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ullTotalPageFile Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullTotalPageFile Field

Syntax

Visual Basic (Declaration)
Public ullTotalPageFile As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullTotalPageFile

instance.ullTotalPageFile = value
C#
public ulong ullTotalPageFile
Managed Extensions for C++
public: ulong ullTotalPageFile
C++/CLI
public:
ulong ullTotalPageFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ullTotalPhys Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullTotalPhys Field

Syntax

Visual Basic (Declaration)
Public ullTotalPhys As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullTotalPhys

instance.ullTotalPhys = value
C#
public ulong ullTotalPhys
Managed Extensions for C++
public: ulong ullTotalPhys
C++/CLI
public:
ulong ullTotalPhys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ullTotalVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullTotalVirtual Field

Syntax

Visual Basic (Declaration)
Public ullTotalVirtual As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullTotalVirtual

instance.ullTotalVirtual = value
C#
public ulong ullTotalVirtual
Managed Extensions for C++
public: ulong ullTotalVirtual
C++/CLI
public:
ulong ullTotalVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure

declare the IP_ADAPTERINFO_STRUCTURE structure

Object Model

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile.IP_ADAPTERINFO_STRUCTURE
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
C#
private struct MachineProfile.IP_ADAPTERINFO_STRUCTURE : ValueType
Managed Extensions for C++
private __value struct MachineProfile.IP_ADAPTERINFO_STRUCTURE : public ValueType
C++/CLI
private value class MachineProfile.IP_ADAPTERINFO_STRUCTURE : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile.IP_ADAPTERINFO_STRUCTURE

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure

The following tables list the members exposed by MachineProfile.IP_ADAPTERINFO_STRUCTURE.

Public Fields

 | Name | Description
Public Field | AdapterName | Specifies the name of the adapter
Public Field | Address | Specifies the hardware address for the adapter
Public Field | AddressLength | Specifies the length of the hardware address for the adapter
Public Field | ComboIndex | Reserved
Public Field | CurrentIPAddress | Specifies the current IP address for this adapter
Public Field | Description | Specifies a description for the adapter
Public Field | DhcpEnabled | Specifies whether dynamic host configuration protocol (DHCP) is enabled for this adapter
Public Field | DhcpServer | Specifies the IP address of the DHCP server for this adapter
Public Field | GatewayList | Specifies the IP address of the default gateway for this adapter
Public Field | HaveWins | Specifies whether this adapter uses Windows Internet Name Service (WINS)
Public Field | Index | Specifies the adapter index
Public Field | IpAddressList | Specifies the list of IP addresses associated with this adapter
Public Field | LeaseExpires | Specifies the time when the current DHCP lease will expire
Public Field | LeaseObtained | Specifies the time when the current DHCP lease was obtained
Public Field | Next | Pointer to the next adapter in the list of adapters
Public Field | PrimaryWinsServer | Specifies the IP address of the primary WINS server
Public Field | SecondaryWinsServer | Specifies the IP address of the secondary WINS server
Public Field | Type | Specifies the adapter type. The type is one of the following values. IF_OTHER_ADAPTERTYPE IF_ETHERNET_ADAPTERTYPE IF_TOKEN_RING_ADAPTERTYPE IF_FDDI_ADAPTERTYPE IF_PPP_ADAPTERTYPE IF_LOOPBACK_ADAPTERTYPE IF_SLIP_ADAPTERTYPE These values are defined in the header file IPIfCons.h
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET Send comments on this topic.
MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure

For a list of all members of this type, see MachineProfile.IP_ADAPTERINFO_STRUCTURE members.

Public Fields

 | Name | Description
Public Field | AdapterName | Specifies the name of the adapter
Public Field | Address | Specifies the hardware address for the adapter
Public Field | AddressLength | Specifies the length of the hardware address for the adapter
Public Field | ComboIndex | Reserved
Public Field | CurrentIPAddress | Specifies the current IP address for this adapter
Public Field | Description | Specifies a description for the adapter
Public Field | DhcpEnabled | Specifies whether dynamic host configuration protocol (DHCP) is enabled for this adapter
Public Field | DhcpServer | Specifies the IP address of the DHCP server for this adapter
Public Field | GatewayList | Specifies the IP address of the default gateway for this adapter
Public Field | HaveWins | Specifies whether this adapter uses Windows Internet Name Service (WINS)
Public Field | Index | Specifies the adapter index
Public Field | IpAddressList | Specifies the list of IP addresses associated with this adapter
Public Field | LeaseExpires | Specifies the time when the current DHCP lease will expire
Public Field | LeaseObtained | Specifies the time when the current DHCP lease was obtained
Public Field | Next | Pointer to the next adapter in the list of adapters
Public Field | PrimaryWinsServer | Specifies the IP address of the primary WINS server
Public Field | SecondaryWinsServer | Specifies the IP address of the secondary WINS server
Public Field | Type | Specifies the adapter type. The type is one of the following values. IF_OTHER_ADAPTERTYPE IF_ETHERNET_ADAPTERTYPE IF_TOKEN_RING_ADAPTERTYPE IF_FDDI_ADAPTERTYPE IF_PPP_ADAPTERTYPE IF_LOOPBACK_ADAPTERTYPE IF_SLIP_ADAPTERTYPE These values are defined in the header file IPIfCons.h
Top

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
AdapterName Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : AdapterName Field

Specifies the name of the adapter

Syntax

Visual Basic (Declaration)
Public AdapterName As Char()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value() As Char

value = instance.AdapterName

instance.AdapterName = value
C#
public char[] AdapterName
Managed Extensions for C++
public: char[] AdapterName
C++/CLI
public:
array<char> AdapterName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Address Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Address Field

Specifies the hardware address for the adapter

Syntax

Visual Basic (Declaration)
Public Address As Byte()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value() As Byte

value = instance.Address

instance.Address = value
C#
public byte[] Address
Managed Extensions for C++
public: byte[] Address
C++/CLI
public:
array<byte> Address

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
AddressLength Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : AddressLength Field

Specifies the length of the hardware address for the adapter

Syntax

Visual Basic (Declaration)
Public AddressLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.AddressLength

instance.AddressLength = value
C#
public int AddressLength
Managed Extensions for C++
public: int AddressLength
C++/CLI
public:
int AddressLength

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
ComboIndex Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : ComboIndex Field

Reserved

Syntax

Visual Basic (Declaration)
Public ComboIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.ComboIndex

instance.ComboIndex = value
C#
public int ComboIndex
Managed Extensions for C++
public: int ComboIndex
C++/CLI
public:
int ComboIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
CurrentIPAddress Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : CurrentIPAddress Field

Specifies the current IP address for this adapter

Syntax

Visual Basic (Declaration)
Public CurrentIPAddress As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.CurrentIPAddress

instance.CurrentIPAddress = value
C#
public int CurrentIPAddress
Managed Extensions for C++
public: int CurrentIPAddress
C++/CLI
public:
int CurrentIPAddress

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Description Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Description Field

Specifies a description for the adapter

Syntax

Visual Basic (Declaration)
Public Description As Char()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value() As Char

value = instance.Description

instance.Description = value
C#
public char[] Description
Managed Extensions for C++
public: char[] Description
C++/CLI
public:
array<char> Description

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
DhcpEnabled Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : DhcpEnabled Field

Specifies whether dynamic host configuration protocol (DHCP) is enabled for this adapter

Syntax

Visual Basic (Declaration)
Public DhcpEnabled As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.DhcpEnabled

instance.DhcpEnabled = value
C#
public int DhcpEnabled
Managed Extensions for C++
public: int DhcpEnabled
C++/CLI
public:
int DhcpEnabled

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
DhcpServer Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : DhcpServer Field

Specifies the IP address of the DHCP server for this adapter

Syntax

Visual Basic (Declaration)
Public DhcpServer As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.DhcpServer

instance.DhcpServer = value
C#
public MachineProfile.IP_ADDR_STRING DhcpServer
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING DhcpServer
C++/CLI
public:
MachineProfile.IP_ADDR_STRING DhcpServer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
GatewayList Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : GatewayList Field

Specifies the IP address of the default gateway for this adapter

Syntax

Visual Basic (Declaration)
Public GatewayList As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.GatewayList

instance.GatewayList = value
C#
public MachineProfile.IP_ADDR_STRING GatewayList
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING GatewayList
C++/CLI
public:
MachineProfile.IP_ADDR_STRING GatewayList

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
HaveWins Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : HaveWins Field

Specifies whether this adapter uses Windows Internet Name Service (WINS)

Syntax

Visual Basic (Declaration)
Public HaveWins As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Byte

value = instance.HaveWins

instance.HaveWins = value
C#
public byte HaveWins
Managed Extensions for C++
public: byte HaveWins
C++/CLI
public:
byte HaveWins

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Index Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Index Field

Specifies the adapter index

Syntax

Visual Basic (Declaration)
Public Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.Index

instance.Index = value
C#
public int Index
Managed Extensions for C++
public: int Index
C++/CLI
public:
int Index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IpAddressList Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : IpAddressList Field

Specifies the list of IP addresses associated with this adapter

Syntax

Visual Basic (Declaration)
Public IpAddressList As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.IpAddressList

instance.IpAddressList = value
C#
public MachineProfile.IP_ADDR_STRING IpAddressList
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING IpAddressList
C++/CLI
public:
MachineProfile.IP_ADDR_STRING IpAddressList

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LeaseExpires Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : LeaseExpires Field

Specifies the time when the current DHCP lease will expire

Syntax

Visual Basic (Declaration)
Public LeaseExpires As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.LeaseExpires

instance.LeaseExpires = value
C#
public int LeaseExpires
Managed Extensions for C++
public: int LeaseExpires
C++/CLI
public:
int LeaseExpires

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
LeaseObtained Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : LeaseObtained Field

Specifies the time when the current DHCP lease was obtained

Syntax

Visual Basic (Declaration)
Public LeaseObtained As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.LeaseObtained

instance.LeaseObtained = value
C#
public int LeaseObtained
Managed Extensions for C++
public: int LeaseObtained
C++/CLI
public:
int LeaseObtained

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Next Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Next Field

Pointer to the next adapter in the list of adapters

Syntax

Visual Basic (Declaration)
Public Next As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As UInteger

value = instance.Next

instance.Next = value
C#
public uint Next
Managed Extensions for C++
public: uint Next
C++/CLI
public:
uint Next

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
PrimaryWinsServer Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : PrimaryWinsServer Field

Specifies the IP address of the primary WINS server

Syntax

Visual Basic (Declaration)
Public PrimaryWinsServer As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.PrimaryWinsServer

instance.PrimaryWinsServer = value
C#
public MachineProfile.IP_ADDR_STRING PrimaryWinsServer
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING PrimaryWinsServer
C++/CLI
public:
MachineProfile.IP_ADDR_STRING PrimaryWinsServer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
SecondaryWinsServer Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : SecondaryWinsServer Field

Specifies the IP address of the secondary WINS server

Syntax

Visual Basic (Declaration)
Public SecondaryWinsServer As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.SecondaryWinsServer

instance.SecondaryWinsServer = value
C#
public MachineProfile.IP_ADDR_STRING SecondaryWinsServer
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING SecondaryWinsServer
C++/CLI
public:
MachineProfile.IP_ADDR_STRING SecondaryWinsServer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Type Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Type Field

Specifies the adapter type. The type is one of the following values. IF_OTHER_ADAPTERTYPE IF_ETHERNET_ADAPTERTYPE IF_TOKEN_RING_ADAPTERTYPE IF_FDDI_ADAPTERTYPE IF_PPP_ADAPTERTYPE IF_LOOPBACK_ADAPTERTYPE IF_SLIP_ADAPTERTYPE These values are defined in the header file IPIfCons.h

Syntax

Visual Basic (Declaration)
Public Type As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.Type

instance.Type = value
C#
public int Type
Managed Extensions for C++
public: int Type
C++/CLI
public:
int Type

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MachineProfile.IP_ADDR_STRING Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADDR_STRING Structure

declare the IP_ADDR_STRING structure

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile.IP_ADDR_STRING
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
C#
private struct MachineProfile.IP_ADDR_STRING : ValueType
Managed Extensions for C++
private __value struct MachineProfile.IP_ADDR_STRING : public ValueType
C++/CLI
private value class MachineProfile.IP_ADDR_STRING : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile.IP_ADDR_STRING

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
MachineProfile.IP_ADDR_STRING Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADDR_STRING Structure

The following tables list the members exposed by MachineProfile.IP_ADDR_STRING.

Public Fields

 | Name | Description
Public Field | Context | Specifies network table entry (NTE). This value corresponds to the NTEContext parameters in the AddIPAddress and DeleteIPAddress functions
Public Field | IpAddress | This array holds the IP address
Public Field | IpMask | This array holds the IP address mask
Public Field | Next | Pointer to the next IP_ADDR_STRING structure in the list
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET Send comments on this topic.
MachineProfile.IP_ADDR_STRING Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADDR_STRING Structure

For a list of all members of this type, see MachineProfile.IP_ADDR_STRING members.

Public Fields

 | Name | Description
Public Field | Context | Specifies network table entry (NTE). This value corresponds to the NTEContext parameters in the AddIPAddress and DeleteIPAddress functions
Public Field | IpAddress | This array holds the IP address
Public Field | IpMask | This array holds the IP address mask
Public Field | Next | Pointer to the next IP_ADDR_STRING structure in the list
Top

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Context Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADDR_STRING Structure : Context Field

Specifies network table entry (NTE). This value corresponds to the NTEContext parameters in the AddIPAddress and DeleteIPAddress functions

Syntax

Visual Basic (Declaration)
Public Context As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
Dim value As Integer

value = instance.Context

instance.Context = value
C#
public int Context
Managed Extensions for C++
public: int Context
C++/CLI
public:
int Context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
MachineProfile.IP_ADDR_STRING Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IpAddress Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADDR_STRING Structure : IpAddress Field

This array holds the IP address

Syntax

Visual Basic (Declaration)
Public IpAddress As Char()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
Dim value() As Char

value = instance.IpAddress

instance.IpAddress = value
C#
public char[] IpAddress
Managed Extensions for C++
public: char[] IpAddress
C++/CLI
public:
array<char> IpAddress

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
MachineProfile.IP_ADDR_STRING Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
IpMask Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADDR_STRING Structure : IpMask Field

This array holds the IP address mask

Syntax

Visual Basic (Declaration)
Public IpMask As Char()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
Dim value() As Char

value = instance.IpMask

instance.IpMask = value
C#
public char[] IpMask
Managed Extensions for C++
public: char[] IpMask
C++/CLI
public:
array<char> IpMask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
MachineProfile.IP_ADDR_STRING Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Next Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADDR_STRING Structure : Next Field

Pointer to the next IP_ADDR_STRING structure in the list

Syntax

Visual Basic (Declaration)
Public Next As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
Dim value As Integer

value = instance.Next

instance.Next = value
C#
public int Next
Managed Extensions for C++
public: int Next
C++/CLI
public:
int Next

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
MachineProfile.IP_ADDR_STRING Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
MachineProfile.TGuid Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.TGuid Structure

Summary of TGuid

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile.TGuid
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
C#
private struct MachineProfile.TGuid : ValueType
Managed Extensions for C++
private __value struct MachineProfile.TGuid : public ValueType
C++/CLI
private value class MachineProfile.TGuid : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile.TGuid

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET Send comments on this topic.
MachineProfile.TGuid Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile.TGuid Structure

The following tables list the members exposed by MachineProfile.TGuid.

Public Fields

 | Name | Description
Public Field | a |
Public Field | b |
Public Field | d |
Public Field | m |
Public Field | m1 |
Public Field | m2 |
Public Field | m3 |
Public Field | m4 |
Public Field | m5 |
Public Field | m6 |
Public Field | s |
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.TGuid Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET Send comments on this topic.
MachineProfile.TGuid Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.TGuid Structure

For a list of all members of this type, see MachineProfile.TGuid members.

Public Fields

 | Name | Description
Public Field | a |
Public Field | b |
Public Field | d |
Public Field | m |
Public Field | m1 |
Public Field | m2 |
Public Field | m3 |
Public Field | m4 |
Public Field | m5 |
Public Field | m6 |
Public Field | s |
Top

See Also

Reference

MachineProfile.TGuid Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
a Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : a Field

Syntax

Visual Basic (Declaration)
Public a As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.a

instance.a = value
C#
public short a
Managed Extensions for C++
public: short a
C++/CLI
public:
short a

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
b Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : b Field

Syntax

Visual Basic (Declaration)
Public b As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.b

instance.b = value
C#
public short b
Managed Extensions for C++
public: short b
C++/CLI
public:
short b

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
d Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : d Field

Syntax

Visual Basic (Declaration)
Public d As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.d

instance.d = value
C#
public short d
Managed Extensions for C++
public: short d
C++/CLI
public:
short d

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
m Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m Field

Syntax

Visual Basic (Declaration)
Public m As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.m

instance.m = value
C#
public short m
Managed Extensions for C++
public: short m
C++/CLI
public:
short m

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
m1 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m1 Field

Syntax

Visual Basic (Declaration)
Public m1 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m1

instance.m1 = value
C#
public byte m1
Managed Extensions for C++
public: byte m1
C++/CLI
public:
byte m1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
m2 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m2 Field

Syntax

Visual Basic (Declaration)
Public m2 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m2

instance.m2 = value
C#
public byte m2
Managed Extensions for C++
public: byte m2
C++/CLI
public:
byte m2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
m3 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m3 Field

Syntax

Visual Basic (Declaration)
Public m3 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m3

instance.m3 = value
C#
public byte m3
Managed Extensions for C++
public: byte m3
C++/CLI
public:
byte m3

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
m4 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m4 Field

Syntax

Visual Basic (Declaration)
Public m4 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m4

instance.m4 = value
C#
public byte m4
Managed Extensions for C++
public: byte m4
C++/CLI
public:
byte m4

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
m5 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m5 Field

Syntax

Visual Basic (Declaration)
Public m5 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m5

instance.m5 = value
C#
public byte m5
Managed Extensions for C++
public: byte m5
C++/CLI
public:
byte m5

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
m6 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m6 Field

Syntax

Visual Basic (Declaration)
Public m6 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m6

instance.m6 = value
C#
public byte m6
Managed Extensions for C++
public: byte m6
C++/CLI
public:
byte m6

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
s Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : s Field

Syntax

Visual Basic (Declaration)
Public s As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.s

instance.s = value
C#
public short s
Managed Extensions for C++
public: short s
C++/CLI
public:
short s

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


$$INTRODUCTION$$ - %%projecttitle%%

Barcode4NET.Windows Send comments on this topic.
Introduction
Welcome to Barcode4NET Windows Forms controls online help.


%%phrase%%

Barcode4NET.Windows Send comments on this topic.
Barcode4NET.Windows Assembly
The Barcode4NET.Windows assembly includes the BarcodeView and BarcodeTextBox controls.

Namespaces

Namespace | Description
Internal |
O2S.Barcode4NET.Licensing |
O2S.Barcode4NET.WinControls | Root namespace for Windows Forms barcode controls included in Barcode4NET toolkit.
Xheo.Licensing |


$$GETTING_STARTED$$ - %%projecttitle%%

Barcode4NET.Windows Send comments on this topic.
Getting Started
This online help will help you get started with BarcodeView and BarcodeTextBox Windows Forms controls.


%%ItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Internal Namespace (Barcode4NET.Windows)
See Also Inheritance Hierarchy

Classes

Class | Description
BigInteger | Implements an large integer of arbitrary length.
CommonRegexes | Declares static versions of some common regular expressions.

See Also

Reference

Barcode4NET.Windows Assembly


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Class
See Also Members
[image]
Internal Namespace : BigInteger Class

Implements an large integer of arbitrary length.

Syntax

Visual Basic (Declaration)
Private Class BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
C#
private class BigInteger
Managed Extensions for C++
private __gc class BigInteger
C++/CLI
private ref class BigInteger

Inheritance Hierarchy

System.Object
Internal.BigInteger

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Members
Internal Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
BigInteger Class Members
See Also Properties Methods
[image]
Internal Namespace : BigInteger Class

The following tables list the members exposed by BigInteger.

Public Constructors

 | Name | Description
Public Constructor | BigInteger Constructor | Overloaded. Initializes a new instance of the BigInteger class.
Top

Public Properties

 | Name | Description
Public Property | Bits | Gets the position of the most significant bit in the value.
Top

Public Methods

 | Name | Description
Public Method | Abs | Returns the absolute value of the BigInteger.
Public Method | Equals | Overridden. Overrides the equals comparison.
Public Method | Gcd | Returns the GCD(this, bi)
Public Method | GenerateCoPrime | Generates a random number with the specified number of bits such that Gcd(number, this) = 1
static (Shared in Visual Basic) | GeneratePseudoPrime | Makes a pseudoprime number that requires at least the given number of bits.
Public Method | GenerateRandomBits | Fills the BigInteger with random bits.
Public Method | GetBytes | Returns the value of the BigInteger as a byte array. The lowest index contains the MSB.
Public Method | GetHashCode | Overridden. Gets the hash code for the value.
Public Method | IntValue | Returns the lowest 4 bytes of the BigInteger as an int.
Public Method | IsProbablePrime | Determines whether a number is probably prime, using the Rabin-Miller's test. Before applying the test, the number is tested for divisibility by primes < 2000
Public Method | LongValue | Returns the lowest 8 bytes of the BigInteger as a long.
Public Method | ModInverse | Returns the modulo inverse of this. Throws ArithmeticException if the inverse does not exist. (i.e. Gcd(this, modulus) != 1)
Public Method | ModPow | Modulo Exponentiation. ( this ^ exp ) % n.
Public Method | Sqrt | Returns a value that is equivalent to the integer square root of the BigInteger.
Public Method | ToString | Overloaded. Overridden. Returns a string representation of the value.
Public Method | ULongValue | Returns the lowest 8 bytes of the BigInteger as a long.
Top

Public Operators

Public Operator Addition | Adds two BigInteger values together.
Public Operator And | Bitwise AND operator.
Public Operator Or | Bitwise OR operator.
Public Operator Decrement | Decrements the BigInteger value by one.
Public Operator Division | Division operator.
Public Operator Equality | Equality operator.
Public Operator Exclusive Or | Bitwise XOR operator.
Public Operator Greater Than | Greater than operator.
Public Operator Greater Than or Equal | Greater than or equal operator.
Public Operator Implicit Type Conversion | Overloaded.
Public Operator Increment | Increments the BigInteger value by 1.
Public Operator Inequality | Inequality operator.
Public Operator Left-shift | Shifts the bits to the left.
Public Operator Less Than | Less than operator.
Public Operator Less Than or Equal | Less than or equal operator.
Public Operator Modulus | Modulus operator.
Public Operator Multiplication | Multiplies two BigInteger values.
Public Operator Bitwise Complement | Implements a 1's compliment.
Public Operator Right-shift | Shifts the bits to the right.
Public Operator Subtraction | Subtracts one BigInteger from another.
Public Operator Unary Negation | Implements a 2's compliment (negative).
Top

See Also

Reference

BigInteger Class
Internal Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Constructor
See Also
[image]
Internal Namespace > BigInteger Class : BigInteger Constructor

Initializes a new instance of the BigInteger class.

Overload List

Overload | Description
BigInteger Constructor() | Initializes a new instance of the BigInteger class.
BigInteger Constructor(BigInteger) | Initializes a new instance of the BigInteger class from an existing instance.
BigInteger Constructor(Byte[]) | Initializes a new instance of the BigInteger class from an array of existing bytes.
BigInteger Constructor(Byte[],Int32) | Initializes a new instance of the BigInteger class from an array of existing bytes.
BigInteger Constructor(Int64) | Initializes a new instance of the BigInteger class from a Int64 value.
BigInteger Constructor(String,Int32) | Initializes a new instance of the BigInteger class from a string representation in the given radix.
BigInteger Constructor(UInt64) | Initializes a new instance of the BigInteger class from a UInt64 value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Constructor()
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor()

Initializes a new instance of the BigInteger class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BigInteger()
C#
public BigInteger()
Managed Extensions for C++
public: BigInteger();
C++/CLI
public:
BigInteger();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Constructor(BigInteger)
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(BigInteger)

bi
The BigInteger to initialize from.
Initializes a new instance of the BigInteger class from an existing instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bi As BigInteger _
)
Visual Basic (Usage) Copy Code
Dim bi As BigInteger

Dim instance As BigInteger(bi)
C#
public BigInteger(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger(
   BigInteger* bi
)
C++/CLI
public:
BigInteger(
   BigInteger^ bi
)

Parameters

bi
The BigInteger to initialize from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Constructor(Byte[])
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Byte[])

inData
The values to initialize from.
Initializes a new instance of the BigInteger class from an array of existing bytes.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As Byte _
)
Visual Basic (Usage) Copy Code
Dim inData() As Byte

Dim instance As BigInteger(inData)
C#
public BigInteger(
   byte[] inData
)
Managed Extensions for C++
public: BigInteger(
   byte[] inData
)
C++/CLI
public:
BigInteger(
   array<byte> inData
)

Parameters

inData
The values to initialize from.

Remarks

The lowest index of the input byte array (i.e [0]) should contain the most significant byte of the number, and the highest index should contain the least significant byte.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Constructor(Byte[],Int32)
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Byte[],Int32)

inData
The values to initialize from.
inLen
The length of the initialization array to use.
Initializes a new instance of the BigInteger class from an array of existing bytes.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As Byte, _
   ByVal inLen As Integer _
)
Visual Basic (Usage) Copy Code
Dim inData() As Byte
Dim inLen As Integer

Dim instance As BigInteger(inData, inLen)
C#
public BigInteger(
   byte[] inData,
   int inLen
)
Managed Extensions for C++
public: BigInteger(
   byte[] inData,
   int inLen
)
C++/CLI
public:
BigInteger(
   array<byte> inData,
   int inLen
)

Parameters

inData
The values to initialize from.
inLen
The length of the initialization array to use.

Remarks

The lowest index of the input byte array (i.e [0]) should contain the most significant byte of the number, and the highest index should contain the least significant byte.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Constructor(Int64)
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Int64)

value
The value to initialize with.
Initializes a new instance of the BigInteger class from a Int64 value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim value As Long

Dim instance As BigInteger(value)
C#
public BigInteger(
   long value
)
Managed Extensions for C++
public: BigInteger(
   long value
)
C++/CLI
public:
BigInteger(
   long value
)

Parameters

value
The value to initialize with.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Constructor(String,Int32)
See Also Example
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(String,Int32)

value
The string value to initialize from.
radix
The radix (or base) the value is offered as.
Initializes a new instance of the BigInteger class from a string representation in the given radix.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal radix As Integer _
)
Visual Basic (Usage) Copy Code
Dim value As String
Dim radix As Integer

Dim instance As BigInteger(value, radix)
C#
public BigInteger(
   string value,
   int radix
)
Managed Extensions for C++
public: BigInteger(
   string* value,
   int radix
)
C++/CLI
public:
BigInteger(
   String^ value,
   int radix
)

Parameters

value
The string value to initialize from.
radix
The radix (or base) the value is offered as.

Example

Example in Base 10

Example in Base 16 (HEX)

C# Copy Code
BigInteger a = new BigInteger( "1234", 10 );
            BigInteger b = new BigInteger( "-1234", 10 )
C# Copy Code
BigInteger a = new BigInteger( "1D4F", 16 );
            BigInteger b = new BigInteger( "-1D4F", 10 )

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Constructor(UInt64)
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(UInt64)

value
The value to initialize with.
Initializes a new instance of the BigInteger class from a UInt64 value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As ULong _
)
Visual Basic (Usage) Copy Code
Dim value As ULong

Dim instance As BigInteger(value)
C#
public BigInteger(
   ulong value
)
Managed Extensions for C++
public: BigInteger(
   ulong value
)
C++/CLI
public:
BigInteger(
   ulong value
)

Parameters

value
The value to initialize with.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
BigInteger Class Methods
See Also
[image]
Internal Namespace : BigInteger Class

For a list of all members of this type, see BigInteger members.

Public Methods

 | Name | Description
Public Method | Abs | Returns the absolute value of the BigInteger.
Public Method | Equals | Overridden. Overrides the equals comparison.
Public Method | Gcd | Returns the GCD(this, bi)
Public Method | GenerateCoPrime | Generates a random number with the specified number of bits such that Gcd(number, this) = 1
static (Shared in Visual Basic) | GeneratePseudoPrime | Makes a pseudoprime number that requires at least the given number of bits.
Public Method | GenerateRandomBits | Fills the BigInteger with random bits.
Public Method | GetBytes | Returns the value of the BigInteger as a byte array. The lowest index contains the MSB.
Public Method | GetHashCode | Overridden. Gets the hash code for the value.
Public Method | IntValue | Returns the lowest 4 bytes of the BigInteger as an int.
Public Method | IsProbablePrime | Determines whether a number is probably prime, using the Rabin-Miller's test. Before applying the test, the number is tested for divisibility by primes < 2000
Public Method | LongValue | Returns the lowest 8 bytes of the BigInteger as a long.
Public Method | ModInverse | Returns the modulo inverse of this. Throws ArithmeticException if the inverse does not exist. (i.e. Gcd(this, modulus) != 1)
Public Method | ModPow | Modulo Exponentiation. ( this ^ exp ) % n.
Public Method | Sqrt | Returns a value that is equivalent to the integer square root of the BigInteger.
Public Method | ToString | Overloaded. Overridden. Returns a string representation of the value.
Public Method | ULongValue | Returns the lowest 8 bytes of the BigInteger as a long.
Top

See Also

Reference

BigInteger Class
Internal Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Abs Method
See Also
[image]
Internal Namespace > BigInteger Class : Abs Method

Returns the absolute value of the BigInteger.

Syntax

Visual Basic (Declaration)
Public Function Abs() As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As BigInteger

value = instance.Abs()
C#
public BigInteger Abs()
Managed Extensions for C++
public: BigInteger* Abs();
C++/CLI
public:
BigInteger^ Abs();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Equals Method
See Also
[image]
Internal Namespace > BigInteger Class : Equals Method

o
Overrides the equals comparison.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal o As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim o As Object
Dim value As Boolean

value = instance.Equals(o)
C#
public override bool Equals(
   object o
)
Managed Extensions for C++
public: bool Equals(
   Object* o
) override
C++/CLI
public:
bool Equals(
   Object^ o
) override

Parameters

o

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Gcd Method
See Also
[image]
Internal Namespace > BigInteger Class : Gcd Method

bi
Returns the GCD(this, bi)

Syntax

Visual Basic (Declaration)
Public Function Gcd( _
   ByVal bi As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bi As BigInteger
Dim value As BigInteger

value = instance.Gcd(bi)
C#
public BigInteger Gcd(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger* Gcd(
   BigInteger* bi
)
C++/CLI
public:
BigInteger^ Gcd(
   BigInteger^ bi
)

Parameters

bi

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GenerateCoPrime Method
See Also
[image]
Internal Namespace > BigInteger Class : GenerateCoPrime Method

bits
Bits to use.
rand
Random number generator.
Generates a random number with the specified number of bits such that Gcd(number, this) = 1

Syntax

Visual Basic (Declaration)
Public Function GenerateCoPrime( _
   ByVal bits As Integer, _
   ByVal rand As Random _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bits As Integer
Dim rand As Random
Dim value As BigInteger

value = instance.GenerateCoPrime(bits, rand)
C#
public BigInteger GenerateCoPrime(
   int bits,
   Random rand
)
Managed Extensions for C++
public: BigInteger* GenerateCoPrime(
   int bits,
   Random* rand
)
C++/CLI
public:
BigInteger^ GenerateCoPrime(
   int bits,
   Random^ rand
)

Parameters

bits
Bits to use.
rand
Random number generator.

Return Value

Returns the co prime.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GeneratePseudoPrime Method
See Also
[image]
Internal Namespace > BigInteger Class : GeneratePseudoPrime Method

bits
The number of bits to use.
confidence
The amount of confidence required...a lower value is more confident.
rand
The random number generator.
Makes a pseudoprime number that requires at least the given number of bits.

Syntax

Visual Basic (Declaration)
Public Shared Function GeneratePseudoPrime( _
   ByVal bits As Integer, _
   ByVal confidence As Integer, _
   ByVal rand As Random _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim bits As Integer
Dim confidence As Integer
Dim rand As Random
Dim value As BigInteger

value = BigInteger.GeneratePseudoPrime(bits, confidence, rand)
C#
public static BigInteger GeneratePseudoPrime(
   int bits,
   int confidence,
   Random rand
)
Managed Extensions for C++
public: static BigInteger* GeneratePseudoPrime(
   int bits,
   int confidence,
   Random* rand
)
C++/CLI
public:
static BigInteger^ GeneratePseudoPrime(
   int bits,
   int confidence,
   Random^ rand
)

Parameters

bits
The number of bits to use.
confidence
The amount of confidence required...a lower value is more confident.
rand
The random number generator.

Return Value

Returns a pseudo prime number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GenerateRandomBits Method
See Also
[image]
Internal Namespace > BigInteger Class : GenerateRandomBits Method

bits
The minimum number of bits.
rand
The random number generator.
Fills the BigInteger with random bits.

Syntax

Visual Basic (Declaration)
Public Sub GenerateRandomBits( _
   ByVal bits As Integer, _
   ByVal rand As Random _
)
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bits As Integer
Dim rand As Random

instance.GenerateRandomBits(bits, rand)
C#
public void GenerateRandomBits(
   int bits,
   Random rand
)
Managed Extensions for C++
public: void GenerateRandomBits(
   int bits,
   Random* rand
)
C++/CLI
public:
void GenerateRandomBits(
   int bits,
   Random^ rand
)

Parameters

bits
The minimum number of bits.
rand
The random number generator.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetBytes Method
See Also
[image]
Internal Namespace > BigInteger Class : GetBytes Method

Returns the value of the BigInteger as a byte array. The lowest index contains the MSB.

Syntax

Visual Basic (Declaration)
Public Function GetBytes() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value() As Byte

value = instance.GetBytes()
C#
public byte[] GetBytes()
Managed Extensions for C++
public: byte[] GetBytes();
C++/CLI
public:
array<byte> GetBytes();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetHashCode Method
See Also
[image]
Internal Namespace > BigInteger Class : GetHashCode Method

Gets the hash code for the value.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IntValue Method
See Also
[image]
Internal Namespace > BigInteger Class : IntValue Method

Returns the lowest 4 bytes of the BigInteger as an int.

Syntax

Visual Basic (Declaration)
Public Function IntValue() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.IntValue()
C#
public int IntValue()
Managed Extensions for C++
public: int IntValue();
C++/CLI
public:
int IntValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IsProbablePrime Method
See Also
[image]
Internal Namespace > BigInteger Class : IsProbablePrime Method

confidence
Amount of confidence allowed.
Determines whether a number is probably prime, using the Rabin-Miller's test. Before applying the test, the number is tested for divisibility by primes < 2000

Syntax

Visual Basic (Declaration)
Public Function IsProbablePrime( _
   ByVal confidence As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim confidence As Integer
Dim value As Boolean

value = instance.IsProbablePrime(confidence)
C#
public bool IsProbablePrime(
   int confidence
)
Managed Extensions for C++
public: bool IsProbablePrime(
   int confidence
)
C++/CLI
public:
bool IsProbablePrime(
   int confidence
)

Parameters

confidence
Amount of confidence allowed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LongValue Method
See Also
[image]
Internal Namespace > BigInteger Class : LongValue Method

Returns the lowest 8 bytes of the BigInteger as a long.

Syntax

Visual Basic (Declaration)
Public Function LongValue() As Long
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Long

value = instance.LongValue()
C#
public long LongValue()
Managed Extensions for C++
public: long LongValue();
C++/CLI
public:
long LongValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ModInverse Method
See Also
[image]
Internal Namespace > BigInteger Class : ModInverse Method

modulus
Returns the modulo inverse of this. Throws ArithmeticException if the inverse does not exist. (i.e. Gcd(this, modulus) != 1)

Syntax

Visual Basic (Declaration)
Public Function ModInverse( _
   ByVal modulus As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim modulus As BigInteger
Dim value As BigInteger

value = instance.ModInverse(modulus)
C#
public BigInteger ModInverse(
   BigInteger modulus
)
Managed Extensions for C++
public: BigInteger* ModInverse(
   BigInteger* modulus
)
C++/CLI
public:
BigInteger^ ModInverse(
   BigInteger^ modulus
)

Parameters

modulus

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ModPow Method
See Also
[image]
Internal Namespace > BigInteger Class : ModPow Method

exp
Exponent.
n
Modulus.
Modulo Exponentiation. ( this ^ exp ) % n.

Syntax

Visual Basic (Declaration)
Public Function ModPow( _
   ByVal exp As BigInteger, _
   ByVal n As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim exp As BigInteger
Dim n As BigInteger
Dim value As BigInteger

value = instance.ModPow(exp, n)
C#
public BigInteger ModPow(
   BigInteger exp,
   BigInteger n
)
Managed Extensions for C++
public: BigInteger* ModPow(
   BigInteger* exp,
   BigInteger* n
)
C++/CLI
public:
BigInteger^ ModPow(
   BigInteger^ exp,
   BigInteger^ n
)

Parameters

exp
Exponent.
n
Modulus.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Sqrt Method
See Also
[image]
Internal Namespace > BigInteger Class : Sqrt Method

Returns a value that is equivalent to the integer square root of the BigInteger.

Syntax

Visual Basic (Declaration)
Public Function Sqrt() As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As BigInteger

value = instance.Sqrt()
C#
public BigInteger Sqrt()
Managed Extensions for C++
public: BigInteger* Sqrt();
C++/CLI
public:
BigInteger^ Sqrt();

Remarks

The integer square root of "this" is defined as the largest integer n such that (n * n) <= this

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ToString Method
See Also
[image]
Internal Namespace > BigInteger Class : ToString Method

Returns a string representation of the value.

Overload List

Overload | Description
ToString() | Returns a string representation of the value.
ToString(Int32) | Returns a string representing the BigInteger in sign-and-magnitude format in the specified radix.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ToString() Method
See Also
[image]
Internal Namespace > BigInteger Class > ToString Method : ToString() Method

Returns a string representation of the value.

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ToString(Int32) Method
See Also
[image]
Internal Namespace > BigInteger Class > ToString Method : ToString(Int32) Method

radix
The radix (or base) of the value to output. Valid values are from 2 to 36.
Returns a string representing the BigInteger in sign-and-magnitude format in the specified radix.

Syntax

Visual Basic (Declaration)
Overloads Public Function ToString( _
   ByVal radix As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim radix As Integer
Dim value As String

value = instance.ToString(radix)
C#
public string ToString(
   int radix
)
Managed Extensions for C++
public: string* ToString(
   int radix
)
C++/CLI
public:
String^ ToString(
   int radix
)

Parameters

radix
The radix (or base) of the value to output. Valid values are from 2 to 36.

Return Value

Returns the formatted string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ULongValue Method
See Also
[image]
Internal Namespace > BigInteger Class : ULongValue Method

Returns the lowest 8 bytes of the BigInteger as a long.

Syntax

Visual Basic (Declaration)
Public Function ULongValue() As ULong
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As ULong

value = instance.ULongValue()
C#
public ulong ULongValue()
Managed Extensions for C++
public: ulong ULongValue();
C++/CLI
public:
ulong ULongValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Windows Send comments on this topic.
BigInteger Class Properties
See Also
[image]
Internal Namespace : BigInteger Class

For a list of all members of this type, see BigInteger members.

Public Properties

 | Name | Description
Public Property | Bits | Gets the position of the most significant bit in the value.
Top

See Also

Reference

BigInteger Class
Internal Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Bits Property
See Also
[image]
Internal Namespace > BigInteger Class : Bits Property

Gets the position of the most significant bit in the value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bits As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.Bits
C#
public int Bits {get;}
Managed Extensions for C++
public: __property int get_Bits();
C++/CLI
public:
property int Bits {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Addition Operator
See Also
[image]
Internal Namespace > BigInteger Class : Addition Operator

bi1
BigInteger 1.
bi2
BigInteger 2.
Adds two BigInteger values together.

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator +(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Addition(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator +(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
BigInteger 1.
bi2
BigInteger 2.

Return Value

Returns the sum of the two values.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
And Operator
See Also
[image]
Internal Namespace > BigInteger Class : And Operator

bi1
bi2
Bitwise AND operator.

Syntax

Visual Basic (Declaration)
Public Operator And( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator &(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_BitwiseAnd(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator &(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Or Operator
See Also
[image]
Internal Namespace > BigInteger Class : Or Operator

bi1
bi2
Bitwise OR operator.

Syntax

Visual Basic (Declaration)
Public Operator Or( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator |(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_BitwiseOr(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator |(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Decrement Operator
See Also
[image]
Internal Namespace > BigInteger Class : Decrement Operator

bi1
Decrements the BigInteger value by one.

Syntax

Visual Basic (Declaration)
This operator type is not supported by Visual Basic
C#
public BigInteger operator --(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_Decrement(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator --(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Division Operator
See Also
[image]
Internal Namespace > BigInteger Class : Division Operator

bi1
bi2
Division operator.

Syntax

Visual Basic (Declaration)
Public Operator /( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator /(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Division(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator /(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Equality Operator
See Also
[image]
Internal Namespace > BigInteger Class : Equality Operator

bi1
bi2
Equality operator.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator ==(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_Equality(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator ==(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Exclusive Or Operator
See Also
[image]
Internal Namespace > BigInteger Class : Exclusive Or Operator

bi1
bi2
Bitwise XOR operator.

Syntax

Visual Basic (Declaration)
Public Operator Xor( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator ^(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_ExclusiveOr(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator ^(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Greater Than Operator
See Also
[image]
Internal Namespace > BigInteger Class : Greater Than Operator

bi1
bi2
Greater than operator.

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator >(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_GreaterThan(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator >(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Greater Than or Equal Operator
See Also
[image]
Internal Namespace > BigInteger Class : Greater Than or Equal Operator

bi1
bi2
Greater than or equal operator.

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator >=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_GreaterThanOrEqual(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator >=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Implicit Type Conversion Operator
See Also
[image]
Internal Namespace > BigInteger Class : Implicit Type Conversion Operator

Overload List

Overload | Description
Implicit Type Conversion(Int32) |
Implicit Type Conversion(Int64) |
Implicit Type Conversion(UInt32) |
Implicit Type Conversion(UInt64) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Increment Operator
See Also
[image]
Internal Namespace > BigInteger Class : Increment Operator

bi1
Increments the BigInteger value by 1.

Syntax

Visual Basic (Declaration)
This operator type is not supported by Visual Basic
C#
public BigInteger operator ++(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_Increment(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator ++(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Inequality Operator
See Also
[image]
Internal Namespace > BigInteger Class : Inequality Operator

bi1
bi2
Inequality operator.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator !=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_Inequality(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator !=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Left-shift Operator
See Also
[image]
Internal Namespace > BigInteger Class : Left-shift Operator

bi1
shiftVal
Shifts the bits to the left.

Syntax

Visual Basic (Declaration)
Public Operator <<( _
   ByVal bi1 As BigInteger, _
   ByVal shiftVal As Integer _
) As BigInteger
C#
public BigInteger operator <<(
   BigInteger bi1,
   int shiftVal
)
Managed Extensions for C++
public: BigInteger* op_LeftShift(
   BigInteger* bi1,
   int shiftVal
)
C++/CLI
public:
BigInteger^ operator <<(
   BigInteger^ bi1,
   int shiftVal
)

Parameters

bi1
shiftVal

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Less Than Operator
See Also
[image]
Internal Namespace > BigInteger Class : Less Than Operator

bi1
bi2
Less than operator.

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator <(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_LessThan(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator <(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Less Than or Equal Operator
See Also
[image]
Internal Namespace > BigInteger Class : Less Than or Equal Operator

bi1
bi2
Less than or equal operator.

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator <=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_LessThanOrEqual(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator <=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Modulus Operator
See Also
[image]
Internal Namespace > BigInteger Class : Modulus Operator

bi1
bi2
Modulus operator.

Syntax

Visual Basic (Declaration)
Public Operator Mod( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator %(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Modulus(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator %(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Multiplication Operator
See Also
[image]
Internal Namespace > BigInteger Class : Multiplication Operator

bi1
bi2
Multiplies two BigInteger values.

Syntax

Visual Basic (Declaration)
Public Operator *( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator *(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Multiply(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator *(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Bitwise Complement Operator
See Also
[image]
Internal Namespace > BigInteger Class : Bitwise Complement Operator

bi1
Implements a 1's compliment.

Syntax

Visual Basic (Declaration)
Public Operator Not( _
   ByVal bi1 As BigInteger _
) As BigInteger
C#
public BigInteger operator ~(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_OnesComplement(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator ~(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Right-shift Operator
See Also
[image]
Internal Namespace > BigInteger Class : Right-shift Operator

bi1
shiftVal
Shifts the bits to the right.

Syntax

Visual Basic (Declaration)
Public Operator >>( _
   ByVal bi1 As BigInteger, _
   ByVal shiftVal As Integer _
) As BigInteger
C#
public BigInteger operator >>(
   BigInteger bi1,
   int shiftVal
)
Managed Extensions for C++
public: BigInteger* op_RightShift(
   BigInteger* bi1,
   int shiftVal
)
C++/CLI
public:
BigInteger^ operator >>(
   BigInteger^ bi1,
   int shiftVal
)

Parameters

bi1
shiftVal

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Subtraction Operator
See Also
[image]
Internal Namespace > BigInteger Class : Subtraction Operator

bi1
bi2
Subtracts one BigInteger from another.

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator -(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Subtraction(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator -(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Unary Negation Operator
See Also
[image]
Internal Namespace > BigInteger Class : Unary Negation Operator

bi1
Implements a 2's compliment (negative).

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal bi1 As BigInteger _
) As BigInteger
C#
public BigInteger operator -(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_UnaryNegation(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator -(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
CommonRegexes Class
See Also Members
[image]
Internal Namespace : CommonRegexes Class

Declares static versions of some common regular expressions.

Syntax

Visual Basic (Declaration)
Private NotInheritable Class CommonRegexes
Visual Basic (Usage) Copy Code
Dim instance As CommonRegexes
C#
private sealed class CommonRegexes
Managed Extensions for C++
private __gc __sealed class CommonRegexes
C++/CLI
private ref class CommonRegexes sealed

Inheritance Hierarchy

System.Object
Internal.CommonRegexes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Members
Internal Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
CommonRegexes Class Members
See Also Fields
[image]
Internal Namespace : CommonRegexes Class

The following tables list the members exposed by CommonRegexes.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DomainName | Pattern for matching against any valid domain name.
static (Shared in Visual Basic) | Email | Pattern for matching against any valid email address.
static (Shared in Visual Basic) | FileName | Pattern for matching a Windows file path.
static (Shared in Visual Basic) | FilePath | Pattern for matching a Windows file path.
static (Shared in Visual Basic) | FullyQualifiedUrl | Pattern for matching against any valid URL.
static (Shared in Visual Basic) | FullyQualifiedUrlFolder | Pattern for matching a fully qualified URL that has no file name.
static (Shared in Visual Basic) | IpAddress | Pattern for matching against any valid IP address.
static (Shared in Visual Basic) | Url | Pattern for matching against any valid URL.
static (Shared in Visual Basic) | UrlFolder | Pattern for matching against any valid URL that has no file name.
static (Shared in Visual Basic) | UsEin | Pattern for a US employer identification number.
static (Shared in Visual Basic) | UsPhone | Pattern for a US 10-digit phone number.
static (Shared in Visual Basic) | UsSsn | Pattern for a US social security number.
static (Shared in Visual Basic) | UsSsnOrEin | Pattern for a US social security number or an employer identification number.
static (Shared in Visual Basic) | UsZip | Pattern for a US 5-digit zip code with an optional 4 digit exchange.
static (Shared in Visual Basic) | UsZip5 | Pattern for a US 5-digit zip code.
static (Shared in Visual Basic) | UsZip5Plus4 | Pattern for a US 5-digit zip code plus 4 digit exchange.
Top

See Also

Reference

CommonRegexes Class
Internal Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.Windows Send comments on this topic.
CommonRegexes Class Fields
See Also
[image]
Internal Namespace : CommonRegexes Class

For a list of all members of this type, see CommonRegexes members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DomainName | Pattern for matching against any valid domain name.
static (Shared in Visual Basic) | Email | Pattern for matching against any valid email address.
static (Shared in Visual Basic) | FileName | Pattern for matching a Windows file path.
static (Shared in Visual Basic) | FilePath | Pattern for matching a Windows file path.
static (Shared in Visual Basic) | FullyQualifiedUrl | Pattern for matching against any valid URL.
static (Shared in Visual Basic) | FullyQualifiedUrlFolder | Pattern for matching a fully qualified URL that has no file name.
static (Shared in Visual Basic) | IpAddress | Pattern for matching against any valid IP address.
static (Shared in Visual Basic) | Url | Pattern for matching against any valid URL.
static (Shared in Visual Basic) | UrlFolder | Pattern for matching against any valid URL that has no file name.
static (Shared in Visual Basic) | UsEin | Pattern for a US employer identification number.
static (Shared in Visual Basic) | UsPhone | Pattern for a US 10-digit phone number.
static (Shared in Visual Basic) | UsSsn | Pattern for a US social security number.
static (Shared in Visual Basic) | UsSsnOrEin | Pattern for a US social security number or an employer identification number.
static (Shared in Visual Basic) | UsZip | Pattern for a US 5-digit zip code with an optional 4 digit exchange.
static (Shared in Visual Basic) | UsZip5 | Pattern for a US 5-digit zip code.
static (Shared in Visual Basic) | UsZip5Plus4 | Pattern for a US 5-digit zip code plus 4 digit exchange.
Top

See Also

Reference

CommonRegexes Class
Internal Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
DomainName Field
See Also
[image]
Internal Namespace > CommonRegexes Class : DomainName Field

Pattern for matching against any valid domain name.

Syntax

Visual Basic (Declaration)
Public Shared DomainName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.DomainName

CommonRegexes.DomainName = value
C#
public static string DomainName
Managed Extensions for C++
public: static string* DomainName
C++/CLI
public:
static String^ DomainName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Email Field
See Also
[image]
Internal Namespace > CommonRegexes Class : Email Field

Pattern for matching against any valid email address.

Syntax

Visual Basic (Declaration)
Public Shared Email As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.Email

CommonRegexes.Email = value
C#
public static string Email
Managed Extensions for C++
public: static string* Email
C++/CLI
public:
static String^ Email

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
FileName Field
See Also
[image]
Internal Namespace > CommonRegexes Class : FileName Field

Pattern for matching a Windows file path.

Syntax

Visual Basic (Declaration)
Public Shared FileName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.FileName

CommonRegexes.FileName = value
C#
public static string FileName
Managed Extensions for C++
public: static string* FileName
C++/CLI
public:
static String^ FileName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
FilePath Field
See Also
[image]
Internal Namespace > CommonRegexes Class : FilePath Field

Pattern for matching a Windows file path.

Syntax

Visual Basic (Declaration)
Public Shared FilePath As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.FilePath

CommonRegexes.FilePath = value
C#
public static string FilePath
Managed Extensions for C++
public: static string* FilePath
C++/CLI
public:
static String^ FilePath

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
FullyQualifiedUrl Field
See Also
[image]
Internal Namespace > CommonRegexes Class : FullyQualifiedUrl Field

Pattern for matching against any valid URL.

Syntax

Visual Basic (Declaration)
Public Shared FullyQualifiedUrl As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.FullyQualifiedUrl

CommonRegexes.FullyQualifiedUrl = value
C#
public static string FullyQualifiedUrl
Managed Extensions for C++
public: static string* FullyQualifiedUrl
C++/CLI
public:
static String^ FullyQualifiedUrl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
FullyQualifiedUrlFolder Field
See Also
[image]
Internal Namespace > CommonRegexes Class : FullyQualifiedUrlFolder Field

Pattern for matching a fully qualified URL that has no file name.

Syntax

Visual Basic (Declaration)
Public Shared FullyQualifiedUrlFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.FullyQualifiedUrlFolder

CommonRegexes.FullyQualifiedUrlFolder = value
C#
public static string FullyQualifiedUrlFolder
Managed Extensions for C++
public: static string* FullyQualifiedUrlFolder
C++/CLI
public:
static String^ FullyQualifiedUrlFolder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IpAddress Field
See Also
[image]
Internal Namespace > CommonRegexes Class : IpAddress Field

Pattern for matching against any valid IP address.

Syntax

Visual Basic (Declaration)
Public Shared IpAddress As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.IpAddress

CommonRegexes.IpAddress = value
C#
public static string IpAddress
Managed Extensions for C++
public: static string* IpAddress
C++/CLI
public:
static String^ IpAddress

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Url Field
See Also
[image]
Internal Namespace > CommonRegexes Class : Url Field

Pattern for matching against any valid URL.

Syntax

Visual Basic (Declaration)
Public Shared Url As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.Url

CommonRegexes.Url = value
C#
public static string Url
Managed Extensions for C++
public: static string* Url
C++/CLI
public:
static String^ Url

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
UrlFolder Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UrlFolder Field

Pattern for matching against any valid URL that has no file name.

Syntax

Visual Basic (Declaration)
Public Shared UrlFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UrlFolder

CommonRegexes.UrlFolder = value
C#
public static string UrlFolder
Managed Extensions for C++
public: static string* UrlFolder
C++/CLI
public:
static String^ UrlFolder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
UsEin Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsEin Field

Pattern for a US employer identification number.

Syntax

Visual Basic (Declaration)
Public Shared UsEin As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsEin

CommonRegexes.UsEin = value
C#
public static string UsEin
Managed Extensions for C++
public: static string* UsEin
C++/CLI
public:
static String^ UsEin

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
UsPhone Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsPhone Field

Pattern for a US 10-digit phone number.

Syntax

Visual Basic (Declaration)
Public Shared UsPhone As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsPhone

CommonRegexes.UsPhone = value
C#
public static string UsPhone
Managed Extensions for C++
public: static string* UsPhone
C++/CLI
public:
static String^ UsPhone

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
UsSsn Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsSsn Field

Pattern for a US social security number.

Syntax

Visual Basic (Declaration)
Public Shared UsSsn As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsSsn

CommonRegexes.UsSsn = value
C#
public static string UsSsn
Managed Extensions for C++
public: static string* UsSsn
C++/CLI
public:
static String^ UsSsn

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
UsSsnOrEin Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsSsnOrEin Field

Pattern for a US social security number or an employer identification number.

Syntax

Visual Basic (Declaration)
Public Shared UsSsnOrEin As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsSsnOrEin

CommonRegexes.UsSsnOrEin = value
C#
public static string UsSsnOrEin
Managed Extensions for C++
public: static string* UsSsnOrEin
C++/CLI
public:
static String^ UsSsnOrEin

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
UsZip Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsZip Field

Pattern for a US 5-digit zip code with an optional 4 digit exchange.

Syntax

Visual Basic (Declaration)
Public Shared UsZip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsZip

CommonRegexes.UsZip = value
C#
public static string UsZip
Managed Extensions for C++
public: static string* UsZip
C++/CLI
public:
static String^ UsZip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
UsZip5 Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsZip5 Field

Pattern for a US 5-digit zip code.

Syntax

Visual Basic (Declaration)
Public Shared UsZip5 As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsZip5

CommonRegexes.UsZip5 = value
C#
public static string UsZip5
Managed Extensions for C++
public: static string* UsZip5
C++/CLI
public:
static String^ UsZip5

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
UsZip5Plus4 Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsZip5Plus4 Field

Pattern for a US 5-digit zip code plus 4 digit exchange.

Syntax

Visual Basic (Declaration)
Public Shared UsZip5Plus4 As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsZip5Plus4

CommonRegexes.UsZip5Plus4 = value
C#
public static string UsZip5Plus4
Managed Extensions for C++
public: static string* UsZip5Plus4
C++/CLI
public:
static String^ UsZip5Plus4

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%ItemTitle%%

Barcode4NET.Windows Send comments on this topic.
O2S.Barcode4NET.Licensing Namespace (Barcode4NET.Windows)
See Also Inheritance Hierarchy

Classes

Class | Description
LicenseValidator | Defines a validator for license serial numbers.

See Also

Reference

Barcode4NET.Windows Assembly


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LicenseValidator Class
See Also Members
[image]
O2S.Barcode4NET.Licensing Namespace : LicenseValidator Class

Defines a validator for license serial numbers.

Syntax

Visual Basic (Declaration)
Private Class LicenseValidator
Visual Basic (Usage) Copy Code
Dim instance As LicenseValidator
C#
private class LicenseValidator
Managed Extensions for C++
private __gc class LicenseValidator
C++/CLI
private ref class LicenseValidator

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Licensing.LicenseValidator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValidator Members
O2S.Barcode4NET.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
LicenseValidator Class Members
See Also Methods
[image]
O2S.Barcode4NET.Licensing Namespace : LicenseValidator Class

The following tables list the members exposed by LicenseValidator.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetSerialNumber | Reads the serial number from the registry to give a default value to SerialNumber property.
static (Shared in Visual Basic) | ValidateSerialNumber | Validates a serial number based on a license file and a public key.
Top

See Also

Reference

LicenseValidator Class
O2S.Barcode4NET.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
LicenseValidator Class Methods
See Also
[image]
O2S.Barcode4NET.Licensing Namespace : LicenseValidator Class

For a list of all members of this type, see LicenseValidator members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetSerialNumber | Reads the serial number from the registry to give a default value to SerialNumber property.
static (Shared in Visual Basic) | ValidateSerialNumber | Validates a serial number based on a license file and a public key.
Top

See Also

Reference

LicenseValidator Class
O2S.Barcode4NET.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetSerialNumber Method
See Also
[image]
O2S.Barcode4NET.Licensing Namespace > LicenseValidator Class : GetSerialNumber Method

edition
The edition to lookup the serial number for.
version
Version to lookup the serial number for.
Reads the serial number from the registry to give a default value to SerialNumber property.

Syntax

Visual Basic (Declaration)
Public Shared Function GetSerialNumber( _
   ByVal edition As String, _
   ByVal version As String _
) As String
Visual Basic (Usage) Copy Code
Dim edition As String
Dim version As String
Dim value As String

value = LicenseValidator.GetSerialNumber(edition, version)
C#
public static string GetSerialNumber(
   string edition,
   string version
)
Managed Extensions for C++
public: static string* GetSerialNumber(
   string* edition,
   string* version
)
C++/CLI
public:
static String^ GetSerialNumber(
   String^ edition,
   String^ version
)

Parameters

edition
The edition to lookup the serial number for.
version
Version to lookup the serial number for.

Return Value

Serial number if exists, empty string otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValidator Class
LicenseValidator Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ValidateSerialNumber Method
See Also
[image]
O2S.Barcode4NET.Licensing Namespace > LicenseValidator Class : ValidateSerialNumber Method

serialNumber
Serial number to validate.
licenseResourceName
License file the serial number is validated against.
publicKeyResourceName
The public key for validating the serial number.
Validates a serial number based on a license file and a public key.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateSerialNumber( _
   ByVal serialNumber As String, _
   ByVal licenseResourceName As String, _
   ByVal publicKeyResourceName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim serialNumber As String
Dim licenseResourceName As String
Dim publicKeyResourceName As String
Dim value As Boolean

value = LicenseValidator.ValidateSerialNumber(serialNumber, licenseResourceName, publicKeyResourceName)
C#
public static bool ValidateSerialNumber(
   string serialNumber,
   string licenseResourceName,
   string publicKeyResourceName
)
Managed Extensions for C++
public: static bool ValidateSerialNumber(
   string* serialNumber,
   string* licenseResourceName,
   string* publicKeyResourceName
)
C++/CLI
public:
static bool ValidateSerialNumber(
   String^ serialNumber,
   String^ licenseResourceName,
   String^ publicKeyResourceName
)

Parameters

serialNumber
Serial number to validate.
licenseResourceName
License file the serial number is validated against.
publicKeyResourceName
The public key for validating the serial number.

Return Value

True if the serial number is valid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValidator Class
LicenseValidator Members


%%ItemTitle%%

Barcode4NET.Windows Send comments on this topic.
O2S.Barcode4NET.WinControls Namespace (Barcode4NET.Windows)
See Also Inheritance Hierarchy
Root namespace for Windows Forms barcode controls included in Barcode4NET toolkit.

Classes

Class | Description
BarcodeTextBox | Represents a barcode control that can be edited.
BarcodeView | Represents a barcode control displayed on a form.

See Also

Reference

Barcode4NET.Windows Assembly


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BarcodeTextBox Class
See Also Members
[image]
O2S.Barcode4NET.WinControls Namespace : BarcodeTextBox Class

Represents a barcode control that can be edited.

Object Model

Syntax

Visual Basic (Declaration)
Public Class BarcodeTextBox
   Inherits TextBox
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
C#
public class BarcodeTextBox : TextBox
Managed Extensions for C++
public __gc class BarcodeTextBox : public TextBox
C++/CLI
public ref class BarcodeTextBox : public TextBox

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.TextBoxBase
System.Windows.Forms.TextBox
O2S.Barcode4NET.WinControls.BarcodeTextBox

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Members
O2S.Barcode4NET.WinControls Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
BarcodeTextBox Class Members
See Also Properties Methods Events
[image]
O2S.Barcode4NET.WinControls Namespace : BarcodeTextBox Class

The following tables list the members exposed by BarcodeTextBox.

Public Constructors

 | Name | Description
Public Constructor | BarcodeTextBox Constructor | Initializes a new BarcodeTextBox object.
Top

Public Properties

 | Name | Description
Public Property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from System.Windows.Forms.TextBox)
Public Property | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoCompleteCustomSource | Gets or sets a custom StringCollection to use when the AutoCompleteSource property is set to CustomSource. (Inherited from System.Windows.Forms.TextBox)
Public Property | AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the TextBox. (Inherited from System.Windows.Forms.TextBox)
Public Property | AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from System.Windows.Forms.TextBox)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView. (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | Overridden. Gets or sets the background color for the barcode.
Public Property | BackgroundImage | Overridden. Gets or sets the background image of the control.
Public Property | Barcode | Gets the Barcode object behind the control.
Public Property | BarcodeFont | Gets or sets the font of the barcode text displayed in the control.
Public Property | BarcodeTextColor | Gets or sets the text color for the barcode.
Public Property | BarColor | Gets or sets the bars color for the barcode.
Public Property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BorderColor | Gets or sets the border color for the barcode.
Public Property | BorderStyle | Gets or sets the border type of the text box control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode.
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | CharacterCasing | Gets or sets whether the TextBox control modifies the case of characters as they are typed. (Inherited from System.Windows.Forms.TextBox)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CodablockFColumns | Gets or sets the number of columns in this CODABLOCK F barcode.
Public Property | CodablockFRows | Gets or sets the number of rows in this CODABLOCK F barcode.
Public Property | Code16KRows | Gets or sets the number of rows in this Code 16K barcode.
Public Property | Code39WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | Gets the IContainer that contains the Component. (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DataMatrixEncoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | DataMatrixSymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties.
Public Property | DisplayCheckSum | Gets or sets a value indicating whether the check characters should be displayed in barcode text.
Public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | EANSupplement | Gets or sets the supplement for barcode data.
Public Property | EANSupplementDisplayLocation | Gets or sets the location of the EAN supplement text.
Public Property | EANSupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum character should be appended automatically to the barcode.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode.
Public Property | Lines | Gets or sets the lines of text in a text box control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the text box control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | MicroPDF417SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | Multiline | Gets or sets a value indicating whether this is a multiline TextBox control. (Inherited from System.Windows.Forms.TextBox)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | PasswordChar | Gets or sets the character used to mask characters of a password in a single-line TextBox control. (Inherited from System.Windows.Forms.TextBox)
Public Property | Pdf417Columns | Gets or sets the number of columns in this PDF417 barcode.
Public Property | Pdf417DataCompactionMode | Gets or sets the data compaction mode for this PDF417 barcode.
Public Property | Pdf417ErrorCorrectionLevel | Gets or sets the level of error correction used by this PDF417 barcode.
Public Property | Pdf417Rows | Gets or sets the number of rows in this PDF417 barcode.
Public Property | PreferredHeight | Gets the preferred height for a text box. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode.
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | Rotation | Gets or sets the rotation angle of the barcode.
Public Property | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from System.Windows.Forms.TextBox)
Public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | SerialNumber | Gets or sets the serial number.
Public Property | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Symbology | Gets or sets the type of the barcode displayed in the control.
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Text | Overridden. Gets or sets the current text in the text box.
Public Property | TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from System.Windows.Forms.TextBox)
Public Property | TextLength | Gets the length of text in the control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode.
Public Property | UseSystemPasswordChar | Gets or sets a value indicating whether the text in the TextBox control should appear as the default password character. (Inherited from System.Windows.Forms.TextBox)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | XDimension | Gets or sets the width of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

Public Methods

 | Name | Description
Public Method | AppendText | Appends text to the current text of a text box. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Clear | Clears all text from the text box control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | DeselectAll | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | Dispose | Clean up any resources being used. Releases all resources used by the Component. (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | Paste | Overloaded. Replaces the specified selection in the TextBox with the contents of the Clipboard. (Inherited from System.Windows.Forms.TextBox)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | Select | Overloaded. Selects a range of text in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | SelectAll | Selects all text in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | Returns a string that represents the TextBoxBase control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | Undo | Undoes the last edit operation in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

Public Events

 | Name | Description
Public Event | AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BorderStyleChanged | Occurs when the value of the BorderStyle property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
Public Event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the text box is clicked. (Inherited from System.Windows.Forms.TextBoxBase)
Public Event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | HideSelectionChanged | Occurs when the value of the HideSelection property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
Public Event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | ModifiedChanged | Occurs when the value of the Modified property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.TextBoxBase)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | MultilineChanged | Occurs when the value of the Multiline property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | ReadOnlyChanged | Occurs when the value of the ReadOnly property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
Public Event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | SizeChanged | Occurs when the Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TextAlignChanged | Occurs when the value of the TextAlign property has changed. (Inherited from System.Windows.Forms.TextBox)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

BarcodeTextBox Class
O2S.Barcode4NET.WinControls Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BarcodeTextBox Constructor
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : BarcodeTextBox Constructor

Initializes a new BarcodeTextBox object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox()
C#
public BarcodeTextBox()
Managed Extensions for C++
public: BarcodeTextBox();
C++/CLI
public:
BarcodeTextBox();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Windows Send comments on this topic.
BarcodeTextBox Class Properties
See Also
[image]
O2S.Barcode4NET.WinControls Namespace : BarcodeTextBox Class

For a list of all members of this type, see BarcodeTextBox members.

Public Properties

 | Name | Description
Public Property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from System.Windows.Forms.TextBox)
Public Property | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoCompleteCustomSource | Gets or sets a custom StringCollection to use when the AutoCompleteSource property is set to CustomSource. (Inherited from System.Windows.Forms.TextBox)
Public Property | AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the TextBox. (Inherited from System.Windows.Forms.TextBox)
Public Property | AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from System.Windows.Forms.TextBox)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView. (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | Overridden. Gets or sets the background color for the barcode.
Public Property | BackgroundImage | Overridden. Gets or sets the background image of the control.
Public Property | Barcode | Gets the Barcode object behind the control.
Public Property | BarcodeFont | Gets or sets the font of the barcode text displayed in the control.
Public Property | BarcodeTextColor | Gets or sets the text color for the barcode.
Public Property | BarColor | Gets or sets the bars color for the barcode.
Public Property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BorderColor | Gets or sets the border color for the barcode.
Public Property | BorderStyle | Gets or sets the border type of the text box control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode.
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | CharacterCasing | Gets or sets whether the TextBox control modifies the case of characters as they are typed. (Inherited from System.Windows.Forms.TextBox)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CodablockFColumns | Gets or sets the number of columns in this CODABLOCK F barcode.
Public Property | CodablockFRows | Gets or sets the number of rows in this CODABLOCK F barcode.
Public Property | Code16KRows | Gets or sets the number of rows in this Code 16K barcode.
Public Property | Code39WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | Gets the IContainer that contains the Component. (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DataMatrixEncoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | DataMatrixSymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties.
Public Property | DisplayCheckSum | Gets or sets a value indicating whether the check characters should be displayed in barcode text.
Public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | EANSupplement | Gets or sets the supplement for barcode data.
Public Property | EANSupplementDisplayLocation | Gets or sets the location of the EAN supplement text.
Public Property | EANSupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum character should be appended automatically to the barcode.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode.
Public Property | Lines | Gets or sets the lines of text in a text box control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the text box control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | MicroPDF417SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | Multiline | Gets or sets a value indicating whether this is a multiline TextBox control. (Inherited from System.Windows.Forms.TextBox)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | PasswordChar | Gets or sets the character used to mask characters of a password in a single-line TextBox control. (Inherited from System.Windows.Forms.TextBox)
Public Property | Pdf417Columns | Gets or sets the number of columns in this PDF417 barcode.
Public Property | Pdf417DataCompactionMode | Gets or sets the data compaction mode for this PDF417 barcode.
Public Property | Pdf417ErrorCorrectionLevel | Gets or sets the level of error correction used by this PDF417 barcode.
Public Property | Pdf417Rows | Gets or sets the number of rows in this PDF417 barcode.
Public Property | PreferredHeight | Gets the preferred height for a text box. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode.
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | Rotation | Gets or sets the rotation angle of the barcode.
Public Property | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from System.Windows.Forms.TextBox)
Public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | SerialNumber | Gets or sets the serial number.
Public Property | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Symbology | Gets or sets the type of the barcode displayed in the control.
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Text | Overridden. Gets or sets the current text in the text box.
Public Property | TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from System.Windows.Forms.TextBox)
Public Property | TextLength | Gets the length of text in the control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode.
Public Property | UseSystemPasswordChar | Gets or sets a value indicating whether the text in the TextBox control should appear as the default password character. (Inherited from System.Windows.Forms.TextBox)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from System.Windows.Forms.TextBoxBase)
Public Property | XDimension | Gets or sets the width of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

See Also

Reference

BarcodeTextBox Class
O2S.Barcode4NET.WinControls Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BackColor Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : BackColor Property

Gets or sets the background color for the barcode.

Syntax

Visual Basic (Declaration)
Overrides Public Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
public override Color BackColor {get; set;}
Managed Extensions for C++
public: __property Color get_BackColor()override ;
public: __property void set_BackColor(
   Color value
)override ;
C++/CLI
public:
property Color BackColor override {
   Color get();
   void set (Color value);
}

Return Value

A Color that represents the background color of the barcode. The default value is White.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BackgroundImage Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : BackgroundImage Property

Gets or sets the background image of the control.

Syntax

Visual Basic (Declaration)
Overrides Public Property BackgroundImage As Image
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Image

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
public override Image BackgroundImage {get; set;}
Managed Extensions for C++
public: __property Image get_BackgroundImage()override ;
public: __property void set_BackgroundImage(
   Image value
)override ;
C++/CLI
public:
property Image BackgroundImage override {
   Image get();
   void set (Image value);
}

Remarks

This property is not used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Barcode Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : Barcode Property

Gets the Barcode object behind the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Barcode As Barcode
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Barcode

value = instance.Barcode
C#
public Barcode Barcode {get;}
Managed Extensions for C++
public: __property Barcode* get_Barcode();
C++/CLI
public:
property Barcode^ Barcode {
   Barcode^ get();
}

Return Value

A Barcode object that represents the barcode displayed in the control.

Remarks

If this Barcode object is modified directly, call control's Update method to reflect the changes in the displayed barcode image.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BarcodeFont Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : BarcodeFont Property

Gets or sets the font of the barcode text displayed in the control.

Syntax

Visual Basic (Declaration)
Public Property BarcodeFont As Font
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Font

instance.BarcodeFont = value

value = instance.BarcodeFont
C#
public Font BarcodeFont {get; set;}
Managed Extensions for C++
public: __property Font get_BarcodeFont();
public: __property void set_BarcodeFont(
   Font value
);
C++/CLI
public:
property Font BarcodeFont {
   Font get();
   void set (Font value);
}

Return Value

The Font object to apply to the barcode text displayed in the control.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BarcodeTextColor Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : BarcodeTextColor Property

Gets or sets the text color for the barcode.

Syntax

Visual Basic (Declaration)
Public Property BarcodeTextColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Color

instance.BarcodeTextColor = value

value = instance.BarcodeTextColor
C#
public Color BarcodeTextColor {get; set;}
Managed Extensions for C++
public: __property Color get_BarcodeTextColor();
public: __property void set_BarcodeTextColor(
   Color value
);
C++/CLI
public:
property Color BarcodeTextColor {
   Color get();
   void set (Color value);
}

Return Value

A Color that represents the color used to display the barcode data. The default value is Black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BarColor Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : BarColor Property

Gets or sets the bars color for the barcode.

Syntax

Visual Basic (Declaration)
Public Property BarColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Color

instance.BarColor = value

value = instance.BarColor
C#
public Color BarColor {get; set;}
Managed Extensions for C++
public: __property Color get_BarColor();
public: __property void set_BarColor(
   Color value
);
C++/CLI
public:
property Color BarColor {
   Color get();
   void set (Color value);
}

Return Value

A Color that represents the bars color of the barcode. The default value is Black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BorderColor Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : BorderColor Property

Gets or sets the border color for the barcode.

Syntax

Visual Basic (Declaration)
Public Property BorderColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Color

instance.BorderColor = value

value = instance.BorderColor
C#
public Color BorderColor {get; set;}
Managed Extensions for C++
public: __property Color get_BorderColor();
public: __property void set_BorderColor(
   Color value
);
C++/CLI
public:
property Color BorderColor {
   Color get();
   void set (Color value);
}

Return Value

A Color object specifying the color of the control border.

Remarks

This border is drawn only if the border width is greater than 0 and BorderStyle property is FixedSingle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BorderWidth Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : BorderWidth Property

Gets or sets the border width.

Syntax

Visual Basic (Declaration)
Public Property BorderWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Integer

instance.BorderWidth = value

value = instance.BorderWidth
C#
public int BorderWidth {get; set;}
Managed Extensions for C++
public: __property int get_BorderWidth();
public: __property void set_BorderWidth(
   int value
);
C++/CLI
public:
property int BorderWidth {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the border width.

Remarks

This border is drawn only if the width is greater than 0 and BorderStyle property is FixedSingle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BottomQuietZone Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : BottomQuietZone Property

Gets or sets the bottom quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property BottomQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Single

instance.BottomQuietZone = value

value = instance.BottomQuietZone
C#
public float BottomQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_BottomQuietZone();
public: __property void set_BottomQuietZone(
   float value
);
C++/CLI
public:
property float BottomQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of bottom quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the bottom quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
CodablockFColumns Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : CodablockFColumns Property

Gets or sets the number of columns in this CODABLOCK F barcode.

Syntax

Visual Basic (Declaration)
Public Property CodablockFColumns As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Integer

instance.CodablockFColumns = value

value = instance.CodablockFColumns
C#
public int CodablockFColumns {get; set;}
Managed Extensions for C++
public: __property int get_CodablockFColumns();
public: __property void set_CodablockFColumns(
   int value
);
C++/CLI
public:
property int CodablockFColumns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this CODABLOCK F barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 7 or greater than 65.

Remarks

The minimum number of columns in a CODABLOCK F barcode is 7 and the maximum number of columns is 65. This property includes the character subset selector, row indicator and row check columns.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
CodablockFRows Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : CodablockFRows Property

Gets or sets the number of rows in this CODABLOCK F barcode.

Syntax

Visual Basic (Declaration)
Public Property CodablockFRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Integer

instance.CodablockFRows = value

value = instance.CodablockFRows
C#
public int CodablockFRows {get; set;}
Managed Extensions for C++
public: __property int get_CodablockFRows();
public: __property void set_CodablockFRows(
   int value
);
C++/CLI
public:
property int CodablockFRows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows in this CODABLOCK F barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2 or greater than 44.

Remarks

The minimum number of rows in a CODABLOCK F barcode is 2 and the maximum number of rows is 44.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Code16KRows Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : Code16KRows Property

Gets or sets the number of rows in this Code 16K barcode.

Syntax

Visual Basic (Declaration)
Public Property Code16KRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Integer

instance.Code16KRows = value

value = instance.Code16KRows
C#
public int Code16KRows {get; set;}
Managed Extensions for C++
public: __property int get_Code16KRows();
public: __property void set_Code16KRows(
   int value
);
C++/CLI
public:
property int Code16KRows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows in this Code 16K barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2 but not 0, or greater than 16.

Remarks

The minimum number of rows in a Code 16K barcode is 2 and the maximum number of rows is 16. If this property is 0, the number of rows is calculated automatically to accomodate the barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Code39WideToNarrowRatio Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : Code39WideToNarrowRatio Property

Gets or sets the ratio between wide bars and narrow bars.

Syntax

Visual Basic (Declaration)
Public Property Code39WideToNarrowRatio As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Single

instance.Code39WideToNarrowRatio = value

value = instance.Code39WideToNarrowRatio
C#
public float Code39WideToNarrowRatio {get; set;}
Managed Extensions for C++
public: __property float get_Code39WideToNarrowRatio();
public: __property void set_Code39WideToNarrowRatio(
   float value
);
C++/CLI
public:
property float Code39WideToNarrowRatio {
   float get();
   void set (float value);
}

Return Value

A float value specifying the ratio between wide bars and narrow bars.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.
This property applies to Code39 barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
DataDisplayLocation Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : DataDisplayLocation Property

Gets or sets the location of the barcode data.

Syntax

Visual Basic (Declaration)
Public Property DataDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As BarcodeTextLocation

instance.DataDisplayLocation = value

value = instance.DataDisplayLocation
C#
public BarcodeTextLocation DataDisplayLocation {get; set;}
Managed Extensions for C++
public: __property BarcodeTextLocation get_DataDisplayLocation();
public: __property void set_DataDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation DataDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location of the barcode data when it is displayed on the barcode.

Remarks

This property applies to 1D barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
DataMatrixEncoding Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : DataMatrixEncoding Property

Gets or sets the encoding of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property DataMatrixEncoding As DataMatrixEncoding
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As DataMatrixEncoding

instance.DataMatrixEncoding = value

value = instance.DataMatrixEncoding
C#
public DataMatrixEncoding DataMatrixEncoding {get; set;}
Managed Extensions for C++
public: __property DataMatrixEncoding get_DataMatrixEncoding();
public: __property void set_DataMatrixEncoding(
   DataMatrixEncoding value
);
C++/CLI
public:
property DataMatrixEncoding DataMatrixEncoding {
   DataMatrixEncoding get();
   void set (DataMatrixEncoding value);
}

Return Value

A DataMatrixEncoding enumeration member specifying the data encoding for this DataMatrix barcode.

Remarks

If the data to encode contains only numbers (ASCII characters from 0x30 to 0x39), then Numeric provides the best encoding. If the data to encode contains only base ASCII characters (0x00 to 0x7F), then both ASCII and Base256 encoding provide the same performance, but if the data to encode contains more than 3 extended ASCII characters (0x80 to 0xFF) then the Base256 encoding is the best option.
If the selected encoding is Auto, then the library will select the encoding that will generate the smallest encoded data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
DataMatrixSymbolSize Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : DataMatrixSymbolSize Property

Gets or sets the symbol size of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property DataMatrixSymbolSize As DataMatrixSymbolSize
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As DataMatrixSymbolSize

instance.DataMatrixSymbolSize = value

value = instance.DataMatrixSymbolSize
C#
public DataMatrixSymbolSize DataMatrixSymbolSize {get; set;}
Managed Extensions for C++
public: __property DataMatrixSymbolSize get_DataMatrixSymbolSize();
public: __property void set_DataMatrixSymbolSize(
   DataMatrixSymbolSize value
);
C++/CLI
public:
property DataMatrixSymbolSize DataMatrixSymbolSize {
   DataMatrixSymbolSize get();
   void set (DataMatrixSymbolSize value);
}

Return Value

A DataMatrixSymbolSize enumeration member specifying the size of symbol used to represent this DataMatrix barcode.

Remarks

If the SymbolSize is Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
DimensionUnit Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : DimensionUnit Property

Gets or sets the measure unit for the XDimension and YDimension properties.

Syntax

Visual Basic (Declaration)
Public Property DimensionUnit As XYDimensionUnit
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As XYDimensionUnit

instance.DimensionUnit = value

value = instance.DimensionUnit
C#
public XYDimensionUnit DimensionUnit {get; set;}
Managed Extensions for C++
public: __property XYDimensionUnit get_DimensionUnit();
public: __property void set_DimensionUnit(
   XYDimensionUnit value
);
C++/CLI
public:
property XYDimensionUnit DimensionUnit {
   XYDimensionUnit get();
   void set (XYDimensionUnit value);
}

Return Value

A XYDimensionUnit enumeration member specifying the measure unit for the XDimension and YDimension properties.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
DisplayCheckSum Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : DisplayCheckSum Property

Gets or sets a value indicating whether the check characters should be displayed in barcode text.

Syntax

Visual Basic (Declaration)
Public Property DisplayCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Boolean

instance.DisplayCheckSum = value

value = instance.DisplayCheckSum
C#
public bool DisplayCheckSum {get; set;}
Managed Extensions for C++
public: __property bool get_DisplayCheckSum();
public: __property void set_DisplayCheckSum(
   bool value
);
C++/CLI
public:
property bool DisplayCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if the check characters should be displayed. Default is false.

Remarks

This property applies to 1D barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
EANSupplement Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : EANSupplement Property

Gets or sets the supplement for barcode data.

Syntax

Visual Basic (Declaration)
Public Property EANSupplement As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As String

instance.EANSupplement = value

value = instance.EANSupplement
C#
public string EANSupplement {get; set;}
Managed Extensions for C++
public: __property string* get_EANSupplement();
public: __property void set_EANSupplement(
   string* value
);
C++/CLI
public:
property String^ EANSupplement {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying a 2 or 5 digit supplemental barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in supplement data or the supplement does not have the required length (2 or 5 digits).

Remarks

This supplement is optional. If it exists, it can be only 2 or 5 digits.
This property applies to EAN13, EAN8, ISBN, ISMN, ISSN, JAN13, UPC-A and UPC-E barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
EANSupplementDisplayLocation Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : EANSupplementDisplayLocation Property

Gets or sets the location of the EAN supplement text.

Syntax

Visual Basic (Declaration)
Public Property EANSupplementDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As BarcodeTextLocation

instance.EANSupplementDisplayLocation = value

value = instance.EANSupplementDisplayLocation
C#
public BarcodeTextLocation EANSupplementDisplayLocation {get; set;}
Managed Extensions for C++
public: __property BarcodeTextLocation get_EANSupplementDisplayLocation();
public: __property void set_EANSupplementDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation EANSupplementDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location where the supplement text is displayed.

Remarks

The embedding options are ignored for supplement text. AboveEmbedded has the same effect like Above, and BelowEmbedded has the same effect like Below.
This property applies to EAN13, EAN8, ISBN, ISMN, ISSN, JAN13, UPC-A and UPC-E barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
EANSupplementYDimension Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : EANSupplementYDimension Property

Gets or sets the height of a bar in the supplement barcode.

Syntax

Visual Basic (Declaration)
Public Property EANSupplementYDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Single

instance.EANSupplementYDimension = value

value = instance.EANSupplementYDimension
C#
public float EANSupplementYDimension {get; set;}
Managed Extensions for C++
public: __property float get_EANSupplementYDimension();
public: __property void set_EANSupplementYDimension(
   float value
);
C++/CLI
public:
property float EANSupplementYDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a bar in the supplement barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
EnableCheckSum Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : EnableCheckSum Property

Gets or sets a value indicating whether a checksum character should be appended automatically to the barcode.

Syntax

Visual Basic (Declaration)
Public Property EnableCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Boolean

instance.EnableCheckSum = value

value = instance.EnableCheckSum
C#
public bool EnableCheckSum {get; set;}
Managed Extensions for C++
public: __property bool get_EnableCheckSum();
public: __property void set_EnableCheckSum(
   bool value
);
C++/CLI
public:
property bool EnableCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if a checksum character should be appended automatically to the barcode, false otherwise.

Remarks

This property applies to 1D barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LeftQuietZone Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : LeftQuietZone Property

Gets or sets the left quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property LeftQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Single

instance.LeftQuietZone = value

value = instance.LeftQuietZone
C#
public float LeftQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_LeftQuietZone();
public: __property void set_LeftQuietZone(
   float value
);
C++/CLI
public:
property float LeftQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of left quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the left quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MicroPDF417SymbolSize Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : MicroPDF417SymbolSize Property

Gets or sets the symbol size of this Micro PDF 417 barcode.

Syntax

Visual Basic (Declaration)
Public Property MicroPDF417SymbolSize As MicroPDF417SymbolSize
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As MicroPDF417SymbolSize

instance.MicroPDF417SymbolSize = value

value = instance.MicroPDF417SymbolSize
C#
public MicroPDF417SymbolSize MicroPDF417SymbolSize {get; set;}
Managed Extensions for C++
public: __property MicroPDF417SymbolSize get_MicroPDF417SymbolSize();
public: __property void set_MicroPDF417SymbolSize(
   MicroPDF417SymbolSize value
);
C++/CLI
public:
property MicroPDF417SymbolSize MicroPDF417SymbolSize {
   MicroPDF417SymbolSize get();
   void set (MicroPDF417SymbolSize value);
}

Return Value

A MicroPDF417SymbolSize enumeration member specifying the size of symbol used to represent this Micro PDF 417 barcode.

Remarks

If the SymbolSize is Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Pdf417Columns Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : Pdf417Columns Property

Gets or sets the number of columns in this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Integer

instance.Pdf417Columns = value

value = instance.Pdf417Columns
C#
public int Pdf417Columns {get; set;}
Managed Extensions for C++
public: __property int get_Pdf417Columns();
public: __property void set_Pdf417Columns(
   int value
);
C++/CLI
public:
property int Pdf417Columns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this PDF417 barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 1 or greater than 30 - OR - Throws when value is 0 and Pdf417Rows is also 0.

Remarks

The minimum number of columns in a PDF 417 barcode is 1 and the maximum number of columns is 30. If this property is 0, the library will compute automatically the number of required columns to encode the barcode data. When this property is 0, the Pdf417Rows property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Pdf417DataCompactionMode Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : Pdf417DataCompactionMode Property

Gets or sets the data compaction mode for this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417DataCompactionMode As PDF417DataCompactionMode
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As PDF417DataCompactionMode

instance.Pdf417DataCompactionMode = value

value = instance.Pdf417DataCompactionMode
C#
public PDF417DataCompactionMode Pdf417DataCompactionMode {get; set;}
Managed Extensions for C++
public: __property PDF417DataCompactionMode get_Pdf417DataCompactionMode();
public: __property void set_Pdf417DataCompactionMode(
   PDF417DataCompactionMode value
);
C++/CLI
public:
property PDF417DataCompactionMode Pdf417DataCompactionMode {
   PDF417DataCompactionMode get();
   void set (PDF417DataCompactionMode value);
}

Return Value

A PDF417DataCompactionMode enumeration member specifying the data compaction mode used in this PDF417 barcode.

Remarks

The Text compaction mode provides a 2:1 compaction ratio when using only ASCII characters from 0x20 to 0x7F. The Numeric compaction mode provides a 2.93:1 compaction ratio when using only digits (0x30 to 0x39). Byte compaction mode provides a 1.2:1 compaction ratio when using any 8bit character.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Pdf417ErrorCorrectionLevel Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : Pdf417ErrorCorrectionLevel Property

Gets or sets the level of error correction used by this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417ErrorCorrectionLevel As PDF417ErrorCorrectionLevel
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As PDF417ErrorCorrectionLevel

instance.Pdf417ErrorCorrectionLevel = value

value = instance.Pdf417ErrorCorrectionLevel
C#
public PDF417ErrorCorrectionLevel Pdf417ErrorCorrectionLevel {get; set;}
Managed Extensions for C++
public: __property PDF417ErrorCorrectionLevel get_Pdf417ErrorCorrectionLevel();
public: __property void set_Pdf417ErrorCorrectionLevel(
   PDF417ErrorCorrectionLevel value
);
C++/CLI
public:
property PDF417ErrorCorrectionLevel Pdf417ErrorCorrectionLevel {
   PDF417ErrorCorrectionLevel get();
   void set (PDF417ErrorCorrectionLevel value);
}

Return Value

A PDF417ErrorCorrectionLevel enumeration member specifying the level or error correction used by this PDF417 barcode.

Remarks

The lowest error correction level is 0 and the greatest error correction level is 8. Each level generates a specific number of error correction codewords.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Pdf417Rows Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : Pdf417Rows Property

Gets or sets the number of rows in this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Integer

instance.Pdf417Rows = value

value = instance.Pdf417Rows
C#
public int Pdf417Rows {get; set;}
Managed Extensions for C++
public: __property int get_Pdf417Rows();
public: __property void set_Pdf417Rows(
   int value
);
C++/CLI
public:
property int Pdf417Rows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows used by this PDF417 barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 3, but not 0, or greater than 90 - OR - Throws when value is 0 and Pdf417Columns is also 0.

Remarks

The minimum number of rows in a PDF 417 barcode is 3 and the maximum number of rows is 90. If this property is 0, the library will compute automatically the number of required rows to encode the barcode data. When this property is 0, the Pdf417Columns property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
RightQuietZone Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : RightQuietZone Property

Gets or sets the right quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property RightQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Single

instance.RightQuietZone = value

value = instance.RightQuietZone
C#
public float RightQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_RightQuietZone();
public: __property void set_RightQuietZone(
   float value
);
C++/CLI
public:
property float RightQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of right quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the right quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Rotation Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : Rotation Property

Gets or sets the rotation angle of the barcode.

Syntax

Visual Basic (Declaration)
Public Property Rotation As BarcodeRotation
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As BarcodeRotation

instance.Rotation = value

value = instance.Rotation
C#
public BarcodeRotation Rotation {get; set;}
Managed Extensions for C++
public: __property BarcodeRotation get_Rotation();
public: __property void set_Rotation(
   BarcodeRotation value
);
C++/CLI
public:
property BarcodeRotation Rotation {
   BarcodeRotation get();
   void set (BarcodeRotation value);
}

Return Value

A BarcodeRotation enumeration member specifying the angle used for rotating the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SerialNumber Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : SerialNumber Property

Gets or sets the serial number.

Syntax

Visual Basic (Declaration)
Public Property SerialNumber As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As String

instance.SerialNumber = value

value = instance.SerialNumber
C#
public string SerialNumber {get; set;}
Managed Extensions for C++
public: __property string* get_SerialNumber();
public: __property void set_SerialNumber(
   string* value
);
C++/CLI
public:
property String^ SerialNumber {
   String^ get();
   void set (String^ value);
}

Return Value

The Barcode4NET serial number.

Remarks

The serial number unlocks the BarcodeTextBox Windows Forms control and removes the TRIAL watermark from the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Symbology Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : Symbology Property

Gets or sets the type of the barcode displayed in the control.

Syntax

Visual Basic (Declaration)
Public Property Symbology As BarcodeSymbology
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As BarcodeSymbology

instance.Symbology = value

value = instance.Symbology
C#
public BarcodeSymbology Symbology {get; set;}
Managed Extensions for C++
public: __property BarcodeSymbology get_Symbology();
public: __property void set_Symbology(
   BarcodeSymbology value
);
C++/CLI
public:
property BarcodeSymbology Symbology {
   BarcodeSymbology get();
   void set (BarcodeSymbology value);
}

Return Value

A BarcodeSymbology enumeration member specifying the type of the barcode displayed in the control.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Text Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : Text Property

Gets or sets the current text in the text box.

Syntax

Visual Basic (Declaration)
Overrides Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As String

instance.Text = value

value = instance.Text
C#
public override string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text()override ;
public: __property void set_Text(
   string* value
)override ;
C++/CLI
public:
property String^ Text override {
   String^ get();
   void set (String^ value);
}

Return Value

The text displayed in the control.

Exceptions

Exception | Description
ArgumentException | Thrown if the data can not be encoded as a barcode of the selected symbology.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
TopQuietZone Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : TopQuietZone Property

Gets or sets the top quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property TopQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Single

instance.TopQuietZone = value

value = instance.TopQuietZone
C#
public float TopQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_TopQuietZone();
public: __property void set_TopQuietZone(
   float value
);
C++/CLI
public:
property float TopQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of top quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the top quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
XDimension Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : XDimension Property

Gets or sets the width of a narrow bar.

Syntax

Visual Basic (Declaration)
Public Property XDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Single

instance.XDimension = value

value = instance.XDimension
C#
public float XDimension {get; set;}
Managed Extensions for C++
public: __property float get_XDimension();
public: __property void set_XDimension(
   float value
);
C++/CLI
public:
property float XDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of a narrow bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.
The recommended width of a narrow bar is 12 mills. Depending on the barcode printer resolution and quality of barcode scanner, the XDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower XDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
YDimension Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeTextBox Class : YDimension Property

Gets or sets the height of a bar.

Syntax

Visual Basic (Declaration)
Public Property YDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextBox
Dim value As Single

instance.YDimension = value

value = instance.YDimension
C#
public float YDimension {get; set;}
Managed Extensions for C++
public: __property float get_YDimension();
public: __property void set_YDimension(
   float value
);
C++/CLI
public:
property float YDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeTextBox Class
BarcodeTextBox Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BarcodeView Class
See Also Members
[image]
O2S.Barcode4NET.WinControls Namespace : BarcodeView Class

Represents a barcode control displayed on a form.

Object Model

Syntax

Visual Basic (Declaration)
Public Class BarcodeView
   Inherits Control
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
C#
public class BarcodeView : Control
Managed Extensions for C++
public __gc class BarcodeView : public Control
C++/CLI
public ref class BarcodeView : public Control

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
O2S.Barcode4NET.WinControls.BarcodeView

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Members
O2S.Barcode4NET.WinControls Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
BarcodeView Class Members
See Also Properties Methods Events
[image]
O2S.Barcode4NET.WinControls Namespace : BarcodeView Class

The following tables list the members exposed by BarcodeView.

Public Constructors

 | Name | Description
Public Constructor | BarcodeView Constructor | Initializes a new BarcodeView object.
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView. (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | Overridden. Gets or sets the background color for the barcode.
Public Property | BackgroundImage | Overridden. Gets or sets the background image of the control.
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | Barcode | Gets the Barcode object behind the control.
Public Property | BarColor | Gets or sets the bars color for the barcode.
Public Property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BorderColor | Gets or sets the border color for the barcode.
Public Property | BorderStyle | Gets or sets the border style for the barcode.
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode.
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CodablockFColumns | Gets or sets the number of columns in this CODABLOCK F barcode.
Public Property | CodablockFRows | Gets or sets the number of rows in this CODABLOCK F barcode.
Public Property | Code16KRows | Gets or sets the number of rows in this Code 16K barcode.
Public Property | Code39WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | Gets the IContainer that contains the Component. (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | Data | Gets or sets the data displayed in the control.
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DataMatrixEncoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | DataMatrixSymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties.
Public Property | DisplayCheckSum | Gets or sets a value indicating whether the check characters should be displayed in barcode text.
Public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | EANSupplement | Gets or sets the supplement for barcode data.
Public Property | EANSupplementDisplayLocation | Gets or sets the location of the EAN supplement text.
Public Property | EANSupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum character should be appended automatically to the barcode.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Overridden. Gets or sets the font of the barcode text displayed in the control.
Public Property | ForeColor | Overridden. Gets or sets the fore color of the control.
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode.
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MicroPDF417SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Pdf417Columns | Gets or sets the number of columns in this PDF417 barcode.
Public Property | Pdf417DataCompactionMode | Gets or sets the data compaction mode for this PDF417 barcode.
Public Property | Pdf417ErrorCorrectionLevel | Gets or sets the level of error correction used by this PDF417 barcode.
Public Property | Pdf417Rows | Gets or sets the number of rows in this PDF417 barcode.
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode.
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | Rotation | Gets or sets the rotation angle of the barcode.
Public Property | SerialNumber | Gets or sets the serial number.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Symbology | Gets or sets the type of the barcode displayed in the control.
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | TextColor | Gets or sets the text color for the barcode.
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode.
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | XDimension | Gets or sets the width of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Clean up any resources being used. Releases all resources used by the Component. (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | SizeChanged | Occurs when the Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

BarcodeView Class
O2S.Barcode4NET.WinControls Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BarcodeView Constructor
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : BarcodeView Constructor

Initializes a new BarcodeView object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView()
C#
public BarcodeView()
Managed Extensions for C++
public: BarcodeView();
C++/CLI
public:
BarcodeView();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Windows Send comments on this topic.
BarcodeView Class Properties
See Also
[image]
O2S.Barcode4NET.WinControls Namespace : BarcodeView Class

For a list of all members of this type, see BarcodeView members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView. (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | Overridden. Gets or sets the background color for the barcode.
Public Property | BackgroundImage | Overridden. Gets or sets the background image of the control.
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | Barcode | Gets the Barcode object behind the control.
Public Property | BarColor | Gets or sets the bars color for the barcode.
Public Property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BorderColor | Gets or sets the border color for the barcode.
Public Property | BorderStyle | Gets or sets the border style for the barcode.
Public Property | BorderWidth | Gets or sets the border width.
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode.
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CodablockFColumns | Gets or sets the number of columns in this CODABLOCK F barcode.
Public Property | CodablockFRows | Gets or sets the number of rows in this CODABLOCK F barcode.
Public Property | Code16KRows | Gets or sets the number of rows in this Code 16K barcode.
Public Property | Code39WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | Gets the IContainer that contains the Component. (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | Data | Gets or sets the data displayed in the control.
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DataMatrixEncoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | DataMatrixSymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties.
Public Property | DisplayCheckSum | Gets or sets a value indicating whether the check characters should be displayed in barcode text.
Public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | EANSupplement | Gets or sets the supplement for barcode data.
Public Property | EANSupplementDisplayLocation | Gets or sets the location of the EAN supplement text.
Public Property | EANSupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum character should be appended automatically to the barcode.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Overridden. Gets or sets the font of the barcode text displayed in the control.
Public Property | ForeColor | Overridden. Gets or sets the fore color of the control.
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode.
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MicroPDF417SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Pdf417Columns | Gets or sets the number of columns in this PDF417 barcode.
Public Property | Pdf417DataCompactionMode | Gets or sets the data compaction mode for this PDF417 barcode.
Public Property | Pdf417ErrorCorrectionLevel | Gets or sets the level of error correction used by this PDF417 barcode.
Public Property | Pdf417Rows | Gets or sets the number of rows in this PDF417 barcode.
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode.
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | Rotation | Gets or sets the rotation angle of the barcode.
Public Property | SerialNumber | Gets or sets the serial number.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Symbology | Gets or sets the type of the barcode displayed in the control.
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | TextColor | Gets or sets the text color for the barcode.
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode.
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | XDimension | Gets or sets the width of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

See Also

Reference

BarcodeView Class
O2S.Barcode4NET.WinControls Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BackColor Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : BackColor Property

Gets or sets the background color for the barcode.

Syntax

Visual Basic (Declaration)
Overrides Public Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
public override Color BackColor {get; set;}
Managed Extensions for C++
public: __property Color get_BackColor()override ;
public: __property void set_BackColor(
   Color value
)override ;
C++/CLI
public:
property Color BackColor override {
   Color get();
   void set (Color value);
}

Return Value

A Color that represents the background color of the barcode. The default value is White.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BackgroundImage Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : BackgroundImage Property

Gets or sets the background image of the control.

Syntax

Visual Basic (Declaration)
Overrides Public Property BackgroundImage As Image
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Image

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
public override Image BackgroundImage {get; set;}
Managed Extensions for C++
public: __property Image get_BackgroundImage()override ;
public: __property void set_BackgroundImage(
   Image value
)override ;
C++/CLI
public:
property Image BackgroundImage override {
   Image get();
   void set (Image value);
}

Remarks

This property is not used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Barcode Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Barcode Property

Gets the Barcode object behind the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Barcode As Barcode
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Barcode

value = instance.Barcode
C#
public Barcode Barcode {get;}
Managed Extensions for C++
public: __property Barcode* get_Barcode();
C++/CLI
public:
property Barcode^ Barcode {
   Barcode^ get();
}

Return Value

A Barcode object that represents the barcode displayed in the control.

Remarks

If this Barcode object is modified directly, call control's Update method to reflect the changes in the displayed barcode image.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BarColor Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : BarColor Property

Gets or sets the bars color for the barcode.

Syntax

Visual Basic (Declaration)
Public Property BarColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Color

instance.BarColor = value

value = instance.BarColor
C#
public Color BarColor {get; set;}
Managed Extensions for C++
public: __property Color get_BarColor();
public: __property void set_BarColor(
   Color value
);
C++/CLI
public:
property Color BarColor {
   Color get();
   void set (Color value);
}

Return Value

A Color that represents the bars color of the barcode. The default value is Black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BorderColor Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : BorderColor Property

Gets or sets the border color for the barcode.

Syntax

Visual Basic (Declaration)
Public Property BorderColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Color

instance.BorderColor = value

value = instance.BorderColor
C#
public Color BorderColor {get; set;}
Managed Extensions for C++
public: __property Color get_BorderColor();
public: __property void set_BorderColor(
   Color value
);
C++/CLI
public:
property Color BorderColor {
   Color get();
   void set (Color value);
}

Return Value

A Color object specifying the color of the control border.

Remarks

This border is drawn only if the border width is greater than 0 and BorderStyle property is Adjust.
Note: BorderStyle property is not available for .Net Compact Framework.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BorderStyle Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : BorderStyle Property

Gets or sets the border style for the barcode.

Syntax

Visual Basic (Declaration)
Public Property BorderStyle As Border3DStyle
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Border3DStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public Border3DStyle BorderStyle {get; set;}
Managed Extensions for C++
public: __property Border3DStyle get_BorderStyle();
public: __property void set_BorderStyle(
   Border3DStyle value
);
C++/CLI
public:
property Border3DStyle BorderStyle {
   Border3DStyle get();
   void set (Border3DStyle value);
}

Return Value

A Border3DStyle enumeration member specifying how the control border is drawn.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BorderWidth Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : BorderWidth Property

Gets or sets the border width.

Syntax

Visual Basic (Declaration)
Public Property BorderWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Integer

instance.BorderWidth = value

value = instance.BorderWidth
C#
public int BorderWidth {get; set;}
Managed Extensions for C++
public: __property int get_BorderWidth();
public: __property void set_BorderWidth(
   int value
);
C++/CLI
public:
property int BorderWidth {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the border width.

Remarks

This border is drawn only if the width is greater than 0 and BorderStyle property is Adjust.
Note: BorderStyle property is not available for .Net Compact Framework.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BottomQuietZone Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : BottomQuietZone Property

Gets or sets the bottom quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property BottomQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.BottomQuietZone = value

value = instance.BottomQuietZone
C#
public float BottomQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_BottomQuietZone();
public: __property void set_BottomQuietZone(
   float value
);
C++/CLI
public:
property float BottomQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of bottom quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the bottom quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
CodablockFColumns Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : CodablockFColumns Property

Gets or sets the number of columns in this CODABLOCK F barcode.

Syntax

Visual Basic (Declaration)
Public Property CodablockFColumns As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Integer

instance.CodablockFColumns = value

value = instance.CodablockFColumns
C#
public int CodablockFColumns {get; set;}
Managed Extensions for C++
public: __property int get_CodablockFColumns();
public: __property void set_CodablockFColumns(
   int value
);
C++/CLI
public:
property int CodablockFColumns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this CODABLOCK F barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 7 or greater than 65.

Remarks

The minimum number of columns in a CODABLOCK F barcode is 7 and the maximum number of columns is 65. This property includes the character subset selector, row indicator and row check columns.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
CodablockFRows Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : CodablockFRows Property

Gets or sets the number of rows in this CODABLOCK F barcode.

Syntax

Visual Basic (Declaration)
Public Property CodablockFRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Integer

instance.CodablockFRows = value

value = instance.CodablockFRows
C#
public int CodablockFRows {get; set;}
Managed Extensions for C++
public: __property int get_CodablockFRows();
public: __property void set_CodablockFRows(
   int value
);
C++/CLI
public:
property int CodablockFRows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows in this CODABLOCK F barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2 or greater than 44.

Remarks

The minimum number of rows in a CODABLOCK F barcode is 2 and the maximum number of rows is 44.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Code16KRows Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Code16KRows Property

Gets or sets the number of rows in this Code 16K barcode.

Syntax

Visual Basic (Declaration)
Public Property Code16KRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Integer

instance.Code16KRows = value

value = instance.Code16KRows
C#
public int Code16KRows {get; set;}
Managed Extensions for C++
public: __property int get_Code16KRows();
public: __property void set_Code16KRows(
   int value
);
C++/CLI
public:
property int Code16KRows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows in this Code 16K barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2 but not 0, or greater than 16.

Remarks

The minimum number of rows in a Code 16K barcode is 2 and the maximum number of rows is 16. If this property is 0, the number of rows is calculated automatically to accomodate the barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Code39WideToNarrowRatio Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Code39WideToNarrowRatio Property

Gets or sets the ratio between wide bars and narrow bars.

Syntax

Visual Basic (Declaration)
Public Property Code39WideToNarrowRatio As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.Code39WideToNarrowRatio = value

value = instance.Code39WideToNarrowRatio
C#
public float Code39WideToNarrowRatio {get; set;}
Managed Extensions for C++
public: __property float get_Code39WideToNarrowRatio();
public: __property void set_Code39WideToNarrowRatio(
   float value
);
C++/CLI
public:
property float Code39WideToNarrowRatio {
   float get();
   void set (float value);
}

Return Value

A float value specifying the ratio between wide bars and narrow bars.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.
This property applies to Code39 barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Data Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Data Property

Gets or sets the data displayed in the control.

Syntax

Visual Basic (Declaration)
Public Property Data As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As String

instance.Data = value

value = instance.Data
C#
public string Data {get; set;}
Managed Extensions for C++
public: __property string* get_Data();
public: __property void set_Data(
   string* value
);
C++/CLI
public:
property String^ Data {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing the data displayed in the control as a barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
DataDisplayLocation Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : DataDisplayLocation Property

Gets or sets the location of the barcode data.

Syntax

Visual Basic (Declaration)
Public Property DataDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As BarcodeTextLocation

instance.DataDisplayLocation = value

value = instance.DataDisplayLocation
C#
public BarcodeTextLocation DataDisplayLocation {get; set;}
Managed Extensions for C++
public: __property BarcodeTextLocation get_DataDisplayLocation();
public: __property void set_DataDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation DataDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location of the barcode data when it is displayed on the barcode.

Remarks

This property applies to 1D barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
DataMatrixEncoding Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : DataMatrixEncoding Property

Gets or sets the encoding of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property DataMatrixEncoding As DataMatrixEncoding
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As DataMatrixEncoding

instance.DataMatrixEncoding = value

value = instance.DataMatrixEncoding
C#
public DataMatrixEncoding DataMatrixEncoding {get; set;}
Managed Extensions for C++
public: __property DataMatrixEncoding get_DataMatrixEncoding();
public: __property void set_DataMatrixEncoding(
   DataMatrixEncoding value
);
C++/CLI
public:
property DataMatrixEncoding DataMatrixEncoding {
   DataMatrixEncoding get();
   void set (DataMatrixEncoding value);
}

Return Value

A DataMatrixEncoding enumeration member specifying the data encoding for this DataMatrix barcode.

Remarks

If the data to encode contains only numbers (ASCII characters from 0x30 to 0x39), then Numeric provides the best encoding. If the data to encode contains only base ASCII characters (0x00 to 0x7F), then both ASCII and Base256 encoding provide the same performance, but if the data to encode contains more than 3 extended ASCII characters (0x80 to 0xFF) then the Base256 encoding is the best option.
If the selected encoding is Auto, then the library will select the encoding that will generate the smallest encoded data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
DataMatrixSymbolSize Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : DataMatrixSymbolSize Property

Gets or sets the symbol size of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property DataMatrixSymbolSize As DataMatrixSymbolSize
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As DataMatrixSymbolSize

instance.DataMatrixSymbolSize = value

value = instance.DataMatrixSymbolSize
C#
public DataMatrixSymbolSize DataMatrixSymbolSize {get; set;}
Managed Extensions for C++
public: __property DataMatrixSymbolSize get_DataMatrixSymbolSize();
public: __property void set_DataMatrixSymbolSize(
   DataMatrixSymbolSize value
);
C++/CLI
public:
property DataMatrixSymbolSize DataMatrixSymbolSize {
   DataMatrixSymbolSize get();
   void set (DataMatrixSymbolSize value);
}

Return Value

A DataMatrixSymbolSize enumeration member specifying the size of symbol used to represent this DataMatrix barcode.

Remarks

If the SymbolSize is Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
DimensionUnit Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : DimensionUnit Property

Gets or sets the measure unit for the XDimension and YDimension properties.

Syntax

Visual Basic (Declaration)
Public Property DimensionUnit As XYDimensionUnit
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As XYDimensionUnit

instance.DimensionUnit = value

value = instance.DimensionUnit
C#
public XYDimensionUnit DimensionUnit {get; set;}
Managed Extensions for C++
public: __property XYDimensionUnit get_DimensionUnit();
public: __property void set_DimensionUnit(
   XYDimensionUnit value
);
C++/CLI
public:
property XYDimensionUnit DimensionUnit {
   XYDimensionUnit get();
   void set (XYDimensionUnit value);
}

Return Value

A XYDimensionUnit enumeration member specifying the measure unit for the XDimension and YDimension properties.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
DisplayCheckSum Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : DisplayCheckSum Property

Gets or sets a value indicating whether the check characters should be displayed in barcode text.

Syntax

Visual Basic (Declaration)
Public Property DisplayCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Boolean

instance.DisplayCheckSum = value

value = instance.DisplayCheckSum
C#
public bool DisplayCheckSum {get; set;}
Managed Extensions for C++
public: __property bool get_DisplayCheckSum();
public: __property void set_DisplayCheckSum(
   bool value
);
C++/CLI
public:
property bool DisplayCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if the check characters should be displayed. Default is false.

Remarks

This property applies to 1D barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
EANSupplement Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : EANSupplement Property

Gets or sets the supplement for barcode data.

Syntax

Visual Basic (Declaration)
Public Property EANSupplement As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As String

instance.EANSupplement = value

value = instance.EANSupplement
C#
public string EANSupplement {get; set;}
Managed Extensions for C++
public: __property string* get_EANSupplement();
public: __property void set_EANSupplement(
   string* value
);
C++/CLI
public:
property String^ EANSupplement {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying a 2 or 5 digit supplemental barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in supplement data or the supplement does not have the required length (2 or 5 digits).

Remarks

This supplement is optional. If it exists, it can be only 2 or 5 digits.
This property applies to EAN13, EAN8, ISBN, ISMN, ISSN, JAN13, UPC-A and UPC-E barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
EANSupplementDisplayLocation Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : EANSupplementDisplayLocation Property

Gets or sets the location of the EAN supplement text.

Syntax

Visual Basic (Declaration)
Public Property EANSupplementDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As BarcodeTextLocation

instance.EANSupplementDisplayLocation = value

value = instance.EANSupplementDisplayLocation
C#
public BarcodeTextLocation EANSupplementDisplayLocation {get; set;}
Managed Extensions for C++
public: __property BarcodeTextLocation get_EANSupplementDisplayLocation();
public: __property void set_EANSupplementDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation EANSupplementDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location where the supplement text is displayed.

Remarks

The embedding options are ignored for supplement text. AboveEmbedded has the same effect like Above, and BelowEmbedded has the same effect like Below.
This property applies to EAN13, EAN8, ISBN, ISMN, ISSN, JAN13, UPC-A and UPC-E barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
EANSupplementYDimension Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : EANSupplementYDimension Property

Gets or sets the height of a bar in the supplement barcode.

Syntax

Visual Basic (Declaration)
Public Property EANSupplementYDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.EANSupplementYDimension = value

value = instance.EANSupplementYDimension
C#
public float EANSupplementYDimension {get; set;}
Managed Extensions for C++
public: __property float get_EANSupplementYDimension();
public: __property void set_EANSupplementYDimension(
   float value
);
C++/CLI
public:
property float EANSupplementYDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a bar in the supplement barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
EnableCheckSum Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : EnableCheckSum Property

Gets or sets a value indicating whether a checksum character should be appended automatically to the barcode.

Syntax

Visual Basic (Declaration)
Public Property EnableCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Boolean

instance.EnableCheckSum = value

value = instance.EnableCheckSum
C#
public bool EnableCheckSum {get; set;}
Managed Extensions for C++
public: __property bool get_EnableCheckSum();
public: __property void set_EnableCheckSum(
   bool value
);
C++/CLI
public:
property bool EnableCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if a checksum character should be appended automatically to the barcode, false otherwise.

Remarks

This property applies to 1D barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Font Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Font Property

Gets or sets the font of the barcode text displayed in the control.

Syntax

Visual Basic (Declaration)
Overrides Public Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Font

instance.Font = value

value = instance.Font
C#
public override Font Font {get; set;}
Managed Extensions for C++
public: __property Font get_Font()override ;
public: __property void set_Font(
   Font value
)override ;
C++/CLI
public:
property Font Font override {
   Font get();
   void set (Font value);
}

Return Value

The Font object to apply to the barcode text displayed in the control.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ForeColor Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : ForeColor Property

Gets or sets the fore color of the control.

Syntax

Visual Basic (Declaration)
Overrides Public Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
C#
public override Color ForeColor {get; set;}
Managed Extensions for C++
public: __property Color get_ForeColor()override ;
public: __property void set_ForeColor(
   Color value
)override ;
C++/CLI
public:
property Color ForeColor override {
   Color get();
   void set (Color value);
}

Remarks

This property is not used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LeftQuietZone Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : LeftQuietZone Property

Gets or sets the left quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property LeftQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.LeftQuietZone = value

value = instance.LeftQuietZone
C#
public float LeftQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_LeftQuietZone();
public: __property void set_LeftQuietZone(
   float value
);
C++/CLI
public:
property float LeftQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of left quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the left quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MicroPDF417SymbolSize Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : MicroPDF417SymbolSize Property

Gets or sets the symbol size of this Micro PDF 417 barcode.

Syntax

Visual Basic (Declaration)
Public Property MicroPDF417SymbolSize As MicroPDF417SymbolSize
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As MicroPDF417SymbolSize

instance.MicroPDF417SymbolSize = value

value = instance.MicroPDF417SymbolSize
C#
public MicroPDF417SymbolSize MicroPDF417SymbolSize {get; set;}
Managed Extensions for C++
public: __property MicroPDF417SymbolSize get_MicroPDF417SymbolSize();
public: __property void set_MicroPDF417SymbolSize(
   MicroPDF417SymbolSize value
);
C++/CLI
public:
property MicroPDF417SymbolSize MicroPDF417SymbolSize {
   MicroPDF417SymbolSize get();
   void set (MicroPDF417SymbolSize value);
}

Return Value

A MicroPDF417SymbolSize enumeration member specifying the size of symbol used to represent this Micro PDF 417 barcode.

Remarks

If the SymbolSize is Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Pdf417Columns Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Pdf417Columns Property

Gets or sets the number of columns in this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Integer

instance.Pdf417Columns = value

value = instance.Pdf417Columns
C#
public int Pdf417Columns {get; set;}
Managed Extensions for C++
public: __property int get_Pdf417Columns();
public: __property void set_Pdf417Columns(
   int value
);
C++/CLI
public:
property int Pdf417Columns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this PDF417 barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 1 or greater than 30 - OR - Throws when value is 0 and Pdf417Rows is also 0.

Remarks

The minimum number of columns in a PDF 417 barcode is 1 and the maximum number of columns is 30. If this property is 0, the library will compute automatically the number of required columns to encode the barcode data. When this property is 0, the Pdf417Rows property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Pdf417DataCompactionMode Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Pdf417DataCompactionMode Property

Gets or sets the data compaction mode for this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417DataCompactionMode As PDF417DataCompactionMode
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As PDF417DataCompactionMode

instance.Pdf417DataCompactionMode = value

value = instance.Pdf417DataCompactionMode
C#
public PDF417DataCompactionMode Pdf417DataCompactionMode {get; set;}
Managed Extensions for C++
public: __property PDF417DataCompactionMode get_Pdf417DataCompactionMode();
public: __property void set_Pdf417DataCompactionMode(
   PDF417DataCompactionMode value
);
C++/CLI
public:
property PDF417DataCompactionMode Pdf417DataCompactionMode {
   PDF417DataCompactionMode get();
   void set (PDF417DataCompactionMode value);
}

Return Value

A PDF417DataCompactionMode enumeration member specifying the data compaction mode used in this PDF417 barcode.

Remarks

The Text compaction mode provides a 2:1 compaction ratio when using only ASCII characters from 0x20 to 0x7F. The Numeric compaction mode provides a 2.93:1 compaction ratio when using only digits (0x30 to 0x39). Byte compaction mode provides a 1.2:1 compaction ratio when using any 8bit character.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Pdf417ErrorCorrectionLevel Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Pdf417ErrorCorrectionLevel Property

Gets or sets the level of error correction used by this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417ErrorCorrectionLevel As PDF417ErrorCorrectionLevel
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As PDF417ErrorCorrectionLevel

instance.Pdf417ErrorCorrectionLevel = value

value = instance.Pdf417ErrorCorrectionLevel
C#
public PDF417ErrorCorrectionLevel Pdf417ErrorCorrectionLevel {get; set;}
Managed Extensions for C++
public: __property PDF417ErrorCorrectionLevel get_Pdf417ErrorCorrectionLevel();
public: __property void set_Pdf417ErrorCorrectionLevel(
   PDF417ErrorCorrectionLevel value
);
C++/CLI
public:
property PDF417ErrorCorrectionLevel Pdf417ErrorCorrectionLevel {
   PDF417ErrorCorrectionLevel get();
   void set (PDF417ErrorCorrectionLevel value);
}

Return Value

A PDF417ErrorCorrectionLevel enumeration member specifying the level or error correction used by this PDF417 barcode.

Remarks

The lowest error correction level is 0 and the greatest error correction level is 8. Each level generates a specific number of error correction codewords.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Pdf417Rows Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Pdf417Rows Property

Gets or sets the number of rows in this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Integer

instance.Pdf417Rows = value

value = instance.Pdf417Rows
C#
public int Pdf417Rows {get; set;}
Managed Extensions for C++
public: __property int get_Pdf417Rows();
public: __property void set_Pdf417Rows(
   int value
);
C++/CLI
public:
property int Pdf417Rows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows used by this PDF417 barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 3, but not 0, or greater than 90 - OR - Throws when value is 0 and Pdf417Columns is also 0.

Remarks

The minimum number of rows in a PDF 417 barcode is 3 and the maximum number of rows is 90. If this property is 0, the library will compute automatically the number of required rows to encode the barcode data. When this property is 0, the Pdf417Columns property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
RightQuietZone Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : RightQuietZone Property

Gets or sets the right quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property RightQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.RightQuietZone = value

value = instance.RightQuietZone
C#
public float RightQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_RightQuietZone();
public: __property void set_RightQuietZone(
   float value
);
C++/CLI
public:
property float RightQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of right quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the right quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Rotation Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Rotation Property

Gets or sets the rotation angle of the barcode.

Syntax

Visual Basic (Declaration)
Public Property Rotation As BarcodeRotation
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As BarcodeRotation

instance.Rotation = value

value = instance.Rotation
C#
public BarcodeRotation Rotation {get; set;}
Managed Extensions for C++
public: __property BarcodeRotation get_Rotation();
public: __property void set_Rotation(
   BarcodeRotation value
);
C++/CLI
public:
property BarcodeRotation Rotation {
   BarcodeRotation get();
   void set (BarcodeRotation value);
}

Return Value

A BarcodeRotation enumeration member specifying the angle used for rotating the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SerialNumber Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : SerialNumber Property

Gets or sets the serial number.

Syntax

Visual Basic (Declaration)
Public Property SerialNumber As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As String

instance.SerialNumber = value

value = instance.SerialNumber
C#
public string SerialNumber {get; set;}
Managed Extensions for C++
public: __property string* get_SerialNumber();
public: __property void set_SerialNumber(
   string* value
);
C++/CLI
public:
property String^ SerialNumber {
   String^ get();
   void set (String^ value);
}

Return Value

The Barcode4NET serial number.

Remarks

The serial number unlocks the BarcodeView Windows Forms control and removes the TRIAL watermark from the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Symbology Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Symbology Property

Gets or sets the type of the barcode displayed in the control.

Syntax

Visual Basic (Declaration)
Public Property Symbology As BarcodeSymbology
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As BarcodeSymbology

instance.Symbology = value

value = instance.Symbology
C#
public BarcodeSymbology Symbology {get; set;}
Managed Extensions for C++
public: __property BarcodeSymbology get_Symbology();
public: __property void set_Symbology(
   BarcodeSymbology value
);
C++/CLI
public:
property BarcodeSymbology Symbology {
   BarcodeSymbology get();
   void set (BarcodeSymbology value);
}

Return Value

A BarcodeSymbology enumeration member specifying the type of the barcode displayed in the control.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
TextColor Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : TextColor Property

Gets or sets the text color for the barcode.

Syntax

Visual Basic (Declaration)
Public Property TextColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Color

instance.TextColor = value

value = instance.TextColor
C#
public Color TextColor {get; set;}
Managed Extensions for C++
public: __property Color get_TextColor();
public: __property void set_TextColor(
   Color value
);
C++/CLI
public:
property Color TextColor {
   Color get();
   void set (Color value);
}

Return Value

A Color that represents the color used to display the barcode data. The default value is Black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
TopQuietZone Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : TopQuietZone Property

Gets or sets the top quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property TopQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.TopQuietZone = value

value = instance.TopQuietZone
C#
public float TopQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_TopQuietZone();
public: __property void set_TopQuietZone(
   float value
);
C++/CLI
public:
property float TopQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of top quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the top quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
XDimension Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : XDimension Property

Gets or sets the width of a narrow bar.

Syntax

Visual Basic (Declaration)
Public Property XDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.XDimension = value

value = instance.XDimension
C#
public float XDimension {get; set;}
Managed Extensions for C++
public: __property float get_XDimension();
public: __property void set_XDimension(
   float value
);
C++/CLI
public:
property float XDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of a narrow bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.
The recommended width of a narrow bar is 12 mills. Depending on the barcode printer resolution and quality of barcode scanner, the XDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower XDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
YDimension Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : YDimension Property

Gets or sets the height of a bar.

Syntax

Visual Basic (Declaration)
Public Property YDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.YDimension = value

value = instance.YDimension
C#
public float YDimension {get; set;}
Managed Extensions for C++
public: __property float get_YDimension();
public: __property void set_YDimension(
   float value
);
C++/CLI
public:
property float YDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%ItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Xheo.Licensing Namespace (Barcode4NET.Windows)
See Also Inheritance Hierarchy

Classes

Class | Description
BigInteger | Implements an large integer of arbitrary length.
ContainerLimit | Serves as a base class for limits that contain other limits.
ExtendedLicense | Primary class for the XHEO|Licensing framework.
ExtendedLicenseException | Represents an exception in a Xheo assembly with a localized FriendlyMessage and DetailedMessage.
ExtendedLicensePack | Represents a collection of licenses stored in a single .LIC file.
LicenseSigningKey | Implements a key pair for signing licenses.
LicenseValuesCollection | Maintains a collection of name value pairs. The collection can be serialized and marked as read only.
Limit | Base class for all license limitations.
LimitCollection | Services as a collection of limits.
MachineProfile | Manages a machine profile used by the license activation system. Profiles represent a collection of generally non volitale system properties that can collectively be used to identify certain machines.
MachineProfile.Constants | A class to contain the constants required for the IP_ADAPTER_INFO struct
MachineProfile.GetAdapterInfo | Uses the windows API to retrieve information about the IP configuration of the local machine
StateEntry |
TransientReadOnlyCollection | Implements a transient read only collection. Values can be added, removed and changed until the SetReadOnly method is called thus forcing the collection to a read only state.

Structures

Structure | Description
LicenseSigningKey.KeyRecord |
MachineProfile._MEMORYSTATUS | Summary of _MEMORYSTATUS
MachineProfile._MEMORYSTATUSEX | Summary of _MEMORYSTATUSEX
MachineProfile.IP_ADAPTERINFO_STRUCTURE | declare the IP_ADAPTERINFO_STRUCTURE structure
MachineProfile.IP_ADDR_STRING | declare the IP_ADDR_STRING structure
MachineProfile.TGuid | Summary of TGuid

Enumerations

Enumeration | Description
PeekResult | Possible results from the Peek method.
SerialNumberSizes | Possible key sizes for use when generating serial numbers. More bits makes it more difficult to crack but also increase the size of the serial number.

See Also

Reference

Barcode4NET.Windows Assembly


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Class
See Also Members
[image]
Xheo.Licensing Namespace : BigInteger Class

Implements an large integer of arbitrary length.

Syntax

Visual Basic (Declaration)
Private Class BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
C#
private class BigInteger
Managed Extensions for C++
private __gc class BigInteger
C++/CLI
private ref class BigInteger

Inheritance Hierarchy

System.Object
Xheo.Licensing.BigInteger

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
BigInteger Class Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : BigInteger Class

The following tables list the members exposed by BigInteger.

Public Constructors

 | Name | Description
Public Constructor | BigInteger Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | dataLength |
static (Shared in Visual Basic) | primesBelow2000 |
Top

Public Methods

 | Name | Description
Public Method | abs |
Public Method | bitCount |
Public Method | Equals | Overridden.
Public Method | FermatLittleTest |
Public Method | gcd |
static (Shared in Visual Basic) | genPseudoPrime |
Public Method | genRandomBits |
Public Method | getBit |
Public Method | getBytes |
Public Method | GetHashCode | Overridden.
Public Method | IntValue |
Public Method | isProbablePrime | Overloaded.
static (Shared in Visual Basic) | Jacobi |
Public Method | LongValue |
static (Shared in Visual Basic) | LucasSequence |
Public Method | LucasStrongTest |
Public Method | min |
Public Method | modInverse |
Public Method | modPow |
Public Method | RabinMillerTest |
Public Method | setBit |
Public Method | sqrt |
Public Method | ToHexString |
Public Method | ToString | Overloaded. Overridden.
Public Method | ULongValue |
Public Method | unsetBit |
Top

Public Operators

Public Operator Addition |
Public Operator And |
Public Operator Or |
Public Operator Decrement |
Public Operator Division |
Public Operator Equality |
Public Operator Exclusive Or |
Public Operator Greater Than |
Public Operator Greater Than or Equal |
Public Operator Implicit Type Conversion | Overloaded.
Public Operator Increment |
Public Operator Inequality |
Public Operator Left-shift |
Public Operator Less Than |
Public Operator Less Than or Equal |
Public Operator Modulus |
Public Operator Multiplication |
Public Operator Bitwise Complement |
Public Operator Right-shift |
Public Operator Subtraction |
Public Operator Unary Negation |
Top

See Also

Reference

BigInteger Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Constructor
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : BigInteger Constructor

Overload List

Overload | Description
BigInteger Constructor() |
BigInteger Constructor(BigInteger) |
BigInteger Constructor(Byte[]) |
BigInteger Constructor(Byte[],Int32) |
BigInteger Constructor(Int64) |
BigInteger Constructor(String,Int32) |
BigInteger Constructor(UInt32[]) |
BigInteger Constructor(UInt64) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Constructor()
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BigInteger()
C#
public BigInteger()
Managed Extensions for C++
public: BigInteger();
C++/CLI
public:
BigInteger();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Constructor(BigInteger)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(BigInteger)

bi

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bi As BigInteger _
)
Visual Basic (Usage) Copy Code
Dim bi As BigInteger

Dim instance As BigInteger(bi)
C#
public BigInteger(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger(
   BigInteger* bi
)
C++/CLI
public:
BigInteger(
   BigInteger^ bi
)

Parameters

bi

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Constructor(Byte[])
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Byte[])

inData

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As Byte _
)
Visual Basic (Usage) Copy Code
Dim inData() As Byte

Dim instance As BigInteger(inData)
C#
public BigInteger(
   byte[] inData
)
Managed Extensions for C++
public: BigInteger(
   byte[] inData
)
C++/CLI
public:
BigInteger(
   array<byte> inData
)

Parameters

inData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Constructor(Byte[],Int32)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Byte[],Int32)

inData
inLen

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As Byte, _
   ByVal inLen As Integer _
)
Visual Basic (Usage) Copy Code
Dim inData() As Byte
Dim inLen As Integer

Dim instance As BigInteger(inData, inLen)
C#
public BigInteger(
   byte[] inData,
   int inLen
)
Managed Extensions for C++
public: BigInteger(
   byte[] inData,
   int inLen
)
C++/CLI
public:
BigInteger(
   array<byte> inData,
   int inLen
)

Parameters

inData
inLen

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Constructor(Int64)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Int64)

value

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim value As Long

Dim instance As BigInteger(value)
C#
public BigInteger(
   long value
)
Managed Extensions for C++
public: BigInteger(
   long value
)
C++/CLI
public:
BigInteger(
   long value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Constructor(String,Int32)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(String,Int32)

value
radix

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal radix As Integer _
)
Visual Basic (Usage) Copy Code
Dim value As String
Dim radix As Integer

Dim instance As BigInteger(value, radix)
C#
public BigInteger(
   string value,
   int radix
)
Managed Extensions for C++
public: BigInteger(
   string* value,
   int radix
)
C++/CLI
public:
BigInteger(
   String^ value,
   int radix
)

Parameters

value
radix

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Constructor(UInt32[])
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(UInt32[])

inData

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As UInteger _
)
Visual Basic (Usage) Copy Code
Dim inData() As UInteger

Dim instance As BigInteger(inData)
C#
public BigInteger(
   uint[] inData
)
Managed Extensions for C++
public: BigInteger(
   uint[] inData
)
C++/CLI
public:
BigInteger(
   array<uint> inData
)

Parameters

inData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
BigInteger Constructor(UInt64)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(UInt64)

value

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As ULong _
)
Visual Basic (Usage) Copy Code
Dim value As ULong

Dim instance As BigInteger(value)
C#
public BigInteger(
   ulong value
)
Managed Extensions for C++
public: BigInteger(
   ulong value
)
C++/CLI
public:
BigInteger(
   ulong value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
BigInteger Class Methods
See Also
[image]
Xheo.Licensing Namespace : BigInteger Class

For a list of all members of this type, see BigInteger members.

Public Methods

 | Name | Description
Public Method | abs |
Public Method | bitCount |
Public Method | Equals | Overridden.
Public Method | FermatLittleTest |
Public Method | gcd |
static (Shared in Visual Basic) | genPseudoPrime |
Public Method | genRandomBits |
Public Method | getBit |
Public Method | getBytes |
Public Method | GetHashCode | Overridden.
Public Method | IntValue |
Public Method | isProbablePrime | Overloaded.
static (Shared in Visual Basic) | Jacobi |
Public Method | LongValue |
static (Shared in Visual Basic) | LucasSequence |
Public Method | LucasStrongTest |
Public Method | min |
Public Method | modInverse |
Public Method | modPow |
Public Method | RabinMillerTest |
Public Method | setBit |
Public Method | sqrt |
Public Method | ToHexString |
Public Method | ToString | Overloaded. Overridden.
Public Method | ULongValue |
Public Method | unsetBit |
Top

See Also

Reference

BigInteger Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
abs Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : abs Method

Syntax

Visual Basic (Declaration)
Public Function abs() As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As BigInteger

value = instance.abs()
C#
public BigInteger abs()
Managed Extensions for C++
public: BigInteger* abs();
C++/CLI
public:
BigInteger^ abs();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
bitCount Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : bitCount Method

Syntax

Visual Basic (Declaration)
Public Function bitCount() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.bitCount()
C#
public int bitCount()
Managed Extensions for C++
public: int bitCount();
C++/CLI
public:
int bitCount();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Equals Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Equals Method

o

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal o As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim o As Object
Dim value As Boolean

value = instance.Equals(o)
C#
public override bool Equals(
   object o
)
Managed Extensions for C++
public: bool Equals(
   Object* o
) override
C++/CLI
public:
bool Equals(
   Object^ o
) override

Parameters

o

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
FermatLittleTest Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : FermatLittleTest Method

confidence

Syntax

Visual Basic (Declaration)
Public Function FermatLittleTest( _
   ByVal confidence As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim confidence As Integer
Dim value As Boolean

value = instance.FermatLittleTest(confidence)
C#
public bool FermatLittleTest(
   int confidence
)
Managed Extensions for C++
public: bool FermatLittleTest(
   int confidence
)
C++/CLI
public:
bool FermatLittleTest(
   int confidence
)

Parameters

confidence

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
gcd Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : gcd Method

bi

Syntax

Visual Basic (Declaration)
Public Function gcd( _
   ByVal bi As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bi As BigInteger
Dim value As BigInteger

value = instance.gcd(bi)
C#
public BigInteger gcd(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger* gcd(
   BigInteger* bi
)
C++/CLI
public:
BigInteger^ gcd(
   BigInteger^ bi
)

Parameters

bi

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
genPseudoPrime Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : genPseudoPrime Method

bits
confidence
rand

Syntax

Visual Basic (Declaration)
Public Shared Function genPseudoPrime( _
   ByVal bits As Integer, _
   ByVal confidence As Integer, _
   ByVal rand As RandomNumberGenerator _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim bits As Integer
Dim confidence As Integer
Dim rand As RandomNumberGenerator
Dim value As BigInteger

value = BigInteger.genPseudoPrime(bits, confidence, rand)
C#
public static BigInteger genPseudoPrime(
   int bits,
   int confidence,
   RandomNumberGenerator rand
)
Managed Extensions for C++
public: static BigInteger* genPseudoPrime(
   int bits,
   int confidence,
   RandomNumberGenerator* rand
)
C++/CLI
public:
static BigInteger^ genPseudoPrime(
   int bits,
   int confidence,
   RandomNumberGenerator^ rand
)

Parameters

bits
confidence
rand

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
genRandomBits Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : genRandomBits Method

bits
rand

Syntax

Visual Basic (Declaration)
Public Sub genRandomBits( _
   ByVal bits As Integer, _
   ByVal rand As RandomNumberGenerator _
)
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bits As Integer
Dim rand As RandomNumberGenerator

instance.genRandomBits(bits, rand)
C#
public void genRandomBits(
   int bits,
   RandomNumberGenerator rand
)
Managed Extensions for C++
public: void genRandomBits(
   int bits,
   RandomNumberGenerator* rand
)
C++/CLI
public:
void genRandomBits(
   int bits,
   RandomNumberGenerator^ rand
)

Parameters

bits
rand

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
getBit Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : getBit Method

bitNum

Syntax

Visual Basic (Declaration)
Public Function getBit( _
   ByVal bitNum As UInteger _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bitNum As UInteger
Dim value As Boolean

value = instance.getBit(bitNum)
C#
public bool getBit(
   uint bitNum
)
Managed Extensions for C++
public: bool getBit(
   uint bitNum
)
C++/CLI
public:
bool getBit(
   uint bitNum
)

Parameters

bitNum

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
getBytes Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : getBytes Method

Syntax

Visual Basic (Declaration)
Public Function getBytes() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value() As Byte

value = instance.getBytes()
C#
public byte[] getBytes()
Managed Extensions for C++
public: byte[] getBytes();
C++/CLI
public:
array<byte> getBytes();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetHashCode Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : GetHashCode Method

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IntValue Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : IntValue Method

Syntax

Visual Basic (Declaration)
Public Function IntValue() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.IntValue()
C#
public int IntValue()
Managed Extensions for C++
public: int IntValue();
C++/CLI
public:
int IntValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
isProbablePrime Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : isProbablePrime Method

Overload List

Overload | Description
isProbablePrime(Int32) |
isProbablePrime() |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
isProbablePrime(Int32) Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > isProbablePrime Method : isProbablePrime(Int32) Method

confidence

Syntax

Visual Basic (Declaration)
Overloads Public Function isProbablePrime( _
   ByVal confidence As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim confidence As Integer
Dim value As Boolean

value = instance.isProbablePrime(confidence)
C#
public bool isProbablePrime(
   int confidence
)
Managed Extensions for C++
public: bool isProbablePrime(
   int confidence
)
C++/CLI
public:
bool isProbablePrime(
   int confidence
)

Parameters

confidence

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
isProbablePrime() Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > isProbablePrime Method : isProbablePrime() Method

Syntax

Visual Basic (Declaration)
Overloads Public Function isProbablePrime() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Boolean

value = instance.isProbablePrime()
C#
public bool isProbablePrime()
Managed Extensions for C++
public: bool isProbablePrime();
C++/CLI
public:
bool isProbablePrime();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Jacobi Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Jacobi Method

a
b

Syntax

Visual Basic (Declaration)
Public Shared Function Jacobi( _
   ByVal a As BigInteger, _
   ByVal b As BigInteger _
) As Integer
Visual Basic (Usage) Copy Code
Dim a As BigInteger
Dim b As BigInteger
Dim value As Integer

value = BigInteger.Jacobi(a, b)
C#
public static int Jacobi(
   BigInteger a,
   BigInteger b
)
Managed Extensions for C++
public: static int Jacobi(
   BigInteger* a,
   BigInteger* b
)
C++/CLI
public:
static int Jacobi(
   BigInteger^ a,
   BigInteger^ b
)

Parameters

a
b

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LongValue Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : LongValue Method

Syntax

Visual Basic (Declaration)
Public Function LongValue() As Long
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Long

value = instance.LongValue()
C#
public long LongValue()
Managed Extensions for C++
public: long LongValue();
C++/CLI
public:
long LongValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LucasSequence Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : LucasSequence Method

P
Q
k
n

Syntax

Visual Basic (Declaration)
Public Shared Function LucasSequence( _
   ByVal P As BigInteger, _
   ByVal Q As BigInteger, _
   ByVal k As BigInteger, _
   ByVal n As BigInteger _
) As BigInteger()
Visual Basic (Usage) Copy Code
Dim P As BigInteger
Dim Q As BigInteger
Dim k As BigInteger
Dim n As BigInteger
Dim value() As BigInteger

value = BigInteger.LucasSequence(P, Q, k, n)
C#
public static BigInteger[] LucasSequence(
   BigInteger P,
   BigInteger Q,
   BigInteger k,
   BigInteger n
)
Managed Extensions for C++
public: static BigInteger*[] LucasSequence(
   BigInteger* P,
   BigInteger* Q,
   BigInteger* k,
   BigInteger* n
)
C++/CLI
public:
static array<BigInteger^> LucasSequence(
   BigInteger^ P,
   BigInteger^ Q,
   BigInteger^ k,
   BigInteger^ n
)

Parameters

P
Q
k
n

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LucasStrongTest Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : LucasStrongTest Method

Syntax

Visual Basic (Declaration)
Public Function LucasStrongTest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Boolean

value = instance.LucasStrongTest()
C#
public bool LucasStrongTest()
Managed Extensions for C++
public: bool LucasStrongTest();
C++/CLI
public:
bool LucasStrongTest();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
min Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : min Method

bi

Syntax

Visual Basic (Declaration)
Public Function min( _
   ByVal bi As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bi As BigInteger
Dim value As BigInteger

value = instance.min(bi)
C#
public BigInteger min(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger* min(
   BigInteger* bi
)
C++/CLI
public:
BigInteger^ min(
   BigInteger^ bi
)

Parameters

bi

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
modInverse Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : modInverse Method

modulus

Syntax

Visual Basic (Declaration)
Public Function modInverse( _
   ByVal modulus As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim modulus As BigInteger
Dim value As BigInteger

value = instance.modInverse(modulus)
C#
public BigInteger modInverse(
   BigInteger modulus
)
Managed Extensions for C++
public: BigInteger* modInverse(
   BigInteger* modulus
)
C++/CLI
public:
BigInteger^ modInverse(
   BigInteger^ modulus
)

Parameters

modulus

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
modPow Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : modPow Method

exp
n

Syntax

Visual Basic (Declaration)
Public Function modPow( _
   ByVal exp As BigInteger, _
   ByVal n As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim exp As BigInteger
Dim n As BigInteger
Dim value As BigInteger

value = instance.modPow(exp, n)
C#
public BigInteger modPow(
   BigInteger exp,
   BigInteger n
)
Managed Extensions for C++
public: BigInteger* modPow(
   BigInteger* exp,
   BigInteger* n
)
C++/CLI
public:
BigInteger^ modPow(
   BigInteger^ exp,
   BigInteger^ n
)

Parameters

exp
n

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
RabinMillerTest Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : RabinMillerTest Method

confidence

Syntax

Visual Basic (Declaration)
Public Function RabinMillerTest( _
   ByVal confidence As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim confidence As Integer
Dim value As Boolean

value = instance.RabinMillerTest(confidence)
C#
public bool RabinMillerTest(
   int confidence
)
Managed Extensions for C++
public: bool RabinMillerTest(
   int confidence
)
C++/CLI
public:
bool RabinMillerTest(
   int confidence
)

Parameters

confidence

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
setBit Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : setBit Method

bitNum

Syntax

Visual Basic (Declaration)
Public Sub setBit( _
   ByVal bitNum As UInteger _
)
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bitNum As UInteger

instance.setBit(bitNum)
C#
public void setBit(
   uint bitNum
)
Managed Extensions for C++
public: void setBit(
   uint bitNum
)
C++/CLI
public:
void setBit(
   uint bitNum
)

Parameters

bitNum

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
sqrt Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : sqrt Method

Syntax

Visual Basic (Declaration)
Public Function sqrt() As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As BigInteger

value = instance.sqrt()
C#
public BigInteger sqrt()
Managed Extensions for C++
public: BigInteger* sqrt();
C++/CLI
public:
BigInteger^ sqrt();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ToHexString Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : ToHexString Method

Syntax

Visual Basic (Declaration)
Public Function ToHexString() As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As String

value = instance.ToHexString()
C#
public string ToHexString()
Managed Extensions for C++
public: string* ToHexString();
C++/CLI
public:
String^ ToHexString();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ToString Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : ToString Method

Overload List

Overload | Description
ToString() |
ToString(Int32) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ToString() Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > ToString Method : ToString() Method

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ToString(Int32) Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > ToString Method : ToString(Int32) Method

radix

Syntax

Visual Basic (Declaration)
Overloads Public Function ToString( _
   ByVal radix As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim radix As Integer
Dim value As String

value = instance.ToString(radix)
C#
public string ToString(
   int radix
)
Managed Extensions for C++
public: string* ToString(
   int radix
)
C++/CLI
public:
String^ ToString(
   int radix
)

Parameters

radix

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ULongValue Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : ULongValue Method

Syntax

Visual Basic (Declaration)
Public Function ULongValue() As ULong
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As ULong

value = instance.ULongValue()
C#
public ulong ULongValue()
Managed Extensions for C++
public: ulong ULongValue();
C++/CLI
public:
ulong ULongValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
unsetBit Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : unsetBit Method

bitNum

Syntax

Visual Basic (Declaration)
Public Sub unsetBit( _
   ByVal bitNum As UInteger _
)
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bitNum As UInteger

instance.unsetBit(bitNum)
C#
public void unsetBit(
   uint bitNum
)
Managed Extensions for C++
public: void unsetBit(
   uint bitNum
)
C++/CLI
public:
void unsetBit(
   uint bitNum
)

Parameters

bitNum

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.Windows Send comments on this topic.
BigInteger Class Fields
See Also
[image]
Xheo.Licensing Namespace : BigInteger Class

For a list of all members of this type, see BigInteger members.

Public Fields

 | Name | Description
Public Field | dataLength |
static (Shared in Visual Basic) | primesBelow2000 |
Top

See Also

Reference

BigInteger Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
dataLength Field
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : dataLength Field

Syntax

Visual Basic (Declaration)
Public dataLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.dataLength

instance.dataLength = value
C#
public int dataLength
Managed Extensions for C++
public: int dataLength
C++/CLI
public:
int dataLength

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
primesBelow2000 Field
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : primesBelow2000 Field

Syntax

Visual Basic (Declaration)
Public Shared primesBelow2000 As Integer()
Visual Basic (Usage) Copy Code
Dim value() As Integer

value = BigInteger.primesBelow2000

BigInteger.primesBelow2000 = value
C#
public static int[] primesBelow2000
Managed Extensions for C++
public: static int[] primesBelow2000
C++/CLI
public:
static array<int> primesBelow2000

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Addition Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Addition Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator +(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Addition(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator +(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
And Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : And Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator And( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator &(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_BitwiseAnd(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator &(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Or Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Or Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator Or( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator |(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_BitwiseOr(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator |(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Decrement Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Decrement Operator

bi1

Syntax

Visual Basic (Declaration)
This operator type is not supported by Visual Basic
C#
public BigInteger operator --(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_Decrement(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator --(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Division Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Division Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator /( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator /(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Division(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator /(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Equality Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Equality Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator ==(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_Equality(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator ==(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Exclusive Or Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Exclusive Or Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator Xor( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator ^(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_ExclusiveOr(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator ^(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Greater Than Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Greater Than Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator >(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_GreaterThan(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator >(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Greater Than or Equal Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Greater Than or Equal Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator >=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_GreaterThanOrEqual(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator >=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Implicit Type Conversion Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Implicit Type Conversion Operator

Overload List

Overload | Description
Implicit Type Conversion(Int32) |
Implicit Type Conversion(Int64) |
Implicit Type Conversion(UInt32) |
Implicit Type Conversion(UInt64) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Increment Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Increment Operator

bi1

Syntax

Visual Basic (Declaration)
This operator type is not supported by Visual Basic
C#
public BigInteger operator ++(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_Increment(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator ++(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Inequality Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Inequality Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator !=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_Inequality(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator !=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Left-shift Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Left-shift Operator

bi1
shiftVal

Syntax

Visual Basic (Declaration)
Public Operator <<( _
   ByVal bi1 As BigInteger, _
   ByVal shiftVal As Integer _
) As BigInteger
C#
public BigInteger operator <<(
   BigInteger bi1,
   int shiftVal
)
Managed Extensions for C++
public: BigInteger* op_LeftShift(
   BigInteger* bi1,
   int shiftVal
)
C++/CLI
public:
BigInteger^ operator <<(
   BigInteger^ bi1,
   int shiftVal
)

Parameters

bi1
shiftVal

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Less Than Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Less Than Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator <(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_LessThan(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator <(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Less Than or Equal Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Less Than or Equal Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator <=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_LessThanOrEqual(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator <=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Modulus Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Modulus Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator Mod( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator %(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Modulus(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator %(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Multiplication Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Multiplication Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator *( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator *(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Multiply(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator *(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Bitwise Complement Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Bitwise Complement Operator

bi1

Syntax

Visual Basic (Declaration)
Public Operator Not( _
   ByVal bi1 As BigInteger _
) As BigInteger
C#
public BigInteger operator ~(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_OnesComplement(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator ~(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Right-shift Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Right-shift Operator

bi1
shiftVal

Syntax

Visual Basic (Declaration)
Public Operator >>( _
   ByVal bi1 As BigInteger, _
   ByVal shiftVal As Integer _
) As BigInteger
C#
public BigInteger operator >>(
   BigInteger bi1,
   int shiftVal
)
Managed Extensions for C++
public: BigInteger* op_RightShift(
   BigInteger* bi1,
   int shiftVal
)
C++/CLI
public:
BigInteger^ operator >>(
   BigInteger^ bi1,
   int shiftVal
)

Parameters

bi1
shiftVal

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Subtraction Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Subtraction Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator -(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Subtraction(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator -(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Unary Negation Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Unary Negation Operator

bi1

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal bi1 As BigInteger _
) As BigInteger
C#
public BigInteger operator -(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_UnaryNegation(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator -(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ContainerLimit Class
See Also Members
[image]
Xheo.Licensing Namespace : ContainerLimit Class

Serves as a base class for limits that contain other limits.

Object Model

Syntax

Visual Basic (Declaration)
Private MustInherit Class ContainerLimit
   Inherits Limit
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
C#
private abstract class ContainerLimit : Limit
Managed Extensions for C++
private __gc abstract class ContainerLimit : public Limit
C++/CLI
private ref class ContainerLimit abstract : public Limit

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Xheo.Licensing.Limit
Xheo.Licensing.ContainerLimit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
ContainerLimit Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : ContainerLimit Class

The following tables list the members exposed by ContainerLimit.

Public Properties

 | Name | Description
Public Property | Description | Gets the description of the limit. (Inherited from Limit)
Public Property | IsGui | Overridden. Gets a value that indicates if the limit may use a GUI interface.
Public Property | IsRemote | Overridden. Gets a value that indicates if the limit may use remote resources.
Public Property | IsTimeSensitive | Overridden. Determines if any contained limits are time sensitive.
Public Property | License | Gets or sets a reference to the ExtendedLicense that contains this Limit. (Inherited from Limit)
Public Property | Limits | Gets the collection of child limits.
Public Property | Name | Gets the display name of the limit. (Inherited from Limit)
Public Property | QualifiedTypeName | Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type. (Inherited from Limit)
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases any managed or unmanged resources. (Inherited from Limit)
Public Method | GetDetailsDescription | Gets a description of the details of the limit. (Inherited from Limit)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Granted | Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created. (Inherited from Limit)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | LoadFromXml | Overridden. Loads the contents of a Limit from an XmlNode.
Public Method | Peek | Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user. (Inherited from Limit)
Public Method | SaveToXml | Overridden. Saves the contents of the Limit as an XmlNode.
Public Method | Validate | Validates that the license being granted is within the limits enforced by this object. (Inherited from Limit)
Top

See Also

Reference

ContainerLimit Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
ContainerLimit Class Methods
See Also
[image]
Xheo.Licensing Namespace : ContainerLimit Class

For a list of all members of this type, see ContainerLimit members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases any managed or unmanged resources. (Inherited from Limit)
Public Method | GetDetailsDescription | Gets a description of the details of the limit. (Inherited from Limit)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Granted | Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created. (Inherited from Limit)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | LoadFromXml | Overridden. Loads the contents of a Limit from an XmlNode.
Public Method | Peek | Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user. (Inherited from Limit)
Public Method | SaveToXml | Overridden. Saves the contents of the Limit as an XmlNode.
Public Method | Validate | Validates that the license being granted is within the limits enforced by this object. (Inherited from Limit)
Top

See Also

Reference

ContainerLimit Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : LoadFromXml Method

node
The XmlNode to load from.
Loads the contents of a Limit from an XmlNode.

Syntax

Visual Basic (Declaration)
Overrides Public Function LoadFromXml( _
   ByVal node As XmlNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim node As XmlNode
Dim value As Boolean

value = instance.LoadFromXml(node)
C#
public override bool LoadFromXml(
   XmlNode node
)
Managed Extensions for C++
public: bool LoadFromXml(
   XmlNode node
) override
C++/CLI
public:
bool LoadFromXml(
   XmlNode node
) override

Parameters

node
The XmlNode to load from.

Return Value

Returns true if the load was successful, otherwise false.
Returns true if the load was successful, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : SaveToXml Method

parent
The parent node to save to.
Saves the contents of the Limit as an XmlNode.

Syntax

Visual Basic (Declaration)
Overrides Public Function SaveToXml( _
   ByVal parent As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim parent As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parent)
C#
public override XmlNode SaveToXml(
   XmlNode parent
)
Managed Extensions for C++
public: XmlNode SaveToXml(
   XmlNode parent
) override
C++/CLI
public:
XmlNode SaveToXml(
   XmlNode parent
) override

Parameters

parent
The parent node to save to.

Return Value

Returns the saved XmlNode.
Returns the saved XmlNode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Windows Send comments on this topic.
ContainerLimit Class Properties
See Also
[image]
Xheo.Licensing Namespace : ContainerLimit Class

For a list of all members of this type, see ContainerLimit members.

Public Properties

 | Name | Description
Public Property | Description | Gets the description of the limit. (Inherited from Limit)
Public Property | IsGui | Overridden. Gets a value that indicates if the limit may use a GUI interface.
Public Property | IsRemote | Overridden. Gets a value that indicates if the limit may use remote resources.
Public Property | IsTimeSensitive | Overridden. Determines if any contained limits are time sensitive.
Public Property | License | Gets or sets a reference to the ExtendedLicense that contains this Limit. (Inherited from Limit)
Public Property | Limits | Gets the collection of child limits.
Public Property | Name | Gets the display name of the limit. (Inherited from Limit)
Public Property | QualifiedTypeName | Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type. (Inherited from Limit)
Top

See Also

Reference

ContainerLimit Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IsGui Property
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : IsGui Property

Gets a value that indicates if the limit may use a GUI interface.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property IsGui As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim value As Boolean

value = instance.IsGui
C#
public override bool IsGui {get;}
Managed Extensions for C++
public: __property bool get_IsGui()override ;
C++/CLI
public:
property bool IsGui override {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IsRemote Property
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : IsRemote Property

Gets a value that indicates if the limit may use remote resources.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property IsRemote As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim value As Boolean

value = instance.IsRemote
C#
public override bool IsRemote {get;}
Managed Extensions for C++
public: __property bool get_IsRemote()override ;
C++/CLI
public:
property bool IsRemote override {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IsTimeSensitive Property
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : IsTimeSensitive Property

Determines if any contained limits are time sensitive.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property IsTimeSensitive As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim value As Boolean

value = instance.IsTimeSensitive
C#
public override bool IsTimeSensitive {get;}
Managed Extensions for C++
public: __property bool get_IsTimeSensitive()override ;
C++/CLI
public:
property bool IsTimeSensitive override {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Limits Property
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : Limits Property

Gets the collection of child limits.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Limits As LimitCollection
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim value As LimitCollection

value = instance.Limits
C#
public LimitCollection Limits {get;}
Managed Extensions for C++
public: __property LimitCollection* get_Limits();
C++/CLI
public:
property LimitCollection^ Limits {
   LimitCollection^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ExtendedLicense Class
See Also Members
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

Primary class for the XHEO|Licensing framework.

Object Model

Syntax

Visual Basic (Declaration)
Private NotInheritable Class ExtendedLicense
   Inherits License
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
C#
private sealed class ExtendedLicense : License
Managed Extensions for C++
private __gc __sealed class ExtendedLicense : public License
C++/CLI
private ref class ExtendedLicense sealed : public License

Remarks

Each Type in an assembly can be protected by XHEO|Licensing. The environment that the Type is allowed to run in, is defined by a collection of Limit instances defined for the license. For instance the license may limit a component for use on a computer with a specific IP address. These limits are implemented and enforced by subclasses of the Limit class.

To ensure that the license files have not been altered since they were issued, each ExtendedLicense is signed with a LicenseSigningKey. The signing key uses a public key encryption method (See Cryptography) with the public key embedded in the assembly that the component is implemented in. The private key remains secured with the original developers ensuring that only they can grant valid licenses.

Inheritance Hierarchy

System.Object
System.ComponentModel.License
Xheo.Licensing.ExtendedLicense

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Members
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
ExtendedLicense Class Members
See Also Fields Properties Methods
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

The following tables list the members exposed by ExtendedLicense.

Public Constructors

 | Name | Description
Public Constructor | ExtendedLicense Constructor | Overloaded. Initializes a new instance of the ExtendedLicense class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ConfigSection | The configuration section where XHEO|Licensing settings are stored in the application's configuration file.
static (Shared in Visual Basic) | CurrentVersion | The current license scheme file version.
Top

Public Properties

 | Name | Description
Public Property | AbsoluteOrganization | Gets or sets the name of the organization that the license is issued to.
Public Property | AbsoluteSerialNumber | Gets or sets the serial number for the license.
Public Property | AbsoluteUser | Gets or sets the name of the user that the license is issued to.
Public Property | AcceptedSerialNumberSizes | Gets or sets the serial number sizes that can be used to unlock the license. If a valid serial number of a different size is used, license validation will fail.
Public Property | AssemblyName | Gets or sets the name of the assembly used to sign the license originally. The value of this property is for reference only and has no impact on the validation of a license.
Public Property | Components | Gets the collection of component names that the license applies to.
static (Shared in Visual Basic) | ConnectionString | Gets the default database connection string for licensing components.
static (Shared in Visual Basic) | EmulateVersion | Gets a value that determines the release version that XHEO|Licensing should emulate.
Public Property | Expires | Gets or sets the expiration date for the license.
static (Shared in Visual Basic) | IisIsAvailable | Gets a value that indicates if IIS is installed and available on the machine. If false then HttpContext should not be checked because it will throw an exception.
Public Property | InvalidReason | Gets or sets the reason the license was not valid. If Validate returns true this is an empty string.
Public Property | IsEmbedded | Gets or sets a value that indicates if the license was loaded from an embedded resource rather then an external .LIC file.
Public Property | IsReadOnly | Gets a value that indicates if the current license is read only.
Public Property | IssuerUrl | Gets or sets the URL to the company that issued the license.
static (Shared in Visual Basic) | IsTerminalServices | Gets a value that indicates if the current session is running under terminal services.
Public Property | IsTimeSensitive | Gets a value that indicates if the license contians time sensitive data and the clock should be protected.
static (Shared in Visual Basic) | IsWebRequest | Gets a value indicating if a web request/HttpContext is currently available.
static (Shared in Visual Basic) | KeyFolder | Gets the folder where the license keys are located as defined in the application's config file.
Public Property | LicensedType | Gets the Type the license was/will be granted to.
static (Shared in Visual Basic) | LicenseFolders | Gets a collection of folders where the licenses are located as defined in the application's config file.
Public Property | LicenseKey | Overridden. Overrides LicenseKey.
Public Property | LicensePack | Gets the ExtendedLicensePack that owns the license.
Public Property | MaximumSerialNumberSeed | Gets or sets the maximum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.
Public Property | MetaValues | Gets a collection of arbitrary values to store with the license. These values are not protected and may be changed without affecting the validity of the license. Use for storing volitle information and other unsecured information.
Public Property | MinimumSerialNumberSeed | Gets or sets the minimum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.
Public Property | Organization | Gets or sets the name of the organization that the license is issued to.
Public Property | PersistantState | Gets a reference to per-license specific state that works independent of any underlying state schemes. This is used to safely track values that should be kept in memory even when a license is reloaded from disk.
Public Property | PublicKey | Gets a reference to the LicenseSigningKey being used to validate the license.
Public Property | SerialNumber | Gets or sets the value of the absolute serial number.
static (Shared in Visual Basic) | SharedFolder | Gets or sets the path to the shared license folder.
Public Property | Signature | Gets or sets the signature used to validate the license data.
Public Property | SurrogateLicensePack | Gets or sets a surrogate license pack to use if validation of this license fails.
Public Property | Tag | Gets or sets an arbitrary piece of data to track with the license. This is a "cheap" way of extending the license scheme by allowing you to store any kind of additional data that can be saved as a string to the license.
static (Shared in Visual Basic) | TemplateFolder | Gets the folder where the license templates are located as defined in the application's config file.
Public Property | Type | Gets or sets an application/product specific description of the type of license. For examples "designer", "single user", "non-profit", etc. This can often be used a reference to the primary key in a database, such as a SKU, for the product that the license represents.
Public Property | UnlockBySerial | Gets or sets a value that indicates if the user must provide a valid serial number to fully unlock the license.
Public Property | UnlockedLicense | Gets or sets the ExtendedLicense that was unlocked by the registration process.
Public Property | User | Gets or sets the value of the user as it should appear on screen.
Public Property | Values | Gets a collection of arbitrary values to store with the license.
Public Property | Version | Gets or sets the version of the licensing scheme used.
Public Property | XmlString | Gets or sets the contents of the license as an XML string fragment.
Top

Public Methods

 | Name | Description
Public Method | ComponentsFromString | Fills the components collection from a comma separated list.
Public Method | ComponentsToString | Gets the components collection as a comma separated list.
Public Method | Dispose | Releases any managed or unmanaged resources.
static (Shared in Visual Basic) | FromXml | Overloaded. Creates a new ExtendedLicense from an XML fragment.
Public Method | FromXmlString | Loads the contents of the license from an XML string.
static (Shared in Visual Basic) | GetFullPath | Utility function that gets the full path of a folder relative to the "application root" of the current application.
Public Method | GetShortAssemblyName | Gets the short name of the assembly. If the AssemblyName property contains version and key information, only the assembly name is returned.
Public Method | GetSigningKey | Overloaded. Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.
Public Method | GetValue | Gets the first value from the Values collection with the given key and if not found returns the default value instead.
Public Method | LoadFromXml | Loads the contents of a license from an XmlNode.
Public Method | SaveToXml | Saves the contents of the ExtendedLicense to the given XmlNode.
Public Method | ToXmlString | Saves the contents of the license to an XML string.
Top

See Also

Reference

ExtendedLicense Class
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ExtendedLicense Constructor
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ExtendedLicense Constructor

Initializes a new instance of the ExtendedLicense class.

Overload List

Overload | Description
ExtendedLicense Constructor() | Initializes a new instance of the ExtendedLicense class.
ExtendedLicense Constructor(XmlNode) | Initializes a new instance of the ExtendedLicense class with the values of the given XmlNode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ExtendedLicense Constructor()
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > ExtendedLicense Constructor : ExtendedLicense Constructor()

Initializes a new instance of the ExtendedLicense class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense()
C#
public ExtendedLicense()
Managed Extensions for C++
public: ExtendedLicense();
C++/CLI
public:
ExtendedLicense();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ExtendedLicense Constructor(XmlNode)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > ExtendedLicense Constructor : ExtendedLicense Constructor(XmlNode)

node
The XmlNode of the ExtendedLicensePack to load the license properties from.
Initializes a new instance of the ExtendedLicense class with the values of the given XmlNode.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal node As XmlNode _
)
Visual Basic (Usage) Copy Code
Dim node As XmlNode

Dim instance As ExtendedLicense(node)
C#
public ExtendedLicense(
   XmlNode node
)
Managed Extensions for C++
public: ExtendedLicense(
   XmlNode node
)
C++/CLI
public:
ExtendedLicense(
   XmlNode node
)

Parameters

node
The XmlNode of the ExtendedLicensePack to load the license properties from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
ExtendedLicense Class Methods
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

For a list of all members of this type, see ExtendedLicense members.

Public Methods

 | Name | Description
Public Method | ComponentsFromString | Fills the components collection from a comma separated list.
Public Method | ComponentsToString | Gets the components collection as a comma separated list.
Public Method | Dispose | Releases any managed or unmanaged resources.
static (Shared in Visual Basic) | FromXml | Overloaded. Creates a new ExtendedLicense from an XML fragment.
Public Method | FromXmlString | Loads the contents of the license from an XML string.
static (Shared in Visual Basic) | GetFullPath | Utility function that gets the full path of a folder relative to the "application root" of the current application.
Public Method | GetShortAssemblyName | Gets the short name of the assembly. If the AssemblyName property contains version and key information, only the assembly name is returned.
Public Method | GetSigningKey | Overloaded. Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.
Public Method | GetValue | Gets the first value from the Values collection with the given key and if not found returns the default value instead.
Public Method | LoadFromXml | Loads the contents of a license from an XmlNode.
Public Method | SaveToXml | Saves the contents of the ExtendedLicense to the given XmlNode.
Public Method | ToXmlString | Saves the contents of the license to an XML string.
Top

See Also

Reference

ExtendedLicense Class
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ComponentsFromString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ComponentsFromString Method

components
Comma separated list of components.
Fills the components collection from a comma separated list.

Syntax

Visual Basic (Declaration)
Public Sub ComponentsFromString( _
   ByVal components As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim components As String

instance.ComponentsFromString(components)
C#
public void ComponentsFromString(
   string components
)
Managed Extensions for C++
public: void ComponentsFromString(
   string* components
)
C++/CLI
public:
void ComponentsFromString(
   String^ components
)

Parameters

components
Comma separated list of components.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ComponentsToString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ComponentsToString Method

Gets the components collection as a comma separated list.

Syntax

Visual Basic (Declaration)
Public Function ComponentsToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

value = instance.ComponentsToString()
C#
public string ComponentsToString()
Managed Extensions for C++
public: string* ComponentsToString();
C++/CLI
public:
String^ ComponentsToString();

Return Value

Returns the list of components.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Dispose Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Dispose Method

Releases any managed or unmanaged resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
FromXml Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : FromXml Method

Creates a new ExtendedLicense from an XML fragment.

Overload List

Overload | Description
FromXml(String) | Creates a new ExtendedLicense from an XML fragment.
FromXml(XmlNode) | Creates a new ExtendedLicense from an XML fragment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
FromXml(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > FromXml Method : FromXml(String) Method

xml
The xml to create the license from.
Creates a new ExtendedLicense from an XML fragment.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromXml( _
   ByVal xml As String _
) As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim xml As String
Dim value As ExtendedLicense

value = ExtendedLicense.FromXml(xml)
C#
public static ExtendedLicense FromXml(
   string xml
)
Managed Extensions for C++
public: static ExtendedLicense* FromXml(
   string* xml
)
C++/CLI
public:
static ExtendedLicense^ FromXml(
   String^ xml
)

Parameters

xml
The xml to create the license from.

Return Value

Returns the newly created extended license.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
FromXml(XmlNode) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > FromXml Method : FromXml(XmlNode) Method

xml
The xml to create the license from.
Creates a new ExtendedLicense from an XML fragment.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromXml( _
   ByVal xml As XmlNode _
) As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim xml As XmlNode
Dim value As ExtendedLicense

value = ExtendedLicense.FromXml(xml)
C#
public static ExtendedLicense FromXml(
   XmlNode xml
)
Managed Extensions for C++
public: static ExtendedLicense* FromXml(
   XmlNode xml
)
C++/CLI
public:
static ExtendedLicense^ FromXml(
   XmlNode xml
)

Parameters

xml
The xml to create the license from.

Return Value

Returns the newly created extended license.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : FromXmlString Method

xml
The XML string to load from.
Loads the contents of the license from an XML string.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
The XML string to load from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetFullPath Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : GetFullPath Method

path
The path to resolve to a complete path.
Utility function that gets the full path of a folder relative to the "application root" of the current application.

Syntax

Visual Basic (Declaration)
Public Shared Function GetFullPath( _
   ByVal path As String _
) As String
Visual Basic (Usage) Copy Code
Dim path As String
Dim value As String

value = ExtendedLicense.GetFullPath(path)
C#
public static string GetFullPath(
   string path
)
Managed Extensions for C++
public: static string* GetFullPath(
   string* path
)
C++/CLI
public:
static String^ GetFullPath(
   String^ path
)

Parameters

path
The path to resolve to a complete path.

Remarks

For console and forms applications the base folder is the folder of the entry executable. For Web sites the base folder is the root of the site...rather than the \bin folder.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetShortAssemblyName Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : GetShortAssemblyName Method

Gets the short name of the assembly. If the AssemblyName property contains version and key information, only the assembly name is returned.

Syntax

Visual Basic (Declaration)
Public Function GetShortAssemblyName() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

value = instance.GetShortAssemblyName()
C#
public string GetShortAssemblyName()
Managed Extensions for C++
public: string* GetShortAssemblyName();
C++/CLI
public:
String^ GetShortAssemblyName();

Return Value

Returns the short version of the AssemblyName if set, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetSigningKey Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : GetSigningKey Method

Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.

Overload List

Overload | Description
GetSigningKey(String) | Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.
GetSigningKey() | Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetSigningKey(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > GetSigningKey Method : GetSigningKey(String) Method

folder
The folder to look for keys. If null KeyFolder is used.
Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetSigningKey( _
   ByVal folder As String _
) As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim folder As String
Dim value As LicenseSigningKey

value = instance.GetSigningKey(folder)
C#
public LicenseSigningKey GetSigningKey(
   string folder
)
Managed Extensions for C++
public: LicenseSigningKey* GetSigningKey(
   string* folder
)
C++/CLI
public:
LicenseSigningKey^ GetSigningKey(
   String^ folder
)

Parameters

folder
The folder to look for keys. If null KeyFolder is used.

Return Value

Returns the key needed to sign the license if found, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetSigningKey() Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > GetSigningKey Method : GetSigningKey() Method

Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetSigningKey() As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As LicenseSigningKey

value = instance.GetSigningKey()
C#
public LicenseSigningKey GetSigningKey()
Managed Extensions for C++
public: LicenseSigningKey* GetSigningKey();
C++/CLI
public:
LicenseSigningKey^ GetSigningKey();

Return Value

Returns the key needed to sign the license if found, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetValue Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : GetValue Method

key
The key of the value to return.
defaultValue
The default value if not found.
Gets the first value from the Values collection with the given key and if not found returns the default value instead.

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal key As String, _
   ByVal defaultValue As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim key As String
Dim defaultValue As String
Dim value As String

value = instance.GetValue(key, defaultValue)
C#
public string GetValue(
   string key,
   string defaultValue
)
Managed Extensions for C++
public: string* GetValue(
   string* key,
   string* defaultValue
)
C++/CLI
public:
String^ GetValue(
   String^ key,
   String^ defaultValue
)

Parameters

key
The key of the value to return.
defaultValue
The default value if not found.

Return Value

Returns the first value with the given key if found, otherwise the default value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LoadFromXml Method

node
An XmlNode containing the license data.
Loads the contents of a license from an XmlNode.

Syntax

Visual Basic (Declaration)
Public Function LoadFromXml( _
   ByVal node As XmlNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim node As XmlNode
Dim value As Boolean

value = instance.LoadFromXml(node)
C#
public bool LoadFromXml(
   XmlNode node
)
Managed Extensions for C++
public: bool LoadFromXml(
   XmlNode node
)
C++/CLI
public:
bool LoadFromXml(
   XmlNode node
)

Parameters

node
An XmlNode containing the license data.

Return Value

Returns true if the load was successful, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : SaveToXml Method

parent
The parent XmlNode.
Saves the contents of the ExtendedLicense to the given XmlNode.

Syntax

Visual Basic (Declaration)
Public Function SaveToXml( _
   ByVal parent As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim parent As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parent)
C#
public XmlNode SaveToXml(
   XmlNode parent
)
Managed Extensions for C++
public: XmlNode SaveToXml(
   XmlNode parent
)
C++/CLI
public:
XmlNode SaveToXml(
   XmlNode parent
)

Parameters

parent
The parent XmlNode.

Return Value

Returns the root node of the saved license.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ToXmlString Method

Saves the contents of the license to an XML string.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

value = instance.ToXmlString()
C#
public string ToXmlString()
Managed Extensions for C++
public: string* ToXmlString();
C++/CLI
public:
String^ ToXmlString();

Return Value

The saved XML.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Windows Send comments on this topic.
ExtendedLicense Class Properties
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

For a list of all members of this type, see ExtendedLicense members.

Public Properties

 | Name | Description
Public Property | AbsoluteOrganization | Gets or sets the name of the organization that the license is issued to.
Public Property | AbsoluteSerialNumber | Gets or sets the serial number for the license.
Public Property | AbsoluteUser | Gets or sets the name of the user that the license is issued to.
Public Property | AcceptedSerialNumberSizes | Gets or sets the serial number sizes that can be used to unlock the license. If a valid serial number of a different size is used, license validation will fail.
Public Property | AssemblyName | Gets or sets the name of the assembly used to sign the license originally. The value of this property is for reference only and has no impact on the validation of a license.
Public Property | Components | Gets the collection of component names that the license applies to.
static (Shared in Visual Basic) | ConnectionString | Gets the default database connection string for licensing components.
static (Shared in Visual Basic) | EmulateVersion | Gets a value that determines the release version that XHEO|Licensing should emulate.
Public Property | Expires | Gets or sets the expiration date for the license.
static (Shared in Visual Basic) | IisIsAvailable | Gets a value that indicates if IIS is installed and available on the machine. If false then HttpContext should not be checked because it will throw an exception.
Public Property | InvalidReason | Gets or sets the reason the license was not valid. If Validate returns true this is an empty string.
Public Property | IsEmbedded | Gets or sets a value that indicates if the license was loaded from an embedded resource rather then an external .LIC file.
Public Property | IsReadOnly | Gets a value that indicates if the current license is read only.
Public Property | IssuerUrl | Gets or sets the URL to the company that issued the license.
static (Shared in Visual Basic) | IsTerminalServices | Gets a value that indicates if the current session is running under terminal services.
Public Property | IsTimeSensitive | Gets a value that indicates if the license contians time sensitive data and the clock should be protected.
static (Shared in Visual Basic) | IsWebRequest | Gets a value indicating if a web request/HttpContext is currently available.
static (Shared in Visual Basic) | KeyFolder | Gets the folder where the license keys are located as defined in the application's config file.
Public Property | LicensedType | Gets the Type the license was/will be granted to.
static (Shared in Visual Basic) | LicenseFolders | Gets a collection of folders where the licenses are located as defined in the application's config file.
Public Property | LicenseKey | Overridden. Overrides LicenseKey.
Public Property | LicensePack | Gets the ExtendedLicensePack that owns the license.
Public Property | MaximumSerialNumberSeed | Gets or sets the maximum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.
Public Property | MetaValues | Gets a collection of arbitrary values to store with the license. These values are not protected and may be changed without affecting the validity of the license. Use for storing volitle information and other unsecured information.
Public Property | MinimumSerialNumberSeed | Gets or sets the minimum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.
Public Property | Organization | Gets or sets the name of the organization that the license is issued to.
Public Property | PersistantState | Gets a reference to per-license specific state that works independent of any underlying state schemes. This is used to safely track values that should be kept in memory even when a license is reloaded from disk.
Public Property | PublicKey | Gets a reference to the LicenseSigningKey being used to validate the license.
Public Property | SerialNumber | Gets or sets the value of the absolute serial number.
static (Shared in Visual Basic) | SharedFolder | Gets or sets the path to the shared license folder.
Public Property | Signature | Gets or sets the signature used to validate the license data.
Public Property | SurrogateLicensePack | Gets or sets a surrogate license pack to use if validation of this license fails.
Public Property | Tag | Gets or sets an arbitrary piece of data to track with the license. This is a "cheap" way of extending the license scheme by allowing you to store any kind of additional data that can be saved as a string to the license.
static (Shared in Visual Basic) | TemplateFolder | Gets the folder where the license templates are located as defined in the application's config file.
Public Property | Type | Gets or sets an application/product specific description of the type of license. For examples "designer", "single user", "non-profit", etc. This can often be used a reference to the primary key in a database, such as a SKU, for the product that the license represents.
Public Property | UnlockBySerial | Gets or sets a value that indicates if the user must provide a valid serial number to fully unlock the license.
Public Property | UnlockedLicense | Gets or sets the ExtendedLicense that was unlocked by the registration process.
Public Property | User | Gets or sets the value of the user as it should appear on screen.
Public Property | Values | Gets a collection of arbitrary values to store with the license.
Public Property | Version | Gets or sets the version of the licensing scheme used.
Public Property | XmlString | Gets or sets the contents of the license as an XML string fragment.
Top

See Also

Reference

ExtendedLicense Class
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
AbsoluteOrganization Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AbsoluteOrganization Property

Gets or sets the name of the organization that the license is issued to.

Syntax

Visual Basic (Declaration)
Public Property AbsoluteOrganization As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.AbsoluteOrganization = value

value = instance.AbsoluteOrganization
C#
public string AbsoluteOrganization {get; set;}
Managed Extensions for C++
public: __property string* get_AbsoluteOrganization();
public: __property void set_AbsoluteOrganization(
   string* value
);
C++/CLI
public:
property String^ AbsoluteOrganization {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
AbsoluteSerialNumber Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AbsoluteSerialNumber Property

Gets or sets the serial number for the license.

Syntax

Visual Basic (Declaration)
Public Property AbsoluteSerialNumber As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.AbsoluteSerialNumber = value

value = instance.AbsoluteSerialNumber
C#
public string AbsoluteSerialNumber {get; set;}
Managed Extensions for C++
public: __property string* get_AbsoluteSerialNumber();
public: __property void set_AbsoluteSerialNumber(
   string* value
);
C++/CLI
public:
property String^ AbsoluteSerialNumber {
   String^ get();
   void set (String^ value);
}

Remarks

Generally the value of the serial number property is completely arbitrary and can contain any value. However the values should be treated as a primary key that uniquely identifies the license. Generally this is used to reference licenses in a back-end system and to uniquely identify the license.

By default a random GUID is generated for the serial number. You can later change it to any desired value.

(Version 1.2+) When using Unlock by Serial to unlock licenses, the Absolute Serial Number is used to match user's serial numbers to licenses.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
AbsoluteUser Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AbsoluteUser Property

Gets or sets the name of the user that the license is issued to.

Syntax

Visual Basic (Declaration)
Public Property AbsoluteUser As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.AbsoluteUser = value

value = instance.AbsoluteUser
C#
public string AbsoluteUser {get; set;}
Managed Extensions for C++
public: __property string* get_AbsoluteUser();
public: __property void set_AbsoluteUser(
   string* value
);
C++/CLI
public:
property String^ AbsoluteUser {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
AcceptedSerialNumberSizes Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AcceptedSerialNumberSizes Property

Gets or sets the serial number sizes that can be used to unlock the license. If a valid serial number of a different size is used, license validation will fail.

Syntax

Visual Basic (Declaration)
Public Property AcceptedSerialNumberSizes As SerialNumberSizes
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As SerialNumberSizes

instance.AcceptedSerialNumberSizes = value

value = instance.AcceptedSerialNumberSizes
C#
public SerialNumberSizes AcceptedSerialNumberSizes {get; set;}
Managed Extensions for C++
public: __property SerialNumberSizes get_AcceptedSerialNumberSizes();
public: __property void set_AcceptedSerialNumberSizes(
   SerialNumberSizes value
);
C++/CLI
public:
property SerialNumberSizes AcceptedSerialNumberSizes {
   SerialNumberSizes get();
   void set (SerialNumberSizes value);
}

Remarks

It is recommended that you only allow the largest size you will reasonably expect to issue to your customers. A malicious user needs only to crack the smallest acceptable size to gain access to the license. The Recommended sizes are Medium (for regular serial numbers) and Huge (for activation keys).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
AssemblyName Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AssemblyName Property

Gets or sets the name of the assembly used to sign the license originally. The value of this property is for reference only and has no impact on the validation of a license.

Syntax

Visual Basic (Declaration)
Public Property AssemblyName As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.AssemblyName = value

value = instance.AssemblyName
C#
public string AssemblyName {get; set;}
Managed Extensions for C++
public: __property string* get_AssemblyName();
public: __property void set_AssemblyName(
   string* value
);
C++/CLI
public:
property String^ AssemblyName {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Components Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Components Property

Gets the collection of component names that the license applies to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As StringCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As StringCollection

value = instance.Components
C#
public StringCollection Components {get;}
Managed Extensions for C++
public: __property StringCollection get_Components();
C++/CLI
public:
property StringCollection Components {
   StringCollection get();
}

Remarks

Each component name in the collection should be the FullName of the Type including the namespace. When the license is read only then a copy of the collection is returned and any changes to the collection are lost.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ConnectionString Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ConnectionString Property

Gets the default database connection string for licensing components.

Syntax

Visual Basic (Declaration)
Public Shared Property ConnectionString As String
Visual Basic (Usage) Copy Code
Dim value As String

ExtendedLicense.ConnectionString = value

value = ExtendedLicense.ConnectionString
C#
public static string ConnectionString {get; set;}
Managed Extensions for C++
public: __property static string* get_ConnectionString();
public: __property static void set_ConnectionString(
   string* value
);
C++/CLI
public:
static property String^ ConnectionString {
   String^ get();
   void set (String^ value);
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.ConnectionString" value="server=localhost;catalog=Northwind" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="ConnectionString" value="server=localhost;catalog=Northwind" />
    </Licensing>
</Xheo>
</configuration>

Remarks

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.ConnectionString and set it to the path where keys are stored on your machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
EmulateVersion Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : EmulateVersion Property

Gets a value that determines the release version that XHEO|Licensing should emulate.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property EmulateVersion As Version
Visual Basic (Usage) Copy Code
Dim value As Version

value = ExtendedLicense.EmulateVersion
C#
public static Version EmulateVersion {get;}
Managed Extensions for C++
public: __property static Version* get_EmulateVersion();
C++/CLI
public:
static property Version^ EmulateVersion {
   Version^ get();
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.EmulateVersion" value="1.1" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="EmulateVersion" value="1.1" />
    </Licensing>
</Xheo>
</configuration>

Remarks

Use this value when migrating a solution from an earlier version to a newer one so that licenses generated with the new assembly will use the previous version until you have fully upgraded all dependent assemblies.

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.EmulateVersion and set it to either true or false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Expires Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Expires Property

Gets or sets the expiration date for the license.

Syntax

Visual Basic (Declaration)
Public Property Expires As Date
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Date

instance.Expires = value

value = instance.Expires
C#
public DateTime Expires {get; set;}
Managed Extensions for C++
public: __property DateTime get_Expires();
public: __property void set_Expires(
   DateTime value
);
C++/CLI
public:
property DateTime Expires {
   DateTime get();
   void set (DateTime value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IisIsAvailable Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IisIsAvailable Property

Gets a value that indicates if IIS is installed and available on the machine. If false then HttpContext should not be checked because it will throw an exception.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IisIsAvailable As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = ExtendedLicense.IisIsAvailable
C#
public static bool IisIsAvailable {get;}
Managed Extensions for C++
public: __property static bool get_IisIsAvailable();
C++/CLI
public:
static property bool IisIsAvailable {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
InvalidReason Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : InvalidReason Property

Gets or sets the reason the license was not valid. If Validate returns true this is an empty string.

Syntax

Visual Basic (Declaration)
Public Property InvalidReason As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.InvalidReason = value

value = instance.InvalidReason
C#
public string InvalidReason {get; set;}
Managed Extensions for C++
public: __property string* get_InvalidReason();
public: __property void set_InvalidReason(
   string* value
);
C++/CLI
public:
property String^ InvalidReason {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IsEmbedded Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsEmbedded Property

Gets or sets a value that indicates if the license was loaded from an embedded resource rather then an external .LIC file.

Syntax

Visual Basic (Declaration)
Public Property IsEmbedded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Boolean

instance.IsEmbedded = value

value = instance.IsEmbedded
C#
public bool IsEmbedded {get; set;}
Managed Extensions for C++
public: __property bool get_IsEmbedded();
public: __property void set_IsEmbedded(
   bool value
);
C++/CLI
public:
property bool IsEmbedded {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IsReadOnly Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsReadOnly Property

Gets a value that indicates if the current license is read only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IssuerUrl Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IssuerUrl Property

Gets or sets the URL to the company that issued the license.

Syntax

Visual Basic (Declaration)
Public Property IssuerUrl As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.IssuerUrl = value

value = instance.IssuerUrl
C#
public string IssuerUrl {get; set;}
Managed Extensions for C++
public: __property string* get_IssuerUrl();
public: __property void set_IssuerUrl(
   string* value
);
C++/CLI
public:
property String^ IssuerUrl {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IsTerminalServices Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsTerminalServices Property

Gets a value that indicates if the current session is running under terminal services.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IsTerminalServices As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = ExtendedLicense.IsTerminalServices
C#
public static bool IsTerminalServices {get;}
Managed Extensions for C++
public: __property static bool get_IsTerminalServices();
C++/CLI
public:
static property bool IsTerminalServices {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IsTimeSensitive Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsTimeSensitive Property

Gets a value that indicates if the license contians time sensitive data and the clock should be protected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsTimeSensitive As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Boolean

value = instance.IsTimeSensitive
C#
public bool IsTimeSensitive {get;}
Managed Extensions for C++
public: __property bool get_IsTimeSensitive();
C++/CLI
public:
property bool IsTimeSensitive {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IsWebRequest Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsWebRequest Property

Gets a value indicating if a web request/HttpContext is currently available.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IsWebRequest As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = ExtendedLicense.IsWebRequest
C#
public static bool IsWebRequest {get;}
Managed Extensions for C++
public: __property static bool get_IsWebRequest();
C++/CLI
public:
static property bool IsWebRequest {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
KeyFolder Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : KeyFolder Property

Gets the folder where the license keys are located as defined in the application's config file.

Syntax

Visual Basic (Declaration)
Public Shared Property KeyFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

ExtendedLicense.KeyFolder = value

value = ExtendedLicense.KeyFolder
C#
public static string KeyFolder {get; set;}
Managed Extensions for C++
public: __property static string* get_KeyFolder();
public: __property static void set_KeyFolder(
   string* value
);
C++/CLI
public:
static property String^ KeyFolder {
   String^ get();
   void set (String^ value);
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.KeyFolder" value="X:\Keys" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="KeyFolder" value="D:\aaa" />
    </Licensing>
</Xheo>
</configuration>

Remarks

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.KeyFolder and set it to the path where keys are stored on your machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LicensedType Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LicensedType Property

Gets the Type the license was/will be granted to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LicensedType As Type
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Type

value = instance.LicensedType
C#
public Type LicensedType {get;}
Managed Extensions for C++
public: __property Type* get_LicensedType();
C++/CLI
public:
property Type^ LicensedType {
   Type^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LicenseFolders Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LicenseFolders Property

Gets a collection of folders where the licenses are located as defined in the application's config file.

Syntax

Visual Basic (Declaration)
Public Shared Property LicenseFolders As String()
Visual Basic (Usage) Copy Code
Dim value() As String

ExtendedLicense.LicenseFolders = value

value = ExtendedLicense.LicenseFolders
C#
public static string[] LicenseFolders {get; set;}
Managed Extensions for C++
public: __property static string*[] get_LicenseFolders();
public: __property static void set_LicenseFolders(
   string*[] value
);
C++/CLI
public:
static property array<String^> LicenseFolders {
   array<String^> get();
   void set (String^array<value> value);
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.LicenseFolder" value="X:\Folder1" />
    <add key="Xheo.Licensing.LicenseFolder" value="X:\Folder2" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="Xheo.Licensing.Configuration.NameValueSectionHandler, System, Version=1.1.0.0, Culture=neutral, PublicKeyToken=798276055709c98a" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="LicenseFolder" value="D:\aaa" />
        <add key="LicenseFolder" value="C:\other" />
    </Licensing>
</Xheo>
</configuration>

Remarks

Use this setting when you install XHEO|Licensing or licensed components into the GAC, or when using a shared install in a hosting environment.

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.LicenseFolders and set it to the path where keys are stored on your machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LicenseKey Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LicenseKey Property

Overrides LicenseKey.

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable ReadOnly Property LicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

value = instance.LicenseKey
C#
public override string LicenseKey {get;}
Managed Extensions for C++
public: __property string* get_LicenseKey()override ;
C++/CLI
public:
property String^ LicenseKey override {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LicensePack Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LicensePack Property

Gets the ExtendedLicensePack that owns the license.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LicensePack As ExtendedLicensePack
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As ExtendedLicensePack

value = instance.LicensePack
C#
public ExtendedLicensePack LicensePack {get;}
Managed Extensions for C++
public: __property ExtendedLicensePack* get_LicensePack();
C++/CLI
public:
property ExtendedLicensePack^ LicensePack {
   ExtendedLicensePack^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MaximumSerialNumberSeed Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : MaximumSerialNumberSeed Property

Gets or sets the maximum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.

Syntax

Visual Basic (Declaration)
Public Property MaximumSerialNumberSeed As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Integer

instance.MaximumSerialNumberSeed = value

value = instance.MaximumSerialNumberSeed
C#
public int MaximumSerialNumberSeed {get; set;}
Managed Extensions for C++
public: __property int get_MaximumSerialNumberSeed();
public: __property void set_MaximumSerialNumberSeed(
   int value
);
C++/CLI
public:
property int MaximumSerialNumberSeed {
   int get();
   void set (int value);
}

Remarks

Use MinimumSerialNumberSeed and MaximumSerialNumberSeed to partition serial numbers to various resellers or vendors. You can then use this to determine which vendor sold your product in case of support requests.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MetaValues Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : MetaValues Property

Gets a collection of arbitrary values to store with the license. These values are not protected and may be changed without affecting the validity of the license. Use for storing volitle information and other unsecured information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetaValues As LicenseValuesCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As LicenseValuesCollection

value = instance.MetaValues
C#
public LicenseValuesCollection MetaValues {get;}
Managed Extensions for C++
public: __property LicenseValuesCollection* get_MetaValues();
C++/CLI
public:
property LicenseValuesCollection^ MetaValues {
   LicenseValuesCollection^ get();
}

Remarks

The MetaValues collection will be persisted with a license. However any changes to the meta values collection after the license is signed will not affect the validity of the signature. Use this to track volitle information that need not be secured and is safe for the user to change.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MinimumSerialNumberSeed Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : MinimumSerialNumberSeed Property

Gets or sets the minimum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.

Syntax

Visual Basic (Declaration)
Public Property MinimumSerialNumberSeed As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Integer

instance.MinimumSerialNumberSeed = value

value = instance.MinimumSerialNumberSeed
C#
public int MinimumSerialNumberSeed {get; set;}
Managed Extensions for C++
public: __property int get_MinimumSerialNumberSeed();
public: __property void set_MinimumSerialNumberSeed(
   int value
);
C++/CLI
public:
property int MinimumSerialNumberSeed {
   int get();
   void set (int value);
}

Remarks

Use MinimumSerialNumberSeed and MaximumSerialNumberSeed to partition serial numbers to various resellers or vendors. You can then use this to determine which vendor sold your product in case of support requests.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Organization Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Organization Property

Gets or sets the name of the organization that the license is issued to.

Syntax

Visual Basic (Declaration)
Public Property Organization As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.Organization = value

value = instance.Organization
C#
public string Organization {get; set;}
Managed Extensions for C++
public: __property string* get_Organization();
public: __property void set_Organization(
   string* value
);
C++/CLI
public:
property String^ Organization {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
PersistantState Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : PersistantState Property

Gets a reference to per-license specific state that works independent of any underlying state schemes. This is used to safely track values that should be kept in memory even when a license is reloaded from disk.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PersistantState As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Hashtable

value = instance.PersistantState
C#
public Hashtable PersistantState {get;}
Managed Extensions for C++
public: __property Hashtable* get_PersistantState();
C++/CLI
public:
property Hashtable^ PersistantState {
   Hashtable^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
PublicKey Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : PublicKey Property

Gets a reference to the LicenseSigningKey being used to validate the license.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PublicKey As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As LicenseSigningKey

value = instance.PublicKey
C#
public LicenseSigningKey PublicKey {get;}
Managed Extensions for C++
public: __property LicenseSigningKey* get_PublicKey();
C++/CLI
public:
property LicenseSigningKey^ PublicKey {
   LicenseSigningKey^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SerialNumber Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : SerialNumber Property

Gets or sets the value of the absolute serial number.

Syntax

Visual Basic (Declaration)
Public Property SerialNumber As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.SerialNumber = value

value = instance.SerialNumber
C#
public string SerialNumber {get; set;}
Managed Extensions for C++
public: __property string* get_SerialNumber();
public: __property void set_SerialNumber(
   string* value
);
C++/CLI
public:
property String^ SerialNumber {
   String^ get();
   void set (String^ value);
}

Remarks

The absolute serial number is used in unlocking a license by serial number. The absolute serial number must begin with the SerialNumber for the license.
Warning This value is unprotected and can be changed by the client. Do not assume the value is valid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SharedFolder Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : SharedFolder Property

Gets or sets the path to the shared license folder.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SharedFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

value = ExtendedLicense.SharedFolder
C#
public static string SharedFolder {get;}
Managed Extensions for C++
public: __property static string* get_SharedFolder();
C++/CLI
public:
static property String^ SharedFolder {
   String^ get();
}

Remarks

The shared license folder is a location on the client machine where all XHEO|Licensing protected applications can look for licenses. This helps with shared hosting environments and large applications that may include multiple assemblies, some in the GAC. Rather then having .LIC files spread over the machine they can be located into a single location.

This is a machine wide setting. The value of this property should be considered configured by the machine's administrator. You should not change it as it will effect all installed applications protected with XHEO|Licensing.

The folder location by default is [Common Files]\Xheo\SharedLicenses. This can be configured per machine or per user in the registry at HKLM or HKLU\Software\Xheo\Licensing\SharedLicenseFolder.

See LicenseFolders for settings you can apply to the application's config or machine.config file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
LicenseFolders Property


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Signature Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Signature Property

Gets or sets the signature used to validate the license data.

Syntax

Visual Basic (Declaration)
Public Property Signature As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.Signature = value

value = instance.Signature
C#
public string Signature {get; set;}
Managed Extensions for C++
public: __property string* get_Signature();
public: __property void set_Signature(
   string* value
);
C++/CLI
public:
property String^ Signature {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SurrogateLicensePack Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : SurrogateLicensePack Property

Gets or sets a surrogate license pack to use if validation of this license fails.

Syntax

Visual Basic (Declaration)
Public Property SurrogateLicensePack As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.SurrogateLicensePack = value

value = instance.SurrogateLicensePack
C#
public string SurrogateLicensePack {get; set;}
Managed Extensions for C++
public: __property string* get_SurrogateLicensePack();
public: __property void set_SurrogateLicensePack(
   string* value
);
C++/CLI
public:
property String^ SurrogateLicensePack {
   String^ get();
   void set (String^ value);
}

Remarks

For limits that alter the current license, or download new licenses you can set this property so that the new or altered license pack is used instead. When Validate is called on the current license, this is initially set to null. If Validate returns false, and this is not null then the license pack indicated in this property, if it contains a license, is used instead. If a surrogate license pack also defines a surrogate license, it will not be checked, the license provider only checks one level deep.

Generally you shouldn't set this to a license pack containing license with with a Trial limit or GUI limit because it will interfere with the optimal license selection of the license provider.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Tag Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Tag Property

Gets or sets an arbitrary piece of data to track with the license. This is a "cheap" way of extending the license scheme by allowing you to store any kind of additional data that can be saved as a string to the license.

Syntax

Visual Basic (Declaration)
Public Property Tag As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.Tag = value

value = instance.Tag
C#
public string Tag {get; set;}
Managed Extensions for C++
public: __property string* get_Tag();
public: __property void set_Tag(
   string* value
);
C++/CLI
public:
property String^ Tag {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
TemplateFolder Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : TemplateFolder Property

Gets the folder where the license templates are located as defined in the application's config file.

Syntax

Visual Basic (Declaration)
Public Shared Property TemplateFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

ExtendedLicense.TemplateFolder = value

value = ExtendedLicense.TemplateFolder
C#
public static string TemplateFolder {get; set;}
Managed Extensions for C++
public: __property static string* get_TemplateFolder();
public: __property static void set_TemplateFolder(
   string* value
);
C++/CLI
public:
static property String^ TemplateFolder {
   String^ get();
   void set (String^ value);
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.TemplateFolder" value="X:\Templates" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="TemplateFolder" value="D:\aaa\Templates" />
    </Licensing>
</Xheo>
</configuration>

Remarks

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.TemplateFolder and set it to the path where keys are stored on your machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Type Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Type Property

Gets or sets an application/product specific description of the type of license. For examples "designer", "single user", "non-profit", etc. This can often be used a reference to the primary key in a database, such as a SKU, for the product that the license represents.

Syntax

Visual Basic (Declaration)
Public Property Type As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.Type = value

value = instance.Type
C#
public string Type {get; set;}
Managed Extensions for C++
public: __property string* get_Type();
public: __property void set_Type(
   string* value
);
C++/CLI
public:
property String^ Type {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
UnlockBySerial Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : UnlockBySerial Property

Gets or sets a value that indicates if the user must provide a valid serial number to fully unlock the license.

Syntax

Visual Basic (Declaration)
Public Property UnlockBySerial As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Boolean

instance.UnlockBySerial = value

value = instance.UnlockBySerial
C#
public bool UnlockBySerial {get; set;}
Managed Extensions for C++
public: __property bool get_UnlockBySerial();
public: __property void set_UnlockBySerial(
   bool value
);
C++/CLI
public:
property bool UnlockBySerial {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
UnlockedLicense Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : UnlockedLicense Property

Gets or sets the ExtendedLicense that was unlocked by the registration process.

Syntax

Visual Basic (Declaration)
Public Property UnlockedLicense As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As ExtendedLicense

instance.UnlockedLicense = value

value = instance.UnlockedLicense
C#
public ExtendedLicense UnlockedLicense {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_UnlockedLicense();
public: __property void set_UnlockedLicense(
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ UnlockedLicense {
   ExtendedLicense^ get();
   void set (ExtendedLicense^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
User Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : User Property

Gets or sets the value of the user as it should appear on screen.

Syntax

Visual Basic (Declaration)
Public Property User As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.User = value

value = instance.User
C#
public string User {get; set;}
Managed Extensions for C++
public: __property string* get_User();
public: __property void set_User(
   string* value
);
C++/CLI
public:
property String^ User {
   String^ get();
   void set (String^ value);
}

Remarks

Warning This value is unprotected and can be changed by the client. Do not assume the value is valid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Values Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Values Property

Gets a collection of arbitrary values to store with the license.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As LicenseValuesCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As LicenseValuesCollection

value = instance.Values
C#
public LicenseValuesCollection Values {get;}
Managed Extensions for C++
public: __property LicenseValuesCollection* get_Values();
C++/CLI
public:
property LicenseValuesCollection^ Values {
   LicenseValuesCollection^ get();
}

Remarks

You can use this to store values for runtime adjustments such as maximum values, names, etc. The values are also signed so adjustments to the values after the license has been signed will invalidate the license. Non primitive values must be marked as Serializable.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Version Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Version Property

Gets or sets the version of the licensing scheme used.

Syntax

Visual Basic (Declaration)
Public Property Version As Version
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Version

instance.Version = value

value = instance.Version
C#
public Version Version {get; set;}
Managed Extensions for C++
public: __property Version* get_Version();
public: __property void set_Version(
   Version* value
);
C++/CLI
public:
property Version^ Version {
   Version^ get();
   void set (Version^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
XmlString Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : XmlString Property

Gets or sets the contents of the license as an XML string fragment.

Syntax

Visual Basic (Declaration)
Public Property XmlString As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.XmlString = value

value = instance.XmlString
C#
public string XmlString {get; set;}
Managed Extensions for C++
public: __property string* get_XmlString();
public: __property void set_XmlString(
   string* value
);
C++/CLI
public:
property String^ XmlString {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.Windows Send comments on this topic.
ExtendedLicense Class Fields
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

For a list of all members of this type, see ExtendedLicense members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ConfigSection | The configuration section where XHEO|Licensing settings are stored in the application's configuration file.
static (Shared in Visual Basic) | CurrentVersion | The current license scheme file version.
Top

See Also

Reference

ExtendedLicense Class
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ConfigSection Field
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ConfigSection Field

The configuration section where XHEO|Licensing settings are stored in the application's configuration file.

Syntax

Visual Basic (Declaration)
Public Shared ConfigSection As String
Visual Basic (Usage) Copy Code
Dim value As String

value = ExtendedLicense.ConfigSection

ExtendedLicense.ConfigSection = value
C#
public static string ConfigSection
Managed Extensions for C++
public: static string* ConfigSection
C++/CLI
public:
static String^ ConfigSection

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.TemplateFolder" value="X:\Keys" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="TemplateFolder" value="D:\aaa" />
    </Licensing>
</Xheo>
</configuration>

Remarks

All of XHEO|Licensing's configuration settings can be set from the application or machine's configuration file. You can use the shared <appSettings> section or the custom section to set settings.

Most configuration options can be set in the configuration file via code by setting the public static property to the desired value. For example to save the location of the KeyFolder simply set KeyFolder to the desired value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
CurrentVersion Field
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : CurrentVersion Field

The current license scheme file version.

Syntax

Visual Basic (Declaration)
Public Shared CurrentVersion As Version
Visual Basic (Usage) Copy Code
Dim value As Version

value = ExtendedLicense.CurrentVersion

ExtendedLicense.CurrentVersion = value
C#
public static Version CurrentVersion
Managed Extensions for C++
public: static Version* CurrentVersion
C++/CLI
public:
static Version^ CurrentVersion

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ExtendedLicenseException Class
See Also Members
[image]
Xheo.Licensing Namespace : ExtendedLicenseException Class

Represents an exception in a Xheo assembly with a localized FriendlyMessage and DetailedMessage.

Syntax

Visual Basic (Declaration)
Private Class ExtendedLicenseException
   Inherits ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException
C#
private class ExtendedLicenseException : ApplicationException
Managed Extensions for C++
private __gc class ExtendedLicenseException : public ApplicationException
C++/CLI
private ref class ExtendedLicenseException : public ApplicationException

Remarks

The Message is used to communicate a simple description of what went wrong and should be written to the non-developer audience. The DetailedMessage should be used to communicate additional technical details and how the problem might be fixed.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Xheo.Licensing.ExtendedLicenseException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
ExtendedLicenseException Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : ExtendedLicenseException Class

The following tables list the members exposed by ExtendedLicenseException.

Public Constructors

 | Name | Description
Public Constructor | ExtendedLicenseException Constructor | Overloaded. Initializes a new instance of the ExtendedLicenseException class.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | DetailedMessage | Gets or sets the detailed message.
Public Property | FriendlyMessage | Gets or sets the friendly message.
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Overridden. Gets a description of the exception.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ExtendedLicenseException Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ExtendedLicenseException Constructor
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class : ExtendedLicenseException Constructor

Initializes a new instance of the ExtendedLicenseException class.

Overload List

Overload | Description
ExtendedLicenseException Constructor() | Initializes a new instance of the ExtendedLicenseException class.
ExtendedLicenseException Constructor(String) | Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.
ExtendedLicenseException Constructor(String,Exception) | Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.
ExtendedLicenseException Constructor(String,Exception,Object[]) | Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.
ExtendedLicenseException Constructor(String,Object[]) | Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ExtendedLicenseException Constructor()
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor()

Initializes a new instance of the ExtendedLicenseException class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException()
C#
public ExtendedLicenseException()
Managed Extensions for C++
public: ExtendedLicenseException();
C++/CLI
public:
ExtendedLicenseException();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ExtendedLicenseException Constructor(String)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor(String)

resourceName
The name of the resource to use for the message.
Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceName As String _
)
Visual Basic (Usage) Copy Code
Dim resourceName As String

Dim instance As ExtendedLicenseException(resourceName)
C#
public ExtendedLicenseException(
   string resourceName
)
Managed Extensions for C++
public: ExtendedLicenseException(
   string* resourceName
)
C++/CLI
public:
ExtendedLicenseException(
   String^ resourceName
)

Parameters

resourceName
The name of the resource to use for the message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ExtendedLicenseException Constructor(String,Exception)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor(String,Exception)

resourceName
The name of the resource to use for the message.
innerException
A reference to any inner exception.
Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceName As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim resourceName As String
Dim innerException As Exception

Dim instance As ExtendedLicenseException(resourceName, innerException)
C#
public ExtendedLicenseException(
   string resourceName,
   Exception innerException
)
Managed Extensions for C++
public: ExtendedLicenseException(
   string* resourceName,
   Exception* innerException
)
C++/CLI
public:
ExtendedLicenseException(
   String^ resourceName,
   Exception^ innerException
)

Parameters

resourceName
The name of the resource to use for the message.
innerException
A reference to any inner exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ExtendedLicenseException Constructor(String,Exception,Object[])
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor(String,Exception,Object[])

resourceName
The name of the resource to use for the message.
innerException
A reference to any inner exception.
args
Variable list of arguments to pass to String.Format.
Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceName As String, _
   ByVal innerException As Exception, _
   ByVal ParamArray args() As Object _
)
Visual Basic (Usage) Copy Code
Dim resourceName As String
Dim innerException As Exception
Dim args() As Object

Dim instance As ExtendedLicenseException(resourceName, innerException, args)
C#
public ExtendedLicenseException(
   string resourceName,
   Exception innerException,
   params object[] args
)
Managed Extensions for C++
public: ExtendedLicenseException(
   string* resourceName,
   Exception* innerException,
   params Object*[] args
)
C++/CLI
public:
ExtendedLicenseException(
   String^ resourceName,
   Exception^ innerException,
   ... array<Object^> args
)

Parameters

resourceName
The name of the resource to use for the message.
innerException
A reference to any inner exception.
args
Variable list of arguments to pass to String.Format.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ExtendedLicenseException Constructor(String,Object[])
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor(String,Object[])

resourceName
The name of the resource to use for the message.
args
Variable list of arguments to pass to String.Format.
Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceName As String, _
   ByVal ParamArray args() As Object _
)
Visual Basic (Usage) Copy Code
Dim resourceName As String
Dim args() As Object

Dim instance As ExtendedLicenseException(resourceName, args)
C#
public ExtendedLicenseException(
   string resourceName,
   params object[] args
)
Managed Extensions for C++
public: ExtendedLicenseException(
   string* resourceName,
   params Object*[] args
)
C++/CLI
public:
ExtendedLicenseException(
   String^ resourceName,
   ... array<Object^> args
)

Parameters

resourceName
The name of the resource to use for the message.
args
Variable list of arguments to pass to String.Format.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET.Windows Send comments on this topic.
ExtendedLicenseException Class Properties
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicenseException Class

For a list of all members of this type, see ExtendedLicenseException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | DetailedMessage | Gets or sets the detailed message.
Public Property | FriendlyMessage | Gets or sets the friendly message.
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Overridden. Gets a description of the exception.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ExtendedLicenseException Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
DetailedMessage Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class : DetailedMessage Property

Gets or sets the detailed message.

Syntax

Visual Basic (Declaration)
Public Property DetailedMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException
Dim value As String

instance.DetailedMessage = value

value = instance.DetailedMessage
C#
public string DetailedMessage {get; set;}
Managed Extensions for C++
public: __property string* get_DetailedMessage();
public: __property void set_DetailedMessage(
   string* value
);
C++/CLI
public:
property String^ DetailedMessage {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
FriendlyMessage Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class : FriendlyMessage Property

Gets or sets the friendly message.

Syntax

Visual Basic (Declaration)
Public Property FriendlyMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException
Dim value As String

instance.FriendlyMessage = value

value = instance.FriendlyMessage
C#
public string FriendlyMessage {get; set;}
Managed Extensions for C++
public: __property string* get_FriendlyMessage();
public: __property void set_FriendlyMessage(
   string* value
);
C++/CLI
public:
property String^ FriendlyMessage {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Message Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class : Message Property

Gets a description of the exception.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property Message As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException
Dim value As String

value = instance.Message
C#
public override string Message {get;}
Managed Extensions for C++
public: __property string* get_Message()override ;
C++/CLI
public:
property String^ Message override {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ExtendedLicensePack Class
See Also Members
[image]
Xheo.Licensing Namespace : ExtendedLicensePack Class

Represents a collection of licenses stored in a single .LIC file.

Object Model

Syntax

Visual Basic (Declaration)
Private Class ExtendedLicensePack
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
C#
private class ExtendedLicensePack : CollectionBase
Managed Extensions for C++
private __gc class ExtendedLicensePack : public CollectionBase
C++/CLI
private ref class ExtendedLicensePack : public CollectionBase

Remarks

Each license pack can serialize to and from an XML license file. Each license within the pack is signed, but the pack itself is not. Licenses can be added or removed without affecting the validity of the pack.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Xheo.Licensing.ExtendedLicensePack

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
ExtendedLicensePack Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : ExtendedLicensePack Class

The following tables list the members exposed by ExtendedLicensePack.

Public Constructors

 | Name | Description
Public Constructor | ExtendedLicensePack Constructor | Overloaded. Initializes a new instance of the ExtendedLicensePack class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsEmbedded | Gets a value that indicates if the pack was loaded directly from an assembly.
Public Property | Item | Overloaded. Gets or sets the ExtendedLicense at the given index.
Public Property | Location | Gets the path to the file where the license pack was originally loaded from. If not loaded from a file, returns null.
Public Property | MetaValues | Gets a collection of arbitrary values to store with the license pack. These values are not protected and may be changed without affecting the validity of the contained licenses. Use for storing volitle information and other unsecured information.
Public Property | SaveToShared | Gets or sets a value that indicates if changes to the license pack when validating should be saved to the shared licenses folder.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the given ExtendedLicense to the collection.
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Clones the license pack in memory.
Public Method | Contains | Determines if the pack contains the given license.
Public Method | CopyTo | Copies the collection of ExtendedLicense objects into the array at the given index.
Public Method | Dispose | Disposes of any managed/unmanged resources.
Public Method | FromXmlString | Loads the contents of the xml string into the license pack.
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetLicensesForComponent | Gets a subset of the current license pack filtered by the given component.
Public Method | IndexOf | Overloaded. Gets the index of the ExtendedLicense with the given serial number.
Public Method | Insert | Inserts the license at the given index.
Public Method | Load | Overloaded. Loads the contents of the license pack from a file.
Public Method | Remove | Overloaded. Removes the given ExtendedLicense from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Save | Overloaded. Saves the contents of the license pack to a stream.
Public Method | ToFormattedXmlString | Gets the contents of the license pack as an friendly XML string.
Public Method | ToXmlString | Gets the contents of the license pack as an XML string.
Public Method | WriteToResponse | Overloaded. Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.
Top

See Also

Reference

ExtendedLicensePack Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ExtendedLicensePack Constructor
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : ExtendedLicensePack Constructor

Initializes a new instance of the ExtendedLicensePack class.

Overload List

Overload | Description
ExtendedLicensePack Constructor() | Initializes a new instance of the ExtendedLicensePack class.
ExtendedLicensePack Constructor(String) | Initializes a new instance of the ExtendedLicensePack class from the given file.
ExtendedLicensePack Constructor(String,Boolean) | Initializes a new instance of the ExtendedLicensePack class from the given file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ExtendedLicensePack Constructor()
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > ExtendedLicensePack Constructor : ExtendedLicensePack Constructor()

Initializes a new instance of the ExtendedLicensePack class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack()
C#
public ExtendedLicensePack()
Managed Extensions for C++
public: ExtendedLicensePack();
C++/CLI
public:
ExtendedLicensePack();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ExtendedLicensePack Constructor(String)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > ExtendedLicensePack Constructor : ExtendedLicensePack Constructor(String)

filename
Path to the file that contains the license pack.
Initializes a new instance of the ExtendedLicensePack class from the given file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim filename As String

Dim instance As ExtendedLicensePack(filename)
C#
public ExtendedLicensePack(
   string filename
)
Managed Extensions for C++
public: ExtendedLicensePack(
   string* filename
)
C++/CLI
public:
ExtendedLicensePack(
   String^ filename
)

Parameters

filename
Path to the file that contains the license pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ExtendedLicensePack Constructor(String,Boolean)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > ExtendedLicensePack Constructor : ExtendedLicensePack Constructor(String,Boolean)

filename
Path to the file that contains the license pack.
tryIsolatedStorage
When true attempts to load a mirrored version of the license from Isolated Storage first.
Initializes a new instance of the ExtendedLicensePack class from the given file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String, _
   ByVal tryIsolatedStorage As Boolean _
)
Visual Basic (Usage) Copy Code
Dim filename As String
Dim tryIsolatedStorage As Boolean

Dim instance As ExtendedLicensePack(filename, tryIsolatedStorage)
C#
public ExtendedLicensePack(
   string filename,
   bool tryIsolatedStorage
)
Managed Extensions for C++
public: ExtendedLicensePack(
   string* filename,
   bool tryIsolatedStorage
)
C++/CLI
public:
ExtendedLicensePack(
   String^ filename,
   bool tryIsolatedStorage
)

Parameters

filename
Path to the file that contains the license pack.
tryIsolatedStorage
When true attempts to load a mirrored version of the license from Isolated Storage first.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
ExtendedLicensePack Class Methods
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicensePack Class

For a list of all members of this type, see ExtendedLicensePack members.

Public Methods

 | Name | Description
Public Method | Add | Adds the given ExtendedLicense to the collection.
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Clones the license pack in memory.
Public Method | Contains | Determines if the pack contains the given license.
Public Method | CopyTo | Copies the collection of ExtendedLicense objects into the array at the given index.
Public Method | Dispose | Disposes of any managed/unmanged resources.
Public Method | FromXmlString | Loads the contents of the xml string into the license pack.
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetLicensesForComponent | Gets a subset of the current license pack filtered by the given component.
Public Method | IndexOf | Overloaded. Gets the index of the ExtendedLicense with the given serial number.
Public Method | Insert | Inserts the license at the given index.
Public Method | Load | Overloaded. Loads the contents of the license pack from a file.
Public Method | Remove | Overloaded. Removes the given ExtendedLicense from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Save | Overloaded. Saves the contents of the license pack to a stream.
Public Method | ToFormattedXmlString | Gets the contents of the license pack as an friendly XML string.
Public Method | ToXmlString | Gets the contents of the license pack as an XML string.
Public Method | WriteToResponse | Overloaded. Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.
Top

See Also

Reference

ExtendedLicensePack Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Add Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Add Method

license
The ExtendedLicense to add.
Adds the given ExtendedLicense to the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim license As ExtendedLicense

instance.Add(license)
C#
public void Add(
   ExtendedLicense license
)
Managed Extensions for C++
public: void Add(
   ExtendedLicense* license
)
C++/CLI
public:
void Add(
   ExtendedLicense^ license
)

Parameters

license
The ExtendedLicense to add.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Clone Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Clone Method

Clones the license pack in memory.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As Object

value = instance.Clone()
C#
public object Clone()
Managed Extensions for C++
public: Object* Clone();
C++/CLI
public:
Object^ Clone();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Contains Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Contains Method

license
The license to look for.
Determines if the pack contains the given license.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal license As ExtendedLicense _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim license As ExtendedLicense
Dim value As Boolean

value = instance.Contains(license)
C#
public bool Contains(
   ExtendedLicense license
)
Managed Extensions for C++
public: bool Contains(
   ExtendedLicense* license
)
C++/CLI
public:
bool Contains(
   ExtendedLicense^ license
)

Parameters

license
The license to look for.

Return Value

Returns true if the license is found, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
CopyTo Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : CopyTo Method

array
The array to copy to.
index
The index in the array to start copying.
Copies the collection of ExtendedLicense objects into the array at the given index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ExtendedLicense, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim array() As ExtendedLicense
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ExtendedLicense[] array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   ExtendedLicense*[] array,
   int index
)
C++/CLI
public:
void CopyTo(
   array<ExtendedLicense^> array,
   int index
)

Parameters

array
The array to copy to.
index
The index in the array to start copying.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Dispose Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Dispose Method

Disposes of any managed/unmanged resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : FromXmlString Method

xml
A string containing the XML for the license pack.
Loads the contents of the xml string into the license pack.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
A string containing the XML for the license pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetLicensesForComponent Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : GetLicensesForComponent Method

component
Name of the component to get licenses for.
Gets a subset of the current license pack filtered by the given component.

Syntax

Visual Basic (Declaration)
Public Function GetLicensesForComponent( _
   ByVal component As String _
) As ICollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim component As String
Dim value As ICollection

value = instance.GetLicensesForComponent(component)
C#
public ICollection GetLicensesForComponent(
   string component
)
Managed Extensions for C++
public: ICollection* GetLicensesForComponent(
   string* component
)
C++/CLI
public:
ICollection^ GetLicensesForComponent(
   String^ component
)

Parameters

component
Name of the component to get licenses for.

Return Value

Returns a new collection with the requested licenses.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IndexOf Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : IndexOf Method

Gets the index of the ExtendedLicense with the given serial number.

Overload List

Overload | Description
IndexOf(String) | Gets the index of the ExtendedLicense with the given serial number.
IndexOf(ExtendedLicense) | Gets the index of the license in the pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IndexOf(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > IndexOf Method : IndexOf(String) Method

serialNumber
The serial number to look for.
Gets the index of the ExtendedLicense with the given serial number.

Syntax

Visual Basic (Declaration)
Overloads Public Function IndexOf( _
   ByVal serialNumber As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim serialNumber As String
Dim value As Integer

value = instance.IndexOf(serialNumber)
C#
public int IndexOf(
   string serialNumber
)
Managed Extensions for C++
public: int IndexOf(
   string* serialNumber
)
C++/CLI
public:
int IndexOf(
   String^ serialNumber
)

Parameters

serialNumber
The serial number to look for.

Return Value

Returns the index of the license if found, otherwise -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IndexOf(ExtendedLicense) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > IndexOf Method : IndexOf(ExtendedLicense) Method

license
The license to look for.
Gets the index of the license in the pack.

Syntax

Visual Basic (Declaration)
Overloads Public Function IndexOf( _
   ByVal license As ExtendedLicense _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim license As ExtendedLicense
Dim value As Integer

value = instance.IndexOf(license)
C#
public int IndexOf(
   ExtendedLicense license
)
Managed Extensions for C++
public: int IndexOf(
   ExtendedLicense* license
)
C++/CLI
public:
int IndexOf(
   ExtendedLicense^ license
)

Parameters

license
The license to look for.

Return Value

Returns the index of the license if found, otherwise -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Insert Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Insert Method

index
The index in the collection to insert the license.
license
The license to be inserted.
Inserts the license at the given index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim index As Integer
Dim license As ExtendedLicense

instance.Insert(index, license)
C#
public void Insert(
   int index,
   ExtendedLicense license
)
Managed Extensions for C++
public: void Insert(
   int index,
   ExtendedLicense* license
)
C++/CLI
public:
void Insert(
   int index,
   ExtendedLicense^ license
)

Parameters

index
The index in the collection to insert the license.
license
The license to be inserted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Load Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Load Method

Loads the contents of the license pack from a file.

Overload List

Overload | Description
Load(String,Boolean) | Loads the contents of the license pack from a file.
Load(String) | Loads the contents of the license pack from a file.
Load(Stream) | Loads the contents of the license pack from a file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Load(String,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Load Method : Load(String,Boolean) Method

filename
Path to the file where the licenses were saved.
tryIsolatedStorage
When true attempts to load a mirrored version of the license from Isolated Storage first.
Loads the contents of the license pack from a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal filename As String, _
   ByVal tryIsolatedStorage As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String
Dim tryIsolatedStorage As Boolean

instance.Load(filename, tryIsolatedStorage)
C#
public void Load(
   string filename,
   bool tryIsolatedStorage
)
Managed Extensions for C++
public: void Load(
   string* filename,
   bool tryIsolatedStorage
)
C++/CLI
public:
void Load(
   String^ filename,
   bool tryIsolatedStorage
)

Parameters

filename
Path to the file where the licenses were saved.
tryIsolatedStorage
When true attempts to load a mirrored version of the license from Isolated Storage first.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Load(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Load Method : Load(String) Method

filename
Path to the file where the licenses were saved.
Loads the contents of the license pack from a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String

instance.Load(filename)
C#
public void Load(
   string filename
)
Managed Extensions for C++
public: void Load(
   string* filename
)
C++/CLI
public:
void Load(
   String^ filename
)

Parameters

filename
Path to the file where the licenses were saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Load(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Load Method : Load(Stream) Method

stream
The stream to load from.
Loads the contents of the license pack from a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim stream As Stream

instance.Load(stream)
C#
public void Load(
   Stream stream
)
Managed Extensions for C++
public: void Load(
   Stream* stream
)
C++/CLI
public:
void Load(
   Stream^ stream
)

Parameters

stream
The stream to load from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Remove Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Remove Method

Removes the given ExtendedLicense from the collection.

Overload List

Overload | Description
Remove(ExtendedLicense) | Removes the given ExtendedLicense from the collection.
Remove(String) | Removes the license with the given serial number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Remove(ExtendedLicense) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Remove Method : Remove(ExtendedLicense) Method

license
The ExtendedLicense to remove.
Removes the given ExtendedLicense from the collection.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim license As ExtendedLicense

instance.Remove(license)
C#
public void Remove(
   ExtendedLicense license
)
Managed Extensions for C++
public: void Remove(
   ExtendedLicense* license
)
C++/CLI
public:
void Remove(
   ExtendedLicense^ license
)

Parameters

license
The ExtendedLicense to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Remove(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Remove Method : Remove(String) Method

serialNumber
The serial numbef of the license to remove.
Removes the license with the given serial number.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal serialNumber As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim serialNumber As String

instance.Remove(serialNumber)
C#
public void Remove(
   string serialNumber
)
Managed Extensions for C++
public: void Remove(
   string* serialNumber
)
C++/CLI
public:
void Remove(
   String^ serialNumber
)

Parameters

serialNumber
The serial numbef of the license to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Save Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Save Method

Saves the contents of the license pack to a stream.

Overload List

Overload | Description
Save(Stream) | Saves the contents of the license pack to a stream.
Save(String) | Saves the contents of the license pack to a file.
Save() | Saves the contents of the license pack to the file that it was originally loaded from.
Save(String,Boolean) | Saves the contents of the license pack to a file.
Save(Boolean) | Saves the contents of the license pack to the file that it was originally loaded from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Save(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save(Stream) Method

stream
The Stream to write the contents of the license pack to.
Saves the contents of the license pack to a stream.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim stream As Stream

instance.Save(stream)
C#
public void Save(
   Stream stream
)
Managed Extensions for C++
public: void Save(
   Stream* stream
)
C++/CLI
public:
void Save(
   Stream^ stream
)

Parameters

stream
The Stream to write the contents of the license pack to.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Save(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save(String) Method

filename
Path to the file where the licenses should be saved.
Saves the contents of the license pack to a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String

instance.Save(filename)
C#
public void Save(
   string filename
)
Managed Extensions for C++
public: void Save(
   string* filename
)
C++/CLI
public:
void Save(
   String^ filename
)

Parameters

filename
Path to the file where the licenses should be saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Save() Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save() Method

Saves the contents of the license pack to the file that it was originally loaded from.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack

instance.Save()
C#
public void Save()
Managed Extensions for C++
public: void Save();
C++/CLI
public:
void Save();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Save(String,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save(String,Boolean) Method

filename
Path to the file where the licenses should be saved.
useIsolatedOnFail
If the save fails because of a permission exception, attempt to save to the isolated storage location instead.
Saves the contents of the license pack to a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal filename As String, _
   ByVal useIsolatedOnFail As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String
Dim useIsolatedOnFail As Boolean

instance.Save(filename, useIsolatedOnFail)
C#
public void Save(
   string filename,
   bool useIsolatedOnFail
)
Managed Extensions for C++
public: void Save(
   string* filename,
   bool useIsolatedOnFail
)
C++/CLI
public:
void Save(
   String^ filename,
   bool useIsolatedOnFail
)

Parameters

filename
Path to the file where the licenses should be saved.
useIsolatedOnFail
If the save fails because of a permission exception, attempt to save to the isolated storage location instead.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Save(Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save(Boolean) Method

useIsolatedOnFail
If the save fails because of a permission exception, attempt to save to the isolated storage location instead.
Saves the contents of the license pack to the file that it was originally loaded from.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal useIsolatedOnFail As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim useIsolatedOnFail As Boolean

instance.Save(useIsolatedOnFail)
C#
public void Save(
   bool useIsolatedOnFail
)
Managed Extensions for C++
public: void Save(
   bool useIsolatedOnFail
)
C++/CLI
public:
void Save(
   bool useIsolatedOnFail
)

Parameters

useIsolatedOnFail
If the save fails because of a permission exception, attempt to save to the isolated storage location instead.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ToFormattedXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : ToFormattedXmlString Method

Gets the contents of the license pack as an friendly XML string.

Syntax

Visual Basic (Declaration)
Public Function ToFormattedXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As String

value = instance.ToFormattedXmlString()
C#
public string ToFormattedXmlString()
Managed Extensions for C++
public: string* ToFormattedXmlString();
C++/CLI
public:
String^ ToFormattedXmlString();

Return Value

An XML string representation of the license pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : ToXmlString Method

Gets the contents of the license pack as an XML string.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As String

value = instance.ToXmlString()
C#
public string ToXmlString()
Managed Extensions for C++
public: string* ToXmlString();
C++/CLI
public:
String^ ToXmlString();

Return Value

An XML string representation of the license pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
WriteToResponse Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : WriteToResponse Method

Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.

Overload List

Overload | Description
WriteToResponse(String,Boolean) | Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.
WriteToResponse(String) | Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.
WriteToResponse() | Writes the license pack to the response stream for download.

Remarks

Use this method to provide license downloads on your website. You should be careful to not write any additional content to the response stream, or call Response.End() after this method.

NOTE: The response must be buffered for this method to work. In general buffering is on by default in ASP.NET applications.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
WriteToResponse(String,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > WriteToResponse Method : WriteToResponse(String,Boolean) Method

filename
Suggested file name.
direct
Indicates that the file should be written directly to the response and not saved as a new file. When false the user is prompted to open or save the file on their computer.
Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.

Syntax

Visual Basic (Declaration)
Overloads Public Sub WriteToResponse( _
   ByVal filename As String, _
   ByVal direct As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String
Dim direct As Boolean

instance.WriteToResponse(filename, direct)
C#
public void WriteToResponse(
   string filename,
   bool direct
)
Managed Extensions for C++
public: void WriteToResponse(
   string* filename,
   bool direct
)
C++/CLI
public:
void WriteToResponse(
   String^ filename,
   bool direct
)

Parameters

filename
Suggested file name.
direct
Indicates that the file should be written directly to the response and not saved as a new file. When false the user is prompted to open or save the file on their computer.

Remarks

Use this method to provide license downloads on your website. You should be careful to not write any additional content to the response stream, or call Response.End() after this method.

NOTE: The response must be buffered for this method to work. In general buffering is on by default in ASP.NET applications.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
WriteToResponse(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > WriteToResponse Method : WriteToResponse(String) Method

filename
Suggested file name.
Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.

Syntax

Visual Basic (Declaration)
Overloads Public Sub WriteToResponse( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String

instance.WriteToResponse(filename)
C#
public void WriteToResponse(
   string filename
)
Managed Extensions for C++
public: void WriteToResponse(
   string* filename
)
C++/CLI
public:
void WriteToResponse(
   String^ filename
)

Parameters

filename
Suggested file name.

Remarks

Use this method to provide license downloads on your website. You should be careful to not write any additional content to the response stream, or call Response.End() after this method.

NOTE: The response must be buffered for this method to work. In general buffering is on by default in ASP.NET applications.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
WriteToResponse() Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > WriteToResponse Method : WriteToResponse() Method

Writes the license pack to the response stream for download.

Syntax

Visual Basic (Declaration)
Overloads Public Sub WriteToResponse()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack

instance.WriteToResponse()
C#
public void WriteToResponse()
Managed Extensions for C++
public: void WriteToResponse();
C++/CLI
public:
void WriteToResponse();

Remarks

Use this method to provide license downloads on your website.

NOTE: The response must be buffered for this method to work. In general buffering is on by default in ASP.NET applications.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET.Windows Send comments on this topic.
ExtendedLicensePack Class Properties
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicensePack Class

For a list of all members of this type, see ExtendedLicensePack members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsEmbedded | Gets a value that indicates if the pack was loaded directly from an assembly.
Public Property | Item | Overloaded. Gets or sets the ExtendedLicense at the given index.
Public Property | Location | Gets the path to the file where the license pack was originally loaded from. If not loaded from a file, returns null.
Public Property | MetaValues | Gets a collection of arbitrary values to store with the license pack. These values are not protected and may be changed without affecting the validity of the contained licenses. Use for storing volitle information and other unsecured information.
Public Property | SaveToShared | Gets or sets a value that indicates if changes to the license pack when validating should be saved to the shared licenses folder.
Top

See Also

Reference

ExtendedLicensePack Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IsEmbedded Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : IsEmbedded Property

Gets a value that indicates if the pack was loaded directly from an assembly.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmbedded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As Boolean

value = instance.IsEmbedded
C#
public bool IsEmbedded {get;}
Managed Extensions for C++
public: __property bool get_IsEmbedded();
C++/CLI
public:
property bool IsEmbedded {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Item Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Item Property

Gets or sets the ExtendedLicense at the given index.

Overload List

Overload | Description
Item(Int32) | Gets or sets the ExtendedLicense at the given index.
Item(String) | Gets or sets the ExtendedLicense with the given serial number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Item(Int32) Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Item Property : Item(Int32) Property

index
Gets or sets the ExtendedLicense at the given index.

Syntax

Visual Basic (Declaration)
Overloads Public Property Item( _
   ByVal index As Integer _
) As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim index As Integer
Dim value As ExtendedLicense

instance.Item(index) = value

value = instance.Item(index)
C#
public ExtendedLicense Item(
   int index
) {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ Item {
   ExtendedLicense^ get(int index);
   void set (int index, ExtendedLicense^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Item(String) Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Item Property : Item(String) Property

serialNumber
Gets or sets the ExtendedLicense with the given serial number.

Syntax

Visual Basic (Declaration)
Overloads Public Property Item( _
   ByVal serialNumber As String _
) As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim serialNumber As String
Dim value As ExtendedLicense

instance.Item(serialNumber) = value

value = instance.Item(serialNumber)
C#
public ExtendedLicense Item(
   string serialNumber
) {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_Item(
   string* serialNumber
);
public: __property void set_Item(
   string* serialNumber,
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ Item {
   ExtendedLicense^ get(String^ serialNumber);
   void set (String^ serialNumber, ExtendedLicense^ value);
}

Parameters

serialNumber

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Location Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Location Property

Gets the path to the file where the license pack was originally loaded from. If not loaded from a file, returns null.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As String

value = instance.Location
C#
public string Location {get;}
Managed Extensions for C++
public: __property string* get_Location();
C++/CLI
public:
property String^ Location {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MetaValues Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : MetaValues Property

Gets a collection of arbitrary values to store with the license pack. These values are not protected and may be changed without affecting the validity of the contained licenses. Use for storing volitle information and other unsecured information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetaValues As LicenseValuesCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As LicenseValuesCollection

value = instance.MetaValues
C#
public LicenseValuesCollection MetaValues {get;}
Managed Extensions for C++
public: __property LicenseValuesCollection* get_MetaValues();
C++/CLI
public:
property LicenseValuesCollection^ MetaValues {
   LicenseValuesCollection^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SaveToShared Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : SaveToShared Property

Gets or sets a value that indicates if changes to the license pack when validating should be saved to the shared licenses folder.

Syntax

Visual Basic (Declaration)
Public Property SaveToShared As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As Boolean

instance.SaveToShared = value

value = instance.SaveToShared
C#
public bool SaveToShared {get; set;}
Managed Extensions for C++
public: __property bool get_SaveToShared();
public: __property void set_SaveToShared(
   bool value
);
C++/CLI
public:
property bool SaveToShared {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LicenseSigningKey Class
See Also Members
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

Implements a key pair for signing licenses.

Syntax

Visual Basic (Declaration)
Private NotInheritable Class LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
C#
private sealed class LicenseSigningKey
Managed Extensions for C++
private __gc __sealed class LicenseSigningKey
C++/CLI
private ref class LicenseSigningKey sealed

Remarks

See ExtendedLicense for details on how this class works with others in the library to enforce component licenses.

Inheritance Hierarchy

System.Object
Xheo.Licensing.LicenseSigningKey

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
LicenseSigningKey Class Members
See Also Fields Properties Methods
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

The following tables list the members exposed by LicenseSigningKey.

Public Constructors

 | Name | Description
Public Constructor | LicenseSigningKey Constructor | Overloaded. Initializes a new instance of the LicenseSigningKey class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CurrentVersion | The current version of the LicenseSigningKey class.
Top

Public Properties

 | Name | Description
Public Property | IsGlobalKey | Gets a value that indicates if the keys are the global keys used during the trial.
Public Property | Location | Gets the location where the keys were loaded from.
Public Property | Version | Gets or sets the version of the signing key.
Top

Public Methods

 | Name | Description
Public Method | Decrypt | Decrypts the data using the key. Use Encrypt to encrypt values.
Public Method | DecryptString | Decrypts the data using the key. Use EncryptString to encrypt values.
Public Method | Dispose | Implements Dispose.
Public Method | Encrypt | Encrypts the data using the key. Use Decrypt to retrieve the encrypted value.
Public Method | EncryptString | Encrypts the data using the key. Use DecryptString to retrieve the encrypted value.
Public Method | Export | Overloaded. Saves the public key contents of the LicenseSigningKey to a file with the given file name.
Public Method | FromXmlString | Initializes the contents of the LicenseSigningKey from the XML string.
static (Shared in Visual Basic) | GetPublicKey | Gets the runtime.lic embedded in the assembly hosting the given type.
Public Method | GetSerialNumberSeed | Gets the original unmasked serial number seed (Int32 value) from the encoded value.
static (Shared in Visual Basic) | GetSigningKey | Overloaded. Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.
Public Method | Load | Overloaded. Loads the LicenseSigningKey with the contents of the given file.
Public Method | MakeSerialNumber | Overloaded. Makes an encoded serial number for the given license.
Public Method | Save | Overloaded. Saves the contents of the LicenseSigningKey to a file with the given file name.
Public Method | SignData |
Public Method | SignLicense | Signs the ExtendedLicense and sets the LicenseKey property
Public Method | SignResponse | Signs a response so that the originator of the message can be validated.
Public Method | ToXmlString | Gets the LicenseSigningKey as an XML strign.
Public Method | UpgradeVersion | Upgrades the keys to the format used by the specified version.
Public Method | ValidateLicense | Validates that the contents of the license has not been changed since it was signed.
Public Method | ValidateResponse | Validates a response signature.
Public Method | ValidateSerialNumber | Overloaded. Validates that a serial number was signed with the license key and falls within a given range of valid numbers.
Public Method | VerifyData |
Top

See Also

Reference

LicenseSigningKey Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LicenseSigningKey Constructor
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : LicenseSigningKey Constructor

Initializes a new instance of the LicenseSigningKey class.

Overload List

Overload | Description
LicenseSigningKey Constructor() | Initializes a new instance of the LicenseSigningKey class.
LicenseSigningKey Constructor(Stream) | Initializes a new instance of the LicenseSigningKey class with the key from the given Stream object.
LicenseSigningKey Constructor(String) | Initializes a new instance of the LicenseSigningKey class with the key from the given file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LicenseSigningKey Constructor()
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > LicenseSigningKey Constructor : LicenseSigningKey Constructor()

Initializes a new instance of the LicenseSigningKey class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey()
C#
public LicenseSigningKey()
Managed Extensions for C++
public: LicenseSigningKey();
C++/CLI
public:
LicenseSigningKey();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LicenseSigningKey Constructor(Stream)
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > LicenseSigningKey Constructor : LicenseSigningKey Constructor(Stream)

stream
The Stream object that contains the data.
Initializes a new instance of the LicenseSigningKey class with the key from the given Stream object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As LicenseSigningKey(stream)
C#
public LicenseSigningKey(
   Stream stream
)
Managed Extensions for C++
public: LicenseSigningKey(
   Stream* stream
)
C++/CLI
public:
LicenseSigningKey(
   Stream^ stream
)

Parameters

stream
The Stream object that contains the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LicenseSigningKey Constructor(String)
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > LicenseSigningKey Constructor : LicenseSigningKey Constructor(String)

filename
Path to the file where the LicenseSigningKey is saved.
Initializes a new instance of the LicenseSigningKey class with the key from the given file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim filename As String

Dim instance As LicenseSigningKey(filename)
C#
public LicenseSigningKey(
   string filename
)
Managed Extensions for C++
public: LicenseSigningKey(
   string* filename
)
C++/CLI
public:
LicenseSigningKey(
   String^ filename
)

Parameters

filename
Path to the file where the LicenseSigningKey is saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
LicenseSigningKey Class Methods
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

For a list of all members of this type, see LicenseSigningKey members.

Public Methods

 | Name | Description
Public Method | Decrypt | Decrypts the data using the key. Use Encrypt to encrypt values.
Public Method | DecryptString | Decrypts the data using the key. Use EncryptString to encrypt values.
Public Method | Dispose | Implements Dispose.
Public Method | Encrypt | Encrypts the data using the key. Use Decrypt to retrieve the encrypted value.
Public Method | EncryptString | Encrypts the data using the key. Use DecryptString to retrieve the encrypted value.
Public Method | Export | Overloaded. Saves the public key contents of the LicenseSigningKey to a file with the given file name.
Public Method | FromXmlString | Initializes the contents of the LicenseSigningKey from the XML string.
static (Shared in Visual Basic) | GetPublicKey | Gets the runtime.lic embedded in the assembly hosting the given type.
Public Method | GetSerialNumberSeed | Gets the original unmasked serial number seed (Int32 value) from the encoded value.
static (Shared in Visual Basic) | GetSigningKey | Overloaded. Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.
Public Method | Load | Overloaded. Loads the LicenseSigningKey with the contents of the given file.
Public Method | MakeSerialNumber | Overloaded. Makes an encoded serial number for the given license.
Public Method | Save | Overloaded. Saves the contents of the LicenseSigningKey to a file with the given file name.
Public Method | SignData |
Public Method | SignLicense | Signs the ExtendedLicense and sets the LicenseKey property
Public Method | SignResponse | Signs a response so that the originator of the message can be validated.
Public Method | ToXmlString | Gets the LicenseSigningKey as an XML strign.
Public Method | UpgradeVersion | Upgrades the keys to the format used by the specified version.
Public Method | ValidateLicense | Validates that the contents of the license has not been changed since it was signed.
Public Method | ValidateResponse | Validates a response signature.
Public Method | ValidateSerialNumber | Overloaded. Validates that a serial number was signed with the license key and falls within a given range of valid numbers.
Public Method | VerifyData |
Top

See Also

Reference

LicenseSigningKey Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Decrypt Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Decrypt Method

data
Data previously encrypted with Encrypt.
Decrypts the data using the key. Use Encrypt to encrypt values.

Syntax

Visual Basic (Declaration)
Public Function Decrypt( _
   ByVal data() As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim value() As Byte

value = instance.Decrypt(data)
C#
public byte[] Decrypt(
   byte[] data
)
Managed Extensions for C++
public: byte[] Decrypt(
   byte[] data
)
C++/CLI
public:
array<byte> Decrypt(
   array<byte> data
)

Parameters

data
Data previously encrypted with Encrypt.

Return Value

Returns the original value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
DecryptString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : DecryptString Method

data
Data previously encrypted with EncryptString.
Decrypts the data using the key. Use EncryptString to encrypt values.

Syntax

Visual Basic (Declaration)
Public Function DecryptString( _
   ByVal data() As Byte _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim value As String

value = instance.DecryptString(data)
C#
public string DecryptString(
   byte[] data
)
Managed Extensions for C++
public: string* DecryptString(
   byte[] data
)
C++/CLI
public:
String^ DecryptString(
   array<byte> data
)

Parameters

data
Data previously encrypted with EncryptString.

Return Value

Returns the original value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Dispose Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Dispose Method

Implements Dispose.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Encrypt Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Encrypt Method

data
The data to encrypt.
Encrypts the data using the key. Use Decrypt to retrieve the encrypted value.

Syntax

Visual Basic (Declaration)
Public Function Encrypt( _
   ByVal data() As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim value() As Byte

value = instance.Encrypt(data)
C#
public byte[] Encrypt(
   byte[] data
)
Managed Extensions for C++
public: byte[] Encrypt(
   byte[] data
)
C++/CLI
public:
array<byte> Encrypt(
   array<byte> data
)

Parameters

data
The data to encrypt.

Return Value

Returns the encrypted version of the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
EncryptString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : EncryptString Method

data
The data to encrypt.
Encrypts the data using the key. Use DecryptString to retrieve the encrypted value.

Syntax

Visual Basic (Declaration)
Public Function EncryptString( _
   ByVal data As String _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data As String
Dim value() As Byte

value = instance.EncryptString(data)
C#
public byte[] EncryptString(
   string data
)
Managed Extensions for C++
public: byte[] EncryptString(
   string* data
)
C++/CLI
public:
array<byte> EncryptString(
   String^ data
)

Parameters

data
The data to encrypt.

Return Value

Returns the encrypted version of the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Export Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Export Method

Saves the public key contents of the LicenseSigningKey to a file with the given file name.

Overload List

Overload | Description
Export(String) | Saves the public key contents of the LicenseSigningKey to a file with the given file name.
Export(Stream) | Saves the contents of the LicenseSigningKey to a Stream object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Export(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Export Method : Export(String) Method

filename
Path to the file where the LicenseSigningKey should be saved.
Saves the public key contents of the LicenseSigningKey to a file with the given file name.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Export( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim filename As String

instance.Export(filename)
C#
public void Export(
   string filename
)
Managed Extensions for C++
public: void Export(
   string* filename
)
C++/CLI
public:
void Export(
   String^ filename
)

Parameters

filename
Path to the file where the LicenseSigningKey should be saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Export(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Export Method : Export(Stream) Method

stream
The Stream object to receive the data.
Saves the contents of the LicenseSigningKey to a Stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Export( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim stream As Stream

instance.Export(stream)
C#
public void Export(
   Stream stream
)
Managed Extensions for C++
public: void Export(
   Stream* stream
)
C++/CLI
public:
void Export(
   Stream^ stream
)

Parameters

stream
The Stream object to receive the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : FromXmlString Method

xml
A string containing an XML representaion of the key.
Initializes the contents of the LicenseSigningKey from the XML string.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
A string containing an XML representaion of the key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetPublicKey Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : GetPublicKey Method

type
The reference type to use for obtaining the assembly.
Gets the runtime.lic embedded in the assembly hosting the given type.

Syntax

Visual Basic (Declaration)
Public Shared Function GetPublicKey( _
   ByVal type As Type _
) As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim type As Type
Dim value As LicenseSigningKey

value = LicenseSigningKey.GetPublicKey(type)
C#
public static LicenseSigningKey GetPublicKey(
   Type type
)
Managed Extensions for C++
public: static LicenseSigningKey* GetPublicKey(
   Type* type
)
C++/CLI
public:
static LicenseSigningKey^ GetPublicKey(
   Type^ type
)

Parameters

type
The reference type to use for obtaining the assembly.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetSerialNumberSeed Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : GetSerialNumberSeed Method

license
The license the serial number was generated for.
serialNumber
The masked serial number created by MakeSerialNumber.
Gets the original unmasked serial number seed (Int32 value) from the encoded value.

Syntax

Visual Basic (Declaration)
Public Function GetSerialNumberSeed( _
   ByVal license As ExtendedLicense, _
   ByVal serialNumber As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim serialNumber As String
Dim value As Integer

value = instance.GetSerialNumberSeed(license, serialNumber)
C#
public int GetSerialNumberSeed(
   ExtendedLicense license,
   string serialNumber
)
Managed Extensions for C++
public: int GetSerialNumberSeed(
   ExtendedLicense* license,
   string* serialNumber
)
C++/CLI
public:
int GetSerialNumberSeed(
   ExtendedLicense^ license,
   String^ serialNumber
)

Parameters

license
The license the serial number was generated for.
serialNumber
The masked serial number created by MakeSerialNumber.

Return Value

Returns the original Int32 seed value for the masked serial number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetSigningKey Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : GetSigningKey Method

Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.

Overload List

Overload | Description
GetSigningKey(String,String) | Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.
GetSigningKey(String) | Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetSigningKey(String,String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > GetSigningKey Method : GetSigningKey(String,String) Method

name
Name of the keys.
folder
Path to the folder where the keys are located.
Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function GetSigningKey( _
   ByVal name As String, _
   ByVal folder As String _
) As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim name As String
Dim folder As String
Dim value As LicenseSigningKey

value = LicenseSigningKey.GetSigningKey(name, folder)
C#
public static LicenseSigningKey GetSigningKey(
   string name,
   string folder
)
Managed Extensions for C++
public: static LicenseSigningKey* GetSigningKey(
   string* name,
   string* folder
)
C++/CLI
public:
static LicenseSigningKey^ GetSigningKey(
   String^ name,
   String^ folder
)

Parameters

name
Name of the keys.
folder
Path to the folder where the keys are located.

Return Value

Returns the signing key if found, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetSigningKey(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > GetSigningKey Method : GetSigningKey(String) Method

name
Name of the keys.
Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function GetSigningKey( _
   ByVal name As String _
) As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim name As String
Dim value As LicenseSigningKey

value = LicenseSigningKey.GetSigningKey(name)
C#
public static LicenseSigningKey GetSigningKey(
   string name
)
Managed Extensions for C++
public: static LicenseSigningKey* GetSigningKey(
   string* name
)
C++/CLI
public:
static LicenseSigningKey^ GetSigningKey(
   String^ name
)

Parameters

name
Name of the keys.

Return Value

Returns the signing key if found, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Load Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Load Method

Loads the LicenseSigningKey with the contents of the given file.

Overload List

Overload | Description
Load(String) | Loads the LicenseSigningKey with the contents of the given file.
Load(Stream) | Loads the LicenseSigningKey from a Stream object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Load(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Load Method : Load(String) Method

filename
Path to the file where the LicenseSigningKey is saved.
Loads the LicenseSigningKey with the contents of the given file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim filename As String

instance.Load(filename)
C#
public void Load(
   string filename
)
Managed Extensions for C++
public: void Load(
   string* filename
)
C++/CLI
public:
void Load(
   String^ filename
)

Parameters

filename
Path to the file where the LicenseSigningKey is saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Load(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Load Method : Load(Stream) Method

stream
The Stream object that contains the data.
Loads the LicenseSigningKey from a Stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim stream As Stream

instance.Load(stream)
C#
public void Load(
   Stream stream
)
Managed Extensions for C++
public: void Load(
   Stream* stream
)
C++/CLI
public:
void Load(
   Stream^ stream
)

Parameters

stream
The Stream object that contains the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MakeSerialNumber Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : MakeSerialNumber Method

Makes an encoded serial number for the given license.

Overload List

Overload | Description
MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32[],Int32) | Makes an encoded serial number for the given license.
MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32) | Makes an encoded serial number for the given license.
MakeSerialNumber(String,SerialNumberSizes,Int32[],Int32) | Makes an encoded serial number for the given license.
MakeSerialNumber(String,SerialNumberSizes,Int32) | Makes an encoded serial number for the given license.

Exceptions

Exception | Description
ExtendedLicenseException | Thrown when the license keys have not been upgraded to at least version 2.0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32[],Int32) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > MakeSerialNumber Method : MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32[],Int32) Method

license
The license to generate a serial number for.
size
The key size to use when encrypting the serial number.
groupSizes
Defines the group sizes used to split the serial number into smaller chunks. A null value will use the default sizes for the given key size.
seed
The serial number value to encode.
Makes an encoded serial number for the given license.

Syntax

Visual Basic (Declaration)
Overloads Public Function MakeSerialNumber( _
   ByVal license As ExtendedLicense, _
   ByVal size As SerialNumberSizes, _
   ByVal groupSizes() As Integer, _
   ByVal seed As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim size As SerialNumberSizes
Dim groupSizes() As Integer
Dim seed As Integer
Dim value As String

value = instance.MakeSerialNumber(license, size, groupSizes, seed)
C#
public string MakeSerialNumber(
   ExtendedLicense license,
   SerialNumberSizes size,
   int[] groupSizes,
   int seed
)
Managed Extensions for C++
public: string* MakeSerialNumber(
   ExtendedLicense* license,
   SerialNumberSizes size,
   int[] groupSizes,
   int seed
)
C++/CLI
public:
String^ MakeSerialNumber(
   ExtendedLicense^ license,
   SerialNumberSizes size,
   array<int> groupSizes,
   int seed
)

Parameters

license
The license to generate a serial number for.
size
The key size to use when encrypting the serial number.
groupSizes
Defines the group sizes used to split the serial number into smaller chunks. A null value will use the default sizes for the given key size.
seed
The serial number value to encode.

Return Value

Returns a new serial number encrypted with the key.

Exceptions

Exception | Description
ExtendedLicenseException | Thrown when the license keys have not been upgraded to at least version 2.0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > MakeSerialNumber Method : MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32) Method

license
The license to generate a serial number for.
size
The key size to use when encrypting the serial number.
seed
The serial number value to encode.
Makes an encoded serial number for the given license.

Syntax

Visual Basic (Declaration)
Overloads Public Function MakeSerialNumber( _
   ByVal license As ExtendedLicense, _
   ByVal size As SerialNumberSizes, _
   ByVal seed As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim size As SerialNumberSizes
Dim seed As Integer
Dim value As String

value = instance.MakeSerialNumber(license, size, seed)
C#
public string MakeSerialNumber(
   ExtendedLicense license,
   SerialNumberSizes size,
   int seed
)
Managed Extensions for C++
public: string* MakeSerialNumber(
   ExtendedLicense* license,
   SerialNumberSizes size,
   int seed
)
C++/CLI
public:
String^ MakeSerialNumber(
   ExtendedLicense^ license,
   SerialNumberSizes size,
   int seed
)

Parameters

license
The license to generate a serial number for.
size
The key size to use when encrypting the serial number.
seed
The serial number value to encode.

Return Value

Returns a new serial number encrypted with the key.

Exceptions

Exception | Description
ExtendedLicenseException | Thrown when the license keys have not been upgraded to at least version 2.0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MakeSerialNumber(String,SerialNumberSizes,Int32[],Int32) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > MakeSerialNumber Method : MakeSerialNumber(String,SerialNumberSizes,Int32[],Int32) Method

prefix
The prefix to add to the serial number. It must match the AbsoluteSerialNumber of the license it will be assigned to.
size
The key size to use when encrypting the serial number.
groupSizes
Defines the group sizes used to split the serial number into smaller chunks. A null value will use the default sizes for the given key size.
seed
The serial number value to encode.
Makes an encoded serial number for the given license.

Syntax

Visual Basic (Declaration)
Overloads Public Function MakeSerialNumber( _
   ByVal prefix As String, _
   ByVal size As SerialNumberSizes, _
   ByVal groupSizes() As Integer, _
   ByVal seed As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim prefix As String
Dim size As SerialNumberSizes
Dim groupSizes() As Integer
Dim seed As Integer
Dim value As String

value = instance.MakeSerialNumber(prefix, size, groupSizes, seed)
C#
public string MakeSerialNumber(
   string prefix,
   SerialNumberSizes size,
   int[] groupSizes,
   int seed
)
Managed Extensions for C++
public: string* MakeSerialNumber(
   string* prefix,
   SerialNumberSizes size,
   int[] groupSizes,
   int seed
)
C++/CLI
public:
String^ MakeSerialNumber(
   String^ prefix,
   SerialNumberSizes size,
   array<int> groupSizes,
   int seed
)

Parameters

prefix
The prefix to add to the serial number. It must match the AbsoluteSerialNumber of the license it will be assigned to.
size
The key size to use when encrypting the serial number.
groupSizes
Defines the group sizes used to split the serial number into smaller chunks. A null value will use the default sizes for the given key size.
seed
The serial number value to encode.

Return Value

Returns a new serial number encrypted with the key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MakeSerialNumber(String,SerialNumberSizes,Int32) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > MakeSerialNumber Method : MakeSerialNumber(String,SerialNumberSizes,Int32) Method

prefix
The prefix to add to the serial number. It must match the AbsoluteSerialNumber of the license it will be assigned to.
size
The key size to use when encrypting the serial number.
seed
The serial number value to encode.
Makes an encoded serial number for the given license.

Syntax

Visual Basic (Declaration)
Overloads Public Function MakeSerialNumber( _
   ByVal prefix As String, _
   ByVal size As SerialNumberSizes, _
   ByVal seed As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim prefix As String
Dim size As SerialNumberSizes
Dim seed As Integer
Dim value As String

value = instance.MakeSerialNumber(prefix, size, seed)
C#
public string MakeSerialNumber(
   string prefix,
   SerialNumberSizes size,
   int seed
)
Managed Extensions for C++
public: string* MakeSerialNumber(
   string* prefix,
   SerialNumberSizes size,
   int seed
)
C++/CLI
public:
String^ MakeSerialNumber(
   String^ prefix,
   SerialNumberSizes size,
   int seed
)

Parameters

prefix
The prefix to add to the serial number. It must match the AbsoluteSerialNumber of the license it will be assigned to.
size
The key size to use when encrypting the serial number.
seed
The serial number value to encode.

Return Value

Returns a new serial number encrypted with the key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Save Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Save Method

Saves the contents of the LicenseSigningKey to a file with the given file name.

Overload List

Overload | Description
Save(String,Boolean) | Saves the contents of the LicenseSigningKey to a file with the given file name.
Save(String) | Saves the contents of the LicenseSigningKey to a file with the given file name.
Save(Stream,Boolean) | Saves the contents of the LicenseSigningKey to a Stream object.
Save(Stream) | Saves the contents of the LicenseSigningKey to a Stream object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Save(String,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Save Method : Save(String,Boolean) Method

filename
Path to the file where the LicenseSigningKey should be saved.
includePrivateData
Indicates if the private portion of the key should be included.
Saves the contents of the LicenseSigningKey to a file with the given file name.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal filename As String, _
   ByVal includePrivateData As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim filename As String
Dim includePrivateData As Boolean

instance.Save(filename, includePrivateData)
C#
public void Save(
   string filename,
   bool includePrivateData
)
Managed Extensions for C++
public: void Save(
   string* filename,
   bool includePrivateData
)
C++/CLI
public:
void Save(
   String^ filename,
   bool includePrivateData
)

Parameters

filename
Path to the file where the LicenseSigningKey should be saved.
includePrivateData
Indicates if the private portion of the key should be included.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Save(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Save Method : Save(String) Method

filename
Path to the file where the LicenseSigningKey should be saved.
Saves the contents of the LicenseSigningKey to a file with the given file name.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim filename As String

instance.Save(filename)
C#
public void Save(
   string filename
)
Managed Extensions for C++
public: void Save(
   string* filename
)
C++/CLI
public:
void Save(
   String^ filename
)

Parameters

filename
Path to the file where the LicenseSigningKey should be saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Save(Stream,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Save Method : Save(Stream,Boolean) Method

stream
The Stream object to receive the data.
includePrivateData
Indicates if the private portion of the key should be included.
Saves the contents of the LicenseSigningKey to a Stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream, _
   ByVal includePrivateData As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim stream As Stream
Dim includePrivateData As Boolean

instance.Save(stream, includePrivateData)
C#
public void Save(
   Stream stream,
   bool includePrivateData
)
Managed Extensions for C++
public: void Save(
   Stream* stream,
   bool includePrivateData
)
C++/CLI
public:
void Save(
   Stream^ stream,
   bool includePrivateData
)

Parameters

stream
The Stream object to receive the data.
includePrivateData
Indicates if the private portion of the key should be included.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Save(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Save Method : Save(Stream) Method

stream
The Stream object to receive the data.
Saves the contents of the LicenseSigningKey to a Stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim stream As Stream

instance.Save(stream)
C#
public void Save(
   Stream stream
)
Managed Extensions for C++
public: void Save(
   Stream* stream
)
C++/CLI
public:
void Save(
   Stream^ stream
)

Parameters

stream
The Stream object to receive the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SignData Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : SignData Method

data

Syntax

Visual Basic (Declaration)
Public Function SignData( _
   ByVal data() As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim value() As Byte

value = instance.SignData(data)
C#
public byte[] SignData(
   byte[] data
)
Managed Extensions for C++
public: byte[] SignData(
   byte[] data
)
C++/CLI
public:
array<byte> SignData(
   array<byte> data
)

Parameters

data

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SignLicense Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : SignLicense Method

license
Signs the ExtendedLicense and sets the LicenseKey property

Syntax

Visual Basic (Declaration)
Public Sub SignLicense( _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense

instance.SignLicense(license)
C#
public void SignLicense(
   ExtendedLicense license
)
Managed Extensions for C++
public: void SignLicense(
   ExtendedLicense* license
)
C++/CLI
public:
void SignLicense(
   ExtendedLicense^ license
)

Parameters

license

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SignResponse Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : SignResponse Method

response
The response to sign.
Signs a response so that the originator of the message can be validated.

Syntax

Visual Basic (Declaration)
Public Function SignResponse( _
   ByVal response As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim response As String
Dim value As String

value = instance.SignResponse(response)
C#
public string SignResponse(
   string response
)
Managed Extensions for C++
public: string* SignResponse(
   string* response
)
C++/CLI
public:
String^ SignResponse(
   String^ response
)

Parameters

response
The response to sign.

Return Value

Returns a signature for the response.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : ToXmlString Method

includePrivateData
Indicates if the private data shouls be included.
Gets the LicenseSigningKey as an XML strign.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString( _
   ByVal includePrivateData As Boolean _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim includePrivateData As Boolean
Dim value As String

value = instance.ToXmlString(includePrivateData)
C#
public string ToXmlString(
   bool includePrivateData
)
Managed Extensions for C++
public: string* ToXmlString(
   bool includePrivateData
)
C++/CLI
public:
String^ ToXmlString(
   bool includePrivateData
)

Parameters

includePrivateData
Indicates if the private data shouls be included.

Return Value

Returns an XML string representation of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
UpgradeVersion Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : UpgradeVersion Method

version
The version to upgrade to.
Upgrades the keys to the format used by the specified version.

Syntax

Visual Basic (Declaration)
Public Sub UpgradeVersion( _
   ByVal version As Version _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim version As Version

instance.UpgradeVersion(version)
C#
public void UpgradeVersion(
   Version version
)
Managed Extensions for C++
public: void UpgradeVersion(
   Version* version
)
C++/CLI
public:
void UpgradeVersion(
   Version^ version
)

Parameters

version
The version to upgrade to.

Remarks

The changes should be saved over the existing keys and the public key re-exported after the upgrade.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ValidateLicense Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : ValidateLicense Method

license
The license to validate.
Validates that the contents of the license has not been changed since it was signed.

Syntax

Visual Basic (Declaration)
Public Function ValidateLicense( _
   ByVal license As ExtendedLicense _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim value As Boolean

value = instance.ValidateLicense(license)
C#
public bool ValidateLicense(
   ExtendedLicense license
)
Managed Extensions for C++
public: bool ValidateLicense(
   ExtendedLicense* license
)
C++/CLI
public:
bool ValidateLicense(
   ExtendedLicense^ license
)

Parameters

license
The license to validate.

Return Value

Returns true if the contents of the license have not been changed, otherwise false.

Remarks

You must use the same LicenseSigningKey to validate the license as you did to sign it. You can use either the full public/private key or just the public key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ValidateResponse Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : ValidateResponse Method

response
The original response.
signature
The signature generated from SignResponse.
Validates a response signature.

Syntax

Visual Basic (Declaration)
Public Function ValidateResponse( _
   ByVal response As String, _
   ByVal signature As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim response As String
Dim signature As String
Dim value As Boolean

value = instance.ValidateResponse(response, signature)
C#
public bool ValidateResponse(
   string response,
   string signature
)
Managed Extensions for C++
public: bool ValidateResponse(
   string* response,
   string* signature
)
C++/CLI
public:
bool ValidateResponse(
   String^ response,
   String^ signature
)

Parameters

response
The original response.
signature
The signature generated from SignResponse.

Return Value

Returns true if the signature and response match.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ValidateSerialNumber Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : ValidateSerialNumber Method

Validates that a serial number was signed with the license key and falls within a given range of valid numbers.

Overload List

Overload | Description
ValidateSerialNumber(ExtendedLicense,String) | Validates that a serial number was signed with the license key and falls within a given range of valid numbers.
ValidateSerialNumber(String,String,Int32,Int32,SerialNumberSizes) | Validates that a serial number was signed with the license key and falls within a given range of valid numbers.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ValidateSerialNumber(ExtendedLicense,String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > ValidateSerialNumber Method : ValidateSerialNumber(ExtendedLicense,String) Method

license
The license the seral number is checked against.
serialNumber
The serial number to check.
Validates that a serial number was signed with the license key and falls within a given range of valid numbers.

Syntax

Visual Basic (Declaration)
Overloads Public Function ValidateSerialNumber( _
   ByVal license As ExtendedLicense, _
   ByVal serialNumber As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim serialNumber As String
Dim value As Boolean

value = instance.ValidateSerialNumber(license, serialNumber)
C#
public bool ValidateSerialNumber(
   ExtendedLicense license,
   string serialNumber
)
Managed Extensions for C++
public: bool ValidateSerialNumber(
   ExtendedLicense* license,
   string* serialNumber
)
C++/CLI
public:
bool ValidateSerialNumber(
   ExtendedLicense^ license,
   String^ serialNumber
)

Parameters

license
The license the seral number is checked against.
serialNumber
The serial number to check.

Return Value

Returns true of the serial number is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ValidateSerialNumber(String,String,Int32,Int32,SerialNumberSizes) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > ValidateSerialNumber Method : ValidateSerialNumber(String,String,Int32,Int32,SerialNumberSizes) Method

prefix
The serial number prefix required.
serialNumber
The serial number to check.
minAcceptedSeed
The minimum acceptable seed value.
maxAcceptedSeed
The maximim acceptable seed value.
acceptedSizes
The accepted serial number sizes.
Validates that a serial number was signed with the license key and falls within a given range of valid numbers.

Syntax

Visual Basic (Declaration)
Overloads Public Function ValidateSerialNumber( _
   ByVal prefix As String, _
   ByVal serialNumber As String, _
   ByVal minAcceptedSeed As Integer, _
   ByVal maxAcceptedSeed As Integer, _
   ByVal acceptedSizes As SerialNumberSizes _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim prefix As String
Dim serialNumber As String
Dim minAcceptedSeed As Integer
Dim maxAcceptedSeed As Integer
Dim acceptedSizes As SerialNumberSizes
Dim value As Boolean

value = instance.ValidateSerialNumber(prefix, serialNumber, minAcceptedSeed, maxAcceptedSeed, acceptedSizes)
C#
public bool ValidateSerialNumber(
   string prefix,
   string serialNumber,
   int minAcceptedSeed,
   int maxAcceptedSeed,
   SerialNumberSizes acceptedSizes
)
Managed Extensions for C++
public: bool ValidateSerialNumber(
   string* prefix,
   string* serialNumber,
   int minAcceptedSeed,
   int maxAcceptedSeed,
   SerialNumberSizes acceptedSizes
)
C++/CLI
public:
bool ValidateSerialNumber(
   String^ prefix,
   String^ serialNumber,
   int minAcceptedSeed,
   int maxAcceptedSeed,
   SerialNumberSizes acceptedSizes
)

Parameters

prefix
The serial number prefix required.
serialNumber
The serial number to check.
minAcceptedSeed
The minimum acceptable seed value.
maxAcceptedSeed
The maximim acceptable seed value.
acceptedSizes
The accepted serial number sizes.

Return Value

Returns true of the serial number is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
VerifyData Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : VerifyData Method

data
signature

Syntax

Visual Basic (Declaration)
Public Function VerifyData( _
   ByVal data() As Byte, _
   ByVal signature() As Byte _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim signature() As Byte
Dim value As Boolean

value = instance.VerifyData(data, signature)
C#
public bool VerifyData(
   byte[] data,
   byte[] signature
)
Managed Extensions for C++
public: bool VerifyData(
   byte[] data,
   byte[] signature
)
C++/CLI
public:
bool VerifyData(
   array<byte> data,
   array<byte> signature
)

Parameters

data
signature

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Windows Send comments on this topic.
LicenseSigningKey Class Properties
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

For a list of all members of this type, see LicenseSigningKey members.

Public Properties

 | Name | Description
Public Property | IsGlobalKey | Gets a value that indicates if the keys are the global keys used during the trial.
Public Property | Location | Gets the location where the keys were loaded from.
Public Property | Version | Gets or sets the version of the signing key.
Top

See Also

Reference

LicenseSigningKey Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IsGlobalKey Property
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : IsGlobalKey Property

Gets a value that indicates if the keys are the global keys used during the trial.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsGlobalKey As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim value As Boolean

value = instance.IsGlobalKey
C#
public bool IsGlobalKey {get;}
Managed Extensions for C++
public: __property bool get_IsGlobalKey();
C++/CLI
public:
property bool IsGlobalKey {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Location Property
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Location Property

Gets the location where the keys were loaded from.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim value As String

value = instance.Location
C#
public string Location {get;}
Managed Extensions for C++
public: __property string* get_Location();
C++/CLI
public:
property String^ Location {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Version Property
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Version Property

Gets or sets the version of the signing key.

Syntax

Visual Basic (Declaration)
Public Property Version As Version
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim value As Version

instance.Version = value

value = instance.Version
C#
public Version Version {get; set;}
Managed Extensions for C++
public: __property Version* get_Version();
public: __property void set_Version(
   Version* value
);
C++/CLI
public:
property Version^ Version {
   Version^ get();
   void set (Version^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.Windows Send comments on this topic.
LicenseSigningKey Class Fields
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

For a list of all members of this type, see LicenseSigningKey members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CurrentVersion | The current version of the LicenseSigningKey class.
Top

See Also

Reference

LicenseSigningKey Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
CurrentVersion Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : CurrentVersion Field

The current version of the LicenseSigningKey class.

Syntax

Visual Basic (Declaration)
Public Shared CurrentVersion As Version
Visual Basic (Usage) Copy Code
Dim value As Version

value = LicenseSigningKey.CurrentVersion

LicenseSigningKey.CurrentVersion = value
C#
public static Version CurrentVersion
Managed Extensions for C++
public: static Version* CurrentVersion
C++/CLI
public:
static Version^ CurrentVersion

Remarks

Later versions may introduce a new signing/file scheme. To maintain backwards compatability the keys are versioned.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LicenseValuesCollection Class
See Also Members
[image]
Xheo.Licensing Namespace : LicenseValuesCollection Class

Maintains a collection of name value pairs. The collection can be serialized and marked as read only.

Syntax

Visual Basic (Declaration)
Private Class LicenseValuesCollection
   Inherits NameValueCollection
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
C#
private class LicenseValuesCollection : NameValueCollection
Managed Extensions for C++
private __gc class LicenseValuesCollection : public NameValueCollection
C++/CLI
private ref class LicenseValuesCollection : public NameValueCollection

Inheritance Hierarchy

System.Object
System.Collections.Specialized.NameObjectCollectionBase
System.Collections.Specialized.NameValueCollection
Xheo.Licensing.LicenseValuesCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
LicenseValuesCollection Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : LicenseValuesCollection Class

The following tables list the members exposed by LicenseValuesCollection.

Public Constructors

 | Name | Description
Public Constructor | LicenseValuesCollection Constructor | Initializes a new instance of the LicenseValuesCollection class.
Top

Public Properties

 | Name | Description
Public Property | AllKeys | Gets all the keys in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Property | Count | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Property | Item | Overloaded. Gets or sets the entry with the specified key in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Property | Keys | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Included for serialization compatability, do not use.
Public Method | Clear | Invalidates the cached arrays and removes all entries from the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | CopyTo | Copies the entire NameValueCollection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | FromXmlString | Loads the values from an XML string.
Public Method | Get | Overloaded. Gets the values associated with the specified key from the NameValueCollection combined into one comma-separated list. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | GetEnumerator | Returns an enumerator that iterates through the NameObjectCollectionBase. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetKey | Gets the key at the specified index of the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetValues | Overloaded. Gets the values associated with the specified key from the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | HasKeys | Gets a value indicating whether the NameValueCollection contains keys that are not null. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | LoadFromXml | Loades the contents of the collection from the XmlNode.
Public Method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | Remove | Removes the entries with the specified key from the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | SaveToXml | Saves the contents of the collection to the parent XmlNode.
Public Method | Set | Sets the value of an entry in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | ToXmlString | Converts the collection to an XML string representation.
Top

See Also

Reference

LicenseValuesCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LicenseValuesCollection Constructor
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : LicenseValuesCollection Constructor

Initializes a new instance of the LicenseValuesCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection()
C#
public LicenseValuesCollection()
Managed Extensions for C++
public: LicenseValuesCollection();
C++/CLI
public:
LicenseValuesCollection();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
LicenseValuesCollection Class Methods
See Also
[image]
Xheo.Licensing Namespace : LicenseValuesCollection Class

For a list of all members of this type, see LicenseValuesCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Included for serialization compatability, do not use.
Public Method | Clear | Invalidates the cached arrays and removes all entries from the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | CopyTo | Copies the entire NameValueCollection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | FromXmlString | Loads the values from an XML string.
Public Method | Get | Overloaded. Gets the values associated with the specified key from the NameValueCollection combined into one comma-separated list. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | GetEnumerator | Returns an enumerator that iterates through the NameObjectCollectionBase. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetKey | Gets the key at the specified index of the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetValues | Overloaded. Gets the values associated with the specified key from the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | HasKeys | Gets a value indicating whether the NameValueCollection contains keys that are not null. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | LoadFromXml | Loades the contents of the collection from the XmlNode.
Public Method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | Remove | Removes the entries with the specified key from the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | SaveToXml | Saves the contents of the collection to the parent XmlNode.
Public Method | Set | Sets the value of an entry in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | ToXmlString | Converts the collection to an XML string representation.
Top

See Also

Reference

LicenseValuesCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Add Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : Add Method

Included for serialization compatability, do not use.

Overload List

Overload | Description
Add(String) | Included for serialization compatability, do not use.
Add(NameValueCollection) | Copies the entries in the specified NameValueCollection to the current NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Add(String,String) | Adds an entry with the specified name and value to the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Add(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class > Add Method : Add(String) Method

value
Included for serialization compatability, do not use.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim value As String

instance.Add(value)
C#
public void Add(
   string value
)
Managed Extensions for C++
public: void Add(
   string* value
)
C++/CLI
public:
void Add(
   String^ value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : FromXmlString Method

xml
The XML document string containing the values collection.
Loads the values from an XML string.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
The XML document string containing the values collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : LoadFromXml Method

parentNode
The root XmlNode containing the collection.
Loades the contents of the collection from the XmlNode.

Syntax

Visual Basic (Declaration)
Public Sub LoadFromXml( _
   ByVal parentNode As XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim parentNode As XmlNode

instance.LoadFromXml(parentNode)
C#
public void LoadFromXml(
   XmlNode parentNode
)
Managed Extensions for C++
public: void LoadFromXml(
   XmlNode parentNode
)
C++/CLI
public:
void LoadFromXml(
   XmlNode parentNode
)

Parameters

parentNode
The root XmlNode containing the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : SaveToXml Method

parentNode
The XmlNode to save the collection to.
Saves the contents of the collection to the parent XmlNode.

Syntax

Visual Basic (Declaration)
Public Function SaveToXml( _
   ByVal parentNode As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim parentNode As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parentNode)
C#
public XmlNode SaveToXml(
   XmlNode parentNode
)
Managed Extensions for C++
public: XmlNode SaveToXml(
   XmlNode parentNode
)
C++/CLI
public:
XmlNode SaveToXml(
   XmlNode parentNode
)

Parameters

parentNode
The XmlNode to save the collection to.

Return Value

Returns the root node of the saved collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : ToXmlString Method

Converts the collection to an XML string representation.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim value As String

value = instance.ToXmlString()
C#
public string ToXmlString()
Managed Extensions for C++
public: string* ToXmlString();
C++/CLI
public:
String^ ToXmlString();

Return Value

Returns the collection as an XML document string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Limit Class
See Also Members
[image]
Xheo.Licensing Namespace : Limit Class

Base class for all license limitations.

Object Model

Syntax

Visual Basic (Declaration)
Private MustInherit Class Limit
   Inherits MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As Limit
C#
private abstract class Limit : MarshalByRefObject
Managed Extensions for C++
private __gc abstract class Limit : public MarshalByRefObject
C++/CLI
private ref class Limit abstract : public MarshalByRefObject

Remarks

Limits are used by the XHEO|Licensing framework to restrict a Component, Class or Control to a specific set of runtime or designtime conditions. The library contains over 15 built in limits that you can use to control the use of your protected Type.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Xheo.Licensing.Limit
Xheo.Licensing.ContainerLimit
Xheo.Licensing.ContainerLimit
Xheo.Licensing.ContainerLimit
Xheo.Licensing.ContainerLimit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
Limit Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : Limit Class

The following tables list the members exposed by Limit.

Public Properties

 | Name | Description
Public Property | Description | Gets the description of the limit.
Public Property | IsGui | Gets a value that indicates if this Limit uses a GUI to interact with the user.
Public Property | IsRemote | Gets a value that indicates if this Limit uses remote processes (such as WebServices) for enforcement.
Public Property | IsTimeSensitive | Gets a value that indicates if the limit is time sensitive and the clock should be protected.
Public Property | License | Gets or sets a reference to the ExtendedLicense that contains this Limit.
Public Property | Name | Gets the display name of the limit.
Public Property | QualifiedTypeName | Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type.
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases any managed or unmangaged resources used by the limit.
static (Shared in Visual Basic) | GetBitmapResource | Gets an Image for the requested resource. Resources can be defined as assembly resources or as remote resources. If the name is prefixed with http then it is assumed to be a remote resource and a WebRequest is made to retrieve the bitmap, otherwise it is assumed to be embedded in the assembly.
Public Method | GetDetailsDescription | Gets a description of the details of the limit.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | GetLimitFromName | Gets a Limit object based on the given name.
static (Shared in Visual Basic) | GetPrivateRegistryKey | Gets a private registry key where values for the license can be stored for the given type.
Public Method | Granted | Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | LoadFromXml | Loads the contents of a Limit from an XmlNode.
static (Shared in Visual Basic) | MaskValue | Performs a simple value obfuscation to make editing client side values more difficult. This is by no means secure.
static (Shared in Visual Basic) | OpenOrCreateRegistryKey | Opens or creates a registry key.
static (Shared in Visual Basic) | ParseIPAddress | Parses an IPAddress to it's actual long value.
Public Method | Peek | Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user.
Public Method | SaveToXml | Saves the contents of the Limit as an XmlNode.
static (Shared in Visual Basic) | SelectCulture | Selects the given culture for the current thread, and returns the previous culture.
static (Shared in Visual Basic) | SelectWebCulture | Selects the culture of the current web request into the current thread, and returns the previous culture.
static (Shared in Visual Basic) | UnmaskValue | Reverses the simple value obfuscation performed by MaskValue.
Public Method | Validate | Validates that the license being granted is within the limits enforced by this object.
static (Shared in Visual Basic) | ValidateDomainName | Validates the format of a domain name.
static (Shared in Visual Basic) | ValidateEmail | Validates if the email is correctly formatted.
static (Shared in Visual Basic) | ValidateIPAddress | Validates the format of an IP address.
static (Shared in Visual Basic) | ValidateUrl | Validates the url is correctly formatted.
Top

See Also

Reference

Limit Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
Limit Class Methods
See Also
[image]
Xheo.Licensing Namespace : Limit Class

For a list of all members of this type, see Limit members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases any managed or unmangaged resources used by the limit.
static (Shared in Visual Basic) | GetBitmapResource | Gets an Image for the requested resource. Resources can be defined as assembly resources or as remote resources. If the name is prefixed with http then it is assumed to be a remote resource and a WebRequest is made to retrieve the bitmap, otherwise it is assumed to be embedded in the assembly.
Public Method | GetDetailsDescription | Gets a description of the details of the limit.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | GetLimitFromName | Gets a Limit object based on the given name.
static (Shared in Visual Basic) | GetPrivateRegistryKey | Gets a private registry key where values for the license can be stored for the given type.
Public Method | Granted | Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | LoadFromXml | Loads the contents of a Limit from an XmlNode.
static (Shared in Visual Basic) | MaskValue | Performs a simple value obfuscation to make editing client side values more difficult. This is by no means secure.
static (Shared in Visual Basic) | OpenOrCreateRegistryKey | Opens or creates a registry key.
static (Shared in Visual Basic) | ParseIPAddress | Parses an IPAddress to it's actual long value.
Public Method | Peek | Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user.
Public Method | SaveToXml | Saves the contents of the Limit as an XmlNode.
static (Shared in Visual Basic) | SelectCulture | Selects the given culture for the current thread, and returns the previous culture.
static (Shared in Visual Basic) | SelectWebCulture | Selects the culture of the current web request into the current thread, and returns the previous culture.
static (Shared in Visual Basic) | UnmaskValue | Reverses the simple value obfuscation performed by MaskValue.
Public Method | Validate | Validates that the license being granted is within the limits enforced by this object.
static (Shared in Visual Basic) | ValidateDomainName | Validates the format of a domain name.
static (Shared in Visual Basic) | ValidateEmail | Validates if the email is correctly formatted.
static (Shared in Visual Basic) | ValidateIPAddress | Validates the format of an IP address.
static (Shared in Visual Basic) | ValidateUrl | Validates the url is correctly formatted.
Top

See Also

Reference

Limit Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Dispose Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Dispose Method

Releases any managed or unmangaged resources used by the limit.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As Limit

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetBitmapResource Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : GetBitmapResource Method

bitmapResource
Name of the resource to retrieve, prefix with http to get a remote resource.
limit
The limit requesting the resource.
parameters
Collection of additional parameters to append to the URL for remote images. Parameters should be in the format "key=value".
Gets an Image for the requested resource. Resources can be defined as assembly resources or as remote resources. If the name is prefixed with http then it is assumed to be a remote resource and a WebRequest is made to retrieve the bitmap, otherwise it is assumed to be embedded in the assembly.

Syntax

Visual Basic (Declaration)
Public Shared Function GetBitmapResource( _
   ByVal bitmapResource As String, _
   ByVal limit As Limit, _
   ByVal ParamArray parameters() As String _
) As Bitmap
Visual Basic (Usage) Copy Code
Dim bitmapResource As String
Dim limit As Limit
Dim parameters() As String
Dim value As Bitmap

value = Limit.GetBitmapResource(bitmapResource, limit, parameters)
C#
public static Bitmap GetBitmapResource(
   string bitmapResource,
   Limit limit,
   params string[] parameters
)
Managed Extensions for C++
public: static Bitmap GetBitmapResource(
   string* bitmapResource,
   Limit* limit,
   params string*[] parameters
)
C++/CLI
public:
static Bitmap GetBitmapResource(
   String^ bitmapResource,
   Limit^ limit,
   ... array<String^> parameters
)

Parameters

bitmapResource
Name of the resource to retrieve, prefix with http to get a remote resource.
limit
The limit requesting the resource.
parameters
Collection of additional parameters to append to the URL for remote images. Parameters should be in the format "key=value".

Return Value

Returns the resource if found, otherwise null.

Remarks

For remote resources the serial number, expiration date, and optional parameters of the License will be appended to the request QueryString. You can use this to provide alternate images based on the conditions of the license.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetDetailsDescription Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : GetDetailsDescription Method

Gets a description of the details of the limit.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetDetailsDescription() As String
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As String

value = instance.GetDetailsDescription()
C#
public virtual string GetDetailsDescription()
Managed Extensions for C++
public: virtual string* GetDetailsDescription();
C++/CLI
public:
virtual String^ GetDetailsDescription();

Return Value

Returns the description.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetLimitFromName Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : GetLimitFromName Method

name
The name of the limit type to retrieve.
Gets a Limit object based on the given name.

Syntax

Visual Basic (Declaration)
Public Shared Function GetLimitFromName( _
   ByVal name As String _
) As Limit
Visual Basic (Usage) Copy Code
Dim name As String
Dim value As Limit

value = Limit.GetLimitFromName(name)
C#
public static Limit GetLimitFromName(
   string name
)
Managed Extensions for C++
public: static Limit* GetLimitFromName(
   string* name
)
C++/CLI
public:
static Limit^ GetLimitFromName(
   String^ name
)

Parameters

name
The name of the limit type to retrieve.

Return Value

Returns a new Limit object of the given type if available, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetPrivateRegistryKey Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : GetPrivateRegistryKey Method

key
A unique key to identify this registry section.
mustExist
Indicates if the key must already exist.
created
Accepts a value that indicates if the key was created.
Gets a private registry key where values for the license can be stored for the given type.

Syntax

Visual Basic (Declaration)
Public Shared Function GetPrivateRegistryKey( _
   ByVal key As String, _
   ByVal mustExist As Boolean, _
   ByRef created As Boolean _
) As RegistryKey
Visual Basic (Usage) Copy Code
Dim key As String
Dim mustExist As Boolean
Dim created As Boolean
Dim value As RegistryKey

value = Limit.GetPrivateRegistryKey(key, mustExist, created)
C#
public static RegistryKey GetPrivateRegistryKey(
   string key,
   bool mustExist,
   out bool created
)
Managed Extensions for C++
public: static RegistryKey* GetPrivateRegistryKey(
   string* key,
   bool mustExist,
   [PARAMFLAG::Out] bool created
)
C++/CLI
public:
static RegistryKey^ GetPrivateRegistryKey(
   String^ key,
   bool mustExist,
   [PARAMFLAG::Out] bool created
)

Parameters

key
A unique key to identify this registry section.
mustExist
Indicates if the key must already exist.
created
Accepts a value that indicates if the key was created.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Granted Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Granted Method

context
The LicenseContext used to determine the environment and settings of the licensing.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Granted( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim context As LicenseContext
Dim type As Type
Dim instance As Object

instance.Granted(context, type, instance)
C#
public virtual void Granted(
   LicenseContext context,
   Type type,
   object instance
)
Managed Extensions for C++
public: virtual void Granted(
   LicenseContext context,
   Type* type,
   Object* instance
)
C++/CLI
public:
virtual void Granted(
   LicenseContext context,
   Type^ type,
   Object^ instance
)

Parameters

context
The LicenseContext used to determine the environment and settings of the licensing.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.

Remarks

Checks in this method should be very fast because they are called every time a licensed object is created. The default implementation does nothing.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : LoadFromXml Method

node
The XmlNode to load from.
Loads the contents of a Limit from an XmlNode.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride Function LoadFromXml( _
   ByVal node As XmlNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim node As XmlNode
Dim value As Boolean

value = instance.LoadFromXml(node)
C#
public virtual abstract bool LoadFromXml(
   XmlNode node
)
Managed Extensions for C++
public: virtual abstract bool LoadFromXml(
   XmlNode node
)
C++/CLI
public:
virtual abstract bool LoadFromXml(
   XmlNode node
)

Parameters

node
The XmlNode to load from.

Return Value

Returns true if the load was successful, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MaskValue Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : MaskValue Method

source
The original value.
Performs a simple value obfuscation to make editing client side values more difficult. This is by no means secure.

Syntax

Visual Basic (Declaration)
Public Shared Function MaskValue( _
   ByVal source As String _
) As String
Visual Basic (Usage) Copy Code
Dim source As String
Dim value As String

value = Limit.MaskValue(source)
C#
public static string MaskValue(
   string source
)
Managed Extensions for C++
public: static string* MaskValue(
   string* source
)
C++/CLI
public:
static String^ MaskValue(
   String^ source
)

Parameters

source
The original value.

Return Value

Returns the masked version of the value. Call UnmaskValue to obtain the original value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
OpenOrCreateRegistryKey Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : OpenOrCreateRegistryKey Method

key
The parent key to open from.
subkey
The path of the sub key to open. Sub key should be separated by \ characters.
Opens or creates a registry key.

Syntax

Visual Basic (Declaration)
Public Shared Function OpenOrCreateRegistryKey( _
   ByVal key As RegistryKey, _
   ByVal subkey As String _
) As RegistryKey
Visual Basic (Usage) Copy Code
Dim key As RegistryKey
Dim subkey As String
Dim value As RegistryKey

value = Limit.OpenOrCreateRegistryKey(key, subkey)
C#
public static RegistryKey OpenOrCreateRegistryKey(
   RegistryKey key,
   string subkey
)
Managed Extensions for C++
public: static RegistryKey* OpenOrCreateRegistryKey(
   RegistryKey* key,
   string* subkey
)
C++/CLI
public:
static RegistryKey^ OpenOrCreateRegistryKey(
   RegistryKey^ key,
   String^ subkey
)

Parameters

key
The parent key to open from.
subkey
The path of the sub key to open. Sub key should be separated by \ characters.

Return Value

Returns the opened or created registry key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ParseIPAddress Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ParseIPAddress Method

address
IPAddress to parse.
Parses an IPAddress to it's actual long value.

Syntax

Visual Basic (Declaration)
Public Shared Function ParseIPAddress( _
   ByVal address As IPAddress _
) As Long
Visual Basic (Usage) Copy Code
Dim address As IPAddress
Dim value As Long

value = Limit.ParseIPAddress(address)
C#
public static long ParseIPAddress(
   IPAddress address
)
Managed Extensions for C++
public: static long ParseIPAddress(
   IPAddress address
)
C++/CLI
public:
static long ParseIPAddress(
   IPAddress address
)

Parameters

address
IPAddress to parse.

Return Value

Returns the actual address of the IPAddress.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Peek Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Peek Method

context
The LicenseContext used to determine the environment and settings of the licensing.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user.

Syntax

Visual Basic (Declaration)
Public Overridable Function Peek( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object _
) As PeekResult
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim context As LicenseContext
Dim type As Type
Dim instance As Object
Dim value As PeekResult

value = instance.Peek(context, type, instance)
C#
public virtual PeekResult Peek(
   LicenseContext context,
   Type type,
   object instance
)
Managed Extensions for C++
public: virtual PeekResult Peek(
   LicenseContext context,
   Type* type,
   Object* instance
)
C++/CLI
public:
virtual PeekResult Peek(
   LicenseContext context,
   Type^ type,
   Object^ instance
)

Parameters

context
The LicenseContext used to determine the environment and settings of the licensing.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : SaveToXml Method

parent
The parent XmlNode to add child nodes to.
Saves the contents of the Limit as an XmlNode.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride Function SaveToXml( _
   ByVal parent As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim parent As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parent)
C#
public virtual abstract XmlNode SaveToXml(
   XmlNode parent
)
Managed Extensions for C++
public: virtual abstract XmlNode SaveToXml(
   XmlNode parent
)
C++/CLI
public:
virtual abstract XmlNode SaveToXml(
   XmlNode parent
)

Parameters

parent
The parent XmlNode to add child nodes to.

Return Value

Returns the saved XML node.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SelectCulture Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : SelectCulture Method

culture
The culture to select.
Selects the given culture for the current thread, and returns the previous culture.

Syntax

Visual Basic (Declaration)
Public Shared Function SelectCulture( _
   ByVal culture As CultureInfo _
) As CultureInfo
Visual Basic (Usage) Copy Code
Dim culture As CultureInfo
Dim value As CultureInfo

value = Limit.SelectCulture(culture)
C#
public static CultureInfo SelectCulture(
   CultureInfo culture
)
Managed Extensions for C++
public: static CultureInfo* SelectCulture(
   CultureInfo* culture
)
C++/CLI
public:
static CultureInfo^ SelectCulture(
   CultureInfo^ culture
)

Parameters

culture
The culture to select.

Return Value

Returns the previous culture.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SelectWebCulture Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : SelectWebCulture Method

Selects the culture of the current web request into the current thread, and returns the previous culture.

Syntax

Visual Basic (Declaration)
Public Shared Function SelectWebCulture() As CultureInfo
Visual Basic (Usage) Copy Code
Dim value As CultureInfo

value = Limit.SelectWebCulture()
C#
public static CultureInfo SelectWebCulture()
Managed Extensions for C++
public: static CultureInfo* SelectWebCulture();
C++/CLI
public:
static CultureInfo^ SelectWebCulture();

Return Value

Returns the previous culture.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
UnmaskValue Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : UnmaskValue Method

source
The original value.
Reverses the simple value obfuscation performed by MaskValue.

Syntax

Visual Basic (Declaration)
Public Shared Function UnmaskValue( _
   ByVal source As String _
) As String
Visual Basic (Usage) Copy Code
Dim source As String
Dim value As String

value = Limit.UnmaskValue(source)
C#
public static string UnmaskValue(
   string source
)
Managed Extensions for C++
public: static string* UnmaskValue(
   string* source
)
C++/CLI
public:
static String^ UnmaskValue(
   String^ source
)

Parameters

source
The original value.

Return Value

Returns the masked version of the value. Call UnmaskValue to obtain the original value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Validate Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Validate Method

context
The LicenseContext passed to GetLicense.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
Validates that the license being granted is within the limits enforced by this object.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride Function Validate( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim context As LicenseContext
Dim type As Type
Dim instance As Object
Dim value As Boolean

value = instance.Validate(context, type, instance)
C#
public virtual abstract bool Validate(
   LicenseContext context,
   Type type,
   object instance
)
Managed Extensions for C++
public: virtual abstract bool Validate(
   LicenseContext context,
   Type* type,
   Object* instance
)
C++/CLI
public:
virtual abstract bool Validate(
   LicenseContext context,
   Type^ type,
   Object^ instance
)

Parameters

context
The LicenseContext passed to GetLicense.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.

Return Value

Returns true if the limits are valid, otherwise false.

Remarks

If validation fails, limits should set their parent License's InvalidReason to a string explaining why it could not be validated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ValidateDomainName Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ValidateDomainName Method

domainName
The domain name to validate.
Validates the format of a domain name.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateDomainName( _
   ByVal domainName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim domainName As String
Dim value As Boolean

value = Limit.ValidateDomainName(domainName)
C#
public static bool ValidateDomainName(
   string domainName
)
Managed Extensions for C++
public: static bool ValidateDomainName(
   string* domainName
)
C++/CLI
public:
static bool ValidateDomainName(
   String^ domainName
)

Parameters

domainName
The domain name to validate.

Return Value

Returns true if the format of the domain name is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ValidateEmail Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ValidateEmail Method

email
The email address to validate.
Validates if the email is correctly formatted.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateEmail( _
   ByVal email As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim email As String
Dim value As Boolean

value = Limit.ValidateEmail(email)
C#
public static bool ValidateEmail(
   string email
)
Managed Extensions for C++
public: static bool ValidateEmail(
   string* email
)
C++/CLI
public:
static bool ValidateEmail(
   String^ email
)

Parameters

email
The email address to validate.

Return Value

Returns true if the email is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ValidateIPAddress Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ValidateIPAddress Method

address
The IP Address to validate.
Validates the format of an IP address.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateIPAddress( _
   ByVal address As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim address As String
Dim value As Boolean

value = Limit.ValidateIPAddress(address)
C#
public static bool ValidateIPAddress(
   string address
)
Managed Extensions for C++
public: static bool ValidateIPAddress(
   string* address
)
C++/CLI
public:
static bool ValidateIPAddress(
   String^ address
)

Parameters

address
The IP Address to validate.

Return Value

Returns true if the format of the address is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ValidateUrl Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ValidateUrl Method

url
The url to validate.
fullyQualified
Indicates if the url must be fully qualified. Containing a host and optional protocol.
Validates the url is correctly formatted.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateUrl( _
   ByVal url As String, _
   ByVal fullyQualified As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim url As String
Dim fullyQualified As Boolean
Dim value As Boolean

value = Limit.ValidateUrl(url, fullyQualified)
C#
public static bool ValidateUrl(
   string url,
   bool fullyQualified
)
Managed Extensions for C++
public: static bool ValidateUrl(
   string* url,
   bool fullyQualified
)
C++/CLI
public:
static bool ValidateUrl(
   String^ url,
   bool fullyQualified
)

Parameters

url
The url to validate.
fullyQualified
Indicates if the url must be fully qualified. Containing a host and optional protocol.

Return Value

Returns true if the url is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Windows Send comments on this topic.
Limit Class Properties
See Also
[image]
Xheo.Licensing Namespace : Limit Class

For a list of all members of this type, see Limit members.

Public Properties

 | Name | Description
Public Property | Description | Gets the description of the limit.
Public Property | IsGui | Gets a value that indicates if this Limit uses a GUI to interact with the user.
Public Property | IsRemote | Gets a value that indicates if this Limit uses remote processes (such as WebServices) for enforcement.
Public Property | IsTimeSensitive | Gets a value that indicates if the limit is time sensitive and the clock should be protected.
Public Property | License | Gets or sets a reference to the ExtendedLicense that contains this Limit.
Public Property | Name | Gets the display name of the limit.
Public Property | QualifiedTypeName | Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type.
Top

See Also

Reference

Limit Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Description Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Description Property

Gets the description of the limit.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride ReadOnly Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As String

value = instance.Description
C#
public virtual abstract string Description {get;}
Managed Extensions for C++
public: __property virtual abstract string* get_Description();
C++/CLI
public:
virtual abstract property String^ Description {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IsGui Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : IsGui Property

Gets a value that indicates if this Limit uses a GUI to interact with the user.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsGui As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As Boolean

value = instance.IsGui
C#
public virtual bool IsGui {get;}
Managed Extensions for C++
public: __property virtual bool get_IsGui();
C++/CLI
public:
virtual property bool IsGui {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IsRemote Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : IsRemote Property

Gets a value that indicates if this Limit uses remote processes (such as WebServices) for enforcement.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsRemote As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As Boolean

value = instance.IsRemote
C#
public virtual bool IsRemote {get;}
Managed Extensions for C++
public: __property virtual bool get_IsRemote();
C++/CLI
public:
virtual property bool IsRemote {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IsTimeSensitive Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : IsTimeSensitive Property

Gets a value that indicates if the limit is time sensitive and the clock should be protected.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsTimeSensitive As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As Boolean

value = instance.IsTimeSensitive
C#
public virtual bool IsTimeSensitive {get;}
Managed Extensions for C++
public: __property virtual bool get_IsTimeSensitive();
C++/CLI
public:
virtual property bool IsTimeSensitive {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
License Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : License Property

Gets or sets a reference to the ExtendedLicense that contains this Limit.

Syntax

Visual Basic (Declaration)
Public Property License As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As ExtendedLicense

instance.License = value

value = instance.License
C#
public ExtendedLicense License {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_License();
public: __property void set_License(
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ License {
   ExtendedLicense^ get();
   void set (ExtendedLicense^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Name Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Name Property

Gets the display name of the limit.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As String

value = instance.Name
C#
public virtual abstract string Name {get;}
Managed Extensions for C++
public: __property virtual abstract string* get_Name();
C++/CLI
public:
virtual abstract property String^ Name {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
QualifiedTypeName Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : QualifiedTypeName Property

Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property QualifiedTypeName As String
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As String

value = instance.QualifiedTypeName
C#
public virtual string QualifiedTypeName {get;}
Managed Extensions for C++
public: __property virtual string* get_QualifiedTypeName();
C++/CLI
public:
virtual property String^ QualifiedTypeName {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LimitCollection Class
See Also Members
[image]
Xheo.Licensing Namespace : LimitCollection Class

Services as a collection of limits.

Object Model

Syntax

Visual Basic (Declaration)
Private Class LimitCollection
   Inherits TransientReadOnlyCollection
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
C#
private class LimitCollection : TransientReadOnlyCollection
Managed Extensions for C++
private __gc class LimitCollection : public TransientReadOnlyCollection
C++/CLI
private ref class LimitCollection : public TransientReadOnlyCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Xheo.Licensing.TransientReadOnlyCollection
Xheo.Licensing.LimitCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
LimitCollection Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : LimitCollection Class

The following tables list the members exposed by LimitCollection.

Public Constructors

 | Name | Description
Public Constructor | LimitCollection Constructor | Overloaded. Initializes a new instance of the LimitCollection class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating if the collection is read only. (Inherited from TransientReadOnlyCollection)
Public Property | Item | Gets or sets a limit at the given index.
Public Property | License | Gets or sets a reference to the containing license.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a new limit to the collection.
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines if the collection contains the given Limit.
Public Method | CopyTo | Copies the collection to an array.
Public Method | FromXmlString | Loads the contents of the limit collection from an XML string.
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetPrioritizedOrder | Gets the limits in order of priority.
Public Method | Granted | Called every time the limit is granted.
Public Method | IndexOf | Gets the index of the given limit.
Public Method | Insert | Inserts the limit at the given index.
Public Method | LoadFromXml | Loads the contents of a LimitCollection from an XmlNode.
Public Method | Remove | Removes the given index from the list.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | SaveToXml | Saves the contents of the LimitCollection to the given XmlNode.
Public Method | SetReadOnly | Sets the collection to a read only state. This cannot be reversed. (Inherited from TransientReadOnlyCollection)
Public Method | ToXmlString | Saves the contents of the limit collection to an XML string.
Public Method | Validate | Ensures that all the Limits in the collection are valid for the given type and context.
Top

See Also

Reference

LimitCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LimitCollection Constructor
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : LimitCollection Constructor

Initializes a new instance of the LimitCollection class.

Overload List

Overload | Description
LimitCollection Constructor() | Included for COM compliance, do not use.
LimitCollection Constructor(ExtendedLicense) | Initializes a new instance of the LimitCollection class.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LimitCollection Constructor()
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class > LimitCollection Constructor : LimitCollection Constructor()

Included for COM compliance, do not use.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection()
C#
public LimitCollection()
Managed Extensions for C++
public: LimitCollection();
C++/CLI
public:
LimitCollection();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LimitCollection Constructor(ExtendedLicense)
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class > LimitCollection Constructor : LimitCollection Constructor(ExtendedLicense)

license
Reference to the containing ExtendedLicense.
Initializes a new instance of the LimitCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim license As ExtendedLicense

Dim instance As LimitCollection(license)
C#
public LimitCollection(
   ExtendedLicense license
)
Managed Extensions for C++
public: LimitCollection(
   ExtendedLicense* license
)
C++/CLI
public:
LimitCollection(
   ExtendedLicense^ license
)

Parameters

license
Reference to the containing ExtendedLicense.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
LimitCollection Class Methods
See Also
[image]
Xheo.Licensing Namespace : LimitCollection Class

For a list of all members of this type, see LimitCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a new limit to the collection.
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines if the collection contains the given Limit.
Public Method | CopyTo | Copies the collection to an array.
Public Method | FromXmlString | Loads the contents of the limit collection from an XML string.
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetPrioritizedOrder | Gets the limits in order of priority.
Public Method | Granted | Called every time the limit is granted.
Public Method | IndexOf | Gets the index of the given limit.
Public Method | Insert | Inserts the limit at the given index.
Public Method | LoadFromXml | Loads the contents of a LimitCollection from an XmlNode.
Public Method | Remove | Removes the given index from the list.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | SaveToXml | Saves the contents of the LimitCollection to the given XmlNode.
Public Method | SetReadOnly | Sets the collection to a read only state. This cannot be reversed. (Inherited from TransientReadOnlyCollection)
Public Method | ToXmlString | Saves the contents of the limit collection to an XML string.
Public Method | Validate | Ensures that all the Limits in the collection are valid for the given type and context.
Top

See Also

Reference

LimitCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Add Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Add Method

limit
The limit to add.
Adds a new limit to the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal limit As Limit _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim limit As Limit

instance.Add(limit)
C#
public void Add(
   Limit limit
)
Managed Extensions for C++
public: void Add(
   Limit* limit
)
C++/CLI
public:
void Add(
   Limit^ limit
)

Parameters

limit
The limit to add.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Contains Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Contains Method

limit
The Limit to look for.
Determines if the collection contains the given Limit.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal limit As Limit _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim limit As Limit
Dim value As Boolean

value = instance.Contains(limit)
C#
public bool Contains(
   Limit limit
)
Managed Extensions for C++
public: bool Contains(
   Limit* limit
)
C++/CLI
public:
bool Contains(
   Limit^ limit
)

Parameters

limit
The Limit to look for.

Return Value

Returns true if the Limit is found, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
CopyTo Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : CopyTo Method

array
The array to copy to.
index
The index in the array to begin copying.
Copies the collection to an array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As Limit, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim array() As Limit
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   Limit[] array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   Limit*[] array,
   int index
)
C++/CLI
public:
void CopyTo(
   array<Limit^> array,
   int index
)

Parameters

array
The array to copy to.
index
The index in the array to begin copying.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : FromXmlString Method

xml
The XML string to load from.
Loads the contents of the limit collection from an XML string.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
The XML string to load from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetPrioritizedOrder Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : GetPrioritizedOrder Method

includeRemote
Indicates if remote limits should be included.
Gets the limits in order of priority.

Syntax

Visual Basic (Declaration)
Public Function GetPrioritizedOrder( _
   ByVal includeRemote As Boolean _
) As LimitCollection
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim includeRemote As Boolean
Dim value As LimitCollection

value = instance.GetPrioritizedOrder(includeRemote)
C#
public LimitCollection GetPrioritizedOrder(
   bool includeRemote
)
Managed Extensions for C++
public: LimitCollection* GetPrioritizedOrder(
   bool includeRemote
)
C++/CLI
public:
LimitCollection^ GetPrioritizedOrder(
   bool includeRemote
)

Parameters

includeRemote
Indicates if remote limits should be included.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Granted Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Granted Method

context
type
instance
Called every time the limit is granted.

Syntax

Visual Basic (Declaration)
Public Sub Granted( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim context As LicenseContext
Dim type As Type
Dim instance As Object

instance.Granted(context, type, instance)
C#
public void Granted(
   LicenseContext context,
   Type type,
   object instance
)
Managed Extensions for C++
public: void Granted(
   LicenseContext context,
   Type* type,
   Object* instance
)
C++/CLI
public:
void Granted(
   LicenseContext context,
   Type^ type,
   Object^ instance
)

Parameters

context
type
instance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IndexOf Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : IndexOf Method

limit
The limit to look for.
Gets the index of the given limit.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal limit As Limit _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim limit As Limit
Dim value As Integer

value = instance.IndexOf(limit)
C#
public int IndexOf(
   Limit limit
)
Managed Extensions for C++
public: int IndexOf(
   Limit* limit
)
C++/CLI
public:
int IndexOf(
   Limit^ limit
)

Parameters

limit
The limit to look for.

Return Value

Returns the index of the given limit if found, otherwise -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Insert Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Insert Method

index
The index where to insert the limit.
limit
The limit to insert.
Inserts the limit at the given index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal limit As Limit _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim index As Integer
Dim limit As Limit

instance.Insert(index, limit)
C#
public void Insert(
   int index,
   Limit limit
)
Managed Extensions for C++
public: void Insert(
   int index,
   Limit* limit
)
C++/CLI
public:
void Insert(
   int index,
   Limit^ limit
)

Parameters

index
The index where to insert the limit.
limit
The limit to insert.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : LoadFromXml Method

node
Loads the contents of a LimitCollection from an XmlNode.

Syntax

Visual Basic (Declaration)
Public Function LoadFromXml( _
   ByVal node As XmlNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim node As XmlNode
Dim value As Boolean

value = instance.LoadFromXml(node)
C#
public bool LoadFromXml(
   XmlNode node
)
Managed Extensions for C++
public: bool LoadFromXml(
   XmlNode node
)
C++/CLI
public:
bool LoadFromXml(
   XmlNode node
)

Parameters

node

Return Value

Returns true if the load was successful, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Remove Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Remove Method

limit
The limit to remove.
Removes the given index from the list.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal limit As Limit _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim limit As Limit

instance.Remove(limit)
C#
public void Remove(
   Limit limit
)
Managed Extensions for C++
public: void Remove(
   Limit* limit
)
C++/CLI
public:
void Remove(
   Limit^ limit
)

Parameters

limit
The limit to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : SaveToXml Method

parent
The parent XmlNode.
Saves the contents of the LimitCollection to the given XmlNode.

Syntax

Visual Basic (Declaration)
Public Function SaveToXml( _
   ByVal parent As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim parent As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parent)
C#
public XmlNode SaveToXml(
   XmlNode parent
)
Managed Extensions for C++
public: XmlNode SaveToXml(
   XmlNode parent
)
C++/CLI
public:
XmlNode SaveToXml(
   XmlNode parent
)

Parameters

parent
The parent XmlNode.

Return Value

Returns the root node of the saved limits.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : ToXmlString Method

Saves the contents of the limit collection to an XML string.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim value As String

value = instance.ToXmlString()
C#
public string ToXmlString()
Managed Extensions for C++
public: string* ToXmlString();
C++/CLI
public:
String^ ToXmlString();

Return Value

The saved XML.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Validate Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Validate Method

context
The LicenseContext passed to GetLicense.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
includeRemote
Indicates if limits that have IsRemote set to true should be included in the validation.
Ensures that all the Limits in the collection are valid for the given type and context.

Syntax

Visual Basic (Declaration)
Public Overridable Function Validate( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object, _
   ByVal includeRemote As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim context As LicenseContext
Dim type As Type
Dim instance As Object
Dim includeRemote As Boolean
Dim value As Boolean

value = instance.Validate(context, type, instance, includeRemote)
C#
public virtual bool Validate(
   LicenseContext context,
   Type type,
   object instance,
   bool includeRemote
)
Managed Extensions for C++
public: virtual bool Validate(
   LicenseContext context,
   Type* type,
   Object* instance,
   bool includeRemote
)
C++/CLI
public:
virtual bool Validate(
   LicenseContext context,
   Type^ type,
   Object^ instance,
   bool includeRemote
)

Parameters

context
The LicenseContext passed to GetLicense.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
includeRemote
Indicates if limits that have IsRemote set to true should be included in the validation.

Return Value

Returns true if the limits are valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Windows Send comments on this topic.
LimitCollection Class Properties
See Also
[image]
Xheo.Licensing Namespace : LimitCollection Class

For a list of all members of this type, see LimitCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating if the collection is read only. (Inherited from TransientReadOnlyCollection)
Public Property | Item | Gets or sets a limit at the given index.
Public Property | License | Gets or sets a reference to the containing license.
Top

See Also

Reference

LimitCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Item Property
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Item Property

index
Gets or sets a limit at the given index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Limit
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim index As Integer
Dim value As Limit

instance.Item(index) = value

value = instance.Item(index)
C#
public Limit this[
   int index
]; {get; set;}
Managed Extensions for C++
public: __property Limit* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   Limit* value
);
C++/CLI
public:
property Limit^ default [int] {
   Limit^ get(int index);
   void set (int index, Limit^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
License Property
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : License Property

Gets or sets a reference to the containing license.

Syntax

Visual Basic (Declaration)
Public Property License As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim value As ExtendedLicense

instance.License = value

value = instance.License
C#
public ExtendedLicense License {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_License();
public: __property void set_License(
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ License {
   ExtendedLicense^ get();
   void set (ExtendedLicense^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MachineProfile Class
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile Class

Manages a machine profile used by the license activation system. Profiles represent a collection of generally non volitale system properties that can collectively be used to identify certain machines.

Syntax

Visual Basic (Declaration)
Private NotInheritable Class MachineProfile
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
C#
private sealed class MachineProfile
Managed Extensions for C++
private __gc __sealed class MachineProfile
C++/CLI
private ref class MachineProfile sealed

Inheritance Hierarchy

System.Object
Xheo.Licensing.MachineProfile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : MachineProfile Class

The following tables list the members exposed by MachineProfile.

Public Constructors

 | Name | Description
Public Constructor | MachineProfile Constructor | Initializes a new instance of the MachineProfile class.
Top

Public Properties

 | Name | Description
Public Property | Hash | Gets the comparable hash for the MachineProfile.
static (Shared in Visual Basic) | Profile | Gets the profile of the current machine.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CompareHash | Compares two machine profile hashes and determines the amount of difference.
Public Method | CompareTo | Determines if the MachineProfile is comparatively similar to the given hash.
Public Method | GetComparableHash | Overloaded. Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.
static (Shared in Visual Basic) | GetDifferences | Gets the name of the hardware types that are different between the two hashes.
Top

See Also

Reference

MachineProfile Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MachineProfile Constructor
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : MachineProfile Constructor

Initializes a new instance of the MachineProfile class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile()
C#
public MachineProfile()
Managed Extensions for C++
public: MachineProfile();
C++/CLI
public:
MachineProfile();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile Class Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile Class

For a list of all members of this type, see MachineProfile members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CompareHash | Compares two machine profile hashes and determines the amount of difference.
Public Method | CompareTo | Determines if the MachineProfile is comparatively similar to the given hash.
Public Method | GetComparableHash | Overloaded. Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.
static (Shared in Visual Basic) | GetDifferences | Gets the name of the hardware types that are different between the two hashes.
Top

See Also

Reference

MachineProfile Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
CompareHash Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : CompareHash Method

hash
The of the machine to compare.
comparedHash
The hashed value of another machine profile to compare to.
Compares two machine profile hashes and determines the amount of difference.

Syntax

Visual Basic (Declaration)
Public Shared Function CompareHash( _
   ByVal hash As String, _
   ByVal comparedHash As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim hash As String
Dim comparedHash As String
Dim value As Integer

value = MachineProfile.CompareHash(hash, comparedHash)
C#
public static int CompareHash(
   string hash,
   string comparedHash
)
Managed Extensions for C++
public: static int CompareHash(
   string* hash,
   string* comparedHash
)
C++/CLI
public:
static int CompareHash(
   String^ hash,
   String^ comparedHash
)

Parameters

hash
The of the machine to compare.
comparedHash
The hashed value of another machine profile to compare to.

Return Value

Returns the difference rating from 0 (same) to 10 (very different).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
CompareTo Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : CompareTo Method

profileHash
The hash to compare to.
tolerance
The tolerance level.
Determines if the MachineProfile is comparatively similar to the given hash.

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal profileHash As String, _
   ByVal tolerance As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
Dim profileHash As String
Dim tolerance As Integer
Dim value As Boolean

value = instance.CompareTo(profileHash, tolerance)
C#
public bool CompareTo(
   string profileHash,
   int tolerance
)
Managed Extensions for C++
public: bool CompareTo(
   string* profileHash,
   int tolerance
)
C++/CLI
public:
bool CompareTo(
   String^ profileHash,
   int tolerance
)

Parameters

profileHash
The hash to compare to.
tolerance
The tolerance level.

Return Value

Returns true if the current machine profile is within the tolerance level of the given profile hash.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetComparableHash Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : GetComparableHash Method

Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.

Overload List

Overload | Description
GetComparableHash(Version) | Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.
GetComparableHash() | Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetComparableHash(Version) Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class > GetComparableHash Method : GetComparableHash(Version) Method

version
The hash version to generate. Use to create backwards compatible hash codes.
Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetComparableHash( _
   ByVal version As Version _
) As String
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
Dim version As Version
Dim value As String

value = instance.GetComparableHash(version)
C#
public string GetComparableHash(
   Version version
)
Managed Extensions for C++
public: string* GetComparableHash(
   Version* version
)
C++/CLI
public:
String^ GetComparableHash(
   Version^ version
)

Parameters

version
The hash version to generate. Use to create backwards compatible hash codes.

Return Value

Returns a comparable has for the current machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetComparableHash() Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class > GetComparableHash Method : GetComparableHash() Method

Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetComparableHash() As String
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
Dim value As String

value = instance.GetComparableHash()
C#
public string GetComparableHash()
Managed Extensions for C++
public: string* GetComparableHash();
C++/CLI
public:
String^ GetComparableHash();

Return Value

Returns a comparable has for the current machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetDifferences Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : GetDifferences Method

hash
The of the machine to compare.
comparedHash
The hashed value of another machine profile to compare to.
Gets the name of the hardware types that are different between the two hashes.

Syntax

Visual Basic (Declaration)
Public Shared Function GetDifferences( _
   ByVal hash As String, _
   ByVal comparedHash As String _
) As String()
Visual Basic (Usage) Copy Code
Dim hash As String
Dim comparedHash As String
Dim value() As String

value = MachineProfile.GetDifferences(hash, comparedHash)
C#
public static string[] GetDifferences(
   string hash,
   string comparedHash
)
Managed Extensions for C++
public: static string*[] GetDifferences(
   string* hash,
   string* comparedHash
)
C++/CLI
public:
static array<String^> GetDifferences(
   String^ hash,
   String^ comparedHash
)

Parameters

hash
The of the machine to compare.
comparedHash
The hashed value of another machine profile to compare to.

Return Value

Returns the collection of hardware changes detected between the two hashes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile Class Properties
See Also
[image]
Xheo.Licensing Namespace : MachineProfile Class

For a list of all members of this type, see MachineProfile members.

Public Properties

 | Name | Description
Public Property | Hash | Gets the comparable hash for the MachineProfile.
static (Shared in Visual Basic) | Profile | Gets the profile of the current machine.
Top

See Also

Reference

MachineProfile Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Hash Property
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : Hash Property

Gets the comparable hash for the MachineProfile.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hash As String
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
Dim value As String

value = instance.Hash
C#
public string Hash {get;}
Managed Extensions for C++
public: __property string* get_Hash();
C++/CLI
public:
property String^ Hash {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Profile Property
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : Profile Property

Gets the profile of the current machine.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Profile As MachineProfile
Visual Basic (Usage) Copy Code
Dim value As MachineProfile

value = MachineProfile.Profile
C#
public static MachineProfile Profile {get;}
Managed Extensions for C++
public: __property static MachineProfile* get_Profile();
C++/CLI
public:
static property MachineProfile^ Profile {
   MachineProfile^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MachineProfile.Constants Class
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.Constants Class

A class to contain the constants required for the IP_ADAPTER_INFO struct

Syntax

Visual Basic (Declaration)
Private Class MachineProfile.Constants
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.Constants
C#
private class MachineProfile.Constants
Managed Extensions for C++
private __gc class MachineProfile.Constants
C++/CLI
private ref class MachineProfile.Constants

Inheritance Hierarchy

System.Object
Xheo.Licensing.MachineProfile.Constants

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile.Constants Class Members
See Also Fields
[image]
Xheo.Licensing Namespace : MachineProfile.Constants Class

The following tables list the members exposed by MachineProfile.Constants.

Public Constructors

 | Name | Description
Public Constructor | MachineProfile.Constants Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MAX_ADAPTER_ADDRESS_LENGTH | The maximum length for the physical address of the adapter
static (Shared in Visual Basic) | MAX_ADAPTER_DESCRIPTION_LENGTH | The maximum length of the description of an adapter
static (Shared in Visual Basic) | MAX_ADAPTER_NAME_LENGTH | The maximum length of an adapter name
Top

See Also

Reference

MachineProfile.Constants Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MachineProfile.Constants Constructor
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.Constants Class : MachineProfile.Constants Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.Constants()
C#
public MachineProfile.Constants()
Managed Extensions for C++
public: MachineProfile.Constants();
C++/CLI
public:
MachineProfile.Constants();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Class
MachineProfile.Constants Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile.Constants Class Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.Constants Class

For a list of all members of this type, see MachineProfile.Constants members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MAX_ADAPTER_ADDRESS_LENGTH | The maximum length for the physical address of the adapter
static (Shared in Visual Basic) | MAX_ADAPTER_DESCRIPTION_LENGTH | The maximum length of the description of an adapter
static (Shared in Visual Basic) | MAX_ADAPTER_NAME_LENGTH | The maximum length of an adapter name
Top

See Also

Reference

MachineProfile.Constants Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MAX_ADAPTER_ADDRESS_LENGTH Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.Constants Class : MAX_ADAPTER_ADDRESS_LENGTH Field

The maximum length for the physical address of the adapter

Syntax

Visual Basic (Declaration)
Public Shared MAX_ADAPTER_ADDRESS_LENGTH As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = MachineProfile.Constants.MAX_ADAPTER_ADDRESS_LENGTH

MachineProfile.Constants.MAX_ADAPTER_ADDRESS_LENGTH = value
C#
public static int MAX_ADAPTER_ADDRESS_LENGTH
Managed Extensions for C++
public: static int MAX_ADAPTER_ADDRESS_LENGTH
C++/CLI
public:
static int MAX_ADAPTER_ADDRESS_LENGTH

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Class
MachineProfile.Constants Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MAX_ADAPTER_DESCRIPTION_LENGTH Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.Constants Class : MAX_ADAPTER_DESCRIPTION_LENGTH Field

The maximum length of the description of an adapter

Syntax

Visual Basic (Declaration)
Public Shared MAX_ADAPTER_DESCRIPTION_LENGTH As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = MachineProfile.Constants.MAX_ADAPTER_DESCRIPTION_LENGTH

MachineProfile.Constants.MAX_ADAPTER_DESCRIPTION_LENGTH = value
C#
public static int MAX_ADAPTER_DESCRIPTION_LENGTH
Managed Extensions for C++
public: static int MAX_ADAPTER_DESCRIPTION_LENGTH
C++/CLI
public:
static int MAX_ADAPTER_DESCRIPTION_LENGTH

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Class
MachineProfile.Constants Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MAX_ADAPTER_NAME_LENGTH Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.Constants Class : MAX_ADAPTER_NAME_LENGTH Field

The maximum length of an adapter name

Syntax

Visual Basic (Declaration)
Public Shared MAX_ADAPTER_NAME_LENGTH As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = MachineProfile.Constants.MAX_ADAPTER_NAME_LENGTH

MachineProfile.Constants.MAX_ADAPTER_NAME_LENGTH = value
C#
public static int MAX_ADAPTER_NAME_LENGTH
Managed Extensions for C++
public: static int MAX_ADAPTER_NAME_LENGTH
C++/CLI
public:
static int MAX_ADAPTER_NAME_LENGTH

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Class
MachineProfile.Constants Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MachineProfile.GetAdapterInfo Class
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.GetAdapterInfo Class

Uses the windows API to retrieve information about the IP configuration of the local machine

Syntax

Visual Basic (Declaration)
Private Class MachineProfile.GetAdapterInfo
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.GetAdapterInfo
C#
private class MachineProfile.GetAdapterInfo
Managed Extensions for C++
private __gc class MachineProfile.GetAdapterInfo
C++/CLI
private ref class MachineProfile.GetAdapterInfo

Inheritance Hierarchy

System.Object
Xheo.Licensing.MachineProfile.GetAdapterInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.GetAdapterInfo Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile.GetAdapterInfo Class Members
See Also Methods
[image]
Xheo.Licensing Namespace : MachineProfile.GetAdapterInfo Class

The following tables list the members exposed by MachineProfile.GetAdapterInfo.

Public Constructors

 | Name | Description
Public Constructor | MachineProfile.GetAdapterInfo Constructor | Constructor for the GetAdapterInfo Class
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetAdapters | Gets details of all the adapters on the local machine
static (Shared in Visual Basic) | GetFirstAdapter | Gets the details of the first available adapter on the local machine
Top

See Also

Reference

MachineProfile.GetAdapterInfo Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MachineProfile.GetAdapterInfo Constructor
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.GetAdapterInfo Class : MachineProfile.GetAdapterInfo Constructor

Constructor for the GetAdapterInfo Class

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.GetAdapterInfo()
C#
public MachineProfile.GetAdapterInfo()
Managed Extensions for C++
public: MachineProfile.GetAdapterInfo();
C++/CLI
public:
MachineProfile.GetAdapterInfo();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.GetAdapterInfo Class
MachineProfile.GetAdapterInfo Members


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile.GetAdapterInfo Class Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.GetAdapterInfo Class

For a list of all members of this type, see MachineProfile.GetAdapterInfo members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetAdapters | Gets details of all the adapters on the local machine
static (Shared in Visual Basic) | GetFirstAdapter | Gets the details of the first available adapter on the local machine
Top

See Also

Reference

MachineProfile.GetAdapterInfo Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetAdapters Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.GetAdapterInfo Class : GetAdapters Method

Gets details of all the adapters on the local machine

Syntax

Visual Basic (Declaration)
Public Shared Function GetAdapters() As ArrayList
Visual Basic (Usage) Copy Code
Dim value As ArrayList

value = MachineProfile.GetAdapterInfo.GetAdapters()
C#
public static ArrayList GetAdapters()
Managed Extensions for C++
public: static ArrayList* GetAdapters();
C++/CLI
public:
static ArrayList^ GetAdapters();

Return Value

The return object is a System.Collections.ArrayList of IPConfig.IP_ADAPTERINFO_STRUCTURE structs containing data about the Adapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.GetAdapterInfo Class
MachineProfile.GetAdapterInfo Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GetFirstAdapter Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.GetAdapterInfo Class : GetFirstAdapter Method

Gets the details of the first available adapter on the local machine

Syntax

Visual Basic (Declaration)
Public Shared Function GetFirstAdapter() As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Visual Basic (Usage) Copy Code
Dim value As MachineProfile.IP_ADAPTERINFO_STRUCTURE

value = MachineProfile.GetAdapterInfo.GetFirstAdapter()
C#
public static MachineProfile.IP_ADAPTERINFO_STRUCTURE GetFirstAdapter()
Managed Extensions for C++
public: static MachineProfile.IP_ADAPTERINFO_STRUCTURE GetFirstAdapter();
C++/CLI
public:
static MachineProfile.IP_ADAPTERINFO_STRUCTURE GetFirstAdapter();

Return Value

The return value is an struct of type IP_ADAPTERINFO_STRUCTURE containing data about the Adapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.GetAdapterInfo Class
MachineProfile.GetAdapterInfo Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
StateEntry Class
See Also Members
[image]
Xheo.Licensing Namespace : StateEntry Class

Syntax

Visual Basic (Declaration)
Private Class StateEntry
Visual Basic (Usage) Copy Code
Dim instance As StateEntry
C#
private class StateEntry
Managed Extensions for C++
private __gc class StateEntry
C++/CLI
private ref class StateEntry

Inheritance Hierarchy

System.Object
Xheo.Licensing.StateEntry

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateEntry Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
StateEntry Class Members
See Also Fields
[image]
Xheo.Licensing Namespace : StateEntry Class

The following tables list the members exposed by StateEntry.

Public Constructors

 | Name | Description
Public Constructor | StateEntry Constructor |
Top

Public Fields

 | Name | Description
Public Field | LastUsed |
Public Field | SessionState |
Top

See Also

Reference

StateEntry Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
StateEntry Constructor
See Also
[image]
Xheo.Licensing Namespace > StateEntry Class : StateEntry Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StateEntry()
C#
public StateEntry()
Managed Extensions for C++
public: StateEntry();
C++/CLI
public:
StateEntry();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateEntry Class
StateEntry Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.Windows Send comments on this topic.
StateEntry Class Fields
See Also
[image]
Xheo.Licensing Namespace : StateEntry Class

For a list of all members of this type, see StateEntry members.

Public Fields

 | Name | Description
Public Field | LastUsed |
Public Field | SessionState |
Top

See Also

Reference

StateEntry Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LastUsed Field
See Also
[image]
Xheo.Licensing Namespace > StateEntry Class : LastUsed Field

Syntax

Visual Basic (Declaration)
Public LastUsed As Date
Visual Basic (Usage) Copy Code
Dim instance As StateEntry
Dim value As Date

value = instance.LastUsed

instance.LastUsed = value
C#
public DateTime LastUsed
Managed Extensions for C++
public: DateTime LastUsed
C++/CLI
public:
DateTime LastUsed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateEntry Class
StateEntry Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SessionState Field
See Also
[image]
Xheo.Licensing Namespace > StateEntry Class : SessionState Field

Syntax

Visual Basic (Declaration)
Public SessionState As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As StateEntry
Dim value As Hashtable

value = instance.SessionState

instance.SessionState = value
C#
public Hashtable SessionState
Managed Extensions for C++
public: Hashtable* SessionState
C++/CLI
public:
Hashtable^ SessionState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateEntry Class
StateEntry Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
TransientReadOnlyCollection Class
See Also Members
[image]
Xheo.Licensing Namespace : TransientReadOnlyCollection Class

Implements a transient read only collection. Values can be added, removed and changed until the SetReadOnly method is called thus forcing the collection to a read only state.

Syntax

Visual Basic (Declaration)
Private MustInherit Class TransientReadOnlyCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As TransientReadOnlyCollection
C#
private abstract class TransientReadOnlyCollection : CollectionBase
Managed Extensions for C++
private __gc abstract class TransientReadOnlyCollection : public CollectionBase
C++/CLI
private ref class TransientReadOnlyCollection abstract : public CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Xheo.Licensing.TransientReadOnlyCollection
Xheo.Licensing.LimitCollection
Xheo.Licensing.LimitCollection
Xheo.Licensing.LimitCollection
Xheo.Licensing.LimitCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TransientReadOnlyCollection Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
TransientReadOnlyCollection Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : TransientReadOnlyCollection Class

The following tables list the members exposed by TransientReadOnlyCollection.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating if the collection is read only.
Top

Public Methods

 | Name | Description
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | SetReadOnly | Sets the collection to a read only state. This cannot be reversed.
Top

See Also

Reference

TransientReadOnlyCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
TransientReadOnlyCollection Class Methods
See Also
[image]
Xheo.Licensing Namespace : TransientReadOnlyCollection Class

For a list of all members of this type, see TransientReadOnlyCollection members.

Public Methods

 | Name | Description
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | SetReadOnly | Sets the collection to a read only state. This cannot be reversed.
Top

See Also

Reference

TransientReadOnlyCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SetReadOnly Method
See Also
[image]
Xheo.Licensing Namespace > TransientReadOnlyCollection Class : SetReadOnly Method

Sets the collection to a read only state. This cannot be reversed.

Syntax

Visual Basic (Declaration)
Public Sub SetReadOnly()
Visual Basic (Usage) Copy Code
Dim instance As TransientReadOnlyCollection

instance.SetReadOnly()
C#
public void SetReadOnly()
Managed Extensions for C++
public: void SetReadOnly();
C++/CLI
public:
void SetReadOnly();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TransientReadOnlyCollection Class
TransientReadOnlyCollection Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Windows Send comments on this topic.
TransientReadOnlyCollection Class Properties
See Also
[image]
Xheo.Licensing Namespace : TransientReadOnlyCollection Class

For a list of all members of this type, see TransientReadOnlyCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating if the collection is read only.
Top

See Also

Reference

TransientReadOnlyCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IsReadOnly Property
See Also
[image]
Xheo.Licensing Namespace > TransientReadOnlyCollection Class : IsReadOnly Property

Gets a value indicating if the collection is read only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TransientReadOnlyCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TransientReadOnlyCollection Class
TransientReadOnlyCollection Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
PeekResult Enumeration
See Also
[image]
Xheo.Licensing Namespace : PeekResult Enumeration

Possible results from the Peek method.

Syntax

Visual Basic (Declaration)
Private Enum PeekResult
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PeekResult
C#
private enum PeekResult : Enum
Managed Extensions for C++
__value private enum PeekResult : public Enum
C++/CLI
private enum class PeekResult : public Enum

Members

Member | Description
Unknown | Unkonwn status.
Valid | The limit is valid in it's current state and Validate will return true without any user interaction.
Invalid | The limit is invalid. Calling Validate may require user interaction.
NeedsUser | The limit may be valid but will require user interaction to ensure.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xheo.Licensing.PeekResult

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SerialNumberSizes Enumeration
See Also
[image]
Xheo.Licensing Namespace : SerialNumberSizes Enumeration

Possible key sizes for use when generating serial numbers. More bits makes it more difficult to crack but also increase the size of the serial number.

Syntax

Visual Basic (Declaration)
Private Enum SerialNumberSizes
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As SerialNumberSizes
C#
private enum SerialNumberSizes : Enum
Managed Extensions for C++
__value private enum SerialNumberSizes : public Enum
C++/CLI
private enum class SerialNumberSizes : public Enum

Members

Member | Description
None | Indicates that no serial number sizes are valid.
Small | Uses a key of 64 bits in length. Generates a serial number ~13 characters in length. Recommended group size = 4.
Medium | Uses a key of 96 bits in length. Generates a serial number ~20 characters in length. Recommended group size = 5.
Large | Uses a key of 128 bits in length. Generates a serial number ~25 characters in length. Recommended group size = 5.
Huge | Uses a key of 320 bits in length. Generates a serial number ~64 characters in length. Recommended group size = 8.
All | Allow any of the stored serial number sizes.
MediumAndBigger | Allow the medium and bigger sizes.
LargeAndBigger | Allow the large and bigger sizes.
Recommended | Recommended sizes for licenses.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xheo.Licensing.SerialNumberSizes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LicenseSigningKey.KeyRecord Structure
See Also Members
[image]
Xheo.Licensing Namespace : LicenseSigningKey.KeyRecord Structure

Object Model

Syntax

Visual Basic (Declaration)
Private Structure LicenseSigningKey.KeyRecord
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
C#
private struct LicenseSigningKey.KeyRecord : ValueType
Managed Extensions for C++
private __value struct LicenseSigningKey.KeyRecord : public ValueType
C++/CLI
private value class LicenseSigningKey.KeyRecord : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.LicenseSigningKey.KeyRecord

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
LicenseSigningKey.KeyRecord Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : LicenseSigningKey.KeyRecord Structure

The following tables list the members exposed by LicenseSigningKey.KeyRecord.

Public Constructors

 | Name | Description
Public Constructor | LicenseSigningKey.KeyRecord Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Bits |
Public Field | d |
Public Field | e |
Public Field | n |
Public Field | p |
Public Field | q |
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Public Method | VerifyKey |
Top

See Also

Reference

LicenseSigningKey.KeyRecord Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LicenseSigningKey.KeyRecord Constructor
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : LicenseSigningKey.KeyRecord Constructor

Overload List

Overload | Description
LicenseSigningKey.KeyRecord Constructor(BigInteger,BigInteger,BigInteger,BigInteger,BigInteger,Int32) |
LicenseSigningKey.KeyRecord Constructor(Int32) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LicenseSigningKey.KeyRecord Constructor(BigInteger,BigInteger,BigInteger,BigInteger,BigInteger,Int32)
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure > LicenseSigningKey.KeyRecord Constructor : LicenseSigningKey.KeyRecord Constructor(BigInteger,BigInteger,BigInteger,BigInteger,BigInteger,Int32)

p
q
e
n
d
bits

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal p As BigInteger, _
   ByVal q As BigInteger, _
   ByVal e As BigInteger, _
   ByVal n As BigInteger, _
   ByVal d As BigInteger, _
   ByVal bits As Integer _
)
Visual Basic (Usage) Copy Code
Dim p As BigInteger
Dim q As BigInteger
Dim e As BigInteger
Dim n As BigInteger
Dim d As BigInteger
Dim bits As Integer

Dim instance As LicenseSigningKey.KeyRecord(p, q, e, n, d, bits)
C#
public LicenseSigningKey.KeyRecord(
   BigInteger p,
   BigInteger q,
   BigInteger e,
   BigInteger n,
   BigInteger d,
   int bits
)
Managed Extensions for C++
public: LicenseSigningKey.KeyRecord(
   BigInteger* p,
   BigInteger* q,
   BigInteger* e,
   BigInteger* n,
   BigInteger* d,
   int bits
)
C++/CLI
public:
LicenseSigningKey.KeyRecord(
   BigInteger^ p,
   BigInteger^ q,
   BigInteger^ e,
   BigInteger^ n,
   BigInteger^ d,
   int bits
)

Parameters

p
q
e
n
d
bits

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LicenseSigningKey.KeyRecord Constructor(Int32)
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure > LicenseSigningKey.KeyRecord Constructor : LicenseSigningKey.KeyRecord Constructor(Int32)

bits

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bits As Integer _
)
Visual Basic (Usage) Copy Code
Dim bits As Integer

Dim instance As LicenseSigningKey.KeyRecord(bits)
C#
public LicenseSigningKey.KeyRecord(
   int bits
)
Managed Extensions for C++
public: LicenseSigningKey.KeyRecord(
   int bits
)
C++/CLI
public:
LicenseSigningKey.KeyRecord(
   int bits
)

Parameters

bits

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
LicenseSigningKey.KeyRecord Structure Methods
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey.KeyRecord Structure

For a list of all members of this type, see LicenseSigningKey.KeyRecord members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Public Method | VerifyKey |
Top

See Also

Reference

LicenseSigningKey.KeyRecord Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
VerifyKey Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : VerifyKey Method

Syntax

Visual Basic (Declaration)
Public Function VerifyKey() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As Boolean

value = instance.VerifyKey()
C#
public bool VerifyKey()
Managed Extensions for C++
public: bool VerifyKey();
C++/CLI
public:
bool VerifyKey();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.Windows Send comments on this topic.
LicenseSigningKey.KeyRecord Structure Fields
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey.KeyRecord Structure

For a list of all members of this type, see LicenseSigningKey.KeyRecord members.

Public Fields

 | Name | Description
Public Field | Bits |
Public Field | d |
Public Field | e |
Public Field | n |
Public Field | p |
Public Field | q |
Top

See Also

Reference

LicenseSigningKey.KeyRecord Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Bits Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : Bits Field

Syntax

Visual Basic (Declaration)
Public Bits As Integer
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As Integer

value = instance.Bits

instance.Bits = value
C#
public int Bits
Managed Extensions for C++
public: int Bits
C++/CLI
public:
int Bits

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
d Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : d Field

Syntax

Visual Basic (Declaration)
Public d As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.d

instance.d = value
C#
public BigInteger d
Managed Extensions for C++
public: BigInteger* d
C++/CLI
public:
BigInteger^ d

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
e Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : e Field

Syntax

Visual Basic (Declaration)
Public e As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.e

instance.e = value
C#
public BigInteger e
Managed Extensions for C++
public: BigInteger* e
C++/CLI
public:
BigInteger^ e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
n Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : n Field

Syntax

Visual Basic (Declaration)
Public n As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.n

instance.n = value
C#
public BigInteger n
Managed Extensions for C++
public: BigInteger* n
C++/CLI
public:
BigInteger^ n

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
p Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : p Field

Syntax

Visual Basic (Declaration)
Public p As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.p

instance.p = value
C#
public BigInteger p
Managed Extensions for C++
public: BigInteger* p
C++/CLI
public:
BigInteger^ p

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
q Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : q Field

Syntax

Visual Basic (Declaration)
Public q As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.q

instance.q = value
C#
public BigInteger q
Managed Extensions for C++
public: BigInteger* q
C++/CLI
public:
BigInteger^ q

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MachineProfile._MEMORYSTATUS Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUS Structure

Summary of _MEMORYSTATUS

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile._MEMORYSTATUS
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
C#
private struct MachineProfile._MEMORYSTATUS : ValueType
Managed Extensions for C++
private __value struct MachineProfile._MEMORYSTATUS : public ValueType
C++/CLI
private value class MachineProfile._MEMORYSTATUS : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile._MEMORYSTATUS

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile._MEMORYSTATUS Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUS Structure

The following tables list the members exposed by MachineProfile._MEMORYSTATUS.

Public Fields

 | Name | Description
Public Field | dwAvailPageFile |
Public Field | dwAvailPhys |
Public Field | dwAvailVirtual |
Public Field | dwLength |
Public Field | dwMemoryLoad |
Public Field | dwTotalPageFile |
Public Field | dwTotalPhys |
Public Field | dwTotalVirtual |
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile._MEMORYSTATUS Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUS Structure

For a list of all members of this type, see MachineProfile._MEMORYSTATUS members.

Public Fields

 | Name | Description
Public Field | dwAvailPageFile |
Public Field | dwAvailPhys |
Public Field | dwAvailVirtual |
Public Field | dwLength |
Public Field | dwMemoryLoad |
Public Field | dwTotalPageFile |
Public Field | dwTotalPhys |
Public Field | dwTotalVirtual |
Top

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
dwAvailPageFile Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwAvailPageFile Field

Syntax

Visual Basic (Declaration)
Public dwAvailPageFile As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwAvailPageFile

instance.dwAvailPageFile = value
C#
public uint dwAvailPageFile
Managed Extensions for C++
public: uint dwAvailPageFile
C++/CLI
public:
uint dwAvailPageFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
dwAvailPhys Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwAvailPhys Field

Syntax

Visual Basic (Declaration)
Public dwAvailPhys As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwAvailPhys

instance.dwAvailPhys = value
C#
public uint dwAvailPhys
Managed Extensions for C++
public: uint dwAvailPhys
C++/CLI
public:
uint dwAvailPhys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
dwAvailVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwAvailVirtual Field

Syntax

Visual Basic (Declaration)
Public dwAvailVirtual As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwAvailVirtual

instance.dwAvailVirtual = value
C#
public uint dwAvailVirtual
Managed Extensions for C++
public: uint dwAvailVirtual
C++/CLI
public:
uint dwAvailVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
dwLength Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwLength Field

Syntax

Visual Basic (Declaration)
Public dwLength As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwLength

instance.dwLength = value
C#
public uint dwLength
Managed Extensions for C++
public: uint dwLength
C++/CLI
public:
uint dwLength

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
dwMemoryLoad Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwMemoryLoad Field

Syntax

Visual Basic (Declaration)
Public dwMemoryLoad As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwMemoryLoad

instance.dwMemoryLoad = value
C#
public uint dwMemoryLoad
Managed Extensions for C++
public: uint dwMemoryLoad
C++/CLI
public:
uint dwMemoryLoad

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
dwTotalPageFile Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwTotalPageFile Field

Syntax

Visual Basic (Declaration)
Public dwTotalPageFile As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwTotalPageFile

instance.dwTotalPageFile = value
C#
public uint dwTotalPageFile
Managed Extensions for C++
public: uint dwTotalPageFile
C++/CLI
public:
uint dwTotalPageFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
dwTotalPhys Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwTotalPhys Field

Syntax

Visual Basic (Declaration)
Public dwTotalPhys As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwTotalPhys

instance.dwTotalPhys = value
C#
public uint dwTotalPhys
Managed Extensions for C++
public: uint dwTotalPhys
C++/CLI
public:
uint dwTotalPhys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
dwTotalVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwTotalVirtual Field

Syntax

Visual Basic (Declaration)
Public dwTotalVirtual As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwTotalVirtual

instance.dwTotalVirtual = value
C#
public uint dwTotalVirtual
Managed Extensions for C++
public: uint dwTotalVirtual
C++/CLI
public:
uint dwTotalVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MachineProfile._MEMORYSTATUSEX Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUSEX Structure

Summary of _MEMORYSTATUSEX

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile._MEMORYSTATUSEX
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
C#
private struct MachineProfile._MEMORYSTATUSEX : ValueType
Managed Extensions for C++
private __value struct MachineProfile._MEMORYSTATUSEX : public ValueType
C++/CLI
private value class MachineProfile._MEMORYSTATUSEX : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile._MEMORYSTATUSEX

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile._MEMORYSTATUSEX Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUSEX Structure

The following tables list the members exposed by MachineProfile._MEMORYSTATUSEX.

Public Fields

 | Name | Description
Public Field | dwLength |
Public Field | dwMemoryLoad |
Public Field | ullAvailExtendedVirtual |
Public Field | ullAvailPageFile |
Public Field | ullAvailPhys |
Public Field | ullAvailVirtual |
Public Field | ullTotalPageFile |
Public Field | ullTotalPhys |
Public Field | ullTotalVirtual |
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile._MEMORYSTATUSEX Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUSEX Structure

For a list of all members of this type, see MachineProfile._MEMORYSTATUSEX members.

Public Fields

 | Name | Description
Public Field | dwLength |
Public Field | dwMemoryLoad |
Public Field | ullAvailExtendedVirtual |
Public Field | ullAvailPageFile |
Public Field | ullAvailPhys |
Public Field | ullAvailVirtual |
Public Field | ullTotalPageFile |
Public Field | ullTotalPhys |
Public Field | ullTotalVirtual |
Top

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
dwLength Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : dwLength Field

Syntax

Visual Basic (Declaration)
Public dwLength As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As UInteger

value = instance.dwLength

instance.dwLength = value
C#
public uint dwLength
Managed Extensions for C++
public: uint dwLength
C++/CLI
public:
uint dwLength

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
dwMemoryLoad Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : dwMemoryLoad Field

Syntax

Visual Basic (Declaration)
Public dwMemoryLoad As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As UInteger

value = instance.dwMemoryLoad

instance.dwMemoryLoad = value
C#
public uint dwMemoryLoad
Managed Extensions for C++
public: uint dwMemoryLoad
C++/CLI
public:
uint dwMemoryLoad

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ullAvailExtendedVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullAvailExtendedVirtual Field

Syntax

Visual Basic (Declaration)
Public ullAvailExtendedVirtual As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullAvailExtendedVirtual

instance.ullAvailExtendedVirtual = value
C#
public ulong ullAvailExtendedVirtual
Managed Extensions for C++
public: ulong ullAvailExtendedVirtual
C++/CLI
public:
ulong ullAvailExtendedVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ullAvailPageFile Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullAvailPageFile Field

Syntax

Visual Basic (Declaration)
Public ullAvailPageFile As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullAvailPageFile

instance.ullAvailPageFile = value
C#
public ulong ullAvailPageFile
Managed Extensions for C++
public: ulong ullAvailPageFile
C++/CLI
public:
ulong ullAvailPageFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ullAvailPhys Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullAvailPhys Field

Syntax

Visual Basic (Declaration)
Public ullAvailPhys As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullAvailPhys

instance.ullAvailPhys = value
C#
public ulong ullAvailPhys
Managed Extensions for C++
public: ulong ullAvailPhys
C++/CLI
public:
ulong ullAvailPhys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ullAvailVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullAvailVirtual Field

Syntax

Visual Basic (Declaration)
Public ullAvailVirtual As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullAvailVirtual

instance.ullAvailVirtual = value
C#
public ulong ullAvailVirtual
Managed Extensions for C++
public: ulong ullAvailVirtual
C++/CLI
public:
ulong ullAvailVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ullTotalPageFile Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullTotalPageFile Field

Syntax

Visual Basic (Declaration)
Public ullTotalPageFile As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullTotalPageFile

instance.ullTotalPageFile = value
C#
public ulong ullTotalPageFile
Managed Extensions for C++
public: ulong ullTotalPageFile
C++/CLI
public:
ulong ullTotalPageFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ullTotalPhys Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullTotalPhys Field

Syntax

Visual Basic (Declaration)
Public ullTotalPhys As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullTotalPhys

instance.ullTotalPhys = value
C#
public ulong ullTotalPhys
Managed Extensions for C++
public: ulong ullTotalPhys
C++/CLI
public:
ulong ullTotalPhys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ullTotalVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullTotalVirtual Field

Syntax

Visual Basic (Declaration)
Public ullTotalVirtual As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullTotalVirtual

instance.ullTotalVirtual = value
C#
public ulong ullTotalVirtual
Managed Extensions for C++
public: ulong ullTotalVirtual
C++/CLI
public:
ulong ullTotalVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure

declare the IP_ADAPTERINFO_STRUCTURE structure

Object Model

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile.IP_ADAPTERINFO_STRUCTURE
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
C#
private struct MachineProfile.IP_ADAPTERINFO_STRUCTURE : ValueType
Managed Extensions for C++
private __value struct MachineProfile.IP_ADAPTERINFO_STRUCTURE : public ValueType
C++/CLI
private value class MachineProfile.IP_ADAPTERINFO_STRUCTURE : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile.IP_ADAPTERINFO_STRUCTURE

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure

The following tables list the members exposed by MachineProfile.IP_ADAPTERINFO_STRUCTURE.

Public Fields

 | Name | Description
Public Field | AdapterName | Specifies the name of the adapter
Public Field | Address | Specifies the hardware address for the adapter
Public Field | AddressLength | Specifies the length of the hardware address for the adapter
Public Field | ComboIndex | Reserved
Public Field | CurrentIPAddress | Specifies the current IP address for this adapter
Public Field | Description | Specifies a description for the adapter
Public Field | DhcpEnabled | Specifies whether dynamic host configuration protocol (DHCP) is enabled for this adapter
Public Field | DhcpServer | Specifies the IP address of the DHCP server for this adapter
Public Field | GatewayList | Specifies the IP address of the default gateway for this adapter
Public Field | HaveWins | Specifies whether this adapter uses Windows Internet Name Service (WINS)
Public Field | Index | Specifies the adapter index
Public Field | IpAddressList | Specifies the list of IP addresses associated with this adapter
Public Field | LeaseExpires | Specifies the time when the current DHCP lease will expire
Public Field | LeaseObtained | Specifies the time when the current DHCP lease was obtained
Public Field | Next | Pointer to the next adapter in the list of adapters
Public Field | PrimaryWinsServer | Specifies the IP address of the primary WINS server
Public Field | SecondaryWinsServer | Specifies the IP address of the secondary WINS server
Public Field | Type | Specifies the adapter type. The type is one of the following values. IF_OTHER_ADAPTERTYPE IF_ETHERNET_ADAPTERTYPE IF_TOKEN_RING_ADAPTERTYPE IF_FDDI_ADAPTERTYPE IF_PPP_ADAPTERTYPE IF_LOOPBACK_ADAPTERTYPE IF_SLIP_ADAPTERTYPE These values are defined in the header file IPIfCons.h
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure

For a list of all members of this type, see MachineProfile.IP_ADAPTERINFO_STRUCTURE members.

Public Fields

 | Name | Description
Public Field | AdapterName | Specifies the name of the adapter
Public Field | Address | Specifies the hardware address for the adapter
Public Field | AddressLength | Specifies the length of the hardware address for the adapter
Public Field | ComboIndex | Reserved
Public Field | CurrentIPAddress | Specifies the current IP address for this adapter
Public Field | Description | Specifies a description for the adapter
Public Field | DhcpEnabled | Specifies whether dynamic host configuration protocol (DHCP) is enabled for this adapter
Public Field | DhcpServer | Specifies the IP address of the DHCP server for this adapter
Public Field | GatewayList | Specifies the IP address of the default gateway for this adapter
Public Field | HaveWins | Specifies whether this adapter uses Windows Internet Name Service (WINS)
Public Field | Index | Specifies the adapter index
Public Field | IpAddressList | Specifies the list of IP addresses associated with this adapter
Public Field | LeaseExpires | Specifies the time when the current DHCP lease will expire
Public Field | LeaseObtained | Specifies the time when the current DHCP lease was obtained
Public Field | Next | Pointer to the next adapter in the list of adapters
Public Field | PrimaryWinsServer | Specifies the IP address of the primary WINS server
Public Field | SecondaryWinsServer | Specifies the IP address of the secondary WINS server
Public Field | Type | Specifies the adapter type. The type is one of the following values. IF_OTHER_ADAPTERTYPE IF_ETHERNET_ADAPTERTYPE IF_TOKEN_RING_ADAPTERTYPE IF_FDDI_ADAPTERTYPE IF_PPP_ADAPTERTYPE IF_LOOPBACK_ADAPTERTYPE IF_SLIP_ADAPTERTYPE These values are defined in the header file IPIfCons.h
Top

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
AdapterName Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : AdapterName Field

Specifies the name of the adapter

Syntax

Visual Basic (Declaration)
Public AdapterName As Char()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value() As Char

value = instance.AdapterName

instance.AdapterName = value
C#
public char[] AdapterName
Managed Extensions for C++
public: char[] AdapterName
C++/CLI
public:
array<char> AdapterName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Address Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Address Field

Specifies the hardware address for the adapter

Syntax

Visual Basic (Declaration)
Public Address As Byte()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value() As Byte

value = instance.Address

instance.Address = value
C#
public byte[] Address
Managed Extensions for C++
public: byte[] Address
C++/CLI
public:
array<byte> Address

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
AddressLength Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : AddressLength Field

Specifies the length of the hardware address for the adapter

Syntax

Visual Basic (Declaration)
Public AddressLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.AddressLength

instance.AddressLength = value
C#
public int AddressLength
Managed Extensions for C++
public: int AddressLength
C++/CLI
public:
int AddressLength

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
ComboIndex Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : ComboIndex Field

Reserved

Syntax

Visual Basic (Declaration)
Public ComboIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.ComboIndex

instance.ComboIndex = value
C#
public int ComboIndex
Managed Extensions for C++
public: int ComboIndex
C++/CLI
public:
int ComboIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
CurrentIPAddress Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : CurrentIPAddress Field

Specifies the current IP address for this adapter

Syntax

Visual Basic (Declaration)
Public CurrentIPAddress As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.CurrentIPAddress

instance.CurrentIPAddress = value
C#
public int CurrentIPAddress
Managed Extensions for C++
public: int CurrentIPAddress
C++/CLI
public:
int CurrentIPAddress

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Description Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Description Field

Specifies a description for the adapter

Syntax

Visual Basic (Declaration)
Public Description As Char()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value() As Char

value = instance.Description

instance.Description = value
C#
public char[] Description
Managed Extensions for C++
public: char[] Description
C++/CLI
public:
array<char> Description

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
DhcpEnabled Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : DhcpEnabled Field

Specifies whether dynamic host configuration protocol (DHCP) is enabled for this adapter

Syntax

Visual Basic (Declaration)
Public DhcpEnabled As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.DhcpEnabled

instance.DhcpEnabled = value
C#
public int DhcpEnabled
Managed Extensions for C++
public: int DhcpEnabled
C++/CLI
public:
int DhcpEnabled

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
DhcpServer Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : DhcpServer Field

Specifies the IP address of the DHCP server for this adapter

Syntax

Visual Basic (Declaration)
Public DhcpServer As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.DhcpServer

instance.DhcpServer = value
C#
public MachineProfile.IP_ADDR_STRING DhcpServer
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING DhcpServer
C++/CLI
public:
MachineProfile.IP_ADDR_STRING DhcpServer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
GatewayList Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : GatewayList Field

Specifies the IP address of the default gateway for this adapter

Syntax

Visual Basic (Declaration)
Public GatewayList As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.GatewayList

instance.GatewayList = value
C#
public MachineProfile.IP_ADDR_STRING GatewayList
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING GatewayList
C++/CLI
public:
MachineProfile.IP_ADDR_STRING GatewayList

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
HaveWins Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : HaveWins Field

Specifies whether this adapter uses Windows Internet Name Service (WINS)

Syntax

Visual Basic (Declaration)
Public HaveWins As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Byte

value = instance.HaveWins

instance.HaveWins = value
C#
public byte HaveWins
Managed Extensions for C++
public: byte HaveWins
C++/CLI
public:
byte HaveWins

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Index Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Index Field

Specifies the adapter index

Syntax

Visual Basic (Declaration)
Public Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.Index

instance.Index = value
C#
public int Index
Managed Extensions for C++
public: int Index
C++/CLI
public:
int Index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IpAddressList Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : IpAddressList Field

Specifies the list of IP addresses associated with this adapter

Syntax

Visual Basic (Declaration)
Public IpAddressList As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.IpAddressList

instance.IpAddressList = value
C#
public MachineProfile.IP_ADDR_STRING IpAddressList
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING IpAddressList
C++/CLI
public:
MachineProfile.IP_ADDR_STRING IpAddressList

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LeaseExpires Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : LeaseExpires Field

Specifies the time when the current DHCP lease will expire

Syntax

Visual Basic (Declaration)
Public LeaseExpires As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.LeaseExpires

instance.LeaseExpires = value
C#
public int LeaseExpires
Managed Extensions for C++
public: int LeaseExpires
C++/CLI
public:
int LeaseExpires

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
LeaseObtained Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : LeaseObtained Field

Specifies the time when the current DHCP lease was obtained

Syntax

Visual Basic (Declaration)
Public LeaseObtained As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.LeaseObtained

instance.LeaseObtained = value
C#
public int LeaseObtained
Managed Extensions for C++
public: int LeaseObtained
C++/CLI
public:
int LeaseObtained

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Next Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Next Field

Pointer to the next adapter in the list of adapters

Syntax

Visual Basic (Declaration)
Public Next As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As UInteger

value = instance.Next

instance.Next = value
C#
public uint Next
Managed Extensions for C++
public: uint Next
C++/CLI
public:
uint Next

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
PrimaryWinsServer Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : PrimaryWinsServer Field

Specifies the IP address of the primary WINS server

Syntax

Visual Basic (Declaration)
Public PrimaryWinsServer As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.PrimaryWinsServer

instance.PrimaryWinsServer = value
C#
public MachineProfile.IP_ADDR_STRING PrimaryWinsServer
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING PrimaryWinsServer
C++/CLI
public:
MachineProfile.IP_ADDR_STRING PrimaryWinsServer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
SecondaryWinsServer Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : SecondaryWinsServer Field

Specifies the IP address of the secondary WINS server

Syntax

Visual Basic (Declaration)
Public SecondaryWinsServer As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.SecondaryWinsServer

instance.SecondaryWinsServer = value
C#
public MachineProfile.IP_ADDR_STRING SecondaryWinsServer
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING SecondaryWinsServer
C++/CLI
public:
MachineProfile.IP_ADDR_STRING SecondaryWinsServer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Type Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Type Field

Specifies the adapter type. The type is one of the following values. IF_OTHER_ADAPTERTYPE IF_ETHERNET_ADAPTERTYPE IF_TOKEN_RING_ADAPTERTYPE IF_FDDI_ADAPTERTYPE IF_PPP_ADAPTERTYPE IF_LOOPBACK_ADAPTERTYPE IF_SLIP_ADAPTERTYPE These values are defined in the header file IPIfCons.h

Syntax

Visual Basic (Declaration)
Public Type As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.Type

instance.Type = value
C#
public int Type
Managed Extensions for C++
public: int Type
C++/CLI
public:
int Type

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MachineProfile.IP_ADDR_STRING Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADDR_STRING Structure

declare the IP_ADDR_STRING structure

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile.IP_ADDR_STRING
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
C#
private struct MachineProfile.IP_ADDR_STRING : ValueType
Managed Extensions for C++
private __value struct MachineProfile.IP_ADDR_STRING : public ValueType
C++/CLI
private value class MachineProfile.IP_ADDR_STRING : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile.IP_ADDR_STRING

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile.IP_ADDR_STRING Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADDR_STRING Structure

The following tables list the members exposed by MachineProfile.IP_ADDR_STRING.

Public Fields

 | Name | Description
Public Field | Context | Specifies network table entry (NTE). This value corresponds to the NTEContext parameters in the AddIPAddress and DeleteIPAddress functions
Public Field | IpAddress | This array holds the IP address
Public Field | IpMask | This array holds the IP address mask
Public Field | Next | Pointer to the next IP_ADDR_STRING structure in the list
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile.IP_ADDR_STRING Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADDR_STRING Structure

For a list of all members of this type, see MachineProfile.IP_ADDR_STRING members.

Public Fields

 | Name | Description
Public Field | Context | Specifies network table entry (NTE). This value corresponds to the NTEContext parameters in the AddIPAddress and DeleteIPAddress functions
Public Field | IpAddress | This array holds the IP address
Public Field | IpMask | This array holds the IP address mask
Public Field | Next | Pointer to the next IP_ADDR_STRING structure in the list
Top

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Context Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADDR_STRING Structure : Context Field

Specifies network table entry (NTE). This value corresponds to the NTEContext parameters in the AddIPAddress and DeleteIPAddress functions

Syntax

Visual Basic (Declaration)
Public Context As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
Dim value As Integer

value = instance.Context

instance.Context = value
C#
public int Context
Managed Extensions for C++
public: int Context
C++/CLI
public:
int Context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
MachineProfile.IP_ADDR_STRING Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IpAddress Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADDR_STRING Structure : IpAddress Field

This array holds the IP address

Syntax

Visual Basic (Declaration)
Public IpAddress As Char()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
Dim value() As Char

value = instance.IpAddress

instance.IpAddress = value
C#
public char[] IpAddress
Managed Extensions for C++
public: char[] IpAddress
C++/CLI
public:
array<char> IpAddress

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
MachineProfile.IP_ADDR_STRING Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
IpMask Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADDR_STRING Structure : IpMask Field

This array holds the IP address mask

Syntax

Visual Basic (Declaration)
Public IpMask As Char()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
Dim value() As Char

value = instance.IpMask

instance.IpMask = value
C#
public char[] IpMask
Managed Extensions for C++
public: char[] IpMask
C++/CLI
public:
array<char> IpMask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
MachineProfile.IP_ADDR_STRING Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Next Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADDR_STRING Structure : Next Field

Pointer to the next IP_ADDR_STRING structure in the list

Syntax

Visual Basic (Declaration)
Public Next As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
Dim value As Integer

value = instance.Next

instance.Next = value
C#
public int Next
Managed Extensions for C++
public: int Next
C++/CLI
public:
int Next

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
MachineProfile.IP_ADDR_STRING Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
MachineProfile.TGuid Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.TGuid Structure

Summary of TGuid

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile.TGuid
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
C#
private struct MachineProfile.TGuid : ValueType
Managed Extensions for C++
private __value struct MachineProfile.TGuid : public ValueType
C++/CLI
private value class MachineProfile.TGuid : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile.TGuid

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile.TGuid Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile.TGuid Structure

The following tables list the members exposed by MachineProfile.TGuid.

Public Fields

 | Name | Description
Public Field | a |
Public Field | b |
Public Field | d |
Public Field | m |
Public Field | m1 |
Public Field | m2 |
Public Field | m3 |
Public Field | m4 |
Public Field | m5 |
Public Field | m6 |
Public Field | s |
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.TGuid Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile.TGuid Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.TGuid Structure

For a list of all members of this type, see MachineProfile.TGuid members.

Public Fields

 | Name | Description
Public Field | a |
Public Field | b |
Public Field | d |
Public Field | m |
Public Field | m1 |
Public Field | m2 |
Public Field | m3 |
Public Field | m4 |
Public Field | m5 |
Public Field | m6 |
Public Field | s |
Top

See Also

Reference

MachineProfile.TGuid Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
a Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : a Field

Syntax

Visual Basic (Declaration)
Public a As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.a

instance.a = value
C#
public short a
Managed Extensions for C++
public: short a
C++/CLI
public:
short a

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
b Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : b Field

Syntax

Visual Basic (Declaration)
Public b As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.b

instance.b = value
C#
public short b
Managed Extensions for C++
public: short b
C++/CLI
public:
short b

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
d Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : d Field

Syntax

Visual Basic (Declaration)
Public d As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.d

instance.d = value
C#
public short d
Managed Extensions for C++
public: short d
C++/CLI
public:
short d

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
m Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m Field

Syntax

Visual Basic (Declaration)
Public m As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.m

instance.m = value
C#
public short m
Managed Extensions for C++
public: short m
C++/CLI
public:
short m

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
m1 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m1 Field

Syntax

Visual Basic (Declaration)
Public m1 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m1

instance.m1 = value
C#
public byte m1
Managed Extensions for C++
public: byte m1
C++/CLI
public:
byte m1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
m2 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m2 Field

Syntax

Visual Basic (Declaration)
Public m2 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m2

instance.m2 = value
C#
public byte m2
Managed Extensions for C++
public: byte m2
C++/CLI
public:
byte m2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
m3 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m3 Field

Syntax

Visual Basic (Declaration)
Public m3 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m3

instance.m3 = value
C#
public byte m3
Managed Extensions for C++
public: byte m3
C++/CLI
public:
byte m3

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
m4 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m4 Field

Syntax

Visual Basic (Declaration)
Public m4 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m4

instance.m4 = value
C#
public byte m4
Managed Extensions for C++
public: byte m4
C++/CLI
public:
byte m4

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
m5 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m5 Field

Syntax

Visual Basic (Declaration)
Public m5 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m5

instance.m5 = value
C#
public byte m5
Managed Extensions for C++
public: byte m5
C++/CLI
public:
byte m5

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
m6 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m6 Field

Syntax

Visual Basic (Declaration)
Public m6 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m6

instance.m6 = value
C#
public byte m6
Managed Extensions for C++
public: byte m6
C++/CLI
public:
byte m6

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
s Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : s Field

Syntax

Visual Basic (Declaration)
Public s As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.s

instance.s = value
C#
public short s
Managed Extensions for C++
public: short s
C++/CLI
public:
short s

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


$$INTRODUCTION$$ - %%projecttitle%%

Barcode4NET.Web Send comments on this topic.
Introduction
Welcome to BarcodeView ASP.NET server control online help.


%%phrase%%

Barcode4NET.Web Send comments on this topic.
Barcode4NET.Web Assembly
The Barcode4NET.Web assembly includes the BarcodeView ASP.NET server control.

Namespaces

Namespace | Description
Internal |
O2S.Barcode4NET.Licensing |
O2S.Barcode4NET.WebControls | Root namespace for all server controls included in Barcode4NET.Web assembly.
Xheo.Licensing |


$$GETTING_STARTED$$ - %%projecttitle%%

Barcode4NET.Web Send comments on this topic.
Getting Started
This online help will help you get started with BarcodeView ASP.NET server control.


%%ItemTitle%%

Barcode4NET.Web Send comments on this topic.
Internal Namespace (Barcode4NET.Web)
See Also Inheritance Hierarchy

Classes

Class | Description
BigInteger | Implements an large integer of arbitrary length.
CommonRegexes | Declares static versions of some common regular expressions.

See Also

Reference

Barcode4NET.Web Assembly


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Class
See Also Members
[image]
Internal Namespace : BigInteger Class

Implements an large integer of arbitrary length.

Syntax

Visual Basic (Declaration)
Private Class BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
C#
private class BigInteger
Managed Extensions for C++
private __gc class BigInteger
C++/CLI
private ref class BigInteger

Inheritance Hierarchy

System.Object
Internal.BigInteger

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Members
Internal Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
BigInteger Class Members
See Also Properties Methods
[image]
Internal Namespace : BigInteger Class

The following tables list the members exposed by BigInteger.

Public Constructors

 | Name | Description
Public Constructor | BigInteger Constructor | Overloaded. Initializes a new instance of the BigInteger class.
Top

Public Properties

 | Name | Description
Public Property | Bits | Gets the position of the most significant bit in the value.
Top

Public Methods

 | Name | Description
Public Method | Abs | Returns the absolute value of the BigInteger.
Public Method | Equals | Overridden. Overrides the equals comparison.
Public Method | Gcd | Returns the GCD(this, bi)
Public Method | GenerateCoPrime | Generates a random number with the specified number of bits such that Gcd(number, this) = 1
static (Shared in Visual Basic) | GeneratePseudoPrime | Makes a pseudoprime number that requires at least the given number of bits.
Public Method | GenerateRandomBits | Fills the BigInteger with random bits.
Public Method | GetBytes | Returns the value of the BigInteger as a byte array. The lowest index contains the MSB.
Public Method | GetHashCode | Overridden. Gets the hash code for the value.
Public Method | IntValue | Returns the lowest 4 bytes of the BigInteger as an int.
Public Method | IsProbablePrime | Determines whether a number is probably prime, using the Rabin-Miller's test. Before applying the test, the number is tested for divisibility by primes < 2000
Public Method | LongValue | Returns the lowest 8 bytes of the BigInteger as a long.
Public Method | ModInverse | Returns the modulo inverse of this. Throws ArithmeticException if the inverse does not exist. (i.e. Gcd(this, modulus) != 1)
Public Method | ModPow | Modulo Exponentiation. ( this ^ exp ) % n.
Public Method | Sqrt | Returns a value that is equivalent to the integer square root of the BigInteger.
Public Method | ToString | Overloaded. Overridden. Returns a string representation of the value.
Public Method | ULongValue | Returns the lowest 8 bytes of the BigInteger as a long.
Top

Public Operators

Public Operator Addition | Adds two BigInteger values together.
Public Operator And | Bitwise AND operator.
Public Operator Or | Bitwise OR operator.
Public Operator Decrement | Decrements the BigInteger value by one.
Public Operator Division | Division operator.
Public Operator Equality | Equality operator.
Public Operator Exclusive Or | Bitwise XOR operator.
Public Operator Greater Than | Greater than operator.
Public Operator Greater Than or Equal | Greater than or equal operator.
Public Operator Implicit Type Conversion | Overloaded.
Public Operator Increment | Increments the BigInteger value by 1.
Public Operator Inequality | Inequality operator.
Public Operator Left-shift | Shifts the bits to the left.
Public Operator Less Than | Less than operator.
Public Operator Less Than or Equal | Less than or equal operator.
Public Operator Modulus | Modulus operator.
Public Operator Multiplication | Multiplies two BigInteger values.
Public Operator Bitwise Complement | Implements a 1's compliment.
Public Operator Right-shift | Shifts the bits to the right.
Public Operator Subtraction | Subtracts one BigInteger from another.
Public Operator Unary Negation | Implements a 2's compliment (negative).
Top

See Also

Reference

BigInteger Class
Internal Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Constructor
See Also
[image]
Internal Namespace > BigInteger Class : BigInteger Constructor

Initializes a new instance of the BigInteger class.

Overload List

Overload | Description
BigInteger Constructor() | Initializes a new instance of the BigInteger class.
BigInteger Constructor(BigInteger) | Initializes a new instance of the BigInteger class from an existing instance.
BigInteger Constructor(Byte[]) | Initializes a new instance of the BigInteger class from an array of existing bytes.
BigInteger Constructor(Byte[],Int32) | Initializes a new instance of the BigInteger class from an array of existing bytes.
BigInteger Constructor(Int64) | Initializes a new instance of the BigInteger class from a Int64 value.
BigInteger Constructor(String,Int32) | Initializes a new instance of the BigInteger class from a string representation in the given radix.
BigInteger Constructor(UInt64) | Initializes a new instance of the BigInteger class from a UInt64 value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Constructor()
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor()

Initializes a new instance of the BigInteger class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BigInteger()
C#
public BigInteger()
Managed Extensions for C++
public: BigInteger();
C++/CLI
public:
BigInteger();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Constructor(BigInteger)
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(BigInteger)

bi
The BigInteger to initialize from.
Initializes a new instance of the BigInteger class from an existing instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bi As BigInteger _
)
Visual Basic (Usage) Copy Code
Dim bi As BigInteger

Dim instance As BigInteger(bi)
C#
public BigInteger(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger(
   BigInteger* bi
)
C++/CLI
public:
BigInteger(
   BigInteger^ bi
)

Parameters

bi
The BigInteger to initialize from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Constructor(Byte[])
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Byte[])

inData
The values to initialize from.
Initializes a new instance of the BigInteger class from an array of existing bytes.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As Byte _
)
Visual Basic (Usage) Copy Code
Dim inData() As Byte

Dim instance As BigInteger(inData)
C#
public BigInteger(
   byte[] inData
)
Managed Extensions for C++
public: BigInteger(
   byte[] inData
)
C++/CLI
public:
BigInteger(
   array<byte> inData
)

Parameters

inData
The values to initialize from.

Remarks

The lowest index of the input byte array (i.e [0]) should contain the most significant byte of the number, and the highest index should contain the least significant byte.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Constructor(Byte[],Int32)
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Byte[],Int32)

inData
The values to initialize from.
inLen
The length of the initialization array to use.
Initializes a new instance of the BigInteger class from an array of existing bytes.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As Byte, _
   ByVal inLen As Integer _
)
Visual Basic (Usage) Copy Code
Dim inData() As Byte
Dim inLen As Integer

Dim instance As BigInteger(inData, inLen)
C#
public BigInteger(
   byte[] inData,
   int inLen
)
Managed Extensions for C++
public: BigInteger(
   byte[] inData,
   int inLen
)
C++/CLI
public:
BigInteger(
   array<byte> inData,
   int inLen
)

Parameters

inData
The values to initialize from.
inLen
The length of the initialization array to use.

Remarks

The lowest index of the input byte array (i.e [0]) should contain the most significant byte of the number, and the highest index should contain the least significant byte.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Constructor(Int64)
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Int64)

value
The value to initialize with.
Initializes a new instance of the BigInteger class from a Int64 value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim value As Long

Dim instance As BigInteger(value)
C#
public BigInteger(
   long value
)
Managed Extensions for C++
public: BigInteger(
   long value
)
C++/CLI
public:
BigInteger(
   long value
)

Parameters

value
The value to initialize with.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Constructor(String,Int32)
See Also Example
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(String,Int32)

value
The string value to initialize from.
radix
The radix (or base) the value is offered as.
Initializes a new instance of the BigInteger class from a string representation in the given radix.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal radix As Integer _
)
Visual Basic (Usage) Copy Code
Dim value As String
Dim radix As Integer

Dim instance As BigInteger(value, radix)
C#
public BigInteger(
   string value,
   int radix
)
Managed Extensions for C++
public: BigInteger(
   string* value,
   int radix
)
C++/CLI
public:
BigInteger(
   String^ value,
   int radix
)

Parameters

value
The string value to initialize from.
radix
The radix (or base) the value is offered as.

Example

Example in Base 10

Example in Base 16 (HEX)

C# Copy Code
BigInteger a = new BigInteger( "1234", 10 );
            BigInteger b = new BigInteger( "-1234", 10 )
C# Copy Code
BigInteger a = new BigInteger( "1D4F", 16 );
            BigInteger b = new BigInteger( "-1D4F", 10 )

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Constructor(UInt64)
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(UInt64)

value
The value to initialize with.
Initializes a new instance of the BigInteger class from a UInt64 value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As ULong _
)
Visual Basic (Usage) Copy Code
Dim value As ULong

Dim instance As BigInteger(value)
C#
public BigInteger(
   ulong value
)
Managed Extensions for C++
public: BigInteger(
   ulong value
)
C++/CLI
public:
BigInteger(
   ulong value
)

Parameters

value
The value to initialize with.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
BigInteger Class Methods
See Also
[image]
Internal Namespace : BigInteger Class

For a list of all members of this type, see BigInteger members.

Public Methods

 | Name | Description
Public Method | Abs | Returns the absolute value of the BigInteger.
Public Method | Equals | Overridden. Overrides the equals comparison.
Public Method | Gcd | Returns the GCD(this, bi)
Public Method | GenerateCoPrime | Generates a random number with the specified number of bits such that Gcd(number, this) = 1
static (Shared in Visual Basic) | GeneratePseudoPrime | Makes a pseudoprime number that requires at least the given number of bits.
Public Method | GenerateRandomBits | Fills the BigInteger with random bits.
Public Method | GetBytes | Returns the value of the BigInteger as a byte array. The lowest index contains the MSB.
Public Method | GetHashCode | Overridden. Gets the hash code for the value.
Public Method | IntValue | Returns the lowest 4 bytes of the BigInteger as an int.
Public Method | IsProbablePrime | Determines whether a number is probably prime, using the Rabin-Miller's test. Before applying the test, the number is tested for divisibility by primes < 2000
Public Method | LongValue | Returns the lowest 8 bytes of the BigInteger as a long.
Public Method | ModInverse | Returns the modulo inverse of this. Throws ArithmeticException if the inverse does not exist. (i.e. Gcd(this, modulus) != 1)
Public Method | ModPow | Modulo Exponentiation. ( this ^ exp ) % n.
Public Method | Sqrt | Returns a value that is equivalent to the integer square root of the BigInteger.
Public Method | ToString | Overloaded. Overridden. Returns a string representation of the value.
Public Method | ULongValue | Returns the lowest 8 bytes of the BigInteger as a long.
Top

See Also

Reference

BigInteger Class
Internal Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Abs Method
See Also
[image]
Internal Namespace > BigInteger Class : Abs Method

Returns the absolute value of the BigInteger.

Syntax

Visual Basic (Declaration)
Public Function Abs() As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As BigInteger

value = instance.Abs()
C#
public BigInteger Abs()
Managed Extensions for C++
public: BigInteger* Abs();
C++/CLI
public:
BigInteger^ Abs();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Equals Method
See Also
[image]
Internal Namespace > BigInteger Class : Equals Method

o
Overrides the equals comparison.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal o As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim o As Object
Dim value As Boolean

value = instance.Equals(o)
C#
public override bool Equals(
   object o
)
Managed Extensions for C++
public: bool Equals(
   Object* o
) override
C++/CLI
public:
bool Equals(
   Object^ o
) override

Parameters

o

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Gcd Method
See Also
[image]
Internal Namespace > BigInteger Class : Gcd Method

bi
Returns the GCD(this, bi)

Syntax

Visual Basic (Declaration)
Public Function Gcd( _
   ByVal bi As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bi As BigInteger
Dim value As BigInteger

value = instance.Gcd(bi)
C#
public BigInteger Gcd(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger* Gcd(
   BigInteger* bi
)
C++/CLI
public:
BigInteger^ Gcd(
   BigInteger^ bi
)

Parameters

bi

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GenerateCoPrime Method
See Also
[image]
Internal Namespace > BigInteger Class : GenerateCoPrime Method

bits
Bits to use.
rand
Random number generator.
Generates a random number with the specified number of bits such that Gcd(number, this) = 1

Syntax

Visual Basic (Declaration)
Public Function GenerateCoPrime( _
   ByVal bits As Integer, _
   ByVal rand As Random _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bits As Integer
Dim rand As Random
Dim value As BigInteger

value = instance.GenerateCoPrime(bits, rand)
C#
public BigInteger GenerateCoPrime(
   int bits,
   Random rand
)
Managed Extensions for C++
public: BigInteger* GenerateCoPrime(
   int bits,
   Random* rand
)
C++/CLI
public:
BigInteger^ GenerateCoPrime(
   int bits,
   Random^ rand
)

Parameters

bits
Bits to use.
rand
Random number generator.

Return Value

Returns the co prime.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GeneratePseudoPrime Method
See Also
[image]
Internal Namespace > BigInteger Class : GeneratePseudoPrime Method

bits
The number of bits to use.
confidence
The amount of confidence required...a lower value is more confident.
rand
The random number generator.
Makes a pseudoprime number that requires at least the given number of bits.

Syntax

Visual Basic (Declaration)
Public Shared Function GeneratePseudoPrime( _
   ByVal bits As Integer, _
   ByVal confidence As Integer, _
   ByVal rand As Random _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim bits As Integer
Dim confidence As Integer
Dim rand As Random
Dim value As BigInteger

value = BigInteger.GeneratePseudoPrime(bits, confidence, rand)
C#
public static BigInteger GeneratePseudoPrime(
   int bits,
   int confidence,
   Random rand
)
Managed Extensions for C++
public: static BigInteger* GeneratePseudoPrime(
   int bits,
   int confidence,
   Random* rand
)
C++/CLI
public:
static BigInteger^ GeneratePseudoPrime(
   int bits,
   int confidence,
   Random^ rand
)

Parameters

bits
The number of bits to use.
confidence
The amount of confidence required...a lower value is more confident.
rand
The random number generator.

Return Value

Returns a pseudo prime number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GenerateRandomBits Method
See Also
[image]
Internal Namespace > BigInteger Class : GenerateRandomBits Method

bits
The minimum number of bits.
rand
The random number generator.
Fills the BigInteger with random bits.

Syntax

Visual Basic (Declaration)
Public Sub GenerateRandomBits( _
   ByVal bits As Integer, _
   ByVal rand As Random _
)
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bits As Integer
Dim rand As Random

instance.GenerateRandomBits(bits, rand)
C#
public void GenerateRandomBits(
   int bits,
   Random rand
)
Managed Extensions for C++
public: void GenerateRandomBits(
   int bits,
   Random* rand
)
C++/CLI
public:
void GenerateRandomBits(
   int bits,
   Random^ rand
)

Parameters

bits
The minimum number of bits.
rand
The random number generator.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetBytes Method
See Also
[image]
Internal Namespace > BigInteger Class : GetBytes Method

Returns the value of the BigInteger as a byte array. The lowest index contains the MSB.

Syntax

Visual Basic (Declaration)
Public Function GetBytes() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value() As Byte

value = instance.GetBytes()
C#
public byte[] GetBytes()
Managed Extensions for C++
public: byte[] GetBytes();
C++/CLI
public:
array<byte> GetBytes();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetHashCode Method
See Also
[image]
Internal Namespace > BigInteger Class : GetHashCode Method

Gets the hash code for the value.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IntValue Method
See Also
[image]
Internal Namespace > BigInteger Class : IntValue Method

Returns the lowest 4 bytes of the BigInteger as an int.

Syntax

Visual Basic (Declaration)
Public Function IntValue() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.IntValue()
C#
public int IntValue()
Managed Extensions for C++
public: int IntValue();
C++/CLI
public:
int IntValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IsProbablePrime Method
See Also
[image]
Internal Namespace > BigInteger Class : IsProbablePrime Method

confidence
Amount of confidence allowed.
Determines whether a number is probably prime, using the Rabin-Miller's test. Before applying the test, the number is tested for divisibility by primes < 2000

Syntax

Visual Basic (Declaration)
Public Function IsProbablePrime( _
   ByVal confidence As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim confidence As Integer
Dim value As Boolean

value = instance.IsProbablePrime(confidence)
C#
public bool IsProbablePrime(
   int confidence
)
Managed Extensions for C++
public: bool IsProbablePrime(
   int confidence
)
C++/CLI
public:
bool IsProbablePrime(
   int confidence
)

Parameters

confidence
Amount of confidence allowed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LongValue Method
See Also
[image]
Internal Namespace > BigInteger Class : LongValue Method

Returns the lowest 8 bytes of the BigInteger as a long.

Syntax

Visual Basic (Declaration)
Public Function LongValue() As Long
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Long

value = instance.LongValue()
C#
public long LongValue()
Managed Extensions for C++
public: long LongValue();
C++/CLI
public:
long LongValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ModInverse Method
See Also
[image]
Internal Namespace > BigInteger Class : ModInverse Method

modulus
Returns the modulo inverse of this. Throws ArithmeticException if the inverse does not exist. (i.e. Gcd(this, modulus) != 1)

Syntax

Visual Basic (Declaration)
Public Function ModInverse( _
   ByVal modulus As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim modulus As BigInteger
Dim value As BigInteger

value = instance.ModInverse(modulus)
C#
public BigInteger ModInverse(
   BigInteger modulus
)
Managed Extensions for C++
public: BigInteger* ModInverse(
   BigInteger* modulus
)
C++/CLI
public:
BigInteger^ ModInverse(
   BigInteger^ modulus
)

Parameters

modulus

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ModPow Method
See Also
[image]
Internal Namespace > BigInteger Class : ModPow Method

exp
Exponent.
n
Modulus.
Modulo Exponentiation. ( this ^ exp ) % n.

Syntax

Visual Basic (Declaration)
Public Function ModPow( _
   ByVal exp As BigInteger, _
   ByVal n As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim exp As BigInteger
Dim n As BigInteger
Dim value As BigInteger

value = instance.ModPow(exp, n)
C#
public BigInteger ModPow(
   BigInteger exp,
   BigInteger n
)
Managed Extensions for C++
public: BigInteger* ModPow(
   BigInteger* exp,
   BigInteger* n
)
C++/CLI
public:
BigInteger^ ModPow(
   BigInteger^ exp,
   BigInteger^ n
)

Parameters

exp
Exponent.
n
Modulus.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Sqrt Method
See Also
[image]
Internal Namespace > BigInteger Class : Sqrt Method

Returns a value that is equivalent to the integer square root of the BigInteger.

Syntax

Visual Basic (Declaration)
Public Function Sqrt() As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As BigInteger

value = instance.Sqrt()
C#
public BigInteger Sqrt()
Managed Extensions for C++
public: BigInteger* Sqrt();
C++/CLI
public:
BigInteger^ Sqrt();

Remarks

The integer square root of "this" is defined as the largest integer n such that (n * n) <= this

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ToString Method
See Also
[image]
Internal Namespace > BigInteger Class : ToString Method

Returns a string representation of the value.

Overload List

Overload | Description
ToString() | Returns a string representation of the value.
ToString(Int32) | Returns a string representing the BigInteger in sign-and-magnitude format in the specified radix.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ToString() Method
See Also
[image]
Internal Namespace > BigInteger Class > ToString Method : ToString() Method

Returns a string representation of the value.

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ToString(Int32) Method
See Also
[image]
Internal Namespace > BigInteger Class > ToString Method : ToString(Int32) Method

radix
The radix (or base) of the value to output. Valid values are from 2 to 36.
Returns a string representing the BigInteger in sign-and-magnitude format in the specified radix.

Syntax

Visual Basic (Declaration)
Overloads Public Function ToString( _
   ByVal radix As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim radix As Integer
Dim value As String

value = instance.ToString(radix)
C#
public string ToString(
   int radix
)
Managed Extensions for C++
public: string* ToString(
   int radix
)
C++/CLI
public:
String^ ToString(
   int radix
)

Parameters

radix
The radix (or base) of the value to output. Valid values are from 2 to 36.

Return Value

Returns the formatted string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ULongValue Method
See Also
[image]
Internal Namespace > BigInteger Class : ULongValue Method

Returns the lowest 8 bytes of the BigInteger as a long.

Syntax

Visual Basic (Declaration)
Public Function ULongValue() As ULong
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As ULong

value = instance.ULongValue()
C#
public ulong ULongValue()
Managed Extensions for C++
public: ulong ULongValue();
C++/CLI
public:
ulong ULongValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Web Send comments on this topic.
BigInteger Class Properties
See Also
[image]
Internal Namespace : BigInteger Class

For a list of all members of this type, see BigInteger members.

Public Properties

 | Name | Description
Public Property | Bits | Gets the position of the most significant bit in the value.
Top

See Also

Reference

BigInteger Class
Internal Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Bits Property
See Also
[image]
Internal Namespace > BigInteger Class : Bits Property

Gets the position of the most significant bit in the value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bits As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.Bits
C#
public int Bits {get;}
Managed Extensions for C++
public: __property int get_Bits();
C++/CLI
public:
property int Bits {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Addition Operator
See Also
[image]
Internal Namespace > BigInteger Class : Addition Operator

bi1
BigInteger 1.
bi2
BigInteger 2.
Adds two BigInteger values together.

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator +(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Addition(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator +(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
BigInteger 1.
bi2
BigInteger 2.

Return Value

Returns the sum of the two values.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
And Operator
See Also
[image]
Internal Namespace > BigInteger Class : And Operator

bi1
bi2
Bitwise AND operator.

Syntax

Visual Basic (Declaration)
Public Operator And( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator &(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_BitwiseAnd(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator &(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Or Operator
See Also
[image]
Internal Namespace > BigInteger Class : Or Operator

bi1
bi2
Bitwise OR operator.

Syntax

Visual Basic (Declaration)
Public Operator Or( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator |(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_BitwiseOr(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator |(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Decrement Operator
See Also
[image]
Internal Namespace > BigInteger Class : Decrement Operator

bi1
Decrements the BigInteger value by one.

Syntax

Visual Basic (Declaration)
This operator type is not supported by Visual Basic
C#
public BigInteger operator --(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_Decrement(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator --(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Division Operator
See Also
[image]
Internal Namespace > BigInteger Class : Division Operator

bi1
bi2
Division operator.

Syntax

Visual Basic (Declaration)
Public Operator /( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator /(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Division(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator /(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Equality Operator
See Also
[image]
Internal Namespace > BigInteger Class : Equality Operator

bi1
bi2
Equality operator.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator ==(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_Equality(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator ==(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Exclusive Or Operator
See Also
[image]
Internal Namespace > BigInteger Class : Exclusive Or Operator

bi1
bi2
Bitwise XOR operator.

Syntax

Visual Basic (Declaration)
Public Operator Xor( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator ^(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_ExclusiveOr(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator ^(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Greater Than Operator
See Also
[image]
Internal Namespace > BigInteger Class : Greater Than Operator

bi1
bi2
Greater than operator.

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator >(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_GreaterThan(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator >(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Greater Than or Equal Operator
See Also
[image]
Internal Namespace > BigInteger Class : Greater Than or Equal Operator

bi1
bi2
Greater than or equal operator.

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator >=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_GreaterThanOrEqual(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator >=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Implicit Type Conversion Operator
See Also
[image]
Internal Namespace > BigInteger Class : Implicit Type Conversion Operator

Overload List

Overload | Description
Implicit Type Conversion(Int32) |
Implicit Type Conversion(Int64) |
Implicit Type Conversion(UInt32) |
Implicit Type Conversion(UInt64) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Increment Operator
See Also
[image]
Internal Namespace > BigInteger Class : Increment Operator

bi1
Increments the BigInteger value by 1.

Syntax

Visual Basic (Declaration)
This operator type is not supported by Visual Basic
C#
public BigInteger operator ++(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_Increment(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator ++(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Inequality Operator
See Also
[image]
Internal Namespace > BigInteger Class : Inequality Operator

bi1
bi2
Inequality operator.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator !=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_Inequality(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator !=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Left-shift Operator
See Also
[image]
Internal Namespace > BigInteger Class : Left-shift Operator

bi1
shiftVal
Shifts the bits to the left.

Syntax

Visual Basic (Declaration)
Public Operator <<( _
   ByVal bi1 As BigInteger, _
   ByVal shiftVal As Integer _
) As BigInteger
C#
public BigInteger operator <<(
   BigInteger bi1,
   int shiftVal
)
Managed Extensions for C++
public: BigInteger* op_LeftShift(
   BigInteger* bi1,
   int shiftVal
)
C++/CLI
public:
BigInteger^ operator <<(
   BigInteger^ bi1,
   int shiftVal
)

Parameters

bi1
shiftVal

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Less Than Operator
See Also
[image]
Internal Namespace > BigInteger Class : Less Than Operator

bi1
bi2
Less than operator.

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator <(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_LessThan(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator <(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Less Than or Equal Operator
See Also
[image]
Internal Namespace > BigInteger Class : Less Than or Equal Operator

bi1
bi2
Less than or equal operator.

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator <=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_LessThanOrEqual(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator <=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Modulus Operator
See Also
[image]
Internal Namespace > BigInteger Class : Modulus Operator

bi1
bi2
Modulus operator.

Syntax

Visual Basic (Declaration)
Public Operator Mod( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator %(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Modulus(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator %(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Multiplication Operator
See Also
[image]
Internal Namespace > BigInteger Class : Multiplication Operator

bi1
bi2
Multiplies two BigInteger values.

Syntax

Visual Basic (Declaration)
Public Operator *( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator *(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Multiply(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator *(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Bitwise Complement Operator
See Also
[image]
Internal Namespace > BigInteger Class : Bitwise Complement Operator

bi1
Implements a 1's compliment.

Syntax

Visual Basic (Declaration)
Public Operator Not( _
   ByVal bi1 As BigInteger _
) As BigInteger
C#
public BigInteger operator ~(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_OnesComplement(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator ~(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Right-shift Operator
See Also
[image]
Internal Namespace > BigInteger Class : Right-shift Operator

bi1
shiftVal
Shifts the bits to the right.

Syntax

Visual Basic (Declaration)
Public Operator >>( _
   ByVal bi1 As BigInteger, _
   ByVal shiftVal As Integer _
) As BigInteger
C#
public BigInteger operator >>(
   BigInteger bi1,
   int shiftVal
)
Managed Extensions for C++
public: BigInteger* op_RightShift(
   BigInteger* bi1,
   int shiftVal
)
C++/CLI
public:
BigInteger^ operator >>(
   BigInteger^ bi1,
   int shiftVal
)

Parameters

bi1
shiftVal

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Subtraction Operator
See Also
[image]
Internal Namespace > BigInteger Class : Subtraction Operator

bi1
bi2
Subtracts one BigInteger from another.

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator -(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Subtraction(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator -(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Unary Negation Operator
See Also
[image]
Internal Namespace > BigInteger Class : Unary Negation Operator

bi1
Implements a 2's compliment (negative).

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal bi1 As BigInteger _
) As BigInteger
C#
public BigInteger operator -(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_UnaryNegation(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator -(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
CommonRegexes Class
See Also Members
[image]
Internal Namespace : CommonRegexes Class

Declares static versions of some common regular expressions.

Syntax

Visual Basic (Declaration)
Private NotInheritable Class CommonRegexes
Visual Basic (Usage) Copy Code
Dim instance As CommonRegexes
C#
private sealed class CommonRegexes
Managed Extensions for C++
private __gc __sealed class CommonRegexes
C++/CLI
private ref class CommonRegexes sealed

Inheritance Hierarchy

System.Object
Internal.CommonRegexes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Members
Internal Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
CommonRegexes Class Members
See Also Fields
[image]
Internal Namespace : CommonRegexes Class

The following tables list the members exposed by CommonRegexes.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DomainName | Pattern for matching against any valid domain name.
static (Shared in Visual Basic) | Email | Pattern for matching against any valid email address.
static (Shared in Visual Basic) | FileName | Pattern for matching a Windows file path.
static (Shared in Visual Basic) | FilePath | Pattern for matching a Windows file path.
static (Shared in Visual Basic) | FullyQualifiedUrl | Pattern for matching against any valid URL.
static (Shared in Visual Basic) | FullyQualifiedUrlFolder | Pattern for matching a fully qualified URL that has no file name.
static (Shared in Visual Basic) | IpAddress | Pattern for matching against any valid IP address.
static (Shared in Visual Basic) | Url | Pattern for matching against any valid URL.
static (Shared in Visual Basic) | UrlFolder | Pattern for matching against any valid URL that has no file name.
static (Shared in Visual Basic) | UsEin | Pattern for a US employer identification number.
static (Shared in Visual Basic) | UsPhone | Pattern for a US 10-digit phone number.
static (Shared in Visual Basic) | UsSsn | Pattern for a US social security number.
static (Shared in Visual Basic) | UsSsnOrEin | Pattern for a US social security number or an employer identification number.
static (Shared in Visual Basic) | UsZip | Pattern for a US 5-digit zip code with an optional 4 digit exchange.
static (Shared in Visual Basic) | UsZip5 | Pattern for a US 5-digit zip code.
static (Shared in Visual Basic) | UsZip5Plus4 | Pattern for a US 5-digit zip code plus 4 digit exchange.
Top

See Also

Reference

CommonRegexes Class
Internal Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.Web Send comments on this topic.
CommonRegexes Class Fields
See Also
[image]
Internal Namespace : CommonRegexes Class

For a list of all members of this type, see CommonRegexes members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DomainName | Pattern for matching against any valid domain name.
static (Shared in Visual Basic) | Email | Pattern for matching against any valid email address.
static (Shared in Visual Basic) | FileName | Pattern for matching a Windows file path.
static (Shared in Visual Basic) | FilePath | Pattern for matching a Windows file path.
static (Shared in Visual Basic) | FullyQualifiedUrl | Pattern for matching against any valid URL.
static (Shared in Visual Basic) | FullyQualifiedUrlFolder | Pattern for matching a fully qualified URL that has no file name.
static (Shared in Visual Basic) | IpAddress | Pattern for matching against any valid IP address.
static (Shared in Visual Basic) | Url | Pattern for matching against any valid URL.
static (Shared in Visual Basic) | UrlFolder | Pattern for matching against any valid URL that has no file name.
static (Shared in Visual Basic) | UsEin | Pattern for a US employer identification number.
static (Shared in Visual Basic) | UsPhone | Pattern for a US 10-digit phone number.
static (Shared in Visual Basic) | UsSsn | Pattern for a US social security number.
static (Shared in Visual Basic) | UsSsnOrEin | Pattern for a US social security number or an employer identification number.
static (Shared in Visual Basic) | UsZip | Pattern for a US 5-digit zip code with an optional 4 digit exchange.
static (Shared in Visual Basic) | UsZip5 | Pattern for a US 5-digit zip code.
static (Shared in Visual Basic) | UsZip5Plus4 | Pattern for a US 5-digit zip code plus 4 digit exchange.
Top

See Also

Reference

CommonRegexes Class
Internal Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
DomainName Field
See Also
[image]
Internal Namespace > CommonRegexes Class : DomainName Field

Pattern for matching against any valid domain name.

Syntax

Visual Basic (Declaration)
Public Shared DomainName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.DomainName

CommonRegexes.DomainName = value
C#
public static string DomainName
Managed Extensions for C++
public: static string* DomainName
C++/CLI
public:
static String^ DomainName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Email Field
See Also
[image]
Internal Namespace > CommonRegexes Class : Email Field

Pattern for matching against any valid email address.

Syntax

Visual Basic (Declaration)
Public Shared Email As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.Email

CommonRegexes.Email = value
C#
public static string Email
Managed Extensions for C++
public: static string* Email
C++/CLI
public:
static String^ Email

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
FileName Field
See Also
[image]
Internal Namespace > CommonRegexes Class : FileName Field

Pattern for matching a Windows file path.

Syntax

Visual Basic (Declaration)
Public Shared FileName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.FileName

CommonRegexes.FileName = value
C#
public static string FileName
Managed Extensions for C++
public: static string* FileName
C++/CLI
public:
static String^ FileName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
FilePath Field
See Also
[image]
Internal Namespace > CommonRegexes Class : FilePath Field

Pattern for matching a Windows file path.

Syntax

Visual Basic (Declaration)
Public Shared FilePath As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.FilePath

CommonRegexes.FilePath = value
C#
public static string FilePath
Managed Extensions for C++
public: static string* FilePath
C++/CLI
public:
static String^ FilePath

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
FullyQualifiedUrl Field
See Also
[image]
Internal Namespace > CommonRegexes Class : FullyQualifiedUrl Field

Pattern for matching against any valid URL.

Syntax

Visual Basic (Declaration)
Public Shared FullyQualifiedUrl As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.FullyQualifiedUrl

CommonRegexes.FullyQualifiedUrl = value
C#
public static string FullyQualifiedUrl
Managed Extensions for C++
public: static string* FullyQualifiedUrl
C++/CLI
public:
static String^ FullyQualifiedUrl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
FullyQualifiedUrlFolder Field
See Also
[image]
Internal Namespace > CommonRegexes Class : FullyQualifiedUrlFolder Field

Pattern for matching a fully qualified URL that has no file name.

Syntax

Visual Basic (Declaration)
Public Shared FullyQualifiedUrlFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.FullyQualifiedUrlFolder

CommonRegexes.FullyQualifiedUrlFolder = value
C#
public static string FullyQualifiedUrlFolder
Managed Extensions for C++
public: static string* FullyQualifiedUrlFolder
C++/CLI
public:
static String^ FullyQualifiedUrlFolder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IpAddress Field
See Also
[image]
Internal Namespace > CommonRegexes Class : IpAddress Field

Pattern for matching against any valid IP address.

Syntax

Visual Basic (Declaration)
Public Shared IpAddress As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.IpAddress

CommonRegexes.IpAddress = value
C#
public static string IpAddress
Managed Extensions for C++
public: static string* IpAddress
C++/CLI
public:
static String^ IpAddress

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Url Field
See Also
[image]
Internal Namespace > CommonRegexes Class : Url Field

Pattern for matching against any valid URL.

Syntax

Visual Basic (Declaration)
Public Shared Url As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.Url

CommonRegexes.Url = value
C#
public static string Url
Managed Extensions for C++
public: static string* Url
C++/CLI
public:
static String^ Url

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
UrlFolder Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UrlFolder Field

Pattern for matching against any valid URL that has no file name.

Syntax

Visual Basic (Declaration)
Public Shared UrlFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UrlFolder

CommonRegexes.UrlFolder = value
C#
public static string UrlFolder
Managed Extensions for C++
public: static string* UrlFolder
C++/CLI
public:
static String^ UrlFolder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
UsEin Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsEin Field

Pattern for a US employer identification number.

Syntax

Visual Basic (Declaration)
Public Shared UsEin As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsEin

CommonRegexes.UsEin = value
C#
public static string UsEin
Managed Extensions for C++
public: static string* UsEin
C++/CLI
public:
static String^ UsEin

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
UsPhone Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsPhone Field

Pattern for a US 10-digit phone number.

Syntax

Visual Basic (Declaration)
Public Shared UsPhone As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsPhone

CommonRegexes.UsPhone = value
C#
public static string UsPhone
Managed Extensions for C++
public: static string* UsPhone
C++/CLI
public:
static String^ UsPhone

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
UsSsn Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsSsn Field

Pattern for a US social security number.

Syntax

Visual Basic (Declaration)
Public Shared UsSsn As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsSsn

CommonRegexes.UsSsn = value
C#
public static string UsSsn
Managed Extensions for C++
public: static string* UsSsn
C++/CLI
public:
static String^ UsSsn

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
UsSsnOrEin Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsSsnOrEin Field

Pattern for a US social security number or an employer identification number.

Syntax

Visual Basic (Declaration)
Public Shared UsSsnOrEin As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsSsnOrEin

CommonRegexes.UsSsnOrEin = value
C#
public static string UsSsnOrEin
Managed Extensions for C++
public: static string* UsSsnOrEin
C++/CLI
public:
static String^ UsSsnOrEin

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
UsZip Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsZip Field

Pattern for a US 5-digit zip code with an optional 4 digit exchange.

Syntax

Visual Basic (Declaration)
Public Shared UsZip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsZip

CommonRegexes.UsZip = value
C#
public static string UsZip
Managed Extensions for C++
public: static string* UsZip
C++/CLI
public:
static String^ UsZip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
UsZip5 Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsZip5 Field

Pattern for a US 5-digit zip code.

Syntax

Visual Basic (Declaration)
Public Shared UsZip5 As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsZip5

CommonRegexes.UsZip5 = value
C#
public static string UsZip5
Managed Extensions for C++
public: static string* UsZip5
C++/CLI
public:
static String^ UsZip5

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
UsZip5Plus4 Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsZip5Plus4 Field

Pattern for a US 5-digit zip code plus 4 digit exchange.

Syntax

Visual Basic (Declaration)
Public Shared UsZip5Plus4 As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsZip5Plus4

CommonRegexes.UsZip5Plus4 = value
C#
public static string UsZip5Plus4
Managed Extensions for C++
public: static string* UsZip5Plus4
C++/CLI
public:
static String^ UsZip5Plus4

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%ItemTitle%%

Barcode4NET.Web Send comments on this topic.
O2S.Barcode4NET.Licensing Namespace (Barcode4NET.Web)
See Also Inheritance Hierarchy

Classes

Class | Description
LicenseValidator | Defines a validator for license serial numbers.

See Also

Reference

Barcode4NET.Web Assembly


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LicenseValidator Class
See Also Members
[image]
O2S.Barcode4NET.Licensing Namespace : LicenseValidator Class

Defines a validator for license serial numbers.

Syntax

Visual Basic (Declaration)
Private Class LicenseValidator
Visual Basic (Usage) Copy Code
Dim instance As LicenseValidator
C#
private class LicenseValidator
Managed Extensions for C++
private __gc class LicenseValidator
C++/CLI
private ref class LicenseValidator

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Licensing.LicenseValidator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValidator Members
O2S.Barcode4NET.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
LicenseValidator Class Members
See Also Methods
[image]
O2S.Barcode4NET.Licensing Namespace : LicenseValidator Class

The following tables list the members exposed by LicenseValidator.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetSerialNumber | Reads the serial number from the registry to give a default value to SerialNumber property.
static (Shared in Visual Basic) | ValidateSerialNumber | Validates a serial number based on a license file and a public key.
Top

See Also

Reference

LicenseValidator Class
O2S.Barcode4NET.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
LicenseValidator Class Methods
See Also
[image]
O2S.Barcode4NET.Licensing Namespace : LicenseValidator Class

For a list of all members of this type, see LicenseValidator members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetSerialNumber | Reads the serial number from the registry to give a default value to SerialNumber property.
static (Shared in Visual Basic) | ValidateSerialNumber | Validates a serial number based on a license file and a public key.
Top

See Also

Reference

LicenseValidator Class
O2S.Barcode4NET.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetSerialNumber Method
See Also
[image]
O2S.Barcode4NET.Licensing Namespace > LicenseValidator Class : GetSerialNumber Method

edition
The edition to lookup the serial number for.
version
Version to lookup the serial number for.
Reads the serial number from the registry to give a default value to SerialNumber property.

Syntax

Visual Basic (Declaration)
Public Shared Function GetSerialNumber( _
   ByVal edition As String, _
   ByVal version As String _
) As String
Visual Basic (Usage) Copy Code
Dim edition As String
Dim version As String
Dim value As String

value = LicenseValidator.GetSerialNumber(edition, version)
C#
public static string GetSerialNumber(
   string edition,
   string version
)
Managed Extensions for C++
public: static string* GetSerialNumber(
   string* edition,
   string* version
)
C++/CLI
public:
static String^ GetSerialNumber(
   String^ edition,
   String^ version
)

Parameters

edition
The edition to lookup the serial number for.
version
Version to lookup the serial number for.

Return Value

Serial number if exists, empty string otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValidator Class
LicenseValidator Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ValidateSerialNumber Method
See Also
[image]
O2S.Barcode4NET.Licensing Namespace > LicenseValidator Class : ValidateSerialNumber Method

serialNumber
Serial number to validate.
licenseResourceName
License file the serial number is validated against.
publicKeyResourceName
The public key for validating the serial number.
Validates a serial number based on a license file and a public key.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateSerialNumber( _
   ByVal serialNumber As String, _
   ByVal licenseResourceName As String, _
   ByVal publicKeyResourceName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim serialNumber As String
Dim licenseResourceName As String
Dim publicKeyResourceName As String
Dim value As Boolean

value = LicenseValidator.ValidateSerialNumber(serialNumber, licenseResourceName, publicKeyResourceName)
C#
public static bool ValidateSerialNumber(
   string serialNumber,
   string licenseResourceName,
   string publicKeyResourceName
)
Managed Extensions for C++
public: static bool ValidateSerialNumber(
   string* serialNumber,
   string* licenseResourceName,
   string* publicKeyResourceName
)
C++/CLI
public:
static bool ValidateSerialNumber(
   String^ serialNumber,
   String^ licenseResourceName,
   String^ publicKeyResourceName
)

Parameters

serialNumber
Serial number to validate.
licenseResourceName
License file the serial number is validated against.
publicKeyResourceName
The public key for validating the serial number.

Return Value

True if the serial number is valid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValidator Class
LicenseValidator Members


%%ItemTitle%%

Barcode4NET.Web Send comments on this topic.
O2S.Barcode4NET.WebControls Namespace
See Also Inheritance Hierarchy
Root namespace for all server controls included in Barcode4NET.Web assembly.

Classes

Class | Description
BarcodeService | Http handler for serving barcode images.
BarcodeView | Represents a barcode control displayed on a web form.

Enumerations

Enumeration | Description
ImageStreamingMode | Specifies the available modes for streaming a barcode image to the browser.
ImageType | Specifies the available image types for rendering a barcode in the browser.

See Also

Reference

Barcode4NET.Web Assembly


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BarcodeService Class
See Also Members
[image]
O2S.Barcode4NET.WebControls Namespace : BarcodeService Class

Http handler for serving barcode images.

Syntax

Visual Basic (Declaration)
Public Class BarcodeService
Visual Basic (Usage) Copy Code
Dim instance As BarcodeService
C#
public class BarcodeService
Managed Extensions for C++
public __gc class BarcodeService
C++/CLI
public ref class BarcodeService

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.WebControls.BarcodeService

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeService Members
O2S.Barcode4NET.WebControls Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
BarcodeService Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET.WebControls Namespace : BarcodeService Class

The following tables list the members exposed by BarcodeService.

Public Constructors

 | Name | Description
Public Constructor | BarcodeService Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsReusable | The handler is reusable.
Top

Public Methods

 | Name | Description
Public Method | ProcessRequest | Process current request and serve the barcode image.
Top

See Also

Reference

BarcodeService Class
O2S.Barcode4NET.WebControls Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BarcodeService Constructor
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeService Class : BarcodeService Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeService()
C#
public BarcodeService()
Managed Extensions for C++
public: BarcodeService();
C++/CLI
public:
BarcodeService();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeService Class
BarcodeService Members


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
BarcodeService Class Methods
See Also
[image]
O2S.Barcode4NET.WebControls Namespace : BarcodeService Class

For a list of all members of this type, see BarcodeService members.

Public Methods

 | Name | Description
Public Method | ProcessRequest | Process current request and serve the barcode image.
Top

See Also

Reference

BarcodeService Class
O2S.Barcode4NET.WebControls Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ProcessRequest Method
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeService Class : ProcessRequest Method

context
Current request context.
Process current request and serve the barcode image.

Syntax

Visual Basic (Declaration)
Public Sub ProcessRequest( _
   ByVal context As HttpContext _
)
Visual Basic (Usage) Copy Code
Dim instance As BarcodeService
Dim context As HttpContext

instance.ProcessRequest(context)
C#
public void ProcessRequest(
   HttpContext context
)
Managed Extensions for C++
public: void ProcessRequest(
   HttpContext context
)
C++/CLI
public:
void ProcessRequest(
   HttpContext context
)

Parameters

context
Current request context.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeService Class
BarcodeService Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Web Send comments on this topic.
BarcodeService Class Properties
See Also
[image]
O2S.Barcode4NET.WebControls Namespace : BarcodeService Class

For a list of all members of this type, see BarcodeService members.

Public Properties

 | Name | Description
Public Property | IsReusable | The handler is reusable.
Top

See Also

Reference

BarcodeService Class
O2S.Barcode4NET.WebControls Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IsReusable Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeService Class : IsReusable Property

The handler is reusable.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReusable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BarcodeService
Dim value As Boolean

value = instance.IsReusable
C#
public bool IsReusable {get;}
Managed Extensions for C++
public: __property bool get_IsReusable();
C++/CLI
public:
property bool IsReusable {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeService Class
BarcodeService Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BarcodeView Class
See Also Members
[image]
O2S.Barcode4NET.WebControls Namespace : BarcodeView Class

Represents a barcode control displayed on a web form.

Object Model

Syntax

Visual Basic (Declaration)
Public Class BarcodeView
   Inherits WebControl
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
C#
public class BarcodeView : WebControl
Managed Extensions for C++
public __gc class BarcodeView : public WebControl
C++/CLI
public ref class BarcodeView : public WebControl

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
O2S.Barcode4NET.WebControls.BarcodeView

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Members
O2S.Barcode4NET.WebControls Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
BarcodeView Class Members
See Also Properties Methods Events
[image]
O2S.Barcode4NET.WebControls Namespace : BarcodeView Class

The following tables list the members exposed by BarcodeView.

Public Constructors

 | Name | Description
Public Constructor | BarcodeView Constructor | Initializes a new BarcodeView object.
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | Overridden. Gets or sets the background color for the barcode.
Public Property | Barcode | Gets the Barcode object behind the control.
Public Property | BarColor | Gets or sets the bars color for the barcode.
Public Property | BorderColor | Gets or sets the border color of the Web control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode.
Public Property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | CodablockFColumns | Gets or sets the number of columns in this CODABLOCK F barcode.
Public Property | CodablockFRows | Gets or sets the number of rows in this CODABLOCK F barcode.
Public Property | Code16KRows | Gets or sets the number of rows in this Code 16K barcode.
Public Property | Code39WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Data | Gets or sets the data displayed in the control.
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DataMatrixEncoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | DataMatrixSymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties.
Public Property | DisplayCheckSum | Gets or sets a value indicating whether the check characters should be displayed in barcode text.
Public Property | EANSupplement | Gets or sets the supplement for barcode data.
Public Property | EANSupplementDisplayLocation | Gets or sets the location of the EAN supplement text.
Public Property | EANSupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum character should be appended automatically to the barcode.
Public Property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from System.Web.UI.Control)
Public Property | Font | Gets or sets the font of the barcode text displayed in the control.
Public Property | ForeColor | Overridden. Gets or sets the fore color of the control.
Public Property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Gets or sets the height of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from System.Web.UI.Control)
Public Property | ImageStreamingMode | Gets or sets the mode the barcode image is streamed to the browser.
Public Property | ImageStreamingUrl | Gets or sets the streaming url for the barcode image.
Public Property | ImageType | Gets or sets the type of the barcode image.
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode.
Public Property | MicroPDF417SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from System.Web.UI.Control)
Public Property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | Pdf417Columns | Gets or sets the number of columns in this PDF417 barcode.
Public Property | Pdf417DataCompactionMode | Gets or sets the data compaction mode for this PDF417 barcode.
Public Property | Pdf417ErrorCorrectionLevel | Gets or sets the level of error correction used by this PDF417 barcode.
Public Property | Pdf417Rows | Gets or sets the number of rows in this PDF417 barcode.
Public Property | Resolution | Gets or sets the resolution of the barcode image.
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode.
Public Property | Rotation | Gets or sets the rotation angle of the barcode.
Public Property | SerialNumber | Gets or sets the serial number.
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Symbology | Gets or sets the type of the barcode displayed in the control.
Public Property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property | TextColor | Gets or sets the text color for the barcode.
Public Property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode.
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from System.Web.UI.Control)
Public Property | Width | Gets or sets the width of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | XDimension | Gets or sets the width of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from System.Web.UI.Control)
Public Method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from System.Web.UI.Control)
Public Method | FindControl | Searches the current naming container for a server control with the specified id parameter. (Inherited from System.Web.UI.Control)
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | Load | Occurs when the server control is loaded into the Page object. (Inherited from System.Web.UI.Control)
Public Event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top

See Also

Reference

BarcodeView Class
O2S.Barcode4NET.WebControls Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BarcodeView Constructor
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : BarcodeView Constructor

Initializes a new BarcodeView object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView()
C#
public BarcodeView()
Managed Extensions for C++
public: BarcodeView();
C++/CLI
public:
BarcodeView();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Web Send comments on this topic.
BarcodeView Class Properties
See Also
[image]
O2S.Barcode4NET.WebControls Namespace : BarcodeView Class

For a list of all members of this type, see BarcodeView members.

Public Properties

 | Name | Description
Public Property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | Overridden. Gets or sets the background color for the barcode.
Public Property | Barcode | Gets the Barcode object behind the control.
Public Property | BarColor | Gets or sets the bars color for the barcode.
Public Property | BorderColor | Gets or sets the border color of the Web control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode.
Public Property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | CodablockFColumns | Gets or sets the number of columns in this CODABLOCK F barcode.
Public Property | CodablockFRows | Gets or sets the number of rows in this CODABLOCK F barcode.
Public Property | Code16KRows | Gets or sets the number of rows in this Code 16K barcode.
Public Property | Code39WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Data | Gets or sets the data displayed in the control.
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DataMatrixEncoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | DataMatrixSymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties.
Public Property | DisplayCheckSum | Gets or sets a value indicating whether the check characters should be displayed in barcode text.
Public Property | EANSupplement | Gets or sets the supplement for barcode data.
Public Property | EANSupplementDisplayLocation | Gets or sets the location of the EAN supplement text.
Public Property | EANSupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum character should be appended automatically to the barcode.
Public Property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from System.Web.UI.Control)
Public Property | Font | Gets or sets the font of the barcode text displayed in the control.
Public Property | ForeColor | Overridden. Gets or sets the fore color of the control.
Public Property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Gets or sets the height of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from System.Web.UI.Control)
Public Property | ImageStreamingMode | Gets or sets the mode the barcode image is streamed to the browser.
Public Property | ImageStreamingUrl | Gets or sets the streaming url for the barcode image.
Public Property | ImageType | Gets or sets the type of the barcode image.
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode.
Public Property | MicroPDF417SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from System.Web.UI.Control)
Public Property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | Pdf417Columns | Gets or sets the number of columns in this PDF417 barcode.
Public Property | Pdf417DataCompactionMode | Gets or sets the data compaction mode for this PDF417 barcode.
Public Property | Pdf417ErrorCorrectionLevel | Gets or sets the level of error correction used by this PDF417 barcode.
Public Property | Pdf417Rows | Gets or sets the number of rows in this PDF417 barcode.
Public Property | Resolution | Gets or sets the resolution of the barcode image.
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode.
Public Property | Rotation | Gets or sets the rotation angle of the barcode.
Public Property | SerialNumber | Gets or sets the serial number.
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Symbology | Gets or sets the type of the barcode displayed in the control.
Public Property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property | TextColor | Gets or sets the text color for the barcode.
Public Property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode.
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from System.Web.UI.Control)
Public Property | Width | Gets or sets the width of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | XDimension | Gets or sets the width of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

See Also

Reference

BarcodeView Class
O2S.Barcode4NET.WebControls Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BackColor Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : BackColor Property

Gets or sets the background color for the barcode.

Syntax

Visual Basic (Declaration)
Overrides Public Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
public override Color BackColor {get; set;}
Managed Extensions for C++
public: __property Color get_BackColor()override ;
public: __property void set_BackColor(
   Color value
)override ;
C++/CLI
public:
property Color BackColor override {
   Color get();
   void set (Color value);
}

Return Value

A Color that represents the background color of the barcode. The default value is White.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Barcode Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : Barcode Property

Gets the Barcode object behind the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Barcode As Barcode
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Barcode

value = instance.Barcode
C#
public Barcode Barcode {get;}
Managed Extensions for C++
public: __property Barcode* get_Barcode();
C++/CLI
public:
property Barcode^ Barcode {
   Barcode^ get();
}

Return Value

A Barcode object that represents the barcode displayed in the control.

Remarks

Do not modify the underlying Barcode object directly because the changes will not be reflected in the control.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BarColor Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : BarColor Property

Gets or sets the bars color for the barcode.

Syntax

Visual Basic (Declaration)
Public Property BarColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Color

instance.BarColor = value

value = instance.BarColor
C#
public Color BarColor {get; set;}
Managed Extensions for C++
public: __property Color get_BarColor();
public: __property void set_BarColor(
   Color value
);
C++/CLI
public:
property Color BarColor {
   Color get();
   void set (Color value);
}

Return Value

A Color that represents the bars color of the barcode. The default value is Black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BottomQuietZone Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : BottomQuietZone Property

Gets or sets the bottom quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property BottomQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.BottomQuietZone = value

value = instance.BottomQuietZone
C#
public float BottomQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_BottomQuietZone();
public: __property void set_BottomQuietZone(
   float value
);
C++/CLI
public:
property float BottomQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of bottom quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the bottom quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
CodablockFColumns Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : CodablockFColumns Property

Gets or sets the number of columns in this CODABLOCK F barcode.

Syntax

Visual Basic (Declaration)
Public Property CodablockFColumns As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Integer

instance.CodablockFColumns = value

value = instance.CodablockFColumns
C#
public int CodablockFColumns {get; set;}
Managed Extensions for C++
public: __property int get_CodablockFColumns();
public: __property void set_CodablockFColumns(
   int value
);
C++/CLI
public:
property int CodablockFColumns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this CODABLOCK F barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 7 or greater than 65.

Remarks

The minimum number of columns in a CODABLOCK F barcode is 7 and the maximum number of columns is 65. This property includes the character subset selector, row indicator and row check columns.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
CodablockFRows Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : CodablockFRows Property

Gets or sets the number of rows in this CODABLOCK F barcode.

Syntax

Visual Basic (Declaration)
Public Property CodablockFRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Integer

instance.CodablockFRows = value

value = instance.CodablockFRows
C#
public int CodablockFRows {get; set;}
Managed Extensions for C++
public: __property int get_CodablockFRows();
public: __property void set_CodablockFRows(
   int value
);
C++/CLI
public:
property int CodablockFRows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows in this CODABLOCK F barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2 or greater than 44.

Remarks

The minimum number of rows in a CODABLOCK F barcode is 2 and the maximum number of rows is 44.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Code16KRows Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : Code16KRows Property

Gets or sets the number of rows in this Code 16K barcode.

Syntax

Visual Basic (Declaration)
Public Property Code16KRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Integer

instance.Code16KRows = value

value = instance.Code16KRows
C#
public int Code16KRows {get; set;}
Managed Extensions for C++
public: __property int get_Code16KRows();
public: __property void set_Code16KRows(
   int value
);
C++/CLI
public:
property int Code16KRows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows in this Code 16K barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2 but not 0, or greater than 16.

Remarks

The minimum number of rows in a Code 16K barcode is 2 and the maximum number of rows is 16. If this property is 0, the number of rows is calculated automatically to accomodate the barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Code39WideToNarrowRatio Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : Code39WideToNarrowRatio Property

Gets or sets the ratio between wide bars and narrow bars.

Syntax

Visual Basic (Declaration)
Public Property Code39WideToNarrowRatio As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.Code39WideToNarrowRatio = value

value = instance.Code39WideToNarrowRatio
C#
public float Code39WideToNarrowRatio {get; set;}
Managed Extensions for C++
public: __property float get_Code39WideToNarrowRatio();
public: __property void set_Code39WideToNarrowRatio(
   float value
);
C++/CLI
public:
property float Code39WideToNarrowRatio {
   float get();
   void set (float value);
}

Return Value

A float value specifying the ratio between wide bars and narrow bars.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.
This property applies to Code39 barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Data Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : Data Property

Gets or sets the data displayed in the control.

Syntax

Visual Basic (Declaration)
Public Property Data As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As String

instance.Data = value

value = instance.Data
C#
public string Data {get; set;}
Managed Extensions for C++
public: __property string* get_Data();
public: __property void set_Data(
   string* value
);
C++/CLI
public:
property String^ Data {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing the data displayed in the control as a barcode.

Exceptions

Exception | Description
ArgumentException | Thrown if the data can not be encoded as a barcode of the select symbology.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
DataDisplayLocation Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : DataDisplayLocation Property

Gets or sets the location of the barcode data.

Syntax

Visual Basic (Declaration)
Public Property DataDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As BarcodeTextLocation

instance.DataDisplayLocation = value

value = instance.DataDisplayLocation
C#
public BarcodeTextLocation DataDisplayLocation {get; set;}
Managed Extensions for C++
public: __property BarcodeTextLocation get_DataDisplayLocation();
public: __property void set_DataDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation DataDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location of the barcode data when it is displayed on the barcode.

Remarks

This property applies to 1D barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
DataMatrixEncoding Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : DataMatrixEncoding Property

Gets or sets the encoding of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property DataMatrixEncoding As DataMatrixEncoding
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As DataMatrixEncoding

instance.DataMatrixEncoding = value

value = instance.DataMatrixEncoding
C#
public DataMatrixEncoding DataMatrixEncoding {get; set;}
Managed Extensions for C++
public: __property DataMatrixEncoding get_DataMatrixEncoding();
public: __property void set_DataMatrixEncoding(
   DataMatrixEncoding value
);
C++/CLI
public:
property DataMatrixEncoding DataMatrixEncoding {
   DataMatrixEncoding get();
   void set (DataMatrixEncoding value);
}

Return Value

A DataMatrixEncoding enumeration member specifying the data encoding for this DataMatrix barcode.

Remarks

If the data to encode contains only numbers (ASCII characters from 0x30 to 0x39), then Numeric provides the best encoding. If the data to encode contains only base ASCII characters (0x00 to 0x7F), then both ASCII and Base256 encoding provide the same performance, but if the data to encode contains more than 3 extended ASCII characters (0x80 to 0xFF) then the Base256 encoding is the best option.
If the selected encoding is Auto, then the library will select the encoding that will generate the smallest encoded data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
DataMatrixSymbolSize Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : DataMatrixSymbolSize Property

Gets or sets the symbol size of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property DataMatrixSymbolSize As DataMatrixSymbolSize
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As DataMatrixSymbolSize

instance.DataMatrixSymbolSize = value

value = instance.DataMatrixSymbolSize
C#
public DataMatrixSymbolSize DataMatrixSymbolSize {get; set;}
Managed Extensions for C++
public: __property DataMatrixSymbolSize get_DataMatrixSymbolSize();
public: __property void set_DataMatrixSymbolSize(
   DataMatrixSymbolSize value
);
C++/CLI
public:
property DataMatrixSymbolSize DataMatrixSymbolSize {
   DataMatrixSymbolSize get();
   void set (DataMatrixSymbolSize value);
}

Return Value

A DataMatrixSymbolSize enumeration member specifying the size of symbol used to represent this DataMatrix barcode.

Remarks

If the SymbolSize is Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
DimensionUnit Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : DimensionUnit Property

Gets or sets the measure unit for the XDimension and YDimension properties.

Syntax

Visual Basic (Declaration)
Public Property DimensionUnit As XYDimensionUnit
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As XYDimensionUnit

instance.DimensionUnit = value

value = instance.DimensionUnit
C#
public XYDimensionUnit DimensionUnit {get; set;}
Managed Extensions for C++
public: __property XYDimensionUnit get_DimensionUnit();
public: __property void set_DimensionUnit(
   XYDimensionUnit value
);
C++/CLI
public:
property XYDimensionUnit DimensionUnit {
   XYDimensionUnit get();
   void set (XYDimensionUnit value);
}

Return Value

A XYDimensionUnit enumeration member specifying the measure unit for the XDimension and YDimension properties.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
DisplayCheckSum Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : DisplayCheckSum Property

Gets or sets a value indicating whether the check characters should be displayed in barcode text.

Syntax

Visual Basic (Declaration)
Public Property DisplayCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Boolean

instance.DisplayCheckSum = value

value = instance.DisplayCheckSum
C#
public bool DisplayCheckSum {get; set;}
Managed Extensions for C++
public: __property bool get_DisplayCheckSum();
public: __property void set_DisplayCheckSum(
   bool value
);
C++/CLI
public:
property bool DisplayCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if the check characters should be displayed. Default is false.

Remarks

This property applies to 1D barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
EANSupplement Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : EANSupplement Property

Gets or sets the supplement for barcode data.

Syntax

Visual Basic (Declaration)
Public Property EANSupplement As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As String

instance.EANSupplement = value

value = instance.EANSupplement
C#
public string EANSupplement {get; set;}
Managed Extensions for C++
public: __property string* get_EANSupplement();
public: __property void set_EANSupplement(
   string* value
);
C++/CLI
public:
property String^ EANSupplement {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying a 2 or 5 digit supplemental barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in supplement data or the supplement does not have the required length (2 or 5 digits).

Remarks

This supplement is optional. If it exists, it can be only 2 or 5 digits.
This property applies to EAN13, EAN8, ISBN, ISMN, ISSN, JAN13, UPC-A and UPC-E barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
EANSupplementDisplayLocation Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : EANSupplementDisplayLocation Property

Gets or sets the location of the EAN supplement text.

Syntax

Visual Basic (Declaration)
Public Property EANSupplementDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As BarcodeTextLocation

instance.EANSupplementDisplayLocation = value

value = instance.EANSupplementDisplayLocation
C#
public BarcodeTextLocation EANSupplementDisplayLocation {get; set;}
Managed Extensions for C++
public: __property BarcodeTextLocation get_EANSupplementDisplayLocation();
public: __property void set_EANSupplementDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation EANSupplementDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location where the supplement text is displayed.

Remarks

The embedding options are ignored for supplement text. AboveEmbedded has the same effect like Above, and BelowEmbedded has the same effect like Below.
This property applies to EAN13, EAN8, ISBN, ISMN, ISSN, JAN13, UPC-A and UPC-E barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
EANSupplementYDimension Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : EANSupplementYDimension Property

Gets or sets the height of a bar in the supplement barcode.

Syntax

Visual Basic (Declaration)
Public Property EANSupplementYDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.EANSupplementYDimension = value

value = instance.EANSupplementYDimension
C#
public float EANSupplementYDimension {get; set;}
Managed Extensions for C++
public: __property float get_EANSupplementYDimension();
public: __property void set_EANSupplementYDimension(
   float value
);
C++/CLI
public:
property float EANSupplementYDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a bar in the supplement barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
EnableCheckSum Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : EnableCheckSum Property

Gets or sets a value indicating whether a checksum character should be appended automatically to the barcode.

Syntax

Visual Basic (Declaration)
Public Property EnableCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Boolean

instance.EnableCheckSum = value

value = instance.EnableCheckSum
C#
public bool EnableCheckSum {get; set;}
Managed Extensions for C++
public: __property bool get_EnableCheckSum();
public: __property void set_EnableCheckSum(
   bool value
);
C++/CLI
public:
property bool EnableCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if a checksum character should be appended automatically to the barcode, false otherwise.

Remarks

This property applies to 1D barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Font Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : Font Property

Gets or sets the font of the barcode text displayed in the control.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Font

instance.Font = value

value = instance.Font
C#
public Font Font {get; set;}
Managed Extensions for C++
public: __property Font get_Font();
public: __property void set_Font(
   Font value
);
C++/CLI
public:
property Font Font {
   Font get();
   void set (Font value);
}

Return Value

The Font object to apply to the barcode text displayed in the control.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ForeColor Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : ForeColor Property

Gets or sets the fore color of the control.

Syntax

Visual Basic (Declaration)
Overrides Public Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
C#
public override Color ForeColor {get; set;}
Managed Extensions for C++
public: __property Color get_ForeColor()override ;
public: __property void set_ForeColor(
   Color value
)override ;
C++/CLI
public:
property Color ForeColor override {
   Color get();
   void set (Color value);
}

Remarks

This property is not used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ImageStreamingMode Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : ImageStreamingMode Property

Gets or sets the mode the barcode image is streamed to the browser.

Syntax

Visual Basic (Declaration)
Public Property ImageStreamingMode As ImageStreamingMode
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As ImageStreamingMode

instance.ImageStreamingMode = value

value = instance.ImageStreamingMode
C#
public ImageStreamingMode ImageStreamingMode {get; set;}
Managed Extensions for C++
public: __property ImageStreamingMode get_ImageStreamingMode();
public: __property void set_ImageStreamingMode(
   ImageStreamingMode value
);
C++/CLI
public:
property ImageStreamingMode ImageStreamingMode {
   ImageStreamingMode get();
   void set (ImageStreamingMode value);
}

Return Value

A ImageStreamingMode enumeration member specifying the mode the barcode image is streamed to the browser.

Remarks

If this property is ServerPage or TempFile then the ImageStreamingUrl property needs to be set.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ImageStreamingUrl Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : ImageStreamingUrl Property

Gets or sets the streaming url for the barcode image.

Syntax

Visual Basic (Declaration)
Public Property ImageStreamingUrl As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As String

instance.ImageStreamingUrl = value

value = instance.ImageStreamingUrl
C#
public string ImageStreamingUrl {get; set;}
Managed Extensions for C++
public: __property string* get_ImageStreamingUrl();
public: __property void set_ImageStreamingUrl(
   string* value
);
C++/CLI
public:
property String^ ImageStreamingUrl {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the streaming Url for the barcode image.

Remarks

This property needs to be set only if ImageStreamingMode property is ServerPage or TempFile.
If ImageStreamingMode property is ServerPage, then this property needs to specify the virtual path to barcode4net.aspx page. This page is included in the installation kit and it is used to generate the barcode image.
If ImageStreamingMode property is TempFile, then this property needs to specify the virtual folder where the temporary barcode image is saved. The ASP.NET machine user needs write access on this folder in order to create the barcode image.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ImageType Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : ImageType Property

Gets or sets the type of the barcode image.

Syntax

Visual Basic (Declaration)
Public Property ImageType As ImageType
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As ImageType

instance.ImageType = value

value = instance.ImageType
C#
public ImageType ImageType {get; set;}
Managed Extensions for C++
public: __property ImageType get_ImageType();
public: __property void set_ImageType(
   ImageType value
);
C++/CLI
public:
property ImageType ImageType {
   ImageType get();
   void set (ImageType value);
}

Return Value

A ImageType enumeration member specifying the type of the barcode image.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LeftQuietZone Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : LeftQuietZone Property

Gets or sets the left quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property LeftQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.LeftQuietZone = value

value = instance.LeftQuietZone
C#
public float LeftQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_LeftQuietZone();
public: __property void set_LeftQuietZone(
   float value
);
C++/CLI
public:
property float LeftQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of left quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the left quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MicroPDF417SymbolSize Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : MicroPDF417SymbolSize Property

Gets or sets the symbol size of this Micro PDF 417 barcode.

Syntax

Visual Basic (Declaration)
Public Property MicroPDF417SymbolSize As MicroPDF417SymbolSize
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As MicroPDF417SymbolSize

instance.MicroPDF417SymbolSize = value

value = instance.MicroPDF417SymbolSize
C#
public MicroPDF417SymbolSize MicroPDF417SymbolSize {get; set;}
Managed Extensions for C++
public: __property MicroPDF417SymbolSize get_MicroPDF417SymbolSize();
public: __property void set_MicroPDF417SymbolSize(
   MicroPDF417SymbolSize value
);
C++/CLI
public:
property MicroPDF417SymbolSize MicroPDF417SymbolSize {
   MicroPDF417SymbolSize get();
   void set (MicroPDF417SymbolSize value);
}

Return Value

A MicroPDF417SymbolSize enumeration member specifying the size of symbol used to represent this Micro PDF 417 barcode.

Remarks

If the SymbolSize is Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Pdf417Columns Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : Pdf417Columns Property

Gets or sets the number of columns in this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Integer

instance.Pdf417Columns = value

value = instance.Pdf417Columns
C#
public int Pdf417Columns {get; set;}
Managed Extensions for C++
public: __property int get_Pdf417Columns();
public: __property void set_Pdf417Columns(
   int value
);
C++/CLI
public:
property int Pdf417Columns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this PDF417 barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 1 or greater than 30 - OR - Throws when value is 0 and Pdf417Rows is also 0.

Remarks

The minimum number of columns in a PDF 417 barcode is 1 and the maximum number of columns is 30. If this property is 0, the library will compute automatically the number of required columns to encode the barcode data. When this property is 0, the Pdf417Rows property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Pdf417DataCompactionMode Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : Pdf417DataCompactionMode Property

Gets or sets the data compaction mode for this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417DataCompactionMode As PDF417DataCompactionMode
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As PDF417DataCompactionMode

instance.Pdf417DataCompactionMode = value

value = instance.Pdf417DataCompactionMode
C#
public PDF417DataCompactionMode Pdf417DataCompactionMode {get; set;}
Managed Extensions for C++
public: __property PDF417DataCompactionMode get_Pdf417DataCompactionMode();
public: __property void set_Pdf417DataCompactionMode(
   PDF417DataCompactionMode value
);
C++/CLI
public:
property PDF417DataCompactionMode Pdf417DataCompactionMode {
   PDF417DataCompactionMode get();
   void set (PDF417DataCompactionMode value);
}

Return Value

A PDF417DataCompactionMode enumeration member specifying the data compaction mode used in this PDF417 barcode.

Remarks

The Text compaction mode provides a 2:1 compaction ratio when using only ASCII characters from 0x20 to 0x7F. The Numeric compaction mode provides a 2.93:1 compaction ratio when using only digits (0x30 to 0x39). Byte compaction mode provides a 1.2:1 compaction ratio when using any 8bit character.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Pdf417ErrorCorrectionLevel Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : Pdf417ErrorCorrectionLevel Property

Gets or sets the level of error correction used by this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417ErrorCorrectionLevel As PDF417ErrorCorrectionLevel
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As PDF417ErrorCorrectionLevel

instance.Pdf417ErrorCorrectionLevel = value

value = instance.Pdf417ErrorCorrectionLevel
C#
public PDF417ErrorCorrectionLevel Pdf417ErrorCorrectionLevel {get; set;}
Managed Extensions for C++
public: __property PDF417ErrorCorrectionLevel get_Pdf417ErrorCorrectionLevel();
public: __property void set_Pdf417ErrorCorrectionLevel(
   PDF417ErrorCorrectionLevel value
);
C++/CLI
public:
property PDF417ErrorCorrectionLevel Pdf417ErrorCorrectionLevel {
   PDF417ErrorCorrectionLevel get();
   void set (PDF417ErrorCorrectionLevel value);
}

Return Value

A PDF417ErrorCorrectionLevel enumeration member specifying the level or error correction used by this PDF417 barcode.

Remarks

The lowest error correction level is 0 and the greatest error correction level is 8. Each level generates a specific number of error correction codewords.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Pdf417Rows Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : Pdf417Rows Property

Gets or sets the number of rows in this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Integer

instance.Pdf417Rows = value

value = instance.Pdf417Rows
C#
public int Pdf417Rows {get; set;}
Managed Extensions for C++
public: __property int get_Pdf417Rows();
public: __property void set_Pdf417Rows(
   int value
);
C++/CLI
public:
property int Pdf417Rows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows used by this PDF417 barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 3, but not 0, or greater than 90 - OR - Throws when value is 0 and Pdf417Columns is also 0.

Remarks

The minimum number of rows in a PDF 417 barcode is 3 and the maximum number of rows is 90. If this property is 0, the library will compute automatically the number of required rows to encode the barcode data. When this property is 0, the Pdf417Columns property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Resolution Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : Resolution Property

Gets or sets the resolution of the barcode image.

Syntax

Visual Basic (Declaration)
Public Property Resolution As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Integer

instance.Resolution = value

value = instance.Resolution
C#
public int Resolution {get; set;}
Managed Extensions for C++
public: __property int get_Resolution();
public: __property void set_Resolution(
   int value
);
C++/CLI
public:
property int Resolution {
   int get();
   void set (int value);
}

Return Value

An integer value representing the resolution of the barcode image.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown if the value is less than or equal to zero.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
RightQuietZone Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : RightQuietZone Property

Gets or sets the right quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property RightQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.RightQuietZone = value

value = instance.RightQuietZone
C#
public float RightQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_RightQuietZone();
public: __property void set_RightQuietZone(
   float value
);
C++/CLI
public:
property float RightQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of right quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the right quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Rotation Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : Rotation Property

Gets or sets the rotation angle of the barcode.

Syntax

Visual Basic (Declaration)
Public Property Rotation As BarcodeRotation
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As BarcodeRotation

instance.Rotation = value

value = instance.Rotation
C#
public BarcodeRotation Rotation {get; set;}
Managed Extensions for C++
public: __property BarcodeRotation get_Rotation();
public: __property void set_Rotation(
   BarcodeRotation value
);
C++/CLI
public:
property BarcodeRotation Rotation {
   BarcodeRotation get();
   void set (BarcodeRotation value);
}

Return Value

A BarcodeRotation enumeration member specifying the angle used for rotating the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SerialNumber Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : SerialNumber Property

Gets or sets the serial number.

Syntax

Visual Basic (Declaration)
Public Property SerialNumber As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As String

instance.SerialNumber = value

value = instance.SerialNumber
C#
public string SerialNumber {get; set;}
Managed Extensions for C++
public: __property string* get_SerialNumber();
public: __property void set_SerialNumber(
   string* value
);
C++/CLI
public:
property String^ SerialNumber {
   String^ get();
   void set (String^ value);
}

Return Value

The Barcode4NET serial number.

Remarks

The serial number unlocks the BarcodeView ASP.NET server control and removes the TRIAL watermark from the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Symbology Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : Symbology Property

Gets or sets the type of the barcode displayed in the control.

Syntax

Visual Basic (Declaration)
Public Property Symbology As BarcodeSymbology
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As BarcodeSymbology

instance.Symbology = value

value = instance.Symbology
C#
public BarcodeSymbology Symbology {get; set;}
Managed Extensions for C++
public: __property BarcodeSymbology get_Symbology();
public: __property void set_Symbology(
   BarcodeSymbology value
);
C++/CLI
public:
property BarcodeSymbology Symbology {
   BarcodeSymbology get();
   void set (BarcodeSymbology value);
}

Return Value

A BarcodeSymbology enumeration member specifying the type of the barcode displayed in the control.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
TextColor Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : TextColor Property

Gets or sets the text color for the barcode.

Syntax

Visual Basic (Declaration)
Public Property TextColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Color

instance.TextColor = value

value = instance.TextColor
C#
public Color TextColor {get; set;}
Managed Extensions for C++
public: __property Color get_TextColor();
public: __property void set_TextColor(
   Color value
);
C++/CLI
public:
property Color TextColor {
   Color get();
   void set (Color value);
}

Return Value

A Color that represents the color used to display the barcode text.The default value is Black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
TopQuietZone Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : TopQuietZone Property

Gets or sets the top quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property TopQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.TopQuietZone = value

value = instance.TopQuietZone
C#
public float TopQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_TopQuietZone();
public: __property void set_TopQuietZone(
   float value
);
C++/CLI
public:
property float TopQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of top quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the top quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
XDimension Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : XDimension Property

Gets or sets the width of a narrow bar.

Syntax

Visual Basic (Declaration)
Public Property XDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.XDimension = value

value = instance.XDimension
C#
public float XDimension {get; set;}
Managed Extensions for C++
public: __property float get_XDimension();
public: __property void set_XDimension(
   float value
);
C++/CLI
public:
property float XDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of a narrow bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.
The recommended width of a narrow bar is 12 mills. Depending on the barcode printer resolution and quality of barcode scanner, the XDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower XDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
YDimension Property
See Also
[image]
O2S.Barcode4NET.WebControls Namespace > BarcodeView Class : YDimension Property

Gets or sets the height of a bar.

Syntax

Visual Basic (Declaration)
Public Property YDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.YDimension = value

value = instance.YDimension
C#
public float YDimension {get; set;}
Managed Extensions for C++
public: __property float get_YDimension();
public: __property void set_YDimension(
   float value
);
C++/CLI
public:
property float YDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ImageStreamingMode Enumeration
See Also
[image]
O2S.Barcode4NET.WebControls Namespace : ImageStreamingMode Enumeration

Specifies the available modes for streaming a barcode image to the browser.

Syntax

Visual Basic (Declaration)
Public Enum ImageStreamingMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ImageStreamingMode
C#
public enum ImageStreamingMode : Enum
Managed Extensions for C++
__value public enum ImageStreamingMode : public Enum
C++/CLI
public enum class ImageStreamingMode : public Enum

Members

Member | Description
HttpHandler | The barcode image is streamed to the browser using a Http handler. No temporary files are created. Additional configuration required in application's web.config file.
ServerPage | The barcode image is streamed to the browser using an aspx page. No temporary files are created.
TempFile | The barcode image is streamed to the browser using a temporary file. A folder with write access for ASP.NET machine user is required for this method.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.WebControls.ImageStreamingMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET.WebControls Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ImageType Enumeration
See Also
[image]
O2S.Barcode4NET.WebControls Namespace : ImageType Enumeration

Specifies the available image types for rendering a barcode in the browser.

Syntax

Visual Basic (Declaration)
Public Enum ImageType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ImageType
C#
public enum ImageType : Enum
Managed Extensions for C++
__value public enum ImageType : public Enum
C++/CLI
public enum class ImageType : public Enum

Members

Member | Description
Bmp | Bitmap image - supported only by Microsoft Internet Explorer.
Gif | Gif image.
Jpeg | Jpeg image.
Png | Png image.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.WebControls.ImageType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET.WebControls Namespace


%%ItemTitle%%

Barcode4NET.Web Send comments on this topic.
Xheo.Licensing Namespace (Barcode4NET.Web)
See Also Inheritance Hierarchy

Classes

Class | Description
BigInteger | Implements an large integer of arbitrary length.
ContainerLimit | Serves as a base class for limits that contain other limits.
ExtendedLicense | Primary class for the XHEO|Licensing framework.
ExtendedLicenseException | Represents an exception in a Xheo assembly with a localized FriendlyMessage and DetailedMessage.
ExtendedLicensePack | Represents a collection of licenses stored in a single .LIC file.
LicenseSigningKey | Implements a key pair for signing licenses.
LicenseValuesCollection | Maintains a collection of name value pairs. The collection can be serialized and marked as read only.
Limit | Base class for all license limitations.
LimitCollection | Services as a collection of limits.
MachineProfile | Manages a machine profile used by the license activation system. Profiles represent a collection of generally non volitale system properties that can collectively be used to identify certain machines.
MachineProfile.Constants | A class to contain the constants required for the IP_ADAPTER_INFO struct
MachineProfile.GetAdapterInfo | Uses the windows API to retrieve information about the IP configuration of the local machine
StateEntry |
TransientReadOnlyCollection | Implements a transient read only collection. Values can be added, removed and changed until the SetReadOnly method is called thus forcing the collection to a read only state.

Structures

Structure | Description
LicenseSigningKey.KeyRecord |
MachineProfile._MEMORYSTATUS | Summary of _MEMORYSTATUS
MachineProfile._MEMORYSTATUSEX | Summary of _MEMORYSTATUSEX
MachineProfile.IP_ADAPTERINFO_STRUCTURE | declare the IP_ADAPTERINFO_STRUCTURE structure
MachineProfile.IP_ADDR_STRING | declare the IP_ADDR_STRING structure
MachineProfile.TGuid | Summary of TGuid

Enumerations

Enumeration | Description
PeekResult | Possible results from the Peek method.
SerialNumberSizes | Possible key sizes for use when generating serial numbers. More bits makes it more difficult to crack but also increase the size of the serial number.

See Also

Reference

Barcode4NET.Web Assembly


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Class
See Also Members
[image]
Xheo.Licensing Namespace : BigInteger Class

Implements an large integer of arbitrary length.

Syntax

Visual Basic (Declaration)
Private Class BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
C#
private class BigInteger
Managed Extensions for C++
private __gc class BigInteger
C++/CLI
private ref class BigInteger

Inheritance Hierarchy

System.Object
Xheo.Licensing.BigInteger

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
BigInteger Class Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : BigInteger Class

The following tables list the members exposed by BigInteger.

Public Constructors

 | Name | Description
Public Constructor | BigInteger Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | dataLength |
static (Shared in Visual Basic) | primesBelow2000 |
Top

Public Methods

 | Name | Description
Public Method | abs |
Public Method | bitCount |
Public Method | Equals | Overridden.
Public Method | FermatLittleTest |
Public Method | gcd |
static (Shared in Visual Basic) | genPseudoPrime |
Public Method | genRandomBits |
Public Method | getBit |
Public Method | getBytes |
Public Method | GetHashCode | Overridden.
Public Method | IntValue |
Public Method | isProbablePrime | Overloaded.
static (Shared in Visual Basic) | Jacobi |
Public Method | LongValue |
static (Shared in Visual Basic) | LucasSequence |
Public Method | LucasStrongTest |
Public Method | min |
Public Method | modInverse |
Public Method | modPow |
Public Method | RabinMillerTest |
Public Method | setBit |
Public Method | sqrt |
Public Method | ToHexString |
Public Method | ToString | Overloaded. Overridden.
Public Method | ULongValue |
Public Method | unsetBit |
Top

Public Operators

Public Operator Addition |
Public Operator And |
Public Operator Or |
Public Operator Decrement |
Public Operator Division |
Public Operator Equality |
Public Operator Exclusive Or |
Public Operator Greater Than |
Public Operator Greater Than or Equal |
Public Operator Implicit Type Conversion | Overloaded.
Public Operator Increment |
Public Operator Inequality |
Public Operator Left-shift |
Public Operator Less Than |
Public Operator Less Than or Equal |
Public Operator Modulus |
Public Operator Multiplication |
Public Operator Bitwise Complement |
Public Operator Right-shift |
Public Operator Subtraction |
Public Operator Unary Negation |
Top

See Also

Reference

BigInteger Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Constructor
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : BigInteger Constructor

Overload List

Overload | Description
BigInteger Constructor() |
BigInteger Constructor(BigInteger) |
BigInteger Constructor(Byte[]) |
BigInteger Constructor(Byte[],Int32) |
BigInteger Constructor(Int64) |
BigInteger Constructor(String,Int32) |
BigInteger Constructor(UInt32[]) |
BigInteger Constructor(UInt64) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Constructor()
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BigInteger()
C#
public BigInteger()
Managed Extensions for C++
public: BigInteger();
C++/CLI
public:
BigInteger();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Constructor(BigInteger)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(BigInteger)

bi

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bi As BigInteger _
)
Visual Basic (Usage) Copy Code
Dim bi As BigInteger

Dim instance As BigInteger(bi)
C#
public BigInteger(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger(
   BigInteger* bi
)
C++/CLI
public:
BigInteger(
   BigInteger^ bi
)

Parameters

bi

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Constructor(Byte[])
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Byte[])

inData

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As Byte _
)
Visual Basic (Usage) Copy Code
Dim inData() As Byte

Dim instance As BigInteger(inData)
C#
public BigInteger(
   byte[] inData
)
Managed Extensions for C++
public: BigInteger(
   byte[] inData
)
C++/CLI
public:
BigInteger(
   array<byte> inData
)

Parameters

inData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Constructor(Byte[],Int32)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Byte[],Int32)

inData
inLen

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As Byte, _
   ByVal inLen As Integer _
)
Visual Basic (Usage) Copy Code
Dim inData() As Byte
Dim inLen As Integer

Dim instance As BigInteger(inData, inLen)
C#
public BigInteger(
   byte[] inData,
   int inLen
)
Managed Extensions for C++
public: BigInteger(
   byte[] inData,
   int inLen
)
C++/CLI
public:
BigInteger(
   array<byte> inData,
   int inLen
)

Parameters

inData
inLen

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Constructor(Int64)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Int64)

value

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim value As Long

Dim instance As BigInteger(value)
C#
public BigInteger(
   long value
)
Managed Extensions for C++
public: BigInteger(
   long value
)
C++/CLI
public:
BigInteger(
   long value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Constructor(String,Int32)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(String,Int32)

value
radix

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal radix As Integer _
)
Visual Basic (Usage) Copy Code
Dim value As String
Dim radix As Integer

Dim instance As BigInteger(value, radix)
C#
public BigInteger(
   string value,
   int radix
)
Managed Extensions for C++
public: BigInteger(
   string* value,
   int radix
)
C++/CLI
public:
BigInteger(
   String^ value,
   int radix
)

Parameters

value
radix

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Constructor(UInt32[])
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(UInt32[])

inData

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As UInteger _
)
Visual Basic (Usage) Copy Code
Dim inData() As UInteger

Dim instance As BigInteger(inData)
C#
public BigInteger(
   uint[] inData
)
Managed Extensions for C++
public: BigInteger(
   uint[] inData
)
C++/CLI
public:
BigInteger(
   array<uint> inData
)

Parameters

inData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
BigInteger Constructor(UInt64)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(UInt64)

value

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As ULong _
)
Visual Basic (Usage) Copy Code
Dim value As ULong

Dim instance As BigInteger(value)
C#
public BigInteger(
   ulong value
)
Managed Extensions for C++
public: BigInteger(
   ulong value
)
C++/CLI
public:
BigInteger(
   ulong value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
BigInteger Class Methods
See Also
[image]
Xheo.Licensing Namespace : BigInteger Class

For a list of all members of this type, see BigInteger members.

Public Methods

 | Name | Description
Public Method | abs |
Public Method | bitCount |
Public Method | Equals | Overridden.
Public Method | FermatLittleTest |
Public Method | gcd |
static (Shared in Visual Basic) | genPseudoPrime |
Public Method | genRandomBits |
Public Method | getBit |
Public Method | getBytes |
Public Method | GetHashCode | Overridden.
Public Method | IntValue |
Public Method | isProbablePrime | Overloaded.
static (Shared in Visual Basic) | Jacobi |
Public Method | LongValue |
static (Shared in Visual Basic) | LucasSequence |
Public Method | LucasStrongTest |
Public Method | min |
Public Method | modInverse |
Public Method | modPow |
Public Method | RabinMillerTest |
Public Method | setBit |
Public Method | sqrt |
Public Method | ToHexString |
Public Method | ToString | Overloaded. Overridden.
Public Method | ULongValue |
Public Method | unsetBit |
Top

See Also

Reference

BigInteger Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
abs Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : abs Method

Syntax

Visual Basic (Declaration)
Public Function abs() As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As BigInteger

value = instance.abs()
C#
public BigInteger abs()
Managed Extensions for C++
public: BigInteger* abs();
C++/CLI
public:
BigInteger^ abs();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
bitCount Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : bitCount Method

Syntax

Visual Basic (Declaration)
Public Function bitCount() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.bitCount()
C#
public int bitCount()
Managed Extensions for C++
public: int bitCount();
C++/CLI
public:
int bitCount();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Equals Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Equals Method

o

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal o As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim o As Object
Dim value As Boolean

value = instance.Equals(o)
C#
public override bool Equals(
   object o
)
Managed Extensions for C++
public: bool Equals(
   Object* o
) override
C++/CLI
public:
bool Equals(
   Object^ o
) override

Parameters

o

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
FermatLittleTest Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : FermatLittleTest Method

confidence

Syntax

Visual Basic (Declaration)
Public Function FermatLittleTest( _
   ByVal confidence As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim confidence As Integer
Dim value As Boolean

value = instance.FermatLittleTest(confidence)
C#
public bool FermatLittleTest(
   int confidence
)
Managed Extensions for C++
public: bool FermatLittleTest(
   int confidence
)
C++/CLI
public:
bool FermatLittleTest(
   int confidence
)

Parameters

confidence

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
gcd Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : gcd Method

bi

Syntax

Visual Basic (Declaration)
Public Function gcd( _
   ByVal bi As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bi As BigInteger
Dim value As BigInteger

value = instance.gcd(bi)
C#
public BigInteger gcd(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger* gcd(
   BigInteger* bi
)
C++/CLI
public:
BigInteger^ gcd(
   BigInteger^ bi
)

Parameters

bi

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
genPseudoPrime Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : genPseudoPrime Method

bits
confidence
rand

Syntax

Visual Basic (Declaration)
Public Shared Function genPseudoPrime( _
   ByVal bits As Integer, _
   ByVal confidence As Integer, _
   ByVal rand As RandomNumberGenerator _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim bits As Integer
Dim confidence As Integer
Dim rand As RandomNumberGenerator
Dim value As BigInteger

value = BigInteger.genPseudoPrime(bits, confidence, rand)
C#
public static BigInteger genPseudoPrime(
   int bits,
   int confidence,
   RandomNumberGenerator rand
)
Managed Extensions for C++
public: static BigInteger* genPseudoPrime(
   int bits,
   int confidence,
   RandomNumberGenerator* rand
)
C++/CLI
public:
static BigInteger^ genPseudoPrime(
   int bits,
   int confidence,
   RandomNumberGenerator^ rand
)

Parameters

bits
confidence
rand

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
genRandomBits Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : genRandomBits Method

bits
rand

Syntax

Visual Basic (Declaration)
Public Sub genRandomBits( _
   ByVal bits As Integer, _
   ByVal rand As RandomNumberGenerator _
)
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bits As Integer
Dim rand As RandomNumberGenerator

instance.genRandomBits(bits, rand)
C#
public void genRandomBits(
   int bits,
   RandomNumberGenerator rand
)
Managed Extensions for C++
public: void genRandomBits(
   int bits,
   RandomNumberGenerator* rand
)
C++/CLI
public:
void genRandomBits(
   int bits,
   RandomNumberGenerator^ rand
)

Parameters

bits
rand

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
getBit Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : getBit Method

bitNum

Syntax

Visual Basic (Declaration)
Public Function getBit( _
   ByVal bitNum As UInteger _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bitNum As UInteger
Dim value As Boolean

value = instance.getBit(bitNum)
C#
public bool getBit(
   uint bitNum
)
Managed Extensions for C++
public: bool getBit(
   uint bitNum
)
C++/CLI
public:
bool getBit(
   uint bitNum
)

Parameters

bitNum

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
getBytes Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : getBytes Method

Syntax

Visual Basic (Declaration)
Public Function getBytes() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value() As Byte

value = instance.getBytes()
C#
public byte[] getBytes()
Managed Extensions for C++
public: byte[] getBytes();
C++/CLI
public:
array<byte> getBytes();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetHashCode Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : GetHashCode Method

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IntValue Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : IntValue Method

Syntax

Visual Basic (Declaration)
Public Function IntValue() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.IntValue()
C#
public int IntValue()
Managed Extensions for C++
public: int IntValue();
C++/CLI
public:
int IntValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
isProbablePrime Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : isProbablePrime Method

Overload List

Overload | Description
isProbablePrime(Int32) |
isProbablePrime() |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
isProbablePrime(Int32) Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > isProbablePrime Method : isProbablePrime(Int32) Method

confidence

Syntax

Visual Basic (Declaration)
Overloads Public Function isProbablePrime( _
   ByVal confidence As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim confidence As Integer
Dim value As Boolean

value = instance.isProbablePrime(confidence)
C#
public bool isProbablePrime(
   int confidence
)
Managed Extensions for C++
public: bool isProbablePrime(
   int confidence
)
C++/CLI
public:
bool isProbablePrime(
   int confidence
)

Parameters

confidence

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
isProbablePrime() Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > isProbablePrime Method : isProbablePrime() Method

Syntax

Visual Basic (Declaration)
Overloads Public Function isProbablePrime() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Boolean

value = instance.isProbablePrime()
C#
public bool isProbablePrime()
Managed Extensions for C++
public: bool isProbablePrime();
C++/CLI
public:
bool isProbablePrime();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Jacobi Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Jacobi Method

a
b

Syntax

Visual Basic (Declaration)
Public Shared Function Jacobi( _
   ByVal a As BigInteger, _
   ByVal b As BigInteger _
) As Integer
Visual Basic (Usage) Copy Code
Dim a As BigInteger
Dim b As BigInteger
Dim value As Integer

value = BigInteger.Jacobi(a, b)
C#
public static int Jacobi(
   BigInteger a,
   BigInteger b
)
Managed Extensions for C++
public: static int Jacobi(
   BigInteger* a,
   BigInteger* b
)
C++/CLI
public:
static int Jacobi(
   BigInteger^ a,
   BigInteger^ b
)

Parameters

a
b

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LongValue Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : LongValue Method

Syntax

Visual Basic (Declaration)
Public Function LongValue() As Long
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Long

value = instance.LongValue()
C#
public long LongValue()
Managed Extensions for C++
public: long LongValue();
C++/CLI
public:
long LongValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LucasSequence Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : LucasSequence Method

P
Q
k
n

Syntax

Visual Basic (Declaration)
Public Shared Function LucasSequence( _
   ByVal P As BigInteger, _
   ByVal Q As BigInteger, _
   ByVal k As BigInteger, _
   ByVal n As BigInteger _
) As BigInteger()
Visual Basic (Usage) Copy Code
Dim P As BigInteger
Dim Q As BigInteger
Dim k As BigInteger
Dim n As BigInteger
Dim value() As BigInteger

value = BigInteger.LucasSequence(P, Q, k, n)
C#
public static BigInteger[] LucasSequence(
   BigInteger P,
   BigInteger Q,
   BigInteger k,
   BigInteger n
)
Managed Extensions for C++
public: static BigInteger*[] LucasSequence(
   BigInteger* P,
   BigInteger* Q,
   BigInteger* k,
   BigInteger* n
)
C++/CLI
public:
static array<BigInteger^> LucasSequence(
   BigInteger^ P,
   BigInteger^ Q,
   BigInteger^ k,
   BigInteger^ n
)

Parameters

P
Q
k
n

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LucasStrongTest Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : LucasStrongTest Method

Syntax

Visual Basic (Declaration)
Public Function LucasStrongTest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Boolean

value = instance.LucasStrongTest()
C#
public bool LucasStrongTest()
Managed Extensions for C++
public: bool LucasStrongTest();
C++/CLI
public:
bool LucasStrongTest();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
min Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : min Method

bi

Syntax

Visual Basic (Declaration)
Public Function min( _
   ByVal bi As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bi As BigInteger
Dim value As BigInteger

value = instance.min(bi)
C#
public BigInteger min(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger* min(
   BigInteger* bi
)
C++/CLI
public:
BigInteger^ min(
   BigInteger^ bi
)

Parameters

bi

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
modInverse Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : modInverse Method

modulus

Syntax

Visual Basic (Declaration)
Public Function modInverse( _
   ByVal modulus As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim modulus As BigInteger
Dim value As BigInteger

value = instance.modInverse(modulus)
C#
public BigInteger modInverse(
   BigInteger modulus
)
Managed Extensions for C++
public: BigInteger* modInverse(
   BigInteger* modulus
)
C++/CLI
public:
BigInteger^ modInverse(
   BigInteger^ modulus
)

Parameters

modulus

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
modPow Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : modPow Method

exp
n

Syntax

Visual Basic (Declaration)
Public Function modPow( _
   ByVal exp As BigInteger, _
   ByVal n As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim exp As BigInteger
Dim n As BigInteger
Dim value As BigInteger

value = instance.modPow(exp, n)
C#
public BigInteger modPow(
   BigInteger exp,
   BigInteger n
)
Managed Extensions for C++
public: BigInteger* modPow(
   BigInteger* exp,
   BigInteger* n
)
C++/CLI
public:
BigInteger^ modPow(
   BigInteger^ exp,
   BigInteger^ n
)

Parameters

exp
n

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
RabinMillerTest Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : RabinMillerTest Method

confidence

Syntax

Visual Basic (Declaration)
Public Function RabinMillerTest( _
   ByVal confidence As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim confidence As Integer
Dim value As Boolean

value = instance.RabinMillerTest(confidence)
C#
public bool RabinMillerTest(
   int confidence
)
Managed Extensions for C++
public: bool RabinMillerTest(
   int confidence
)
C++/CLI
public:
bool RabinMillerTest(
   int confidence
)

Parameters

confidence

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
setBit Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : setBit Method

bitNum

Syntax

Visual Basic (Declaration)
Public Sub setBit( _
   ByVal bitNum As UInteger _
)
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bitNum As UInteger

instance.setBit(bitNum)
C#
public void setBit(
   uint bitNum
)
Managed Extensions for C++
public: void setBit(
   uint bitNum
)
C++/CLI
public:
void setBit(
   uint bitNum
)

Parameters

bitNum

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
sqrt Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : sqrt Method

Syntax

Visual Basic (Declaration)
Public Function sqrt() As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As BigInteger

value = instance.sqrt()
C#
public BigInteger sqrt()
Managed Extensions for C++
public: BigInteger* sqrt();
C++/CLI
public:
BigInteger^ sqrt();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ToHexString Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : ToHexString Method

Syntax

Visual Basic (Declaration)
Public Function ToHexString() As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As String

value = instance.ToHexString()
C#
public string ToHexString()
Managed Extensions for C++
public: string* ToHexString();
C++/CLI
public:
String^ ToHexString();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ToString Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : ToString Method

Overload List

Overload | Description
ToString() |
ToString(Int32) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ToString() Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > ToString Method : ToString() Method

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ToString(Int32) Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > ToString Method : ToString(Int32) Method

radix

Syntax

Visual Basic (Declaration)
Overloads Public Function ToString( _
   ByVal radix As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim radix As Integer
Dim value As String

value = instance.ToString(radix)
C#
public string ToString(
   int radix
)
Managed Extensions for C++
public: string* ToString(
   int radix
)
C++/CLI
public:
String^ ToString(
   int radix
)

Parameters

radix

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ULongValue Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : ULongValue Method

Syntax

Visual Basic (Declaration)
Public Function ULongValue() As ULong
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As ULong

value = instance.ULongValue()
C#
public ulong ULongValue()
Managed Extensions for C++
public: ulong ULongValue();
C++/CLI
public:
ulong ULongValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
unsetBit Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : unsetBit Method

bitNum

Syntax

Visual Basic (Declaration)
Public Sub unsetBit( _
   ByVal bitNum As UInteger _
)
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bitNum As UInteger

instance.unsetBit(bitNum)
C#
public void unsetBit(
   uint bitNum
)
Managed Extensions for C++
public: void unsetBit(
   uint bitNum
)
C++/CLI
public:
void unsetBit(
   uint bitNum
)

Parameters

bitNum

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.Web Send comments on this topic.
BigInteger Class Fields
See Also
[image]
Xheo.Licensing Namespace : BigInteger Class

For a list of all members of this type, see BigInteger members.

Public Fields

 | Name | Description
Public Field | dataLength |
static (Shared in Visual Basic) | primesBelow2000 |
Top

See Also

Reference

BigInteger Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
dataLength Field
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : dataLength Field

Syntax

Visual Basic (Declaration)
Public dataLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.dataLength

instance.dataLength = value
C#
public int dataLength
Managed Extensions for C++
public: int dataLength
C++/CLI
public:
int dataLength

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
primesBelow2000 Field
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : primesBelow2000 Field

Syntax

Visual Basic (Declaration)
Public Shared primesBelow2000 As Integer()
Visual Basic (Usage) Copy Code
Dim value() As Integer

value = BigInteger.primesBelow2000

BigInteger.primesBelow2000 = value
C#
public static int[] primesBelow2000
Managed Extensions for C++
public: static int[] primesBelow2000
C++/CLI
public:
static array<int> primesBelow2000

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Addition Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Addition Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator +(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Addition(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator +(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
And Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : And Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator And( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator &(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_BitwiseAnd(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator &(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Or Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Or Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator Or( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator |(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_BitwiseOr(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator |(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Decrement Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Decrement Operator

bi1

Syntax

Visual Basic (Declaration)
This operator type is not supported by Visual Basic
C#
public BigInteger operator --(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_Decrement(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator --(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Division Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Division Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator /( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator /(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Division(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator /(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Equality Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Equality Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator ==(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_Equality(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator ==(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Exclusive Or Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Exclusive Or Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator Xor( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator ^(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_ExclusiveOr(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator ^(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Greater Than Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Greater Than Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator >(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_GreaterThan(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator >(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Greater Than or Equal Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Greater Than or Equal Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator >=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_GreaterThanOrEqual(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator >=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Implicit Type Conversion Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Implicit Type Conversion Operator

Overload List

Overload | Description
Implicit Type Conversion(Int32) |
Implicit Type Conversion(Int64) |
Implicit Type Conversion(UInt32) |
Implicit Type Conversion(UInt64) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Increment Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Increment Operator

bi1

Syntax

Visual Basic (Declaration)
This operator type is not supported by Visual Basic
C#
public BigInteger operator ++(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_Increment(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator ++(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Inequality Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Inequality Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator !=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_Inequality(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator !=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Left-shift Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Left-shift Operator

bi1
shiftVal

Syntax

Visual Basic (Declaration)
Public Operator <<( _
   ByVal bi1 As BigInteger, _
   ByVal shiftVal As Integer _
) As BigInteger
C#
public BigInteger operator <<(
   BigInteger bi1,
   int shiftVal
)
Managed Extensions for C++
public: BigInteger* op_LeftShift(
   BigInteger* bi1,
   int shiftVal
)
C++/CLI
public:
BigInteger^ operator <<(
   BigInteger^ bi1,
   int shiftVal
)

Parameters

bi1
shiftVal

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Less Than Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Less Than Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator <(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_LessThan(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator <(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Less Than or Equal Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Less Than or Equal Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator <=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_LessThanOrEqual(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator <=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Modulus Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Modulus Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator Mod( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator %(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Modulus(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator %(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Multiplication Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Multiplication Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator *( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator *(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Multiply(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator *(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Bitwise Complement Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Bitwise Complement Operator

bi1

Syntax

Visual Basic (Declaration)
Public Operator Not( _
   ByVal bi1 As BigInteger _
) As BigInteger
C#
public BigInteger operator ~(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_OnesComplement(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator ~(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Right-shift Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Right-shift Operator

bi1
shiftVal

Syntax

Visual Basic (Declaration)
Public Operator >>( _
   ByVal bi1 As BigInteger, _
   ByVal shiftVal As Integer _
) As BigInteger
C#
public BigInteger operator >>(
   BigInteger bi1,
   int shiftVal
)
Managed Extensions for C++
public: BigInteger* op_RightShift(
   BigInteger* bi1,
   int shiftVal
)
C++/CLI
public:
BigInteger^ operator >>(
   BigInteger^ bi1,
   int shiftVal
)

Parameters

bi1
shiftVal

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Subtraction Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Subtraction Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator -(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Subtraction(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator -(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Unary Negation Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Unary Negation Operator

bi1

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal bi1 As BigInteger _
) As BigInteger
C#
public BigInteger operator -(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_UnaryNegation(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator -(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ContainerLimit Class
See Also Members
[image]
Xheo.Licensing Namespace : ContainerLimit Class

Serves as a base class for limits that contain other limits.

Object Model

Syntax

Visual Basic (Declaration)
Private MustInherit Class ContainerLimit
   Inherits Limit
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
C#
private abstract class ContainerLimit : Limit
Managed Extensions for C++
private __gc abstract class ContainerLimit : public Limit
C++/CLI
private ref class ContainerLimit abstract : public Limit

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Xheo.Licensing.Limit
Xheo.Licensing.ContainerLimit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
ContainerLimit Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : ContainerLimit Class

The following tables list the members exposed by ContainerLimit.

Public Properties

 | Name | Description
Public Property | Description | Gets the description of the limit. (Inherited from Limit)
Public Property | IsGui | Overridden. Gets a value that indicates if the limit may use a GUI interface.
Public Property | IsRemote | Overridden. Gets a value that indicates if the limit may use remote resources.
Public Property | IsTimeSensitive | Overridden. Determines if any contained limits are time sensitive.
Public Property | License | Gets or sets a reference to the ExtendedLicense that contains this Limit. (Inherited from Limit)
Public Property | Limits | Gets the collection of child limits.
Public Property | Name | Gets the display name of the limit. (Inherited from Limit)
Public Property | QualifiedTypeName | Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type. (Inherited from Limit)
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases any managed or unmanged resources. (Inherited from Limit)
Public Method | GetDetailsDescription | Gets a description of the details of the limit. (Inherited from Limit)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Granted | Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created. (Inherited from Limit)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | LoadFromXml | Overridden. Loads the contents of a Limit from an XmlNode.
Public Method | Peek | Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user. (Inherited from Limit)
Public Method | SaveToXml | Overridden. Saves the contents of the Limit as an XmlNode.
Public Method | Validate | Validates that the license being granted is within the limits enforced by this object. (Inherited from Limit)
Top

See Also

Reference

ContainerLimit Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
ContainerLimit Class Methods
See Also
[image]
Xheo.Licensing Namespace : ContainerLimit Class

For a list of all members of this type, see ContainerLimit members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases any managed or unmanged resources. (Inherited from Limit)
Public Method | GetDetailsDescription | Gets a description of the details of the limit. (Inherited from Limit)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Granted | Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created. (Inherited from Limit)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | LoadFromXml | Overridden. Loads the contents of a Limit from an XmlNode.
Public Method | Peek | Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user. (Inherited from Limit)
Public Method | SaveToXml | Overridden. Saves the contents of the Limit as an XmlNode.
Public Method | Validate | Validates that the license being granted is within the limits enforced by this object. (Inherited from Limit)
Top

See Also

Reference

ContainerLimit Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : LoadFromXml Method

node
The XmlNode to load from.
Loads the contents of a Limit from an XmlNode.

Syntax

Visual Basic (Declaration)
Overrides Public Function LoadFromXml( _
   ByVal node As XmlNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim node As XmlNode
Dim value As Boolean

value = instance.LoadFromXml(node)
C#
public override bool LoadFromXml(
   XmlNode node
)
Managed Extensions for C++
public: bool LoadFromXml(
   XmlNode node
) override
C++/CLI
public:
bool LoadFromXml(
   XmlNode node
) override

Parameters

node
The XmlNode to load from.

Return Value

Returns true if the load was successful, otherwise false.
Returns true if the load was successful, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : SaveToXml Method

parent
The parent node to save to.
Saves the contents of the Limit as an XmlNode.

Syntax

Visual Basic (Declaration)
Overrides Public Function SaveToXml( _
   ByVal parent As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim parent As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parent)
C#
public override XmlNode SaveToXml(
   XmlNode parent
)
Managed Extensions for C++
public: XmlNode SaveToXml(
   XmlNode parent
) override
C++/CLI
public:
XmlNode SaveToXml(
   XmlNode parent
) override

Parameters

parent
The parent node to save to.

Return Value

Returns the saved XmlNode.
Returns the saved XmlNode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Web Send comments on this topic.
ContainerLimit Class Properties
See Also
[image]
Xheo.Licensing Namespace : ContainerLimit Class

For a list of all members of this type, see ContainerLimit members.

Public Properties

 | Name | Description
Public Property | Description | Gets the description of the limit. (Inherited from Limit)
Public Property | IsGui | Overridden. Gets a value that indicates if the limit may use a GUI interface.
Public Property | IsRemote | Overridden. Gets a value that indicates if the limit may use remote resources.
Public Property | IsTimeSensitive | Overridden. Determines if any contained limits are time sensitive.
Public Property | License | Gets or sets a reference to the ExtendedLicense that contains this Limit. (Inherited from Limit)
Public Property | Limits | Gets the collection of child limits.
Public Property | Name | Gets the display name of the limit. (Inherited from Limit)
Public Property | QualifiedTypeName | Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type. (Inherited from Limit)
Top

See Also

Reference

ContainerLimit Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IsGui Property
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : IsGui Property

Gets a value that indicates if the limit may use a GUI interface.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property IsGui As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim value As Boolean

value = instance.IsGui
C#
public override bool IsGui {get;}
Managed Extensions for C++
public: __property bool get_IsGui()override ;
C++/CLI
public:
property bool IsGui override {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IsRemote Property
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : IsRemote Property

Gets a value that indicates if the limit may use remote resources.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property IsRemote As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim value As Boolean

value = instance.IsRemote
C#
public override bool IsRemote {get;}
Managed Extensions for C++
public: __property bool get_IsRemote()override ;
C++/CLI
public:
property bool IsRemote override {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IsTimeSensitive Property
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : IsTimeSensitive Property

Determines if any contained limits are time sensitive.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property IsTimeSensitive As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim value As Boolean

value = instance.IsTimeSensitive
C#
public override bool IsTimeSensitive {get;}
Managed Extensions for C++
public: __property bool get_IsTimeSensitive()override ;
C++/CLI
public:
property bool IsTimeSensitive override {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Limits Property
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : Limits Property

Gets the collection of child limits.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Limits As LimitCollection
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim value As LimitCollection

value = instance.Limits
C#
public LimitCollection Limits {get;}
Managed Extensions for C++
public: __property LimitCollection* get_Limits();
C++/CLI
public:
property LimitCollection^ Limits {
   LimitCollection^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ExtendedLicense Class
See Also Members
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

Primary class for the XHEO|Licensing framework.

Object Model

Syntax

Visual Basic (Declaration)
Private NotInheritable Class ExtendedLicense
   Inherits License
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
C#
private sealed class ExtendedLicense : License
Managed Extensions for C++
private __gc __sealed class ExtendedLicense : public License
C++/CLI
private ref class ExtendedLicense sealed : public License

Remarks

Each Type in an assembly can be protected by XHEO|Licensing. The environment that the Type is allowed to run in, is defined by a collection of Limit instances defined for the license. For instance the license may limit a component for use on a computer with a specific IP address. These limits are implemented and enforced by subclasses of the Limit class.

To ensure that the license files have not been altered since they were issued, each ExtendedLicense is signed with a LicenseSigningKey. The signing key uses a public key encryption method (See Cryptography) with the public key embedded in the assembly that the component is implemented in. The private key remains secured with the original developers ensuring that only they can grant valid licenses.

Inheritance Hierarchy

System.Object
System.ComponentModel.License
Xheo.Licensing.ExtendedLicense

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Members
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
ExtendedLicense Class Members
See Also Fields Properties Methods
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

The following tables list the members exposed by ExtendedLicense.

Public Constructors

 | Name | Description
Public Constructor | ExtendedLicense Constructor | Overloaded. Initializes a new instance of the ExtendedLicense class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ConfigSection | The configuration section where XHEO|Licensing settings are stored in the application's configuration file.
static (Shared in Visual Basic) | CurrentVersion | The current license scheme file version.
Top

Public Properties

 | Name | Description
Public Property | AbsoluteOrganization | Gets or sets the name of the organization that the license is issued to.
Public Property | AbsoluteSerialNumber | Gets or sets the serial number for the license.
Public Property | AbsoluteUser | Gets or sets the name of the user that the license is issued to.
Public Property | AcceptedSerialNumberSizes | Gets or sets the serial number sizes that can be used to unlock the license. If a valid serial number of a different size is used, license validation will fail.
Public Property | AssemblyName | Gets or sets the name of the assembly used to sign the license originally. The value of this property is for reference only and has no impact on the validation of a license.
Public Property | Components | Gets the collection of component names that the license applies to.
static (Shared in Visual Basic) | ConnectionString | Gets the default database connection string for licensing components.
static (Shared in Visual Basic) | EmulateVersion | Gets a value that determines the release version that XHEO|Licensing should emulate.
Public Property | Expires | Gets or sets the expiration date for the license.
static (Shared in Visual Basic) | IisIsAvailable | Gets a value that indicates if IIS is installed and available on the machine. If false then HttpContext should not be checked because it will throw an exception.
Public Property | InvalidReason | Gets or sets the reason the license was not valid. If Validate returns true this is an empty string.
Public Property | IsEmbedded | Gets or sets a value that indicates if the license was loaded from an embedded resource rather then an external .LIC file.
Public Property | IsReadOnly | Gets a value that indicates if the current license is read only.
Public Property | IssuerUrl | Gets or sets the URL to the company that issued the license.
static (Shared in Visual Basic) | IsTerminalServices | Gets a value that indicates if the current session is running under terminal services.
Public Property | IsTimeSensitive | Gets a value that indicates if the license contians time sensitive data and the clock should be protected.
static (Shared in Visual Basic) | IsWebRequest | Gets a value indicating if a web request/HttpContext is currently available.
static (Shared in Visual Basic) | KeyFolder | Gets the folder where the license keys are located as defined in the application's config file.
Public Property | LicensedType | Gets the Type the license was/will be granted to.
static (Shared in Visual Basic) | LicenseFolders | Gets a collection of folders where the licenses are located as defined in the application's config file.
Public Property | LicenseKey | Overridden. Overrides LicenseKey.
Public Property | LicensePack | Gets the ExtendedLicensePack that owns the license.
Public Property | MaximumSerialNumberSeed | Gets or sets the maximum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.
Public Property | MetaValues | Gets a collection of arbitrary values to store with the license. These values are not protected and may be changed without affecting the validity of the license. Use for storing volitle information and other unsecured information.
Public Property | MinimumSerialNumberSeed | Gets or sets the minimum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.
Public Property | Organization | Gets or sets the name of the organization that the license is issued to.
Public Property | PersistantState | Gets a reference to per-license specific state that works independent of any underlying state schemes. This is used to safely track values that should be kept in memory even when a license is reloaded from disk.
Public Property | PublicKey | Gets a reference to the LicenseSigningKey being used to validate the license.
Public Property | SerialNumber | Gets or sets the value of the absolute serial number.
static (Shared in Visual Basic) | SharedFolder | Gets or sets the path to the shared license folder.
Public Property | Signature | Gets or sets the signature used to validate the license data.
Public Property | SurrogateLicensePack | Gets or sets a surrogate license pack to use if validation of this license fails.
Public Property | Tag | Gets or sets an arbitrary piece of data to track with the license. This is a "cheap" way of extending the license scheme by allowing you to store any kind of additional data that can be saved as a string to the license.
static (Shared in Visual Basic) | TemplateFolder | Gets the folder where the license templates are located as defined in the application's config file.
Public Property | Type | Gets or sets an application/product specific description of the type of license. For examples "designer", "single user", "non-profit", etc. This can often be used a reference to the primary key in a database, such as a SKU, for the product that the license represents.
Public Property | UnlockBySerial | Gets or sets a value that indicates if the user must provide a valid serial number to fully unlock the license.
Public Property | UnlockedLicense | Gets or sets the ExtendedLicense that was unlocked by the registration process.
Public Property | User | Gets or sets the value of the user as it should appear on screen.
Public Property | Values | Gets a collection of arbitrary values to store with the license.
Public Property | Version | Gets or sets the version of the licensing scheme used.
Public Property | XmlString | Gets or sets the contents of the license as an XML string fragment.
Top

Public Methods

 | Name | Description
Public Method | ComponentsFromString | Fills the components collection from a comma separated list.
Public Method | ComponentsToString | Gets the components collection as a comma separated list.
Public Method | Dispose | Releases any managed or unmanaged resources.
static (Shared in Visual Basic) | FromXml | Overloaded. Creates a new ExtendedLicense from an XML fragment.
Public Method | FromXmlString | Loads the contents of the license from an XML string.
static (Shared in Visual Basic) | GetFullPath | Utility function that gets the full path of a folder relative to the "application root" of the current application.
Public Method | GetShortAssemblyName | Gets the short name of the assembly. If the AssemblyName property contains version and key information, only the assembly name is returned.
Public Method | GetSigningKey | Overloaded. Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.
Public Method | GetValue | Gets the first value from the Values collection with the given key and if not found returns the default value instead.
Public Method | LoadFromXml | Loads the contents of a license from an XmlNode.
Public Method | SaveToXml | Saves the contents of the ExtendedLicense to the given XmlNode.
Public Method | ToXmlString | Saves the contents of the license to an XML string.
Top

See Also

Reference

ExtendedLicense Class
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ExtendedLicense Constructor
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ExtendedLicense Constructor

Initializes a new instance of the ExtendedLicense class.

Overload List

Overload | Description
ExtendedLicense Constructor() | Initializes a new instance of the ExtendedLicense class.
ExtendedLicense Constructor(XmlNode) | Initializes a new instance of the ExtendedLicense class with the values of the given XmlNode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ExtendedLicense Constructor()
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > ExtendedLicense Constructor : ExtendedLicense Constructor()

Initializes a new instance of the ExtendedLicense class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense()
C#
public ExtendedLicense()
Managed Extensions for C++
public: ExtendedLicense();
C++/CLI
public:
ExtendedLicense();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ExtendedLicense Constructor(XmlNode)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > ExtendedLicense Constructor : ExtendedLicense Constructor(XmlNode)

node
The XmlNode of the ExtendedLicensePack to load the license properties from.
Initializes a new instance of the ExtendedLicense class with the values of the given XmlNode.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal node As XmlNode _
)
Visual Basic (Usage) Copy Code
Dim node As XmlNode

Dim instance As ExtendedLicense(node)
C#
public ExtendedLicense(
   XmlNode node
)
Managed Extensions for C++
public: ExtendedLicense(
   XmlNode node
)
C++/CLI
public:
ExtendedLicense(
   XmlNode node
)

Parameters

node
The XmlNode of the ExtendedLicensePack to load the license properties from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
ExtendedLicense Class Methods
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

For a list of all members of this type, see ExtendedLicense members.

Public Methods

 | Name | Description
Public Method | ComponentsFromString | Fills the components collection from a comma separated list.
Public Method | ComponentsToString | Gets the components collection as a comma separated list.
Public Method | Dispose | Releases any managed or unmanaged resources.
static (Shared in Visual Basic) | FromXml | Overloaded. Creates a new ExtendedLicense from an XML fragment.
Public Method | FromXmlString | Loads the contents of the license from an XML string.
static (Shared in Visual Basic) | GetFullPath | Utility function that gets the full path of a folder relative to the "application root" of the current application.
Public Method | GetShortAssemblyName | Gets the short name of the assembly. If the AssemblyName property contains version and key information, only the assembly name is returned.
Public Method | GetSigningKey | Overloaded. Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.
Public Method | GetValue | Gets the first value from the Values collection with the given key and if not found returns the default value instead.
Public Method | LoadFromXml | Loads the contents of a license from an XmlNode.
Public Method | SaveToXml | Saves the contents of the ExtendedLicense to the given XmlNode.
Public Method | ToXmlString | Saves the contents of the license to an XML string.
Top

See Also

Reference

ExtendedLicense Class
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ComponentsFromString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ComponentsFromString Method

components
Comma separated list of components.
Fills the components collection from a comma separated list.

Syntax

Visual Basic (Declaration)
Public Sub ComponentsFromString( _
   ByVal components As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim components As String

instance.ComponentsFromString(components)
C#
public void ComponentsFromString(
   string components
)
Managed Extensions for C++
public: void ComponentsFromString(
   string* components
)
C++/CLI
public:
void ComponentsFromString(
   String^ components
)

Parameters

components
Comma separated list of components.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ComponentsToString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ComponentsToString Method

Gets the components collection as a comma separated list.

Syntax

Visual Basic (Declaration)
Public Function ComponentsToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

value = instance.ComponentsToString()
C#
public string ComponentsToString()
Managed Extensions for C++
public: string* ComponentsToString();
C++/CLI
public:
String^ ComponentsToString();

Return Value

Returns the list of components.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Dispose Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Dispose Method

Releases any managed or unmanaged resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
FromXml Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : FromXml Method

Creates a new ExtendedLicense from an XML fragment.

Overload List

Overload | Description
FromXml(String) | Creates a new ExtendedLicense from an XML fragment.
FromXml(XmlNode) | Creates a new ExtendedLicense from an XML fragment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
FromXml(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > FromXml Method : FromXml(String) Method

xml
The xml to create the license from.
Creates a new ExtendedLicense from an XML fragment.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromXml( _
   ByVal xml As String _
) As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim xml As String
Dim value As ExtendedLicense

value = ExtendedLicense.FromXml(xml)
C#
public static ExtendedLicense FromXml(
   string xml
)
Managed Extensions for C++
public: static ExtendedLicense* FromXml(
   string* xml
)
C++/CLI
public:
static ExtendedLicense^ FromXml(
   String^ xml
)

Parameters

xml
The xml to create the license from.

Return Value

Returns the newly created extended license.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
FromXml(XmlNode) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > FromXml Method : FromXml(XmlNode) Method

xml
The xml to create the license from.
Creates a new ExtendedLicense from an XML fragment.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromXml( _
   ByVal xml As XmlNode _
) As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim xml As XmlNode
Dim value As ExtendedLicense

value = ExtendedLicense.FromXml(xml)
C#
public static ExtendedLicense FromXml(
   XmlNode xml
)
Managed Extensions for C++
public: static ExtendedLicense* FromXml(
   XmlNode xml
)
C++/CLI
public:
static ExtendedLicense^ FromXml(
   XmlNode xml
)

Parameters

xml
The xml to create the license from.

Return Value

Returns the newly created extended license.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : FromXmlString Method

xml
The XML string to load from.
Loads the contents of the license from an XML string.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
The XML string to load from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetFullPath Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : GetFullPath Method

path
The path to resolve to a complete path.
Utility function that gets the full path of a folder relative to the "application root" of the current application.

Syntax

Visual Basic (Declaration)
Public Shared Function GetFullPath( _
   ByVal path As String _
) As String
Visual Basic (Usage) Copy Code
Dim path As String
Dim value As String

value = ExtendedLicense.GetFullPath(path)
C#
public static string GetFullPath(
   string path
)
Managed Extensions for C++
public: static string* GetFullPath(
   string* path
)
C++/CLI
public:
static String^ GetFullPath(
   String^ path
)

Parameters

path
The path to resolve to a complete path.

Remarks

For console and forms applications the base folder is the folder of the entry executable. For Web sites the base folder is the root of the site...rather than the \bin folder.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetShortAssemblyName Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : GetShortAssemblyName Method

Gets the short name of the assembly. If the AssemblyName property contains version and key information, only the assembly name is returned.

Syntax

Visual Basic (Declaration)
Public Function GetShortAssemblyName() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

value = instance.GetShortAssemblyName()
C#
public string GetShortAssemblyName()
Managed Extensions for C++
public: string* GetShortAssemblyName();
C++/CLI
public:
String^ GetShortAssemblyName();

Return Value

Returns the short version of the AssemblyName if set, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetSigningKey Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : GetSigningKey Method

Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.

Overload List

Overload | Description
GetSigningKey(String) | Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.
GetSigningKey() | Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetSigningKey(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > GetSigningKey Method : GetSigningKey(String) Method

folder
The folder to look for keys. If null KeyFolder is used.
Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetSigningKey( _
   ByVal folder As String _
) As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim folder As String
Dim value As LicenseSigningKey

value = instance.GetSigningKey(folder)
C#
public LicenseSigningKey GetSigningKey(
   string folder
)
Managed Extensions for C++
public: LicenseSigningKey* GetSigningKey(
   string* folder
)
C++/CLI
public:
LicenseSigningKey^ GetSigningKey(
   String^ folder
)

Parameters

folder
The folder to look for keys. If null KeyFolder is used.

Return Value

Returns the key needed to sign the license if found, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetSigningKey() Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > GetSigningKey Method : GetSigningKey() Method

Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetSigningKey() As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As LicenseSigningKey

value = instance.GetSigningKey()
C#
public LicenseSigningKey GetSigningKey()
Managed Extensions for C++
public: LicenseSigningKey* GetSigningKey();
C++/CLI
public:
LicenseSigningKey^ GetSigningKey();

Return Value

Returns the key needed to sign the license if found, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetValue Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : GetValue Method

key
The key of the value to return.
defaultValue
The default value if not found.
Gets the first value from the Values collection with the given key and if not found returns the default value instead.

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal key As String, _
   ByVal defaultValue As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim key As String
Dim defaultValue As String
Dim value As String

value = instance.GetValue(key, defaultValue)
C#
public string GetValue(
   string key,
   string defaultValue
)
Managed Extensions for C++
public: string* GetValue(
   string* key,
   string* defaultValue
)
C++/CLI
public:
String^ GetValue(
   String^ key,
   String^ defaultValue
)

Parameters

key
The key of the value to return.
defaultValue
The default value if not found.

Return Value

Returns the first value with the given key if found, otherwise the default value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LoadFromXml Method

node
An XmlNode containing the license data.
Loads the contents of a license from an XmlNode.

Syntax

Visual Basic (Declaration)
Public Function LoadFromXml( _
   ByVal node As XmlNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim node As XmlNode
Dim value As Boolean

value = instance.LoadFromXml(node)
C#
public bool LoadFromXml(
   XmlNode node
)
Managed Extensions for C++
public: bool LoadFromXml(
   XmlNode node
)
C++/CLI
public:
bool LoadFromXml(
   XmlNode node
)

Parameters

node
An XmlNode containing the license data.

Return Value

Returns true if the load was successful, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : SaveToXml Method

parent
The parent XmlNode.
Saves the contents of the ExtendedLicense to the given XmlNode.

Syntax

Visual Basic (Declaration)
Public Function SaveToXml( _
   ByVal parent As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim parent As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parent)
C#
public XmlNode SaveToXml(
   XmlNode parent
)
Managed Extensions for C++
public: XmlNode SaveToXml(
   XmlNode parent
)
C++/CLI
public:
XmlNode SaveToXml(
   XmlNode parent
)

Parameters

parent
The parent XmlNode.

Return Value

Returns the root node of the saved license.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ToXmlString Method

Saves the contents of the license to an XML string.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

value = instance.ToXmlString()
C#
public string ToXmlString()
Managed Extensions for C++
public: string* ToXmlString();
C++/CLI
public:
String^ ToXmlString();

Return Value

The saved XML.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Web Send comments on this topic.
ExtendedLicense Class Properties
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

For a list of all members of this type, see ExtendedLicense members.

Public Properties

 | Name | Description
Public Property | AbsoluteOrganization | Gets or sets the name of the organization that the license is issued to.
Public Property | AbsoluteSerialNumber | Gets or sets the serial number for the license.
Public Property | AbsoluteUser | Gets or sets the name of the user that the license is issued to.
Public Property | AcceptedSerialNumberSizes | Gets or sets the serial number sizes that can be used to unlock the license. If a valid serial number of a different size is used, license validation will fail.
Public Property | AssemblyName | Gets or sets the name of the assembly used to sign the license originally. The value of this property is for reference only and has no impact on the validation of a license.
Public Property | Components | Gets the collection of component names that the license applies to.
static (Shared in Visual Basic) | ConnectionString | Gets the default database connection string for licensing components.
static (Shared in Visual Basic) | EmulateVersion | Gets a value that determines the release version that XHEO|Licensing should emulate.
Public Property | Expires | Gets or sets the expiration date for the license.
static (Shared in Visual Basic) | IisIsAvailable | Gets a value that indicates if IIS is installed and available on the machine. If false then HttpContext should not be checked because it will throw an exception.
Public Property | InvalidReason | Gets or sets the reason the license was not valid. If Validate returns true this is an empty string.
Public Property | IsEmbedded | Gets or sets a value that indicates if the license was loaded from an embedded resource rather then an external .LIC file.
Public Property | IsReadOnly | Gets a value that indicates if the current license is read only.
Public Property | IssuerUrl | Gets or sets the URL to the company that issued the license.
static (Shared in Visual Basic) | IsTerminalServices | Gets a value that indicates if the current session is running under terminal services.
Public Property | IsTimeSensitive | Gets a value that indicates if the license contians time sensitive data and the clock should be protected.
static (Shared in Visual Basic) | IsWebRequest | Gets a value indicating if a web request/HttpContext is currently available.
static (Shared in Visual Basic) | KeyFolder | Gets the folder where the license keys are located as defined in the application's config file.
Public Property | LicensedType | Gets the Type the license was/will be granted to.
static (Shared in Visual Basic) | LicenseFolders | Gets a collection of folders where the licenses are located as defined in the application's config file.
Public Property | LicenseKey | Overridden. Overrides LicenseKey.
Public Property | LicensePack | Gets the ExtendedLicensePack that owns the license.
Public Property | MaximumSerialNumberSeed | Gets or sets the maximum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.
Public Property | MetaValues | Gets a collection of arbitrary values to store with the license. These values are not protected and may be changed without affecting the validity of the license. Use for storing volitle information and other unsecured information.
Public Property | MinimumSerialNumberSeed | Gets or sets the minimum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.
Public Property | Organization | Gets or sets the name of the organization that the license is issued to.
Public Property | PersistantState | Gets a reference to per-license specific state that works independent of any underlying state schemes. This is used to safely track values that should be kept in memory even when a license is reloaded from disk.
Public Property | PublicKey | Gets a reference to the LicenseSigningKey being used to validate the license.
Public Property | SerialNumber | Gets or sets the value of the absolute serial number.
static (Shared in Visual Basic) | SharedFolder | Gets or sets the path to the shared license folder.
Public Property | Signature | Gets or sets the signature used to validate the license data.
Public Property | SurrogateLicensePack | Gets or sets a surrogate license pack to use if validation of this license fails.
Public Property | Tag | Gets or sets an arbitrary piece of data to track with the license. This is a "cheap" way of extending the license scheme by allowing you to store any kind of additional data that can be saved as a string to the license.
static (Shared in Visual Basic) | TemplateFolder | Gets the folder where the license templates are located as defined in the application's config file.
Public Property | Type | Gets or sets an application/product specific description of the type of license. For examples "designer", "single user", "non-profit", etc. This can often be used a reference to the primary key in a database, such as a SKU, for the product that the license represents.
Public Property | UnlockBySerial | Gets or sets a value that indicates if the user must provide a valid serial number to fully unlock the license.
Public Property | UnlockedLicense | Gets or sets the ExtendedLicense that was unlocked by the registration process.
Public Property | User | Gets or sets the value of the user as it should appear on screen.
Public Property | Values | Gets a collection of arbitrary values to store with the license.
Public Property | Version | Gets or sets the version of the licensing scheme used.
Public Property | XmlString | Gets or sets the contents of the license as an XML string fragment.
Top

See Also

Reference

ExtendedLicense Class
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
AbsoluteOrganization Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AbsoluteOrganization Property

Gets or sets the name of the organization that the license is issued to.

Syntax

Visual Basic (Declaration)
Public Property AbsoluteOrganization As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.AbsoluteOrganization = value

value = instance.AbsoluteOrganization
C#
public string AbsoluteOrganization {get; set;}
Managed Extensions for C++
public: __property string* get_AbsoluteOrganization();
public: __property void set_AbsoluteOrganization(
   string* value
);
C++/CLI
public:
property String^ AbsoluteOrganization {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
AbsoluteSerialNumber Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AbsoluteSerialNumber Property

Gets or sets the serial number for the license.

Syntax

Visual Basic (Declaration)
Public Property AbsoluteSerialNumber As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.AbsoluteSerialNumber = value

value = instance.AbsoluteSerialNumber
C#
public string AbsoluteSerialNumber {get; set;}
Managed Extensions for C++
public: __property string* get_AbsoluteSerialNumber();
public: __property void set_AbsoluteSerialNumber(
   string* value
);
C++/CLI
public:
property String^ AbsoluteSerialNumber {
   String^ get();
   void set (String^ value);
}

Remarks

Generally the value of the serial number property is completely arbitrary and can contain any value. However the values should be treated as a primary key that uniquely identifies the license. Generally this is used to reference licenses in a back-end system and to uniquely identify the license.

By default a random GUID is generated for the serial number. You can later change it to any desired value.

(Version 1.2+) When using Unlock by Serial to unlock licenses, the Absolute Serial Number is used to match user's serial numbers to licenses.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
AbsoluteUser Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AbsoluteUser Property

Gets or sets the name of the user that the license is issued to.

Syntax

Visual Basic (Declaration)
Public Property AbsoluteUser As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.AbsoluteUser = value

value = instance.AbsoluteUser
C#
public string AbsoluteUser {get; set;}
Managed Extensions for C++
public: __property string* get_AbsoluteUser();
public: __property void set_AbsoluteUser(
   string* value
);
C++/CLI
public:
property String^ AbsoluteUser {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
AcceptedSerialNumberSizes Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AcceptedSerialNumberSizes Property

Gets or sets the serial number sizes that can be used to unlock the license. If a valid serial number of a different size is used, license validation will fail.

Syntax

Visual Basic (Declaration)
Public Property AcceptedSerialNumberSizes As SerialNumberSizes
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As SerialNumberSizes

instance.AcceptedSerialNumberSizes = value

value = instance.AcceptedSerialNumberSizes
C#
public SerialNumberSizes AcceptedSerialNumberSizes {get; set;}
Managed Extensions for C++
public: __property SerialNumberSizes get_AcceptedSerialNumberSizes();
public: __property void set_AcceptedSerialNumberSizes(
   SerialNumberSizes value
);
C++/CLI
public:
property SerialNumberSizes AcceptedSerialNumberSizes {
   SerialNumberSizes get();
   void set (SerialNumberSizes value);
}

Remarks

It is recommended that you only allow the largest size you will reasonably expect to issue to your customers. A malicious user needs only to crack the smallest acceptable size to gain access to the license. The Recommended sizes are Medium (for regular serial numbers) and Huge (for activation keys).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
AssemblyName Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AssemblyName Property

Gets or sets the name of the assembly used to sign the license originally. The value of this property is for reference only and has no impact on the validation of a license.

Syntax

Visual Basic (Declaration)
Public Property AssemblyName As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.AssemblyName = value

value = instance.AssemblyName
C#
public string AssemblyName {get; set;}
Managed Extensions for C++
public: __property string* get_AssemblyName();
public: __property void set_AssemblyName(
   string* value
);
C++/CLI
public:
property String^ AssemblyName {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Components Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Components Property

Gets the collection of component names that the license applies to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As StringCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As StringCollection

value = instance.Components
C#
public StringCollection Components {get;}
Managed Extensions for C++
public: __property StringCollection get_Components();
C++/CLI
public:
property StringCollection Components {
   StringCollection get();
}

Remarks

Each component name in the collection should be the FullName of the Type including the namespace. When the license is read only then a copy of the collection is returned and any changes to the collection are lost.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ConnectionString Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ConnectionString Property

Gets the default database connection string for licensing components.

Syntax

Visual Basic (Declaration)
Public Shared Property ConnectionString As String
Visual Basic (Usage) Copy Code
Dim value As String

ExtendedLicense.ConnectionString = value

value = ExtendedLicense.ConnectionString
C#
public static string ConnectionString {get; set;}
Managed Extensions for C++
public: __property static string* get_ConnectionString();
public: __property static void set_ConnectionString(
   string* value
);
C++/CLI
public:
static property String^ ConnectionString {
   String^ get();
   void set (String^ value);
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.ConnectionString" value="server=localhost;catalog=Northwind" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="ConnectionString" value="server=localhost;catalog=Northwind" />
    </Licensing>
</Xheo>
</configuration>

Remarks

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.ConnectionString and set it to the path where keys are stored on your machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
EmulateVersion Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : EmulateVersion Property

Gets a value that determines the release version that XHEO|Licensing should emulate.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property EmulateVersion As Version
Visual Basic (Usage) Copy Code
Dim value As Version

value = ExtendedLicense.EmulateVersion
C#
public static Version EmulateVersion {get;}
Managed Extensions for C++
public: __property static Version* get_EmulateVersion();
C++/CLI
public:
static property Version^ EmulateVersion {
   Version^ get();
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.EmulateVersion" value="1.1" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="EmulateVersion" value="1.1" />
    </Licensing>
</Xheo>
</configuration>

Remarks

Use this value when migrating a solution from an earlier version to a newer one so that licenses generated with the new assembly will use the previous version until you have fully upgraded all dependent assemblies.

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.EmulateVersion and set it to either true or false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Expires Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Expires Property

Gets or sets the expiration date for the license.

Syntax

Visual Basic (Declaration)
Public Property Expires As Date
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Date

instance.Expires = value

value = instance.Expires
C#
public DateTime Expires {get; set;}
Managed Extensions for C++
public: __property DateTime get_Expires();
public: __property void set_Expires(
   DateTime value
);
C++/CLI
public:
property DateTime Expires {
   DateTime get();
   void set (DateTime value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IisIsAvailable Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IisIsAvailable Property

Gets a value that indicates if IIS is installed and available on the machine. If false then HttpContext should not be checked because it will throw an exception.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IisIsAvailable As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = ExtendedLicense.IisIsAvailable
C#
public static bool IisIsAvailable {get;}
Managed Extensions for C++
public: __property static bool get_IisIsAvailable();
C++/CLI
public:
static property bool IisIsAvailable {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
InvalidReason Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : InvalidReason Property

Gets or sets the reason the license was not valid. If Validate returns true this is an empty string.

Syntax

Visual Basic (Declaration)
Public Property InvalidReason As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.InvalidReason = value

value = instance.InvalidReason
C#
public string InvalidReason {get; set;}
Managed Extensions for C++
public: __property string* get_InvalidReason();
public: __property void set_InvalidReason(
   string* value
);
C++/CLI
public:
property String^ InvalidReason {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IsEmbedded Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsEmbedded Property

Gets or sets a value that indicates if the license was loaded from an embedded resource rather then an external .LIC file.

Syntax

Visual Basic (Declaration)
Public Property IsEmbedded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Boolean

instance.IsEmbedded = value

value = instance.IsEmbedded
C#
public bool IsEmbedded {get; set;}
Managed Extensions for C++
public: __property bool get_IsEmbedded();
public: __property void set_IsEmbedded(
   bool value
);
C++/CLI
public:
property bool IsEmbedded {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IsReadOnly Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsReadOnly Property

Gets a value that indicates if the current license is read only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IssuerUrl Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IssuerUrl Property

Gets or sets the URL to the company that issued the license.

Syntax

Visual Basic (Declaration)
Public Property IssuerUrl As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.IssuerUrl = value

value = instance.IssuerUrl
C#
public string IssuerUrl {get; set;}
Managed Extensions for C++
public: __property string* get_IssuerUrl();
public: __property void set_IssuerUrl(
   string* value
);
C++/CLI
public:
property String^ IssuerUrl {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IsTerminalServices Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsTerminalServices Property

Gets a value that indicates if the current session is running under terminal services.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IsTerminalServices As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = ExtendedLicense.IsTerminalServices
C#
public static bool IsTerminalServices {get;}
Managed Extensions for C++
public: __property static bool get_IsTerminalServices();
C++/CLI
public:
static property bool IsTerminalServices {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IsTimeSensitive Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsTimeSensitive Property

Gets a value that indicates if the license contians time sensitive data and the clock should be protected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsTimeSensitive As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Boolean

value = instance.IsTimeSensitive
C#
public bool IsTimeSensitive {get;}
Managed Extensions for C++
public: __property bool get_IsTimeSensitive();
C++/CLI
public:
property bool IsTimeSensitive {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IsWebRequest Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsWebRequest Property

Gets a value indicating if a web request/HttpContext is currently available.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IsWebRequest As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = ExtendedLicense.IsWebRequest
C#
public static bool IsWebRequest {get;}
Managed Extensions for C++
public: __property static bool get_IsWebRequest();
C++/CLI
public:
static property bool IsWebRequest {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
KeyFolder Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : KeyFolder Property

Gets the folder where the license keys are located as defined in the application's config file.

Syntax

Visual Basic (Declaration)
Public Shared Property KeyFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

ExtendedLicense.KeyFolder = value

value = ExtendedLicense.KeyFolder
C#
public static string KeyFolder {get; set;}
Managed Extensions for C++
public: __property static string* get_KeyFolder();
public: __property static void set_KeyFolder(
   string* value
);
C++/CLI
public:
static property String^ KeyFolder {
   String^ get();
   void set (String^ value);
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.KeyFolder" value="X:\Keys" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="KeyFolder" value="D:\aaa" />
    </Licensing>
</Xheo>
</configuration>

Remarks

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.KeyFolder and set it to the path where keys are stored on your machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LicensedType Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LicensedType Property

Gets the Type the license was/will be granted to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LicensedType As Type
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Type

value = instance.LicensedType
C#
public Type LicensedType {get;}
Managed Extensions for C++
public: __property Type* get_LicensedType();
C++/CLI
public:
property Type^ LicensedType {
   Type^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LicenseFolders Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LicenseFolders Property

Gets a collection of folders where the licenses are located as defined in the application's config file.

Syntax

Visual Basic (Declaration)
Public Shared Property LicenseFolders As String()
Visual Basic (Usage) Copy Code
Dim value() As String

ExtendedLicense.LicenseFolders = value

value = ExtendedLicense.LicenseFolders
C#
public static string[] LicenseFolders {get; set;}
Managed Extensions for C++
public: __property static string*[] get_LicenseFolders();
public: __property static void set_LicenseFolders(
   string*[] value
);
C++/CLI
public:
static property array<String^> LicenseFolders {
   array<String^> get();
   void set (String^array<value> value);
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.LicenseFolder" value="X:\Folder1" />
    <add key="Xheo.Licensing.LicenseFolder" value="X:\Folder2" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="Xheo.Licensing.Configuration.NameValueSectionHandler, System, Version=1.1.0.0, Culture=neutral, PublicKeyToken=798276055709c98a" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="LicenseFolder" value="D:\aaa" />
        <add key="LicenseFolder" value="C:\other" />
    </Licensing>
</Xheo>
</configuration>

Remarks

Use this setting when you install XHEO|Licensing or licensed components into the GAC, or when using a shared install in a hosting environment.

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.LicenseFolders and set it to the path where keys are stored on your machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LicenseKey Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LicenseKey Property

Overrides LicenseKey.

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable ReadOnly Property LicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

value = instance.LicenseKey
C#
public override string LicenseKey {get;}
Managed Extensions for C++
public: __property string* get_LicenseKey()override ;
C++/CLI
public:
property String^ LicenseKey override {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LicensePack Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LicensePack Property

Gets the ExtendedLicensePack that owns the license.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LicensePack As ExtendedLicensePack
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As ExtendedLicensePack

value = instance.LicensePack
C#
public ExtendedLicensePack LicensePack {get;}
Managed Extensions for C++
public: __property ExtendedLicensePack* get_LicensePack();
C++/CLI
public:
property ExtendedLicensePack^ LicensePack {
   ExtendedLicensePack^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MaximumSerialNumberSeed Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : MaximumSerialNumberSeed Property

Gets or sets the maximum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.

Syntax

Visual Basic (Declaration)
Public Property MaximumSerialNumberSeed As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Integer

instance.MaximumSerialNumberSeed = value

value = instance.MaximumSerialNumberSeed
C#
public int MaximumSerialNumberSeed {get; set;}
Managed Extensions for C++
public: __property int get_MaximumSerialNumberSeed();
public: __property void set_MaximumSerialNumberSeed(
   int value
);
C++/CLI
public:
property int MaximumSerialNumberSeed {
   int get();
   void set (int value);
}

Remarks

Use MinimumSerialNumberSeed and MaximumSerialNumberSeed to partition serial numbers to various resellers or vendors. You can then use this to determine which vendor sold your product in case of support requests.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MetaValues Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : MetaValues Property

Gets a collection of arbitrary values to store with the license. These values are not protected and may be changed without affecting the validity of the license. Use for storing volitle information and other unsecured information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetaValues As LicenseValuesCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As LicenseValuesCollection

value = instance.MetaValues
C#
public LicenseValuesCollection MetaValues {get;}
Managed Extensions for C++
public: __property LicenseValuesCollection* get_MetaValues();
C++/CLI
public:
property LicenseValuesCollection^ MetaValues {
   LicenseValuesCollection^ get();
}

Remarks

The MetaValues collection will be persisted with a license. However any changes to the meta values collection after the license is signed will not affect the validity of the signature. Use this to track volitle information that need not be secured and is safe for the user to change.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MinimumSerialNumberSeed Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : MinimumSerialNumberSeed Property

Gets or sets the minimum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.

Syntax

Visual Basic (Declaration)
Public Property MinimumSerialNumberSeed As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Integer

instance.MinimumSerialNumberSeed = value

value = instance.MinimumSerialNumberSeed
C#
public int MinimumSerialNumberSeed {get; set;}
Managed Extensions for C++
public: __property int get_MinimumSerialNumberSeed();
public: __property void set_MinimumSerialNumberSeed(
   int value
);
C++/CLI
public:
property int MinimumSerialNumberSeed {
   int get();
   void set (int value);
}

Remarks

Use MinimumSerialNumberSeed and MaximumSerialNumberSeed to partition serial numbers to various resellers or vendors. You can then use this to determine which vendor sold your product in case of support requests.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Organization Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Organization Property

Gets or sets the name of the organization that the license is issued to.

Syntax

Visual Basic (Declaration)
Public Property Organization As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.Organization = value

value = instance.Organization
C#
public string Organization {get; set;}
Managed Extensions for C++
public: __property string* get_Organization();
public: __property void set_Organization(
   string* value
);
C++/CLI
public:
property String^ Organization {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
PersistantState Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : PersistantState Property

Gets a reference to per-license specific state that works independent of any underlying state schemes. This is used to safely track values that should be kept in memory even when a license is reloaded from disk.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PersistantState As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Hashtable

value = instance.PersistantState
C#
public Hashtable PersistantState {get;}
Managed Extensions for C++
public: __property Hashtable* get_PersistantState();
C++/CLI
public:
property Hashtable^ PersistantState {
   Hashtable^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
PublicKey Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : PublicKey Property

Gets a reference to the LicenseSigningKey being used to validate the license.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PublicKey As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As LicenseSigningKey

value = instance.PublicKey
C#
public LicenseSigningKey PublicKey {get;}
Managed Extensions for C++
public: __property LicenseSigningKey* get_PublicKey();
C++/CLI
public:
property LicenseSigningKey^ PublicKey {
   LicenseSigningKey^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SerialNumber Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : SerialNumber Property

Gets or sets the value of the absolute serial number.

Syntax

Visual Basic (Declaration)
Public Property SerialNumber As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.SerialNumber = value

value = instance.SerialNumber
C#
public string SerialNumber {get; set;}
Managed Extensions for C++
public: __property string* get_SerialNumber();
public: __property void set_SerialNumber(
   string* value
);
C++/CLI
public:
property String^ SerialNumber {
   String^ get();
   void set (String^ value);
}

Remarks

The absolute serial number is used in unlocking a license by serial number. The absolute serial number must begin with the SerialNumber for the license.
Warning This value is unprotected and can be changed by the client. Do not assume the value is valid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SharedFolder Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : SharedFolder Property

Gets or sets the path to the shared license folder.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SharedFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

value = ExtendedLicense.SharedFolder
C#
public static string SharedFolder {get;}
Managed Extensions for C++
public: __property static string* get_SharedFolder();
C++/CLI
public:
static property String^ SharedFolder {
   String^ get();
}

Remarks

The shared license folder is a location on the client machine where all XHEO|Licensing protected applications can look for licenses. This helps with shared hosting environments and large applications that may include multiple assemblies, some in the GAC. Rather then having .LIC files spread over the machine they can be located into a single location.

This is a machine wide setting. The value of this property should be considered configured by the machine's administrator. You should not change it as it will effect all installed applications protected with XHEO|Licensing.

The folder location by default is [Common Files]\Xheo\SharedLicenses. This can be configured per machine or per user in the registry at HKLM or HKLU\Software\Xheo\Licensing\SharedLicenseFolder.

See LicenseFolders for settings you can apply to the application's config or machine.config file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
LicenseFolders Property


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Signature Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Signature Property

Gets or sets the signature used to validate the license data.

Syntax

Visual Basic (Declaration)
Public Property Signature As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.Signature = value

value = instance.Signature
C#
public string Signature {get; set;}
Managed Extensions for C++
public: __property string* get_Signature();
public: __property void set_Signature(
   string* value
);
C++/CLI
public:
property String^ Signature {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SurrogateLicensePack Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : SurrogateLicensePack Property

Gets or sets a surrogate license pack to use if validation of this license fails.

Syntax

Visual Basic (Declaration)
Public Property SurrogateLicensePack As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.SurrogateLicensePack = value

value = instance.SurrogateLicensePack
C#
public string SurrogateLicensePack {get; set;}
Managed Extensions for C++
public: __property string* get_SurrogateLicensePack();
public: __property void set_SurrogateLicensePack(
   string* value
);
C++/CLI
public:
property String^ SurrogateLicensePack {
   String^ get();
   void set (String^ value);
}

Remarks

For limits that alter the current license, or download new licenses you can set this property so that the new or altered license pack is used instead. When Validate is called on the current license, this is initially set to null. If Validate returns false, and this is not null then the license pack indicated in this property, if it contains a license, is used instead. If a surrogate license pack also defines a surrogate license, it will not be checked, the license provider only checks one level deep.

Generally you shouldn't set this to a license pack containing license with with a Trial limit or GUI limit because it will interfere with the optimal license selection of the license provider.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Tag Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Tag Property

Gets or sets an arbitrary piece of data to track with the license. This is a "cheap" way of extending the license scheme by allowing you to store any kind of additional data that can be saved as a string to the license.

Syntax

Visual Basic (Declaration)
Public Property Tag As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.Tag = value

value = instance.Tag
C#
public string Tag {get; set;}
Managed Extensions for C++
public: __property string* get_Tag();
public: __property void set_Tag(
   string* value
);
C++/CLI
public:
property String^ Tag {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
TemplateFolder Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : TemplateFolder Property

Gets the folder where the license templates are located as defined in the application's config file.

Syntax

Visual Basic (Declaration)
Public Shared Property TemplateFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

ExtendedLicense.TemplateFolder = value

value = ExtendedLicense.TemplateFolder
C#
public static string TemplateFolder {get; set;}
Managed Extensions for C++
public: __property static string* get_TemplateFolder();
public: __property static void set_TemplateFolder(
   string* value
);
C++/CLI
public:
static property String^ TemplateFolder {
   String^ get();
   void set (String^ value);
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.TemplateFolder" value="X:\Templates" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="TemplateFolder" value="D:\aaa\Templates" />
    </Licensing>
</Xheo>
</configuration>

Remarks

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.TemplateFolder and set it to the path where keys are stored on your machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Type Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Type Property

Gets or sets an application/product specific description of the type of license. For examples "designer", "single user", "non-profit", etc. This can often be used a reference to the primary key in a database, such as a SKU, for the product that the license represents.

Syntax

Visual Basic (Declaration)
Public Property Type As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.Type = value

value = instance.Type
C#
public string Type {get; set;}
Managed Extensions for C++
public: __property string* get_Type();
public: __property void set_Type(
   string* value
);
C++/CLI
public:
property String^ Type {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
UnlockBySerial Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : UnlockBySerial Property

Gets or sets a value that indicates if the user must provide a valid serial number to fully unlock the license.

Syntax

Visual Basic (Declaration)
Public Property UnlockBySerial As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Boolean

instance.UnlockBySerial = value

value = instance.UnlockBySerial
C#
public bool UnlockBySerial {get; set;}
Managed Extensions for C++
public: __property bool get_UnlockBySerial();
public: __property void set_UnlockBySerial(
   bool value
);
C++/CLI
public:
property bool UnlockBySerial {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
UnlockedLicense Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : UnlockedLicense Property

Gets or sets the ExtendedLicense that was unlocked by the registration process.

Syntax

Visual Basic (Declaration)
Public Property UnlockedLicense As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As ExtendedLicense

instance.UnlockedLicense = value

value = instance.UnlockedLicense
C#
public ExtendedLicense UnlockedLicense {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_UnlockedLicense();
public: __property void set_UnlockedLicense(
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ UnlockedLicense {
   ExtendedLicense^ get();
   void set (ExtendedLicense^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
User Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : User Property

Gets or sets the value of the user as it should appear on screen.

Syntax

Visual Basic (Declaration)
Public Property User As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.User = value

value = instance.User
C#
public string User {get; set;}
Managed Extensions for C++
public: __property string* get_User();
public: __property void set_User(
   string* value
);
C++/CLI
public:
property String^ User {
   String^ get();
   void set (String^ value);
}

Remarks

Warning This value is unprotected and can be changed by the client. Do not assume the value is valid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Values Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Values Property

Gets a collection of arbitrary values to store with the license.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As LicenseValuesCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As LicenseValuesCollection

value = instance.Values
C#
public LicenseValuesCollection Values {get;}
Managed Extensions for C++
public: __property LicenseValuesCollection* get_Values();
C++/CLI
public:
property LicenseValuesCollection^ Values {
   LicenseValuesCollection^ get();
}

Remarks

You can use this to store values for runtime adjustments such as maximum values, names, etc. The values are also signed so adjustments to the values after the license has been signed will invalidate the license. Non primitive values must be marked as Serializable.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Version Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Version Property

Gets or sets the version of the licensing scheme used.

Syntax

Visual Basic (Declaration)
Public Property Version As Version
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Version

instance.Version = value

value = instance.Version
C#
public Version Version {get; set;}
Managed Extensions for C++
public: __property Version* get_Version();
public: __property void set_Version(
   Version* value
);
C++/CLI
public:
property Version^ Version {
   Version^ get();
   void set (Version^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
XmlString Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : XmlString Property

Gets or sets the contents of the license as an XML string fragment.

Syntax

Visual Basic (Declaration)
Public Property XmlString As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.XmlString = value

value = instance.XmlString
C#
public string XmlString {get; set;}
Managed Extensions for C++
public: __property string* get_XmlString();
public: __property void set_XmlString(
   string* value
);
C++/CLI
public:
property String^ XmlString {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.Web Send comments on this topic.
ExtendedLicense Class Fields
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

For a list of all members of this type, see ExtendedLicense members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ConfigSection | The configuration section where XHEO|Licensing settings are stored in the application's configuration file.
static (Shared in Visual Basic) | CurrentVersion | The current license scheme file version.
Top

See Also

Reference

ExtendedLicense Class
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ConfigSection Field
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ConfigSection Field

The configuration section where XHEO|Licensing settings are stored in the application's configuration file.

Syntax

Visual Basic (Declaration)
Public Shared ConfigSection As String
Visual Basic (Usage) Copy Code
Dim value As String

value = ExtendedLicense.ConfigSection

ExtendedLicense.ConfigSection = value
C#
public static string ConfigSection
Managed Extensions for C++
public: static string* ConfigSection
C++/CLI
public:
static String^ ConfigSection

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.TemplateFolder" value="X:\Keys" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="TemplateFolder" value="D:\aaa" />
    </Licensing>
</Xheo>
</configuration>

Remarks

All of XHEO|Licensing's configuration settings can be set from the application or machine's configuration file. You can use the shared <appSettings> section or the custom section to set settings.

Most configuration options can be set in the configuration file via code by setting the public static property to the desired value. For example to save the location of the KeyFolder simply set KeyFolder to the desired value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
CurrentVersion Field
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : CurrentVersion Field

The current license scheme file version.

Syntax

Visual Basic (Declaration)
Public Shared CurrentVersion As Version
Visual Basic (Usage) Copy Code
Dim value As Version

value = ExtendedLicense.CurrentVersion

ExtendedLicense.CurrentVersion = value
C#
public static Version CurrentVersion
Managed Extensions for C++
public: static Version* CurrentVersion
C++/CLI
public:
static Version^ CurrentVersion

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ExtendedLicenseException Class
See Also Members
[image]
Xheo.Licensing Namespace : ExtendedLicenseException Class

Represents an exception in a Xheo assembly with a localized FriendlyMessage and DetailedMessage.

Syntax

Visual Basic (Declaration)
Private Class ExtendedLicenseException
   Inherits ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException
C#
private class ExtendedLicenseException : ApplicationException
Managed Extensions for C++
private __gc class ExtendedLicenseException : public ApplicationException
C++/CLI
private ref class ExtendedLicenseException : public ApplicationException

Remarks

The Message is used to communicate a simple description of what went wrong and should be written to the non-developer audience. The DetailedMessage should be used to communicate additional technical details and how the problem might be fixed.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Xheo.Licensing.ExtendedLicenseException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
ExtendedLicenseException Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : ExtendedLicenseException Class

The following tables list the members exposed by ExtendedLicenseException.

Public Constructors

 | Name | Description
Public Constructor | ExtendedLicenseException Constructor | Overloaded. Initializes a new instance of the ExtendedLicenseException class.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | DetailedMessage | Gets or sets the detailed message.
Public Property | FriendlyMessage | Gets or sets the friendly message.
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Overridden. Gets a description of the exception.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ExtendedLicenseException Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ExtendedLicenseException Constructor
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class : ExtendedLicenseException Constructor

Initializes a new instance of the ExtendedLicenseException class.

Overload List

Overload | Description
ExtendedLicenseException Constructor() | Initializes a new instance of the ExtendedLicenseException class.
ExtendedLicenseException Constructor(String) | Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.
ExtendedLicenseException Constructor(String,Exception) | Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.
ExtendedLicenseException Constructor(String,Exception,Object[]) | Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.
ExtendedLicenseException Constructor(String,Object[]) | Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ExtendedLicenseException Constructor()
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor()

Initializes a new instance of the ExtendedLicenseException class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException()
C#
public ExtendedLicenseException()
Managed Extensions for C++
public: ExtendedLicenseException();
C++/CLI
public:
ExtendedLicenseException();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ExtendedLicenseException Constructor(String)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor(String)

resourceName
The name of the resource to use for the message.
Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceName As String _
)
Visual Basic (Usage) Copy Code
Dim resourceName As String

Dim instance As ExtendedLicenseException(resourceName)
C#
public ExtendedLicenseException(
   string resourceName
)
Managed Extensions for C++
public: ExtendedLicenseException(
   string* resourceName
)
C++/CLI
public:
ExtendedLicenseException(
   String^ resourceName
)

Parameters

resourceName
The name of the resource to use for the message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ExtendedLicenseException Constructor(String,Exception)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor(String,Exception)

resourceName
The name of the resource to use for the message.
innerException
A reference to any inner exception.
Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceName As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim resourceName As String
Dim innerException As Exception

Dim instance As ExtendedLicenseException(resourceName, innerException)
C#
public ExtendedLicenseException(
   string resourceName,
   Exception innerException
)
Managed Extensions for C++
public: ExtendedLicenseException(
   string* resourceName,
   Exception* innerException
)
C++/CLI
public:
ExtendedLicenseException(
   String^ resourceName,
   Exception^ innerException
)

Parameters

resourceName
The name of the resource to use for the message.
innerException
A reference to any inner exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ExtendedLicenseException Constructor(String,Exception,Object[])
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor(String,Exception,Object[])

resourceName
The name of the resource to use for the message.
innerException
A reference to any inner exception.
args
Variable list of arguments to pass to String.Format.
Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceName As String, _
   ByVal innerException As Exception, _
   ByVal ParamArray args() As Object _
)
Visual Basic (Usage) Copy Code
Dim resourceName As String
Dim innerException As Exception
Dim args() As Object

Dim instance As ExtendedLicenseException(resourceName, innerException, args)
C#
public ExtendedLicenseException(
   string resourceName,
   Exception innerException,
   params object[] args
)
Managed Extensions for C++
public: ExtendedLicenseException(
   string* resourceName,
   Exception* innerException,
   params Object*[] args
)
C++/CLI
public:
ExtendedLicenseException(
   String^ resourceName,
   Exception^ innerException,
   ... array<Object^> args
)

Parameters

resourceName
The name of the resource to use for the message.
innerException
A reference to any inner exception.
args
Variable list of arguments to pass to String.Format.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ExtendedLicenseException Constructor(String,Object[])
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor(String,Object[])

resourceName
The name of the resource to use for the message.
args
Variable list of arguments to pass to String.Format.
Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceName As String, _
   ByVal ParamArray args() As Object _
)
Visual Basic (Usage) Copy Code
Dim resourceName As String
Dim args() As Object

Dim instance As ExtendedLicenseException(resourceName, args)
C#
public ExtendedLicenseException(
   string resourceName,
   params object[] args
)
Managed Extensions for C++
public: ExtendedLicenseException(
   string* resourceName,
   params Object*[] args
)
C++/CLI
public:
ExtendedLicenseException(
   String^ resourceName,
   ... array<Object^> args
)

Parameters

resourceName
The name of the resource to use for the message.
args
Variable list of arguments to pass to String.Format.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET.Web Send comments on this topic.
ExtendedLicenseException Class Properties
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicenseException Class

For a list of all members of this type, see ExtendedLicenseException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | DetailedMessage | Gets or sets the detailed message.
Public Property | FriendlyMessage | Gets or sets the friendly message.
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Overridden. Gets a description of the exception.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ExtendedLicenseException Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
DetailedMessage Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class : DetailedMessage Property

Gets or sets the detailed message.

Syntax

Visual Basic (Declaration)
Public Property DetailedMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException
Dim value As String

instance.DetailedMessage = value

value = instance.DetailedMessage
C#
public string DetailedMessage {get; set;}
Managed Extensions for C++
public: __property string* get_DetailedMessage();
public: __property void set_DetailedMessage(
   string* value
);
C++/CLI
public:
property String^ DetailedMessage {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
FriendlyMessage Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class : FriendlyMessage Property

Gets or sets the friendly message.

Syntax

Visual Basic (Declaration)
Public Property FriendlyMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException
Dim value As String

instance.FriendlyMessage = value

value = instance.FriendlyMessage
C#
public string FriendlyMessage {get; set;}
Managed Extensions for C++
public: __property string* get_FriendlyMessage();
public: __property void set_FriendlyMessage(
   string* value
);
C++/CLI
public:
property String^ FriendlyMessage {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Message Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class : Message Property

Gets a description of the exception.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property Message As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException
Dim value As String

value = instance.Message
C#
public override string Message {get;}
Managed Extensions for C++
public: __property string* get_Message()override ;
C++/CLI
public:
property String^ Message override {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ExtendedLicensePack Class
See Also Members
[image]
Xheo.Licensing Namespace : ExtendedLicensePack Class

Represents a collection of licenses stored in a single .LIC file.

Object Model

Syntax

Visual Basic (Declaration)
Private Class ExtendedLicensePack
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
C#
private class ExtendedLicensePack : CollectionBase
Managed Extensions for C++
private __gc class ExtendedLicensePack : public CollectionBase
C++/CLI
private ref class ExtendedLicensePack : public CollectionBase

Remarks

Each license pack can serialize to and from an XML license file. Each license within the pack is signed, but the pack itself is not. Licenses can be added or removed without affecting the validity of the pack.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Xheo.Licensing.ExtendedLicensePack

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
ExtendedLicensePack Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : ExtendedLicensePack Class

The following tables list the members exposed by ExtendedLicensePack.

Public Constructors

 | Name | Description
Public Constructor | ExtendedLicensePack Constructor | Overloaded. Initializes a new instance of the ExtendedLicensePack class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsEmbedded | Gets a value that indicates if the pack was loaded directly from an assembly.
Public Property | Item | Overloaded. Gets or sets the ExtendedLicense at the given index.
Public Property | Location | Gets the path to the file where the license pack was originally loaded from. If not loaded from a file, returns null.
Public Property | MetaValues | Gets a collection of arbitrary values to store with the license pack. These values are not protected and may be changed without affecting the validity of the contained licenses. Use for storing volitle information and other unsecured information.
Public Property | SaveToShared | Gets or sets a value that indicates if changes to the license pack when validating should be saved to the shared licenses folder.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the given ExtendedLicense to the collection.
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Clones the license pack in memory.
Public Method | Contains | Determines if the pack contains the given license.
Public Method | CopyTo | Copies the collection of ExtendedLicense objects into the array at the given index.
Public Method | Dispose | Disposes of any managed/unmanged resources.
Public Method | FromXmlString | Loads the contents of the xml string into the license pack.
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetLicensesForComponent | Gets a subset of the current license pack filtered by the given component.
Public Method | IndexOf | Overloaded. Gets the index of the ExtendedLicense with the given serial number.
Public Method | Insert | Inserts the license at the given index.
Public Method | Load | Overloaded. Loads the contents of the license pack from a file.
Public Method | Remove | Overloaded. Removes the given ExtendedLicense from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Save | Overloaded. Saves the contents of the license pack to a stream.
Public Method | ToFormattedXmlString | Gets the contents of the license pack as an friendly XML string.
Public Method | ToXmlString | Gets the contents of the license pack as an XML string.
Public Method | WriteToResponse | Overloaded. Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.
Top

See Also

Reference

ExtendedLicensePack Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ExtendedLicensePack Constructor
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : ExtendedLicensePack Constructor

Initializes a new instance of the ExtendedLicensePack class.

Overload List

Overload | Description
ExtendedLicensePack Constructor() | Initializes a new instance of the ExtendedLicensePack class.
ExtendedLicensePack Constructor(String) | Initializes a new instance of the ExtendedLicensePack class from the given file.
ExtendedLicensePack Constructor(String,Boolean) | Initializes a new instance of the ExtendedLicensePack class from the given file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ExtendedLicensePack Constructor()
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > ExtendedLicensePack Constructor : ExtendedLicensePack Constructor()

Initializes a new instance of the ExtendedLicensePack class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack()
C#
public ExtendedLicensePack()
Managed Extensions for C++
public: ExtendedLicensePack();
C++/CLI
public:
ExtendedLicensePack();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ExtendedLicensePack Constructor(String)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > ExtendedLicensePack Constructor : ExtendedLicensePack Constructor(String)

filename
Path to the file that contains the license pack.
Initializes a new instance of the ExtendedLicensePack class from the given file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim filename As String

Dim instance As ExtendedLicensePack(filename)
C#
public ExtendedLicensePack(
   string filename
)
Managed Extensions for C++
public: ExtendedLicensePack(
   string* filename
)
C++/CLI
public:
ExtendedLicensePack(
   String^ filename
)

Parameters

filename
Path to the file that contains the license pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ExtendedLicensePack Constructor(String,Boolean)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > ExtendedLicensePack Constructor : ExtendedLicensePack Constructor(String,Boolean)

filename
Path to the file that contains the license pack.
tryIsolatedStorage
When true attempts to load a mirrored version of the license from Isolated Storage first.
Initializes a new instance of the ExtendedLicensePack class from the given file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String, _
   ByVal tryIsolatedStorage As Boolean _
)
Visual Basic (Usage) Copy Code
Dim filename As String
Dim tryIsolatedStorage As Boolean

Dim instance As ExtendedLicensePack(filename, tryIsolatedStorage)
C#
public ExtendedLicensePack(
   string filename,
   bool tryIsolatedStorage
)
Managed Extensions for C++
public: ExtendedLicensePack(
   string* filename,
   bool tryIsolatedStorage
)
C++/CLI
public:
ExtendedLicensePack(
   String^ filename,
   bool tryIsolatedStorage
)

Parameters

filename
Path to the file that contains the license pack.
tryIsolatedStorage
When true attempts to load a mirrored version of the license from Isolated Storage first.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
ExtendedLicensePack Class Methods
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicensePack Class

For a list of all members of this type, see ExtendedLicensePack members.

Public Methods

 | Name | Description
Public Method | Add | Adds the given ExtendedLicense to the collection.
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Clones the license pack in memory.
Public Method | Contains | Determines if the pack contains the given license.
Public Method | CopyTo | Copies the collection of ExtendedLicense objects into the array at the given index.
Public Method | Dispose | Disposes of any managed/unmanged resources.
Public Method | FromXmlString | Loads the contents of the xml string into the license pack.
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetLicensesForComponent | Gets a subset of the current license pack filtered by the given component.
Public Method | IndexOf | Overloaded. Gets the index of the ExtendedLicense with the given serial number.
Public Method | Insert | Inserts the license at the given index.
Public Method | Load | Overloaded. Loads the contents of the license pack from a file.
Public Method | Remove | Overloaded. Removes the given ExtendedLicense from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Save | Overloaded. Saves the contents of the license pack to a stream.
Public Method | ToFormattedXmlString | Gets the contents of the license pack as an friendly XML string.
Public Method | ToXmlString | Gets the contents of the license pack as an XML string.
Public Method | WriteToResponse | Overloaded. Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.
Top

See Also

Reference

ExtendedLicensePack Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Add Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Add Method

license
The ExtendedLicense to add.
Adds the given ExtendedLicense to the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim license As ExtendedLicense

instance.Add(license)
C#
public void Add(
   ExtendedLicense license
)
Managed Extensions for C++
public: void Add(
   ExtendedLicense* license
)
C++/CLI
public:
void Add(
   ExtendedLicense^ license
)

Parameters

license
The ExtendedLicense to add.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Clone Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Clone Method

Clones the license pack in memory.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As Object

value = instance.Clone()
C#
public object Clone()
Managed Extensions for C++
public: Object* Clone();
C++/CLI
public:
Object^ Clone();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Contains Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Contains Method

license
The license to look for.
Determines if the pack contains the given license.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal license As ExtendedLicense _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim license As ExtendedLicense
Dim value As Boolean

value = instance.Contains(license)
C#
public bool Contains(
   ExtendedLicense license
)
Managed Extensions for C++
public: bool Contains(
   ExtendedLicense* license
)
C++/CLI
public:
bool Contains(
   ExtendedLicense^ license
)

Parameters

license
The license to look for.

Return Value

Returns true if the license is found, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
CopyTo Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : CopyTo Method

array
The array to copy to.
index
The index in the array to start copying.
Copies the collection of ExtendedLicense objects into the array at the given index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ExtendedLicense, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim array() As ExtendedLicense
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ExtendedLicense[] array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   ExtendedLicense*[] array,
   int index
)
C++/CLI
public:
void CopyTo(
   array<ExtendedLicense^> array,
   int index
)

Parameters

array
The array to copy to.
index
The index in the array to start copying.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Dispose Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Dispose Method

Disposes of any managed/unmanged resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : FromXmlString Method

xml
A string containing the XML for the license pack.
Loads the contents of the xml string into the license pack.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
A string containing the XML for the license pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetLicensesForComponent Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : GetLicensesForComponent Method

component
Name of the component to get licenses for.
Gets a subset of the current license pack filtered by the given component.

Syntax

Visual Basic (Declaration)
Public Function GetLicensesForComponent( _
   ByVal component As String _
) As ICollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim component As String
Dim value As ICollection

value = instance.GetLicensesForComponent(component)
C#
public ICollection GetLicensesForComponent(
   string component
)
Managed Extensions for C++
public: ICollection* GetLicensesForComponent(
   string* component
)
C++/CLI
public:
ICollection^ GetLicensesForComponent(
   String^ component
)

Parameters

component
Name of the component to get licenses for.

Return Value

Returns a new collection with the requested licenses.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IndexOf Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : IndexOf Method

Gets the index of the ExtendedLicense with the given serial number.

Overload List

Overload | Description
IndexOf(String) | Gets the index of the ExtendedLicense with the given serial number.
IndexOf(ExtendedLicense) | Gets the index of the license in the pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IndexOf(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > IndexOf Method : IndexOf(String) Method

serialNumber
The serial number to look for.
Gets the index of the ExtendedLicense with the given serial number.

Syntax

Visual Basic (Declaration)
Overloads Public Function IndexOf( _
   ByVal serialNumber As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim serialNumber As String
Dim value As Integer

value = instance.IndexOf(serialNumber)
C#
public int IndexOf(
   string serialNumber
)
Managed Extensions for C++
public: int IndexOf(
   string* serialNumber
)
C++/CLI
public:
int IndexOf(
   String^ serialNumber
)

Parameters

serialNumber
The serial number to look for.

Return Value

Returns the index of the license if found, otherwise -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IndexOf(ExtendedLicense) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > IndexOf Method : IndexOf(ExtendedLicense) Method

license
The license to look for.
Gets the index of the license in the pack.

Syntax

Visual Basic (Declaration)
Overloads Public Function IndexOf( _
   ByVal license As ExtendedLicense _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim license As ExtendedLicense
Dim value As Integer

value = instance.IndexOf(license)
C#
public int IndexOf(
   ExtendedLicense license
)
Managed Extensions for C++
public: int IndexOf(
   ExtendedLicense* license
)
C++/CLI
public:
int IndexOf(
   ExtendedLicense^ license
)

Parameters

license
The license to look for.

Return Value

Returns the index of the license if found, otherwise -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Insert Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Insert Method

index
The index in the collection to insert the license.
license
The license to be inserted.
Inserts the license at the given index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim index As Integer
Dim license As ExtendedLicense

instance.Insert(index, license)
C#
public void Insert(
   int index,
   ExtendedLicense license
)
Managed Extensions for C++
public: void Insert(
   int index,
   ExtendedLicense* license
)
C++/CLI
public:
void Insert(
   int index,
   ExtendedLicense^ license
)

Parameters

index
The index in the collection to insert the license.
license
The license to be inserted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Load Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Load Method

Loads the contents of the license pack from a file.

Overload List

Overload | Description
Load(String,Boolean) | Loads the contents of the license pack from a file.
Load(String) | Loads the contents of the license pack from a file.
Load(Stream) | Loads the contents of the license pack from a file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Load(String,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Load Method : Load(String,Boolean) Method

filename
Path to the file where the licenses were saved.
tryIsolatedStorage
When true attempts to load a mirrored version of the license from Isolated Storage first.
Loads the contents of the license pack from a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal filename As String, _
   ByVal tryIsolatedStorage As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String
Dim tryIsolatedStorage As Boolean

instance.Load(filename, tryIsolatedStorage)
C#
public void Load(
   string filename,
   bool tryIsolatedStorage
)
Managed Extensions for C++
public: void Load(
   string* filename,
   bool tryIsolatedStorage
)
C++/CLI
public:
void Load(
   String^ filename,
   bool tryIsolatedStorage
)

Parameters

filename
Path to the file where the licenses were saved.
tryIsolatedStorage
When true attempts to load a mirrored version of the license from Isolated Storage first.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Load(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Load Method : Load(String) Method

filename
Path to the file where the licenses were saved.
Loads the contents of the license pack from a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String

instance.Load(filename)
C#
public void Load(
   string filename
)
Managed Extensions for C++
public: void Load(
   string* filename
)
C++/CLI
public:
void Load(
   String^ filename
)

Parameters

filename
Path to the file where the licenses were saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Load(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Load Method : Load(Stream) Method

stream
The stream to load from.
Loads the contents of the license pack from a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim stream As Stream

instance.Load(stream)
C#
public void Load(
   Stream stream
)
Managed Extensions for C++
public: void Load(
   Stream* stream
)
C++/CLI
public:
void Load(
   Stream^ stream
)

Parameters

stream
The stream to load from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Remove Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Remove Method

Removes the given ExtendedLicense from the collection.

Overload List

Overload | Description
Remove(ExtendedLicense) | Removes the given ExtendedLicense from the collection.
Remove(String) | Removes the license with the given serial number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Remove(ExtendedLicense) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Remove Method : Remove(ExtendedLicense) Method

license
The ExtendedLicense to remove.
Removes the given ExtendedLicense from the collection.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim license As ExtendedLicense

instance.Remove(license)
C#
public void Remove(
   ExtendedLicense license
)
Managed Extensions for C++
public: void Remove(
   ExtendedLicense* license
)
C++/CLI
public:
void Remove(
   ExtendedLicense^ license
)

Parameters

license
The ExtendedLicense to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Remove(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Remove Method : Remove(String) Method

serialNumber
The serial numbef of the license to remove.
Removes the license with the given serial number.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal serialNumber As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim serialNumber As String

instance.Remove(serialNumber)
C#
public void Remove(
   string serialNumber
)
Managed Extensions for C++
public: void Remove(
   string* serialNumber
)
C++/CLI
public:
void Remove(
   String^ serialNumber
)

Parameters

serialNumber
The serial numbef of the license to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Save Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Save Method

Saves the contents of the license pack to a stream.

Overload List

Overload | Description
Save(Stream) | Saves the contents of the license pack to a stream.
Save(String) | Saves the contents of the license pack to a file.
Save() | Saves the contents of the license pack to the file that it was originally loaded from.
Save(String,Boolean) | Saves the contents of the license pack to a file.
Save(Boolean) | Saves the contents of the license pack to the file that it was originally loaded from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Save(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save(Stream) Method

stream
The Stream to write the contents of the license pack to.
Saves the contents of the license pack to a stream.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim stream As Stream

instance.Save(stream)
C#
public void Save(
   Stream stream
)
Managed Extensions for C++
public: void Save(
   Stream* stream
)
C++/CLI
public:
void Save(
   Stream^ stream
)

Parameters

stream
The Stream to write the contents of the license pack to.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Save(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save(String) Method

filename
Path to the file where the licenses should be saved.
Saves the contents of the license pack to a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String

instance.Save(filename)
C#
public void Save(
   string filename
)
Managed Extensions for C++
public: void Save(
   string* filename
)
C++/CLI
public:
void Save(
   String^ filename
)

Parameters

filename
Path to the file where the licenses should be saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Save() Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save() Method

Saves the contents of the license pack to the file that it was originally loaded from.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack

instance.Save()
C#
public void Save()
Managed Extensions for C++
public: void Save();
C++/CLI
public:
void Save();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Save(String,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save(String,Boolean) Method

filename
Path to the file where the licenses should be saved.
useIsolatedOnFail
If the save fails because of a permission exception, attempt to save to the isolated storage location instead.
Saves the contents of the license pack to a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal filename As String, _
   ByVal useIsolatedOnFail As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String
Dim useIsolatedOnFail As Boolean

instance.Save(filename, useIsolatedOnFail)
C#
public void Save(
   string filename,
   bool useIsolatedOnFail
)
Managed Extensions for C++
public: void Save(
   string* filename,
   bool useIsolatedOnFail
)
C++/CLI
public:
void Save(
   String^ filename,
   bool useIsolatedOnFail
)

Parameters

filename
Path to the file where the licenses should be saved.
useIsolatedOnFail
If the save fails because of a permission exception, attempt to save to the isolated storage location instead.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Save(Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save(Boolean) Method

useIsolatedOnFail
If the save fails because of a permission exception, attempt to save to the isolated storage location instead.
Saves the contents of the license pack to the file that it was originally loaded from.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal useIsolatedOnFail As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim useIsolatedOnFail As Boolean

instance.Save(useIsolatedOnFail)
C#
public void Save(
   bool useIsolatedOnFail
)
Managed Extensions for C++
public: void Save(
   bool useIsolatedOnFail
)
C++/CLI
public:
void Save(
   bool useIsolatedOnFail
)

Parameters

useIsolatedOnFail
If the save fails because of a permission exception, attempt to save to the isolated storage location instead.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ToFormattedXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : ToFormattedXmlString Method

Gets the contents of the license pack as an friendly XML string.

Syntax

Visual Basic (Declaration)
Public Function ToFormattedXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As String

value = instance.ToFormattedXmlString()
C#
public string ToFormattedXmlString()
Managed Extensions for C++
public: string* ToFormattedXmlString();
C++/CLI
public:
String^ ToFormattedXmlString();

Return Value

An XML string representation of the license pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : ToXmlString Method

Gets the contents of the license pack as an XML string.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As String

value = instance.ToXmlString()
C#
public string ToXmlString()
Managed Extensions for C++
public: string* ToXmlString();
C++/CLI
public:
String^ ToXmlString();

Return Value

An XML string representation of the license pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
WriteToResponse Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : WriteToResponse Method

Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.

Overload List

Overload | Description
WriteToResponse(String,Boolean) | Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.
WriteToResponse(String) | Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.
WriteToResponse() | Writes the license pack to the response stream for download.

Remarks

Use this method to provide license downloads on your website. You should be careful to not write any additional content to the response stream, or call Response.End() after this method.

NOTE: The response must be buffered for this method to work. In general buffering is on by default in ASP.NET applications.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
WriteToResponse(String,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > WriteToResponse Method : WriteToResponse(String,Boolean) Method

filename
Suggested file name.
direct
Indicates that the file should be written directly to the response and not saved as a new file. When false the user is prompted to open or save the file on their computer.
Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.

Syntax

Visual Basic (Declaration)
Overloads Public Sub WriteToResponse( _
   ByVal filename As String, _
   ByVal direct As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String
Dim direct As Boolean

instance.WriteToResponse(filename, direct)
C#
public void WriteToResponse(
   string filename,
   bool direct
)
Managed Extensions for C++
public: void WriteToResponse(
   string* filename,
   bool direct
)
C++/CLI
public:
void WriteToResponse(
   String^ filename,
   bool direct
)

Parameters

filename
Suggested file name.
direct
Indicates that the file should be written directly to the response and not saved as a new file. When false the user is prompted to open or save the file on their computer.

Remarks

Use this method to provide license downloads on your website. You should be careful to not write any additional content to the response stream, or call Response.End() after this method.

NOTE: The response must be buffered for this method to work. In general buffering is on by default in ASP.NET applications.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
WriteToResponse(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > WriteToResponse Method : WriteToResponse(String) Method

filename
Suggested file name.
Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.

Syntax

Visual Basic (Declaration)
Overloads Public Sub WriteToResponse( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String

instance.WriteToResponse(filename)
C#
public void WriteToResponse(
   string filename
)
Managed Extensions for C++
public: void WriteToResponse(
   string* filename
)
C++/CLI
public:
void WriteToResponse(
   String^ filename
)

Parameters

filename
Suggested file name.

Remarks

Use this method to provide license downloads on your website. You should be careful to not write any additional content to the response stream, or call Response.End() after this method.

NOTE: The response must be buffered for this method to work. In general buffering is on by default in ASP.NET applications.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
WriteToResponse() Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > WriteToResponse Method : WriteToResponse() Method

Writes the license pack to the response stream for download.

Syntax

Visual Basic (Declaration)
Overloads Public Sub WriteToResponse()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack

instance.WriteToResponse()
C#
public void WriteToResponse()
Managed Extensions for C++
public: void WriteToResponse();
C++/CLI
public:
void WriteToResponse();

Remarks

Use this method to provide license downloads on your website.

NOTE: The response must be buffered for this method to work. In general buffering is on by default in ASP.NET applications.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET.Web Send comments on this topic.
ExtendedLicensePack Class Properties
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicensePack Class

For a list of all members of this type, see ExtendedLicensePack members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsEmbedded | Gets a value that indicates if the pack was loaded directly from an assembly.
Public Property | Item | Overloaded. Gets or sets the ExtendedLicense at the given index.
Public Property | Location | Gets the path to the file where the license pack was originally loaded from. If not loaded from a file, returns null.
Public Property | MetaValues | Gets a collection of arbitrary values to store with the license pack. These values are not protected and may be changed without affecting the validity of the contained licenses. Use for storing volitle information and other unsecured information.
Public Property | SaveToShared | Gets or sets a value that indicates if changes to the license pack when validating should be saved to the shared licenses folder.
Top

See Also

Reference

ExtendedLicensePack Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IsEmbedded Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : IsEmbedded Property

Gets a value that indicates if the pack was loaded directly from an assembly.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmbedded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As Boolean

value = instance.IsEmbedded
C#
public bool IsEmbedded {get;}
Managed Extensions for C++
public: __property bool get_IsEmbedded();
C++/CLI
public:
property bool IsEmbedded {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Item Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Item Property

Gets or sets the ExtendedLicense at the given index.

Overload List

Overload | Description
Item(Int32) | Gets or sets the ExtendedLicense at the given index.
Item(String) | Gets or sets the ExtendedLicense with the given serial number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Item(Int32) Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Item Property : Item(Int32) Property

index
Gets or sets the ExtendedLicense at the given index.

Syntax

Visual Basic (Declaration)
Overloads Public Property Item( _
   ByVal index As Integer _
) As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim index As Integer
Dim value As ExtendedLicense

instance.Item(index) = value

value = instance.Item(index)
C#
public ExtendedLicense Item(
   int index
) {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ Item {
   ExtendedLicense^ get(int index);
   void set (int index, ExtendedLicense^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Item(String) Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Item Property : Item(String) Property

serialNumber
Gets or sets the ExtendedLicense with the given serial number.

Syntax

Visual Basic (Declaration)
Overloads Public Property Item( _
   ByVal serialNumber As String _
) As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim serialNumber As String
Dim value As ExtendedLicense

instance.Item(serialNumber) = value

value = instance.Item(serialNumber)
C#
public ExtendedLicense Item(
   string serialNumber
) {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_Item(
   string* serialNumber
);
public: __property void set_Item(
   string* serialNumber,
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ Item {
   ExtendedLicense^ get(String^ serialNumber);
   void set (String^ serialNumber, ExtendedLicense^ value);
}

Parameters

serialNumber

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Location Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Location Property

Gets the path to the file where the license pack was originally loaded from. If not loaded from a file, returns null.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As String

value = instance.Location
C#
public string Location {get;}
Managed Extensions for C++
public: __property string* get_Location();
C++/CLI
public:
property String^ Location {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MetaValues Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : MetaValues Property

Gets a collection of arbitrary values to store with the license pack. These values are not protected and may be changed without affecting the validity of the contained licenses. Use for storing volitle information and other unsecured information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetaValues As LicenseValuesCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As LicenseValuesCollection

value = instance.MetaValues
C#
public LicenseValuesCollection MetaValues {get;}
Managed Extensions for C++
public: __property LicenseValuesCollection* get_MetaValues();
C++/CLI
public:
property LicenseValuesCollection^ MetaValues {
   LicenseValuesCollection^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SaveToShared Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : SaveToShared Property

Gets or sets a value that indicates if changes to the license pack when validating should be saved to the shared licenses folder.

Syntax

Visual Basic (Declaration)
Public Property SaveToShared As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As Boolean

instance.SaveToShared = value

value = instance.SaveToShared
C#
public bool SaveToShared {get; set;}
Managed Extensions for C++
public: __property bool get_SaveToShared();
public: __property void set_SaveToShared(
   bool value
);
C++/CLI
public:
property bool SaveToShared {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LicenseSigningKey Class
See Also Members
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

Implements a key pair for signing licenses.

Syntax

Visual Basic (Declaration)
Private NotInheritable Class LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
C#
private sealed class LicenseSigningKey
Managed Extensions for C++
private __gc __sealed class LicenseSigningKey
C++/CLI
private ref class LicenseSigningKey sealed

Remarks

See ExtendedLicense for details on how this class works with others in the library to enforce component licenses.

Inheritance Hierarchy

System.Object
Xheo.Licensing.LicenseSigningKey

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
LicenseSigningKey Class Members
See Also Fields Properties Methods
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

The following tables list the members exposed by LicenseSigningKey.

Public Constructors

 | Name | Description
Public Constructor | LicenseSigningKey Constructor | Overloaded. Initializes a new instance of the LicenseSigningKey class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CurrentVersion | The current version of the LicenseSigningKey class.
Top

Public Properties

 | Name | Description
Public Property | IsGlobalKey | Gets a value that indicates if the keys are the global keys used during the trial.
Public Property | Location | Gets the location where the keys were loaded from.
Public Property | Version | Gets or sets the version of the signing key.
Top

Public Methods

 | Name | Description
Public Method | Decrypt | Decrypts the data using the key. Use Encrypt to encrypt values.
Public Method | DecryptString | Decrypts the data using the key. Use EncryptString to encrypt values.
Public Method | Dispose | Implements Dispose.
Public Method | Encrypt | Encrypts the data using the key. Use Decrypt to retrieve the encrypted value.
Public Method | EncryptString | Encrypts the data using the key. Use DecryptString to retrieve the encrypted value.
Public Method | Export | Overloaded. Saves the public key contents of the LicenseSigningKey to a file with the given file name.
Public Method | FromXmlString | Initializes the contents of the LicenseSigningKey from the XML string.
static (Shared in Visual Basic) | GetPublicKey | Gets the runtime.lic embedded in the assembly hosting the given type.
Public Method | GetSerialNumberSeed | Gets the original unmasked serial number seed (Int32 value) from the encoded value.
static (Shared in Visual Basic) | GetSigningKey | Overloaded. Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.
Public Method | Load | Overloaded. Loads the LicenseSigningKey with the contents of the given file.
Public Method | MakeSerialNumber | Overloaded. Makes an encoded serial number for the given license.
Public Method | Save | Overloaded. Saves the contents of the LicenseSigningKey to a file with the given file name.
Public Method | SignData |
Public Method | SignLicense | Signs the ExtendedLicense and sets the LicenseKey property
Public Method | SignResponse | Signs a response so that the originator of the message can be validated.
Public Method | ToXmlString | Gets the LicenseSigningKey as an XML strign.
Public Method | UpgradeVersion | Upgrades the keys to the format used by the specified version.
Public Method | ValidateLicense | Validates that the contents of the license has not been changed since it was signed.
Public Method | ValidateResponse | Validates a response signature.
Public Method | ValidateSerialNumber | Overloaded. Validates that a serial number was signed with the license key and falls within a given range of valid numbers.
Public Method | VerifyData |
Top

See Also

Reference

LicenseSigningKey Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LicenseSigningKey Constructor
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : LicenseSigningKey Constructor

Initializes a new instance of the LicenseSigningKey class.

Overload List

Overload | Description
LicenseSigningKey Constructor() | Initializes a new instance of the LicenseSigningKey class.
LicenseSigningKey Constructor(Stream) | Initializes a new instance of the LicenseSigningKey class with the key from the given Stream object.
LicenseSigningKey Constructor(String) | Initializes a new instance of the LicenseSigningKey class with the key from the given file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LicenseSigningKey Constructor()
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > LicenseSigningKey Constructor : LicenseSigningKey Constructor()

Initializes a new instance of the LicenseSigningKey class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey()
C#
public LicenseSigningKey()
Managed Extensions for C++
public: LicenseSigningKey();
C++/CLI
public:
LicenseSigningKey();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LicenseSigningKey Constructor(Stream)
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > LicenseSigningKey Constructor : LicenseSigningKey Constructor(Stream)

stream
The Stream object that contains the data.
Initializes a new instance of the LicenseSigningKey class with the key from the given Stream object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As LicenseSigningKey(stream)
C#
public LicenseSigningKey(
   Stream stream
)
Managed Extensions for C++
public: LicenseSigningKey(
   Stream* stream
)
C++/CLI
public:
LicenseSigningKey(
   Stream^ stream
)

Parameters

stream
The Stream object that contains the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LicenseSigningKey Constructor(String)
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > LicenseSigningKey Constructor : LicenseSigningKey Constructor(String)

filename
Path to the file where the LicenseSigningKey is saved.
Initializes a new instance of the LicenseSigningKey class with the key from the given file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim filename As String

Dim instance As LicenseSigningKey(filename)
C#
public LicenseSigningKey(
   string filename
)
Managed Extensions for C++
public: LicenseSigningKey(
   string* filename
)
C++/CLI
public:
LicenseSigningKey(
   String^ filename
)

Parameters

filename
Path to the file where the LicenseSigningKey is saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
LicenseSigningKey Class Methods
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

For a list of all members of this type, see LicenseSigningKey members.

Public Methods

 | Name | Description
Public Method | Decrypt | Decrypts the data using the key. Use Encrypt to encrypt values.
Public Method | DecryptString | Decrypts the data using the key. Use EncryptString to encrypt values.
Public Method | Dispose | Implements Dispose.
Public Method | Encrypt | Encrypts the data using the key. Use Decrypt to retrieve the encrypted value.
Public Method | EncryptString | Encrypts the data using the key. Use DecryptString to retrieve the encrypted value.
Public Method | Export | Overloaded. Saves the public key contents of the LicenseSigningKey to a file with the given file name.
Public Method | FromXmlString | Initializes the contents of the LicenseSigningKey from the XML string.
static (Shared in Visual Basic) | GetPublicKey | Gets the runtime.lic embedded in the assembly hosting the given type.
Public Method | GetSerialNumberSeed | Gets the original unmasked serial number seed (Int32 value) from the encoded value.
static (Shared in Visual Basic) | GetSigningKey | Overloaded. Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.
Public Method | Load | Overloaded. Loads the LicenseSigningKey with the contents of the given file.
Public Method | MakeSerialNumber | Overloaded. Makes an encoded serial number for the given license.
Public Method | Save | Overloaded. Saves the contents of the LicenseSigningKey to a file with the given file name.
Public Method | SignData |
Public Method | SignLicense | Signs the ExtendedLicense and sets the LicenseKey property
Public Method | SignResponse | Signs a response so that the originator of the message can be validated.
Public Method | ToXmlString | Gets the LicenseSigningKey as an XML strign.
Public Method | UpgradeVersion | Upgrades the keys to the format used by the specified version.
Public Method | ValidateLicense | Validates that the contents of the license has not been changed since it was signed.
Public Method | ValidateResponse | Validates a response signature.
Public Method | ValidateSerialNumber | Overloaded. Validates that a serial number was signed with the license key and falls within a given range of valid numbers.
Public Method | VerifyData |
Top

See Also

Reference

LicenseSigningKey Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Decrypt Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Decrypt Method

data
Data previously encrypted with Encrypt.
Decrypts the data using the key. Use Encrypt to encrypt values.

Syntax

Visual Basic (Declaration)
Public Function Decrypt( _
   ByVal data() As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim value() As Byte

value = instance.Decrypt(data)
C#
public byte[] Decrypt(
   byte[] data
)
Managed Extensions for C++
public: byte[] Decrypt(
   byte[] data
)
C++/CLI
public:
array<byte> Decrypt(
   array<byte> data
)

Parameters

data
Data previously encrypted with Encrypt.

Return Value

Returns the original value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
DecryptString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : DecryptString Method

data
Data previously encrypted with EncryptString.
Decrypts the data using the key. Use EncryptString to encrypt values.

Syntax

Visual Basic (Declaration)
Public Function DecryptString( _
   ByVal data() As Byte _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim value As String

value = instance.DecryptString(data)
C#
public string DecryptString(
   byte[] data
)
Managed Extensions for C++
public: string* DecryptString(
   byte[] data
)
C++/CLI
public:
String^ DecryptString(
   array<byte> data
)

Parameters

data
Data previously encrypted with EncryptString.

Return Value

Returns the original value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Dispose Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Dispose Method

Implements Dispose.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Encrypt Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Encrypt Method

data
The data to encrypt.
Encrypts the data using the key. Use Decrypt to retrieve the encrypted value.

Syntax

Visual Basic (Declaration)
Public Function Encrypt( _
   ByVal data() As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim value() As Byte

value = instance.Encrypt(data)
C#
public byte[] Encrypt(
   byte[] data
)
Managed Extensions for C++
public: byte[] Encrypt(
   byte[] data
)
C++/CLI
public:
array<byte> Encrypt(
   array<byte> data
)

Parameters

data
The data to encrypt.

Return Value

Returns the encrypted version of the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
EncryptString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : EncryptString Method

data
The data to encrypt.
Encrypts the data using the key. Use DecryptString to retrieve the encrypted value.

Syntax

Visual Basic (Declaration)
Public Function EncryptString( _
   ByVal data As String _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data As String
Dim value() As Byte

value = instance.EncryptString(data)
C#
public byte[] EncryptString(
   string data
)
Managed Extensions for C++
public: byte[] EncryptString(
   string* data
)
C++/CLI
public:
array<byte> EncryptString(
   String^ data
)

Parameters

data
The data to encrypt.

Return Value

Returns the encrypted version of the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Export Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Export Method

Saves the public key contents of the LicenseSigningKey to a file with the given file name.

Overload List

Overload | Description
Export(String) | Saves the public key contents of the LicenseSigningKey to a file with the given file name.
Export(Stream) | Saves the contents of the LicenseSigningKey to a Stream object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Export(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Export Method : Export(String) Method

filename
Path to the file where the LicenseSigningKey should be saved.
Saves the public key contents of the LicenseSigningKey to a file with the given file name.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Export( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim filename As String

instance.Export(filename)
C#
public void Export(
   string filename
)
Managed Extensions for C++
public: void Export(
   string* filename
)
C++/CLI
public:
void Export(
   String^ filename
)

Parameters

filename
Path to the file where the LicenseSigningKey should be saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Export(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Export Method : Export(Stream) Method

stream
The Stream object to receive the data.
Saves the contents of the LicenseSigningKey to a Stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Export( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim stream As Stream

instance.Export(stream)
C#
public void Export(
   Stream stream
)
Managed Extensions for C++
public: void Export(
   Stream* stream
)
C++/CLI
public:
void Export(
   Stream^ stream
)

Parameters

stream
The Stream object to receive the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : FromXmlString Method

xml
A string containing an XML representaion of the key.
Initializes the contents of the LicenseSigningKey from the XML string.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
A string containing an XML representaion of the key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetPublicKey Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : GetPublicKey Method

type
The reference type to use for obtaining the assembly.
Gets the runtime.lic embedded in the assembly hosting the given type.

Syntax

Visual Basic (Declaration)
Public Shared Function GetPublicKey( _
   ByVal type As Type _
) As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim type As Type
Dim value As LicenseSigningKey

value = LicenseSigningKey.GetPublicKey(type)
C#
public static LicenseSigningKey GetPublicKey(
   Type type
)
Managed Extensions for C++
public: static LicenseSigningKey* GetPublicKey(
   Type* type
)
C++/CLI
public:
static LicenseSigningKey^ GetPublicKey(
   Type^ type
)

Parameters

type
The reference type to use for obtaining the assembly.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetSerialNumberSeed Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : GetSerialNumberSeed Method

license
The license the serial number was generated for.
serialNumber
The masked serial number created by MakeSerialNumber.
Gets the original unmasked serial number seed (Int32 value) from the encoded value.

Syntax

Visual Basic (Declaration)
Public Function GetSerialNumberSeed( _
   ByVal license As ExtendedLicense, _
   ByVal serialNumber As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim serialNumber As String
Dim value As Integer

value = instance.GetSerialNumberSeed(license, serialNumber)
C#
public int GetSerialNumberSeed(
   ExtendedLicense license,
   string serialNumber
)
Managed Extensions for C++
public: int GetSerialNumberSeed(
   ExtendedLicense* license,
   string* serialNumber
)
C++/CLI
public:
int GetSerialNumberSeed(
   ExtendedLicense^ license,
   String^ serialNumber
)

Parameters

license
The license the serial number was generated for.
serialNumber
The masked serial number created by MakeSerialNumber.

Return Value

Returns the original Int32 seed value for the masked serial number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetSigningKey Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : GetSigningKey Method

Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.

Overload List

Overload | Description
GetSigningKey(String,String) | Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.
GetSigningKey(String) | Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetSigningKey(String,String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > GetSigningKey Method : GetSigningKey(String,String) Method

name
Name of the keys.
folder
Path to the folder where the keys are located.
Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function GetSigningKey( _
   ByVal name As String, _
   ByVal folder As String _
) As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim name As String
Dim folder As String
Dim value As LicenseSigningKey

value = LicenseSigningKey.GetSigningKey(name, folder)
C#
public static LicenseSigningKey GetSigningKey(
   string name,
   string folder
)
Managed Extensions for C++
public: static LicenseSigningKey* GetSigningKey(
   string* name,
   string* folder
)
C++/CLI
public:
static LicenseSigningKey^ GetSigningKey(
   String^ name,
   String^ folder
)

Parameters

name
Name of the keys.
folder
Path to the folder where the keys are located.

Return Value

Returns the signing key if found, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetSigningKey(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > GetSigningKey Method : GetSigningKey(String) Method

name
Name of the keys.
Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function GetSigningKey( _
   ByVal name As String _
) As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim name As String
Dim value As LicenseSigningKey

value = LicenseSigningKey.GetSigningKey(name)
C#
public static LicenseSigningKey GetSigningKey(
   string name
)
Managed Extensions for C++
public: static LicenseSigningKey* GetSigningKey(
   string* name
)
C++/CLI
public:
static LicenseSigningKey^ GetSigningKey(
   String^ name
)

Parameters

name
Name of the keys.

Return Value

Returns the signing key if found, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Load Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Load Method

Loads the LicenseSigningKey with the contents of the given file.

Overload List

Overload | Description
Load(String) | Loads the LicenseSigningKey with the contents of the given file.
Load(Stream) | Loads the LicenseSigningKey from a Stream object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Load(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Load Method : Load(String) Method

filename
Path to the file where the LicenseSigningKey is saved.
Loads the LicenseSigningKey with the contents of the given file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim filename As String

instance.Load(filename)
C#
public void Load(
   string filename
)
Managed Extensions for C++
public: void Load(
   string* filename
)
C++/CLI
public:
void Load(
   String^ filename
)

Parameters

filename
Path to the file where the LicenseSigningKey is saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Load(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Load Method : Load(Stream) Method

stream
The Stream object that contains the data.
Loads the LicenseSigningKey from a Stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim stream As Stream

instance.Load(stream)
C#
public void Load(
   Stream stream
)
Managed Extensions for C++
public: void Load(
   Stream* stream
)
C++/CLI
public:
void Load(
   Stream^ stream
)

Parameters

stream
The Stream object that contains the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MakeSerialNumber Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : MakeSerialNumber Method

Makes an encoded serial number for the given license.

Overload List

Overload | Description
MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32[],Int32) | Makes an encoded serial number for the given license.
MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32) | Makes an encoded serial number for the given license.
MakeSerialNumber(String,SerialNumberSizes,Int32[],Int32) | Makes an encoded serial number for the given license.
MakeSerialNumber(String,SerialNumberSizes,Int32) | Makes an encoded serial number for the given license.

Exceptions

Exception | Description
ExtendedLicenseException | Thrown when the license keys have not been upgraded to at least version 2.0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32[],Int32) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > MakeSerialNumber Method : MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32[],Int32) Method

license
The license to generate a serial number for.
size
The key size to use when encrypting the serial number.
groupSizes
Defines the group sizes used to split the serial number into smaller chunks. A null value will use the default sizes for the given key size.
seed
The serial number value to encode.
Makes an encoded serial number for the given license.

Syntax

Visual Basic (Declaration)
Overloads Public Function MakeSerialNumber( _
   ByVal license As ExtendedLicense, _
   ByVal size As SerialNumberSizes, _
   ByVal groupSizes() As Integer, _
   ByVal seed As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim size As SerialNumberSizes
Dim groupSizes() As Integer
Dim seed As Integer
Dim value As String

value = instance.MakeSerialNumber(license, size, groupSizes, seed)
C#
public string MakeSerialNumber(
   ExtendedLicense license,
   SerialNumberSizes size,
   int[] groupSizes,
   int seed
)
Managed Extensions for C++
public: string* MakeSerialNumber(
   ExtendedLicense* license,
   SerialNumberSizes size,
   int[] groupSizes,
   int seed
)
C++/CLI
public:
String^ MakeSerialNumber(
   ExtendedLicense^ license,
   SerialNumberSizes size,
   array<int> groupSizes,
   int seed
)

Parameters

license
The license to generate a serial number for.
size
The key size to use when encrypting the serial number.
groupSizes
Defines the group sizes used to split the serial number into smaller chunks. A null value will use the default sizes for the given key size.
seed
The serial number value to encode.

Return Value

Returns a new serial number encrypted with the key.

Exceptions

Exception | Description
ExtendedLicenseException | Thrown when the license keys have not been upgraded to at least version 2.0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > MakeSerialNumber Method : MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32) Method

license
The license to generate a serial number for.
size
The key size to use when encrypting the serial number.
seed
The serial number value to encode.
Makes an encoded serial number for the given license.

Syntax

Visual Basic (Declaration)
Overloads Public Function MakeSerialNumber( _
   ByVal license As ExtendedLicense, _
   ByVal size As SerialNumberSizes, _
   ByVal seed As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim size As SerialNumberSizes
Dim seed As Integer
Dim value As String

value = instance.MakeSerialNumber(license, size, seed)
C#
public string MakeSerialNumber(
   ExtendedLicense license,
   SerialNumberSizes size,
   int seed
)
Managed Extensions for C++
public: string* MakeSerialNumber(
   ExtendedLicense* license,
   SerialNumberSizes size,
   int seed
)
C++/CLI
public:
String^ MakeSerialNumber(
   ExtendedLicense^ license,
   SerialNumberSizes size,
   int seed
)

Parameters

license
The license to generate a serial number for.
size
The key size to use when encrypting the serial number.
seed
The serial number value to encode.

Return Value

Returns a new serial number encrypted with the key.

Exceptions

Exception | Description
ExtendedLicenseException | Thrown when the license keys have not been upgraded to at least version 2.0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MakeSerialNumber(String,SerialNumberSizes,Int32[],Int32) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > MakeSerialNumber Method : MakeSerialNumber(String,SerialNumberSizes,Int32[],Int32) Method

prefix
The prefix to add to the serial number. It must match the AbsoluteSerialNumber of the license it will be assigned to.
size
The key size to use when encrypting the serial number.
groupSizes
Defines the group sizes used to split the serial number into smaller chunks. A null value will use the default sizes for the given key size.
seed
The serial number value to encode.
Makes an encoded serial number for the given license.

Syntax

Visual Basic (Declaration)
Overloads Public Function MakeSerialNumber( _
   ByVal prefix As String, _
   ByVal size As SerialNumberSizes, _
   ByVal groupSizes() As Integer, _
   ByVal seed As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim prefix As String
Dim size As SerialNumberSizes
Dim groupSizes() As Integer
Dim seed As Integer
Dim value As String

value = instance.MakeSerialNumber(prefix, size, groupSizes, seed)
C#
public string MakeSerialNumber(
   string prefix,
   SerialNumberSizes size,
   int[] groupSizes,
   int seed
)
Managed Extensions for C++
public: string* MakeSerialNumber(
   string* prefix,
   SerialNumberSizes size,
   int[] groupSizes,
   int seed
)
C++/CLI
public:
String^ MakeSerialNumber(
   String^ prefix,
   SerialNumberSizes size,
   array<int> groupSizes,
   int seed
)

Parameters

prefix
The prefix to add to the serial number. It must match the AbsoluteSerialNumber of the license it will be assigned to.
size
The key size to use when encrypting the serial number.
groupSizes
Defines the group sizes used to split the serial number into smaller chunks. A null value will use the default sizes for the given key size.
seed
The serial number value to encode.

Return Value

Returns a new serial number encrypted with the key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MakeSerialNumber(String,SerialNumberSizes,Int32) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > MakeSerialNumber Method : MakeSerialNumber(String,SerialNumberSizes,Int32) Method

prefix
The prefix to add to the serial number. It must match the AbsoluteSerialNumber of the license it will be assigned to.
size
The key size to use when encrypting the serial number.
seed
The serial number value to encode.
Makes an encoded serial number for the given license.

Syntax

Visual Basic (Declaration)
Overloads Public Function MakeSerialNumber( _
   ByVal prefix As String, _
   ByVal size As SerialNumberSizes, _
   ByVal seed As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim prefix As String
Dim size As SerialNumberSizes
Dim seed As Integer
Dim value As String

value = instance.MakeSerialNumber(prefix, size, seed)
C#
public string MakeSerialNumber(
   string prefix,
   SerialNumberSizes size,
   int seed
)
Managed Extensions for C++
public: string* MakeSerialNumber(
   string* prefix,
   SerialNumberSizes size,
   int seed
)
C++/CLI
public:
String^ MakeSerialNumber(
   String^ prefix,
   SerialNumberSizes size,
   int seed
)

Parameters

prefix
The prefix to add to the serial number. It must match the AbsoluteSerialNumber of the license it will be assigned to.
size
The key size to use when encrypting the serial number.
seed
The serial number value to encode.

Return Value

Returns a new serial number encrypted with the key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Save Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Save Method

Saves the contents of the LicenseSigningKey to a file with the given file name.

Overload List

Overload | Description
Save(String,Boolean) | Saves the contents of the LicenseSigningKey to a file with the given file name.
Save(String) | Saves the contents of the LicenseSigningKey to a file with the given file name.
Save(Stream,Boolean) | Saves the contents of the LicenseSigningKey to a Stream object.
Save(Stream) | Saves the contents of the LicenseSigningKey to a Stream object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Save(String,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Save Method : Save(String,Boolean) Method

filename
Path to the file where the LicenseSigningKey should be saved.
includePrivateData
Indicates if the private portion of the key should be included.
Saves the contents of the LicenseSigningKey to a file with the given file name.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal filename As String, _
   ByVal includePrivateData As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim filename As String
Dim includePrivateData As Boolean

instance.Save(filename, includePrivateData)
C#
public void Save(
   string filename,
   bool includePrivateData
)
Managed Extensions for C++
public: void Save(
   string* filename,
   bool includePrivateData
)
C++/CLI
public:
void Save(
   String^ filename,
   bool includePrivateData
)

Parameters

filename
Path to the file where the LicenseSigningKey should be saved.
includePrivateData
Indicates if the private portion of the key should be included.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Save(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Save Method : Save(String) Method

filename
Path to the file where the LicenseSigningKey should be saved.
Saves the contents of the LicenseSigningKey to a file with the given file name.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim filename As String

instance.Save(filename)
C#
public void Save(
   string filename
)
Managed Extensions for C++
public: void Save(
   string* filename
)
C++/CLI
public:
void Save(
   String^ filename
)

Parameters

filename
Path to the file where the LicenseSigningKey should be saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Save(Stream,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Save Method : Save(Stream,Boolean) Method

stream
The Stream object to receive the data.
includePrivateData
Indicates if the private portion of the key should be included.
Saves the contents of the LicenseSigningKey to a Stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream, _
   ByVal includePrivateData As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim stream As Stream
Dim includePrivateData As Boolean

instance.Save(stream, includePrivateData)
C#
public void Save(
   Stream stream,
   bool includePrivateData
)
Managed Extensions for C++
public: void Save(
   Stream* stream,
   bool includePrivateData
)
C++/CLI
public:
void Save(
   Stream^ stream,
   bool includePrivateData
)

Parameters

stream
The Stream object to receive the data.
includePrivateData
Indicates if the private portion of the key should be included.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Save(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Save Method : Save(Stream) Method

stream
The Stream object to receive the data.
Saves the contents of the LicenseSigningKey to a Stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim stream As Stream

instance.Save(stream)
C#
public void Save(
   Stream stream
)
Managed Extensions for C++
public: void Save(
   Stream* stream
)
C++/CLI
public:
void Save(
   Stream^ stream
)

Parameters

stream
The Stream object to receive the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SignData Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : SignData Method

data

Syntax

Visual Basic (Declaration)
Public Function SignData( _
   ByVal data() As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim value() As Byte

value = instance.SignData(data)
C#
public byte[] SignData(
   byte[] data
)
Managed Extensions for C++
public: byte[] SignData(
   byte[] data
)
C++/CLI
public:
array<byte> SignData(
   array<byte> data
)

Parameters

data

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SignLicense Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : SignLicense Method

license
Signs the ExtendedLicense and sets the LicenseKey property

Syntax

Visual Basic (Declaration)
Public Sub SignLicense( _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense

instance.SignLicense(license)
C#
public void SignLicense(
   ExtendedLicense license
)
Managed Extensions for C++
public: void SignLicense(
   ExtendedLicense* license
)
C++/CLI
public:
void SignLicense(
   ExtendedLicense^ license
)

Parameters

license

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SignResponse Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : SignResponse Method

response
The response to sign.
Signs a response so that the originator of the message can be validated.

Syntax

Visual Basic (Declaration)
Public Function SignResponse( _
   ByVal response As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim response As String
Dim value As String

value = instance.SignResponse(response)
C#
public string SignResponse(
   string response
)
Managed Extensions for C++
public: string* SignResponse(
   string* response
)
C++/CLI
public:
String^ SignResponse(
   String^ response
)

Parameters

response
The response to sign.

Return Value

Returns a signature for the response.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : ToXmlString Method

includePrivateData
Indicates if the private data shouls be included.
Gets the LicenseSigningKey as an XML strign.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString( _
   ByVal includePrivateData As Boolean _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim includePrivateData As Boolean
Dim value As String

value = instance.ToXmlString(includePrivateData)
C#
public string ToXmlString(
   bool includePrivateData
)
Managed Extensions for C++
public: string* ToXmlString(
   bool includePrivateData
)
C++/CLI
public:
String^ ToXmlString(
   bool includePrivateData
)

Parameters

includePrivateData
Indicates if the private data shouls be included.

Return Value

Returns an XML string representation of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
UpgradeVersion Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : UpgradeVersion Method

version
The version to upgrade to.
Upgrades the keys to the format used by the specified version.

Syntax

Visual Basic (Declaration)
Public Sub UpgradeVersion( _
   ByVal version As Version _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim version As Version

instance.UpgradeVersion(version)
C#
public void UpgradeVersion(
   Version version
)
Managed Extensions for C++
public: void UpgradeVersion(
   Version* version
)
C++/CLI
public:
void UpgradeVersion(
   Version^ version
)

Parameters

version
The version to upgrade to.

Remarks

The changes should be saved over the existing keys and the public key re-exported after the upgrade.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ValidateLicense Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : ValidateLicense Method

license
The license to validate.
Validates that the contents of the license has not been changed since it was signed.

Syntax

Visual Basic (Declaration)
Public Function ValidateLicense( _
   ByVal license As ExtendedLicense _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim value As Boolean

value = instance.ValidateLicense(license)
C#
public bool ValidateLicense(
   ExtendedLicense license
)
Managed Extensions for C++
public: bool ValidateLicense(
   ExtendedLicense* license
)
C++/CLI
public:
bool ValidateLicense(
   ExtendedLicense^ license
)

Parameters

license
The license to validate.

Return Value

Returns true if the contents of the license have not been changed, otherwise false.

Remarks

You must use the same LicenseSigningKey to validate the license as you did to sign it. You can use either the full public/private key or just the public key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ValidateResponse Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : ValidateResponse Method

response
The original response.
signature
The signature generated from SignResponse.
Validates a response signature.

Syntax

Visual Basic (Declaration)
Public Function ValidateResponse( _
   ByVal response As String, _
   ByVal signature As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim response As String
Dim signature As String
Dim value As Boolean

value = instance.ValidateResponse(response, signature)
C#
public bool ValidateResponse(
   string response,
   string signature
)
Managed Extensions for C++
public: bool ValidateResponse(
   string* response,
   string* signature
)
C++/CLI
public:
bool ValidateResponse(
   String^ response,
   String^ signature
)

Parameters

response
The original response.
signature
The signature generated from SignResponse.

Return Value

Returns true if the signature and response match.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ValidateSerialNumber Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : ValidateSerialNumber Method

Validates that a serial number was signed with the license key and falls within a given range of valid numbers.

Overload List

Overload | Description
ValidateSerialNumber(ExtendedLicense,String) | Validates that a serial number was signed with the license key and falls within a given range of valid numbers.
ValidateSerialNumber(String,String,Int32,Int32,SerialNumberSizes) | Validates that a serial number was signed with the license key and falls within a given range of valid numbers.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ValidateSerialNumber(ExtendedLicense,String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > ValidateSerialNumber Method : ValidateSerialNumber(ExtendedLicense,String) Method

license
The license the seral number is checked against.
serialNumber
The serial number to check.
Validates that a serial number was signed with the license key and falls within a given range of valid numbers.

Syntax

Visual Basic (Declaration)
Overloads Public Function ValidateSerialNumber( _
   ByVal license As ExtendedLicense, _
   ByVal serialNumber As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim serialNumber As String
Dim value As Boolean

value = instance.ValidateSerialNumber(license, serialNumber)
C#
public bool ValidateSerialNumber(
   ExtendedLicense license,
   string serialNumber
)
Managed Extensions for C++
public: bool ValidateSerialNumber(
   ExtendedLicense* license,
   string* serialNumber
)
C++/CLI
public:
bool ValidateSerialNumber(
   ExtendedLicense^ license,
   String^ serialNumber
)

Parameters

license
The license the seral number is checked against.
serialNumber
The serial number to check.

Return Value

Returns true of the serial number is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ValidateSerialNumber(String,String,Int32,Int32,SerialNumberSizes) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > ValidateSerialNumber Method : ValidateSerialNumber(String,String,Int32,Int32,SerialNumberSizes) Method

prefix
The serial number prefix required.
serialNumber
The serial number to check.
minAcceptedSeed
The minimum acceptable seed value.
maxAcceptedSeed
The maximim acceptable seed value.
acceptedSizes
The accepted serial number sizes.
Validates that a serial number was signed with the license key and falls within a given range of valid numbers.

Syntax

Visual Basic (Declaration)
Overloads Public Function ValidateSerialNumber( _
   ByVal prefix As String, _
   ByVal serialNumber As String, _
   ByVal minAcceptedSeed As Integer, _
   ByVal maxAcceptedSeed As Integer, _
   ByVal acceptedSizes As SerialNumberSizes _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim prefix As String
Dim serialNumber As String
Dim minAcceptedSeed As Integer
Dim maxAcceptedSeed As Integer
Dim acceptedSizes As SerialNumberSizes
Dim value As Boolean

value = instance.ValidateSerialNumber(prefix, serialNumber, minAcceptedSeed, maxAcceptedSeed, acceptedSizes)
C#
public bool ValidateSerialNumber(
   string prefix,
   string serialNumber,
   int minAcceptedSeed,
   int maxAcceptedSeed,
   SerialNumberSizes acceptedSizes
)
Managed Extensions for C++
public: bool ValidateSerialNumber(
   string* prefix,
   string* serialNumber,
   int minAcceptedSeed,
   int maxAcceptedSeed,
   SerialNumberSizes acceptedSizes
)
C++/CLI
public:
bool ValidateSerialNumber(
   String^ prefix,
   String^ serialNumber,
   int minAcceptedSeed,
   int maxAcceptedSeed,
   SerialNumberSizes acceptedSizes
)

Parameters

prefix
The serial number prefix required.
serialNumber
The serial number to check.
minAcceptedSeed
The minimum acceptable seed value.
maxAcceptedSeed
The maximim acceptable seed value.
acceptedSizes
The accepted serial number sizes.

Return Value

Returns true of the serial number is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
VerifyData Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : VerifyData Method

data
signature

Syntax

Visual Basic (Declaration)
Public Function VerifyData( _
   ByVal data() As Byte, _
   ByVal signature() As Byte _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim signature() As Byte
Dim value As Boolean

value = instance.VerifyData(data, signature)
C#
public bool VerifyData(
   byte[] data,
   byte[] signature
)
Managed Extensions for C++
public: bool VerifyData(
   byte[] data,
   byte[] signature
)
C++/CLI
public:
bool VerifyData(
   array<byte> data,
   array<byte> signature
)

Parameters

data
signature

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Web Send comments on this topic.
LicenseSigningKey Class Properties
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

For a list of all members of this type, see LicenseSigningKey members.

Public Properties

 | Name | Description
Public Property | IsGlobalKey | Gets a value that indicates if the keys are the global keys used during the trial.
Public Property | Location | Gets the location where the keys were loaded from.
Public Property | Version | Gets or sets the version of the signing key.
Top

See Also

Reference

LicenseSigningKey Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IsGlobalKey Property
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : IsGlobalKey Property

Gets a value that indicates if the keys are the global keys used during the trial.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsGlobalKey As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim value As Boolean

value = instance.IsGlobalKey
C#
public bool IsGlobalKey {get;}
Managed Extensions for C++
public: __property bool get_IsGlobalKey();
C++/CLI
public:
property bool IsGlobalKey {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Location Property
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Location Property

Gets the location where the keys were loaded from.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim value As String

value = instance.Location
C#
public string Location {get;}
Managed Extensions for C++
public: __property string* get_Location();
C++/CLI
public:
property String^ Location {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Version Property
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Version Property

Gets or sets the version of the signing key.

Syntax

Visual Basic (Declaration)
Public Property Version As Version
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim value As Version

instance.Version = value

value = instance.Version
C#
public Version Version {get; set;}
Managed Extensions for C++
public: __property Version* get_Version();
public: __property void set_Version(
   Version* value
);
C++/CLI
public:
property Version^ Version {
   Version^ get();
   void set (Version^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.Web Send comments on this topic.
LicenseSigningKey Class Fields
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

For a list of all members of this type, see LicenseSigningKey members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CurrentVersion | The current version of the LicenseSigningKey class.
Top

See Also

Reference

LicenseSigningKey Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
CurrentVersion Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : CurrentVersion Field

The current version of the LicenseSigningKey class.

Syntax

Visual Basic (Declaration)
Public Shared CurrentVersion As Version
Visual Basic (Usage) Copy Code
Dim value As Version

value = LicenseSigningKey.CurrentVersion

LicenseSigningKey.CurrentVersion = value
C#
public static Version CurrentVersion
Managed Extensions for C++
public: static Version* CurrentVersion
C++/CLI
public:
static Version^ CurrentVersion

Remarks

Later versions may introduce a new signing/file scheme. To maintain backwards compatability the keys are versioned.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LicenseValuesCollection Class
See Also Members
[image]
Xheo.Licensing Namespace : LicenseValuesCollection Class

Maintains a collection of name value pairs. The collection can be serialized and marked as read only.

Syntax

Visual Basic (Declaration)
Private Class LicenseValuesCollection
   Inherits NameValueCollection
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
C#
private class LicenseValuesCollection : NameValueCollection
Managed Extensions for C++
private __gc class LicenseValuesCollection : public NameValueCollection
C++/CLI
private ref class LicenseValuesCollection : public NameValueCollection

Inheritance Hierarchy

System.Object
System.Collections.Specialized.NameObjectCollectionBase
System.Collections.Specialized.NameValueCollection
Xheo.Licensing.LicenseValuesCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
LicenseValuesCollection Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : LicenseValuesCollection Class

The following tables list the members exposed by LicenseValuesCollection.

Public Constructors

 | Name | Description
Public Constructor | LicenseValuesCollection Constructor | Initializes a new instance of the LicenseValuesCollection class.
Top

Public Properties

 | Name | Description
Public Property | AllKeys | Gets all the keys in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Property | Count | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Property | Item | Overloaded. Gets or sets the entry with the specified key in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Property | Keys | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Included for serialization compatability, do not use.
Public Method | Clear | Invalidates the cached arrays and removes all entries from the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | CopyTo | Copies the entire NameValueCollection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | FromXmlString | Loads the values from an XML string.
Public Method | Get | Overloaded. Gets the values associated with the specified key from the NameValueCollection combined into one comma-separated list. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | GetEnumerator | Returns an enumerator that iterates through the NameObjectCollectionBase. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetKey | Gets the key at the specified index of the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetValues | Overloaded. Gets the values associated with the specified key from the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | HasKeys | Gets a value indicating whether the NameValueCollection contains keys that are not null. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | LoadFromXml | Loades the contents of the collection from the XmlNode.
Public Method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | Remove | Removes the entries with the specified key from the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | SaveToXml | Saves the contents of the collection to the parent XmlNode.
Public Method | Set | Sets the value of an entry in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | ToXmlString | Converts the collection to an XML string representation.
Top

See Also

Reference

LicenseValuesCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LicenseValuesCollection Constructor
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : LicenseValuesCollection Constructor

Initializes a new instance of the LicenseValuesCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection()
C#
public LicenseValuesCollection()
Managed Extensions for C++
public: LicenseValuesCollection();
C++/CLI
public:
LicenseValuesCollection();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
LicenseValuesCollection Class Methods
See Also
[image]
Xheo.Licensing Namespace : LicenseValuesCollection Class

For a list of all members of this type, see LicenseValuesCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Included for serialization compatability, do not use.
Public Method | Clear | Invalidates the cached arrays and removes all entries from the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | CopyTo | Copies the entire NameValueCollection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | FromXmlString | Loads the values from an XML string.
Public Method | Get | Overloaded. Gets the values associated with the specified key from the NameValueCollection combined into one comma-separated list. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | GetEnumerator | Returns an enumerator that iterates through the NameObjectCollectionBase. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetKey | Gets the key at the specified index of the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetValues | Overloaded. Gets the values associated with the specified key from the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | HasKeys | Gets a value indicating whether the NameValueCollection contains keys that are not null. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | LoadFromXml | Loades the contents of the collection from the XmlNode.
Public Method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | Remove | Removes the entries with the specified key from the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | SaveToXml | Saves the contents of the collection to the parent XmlNode.
Public Method | Set | Sets the value of an entry in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | ToXmlString | Converts the collection to an XML string representation.
Top

See Also

Reference

LicenseValuesCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Add Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : Add Method

Included for serialization compatability, do not use.

Overload List

Overload | Description
Add(String) | Included for serialization compatability, do not use.
Add(NameValueCollection) | Copies the entries in the specified NameValueCollection to the current NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Add(String,String) | Adds an entry with the specified name and value to the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Add(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class > Add Method : Add(String) Method

value
Included for serialization compatability, do not use.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim value As String

instance.Add(value)
C#
public void Add(
   string value
)
Managed Extensions for C++
public: void Add(
   string* value
)
C++/CLI
public:
void Add(
   String^ value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : FromXmlString Method

xml
The XML document string containing the values collection.
Loads the values from an XML string.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
The XML document string containing the values collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : LoadFromXml Method

parentNode
The root XmlNode containing the collection.
Loades the contents of the collection from the XmlNode.

Syntax

Visual Basic (Declaration)
Public Sub LoadFromXml( _
   ByVal parentNode As XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim parentNode As XmlNode

instance.LoadFromXml(parentNode)
C#
public void LoadFromXml(
   XmlNode parentNode
)
Managed Extensions for C++
public: void LoadFromXml(
   XmlNode parentNode
)
C++/CLI
public:
void LoadFromXml(
   XmlNode parentNode
)

Parameters

parentNode
The root XmlNode containing the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : SaveToXml Method

parentNode
The XmlNode to save the collection to.
Saves the contents of the collection to the parent XmlNode.

Syntax

Visual Basic (Declaration)
Public Function SaveToXml( _
   ByVal parentNode As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim parentNode As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parentNode)
C#
public XmlNode SaveToXml(
   XmlNode parentNode
)
Managed Extensions for C++
public: XmlNode SaveToXml(
   XmlNode parentNode
)
C++/CLI
public:
XmlNode SaveToXml(
   XmlNode parentNode
)

Parameters

parentNode
The XmlNode to save the collection to.

Return Value

Returns the root node of the saved collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : ToXmlString Method

Converts the collection to an XML string representation.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim value As String

value = instance.ToXmlString()
C#
public string ToXmlString()
Managed Extensions for C++
public: string* ToXmlString();
C++/CLI
public:
String^ ToXmlString();

Return Value

Returns the collection as an XML document string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Limit Class
See Also Members
[image]
Xheo.Licensing Namespace : Limit Class

Base class for all license limitations.

Object Model

Syntax

Visual Basic (Declaration)
Private MustInherit Class Limit
   Inherits MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As Limit
C#
private abstract class Limit : MarshalByRefObject
Managed Extensions for C++
private __gc abstract class Limit : public MarshalByRefObject
C++/CLI
private ref class Limit abstract : public MarshalByRefObject

Remarks

Limits are used by the XHEO|Licensing framework to restrict a Component, Class or Control to a specific set of runtime or designtime conditions. The library contains over 15 built in limits that you can use to control the use of your protected Type.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Xheo.Licensing.Limit
Xheo.Licensing.ContainerLimit
Xheo.Licensing.ContainerLimit
Xheo.Licensing.ContainerLimit
Xheo.Licensing.ContainerLimit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
Limit Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : Limit Class

The following tables list the members exposed by Limit.

Public Properties

 | Name | Description
Public Property | Description | Gets the description of the limit.
Public Property | IsGui | Gets a value that indicates if this Limit uses a GUI to interact with the user.
Public Property | IsRemote | Gets a value that indicates if this Limit uses remote processes (such as WebServices) for enforcement.
Public Property | IsTimeSensitive | Gets a value that indicates if the limit is time sensitive and the clock should be protected.
Public Property | License | Gets or sets a reference to the ExtendedLicense that contains this Limit.
Public Property | Name | Gets the display name of the limit.
Public Property | QualifiedTypeName | Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type.
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases any managed or unmangaged resources used by the limit.
static (Shared in Visual Basic) | GetBitmapResource | Gets an Image for the requested resource. Resources can be defined as assembly resources or as remote resources. If the name is prefixed with http then it is assumed to be a remote resource and a WebRequest is made to retrieve the bitmap, otherwise it is assumed to be embedded in the assembly.
Public Method | GetDetailsDescription | Gets a description of the details of the limit.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | GetLimitFromName | Gets a Limit object based on the given name.
static (Shared in Visual Basic) | GetPrivateRegistryKey | Gets a private registry key where values for the license can be stored for the given type.
Public Method | Granted | Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | LoadFromXml | Loads the contents of a Limit from an XmlNode.
static (Shared in Visual Basic) | MaskValue | Performs a simple value obfuscation to make editing client side values more difficult. This is by no means secure.
static (Shared in Visual Basic) | OpenOrCreateRegistryKey | Opens or creates a registry key.
static (Shared in Visual Basic) | ParseIPAddress | Parses an IPAddress to it's actual long value.
Public Method | Peek | Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user.
Public Method | SaveToXml | Saves the contents of the Limit as an XmlNode.
static (Shared in Visual Basic) | SelectCulture | Selects the given culture for the current thread, and returns the previous culture.
static (Shared in Visual Basic) | SelectWebCulture | Selects the culture of the current web request into the current thread, and returns the previous culture.
static (Shared in Visual Basic) | UnmaskValue | Reverses the simple value obfuscation performed by MaskValue.
Public Method | Validate | Validates that the license being granted is within the limits enforced by this object.
static (Shared in Visual Basic) | ValidateDomainName | Validates the format of a domain name.
static (Shared in Visual Basic) | ValidateEmail | Validates if the email is correctly formatted.
static (Shared in Visual Basic) | ValidateIPAddress | Validates the format of an IP address.
static (Shared in Visual Basic) | ValidateUrl | Validates the url is correctly formatted.
Top

See Also

Reference

Limit Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
Limit Class Methods
See Also
[image]
Xheo.Licensing Namespace : Limit Class

For a list of all members of this type, see Limit members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases any managed or unmangaged resources used by the limit.
static (Shared in Visual Basic) | GetBitmapResource | Gets an Image for the requested resource. Resources can be defined as assembly resources or as remote resources. If the name is prefixed with http then it is assumed to be a remote resource and a WebRequest is made to retrieve the bitmap, otherwise it is assumed to be embedded in the assembly.
Public Method | GetDetailsDescription | Gets a description of the details of the limit.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | GetLimitFromName | Gets a Limit object based on the given name.
static (Shared in Visual Basic) | GetPrivateRegistryKey | Gets a private registry key where values for the license can be stored for the given type.
Public Method | Granted | Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | LoadFromXml | Loads the contents of a Limit from an XmlNode.
static (Shared in Visual Basic) | MaskValue | Performs a simple value obfuscation to make editing client side values more difficult. This is by no means secure.
static (Shared in Visual Basic) | OpenOrCreateRegistryKey | Opens or creates a registry key.
static (Shared in Visual Basic) | ParseIPAddress | Parses an IPAddress to it's actual long value.
Public Method | Peek | Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user.
Public Method | SaveToXml | Saves the contents of the Limit as an XmlNode.
static (Shared in Visual Basic) | SelectCulture | Selects the given culture for the current thread, and returns the previous culture.
static (Shared in Visual Basic) | SelectWebCulture | Selects the culture of the current web request into the current thread, and returns the previous culture.
static (Shared in Visual Basic) | UnmaskValue | Reverses the simple value obfuscation performed by MaskValue.
Public Method | Validate | Validates that the license being granted is within the limits enforced by this object.
static (Shared in Visual Basic) | ValidateDomainName | Validates the format of a domain name.
static (Shared in Visual Basic) | ValidateEmail | Validates if the email is correctly formatted.
static (Shared in Visual Basic) | ValidateIPAddress | Validates the format of an IP address.
static (Shared in Visual Basic) | ValidateUrl | Validates the url is correctly formatted.
Top

See Also

Reference

Limit Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Dispose Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Dispose Method

Releases any managed or unmangaged resources used by the limit.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As Limit

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetBitmapResource Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : GetBitmapResource Method

bitmapResource
Name of the resource to retrieve, prefix with http to get a remote resource.
limit
The limit requesting the resource.
parameters
Collection of additional parameters to append to the URL for remote images. Parameters should be in the format "key=value".
Gets an Image for the requested resource. Resources can be defined as assembly resources or as remote resources. If the name is prefixed with http then it is assumed to be a remote resource and a WebRequest is made to retrieve the bitmap, otherwise it is assumed to be embedded in the assembly.

Syntax

Visual Basic (Declaration)
Public Shared Function GetBitmapResource( _
   ByVal bitmapResource As String, _
   ByVal limit As Limit, _
   ByVal ParamArray parameters() As String _
) As Bitmap
Visual Basic (Usage) Copy Code
Dim bitmapResource As String
Dim limit As Limit
Dim parameters() As String
Dim value As Bitmap

value = Limit.GetBitmapResource(bitmapResource, limit, parameters)
C#
public static Bitmap GetBitmapResource(
   string bitmapResource,
   Limit limit,
   params string[] parameters
)
Managed Extensions for C++
public: static Bitmap GetBitmapResource(
   string* bitmapResource,
   Limit* limit,
   params string*[] parameters
)
C++/CLI
public:
static Bitmap GetBitmapResource(
   String^ bitmapResource,
   Limit^ limit,
   ... array<String^> parameters
)

Parameters

bitmapResource
Name of the resource to retrieve, prefix with http to get a remote resource.
limit
The limit requesting the resource.
parameters
Collection of additional parameters to append to the URL for remote images. Parameters should be in the format "key=value".

Return Value

Returns the resource if found, otherwise null.

Remarks

For remote resources the serial number, expiration date, and optional parameters of the License will be appended to the request QueryString. You can use this to provide alternate images based on the conditions of the license.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetDetailsDescription Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : GetDetailsDescription Method

Gets a description of the details of the limit.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetDetailsDescription() As String
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As String

value = instance.GetDetailsDescription()
C#
public virtual string GetDetailsDescription()
Managed Extensions for C++
public: virtual string* GetDetailsDescription();
C++/CLI
public:
virtual String^ GetDetailsDescription();

Return Value

Returns the description.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetLimitFromName Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : GetLimitFromName Method

name
The name of the limit type to retrieve.
Gets a Limit object based on the given name.

Syntax

Visual Basic (Declaration)
Public Shared Function GetLimitFromName( _
   ByVal name As String _
) As Limit
Visual Basic (Usage) Copy Code
Dim name As String
Dim value As Limit

value = Limit.GetLimitFromName(name)
C#
public static Limit GetLimitFromName(
   string name
)
Managed Extensions for C++
public: static Limit* GetLimitFromName(
   string* name
)
C++/CLI
public:
static Limit^ GetLimitFromName(
   String^ name
)

Parameters

name
The name of the limit type to retrieve.

Return Value

Returns a new Limit object of the given type if available, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetPrivateRegistryKey Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : GetPrivateRegistryKey Method

key
A unique key to identify this registry section.
mustExist
Indicates if the key must already exist.
created
Accepts a value that indicates if the key was created.
Gets a private registry key where values for the license can be stored for the given type.

Syntax

Visual Basic (Declaration)
Public Shared Function GetPrivateRegistryKey( _
   ByVal key As String, _
   ByVal mustExist As Boolean, _
   ByRef created As Boolean _
) As RegistryKey
Visual Basic (Usage) Copy Code
Dim key As String
Dim mustExist As Boolean
Dim created As Boolean
Dim value As RegistryKey

value = Limit.GetPrivateRegistryKey(key, mustExist, created)
C#
public static RegistryKey GetPrivateRegistryKey(
   string key,
   bool mustExist,
   out bool created
)
Managed Extensions for C++
public: static RegistryKey* GetPrivateRegistryKey(
   string* key,
   bool mustExist,
   [PARAMFLAG::Out] bool created
)
C++/CLI
public:
static RegistryKey^ GetPrivateRegistryKey(
   String^ key,
   bool mustExist,
   [PARAMFLAG::Out] bool created
)

Parameters

key
A unique key to identify this registry section.
mustExist
Indicates if the key must already exist.
created
Accepts a value that indicates if the key was created.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Granted Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Granted Method

context
The LicenseContext used to determine the environment and settings of the licensing.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Granted( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim context As LicenseContext
Dim type As Type
Dim instance As Object

instance.Granted(context, type, instance)
C#
public virtual void Granted(
   LicenseContext context,
   Type type,
   object instance
)
Managed Extensions for C++
public: virtual void Granted(
   LicenseContext context,
   Type* type,
   Object* instance
)
C++/CLI
public:
virtual void Granted(
   LicenseContext context,
   Type^ type,
   Object^ instance
)

Parameters

context
The LicenseContext used to determine the environment and settings of the licensing.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.

Remarks

Checks in this method should be very fast because they are called every time a licensed object is created. The default implementation does nothing.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : LoadFromXml Method

node
The XmlNode to load from.
Loads the contents of a Limit from an XmlNode.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride Function LoadFromXml( _
   ByVal node As XmlNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim node As XmlNode
Dim value As Boolean

value = instance.LoadFromXml(node)
C#
public virtual abstract bool LoadFromXml(
   XmlNode node
)
Managed Extensions for C++
public: virtual abstract bool LoadFromXml(
   XmlNode node
)
C++/CLI
public:
virtual abstract bool LoadFromXml(
   XmlNode node
)

Parameters

node
The XmlNode to load from.

Return Value

Returns true if the load was successful, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MaskValue Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : MaskValue Method

source
The original value.
Performs a simple value obfuscation to make editing client side values more difficult. This is by no means secure.

Syntax

Visual Basic (Declaration)
Public Shared Function MaskValue( _
   ByVal source As String _
) As String
Visual Basic (Usage) Copy Code
Dim source As String
Dim value As String

value = Limit.MaskValue(source)
C#
public static string MaskValue(
   string source
)
Managed Extensions for C++
public: static string* MaskValue(
   string* source
)
C++/CLI
public:
static String^ MaskValue(
   String^ source
)

Parameters

source
The original value.

Return Value

Returns the masked version of the value. Call UnmaskValue to obtain the original value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
OpenOrCreateRegistryKey Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : OpenOrCreateRegistryKey Method

key
The parent key to open from.
subkey
The path of the sub key to open. Sub key should be separated by \ characters.
Opens or creates a registry key.

Syntax

Visual Basic (Declaration)
Public Shared Function OpenOrCreateRegistryKey( _
   ByVal key As RegistryKey, _
   ByVal subkey As String _
) As RegistryKey
Visual Basic (Usage) Copy Code
Dim key As RegistryKey
Dim subkey As String
Dim value As RegistryKey

value = Limit.OpenOrCreateRegistryKey(key, subkey)
C#
public static RegistryKey OpenOrCreateRegistryKey(
   RegistryKey key,
   string subkey
)
Managed Extensions for C++
public: static RegistryKey* OpenOrCreateRegistryKey(
   RegistryKey* key,
   string* subkey
)
C++/CLI
public:
static RegistryKey^ OpenOrCreateRegistryKey(
   RegistryKey^ key,
   String^ subkey
)

Parameters

key
The parent key to open from.
subkey
The path of the sub key to open. Sub key should be separated by \ characters.

Return Value

Returns the opened or created registry key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ParseIPAddress Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ParseIPAddress Method

address
IPAddress to parse.
Parses an IPAddress to it's actual long value.

Syntax

Visual Basic (Declaration)
Public Shared Function ParseIPAddress( _
   ByVal address As IPAddress _
) As Long
Visual Basic (Usage) Copy Code
Dim address As IPAddress
Dim value As Long

value = Limit.ParseIPAddress(address)
C#
public static long ParseIPAddress(
   IPAddress address
)
Managed Extensions for C++
public: static long ParseIPAddress(
   IPAddress address
)
C++/CLI
public:
static long ParseIPAddress(
   IPAddress address
)

Parameters

address
IPAddress to parse.

Return Value

Returns the actual address of the IPAddress.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Peek Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Peek Method

context
The LicenseContext used to determine the environment and settings of the licensing.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user.

Syntax

Visual Basic (Declaration)
Public Overridable Function Peek( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object _
) As PeekResult
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim context As LicenseContext
Dim type As Type
Dim instance As Object
Dim value As PeekResult

value = instance.Peek(context, type, instance)
C#
public virtual PeekResult Peek(
   LicenseContext context,
   Type type,
   object instance
)
Managed Extensions for C++
public: virtual PeekResult Peek(
   LicenseContext context,
   Type* type,
   Object* instance
)
C++/CLI
public:
virtual PeekResult Peek(
   LicenseContext context,
   Type^ type,
   Object^ instance
)

Parameters

context
The LicenseContext used to determine the environment and settings of the licensing.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : SaveToXml Method

parent
The parent XmlNode to add child nodes to.
Saves the contents of the Limit as an XmlNode.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride Function SaveToXml( _
   ByVal parent As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim parent As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parent)
C#
public virtual abstract XmlNode SaveToXml(
   XmlNode parent
)
Managed Extensions for C++
public: virtual abstract XmlNode SaveToXml(
   XmlNode parent
)
C++/CLI
public:
virtual abstract XmlNode SaveToXml(
   XmlNode parent
)

Parameters

parent
The parent XmlNode to add child nodes to.

Return Value

Returns the saved XML node.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SelectCulture Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : SelectCulture Method

culture
The culture to select.
Selects the given culture for the current thread, and returns the previous culture.

Syntax

Visual Basic (Declaration)
Public Shared Function SelectCulture( _
   ByVal culture As CultureInfo _
) As CultureInfo
Visual Basic (Usage) Copy Code
Dim culture As CultureInfo
Dim value As CultureInfo

value = Limit.SelectCulture(culture)
C#
public static CultureInfo SelectCulture(
   CultureInfo culture
)
Managed Extensions for C++
public: static CultureInfo* SelectCulture(
   CultureInfo* culture
)
C++/CLI
public:
static CultureInfo^ SelectCulture(
   CultureInfo^ culture
)

Parameters

culture
The culture to select.

Return Value

Returns the previous culture.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SelectWebCulture Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : SelectWebCulture Method

Selects the culture of the current web request into the current thread, and returns the previous culture.

Syntax

Visual Basic (Declaration)
Public Shared Function SelectWebCulture() As CultureInfo
Visual Basic (Usage) Copy Code
Dim value As CultureInfo

value = Limit.SelectWebCulture()
C#
public static CultureInfo SelectWebCulture()
Managed Extensions for C++
public: static CultureInfo* SelectWebCulture();
C++/CLI
public:
static CultureInfo^ SelectWebCulture();

Return Value

Returns the previous culture.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
UnmaskValue Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : UnmaskValue Method

source
The original value.
Reverses the simple value obfuscation performed by MaskValue.

Syntax

Visual Basic (Declaration)
Public Shared Function UnmaskValue( _
   ByVal source As String _
) As String
Visual Basic (Usage) Copy Code
Dim source As String
Dim value As String

value = Limit.UnmaskValue(source)
C#
public static string UnmaskValue(
   string source
)
Managed Extensions for C++
public: static string* UnmaskValue(
   string* source
)
C++/CLI
public:
static String^ UnmaskValue(
   String^ source
)

Parameters

source
The original value.

Return Value

Returns the masked version of the value. Call UnmaskValue to obtain the original value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Validate Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Validate Method

context
The LicenseContext passed to GetLicense.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
Validates that the license being granted is within the limits enforced by this object.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride Function Validate( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim context As LicenseContext
Dim type As Type
Dim instance As Object
Dim value As Boolean

value = instance.Validate(context, type, instance)
C#
public virtual abstract bool Validate(
   LicenseContext context,
   Type type,
   object instance
)
Managed Extensions for C++
public: virtual abstract bool Validate(
   LicenseContext context,
   Type* type,
   Object* instance
)
C++/CLI
public:
virtual abstract bool Validate(
   LicenseContext context,
   Type^ type,
   Object^ instance
)

Parameters

context
The LicenseContext passed to GetLicense.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.

Return Value

Returns true if the limits are valid, otherwise false.

Remarks

If validation fails, limits should set their parent License's InvalidReason to a string explaining why it could not be validated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ValidateDomainName Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ValidateDomainName Method

domainName
The domain name to validate.
Validates the format of a domain name.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateDomainName( _
   ByVal domainName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim domainName As String
Dim value As Boolean

value = Limit.ValidateDomainName(domainName)
C#
public static bool ValidateDomainName(
   string domainName
)
Managed Extensions for C++
public: static bool ValidateDomainName(
   string* domainName
)
C++/CLI
public:
static bool ValidateDomainName(
   String^ domainName
)

Parameters

domainName
The domain name to validate.

Return Value

Returns true if the format of the domain name is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ValidateEmail Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ValidateEmail Method

email
The email address to validate.
Validates if the email is correctly formatted.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateEmail( _
   ByVal email As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim email As String
Dim value As Boolean

value = Limit.ValidateEmail(email)
C#
public static bool ValidateEmail(
   string email
)
Managed Extensions for C++
public: static bool ValidateEmail(
   string* email
)
C++/CLI
public:
static bool ValidateEmail(
   String^ email
)

Parameters

email
The email address to validate.

Return Value

Returns true if the email is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ValidateIPAddress Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ValidateIPAddress Method

address
The IP Address to validate.
Validates the format of an IP address.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateIPAddress( _
   ByVal address As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim address As String
Dim value As Boolean

value = Limit.ValidateIPAddress(address)
C#
public static bool ValidateIPAddress(
   string address
)
Managed Extensions for C++
public: static bool ValidateIPAddress(
   string* address
)
C++/CLI
public:
static bool ValidateIPAddress(
   String^ address
)

Parameters

address
The IP Address to validate.

Return Value

Returns true if the format of the address is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ValidateUrl Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ValidateUrl Method

url
The url to validate.
fullyQualified
Indicates if the url must be fully qualified. Containing a host and optional protocol.
Validates the url is correctly formatted.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateUrl( _
   ByVal url As String, _
   ByVal fullyQualified As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim url As String
Dim fullyQualified As Boolean
Dim value As Boolean

value = Limit.ValidateUrl(url, fullyQualified)
C#
public static bool ValidateUrl(
   string url,
   bool fullyQualified
)
Managed Extensions for C++
public: static bool ValidateUrl(
   string* url,
   bool fullyQualified
)
C++/CLI
public:
static bool ValidateUrl(
   String^ url,
   bool fullyQualified
)

Parameters

url
The url to validate.
fullyQualified
Indicates if the url must be fully qualified. Containing a host and optional protocol.

Return Value

Returns true if the url is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Web Send comments on this topic.
Limit Class Properties
See Also
[image]
Xheo.Licensing Namespace : Limit Class

For a list of all members of this type, see Limit members.

Public Properties

 | Name | Description
Public Property | Description | Gets the description of the limit.
Public Property | IsGui | Gets a value that indicates if this Limit uses a GUI to interact with the user.
Public Property | IsRemote | Gets a value that indicates if this Limit uses remote processes (such as WebServices) for enforcement.
Public Property | IsTimeSensitive | Gets a value that indicates if the limit is time sensitive and the clock should be protected.
Public Property | License | Gets or sets a reference to the ExtendedLicense that contains this Limit.
Public Property | Name | Gets the display name of the limit.
Public Property | QualifiedTypeName | Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type.
Top

See Also

Reference

Limit Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Description Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Description Property

Gets the description of the limit.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride ReadOnly Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As String

value = instance.Description
C#
public virtual abstract string Description {get;}
Managed Extensions for C++
public: __property virtual abstract string* get_Description();
C++/CLI
public:
virtual abstract property String^ Description {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IsGui Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : IsGui Property

Gets a value that indicates if this Limit uses a GUI to interact with the user.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsGui As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As Boolean

value = instance.IsGui
C#
public virtual bool IsGui {get;}
Managed Extensions for C++
public: __property virtual bool get_IsGui();
C++/CLI
public:
virtual property bool IsGui {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IsRemote Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : IsRemote Property

Gets a value that indicates if this Limit uses remote processes (such as WebServices) for enforcement.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsRemote As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As Boolean

value = instance.IsRemote
C#
public virtual bool IsRemote {get;}
Managed Extensions for C++
public: __property virtual bool get_IsRemote();
C++/CLI
public:
virtual property bool IsRemote {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IsTimeSensitive Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : IsTimeSensitive Property

Gets a value that indicates if the limit is time sensitive and the clock should be protected.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsTimeSensitive As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As Boolean

value = instance.IsTimeSensitive
C#
public virtual bool IsTimeSensitive {get;}
Managed Extensions for C++
public: __property virtual bool get_IsTimeSensitive();
C++/CLI
public:
virtual property bool IsTimeSensitive {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
License Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : License Property

Gets or sets a reference to the ExtendedLicense that contains this Limit.

Syntax

Visual Basic (Declaration)
Public Property License As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As ExtendedLicense

instance.License = value

value = instance.License
C#
public ExtendedLicense License {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_License();
public: __property void set_License(
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ License {
   ExtendedLicense^ get();
   void set (ExtendedLicense^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Name Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Name Property

Gets the display name of the limit.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As String

value = instance.Name
C#
public virtual abstract string Name {get;}
Managed Extensions for C++
public: __property virtual abstract string* get_Name();
C++/CLI
public:
virtual abstract property String^ Name {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
QualifiedTypeName Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : QualifiedTypeName Property

Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property QualifiedTypeName As String
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As String

value = instance.QualifiedTypeName
C#
public virtual string QualifiedTypeName {get;}
Managed Extensions for C++
public: __property virtual string* get_QualifiedTypeName();
C++/CLI
public:
virtual property String^ QualifiedTypeName {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LimitCollection Class
See Also Members
[image]
Xheo.Licensing Namespace : LimitCollection Class

Services as a collection of limits.

Object Model

Syntax

Visual Basic (Declaration)
Private Class LimitCollection
   Inherits TransientReadOnlyCollection
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
C#
private class LimitCollection : TransientReadOnlyCollection
Managed Extensions for C++
private __gc class LimitCollection : public TransientReadOnlyCollection
C++/CLI
private ref class LimitCollection : public TransientReadOnlyCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Xheo.Licensing.TransientReadOnlyCollection
Xheo.Licensing.LimitCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
LimitCollection Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : LimitCollection Class

The following tables list the members exposed by LimitCollection.

Public Constructors

 | Name | Description
Public Constructor | LimitCollection Constructor | Overloaded. Initializes a new instance of the LimitCollection class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating if the collection is read only. (Inherited from TransientReadOnlyCollection)
Public Property | Item | Gets or sets a limit at the given index.
Public Property | License | Gets or sets a reference to the containing license.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a new limit to the collection.
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines if the collection contains the given Limit.
Public Method | CopyTo | Copies the collection to an array.
Public Method | FromXmlString | Loads the contents of the limit collection from an XML string.
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetPrioritizedOrder | Gets the limits in order of priority.
Public Method | Granted | Called every time the limit is granted.
Public Method | IndexOf | Gets the index of the given limit.
Public Method | Insert | Inserts the limit at the given index.
Public Method | LoadFromXml | Loads the contents of a LimitCollection from an XmlNode.
Public Method | Remove | Removes the given index from the list.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | SaveToXml | Saves the contents of the LimitCollection to the given XmlNode.
Public Method | SetReadOnly | Sets the collection to a read only state. This cannot be reversed. (Inherited from TransientReadOnlyCollection)
Public Method | ToXmlString | Saves the contents of the limit collection to an XML string.
Public Method | Validate | Ensures that all the Limits in the collection are valid for the given type and context.
Top

See Also

Reference

LimitCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LimitCollection Constructor
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : LimitCollection Constructor

Initializes a new instance of the LimitCollection class.

Overload List

Overload | Description
LimitCollection Constructor() | Included for COM compliance, do not use.
LimitCollection Constructor(ExtendedLicense) | Initializes a new instance of the LimitCollection class.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LimitCollection Constructor()
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class > LimitCollection Constructor : LimitCollection Constructor()

Included for COM compliance, do not use.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection()
C#
public LimitCollection()
Managed Extensions for C++
public: LimitCollection();
C++/CLI
public:
LimitCollection();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LimitCollection Constructor(ExtendedLicense)
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class > LimitCollection Constructor : LimitCollection Constructor(ExtendedLicense)

license
Reference to the containing ExtendedLicense.
Initializes a new instance of the LimitCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim license As ExtendedLicense

Dim instance As LimitCollection(license)
C#
public LimitCollection(
   ExtendedLicense license
)
Managed Extensions for C++
public: LimitCollection(
   ExtendedLicense* license
)
C++/CLI
public:
LimitCollection(
   ExtendedLicense^ license
)

Parameters

license
Reference to the containing ExtendedLicense.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
LimitCollection Class Methods
See Also
[image]
Xheo.Licensing Namespace : LimitCollection Class

For a list of all members of this type, see LimitCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a new limit to the collection.
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines if the collection contains the given Limit.
Public Method | CopyTo | Copies the collection to an array.
Public Method | FromXmlString | Loads the contents of the limit collection from an XML string.
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetPrioritizedOrder | Gets the limits in order of priority.
Public Method | Granted | Called every time the limit is granted.
Public Method | IndexOf | Gets the index of the given limit.
Public Method | Insert | Inserts the limit at the given index.
Public Method | LoadFromXml | Loads the contents of a LimitCollection from an XmlNode.
Public Method | Remove | Removes the given index from the list.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | SaveToXml | Saves the contents of the LimitCollection to the given XmlNode.
Public Method | SetReadOnly | Sets the collection to a read only state. This cannot be reversed. (Inherited from TransientReadOnlyCollection)
Public Method | ToXmlString | Saves the contents of the limit collection to an XML string.
Public Method | Validate | Ensures that all the Limits in the collection are valid for the given type and context.
Top

See Also

Reference

LimitCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Add Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Add Method

limit
The limit to add.
Adds a new limit to the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal limit As Limit _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim limit As Limit

instance.Add(limit)
C#
public void Add(
   Limit limit
)
Managed Extensions for C++
public: void Add(
   Limit* limit
)
C++/CLI
public:
void Add(
   Limit^ limit
)

Parameters

limit
The limit to add.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Contains Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Contains Method

limit
The Limit to look for.
Determines if the collection contains the given Limit.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal limit As Limit _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim limit As Limit
Dim value As Boolean

value = instance.Contains(limit)
C#
public bool Contains(
   Limit limit
)
Managed Extensions for C++
public: bool Contains(
   Limit* limit
)
C++/CLI
public:
bool Contains(
   Limit^ limit
)

Parameters

limit
The Limit to look for.

Return Value

Returns true if the Limit is found, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
CopyTo Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : CopyTo Method

array
The array to copy to.
index
The index in the array to begin copying.
Copies the collection to an array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As Limit, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim array() As Limit
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   Limit[] array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   Limit*[] array,
   int index
)
C++/CLI
public:
void CopyTo(
   array<Limit^> array,
   int index
)

Parameters

array
The array to copy to.
index
The index in the array to begin copying.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : FromXmlString Method

xml
The XML string to load from.
Loads the contents of the limit collection from an XML string.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
The XML string to load from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetPrioritizedOrder Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : GetPrioritizedOrder Method

includeRemote
Indicates if remote limits should be included.
Gets the limits in order of priority.

Syntax

Visual Basic (Declaration)
Public Function GetPrioritizedOrder( _
   ByVal includeRemote As Boolean _
) As LimitCollection
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim includeRemote As Boolean
Dim value As LimitCollection

value = instance.GetPrioritizedOrder(includeRemote)
C#
public LimitCollection GetPrioritizedOrder(
   bool includeRemote
)
Managed Extensions for C++
public: LimitCollection* GetPrioritizedOrder(
   bool includeRemote
)
C++/CLI
public:
LimitCollection^ GetPrioritizedOrder(
   bool includeRemote
)

Parameters

includeRemote
Indicates if remote limits should be included.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Granted Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Granted Method

context
type
instance
Called every time the limit is granted.

Syntax

Visual Basic (Declaration)
Public Sub Granted( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim context As LicenseContext
Dim type As Type
Dim instance As Object

instance.Granted(context, type, instance)
C#
public void Granted(
   LicenseContext context,
   Type type,
   object instance
)
Managed Extensions for C++
public: void Granted(
   LicenseContext context,
   Type* type,
   Object* instance
)
C++/CLI
public:
void Granted(
   LicenseContext context,
   Type^ type,
   Object^ instance
)

Parameters

context
type
instance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IndexOf Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : IndexOf Method

limit
The limit to look for.
Gets the index of the given limit.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal limit As Limit _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim limit As Limit
Dim value As Integer

value = instance.IndexOf(limit)
C#
public int IndexOf(
   Limit limit
)
Managed Extensions for C++
public: int IndexOf(
   Limit* limit
)
C++/CLI
public:
int IndexOf(
   Limit^ limit
)

Parameters

limit
The limit to look for.

Return Value

Returns the index of the given limit if found, otherwise -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Insert Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Insert Method

index
The index where to insert the limit.
limit
The limit to insert.
Inserts the limit at the given index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal limit As Limit _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim index As Integer
Dim limit As Limit

instance.Insert(index, limit)
C#
public void Insert(
   int index,
   Limit limit
)
Managed Extensions for C++
public: void Insert(
   int index,
   Limit* limit
)
C++/CLI
public:
void Insert(
   int index,
   Limit^ limit
)

Parameters

index
The index where to insert the limit.
limit
The limit to insert.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : LoadFromXml Method

node
Loads the contents of a LimitCollection from an XmlNode.

Syntax

Visual Basic (Declaration)
Public Function LoadFromXml( _
   ByVal node As XmlNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim node As XmlNode
Dim value As Boolean

value = instance.LoadFromXml(node)
C#
public bool LoadFromXml(
   XmlNode node
)
Managed Extensions for C++
public: bool LoadFromXml(
   XmlNode node
)
C++/CLI
public:
bool LoadFromXml(
   XmlNode node
)

Parameters

node

Return Value

Returns true if the load was successful, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Remove Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Remove Method

limit
The limit to remove.
Removes the given index from the list.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal limit As Limit _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim limit As Limit

instance.Remove(limit)
C#
public void Remove(
   Limit limit
)
Managed Extensions for C++
public: void Remove(
   Limit* limit
)
C++/CLI
public:
void Remove(
   Limit^ limit
)

Parameters

limit
The limit to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : SaveToXml Method

parent
The parent XmlNode.
Saves the contents of the LimitCollection to the given XmlNode.

Syntax

Visual Basic (Declaration)
Public Function SaveToXml( _
   ByVal parent As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim parent As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parent)
C#
public XmlNode SaveToXml(
   XmlNode parent
)
Managed Extensions for C++
public: XmlNode SaveToXml(
   XmlNode parent
)
C++/CLI
public:
XmlNode SaveToXml(
   XmlNode parent
)

Parameters

parent
The parent XmlNode.

Return Value

Returns the root node of the saved limits.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : ToXmlString Method

Saves the contents of the limit collection to an XML string.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim value As String

value = instance.ToXmlString()
C#
public string ToXmlString()
Managed Extensions for C++
public: string* ToXmlString();
C++/CLI
public:
String^ ToXmlString();

Return Value

The saved XML.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Validate Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Validate Method

context
The LicenseContext passed to GetLicense.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
includeRemote
Indicates if limits that have IsRemote set to true should be included in the validation.
Ensures that all the Limits in the collection are valid for the given type and context.

Syntax

Visual Basic (Declaration)
Public Overridable Function Validate( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object, _
   ByVal includeRemote As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim context As LicenseContext
Dim type As Type
Dim instance As Object
Dim includeRemote As Boolean
Dim value As Boolean

value = instance.Validate(context, type, instance, includeRemote)
C#
public virtual bool Validate(
   LicenseContext context,
   Type type,
   object instance,
   bool includeRemote
)
Managed Extensions for C++
public: virtual bool Validate(
   LicenseContext context,
   Type* type,
   Object* instance,
   bool includeRemote
)
C++/CLI
public:
virtual bool Validate(
   LicenseContext context,
   Type^ type,
   Object^ instance,
   bool includeRemote
)

Parameters

context
The LicenseContext passed to GetLicense.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
includeRemote
Indicates if limits that have IsRemote set to true should be included in the validation.

Return Value

Returns true if the limits are valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Web Send comments on this topic.
LimitCollection Class Properties
See Also
[image]
Xheo.Licensing Namespace : LimitCollection Class

For a list of all members of this type, see LimitCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating if the collection is read only. (Inherited from TransientReadOnlyCollection)
Public Property | Item | Gets or sets a limit at the given index.
Public Property | License | Gets or sets a reference to the containing license.
Top

See Also

Reference

LimitCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Item Property
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Item Property

index
Gets or sets a limit at the given index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Limit
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim index As Integer
Dim value As Limit

instance.Item(index) = value

value = instance.Item(index)
C#
public Limit this[
   int index
]; {get; set;}
Managed Extensions for C++
public: __property Limit* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   Limit* value
);
C++/CLI
public:
property Limit^ default [int] {
   Limit^ get(int index);
   void set (int index, Limit^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
License Property
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : License Property

Gets or sets a reference to the containing license.

Syntax

Visual Basic (Declaration)
Public Property License As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim value As ExtendedLicense

instance.License = value

value = instance.License
C#
public ExtendedLicense License {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_License();
public: __property void set_License(
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ License {
   ExtendedLicense^ get();
   void set (ExtendedLicense^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MachineProfile Class
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile Class

Manages a machine profile used by the license activation system. Profiles represent a collection of generally non volitale system properties that can collectively be used to identify certain machines.

Syntax

Visual Basic (Declaration)
Private NotInheritable Class MachineProfile
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
C#
private sealed class MachineProfile
Managed Extensions for C++
private __gc __sealed class MachineProfile
C++/CLI
private ref class MachineProfile sealed

Inheritance Hierarchy

System.Object
Xheo.Licensing.MachineProfile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
MachineProfile Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : MachineProfile Class

The following tables list the members exposed by MachineProfile.

Public Constructors

 | Name | Description
Public Constructor | MachineProfile Constructor | Initializes a new instance of the MachineProfile class.
Top

Public Properties

 | Name | Description
Public Property | Hash | Gets the comparable hash for the MachineProfile.
static (Shared in Visual Basic) | Profile | Gets the profile of the current machine.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CompareHash | Compares two machine profile hashes and determines the amount of difference.
Public Method | CompareTo | Determines if the MachineProfile is comparatively similar to the given hash.
Public Method | GetComparableHash | Overloaded. Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.
static (Shared in Visual Basic) | GetDifferences | Gets the name of the hardware types that are different between the two hashes.
Top

See Also

Reference

MachineProfile Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MachineProfile Constructor
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : MachineProfile Constructor

Initializes a new instance of the MachineProfile class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile()
C#
public MachineProfile()
Managed Extensions for C++
public: MachineProfile();
C++/CLI
public:
MachineProfile();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
MachineProfile Class Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile Class

For a list of all members of this type, see MachineProfile members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CompareHash | Compares two machine profile hashes and determines the amount of difference.
Public Method | CompareTo | Determines if the MachineProfile is comparatively similar to the given hash.
Public Method | GetComparableHash | Overloaded. Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.
static (Shared in Visual Basic) | GetDifferences | Gets the name of the hardware types that are different between the two hashes.
Top

See Also

Reference

MachineProfile Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
CompareHash Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : CompareHash Method

hash
The of the machine to compare.
comparedHash
The hashed value of another machine profile to compare to.
Compares two machine profile hashes and determines the amount of difference.

Syntax

Visual Basic (Declaration)
Public Shared Function CompareHash( _
   ByVal hash As String, _
   ByVal comparedHash As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim hash As String
Dim comparedHash As String
Dim value As Integer

value = MachineProfile.CompareHash(hash, comparedHash)
C#
public static int CompareHash(
   string hash,
   string comparedHash
)
Managed Extensions for C++
public: static int CompareHash(
   string* hash,
   string* comparedHash
)
C++/CLI
public:
static int CompareHash(
   String^ hash,
   String^ comparedHash
)

Parameters

hash
The of the machine to compare.
comparedHash
The hashed value of another machine profile to compare to.

Return Value

Returns the difference rating from 0 (same) to 10 (very different).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
CompareTo Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : CompareTo Method

profileHash
The hash to compare to.
tolerance
The tolerance level.
Determines if the MachineProfile is comparatively similar to the given hash.

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal profileHash As String, _
   ByVal tolerance As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
Dim profileHash As String
Dim tolerance As Integer
Dim value As Boolean

value = instance.CompareTo(profileHash, tolerance)
C#
public bool CompareTo(
   string profileHash,
   int tolerance
)
Managed Extensions for C++
public: bool CompareTo(
   string* profileHash,
   int tolerance
)
C++/CLI
public:
bool CompareTo(
   String^ profileHash,
   int tolerance
)

Parameters

profileHash
The hash to compare to.
tolerance
The tolerance level.

Return Value

Returns true if the current machine profile is within the tolerance level of the given profile hash.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetComparableHash Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : GetComparableHash Method

Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.

Overload List

Overload | Description
GetComparableHash(Version) | Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.
GetComparableHash() | Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetComparableHash(Version) Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class > GetComparableHash Method : GetComparableHash(Version) Method

version
The hash version to generate. Use to create backwards compatible hash codes.
Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetComparableHash( _
   ByVal version As Version _
) As String
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
Dim version As Version
Dim value As String

value = instance.GetComparableHash(version)
C#
public string GetComparableHash(
   Version version
)
Managed Extensions for C++
public: string* GetComparableHash(
   Version* version
)
C++/CLI
public:
String^ GetComparableHash(
   Version^ version
)

Parameters

version
The hash version to generate. Use to create backwards compatible hash codes.

Return Value

Returns a comparable has for the current machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetComparableHash() Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class > GetComparableHash Method : GetComparableHash() Method

Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetComparableHash() As String
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
Dim value As String

value = instance.GetComparableHash()
C#
public string GetComparableHash()
Managed Extensions for C++
public: string* GetComparableHash();
C++/CLI
public:
String^ GetComparableHash();

Return Value

Returns a comparable has for the current machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetDifferences Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : GetDifferences Method

hash
The of the machine to compare.
comparedHash
The hashed value of another machine profile to compare to.
Gets the name of the hardware types that are different between the two hashes.

Syntax

Visual Basic (Declaration)
Public Shared Function GetDifferences( _
   ByVal hash As String, _
   ByVal comparedHash As String _
) As String()
Visual Basic (Usage) Copy Code
Dim hash As String
Dim comparedHash As String
Dim value() As String

value = MachineProfile.GetDifferences(hash, comparedHash)
C#
public static string[] GetDifferences(
   string hash,
   string comparedHash
)
Managed Extensions for C++
public: static string*[] GetDifferences(
   string* hash,
   string* comparedHash
)
C++/CLI
public:
static array<String^> GetDifferences(
   String^ hash,
   String^ comparedHash
)

Parameters

hash
The of the machine to compare.
comparedHash
The hashed value of another machine profile to compare to.

Return Value

Returns the collection of hardware changes detected between the two hashes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Web Send comments on this topic.
MachineProfile Class Properties
See Also
[image]
Xheo.Licensing Namespace : MachineProfile Class

For a list of all members of this type, see MachineProfile members.

Public Properties

 | Name | Description
Public Property | Hash | Gets the comparable hash for the MachineProfile.
static (Shared in Visual Basic) | Profile | Gets the profile of the current machine.
Top

See Also

Reference

MachineProfile Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Hash Property
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : Hash Property

Gets the comparable hash for the MachineProfile.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hash As String
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
Dim value As String

value = instance.Hash
C#
public string Hash {get;}
Managed Extensions for C++
public: __property string* get_Hash();
C++/CLI
public:
property String^ Hash {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Profile Property
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : Profile Property

Gets the profile of the current machine.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Profile As MachineProfile
Visual Basic (Usage) Copy Code
Dim value As MachineProfile

value = MachineProfile.Profile
C#
public static MachineProfile Profile {get;}
Managed Extensions for C++
public: __property static MachineProfile* get_Profile();
C++/CLI
public:
static property MachineProfile^ Profile {
   MachineProfile^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MachineProfile.Constants Class
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.Constants Class

A class to contain the constants required for the IP_ADAPTER_INFO struct

Syntax

Visual Basic (Declaration)
Private Class MachineProfile.Constants
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.Constants
C#
private class MachineProfile.Constants
Managed Extensions for C++
private __gc class MachineProfile.Constants
C++/CLI
private ref class MachineProfile.Constants

Inheritance Hierarchy

System.Object
Xheo.Licensing.MachineProfile.Constants

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
MachineProfile.Constants Class Members
See Also Fields
[image]
Xheo.Licensing Namespace : MachineProfile.Constants Class

The following tables list the members exposed by MachineProfile.Constants.

Public Constructors

 | Name | Description
Public Constructor | MachineProfile.Constants Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MAX_ADAPTER_ADDRESS_LENGTH | The maximum length for the physical address of the adapter
static (Shared in Visual Basic) | MAX_ADAPTER_DESCRIPTION_LENGTH | The maximum length of the description of an adapter
static (Shared in Visual Basic) | MAX_ADAPTER_NAME_LENGTH | The maximum length of an adapter name
Top

See Also

Reference

MachineProfile.Constants Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MachineProfile.Constants Constructor
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.Constants Class : MachineProfile.Constants Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.Constants()
C#
public MachineProfile.Constants()
Managed Extensions for C++
public: MachineProfile.Constants();
C++/CLI
public:
MachineProfile.Constants();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Class
MachineProfile.Constants Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.Web Send comments on this topic.
MachineProfile.Constants Class Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.Constants Class

For a list of all members of this type, see MachineProfile.Constants members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MAX_ADAPTER_ADDRESS_LENGTH | The maximum length for the physical address of the adapter
static (Shared in Visual Basic) | MAX_ADAPTER_DESCRIPTION_LENGTH | The maximum length of the description of an adapter
static (Shared in Visual Basic) | MAX_ADAPTER_NAME_LENGTH | The maximum length of an adapter name
Top

See Also

Reference

MachineProfile.Constants Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MAX_ADAPTER_ADDRESS_LENGTH Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.Constants Class : MAX_ADAPTER_ADDRESS_LENGTH Field

The maximum length for the physical address of the adapter

Syntax

Visual Basic (Declaration)
Public Shared MAX_ADAPTER_ADDRESS_LENGTH As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = MachineProfile.Constants.MAX_ADAPTER_ADDRESS_LENGTH

MachineProfile.Constants.MAX_ADAPTER_ADDRESS_LENGTH = value
C#
public static int MAX_ADAPTER_ADDRESS_LENGTH
Managed Extensions for C++
public: static int MAX_ADAPTER_ADDRESS_LENGTH
C++/CLI
public:
static int MAX_ADAPTER_ADDRESS_LENGTH

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Class
MachineProfile.Constants Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MAX_ADAPTER_DESCRIPTION_LENGTH Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.Constants Class : MAX_ADAPTER_DESCRIPTION_LENGTH Field

The maximum length of the description of an adapter

Syntax

Visual Basic (Declaration)
Public Shared MAX_ADAPTER_DESCRIPTION_LENGTH As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = MachineProfile.Constants.MAX_ADAPTER_DESCRIPTION_LENGTH

MachineProfile.Constants.MAX_ADAPTER_DESCRIPTION_LENGTH = value
C#
public static int MAX_ADAPTER_DESCRIPTION_LENGTH
Managed Extensions for C++
public: static int MAX_ADAPTER_DESCRIPTION_LENGTH
C++/CLI
public:
static int MAX_ADAPTER_DESCRIPTION_LENGTH

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Class
MachineProfile.Constants Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MAX_ADAPTER_NAME_LENGTH Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.Constants Class : MAX_ADAPTER_NAME_LENGTH Field

The maximum length of an adapter name

Syntax

Visual Basic (Declaration)
Public Shared MAX_ADAPTER_NAME_LENGTH As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = MachineProfile.Constants.MAX_ADAPTER_NAME_LENGTH

MachineProfile.Constants.MAX_ADAPTER_NAME_LENGTH = value
C#
public static int MAX_ADAPTER_NAME_LENGTH
Managed Extensions for C++
public: static int MAX_ADAPTER_NAME_LENGTH
C++/CLI
public:
static int MAX_ADAPTER_NAME_LENGTH

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Class
MachineProfile.Constants Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MachineProfile.GetAdapterInfo Class
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.GetAdapterInfo Class

Uses the windows API to retrieve information about the IP configuration of the local machine

Syntax

Visual Basic (Declaration)
Private Class MachineProfile.GetAdapterInfo
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.GetAdapterInfo
C#
private class MachineProfile.GetAdapterInfo
Managed Extensions for C++
private __gc class MachineProfile.GetAdapterInfo
C++/CLI
private ref class MachineProfile.GetAdapterInfo

Inheritance Hierarchy

System.Object
Xheo.Licensing.MachineProfile.GetAdapterInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.GetAdapterInfo Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
MachineProfile.GetAdapterInfo Class Members
See Also Methods
[image]
Xheo.Licensing Namespace : MachineProfile.GetAdapterInfo Class

The following tables list the members exposed by MachineProfile.GetAdapterInfo.

Public Constructors

 | Name | Description
Public Constructor | MachineProfile.GetAdapterInfo Constructor | Constructor for the GetAdapterInfo Class
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetAdapters | Gets details of all the adapters on the local machine
static (Shared in Visual Basic) | GetFirstAdapter | Gets the details of the first available adapter on the local machine
Top

See Also

Reference

MachineProfile.GetAdapterInfo Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MachineProfile.GetAdapterInfo Constructor
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.GetAdapterInfo Class : MachineProfile.GetAdapterInfo Constructor

Constructor for the GetAdapterInfo Class

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.GetAdapterInfo()
C#
public MachineProfile.GetAdapterInfo()
Managed Extensions for C++
public: MachineProfile.GetAdapterInfo();
C++/CLI
public:
MachineProfile.GetAdapterInfo();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.GetAdapterInfo Class
MachineProfile.GetAdapterInfo Members


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
MachineProfile.GetAdapterInfo Class Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.GetAdapterInfo Class

For a list of all members of this type, see MachineProfile.GetAdapterInfo members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetAdapters | Gets details of all the adapters on the local machine
static (Shared in Visual Basic) | GetFirstAdapter | Gets the details of the first available adapter on the local machine
Top

See Also

Reference

MachineProfile.GetAdapterInfo Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetAdapters Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.GetAdapterInfo Class : GetAdapters Method

Gets details of all the adapters on the local machine

Syntax

Visual Basic (Declaration)
Public Shared Function GetAdapters() As ArrayList
Visual Basic (Usage) Copy Code
Dim value As ArrayList

value = MachineProfile.GetAdapterInfo.GetAdapters()
C#
public static ArrayList GetAdapters()
Managed Extensions for C++
public: static ArrayList* GetAdapters();
C++/CLI
public:
static ArrayList^ GetAdapters();

Return Value

The return object is a System.Collections.ArrayList of IPConfig.IP_ADAPTERINFO_STRUCTURE structs containing data about the Adapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.GetAdapterInfo Class
MachineProfile.GetAdapterInfo Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GetFirstAdapter Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.GetAdapterInfo Class : GetFirstAdapter Method

Gets the details of the first available adapter on the local machine

Syntax

Visual Basic (Declaration)
Public Shared Function GetFirstAdapter() As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Visual Basic (Usage) Copy Code
Dim value As MachineProfile.IP_ADAPTERINFO_STRUCTURE

value = MachineProfile.GetAdapterInfo.GetFirstAdapter()
C#
public static MachineProfile.IP_ADAPTERINFO_STRUCTURE GetFirstAdapter()
Managed Extensions for C++
public: static MachineProfile.IP_ADAPTERINFO_STRUCTURE GetFirstAdapter();
C++/CLI
public:
static MachineProfile.IP_ADAPTERINFO_STRUCTURE GetFirstAdapter();

Return Value

The return value is an struct of type IP_ADAPTERINFO_STRUCTURE containing data about the Adapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.GetAdapterInfo Class
MachineProfile.GetAdapterInfo Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
StateEntry Class
See Also Members
[image]
Xheo.Licensing Namespace : StateEntry Class

Syntax

Visual Basic (Declaration)
Private Class StateEntry
Visual Basic (Usage) Copy Code
Dim instance As StateEntry
C#
private class StateEntry
Managed Extensions for C++
private __gc class StateEntry
C++/CLI
private ref class StateEntry

Inheritance Hierarchy

System.Object
Xheo.Licensing.StateEntry

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateEntry Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
StateEntry Class Members
See Also Fields
[image]
Xheo.Licensing Namespace : StateEntry Class

The following tables list the members exposed by StateEntry.

Public Constructors

 | Name | Description
Public Constructor | StateEntry Constructor |
Top

Public Fields

 | Name | Description
Public Field | LastUsed |
Public Field | SessionState |
Top

See Also

Reference

StateEntry Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
StateEntry Constructor
See Also
[image]
Xheo.Licensing Namespace > StateEntry Class : StateEntry Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StateEntry()
C#
public StateEntry()
Managed Extensions for C++
public: StateEntry();
C++/CLI
public:
StateEntry();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateEntry Class
StateEntry Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.Web Send comments on this topic.
StateEntry Class Fields
See Also
[image]
Xheo.Licensing Namespace : StateEntry Class

For a list of all members of this type, see StateEntry members.

Public Fields

 | Name | Description
Public Field | LastUsed |
Public Field | SessionState |
Top

See Also

Reference

StateEntry Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LastUsed Field
See Also
[image]
Xheo.Licensing Namespace > StateEntry Class : LastUsed Field

Syntax

Visual Basic (Declaration)
Public LastUsed As Date
Visual Basic (Usage) Copy Code
Dim instance As StateEntry
Dim value As Date

value = instance.LastUsed

instance.LastUsed = value
C#
public DateTime LastUsed
Managed Extensions for C++
public: DateTime LastUsed
C++/CLI
public:
DateTime LastUsed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateEntry Class
StateEntry Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SessionState Field
See Also
[image]
Xheo.Licensing Namespace > StateEntry Class : SessionState Field

Syntax

Visual Basic (Declaration)
Public SessionState As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As StateEntry
Dim value As Hashtable

value = instance.SessionState

instance.SessionState = value
C#
public Hashtable SessionState
Managed Extensions for C++
public: Hashtable* SessionState
C++/CLI
public:
Hashtable^ SessionState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateEntry Class
StateEntry Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
TransientReadOnlyCollection Class
See Also Members
[image]
Xheo.Licensing Namespace : TransientReadOnlyCollection Class

Implements a transient read only collection. Values can be added, removed and changed until the SetReadOnly method is called thus forcing the collection to a read only state.

Syntax

Visual Basic (Declaration)
Private MustInherit Class TransientReadOnlyCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As TransientReadOnlyCollection
C#
private abstract class TransientReadOnlyCollection : CollectionBase
Managed Extensions for C++
private __gc abstract class TransientReadOnlyCollection : public CollectionBase
C++/CLI
private ref class TransientReadOnlyCollection abstract : public CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Xheo.Licensing.TransientReadOnlyCollection
Xheo.Licensing.LimitCollection
Xheo.Licensing.LimitCollection
Xheo.Licensing.LimitCollection
Xheo.Licensing.LimitCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TransientReadOnlyCollection Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
TransientReadOnlyCollection Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : TransientReadOnlyCollection Class

The following tables list the members exposed by TransientReadOnlyCollection.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating if the collection is read only.
Top

Public Methods

 | Name | Description
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | SetReadOnly | Sets the collection to a read only state. This cannot be reversed.
Top

See Also

Reference

TransientReadOnlyCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
TransientReadOnlyCollection Class Methods
See Also
[image]
Xheo.Licensing Namespace : TransientReadOnlyCollection Class

For a list of all members of this type, see TransientReadOnlyCollection members.

Public Methods

 | Name | Description
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | SetReadOnly | Sets the collection to a read only state. This cannot be reversed.
Top

See Also

Reference

TransientReadOnlyCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SetReadOnly Method
See Also
[image]
Xheo.Licensing Namespace > TransientReadOnlyCollection Class : SetReadOnly Method

Sets the collection to a read only state. This cannot be reversed.

Syntax

Visual Basic (Declaration)
Public Sub SetReadOnly()
Visual Basic (Usage) Copy Code
Dim instance As TransientReadOnlyCollection

instance.SetReadOnly()
C#
public void SetReadOnly()
Managed Extensions for C++
public: void SetReadOnly();
C++/CLI
public:
void SetReadOnly();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TransientReadOnlyCollection Class
TransientReadOnlyCollection Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Web Send comments on this topic.
TransientReadOnlyCollection Class Properties
See Also
[image]
Xheo.Licensing Namespace : TransientReadOnlyCollection Class

For a list of all members of this type, see TransientReadOnlyCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating if the collection is read only.
Top

See Also

Reference

TransientReadOnlyCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IsReadOnly Property
See Also
[image]
Xheo.Licensing Namespace > TransientReadOnlyCollection Class : IsReadOnly Property

Gets a value indicating if the collection is read only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TransientReadOnlyCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TransientReadOnlyCollection Class
TransientReadOnlyCollection Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
PeekResult Enumeration
See Also
[image]
Xheo.Licensing Namespace : PeekResult Enumeration

Possible results from the Peek method.

Syntax

Visual Basic (Declaration)
Private Enum PeekResult
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PeekResult
C#
private enum PeekResult : Enum
Managed Extensions for C++
__value private enum PeekResult : public Enum
C++/CLI
private enum class PeekResult : public Enum

Members

Member | Description
Unknown | Unkonwn status.
Valid | The limit is valid in it's current state and Validate will return true without any user interaction.
Invalid | The limit is invalid. Calling Validate may require user interaction.
NeedsUser | The limit may be valid but will require user interaction to ensure.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xheo.Licensing.PeekResult

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SerialNumberSizes Enumeration
See Also
[image]
Xheo.Licensing Namespace : SerialNumberSizes Enumeration

Possible key sizes for use when generating serial numbers. More bits makes it more difficult to crack but also increase the size of the serial number.

Syntax

Visual Basic (Declaration)
Private Enum SerialNumberSizes
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As SerialNumberSizes
C#
private enum SerialNumberSizes : Enum
Managed Extensions for C++
__value private enum SerialNumberSizes : public Enum
C++/CLI
private enum class SerialNumberSizes : public Enum

Members

Member | Description
None | Indicates that no serial number sizes are valid.
Small | Uses a key of 64 bits in length. Generates a serial number ~13 characters in length. Recommended group size = 4.
Medium | Uses a key of 96 bits in length. Generates a serial number ~20 characters in length. Recommended group size = 5.
Large | Uses a key of 128 bits in length. Generates a serial number ~25 characters in length. Recommended group size = 5.
Huge | Uses a key of 320 bits in length. Generates a serial number ~64 characters in length. Recommended group size = 8.
All | Allow any of the stored serial number sizes.
MediumAndBigger | Allow the medium and bigger sizes.
LargeAndBigger | Allow the large and bigger sizes.
Recommended | Recommended sizes for licenses.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xheo.Licensing.SerialNumberSizes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LicenseSigningKey.KeyRecord Structure
See Also Members
[image]
Xheo.Licensing Namespace : LicenseSigningKey.KeyRecord Structure

Object Model

Syntax

Visual Basic (Declaration)
Private Structure LicenseSigningKey.KeyRecord
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
C#
private struct LicenseSigningKey.KeyRecord : ValueType
Managed Extensions for C++
private __value struct LicenseSigningKey.KeyRecord : public ValueType
C++/CLI
private value class LicenseSigningKey.KeyRecord : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.LicenseSigningKey.KeyRecord

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
LicenseSigningKey.KeyRecord Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : LicenseSigningKey.KeyRecord Structure

The following tables list the members exposed by LicenseSigningKey.KeyRecord.

Public Constructors

 | Name | Description
Public Constructor | LicenseSigningKey.KeyRecord Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Bits |
Public Field | d |
Public Field | e |
Public Field | n |
Public Field | p |
Public Field | q |
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Public Method | VerifyKey |
Top

See Also

Reference

LicenseSigningKey.KeyRecord Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LicenseSigningKey.KeyRecord Constructor
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : LicenseSigningKey.KeyRecord Constructor

Overload List

Overload | Description
LicenseSigningKey.KeyRecord Constructor(BigInteger,BigInteger,BigInteger,BigInteger,BigInteger,Int32) |
LicenseSigningKey.KeyRecord Constructor(Int32) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LicenseSigningKey.KeyRecord Constructor(BigInteger,BigInteger,BigInteger,BigInteger,BigInteger,Int32)
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure > LicenseSigningKey.KeyRecord Constructor : LicenseSigningKey.KeyRecord Constructor(BigInteger,BigInteger,BigInteger,BigInteger,BigInteger,Int32)

p
q
e
n
d
bits

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal p As BigInteger, _
   ByVal q As BigInteger, _
   ByVal e As BigInteger, _
   ByVal n As BigInteger, _
   ByVal d As BigInteger, _
   ByVal bits As Integer _
)
Visual Basic (Usage) Copy Code
Dim p As BigInteger
Dim q As BigInteger
Dim e As BigInteger
Dim n As BigInteger
Dim d As BigInteger
Dim bits As Integer

Dim instance As LicenseSigningKey.KeyRecord(p, q, e, n, d, bits)
C#
public LicenseSigningKey.KeyRecord(
   BigInteger p,
   BigInteger q,
   BigInteger e,
   BigInteger n,
   BigInteger d,
   int bits
)
Managed Extensions for C++
public: LicenseSigningKey.KeyRecord(
   BigInteger* p,
   BigInteger* q,
   BigInteger* e,
   BigInteger* n,
   BigInteger* d,
   int bits
)
C++/CLI
public:
LicenseSigningKey.KeyRecord(
   BigInteger^ p,
   BigInteger^ q,
   BigInteger^ e,
   BigInteger^ n,
   BigInteger^ d,
   int bits
)

Parameters

p
q
e
n
d
bits

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LicenseSigningKey.KeyRecord Constructor(Int32)
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure > LicenseSigningKey.KeyRecord Constructor : LicenseSigningKey.KeyRecord Constructor(Int32)

bits

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bits As Integer _
)
Visual Basic (Usage) Copy Code
Dim bits As Integer

Dim instance As LicenseSigningKey.KeyRecord(bits)
C#
public LicenseSigningKey.KeyRecord(
   int bits
)
Managed Extensions for C++
public: LicenseSigningKey.KeyRecord(
   int bits
)
C++/CLI
public:
LicenseSigningKey.KeyRecord(
   int bits
)

Parameters

bits

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
LicenseSigningKey.KeyRecord Structure Methods
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey.KeyRecord Structure

For a list of all members of this type, see LicenseSigningKey.KeyRecord members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Public Method | VerifyKey |
Top

See Also

Reference

LicenseSigningKey.KeyRecord Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
VerifyKey Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : VerifyKey Method

Syntax

Visual Basic (Declaration)
Public Function VerifyKey() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As Boolean

value = instance.VerifyKey()
C#
public bool VerifyKey()
Managed Extensions for C++
public: bool VerifyKey();
C++/CLI
public:
bool VerifyKey();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.Web Send comments on this topic.
LicenseSigningKey.KeyRecord Structure Fields
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey.KeyRecord Structure

For a list of all members of this type, see LicenseSigningKey.KeyRecord members.

Public Fields

 | Name | Description
Public Field | Bits |
Public Field | d |
Public Field | e |
Public Field | n |
Public Field | p |
Public Field | q |
Top

See Also

Reference

LicenseSigningKey.KeyRecord Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Bits Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : Bits Field

Syntax

Visual Basic (Declaration)
Public Bits As Integer
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As Integer

value = instance.Bits

instance.Bits = value
C#
public int Bits
Managed Extensions for C++
public: int Bits
C++/CLI
public:
int Bits

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
d Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : d Field

Syntax

Visual Basic (Declaration)
Public d As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.d

instance.d = value
C#
public BigInteger d
Managed Extensions for C++
public: BigInteger* d
C++/CLI
public:
BigInteger^ d

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
e Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : e Field

Syntax

Visual Basic (Declaration)
Public e As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.e

instance.e = value
C#
public BigInteger e
Managed Extensions for C++
public: BigInteger* e
C++/CLI
public:
BigInteger^ e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
n Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : n Field

Syntax

Visual Basic (Declaration)
Public n As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.n

instance.n = value
C#
public BigInteger n
Managed Extensions for C++
public: BigInteger* n
C++/CLI
public:
BigInteger^ n

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
p Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : p Field

Syntax

Visual Basic (Declaration)
Public p As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.p

instance.p = value
C#
public BigInteger p
Managed Extensions for C++
public: BigInteger* p
C++/CLI
public:
BigInteger^ p

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
q Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : q Field

Syntax

Visual Basic (Declaration)
Public q As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.q

instance.q = value
C#
public BigInteger q
Managed Extensions for C++
public: BigInteger* q
C++/CLI
public:
BigInteger^ q

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MachineProfile._MEMORYSTATUS Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUS Structure

Summary of _MEMORYSTATUS

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile._MEMORYSTATUS
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
C#
private struct MachineProfile._MEMORYSTATUS : ValueType
Managed Extensions for C++
private __value struct MachineProfile._MEMORYSTATUS : public ValueType
C++/CLI
private value class MachineProfile._MEMORYSTATUS : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile._MEMORYSTATUS

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
MachineProfile._MEMORYSTATUS Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUS Structure

The following tables list the members exposed by MachineProfile._MEMORYSTATUS.

Public Fields

 | Name | Description
Public Field | dwAvailPageFile |
Public Field | dwAvailPhys |
Public Field | dwAvailVirtual |
Public Field | dwLength |
Public Field | dwMemoryLoad |
Public Field | dwTotalPageFile |
Public Field | dwTotalPhys |
Public Field | dwTotalVirtual |
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.Web Send comments on this topic.
MachineProfile._MEMORYSTATUS Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUS Structure

For a list of all members of this type, see MachineProfile._MEMORYSTATUS members.

Public Fields

 | Name | Description
Public Field | dwAvailPageFile |
Public Field | dwAvailPhys |
Public Field | dwAvailVirtual |
Public Field | dwLength |
Public Field | dwMemoryLoad |
Public Field | dwTotalPageFile |
Public Field | dwTotalPhys |
Public Field | dwTotalVirtual |
Top

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
dwAvailPageFile Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwAvailPageFile Field

Syntax

Visual Basic (Declaration)
Public dwAvailPageFile As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwAvailPageFile

instance.dwAvailPageFile = value
C#
public uint dwAvailPageFile
Managed Extensions for C++
public: uint dwAvailPageFile
C++/CLI
public:
uint dwAvailPageFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
dwAvailPhys Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwAvailPhys Field

Syntax

Visual Basic (Declaration)
Public dwAvailPhys As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwAvailPhys

instance.dwAvailPhys = value
C#
public uint dwAvailPhys
Managed Extensions for C++
public: uint dwAvailPhys
C++/CLI
public:
uint dwAvailPhys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
dwAvailVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwAvailVirtual Field

Syntax

Visual Basic (Declaration)
Public dwAvailVirtual As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwAvailVirtual

instance.dwAvailVirtual = value
C#
public uint dwAvailVirtual
Managed Extensions for C++
public: uint dwAvailVirtual
C++/CLI
public:
uint dwAvailVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
dwLength Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwLength Field

Syntax

Visual Basic (Declaration)
Public dwLength As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwLength

instance.dwLength = value
C#
public uint dwLength
Managed Extensions for C++
public: uint dwLength
C++/CLI
public:
uint dwLength

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
dwMemoryLoad Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwMemoryLoad Field

Syntax

Visual Basic (Declaration)
Public dwMemoryLoad As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwMemoryLoad

instance.dwMemoryLoad = value
C#
public uint dwMemoryLoad
Managed Extensions for C++
public: uint dwMemoryLoad
C++/CLI
public:
uint dwMemoryLoad

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
dwTotalPageFile Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwTotalPageFile Field

Syntax

Visual Basic (Declaration)
Public dwTotalPageFile As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwTotalPageFile

instance.dwTotalPageFile = value
C#
public uint dwTotalPageFile
Managed Extensions for C++
public: uint dwTotalPageFile
C++/CLI
public:
uint dwTotalPageFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
dwTotalPhys Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwTotalPhys Field

Syntax

Visual Basic (Declaration)
Public dwTotalPhys As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwTotalPhys

instance.dwTotalPhys = value
C#
public uint dwTotalPhys
Managed Extensions for C++
public: uint dwTotalPhys
C++/CLI
public:
uint dwTotalPhys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
dwTotalVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwTotalVirtual Field

Syntax

Visual Basic (Declaration)
Public dwTotalVirtual As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwTotalVirtual

instance.dwTotalVirtual = value
C#
public uint dwTotalVirtual
Managed Extensions for C++
public: uint dwTotalVirtual
C++/CLI
public:
uint dwTotalVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MachineProfile._MEMORYSTATUSEX Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUSEX Structure

Summary of _MEMORYSTATUSEX

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile._MEMORYSTATUSEX
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
C#
private struct MachineProfile._MEMORYSTATUSEX : ValueType
Managed Extensions for C++
private __value struct MachineProfile._MEMORYSTATUSEX : public ValueType
C++/CLI
private value class MachineProfile._MEMORYSTATUSEX : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile._MEMORYSTATUSEX

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
MachineProfile._MEMORYSTATUSEX Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUSEX Structure

The following tables list the members exposed by MachineProfile._MEMORYSTATUSEX.

Public Fields

 | Name | Description
Public Field | dwLength |
Public Field | dwMemoryLoad |
Public Field | ullAvailExtendedVirtual |
Public Field | ullAvailPageFile |
Public Field | ullAvailPhys |
Public Field | ullAvailVirtual |
Public Field | ullTotalPageFile |
Public Field | ullTotalPhys |
Public Field | ullTotalVirtual |
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.Web Send comments on this topic.
MachineProfile._MEMORYSTATUSEX Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUSEX Structure

For a list of all members of this type, see MachineProfile._MEMORYSTATUSEX members.

Public Fields

 | Name | Description
Public Field | dwLength |
Public Field | dwMemoryLoad |
Public Field | ullAvailExtendedVirtual |
Public Field | ullAvailPageFile |
Public Field | ullAvailPhys |
Public Field | ullAvailVirtual |
Public Field | ullTotalPageFile |
Public Field | ullTotalPhys |
Public Field | ullTotalVirtual |
Top

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
dwLength Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : dwLength Field

Syntax

Visual Basic (Declaration)
Public dwLength As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As UInteger

value = instance.dwLength

instance.dwLength = value
C#
public uint dwLength
Managed Extensions for C++
public: uint dwLength
C++/CLI
public:
uint dwLength

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
dwMemoryLoad Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : dwMemoryLoad Field

Syntax

Visual Basic (Declaration)
Public dwMemoryLoad As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As UInteger

value = instance.dwMemoryLoad

instance.dwMemoryLoad = value
C#
public uint dwMemoryLoad
Managed Extensions for C++
public: uint dwMemoryLoad
C++/CLI
public:
uint dwMemoryLoad

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ullAvailExtendedVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullAvailExtendedVirtual Field

Syntax

Visual Basic (Declaration)
Public ullAvailExtendedVirtual As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullAvailExtendedVirtual

instance.ullAvailExtendedVirtual = value
C#
public ulong ullAvailExtendedVirtual
Managed Extensions for C++
public: ulong ullAvailExtendedVirtual
C++/CLI
public:
ulong ullAvailExtendedVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ullAvailPageFile Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullAvailPageFile Field

Syntax

Visual Basic (Declaration)
Public ullAvailPageFile As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullAvailPageFile

instance.ullAvailPageFile = value
C#
public ulong ullAvailPageFile
Managed Extensions for C++
public: ulong ullAvailPageFile
C++/CLI
public:
ulong ullAvailPageFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ullAvailPhys Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullAvailPhys Field

Syntax

Visual Basic (Declaration)
Public ullAvailPhys As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullAvailPhys

instance.ullAvailPhys = value
C#
public ulong ullAvailPhys
Managed Extensions for C++
public: ulong ullAvailPhys
C++/CLI
public:
ulong ullAvailPhys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ullAvailVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullAvailVirtual Field

Syntax

Visual Basic (Declaration)
Public ullAvailVirtual As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullAvailVirtual

instance.ullAvailVirtual = value
C#
public ulong ullAvailVirtual
Managed Extensions for C++
public: ulong ullAvailVirtual
C++/CLI
public:
ulong ullAvailVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ullTotalPageFile Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullTotalPageFile Field

Syntax

Visual Basic (Declaration)
Public ullTotalPageFile As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullTotalPageFile

instance.ullTotalPageFile = value
C#
public ulong ullTotalPageFile
Managed Extensions for C++
public: ulong ullTotalPageFile
C++/CLI
public:
ulong ullTotalPageFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ullTotalPhys Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullTotalPhys Field

Syntax

Visual Basic (Declaration)
Public ullTotalPhys As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullTotalPhys

instance.ullTotalPhys = value
C#
public ulong ullTotalPhys
Managed Extensions for C++
public: ulong ullTotalPhys
C++/CLI
public:
ulong ullTotalPhys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ullTotalVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullTotalVirtual Field

Syntax

Visual Basic (Declaration)
Public ullTotalVirtual As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullTotalVirtual

instance.ullTotalVirtual = value
C#
public ulong ullTotalVirtual
Managed Extensions for C++
public: ulong ullTotalVirtual
C++/CLI
public:
ulong ullTotalVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure

declare the IP_ADAPTERINFO_STRUCTURE structure

Object Model

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile.IP_ADAPTERINFO_STRUCTURE
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
C#
private struct MachineProfile.IP_ADAPTERINFO_STRUCTURE : ValueType
Managed Extensions for C++
private __value struct MachineProfile.IP_ADAPTERINFO_STRUCTURE : public ValueType
C++/CLI
private value class MachineProfile.IP_ADAPTERINFO_STRUCTURE : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile.IP_ADAPTERINFO_STRUCTURE

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure

The following tables list the members exposed by MachineProfile.IP_ADAPTERINFO_STRUCTURE.

Public Fields

 | Name | Description
Public Field | AdapterName | Specifies the name of the adapter
Public Field | Address | Specifies the hardware address for the adapter
Public Field | AddressLength | Specifies the length of the hardware address for the adapter
Public Field | ComboIndex | Reserved
Public Field | CurrentIPAddress | Specifies the current IP address for this adapter
Public Field | Description | Specifies a description for the adapter
Public Field | DhcpEnabled | Specifies whether dynamic host configuration protocol (DHCP) is enabled for this adapter
Public Field | DhcpServer | Specifies the IP address of the DHCP server for this adapter
Public Field | GatewayList | Specifies the IP address of the default gateway for this adapter
Public Field | HaveWins | Specifies whether this adapter uses Windows Internet Name Service (WINS)
Public Field | Index | Specifies the adapter index
Public Field | IpAddressList | Specifies the list of IP addresses associated with this adapter
Public Field | LeaseExpires | Specifies the time when the current DHCP lease will expire
Public Field | LeaseObtained | Specifies the time when the current DHCP lease was obtained
Public Field | Next | Pointer to the next adapter in the list of adapters
Public Field | PrimaryWinsServer | Specifies the IP address of the primary WINS server
Public Field | SecondaryWinsServer | Specifies the IP address of the secondary WINS server
Public Field | Type | Specifies the adapter type. The type is one of the following values. IF_OTHER_ADAPTERTYPE IF_ETHERNET_ADAPTERTYPE IF_TOKEN_RING_ADAPTERTYPE IF_FDDI_ADAPTERTYPE IF_PPP_ADAPTERTYPE IF_LOOPBACK_ADAPTERTYPE IF_SLIP_ADAPTERTYPE These values are defined in the header file IPIfCons.h
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.Web Send comments on this topic.
MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure

For a list of all members of this type, see MachineProfile.IP_ADAPTERINFO_STRUCTURE members.

Public Fields

 | Name | Description
Public Field | AdapterName | Specifies the name of the adapter
Public Field | Address | Specifies the hardware address for the adapter
Public Field | AddressLength | Specifies the length of the hardware address for the adapter
Public Field | ComboIndex | Reserved
Public Field | CurrentIPAddress | Specifies the current IP address for this adapter
Public Field | Description | Specifies a description for the adapter
Public Field | DhcpEnabled | Specifies whether dynamic host configuration protocol (DHCP) is enabled for this adapter
Public Field | DhcpServer | Specifies the IP address of the DHCP server for this adapter
Public Field | GatewayList | Specifies the IP address of the default gateway for this adapter
Public Field | HaveWins | Specifies whether this adapter uses Windows Internet Name Service (WINS)
Public Field | Index | Specifies the adapter index
Public Field | IpAddressList | Specifies the list of IP addresses associated with this adapter
Public Field | LeaseExpires | Specifies the time when the current DHCP lease will expire
Public Field | LeaseObtained | Specifies the time when the current DHCP lease was obtained
Public Field | Next | Pointer to the next adapter in the list of adapters
Public Field | PrimaryWinsServer | Specifies the IP address of the primary WINS server
Public Field | SecondaryWinsServer | Specifies the IP address of the secondary WINS server
Public Field | Type | Specifies the adapter type. The type is one of the following values. IF_OTHER_ADAPTERTYPE IF_ETHERNET_ADAPTERTYPE IF_TOKEN_RING_ADAPTERTYPE IF_FDDI_ADAPTERTYPE IF_PPP_ADAPTERTYPE IF_LOOPBACK_ADAPTERTYPE IF_SLIP_ADAPTERTYPE These values are defined in the header file IPIfCons.h
Top

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
AdapterName Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : AdapterName Field

Specifies the name of the adapter

Syntax

Visual Basic (Declaration)
Public AdapterName As Char()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value() As Char

value = instance.AdapterName

instance.AdapterName = value
C#
public char[] AdapterName
Managed Extensions for C++
public: char[] AdapterName
C++/CLI
public:
array<char> AdapterName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Address Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Address Field

Specifies the hardware address for the adapter

Syntax

Visual Basic (Declaration)
Public Address As Byte()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value() As Byte

value = instance.Address

instance.Address = value
C#
public byte[] Address
Managed Extensions for C++
public: byte[] Address
C++/CLI
public:
array<byte> Address

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
AddressLength Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : AddressLength Field

Specifies the length of the hardware address for the adapter

Syntax

Visual Basic (Declaration)
Public AddressLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.AddressLength

instance.AddressLength = value
C#
public int AddressLength
Managed Extensions for C++
public: int AddressLength
C++/CLI
public:
int AddressLength

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
ComboIndex Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : ComboIndex Field

Reserved

Syntax

Visual Basic (Declaration)
Public ComboIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.ComboIndex

instance.ComboIndex = value
C#
public int ComboIndex
Managed Extensions for C++
public: int ComboIndex
C++/CLI
public:
int ComboIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
CurrentIPAddress Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : CurrentIPAddress Field

Specifies the current IP address for this adapter

Syntax

Visual Basic (Declaration)
Public CurrentIPAddress As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.CurrentIPAddress

instance.CurrentIPAddress = value
C#
public int CurrentIPAddress
Managed Extensions for C++
public: int CurrentIPAddress
C++/CLI
public:
int CurrentIPAddress

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Description Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Description Field

Specifies a description for the adapter

Syntax

Visual Basic (Declaration)
Public Description As Char()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value() As Char

value = instance.Description

instance.Description = value
C#
public char[] Description
Managed Extensions for C++
public: char[] Description
C++/CLI
public:
array<char> Description

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
DhcpEnabled Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : DhcpEnabled Field

Specifies whether dynamic host configuration protocol (DHCP) is enabled for this adapter

Syntax

Visual Basic (Declaration)
Public DhcpEnabled As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.DhcpEnabled

instance.DhcpEnabled = value
C#
public int DhcpEnabled
Managed Extensions for C++
public: int DhcpEnabled
C++/CLI
public:
int DhcpEnabled

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
DhcpServer Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : DhcpServer Field

Specifies the IP address of the DHCP server for this adapter

Syntax

Visual Basic (Declaration)
Public DhcpServer As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.DhcpServer

instance.DhcpServer = value
C#
public MachineProfile.IP_ADDR_STRING DhcpServer
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING DhcpServer
C++/CLI
public:
MachineProfile.IP_ADDR_STRING DhcpServer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
GatewayList Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : GatewayList Field

Specifies the IP address of the default gateway for this adapter

Syntax

Visual Basic (Declaration)
Public GatewayList As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.GatewayList

instance.GatewayList = value
C#
public MachineProfile.IP_ADDR_STRING GatewayList
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING GatewayList
C++/CLI
public:
MachineProfile.IP_ADDR_STRING GatewayList

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
HaveWins Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : HaveWins Field

Specifies whether this adapter uses Windows Internet Name Service (WINS)

Syntax

Visual Basic (Declaration)
Public HaveWins As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Byte

value = instance.HaveWins

instance.HaveWins = value
C#
public byte HaveWins
Managed Extensions for C++
public: byte HaveWins
C++/CLI
public:
byte HaveWins

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Index Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Index Field

Specifies the adapter index

Syntax

Visual Basic (Declaration)
Public Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.Index

instance.Index = value
C#
public int Index
Managed Extensions for C++
public: int Index
C++/CLI
public:
int Index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IpAddressList Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : IpAddressList Field

Specifies the list of IP addresses associated with this adapter

Syntax

Visual Basic (Declaration)
Public IpAddressList As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.IpAddressList

instance.IpAddressList = value
C#
public MachineProfile.IP_ADDR_STRING IpAddressList
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING IpAddressList
C++/CLI
public:
MachineProfile.IP_ADDR_STRING IpAddressList

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LeaseExpires Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : LeaseExpires Field

Specifies the time when the current DHCP lease will expire

Syntax

Visual Basic (Declaration)
Public LeaseExpires As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.LeaseExpires

instance.LeaseExpires = value
C#
public int LeaseExpires
Managed Extensions for C++
public: int LeaseExpires
C++/CLI
public:
int LeaseExpires

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
LeaseObtained Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : LeaseObtained Field

Specifies the time when the current DHCP lease was obtained

Syntax

Visual Basic (Declaration)
Public LeaseObtained As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.LeaseObtained

instance.LeaseObtained = value
C#
public int LeaseObtained
Managed Extensions for C++
public: int LeaseObtained
C++/CLI
public:
int LeaseObtained

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Next Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Next Field

Pointer to the next adapter in the list of adapters

Syntax

Visual Basic (Declaration)
Public Next As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As UInteger

value = instance.Next

instance.Next = value
C#
public uint Next
Managed Extensions for C++
public: uint Next
C++/CLI
public:
uint Next

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
PrimaryWinsServer Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : PrimaryWinsServer Field

Specifies the IP address of the primary WINS server

Syntax

Visual Basic (Declaration)
Public PrimaryWinsServer As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.PrimaryWinsServer

instance.PrimaryWinsServer = value
C#
public MachineProfile.IP_ADDR_STRING PrimaryWinsServer
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING PrimaryWinsServer
C++/CLI
public:
MachineProfile.IP_ADDR_STRING PrimaryWinsServer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
SecondaryWinsServer Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : SecondaryWinsServer Field

Specifies the IP address of the secondary WINS server

Syntax

Visual Basic (Declaration)
Public SecondaryWinsServer As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.SecondaryWinsServer

instance.SecondaryWinsServer = value
C#
public MachineProfile.IP_ADDR_STRING SecondaryWinsServer
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING SecondaryWinsServer
C++/CLI
public:
MachineProfile.IP_ADDR_STRING SecondaryWinsServer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Type Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Type Field

Specifies the adapter type. The type is one of the following values. IF_OTHER_ADAPTERTYPE IF_ETHERNET_ADAPTERTYPE IF_TOKEN_RING_ADAPTERTYPE IF_FDDI_ADAPTERTYPE IF_PPP_ADAPTERTYPE IF_LOOPBACK_ADAPTERTYPE IF_SLIP_ADAPTERTYPE These values are defined in the header file IPIfCons.h

Syntax

Visual Basic (Declaration)
Public Type As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.Type

instance.Type = value
C#
public int Type
Managed Extensions for C++
public: int Type
C++/CLI
public:
int Type

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MachineProfile.IP_ADDR_STRING Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADDR_STRING Structure

declare the IP_ADDR_STRING structure

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile.IP_ADDR_STRING
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
C#
private struct MachineProfile.IP_ADDR_STRING : ValueType
Managed Extensions for C++
private __value struct MachineProfile.IP_ADDR_STRING : public ValueType
C++/CLI
private value class MachineProfile.IP_ADDR_STRING : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile.IP_ADDR_STRING

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
MachineProfile.IP_ADDR_STRING Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADDR_STRING Structure

The following tables list the members exposed by MachineProfile.IP_ADDR_STRING.

Public Fields

 | Name | Description
Public Field | Context | Specifies network table entry (NTE). This value corresponds to the NTEContext parameters in the AddIPAddress and DeleteIPAddress functions
Public Field | IpAddress | This array holds the IP address
Public Field | IpMask | This array holds the IP address mask
Public Field | Next | Pointer to the next IP_ADDR_STRING structure in the list
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.Web Send comments on this topic.
MachineProfile.IP_ADDR_STRING Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADDR_STRING Structure

For a list of all members of this type, see MachineProfile.IP_ADDR_STRING members.

Public Fields

 | Name | Description
Public Field | Context | Specifies network table entry (NTE). This value corresponds to the NTEContext parameters in the AddIPAddress and DeleteIPAddress functions
Public Field | IpAddress | This array holds the IP address
Public Field | IpMask | This array holds the IP address mask
Public Field | Next | Pointer to the next IP_ADDR_STRING structure in the list
Top

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Context Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADDR_STRING Structure : Context Field

Specifies network table entry (NTE). This value corresponds to the NTEContext parameters in the AddIPAddress and DeleteIPAddress functions

Syntax

Visual Basic (Declaration)
Public Context As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
Dim value As Integer

value = instance.Context

instance.Context = value
C#
public int Context
Managed Extensions for C++
public: int Context
C++/CLI
public:
int Context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
MachineProfile.IP_ADDR_STRING Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IpAddress Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADDR_STRING Structure : IpAddress Field

This array holds the IP address

Syntax

Visual Basic (Declaration)
Public IpAddress As Char()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
Dim value() As Char

value = instance.IpAddress

instance.IpAddress = value
C#
public char[] IpAddress
Managed Extensions for C++
public: char[] IpAddress
C++/CLI
public:
array<char> IpAddress

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
MachineProfile.IP_ADDR_STRING Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
IpMask Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADDR_STRING Structure : IpMask Field

This array holds the IP address mask

Syntax

Visual Basic (Declaration)
Public IpMask As Char()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
Dim value() As Char

value = instance.IpMask

instance.IpMask = value
C#
public char[] IpMask
Managed Extensions for C++
public: char[] IpMask
C++/CLI
public:
array<char> IpMask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
MachineProfile.IP_ADDR_STRING Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Next Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADDR_STRING Structure : Next Field

Pointer to the next IP_ADDR_STRING structure in the list

Syntax

Visual Basic (Declaration)
Public Next As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
Dim value As Integer

value = instance.Next

instance.Next = value
C#
public int Next
Managed Extensions for C++
public: int Next
C++/CLI
public:
int Next

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
MachineProfile.IP_ADDR_STRING Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
MachineProfile.TGuid Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.TGuid Structure

Summary of TGuid

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile.TGuid
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
C#
private struct MachineProfile.TGuid : ValueType
Managed Extensions for C++
private __value struct MachineProfile.TGuid : public ValueType
C++/CLI
private value class MachineProfile.TGuid : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile.TGuid

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Web Send comments on this topic.
MachineProfile.TGuid Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile.TGuid Structure

The following tables list the members exposed by MachineProfile.TGuid.

Public Fields

 | Name | Description
Public Field | a |
Public Field | b |
Public Field | d |
Public Field | m |
Public Field | m1 |
Public Field | m2 |
Public Field | m3 |
Public Field | m4 |
Public Field | m5 |
Public Field | m6 |
Public Field | s |
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.TGuid Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.Web Send comments on this topic.
MachineProfile.TGuid Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.TGuid Structure

For a list of all members of this type, see MachineProfile.TGuid members.

Public Fields

 | Name | Description
Public Field | a |
Public Field | b |
Public Field | d |
Public Field | m |
Public Field | m1 |
Public Field | m2 |
Public Field | m3 |
Public Field | m4 |
Public Field | m5 |
Public Field | m6 |
Public Field | s |
Top

See Also

Reference

MachineProfile.TGuid Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
a Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : a Field

Syntax

Visual Basic (Declaration)
Public a As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.a

instance.a = value
C#
public short a
Managed Extensions for C++
public: short a
C++/CLI
public:
short a

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
b Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : b Field

Syntax

Visual Basic (Declaration)
Public b As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.b

instance.b = value
C#
public short b
Managed Extensions for C++
public: short b
C++/CLI
public:
short b

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
d Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : d Field

Syntax

Visual Basic (Declaration)
Public d As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.d

instance.d = value
C#
public short d
Managed Extensions for C++
public: short d
C++/CLI
public:
short d

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
m Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m Field

Syntax

Visual Basic (Declaration)
Public m As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.m

instance.m = value
C#
public short m
Managed Extensions for C++
public: short m
C++/CLI
public:
short m

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
m1 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m1 Field

Syntax

Visual Basic (Declaration)
Public m1 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m1

instance.m1 = value
C#
public byte m1
Managed Extensions for C++
public: byte m1
C++/CLI
public:
byte m1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
m2 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m2 Field

Syntax

Visual Basic (Declaration)
Public m2 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m2

instance.m2 = value
C#
public byte m2
Managed Extensions for C++
public: byte m2
C++/CLI
public:
byte m2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
m3 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m3 Field

Syntax

Visual Basic (Declaration)
Public m3 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m3

instance.m3 = value
C#
public byte m3
Managed Extensions for C++
public: byte m3
C++/CLI
public:
byte m3

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
m4 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m4 Field

Syntax

Visual Basic (Declaration)
Public m4 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m4

instance.m4 = value
C#
public byte m4
Managed Extensions for C++
public: byte m4
C++/CLI
public:
byte m4

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
m5 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m5 Field

Syntax

Visual Basic (Declaration)
Public m5 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m5

instance.m5 = value
C#
public byte m5
Managed Extensions for C++
public: byte m5
C++/CLI
public:
byte m5

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
m6 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m6 Field

Syntax

Visual Basic (Declaration)
Public m6 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m6

instance.m6 = value
C#
public byte m6
Managed Extensions for C++
public: byte m6
C++/CLI
public:
byte m6

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
s Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : s Field

Syntax

Visual Basic (Declaration)
Public s As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.s

instance.s = value
C#
public short s
Managed Extensions for C++
public: short s
C++/CLI
public:
short s

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


$$INTRODUCTION$$ - %%projecttitle%%

Barcode4NET.CF Send comments on this topic.
Introduction
Welcome to Barcode4NET class library for .NetCF online help.


%%phrase%%

Barcode4NET.CF Send comments on this topic.
Barcode4NET.CF Assembly
The Barcode4NET.CF assembly includes the Barcode4NET class library for .NetCF 1.0 & 2.0.

Namespaces

Namespace | Description
O2S.Barcode4NET | Root namespace for all barcodes included in Barcode4NET toolkit for .NetCF.


$$GETTING_STARTED$$ - %%projecttitle%%

Barcode4NET.CF Send comments on this topic.
Getting Started
This online help will help you get started with Barcode4NET class library. It includes detailed information about all classes included in Barcode4NET class library.


%%ItemTitle%%

Barcode4NET.CF Send comments on this topic.
O2S.Barcode4NET Namespace (Barcode4NET.CF)
See Also Inheritance Hierarchy
Root namespace for all barcodes included in Barcode4NET toolkit for .NetCF.

Classes

Class | Description
Barcode | Defines the base class for all barcode types.
BarcodeEncodingException | Defines an exception that is thrown when the barcode data can not be encoded according to barcode's rules.
BasePDF417Barcode | Defines the base class for all PDF 417 barcodes.
BidimensionalBarcode | Defines the base class for all bidimensional barcodes.
CodabarBarcode | Defines a Codabar barcode.
CodablockFBarcode | Defines a CODABLOCK F barcode.
Code11Barcode | Defines a Code 11 barcode.
Code128ABarcode | Defines a Code 128 barcode.
Code128Barcode | Defines the base class for all Code 128 barcodes.
Code128BBarcode | Defines a Code 128 barcode.
Code128CBarcode | Defines a Code 128 barcode.
Code16KBarcode | Defines a Code 16K barcode.
Code25Barcode | Defines a Code 2 of 5 barcode.
Code25InterleavedBarcode | Defines an Interleaved 2 of 5 barcode.
Code39Barcode | Defines a Code 39 barcode.
Code39ExtendedBarcode | Defines an extended Code 39 barcode.
Code93Barcode | Defines a Code 93 barcode.
Code93ExtendedBarcode | Defines an extended Code 93 barcode.
COOP25Barcode | Defines a COOP 2 of 5 barcode.
DataMatrixBarcode | Defines a DataMatrix barcode.
EAN13Barcode | Defines the class for EAN-13 barcodes.
EAN8Barcode | Defines the class for EAN-8 barcodes.
EANBarcode | Defines the base class for EAN based barcodes.
HeightModulatedBarcode | Defines the base class for all height modulated barcodes.
IATA25Barcode | Defines a IATA 2 of 5 barcode.
ISBNBarcode | Defines the class for ISBN barcodes.
ISMNBarcode | Defines the class for ISMN barcodes.
ISSNBarcode | Defines the class for ISSN barcodes.
JAN13Barcode | Defines the class for JAN13 barcodes.
Matrix25Barcode | Defines a Matrix 2 of 5 barcode.
MicroPDF417Barcode | Defines a Micro PDF 417 barcode.
MSIPlesseyBarcode | Defines a MSI/Plessey barcode.
PDF417Barcode | Defines a PDF 417 barcode.
PlanetBarcode | Defines a Planet barcode.
PostnetBarcode | Defines a Postnet barcode.
RM4SCCBarcode | Defines a RM4SCC barcode.
SCC14Barcode | Defines a SCC-14 barcode.
SSCC18Barcode | Defines a SSCC-18 barcode.
UnidimensionalBarcode | Defines the base class for 1D barcodes.
UPCABarcode | Defines the class for UPC-A barcodes.
UPCEBarcode | Defines the class for UPC-E barcodes.

Enumerations

Enumeration | Description
BarcodeImageFormat | Specifies the available file formats for saving a barcode image.
BarcodeRotation | Specifies the available rotation angles of the barcode image.
BarcodeSymbology | Specifies the available barcode symbologies.
BarcodeTextLocation | Specifies the available locations for displaying text on a linear barcode.
DataMatrixEncoding | Specifies the available encoding modes for a DataMatrix barcode.
DataMatrixSymbolSize | Specifies the available sizes for a DataMatrix symbol.
MicroPDF417SymbolSize | Specifies the available sizes for a Micro PDF417 symbol.
PDF417DataCompactionMode | Specifies the available data compaction modes for a PDF417 barcode.
PDF417ErrorCorrectionLevel | Specifies the available error correction levels for a PDF417 barcode.
XYDimensionUnit | Specifies the unit of measure for the barcode's XDimension and YDimension properties.

See Also

Reference

Barcode4NET.CF Assembly


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Barcode Class

Defines the base class for all barcode types.

Syntax

Visual Basic (Declaration)
Public MustInherit Class Barcode
Visual Basic (Usage) Copy Code
Dim instance As Barcode
C#
public abstract class Barcode
Managed Extensions for C++
public __gc abstract class Barcode
C++/CLI
public ref class Barcode abstract

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.BidimensionalBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Barcode Class

The following tables list the members exposed by Barcode.

Public Constructors

 | Name | Description
Public Constructor | Barcode Constructor | Initializes a new Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode.
Public Property | BarColor | Gets or sets the color of the bars.
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode.
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties.
Public Property | Font | Gets or sets the font used to display the barcode text.
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode.
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode.
Public Property | SerialNumber | Gets or sets the serial number.
Public Property | TextColor | Gets or sets the color of the barcode text.
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode.
Public Property | XDimension | Gets or sets the width of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface.
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution.
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer.
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode.
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format.
Top

See Also

Reference

Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : Barcode Constructor

Initializes a new Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Barcode()
C#
public Barcode()
Managed Extensions for C++
public: Barcode();
C++/CLI
public:
Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Barcode Class

For a list of all members of this type, see Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface.
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution.
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer.
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode.
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format.
Top

See Also

Reference

Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Draw Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : Draw Method

Draws the barcode on a graphics surface.

Overload List

Overload | Description
Draw(Graphics) | Draws the barcode on a graphics surface.
Draw(Graphics,Int32,Int32) | Draws the barcode on a graphics surface.
Draw(Graphics,Single,Single) | Draws the barcode on a graphics surface.

Exceptions

Exception | Description
BarcodeEncodingException | Thrown when the barcode can not encode the given data.

Remarks

This method draws the barcode on a graphics surface. The top left corner of the barcode is drawn at (0, 0).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Draw(Graphics) Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class > Draw Method : Draw(Graphics) Method

g
The Graphics surface to draw the barcode on.
Draws the barcode on a graphics surface.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Draw( _
   ByVal g As Graphics _
)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim g As Graphics

instance.Draw(g)
C#
public void Draw(
   Graphics g
)
Managed Extensions for C++
public: void Draw(
   Graphics g
)
C++/CLI
public:
void Draw(
   Graphics g
)

Parameters

g
The Graphics surface to draw the barcode on.

Exceptions

Exception | Description
BarcodeEncodingException | Thrown when the barcode can not encode the given data.

Remarks

This method draws the barcode on a graphics surface. The top left corner of the barcode is drawn at (0, 0).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Draw(Graphics,Int32,Int32) Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class > Draw Method : Draw(Graphics,Int32,Int32) Method

g
The Graphics surface to draw the barcode on.
x
The X coordinate of the top left corner of the barcode.
y
The Y coordinate of the top left corner of the barcode.
Draws the barcode on a graphics surface.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Draw( _
   ByVal g As Graphics, _
   ByVal x As Integer, _
   ByVal y As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim g As Graphics
Dim x As Integer
Dim y As Integer

instance.Draw(g, x, y)
C#
public void Draw(
   Graphics g,
   int x,
   int y
)
Managed Extensions for C++
public: void Draw(
   Graphics g,
   int x,
   int y
)
C++/CLI
public:
void Draw(
   Graphics g,
   int x,
   int y
)

Parameters

g
The Graphics surface to draw the barcode on.
x
The X coordinate of the top left corner of the barcode.
y
The Y coordinate of the top left corner of the barcode.

Exceptions

Exception | Description
BarcodeEncodingException | Thrown when the barcode can not encode the given data.

Remarks

This method draws the barcode on a graphics surface. The top left corner of the barcode is drawn at (x, y).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Draw(Graphics,Single,Single) Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class > Draw Method : Draw(Graphics,Single,Single) Method

g
The Graphics surface to draw the barcode on.
x
The X coordinate of the top left corner of the barcode.
y
The Y coordinate of the top left corner of the barcode.
Draws the barcode on a graphics surface.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Draw( _
   ByVal g As Graphics, _
   ByVal x As Single, _
   ByVal y As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim g As Graphics
Dim x As Single
Dim y As Single

instance.Draw(g, x, y)
C#
public void Draw(
   Graphics g,
   float x,
   float y
)
Managed Extensions for C++
public: void Draw(
   Graphics g,
   float x,
   float y
)
C++/CLI
public:
void Draw(
   Graphics g,
   float x,
   float y
)

Parameters

g
The Graphics surface to draw the barcode on.
x
The X coordinate of the top left corner of the barcode.
y
The Y coordinate of the top left corner of the barcode.

Exceptions

Exception | Description
BarcodeEncodingException | Thrown when the barcode can not encode the given data.

Remarks

This method draws the barcode on a graphics surface. The top left corner of the barcode is drawn at (x, y).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
GetImage Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : GetImage Method

Gets the image of the barcode at the current graphics resolution.

Syntax

Visual Basic (Declaration)
Public Function GetImage() As Bitmap
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Bitmap

value = instance.GetImage()
C#
public Bitmap GetImage()
Managed Extensions for C++
public: Bitmap GetImage();
C++/CLI
public:
Bitmap GetImage();

Return Value

A Bitmap object with the barcode image or null (Nothing in VB.NET) if the data can not be encoded as barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
GetSize Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : GetSize Method

Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer.

Syntax

Visual Basic (Declaration)
Public Function GetSize() As SizeF
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As SizeF

value = instance.GetSize()
C#
public SizeF GetSize()
Managed Extensions for C++
public: SizeF GetSize();
C++/CLI
public:
SizeF GetSize();

Return Value

A SizeF structure with the size of the barcode image.
A SizeF structure with the size of the barcode image.

Remarks

If either the Width or the Height properties of the returned structure are -1, then the data can not be encoded as a barcode and an exception will be thrown when drawing the barcode.
If the DimensionUnit property is Pixel, then the resolution has no effect because all the dimensions are already measured in pixels.
If either the Width or the Height properties of the returned structure are -1, then the data can not be encoded as a barcode and an exception will be thrown when drawing the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
IsValidCharacterCode Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : IsValidCharacterCode Method

characterCode
The character code to test.
Gets whether the given character code can be encoded by the barcode.

Syntax

Visual Basic (Declaration)
Public Overridable Function IsValidCharacterCode( _
   ByVal characterCode As Byte _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim characterCode As Byte
Dim value As Boolean

value = instance.IsValidCharacterCode(characterCode)
C#
public virtual bool IsValidCharacterCode(
   byte characterCode
)
Managed Extensions for C++
public: virtual bool IsValidCharacterCode(
   byte characterCode
)
C++/CLI
public:
virtual bool IsValidCharacterCode(
   byte characterCode
)

Parameters

characterCode
The character code to test.

Return Value

True if the character code can be encoded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Save Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : Save Method

Saves this Barcode object to the specified file in the specified format.

Overload List

Overload | Description
Save(String,BarcodeImageFormat,Single) | Saves this Barcode object to the specified file in the specified format.
Save(Stream,BarcodeImageFormat,Single) | Saves this Barcode object to the specified stream in the specified format.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when dpi is 0 and DimensionUnit is different from Pixel.

Remarks

The dpi parameter has effect only on raster image formats (Bmp, Gif, Jpeg, Png, Tiff) and only if DimensionUnit is not Pixel.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Save(String,BarcodeImageFormat,Single) Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class > Save Method : Save(String,BarcodeImageFormat,Single) Method

fileName
A string that contains the name of the file to which to save this Barcode object.
barcodeImageFormat
The format of barcode image file.
dpi
The resolution for barcode image.
Saves this Barcode object to the specified file in the specified format.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal fileName As String, _
   ByVal barcodeImageFormat As BarcodeImageFormat, _
   ByVal dpi As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim fileName As String
Dim barcodeImageFormat As BarcodeImageFormat
Dim dpi As Single

instance.Save(fileName, barcodeImageFormat, dpi)
C#
public void Save(
   string fileName,
   BarcodeImageFormat barcodeImageFormat,
   float dpi
)
Managed Extensions for C++
public: void Save(
   string* fileName,
   BarcodeImageFormat barcodeImageFormat,
   float dpi
)
C++/CLI
public:
void Save(
   String^ fileName,
   BarcodeImageFormat barcodeImageFormat,
   float dpi
)

Parameters

fileName
A string that contains the name of the file to which to save this Barcode object.
barcodeImageFormat
The format of barcode image file.
dpi
The resolution for barcode image.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when dpi is 0 and DimensionUnit is different from Pixel.

Remarks

The dpi parameter has effect only on raster image formats (Bmp, Gif, Jpeg, Png, Tiff) and only if DimensionUnit is not Pixel.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Save(Stream,BarcodeImageFormat,Single) Method
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class > Save Method : Save(Stream,BarcodeImageFormat,Single) Method

stream
The Stream where the Barcode object will be saved.
barcodeImageFormat
The format of barcode image file.
dpi
The resolution for barcode image.
Saves this Barcode object to the specified stream in the specified format.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream, _
   ByVal barcodeImageFormat As BarcodeImageFormat, _
   ByVal dpi As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim stream As Stream
Dim barcodeImageFormat As BarcodeImageFormat
Dim dpi As Single

instance.Save(stream, barcodeImageFormat, dpi)
C#
public void Save(
   Stream stream,
   BarcodeImageFormat barcodeImageFormat,
   float dpi
)
Managed Extensions for C++
public: void Save(
   Stream* stream,
   BarcodeImageFormat barcodeImageFormat,
   float dpi
)
C++/CLI
public:
void Save(
   Stream^ stream,
   BarcodeImageFormat barcodeImageFormat,
   float dpi
)

Parameters

stream
The Stream where the Barcode object will be saved.
barcodeImageFormat
The format of barcode image file.
dpi
The resolution for barcode image.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when dpi is 0 and DimensionUnit is different from Pixel.

Remarks

The dpi parameter has effect only on raster image formats (Bmp, Gif, Jpeg, Png, Tiff) and only if DimensionUnit is not Pixel.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Barcode Class

For a list of all members of this type, see Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode.
Public Property | BarColor | Gets or sets the color of the bars.
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode.
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties.
Public Property | Font | Gets or sets the font used to display the barcode text.
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode.
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode.
Public Property | SerialNumber | Gets or sets the serial number.
Public Property | TextColor | Gets or sets the color of the barcode text.
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode.
Public Property | XDimension | Gets or sets the width of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

See Also

Reference

Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
BackColor Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : BackColor Property

Gets or sets the background color of the barcode.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
public Color BackColor {get; set;}
Managed Extensions for C++
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
C++/CLI
public:
property Color BackColor {
   Color get();
   void set (Color value);
}

Return Value

A Color object specifying the background color of barcode.

Remarks

If this property is Empty, then the barcode's background will be transparent. Default barcode background color is white.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
BarColor Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : BarColor Property

Gets or sets the color of the bars.

Syntax

Visual Basic (Declaration)
Public Property BarColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Color

instance.BarColor = value

value = instance.BarColor
C#
public Color BarColor {get; set;}
Managed Extensions for C++
public: __property Color get_BarColor();
public: __property void set_BarColor(
   Color value
);
C++/CLI
public:
property Color BarColor {
   Color get();
   void set (Color value);
}

Return Value

A Color object specifying the color of the bars.

Remarks

If this property is Empty, then no bars are shown. Default bars color is black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
BottomQuietZone Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : BottomQuietZone Property

Gets or sets the bottom quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property BottomQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Single

instance.BottomQuietZone = value

value = instance.BottomQuietZone
C#
public float BottomQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_BottomQuietZone();
public: __property void set_BottomQuietZone(
   float value
);
C++/CLI
public:
property float BottomQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of bottom quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the bottom quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Data Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : Data Property

Gets or sets the string to be encoded as barcode.

Syntax

Visual Basic (Declaration)
Public Property Data As String
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As String

instance.Data = value

value = instance.Data
C#
public string Data {get; set;}
Managed Extensions for C++
public: __property string* get_Data();
public: __property void set_Data(
   string* value
);
C++/CLI
public:
property String^ Data {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the value to be encoded as barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length (applies to some barcodes only).

Remarks

The characters allowed to be encoded are defined by each barcode type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
DimensionUnit Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : DimensionUnit Property

Gets or sets the measure unit for the XDimension and YDimension properties.

Syntax

Visual Basic (Declaration)
Public Property DimensionUnit As XYDimensionUnit
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As XYDimensionUnit

instance.DimensionUnit = value

value = instance.DimensionUnit
C#
public XYDimensionUnit DimensionUnit {get; set;}
Managed Extensions for C++
public: __property XYDimensionUnit get_DimensionUnit();
public: __property void set_DimensionUnit(
   XYDimensionUnit value
);
C++/CLI
public:
property XYDimensionUnit DimensionUnit {
   XYDimensionUnit get();
   void set (XYDimensionUnit value);
}

Return Value

A XYDimensionUnit enumeration member specifying the measure unit for the XDimension and YDimension properties.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Font Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : Font Property

Gets or sets the font used to display the barcode text.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Font

instance.Font = value

value = instance.Font
C#
public Font Font {get; set;}
Managed Extensions for C++
public: __property Font get_Font();
public: __property void set_Font(
   Font value
);
C++/CLI
public:
property Font Font {
   Font get();
   void set (Font value);
}

Return Value

A Font object used to display the barcode text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
LeftQuietZone Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : LeftQuietZone Property

Gets or sets the left quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property LeftQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Single

instance.LeftQuietZone = value

value = instance.LeftQuietZone
C#
public float LeftQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_LeftQuietZone();
public: __property void set_LeftQuietZone(
   float value
);
C++/CLI
public:
property float LeftQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of left quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the left quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
RightQuietZone Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : RightQuietZone Property

Gets or sets the right quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property RightQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Single

instance.RightQuietZone = value

value = instance.RightQuietZone
C#
public float RightQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_RightQuietZone();
public: __property void set_RightQuietZone(
   float value
);
C++/CLI
public:
property float RightQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of right quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the right quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
SerialNumber Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : SerialNumber Property

Gets or sets the serial number.

Syntax

Visual Basic (Declaration)
Public Property SerialNumber As String
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As String

instance.SerialNumber = value

value = instance.SerialNumber
C#
public string SerialNumber {get; set;}
Managed Extensions for C++
public: __property string* get_SerialNumber();
public: __property void set_SerialNumber(
   string* value
);
C++/CLI
public:
property String^ SerialNumber {
   String^ get();
   void set (String^ value);
}

Return Value

The Barcode4NET serial number.

Remarks

The serial number unlocks the Barcode4NET library and removes the TRIAL watermark from the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
TextColor Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : TextColor Property

Gets or sets the color of the barcode text.

Syntax

Visual Basic (Declaration)
Public Property TextColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Color

instance.TextColor = value

value = instance.TextColor
C#
public Color TextColor {get; set;}
Managed Extensions for C++
public: __property Color get_TextColor();
public: __property void set_TextColor(
   Color value
);
C++/CLI
public:
property Color TextColor {
   Color get();
   void set (Color value);
}

Return Value

A Color object specifying the text color.

Remarks

If this property is Empty, then no text is shown. Default text color is black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
TopQuietZone Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : TopQuietZone Property

Gets or sets the top quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property TopQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Single

instance.TopQuietZone = value

value = instance.TopQuietZone
C#
public float TopQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_TopQuietZone();
public: __property void set_TopQuietZone(
   float value
);
C++/CLI
public:
property float TopQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of top quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the top quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
XDimension Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : XDimension Property

Gets or sets the width of a narrow bar.

Syntax

Visual Basic (Declaration)
Public Property XDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Single

instance.XDimension = value

value = instance.XDimension
C#
public float XDimension {get; set;}
Managed Extensions for C++
public: __property float get_XDimension();
public: __property void set_XDimension(
   float value
);
C++/CLI
public:
property float XDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of a narrow bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.
The recommended width of a narrow bar is 12 mills. Depending on the barcode printer resolution and quality of barcode scanner, the XDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower XDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
YDimension Property
See Also
[image]
O2S.Barcode4NET Namespace > Barcode Class : YDimension Property

Gets or sets the height of a bar.

Syntax

Visual Basic (Declaration)
Public Overridable Property YDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As Barcode
Dim value As Single

instance.YDimension = value

value = instance.YDimension
C#
public virtual float YDimension {get; set;}
Managed Extensions for C++
public: __property virtual float get_YDimension();
public: __property virtual void set_YDimension(
   float value
);
C++/CLI
public:
virtual property float YDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Barcode Class
Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
BarcodeEncodingException Class
See Also Members
[image]
O2S.Barcode4NET Namespace : BarcodeEncodingException Class

Defines an exception that is thrown when the barcode data can not be encoded according to barcode's rules.

Syntax

Visual Basic (Declaration)
Public Class BarcodeEncodingException
   Inherits ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As BarcodeEncodingException
C#
public class BarcodeEncodingException : ApplicationException
Managed Extensions for C++
public __gc class BarcodeEncodingException : public ApplicationException
C++/CLI
public ref class BarcodeEncodingException : public ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Barcode4NET.BarcodeEncodingException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeEncodingException Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
BarcodeEncodingException Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : BarcodeEncodingException Class

The following tables list the members exposed by BarcodeEncodingException.

Public Constructors

 | Name | Description
Public Constructor | BarcodeEncodingException Constructor | Initializes a new BarcodeEncodingException object with the specified message.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

BarcodeEncodingException Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
BarcodeEncodingException Constructor
See Also
[image]
O2S.Barcode4NET Namespace > BarcodeEncodingException Class : BarcodeEncodingException Constructor

message
The exception message.
Initializes a new BarcodeEncodingException object with the specified message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As BarcodeEncodingException(message)
C#
public BarcodeEncodingException(
   string message
)
Managed Extensions for C++
public: BarcodeEncodingException(
   string* message
)
C++/CLI
public:
BarcodeEncodingException(
   String^ message
)

Parameters

message
The exception message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeEncodingException Class
BarcodeEncodingException Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
BasePDF417Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : BasePDF417Barcode Class

Defines the base class for all PDF 417 barcodes.

Syntax

Visual Basic (Declaration)
Public MustInherit Class BasePDF417Barcode
   Inherits BidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As BasePDF417Barcode
C#
public abstract class BasePDF417Barcode : BidimensionalBarcode
Managed Extensions for C++
public __gc abstract class BasePDF417Barcode : public BidimensionalBarcode
C++/CLI
public ref class BasePDF417Barcode abstract : public BidimensionalBarcode

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.BasePDF417Barcode
O2S.Barcode4NET.PDF417Barcode
O2S.Barcode4NET.PDF417Barcode
O2S.Barcode4NET.MicroPDF417Barcode
O2S.Barcode4NET.MicroPDF417Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BasePDF417Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
BasePDF417Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : BasePDF417Barcode Class

The following tables list the members exposed by BasePDF417Barcode.

Public Constructors

 | Name | Description
Public Constructor | BasePDF417Barcode Constructor | Initializes a new PDF417Barcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built.
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Overridden. Gets whether the given character code can be encoded by the barcode.
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

BasePDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
BasePDF417Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > BasePDF417Barcode Class : BasePDF417Barcode Constructor

Initializes a new PDF417Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BasePDF417Barcode()
C#
public BasePDF417Barcode()
Managed Extensions for C++
public: BasePDF417Barcode();
C++/CLI
public:
BasePDF417Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BasePDF417Barcode Class
BasePDF417Barcode Members


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
BasePDF417Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : BasePDF417Barcode Class

For a list of all members of this type, see BasePDF417Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Overridden. Gets whether the given character code can be encoded by the barcode.
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

BasePDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
IsValidCharacterCode Method
See Also
[image]
O2S.Barcode4NET Namespace > BasePDF417Barcode Class : IsValidCharacterCode Method

characterCode
The character code to test.
Gets whether the given character code can be encoded by the barcode.

Syntax

Visual Basic (Declaration)
Overrides Public Function IsValidCharacterCode( _
   ByVal characterCode As Byte _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasePDF417Barcode
Dim characterCode As Byte
Dim value As Boolean

value = instance.IsValidCharacterCode(characterCode)
C#
public override bool IsValidCharacterCode(
   byte characterCode
)
Managed Extensions for C++
public: bool IsValidCharacterCode(
   byte characterCode
) override
C++/CLI
public:
bool IsValidCharacterCode(
   byte characterCode
) override

Parameters

characterCode
The character code to test.

Return Value

True if the character code can be encoded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BasePDF417Barcode Class
BasePDF417Barcode Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
BasePDF417Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : BasePDF417Barcode Class

For a list of all members of this type, see BasePDF417Barcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built.
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

BasePDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
CompactionMode Property
See Also
[image]
O2S.Barcode4NET Namespace > BasePDF417Barcode Class : CompactionMode Property

Gets or sets the data compaction mode for this barcode.

Syntax

Visual Basic (Declaration)
Public Property CompactionMode As PDF417DataCompactionMode
Visual Basic (Usage) Copy Code
Dim instance As BasePDF417Barcode
Dim value As PDF417DataCompactionMode

instance.CompactionMode = value

value = instance.CompactionMode
C#
public PDF417DataCompactionMode CompactionMode {get; set;}
Managed Extensions for C++
public: __property PDF417DataCompactionMode get_CompactionMode();
public: __property void set_CompactionMode(
   PDF417DataCompactionMode value
);
C++/CLI
public:
property PDF417DataCompactionMode CompactionMode {
   PDF417DataCompactionMode get();
   void set (PDF417DataCompactionMode value);
}

Return Value

A PDF417DataCompactionMode enumeration member specifying the data compaction mode used in this barcode.

Remarks

The Text compaction mode provides a 2:1 compaction ratio when using only ASCII characters from 0x20 to 0x7F. The Numeric compaction mode provides a 2.93:1 compaction ratio when using only digits (0x30 to 0x39). Byte compaction mode provides a 1.2:1 compaction ratio when using any 8bit character.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BasePDF417Barcode Class
BasePDF417Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
IsValid Property
See Also
[image]
O2S.Barcode4NET Namespace > BasePDF417Barcode Class : IsValid Property

Gets a value indicating whether a valid barcode can be built.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsValid As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasePDF417Barcode
Dim value As Boolean

value = instance.IsValid
C#
public bool IsValid {get;}
Managed Extensions for C++
public: __property bool get_IsValid();
C++/CLI
public:
property bool IsValid {
   bool get();
}

Return Value

True if the barcode can be built, false otherwise.

Remarks

The following items are considered when building the barcode: barcode data, rows, columns and error correction level.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BasePDF417Barcode Class
BasePDF417Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
BidimensionalBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : BidimensionalBarcode Class

Defines the base class for all bidimensional barcodes.

Syntax

Visual Basic (Declaration)
Public MustInherit Class BidimensionalBarcode
   Inherits Barcode
Visual Basic (Usage) Copy Code
Dim instance As BidimensionalBarcode
C#
public abstract class BidimensionalBarcode : Barcode
Managed Extensions for C++
public __gc abstract class BidimensionalBarcode : public Barcode
C++/CLI
public ref class BidimensionalBarcode abstract : public Barcode

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.DataMatrixBarcode
O2S.Barcode4NET.DataMatrixBarcode
O2S.Barcode4NET.Code16KBarcode
O2S.Barcode4NET.Code16KBarcode
O2S.Barcode4NET.CodablockFBarcode
O2S.Barcode4NET.CodablockFBarcode
O2S.Barcode4NET.BasePDF417Barcode
O2S.Barcode4NET.BasePDF417Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BidimensionalBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
BidimensionalBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : BidimensionalBarcode Class

The following tables list the members exposed by BidimensionalBarcode.

Public Constructors

 | Name | Description
Public Constructor | BidimensionalBarcode Constructor | Initializes a new BidimensionalBarcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

BidimensionalBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
BidimensionalBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > BidimensionalBarcode Class : BidimensionalBarcode Constructor

Initializes a new BidimensionalBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BidimensionalBarcode()
C#
public BidimensionalBarcode()
Managed Extensions for C++
public: BidimensionalBarcode();
C++/CLI
public:
BidimensionalBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BidimensionalBarcode Class
BidimensionalBarcode Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
BidimensionalBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : BidimensionalBarcode Class

For a list of all members of this type, see BidimensionalBarcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

BidimensionalBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
AlternateData Property
See Also Example
[image]
O2S.Barcode4NET Namespace > BidimensionalBarcode Class : AlternateData Property

Gets or sets the alternate data to encode as a barcode.

Syntax

Visual Basic (Declaration)
Public Property AlternateData As Byte()
Visual Basic (Usage) Copy Code
Dim instance As BidimensionalBarcode
Dim value() As Byte

instance.AlternateData = value

value = instance.AlternateData
C#
public byte[] AlternateData {get; set;}
Managed Extensions for C++
public: __property byte[] get_AlternateData();
public: __property void set_AlternateData(
   byte[] value
);
C++/CLI
public:
property array<byte> AlternateData {
   array<byte> get();
   void set (bytearray<value> value);
}

Return Value

A byte array specifying the data to be encoded as a barcode.

Example

The following line of code shows how to encode a Unicode string:
C# Copy Code
...<br/>
barcode.AlternateData = Encoding.Unicode.GetBytes("my unicode string");
...<br/>

Remarks

Barcodes were designed to work with 8bit characters. Because .NET strings are Unicode, when they are converted to 8bit characters (using ISO 8859-1 encoding) the Unicode characters are removed. This property allows you to specify directly the byte array to encode.
If both Data and AlternateData properties are specified, the AlternateData property is used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BidimensionalBarcode Class
BidimensionalBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
CodabarBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : CodabarBarcode Class

Defines a Codabar barcode.

Syntax

Visual Basic (Declaration)
Public Class CodabarBarcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As CodabarBarcode
C#
public class CodabarBarcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc class CodabarBarcode : public UnidimensionalBarcode
C++/CLI
public ref class CodabarBarcode : public UnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Codabar barcode: 0 1 2 3 4 5 6 7 8 9 - $ : / . +

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.CodabarBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodabarBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
CodabarBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : CodabarBarcode Class

The following tables list the members exposed by CodabarBarcode.

Public Constructors

 | Name | Description
Public Constructor | CodabarBarcode Constructor | Overloaded. Initializes a new CodabarBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

CodabarBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
CodabarBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > CodabarBarcode Class : CodabarBarcode Constructor

Initializes a new CodabarBarcode object.

Overload List

Overload | Description
CodabarBarcode Constructor() | Initializes a new CodabarBarcode object.
CodabarBarcode Constructor(String) | Initializes a new CodabarBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodabarBarcode Class
CodabarBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
CodabarBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > CodabarBarcode Class > CodabarBarcode Constructor : CodabarBarcode Constructor()

Initializes a new CodabarBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CodabarBarcode()
C#
public CodabarBarcode()
Managed Extensions for C++
public: CodabarBarcode();
C++/CLI
public:
CodabarBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodabarBarcode Class
CodabarBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
CodabarBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > CodabarBarcode Class > CodabarBarcode Constructor : CodabarBarcode Constructor(String)

data
The data to be encoded.
Initializes a new CodabarBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As CodabarBarcode(data)
C#
public CodabarBarcode(
   string data
)
Managed Extensions for C++
public: CodabarBarcode(
   string* data
)
C++/CLI
public:
CodabarBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodabarBarcode Class
CodabarBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
CodablockFBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : CodablockFBarcode Class

Defines a CODABLOCK F barcode.

Syntax

Visual Basic (Declaration)
Public Class CodablockFBarcode
   Inherits BidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As CodablockFBarcode
C#
public class CodablockFBarcode : BidimensionalBarcode
Managed Extensions for C++
public __gc class CodablockFBarcode : public BidimensionalBarcode
C++/CLI
public ref class CodablockFBarcode : public BidimensionalBarcode

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.CodablockFBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodablockFBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
CodablockFBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : CodablockFBarcode Class

The following tables list the members exposed by CodablockFBarcode.

Public Constructors

 | Name | Description
Public Constructor | CodablockFBarcode Constructor | Overloaded. Initializes a new CodablockFBarcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Overridden. Gets or sets the height of a barcode row.
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

CodablockFBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
CodablockFBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > CodablockFBarcode Class : CodablockFBarcode Constructor

Initializes a new CodablockFBarcode object.

Overload List

Overload | Description
CodablockFBarcode Constructor() | Initializes a new CodablockFBarcode object.
CodablockFBarcode Constructor(String) | Initializes a new CodablockFBarcode object with the given data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodablockFBarcode Class
CodablockFBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
CodablockFBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > CodablockFBarcode Class > CodablockFBarcode Constructor : CodablockFBarcode Constructor()

Initializes a new CodablockFBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CodablockFBarcode()
C#
public CodablockFBarcode()
Managed Extensions for C++
public: CodablockFBarcode();
C++/CLI
public:
CodablockFBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodablockFBarcode Class
CodablockFBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
CodablockFBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > CodablockFBarcode Class > CodablockFBarcode Constructor : CodablockFBarcode Constructor(String)

data
The data to be encoded.
Initializes a new CodablockFBarcode object with the given data.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As CodablockFBarcode(data)
C#
public CodablockFBarcode(
   string data
)
Managed Extensions for C++
public: CodablockFBarcode(
   string* data
)
C++/CLI
public:
CodablockFBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodablockFBarcode Class
CodablockFBarcode Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
CodablockFBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : CodablockFBarcode Class

For a list of all members of this type, see CodablockFBarcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Overridden. Gets or sets the height of a barcode row.
Top

See Also

Reference

CodablockFBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Columns Property
See Also
[image]
O2S.Barcode4NET Namespace > CodablockFBarcode Class : Columns Property

Gets or sets the number of columns in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As CodablockFBarcode
Dim value As Integer

instance.Columns = value

value = instance.Columns
C#
public int Columns {get; set;}
Managed Extensions for C++
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
C++/CLI
public:
property int Columns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 7 or greater than 65.

Remarks

The minimum number of columns in a CODABLOCK F barcode is 7 and the maximum number of columns is 65. This property includes the character subset selector, row indicator and row check columns.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodablockFBarcode Class
CodablockFBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Rows Property
See Also
[image]
O2S.Barcode4NET Namespace > CodablockFBarcode Class : Rows Property

Gets or sets the number of rows in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As CodablockFBarcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
public int Rows {get; set;}
Managed Extensions for C++
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
C++/CLI
public:
property int Rows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2, or greater than 44.

Remarks

The minimum number of rows in a CODABLOCK F barcode is 2 and the maximum number of rows is 44.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodablockFBarcode Class
CodablockFBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
YDimension Property
See Also
[image]
O2S.Barcode4NET Namespace > CodablockFBarcode Class : YDimension Property

Gets or sets the height of a barcode row.

Syntax

Visual Basic (Declaration)
Overrides Public Property YDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As CodablockFBarcode
Dim value As Single

instance.YDimension = value

value = instance.YDimension
C#
public override float YDimension {get; set;}
Managed Extensions for C++
public: __property float get_YDimension()override ;
public: __property void set_YDimension(
   float value
)override ;
C++/CLI
public:
property float YDimension override {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a barcode row.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The row height is specified using the "mills" measure unit. A mill is 1/1000th of an inch.
The minimum YDimension should be either 8*XDimension or 0.55*Columns+3, whichever is greater. If this property is 0, the row height will be computed automatically.
Depending on the barcode printer resolution and quality of barcode scanner, the YDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower YDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CodablockFBarcode Class
CodablockFBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code11Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code11Barcode Class

Defines a Code 11 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code11Barcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As Code11Barcode
C#
public class Code11Barcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc class Code11Barcode : public UnidimensionalBarcode
C++/CLI
public ref class Code11Barcode : public UnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Code 11 barcode: 0 1 2 3 4 5 6 7 8 9 -

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code11Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code11Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
Code11Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code11Barcode Class

The following tables list the members exposed by Code11Barcode.

Public Constructors

 | Name | Description
Public Constructor | Code11Barcode Constructor | Overloaded. Initializes a new Code11Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code11Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code11Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code11Barcode Class : Code11Barcode Constructor

Initializes a new Code11Barcode object.

Overload List

Overload | Description
Code11Barcode Constructor() | Initializes a new Code11Barcode object.
Code11Barcode Constructor(String) | Initializes a new Code11Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code11Barcode Class
Code11Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code11Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code11Barcode Class > Code11Barcode Constructor : Code11Barcode Constructor()

Initializes a new Code11Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code11Barcode()
C#
public Code11Barcode()
Managed Extensions for C++
public: Code11Barcode();
C++/CLI
public:
Code11Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code11Barcode Class
Code11Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code11Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code11Barcode Class > Code11Barcode Constructor : Code11Barcode Constructor(String)

data
The data to be encoded.
Initializes a new Code11Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code11Barcode(data)
C#
public Code11Barcode(
   string data
)
Managed Extensions for C++
public: Code11Barcode(
   string* data
)
C++/CLI
public:
Code11Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code11Barcode Class
Code11Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code128ABarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code128ABarcode Class

Defines a Code 128 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code128ABarcode
   Inherits Code128Barcode
Visual Basic (Usage) Copy Code
Dim instance As Code128ABarcode
C#
public class Code128ABarcode : Code128Barcode
Managed Extensions for C++
public __gc class Code128ABarcode : public Code128Barcode
C++/CLI
public ref class Code128ABarcode : public Code128Barcode

Remarks

This class defines a Code 128 barcode using the A character set. Only the following symbols are allowed in a Code 128 A barcode: NUL (\x00) SOH (\x01) STX (\x02) ETX (\x03) EOT (\x04) ENQ (\x05) ACK (\x06) BEL (\x07) BS (\x08) HT (\x09) LF (\x0A) VT (\x0B) FF (\x0C) CR (\x0D) SO (\x0E) SI (\x0F) DLE (\x10) DC1 (\x11) DC2 (\x12) DC3 (\x13) DC4 (\x14) NAK (\x15) SYN (\x16) ETB (\x17) CAN (\x18) EM (\x19) SUB (\x1A) ESC (\x1B) FS (\x1C) GS (\x1D) RS (\x1E) US (\x1F) SPACE ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _ FNC1 (\xF0) FNC2 (\xF1) FNC3 (\xF2) FNC4 (\xF3) SHIFT (\xF4).

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code128ABarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128ABarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
Code128ABarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code128ABarcode Class

The following tables list the members exposed by Code128ABarcode.

Public Constructors

 | Name | Description
Public Constructor | Code128ABarcode Constructor | Overloaded. Initializes a new Code128ABarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code128ABarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code128ABarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code128ABarcode Class : Code128ABarcode Constructor

Initializes a new Code128ABarcode object.

Overload List

Overload | Description
Code128ABarcode Constructor() | Initializes a new Code128ABarcode object.
Code128ABarcode Constructor(String) | Initializes a new Code128ABarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128ABarcode Class
Code128ABarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code128ABarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code128ABarcode Class > Code128ABarcode Constructor : Code128ABarcode Constructor()

Initializes a new Code128ABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code128ABarcode()
C#
public Code128ABarcode()
Managed Extensions for C++
public: Code128ABarcode();
C++/CLI
public:
Code128ABarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128ABarcode Class
Code128ABarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code128ABarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code128ABarcode Class > Code128ABarcode Constructor : Code128ABarcode Constructor(String)

data
The data to be encoded.
Initializes a new Code128ABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code128ABarcode(data)
C#
public Code128ABarcode(
   string data
)
Managed Extensions for C++
public: Code128ABarcode(
   string* data
)
C++/CLI
public:
Code128ABarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128ABarcode Class
Code128ABarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code128Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code128Barcode Class

Defines the base class for all Code 128 barcodes.

Syntax

Visual Basic (Declaration)
Public MustInherit Class Code128Barcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As Code128Barcode
C#
public abstract class Code128Barcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc abstract class Code128Barcode : public UnidimensionalBarcode
C++/CLI
public ref class Code128Barcode abstract : public UnidimensionalBarcode

Remarks

Code 128 allows to encode 102 symbols, grouped in 3 sets of symbols, A, B and C. Each symbol set is represented by its own barcode class: Code128ABarcode, Code128BBarcode and Code128CBarcode.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code128CBarcode
O2S.Barcode4NET.Code128CBarcode
O2S.Barcode4NET.Code128BBarcode
O2S.Barcode4NET.Code128BBarcode
O2S.Barcode4NET.Code128ABarcode
O2S.Barcode4NET.Code128ABarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
Code128Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code128Barcode Class

The following tables list the members exposed by Code128Barcode.

Public Constructors

 | Name | Description
Public Constructor | Code128Barcode Constructor | Overloaded. Initializes a new Code128Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code128Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code128Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code128Barcode Class : Code128Barcode Constructor

Initializes a new Code128Barcode object.

Overload List

Overload | Description
Code128Barcode Constructor() | Initializes a new Code128Barcode object.
Code128Barcode Constructor(String) | Initializes a new Code128Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128Barcode Class
Code128Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code128Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code128Barcode Class > Code128Barcode Constructor : Code128Barcode Constructor()

Initializes a new Code128Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code128Barcode()
C#
public Code128Barcode()
Managed Extensions for C++
public: Code128Barcode();
C++/CLI
public:
Code128Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128Barcode Class
Code128Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code128Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code128Barcode Class > Code128Barcode Constructor : Code128Barcode Constructor(String)

data
The data to be encoded.
Initializes a new Code128Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code128Barcode(data)
C#
public Code128Barcode(
   string data
)
Managed Extensions for C++
public: Code128Barcode(
   string* data
)
C++/CLI
public:
Code128Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128Barcode Class
Code128Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code128BBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code128BBarcode Class

Defines a Code 128 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code128BBarcode
   Inherits Code128Barcode
Visual Basic (Usage) Copy Code
Dim instance As Code128BBarcode
C#
public class Code128BBarcode : Code128Barcode
Managed Extensions for C++
public __gc class Code128BBarcode : public Code128Barcode
C++/CLI
public ref class Code128BBarcode : public Code128Barcode

Remarks

This class defines a Code 128 barcode using the B character set. Only the following symbols are allowed in a Code 128 B barcode: SPACE ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _ ` a b c d e f g h i j k l m n o p q r s t u v w x y z { | } ~ DEL (\x7F) FNC1 (\xF0) FNC2 (\xF1) FNC3 (\xF2) FNC4 (\xF3) SHIFT (\xF4).

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code128BBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128BBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
Code128BBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code128BBarcode Class

The following tables list the members exposed by Code128BBarcode.

Public Constructors

 | Name | Description
Public Constructor | Code128BBarcode Constructor | Overloaded. Initializes a new Code128BBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code128BBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code128BBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code128BBarcode Class : Code128BBarcode Constructor

Initializes a new Code128BBarcode object.

Overload List

Overload | Description
Code128BBarcode Constructor() | Initializes a new Code128BBarcode object.
Code128BBarcode Constructor(String) | Initializes a new Code128BBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128BBarcode Class
Code128BBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code128BBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code128BBarcode Class > Code128BBarcode Constructor : Code128BBarcode Constructor()

Initializes a new Code128BBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code128BBarcode()
C#
public Code128BBarcode()
Managed Extensions for C++
public: Code128BBarcode();
C++/CLI
public:
Code128BBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128BBarcode Class
Code128BBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code128BBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code128BBarcode Class > Code128BBarcode Constructor : Code128BBarcode Constructor(String)

data
The data to be encoded.
Initializes a new Code128BBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code128BBarcode(data)
C#
public Code128BBarcode(
   string data
)
Managed Extensions for C++
public: Code128BBarcode(
   string* data
)
C++/CLI
public:
Code128BBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128BBarcode Class
Code128BBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code128CBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code128CBarcode Class

Defines a Code 128 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code128CBarcode
   Inherits Code128Barcode
Visual Basic (Usage) Copy Code
Dim instance As Code128CBarcode
C#
public class Code128CBarcode : Code128Barcode
Managed Extensions for C++
public __gc class Code128CBarcode : public Code128Barcode
C++/CLI
public ref class Code128CBarcode : public Code128Barcode

Remarks

This class defines a Code 128 barcode using the C character set. Only the following symbols are allowed in a Code 128 C barcode: 0 1 2 3 4 5 6 7 8 9 FNC1 (\xF0).
Code 128 C encodes only numeric symbols at float density, each pair of digits is encoded using a single symbol.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code128CBarcode
O2S.Barcode4NET.SSCC18Barcode
O2S.Barcode4NET.SSCC18Barcode
O2S.Barcode4NET.SCC14Barcode
O2S.Barcode4NET.SCC14Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128CBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
Code128CBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code128CBarcode Class

The following tables list the members exposed by Code128CBarcode.

Public Constructors

 | Name | Description
Public Constructor | Code128CBarcode Constructor | Overloaded. Initializes a new Code128CBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code128CBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code128CBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code128CBarcode Class : Code128CBarcode Constructor

Initializes a new Code128CBarcode object.

Overload List

Overload | Description
Code128CBarcode Constructor() | Initializes a new Code128CBarcode object.
Code128CBarcode Constructor(String) | Initializes a new Code128CBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128CBarcode Class
Code128CBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code128CBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code128CBarcode Class > Code128CBarcode Constructor : Code128CBarcode Constructor()

Initializes a new Code128CBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code128CBarcode()
C#
public Code128CBarcode()
Managed Extensions for C++
public: Code128CBarcode();
C++/CLI
public:
Code128CBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128CBarcode Class
Code128CBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code128CBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code128CBarcode Class > Code128CBarcode Constructor : Code128CBarcode Constructor(String)

data
The data to be encoded.
Initializes a new Code128CBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code128CBarcode(data)
C#
public Code128CBarcode(
   string data
)
Managed Extensions for C++
public: Code128CBarcode(
   string* data
)
C++/CLI
public:
Code128CBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code128CBarcode Class
Code128CBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code16KBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code16KBarcode Class

Defines a Code 16K barcode.

Syntax

Visual Basic (Declaration)
Public Class Code16KBarcode
   Inherits BidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As Code16KBarcode
C#
public class Code16KBarcode : BidimensionalBarcode
Managed Extensions for C++
public __gc class Code16KBarcode : public BidimensionalBarcode
C++/CLI
public ref class Code16KBarcode : public BidimensionalBarcode

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.Code16KBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code16KBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
Code16KBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code16KBarcode Class

The following tables list the members exposed by Code16KBarcode.

Public Constructors

 | Name | Description
Public Constructor | Code16KBarcode Constructor | Overloaded. Initializes a new Code16KBarcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Columns | Gets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Overridden. Gets or sets the height of a barcode row.
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code16KBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code16KBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code16KBarcode Class : Code16KBarcode Constructor

Initializes a new Code16KBarcode object.

Overload List

Overload | Description
Code16KBarcode Constructor() | Initializes a new Code16KBarcode object.
Code16KBarcode Constructor(String) | Initializes a new Code16KBarcode object with the given data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code16KBarcode Class
Code16KBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code16KBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code16KBarcode Class > Code16KBarcode Constructor : Code16KBarcode Constructor()

Initializes a new Code16KBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code16KBarcode()
C#
public Code16KBarcode()
Managed Extensions for C++
public: Code16KBarcode();
C++/CLI
public:
Code16KBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code16KBarcode Class
Code16KBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code16KBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code16KBarcode Class > Code16KBarcode Constructor : Code16KBarcode Constructor(String)

data
The data to be encoded.
Initializes a new Code16KBarcode object with the given data.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code16KBarcode(data)
C#
public Code16KBarcode(
   string data
)
Managed Extensions for C++
public: Code16KBarcode(
   string* data
)
C++/CLI
public:
Code16KBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code16KBarcode Class
Code16KBarcode Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
Code16KBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code16KBarcode Class

For a list of all members of this type, see Code16KBarcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Columns | Gets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Overridden. Gets or sets the height of a barcode row.
Top

See Also

Reference

Code16KBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Columns Property
See Also
[image]
O2S.Barcode4NET Namespace > Code16KBarcode Class : Columns Property

Gets the number of columns in this barcode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As Code16KBarcode
Dim value As Integer

value = instance.Columns
C#
public int Columns {get;}
Managed Extensions for C++
public: __property int get_Columns();
C++/CLI
public:
property int Columns {
   int get();
}

Return Value

An integer value specifying the number of columns used by this barcode.

Remarks

A Code 16K barcode has always 5 columns.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code16KBarcode Class
Code16KBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Rows Property
See Also
[image]
O2S.Barcode4NET Namespace > Code16KBarcode Class : Rows Property

Gets or sets the number of rows in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As Code16KBarcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
public int Rows {get; set;}
Managed Extensions for C++
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
C++/CLI
public:
property int Rows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2 but not 0, or greater than 16.

Remarks

The minimum number of rows in a Code 16K barcode is 2 and the maximum number of rows is 16. If this property is 0, the number of rows is calculated automatically to accomodate the barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code16KBarcode Class
Code16KBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
YDimension Property
See Also
[image]
O2S.Barcode4NET Namespace > Code16KBarcode Class : YDimension Property

Gets or sets the height of a barcode row.

Syntax

Visual Basic (Declaration)
Overrides Public Property YDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As Code16KBarcode
Dim value As Single

instance.YDimension = value

value = instance.YDimension
C#
public override float YDimension {get; set;}
Managed Extensions for C++
public: __property float get_YDimension()override ;
public: __property void set_YDimension(
   float value
)override ;
C++/CLI
public:
property float YDimension override {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a barcode row.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The row height is specified using the "mills" measure unit. A mill is 1/1000th of an inch.
A minimum YDimension of 8*XDimension is recommended for ease of scanning. If this property is 0, the row height will be computed automatically.
Depending on the barcode printer resolution and quality of barcode scanner, the YDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower YDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code16KBarcode Class
Code16KBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code25Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code25Barcode Class

Defines a Code 2 of 5 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code25Barcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As Code25Barcode
C#
public class Code25Barcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc class Code25Barcode : public UnidimensionalBarcode
C++/CLI
public ref class Code25Barcode : public UnidimensionalBarcode

Remarks

Code 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Code 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code25Barcode
O2S.Barcode4NET.Matrix25Barcode
O2S.Barcode4NET.Matrix25Barcode
O2S.Barcode4NET.IATA25Barcode
O2S.Barcode4NET.IATA25Barcode
O2S.Barcode4NET.COOP25Barcode
O2S.Barcode4NET.COOP25Barcode
O2S.Barcode4NET.Code25InterleavedBarcode
O2S.Barcode4NET.Code25InterleavedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
Code25Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code25Barcode Class

The following tables list the members exposed by Code25Barcode.

Public Constructors

 | Name | Description
Public Constructor | Code25Barcode Constructor | Overloaded. Initializes a new Code25Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code25Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code25Barcode Class : Code25Barcode Constructor

Initializes a new Code25Barcode object.

Overload List

Overload | Description
Code25Barcode Constructor() | Initializes a new Code25Barcode object.
Code25Barcode Constructor(String) | Initializes a new Code25Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25Barcode Class
Code25Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code25Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code25Barcode Class > Code25Barcode Constructor : Code25Barcode Constructor()

Initializes a new Code25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code25Barcode()
C#
public Code25Barcode()
Managed Extensions for C++
public: Code25Barcode();
C++/CLI
public:
Code25Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25Barcode Class
Code25Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code25Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code25Barcode Class > Code25Barcode Constructor : Code25Barcode Constructor(String)

data
The data to be encoded.
Initializes a new Code25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code25Barcode(data)
C#
public Code25Barcode(
   string data
)
Managed Extensions for C++
public: Code25Barcode(
   string* data
)
C++/CLI
public:
Code25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25Barcode Class
Code25Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code25InterleavedBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code25InterleavedBarcode Class

Defines an Interleaved 2 of 5 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code25InterleavedBarcode
   Inherits Code25Barcode
Visual Basic (Usage) Copy Code
Dim instance As Code25InterleavedBarcode
C#
public class Code25InterleavedBarcode : Code25Barcode
Managed Extensions for C++
public __gc class Code25InterleavedBarcode : public Code25Barcode
C++/CLI
public ref class Code25InterleavedBarcode : public Code25Barcode

Remarks

Interleaved 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Interleaved 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code25Barcode
O2S.Barcode4NET.Code25InterleavedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25InterleavedBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
Code25InterleavedBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code25InterleavedBarcode Class

The following tables list the members exposed by Code25InterleavedBarcode.

Public Constructors

 | Name | Description
Public Constructor | Code25InterleavedBarcode Constructor | Overloaded. Initializes a new Code25InterleavedBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code25InterleavedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code25InterleavedBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code25InterleavedBarcode Class : Code25InterleavedBarcode Constructor

Initializes a new Code25InterleavedBarcode object.

Overload List

Overload | Description
Code25InterleavedBarcode Constructor() | Initializes a new Code25InterleavedBarcode object.
Code25InterleavedBarcode Constructor(String) | Initializes a new Code25InterleavedBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25InterleavedBarcode Class
Code25InterleavedBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code25InterleavedBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code25InterleavedBarcode Class > Code25InterleavedBarcode Constructor : Code25InterleavedBarcode Constructor()

Initializes a new Code25InterleavedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code25InterleavedBarcode()
C#
public Code25InterleavedBarcode()
Managed Extensions for C++
public: Code25InterleavedBarcode();
C++/CLI
public:
Code25InterleavedBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25InterleavedBarcode Class
Code25InterleavedBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code25InterleavedBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code25InterleavedBarcode Class > Code25InterleavedBarcode Constructor : Code25InterleavedBarcode Constructor(String)

data
The data to be encoded.
Initializes a new Code25InterleavedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code25InterleavedBarcode(data)
C#
public Code25InterleavedBarcode(
   string data
)
Managed Extensions for C++
public: Code25InterleavedBarcode(
   string* data
)
C++/CLI
public:
Code25InterleavedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code25InterleavedBarcode Class
Code25InterleavedBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code39Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code39Barcode Class

Defines a Code 39 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code39Barcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As Code39Barcode
C#
public class Code39Barcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc class Code39Barcode : public UnidimensionalBarcode
C++/CLI
public ref class Code39Barcode : public UnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Code 39 barcode: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
All alphabetic characters are uppercase. If lowercase characters are required, then a Code 39 Extended barcode must be used.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code39Barcode
O2S.Barcode4NET.Code39ExtendedBarcode
O2S.Barcode4NET.Code39ExtendedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
Code39Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code39Barcode Class

The following tables list the members exposed by Code39Barcode.

Public Constructors

 | Name | Description
Public Constructor | Code39Barcode Constructor | Overloaded. Initializes a new Code39Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code39Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code39Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code39Barcode Class : Code39Barcode Constructor

Initializes a new Code39Barcode object.

Overload List

Overload | Description
Code39Barcode Constructor() | Initializes a new Code39Barcode object.
Code39Barcode Constructor(String) | Initializes a new Code39Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39Barcode Class
Code39Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code39Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code39Barcode Class > Code39Barcode Constructor : Code39Barcode Constructor()

Initializes a new Code39Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code39Barcode()
C#
public Code39Barcode()
Managed Extensions for C++
public: Code39Barcode();
C++/CLI
public:
Code39Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39Barcode Class
Code39Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code39Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code39Barcode Class > Code39Barcode Constructor : Code39Barcode Constructor(String)

data
The data to be encoded.
Initializes a new Code39Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code39Barcode(data)
C#
public Code39Barcode(
   string data
)
Managed Extensions for C++
public: Code39Barcode(
   string* data
)
C++/CLI
public:
Code39Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39Barcode Class
Code39Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
Code39Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code39Barcode Class

For a list of all members of this type, see Code39Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code39Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
WideToNarrowRatio Property
See Also
[image]
O2S.Barcode4NET Namespace > Code39Barcode Class : WideToNarrowRatio Property

Gets or sets the ratio between wide bars and narrow bars.

Syntax

Visual Basic (Declaration)
Public Property WideToNarrowRatio As Single
Visual Basic (Usage) Copy Code
Dim instance As Code39Barcode
Dim value As Single

instance.WideToNarrowRatio = value

value = instance.WideToNarrowRatio
C#
public float WideToNarrowRatio {get; set;}
Managed Extensions for C++
public: __property float get_WideToNarrowRatio();
public: __property void set_WideToNarrowRatio(
   float value
);
C++/CLI
public:
property float WideToNarrowRatio {
   float get();
   void set (float value);
}

Return Value

A float value specifying the ratio between wide bars and narrow bars.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39Barcode Class
Code39Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code39ExtendedBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code39ExtendedBarcode Class

Defines an extended Code 39 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code39ExtendedBarcode
   Inherits Code39Barcode
Visual Basic (Usage) Copy Code
Dim instance As Code39ExtendedBarcode
C#
public class Code39ExtendedBarcode : Code39Barcode
Managed Extensions for C++
public __gc class Code39ExtendedBarcode : public Code39Barcode
C++/CLI
public ref class Code39ExtendedBarcode : public Code39Barcode

Remarks

All 128 ASCII characters can be encoded in an extended Code 39 barcode.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code39Barcode
O2S.Barcode4NET.Code39ExtendedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39ExtendedBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
Code39ExtendedBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code39ExtendedBarcode Class

The following tables list the members exposed by Code39ExtendedBarcode.

Public Constructors

 | Name | Description
Public Constructor | Code39ExtendedBarcode Constructor | Overloaded. Initializes a new Code39ExtendedBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from Code39Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code39ExtendedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code39ExtendedBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code39ExtendedBarcode Class : Code39ExtendedBarcode Constructor

Initializes a new Code39ExtendedBarcode object.

Overload List

Overload | Description
Code39ExtendedBarcode Constructor() | Initializes a new Code39ExtendedBarcode object.
Code39ExtendedBarcode Constructor(String) | Initializes a new Code39ExtendedBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39ExtendedBarcode Class
Code39ExtendedBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code39ExtendedBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code39ExtendedBarcode Class > Code39ExtendedBarcode Constructor : Code39ExtendedBarcode Constructor()

Initializes a new Code39ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code39ExtendedBarcode()
C#
public Code39ExtendedBarcode()
Managed Extensions for C++
public: Code39ExtendedBarcode();
C++/CLI
public:
Code39ExtendedBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39ExtendedBarcode Class
Code39ExtendedBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code39ExtendedBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code39ExtendedBarcode Class > Code39ExtendedBarcode Constructor : Code39ExtendedBarcode Constructor(String)

data
The data to be encoded.
Initializes a new Code39ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code39ExtendedBarcode(data)
C#
public Code39ExtendedBarcode(
   string data
)
Managed Extensions for C++
public: Code39ExtendedBarcode(
   string* data
)
C++/CLI
public:
Code39ExtendedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code39ExtendedBarcode Class
Code39ExtendedBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code93Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code93Barcode Class

Defines a Code 93 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code93Barcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As Code93Barcode
C#
public class Code93Barcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc class Code93Barcode : public UnidimensionalBarcode
C++/CLI
public ref class Code93Barcode : public UnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Code 93 barcode: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
All alphabetic characters are uppercase. If lowercase characters are required, then a Code 93 Extended barcode must be used.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code93Barcode
O2S.Barcode4NET.Code93ExtendedBarcode
O2S.Barcode4NET.Code93ExtendedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
Code93Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code93Barcode Class

The following tables list the members exposed by Code93Barcode.

Public Constructors

 | Name | Description
Public Constructor | Code93Barcode Constructor | Overloaded. Initializes a new Code93Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code93Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code93Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code93Barcode Class : Code93Barcode Constructor

Initializes a new Code93Barcode object.

Overload List

Overload | Description
Code93Barcode Constructor() | Initializes a new Code93Barcode object.
Code93Barcode Constructor(String) | Initializes a new Code93Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93Barcode Class
Code93Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code93Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code93Barcode Class > Code93Barcode Constructor : Code93Barcode Constructor()

Initializes a new Code93Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code93Barcode()
C#
public Code93Barcode()
Managed Extensions for C++
public: Code93Barcode();
C++/CLI
public:
Code93Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93Barcode Class
Code93Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code93Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code93Barcode Class > Code93Barcode Constructor : Code93Barcode Constructor(String)

data
The data to be encoded.
Initializes a new Code93Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code93Barcode(data)
C#
public Code93Barcode(
   string data
)
Managed Extensions for C++
public: Code93Barcode(
   string* data
)
C++/CLI
public:
Code93Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93Barcode Class
Code93Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code93ExtendedBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Code93ExtendedBarcode Class

Defines an extended Code 93 barcode.

Syntax

Visual Basic (Declaration)
Public Class Code93ExtendedBarcode
   Inherits Code93Barcode
Visual Basic (Usage) Copy Code
Dim instance As Code93ExtendedBarcode
C#
public class Code93ExtendedBarcode : Code93Barcode
Managed Extensions for C++
public __gc class Code93ExtendedBarcode : public Code93Barcode
C++/CLI
public ref class Code93ExtendedBarcode : public Code93Barcode

Remarks

All 128 ASCII characters can be encoded in an extended Code 93 barcode.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code93Barcode
O2S.Barcode4NET.Code93ExtendedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93ExtendedBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
Code93ExtendedBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Code93ExtendedBarcode Class

The following tables list the members exposed by Code93ExtendedBarcode.

Public Constructors

 | Name | Description
Public Constructor | Code93ExtendedBarcode Constructor | Overloaded. Initializes a new Code93ExtendedBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code93ExtendedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code93ExtendedBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Code93ExtendedBarcode Class : Code93ExtendedBarcode Constructor

Initializes a new Code93ExtendedBarcode object.

Overload List

Overload | Description
Code93ExtendedBarcode Constructor() | Initializes a new Code93ExtendedBarcode object.
Code93ExtendedBarcode Constructor(String) | Initializes a new Code93ExtendedBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93ExtendedBarcode Class
Code93ExtendedBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code93ExtendedBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Code93ExtendedBarcode Class > Code93ExtendedBarcode Constructor : Code93ExtendedBarcode Constructor()

Initializes a new Code93ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Code93ExtendedBarcode()
C#
public Code93ExtendedBarcode()
Managed Extensions for C++
public: Code93ExtendedBarcode();
C++/CLI
public:
Code93ExtendedBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93ExtendedBarcode Class
Code93ExtendedBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Code93ExtendedBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Code93ExtendedBarcode Class > Code93ExtendedBarcode Constructor : Code93ExtendedBarcode Constructor(String)

data
The data to be encoded.
Initializes a new Code93ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Code93ExtendedBarcode(data)
C#
public Code93ExtendedBarcode(
   string data
)
Managed Extensions for C++
public: Code93ExtendedBarcode(
   string* data
)
C++/CLI
public:
Code93ExtendedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Code93ExtendedBarcode Class
Code93ExtendedBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
COOP25Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : COOP25Barcode Class

Defines a COOP 2 of 5 barcode.

Syntax

Visual Basic (Declaration)
Public Class COOP25Barcode
   Inherits Code25Barcode
Visual Basic (Usage) Copy Code
Dim instance As COOP25Barcode
C#
public class COOP25Barcode : Code25Barcode
Managed Extensions for C++
public __gc class COOP25Barcode : public Code25Barcode
C++/CLI
public ref class COOP25Barcode : public Code25Barcode

Remarks

COOP 2 of 5 is a numeric symbology. Only the following symbols are allowed in a COOP 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code25Barcode
O2S.Barcode4NET.COOP25Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

COOP25Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
COOP25Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : COOP25Barcode Class

The following tables list the members exposed by COOP25Barcode.

Public Constructors

 | Name | Description
Public Constructor | COOP25Barcode Constructor | Overloaded. Initializes a new COOP25Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

COOP25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
COOP25Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > COOP25Barcode Class : COOP25Barcode Constructor

Initializes a new COOP25Barcode object.

Overload List

Overload | Description
COOP25Barcode Constructor() | Initializes a new COOP25Barcode object.
COOP25Barcode Constructor(String) | Initializes a new COOP25Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

COOP25Barcode Class
COOP25Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
COOP25Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > COOP25Barcode Class > COOP25Barcode Constructor : COOP25Barcode Constructor()

Initializes a new COOP25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As COOP25Barcode()
C#
public COOP25Barcode()
Managed Extensions for C++
public: COOP25Barcode();
C++/CLI
public:
COOP25Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

COOP25Barcode Class
COOP25Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
COOP25Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > COOP25Barcode Class > COOP25Barcode Constructor : COOP25Barcode Constructor(String)

data
The data to be encoded.
Initializes a new COOP25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As COOP25Barcode(data)
C#
public COOP25Barcode(
   string data
)
Managed Extensions for C++
public: COOP25Barcode(
   string* data
)
C++/CLI
public:
COOP25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

COOP25Barcode Class
COOP25Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
DataMatrixBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : DataMatrixBarcode Class

Defines a DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Class DataMatrixBarcode
   Inherits BidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixBarcode
C#
public class DataMatrixBarcode : BidimensionalBarcode
Managed Extensions for C++
public __gc class DataMatrixBarcode : public BidimensionalBarcode
C++/CLI
public ref class DataMatrixBarcode : public BidimensionalBarcode

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.DataMatrixBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataMatrixBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
DataMatrixBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : DataMatrixBarcode Class

The following tables list the members exposed by DataMatrixBarcode.

Public Constructors

 | Name | Description
Public Constructor | DataMatrixBarcode Constructor | Overloaded. Initializes a new DataMatrixBarcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Encoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | SymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Overridden. Gets whether the given character code can be encoded by the barcode.
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

DataMatrixBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
DataMatrixBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > DataMatrixBarcode Class : DataMatrixBarcode Constructor

Initializes a new DataMatrixBarcode object.

Overload List

Overload | Description
DataMatrixBarcode Constructor() | Initializes a new DataMatrixBarcode object.
DataMatrixBarcode Constructor(String) | Initializes a new DataMatrixBarcode object with the given data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataMatrixBarcode Class
DataMatrixBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
DataMatrixBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > DataMatrixBarcode Class > DataMatrixBarcode Constructor : DataMatrixBarcode Constructor()

Initializes a new DataMatrixBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixBarcode()
C#
public DataMatrixBarcode()
Managed Extensions for C++
public: DataMatrixBarcode();
C++/CLI
public:
DataMatrixBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataMatrixBarcode Class
DataMatrixBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
DataMatrixBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > DataMatrixBarcode Class > DataMatrixBarcode Constructor : DataMatrixBarcode Constructor(String)

data
The data to be encoded.
Initializes a new DataMatrixBarcode object with the given data.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As DataMatrixBarcode(data)
C#
public DataMatrixBarcode(
   string data
)
Managed Extensions for C++
public: DataMatrixBarcode(
   string* data
)
C++/CLI
public:
DataMatrixBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataMatrixBarcode Class
DataMatrixBarcode Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
DataMatrixBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : DataMatrixBarcode Class

For a list of all members of this type, see DataMatrixBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Overridden. Gets whether the given character code can be encoded by the barcode.
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

DataMatrixBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
IsValidCharacterCode Method
See Also
[image]
O2S.Barcode4NET Namespace > DataMatrixBarcode Class : IsValidCharacterCode Method

characterCode
The character code to test.
Gets whether the given character code can be encoded by the barcode.

Syntax

Visual Basic (Declaration)
Overrides Public Function IsValidCharacterCode( _
   ByVal characterCode As Byte _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixBarcode
Dim characterCode As Byte
Dim value As Boolean

value = instance.IsValidCharacterCode(characterCode)
C#
public override bool IsValidCharacterCode(
   byte characterCode
)
Managed Extensions for C++
public: bool IsValidCharacterCode(
   byte characterCode
) override
C++/CLI
public:
bool IsValidCharacterCode(
   byte characterCode
) override

Parameters

characterCode
The character code to test.

Return Value

True if the character code can be encoded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataMatrixBarcode Class
DataMatrixBarcode Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
DataMatrixBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : DataMatrixBarcode Class

For a list of all members of this type, see DataMatrixBarcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Encoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | SymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

DataMatrixBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Encoding Property
See Also
[image]
O2S.Barcode4NET Namespace > DataMatrixBarcode Class : Encoding Property

Gets or sets the encoding of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property Encoding As DataMatrixEncoding
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixBarcode
Dim value As DataMatrixEncoding

instance.Encoding = value

value = instance.Encoding
C#
public DataMatrixEncoding Encoding {get; set;}
Managed Extensions for C++
public: __property DataMatrixEncoding get_Encoding();
public: __property void set_Encoding(
   DataMatrixEncoding value
);
C++/CLI
public:
property DataMatrixEncoding Encoding {
   DataMatrixEncoding get();
   void set (DataMatrixEncoding value);
}

Return Value

A DataMatrixEncoding enumeration member specifying the data encoding for this DataMatrix barcode.

Remarks

If the data to encode contains only numbers (ASCII characters from 0x30 to 0x39), then Numeric provides the best encoding. If the data to encode contains only base ASCII characters (0x00 to 0x7F), then both ASCII and Base256 encoding provide the same performance, but if the data to encode contains more than 3 extended ASCII characters (0x80 to 0xFF) then the Base256 encoding is the best option.
If the selected encoding is Auto, then the library will select the encoding that will generate the smallest encoded data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataMatrixBarcode Class
DataMatrixBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
SymbolSize Property
See Also
[image]
O2S.Barcode4NET Namespace > DataMatrixBarcode Class : SymbolSize Property

Gets or sets the symbol size of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property SymbolSize As DataMatrixSymbolSize
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixBarcode
Dim value As DataMatrixSymbolSize

instance.SymbolSize = value

value = instance.SymbolSize
C#
public DataMatrixSymbolSize SymbolSize {get; set;}
Managed Extensions for C++
public: __property DataMatrixSymbolSize get_SymbolSize();
public: __property void set_SymbolSize(
   DataMatrixSymbolSize value
);
C++/CLI
public:
property DataMatrixSymbolSize SymbolSize {
   DataMatrixSymbolSize get();
   void set (DataMatrixSymbolSize value);
}

Return Value

A DataMatrixSymbolSize enumeration member specifying the size of symbol used to represent this DataMatrix barcode.

Remarks

If the SymbolSize is Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DataMatrixBarcode Class
DataMatrixBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
EAN13Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : EAN13Barcode Class

Defines the class for EAN-13 barcodes.

Syntax

Visual Basic (Declaration)
Public Class EAN13Barcode
   Inherits EANBarcode
Visual Basic (Usage) Copy Code
Dim instance As EAN13Barcode
C#
public class EAN13Barcode : EANBarcode
Managed Extensions for C++
public __gc class EAN13Barcode : public EANBarcode
C++/CLI
public ref class EAN13Barcode : public EANBarcode

Remarks

EAN-13 symbology is a numeric symbology. Only the following symbols are allowed in an EAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-13 barcode must always have 12 characters length. The 13th character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.EAN13Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN13Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
EAN13Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : EAN13Barcode Class

The following tables list the members exposed by EAN13Barcode.

Public Constructors

 | Name | Description
Public Constructor | EAN13Barcode Constructor | Overloaded. Initializes a new EAN13Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

EAN13Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
EAN13Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > EAN13Barcode Class : EAN13Barcode Constructor

Initializes a new EAN13Barcode object.

Overload List

Overload | Description
EAN13Barcode Constructor() | Initializes a new EAN13Barcode object.
EAN13Barcode Constructor(String) | Initializes a new EAN13Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN13Barcode Class
EAN13Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
EAN13Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > EAN13Barcode Class > EAN13Barcode Constructor : EAN13Barcode Constructor()

Initializes a new EAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EAN13Barcode()
C#
public EAN13Barcode()
Managed Extensions for C++
public: EAN13Barcode();
C++/CLI
public:
EAN13Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN13Barcode Class
EAN13Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
EAN13Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > EAN13Barcode Class > EAN13Barcode Constructor : EAN13Barcode Constructor(String)

data
The data to be encoded.
Initializes a new EAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As EAN13Barcode(data)
C#
public EAN13Barcode(
   string data
)
Managed Extensions for C++
public: EAN13Barcode(
   string* data
)
C++/CLI
public:
EAN13Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN13Barcode Class
EAN13Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
EAN8Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : EAN8Barcode Class

Defines the class for EAN-8 barcodes.

Syntax

Visual Basic (Declaration)
Public Class EAN8Barcode
   Inherits EANBarcode
Visual Basic (Usage) Copy Code
Dim instance As EAN8Barcode
C#
public class EAN8Barcode : EANBarcode
Managed Extensions for C++
public __gc class EAN8Barcode : public EANBarcode
C++/CLI
public ref class EAN8Barcode : public EANBarcode

Remarks

EAN-8 symbology is a numeric symbology. Only the following symbols are allowed in an EAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-8 barcode must always have 7 characters length. The 8th character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.EAN8Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN8Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
EAN8Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : EAN8Barcode Class

The following tables list the members exposed by EAN8Barcode.

Public Constructors

 | Name | Description
Public Constructor | EAN8Barcode Constructor | Overloaded. Initializes a new EAN8Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

EAN8Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
EAN8Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > EAN8Barcode Class : EAN8Barcode Constructor

Initializes a new EAN8Barcode object.

Overload List

Overload | Description
EAN8Barcode Constructor() | Initializes a new EAN8Barcode object.
EAN8Barcode Constructor(String) | Initializes a new EAN8Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN8Barcode Class
EAN8Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
EAN8Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > EAN8Barcode Class > EAN8Barcode Constructor : EAN8Barcode Constructor()

Initializes a new EAN8Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EAN8Barcode()
C#
public EAN8Barcode()
Managed Extensions for C++
public: EAN8Barcode();
C++/CLI
public:
EAN8Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN8Barcode Class
EAN8Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
EAN8Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > EAN8Barcode Class > EAN8Barcode Constructor : EAN8Barcode Constructor(String)

data
The data to be encoded.
Initializes a new EAN8Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As EAN8Barcode(data)
C#
public EAN8Barcode(
   string data
)
Managed Extensions for C++
public: EAN8Barcode(
   string* data
)
C++/CLI
public:
EAN8Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EAN8Barcode Class
EAN8Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
EANBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : EANBarcode Class

Defines the base class for EAN based barcodes.

Syntax

Visual Basic (Declaration)
Public MustInherit Class EANBarcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As EANBarcode
C#
public abstract class EANBarcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc abstract class EANBarcode : public UnidimensionalBarcode
C++/CLI
public ref class EANBarcode abstract : public UnidimensionalBarcode

Remarks

An EAN based symbology is a numeric symbology. Only the following symbols are allowed in an EAN based barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-13 barcode must always has 12 characters length. The 13th character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.UPCEBarcode
O2S.Barcode4NET.UPCEBarcode
O2S.Barcode4NET.UPCABarcode
O2S.Barcode4NET.UPCABarcode
O2S.Barcode4NET.JAN13Barcode
O2S.Barcode4NET.JAN13Barcode
O2S.Barcode4NET.ISSNBarcode
O2S.Barcode4NET.ISSNBarcode
O2S.Barcode4NET.ISMNBarcode
O2S.Barcode4NET.ISMNBarcode
O2S.Barcode4NET.ISBNBarcode
O2S.Barcode4NET.ISBNBarcode
O2S.Barcode4NET.EAN8Barcode
O2S.Barcode4NET.EAN8Barcode
O2S.Barcode4NET.EAN13Barcode
O2S.Barcode4NET.EAN13Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EANBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
EANBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : EANBarcode Class

The following tables list the members exposed by EANBarcode.

Public Constructors

 | Name | Description
Public Constructor | EANBarcode Constructor | Overloaded. Initializes a new EANBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data.
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text.
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

EANBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
EANBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > EANBarcode Class : EANBarcode Constructor

Initializes a new EANBarcode object.

Overload List

Overload | Description
EANBarcode Constructor() | Initializes a new EANBarcode object.
EANBarcode Constructor(String) | Initializes a new EANBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EANBarcode Class
EANBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
EANBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > EANBarcode Class > EANBarcode Constructor : EANBarcode Constructor()

Initializes a new EANBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As EANBarcode()
C#
public EANBarcode()
Managed Extensions for C++
public: EANBarcode();
C++/CLI
public:
EANBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EANBarcode Class
EANBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
EANBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > EANBarcode Class > EANBarcode Constructor : EANBarcode Constructor(String)

data
The data to be encoded.
Initializes a new EANBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As EANBarcode(data)
C#
public EANBarcode(
   string data
)
Managed Extensions for C++
public: EANBarcode(
   string* data
)
C++/CLI
public:
EANBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EANBarcode Class
EANBarcode Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
EANBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : EANBarcode Class

For a list of all members of this type, see EANBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data.
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text.
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

EANBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Supplement Property
See Also
[image]
O2S.Barcode4NET Namespace > EANBarcode Class : Supplement Property

Gets or sets the supplement for barcode data.

Syntax

Visual Basic (Declaration)
Public Property Supplement As String
Visual Basic (Usage) Copy Code
Dim instance As EANBarcode
Dim value As String

instance.Supplement = value

value = instance.Supplement
C#
public string Supplement {get; set;}
Managed Extensions for C++
public: __property string* get_Supplement();
public: __property void set_Supplement(
   string* value
);
C++/CLI
public:
property String^ Supplement {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying a 2 or 5 digit supplemental barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in supplement data or the supplement does not have the required length (2 or 5 digits).

Remarks

This supplement is optional. If it exists, it can be only 2 or 5 digits.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EANBarcode Class
EANBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
SupplementDisplayLocation Property
See Also
[image]
O2S.Barcode4NET Namespace > EANBarcode Class : SupplementDisplayLocation Property

Gets or sets the location of the supplement text.

Syntax

Visual Basic (Declaration)
Public Property SupplementDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As EANBarcode
Dim value As BarcodeTextLocation

instance.SupplementDisplayLocation = value

value = instance.SupplementDisplayLocation
C#
public BarcodeTextLocation SupplementDisplayLocation {get; set;}
Managed Extensions for C++
public: __property BarcodeTextLocation get_SupplementDisplayLocation();
public: __property void set_SupplementDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation SupplementDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location where the supplement text is displayed.

Remarks

The embedding options are ignored for supplement text. AboveEmbedded has the same effect like Above, and BelowEmbedded has the same effect like Below.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EANBarcode Class
EANBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
SupplementYDimension Property
See Also
[image]
O2S.Barcode4NET Namespace > EANBarcode Class : SupplementYDimension Property

Gets or sets the height of a bar in the supplement barcode.

Syntax

Visual Basic (Declaration)
Public Property SupplementYDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As EANBarcode
Dim value As Single

instance.SupplementYDimension = value

value = instance.SupplementYDimension
C#
public float SupplementYDimension {get; set;}
Managed Extensions for C++
public: __property float get_SupplementYDimension();
public: __property void set_SupplementYDimension(
   float value
);
C++/CLI
public:
property float SupplementYDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a bar in the supplement barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by XYDimensionUnit property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

EANBarcode Class
EANBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
HeightModulatedBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : HeightModulatedBarcode Class

Defines the base class for all height modulated barcodes.

Syntax

Visual Basic (Declaration)
Public MustInherit Class HeightModulatedBarcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As HeightModulatedBarcode
C#
public abstract class HeightModulatedBarcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc abstract class HeightModulatedBarcode : public UnidimensionalBarcode
C++/CLI
public ref class HeightModulatedBarcode abstract : public UnidimensionalBarcode

Remarks

Height modulated barcodes encode the information in the height of the bars, not and in the width of the bars and spaces.
Usually height modulated barcodes are used for encoding postal information, such as ZIP/Postal codes or delivery points.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.HeightModulatedBarcode
O2S.Barcode4NET.RM4SCCBarcode
O2S.Barcode4NET.RM4SCCBarcode
O2S.Barcode4NET.PostnetBarcode
O2S.Barcode4NET.PostnetBarcode
O2S.Barcode4NET.PlanetBarcode
O2S.Barcode4NET.PlanetBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

HeightModulatedBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
HeightModulatedBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : HeightModulatedBarcode Class

The following tables list the members exposed by HeightModulatedBarcode.

Public Constructors

 | Name | Description
Public Constructor | HeightModulatedBarcode Constructor | Overloaded. Initializes a new HeightModulatedBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

HeightModulatedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
HeightModulatedBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > HeightModulatedBarcode Class : HeightModulatedBarcode Constructor

Initializes a new HeightModulatedBarcode object.

Overload List

Overload | Description
HeightModulatedBarcode Constructor() | Initializes a new HeightModulatedBarcode object.
HeightModulatedBarcode Constructor(String) | Initializes a new HeightModulatedBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

HeightModulatedBarcode Class
HeightModulatedBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
HeightModulatedBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > HeightModulatedBarcode Class > HeightModulatedBarcode Constructor : HeightModulatedBarcode Constructor()

Initializes a new HeightModulatedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As HeightModulatedBarcode()
C#
public HeightModulatedBarcode()
Managed Extensions for C++
public: HeightModulatedBarcode();
C++/CLI
public:
HeightModulatedBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

HeightModulatedBarcode Class
HeightModulatedBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
HeightModulatedBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > HeightModulatedBarcode Class > HeightModulatedBarcode Constructor : HeightModulatedBarcode Constructor(String)

data
The data to be encoded.
Initializes a new HeightModulatedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As HeightModulatedBarcode(data)
C#
public HeightModulatedBarcode(
   string data
)
Managed Extensions for C++
public: HeightModulatedBarcode(
   string* data
)
C++/CLI
public:
HeightModulatedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

HeightModulatedBarcode Class
HeightModulatedBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
IATA25Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : IATA25Barcode Class

Defines a IATA 2 of 5 barcode.

Syntax

Visual Basic (Declaration)
Public Class IATA25Barcode
   Inherits Code25Barcode
Visual Basic (Usage) Copy Code
Dim instance As IATA25Barcode
C#
public class IATA25Barcode : Code25Barcode
Managed Extensions for C++
public __gc class IATA25Barcode : public Code25Barcode
C++/CLI
public ref class IATA25Barcode : public Code25Barcode

Remarks

IATA 2 of 5 is a numeric symbology. Only the following symbols are allowed in a IATA 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9. The required data length is 16 digits (the 17th digit is the check digit and it is computed automatically).
IATA (International Air Transport Assosiation) uses this for the management of air cargo.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code25Barcode
O2S.Barcode4NET.IATA25Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IATA25Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
IATA25Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : IATA25Barcode Class

The following tables list the members exposed by IATA25Barcode.

Public Constructors

 | Name | Description
Public Constructor | IATA25Barcode Constructor | Overloaded. Initializes a new IATA25Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

IATA25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
IATA25Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > IATA25Barcode Class : IATA25Barcode Constructor

Initializes a new IATA25Barcode object.

Overload List

Overload | Description
IATA25Barcode Constructor() | Initializes a new IATA25Barcode object.
IATA25Barcode Constructor(String) | Initializes a new IATA25Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IATA25Barcode Class
IATA25Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
IATA25Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > IATA25Barcode Class > IATA25Barcode Constructor : IATA25Barcode Constructor()

Initializes a new IATA25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As IATA25Barcode()
C#
public IATA25Barcode()
Managed Extensions for C++
public: IATA25Barcode();
C++/CLI
public:
IATA25Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IATA25Barcode Class
IATA25Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
IATA25Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > IATA25Barcode Class > IATA25Barcode Constructor : IATA25Barcode Constructor(String)

data
The data to be encoded.
Initializes a new IATA25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As IATA25Barcode(data)
C#
public IATA25Barcode(
   string data
)
Managed Extensions for C++
public: IATA25Barcode(
   string* data
)
C++/CLI
public:
IATA25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IATA25Barcode Class
IATA25Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
ISBNBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : ISBNBarcode Class

Defines the class for ISBN barcodes.

Syntax

Visual Basic (Declaration)
Public Class ISBNBarcode
   Inherits EANBarcode
Visual Basic (Usage) Copy Code
Dim instance As ISBNBarcode
C#
public class ISBNBarcode : EANBarcode
Managed Extensions for C++
public __gc class ISBNBarcode : public EANBarcode
C++/CLI
public ref class ISBNBarcode : public EANBarcode

Remarks

ISBN symbology is a numeric symbology. Only the following symbols are allowed in an ISBN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISBN barcode (International Standard Book Numbering) is in fact an EAN-13 barcode having the 978 number system. The data for an ISBN barcode must always have 9 characters length. The number system is always 978 and the last character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.ISBNBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISBNBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
ISBNBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : ISBNBarcode Class

The following tables list the members exposed by ISBNBarcode.

Public Constructors

 | Name | Description
Public Constructor | ISBNBarcode Constructor | Overloaded. Initializes a new ISBNBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

ISBNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
ISBNBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > ISBNBarcode Class : ISBNBarcode Constructor

Initializes a new ISBNBarcode object.

Overload List

Overload | Description
ISBNBarcode Constructor() | Initializes a new ISBNBarcode object.
ISBNBarcode Constructor(String) | Initializes a new ISBNBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISBNBarcode Class
ISBNBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
ISBNBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > ISBNBarcode Class > ISBNBarcode Constructor : ISBNBarcode Constructor()

Initializes a new ISBNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ISBNBarcode()
C#
public ISBNBarcode()
Managed Extensions for C++
public: ISBNBarcode();
C++/CLI
public:
ISBNBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISBNBarcode Class
ISBNBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
ISBNBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > ISBNBarcode Class > ISBNBarcode Constructor : ISBNBarcode Constructor(String)

data
The data to be encoded.
Initializes a new ISBNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As ISBNBarcode(data)
C#
public ISBNBarcode(
   string data
)
Managed Extensions for C++
public: ISBNBarcode(
   string* data
)
C++/CLI
public:
ISBNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISBNBarcode Class
ISBNBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
ISMNBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : ISMNBarcode Class

Defines the class for ISMN barcodes.

Syntax

Visual Basic (Declaration)
Public Class ISMNBarcode
   Inherits EANBarcode
Visual Basic (Usage) Copy Code
Dim instance As ISMNBarcode
C#
public class ISMNBarcode : EANBarcode
Managed Extensions for C++
public __gc class ISMNBarcode : public EANBarcode
C++/CLI
public ref class ISMNBarcode : public EANBarcode

Remarks

ISMN symbology is a numeric symbology. Only the following symbols are allowed in an ISMN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISMN barcode (International Standard Music Number) is in fact an EAN-13 barcode having the 979 number system. The data for an ISMN barcode must always have 9 characters length. The number system is always 979 and the last character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.ISMNBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISMNBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
ISMNBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : ISMNBarcode Class

The following tables list the members exposed by ISMNBarcode.

Public Constructors

 | Name | Description
Public Constructor | ISMNBarcode Constructor | Overloaded. Initializes a new ISMNBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

ISMNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
ISMNBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > ISMNBarcode Class : ISMNBarcode Constructor

Initializes a new ISMNBarcode object.

Overload List

Overload | Description
ISMNBarcode Constructor() | Initializes a new ISMNBarcode object.
ISMNBarcode Constructor(String) | Initializes a new ISMNBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISMNBarcode Class
ISMNBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
ISMNBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > ISMNBarcode Class > ISMNBarcode Constructor : ISMNBarcode Constructor()

Initializes a new ISMNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ISMNBarcode()
C#
public ISMNBarcode()
Managed Extensions for C++
public: ISMNBarcode();
C++/CLI
public:
ISMNBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISMNBarcode Class
ISMNBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
ISMNBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > ISMNBarcode Class > ISMNBarcode Constructor : ISMNBarcode Constructor(String)

data
The data to be encoded.
Initializes a new ISMNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As ISMNBarcode(data)
C#
public ISMNBarcode(
   string data
)
Managed Extensions for C++
public: ISMNBarcode(
   string* data
)
C++/CLI
public:
ISMNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISMNBarcode Class
ISMNBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
ISSNBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : ISSNBarcode Class

Defines the class for ISSN barcodes.

Syntax

Visual Basic (Declaration)
Public Class ISSNBarcode
   Inherits EANBarcode
Visual Basic (Usage) Copy Code
Dim instance As ISSNBarcode
C#
public class ISSNBarcode : EANBarcode
Managed Extensions for C++
public __gc class ISSNBarcode : public EANBarcode
C++/CLI
public ref class ISSNBarcode : public EANBarcode

Remarks

ISSN symbology is a numeric symbology. Only the following symbols are allowed in an ISSN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISSN barcode (International Standard Serial Number for Periodicals) is in fact an EAN-13 barcode having the 977 number system. The data for an ISSN barcode must always have 9 characters length. The number system is always 977 and the last character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.ISSNBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISSNBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
ISSNBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : ISSNBarcode Class

The following tables list the members exposed by ISSNBarcode.

Public Constructors

 | Name | Description
Public Constructor | ISSNBarcode Constructor | Overloaded. Initializes a new ISSNBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

ISSNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
ISSNBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > ISSNBarcode Class : ISSNBarcode Constructor

Initializes a new ISSNBarcode object.

Overload List

Overload | Description
ISSNBarcode Constructor() | Initializes a new ISSNBarcode object.
ISSNBarcode Constructor(String) | Initializes a new ISSNBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISSNBarcode Class
ISSNBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
ISSNBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > ISSNBarcode Class > ISSNBarcode Constructor : ISSNBarcode Constructor()

Initializes a new ISSNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ISSNBarcode()
C#
public ISSNBarcode()
Managed Extensions for C++
public: ISSNBarcode();
C++/CLI
public:
ISSNBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISSNBarcode Class
ISSNBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
ISSNBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > ISSNBarcode Class > ISSNBarcode Constructor : ISSNBarcode Constructor(String)

data
The data to be encoded.
Initializes a new ISSNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As ISSNBarcode(data)
C#
public ISSNBarcode(
   string data
)
Managed Extensions for C++
public: ISSNBarcode(
   string* data
)
C++/CLI
public:
ISSNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ISSNBarcode Class
ISSNBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
JAN13Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : JAN13Barcode Class

Defines the class for JAN13 barcodes.

Syntax

Visual Basic (Declaration)
Public Class JAN13Barcode
   Inherits EANBarcode
Visual Basic (Usage) Copy Code
Dim instance As JAN13Barcode
C#
public class JAN13Barcode : EANBarcode
Managed Extensions for C++
public __gc class JAN13Barcode : public EANBarcode
C++/CLI
public ref class JAN13Barcode : public EANBarcode

Remarks

JAN-13 symbology is a numeric symbology. Only the following symbols are allowed in an JAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. An JAN-13 barcode (Japanese Article Numbering) is in fact an EAN-13 barcode having the 49 number system. The data for an JAN-13 barcode must always have 10 characters length. The number system is always 49 and the last character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.JAN13Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

JAN13Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
JAN13Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : JAN13Barcode Class

The following tables list the members exposed by JAN13Barcode.

Public Constructors

 | Name | Description
Public Constructor | JAN13Barcode Constructor | Overloaded. Initializes a new JAN13Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

JAN13Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
JAN13Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > JAN13Barcode Class : JAN13Barcode Constructor

Initializes a new JAN13Barcode object.

Overload List

Overload | Description
JAN13Barcode Constructor() | Initializes a new JAN13Barcode object.
JAN13Barcode Constructor(String) | Initializes a new JAN13Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

JAN13Barcode Class
JAN13Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
JAN13Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > JAN13Barcode Class > JAN13Barcode Constructor : JAN13Barcode Constructor()

Initializes a new JAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As JAN13Barcode()
C#
public JAN13Barcode()
Managed Extensions for C++
public: JAN13Barcode();
C++/CLI
public:
JAN13Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

JAN13Barcode Class
JAN13Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
JAN13Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > JAN13Barcode Class > JAN13Barcode Constructor : JAN13Barcode Constructor(String)

data
The data to be encoded.
Initializes a new JAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As JAN13Barcode(data)
C#
public JAN13Barcode(
   string data
)
Managed Extensions for C++
public: JAN13Barcode(
   string* data
)
C++/CLI
public:
JAN13Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

JAN13Barcode Class
JAN13Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Matrix25Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : Matrix25Barcode Class

Defines a Matrix 2 of 5 barcode.

Syntax

Visual Basic (Declaration)
Public Class Matrix25Barcode
   Inherits Code25Barcode
Visual Basic (Usage) Copy Code
Dim instance As Matrix25Barcode
C#
public class Matrix25Barcode : Code25Barcode
Managed Extensions for C++
public __gc class Matrix25Barcode : public Code25Barcode
C++/CLI
public ref class Matrix25Barcode : public Code25Barcode

Remarks

Matrix 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Matrix 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code25Barcode
O2S.Barcode4NET.Matrix25Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Matrix25Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
Matrix25Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : Matrix25Barcode Class

The following tables list the members exposed by Matrix25Barcode.

Public Constructors

 | Name | Description
Public Constructor | Matrix25Barcode Constructor | Overloaded. Initializes a new Matrix25Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Matrix25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Matrix25Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > Matrix25Barcode Class : Matrix25Barcode Constructor

Initializes a new Matrix25Barcode object.

Overload List

Overload | Description
Matrix25Barcode Constructor() | Initializes a new Matrix25Barcode object.
Matrix25Barcode Constructor(String) | Initializes a new Matrix25Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Matrix25Barcode Class
Matrix25Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Matrix25Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > Matrix25Barcode Class > Matrix25Barcode Constructor : Matrix25Barcode Constructor()

Initializes a new Matrix25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Matrix25Barcode()
C#
public Matrix25Barcode()
Managed Extensions for C++
public: Matrix25Barcode();
C++/CLI
public:
Matrix25Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Matrix25Barcode Class
Matrix25Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Matrix25Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > Matrix25Barcode Class > Matrix25Barcode Constructor : Matrix25Barcode Constructor(String)

data
The data to be encoded.
Initializes a new Matrix25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As Matrix25Barcode(data)
C#
public Matrix25Barcode(
   string data
)
Managed Extensions for C++
public: Matrix25Barcode(
   string* data
)
C++/CLI
public:
Matrix25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Matrix25Barcode Class
Matrix25Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
MicroPDF417Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : MicroPDF417Barcode Class

Defines a Micro PDF 417 barcode.

Syntax

Visual Basic (Declaration)
Public Class MicroPDF417Barcode
   Inherits BasePDF417Barcode
Visual Basic (Usage) Copy Code
Dim instance As MicroPDF417Barcode
C#
public class MicroPDF417Barcode : BasePDF417Barcode
Managed Extensions for C++
public __gc class MicroPDF417Barcode : public BasePDF417Barcode
C++/CLI
public ref class MicroPDF417Barcode : public BasePDF417Barcode

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.BasePDF417Barcode
O2S.Barcode4NET.MicroPDF417Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MicroPDF417Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
MicroPDF417Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : MicroPDF417Barcode Class

The following tables list the members exposed by MicroPDF417Barcode.

Public Constructors

 | Name | Description
Public Constructor | MicroPDF417Barcode Constructor | Overloaded. Initializes a new MicroPDF417Barcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from BasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from BasePDF417Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from BasePDF417Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

MicroPDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
MicroPDF417Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > MicroPDF417Barcode Class : MicroPDF417Barcode Constructor

Initializes a new MicroPDF417Barcode object.

Overload List

Overload | Description
MicroPDF417Barcode Constructor() | Initializes a new MicroPDF417Barcode object.
MicroPDF417Barcode Constructor(String) | Initializes a new MicroPDF417Barcode object with the given data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MicroPDF417Barcode Class
MicroPDF417Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
MicroPDF417Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > MicroPDF417Barcode Class > MicroPDF417Barcode Constructor : MicroPDF417Barcode Constructor()

Initializes a new MicroPDF417Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MicroPDF417Barcode()
C#
public MicroPDF417Barcode()
Managed Extensions for C++
public: MicroPDF417Barcode();
C++/CLI
public:
MicroPDF417Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MicroPDF417Barcode Class
MicroPDF417Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
MicroPDF417Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > MicroPDF417Barcode Class > MicroPDF417Barcode Constructor : MicroPDF417Barcode Constructor(String)

data
The data to be encoded.
Initializes a new MicroPDF417Barcode object with the given data.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As MicroPDF417Barcode(data)
C#
public MicroPDF417Barcode(
   string data
)
Managed Extensions for C++
public: MicroPDF417Barcode(
   string* data
)
C++/CLI
public:
MicroPDF417Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MicroPDF417Barcode Class
MicroPDF417Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
MicroPDF417Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : MicroPDF417Barcode Class

For a list of all members of this type, see MicroPDF417Barcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from BasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from BasePDF417Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

MicroPDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
SymbolSize Property
See Also
[image]
O2S.Barcode4NET Namespace > MicroPDF417Barcode Class : SymbolSize Property

Gets or sets the symbol size of this Micro PDF 417 barcode.

Syntax

Visual Basic (Declaration)
Public Property SymbolSize As MicroPDF417SymbolSize
Visual Basic (Usage) Copy Code
Dim instance As MicroPDF417Barcode
Dim value As MicroPDF417SymbolSize

instance.SymbolSize = value

value = instance.SymbolSize
C#
public MicroPDF417SymbolSize SymbolSize {get; set;}
Managed Extensions for C++
public: __property MicroPDF417SymbolSize get_SymbolSize();
public: __property void set_SymbolSize(
   MicroPDF417SymbolSize value
);
C++/CLI
public:
property MicroPDF417SymbolSize SymbolSize {
   MicroPDF417SymbolSize get();
   void set (MicroPDF417SymbolSize value);
}

Return Value

A MicroPDF417SymbolSize enumeration member specifying the size of symbol used to represent this Micro PDF 417 barcode.

Remarks

If the SymbolSize is Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MicroPDF417Barcode Class
MicroPDF417Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
MSIPlesseyBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : MSIPlesseyBarcode Class

Defines a MSI/Plessey barcode.

Syntax

Visual Basic (Declaration)
Public Class MSIPlesseyBarcode
   Inherits UnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As MSIPlesseyBarcode
C#
public class MSIPlesseyBarcode : UnidimensionalBarcode
Managed Extensions for C++
public __gc class MSIPlesseyBarcode : public UnidimensionalBarcode
C++/CLI
public ref class MSIPlesseyBarcode : public UnidimensionalBarcode

Remarks

MSI/Plessey is a numeric symbology. Only the following symbols are allowed in a MSI/Plessey barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.MSIPlesseyBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MSIPlesseyBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
MSIPlesseyBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : MSIPlesseyBarcode Class

The following tables list the members exposed by MSIPlesseyBarcode.

Public Constructors

 | Name | Description
Public Constructor | MSIPlesseyBarcode Constructor | Overloaded. Initializes a new MSIPlesseyBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

MSIPlesseyBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
MSIPlesseyBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > MSIPlesseyBarcode Class : MSIPlesseyBarcode Constructor

Initializes a new MSIPlesseyBarcode object.

Overload List

Overload | Description
MSIPlesseyBarcode Constructor() | Initializes a new MSIPlesseyBarcode object.
MSIPlesseyBarcode Constructor(String) | Initializes a new MSIPlesseyBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MSIPlesseyBarcode Class
MSIPlesseyBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
MSIPlesseyBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > MSIPlesseyBarcode Class > MSIPlesseyBarcode Constructor : MSIPlesseyBarcode Constructor()

Initializes a new MSIPlesseyBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MSIPlesseyBarcode()
C#
public MSIPlesseyBarcode()
Managed Extensions for C++
public: MSIPlesseyBarcode();
C++/CLI
public:
MSIPlesseyBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MSIPlesseyBarcode Class
MSIPlesseyBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
MSIPlesseyBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > MSIPlesseyBarcode Class > MSIPlesseyBarcode Constructor : MSIPlesseyBarcode Constructor(String)

data
The data to be encoded.
Initializes a new MSIPlesseyBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As MSIPlesseyBarcode(data)
C#
public MSIPlesseyBarcode(
   string data
)
Managed Extensions for C++
public: MSIPlesseyBarcode(
   string* data
)
C++/CLI
public:
MSIPlesseyBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MSIPlesseyBarcode Class
MSIPlesseyBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
PDF417Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : PDF417Barcode Class

Defines a PDF 417 barcode.

Syntax

Visual Basic (Declaration)
Public Class PDF417Barcode
   Inherits BasePDF417Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
C#
public class PDF417Barcode : BasePDF417Barcode
Managed Extensions for C++
public __gc class PDF417Barcode : public BasePDF417Barcode
C++/CLI
public ref class PDF417Barcode : public BasePDF417Barcode

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.BasePDF417Barcode
O2S.Barcode4NET.PDF417Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
PDF417Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : PDF417Barcode Class

The following tables list the members exposed by PDF417Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDF417Barcode Constructor | Overloaded. Initializes a new PDF417Barcode object.
Top

Public Properties

 | Name | Description
Public Property | ActualColumns | Returns the actual number of columns used by this barcode.
Public Property | ActualRows | Returns the actual number of rows used by this barcode.
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from BasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | ErrorCorrectionLevel | Gets or sets the level of error correction used by this barcode.
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from BasePDF417Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from BasePDF417Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

PDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
PDF417Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > PDF417Barcode Class : PDF417Barcode Constructor

Initializes a new PDF417Barcode object.

Overload List

Overload | Description
PDF417Barcode Constructor() | Initializes a new PDF417Barcode object.
PDF417Barcode Constructor(String) | Initializes a new PDF417Barcode object with the given data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
PDF417Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > PDF417Barcode Class > PDF417Barcode Constructor : PDF417Barcode Constructor()

Initializes a new PDF417Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode()
C#
public PDF417Barcode()
Managed Extensions for C++
public: PDF417Barcode();
C++/CLI
public:
PDF417Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
PDF417Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > PDF417Barcode Class > PDF417Barcode Constructor : PDF417Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDF417Barcode object with the given data.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDF417Barcode(data)
C#
public PDF417Barcode(
   string data
)
Managed Extensions for C++
public: PDF417Barcode(
   string* data
)
C++/CLI
public:
PDF417Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
PDF417Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : PDF417Barcode Class

For a list of all members of this type, see PDF417Barcode members.

Public Properties

 | Name | Description
Public Property | ActualColumns | Returns the actual number of columns used by this barcode.
Public Property | ActualRows | Returns the actual number of rows used by this barcode.
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from BidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from BasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | ErrorCorrectionLevel | Gets or sets the level of error correction used by this barcode.
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from BasePDF417Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

PDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
ActualColumns Property
See Also
[image]
O2S.Barcode4NET Namespace > PDF417Barcode Class : ActualColumns Property

Returns the actual number of columns used by this barcode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActualColumns As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As Integer

value = instance.ActualColumns
C#
public int ActualColumns {get;}
Managed Extensions for C++
public: __property int get_ActualColumns();
C++/CLI
public:
property int ActualColumns {
   int get();
}

Return Value

An integer value specifying the actual number of columns used by this barcode.

Remarks

This value is computed automatically by the library when Columns property is 0. When Columns property is not 0, this property matches the Columns property.
This property returns -1 if a valid number of columns can not be computed for the following combination: barcode data, rows and error correction level.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
ActualRows Property
See Also
[image]
O2S.Barcode4NET Namespace > PDF417Barcode Class : ActualRows Property

Returns the actual number of rows used by this barcode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActualRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As Integer

value = instance.ActualRows
C#
public int ActualRows {get;}
Managed Extensions for C++
public: __property int get_ActualRows();
C++/CLI
public:
property int ActualRows {
   int get();
}

Return Value

An integer value specifying the actual number of rows used by this barcode.

Remarks

This value is computed automatically by the library when Rows property is 0. When Rows property is not 0, this property matches the Rows property.
This property returns -1 if a valid number of rows can not be computed for the following combination: barcode data, columns and error correction level.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Columns Property
See Also
[image]
O2S.Barcode4NET Namespace > PDF417Barcode Class : Columns Property

Gets or sets the number of columns in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As Integer

instance.Columns = value

value = instance.Columns
C#
public int Columns {get; set;}
Managed Extensions for C++
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
C++/CLI
public:
property int Columns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 1 or greater than 30 - OR - Throws when value is 0 and Rows is also 0.

Remarks

The minimum number of columns in a PDF 417 barcode is 1 and the maximum number of columns is 30. If this property is 0, the library will compute automatically the number of required columns to encode the barcode data. When this property is 0, the Rows property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
ErrorCorrectionLevel Property
See Also
[image]
O2S.Barcode4NET Namespace > PDF417Barcode Class : ErrorCorrectionLevel Property

Gets or sets the level of error correction used by this barcode.

Syntax

Visual Basic (Declaration)
Public Property ErrorCorrectionLevel As PDF417ErrorCorrectionLevel
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As PDF417ErrorCorrectionLevel

instance.ErrorCorrectionLevel = value

value = instance.ErrorCorrectionLevel
C#
public PDF417ErrorCorrectionLevel ErrorCorrectionLevel {get; set;}
Managed Extensions for C++
public: __property PDF417ErrorCorrectionLevel get_ErrorCorrectionLevel();
public: __property void set_ErrorCorrectionLevel(
   PDF417ErrorCorrectionLevel value
);
C++/CLI
public:
property PDF417ErrorCorrectionLevel ErrorCorrectionLevel {
   PDF417ErrorCorrectionLevel get();
   void set (PDF417ErrorCorrectionLevel value);
}

Return Value

A PDF417ErrorCorrectionLevel enumeration member specifying the level or error correction used by this barcode.

Remarks

The lowest error correction level is 0 and the greatest error correction level is 8. Each level generates a specific number of error correction codewords.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
Rows Property
See Also
[image]
O2S.Barcode4NET Namespace > PDF417Barcode Class : Rows Property

Gets or sets the number of rows in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
public int Rows {get; set;}
Managed Extensions for C++
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
C++/CLI
public:
property int Rows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 3, but not 0, or greater than 90 - OR - Throws when value is 0 and Columns is also 0.

Remarks

The minimum number of rows in a PDF 417 barcode is 3 and the maximum number of rows is 90. If this property is 0, the library will compute automatically the number of required rows to encode the barcode data. When this property is 0, the Columns property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
PlanetBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : PlanetBarcode Class

Defines a Planet barcode.

Syntax

Visual Basic (Declaration)
Public Class PlanetBarcode
   Inherits HeightModulatedBarcode
Visual Basic (Usage) Copy Code
Dim instance As PlanetBarcode
C#
public class PlanetBarcode : HeightModulatedBarcode
Managed Extensions for C++
public __gc class PlanetBarcode : public HeightModulatedBarcode
C++/CLI
public ref class PlanetBarcode : public HeightModulatedBarcode

Remarks

The Planet barcode was developed by the United States Postal Service (USPS).
Only the following symbols are allowed in a Planet barcode: 0 1 2 3 4 5 6 7 8 9
The information is encoded in the height of the barcodes, not in their width.
The required data length for a Planet barcode is either 11 or 13 digits.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.HeightModulatedBarcode
O2S.Barcode4NET.PlanetBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PlanetBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
PlanetBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : PlanetBarcode Class

The following tables list the members exposed by PlanetBarcode.

Public Constructors

 | Name | Description
Public Constructor | PlanetBarcode Constructor | Overloaded. Initializes a new PlanetBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

PlanetBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
PlanetBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > PlanetBarcode Class : PlanetBarcode Constructor

Initializes a new PlanetBarcode object.

Overload List

Overload | Description
PlanetBarcode Constructor() | Initializes a new PlanetBarcode object.
PlanetBarcode Constructor(String) | Initializes a new PlanetBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PlanetBarcode Class
PlanetBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
PlanetBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > PlanetBarcode Class > PlanetBarcode Constructor : PlanetBarcode Constructor()

Initializes a new PlanetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PlanetBarcode()
C#
public PlanetBarcode()
Managed Extensions for C++
public: PlanetBarcode();
C++/CLI
public:
PlanetBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PlanetBarcode Class
PlanetBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
PlanetBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > PlanetBarcode Class > PlanetBarcode Constructor : PlanetBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PlanetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PlanetBarcode(data)
C#
public PlanetBarcode(
   string data
)
Managed Extensions for C++
public: PlanetBarcode(
   string* data
)
C++/CLI
public:
PlanetBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PlanetBarcode Class
PlanetBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
PostnetBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : PostnetBarcode Class

Defines a Postnet barcode.

Syntax

Visual Basic (Declaration)
Public Class PostnetBarcode
   Inherits HeightModulatedBarcode
Visual Basic (Usage) Copy Code
Dim instance As PostnetBarcode
C#
public class PostnetBarcode : HeightModulatedBarcode
Managed Extensions for C++
public __gc class PostnetBarcode : public HeightModulatedBarcode
C++/CLI
public ref class PostnetBarcode : public HeightModulatedBarcode

Remarks

Postnet was developed by the United States Postal Service (USPS) to allow faster sorting and routing of mail.
Only the following symbols are allowed in a Planet barcode: 0 1 2 3 4 5 6 7 8 9
The information is encoded in the height of the barcodes, not in their width.
The required length for a Postnet barcode is 5 (ZIP), 9 (ZI+4) or 11 (full delivery point) digits.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.HeightModulatedBarcode
O2S.Barcode4NET.PostnetBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostnetBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
PostnetBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : PostnetBarcode Class

The following tables list the members exposed by PostnetBarcode.

Public Constructors

 | Name | Description
Public Constructor | PostnetBarcode Constructor | Overloaded. Initializes a new PostnetBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

PostnetBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
PostnetBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > PostnetBarcode Class : PostnetBarcode Constructor

Initializes a new PostnetBarcode object.

Overload List

Overload | Description
PostnetBarcode Constructor() | Initializes a new PostnetBarcode object.
PostnetBarcode Constructor(String) | Initializes a new PostnetBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostnetBarcode Class
PostnetBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
PostnetBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > PostnetBarcode Class > PostnetBarcode Constructor : PostnetBarcode Constructor()

Initializes a new PostnetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PostnetBarcode()
C#
public PostnetBarcode()
Managed Extensions for C++
public: PostnetBarcode();
C++/CLI
public:
PostnetBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostnetBarcode Class
PostnetBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
PostnetBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > PostnetBarcode Class > PostnetBarcode Constructor : PostnetBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PostnetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PostnetBarcode(data)
C#
public PostnetBarcode(
   string data
)
Managed Extensions for C++
public: PostnetBarcode(
   string* data
)
C++/CLI
public:
PostnetBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostnetBarcode Class
PostnetBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
RM4SCCBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : RM4SCCBarcode Class

Defines a RM4SCC barcode.

Syntax

Visual Basic (Declaration)
Public Class RM4SCCBarcode
   Inherits HeightModulatedBarcode
Visual Basic (Usage) Copy Code
Dim instance As RM4SCCBarcode
C#
public class RM4SCCBarcode : HeightModulatedBarcode
Managed Extensions for C++
public __gc class RM4SCCBarcode : public HeightModulatedBarcode
C++/CLI
public ref class RM4SCCBarcode : public HeightModulatedBarcode

Remarks

The Royal Mail 4-state Customer Code (RM4SCC) is a height-modulated barcode symbology for use in automated mail sortation process.
Only the following symbols are allowed in a RM4SCC barcode: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z.
The information is encoded in the height of the barcodes, not in their width.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.HeightModulatedBarcode
O2S.Barcode4NET.RM4SCCBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RM4SCCBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
RM4SCCBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : RM4SCCBarcode Class

The following tables list the members exposed by RM4SCCBarcode.

Public Constructors

 | Name | Description
Public Constructor | RM4SCCBarcode Constructor | Overloaded. Initializes a new RM4SCCBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

RM4SCCBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
RM4SCCBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > RM4SCCBarcode Class : RM4SCCBarcode Constructor

Initializes a new RM4SCCBarcode object.

Overload List

Overload | Description
RM4SCCBarcode Constructor() | Initializes a new RM4SCCBarcode object.
RM4SCCBarcode Constructor(String) | Initializes a new RM4SCCBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RM4SCCBarcode Class
RM4SCCBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
RM4SCCBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > RM4SCCBarcode Class > RM4SCCBarcode Constructor : RM4SCCBarcode Constructor()

Initializes a new RM4SCCBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RM4SCCBarcode()
C#
public RM4SCCBarcode()
Managed Extensions for C++
public: RM4SCCBarcode();
C++/CLI
public:
RM4SCCBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RM4SCCBarcode Class
RM4SCCBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
RM4SCCBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > RM4SCCBarcode Class > RM4SCCBarcode Constructor : RM4SCCBarcode Constructor(String)

data
The data to be encoded.
Initializes a new RM4SCCBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As RM4SCCBarcode(data)
C#
public RM4SCCBarcode(
   string data
)
Managed Extensions for C++
public: RM4SCCBarcode(
   string* data
)
C++/CLI
public:
RM4SCCBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RM4SCCBarcode Class
RM4SCCBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
SCC14Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : SCC14Barcode Class

Defines a SCC-14 barcode.

Syntax

Visual Basic (Declaration)
Public Class SCC14Barcode
   Inherits Code128CBarcode
Visual Basic (Usage) Copy Code
Dim instance As SCC14Barcode
C#
public class SCC14Barcode : Code128CBarcode
Managed Extensions for C++
public __gc class SCC14Barcode : public Code128CBarcode
C++/CLI
public ref class SCC14Barcode : public Code128CBarcode

Remarks

This class defines a SCC-14 (Shipping Container Code) barcode. Only the following symbols are allowed in a SCC-14 barcode: 0 1 2 3 4 5 6 7 8 9.
A SCC-14 barcode is a special Code 128C barcode using a predefined format with a fixed length. The barcode length is 14 digits. 13 digits are provided by the user, the 14th digit is the check digit and it is calculated automatically by the library.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code128CBarcode
O2S.Barcode4NET.SCC14Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SCC14Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
SCC14Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : SCC14Barcode Class

The following tables list the members exposed by SCC14Barcode.

Public Constructors

 | Name | Description
Public Constructor | SCC14Barcode Constructor | Overloaded. Initializes a new SCC14Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

SCC14Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
SCC14Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > SCC14Barcode Class : SCC14Barcode Constructor

Initializes a new SCC14Barcode object.

Overload List

Overload | Description
SCC14Barcode Constructor() | Initializes a new SCC14Barcode object.
SCC14Barcode Constructor(String) | Initializes a new SCC14Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SCC14Barcode Class
SCC14Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
SCC14Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > SCC14Barcode Class > SCC14Barcode Constructor : SCC14Barcode Constructor()

Initializes a new SCC14Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SCC14Barcode()
C#
public SCC14Barcode()
Managed Extensions for C++
public: SCC14Barcode();
C++/CLI
public:
SCC14Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SCC14Barcode Class
SCC14Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
SCC14Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > SCC14Barcode Class > SCC14Barcode Constructor : SCC14Barcode Constructor(String)

data
The data to be encoded.
Initializes a new SCC14Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As SCC14Barcode(data)
C#
public SCC14Barcode(
   string data
)
Managed Extensions for C++
public: SCC14Barcode(
   string* data
)
C++/CLI
public:
SCC14Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SCC14Barcode Class
SCC14Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
SSCC18Barcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : SSCC18Barcode Class

Defines a SSCC-18 barcode.

Syntax

Visual Basic (Declaration)
Public Class SSCC18Barcode
   Inherits Code128CBarcode
Visual Basic (Usage) Copy Code
Dim instance As SSCC18Barcode
C#
public class SSCC18Barcode : Code128CBarcode
Managed Extensions for C++
public __gc class SSCC18Barcode : public Code128CBarcode
C++/CLI
public ref class SSCC18Barcode : public Code128CBarcode

Remarks

This class defines a SSCC-18 (Serial Shipping Container Code) barcode. Only the following symbols are allowed in a SSCC-18 barcode: 0 1 2 3 4 5 6 7 8 9.
A SSCC-18 barcode is a special Code 128C barcode using a predefined format with a fixed length. The barcode length is 18 digits. 17 digits are provided by the user, the 18th digit is the check digit and it is calculated automatically by the library.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code128CBarcode
O2S.Barcode4NET.SSCC18Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SSCC18Barcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
SSCC18Barcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : SSCC18Barcode Class

The following tables list the members exposed by SSCC18Barcode.

Public Constructors

 | Name | Description
Public Constructor | SSCC18Barcode Constructor | Overloaded. Initializes a new SSCC18Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

SSCC18Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
SSCC18Barcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > SSCC18Barcode Class : SSCC18Barcode Constructor

Initializes a new SSCC18Barcode object.

Overload List

Overload | Description
SSCC18Barcode Constructor() | Initializes a new SSCC18Barcode object.
SSCC18Barcode Constructor(String) | Initializes a new SSCC18Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SSCC18Barcode Class
SSCC18Barcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
SSCC18Barcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > SSCC18Barcode Class > SSCC18Barcode Constructor : SSCC18Barcode Constructor()

Initializes a new SSCC18Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SSCC18Barcode()
C#
public SSCC18Barcode()
Managed Extensions for C++
public: SSCC18Barcode();
C++/CLI
public:
SSCC18Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SSCC18Barcode Class
SSCC18Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
SSCC18Barcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > SSCC18Barcode Class > SSCC18Barcode Constructor : SSCC18Barcode Constructor(String)

data
The data to be encoded.
Initializes a new SSCC18Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As SSCC18Barcode(data)
C#
public SSCC18Barcode(
   string data
)
Managed Extensions for C++
public: SSCC18Barcode(
   string* data
)
C++/CLI
public:
SSCC18Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

SSCC18Barcode Class
SSCC18Barcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
UnidimensionalBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : UnidimensionalBarcode Class

Defines the base class for 1D barcodes.

Syntax

Visual Basic (Declaration)
Public MustInherit Class UnidimensionalBarcode
   Inherits Barcode
Visual Basic (Usage) Copy Code
Dim instance As UnidimensionalBarcode
C#
public abstract class UnidimensionalBarcode : Barcode
Managed Extensions for C++
public __gc abstract class UnidimensionalBarcode : public Barcode
C++/CLI
public ref class UnidimensionalBarcode abstract : public Barcode

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.MSIPlesseyBarcode
O2S.Barcode4NET.MSIPlesseyBarcode
O2S.Barcode4NET.HeightModulatedBarcode
O2S.Barcode4NET.HeightModulatedBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.Code93Barcode
O2S.Barcode4NET.Code93Barcode
O2S.Barcode4NET.Code39Barcode
O2S.Barcode4NET.Code39Barcode
O2S.Barcode4NET.Code25Barcode
O2S.Barcode4NET.Code25Barcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code11Barcode
O2S.Barcode4NET.Code11Barcode
O2S.Barcode4NET.CodabarBarcode
O2S.Barcode4NET.CodabarBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnidimensionalBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
UnidimensionalBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : UnidimensionalBarcode Class

The following tables list the members exposed by UnidimensionalBarcode.

Public Constructors

 | Name | Description
Public Constructor | UnidimensionalBarcode Constructor | Overloaded. Initializes a new UnidimensionalBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Overridden. Gets whether the given character code can be encoded by the barcode.
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

UnidimensionalBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
UnidimensionalBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > UnidimensionalBarcode Class : UnidimensionalBarcode Constructor

Initializes a new UnidimensionalBarcode object.

Overload List

Overload | Description
UnidimensionalBarcode Constructor() | Initializes a new UnidimensionalBarcode object.
UnidimensionalBarcode Constructor(String) | Initializes a new UnidimensionalBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnidimensionalBarcode Class
UnidimensionalBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
UnidimensionalBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > UnidimensionalBarcode Class > UnidimensionalBarcode Constructor : UnidimensionalBarcode Constructor()

Initializes a new UnidimensionalBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UnidimensionalBarcode()
C#
public UnidimensionalBarcode()
Managed Extensions for C++
public: UnidimensionalBarcode();
C++/CLI
public:
UnidimensionalBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnidimensionalBarcode Class
UnidimensionalBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
UnidimensionalBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > UnidimensionalBarcode Class > UnidimensionalBarcode Constructor : UnidimensionalBarcode Constructor(String)

data
The data to be encoded.
Initializes a new UnidimensionalBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As UnidimensionalBarcode(data)
C#
public UnidimensionalBarcode(
   string data
)
Managed Extensions for C++
public: UnidimensionalBarcode(
   string* data
)
C++/CLI
public:
UnidimensionalBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length (applies to some barcodes only).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnidimensionalBarcode Class
UnidimensionalBarcode Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
UnidimensionalBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : UnidimensionalBarcode Class

For a list of all members of this type, see UnidimensionalBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Overridden. Gets whether the given character code can be encoded by the barcode.
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

UnidimensionalBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
IsValidCharacterCode Method
See Also
[image]
O2S.Barcode4NET Namespace > UnidimensionalBarcode Class : IsValidCharacterCode Method

characterCode
The character code to test.
Gets whether the given character code can be encoded by the barcode.

Syntax

Visual Basic (Declaration)
Overrides Public Function IsValidCharacterCode( _
   ByVal characterCode As Byte _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UnidimensionalBarcode
Dim characterCode As Byte
Dim value As Boolean

value = instance.IsValidCharacterCode(characterCode)
C#
public override bool IsValidCharacterCode(
   byte characterCode
)
Managed Extensions for C++
public: bool IsValidCharacterCode(
   byte characterCode
) override
C++/CLI
public:
bool IsValidCharacterCode(
   byte characterCode
) override

Parameters

characterCode
The character code to test.

Return Value

True if the character code can be encoded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnidimensionalBarcode Class
UnidimensionalBarcode Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
UnidimensionalBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : UnidimensionalBarcode Class

For a list of all members of this type, see UnidimensionalBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

UnidimensionalBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
DataDisplayLocation Property
See Also
[image]
O2S.Barcode4NET Namespace > UnidimensionalBarcode Class : DataDisplayLocation Property

Gets or sets the location of the barcode data.

Syntax

Visual Basic (Declaration)
Public Property DataDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As UnidimensionalBarcode
Dim value As BarcodeTextLocation

instance.DataDisplayLocation = value

value = instance.DataDisplayLocation
C#
public BarcodeTextLocation DataDisplayLocation {get; set;}
Managed Extensions for C++
public: __property BarcodeTextLocation get_DataDisplayLocation();
public: __property void set_DataDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation DataDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location of the barcode data when it is displayed on the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnidimensionalBarcode Class
UnidimensionalBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
DisplayCheckSum Property
See Also
[image]
O2S.Barcode4NET Namespace > UnidimensionalBarcode Class : DisplayCheckSum Property

Gets or sets whether the check characters should be displayed in barcode text.

Syntax

Visual Basic (Declaration)
Public Property DisplayCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UnidimensionalBarcode
Dim value As Boolean

instance.DisplayCheckSum = value

value = instance.DisplayCheckSum
C#
public bool DisplayCheckSum {get; set;}
Managed Extensions for C++
public: __property bool get_DisplayCheckSum();
public: __property void set_DisplayCheckSum(
   bool value
);
C++/CLI
public:
property bool DisplayCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if the check characters should be displayed. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnidimensionalBarcode Class
UnidimensionalBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
EnableCheckSum Property
See Also
[image]
O2S.Barcode4NET Namespace > UnidimensionalBarcode Class : EnableCheckSum Property

Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.

Syntax

Visual Basic (Declaration)
Public Property EnableCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UnidimensionalBarcode
Dim value As Boolean

instance.EnableCheckSum = value

value = instance.EnableCheckSum
C#
public bool EnableCheckSum {get; set;}
Managed Extensions for C++
public: __property bool get_EnableCheckSum();
public: __property void set_EnableCheckSum(
   bool value
);
C++/CLI
public:
property bool EnableCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if a checksum symbol should be appended automatically to the barcode, false otherwise.

Remarks

Not all barcodes support checksum symbols. This property is ignored for those that do not support them.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UnidimensionalBarcode Class
UnidimensionalBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
UPCABarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : UPCABarcode Class

Defines the class for UPC-A barcodes.

Syntax

Visual Basic (Declaration)
Public Class UPCABarcode
   Inherits EANBarcode
Visual Basic (Usage) Copy Code
Dim instance As UPCABarcode
C#
public class UPCABarcode : EANBarcode
Managed Extensions for C++
public __gc class UPCABarcode : public EANBarcode
C++/CLI
public ref class UPCABarcode : public EANBarcode

Remarks

UPC-A symbology is a numeric symbology. Only the following symbols are allowed in an UPC-A barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an UPC-A barcode must always have 11 characters length. The first digit is the number system, usually 0, and the last digit is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.UPCABarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCABarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
UPCABarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : UPCABarcode Class

The following tables list the members exposed by UPCABarcode.

Public Constructors

 | Name | Description
Public Constructor | UPCABarcode Constructor | Overloaded. Initializes a new UPCABarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

UPCABarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
UPCABarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > UPCABarcode Class : UPCABarcode Constructor

Initializes a new UPCABarcode object.

Overload List

Overload | Description
UPCABarcode Constructor() | Initializes a new UPCABarcode object.
UPCABarcode Constructor(String) | Initializes a new UPCABarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCABarcode Class
UPCABarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
UPCABarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > UPCABarcode Class > UPCABarcode Constructor : UPCABarcode Constructor()

Initializes a new UPCABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UPCABarcode()
C#
public UPCABarcode()
Managed Extensions for C++
public: UPCABarcode();
C++/CLI
public:
UPCABarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCABarcode Class
UPCABarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
UPCABarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > UPCABarcode Class > UPCABarcode Constructor : UPCABarcode Constructor(String)

data
The data to be encoded.
Initializes a new UPCABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As UPCABarcode(data)
C#
public UPCABarcode(
   string data
)
Managed Extensions for C++
public: UPCABarcode(
   string* data
)
C++/CLI
public:
UPCABarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCABarcode Class
UPCABarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
UPCEBarcode Class
See Also Members
[image]
O2S.Barcode4NET Namespace : UPCEBarcode Class

Defines the class for UPC-E barcodes.

Syntax

Visual Basic (Declaration)
Public Class UPCEBarcode
   Inherits EANBarcode
Visual Basic (Usage) Copy Code
Dim instance As UPCEBarcode
C#
public class UPCEBarcode : EANBarcode
Managed Extensions for C++
public __gc class UPCEBarcode : public EANBarcode
C++/CLI
public ref class UPCEBarcode : public EANBarcode

Remarks

UPC-E symbology is a numeric symbology. Only the following symbols are allowed in an UPC-E barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an UPC-E barcode must always have 7 digits length. The first digit is the number system, usually 0, and the last digit is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.UPCEBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCEBarcode Members
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.CF Send comments on this topic.
UPCEBarcode Class Members
See Also Properties Methods
[image]
O2S.Barcode4NET Namespace : UPCEBarcode Class

The following tables list the members exposed by UPCEBarcode.

Public Constructors

 | Name | Description
Public Constructor | UPCEBarcode Constructor | Overloaded. Initializes a new UPCEBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

UPCEBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
UPCEBarcode Constructor
See Also
[image]
O2S.Barcode4NET Namespace > UPCEBarcode Class : UPCEBarcode Constructor

Initializes a new UPCEBarcode object.

Overload List

Overload | Description
UPCEBarcode Constructor() | Initializes a new UPCEBarcode object.
UPCEBarcode Constructor(String) | Initializes a new UPCEBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCEBarcode Class
UPCEBarcode Members


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
UPCEBarcode Constructor()
See Also
[image]
O2S.Barcode4NET Namespace > UPCEBarcode Class > UPCEBarcode Constructor : UPCEBarcode Constructor()

Initializes a new UPCEBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UPCEBarcode()
C#
public UPCEBarcode()
Managed Extensions for C++
public: UPCEBarcode();
C++/CLI
public:
UPCEBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCEBarcode Class
UPCEBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
UPCEBarcode Constructor(String)
See Also
[image]
O2S.Barcode4NET Namespace > UPCEBarcode Class > UPCEBarcode Constructor : UPCEBarcode Constructor(String)

data
The data to be encoded.
Initializes a new UPCEBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As UPCEBarcode(data)
C#
public UPCEBarcode(
   string data
)
Managed Extensions for C++
public: UPCEBarcode(
   string* data
)
C++/CLI
public:
UPCEBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

UPCEBarcode Class
UPCEBarcode Members
Overload List


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
BarcodeImageFormat Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : BarcodeImageFormat Enumeration

Specifies the available file formats for saving a barcode image.

Syntax

Visual Basic (Declaration)
Public Enum BarcodeImageFormat
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BarcodeImageFormat
C#
public enum BarcodeImageFormat : Enum
Managed Extensions for C++
__value public enum BarcodeImageFormat : public Enum
C++/CLI
public enum class BarcodeImageFormat : public Enum

Members

Member | Description
Bmp | Bitmap file format.
Emf | EMF (Enhanced Windows Metafile) file format.
Eps | EPS (Encapsulated PostScript) file format.
Gif | GIF (Graphics Interchange Format) file format.
Jpeg | JPEG (Joint Photographic Experts Group) file format.
Pdf | PDF (Portable Document Format) file format.
Png | PNG (Portable Network Graphics) file format.
Ps | PS (PostScript) file format.
Svg | SVG (Scalable Vector Graphics) file format.
Tiff | TIFF (Tag Image File Format) file format.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.BarcodeImageFormat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
BarcodeRotation Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : BarcodeRotation Enumeration

Specifies the available rotation angles of the barcode image.

Syntax

Visual Basic (Declaration)
Public Enum BarcodeRotation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BarcodeRotation
C#
public enum BarcodeRotation : Enum
Managed Extensions for C++
__value public enum BarcodeRotation : public Enum
C++/CLI
public enum class BarcodeRotation : public Enum

Members

Member | Description
NoRotation | The barcode image is not rotated.
Rotation90Degrees | The barcode image is rotated with 90 degrees counterclockwise.
Rotation180Degrees | The barcode image is rotated with 180 degrees counterclockwise.
Rotation270Degrees | The barcode image is rotated with 270 degrees counterclockwise.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.BarcodeRotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
BarcodeSymbology Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : BarcodeSymbology Enumeration

Specifies the available barcode symbologies.

Syntax

Visual Basic (Declaration)
Public Enum BarcodeSymbology
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BarcodeSymbology
C#
public enum BarcodeSymbology : Enum
Managed Extensions for C++
__value public enum BarcodeSymbology : public Enum
C++/CLI
public enum class BarcodeSymbology : public Enum

Members

Member | Description
Codabar | Codabar barcode.
Code11 | Code 11 barcode.
Code128A | Code 128A barcode.
Code128B | Code 128B barcode.
Code128C | Code 128C barcode.
Code25 | Industrial 2 of 5 barcode.
Code25Interleaved | Interleaved 2 of 5 barcode.
Code39 | Code 3 of 9 barcode.
Code39Extended | Code 3 of 9 extended barcode.
Code93 | Code 93 barcode.
Code93Extended | Code 93 extended barcode.
Coop25 | COOP 2 of 5 barcode.
Ean13 | EAN13 barcode.
Ean8 | EAN8 barcode.
Iata25 | IATA 2 of 5 barcode.
Isbn | ISBN (International Standard Book Numbering) barcode.
Ismn | ISMN (International Standard Music Number) barcode.
Issn | ISSN (International Standard Serial Number for Periodicals) barcode.
Jan13 | JAN13 barcode.
Matrix25 | Matrix 2 of 5 barcode.
MsiPlessey | MSI Plessey barcode.
Planet | Planet barcode.
PostNet | PostNet barcode.
Rm4Scc | RM4SCC (Royal Mail 4-state Customer Code) barcode.
Scc14 | SCC-14 (Shipping Container Code) barcode
Sscc18 | SSCC-18 (Serial Shipping Container Code) barcode.
UpcA | UPC-A barcode.
UpcE | UPC-E barcode.
CodablockF | CodablockF barcode.
Code16K | Code16K barcode.
DataMatrix | DataMatrix barcode.
MicroPdf417 | Micro PDF417 barcode.
Pdf417 | PDF417 (Portable Data Format) barcode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.BarcodeSymbology

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
BarcodeTextLocation Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : BarcodeTextLocation Enumeration

Specifies the available locations for displaying text on a linear barcode.

Syntax

Visual Basic (Declaration)
Public Enum BarcodeTextLocation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextLocation
C#
public enum BarcodeTextLocation : Enum
Managed Extensions for C++
__value public enum BarcodeTextLocation : public Enum
C++/CLI
public enum class BarcodeTextLocation : public Enum

Members

Member | Description
None | Barcode text is not displayed.
Above | Barcode text is placed above the bar code.
AboveEmbedded | Barcode text is partially embedded at the top of the bar code. The top of the text is aligned with the top of the bars.
Below | Barcode text is placed below the bar code.
BelowEmbedded | Barcode text is partially embedded in the bottom of the bar code. The baseline of the text is aligned with the bottom of the bars.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.BarcodeTextLocation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
DataMatrixEncoding Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : DataMatrixEncoding Enumeration

Specifies the available encoding modes for a DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Enum DataMatrixEncoding
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixEncoding
C#
public enum DataMatrixEncoding : Enum
Managed Extensions for C++
__value public enum DataMatrixEncoding : public Enum
C++/CLI
public enum class DataMatrixEncoding : public Enum

Members

Member | Description
Auto | The encoding is determined automatically based on the data to encode.
ASCII | The data to encode contains ASCII characters only (0x00 - 0x7F). Extended ASCII characters (0x80 - 0xFF) are also supported.
Base256 | The data to encode is a binary stream.
Numeric | The data to encode contains only numbers (ASCII characters 0x30 - 0x39)

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.DataMatrixEncoding

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
DataMatrixSymbolSize Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : DataMatrixSymbolSize Enumeration

Specifies the available sizes for a DataMatrix symbol.

Syntax

Visual Basic (Declaration)
Public Enum DataMatrixSymbolSize
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixSymbolSize
C#
public enum DataMatrixSymbolSize : Enum
Managed Extensions for C++
__value public enum DataMatrixSymbolSize : public Enum
C++/CLI
public enum class DataMatrixSymbolSize : public Enum

Members

Member | Description
Auto | The smallest symbol size is calculated based on available data.
Size10x10 | Square DataMatrix symbol with 10 rows and 10 columns.
Size12x12 | Square DataMatrix symbol with 12 rows and 12 columns.
Size14x14 | Square DataMatrix symbol with 14 rows and 14 columns.
Size16x16 | Square DataMatrix symbol with 16 rows and 16 columns.
Size18x18 | Square DataMatrix symbol with 18 rows and 18 columns.
Size20x20 | Square DataMatrix symbol with 20 rows and 20 columns.
Size22x22 | Square DataMatrix symbol with 22 rows and 22 columns.
Size24x24 | Square DataMatrix symbol with 24 rows and 24 columns.
Size26x26 | Square DataMatrix symbol with 26 rows and 26 columns.
Size32x32 | Square DataMatrix symbol with 32 rows and 32 columns.
Size36x36 | Square DataMatrix symbol with 36 rows and 36 columns.
Size40x40 | Square DataMatrix symbol with 40 rows and 40 columns.
Size44x44 | Square DataMatrix symbol with 44 rows and 44 columns.
Size48x48 | Square DataMatrix symbol with 48 rows and 48 columns.
Size52x52 | Square DataMatrix symbol with 52 rows and 52 columns.
Size64x64 | Square DataMatrix symbol with 64 rows and 64 columns.
Size72x72 | Square DataMatrix symbol with 72 rows and 72 columns.
Size80x80 | Square DataMatrix symbol with 80 rows and 80 columns.
Size88x88 | Square DataMatrix symbol with 88 rows and 88 columns.
Size96x96 | Square DataMatrix symbol with 96 rows and 96 columns.
Size104x104 | Square DataMatrix symbol with 104 rows and 104 columns.
Size120x120 | Square DataMatrix symbol with 120 rows and 120 columns.
Size132x132 | Square DataMatrix symbol with 132 rows and 132 columns.
Size144x144 | Square DataMatrix symbol with 144 rows and 144 columns.
Size8x18 | Rectangular DataMatrix symbol with 8 rows and 18 columns.
Size8x32 | Rectangular DataMatrix symbol with 8 rows and 32 columns.
Size12x26 | Rectangular DataMatrix symbol with 12 rows and 26 columns.
Size12x36 | Rectangular DataMatrix symbol with 12 rows and 36 columns.
Size16x36 | Rectangular DataMatrix symbol with 16 rows and 36 columns.
Size16x48 | Rectangular DataMatrix symbol with 16 rows and 48 columns.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.DataMatrixSymbolSize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
MicroPDF417SymbolSize Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : MicroPDF417SymbolSize Enumeration

Specifies the available sizes for a Micro PDF417 symbol.

Syntax

Visual Basic (Declaration)
Public Enum MicroPDF417SymbolSize
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MicroPDF417SymbolSize
C#
public enum MicroPDF417SymbolSize : Enum
Managed Extensions for C++
__value public enum MicroPDF417SymbolSize : public Enum
C++/CLI
public enum class MicroPDF417SymbolSize : public Enum

Members

Member | Description
Auto | The smallest symbol size is calculated based on available data.
Size11x1 | Micro PDF417 symbol with 11 rows and 1 column.
Size14x1 | Micro PDF417 symbol with 14 rows and 1 column.
Size17x1 | Micro PDF417 symbol with 17 rows and 1 column.
Size20x1 | Micro PDF417 symbol with 20 rows and 1 column.
Size24x1 | Micro PDF417 symbol with 24 rows and 1 column.
Size28x1 | Micro PDF417 symbol with 28 rows and 1 column.
Size8x2 | Micro PDF417 symbol with 8 rows and 2 columns.
Size11x2 | Micro PDF417 symbol with 11 rows and 2 columns.
Size14x2 | Micro PDF417 symbol with 14 rows and 2 columns.
Size17x2 | Micro PDF417 symbol with 17 rows and 2 columns.
Size20x2 | Micro PDF417 symbol with 20 rows and 2 columns.
Size23x2 | Micro PDF417 symbol with 23 rows and 2 columns.
Size26x2 | Micro PDF417 symbol with 26 rows and 2 columns.
Size6x3 | Micro PDF417 symbol with 6 rows and 3 columns.
Size8x3 | Micro PDF417 symbol with 8 rows and 3 columns.
Size10x3 | Micro PDF417 symbol with 10 rows and 3 columns.
Size12x3 | Micro PDF417 symbol with 12 rows and 3 columns.
Size15x3 | Micro PDF417 symbol with 15 rows and 3 columns.
Size20x3 | Micro PDF417 symbol with 20 rows and 3 columns.
Size26x3 | Micro PDF417 symbol with 26 rows and 3 columns.
Size32x3 | Micro PDF417 symbol with 32 rows and 3 columns.
Size38x3 | Micro PDF417 symbol with 38 rows and 3 columns.
Size44x3 | Micro PDF417 symbol with 44 rows and 3 columns.
Size4x4 | Micro PDF417 symbol with 4 rows and 4 columns.
Size6x4 | Micro PDF417 symbol with 6 rows and 4 columns.
Size8x4 | Micro PDF417 symbol with 8 rows and 4 columns.
Size10x4 | Micro PDF417 symbol with 10 rows and 4 columns.
Size12x4 | Micro PDF417 symbol with 12 rows and 4 columns.
Size15x4 | Micro PDF417 symbol with 15 rows and 4 columns.
Size20x4 | Micro PDF417 symbol with 20 rows and 4 columns.
Size26x4 | Micro PDF417 symbol with 26 rows and 4 columns.
Size32x4 | Micro PDF417 symbol with 32 rows and 4 columns.
Size38x4 | Micro PDF417 symbol with 38 rows and 4 columns.
Size44x4 | Micro PDF417 symbol with 44 rows and 4 columns.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.MicroPDF417SymbolSize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
PDF417DataCompactionMode Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : PDF417DataCompactionMode Enumeration

Specifies the available data compaction modes for a PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Enum PDF417DataCompactionMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF417DataCompactionMode
C#
public enum PDF417DataCompactionMode : Enum
Managed Extensions for C++
__value public enum PDF417DataCompactionMode : public Enum
C++/CLI
public enum class PDF417DataCompactionMode : public Enum

Members

Member | Description
Text | Text compaction mode.
Numeric | Numeric compaction mode.
Byte | Binary compaction mode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.PDF417DataCompactionMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
PDF417ErrorCorrectionLevel Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : PDF417ErrorCorrectionLevel Enumeration

Specifies the available error correction levels for a PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Enum PDF417ErrorCorrectionLevel
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF417ErrorCorrectionLevel
C#
public enum PDF417ErrorCorrectionLevel : Enum
Managed Extensions for C++
__value public enum PDF417ErrorCorrectionLevel : public Enum
C++/CLI
public enum class PDF417ErrorCorrectionLevel : public Enum

Members

Member | Description
Level0 | Level 0 - 2 error correction codewords.
Level1 | Level 1 - 4 error correction codewords.
Level2 | Level 2 - 8 error correction codewords.
Level3 | Level 3 - 16 error correction codewords.
Level4 | Level 4 - 32 error correction codewords.
Level5 | Level 5 - 64 error correction codewords.
Level6 | Level 6 - 128 error correction codewords.
Level7 | Level 7 - 256 error correction codewords.
Level8 | Level 8 - 512 error correction codewords.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.PDF417ErrorCorrectionLevel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


%%PageItemTitle%%

Barcode4NET.CF Send comments on this topic.
XYDimensionUnit Enumeration
See Also
[image]
O2S.Barcode4NET Namespace : XYDimensionUnit Enumeration

Specifies the unit of measure for the barcode's XDimension and YDimension properties.

Syntax

Visual Basic (Declaration)
Public Enum XYDimensionUnit
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XYDimensionUnit
C#
public enum XYDimensionUnit : Enum
Managed Extensions for C++
__value public enum XYDimensionUnit : public Enum
C++/CLI
public enum class XYDimensionUnit : public Enum

Members

Member | Description
Inch | Specifies the inch as the unit of measure.
Mil | Specifies the mil (1/1000 inch) as the unit of measure.
Millimeter | Specifies the millimeter as the unit of measure.
Pixel | Specifies the pixel as the unit of measure.
Point | Specifies a printer's point (1/72 inch) as the unit of measure.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Barcode4NET.XYDimensionUnit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Barcode4NET Namespace


$$INTRODUCTION$$ - %%projecttitle%%

Barcode4NET.Windows.CF Send comments on this topic.
Introduction
Welcome to Barcode4View Windows Forms control for .NetCF online help.


%%phrase%%

Barcode4NET.Windows.CF Send comments on this topic.
Barcode4NET.Windows.CF Assembly
The Barcode4NET.Windows.CF assembly includes the BarcodeView Windows Forms control for .NetCF.

Namespaces

Namespace | Description
O2S.Barcode4NET.WinControls | Root namespace for all Windows Forms controls included in Barcode4NET.Windows.CF assembly.


$$GETTING_STARTED$$ - %%projecttitle%%

Barcode4NET.Windows.CF Send comments on this topic.
Getting Started
This online help will help you get started with BarcodeView Windows Forms control for .NetCF.


%%ItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
O2S.Barcode4NET.WinControls Namespace (Barcode4NET.Windows.CF)
See Also Inheritance Hierarchy
Root namespace for all Windows Forms controls included in Barcode4NET.Windows.CF assembly.

Classes

Class | Description
BarcodeView | Represents a barcode control displayed on a form.

See Also

Reference

Barcode4NET.Windows.CF Assembly


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
BarcodeView Class
See Also Members
[image]
O2S.Barcode4NET.WinControls Namespace : BarcodeView Class

Represents a barcode control displayed on a form.

Object Model

Syntax

Visual Basic (Declaration)
Public Class BarcodeView
   Inherits Control
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
C#
public class BarcodeView : Control
Managed Extensions for C++
public __gc class BarcodeView : public Control
C++/CLI
public ref class BarcodeView : public Control

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
O2S.Barcode4NET.WinControls.BarcodeView

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Members
O2S.Barcode4NET.WinControls Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.Windows.CF Send comments on this topic.
BarcodeView Class Members
See Also Properties Methods Events
[image]
O2S.Barcode4NET.WinControls Namespace : BarcodeView Class

The following tables list the members exposed by BarcodeView.

Public Constructors

 | Name | Description
Public Constructor | BarcodeView Constructor | Initializes a new BarcodeView object.
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView. (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | Overridden. Gets or sets the background color for the barcode.
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | Barcode | Gets the Barcode object behind the control.
Public Property | BarColor | Gets or sets the bars color for the barcode.
Public Property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BorderColor | Gets or sets the border color for the barcode.
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode.
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CodablockFColumns | Gets or sets the number of columns in this CODABLOCK F barcode.
Public Property | CodablockFRows | Gets or sets the number of rows in this CODABLOCK F barcode.
Public Property | Code16KRows | Gets or sets the number of rows in this Code 16K barcode.
Public Property | Code39WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | Gets the IContainer that contains the Component. (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | Data | Gets or sets the data displayed in the control.
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DataMatrixEncoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | DataMatrixSymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties.
Public Property | DisplayCheckSum | Gets or sets a value indicating whether the check characters should be displayed in barcode text.
Public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | EANSupplement | Gets or sets the supplement for barcode data.
Public Property | EANSupplementDisplayLocation | Gets or sets the location of the EAN supplement text.
Public Property | EANSupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum character should be appended automatically to the barcode.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Overridden. Gets or sets the font of the barcode text displayed in the control.
Public Property | ForeColor | Overridden. Gets or sets the fore color of the control.
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode.
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MicroPDF417SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Pdf417Columns | Gets or sets the number of columns in this PDF417 barcode.
Public Property | Pdf417DataCompactionMode | Gets or sets the data compaction mode for this PDF417 barcode.
Public Property | Pdf417ErrorCorrectionLevel | Gets or sets the level of error correction used by this PDF417 barcode.
Public Property | Pdf417Rows | Gets or sets the number of rows in this PDF417 barcode.
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode.
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | SerialNumber | Gets or sets the serial number.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Symbology | Gets or sets the type of the barcode displayed in the control.
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | TextColor | Gets or sets the text color for the barcode.
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode.
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | XDimension | Gets or sets the width of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Clean up any resources being used. Releases all resources used by the Component. (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | SizeChanged | Occurs when the Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

BarcodeView Class
O2S.Barcode4NET.WinControls Namespace


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
BarcodeView Constructor
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : BarcodeView Constructor

Initializes a new BarcodeView object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView()
C#
public BarcodeView()
Managed Extensions for C++
public: BarcodeView();
C++/CLI
public:
BarcodeView();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.Windows.CF Send comments on this topic.
BarcodeView Class Properties
See Also
[image]
O2S.Barcode4NET.WinControls Namespace : BarcodeView Class

For a list of all members of this type, see BarcodeView members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView. (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | Overridden. Gets or sets the background color for the barcode.
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | Barcode | Gets the Barcode object behind the control.
Public Property | BarColor | Gets or sets the bars color for the barcode.
Public Property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BorderColor | Gets or sets the border color for the barcode.
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode.
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CodablockFColumns | Gets or sets the number of columns in this CODABLOCK F barcode.
Public Property | CodablockFRows | Gets or sets the number of rows in this CODABLOCK F barcode.
Public Property | Code16KRows | Gets or sets the number of rows in this Code 16K barcode.
Public Property | Code39WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | Gets the IContainer that contains the Component. (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | Data | Gets or sets the data displayed in the control.
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DataMatrixEncoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | DataMatrixSymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties.
Public Property | DisplayCheckSum | Gets or sets a value indicating whether the check characters should be displayed in barcode text.
Public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | EANSupplement | Gets or sets the supplement for barcode data.
Public Property | EANSupplementDisplayLocation | Gets or sets the location of the EAN supplement text.
Public Property | EANSupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum character should be appended automatically to the barcode.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Overridden. Gets or sets the font of the barcode text displayed in the control.
Public Property | ForeColor | Overridden. Gets or sets the fore color of the control.
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode.
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MicroPDF417SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Pdf417Columns | Gets or sets the number of columns in this PDF417 barcode.
Public Property | Pdf417DataCompactionMode | Gets or sets the data compaction mode for this PDF417 barcode.
Public Property | Pdf417ErrorCorrectionLevel | Gets or sets the level of error correction used by this PDF417 barcode.
Public Property | Pdf417Rows | Gets or sets the number of rows in this PDF417 barcode.
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode.
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | SerialNumber | Gets or sets the serial number.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Symbology | Gets or sets the type of the barcode displayed in the control.
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | TextColor | Gets or sets the text color for the barcode.
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode.
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from System.Windows.Forms.Control)
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | XDimension | Gets or sets the width of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

See Also

Reference

BarcodeView Class
O2S.Barcode4NET.WinControls Namespace


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
BackColor Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : BackColor Property

Gets or sets the background color for the barcode.

Syntax

Visual Basic (Declaration)
Overrides Public Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
public override Color BackColor {get; set;}
Managed Extensions for C++
public: __property Color get_BackColor()override ;
public: __property void set_BackColor(
   Color value
)override ;
C++/CLI
public:
property Color BackColor override {
   Color get();
   void set (Color value);
}

Return Value

A Color that represents the background color of the barcode. The default value is White.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
Barcode Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Barcode Property

Gets the Barcode object behind the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Barcode As Barcode
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Barcode

value = instance.Barcode
C#
public Barcode Barcode {get;}
Managed Extensions for C++
public: __property Barcode* get_Barcode();
C++/CLI
public:
property Barcode^ Barcode {
   Barcode^ get();
}

Return Value

A Barcode object that represents the barcode displayed in the control.

Remarks

If this Barcode object is modified directly, call control's Update method to reflect the changes in the displayed barcode image.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
BarColor Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : BarColor Property

Gets or sets the bars color for the barcode.

Syntax

Visual Basic (Declaration)
Public Property BarColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Color

instance.BarColor = value

value = instance.BarColor
C#
public Color BarColor {get; set;}
Managed Extensions for C++
public: __property Color get_BarColor();
public: __property void set_BarColor(
   Color value
);
C++/CLI
public:
property Color BarColor {
   Color get();
   void set (Color value);
}

Return Value

A Color that represents the bars color of the barcode. The default value is Black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
BorderColor Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : BorderColor Property

Gets or sets the border color for the barcode.

Syntax

Visual Basic (Declaration)
Public Property BorderColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Color

instance.BorderColor = value

value = instance.BorderColor
C#
public Color BorderColor {get; set;}
Managed Extensions for C++
public: __property Color get_BorderColor();
public: __property void set_BorderColor(
   Color value
);
C++/CLI
public:
property Color BorderColor {
   Color get();
   void set (Color value);
}

Return Value

A Color object specifying the color of the control border.

Remarks

This border is drawn only if the border width is greater than 0 and BorderStyle property is Adjust.
Note: BorderStyle property is not available for .Net Compact Framework.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
BottomQuietZone Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : BottomQuietZone Property

Gets or sets the bottom quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property BottomQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.BottomQuietZone = value

value = instance.BottomQuietZone
C#
public float BottomQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_BottomQuietZone();
public: __property void set_BottomQuietZone(
   float value
);
C++/CLI
public:
property float BottomQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of bottom quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the bottom quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
CodablockFColumns Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : CodablockFColumns Property

Gets or sets the number of columns in this CODABLOCK F barcode.

Syntax

Visual Basic (Declaration)
Public Property CodablockFColumns As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Integer

instance.CodablockFColumns = value

value = instance.CodablockFColumns
C#
public int CodablockFColumns {get; set;}
Managed Extensions for C++
public: __property int get_CodablockFColumns();
public: __property void set_CodablockFColumns(
   int value
);
C++/CLI
public:
property int CodablockFColumns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this CODABLOCK F barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 7 or greater than 65.

Remarks

The minimum number of columns in a CODABLOCK F barcode is 7 and the maximum number of columns is 65. This property includes the character subset selector, row indicator and row check columns.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
CodablockFRows Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : CodablockFRows Property

Gets or sets the number of rows in this CODABLOCK F barcode.

Syntax

Visual Basic (Declaration)
Public Property CodablockFRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Integer

instance.CodablockFRows = value

value = instance.CodablockFRows
C#
public int CodablockFRows {get; set;}
Managed Extensions for C++
public: __property int get_CodablockFRows();
public: __property void set_CodablockFRows(
   int value
);
C++/CLI
public:
property int CodablockFRows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows in this CODABLOCK F barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2 or greater than 44.

Remarks

The minimum number of rows in a CODABLOCK F barcode is 2 and the maximum number of rows is 44.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
Code16KRows Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Code16KRows Property

Gets or sets the number of rows in this Code 16K barcode.

Syntax

Visual Basic (Declaration)
Public Property Code16KRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Integer

instance.Code16KRows = value

value = instance.Code16KRows
C#
public int Code16KRows {get; set;}
Managed Extensions for C++
public: __property int get_Code16KRows();
public: __property void set_Code16KRows(
   int value
);
C++/CLI
public:
property int Code16KRows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows in this Code 16K barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2 but not 0, or greater than 16.

Remarks

The minimum number of rows in a Code 16K barcode is 2 and the maximum number of rows is 16. If this property is 0, the number of rows is calculated automatically to accomodate the barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
Code39WideToNarrowRatio Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Code39WideToNarrowRatio Property

Gets or sets the ratio between wide bars and narrow bars.

Syntax

Visual Basic (Declaration)
Public Property Code39WideToNarrowRatio As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.Code39WideToNarrowRatio = value

value = instance.Code39WideToNarrowRatio
C#
public float Code39WideToNarrowRatio {get; set;}
Managed Extensions for C++
public: __property float get_Code39WideToNarrowRatio();
public: __property void set_Code39WideToNarrowRatio(
   float value
);
C++/CLI
public:
property float Code39WideToNarrowRatio {
   float get();
   void set (float value);
}

Return Value

A float value specifying the ratio between wide bars and narrow bars.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.
This property applies to Code39 barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
Data Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Data Property

Gets or sets the data displayed in the control.

Syntax

Visual Basic (Declaration)
Public Property Data As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As String

instance.Data = value

value = instance.Data
C#
public string Data {get; set;}
Managed Extensions for C++
public: __property string* get_Data();
public: __property void set_Data(
   string* value
);
C++/CLI
public:
property String^ Data {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing the data displayed in the control as a barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
DataDisplayLocation Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : DataDisplayLocation Property

Gets or sets the location of the barcode data.

Syntax

Visual Basic (Declaration)
Public Property DataDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As BarcodeTextLocation

instance.DataDisplayLocation = value

value = instance.DataDisplayLocation
C#
public BarcodeTextLocation DataDisplayLocation {get; set;}
Managed Extensions for C++
public: __property BarcodeTextLocation get_DataDisplayLocation();
public: __property void set_DataDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation DataDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location of the barcode data when it is displayed on the barcode.

Remarks

This property applies to 1D barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
DataMatrixEncoding Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : DataMatrixEncoding Property

Gets or sets the encoding of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property DataMatrixEncoding As DataMatrixEncoding
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As DataMatrixEncoding

instance.DataMatrixEncoding = value

value = instance.DataMatrixEncoding
C#
public DataMatrixEncoding DataMatrixEncoding {get; set;}
Managed Extensions for C++
public: __property DataMatrixEncoding get_DataMatrixEncoding();
public: __property void set_DataMatrixEncoding(
   DataMatrixEncoding value
);
C++/CLI
public:
property DataMatrixEncoding DataMatrixEncoding {
   DataMatrixEncoding get();
   void set (DataMatrixEncoding value);
}

Return Value

A DataMatrixEncoding enumeration member specifying the data encoding for this DataMatrix barcode.

Remarks

If the data to encode contains only numbers (ASCII characters from 0x30 to 0x39), then Numeric provides the best encoding. If the data to encode contains only base ASCII characters (0x00 to 0x7F), then both ASCII and Base256 encoding provide the same performance, but if the data to encode contains more than 3 extended ASCII characters (0x80 to 0xFF) then the Base256 encoding is the best option.
If the selected encoding is Auto, then the library will select the encoding that will generate the smallest encoded data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
DataMatrixSymbolSize Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : DataMatrixSymbolSize Property

Gets or sets the symbol size of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property DataMatrixSymbolSize As DataMatrixSymbolSize
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As DataMatrixSymbolSize

instance.DataMatrixSymbolSize = value

value = instance.DataMatrixSymbolSize
C#
public DataMatrixSymbolSize DataMatrixSymbolSize {get; set;}
Managed Extensions for C++
public: __property DataMatrixSymbolSize get_DataMatrixSymbolSize();
public: __property void set_DataMatrixSymbolSize(
   DataMatrixSymbolSize value
);
C++/CLI
public:
property DataMatrixSymbolSize DataMatrixSymbolSize {
   DataMatrixSymbolSize get();
   void set (DataMatrixSymbolSize value);
}

Return Value

A DataMatrixSymbolSize enumeration member specifying the size of symbol used to represent this DataMatrix barcode.

Remarks

If the SymbolSize is Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
DimensionUnit Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : DimensionUnit Property

Gets or sets the measure unit for the XDimension and YDimension properties.

Syntax

Visual Basic (Declaration)
Public Property DimensionUnit As XYDimensionUnit
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As XYDimensionUnit

instance.DimensionUnit = value

value = instance.DimensionUnit
C#
public XYDimensionUnit DimensionUnit {get; set;}
Managed Extensions for C++
public: __property XYDimensionUnit get_DimensionUnit();
public: __property void set_DimensionUnit(
   XYDimensionUnit value
);
C++/CLI
public:
property XYDimensionUnit DimensionUnit {
   XYDimensionUnit get();
   void set (XYDimensionUnit value);
}

Return Value

A XYDimensionUnit enumeration member specifying the measure unit for the XDimension and YDimension properties.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
DisplayCheckSum Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : DisplayCheckSum Property

Gets or sets a value indicating whether the check characters should be displayed in barcode text.

Syntax

Visual Basic (Declaration)
Public Property DisplayCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Boolean

instance.DisplayCheckSum = value

value = instance.DisplayCheckSum
C#
public bool DisplayCheckSum {get; set;}
Managed Extensions for C++
public: __property bool get_DisplayCheckSum();
public: __property void set_DisplayCheckSum(
   bool value
);
C++/CLI
public:
property bool DisplayCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if the check characters should be displayed. Default is false.

Remarks

This property applies to 1D barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
EANSupplement Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : EANSupplement Property

Gets or sets the supplement for barcode data.

Syntax

Visual Basic (Declaration)
Public Property EANSupplement As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As String

instance.EANSupplement = value

value = instance.EANSupplement
C#
public string EANSupplement {get; set;}
Managed Extensions for C++
public: __property string* get_EANSupplement();
public: __property void set_EANSupplement(
   string* value
);
C++/CLI
public:
property String^ EANSupplement {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying a 2 or 5 digit supplemental barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in supplement data or the supplement does not have the required length (2 or 5 digits).

Remarks

This supplement is optional. If it exists, it can be only 2 or 5 digits.
This property applies to EAN13, EAN8, ISBN, ISMN, ISSN, JAN13, UPC-A and UPC-E barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
EANSupplementDisplayLocation Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : EANSupplementDisplayLocation Property

Gets or sets the location of the EAN supplement text.

Syntax

Visual Basic (Declaration)
Public Property EANSupplementDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As BarcodeTextLocation

instance.EANSupplementDisplayLocation = value

value = instance.EANSupplementDisplayLocation
C#
public BarcodeTextLocation EANSupplementDisplayLocation {get; set;}
Managed Extensions for C++
public: __property BarcodeTextLocation get_EANSupplementDisplayLocation();
public: __property void set_EANSupplementDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation EANSupplementDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location where the supplement text is displayed.

Remarks

The embedding options are ignored for supplement text. AboveEmbedded has the same effect like Above, and BelowEmbedded has the same effect like Below.
This property applies to EAN13, EAN8, ISBN, ISMN, ISSN, JAN13, UPC-A and UPC-E barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
EANSupplementYDimension Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : EANSupplementYDimension Property

Gets or sets the height of a bar in the supplement barcode.

Syntax

Visual Basic (Declaration)
Public Property EANSupplementYDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.EANSupplementYDimension = value

value = instance.EANSupplementYDimension
C#
public float EANSupplementYDimension {get; set;}
Managed Extensions for C++
public: __property float get_EANSupplementYDimension();
public: __property void set_EANSupplementYDimension(
   float value
);
C++/CLI
public:
property float EANSupplementYDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a bar in the supplement barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
EnableCheckSum Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : EnableCheckSum Property

Gets or sets a value indicating whether a checksum character should be appended automatically to the barcode.

Syntax

Visual Basic (Declaration)
Public Property EnableCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Boolean

instance.EnableCheckSum = value

value = instance.EnableCheckSum
C#
public bool EnableCheckSum {get; set;}
Managed Extensions for C++
public: __property bool get_EnableCheckSum();
public: __property void set_EnableCheckSum(
   bool value
);
C++/CLI
public:
property bool EnableCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if a checksum character should be appended automatically to the barcode, false otherwise.

Remarks

This property applies to 1D barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
Font Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Font Property

Gets or sets the font of the barcode text displayed in the control.

Syntax

Visual Basic (Declaration)
Overrides Public Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Font

instance.Font = value

value = instance.Font
C#
public override Font Font {get; set;}
Managed Extensions for C++
public: __property Font get_Font()override ;
public: __property void set_Font(
   Font value
)override ;
C++/CLI
public:
property Font Font override {
   Font get();
   void set (Font value);
}

Return Value

The Font object to apply to the barcode text displayed in the control.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
ForeColor Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : ForeColor Property

Gets or sets the fore color of the control.

Syntax

Visual Basic (Declaration)
Overrides Public Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
C#
public override Color ForeColor {get; set;}
Managed Extensions for C++
public: __property Color get_ForeColor()override ;
public: __property void set_ForeColor(
   Color value
)override ;
C++/CLI
public:
property Color ForeColor override {
   Color get();
   void set (Color value);
}

Remarks

This property is not used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
LeftQuietZone Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : LeftQuietZone Property

Gets or sets the left quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property LeftQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.LeftQuietZone = value

value = instance.LeftQuietZone
C#
public float LeftQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_LeftQuietZone();
public: __property void set_LeftQuietZone(
   float value
);
C++/CLI
public:
property float LeftQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of left quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the left quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
MicroPDF417SymbolSize Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : MicroPDF417SymbolSize Property

Gets or sets the symbol size of this Micro PDF 417 barcode.

Syntax

Visual Basic (Declaration)
Public Property MicroPDF417SymbolSize As MicroPDF417SymbolSize
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As MicroPDF417SymbolSize

instance.MicroPDF417SymbolSize = value

value = instance.MicroPDF417SymbolSize
C#
public MicroPDF417SymbolSize MicroPDF417SymbolSize {get; set;}
Managed Extensions for C++
public: __property MicroPDF417SymbolSize get_MicroPDF417SymbolSize();
public: __property void set_MicroPDF417SymbolSize(
   MicroPDF417SymbolSize value
);
C++/CLI
public:
property MicroPDF417SymbolSize MicroPDF417SymbolSize {
   MicroPDF417SymbolSize get();
   void set (MicroPDF417SymbolSize value);
}

Return Value

A MicroPDF417SymbolSize enumeration member specifying the size of symbol used to represent this Micro PDF 417 barcode.

Remarks

If the SymbolSize is Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
Pdf417Columns Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Pdf417Columns Property

Gets or sets the number of columns in this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Integer

instance.Pdf417Columns = value

value = instance.Pdf417Columns
C#
public int Pdf417Columns {get; set;}
Managed Extensions for C++
public: __property int get_Pdf417Columns();
public: __property void set_Pdf417Columns(
   int value
);
C++/CLI
public:
property int Pdf417Columns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this PDF417 barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 1 or greater than 30 - OR - Throws when value is 0 and Pdf417Rows is also 0.

Remarks

The minimum number of columns in a PDF 417 barcode is 1 and the maximum number of columns is 30. If this property is 0, the library will compute automatically the number of required columns to encode the barcode data. When this property is 0, the Pdf417Rows property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
Pdf417DataCompactionMode Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Pdf417DataCompactionMode Property

Gets or sets the data compaction mode for this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417DataCompactionMode As PDF417DataCompactionMode
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As PDF417DataCompactionMode

instance.Pdf417DataCompactionMode = value

value = instance.Pdf417DataCompactionMode
C#
public PDF417DataCompactionMode Pdf417DataCompactionMode {get; set;}
Managed Extensions for C++
public: __property PDF417DataCompactionMode get_Pdf417DataCompactionMode();
public: __property void set_Pdf417DataCompactionMode(
   PDF417DataCompactionMode value
);
C++/CLI
public:
property PDF417DataCompactionMode Pdf417DataCompactionMode {
   PDF417DataCompactionMode get();
   void set (PDF417DataCompactionMode value);
}

Return Value

A PDF417DataCompactionMode enumeration member specifying the data compaction mode used in this PDF417 barcode.

Remarks

The Text compaction mode provides a 2:1 compaction ratio when using only ASCII characters from 0x20 to 0x7F. The Numeric compaction mode provides a 2.93:1 compaction ratio when using only digits (0x30 to 0x39). Byte compaction mode provides a 1.2:1 compaction ratio when using any 8bit character.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
Pdf417ErrorCorrectionLevel Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Pdf417ErrorCorrectionLevel Property

Gets or sets the level of error correction used by this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417ErrorCorrectionLevel As PDF417ErrorCorrectionLevel
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As PDF417ErrorCorrectionLevel

instance.Pdf417ErrorCorrectionLevel = value

value = instance.Pdf417ErrorCorrectionLevel
C#
public PDF417ErrorCorrectionLevel Pdf417ErrorCorrectionLevel {get; set;}
Managed Extensions for C++
public: __property PDF417ErrorCorrectionLevel get_Pdf417ErrorCorrectionLevel();
public: __property void set_Pdf417ErrorCorrectionLevel(
   PDF417ErrorCorrectionLevel value
);
C++/CLI
public:
property PDF417ErrorCorrectionLevel Pdf417ErrorCorrectionLevel {
   PDF417ErrorCorrectionLevel get();
   void set (PDF417ErrorCorrectionLevel value);
}

Return Value

A PDF417ErrorCorrectionLevel enumeration member specifying the level or error correction used by this PDF417 barcode.

Remarks

The lowest error correction level is 0 and the greatest error correction level is 8. Each level generates a specific number of error correction codewords.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
Pdf417Rows Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Pdf417Rows Property

Gets or sets the number of rows in this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Integer

instance.Pdf417Rows = value

value = instance.Pdf417Rows
C#
public int Pdf417Rows {get; set;}
Managed Extensions for C++
public: __property int get_Pdf417Rows();
public: __property void set_Pdf417Rows(
   int value
);
C++/CLI
public:
property int Pdf417Rows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows used by this PDF417 barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 3, but not 0, or greater than 90 - OR - Throws when value is 0 and Pdf417Columns is also 0.

Remarks

The minimum number of rows in a PDF 417 barcode is 3 and the maximum number of rows is 90. If this property is 0, the library will compute automatically the number of required rows to encode the barcode data. When this property is 0, the Pdf417Columns property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
RightQuietZone Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : RightQuietZone Property

Gets or sets the right quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property RightQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.RightQuietZone = value

value = instance.RightQuietZone
C#
public float RightQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_RightQuietZone();
public: __property void set_RightQuietZone(
   float value
);
C++/CLI
public:
property float RightQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of right quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the right quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
SerialNumber Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : SerialNumber Property

Gets or sets the serial number.

Syntax

Visual Basic (Declaration)
Public Property SerialNumber As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As String

instance.SerialNumber = value

value = instance.SerialNumber
C#
public string SerialNumber {get; set;}
Managed Extensions for C++
public: __property string* get_SerialNumber();
public: __property void set_SerialNumber(
   string* value
);
C++/CLI
public:
property String^ SerialNumber {
   String^ get();
   void set (String^ value);
}

Return Value

The Barcode4NET serial number.

Remarks

The serial number unlocks the BarcodeView Windows Forms control and removes the TRIAL watermark from the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
Symbology Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : Symbology Property

Gets or sets the type of the barcode displayed in the control.

Syntax

Visual Basic (Declaration)
Public Property Symbology As BarcodeSymbology
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As BarcodeSymbology

instance.Symbology = value

value = instance.Symbology
C#
public BarcodeSymbology Symbology {get; set;}
Managed Extensions for C++
public: __property BarcodeSymbology get_Symbology();
public: __property void set_Symbology(
   BarcodeSymbology value
);
C++/CLI
public:
property BarcodeSymbology Symbology {
   BarcodeSymbology get();
   void set (BarcodeSymbology value);
}

Return Value

A BarcodeSymbology enumeration member specifying the type of the barcode displayed in the control.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
TextColor Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : TextColor Property

Gets or sets the text color for the barcode.

Syntax

Visual Basic (Declaration)
Public Property TextColor As Color
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Color

instance.TextColor = value

value = instance.TextColor
C#
public Color TextColor {get; set;}
Managed Extensions for C++
public: __property Color get_TextColor();
public: __property void set_TextColor(
   Color value
);
C++/CLI
public:
property Color TextColor {
   Color get();
   void set (Color value);
}

Return Value

A Color that represents the color used to display the barcode data. The default value is Black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
TopQuietZone Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : TopQuietZone Property

Gets or sets the top quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property TopQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.TopQuietZone = value

value = instance.TopQuietZone
C#
public float TopQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_TopQuietZone();
public: __property void set_TopQuietZone(
   float value
);
C++/CLI
public:
property float TopQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of top quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the top quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
XDimension Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : XDimension Property

Gets or sets the width of a narrow bar.

Syntax

Visual Basic (Declaration)
Public Property XDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.XDimension = value

value = instance.XDimension
C#
public float XDimension {get; set;}
Managed Extensions for C++
public: __property float get_XDimension();
public: __property void set_XDimension(
   float value
);
C++/CLI
public:
property float XDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of a narrow bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.
The recommended width of a narrow bar is 12 mills. Depending on the barcode printer resolution and quality of barcode scanner, the XDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower XDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


%%PageItemTitle%%

Barcode4NET.Windows.CF Send comments on this topic.
YDimension Property
See Also
[image]
O2S.Barcode4NET.WinControls Namespace > BarcodeView Class : YDimension Property

Gets or sets the height of a bar.

Syntax

Visual Basic (Declaration)
Public Property YDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeView
Dim value As Single

instance.YDimension = value

value = instance.YDimension
C#
public float YDimension {get; set;}
Managed Extensions for C++
public: __property float get_YDimension();
public: __property void set_YDimension(
   float value
);
C++/CLI
public:
property float YDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeView Class
BarcodeView Members


$$INTRODUCTION$$ - %%projecttitle%%

Barcode4NET.RS.Design Send comments on this topic.
Introduction
Welcome to BarcodeView design time control online help.


%%phrase%%

Barcode4NET.RS.Design Send comments on this topic.
Barcode4NET.RS.Design Assembly
The Barcode4NET.RS.Design assembly includes the BarcodeView design time control for Sql Server Reporting Services 2005.

Namespaces

Namespace | Description
Internal |
O2S.Barcode4NET.Licensing |
O2S.Barcode4NET.ReportingServices.Design | Root namespace for all class included in Barcode4NET.RS.Design assembly.
Xheo.Licensing |


$$GETTING_STARTED$$ - %%projecttitle%%

Barcode4NET.RS.Design Send comments on this topic.
Getting Started
This online help will help you get started with BarcodeView design time control for Sql Server Reporting Services 2005.


%%ItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Internal Namespace (Barcode4NET.RS.Design)
See Also Inheritance Hierarchy

Classes

Class | Description
BigInteger | Implements an large integer of arbitrary length.
CommonRegexes | Declares static versions of some common regular expressions.

See Also

Reference

Barcode4NET.RS.Design Assembly


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Class
See Also Members
[image]
Internal Namespace : BigInteger Class

Implements an large integer of arbitrary length.

Syntax

Visual Basic (Declaration)
Private Class BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
C#
private class BigInteger
Managed Extensions for C++
private __gc class BigInteger
C++/CLI
private ref class BigInteger

Inheritance Hierarchy

System.Object
Internal.BigInteger

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Members
Internal Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Class Members
See Also Properties Methods
[image]
Internal Namespace : BigInteger Class

The following tables list the members exposed by BigInteger.

Public Constructors

 | Name | Description
Public Constructor | BigInteger Constructor | Overloaded. Initializes a new instance of the BigInteger class.
Top

Public Properties

 | Name | Description
Public Property | Bits | Gets the position of the most significant bit in the value.
Top

Public Methods

 | Name | Description
Public Method | Abs | Returns the absolute value of the BigInteger.
Public Method | Equals | Overridden. Overrides the equals comparison.
Public Method | Gcd | Returns the GCD(this, bi)
Public Method | GenerateCoPrime | Generates a random number with the specified number of bits such that Gcd(number, this) = 1
static (Shared in Visual Basic) | GeneratePseudoPrime | Makes a pseudoprime number that requires at least the given number of bits.
Public Method | GenerateRandomBits | Fills the BigInteger with random bits.
Public Method | GetBytes | Returns the value of the BigInteger as a byte array. The lowest index contains the MSB.
Public Method | GetHashCode | Overridden. Gets the hash code for the value.
Public Method | IntValue | Returns the lowest 4 bytes of the BigInteger as an int.
Public Method | IsProbablePrime | Determines whether a number is probably prime, using the Rabin-Miller's test. Before applying the test, the number is tested for divisibility by primes < 2000
Public Method | LongValue | Returns the lowest 8 bytes of the BigInteger as a long.
Public Method | ModInverse | Returns the modulo inverse of this. Throws ArithmeticException if the inverse does not exist. (i.e. Gcd(this, modulus) != 1)
Public Method | ModPow | Modulo Exponentiation. ( this ^ exp ) % n.
Public Method | Sqrt | Returns a value that is equivalent to the integer square root of the BigInteger.
Public Method | ToString | Overloaded. Overridden. Returns a string representation of the value.
Public Method | ULongValue | Returns the lowest 8 bytes of the BigInteger as a long.
Top

Public Operators

Public Operator Addition | Adds two BigInteger values together.
Public Operator And | Bitwise AND operator.
Public Operator Or | Bitwise OR operator.
Public Operator Decrement | Decrements the BigInteger value by one.
Public Operator Division | Division operator.
Public Operator Equality | Equality operator.
Public Operator Exclusive Or | Bitwise XOR operator.
Public Operator Greater Than | Greater than operator.
Public Operator Greater Than or Equal | Greater than or equal operator.
Public Operator Implicit Type Conversion | Overloaded.
Public Operator Increment | Increments the BigInteger value by 1.
Public Operator Inequality | Inequality operator.
Public Operator Left-shift | Shifts the bits to the left.
Public Operator Less Than | Less than operator.
Public Operator Less Than or Equal | Less than or equal operator.
Public Operator Modulus | Modulus operator.
Public Operator Multiplication | Multiplies two BigInteger values.
Public Operator Bitwise Complement | Implements a 1's compliment.
Public Operator Right-shift | Shifts the bits to the right.
Public Operator Subtraction | Subtracts one BigInteger from another.
Public Operator Unary Negation | Implements a 2's compliment (negative).
Top

See Also

Reference

BigInteger Class
Internal Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Constructor
See Also
[image]
Internal Namespace > BigInteger Class : BigInteger Constructor

Initializes a new instance of the BigInteger class.

Overload List

Overload | Description
BigInteger Constructor() | Initializes a new instance of the BigInteger class.
BigInteger Constructor(BigInteger) | Initializes a new instance of the BigInteger class from an existing instance.
BigInteger Constructor(Byte[]) | Initializes a new instance of the BigInteger class from an array of existing bytes.
BigInteger Constructor(Byte[],Int32) | Initializes a new instance of the BigInteger class from an array of existing bytes.
BigInteger Constructor(Int64) | Initializes a new instance of the BigInteger class from a Int64 value.
BigInteger Constructor(String,Int32) | Initializes a new instance of the BigInteger class from a string representation in the given radix.
BigInteger Constructor(UInt64) | Initializes a new instance of the BigInteger class from a UInt64 value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Constructor()
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor()

Initializes a new instance of the BigInteger class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BigInteger()
C#
public BigInteger()
Managed Extensions for C++
public: BigInteger();
C++/CLI
public:
BigInteger();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Constructor(BigInteger)
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(BigInteger)

bi
The BigInteger to initialize from.
Initializes a new instance of the BigInteger class from an existing instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bi As BigInteger _
)
Visual Basic (Usage) Copy Code
Dim bi As BigInteger

Dim instance As BigInteger(bi)
C#
public BigInteger(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger(
   BigInteger* bi
)
C++/CLI
public:
BigInteger(
   BigInteger^ bi
)

Parameters

bi
The BigInteger to initialize from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Constructor(Byte[])
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Byte[])

inData
The values to initialize from.
Initializes a new instance of the BigInteger class from an array of existing bytes.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As Byte _
)
Visual Basic (Usage) Copy Code
Dim inData() As Byte

Dim instance As BigInteger(inData)
C#
public BigInteger(
   byte[] inData
)
Managed Extensions for C++
public: BigInteger(
   byte[] inData
)
C++/CLI
public:
BigInteger(
   array<byte> inData
)

Parameters

inData
The values to initialize from.

Remarks

The lowest index of the input byte array (i.e [0]) should contain the most significant byte of the number, and the highest index should contain the least significant byte.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Constructor(Byte[],Int32)
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Byte[],Int32)

inData
The values to initialize from.
inLen
The length of the initialization array to use.
Initializes a new instance of the BigInteger class from an array of existing bytes.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As Byte, _
   ByVal inLen As Integer _
)
Visual Basic (Usage) Copy Code
Dim inData() As Byte
Dim inLen As Integer

Dim instance As BigInteger(inData, inLen)
C#
public BigInteger(
   byte[] inData,
   int inLen
)
Managed Extensions for C++
public: BigInteger(
   byte[] inData,
   int inLen
)
C++/CLI
public:
BigInteger(
   array<byte> inData,
   int inLen
)

Parameters

inData
The values to initialize from.
inLen
The length of the initialization array to use.

Remarks

The lowest index of the input byte array (i.e [0]) should contain the most significant byte of the number, and the highest index should contain the least significant byte.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Constructor(Int64)
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Int64)

value
The value to initialize with.
Initializes a new instance of the BigInteger class from a Int64 value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim value As Long

Dim instance As BigInteger(value)
C#
public BigInteger(
   long value
)
Managed Extensions for C++
public: BigInteger(
   long value
)
C++/CLI
public:
BigInteger(
   long value
)

Parameters

value
The value to initialize with.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Constructor(String,Int32)
See Also Example
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(String,Int32)

value
The string value to initialize from.
radix
The radix (or base) the value is offered as.
Initializes a new instance of the BigInteger class from a string representation in the given radix.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal radix As Integer _
)
Visual Basic (Usage) Copy Code
Dim value As String
Dim radix As Integer

Dim instance As BigInteger(value, radix)
C#
public BigInteger(
   string value,
   int radix
)
Managed Extensions for C++
public: BigInteger(
   string* value,
   int radix
)
C++/CLI
public:
BigInteger(
   String^ value,
   int radix
)

Parameters

value
The string value to initialize from.
radix
The radix (or base) the value is offered as.

Example

Example in Base 10

Example in Base 16 (HEX)

C# Copy Code
BigInteger a = new BigInteger( "1234", 10 );
            BigInteger b = new BigInteger( "-1234", 10 )
C# Copy Code
BigInteger a = new BigInteger( "1D4F", 16 );
            BigInteger b = new BigInteger( "-1D4F", 10 )

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Constructor(UInt64)
See Also
[image]
Internal Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(UInt64)

value
The value to initialize with.
Initializes a new instance of the BigInteger class from a UInt64 value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As ULong _
)
Visual Basic (Usage) Copy Code
Dim value As ULong

Dim instance As BigInteger(value)
C#
public BigInteger(
   ulong value
)
Managed Extensions for C++
public: BigInteger(
   ulong value
)
C++/CLI
public:
BigInteger(
   ulong value
)

Parameters

value
The value to initialize with.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Class Methods
See Also
[image]
Internal Namespace : BigInteger Class

For a list of all members of this type, see BigInteger members.

Public Methods

 | Name | Description
Public Method | Abs | Returns the absolute value of the BigInteger.
Public Method | Equals | Overridden. Overrides the equals comparison.
Public Method | Gcd | Returns the GCD(this, bi)
Public Method | GenerateCoPrime | Generates a random number with the specified number of bits such that Gcd(number, this) = 1
static (Shared in Visual Basic) | GeneratePseudoPrime | Makes a pseudoprime number that requires at least the given number of bits.
Public Method | GenerateRandomBits | Fills the BigInteger with random bits.
Public Method | GetBytes | Returns the value of the BigInteger as a byte array. The lowest index contains the MSB.
Public Method | GetHashCode | Overridden. Gets the hash code for the value.
Public Method | IntValue | Returns the lowest 4 bytes of the BigInteger as an int.
Public Method | IsProbablePrime | Determines whether a number is probably prime, using the Rabin-Miller's test. Before applying the test, the number is tested for divisibility by primes < 2000
Public Method | LongValue | Returns the lowest 8 bytes of the BigInteger as a long.
Public Method | ModInverse | Returns the modulo inverse of this. Throws ArithmeticException if the inverse does not exist. (i.e. Gcd(this, modulus) != 1)
Public Method | ModPow | Modulo Exponentiation. ( this ^ exp ) % n.
Public Method | Sqrt | Returns a value that is equivalent to the integer square root of the BigInteger.
Public Method | ToString | Overloaded. Overridden. Returns a string representation of the value.
Public Method | ULongValue | Returns the lowest 8 bytes of the BigInteger as a long.
Top

See Also

Reference

BigInteger Class
Internal Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Abs Method
See Also
[image]
Internal Namespace > BigInteger Class : Abs Method

Returns the absolute value of the BigInteger.

Syntax

Visual Basic (Declaration)
Public Function Abs() As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As BigInteger

value = instance.Abs()
C#
public BigInteger Abs()
Managed Extensions for C++
public: BigInteger* Abs();
C++/CLI
public:
BigInteger^ Abs();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Equals Method
See Also
[image]
Internal Namespace > BigInteger Class : Equals Method

o
Overrides the equals comparison.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal o As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim o As Object
Dim value As Boolean

value = instance.Equals(o)
C#
public override bool Equals(
   object o
)
Managed Extensions for C++
public: bool Equals(
   Object* o
) override
C++/CLI
public:
bool Equals(
   Object^ o
) override

Parameters

o

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Gcd Method
See Also
[image]
Internal Namespace > BigInteger Class : Gcd Method

bi
Returns the GCD(this, bi)

Syntax

Visual Basic (Declaration)
Public Function Gcd( _
   ByVal bi As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bi As BigInteger
Dim value As BigInteger

value = instance.Gcd(bi)
C#
public BigInteger Gcd(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger* Gcd(
   BigInteger* bi
)
C++/CLI
public:
BigInteger^ Gcd(
   BigInteger^ bi
)

Parameters

bi

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GenerateCoPrime Method
See Also
[image]
Internal Namespace > BigInteger Class : GenerateCoPrime Method

bits
Bits to use.
rand
Random number generator.
Generates a random number with the specified number of bits such that Gcd(number, this) = 1

Syntax

Visual Basic (Declaration)
Public Function GenerateCoPrime( _
   ByVal bits As Integer, _
   ByVal rand As Random _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bits As Integer
Dim rand As Random
Dim value As BigInteger

value = instance.GenerateCoPrime(bits, rand)
C#
public BigInteger GenerateCoPrime(
   int bits,
   Random rand
)
Managed Extensions for C++
public: BigInteger* GenerateCoPrime(
   int bits,
   Random* rand
)
C++/CLI
public:
BigInteger^ GenerateCoPrime(
   int bits,
   Random^ rand
)

Parameters

bits
Bits to use.
rand
Random number generator.

Return Value

Returns the co prime.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GeneratePseudoPrime Method
See Also
[image]
Internal Namespace > BigInteger Class : GeneratePseudoPrime Method

bits
The number of bits to use.
confidence
The amount of confidence required...a lower value is more confident.
rand
The random number generator.
Makes a pseudoprime number that requires at least the given number of bits.

Syntax

Visual Basic (Declaration)
Public Shared Function GeneratePseudoPrime( _
   ByVal bits As Integer, _
   ByVal confidence As Integer, _
   ByVal rand As Random _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim bits As Integer
Dim confidence As Integer
Dim rand As Random
Dim value As BigInteger

value = BigInteger.GeneratePseudoPrime(bits, confidence, rand)
C#
public static BigInteger GeneratePseudoPrime(
   int bits,
   int confidence,
   Random rand
)
Managed Extensions for C++
public: static BigInteger* GeneratePseudoPrime(
   int bits,
   int confidence,
   Random* rand
)
C++/CLI
public:
static BigInteger^ GeneratePseudoPrime(
   int bits,
   int confidence,
   Random^ rand
)

Parameters

bits
The number of bits to use.
confidence
The amount of confidence required...a lower value is more confident.
rand
The random number generator.

Return Value

Returns a pseudo prime number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GenerateRandomBits Method
See Also
[image]
Internal Namespace > BigInteger Class : GenerateRandomBits Method

bits
The minimum number of bits.
rand
The random number generator.
Fills the BigInteger with random bits.

Syntax

Visual Basic (Declaration)
Public Sub GenerateRandomBits( _
   ByVal bits As Integer, _
   ByVal rand As Random _
)
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bits As Integer
Dim rand As Random

instance.GenerateRandomBits(bits, rand)
C#
public void GenerateRandomBits(
   int bits,
   Random rand
)
Managed Extensions for C++
public: void GenerateRandomBits(
   int bits,
   Random* rand
)
C++/CLI
public:
void GenerateRandomBits(
   int bits,
   Random^ rand
)

Parameters

bits
The minimum number of bits.
rand
The random number generator.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetBytes Method
See Also
[image]
Internal Namespace > BigInteger Class : GetBytes Method

Returns the value of the BigInteger as a byte array. The lowest index contains the MSB.

Syntax

Visual Basic (Declaration)
Public Function GetBytes() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value() As Byte

value = instance.GetBytes()
C#
public byte[] GetBytes()
Managed Extensions for C++
public: byte[] GetBytes();
C++/CLI
public:
array<byte> GetBytes();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetHashCode Method
See Also
[image]
Internal Namespace > BigInteger Class : GetHashCode Method

Gets the hash code for the value.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IntValue Method
See Also
[image]
Internal Namespace > BigInteger Class : IntValue Method

Returns the lowest 4 bytes of the BigInteger as an int.

Syntax

Visual Basic (Declaration)
Public Function IntValue() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.IntValue()
C#
public int IntValue()
Managed Extensions for C++
public: int IntValue();
C++/CLI
public:
int IntValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IsProbablePrime Method
See Also
[image]
Internal Namespace > BigInteger Class : IsProbablePrime Method

confidence
Amount of confidence allowed.
Determines whether a number is probably prime, using the Rabin-Miller's test. Before applying the test, the number is tested for divisibility by primes < 2000

Syntax

Visual Basic (Declaration)
Public Function IsProbablePrime( _
   ByVal confidence As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim confidence As Integer
Dim value As Boolean

value = instance.IsProbablePrime(confidence)
C#
public bool IsProbablePrime(
   int confidence
)
Managed Extensions for C++
public: bool IsProbablePrime(
   int confidence
)
C++/CLI
public:
bool IsProbablePrime(
   int confidence
)

Parameters

confidence
Amount of confidence allowed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LongValue Method
See Also
[image]
Internal Namespace > BigInteger Class : LongValue Method

Returns the lowest 8 bytes of the BigInteger as a long.

Syntax

Visual Basic (Declaration)
Public Function LongValue() As Long
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Long

value = instance.LongValue()
C#
public long LongValue()
Managed Extensions for C++
public: long LongValue();
C++/CLI
public:
long LongValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ModInverse Method
See Also
[image]
Internal Namespace > BigInteger Class : ModInverse Method

modulus
Returns the modulo inverse of this. Throws ArithmeticException if the inverse does not exist. (i.e. Gcd(this, modulus) != 1)

Syntax

Visual Basic (Declaration)
Public Function ModInverse( _
   ByVal modulus As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim modulus As BigInteger
Dim value As BigInteger

value = instance.ModInverse(modulus)
C#
public BigInteger ModInverse(
   BigInteger modulus
)
Managed Extensions for C++
public: BigInteger* ModInverse(
   BigInteger* modulus
)
C++/CLI
public:
BigInteger^ ModInverse(
   BigInteger^ modulus
)

Parameters

modulus

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ModPow Method
See Also
[image]
Internal Namespace > BigInteger Class : ModPow Method

exp
Exponent.
n
Modulus.
Modulo Exponentiation. ( this ^ exp ) % n.

Syntax

Visual Basic (Declaration)
Public Function ModPow( _
   ByVal exp As BigInteger, _
   ByVal n As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim exp As BigInteger
Dim n As BigInteger
Dim value As BigInteger

value = instance.ModPow(exp, n)
C#
public BigInteger ModPow(
   BigInteger exp,
   BigInteger n
)
Managed Extensions for C++
public: BigInteger* ModPow(
   BigInteger* exp,
   BigInteger* n
)
C++/CLI
public:
BigInteger^ ModPow(
   BigInteger^ exp,
   BigInteger^ n
)

Parameters

exp
Exponent.
n
Modulus.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Sqrt Method
See Also
[image]
Internal Namespace > BigInteger Class : Sqrt Method

Returns a value that is equivalent to the integer square root of the BigInteger.

Syntax

Visual Basic (Declaration)
Public Function Sqrt() As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As BigInteger

value = instance.Sqrt()
C#
public BigInteger Sqrt()
Managed Extensions for C++
public: BigInteger* Sqrt();
C++/CLI
public:
BigInteger^ Sqrt();

Remarks

The integer square root of "this" is defined as the largest integer n such that (n * n) <= this

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ToString Method
See Also
[image]
Internal Namespace > BigInteger Class : ToString Method

Returns a string representation of the value.

Overload List

Overload | Description
ToString() | Returns a string representation of the value.
ToString(Int32) | Returns a string representing the BigInteger in sign-and-magnitude format in the specified radix.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ToString() Method
See Also
[image]
Internal Namespace > BigInteger Class > ToString Method : ToString() Method

Returns a string representation of the value.

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ToString(Int32) Method
See Also
[image]
Internal Namespace > BigInteger Class > ToString Method : ToString(Int32) Method

radix
The radix (or base) of the value to output. Valid values are from 2 to 36.
Returns a string representing the BigInteger in sign-and-magnitude format in the specified radix.

Syntax

Visual Basic (Declaration)
Overloads Public Function ToString( _
   ByVal radix As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim radix As Integer
Dim value As String

value = instance.ToString(radix)
C#
public string ToString(
   int radix
)
Managed Extensions for C++
public: string* ToString(
   int radix
)
C++/CLI
public:
String^ ToString(
   int radix
)

Parameters

radix
The radix (or base) of the value to output. Valid values are from 2 to 36.

Return Value

Returns the formatted string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ULongValue Method
See Also
[image]
Internal Namespace > BigInteger Class : ULongValue Method

Returns the lowest 8 bytes of the BigInteger as a long.

Syntax

Visual Basic (Declaration)
Public Function ULongValue() As ULong
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As ULong

value = instance.ULongValue()
C#
public ulong ULongValue()
Managed Extensions for C++
public: ulong ULongValue();
C++/CLI
public:
ulong ULongValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Class Properties
See Also
[image]
Internal Namespace : BigInteger Class

For a list of all members of this type, see BigInteger members.

Public Properties

 | Name | Description
Public Property | Bits | Gets the position of the most significant bit in the value.
Top

See Also

Reference

BigInteger Class
Internal Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Bits Property
See Also
[image]
Internal Namespace > BigInteger Class : Bits Property

Gets the position of the most significant bit in the value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bits As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.Bits
C#
public int Bits {get;}
Managed Extensions for C++
public: __property int get_Bits();
C++/CLI
public:
property int Bits {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Addition Operator
See Also
[image]
Internal Namespace > BigInteger Class : Addition Operator

bi1
BigInteger 1.
bi2
BigInteger 2.
Adds two BigInteger values together.

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator +(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Addition(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator +(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
BigInteger 1.
bi2
BigInteger 2.

Return Value

Returns the sum of the two values.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
And Operator
See Also
[image]
Internal Namespace > BigInteger Class : And Operator

bi1
bi2
Bitwise AND operator.

Syntax

Visual Basic (Declaration)
Public Operator And( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator &(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_BitwiseAnd(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator &(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Or Operator
See Also
[image]
Internal Namespace > BigInteger Class : Or Operator

bi1
bi2
Bitwise OR operator.

Syntax

Visual Basic (Declaration)
Public Operator Or( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator |(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_BitwiseOr(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator |(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Decrement Operator
See Also
[image]
Internal Namespace > BigInteger Class : Decrement Operator

bi1
Decrements the BigInteger value by one.

Syntax

Visual Basic (Declaration)
This operator type is not supported by Visual Basic
C#
public BigInteger operator --(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_Decrement(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator --(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Division Operator
See Also
[image]
Internal Namespace > BigInteger Class : Division Operator

bi1
bi2
Division operator.

Syntax

Visual Basic (Declaration)
Public Operator /( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator /(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Division(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator /(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Equality Operator
See Also
[image]
Internal Namespace > BigInteger Class : Equality Operator

bi1
bi2
Equality operator.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator ==(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_Equality(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator ==(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Exclusive Or Operator
See Also
[image]
Internal Namespace > BigInteger Class : Exclusive Or Operator

bi1
bi2
Bitwise XOR operator.

Syntax

Visual Basic (Declaration)
Public Operator Xor( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator ^(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_ExclusiveOr(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator ^(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Greater Than Operator
See Also
[image]
Internal Namespace > BigInteger Class : Greater Than Operator

bi1
bi2
Greater than operator.

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator >(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_GreaterThan(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator >(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Greater Than or Equal Operator
See Also
[image]
Internal Namespace > BigInteger Class : Greater Than or Equal Operator

bi1
bi2
Greater than or equal operator.

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator >=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_GreaterThanOrEqual(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator >=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Implicit Type Conversion Operator
See Also
[image]
Internal Namespace > BigInteger Class : Implicit Type Conversion Operator

Overload List

Overload | Description
Implicit Type Conversion(Int32) |
Implicit Type Conversion(Int64) |
Implicit Type Conversion(UInt32) |
Implicit Type Conversion(UInt64) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Increment Operator
See Also
[image]
Internal Namespace > BigInteger Class : Increment Operator

bi1
Increments the BigInteger value by 1.

Syntax

Visual Basic (Declaration)
This operator type is not supported by Visual Basic
C#
public BigInteger operator ++(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_Increment(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator ++(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Inequality Operator
See Also
[image]
Internal Namespace > BigInteger Class : Inequality Operator

bi1
bi2
Inequality operator.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator !=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_Inequality(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator !=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Left-shift Operator
See Also
[image]
Internal Namespace > BigInteger Class : Left-shift Operator

bi1
shiftVal
Shifts the bits to the left.

Syntax

Visual Basic (Declaration)
Public Operator <<( _
   ByVal bi1 As BigInteger, _
   ByVal shiftVal As Integer _
) As BigInteger
C#
public BigInteger operator <<(
   BigInteger bi1,
   int shiftVal
)
Managed Extensions for C++
public: BigInteger* op_LeftShift(
   BigInteger* bi1,
   int shiftVal
)
C++/CLI
public:
BigInteger^ operator <<(
   BigInteger^ bi1,
   int shiftVal
)

Parameters

bi1
shiftVal

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Less Than Operator
See Also
[image]
Internal Namespace > BigInteger Class : Less Than Operator

bi1
bi2
Less than operator.

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator <(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_LessThan(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator <(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Less Than or Equal Operator
See Also
[image]
Internal Namespace > BigInteger Class : Less Than or Equal Operator

bi1
bi2
Less than or equal operator.

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator <=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_LessThanOrEqual(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator <=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Modulus Operator
See Also
[image]
Internal Namespace > BigInteger Class : Modulus Operator

bi1
bi2
Modulus operator.

Syntax

Visual Basic (Declaration)
Public Operator Mod( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator %(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Modulus(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator %(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Multiplication Operator
See Also
[image]
Internal Namespace > BigInteger Class : Multiplication Operator

bi1
bi2
Multiplies two BigInteger values.

Syntax

Visual Basic (Declaration)
Public Operator *( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator *(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Multiply(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator *(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Bitwise Complement Operator
See Also
[image]
Internal Namespace > BigInteger Class : Bitwise Complement Operator

bi1
Implements a 1's compliment.

Syntax

Visual Basic (Declaration)
Public Operator Not( _
   ByVal bi1 As BigInteger _
) As BigInteger
C#
public BigInteger operator ~(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_OnesComplement(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator ~(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Right-shift Operator
See Also
[image]
Internal Namespace > BigInteger Class : Right-shift Operator

bi1
shiftVal
Shifts the bits to the right.

Syntax

Visual Basic (Declaration)
Public Operator >>( _
   ByVal bi1 As BigInteger, _
   ByVal shiftVal As Integer _
) As BigInteger
C#
public BigInteger operator >>(
   BigInteger bi1,
   int shiftVal
)
Managed Extensions for C++
public: BigInteger* op_RightShift(
   BigInteger* bi1,
   int shiftVal
)
C++/CLI
public:
BigInteger^ operator >>(
   BigInteger^ bi1,
   int shiftVal
)

Parameters

bi1
shiftVal

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Subtraction Operator
See Also
[image]
Internal Namespace > BigInteger Class : Subtraction Operator

bi1
bi2
Subtracts one BigInteger from another.

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator -(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Subtraction(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator -(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Unary Negation Operator
See Also
[image]
Internal Namespace > BigInteger Class : Unary Negation Operator

bi1
Implements a 2's compliment (negative).

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal bi1 As BigInteger _
) As BigInteger
C#
public BigInteger operator -(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_UnaryNegation(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator -(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
CommonRegexes Class
See Also Members
[image]
Internal Namespace : CommonRegexes Class

Declares static versions of some common regular expressions.

Syntax

Visual Basic (Declaration)
Private NotInheritable Class CommonRegexes
Visual Basic (Usage) Copy Code
Dim instance As CommonRegexes
C#
private sealed class CommonRegexes
Managed Extensions for C++
private __gc __sealed class CommonRegexes
C++/CLI
private ref class CommonRegexes sealed

Inheritance Hierarchy

System.Object
Internal.CommonRegexes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Members
Internal Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
CommonRegexes Class Members
See Also Fields
[image]
Internal Namespace : CommonRegexes Class

The following tables list the members exposed by CommonRegexes.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DomainName | Pattern for matching against any valid domain name.
static (Shared in Visual Basic) | Email | Pattern for matching against any valid email address.
static (Shared in Visual Basic) | FileName | Pattern for matching a Windows file path.
static (Shared in Visual Basic) | FilePath | Pattern for matching a Windows file path.
static (Shared in Visual Basic) | FullyQualifiedUrl | Pattern for matching against any valid URL.
static (Shared in Visual Basic) | FullyQualifiedUrlFolder | Pattern for matching a fully qualified URL that has no file name.
static (Shared in Visual Basic) | IpAddress | Pattern for matching against any valid IP address.
static (Shared in Visual Basic) | Url | Pattern for matching against any valid URL.
static (Shared in Visual Basic) | UrlFolder | Pattern for matching against any valid URL that has no file name.
static (Shared in Visual Basic) | UsEin | Pattern for a US employer identification number.
static (Shared in Visual Basic) | UsPhone | Pattern for a US 10-digit phone number.
static (Shared in Visual Basic) | UsSsn | Pattern for a US social security number.
static (Shared in Visual Basic) | UsSsnOrEin | Pattern for a US social security number or an employer identification number.
static (Shared in Visual Basic) | UsZip | Pattern for a US 5-digit zip code with an optional 4 digit exchange.
static (Shared in Visual Basic) | UsZip5 | Pattern for a US 5-digit zip code.
static (Shared in Visual Basic) | UsZip5Plus4 | Pattern for a US 5-digit zip code plus 4 digit exchange.
Top

See Also

Reference

CommonRegexes Class
Internal Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.RS.Design Send comments on this topic.
CommonRegexes Class Fields
See Also
[image]
Internal Namespace : CommonRegexes Class

For a list of all members of this type, see CommonRegexes members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DomainName | Pattern for matching against any valid domain name.
static (Shared in Visual Basic) | Email | Pattern for matching against any valid email address.
static (Shared in Visual Basic) | FileName | Pattern for matching a Windows file path.
static (Shared in Visual Basic) | FilePath | Pattern for matching a Windows file path.
static (Shared in Visual Basic) | FullyQualifiedUrl | Pattern for matching against any valid URL.
static (Shared in Visual Basic) | FullyQualifiedUrlFolder | Pattern for matching a fully qualified URL that has no file name.
static (Shared in Visual Basic) | IpAddress | Pattern for matching against any valid IP address.
static (Shared in Visual Basic) | Url | Pattern for matching against any valid URL.
static (Shared in Visual Basic) | UrlFolder | Pattern for matching against any valid URL that has no file name.
static (Shared in Visual Basic) | UsEin | Pattern for a US employer identification number.
static (Shared in Visual Basic) | UsPhone | Pattern for a US 10-digit phone number.
static (Shared in Visual Basic) | UsSsn | Pattern for a US social security number.
static (Shared in Visual Basic) | UsSsnOrEin | Pattern for a US social security number or an employer identification number.
static (Shared in Visual Basic) | UsZip | Pattern for a US 5-digit zip code with an optional 4 digit exchange.
static (Shared in Visual Basic) | UsZip5 | Pattern for a US 5-digit zip code.
static (Shared in Visual Basic) | UsZip5Plus4 | Pattern for a US 5-digit zip code plus 4 digit exchange.
Top

See Also

Reference

CommonRegexes Class
Internal Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
DomainName Field
See Also
[image]
Internal Namespace > CommonRegexes Class : DomainName Field

Pattern for matching against any valid domain name.

Syntax

Visual Basic (Declaration)
Public Shared DomainName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.DomainName

CommonRegexes.DomainName = value
C#
public static string DomainName
Managed Extensions for C++
public: static string* DomainName
C++/CLI
public:
static String^ DomainName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Email Field
See Also
[image]
Internal Namespace > CommonRegexes Class : Email Field

Pattern for matching against any valid email address.

Syntax

Visual Basic (Declaration)
Public Shared Email As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.Email

CommonRegexes.Email = value
C#
public static string Email
Managed Extensions for C++
public: static string* Email
C++/CLI
public:
static String^ Email

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
FileName Field
See Also
[image]
Internal Namespace > CommonRegexes Class : FileName Field

Pattern for matching a Windows file path.

Syntax

Visual Basic (Declaration)
Public Shared FileName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.FileName

CommonRegexes.FileName = value
C#
public static string FileName
Managed Extensions for C++
public: static string* FileName
C++/CLI
public:
static String^ FileName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
FilePath Field
See Also
[image]
Internal Namespace > CommonRegexes Class : FilePath Field

Pattern for matching a Windows file path.

Syntax

Visual Basic (Declaration)
Public Shared FilePath As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.FilePath

CommonRegexes.FilePath = value
C#
public static string FilePath
Managed Extensions for C++
public: static string* FilePath
C++/CLI
public:
static String^ FilePath

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
FullyQualifiedUrl Field
See Also
[image]
Internal Namespace > CommonRegexes Class : FullyQualifiedUrl Field

Pattern for matching against any valid URL.

Syntax

Visual Basic (Declaration)
Public Shared FullyQualifiedUrl As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.FullyQualifiedUrl

CommonRegexes.FullyQualifiedUrl = value
C#
public static string FullyQualifiedUrl
Managed Extensions for C++
public: static string* FullyQualifiedUrl
C++/CLI
public:
static String^ FullyQualifiedUrl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
FullyQualifiedUrlFolder Field
See Also
[image]
Internal Namespace > CommonRegexes Class : FullyQualifiedUrlFolder Field

Pattern for matching a fully qualified URL that has no file name.

Syntax

Visual Basic (Declaration)
Public Shared FullyQualifiedUrlFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.FullyQualifiedUrlFolder

CommonRegexes.FullyQualifiedUrlFolder = value
C#
public static string FullyQualifiedUrlFolder
Managed Extensions for C++
public: static string* FullyQualifiedUrlFolder
C++/CLI
public:
static String^ FullyQualifiedUrlFolder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IpAddress Field
See Also
[image]
Internal Namespace > CommonRegexes Class : IpAddress Field

Pattern for matching against any valid IP address.

Syntax

Visual Basic (Declaration)
Public Shared IpAddress As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.IpAddress

CommonRegexes.IpAddress = value
C#
public static string IpAddress
Managed Extensions for C++
public: static string* IpAddress
C++/CLI
public:
static String^ IpAddress

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Url Field
See Also
[image]
Internal Namespace > CommonRegexes Class : Url Field

Pattern for matching against any valid URL.

Syntax

Visual Basic (Declaration)
Public Shared Url As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.Url

CommonRegexes.Url = value
C#
public static string Url
Managed Extensions for C++
public: static string* Url
C++/CLI
public:
static String^ Url

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
UrlFolder Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UrlFolder Field

Pattern for matching against any valid URL that has no file name.

Syntax

Visual Basic (Declaration)
Public Shared UrlFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UrlFolder

CommonRegexes.UrlFolder = value
C#
public static string UrlFolder
Managed Extensions for C++
public: static string* UrlFolder
C++/CLI
public:
static String^ UrlFolder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
UsEin Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsEin Field

Pattern for a US employer identification number.

Syntax

Visual Basic (Declaration)
Public Shared UsEin As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsEin

CommonRegexes.UsEin = value
C#
public static string UsEin
Managed Extensions for C++
public: static string* UsEin
C++/CLI
public:
static String^ UsEin

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
UsPhone Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsPhone Field

Pattern for a US 10-digit phone number.

Syntax

Visual Basic (Declaration)
Public Shared UsPhone As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsPhone

CommonRegexes.UsPhone = value
C#
public static string UsPhone
Managed Extensions for C++
public: static string* UsPhone
C++/CLI
public:
static String^ UsPhone

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
UsSsn Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsSsn Field

Pattern for a US social security number.

Syntax

Visual Basic (Declaration)
Public Shared UsSsn As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsSsn

CommonRegexes.UsSsn = value
C#
public static string UsSsn
Managed Extensions for C++
public: static string* UsSsn
C++/CLI
public:
static String^ UsSsn

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
UsSsnOrEin Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsSsnOrEin Field

Pattern for a US social security number or an employer identification number.

Syntax

Visual Basic (Declaration)
Public Shared UsSsnOrEin As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsSsnOrEin

CommonRegexes.UsSsnOrEin = value
C#
public static string UsSsnOrEin
Managed Extensions for C++
public: static string* UsSsnOrEin
C++/CLI
public:
static String^ UsSsnOrEin

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
UsZip Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsZip Field

Pattern for a US 5-digit zip code with an optional 4 digit exchange.

Syntax

Visual Basic (Declaration)
Public Shared UsZip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsZip

CommonRegexes.UsZip = value
C#
public static string UsZip
Managed Extensions for C++
public: static string* UsZip
C++/CLI
public:
static String^ UsZip

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
UsZip5 Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsZip5 Field

Pattern for a US 5-digit zip code.

Syntax

Visual Basic (Declaration)
Public Shared UsZip5 As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsZip5

CommonRegexes.UsZip5 = value
C#
public static string UsZip5
Managed Extensions for C++
public: static string* UsZip5
C++/CLI
public:
static String^ UsZip5

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
UsZip5Plus4 Field
See Also
[image]
Internal Namespace > CommonRegexes Class : UsZip5Plus4 Field

Pattern for a US 5-digit zip code plus 4 digit exchange.

Syntax

Visual Basic (Declaration)
Public Shared UsZip5Plus4 As String
Visual Basic (Usage) Copy Code
Dim value As String

value = CommonRegexes.UsZip5Plus4

CommonRegexes.UsZip5Plus4 = value
C#
public static string UsZip5Plus4
Managed Extensions for C++
public: static string* UsZip5Plus4
C++/CLI
public:
static String^ UsZip5Plus4

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CommonRegexes Class
CommonRegexes Members


%%ItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
O2S.Barcode4NET.Licensing Namespace (Barcode4NET.RS.Design)
See Also Inheritance Hierarchy

Classes

Class | Description
LicenseValidator | Defines a validator for license serial numbers.

See Also

Reference

Barcode4NET.RS.Design Assembly


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LicenseValidator Class
See Also Members
[image]
O2S.Barcode4NET.Licensing Namespace : LicenseValidator Class

Defines a validator for license serial numbers.

Syntax

Visual Basic (Declaration)
Private Class LicenseValidator
Visual Basic (Usage) Copy Code
Dim instance As LicenseValidator
C#
private class LicenseValidator
Managed Extensions for C++
private __gc class LicenseValidator
C++/CLI
private ref class LicenseValidator

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Licensing.LicenseValidator

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValidator Members
O2S.Barcode4NET.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
LicenseValidator Class Members
See Also Methods
[image]
O2S.Barcode4NET.Licensing Namespace : LicenseValidator Class

The following tables list the members exposed by LicenseValidator.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetSerialNumber | Reads the serial number from the registry to give a default value to SerialNumber property.
static (Shared in Visual Basic) | ValidateSerialNumber | Validates a serial number based on a license file and a public key.
Top

See Also

Reference

LicenseValidator Class
O2S.Barcode4NET.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
LicenseValidator Class Methods
See Also
[image]
O2S.Barcode4NET.Licensing Namespace : LicenseValidator Class

For a list of all members of this type, see LicenseValidator members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetSerialNumber | Reads the serial number from the registry to give a default value to SerialNumber property.
static (Shared in Visual Basic) | ValidateSerialNumber | Validates a serial number based on a license file and a public key.
Top

See Also

Reference

LicenseValidator Class
O2S.Barcode4NET.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetSerialNumber Method
See Also
[image]
O2S.Barcode4NET.Licensing Namespace > LicenseValidator Class : GetSerialNumber Method

edition
The edition to lookup the serial number for.
version
Version to lookup the serial number for.
Reads the serial number from the registry to give a default value to SerialNumber property.

Syntax

Visual Basic (Declaration)
Public Shared Function GetSerialNumber( _
   ByVal edition As String, _
   ByVal version As String _
) As String
Visual Basic (Usage) Copy Code
Dim edition As String
Dim version As String
Dim value As String

value = LicenseValidator.GetSerialNumber(edition, version)
C#
public static string GetSerialNumber(
   string edition,
   string version
)
Managed Extensions for C++
public: static string* GetSerialNumber(
   string* edition,
   string* version
)
C++/CLI
public:
static String^ GetSerialNumber(
   String^ edition,
   String^ version
)

Parameters

edition
The edition to lookup the serial number for.
version
Version to lookup the serial number for.

Return Value

Serial number if exists, empty string otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValidator Class
LicenseValidator Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ValidateSerialNumber Method
See Also
[image]
O2S.Barcode4NET.Licensing Namespace > LicenseValidator Class : ValidateSerialNumber Method

serialNumber
Serial number to validate.
licenseResourceName
License file the serial number is validated against.
publicKeyResourceName
The public key for validating the serial number.
Validates a serial number based on a license file and a public key.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateSerialNumber( _
   ByVal serialNumber As String, _
   ByVal licenseResourceName As String, _
   ByVal publicKeyResourceName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim serialNumber As String
Dim licenseResourceName As String
Dim publicKeyResourceName As String
Dim value As Boolean

value = LicenseValidator.ValidateSerialNumber(serialNumber, licenseResourceName, publicKeyResourceName)
C#
public static bool ValidateSerialNumber(
   string serialNumber,
   string licenseResourceName,
   string publicKeyResourceName
)
Managed Extensions for C++
public: static bool ValidateSerialNumber(
   string* serialNumber,
   string* licenseResourceName,
   string* publicKeyResourceName
)
C++/CLI
public:
static bool ValidateSerialNumber(
   String^ serialNumber,
   String^ licenseResourceName,
   String^ publicKeyResourceName
)

Parameters

serialNumber
Serial number to validate.
licenseResourceName
License file the serial number is validated against.
publicKeyResourceName
The public key for validating the serial number.

Return Value

True if the serial number is valid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValidator Class
LicenseValidator Members


%%ItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
O2S.Barcode4NET.ReportingServices.Design Namespace
See Also Inheritance Hierarchy
Root namespace for all class included in Barcode4NET.RS.Design assembly.

Classes

Class | Description
BarcodeDesigner | Defines a designer for Barcode4NET items in reports.

See Also

Reference

Barcode4NET.RS.Design Assembly


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BarcodeDesigner Class
See Also Members
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace : BarcodeDesigner Class

Defines a designer for Barcode4NET items in reports.

Object Model

Syntax

Visual Basic (Declaration)
Public Class BarcodeDesigner
   Inherits CustomReportItemDesigner
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
C#
public class BarcodeDesigner : CustomReportItemDesigner
Managed Extensions for C++
public __gc class BarcodeDesigner : public CustomReportItemDesigner
C++/CLI
public ref class BarcodeDesigner : public CustomReportItemDesigner

Inheritance Hierarchy

System.Object
Microsoft.ReportDesigner.CustomReportItemDesigner
O2S.Barcode4NET.ReportingServices.Design.BarcodeDesigner

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Members
O2S.Barcode4NET.ReportingServices.Design Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
BarcodeDesigner Class Members
See Also Properties Methods Events
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace : BarcodeDesigner Class

The following tables list the members exposed by BarcodeDesigner.

Public Constructors

 | Name | Description
Public Constructor | BarcodeDesigner Constructor | Initializes a new BarcodeDesigner object.
Top

Public Properties

 | Name | Description
Public Property | ActionInfo | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Adornment | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | AltReportItem | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Barcode | Gets the Barcode object behind the control.
Public Property | Bookmark | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode.
Public Property | CodablockFColumns | Gets or sets the number of columns in this CODABLOCK F barcode.
Public Property | CodablockFRows | Gets or sets the number of rows in this CODABLOCK F barcode.
Public Property | Code16KRows | Gets or sets the number of rows in this Code 16K barcode.
Public Property | Code39WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | CustomData | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | CustomProperties | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Data | Gets or sets the data displayed in the control.
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DataElementName | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | DataElementOutput | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | DataMatrixEncoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | DataMatrixSymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | DefaultSize | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties.
Public Property | DisplayCheckSum | Gets or sets a value indicating whether the check characters should be displayed in barcode text.
Public Property | DisplayRectangle | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | EANSupplement | Gets or sets the supplement for barcode data.
Public Property | EANSupplementDisplayLocation | Gets or sets the location of the EAN supplement text.
Public Property | EANSupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum character should be appended automatically to the barcode.
Public Property | Height | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Label | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode.
Public Property | MicroPDF417SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | Name | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Pdf417Columns | Gets or sets the number of columns in this PDF417 barcode.
Public Property | Pdf417DataCompactionMode | Gets or sets the data compaction mode for this PDF417 barcode.
Public Property | Pdf417ErrorCorrectionLevel | Gets or sets the level of error correction used by this PDF417 barcode.
Public Property | Pdf417Rows | Gets or sets the number of rows in this PDF417 barcode.
Public Property | RepeatWith | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Report | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Resolution | Gets or sets the resolution of the barcode image.
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode.
Public Property | Rotation | Gets or sets the rotation angle of the barcode.
Public Property | ScreenLocation | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | SerialNumber | Gets or sets the serial number.
Public Property | Site | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Style | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Symbology | Gets or sets the type of the barcode displayed in the control.
Public Property | TextColor | Gets or sets the text color for the barcode.
Public Property | ToolTip | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode.
Public Property | Type | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Verbs | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Visibility | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Width | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | XDimension | Gets or sets the width of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

Public Methods

 | Name | Description
Public Method | BeginEdit | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | Dispose | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | DoDefaultAction | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | EndEdit | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | InitializeNewComponent | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | Invalidate | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnBackgroundColorChanged | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnColorChanged | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnDragDrop | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnDragEnter | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnDragLeave | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnDragOver | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnFontChanged | Overridden. Handles the font changed event.
Public Method | OnLocationChanged | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnPaddingChanged | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnPaint | Overridden. Paints the barcode on the design surface.
Public Method | OnSizeChanged | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnTextAlignChanged | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnTextDecorationChanged | Overridden. Handles the text decoration changed event.
Public Method | ShowContextMenu | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Top

See Also

Reference

BarcodeDesigner Class
O2S.Barcode4NET.ReportingServices.Design Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BarcodeDesigner Constructor
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : BarcodeDesigner Constructor

Initializes a new BarcodeDesigner object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner()
C#
public BarcodeDesigner()
Managed Extensions for C++
public: BarcodeDesigner();
C++/CLI
public:
BarcodeDesigner();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
BarcodeDesigner Class Methods
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace : BarcodeDesigner Class

For a list of all members of this type, see BarcodeDesigner members.

Public Methods

 | Name | Description
Public Method | BeginEdit | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | Dispose | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | DoDefaultAction | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | EndEdit | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | InitializeNewComponent | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | Invalidate | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnBackgroundColorChanged | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnColorChanged | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnDragDrop | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnDragEnter | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnDragLeave | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnDragOver | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnFontChanged | Overridden. Handles the font changed event.
Public Method | OnLocationChanged | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnPaddingChanged | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnPaint | Overridden. Paints the barcode on the design surface.
Public Method | OnSizeChanged | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnTextAlignChanged | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Method | OnTextDecorationChanged | Overridden. Handles the text decoration changed event.
Public Method | ShowContextMenu | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Top

See Also

Reference

BarcodeDesigner Class
O2S.Barcode4NET.ReportingServices.Design Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
OnFontChanged Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : OnFontChanged Method

Handles the font changed event.

Syntax

Visual Basic (Declaration)
Overrides Public Sub OnFontChanged()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner

instance.OnFontChanged()
C#
public override void OnFontChanged()
Managed Extensions for C++
public: void OnFontChanged(); override
C++/CLI
public:
void OnFontChanged(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
OnPaint Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : OnPaint Method

e
Arguments of the paint event.
Paints the barcode on the design surface.

Syntax

Visual Basic (Declaration)
Overrides Public Sub OnPaint( _
   ByVal e As PaintEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim e As PaintEventArgs

instance.OnPaint(e)
C#
public override void OnPaint(
   PaintEventArgs e
)
Managed Extensions for C++
public: void OnPaint(
   PaintEventArgs e
) override
C++/CLI
public:
void OnPaint(
   PaintEventArgs e
) override

Parameters

e
Arguments of the paint event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
OnTextDecorationChanged Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : OnTextDecorationChanged Method

Handles the text decoration changed event.

Syntax

Visual Basic (Declaration)
Overrides Public Sub OnTextDecorationChanged()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner

instance.OnTextDecorationChanged()
C#
public override void OnTextDecorationChanged()
Managed Extensions for C++
public: void OnTextDecorationChanged(); override
C++/CLI
public:
void OnTextDecorationChanged(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.RS.Design Send comments on this topic.
BarcodeDesigner Class Properties
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace : BarcodeDesigner Class

For a list of all members of this type, see BarcodeDesigner members.

Public Properties

 | Name | Description
Public Property | ActionInfo | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Adornment | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | AltReportItem | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Barcode | Gets the Barcode object behind the control.
Public Property | Bookmark | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode.
Public Property | CodablockFColumns | Gets or sets the number of columns in this CODABLOCK F barcode.
Public Property | CodablockFRows | Gets or sets the number of rows in this CODABLOCK F barcode.
Public Property | Code16KRows | Gets or sets the number of rows in this Code 16K barcode.
Public Property | Code39WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | CustomData | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | CustomProperties | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Data | Gets or sets the data displayed in the control.
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DataElementName | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | DataElementOutput | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | DataMatrixEncoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | DataMatrixSymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | DefaultSize | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties.
Public Property | DisplayCheckSum | Gets or sets a value indicating whether the check characters should be displayed in barcode text.
Public Property | DisplayRectangle | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | EANSupplement | Gets or sets the supplement for barcode data.
Public Property | EANSupplementDisplayLocation | Gets or sets the location of the EAN supplement text.
Public Property | EANSupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum character should be appended automatically to the barcode.
Public Property | Height | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Label | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode.
Public Property | MicroPDF417SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | Name | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Pdf417Columns | Gets or sets the number of columns in this PDF417 barcode.
Public Property | Pdf417DataCompactionMode | Gets or sets the data compaction mode for this PDF417 barcode.
Public Property | Pdf417ErrorCorrectionLevel | Gets or sets the level of error correction used by this PDF417 barcode.
Public Property | Pdf417Rows | Gets or sets the number of rows in this PDF417 barcode.
Public Property | RepeatWith | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Report | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Resolution | Gets or sets the resolution of the barcode image.
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode.
Public Property | Rotation | Gets or sets the rotation angle of the barcode.
Public Property | ScreenLocation | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | SerialNumber | Gets or sets the serial number.
Public Property | Site | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Style | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Symbology | Gets or sets the type of the barcode displayed in the control.
Public Property | TextColor | Gets or sets the text color for the barcode.
Public Property | ToolTip | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode.
Public Property | Type | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Verbs | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Visibility | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | Width | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Public Property | XDimension | Gets or sets the width of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

See Also

Reference

BarcodeDesigner Class
O2S.Barcode4NET.ReportingServices.Design Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Barcode Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Barcode Property

Gets the Barcode object behind the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Barcode As Barcode
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Barcode

value = instance.Barcode
C#
public Barcode Barcode {get;}
Managed Extensions for C++
public: __property Barcode* get_Barcode();
C++/CLI
public:
property Barcode^ Barcode {
   Barcode^ get();
}

Return Value

A Barcode object that represents the barcode displayed in the control.

Remarks

Do not modify the underlying Barcode object directly because the changes will not be reflected in the control.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BottomQuietZone Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : BottomQuietZone Property

Gets or sets the bottom quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property BottomQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Single

instance.BottomQuietZone = value

value = instance.BottomQuietZone
C#
public float BottomQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_BottomQuietZone();
public: __property void set_BottomQuietZone(
   float value
);
C++/CLI
public:
property float BottomQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of bottom quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the bottom quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
CodablockFColumns Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : CodablockFColumns Property

Gets or sets the number of columns in this CODABLOCK F barcode.

Syntax

Visual Basic (Declaration)
Public Property CodablockFColumns As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Integer

instance.CodablockFColumns = value

value = instance.CodablockFColumns
C#
public int CodablockFColumns {get; set;}
Managed Extensions for C++
public: __property int get_CodablockFColumns();
public: __property void set_CodablockFColumns(
   int value
);
C++/CLI
public:
property int CodablockFColumns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this CODABLOCK F barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 7 or greater than 65.

Remarks

The minimum number of columns in a CODABLOCK F barcode is 7 and the maximum number of columns is 65. This property includes the character subset selector, row indicator and row check columns.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
CodablockFRows Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : CodablockFRows Property

Gets or sets the number of rows in this CODABLOCK F barcode.

Syntax

Visual Basic (Declaration)
Public Property CodablockFRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Integer

instance.CodablockFRows = value

value = instance.CodablockFRows
C#
public int CodablockFRows {get; set;}
Managed Extensions for C++
public: __property int get_CodablockFRows();
public: __property void set_CodablockFRows(
   int value
);
C++/CLI
public:
property int CodablockFRows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows in this CODABLOCK F barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2 or greater than 44.

Remarks

The minimum number of rows in a CODABLOCK F barcode is 2 and the maximum number of rows is 44.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Code16KRows Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Code16KRows Property

Gets or sets the number of rows in this Code 16K barcode.

Syntax

Visual Basic (Declaration)
Public Property Code16KRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Integer

instance.Code16KRows = value

value = instance.Code16KRows
C#
public int Code16KRows {get; set;}
Managed Extensions for C++
public: __property int get_Code16KRows();
public: __property void set_Code16KRows(
   int value
);
C++/CLI
public:
property int Code16KRows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows in this Code 16K barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2 but not 0, or greater than 16.

Remarks

The minimum number of rows in a Code 16K barcode is 2 and the maximum number of rows is 16. If this property is 0, the number of rows is calculated automatically to accomodate the barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Code39WideToNarrowRatio Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Code39WideToNarrowRatio Property

Gets or sets the ratio between wide bars and narrow bars.

Syntax

Visual Basic (Declaration)
Public Property Code39WideToNarrowRatio As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Single

instance.Code39WideToNarrowRatio = value

value = instance.Code39WideToNarrowRatio
C#
public float Code39WideToNarrowRatio {get; set;}
Managed Extensions for C++
public: __property float get_Code39WideToNarrowRatio();
public: __property void set_Code39WideToNarrowRatio(
   float value
);
C++/CLI
public:
property float Code39WideToNarrowRatio {
   float get();
   void set (float value);
}

Return Value

A float value specifying the ratio between wide bars and narrow bars.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.
This property applies to Code39 barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Data Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Data Property

Gets or sets the data displayed in the control.

Syntax

Visual Basic (Declaration)
Public Property Data As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As String

instance.Data = value

value = instance.Data
C#
public string Data {get; set;}
Managed Extensions for C++
public: __property string* get_Data();
public: __property void set_Data(
   string* value
);
C++/CLI
public:
property String^ Data {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing the data displayed in the control as a barcode.

Exceptions

Exception | Description
ArgumentException | Thrown if the data can not be encoded as a barcode of the select symbology.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
DataDisplayLocation Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : DataDisplayLocation Property

Gets or sets the location of the barcode data.

Syntax

Visual Basic (Declaration)
Public Property DataDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As BarcodeTextLocation

instance.DataDisplayLocation = value

value = instance.DataDisplayLocation
C#
public BarcodeTextLocation DataDisplayLocation {get; set;}
Managed Extensions for C++
public: __property BarcodeTextLocation get_DataDisplayLocation();
public: __property void set_DataDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation DataDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location of the barcode data when it is displayed on the barcode.

Remarks

This property applies to 1D barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
DataMatrixEncoding Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : DataMatrixEncoding Property

Gets or sets the encoding of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property DataMatrixEncoding As DataMatrixEncoding
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As DataMatrixEncoding

instance.DataMatrixEncoding = value

value = instance.DataMatrixEncoding
C#
public DataMatrixEncoding DataMatrixEncoding {get; set;}
Managed Extensions for C++
public: __property DataMatrixEncoding get_DataMatrixEncoding();
public: __property void set_DataMatrixEncoding(
   DataMatrixEncoding value
);
C++/CLI
public:
property DataMatrixEncoding DataMatrixEncoding {
   DataMatrixEncoding get();
   void set (DataMatrixEncoding value);
}

Return Value

A DataMatrixEncoding enumeration member specifying the data encoding for this DataMatrix barcode.

Remarks

If the data to encode contains only numbers (ASCII characters from 0x30 to 0x39), then Numeric provides the best encoding. If the data to encode contains only base ASCII characters (0x00 to 0x7F), then both ASCII and Base256 encoding provide the same performance, but if the data to encode contains more than 3 extended ASCII characters (0x80 to 0xFF) then the Base256 encoding is the best option.
If the selected encoding is Auto, then the library will select the encoding that will generate the smallest encoded data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
DataMatrixSymbolSize Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : DataMatrixSymbolSize Property

Gets or sets the symbol size of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property DataMatrixSymbolSize As DataMatrixSymbolSize
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As DataMatrixSymbolSize

instance.DataMatrixSymbolSize = value

value = instance.DataMatrixSymbolSize
C#
public DataMatrixSymbolSize DataMatrixSymbolSize {get; set;}
Managed Extensions for C++
public: __property DataMatrixSymbolSize get_DataMatrixSymbolSize();
public: __property void set_DataMatrixSymbolSize(
   DataMatrixSymbolSize value
);
C++/CLI
public:
property DataMatrixSymbolSize DataMatrixSymbolSize {
   DataMatrixSymbolSize get();
   void set (DataMatrixSymbolSize value);
}

Return Value

A DataMatrixSymbolSize enumeration member specifying the size of symbol used to represent this DataMatrix barcode.

Remarks

If the SymbolSize is Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
DimensionUnit Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : DimensionUnit Property

Gets or sets the measure unit for the XDimension and YDimension properties.

Syntax

Visual Basic (Declaration)
Public Property DimensionUnit As XYDimensionUnit
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As XYDimensionUnit

instance.DimensionUnit = value

value = instance.DimensionUnit
C#
public XYDimensionUnit DimensionUnit {get; set;}
Managed Extensions for C++
public: __property XYDimensionUnit get_DimensionUnit();
public: __property void set_DimensionUnit(
   XYDimensionUnit value
);
C++/CLI
public:
property XYDimensionUnit DimensionUnit {
   XYDimensionUnit get();
   void set (XYDimensionUnit value);
}

Return Value

A XYDimensionUnit enumeration member specifying the measure unit for the XDimension and YDimension properties.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
DisplayCheckSum Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : DisplayCheckSum Property

Gets or sets a value indicating whether the check characters should be displayed in barcode text.

Syntax

Visual Basic (Declaration)
Public Property DisplayCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Boolean

instance.DisplayCheckSum = value

value = instance.DisplayCheckSum
C#
public bool DisplayCheckSum {get; set;}
Managed Extensions for C++
public: __property bool get_DisplayCheckSum();
public: __property void set_DisplayCheckSum(
   bool value
);
C++/CLI
public:
property bool DisplayCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if the check characters should be displayed. Default is false.

Remarks

This property applies to 1D barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
EANSupplement Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : EANSupplement Property

Gets or sets the supplement for barcode data.

Syntax

Visual Basic (Declaration)
Public Property EANSupplement As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As String

instance.EANSupplement = value

value = instance.EANSupplement
C#
public string EANSupplement {get; set;}
Managed Extensions for C++
public: __property string* get_EANSupplement();
public: __property void set_EANSupplement(
   string* value
);
C++/CLI
public:
property String^ EANSupplement {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying a 2 or 5 digit supplemental barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in supplement data or the supplement does not have the required length (2 or 5 digits).

Remarks

This supplement is optional. If it exists, it can be only 2 or 5 digits.
This property applies to EAN13, EAN8, ISBN, ISMN, ISSN, JAN13, UPC-A and UPC-E barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
EANSupplementDisplayLocation Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : EANSupplementDisplayLocation Property

Gets or sets the location of the EAN supplement text.

Syntax

Visual Basic (Declaration)
Public Property EANSupplementDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As BarcodeTextLocation

instance.EANSupplementDisplayLocation = value

value = instance.EANSupplementDisplayLocation
C#
public BarcodeTextLocation EANSupplementDisplayLocation {get; set;}
Managed Extensions for C++
public: __property BarcodeTextLocation get_EANSupplementDisplayLocation();
public: __property void set_EANSupplementDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation EANSupplementDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location where the supplement text is displayed.

Remarks

The embedding options are ignored for supplement text. AboveEmbedded has the same effect like Above, and BelowEmbedded has the same effect like Below.
This property applies to EAN13, EAN8, ISBN, ISMN, ISSN, JAN13, UPC-A and UPC-E barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
EANSupplementYDimension Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : EANSupplementYDimension Property

Gets or sets the height of a bar in the supplement barcode.

Syntax

Visual Basic (Declaration)
Public Property EANSupplementYDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Single

instance.EANSupplementYDimension = value

value = instance.EANSupplementYDimension
C#
public float EANSupplementYDimension {get; set;}
Managed Extensions for C++
public: __property float get_EANSupplementYDimension();
public: __property void set_EANSupplementYDimension(
   float value
);
C++/CLI
public:
property float EANSupplementYDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a bar in the supplement barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
EnableCheckSum Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : EnableCheckSum Property

Gets or sets a value indicating whether a checksum character should be appended automatically to the barcode.

Syntax

Visual Basic (Declaration)
Public Property EnableCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Boolean

instance.EnableCheckSum = value

value = instance.EnableCheckSum
C#
public bool EnableCheckSum {get; set;}
Managed Extensions for C++
public: __property bool get_EnableCheckSum();
public: __property void set_EnableCheckSum(
   bool value
);
C++/CLI
public:
property bool EnableCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if a checksum character should be appended automatically to the barcode, false otherwise.

Remarks

This property applies to 1D barcodes only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LeftQuietZone Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : LeftQuietZone Property

Gets or sets the left quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property LeftQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Single

instance.LeftQuietZone = value

value = instance.LeftQuietZone
C#
public float LeftQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_LeftQuietZone();
public: __property void set_LeftQuietZone(
   float value
);
C++/CLI
public:
property float LeftQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of left quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the left quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MicroPDF417SymbolSize Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : MicroPDF417SymbolSize Property

Gets or sets the symbol size of this Micro PDF 417 barcode.

Syntax

Visual Basic (Declaration)
Public Property MicroPDF417SymbolSize As MicroPDF417SymbolSize
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As MicroPDF417SymbolSize

instance.MicroPDF417SymbolSize = value

value = instance.MicroPDF417SymbolSize
C#
public MicroPDF417SymbolSize MicroPDF417SymbolSize {get; set;}
Managed Extensions for C++
public: __property MicroPDF417SymbolSize get_MicroPDF417SymbolSize();
public: __property void set_MicroPDF417SymbolSize(
   MicroPDF417SymbolSize value
);
C++/CLI
public:
property MicroPDF417SymbolSize MicroPDF417SymbolSize {
   MicroPDF417SymbolSize get();
   void set (MicroPDF417SymbolSize value);
}

Return Value

A MicroPDF417SymbolSize enumeration member specifying the size of symbol used to represent this Micro PDF 417 barcode.

Remarks

If the SymbolSize is Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Pdf417Columns Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Pdf417Columns Property

Gets or sets the number of columns in this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Integer

instance.Pdf417Columns = value

value = instance.Pdf417Columns
C#
public int Pdf417Columns {get; set;}
Managed Extensions for C++
public: __property int get_Pdf417Columns();
public: __property void set_Pdf417Columns(
   int value
);
C++/CLI
public:
property int Pdf417Columns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this PDF417 barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 1 or greater than 30 - OR - Throws when value is 0 and Pdf417Rows is also 0.

Remarks

The minimum number of columns in a PDF 417 barcode is 1 and the maximum number of columns is 30. If this property is 0, the library will compute automatically the number of required columns to encode the barcode data. When this property is 0, the Pdf417Rows property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Pdf417DataCompactionMode Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Pdf417DataCompactionMode Property

Gets or sets the data compaction mode for this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417DataCompactionMode As PDF417DataCompactionMode
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As PDF417DataCompactionMode

instance.Pdf417DataCompactionMode = value

value = instance.Pdf417DataCompactionMode
C#
public PDF417DataCompactionMode Pdf417DataCompactionMode {get; set;}
Managed Extensions for C++
public: __property PDF417DataCompactionMode get_Pdf417DataCompactionMode();
public: __property void set_Pdf417DataCompactionMode(
   PDF417DataCompactionMode value
);
C++/CLI
public:
property PDF417DataCompactionMode Pdf417DataCompactionMode {
   PDF417DataCompactionMode get();
   void set (PDF417DataCompactionMode value);
}

Return Value

A PDF417DataCompactionMode enumeration member specifying the data compaction mode used in this PDF417 barcode.

Remarks

The Text compaction mode provides a 2:1 compaction ratio when using only ASCII characters from 0x20 to 0x7F. The Numeric compaction mode provides a 2.93:1 compaction ratio when using only digits (0x30 to 0x39). Byte compaction mode provides a 1.2:1 compaction ratio when using any 8bit character.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Pdf417ErrorCorrectionLevel Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Pdf417ErrorCorrectionLevel Property

Gets or sets the level of error correction used by this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417ErrorCorrectionLevel As PDF417ErrorCorrectionLevel
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As PDF417ErrorCorrectionLevel

instance.Pdf417ErrorCorrectionLevel = value

value = instance.Pdf417ErrorCorrectionLevel
C#
public PDF417ErrorCorrectionLevel Pdf417ErrorCorrectionLevel {get; set;}
Managed Extensions for C++
public: __property PDF417ErrorCorrectionLevel get_Pdf417ErrorCorrectionLevel();
public: __property void set_Pdf417ErrorCorrectionLevel(
   PDF417ErrorCorrectionLevel value
);
C++/CLI
public:
property PDF417ErrorCorrectionLevel Pdf417ErrorCorrectionLevel {
   PDF417ErrorCorrectionLevel get();
   void set (PDF417ErrorCorrectionLevel value);
}

Return Value

A PDF417ErrorCorrectionLevel enumeration member specifying the level or error correction used by this PDF417 barcode.

Remarks

The lowest error correction level is 0 and the greatest error correction level is 8. Each level generates a specific number of error correction codewords.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Pdf417Rows Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Pdf417Rows Property

Gets or sets the number of rows in this PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Property Pdf417Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Integer

instance.Pdf417Rows = value

value = instance.Pdf417Rows
C#
public int Pdf417Rows {get; set;}
Managed Extensions for C++
public: __property int get_Pdf417Rows();
public: __property void set_Pdf417Rows(
   int value
);
C++/CLI
public:
property int Pdf417Rows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows used by this PDF417 barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 3, but not 0, or greater than 90 - OR - Throws when value is 0 and Pdf417Columns is also 0.

Remarks

The minimum number of rows in a PDF 417 barcode is 3 and the maximum number of rows is 90. If this property is 0, the library will compute automatically the number of required rows to encode the barcode data. When this property is 0, the Pdf417Columns property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Resolution Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Resolution Property

Gets or sets the resolution of the barcode image.

Syntax

Visual Basic (Declaration)
Public Property Resolution As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Single

instance.Resolution = value

value = instance.Resolution
C#
public float Resolution {get; set;}
Managed Extensions for C++
public: __property float get_Resolution();
public: __property void set_Resolution(
   float value
);
C++/CLI
public:
property float Resolution {
   float get();
   void set (float value);
}

Return Value

An integer value representing the resolution of the barcode image.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown if the value is less than or equal to zero.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
RightQuietZone Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : RightQuietZone Property

Gets or sets the right quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property RightQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Single

instance.RightQuietZone = value

value = instance.RightQuietZone
C#
public float RightQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_RightQuietZone();
public: __property void set_RightQuietZone(
   float value
);
C++/CLI
public:
property float RightQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of right quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the right quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Rotation Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Rotation Property

Gets or sets the rotation angle of the barcode.

Syntax

Visual Basic (Declaration)
Public Property Rotation As BarcodeRotation
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As BarcodeRotation

instance.Rotation = value

value = instance.Rotation
C#
public BarcodeRotation Rotation {get; set;}
Managed Extensions for C++
public: __property BarcodeRotation get_Rotation();
public: __property void set_Rotation(
   BarcodeRotation value
);
C++/CLI
public:
property BarcodeRotation Rotation {
   BarcodeRotation get();
   void set (BarcodeRotation value);
}

Return Value

A BarcodeRotation enumeration member specifying the angle used for rotating the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SerialNumber Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : SerialNumber Property

Gets or sets the serial number.

Syntax

Visual Basic (Declaration)
Public Property SerialNumber As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As String

instance.SerialNumber = value

value = instance.SerialNumber
C#
public string SerialNumber {get; set;}
Managed Extensions for C++
public: __property string* get_SerialNumber();
public: __property void set_SerialNumber(
   string* value
);
C++/CLI
public:
property String^ SerialNumber {
   String^ get();
   void set (String^ value);
}

Return Value

The Barcode4NET serial number.

Remarks

The serial number unlocks the BarcodeView Reporting Services control and removes the TRIAL watermark from the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Symbology Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Symbology Property

Gets or sets the type of the barcode displayed in the control.

Syntax

Visual Basic (Declaration)
Public Property Symbology As BarcodeSymbology
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As BarcodeSymbology

instance.Symbology = value

value = instance.Symbology
C#
public BarcodeSymbology Symbology {get; set;}
Managed Extensions for C++
public: __property BarcodeSymbology get_Symbology();
public: __property void set_Symbology(
   BarcodeSymbology value
);
C++/CLI
public:
property BarcodeSymbology Symbology {
   BarcodeSymbology get();
   void set (BarcodeSymbology value);
}

Return Value

A BarcodeSymbology enumeration member specifying the type of the barcode displayed in the control.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
TextColor Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : TextColor Property

Gets or sets the text color for the barcode.

Syntax

Visual Basic (Declaration)
Public Property TextColor As ReportColor
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As ReportColor

instance.TextColor = value

value = instance.TextColor
C#
public ReportColor TextColor {get; set;}
Managed Extensions for C++
public: __property ReportColor get_TextColor();
public: __property void set_TextColor(
   ReportColor value
);
C++/CLI
public:
property ReportColor TextColor {
   ReportColor get();
   void set (ReportColor value);
}

Return Value

A Color that represents the color used to display the barcode text.The default value is Black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
TopQuietZone Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : TopQuietZone Property

Gets or sets the top quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property TopQuietZone As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Single

instance.TopQuietZone = value

value = instance.TopQuietZone
C#
public float TopQuietZone {get; set;}
Managed Extensions for C++
public: __property float get_TopQuietZone();
public: __property void set_TopQuietZone(
   float value
);
C++/CLI
public:
property float TopQuietZone {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of top quiet zone in bar units (xDimension).

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Remarks

The size of the top quiet zone is specified as a multiple of XDimension property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
XDimension Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : XDimension Property

Gets or sets the width of a narrow bar.

Syntax

Visual Basic (Declaration)
Public Property XDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Single

instance.XDimension = value

value = instance.XDimension
C#
public float XDimension {get; set;}
Managed Extensions for C++
public: __property float get_XDimension();
public: __property void set_XDimension(
   float value
);
C++/CLI
public:
property float XDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the width of a narrow bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.
The recommended width of a narrow bar is 12 mills. Depending on the barcode printer resolution and quality of barcode scanner, the XDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower XDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
YDimension Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : YDimension Property

Gets or sets the height of a bar.

Syntax

Visual Basic (Declaration)
Public Property YDimension As Single
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Single

instance.YDimension = value

value = instance.YDimension
C#
public float YDimension {get; set;}
Managed Extensions for C++
public: __property float get_YDimension();
public: __property void set_YDimension(
   float value
);
C++/CLI
public:
property float YDimension {
   float get();
   void set (float value);
}

Return Value

A float value specifying the height of a bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The measure unit applied to this property is specified by DimensionUnit property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%ItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Xheo.Licensing Namespace (Barcode4NET.RS.Design)
See Also Inheritance Hierarchy

Classes

Class | Description
BigInteger | Implements an large integer of arbitrary length.
ContainerLimit | Serves as a base class for limits that contain other limits.
ExtendedLicense | Primary class for the XHEO|Licensing framework.
ExtendedLicenseException | Represents an exception in a Xheo assembly with a localized FriendlyMessage and DetailedMessage.
ExtendedLicensePack | Represents a collection of licenses stored in a single .LIC file.
LicenseSigningKey | Implements a key pair for signing licenses.
LicenseValuesCollection | Maintains a collection of name value pairs. The collection can be serialized and marked as read only.
Limit | Base class for all license limitations.
LimitCollection | Services as a collection of limits.
MachineProfile | Manages a machine profile used by the license activation system. Profiles represent a collection of generally non volitale system properties that can collectively be used to identify certain machines.
MachineProfile.Constants | A class to contain the constants required for the IP_ADAPTER_INFO struct
MachineProfile.GetAdapterInfo | Uses the windows API to retrieve information about the IP configuration of the local machine
StateEntry |
TransientReadOnlyCollection | Implements a transient read only collection. Values can be added, removed and changed until the SetReadOnly method is called thus forcing the collection to a read only state.

Structures

Structure | Description
LicenseSigningKey.KeyRecord |
MachineProfile._MEMORYSTATUS | Summary of _MEMORYSTATUS
MachineProfile._MEMORYSTATUSEX | Summary of _MEMORYSTATUSEX
MachineProfile.IP_ADAPTERINFO_STRUCTURE | declare the IP_ADAPTERINFO_STRUCTURE structure
MachineProfile.IP_ADDR_STRING | declare the IP_ADDR_STRING structure
MachineProfile.TGuid | Summary of TGuid

Enumerations

Enumeration | Description
PeekResult | Possible results from the Peek method.
SerialNumberSizes | Possible key sizes for use when generating serial numbers. More bits makes it more difficult to crack but also increase the size of the serial number.

See Also

Reference

Barcode4NET.RS.Design Assembly


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Class
See Also Members
[image]
Xheo.Licensing Namespace : BigInteger Class

Implements an large integer of arbitrary length.

Syntax

Visual Basic (Declaration)
Private Class BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
C#
private class BigInteger
Managed Extensions for C++
private __gc class BigInteger
C++/CLI
private ref class BigInteger

Inheritance Hierarchy

System.Object
Xheo.Licensing.BigInteger

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Class Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : BigInteger Class

The following tables list the members exposed by BigInteger.

Public Constructors

 | Name | Description
Public Constructor | BigInteger Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | dataLength |
static (Shared in Visual Basic) | primesBelow2000 |
Top

Public Methods

 | Name | Description
Public Method | abs |
Public Method | bitCount |
Public Method | Equals | Overridden.
Public Method | FermatLittleTest |
Public Method | gcd |
static (Shared in Visual Basic) | genPseudoPrime |
Public Method | genRandomBits |
Public Method | getBit |
Public Method | getBytes |
Public Method | GetHashCode | Overridden.
Public Method | IntValue |
Public Method | isProbablePrime | Overloaded.
static (Shared in Visual Basic) | Jacobi |
Public Method | LongValue |
static (Shared in Visual Basic) | LucasSequence |
Public Method | LucasStrongTest |
Public Method | min |
Public Method | modInverse |
Public Method | modPow |
Public Method | RabinMillerTest |
Public Method | setBit |
Public Method | sqrt |
Public Method | ToHexString |
Public Method | ToString | Overloaded. Overridden.
Public Method | ULongValue |
Public Method | unsetBit |
Top

Public Operators

Public Operator Addition |
Public Operator And |
Public Operator Or |
Public Operator Decrement |
Public Operator Division |
Public Operator Equality |
Public Operator Exclusive Or |
Public Operator Greater Than |
Public Operator Greater Than or Equal |
Public Operator Implicit Type Conversion | Overloaded.
Public Operator Increment |
Public Operator Inequality |
Public Operator Left-shift |
Public Operator Less Than |
Public Operator Less Than or Equal |
Public Operator Modulus |
Public Operator Multiplication |
Public Operator Bitwise Complement |
Public Operator Right-shift |
Public Operator Subtraction |
Public Operator Unary Negation |
Top

See Also

Reference

BigInteger Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Constructor
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : BigInteger Constructor

Overload List

Overload | Description
BigInteger Constructor() |
BigInteger Constructor(BigInteger) |
BigInteger Constructor(Byte[]) |
BigInteger Constructor(Byte[],Int32) |
BigInteger Constructor(Int64) |
BigInteger Constructor(String,Int32) |
BigInteger Constructor(UInt32[]) |
BigInteger Constructor(UInt64) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Constructor()
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BigInteger()
C#
public BigInteger()
Managed Extensions for C++
public: BigInteger();
C++/CLI
public:
BigInteger();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Constructor(BigInteger)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(BigInteger)

bi

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bi As BigInteger _
)
Visual Basic (Usage) Copy Code
Dim bi As BigInteger

Dim instance As BigInteger(bi)
C#
public BigInteger(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger(
   BigInteger* bi
)
C++/CLI
public:
BigInteger(
   BigInteger^ bi
)

Parameters

bi

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Constructor(Byte[])
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Byte[])

inData

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As Byte _
)
Visual Basic (Usage) Copy Code
Dim inData() As Byte

Dim instance As BigInteger(inData)
C#
public BigInteger(
   byte[] inData
)
Managed Extensions for C++
public: BigInteger(
   byte[] inData
)
C++/CLI
public:
BigInteger(
   array<byte> inData
)

Parameters

inData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Constructor(Byte[],Int32)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Byte[],Int32)

inData
inLen

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As Byte, _
   ByVal inLen As Integer _
)
Visual Basic (Usage) Copy Code
Dim inData() As Byte
Dim inLen As Integer

Dim instance As BigInteger(inData, inLen)
C#
public BigInteger(
   byte[] inData,
   int inLen
)
Managed Extensions for C++
public: BigInteger(
   byte[] inData,
   int inLen
)
C++/CLI
public:
BigInteger(
   array<byte> inData,
   int inLen
)

Parameters

inData
inLen

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Constructor(Int64)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(Int64)

value

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim value As Long

Dim instance As BigInteger(value)
C#
public BigInteger(
   long value
)
Managed Extensions for C++
public: BigInteger(
   long value
)
C++/CLI
public:
BigInteger(
   long value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Constructor(String,Int32)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(String,Int32)

value
radix

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal radix As Integer _
)
Visual Basic (Usage) Copy Code
Dim value As String
Dim radix As Integer

Dim instance As BigInteger(value, radix)
C#
public BigInteger(
   string value,
   int radix
)
Managed Extensions for C++
public: BigInteger(
   string* value,
   int radix
)
C++/CLI
public:
BigInteger(
   String^ value,
   int radix
)

Parameters

value
radix

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Constructor(UInt32[])
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(UInt32[])

inData

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inData() As UInteger _
)
Visual Basic (Usage) Copy Code
Dim inData() As UInteger

Dim instance As BigInteger(inData)
C#
public BigInteger(
   uint[] inData
)
Managed Extensions for C++
public: BigInteger(
   uint[] inData
)
C++/CLI
public:
BigInteger(
   array<uint> inData
)

Parameters

inData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Constructor(UInt64)
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > BigInteger Constructor : BigInteger Constructor(UInt64)

value

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As ULong _
)
Visual Basic (Usage) Copy Code
Dim value As ULong

Dim instance As BigInteger(value)
C#
public BigInteger(
   ulong value
)
Managed Extensions for C++
public: BigInteger(
   ulong value
)
C++/CLI
public:
BigInteger(
   ulong value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Class Methods
See Also
[image]
Xheo.Licensing Namespace : BigInteger Class

For a list of all members of this type, see BigInteger members.

Public Methods

 | Name | Description
Public Method | abs |
Public Method | bitCount |
Public Method | Equals | Overridden.
Public Method | FermatLittleTest |
Public Method | gcd |
static (Shared in Visual Basic) | genPseudoPrime |
Public Method | genRandomBits |
Public Method | getBit |
Public Method | getBytes |
Public Method | GetHashCode | Overridden.
Public Method | IntValue |
Public Method | isProbablePrime | Overloaded.
static (Shared in Visual Basic) | Jacobi |
Public Method | LongValue |
static (Shared in Visual Basic) | LucasSequence |
Public Method | LucasStrongTest |
Public Method | min |
Public Method | modInverse |
Public Method | modPow |
Public Method | RabinMillerTest |
Public Method | setBit |
Public Method | sqrt |
Public Method | ToHexString |
Public Method | ToString | Overloaded. Overridden.
Public Method | ULongValue |
Public Method | unsetBit |
Top

See Also

Reference

BigInteger Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
abs Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : abs Method

Syntax

Visual Basic (Declaration)
Public Function abs() As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As BigInteger

value = instance.abs()
C#
public BigInteger abs()
Managed Extensions for C++
public: BigInteger* abs();
C++/CLI
public:
BigInteger^ abs();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
bitCount Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : bitCount Method

Syntax

Visual Basic (Declaration)
Public Function bitCount() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.bitCount()
C#
public int bitCount()
Managed Extensions for C++
public: int bitCount();
C++/CLI
public:
int bitCount();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Equals Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Equals Method

o

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal o As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim o As Object
Dim value As Boolean

value = instance.Equals(o)
C#
public override bool Equals(
   object o
)
Managed Extensions for C++
public: bool Equals(
   Object* o
) override
C++/CLI
public:
bool Equals(
   Object^ o
) override

Parameters

o

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
FermatLittleTest Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : FermatLittleTest Method

confidence

Syntax

Visual Basic (Declaration)
Public Function FermatLittleTest( _
   ByVal confidence As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim confidence As Integer
Dim value As Boolean

value = instance.FermatLittleTest(confidence)
C#
public bool FermatLittleTest(
   int confidence
)
Managed Extensions for C++
public: bool FermatLittleTest(
   int confidence
)
C++/CLI
public:
bool FermatLittleTest(
   int confidence
)

Parameters

confidence

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
gcd Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : gcd Method

bi

Syntax

Visual Basic (Declaration)
Public Function gcd( _
   ByVal bi As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bi As BigInteger
Dim value As BigInteger

value = instance.gcd(bi)
C#
public BigInteger gcd(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger* gcd(
   BigInteger* bi
)
C++/CLI
public:
BigInteger^ gcd(
   BigInteger^ bi
)

Parameters

bi

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
genPseudoPrime Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : genPseudoPrime Method

bits
confidence
rand

Syntax

Visual Basic (Declaration)
Public Shared Function genPseudoPrime( _
   ByVal bits As Integer, _
   ByVal confidence As Integer, _
   ByVal rand As RandomNumberGenerator _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim bits As Integer
Dim confidence As Integer
Dim rand As RandomNumberGenerator
Dim value As BigInteger

value = BigInteger.genPseudoPrime(bits, confidence, rand)
C#
public static BigInteger genPseudoPrime(
   int bits,
   int confidence,
   RandomNumberGenerator rand
)
Managed Extensions for C++
public: static BigInteger* genPseudoPrime(
   int bits,
   int confidence,
   RandomNumberGenerator* rand
)
C++/CLI
public:
static BigInteger^ genPseudoPrime(
   int bits,
   int confidence,
   RandomNumberGenerator^ rand
)

Parameters

bits
confidence
rand

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
genRandomBits Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : genRandomBits Method

bits
rand

Syntax

Visual Basic (Declaration)
Public Sub genRandomBits( _
   ByVal bits As Integer, _
   ByVal rand As RandomNumberGenerator _
)
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bits As Integer
Dim rand As RandomNumberGenerator

instance.genRandomBits(bits, rand)
C#
public void genRandomBits(
   int bits,
   RandomNumberGenerator rand
)
Managed Extensions for C++
public: void genRandomBits(
   int bits,
   RandomNumberGenerator* rand
)
C++/CLI
public:
void genRandomBits(
   int bits,
   RandomNumberGenerator^ rand
)

Parameters

bits
rand

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
getBit Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : getBit Method

bitNum

Syntax

Visual Basic (Declaration)
Public Function getBit( _
   ByVal bitNum As UInteger _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bitNum As UInteger
Dim value As Boolean

value = instance.getBit(bitNum)
C#
public bool getBit(
   uint bitNum
)
Managed Extensions for C++
public: bool getBit(
   uint bitNum
)
C++/CLI
public:
bool getBit(
   uint bitNum
)

Parameters

bitNum

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
getBytes Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : getBytes Method

Syntax

Visual Basic (Declaration)
Public Function getBytes() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value() As Byte

value = instance.getBytes()
C#
public byte[] getBytes()
Managed Extensions for C++
public: byte[] getBytes();
C++/CLI
public:
array<byte> getBytes();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetHashCode Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : GetHashCode Method

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IntValue Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : IntValue Method

Syntax

Visual Basic (Declaration)
Public Function IntValue() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.IntValue()
C#
public int IntValue()
Managed Extensions for C++
public: int IntValue();
C++/CLI
public:
int IntValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
isProbablePrime Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : isProbablePrime Method

Overload List

Overload | Description
isProbablePrime(Int32) |
isProbablePrime() |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
isProbablePrime(Int32) Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > isProbablePrime Method : isProbablePrime(Int32) Method

confidence

Syntax

Visual Basic (Declaration)
Overloads Public Function isProbablePrime( _
   ByVal confidence As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim confidence As Integer
Dim value As Boolean

value = instance.isProbablePrime(confidence)
C#
public bool isProbablePrime(
   int confidence
)
Managed Extensions for C++
public: bool isProbablePrime(
   int confidence
)
C++/CLI
public:
bool isProbablePrime(
   int confidence
)

Parameters

confidence

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
isProbablePrime() Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > isProbablePrime Method : isProbablePrime() Method

Syntax

Visual Basic (Declaration)
Overloads Public Function isProbablePrime() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Boolean

value = instance.isProbablePrime()
C#
public bool isProbablePrime()
Managed Extensions for C++
public: bool isProbablePrime();
C++/CLI
public:
bool isProbablePrime();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Jacobi Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Jacobi Method

a
b

Syntax

Visual Basic (Declaration)
Public Shared Function Jacobi( _
   ByVal a As BigInteger, _
   ByVal b As BigInteger _
) As Integer
Visual Basic (Usage) Copy Code
Dim a As BigInteger
Dim b As BigInteger
Dim value As Integer

value = BigInteger.Jacobi(a, b)
C#
public static int Jacobi(
   BigInteger a,
   BigInteger b
)
Managed Extensions for C++
public: static int Jacobi(
   BigInteger* a,
   BigInteger* b
)
C++/CLI
public:
static int Jacobi(
   BigInteger^ a,
   BigInteger^ b
)

Parameters

a
b

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LongValue Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : LongValue Method

Syntax

Visual Basic (Declaration)
Public Function LongValue() As Long
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Long

value = instance.LongValue()
C#
public long LongValue()
Managed Extensions for C++
public: long LongValue();
C++/CLI
public:
long LongValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LucasSequence Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : LucasSequence Method

P
Q
k
n

Syntax

Visual Basic (Declaration)
Public Shared Function LucasSequence( _
   ByVal P As BigInteger, _
   ByVal Q As BigInteger, _
   ByVal k As BigInteger, _
   ByVal n As BigInteger _
) As BigInteger()
Visual Basic (Usage) Copy Code
Dim P As BigInteger
Dim Q As BigInteger
Dim k As BigInteger
Dim n As BigInteger
Dim value() As BigInteger

value = BigInteger.LucasSequence(P, Q, k, n)
C#
public static BigInteger[] LucasSequence(
   BigInteger P,
   BigInteger Q,
   BigInteger k,
   BigInteger n
)
Managed Extensions for C++
public: static BigInteger*[] LucasSequence(
   BigInteger* P,
   BigInteger* Q,
   BigInteger* k,
   BigInteger* n
)
C++/CLI
public:
static array<BigInteger^> LucasSequence(
   BigInteger^ P,
   BigInteger^ Q,
   BigInteger^ k,
   BigInteger^ n
)

Parameters

P
Q
k
n

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LucasStrongTest Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : LucasStrongTest Method

Syntax

Visual Basic (Declaration)
Public Function LucasStrongTest() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Boolean

value = instance.LucasStrongTest()
C#
public bool LucasStrongTest()
Managed Extensions for C++
public: bool LucasStrongTest();
C++/CLI
public:
bool LucasStrongTest();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
min Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : min Method

bi

Syntax

Visual Basic (Declaration)
Public Function min( _
   ByVal bi As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bi As BigInteger
Dim value As BigInteger

value = instance.min(bi)
C#
public BigInteger min(
   BigInteger bi
)
Managed Extensions for C++
public: BigInteger* min(
   BigInteger* bi
)
C++/CLI
public:
BigInteger^ min(
   BigInteger^ bi
)

Parameters

bi

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
modInverse Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : modInverse Method

modulus

Syntax

Visual Basic (Declaration)
Public Function modInverse( _
   ByVal modulus As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim modulus As BigInteger
Dim value As BigInteger

value = instance.modInverse(modulus)
C#
public BigInteger modInverse(
   BigInteger modulus
)
Managed Extensions for C++
public: BigInteger* modInverse(
   BigInteger* modulus
)
C++/CLI
public:
BigInteger^ modInverse(
   BigInteger^ modulus
)

Parameters

modulus

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
modPow Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : modPow Method

exp
n

Syntax

Visual Basic (Declaration)
Public Function modPow( _
   ByVal exp As BigInteger, _
   ByVal n As BigInteger _
) As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim exp As BigInteger
Dim n As BigInteger
Dim value As BigInteger

value = instance.modPow(exp, n)
C#
public BigInteger modPow(
   BigInteger exp,
   BigInteger n
)
Managed Extensions for C++
public: BigInteger* modPow(
   BigInteger* exp,
   BigInteger* n
)
C++/CLI
public:
BigInteger^ modPow(
   BigInteger^ exp,
   BigInteger^ n
)

Parameters

exp
n

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
RabinMillerTest Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : RabinMillerTest Method

confidence

Syntax

Visual Basic (Declaration)
Public Function RabinMillerTest( _
   ByVal confidence As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim confidence As Integer
Dim value As Boolean

value = instance.RabinMillerTest(confidence)
C#
public bool RabinMillerTest(
   int confidence
)
Managed Extensions for C++
public: bool RabinMillerTest(
   int confidence
)
C++/CLI
public:
bool RabinMillerTest(
   int confidence
)

Parameters

confidence

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
setBit Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : setBit Method

bitNum

Syntax

Visual Basic (Declaration)
Public Sub setBit( _
   ByVal bitNum As UInteger _
)
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bitNum As UInteger

instance.setBit(bitNum)
C#
public void setBit(
   uint bitNum
)
Managed Extensions for C++
public: void setBit(
   uint bitNum
)
C++/CLI
public:
void setBit(
   uint bitNum
)

Parameters

bitNum

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
sqrt Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : sqrt Method

Syntax

Visual Basic (Declaration)
Public Function sqrt() As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As BigInteger

value = instance.sqrt()
C#
public BigInteger sqrt()
Managed Extensions for C++
public: BigInteger* sqrt();
C++/CLI
public:
BigInteger^ sqrt();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ToHexString Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : ToHexString Method

Syntax

Visual Basic (Declaration)
Public Function ToHexString() As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As String

value = instance.ToHexString()
C#
public string ToHexString()
Managed Extensions for C++
public: string* ToHexString();
C++/CLI
public:
String^ ToHexString();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ToString Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : ToString Method

Overload List

Overload | Description
ToString() |
ToString(Int32) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ToString() Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > ToString Method : ToString() Method

Syntax

Visual Basic (Declaration)
Overloads Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ToString(Int32) Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > ToString Method : ToString(Int32) Method

radix

Syntax

Visual Basic (Declaration)
Overloads Public Function ToString( _
   ByVal radix As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim radix As Integer
Dim value As String

value = instance.ToString(radix)
C#
public string ToString(
   int radix
)
Managed Extensions for C++
public: string* ToString(
   int radix
)
C++/CLI
public:
String^ ToString(
   int radix
)

Parameters

radix

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ULongValue Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : ULongValue Method

Syntax

Visual Basic (Declaration)
Public Function ULongValue() As ULong
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As ULong

value = instance.ULongValue()
C#
public ulong ULongValue()
Managed Extensions for C++
public: ulong ULongValue();
C++/CLI
public:
ulong ULongValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
unsetBit Method
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : unsetBit Method

bitNum

Syntax

Visual Basic (Declaration)
Public Sub unsetBit( _
   ByVal bitNum As UInteger _
)
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim bitNum As UInteger

instance.unsetBit(bitNum)
C#
public void unsetBit(
   uint bitNum
)
Managed Extensions for C++
public: void unsetBit(
   uint bitNum
)
C++/CLI
public:
void unsetBit(
   uint bitNum
)

Parameters

bitNum

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.RS.Design Send comments on this topic.
BigInteger Class Fields
See Also
[image]
Xheo.Licensing Namespace : BigInteger Class

For a list of all members of this type, see BigInteger members.

Public Fields

 | Name | Description
Public Field | dataLength |
static (Shared in Visual Basic) | primesBelow2000 |
Top

See Also

Reference

BigInteger Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
dataLength Field
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : dataLength Field

Syntax

Visual Basic (Declaration)
Public dataLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As BigInteger
Dim value As Integer

value = instance.dataLength

instance.dataLength = value
C#
public int dataLength
Managed Extensions for C++
public: int dataLength
C++/CLI
public:
int dataLength

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
primesBelow2000 Field
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : primesBelow2000 Field

Syntax

Visual Basic (Declaration)
Public Shared primesBelow2000 As Integer()
Visual Basic (Usage) Copy Code
Dim value() As Integer

value = BigInteger.primesBelow2000

BigInteger.primesBelow2000 = value
C#
public static int[] primesBelow2000
Managed Extensions for C++
public: static int[] primesBelow2000
C++/CLI
public:
static array<int> primesBelow2000

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Addition Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Addition Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator +(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Addition(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator +(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
And Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : And Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator And( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator &(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_BitwiseAnd(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator &(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Or Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Or Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator Or( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator |(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_BitwiseOr(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator |(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Decrement Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Decrement Operator

bi1

Syntax

Visual Basic (Declaration)
This operator type is not supported by Visual Basic
C#
public BigInteger operator --(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_Decrement(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator --(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Division Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Division Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator /( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator /(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Division(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator /(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Equality Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Equality Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator ==(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_Equality(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator ==(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Exclusive Or Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Exclusive Or Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator Xor( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator ^(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_ExclusiveOr(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator ^(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Greater Than Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Greater Than Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator >(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_GreaterThan(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator >(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Greater Than or Equal Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Greater Than or Equal Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator >=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_GreaterThanOrEqual(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator >=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Implicit Type Conversion Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Implicit Type Conversion Operator

Overload List

Overload | Description
Implicit Type Conversion(Int32) |
Implicit Type Conversion(Int64) |
Implicit Type Conversion(UInt32) |
Implicit Type Conversion(UInt64) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Increment Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Increment Operator

bi1

Syntax

Visual Basic (Declaration)
This operator type is not supported by Visual Basic
C#
public BigInteger operator ++(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_Increment(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator ++(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Inequality Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Inequality Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator !=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_Inequality(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator !=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Left-shift Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Left-shift Operator

bi1
shiftVal

Syntax

Visual Basic (Declaration)
Public Operator <<( _
   ByVal bi1 As BigInteger, _
   ByVal shiftVal As Integer _
) As BigInteger
C#
public BigInteger operator <<(
   BigInteger bi1,
   int shiftVal
)
Managed Extensions for C++
public: BigInteger* op_LeftShift(
   BigInteger* bi1,
   int shiftVal
)
C++/CLI
public:
BigInteger^ operator <<(
   BigInteger^ bi1,
   int shiftVal
)

Parameters

bi1
shiftVal

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Less Than Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Less Than Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator <(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_LessThan(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator <(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Less Than or Equal Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Less Than or Equal Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As Boolean
C#
public bool operator <=(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: bool op_LessThanOrEqual(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
bool operator <=(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Modulus Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Modulus Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator Mod( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator %(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Modulus(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator %(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Multiplication Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Multiplication Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator *( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator *(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Multiply(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator *(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Bitwise Complement Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Bitwise Complement Operator

bi1

Syntax

Visual Basic (Declaration)
Public Operator Not( _
   ByVal bi1 As BigInteger _
) As BigInteger
C#
public BigInteger operator ~(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_OnesComplement(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator ~(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Right-shift Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Right-shift Operator

bi1
shiftVal

Syntax

Visual Basic (Declaration)
Public Operator >>( _
   ByVal bi1 As BigInteger, _
   ByVal shiftVal As Integer _
) As BigInteger
C#
public BigInteger operator >>(
   BigInteger bi1,
   int shiftVal
)
Managed Extensions for C++
public: BigInteger* op_RightShift(
   BigInteger* bi1,
   int shiftVal
)
C++/CLI
public:
BigInteger^ operator >>(
   BigInteger^ bi1,
   int shiftVal
)

Parameters

bi1
shiftVal

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Subtraction Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Subtraction Operator

bi1
bi2

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal bi1 As BigInteger, _
   ByVal bi2 As BigInteger _
) As BigInteger
C#
public BigInteger operator -(
   BigInteger bi1,
   BigInteger bi2
)
Managed Extensions for C++
public: BigInteger* op_Subtraction(
   BigInteger* bi1,
   BigInteger* bi2
)
C++/CLI
public:
BigInteger^ operator -(
   BigInteger^ bi1,
   BigInteger^ bi2
)

Parameters

bi1
bi2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Unary Negation Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class : Unary Negation Operator

bi1

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal bi1 As BigInteger _
) As BigInteger
C#
public BigInteger operator -(
   BigInteger bi1
)
Managed Extensions for C++
public: BigInteger* op_UnaryNegation(
   BigInteger* bi1
)
C++/CLI
public:
BigInteger^ operator -(
   BigInteger^ bi1
)

Parameters

bi1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ContainerLimit Class
See Also Members
[image]
Xheo.Licensing Namespace : ContainerLimit Class

Serves as a base class for limits that contain other limits.

Object Model

Syntax

Visual Basic (Declaration)
Private MustInherit Class ContainerLimit
   Inherits Limit
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
C#
private abstract class ContainerLimit : Limit
Managed Extensions for C++
private __gc abstract class ContainerLimit : public Limit
C++/CLI
private ref class ContainerLimit abstract : public Limit

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Xheo.Licensing.Limit
Xheo.Licensing.ContainerLimit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
ContainerLimit Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : ContainerLimit Class

The following tables list the members exposed by ContainerLimit.

Public Properties

 | Name | Description
Public Property | Description | Gets the description of the limit. (Inherited from Limit)
Public Property | IsGui | Overridden. Gets a value that indicates if the limit may use a GUI interface.
Public Property | IsRemote | Overridden. Gets a value that indicates if the limit may use remote resources.
Public Property | IsTimeSensitive | Overridden. Determines if any contained limits are time sensitive.
Public Property | License | Gets or sets a reference to the ExtendedLicense that contains this Limit. (Inherited from Limit)
Public Property | Limits | Gets the collection of child limits.
Public Property | Name | Gets the display name of the limit. (Inherited from Limit)
Public Property | QualifiedTypeName | Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type. (Inherited from Limit)
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases any managed or unmanged resources. (Inherited from Limit)
Public Method | GetDetailsDescription | Gets a description of the details of the limit. (Inherited from Limit)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Granted | Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created. (Inherited from Limit)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | LoadFromXml | Overridden. Loads the contents of a Limit from an XmlNode.
Public Method | Peek | Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user. (Inherited from Limit)
Public Method | SaveToXml | Overridden. Saves the contents of the Limit as an XmlNode.
Public Method | Validate | Validates that the license being granted is within the limits enforced by this object. (Inherited from Limit)
Top

See Also

Reference

ContainerLimit Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
ContainerLimit Class Methods
See Also
[image]
Xheo.Licensing Namespace : ContainerLimit Class

For a list of all members of this type, see ContainerLimit members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases any managed or unmanged resources. (Inherited from Limit)
Public Method | GetDetailsDescription | Gets a description of the details of the limit. (Inherited from Limit)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Granted | Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created. (Inherited from Limit)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | LoadFromXml | Overridden. Loads the contents of a Limit from an XmlNode.
Public Method | Peek | Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user. (Inherited from Limit)
Public Method | SaveToXml | Overridden. Saves the contents of the Limit as an XmlNode.
Public Method | Validate | Validates that the license being granted is within the limits enforced by this object. (Inherited from Limit)
Top

See Also

Reference

ContainerLimit Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : LoadFromXml Method

node
The XmlNode to load from.
Loads the contents of a Limit from an XmlNode.

Syntax

Visual Basic (Declaration)
Overrides Public Function LoadFromXml( _
   ByVal node As XmlNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim node As XmlNode
Dim value As Boolean

value = instance.LoadFromXml(node)
C#
public override bool LoadFromXml(
   XmlNode node
)
Managed Extensions for C++
public: bool LoadFromXml(
   XmlNode node
) override
C++/CLI
public:
bool LoadFromXml(
   XmlNode node
) override

Parameters

node
The XmlNode to load from.

Return Value

Returns true if the load was successful, otherwise false.
Returns true if the load was successful, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : SaveToXml Method

parent
The parent node to save to.
Saves the contents of the Limit as an XmlNode.

Syntax

Visual Basic (Declaration)
Overrides Public Function SaveToXml( _
   ByVal parent As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim parent As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parent)
C#
public override XmlNode SaveToXml(
   XmlNode parent
)
Managed Extensions for C++
public: XmlNode SaveToXml(
   XmlNode parent
) override
C++/CLI
public:
XmlNode SaveToXml(
   XmlNode parent
) override

Parameters

parent
The parent node to save to.

Return Value

Returns the saved XmlNode.
Returns the saved XmlNode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.RS.Design Send comments on this topic.
ContainerLimit Class Properties
See Also
[image]
Xheo.Licensing Namespace : ContainerLimit Class

For a list of all members of this type, see ContainerLimit members.

Public Properties

 | Name | Description
Public Property | Description | Gets the description of the limit. (Inherited from Limit)
Public Property | IsGui | Overridden. Gets a value that indicates if the limit may use a GUI interface.
Public Property | IsRemote | Overridden. Gets a value that indicates if the limit may use remote resources.
Public Property | IsTimeSensitive | Overridden. Determines if any contained limits are time sensitive.
Public Property | License | Gets or sets a reference to the ExtendedLicense that contains this Limit. (Inherited from Limit)
Public Property | Limits | Gets the collection of child limits.
Public Property | Name | Gets the display name of the limit. (Inherited from Limit)
Public Property | QualifiedTypeName | Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type. (Inherited from Limit)
Top

See Also

Reference

ContainerLimit Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IsGui Property
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : IsGui Property

Gets a value that indicates if the limit may use a GUI interface.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property IsGui As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim value As Boolean

value = instance.IsGui
C#
public override bool IsGui {get;}
Managed Extensions for C++
public: __property bool get_IsGui()override ;
C++/CLI
public:
property bool IsGui override {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IsRemote Property
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : IsRemote Property

Gets a value that indicates if the limit may use remote resources.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property IsRemote As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim value As Boolean

value = instance.IsRemote
C#
public override bool IsRemote {get;}
Managed Extensions for C++
public: __property bool get_IsRemote()override ;
C++/CLI
public:
property bool IsRemote override {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IsTimeSensitive Property
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : IsTimeSensitive Property

Determines if any contained limits are time sensitive.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property IsTimeSensitive As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim value As Boolean

value = instance.IsTimeSensitive
C#
public override bool IsTimeSensitive {get;}
Managed Extensions for C++
public: __property bool get_IsTimeSensitive()override ;
C++/CLI
public:
property bool IsTimeSensitive override {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Limits Property
See Also
[image]
Xheo.Licensing Namespace > ContainerLimit Class : Limits Property

Gets the collection of child limits.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Limits As LimitCollection
Visual Basic (Usage) Copy Code
Dim instance As ContainerLimit
Dim value As LimitCollection

value = instance.Limits
C#
public LimitCollection Limits {get;}
Managed Extensions for C++
public: __property LimitCollection* get_Limits();
C++/CLI
public:
property LimitCollection^ Limits {
   LimitCollection^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ContainerLimit Class
ContainerLimit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicense Class
See Also Members
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

Primary class for the XHEO|Licensing framework.

Object Model

Syntax

Visual Basic (Declaration)
Private NotInheritable Class ExtendedLicense
   Inherits License
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
C#
private sealed class ExtendedLicense : License
Managed Extensions for C++
private __gc __sealed class ExtendedLicense : public License
C++/CLI
private ref class ExtendedLicense sealed : public License

Remarks

Each Type in an assembly can be protected by XHEO|Licensing. The environment that the Type is allowed to run in, is defined by a collection of Limit instances defined for the license. For instance the license may limit a component for use on a computer with a specific IP address. These limits are implemented and enforced by subclasses of the Limit class.

To ensure that the license files have not been altered since they were issued, each ExtendedLicense is signed with a LicenseSigningKey. The signing key uses a public key encryption method (See Cryptography) with the public key embedded in the assembly that the component is implemented in. The private key remains secured with the original developers ensuring that only they can grant valid licenses.

Inheritance Hierarchy

System.Object
System.ComponentModel.License
Xheo.Licensing.ExtendedLicense

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Members
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicense Class Members
See Also Fields Properties Methods
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

The following tables list the members exposed by ExtendedLicense.

Public Constructors

 | Name | Description
Public Constructor | ExtendedLicense Constructor | Overloaded. Initializes a new instance of the ExtendedLicense class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ConfigSection | The configuration section where XHEO|Licensing settings are stored in the application's configuration file.
static (Shared in Visual Basic) | CurrentVersion | The current license scheme file version.
Top

Public Properties

 | Name | Description
Public Property | AbsoluteOrganization | Gets or sets the name of the organization that the license is issued to.
Public Property | AbsoluteSerialNumber | Gets or sets the serial number for the license.
Public Property | AbsoluteUser | Gets or sets the name of the user that the license is issued to.
Public Property | AcceptedSerialNumberSizes | Gets or sets the serial number sizes that can be used to unlock the license. If a valid serial number of a different size is used, license validation will fail.
Public Property | AssemblyName | Gets or sets the name of the assembly used to sign the license originally. The value of this property is for reference only and has no impact on the validation of a license.
Public Property | Components | Gets the collection of component names that the license applies to.
static (Shared in Visual Basic) | ConnectionString | Gets the default database connection string for licensing components.
static (Shared in Visual Basic) | EmulateVersion | Gets a value that determines the release version that XHEO|Licensing should emulate.
Public Property | Expires | Gets or sets the expiration date for the license.
static (Shared in Visual Basic) | IisIsAvailable | Gets a value that indicates if IIS is installed and available on the machine. If false then HttpContext should not be checked because it will throw an exception.
Public Property | InvalidReason | Gets or sets the reason the license was not valid. If Validate returns true this is an empty string.
Public Property | IsEmbedded | Gets or sets a value that indicates if the license was loaded from an embedded resource rather then an external .LIC file.
Public Property | IsReadOnly | Gets a value that indicates if the current license is read only.
Public Property | IssuerUrl | Gets or sets the URL to the company that issued the license.
static (Shared in Visual Basic) | IsTerminalServices | Gets a value that indicates if the current session is running under terminal services.
Public Property | IsTimeSensitive | Gets a value that indicates if the license contians time sensitive data and the clock should be protected.
static (Shared in Visual Basic) | IsWebRequest | Gets a value indicating if a web request/HttpContext is currently available.
static (Shared in Visual Basic) | KeyFolder | Gets the folder where the license keys are located as defined in the application's config file.
Public Property | LicensedType | Gets the Type the license was/will be granted to.
static (Shared in Visual Basic) | LicenseFolders | Gets a collection of folders where the licenses are located as defined in the application's config file.
Public Property | LicenseKey | Overridden. Overrides LicenseKey.
Public Property | LicensePack | Gets the ExtendedLicensePack that owns the license.
Public Property | MaximumSerialNumberSeed | Gets or sets the maximum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.
Public Property | MetaValues | Gets a collection of arbitrary values to store with the license. These values are not protected and may be changed without affecting the validity of the license. Use for storing volitle information and other unsecured information.
Public Property | MinimumSerialNumberSeed | Gets or sets the minimum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.
Public Property | Organization | Gets or sets the name of the organization that the license is issued to.
Public Property | PersistantState | Gets a reference to per-license specific state that works independent of any underlying state schemes. This is used to safely track values that should be kept in memory even when a license is reloaded from disk.
Public Property | PublicKey | Gets a reference to the LicenseSigningKey being used to validate the license.
Public Property | SerialNumber | Gets or sets the value of the absolute serial number.
static (Shared in Visual Basic) | SharedFolder | Gets or sets the path to the shared license folder.
Public Property | Signature | Gets or sets the signature used to validate the license data.
Public Property | SurrogateLicensePack | Gets or sets a surrogate license pack to use if validation of this license fails.
Public Property | Tag | Gets or sets an arbitrary piece of data to track with the license. This is a "cheap" way of extending the license scheme by allowing you to store any kind of additional data that can be saved as a string to the license.
static (Shared in Visual Basic) | TemplateFolder | Gets the folder where the license templates are located as defined in the application's config file.
Public Property | Type | Gets or sets an application/product specific description of the type of license. For examples "designer", "single user", "non-profit", etc. This can often be used a reference to the primary key in a database, such as a SKU, for the product that the license represents.
Public Property | UnlockBySerial | Gets or sets a value that indicates if the user must provide a valid serial number to fully unlock the license.
Public Property | UnlockedLicense | Gets or sets the ExtendedLicense that was unlocked by the registration process.
Public Property | User | Gets or sets the value of the user as it should appear on screen.
Public Property | Values | Gets a collection of arbitrary values to store with the license.
Public Property | Version | Gets or sets the version of the licensing scheme used.
Public Property | XmlString | Gets or sets the contents of the license as an XML string fragment.
Top

Public Methods

 | Name | Description
Public Method | ComponentsFromString | Fills the components collection from a comma separated list.
Public Method | ComponentsToString | Gets the components collection as a comma separated list.
Public Method | Dispose | Releases any managed or unmanaged resources.
static (Shared in Visual Basic) | FromXml | Overloaded. Creates a new ExtendedLicense from an XML fragment.
Public Method | FromXmlString | Loads the contents of the license from an XML string.
static (Shared in Visual Basic) | GetFullPath | Utility function that gets the full path of a folder relative to the "application root" of the current application.
Public Method | GetShortAssemblyName | Gets the short name of the assembly. If the AssemblyName property contains version and key information, only the assembly name is returned.
Public Method | GetSigningKey | Overloaded. Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.
Public Method | GetValue | Gets the first value from the Values collection with the given key and if not found returns the default value instead.
Public Method | LoadFromXml | Loads the contents of a license from an XmlNode.
Public Method | SaveToXml | Saves the contents of the ExtendedLicense to the given XmlNode.
Public Method | ToXmlString | Saves the contents of the license to an XML string.
Top

See Also

Reference

ExtendedLicense Class
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicense Constructor
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ExtendedLicense Constructor

Initializes a new instance of the ExtendedLicense class.

Overload List

Overload | Description
ExtendedLicense Constructor() | Initializes a new instance of the ExtendedLicense class.
ExtendedLicense Constructor(XmlNode) | Initializes a new instance of the ExtendedLicense class with the values of the given XmlNode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicense Constructor()
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > ExtendedLicense Constructor : ExtendedLicense Constructor()

Initializes a new instance of the ExtendedLicense class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense()
C#
public ExtendedLicense()
Managed Extensions for C++
public: ExtendedLicense();
C++/CLI
public:
ExtendedLicense();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicense Constructor(XmlNode)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > ExtendedLicense Constructor : ExtendedLicense Constructor(XmlNode)

node
The XmlNode of the ExtendedLicensePack to load the license properties from.
Initializes a new instance of the ExtendedLicense class with the values of the given XmlNode.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal node As XmlNode _
)
Visual Basic (Usage) Copy Code
Dim node As XmlNode

Dim instance As ExtendedLicense(node)
C#
public ExtendedLicense(
   XmlNode node
)
Managed Extensions for C++
public: ExtendedLicense(
   XmlNode node
)
C++/CLI
public:
ExtendedLicense(
   XmlNode node
)

Parameters

node
The XmlNode of the ExtendedLicensePack to load the license properties from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicense Class Methods
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

For a list of all members of this type, see ExtendedLicense members.

Public Methods

 | Name | Description
Public Method | ComponentsFromString | Fills the components collection from a comma separated list.
Public Method | ComponentsToString | Gets the components collection as a comma separated list.
Public Method | Dispose | Releases any managed or unmanaged resources.
static (Shared in Visual Basic) | FromXml | Overloaded. Creates a new ExtendedLicense from an XML fragment.
Public Method | FromXmlString | Loads the contents of the license from an XML string.
static (Shared in Visual Basic) | GetFullPath | Utility function that gets the full path of a folder relative to the "application root" of the current application.
Public Method | GetShortAssemblyName | Gets the short name of the assembly. If the AssemblyName property contains version and key information, only the assembly name is returned.
Public Method | GetSigningKey | Overloaded. Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.
Public Method | GetValue | Gets the first value from the Values collection with the given key and if not found returns the default value instead.
Public Method | LoadFromXml | Loads the contents of a license from an XmlNode.
Public Method | SaveToXml | Saves the contents of the ExtendedLicense to the given XmlNode.
Public Method | ToXmlString | Saves the contents of the license to an XML string.
Top

See Also

Reference

ExtendedLicense Class
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ComponentsFromString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ComponentsFromString Method

components
Comma separated list of components.
Fills the components collection from a comma separated list.

Syntax

Visual Basic (Declaration)
Public Sub ComponentsFromString( _
   ByVal components As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim components As String

instance.ComponentsFromString(components)
C#
public void ComponentsFromString(
   string components
)
Managed Extensions for C++
public: void ComponentsFromString(
   string* components
)
C++/CLI
public:
void ComponentsFromString(
   String^ components
)

Parameters

components
Comma separated list of components.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ComponentsToString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ComponentsToString Method

Gets the components collection as a comma separated list.

Syntax

Visual Basic (Declaration)
Public Function ComponentsToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

value = instance.ComponentsToString()
C#
public string ComponentsToString()
Managed Extensions for C++
public: string* ComponentsToString();
C++/CLI
public:
String^ ComponentsToString();

Return Value

Returns the list of components.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Dispose Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Dispose Method

Releases any managed or unmanaged resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
FromXml Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : FromXml Method

Creates a new ExtendedLicense from an XML fragment.

Overload List

Overload | Description
FromXml(String) | Creates a new ExtendedLicense from an XML fragment.
FromXml(XmlNode) | Creates a new ExtendedLicense from an XML fragment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
FromXml(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > FromXml Method : FromXml(String) Method

xml
The xml to create the license from.
Creates a new ExtendedLicense from an XML fragment.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromXml( _
   ByVal xml As String _
) As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim xml As String
Dim value As ExtendedLicense

value = ExtendedLicense.FromXml(xml)
C#
public static ExtendedLicense FromXml(
   string xml
)
Managed Extensions for C++
public: static ExtendedLicense* FromXml(
   string* xml
)
C++/CLI
public:
static ExtendedLicense^ FromXml(
   String^ xml
)

Parameters

xml
The xml to create the license from.

Return Value

Returns the newly created extended license.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
FromXml(XmlNode) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > FromXml Method : FromXml(XmlNode) Method

xml
The xml to create the license from.
Creates a new ExtendedLicense from an XML fragment.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromXml( _
   ByVal xml As XmlNode _
) As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim xml As XmlNode
Dim value As ExtendedLicense

value = ExtendedLicense.FromXml(xml)
C#
public static ExtendedLicense FromXml(
   XmlNode xml
)
Managed Extensions for C++
public: static ExtendedLicense* FromXml(
   XmlNode xml
)
C++/CLI
public:
static ExtendedLicense^ FromXml(
   XmlNode xml
)

Parameters

xml
The xml to create the license from.

Return Value

Returns the newly created extended license.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : FromXmlString Method

xml
The XML string to load from.
Loads the contents of the license from an XML string.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
The XML string to load from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetFullPath Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : GetFullPath Method

path
The path to resolve to a complete path.
Utility function that gets the full path of a folder relative to the "application root" of the current application.

Syntax

Visual Basic (Declaration)
Public Shared Function GetFullPath( _
   ByVal path As String _
) As String
Visual Basic (Usage) Copy Code
Dim path As String
Dim value As String

value = ExtendedLicense.GetFullPath(path)
C#
public static string GetFullPath(
   string path
)
Managed Extensions for C++
public: static string* GetFullPath(
   string* path
)
C++/CLI
public:
static String^ GetFullPath(
   String^ path
)

Parameters

path
The path to resolve to a complete path.

Remarks

For console and forms applications the base folder is the folder of the entry executable. For Web sites the base folder is the root of the site...rather than the \bin folder.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetShortAssemblyName Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : GetShortAssemblyName Method

Gets the short name of the assembly. If the AssemblyName property contains version and key information, only the assembly name is returned.

Syntax

Visual Basic (Declaration)
Public Function GetShortAssemblyName() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

value = instance.GetShortAssemblyName()
C#
public string GetShortAssemblyName()
Managed Extensions for C++
public: string* GetShortAssemblyName();
C++/CLI
public:
String^ GetShortAssemblyName();

Return Value

Returns the short version of the AssemblyName if set, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetSigningKey Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : GetSigningKey Method

Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.

Overload List

Overload | Description
GetSigningKey(String) | Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.
GetSigningKey() | Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetSigningKey(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > GetSigningKey Method : GetSigningKey(String) Method

folder
The folder to look for keys. If null KeyFolder is used.
Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetSigningKey( _
   ByVal folder As String _
) As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim folder As String
Dim value As LicenseSigningKey

value = instance.GetSigningKey(folder)
C#
public LicenseSigningKey GetSigningKey(
   string folder
)
Managed Extensions for C++
public: LicenseSigningKey* GetSigningKey(
   string* folder
)
C++/CLI
public:
LicenseSigningKey^ GetSigningKey(
   String^ folder
)

Parameters

folder
The folder to look for keys. If null KeyFolder is used.

Return Value

Returns the key needed to sign the license if found, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetSigningKey() Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class > GetSigningKey Method : GetSigningKey() Method

Gets the LicenseSigningKey needed to sign the license. AssemblyName must contain a valid name for this to return a value.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetSigningKey() As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As LicenseSigningKey

value = instance.GetSigningKey()
C#
public LicenseSigningKey GetSigningKey()
Managed Extensions for C++
public: LicenseSigningKey* GetSigningKey();
C++/CLI
public:
LicenseSigningKey^ GetSigningKey();

Return Value

Returns the key needed to sign the license if found, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetValue Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : GetValue Method

key
The key of the value to return.
defaultValue
The default value if not found.
Gets the first value from the Values collection with the given key and if not found returns the default value instead.

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal key As String, _
   ByVal defaultValue As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim key As String
Dim defaultValue As String
Dim value As String

value = instance.GetValue(key, defaultValue)
C#
public string GetValue(
   string key,
   string defaultValue
)
Managed Extensions for C++
public: string* GetValue(
   string* key,
   string* defaultValue
)
C++/CLI
public:
String^ GetValue(
   String^ key,
   String^ defaultValue
)

Parameters

key
The key of the value to return.
defaultValue
The default value if not found.

Return Value

Returns the first value with the given key if found, otherwise the default value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LoadFromXml Method

node
An XmlNode containing the license data.
Loads the contents of a license from an XmlNode.

Syntax

Visual Basic (Declaration)
Public Function LoadFromXml( _
   ByVal node As XmlNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim node As XmlNode
Dim value As Boolean

value = instance.LoadFromXml(node)
C#
public bool LoadFromXml(
   XmlNode node
)
Managed Extensions for C++
public: bool LoadFromXml(
   XmlNode node
)
C++/CLI
public:
bool LoadFromXml(
   XmlNode node
)

Parameters

node
An XmlNode containing the license data.

Return Value

Returns true if the load was successful, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : SaveToXml Method

parent
The parent XmlNode.
Saves the contents of the ExtendedLicense to the given XmlNode.

Syntax

Visual Basic (Declaration)
Public Function SaveToXml( _
   ByVal parent As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim parent As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parent)
C#
public XmlNode SaveToXml(
   XmlNode parent
)
Managed Extensions for C++
public: XmlNode SaveToXml(
   XmlNode parent
)
C++/CLI
public:
XmlNode SaveToXml(
   XmlNode parent
)

Parameters

parent
The parent XmlNode.

Return Value

Returns the root node of the saved license.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ToXmlString Method

Saves the contents of the license to an XML string.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

value = instance.ToXmlString()
C#
public string ToXmlString()
Managed Extensions for C++
public: string* ToXmlString();
C++/CLI
public:
String^ ToXmlString();

Return Value

The saved XML.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicense Class Properties
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

For a list of all members of this type, see ExtendedLicense members.

Public Properties

 | Name | Description
Public Property | AbsoluteOrganization | Gets or sets the name of the organization that the license is issued to.
Public Property | AbsoluteSerialNumber | Gets or sets the serial number for the license.
Public Property | AbsoluteUser | Gets or sets the name of the user that the license is issued to.
Public Property | AcceptedSerialNumberSizes | Gets or sets the serial number sizes that can be used to unlock the license. If a valid serial number of a different size is used, license validation will fail.
Public Property | AssemblyName | Gets or sets the name of the assembly used to sign the license originally. The value of this property is for reference only and has no impact on the validation of a license.
Public Property | Components | Gets the collection of component names that the license applies to.
static (Shared in Visual Basic) | ConnectionString | Gets the default database connection string for licensing components.
static (Shared in Visual Basic) | EmulateVersion | Gets a value that determines the release version that XHEO|Licensing should emulate.
Public Property | Expires | Gets or sets the expiration date for the license.
static (Shared in Visual Basic) | IisIsAvailable | Gets a value that indicates if IIS is installed and available on the machine. If false then HttpContext should not be checked because it will throw an exception.
Public Property | InvalidReason | Gets or sets the reason the license was not valid. If Validate returns true this is an empty string.
Public Property | IsEmbedded | Gets or sets a value that indicates if the license was loaded from an embedded resource rather then an external .LIC file.
Public Property | IsReadOnly | Gets a value that indicates if the current license is read only.
Public Property | IssuerUrl | Gets or sets the URL to the company that issued the license.
static (Shared in Visual Basic) | IsTerminalServices | Gets a value that indicates if the current session is running under terminal services.
Public Property | IsTimeSensitive | Gets a value that indicates if the license contians time sensitive data and the clock should be protected.
static (Shared in Visual Basic) | IsWebRequest | Gets a value indicating if a web request/HttpContext is currently available.
static (Shared in Visual Basic) | KeyFolder | Gets the folder where the license keys are located as defined in the application's config file.
Public Property | LicensedType | Gets the Type the license was/will be granted to.
static (Shared in Visual Basic) | LicenseFolders | Gets a collection of folders where the licenses are located as defined in the application's config file.
Public Property | LicenseKey | Overridden. Overrides LicenseKey.
Public Property | LicensePack | Gets the ExtendedLicensePack that owns the license.
Public Property | MaximumSerialNumberSeed | Gets or sets the maximum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.
Public Property | MetaValues | Gets a collection of arbitrary values to store with the license. These values are not protected and may be changed without affecting the validity of the license. Use for storing volitle information and other unsecured information.
Public Property | MinimumSerialNumberSeed | Gets or sets the minimum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.
Public Property | Organization | Gets or sets the name of the organization that the license is issued to.
Public Property | PersistantState | Gets a reference to per-license specific state that works independent of any underlying state schemes. This is used to safely track values that should be kept in memory even when a license is reloaded from disk.
Public Property | PublicKey | Gets a reference to the LicenseSigningKey being used to validate the license.
Public Property | SerialNumber | Gets or sets the value of the absolute serial number.
static (Shared in Visual Basic) | SharedFolder | Gets or sets the path to the shared license folder.
Public Property | Signature | Gets or sets the signature used to validate the license data.
Public Property | SurrogateLicensePack | Gets or sets a surrogate license pack to use if validation of this license fails.
Public Property | Tag | Gets or sets an arbitrary piece of data to track with the license. This is a "cheap" way of extending the license scheme by allowing you to store any kind of additional data that can be saved as a string to the license.
static (Shared in Visual Basic) | TemplateFolder | Gets the folder where the license templates are located as defined in the application's config file.
Public Property | Type | Gets or sets an application/product specific description of the type of license. For examples "designer", "single user", "non-profit", etc. This can often be used a reference to the primary key in a database, such as a SKU, for the product that the license represents.
Public Property | UnlockBySerial | Gets or sets a value that indicates if the user must provide a valid serial number to fully unlock the license.
Public Property | UnlockedLicense | Gets or sets the ExtendedLicense that was unlocked by the registration process.
Public Property | User | Gets or sets the value of the user as it should appear on screen.
Public Property | Values | Gets a collection of arbitrary values to store with the license.
Public Property | Version | Gets or sets the version of the licensing scheme used.
Public Property | XmlString | Gets or sets the contents of the license as an XML string fragment.
Top

See Also

Reference

ExtendedLicense Class
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
AbsoluteOrganization Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AbsoluteOrganization Property

Gets or sets the name of the organization that the license is issued to.

Syntax

Visual Basic (Declaration)
Public Property AbsoluteOrganization As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.AbsoluteOrganization = value

value = instance.AbsoluteOrganization
C#
public string AbsoluteOrganization {get; set;}
Managed Extensions for C++
public: __property string* get_AbsoluteOrganization();
public: __property void set_AbsoluteOrganization(
   string* value
);
C++/CLI
public:
property String^ AbsoluteOrganization {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
AbsoluteSerialNumber Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AbsoluteSerialNumber Property

Gets or sets the serial number for the license.

Syntax

Visual Basic (Declaration)
Public Property AbsoluteSerialNumber As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.AbsoluteSerialNumber = value

value = instance.AbsoluteSerialNumber
C#
public string AbsoluteSerialNumber {get; set;}
Managed Extensions for C++
public: __property string* get_AbsoluteSerialNumber();
public: __property void set_AbsoluteSerialNumber(
   string* value
);
C++/CLI
public:
property String^ AbsoluteSerialNumber {
   String^ get();
   void set (String^ value);
}

Remarks

Generally the value of the serial number property is completely arbitrary and can contain any value. However the values should be treated as a primary key that uniquely identifies the license. Generally this is used to reference licenses in a back-end system and to uniquely identify the license.

By default a random GUID is generated for the serial number. You can later change it to any desired value.

(Version 1.2+) When using Unlock by Serial to unlock licenses, the Absolute Serial Number is used to match user's serial numbers to licenses.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
AbsoluteUser Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AbsoluteUser Property

Gets or sets the name of the user that the license is issued to.

Syntax

Visual Basic (Declaration)
Public Property AbsoluteUser As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.AbsoluteUser = value

value = instance.AbsoluteUser
C#
public string AbsoluteUser {get; set;}
Managed Extensions for C++
public: __property string* get_AbsoluteUser();
public: __property void set_AbsoluteUser(
   string* value
);
C++/CLI
public:
property String^ AbsoluteUser {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
AcceptedSerialNumberSizes Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AcceptedSerialNumberSizes Property

Gets or sets the serial number sizes that can be used to unlock the license. If a valid serial number of a different size is used, license validation will fail.

Syntax

Visual Basic (Declaration)
Public Property AcceptedSerialNumberSizes As SerialNumberSizes
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As SerialNumberSizes

instance.AcceptedSerialNumberSizes = value

value = instance.AcceptedSerialNumberSizes
C#
public SerialNumberSizes AcceptedSerialNumberSizes {get; set;}
Managed Extensions for C++
public: __property SerialNumberSizes get_AcceptedSerialNumberSizes();
public: __property void set_AcceptedSerialNumberSizes(
   SerialNumberSizes value
);
C++/CLI
public:
property SerialNumberSizes AcceptedSerialNumberSizes {
   SerialNumberSizes get();
   void set (SerialNumberSizes value);
}

Remarks

It is recommended that you only allow the largest size you will reasonably expect to issue to your customers. A malicious user needs only to crack the smallest acceptable size to gain access to the license. The Recommended sizes are Medium (for regular serial numbers) and Huge (for activation keys).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
AssemblyName Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : AssemblyName Property

Gets or sets the name of the assembly used to sign the license originally. The value of this property is for reference only and has no impact on the validation of a license.

Syntax

Visual Basic (Declaration)
Public Property AssemblyName As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.AssemblyName = value

value = instance.AssemblyName
C#
public string AssemblyName {get; set;}
Managed Extensions for C++
public: __property string* get_AssemblyName();
public: __property void set_AssemblyName(
   string* value
);
C++/CLI
public:
property String^ AssemblyName {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Components Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Components Property

Gets the collection of component names that the license applies to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Components As StringCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As StringCollection

value = instance.Components
C#
public StringCollection Components {get;}
Managed Extensions for C++
public: __property StringCollection get_Components();
C++/CLI
public:
property StringCollection Components {
   StringCollection get();
}

Remarks

Each component name in the collection should be the FullName of the Type including the namespace. When the license is read only then a copy of the collection is returned and any changes to the collection are lost.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ConnectionString Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ConnectionString Property

Gets the default database connection string for licensing components.

Syntax

Visual Basic (Declaration)
Public Shared Property ConnectionString As String
Visual Basic (Usage) Copy Code
Dim value As String

ExtendedLicense.ConnectionString = value

value = ExtendedLicense.ConnectionString
C#
public static string ConnectionString {get; set;}
Managed Extensions for C++
public: __property static string* get_ConnectionString();
public: __property static void set_ConnectionString(
   string* value
);
C++/CLI
public:
static property String^ ConnectionString {
   String^ get();
   void set (String^ value);
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.ConnectionString" value="server=localhost;catalog=Northwind" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="ConnectionString" value="server=localhost;catalog=Northwind" />
    </Licensing>
</Xheo>
</configuration>

Remarks

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.ConnectionString and set it to the path where keys are stored on your machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
EmulateVersion Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : EmulateVersion Property

Gets a value that determines the release version that XHEO|Licensing should emulate.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property EmulateVersion As Version
Visual Basic (Usage) Copy Code
Dim value As Version

value = ExtendedLicense.EmulateVersion
C#
public static Version EmulateVersion {get;}
Managed Extensions for C++
public: __property static Version* get_EmulateVersion();
C++/CLI
public:
static property Version^ EmulateVersion {
   Version^ get();
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.EmulateVersion" value="1.1" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="EmulateVersion" value="1.1" />
    </Licensing>
</Xheo>
</configuration>

Remarks

Use this value when migrating a solution from an earlier version to a newer one so that licenses generated with the new assembly will use the previous version until you have fully upgraded all dependent assemblies.

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.EmulateVersion and set it to either true or false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Expires Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Expires Property

Gets or sets the expiration date for the license.

Syntax

Visual Basic (Declaration)
Public Property Expires As Date
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Date

instance.Expires = value

value = instance.Expires
C#
public DateTime Expires {get; set;}
Managed Extensions for C++
public: __property DateTime get_Expires();
public: __property void set_Expires(
   DateTime value
);
C++/CLI
public:
property DateTime Expires {
   DateTime get();
   void set (DateTime value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IisIsAvailable Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IisIsAvailable Property

Gets a value that indicates if IIS is installed and available on the machine. If false then HttpContext should not be checked because it will throw an exception.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IisIsAvailable As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = ExtendedLicense.IisIsAvailable
C#
public static bool IisIsAvailable {get;}
Managed Extensions for C++
public: __property static bool get_IisIsAvailable();
C++/CLI
public:
static property bool IisIsAvailable {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
InvalidReason Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : InvalidReason Property

Gets or sets the reason the license was not valid. If Validate returns true this is an empty string.

Syntax

Visual Basic (Declaration)
Public Property InvalidReason As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.InvalidReason = value

value = instance.InvalidReason
C#
public string InvalidReason {get; set;}
Managed Extensions for C++
public: __property string* get_InvalidReason();
public: __property void set_InvalidReason(
   string* value
);
C++/CLI
public:
property String^ InvalidReason {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IsEmbedded Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsEmbedded Property

Gets or sets a value that indicates if the license was loaded from an embedded resource rather then an external .LIC file.

Syntax

Visual Basic (Declaration)
Public Property IsEmbedded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Boolean

instance.IsEmbedded = value

value = instance.IsEmbedded
C#
public bool IsEmbedded {get; set;}
Managed Extensions for C++
public: __property bool get_IsEmbedded();
public: __property void set_IsEmbedded(
   bool value
);
C++/CLI
public:
property bool IsEmbedded {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IsReadOnly Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsReadOnly Property

Gets a value that indicates if the current license is read only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IssuerUrl Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IssuerUrl Property

Gets or sets the URL to the company that issued the license.

Syntax

Visual Basic (Declaration)
Public Property IssuerUrl As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.IssuerUrl = value

value = instance.IssuerUrl
C#
public string IssuerUrl {get; set;}
Managed Extensions for C++
public: __property string* get_IssuerUrl();
public: __property void set_IssuerUrl(
   string* value
);
C++/CLI
public:
property String^ IssuerUrl {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IsTerminalServices Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsTerminalServices Property

Gets a value that indicates if the current session is running under terminal services.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IsTerminalServices As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = ExtendedLicense.IsTerminalServices
C#
public static bool IsTerminalServices {get;}
Managed Extensions for C++
public: __property static bool get_IsTerminalServices();
C++/CLI
public:
static property bool IsTerminalServices {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IsTimeSensitive Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsTimeSensitive Property

Gets a value that indicates if the license contians time sensitive data and the clock should be protected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsTimeSensitive As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Boolean

value = instance.IsTimeSensitive
C#
public bool IsTimeSensitive {get;}
Managed Extensions for C++
public: __property bool get_IsTimeSensitive();
C++/CLI
public:
property bool IsTimeSensitive {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IsWebRequest Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : IsWebRequest Property

Gets a value indicating if a web request/HttpContext is currently available.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IsWebRequest As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = ExtendedLicense.IsWebRequest
C#
public static bool IsWebRequest {get;}
Managed Extensions for C++
public: __property static bool get_IsWebRequest();
C++/CLI
public:
static property bool IsWebRequest {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
KeyFolder Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : KeyFolder Property

Gets the folder where the license keys are located as defined in the application's config file.

Syntax

Visual Basic (Declaration)
Public Shared Property KeyFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

ExtendedLicense.KeyFolder = value

value = ExtendedLicense.KeyFolder
C#
public static string KeyFolder {get; set;}
Managed Extensions for C++
public: __property static string* get_KeyFolder();
public: __property static void set_KeyFolder(
   string* value
);
C++/CLI
public:
static property String^ KeyFolder {
   String^ get();
   void set (String^ value);
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.KeyFolder" value="X:\Keys" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="KeyFolder" value="D:\aaa" />
    </Licensing>
</Xheo>
</configuration>

Remarks

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.KeyFolder and set it to the path where keys are stored on your machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LicensedType Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LicensedType Property

Gets the Type the license was/will be granted to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LicensedType As Type
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Type

value = instance.LicensedType
C#
public Type LicensedType {get;}
Managed Extensions for C++
public: __property Type* get_LicensedType();
C++/CLI
public:
property Type^ LicensedType {
   Type^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LicenseFolders Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LicenseFolders Property

Gets a collection of folders where the licenses are located as defined in the application's config file.

Syntax

Visual Basic (Declaration)
Public Shared Property LicenseFolders As String()
Visual Basic (Usage) Copy Code
Dim value() As String

ExtendedLicense.LicenseFolders = value

value = ExtendedLicense.LicenseFolders
C#
public static string[] LicenseFolders {get; set;}
Managed Extensions for C++
public: __property static string*[] get_LicenseFolders();
public: __property static void set_LicenseFolders(
   string*[] value
);
C++/CLI
public:
static property array<String^> LicenseFolders {
   array<String^> get();
   void set (String^array<value> value);
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.LicenseFolder" value="X:\Folder1" />
    <add key="Xheo.Licensing.LicenseFolder" value="X:\Folder2" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="Xheo.Licensing.Configuration.NameValueSectionHandler, System, Version=1.1.0.0, Culture=neutral, PublicKeyToken=798276055709c98a" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="LicenseFolder" value="D:\aaa" />
        <add key="LicenseFolder" value="C:\other" />
    </Licensing>
</Xheo>
</configuration>

Remarks

Use this setting when you install XHEO|Licensing or licensed components into the GAC, or when using a shared install in a hosting environment.

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.LicenseFolders and set it to the path where keys are stored on your machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LicenseKey Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LicenseKey Property

Overrides LicenseKey.

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable ReadOnly Property LicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

value = instance.LicenseKey
C#
public override string LicenseKey {get;}
Managed Extensions for C++
public: __property string* get_LicenseKey()override ;
C++/CLI
public:
property String^ LicenseKey override {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LicensePack Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : LicensePack Property

Gets the ExtendedLicensePack that owns the license.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LicensePack As ExtendedLicensePack
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As ExtendedLicensePack

value = instance.LicensePack
C#
public ExtendedLicensePack LicensePack {get;}
Managed Extensions for C++
public: __property ExtendedLicensePack* get_LicensePack();
C++/CLI
public:
property ExtendedLicensePack^ LicensePack {
   ExtendedLicensePack^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MaximumSerialNumberSeed Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : MaximumSerialNumberSeed Property

Gets or sets the maximum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.

Syntax

Visual Basic (Declaration)
Public Property MaximumSerialNumberSeed As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Integer

instance.MaximumSerialNumberSeed = value

value = instance.MaximumSerialNumberSeed
C#
public int MaximumSerialNumberSeed {get; set;}
Managed Extensions for C++
public: __property int get_MaximumSerialNumberSeed();
public: __property void set_MaximumSerialNumberSeed(
   int value
);
C++/CLI
public:
property int MaximumSerialNumberSeed {
   int get();
   void set (int value);
}

Remarks

Use MinimumSerialNumberSeed and MaximumSerialNumberSeed to partition serial numbers to various resellers or vendors. You can then use this to determine which vendor sold your product in case of support requests.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MetaValues Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : MetaValues Property

Gets a collection of arbitrary values to store with the license. These values are not protected and may be changed without affecting the validity of the license. Use for storing volitle information and other unsecured information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetaValues As LicenseValuesCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As LicenseValuesCollection

value = instance.MetaValues
C#
public LicenseValuesCollection MetaValues {get;}
Managed Extensions for C++
public: __property LicenseValuesCollection* get_MetaValues();
C++/CLI
public:
property LicenseValuesCollection^ MetaValues {
   LicenseValuesCollection^ get();
}

Remarks

The MetaValues collection will be persisted with a license. However any changes to the meta values collection after the license is signed will not affect the validity of the signature. Use this to track volitle information that need not be secured and is safe for the user to change.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MinimumSerialNumberSeed Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : MinimumSerialNumberSeed Property

Gets or sets the minimum serial number seed value accepted by this license. Use to partition serial number seeds to various vendors.

Syntax

Visual Basic (Declaration)
Public Property MinimumSerialNumberSeed As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Integer

instance.MinimumSerialNumberSeed = value

value = instance.MinimumSerialNumberSeed
C#
public int MinimumSerialNumberSeed {get; set;}
Managed Extensions for C++
public: __property int get_MinimumSerialNumberSeed();
public: __property void set_MinimumSerialNumberSeed(
   int value
);
C++/CLI
public:
property int MinimumSerialNumberSeed {
   int get();
   void set (int value);
}

Remarks

Use MinimumSerialNumberSeed and MaximumSerialNumberSeed to partition serial numbers to various resellers or vendors. You can then use this to determine which vendor sold your product in case of support requests.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Organization Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Organization Property

Gets or sets the name of the organization that the license is issued to.

Syntax

Visual Basic (Declaration)
Public Property Organization As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.Organization = value

value = instance.Organization
C#
public string Organization {get; set;}
Managed Extensions for C++
public: __property string* get_Organization();
public: __property void set_Organization(
   string* value
);
C++/CLI
public:
property String^ Organization {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
PersistantState Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : PersistantState Property

Gets a reference to per-license specific state that works independent of any underlying state schemes. This is used to safely track values that should be kept in memory even when a license is reloaded from disk.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PersistantState As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Hashtable

value = instance.PersistantState
C#
public Hashtable PersistantState {get;}
Managed Extensions for C++
public: __property Hashtable* get_PersistantState();
C++/CLI
public:
property Hashtable^ PersistantState {
   Hashtable^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
PublicKey Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : PublicKey Property

Gets a reference to the LicenseSigningKey being used to validate the license.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PublicKey As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As LicenseSigningKey

value = instance.PublicKey
C#
public LicenseSigningKey PublicKey {get;}
Managed Extensions for C++
public: __property LicenseSigningKey* get_PublicKey();
C++/CLI
public:
property LicenseSigningKey^ PublicKey {
   LicenseSigningKey^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SerialNumber Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : SerialNumber Property

Gets or sets the value of the absolute serial number.

Syntax

Visual Basic (Declaration)
Public Property SerialNumber As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.SerialNumber = value

value = instance.SerialNumber
C#
public string SerialNumber {get; set;}
Managed Extensions for C++
public: __property string* get_SerialNumber();
public: __property void set_SerialNumber(
   string* value
);
C++/CLI
public:
property String^ SerialNumber {
   String^ get();
   void set (String^ value);
}

Remarks

The absolute serial number is used in unlocking a license by serial number. The absolute serial number must begin with the SerialNumber for the license.
Warning This value is unprotected and can be changed by the client. Do not assume the value is valid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SharedFolder Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : SharedFolder Property

Gets or sets the path to the shared license folder.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SharedFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

value = ExtendedLicense.SharedFolder
C#
public static string SharedFolder {get;}
Managed Extensions for C++
public: __property static string* get_SharedFolder();
C++/CLI
public:
static property String^ SharedFolder {
   String^ get();
}

Remarks

The shared license folder is a location on the client machine where all XHEO|Licensing protected applications can look for licenses. This helps with shared hosting environments and large applications that may include multiple assemblies, some in the GAC. Rather then having .LIC files spread over the machine they can be located into a single location.

This is a machine wide setting. The value of this property should be considered configured by the machine's administrator. You should not change it as it will effect all installed applications protected with XHEO|Licensing.

The folder location by default is [Common Files]\Xheo\SharedLicenses. This can be configured per machine or per user in the registry at HKLM or HKLU\Software\Xheo\Licensing\SharedLicenseFolder.

See LicenseFolders for settings you can apply to the application's config or machine.config file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members
LicenseFolders Property


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Signature Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Signature Property

Gets or sets the signature used to validate the license data.

Syntax

Visual Basic (Declaration)
Public Property Signature As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.Signature = value

value = instance.Signature
C#
public string Signature {get; set;}
Managed Extensions for C++
public: __property string* get_Signature();
public: __property void set_Signature(
   string* value
);
C++/CLI
public:
property String^ Signature {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SurrogateLicensePack Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : SurrogateLicensePack Property

Gets or sets a surrogate license pack to use if validation of this license fails.

Syntax

Visual Basic (Declaration)
Public Property SurrogateLicensePack As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.SurrogateLicensePack = value

value = instance.SurrogateLicensePack
C#
public string SurrogateLicensePack {get; set;}
Managed Extensions for C++
public: __property string* get_SurrogateLicensePack();
public: __property void set_SurrogateLicensePack(
   string* value
);
C++/CLI
public:
property String^ SurrogateLicensePack {
   String^ get();
   void set (String^ value);
}

Remarks

For limits that alter the current license, or download new licenses you can set this property so that the new or altered license pack is used instead. When Validate is called on the current license, this is initially set to null. If Validate returns false, and this is not null then the license pack indicated in this property, if it contains a license, is used instead. If a surrogate license pack also defines a surrogate license, it will not be checked, the license provider only checks one level deep.

Generally you shouldn't set this to a license pack containing license with with a Trial limit or GUI limit because it will interfere with the optimal license selection of the license provider.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Tag Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Tag Property

Gets or sets an arbitrary piece of data to track with the license. This is a "cheap" way of extending the license scheme by allowing you to store any kind of additional data that can be saved as a string to the license.

Syntax

Visual Basic (Declaration)
Public Property Tag As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.Tag = value

value = instance.Tag
C#
public string Tag {get; set;}
Managed Extensions for C++
public: __property string* get_Tag();
public: __property void set_Tag(
   string* value
);
C++/CLI
public:
property String^ Tag {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
TemplateFolder Property
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : TemplateFolder Property

Gets the folder where the license templates are located as defined in the application's config file.

Syntax

Visual Basic (Declaration)
Public Shared Property TemplateFolder As String
Visual Basic (Usage) Copy Code
Dim value As String

ExtendedLicense.TemplateFolder = value

value = ExtendedLicense.TemplateFolder
C#
public static string TemplateFolder {get; set;}
Managed Extensions for C++
public: __property static string* get_TemplateFolder();
public: __property static void set_TemplateFolder(
   string* value
);
C++/CLI
public:
static property String^ TemplateFolder {
   String^ get();
   void set (String^ value);
}

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.TemplateFolder" value="X:\Templates" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="TemplateFolder" value="D:\aaa\Templates" />
    </Licensing>
</Xheo>
</configuration>

Remarks

You can configure the value of this property in your application's configuration file. In the appSettings section add an entry for Xheo.Licensing.TemplateFolder and set it to the path where keys are stored on your machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Type Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Type Property

Gets or sets an application/product specific description of the type of license. For examples "designer", "single user", "non-profit", etc. This can often be used a reference to the primary key in a database, such as a SKU, for the product that the license represents.

Syntax

Visual Basic (Declaration)
Public Property Type As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.Type = value

value = instance.Type
C#
public string Type {get; set;}
Managed Extensions for C++
public: __property string* get_Type();
public: __property void set_Type(
   string* value
);
C++/CLI
public:
property String^ Type {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
UnlockBySerial Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : UnlockBySerial Property

Gets or sets a value that indicates if the user must provide a valid serial number to fully unlock the license.

Syntax

Visual Basic (Declaration)
Public Property UnlockBySerial As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Boolean

instance.UnlockBySerial = value

value = instance.UnlockBySerial
C#
public bool UnlockBySerial {get; set;}
Managed Extensions for C++
public: __property bool get_UnlockBySerial();
public: __property void set_UnlockBySerial(
   bool value
);
C++/CLI
public:
property bool UnlockBySerial {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
UnlockedLicense Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : UnlockedLicense Property

Gets or sets the ExtendedLicense that was unlocked by the registration process.

Syntax

Visual Basic (Declaration)
Public Property UnlockedLicense As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As ExtendedLicense

instance.UnlockedLicense = value

value = instance.UnlockedLicense
C#
public ExtendedLicense UnlockedLicense {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_UnlockedLicense();
public: __property void set_UnlockedLicense(
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ UnlockedLicense {
   ExtendedLicense^ get();
   void set (ExtendedLicense^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
User Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : User Property

Gets or sets the value of the user as it should appear on screen.

Syntax

Visual Basic (Declaration)
Public Property User As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.User = value

value = instance.User
C#
public string User {get; set;}
Managed Extensions for C++
public: __property string* get_User();
public: __property void set_User(
   string* value
);
C++/CLI
public:
property String^ User {
   String^ get();
   void set (String^ value);
}

Remarks

Warning This value is unprotected and can be changed by the client. Do not assume the value is valid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Values Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Values Property

Gets a collection of arbitrary values to store with the license.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As LicenseValuesCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As LicenseValuesCollection

value = instance.Values
C#
public LicenseValuesCollection Values {get;}
Managed Extensions for C++
public: __property LicenseValuesCollection* get_Values();
C++/CLI
public:
property LicenseValuesCollection^ Values {
   LicenseValuesCollection^ get();
}

Remarks

You can use this to store values for runtime adjustments such as maximum values, names, etc. The values are also signed so adjustments to the values after the license has been signed will invalidate the license. Non primitive values must be marked as Serializable.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Version Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : Version Property

Gets or sets the version of the licensing scheme used.

Syntax

Visual Basic (Declaration)
Public Property Version As Version
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As Version

instance.Version = value

value = instance.Version
C#
public Version Version {get; set;}
Managed Extensions for C++
public: __property Version* get_Version();
public: __property void set_Version(
   Version* value
);
C++/CLI
public:
property Version^ Version {
   Version^ get();
   void set (Version^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
XmlString Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : XmlString Property

Gets or sets the contents of the license as an XML string fragment.

Syntax

Visual Basic (Declaration)
Public Property XmlString As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicense
Dim value As String

instance.XmlString = value

value = instance.XmlString
C#
public string XmlString {get; set;}
Managed Extensions for C++
public: __property string* get_XmlString();
public: __property void set_XmlString(
   string* value
);
C++/CLI
public:
property String^ XmlString {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicense Class Fields
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicense Class

For a list of all members of this type, see ExtendedLicense members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ConfigSection | The configuration section where XHEO|Licensing settings are stored in the application's configuration file.
static (Shared in Visual Basic) | CurrentVersion | The current license scheme file version.
Top

See Also

Reference

ExtendedLicense Class
Xheo.Licensing Namespace
License File Probing


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ConfigSection Field
See Also Example
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : ConfigSection Field

The configuration section where XHEO|Licensing settings are stored in the application's configuration file.

Syntax

Visual Basic (Declaration)
Public Shared ConfigSection As String
Visual Basic (Usage) Copy Code
Dim value As String

value = ExtendedLicense.ConfigSection

ExtendedLicense.ConfigSection = value
C#
public static string ConfigSection
Managed Extensions for C++
public: static string* ConfigSection
C++/CLI
public:
static String^ ConfigSection

Example

C# Copy Code
<configuration>
<appSettings>
    <add key="Xheo.Licensing.TemplateFolder" value="X:\Keys" />
</appSettings>

or

<configSections>
    <sectionGroup name="Xheo">
        <section name="Licensing" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    </sectionGroup>
</configSections>

<Xheo>
    <Licensing>
        <add key="TemplateFolder" value="D:\aaa" />
    </Licensing>
</Xheo>
</configuration>

Remarks

All of XHEO|Licensing's configuration settings can be set from the application or machine's configuration file. You can use the shared <appSettings> section or the custom section to set settings.

Most configuration options can be set in the configuration file via code by setting the public static property to the desired value. For example to save the location of the KeyFolder simply set KeyFolder to the desired value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
CurrentVersion Field
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicense Class : CurrentVersion Field

The current license scheme file version.

Syntax

Visual Basic (Declaration)
Public Shared CurrentVersion As Version
Visual Basic (Usage) Copy Code
Dim value As Version

value = ExtendedLicense.CurrentVersion

ExtendedLicense.CurrentVersion = value
C#
public static Version CurrentVersion
Managed Extensions for C++
public: static Version* CurrentVersion
C++/CLI
public:
static Version^ CurrentVersion

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicense Class
ExtendedLicense Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicenseException Class
See Also Members
[image]
Xheo.Licensing Namespace : ExtendedLicenseException Class

Represents an exception in a Xheo assembly with a localized FriendlyMessage and DetailedMessage.

Syntax

Visual Basic (Declaration)
Private Class ExtendedLicenseException
   Inherits ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException
C#
private class ExtendedLicenseException : ApplicationException
Managed Extensions for C++
private __gc class ExtendedLicenseException : public ApplicationException
C++/CLI
private ref class ExtendedLicenseException : public ApplicationException

Remarks

The Message is used to communicate a simple description of what went wrong and should be written to the non-developer audience. The DetailedMessage should be used to communicate additional technical details and how the problem might be fixed.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Xheo.Licensing.ExtendedLicenseException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicenseException Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : ExtendedLicenseException Class

The following tables list the members exposed by ExtendedLicenseException.

Public Constructors

 | Name | Description
Public Constructor | ExtendedLicenseException Constructor | Overloaded. Initializes a new instance of the ExtendedLicenseException class.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | DetailedMessage | Gets or sets the detailed message.
Public Property | FriendlyMessage | Gets or sets the friendly message.
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Overridden. Gets a description of the exception.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ExtendedLicenseException Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicenseException Constructor
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class : ExtendedLicenseException Constructor

Initializes a new instance of the ExtendedLicenseException class.

Overload List

Overload | Description
ExtendedLicenseException Constructor() | Initializes a new instance of the ExtendedLicenseException class.
ExtendedLicenseException Constructor(String) | Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.
ExtendedLicenseException Constructor(String,Exception) | Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.
ExtendedLicenseException Constructor(String,Exception,Object[]) | Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.
ExtendedLicenseException Constructor(String,Object[]) | Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicenseException Constructor()
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor()

Initializes a new instance of the ExtendedLicenseException class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException()
C#
public ExtendedLicenseException()
Managed Extensions for C++
public: ExtendedLicenseException();
C++/CLI
public:
ExtendedLicenseException();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicenseException Constructor(String)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor(String)

resourceName
The name of the resource to use for the message.
Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceName As String _
)
Visual Basic (Usage) Copy Code
Dim resourceName As String

Dim instance As ExtendedLicenseException(resourceName)
C#
public ExtendedLicenseException(
   string resourceName
)
Managed Extensions for C++
public: ExtendedLicenseException(
   string* resourceName
)
C++/CLI
public:
ExtendedLicenseException(
   String^ resourceName
)

Parameters

resourceName
The name of the resource to use for the message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicenseException Constructor(String,Exception)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor(String,Exception)

resourceName
The name of the resource to use for the message.
innerException
A reference to any inner exception.
Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceName As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim resourceName As String
Dim innerException As Exception

Dim instance As ExtendedLicenseException(resourceName, innerException)
C#
public ExtendedLicenseException(
   string resourceName,
   Exception innerException
)
Managed Extensions for C++
public: ExtendedLicenseException(
   string* resourceName,
   Exception* innerException
)
C++/CLI
public:
ExtendedLicenseException(
   String^ resourceName,
   Exception^ innerException
)

Parameters

resourceName
The name of the resource to use for the message.
innerException
A reference to any inner exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicenseException Constructor(String,Exception,Object[])
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor(String,Exception,Object[])

resourceName
The name of the resource to use for the message.
innerException
A reference to any inner exception.
args
Variable list of arguments to pass to String.Format.
Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceName As String, _
   ByVal innerException As Exception, _
   ByVal ParamArray args() As Object _
)
Visual Basic (Usage) Copy Code
Dim resourceName As String
Dim innerException As Exception
Dim args() As Object

Dim instance As ExtendedLicenseException(resourceName, innerException, args)
C#
public ExtendedLicenseException(
   string resourceName,
   Exception innerException,
   params object[] args
)
Managed Extensions for C++
public: ExtendedLicenseException(
   string* resourceName,
   Exception* innerException,
   params Object*[] args
)
C++/CLI
public:
ExtendedLicenseException(
   String^ resourceName,
   Exception^ innerException,
   ... array<Object^> args
)

Parameters

resourceName
The name of the resource to use for the message.
innerException
A reference to any inner exception.
args
Variable list of arguments to pass to String.Format.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicenseException Constructor(String,Object[])
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class > ExtendedLicenseException Constructor : ExtendedLicenseException Constructor(String,Object[])

resourceName
The name of the resource to use for the message.
args
Variable list of arguments to pass to String.Format.
Initializes a new instance of the ExtendedLicenseException class and uses the resource given for the message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal resourceName As String, _
   ByVal ParamArray args() As Object _
)
Visual Basic (Usage) Copy Code
Dim resourceName As String
Dim args() As Object

Dim instance As ExtendedLicenseException(resourceName, args)
C#
public ExtendedLicenseException(
   string resourceName,
   params object[] args
)
Managed Extensions for C++
public: ExtendedLicenseException(
   string* resourceName,
   params Object*[] args
)
C++/CLI
public:
ExtendedLicenseException(
   String^ resourceName,
   ... array<Object^> args
)

Parameters

resourceName
The name of the resource to use for the message.
args
Variable list of arguments to pass to String.Format.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicenseException Class Properties
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicenseException Class

For a list of all members of this type, see ExtendedLicenseException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | DetailedMessage | Gets or sets the detailed message.
Public Property | FriendlyMessage | Gets or sets the friendly message.
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Overridden. Gets a description of the exception.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ExtendedLicenseException Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
DetailedMessage Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class : DetailedMessage Property

Gets or sets the detailed message.

Syntax

Visual Basic (Declaration)
Public Property DetailedMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException
Dim value As String

instance.DetailedMessage = value

value = instance.DetailedMessage
C#
public string DetailedMessage {get; set;}
Managed Extensions for C++
public: __property string* get_DetailedMessage();
public: __property void set_DetailedMessage(
   string* value
);
C++/CLI
public:
property String^ DetailedMessage {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
FriendlyMessage Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class : FriendlyMessage Property

Gets or sets the friendly message.

Syntax

Visual Basic (Declaration)
Public Property FriendlyMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException
Dim value As String

instance.FriendlyMessage = value

value = instance.FriendlyMessage
C#
public string FriendlyMessage {get; set;}
Managed Extensions for C++
public: __property string* get_FriendlyMessage();
public: __property void set_FriendlyMessage(
   string* value
);
C++/CLI
public:
property String^ FriendlyMessage {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Message Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicenseException Class : Message Property

Gets a description of the exception.

Syntax

Visual Basic (Declaration)
Overrides Public ReadOnly Property Message As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicenseException
Dim value As String

value = instance.Message
C#
public override string Message {get;}
Managed Extensions for C++
public: __property string* get_Message()override ;
C++/CLI
public:
property String^ Message override {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicenseException Class
ExtendedLicenseException Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicensePack Class
See Also Members
[image]
Xheo.Licensing Namespace : ExtendedLicensePack Class

Represents a collection of licenses stored in a single .LIC file.

Object Model

Syntax

Visual Basic (Declaration)
Private Class ExtendedLicensePack
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
C#
private class ExtendedLicensePack : CollectionBase
Managed Extensions for C++
private __gc class ExtendedLicensePack : public CollectionBase
C++/CLI
private ref class ExtendedLicensePack : public CollectionBase

Remarks

Each license pack can serialize to and from an XML license file. Each license within the pack is signed, but the pack itself is not. Licenses can be added or removed without affecting the validity of the pack.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Xheo.Licensing.ExtendedLicensePack

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicensePack Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : ExtendedLicensePack Class

The following tables list the members exposed by ExtendedLicensePack.

Public Constructors

 | Name | Description
Public Constructor | ExtendedLicensePack Constructor | Overloaded. Initializes a new instance of the ExtendedLicensePack class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsEmbedded | Gets a value that indicates if the pack was loaded directly from an assembly.
Public Property | Item | Overloaded. Gets or sets the ExtendedLicense at the given index.
Public Property | Location | Gets the path to the file where the license pack was originally loaded from. If not loaded from a file, returns null.
Public Property | MetaValues | Gets a collection of arbitrary values to store with the license pack. These values are not protected and may be changed without affecting the validity of the contained licenses. Use for storing volitle information and other unsecured information.
Public Property | SaveToShared | Gets or sets a value that indicates if changes to the license pack when validating should be saved to the shared licenses folder.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the given ExtendedLicense to the collection.
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Clones the license pack in memory.
Public Method | Contains | Determines if the pack contains the given license.
Public Method | CopyTo | Copies the collection of ExtendedLicense objects into the array at the given index.
Public Method | Dispose | Disposes of any managed/unmanged resources.
Public Method | FromXmlString | Loads the contents of the xml string into the license pack.
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetLicensesForComponent | Gets a subset of the current license pack filtered by the given component.
Public Method | IndexOf | Overloaded. Gets the index of the ExtendedLicense with the given serial number.
Public Method | Insert | Inserts the license at the given index.
Public Method | Load | Overloaded. Loads the contents of the license pack from a file.
Public Method | Remove | Overloaded. Removes the given ExtendedLicense from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Save | Overloaded. Saves the contents of the license pack to a stream.
Public Method | ToFormattedXmlString | Gets the contents of the license pack as an friendly XML string.
Public Method | ToXmlString | Gets the contents of the license pack as an XML string.
Public Method | WriteToResponse | Overloaded. Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.
Top

See Also

Reference

ExtendedLicensePack Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicensePack Constructor
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : ExtendedLicensePack Constructor

Initializes a new instance of the ExtendedLicensePack class.

Overload List

Overload | Description
ExtendedLicensePack Constructor() | Initializes a new instance of the ExtendedLicensePack class.
ExtendedLicensePack Constructor(String) | Initializes a new instance of the ExtendedLicensePack class from the given file.
ExtendedLicensePack Constructor(String,Boolean) | Initializes a new instance of the ExtendedLicensePack class from the given file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicensePack Constructor()
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > ExtendedLicensePack Constructor : ExtendedLicensePack Constructor()

Initializes a new instance of the ExtendedLicensePack class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack()
C#
public ExtendedLicensePack()
Managed Extensions for C++
public: ExtendedLicensePack();
C++/CLI
public:
ExtendedLicensePack();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicensePack Constructor(String)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > ExtendedLicensePack Constructor : ExtendedLicensePack Constructor(String)

filename
Path to the file that contains the license pack.
Initializes a new instance of the ExtendedLicensePack class from the given file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim filename As String

Dim instance As ExtendedLicensePack(filename)
C#
public ExtendedLicensePack(
   string filename
)
Managed Extensions for C++
public: ExtendedLicensePack(
   string* filename
)
C++/CLI
public:
ExtendedLicensePack(
   String^ filename
)

Parameters

filename
Path to the file that contains the license pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicensePack Constructor(String,Boolean)
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > ExtendedLicensePack Constructor : ExtendedLicensePack Constructor(String,Boolean)

filename
Path to the file that contains the license pack.
tryIsolatedStorage
When true attempts to load a mirrored version of the license from Isolated Storage first.
Initializes a new instance of the ExtendedLicensePack class from the given file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String, _
   ByVal tryIsolatedStorage As Boolean _
)
Visual Basic (Usage) Copy Code
Dim filename As String
Dim tryIsolatedStorage As Boolean

Dim instance As ExtendedLicensePack(filename, tryIsolatedStorage)
C#
public ExtendedLicensePack(
   string filename,
   bool tryIsolatedStorage
)
Managed Extensions for C++
public: ExtendedLicensePack(
   string* filename,
   bool tryIsolatedStorage
)
C++/CLI
public:
ExtendedLicensePack(
   String^ filename,
   bool tryIsolatedStorage
)

Parameters

filename
Path to the file that contains the license pack.
tryIsolatedStorage
When true attempts to load a mirrored version of the license from Isolated Storage first.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicensePack Class Methods
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicensePack Class

For a list of all members of this type, see ExtendedLicensePack members.

Public Methods

 | Name | Description
Public Method | Add | Adds the given ExtendedLicense to the collection.
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Clones the license pack in memory.
Public Method | Contains | Determines if the pack contains the given license.
Public Method | CopyTo | Copies the collection of ExtendedLicense objects into the array at the given index.
Public Method | Dispose | Disposes of any managed/unmanged resources.
Public Method | FromXmlString | Loads the contents of the xml string into the license pack.
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetLicensesForComponent | Gets a subset of the current license pack filtered by the given component.
Public Method | IndexOf | Overloaded. Gets the index of the ExtendedLicense with the given serial number.
Public Method | Insert | Inserts the license at the given index.
Public Method | Load | Overloaded. Loads the contents of the license pack from a file.
Public Method | Remove | Overloaded. Removes the given ExtendedLicense from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Save | Overloaded. Saves the contents of the license pack to a stream.
Public Method | ToFormattedXmlString | Gets the contents of the license pack as an friendly XML string.
Public Method | ToXmlString | Gets the contents of the license pack as an XML string.
Public Method | WriteToResponse | Overloaded. Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.
Top

See Also

Reference

ExtendedLicensePack Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Add Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Add Method

license
The ExtendedLicense to add.
Adds the given ExtendedLicense to the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim license As ExtendedLicense

instance.Add(license)
C#
public void Add(
   ExtendedLicense license
)
Managed Extensions for C++
public: void Add(
   ExtendedLicense* license
)
C++/CLI
public:
void Add(
   ExtendedLicense^ license
)

Parameters

license
The ExtendedLicense to add.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Clone Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Clone Method

Clones the license pack in memory.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As Object

value = instance.Clone()
C#
public object Clone()
Managed Extensions for C++
public: Object* Clone();
C++/CLI
public:
Object^ Clone();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Contains Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Contains Method

license
The license to look for.
Determines if the pack contains the given license.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal license As ExtendedLicense _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim license As ExtendedLicense
Dim value As Boolean

value = instance.Contains(license)
C#
public bool Contains(
   ExtendedLicense license
)
Managed Extensions for C++
public: bool Contains(
   ExtendedLicense* license
)
C++/CLI
public:
bool Contains(
   ExtendedLicense^ license
)

Parameters

license
The license to look for.

Return Value

Returns true if the license is found, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
CopyTo Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : CopyTo Method

array
The array to copy to.
index
The index in the array to start copying.
Copies the collection of ExtendedLicense objects into the array at the given index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ExtendedLicense, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim array() As ExtendedLicense
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ExtendedLicense[] array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   ExtendedLicense*[] array,
   int index
)
C++/CLI
public:
void CopyTo(
   array<ExtendedLicense^> array,
   int index
)

Parameters

array
The array to copy to.
index
The index in the array to start copying.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Dispose Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Dispose Method

Disposes of any managed/unmanged resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : FromXmlString Method

xml
A string containing the XML for the license pack.
Loads the contents of the xml string into the license pack.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
A string containing the XML for the license pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetLicensesForComponent Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : GetLicensesForComponent Method

component
Name of the component to get licenses for.
Gets a subset of the current license pack filtered by the given component.

Syntax

Visual Basic (Declaration)
Public Function GetLicensesForComponent( _
   ByVal component As String _
) As ICollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim component As String
Dim value As ICollection

value = instance.GetLicensesForComponent(component)
C#
public ICollection GetLicensesForComponent(
   string component
)
Managed Extensions for C++
public: ICollection* GetLicensesForComponent(
   string* component
)
C++/CLI
public:
ICollection^ GetLicensesForComponent(
   String^ component
)

Parameters

component
Name of the component to get licenses for.

Return Value

Returns a new collection with the requested licenses.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IndexOf Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : IndexOf Method

Gets the index of the ExtendedLicense with the given serial number.

Overload List

Overload | Description
IndexOf(String) | Gets the index of the ExtendedLicense with the given serial number.
IndexOf(ExtendedLicense) | Gets the index of the license in the pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IndexOf(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > IndexOf Method : IndexOf(String) Method

serialNumber
The serial number to look for.
Gets the index of the ExtendedLicense with the given serial number.

Syntax

Visual Basic (Declaration)
Overloads Public Function IndexOf( _
   ByVal serialNumber As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim serialNumber As String
Dim value As Integer

value = instance.IndexOf(serialNumber)
C#
public int IndexOf(
   string serialNumber
)
Managed Extensions for C++
public: int IndexOf(
   string* serialNumber
)
C++/CLI
public:
int IndexOf(
   String^ serialNumber
)

Parameters

serialNumber
The serial number to look for.

Return Value

Returns the index of the license if found, otherwise -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IndexOf(ExtendedLicense) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > IndexOf Method : IndexOf(ExtendedLicense) Method

license
The license to look for.
Gets the index of the license in the pack.

Syntax

Visual Basic (Declaration)
Overloads Public Function IndexOf( _
   ByVal license As ExtendedLicense _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim license As ExtendedLicense
Dim value As Integer

value = instance.IndexOf(license)
C#
public int IndexOf(
   ExtendedLicense license
)
Managed Extensions for C++
public: int IndexOf(
   ExtendedLicense* license
)
C++/CLI
public:
int IndexOf(
   ExtendedLicense^ license
)

Parameters

license
The license to look for.

Return Value

Returns the index of the license if found, otherwise -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Insert Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Insert Method

index
The index in the collection to insert the license.
license
The license to be inserted.
Inserts the license at the given index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim index As Integer
Dim license As ExtendedLicense

instance.Insert(index, license)
C#
public void Insert(
   int index,
   ExtendedLicense license
)
Managed Extensions for C++
public: void Insert(
   int index,
   ExtendedLicense* license
)
C++/CLI
public:
void Insert(
   int index,
   ExtendedLicense^ license
)

Parameters

index
The index in the collection to insert the license.
license
The license to be inserted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Load Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Load Method

Loads the contents of the license pack from a file.

Overload List

Overload | Description
Load(String,Boolean) | Loads the contents of the license pack from a file.
Load(String) | Loads the contents of the license pack from a file.
Load(Stream) | Loads the contents of the license pack from a file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Load(String,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Load Method : Load(String,Boolean) Method

filename
Path to the file where the licenses were saved.
tryIsolatedStorage
When true attempts to load a mirrored version of the license from Isolated Storage first.
Loads the contents of the license pack from a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal filename As String, _
   ByVal tryIsolatedStorage As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String
Dim tryIsolatedStorage As Boolean

instance.Load(filename, tryIsolatedStorage)
C#
public void Load(
   string filename,
   bool tryIsolatedStorage
)
Managed Extensions for C++
public: void Load(
   string* filename,
   bool tryIsolatedStorage
)
C++/CLI
public:
void Load(
   String^ filename,
   bool tryIsolatedStorage
)

Parameters

filename
Path to the file where the licenses were saved.
tryIsolatedStorage
When true attempts to load a mirrored version of the license from Isolated Storage first.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Load(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Load Method : Load(String) Method

filename
Path to the file where the licenses were saved.
Loads the contents of the license pack from a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String

instance.Load(filename)
C#
public void Load(
   string filename
)
Managed Extensions for C++
public: void Load(
   string* filename
)
C++/CLI
public:
void Load(
   String^ filename
)

Parameters

filename
Path to the file where the licenses were saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Load(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Load Method : Load(Stream) Method

stream
The stream to load from.
Loads the contents of the license pack from a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim stream As Stream

instance.Load(stream)
C#
public void Load(
   Stream stream
)
Managed Extensions for C++
public: void Load(
   Stream* stream
)
C++/CLI
public:
void Load(
   Stream^ stream
)

Parameters

stream
The stream to load from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Remove Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Remove Method

Removes the given ExtendedLicense from the collection.

Overload List

Overload | Description
Remove(ExtendedLicense) | Removes the given ExtendedLicense from the collection.
Remove(String) | Removes the license with the given serial number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Remove(ExtendedLicense) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Remove Method : Remove(ExtendedLicense) Method

license
The ExtendedLicense to remove.
Removes the given ExtendedLicense from the collection.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim license As ExtendedLicense

instance.Remove(license)
C#
public void Remove(
   ExtendedLicense license
)
Managed Extensions for C++
public: void Remove(
   ExtendedLicense* license
)
C++/CLI
public:
void Remove(
   ExtendedLicense^ license
)

Parameters

license
The ExtendedLicense to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Remove(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Remove Method : Remove(String) Method

serialNumber
The serial numbef of the license to remove.
Removes the license with the given serial number.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal serialNumber As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim serialNumber As String

instance.Remove(serialNumber)
C#
public void Remove(
   string serialNumber
)
Managed Extensions for C++
public: void Remove(
   string* serialNumber
)
C++/CLI
public:
void Remove(
   String^ serialNumber
)

Parameters

serialNumber
The serial numbef of the license to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Save Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Save Method

Saves the contents of the license pack to a stream.

Overload List

Overload | Description
Save(Stream) | Saves the contents of the license pack to a stream.
Save(String) | Saves the contents of the license pack to a file.
Save() | Saves the contents of the license pack to the file that it was originally loaded from.
Save(String,Boolean) | Saves the contents of the license pack to a file.
Save(Boolean) | Saves the contents of the license pack to the file that it was originally loaded from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Save(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save(Stream) Method

stream
The Stream to write the contents of the license pack to.
Saves the contents of the license pack to a stream.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim stream As Stream

instance.Save(stream)
C#
public void Save(
   Stream stream
)
Managed Extensions for C++
public: void Save(
   Stream* stream
)
C++/CLI
public:
void Save(
   Stream^ stream
)

Parameters

stream
The Stream to write the contents of the license pack to.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Save(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save(String) Method

filename
Path to the file where the licenses should be saved.
Saves the contents of the license pack to a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String

instance.Save(filename)
C#
public void Save(
   string filename
)
Managed Extensions for C++
public: void Save(
   string* filename
)
C++/CLI
public:
void Save(
   String^ filename
)

Parameters

filename
Path to the file where the licenses should be saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Save() Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save() Method

Saves the contents of the license pack to the file that it was originally loaded from.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack

instance.Save()
C#
public void Save()
Managed Extensions for C++
public: void Save();
C++/CLI
public:
void Save();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Save(String,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save(String,Boolean) Method

filename
Path to the file where the licenses should be saved.
useIsolatedOnFail
If the save fails because of a permission exception, attempt to save to the isolated storage location instead.
Saves the contents of the license pack to a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal filename As String, _
   ByVal useIsolatedOnFail As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String
Dim useIsolatedOnFail As Boolean

instance.Save(filename, useIsolatedOnFail)
C#
public void Save(
   string filename,
   bool useIsolatedOnFail
)
Managed Extensions for C++
public: void Save(
   string* filename,
   bool useIsolatedOnFail
)
C++/CLI
public:
void Save(
   String^ filename,
   bool useIsolatedOnFail
)

Parameters

filename
Path to the file where the licenses should be saved.
useIsolatedOnFail
If the save fails because of a permission exception, attempt to save to the isolated storage location instead.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Save(Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Save Method : Save(Boolean) Method

useIsolatedOnFail
If the save fails because of a permission exception, attempt to save to the isolated storage location instead.
Saves the contents of the license pack to the file that it was originally loaded from.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal useIsolatedOnFail As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim useIsolatedOnFail As Boolean

instance.Save(useIsolatedOnFail)
C#
public void Save(
   bool useIsolatedOnFail
)
Managed Extensions for C++
public: void Save(
   bool useIsolatedOnFail
)
C++/CLI
public:
void Save(
   bool useIsolatedOnFail
)

Parameters

useIsolatedOnFail
If the save fails because of a permission exception, attempt to save to the isolated storage location instead.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ToFormattedXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : ToFormattedXmlString Method

Gets the contents of the license pack as an friendly XML string.

Syntax

Visual Basic (Declaration)
Public Function ToFormattedXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As String

value = instance.ToFormattedXmlString()
C#
public string ToFormattedXmlString()
Managed Extensions for C++
public: string* ToFormattedXmlString();
C++/CLI
public:
String^ ToFormattedXmlString();

Return Value

An XML string representation of the license pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : ToXmlString Method

Gets the contents of the license pack as an XML string.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As String

value = instance.ToXmlString()
C#
public string ToXmlString()
Managed Extensions for C++
public: string* ToXmlString();
C++/CLI
public:
String^ ToXmlString();

Return Value

An XML string representation of the license pack.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
WriteToResponse Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : WriteToResponse Method

Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.

Overload List

Overload | Description
WriteToResponse(String,Boolean) | Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.
WriteToResponse(String) | Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.
WriteToResponse() | Writes the license pack to the response stream for download.

Remarks

Use this method to provide license downloads on your website. You should be careful to not write any additional content to the response stream, or call Response.End() after this method.

NOTE: The response must be buffered for this method to work. In general buffering is on by default in ASP.NET applications.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
WriteToResponse(String,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > WriteToResponse Method : WriteToResponse(String,Boolean) Method

filename
Suggested file name.
direct
Indicates that the file should be written directly to the response and not saved as a new file. When false the user is prompted to open or save the file on their computer.
Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.

Syntax

Visual Basic (Declaration)
Overloads Public Sub WriteToResponse( _
   ByVal filename As String, _
   ByVal direct As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String
Dim direct As Boolean

instance.WriteToResponse(filename, direct)
C#
public void WriteToResponse(
   string filename,
   bool direct
)
Managed Extensions for C++
public: void WriteToResponse(
   string* filename,
   bool direct
)
C++/CLI
public:
void WriteToResponse(
   String^ filename,
   bool direct
)

Parameters

filename
Suggested file name.
direct
Indicates that the file should be written directly to the response and not saved as a new file. When false the user is prompted to open or save the file on their computer.

Remarks

Use this method to provide license downloads on your website. You should be careful to not write any additional content to the response stream, or call Response.End() after this method.

NOTE: The response must be buffered for this method to work. In general buffering is on by default in ASP.NET applications.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
WriteToResponse(String) Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > WriteToResponse Method : WriteToResponse(String) Method

filename
Suggested file name.
Writes the license pack to the response stream for download. The included filename is only a suggestion to the user agent.

Syntax

Visual Basic (Declaration)
Overloads Public Sub WriteToResponse( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim filename As String

instance.WriteToResponse(filename)
C#
public void WriteToResponse(
   string filename
)
Managed Extensions for C++
public: void WriteToResponse(
   string* filename
)
C++/CLI
public:
void WriteToResponse(
   String^ filename
)

Parameters

filename
Suggested file name.

Remarks

Use this method to provide license downloads on your website. You should be careful to not write any additional content to the response stream, or call Response.End() after this method.

NOTE: The response must be buffered for this method to work. In general buffering is on by default in ASP.NET applications.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
WriteToResponse() Method
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > WriteToResponse Method : WriteToResponse() Method

Writes the license pack to the response stream for download.

Syntax

Visual Basic (Declaration)
Overloads Public Sub WriteToResponse()
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack

instance.WriteToResponse()
C#
public void WriteToResponse()
Managed Extensions for C++
public: void WriteToResponse();
C++/CLI
public:
void WriteToResponse();

Remarks

Use this method to provide license downloads on your website.

NOTE: The response must be buffered for this method to work. In general buffering is on by default in ASP.NET applications.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%% $$Properties$$

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicensePack Class Properties
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicensePack Class

For a list of all members of this type, see ExtendedLicensePack members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsEmbedded | Gets a value that indicates if the pack was loaded directly from an assembly.
Public Property | Item | Overloaded. Gets or sets the ExtendedLicense at the given index.
Public Property | Location | Gets the path to the file where the license pack was originally loaded from. If not loaded from a file, returns null.
Public Property | MetaValues | Gets a collection of arbitrary values to store with the license pack. These values are not protected and may be changed without affecting the validity of the contained licenses. Use for storing volitle information and other unsecured information.
Public Property | SaveToShared | Gets or sets a value that indicates if changes to the license pack when validating should be saved to the shared licenses folder.
Top

See Also

Reference

ExtendedLicensePack Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IsEmbedded Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : IsEmbedded Property

Gets a value that indicates if the pack was loaded directly from an assembly.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmbedded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As Boolean

value = instance.IsEmbedded
C#
public bool IsEmbedded {get;}
Managed Extensions for C++
public: __property bool get_IsEmbedded();
C++/CLI
public:
property bool IsEmbedded {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Item Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Item Property

Gets or sets the ExtendedLicense at the given index.

Overload List

Overload | Description
Item(Int32) | Gets or sets the ExtendedLicense at the given index.
Item(String) | Gets or sets the ExtendedLicense with the given serial number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Item(Int32) Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Item Property : Item(Int32) Property

index
Gets or sets the ExtendedLicense at the given index.

Syntax

Visual Basic (Declaration)
Overloads Public Property Item( _
   ByVal index As Integer _
) As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim index As Integer
Dim value As ExtendedLicense

instance.Item(index) = value

value = instance.Item(index)
C#
public ExtendedLicense Item(
   int index
) {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ Item {
   ExtendedLicense^ get(int index);
   void set (int index, ExtendedLicense^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Item(String) Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class > Item Property : Item(String) Property

serialNumber
Gets or sets the ExtendedLicense with the given serial number.

Syntax

Visual Basic (Declaration)
Overloads Public Property Item( _
   ByVal serialNumber As String _
) As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim serialNumber As String
Dim value As ExtendedLicense

instance.Item(serialNumber) = value

value = instance.Item(serialNumber)
C#
public ExtendedLicense Item(
   string serialNumber
) {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_Item(
   string* serialNumber
);
public: __property void set_Item(
   string* serialNumber,
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ Item {
   ExtendedLicense^ get(String^ serialNumber);
   void set (String^ serialNumber, ExtendedLicense^ value);
}

Parameters

serialNumber

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Location Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : Location Property

Gets the path to the file where the license pack was originally loaded from. If not loaded from a file, returns null.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As String

value = instance.Location
C#
public string Location {get;}
Managed Extensions for C++
public: __property string* get_Location();
C++/CLI
public:
property String^ Location {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MetaValues Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : MetaValues Property

Gets a collection of arbitrary values to store with the license pack. These values are not protected and may be changed without affecting the validity of the contained licenses. Use for storing volitle information and other unsecured information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetaValues As LicenseValuesCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As LicenseValuesCollection

value = instance.MetaValues
C#
public LicenseValuesCollection MetaValues {get;}
Managed Extensions for C++
public: __property LicenseValuesCollection* get_MetaValues();
C++/CLI
public:
property LicenseValuesCollection^ MetaValues {
   LicenseValuesCollection^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SaveToShared Property
See Also
[image]
Xheo.Licensing Namespace > ExtendedLicensePack Class : SaveToShared Property

Gets or sets a value that indicates if changes to the license pack when validating should be saved to the shared licenses folder.

Syntax

Visual Basic (Declaration)
Public Property SaveToShared As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtendedLicensePack
Dim value As Boolean

instance.SaveToShared = value

value = instance.SaveToShared
C#
public bool SaveToShared {get; set;}
Managed Extensions for C++
public: __property bool get_SaveToShared();
public: __property void set_SaveToShared(
   bool value
);
C++/CLI
public:
property bool SaveToShared {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

ExtendedLicensePack Class
ExtendedLicensePack Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LicenseSigningKey Class
See Also Members
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

Implements a key pair for signing licenses.

Syntax

Visual Basic (Declaration)
Private NotInheritable Class LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
C#
private sealed class LicenseSigningKey
Managed Extensions for C++
private __gc __sealed class LicenseSigningKey
C++/CLI
private ref class LicenseSigningKey sealed

Remarks

See ExtendedLicense for details on how this class works with others in the library to enforce component licenses.

Inheritance Hierarchy

System.Object
Xheo.Licensing.LicenseSigningKey

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
LicenseSigningKey Class Members
See Also Fields Properties Methods
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

The following tables list the members exposed by LicenseSigningKey.

Public Constructors

 | Name | Description
Public Constructor | LicenseSigningKey Constructor | Overloaded. Initializes a new instance of the LicenseSigningKey class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CurrentVersion | The current version of the LicenseSigningKey class.
Top

Public Properties

 | Name | Description
Public Property | IsGlobalKey | Gets a value that indicates if the keys are the global keys used during the trial.
Public Property | Location | Gets the location where the keys were loaded from.
Public Property | Version | Gets or sets the version of the signing key.
Top

Public Methods

 | Name | Description
Public Method | Decrypt | Decrypts the data using the key. Use Encrypt to encrypt values.
Public Method | DecryptString | Decrypts the data using the key. Use EncryptString to encrypt values.
Public Method | Dispose | Implements Dispose.
Public Method | Encrypt | Encrypts the data using the key. Use Decrypt to retrieve the encrypted value.
Public Method | EncryptString | Encrypts the data using the key. Use DecryptString to retrieve the encrypted value.
Public Method | Export | Overloaded. Saves the public key contents of the LicenseSigningKey to a file with the given file name.
Public Method | FromXmlString | Initializes the contents of the LicenseSigningKey from the XML string.
static (Shared in Visual Basic) | GetPublicKey | Gets the runtime.lic embedded in the assembly hosting the given type.
Public Method | GetSerialNumberSeed | Gets the original unmasked serial number seed (Int32 value) from the encoded value.
static (Shared in Visual Basic) | GetSigningKey | Overloaded. Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.
Public Method | Load | Overloaded. Loads the LicenseSigningKey with the contents of the given file.
Public Method | MakeSerialNumber | Overloaded. Makes an encoded serial number for the given license.
Public Method | Save | Overloaded. Saves the contents of the LicenseSigningKey to a file with the given file name.
Public Method | SignData |
Public Method | SignLicense | Signs the ExtendedLicense and sets the LicenseKey property
Public Method | SignResponse | Signs a response so that the originator of the message can be validated.
Public Method | ToXmlString | Gets the LicenseSigningKey as an XML strign.
Public Method | UpgradeVersion | Upgrades the keys to the format used by the specified version.
Public Method | ValidateLicense | Validates that the contents of the license has not been changed since it was signed.
Public Method | ValidateResponse | Validates a response signature.
Public Method | ValidateSerialNumber | Overloaded. Validates that a serial number was signed with the license key and falls within a given range of valid numbers.
Public Method | VerifyData |
Top

See Also

Reference

LicenseSigningKey Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LicenseSigningKey Constructor
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : LicenseSigningKey Constructor

Initializes a new instance of the LicenseSigningKey class.

Overload List

Overload | Description
LicenseSigningKey Constructor() | Initializes a new instance of the LicenseSigningKey class.
LicenseSigningKey Constructor(Stream) | Initializes a new instance of the LicenseSigningKey class with the key from the given Stream object.
LicenseSigningKey Constructor(String) | Initializes a new instance of the LicenseSigningKey class with the key from the given file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LicenseSigningKey Constructor()
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > LicenseSigningKey Constructor : LicenseSigningKey Constructor()

Initializes a new instance of the LicenseSigningKey class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey()
C#
public LicenseSigningKey()
Managed Extensions for C++
public: LicenseSigningKey();
C++/CLI
public:
LicenseSigningKey();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LicenseSigningKey Constructor(Stream)
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > LicenseSigningKey Constructor : LicenseSigningKey Constructor(Stream)

stream
The Stream object that contains the data.
Initializes a new instance of the LicenseSigningKey class with the key from the given Stream object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As LicenseSigningKey(stream)
C#
public LicenseSigningKey(
   Stream stream
)
Managed Extensions for C++
public: LicenseSigningKey(
   Stream* stream
)
C++/CLI
public:
LicenseSigningKey(
   Stream^ stream
)

Parameters

stream
The Stream object that contains the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LicenseSigningKey Constructor(String)
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > LicenseSigningKey Constructor : LicenseSigningKey Constructor(String)

filename
Path to the file where the LicenseSigningKey is saved.
Initializes a new instance of the LicenseSigningKey class with the key from the given file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim filename As String

Dim instance As LicenseSigningKey(filename)
C#
public LicenseSigningKey(
   string filename
)
Managed Extensions for C++
public: LicenseSigningKey(
   string* filename
)
C++/CLI
public:
LicenseSigningKey(
   String^ filename
)

Parameters

filename
Path to the file where the LicenseSigningKey is saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
LicenseSigningKey Class Methods
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

For a list of all members of this type, see LicenseSigningKey members.

Public Methods

 | Name | Description
Public Method | Decrypt | Decrypts the data using the key. Use Encrypt to encrypt values.
Public Method | DecryptString | Decrypts the data using the key. Use EncryptString to encrypt values.
Public Method | Dispose | Implements Dispose.
Public Method | Encrypt | Encrypts the data using the key. Use Decrypt to retrieve the encrypted value.
Public Method | EncryptString | Encrypts the data using the key. Use DecryptString to retrieve the encrypted value.
Public Method | Export | Overloaded. Saves the public key contents of the LicenseSigningKey to a file with the given file name.
Public Method | FromXmlString | Initializes the contents of the LicenseSigningKey from the XML string.
static (Shared in Visual Basic) | GetPublicKey | Gets the runtime.lic embedded in the assembly hosting the given type.
Public Method | GetSerialNumberSeed | Gets the original unmasked serial number seed (Int32 value) from the encoded value.
static (Shared in Visual Basic) | GetSigningKey | Overloaded. Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.
Public Method | Load | Overloaded. Loads the LicenseSigningKey with the contents of the given file.
Public Method | MakeSerialNumber | Overloaded. Makes an encoded serial number for the given license.
Public Method | Save | Overloaded. Saves the contents of the LicenseSigningKey to a file with the given file name.
Public Method | SignData |
Public Method | SignLicense | Signs the ExtendedLicense and sets the LicenseKey property
Public Method | SignResponse | Signs a response so that the originator of the message can be validated.
Public Method | ToXmlString | Gets the LicenseSigningKey as an XML strign.
Public Method | UpgradeVersion | Upgrades the keys to the format used by the specified version.
Public Method | ValidateLicense | Validates that the contents of the license has not been changed since it was signed.
Public Method | ValidateResponse | Validates a response signature.
Public Method | ValidateSerialNumber | Overloaded. Validates that a serial number was signed with the license key and falls within a given range of valid numbers.
Public Method | VerifyData |
Top

See Also

Reference

LicenseSigningKey Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Decrypt Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Decrypt Method

data
Data previously encrypted with Encrypt.
Decrypts the data using the key. Use Encrypt to encrypt values.

Syntax

Visual Basic (Declaration)
Public Function Decrypt( _
   ByVal data() As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim value() As Byte

value = instance.Decrypt(data)
C#
public byte[] Decrypt(
   byte[] data
)
Managed Extensions for C++
public: byte[] Decrypt(
   byte[] data
)
C++/CLI
public:
array<byte> Decrypt(
   array<byte> data
)

Parameters

data
Data previously encrypted with Encrypt.

Return Value

Returns the original value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
DecryptString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : DecryptString Method

data
Data previously encrypted with EncryptString.
Decrypts the data using the key. Use EncryptString to encrypt values.

Syntax

Visual Basic (Declaration)
Public Function DecryptString( _
   ByVal data() As Byte _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim value As String

value = instance.DecryptString(data)
C#
public string DecryptString(
   byte[] data
)
Managed Extensions for C++
public: string* DecryptString(
   byte[] data
)
C++/CLI
public:
String^ DecryptString(
   array<byte> data
)

Parameters

data
Data previously encrypted with EncryptString.

Return Value

Returns the original value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Dispose Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Dispose Method

Implements Dispose.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Encrypt Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Encrypt Method

data
The data to encrypt.
Encrypts the data using the key. Use Decrypt to retrieve the encrypted value.

Syntax

Visual Basic (Declaration)
Public Function Encrypt( _
   ByVal data() As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim value() As Byte

value = instance.Encrypt(data)
C#
public byte[] Encrypt(
   byte[] data
)
Managed Extensions for C++
public: byte[] Encrypt(
   byte[] data
)
C++/CLI
public:
array<byte> Encrypt(
   array<byte> data
)

Parameters

data
The data to encrypt.

Return Value

Returns the encrypted version of the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
EncryptString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : EncryptString Method

data
The data to encrypt.
Encrypts the data using the key. Use DecryptString to retrieve the encrypted value.

Syntax

Visual Basic (Declaration)
Public Function EncryptString( _
   ByVal data As String _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data As String
Dim value() As Byte

value = instance.EncryptString(data)
C#
public byte[] EncryptString(
   string data
)
Managed Extensions for C++
public: byte[] EncryptString(
   string* data
)
C++/CLI
public:
array<byte> EncryptString(
   String^ data
)

Parameters

data
The data to encrypt.

Return Value

Returns the encrypted version of the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Export Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Export Method

Saves the public key contents of the LicenseSigningKey to a file with the given file name.

Overload List

Overload | Description
Export(String) | Saves the public key contents of the LicenseSigningKey to a file with the given file name.
Export(Stream) | Saves the contents of the LicenseSigningKey to a Stream object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Export(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Export Method : Export(String) Method

filename
Path to the file where the LicenseSigningKey should be saved.
Saves the public key contents of the LicenseSigningKey to a file with the given file name.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Export( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim filename As String

instance.Export(filename)
C#
public void Export(
   string filename
)
Managed Extensions for C++
public: void Export(
   string* filename
)
C++/CLI
public:
void Export(
   String^ filename
)

Parameters

filename
Path to the file where the LicenseSigningKey should be saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Export(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Export Method : Export(Stream) Method

stream
The Stream object to receive the data.
Saves the contents of the LicenseSigningKey to a Stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Export( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim stream As Stream

instance.Export(stream)
C#
public void Export(
   Stream stream
)
Managed Extensions for C++
public: void Export(
   Stream* stream
)
C++/CLI
public:
void Export(
   Stream^ stream
)

Parameters

stream
The Stream object to receive the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : FromXmlString Method

xml
A string containing an XML representaion of the key.
Initializes the contents of the LicenseSigningKey from the XML string.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
A string containing an XML representaion of the key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetPublicKey Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : GetPublicKey Method

type
The reference type to use for obtaining the assembly.
Gets the runtime.lic embedded in the assembly hosting the given type.

Syntax

Visual Basic (Declaration)
Public Shared Function GetPublicKey( _
   ByVal type As Type _
) As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim type As Type
Dim value As LicenseSigningKey

value = LicenseSigningKey.GetPublicKey(type)
C#
public static LicenseSigningKey GetPublicKey(
   Type type
)
Managed Extensions for C++
public: static LicenseSigningKey* GetPublicKey(
   Type* type
)
C++/CLI
public:
static LicenseSigningKey^ GetPublicKey(
   Type^ type
)

Parameters

type
The reference type to use for obtaining the assembly.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetSerialNumberSeed Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : GetSerialNumberSeed Method

license
The license the serial number was generated for.
serialNumber
The masked serial number created by MakeSerialNumber.
Gets the original unmasked serial number seed (Int32 value) from the encoded value.

Syntax

Visual Basic (Declaration)
Public Function GetSerialNumberSeed( _
   ByVal license As ExtendedLicense, _
   ByVal serialNumber As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim serialNumber As String
Dim value As Integer

value = instance.GetSerialNumberSeed(license, serialNumber)
C#
public int GetSerialNumberSeed(
   ExtendedLicense license,
   string serialNumber
)
Managed Extensions for C++
public: int GetSerialNumberSeed(
   ExtendedLicense* license,
   string* serialNumber
)
C++/CLI
public:
int GetSerialNumberSeed(
   ExtendedLicense^ license,
   String^ serialNumber
)

Parameters

license
The license the serial number was generated for.
serialNumber
The masked serial number created by MakeSerialNumber.

Return Value

Returns the original Int32 seed value for the masked serial number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetSigningKey Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : GetSigningKey Method

Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.

Overload List

Overload | Description
GetSigningKey(String,String) | Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.
GetSigningKey(String) | Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetSigningKey(String,String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > GetSigningKey Method : GetSigningKey(String,String) Method

name
Name of the keys.
folder
Path to the folder where the keys are located.
Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function GetSigningKey( _
   ByVal name As String, _
   ByVal folder As String _
) As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim name As String
Dim folder As String
Dim value As LicenseSigningKey

value = LicenseSigningKey.GetSigningKey(name, folder)
C#
public static LicenseSigningKey GetSigningKey(
   string name,
   string folder
)
Managed Extensions for C++
public: static LicenseSigningKey* GetSigningKey(
   string* name,
   string* folder
)
C++/CLI
public:
static LicenseSigningKey^ GetSigningKey(
   String^ name,
   String^ folder
)

Parameters

name
Name of the keys.
folder
Path to the folder where the keys are located.

Return Value

Returns the signing key if found, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetSigningKey(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > GetSigningKey Method : GetSigningKey(String) Method

name
Name of the keys.
Attempts to locate a signing key pair by name in the key folder specified in KeyFolder.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function GetSigningKey( _
   ByVal name As String _
) As LicenseSigningKey
Visual Basic (Usage) Copy Code
Dim name As String
Dim value As LicenseSigningKey

value = LicenseSigningKey.GetSigningKey(name)
C#
public static LicenseSigningKey GetSigningKey(
   string name
)
Managed Extensions for C++
public: static LicenseSigningKey* GetSigningKey(
   string* name
)
C++/CLI
public:
static LicenseSigningKey^ GetSigningKey(
   String^ name
)

Parameters

name
Name of the keys.

Return Value

Returns the signing key if found, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Load Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Load Method

Loads the LicenseSigningKey with the contents of the given file.

Overload List

Overload | Description
Load(String) | Loads the LicenseSigningKey with the contents of the given file.
Load(Stream) | Loads the LicenseSigningKey from a Stream object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Load(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Load Method : Load(String) Method

filename
Path to the file where the LicenseSigningKey is saved.
Loads the LicenseSigningKey with the contents of the given file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim filename As String

instance.Load(filename)
C#
public void Load(
   string filename
)
Managed Extensions for C++
public: void Load(
   string* filename
)
C++/CLI
public:
void Load(
   String^ filename
)

Parameters

filename
Path to the file where the LicenseSigningKey is saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Load(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Load Method : Load(Stream) Method

stream
The Stream object that contains the data.
Loads the LicenseSigningKey from a Stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Load( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim stream As Stream

instance.Load(stream)
C#
public void Load(
   Stream stream
)
Managed Extensions for C++
public: void Load(
   Stream* stream
)
C++/CLI
public:
void Load(
   Stream^ stream
)

Parameters

stream
The Stream object that contains the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MakeSerialNumber Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : MakeSerialNumber Method

Makes an encoded serial number for the given license.

Overload List

Overload | Description
MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32[],Int32) | Makes an encoded serial number for the given license.
MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32) | Makes an encoded serial number for the given license.
MakeSerialNumber(String,SerialNumberSizes,Int32[],Int32) | Makes an encoded serial number for the given license.
MakeSerialNumber(String,SerialNumberSizes,Int32) | Makes an encoded serial number for the given license.

Exceptions

Exception | Description
ExtendedLicenseException | Thrown when the license keys have not been upgraded to at least version 2.0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32[],Int32) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > MakeSerialNumber Method : MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32[],Int32) Method

license
The license to generate a serial number for.
size
The key size to use when encrypting the serial number.
groupSizes
Defines the group sizes used to split the serial number into smaller chunks. A null value will use the default sizes for the given key size.
seed
The serial number value to encode.
Makes an encoded serial number for the given license.

Syntax

Visual Basic (Declaration)
Overloads Public Function MakeSerialNumber( _
   ByVal license As ExtendedLicense, _
   ByVal size As SerialNumberSizes, _
   ByVal groupSizes() As Integer, _
   ByVal seed As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim size As SerialNumberSizes
Dim groupSizes() As Integer
Dim seed As Integer
Dim value As String

value = instance.MakeSerialNumber(license, size, groupSizes, seed)
C#
public string MakeSerialNumber(
   ExtendedLicense license,
   SerialNumberSizes size,
   int[] groupSizes,
   int seed
)
Managed Extensions for C++
public: string* MakeSerialNumber(
   ExtendedLicense* license,
   SerialNumberSizes size,
   int[] groupSizes,
   int seed
)
C++/CLI
public:
String^ MakeSerialNumber(
   ExtendedLicense^ license,
   SerialNumberSizes size,
   array<int> groupSizes,
   int seed
)

Parameters

license
The license to generate a serial number for.
size
The key size to use when encrypting the serial number.
groupSizes
Defines the group sizes used to split the serial number into smaller chunks. A null value will use the default sizes for the given key size.
seed
The serial number value to encode.

Return Value

Returns a new serial number encrypted with the key.

Exceptions

Exception | Description
ExtendedLicenseException | Thrown when the license keys have not been upgraded to at least version 2.0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > MakeSerialNumber Method : MakeSerialNumber(ExtendedLicense,SerialNumberSizes,Int32) Method

license
The license to generate a serial number for.
size
The key size to use when encrypting the serial number.
seed
The serial number value to encode.
Makes an encoded serial number for the given license.

Syntax

Visual Basic (Declaration)
Overloads Public Function MakeSerialNumber( _
   ByVal license As ExtendedLicense, _
   ByVal size As SerialNumberSizes, _
   ByVal seed As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim size As SerialNumberSizes
Dim seed As Integer
Dim value As String

value = instance.MakeSerialNumber(license, size, seed)
C#
public string MakeSerialNumber(
   ExtendedLicense license,
   SerialNumberSizes size,
   int seed
)
Managed Extensions for C++
public: string* MakeSerialNumber(
   ExtendedLicense* license,
   SerialNumberSizes size,
   int seed
)
C++/CLI
public:
String^ MakeSerialNumber(
   ExtendedLicense^ license,
   SerialNumberSizes size,
   int seed
)

Parameters

license
The license to generate a serial number for.
size
The key size to use when encrypting the serial number.
seed
The serial number value to encode.

Return Value

Returns a new serial number encrypted with the key.

Exceptions

Exception | Description
ExtendedLicenseException | Thrown when the license keys have not been upgraded to at least version 2.0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MakeSerialNumber(String,SerialNumberSizes,Int32[],Int32) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > MakeSerialNumber Method : MakeSerialNumber(String,SerialNumberSizes,Int32[],Int32) Method

prefix
The prefix to add to the serial number. It must match the AbsoluteSerialNumber of the license it will be assigned to.
size
The key size to use when encrypting the serial number.
groupSizes
Defines the group sizes used to split the serial number into smaller chunks. A null value will use the default sizes for the given key size.
seed
The serial number value to encode.
Makes an encoded serial number for the given license.

Syntax

Visual Basic (Declaration)
Overloads Public Function MakeSerialNumber( _
   ByVal prefix As String, _
   ByVal size As SerialNumberSizes, _
   ByVal groupSizes() As Integer, _
   ByVal seed As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim prefix As String
Dim size As SerialNumberSizes
Dim groupSizes() As Integer
Dim seed As Integer
Dim value As String

value = instance.MakeSerialNumber(prefix, size, groupSizes, seed)
C#
public string MakeSerialNumber(
   string prefix,
   SerialNumberSizes size,
   int[] groupSizes,
   int seed
)
Managed Extensions for C++
public: string* MakeSerialNumber(
   string* prefix,
   SerialNumberSizes size,
   int[] groupSizes,
   int seed
)
C++/CLI
public:
String^ MakeSerialNumber(
   String^ prefix,
   SerialNumberSizes size,
   array<int> groupSizes,
   int seed
)

Parameters

prefix
The prefix to add to the serial number. It must match the AbsoluteSerialNumber of the license it will be assigned to.
size
The key size to use when encrypting the serial number.
groupSizes
Defines the group sizes used to split the serial number into smaller chunks. A null value will use the default sizes for the given key size.
seed
The serial number value to encode.

Return Value

Returns a new serial number encrypted with the key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MakeSerialNumber(String,SerialNumberSizes,Int32) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > MakeSerialNumber Method : MakeSerialNumber(String,SerialNumberSizes,Int32) Method

prefix
The prefix to add to the serial number. It must match the AbsoluteSerialNumber of the license it will be assigned to.
size
The key size to use when encrypting the serial number.
seed
The serial number value to encode.
Makes an encoded serial number for the given license.

Syntax

Visual Basic (Declaration)
Overloads Public Function MakeSerialNumber( _
   ByVal prefix As String, _
   ByVal size As SerialNumberSizes, _
   ByVal seed As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim prefix As String
Dim size As SerialNumberSizes
Dim seed As Integer
Dim value As String

value = instance.MakeSerialNumber(prefix, size, seed)
C#
public string MakeSerialNumber(
   string prefix,
   SerialNumberSizes size,
   int seed
)
Managed Extensions for C++
public: string* MakeSerialNumber(
   string* prefix,
   SerialNumberSizes size,
   int seed
)
C++/CLI
public:
String^ MakeSerialNumber(
   String^ prefix,
   SerialNumberSizes size,
   int seed
)

Parameters

prefix
The prefix to add to the serial number. It must match the AbsoluteSerialNumber of the license it will be assigned to.
size
The key size to use when encrypting the serial number.
seed
The serial number value to encode.

Return Value

Returns a new serial number encrypted with the key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Save Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Save Method

Saves the contents of the LicenseSigningKey to a file with the given file name.

Overload List

Overload | Description
Save(String,Boolean) | Saves the contents of the LicenseSigningKey to a file with the given file name.
Save(String) | Saves the contents of the LicenseSigningKey to a file with the given file name.
Save(Stream,Boolean) | Saves the contents of the LicenseSigningKey to a Stream object.
Save(Stream) | Saves the contents of the LicenseSigningKey to a Stream object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Save(String,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Save Method : Save(String,Boolean) Method

filename
Path to the file where the LicenseSigningKey should be saved.
includePrivateData
Indicates if the private portion of the key should be included.
Saves the contents of the LicenseSigningKey to a file with the given file name.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal filename As String, _
   ByVal includePrivateData As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim filename As String
Dim includePrivateData As Boolean

instance.Save(filename, includePrivateData)
C#
public void Save(
   string filename,
   bool includePrivateData
)
Managed Extensions for C++
public: void Save(
   string* filename,
   bool includePrivateData
)
C++/CLI
public:
void Save(
   String^ filename,
   bool includePrivateData
)

Parameters

filename
Path to the file where the LicenseSigningKey should be saved.
includePrivateData
Indicates if the private portion of the key should be included.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Save(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Save Method : Save(String) Method

filename
Path to the file where the LicenseSigningKey should be saved.
Saves the contents of the LicenseSigningKey to a file with the given file name.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim filename As String

instance.Save(filename)
C#
public void Save(
   string filename
)
Managed Extensions for C++
public: void Save(
   string* filename
)
C++/CLI
public:
void Save(
   String^ filename
)

Parameters

filename
Path to the file where the LicenseSigningKey should be saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Save(Stream,Boolean) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Save Method : Save(Stream,Boolean) Method

stream
The Stream object to receive the data.
includePrivateData
Indicates if the private portion of the key should be included.
Saves the contents of the LicenseSigningKey to a Stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream, _
   ByVal includePrivateData As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim stream As Stream
Dim includePrivateData As Boolean

instance.Save(stream, includePrivateData)
C#
public void Save(
   Stream stream,
   bool includePrivateData
)
Managed Extensions for C++
public: void Save(
   Stream* stream,
   bool includePrivateData
)
C++/CLI
public:
void Save(
   Stream^ stream,
   bool includePrivateData
)

Parameters

stream
The Stream object to receive the data.
includePrivateData
Indicates if the private portion of the key should be included.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Save(Stream) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > Save Method : Save(Stream) Method

stream
The Stream object to receive the data.
Saves the contents of the LicenseSigningKey to a Stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim stream As Stream

instance.Save(stream)
C#
public void Save(
   Stream stream
)
Managed Extensions for C++
public: void Save(
   Stream* stream
)
C++/CLI
public:
void Save(
   Stream^ stream
)

Parameters

stream
The Stream object to receive the data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SignData Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : SignData Method

data

Syntax

Visual Basic (Declaration)
Public Function SignData( _
   ByVal data() As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim value() As Byte

value = instance.SignData(data)
C#
public byte[] SignData(
   byte[] data
)
Managed Extensions for C++
public: byte[] SignData(
   byte[] data
)
C++/CLI
public:
array<byte> SignData(
   array<byte> data
)

Parameters

data

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SignLicense Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : SignLicense Method

license
Signs the ExtendedLicense and sets the LicenseKey property

Syntax

Visual Basic (Declaration)
Public Sub SignLicense( _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense

instance.SignLicense(license)
C#
public void SignLicense(
   ExtendedLicense license
)
Managed Extensions for C++
public: void SignLicense(
   ExtendedLicense* license
)
C++/CLI
public:
void SignLicense(
   ExtendedLicense^ license
)

Parameters

license

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SignResponse Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : SignResponse Method

response
The response to sign.
Signs a response so that the originator of the message can be validated.

Syntax

Visual Basic (Declaration)
Public Function SignResponse( _
   ByVal response As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim response As String
Dim value As String

value = instance.SignResponse(response)
C#
public string SignResponse(
   string response
)
Managed Extensions for C++
public: string* SignResponse(
   string* response
)
C++/CLI
public:
String^ SignResponse(
   String^ response
)

Parameters

response
The response to sign.

Return Value

Returns a signature for the response.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : ToXmlString Method

includePrivateData
Indicates if the private data shouls be included.
Gets the LicenseSigningKey as an XML strign.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString( _
   ByVal includePrivateData As Boolean _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim includePrivateData As Boolean
Dim value As String

value = instance.ToXmlString(includePrivateData)
C#
public string ToXmlString(
   bool includePrivateData
)
Managed Extensions for C++
public: string* ToXmlString(
   bool includePrivateData
)
C++/CLI
public:
String^ ToXmlString(
   bool includePrivateData
)

Parameters

includePrivateData
Indicates if the private data shouls be included.

Return Value

Returns an XML string representation of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
UpgradeVersion Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : UpgradeVersion Method

version
The version to upgrade to.
Upgrades the keys to the format used by the specified version.

Syntax

Visual Basic (Declaration)
Public Sub UpgradeVersion( _
   ByVal version As Version _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim version As Version

instance.UpgradeVersion(version)
C#
public void UpgradeVersion(
   Version version
)
Managed Extensions for C++
public: void UpgradeVersion(
   Version* version
)
C++/CLI
public:
void UpgradeVersion(
   Version^ version
)

Parameters

version
The version to upgrade to.

Remarks

The changes should be saved over the existing keys and the public key re-exported after the upgrade.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ValidateLicense Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : ValidateLicense Method

license
The license to validate.
Validates that the contents of the license has not been changed since it was signed.

Syntax

Visual Basic (Declaration)
Public Function ValidateLicense( _
   ByVal license As ExtendedLicense _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim value As Boolean

value = instance.ValidateLicense(license)
C#
public bool ValidateLicense(
   ExtendedLicense license
)
Managed Extensions for C++
public: bool ValidateLicense(
   ExtendedLicense* license
)
C++/CLI
public:
bool ValidateLicense(
   ExtendedLicense^ license
)

Parameters

license
The license to validate.

Return Value

Returns true if the contents of the license have not been changed, otherwise false.

Remarks

You must use the same LicenseSigningKey to validate the license as you did to sign it. You can use either the full public/private key or just the public key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ValidateResponse Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : ValidateResponse Method

response
The original response.
signature
The signature generated from SignResponse.
Validates a response signature.

Syntax

Visual Basic (Declaration)
Public Function ValidateResponse( _
   ByVal response As String, _
   ByVal signature As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim response As String
Dim signature As String
Dim value As Boolean

value = instance.ValidateResponse(response, signature)
C#
public bool ValidateResponse(
   string response,
   string signature
)
Managed Extensions for C++
public: bool ValidateResponse(
   string* response,
   string* signature
)
C++/CLI
public:
bool ValidateResponse(
   String^ response,
   String^ signature
)

Parameters

response
The original response.
signature
The signature generated from SignResponse.

Return Value

Returns true if the signature and response match.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ValidateSerialNumber Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : ValidateSerialNumber Method

Validates that a serial number was signed with the license key and falls within a given range of valid numbers.

Overload List

Overload | Description
ValidateSerialNumber(ExtendedLicense,String) | Validates that a serial number was signed with the license key and falls within a given range of valid numbers.
ValidateSerialNumber(String,String,Int32,Int32,SerialNumberSizes) | Validates that a serial number was signed with the license key and falls within a given range of valid numbers.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ValidateSerialNumber(ExtendedLicense,String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > ValidateSerialNumber Method : ValidateSerialNumber(ExtendedLicense,String) Method

license
The license the seral number is checked against.
serialNumber
The serial number to check.
Validates that a serial number was signed with the license key and falls within a given range of valid numbers.

Syntax

Visual Basic (Declaration)
Overloads Public Function ValidateSerialNumber( _
   ByVal license As ExtendedLicense, _
   ByVal serialNumber As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim license As ExtendedLicense
Dim serialNumber As String
Dim value As Boolean

value = instance.ValidateSerialNumber(license, serialNumber)
C#
public bool ValidateSerialNumber(
   ExtendedLicense license,
   string serialNumber
)
Managed Extensions for C++
public: bool ValidateSerialNumber(
   ExtendedLicense* license,
   string* serialNumber
)
C++/CLI
public:
bool ValidateSerialNumber(
   ExtendedLicense^ license,
   String^ serialNumber
)

Parameters

license
The license the seral number is checked against.
serialNumber
The serial number to check.

Return Value

Returns true of the serial number is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ValidateSerialNumber(String,String,Int32,Int32,SerialNumberSizes) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class > ValidateSerialNumber Method : ValidateSerialNumber(String,String,Int32,Int32,SerialNumberSizes) Method

prefix
The serial number prefix required.
serialNumber
The serial number to check.
minAcceptedSeed
The minimum acceptable seed value.
maxAcceptedSeed
The maximim acceptable seed value.
acceptedSizes
The accepted serial number sizes.
Validates that a serial number was signed with the license key and falls within a given range of valid numbers.

Syntax

Visual Basic (Declaration)
Overloads Public Function ValidateSerialNumber( _
   ByVal prefix As String, _
   ByVal serialNumber As String, _
   ByVal minAcceptedSeed As Integer, _
   ByVal maxAcceptedSeed As Integer, _
   ByVal acceptedSizes As SerialNumberSizes _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim prefix As String
Dim serialNumber As String
Dim minAcceptedSeed As Integer
Dim maxAcceptedSeed As Integer
Dim acceptedSizes As SerialNumberSizes
Dim value As Boolean

value = instance.ValidateSerialNumber(prefix, serialNumber, minAcceptedSeed, maxAcceptedSeed, acceptedSizes)
C#
public bool ValidateSerialNumber(
   string prefix,
   string serialNumber,
   int minAcceptedSeed,
   int maxAcceptedSeed,
   SerialNumberSizes acceptedSizes
)
Managed Extensions for C++
public: bool ValidateSerialNumber(
   string* prefix,
   string* serialNumber,
   int minAcceptedSeed,
   int maxAcceptedSeed,
   SerialNumberSizes acceptedSizes
)
C++/CLI
public:
bool ValidateSerialNumber(
   String^ prefix,
   String^ serialNumber,
   int minAcceptedSeed,
   int maxAcceptedSeed,
   SerialNumberSizes acceptedSizes
)

Parameters

prefix
The serial number prefix required.
serialNumber
The serial number to check.
minAcceptedSeed
The minimum acceptable seed value.
maxAcceptedSeed
The maximim acceptable seed value.
acceptedSizes
The accepted serial number sizes.

Return Value

Returns true of the serial number is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
VerifyData Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : VerifyData Method

data
signature

Syntax

Visual Basic (Declaration)
Public Function VerifyData( _
   ByVal data() As Byte, _
   ByVal signature() As Byte _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim data() As Byte
Dim signature() As Byte
Dim value As Boolean

value = instance.VerifyData(data, signature)
C#
public bool VerifyData(
   byte[] data,
   byte[] signature
)
Managed Extensions for C++
public: bool VerifyData(
   byte[] data,
   byte[] signature
)
C++/CLI
public:
bool VerifyData(
   array<byte> data,
   array<byte> signature
)

Parameters

data
signature

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.RS.Design Send comments on this topic.
LicenseSigningKey Class Properties
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

For a list of all members of this type, see LicenseSigningKey members.

Public Properties

 | Name | Description
Public Property | IsGlobalKey | Gets a value that indicates if the keys are the global keys used during the trial.
Public Property | Location | Gets the location where the keys were loaded from.
Public Property | Version | Gets or sets the version of the signing key.
Top

See Also

Reference

LicenseSigningKey Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IsGlobalKey Property
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : IsGlobalKey Property

Gets a value that indicates if the keys are the global keys used during the trial.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsGlobalKey As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim value As Boolean

value = instance.IsGlobalKey
C#
public bool IsGlobalKey {get;}
Managed Extensions for C++
public: __property bool get_IsGlobalKey();
C++/CLI
public:
property bool IsGlobalKey {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Location Property
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Location Property

Gets the location where the keys were loaded from.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Location As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim value As String

value = instance.Location
C#
public string Location {get;}
Managed Extensions for C++
public: __property string* get_Location();
C++/CLI
public:
property String^ Location {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Version Property
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : Version Property

Gets or sets the version of the signing key.

Syntax

Visual Basic (Declaration)
Public Property Version As Version
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey
Dim value As Version

instance.Version = value

value = instance.Version
C#
public Version Version {get; set;}
Managed Extensions for C++
public: __property Version* get_Version();
public: __property void set_Version(
   Version* value
);
C++/CLI
public:
property Version^ Version {
   Version^ get();
   void set (Version^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.RS.Design Send comments on this topic.
LicenseSigningKey Class Fields
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey Class

For a list of all members of this type, see LicenseSigningKey members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CurrentVersion | The current version of the LicenseSigningKey class.
Top

See Also

Reference

LicenseSigningKey Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
CurrentVersion Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey Class : CurrentVersion Field

The current version of the LicenseSigningKey class.

Syntax

Visual Basic (Declaration)
Public Shared CurrentVersion As Version
Visual Basic (Usage) Copy Code
Dim value As Version

value = LicenseSigningKey.CurrentVersion

LicenseSigningKey.CurrentVersion = value
C#
public static Version CurrentVersion
Managed Extensions for C++
public: static Version* CurrentVersion
C++/CLI
public:
static Version^ CurrentVersion

Remarks

Later versions may introduce a new signing/file scheme. To maintain backwards compatability the keys are versioned.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey Class
LicenseSigningKey Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LicenseValuesCollection Class
See Also Members
[image]
Xheo.Licensing Namespace : LicenseValuesCollection Class

Maintains a collection of name value pairs. The collection can be serialized and marked as read only.

Syntax

Visual Basic (Declaration)
Private Class LicenseValuesCollection
   Inherits NameValueCollection
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
C#
private class LicenseValuesCollection : NameValueCollection
Managed Extensions for C++
private __gc class LicenseValuesCollection : public NameValueCollection
C++/CLI
private ref class LicenseValuesCollection : public NameValueCollection

Inheritance Hierarchy

System.Object
System.Collections.Specialized.NameObjectCollectionBase
System.Collections.Specialized.NameValueCollection
Xheo.Licensing.LicenseValuesCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
LicenseValuesCollection Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : LicenseValuesCollection Class

The following tables list the members exposed by LicenseValuesCollection.

Public Constructors

 | Name | Description
Public Constructor | LicenseValuesCollection Constructor | Initializes a new instance of the LicenseValuesCollection class.
Top

Public Properties

 | Name | Description
Public Property | AllKeys | Gets all the keys in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Property | Count | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Property | Item | Overloaded. Gets or sets the entry with the specified key in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Property | Keys | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Included for serialization compatability, do not use.
Public Method | Clear | Invalidates the cached arrays and removes all entries from the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | CopyTo | Copies the entire NameValueCollection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | FromXmlString | Loads the values from an XML string.
Public Method | Get | Overloaded. Gets the values associated with the specified key from the NameValueCollection combined into one comma-separated list. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | GetEnumerator | Returns an enumerator that iterates through the NameObjectCollectionBase. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetKey | Gets the key at the specified index of the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetValues | Overloaded. Gets the values associated with the specified key from the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | HasKeys | Gets a value indicating whether the NameValueCollection contains keys that are not null. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | LoadFromXml | Loades the contents of the collection from the XmlNode.
Public Method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | Remove | Removes the entries with the specified key from the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | SaveToXml | Saves the contents of the collection to the parent XmlNode.
Public Method | Set | Sets the value of an entry in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | ToXmlString | Converts the collection to an XML string representation.
Top

See Also

Reference

LicenseValuesCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LicenseValuesCollection Constructor
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : LicenseValuesCollection Constructor

Initializes a new instance of the LicenseValuesCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection()
C#
public LicenseValuesCollection()
Managed Extensions for C++
public: LicenseValuesCollection();
C++/CLI
public:
LicenseValuesCollection();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
LicenseValuesCollection Class Methods
See Also
[image]
Xheo.Licensing Namespace : LicenseValuesCollection Class

For a list of all members of this type, see LicenseValuesCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Included for serialization compatability, do not use.
Public Method | Clear | Invalidates the cached arrays and removes all entries from the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | CopyTo | Copies the entire NameValueCollection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | FromXmlString | Loads the values from an XML string.
Public Method | Get | Overloaded. Gets the values associated with the specified key from the NameValueCollection combined into one comma-separated list. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | GetEnumerator | Returns an enumerator that iterates through the NameObjectCollectionBase. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetKey | Gets the key at the specified index of the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetValues | Overloaded. Gets the values associated with the specified key from the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | HasKeys | Gets a value indicating whether the NameValueCollection contains keys that are not null. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | LoadFromXml | Loades the contents of the collection from the XmlNode.
Public Method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | Remove | Removes the entries with the specified key from the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | SaveToXml | Saves the contents of the collection to the parent XmlNode.
Public Method | Set | Sets the value of an entry in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Method | ToXmlString | Converts the collection to an XML string representation.
Top

See Also

Reference

LicenseValuesCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Add Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : Add Method

Included for serialization compatability, do not use.

Overload List

Overload | Description
Add(String) | Included for serialization compatability, do not use.
Add(NameValueCollection) | Copies the entries in the specified NameValueCollection to the current NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Add(String,String) | Adds an entry with the specified name and value to the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Add(String) Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class > Add Method : Add(String) Method

value
Included for serialization compatability, do not use.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim value As String

instance.Add(value)
C#
public void Add(
   string value
)
Managed Extensions for C++
public: void Add(
   string* value
)
C++/CLI
public:
void Add(
   String^ value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : FromXmlString Method

xml
The XML document string containing the values collection.
Loads the values from an XML string.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
The XML document string containing the values collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : LoadFromXml Method

parentNode
The root XmlNode containing the collection.
Loades the contents of the collection from the XmlNode.

Syntax

Visual Basic (Declaration)
Public Sub LoadFromXml( _
   ByVal parentNode As XmlNode _
)
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim parentNode As XmlNode

instance.LoadFromXml(parentNode)
C#
public void LoadFromXml(
   XmlNode parentNode
)
Managed Extensions for C++
public: void LoadFromXml(
   XmlNode parentNode
)
C++/CLI
public:
void LoadFromXml(
   XmlNode parentNode
)

Parameters

parentNode
The root XmlNode containing the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : SaveToXml Method

parentNode
The XmlNode to save the collection to.
Saves the contents of the collection to the parent XmlNode.

Syntax

Visual Basic (Declaration)
Public Function SaveToXml( _
   ByVal parentNode As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim parentNode As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parentNode)
C#
public XmlNode SaveToXml(
   XmlNode parentNode
)
Managed Extensions for C++
public: XmlNode SaveToXml(
   XmlNode parentNode
)
C++/CLI
public:
XmlNode SaveToXml(
   XmlNode parentNode
)

Parameters

parentNode
The XmlNode to save the collection to.

Return Value

Returns the root node of the saved collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LicenseValuesCollection Class : ToXmlString Method

Converts the collection to an XML string representation.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As LicenseValuesCollection
Dim value As String

value = instance.ToXmlString()
C#
public string ToXmlString()
Managed Extensions for C++
public: string* ToXmlString();
C++/CLI
public:
String^ ToXmlString();

Return Value

Returns the collection as an XML document string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseValuesCollection Class
LicenseValuesCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Limit Class
See Also Members
[image]
Xheo.Licensing Namespace : Limit Class

Base class for all license limitations.

Object Model

Syntax

Visual Basic (Declaration)
Private MustInherit Class Limit
   Inherits MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As Limit
C#
private abstract class Limit : MarshalByRefObject
Managed Extensions for C++
private __gc abstract class Limit : public MarshalByRefObject
C++/CLI
private ref class Limit abstract : public MarshalByRefObject

Remarks

Limits are used by the XHEO|Licensing framework to restrict a Component, Class or Control to a specific set of runtime or designtime conditions. The library contains over 15 built in limits that you can use to control the use of your protected Type.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Xheo.Licensing.Limit
Xheo.Licensing.ContainerLimit
Xheo.Licensing.ContainerLimit
Xheo.Licensing.ContainerLimit
Xheo.Licensing.ContainerLimit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
Limit Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : Limit Class

The following tables list the members exposed by Limit.

Public Properties

 | Name | Description
Public Property | Description | Gets the description of the limit.
Public Property | IsGui | Gets a value that indicates if this Limit uses a GUI to interact with the user.
Public Property | IsRemote | Gets a value that indicates if this Limit uses remote processes (such as WebServices) for enforcement.
Public Property | IsTimeSensitive | Gets a value that indicates if the limit is time sensitive and the clock should be protected.
Public Property | License | Gets or sets a reference to the ExtendedLicense that contains this Limit.
Public Property | Name | Gets the display name of the limit.
Public Property | QualifiedTypeName | Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type.
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases any managed or unmangaged resources used by the limit.
static (Shared in Visual Basic) | GetBitmapResource | Gets an Image for the requested resource. Resources can be defined as assembly resources or as remote resources. If the name is prefixed with http then it is assumed to be a remote resource and a WebRequest is made to retrieve the bitmap, otherwise it is assumed to be embedded in the assembly.
Public Method | GetDetailsDescription | Gets a description of the details of the limit.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | GetLimitFromName | Gets a Limit object based on the given name.
static (Shared in Visual Basic) | GetPrivateRegistryKey | Gets a private registry key where values for the license can be stored for the given type.
Public Method | Granted | Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | LoadFromXml | Loads the contents of a Limit from an XmlNode.
static (Shared in Visual Basic) | MaskValue | Performs a simple value obfuscation to make editing client side values more difficult. This is by no means secure.
static (Shared in Visual Basic) | OpenOrCreateRegistryKey | Opens or creates a registry key.
static (Shared in Visual Basic) | ParseIPAddress | Parses an IPAddress to it's actual long value.
Public Method | Peek | Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user.
Public Method | SaveToXml | Saves the contents of the Limit as an XmlNode.
static (Shared in Visual Basic) | SelectCulture | Selects the given culture for the current thread, and returns the previous culture.
static (Shared in Visual Basic) | SelectWebCulture | Selects the culture of the current web request into the current thread, and returns the previous culture.
static (Shared in Visual Basic) | UnmaskValue | Reverses the simple value obfuscation performed by MaskValue.
Public Method | Validate | Validates that the license being granted is within the limits enforced by this object.
static (Shared in Visual Basic) | ValidateDomainName | Validates the format of a domain name.
static (Shared in Visual Basic) | ValidateEmail | Validates if the email is correctly formatted.
static (Shared in Visual Basic) | ValidateIPAddress | Validates the format of an IP address.
static (Shared in Visual Basic) | ValidateUrl | Validates the url is correctly formatted.
Top

See Also

Reference

Limit Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
Limit Class Methods
See Also
[image]
Xheo.Licensing Namespace : Limit Class

For a list of all members of this type, see Limit members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases any managed or unmangaged resources used by the limit.
static (Shared in Visual Basic) | GetBitmapResource | Gets an Image for the requested resource. Resources can be defined as assembly resources or as remote resources. If the name is prefixed with http then it is assumed to be a remote resource and a WebRequest is made to retrieve the bitmap, otherwise it is assumed to be embedded in the assembly.
Public Method | GetDetailsDescription | Gets a description of the details of the limit.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | GetLimitFromName | Gets a Limit object based on the given name.
static (Shared in Visual Basic) | GetPrivateRegistryKey | Gets a private registry key where values for the license can be stored for the given type.
Public Method | Granted | Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | LoadFromXml | Loads the contents of a Limit from an XmlNode.
static (Shared in Visual Basic) | MaskValue | Performs a simple value obfuscation to make editing client side values more difficult. This is by no means secure.
static (Shared in Visual Basic) | OpenOrCreateRegistryKey | Opens or creates a registry key.
static (Shared in Visual Basic) | ParseIPAddress | Parses an IPAddress to it's actual long value.
Public Method | Peek | Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user.
Public Method | SaveToXml | Saves the contents of the Limit as an XmlNode.
static (Shared in Visual Basic) | SelectCulture | Selects the given culture for the current thread, and returns the previous culture.
static (Shared in Visual Basic) | SelectWebCulture | Selects the culture of the current web request into the current thread, and returns the previous culture.
static (Shared in Visual Basic) | UnmaskValue | Reverses the simple value obfuscation performed by MaskValue.
Public Method | Validate | Validates that the license being granted is within the limits enforced by this object.
static (Shared in Visual Basic) | ValidateDomainName | Validates the format of a domain name.
static (Shared in Visual Basic) | ValidateEmail | Validates if the email is correctly formatted.
static (Shared in Visual Basic) | ValidateIPAddress | Validates the format of an IP address.
static (Shared in Visual Basic) | ValidateUrl | Validates the url is correctly formatted.
Top

See Also

Reference

Limit Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Dispose Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Dispose Method

Releases any managed or unmangaged resources used by the limit.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As Limit

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetBitmapResource Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : GetBitmapResource Method

bitmapResource
Name of the resource to retrieve, prefix with http to get a remote resource.
limit
The limit requesting the resource.
parameters
Collection of additional parameters to append to the URL for remote images. Parameters should be in the format "key=value".
Gets an Image for the requested resource. Resources can be defined as assembly resources or as remote resources. If the name is prefixed with http then it is assumed to be a remote resource and a WebRequest is made to retrieve the bitmap, otherwise it is assumed to be embedded in the assembly.

Syntax

Visual Basic (Declaration)
Public Shared Function GetBitmapResource( _
   ByVal bitmapResource As String, _
   ByVal limit As Limit, _
   ByVal ParamArray parameters() As String _
) As Bitmap
Visual Basic (Usage) Copy Code
Dim bitmapResource As String
Dim limit As Limit
Dim parameters() As String
Dim value As Bitmap

value = Limit.GetBitmapResource(bitmapResource, limit, parameters)
C#
public static Bitmap GetBitmapResource(
   string bitmapResource,
   Limit limit,
   params string[] parameters
)
Managed Extensions for C++
public: static Bitmap GetBitmapResource(
   string* bitmapResource,
   Limit* limit,
   params string*[] parameters
)
C++/CLI
public:
static Bitmap GetBitmapResource(
   String^ bitmapResource,
   Limit^ limit,
   ... array<String^> parameters
)

Parameters

bitmapResource
Name of the resource to retrieve, prefix with http to get a remote resource.
limit
The limit requesting the resource.
parameters
Collection of additional parameters to append to the URL for remote images. Parameters should be in the format "key=value".

Return Value

Returns the resource if found, otherwise null.

Remarks

For remote resources the serial number, expiration date, and optional parameters of the License will be appended to the request QueryString. You can use this to provide alternate images based on the conditions of the license.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetDetailsDescription Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : GetDetailsDescription Method

Gets a description of the details of the limit.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetDetailsDescription() As String
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As String

value = instance.GetDetailsDescription()
C#
public virtual string GetDetailsDescription()
Managed Extensions for C++
public: virtual string* GetDetailsDescription();
C++/CLI
public:
virtual String^ GetDetailsDescription();

Return Value

Returns the description.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetLimitFromName Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : GetLimitFromName Method

name
The name of the limit type to retrieve.
Gets a Limit object based on the given name.

Syntax

Visual Basic (Declaration)
Public Shared Function GetLimitFromName( _
   ByVal name As String _
) As Limit
Visual Basic (Usage) Copy Code
Dim name As String
Dim value As Limit

value = Limit.GetLimitFromName(name)
C#
public static Limit GetLimitFromName(
   string name
)
Managed Extensions for C++
public: static Limit* GetLimitFromName(
   string* name
)
C++/CLI
public:
static Limit^ GetLimitFromName(
   String^ name
)

Parameters

name
The name of the limit type to retrieve.

Return Value

Returns a new Limit object of the given type if available, otherwise null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetPrivateRegistryKey Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : GetPrivateRegistryKey Method

key
A unique key to identify this registry section.
mustExist
Indicates if the key must already exist.
created
Accepts a value that indicates if the key was created.
Gets a private registry key where values for the license can be stored for the given type.

Syntax

Visual Basic (Declaration)
Public Shared Function GetPrivateRegistryKey( _
   ByVal key As String, _
   ByVal mustExist As Boolean, _
   ByRef created As Boolean _
) As RegistryKey
Visual Basic (Usage) Copy Code
Dim key As String
Dim mustExist As Boolean
Dim created As Boolean
Dim value As RegistryKey

value = Limit.GetPrivateRegistryKey(key, mustExist, created)
C#
public static RegistryKey GetPrivateRegistryKey(
   string key,
   bool mustExist,
   out bool created
)
Managed Extensions for C++
public: static RegistryKey* GetPrivateRegistryKey(
   string* key,
   bool mustExist,
   [PARAMFLAG::Out] bool created
)
C++/CLI
public:
static RegistryKey^ GetPrivateRegistryKey(
   String^ key,
   bool mustExist,
   [PARAMFLAG::Out] bool created
)

Parameters

key
A unique key to identify this registry section.
mustExist
Indicates if the key must already exist.
created
Accepts a value that indicates if the key was created.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Granted Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Granted Method

context
The LicenseContext used to determine the environment and settings of the licensing.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
Called every time the limit is granted. Used to enforce limits that must be checked each time a Type is created.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Granted( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim context As LicenseContext
Dim type As Type
Dim instance As Object

instance.Granted(context, type, instance)
C#
public virtual void Granted(
   LicenseContext context,
   Type type,
   object instance
)
Managed Extensions for C++
public: virtual void Granted(
   LicenseContext context,
   Type* type,
   Object* instance
)
C++/CLI
public:
virtual void Granted(
   LicenseContext context,
   Type^ type,
   Object^ instance
)

Parameters

context
The LicenseContext used to determine the environment and settings of the licensing.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.

Remarks

Checks in this method should be very fast because they are called every time a licensed object is created. The default implementation does nothing.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : LoadFromXml Method

node
The XmlNode to load from.
Loads the contents of a Limit from an XmlNode.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride Function LoadFromXml( _
   ByVal node As XmlNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim node As XmlNode
Dim value As Boolean

value = instance.LoadFromXml(node)
C#
public virtual abstract bool LoadFromXml(
   XmlNode node
)
Managed Extensions for C++
public: virtual abstract bool LoadFromXml(
   XmlNode node
)
C++/CLI
public:
virtual abstract bool LoadFromXml(
   XmlNode node
)

Parameters

node
The XmlNode to load from.

Return Value

Returns true if the load was successful, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MaskValue Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : MaskValue Method

source
The original value.
Performs a simple value obfuscation to make editing client side values more difficult. This is by no means secure.

Syntax

Visual Basic (Declaration)
Public Shared Function MaskValue( _
   ByVal source As String _
) As String
Visual Basic (Usage) Copy Code
Dim source As String
Dim value As String

value = Limit.MaskValue(source)
C#
public static string MaskValue(
   string source
)
Managed Extensions for C++
public: static string* MaskValue(
   string* source
)
C++/CLI
public:
static String^ MaskValue(
   String^ source
)

Parameters

source
The original value.

Return Value

Returns the masked version of the value. Call UnmaskValue to obtain the original value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
OpenOrCreateRegistryKey Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : OpenOrCreateRegistryKey Method

key
The parent key to open from.
subkey
The path of the sub key to open. Sub key should be separated by \ characters.
Opens or creates a registry key.

Syntax

Visual Basic (Declaration)
Public Shared Function OpenOrCreateRegistryKey( _
   ByVal key As RegistryKey, _
   ByVal subkey As String _
) As RegistryKey
Visual Basic (Usage) Copy Code
Dim key As RegistryKey
Dim subkey As String
Dim value As RegistryKey

value = Limit.OpenOrCreateRegistryKey(key, subkey)
C#
public static RegistryKey OpenOrCreateRegistryKey(
   RegistryKey key,
   string subkey
)
Managed Extensions for C++
public: static RegistryKey* OpenOrCreateRegistryKey(
   RegistryKey* key,
   string* subkey
)
C++/CLI
public:
static RegistryKey^ OpenOrCreateRegistryKey(
   RegistryKey^ key,
   String^ subkey
)

Parameters

key
The parent key to open from.
subkey
The path of the sub key to open. Sub key should be separated by \ characters.

Return Value

Returns the opened or created registry key.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ParseIPAddress Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ParseIPAddress Method

address
IPAddress to parse.
Parses an IPAddress to it's actual long value.

Syntax

Visual Basic (Declaration)
Public Shared Function ParseIPAddress( _
   ByVal address As IPAddress _
) As Long
Visual Basic (Usage) Copy Code
Dim address As IPAddress
Dim value As Long

value = Limit.ParseIPAddress(address)
C#
public static long ParseIPAddress(
   IPAddress address
)
Managed Extensions for C++
public: static long ParseIPAddress(
   IPAddress address
)
C++/CLI
public:
static long ParseIPAddress(
   IPAddress address
)

Parameters

address
IPAddress to parse.

Return Value

Returns the actual address of the IPAddress.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Peek Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Peek Method

context
The LicenseContext used to determine the environment and settings of the licensing.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
Allows a limit to communicate it's valid status without interacting with the user. Used with Or limits to pick limits that are valid before attempting to interact with the user.

Syntax

Visual Basic (Declaration)
Public Overridable Function Peek( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object _
) As PeekResult
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim context As LicenseContext
Dim type As Type
Dim instance As Object
Dim value As PeekResult

value = instance.Peek(context, type, instance)
C#
public virtual PeekResult Peek(
   LicenseContext context,
   Type type,
   object instance
)
Managed Extensions for C++
public: virtual PeekResult Peek(
   LicenseContext context,
   Type* type,
   Object* instance
)
C++/CLI
public:
virtual PeekResult Peek(
   LicenseContext context,
   Type^ type,
   Object^ instance
)

Parameters

context
The LicenseContext used to determine the environment and settings of the licensing.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : SaveToXml Method

parent
The parent XmlNode to add child nodes to.
Saves the contents of the Limit as an XmlNode.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride Function SaveToXml( _
   ByVal parent As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim parent As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parent)
C#
public virtual abstract XmlNode SaveToXml(
   XmlNode parent
)
Managed Extensions for C++
public: virtual abstract XmlNode SaveToXml(
   XmlNode parent
)
C++/CLI
public:
virtual abstract XmlNode SaveToXml(
   XmlNode parent
)

Parameters

parent
The parent XmlNode to add child nodes to.

Return Value

Returns the saved XML node.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SelectCulture Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : SelectCulture Method

culture
The culture to select.
Selects the given culture for the current thread, and returns the previous culture.

Syntax

Visual Basic (Declaration)
Public Shared Function SelectCulture( _
   ByVal culture As CultureInfo _
) As CultureInfo
Visual Basic (Usage) Copy Code
Dim culture As CultureInfo
Dim value As CultureInfo

value = Limit.SelectCulture(culture)
C#
public static CultureInfo SelectCulture(
   CultureInfo culture
)
Managed Extensions for C++
public: static CultureInfo* SelectCulture(
   CultureInfo* culture
)
C++/CLI
public:
static CultureInfo^ SelectCulture(
   CultureInfo^ culture
)

Parameters

culture
The culture to select.

Return Value

Returns the previous culture.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SelectWebCulture Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : SelectWebCulture Method

Selects the culture of the current web request into the current thread, and returns the previous culture.

Syntax

Visual Basic (Declaration)
Public Shared Function SelectWebCulture() As CultureInfo
Visual Basic (Usage) Copy Code
Dim value As CultureInfo

value = Limit.SelectWebCulture()
C#
public static CultureInfo SelectWebCulture()
Managed Extensions for C++
public: static CultureInfo* SelectWebCulture();
C++/CLI
public:
static CultureInfo^ SelectWebCulture();

Return Value

Returns the previous culture.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
UnmaskValue Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : UnmaskValue Method

source
The original value.
Reverses the simple value obfuscation performed by MaskValue.

Syntax

Visual Basic (Declaration)
Public Shared Function UnmaskValue( _
   ByVal source As String _
) As String
Visual Basic (Usage) Copy Code
Dim source As String
Dim value As String

value = Limit.UnmaskValue(source)
C#
public static string UnmaskValue(
   string source
)
Managed Extensions for C++
public: static string* UnmaskValue(
   string* source
)
C++/CLI
public:
static String^ UnmaskValue(
   String^ source
)

Parameters

source
The original value.

Return Value

Returns the masked version of the value. Call UnmaskValue to obtain the original value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Validate Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Validate Method

context
The LicenseContext passed to GetLicense.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
Validates that the license being granted is within the limits enforced by this object.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride Function Validate( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim context As LicenseContext
Dim type As Type
Dim instance As Object
Dim value As Boolean

value = instance.Validate(context, type, instance)
C#
public virtual abstract bool Validate(
   LicenseContext context,
   Type type,
   object instance
)
Managed Extensions for C++
public: virtual abstract bool Validate(
   LicenseContext context,
   Type* type,
   Object* instance
)
C++/CLI
public:
virtual abstract bool Validate(
   LicenseContext context,
   Type^ type,
   Object^ instance
)

Parameters

context
The LicenseContext passed to GetLicense.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.

Return Value

Returns true if the limits are valid, otherwise false.

Remarks

If validation fails, limits should set their parent License's InvalidReason to a string explaining why it could not be validated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ValidateDomainName Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ValidateDomainName Method

domainName
The domain name to validate.
Validates the format of a domain name.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateDomainName( _
   ByVal domainName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim domainName As String
Dim value As Boolean

value = Limit.ValidateDomainName(domainName)
C#
public static bool ValidateDomainName(
   string domainName
)
Managed Extensions for C++
public: static bool ValidateDomainName(
   string* domainName
)
C++/CLI
public:
static bool ValidateDomainName(
   String^ domainName
)

Parameters

domainName
The domain name to validate.

Return Value

Returns true if the format of the domain name is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ValidateEmail Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ValidateEmail Method

email
The email address to validate.
Validates if the email is correctly formatted.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateEmail( _
   ByVal email As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim email As String
Dim value As Boolean

value = Limit.ValidateEmail(email)
C#
public static bool ValidateEmail(
   string email
)
Managed Extensions for C++
public: static bool ValidateEmail(
   string* email
)
C++/CLI
public:
static bool ValidateEmail(
   String^ email
)

Parameters

email
The email address to validate.

Return Value

Returns true if the email is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ValidateIPAddress Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ValidateIPAddress Method

address
The IP Address to validate.
Validates the format of an IP address.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateIPAddress( _
   ByVal address As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim address As String
Dim value As Boolean

value = Limit.ValidateIPAddress(address)
C#
public static bool ValidateIPAddress(
   string address
)
Managed Extensions for C++
public: static bool ValidateIPAddress(
   string* address
)
C++/CLI
public:
static bool ValidateIPAddress(
   String^ address
)

Parameters

address
The IP Address to validate.

Return Value

Returns true if the format of the address is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ValidateUrl Method
See Also
[image]
Xheo.Licensing Namespace > Limit Class : ValidateUrl Method

url
The url to validate.
fullyQualified
Indicates if the url must be fully qualified. Containing a host and optional protocol.
Validates the url is correctly formatted.

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateUrl( _
   ByVal url As String, _
   ByVal fullyQualified As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim url As String
Dim fullyQualified As Boolean
Dim value As Boolean

value = Limit.ValidateUrl(url, fullyQualified)
C#
public static bool ValidateUrl(
   string url,
   bool fullyQualified
)
Managed Extensions for C++
public: static bool ValidateUrl(
   string* url,
   bool fullyQualified
)
C++/CLI
public:
static bool ValidateUrl(
   String^ url,
   bool fullyQualified
)

Parameters

url
The url to validate.
fullyQualified
Indicates if the url must be fully qualified. Containing a host and optional protocol.

Return Value

Returns true if the url is valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.RS.Design Send comments on this topic.
Limit Class Properties
See Also
[image]
Xheo.Licensing Namespace : Limit Class

For a list of all members of this type, see Limit members.

Public Properties

 | Name | Description
Public Property | Description | Gets the description of the limit.
Public Property | IsGui | Gets a value that indicates if this Limit uses a GUI to interact with the user.
Public Property | IsRemote | Gets a value that indicates if this Limit uses remote processes (such as WebServices) for enforcement.
Public Property | IsTimeSensitive | Gets a value that indicates if the limit is time sensitive and the clock should be protected.
Public Property | License | Gets or sets a reference to the ExtendedLicense that contains this Limit.
Public Property | Name | Gets the display name of the limit.
Public Property | QualifiedTypeName | Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type.
Top

See Also

Reference

Limit Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Description Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Description Property

Gets the description of the limit.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride ReadOnly Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As String

value = instance.Description
C#
public virtual abstract string Description {get;}
Managed Extensions for C++
public: __property virtual abstract string* get_Description();
C++/CLI
public:
virtual abstract property String^ Description {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IsGui Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : IsGui Property

Gets a value that indicates if this Limit uses a GUI to interact with the user.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsGui As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As Boolean

value = instance.IsGui
C#
public virtual bool IsGui {get;}
Managed Extensions for C++
public: __property virtual bool get_IsGui();
C++/CLI
public:
virtual property bool IsGui {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IsRemote Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : IsRemote Property

Gets a value that indicates if this Limit uses remote processes (such as WebServices) for enforcement.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsRemote As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As Boolean

value = instance.IsRemote
C#
public virtual bool IsRemote {get;}
Managed Extensions for C++
public: __property virtual bool get_IsRemote();
C++/CLI
public:
virtual property bool IsRemote {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IsTimeSensitive Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : IsTimeSensitive Property

Gets a value that indicates if the limit is time sensitive and the clock should be protected.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsTimeSensitive As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As Boolean

value = instance.IsTimeSensitive
C#
public virtual bool IsTimeSensitive {get;}
Managed Extensions for C++
public: __property virtual bool get_IsTimeSensitive();
C++/CLI
public:
virtual property bool IsTimeSensitive {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
License Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : License Property

Gets or sets a reference to the ExtendedLicense that contains this Limit.

Syntax

Visual Basic (Declaration)
Public Property License As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As ExtendedLicense

instance.License = value

value = instance.License
C#
public ExtendedLicense License {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_License();
public: __property void set_License(
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ License {
   ExtendedLicense^ get();
   void set (ExtendedLicense^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Name Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : Name Property

Gets the display name of the limit.

Syntax

Visual Basic (Declaration)
Public Overridable MustOverride ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As String

value = instance.Name
C#
public virtual abstract string Name {get;}
Managed Extensions for C++
public: __property virtual abstract string* get_Name();
C++/CLI
public:
virtual abstract property String^ Name {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
QualifiedTypeName Property
See Also
[image]
Xheo.Licensing Namespace > Limit Class : QualifiedTypeName Property

Gets a string to be used for loading the custom limit. The defualt is the fully qualified assembly name of the type.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property QualifiedTypeName As String
Visual Basic (Usage) Copy Code
Dim instance As Limit
Dim value As String

value = instance.QualifiedTypeName
C#
public virtual string QualifiedTypeName {get;}
Managed Extensions for C++
public: __property virtual string* get_QualifiedTypeName();
C++/CLI
public:
virtual property String^ QualifiedTypeName {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Limit Class
Limit Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LimitCollection Class
See Also Members
[image]
Xheo.Licensing Namespace : LimitCollection Class

Services as a collection of limits.

Object Model

Syntax

Visual Basic (Declaration)
Private Class LimitCollection
   Inherits TransientReadOnlyCollection
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
C#
private class LimitCollection : TransientReadOnlyCollection
Managed Extensions for C++
private __gc class LimitCollection : public TransientReadOnlyCollection
C++/CLI
private ref class LimitCollection : public TransientReadOnlyCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Xheo.Licensing.TransientReadOnlyCollection
Xheo.Licensing.LimitCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
LimitCollection Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : LimitCollection Class

The following tables list the members exposed by LimitCollection.

Public Constructors

 | Name | Description
Public Constructor | LimitCollection Constructor | Overloaded. Initializes a new instance of the LimitCollection class.
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating if the collection is read only. (Inherited from TransientReadOnlyCollection)
Public Property | Item | Gets or sets a limit at the given index.
Public Property | License | Gets or sets a reference to the containing license.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a new limit to the collection.
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines if the collection contains the given Limit.
Public Method | CopyTo | Copies the collection to an array.
Public Method | FromXmlString | Loads the contents of the limit collection from an XML string.
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetPrioritizedOrder | Gets the limits in order of priority.
Public Method | Granted | Called every time the limit is granted.
Public Method | IndexOf | Gets the index of the given limit.
Public Method | Insert | Inserts the limit at the given index.
Public Method | LoadFromXml | Loads the contents of a LimitCollection from an XmlNode.
Public Method | Remove | Removes the given index from the list.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | SaveToXml | Saves the contents of the LimitCollection to the given XmlNode.
Public Method | SetReadOnly | Sets the collection to a read only state. This cannot be reversed. (Inherited from TransientReadOnlyCollection)
Public Method | ToXmlString | Saves the contents of the limit collection to an XML string.
Public Method | Validate | Ensures that all the Limits in the collection are valid for the given type and context.
Top

See Also

Reference

LimitCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LimitCollection Constructor
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : LimitCollection Constructor

Initializes a new instance of the LimitCollection class.

Overload List

Overload | Description
LimitCollection Constructor() | Included for COM compliance, do not use.
LimitCollection Constructor(ExtendedLicense) | Initializes a new instance of the LimitCollection class.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LimitCollection Constructor()
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class > LimitCollection Constructor : LimitCollection Constructor()

Included for COM compliance, do not use.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection()
C#
public LimitCollection()
Managed Extensions for C++
public: LimitCollection();
C++/CLI
public:
LimitCollection();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LimitCollection Constructor(ExtendedLicense)
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class > LimitCollection Constructor : LimitCollection Constructor(ExtendedLicense)

license
Reference to the containing ExtendedLicense.
Initializes a new instance of the LimitCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal license As ExtendedLicense _
)
Visual Basic (Usage) Copy Code
Dim license As ExtendedLicense

Dim instance As LimitCollection(license)
C#
public LimitCollection(
   ExtendedLicense license
)
Managed Extensions for C++
public: LimitCollection(
   ExtendedLicense* license
)
C++/CLI
public:
LimitCollection(
   ExtendedLicense^ license
)

Parameters

license
Reference to the containing ExtendedLicense.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
LimitCollection Class Methods
See Also
[image]
Xheo.Licensing Namespace : LimitCollection Class

For a list of all members of this type, see LimitCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a new limit to the collection.
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines if the collection contains the given Limit.
Public Method | CopyTo | Copies the collection to an array.
Public Method | FromXmlString | Loads the contents of the limit collection from an XML string.
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetPrioritizedOrder | Gets the limits in order of priority.
Public Method | Granted | Called every time the limit is granted.
Public Method | IndexOf | Gets the index of the given limit.
Public Method | Insert | Inserts the limit at the given index.
Public Method | LoadFromXml | Loads the contents of a LimitCollection from an XmlNode.
Public Method | Remove | Removes the given index from the list.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | SaveToXml | Saves the contents of the LimitCollection to the given XmlNode.
Public Method | SetReadOnly | Sets the collection to a read only state. This cannot be reversed. (Inherited from TransientReadOnlyCollection)
Public Method | ToXmlString | Saves the contents of the limit collection to an XML string.
Public Method | Validate | Ensures that all the Limits in the collection are valid for the given type and context.
Top

See Also

Reference

LimitCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Add Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Add Method

limit
The limit to add.
Adds a new limit to the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal limit As Limit _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim limit As Limit

instance.Add(limit)
C#
public void Add(
   Limit limit
)
Managed Extensions for C++
public: void Add(
   Limit* limit
)
C++/CLI
public:
void Add(
   Limit^ limit
)

Parameters

limit
The limit to add.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Contains Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Contains Method

limit
The Limit to look for.
Determines if the collection contains the given Limit.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal limit As Limit _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim limit As Limit
Dim value As Boolean

value = instance.Contains(limit)
C#
public bool Contains(
   Limit limit
)
Managed Extensions for C++
public: bool Contains(
   Limit* limit
)
C++/CLI
public:
bool Contains(
   Limit^ limit
)

Parameters

limit
The Limit to look for.

Return Value

Returns true if the Limit is found, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
CopyTo Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : CopyTo Method

array
The array to copy to.
index
The index in the array to begin copying.
Copies the collection to an array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As Limit, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim array() As Limit
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   Limit[] array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   Limit*[] array,
   int index
)
C++/CLI
public:
void CopyTo(
   array<Limit^> array,
   int index
)

Parameters

array
The array to copy to.
index
The index in the array to begin copying.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
FromXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : FromXmlString Method

xml
The XML string to load from.
Loads the contents of the limit collection from an XML string.

Syntax

Visual Basic (Declaration)
Public Sub FromXmlString( _
   ByVal xml As String _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim xml As String

instance.FromXmlString(xml)
C#
public void FromXmlString(
   string xml
)
Managed Extensions for C++
public: void FromXmlString(
   string* xml
)
C++/CLI
public:
void FromXmlString(
   String^ xml
)

Parameters

xml
The XML string to load from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetPrioritizedOrder Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : GetPrioritizedOrder Method

includeRemote
Indicates if remote limits should be included.
Gets the limits in order of priority.

Syntax

Visual Basic (Declaration)
Public Function GetPrioritizedOrder( _
   ByVal includeRemote As Boolean _
) As LimitCollection
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim includeRemote As Boolean
Dim value As LimitCollection

value = instance.GetPrioritizedOrder(includeRemote)
C#
public LimitCollection GetPrioritizedOrder(
   bool includeRemote
)
Managed Extensions for C++
public: LimitCollection* GetPrioritizedOrder(
   bool includeRemote
)
C++/CLI
public:
LimitCollection^ GetPrioritizedOrder(
   bool includeRemote
)

Parameters

includeRemote
Indicates if remote limits should be included.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Granted Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Granted Method

context
type
instance
Called every time the limit is granted.

Syntax

Visual Basic (Declaration)
Public Sub Granted( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim context As LicenseContext
Dim type As Type
Dim instance As Object

instance.Granted(context, type, instance)
C#
public void Granted(
   LicenseContext context,
   Type type,
   object instance
)
Managed Extensions for C++
public: void Granted(
   LicenseContext context,
   Type* type,
   Object* instance
)
C++/CLI
public:
void Granted(
   LicenseContext context,
   Type^ type,
   Object^ instance
)

Parameters

context
type
instance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IndexOf Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : IndexOf Method

limit
The limit to look for.
Gets the index of the given limit.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal limit As Limit _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim limit As Limit
Dim value As Integer

value = instance.IndexOf(limit)
C#
public int IndexOf(
   Limit limit
)
Managed Extensions for C++
public: int IndexOf(
   Limit* limit
)
C++/CLI
public:
int IndexOf(
   Limit^ limit
)

Parameters

limit
The limit to look for.

Return Value

Returns the index of the given limit if found, otherwise -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Insert Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Insert Method

index
The index where to insert the limit.
limit
The limit to insert.
Inserts the limit at the given index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal limit As Limit _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim index As Integer
Dim limit As Limit

instance.Insert(index, limit)
C#
public void Insert(
   int index,
   Limit limit
)
Managed Extensions for C++
public: void Insert(
   int index,
   Limit* limit
)
C++/CLI
public:
void Insert(
   int index,
   Limit^ limit
)

Parameters

index
The index where to insert the limit.
limit
The limit to insert.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LoadFromXml Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : LoadFromXml Method

node
Loads the contents of a LimitCollection from an XmlNode.

Syntax

Visual Basic (Declaration)
Public Function LoadFromXml( _
   ByVal node As XmlNode _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim node As XmlNode
Dim value As Boolean

value = instance.LoadFromXml(node)
C#
public bool LoadFromXml(
   XmlNode node
)
Managed Extensions for C++
public: bool LoadFromXml(
   XmlNode node
)
C++/CLI
public:
bool LoadFromXml(
   XmlNode node
)

Parameters

node

Return Value

Returns true if the load was successful, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Remove Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Remove Method

limit
The limit to remove.
Removes the given index from the list.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal limit As Limit _
)
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim limit As Limit

instance.Remove(limit)
C#
public void Remove(
   Limit limit
)
Managed Extensions for C++
public: void Remove(
   Limit* limit
)
C++/CLI
public:
void Remove(
   Limit^ limit
)

Parameters

limit
The limit to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SaveToXml Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : SaveToXml Method

parent
The parent XmlNode.
Saves the contents of the LimitCollection to the given XmlNode.

Syntax

Visual Basic (Declaration)
Public Function SaveToXml( _
   ByVal parent As XmlNode _
) As XmlNode
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim parent As XmlNode
Dim value As XmlNode

value = instance.SaveToXml(parent)
C#
public XmlNode SaveToXml(
   XmlNode parent
)
Managed Extensions for C++
public: XmlNode SaveToXml(
   XmlNode parent
)
C++/CLI
public:
XmlNode SaveToXml(
   XmlNode parent
)

Parameters

parent
The parent XmlNode.

Return Value

Returns the root node of the saved limits.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ToXmlString Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : ToXmlString Method

Saves the contents of the limit collection to an XML string.

Syntax

Visual Basic (Declaration)
Public Function ToXmlString() As String
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim value As String

value = instance.ToXmlString()
C#
public string ToXmlString()
Managed Extensions for C++
public: string* ToXmlString();
C++/CLI
public:
String^ ToXmlString();

Return Value

The saved XML.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Validate Method
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Validate Method

context
The LicenseContext passed to GetLicense.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
includeRemote
Indicates if limits that have IsRemote set to true should be included in the validation.
Ensures that all the Limits in the collection are valid for the given type and context.

Syntax

Visual Basic (Declaration)
Public Overridable Function Validate( _
   ByVal context As LicenseContext, _
   ByVal type As Type, _
   ByVal instance As Object, _
   ByVal includeRemote As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim context As LicenseContext
Dim type As Type
Dim instance As Object
Dim includeRemote As Boolean
Dim value As Boolean

value = instance.Validate(context, type, instance, includeRemote)
C#
public virtual bool Validate(
   LicenseContext context,
   Type type,
   object instance,
   bool includeRemote
)
Managed Extensions for C++
public: virtual bool Validate(
   LicenseContext context,
   Type* type,
   Object* instance,
   bool includeRemote
)
C++/CLI
public:
virtual bool Validate(
   LicenseContext context,
   Type^ type,
   Object^ instance,
   bool includeRemote
)

Parameters

context
The LicenseContext passed to GetLicense.
type
The Type of the object being licensed.
instance
The instance of the object being licensed.
includeRemote
Indicates if limits that have IsRemote set to true should be included in the validation.

Return Value

Returns true if the limits are valid, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.RS.Design Send comments on this topic.
LimitCollection Class Properties
See Also
[image]
Xheo.Licensing Namespace : LimitCollection Class

For a list of all members of this type, see LimitCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating if the collection is read only. (Inherited from TransientReadOnlyCollection)
Public Property | Item | Gets or sets a limit at the given index.
Public Property | License | Gets or sets a reference to the containing license.
Top

See Also

Reference

LimitCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Item Property
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : Item Property

index
Gets or sets a limit at the given index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Limit
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim index As Integer
Dim value As Limit

instance.Item(index) = value

value = instance.Item(index)
C#
public Limit this[
   int index
]; {get; set;}
Managed Extensions for C++
public: __property Limit* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   Limit* value
);
C++/CLI
public:
property Limit^ default [int] {
   Limit^ get(int index);
   void set (int index, Limit^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
License Property
See Also
[image]
Xheo.Licensing Namespace > LimitCollection Class : License Property

Gets or sets a reference to the containing license.

Syntax

Visual Basic (Declaration)
Public Property License As ExtendedLicense
Visual Basic (Usage) Copy Code
Dim instance As LimitCollection
Dim value As ExtendedLicense

instance.License = value

value = instance.License
C#
public ExtendedLicense License {get; set;}
Managed Extensions for C++
public: __property ExtendedLicense* get_License();
public: __property void set_License(
   ExtendedLicense* value
);
C++/CLI
public:
property ExtendedLicense^ License {
   ExtendedLicense^ get();
   void set (ExtendedLicense^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LimitCollection Class
LimitCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile Class
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile Class

Manages a machine profile used by the license activation system. Profiles represent a collection of generally non volitale system properties that can collectively be used to identify certain machines.

Syntax

Visual Basic (Declaration)
Private NotInheritable Class MachineProfile
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
C#
private sealed class MachineProfile
Managed Extensions for C++
private __gc __sealed class MachineProfile
C++/CLI
private ref class MachineProfile sealed

Inheritance Hierarchy

System.Object
Xheo.Licensing.MachineProfile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : MachineProfile Class

The following tables list the members exposed by MachineProfile.

Public Constructors

 | Name | Description
Public Constructor | MachineProfile Constructor | Initializes a new instance of the MachineProfile class.
Top

Public Properties

 | Name | Description
Public Property | Hash | Gets the comparable hash for the MachineProfile.
static (Shared in Visual Basic) | Profile | Gets the profile of the current machine.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CompareHash | Compares two machine profile hashes and determines the amount of difference.
Public Method | CompareTo | Determines if the MachineProfile is comparatively similar to the given hash.
Public Method | GetComparableHash | Overloaded. Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.
static (Shared in Visual Basic) | GetDifferences | Gets the name of the hardware types that are different between the two hashes.
Top

See Also

Reference

MachineProfile Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile Constructor
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : MachineProfile Constructor

Initializes a new instance of the MachineProfile class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile()
C#
public MachineProfile()
Managed Extensions for C++
public: MachineProfile();
C++/CLI
public:
MachineProfile();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile Class Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile Class

For a list of all members of this type, see MachineProfile members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CompareHash | Compares two machine profile hashes and determines the amount of difference.
Public Method | CompareTo | Determines if the MachineProfile is comparatively similar to the given hash.
Public Method | GetComparableHash | Overloaded. Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.
static (Shared in Visual Basic) | GetDifferences | Gets the name of the hardware types that are different between the two hashes.
Top

See Also

Reference

MachineProfile Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
CompareHash Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : CompareHash Method

hash
The of the machine to compare.
comparedHash
The hashed value of another machine profile to compare to.
Compares two machine profile hashes and determines the amount of difference.

Syntax

Visual Basic (Declaration)
Public Shared Function CompareHash( _
   ByVal hash As String, _
   ByVal comparedHash As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim hash As String
Dim comparedHash As String
Dim value As Integer

value = MachineProfile.CompareHash(hash, comparedHash)
C#
public static int CompareHash(
   string hash,
   string comparedHash
)
Managed Extensions for C++
public: static int CompareHash(
   string* hash,
   string* comparedHash
)
C++/CLI
public:
static int CompareHash(
   String^ hash,
   String^ comparedHash
)

Parameters

hash
The of the machine to compare.
comparedHash
The hashed value of another machine profile to compare to.

Return Value

Returns the difference rating from 0 (same) to 10 (very different).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
CompareTo Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : CompareTo Method

profileHash
The hash to compare to.
tolerance
The tolerance level.
Determines if the MachineProfile is comparatively similar to the given hash.

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal profileHash As String, _
   ByVal tolerance As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
Dim profileHash As String
Dim tolerance As Integer
Dim value As Boolean

value = instance.CompareTo(profileHash, tolerance)
C#
public bool CompareTo(
   string profileHash,
   int tolerance
)
Managed Extensions for C++
public: bool CompareTo(
   string* profileHash,
   int tolerance
)
C++/CLI
public:
bool CompareTo(
   String^ profileHash,
   int tolerance
)

Parameters

profileHash
The hash to compare to.
tolerance
The tolerance level.

Return Value

Returns true if the current machine profile is within the tolerance level of the given profile hash.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetComparableHash Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : GetComparableHash Method

Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.

Overload List

Overload | Description
GetComparableHash(Version) | Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.
GetComparableHash() | Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetComparableHash(Version) Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class > GetComparableHash Method : GetComparableHash(Version) Method

version
The hash version to generate. Use to create backwards compatible hash codes.
Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetComparableHash( _
   ByVal version As Version _
) As String
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
Dim version As Version
Dim value As String

value = instance.GetComparableHash(version)
C#
public string GetComparableHash(
   Version version
)
Managed Extensions for C++
public: string* GetComparableHash(
   Version* version
)
C++/CLI
public:
String^ GetComparableHash(
   Version^ version
)

Parameters

version
The hash version to generate. Use to create backwards compatible hash codes.

Return Value

Returns a comparable has for the current machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetComparableHash() Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class > GetComparableHash Method : GetComparableHash() Method

Creates a comparable hash value for the current profile. The hash can be used to compare how similar one machine profile is to another without actually having knowledge of the exact machine characteristics.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetComparableHash() As String
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
Dim value As String

value = instance.GetComparableHash()
C#
public string GetComparableHash()
Managed Extensions for C++
public: string* GetComparableHash();
C++/CLI
public:
String^ GetComparableHash();

Return Value

Returns a comparable has for the current machine.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetDifferences Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : GetDifferences Method

hash
The of the machine to compare.
comparedHash
The hashed value of another machine profile to compare to.
Gets the name of the hardware types that are different between the two hashes.

Syntax

Visual Basic (Declaration)
Public Shared Function GetDifferences( _
   ByVal hash As String, _
   ByVal comparedHash As String _
) As String()
Visual Basic (Usage) Copy Code
Dim hash As String
Dim comparedHash As String
Dim value() As String

value = MachineProfile.GetDifferences(hash, comparedHash)
C#
public static string[] GetDifferences(
   string hash,
   string comparedHash
)
Managed Extensions for C++
public: static string*[] GetDifferences(
   string* hash,
   string* comparedHash
)
C++/CLI
public:
static array<String^> GetDifferences(
   String^ hash,
   String^ comparedHash
)

Parameters

hash
The of the machine to compare.
comparedHash
The hashed value of another machine profile to compare to.

Return Value

Returns the collection of hardware changes detected between the two hashes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile Class Properties
See Also
[image]
Xheo.Licensing Namespace : MachineProfile Class

For a list of all members of this type, see MachineProfile members.

Public Properties

 | Name | Description
Public Property | Hash | Gets the comparable hash for the MachineProfile.
static (Shared in Visual Basic) | Profile | Gets the profile of the current machine.
Top

See Also

Reference

MachineProfile Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Hash Property
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : Hash Property

Gets the comparable hash for the MachineProfile.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hash As String
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile
Dim value As String

value = instance.Hash
C#
public string Hash {get;}
Managed Extensions for C++
public: __property string* get_Hash();
C++/CLI
public:
property String^ Hash {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Profile Property
See Also
[image]
Xheo.Licensing Namespace > MachineProfile Class : Profile Property

Gets the profile of the current machine.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Profile As MachineProfile
Visual Basic (Usage) Copy Code
Dim value As MachineProfile

value = MachineProfile.Profile
C#
public static MachineProfile Profile {get;}
Managed Extensions for C++
public: __property static MachineProfile* get_Profile();
C++/CLI
public:
static property MachineProfile^ Profile {
   MachineProfile^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile Class
MachineProfile Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.Constants Class
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.Constants Class

A class to contain the constants required for the IP_ADAPTER_INFO struct

Syntax

Visual Basic (Declaration)
Private Class MachineProfile.Constants
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.Constants
C#
private class MachineProfile.Constants
Managed Extensions for C++
private __gc class MachineProfile.Constants
C++/CLI
private ref class MachineProfile.Constants

Inheritance Hierarchy

System.Object
Xheo.Licensing.MachineProfile.Constants

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.Constants Class Members
See Also Fields
[image]
Xheo.Licensing Namespace : MachineProfile.Constants Class

The following tables list the members exposed by MachineProfile.Constants.

Public Constructors

 | Name | Description
Public Constructor | MachineProfile.Constants Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MAX_ADAPTER_ADDRESS_LENGTH | The maximum length for the physical address of the adapter
static (Shared in Visual Basic) | MAX_ADAPTER_DESCRIPTION_LENGTH | The maximum length of the description of an adapter
static (Shared in Visual Basic) | MAX_ADAPTER_NAME_LENGTH | The maximum length of an adapter name
Top

See Also

Reference

MachineProfile.Constants Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.Constants Constructor
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.Constants Class : MachineProfile.Constants Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.Constants()
C#
public MachineProfile.Constants()
Managed Extensions for C++
public: MachineProfile.Constants();
C++/CLI
public:
MachineProfile.Constants();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Class
MachineProfile.Constants Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.Constants Class Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.Constants Class

For a list of all members of this type, see MachineProfile.Constants members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MAX_ADAPTER_ADDRESS_LENGTH | The maximum length for the physical address of the adapter
static (Shared in Visual Basic) | MAX_ADAPTER_DESCRIPTION_LENGTH | The maximum length of the description of an adapter
static (Shared in Visual Basic) | MAX_ADAPTER_NAME_LENGTH | The maximum length of an adapter name
Top

See Also

Reference

MachineProfile.Constants Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MAX_ADAPTER_ADDRESS_LENGTH Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.Constants Class : MAX_ADAPTER_ADDRESS_LENGTH Field

The maximum length for the physical address of the adapter

Syntax

Visual Basic (Declaration)
Public Shared MAX_ADAPTER_ADDRESS_LENGTH As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = MachineProfile.Constants.MAX_ADAPTER_ADDRESS_LENGTH

MachineProfile.Constants.MAX_ADAPTER_ADDRESS_LENGTH = value
C#
public static int MAX_ADAPTER_ADDRESS_LENGTH
Managed Extensions for C++
public: static int MAX_ADAPTER_ADDRESS_LENGTH
C++/CLI
public:
static int MAX_ADAPTER_ADDRESS_LENGTH

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Class
MachineProfile.Constants Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MAX_ADAPTER_DESCRIPTION_LENGTH Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.Constants Class : MAX_ADAPTER_DESCRIPTION_LENGTH Field

The maximum length of the description of an adapter

Syntax

Visual Basic (Declaration)
Public Shared MAX_ADAPTER_DESCRIPTION_LENGTH As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = MachineProfile.Constants.MAX_ADAPTER_DESCRIPTION_LENGTH

MachineProfile.Constants.MAX_ADAPTER_DESCRIPTION_LENGTH = value
C#
public static int MAX_ADAPTER_DESCRIPTION_LENGTH
Managed Extensions for C++
public: static int MAX_ADAPTER_DESCRIPTION_LENGTH
C++/CLI
public:
static int MAX_ADAPTER_DESCRIPTION_LENGTH

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Class
MachineProfile.Constants Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MAX_ADAPTER_NAME_LENGTH Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.Constants Class : MAX_ADAPTER_NAME_LENGTH Field

The maximum length of an adapter name

Syntax

Visual Basic (Declaration)
Public Shared MAX_ADAPTER_NAME_LENGTH As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = MachineProfile.Constants.MAX_ADAPTER_NAME_LENGTH

MachineProfile.Constants.MAX_ADAPTER_NAME_LENGTH = value
C#
public static int MAX_ADAPTER_NAME_LENGTH
Managed Extensions for C++
public: static int MAX_ADAPTER_NAME_LENGTH
C++/CLI
public:
static int MAX_ADAPTER_NAME_LENGTH

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.Constants Class
MachineProfile.Constants Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.GetAdapterInfo Class
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.GetAdapterInfo Class

Uses the windows API to retrieve information about the IP configuration of the local machine

Syntax

Visual Basic (Declaration)
Private Class MachineProfile.GetAdapterInfo
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.GetAdapterInfo
C#
private class MachineProfile.GetAdapterInfo
Managed Extensions for C++
private __gc class MachineProfile.GetAdapterInfo
C++/CLI
private ref class MachineProfile.GetAdapterInfo

Inheritance Hierarchy

System.Object
Xheo.Licensing.MachineProfile.GetAdapterInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.GetAdapterInfo Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.GetAdapterInfo Class Members
See Also Methods
[image]
Xheo.Licensing Namespace : MachineProfile.GetAdapterInfo Class

The following tables list the members exposed by MachineProfile.GetAdapterInfo.

Public Constructors

 | Name | Description
Public Constructor | MachineProfile.GetAdapterInfo Constructor | Constructor for the GetAdapterInfo Class
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetAdapters | Gets details of all the adapters on the local machine
static (Shared in Visual Basic) | GetFirstAdapter | Gets the details of the first available adapter on the local machine
Top

See Also

Reference

MachineProfile.GetAdapterInfo Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.GetAdapterInfo Constructor
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.GetAdapterInfo Class : MachineProfile.GetAdapterInfo Constructor

Constructor for the GetAdapterInfo Class

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.GetAdapterInfo()
C#
public MachineProfile.GetAdapterInfo()
Managed Extensions for C++
public: MachineProfile.GetAdapterInfo();
C++/CLI
public:
MachineProfile.GetAdapterInfo();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.GetAdapterInfo Class
MachineProfile.GetAdapterInfo Members


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.GetAdapterInfo Class Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.GetAdapterInfo Class

For a list of all members of this type, see MachineProfile.GetAdapterInfo members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetAdapters | Gets details of all the adapters on the local machine
static (Shared in Visual Basic) | GetFirstAdapter | Gets the details of the first available adapter on the local machine
Top

See Also

Reference

MachineProfile.GetAdapterInfo Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetAdapters Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.GetAdapterInfo Class : GetAdapters Method

Gets details of all the adapters on the local machine

Syntax

Visual Basic (Declaration)
Public Shared Function GetAdapters() As ArrayList
Visual Basic (Usage) Copy Code
Dim value As ArrayList

value = MachineProfile.GetAdapterInfo.GetAdapters()
C#
public static ArrayList GetAdapters()
Managed Extensions for C++
public: static ArrayList* GetAdapters();
C++/CLI
public:
static ArrayList^ GetAdapters();

Return Value

The return object is a System.Collections.ArrayList of IPConfig.IP_ADAPTERINFO_STRUCTURE structs containing data about the Adapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.GetAdapterInfo Class
MachineProfile.GetAdapterInfo Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GetFirstAdapter Method
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.GetAdapterInfo Class : GetFirstAdapter Method

Gets the details of the first available adapter on the local machine

Syntax

Visual Basic (Declaration)
Public Shared Function GetFirstAdapter() As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Visual Basic (Usage) Copy Code
Dim value As MachineProfile.IP_ADAPTERINFO_STRUCTURE

value = MachineProfile.GetAdapterInfo.GetFirstAdapter()
C#
public static MachineProfile.IP_ADAPTERINFO_STRUCTURE GetFirstAdapter()
Managed Extensions for C++
public: static MachineProfile.IP_ADAPTERINFO_STRUCTURE GetFirstAdapter();
C++/CLI
public:
static MachineProfile.IP_ADAPTERINFO_STRUCTURE GetFirstAdapter();

Return Value

The return value is an struct of type IP_ADAPTERINFO_STRUCTURE containing data about the Adapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.GetAdapterInfo Class
MachineProfile.GetAdapterInfo Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
StateEntry Class
See Also Members
[image]
Xheo.Licensing Namespace : StateEntry Class

Syntax

Visual Basic (Declaration)
Private Class StateEntry
Visual Basic (Usage) Copy Code
Dim instance As StateEntry
C#
private class StateEntry
Managed Extensions for C++
private __gc class StateEntry
C++/CLI
private ref class StateEntry

Inheritance Hierarchy

System.Object
Xheo.Licensing.StateEntry

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateEntry Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
StateEntry Class Members
See Also Fields
[image]
Xheo.Licensing Namespace : StateEntry Class

The following tables list the members exposed by StateEntry.

Public Constructors

 | Name | Description
Public Constructor | StateEntry Constructor |
Top

Public Fields

 | Name | Description
Public Field | LastUsed |
Public Field | SessionState |
Top

See Also

Reference

StateEntry Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
StateEntry Constructor
See Also
[image]
Xheo.Licensing Namespace > StateEntry Class : StateEntry Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StateEntry()
C#
public StateEntry()
Managed Extensions for C++
public: StateEntry();
C++/CLI
public:
StateEntry();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateEntry Class
StateEntry Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.RS.Design Send comments on this topic.
StateEntry Class Fields
See Also
[image]
Xheo.Licensing Namespace : StateEntry Class

For a list of all members of this type, see StateEntry members.

Public Fields

 | Name | Description
Public Field | LastUsed |
Public Field | SessionState |
Top

See Also

Reference

StateEntry Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LastUsed Field
See Also
[image]
Xheo.Licensing Namespace > StateEntry Class : LastUsed Field

Syntax

Visual Basic (Declaration)
Public LastUsed As Date
Visual Basic (Usage) Copy Code
Dim instance As StateEntry
Dim value As Date

value = instance.LastUsed

instance.LastUsed = value
C#
public DateTime LastUsed
Managed Extensions for C++
public: DateTime LastUsed
C++/CLI
public:
DateTime LastUsed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateEntry Class
StateEntry Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SessionState Field
See Also
[image]
Xheo.Licensing Namespace > StateEntry Class : SessionState Field

Syntax

Visual Basic (Declaration)
Public SessionState As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As StateEntry
Dim value As Hashtable

value = instance.SessionState

instance.SessionState = value
C#
public Hashtable SessionState
Managed Extensions for C++
public: Hashtable* SessionState
C++/CLI
public:
Hashtable^ SessionState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

StateEntry Class
StateEntry Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
TransientReadOnlyCollection Class
See Also Members
[image]
Xheo.Licensing Namespace : TransientReadOnlyCollection Class

Implements a transient read only collection. Values can be added, removed and changed until the SetReadOnly method is called thus forcing the collection to a read only state.

Syntax

Visual Basic (Declaration)
Private MustInherit Class TransientReadOnlyCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As TransientReadOnlyCollection
C#
private abstract class TransientReadOnlyCollection : CollectionBase
Managed Extensions for C++
private __gc abstract class TransientReadOnlyCollection : public CollectionBase
C++/CLI
private ref class TransientReadOnlyCollection abstract : public CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Xheo.Licensing.TransientReadOnlyCollection
Xheo.Licensing.LimitCollection
Xheo.Licensing.LimitCollection
Xheo.Licensing.LimitCollection
Xheo.Licensing.LimitCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TransientReadOnlyCollection Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
TransientReadOnlyCollection Class Members
See Also Properties Methods
[image]
Xheo.Licensing Namespace : TransientReadOnlyCollection Class

The following tables list the members exposed by TransientReadOnlyCollection.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating if the collection is read only.
Top

Public Methods

 | Name | Description
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | SetReadOnly | Sets the collection to a read only state. This cannot be reversed.
Top

See Also

Reference

TransientReadOnlyCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
TransientReadOnlyCollection Class Methods
See Also
[image]
Xheo.Licensing Namespace : TransientReadOnlyCollection Class

For a list of all members of this type, see TransientReadOnlyCollection members.

Public Methods

 | Name | Description
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | SetReadOnly | Sets the collection to a read only state. This cannot be reversed.
Top

See Also

Reference

TransientReadOnlyCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SetReadOnly Method
See Also
[image]
Xheo.Licensing Namespace > TransientReadOnlyCollection Class : SetReadOnly Method

Sets the collection to a read only state. This cannot be reversed.

Syntax

Visual Basic (Declaration)
Public Sub SetReadOnly()
Visual Basic (Usage) Copy Code
Dim instance As TransientReadOnlyCollection

instance.SetReadOnly()
C#
public void SetReadOnly()
Managed Extensions for C++
public: void SetReadOnly();
C++/CLI
public:
void SetReadOnly();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TransientReadOnlyCollection Class
TransientReadOnlyCollection Members


%%PageItemTitle%% $$Properties$$

Barcode4NET.RS.Design Send comments on this topic.
TransientReadOnlyCollection Class Properties
See Also
[image]
Xheo.Licensing Namespace : TransientReadOnlyCollection Class

For a list of all members of this type, see TransientReadOnlyCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating if the collection is read only.
Top

See Also

Reference

TransientReadOnlyCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IsReadOnly Property
See Also
[image]
Xheo.Licensing Namespace > TransientReadOnlyCollection Class : IsReadOnly Property

Gets a value indicating if the collection is read only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TransientReadOnlyCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TransientReadOnlyCollection Class
TransientReadOnlyCollection Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
PeekResult Enumeration
See Also
[image]
Xheo.Licensing Namespace : PeekResult Enumeration

Possible results from the Peek method.

Syntax

Visual Basic (Declaration)
Private Enum PeekResult
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PeekResult
C#
private enum PeekResult : Enum
Managed Extensions for C++
__value private enum PeekResult : public Enum
C++/CLI
private enum class PeekResult : public Enum

Members

Member | Description
Unknown | Unkonwn status.
Valid | The limit is valid in it's current state and Validate will return true without any user interaction.
Invalid | The limit is invalid. Calling Validate may require user interaction.
NeedsUser | The limit may be valid but will require user interaction to ensure.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xheo.Licensing.PeekResult

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SerialNumberSizes Enumeration
See Also
[image]
Xheo.Licensing Namespace : SerialNumberSizes Enumeration

Possible key sizes for use when generating serial numbers. More bits makes it more difficult to crack but also increase the size of the serial number.

Syntax

Visual Basic (Declaration)
Private Enum SerialNumberSizes
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As SerialNumberSizes
C#
private enum SerialNumberSizes : Enum
Managed Extensions for C++
__value private enum SerialNumberSizes : public Enum
C++/CLI
private enum class SerialNumberSizes : public Enum

Members

Member | Description
None | Indicates that no serial number sizes are valid.
Small | Uses a key of 64 bits in length. Generates a serial number ~13 characters in length. Recommended group size = 4.
Medium | Uses a key of 96 bits in length. Generates a serial number ~20 characters in length. Recommended group size = 5.
Large | Uses a key of 128 bits in length. Generates a serial number ~25 characters in length. Recommended group size = 5.
Huge | Uses a key of 320 bits in length. Generates a serial number ~64 characters in length. Recommended group size = 8.
All | Allow any of the stored serial number sizes.
MediumAndBigger | Allow the medium and bigger sizes.
LargeAndBigger | Allow the large and bigger sizes.
Recommended | Recommended sizes for licenses.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Xheo.Licensing.SerialNumberSizes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LicenseSigningKey.KeyRecord Structure
See Also Members
[image]
Xheo.Licensing Namespace : LicenseSigningKey.KeyRecord Structure

Object Model

Syntax

Visual Basic (Declaration)
Private Structure LicenseSigningKey.KeyRecord
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
C#
private struct LicenseSigningKey.KeyRecord : ValueType
Managed Extensions for C++
private __value struct LicenseSigningKey.KeyRecord : public ValueType
C++/CLI
private value class LicenseSigningKey.KeyRecord : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.LicenseSigningKey.KeyRecord

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
LicenseSigningKey.KeyRecord Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : LicenseSigningKey.KeyRecord Structure

The following tables list the members exposed by LicenseSigningKey.KeyRecord.

Public Constructors

 | Name | Description
Public Constructor | LicenseSigningKey.KeyRecord Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Bits |
Public Field | d |
Public Field | e |
Public Field | n |
Public Field | p |
Public Field | q |
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Public Method | VerifyKey |
Top

See Also

Reference

LicenseSigningKey.KeyRecord Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LicenseSigningKey.KeyRecord Constructor
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : LicenseSigningKey.KeyRecord Constructor

Overload List

Overload | Description
LicenseSigningKey.KeyRecord Constructor(BigInteger,BigInteger,BigInteger,BigInteger,BigInteger,Int32) |
LicenseSigningKey.KeyRecord Constructor(Int32) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LicenseSigningKey.KeyRecord Constructor(BigInteger,BigInteger,BigInteger,BigInteger,BigInteger,Int32)
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure > LicenseSigningKey.KeyRecord Constructor : LicenseSigningKey.KeyRecord Constructor(BigInteger,BigInteger,BigInteger,BigInteger,BigInteger,Int32)

p
q
e
n
d
bits

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal p As BigInteger, _
   ByVal q As BigInteger, _
   ByVal e As BigInteger, _
   ByVal n As BigInteger, _
   ByVal d As BigInteger, _
   ByVal bits As Integer _
)
Visual Basic (Usage) Copy Code
Dim p As BigInteger
Dim q As BigInteger
Dim e As BigInteger
Dim n As BigInteger
Dim d As BigInteger
Dim bits As Integer

Dim instance As LicenseSigningKey.KeyRecord(p, q, e, n, d, bits)
C#
public LicenseSigningKey.KeyRecord(
   BigInteger p,
   BigInteger q,
   BigInteger e,
   BigInteger n,
   BigInteger d,
   int bits
)
Managed Extensions for C++
public: LicenseSigningKey.KeyRecord(
   BigInteger* p,
   BigInteger* q,
   BigInteger* e,
   BigInteger* n,
   BigInteger* d,
   int bits
)
C++/CLI
public:
LicenseSigningKey.KeyRecord(
   BigInteger^ p,
   BigInteger^ q,
   BigInteger^ e,
   BigInteger^ n,
   BigInteger^ d,
   int bits
)

Parameters

p
q
e
n
d
bits

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LicenseSigningKey.KeyRecord Constructor(Int32)
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure > LicenseSigningKey.KeyRecord Constructor : LicenseSigningKey.KeyRecord Constructor(Int32)

bits

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bits As Integer _
)
Visual Basic (Usage) Copy Code
Dim bits As Integer

Dim instance As LicenseSigningKey.KeyRecord(bits)
C#
public LicenseSigningKey.KeyRecord(
   int bits
)
Managed Extensions for C++
public: LicenseSigningKey.KeyRecord(
   int bits
)
C++/CLI
public:
LicenseSigningKey.KeyRecord(
   int bits
)

Parameters

bits

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
LicenseSigningKey.KeyRecord Structure Methods
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey.KeyRecord Structure

For a list of all members of this type, see LicenseSigningKey.KeyRecord members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Public Method | VerifyKey |
Top

See Also

Reference

LicenseSigningKey.KeyRecord Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
VerifyKey Method
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : VerifyKey Method

Syntax

Visual Basic (Declaration)
Public Function VerifyKey() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As Boolean

value = instance.VerifyKey()
C#
public bool VerifyKey()
Managed Extensions for C++
public: bool VerifyKey();
C++/CLI
public:
bool VerifyKey();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%% $$Fields$$

Barcode4NET.RS.Design Send comments on this topic.
LicenseSigningKey.KeyRecord Structure Fields
See Also
[image]
Xheo.Licensing Namespace : LicenseSigningKey.KeyRecord Structure

For a list of all members of this type, see LicenseSigningKey.KeyRecord members.

Public Fields

 | Name | Description
Public Field | Bits |
Public Field | d |
Public Field | e |
Public Field | n |
Public Field | p |
Public Field | q |
Top

See Also

Reference

LicenseSigningKey.KeyRecord Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Bits Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : Bits Field

Syntax

Visual Basic (Declaration)
Public Bits As Integer
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As Integer

value = instance.Bits

instance.Bits = value
C#
public int Bits
Managed Extensions for C++
public: int Bits
C++/CLI
public:
int Bits

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
d Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : d Field

Syntax

Visual Basic (Declaration)
Public d As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.d

instance.d = value
C#
public BigInteger d
Managed Extensions for C++
public: BigInteger* d
C++/CLI
public:
BigInteger^ d

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
e Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : e Field

Syntax

Visual Basic (Declaration)
Public e As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.e

instance.e = value
C#
public BigInteger e
Managed Extensions for C++
public: BigInteger* e
C++/CLI
public:
BigInteger^ e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
n Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : n Field

Syntax

Visual Basic (Declaration)
Public n As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.n

instance.n = value
C#
public BigInteger n
Managed Extensions for C++
public: BigInteger* n
C++/CLI
public:
BigInteger^ n

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
p Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : p Field

Syntax

Visual Basic (Declaration)
Public p As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.p

instance.p = value
C#
public BigInteger p
Managed Extensions for C++
public: BigInteger* p
C++/CLI
public:
BigInteger^ p

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
q Field
See Also
[image]
Xheo.Licensing Namespace > LicenseSigningKey.KeyRecord Structure : q Field

Syntax

Visual Basic (Declaration)
Public q As BigInteger
Visual Basic (Usage) Copy Code
Dim instance As LicenseSigningKey.KeyRecord
Dim value As BigInteger

value = instance.q

instance.q = value
C#
public BigInteger q
Managed Extensions for C++
public: BigInteger* q
C++/CLI
public:
BigInteger^ q

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

LicenseSigningKey.KeyRecord Structure
LicenseSigningKey.KeyRecord Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile._MEMORYSTATUS Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUS Structure

Summary of _MEMORYSTATUS

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile._MEMORYSTATUS
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
C#
private struct MachineProfile._MEMORYSTATUS : ValueType
Managed Extensions for C++
private __value struct MachineProfile._MEMORYSTATUS : public ValueType
C++/CLI
private value class MachineProfile._MEMORYSTATUS : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile._MEMORYSTATUS

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile._MEMORYSTATUS Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUS Structure

The following tables list the members exposed by MachineProfile._MEMORYSTATUS.

Public Fields

 | Name | Description
Public Field | dwAvailPageFile |
Public Field | dwAvailPhys |
Public Field | dwAvailVirtual |
Public Field | dwLength |
Public Field | dwMemoryLoad |
Public Field | dwTotalPageFile |
Public Field | dwTotalPhys |
Public Field | dwTotalVirtual |
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile._MEMORYSTATUS Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUS Structure

For a list of all members of this type, see MachineProfile._MEMORYSTATUS members.

Public Fields

 | Name | Description
Public Field | dwAvailPageFile |
Public Field | dwAvailPhys |
Public Field | dwAvailVirtual |
Public Field | dwLength |
Public Field | dwMemoryLoad |
Public Field | dwTotalPageFile |
Public Field | dwTotalPhys |
Public Field | dwTotalVirtual |
Top

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
dwAvailPageFile Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwAvailPageFile Field

Syntax

Visual Basic (Declaration)
Public dwAvailPageFile As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwAvailPageFile

instance.dwAvailPageFile = value
C#
public uint dwAvailPageFile
Managed Extensions for C++
public: uint dwAvailPageFile
C++/CLI
public:
uint dwAvailPageFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
dwAvailPhys Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwAvailPhys Field

Syntax

Visual Basic (Declaration)
Public dwAvailPhys As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwAvailPhys

instance.dwAvailPhys = value
C#
public uint dwAvailPhys
Managed Extensions for C++
public: uint dwAvailPhys
C++/CLI
public:
uint dwAvailPhys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
dwAvailVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwAvailVirtual Field

Syntax

Visual Basic (Declaration)
Public dwAvailVirtual As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwAvailVirtual

instance.dwAvailVirtual = value
C#
public uint dwAvailVirtual
Managed Extensions for C++
public: uint dwAvailVirtual
C++/CLI
public:
uint dwAvailVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
dwLength Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwLength Field

Syntax

Visual Basic (Declaration)
Public dwLength As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwLength

instance.dwLength = value
C#
public uint dwLength
Managed Extensions for C++
public: uint dwLength
C++/CLI
public:
uint dwLength

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
dwMemoryLoad Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwMemoryLoad Field

Syntax

Visual Basic (Declaration)
Public dwMemoryLoad As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwMemoryLoad

instance.dwMemoryLoad = value
C#
public uint dwMemoryLoad
Managed Extensions for C++
public: uint dwMemoryLoad
C++/CLI
public:
uint dwMemoryLoad

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
dwTotalPageFile Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwTotalPageFile Field

Syntax

Visual Basic (Declaration)
Public dwTotalPageFile As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwTotalPageFile

instance.dwTotalPageFile = value
C#
public uint dwTotalPageFile
Managed Extensions for C++
public: uint dwTotalPageFile
C++/CLI
public:
uint dwTotalPageFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
dwTotalPhys Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwTotalPhys Field

Syntax

Visual Basic (Declaration)
Public dwTotalPhys As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwTotalPhys

instance.dwTotalPhys = value
C#
public uint dwTotalPhys
Managed Extensions for C++
public: uint dwTotalPhys
C++/CLI
public:
uint dwTotalPhys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
dwTotalVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUS Structure : dwTotalVirtual Field

Syntax

Visual Basic (Declaration)
Public dwTotalVirtual As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUS
Dim value As UInteger

value = instance.dwTotalVirtual

instance.dwTotalVirtual = value
C#
public uint dwTotalVirtual
Managed Extensions for C++
public: uint dwTotalVirtual
C++/CLI
public:
uint dwTotalVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
MachineProfile._MEMORYSTATUS Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile._MEMORYSTATUSEX Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUSEX Structure

Summary of _MEMORYSTATUSEX

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile._MEMORYSTATUSEX
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
C#
private struct MachineProfile._MEMORYSTATUSEX : ValueType
Managed Extensions for C++
private __value struct MachineProfile._MEMORYSTATUSEX : public ValueType
C++/CLI
private value class MachineProfile._MEMORYSTATUSEX : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile._MEMORYSTATUSEX

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile._MEMORYSTATUSEX Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUSEX Structure

The following tables list the members exposed by MachineProfile._MEMORYSTATUSEX.

Public Fields

 | Name | Description
Public Field | dwLength |
Public Field | dwMemoryLoad |
Public Field | ullAvailExtendedVirtual |
Public Field | ullAvailPageFile |
Public Field | ullAvailPhys |
Public Field | ullAvailVirtual |
Public Field | ullTotalPageFile |
Public Field | ullTotalPhys |
Public Field | ullTotalVirtual |
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile._MEMORYSTATUSEX Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUSEX Structure

For a list of all members of this type, see MachineProfile._MEMORYSTATUSEX members.

Public Fields

 | Name | Description
Public Field | dwLength |
Public Field | dwMemoryLoad |
Public Field | ullAvailExtendedVirtual |
Public Field | ullAvailPageFile |
Public Field | ullAvailPhys |
Public Field | ullAvailVirtual |
Public Field | ullTotalPageFile |
Public Field | ullTotalPhys |
Public Field | ullTotalVirtual |
Top

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
dwLength Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : dwLength Field

Syntax

Visual Basic (Declaration)
Public dwLength As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As UInteger

value = instance.dwLength

instance.dwLength = value
C#
public uint dwLength
Managed Extensions for C++
public: uint dwLength
C++/CLI
public:
uint dwLength

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
dwMemoryLoad Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : dwMemoryLoad Field

Syntax

Visual Basic (Declaration)
Public dwMemoryLoad As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As UInteger

value = instance.dwMemoryLoad

instance.dwMemoryLoad = value
C#
public uint dwMemoryLoad
Managed Extensions for C++
public: uint dwMemoryLoad
C++/CLI
public:
uint dwMemoryLoad

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ullAvailExtendedVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullAvailExtendedVirtual Field

Syntax

Visual Basic (Declaration)
Public ullAvailExtendedVirtual As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullAvailExtendedVirtual

instance.ullAvailExtendedVirtual = value
C#
public ulong ullAvailExtendedVirtual
Managed Extensions for C++
public: ulong ullAvailExtendedVirtual
C++/CLI
public:
ulong ullAvailExtendedVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ullAvailPageFile Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullAvailPageFile Field

Syntax

Visual Basic (Declaration)
Public ullAvailPageFile As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullAvailPageFile

instance.ullAvailPageFile = value
C#
public ulong ullAvailPageFile
Managed Extensions for C++
public: ulong ullAvailPageFile
C++/CLI
public:
ulong ullAvailPageFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ullAvailPhys Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullAvailPhys Field

Syntax

Visual Basic (Declaration)
Public ullAvailPhys As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullAvailPhys

instance.ullAvailPhys = value
C#
public ulong ullAvailPhys
Managed Extensions for C++
public: ulong ullAvailPhys
C++/CLI
public:
ulong ullAvailPhys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ullAvailVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullAvailVirtual Field

Syntax

Visual Basic (Declaration)
Public ullAvailVirtual As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullAvailVirtual

instance.ullAvailVirtual = value
C#
public ulong ullAvailVirtual
Managed Extensions for C++
public: ulong ullAvailVirtual
C++/CLI
public:
ulong ullAvailVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ullTotalPageFile Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullTotalPageFile Field

Syntax

Visual Basic (Declaration)
Public ullTotalPageFile As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullTotalPageFile

instance.ullTotalPageFile = value
C#
public ulong ullTotalPageFile
Managed Extensions for C++
public: ulong ullTotalPageFile
C++/CLI
public:
ulong ullTotalPageFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ullTotalPhys Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullTotalPhys Field

Syntax

Visual Basic (Declaration)
Public ullTotalPhys As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullTotalPhys

instance.ullTotalPhys = value
C#
public ulong ullTotalPhys
Managed Extensions for C++
public: ulong ullTotalPhys
C++/CLI
public:
ulong ullTotalPhys

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ullTotalVirtual Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile._MEMORYSTATUSEX Structure : ullTotalVirtual Field

Syntax

Visual Basic (Declaration)
Public ullTotalVirtual As ULong
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile._MEMORYSTATUSEX
Dim value As ULong

value = instance.ullTotalVirtual

instance.ullTotalVirtual = value
C#
public ulong ullTotalVirtual
Managed Extensions for C++
public: ulong ullTotalVirtual
C++/CLI
public:
ulong ullTotalVirtual

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
MachineProfile._MEMORYSTATUSEX Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure

declare the IP_ADAPTERINFO_STRUCTURE structure

Object Model

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile.IP_ADAPTERINFO_STRUCTURE
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
C#
private struct MachineProfile.IP_ADAPTERINFO_STRUCTURE : ValueType
Managed Extensions for C++
private __value struct MachineProfile.IP_ADAPTERINFO_STRUCTURE : public ValueType
C++/CLI
private value class MachineProfile.IP_ADAPTERINFO_STRUCTURE : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile.IP_ADAPTERINFO_STRUCTURE

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure

The following tables list the members exposed by MachineProfile.IP_ADAPTERINFO_STRUCTURE.

Public Fields

 | Name | Description
Public Field | AdapterName | Specifies the name of the adapter
Public Field | Address | Specifies the hardware address for the adapter
Public Field | AddressLength | Specifies the length of the hardware address for the adapter
Public Field | ComboIndex | Reserved
Public Field | CurrentIPAddress | Specifies the current IP address for this adapter
Public Field | Description | Specifies a description for the adapter
Public Field | DhcpEnabled | Specifies whether dynamic host configuration protocol (DHCP) is enabled for this adapter
Public Field | DhcpServer | Specifies the IP address of the DHCP server for this adapter
Public Field | GatewayList | Specifies the IP address of the default gateway for this adapter
Public Field | HaveWins | Specifies whether this adapter uses Windows Internet Name Service (WINS)
Public Field | Index | Specifies the adapter index
Public Field | IpAddressList | Specifies the list of IP addresses associated with this adapter
Public Field | LeaseExpires | Specifies the time when the current DHCP lease will expire
Public Field | LeaseObtained | Specifies the time when the current DHCP lease was obtained
Public Field | Next | Pointer to the next adapter in the list of adapters
Public Field | PrimaryWinsServer | Specifies the IP address of the primary WINS server
Public Field | SecondaryWinsServer | Specifies the IP address of the secondary WINS server
Public Field | Type | Specifies the adapter type. The type is one of the following values. IF_OTHER_ADAPTERTYPE IF_ETHERNET_ADAPTERTYPE IF_TOKEN_RING_ADAPTERTYPE IF_FDDI_ADAPTERTYPE IF_PPP_ADAPTERTYPE IF_LOOPBACK_ADAPTERTYPE IF_SLIP_ADAPTERTYPE These values are defined in the header file IPIfCons.h
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure

For a list of all members of this type, see MachineProfile.IP_ADAPTERINFO_STRUCTURE members.

Public Fields

 | Name | Description
Public Field | AdapterName | Specifies the name of the adapter
Public Field | Address | Specifies the hardware address for the adapter
Public Field | AddressLength | Specifies the length of the hardware address for the adapter
Public Field | ComboIndex | Reserved
Public Field | CurrentIPAddress | Specifies the current IP address for this adapter
Public Field | Description | Specifies a description for the adapter
Public Field | DhcpEnabled | Specifies whether dynamic host configuration protocol (DHCP) is enabled for this adapter
Public Field | DhcpServer | Specifies the IP address of the DHCP server for this adapter
Public Field | GatewayList | Specifies the IP address of the default gateway for this adapter
Public Field | HaveWins | Specifies whether this adapter uses Windows Internet Name Service (WINS)
Public Field | Index | Specifies the adapter index
Public Field | IpAddressList | Specifies the list of IP addresses associated with this adapter
Public Field | LeaseExpires | Specifies the time when the current DHCP lease will expire
Public Field | LeaseObtained | Specifies the time when the current DHCP lease was obtained
Public Field | Next | Pointer to the next adapter in the list of adapters
Public Field | PrimaryWinsServer | Specifies the IP address of the primary WINS server
Public Field | SecondaryWinsServer | Specifies the IP address of the secondary WINS server
Public Field | Type | Specifies the adapter type. The type is one of the following values. IF_OTHER_ADAPTERTYPE IF_ETHERNET_ADAPTERTYPE IF_TOKEN_RING_ADAPTERTYPE IF_FDDI_ADAPTERTYPE IF_PPP_ADAPTERTYPE IF_LOOPBACK_ADAPTERTYPE IF_SLIP_ADAPTERTYPE These values are defined in the header file IPIfCons.h
Top

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
AdapterName Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : AdapterName Field

Specifies the name of the adapter

Syntax

Visual Basic (Declaration)
Public AdapterName As Char()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value() As Char

value = instance.AdapterName

instance.AdapterName = value
C#
public char[] AdapterName
Managed Extensions for C++
public: char[] AdapterName
C++/CLI
public:
array<char> AdapterName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Address Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Address Field

Specifies the hardware address for the adapter

Syntax

Visual Basic (Declaration)
Public Address As Byte()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value() As Byte

value = instance.Address

instance.Address = value
C#
public byte[] Address
Managed Extensions for C++
public: byte[] Address
C++/CLI
public:
array<byte> Address

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
AddressLength Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : AddressLength Field

Specifies the length of the hardware address for the adapter

Syntax

Visual Basic (Declaration)
Public AddressLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.AddressLength

instance.AddressLength = value
C#
public int AddressLength
Managed Extensions for C++
public: int AddressLength
C++/CLI
public:
int AddressLength

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ComboIndex Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : ComboIndex Field

Reserved

Syntax

Visual Basic (Declaration)
Public ComboIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.ComboIndex

instance.ComboIndex = value
C#
public int ComboIndex
Managed Extensions for C++
public: int ComboIndex
C++/CLI
public:
int ComboIndex

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
CurrentIPAddress Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : CurrentIPAddress Field

Specifies the current IP address for this adapter

Syntax

Visual Basic (Declaration)
Public CurrentIPAddress As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.CurrentIPAddress

instance.CurrentIPAddress = value
C#
public int CurrentIPAddress
Managed Extensions for C++
public: int CurrentIPAddress
C++/CLI
public:
int CurrentIPAddress

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Description Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Description Field

Specifies a description for the adapter

Syntax

Visual Basic (Declaration)
Public Description As Char()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value() As Char

value = instance.Description

instance.Description = value
C#
public char[] Description
Managed Extensions for C++
public: char[] Description
C++/CLI
public:
array<char> Description

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
DhcpEnabled Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : DhcpEnabled Field

Specifies whether dynamic host configuration protocol (DHCP) is enabled for this adapter

Syntax

Visual Basic (Declaration)
Public DhcpEnabled As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.DhcpEnabled

instance.DhcpEnabled = value
C#
public int DhcpEnabled
Managed Extensions for C++
public: int DhcpEnabled
C++/CLI
public:
int DhcpEnabled

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
DhcpServer Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : DhcpServer Field

Specifies the IP address of the DHCP server for this adapter

Syntax

Visual Basic (Declaration)
Public DhcpServer As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.DhcpServer

instance.DhcpServer = value
C#
public MachineProfile.IP_ADDR_STRING DhcpServer
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING DhcpServer
C++/CLI
public:
MachineProfile.IP_ADDR_STRING DhcpServer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
GatewayList Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : GatewayList Field

Specifies the IP address of the default gateway for this adapter

Syntax

Visual Basic (Declaration)
Public GatewayList As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.GatewayList

instance.GatewayList = value
C#
public MachineProfile.IP_ADDR_STRING GatewayList
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING GatewayList
C++/CLI
public:
MachineProfile.IP_ADDR_STRING GatewayList

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
HaveWins Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : HaveWins Field

Specifies whether this adapter uses Windows Internet Name Service (WINS)

Syntax

Visual Basic (Declaration)
Public HaveWins As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Byte

value = instance.HaveWins

instance.HaveWins = value
C#
public byte HaveWins
Managed Extensions for C++
public: byte HaveWins
C++/CLI
public:
byte HaveWins

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Index Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Index Field

Specifies the adapter index

Syntax

Visual Basic (Declaration)
Public Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.Index

instance.Index = value
C#
public int Index
Managed Extensions for C++
public: int Index
C++/CLI
public:
int Index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IpAddressList Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : IpAddressList Field

Specifies the list of IP addresses associated with this adapter

Syntax

Visual Basic (Declaration)
Public IpAddressList As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.IpAddressList

instance.IpAddressList = value
C#
public MachineProfile.IP_ADDR_STRING IpAddressList
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING IpAddressList
C++/CLI
public:
MachineProfile.IP_ADDR_STRING IpAddressList

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LeaseExpires Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : LeaseExpires Field

Specifies the time when the current DHCP lease will expire

Syntax

Visual Basic (Declaration)
Public LeaseExpires As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.LeaseExpires

instance.LeaseExpires = value
C#
public int LeaseExpires
Managed Extensions for C++
public: int LeaseExpires
C++/CLI
public:
int LeaseExpires

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
LeaseObtained Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : LeaseObtained Field

Specifies the time when the current DHCP lease was obtained

Syntax

Visual Basic (Declaration)
Public LeaseObtained As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.LeaseObtained

instance.LeaseObtained = value
C#
public int LeaseObtained
Managed Extensions for C++
public: int LeaseObtained
C++/CLI
public:
int LeaseObtained

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Next Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Next Field

Pointer to the next adapter in the list of adapters

Syntax

Visual Basic (Declaration)
Public Next As UInteger
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As UInteger

value = instance.Next

instance.Next = value
C#
public uint Next
Managed Extensions for C++
public: uint Next
C++/CLI
public:
uint Next

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
PrimaryWinsServer Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : PrimaryWinsServer Field

Specifies the IP address of the primary WINS server

Syntax

Visual Basic (Declaration)
Public PrimaryWinsServer As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.PrimaryWinsServer

instance.PrimaryWinsServer = value
C#
public MachineProfile.IP_ADDR_STRING PrimaryWinsServer
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING PrimaryWinsServer
C++/CLI
public:
MachineProfile.IP_ADDR_STRING PrimaryWinsServer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
SecondaryWinsServer Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : SecondaryWinsServer Field

Specifies the IP address of the secondary WINS server

Syntax

Visual Basic (Declaration)
Public SecondaryWinsServer As MachineProfile.IP_ADDR_STRING
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As MachineProfile.IP_ADDR_STRING

value = instance.SecondaryWinsServer

instance.SecondaryWinsServer = value
C#
public MachineProfile.IP_ADDR_STRING SecondaryWinsServer
Managed Extensions for C++
public: MachineProfile.IP_ADDR_STRING SecondaryWinsServer
C++/CLI
public:
MachineProfile.IP_ADDR_STRING SecondaryWinsServer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Type Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure : Type Field

Specifies the adapter type. The type is one of the following values. IF_OTHER_ADAPTERTYPE IF_ETHERNET_ADAPTERTYPE IF_TOKEN_RING_ADAPTERTYPE IF_FDDI_ADAPTERTYPE IF_PPP_ADAPTERTYPE IF_LOOPBACK_ADAPTERTYPE IF_SLIP_ADAPTERTYPE These values are defined in the header file IPIfCons.h

Syntax

Visual Basic (Declaration)
Public Type As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADAPTERINFO_STRUCTURE
Dim value As Integer

value = instance.Type

instance.Type = value
C#
public int Type
Managed Extensions for C++
public: int Type
C++/CLI
public:
int Type

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
MachineProfile.IP_ADAPTERINFO_STRUCTURE Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.IP_ADDR_STRING Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADDR_STRING Structure

declare the IP_ADDR_STRING structure

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile.IP_ADDR_STRING
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
C#
private struct MachineProfile.IP_ADDR_STRING : ValueType
Managed Extensions for C++
private __value struct MachineProfile.IP_ADDR_STRING : public ValueType
C++/CLI
private value class MachineProfile.IP_ADDR_STRING : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile.IP_ADDR_STRING

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.IP_ADDR_STRING Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADDR_STRING Structure

The following tables list the members exposed by MachineProfile.IP_ADDR_STRING.

Public Fields

 | Name | Description
Public Field | Context | Specifies network table entry (NTE). This value corresponds to the NTEContext parameters in the AddIPAddress and DeleteIPAddress functions
Public Field | IpAddress | This array holds the IP address
Public Field | IpMask | This array holds the IP address mask
Public Field | Next | Pointer to the next IP_ADDR_STRING structure in the list
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.IP_ADDR_STRING Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADDR_STRING Structure

For a list of all members of this type, see MachineProfile.IP_ADDR_STRING members.

Public Fields

 | Name | Description
Public Field | Context | Specifies network table entry (NTE). This value corresponds to the NTEContext parameters in the AddIPAddress and DeleteIPAddress functions
Public Field | IpAddress | This array holds the IP address
Public Field | IpMask | This array holds the IP address mask
Public Field | Next | Pointer to the next IP_ADDR_STRING structure in the list
Top

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Context Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADDR_STRING Structure : Context Field

Specifies network table entry (NTE). This value corresponds to the NTEContext parameters in the AddIPAddress and DeleteIPAddress functions

Syntax

Visual Basic (Declaration)
Public Context As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
Dim value As Integer

value = instance.Context

instance.Context = value
C#
public int Context
Managed Extensions for C++
public: int Context
C++/CLI
public:
int Context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
MachineProfile.IP_ADDR_STRING Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IpAddress Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADDR_STRING Structure : IpAddress Field

This array holds the IP address

Syntax

Visual Basic (Declaration)
Public IpAddress As Char()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
Dim value() As Char

value = instance.IpAddress

instance.IpAddress = value
C#
public char[] IpAddress
Managed Extensions for C++
public: char[] IpAddress
C++/CLI
public:
array<char> IpAddress

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
MachineProfile.IP_ADDR_STRING Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
IpMask Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADDR_STRING Structure : IpMask Field

This array holds the IP address mask

Syntax

Visual Basic (Declaration)
Public IpMask As Char()
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
Dim value() As Char

value = instance.IpMask

instance.IpMask = value
C#
public char[] IpMask
Managed Extensions for C++
public: char[] IpMask
C++/CLI
public:
array<char> IpMask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
MachineProfile.IP_ADDR_STRING Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Next Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.IP_ADDR_STRING Structure : Next Field

Pointer to the next IP_ADDR_STRING structure in the list

Syntax

Visual Basic (Declaration)
Public Next As Integer
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.IP_ADDR_STRING
Dim value As Integer

value = instance.Next

instance.Next = value
C#
public int Next
Managed Extensions for C++
public: int Next
C++/CLI
public:
int Next

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
MachineProfile.IP_ADDR_STRING Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.TGuid Structure
See Also Members
[image]
Xheo.Licensing Namespace : MachineProfile.TGuid Structure

Summary of TGuid

Syntax

Visual Basic (Declaration)
Private Structure MachineProfile.TGuid
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
C#
private struct MachineProfile.TGuid : ValueType
Managed Extensions for C++
private __value struct MachineProfile.TGuid : public ValueType
C++/CLI
private value class MachineProfile.TGuid : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Xheo.Licensing.MachineProfile.TGuid

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Members
Xheo.Licensing Namespace


%%PageItemTitle%% $$Members$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.TGuid Structure Members
See Also Fields Methods
[image]
Xheo.Licensing Namespace : MachineProfile.TGuid Structure

The following tables list the members exposed by MachineProfile.TGuid.

Public Fields

 | Name | Description
Public Field | a |
Public Field | b |
Public Field | d |
Public Field | m |
Public Field | m1 |
Public Field | m2 |
Public Field | m3 |
Public Field | m4 |
Public Field | m5 |
Public Field | m6 |
Public Field | s |
Top

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.TGuid Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Fields$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.TGuid Structure Fields
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.TGuid Structure

For a list of all members of this type, see MachineProfile.TGuid members.

Public Fields

 | Name | Description
Public Field | a |
Public Field | b |
Public Field | d |
Public Field | m |
Public Field | m1 |
Public Field | m2 |
Public Field | m3 |
Public Field | m4 |
Public Field | m5 |
Public Field | m6 |
Public Field | s |
Top

See Also

Reference

MachineProfile.TGuid Structure
Xheo.Licensing Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
a Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : a Field

Syntax

Visual Basic (Declaration)
Public a As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.a

instance.a = value
C#
public short a
Managed Extensions for C++
public: short a
C++/CLI
public:
short a

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
b Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : b Field

Syntax

Visual Basic (Declaration)
Public b As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.b

instance.b = value
C#
public short b
Managed Extensions for C++
public: short b
C++/CLI
public:
short b

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
d Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : d Field

Syntax

Visual Basic (Declaration)
Public d As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.d

instance.d = value
C#
public short d
Managed Extensions for C++
public: short d
C++/CLI
public:
short d

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
m Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m Field

Syntax

Visual Basic (Declaration)
Public m As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.m

instance.m = value
C#
public short m
Managed Extensions for C++
public: short m
C++/CLI
public:
short m

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
m1 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m1 Field

Syntax

Visual Basic (Declaration)
Public m1 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m1

instance.m1 = value
C#
public byte m1
Managed Extensions for C++
public: byte m1
C++/CLI
public:
byte m1

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
m2 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m2 Field

Syntax

Visual Basic (Declaration)
Public m2 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m2

instance.m2 = value
C#
public byte m2
Managed Extensions for C++
public: byte m2
C++/CLI
public:
byte m2

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
m3 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m3 Field

Syntax

Visual Basic (Declaration)
Public m3 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m3

instance.m3 = value
C#
public byte m3
Managed Extensions for C++
public: byte m3
C++/CLI
public:
byte m3

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
m4 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m4 Field

Syntax

Visual Basic (Declaration)
Public m4 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m4

instance.m4 = value
C#
public byte m4
Managed Extensions for C++
public: byte m4
C++/CLI
public:
byte m4

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
m5 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m5 Field

Syntax

Visual Basic (Declaration)
Public m5 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m5

instance.m5 = value
C#
public byte m5
Managed Extensions for C++
public: byte m5
C++/CLI
public:
byte m5

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
m6 Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : m6 Field

Syntax

Visual Basic (Declaration)
Public m6 As Byte
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Byte

value = instance.m6

instance.m6 = value
C#
public byte m6
Managed Extensions for C++
public: byte m6
C++/CLI
public:
byte m6

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
s Field
See Also
[image]
Xheo.Licensing Namespace > MachineProfile.TGuid Structure : s Field

Syntax

Visual Basic (Declaration)
Public s As Short
Visual Basic (Usage) Copy Code
Dim instance As MachineProfile.TGuid
Dim value As Short

value = instance.s

instance.s = value
C#
public short s
Managed Extensions for C++
public: short s
C++/CLI
public:
short s

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

MachineProfile.TGuid Structure
MachineProfile.TGuid Members


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Samples

Glossary Item Box

This section presents all the samples that come with Barcode4NET toolkit. These samples have been designed to help you understand how Barcode4NET toolkit can be used and ease your learning curve.

Windows Forms
These samples show how to use Barcode4NET toolkit in Windows Forms applications. Various scenarios are presented, including 2 custom controls, a listbox and a combobox, that can display barcodes instead of actual items.

ASP.NET
These samples show how to use Barcode4NET toolkit in ASP.NET applications. They show how to use Barcode4NET controls in a simple form or in a DataGrid. They also present how to use Barcode4NET in reports created with Sql Server Reporting Services 2000 & 2005.

Mobile Devices
These samples show how to use Barcode4NET toolkit in mobile devices applications. They show how to use the BarcodeView control or how to draw barcodes directly on the form.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Windows Forms

Glossary Item Box

These samples show how to use Barcode4NET toolkit in Windows Forms applications.

BarcodeDataBind
This sample shows how to use BarcodeTextBox control in Windows Forms data bound applications.

Enlarge Click to enlarge

BarcodeExplorer
This is an interactive sample that lets you change the barcode properties and displays the updated barcode. Good to see how each barcode property affects the displayed barcode.

Enlarge Click to enlarge

BarcodeGridColumn
This sample shows how to display barcodes in a Windows DataGrid control. A custom barcode data grid column is implemented for this task.

Enlarge Click to enlarge

BarcodeListControls
This sample shows how to implement 2 list controls that display barcodes instead of actual items. It includes source code for a barcode listbox and a barcode combobox.

Enlarge Click to enlarge

BarcodePrint
This sample shows how to display barcodes on a page using a PrintDocument and a PrintPreviewDialog. The barcodes can be printed on any printer.

Enlarge Click to enlarge

CristalReportsBarcodes
This sample shows how to display barcodes in Crystal Reports. The complete tutorial that explains all the steps can be read here.

Enlarge Click to enlarge

LocalReportsBarcodes
This sample shows how to display barcodes in local reports (RDLC) created with Visual Studio 2005. The complete tutorial that explains all the steps can be read here.

Enlarge Click to enlarge


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
ASP.NET

Glossary Item Box

These samples show how to use Barcode4NET toolkit in ASP.NET applications.

LocalReportsBarcodes
This sample shows how to display barcodes in local reports (RDLC) created with Visual Studio 2005. The complete tutorial that explains all the steps can be read here.

SSRS2000Barcodes
This sample shows how to display barcodes in reports created with Sql Server Reporting Services 2000. The complete tutorial that explains all the steps can be read here.

SSRS2005Barcodes
This sample shows how to displa barcodes in reports created with Sql Server Reporting Services 2005. Because SSRS2005 provide support for custom controls at design time, a custom Barcode control for SSRS2005 is included in Barcode4NET toolkit.

WebBarcodes
This sample shows how to display barcodes in a web page. It shows how BarcodeView control, included in Barcode4NET toolkit, can be used in a simple web form and in a data grid.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Mobile Devices

Glossary Item Box

These samples show how to use Barcode4NET toolkit in mobile devices applications.

BarcodeDraw
This sample shows how to draw barcodes directly on a form.

BarcodeControl
This sample shows how to use BarcodeView control included in Barcode4NET toolkit.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Empty Index Entry

Glossary Item Box

Empty Index Entry

The index entry you selected has no target topics associated with it.

If you have chosen a parent entry, please select a child entry.


%%ItemTitle%%

Barcode4NET for .NET Send comments on this topic.
Topic Not Found

Glossary Item Box

Topic Not Found

The link you just clicked was not able to connect to the target page.

Some possible reasons and remedies are as follows:

Reason | Remedy
Destination topic is not part of the area you specified in the Filtered by field. | Either select another filter or select (no filter).
The URL of the destination topic is incorrect or has changed. | Use the index or the search function instead.
Problems with the help installation. | Rerun Setup for the product this help is related to and select the 'Repair' option.

Additional help is available for filters, search, and the index.

Click Back to return to the page you were on.

The target parameters are:

Keyword:
Index Moniker:
URL:


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
BarcodeEncodingException Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : BarcodeEncodingException Class

For a list of all members of this type, see BarcodeEncodingException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

BarcodeEncodingException Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
BarcodeEncodingException Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : BarcodeEncodingException Class

For a list of all members of this type, see BarcodeEncodingException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

BarcodeEncodingException Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
BidimensionalBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : BidimensionalBarcode Class

For a list of all members of this type, see BidimensionalBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

BidimensionalBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
CodabarBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : CodabarBarcode Class

For a list of all members of this type, see CodabarBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

CodabarBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
CodabarBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : CodabarBarcode Class

For a list of all members of this type, see CodabarBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

CodabarBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
CodablockFBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : CodablockFBarcode Class

For a list of all members of this type, see CodablockFBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

CodablockFBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
Code11Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code11Barcode Class

For a list of all members of this type, see Code11Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code11Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
Code11Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code11Barcode Class

For a list of all members of this type, see Code11Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code11Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
Code16KBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code16KBarcode Class

For a list of all members of this type, see Code16KBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code16KBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
Code25Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code25Barcode Class

For a list of all members of this type, see Code25Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
Code25Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code25Barcode Class

For a list of all members of this type, see Code25Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
Code25InterleavedBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code25InterleavedBarcode Class

For a list of all members of this type, see Code25InterleavedBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code25InterleavedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
Code25InterleavedBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code25InterleavedBarcode Class

For a list of all members of this type, see Code25InterleavedBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code25InterleavedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
Code39Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code39Barcode Class

For a list of all members of this type, see Code39Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code39Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
Code39ExtendedBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code39ExtendedBarcode Class

For a list of all members of this type, see Code39ExtendedBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code39ExtendedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
Code39ExtendedBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code39ExtendedBarcode Class

For a list of all members of this type, see Code39ExtendedBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from Code39Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code39ExtendedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
Code93Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code93Barcode Class

For a list of all members of this type, see Code93Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code93Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
Code93Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code93Barcode Class

For a list of all members of this type, see Code93Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code93Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
Code93ExtendedBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code93ExtendedBarcode Class

For a list of all members of this type, see Code93ExtendedBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code93ExtendedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
Code93ExtendedBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code93ExtendedBarcode Class

For a list of all members of this type, see Code93ExtendedBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code93ExtendedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
Code128ABarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code128ABarcode Class

For a list of all members of this type, see Code128ABarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code128ABarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
Code128ABarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code128ABarcode Class

For a list of all members of this type, see Code128ABarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code128ABarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
Code128Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code128Barcode Class

For a list of all members of this type, see Code128Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code128Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
Code128Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code128Barcode Class

For a list of all members of this type, see Code128Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code128Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
Code128BBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code128BBarcode Class

For a list of all members of this type, see Code128BBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code128BBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
Code128BBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code128BBarcode Class

For a list of all members of this type, see Code128BBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code128BBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
Code128CBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code128CBarcode Class

For a list of all members of this type, see Code128CBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code128CBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
Code128CBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code128CBarcode Class

For a list of all members of this type, see Code128CBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code128CBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
COOP25Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : COOP25Barcode Class

For a list of all members of this type, see COOP25Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

COOP25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
COOP25Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : COOP25Barcode Class

For a list of all members of this type, see COOP25Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

COOP25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
EAN8Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : EAN8Barcode Class

For a list of all members of this type, see EAN8Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

EAN8Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
EAN8Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : EAN8Barcode Class

For a list of all members of this type, see EAN8Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

EAN8Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
EAN13Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : EAN13Barcode Class

For a list of all members of this type, see EAN13Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

EAN13Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
EAN13Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : EAN13Barcode Class

For a list of all members of this type, see EAN13Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

EAN13Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
EANBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : EANBarcode Class

For a list of all members of this type, see EANBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

EANBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
HeightModulatedBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : HeightModulatedBarcode Class

For a list of all members of this type, see HeightModulatedBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

HeightModulatedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
HeightModulatedBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : HeightModulatedBarcode Class

For a list of all members of this type, see HeightModulatedBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

HeightModulatedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
IATA25Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : IATA25Barcode Class

For a list of all members of this type, see IATA25Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

IATA25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
IATA25Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : IATA25Barcode Class

For a list of all members of this type, see IATA25Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

IATA25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
ISBNBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : ISBNBarcode Class

For a list of all members of this type, see ISBNBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

ISBNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
ISBNBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : ISBNBarcode Class

For a list of all members of this type, see ISBNBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

ISBNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
ISMNBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : ISMNBarcode Class

For a list of all members of this type, see ISMNBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

ISMNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
ISMNBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : ISMNBarcode Class

For a list of all members of this type, see ISMNBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

ISMNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
ISSNBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : ISSNBarcode Class

For a list of all members of this type, see ISSNBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

ISSNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
ISSNBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : ISSNBarcode Class

For a list of all members of this type, see ISSNBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

ISSNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
JAN13Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : JAN13Barcode Class

For a list of all members of this type, see JAN13Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

JAN13Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
JAN13Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : JAN13Barcode Class

For a list of all members of this type, see JAN13Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

JAN13Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
Matrix25Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Matrix25Barcode Class

For a list of all members of this type, see Matrix25Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Matrix25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
Matrix25Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Matrix25Barcode Class

For a list of all members of this type, see Matrix25Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Matrix25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
MicroPDF417Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : MicroPDF417Barcode Class

For a list of all members of this type, see MicroPDF417Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from BasePDF417Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

MicroPDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
MSIPlesseyBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : MSIPlesseyBarcode Class

For a list of all members of this type, see MSIPlesseyBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

MSIPlesseyBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
MSIPlesseyBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : MSIPlesseyBarcode Class

For a list of all members of this type, see MSIPlesseyBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

MSIPlesseyBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
PDF417Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : PDF417Barcode Class

For a list of all members of this type, see PDF417Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from BasePDF417Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

PDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
PlanetBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : PlanetBarcode Class

For a list of all members of this type, see PlanetBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

PlanetBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
PlanetBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : PlanetBarcode Class

For a list of all members of this type, see PlanetBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

PlanetBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
PostnetBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : PostnetBarcode Class

For a list of all members of this type, see PostnetBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

PostnetBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
PostnetBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : PostnetBarcode Class

For a list of all members of this type, see PostnetBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

PostnetBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
RM4SCCBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : RM4SCCBarcode Class

For a list of all members of this type, see RM4SCCBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

RM4SCCBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
RM4SCCBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : RM4SCCBarcode Class

For a list of all members of this type, see RM4SCCBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

RM4SCCBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
SCC14Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : SCC14Barcode Class

For a list of all members of this type, see SCC14Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

SCC14Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
SCC14Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : SCC14Barcode Class

For a list of all members of this type, see SCC14Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

SCC14Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
SSCC18Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : SSCC18Barcode Class

For a list of all members of this type, see SSCC18Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

SSCC18Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
SSCC18Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : SSCC18Barcode Class

For a list of all members of this type, see SSCC18Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

SSCC18Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
UPCABarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : UPCABarcode Class

For a list of all members of this type, see UPCABarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

UPCABarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
UPCABarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : UPCABarcode Class

For a list of all members of this type, see UPCABarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

UPCABarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.CF Send comments on this topic.
UPCEBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : UPCEBarcode Class

For a list of all members of this type, see UPCEBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Gets the image of the barcode at the current graphics resolution. (Inherited from Barcode)
Public Method | GetSize | Gets the size of the barcode image at the specified horizontal and vertical resolutions using the given renderer. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

UPCEBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.CF Send comments on this topic.
UPCEBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : UPCEBarcode Class

For a list of all members of this type, see UPCEBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

UPCEBarcode Class
O2S.Barcode4NET Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET.CF Send comments on this topic.
O2S.Barcode4NET Namespace (Barcode4NET.CF) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.BasePDF417Barcode
O2S.Barcode4NET.MicroPDF417Barcode
O2S.Barcode4NET.PDF417Barcode
O2S.Barcode4NET.CodablockFBarcode
O2S.Barcode4NET.Code16KBarcode
O2S.Barcode4NET.DataMatrixBarcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.CodabarBarcode
O2S.Barcode4NET.Code11Barcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code128ABarcode
O2S.Barcode4NET.Code128BBarcode
O2S.Barcode4NET.Code128CBarcode
O2S.Barcode4NET.SCC14Barcode
O2S.Barcode4NET.SSCC18Barcode
O2S.Barcode4NET.Code25Barcode
O2S.Barcode4NET.Code25InterleavedBarcode
O2S.Barcode4NET.COOP25Barcode
O2S.Barcode4NET.IATA25Barcode
O2S.Barcode4NET.Matrix25Barcode
O2S.Barcode4NET.Code39Barcode
O2S.Barcode4NET.Code39ExtendedBarcode
O2S.Barcode4NET.Code93Barcode
O2S.Barcode4NET.Code93ExtendedBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.EAN13Barcode
O2S.Barcode4NET.EAN8Barcode
O2S.Barcode4NET.ISBNBarcode
O2S.Barcode4NET.ISMNBarcode
O2S.Barcode4NET.ISSNBarcode
O2S.Barcode4NET.JAN13Barcode
O2S.Barcode4NET.UPCABarcode
O2S.Barcode4NET.UPCEBarcode
O2S.Barcode4NET.HeightModulatedBarcode
O2S.Barcode4NET.PlanetBarcode
O2S.Barcode4NET.PostnetBarcode
O2S.Barcode4NET.RM4SCCBarcode
O2S.Barcode4NET.MSIPlesseyBarcode
System.Exception
System.ApplicationException
O2S.Barcode4NET.BarcodeEncodingException

See Also

Reference

Barcode4NET.CF Assembly


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Implicit Type Conversion(Int32) Operator
See Also
[image]
Internal Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(Int32) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Integer _
) As BigInteger
C#
public BigInteger operator implicit(
   int value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   int value
)
C++/CLI
public:
BigInteger^ operator implicit(
   int value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Implicit Type Conversion(Int64) Operator
See Also
[image]
Internal Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(Int64) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Long _
) As BigInteger
C#
public BigInteger operator implicit(
   long value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   long value
)
C++/CLI
public:
BigInteger^ operator implicit(
   long value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Implicit Type Conversion(UInt32) Operator
See Also
[image]
Internal Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(UInt32) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As UInteger _
) As BigInteger
C#
public BigInteger operator implicit(
   uint value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   uint value
)
C++/CLI
public:
BigInteger^ operator implicit(
   uint value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Implicit Type Conversion(UInt64) Operator
See Also
[image]
Internal Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(UInt64) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As ULong _
) As BigInteger
C#
public BigInteger operator implicit(
   ulong value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   ulong value
)
C++/CLI
public:
BigInteger^ operator implicit(
   ulong value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET.RS.Design Send comments on this topic.
Internal Namespace (Barcode4NET.RS.Design) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
Internal.BigInteger
Internal.CommonRegexes

See Also

Reference

Barcode4NET.RS.Design Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET.RS.Design Send comments on this topic.
O2S.Barcode4NET.Licensing Namespace (Barcode4NET.RS.Design) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Licensing.LicenseValidator

See Also

Reference

Barcode4NET.RS.Design Assembly


%%PageItemTitle%% $$Events$$

Barcode4NET.RS.Design Send comments on this topic.
BarcodeDesigner Class Events
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace : BarcodeDesigner Class

For a list of all members of this type, see BarcodeDesigner members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from Microsoft.ReportDesigner.CustomReportItemDesigner)
Top

See Also

Reference

BarcodeDesigner Class
O2S.Barcode4NET.ReportingServices.Design Namespace


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ActionInfo Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : ActionInfo Property

Syntax

Visual Basic (Declaration)
Public Property ActionInfo As ActionInfo
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As ActionInfo

instance.ActionInfo = value

value = instance.ActionInfo
C#
public ActionInfo ActionInfo {get; set;}
Managed Extensions for C++
public: __property ActionInfo get_ActionInfo();
public: __property void set_ActionInfo(
   ActionInfo value
);
C++/CLI
public:
property ActionInfo ActionInfo {
   ActionInfo get();
   void set (ActionInfo value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Adornment Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Adornment Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Adornment As Adornment
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Adornment

value = instance.Adornment
C#
public virtual Adornment Adornment {get;}
Managed Extensions for C++
public: __property virtual Adornment get_Adornment();
C++/CLI
public:
virtual property Adornment Adornment {
   Adornment get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
AltReportItem Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : AltReportItem Property

Syntax

Visual Basic (Declaration)
Public Property AltReportItem As XmlElement
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As XmlElement

instance.AltReportItem = value

value = instance.AltReportItem
C#
public XmlElement AltReportItem {get; set;}
Managed Extensions for C++
public: __property XmlElement get_AltReportItem();
public: __property void set_AltReportItem(
   XmlElement value
);
C++/CLI
public:
property XmlElement AltReportItem {
   XmlElement get();
   void set (XmlElement value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
BeginEdit Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : BeginEdit Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub BeginEdit()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner

instance.BeginEdit()
C#
public virtual void BeginEdit()
Managed Extensions for C++
public: virtual void BeginEdit();
C++/CLI
public:
virtual void BeginEdit();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Bookmark Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Bookmark Property

Syntax

Visual Basic (Declaration)
Public Property Bookmark As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As String

instance.Bookmark = value

value = instance.Bookmark
C#
public string Bookmark {get; set;}
Managed Extensions for C++
public: __property string* get_Bookmark();
public: __property void set_Bookmark(
   string* value
);
C++/CLI
public:
property String^ Bookmark {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
CustomData Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : CustomData Property

Syntax

Visual Basic (Declaration)
Public Property CustomData As CustomData
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As CustomData

instance.CustomData = value

value = instance.CustomData
C#
public CustomData CustomData {get; set;}
Managed Extensions for C++
public: __property CustomData get_CustomData();
public: __property void set_CustomData(
   CustomData value
);
C++/CLI
public:
property CustomData CustomData {
   CustomData get();
   void set (CustomData value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
CustomProperties Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : CustomProperties Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CustomProperties As Dictionary(Of String, String)
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Dictionary(Of String, String)

value = instance.CustomProperties
C#
public Dictionary<string, string> CustomProperties {get;}
Managed Extensions for C++
public: __property Dictionary<string, string>* get_CustomProperties();
C++/CLI
public:
property Dictionary<String, String>^ CustomProperties {
   Dictionary<String, String>^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
DataElementName Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : DataElementName Property

Syntax

Visual Basic (Declaration)
Public Property DataElementName As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As String

instance.DataElementName = value

value = instance.DataElementName
C#
public string DataElementName {get; set;}
Managed Extensions for C++
public: __property string* get_DataElementName();
public: __property void set_DataElementName(
   string* value
);
C++/CLI
public:
property String^ DataElementName {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
DataElementOutput Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : DataElementOutput Property

Syntax

Visual Basic (Declaration)
Public Property DataElementOutput As DataElementOutputs
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As DataElementOutputs

instance.DataElementOutput = value

value = instance.DataElementOutput
C#
public DataElementOutputs DataElementOutput {get; set;}
Managed Extensions for C++
public: __property DataElementOutputs get_DataElementOutput();
public: __property void set_DataElementOutput(
   DataElementOutputs value
);
C++/CLI
public:
property DataElementOutputs DataElementOutput {
   DataElementOutputs get();
   void set (DataElementOutputs value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
DefaultSize Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : DefaultSize Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DefaultSize As DesignSize
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As DesignSize

value = instance.DefaultSize
C#
public virtual DesignSize DefaultSize {get;}
Managed Extensions for C++
public: __property virtual DesignSize get_DefaultSize();
C++/CLI
public:
virtual property DesignSize DefaultSize {
   DesignSize get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
DisplayRectangle Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : DisplayRectangle Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisplayRectangle As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Rectangle

value = instance.DisplayRectangle
C#
public Rectangle DisplayRectangle {get;}
Managed Extensions for C++
public: __property Rectangle get_DisplayRectangle();
C++/CLI
public:
property Rectangle DisplayRectangle {
   Rectangle get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Dispose Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Dispose Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner

instance.Dispose()
C#
public virtual void Dispose()
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Disposed Event
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Disposed Event

Syntax

Visual Basic (Declaration)
Public Event Disposed() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
public event EventHandler Disposed()
Managed Extensions for C++
public: __event EventHandler* Disposed();
C++/CLI
public:
event EventHandler^ Disposed();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
DoDefaultAction Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : DoDefaultAction Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub DoDefaultAction()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner

instance.DoDefaultAction()
C#
public virtual void DoDefaultAction()
Managed Extensions for C++
public: virtual void DoDefaultAction();
C++/CLI
public:
virtual void DoDefaultAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
EndEdit Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : EndEdit Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndEdit()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner

instance.EndEdit()
C#
public virtual void EndEdit()
Managed Extensions for C++
public: virtual void EndEdit();
C++/CLI
public:
virtual void EndEdit();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Height Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Height Property

Syntax

Visual Basic (Declaration)
Public Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Unit

instance.Height = value

value = instance.Height
C#
public Unit Height {get; set;}
Managed Extensions for C++
public: __property Unit get_Height();
public: __property void set_Height(
   Unit value
);
C++/CLI
public:
property Unit Height {
   Unit get();
   void set (Unit value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
InitializeNewComponent Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : InitializeNewComponent Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub InitializeNewComponent()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner

instance.InitializeNewComponent()
C#
public virtual void InitializeNewComponent()
Managed Extensions for C++
public: virtual void InitializeNewComponent();
C++/CLI
public:
virtual void InitializeNewComponent();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Invalidate Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Invalidate Method

Syntax

Visual Basic (Declaration)
Public Sub Invalidate()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner

instance.Invalidate()
C#
public void Invalidate()
Managed Extensions for C++
public: void Invalidate();
C++/CLI
public:
void Invalidate();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Label Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Label Property

Syntax

Visual Basic (Declaration)
Public Property Label As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As String

instance.Label = value

value = instance.Label
C#
public string Label {get; set;}
Managed Extensions for C++
public: __property string* get_Label();
public: __property void set_Label(
   string* value
);
C++/CLI
public:
property String^ Label {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Name Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Name Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As String

value = instance.Name
C#
public string Name {get;}
Managed Extensions for C++
public: __property string* get_Name();
C++/CLI
public:
property String^ Name {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
OnBackgroundColorChanged Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : OnBackgroundColorChanged Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnBackgroundColorChanged()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner

instance.OnBackgroundColorChanged()
C#
public virtual void OnBackgroundColorChanged()
Managed Extensions for C++
public: virtual void OnBackgroundColorChanged();
C++/CLI
public:
virtual void OnBackgroundColorChanged();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
OnColorChanged Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : OnColorChanged Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnColorChanged()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner

instance.OnColorChanged()
C#
public virtual void OnColorChanged()
Managed Extensions for C++
public: virtual void OnColorChanged();
C++/CLI
public:
virtual void OnColorChanged();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
OnDragDrop Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : OnDragDrop Method

e

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnDragDrop( _
   ByVal e As DragEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim e As DragEventArgs

instance.OnDragDrop(e)
C#
public virtual void OnDragDrop(
   DragEventArgs e
)
Managed Extensions for C++
public: virtual void OnDragDrop(
   DragEventArgs e
)
C++/CLI
public:
virtual void OnDragDrop(
   DragEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
OnDragEnter Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : OnDragEnter Method

e

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnDragEnter( _
   ByVal e As DragEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim e As DragEventArgs

instance.OnDragEnter(e)
C#
public virtual void OnDragEnter(
   DragEventArgs e
)
Managed Extensions for C++
public: virtual void OnDragEnter(
   DragEventArgs e
)
C++/CLI
public:
virtual void OnDragEnter(
   DragEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
OnDragLeave Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : OnDragLeave Method

e

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnDragLeave( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim e As EventArgs

instance.OnDragLeave(e)
C#
public virtual void OnDragLeave(
   EventArgs e
)
Managed Extensions for C++
public: virtual void OnDragLeave(
   EventArgs* e
)
C++/CLI
public:
virtual void OnDragLeave(
   EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
OnDragOver Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : OnDragOver Method

e

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnDragOver( _
   ByVal e As DragEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim e As DragEventArgs

instance.OnDragOver(e)
C#
public virtual void OnDragOver(
   DragEventArgs e
)
Managed Extensions for C++
public: virtual void OnDragOver(
   DragEventArgs e
)
C++/CLI
public:
virtual void OnDragOver(
   DragEventArgs e
)

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
OnLocationChanged Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : OnLocationChanged Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnLocationChanged()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner

instance.OnLocationChanged()
C#
public virtual void OnLocationChanged()
Managed Extensions for C++
public: virtual void OnLocationChanged();
C++/CLI
public:
virtual void OnLocationChanged();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
OnPaddingChanged Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : OnPaddingChanged Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPaddingChanged()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner

instance.OnPaddingChanged()
C#
public virtual void OnPaddingChanged()
Managed Extensions for C++
public: virtual void OnPaddingChanged();
C++/CLI
public:
virtual void OnPaddingChanged();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
OnSizeChanged Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : OnSizeChanged Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnSizeChanged()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner

instance.OnSizeChanged()
C#
public virtual void OnSizeChanged()
Managed Extensions for C++
public: virtual void OnSizeChanged();
C++/CLI
public:
virtual void OnSizeChanged();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
OnTextAlignChanged Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : OnTextAlignChanged Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnTextAlignChanged()
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner

instance.OnTextAlignChanged()
C#
public virtual void OnTextAlignChanged()
Managed Extensions for C++
public: virtual void OnTextAlignChanged();
C++/CLI
public:
virtual void OnTextAlignChanged();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
RepeatWith Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : RepeatWith Property

Syntax

Visual Basic (Declaration)
Public Property RepeatWith As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As String

instance.RepeatWith = value

value = instance.RepeatWith
C#
public string RepeatWith {get; set;}
Managed Extensions for C++
public: __property string* get_RepeatWith();
public: __property void set_RepeatWith(
   string* value
);
C++/CLI
public:
property String^ RepeatWith {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Report Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Report Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As IReport
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As IReport

value = instance.Report
C#
public IReport Report {get;}
Managed Extensions for C++
public: __property IReport get_Report();
C++/CLI
public:
property IReport Report {
   IReport get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ScreenLocation Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : ScreenLocation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ScreenLocation As Point
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Point

value = instance.ScreenLocation
C#
public Point ScreenLocation {get;}
Managed Extensions for C++
public: __property Point get_ScreenLocation();
C++/CLI
public:
property Point ScreenLocation {
   Point get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ShowContextMenu Method
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : ShowContextMenu Method

x
y

Syntax

Visual Basic (Declaration)
Public Overridable Function ShowContextMenu( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim x As Integer
Dim y As Integer
Dim value As Boolean

value = instance.ShowContextMenu(x, y)
C#
public virtual bool ShowContextMenu(
   int x,
   int y
)
Managed Extensions for C++
public: virtual bool ShowContextMenu(
   int x,
   int y
)
C++/CLI
public:
virtual bool ShowContextMenu(
   int x,
   int y
)

Parameters

x
y

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Site Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Site Property

Syntax

Visual Basic (Declaration)
Public Property Site As ISite
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As ISite

instance.Site = value

value = instance.Site
C#
public ISite Site {get; set;}
Managed Extensions for C++
public: __property ISite get_Site();
public: __property void set_Site(
   ISite value
);
C++/CLI
public:
property ISite Site {
   ISite get();
   void set (ISite value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Style Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Style Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As Style
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Style

value = instance.Style
C#
public Style Style {get;}
Managed Extensions for C++
public: __property Style get_Style();
C++/CLI
public:
property Style Style {
   Style get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
ToolTip Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : ToolTip Property

Syntax

Visual Basic (Declaration)
Public Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
public string ToolTip {get; set;}
Managed Extensions for C++
public: __property string* get_ToolTip();
public: __property void set_ToolTip(
   string* value
);
C++/CLI
public:
property String^ ToolTip {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Type Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Type Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As String
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As String

value = instance.Type
C#
public string Type {get;}
Managed Extensions for C++
public: __property string* get_Type();
C++/CLI
public:
property String^ Type {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Verbs Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Verbs Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Verbs As DesignerVerbCollection
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As DesignerVerbCollection

value = instance.Verbs
C#
public virtual DesignerVerbCollection Verbs {get;}
Managed Extensions for C++
public: __property virtual DesignerVerbCollection get_Verbs();
C++/CLI
public:
virtual property DesignerVerbCollection Verbs {
   DesignerVerbCollection get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Visibility Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Visibility Property

Syntax

Visual Basic (Declaration)
Public Property Visibility As Visibility
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Visibility

instance.Visibility = value

value = instance.Visibility
C#
public Visibility Visibility {get; set;}
Managed Extensions for C++
public: __property Visibility get_Visibility();
public: __property void set_Visibility(
   Visibility value
);
C++/CLI
public:
property Visibility Visibility {
   Visibility get();
   void set (Visibility value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Width Property
See Also
[image]
O2S.Barcode4NET.ReportingServices.Design Namespace > BarcodeDesigner Class : Width Property

Syntax

Visual Basic (Declaration)
Public Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As BarcodeDesigner
Dim value As Unit

instance.Width = value

value = instance.Width
C#
public Unit Width {get; set;}
Managed Extensions for C++
public: __property Unit get_Width();
public: __property void set_Width(
   Unit value
);
C++/CLI
public:
property Unit Width {
   Unit get();
   void set (Unit value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeDesigner Class
BarcodeDesigner Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET.RS.Design Send comments on this topic.
O2S.Barcode4NET.ReportingServices.Design Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
Microsoft.ReportDesigner.CustomReportItemDesigner
O2S.Barcode4NET.ReportingServices.Design.BarcodeDesigner

See Also

Reference

Barcode4NET.RS.Design Assembly


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Implicit Type Conversion(Int32) Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(Int32) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Integer _
) As BigInteger
C#
public BigInteger operator implicit(
   int value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   int value
)
C++/CLI
public:
BigInteger^ operator implicit(
   int value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Implicit Type Conversion(Int64) Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(Int64) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Long _
) As BigInteger
C#
public BigInteger operator implicit(
   long value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   long value
)
C++/CLI
public:
BigInteger^ operator implicit(
   long value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Implicit Type Conversion(UInt32) Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(UInt32) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As UInteger _
) As BigInteger
C#
public BigInteger operator implicit(
   uint value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   uint value
)
C++/CLI
public:
BigInteger^ operator implicit(
   uint value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.RS.Design Send comments on this topic.
Implicit Type Conversion(UInt64) Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(UInt64) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As ULong _
) As BigInteger
C#
public BigInteger operator implicit(
   ulong value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   ulong value
)
C++/CLI
public:
BigInteger^ operator implicit(
   ulong value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
ExtendedLicenseException Class Methods
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicenseException Class

For a list of all members of this type, see ExtendedLicenseException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ExtendedLicenseException Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.RS.Design Send comments on this topic.
LicenseValuesCollection Class Properties
See Also
[image]
Xheo.Licensing Namespace : LicenseValuesCollection Class

For a list of all members of this type, see LicenseValuesCollection members.

Public Properties

 | Name | Description
Public Property | AllKeys | Gets all the keys in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Property | Count | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Property | Item | Overloaded. Gets or sets the entry with the specified key in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Property | Keys | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top

See Also

Reference

LicenseValuesCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile._MEMORYSTATUS Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUS Structure

For a list of all members of this type, see MachineProfile._MEMORYSTATUS members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile._MEMORYSTATUSEX Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUSEX Structure

For a list of all members of this type, see MachineProfile._MEMORYSTATUSEX members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure

For a list of all members of this type, see MachineProfile.IP_ADAPTERINFO_STRUCTURE members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.IP_ADDR_STRING Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADDR_STRING Structure

For a list of all members of this type, see MachineProfile.IP_ADDR_STRING members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.RS.Design Send comments on this topic.
MachineProfile.TGuid Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.TGuid Structure

For a list of all members of this type, see MachineProfile.TGuid members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.TGuid Structure
Xheo.Licensing Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET.RS.Design Send comments on this topic.
Xheo.Licensing Namespace (Barcode4NET.RS.Design) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Xheo.Licensing.ExtendedLicensePack
Xheo.Licensing.TransientReadOnlyCollection
Xheo.Licensing.LimitCollection
System.Collections.Specialized.NameObjectCollectionBase
System.Collections.Specialized.NameValueCollection
Xheo.Licensing.LicenseValuesCollection
System.ComponentModel.License
Xheo.Licensing.ExtendedLicense
System.Exception
System.ApplicationException
Xheo.Licensing.ExtendedLicenseException
System.MarshalByRefObject
Xheo.Licensing.Limit
Xheo.Licensing.ContainerLimit
Xheo.Licensing.BigInteger
Xheo.Licensing.LicenseSigningKey
Xheo.Licensing.MachineProfile
Xheo.Licensing.MachineProfile.Constants
Xheo.Licensing.MachineProfile.GetAdapterInfo
Xheo.Licensing.StateEntry

See Also

Reference

Barcode4NET.RS.Design Assembly


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Implicit Type Conversion(Int32) Operator
See Also
[image]
Internal Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(Int32) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Integer _
) As BigInteger
C#
public BigInteger operator implicit(
   int value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   int value
)
C++/CLI
public:
BigInteger^ operator implicit(
   int value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Implicit Type Conversion(Int64) Operator
See Also
[image]
Internal Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(Int64) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Long _
) As BigInteger
C#
public BigInteger operator implicit(
   long value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   long value
)
C++/CLI
public:
BigInteger^ operator implicit(
   long value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Implicit Type Conversion(UInt32) Operator
See Also
[image]
Internal Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(UInt32) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As UInteger _
) As BigInteger
C#
public BigInteger operator implicit(
   uint value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   uint value
)
C++/CLI
public:
BigInteger^ operator implicit(
   uint value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Implicit Type Conversion(UInt64) Operator
See Also
[image]
Internal Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(UInt64) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As ULong _
) As BigInteger
C#
public BigInteger operator implicit(
   ulong value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   ulong value
)
C++/CLI
public:
BigInteger^ operator implicit(
   ulong value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET.Web Send comments on this topic.
Internal Namespace (Barcode4NET.Web) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
Internal.BigInteger
Internal.CommonRegexes

See Also

Reference

Barcode4NET.Web Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET.Web Send comments on this topic.
O2S.Barcode4NET.Licensing Namespace (Barcode4NET.Web) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Licensing.LicenseValidator

See Also

Reference

Barcode4NET.Web Assembly


%%PageItemTitle%% $$Events$$

Barcode4NET.Web Send comments on this topic.
BarcodeView Class Events
See Also
[image]
O2S.Barcode4NET.WebControls Namespace : BarcodeView Class

For a list of all members of this type, see BarcodeView members.

Public Events

 | Name | Description
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | Load | Occurs when the server control is loaded into the Page object. (Inherited from System.Web.UI.Control)
Public Event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top

See Also

Reference

BarcodeView Class
O2S.Barcode4NET.WebControls Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
BarcodeView Class Methods
See Also
[image]
O2S.Barcode4NET.WebControls Namespace : BarcodeView Class

For a list of all members of this type, see BarcodeView members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from System.Web.UI.Control)
Public Method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from System.Web.UI.Control)
Public Method | FindControl | Searches the current naming container for a server control with the specified id parameter. (Inherited from System.Web.UI.Control)
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Top

See Also

Reference

BarcodeView Class
O2S.Barcode4NET.WebControls Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET.Web Send comments on this topic.
O2S.Barcode4NET.WebControls Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.WebControls.BarcodeService
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
O2S.Barcode4NET.WebControls.BarcodeView

See Also

Reference

Barcode4NET.Web Assembly


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Implicit Type Conversion(Int32) Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(Int32) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Integer _
) As BigInteger
C#
public BigInteger operator implicit(
   int value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   int value
)
C++/CLI
public:
BigInteger^ operator implicit(
   int value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Implicit Type Conversion(Int64) Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(Int64) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Long _
) As BigInteger
C#
public BigInteger operator implicit(
   long value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   long value
)
C++/CLI
public:
BigInteger^ operator implicit(
   long value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Implicit Type Conversion(UInt32) Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(UInt32) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As UInteger _
) As BigInteger
C#
public BigInteger operator implicit(
   uint value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   uint value
)
C++/CLI
public:
BigInteger^ operator implicit(
   uint value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Web Send comments on this topic.
Implicit Type Conversion(UInt64) Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(UInt64) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As ULong _
) As BigInteger
C#
public BigInteger operator implicit(
   ulong value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   ulong value
)
C++/CLI
public:
BigInteger^ operator implicit(
   ulong value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
ExtendedLicenseException Class Methods
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicenseException Class

For a list of all members of this type, see ExtendedLicenseException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ExtendedLicenseException Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.Web Send comments on this topic.
LicenseValuesCollection Class Properties
See Also
[image]
Xheo.Licensing Namespace : LicenseValuesCollection Class

For a list of all members of this type, see LicenseValuesCollection members.

Public Properties

 | Name | Description
Public Property | AllKeys | Gets all the keys in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Property | Count | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Property | Item | Overloaded. Gets or sets the entry with the specified key in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Property | Keys | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top

See Also

Reference

LicenseValuesCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
MachineProfile._MEMORYSTATUS Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUS Structure

For a list of all members of this type, see MachineProfile._MEMORYSTATUS members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
MachineProfile._MEMORYSTATUSEX Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUSEX Structure

For a list of all members of this type, see MachineProfile._MEMORYSTATUSEX members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure

For a list of all members of this type, see MachineProfile.IP_ADAPTERINFO_STRUCTURE members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
MachineProfile.IP_ADDR_STRING Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADDR_STRING Structure

For a list of all members of this type, see MachineProfile.IP_ADDR_STRING members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Web Send comments on this topic.
MachineProfile.TGuid Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.TGuid Structure

For a list of all members of this type, see MachineProfile.TGuid members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.TGuid Structure
Xheo.Licensing Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET.Web Send comments on this topic.
Xheo.Licensing Namespace (Barcode4NET.Web) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Xheo.Licensing.ExtendedLicensePack
Xheo.Licensing.TransientReadOnlyCollection
Xheo.Licensing.LimitCollection
System.Collections.Specialized.NameObjectCollectionBase
System.Collections.Specialized.NameValueCollection
Xheo.Licensing.LicenseValuesCollection
System.ComponentModel.License
Xheo.Licensing.ExtendedLicense
System.Exception
System.ApplicationException
Xheo.Licensing.ExtendedLicenseException
System.MarshalByRefObject
Xheo.Licensing.Limit
Xheo.Licensing.ContainerLimit
Xheo.Licensing.BigInteger
Xheo.Licensing.LicenseSigningKey
Xheo.Licensing.MachineProfile
Xheo.Licensing.MachineProfile.Constants
Xheo.Licensing.MachineProfile.GetAdapterInfo
Xheo.Licensing.StateEntry

See Also

Reference

Barcode4NET.Web Assembly


%%PageItemTitle%% $$Events$$

Barcode4NET.Windows.CF Send comments on this topic.
BarcodeView Class Events
See Also
[image]
O2S.Barcode4NET.WinControls Namespace : BarcodeView Class

For a list of all members of this type, see BarcodeView members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | SizeChanged | Occurs when the Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

BarcodeView Class
O2S.Barcode4NET.WinControls Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows.CF Send comments on this topic.
BarcodeView Class Methods
See Also
[image]
O2S.Barcode4NET.WinControls Namespace : BarcodeView Class

For a list of all members of this type, see BarcodeView members.

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Clean up any resources being used. Releases all resources used by the Component. (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

BarcodeView Class
O2S.Barcode4NET.WinControls Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET.Windows.CF Send comments on this topic.
O2S.Barcode4NET.WinControls Namespace (Barcode4NET.Windows.CF) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
O2S.Barcode4NET.WinControls.BarcodeView

See Also

Reference

Barcode4NET.Windows.CF Assembly


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Implicit Type Conversion(Int32) Operator
See Also
[image]
Internal Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(Int32) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Integer _
) As BigInteger
C#
public BigInteger operator implicit(
   int value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   int value
)
C++/CLI
public:
BigInteger^ operator implicit(
   int value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Implicit Type Conversion(Int64) Operator
See Also
[image]
Internal Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(Int64) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Long _
) As BigInteger
C#
public BigInteger operator implicit(
   long value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   long value
)
C++/CLI
public:
BigInteger^ operator implicit(
   long value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Implicit Type Conversion(UInt32) Operator
See Also
[image]
Internal Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(UInt32) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As UInteger _
) As BigInteger
C#
public BigInteger operator implicit(
   uint value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   uint value
)
C++/CLI
public:
BigInteger^ operator implicit(
   uint value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Implicit Type Conversion(UInt64) Operator
See Also
[image]
Internal Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(UInt64) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As ULong _
) As BigInteger
C#
public BigInteger operator implicit(
   ulong value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   ulong value
)
C++/CLI
public:
BigInteger^ operator implicit(
   ulong value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET.Windows Send comments on this topic.
Internal Namespace (Barcode4NET.Windows) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
Internal.BigInteger
Internal.CommonRegexes

See Also

Reference

Barcode4NET.Windows Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET.Windows Send comments on this topic.
O2S.Barcode4NET.Licensing Namespace (Barcode4NET.Windows) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Licensing.LicenseValidator

See Also

Reference

Barcode4NET.Windows Assembly


%%PageItemTitle%% $$Events$$

Barcode4NET.Windows Send comments on this topic.
BarcodeTextBox Class Events
See Also
[image]
O2S.Barcode4NET.WinControls Namespace : BarcodeTextBox Class

For a list of all members of this type, see BarcodeTextBox members.

Public Events

 | Name | Description
Public Event | AcceptsTabChanged | Occurs when the value of the AcceptsTab property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BorderStyleChanged | Occurs when the value of the BorderStyle property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
Public Event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the text box is clicked. (Inherited from System.Windows.Forms.TextBoxBase)
Public Event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | HideSelectionChanged | Occurs when the value of the HideSelection property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
Public Event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | ModifiedChanged | Occurs when the value of the Modified property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.TextBoxBase)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | MultilineChanged | Occurs when the value of the Multiline property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | ReadOnlyChanged | Occurs when the value of the ReadOnly property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
Public Event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | SizeChanged | Occurs when the Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TextAlignChanged | Occurs when the value of the TextAlign property has changed. (Inherited from System.Windows.Forms.TextBox)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

BarcodeTextBox Class
O2S.Barcode4NET.WinControls Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
BarcodeTextBox Class Methods
See Also
[image]
O2S.Barcode4NET.WinControls Namespace : BarcodeTextBox Class

For a list of all members of this type, see BarcodeTextBox members.

Public Methods

 | Name | Description
Public Method | AppendText | Appends text to the current text of a text box. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Clear | Clears all text from the text box control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | DeselectAll | Specifies that the value of the SelectionLength property is zero so that no characters are selected in the control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | Dispose | Clean up any resources being used. Releases all resources used by the Component. (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | Paste | Overloaded. Replaces the specified selection in the TextBox with the contents of the Clipboard. (Inherited from System.Windows.Forms.TextBox)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | Select | Overloaded. Selects a range of text in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | SelectAll | Selects all text in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | Returns a string that represents the TextBoxBase control. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | Undo | Undoes the last edit operation in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

BarcodeTextBox Class
O2S.Barcode4NET.WinControls Namespace


%%PageItemTitle%% $$Events$$

Barcode4NET.Windows Send comments on this topic.
BarcodeView Class Events
See Also
[image]
O2S.Barcode4NET.WinControls Namespace : BarcodeView Class

For a list of all members of this type, see BarcodeView members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | Occurs when the Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | SizeChanged | Occurs when the Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

BarcodeView Class
O2S.Barcode4NET.WinControls Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
BarcodeView Class Methods
See Also
[image]
O2S.Barcode4NET.WinControls Namespace : BarcodeView Class

For a list of all members of this type, see BarcodeView members.

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Clean up any resources being used. Releases all resources used by the Component. (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

BarcodeView Class
O2S.Barcode4NET.WinControls Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET.Windows Send comments on this topic.
O2S.Barcode4NET.WinControls Namespace (Barcode4NET.Windows) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
O2S.Barcode4NET.WinControls.BarcodeView
System.Windows.Forms.TextBoxBase
System.Windows.Forms.TextBox
O2S.Barcode4NET.WinControls.BarcodeTextBox

See Also

Reference

Barcode4NET.Windows Assembly


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Implicit Type Conversion(Int32) Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(Int32) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Integer _
) As BigInteger
C#
public BigInteger operator implicit(
   int value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   int value
)
C++/CLI
public:
BigInteger^ operator implicit(
   int value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Implicit Type Conversion(Int64) Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(Int64) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Long _
) As BigInteger
C#
public BigInteger operator implicit(
   long value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   long value
)
C++/CLI
public:
BigInteger^ operator implicit(
   long value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Implicit Type Conversion(UInt32) Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(UInt32) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As UInteger _
) As BigInteger
C#
public BigInteger operator implicit(
   uint value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   uint value
)
C++/CLI
public:
BigInteger^ operator implicit(
   uint value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET.Windows Send comments on this topic.
Implicit Type Conversion(UInt64) Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(UInt64) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As ULong _
) As BigInteger
C#
public BigInteger operator implicit(
   ulong value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   ulong value
)
C++/CLI
public:
BigInteger^ operator implicit(
   ulong value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
ExtendedLicenseException Class Methods
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicenseException Class

For a list of all members of this type, see ExtendedLicenseException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ExtendedLicenseException Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET.Windows Send comments on this topic.
LicenseValuesCollection Class Properties
See Also
[image]
Xheo.Licensing Namespace : LicenseValuesCollection Class

For a list of all members of this type, see LicenseValuesCollection members.

Public Properties

 | Name | Description
Public Property | AllKeys | Gets all the keys in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Property | Count | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Property | Item | Overloaded. Gets or sets the entry with the specified key in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Property | Keys | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top

See Also

Reference

LicenseValuesCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile._MEMORYSTATUS Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUS Structure

For a list of all members of this type, see MachineProfile._MEMORYSTATUS members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile._MEMORYSTATUSEX Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUSEX Structure

For a list of all members of this type, see MachineProfile._MEMORYSTATUSEX members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure

For a list of all members of this type, see MachineProfile.IP_ADAPTERINFO_STRUCTURE members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile.IP_ADDR_STRING Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADDR_STRING Structure

For a list of all members of this type, see MachineProfile.IP_ADDR_STRING members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET.Windows Send comments on this topic.
MachineProfile.TGuid Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.TGuid Structure

For a list of all members of this type, see MachineProfile.TGuid members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.TGuid Structure
Xheo.Licensing Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET.Windows Send comments on this topic.
Xheo.Licensing Namespace (Barcode4NET.Windows) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Xheo.Licensing.ExtendedLicensePack
Xheo.Licensing.TransientReadOnlyCollection
Xheo.Licensing.LimitCollection
System.Collections.Specialized.NameObjectCollectionBase
System.Collections.Specialized.NameValueCollection
Xheo.Licensing.LicenseValuesCollection
System.ComponentModel.License
Xheo.Licensing.ExtendedLicense
System.Exception
System.ApplicationException
Xheo.Licensing.ExtendedLicenseException
System.MarshalByRefObject
Xheo.Licensing.Limit
Xheo.Licensing.ContainerLimit
Xheo.Licensing.BigInteger
Xheo.Licensing.LicenseSigningKey
Xheo.Licensing.MachineProfile
Xheo.Licensing.MachineProfile.Constants
Xheo.Licensing.MachineProfile.GetAdapterInfo
Xheo.Licensing.StateEntry

See Also

Reference

Barcode4NET.Windows Assembly


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Implicit Type Conversion(Int32) Operator
See Also
[image]
Internal Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(Int32) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Integer _
) As BigInteger
C#
public BigInteger operator implicit(
   int value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   int value
)
C++/CLI
public:
BigInteger^ operator implicit(
   int value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Implicit Type Conversion(Int64) Operator
See Also
[image]
Internal Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(Int64) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Long _
) As BigInteger
C#
public BigInteger operator implicit(
   long value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   long value
)
C++/CLI
public:
BigInteger^ operator implicit(
   long value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Implicit Type Conversion(UInt32) Operator
See Also
[image]
Internal Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(UInt32) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As UInteger _
) As BigInteger
C#
public BigInteger operator implicit(
   uint value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   uint value
)
C++/CLI
public:
BigInteger^ operator implicit(
   uint value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Implicit Type Conversion(UInt64) Operator
See Also
[image]
Internal Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(UInt64) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As ULong _
) As BigInteger
C#
public BigInteger operator implicit(
   ulong value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   ulong value
)
C++/CLI
public:
BigInteger^ operator implicit(
   ulong value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET Send comments on this topic.
Internal Namespace (Barcode4NET) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
Internal.BigInteger
Internal.CommonRegexes

See Also

Reference

Barcode4NET Assembly


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
BarcodeEncodingException Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : BarcodeEncodingException Class

For a list of all members of this type, see BarcodeEncodingException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

BarcodeEncodingException Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
BarcodeEncodingException Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : BarcodeEncodingException Class

For a list of all members of this type, see BarcodeEncodingException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

BarcodeEncodingException Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
BidimensionalBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : BidimensionalBarcode Class

For a list of all members of this type, see BidimensionalBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

BidimensionalBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
CodabarBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : CodabarBarcode Class

For a list of all members of this type, see CodabarBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

CodabarBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
CodabarBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : CodabarBarcode Class

For a list of all members of this type, see CodabarBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

CodabarBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
CodablockFBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : CodablockFBarcode Class

For a list of all members of this type, see CodablockFBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

CodablockFBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
Code11Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code11Barcode Class

For a list of all members of this type, see Code11Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code11Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
Code11Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code11Barcode Class

For a list of all members of this type, see Code11Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code11Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
Code16KBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code16KBarcode Class

For a list of all members of this type, see Code16KBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code16KBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
Code25Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code25Barcode Class

For a list of all members of this type, see Code25Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
Code25Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code25Barcode Class

For a list of all members of this type, see Code25Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
Code25InterleavedBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code25InterleavedBarcode Class

For a list of all members of this type, see Code25InterleavedBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code25InterleavedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
Code25InterleavedBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code25InterleavedBarcode Class

For a list of all members of this type, see Code25InterleavedBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code25InterleavedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
Code39Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code39Barcode Class

For a list of all members of this type, see Code39Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code39Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
Code39ExtendedBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code39ExtendedBarcode Class

For a list of all members of this type, see Code39ExtendedBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code39ExtendedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
Code39ExtendedBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code39ExtendedBarcode Class

For a list of all members of this type, see Code39ExtendedBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from Code39Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code39ExtendedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
Code93Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code93Barcode Class

For a list of all members of this type, see Code93Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code93Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
Code93Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code93Barcode Class

For a list of all members of this type, see Code93Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code93Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
Code93ExtendedBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code93ExtendedBarcode Class

For a list of all members of this type, see Code93ExtendedBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code93ExtendedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
Code93ExtendedBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code93ExtendedBarcode Class

For a list of all members of this type, see Code93ExtendedBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code93ExtendedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
Code128ABarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code128ABarcode Class

For a list of all members of this type, see Code128ABarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code128ABarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
Code128ABarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code128ABarcode Class

For a list of all members of this type, see Code128ABarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code128ABarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
Code128Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code128Barcode Class

For a list of all members of this type, see Code128Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code128Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
Code128Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code128Barcode Class

For a list of all members of this type, see Code128Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code128Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
Code128BBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code128BBarcode Class

For a list of all members of this type, see Code128BBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code128BBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
Code128BBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code128BBarcode Class

For a list of all members of this type, see Code128BBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code128BBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
Code128CBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Code128CBarcode Class

For a list of all members of this type, see Code128CBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Code128CBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
Code128CBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Code128CBarcode Class

For a list of all members of this type, see Code128CBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Code128CBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
COOP25Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : COOP25Barcode Class

For a list of all members of this type, see COOP25Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

COOP25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
COOP25Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : COOP25Barcode Class

For a list of all members of this type, see COOP25Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

COOP25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
EAN8Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : EAN8Barcode Class

For a list of all members of this type, see EAN8Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

EAN8Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
EAN8Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : EAN8Barcode Class

For a list of all members of this type, see EAN8Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

EAN8Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
EAN13Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : EAN13Barcode Class

For a list of all members of this type, see EAN13Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

EAN13Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
EAN13Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : EAN13Barcode Class

For a list of all members of this type, see EAN13Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

EAN13Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
EANBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : EANBarcode Class

For a list of all members of this type, see EANBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

EANBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
HeightModulatedBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : HeightModulatedBarcode Class

For a list of all members of this type, see HeightModulatedBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

HeightModulatedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
HeightModulatedBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : HeightModulatedBarcode Class

For a list of all members of this type, see HeightModulatedBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

HeightModulatedBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
IATA25Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : IATA25Barcode Class

For a list of all members of this type, see IATA25Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

IATA25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
IATA25Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : IATA25Barcode Class

For a list of all members of this type, see IATA25Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

IATA25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
ISBNBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : ISBNBarcode Class

For a list of all members of this type, see ISBNBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

ISBNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
ISBNBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : ISBNBarcode Class

For a list of all members of this type, see ISBNBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

ISBNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
ISMNBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : ISMNBarcode Class

For a list of all members of this type, see ISMNBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

ISMNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
ISMNBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : ISMNBarcode Class

For a list of all members of this type, see ISMNBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

ISMNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
ISSNBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : ISSNBarcode Class

For a list of all members of this type, see ISSNBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

ISSNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
ISSNBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : ISSNBarcode Class

For a list of all members of this type, see ISSNBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

ISSNBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
JAN13Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : JAN13Barcode Class

For a list of all members of this type, see JAN13Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

JAN13Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
JAN13Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : JAN13Barcode Class

For a list of all members of this type, see JAN13Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

JAN13Barcode Class
O2S.Barcode4NET Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET Send comments on this topic.
O2S.Barcode4NET.Licensing Namespace (Barcode4NET) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Licensing.LicenseValidator

See Also

Reference

Barcode4NET Assembly


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
Matrix25Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : Matrix25Barcode Class

For a list of all members of this type, see Matrix25Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

Matrix25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
Matrix25Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : Matrix25Barcode Class

For a list of all members of this type, see Matrix25Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

Matrix25Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
MicroPDF417Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : MicroPDF417Barcode Class

For a list of all members of this type, see MicroPDF417Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from BasePDF417Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

MicroPDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
MSIPlesseyBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : MSIPlesseyBarcode Class

For a list of all members of this type, see MSIPlesseyBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

MSIPlesseyBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
MSIPlesseyBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : MSIPlesseyBarcode Class

For a list of all members of this type, see MSIPlesseyBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

MSIPlesseyBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
PDF417Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : PDF417Barcode Class

For a list of all members of this type, see PDF417Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from BasePDF417Barcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

PDF417Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
PlanetBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : PlanetBarcode Class

For a list of all members of this type, see PlanetBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

PlanetBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
PlanetBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : PlanetBarcode Class

For a list of all members of this type, see PlanetBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

PlanetBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
PostnetBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : PostnetBarcode Class

For a list of all members of this type, see PostnetBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

PostnetBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
PostnetBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : PostnetBarcode Class

For a list of all members of this type, see PostnetBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

PostnetBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
RM4SCCBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : RM4SCCBarcode Class

For a list of all members of this type, see RM4SCCBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

RM4SCCBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
RM4SCCBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : RM4SCCBarcode Class

For a list of all members of this type, see RM4SCCBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

RM4SCCBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
SCC14Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : SCC14Barcode Class

For a list of all members of this type, see SCC14Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

SCC14Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
SCC14Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : SCC14Barcode Class

For a list of all members of this type, see SCC14Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

SCC14Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
SSCC18Barcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : SSCC18Barcode Class

For a list of all members of this type, see SSCC18Barcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

SSCC18Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
SSCC18Barcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : SSCC18Barcode Class

For a list of all members of this type, see SSCC18Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

SSCC18Barcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
UPCABarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : UPCABarcode Class

For a list of all members of this type, see UPCABarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

UPCABarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
UPCABarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : UPCABarcode Class

For a list of all members of this type, see UPCABarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

UPCABarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
UPCEBarcode Class Methods
See Also
[image]
O2S.Barcode4NET Namespace : UPCEBarcode Class

For a list of all members of this type, see UPCEBarcode members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Draws the barcode on a graphics surface. (Inherited from Barcode)
Public Method | GetImage | Overloaded. Gets the image of the barcode at the specified resolution. (Inherited from Barcode)
Public Method | GetImageData | Gets the barcode image as a byte array. (Inherited from Barcode)
Public Method | GetSize | Overloaded. Gets the size of the barcode image at the specified resolution. (Inherited from Barcode)
Public Method | IsValidCharacterCode | Gets whether the given character code can be encoded by the barcode. (Inherited from UnidimensionalBarcode)
Public Method | Save | Overloaded. Saves this Barcode object to the specified file in the specified format. (Inherited from Barcode)
Top

See Also

Reference

UPCEBarcode Class
O2S.Barcode4NET Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
UPCEBarcode Class Properties
See Also
[image]
O2S.Barcode4NET Namespace : UPCEBarcode Class

For a list of all members of this type, see UPCEBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from Barcode)
Public Property | BarColor | Gets or sets the color of the bars. (Inherited from Barcode)
Public Property | BottomQuietZone | Gets or sets the bottom quiet zone of the barcode. (Inherited from Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from Barcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from UnidimensionalBarcode)
Public Property | DimensionUnit | Gets or sets the measure unit for the XDimension and YDimension properties. (Inherited from Barcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in barcode text. (Inherited from UnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from UnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from Barcode)
Public Property | LeftQuietZone | Gets or sets the left quiet zone of the barcode. (Inherited from Barcode)
Public Property | RightQuietZone | Gets or sets the right quiet zone of the barcode. (Inherited from Barcode)
Public Property | Rotation | Gets or sets the rotation angle of the barcode image. (Inherited from Barcode)
Public Property | SerialNumber | Gets or sets the serial number. (Inherited from Barcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from EANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from EANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from EANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from Barcode)
Public Property | TopQuietZone | Gets or sets the top quiet zone of the barcode. (Inherited from Barcode)
Public Property | XDimension | Gets or sets the width of a narrow bar. (Inherited from Barcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from Barcode)
Top

See Also

Reference

UPCEBarcode Class
O2S.Barcode4NET Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET Send comments on this topic.
O2S.Barcode4NET Namespace (Barcode4NET) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Barcode4NET.Barcode
O2S.Barcode4NET.BidimensionalBarcode
O2S.Barcode4NET.BasePDF417Barcode
O2S.Barcode4NET.MicroPDF417Barcode
O2S.Barcode4NET.PDF417Barcode
O2S.Barcode4NET.CodablockFBarcode
O2S.Barcode4NET.Code16KBarcode
O2S.Barcode4NET.DataMatrixBarcode
O2S.Barcode4NET.UnidimensionalBarcode
O2S.Barcode4NET.CodabarBarcode
O2S.Barcode4NET.Code11Barcode
O2S.Barcode4NET.Code128Barcode
O2S.Barcode4NET.Code128ABarcode
O2S.Barcode4NET.Code128BBarcode
O2S.Barcode4NET.Code128CBarcode
O2S.Barcode4NET.SCC14Barcode
O2S.Barcode4NET.SSCC18Barcode
O2S.Barcode4NET.Code25Barcode
O2S.Barcode4NET.Code25InterleavedBarcode
O2S.Barcode4NET.COOP25Barcode
O2S.Barcode4NET.IATA25Barcode
O2S.Barcode4NET.Matrix25Barcode
O2S.Barcode4NET.Code39Barcode
O2S.Barcode4NET.Code39ExtendedBarcode
O2S.Barcode4NET.Code93Barcode
O2S.Barcode4NET.Code93ExtendedBarcode
O2S.Barcode4NET.EANBarcode
O2S.Barcode4NET.EAN13Barcode
O2S.Barcode4NET.EAN8Barcode
O2S.Barcode4NET.ISBNBarcode
O2S.Barcode4NET.ISMNBarcode
O2S.Barcode4NET.ISSNBarcode
O2S.Barcode4NET.JAN13Barcode
O2S.Barcode4NET.UPCABarcode
O2S.Barcode4NET.UPCEBarcode
O2S.Barcode4NET.HeightModulatedBarcode
O2S.Barcode4NET.PlanetBarcode
O2S.Barcode4NET.PostnetBarcode
O2S.Barcode4NET.RM4SCCBarcode
O2S.Barcode4NET.MSIPlesseyBarcode
System.Exception
System.ApplicationException
O2S.Barcode4NET.BarcodeEncodingException

See Also

Reference

Barcode4NET Assembly


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Implicit Type Conversion(Int32) Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(Int32) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Integer _
) As BigInteger
C#
public BigInteger operator implicit(
   int value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   int value
)
C++/CLI
public:
BigInteger^ operator implicit(
   int value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Implicit Type Conversion(Int64) Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(Int64) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Long _
) As BigInteger
C#
public BigInteger operator implicit(
   long value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   long value
)
C++/CLI
public:
BigInteger^ operator implicit(
   long value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Implicit Type Conversion(UInt32) Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(UInt32) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As UInteger _
) As BigInteger
C#
public BigInteger operator implicit(
   uint value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   uint value
)
C++/CLI
public:
BigInteger^ operator implicit(
   uint value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%%

Barcode4NET Send comments on this topic.
Implicit Type Conversion(UInt64) Operator
See Also
[image]
Xheo.Licensing Namespace > BigInteger Class > Implicit Type Conversion Operator : Implicit Type Conversion(UInt64) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As ULong _
) As BigInteger
C#
public BigInteger operator implicit(
   ulong value
)
Managed Extensions for C++
public: BigInteger* op_Implicit(
   ulong value
)
C++/CLI
public:
BigInteger^ operator implicit(
   ulong value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BigInteger Class
BigInteger Members
Overload List


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
ExtendedLicenseException Class Methods
See Also
[image]
Xheo.Licensing Namespace : ExtendedLicenseException Class

For a list of all members of this type, see ExtendedLicenseException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ExtendedLicenseException Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Properties$$

Barcode4NET Send comments on this topic.
LicenseValuesCollection Class Properties
See Also
[image]
Xheo.Licensing Namespace : LicenseValuesCollection Class

For a list of all members of this type, see LicenseValuesCollection members.

Public Properties

 | Name | Description
Public Property | AllKeys | Gets all the keys in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Property | Count | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Property | Item | Overloaded. Gets or sets the entry with the specified key in the NameValueCollection. (Inherited from System.Collections.Specialized.NameValueCollection)
Public Property | Keys | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top

See Also

Reference

LicenseValuesCollection Class
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
MachineProfile._MEMORYSTATUS Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUS Structure

For a list of all members of this type, see MachineProfile._MEMORYSTATUS members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile._MEMORYSTATUS Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
MachineProfile._MEMORYSTATUSEX Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile._MEMORYSTATUSEX Structure

For a list of all members of this type, see MachineProfile._MEMORYSTATUSEX members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile._MEMORYSTATUSEX Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure

For a list of all members of this type, see MachineProfile.IP_ADAPTERINFO_STRUCTURE members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.IP_ADAPTERINFO_STRUCTURE Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
MachineProfile.IP_ADDR_STRING Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.IP_ADDR_STRING Structure

For a list of all members of this type, see MachineProfile.IP_ADDR_STRING members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.IP_ADDR_STRING Structure
Xheo.Licensing Namespace


%%PageItemTitle%% $$Methods$$

Barcode4NET Send comments on this topic.
MachineProfile.TGuid Structure Methods
See Also
[image]
Xheo.Licensing Namespace : MachineProfile.TGuid Structure

For a list of all members of this type, see MachineProfile.TGuid members.

Public Methods

 | Name | Description
Public Method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from System.ValueType)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.ValueType)
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

MachineProfile.TGuid Structure
Xheo.Licensing Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Barcode4NET Send comments on this topic.
Xheo.Licensing Namespace (Barcode4NET) Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Xheo.Licensing.ExtendedLicensePack
Xheo.Licensing.TransientReadOnlyCollection
Xheo.Licensing.LimitCollection
System.Collections.Specialized.NameObjectCollectionBase
System.Collections.Specialized.NameValueCollection
Xheo.Licensing.LicenseValuesCollection
System.ComponentModel.License
Xheo.Licensing.ExtendedLicense
System.Exception
System.ApplicationException
Xheo.Licensing.ExtendedLicenseException
System.MarshalByRefObject
Xheo.Licensing.Limit
Xheo.Licensing.ContainerLimit
Xheo.Licensing.BigInteger
Xheo.Licensing.LicenseSigningKey
Xheo.Licensing.MachineProfile
Xheo.Licensing.MachineProfile.Constants
Xheo.Licensing.MachineProfile.GetAdapterInfo
Xheo.Licensing.StateEntry

See Also

Reference

Barcode4NET Assembly


%%Variable%%

Barcode4NET for .NET Send comments on this topic.
Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you