PDF4NET

PDF4NET Send comments on this topic.
PDF4NET

Glossary Item Box

PDF enable Your .NET application
Create, edit, fill, merge, split and encrypt PDF files from your .Net application.

© O2 Solutions. All Rights Reserved.


Getting Started

PDF4NET Send comments on this topic.
Getting Started
PDF4NET On-line Help > Getting Started

Glossary Item Box

This section of the documentation helps you get started with PDF4NET application development.

In this section

Overview

Covers the features of PDF4NET class library.

System Requirements

Provides information about the PDF4NET's system requirements.

Installation

Provides information regarding the installation of PDF4NET product.

Licensing

Provides information regarding the licensing modes of PDF4NET product.


Overview

PDF4NET Send comments on this topic.
Overview
PDF4NET On-line Help > Getting Started > Overview

Glossary Item Box

PDF4NET is a .NET library for generating pdf documents on the fly from any .NET application. The library does not rely on any Adobe products for creating pdf files. It hides the complex structure of pdf files behind a simple object model that allows creation of complex pdf files with a few lines of code. The PDF4NET library follows the GDI+ model, thus reducing the learning time and increasing productivity. It uses a grid based layout approach allowing precise positioning of content on document's pages. The library also creates and fills PDF e-forms and merges or splits PDF documents.
The final pdf file is compressed, making the library apropriate for web applications. The library can be used both from WinForms and WebForms (ASP.NET) applications without any restrictions. Also, the same package includes a Compact .NET Framework edition of the library. The library is written entirely in C#, being 100% managed.
The PDF4NET library is licensed per developer and can be distributed ROYALTY FREE, reducing project costs.

Here is the classic “Hello world” example:

…
PDFDocument doc = new PDFDocument( );
PDFPage page = doc.AddPage( );
page.Canvas.DrawText( “Hello world”, new PDFFont( FontFace.Helvetica, 12 ),
     new PDFPen( PDFRgbColor( 255, 0, 0 ), 1 ),
     new PDFBrush( new PDFRgbColor( 0, 0, 255 ) ), 10, 20 );
doc.Save( “helloworld.pdf” );
// or
// Response.ContentType = "application/pdf";
// doc.Save( Response.OutputStream ); // for ASP.NET apps
…

The example above creates a PDF file with on page, and draws the string “Hello World” on the page. The used font is Helvetica, and its size is 12. The drawn string is stroked with red color and filled with blue. The text is positioned at 10 points from left margin and at 20 points from top margin of the page (see the Hello World sample).

Features

The main features of PDF4NET library are outlined below:

 | Standard .NET Framework Edition | Compact .NET Framework Edition
PDF Document Features
Partial document load |  |
Digitally sign the document |  |
Document information |  |
XMP Metadata |  |
Custom document properties |  |
Compressed document content |  |
Save to file/stream |  |
Save document page by page, or page fragment by page fragment |  |
Incremental updates |  |
Automatic page numbering |  |
Import of damaged PDF files (some of them) |  |
Add/Edit/Remove document attachments |  |
Add/Edit/Remove document level JavaScript |  |
Extract text from PDF files |  |
Extract images from PDF files |  |
PDF Editing Features
Add new content/pages to existing pdf files |  |
Merge multiple pdf files to disk or to stream |  |
Split pdf files to single pages |  |
Apply security to existing pdf files |  |
Extract pages from pdf files and include them in new documents |  |
Place multiple pages on a single page (page imposition) |  |
Support for encrypted PDF files |  |
PDF Forms
Create and modify PDF forms (Acroforms only) |  |
Fill PDF forms (Acroforms) |  |
Read values from PDF form fields (Acroforms) |  |
Support for pushbuttons, single and multi lines text fields, checkboxes, radio buttons, comboboxes and listboxes (Acroforms) |  |
Fill static XFA forms (Adobe Designer 7 static forms) |  |
Read values from XFA forms (Adobe Designer 7 static forms) |  |
Support for pushbuttons, single and multi lines text fields, numeric fields, datetime fields, checkboxes, radio buttons, choice fields, image fields and barcode fields (XFA forms) |  |
Support for encrypted forms |  |
Form fields flattening, all fields or field by field |  |
Import/Export of form data in FDF, XFDF and XML |  |
Page features
Standard and custom page sizes |  |
Portrait/Landscape orientations |  |
User defined measure units |  |
User defined coordinate system |  |
Absolute positioning (grid based layout) |  |
Document layout
Headers |  |
Footers |  |
Page templates |  |
Layers and sub-layers |  |
Graphics
DeviceRGB, DeviceCMYK, DeviceGray, Indexed, CalGray, CalRGB, Lab, ICC, Separation and DeviceN colorspaces |  |
PANTONE colors |  |
Lines, polylines, arcs, pies, bezier, ellipses, rectangles |  |
Polygons, polypolygons, chords, rounded rectangles, paths |  |
Pen styles and solid brushes |  |
Hatched and gradient brushes |  |
Transparency and blend modes |  |
Images |  |
Clipping regions |  |
Form XObjects |  |
Images
JPEG, GIF, BMP, EMF, PNG |  | *
Images from file/stream/System.Drawing.Bitmap |  | **
Rotated images |  |
Transparent images |  |
Color key masking |  |
Image masking |  |
DEFLATE image compression |  |
TIFF to PDF conversion |  |
CCITT G4 compression for B/W images |  |
Alpha channel transparency |  |
Native EMF support |  |
Text features
Single line text |  |
Multiline text |  |
Rotated text |  |
HTML formatted text |  |
Underline, strikethrough, overline |  |
Hyperlinks |  |
Left, center, right horizontal alignment |  |
Top, middle, bottom vertical alignment |  |
Justified text |  |
Fonts
Base 14 Postscript fonts |  |
CJK fonts |  |
Type1 fonts |  |
TrueType fonts with subsetting |  |
Unicode TrueType fonts |  |
TrueType fonts from System.Drawing.Font |  |
PDF Security
AES & RC4 encryption |  |
40/128 bit encryption |  |
User and owner password |  |
Restricted document operations |  |
Hyperlinks
Bookmarks |  |
Internal cross-references |  |
External cross-references |  |
PDF Actions
Actions support at document and page level |  |
Actions support at bookmark level |  |
GoTo actions |  |
Remote GoTo actions |  |
Javascript actions |  |
Launch actions |  |
Named actions |  |
URI actions |  |
SubmitForm and ResetForm actions |  |
Annotations
3D annotations |  |
Text annotations |  |
Free text annotations |  |
Rubber stamp annotations |  |
File attachment annotations |  |
Movie annotations |  |
Line/Circle/Square annotations |  |
Link annotations |  |
Extract annotations from existing PDF files |  |
Custom appearance for annotations |  |
Flatten annotations |  |
Barcodes
1D Barcodes (Codabar, Code 11, Code 128 A/B/C, Code 25, Code 25 Interleaved, Code 39, Code 93, COOP 25, EAN-13, EAN-8, IATA 25, ISBN, ISMN, ISSN, JAN-13, Matrix 25, MSI/Plessey, Planet, Postnet, RM4SCC, SCC-14, SSCC-18, UPC-A, UPC-E, Singapore Post, Royal Dutch TPG Post, PZN, Deutsche Post Identcode, Deutsche Post Leitcode, USPS FIM, UCC/EAN128, USPS Horizontal Bars, USPS Package Identification Code, FedEx Ground 96, Pharmacode, Code 32) |  |
2D Barcodes (Codablock F, Code 16K, DataMatrix, MicroPDF417, PDF417) |  |
Miscellaneous
Royalty free distribution |  |
* - JPEG & BMP only; ** - file only


What's new

PDF4NET Send comments on this topic.
What's new
PDF4NET On-line Help > Getting Started > What's new

Glossary Item Box

PDF4NET 4.0.0 - January 15, 2010

The following new features have been added in PDF4NET 4.0:
+ Partial document load
+ Partial document save, save document page by page, or page fragment by page fragment
+ Incremental updates
+ Text extraction
+ Text search
+ Custom appearance for annotations
+ Flatten annotations
+ Enhanced AcroForms object model
+ JPEG 2000 and JBIG2 support in image extraction
+ Public API for access to low level COS objects

Breaking changes
PDF4NET 4.0 introduces several breaking changes relative to PDF4NET 3.3. Why did we choose this solution?
After 6 years of development on this product, and other PDF related products, we gained deep knowledge on PDF and the existing architecture of PDF4NET could no longer face the challenges. We had to redesign the internal architecture, to make it more extensible, to easily support new features. We kept the public API the same like in previous versions in most scenarios but in several situations we had to change it, to make it easier to understand. Although several classes and enums have been removed because, based on our experience they were not used by customers, the corresponding functionality is still available in PDF4NET. For example the classes in O2S.Components.PDF4NET.Graphics.Shapes namespace have been removed because it is more natural to draw a line using page.Canvas.DrawLine() method then to create a PDFLine object and add it to the canvas.
PDF4NET 3.3 also did not support PDF files with custom information. Loading and saving such a PDF file with PDF4NET 3.3 caused all the custom information to be discarded. The generic PDF engine in PDF4NET 4.0 no longer does this and it also supports adding custom information to PDF objects.
If you upgrade your PDF4NET 3.3 code to PDF4NET 4.0 and you encounter any problems, send us an e-mail and we'll assist you. Also support for PDF4NET 3.3 (bug fixes but no new features) will be available till 31 December 2010.
The breaking changes in PDF4NET 4.0 are listed below:
Removed classes/enums
- O2S.Components.PDF4NET.Annotations.MarkupStyle
- O2S.Components.PDF4NET.Annotations.Movie
- O2S.Components.PDF4NET.Forms.FieldRemoveOptions
- O2S.Components.PDF4NET.Forms.FieldRenameOptions
- O2S.Components.PDF4NET.Forms.IconLayoutMode
- O2S.Components.PDF4NET.Forms.PDFCheckBoxAppearance
- O2S.Components.PDF4NET.Forms.PDFFieldActions
- O2S.Components.PDF4NET.Forms.PDFFieldAppearance
- O2S.Components.PDF4NET.Forms.PDFFieldBorder
- O2S.Components.PDF4NET.Forms.PDFFieldInfo
- O2S.Components.PDF4NET.Forms.PDFPushbuttonAppearance
- O2S.Components.PDF4NET.Forms.PDFRadioButtonAppearance
- O2S.Components.PDF4NET.Forms.PDFRadioButtonItemCollection
- O2S.Components.PDF4NET.Forms.PDFSignatureAppearance
- O2S.Components.PDF4NET.Forms.PDFWidgetActions
- O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFExtendedColor
- O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFImportedSeparationColorSpace
- O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColorSpaceCollection
- O2S.Components.PDF4NET.Graphics.PDFBaseColor
- O2S.Components.PDF4NET.Graphics.PDFCustomBrush
- O2S.Components.PDF4NET.Graphics.PDFGradientBrush
- O2S.Components.PDF4NET.Graphics.PDFGraphic
- O2S.Components.PDF4NET.Graphics.Shapes.PDFArc
- O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaDocLink
- O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaFileLink
- O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaRemoteDocLink
- O2S.Components.PDF4NET.Graphics.Shapes.PDFAreaWebLink
- O2S.Components.PDF4NET.Graphics.Shapes.PDFBezier
- O2S.Components.PDF4NET.Graphics.Shapes.PDFChord
- O2S.Components.PDF4NET.Graphics.Shapes.PDFClippingRegion
- O2S.Components.PDF4NET.Graphics.Shapes.PDFEllipse
- O2S.Components.PDF4NET.Graphics.Shapes.PDFHTMLText
- O2S.Components.PDF4NET.Graphics.Shapes.PDFHTMLTextBox
- O2S.Components.PDF4NET.Graphics.Shapes.PDFLine
- O2S.Components.PDF4NET.Graphics.Shapes.PDFLines
- O2S.Components.PDF4NET.Graphics.Shapes.PDFLink
- O2S.Components.PDF4NET.Graphics.Shapes.PDFPie
- O2S.Components.PDF4NET.Graphics.Shapes.PDFPolyBezier
- O2S.Components.PDF4NET.Graphics.Shapes.PDFPolygon
- O2S.Components.PDF4NET.Graphics.Shapes.PDFPolyPolygon
- O2S.Components.PDF4NET.Graphics.Shapes.PDFRect
- O2S.Components.PDF4NET.Graphics.Shapes.PDFRectangularObject
- O2S.Components.PDF4NET.Graphics.Shapes.PDFRoundRectangle
- O2S.Components.PDF4NET.Graphics.Shapes.PDFText
- O2S.Components.PDF4NET.Graphics.Shapes.PDFTextBox
- O2S.Components.PDF4NET.Graphics.Shapes.PDFTextDocLink
- O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFileLink
- O2S.Components.PDF4NET.Graphics.Shapes.PDFTextRemoteDocLink
- O2S.Components.PDF4NET.Graphics.Shapes.PDFTextWebLink
- O2S.Components.PDF4NET.PageTransitionEffect
- O2S.Components.PDF4NET.PDFBaseObject
- O2S.Components.PDF4NET.PDFFile.PDFImportedObject
- O2S.Components.PDF4NET.PDFFile.Resources.PDFImportedColorSpacesCollection
- O2S.Components.PDF4NET.PDFFile.Resources.PDFResourceManager
- O2S.Components.PDF4NET.PDFPageTemplate
- O2S.Components.PDF4NET.PDFPageTransition
- O2S.Components.PDF4NET.PDFParserException
- O2S.Components.PDF4NET.SaveProgressEventArgs
- O2S.Components.PDF4NET.TransitionAngleDirection
- O2S.Components.PDF4NET.TransitionDimension
- O2S.Components.PDF4NET.TransitionMotionDirection

Renamed classes/enums
- AnnotationFlags has been renamed to PDFAnnotationFlags.
- BlendMode has been renamed to PDFBlendMode and has been moved from namespace O2S.Components.PDF4NET.Graphics.Shapes to namespace O2S.Components.PDF4NET.Graphics.
- BorderStyle has been renamed to PDFBorderStyle.
- ClipText has been renamed to PDFClipText.
- ColorSpace has been renamed to PDFColorSpace and has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.ColorSpaces.
- ContentMirroring has been renamed to PDFContentMirroring and has been moved from namespace O2S.Components.PDF4NET.PDFFile to namespace O2S.Components.PDF4NET.Graphics.
- DashStyle has been renamed to PDFDashStyle.
- DataFormat has been renamed to PDFFormDataFormat.
- DisplayMode has been renamed to PDFDisplayMode.
- ExportDataOptions has been renamed to PDFExportDataOptions.
- FieldBorderStyle has been renamed to PDFBorderStyle.
- FieldVisibilityStatus has been renamed to PDFFieldWidgetVisibilityStatus.
- FileAttachmentAnnotationIcon has been renamed to PDFFileAttachmentAnnotationIcon.
- FillMode has been renamed to PDFFillMode and has been moved from namespace O2S.Components.PDF4NET.Graphics.Shapes to namespace O2S.Components.PDF4NET.Graphics.
- FontFace has been renamed to PDFFontFace and has been moved from namespace O2S.Components.PDF4NET.Graphics to namespace O2S.Components.PDF4NET.Graphics.Fonts.
- HatchType has been renamed to PDFHatchType.
- HighlightMode has been renamed to PDFPushButtonHighlightMode.
- ImageCompression has been renamed to PDFImageCompression.
- KeepAspectRatio has been renamed to PDFKeepAspectRatio.
- LineCap has been renamed to PDFLineCap.
- LineEndingStyle has been renamed to PDFLineEndingStyle.
- LineJoin has been renamed to PDFLineJoin.
- LinkHighlightMode has been renamed to PDFLinkHighlightMode.
- MagnificationMode has been renamed to PDFMagnificationMode and has been moved from namespace O2S.Components.PDF4NET.Actions to namespace O2S.Components.PDF4NET.
- NumberingStyle has been renamed to PDFNumberingStyle.
- OutlineDisplay has been renamed to PDFBookmarkDisplayStyle.
- PageLayout has been renamed to PDFPageLayout.
- PageNumber has been renamed to PDFPageNumber.
- PageNumberingRange has been renamed to PDFPageNumberingRange.
- PageNumberingRangeCollection has been renamed to PDFPageNumberingRangeCollection.
- PageOrientation has been renamed to PDFPageOrientation.
- PageSize has been renamed to PDFPageSize.
- PDFAnnotations has been renamed to PDFAnnotationCollection.
- PDFCircleAnnotation has been renamed to PDFEllipseAnnotation.
- PDFFields has been renamed to PDFFieldCollection.
- PDFFunctions has been renamed to PDFFunctionCollection.
- PDFJavaScriptBlock has been renamed to PDFJavaScript.
- PDFJPXImage has been renamed to PDFJpeg2000Image.
- PDFLayers has been renamed to PDFLayerCollection.
- PDFMarkupAnnotation has been renamed to PDFTextMarkupAnnotation.
- PDFMetadataSchemas has been renamed to PDFMetadataSchemaCollection.
- PDFOutline has been renamed to PDFBookmark.
- PDFOutlines has been renamed to PDFBookmarkCollection.
- PDFPages has been renamed to PDFPageCollection.
- PDFPushbuttonField has been renamed to PDFPushButtonField
- PDFSquareAnnotation has been renamed to PDFRectangleAnnotation.
- PDFWidgetAnnotation has been renamed to PDFFieldWidget.
- PrintScaling has been renamed to PDFPrintScaling.
- RubberStampAnnotationIcon has been renamed to PDFRubberStampAnnotationIcon.
- SymbolStyle has been renamed to PDFCheckSymbolStyle.
- TextAlign has been renamed to PDFTextAlign and has been moved from namespace O2S.Components.PDF4NET.Graphics.Shapes to namespace O2S.Components.PDF4NET.Graphics.
- TextAnnotationIcon has been renamed to PDFTextAnnotationIcon.
- XAxisDirection has been renamed to PDFXAxisDirection and has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.
- YAxisDirection has been renamed to PDFYAxisDirection and has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.

Moved classes/enums
- PDFBasicCanvas has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.
- PDFCalGrayColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFCalRgbColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFCanvas has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.
- PDFCMLogicalUnit has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.
- PDFCmykColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFDeviceNColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFFont has been moved from namespace O2S.Components.PDF4NET.Graphics to namespace O2S.Components.PDF4NET.Graphics.Fonts.
- PDFGrayColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFICCColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFInchLogicalUnit has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.
- PDFIndexedColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFLabColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFLogicalUnitBase has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.
- PDFMMLogicalUnit has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.
- PDFObject has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Cos.
- PDFPoint has been moved from namespace O2S.Components.PDF4NET.Graphics to namespace O2S.Components.PDF4NET.
- PDFPointLogicalUnit has been moved from namespace O2S.Components.PDF4NET to namespace O2S.Components.PDF4NET.Graphics.
- PDFRectangle has been moved from namespace O2S.Components.PDF4NET.Graphics.Shapes to namespace O2S.Components.PDF4NET.
- PDFRgbColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.
- PDFSeparationColor has been moved from namespace O2S.Components.PDF4NET.Graphics.ColorSpaces to namespace O2S.Components.PDF4NET.Graphics.


System requirements

PDF4NET Send comments on this topic.
System requirements
PDF4NET On-line Help > Getting Started > System requirements

Glossary Item Box

The PDF4NET library requires .NET Framework 2.0 or later to be installed on the target computer for standard .NET framework edition of PDF4NET. Compact .NET Framework edition of PDF4NET library requires a Windows CE.NET powered mobile device with Compact .NET Framework 1.0 or later installed. The .NET Framework redistributable is not included in the installation kit. It can be obtained from the Microsoft website.


Getting Started

PDF4NET Send comments on this topic.
Getting Started
PDF4NET On-line Help > Getting Started > Getting Started

Glossary Item Box

In order to minimize the download time, the PDF4NET library is provided as a single msi package.

How to install

After downloading the archive, run the installation package and follow the installation instructions.

After the installation, the following files will be present on computer's disk:

bin\
o2s.components.pdf4net.dll - the PDF4NET class library compiled for .NET Framework 2.0.
o2s.components.pdf4net.compact.dll - the PDF4NET compact .NET class library.
help\
pdf4net.chm - the PDF4NET online help file.

samples\ - over 40 samples (C# and VB.NET) showing how to use the PDF4NET library.

supportfiles\
*.pdf, *.jpg, *.emf, *.ttf, *.u3d - helper files for PDF4NET samples.
samplesign.pfx - sample X.509 certificate.


Licensing

PDF4NET Send comments on this topic.
Licensing
PDF4NET On-line Help > Getting Started > Licensing

Glossary Item Box

Key points of the license agreement.
- The PDF4NET library is licensed per developer. One license can be used on multiple computers as long as it is used by the same developer, and it can not be used concurently or shared by other developers.
- When using the PDF4NET library for desktop development (native Windows applications), the library is licensed royalty free. You pay to use during the development time to create your final product. You do not need to pay any other fees when you distribute the PDF4NET library with your final product.
- When using the PDF4NET library for mobile development (compact .NET framework applications), the library is licensed royalty free. You pay to use during the development time to create your final product. You do not need to pay any other fees when you distribute the PDF4NET library with your final product.
- When using the PDF4NET library for server-side development (ASP.NET web applications), the library is licensed deployment free. You pay to used during the development time to create your final product. You do not need to pay any other fees when you deploy the PDF4NET library along with your final product on other servers.
- This license does NOT ALLOW you to distribute the PDF4NET library for use in development. This requires an OEM distribution license. If you want to do so, please contact us.


License Agreement

PDF4NET Send comments on this topic.
License Agreement
PDF4NET On-line Help > Getting Started > Licensing > License Agreement

Glossary Item Box

VERY IMPORTANT - READ CAREFULLY: This O2 Solutions Software License Agreement (hereinafter, this "LICENSE") is a legal agreement between you (either an individual or a single entity) and O2 Solutions, SRL. ("O2 Solutions"), for the software containing this LICENSE which has been obtained through O2 Solutions or its authorized distributor.

1. OWNERSHIP; LICENSE GRANT.

This is a license agreement and NOT an agreement for sale. O2 Solutions continues to own the copy of the SOFTWARE contained on the disk and all other copies that you are authorized by this LICENSE to make. Your rights to the SOFTWARE are specified in this LICENSE, and O2 Solutions retains all rights not expressly granted to you in this LICENSE. O2 Solutions hereby grants to you, and you accept, a non-exclusive, non-transferable license to use, copy and modify the SOFTWARE only as authorized below.

2. PERMITTED USES.

This LICENSE grants you the following rights:
A. The SOFTWARE is licensed per individual developer. You may make copies on more than one computer, as long as the use of the SOFTWARE is by the same developer.
B. Solely with respect to electronic documents included with the SOFTWARE, you may make a copy for each developer for which the Software has been licensed as described in Section 2.A, above; provided, that such copies shall be used only by such developer for internal purposes and are not to be republished or distributed to any other third party.
C. You may use the evaluation versions of the SOFTWARE for the limited purposes of demonstrations, trials and design time evaluations.

3. PROHIBITED USES.

You may not, without the prior written permission of O2 Solutions:
A. Disassemble, decompile or "unlock", decode or otherwise reverse translate or engineer, or attempt in any manner to reconstruct or discover any source code or underlying algorithms of SOFTWARE provided in object code form only.
B. Use, copy, modify, or merge copies of the SOFTWARE and any accompanying documents except as permitted in this LICENSE.
C. Transfer, rent, lease, or sublicense the SOFTWARE.

4. REDISTRIBUTABLE COMPONENTS.

A. The files o2s.components.pdf4net.dll and o2s.components.pdf4net.compact.dll are considered as REDISTRIBUTABLE DLLs.
B. In addition to the license and rights granted in Sections I and II, O2 Solutions grants you a nonexclusive, royalty-free right to reproduce and distribute the object code version of the SOFTWARE designated in the SOFTWARE as (i) those portions of the SOFTWARE which are identified in the documentation as REDISTRIBUTABLE DLLs ("DLLs"); provided: you distribute the REDISTRIBUTABLES in object code form only in conjunction with and as part of your software application product which adds significant and primary functionality; you do not use O2 Solutions' name, logo or trademarks to market your software application product; you include a valid copyright notice on your SOFTWARE; and
C. In addition to the other requirements set forth in this Section 4, you hereby agree to indemnify, hold harmless, and defend O2 Solutions from and against any and all liabilities, damages, losses, costs and expenses (including attorneys' fees) arising from or related to any claim, action, proceeding or allegation that arise or result from the use and distribution of any of your software application product(s) or components.

5. COPYRIGHT.

All title and copyrights in and to the SOFTWARE are owned by O2 Solutions. The SOFTWARE is protected by United States copyright laws and international treaty provisions. All rights are reserved worldwide. You must treat the SOFTWARE like any other copyrighted material, except that you may, in addition to the copies permitted in this LICENSE, make one copy of the SOFTWARE solely for backup or archival purposes. No part of the accompanying printed materials may be reproduced, transmitted, transcribed, stored in any retrieval system, or translated into any language by any means without the express prior written permission of O2 Solutions.

6. TERMINATION.

This LICENSE and your right to use the SOFTWARE will terminate immediately without notice from O2 Solutions if you fail to comply with the terms and conditions of this LICENSE. Upon termination, you agree to destroy the SOFTWARE, including all accompanying documents and copies. This is in addition to and not in lieu of any criminal, civil or other remedies available to O2 Solution

7. LIMITED WARRANTY

A. O2 Solutions does not warranty that the SOFTWARE will be error-free. Except with respect to REDISTRIBUTABLES, which are provided "AS IS," without warranty of any kind, O2 Solutions warrants that the SOFTWARE will perform substantially in accordance with the accompanying electronic documentation for a period of thirty (30) days from the date of receipt.
B. O2 Solutions' entire liability, in contract tort or otherwise, and your exclusive remedy under the performance warranty set forth in Section 7.A, shall be, at O2 Solutions' option, either (a) return of the purchase price paid, or (b) repair or replacement of the defective SOFTWARE. This limited warranty is void if failure of the SOFTWARE has resulted from accident, abuse, or misapplication. Any replacement SOFTWARE will be warranted for the remainder of the original thirty (30) day period.
C. EXCEPT AS EXPRESSLY SET FORTH IN THIS SECTION 7, O2 SOLUTIONS DISCLAIMS ALL OTHER WARRANTIES, EITHER EXPRESS OR IMPLIED, WHETHER ARISING BY STATUTE OR OTHERWISE IN LAW OR FROM A COURSE OF DEALING OR USAGE OR TRADE, INCLUDING, BUT NOT LIMITED TO, ANY IMPLIED WARRANTIES OF ACCURACY, COMPLETENESS, PERFORMANCE, CURRENCY, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE WITH REGARD TO THE SOFTWARE.

8. LIMITATION OF LIABILITIES.

O2 Solutions' liability, whether in contract, or otherwise, arising out of Licensee's use of, or in connection with, the SOFTWARE, or otherwise under this Agreement, shall not exceed the amount of the license fee paid by you to O2 Solutions. IN NO EVENT SHALL O2 SOLUTIONS BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR CONSEQUENTIAL DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE, EVEN IF O2 SOLUTIONS HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.


License Activation

PDF4NET Send comments on this topic.
License Activation
PDF4NET On-line Help > Getting Started > License Activation

Glossary Item Box

After you purchase the PDF4NET toolkit, you will receive a serial number for unlocking the evaluation version.

Unlocking the PDFFile class

The PDFFile class has a property called SerialNumber. Set this property to the serial number you received and the TRIAL tag will be removed from the imported pages.

Unlocking the PDFDocument class

The PDFDocument class has a property called SerialNumber. Set this property to the serial number you received and the TRIAL tag will be removed from documents saved with this class.


Developer's Guide

PDF4NET Send comments on this topic.
Developer's Guide
PDF4NET On-line Help > Developer's Guide

Glossary Item Box

This section of the documentation helps you get a more specific view of PDF4NET features.

In this section

First PDF file

Covers the creation of a simple pdf file.

The Object Model

Provides information about the PDF4NET's object model.

Creating content

Covers the creation of the pdf file specific content.

TrueType / Type1 fonts support

Covers the external fonts support in PDF4NET library.

PDF editing

Covers the pdf editing (merge, split, encrypt, extract) capabilities of PDF4NET library.

Automatic page numbering

Covers the page numbering features of PDF4NET library.

Creating document's bookmarks tree

Provides information about the creation of bookmarks tree that is displayed in the Bookmarks navigation pane of Adobe's pdf viewers.

Linking to other content

Provides information about creating links in a pdf file.

PDF support for presentations

Covers the presentation features found in pdf files.

Document metadata

Covers the document metadata information and viewer preferences when opening the pdf file.

PDF security and encryption

Provides information about the pdf security and encryption support available in PDF4NET library.

PDF actions

Shows how to work with PDF actions in PDF4NET library.

Annotations

Presents the support for PDF annotations available in PDF4NET library.

Working with forms

Presents the PDF forms support available in PDF4NET library.

Barcodes

Presents the barcodes support available in PDF4NET library.


First PDF file

PDF4NET Send comments on this topic.
First PDF file
PDF4NET On-line Help > Developer's Guide > First PDF file

Glossary Item Box

Creating pdf files with PDF4NET library is an easy task. Although it is a general purpose library, its simple and easy to use object model allows you to create pdf files with no effort.

The following steps will show how easy is and how few coding lines are needed to create a pdf file (the sample below uses C#. There is no difference using Visual Basic.NET).

Set up references

First, you need to set up the references to PDF4NET library. Using Visual Studio.NET, add a reference to your project to O2S.Components.PDF4NET.dll assembly. Then, add the following lines at the beginning of your source file.
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Fonts;
using O2S.Components.PDF4NET.Graphics.Shapes;

Create the document

The first thing to do in your code is to create the document, which is an instance of PDFDocument class.
PDFDocument doc = new PDFDocument();

Create the first page of the document

The next thing to do is to create at least one page in the document. This is accomplished using the AddPage( ) member of document object. A page in the document is an instance of PDFPage class.
PDFPage page = doc.AddPage( );

Create the content of the page

After creating the page, we need to fill it with content. The content of a page is created using the Canvas property of the page object. The canvas encapsulates the drawing surface of the page, like a device context for the screen. Using the Canvas property, you can draw figures on a page or you can write text. In this sample, we'll write a simple text on the page.
page.Canvas.DrawText(“Hello world”, new PDFFont(FontFace.Helvetica, 12),
     new PDFPen(new PDFRgbColor(255, 0, 0), 1),
     new PDFBrush(new PDFRgbColor(0, 0, 255)), 10, 20);
When drawing text, we need a font, a pen and a brush. The pen is used to color the border of the text, and the brush is used to fill the interior of the text. The text is written at 10 points from the left margin and 20 point from the top margin of the page.

Saving the document

Once we created the content, we can save the document. The document can be saved to a file on disk
doc.Save("HelloWorld.pdf");
or it can be saved to a stream, like the response stream of an ASP.NET application
Response.ContentType = "application/pdf";
doc.Save(Response.OutputStream);


Compact .NET Framework support

PDF4NET Send comments on this topic.
Compact .NET Framework support
PDF4NET On-line Help > Developer's Guide > Compact .NET Framework support

Glossary Item Box

PDF4NET library supports Compact .NET Framework through a separate assembly, included in the same installation kit and covered by the same license. Please refer to Overview page for details about the features supported by PDF4NET Compact .NET Edition.


The Object Model

PDF4NET Send comments on this topic.
The Object Model
PDF4NET On-line Help > Developer's Guide > The Object Model

Glossary Item Box

The PDF4NET library exposes a simple but powerfull object model that gives a developer access to most of pdf features.
The object model is displayed in the diagram below:

The root of the object model is the document object. It has a collection of pages and a collection of outlines. It also has a default page number, template and transition. The outlines collection is composed of individual outline items. The pages collection consists of individual page objects. A page has a canvas and specific page number, template and transition. The canvas holds the list of graphic objects that drawn on the page.


Creating Content

PDF4NET Send comments on this topic.
Creating Content
PDF4NET On-line Help > Developer's Guide > Creating Content

Glossary Item Box

A pdf document consists of several pages. Creating document content implies creating the content for each page.

Page content

The content of a page is created using the Canvas property of the page object. The Canvas encapsulates the drawing surface of the page. Using its properties and methods, the developer can add new content to a page. The content of the page mainly consists of text, images and graphic shapes. A page can also include links to other content.

The Canvas object exposes a rich set of functions to help the developer to create rich content. Using the canvas, the following graphic shapes can be drawn on a page:
- lines (a single line or a sequence of lines).
- bezier splines.
- rectangles.
- circles.
- ellipses.
- arcs.
- pies.
- polygons.
- images.
Also, a rich set of functions is available for drawing text on the page. The canvas allows to draw single line text or multi line text. For multiline text, it is automatically wrapped to fit the required width. All types of text can be aligned in different ways. Also, the text can be displayed rotated around a specified point.

When drawing on the page, the canvas uses several painting objects to create the graphics. The pen object are used to draw the lines and the contour of graphic shapes and text, the brush is used to fill the interior of closed shapes and text, and the font object is used to set the visual appearance of the text.

The default origin of the coordinate system (0, 0) is located at the top left corner of the page. The X axis grows from left to right, the Y axis grows from top to bottom. All the dimensions and positions are given in logical units. The default logical unit used by the library is the point (1/72 inches).

Repetitive content

An important feature of the PDF4NET library is the ability to setup templates to be applied on several pages. The content of a template is created in the same way the content of a page is created. The template has a canvas that is drawing surface. After creating the content of the template, it is applied automatically to each designated page. The developer can setup multiple templates for a document, each set of pages having its own template. The content of the template is applied on a page before the actual content of the page, so the template content is under the page content when the final pdf file is created. The template feature is implemented through the PDFPageTemplate class.

Page sizes

The PDF4NET library lets the user to create documents having pages of different sizes. Each page can have its own size (controlled by Width and Height properties) and orientation (landscape or portrait). The library supports 14 standard page formats, but other sizes can be used by setting the corresponding properties.
The following standard sizes are predefined by the library:

Page format | Width (points) | Height (points)
A3 | 842 | 1190
A4 | 595 | 842
A5 | 420 | 595
B4 | 729 | 1032
B5 | 516 | 729
Letter | 612 | 792
Legal | 612 | 1008
Tabloid | 792 | 1224
Ledger | 1224 | 792
Statement | 396 | 612
Executive | 540 | 720
Folio | 612 | 936
Quarto | 610 | 780
10x14 | 720 | 1008


Logical units

PDF4NET Send comments on this topic.
Logical units
PDF4NET On-line Help > Developer's Guide > Creating content > Logical units

Glossary Item Box

The concept of logical unit has been introduced in order to facilitate the positioning of content within a page. All drawing functions now use logical units to position the content on the page. A logical unit defines the transformation between the transformation between user's measure unit and the default measure unit used within the pdf files which is the point. Now, you can specify the position of page content using inches, millimeters, centimeters, or any other unit that fits you best. The default logical unit used by the library is the point, so compatibility with previous versions is kept.

Defining a new logical unit

All the logical units used with PDF4NET library must inherit from PDFLogicalUnitBase class, which is the base class representing an abstract logical unit.

When inheriting from PDFLogicalUnitBase, 2 methods must be implemented: ToPDFUnitX( float unit ) and ToPDFUnitY( float unit ).

Method ToPDFUnitX( float unit ) defines the transformation between the user's measure unit and the pdf unit (the point) for the X axis. It says how many pdf units correspond to the number of units given as parameter when representing the logical unit on the X axis.

Method ToPDFUnitY( float unit ) defines the transformation between the user's measure unit and the pdf unit (the point) for the Y axis. It says how many pdf units correspond to the number of units given as parameter when representing the logical unit on the Y axis.

Defining different mappings for X and Y axes, allows a developer to have different physical lengths for a unit on X and Y axes. Thus, a unit on X axis might represent 10 points, while a unit on Y axis might represent 100 points.

The example below shows how to define a new logical unit that maps to 10 points on X axis and to 100 points on Y axis.

class Unit : PDFLogicalUnitBase
{
    float ToPDFUnitX( float unit )
    {
        return unit * 10;
    }

    float ToPDFUnitY( float unit )
    {
        return unit * 100;
    }
}

Using logical units

The PDFDocument class allows to define a global logical unit used across the document. When a new page is added to the document, it inherits the logical unit to be used from the document, but the library allows to set a different logical unit for each page to fit best the drawing needs. Also, in order to provide more flexibility during the drawing process, the developer can change the logical unit while drawing on the page. You can accomplish this using the SetLogicalUnit( ) method of the Canvas object.

The following sample shows how to do it:

...
// create a new logical unit that represents the centimeter.
PDFCMLogicalUnit cm = PDFCMLogicalUnit( );
page.Canvas.SetLogicalUnit( cm );
// the following drawing operations use the centimeter to draw the content
//
// Draw a horizontal line, 10 cm in length, at 1 cm from the top and
// starting at 1 cm from the left of the page and ending at 11 cm from the
// left of the page.
page.Canvas.DrawLine( pen, 1, 1, 11, 1 );
// continue drawing here
...
...
// create a new logical unit that represents the inch
PDFInchLogicalUnit in = PDFInchLogicalUnit( );
page.Canvas.SetLogicalUnit( in );
// the following drawing operations use the inch to draw the content

// Draw a horizontal line, 3 inches in length, at 1 inch from the top and
// starting at 1 inch from the left of the page and ending at 4 inches
// from the left of the page.
page.Canvas.DrawLine( pen, 1, 1, 4, 1 );
// continue drawing here
...

Predefined units

The library defines classes that represent the following units:
- point - PDFPointLogicalUnit
- millimeter - PDFMMLogicalUnit
- centimeter - PDFCMLogicalUnit
- inch - PDFInchLogicalUnit

When a document is created, the default logical unit is the point. Also, when a page is created the default logical unit is the point. At this time, the page size, width and height, is given in points. When a new logical unit is assigned to the page, through LogicalUnit property, these values are recomputed automatically to represent the new units. In this case, changing the page size needs to be done after changing the logical unit for the page, and not before.

The following sample shows how to do it:

PDFDocument doc = new PDFDocument( );
PDFPage page = doc.AddPage( );
// at this time the logical unit of the page is the point
// the Width is set to 612 points and the Height is set to
// 792 points (standard letter values).
...
// Create a new logical unit
PDFInchLogicalUnit in = PDFInchLogicalUnit( );
page.LogicalUnit = in;
// now, the Width is 8.5 in, and Height is 11 in.
page.Width = 10;
page.Height = 10;
// now, the Width is 10 in, and Height is 10 in.
...

In the sample above, if the assignment

page.Width = 10;
page.Height = 10;

would have been done before setting the logical unit for the page, then the page size would have been considered to be 10 points x 10 points and setting the logical unit to inch would have converted the page size to 0.14 x 0.14 inches.


Coordinate systems

PDF4NET Send comments on this topic.
Coordinate systems
PDF4NET On-line Help > Developer's Guide > Creating content > Coordinate systems

Glossary Item Box

The PDF4NET library introduces a new feature that allows a developer to customize the coordinate system in order to fit the drawing requirements. The default coordinate system has its origin in the top left corner of the page, the X axis grows from left to right, and the Y axis grows from top to bottom. The new features allows the developer to set the origin of the coordinate system anywhere on the page, and set arbitrary directions for each axis. When changing the origin of the coordinate system, the new position is always given in the coordinates of the current system.

The following sample moves the origin of the coordinate system to bottom left corner of the page and changes the direction of the Y axis to bottom to top (this is the default pdf coordinate system).

...
// the initial coordinate system has the origin in top left corner
...
// move the origin to bottom left corner
page.Canvas.SetOrigin( 0, page.Height );
// change Y axis direction to grow from bottom to top
page.Canvas.SetAxesDirections( XAxisDirection.LeftToRight, YAxisDirection.BottomToTop ); ...

Left, Top positioned objects

For graphic objects that are positioned on the page using Left, Top, Right, Bottom coordinates the Left coordinate is always on the left of the page and the Right coordinate is always on the right of the page, no matter the direction of the X axis is, left to right, or right to left. When the direction of X axis is LeftToRight, the following relation is always true: Right >= Left. When the direction of X axis is RightToLeft, the following relation is always true: Left >= Right. For Y axis the situation is similar, Top is always at the top of the page and Bottom is at the bottom of the page, no matter the direction of the Y axis is, top to bottom, or bottom to top. When the direction of Y axis is TopToBottom, the following relation is always true: Bottom >= Top. When the direction of Y axis is BottomToTop, the following relation is always true: Top >= Bottom.

The width of these graphic objects is always from Left to Right, and the Height is always from Top to Bottom.

The above situation is detailed in the images below:

Default coordinate system Reversed coordinate system

The relative position of Left, Right, Top, Bottom coordinate is always the same, no matter the axes direction.

Text lines

When drawing text lines, the text alignment is always relative to the printing coordinate, no matter the directions of the axes.

The following images show how TopLeft text alignment is handled for different directions of the axes:

TopLeft text aligment for different axes directions.

Text boxes

When drawing text boxes, the alignment of the text is relative to the interior of the box, no matter the directions of the axes and the text box follows the rules for the graphic objects shown above.

The images below show how the drawing of text boxes is handled for different directions of axes.

Textbox alignment for different axes directions.


HTML formatting

PDF4NET Send comments on this topic.
HTML formatting
PDF4NET On-line Help > Developer's Guide > Creating content > HTML formatting

Glossary Item Box

The PDF4NET library provides HTML formatting features for displayed text, enhancing existing text display capabilities.

Support classes and methods

A series of methods have been added to PDFCanvas class to support the drawing of HTML text. The following methods provide support for HTML formatted text:
DrawHTMLText( ) - works the same way like its counterparts DrawText( ) methods but parses its text in order to display the correct formatting.
DrawHTMLTextBox( ) - works the same way like its counterparts DrawTextBox( ) methods but parses its text in order to display the correct formatting.

Supported HTML tags

The HTML must be well formed, all tags must be closed. The text must be a valid XML document. Also, the tags are case sensitive and lower case must be used.
All the attributes must be quoted, otherwise an exception will be raised. E.g: <font color="#000000">test</font> is valid while <font color=#000000>test</font> will raise an exception.
Overlapping of tags is not allowed, e.g.: <b><i>test</b></i> will not work, while <b><i>test</i></b> is correct.
The following HTML tags are supported:

<b> - marks a block of text as bold.

<i> - marks a block of text as italic.

<u> - marks a block of text as underline.

<st> - marks a block of text as strikethrough.

<o> - marks a block of text as overline.

<br/> - forces a new line in the text box.

<font> - sets the display font for a block of text. The following attributes are supported:
- color - sets the color of the text. Supports both named colors and hex coded colors.
- fillcolor - sets the color of the text interior. Supports both named colors and hex coded colors. This attribute is identical to "color" attribute.
- strokecolor - sets the color of the text border. Supportsbothnamed colors and hex coded colors.
- face - sets the name of the font used to display the text. The following values are accepted for this attribute: Helvetica, Courier, TimesRoman, Symbol, ZapfDingbats.
- size - sets the size, in points, of the font used to display the text. This attribute accepts as value any float value.

The <st> and <o> tags, and "fillcolor" and "strokecolor" attributes are PDF4NET extensions to HTML specification.


Fonts metrics

PDF4NET Send comments on this topic.
Fonts metrics
PDF4NET On-line Help > Developer's Guide > Creating content > Fonts metrics

Glossary Item Box

Version 2.1 of PDF4NET library gives access to the metrics of the fonts used to display text. Any font object exposes a property named Metrics of type PDFFontMetrics that returns read only values of font metrics. Ascent, descent, leading, stemV, stemH, cap height, x height, average width and max width metrics are available. All these values are given in unscaled glyph units.
Also, two new methods are available in any font object:
fontobj.MeasureString(string text) - returns the width of the text in points, based on the fontobj metrics
fontobj.GetCharWidth(char charCode) - returns the width of the given character in unscaled glyph units.
To convert from unscaled glyph units to points, divide the value by 1000 then multiply it by font size.


Clipping regions

PDF4NET Send comments on this topic.
Clipping regions
PDF4NET On-line Help > Developer's Guide > Creating content > Clipping regions

Glossary Item Box

Version 2.1 of PDF4NET library brings support for clipping regions. When a clipping region is active, only the graphics inside the region are visible. Any graphic or part of a graphic that falls outside of the region is clipped at region boundary. The PDFCanvas class makes public two methods to work with clipping regions:
SetClipRegion(PDFPath clipGraphic) sets the given graphic object as a clipping region
ResetClipRegion() clears the active clipping region.
The following sample shows how to use a clipping region:
...
// create a rectangular clip region, with top left at 10, 10, width 200, height 100
// pen and brush do not matter, they can be null
PDFRectangle rc = new PDFRectangle( null, null, 10, 10, 200, 100 );
page.Canvas.SetClipRegion( rc );
...
// continue to add content here
// when the pdf file is viewed, only the graphics inside the rectangle will be visible
...
// The clip region is cleared
page.Canvas.ResetClipRegion( );
...
// all the graphics drawn from this point on the page will be visible when the pdf file is viewed
...


Layers

PDF4NET Send comments on this topic.
Layers
PDF4NET On-line Help > Developer's Guide > Creating content > Layers

Glossary Item Box

Layers in a PDF file allows to define optional content that can selectively shown or hidden by the user. Layers are especially useful in graphics applications for grouping related content.
PDF4NET library allows to create unlimited levels of layers and sub-layers in a parent-child relationship. The page's Canvas has a Layers property that allows to add new layers to a page. Each layer has its own independent Canvas for creating its content. The z-order of the layers on a page is determined by the order they have been added to the layers collection of the page.
Regular page content (created through page's Canvas) is separate from layers' content and its visibility (show/hide) can not be controlled by the user that views the PDF file. For imported PDF documents, layers can be created also under existing page content.
The following sample shows how to create 2 top level layers and 4 sub-layers for the first layer:

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;

namespace O2S.Samples.PDF4NET.Layers
{
   class Layers
   {
      [STAThread]
      static void Main(string[] args)
      {
         // Create the pdf document
         PDFDocument doc = new PDFDocument( );

         // Create one page
         PDFPage page = doc.AddPage( );

         PDFPen redPen = new PDFPen( new PDFColor( 192, 0, 0 ), 1 );
         PDFBrush blueBrush = new PDFBrush( new PDFColor( 0, 0, 255 ) );
         PDFBrush darkBlueBrush = new PDFBrush( new PDFColor( 0, 0, 128 ) );

         // Draw "Hello world" in the center of the page
         // this text is always visible.
         page.Canvas.DrawText( "Hello world !",
            new PDFFont( FontFace.Helvetica, 100 ), redPen, blueBrush, page.Width/2, page.Height/2,
            0, TextAlign.MiddleCenter );

         // Create a parent layer
         PDFLayer squareLayer = page.Canvas.Layers.Add( "Empty square" );
         // Create a poly polygon and draw it on the layer
         PDFPoint[][] polygons = new PDFPoint[2][];
         polygons[0] = new PDFPoint[]{ new PDFPoint( 50, 100 ), new PDFPoint( 550, 100 ),
                                 new PDFPoint( 550, 600 ), new PDFPoint( 50, 600 ) };
         polygons[1] = new PDFPoint[]{ new PDFPoint( 100, 150 ), new PDFPoint( 500, 150 ),
                                 new PDFPoint( 500, 550 ), new PDFPoint( 100, 550 ) };
         PDFPolyPolygon pp = new PDFPolyPolygon( redPen, darkBlueBrush, polygons );
         pp.FillMode = FillMode.EvenOdd;
         squareLayer.Canvas.Add( pp );

         // create 4 sublayers
         // 1. Hatched layer
         PDFLayer hatchedLayer = squareLayer.Canvas.Layers.Add( "Hatched square" );
         // Create a hatch brush
         PDFHatchBrush hb = new PDFHatchBrush( HatchType.DiagonalCross ); hb.HatchColor = new PDFColor( Color.Aquamarine );
         hb.Color = new PDFColor( Color.Azure );
         hatchedLayer.Canvas.DrawRectangle2( redPen, hb, 100, 150, 200, 200 );

         // 2. Vertical gradient layer
         PDFLayer verticalGradientLayer = squareLayer.Canvas.Layers.Add( "Vertical gradient square" );
         // Create a vertical gradien brush
         PDFVerticalGradientBrush vgb = new PDFVerticalGradientBrush( );
         vgb.StartColor = new PDFColor( Color.Aquamarine );
         vgb.EndColor = new PDFColor( Color.Purple );
         verticalGradientLayer.Canvas.DrawRectangle2( redPen, vgb, 300, 150, 200, 200 );

         // 4. Horizontal gradient layer
         PDFLayer horizontalGradientLayer = squareLayer.Canvas.Layers.Add( "Horizontal gradient square" );
         // Create a horizontal gradient brush
         PDFHorizontalGradientBrush hgb = new PDFHorizontalGradientBrush( );
         hgb.StartColor = new PDFColor( Color.YellowGreen );
         hgb.EndColor = new PDFColor( Color.Violet );
         horizontalGradientLayer.Canvas.DrawRectangle2( redPen, hgb, 100, 350, 200, 200 );

         // 4. Solid layer
         PDFLayer solidLayer = squareLayer.Canvas.Layers.Add( "Solid square" );
         // Create a solid brush
         PDFBrush solidBrush = new PDFBrush( new PDFColor( Color.CornflowerBlue ) );
         solidLayer.Canvas.DrawRectangle2( redPen, solidBrush, 300, 350, 200, 200 );

         // create another layer on top of existing ones
         PDFLayer xLayer = page.Canvas.Layers.Add( "Green X" );
         PDFPen greenPen = new PDFPen( new PDFColor( Color.GreenYellow ), 32 );
         greenPen.LineCap = LineCap.Round;
         xLayer.Canvas.DrawLine( greenPen, 50, 100, 550, 600 );
         xLayer.Canvas.DrawLine( greenPen, 550, 100, 50, 600 );

         // Save the document to disk
         doc.SaveToFile( "layers.pdf" );
      }
   }
}

The results of the code above are displayed below:

All layers visible | Top level X layer and 2 child layers invisible | All layers invisible


Form XObjects

PDF4NET Send comments on this topic.
Form XObjects
PDF4NET On-line Help > Developer's Guide > Creating content > Form XObjects

Glossary Item Box

A form XObject is a self contained graphic block. Its content is created like usual page content, using its own Canvas, and it can be painted multiple times on several pages in the same document or on several locations on the same page. The size of a form XObject is defined by its Width and Height properties, anything that falls outside the form XObject's rectangle is not visible. The coordinate system used by a form XObject has its origin in the top left corner. The form XObject has a Canvas property that allows to create its content, much like creating page content.
When a form XObject is drawn onto a page, its content is scaled and/or rotated to fit the given drawing rectangle.
The following sample shows how to create a simple form XObject and draw it multiple times on a page.
using System;
using System.IO;
using System.Drawing;
using System.Drawing.Imaging;
using System.Text;
using System.Net;
using System.Collections;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Fonts;
using O2S.Components.PDF4NET.Graphics.Shapes;

namespace Test
{

   class Test
   {

      [STAThread]
      static void Main(string[] args)
      {
         // Create the pdf document
         PDFDocument doc = new PDFDocument( );

         // Create one page
         PDFPage page = doc.AddPage( );

         PDFPen redPen = new PDFPen( new PDFColor( 255, 0, 0 ), 1 );
         PDFBrush darkBlueBrush = new PDFBrush( new PDFColor( 0, 0, 128 ) );

         // create a form XObject
         PDFFont font = new PDFFont( FontFace.Helvetica, 16 );
         string pdf4net = "PDF4NET";
         // the size of form xobject matches the text size
         PDFFormXObject form = new PDFFormXObject( );
         form.Width = font.MeasureString( pdf4net );
         form.Height = 16;
         // draw the text on the form xobject
         form.Canvas.DrawText( pdf4net, font, null, darkBlueBrush, 0, 0 );

         // draw the form XObject on the page.
         // strectch it to cover the whole page header and on the left margin
         page.Canvas.DrawFormXObject( form, 0, 0, page.Width, 24 );
         page.Canvas.DrawFormXObject( form, 32, 0, page.Height, 32, -90 );
         // draw the form XObject in its original size
         page.Canvas.DrawFormXObject( form, 50, 50, form.Width, form.Height );

         doc.SaveToFile( "formxobject.pdf" );
      }
   }
}

The result is displayed below:

The content of a form XObject is stored only once in the PDF file, no matter how many times it is drawn. This allows to reduce PDF file size when there are graphic patterns that repeat themselves on the same page or on several pages.


Custom brushes

PDF4NET Send comments on this topic.
Custom brushes
PDF4NET On-line Help > Developer's Guide > Creating content > Custom brushes

Glossary Item Box

The PDF4NET library provides support for custom brushes for filling closed paths. Both hatched brushes and gradient brushes are supported.

Hatched brushes

Hatched brushes allow filling closed paths with predefined patterns. The following patterns are available:
HatchType.BackwardDiagonal | HatchType.ForwardDiagonal | HatchType.Cross | HatchType.DiagonalCross | HatchType.Horizontal | HatchType.Vertical

Hatched brushes can be drawn either transparent (default) or opaque. To draw an opaque hatched pattern, set the Color property of the PDFHatchBrush object. Also, the color of the hatch pattern can be specified.
The following sample shows how to create a red hatched pattern with yellow background:
...
PDFHatchBrush hb = new PDFHatchBrush( HatchType.DiagonalCross );
hb.Color = new PDFColor( 255, 255, 0 ); // yellow background
hb.HatchColor = new PDFColor( 255, 0, 0 ); // red hatch
...
The result is displayed below:

The library allows to customize the distance between pattern's lines, both on vertical and on horizontal.
...
PDFHatchBrush hb = new PDFHatchBrush( HatchType.BackwardDiagonal );
hb.Color = new PDFColor( 255, 255, 0 ); // yellow background
hb.HatchColor = new PDFColor( 255, 0, 0 ); // red hatch
hb.HatchVerticalSize = 5;
hb.HatchHorizontalSize = 10;
...
The result is displayed below:

Gradient brushes

Gradient brushes can be used with any fillable path. They use linear gradients with 2 colors for filling the paths. Both horizontal and vertical gradients can be used with gradient brushes.
The following sample shows how to create a horizontal gradient:
...
PDFHorizontalGradientBrush hgb = new PDFHorizontalGradientBrush( );
hgb.StartColor = new PDFColor( Color.Red );
hgb.EndColor = new PDFColor( Color.Blue );
...
The result is displayed below:

The following sample shows how to create a vertical gradient:
...
PDFVerticalGradientBrush vgb = new PDFVerticalGradientBrush( );
vgb.StartColor = new PDFColor( Color.Green );
vgb.EndColor = new PDFColor( Color.Blue );
...
The result is displayed below:

Gradient brushes work only when using the default coordinate system (the point is the measure unit and the origin of the coordinate system is in the top left corner of the page).


Transparency

PDF4NET Send comments on this topic.
Transparency
PDF4NET On-line Help > Developer's Guide > Creating content > Transparency

Glossary Item Box

PDF4NET library allows to define unlimited levels of transparency in a PDF file. Once a transparency level has been set in place, all subsequent drawing operations will use it. Only one transparency level can be active at a moment. The transparency levels vary from 0% (opaque) to 100% (full transparency).
The following sample shows how to draw lines of text, each one with its transparency level:
using System;
using System.IO;
using System.Drawing;
using System.Text;
using System.Collections;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Fonts;
using O2S.Components.PDF4NET.Graphics.Shapes;

namespace Test
{
   class Test
   {
      [STAThread]
      static void Main(string[] args)
      {
         // Create the pdf document
         PDFDocument doc = new PDFDocument();

         // Create the graphic objects
         PDFBrush blackBrush = new PDFBrush(new PDFColor());
         PDFFont font = new PDFFont(FontFace.Helvetica, 20);
         font.Bold = true;
         PDFPage page = doc.AddPage( );

         // generate random background
         Random rnd = new Random( );
         for( int i = 0; i < 50; i++ )
         {
            // Create random colors for drawing the spline
            PDFRgbColor penColor = new PDFRgbColor(
               (byte)rnd.Next(256), (byte)rnd.Next(256), (byte)rnd.Next(256));

            // Create the pen to draw the border
            PDFPen randomPen = new PDFPen( penColor, 1 );

            // Generate random control points
            float x1 = rnd.Next( ( int )page.Width );
            float y1 = rnd.Next( ( int )page.Height );
            float x2 = rnd.Next( ( int )page.Width );
            float y2 = rnd.Next( ( int )page.Height );
            float x3 = rnd.Next( ( int )page.Width );
            float y3 = rnd.Next( ( int )page.Height );
            float x4 = rnd.Next( ( int )page.Width );
            float y4 = rnd.Next( ( int )page.Height );

            // Draw the Bezier spline
            page.Canvas.DrawBezier( randomPen, x1, y1, x2, y2, x3, y3, x4, y4 );
         }

         float y = 100;
         // draw several strings, each one with its level of transparency
         for( int i = 0; i <=  10 0; i = i + 5)
         {
            page.Canvas.SetTransparency( i );
            page.Canvas.DrawText( "PDF4NET transparency sample", font, null, blackBrush, 120, y );
            y = y + 24;
         }

         doc.SaveToFile( "transparency.pdf" );
      }
   }
}

The result is displayed below:


TrueType / Type1 fonts / CJK Fonts

PDF4NET Send comments on this topic.
TrueType / Type1 fonts / CJK Fonts
PDF4NET On-line Help > Developer's Guide > TrueType / Type1 fonts / CJK Fonts

Glossary Item Box

The PDF4NET library can use both TrueType/OpenType fonts and Type1 PostScript fonts.

TrueType/OpenType fonts

The TrueType/OpenType fonts can be used with PDF4NET library through TrueTypeFont class. These fonts are used in the same way the built in fonts are used. When a TrueTypeFont object is created, the path to the font file on disk must be provided. The font can be embedded or not in the pdf file.

When the TrueType font is embedded in the pdf file, the best results are obtained when the pdf file is viewed or printed, because the font data is available within the file.

When the TrueType font is not embedded in the pdf file, the pdf viewer will load the font, if available, from the local machine. If the font is not available on the local machine, the pdf viewer with substitute it with a font that matches the best the original font metrics.

At development time, the font must be present on the local machine, no matter the font will be embedded or not in the final pdf file, because the necessary metrics information must be extracted from the file. Because the library parses the font data in order to load the necessary metrics information, the font does not need to be installed on the local machine.

The following code snippet shows how to use a TrueType font:

...
TrueTypeFont ttf = new TrueTypeFont( "verdana.ttf", 12, true );
page.Canvas.DrawText( "This text uses Verdana font, size 12 and the font is embedded", ttf, pen, brush, 10, 10 );
...

The library allows to create a TrueTypeFont object based on an existing TrueTypeFont object. In this way, the second font object does not reparse the TrueType font file, and the font data is shared by both font objects. Because the Bold and Italic attributes are read from the font file, they are shared, so changing the Bold property for one font object causes the other font object to update its Bold property. These 2 properties are the only ones that are shared, all the other properties can be used without side effects.

When the font is embedded in the pdf file, the values of Bold and Italic properties are ignored, because the pdf viewer synthesize the correct font appearance based on the embedded font data. When the font is not embedded, these 2 properties are used to give the pdf viewer a hint about the font appearance.

The following code snippet shows how to create a TrueTypeFont object based on an existing one:

...
TrueTypeFont ttf2 = new TrueTypeFont( ttf, 16 );
page.Canvas.DrawText( "This text uses Verdana font, size 16", ttf2, pen, brush, 10, 50 );
...

The PDF4NET library provides support for Unicode characters, when using TrueType fonts. A Unicode TrueType font is created like in the sample below:

...
TrueTypeFont ttf = new TrueTypeFont( "verdana.ttf", 12, true, true );
page.Canvas.DrawText( "This text uses Unicode Verdana font, size 12 and the font is embedded", ttf, pen, brush, 10, 10 );
...

The 4th parameter of the constructor instructs the library to use Unicode features of the TrueType font.

A TrueType font can also be created from a System.Drawing.Font object. The following sample shows how to do it:

...
System.Drawing.Font fnt = new System.Drawing.Font( "verdana", 12 );
TrueTypeFont ttf = new TrueTypeFont( fnt, true, true );
page.Canvas.DrawText( "This text uses Unicode Verdana font, based on a System.Drawing.Font object, and the font is embedded", ttf, pen, brush, 10, 10 );
...

Type1 PostScript fonts

The Type1 PostScript fonts are used the same way (all that has been said above about TrueType fonts applies to Type1 fonts) like TrueType fonts, with one exception: when creating a PostScriptFont object, there are 2 files that define the font on disk. The PDF4NET library uses a .afm file (Adobe Font Metrics) or a .pfm file (Printer Font Metrics) to read font metrics, and a .pfb file (Printer Font Binary) to read font data.

The following code snippet shows how to use a Type1 font:

...
PostScriptFont psf = new PostScriptFont( "times-roman.afm", "times-roman.pfb", 12, true );
page.Canvas.DrawText( "This text uses Times-Roman postscript font, size 12 and the font is embedded", psf, pen, brush, 10, 10 );
...

CJK fonts

The PDF4NET library provides supports for CJK fonts based on Adobe Asian Language Pack. The following fonts are supported:
- Heisei Kaku Gothic W5 japanese font face (UniJIS-UCS2-H encoding).
- Heisei Mincho W3 japanese font face (UniJIS-UCS2-H encoding).
- Hanyang Systems Gothic Medium korean font face (UniKS-UCS2-H encoding).
- Hanyang Systems Shin MyeongJo Medium korean font face (UniKS-UCS2-H encoding).
- Monotype Hei Medium chinese traditional font face (UniCNS-UCS2-H encoding).
- Monotype Sung Light chinese traditional font face (UniCNS-UCS2-H encoding).
- SinoType Song Light chinese simplified font face (UniGB-UCS2-H encoding).

The following code snippet shows how to use a CJK font:

...
CJKFont cjk = new CJKFont( CJKFontFace.HeiseiKakuGothicW5, 12 );
page.Canvas.DrawText( "PDF4NET はあらゆるNET のアプリケーションからPDF 文書をオンザフラ", psf, pen, brush, 10, 10 );
...


Update existing pdf files

PDF4NET Send comments on this topic.
Update existing pdf files
PDF4NET On-line Help > Developer's Guide > Update existing pdf files

Glossary Item Box

With PDF4NET library, existing pdf files can be updated to include new content. The library can add new pages to an existing document, at any location, in front of existing pages, in the middle or at the end of the imported document. Adding new content to an existing page is the same like adding content to a new page. The new content is drawn on top of existing content. The existing content of a page can not me changed.

To import a pdf document in PDF4NET library, the following constructor should be used: PDFDocument( string pdfFile ); where the pdfFile parameter is the full path to a pdf file on disk. After the constructor is executed, the Pages collection of PDFDocument object contains a PDFPage object for each page in the source pdf file. The pages of the imported document can be accessed using the index based PDFDocument.Pages collection. Pages[0] is the first page of the document, while Pages[Pages.Count-1] is the last page of the document. New pages can be added anywhere in the document.

The following sample code shows how to add new content to an existing pdf file. It draws a line on top of the first page of the imported document.
...
PDFDocument doc = new PDFDocument( "helloworld.pdf" );
PDFPen pen = new PDFPen( );
doc.Pages[0].Canvas.DrawLine( pen, 0, 0, doc.Pages[0].Width, doc.Pages[0].Height );
doc.Save( "new.pdf" );
...

The next sample code shows how to create a new page at the beginning of the imported file, then it draws a line of text on it.
...
PDFDocument doc = new PDFDocument( "helloworld.pdf" );
// create a new page at the beginning of the document (insert it at index 0)
PDFPage page = doc.InsertPage( 0 );
page.Canvas.DrawText( "This is a new page", font, null, brush, 10, 10 );
doc.Save( "new.pdf" );
...


PDF Editing

PDF4NET Send comments on this topic.
PDF Editing
PDF4NET On-line Help > Developer's Guide > PDF Editing

Glossary Item Box

PDF4NET library allows to perfom a wide range of operations on existing pdf files. The library allows to merge multiple pdf files or to split a pdf file to individual pages, it allows to apply security to existing pdf files. It also allows to extract full pages or their content from a pdf file. All the methods dealing with pdf editing capabilities are located in the O2S.Components.PDF4NET.PDFFile namespace and PDFFile class implements all these operations.

Merging pdf files

Multiple pdf files can be merged at once with a single line of code. The resulted pdf file can be automatically saved to disk, or it can be used further in the application to add new content.
The following 2 methods are available for merging pdf files:
public static void MergeFiles( string destFileName, string[] srcFileNames );
This method allows to merge multiple pdf files into a single one that is automatically saved to disk. The source pdf files are provided in a string array. They are merged in the order they appear in the array. The resulted pdf file is saved to the file specified by destFileName parameter.
public static PDFDocument MergeFiles( string[] srcFileNames );
This method allows to merge multiple pdf files into a single one and returns the corresponding PDFDocument object to be further used in the application. The source pdf files are provided in a string array. They are merged in the order they appear in the array. The resulted pdf file is returned as a PDFDocument object.
Sample
The following sample shows how to append 2 pdf files:
PDFFile.MergeFiles( "append.pdf", new string[]{ "unicode.pdf", "multicolumntextandimages.pdf" } );

or

PDFDocument doc = PDFFile.MergeFiles( new string[]{ "unicode.pdf", "multicolumntextandimages.pdf" } );
doc.Save( stream );

Splitting pdf files

A pdf file can be splitted to individual pages and each pdf file corresponding to a page saved to disk.
The following method is available for splitting pdf files:
public static void SplitFile( string srcFileName, string destFileName );
This method allows to merge split a pdf file into a single pages that are automatically saved to disk. The source pdf file is specified by srcFileName parameter. The destFileName parameter is used to construct the name of each page. At the end of the name a suffix representing the page number is appended.
Sample
The following sample shows how to split a pdf file to single pages:
...
PDFFile.SplitFile( "unicode.pdf", "unicode-page.pdf" );
...

Applying security to existing pdf files

Existing pdf files can be secured at once with a single line of code. The resulted pdf file can be automatically saved to disk, or it can be used further in the application to add new content.
The following 2 methods are available for applying security to an existing pdf file:
public static void EncryptFile( PDFSEcurityManager securityManager, string srcFileName, string destFileName );
This method allows to encrypt a pdf file that is automatically saved to disk. The source pdf file specified by srcFileName parameter. The resulted pdf file that is encrypted is saved to the file specified by destFileName parameter. The security settings are specified by the securityManager parameter.
public static PDFDocument EncryptFile( PDFSEcurityManager securityManager, string srcFileName );
This method allows to encrypt a pdf file and returns the corresponding PDFDocument object to be further used in the application. The source pdf file specified by srcFileName parameter. The resulted pdf file is returned as a PDFDocument object. The security settings are specified by the securityManager parameter.

Sample
The following sample shows how to encrypt a pdf file:
PDFSecurityManager securityManager = new PDFSecurityManager( );
securityManager = securityManager;
securityManager.KeySize = EncryptionKeySize.Use128BitKey;
securityManager.UserPassword = Encoding.ASCII.GetBytes( "userpass" );
securityManager.OwnerPassword = Encoding.ASCII.GetBytes( "ownerpass" );
securityManager.AllowPrint = false;
securityManager.FullQualityPrint = true;
securityManager.AllowModifyDocument = false;
securityManager.AllowExtractContent = false;
securityManager.AllowInteractiveEdit = false;
securityManager.AllowFormsFill = true;
securityManager.AllowAccessibilityExtractContent = true;
securityManager.AllowAssembleDocument = false;

PDFFile.EncryptFile( securityManager, "unicode.pdf", "unicode_secure.pdf" );

// or

PDFDocument doc = PDFFile.EncryptFile( securityManager, "unicode.pdf" );
doc.Save( stream );

Page and content extraction

PDF4NET library allows to extract both full pages and page content only from existing pdf files. The difference between these 2 features is that a full page can be inserted as it is in a new document and includes annotations, links and form fields, while the page content can be drawn on any new page, rotated and scaled. Multiple extracted page contents can be placed on a single new page (page imposition). Page content is extracted as a binary block, not as single items (images, text, drawing primitives)
The following methods are available for extracting pages from an existing pdf file:
public PDFImportedPage ExtractPage( int pageNumber );
This method extracts a single page from a pdf document and returns the corresponding PDFImportedPage object. pageNumber is zero based index.
public PDFImportedPage[] ExtractPages( string pageNumbers );
This method extracts a set of pages from a pdf document and returns an array of PDFImportedPage objects.
The page numbers are specified using a comma or dash separated list. Page numbers separated by comma represent single pages, while dash separated page numbers represent page ranges. "1,2,3" represents pages 2, 3 and 4 (remember the page number as parameter is zero based), while "2-5" represents pages 3, 4, 5 and 6. A pages list can contain both comma and dashes, ex: "1, 3, 5-7, 10" meaning that pages 2, 4, 6, 7, 8 and 11 will be extracted.
An imported page can be added to a new pdf document using the AddPage( PDFPage page ) method of PDFDocument class.
The PDF4NET library can extract pages and content from encrypted PDF file. The overloaded FromFile method of PDFFile class accepts a password (user or owner password) as its second parameter.
Sample
The following sample shows how to mix 2 pdf files:
PDFFile unicodeFile = PDFFile.FromFile( "unicode.pdf" );
PDFFile mctiFile = PDFFile.FromFile( "multicolumntextandimages.pdf" );
PDFImportedPage ip = null;

PDFDocument doc = new PDFDocument( );
for( int i = 0; i < 4; i++ )
{
    // extract the page
    ip = unicodeFile.ExtractPage( i );

    // add the page to new document
    doc.AddPage( ip );

    // extract the page
    ip = mctiFile.ExtractPage( i );

    // add the page to new document
    doc.AddPage( ip );
}

// save the mixed document
doc.Save( "mix.pdf" );

unicodeFile.Close( );
mctiFile.Close( );

The following methods are available for extracting page content from an existing pdf file:
public PDFImportedContent ExtractPageContent( int pageNumber );
This method extracts a single page content from a pdf document and returns the corresponding PDFImportedContent object. pageNumber is zero based index.
public PDFImportedContent[] ExtractPagesContent( string pageNumbers );
This method extracts a set of pages content from a pdf document and returns an array of PDFImportedContent objects.
The page numbers are specified using a comma or dash separated list. Page numbers separated by comma represent single pages, while dash separated page numbers represent page ranges. "1,2,3" represents pages 2, 3 and 4 (remember the page number as parameter is zero based), while "2-5" represents pages 3, 4, 5 and 6. A pages list can contain both comma and dashes, ex: "1, 3, 5-7, 10" meaning that pages 2, 4, 6, 7, 8 and 11 will be extracted.
Imported content is drawn on a new page using the DrawImportedContent method of PDFCanvas class.

Sample
The following sample shows how to place the content of 4 pages on a single new page:
PDFFile mctiFile = PDFFile.FromFile( "multicolumntextandimages.pdf" );
// extract the content of first 4 pages
PDFImportedContent[] ic = mctiFile.ExtractPagesContent( "0-3" );

// create the new document
PDFDocument doc = new PDFDocument( );
// add a page to it
PDFPage page = doc.AddPage( );

// draw the imported content (4 pages) on the new page
page.Canvas.DrawImportedContent( ic[0], 0, 0, page.Width/2, page.Height/2 );
page.Canvas.DrawImportedContent( ic[1], page.Width/2, 0, page.Width/2, page.Height/2 );
page.Canvas.DrawImportedContent( ic[2], 0, page.Height/2, page.Width/2, page.Height/2 );
page.Canvas.DrawImportedContent( ic[3], page.Width/2, page.Height/2, page.Width/2, page.Height/2 );

// save the mixed document
doc.Save( "imposition.pdf" );

mctiFile.Close( );


Automatic page numbering

PDF4NET Send comments on this topic.
Automatic page numbering
PDF4NET On-line Help > Developer's Guide > Automatic page numbering

Glossary Item Box

The PDF4NET library offers the possibility of numbering document's pages in an automated way. The developer can customize the way the page number is displayed on document's pages. The visual aspect of page number can be customized for each page, if desired. Also, the developer can set up numbering schemes (also known as numbering ranges), associating a numbering range with a set of consecutive pages in the document. The pages covered by a numbering range share the same numbering system. A numbering range starts from a page in the document and ends where the next numbering range starts, or at the end of the document. The start of a numbering range is defined by the index of first page in range. This index a document global index and represents the position of the page in document's Pages collection. This index is 0 based. The first page of the document has 0 index, the second page has 1 index, the third page has 2 index, and so on. This index is not the same with the page number. While for some documents they may coincide, generally they do not match. The page index always starts at 0 for the first page and runs consecutively through the document, while the page numbers can start with any value that is appropiate for the document's logical structure. For example, a document may have an introduction of 10 pages numbered in roman numerals, while the rest of the document is numbered using arabic numerals. The first page in the document has index 0 and page number i, the tenth page in the document has index 9 and page number x, and the eleventh page has index 10 and page number 1. The previous example assumes that 2 numbering ranges have been defined for the document, one starting at index 0 with roman numbering system, and another starting at index 10 with arabic numberic system.

Implementation

The automatic page numbering features of PDF4NET library are implemented by 2 classes:.

- PDFPageNumberingRange - defines a numbering range.

- PDFPageNumber - defines the visual aspect of the page number as it is printed on the page.

PDFPageNumberingRange
A numering range defines a common numbering system for a set of consecutive pages. A numbering range is characterized by the following properties:
- start page index - the index of the page where the numbering range starts
- start page number - the value of the page number for the first page in range. For the rest of the pages in range, this value is incremented accordingly with page's position in range. For example, the page number for the first page in a range in 10, then for the second page it is 11, for the third page it is 12, and so on.
- numbering style - defines the numbering system for the range. It can be roman numbering system or arabic numbering system. For roman numbering system, uppercase or lowercase letters can be used.
- page prefix - a string the will be displayed in front of the page number when it is printed on the page. For example, for a range the string "Chapter 1 - " is defined as prefix and the page number starts at 1. When the page numbers are drawn on the page, they will look like this: Chapter 1 - 1 for the first page, Chapter 1 - 2 for the second page, and so on.
The following sample source code numbers the document in the following way: introduction on first 10 page with roman numbering system, and the rest of the pages with arabic numbering system
...
PDFPageNumberingRange pnr1 = new PDFPageNumberingRange( );
pnr1.StartPageIndex = 0;
pnr1.StartPageNumber = 1;
pnr1.NumberingStyle = NumberingStyle.LowerCaseRoman;
PDFPageNumberingRange pnr2 = new PDFPageNumberingRange( );
pnr2.StartPageIndex = 10;
pnr2.StartPageNumber = 1;
pnr2.NumberingStyle = NumberingStyle.Arabic;
doc.AddNumberingRange( pnr1 );
doc.AddNumberingRange( pnr2 );
...

PDFPageNumber
This class defines the visual aspect of the printed page number. A page number is characterized by the following properties:
- font - the font used to draw the page number.
- pen - the pen used to draw the border of the text representing the page number.
- brush - the brush used to fill the interior of the text representing the page number.
- align - the alignment of the page number when it is drawn on the page.
- vertical offset and horizontal offset - these 2 values are dependent on the type of alignment of the page number. When the page number is left aligned on horizontal, the horizontal offset represents the distance between the left margin of the page and the left margin of the text. When the page number is right aligned on horizontal, the horizontal offset represents the distance between the right margin of the page and the right margin of the text. When the page number is center aligned on horizontal, the horizontal offset is not used, the page number is positioned in the center of the page, on horizontal. When the page number is top aligned on verical, the vertical offset represents the distance between the top margin of the page and the top margin of the text. When the page number is bottom aligned on vertical, the vertical offset represents the distance between the bottom margin of the page and the bottom margin of the text. When the page number is middle aligned on vertical, the vertical offset is not used, the page number is positioned in the middle of the page, on vertical.
The page number appearance can be customized separately for each page of the document.

Note: The page number is printed on a page only if the page belongs to a numbering range and it has defined a page number (the Number property of the page is not null).


Creating document's bookmarks tree

PDF4NET Send comments on this topic.
Creating document's bookmarks tree
PDF4NET On-line Help > Developer's Guide > Creating document's bookmarks tree

Glossary Item Box

To ease navigation in large documents, pdf files may display a document outline in the viewer, allowing the user to navigate from one page to another. The document outline consists of a tree like hierarchy of bookmark items. This tree hierarchy serves as a visual table of content that display the structure of the document to the user. Each node in the outline can be open or closed with the mouse. When a node is open, its immediate children are displayed. Each child can be open or closed, revealing further the parts of the hierarchy. When an item is clicked, the viewer displays the destination page associated with the item. In fact, a bookmark item acts like an internal link, the difference is that the document bookmarks are displayed in a separate navigation page, and both the document and its bookmarks can be visible at the same time.

The document bookmarks are displayed using a viewer selected font, but the document can specify whether a bookmark item should be displayed bold and/or italic. Also, the document can choose a different color for each bookmark item.

In the PDF4NET object model an outline item is represented by PDFBookmark class. Each bookmark has a Bookmarks collection which represents its immediate children. The document object also holds a Bookmarks collection. The bookmark items in this collection represent the top level items in the hierarchy.


Linking to other content

PDF4NET Send comments on this topic.
Linking to other content
PDF4NET On-line Help > Developer's Guide > Linking to other content

Glossary Item Box

PDF files may include hyperlinks to various content. This content can be internal or external to the document. A hyperlink is defined by a rectangular area on the page.

Depending on the type of the referred content, the hyperlinks can be divided in 4 categories:

1. Internal document links - these links point to pages in the same document. These links can be created using PDFAreaDocLink / PDFTextDocLink classes. When creating an internal link, the destination page and a vertical offset must be specified. The vertical offset is used to position the destination page when it is open in the viewer as a result of using the link. If the vertical offset is 0, then the page is displayed at top, and if it is page.Height/2 then the page is displayed starting from middle. This positioning is dependent on the screen resolution, if the screen resolution allows the display of a full page, then the value of the vertical offset does not matter because the destination page will be always displayed in full. If the screen resolution does not allow the display of a full page and you have to scroll up and down to view the page, then the vertical offset works. The vertical offset is set using the TopDestination property of the document link classes.
When an internal link is clicked, the destination page is displayed in the viewer and it is positioned as specified by the vertical offset.

2. External document links - these links point to other pdf files. These links can be created using PDFAreaRemoteDocLink / PDFTextRemoteDocLink classes. When creating an external document link, the path to the destination pdf document must be specified. If the path is a relative one, then it is considered relative to the location of the current document.
When an external document link is clicked, the destination pdf file is loaded in the viewer.

3. External file links - these links point to other types of files. These links can be created using PDFAreaFileLink / PDFTextFileLink classes. When creating an external file link, the path to the destination file must be specified. If the path is a relative one, then it is considered relative to the location of the current document.
When an external file link is clicked, the destination file is launched or it is opened by its associated application.

4. Web links - these links point to web locations. These links can be created using PDFAreaWebLink / PDFTextwebLink classes. When creating a web link, the URL of the web location file must be specified.
When a web link is clicked, the URL is opened in the browser.

The PDF4NET library allows the creation of all 4 types of links. Each type of link comes in 2 flavours: a rectangular link and a text link.

- rectangular links are defined by a rectangular area on the page. When the user clicks inside the rectangle, he is taken to the corresponding destination.

- text links are a specialized version of the rectangular links. In fact, they are rectangular links, but the library calculates the rectangular area automatically, as the bounding rectangle of the text.

Neither types of links can be displayed rotated.


Document metadata

PDF4NET Send comments on this topic.
Document metadata
PDF4NET On-line Help > Developer's Guide > Document metadata

Glossary Item Box

PDF files can store general information about the document itself. They also can control the way they are displayed when they are open in the viewer.

Document information

A PDF file may store information about the document, such as document's title, subject, etc. This information can be searched by external applications for different purposes.

You can access this information using the DocumentInformation property of the document class. The value of this property is an instance of PDFDocumentInformation class. All the information fields can be accessed using the properties of DocumentInformation object. The following items can be used:

- Title (read/write)

- Author (read/write)

- Subject (read/write)

- Keywords (read/write)

- Creator (read/write) - the application that is creating the pdf file.

- Producer (read only) - this property always evaluates to "PDF4NET (http://www.pdf4net.com/)".

This information is displayed in Document Info window in Adobe's viewers.

Viewer preferences

A PDF file can control the way the document is presented on the screen when it is open in the viewer. The following customizations of the viewer can be performed when a document is open:

- hide toolbar - when the document is open, the toolbar can be made invisible.

- hide menu bar - when the document is open, the menu bar can be made invisible.

- hide viewer user interface - when the document is open, the whole viewer user interface can be made invisible.

- fit window - when the document is open, the document's window can be resized to fit the size of first displayed page.

- center window - when the document is open, the document's window can be placed in the center of the screen.

- display document title - when the document is open, the document's title is displayed in the titlebar of the viewer, instead of file's name.

These properties can be accessed using the ViewerPreferences property of the document class. The value of this property is an instance of PDFViewerPreferences class.


PDF Security and encryption

PDF4NET Send comments on this topic.
PDF Security and encryption
PDF4NET On-line Help > Developer's Guide > PDF Security and encryption

Glossary Item Box

PDF4NET library allows to create secure pdf documents, with support for user and owner passwords, document encryption and document access rights.

The following options are available when creating a secure document:

Encryption - pdf documents can be encrypted using 40 bit or 128 bit keys. PDF4NET library supports both key types.

User and owner password - pdf documents can be protected using 2 passwords: a user password and an owner password. The user password allows a user to view the document and the access to document is restricted based on the access rights that have been set. The owner password allows a user to get full control over the pdf document. When both password are identical, the user is considered to log in as owner.

Access rights - the following access rights can be set on a pdf document:
Allow Print - this flag, together with FullQualityPrint flag and encryption key size, controls the printing of the document. If this flag is not set, then the user is not allowed to print the document. If this property is true, then the user is allowed to print the document, depending on the value of FullQualityPrint flag and encryption key size. If encryption key size is 40 bit then FullQualityPrint flag property is ignored. If encryption key size is 128 bit then if FullQualityPrint flag is set, then the document is printed at full quality, otherwise printing of the document is limited to a low-level representation of the document, of degraded quality. This degraded quality printing is viewer implementation dependent.
Full Quality Print - This property has effect only when AllowPrint flag is set and encryption key size is 128 bit. If this flag is set, then the document is printed at full quality, otherwise printing of the document is limited to a low-level representation of the document, of degraded quality. This degraded quality printing is viewer implementation dependent.
Allow Modify Document - This flag, if set, allows a user to modify the content of pdf document by operations other than those controlled by the following flags: Allow Interactive Edit, Allow Forms Fill, Allow Assemble Document.
Allow Interactive Edit - This flag, if set, allows a user to add or modify text annotations, fill in interactive forms fields, and, if AllowModifyDocument flag is set, create or modify interactive form fields (including signature fields).
Allow Forms Fill - This flag has effect only when using 128 bit encryption. This flag, if set, allows a user to fill in existing interactive form fields (including signature fields), even the Allow Interactive Edit flag is not set.
Allow Assemble Document - This flag has effect only when using 128 bit encryption This flag, if set, allows a user to assemble the document (insert, rotate, or delete pages and create bookmarks or thumbnail images), even the Allow Modify Document flag is not set.
Allow Extract Content - When using 128 bit encryption this flag, if set, allows a user to copy or otherwise extract text and graphics from the document by operations other than those controlled by AllowAccessibilityExtractContent flag. When using 40 bit encryption, then this flag also controls extraction of text and graphics in support of accessibility to disabled users or other purposes.
Allow Accessibility Extract Content - This property has effect only when using 128 bit encryption This flag, if set, allows a user to copy or otherwise extract text and graphics from the document in support of accessibility to disabled users or for other.

The PDF security and encryption are implemented by PDFSecurityManager class. It exposes properties for setting the encryption key size, the user and owner passwords and the above access rights. A pdf document is encrypted automatically when the SecurityManager property of a PDFDocument object is set to a valid instance of PDFSEcurityManager class.

The following sample shows how to set the security over a pdf file:
...
// Create the pdf document
PDFDocument doc = new PDFDocument( );

// set the security options
doc.SecurityManager = new PDFSecurityManager( );
// use 128 bit encryption
doc.SecurityManager.KeySize = EncryptionKeySize.Use128BitKey;
// set user password to "userpass"
doc.SecurityManager.UserPassword = Encoding.ASCII.GetBytes( "userpass" );
// set owner password to "ownerpass"
doc.SecurityManager.OwnerPassword = Encoding.ASCII.GetBytes( "ownerpass" );
// allow to print the pdf document
doc.SecurityManager.AllowPrint = true;
// do not allow high quality print
doc.SecurityManager.FullQualityPrint = false;
// do not alow to modify the document
doc.SecurityManager.AllowModifyDocument = false;
// do not allow to extract content (text and images) from the document
doc.SecurityManager.AllowExtractContent = false;
// do not allow to fill forms or to create annotations
doc.SecurityManager.AllowInteractiveEdit = false;
// do not allow forms fill
doc.SecurityManager.AllowFormsFill = false;
// allow to extract content in support for accessibility
doc.SecurityManager.AllowAccessibilityExtractContent = true;
// do not allow to assemble document
doc.SecurityManager.AllowAssembleDocument = false;
...
...
doc.SaveToFile( "encrypted.pdf" );


PDF Actions

PDF4NET Send comments on this topic.
PDF Actions
PDF4NET On-line Help > Developer's Guide > PDF Actions

Glossary Item Box

In a PDF file, the target of a bookmark can be an action to be performed when the bookmark is selected. Also, actions can be executed automatically when a document is opened or when a page is displayed.
The following actions are supported by PDF4NET library:

GoTo actions

A GoTo action (PDFGoToAction class) displays a specified page in the current document. A position and a magnification factor can be specified for the destination page.

The sample below shows a GoTo action that displays the second page of the document at the top using a magnification factor of 800%:

static void Main(string[] args)
{
     // Create the pdf document
     PDFDocument doc = new PDFDocument( );

     // Create two pages
     doc.AddPage( );
     doc.AddPage( );

     /// OpenDocument action
     // Create an action to be executed when the document is opened
     // The action will open the document at the
     // second page of the document using a 800% zoom
     PDFGoToAction goToAction = new PDFGoToAction( );
     goToAction.Page = doc.Pages[1];
     goToAction.MagnificationMode = PDFMagnificationMode.XYZ;
     goToAction.Left = 0;
     goToAction.Top = 0;
     goToAction.Zoom = 800;

     // set the action on the document
     doc.OpenAction = goToAction;
     /// OpenDocument action

     // Save the document to disk
     doc.Save( "actions.pdf" );
}

Remote GoTo actions

A Remote GoTo action (PDFRemoteGoToAction class) displays a specified page in an external pdf document. A position and a magnification factor can be specified for the destination page.

The sample below shows a Remote GoTo action that displays the second page of the "second.pdf" document at the top using a magnification factor of 800%:

static void Main(string[] args)
{
     // Create the pdf document
     PDFDocument doc = new PDFDocument( );

     // Create one page
     doc.AddPage( );

     // create a remote GoTo action
     PDFRemoteGoToAction remoteGoToAction = new PDFRemoteGoToAction( );
     // the page number is zero based
     remoteGoToAction.PageNumber = 1;
     remoteGoToAction.RemoteFile = "second.pdf";

     // create a bookmark to point to the "second.pdf"
     PDFBookmark bk = new PDFBookmark("External pdf document", new PDFColor( ), false, OutlineDisplay.Regular, remoteGoToAction);

     // add the bookmark to the document
     doc.Bookmarks.Add(bk);

     // Save the document to disk
     doc.Save( "actions.pdf" );
}

JavaScript actions

A JavaScript action (PDFJavaScriptAction class) allows execution of javascript code embedded in the pdf document.

The sample below shows a JavaScript action that prints the document:

static void Main(string[] args)
{
     // Create the pdf document
     PDFDocument doc = new PDFDocument( );

     // Create one page
     doc.AddPage( );

     // create a javascript action to print the document
     PDFJavaScriptAction jsAction = new PDFJavaScriptAction( );
     jsAction.Script = "this.print(true);\n";

     // create a bookmark to execute the action
     PDFOutline js = new PDFOutline( "Print me from JavaScript", new PDFColor( ), false, OutlineDisplay.Regular, jsAction );

     // add the bookmark to the document
     doc.Outlines.Add( js );

     // Save the document to disk
     doc.Save( "actions.pdf" );
}

Launch actions

A Launch action (PDFLaunchAction class) allows execution of an external application or file.

The sample below shows a Launch action that launches Microsoft Word:

static void Main(string[] args)
{
     // Create the pdf document
     PDFDocument doc = new PDFDocument( );

     // Create one page
     doc.AddPage( );

     // create a Launch action to start the MS Word application
     PDFLaunchAction launchAction = new PDFLaunchAction( );
     launchAction.File = "msword.exe";

     // create a bookmark to execute the action
     PDFBookmark bk = new PDFBookmark( "Start me", new PDFColor( ), false, OutlineDisplay.Regular, launchAction );

     // add the bookmark to the document
     doc.Outlines.Add(bk);

     // Save the document to disk
     doc.Save( "actions.pdf" );
}

Named actions

A Named action (PDFNamedAction class) allows execution of predefined PDF actions. The following predefined PDF actions are available: go to next page, go to prev page, go to first page, go to last page.

The sample below shows a Named action that displays the last page of the document:

static void Main(string[] args)
{
     // Create the pdf document
     PDFDocument doc = new PDFDocument( );

     // Create one page
     doc.AddPage( );

     // create a Named action to display the last page of the document
     PDFNamedAction namedAction = new PDFNamedAction( );
     namedAction.NamedAction = NamedAction.LastPage;

     // create a bookmark to execute the action
     PDFOutline ol = new PDFOutline( "Go to last page", new PDFColor( ), false, OutlineDisplay.Regular, namedAction );

     // add the bookmark to the document
     doc.Outlines.Add( ol );

     // Save the document to disk
     doc.SaveToFile( "actions.pdf" );
}

URI actions

A URI action (PDFURIAction class) allows to display a hypertext link in a web browser.

The sample below shows an URI action that displays the O2 Solutions homepage in the browser:

static void Main(string[] args)
{
     // Create the pdf document
     PDFDocument doc = new PDFDocument( );

     // Create one page
     doc.AddPage( );

     // create a URI action to display the O2 Solutions homepage
     PDFURIAction uriAction = new PDFURIAction( );
     uriAction.URI = "http://www.o2sol.com/";

     // create a bookmark to execute the action
     PDFBookmark bk = new PDFBookmark( "www.o2sol.com", new PDFColor( ), false, OutlineDisplay.Regular, uriAction );

     // add the bookmark to the document
     doc.Bookmarks.Add(bk);

     // Save the document to disk
     doc.Save( "actions.pdf" );
}


Annotations

PDF4NET Send comments on this topic.
Annotations
PDF4NET On-line Help > Developer's Guide > Annotations

Glossary Item Box

PDF4NET library provides support for adding annotations both to existing and newly created PDF files. The following annotation types are supported: circle annotation, file attachment annotation (for embedding files into a PDF file), line annotation, markup annotation, movie annotation, rubber stamp annotation, square annotation and text annotation. Each annotation allows to control its opacity. The annotation's opacity can vary from 0 (fully transparent) to 100 (opaque).

The following sample shows how to create several types of annotations:

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Annotations;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;

namespace O2S.Samples.PDF4NET.Annotations
{
   /// <summary>
   /// This sample shows all annotations that can be created with PDF4NET.
   /// </summary>
   class Annotations
   {
      /// <summary>
      /// The main entry point for the application.
      /// </summary>
      [STAThread]
      static void Main(string[] args)
      {
         // Create the pdf document
         PDFDocument doc = new PDFDocument( );

         // Create one page
         PDFPage page = doc.AddPage( );

         PDFBrush blackBrush = new PDFBrush( new PDFColor( 0, 0, 0 ) );
         PDFFont fontSection = new PDFFont( FontFace.Helvetica, 10 );
         fontSection.Bold = true;
         PDFFont fontText = new PDFFont( FontFace.Helvetica, 8 );

         page.Canvas.DrawText( "Text annotations", fontSection, null, blackBrush, 20, 45, 0, TextAlign.BottomLeft );
         // Create all available text annotations
         PDFTextAnnotation ta = new PDFTextAnnotation( "Comment", "Comment annotation" );
         ta.Icon = TextAnnotationIcon.Comment;
         ta.Rectangle = new RectangleF( 20, 60, 100, 100 );
         page.Annotations.Add( ta );
         page.Canvas.DrawText( "Comment", fontText, null, blackBrush, 20, 80, 0, TextAlign.TopLeft );

         ta = new PDFTextAnnotation( "Help", "Help annotation" );
         ta.Icon = TextAnnotationIcon.Help;
         ta.Rectangle = new RectangleF( 100, 60, 100, 100 );
         page.Annotations.Add( ta );
         page.Canvas.DrawText( "Help", fontText, null, blackBrush, 100, 80, 0, TextAlign.TopLeft );

         ta = new PDFTextAnnotation( "Insert", "Insert annotation" );
         ta.Icon = TextAnnotationIcon.Insert;
         ta.Rectangle = new RectangleF( 180, 60, 100, 100 );
         page.Annotations.Add( ta );
         page.Canvas.DrawText( "Insert", fontText, null, blackBrush, 180, 80, 0, TextAlign.TopLeft );

         ta = new PDFTextAnnotation( "Key", "Key annotation" );
         ta.Icon = TextAnnotationIcon.Key;
         ta.Rectangle = new RectangleF( 260, 60, 100, 100 );
         page.Annotations.Add( ta );
         page.Canvas.DrawText( "Key", fontText, null, blackBrush, 260, 80, 0, TextAlign.TopLeft );

         ta = new PDFTextAnnotation( "New paragraph", "New paragraph annotation" );
         ta.Icon = TextAnnotationIcon.NewParagraph;
         ta.Rectangle = new RectangleF( 340, 60, 100, 100 );
         page.Annotations.Add( ta );
         page.Canvas.DrawText( "New paragraph", fontText, null, blackBrush, 340, 80, 0, TextAlign.TopLeft );

         ta = new PDFTextAnnotation( "Note", "Note annotation" );
         ta.Icon = TextAnnotationIcon.Note;
         ta.Rectangle = new RectangleF( 420, 60, 100, 100 );
         page.Annotations.Add( ta );
         page.Canvas.DrawText( "Note", fontText, null, blackBrush, 420, 80, 0, TextAlign.TopLeft );

         ta = new PDFTextAnnotation( "Paragraph", "Paragraph annotation" );
         ta.Icon = TextAnnotationIcon.Paragraph;
         ta.Rectangle = new RectangleF( 500, 60, 100, 100 );
         page.Annotations.Add( ta );
         page.Canvas.DrawText( "Paragraph", fontText, null, blackBrush, 500, 80, 0, TextAlign.TopLeft );

         // Rubber stamp annotations

         page.Canvas.DrawText( "Rubber stamp annotations", fontSection, null, blackBrush, 20, 120, 0, TextAlign.TopLeft );
         // Create all available rubber stamp annotations
         PDFRubberStampAnnotation rsa = new PDFRubberStampAnnotation( "Approved", "Approved annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Approved;
         rsa.Rectangle = new RectangleF( 20, 140, 100, 30 );
         rsa.Opacity = 50;
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "Approved", fontText, null, blackBrush, 20, 180, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "As Is", "As Is annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Asis;
         rsa.Rectangle = new RectangleF( 120, 140, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "As Is", fontText, null, blackBrush, 120, 180, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "Confidential", "Confidential annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Confidential;
         rsa.Rectangle = new RectangleF( 220, 140, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "Confidential", fontText, null, blackBrush, 220, 180, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "Departmental", "Departmental annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Departmental;
         rsa.Rectangle = new RectangleF( 320, 140, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "Departmental", fontText, null, blackBrush, 320, 180, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "Draft", "Draft annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Draft;
         rsa.Rectangle = new RectangleF( 420, 140, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "Draft", fontText, null, blackBrush, 420, 180, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "Experimental", "Experimental annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Experimental;
         rsa.Rectangle = new RectangleF( 520, 140, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "Experimental", fontText, null, blackBrush, 520, 180, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "Expired", "Expired annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Expired;
         rsa.Rectangle = new RectangleF( 20, 200, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "Expired", fontText, null, blackBrush, 20, 240, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "Final", "Final annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Final;
         rsa.Rectangle = new RectangleF( 120, 200, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "Final", fontText, null, blackBrush, 120, 240, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "ForComment", "ForComment annotation" );
         rsa.Icon = RubberStampAnnotationIcon.ForComment;
         rsa.Rectangle = new RectangleF( 220, 200, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "ForComment", fontText, null, blackBrush, 220, 240, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "ForPublicRelease", "ForPublicRelease annotation" );
         rsa.Icon = RubberStampAnnotationIcon.ForPublicRelease;
         rsa.Rectangle = new RectangleF( 320, 200, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "ForPublicRelease", fontText, null, blackBrush, 320, 240, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "NotApproved", "NotApproved annotation" );
         rsa.Icon = RubberStampAnnotationIcon.NotApproved;
         rsa.Rectangle = new RectangleF( 420, 200, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "NotApproved", fontText, null, blackBrush, 420, 240, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "NotForPublicRelease", "NotForPublicRelease annotation" );
         rsa.Icon = RubberStampAnnotationIcon.NotForPublicRelease;
         rsa.Rectangle = new RectangleF( 520, 200, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "NotForPublicRelease", fontText, null, blackBrush, 520, 240, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "Sold", "Sold annotation" );
         rsa.Icon = RubberStampAnnotationIcon.Sold;
         rsa.Rectangle = new RectangleF( 20, 260, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "Sold", fontText, null, blackBrush, 20, 300, 0, TextAlign.TopLeft );

         rsa = new PDFRubberStampAnnotation( "TopSecret", "TopSecret annotation" );
         rsa.Icon = RubberStampAnnotationIcon.TopSecret;
         rsa.Rectangle = new RectangleF( 120, 260, 100, 30 );
         page.Annotations.Add( rsa );
         page.Canvas.DrawText( "TopSecret", fontText, null, blackBrush, 120, 300, 0, TextAlign.TopLeft );

         // Line annotations

         page.Canvas.DrawText( "Line annotations", fontSection, null, blackBrush, 20, 350, 0, TextAlign.TopLeft );
         PDFLineAnnotation la = new PDFLineAnnotation( "Line", "Line annotation" );
         la.BeginLineStyle = LineEndingStyle.Circle;
         la.EndLineStyle = LineEndingStyle.OpenArrow;
         la.Rectangle = new RectangleF( 20, 370, 150, 30 );
         la.Border = new PDFAnnotationBorder( 1, BorderStyle.Solid );
         la.BorderColor = new PDFColor( Color.Red );
         la.InteriorColor = new PDFColor( Color.CornflowerBlue );
         page.Annotations.Add( la );
         page.Canvas.DrawText( "Line annotation with a circle and open arrow", fontText, null, blackBrush,
            20, 420, 0, TextAlign.TopLeft );

         // File attachment annotations

         page.Canvas.DrawText( "File attachment annotations", fontSection, null, blackBrush, 20, 480, 0, TextAlign.TopLeft );
         // Create all available file attachment annotations
         PDFFileAttachmentAnnotation faa = new PDFFileAttachmentAnnotation( "Graph", "Graph icon" );
         faa.Icon =FileAttachmentAnnotationIcon.Graph;
         faa.Rectangle = new RectangleF( 20, 500, 100, 30 );
         faa.Compress = true;
         faa.File = "sample.pdf";
         page.Annotations.Add( faa );
         page.Canvas.DrawText( "Graph", fontText, null, blackBrush, 20, 530, 0, TextAlign.TopLeft );

         faa = new PDFFileAttachmentAnnotation( "Paperclip", "Paperclip icon" );
         faa.Icon =FileAttachmentAnnotationIcon.Paperclip;
         faa.Rectangle = new RectangleF( 100, 500, 100, 30 );
         faa.Compress = true;
         faa.File = "sample.pdf";
         page.Annotations.Add( faa );
         page.Canvas.DrawText( "Paperclip", fontText, null, blackBrush, 100, 530, 0, TextAlign.TopLeft );

         faa = new PDFFileAttachmentAnnotation( "PushPin", "PushPin icon" );
         faa.Icon =FileAttachmentAnnotationIcon.PushPin;
         faa.Rectangle = new RectangleF( 180, 500, 100, 30 );
         faa.Compress = true;
         faa.File = "sample.pdf";
         page.Annotations.Add( faa );
         page.Canvas.DrawText( "PushPin", fontText, null, blackBrush, 180, 530, 0, TextAlign.TopLeft );

         faa = new PDFFileAttachmentAnnotation( "Tag", "Tag icon" );
         faa.Icon =FileAttachmentAnnotationIcon.Tag;
         faa.Rectangle = new RectangleF( 260, 500, 100, 30 );
         faa.Compress = true;
         faa.File = "sample.pdf";
         page.Annotations.Add( faa );
         page.Canvas.DrawText( "Graph", fontText, null, blackBrush, 260, 530, 0, TextAlign.TopLeft );

         // Save the document to disk
         doc.Save( "annotations.pdf" );
      }
   }
}

The result is displayed below:


PDF Forms

PDF4NET Send comments on this topic.
PDF Forms
PDF4NET On-line Help > Developer's Guide > PDF Forms

Glossary Item Box

This section shows how to use PDF4NET library when working with PDF forms.
Interactive forms allows to collect input from user. The PDF specification, starting with PDF 1.5, supports 2 types of interactive forms: AcroForms and XFA Forms.

AcroForms

AcroForms are available starting with PDF 1.2. They evolved as the PDF specification evolved, and now complex business scenarios can be developed using AcroForms.
The following form field types are supported in AcroForms:
• textboxes - single and multi line
• pushbuttons
• checboxes
• radiobuttons
• dropdown lists
• listboxes
Form fields can be enhanced with JavaScript actions for data formatting and validation, or for interoperability with external data sources, such as SOAP webservices.
PDF4NET library supports both creating new AcroForms and reading and filling existing AcroForms.

XFA Forms

XFA Forms are available starting with PDF 1.5, but they become widely used starting with PDF 1.6. They are the new generation of PDF forms that follow the Adobe's XML Forms Architecture. They are more complex that AcroForms and they have features that are not available in AcroForms.
The following form field types are supported in XFA Forms:
• text fields - single and multi line
• password fields
• numeric fields
• date and time fields
• pushbutton fields
• checkbutton fields
• radiobutton lists
• choice fields - both drop down and list
• image fields
• barcode fields
Form fields can be enhanced with JavaScript or FormCalc scripts for data formatting, validation and complex calculations, or for interoperability with external data sources, such as databases and SOAP web services.
PDF4NET library supports reading and filling existing XFA Forms, all the above field types being supported.

Working with interactive forms

The PDF4NET library allows to accomplish a variety of form related tasks when working PDF forms.
• Create AcroForms - shows how to create AcroFroms using the object model available in PDF4NET library.
• Read and fill AcroForms - shows how to read values from AcroForms and how to fill fields in AcroForms.
• Read and fill XFA Forms - shows how to read values from XFA Forms and how to fill fields in XFA Forms.
• Data import/export - shows how to import and export data from PDF forms.
• Advanced topics - less known things about PDF forms.


PDF Forms: Create AcroForms

PDF4NET Send comments on this topic.
PDF Forms: Create AcroForms
PDF4NET On-line Help > Developer's Guide > Working with forms > PDF Forms: Create AcroForms

Glossary Item Box

PDF4NET library can create fully working PDF forms that can be filled from code or from any interactive PDF viewer application.
All AcroForm fields can be created with PDF4NET library. Throughout the sample code fragments below, the doc variable is a PDFDocument object and page variable is a PDFPage object.
All form related classes are located in O2S.Components.PDF4NET.Forms namespace.

How to create a text box

A text box field is represented in PDF4NET library by PDFTextBoxField class.
A simple text box field can be created with only 3 lines of code:
...
// Create the text box field.
PDFTextBoxField tbx = new PDFTextBoxField( "TextBox1" );
// Set the field's position on page.
tbx.Appearance.Rectangle = new RectangleF( 50, 50, 200, 20 );
// Attach the field to the page.
page.Fields.Add( tbx );
...

The following sample creates a text field with an enhanced visual appearance:
...
// Create the text box field.
PDFTextBoxField tbx = new PDFTextBoxField( "Name" );
// Set a tooltip for the text box.
tbx.Tooltip = "Enter your full name here";
// Set the field's position.
tbx.Appearance.Rectangle = new RectangleF( 50, 50, 200, 20 );
// Use Verdana font, size 10 pt, for the text in the field.
tbx.Appearance.Font = new TrueTypeFont( "verdana.ttf", 10, true );
// Use black color for text.
tbx.Appearance.ForeColor = new PDFColor( 0, 0, 0 );
// Use red color for background.
tbx.Appearance.BackColor = new PDFColor( 255, 0, 0 );
// Create a border around the field.
tbx.Appearance.Border = new PDFFieldBorder( );
// Make the border solid.
tbx.Appearance.Border.Style = FieldBorderStyle.Solid;
// Make the border thin.
tbx.Appearance.Border.Width = 1;
// Use blue for border color.
tbx.Appearance.Border.Color = new PDFColor( 0, 0, 255 );
// Make the field visible.
tbx.Appearance.VisibilityStatus = FieldVisibilityStatus.Visible;
// Align the text in the field to the left.
tbx.Align = FieldTextAlign.Left;
// Limit the text input to 32 characters.
tbx.MaxLen = 32;
// Set the field's text.
tbx.Text = "<Your name here>";
// Set the field's value.
tbx.Value = "";
// Add the text box to the page.
page.Fields.Add( tbx );
...

The Text and Value properties allow to create an interesting effect: when the field does not have focus, the Text is displayed, but when the user clicks the field, the Text disappears and the field is empty and ready for text input. This helps to create user friendly forms. For this feature to work, the Value must be an empty string. If either Text or Value are null (Nothing in VB.NET), when the form is created the one that has a value is used both for Text and for Value.

How to create a pushbutton

A pushbutton field is represented in PDF4NET library by PDFPushButtonField class.
Here it is how to create a pushbutton:
...
// Create the push button field.
PDFPushbuttonField btn = new PDFPushbuttonField( "Pushbutton" );
// Set the button's caption.
btn.NormalAppearance.Caption = "Push me";
// Set the button's position.
btn.NormalAppearance.Rectangle = new RectangleF( 50, 150, 200, 20 );
// Use red for button caption.
btn.NormalAppearance.ForeColor = new PDFColor( 255, 0, 0 );
// Use green for button background.
btn.NormalAppearance.BackColor = new PDFColor( 0, 255, 0 );
// Add the button to the page.
page.Fields.Add( btn );
...

A pushbutton can have up to 3 appearances: one for normal button state, called NormalAppearance, one for when the mouse is over the button, called RolloverAppearance, and one when the button is pressed, called DownAppearance. Normal appearance exists always, the other 2 appearances are optional.
Pushbuttons are used for executing actions inside a form. The following code fragment shows how to execute a JavaScript action when the button is pressed:
...
// Create the JavaScript action.
PDFJavaScriptAction js = new PDFJavaScriptAction( );
// Set the action's code to execute.
js.Script = "var f = this.getField(\"Name\");\r\nf.value = \"John Doe\";";
// Attach the action to the button.
btn.Actions.MouseUp = js;
...

Pushbuttons are also used to initiate the submission of form data to a server. The following code fragment shows how to create an action that will submit the form data to a server:
...
// Create the submit form action.
PDFSubmitFormAction submitFormAction = new PDFSubmitFormAction( );
// Set the Url where the form data is submitted.
submitFormAction.Url = "http://localhost/fieldsexplorer/fieldsviewer.aspx";
// Attach the action to the button.
btn.Actions.MouseUp = submitFormAction;
...

How to create a checkbox

A checkbox field is represented in PDF4NET library by PDFCheckBoxField class.
Here it is how to create a checkbox:
...
// Create the checkbox field.
PDFCheckBoxField checkBox = new PDFCheckBoxField( "CheckBox" );
// Set the checbox export value.
checkBox.Value = "1";
// Use a checkmark symbol for the checkbox.
checkBox.Style = SymbolStyle.Check;
// Set the checkbox position.
checkBox.CheckedNormalAppearance.Rectangle = new RectangleF( 50, 200, 20, 20 );
// Use black for the checkmark
checkBox.CheckedNormalAppearance.ForeColor = new PDFColor( 0, 0, 0 );
// Use white for the background.
checkBox.CheckedNormalAppearance.BackColor = new PDFColor( 255, 255, 255 );
// Add the checkbox to the page.
page.Fields.Add( checkBox );
...

A checkbox can have up to 3 appearances for each state, checked and unchecked: one for normal checkbox state, called CheckedNormalAppearance and UncheckedNormalAppearance, one when the mouse is over the button, called CheckedRolloverAppearance and UncheckedRolloverAppearance, and one when the button is pressed, called CheckedDownAppearance and UncheckedDownAppearance. Normal appearance exists always, the other 2 appearances are optional.

How to create a radiobutton list

A radiobutton list field is represented in PDF4NET library by PDFRadioButtonListField class.
A radiobutton list field consists of several exclusive radiobutton items. Here it is how to create a radiobutton list field with 2 radiobutton items:
...
// Create the radiobutton list.
PDFRadioButtonListField rbl = new PDFRadioButtonListField( "Field.4" );
// Use a circle symbol for the radio buttons.
rbl.Style = SymbolStyle.Circle;
// Create first radiobutton item.
PDFRadioButtonItem rbi = new PDFRadioButtonItem( );
// Set the item's export value.
rbi.Value = "1";
// Set the item's position.
rbi.CheckedNormalAppearance.Rectangle = new RectangleF( 50, 250, 20, 20 );
// Use white for the circle symbol.
rbi.CheckedNormalAppearance.ForeColor = new PDFColor( 255, 255, 255 );
// Use black for the background.
rbi.CheckedNormalAppearance.BackColor = new PDFColor( 0, 0, 0 );
// Add the item to the list.
rbl.Items.Add( rbi );
// Create the second item.
PDFRadioButtonItem rbi2 = new PDFRadioButtonItem( );
// Set the item's export value.
rbi2.Value = "2";
// Set the item's position.
rbi2.CheckedNormalAppearance.Rectangle = new RectangleF( 50, 300, 20, 20 );
// Use white for the circle symbol.
rbi2.CheckedNormalAppearance.ForeColor = new PDFColor( 255, 255, 255 );
// Use black for the background.
rbi2.CheckedNormalAppearance.BackColor = new PDFColor( 0, 0, 0 );
// Add the item to the list.
rbl.Items.Add( rbi2 );
// Add the radiobutton list to the page.
page.Fields.Add( rbl );
...

A radiobutton item, like a checkbox, can have up to 3 appearances for each state, checked and unchecked: one for normal checkbox state, called CheckedNormalAppearance and UncheckedNormalAppearance, one when the mouse is over the button, called CheckedRolloverAppearance and UncheckedRolloverAppearance, and one when the button is pressed, called CheckedDownAppearance and UncheckedDownAppearance. Normal appearance exists always, the other 2 appearances are optional.

How to create a drop down list

A drop down list field is represented in PDF4NET library by PDFDropDownListField class.
Here it is how to create a drop down list:
...
// Create the drop down list field.
PDFDropDownListField ddl = new PDFDropDownListField( "Dropdownlist" );
// Set its position.
ddl.Appearance.Rectangle = new RectangleF( 50, 400, 200, 20 );
// Add 3 items to the list.
PDFListItem li = new PDFListItem( "Item 1", "1" );
ddl.Items.Add( li );
PDFListItem li2 = new PDFListItem( "Item 2", "2" );
ddl.Items.Add( li2 );
PDFListItem li3 = new PDFListItem( "Item 3", "3" );
ddl.Items.Add( li3 );
// Select the second item.
ddl.SelectedIndex = 1;
// Add the drop down list to the page.
page.Fields.Add( ddl );
...

How to create a list box

A list box field is represented in PDF4NET library by PDFListBoxField class.
Here it is how to create a list box field:
...
// Create the drop down list field.
PDFListBoxField lbx = new PDFListBoxField( "ListBox" );
// Set its position.
lbx.Appearance.Rectangle = new RectangleF( 50, 400, 200, 20 );
// Add 3 items to the list.
PDFListItem li = new PDFListItem( "Item 1", "1" );
lbx.Items.Add( li );
PDFListItem li2 = new PDFListItem( "Item 2", "2" );
lbx.Items.Add( li2 );
PDFListItem li3 = new PDFListItem( "Item 3", "3" );
lbx.Items.Add( li3 );
// Select the second item.
lbx.SelectedIndex = 1;
// Add the list box to the page.
page.Fields.Add( lbx );
...

Other considerations

A field can be added only to the Fields collection of a PDFPage object. If a field is added to the Fields collection of the PDFDocument object, an exception is thrown. The line below throws an exception:
...
doc.Fields.Add( field ); // this line throws an exception.
...


PDF Forms: Reading and filling AcroForms

PDF4NET Send comments on this topic.
PDF Forms: Reading and filling AcroForms
PDF4NET On-line Help > Developer's Guide > Working with forms > PDF Forms: Reading and filling AcroForms

Glossary Item Box

PDF4NET can read and fill field values in existing PDF forms that have been created with other form design tools.
When a PDF form is loaded with PDF4NET, each field in the form is transformed into a corresponding field object. These fields are available through the Fields collections of PDFDocument object and corresponding PDFPage objects. For each field in the form, a library field object is created:
• text fields - they are available as PDFTextBoxField objects
• pushbutton fields - they are available as PDFPushButtonField objects
• checkbox fields - they are available as PDFCheckBoxField objects
• radiobutton list fields - they are available as PDFRadioButtonListField objects
• drop down list fields - they are available as PDFDropDownListField objects
• list box fields - they are available as PDFListBoxField objects
The Fields collections can be indexed either by field name or by its position. The position of a field in the Fields collection is not related to the position of the field on the page.

The sample below shows how to fill the fields from a PDF document:

...
// Load the PDF form
PDFDocument doc = new PDFDocument( "form.pdf" );
// Fill the fields
doc.Form.Fields["companyName"].Value = "O2 Solutions";
doc.Form.Fields["url"].Value = "http://www.o2sol.com/";
doc.Form.Fields["taxed"].Value = "3";
doc.Form.Fields["country"].Value = "20";
doc.Form.Fields["area"].Value = "2";
// Save the document to disk
doc.Save( "formfill.pdf" );
...

If the PDF form already contains values in its fields, these values can be read into application's variables. The following code fragment shows how to read field values into local variables:
...
// Load the PDF form
PDFDocument doc = new PDFDocument( "form.pdf" );
// Read the fields
string companyName = doc.Form.Fields["companyName"].Value;
string website = doc.Form.Fields["url"].Value;
string countryCode = doc.Form.Fields["country"].Value;
...

In the samples above the fields are used through the generic PDFField class (all field classes inherit this class). If the specialized properties of a field need to be used, the field object needs to be converted to its native type.
The following sample shows how to inspect the items in a drop down list field:

...
// Load the PDF form
PDFDocument doc = new PDFDocument( "form.pdf" );
// Get the countries drop down list
PDFDropDownListField countriesList = doc.Form.Fields["ddlCountry"] as PDFDropDownListField;
// Loop through the list items. for( int i = 0; i < countriesList.Items.Count; i++ )
{
    // Display the item content.
    Console.WriteLine( "Country id-name: {0}-{1)", countriesList.Items[i].Value, countriesList.Items[i].Name );
}
...

Field references can be retrieved both from the Fields collection of the PDFDocument object and the corresponding PDFPage objects. When the Fields collections are accessed by numeric index, a field object is always returned. If the Fields collections are accessed by field name, the collection returns null (Nothing in VB.NET) if the field does not exist in the collection.


PDF Forms: Reading and filling XFA Forms

PDF4NET Send comments on this topic.
PDF Forms: Reading and filling XFA Forms
PDF4NET On-line Help > Developer's Guide > Working with forms > PDF Forms: Reading and filling XFA Forms

Glossary Item Box

PDF4NET can read and fill field values in existing XFA forms (embedded in PDF documents) that have been created with other form design tools.
XFA forms have a hierarchical structure which is reflected in the object model available in PDF4NET. A XFA form can include several subforms and fields. Each subform can include also other subforms and fields and this leads to a tree like structure. The tree structure in the XFA form is mapped 1-to-1 to objects in PDF4NET library. The XFA form embedded in a PDF file is available through the XFAForm property of the PDFDocument object. When a XFA form is loaded with PDF4NET, the library creates an object for each support XFA form element:
• subform - XFASubform class
• area - XFAArea class
• pageSet - XFAPageSet class
• pageArea - XFAPageArea class
• field - XFAField class

Form fields are available for read/write operations through the Fields collections of XFASubform, XFAArea and XFAPageArea objects. For each field in the form, a library field object is created:
• text edit fields - they are available as XFATextEditField objects
• password edit fields - they are available as XFAPasswordEditField objects
• numeric edit fields - they are available as XFANumericEditField objects
• datetime edit fields - they are available as XFADateTimeEditField objects
• pushbutton fields - they are available as XFAButtonField objects
• checkbox fields - they are available as XFACheckButtonField objects
• radiobutton list fields - they are available as XFARadioButtonListField objects
• drop down list fields and list boxes - they are available as XFAChoiceField objects
• image fields - they are available as XFAImageEditField objects
• barcode fields - they are available as XFABarcodeField objects
The Fields collections can be indexed either by field name or by its position. The position of a field in the Fields collection is not related to the position of the field on the page.

The sample below shows how to fill the fields from a XFA form:

...
// Load the XFA form
PDFDocument doc = new PDFDocument( "xfasampleform.pdf" );
// Get the main subform.
XFASubform mainSubform = doc.XFAForm.Subforms[0].Subforms[0];
// Fill the product name.
mainSubform.Fields["txtName"].Value = "PDF4NET";
// Fill the product SKU.
mainSubform.Fields["txtSKU"].Value = "PDF4NET01090";
// Fill the product URL.
mainSubform.Fields["txtURL"].Value = "http://www.o2sol.com/pdf4net/products.htm";
// Select the product category.
mainSubform.Fields["ddlCategory"].Value = "PDF";
// Also add a new item to Category drop down list.
XFAListItem listItem = new XFAListItem( "Compression", "CMP" );
( mainSubform.Fields["ddlCategory"] as XFAChoiceListField ).Items.Add( listItem );
// Fill the product image.
mainSubform.Fields["imgProduct"].Value = "pdf4net.jpg";
( mainSubform.Fields["imgProduct"] as XFAImageEditField ).ContentType = "image/jpg";
// Fill the product short description.
mainSubform.Fields["txtShortDescription"].Value = "PDF4NET is a .NET library for adding " +
    "PDF capabilities to .NET applications. It supports both desktop and web applications.";
// Fill the product features.
mainSubform.Fields["txtFeature1"].Value = "Create PDF files from scratch.";
mainSubform.Fields["txtFeature2"].Value = "Merge, split and encrypt PDF files.";
mainSubform.Fields["txtFeature3"].Value = "Create, fill and flatten PDF e-forms.";
mainSubform.Fields["txtFeature4"].Value = "Fill XFA forms.";
mainSubform.Fields["txtFeature5"].Value = "Add, edit and remove document attachments.";
mainSubform.Fields["txtFeature6"].Value = "Add, edit and remove text annotations.";
mainSubform.Fields["txtFeature7"].Value = "Support for WinForms and ASP.NET applications.";
// Fill the product long description.
mainSubform.Fields["txtLongDescription"].Value = "PDF4NET is a .NET library for adding " +
    "PDF capabilities to .NET applications. Version 2.7 brings support for PDF e-form " +
    "creation, support for reading and filling static XFA forms and document attachments. " +
    "It supports both desktop and web applications.";
// Save the document to disk
doc.Save( "xfasampleform.fill.pdf" );
...

If the PDF form already contains values in its fields, these values can be read into application's variables. The following code fragment shows how to read field values into local variables:
...
// Load the XFA form
PDFDocument doc = new PDFDocument( "xfasampleform.pdf" );
// Get the main subform.
XFASubform mainSubform = doc.XFAForm.Subforms[0].Subforms[0];
// Read the fields
string productName = (string)mainSubform.Fields["companyName"].Value;
string sku = (string)mainSubform.Fields["url"].Value;
byte[] productImage = (byte[])mainSubform.Fields["country"].Value;
...

In the samples above the fields are used through the generic XFAField class (all XFA field classes inherit this class). If the specialized properties of a field need to be used, the field object needs to be converted to its native type.
The following sample shows how to inspect the items in a choice list field:

...
// Load the XFA form
PDFDocument doc = new PDFDocument( "xfasamplesform.pdf" );
// Get the main subform.
XFASubform mainSubform = doc.XFAForm.Subforms[0].Subforms[0];
// Get the countries drop down list
XFAChoiceListField countriesList = mainSubform.Fields["ddlCountry"] as XFAChoiceListField;
// Loop through the list items. for( int i = 0; i < countriesList.Items.Count; i++ )
{
    // Display the item content.
    Console.WriteLine( "Country id-name: {0}-{1)", countriesList.Items[i].Value, countriesList.Items[i].Name );
}
...


PDF Forms: Form data import/export

PDF4NET Send comments on this topic.
PDF Forms: Form data import/export
PDF4NET On-line Help > Developer's Guide > Working with forms > PDF Forms: Form data import/export

Glossary Item Box

Data export

Data from PDF forms can be exported to files using several formats, such as FDF, XFDF and XML.
AcroForms data can be exported using all 3 formats, while XFA form data can be exported only as XML.

The following sample shows how to export data from an AcroForm in FDF format:

...
// Load the PDF form
PDFDocument doc = new PDFDocument( "form.pdf" );
// Export the form data.
doc.Form.ExportData( "form_data.fdf", DataFormat.FDF, ExportDataOptions.FormData, "form.pdf" );
...

The reason for the last parameter is that FDF and XFDF files require a refernce back to the PDF file they were exported from. Because the PDF file can be loaded from a stream, its name might not be available when exporting the form data.

The next sample shows how to export data from a XFA form in XML format:

...
// Load the XFA form
PDFDocument doc = new PDFDocument( "xfasampleform.pdf" );
// Export the form data.
doc.Form.ExportData( "xfasampleform_data.xml", XFADataFormat.XML );
...

Data import

PDF forms can be filled automatically using data files. The data files can have several formats, such as FDF, XFDF and XML.
Data can be imported into AcroForm using all 3 formats, while XFA forms can import only XML data files.

The following sample shows how to import FDF data from into an AcroForm:

...
// Load the PDF form
PDFDocument doc = new PDFDocument( "form.pdf" );
// Import the form data. doc.Form.ImportData( "form_data.fdf", DataFormat.FDF );
...

The next sample shows how to import XML data into a XFA form:

...
// Load the XFA form
PDFDocument doc = new PDFDocument( "xfasampleform.pdf" );
// Import the form data.
doc.Form.ImportData( "xfasampleform_data.xml", XFADataFormat.XML );
...

The data files can be created by exporting form data or using 3rd party tools to create them. While FDF format is more complex and difficult to create, the XML and XFDF (also XML based) formats are easier to create by external tools.


PDF Forms: Advanced topics

PDF4NET Send comments on this topic.
PDF Forms: Advanced topics
PDF4NET On-line Help > Developer's Guide > Working with forms > PDF Forms: Advanced topics

Glossary Item Box

AcroForm advanced topics

This section applies to AcroForms only.

Fields and widgets

An AcroForm field consists of 2 parts: the logical field that stores the field value and the visual part that displays the field value on the form. The visual part of the field is called widget. Any field has always at least a widget, but there are situations when a field can have multiple widgets. A field with multiple widgets appears to the user (in the PDF viewer) as multiple fields but all with the same name. Because the logical field stores the value, all widgets will display always the same value.

When a form is loaded, the Fields collections are filled with the logical fields, and not with the field widgets. Each PDFField object corresponds to a logical field. For example, if an AcroForm contains 7 fields with the same name (they are in fact a single field with 7 widgets), when it is loaded the in PDF4NET, the Fields collection of the PDFDocument object will have only one field. The widgets are loaded into field's Widgets collection.

PDF4NET library can create fields with multiple widgets by creating field objects with the same name.
The following code creates a text box field with 2 widgets:
...
// Create the first text box field.
PDFTextBoxField tbx1 = new PDFTextBoxField( "MultiWidgetTextBox" );
// Set the field's position on page.
tbx1.Appearance.Rectangle = new RectangleF( 50, 50, 200, 20 );
// Attach the field to the page.
page.Fields.Add( tbx1 );
// Create the second text box field.
PDFTextBoxField tbx2 = new PDFTextBoxField( "MultiWidgetTextBox" );// The same field name is used.
// Set the field's position on page.
tbx2.Appearance.Rectangle = new RectangleF( 50, 100, 200, 20 );
// Attach the field to the page.
page.Fields.Add( tbx2 );
...

The code above generates a text box field with 2 widgets. Also, after the above code is executed, the Fields collection of the page object contains only one element (the MultiWidgetTextBox field), not two. A side effect of the above code is that after tbx2 object is added to the page, the library merges its information with the first field (tbx1) and tbx2 is no longer a valid field reference.

How to merge identical AcroForms but with different data.

A common requirement is to merge multiple AcroForms that are identical as structure, but each one containing different data. Because the AcroForms have identical structure, when they are merged, the fields are also merged (fields with the same name appear in each AcroForm) and the final document keeps the data only from the first form used in the merge process, and this data is propagated to all the other forms. In order to avoid this to happen, each form needs to be flattened after it has been inserted in the main document. Fields flattening is the process that transforms all fields into plain PDF content, therefore making the fields no longer editable. Fields flattening is a destructive process, the field definitions are removed from the document and they can no longer be recovered. It is important to mention that this process takes place on the in-memory copy of the form, the actual form is not affected.
The following sample shows how to merge the forms into a single document and also keep the form data intact:
...
// Create a new PDF document that will store the merged forms.
PDFDocument doc = new PDFDocument( );
// Let's assume the GetFormsToMerge method returns the list of forms.
string[] formFiles = GetFormsToMerge();
// Loop through all the forms
for( int i = 0; i < formFiles.Length; i++ ).
{
    // Open the form file.
    PDFFile file = PDFFile.FromFile(formFiles[i]);
    // Let's assume each form is one page length.
    // Extract the page containing the form.
    PDFImportedPage page = file.ExtractPage(0);
    // Insert the page in the new document.
    doc.AddPage(page);
    // Flatten the form fields.
    doc.Form.FlattenFormFields;
}
// Save the final document.
doc.Save("mergedforms.pdf");


Barcodes

PDF4NET Send comments on this topic.
Barcodes
PDF4NET On-line Help > Developer's Guide > Barcodes

Glossary Item Box

PDF4NET library provides native support for dislaying barcodes in PDF document. The library supports both 1D and 2D barcode symbologies. The library validates the data automatically and computes the check characters as needed. The size of the barcodes is computed automatically based on encoded data and XDimension and YDimension properties.

The following code fragment shows the minimum required code to display a Code39 barcode in a PDF page:
PDFDocument doc = new PDFDocument( );
PDFPage page = new PDFPage( );
// Create and draw the barcode
PDFCode39Barcode c39 = new PDFCode39Barcode( "CODE39" );
page.Canvas.DrawBarcode( c39, 20, 570 );
// Save the PDF file
doc.Save( "Code39.pdf" );

All barcode related classes are included in the following namespace: O2S.Components.PDF4NET.Graphics.Barcodes


Barcode symbologies

PDF4NET Send comments on this topic.
Barcode symbologies
PDF4NET On-line Help > Developer's Guide > Barcodes > Barcode symbologies

Glossary Item Box

PDF4NET supports both 1D and 2D barcode symbologies. 1D symbologies are also called linear or unidimensional symbologies and 2D symbologies are also called bidimensional symbologies.
The following barcode symbologies are supported by PDF4NET library:
1D Symbologies
Codabar | Codabar
 | Also known as: USD-4 | NW-7 | Code 2 of 7
 | Codabar symbology was developer by Pitney Bowes, Inc in 1972. It is a discrete and self-checking symbology that supports 16 different characters for encoding. Because it is a self-checking symbology, it does not have a checksum character. EnableCheckSum and DisplayCheckSum properties have no effect on this symbology. Codabar symbology uses start and stop characters to mark the beginning and the end of the barcode. The start/stop characters are not returned by barcode reader when the barcode is scanned. Codabar symbology is used by U.S. blood banks, photo labs, and on FedEx airbills.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9 - $ : / . +
 | Required data length: Variable.
Code 11 | Code 11
 | Also known as: USD-8
 | Code 11 is a high density numeric only symbology. The symbology is discrete and is able to encode the numbers 0 through 9, the dash symbol (-) and start/stop characters. Code 11 symbology uses start and stop characters to mark the beginning and the end of the barcode. The start/stop characters are not returned by barcode reader when the barcode is scanned. This symbology is not very secure, printing defects can convert one character into another vald character. Because of this, Code 11 supports one or two check characters, depending on data length. If data length is less than 10, only one check character is used, otherwise two check characters are used. PDF4NET automatically computes the check characters if EnableCheckSum property is true. Code 11 symbology is used primarily in labeling telecommunications equipment.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9 -
 | Required data length: Variable.
Code 128A | Code 128A
 | Code 128A is a high density alphanumeric symbology that uses codeset A of Code 128. The symbology is self-checking and also requires check digit (EnableCheckSum property is true by default and the check character is computed automatically) for greater security. Code 128A symbology is used primarily in applications where large amounts of data must be encoded in a small space.
 | Allowed characters: NUL (0x00) SOH (0x01) STX (0x02) ETX (0x03) EOT (0x04) ENQ (0x05) ACK (0x06) BEL (0x07) BS (0x08) HT (0x09) LF (0x0A) VT (0x0B) FF (0x0C) CR (0x0D) SO (0x0E) SI (0x0F) DLE (0x10) DC1 (0x11) DC2 (0x12) DC3 (0x13) DC4 (0x14) NAK (0x15) SYN (0x16) ETB (0x17) CAN (0x18) EM (0x19) SUB (0x1A) ESC (0x1B) FS (0x1C) GS (0x1D) RS (0x1E) US (0x1F) SPACE (0x20) ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _
 | Required data length: Variable.
Code 128B | Code 128B
 | Code 128B is a high density alphanumeric symbology that uses codeset B of Code 128. The symbology is self-checking and also requires check digit (EnableCheckSum property is true by default and the check character is computed automatically) for greater security. Code 128B symbology is used primarily in applications where large amounts of data must be encoded in a small space.
 | Allowed characters: SPACE (0x20) ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _ ` a b c d e f g h i j k l m n o p q r s t u v w x y z { | } ~ DEL (\x7F)
 | Required data length: Variable.
Code 128C | Code 128C
 | Code 128C is a high density numberic only symbology that uses codeset C of Code 128. The symbology is self-checking and also requires check digit (EnableCheckSum property is true by default and the check character is computed automatically) for greater security. Code 128C symbology is used primarily in applications where large amounts of numeric data must be encoded in a small space, because each pair of digits is encoded as a single barcode symbol.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
Code 2 of 5 | Code 2 of 5
 | Also known as: Standard 2 of 5 | Industrial 2 of 5
 | Code 2 of 5 is a low density numeric only symbology. It has been in use since 1960. This symbology may include an optional check character. PDF4NET automatically computes the check character if EnableCheckSum property is true. A newer version of this symbology is Code 2 of 5 Interleaved which achieves a higher density. Code 2 of 5 is used for sequentially numbering airline tickets, for photofinishing and warehouse sorting industries.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
Code 2 of 5 Interleaved | Code 2 of 5 Interleaved
 | Also known as: Interleaved 2 of 5
 | Code 2 of 5 Interleaved is a high density numeric only symbology and it is a newer version of Code 2 of 5. This symbology may include an optional check character. PDF4NET automatically computes the check character if EnableCheckSum property is true. Code 2 of 5 is used in distribution and warehouse industry.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
Code 39 | Code 39
 | Also known as: USD-3 | Code 3 of 9 | LOGMARS
 | Code 39 is the first developed barcode symbology. It is self checking and may include an optional check character. PDF4NET automatically computes the check character if EnableCheckSum property is true. Code 39 is used by the United States Department of Defense, by the Health Industry Bar Code Council (HIBCC) and also in non-retail environments.
 | Allowed characters: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
 | Required data length: Variable.
Code 39 Extended | Code 39 Extended
 | Also known as: USD-3 | Code 3 of 9 | LOGMARS
 | Code 39 Extended is based on Code 39 and supports all 128 ASCII characters.
 | Allowed characters: All 128 ASCII characters.
 | Required data length: Variable.
Code 93 | Code 93
 | Also known as: USS-93
 | Code 93 symbology was designed to improve and complement the Code 39 symbology. It supports 47 different characters to encode. Two check characters are required (EnableCheckSum property is true by default) and they are computed automatically.
 | Allowed characters: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
 | Required data length: Variable.
Code 93 Extended | Code 93 Extended
 | Also known as: USS-93
 | Code 93 Extended is based on Code 93 and supports all 128 ASCII characters.
 | Allowed characters: All 128 ASCII characters.
 | Required data length: Variable.
COOP 2 of 5 | COOP 2 of 5
 | Also known as: COOP 25
 | COOP 2 of 5 is a numeric only symbology. It is self checking and it may include an optional check character. PDF4NET automatically computes the check character if EnableCheckSum property is true. COOP 2 of 5 is used for management of physical distribution.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
EAN-13 | EAN-13
 | EAN-13 is a numeric only symbology based on UPC-A standard (it is a super set of UPC-A). It is self checking and it requires a check character. PDF4NET automatically computes the check character regardless of EnableCheckSum property and the check character is always displayed regardless of DisplayCheckSum property. EAN-13 barcodes allow a secondary barcode, called supplement, to be added to main barcode. PDF4NET supports both 2 and 5 digits supplement. EAN-13 was implemented by the International Article Numbering Association (EAN) in Europe and it uses 2 digits for the number system code.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 12 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
EAN-8 | EAN-8
 | EAN-8 is a numeric only symbology, the "short" version of EAN-13 designed for small packages. It is self checking and it requires a check character. PDF4NET automatically computes the check character regardless of EnableCheckSum property and the check character is always displayed regardless of DisplayCheckSum property. EAN-8 barcodes allow a secondary barcode, called supplement, to be added to main barcode. PDF4NET supports both 2 and 5 digits supplement.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 7 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
IATA 2 of 5 | IATA 2 of 5
 | IATA 2 of 5 is a numeric only symbology. It is self checking and a check character is always required. PDF4NET automatically computes the check character if EnableCheckSum property is true (this is default). IATA 2 of 5 is used by IATA (International Air Transport Association) for the management of air cargo.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: 16 digits.
ISBN | ISBN
 | ISBN (International Standard Book Numbering) is a EAN-13 symbology that uses the number system 978. ISBN barcodes allow a secondary barcode, called supplement, to be added to main barcode. PDF4NET supports both 2 and 5 digits supplement. This symbology is used for labeling books.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 9 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
ISMN | ISMN
 | ISMN (International Standard Music Number) is a EAN-13 symbology that uses the number system 979. ISMN barcodes allow a secondary barcode, called supplement, to be added to main barcode. PDF4NET supports both 2 and 5 digits supplement. This symbology is used for labeling music casettes and CDs.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 9 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
ISSN | ISSN
 | ISSN (International Standard Serial Number for Periodicals) is a EAN-13 symbology that uses the number system 977. ISSN barcodes allow a secondary barcode, called supplement, to be added to main barcode. PDF4NET supports both 2 and 5 digits supplement. This symbology is used for labeling periodicals and newspapers.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 9 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
JAN-13 | JAN-13
 | JAN-13 is a EAN-13 symbology that uses the number system 49. JAN-13 barcodes allow a secondary barcode, called supplement, to be added to main barcode. PDF4NET supports both 2 and 5 digits supplement. This symbology is used in Japan in retail applications.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 10 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
Matrix 2 of 5 | Matrix 2 of 5
 | Matrix 2 of 5 is a numeric only symbology. It is self checking and an optional check character may be included. PDF4NET automatically computes the check character if EnableCheckSum property is true.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
MSI/Plessey | MSI/Plessey
 | Also known as: Modified Plessey
 | MSI/Plessey is a numeric only symbology. It was developed by MSI Data Corporation, based on the original Plessey Code. It is not self checking but an optional check character may be included. PDF4NET automatically computes the check character if EnableCheckSum property is true. This symbology is used primarily to mark retail shelves for inventory control.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: Variable.
Planet | Planet
 | Planet is a height modulated numeric only symbology, it is the inverse of PostNet symbology. A check character is required and it is computed automatically regardless of EnableCheckSum property. This symbology is used in combination with PostNet by USPS to track customer's piece of mail.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: 11 or 13 digits.
Postnet | Postnet
 | Postnet is a height modulated numeric only symbology. It was created by USPS to allow faster sorting and routing of mail. A check character is required and it is computed automatically regardless of EnableCheckSum property. Postnet barcodes can encode 5 digits (ZIP code), 9 digits (ZIP+4) or 11 digits (full delivery point). This symbology is used by USPS to allow faster sorting and routing of mail.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: 5, 9 or 11 digits.
RM4SCC | RM4SCC
 | RM4SCC (Royal Mail 4-state Customer Code) is a height modulated symbology. A check character is required and it is computed automatically regardless of EnableCheckSum property. This symbology is used by UK Royal Mail to allow faster sorting and routing of mail.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
 | Required data length: Variable.
SCC-14 | SCC-14
 | SCC-14 (Shipping Container Code 14) is a numeric only symbology based on Code 128C. It is in fact a Code 128C barcode with a fixed data format. A check character is required and it is computed automatically regardless of EnableCheckSum property. SCC-14 is part of the larger UCC/EAN-128 specification with application identifier 01, and it is a shorter version of SSCC-18 symbology. Shipping Container Code is used to identify individual shipping containers. This is used, generally, to establish a number that is unique worldwide to track a specific container.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: 13 digits.
SSCC-18 | SSCC-18
 | SSCC-18 (Serial Shipping Container Code 18) is a numeric only symbology based on Code 128C. It is in fact a Code 128C barcode with a fixed data format. A check character is required and it is computed automatically regardless of EnableCheckSum property. SCC-18 is part of the larger UCC/EAN-128 specification with application identifier 00. Serial Shipping Container Code is used to identify individual shipping containers. This is used, generally, to establish a number that is unique worldwide to track a specific container.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length: 17 digits.
UPC-A | UPC-A
 | UPC-A is a numeric only symbology. It is self checking and it requires a check character. PDF4NET automatically computes the check character regardless of EnableCheckSum property and the check character is always displayed regardless of DisplayCheckSum property. UPC-A barcodes allow a secondary barcode, called supplement, to be added to main barcode. PDF4NET supports both 2 and 5 digits supplement. UPC-A is widely used in United States in retail.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 11 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
UPC-E | UPC-E
 | UPC-E is a numeric only symbology, a shorter version of UPC-A symbology. It is self checking and it requires a check character. PDF4NET automatically computes the check character regardless of EnableCheckSum property and the check character is always displayed regardless of DisplayCheckSum property. UPC-E barcodes allow a secondary barcode, called supplement, to be added to main barcode. PDF4NET supports both 2 and 5 digits supplement. UPC-E is widely used in United States in retail and it is used instead of UPC-A for products with very small packaging.
 | Allowed characters: 0 1 2 3 4 5 6 7 8 9
 | Required data length for main barcode: 7 digits.
 | Required data length for supplement barcode: 2 or 5 digits.
2D Symbologies
CODABLOCK F | CODABLOCK F
 | CODABLOCK F is is multirow symbology, a 2D version of Code 128. It was created at ICS Identcode-Systeme, being invented by Heinrich Oehlmann.
 | Allowed characters: All 256 ISO 8859-1 characters.
 | Required data length: Variable, up to 2725 characters.
Code 16K | Code 16K
 | Code 16K is is multirow symbology based on Code 128. It was created by Ted Williams in 1989.
 | Allowed characters: All 256 ISO 8859-1 characters.
 | Required data length: Variable, up to 77 ASCII characters or 154 numeric characters.
DataMatrix | DataMatrix
 | DataMatrix is a 2D matrix symbology made up of square modules arranged within a perimeter finder pattern. A limited set of symbol sizes, both square and rectangular, is available, together with a fixed level of error correction for each symbol size. PDF4NET uses ECC200 version of DataMatrix symbology.
 | Allowed characters: All 256 ISO 8859-1 characters.
 | Required data length: Variable, up to 1556 bytes or 2335 alphanumeric characters or 3116 numeric characters.
MicroPDF417 | MicroPDF417
 | MicroPDF417 is a multi-row symbology, derived from and closely based on PDF417. MicroPDF417 is designed for applications with a need for improved area efficiency but without the requirement for PDF417's maximum data capacity. A limited set of symbol sizes is available, together with a fixed level of error correction for each symbol size.
 | Allowed characters: All 256 ISO 8859-1 characters.
 | Required data length: Variable, up to 150 bytes or 250 alphanumeric characters or 366 numeric characters.
PDF417 | PDF417
 | PDF417 is a multi-row, variable-length symbology that offers high data capacity and error correction capabilities. Up to 2700 characters can be encoded depending on the selected data compaction mode. PDF4NET supports all 3 data compaction modes: Text, Byte and Numeric.
 | Allowed characters: All 256 ISO 8859-1 characters.
 | Required data length: Variable, up to 1108 bytes or 1850 alphanumeric characters or 2710 numeric characters.


Samples
PDF4NET On-line Help > Samples

Glossary Item Box

The following samples are available. They cover all the features of the PDF4NET library.

Samples

3D

Actions

Annotations

ArcsPies

Attachments

Autonumbering

Barcodes

Bezier

Bookmarks

CharacterMap

ColorSpaces

Digital Signature

DocAndViewer

Edit PDF

Ellipses

Encryption

ExtractImages

Forms

Form XObjects

GroupingGrid

HelloWorld

Images

Layers

Lines

Links

Metafiles

MulticolumnTextAndImages

PageOrientations

PageSizes

Pantone colors

Paths

Polygons

Rectangles

SimpleGrid

Sin(x) Graph

SlideShow

Stamp PDF

TextBoxes - with TrueType font support

Samples: TextExtract

TextLines

Tiff2PDF

Unicode

Update PDF

Watermarks


Samples: 3D

PDF4NET Send comments on this topic.
Samples: 3D
PDF4NET On-line Help > Samples > Samples: 3D

Glossary Item Box

This sample shows how to embed 3D artwork (U3D data) in PDF files. It shows how to work with 3D annotations, projections, render modes and lighting schemes.

C# Source code | VB.NET Source code | PDF file


3D.cs

PDF4NET Send comments on this topic.
3D.cs
PDF4NET On-line Help > Samples > 3D > 3D.cs

Glossary Item Box

using System;
using System.IO;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Annotations;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;

namespace O2S.Samples.PDF4NET
{
    /// <summary>
    /// This sample shows how to embed 3D artwork in PDF files.
    /// </summary>
    class _3DArtwork
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument doc = new PDFDocument();

            // Create a blank page
            PDFPage page = doc.AddPage();

            // Create the annotation that will display the 3D artwork.
            PDF3DAnnotation annot3d = new PDF3DAnnotation();
            annot3d.Rectangle = new RectangleF(50, 50, 400, 400);
            annot3d.Stream = Create3DStream();
            annot3d.Appearance = new PDFFormXObject();
            annot3d.Appearance.Canvas.DrawText("Click to activate", new PDFFont(),
                null, new PDFBrush(new PDFColor()), 200, 200, 0, TextAlign.MiddleCenter);

            // Create the default view.
            PDF3DProjection projection1 = new PDF3DProjection(PDF3DProjectionType.Perspective);
            projection1.FieldOfView = 30;
            PDF3DLightingScheme lightScheme1 = null;//new PDF3DLightingScheme(PDF3DLightingStyle.Artwork);
            PDF3DRenderMode renderMode1 = new PDF3DRenderMode(PDF3DRenderStyle.Solid);
            PDF3DBackground background1 = new PDF3DBackground(new PDFColor(255, 255, 255));
            PDF3DView defaultView = CreateView("Default view",
                new float[]{-0.382684f, 0.92388f, -0.0000000766026f, 0.18024f, 0.0746579f, 0.980785f, 0.906127f, 0.37533f, -0.19509f, -122.669f, -112.432f, 45.6829f},
                131.695f, background1, projection1, renderMode1, lightScheme1);

            // Create a wireframe view.
            PDF3DRenderMode renderMode2 = new PDF3DRenderMode(PDF3DRenderStyle.Wireframe);
            PDF3DView wireframeView = CreateView("Wireframe view",
                new float[]{-0.382684f, 0.92388f, -0.0000000766026f, 0.18024f, 0.0746579f, 0.980785f, 0.906127f, 0.37533f, -0.19509f, -122.669f, -112.432f, 45.6829f},
                131.695f, background1, projection1, renderMode2, lightScheme1);

            // Create a wireframe view.
            PDF3DRenderMode renderMode3 = new PDF3DRenderMode(PDF3DRenderStyle.TransparentWireframe);
            renderMode3.AuxiliaryColor = new PDFColor(0, 192, 0);
            PDF3DView transparentWireframeView = CreateView("Transparent wireframe view",
                new float[]{-0.382684f, 0.92388f, -0.0000000766026f, 0.18024f, 0.0746579f, 0.980785f, 0.906127f, 0.37533f, -0.19509f, -122.669f, -112.432f, 45.6829f},
                131.695f, background1, projection1, renderMode3, lightScheme1);

            annot3d.Stream.Views.Add(defaultView);
            annot3d.Stream.Views.Add(wireframeView);
            annot3d.Stream.Views.Add(transparentWireframeView);
            annot3d.Stream.DefaultView = 0;

            // Add the annotation to the page.
            page.Annotations.Add(annot3d);

            doc.Save("3d.pdf");
        }

        /// <summary>
        /// Creates the 3D stream.
        /// </summary>
        private static PDF3DStream Create3DStream()
        {
            // Read the U3D file.
            FileStream fs = new FileStream("box.u3d", FileMode.Open, FileAccess.Read);
            byte[] u3data = new byte[fs.Length];
            fs.Read(u3data, 0, u3data.Length);
            fs.Close();

            PDF3DStream stream = new PDF3DStream();
            stream.Content = u3data;

            return stream;
        }

        /// <summary>
        /// Creates a view for the 3D artwork.
        /// </summary>
        private static PDF3DView CreateView(string viewName, float[] camera2world, float centerOfOrbit,
            PDF3DBackground background, PDF3DProjection projection, PDF3DRenderMode renderMode, PDF3DLightingScheme lightingScheme)
        {
            PDF3DView view = new PDF3DView();
            view.ExternalName = viewName;
            view.InternalName = Guid.NewGuid().ToString("N");
            view.CameraToWorldMatrix = camera2world;
            view.CenterOfOrbit = centerOfOrbit;
            view.Background = background;
            view.Projection = projection;
            view.RenderMode = renderMode;
            view.LightingScheme = lightingScheme;
            view.ResetNodesState = true;

            return view;
        }
    }
}


3D.vb

PDF4NET Send comments on this topic.
3D.vb
PDF4NET On-line Help > Samples > 3D > 3D.vb

Glossary Item Box

Imports System
Imports System.IO
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Annotations
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Fonts
Imports O2S.Components.PDF4NET.Graphics.Shapes

Namespace O2S.Samples.PDF4NET
    ''' <summary>
    ''' This sample shows how to embed 3D artwork in PDF files.
    ''' </summary>
    Class _3DArtwork
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim doc As New PDFDocument()

            ' Create a blank page
            Dim page As PDFPage = doc.AddPage()

            ' Create the annotation that will display the 3D artwork.
            Dim annot3d As New PDF3DAnnotation()
            annot3d.Rectangle = New RectangleF(50, 50, 400, 400)
            annot3d.Stream = Create3DStream()
            annot3d.Appearance = New PDFAnnotationAppearance()
            annot3d.Appearance.Canvas.DrawText("Click to activate", New PDFFont(), Nothing, New PDFBrush(New PDFRgbColor()), 200, 200, _
                0, PDFTextAlign.MiddleCenter)

            ' Create the default view.
            Dim projection1 As New PDF3DProjection(PDF3DProjectionType.Perspective)
            projection1.FieldOfView = 30
            Dim lightScheme1 As PDF3DLightingScheme = Nothing
            'new PDF3DLightingScheme(PDF3DLightingStyle.Artwork);
            Dim renderMode1 As New PDF3DRenderMode(PDF3DRenderStyle.Solid)
            Dim background1 As New PDF3DBackground(New PDFRgbColor(255, 255, 255))
            Dim defaultView As PDF3DView = CreateView("Default view", New Double() {-0.382684F, 0.92388F, -7.66026E-08F, 0.18024F, 0.0746579F, 0.980785F, _
                0.906127F, 0.37533F, -0.19509F, -122.669F, -112.432F, 45.6829F}, 131.695F, background1, projection1, renderMode1, _
                lightScheme1)

            ' Create a wireframe view.
            Dim renderMode2 As New PDF3DRenderMode(PDF3DRenderStyle.Wireframe)
            Dim wireframeView As PDF3DView = CreateView("Wireframe view", New Double() {-0.382684F, 0.92388F, -7.66026E-08F, 0.18024F, 0.0746579F, 0.980785F, _
                0.906127F, 0.37533F, -0.19509F, -122.669F, -112.432F, 45.6829F}, 131.695F, background1, projection1, renderMode2, _
                lightScheme1)

            ' Create a wireframe view.
            Dim renderMode3 As New PDF3DRenderMode(PDF3DRenderStyle.TransparentWireframe)
            renderMode3.AuxiliaryColor = New PDFRgbColor(0, 192, 0)
            Dim transparentWireframeView As PDF3DView = CreateView("Transparent wireframe view", New Double() {-0.382684F, 0.92388F, -7.66026E-08F, 0.18024F, 0.0746579F, 0.980785F, _
                0.906127F, 0.37533F, -0.19509F, -122.669F, -112.432F, 45.6829F}, 131.695F, background1, projection1, renderMode3, _
                lightScheme1)

            annot3d.Stream.Views.Add(defaultView)
            annot3d.Stream.Views.Add(wireframeView)
            annot3d.Stream.Views.Add(transparentWireframeView)
            annot3d.Stream.DefaultView = 0

            ' Add the annotation to the page.
            page.Annotations.Add(annot3d)

            doc.Save("Sample_3D.pdf")
        End Sub

        ''' <summary>
        ''' Creates the 3D stream.
        ''' </summary>
        Private Shared Function Create3DStream() As PDF3DStream
            ' Read the U3D file.
            Dim fs As New FileStream("..\SupportFiles\box.u3d", FileMode.Open, FileAccess.Read)
            Dim u3data As Byte() = New Byte(fs.Length) {}
            fs.Read(u3data, 0, u3data.Length)
            fs.Close()

            Dim stream As New PDF3DStream()
            stream.Content = u3data

            Return stream
        End Function

        ''' <summary>
        ''' Creates a view for the 3D artwork.
        ''' </summary>
        Private Shared Function CreateView(viewName As String, camera2world As Double(), centerOfOrbit As Single, background As PDF3DBackground, projection As PDF3DProjection, renderMode As PDF3DRenderMode, _
            lightingScheme As PDF3DLightingScheme) As PDF3DView
            Dim view As New PDF3DView()
            view.ExternalName = viewName
            view.InternalName = Guid.NewGuid().ToString("N")
            view.CameraToWorldMatrix = camera2world
            view.CenterOfOrbit = centerOfOrbit
            view.Background = background
            view.Projection = projection
            view.RenderMode = renderMode
            view.LightingScheme = lightingScheme
            view.ResetNodesState = True

            Return view
        End Function
    End Class
End Namespace


Samples: Actions

PDF4NET Send comments on this topic.
Samples: Actions
PDF4NET On-line Help > Samples > Samples: Actions

Glossary Item Box

This sample demonstrates the support for PDF actions implemented in PDF4NET library.

C# Source code | VB.NET Source code | PDF file


Actions.cs

PDF4NET Send comments on this topic.
Actions.cs
PDF4NET On-line Help > Samples > Actions > Actions.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Actions;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.Actions
{
    /// <summary>
    /// This sample shows how to use the PDF actions.
    /// </summary>
    class Actions
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument doc = new PDFDocument();

            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());

            // Create 3 pages
            PDFPage page = doc.AddPage();
            page.Canvas.DrawText("Page 1", fontText, null, blackBrush, 20, 30);
            page = doc.AddPage();
            page.Canvas.DrawText("Page 2", fontText, null, blackBrush, 20, 30);
            page = doc.AddPage();
            page.Canvas.DrawText("Page 3", fontText, null, blackBrush, 20, 30);

            /// URI Action
            // create a web action
            PDFURIAction uriAction = new PDFURIAction();
            uriAction.URI = "http://www.o2sol.com/";

            // create a bookmark to point to the url above
            PDFBookmark url = new PDFBookmark();
            url.Title = "www.o2sol.com";
            url.Color = new PDFRgbColor();
            url.Action = uriAction;
            // add the bookmark to the document
            doc.Bookmarks.Add(url);
            /// URI Action

            /// Javascript Action
            // create a javascript action to print the document
            PDFJavaScriptAction jsAction = new PDFJavaScriptAction();
            jsAction.Script = "this.print(true);\n";

            // create a bookmark to point to execute the action
            PDFBookmark js = new PDFBookmark();
            js.Title = "Print me from JavaScript";
            js.Color = new PDFRgbColor();
            js.Action = jsAction;
            // add the bookmark to the document
            doc.Bookmarks.Add(js);
            /// Javascript Action

            /// OpenDocument action
            // Create an action to be executed when the document is opened
            // The action will open the document at the
            // second page of the document using a 800% zoom
            PDFPageDestination pageDestination = new PDFPageDestination();
            pageDestination.Page = doc.Pages[1];
            pageDestination.MagnificationMode = PDFMagnificationMode.XYZ;
            pageDestination.Left = 0;
            pageDestination.Top = 0;
            pageDestination.Zoom = 800;
            PDFGoToAction goToAction = new PDFGoToAction();
            goToAction.Destination = pageDestination;

            // set the action on the document
            doc.OpenAction = goToAction;
            /// OpenDocument action

            // Save the document to disk
            doc.Save("Sample_Actions.pdf");
        }
    }
}


Actions.vb

PDF4NET Send comments on this topic.
Actions.vb
PDF4NET On-line Help > Samples > Actions > Actions.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Actions
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.Actions
    ''' <summary>
    ''' This sample shows how to use the PDF actions.
    ''' </summary>
    Class Actions
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim doc As New PDFDocument()

            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())

            ' Create 3 pages
            Dim page As PDFPage = doc.AddPage()
            page.Canvas.DrawText("Page 1", fontText, Nothing, blackBrush, 20, 30)
            page = doc.AddPage()
            page.Canvas.DrawText("Page 2", fontText, Nothing, blackBrush, 20, 30)
            page = doc.AddPage()
            page.Canvas.DrawText("Page 3", fontText, Nothing, blackBrush, 20, 30)

            ' create a web action
            Dim uriAction As New PDFURIAction()
            uriAction.URI = "http://www.o2sol.com/"

            ' create a bookmark to point to the url above
            Dim url As New PDFBookmark()
            url.Title = "www.o2sol.com"
            url.Color = New PDFRgbColor()
            url.Action = uriAction
            ' add the bookmark to the document
            doc.Bookmarks.Add(url)

            ' create a javascript action to print the document
            Dim jsAction As New PDFJavaScriptAction()
            jsAction.Script = "this.print(true);" & vbLf

            ' create a bookmark to point to execute the action
            Dim js As New PDFBookmark()
            js.Title = "Print me from JavaScript"
            js.Color = New PDFRgbColor()
            js.Action = jsAction
            ' add the bookmark to the document
            doc.Bookmarks.Add(js)

            ' Create an action to be executed when the document is opened
            ' The action will open the document at the
            ' second page of the document using a 800% zoom
            Dim pageDestination As New PDFPageDestination()
            pageDestination.Page = doc.Pages(1)
            pageDestination.MagnificationMode = PDFMagnificationMode.XYZ
            pageDestination.Left = 0
            pageDestination.Top = 0
            pageDestination.Zoom = 800
            Dim goToAction As New PDFGoToAction()
            goToAction.Destination = pageDestination

            ' set the action on the document
            doc.OpenAction = goToAction

            ' Save the document to disk
            doc.Save("Sample_Actions.pdf")
        End Sub
    End Class
End Namespace


Samples: Annotations

PDF4NET Send comments on this topic.
Samples: Annotations
PDF4NET On-line Help > Samples > Samples: Annotations

Glossary Item Box

This sample demonstrates the support for PDF annotations implemented in PDF4NET library.

C# Source code | VB.NET Source code | PDF file


Annotations.cs

PDF4NET Send comments on this topic.
Annotations.cs
PDF4NET On-line Help > Samples > Annotations > Annotations.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Annotations;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Fonts;
using O2S.Components.PDF4NET.Graphics.Shapes;

namespace O2S.Samples.PDF4NET.Annotations
{
    /// <summary>
    /// This sample shows all annotations that can be created with PDF4NET.
    /// </summary>
    class Annotations
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument doc = new PDFDocument();

            // Create one page
            PDFPage page = doc.AddPage();

            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor(0, 0, 0));
            PDFFont fontSection = new PDFFont(PDFFontFace.Helvetica, 10);
            fontSection.Bold = true;
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 8);

            page.Canvas.DrawText("Text annotations", fontSection, null, blackBrush, 20, 45, 0, PDFTextAlign.BottomLeft);
            // Create all available text annotations
            PDFTextAnnotation ta = new PDFTextAnnotation("Comment", "Comment annotation");
            ta.Icon = PDFTextAnnotationIcon.Comment;
            ta.Rectangle = new RectangleF(20, 60, 20, 20);
            page.Annotations.Add(ta);
            page.Canvas.DrawText("Comment", fontText, null, blackBrush, 20, 80, 0, PDFTextAlign.TopLeft);

            ta = new PDFTextAnnotation("Help", "Help annotation");
            ta.Icon = PDFTextAnnotationIcon.Help;
            ta.Rectangle = new RectangleF(100, 60, 20, 20);
            page.Annotations.Add(ta);
            page.Canvas.DrawText("Help", fontText, null, blackBrush, 100, 80, 0, PDFTextAlign.TopLeft);

            ta = new PDFTextAnnotation("Insert", "Insert annotation");
            ta.Icon = PDFTextAnnotationIcon.Insert;
            ta.Rectangle = new RectangleF(180, 60, 20, 20);
            page.Annotations.Add(ta);
            page.Canvas.DrawText("Insert", fontText, null, blackBrush, 180, 80, 0, PDFTextAlign.TopLeft);

            ta = new PDFTextAnnotation("Key", "Key annotation");
            ta.Icon = PDFTextAnnotationIcon.Key;
            ta.Rectangle = new RectangleF(260, 60, 20, 20);
            page.Annotations.Add(ta);
            page.Canvas.DrawText("Key", fontText, null, blackBrush, 260, 80, 0, PDFTextAlign.TopLeft);

            ta = new PDFTextAnnotation("New paragraph", "New paragraph annotation");
            ta.Icon = PDFTextAnnotationIcon.NewParagraph;
            ta.Rectangle = new RectangleF(340, 60, 20, 20);
            page.Annotations.Add(ta);
            page.Canvas.DrawText("New paragraph", fontText, null, blackBrush, 340, 80, 0, PDFTextAlign.TopLeft);

            ta = new PDFTextAnnotation("Note", "Note annotation");
            ta.Icon = PDFTextAnnotationIcon.Note;
            ta.Rectangle = new RectangleF(420, 60, 20, 20);
            page.Annotations.Add(ta);
            page.Canvas.DrawText("Note", fontText, null, blackBrush, 420, 80, 0, PDFTextAlign.TopLeft);

            ta = new PDFTextAnnotation("Paragraph", "Paragraph annotation");
            ta.Icon = PDFTextAnnotationIcon.Paragraph;
            ta.Rectangle = new RectangleF(500, 60, 20, 20);
            page.Annotations.Add(ta);
            page.Canvas.DrawText("Paragraph", fontText, null, blackBrush, 500, 80, 0, PDFTextAlign.TopLeft);

            // Rubber stamp annotations

            page.Canvas.DrawText("Rubber stamp annotations", fontSection, null, blackBrush, 20, 120, 0, PDFTextAlign.TopLeft);
            // Create all available rubber stamp annotations
            PDFRubberStampAnnotation rsa = new PDFRubberStampAnnotation("Approved", "Approved annotation");
            rsa.Icon = PDFRubberStampAnnotationIcon.Approved;
            rsa.Rectangle = new RectangleF(20, 140, 100, 30);
            rsa.Opacity = 50;
            page.Annotations.Add(rsa);
            page.Canvas.DrawText("Approved", fontText, null, blackBrush, 20, 180, 0, PDFTextAlign.TopLeft);

            rsa = new PDFRubberStampAnnotation("As Is", "As Is annotation");
            rsa.Icon = PDFRubberStampAnnotationIcon.AsIs;
            rsa.Rectangle = new RectangleF(120, 140, 100, 30);
            page.Annotations.Add(rsa);
            page.Canvas.DrawText("As Is", fontText, null, blackBrush, 120, 180, 0, PDFTextAlign.TopLeft);

            rsa = new PDFRubberStampAnnotation("Confidential", "Confidential annotation");
            rsa.Icon = PDFRubberStampAnnotationIcon.Confidential;
            rsa.Rectangle = new RectangleF(220, 140, 100, 30);
            page.Annotations.Add(rsa);
            page.Canvas.DrawText("Confidential", fontText, null, blackBrush, 220, 180, 0, PDFTextAlign.TopLeft);

            rsa = new PDFRubberStampAnnotation("Departmental", "Departmental annotation");
            rsa.Icon = PDFRubberStampAnnotationIcon.Departmental;
            rsa.Rectangle = new RectangleF(320, 140, 100, 30);
            page.Annotations.Add(rsa);
            page.Canvas.DrawText("Departmental", fontText, null, blackBrush, 320, 180, 0, PDFTextAlign.TopLeft);

            rsa = new PDFRubberStampAnnotation("Draft", "Draft annotation");
            rsa.Icon = PDFRubberStampAnnotationIcon.Draft;
            rsa.Rectangle = new RectangleF(420, 140, 100, 30);
            page.Annotations.Add(rsa);
            page.Canvas.DrawText("Draft", fontText, null, blackBrush, 420, 180, 0, PDFTextAlign.TopLeft);

            rsa = new PDFRubberStampAnnotation("Experimental", "Experimental annotation");
            rsa.Icon = PDFRubberStampAnnotationIcon.Experimental;
            rsa.Rectangle = new RectangleF(520, 140, 100, 30);
            page.Annotations.Add(rsa);
            page.Canvas.DrawText("Experimental", fontText, null, blackBrush, 520, 180, 0, PDFTextAlign.TopLeft);

            rsa = new PDFRubberStampAnnotation("Expired", "Expired annotation");
            rsa.Icon = PDFRubberStampAnnotationIcon.Expired;
            rsa.Rectangle = new RectangleF(20, 200, 100, 30);
            page.Annotations.Add(rsa);
            page.Canvas.DrawText("Expired", fontText, null, blackBrush, 20, 240, 0, PDFTextAlign.TopLeft);

            rsa = new PDFRubberStampAnnotation("Final", "Final annotation");
            rsa.Icon = PDFRubberStampAnnotationIcon.Final;
            rsa.Rectangle = new RectangleF(120, 200, 100, 30);
            page.Annotations.Add(rsa);
            page.Canvas.DrawText("Final", fontText, null, blackBrush, 120, 240, 0, PDFTextAlign.TopLeft);

            rsa = new PDFRubberStampAnnotation("ForComment", "ForComment annotation");
            rsa.Icon = PDFRubberStampAnnotationIcon.ForComment;
            rsa.Rectangle = new RectangleF(220, 200, 100, 30);
            page.Annotations.Add(rsa);
            page.Canvas.DrawText("ForComment", fontText, null, blackBrush, 220, 240, 0, PDFTextAlign.TopLeft);

            rsa = new PDFRubberStampAnnotation("ForPublicRelease", "ForPublicRelease annotation");
            rsa.Icon = PDFRubberStampAnnotationIcon.ForPublicRelease;
            rsa.Rectangle = new RectangleF(320, 200, 100, 30);
            page.Annotations.Add(rsa);
            page.Canvas.DrawText("ForPublicRelease", fontText, null, blackBrush, 320, 240, 0, PDFTextAlign.TopLeft);

            rsa = new PDFRubberStampAnnotation("NotApproved", "NotApproved annotation");
            rsa.Icon = PDFRubberStampAnnotationIcon.NotApproved;
            rsa.Rectangle = new RectangleF(420, 200, 100, 30);
            page.Annotations.Add(rsa);
            page.Canvas.DrawText("NotApproved", fontText, null, blackBrush, 420, 240, 0, PDFTextAlign.TopLeft);

            rsa = new PDFRubberStampAnnotation("NotForPublicRelease", "NotForPublicRelease annotation");
            rsa.Icon = PDFRubberStampAnnotationIcon.NotForPublicRelease;
            rsa.Rectangle = new RectangleF(520, 200, 100, 30);
            page.Annotations.Add(rsa);
            page.Canvas.DrawText("NotForPublicRelease", fontText, null, blackBrush, 520, 240, 0, PDFTextAlign.TopLeft);

            rsa = new PDFRubberStampAnnotation("Sold", "Sold annotation");
            rsa.Icon = PDFRubberStampAnnotationIcon.Sold;
            rsa.Rectangle = new RectangleF(20, 260, 100, 30);
            page.Annotations.Add(rsa);
            page.Canvas.DrawText("Sold", fontText, null, blackBrush, 20, 300, 0, PDFTextAlign.TopLeft);

            rsa = new PDFRubberStampAnnotation("TopSecret", "TopSecret annotation");
            rsa.Icon = PDFRubberStampAnnotationIcon.TopSecret;
            rsa.Rectangle = new RectangleF(120, 260, 100, 30);
            page.Annotations.Add(rsa);
            page.Canvas.DrawText("TopSecret", fontText, null, blackBrush, 120, 300, 0, PDFTextAlign.TopLeft);

            // Line annotations

            page.Canvas.DrawText("Line annotations", fontSection, null, blackBrush, 20, 350, 0, PDFTextAlign.TopLeft);
            PDFLineAnnotation la = new PDFLineAnnotation("Line", "Line annotation");
            la.BeginLineStyle = PDFLineEndingStyle.Circle;
            la.EndLineStyle = PDFLineEndingStyle.OpenArrow;
            la.LineDirection = PDFLineDirection.TopLeftToBottomRight;
            la.Rectangle = new RectangleF(20, 370, 150, 30);
            la.Border = new PDFAnnotationBorder(1, PDFBorderStyle.Solid);
            la.Color = new PDFRgbColor(Color.Red);
            la.InteriorColor = new PDFRgbColor(Color.CornflowerBlue);
            page.Annotations.Add(la);
            page.Canvas.DrawText("Line annotation with a circle and open arrow", fontText, null, blackBrush,
                20, 420, 0, PDFTextAlign.TopLeft);

            // File attachment annotations

            page.Canvas.DrawText("File attachment annotations", fontSection, null, blackBrush, 20, 450, 0, PDFTextAlign.TopLeft);
            // Create all available file attachment annotations
            PDFFileAttachmentAnnotation faa = new PDFFileAttachmentAnnotation("Graph", "Graph icon");
            faa.Icon = PDFFileAttachmentAnnotationIcon.Graph;
            faa.Rectangle = new RectangleF(20, 470, 20, 20);
            faa.FileName = "sample.pdf";
            page.Annotations.Add(faa);
            page.Canvas.DrawText("Graph", fontText, null, blackBrush, 20, 500, 0, PDFTextAlign.TopLeft);

            faa = new PDFFileAttachmentAnnotation("Paperclip", "Paperclip icon");
            faa.Icon = PDFFileAttachmentAnnotationIcon.Paperclip;
            faa.Rectangle = new RectangleF(100, 470, 20, 20);
            faa.FileName = "sample.pdf";
            page.Annotations.Add(faa);
            page.Canvas.DrawText("Paperclip", fontText, null, blackBrush, 100, 500, 0, PDFTextAlign.TopLeft);

            faa = new PDFFileAttachmentAnnotation("PushPin", "PushPin icon");
            faa.Icon = PDFFileAttachmentAnnotationIcon.PushPin;
            faa.Rectangle = new RectangleF(180, 470, 20, 20);
            faa.FileName = "sample.pdf";
            page.Annotations.Add(faa);
            page.Canvas.DrawText("PushPin", fontText, null, blackBrush, 180, 500, 0, PDFTextAlign.TopLeft);

            faa = new PDFFileAttachmentAnnotation("Tag", "Tag icon");
            faa.Icon = PDFFileAttachmentAnnotationIcon.Tag;
            faa.Rectangle = new RectangleF(260, 470, 20, 20);
            faa.FileName = "sample.pdf";
            page.Annotations.Add(faa);
            page.Canvas.DrawText("Graph", fontText, null, blackBrush, 260, 500, 0, PDFTextAlign.TopLeft);

            // Highlight annotation

            page.Canvas.DrawText("Markup annotation - this text will be highlighted",
                fontSection, null, blackBrush, 20, 610);
            PDFHighlightAnnotation ha =
                new PDFHighlightAnnotation("Markup annotation", "Markup annotation with highlight style");
            ha.Rectangle = new RectangleF(100, 610, 100, 10);
            ha.Color = new PDFRgbColor(255, 255, 0);
            page.Annotations.Add(ha);

            // Square and circle annotations

            page.Canvas.DrawText("Square and circle annotations", fontSection, null, blackBrush, 20, 650);
            PDFEllipseAnnotation ea =
                new PDFEllipseAnnotation("Ellipse annotation", "An ellipse annotation");
            ea.Rectangle = new RectangleF(20, 670, 150, 75);
            ea.Color = new PDFRgbColor(255, 255, 0);
            ea.InteriorColor = new PDFRgbColor(0, 255, 0);
            page.Annotations.Add(ea);

            PDFRectangleAnnotation ra =
                new PDFRectangleAnnotation("Rectangle annotation", "A rectangle annotation");
            ra.Rectangle = new RectangleF(200, 670, 150, 75);
            ra.Color = new PDFRgbColor(255, 64, 0);
            ra.InteriorColor = new PDFRgbColor(64, 0, 255);
            page.Annotations.Add(ra);

            // Create 2nd page
            page = doc.AddPage();

            page.Canvas.DrawText("Annotations with custom appearance", fontSection, null, blackBrush, 20, 45, 0, PDFTextAlign.BottomLeft);

            page.Canvas.DrawText("a. Annotations with image appearance", fontSection, null, blackBrush, 20, 60, 0, PDFTextAlign.BottomLeft);
            PDFRubberStampAnnotation isa = new PDFRubberStampAnnotation("ImageAppearance", "Annotation with image appearance.");
            Bitmap img = new Bitmap("..\\SupportFiles\\auto1.jpg");
            isa.Appearance = new PDFImageAppearance(img);
            img.Dispose();
            isa.Rectangle = new RectangleF(20, 70, 200, 100);
            page.Annotations.Add(isa);
            page.Canvas.DrawText("Image appearance", fontText, null, blackBrush, 20, 175, 0, PDFTextAlign.TopLeft);

            page.Canvas.DrawText("b. Annotations with owner draw appearance", fontSection, null, blackBrush, 20, 200, 0, PDFTextAlign.TopLeft);
            PDFRubberStampAnnotation odsa = new PDFRubberStampAnnotation("OwnerDrawAppearance", "Annotation with owner draw appearance.");
            odsa.Rectangle = new RectangleF(20, 220, 200, 100);
            odsa.Appearance = new PDFAnnotationAppearance();
            odsa.Appearance.Width = odsa.Rectangle.Width;
            odsa.Appearance.Height = odsa.Rectangle.Height;
            PDFBrush redBrush = new PDFBrush(new PDFRgbColor(192, 0, 0));
            odsa.Appearance.Canvas.DrawRoundRectangle(redBrush, 0, 0, odsa.Rectangle.Width, odsa.Rectangle.Height, 40, 40);
            PDFBrush blueBrush = new PDFBrush(new PDFRgbColor(0, 0, 128));
            odsa.Appearance.Canvas.DrawEllipse(blueBrush, (odsa.Rectangle.Width - odsa.Rectangle.Height) / 2, 0, odsa.Rectangle.Height, odsa.Rectangle.Height);
            page.Annotations.Add(odsa);
            page.Canvas.DrawText("Owner draw appearance", fontText, null, blackBrush, 20, 325, 0, PDFTextAlign.TopLeft);

            // Save the document to disk
            doc.Save("Sample_Annotations.pdf");
        }
    }
}


Annotations.vb

PDF4NET Send comments on this topic.
Annotations.vb
PDF4NET On-line Help > Samples > Annotations > Annotations.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Annotations
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Fonts
Imports O2S.Components.PDF4NET.Graphics.Shapes

Namespace O2S.Samples.PDF4NET.Annotations
    ''' <summary>
    ''' This sample shows all annotations that can be created with PDF4NET.
    ''' </summary>
    Class Annotations
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim doc As New PDFDocument()

            ' Create one page
            Dim page As PDFPage = doc.AddPage()

            Dim blackBrush As New PDFBrush(New PDFRgbColor(0, 0, 0))
            Dim fontSection As New PDFFont(PDFFontFace.Helvetica, 10)
            fontSection.Bold = True
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 8)

            page.Canvas.DrawText("Text annotations", fontSection, Nothing, blackBrush, 20, 45, _
                0, PDFTextAlign.BottomLeft)
            ' Create all available text annotations
            Dim ta As New PDFTextAnnotation("Comment", "Comment annotation")
            ta.Icon = PDFTextAnnotationIcon.Comment
            ta.Rectangle = New RectangleF(20, 60, 20, 20)
            page.Annotations.Add(ta)
            page.Canvas.DrawText("Comment", fontText, Nothing, blackBrush, 20, 80, _
                0, PDFTextAlign.TopLeft)

            ta = New PDFTextAnnotation("Help", "Help annotation")
            ta.Icon = PDFTextAnnotationIcon.Help
            ta.Rectangle = New RectangleF(100, 60, 20, 20)
            page.Annotations.Add(ta)
            page.Canvas.DrawText("Help", fontText, Nothing, blackBrush, 100, 80, _
                0, PDFTextAlign.TopLeft)

            ta = New PDFTextAnnotation("Insert", "Insert annotation")
            ta.Icon = PDFTextAnnotationIcon.Insert
            ta.Rectangle = New RectangleF(180, 60, 20, 20)
            page.Annotations.Add(ta)
            page.Canvas.DrawText("Insert", fontText, Nothing, blackBrush, 180, 80, _
                0, PDFTextAlign.TopLeft)

            ta = New PDFTextAnnotation("Key", "Key annotation")
            ta.Icon = PDFTextAnnotationIcon.Key
            ta.Rectangle = New RectangleF(260, 60, 20, 20)
            page.Annotations.Add(ta)
            page.Canvas.DrawText("Key", fontText, Nothing, blackBrush, 260, 80, _
                0, PDFTextAlign.TopLeft)

            ta = New PDFTextAnnotation("New paragraph", "New paragraph annotation")
            ta.Icon = PDFTextAnnotationIcon.NewParagraph
            ta.Rectangle = New RectangleF(340, 60, 20, 20)
            page.Annotations.Add(ta)
            page.Canvas.DrawText("New paragraph", fontText, Nothing, blackBrush, 340, 80, _
                0, PDFTextAlign.TopLeft)

            ta = New PDFTextAnnotation("Note", "Note annotation")
            ta.Icon = PDFTextAnnotationIcon.Note
            ta.Rectangle = New RectangleF(420, 60, 20, 20)
            page.Annotations.Add(ta)
            page.Canvas.DrawText("Note", fontText, Nothing, blackBrush, 420, 80, _
                0, PDFTextAlign.TopLeft)

            ta = New PDFTextAnnotation("Paragraph", "Paragraph annotation")
            ta.Icon = PDFTextAnnotationIcon.Paragraph
            ta.Rectangle = New RectangleF(500, 60, 20, 20)
            page.Annotations.Add(ta)
            page.Canvas.DrawText("Paragraph", fontText, Nothing, blackBrush, 500, 80, _
                0, PDFTextAlign.TopLeft)

            ' Rubber stamp annotations

            page.Canvas.DrawText("Rubber stamp annotations", fontSection, Nothing, blackBrush, 20, 120, _
                0, PDFTextAlign.TopLeft)
            ' Create all available rubber stamp annotations
            Dim rsa As New PDFRubberStampAnnotation("Approved", "Approved annotation")
            rsa.Icon = PDFRubberStampAnnotationIcon.Approved
            rsa.Rectangle = New RectangleF(20, 140, 100, 30)
            rsa.Opacity = 50
            page.Annotations.Add(rsa)
            page.Canvas.DrawText("Approved", fontText, Nothing, blackBrush, 20, 180, _
                0, PDFTextAlign.TopLeft)

            rsa = New PDFRubberStampAnnotation("As Is", "As Is annotation")
            rsa.Icon = PDFRubberStampAnnotationIcon.AsIs
            rsa.Rectangle = New RectangleF(120, 140, 100, 30)
            page.Annotations.Add(rsa)
            page.Canvas.DrawText("As Is", fontText, Nothing, blackBrush, 120, 180, _
                0, PDFTextAlign.TopLeft)

            rsa = New PDFRubberStampAnnotation("Confidential", "Confidential annotation")
            rsa.Icon = PDFRubberStampAnnotationIcon.Confidential
            rsa.Rectangle = New RectangleF(220, 140, 100, 30)
            page.Annotations.Add(rsa)
            page.Canvas.DrawText("Confidential", fontText, Nothing, blackBrush, 220, 180, _
                0, PDFTextAlign.TopLeft)

            rsa = New PDFRubberStampAnnotation("Departmental", "Departmental annotation")
            rsa.Icon = PDFRubberStampAnnotationIcon.Departmental
            rsa.Rectangle = New RectangleF(320, 140, 100, 30)
            page.Annotations.Add(rsa)
            page.Canvas.DrawText("Departmental", fontText, Nothing, blackBrush, 320, 180, _
                0, PDFTextAlign.TopLeft)

            rsa = New PDFRubberStampAnnotation("Draft", "Draft annotation")
            rsa.Icon = PDFRubberStampAnnotationIcon.Draft
            rsa.Rectangle = New RectangleF(420, 140, 100, 30)
            page.Annotations.Add(rsa)
            page.Canvas.DrawText("Draft", fontText, Nothing, blackBrush, 420, 180, _
                0, PDFTextAlign.TopLeft)

            rsa = New PDFRubberStampAnnotation("Experimental", "Experimental annotation")
            rsa.Icon = PDFRubberStampAnnotationIcon.Experimental
            rsa.Rectangle = New RectangleF(520, 140, 100, 30)
            page.Annotations.Add(rsa)
            page.Canvas.DrawText("Experimental", fontText, Nothing, blackBrush, 520, 180, _
                0, PDFTextAlign.TopLeft)

            rsa = New PDFRubberStampAnnotation("Expired", "Expired annotation")
            rsa.Icon = PDFRubberStampAnnotationIcon.Expired
            rsa.Rectangle = New RectangleF(20, 200, 100, 30)
            page.Annotations.Add(rsa)
            page.Canvas.DrawText("Expired", fontText, Nothing, blackBrush, 20, 240, _
                0, PDFTextAlign.TopLeft)

            rsa = New PDFRubberStampAnnotation("Final", "Final annotation")
            rsa.Icon = PDFRubberStampAnnotationIcon.Final
            rsa.Rectangle = New RectangleF(120, 200, 100, 30)
            page.Annotations.Add(rsa)
            page.Canvas.DrawText("Final", fontText, Nothing, blackBrush, 120, 240, _
                0, PDFTextAlign.TopLeft)

            rsa = New PDFRubberStampAnnotation("ForComment", "ForComment annotation")
            rsa.Icon = PDFRubberStampAnnotationIcon.ForComment
            rsa.Rectangle = New RectangleF(220, 200, 100, 30)
            page.Annotations.Add(rsa)
            page.Canvas.DrawText("ForComment", fontText, Nothing, blackBrush, 220, 240, _
                0, PDFTextAlign.TopLeft)

            rsa = New PDFRubberStampAnnotation("ForPublicRelease", "ForPublicRelease annotation")
            rsa.Icon = PDFRubberStampAnnotationIcon.ForPublicRelease
            rsa.Rectangle = New RectangleF(320, 200, 100, 30)
            page.Annotations.Add(rsa)
            page.Canvas.DrawText("ForPublicRelease", fontText, Nothing, blackBrush, 320, 240, _
                0, PDFTextAlign.TopLeft)

            rsa = New PDFRubberStampAnnotation("NotApproved", "NotApproved annotation")
            rsa.Icon = PDFRubberStampAnnotationIcon.NotApproved
            rsa.Rectangle = New RectangleF(420, 200, 100, 30)
            page.Annotations.Add(rsa)
            page.Canvas.DrawText("NotApproved", fontText, Nothing, blackBrush, 420, 240, _
                0, PDFTextAlign.TopLeft)

            rsa = New PDFRubberStampAnnotation("NotForPublicRelease", "NotForPublicRelease annotation")
            rsa.Icon = PDFRubberStampAnnotationIcon.NotForPublicRelease
            rsa.Rectangle = New RectangleF(520, 200, 100, 30)
            page.Annotations.Add(rsa)
            page.Canvas.DrawText("NotForPublicRelease", fontText, Nothing, blackBrush, 520, 240, _
                0, PDFTextAlign.TopLeft)

            rsa = New PDFRubberStampAnnotation("Sold", "Sold annotation")
            rsa.Icon = PDFRubberStampAnnotationIcon.Sold
            rsa.Rectangle = New RectangleF(20, 260, 100, 30)
            page.Annotations.Add(rsa)
            page.Canvas.DrawText("Sold", fontText, Nothing, blackBrush, 20, 300, _
                0, PDFTextAlign.TopLeft)

            rsa = New PDFRubberStampAnnotation("TopSecret", "TopSecret annotation")
            rsa.Icon = PDFRubberStampAnnotationIcon.TopSecret
            rsa.Rectangle = New RectangleF(120, 260, 100, 30)
            page.Annotations.Add(rsa)
            page.Canvas.DrawText("TopSecret", fontText, Nothing, blackBrush, 120, 300, _
                0, PDFTextAlign.TopLeft)

            ' Line annotations

            page.Canvas.DrawText("Line annotations", fontSection, Nothing, blackBrush, 20, 350, _
                0, PDFTextAlign.TopLeft)
            Dim la As New PDFLineAnnotation("Line", "Line annotation")
            la.BeginLineStyle = PDFLineEndingStyle.Circle
            la.EndLineStyle = PDFLineEndingStyle.OpenArrow
            la.LineDirection = PDFLineDirection.TopLeftToBottomRight
            la.Rectangle = New RectangleF(20, 370, 150, 30)
            la.Border = New PDFAnnotationBorder(1, PDFBorderStyle.Solid)
            la.Color = New PDFRgbColor(Color.Red)
            la.InteriorColor = New PDFRgbColor(Color.CornflowerBlue)
            page.Annotations.Add(la)
            page.Canvas.DrawText("Line annotation with a circle and open arrow", fontText, Nothing, blackBrush, 20, 420, _
                0, PDFTextAlign.TopLeft)

            ' File attachment annotations

            page.Canvas.DrawText("File attachment annotations", fontSection, Nothing, blackBrush, 20, 450, _
                0, PDFTextAlign.TopLeft)
            ' Create all available file attachment annotations
            Dim faa As New PDFFileAttachmentAnnotation("Graph", "Graph icon")
            faa.Icon = PDFFileAttachmentAnnotationIcon.Graph
            faa.Rectangle = New RectangleF(20, 470, 20, 20)
            faa.FileName = "sample.pdf"
            page.Annotations.Add(faa)
            page.Canvas.DrawText("Graph", fontText, Nothing, blackBrush, 20, 500, _
                0, PDFTextAlign.TopLeft)

            faa = New PDFFileAttachmentAnnotation("Paperclip", "Paperclip icon")
            faa.Icon = PDFFileAttachmentAnnotationIcon.Paperclip
            faa.Rectangle = New RectangleF(100, 470, 20, 20)
            faa.FileName = "sample.pdf"
            page.Annotations.Add(faa)
            page.Canvas.DrawText("Paperclip", fontText, Nothing, blackBrush, 100, 500, _
                0, PDFTextAlign.TopLeft)

            faa = New PDFFileAttachmentAnnotation("PushPin", "PushPin icon")
            faa.Icon = PDFFileAttachmentAnnotationIcon.PushPin
            faa.Rectangle = New RectangleF(180, 470, 20, 20)
            faa.FileName = "sample.pdf"
            page.Annotations.Add(faa)
            page.Canvas.DrawText("PushPin", fontText, Nothing, blackBrush, 180, 500, _
                0, PDFTextAlign.TopLeft)

            faa = New PDFFileAttachmentAnnotation("Tag", "Tag icon")
            faa.Icon = PDFFileAttachmentAnnotationIcon.Tag
            faa.Rectangle = New RectangleF(260, 470, 20, 20)
            faa.FileName = "sample.pdf"
            page.Annotations.Add(faa)
            page.Canvas.DrawText("Graph", fontText, Nothing, blackBrush, 260, 500, _
                0, PDFTextAlign.TopLeft)

            ' Highlight annotation

            page.Canvas.DrawText("Markup annotation - this text will be highlighted", fontSection, Nothing, blackBrush, 20, 610)
            Dim ha As New PDFHighlightAnnotation("Markup annotation", "Markup annotation with highlight style")
            ha.Rectangle = New RectangleF(100, 610, 100, 10)
            ha.Color = New PDFRgbColor(255, 255, 0)
            page.Annotations.Add(ha)

            ' Square and circle annotations

            page.Canvas.DrawText("Square and circle annotations", fontSection, Nothing, blackBrush, 20, 650)
            Dim ea As New PDFEllipseAnnotation("Ellipse annotation", "An ellipse annotation")
            ea.Rectangle = New RectangleF(20, 670, 150, 75)
            ea.Color = New PDFRgbColor(255, 255, 0)
            ea.InteriorColor = New PDFRgbColor(0, 255, 0)
            page.Annotations.Add(ea)

            Dim ra As New PDFRectangleAnnotation("Rectangle annotation", "A rectangle annotation")
            ra.Rectangle = New RectangleF(200, 670, 150, 75)
            ra.Color = New PDFRgbColor(255, 64, 0)
            ra.InteriorColor = New PDFRgbColor(64, 0, 255)
            page.Annotations.Add(ra)

            ' Create 2nd page
            page = doc.AddPage()

            page.Canvas.DrawText("Annotations with custom appearance", fontSection, Nothing, blackBrush, 20, 45, 0, PDFTextAlign.BottomLeft)

            page.Canvas.DrawText("a. Annotations with image appearance", fontSection, Nothing, blackBrush, 20, 60, 0, PDFTextAlign.BottomLeft)
            Dim isa As New PDFRubberStampAnnotation("ImageAppearance", "Annotation with image appearance.")
            Dim img As New Bitmap("..\SupportFiles\auto1.jpg")
            isa.Appearance = New PDFImageAppearance(img)
            img.Dispose()
            isa.Rectangle = New RectangleF(20, 70, 200, 100)
            page.Annotations.Add(isa)
            page.Canvas.DrawText("Image appearance", fontText, Nothing, blackBrush, 20, 175, 0, PDFTextAlign.TopLeft)

            page.Canvas.DrawText("b. Annotations with owner draw appearance", fontSection, Nothing, blackBrush, 20, 200, 0, PDFTextAlign.TopLeft)
            Dim odsa As New PDFRubberStampAnnotation("OwnerDrawAppearance", "Annotation with owner draw appearance.")
            odsa.Rectangle = New RectangleF(20, 220, 200, 100)
            odsa.Appearance = New PDFAnnotationAppearance()
            odsa.Appearance.Width = odsa.Rectangle.Width
            odsa.Appearance.Height = odsa.Rectangle.Height
            Dim redBrush As New PDFBrush(New PDFRgbColor(192, 0, 0))
            odsa.Appearance.Canvas.DrawRoundRectangle(redBrush, 0, 0, odsa.Rectangle.Width, odsa.Rectangle.Height, 40, 40)
            Dim blueBrush As New PDFBrush(New PDFRgbColor(0, 0, 128))
            odsa.Appearance.Canvas.DrawEllipse(blueBrush, (odsa.Rectangle.Width - odsa.Rectangle.Height) / 2, 0, odsa.Rectangle.Height, odsa.Rectangle.Height)
            page.Annotations.Add(odsa)
            page.Canvas.DrawText("Owner draw appearance", fontText, Nothing, blackBrush, 20, 325, 0, PDFTextAlign.TopLeft)

            ' Save the document to disk
            doc.Save("Sample_Annotations.pdf")
        End Sub
    End Class
End Namespace


Samples: ArcsPies

PDF4NET Send comments on this topic.
Samples: ArcsPies
PDF4NET On-line Help > Samples > Samples: ArcsPies

Glossary Item Box

This samples demonstrates the arcs and pies drawing capabilities of the PDF4NET library. It creates a 2 pages document. On the first page, it draws 50 arcs positioned at random locations, with random angles. On the second page, it draws 50 pies positioned at random locations, with random angles. The colors of the arcs and pies are generated randomly.

C# Source code | VB.NET Source code | PDF file


ArcsPies.cs

PDF4NET Send comments on this topic.
ArcsPies.cs
PDF4NET On-line Help > Samples > ArcsPies > ArcsPies.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Fonts;
using O2S.Components.PDF4NET.Graphics.Shapes;

namespace O2S.Samples.PDF4NET.ArcsPies
{
    /// <summary>
    /// This sample will show how to draw arcs and pies
    /// on the page.
    /// </summary>
    class ArcsPies
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor(Color.Black));
            PDFBrush greenBrush = new PDFBrush(new PDFRgbColor(Color.Green));
            PDFPen pen = new PDFPen(new PDFRgbColor(Color.Orange), 1);

            Random rnd = new Random();

            // Create first page
            PDFPage pdfPage1 = pdfDoc.AddPage();

            // Draw 50 arcs
            for (int i = 0; i < 50; i++)
            {
                // Create random colors for the border and the interior
                Color penColor = Color.FromArgb(rnd.Next(256), rnd.Next(256), rnd.Next(256));

                // Create the pen to draw the border
                PDFPen randomPen = new PDFPen(new PDFRgbColor(penColor), 1);

                // Generate random positions
                float left = rnd.Next((int)pdfPage1.Width);
                float top = rnd.Next((int)pdfPage1.Height);

                // Generate random sizes
                float width = rnd.Next((int)(pdfPage1.Width - left)); // try to keep the arc within the page
                float height = rnd.Next((int)(pdfPage1.Height - top)); // try to keep the arc within the page
                float startAngle = rnd.Next(360);
                float sweepAngle = rnd.Next(360);

                // Draw the ellipse
                pdfPage1.Canvas.DrawArc(randomPen, top, left, width, height, startAngle, sweepAngle);
            }

            // Draw a label
            pdfPage1.Canvas.DrawText("Random arcs",
                fontText, null, blackBrush, 20, 20);

            // Create the second page
            PDFPage pdfPage2 = pdfDoc.AddPage();

            // Draw 50 pies
            for (int i = 0; i < 50; i++)
            {
                // Create random colors for the border and the interior
                Color brushColor = Color.FromArgb(rnd.Next(256), rnd.Next(256), rnd.Next(256));
                Color penColor = Color.FromArgb(rnd.Next(256), rnd.Next(256), rnd.Next(256));

                // Create the brush to fill the interior
                PDFBrush randomBrush = new PDFBrush(new PDFRgbColor(brushColor));
                // Create the pen to draw the border
                PDFPen randomPen = new PDFPen(new PDFRgbColor(penColor), 1);

                // Generate random positions
                float left = rnd.Next((int)pdfPage2.Width);
                float top = rnd.Next((int)pdfPage2.Height);

                // Generate random sizes
                float width = rnd.Next((int)(pdfPage2.Width - left)); // try to keep the pie within the page
                float height = rnd.Next((int)(pdfPage2.Height - top)); // try to keep the pie within the page
                float startAngle = rnd.Next(360);
                float sweepAngle = rnd.Next(360);

                // Draw the ellipse
                pdfPage2.Canvas.DrawPie(randomPen, randomBrush,
                    top, left, width, height, startAngle, sweepAngle);
            }

            // Draw a label
            pdfPage2.Canvas.DrawText("Random pies",
                fontText, null, blackBrush, 20, 20);

            // Save the document to disk
            pdfDoc.Save("Sample_ArcsPies.pdf");
        }
    }
}


ArcsPies.vb

PDF4NET Send comments on this topic.
ArcsPies.vb
PDF4NET On-line Help > Samples > ArcsPies > ArcsPies.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Fonts
Imports O2S.Components.PDF4NET.Graphics.Shapes

Namespace O2S.Samples.PDF4NET.ArcsPies
    ''' <summary>
    ''' This sample will show how to draw arcs and pies
    ''' on the page.
    ''' </summary>
    Class ArcsPies
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim blackBrush As New PDFBrush(New PDFRgbColor(Color.Black))
            Dim greenBrush As New PDFBrush(New PDFRgbColor(Color.Green))
            Dim pen As New PDFPen(New PDFRgbColor(Color.Orange), 1)

            Dim rnd As New Random()

            ' Create first page
            Dim pdfPage1 As PDFPage = pdfDoc.AddPage()

            ' Draw 50 arcs
            Dim i As Integer = 0
            While i < 50
                ' Create random colors for the border and the interior
                Dim penColor As Color = Color.FromArgb(rnd.Next(256), rnd.Next(256), rnd.Next(256))

                ' Create the pen to draw the border
                Dim randomPen As New PDFPen(New PDFRgbColor(penColor), 1)

                ' Generate random positions
                Dim left As Single = rnd.NextDouble() * pdfPage1.Width
                Dim top As Single = rnd.NextDouble() * pdfPage1.Height

                ' Generate random sizes
                Dim width As Single = rnd.NextDouble() * (pdfPage1.Width - left)
                ' try to keep the arc within the page
                Dim height As Single = rnd.NextDouble() * (pdfPage1.Height - top)
                ' try to keep the arc within the page
                Dim startAngle As Single = rnd.Next(360)
                Dim sweepAngle As Single = rnd.Next(360)

                ' Draw the ellipse
                pdfPage1.Canvas.DrawArc(randomPen, top, left, width, height, startAngle, _
                    sweepAngle)
                i = i + 1
            End While

            ' Draw a label
            pdfPage1.Canvas.DrawText("Random arcs", fontText, Nothing, blackBrush, 20, 20)

            ' Create the second page
            Dim pdfPage2 As PDFPage = pdfDoc.AddPage()

            ' Draw 50 pies
            i = 0
            While i < 50
                ' Create random colors for the border and the interior
                Dim brushColor As Color = Color.FromArgb(rnd.Next(256), rnd.Next(256), rnd.Next(256))
                Dim penColor As Color = Color.FromArgb(rnd.Next(256), rnd.Next(256), rnd.Next(256))

                ' Create the brush to fill the interior
                Dim randomBrush As New PDFBrush(New PDFRgbColor(brushColor))
                ' Create the pen to draw the border
                Dim randomPen As New PDFPen(New PDFRgbColor(penColor), 1)

                ' Generate random positions
                Dim left As Single = rnd.NextDouble() * pdfPage2.Width
                Dim top As Single = rnd.NextDouble() * pdfPage2.Height

                ' Generate random sizes
                Dim width As Single = rnd.NextDouble() * (pdfPage2.Width - left)
                ' try to keep the pie within the page
                Dim height As Single = rnd.NextDouble() * (pdfPage2.Height - top)
                ' try to keep the pie within the page
                Dim startAngle As Single = rnd.Next(360)
                Dim sweepAngle As Single = rnd.Next(360)

                ' Draw the ellipse
                pdfPage2.Canvas.DrawPie(randomPen, randomBrush, top, left, width, height, _
                    startAngle, sweepAngle)
                i = i + 1
            End While

            ' Draw a label
            pdfPage2.Canvas.DrawText("Random pies", fontText, Nothing, blackBrush, 20, 20)

            ' Save the document to disk
            pdfDoc.Save("Sample_ArcsPies.pdf")
        End Sub
    End Class
End Namespace


Samples: Attachments

PDF4NET Send comments on this topic.
Samples: Attachments
PDF4NET On-line Help > Samples > Samples: Attachments

Glossary Item Box

This sample shows how to work with document attachments using PDF4NET library.

C# Source code | VB.NET Source code | PDF file


Attachments.cs

PDF4NET Send comments on this topic.
Attachments.cs
PDF4NET On-line Help > Samples > Attachments > Attachments.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Fonts;
using O2S.Components.PDF4NET.Graphics.Shapes;

namespace O2S.Samples.PDF4NET
{
    /// <summary>
    /// This sample shows how to work with document attachments using PDF4NET library.
    /// </summary>
    class Attachments
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create a document with 2 file attachments.
            CreateAttachments();

            // Display attachments in a PDF file.
            DisplayAttachments();
        }

        /// <summary>
        /// Creates a PDF file that contains 2 file attachments.
        /// </summary>
        private static void CreateAttachments()
        {
            // Create the pdf document
            PDFDocument doc = new PDFDocument();

            // Create a blank page
            PDFPage page = doc.AddPage();
            // Print instructions about how to view the attachments in the PDF file.
            PDFBrush brush = new PDFBrush(new PDFRgbColor(0, 0, 0));
            PDFFont font = new PDFFont();
            page.Canvas.DrawText("This document contains 2 file attachments.",
                font, null, brush, 50, 50);
            page.Canvas.DrawText("In the Acrobat/Reader menu click on View > " +
                "Navigation tabs > Attachments to view them.", font, null, brush, 50, 60);

            // Create an attachment for 'xfasampleform.pdf' file
            PDFDocumentAttachment attachment = new PDFDocumentAttachment();
            attachment.FileName = "..\\SupportFiles\\xfasampleform.pdf";
            attachment.MimeType = "application/pdf";
            attachment.Description = "XFA sample form";
            // Add the attachment to document.
            doc.Attachments.Add(attachment);

            // Create an attachment for 'auto1.pdf' file
            attachment = new PDFDocumentAttachment();
            attachment.FileName = "..\\SupportFiles\\auto1.jpg";
            attachment.MimeType = "image/jpg";
            attachment.Description = "Lexus - Minority Report";
            // Add the attachment to document.
            doc.Attachments.Add(attachment);

            // Save the document to disk
            doc.Save("Sample_Attachments.pdf");
        }

        private static void DisplayAttachments()
        {
            // Load the PDF file that contains the attachments
            // (use the document created by previous function)
            PDFDocument doc = new PDFDocument("Sample_Attachments.pdf");
            // Display the attachments in the document
            for (int i = 0; i < doc.Attachments.Count; i++)
            {
                Console.WriteLine("Attachment: {0}; Description: {1}; Creation Date: {2}",
                    doc.Attachments[i].FileName, doc.Attachments[i].Description,
                    doc.Attachments[i].CreationDate);
                // doc.Attachments[i].FileData contains the attachment content.
                // It can be saved to disk if needed.
            }
        }
    }
}


Attachments.vb

PDF4NET Send comments on this topic.
Attachments.vb
PDF4NET On-line Help > Samples > Attachments > Attachments.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Fonts
Imports O2S.Components.PDF4NET.Graphics.Shapes

Namespace O2S.Samples.PDF4NET
    ''' <summary>
    ''' This sample shows how to work with document attachments using PDF4NET library.
    ''' </summary>
    Class Attachments
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create a document with 2 file attachments.
            CreateAttachments()

            ' Display attachments in a PDF file.
            DisplayAttachments()
        End Sub

        ''' <summary>
        ''' Creates a PDF file that contains 2 file attachments.
        ''' </summary>
        Private Shared Sub CreateAttachments()
            ' Create the pdf document
            Dim doc As New PDFDocument()

            ' Create a blank page
            Dim page As PDFPage = doc.AddPage()
            ' Print instructions about how to view the attachments in the PDF file.
            Dim brush As New PDFBrush(New PDFRgbColor(0, 0, 0))
            Dim font As New PDFFont()
            page.Canvas.DrawText("This document contains 2 file attachments.", font, Nothing, brush, 50, 50)
            page.Canvas.DrawText("In the Acrobat/Reader menu click on View > " + "Navigation tabs > Attachments to view them.", font, Nothing, brush, 50, 60)

            ' Create an attachment for 'xfasampleform.pdf' file
            Dim attachment As New PDFDocumentAttachment()
            attachment.FileName = "..\SupportFiles\xfasampleform.pdf"
            attachment.MimeType = "application/pdf"
            attachment.Description = "XFA sample form"
            ' Add the attachment to document.
            doc.Attachments.Add(attachment)

            ' Create an attachment for 'auto1.pdf' file
            attachment = New PDFDocumentAttachment()
            attachment.FileName = "..\SupportFiles\auto1.jpg"
            attachment.MimeType = "image/jpg"
            attachment.Description = "Lexus - Minority Report"
            ' Add the attachment to document.
            doc.Attachments.Add(attachment)

            ' Save the document to disk
            doc.Save("Sample_Attachments.pdf")
        End Sub

        Private Shared Sub DisplayAttachments()
            ' Load the PDF file that contains the attachments
            ' (use the document created by previous function)
            Dim doc As New PDFDocument("Sample_Attachments.pdf")
            ' Display the attachments in the document
            Dim i As Integer = 0
            While i < doc.Attachments.Count
                    ' doc.Attachments[i].FileData contains the attachment content.
                    ' It can be saved to disk if needed.
                Console.WriteLine("Attachment: {0}; Description: {1}; Creation Date: {2}", doc.Attachments(i).FileName, doc.Attachments(i).Description, doc.Attachments(i).CreationDate)
                i = i + 1
            End While
        End Sub
    End Class
End Namespace


Samples: Autonumbering

PDF4NET Send comments on this topic.
Samples: Autonumbering
PDF4NET On-line Help > Samples > Samples: Autonumbering

Glossary Item Box

This samples demonstrates the autonumbering capabilities of the PDF4NET library. It creates a 100 pages document. Then, it creates 10 numbering ranges, one range for each 10 pages. Each numbering range is considered to be a chapter, the first range is considered to be the introduction. The first numbering range uses roman numbering system, while the others use arabic numbering system. The numbering of the chapters use the chapter number as the prefix for page number.

C# Source code | VB.NET Source code | PDF file


AutoNumbering.cs

PDF4NET Send comments on this topic.
AutoNumbering.cs
PDF4NET On-line Help > Samples > Autonumbering > AutoNumbering.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.AutoNumbering
{
    /// <summary>
    /// This sample will show how to use the automatic page numbering feature
    /// available with the PDF4NET library.
    /// The document will have 100 pages, first 10 pages will be the introduction
    /// and they will use roman numerals, then each 10 pages will be grouped as
    /// a chapter. The numbering will be chapter based, meaning the pages will be
    /// numbered within the chapter. Ex: chapte 1: 1-1, 1-2, 1-3, etc, chapter 2:
    /// 2-1, 2-2, 2-3, etc.
    /// </summary>
    class AutoNumbering
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 96);
            PDFFont fontNumber = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());

            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            int i;
            // Create 10 numbering ranges, each range will correspond to a chapter
            // The first range is for the introduction.
            for (i = 0; i < 10; i++)
            {
                PDFPageNumberingRange pnr = new PDFPageNumberingRange();
                if (i == 0)
                { // pages in the introduction use roman numerals
                    pnr.NumberingStyle = PDFNumberingStyle.LowerCaseRoman;
                }
                else
                { // pages in the rest of the chapters use arabic numerals
                    pnr.NumberingStyle = PDFNumberingStyle.Arabic;
                }
                // Each numbering range covers 10 pages
                pnr.StartPageIndex = i * 10;

                // Within each chapter, the page numbers will start from 1
                pnr.StartPageNumber = 1;

                // Set the page number prefix for each numbering range
                // to be the number of the chapter. For the introduction
                // we do not set a page number.
                if (i > 0)
                {
                    pnr.PageNumberPrefix = i.ToString() + " - ";
                }

                // Add the numbering range to document
                pdfDoc.PageNumberingRanges.Add(pnr);
            }

            // Create the visual aspect of the page number
            PDFPageNumber pn = new PDFPageNumber();
            pn.Font = fontNumber;
            pn.Brush = blackBrush;
            // Print the page number centered at the bottom of the page
            pn.Align = PDFTextAlign.BottomCenter;
            // The page number will be printed 10 points above the bottom margin.
            pn.VerticalOffset = 10;

            // Set the page number visual aspect for all the pages in the document
            // by attaching it to the document.
            pdfDoc.PageNumber = pn;

            // Create the pages of the document, 100 pages
            for (i = 0; i < 100; i++)
            {
                // Create the page
                PDFPage pdfPage = pdfDoc.AddPage();
                // Draw a label on it
                if (i / 10 == 0)
                {
                    pdfPage.Canvas.DrawText("Introduction",
                        fontText, null, blackBrush, pdfPage.Width / 2, pdfPage.Height / 2,
                        0, PDFTextAlign.MiddleCenter);
                }
                else
                {
                    pdfPage.Canvas.DrawText("Chapter " + (i / 10).ToString(),
                        fontText, null, blackBrush, pdfPage.Width / 2, pdfPage.Height / 2,
                        0, PDFTextAlign.MiddleCenter);
                }
            }

            // Save the document to disk
            pdfDoc.Save("Sample_AutoNumbering.pdf");
        }
    }
}


AutoNumbering.vb

PDF4NET Send comments on this topic.
AutoNumbering.vb
PDF4NET On-line Help > Samples > Autonumbering > AutoNumbering.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.AutoNumbering
    ''' <summary>
    ''' This sample will show how to use the automatic page numbering feature
    ''' available with the PDF4NET library.
    ''' The document will have 100 pages, first 10 pages will be the introduction
    ''' and they will use roman numerals, then each 10 pages will be grouped as
    ''' a chapter. The numbering will be chapter based, meaning the pages will be
    ''' numbered within the chapter. Ex: chapter 1: 1-1, 1-2, 1-3, etc, chapter 2:
    ''' 2-1, 2-2, 2-3, etc.
    ''' </summary>
    Class AutoNumbering
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 96)
            Dim fontNumber As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())

            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            Dim i As Integer
            ' Create 10 numbering ranges, each range will correspond to a chapter
            ' The first range is for the introduction.
            i = 0
            While i < 10
                Dim pnr As New PDFPageNumberingRange()
                If i = 0 Then
                    ' pages in the introduction use roman numerals
                    pnr.NumberingStyle = PDFNumberingStyle.LowerCaseRoman
                Else
                    ' pages in the rest of the chapters use arabic numerals
                    pnr.NumberingStyle = PDFNumberingStyle.Arabic
                End If
                ' Each numbering range covers 10 pages
                pnr.StartPageIndex = i * 10

                ' Within each chapter, the page numbers will start from 1
                pnr.StartPageNumber = 1

                ' Set the page number prefix for each numbering range
                ' to be the number of the chapter. For the introduction
                ' we do not set a page number.
                If i > 0 Then
                    pnr.PageNumberPrefix = i.ToString() + " - "
                End If

                ' Add the numbering range to document
                pdfDoc.PageNumberingRanges.Add(pnr)
                i = i + 1
            End While

            ' Create the visual aspect of the page number
            Dim pn As New PDFPageNumber()
            pn.Font = fontNumber
            pn.Brush = blackBrush
            ' Print the page number centered at the bottom of the page
            pn.Align = PDFTextAlign.BottomCenter
            ' The page number will be printed 10 points above the bottom margin.
            pn.VerticalOffset = 10

            ' Set the page number visual aspect for all the pages in the document
            ' by attaching it to the document.
            pdfDoc.PageNumber = pn

            ' Create the pages of the document, 100 pages
            i = 0
            While i < 100
                ' Create the page
                Dim pdfPage As PDFPage = pdfDoc.AddPage()
                ' Draw a label on it
                If i / 10 = 0 Then
                    pdfPage.Canvas.DrawText("Introduction", fontText, Nothing, blackBrush, pdfPage.Width / 2, pdfPage.Height / 2, _
                        0, PDFTextAlign.MiddleCenter)
                Else
                    pdfPage.Canvas.DrawText("Chapter " + (i / 10).ToString(), fontText, Nothing, blackBrush, pdfPage.Width / 2, pdfPage.Height / 2, _
                        0, PDFTextAlign.MiddleCenter)
                End If
                i = i + 1
            End While

            ' Save the document to disk
            pdfDoc.Save("Sample_AutoNumbering.pdf")
        End Sub
    End Class
End Namespace


Samples: Barcodes

PDF4NET Send comments on this topic.
Samples: Barcodes
PDF4NET On-line Help > Samples > Samples: Barcodes

Glossary Item Box

This sample demonstrates the native support for barcodes implemented in PDF4NET library. Both 1D and 2D barcodes are shown in this sample.

C# Source code | VB.NET Source code | PDF file


Barcodes.cs

PDF4NET Send comments on this topic.
Barcodes.cs
PDF4NET On-line Help > Samples > Barcodes > Barcodes.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Barcodes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.Barcodes
{
    /// <summary>
    /// This sample shows how to display barcodes in a PDF document.
    /// </summary>
    class Barcodes
    {
        [STAThread]
        static void Main(string[] args)
        {
            // Create the PDF document
            PDFDocument doc = new PDFDocument();

            // Create the helper graphic objects.
            PDFFont titleFont = new PDFFont(PDFFontFace.Helvetica, 10);
            titleFont.Bold = true;
            PDFFont textFont = new PDFFont(PDFFontFace.Helvetica, 8);
            PDFBrush brush = new PDFBrush(new PDFRgbColor(Color.Black));

            // First page for linear barcodes.
            PDFPage page = doc.AddPage();
            page.Canvas.DrawText("1D/Linear barcodes", titleFont, null, brush, 20, 50);

            page.Canvas.DrawText("1. Codabar", textFont, null, brush, 20, 70);
            PDFCodabarBarcode cb = new PDFCodabarBarcode("0123456789");
            page.Canvas.DrawBarcode(cb, 20, 80);

            page.Canvas.DrawText("2. Code 11", textFont, null, brush, 20, 140);
            PDFCode11Barcode c11 = new PDFCode11Barcode("0123456789");
            page.Canvas.DrawBarcode(c11, 20, 150);

            page.Canvas.DrawText("3. Code 128A", textFont, null, brush, 20, 210);
            PDFCode128ABarcode c128a = new PDFCode128ABarcode("CODE128A");
            page.Canvas.DrawBarcode(c128a, 20, 220);

            page.Canvas.DrawText("4. Code 128B", textFont, null, brush, 20, 280);
            PDFCode128BBarcode c128b = new PDFCode128BBarcode("CODE128B");
            page.Canvas.DrawBarcode(c128b, 20, 290);

            page.Canvas.DrawText("5. Code 128C", textFont, null, brush, 20, 350);
            PDFCode128CBarcode c128c = new PDFCode128CBarcode("0123456789");
            page.Canvas.DrawBarcode(c128c, 20, 360);

            page.Canvas.DrawText("6. Code 25", textFont, null, brush, 20, 420);
            PDFCode25Barcode c25 = new PDFCode25Barcode("0123456789");
            page.Canvas.DrawBarcode(c25, 20, 430);

            page.Canvas.DrawText("7. Code 25 Interleaved", textFont, null, brush, 20, 490);
            PDFCode25InterleavedBarcode c25i = new PDFCode25InterleavedBarcode("0123456789");
            page.Canvas.DrawBarcode(c25i, 20, 500);

            page.Canvas.DrawText("8. Code 39", textFont, null, brush, 20, 560);
            PDFCode39Barcode c39 = new PDFCode39Barcode("CODE39");
            page.Canvas.DrawBarcode(c39, 20, 570);

            page.Canvas.DrawText("9. Code 39 Extended", textFont, null, brush, 20, 630);
            PDFCode39ExtendedBarcode c39x = new PDFCode39ExtendedBarcode("C39Ext");
            page.Canvas.DrawBarcode(c39x, 20, 640);

            page.Canvas.DrawText("10. Code 93", textFont, null, brush, 20, 700);
            PDFCode93Barcode c93 = new PDFCode93Barcode("CODE93");
            page.Canvas.DrawBarcode(c93, 20, 710);

            page.Canvas.DrawText("11. Code 93 Extended", textFont, null, brush, 200, 70);
            PDFCode93ExtendedBarcode c93x = new PDFCode93ExtendedBarcode("C93Ext");
            page.Canvas.DrawBarcode(c93x, 200, 80);

            page.Canvas.DrawText("12. COOP 25", textFont, null, brush, 200, 140);
            PDFCOOP25Barcode coop25 = new PDFCOOP25Barcode("0123456789");
            page.Canvas.DrawBarcode(coop25, 200, 150);

            page.Canvas.DrawText("13. EAN-13", textFont, null, brush, 200, 210);
            PDFEAN13Barcode ean13 = new PDFEAN13Barcode("012345678901");
            page.Canvas.DrawBarcode(ean13, 200, 220);

            page.Canvas.DrawText("14. EAN-8", textFont, null, brush, 200, 280);
            PDFEAN8Barcode ean8 = new PDFEAN8Barcode("0123456");
            page.Canvas.DrawBarcode(ean8, 200, 290);

            page.Canvas.DrawText("15. IATA 25", textFont, null, brush, 200, 350);
            PDFIATA25Barcode i25 = new PDFIATA25Barcode("0123456789");
            page.Canvas.DrawBarcode(i25, 200, 360);

            page.Canvas.DrawText("16. ISBN", textFont, null, brush, 200, 420);
            PDFISBNBarcode isbn = new PDFISBNBarcode("123456789");
            page.Canvas.DrawBarcode(isbn, 200, 430);

            page.Canvas.DrawText("17. ISMN", textFont, null, brush, 200, 490);
            PDFISMNBarcode ismn = new PDFISMNBarcode("123456789");
            page.Canvas.DrawBarcode(ismn, 200, 500);

            page.Canvas.DrawText("18. ISSN", textFont, null, brush, 200, 560);
            PDFISSNBarcode issn = new PDFISSNBarcode("123456789");
            page.Canvas.DrawBarcode(issn, 200, 570);

            page.Canvas.DrawText("19. JAN-13", textFont, null, brush, 200, 630);
            PDFJAN13Barcode jan13 = new PDFJAN13Barcode("1234567890");
            page.Canvas.DrawBarcode(jan13, 200, 640);

            page.Canvas.DrawText("20. Matrix 25", textFont, null, brush, 200, 700);
            PDFMatrix25Barcode m25 = new PDFMatrix25Barcode("0123456789");
            page.Canvas.DrawBarcode(m25, 200, 710);

            page.Canvas.DrawText("21. Msi/Plessey", textFont, null, brush, 350, 70);
            PDFMSIPlesseyBarcode msi = new PDFMSIPlesseyBarcode("0123456789");
            page.Canvas.DrawBarcode(msi, 350, 80);

            page.Canvas.DrawText("22. Planet", textFont, null, brush, 350, 140);
            PDFPlanetBarcode planet = new PDFPlanetBarcode("012345678901");
            page.Canvas.DrawBarcode(planet, 350, 150);

            page.Canvas.DrawText("23. Postnet", textFont, null, brush, 350, 210);
            PDFPostNetBarcode postnet = new PDFPostNetBarcode("012345678");
            page.Canvas.DrawBarcode(postnet, 350, 220);

            page.Canvas.DrawText("24. RM4SCC", textFont, null, brush, 350, 280);
            PDFRM4SCCBarcode rm4scc = new PDFRM4SCCBarcode("RM4SCC");
            page.Canvas.DrawBarcode(rm4scc, 350, 290);

            page.Canvas.DrawText("25. SCC-14", textFont, null, brush, 350, 350);
            PDFSCC14Barcode scc14 = new PDFSCC14Barcode("0123456789012");
            page.Canvas.DrawBarcode(scc14, 350, 360);

            page.Canvas.DrawText("26. SSCC-18", textFont, null, brush, 350, 420);
            PDFSSCC18Barcode sscc18 = new PDFSSCC18Barcode("00000012331234567");
            page.Canvas.DrawBarcode(sscc18, 350, 430);

            page.Canvas.DrawText("27. UPC-A", textFont, null, brush, 350, 490);
            PDFUPCABarcode upca = new PDFUPCABarcode("87567816412");
            upca.Supplement = "59999";
            upca.SupplementYDimension = 20;
            upca.SupplementDisplayLocation = BarcodeTextLocation.Above;
            page.Canvas.DrawBarcode(upca, 350, 500);

            page.Canvas.DrawText("28. UPC-E", textFont, null, brush, 350, 560);
            PDFUPCEBarcode upce = new PDFUPCEBarcode("0425261");
            page.Canvas.DrawBarcode(upce, 350, 570);

            // Second page for linear barcodes.
            page = doc.AddPage();
            page.Canvas.DrawText("1D/Linear barcodes (continued)", titleFont, null, brush, 20, 50);

            page.Canvas.DrawText("29. Singapore Post", textFont, null, brush, 20, 70);
            PDFSingaporePostBarcode singPost = new PDFSingaporePostBarcode("0123456789");
            page.Canvas.DrawBarcode(singPost, 20, 80);

            page.Canvas.DrawText("30. Royal Dutch TPG Post", textFont, null, brush, 20, 140);
            PDFKixBarcode kix = new PDFKixBarcode("0123456789");
            page.Canvas.DrawBarcode(kix, 20, 150);

            page.Canvas.DrawText("31. PZN", textFont, null, brush, 20, 210);
            PDFPZNBarcode pzn = new PDFPZNBarcode("123456");
            page.Canvas.DrawBarcode(pzn, 20, 220);

            page.Canvas.DrawText("32. Deutsche Post Identcode", textFont, null, brush, 20, 280);
            PDFIdentcodeBarcode identcode = new PDFIdentcodeBarcode("01234567890");
            page.Canvas.DrawBarcode(identcode, 20, 290);

            page.Canvas.DrawText("33. Deutsche Post Leitcode", textFont, null, brush, 20, 350);
            PDFLeitcodeBarcode leitcode = new PDFLeitcodeBarcode("0123456789012");
            page.Canvas.DrawBarcode(leitcode, 20, 360);

            page.Canvas.DrawText("34. USPS Facing Identification Mark", textFont, null, brush, 20, 420);
            PDFUSPSFIMBarcode fim = new PDFUSPSFIMBarcode("A");
            page.Canvas.DrawBarcode(fim, 20, 430);

            page.Canvas.DrawText("35. USPS Horizontal Bars", textFont, null, brush, 20, 490);
            PDFUSPSHorizontalBarcode hb = new PDFUSPSHorizontalBarcode("111");
            page.Canvas.DrawBarcode(hb, 20, 500);

            page.Canvas.DrawText("36. USPS Package Identification Code", textFont, null, brush, 20, 560);
            PDFUSPSPICBarcode pic = new PDFUSPSPICBarcode("910123456789012345678");
            page.Canvas.DrawBarcode(pic, 20, 570);

            page.Canvas.DrawText("37. FedEx Ground 96", textFont, null, brush, 20, 630);
            PDFFedExGround96Barcode fg96 = new PDFFedExGround96Barcode("960123456789012345678");
            page.Canvas.DrawBarcode(fg96, 20, 640);

            page.Canvas.DrawText("38. Pharmacode", textFont, null, brush, 20, 700);
            PDFPharmacodeBarcode pharma = new PDFPharmacodeBarcode("12345");
            page.Canvas.DrawBarcode(pharma, 20, 710);

            page.Canvas.DrawText("39. Code 32 - Italian Pharmacode", textFont, null, brush, 200, 70);
            PDFCode32Barcode c32 = new PDFCode32Barcode("12345678");
            page.Canvas.DrawBarcode(c32, 200, 80);

            page.Canvas.DrawText("40. UCC/EAN 128", textFont, null, brush, 200, 140);
            PDFEAN128Barcode ean128 = new PDFEAN128Barcode("0123456789");
            ean128.ApplicationIdentifier = "101";
            page.Canvas.DrawBarcode(ean128, 200, 150);

            // Create the 3rd page to display 2D barcodes.
            page = doc.AddPage();

            page.Canvas.DrawText("2D/Bidimensional barcodes", titleFont, null, brush, 20, 50);

            page.Canvas.DrawText("1. Codablock F", textFont, null, brush, 20, 70);
            PDFCodablockFBarcode cf = new PDFCodablockFBarcode();
            cf.Rows = 5;
            cf.Columns = 7;
            cf.Data = "1234567890";
            page.Canvas.DrawBarcode(cf, 20, 80);

            page.Canvas.DrawText("2. Code 16K", textFont, null, brush, 20, 140);
            PDFCode16KBarcode c16k = new PDFCode16KBarcode();
            c16k.Rows = 0;
            c16k.Data = "Abcd-1234567890-wxyZ";
            page.Canvas.DrawBarcode(c16k, 20, 150);

            page.Canvas.DrawText("3. DataMatrix", textFont, null, brush, 20, 210);
            PDFDataMatrixBarcode dm = new PDFDataMatrixBarcode();
            dm.Encoding = DataMatrixEncoding.ASCII;
            dm.SymbolSize = DataMatrixSymbolSize.Auto;
            dm.Data = "ABCDabcd";
            dm.XDimension = 3;
            page.Canvas.DrawBarcode(dm, 20, 220);

            page.Canvas.DrawText("4. MicroPDF417", textFont, null, brush, 20, 280);
            PDFMicroPDF417Barcode mpdf417 = new PDFMicroPDF417Barcode();
            mpdf417.CompactionMode = PDF417DataCompactionMode.Text;
            mpdf417.Data = "ABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZ" +
                "ABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZAB";
            mpdf417.XDimension = 1;
            mpdf417.YDimension = 2.5f;
            mpdf417.SymbolSize = MicroPDF417SymbolSize.Size20x4;
            page.Canvas.DrawBarcode(mpdf417, 20, 290);

            page.Canvas.DrawText("5. PDF417", textFont, null, brush, 20, 370);
            PDF417Barcode pdf417 = new PDF417Barcode();
            pdf417.CompactionMode = PDF417DataCompactionMode.Text;
            pdf417.Data = "ABCDEF";
            pdf417.Rows = 5;
            pdf417.Columns = 5;
            pdf417.XDimension = 1;
            pdf417.YDimension = 10;
            pdf417.ErrorCorrectionLevel = PDF417ErrorCorrectionLevel.Level2;
            page.Canvas.DrawBarcode(pdf417, 20, 380);

            doc.Save("Sample_Barcodes.pdf");
        }
    }
}


Barcodes.vb

PDF4NET Send comments on this topic.
Barcodes.vb
PDF4NET On-line Help > Samples > Barcodes > Barcodes.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Barcodes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.Barcodes
    ''' <summary>
    ''' This sample shows how to display barcodes in a PDF document.
    ''' </summary>
    Class Barcodes
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the PDF document
            Dim doc As New PDFDocument()

            ' Create the helper graphic objects.
            Dim titleFont As New PDFFont(PDFFontFace.Helvetica, 10)
            titleFont.Bold = True
            Dim textFont As New PDFFont(PDFFontFace.Helvetica, 8)
            Dim brush As New PDFBrush(New PDFRgbColor(Color.Black))

            ' First page for linear barcodes.
            Dim page As PDFPage = doc.AddPage()
            page.Canvas.DrawText("1D/Linear barcodes", titleFont, Nothing, brush, 20, 50)

            page.Canvas.DrawText("1. Codabar", textFont, Nothing, brush, 20, 70)
            Dim cb As New PDFCodabarBarcode("0123456789")
            page.Canvas.DrawBarcode(cb, 20, 80)

            page.Canvas.DrawText("2. Code 11", textFont, Nothing, brush, 20, 140)
            Dim c11 As New PDFCode11Barcode("0123456789")
            page.Canvas.DrawBarcode(c11, 20, 150)

            page.Canvas.DrawText("3. Code 128A", textFont, Nothing, brush, 20, 210)
            Dim c128a As New PDFCode128ABarcode("CODE128A")
            page.Canvas.DrawBarcode(c128a, 20, 220)

            page.Canvas.DrawText("4. Code 128B", textFont, Nothing, brush, 20, 280)
            Dim c128b As New PDFCode128BBarcode("CODE128B")
            page.Canvas.DrawBarcode(c128b, 20, 290)

            page.Canvas.DrawText("5. Code 128C", textFont, Nothing, brush, 20, 350)
            Dim c128c As New PDFCode128CBarcode("0123456789")
            page.Canvas.DrawBarcode(c128c, 20, 360)

            page.Canvas.DrawText("6. Code 25", textFont, Nothing, brush, 20, 420)
            Dim c25 As New PDFCode25Barcode("0123456789")
            page.Canvas.DrawBarcode(c25, 20, 430)

            page.Canvas.DrawText("7. Code 25 Interleaved", textFont, Nothing, brush, 20, 490)
            Dim c25i As New PDFCode25InterleavedBarcode("0123456789")
            page.Canvas.DrawBarcode(c25i, 20, 500)

            page.Canvas.DrawText("8. Code 39", textFont, Nothing, brush, 20, 560)
            Dim c39 As New PDFCode39Barcode("CODE39")
            page.Canvas.DrawBarcode(c39, 20, 570)

            page.Canvas.DrawText("9. Code 39 Extended", textFont, Nothing, brush, 20, 630)
            Dim c39x As New PDFCode39ExtendedBarcode("C39Ext")
            page.Canvas.DrawBarcode(c39x, 20, 640)

            page.Canvas.DrawText("10. Code 93", textFont, Nothing, brush, 20, 700)
            Dim c93 As New PDFCode93Barcode("CODE93")
            page.Canvas.DrawBarcode(c93, 20, 710)

            page.Canvas.DrawText("11. Code 93 Extended", textFont, Nothing, brush, 200, 70)
            Dim c93x As New PDFCode93ExtendedBarcode("C93Ext")
            page.Canvas.DrawBarcode(c93x, 200, 80)

            page.Canvas.DrawText("12. COOP 25", textFont, Nothing, brush, 200, 140)
            Dim coop25 As New PDFCOOP25Barcode("0123456789")
            page.Canvas.DrawBarcode(coop25, 200, 150)

            page.Canvas.DrawText("13. EAN-13", textFont, Nothing, brush, 200, 210)
            Dim ean13 As New PDFEAN13Barcode("012345678901")
            page.Canvas.DrawBarcode(ean13, 200, 220)

            page.Canvas.DrawText("14. EAN-8", textFont, Nothing, brush, 200, 280)
            Dim ean8 As New PDFEAN8Barcode("0123456")
            page.Canvas.DrawBarcode(ean8, 200, 290)

            page.Canvas.DrawText("15. IATA 25", textFont, Nothing, brush, 200, 350)
            Dim i25 As New PDFIATA25Barcode("0123456789")
            page.Canvas.DrawBarcode(i25, 200, 360)

            page.Canvas.DrawText("16. ISBN", textFont, Nothing, brush, 200, 420)
            Dim isbn As New PDFISBNBarcode("123456789")
            page.Canvas.DrawBarcode(isbn, 200, 430)

            page.Canvas.DrawText("17. ISMN", textFont, Nothing, brush, 200, 490)
            Dim ismn As New PDFISMNBarcode("123456789")
            page.Canvas.DrawBarcode(ismn, 200, 500)

            page.Canvas.DrawText("18. ISSN", textFont, Nothing, brush, 200, 560)
            Dim issn As New PDFISSNBarcode("123456789")
            page.Canvas.DrawBarcode(issn, 200, 570)

            page.Canvas.DrawText("19. JAN-13", textFont, Nothing, brush, 200, 630)
            Dim jan13 As New PDFJAN13Barcode("1234567890")
            page.Canvas.DrawBarcode(jan13, 200, 640)

            page.Canvas.DrawText("20. Matrix 25", textFont, Nothing, brush, 200, 700)
            Dim m25 As New PDFMatrix25Barcode("0123456789")
            page.Canvas.DrawBarcode(m25, 200, 710)

            page.Canvas.DrawText("21. Msi/Plessey", textFont, Nothing, brush, 350, 70)
            Dim msi As New PDFMSIPlesseyBarcode("0123456789")
            page.Canvas.DrawBarcode(msi, 350, 80)

            page.Canvas.DrawText("22. Planet", textFont, Nothing, brush, 350, 140)
            Dim planet As New PDFPlanetBarcode("012345678901")
            page.Canvas.DrawBarcode(planet, 350, 150)

            page.Canvas.DrawText("23. Postnet", textFont, Nothing, brush, 350, 210)
            Dim postnet As New PDFPostNetBarcode("012345678")
            page.Canvas.DrawBarcode(postnet, 350, 220)

            page.Canvas.DrawText("24. RM4SCC", textFont, Nothing, brush, 350, 280)
            Dim rm4scc As New PDFRM4SCCBarcode("RM4SCC")
            page.Canvas.DrawBarcode(rm4scc, 350, 290)

            page.Canvas.DrawText("25. SCC-14", textFont, Nothing, brush, 350, 350)
            Dim scc14 As New PDFSCC14Barcode("0123456789012")
            page.Canvas.DrawBarcode(scc14, 350, 360)

            page.Canvas.DrawText("26. SSCC-18", textFont, Nothing, brush, 350, 420)
            Dim sscc18 As New PDFSSCC18Barcode("00000012331234567")
            page.Canvas.DrawBarcode(sscc18, 350, 430)

            page.Canvas.DrawText("27. UPC-A", textFont, Nothing, brush, 350, 490)
            Dim upca As New PDFUPCABarcode("87567816412")
            upca.Supplement = "59999"
            upca.SupplementYDimension = 20
            upca.SupplementDisplayLocation = BarcodeTextLocation.Above
            page.Canvas.DrawBarcode(upca, 350, 500)

            page.Canvas.DrawText("28. UPC-E", textFont, Nothing, brush, 350, 560)
            Dim upce As New PDFUPCEBarcode("0425261")
            page.Canvas.DrawBarcode(upce, 350, 570)

            ' Second page for linear barcodes.
            page = doc.AddPage()
            page.Canvas.DrawText("1D/Linear barcodes (continued)", titleFont, Nothing, brush, 20, 50)

            page.Canvas.DrawText("29. Singapore Post", textFont, Nothing, brush, 20, 70)
            Dim singPost As New PDFSingaporePostBarcode("0123456789")
            page.Canvas.DrawBarcode(singPost, 20, 80)

            page.Canvas.DrawText("30. Royal Dutch TPG Post", textFont, Nothing, brush, 20, 140)
            Dim kix As New PDFKixBarcode("0123456789")
            page.Canvas.DrawBarcode(kix, 20, 150)

            page.Canvas.DrawText("31. PZN", textFont, Nothing, brush, 20, 210)
            Dim pzn As New PDFPZNBarcode("123456")
            page.Canvas.DrawBarcode(pzn, 20, 220)

            page.Canvas.DrawText("32. Deutsche Post Identcode", textFont, Nothing, brush, 20, 280)
            Dim identcode As New PDFIdentcodeBarcode("01234567890")
            page.Canvas.DrawBarcode(identcode, 20, 290)

            page.Canvas.DrawText("33. Deutsche Post Leitcode", textFont, Nothing, brush, 20, 350)
            Dim leitcode As New PDFLeitcodeBarcode("0123456789012")
            page.Canvas.DrawBarcode(leitcode, 20, 360)

            page.Canvas.DrawText("34. USPS Facing Identification Mark", textFont, Nothing, brush, 20, 420)
            Dim fim As New PDFUSPSFIMBarcode("A")
            page.Canvas.DrawBarcode(fim, 20, 430)

            page.Canvas.DrawText("35. USPS Horizontal Bars", textFont, Nothing, brush, 20, 490)
            Dim hb As New PDFUSPSHorizontalBarcode("111")
            page.Canvas.DrawBarcode(hb, 20, 500)

            page.Canvas.DrawText("36. USPS Package Identification Code", textFont, Nothing, brush, 20, 560)
            Dim pic As New PDFUSPSPICBarcode("910123456789012345678")
            page.Canvas.DrawBarcode(pic, 20, 570)

            page.Canvas.DrawText("37. FedEx Ground 96", textFont, Nothing, brush, 20, 630)
            Dim fg96 As New PDFFedExGround96Barcode("960123456789012345678")
            page.Canvas.DrawBarcode(fg96, 20, 640)

            page.Canvas.DrawText("38. Pharmacode", textFont, Nothing, brush, 20, 700)
            Dim pharma As New PDFPharmacodeBarcode("12345")
            page.Canvas.DrawBarcode(pharma, 20, 710)

            page.Canvas.DrawText("39. Code 32 - Italian Pharmacode", textFont, Nothing, brush, 200, 70)
            Dim c32 As New PDFCode32Barcode("12345678")
            page.Canvas.DrawBarcode(c32, 200, 80)

            page.Canvas.DrawText("40. UCC/EAN 128", textFont, Nothing, brush, 200, 140)
            Dim ean128 As New PDFEAN128Barcode("0123456789")
            ean128.ApplicationIdentifier = "101"
            page.Canvas.DrawBarcode(ean128, 200, 150)

            ' Create the 3rd page to display 2D barcodes.
            page = doc.AddPage()

            page.Canvas.DrawText("2D/Bidimensional barcodes", titleFont, Nothing, brush, 20, 50)

            page.Canvas.DrawText("1. Codablock F", textFont, Nothing, brush, 20, 70)
            Dim cf As New PDFCodablockFBarcode()
            cf.Rows = 5
            cf.Columns = 7
            cf.Data = "1234567890"
            page.Canvas.DrawBarcode(cf, 20, 80)

            page.Canvas.DrawText("2. Code 16K", textFont, Nothing, brush, 20, 140)
            Dim c16k As New PDFCode16KBarcode()
            c16k.Rows = 0
            c16k.Data = "Abcd-1234567890-wxyZ"
            page.Canvas.DrawBarcode(c16k, 20, 150)

            page.Canvas.DrawText("3. DataMatrix", textFont, Nothing, brush, 20, 210)
            Dim dm As New PDFDataMatrixBarcode()
            dm.Encoding = DataMatrixEncoding.ASCII
            dm.SymbolSize = DataMatrixSymbolSize.Auto
            dm.Data = "ABCDabcd"
            dm.XDimension = 3
            page.Canvas.DrawBarcode(dm, 20, 220)

            page.Canvas.DrawText("4. MicroPDF417", textFont, Nothing, brush, 20, 280)
            Dim mpdf417 As New PDFMicroPDF417Barcode()
            mpdf417.CompactionMode = PDF417DataCompactionMode.Text
            mpdf417.Data = "ABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZ" + "ABCDEFGHIJKLMNOPQRSTUVWXYZABCDEFGHIJKLMNOPQRSTUVWXYZAB"
            mpdf417.XDimension = 1
            mpdf417.YDimension = 2.5F
            mpdf417.SymbolSize = MicroPDF417SymbolSize.Size20x4
            page.Canvas.DrawBarcode(mpdf417, 20, 290)

            page.Canvas.DrawText("5. PDF417", textFont, Nothing, brush, 20, 370)
            Dim pdf417 As New PDF417Barcode()
            pdf417.CompactionMode = PDF417DataCompactionMode.Text
            pdf417.Data = "ABCDEF"
            pdf417.Rows = 5
            pdf417.Columns = 5
            pdf417.XDimension = 1
            pdf417.YDimension = 10
            pdf417.ErrorCorrectionLevel = PDF417ErrorCorrectionLevel.Level2
            page.Canvas.DrawBarcode(pdf417, 20, 380)

            doc.Save("Sample_Barcodes.pdf")
        End Sub
    End Class
End Namespace


Samples: Bezier

PDF4NET Send comments on this topic.
Samples: Bezier
PDF4NET On-line Help > Samples > Samples: Bezier

Glossary Item Box

This samples demonstrates the bezier splines drawing capabilities of the PDF4NET library. It creates a 1 page document. On the first page, it draws 50 bezier splines positioned at random locations. The colors of the bezier splines are generated randomly.

C# Source code | VB.NET Source code | PDF file


Bezier.cs

PDF4NET Send comments on this topic.
Bezier.cs
PDF4NET On-line Help > Samples > Bezier > Bezier.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.Bezier
{
    /// <summary>
    /// This sample will show how to draw Bezier splines
    /// on the page.
    /// </summary>
    class Bezier
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            // Create first page
            PDFPage pdfPage1 = pdfDoc.AddPage();

            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());

            Random rnd = new Random();
            for (int i = 0; i < 50; i++)
            {
                // Create random colors for drawing the spline
                PDFColor penColor = new PDFRgbColor((byte)rnd.Next(256),
                    (byte)rnd.Next(256), (byte)rnd.Next(256));

                // Create the pen to draw the border
                PDFPen randomPen = new PDFPen(penColor, 1);

                // Generate random control points
                float x1 = rnd.Next((int)pdfPage1.Width);
                float y1 = rnd.Next((int)pdfPage1.Height);
                float x2 = rnd.Next((int)pdfPage1.Width);
                float y2 = rnd.Next((int)pdfPage1.Height);
                float x3 = rnd.Next((int)pdfPage1.Width);
                float y3 = rnd.Next((int)pdfPage1.Height);
                float x4 = rnd.Next((int)pdfPage1.Width);
                float y4 = rnd.Next((int)pdfPage1.Height);

                // Draw the Bezier spline
                pdfPage1.Canvas.DrawBezier(randomPen, x1, y1, x2, y2, x3, y3, x4, y4);
            }

            // Draw a label
            pdfPage1.Canvas.DrawText("Random Bezier splines",
                fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft);

            // Save the document to disk
            pdfDoc.Save("Sample_Bezier.pdf");
        }
    }
}


Bezier.vb

PDF4NET Send comments on this topic.
Bezier.vb
PDF4NET On-line Help > Samples > Bezier > Bezier.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.Bezier
    ''' <summary>
    ''' This sample will show how to draw Bezier splines
    ''' on the page.
    ''' </summary>
    Class Bezier
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            ' Create first page
            Dim pdfPage1 As PDFPage = pdfDoc.AddPage()

            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())

            Dim rnd As New Random()
            Dim i As Integer = 0
            While i < 50
                ' Create random colors for drawing the spline
                Dim penColor As PDFColor = New PDFRgbColor(rnd.Next(256), rnd.Next(256), rnd.Next(256))

                ' Create the pen to draw the border
                Dim randomPen As New PDFPen(penColor, 1)

                ' Generate random control points
                Dim x1 As Double = rnd.NextDouble() * pdfPage1.Width
                Dim y1 As Double = rnd.NextDouble() * pdfPage1.Height
                Dim x2 As Double = rnd.NextDouble() * pdfPage1.Width
                Dim y2 As Double = rnd.NextDouble() * pdfPage1.Height
                Dim x3 As Double = rnd.NextDouble() * pdfPage1.Width
                Dim y3 As Double = rnd.NextDouble() * pdfPage1.Height
                Dim x4 As Double = rnd.NextDouble() * pdfPage1.Width
                Dim y4 As Double = rnd.NextDouble() * pdfPage1.Height

                ' Draw the Bezier spline
                pdfPage1.Canvas.DrawBezier(randomPen, x1, y1, x2, y2, x3, y3, x4, y4)
                i = i + 1
            End While

            ' Draw a label
            pdfPage1.Canvas.DrawText("Random Bezier splines", _
                fontText, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft)

            ' Save the document to disk
            pdfDoc.Save("Sample_Bezier.pdf")
        End Sub
    End Class
End Namespace


Samples: Bookmarks

PDF4NET Send comments on this topic.
Samples: Bookmarks
PDF4NET On-line Help > Samples > Samples: Bookmarks

Glossary Item Box

This samples demonstrates the bookmarks capabilities of the PDF4NET library. It creates a 10 pages document. Each page is considered to be a chapter. Each chapter has 2 sections, and each section has 3 paragraphs. Then, the sample builds the corresponding outlines tree, allowing to quickly navigate to each chapter / section / paragraph.

C# Source code | VB.NET Source code | PDF file


Bookmarks.cs

PDF4NET Send comments on this topic.
Bookmarks.cs
PDF4NET On-line Help > Samples > Bookmarks > Bookmarks.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;
using O2S.Components.PDF4NET.Actions;

namespace O2S.Samples.PDF4NET.Bookmarks
{
    /// <summary>
    /// This sample will show how to create a bookmarks/outlines tree
    /// for a document
    /// </summary>
    class Bookmarks
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the graphic objects
            PDFFont fontChapter = new PDFFont(PDFFontFace.Helvetica, 20);
            fontChapter.Bold = true;
            PDFFont fontSection = new PDFFont(PDFFontFace.Helvetica, 16);
            fontSection.Italic = true;
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());

            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            // Display the outlines when opening the document
            pdfDoc.DisplayMode = PDFDisplayMode.UseOutlines;

            // Create 10 pages
            for (int i = 0; i < 10; i++)
            {
                PDFPage pdfPage = pdfDoc.AddPage();
                pdfPage.Canvas.DrawText("Chapter " + (i + 1).ToString(),
                    fontChapter, null, blackBrush, 10, 10, 0, PDFTextAlign.TopLeft);
                pdfPage.Canvas.DrawText("Section " + (i + 1).ToString() + ".1",
                    fontSection, null, blackBrush, 20, 32, 0, PDFTextAlign.TopLeft);
                pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".1.1",
                    fontText, null, blackBrush, 30, 50, 0, PDFTextAlign.TopLeft);
                pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".1.2",
                    fontText, null, blackBrush, 30, 200, 0, PDFTextAlign.TopLeft);
                pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".1.3",
                    fontText, null, blackBrush, 30, 300, 0, PDFTextAlign.TopLeft);
                pdfPage.Canvas.DrawText("Section " + (i + 1).ToString() + ".2",
                    fontSection, null, blackBrush, 20, 400, 0, PDFTextAlign.TopLeft);
                pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".2.1",
                    fontText, null, blackBrush, 30, 420, 0, PDFTextAlign.TopLeft);
                pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".2.2",
                    fontText, null, blackBrush, 30, 570, 0, PDFTextAlign.TopLeft);
                pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".2.3",
                    fontText, null, blackBrush, 30, 650, 0, PDFTextAlign.TopLeft);
            }

            // Create the bookmarks tree
            // Create a root outline
            PDFBookmark root = CreateBookmark("Bookmarks", new PDFRgbColor(Color.Black), PDFBookmarkDisplayStyle.Bold, pdfDoc.Pages[0]);
            pdfDoc.Bookmarks.Add(root);

            // Create document bookmarks
            for (int i = 0; i < pdfDoc.Pages.Count; i++)
            {
                // Create chapter bookmark
                PDFBookmark chapter = CreateBookmark("Chapter " + (i + 1).ToString(),
                    new PDFRgbColor(Color.Blue), PDFBookmarkDisplayStyle.Italic, pdfDoc.Pages[i]);
                root.Bookmarks.Add(chapter);
                // Create section 1 bookmark
                PDFBookmark section1 = CreateBookmark("Section " + (i + 1).ToString() + ".1",
                    new PDFRgbColor(Color.Green), PDFBookmarkDisplayStyle.Italic, pdfDoc.Pages[i]);
                chapter.Bookmarks.Add(section1);
                // Create paragraph bookmarks
                PDFBookmark paragraph11 = CreateBookmark("Paragraph " + (i + 1).ToString() + ".1.1",
                    new PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages[i]);
                section1.Bookmarks.Add(paragraph11);
                PDFBookmark paragraph12 = CreateBookmark("Paragraph " + (i + 1).ToString() + ".1.2",
                    new PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages[i]);
                section1.Bookmarks.Add(paragraph12);
                PDFBookmark paragraph13 = CreateBookmark("Paragraph " + (i + 1).ToString() + ".1.3",
                    new PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages[i]);
                section1.Bookmarks.Add(paragraph13);
                section1.Expanded = true;

                // Create section 2 bookmark
                PDFBookmark section2 = CreateBookmark("Section " + (i + 1).ToString() + ".2",
                    new PDFRgbColor(Color.Green), PDFBookmarkDisplayStyle.Italic, pdfDoc.Pages[i]);
                chapter.Bookmarks.Add(section2);
                // Create paragraph bookmarks
                PDFBookmark paragraph21 = CreateBookmark("Paragraph " + (i + 1).ToString() + ".2.1",
                    new PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages[i]);
                section2.Bookmarks.Add(paragraph21);
                PDFBookmark paragraph22 = CreateBookmark("Paragraph " + (i + 1).ToString() + ".2.2",
                    new PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages[i]);
                section2.Bookmarks.Add(paragraph22);
                PDFBookmark paragraph23 = CreateBookmark("Paragraph " + (i + 1).ToString() + ".2.3",
                    new PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages[i]);
                section2.Bookmarks.Add(paragraph23);
                section2.Expanded = true;

                chapter.Expanded = true;
            }

            root.Expanded = true;

            // Save the document to disk
            pdfDoc.Save("Sample_Bookmarks.pdf");
        }
        /// <summary>
        /// Creates a new bookmark and adds it at the end of the collection.
        /// </summary>
        /// <param name="title">the title of the bookmark</param>
        /// <param name="bookmarkColor">a <see cref="PDFRgbColor"/> object specifying
        /// the color used to draw the bookmark in the bookmark tree.</param>
        /// <param name="displayStyle">a combination of <see cref="PDFBookmarkDisplayStyle"/>
        /// enumeration members, specifying the font style used to draw
        /// the bookmark title.</param>
        /// <param name="destinationPage">a <see cref="PDFPage"/> object
        /// representing the destination of the bookmark.</param>
        /// <returns>a <see cref="PDFBookmark"/> object representing the
        /// newly created bookmark.</returns>
        public static PDFBookmark CreateBookmark(string title,
            PDFRgbColor bookmarkColor, PDFBookmarkDisplayStyle displayStyle, PDFPage destinationPage)
        {
            PDFBookmark bookmark = new PDFBookmark();
            bookmark.Title = title;
            bookmark.Color = bookmarkColor;
            bookmark.DisplayStyle = displayStyle;

            PDFGoToAction gotoAction = new PDFGoToAction();
            gotoAction.Destination = new PDFPageDestination();
            gotoAction.Destination.Page = destinationPage;
            bookmark.Action = gotoAction;

            return bookmark;
        }
    }
}


Bookmarks.vb

PDF4NET Send comments on this topic.
Bookmarks.vb
PDF4NET On-line Help > Samples > Bookmarks > Bookmarks.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts
Imports O2S.Components.PDF4NET.Actions

Namespace O2S.Samples.PDF4NET.Bookmarks
    ''' <summary>
    ''' This sample will show how to create a bookmarks/outlines tree
    ''' for a document
    ''' </summary>
    Class Bookmarks
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the graphic objects
            Dim fontChapter As New PDFFont(PDFFontFace.Helvetica, 20)
            fontChapter.Bold = True
            Dim fontSection As New PDFFont(PDFFontFace.Helvetica, 16)
            fontSection.Italic = True
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())

            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            ' Display the outlines when opening the document
            pdfDoc.DisplayMode = PDFDisplayMode.UseOutlines

            ' Create 10 pages
            Dim i As Integer = 0
            While i < 10
                Dim pdfPage As PDFPage = pdfDoc.AddPage()
                pdfPage.Canvas.DrawText("Chapter " + (i + 1).ToString(), fontChapter, Nothing, blackBrush, 10, 10, _
                    0, PDFTextAlign.TopLeft)
                pdfPage.Canvas.DrawText("Section " + (i + 1).ToString() + ".1", fontSection, Nothing, blackBrush, 20, 32, _
                    0, PDFTextAlign.TopLeft)
                pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".1.1", fontText, Nothing, blackBrush, 30, 50, _
                    0, PDFTextAlign.TopLeft)
                pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".1.2", fontText, Nothing, blackBrush, 30, 200, _
                    0, PDFTextAlign.TopLeft)
                pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".1.3", fontText, Nothing, blackBrush, 30, 300, _
                    0, PDFTextAlign.TopLeft)
                pdfPage.Canvas.DrawText("Section " + (i + 1).ToString() + ".2", fontSection, Nothing, blackBrush, 20, 400, _
                    0, PDFTextAlign.TopLeft)
                pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".2.1", fontText, Nothing, blackBrush, 30, 420, _
                    0, PDFTextAlign.TopLeft)
                pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".2.2", fontText, Nothing, blackBrush, 30, 570, _
                    0, PDFTextAlign.TopLeft)
                pdfPage.Canvas.DrawText("Paragraph " + (i + 1).ToString() + ".2.3", fontText, Nothing, blackBrush, 30, 650, _
                    0, PDFTextAlign.TopLeft)
                i = i + 1
            End While

            ' Create the bookmarks tree
            ' Create a root outline
            Dim root As PDFBookmark = CreateBookmark("Bookmarks", New PDFRgbColor(Color.Black), PDFBookmarkDisplayStyle.Bold, pdfDoc.Pages(0))
            pdfDoc.Bookmarks.Add(root)

            ' Create document bookmarks
            i = 0
            While i < pdfDoc.Pages.Count
                ' Create chapter bookmark
                Dim chapter As PDFBookmark = CreateBookmark("Chapter " + (i + 1).ToString(), New PDFRgbColor(Color.Blue), PDFBookmarkDisplayStyle.Italic, pdfDoc.Pages(i))
                root.Bookmarks.Add(chapter)
                ' Create section 1 bookmark
                Dim section1 As PDFBookmark = CreateBookmark("Section " + (i + 1).ToString() + ".1", New PDFRgbColor(Color.Green), PDFBookmarkDisplayStyle.Italic, pdfDoc.Pages(i))
                chapter.Bookmarks.Add(section1)
                ' Create paragraph bookmarks
                Dim paragraph11 As PDFBookmark = CreateBookmark("Paragraph " + (i + 1).ToString() + ".1.1", New PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages(i))
                section1.Bookmarks.Add(paragraph11)
                Dim paragraph12 As PDFBookmark = CreateBookmark("Paragraph " + (i + 1).ToString() + ".1.2", New PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages(i))
                section1.Bookmarks.Add(paragraph12)
                Dim paragraph13 As PDFBookmark = CreateBookmark("Paragraph " + (i + 1).ToString() + ".1.3", New PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages(i))
                section1.Bookmarks.Add(paragraph13)
                section1.Expanded = True

                ' Create section 2 bookmark
                Dim section2 As PDFBookmark = CreateBookmark("Section " + (i + 1).ToString() + ".2", New PDFRgbColor(Color.Green), PDFBookmarkDisplayStyle.Italic, pdfDoc.Pages(i))
                chapter.Bookmarks.Add(section2)
                ' Create paragraph bookmarks
                Dim paragraph21 As PDFBookmark = CreateBookmark("Paragraph " + (i + 1).ToString() + ".2.1", New PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages(i))
                section2.Bookmarks.Add(paragraph21)
                Dim paragraph22 As PDFBookmark = CreateBookmark("Paragraph " + (i + 1).ToString() + ".2.2", New PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages(i))
                section2.Bookmarks.Add(paragraph22)
                Dim paragraph23 As PDFBookmark = CreateBookmark("Paragraph " + (i + 1).ToString() + ".2.3", New PDFRgbColor(Color.Red), PDFBookmarkDisplayStyle.Regular, pdfDoc.Pages(i))
                section2.Bookmarks.Add(paragraph23)
                section2.Expanded = True

                chapter.Expanded = True
                i = i + 1
            End While

            root.Expanded = True

            ' Save the document to disk
            pdfDoc.Save("Sample_Bookmarks.pdf")
        End Sub
        ''' <summary>
        ''' Creates a new bookmark and adds it at the end of the collection.
        ''' </summary>
        ''' <param name="title">the title of the bookmark</param>
        ''' <param name="bookmarkColor">a <see cref="PDFRgbColor"/> object specifying
        ''' the color used to draw the bookmark in the bookmark tree.</param>
        ''' <param name="displayStyle">a combination of <see cref="PDFBookmarkDisplayStyle"/>
        ''' enumeration members, specifying the font style used to draw
        ''' the bookmark title.</param>
        ''' <param name="destinationPage">a <see cref="PDFPage"/> object
        ''' representing the destination of the bookmark.</param>
        ''' <returns>a <see cref="PDFBookmark"/> object representing the
        ''' newly created bookmark.</returns>
        Public Shared Function CreateBookmark(title As String, bookmarkColor As PDFRgbColor, displayStyle As PDFBookmarkDisplayStyle, destinationPage As PDFPage) As PDFBookmark
            Dim bookmark As New PDFBookmark()
            bookmark.Title = title
            bookmark.Color = bookmarkColor
            bookmark.DisplayStyle = displayStyle

            Dim gotoAction As New PDFGoToAction()
            gotoAction.Destination = New PDFPageDestination()
            gotoAction.Destination.Page = destinationPage
            bookmark.Action = gotoAction

            Return bookmark
        End Function
    End Class
End Namespace


Samples: CharacterMap

PDF4NET Send comments on this topic.
Samples: CharacterMap
PDF4NET On-line Help > Samples > Samples: CharacterMap

Glossary Item Box

This samples prints all the font glyphs in a standard latin font, as they are represented by the pdf. For each glyph, its decimal and hex code are printed. On the second page, it prints all the glyphs in Symbol font, together with their decimal and hex codes. The third page is similar to second page, but it uses the ZapfDingbats font.

C# Source code | VB.NET Source code | PDF file


CharacterMap.cs

PDF4NET Send comments on this topic.
CharacterMap.cs
PDF4NET On-line Help > Samples > CharacterMap > CharacterMap.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.CharacterMap
{
    /// <summary>
    /// This sample prints all available characters in WinAnsiEncoding, plus
    /// those available in ZapfDingbats and Symbol fonts.
    /// </summary>
    class CharacterMap
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            DrawFirstPage(pdfDoc);
            DrawSecondPage(pdfDoc);
            DrawThirdPage(pdfDoc);

            // Save the document to disk
            pdfDoc.Save("Sample_CharacterMap.pdf");
        }

        private static void DrawFirstPage(PDFDocument pdfDoc)
        {
            PDFPage pdfPage = pdfDoc.AddPage();

            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFFont fontCode = new PDFFont(PDFFontFace.Helvetica, 11);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());

            pdfPage.Canvas.DrawText("Latin font - WinAnsiEncoding", fontText, null, blackBrush,
                10, 30, 0, PDFTextAlign.TopLeft);

            // Draw the header for the first column
            pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 10, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 70, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 100, 50, 0, PDFTextAlign.TopLeft);
            // Draw the header for the second column
            pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 170, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 230, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 260, 50, 0, PDFTextAlign.TopLeft);
            // Draw the header for the third column
            pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 330, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 390, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 420, 50, 0, PDFTextAlign.TopLeft);
            // Draw the header for the fourth column
            pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 490, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 550, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 580, 50, 0, PDFTextAlign.TopLeft);

            // Draw the codes and characters
            float xDec = 10;
            float xHex = 70;
            float xChar = 100;
            float xDelta = 160;
            float y = 65;
            byte i = 31;
            while (i <= 255)
            {
                i++;
                if (((i - 32) % 60 == 0) && i != 32)
                {
                    xDec = xDec + xDelta;
                    xHex = xHex + xDelta;
                    xChar = xChar + xDelta;
                    y = 65;
                }

                char c = (char)i;
                pdfPage.Canvas.DrawText(i.ToString(), fontCode, null, blackBrush, xDec, y, 0, PDFTextAlign.TopLeft);
                pdfPage.Canvas.DrawText("\\x" + i.ToString("X"),
                    fontCode, null, blackBrush, xHex, y, 0, PDFTextAlign.TopLeft);
                pdfPage.Canvas.DrawText(c.ToString(), fontCode, null, blackBrush, xChar, y, 0, PDFTextAlign.TopLeft);
                y = y + 12;

                if (i == 255)
                {
                    break;
                }
            }
        }

        private static void DrawSecondPage(PDFDocument pdfDoc)
        {
            // Create second page
            PDFPage pdfPage = pdfDoc.AddPage();

            // Create the graphic objects
            PDFFont fontChar = new PDFFont(PDFFontFace.Symbol, 11);
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());
            PDFFont fontCode = new PDFFont(PDFFontFace.Helvetica, 11);

            pdfPage.Canvas.DrawText("Symbol font", fontText, null, blackBrush,
                10, 30, 0, PDFTextAlign.TopLeft);

            // Draw the header for the first column
            pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 10, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 70, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 100, 50, 0, PDFTextAlign.TopLeft);
            // Draw the header for the second column
            pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 170, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 230, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 260, 50, 0, PDFTextAlign.TopLeft);
            // Draw the header for the third column
            pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 330, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 390, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 420, 50, 0, PDFTextAlign.TopLeft);
            // Draw the header for the fourth column
            pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 490, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 550, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 580, 50, 0, PDFTextAlign.TopLeft);

            // Draw the codes and characters
            float xDec = 10;
            float xHex = 70;
            float xChar = 100;
            float xDelta = 160;
            float y = 65;
            byte i = 31;
            while (i <= 255)
            {
                i++;
                if (((i - 32) % 60 == 0) && i != 32)
                {
                    xDec = xDec + xDelta;
                    xHex = xHex + xDelta;
                    xChar = xChar + xDelta;
                    y = 65;
                }

                char c = (char)i;
                pdfPage.Canvas.DrawText(i.ToString(), fontCode, null, blackBrush, xDec, y, 0, PDFTextAlign.TopLeft);
                pdfPage.Canvas.DrawText("\\x" + i.ToString("X"), fontCode, null, blackBrush, xHex, y, 0, PDFTextAlign.TopLeft);
                pdfPage.Canvas.DrawText(c.ToString(), fontChar, null, blackBrush, xChar, y, 0, PDFTextAlign.TopLeft);
                y = y + 12;

                if (i == 255)
                {
                    break;
                }
            }
        }

        private static void DrawThirdPage(PDFDocument pdfDoc)
        {
            // Create first page
            PDFPage pdfPage = pdfDoc.AddPage();

            // Create the graphic objects
            PDFFont fontChar = new PDFFont(PDFFontFace.ZapfDingbats, 11);
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFFont fontCode = new PDFFont(PDFFontFace.Helvetica, 11);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());

            pdfPage.Canvas.DrawText("ZapfDingbats font", fontText, null, blackBrush, 10, 30, 0, PDFTextAlign.TopLeft);

            // Draw the header for the first column
            pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 10, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 70, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 100, 50, 0, PDFTextAlign.TopLeft);
            // Draw the header for the second column
            pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 170, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 230, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 260, 50, 0, PDFTextAlign.TopLeft);
            // Draw the header for the third column
            pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 330, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 390, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 420, 50, 0, PDFTextAlign.TopLeft);
            // Draw the header for the fourth column
            pdfPage.Canvas.DrawText("Decimal", fontText, null, blackBrush, 490, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Hex", fontText, null, blackBrush, 550, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Char", fontText, null, blackBrush, 580, 50, 0, PDFTextAlign.TopLeft);

            // Draw the codes and characters
            float xDec = 10;
            float xHex = 70;
            float xChar = 100;
            float xDelta = 160;
            float y = 65;
            byte i = 31;
            while (i <= 255)
            {
                i++;
                if (((i - 32) % 60 == 0) && i != 32)
                {
                    xDec = xDec + xDelta;
                    xHex = xHex + xDelta;
                    xChar = xChar + xDelta;
                    y = 65;
                }

                char c = (char)i;
                pdfPage.Canvas.DrawText(i.ToString(), fontCode, null, blackBrush, xDec, y, 0, PDFTextAlign.TopLeft);
                pdfPage.Canvas.DrawText("\\x" + i.ToString("X"), fontCode, null, blackBrush, xHex, y, 0, PDFTextAlign.TopLeft);
                pdfPage.Canvas.DrawText(c.ToString(), fontChar, null, blackBrush, xChar, y, 0, PDFTextAlign.TopLeft);
                y = y + 12;

                if (i == 255)
                {
                    break;
                }
            }
        }
    }
}


CharacterMap.vb

PDF4NET Send comments on this topic.
CharacterMap.vb
PDF4NET On-line Help > Samples > CharacterMap > CharacterMap.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.CharacterMap
    ''' <summary>
    ''' This sample prints all available characters in WinAnsiEncoding, plus
    ''' those available in ZapfDingbats and Symbol fonts.
    ''' </summary>
    Class CharacterMap
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            DrawFirstPage(pdfDoc)
            DrawSecondPage(pdfDoc)
            DrawThirdPage(pdfDoc)

            ' Save the document to disk
            pdfDoc.Save("Sample_CharacterMap.pdf")
        End Sub

        Private Shared Sub DrawFirstPage(pdfDoc As PDFDocument)
            Dim pdfPage As PDFPage = pdfDoc.AddPage()

            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim fontCode As New PDFFont(PDFFontFace.Helvetica, 11)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())

            pdfPage.Canvas.DrawText("Latin font - WinAnsiEncoding", fontText, Nothing, blackBrush, 10, 30, _
                0, PDFTextAlign.TopLeft)

            ' Draw the header for the first column
            pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 10, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 70, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 100, 50, _
                0, PDFTextAlign.TopLeft)
            ' Draw the header for the second column
            pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 170, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 230, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 260, 50, _
                0, PDFTextAlign.TopLeft)
            ' Draw the header for the third column
            pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 330, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 390, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 420, 50, _
                0, PDFTextAlign.TopLeft)
            ' Draw the header for the fourth column
            pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 490, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 550, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 580, 50, _
                0, PDFTextAlign.TopLeft)

            ' Draw the codes and characters
            Dim xDec As Single = 10
            Dim xHex As Single = 70
            Dim xChar As Single = 100
            Dim xDelta As Single = 160
            Dim y As Single = 65
            Dim i As Byte = 31
            While i <= 255
                i = i + 1
                If ((i - 32) Mod 60 = 0) AndAlso i <> 32 Then
                    xDec = xDec + xDelta
                    xHex = xHex + xDelta
                    xChar = xChar + xDelta
                    y = 65
                End If

                Dim c As Char = Microsoft.VisualBasic.ChrW(i)
                pdfPage.Canvas.DrawText(i.ToString(), fontCode, Nothing, blackBrush, xDec, y, _
                    0, PDFTextAlign.TopLeft)
                pdfPage.Canvas.DrawText("\x" + i.ToString("X"), fontCode, Nothing, blackBrush, xHex, y, _
                    0, PDFTextAlign.TopLeft)
                pdfPage.Canvas.DrawText(c.ToString(), fontCode, Nothing, blackBrush, xChar, y, _
                    0, PDFTextAlign.TopLeft)
                y = y + 12

                If i = 255 Then
                    Exit While
                End If
            End While
        End Sub

        Private Shared Sub DrawSecondPage(pdfDoc As PDFDocument)
            ' Create second page
            Dim pdfPage As PDFPage = pdfDoc.AddPage()

            ' Create the graphic objects
            Dim fontChar As New PDFFont(PDFFontFace.Symbol, 11)
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())
            Dim fontCode As New PDFFont(PDFFontFace.Helvetica, 11)

            pdfPage.Canvas.DrawText("Symbol font", fontText, Nothing, blackBrush, 10, 30, _
                0, PDFTextAlign.TopLeft)

            ' Draw the header for the first column
            pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 10, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 70, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 100, 50, _
                0, PDFTextAlign.TopLeft)
            ' Draw the header for the second column
            pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 170, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 230, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 260, 50, _
                0, PDFTextAlign.TopLeft)
            ' Draw the header for the third column
            pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 330, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 390, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 420, 50, _
                0, PDFTextAlign.TopLeft)
            ' Draw the header for the fourth column
            pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 490, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 550, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 580, 50, _
                0, PDFTextAlign.TopLeft)

            ' Draw the codes and characters
            Dim xDec As Single = 10
            Dim xHex As Single = 70
            Dim xChar As Single = 100
            Dim xDelta As Single = 160
            Dim y As Single = 65
            Dim i As Byte = 31
            While i <= 255
                i = i + 1
                If ((i - 32) Mod 60 = 0) AndAlso i <> 32 Then
                    xDec = xDec + xDelta
                    xHex = xHex + xDelta
                    xChar = xChar + xDelta
                    y = 65
                End If

                Dim c As Char = Microsoft.VisualBasic.ChrW(i)
                pdfPage.Canvas.DrawText(i.ToString(), fontCode, Nothing, blackBrush, xDec, y, _
                    0, PDFTextAlign.TopLeft)
                pdfPage.Canvas.DrawText("\x" + i.ToString("X"), fontCode, Nothing, blackBrush, xHex, y, _
                    0, PDFTextAlign.TopLeft)
                pdfPage.Canvas.DrawText(c.ToString(), fontChar, Nothing, blackBrush, xChar, y, _
                    0, PDFTextAlign.TopLeft)
                y = y + 12

                If i = 255 Then
                    Exit While
                End If
            End While
        End Sub

        Private Shared Sub DrawThirdPage(pdfDoc As PDFDocument)
            ' Create first page
            Dim pdfPage As PDFPage = pdfDoc.AddPage()

            ' Create the graphic objects
            Dim fontChar As New PDFFont(PDFFontFace.ZapfDingbats, 11)
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim fontCode As New PDFFont(PDFFontFace.Helvetica, 11)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())

            pdfPage.Canvas.DrawText("ZapfDingbats font", fontText, Nothing, blackBrush, 10, 30, _
                0, PDFTextAlign.TopLeft)

            ' Draw the header for the first column
            pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 10, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 70, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 100, 50, _
                0, PDFTextAlign.TopLeft)
            ' Draw the header for the second column
            pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 170, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 230, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 260, 50, _
                0, PDFTextAlign.TopLeft)
            ' Draw the header for the third column
            pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 330, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 390, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 420, 50, _
                0, PDFTextAlign.TopLeft)
            ' Draw the header for the fourth column
            pdfPage.Canvas.DrawText("Decimal", fontText, Nothing, blackBrush, 490, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Hex", fontText, Nothing, blackBrush, 550, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Char", fontText, Nothing, blackBrush, 580, 50, _
                0, PDFTextAlign.TopLeft)

            ' Draw the codes and characters
            Dim xDec As Single = 10
            Dim xHex As Single = 70
            Dim xChar As Single = 100
            Dim xDelta As Single = 160
            Dim y As Single = 65
            Dim i As Byte = 31
            While i <= 255
                i = i + 1
                If ((i - 32) Mod 60 = 0) AndAlso i <> 32 Then
                    xDec = xDec + xDelta
                    xHex = xHex + xDelta
                    xChar = xChar + xDelta
                    y = 65
                End If

                Dim c As Char = Microsoft.VisualBasic.ChrW(i)
                pdfPage.Canvas.DrawText(i.ToString(), fontCode, Nothing, blackBrush, xDec, y, _
                    0, PDFTextAlign.TopLeft)
                pdfPage.Canvas.DrawText("\x" + i.ToString("X"), fontCode, Nothing, blackBrush, xHex, y, _
                    0, PDFTextAlign.TopLeft)
                pdfPage.Canvas.DrawText(c.ToString(), fontChar, Nothing, blackBrush, xChar, y, _
                    0, PDFTextAlign.TopLeft)
                y = y + 12

                If i = 255 Then
                    Exit While
                End If
            End While
        End Sub
    End Class
End Namespace


Samples: ColorSpaces

PDF4NET Send comments on this topic.
Samples: ColorSpaces
PDF4NET On-line Help > Samples > Samples: ColorSpaces

Glossary Item Box

This sample shows how to work with various PDF colorspaces. New color classes have been introduced to allow creation of colors based on specific colorspaces. The new colors can be used instead of existing PDFColor objects.

C# Source code | VB.NET Source code | PDF file


ColorSpaces.cs

PDF4NET Send comments on this topic.
ColorSpaces.cs
PDF4NET On-line Help > Samples > ColorSpaces > ColorSpaces.cs

Glossary Item Box

using System;
using System.IO;
using System.Text;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Functions;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.ColorSpaces;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET
{
    /// <summary>
    /// This sample shows how to work with various PDF colorspaces when creating a PDF document.
    /// </summary>
    class ColorSpaces
    {
        [STAThread]
        static void Main(string[] args)
        {
            PDFDocument doc = new PDFDocument();

            PDFPage page = doc.AddPage();
            DrawDeviceColorSpace(page);

            page = doc.AddPage();
            DrawIndexedColorSpace(page);

            page = doc.AddPage();
            DrawCalGrayColorSpace(page);

            page = doc.AddPage();
            DrawCalRgbColorSpace(page);

            page = doc.AddPage();
            DrawLabColorSpace(page);

            page = doc.AddPage();
            DrawICCColorSpace(page);

            page = doc.AddPage();
            DrawSeparationColorSpace(page);

            doc.Save("Sample_ColorSpaces.pdf");
        }

        /// <summary>
        /// Draws content on a page using colors created from a device colorspace.
        /// </summary>
        /// <param name="page">The page to draw to.</param>
        /// <remarks>RGB, CMYK and Gray are device colorspaces.
        /// The PDFRgbColor, PDFCmykColor and PDFGrayColor classes create automatically the
        /// required colorspaces.</remarks>
        private static void DrawDeviceColorSpace(PDFPage page)
        {
            PDFRgbColor black = new PDFRgbColor(0, 0, 0);
            PDFBrush blackBrush = new PDFBrush(black);
            PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16);

            page.Canvas.DrawText("Device colorspaces: RGB, CMYK and Gray", font, null, blackBrush, 50, 50);

            // Draw RGB content.
            page.Canvas.DrawText("RGB", font, null, blackBrush, 50, 80);
            PDFRgbColor red = new PDFRgbColor(255, 0, 0);
            PDFRgbColor blue = new PDFRgbColor(0, 0, 255);
            PDFBrush redBrush = new PDFBrush(red);
            PDFPen bluePen = new PDFPen(blue, 5);
            page.Canvas.DrawRoundRectangle(bluePen, redBrush, 50, 100, 400, 150, 20, 20);

            // Draw CMYK content.
            page.Canvas.DrawText("CMYK", font, null, blackBrush, 50, 280);
            PDFCmykColor cyan = new PDFCmykColor(1, 0, 0, 0);
            PDFCmykColor magenta = new PDFCmykColor(0, 1, 0, 0);
            PDFBrush cyanBrush = new PDFBrush(cyan);
            PDFPen magentaPen = new PDFPen(magenta, 5);
            page.Canvas.DrawRoundRectangle(magentaPen, cyanBrush, 50, 300, 400, 150, 20, 20);

            // Draw Gray content.
            page.Canvas.DrawText("Gray", font, null, blackBrush, 50, 480);
            PDFGrayColor lightGray = new PDFGrayColor(0.85);
            PDFGrayColor darkGray = new PDFGrayColor(0.1);
            PDFBrush lgBrush = new PDFBrush(lightGray);
            PDFPen dgPen = new PDFPen(darkGray, 5);
            page.Canvas.DrawRoundRectangle(dgPen, lgBrush, 50, 500, 400, 150, 20, 20);
        }

        /// <summary>
        /// Draws content on a page using colors created from an indexed colorspace.
        /// </summary>
        /// <param name="page">The page to draw to.</param>
        private static void DrawIndexedColorSpace(PDFPage page)
        {
            PDFRgbColor black = new PDFRgbColor(0, 0, 0);
            PDFBrush blackBrush = new PDFBrush(black);
            PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16);

            page.Canvas.DrawText("Indexed colorspace with 2 colors", font, null, blackBrush, 50, 50);

            // Create an indexed colorspace with 2 RGB colors, 24bits (3*8bytes) per color.
            PDFIndexedColorSpace ixCS = new PDFIndexedColorSpace();
            ixCS.MaxIndex = 1;
            ixCS.ColorTable = new byte[] { 255, 0, 0, 192, 0, 255 };
            PDFIndexedColor red = new PDFIndexedColor(ixCS);
            red.ColorIndex = 0;
            PDFIndexedColor violet = new PDFIndexedColor(ixCS);
            violet.ColorIndex = 1;
            PDFBrush redBrush = new PDFBrush(red);
            PDFPen violetPen = new PDFPen(violet, 5);
            page.Canvas.DrawRoundRectangle(violetPen, redBrush, 50, 100, 400, 150, 20, 20);
        }

        /// <summary>
        /// Draws content on a page using colors created from a calibrated gray colorspace.
        /// </summary>
        /// <param name="page">The page to draw to.</param>
        private static void DrawCalGrayColorSpace(PDFPage page)
        {
            PDFRgbColor black = new PDFRgbColor(0, 0, 0);
            PDFBrush blackBrush = new PDFBrush(black);
            PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16);

            page.Canvas.DrawText("CalGray colorspace", font, null, blackBrush, 50, 50);

            PDFCalGrayColorSpace calGrayCS = new PDFCalGrayColorSpace();
            PDFCalGrayColor dkGray = new PDFCalGrayColor(calGrayCS);
            dkGray.Gray = 0.1;
            PDFCalGrayColor ltGray = new PDFCalGrayColor(calGrayCS);
            ltGray.Gray = 0.8;
            PDFBrush dkBrush = new PDFBrush(dkGray);
            PDFPen ltPen = new PDFPen(ltGray, 5);
            page.Canvas.DrawRoundRectangle(ltPen, dkBrush, 50, 100, 400, 150, 20, 20);
        }

        /// <summary>
        /// Draws content on a page using colors created from a calibrated RGB colorspace.
        /// </summary>
        /// <param name="page">The page to draw to.</param>
        private static void DrawCalRgbColorSpace(PDFPage page)
        {
            PDFRgbColor black = new PDFRgbColor(0, 0, 0);
            PDFBrush blackBrush = new PDFBrush(black);
            PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16);

            page.Canvas.DrawText("CalRGB colorspace", font, null, blackBrush, 50, 50);

            PDFCalRgbColorSpace calRgbCS = new PDFCalRgbColorSpace();
            PDFCalRgbColor red = new PDFCalRgbColor(calRgbCS);
            red.Red = 1;
            red.Green = 0;
            red.Blue = 0;
            PDFCalRgbColor blue = new PDFCalRgbColor(calRgbCS);
            blue.Red = 0;
            blue.Green = 0;
            blue.Blue = 1;
            PDFBrush blueBrush = new PDFBrush(blue);
            PDFPen redPen = new PDFPen(red, 5);
            page.Canvas.DrawRoundRectangle(redPen, blueBrush, 50, 100, 400, 150, 20, 20);
        }

        /// <summary>
        /// Draws content on a page using colors created from a calibrated Lab colorspace.
        /// </summary>
        /// <param name="page">The page to draw to.</param>
        private static void DrawLabColorSpace(PDFPage page)
        {
            PDFRgbColor black = new PDFRgbColor(0, 0, 0);
            PDFBrush blackBrush = new PDFBrush(black);
            PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16);

            page.Canvas.DrawText("L*a*b* colorspace", font, null, blackBrush, 50, 50);

            PDFLabColorSpace labCS = new PDFLabColorSpace();
            PDFLabColor labClr1 = new PDFLabColor(labCS);
            labClr1.L = 90;
            labClr1.A = 20;
            labClr1.B = -10;
            PDFLabColor labClr2 = new PDFLabColor(labCS);
            labClr2.L = 10;
            labClr2.A = 70;
            labClr2.B = -50;
            PDFBrush brush = new PDFBrush(labClr1);
            PDFPen pen = new PDFPen(labClr2, 5);
            page.Canvas.DrawRoundRectangle(pen, brush, 50, 100, 400, 150, 20, 20);
        }

        /// <summary>
        /// Draws content on a page using colors created from a calibrated ICC colorspace.
        /// </summary>
        /// <param name="page">The page to draw to.</param>
        private static void DrawICCColorSpace(PDFPage page)
        {
            PDFRgbColor black = new PDFRgbColor(0, 0, 0);
            PDFBrush blackBrush = new PDFBrush(black);
            PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16);

            page.Canvas.DrawText("ICC colorspace", font, null, blackBrush, 50, 50);

            // Read the ICC profile from disk.
            FileStream fs = new FileStream("..\\SupportFiles\\rgb.icc", FileMode.Open, FileAccess.Read);
            byte[] profileData = new byte[fs.Length];
            fs.Read(profileData, 0, profileData.Length);
            fs.Close();

            PDFICCColorSpace iccCS = new PDFICCColorSpace();
            iccCS.ProfileData = profileData;
            PDFICCColor red = new PDFICCColor(iccCS);
            red.ColorComponents = new double[] { 192, 0, 0 };
            PDFICCColor blue = new PDFICCColor(iccCS);
            blue.ColorComponents = new double[] { 0, 0, 192 };
            PDFBrush blueBrush = new PDFBrush(blue);
            PDFPen redPen = new PDFPen(red, 5);
            page.Canvas.DrawRoundRectangle(redPen, blueBrush, 50, 100, 400, 150, 20, 20);
        }

        /// <summary>
        /// Draws content on a page using colors created from a separation colorspace.
        /// </summary>
        /// <param name="page">The page to draw to.</param>
        private static void DrawSeparationColorSpace(PDFPage page)
        {
            PDFRgbColor black = new PDFRgbColor(0, 0, 0);
            PDFBrush blackBrush = new PDFBrush(black);
            PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16);

            page.Canvas.DrawText("Separation colorspace", font, null, blackBrush, 50, 50);

            PDFType2Function tintTransform = new PDFType2Function();
            tintTransform.C0 = new double[] { 0, 0, 0, 0 };
            tintTransform.C1 = new double[] { 0, 0.53f, 1, 0 };
            tintTransform.Exponent = 1;
            tintTransform.Domain = new double[] { 0, 1 };
            tintTransform.Range = new double[] { 0, 1, 0, 1, 0, 1, 0, 1 };
            PDFSeparationColorSpace separationCS = new PDFSeparationColorSpace();
            separationCS.Colorant = "PANTONE Orange 021 C";
            separationCS.TintTransform = tintTransform;
            PDFSeparationColor orange = new PDFSeparationColor(separationCS);
            orange.Tint = 0.9;

            tintTransform = new PDFType2Function();
            tintTransform.C0 = new double[] { 0, 0, 0, 0 };
            tintTransform.C1 = new double[] { 0, 0.75f, 0.9f, 0 };
            tintTransform.Exponent = 1;
            tintTransform.Domain = new double[] { 0, 1 };
            tintTransform.Range = new double[] { 0, 1, 0, 1, 0, 1, 0, 1 };
            separationCS = new PDFSeparationColorSpace();
            separationCS.Colorant = "PANTONE Warm Red C";
            separationCS.TintTransform = tintTransform;
            PDFSeparationColor warmRed = new PDFSeparationColor(separationCS);
            warmRed.Tint = 0.4;

            PDFBrush orangeBrush = new PDFBrush(orange);
            PDFPen warmRedPen = new PDFPen(warmRed, 5);
            page.Canvas.DrawRoundRectangle(warmRedPen, orangeBrush, 50, 100, 400, 150, 20, 20);
        }
    }
}


ColorSpaces.vb

PDF4NET Send comments on this topic.
ColorSpaces.vb
PDF4NET On-line Help > Samples > ColorSpaces > ColorSpaces.vb

Glossary Item Box

Imports System
Imports System.IO
Imports System.Text
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Functions
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.ColorSpaces
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET
    ''' <summary>
    ''' This sample shows how to work with various PDF colorspaces when creating a PDF document.
    ''' </summary>
    Class ColorSpaces
        <STAThread> _
        Shared Sub Main(args As String())
            Dim doc As New PDFDocument()

            Dim page As PDFPage = doc.AddPage()
            DrawDeviceColorSpace(page)

            page = doc.AddPage()
            DrawIndexedColorSpace(page)

            page = doc.AddPage()
            DrawCalGrayColorSpace(page)

            page = doc.AddPage()
            DrawCalRgbColorSpace(page)

            page = doc.AddPage()
            DrawLabColorSpace(page)

            page = doc.AddPage()
            DrawICCColorSpace(page)

            page = doc.AddPage()
            DrawSeparationColorSpace(page)

            doc.Save("Sample_ColorSpaces.pdf")
        End Sub

        ''' <summary>
        ''' Draws content on a page using colors created from a device colorspace.
        ''' </summary>
        ''' <param name="page">The page to draw to.</param>
        ''' <remarks>RGB, CMYK and Gray are device colorspaces.
        ''' The PDFRgbColor, PDFCmykColor and PDFGrayColor classes create automatically the
        ''' required colorspaces.</remarks>
        Private Shared Sub DrawDeviceColorSpace(page As PDFPage)
            Dim black As New PDFRgbColor(0, 0, 0)
            Dim blackBrush As New PDFBrush(black)
            Dim font As New PDFFont(PDFFontFace.Helvetica, 16)

            page.Canvas.DrawText("Device colorspaces: RGB, CMYK and Gray", font, Nothing, blackBrush, 50, 50)

            ' Draw RGB content.
            page.Canvas.DrawText("RGB", font, Nothing, blackBrush, 50, 80)
            Dim red As New PDFRgbColor(255, 0, 0)
            Dim blue As New PDFRgbColor(0, 0, 255)
            Dim redBrush As New PDFBrush(red)
            Dim bluePen As New PDFPen(blue, 5)
            page.Canvas.DrawRoundRectangle(bluePen, redBrush, 50, 100, 400, 150, _
                20, 20)

            ' Draw CMYK content.
            page.Canvas.DrawText("CMYK", font, Nothing, blackBrush, 50, 280)
            Dim cyan As New PDFCmykColor(1, 0, 0, 0)
            Dim magenta As New PDFCmykColor(0, 1, 0, 0)
            Dim cyanBrush As New PDFBrush(cyan)
            Dim magentaPen As New PDFPen(magenta, 5)
            page.Canvas.DrawRoundRectangle(magentaPen, cyanBrush, 50, 300, 400, 150, _
                20, 20)

            ' Draw Gray content.
            page.Canvas.DrawText("Gray", font, Nothing, blackBrush, 50, 480)
            Dim lightGray As New PDFGrayColor(0.85)
            Dim darkGray As New PDFGrayColor(0.1)
            Dim lgBrush As New PDFBrush(lightGray)
            Dim dgPen As New PDFPen(darkGray, 5)
            page.Canvas.DrawRoundRectangle(dgPen, lgBrush, 50, 500, 400, 150, _
                20, 20)
        End Sub

        ''' <summary>
        ''' Draws content on a page using colors created from an indexed colorspace.
        ''' </summary>
        ''' <param name="page">The page to draw to.</param>
        Private Shared Sub DrawIndexedColorSpace(page As PDFPage)
            Dim black As New PDFRgbColor(0, 0, 0)
            Dim blackBrush As New PDFBrush(black)
            Dim font As New PDFFont(PDFFontFace.Helvetica, 16)

            page.Canvas.DrawText("Indexed colorspace with 2 colors", font, Nothing, blackBrush, 50, 50)

            ' Create an indexed colorspace with 2 RGB colors, 24bits (3*8bytes) per color.
            Dim ixCS As New PDFIndexedColorSpace()
            ixCS.MaxIndex = 1
            ixCS.ColorTable = New Byte() {255, 0, 0, 192, 0, 255}
            Dim red As New PDFIndexedColor(ixCS)
            red.ColorIndex = 0
            Dim violet As New PDFIndexedColor(ixCS)
            violet.ColorIndex = 1
            Dim redBrush As New PDFBrush(red)
            Dim violetPen As New PDFPen(violet, 5)
            page.Canvas.DrawRoundRectangle(violetPen, redBrush, 50, 100, 400, 150, _
                20, 20)
        End Sub

        ''' <summary>
        ''' Draws content on a page using colors created from a calibrated gray colorspace.
        ''' </summary>
        ''' <param name="page">The page to draw to.</param>
        Private Shared Sub DrawCalGrayColorSpace(page As PDFPage)
            Dim black As New PDFRgbColor(0, 0, 0)
            Dim blackBrush As New PDFBrush(black)
            Dim font As New PDFFont(PDFFontFace.Helvetica, 16)

            page.Canvas.DrawText("CalGray colorspace", font, Nothing, blackBrush, 50, 50)

            Dim calGrayCS As New PDFCalGrayColorSpace()
            Dim dkGray As New PDFCalGrayColor(calGrayCS)
            dkGray.Gray = 0.1
            Dim ltGray As New PDFCalGrayColor(calGrayCS)
            ltGray.Gray = 0.8
            Dim dkBrush As New PDFBrush(dkGray)
            Dim ltPen As New PDFPen(ltGray, 5)
            page.Canvas.DrawRoundRectangle(ltPen, dkBrush, 50, 100, 400, 150, _
                20, 20)
        End Sub

        ''' <summary>
        ''' Draws content on a page using colors created from a calibrated RGB colorspace.
        ''' </summary>
        ''' <param name="page">The page to draw to.</param>
        Private Shared Sub DrawCalRgbColorSpace(page As PDFPage)
            Dim black As New PDFRgbColor(0, 0, 0)
            Dim blackBrush As New PDFBrush(black)
            Dim font As New PDFFont(PDFFontFace.Helvetica, 16)

            page.Canvas.DrawText("CalRGB colorspace", font, Nothing, blackBrush, 50, 50)

            Dim calRgbCS As New PDFCalRgbColorSpace()
            Dim red As New PDFCalRgbColor(calRgbCS)
            red.Red = 1
            red.Green = 0
            red.Blue = 0
            Dim blue As New PDFCalRgbColor(calRgbCS)
            blue.Red = 0
            blue.Green = 0
            blue.Blue = 1
            Dim blueBrush As New PDFBrush(blue)
            Dim redPen As New PDFPen(red, 5)
            page.Canvas.DrawRoundRectangle(redPen, blueBrush, 50, 100, 400, 150, _
                20, 20)
        End Sub

        ''' <summary>
        ''' Draws content on a page using colors created from a calibrated Lab colorspace.
        ''' </summary>
        ''' <param name="page">The page to draw to.</param>
        Private Shared Sub DrawLabColorSpace(page As PDFPage)
            Dim black As New PDFRgbColor(0, 0, 0)
            Dim blackBrush As New PDFBrush(black)
            Dim font As New PDFFont(PDFFontFace.Helvetica, 16)

            page.Canvas.DrawText("L*a*b* colorspace", font, Nothing, blackBrush, 50, 50)

            Dim labCS As New PDFLabColorSpace()
            Dim labClr1 As New PDFLabColor(labCS)
            labClr1.L = 90
            labClr1.A = 20
            labClr1.B = -10
            Dim labClr2 As New PDFLabColor(labCS)
            labClr2.L = 10
            labClr2.A = 70
            labClr2.B = -50
            Dim brush As New PDFBrush(labClr1)
            Dim pen As New PDFPen(labClr2, 5)
            page.Canvas.DrawRoundRectangle(pen, brush, 50, 100, 400, 150, _
                20, 20)
        End Sub

        ''' <summary>
        ''' Draws content on a page using colors created from a calibrated ICC colorspace.
        ''' </summary>
        ''' <param name="page">The page to draw to.</param>
        Private Shared Sub DrawICCColorSpace(page As PDFPage)
            Dim black As New PDFRgbColor(0, 0, 0)
            Dim blackBrush As New PDFBrush(black)
            Dim font As New PDFFont(PDFFontFace.Helvetica, 16)

            page.Canvas.DrawText("ICC colorspace", font, Nothing, blackBrush, 50, 50)

            ' Read the ICC profile from disk.
            Dim fs As New FileStream("..\SupportFiles\rgb.icc", FileMode.Open, FileAccess.Read)
            Dim profileData As Byte() = New Byte(fs.Length) {}
            fs.Read(profileData, 0, profileData.Length)
            fs.Close()

            Dim iccCS As New PDFICCColorSpace()
            iccCS.ProfileData = profileData
            Dim red As New PDFICCColor(iccCS)
            red.ColorComponents = New Double() {192, 0, 0}
            Dim blue As New PDFICCColor(iccCS)
            blue.ColorComponents = New Double() {0, 0, 192}
            Dim blueBrush As New PDFBrush(blue)
            Dim redPen As New PDFPen(red, 5)
            page.Canvas.DrawRoundRectangle(redPen, blueBrush, 50, 100, 400, 150, _
                20, 20)
        End Sub

        ''' <summary>
        ''' Draws content on a page using colors created from a separation colorspace.
        ''' </summary>
        ''' <param name="page">The page to draw to.</param>
        Private Shared Sub DrawSeparationColorSpace(page As PDFPage)
            Dim black As New PDFRgbColor(0, 0, 0)
            Dim blackBrush As New PDFBrush(black)
            Dim font As New PDFFont(PDFFontFace.Helvetica, 16)

            page.Canvas.DrawText("Separation colorspace", font, Nothing, blackBrush, 50, 50)

            Dim tintTransform As New PDFType2Function()
            tintTransform.C0 = New Double() {0, 0, 0, 0}
            tintTransform.C1 = New Double() {0, 0.53F, 1, 0}
            tintTransform.Exponent = 1
            tintTransform.Domain = New Double() {0, 1}
            tintTransform.Range = New Double() {0, 1, 0, 1, 0, 1, _
                0, 1}
            Dim separationCS As New PDFSeparationColorSpace()
            separationCS.Colorant = "PANTONE Orange 021 C"
            separationCS.TintTransform = tintTransform
            Dim orange As New PDFSeparationColor(separationCS)
            orange.Tint = 0.9

            tintTransform = New PDFType2Function()
            tintTransform.C0 = New Double() {0, 0, 0, 0}
            tintTransform.C1 = New Double() {0, 0.75F, 0.9F, 0}
            tintTransform.Exponent = 1
            tintTransform.Domain = New Double() {0, 1}
            tintTransform.Range = New Double() {0, 1, 0, 1, 0, 1, _
                0, 1}
            separationCS = New PDFSeparationColorSpace()
            separationCS.Colorant = "PANTONE Warm Red C"
            separationCS.TintTransform = tintTransform
            Dim warmRed As New PDFSeparationColor(separationCS)
            warmRed.Tint = 0.4

            Dim orangeBrush As New PDFBrush(orange)
            Dim warmRedPen As New PDFPen(warmRed, 5)
            page.Canvas.DrawRoundRectangle(warmRedPen, orangeBrush, 50, 100, 400, 150, _
                20, 20)
        End Sub
    End Class
End Namespace


Samples: Digital Signature

PDF4NET Send comments on this topic.
Samples: Digital Signature
PDF4NET On-line Help > Samples > Samples: Digital Signature

Glossary Item Box

This sample shows how to add digital signatures, based on X.509 certificates, to PDF files.

C# Source code | VB.NET Source code | PDF file


DigitalSignature.cs

PDF4NET Send comments on this topic.
DigitalSignature.cs
PDF4NET On-line Help > Samples > Digital Signature > DigitalSignature.cs

Glossary Item Box

using System;
using System.IO;
using System.Drawing;
using System.Security.Cryptography.X509Certificates;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Forms;
using O2S.Components.PDF4NET.Security;

namespace O2S.Samples.PDF4NET
{
    /// <summary>
    /// This sample shows how to sign a PDF file using X.509 certificates.
    /// </summary>
    class DigitalSignature
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument doc = new PDFDocument();

            // Create a blank page
            PDFPage page = doc.AddPage();

            // Create the signature field.
            PDFSignatureField sign = new PDFSignatureField("Signature");
            sign.Widgets[0].DisplayRectangle = new DisplayRectangle(50, 100, 200, 40);
            // Create the digital signature.
            sign.Signature = new PDFDigitalSignature();
            // The certificate is loaded from disk, but it also can be loaded from a certificate store.
            sign.Signature.Certificate = new X509Certificate2("..\\SupportFiles\\samplesign.pfx", "password");
            sign.Signature.Location = "Romania";
            sign.Signature.Reason = "For demo";
            sign.Signature.ContactInfo = "techsupport@o2sol.com";
            page.Fields.Add(sign);

            doc.Save("Sample_DigitalSign.pdf");
        }
    }
}


DigitalSignature.vb

PDF4NET Send comments on this topic.
DigitalSignature.vb
PDF4NET On-line Help > Samples > Digital Signature > DigitalSignature.vb

Glossary Item Box

Imports System
Imports System.IO
Imports System.Drawing
Imports System.Security.Cryptography.X509Certificates
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Forms
Imports O2S.Components.PDF4NET.Security

Namespace O2S.Samples.PDF4NET
    ''' <summary>
    ''' This sample shows how to sign a PDF file using X.509 certificates.
    ''' </summary>
    Class DigitalSignature
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim doc As New PDFDocument()

            ' Create a blank page
            Dim page As PDFPage = doc.AddPage()

            ' Create the signature field.
            Dim sign As New PDFSignatureField("Signature")
            sign.Widgets(0).DisplayRectangle = New DisplayRectangle(50, 100, 200, 40)
            ' Create the digital signature.
            sign.Signature = New PDFDigitalSignature()
            ' The certificate is loaded from disk, but it also can be loaded from a certificate store.
            sign.Signature.Certificate = New X509Certificate2("..\SupportFiles\samplesign.pfx", "password")
            sign.Signature.Location = "Romania"
            sign.Signature.Reason = "For demo"
            sign.Signature.ContactInfo = "techsupport@o2sol.com"
            page.Fields.Add(sign)

            doc.Save("Sample_DigitalSign.pdf")
        End Sub
    End Class
End Namespace


Samples: DocAndViewer

PDF4NET Send comments on this topic.
Samples: DocAndViewer
PDF4NET On-line Help > Samples > Samples: DocAndViewer

Glossary Item Box

This samples shows how to set the metadata information for a pdf document. Also, it demonstrates how to set the way the pdf document is open in the viewer. In this sample, when the pdf document is open in the viewer, the whole user interface of the viewer is hidden. This sample has been enhanced to show how to add custom properties to a document. To view the custom properties, in Adobe Acrobat (Reader) go to File > Document Properties > Document Metadata.

C# Source code | VB.NET Source code | PDF file


DocAndViewer.cs

PDF4NET Send comments on this topic.
DocAndViewer.cs
PDF4NET On-line Help > Samples > DocAndViewer > DocAndViewer.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.DocAndViewer
{
    /// <summary>
    /// This sample will show how to set the document information
    /// and the way the viewer will behave when will open the document.
    /// It also shows how to create custom properties for the document.
    /// </summary>
    class DocAndViewer
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            // Set the document information
            pdfDoc.DocumentInformation = new PDFDocumentInformation();
            pdfDoc.DocumentInformation.Author = "O2 Solutions (http://www.o2sol.com)";
            pdfDoc.DocumentInformation.Title = "Sample document";
            pdfDoc.DocumentInformation.Subject = "The abilities of the PDF4NET library";
            pdfDoc.DocumentInformation.Keywords = "pdf4net, pdf, .net, sample";
            pdfDoc.DocumentInformation.Creator = "DocAndViewer";

            // Set viewer preferences
            // Change HideMenubar to false in order to
            // access the Preferences menu item.
            pdfDoc.ViewerPreferences = new PDFViewerPreferences();
            pdfDoc.ViewerPreferences.HideMenubar = false;
            pdfDoc.ViewerPreferences.HideToolbar = true;
            pdfDoc.ViewerPreferences.HideWindowUI = true;
            pdfDoc.ViewerPreferences.DisplayDocTitle = true;

            // Set up custom properties
            PDFMetadataSchema ms = new PDFMetadataSchema();
            ms["Company"] = "O2 Solutions";
            ms["Website"] = "http://www.o2sol.com/";
            ms["Product"] = "PDF4NET Library";

            // Add schema to document
            pdfDoc.Metadata.MetadataSchemas.Add(ms);

            // Create one page
            PDFPage pdfPage = pdfDoc.AddPage();

            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFFont fontTitle = new PDFFont(PDFFontFace.Helvetica, 12);
            fontTitle.Bold = true;
            PDFBrush brush = new PDFBrush(new PDFRgbColor());

            // Write on the page the current settings
            pdfPage.Canvas.DrawText("Document information",
                fontTitle, null, brush, 20, 20, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Author: " + pdfDoc.DocumentInformation.Author,
                fontText, null, brush, 20, 35, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Title: " + pdfDoc.DocumentInformation.Title,
                fontText, null, brush, 20, 50, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Subject: " + pdfDoc.DocumentInformation.Subject,
                fontText, null, brush, 20, 65, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Keywords: " + pdfDoc.DocumentInformation.Keywords,
                fontText, null, brush, 20, 80, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Creator: " + pdfDoc.DocumentInformation.Creator,
                fontText, null, brush, 20, 95, 0, PDFTextAlign.TopLeft);

            pdfPage.Canvas.DrawText("Viewer preferences",
                fontTitle, null, brush, 20, 120, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("HideMenubar: " +
                pdfDoc.ViewerPreferences.HideMenubar.ToString(),
                fontText, null, brush, 20, 135, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("HideToolbar: " +
                pdfDoc.ViewerPreferences.HideToolbar.ToString(),
                fontText, null, brush, 20, 150, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("HideWindowUI: " +
                pdfDoc.ViewerPreferences.HideWindowUI.ToString(),
                fontText, null, brush, 20, 165, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("DisplayDocTitle: " +
                pdfDoc.ViewerPreferences.DisplayDocTitle.ToString(),
                fontText, null, brush, 20, 180, 0, PDFTextAlign.TopLeft);

            // Save the document to disk
            pdfDoc.Save("Sample_DocAndViewer.pdf");
        }
    }
}


DocAndViewer.vb

PDF4NET Send comments on this topic.
DocAndViewer.vb
PDF4NET On-line Help > Samples > DocAndViewer > DocAndViewer.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.DocAndViewer
    ''' <summary>
    ''' This sample will show how to set the document information
    ''' and the way the viewer will behave when will open the document.
    ''' It also shows how to create custom properties for the document.
    ''' </summary>
    Class DocAndViewer
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            ' Set the document information
            pdfDoc.DocumentInformation = New PDFDocumentInformation()
            pdfDoc.DocumentInformation.Author = "O2 Solutions (http://www.o2sol.com)"
            pdfDoc.DocumentInformation.Title = "Sample document"
            pdfDoc.DocumentInformation.Subject = "The abilities of the PDF4NET library"
            pdfDoc.DocumentInformation.Keywords = "pdf4net, pdf, .net, sample"
            pdfDoc.DocumentInformation.Creator = "DocAndViewer"

            ' Set viewer preferences
            ' Change HideMenubar to false in order to
            ' access the Preferences menu item.
            pdfDoc.ViewerPreferences = New PDFViewerPreferences()
            pdfDoc.ViewerPreferences.HideMenubar = False
            pdfDoc.ViewerPreferences.HideToolbar = True
            pdfDoc.ViewerPreferences.HideWindowUI = True
            pdfDoc.ViewerPreferences.DisplayDocTitle = True

            ' Set up custom properties
            Dim ms As New PDFMetadataSchema()
            ms("Company") = "O2 Solutions"
            ms("Website") = "http://www.o2sol.com/"
            ms("Product") = "PDF4NET Library"

            ' Add schema to document
            pdfDoc.Metadata.MetadataSchemas.Add(ms)

            ' Create one page
            Dim pdfPage As PDFPage = pdfDoc.AddPage()

            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim fontTitle As New PDFFont(PDFFontFace.Helvetica, 12)
            fontTitle.Bold = True
            Dim brush As New PDFBrush(New PDFRgbColor())

            ' Write on the page the current settings
            pdfPage.Canvas.DrawText("Document information", fontTitle, Nothing, brush, 20, 20, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Author: " + pdfDoc.DocumentInformation.Author, fontText, Nothing, brush, 20, 35, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Title: " + pdfDoc.DocumentInformation.Title, fontText, Nothing, brush, 20, 50, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Subject: " + pdfDoc.DocumentInformation.Subject, fontText, Nothing, brush, 20, 65, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Keywords: " + pdfDoc.DocumentInformation.Keywords, fontText, Nothing, brush, 20, 80, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Creator: " + pdfDoc.DocumentInformation.Creator, fontText, Nothing, brush, 20, 95, _
                0, PDFTextAlign.TopLeft)

            pdfPage.Canvas.DrawText("Viewer preferences", fontTitle, Nothing, brush, 20, 120, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("HideMenubar: " + pdfDoc.ViewerPreferences.HideMenubar.ToString(), fontText, Nothing, brush, 20, 135, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("HideToolbar: " + pdfDoc.ViewerPreferences.HideToolbar.ToString(), fontText, Nothing, brush, 20, 150, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("HideWindowUI: " + pdfDoc.ViewerPreferences.HideWindowUI.ToString(), fontText, Nothing, brush, 20, 165, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("DisplayDocTitle: " + pdfDoc.ViewerPreferences.DisplayDocTitle.ToString(), fontText, Nothing, brush, 20, 180, _
                0, PDFTextAlign.TopLeft)

            ' Save the document to disk
            pdfDoc.Save("Sample_DocAndViewer.pdf")
        End Sub
    End Class
End Namespace


Samples: Edit PDF

PDF4NET Send comments on this topic.
Samples: Edit PDF
PDF4NET On-line Help > Samples > Samples: Edit PDF

Glossary Item Box

This sample shows the pdf editing capabilities of PDF4NET library. The following features are shown: mixing 2 different documents, merge files, apply security to existing files, page imposition and pdf file splitting.

C# Source code | VB.NET Source code


EditPDF.cs

PDF4NET Send comments on this topic.
EditPDF.cs
PDF4NET On-line Help > Samples > Edit PDF > EditPDF.cs

Glossary Item Box

using System;
using System.Drawing;
using System.Text;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Security;
using O2S.Components.PDF4NET.PDFFile;

namespace O2S.Samples.PDF4NET.EditPDF
{
    /// <summary>
    /// This sample shows the pdf editing capabilities of
    /// PDF4NET library. The following features are shown:
    /// Mixing 2 different documents, merge files,
    /// encryption of existing files,
    /// page imposition and pdf file splitting.
    /// </summary>
    class EditPDF
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Documents mix
            MixFiles();

            // Apppend files
            AppendFiles();

            // Encrypt file
            EncryptFile();

            // Split file
            SplitFile();

            // Page imposition
            MultiPage();
        }

        // For this sample to work, the following files
        // need to exist: unicode.pdf and multicolumntextandimages.pdf.
        // Compile the corresponding samples to get these files
        public static void MixFiles()
        {
            PDFFile unicodeFile = PDFFile.FromFile("Sample_Unicode.pdf");
            PDFFile mctiFile = PDFFile.FromFile("Sample_MultiColumnTextAndImages.pdf");
            PDFImportedPage ip = null;

            PDFDocument doc = new PDFDocument();
            for (int i = 0; i < 4; i++)
            {
                // extract the page
                ip = unicodeFile.ExtractPage(i);

                // add the page to new document
                doc.Pages.Add(ip);

                // extract the page
                ip = mctiFile.ExtractPage(i);

                // add the page to new document
                doc.Pages.Add(ip);
            }

            // save the mixed document
            doc.Save("Sample_Mix.pdf");

            unicodeFile.Close();
            mctiFile.Close();
        }

        // For this sample to work, the following files
        // need to exist: unicode.pdf and multicolumntextandimages.pdf.
        // Compile the corresponding samples to get these files
        public static void AppendFiles()
        {
            PDFFile.MergeFiles("Sample_Append.pdf", new string[] { "Sample_Unicode.pdf", "Sample_MultiColumnTextAndImages.pdf" });

            // or
            //PDFDocument doc =
            //    PDFFile.MergeFiles( new string[]{ "unicode.pdf", "multicolumntextandimages.pdf" } );
            //doc.SaveToStream( stream );
        }

        // For this sample to work, the following file
        // need to exist: multicolumntextandimages.pdf.
        // Compile the corresponding sample to get this file
        public static void EncryptFile()
        {
            PDFSecurityManager securityManager = new PDFSecurityManager();
            securityManager.KeySize = EncryptionKeySize.Use128BitKey;
            securityManager.UserPassword = Encoding.ASCII.GetBytes("userpass");
            securityManager.OwnerPassword = Encoding.ASCII.GetBytes("ownerpass");
            securityManager.AllowPrint = false;
            securityManager.FullQualityPrint = true;
            securityManager.AllowModifyDocument = false;
            securityManager.AllowExtractContent = false;
            securityManager.AllowInteractiveEdit = false;
            securityManager.AllowFormsFill = true;
            securityManager.AllowAccessibilityExtractContent = true;
            securityManager.AllowAssembleDocument = false;

            PDFFile.EncryptFile(securityManager,
                "Sample_MultiColumnTextAndImages.pdf", "Sample_MultiColumnTextAndImages-Secure.pdf");

            // or
            //PDFDocument doc =
            //    PDFFile.EncryptFile( securityManager, "multicolumntextandimages-secure.pdf" );
            //doc.SaveToStream( stream );
        }

        // For this sample to work, the following file
        // need to exist: unicode.pdf.
        // Compile the corresponding sample to get this file
        public static void SplitFile()
        {
            PDFFile.SplitFile("Sample_Unicode.pdf", "Sample_Unicode-page.pdf");
        }

        // For this sample to work, the following file
        // needs to exist: multicolumntextandimages.pdf.
        // Compile the corresponding sample to get this file
        public static void MultiPage()
        {
            PDFFile mctiFile = PDFFile.FromFile("Sample_MultiColumnTextAndImages-Secure.pdf", Encoding.ASCII.GetBytes("userpass"));
            // extract the content of first 4 pages
            PDFImportedContent[] ic = mctiFile.ExtractPagesContent("0-3");

            // create the new document
            PDFDocument doc = new PDFDocument();
            // add a page to it
            PDFPage page = doc.AddPage();

            // draw the imported content (4 pages) on the new page
            page.Canvas.DrawImportedContent(ic[0], 0, 0, page.Width / 2, page.Height / 2);
            page.Canvas.DrawImportedContent(ic[1], page.Width / 2, 0, page.Width / 2, page.Height / 2);
            page.Canvas.DrawImportedContent(ic[2], 0, page.Height / 2, page.Width / 2, page.Height / 2);
            page.Canvas.DrawImportedContent(ic[3], page.Width / 2, page.Height / 2, page.Width / 2, page.Height / 2);

            // save the mixed document
            doc.Save("Sample_Imposition.pdf");

            mctiFile.Close();
        }
    }
}


EditPDF.vb

PDF4NET Send comments on this topic.
EditPDF.vb
PDF4NET On-line Help > Samples > Edit PDF > EditPDF.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports System.Text
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Security
Imports O2S.Components.PDF4NET.PDFFile

Namespace O2S.Samples.PDF4NET.EditPDF
    ''' <summary>
    ''' This sample shows the pdf editing capabilities of
    ''' PDF4NET library. The following features are shown:
    ''' Mixing 2 different documents, merge files,
    ''' encryption of existing files,
    ''' page imposition and pdf file splitting.
    ''' </summary>
    Class EditPDF
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Documents mix
            MixFiles()

            ' Apppend files
            AppendFiles()

            ' Encrypt file
            EncryptFile()

            ' Split file
            SplitFile()

            ' Page imposition
            MultiPage()
        End Sub

        ' For this sample to work, the following files
        ' need to exist: unicode.pdf and multicolumntextandimages.pdf.
        ' Compile the corresponding samples to get these files
        Public Shared Sub MixFiles()
            Dim unicodeFile As PDFFile = PDFFile.FromFile("Sample_Unicode.pdf")
            Dim mctiFile As PDFFile = PDFFile.FromFile("Sample_MultiColumnTextAndImages.pdf")
            Dim ip As PDFImportedPage = Nothing

            Dim doc As New PDFDocument()
            Dim i As Integer = 0
            While i < 4
                ' extract the page
                ip = unicodeFile.ExtractPage(i)

                ' add the page to new document
                doc.Pages.Add(ip)

                ' extract the page
                ip = mctiFile.ExtractPage(i)

                ' add the page to new document
                doc.Pages.Add(ip)
                i = i + 1
            End While

            ' save the mixed document
            doc.Save("Sample_Mix.pdf")

            unicodeFile.Close()
            mctiFile.Close()
        End Sub

        ' For this sample to work, the following files
        ' need to exist: unicode.pdf and multicolumntextandimages.pdf.
        ' Compile the corresponding samples to get these files
        Public Shared Sub AppendFiles()
            PDFFile.MergeFiles("Sample_Append.pdf", New String() {"Sample_Unicode.pdf", "Sample_MultiColumnTextAndImages.pdf"})

            ' or
            'PDFDocument doc =
            '    PDFFile.MergeFiles( new string[]{ "unicode.pdf", "multicolumntextandimages.pdf" } );
            'doc.SaveToStream( stream );
        End Sub

        ' For this sample to work, the following file
        ' need to exist: multicolumntextandimages.pdf.
        ' Compile the corresponding sample to get this file
        Public Shared Sub EncryptFile()
            Dim securityManager As New PDFSecurityManager()
            securityManager.KeySize = EncryptionKeySize.Use128BitKey
            securityManager.UserPassword = Encoding.ASCII.GetBytes("userpass")
            securityManager.OwnerPassword = Encoding.ASCII.GetBytes("ownerpass")
            securityManager.AllowPrint = False
            securityManager.FullQualityPrint = True
            securityManager.AllowModifyDocument = False
            securityManager.AllowExtractContent = False
            securityManager.AllowInteractiveEdit = False
            securityManager.AllowFormsFill = True
            securityManager.AllowAccessibilityExtractContent = True
            securityManager.AllowAssembleDocument = False

            PDFFile.EncryptFile(securityManager, "Sample_MultiColumnTextAndImages.pdf", "Sample_MultiColumnTextAndImages-Secure.pdf")

            ' or
            'PDFDocument doc =
            '    PDFFile.EncryptFile( securityManager, "multicolumntextandimages-secure.pdf" );
            'doc.SaveToStream( stream );
        End Sub

        ' For this sample to work, the following file
        ' need to exist: unicode.pdf.
        ' Compile the corresponding sample to get this file
        Public Shared Sub SplitFile()
            PDFFile.SplitFile("Sample_Unicode.pdf", "Sample_Unicode-page.pdf")
        End Sub

        ' For this sample to work, the following file
        ' needs to exist: multicolumntextandimages.pdf.
        ' Compile the corresponding sample to get this file
        Public Shared Sub MultiPage()
            Dim mctiFile As PDFFile = PDFFile.FromFile("Sample_MultiColumnTextAndImages-Secure.pdf", Encoding.ASCII.GetBytes("userpass"))
            ' extract the content of first 4 pages
            Dim ic As PDFImportedContent() = mctiFile.ExtractPagesContent("0-3")

            ' create the new document
            Dim doc As New PDFDocument()
            ' add a page to it
            Dim page As PDFPage = doc.AddPage()

            ' draw the imported content (4 pages) on the new page
            page.Canvas.DrawImportedContent(ic(0), 0, 0, page.Width / 2, page.Height / 2)
            page.Canvas.DrawImportedContent(ic(1), page.Width / 2, 0, page.Width / 2, page.Height / 2)
            page.Canvas.DrawImportedContent(ic(2), 0, page.Height / 2, page.Width / 2, page.Height / 2)
            page.Canvas.DrawImportedContent(ic(3), page.Width / 2, page.Height / 2, page.Width / 2, page.Height / 2)

            ' save the mixed document
            doc.Save("Sample_Imposition.pdf")

            mctiFile.Close()
        End Sub
    End Class
End Namespace


Samples: Ellipses

PDF4NET Send comments on this topic.
Samples: Ellipses
PDF4NET On-line Help > Samples > Samples: Ellipses

Glossary Item Box

This samples shows the ellipse drawing capabilities of the PDF4NET library. On the first page, it draws an ellipse by painting its border, an ellipse by filling its interior, and an ellipse by painting its border and filling its interior. It also show how to draw a circle. On the second page it draws 50 ellipses at random locations on the page. The color of the ellipses is generated randomly.

C# Source code | VB.NET Source code | PDF file


Ellipses.cs

PDF4NET Send comments on this topic.
Ellipses.cs
PDF4NET On-line Help > Samples > Ellipses > Ellipses.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.Ellipses
{
    /// <summary>
    /// This sample will show how to draw various ellipses
    /// on the page.
    /// </summary>
    class Ellipses
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            // Create first page
            PDFPage pdfPage1 = pdfDoc.AddPage();

            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());
            PDFBrush greenBrush = new PDFBrush(new PDFRgbColor(0, 255, 0));
            PDFPen pen = new PDFPen(new PDFRgbColor(Color.Orange), 1);

            // Draw an ellipse that has a border
            pdfPage1.Canvas.DrawText("This ellipse is drawn by drawing its border",
                fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft);
            pdfPage1.Canvas.DrawEllipse(pen, null, 20, 35, 200, 100);

            // Draw an ellipse that has no border and its interior is filled
            pdfPage1.Canvas.DrawText("This ellipse is drawn by filling its interior",
                fontText, null, blackBrush, 300, 20, 0, PDFTextAlign.TopLeft);
            pdfPage1.Canvas.DrawEllipse(null, greenBrush, 300, 35, 300, 150);

            // Draw an ellipse that has a border and its interior is filled
            pdfPage1.Canvas.DrawText("This ellipse has a border and a filled interior",
                fontText, null, blackBrush, 20, 200, 0, PDFTextAlign.TopLeft);
            pdfPage1.Canvas.DrawEllipse(pen, greenBrush, 20, 215, 200, 150);

            // Draw a circle
            pdfPage1.Canvas.DrawText("This is a circle",
                fontText, null, blackBrush, 300, 200, 0, PDFTextAlign.TopLeft);
            pdfPage1.Canvas.DrawEllipse(pen, greenBrush, 300, 215, 200, 200);

            // Create the second page
            PDFPage pdfPage2 = pdfDoc.AddPage();

            Random rnd = new Random();
            for (int i = 0; i < 50; i++)
            {
                // Create random colors for the border and the interior
                PDFRgbColor brushColor = new PDFRgbColor((byte)rnd.Next(256),
                    (byte)rnd.Next(256), (byte)rnd.Next(256));
                PDFRgbColor penColor = new PDFRgbColor((byte)rnd.Next(256),
                    (byte)rnd.Next(256), (byte)rnd.Next(256));

                // Create the brush to fill the interior
                PDFBrush randomBrush = new PDFBrush(brushColor);
                // Create the pen to draw the border
                PDFPen randomPen = new PDFPen(penColor, 1);

                // Generate random positions
                float left = rnd.Next((int)pdfPage2.Width);
                float top = rnd.Next((int)pdfPage2.Height);

                // Generate random sizes
                float width = rnd.Next((int)(pdfPage2.Width - left)); // try to keep the rectangle
                float height = rnd.Next((int)(pdfPage2.Height - top));   // within the page

                // Draw the ellipse
                pdfPage2.Canvas.DrawEllipse(randomPen, randomBrush,
                    left, top, width, height);
            }

            // Draw a label
            pdfPage2.Canvas.DrawText("Random ellipses",
                fontText, null, blackBrush, 20, 350, 0, PDFTextAlign.TopLeft);

            // Save the document to disk
            pdfDoc.Save("Sample_Ellipses.pdf");
        }
    }
}


Ellipses.vb

PDF4NET Send comments on this topic.
Ellipses.vb
PDF4NET On-line Help > Samples > Ellipses > Ellipses.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.Ellipses
    ''' <summary>
    ''' This sample will show how to draw various ellipses
    ''' on the page.
    ''' </summary>
    Class Ellipses
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            ' Create first page
            Dim pdfPage1 As PDFPage = pdfDoc.AddPage()

            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())
            Dim greenBrush As New PDFBrush(New PDFRgbColor(0, 255, 0))
            Dim pen As New PDFPen(New PDFRgbColor(Color.Orange), 1)

            ' Draw an ellipse that has a border
            pdfPage1.Canvas.DrawText("This ellipse is drawn by drawing its border", fontText, Nothing, blackBrush, 20, 20, _
                0, PDFTextAlign.TopLeft)
            pdfPage1.Canvas.DrawEllipse(pen, 20, 35, 200, 100)

            ' Draw an ellipse that has no border and its interior is filled
            pdfPage1.Canvas.DrawText("This ellipse is drawn by filling its interior", fontText, Nothing, blackBrush, 300, 20, _
                0, PDFTextAlign.TopLeft)
            pdfPage1.Canvas.DrawEllipse(greenBrush, 300, 35, 300, 150)

            ' Draw an ellipse that has a border and its interior is filled
            pdfPage1.Canvas.DrawText("This ellipse has a border and a filled interior", fontText, Nothing, blackBrush, 20, 200, _
                0, PDFTextAlign.TopLeft)
            pdfPage1.Canvas.DrawEllipse(pen, greenBrush, 20, 215, 200, 150)

            ' Draw a circle
            pdfPage1.Canvas.DrawText("This is a circle", fontText, Nothing, blackBrush, 300, 200, _
                0, PDFTextAlign.TopLeft)
            pdfPage1.Canvas.DrawEllipse(pen, greenBrush, 300, 215, 200, 200)

            ' Create the second page
            Dim pdfPage2 As PDFPage = pdfDoc.AddPage()

            Dim rnd As New Random()
            Dim i As Integer = 0
            While i < 50
                ' Create random colors for the border and the interior
                Dim brushColor As New PDFRgbColor(rnd.Next(256), rnd.Next(256), rnd.Next(256))
                Dim penColor As New PDFRgbColor(rnd.Next(256), rnd.Next(256), rnd.Next(256))

                ' Create the brush to fill the interior
                Dim randomBrush As New PDFBrush(brushColor)
                ' Create the pen to draw the border
                Dim randomPen As New PDFPen(penColor, 1)

                ' Generate random positions
                Dim left As Double = rnd.NextDouble() * pdfPage2.Width
                Dim top As Double = rnd.NextDouble() * pdfPage2.Height

                ' Generate random sizes
                Dim width As Double = rnd.NextDouble() * (pdfPage2.Width - left)
                ' try to keep the rectangle
                Dim height As Double = rnd.NextDouble() * (pdfPage2.Height - top)
                ' within the page
                ' Draw the ellipse
                pdfPage2.Canvas.DrawEllipse(randomPen, randomBrush, left, top, width, height)

                i = i + 1
            End While

            ' Draw a label
            pdfPage2.Canvas.DrawText("Random ellipses", fontText, Nothing, blackBrush, 20, 350, _
                0, PDFTextAlign.TopLeft)

            ' Save the document to disk
            pdfDoc.Save("Sample_Ellipses.pdf")
        End Sub
    End Class
End Namespace


Samples: Encryption

PDF4NET Send comments on this topic.
Samples: Encryption
PDF4NET On-line Help > Samples > Samples: Encryption

Glossary Item Box

This samples shows the pdf security features of PDF4NET library. It shows user and owner passwords, encryption strength and document access rights. The user user password for the attached document is 'userpass', and the owner password is 'ownerpass'.

C# Source code | VB.NET Source code | PDF file


Encryption.cs

PDF4NET Send comments on this topic.
Encryption.cs
PDF4NET On-line Help > Samples > Encryption > Encryption.cs

Glossary Item Box

using System;
using System.Text;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Security;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.Encryption
{
    /// <summary>
    /// This sample shows how to use the pdf
    /// security features of PDF4NET library
    /// </summary>
    class Encryption
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            // set the security options
            pdfDoc.SecurityManager = new PDFSecurityManager();
            // use 128 bit encryption
            pdfDoc.SecurityManager.KeySize = EncryptionKeySize.Use128BitKey;
            // set user password to "userpass"
            pdfDoc.SecurityManager.UserPassword = Encoding.ASCII.GetBytes("userpass");
            // set owner password to "ownerpass"
            pdfDoc.SecurityManager.OwnerPassword = Encoding.ASCII.GetBytes("ownerpass");
            // allow to print the pdf document
            pdfDoc.SecurityManager.AllowPrint = true;
            // do not allow high quality print
            pdfDoc.SecurityManager.FullQualityPrint = false;
            // do not alow to modify the document
            pdfDoc.SecurityManager.AllowModifyDocument = false;
            // do not allow to extract content (text and images) from the document
            pdfDoc.SecurityManager.AllowExtractContent = false;
            // do not allow to fill forms or to create annotations
            pdfDoc.SecurityManager.AllowInteractiveEdit = false;
            // do not allow forms fill
            pdfDoc.SecurityManager.AllowFormsFill = false;
            // allow to extract content in support for accessibility
            pdfDoc.SecurityManager.AllowAccessibilityExtractContent = true;
            // do not allow to assemble document
            pdfDoc.SecurityManager.AllowAssembleDocument = false;

            // Create one page
            PDFPage pdfPage = pdfDoc.AddPage();

            // Draw "Encrypted Hello world" in the center of the page
            pdfPage.Canvas.DrawText("Encrypted",
                new PDFFont(PDFFontFace.Helvetica, 100), new PDFPen(new PDFRgbColor(255, 0, 0), 1),
                new PDFBrush(new PDFRgbColor(0, 0, 255)), pdfPage.Width / 2, pdfPage.Height / 2 - 3,
                0, PDFTextAlign.BottomCenter);
            pdfPage.Canvas.DrawText("Hello world !",
                new PDFFont(PDFFontFace.Helvetica, 100), new PDFPen(new PDFRgbColor(255, 0, 0), 1),
                new PDFBrush(new PDFRgbColor(0, 0, 255)), pdfPage.Width / 2, pdfPage.Height / 2 + 3,
                0, PDFTextAlign.TopCenter);

            // Save the document to disk
            pdfDoc.Save("Sample_Encryption.pdf");
        }
    }
}


Encryption.vb

PDF4NET Send comments on this topic.
Encryption.vb
PDF4NET On-line Help > Samples > Encryption > Encryption.vb

Glossary Item Box

Imports System
Imports System.Text
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Security
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.Encryption
    ''' <summary>
    ''' This sample shows how to use the pdf
    ''' security features of PDF4NET library
    ''' </summary>
    Class Encryption
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            ' set the security options
            pdfDoc.SecurityManager = New PDFSecurityManager()
            ' use 128 bit encryption
            pdfDoc.SecurityManager.KeySize = EncryptionKeySize.Use128BitKey
            ' set user password to "userpass"
            pdfDoc.SecurityManager.UserPassword = Encoding.ASCII.GetBytes("userpass")
            ' set owner password to "ownerpass"
            pdfDoc.SecurityManager.OwnerPassword = Encoding.ASCII.GetBytes("ownerpass")
            ' allow to print the pdf document
            pdfDoc.SecurityManager.AllowPrint = True
            ' do not allow high quality print
            pdfDoc.SecurityManager.FullQualityPrint = False
            ' do not alow to modify the document
            pdfDoc.SecurityManager.AllowModifyDocument = False
            ' do not allow to extract content (text and images) from the document
            pdfDoc.SecurityManager.AllowExtractContent = False
            ' do not allow to fill forms or to create annotations
            pdfDoc.SecurityManager.AllowInteractiveEdit = False
            ' do not allow forms fill
            pdfDoc.SecurityManager.AllowFormsFill = False
            ' allow to extract content in support for accessibility
            pdfDoc.SecurityManager.AllowAccessibilityExtractContent = True
            ' do not allow to assemble document
            pdfDoc.SecurityManager.AllowAssembleDocument = False

            ' Create one page
            Dim pdfPage As PDFPage = pdfDoc.AddPage()

            ' Draw "Encrypted Hello world" in the center of the page
            pdfPage.Canvas.DrawText("Encrypted", New PDFFont(PDFFontFace.Helvetica, 100), New PDFPen(New PDFRgbColor(255, 0, 0), 1), New PDFBrush(New PDFRgbColor(0, 0, 255)), pdfPage.Width / 2, pdfPage.Height / 2 - 3, _
                0, PDFTextAlign.BottomCenter)
            pdfPage.Canvas.DrawText("Hello world !", New PDFFont(PDFFontFace.Helvetica, 100), New PDFPen(New PDFRgbColor(255, 0, 0), 1), New PDFBrush(New PDFRgbColor(0, 0, 255)), pdfPage.Width / 2, pdfPage.Height / 2 + 3, _
                0, PDFTextAlign.TopCenter)

            ' Save the document to disk
            pdfDoc.Save("Sample_Encryption.pdf")
        End Sub
    End Class
End Namespace


Samples: ExtractImages

PDF4NET Send comments on this topic.
Samples: ExtractImages
PDF4NET On-line Help > Samples > Samples: ExtractImages

Glossary Item Box

This samples shows how to extract the images stored in a PDF file.

C# Source code | VB.NET Source code


ExtractImages.cs

PDF4NET Send comments on this topic.
ExtractImages.cs
PDF4NET On-line Help > Samples > ExtractImages > ExtractImages.cs

Glossary Item Box

using System;
using System.IO;
using System.Text;
using System.Drawing;
using System.Drawing.Imaging;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.PDFFile;

namespace O2S.Samples.PDF4NET
{
    class ExtractImages
    {
        static void Main(string[] args)
        {
            // Load the PDF file.
            PDFDocument doc = new PDFDocument("..\\SupportFiles\\Images.pdf");
            for (int i = 0; i < doc.Pages.Count; i++)
            {
                // Convert the pages to PDFImportedPage to get access to ExtractImages method.
                PDFImportedPage ip = doc.Pages[i] as PDFImportedPage;
                Bitmap[] images = ip.ExtractImages();
                // Save the page images to disk, if there are any.
                for (int j = 0; j < images.Length; j++)
                {
                    images[j].Save("image" + i.ToString() + j.ToString() + ".png", ImageFormat.Png);
                }
            }
        }
    }
}


ExtractImages.vb

PDF4NET Send comments on this topic.
ExtractImages.vb
PDF4NET On-line Help > Samples > ExtractImages > ExtractImages.vb

Glossary Item Box

Imports System
Imports System.IO
Imports System.Text
Imports System.Drawing
Imports System.Drawing.Imaging
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.PDFFile

Namespace O2S.Samples.PDF4NET
    Class ExtractImages
        Shared Sub Main(args As String())
            ' Load the PDF file.
            Dim doc As New PDFDocument("..\SupportFiles\Images.pdf")
            Dim i As Integer = 0
            While i < doc.Pages.Count
                ' Convert the pages to PDFImportedPage to get access to ExtractImages method.
                Dim ip As PDFImportedPage = TryCast(doc.Pages(i), PDFImportedPage)
                Dim images As Bitmap() = ip.ExtractImages()
                ' Save the page images to disk, if there are any.
                Dim j As Integer = 0
                While j < images.Length
                    images(j).Save("image" + i.ToString() + j.ToString() + ".png", ImageFormat.Png)
                    j = j + 1
                End While
                i = i + 1
            End While
        End Sub
    End Class
End Namespace


Samples: Forms

PDF4NET Send comments on this topic.
Samples: Forms
PDF4NET On-line Help > Samples > Samples: Forms

Glossary Item Box

This section includes several samples related to PDF forms.

FormCreate - shows how to create a PDF form using PDF4NET library.

FormFieldsEnumerator - shows how to enumerate all the fields in a PDF form using PDF4NET library.

FormFill - shows how to fill a PDF form using PDF4NET library.

FormFillXFA - shows how to fill a XFA form using PDF4NET library.


Samples: FormCreate

PDF4NET Send comments on this topic.
Samples: FormCreate
PDF4NET On-line Help > Samples > Forms > Samples: FormCreate

Glossary Item Box

This samples shows how to create a PDF e-form using PDF4NET library. The sample creates all types of available fields. It also shows how to attach actions to button clicks and how to create a submit form button.

C# Source code | VB.NET Source code | PDF file


FormCreate.cs

PDF4NET Send comments on this topic.
FormCreate.cs
PDF4NET On-line Help > Samples > Forms > FormCreate > FormCreate.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Actions;
using O2S.Components.PDF4NET.Forms;
using O2S.Components.PDF4NET.Graphics.Fonts;
using O2S.Components.PDF4NET.Annotations;

namespace O2S.Samples.PDF4NET
{
    /// <summary>
    /// This samples shows how to create a PDF e-form using PDF4NET library. The
    /// sample creates all types of available fields. It also shows how to attach
    /// actions to button clicks and how to create a submit form button.
    /// </summary>
    class FormCreate
    {

        [STAThread]
        static void Main(string[] args)
        {
            PDFDocument doc = new PDFDocument();
            PDFPage page = doc.AddPage();

            PDFRgbColor blackColor = new PDFRgbColor(0, 0, 0);

            // Create 4 textboxes.
            PDFTextBoxField tbx = new PDFTextBoxField("TextBox1");
            tbx.Widgets[0].Rectangle = new RectangleF(50, 50, 200, 20);
            tbx.Widgets[0].BorderWidth = 1;
            tbx.Widgets[0].BorderStyle = PDFBorderStyle.Solid;
            tbx.Widgets[0].BorderColor = blackColor;
            page.Fields.Add(tbx);

            tbx = new PDFTextBoxField("TextBox3");
            tbx.Widgets[0].Rectangle = new RectangleF(300, 50, 200, 40);
            tbx.Widgets[0].BorderWidth = 1;
            tbx.Widgets[0].BorderStyle = PDFBorderStyle.Solid;
            tbx.Widgets[0].BorderColor = blackColor;
            tbx.Text = "Sample field value";
            page.Fields.Add(tbx);

            // These 2 textboxes have no border.
            tbx = new PDFTextBoxField("TextBox2");
            tbx.Widgets[0].Rectangle = new RectangleF(50, 100, 200, 20);
            tbx.Text = "<Click here to fill your name>";
            tbx.Value = "";
            page.Fields.Add(tbx);

            tbx = new PDFTextBoxField("TextBox4");
            tbx.Widgets[0].Rectangle = new RectangleF(300, 100, 200, 40);
            page.Fields.Add(tbx);

            // Create a push button
            PDFPushButtonField btn = new PDFPushButtonField("Pushbutton");
            btn.Tooltip = "Button Tooltip";
            (btn.Widgets[0] as PDFPushButtonWidget).Caption = "Push me";
            btn.Widgets[0].Rectangle = new RectangleF(50, 150, 200, 20);
            btn.Widgets[0].Color = new PDFRgbColor(255, 0, 0);
            btn.Widgets[0].BackColor = new PDFRgbColor(0, 255, 0);
            page.Fields.Add(btn);

            // Set an OnClick action for the button
            PDFJavaScriptAction js = new PDFJavaScriptAction();
            js.Script = "var f = this.getField(\"TextBox1\");\r\nf.value = \"test\";";
            btn.Widgets[0].MouseUp = js;

            // Create a submit form push button
            btn = new PDFPushButtonField("SubmitForm");
            btn.Tooltip = "Submits the form fields";
            (btn.Widgets[0] as PDFPushButtonWidget).Caption = "Submit form";
            btn.Widgets[0].Rectangle = new RectangleF(300, 150, 200, 20);
            btn.Widgets[0].Color = new PDFRgbColor(255, 0, 0);
            btn.Widgets[0].BackColor = new PDFRgbColor(0, 255, 0);
            page.Fields.Add(btn);

            // Set an OnClick action for the button
            PDFSubmitFormAction submitFormAction = new PDFSubmitFormAction();
            submitFormAction.Url = "http://localhost/fieldsexplorer/fieldsviewer.aspx";
            submitFormAction.DataFormat = SubmitDataFormat.HTML;
            btn.Widgets[0].MouseUp = submitFormAction;

            // Create a checkbox
            PDFCheckBoxField checkBox = new PDFCheckBoxField("CheckBox");
            (checkBox.Widgets[0] as PDFCheckBoxWidget).ExportValue = "1";
            checkBox.Checked = true;
            (checkBox.Widgets[0] as PDFCheckBoxWidget).CheckSymbolStyle = PDFCheckSymbolStyle.Check;
            checkBox.Widgets[0].Rectangle = new RectangleF(50, 200, 20, 20);
            checkBox.Widgets[0].Color = new PDFRgbColor(0, 0, 0);
            checkBox.Widgets[0].BackColor = new PDFRgbColor(255, 255, 255);
            page.Fields.Add(checkBox);

            // Create a radiobutton list
            PDFRadioButtonListField rbl = new PDFRadioButtonListField("RadioButtonList");
            PDFRadioButtonItem rbi = new PDFRadioButtonItem();
            rbi.CheckSymbolStyle = PDFCheckSymbolStyle.Diamond;
            rbi.ExportValue = "1";
            rbi.Rectangle = new RectangleF(50, 250, 20, 20);
            rbi.Color = new PDFRgbColor(255, 255, 255);
            rbi.BackColor = new PDFRgbColor(0, 0, 0);
            rbl.Widgets.Add(rbi);
            PDFRadioButtonItem rbi2 = new PDFRadioButtonItem();
            rbi2.CheckSymbolStyle = PDFCheckSymbolStyle.Diamond;
            rbi2.ExportValue = "2";
            rbi2.Rectangle = new RectangleF(50, 300, 20, 20);
            rbi2.Color = new PDFRgbColor(255, 255, 255);
            rbi2.BackColor = new PDFRgbColor(0, 0, 0);
            rbl.Widgets.Add(rbi2);
            PDFRadioButtonItem rbi3 = new PDFRadioButtonItem();
            rbi3.CheckSymbolStyle = PDFCheckSymbolStyle.Diamond;
            rbi3.ExportValue = "3";
            rbi3.Rectangle = new RectangleF(50, 350, 20, 20);
            rbi3.Color = new PDFRgbColor(255, 255, 255);
            rbi3.BackColor = new PDFRgbColor(0, 0, 0);
            rbl.Widgets.Add(rbi3);
            rbl.SelectedValue = "3";
            page.Fields.Add(rbl);

            // Create a drop down list
            PDFDropDownListField ddl = new PDFDropDownListField("DropDownList");
            PDFListItem li = new PDFListItem("Item 1", "1");
            ddl.Items.Add(li);
            PDFListItem li2 = new PDFListItem("Item 2", "2");
            ddl.Items.Add(li2);
            PDFListItem li3 = new PDFListItem("Item 3", "3");
            ddl.Items.Add(li3);
            ddl.Widgets[0].Rectangle = new RectangleF(50, 400, 200, 20);
            ddl.Widgets[0].Font = new PDFFont(PDFFontFace.Courier, 10);
            ddl.Widgets[0].BorderWidth = 1;
            ddl.Widgets[0].BorderStyle = PDFBorderStyle.Solid;
            ddl.Widgets[0].BorderColor = new PDFRgbColor(0, 0, 255);
            ddl.SelectedIndex = 1;
            page.Fields.Add(ddl);

            // Create a list box
            PDFListBoxField lbx = new PDFListBoxField("ListBox");
            PDFListItem lxi = new PDFListItem("Item 1", "1");
            PDFListItem lxi2 = new PDFListItem("Item 2", "2");
            PDFListItem lxi3 = new PDFListItem("Item 3", "3");
            lbx.Items.Add(lxi);
            lbx.Items.Add(lxi2);
            lbx.Items.Add(lxi3);
            lbx.Widgets[0].Rectangle = new RectangleF(50, 450, 200, 80);
            lbx.Widgets[0].BorderWidth = 1;
            lbx.Widgets[0].BorderStyle = PDFBorderStyle.Solid;
            lbx.Widgets[0].BorderColor = new PDFRgbColor(0, 0, 255);
            lbx.SelectedIndex = 2;
            page.Fields.Add(lbx);

            doc.Save("Sample_FormNew.pdf");
        }
    }
}


FormCreate.vb

PDF4NET Send comments on this topic.
FormCreate.vb
PDF4NET On-line Help > Samples > Forms > FormCreate > FormCreate.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Actions
Imports O2S.Components.PDF4NET.Forms
Imports O2S.Components.PDF4NET.Graphics.Fonts
Imports O2S.Components.PDF4NET.Annotations

Namespace O2S.Samples.PDF4NET
    ''' <summary>
    ''' This samples shows how to create a PDF e-form using PDF4NET library. The
    ''' sample creates all types of available fields. It also shows how to attach
    ''' actions to button clicks and how to create a submit form button.
    ''' </summary>
    Class FormCreate

        <STAThread> _
        Shared Sub Main(args As String())
            Dim doc As New PDFDocument()
            Dim page As PDFPage = doc.AddPage()

            Dim blackColor As New PDFRgbColor(0, 0, 0)

            ' Create 4 textboxes.
            Dim tbx As New PDFTextBoxField("TextBox1")
            tbx.Widgets(0).Rectangle = New RectangleF(50, 50, 200, 20)
            tbx.Widgets(0).BorderWidth = 1
            tbx.Widgets(0).BorderStyle = PDFBorderStyle.Solid
            tbx.Widgets(0).BorderColor = blackColor
            page.Fields.Add(tbx)

            tbx = New PDFTextBoxField("TextBox3")
            tbx.Widgets(0).Rectangle = New RectangleF(300, 50, 200, 40)
            tbx.Widgets(0).BorderWidth = 1
            tbx.Widgets(0).BorderStyle = PDFBorderStyle.Solid
            tbx.Widgets(0).BorderColor = blackColor
            tbx.Text = "Sample field value"
            page.Fields.Add(tbx)

            ' These 2 textboxes have no border.
            tbx = New PDFTextBoxField("TextBox2")
            tbx.Widgets(0).Rectangle = New RectangleF(50, 100, 200, 20)
            tbx.Text = "<Click here to fill your name>"
            tbx.Value = ""
            page.Fields.Add(tbx)

            tbx = New PDFTextBoxField("TextBox4")
            tbx.Widgets(0).Rectangle = New RectangleF(300, 100, 200, 40)
            page.Fields.Add(tbx)

            ' Create a push button
            Dim btn As New PDFPushButtonField("Pushbutton")
            btn.Tooltip = "Button Tooltip"
            Dim pushButtonWidget As PDFPushButtonWidget = btn.Widgets(0)
            pushButtonWidget.Caption = "Push me"
            btn.Widgets(0).Rectangle = New RectangleF(50, 150, 200, 20)
            btn.Widgets(0).Color = New PDFRgbColor(255, 0, 0)
            btn.Widgets(0).BackColor = New PDFRgbColor(0, 255, 0)
            page.Fields.Add(btn)

            ' Set an OnClick action for the button
            Dim js As New PDFJavaScriptAction()
            js.Script = "var f = this.getField(""TextBox1"");" & vbCr & vbLf & "f.value = ""test"";"
            btn.Widgets(0).MouseUp = js

            ' Create a submit form push button
            btn = New PDFPushButtonField("SubmitForm")
            btn.Tooltip = "Submits the form fields"
            pushButtonWidget = btn.Widgets(0)
            pushButtonWidget.Caption = "Submit form"
            btn.Widgets(0).Rectangle = New RectangleF(300, 150, 200, 20)
            btn.Widgets(0).Color = New PDFRgbColor(255, 0, 0)
            btn.Widgets(0).BackColor = New PDFRgbColor(0, 255, 0)
            page.Fields.Add(btn)

            ' Set an OnClick action for the button
            Dim submitFormAction As New PDFSubmitFormAction()
            submitFormAction.Url = "http://localhost/fieldsexplorer/fieldsviewer.aspx"
            submitFormAction.DataFormat = SubmitDataFormat.HTML
            btn.Widgets(0).MouseUp = submitFormAction

            ' Create a checkbox
            Dim checkBox As New PDFCheckBoxField("CheckBox")
            Dim checkBoxWidget As PDFCheckBoxWidget = checkBox.Widgets(0)
            checkBoxWidget.ExportValue = "1"
            checkBoxWidget.CheckSymbolStyle = PDFCheckSymbolStyle.Check
            checkBox.Widgets(0).Rectangle = New RectangleF(50, 200, 20, 20)
            checkBox.Widgets(0).Color = New PDFRgbColor(0, 0, 0)
            checkBox.Widgets(0).BackColor = New PDFRgbColor(255, 255, 255)
            checkBox.Checked = True
            page.Fields.Add(checkBox)

            ' Create a radiobutton list
            Dim rbl As New PDFRadioButtonListField("RadioButtonList")
            Dim rbi As New PDFRadioButtonItem()
            rbi.CheckSymbolStyle = PDFCheckSymbolStyle.Diamond
            rbi.ExportValue = "1"
            rbi.Rectangle = New RectangleF(50, 250, 20, 20)
            rbi.Color = New PDFRgbColor(255, 255, 255)
            rbi.BackColor = New PDFRgbColor(0, 0, 0)
            rbl.Widgets.Add(rbi)
            Dim rbi2 As New PDFRadioButtonItem()
            rbi2.CheckSymbolStyle = PDFCheckSymbolStyle.Diamond
            rbi2.ExportValue = "2"
            rbi2.Rectangle = New RectangleF(50, 300, 20, 20)
            rbi2.Color = New PDFRgbColor(255, 255, 255)
            rbi2.BackColor = New PDFRgbColor(0, 0, 0)
            rbl.Widgets.Add(rbi2)
            Dim rbi3 As New PDFRadioButtonItem()
            rbi3.CheckSymbolStyle = PDFCheckSymbolStyle.Diamond
            rbi3.ExportValue = "3"
            rbi3.Rectangle = New RectangleF(50, 350, 20, 20)
            rbi3.Color = New PDFRgbColor(255, 255, 255)
            rbi3.BackColor = New PDFRgbColor(0, 0, 0)
            rbl.Widgets.Add(rbi3)
            rbl.SelectedValue = "3"
            page.Fields.Add(rbl)

            ' Create a drop down list
            Dim ddl As New PDFDropDownListField("DropDownList")
            Dim li As New PDFListItem("Item 1", "1")
            ddl.Items.Add(li)
            Dim li2 As New PDFListItem("Item 2", "2")
            ddl.Items.Add(li2)
            Dim li3 As New PDFListItem("Item 3", "3")
            ddl.Items.Add(li3)
            ddl.Widgets(0).Rectangle = New RectangleF(50, 400, 200, 20)
            ddl.Widgets(0).Font = New PDFFont(PDFFontFace.Courier, 10)
            ddl.Widgets(0).BorderWidth = 1
            ddl.Widgets(0).BorderStyle = PDFBorderStyle.Solid
            ddl.Widgets(0).BorderColor = New PDFRgbColor(0, 0, 255)
            ddl.SelectedIndex = 1
            page.Fields.Add(ddl)

            ' Create a list box
            Dim lbx As New PDFListBoxField("ListBox")
            Dim lxi As New PDFListItem("Item 1", "1")
            Dim lxi2 As New PDFListItem("Item 2", "2")
            Dim lxi3 As New PDFListItem("Item 3", "3")
            lbx.Items.Add(lxi)
            lbx.Items.Add(lxi2)
            lbx.Items.Add(lxi3)
            lbx.Widgets(0).Rectangle = New RectangleF(50, 450, 200, 80)
            lbx.Widgets(0).BorderWidth = 1
            lbx.Widgets(0).BorderStyle = PDFBorderStyle.Solid
            lbx.Widgets(0).BorderColor = New PDFRgbColor(0, 0, 255)
            lbx.SelectedIndex = 2
            page.Fields.Add(lbx)

            doc.Save("Sample_FormNew.pdf")
        End Sub
    End Class
End Namespace


Samples: FormFieldsEnumerator

PDF4NET Send comments on this topic.
Samples: FormFieldsEnumerator
PDF4NET On-line Help > Samples > Forms > Samples: FormFieldsEnumerator

Glossary Item Box

This sample shows how to enumerate the fields in a PDF document. Because PDF specification allows the same field to appear multiple times (both on the same page, and in the document), a difference is made between fields and their widgets (their visual representations). For example, if the same field appears 3 times in a PDF file, the Fields collection of the document will contain only one element, 1 field. The field tells the user how many widgets it has.
The radiobutton list is a special case: each item can have only one widget, but the list can spread over multiple pages (for example 3 items on a page, 3 items on another page, like in the PDF file used in this sample).

C# Source code | VB.NET Source code | PDF file


FormFieldsEnumerator.cs

PDF4NET Send comments on this topic.
FormFieldsEnumerator.cs
PDF4NET On-line Help > Samples > Forms > FormFieldsEnumerator > FormFieldsEnumerator.cs

Glossary Item Box

using System;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Forms;

namespace O2S.Samples.PDF4NET
{
    /// <summary>
    /// This sample shows how to enumerate the fields in a PDF document. Because PDF specification
    /// allows the same field to appear multiple times (both on the same page, and in the document),
    /// a difference is made between fields and their widgets (their visual representations).
    /// For example, if the same field appears 3 times in a PDF file, the Fields collection of the
    /// document will contain only one element, 1 field. The field tells the user how many
    /// widgets it has.
    /// The radiobutton list is a special case: each item can have only one widget, but the list
    /// can spread over multiple pages (for example 3 items on a page, 3 items on another page, like
    /// in the PDF file used in this sample).
    /// </summary>
    class FormFieldsEnumerator
    {
        [STAThread]
        static void Main(string[] args)
        {
            // Load the PDF document
            PDFDocument doc = new PDFDocument( "..\\SupportFiles\\FormFieldsEnumerator.pdf" );

            // Display total number of fields in the document
            // 6 fields: 1 text box (3 widgets), 1 checkbox (3 widgets), 1 combobox (1 widget)
            // 1 listbox (1 widget), 1 radiobuttonlist (6 items), 1 pushbutton (1 widget)
            Console.WriteLine( "Total number of fields in the document: {0}", doc.Form.Fields.Count );

            // Display number of fields located on page 1
            // 6 fields: 1 text box (2 widgets), 1 checkbox (3 widgets), 1 combobox (1 widget)
            // 1 listbox (1 widget), 1 radiobuttonlist (3 items on this page), 1 pushbutton
            Console.WriteLine( "Number of fields on page 1: {0}", doc.Pages[0].Fields.Count );

            // Display number of fields located on page 2
            // 2 fields: 1 text box (1 widgets), 1 radiobuttonlist (3 items on this page)
            Console.WriteLine( "Number of fields on page 2: {0}", doc.Pages[1].Fields.Count );

            // Sum of fields on both pages is different from the number of fields
            // in the document because there are fields that appear on both pages (TextBox and RadioButton)
            Console.WriteLine( "Sum of fields on both pages is different from the number of fields " +
                "in the document because there are fields that appear on both pages (TextBox and RadioButton)" );
            Console.WriteLine( " " );

            // Enumerate the widgets of all fields in the document
            Console.WriteLine( "Field widgets at document level" );
            for( int i = 0; i < doc.Form.Fields.Count; i++ )
            {
                // Display the field name
                Console.WriteLine( "Field name: {0}", doc.Form.Fields[i].Name );

                switch (doc.Form.Fields[i].Type)
                {
                    case PDFFieldType.TextBox:
                        PDFTextBoxField textBox = (PDFTextBoxField)doc.Form.Fields[i];
                        for (int wx = 0; wx < textBox.Widgets.Count; wx++)
                        {
                            DisplayRectangle rc = textBox.Widgets[wx].DisplayRectangle;
                            // Display widget position on the page
                            Console.WriteLine(" Position for widget {0} " +
                                "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}",
                                wx + 1, rc.Left, rc.Top, rc.Width, rc.Height);
                        }
                        break;
                    case PDFFieldType.PushButton:
                        PDFPushButtonField pushButton = (PDFPushButtonField)doc.Form.Fields[i];
                        for (int wx = 0; wx < pushButton.Widgets.Count; wx++)
                        {
                            DisplayRectangle rc = pushButton.Widgets[wx].DisplayRectangle;
                            // Display widget position on the page
                            Console.WriteLine(" Position for widget {0} " +
                                "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}",
                                wx + 1, rc.Left, rc.Top, rc.Width, rc.Height);
                        }
                        break;
                    case PDFFieldType.CheckBox:
                        PDFCheckBoxField checkBox = (PDFCheckBoxField)doc.Form.Fields[i];
                        for (int wx = 0; wx < checkBox.Widgets.Count; wx++)
                        {
                            DisplayRectangle rc = checkBox.Widgets[wx].DisplayRectangle;
                            // Display widget position on the page
                            Console.WriteLine(" Position for widget {0} " +
                                "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}",
                                wx + 1, rc.Left, rc.Top, rc.Width, rc.Height);

                            Console.WriteLine(" Export value for widget {0}: {1}",
                                wx + 1, (checkBox.Widgets[wx] as PDFCheckBoxWidget).ExportValue);
                            Console.WriteLine(" Widget {0} is checked: {1}",
                                wx + 1, (checkBox.Widgets[wx] as PDFCheckBoxWidget).Checked);
                        }
                        break;
                    case PDFFieldType.DropDownList:
                        PDFDropDownListField dropDownList = (PDFDropDownListField)doc.Form.Fields[i];
                        for (int wx = 0; wx < dropDownList.Widgets.Count; wx++)
                        {
                            DisplayRectangle rc = dropDownList.Widgets[wx].DisplayRectangle;
                            // Display widget position on the page
                            Console.WriteLine(" Position for widget {0} " +
                                "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}",
                                wx + 1, rc.Left, rc.Top, rc.Width, rc.Height);
                        }
                        break;
                    case PDFFieldType.ListBox:
                        PDFListBoxField listBox = (PDFListBoxField)doc.Form.Fields[i];
                        for (int wx = 0; wx < listBox.Widgets.Count; wx++)
                        {
                            DisplayRectangle rc = listBox.Widgets[wx].DisplayRectangle;
                            // Display widget position on the page
                            Console.WriteLine(" Position for widget {0} " +
                                "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}",
                                wx + 1, rc.Left, rc.Top, rc.Width, rc.Height);
                        }
                        break;
                    case PDFFieldType.RadioButton:
                        PDFRadioButtonListField radioButtonList =
                            (PDFRadioButtonListField)doc.Form.Fields[i];
                        Console.WriteLine(" Field \"{0}\" has {1} item(s)",
                            radioButtonList.Name, radioButtonList.Widgets.Count);
                        break;
                }
                Console.WriteLine(" Field \"{0}\" has {1} widget(s)", doc.Form.Fields[i].Name, doc.Form.Fields[i].Widgets.Count);
            }

            Console.WriteLine( " " );

            // Enumerate the widgets of all fields at page level
            Console.WriteLine( "Field widgets at page level" );
            for( int j = 0; j < doc.Pages.Count; j++ )
            {
                Console.WriteLine( "*** Field widgets on page {0}", j + 1 );

                for (int i = 0; i < doc.Pages[j].Fields.Count; i++)
                {
                    // Display the field name
                    Console.WriteLine("Field name: {0}", doc.Pages[j].Fields[i].Name);

                    switch (doc.Pages[j].Fields[i].Type)
                    {
                        case PDFFieldType.TextBox:
                            PDFTextBoxField textBox = (PDFTextBoxField)doc.Pages[j].Fields[i];
                            for (int wx = 0; wx < textBox.Widgets.Count; wx++)
                            {
                                // Consider only the widgets on current page.
                                if (textBox.Widgets[wx].Page == doc.Pages[j])
                                {
                                    DisplayRectangle rc = textBox.Widgets[wx].DisplayRectangle;
                                    // Display widget position on the page
                                    Console.WriteLine(" Position for widget {0} " +
                                        "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}",
                                        wx + 1, rc.Left, rc.Top, rc.Width, rc.Height);
                                }
                            }
                            break;
                        case PDFFieldType.PushButton:
                            PDFPushButtonField pushButton = (PDFPushButtonField)doc.Pages[j].Fields[i];
                            for (int wx = 0; wx < pushButton.Widgets.Count; wx++)
                            {
                                // Consider only the widgets on current page.
                                if (pushButton.Widgets[wx].Page == doc.Pages[j])
                                {
                                    DisplayRectangle rc = pushButton.Widgets[wx].DisplayRectangle;
                                    // Display widget position on the page
                                    Console.WriteLine(" Position for widget {0} " +
                                        "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}",
                                        wx + 1, rc.Left, rc.Top, rc.Width, rc.Height);
                                }
                            }
                            break;
                        case PDFFieldType.CheckBox:
                            PDFCheckBoxField checkBox = (PDFCheckBoxField)doc.Pages[j].Fields[i];
                            for (int wx = 0; wx < checkBox.Widgets.Count; wx++)
                            {
                                // Consider only the widgets on current page.
                                if (checkBox.Widgets[wx].Page == doc.Pages[j])
                                {
                                    DisplayRectangle rc = checkBox.Widgets[wx].DisplayRectangle;
                                    // Display widget position on the page
                                    Console.WriteLine(" Position for widget {0} " +
                                        "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}",
                                        wx + 1, rc.Left, rc.Top, rc.Width, rc.Height);

                                    Console.WriteLine(" Export value for widget {0}: {1}",
                                        wx + 1, (checkBox.Widgets[wx] as PDFCheckBoxWidget).ExportValue);
                                    Console.WriteLine(" Widget {0} is checked: {1}",
                                        wx + 1, (checkBox.Widgets[wx] as PDFCheckBoxWidget).Checked);
                                }
                            }
                            break;
                        case PDFFieldType.DropDownList:
                            PDFDropDownListField dropDownList = (PDFDropDownListField)doc.Pages[j].Fields[i];
                            for (int wx = 0; wx < dropDownList.Widgets.Count; wx++)
                            {
                                // Consider only the widgets on current page.
                                if (dropDownList.Widgets[wx].Page == doc.Pages[j])
                                {
                                    DisplayRectangle rc = dropDownList.Widgets[wx].DisplayRectangle;
                                    // Display widget position on the page
                                    Console.WriteLine(" Position for widget {0} " +
                                        "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}",
                                        wx + 1, rc.Left, rc.Top, rc.Width, rc.Height);
                                }
                            }
                            break;
                        case PDFFieldType.ListBox:
                            PDFListBoxField listBox = (PDFListBoxField)doc.Pages[j].Fields[i];
                            for (int wx = 0; wx < listBox.Widgets.Count; wx++)
                            {
                                // Consider only the widgets on current page.
                                if (listBox.Widgets[wx].Page == doc.Pages[j])
                                {
                                    DisplayRectangle rc = listBox.Widgets[wx].DisplayRectangle;
                                    // Display widget position on the page
                                    Console.WriteLine(" Position for widget {0} " +
                                        "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}",
                                        wx + 1, rc.Left, rc.Top, rc.Width, rc.Height);
                                }
                            }
                            break;
                        case PDFFieldType.RadioButton:
                            PDFRadioButtonListField radioButtonList =
                                (PDFRadioButtonListField)doc.Pages[j].Fields[i];
                            // Number of radiobutton items located on this page
                            int itemsCount = 0;
                            for (int k = 0; k < radioButtonList.Widgets.Count; k++)
                            {
                                if (radioButtonList.Widgets[k].Page == doc.Pages[j])
                                {
                                    itemsCount++;
                                    DisplayRectangle rc = radioButtonList.Widgets[k].DisplayRectangle;
                                    // Display widget position on the page
                                    Console.WriteLine(" Position for item {0} " +
                                        "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}",
                                        itemsCount, rc.Left, rc.Top, rc.Width, rc.Height);
                                }
                            }
                            Console.WriteLine(" Field \"{0}\" has {1} item(s) on this page",
                                radioButtonList.Name, itemsCount);
                            break;
                    }
                }
            }
        }
    }
}


FormFieldsEnumerator.vb

PDF4NET Send comments on this topic.
FormFieldsEnumerator.vb
PDF4NET On-line Help > Samples > Forms > FormFieldsEnumerator > FormFieldsEnumerator.vb

Glossary Item Box

Imports System
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Forms

Namespace O2S.Samples.PDF4NET
    ''' <summary>
    ''' This sample shows how to enumerate the fields in a PDF document. Because PDF specification
    ''' allows the same field to appear multiple times (both on the same page, and in the document),
    ''' a difference is made between fields and their widgets (their visual representations).
    ''' For example, if the same field appears 3 times in a PDF file, the Fields collection of the
    ''' document will contain only one element, 1 field. The field tells the user how many
    ''' widgets it has.
    ''' The radiobutton list is a special case: each item can have only one widget, but the list
    ''' can spread over multiple pages (for example 3 items on a page, 3 items on another page, like
    ''' in the PDF file used in this sample).
    ''' </summary>
    Class FormFieldsEnumerator
        <STAThread> _
        Shared Sub Main(args As String())
            ' Load the PDF document
            Dim doc As New PDFDocument("..\SupportFiles\FormFieldsEnumerator.pdf")

            ' Display total number of fields in the document
            ' 6 fields: 1 text box (3 widgets), 1 checkbox (3 widgets), 1 combobox (1 widget)
            ' 1 listbox (1 widget), 1 radiobuttonlist (6 items), 1 pushbutton (1 widget)
            Console.WriteLine("Total number of fields in the document: {0}", doc.Form.Fields.Count)

            ' Display number of fields located on page 1
            ' 6 fields: 1 text box (2 widgets), 1 checkbox (3 widgets), 1 combobox (1 widget)
            ' 1 listbox (1 widget), 1 radiobuttonlist (3 items on this page), 1 pushbutton
            Console.WriteLine("Number of fields on page 1: {0}", doc.Pages(0).Fields.Count)

            ' Display number of fields located on page 2
            ' 2 fields: 1 text box (1 widgets), 1 radiobuttonlist (3 items on this page)
            Console.WriteLine("Number of fields on page 2: {0}", doc.Pages(1).Fields.Count)

            ' Sum of fields on both pages is different from the number of fields
            ' in the document because there are fields that appear on both pages (TextBox and RadioButton)
            Console.WriteLine("Sum of fields on both pages is different from the number of fields " + "in the document because there are fields that appear on both pages (TextBox and RadioButton)")
            Console.WriteLine(" ")

            ' Enumerate the widgets of all fields in the document
            Console.WriteLine("Field widgets at document level")
            Dim i As Integer = 0
            While i < doc.Form.Fields.Count
                ' Display the field name
                Console.WriteLine("Field name: {0}", doc.Form.Fields(i).Name)

                Select Case doc.Form.Fields(i).Type
                    Case PDFFieldType.TextBox
                        Dim textBox As PDFTextBoxField = DirectCast(doc.Form.Fields(i), PDFTextBoxField)
                        Dim wx As Integer = 0
                        While wx < textBox.Widgets.Count
                            Dim rc As DisplayRectangle = textBox.Widgets(wx).DisplayRectangle
                            ' Display widget position on the page
                            Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height)
                            wx = wx + 1
                        End While
                        Exit Select
                    Case PDFFieldType.PushButton
                        Dim pushButton As PDFPushButtonField = DirectCast(doc.Form.Fields(i), PDFPushButtonField)
                        Dim wx As Integer = 0
                        While wx < pushButton.Widgets.Count
                            Dim rc As DisplayRectangle = pushButton.Widgets(wx).DisplayRectangle
                            ' Display widget position on the page
                            Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height)
                            wx = wx + 1
                        End While
                        Exit Select
                    Case PDFFieldType.CheckBox
                        Dim checkBox As PDFCheckBoxField = DirectCast(doc.Form.Fields(i), PDFCheckBoxField)
                        Dim wx As Integer = 0
                        While wx < checkBox.Widgets.Count
                            Dim rc As DisplayRectangle = checkBox.Widgets(wx).DisplayRectangle
                            ' Display widget position on the page
                            Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height)

                            Console.WriteLine(" Export value for widget {0}: {1}", wx + 1, (TryCast(checkBox.Widgets(wx), PDFCheckBoxWidget)).ExportValue)
                            Console.WriteLine(" Widget {0} is checked: {1}", wx + 1, (TryCast(checkBox.Widgets(wx), PDFCheckBoxWidget)).Checked)
                            wx = wx + 1
                        End While
                        Exit Select
                    Case PDFFieldType.DropDownList
                        Dim dropDownList As PDFDropDownListField = DirectCast(doc.Form.Fields(i), PDFDropDownListField)
                        Dim wx As Integer = 0
                        While wx < dropDownList.Widgets.Count
                            Dim rc As DisplayRectangle = dropDownList.Widgets(wx).DisplayRectangle
                            ' Display widget position on the page
                            Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height)
                            wx = wx + 1
                        End While
                        Exit Select
                    Case PDFFieldType.ListBox
                        Dim listBox As PDFListBoxField = DirectCast(doc.Form.Fields(i), PDFListBoxField)
                        Dim wx As Integer = 0
                        While wx < listBox.Widgets.Count
                            Dim rc As DisplayRectangle = listBox.Widgets(wx).DisplayRectangle
                            ' Display widget position on the page
                            Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height)
                            wx = wx + 1
                        End While
                        Exit Select
                    Case PDFFieldType.RadioButton
                        Dim radioButtonList As PDFRadioButtonListField = DirectCast(doc.Form.Fields(i), PDFRadioButtonListField)
                        Console.WriteLine(" Field ""{0}"" has {1} item(s)", radioButtonList.Name, radioButtonList.Widgets.Count)
                        Exit Select
                End Select
                Console.WriteLine(" Field ""{0}"" has {1} widget(s)", doc.Form.Fields(i).Name, doc.Form.Fields(i).Widgets.Count)
                i = i + 1
            End While

            Console.WriteLine(" ")

            ' Enumerate the widgets of all fields at page level
            Console.WriteLine("Field widgets at page level")
            Dim j As Integer = 0
            While j < doc.Pages.Count
                Console.WriteLine("*** Field widgets on page {0}", j + 1)

                i = 0
                While i < doc.Pages(j).Fields.Count
                    ' Display the field name
                    Console.WriteLine("Field name: {0}", doc.Pages(j).Fields(i).Name)

                    Select Case doc.Pages(j).Fields(i).Type
                        Case PDFFieldType.TextBox
                            Dim textBox As PDFTextBoxField = DirectCast(doc.Pages(j).Fields(i), PDFTextBoxField)
                            Dim wx As Integer = 0
                            While wx < textBox.Widgets.Count
                                ' Consider only the widgets on current page.
                                If Object.Equals(textBox.Widgets(wx).Page, doc.Pages(j)) Then
                                    Dim rc As DisplayRectangle = textBox.Widgets(wx).DisplayRectangle
                                    ' Display widget position on the page
                                    Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height)
                                End If
                                wx = wx + 1
                            End While
                            Exit Select
                        Case PDFFieldType.PushButton
                            Dim pushButton As PDFPushButtonField = DirectCast(doc.Pages(j).Fields(i), PDFPushButtonField)
                            Dim wx As Integer = 0
                            While wx < pushButton.Widgets.Count
                                ' Consider only the widgets on current page.
                                If Object.Equals(pushButton.Widgets(wx).Page, doc.Pages(j)) Then
                                    Dim rc As DisplayRectangle = pushButton.Widgets(wx).DisplayRectangle
                                    ' Display widget position on the page
                                    Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height)
                                End If
                                wx = wx + 1
                            End While
                            Exit Select
                        Case PDFFieldType.CheckBox
                            Dim checkBox As PDFCheckBoxField = DirectCast(doc.Pages(j).Fields(i), PDFCheckBoxField)
                            Dim wx As Integer = 0
                            While wx < checkBox.Widgets.Count
                                ' Consider only the widgets on current page.
                                If Object.Equals(checkBox.Widgets(wx).Page, doc.Pages(j)) Then
                                    Dim rc As DisplayRectangle = checkBox.Widgets(wx).DisplayRectangle
                                    ' Display widget position on the page
                                    Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height)

                                    Console.WriteLine(" Export value for widget {0}: {1}", wx + 1, (TryCast(checkBox.Widgets(wx), PDFCheckBoxWidget)).ExportValue)
                                    Console.WriteLine(" Widget {0} is checked: {1}", wx + 1, (TryCast(checkBox.Widgets(wx), PDFCheckBoxWidget)).Checked)
                                End If
                                wx = wx + 1
                            End While
                            Exit Select
                        Case PDFFieldType.DropDownList
                            Dim dropDownList As PDFDropDownListField = DirectCast(doc.Pages(j).Fields(i), PDFDropDownListField)
                            Dim wx As Integer = 0
                            While wx < dropDownList.Widgets.Count
                                ' Consider only the widgets on current page.
                                If Object.Equals(dropDownList.Widgets(wx).Page, doc.Pages(j)) Then
                                    Dim rc As DisplayRectangle = dropDownList.Widgets(wx).DisplayRectangle
                                    ' Display widget position on the page
                                    Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height)
                                End If
                                wx = wx + 1
                            End While
                            Exit Select
                        Case PDFFieldType.ListBox
                            Dim listBox As PDFListBoxField = DirectCast(doc.Pages(j).Fields(i), PDFListBoxField)
                            Dim wx As Integer = 0
                            While wx < listBox.Widgets.Count
                                ' Consider only the widgets on current page.
                                If Object.Equals(listBox.Widgets(wx).Page, doc.Pages(j)) Then
                                    Dim rc As DisplayRectangle = listBox.Widgets(wx).DisplayRectangle
                                    ' Display widget position on the page
                                    Console.WriteLine(" Position for widget {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", wx + 1, rc.Left, rc.Top, rc.Width, rc.Height)
                                End If
                                wx = wx + 1
                            End While
                            Exit Select
                        Case PDFFieldType.RadioButton
                            Dim radioButtonList As PDFRadioButtonListField = DirectCast(doc.Pages(j).Fields(i), PDFRadioButtonListField)
                            ' Number of radiobutton items located on this page
                            Dim itemsCount As Integer = 0
                            Dim k As Integer = 0
                            While k < radioButtonList.Widgets.Count
                                If Object.Equals(radioButtonList.Widgets(k).Page, doc.Pages(j)) Then
                                    itemsCount = itemsCount + 1
                                    Dim rc As DisplayRectangle = radioButtonList.Widgets(k).DisplayRectangle
                                    ' Display widget position on the page
                                    Console.WriteLine(" Position for item {0} " + "(Left|Top|Width|Height): {1:0.####}|{2:0.####}|{3:0.####}|{4:0.####}", itemsCount, rc.Left, rc.Top, rc.Width, rc.Height)
                                End If
                                k = k + 1
                            End While
                            Console.WriteLine(" Field ""{0}"" has {1} item(s) on this page", radioButtonList.Name, itemsCount)
                            Exit Select
                    End Select
                    i = i + 1
                End While
                j = j + 1
            End While
        End Sub
    End Class
End Namespace


Samples: Formfill

PDF4NET Send comments on this topic.
Samples: Formfill
PDF4NET On-line Help > Samples > Forms > Samples: Formfill

Glossary Item Box

This sample demonstrates how to fill a PDF form using PDF4NET.

C# Source code | VB.NET Source code | PDF file


FormFill.cs

PDF4NET Send comments on this topic.
FormFill.cs
PDF4NET On-line Help > Samples > Forms > FormFill > FormFill.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Forms;

namespace O2S.Samples.PDF4NET
{
    /// <summary>
    /// This sample shows how to fill a PDF form using PDF4NET library.
    /// </summary>
    class FormFill
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument doc = new PDFDocument("..\\SupportFiles\\fw4.pdf");

            // fill the fields from the first page
            (doc.Form.Fields["f1-1"] as PDFTextBoxField).Text = "1";
            (doc.Form.Fields["f1-2"] as PDFTextBoxField).Text = "1";
            (doc.Form.Fields["f1-3"] as PDFTextBoxField).Text = "1";
            (doc.Form.Fields["f1-4"] as PDFTextBoxField).Text = "3";
            (doc.Form.Fields["f1-5"] as PDFTextBoxField).Text = "1";
            (doc.Form.Fields["f1-6"] as PDFTextBoxField).Text = "1";
            (doc.Form.Fields["f1-7"] as PDFTextBoxField).Text = "22";
            (doc.Form.Fields["f1-8"] as PDFTextBoxField).Text = "30";
            (doc.Form.Fields["f1-9"] as PDFTextBoxField).Text = "John";
            (doc.Form.Fields["f1-10"] as PDFTextBoxField).Text = "Doe";
            (doc.Form.Fields["f1-11"] as PDFTextBoxField).Text = "11 Voltaire str.";
            (doc.Form.Fields["f1-12"] as PDFTextBoxField).Text = "Cluj-Napoca, CJ 400000";
            (doc.Form.Fields["f1-13"] as PDFTextBoxField).Text = "332";
            (doc.Form.Fields["f1-14"] as PDFTextBoxField).Text = "43";
            (doc.Form.Fields["f1-15"] as PDFTextBoxField).Text = "4556";
            (doc.Form.Fields["f1-16"] as PDFTextBoxField).Text = "3";
            (doc.Form.Fields["f1-17"] as PDFTextBoxField).Text = "2000";
            (doc.Form.Fields["f1-18"] as PDFTextBoxField).Text = "Exempt";
            (doc.Form.Fields["f1-19"] as PDFTextBoxField).Text = "PDF4NET SRL, 11 Voltaire str., Cluj-Napoca, CJ 400000";
            (doc.Form.Fields["f1-20"] as PDFTextBoxField).Text = "200";
            (doc.Form.Fields["f1-21"] as PDFTextBoxField).Text = "22";
            (doc.Form.Fields["f1-22"] as PDFTextBoxField).Text = "56654";
            (doc.Form.Fields["c1-1"] as PDFCheckBoxField).Value = "Yes";
            (doc.Form.Fields["c1-2"] as PDFCheckBoxField).Checked = true;

            // fill the fields from the second page
            (doc.Form.Fields["f2-1"] as PDFTextBoxField).Text = "3200";
            (doc.Form.Fields["f2-2"] as PDFTextBoxField).Text = "4850";
            (doc.Form.Fields["f2-3"] as PDFTextBoxField).Text = "0";
            (doc.Form.Fields["f2-4"] as PDFTextBoxField).Text = "500";
            (doc.Form.Fields["f2-5"] as PDFTextBoxField).Text = "500";
            (doc.Form.Fields["f2-6"] as PDFTextBoxField).Text = "800";
            (doc.Form.Fields["f2-7"] as PDFTextBoxField).Text = "0";
            (doc.Form.Fields["f2-8"] as PDFTextBoxField).Text = "0";
            (doc.Form.Fields["f2-9"] as PDFTextBoxField).Text = "3";
            (doc.Form.Fields["f2-10"] as PDFTextBoxField).Text = "3";
            (doc.Form.Fields["f2-11"] as PDFTextBoxField).Text = "3";
            (doc.Form.Fields["f2-12"] as PDFTextBoxField).Text = "2";
            (doc.Form.Fields["f2-13"] as PDFTextBoxField).Text = "3";
            (doc.Form.Fields["f2-14"] as PDFTextBoxField).Text = "3";
            (doc.Form.Fields["f2-15"] as PDFTextBoxField).Text = "2";
            (doc.Form.Fields["f2-16"] as PDFTextBoxField).Text = "1";
            (doc.Form.Fields["f2-17"] as PDFTextBoxField).Text = "200";
            (doc.Form.Fields["f2-18"] as PDFTextBoxField).Text = "600";
            (doc.Form.Fields["f2-19"] as PDFTextBoxField).Text = "250";

            // the fields below do not exist in the sample pdf file
            // the code is provided to show how to work with other field types

            // select a checkbox
            //( doc.Form.Fields["c1-1"] as PDFCheckBoxField ).Checked = true;

            // select the second radio button in the list
            //( doc.Form.Fields["r1-1"] as PDFRadioButtonListField ).SelectedIndex = 1;

            // select the first item in the drop down list
            //( doc.Form.Fields["ddl1-1"] as PDFDropDownListField ).SelectedIndex = 0;

            // select the 4th item in the list box
            //( doc.Form.Fields["lb1-1"] as PDFTextBoxField ).SelectedIndex = 3;

            // Save the document to disk
            doc.Save("Sample_Fw4fill.pdf");
        }
    }
}


FormFill.vb

PDF4NET Send comments on this topic.
FormFill.vb
PDF4NET On-line Help > Samples > Forms > FormFill > FormFill.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Forms

Namespace O2S.Samples.PDF4NET
    ''' <summary>
    ''' This sample shows how to fill a PDF form using PDF4NET library.
    ''' </summary>
    Class FormFill
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim doc As New PDFDocument("..\SupportFiles\fw4.pdf")

            ' fill the fields from the first page
            CType(doc.Form.Fields("f1-1"), PDFTextBoxField).Text = "1"
            CType(doc.Form.Fields("f1-2"), PDFTextBoxField).Text = "1"
            CType(doc.Form.Fields("f1-3"), PDFTextBoxField).Text = "1"
            CType(doc.Form.Fields("f1-4"), PDFTextBoxField).Text = "3"
            CType(doc.Form.Fields("f1-5"), PDFTextBoxField).Text = "1"
            CType(doc.Form.Fields("f1-6"), PDFTextBoxField).Text = "1"
            CType(doc.Form.Fields("f1-7"), PDFTextBoxField).Text = "22"
            CType(doc.Form.Fields("f1-8"), PDFTextBoxField).Text = "30"
            CType(doc.Form.Fields("f1-9"), PDFTextBoxField).Text = "John"
            CType(doc.Form.Fields("f1-10"), PDFTextBoxField).Text = "Doe"
            CType(doc.Form.Fields("f1-11"), PDFTextBoxField).Text = "11 Voltaire str."
            CType(doc.Form.Fields("f1-12"), PDFTextBoxField).Text = "Cluj-Napoca, CJ 400000"
            CType(doc.Form.Fields("f1-13"), PDFTextBoxField).Text = "332"
            CType(doc.Form.Fields("f1-14"), PDFTextBoxField).Text = "43"
            CType(doc.Form.Fields("f1-15"), PDFTextBoxField).Text = "4556"
            CType(doc.Form.Fields("f1-16"), PDFTextBoxField).Text = "3"
            CType(doc.Form.Fields("f1-17"), PDFTextBoxField).Text = "2000"
            CType(doc.Form.Fields("f1-18"), PDFTextBoxField).Text = "Exempt"
            CType(doc.Form.Fields("f1-19"), PDFTextBoxField).Text = "PDF4NET SRL, 11 Voltaire str., Cluj-Napoca, CJ 400000"
            CType(doc.Form.Fields("f1-20"), PDFTextBoxField).Text = "200"
            CType(doc.Form.Fields("f1-21"), PDFTextBoxField).Text = "22"
            CType(doc.Form.Fields("f1-22"), PDFTextBoxField).Text = "56654"
            CType(doc.Form.Fields("c1-1"), PDFCheckBoxField).Value = "Yes"
            CType(doc.Form.Fields("c1-2"), PDFCheckBoxField).Checked = True

            ' fill the fields from the second page
            CType(doc.Form.Fields("f2-1"), PDFTextBoxField).Text = "3200"
            CType(doc.Form.Fields("f2-2"), PDFTextBoxField).Text = "4850"
            CType(doc.Form.Fields("f2-3"), PDFTextBoxField).Text = "0"
            CType(doc.Form.Fields("f2-4"), PDFTextBoxField).Text = "500"
            CType(doc.Form.Fields("f2-5"), PDFTextBoxField).Text = "500"
            CType(doc.Form.Fields("f2-6"), PDFTextBoxField).Text = "800"
            CType(doc.Form.Fields("f2-7"), PDFTextBoxField).Text = "0"
            CType(doc.Form.Fields("f2-8"), PDFTextBoxField).Text = "0"
            CType(doc.Form.Fields("f2-9"), PDFTextBoxField).Text = "3"
            CType(doc.Form.Fields("f2-10"), PDFTextBoxField).Text = "3"
            CType(doc.Form.Fields("f2-11"), PDFTextBoxField).Text = "3"
            CType(doc.Form.Fields("f2-12"), PDFTextBoxField).Text = "2"
            CType(doc.Form.Fields("f2-13"), PDFTextBoxField).Text = "3"
            CType(doc.Form.Fields("f2-14"), PDFTextBoxField).Text = "3"
            CType(doc.Form.Fields("f2-15"), PDFTextBoxField).Text = "2"
            CType(doc.Form.Fields("f2-16"), PDFTextBoxField).Text = "1"
            CType(doc.Form.Fields("f2-17"), PDFTextBoxField).Text = "200"
            CType(doc.Form.Fields("f2-18"), PDFTextBoxField).Text = "600"
            CType(doc.Form.Fields("f2-19"), PDFTextBoxField).Text = "250"

            ' the fields below do not exist in the sample pdf file
            ' the code is provided to show how to work with other field types

            ' select a checkbox
            '( doc.Form.Fields["c1-1"] as PDFCheckBoxField ).Checked = true

            ' select the second radio button in the list
            '( doc.Form.Fields["r1-1"] as PDFRadioButtonListField ).SelectedIndex = 1

            ' select the first item in the drop down list
            '( doc.Form.Fields["ddl1-1"] as PDFDropDownListField ).SelectedIndex = 0

            ' select the 4th item in the list box
            '( doc.Form.Fields["lb1-1"] as PDFTextBoxField ).SelectedIndex = 3

            ' Save the document to disk
            doc.Save("Sample_Fw4fill.pdf")
        End Sub
    End Class
End Namespace


Samples: FormFillXFA

PDF4NET Send comments on this topic.
Samples: FormFillXFA
PDF4NET On-line Help > Samples > Forms > Samples: FormFillXFA

Glossary Item Box

This sample demonstrates how to fill a XFA form using PDF4NET.

C# Source code | VB.NET Source code | PDF file


FormFillXFA.cs

PDF4NET Send comments on this topic.
FormFillXFA.cs
PDF4NET On-line Help > Samples > Forms > FormFillXFA > FormFillXFA.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Forms;
using O2S.Components.PDF4NET.Forms.XFA;

namespace O2S.Samples.PDF4NET
{
    /// <summary>
    /// This sample shows how to fill a XFA form using PDF4NET library.
    /// XFA forms are created with Adobe Designer 7.
    /// </summary>
    class FormFillXFA
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument doc = new PDFDocument( "..\\SupportFiles\\xfasampleform.pdf" );

            // Get the main subform.
            XFASubform mainSubform = doc.XFAForm.Subforms[0].Subforms[0];

            // Fill the product name.
            mainSubform.Fields["txtName"].Value = "PDF4NET";
            // Fill the product SKU.
            mainSubform.Fields["txtSKU"].Value = "PDF4NET01090";
            // Fill the product URL.
            mainSubform.Fields["txtURL"].Value = "http://www.o2sol.com/pdf4net/products.htm";
            // Select the product category.
            mainSubform.Fields["ddlCategory"].Value = "PDF";
            // Also add a new item to Category drop down list.
            XFAListItem listItem = new XFAListItem( "Compression", "CMP" );
            ( mainSubform.Fields["ddlCategory"] as XFAChoiceListField ).Items.Add( listItem );
            // Fill the product image.
            mainSubform.Fields["imgProduct"].Value = "..\\SupportFiles\\pdf4net.jpg";
            ( mainSubform.Fields["imgProduct"] as XFAImageEditField ).ContentType = "image/jpg";
            // Fill the product short description.
            mainSubform.Fields["txtShortDescription"].Value = "PDF4NET is a .NET library for adding " +
                "PDF capabilities to .NET applications. It supports both desktop and web applications.";
            // Fill the product features.
            mainSubform.Fields["txtFeature1"].Value = "Create PDF files from scratch.";
            mainSubform.Fields["txtFeature2"].Value = "Merge, split and encrypt PDF files.";
            mainSubform.Fields["txtFeature3"].Value = "Create, fill and flatten PDF e-forms.";
            mainSubform.Fields["txtFeature4"].Value = "Fill XFA forms.";
            mainSubform.Fields["txtFeature5"].Value = "Add, edit and remove document attachments.";
            mainSubform.Fields["txtFeature6"].Value = "Add, edit and remove text annotations.";
            mainSubform.Fields["txtFeature7"].Value = "Support for WinForms and ASP.NET applications.";
            // Fill the product long description.
            mainSubform.Fields["txtLongDescription"].Value = "PDF4NET is a .NET library for adding " +
                "PDF capabilities to .NET applications. Version 2.7 brings support for PDF e-form " +
                "creation, support for reading and filling static XFA forms and document attachments. " +
                "It supports both desktop and web applications.";

            // Save the document to disk
            doc.Save( "Sample_XfaSampleForm_Fill.pdf" );
        }
    }
}


FormFillXFA.vb

PDF4NET Send comments on this topic.
FormFillXFA.vb
PDF4NET On-line Help > Samples > Forms > FormFillXFA > FormFillXFA.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Forms
Imports O2S.Components.PDF4NET.Forms.XFA

Namespace O2S.Samples.PDF4NET
    ''' <summary>
    ''' This sample shows how to fill a XFA form using PDF4NET library.
    ''' XFA forms are created with Adobe Designer 7.
    ''' </summary>
    Class FormFillXFA
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim doc As New PDFDocument("..\SupportFiles\xfasampleform.pdf")

            ' Get the main subform.
            Dim mainSubform As XFASubform = doc.XFAForm.Subforms(0).Subforms(0)

            ' Fill the product name.
            mainSubform.Fields("txtName").Value = "PDF4NET"
            ' Fill the product SKU.
            mainSubform.Fields("txtSKU").Value = "PDF4NET01090"
            ' Fill the product URL.
            mainSubform.Fields("txtURL").Value = "http://www.o2sol.com/pdf4net/products.htm"
            ' Select the product category.
            mainSubform.Fields("ddlCategory").Value = "PDF"
            ' Also add a new item to Category drop down list.
            Dim listItem As New XFAListItem("Compression", "CMP")
            CType(mainSubform.Fields("ddlCategory"), XFAChoiceListField).Items.Add(listItem)
            ' Fill the product image.
            mainSubform.Fields("imgProduct").Value = "..\SupportFiles\pdf4net.jpg"
            CType(mainSubform.Fields("imgProduct"), XFAImageEditField).ContentType = "image/jpg"
            ' Fill the product short description.
            mainSubform.Fields("txtShortDescription").Value = "PDF4NET is a .NET library for adding " + "PDF capabilities to .NET applications. It supports both desktop and web applications."
            ' Fill the product features.
            mainSubform.Fields("txtFeature1").Value = "Create PDF files from scratch."
            mainSubform.Fields("txtFeature2").Value = "Merge, split and encrypt PDF files."
            mainSubform.Fields("txtFeature3").Value = "Create, fill and flatten PDF e-forms."
            mainSubform.Fields("txtFeature4").Value = "Fill XFA forms."
            mainSubform.Fields("txtFeature5").Value = "Add, edit and remove document attachments."
            mainSubform.Fields("txtFeature6").Value = "Add, edit and remove text annotations."
            mainSubform.Fields("txtFeature7").Value = "Support for WinForms and ASP.NET applications."
            ' Fill the product long description.
            mainSubform.Fields("txtLongDescription").Value = "PDF4NET is a .NET library for adding " + "PDF capabilities to .NET applications. Version 2.7 brings support for PDF e-form " + "creation, support for reading and filling static XFA forms and document attachments. " + "It supports both desktop and web applications."

            ' Save the document to disk
            doc.Save("Sample_XfaSampleForm_Fill.pdf")
        End Sub
    End Class
End Namespace


Samples: Form XObjects

PDF4NET Send comments on this topic.
Samples: Form XObjects
PDF4NET On-line Help > Samples > Samples: Form XObjects

Glossary Item Box

This sample demonstrates the support for PDF form XObjects implemented in PDF4NET library. Form XObjects are graphic blocks that can be drawn multiple times in a PDF document and their content is stored only once in the PDF file.

C# Source code | VB.NET Source code | PDF file


FormXObject.cs

PDF4NET Send comments on this topic.
FormXObject.cs
PDF4NET On-line Help > Samples > Form XObjects > FormXObject.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Actions;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.FormXObject
{
    /// <summary>
    /// This sample shows how to use form XObjects with PDF4NET.
    /// </summary>
    class FormXObject
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument doc = new PDFDocument();

            // Create one page
            PDFPage page = doc.AddPage();

            PDFPen redPen = new PDFPen(new PDFRgbColor(255, 0, 0), 1);
            PDFBrush darkBlueBrush = new PDFBrush(new PDFRgbColor(0, 0, 128));

            // create a form XObject for stretched text
            PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16);
            string pdf4net = "PDF4NET";
            // the size of form xobject matches the text
            PDFFormXObject form = new PDFFormXObject();
            form.Width = font.MeasureString(pdf4net);
            form.Height = 16;
            // draw the text on the form xobject
            form.Canvas.DrawText(pdf4net, font, null, darkBlueBrush, 0, 0);

            // draw the form xobject on the page.
            // strectch it to cover the whole page header and on the left margin
            page.Canvas.DrawFormXObject(form, 0, 0, page.Width, 24);
            page.Canvas.DrawFormXObject(form, 32, 0, page.Height, 32, -90);

            // create another for xobject that is more complex
            PDFFormXObject form2 = new PDFFormXObject();
            form2.Width = 100;
            form2.Height = 100;
            // create the form content
            // draw an image
            form2.Canvas.DrawImage("..\\SupportFiles\\target.gif", 0, 0, 50, 50);
            // draw a round rectangle filled with a hatched brush
            PDFHatchBrush hb = new PDFHatchBrush(PDFHatchType.DiagonalCross);
            hb.HatchForeColor = new PDFRgbColor(Color.CornflowerBlue);
            form2.Canvas.DrawRoundRectangle(redPen, hb, 50, 0, 50, 50, 20, 20);
            // draw a square with vertical gradient filling
            PDFVerticalGradientBrush vgb = new PDFVerticalGradientBrush();
            vgb.StartColor = new PDFRgbColor(Color.Crimson);
            vgb.EndColor = new PDFRgbColor(Color.GreenYellow);
            form2.Canvas.DrawRectangle(redPen, vgb, 0, 50, 50, 50);
            // draw a square with horizontal gradient filling
            PDFHorizontalGradientBrush hgb = new PDFHorizontalGradientBrush();
            hgb.StartColor = new PDFRgbColor(Color.CornflowerBlue);
            hgb.EndColor = new PDFRgbColor(Color.Chartreuse);
            form2.Canvas.DrawRectangle(redPen, hgb, 50, 50, 50, 50);
            // draw text
            PDFFont font2 = new PDFFont(PDFFontFace.Helvetica, 20);
            font2.Bold = true;
            form2.Canvas.DrawText(pdf4net, font2, null, darkBlueBrush, 50, 50, 0, PDFTextAlign.MiddleCenter);

            // draw the form xobject on the page.
            // no stretch
            page.Canvas.DrawFormXObject(form2, 100, 50, form2.Width, form2.Height);
            // stretch 200%
            page.Canvas.DrawFormXObject(form2, 100, 50 + form2.Height, 2 * form2.Width, 2 * form2.Height);
            // stretch 400%
            page.Canvas.DrawFormXObject(form2, 100, 50 + form2.Height + 2 * form2.Height, 4 * form2.Width, 4 * form2.Height);

            // Save the document to disk
            doc.Save("Sample_FormXObject.pdf");
        }
    }
}


FormXObject.vb

PDF4NET Send comments on this topic.
FormXObject.vb
PDF4NET On-line Help > Samples > Form XObjects > FormXObject.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Actions
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.FormXObject
    ''' <summary>
    ''' This sample shows how to use form XObjects with PDF4NET.
    ''' </summary>
    Class FormXObject
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim doc As New PDFDocument()

            ' Create one page
            Dim page As PDFPage = doc.AddPage()

            Dim redPen As New PDFPen(New PDFRgbColor(255, 0, 0), 1)
            Dim darkBlueBrush As New PDFBrush(New PDFRgbColor(0, 0, 128))

            ' create a form XObject for stretched text
            Dim font As New PDFFont(PDFFontFace.Helvetica, 16)
            Dim pdf4net As String = "PDF4NET"
            ' the size of form xobject matches the text
            Dim form As New PDFFormXObject()
            form.Width = font.MeasureString(pdf4net)
            form.Height = 16
            ' draw the text on the form xobject
            form.Canvas.DrawText(pdf4net, font, Nothing, darkBlueBrush, 0, 0)

            ' draw the form xobject on the page.
            ' strectch it to cover the whole page header and on the left margin
            page.Canvas.DrawFormXObject(form, 0, 0, page.Width, 24)
            page.Canvas.DrawFormXObject(form, 32, 0, page.Height, 32, -90)

            ' create another for xobject that is more complex
            Dim form2 As New PDFFormXObject()
            form2.Width = 100
            form2.Height = 100
            ' create the form content
            ' draw an image
            form2.Canvas.DrawImage("..\SupportFiles\target.gif", 0, 0, 50, 50)
            ' draw a round rectangle filled with a hatched brush
            Dim hb As New PDFHatchBrush(PDFHatchType.DiagonalCross)
            hb.HatchForeColor = New PDFRgbColor(Color.CornflowerBlue)
            form2.Canvas.DrawRoundRectangle(redPen, hb, 50, 0, 50, 50, 20, 20)
            ' draw a square with vertical gradient filling
            Dim vgb As New PDFVerticalGradientBrush()
            vgb.StartColor = New PDFRgbColor(Color.Crimson)
            vgb.EndColor = New PDFRgbColor(Color.GreenYellow)
            form2.Canvas.DrawRectangle(redPen, vgb, 0, 50, 50, 50)
            ' draw a square with horizontal gradient filling
            Dim hgb As New PDFHorizontalGradientBrush()
            hgb.StartColor = New PDFRgbColor(Color.CornflowerBlue)
            hgb.EndColor = New PDFRgbColor(Color.Chartreuse)
            form2.Canvas.DrawRectangle(redPen, hgb, 50, 50, 50, 50)
            ' draw text
            Dim font2 As New PDFFont(PDFFontFace.Helvetica, 20)
            font2.Bold = True
            form2.Canvas.DrawText(pdf4net, font2, Nothing, darkBlueBrush, 50, 50, _
                0, PDFTextAlign.MiddleCenter)

            ' draw the form xobject on the page.
            ' no stretch
            page.Canvas.DrawFormXObject(form2, 100, 50, form2.Width, form2.Height)
            ' stretch 200%
            page.Canvas.DrawFormXObject(form2, 100, 50 + form2.Height, 2 * form2.Width, 2 * form2.Height)
            ' stretch 400%
            page.Canvas.DrawFormXObject(form2, 100, 50 + form2.Height + 2 * form2.Height, 4 * form2.Width, 4 * form2.Height)

            ' Save the document to disk
            doc.Save("Sample_FormXObject.pdf")
        End Sub
    End Class
End Namespace


Samples: GroupingGrid

PDF4NET Send comments on this topic.
Samples: GroupingGrid
PDF4NET On-line Help > Samples > Samples: GroupingGrid

Glossary Item Box

This sample shows how to draw a complex report with grouping capabilites. It loads the data from an XML file, then draws the lines of the report. The lines of the report are grouped by client id. Each time a new group starts, a group header is drawn, and each time a group ends a group footer is drawn. This sample uses customerorders.xml file found in \bin folder.

C# Source code | VB.NET Source code | PDF file


GroupingGrid.cs

PDF4NET Send comments on this topic.
GroupingGrid.cs
PDF4NET On-line Help > Samples > GroupingGrid > GroupingGrid.cs

Glossary Item Box

using System;
using System.Drawing;
using System.Data;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.GroupingGrid
{
    /// <summary>
    /// This sample will show how to draw a complex report
    /// with groping using content from a database/xml file.
    /// </summary>
    class GroupingGrid
    {
        private static float leftMargin = 15;
        private static float rightMargin = 15;
        private static float topMargin = 20;
        private static float minBottomMargin = 20;
        private static float rowHeight = 20;
        private static float groupHeaderHeight = 20;
        private static float groupFooterHeight = 20;
        private static float headerHeight = 30;
        private static float firstPageTopOffset = 50;
        private static float[] columnsWidth = { 50, 80, 80, 170, 222, 100, 60 };
        private static string[] columnsHeader = { "Order ID", "Order date", "Shipped date", "Ship to",
                                                    "Address", "City", "Country" };

        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the graphic objects
            PDFFont fontTitle = new PDFFont(PDFFontFace.Helvetica, 20);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());

            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();
            // Set the document to be Landscape oriented
            pdfDoc.PageOrientation = PDFPageOrientation.Landscape;

            // Create first page of the report
            PDFPage page = pdfDoc.AddPage();

            // Draw the title of the report
            page.Canvas.DrawText("Orders for customers", fontTitle, null, blackBrush,
                page.Width / 2, 15, 0, PDFTextAlign.TopCenter);

            // Draw report header
            DrawReportHeader(page, firstPageTopOffset);

            // Create the dataset
            DataSet ds = new DataSet();

            // Load the dataset
            ds.ReadXml("..\\SupportFiles\\customerorders.xml", XmlReadMode.ReadSchema);

            // Get the table from the dataset
            DataTable co = ds.Tables[0];

            // rowOffset - specifies the vertical position where a row
            // should begin to be printed
            float rowOffset = firstPageTopOffset + headerHeight;
            // initial customer code
            string customerID = "";
            int ordersCount = 0;

            // draw the rows in the dataset
            for (int i = 0; i < co.Rows.Count; i++)
            {
                // new customer, we need to draw the group header
                if (customerID != co.Rows[i][0].ToString())
                {
                    if (customerID != "")
                    { // draw the footer for the previous group
                        if (rowOffset + groupFooterHeight > page.Height - minBottomMargin)
                        { // not enough space to draw the footer
                            // create a new page
                            page = pdfDoc.AddPage();

                            // draw the report header
                            DrawReportHeader(page, topMargin);

                            // adjust the position for next prints
                            rowOffset = topMargin + headerHeight;
                        }
                        // draw the group header
                        DrawGroupFooter(page, rowOffset, customerID, ordersCount);

                        // Adjust the position of the next row
                        rowOffset = rowOffset + groupFooterHeight;
                    }

                    // do we has enough space to draw the group header and at least one row?
                    if (rowOffset + groupHeaderHeight + rowHeight > page.Height - minBottomMargin)
                    { // not enough
                        // create a new page
                        page = pdfDoc.AddPage();

                        // draw the report header
                        DrawReportHeader(page, topMargin);

                        // adjust the position of next rows
                        rowOffset = topMargin + headerHeight;
                    }

                    // draw the group header
                    DrawGroupHeader(page, rowOffset, co.Rows[i]);

                    // Adjust the position of the next row
                    rowOffset = rowOffset + groupHeaderHeight;
                    customerID = co.Rows[i][0].ToString();
                    // reset customer's orders count
                    ordersCount = 0;
                }

                if (rowOffset + rowHeight > page.Height - minBottomMargin)
                { // not enough space to draw a new row, then create a new page,
                    // draw the header, then draw the rows.
                    page = pdfDoc.AddPage();
                    DrawReportHeader(page, topMargin);
                    rowOffset = topMargin + headerHeight;
                }
                DrawReportRow(page, rowOffset, co.Rows[i]);
                rowOffset = rowOffset + rowHeight;
                ordersCount++;
            }

            // Save the document to disk
            pdfDoc.Save("Sample_GroupingGrid.pdf");
        }

        private static void DrawReportHeader(PDFPage pdfPage, float topOffset)
        {
            // Create the graphic objects
            PDFFont fontHeader = new PDFFont(PDFFontFace.Helvetica, 12);
            fontHeader.Bold = true;
            PDFPen borderColor = new PDFPen(new PDFRgbColor(), 1);
            PDFBrush textColor = new PDFBrush(new PDFRgbColor());
            PDFBrush headerFill = new PDFBrush(new PDFRgbColor(192, 192, 192));

            // Draw the header
            pdfPage.Canvas.DrawRectangle(borderColor, headerFill, leftMargin, topOffset,
                pdfPage.Width - leftMargin - rightMargin, headerHeight);

            int i;
            float xOffset = leftMargin;
            // Draw the columns separators
            for (i = 0; i < columnsWidth.Length - 1; i++)
            {
                xOffset = xOffset + columnsWidth[i];
                pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset,
                    xOffset, topOffset + headerHeight);
            }

            xOffset = leftMargin;
            // Draw the columns header
            for (i = 0; i < columnsWidth.Length; i++)
            {
                pdfPage.Canvas.DrawText(columnsHeader[i], fontHeader, null, textColor,
                    xOffset + columnsWidth[i] / 2, topOffset + headerHeight / 2, 0, PDFTextAlign.MiddleCenter);
                xOffset = xOffset + columnsWidth[i];
            }
        }

        private static void DrawReportRow(PDFPage pdfPage, float topOffset, DataRow row)
        {
            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 10);
            PDFPen borderColor = new PDFPen(new PDFRgbColor(), 1);
            PDFBrush textColor = new PDFBrush(new PDFRgbColor());
            PDFBrush headerFill = new PDFBrush(new PDFRgbColor(192, 192, 192));

            // Draw rows borders
            PointF[] points = { new PointF( leftMargin, topOffset ),
                                  new PointF( leftMargin, topOffset + rowHeight),
                                  new PointF( (float)pdfPage.Width - rightMargin, topOffset + rowHeight ),
                                  new PointF( (float)pdfPage.Width - rightMargin, topOffset )};
            pdfPage.Canvas.DrawLines(borderColor, points);

            int i;
            float xOffset = leftMargin;
            // Draw the columns separators
            for (i = 0; i < columnsWidth.Length - 1; i++)
            {
                xOffset = xOffset + columnsWidth[i];
                pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset,
                    xOffset, topOffset + rowHeight);
            }

            xOffset = leftMargin;
            // Draw the columns values
            // Order id
            pdfPage.Canvas.DrawText(row[2].ToString(), fontText, null, textColor,
                xOffset + 2, topOffset + rowHeight / 2, 0, PDFTextAlign.MiddleLeft);
            xOffset = xOffset + columnsWidth[0];
            // Order date
            DateTime date;
            if (row[3] != System.DBNull.Value)
            {
                date = (DateTime)row[3];
                pdfPage.Canvas.DrawText(date.ToString("MM/dd/yyyy"), fontText, null, textColor,
                    xOffset + columnsWidth[1] / 2, topOffset + rowHeight / 2, 0, PDFTextAlign.MiddleCenter);
            }
            xOffset = xOffset + columnsWidth[1];
            // Shipped date
            if (row[4] != System.DBNull.Value)
            {
                date = (DateTime)row[4];
                pdfPage.Canvas.DrawText(date.ToString("MM/dd/yyyy"), fontText, null, textColor,
                    xOffset + columnsWidth[2] / 2, topOffset + rowHeight / 2, 0, PDFTextAlign.MiddleCenter);
            }
            xOffset = xOffset + columnsWidth[2];
            // Ship to
            pdfPage.Canvas.DrawText(row[5].ToString(), fontText, null, textColor,
                xOffset + 2, topOffset + rowHeight / 2, 0, PDFTextAlign.MiddleLeft);
            xOffset = xOffset + columnsWidth[3];
            // Address
            pdfPage.Canvas.DrawText(row[6].ToString(), fontText, null, textColor,
                xOffset + 2, topOffset + rowHeight / 2, 0, PDFTextAlign.MiddleLeft);
            xOffset = xOffset + columnsWidth[4];
            // City
            pdfPage.Canvas.DrawText(row[7].ToString(), fontText, null, textColor,
                xOffset + 2, topOffset + rowHeight / 2, 0, PDFTextAlign.MiddleLeft);
            xOffset = xOffset + columnsWidth[5];
            // Country
            pdfPage.Canvas.DrawText(row[8].ToString(), fontText, null, textColor,
                xOffset + 2, topOffset + rowHeight / 2, 0, PDFTextAlign.MiddleLeft);
            xOffset = xOffset + columnsWidth[6];
        }

        private static void DrawGroupHeader(PDFPage pdfPage, float topOffset, DataRow row)
        {
            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFPen borderColor = new PDFPen(new PDFRgbColor(), 1);
            PDFBrush textColor = new PDFBrush(new PDFRgbColor());
            PDFBrush groupFill = new PDFBrush(new PDFRgbColor(192, 192, 192));

            // Draw group header
            pdfPage.Canvas.DrawRectangle(borderColor, groupFill, leftMargin, topOffset,
                pdfPage.Width - leftMargin - rightMargin, groupHeaderHeight);

            // Draw the content of the header
            pdfPage.Canvas.DrawText("Customer ID: " + row[0].ToString() +
                " / Company name: " + row[1].ToString(), fontText, null, textColor,
                leftMargin + 2, topOffset + groupHeaderHeight / 2, 0, PDFTextAlign.MiddleLeft);
        }

        private static void DrawGroupFooter(PDFPage pdfPage, float topOffset,
            string customerID, int totalOrders)
        {
            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFPen borderColor = new PDFPen(new PDFRgbColor(), 1);
            PDFBrush textColor = new PDFBrush(new PDFRgbColor());
            PDFBrush groupFill = new PDFBrush(new PDFRgbColor(192, 192, 192));

            // Draw group header
            pdfPage.Canvas.DrawRectangle(borderColor, groupFill, leftMargin, topOffset,
                pdfPage.Width - leftMargin - rightMargin, groupFooterHeight);

            // Draw the content of the header
            pdfPage.Canvas.DrawText("Total number of orders for customer " + customerID +
                " is " + totalOrders.ToString(), fontText, null, textColor,
                leftMargin + 2, topOffset + groupFooterHeight / 2, 0, PDFTextAlign.MiddleLeft);
        }
    }
}


GroupingGrid.vb

PDF4NET Send comments on this topic.
GroupingGrid.vb
PDF4NET On-line Help > Samples > GroupingGrid > GroupingGrid.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports System.Data
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.GroupingGrid
    ''' <summary>
    ''' This sample will show how to draw a complex report
    ''' with groping using content from a database/xml file.
    ''' </summary>
    Class GroupingGrid
        Private Shared leftMargin As Single = 15
        Private Shared rightMargin As Single = 15
        Private Shared topMargin As Single = 20
        Private Shared minBottomMargin As Single = 20
        Private Shared rowHeight As Single = 20
        Private Shared groupHeaderHeight As Single = 20
        Private Shared groupFooterHeight As Single = 20
        Private Shared headerHeight As Single = 30
        Private Shared firstPageTopOffset As Single = 50
        Private Shared columnsWidth As Single() = {50, 80, 80, 170, 222, 100, _
            60}
        Private Shared columnsHeader As String() = {"Order ID", "Order date", "Shipped date", "Ship to", "Address", "City", _
            "Country"}

        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the graphic objects
            Dim fontTitle As New PDFFont(PDFFontFace.Helvetica, 20)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())

            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()
            ' Set the document to be Landscape oriented
            pdfDoc.PageOrientation = PDFPageOrientation.Landscape

            ' Create first page of the report
            Dim page As PDFPage = pdfDoc.AddPage()

            ' Draw the title of the report
            page.Canvas.DrawText("Orders for customers", fontTitle, Nothing, blackBrush, page.Width / 2, 15, _
                0, PDFTextAlign.TopCenter)

            ' Draw report header
            DrawReportHeader(page, firstPageTopOffset)

            ' Create the dataset
            Dim ds As New DataSet()

            ' Load the dataset
            ds.ReadXml("..\SupportFiles\customerorders.xml", XmlReadMode.ReadSchema)

            ' Get the table from the dataset
            Dim co As DataTable = ds.Tables(0)

            ' rowOffset - specifies the vertical position where a row
            ' should begin to be printed
            Dim rowOffset As Single = firstPageTopOffset + headerHeight
            ' initial customer code
            Dim customerID As String = ""
            Dim ordersCount As Integer = 0

            ' draw the rows in the dataset
            Dim i As Integer = 0
            While i < co.Rows.Count
                ' new customer, we need to draw the group header
                If customerID <> co.Rows(i)(0).ToString() Then
                    If customerID <> "" Then
                        ' draw the footer for the previous group
                        If rowOffset + groupFooterHeight > page.Height - minBottomMargin Then
                            ' not enough space to draw the footer
                            ' create a new page
                            page = pdfDoc.AddPage()

                            ' draw the report header
                            DrawReportHeader(page, topMargin)

                            ' adjust the position for next prints
                            rowOffset = topMargin + headerHeight
                        End If
                        ' draw the group header
                        DrawGroupFooter(page, rowOffset, customerID, ordersCount)

                        ' Adjust the position of the next row
                        rowOffset = rowOffset + groupFooterHeight
                    End If

                    ' do we has enough space to draw the group header and at least one row?
                    If rowOffset + groupHeaderHeight + rowHeight > page.Height - minBottomMargin Then
                        ' not enough
                        ' create a new page
                        page = pdfDoc.AddPage()

                        ' draw the report header
                        DrawReportHeader(page, topMargin)

                        ' adjust the position of next rows
                        rowOffset = topMargin + headerHeight
                    End If

                    ' draw the group header
                    DrawGroupHeader(page, rowOffset, co.Rows(i))

                    ' Adjust the position of the next row
                    rowOffset = rowOffset + groupHeaderHeight
                    customerID = co.Rows(i)(0).ToString()
                    ' reset customer's orders count
                    ordersCount = 0
                End If

                If rowOffset + rowHeight > page.Height - minBottomMargin Then
                    ' not enough space to draw a new row, then create a new page,
                    ' draw the header, then draw the rows.
                    page = pdfDoc.AddPage()
                    DrawReportHeader(page, topMargin)
                    rowOffset = topMargin + headerHeight
                End If
                DrawReportRow(page, rowOffset, co.Rows(i))
                rowOffset = rowOffset + rowHeight
                ordersCount = ordersCount + 1
                i = i + 1
            End While

            ' Save the document to disk
            pdfDoc.Save("Sample_GroupingGrid.pdf")
        End Sub

        Private Shared Sub DrawReportHeader(pdfPage As PDFPage, topOffset As Single)
            ' Create the graphic objects
            Dim fontHeader As New PDFFont(PDFFontFace.Helvetica, 12)
            fontHeader.Bold = True
            Dim borderColor As New PDFPen(New PDFRgbColor(), 1)
            Dim textColor As New PDFBrush(New PDFRgbColor())
            Dim headerFill As New PDFBrush(New PDFRgbColor(192, 192, 192))

            ' Draw the header
            pdfPage.Canvas.DrawRectangle(borderColor, headerFill, leftMargin, topOffset, pdfPage.Width - leftMargin - rightMargin, headerHeight)

            Dim i As Integer
            Dim xOffset As Single = leftMargin
            ' Draw the columns separators
            i = 0
            While i < columnsWidth.Length - 1
                xOffset = xOffset + columnsWidth(i)
                pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset, xOffset, topOffset + headerHeight)
                i = i + 1
            End While

            xOffset = leftMargin
            ' Draw the columns header
            i = 0
            While i < columnsWidth.Length
                pdfPage.Canvas.DrawText(columnsHeader(i), fontHeader, Nothing, textColor, xOffset + columnsWidth(i) / 2, topOffset + headerHeight / 2, _
                    0, PDFTextAlign.MiddleCenter)
                xOffset = xOffset + columnsWidth(i)
                i = i + 1
            End While
        End Sub

        Private Shared Sub DrawReportRow(pdfPage As PDFPage, topOffset As Single, row As DataRow)
            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 10)
            Dim borderColor As New PDFPen(New PDFRgbColor(), 1)
            Dim textColor As New PDFBrush(New PDFRgbColor())
            Dim headerFill As New PDFBrush(New PDFRgbColor(192, 192, 192))

            ' Draw rows borders
            Dim points As PointF() = {New PointF(leftMargin, topOffset), _
                                      New PointF(leftMargin, topOffset + rowHeight), _
                                      New PointF(pdfPage.Width - rightMargin, topOffset + rowHeight), _
                                      New PointF(pdfPage.Width - rightMargin, topOffset)}
            pdfPage.Canvas.DrawLines(borderColor, points)

            Dim i As Integer
            Dim xOffset As Single = leftMargin
            ' Draw the columns separators
            i = 0
            While i < columnsWidth.Length - 1
                xOffset = xOffset + columnsWidth(i)
                pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset, xOffset, topOffset + rowHeight)
                i = i + 1
            End While

            xOffset = leftMargin
            ' Draw the columns values
            ' Order id
            pdfPage.Canvas.DrawText(row(2).ToString(), fontText, Nothing, textColor, xOffset + 2, topOffset + rowHeight / 2, _
                0, PDFTextAlign.MiddleLeft)
            xOffset = xOffset + columnsWidth(0)
            ' Order date
            Dim [date] As DateTime
            If Not (row(3) Is System.DBNull.Value) Then
                [date] = DirectCast(row(3), DateTime)
                pdfPage.Canvas.DrawText([date].ToString("MM/dd/yyyy"), fontText, Nothing, textColor, xOffset + columnsWidth(1) / 2, topOffset + rowHeight / 2, _
                 0, PDFTextAlign.MiddleCenter)
            End If
            xOffset = xOffset + columnsWidth(1)
            ' Shipped date
            If Not (row(4) Is System.DBNull.Value) Then
                [date] = DirectCast(row(4), DateTime)
                pdfPage.Canvas.DrawText([date].ToString("MM/dd/yyyy"), fontText, Nothing, textColor, xOffset + columnsWidth(2) / 2, topOffset + rowHeight / 2, _
                 0, PDFTextAlign.MiddleCenter)
            End If
            xOffset = xOffset + columnsWidth(2)
            ' Ship to
            pdfPage.Canvas.DrawText(row(5).ToString(), fontText, Nothing, textColor, xOffset + 2, topOffset + rowHeight / 2, _
                0, PDFTextAlign.MiddleLeft)
            xOffset = xOffset + columnsWidth(3)
            ' Address
            pdfPage.Canvas.DrawText(row(6).ToString(), fontText, Nothing, textColor, xOffset + 2, topOffset + rowHeight / 2, _
                0, PDFTextAlign.MiddleLeft)
            xOffset = xOffset + columnsWidth(4)
            ' City
            pdfPage.Canvas.DrawText(row(7).ToString(), fontText, Nothing, textColor, xOffset + 2, topOffset + rowHeight / 2, _
                0, PDFTextAlign.MiddleLeft)
            xOffset = xOffset + columnsWidth(5)
            ' Country
            pdfPage.Canvas.DrawText(row(8).ToString(), fontText, Nothing, textColor, xOffset + 2, topOffset + rowHeight / 2, _
                0, PDFTextAlign.MiddleLeft)
            xOffset = xOffset + columnsWidth(6)
        End Sub

        Private Shared Sub DrawGroupHeader(pdfPage As PDFPage, topOffset As Single, row As DataRow)
            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim borderColor As New PDFPen(New PDFRgbColor(), 1)
            Dim textColor As New PDFBrush(New PDFRgbColor())
            Dim groupFill As New PDFBrush(New PDFRgbColor(192, 192, 192))

            ' Draw group header
            pdfPage.Canvas.DrawRectangle(borderColor, groupFill, leftMargin, topOffset, pdfPage.Width - leftMargin - rightMargin, groupHeaderHeight)

            ' Draw the content of the header
            pdfPage.Canvas.DrawText("Customer ID: " + row(0).ToString() + " / Company name: " + row(1).ToString(), fontText, Nothing, textColor, leftMargin + 2, topOffset + groupHeaderHeight / 2, _
                0, PDFTextAlign.MiddleLeft)
        End Sub

        Private Shared Sub DrawGroupFooter(pdfPage As PDFPage, topOffset As Single, customerID As String, totalOrders As Integer)
            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim borderColor As New PDFPen(New PDFRgbColor(), 1)
            Dim textColor As New PDFBrush(New PDFRgbColor())
            Dim groupFill As New PDFBrush(New PDFRgbColor(192, 192, 192))

            ' Draw group header
            pdfPage.Canvas.DrawRectangle(borderColor, groupFill, leftMargin, topOffset, pdfPage.Width - leftMargin - rightMargin, groupFooterHeight)

            ' Draw the content of the header
            pdfPage.Canvas.DrawText("Total number of orders for customer " + customerID + " is " + totalOrders.ToString(), _
                                    fontText, Nothing, textColor, leftMargin + 2, topOffset + groupFooterHeight / 2, _
                                    0, PDFTextAlign.MiddleLeft)
        End Sub
    End Class
End Namespace


Samples: HelloWorld

PDF4NET Send comments on this topic.
Samples: HelloWorld
PDF4NET On-line Help > Samples > Samples: HelloWorld

Glossary Item Box

This sample is the simplest pdf file. It draws the string "Hello PDF World" in the center of the page. The text has a red border and it is filled with blue.

C# Source code | VB.NET Source code | PDF file


HelloWorld.cs

PDF4NET Send comments on this topic.
HelloWorld.cs
PDF4NET On-line Help > Samples > HelloWorld > HelloWorld.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET
{
    /// <summary>
    /// The classic Hello world sample.
    /// </summary>
    class HelloPDFWorld
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            // Create one page
            PDFPage pdfPage = pdfDoc.AddPage();

            // Draw "Hello world" in the center of the page
            pdfPage.Canvas.DrawText("Hello PDF world!",
                new PDFFont(PDFFontFace.Helvetica, 100), new PDFPen(new PDFRgbColor(255, 0, 0), 1),
                new PDFBrush(new PDFRgbColor(0, 0, 255)), pdfPage.Width / 2, pdfPage.Height / 2,
                -60, PDFTextAlign.MiddleCenter);

            // Save the document to disk
            pdfDoc.Save("Sample_HelloPDFWorld.pdf");
        }
    }
}


HelloWorld.vb

PDF4NET Send comments on this topic.
HelloWorld.vb
PDF4NET On-line Help > Samples > HelloWorld > HelloWorld.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET
    ''' <summary>
    ''' The classic Hello world sample.
    ''' </summary>
    Class HelloPDFWorld
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            ' Create one page
            Dim pdfPage As PDFPage = pdfDoc.AddPage()

            ' Draw "Hello world" in the center of the page
            pdfPage.Canvas.DrawText("Hello PDF world!", _
                                    New PDFFont(PDFFontFace.Helvetica, 100), _
                                    New PDFPen(New PDFRgbColor(255, 0, 0), 1), _
                                    New PDFBrush(New PDFRgbColor(0, 0, 255)), _
                                    pdfPage.Width / 2, pdfPage.Height / 2, _
                                    -60, PDFTextAlign.MiddleCenter)

            ' Save the document to disk
            pdfDoc.Save("Sample_HelloPDFWorld.pdf")
        End Sub
    End Class
End Namespace


Samples: Images

PDF4NET Send comments on this topic.
Samples: Images
PDF4NET On-line Help > Samples > Samples: Images

Glossary Item Box

This sample shows how to draw images on a page. It draws a normal image, then it draws another image that is rotated with 30 degrees around the top left corner.
The sample also demonstrates the image transparency capabilities in PDF4NET library. Color keys masking, image masks and alpha channel transparency are shown. This sample uses pdf4net.jpg, pdf4net.png and o2solutions.jpg images found in \bin folder.

C# Source code | VB.NET Source code | PDF file


Images.cs

PDF4NET Send comments on this topic.
Images.cs
PDF4NET On-line Help > Samples > Images > Images.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Shapes.Transparency;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.Images
{
    /// <summary>
    /// This sample will show how to draw jpeg images on a page.
    /// </summary>
    class Images
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());

            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            // Create first page
            PDFPage page = pdfDoc.AddPage();

            // Draw a label
            page.Canvas.DrawText("Normal image", fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft);

            // Draw the image
            page.Canvas.DrawImage("..\\SupportFiles\\pdf4net.jpg", 20, 35, 467, 200, 0, PDFKeepAspectRatio.KeepWidth);

            // Draw the image
            page.Canvas.DrawImage("..\\SupportFiles\\pdf4net.jpg", 20, 250, 467, 200, 0, PDFKeepAspectRatio.KeepWidth);

            // Draw a label
            page.Canvas.DrawText("30 degrees rotated image",
                fontText, null, blackBrush, 20, 300, 0, PDFTextAlign.TopLeft);

            // Draw the image
            page.Canvas.DrawImage("..\\SupportFiles\\o2solutions.jpg", 20, 435, 444, 126.85F, 30, PDFKeepAspectRatio.KeepWidth);

            // Create second page
            page = pdfDoc.AddPage();

            // Draw a label
            page.Canvas.DrawText("Image with a transparent color",
                fontText, null, blackBrush, 20, 30, 0, PDFTextAlign.TopLeft);

            // create an image object
            PDFImage img = new PDFImage("..\\SupportFiles\\pdf4net.jpg");

            // set the transparent color
            // even opaque images can be made transparent
            // the color image mask allows to set a range of colors as tranparent, not only one color
            img.Mask = new PDFColorImageMask(new PDFRgbColor(220, 220, 220), new PDFRgbColor(220, 220, 220));

            // Draw the image
            page.Canvas.DrawImage(img, 20, 40, 467, 200, 0, PDFKeepAspectRatio.KeepBoth);

            // Draw a label
            page.Canvas.DrawText("Image with a mask, black color is transparent, white is opaque",
                fontText, null, blackBrush, 20, 250, 0, PDFTextAlign.TopLeft);

            // create another image object
            img = new PDFImage("..\\SupportFiles\\pdf4net.jpg");

            // set an image mask for this image
            img.Mask = new PDFImageMask("..\\SupportFiles\\mask.bmp");

            // Draw the image
            page.Canvas.DrawImage(img, 20, 260, 467, 200, 0, PDFKeepAspectRatio.KeepBoth);

            // Create third page
            page = pdfDoc.AddPage();

            // Draw a label
            page.Canvas.DrawText("Image with alpha channel transparency (take a look at the rounded corners)",
                fontText, null, blackBrush, 20, 30, 0, PDFTextAlign.TopLeft);

            PDFBrush greenBrush = new PDFBrush(new PDFRgbColor(Color.GreenYellow));
            // Draw a green rectangle under the image to emphasize the alpha channel transparency
            page.Canvas.DrawRectangle(greenBrush, 45, 45, 510, 325);

            // create an image object
            PDFImage cc = new PDFImage("..\\SupportFiles\\pdf4net.png");

            // Draw the image on green background
            page.Canvas.DrawImage(cc, 50, 50, 500, 200);

            PDFBrush redBrush = new PDFBrush(new PDFRgbColor(Color.RosyBrown));
            // Draw a rosy rectangle under the image to emphasize the alpha channel transparency
            page.Canvas.DrawRectangle(redBrush, 45, 395, 510, 325);

            // Draw the image on rosy background
            page.Canvas.DrawImage(cc, 50, 400, 500, 200, 0, PDFKeepAspectRatio.KeepWidth);

            // Save the document to disk
            pdfDoc.Save("Sample_Images.pdf");
        }
    }
}


Images.vb

PDF4NET Send comments on this topic.
Images.vb
PDF4NET On-line Help > Samples > Images > Images.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Shapes.Transparency
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.Images
    ''' <summary>
    ''' This sample will show how to draw jpeg images on a page.
    ''' </summary>
    Class Images
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())

            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            ' Create first page
            Dim page As PDFPage = pdfDoc.AddPage()

            ' Draw a label
            page.Canvas.DrawText("Normal image", fontText, Nothing, blackBrush, 20, 20, _
                0, PDFTextAlign.TopLeft)

            ' Draw the image
            page.Canvas.DrawImage("..\SupportFiles\pdf4net.jpg", 20, 35, 467, 200, 0, _
             PDFKeepAspectRatio.KeepWidth)

            ' Draw the image
            page.Canvas.DrawImage("..\SupportFiles\pdf4net.jpg", 20, 250, 467, 200, 0, _
             PDFKeepAspectRatio.KeepWidth)

            ' Draw a label
            page.Canvas.DrawText("30 degrees rotated image", fontText, Nothing, blackBrush, 20, 300, _
                0, PDFTextAlign.TopLeft)

            ' Draw the image
            page.Canvas.DrawImage("..\SupportFiles\o2solutions.jpg", 20, 435, 444, 126.85F, 30, _
             PDFKeepAspectRatio.KeepWidth)

            ' Create second page
            page = pdfDoc.AddPage()

            ' Draw a label
            page.Canvas.DrawText("Image with a transparent color", fontText, Nothing, blackBrush, 20, 30, _
                0, PDFTextAlign.TopLeft)

            ' create an image object
            Dim img As New PDFImage("..\SupportFiles\pdf4net.jpg")

            ' set the transparent color
            ' even opaque images can be made transparent
            ' the color image mask allows to set a range of colors as tranparent, not only one color
            img.Mask = New PDFColorImageMask(New PDFRgbColor(220, 220, 220), New PDFRgbColor(220, 220, 220))

            ' Draw the image
            page.Canvas.DrawImage(img, 20, 40, 467, 200, 0, _
             PDFKeepAspectRatio.KeepBoth)

            ' Draw a label
            page.Canvas.DrawText("Image with a mask, black color is transparent, white is opaque", fontText, Nothing, blackBrush, 20, 250, _
                0, PDFTextAlign.TopLeft)

            ' create another image object
            img = New PDFImage("..\SupportFiles\pdf4net.jpg")

            ' set an image mask for this image
            img.Mask = New PDFImageMask("..\SupportFiles\mask.bmp")

            ' Draw the image
            page.Canvas.DrawImage(img, 20, 260, 467, 200, 0, _
             PDFKeepAspectRatio.KeepBoth)

            ' Create third page
            page = pdfDoc.AddPage()

            ' Draw a label
            page.Canvas.DrawText("Image with alpha channel transparency (take a look at the rounded corners)", fontText, Nothing, blackBrush, 20, 30, _
                0, PDFTextAlign.TopLeft)

            Dim greenBrush As New PDFBrush(New PDFRgbColor(Color.GreenYellow))
            ' Draw a green rectangle under the image to emphasize the alpha channel transparency
            page.Canvas.DrawRectangle(greenBrush, 45, 45, 510, 325)

            ' create an image object
            Dim cc As New PDFImage("..\SupportFiles\pdf4net.png")

            ' Draw the image on green background
            page.Canvas.DrawImage(cc, 50, 50, 500, 200)

            Dim redBrush As New PDFBrush(New PDFRgbColor(Color.RosyBrown))
            ' Draw a rosy rectangle under the image to emphasize the alpha channel transparency
            page.Canvas.DrawRectangle(redBrush, 45, 395, 510, 325)

            ' Draw the image on rosy background
            page.Canvas.DrawImage(cc, 50, 400, 500, 200, 0, _
             PDFKeepAspectRatio.KeepWidth)

            ' Save the document to disk
            pdfDoc.Save("Sample_Images.pdf")
        End Sub
    End Class
End Namespace


Samples: Layers

PDF4NET Send comments on this topic.
Samples: Layers
PDF4NET On-line Help > Samples > Samples: Layers

Glossary Item Box

This sample demonstrates the support for layers in a PDF file implemented in PDF4NET library. Unlimited levels of layers and sublayers can be created. The layers are stacked on top of each other in the order they were created.

C# Source code | VB.NET Source code | PDF file


Layers.cs

PDF4NET Send comments on this topic.
Layers.cs
PDF4NET On-line Help > Samples > Layers > Layers.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.Layers
{
    /// <summary>
    /// The sample shows how to use layers in a PDF file.
    /// The PDF4NET library supports unlimited levels of nested layers.
    /// Each layers can be hidden or shown independently. Hidding a parent layer
    /// will hide all its child layers. Layers' content is always drawn on top of page content
    /// and they are drawn on top of each other in the order they have been added to the Layers collection.
    /// Page main content can not be hidden, it is always visible.
    /// </summary>
    class Layers
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument doc = new PDFDocument();

            // Create one page
            PDFPage page = doc.AddPage();

            PDFPen redPen = new PDFPen(new PDFRgbColor(192, 0, 0), 1);
            PDFBrush blueBrush = new PDFBrush(new PDFRgbColor(0, 0, 255));
            PDFBrush darkBlueBrush = new PDFBrush(new PDFRgbColor(0, 0, 128));

            // Draw "Hello world" in the center of the page
            // this text is always visible.
            page.Canvas.DrawText("Hello world !",
                new PDFFont(PDFFontFace.Helvetica, 100), redPen, blueBrush, page.Width / 2, page.Height / 2,
                0, PDFTextAlign.MiddleCenter);

            // Create a parent layer
            PDFLayer squareLayer = page.Canvas.Layers.Add("Empty square");
            // Create a poly polygon and draw it on the layer
            PDFPoint[][] polygons = new PDFPoint[2][];
            polygons[0] = new PDFPoint[]{ new PDFPoint( 50, 100 ), new PDFPoint( 550, 100 ),
                                            new PDFPoint( 550, 600 ), new PDFPoint( 50, 600 ) };
            polygons[1] = new PDFPoint[]{ new PDFPoint( 100, 150 ), new PDFPoint( 500, 150 ),
                                            new PDFPoint( 500, 550 ), new PDFPoint( 100, 550 ) };
            squareLayer.Canvas.DrawPolyPolygon(redPen, darkBlueBrush, polygons, PDFFillMode.EvenOdd);

            // create 4 sublayers
            // 1. Hatched layer
            PDFLayer hatchedLayer = squareLayer.Canvas.Layers.Add("Hatched square");
            // Create a hatch brush
            PDFHatchBrush hb = new PDFHatchBrush(PDFHatchType.DiagonalCross);
            hb.HatchForeColor = new PDFRgbColor(Color.Aquamarine);
            hb.HatchBackColor = new PDFRgbColor(Color.Azure);
            hatchedLayer.Canvas.DrawRectangle(redPen, hb, 100, 150, 200, 200);

            // 2. Vertical gradient layer
            PDFLayer verticalGradientLayer = squareLayer.Canvas.Layers.Add("Vertical gradient square");
            // Create a vertical gradien brush
            PDFVerticalGradientBrush vgb = new PDFVerticalGradientBrush();
            vgb.StartColor = new PDFRgbColor(Color.Aquamarine);
            vgb.EndColor = new PDFRgbColor(Color.Purple);
            verticalGradientLayer.Canvas.DrawRectangle(redPen, vgb, 300, 150, 200, 200);

            // 3. Horizontal gradient layer
            PDFLayer horizontalGradientLayer = squareLayer.Canvas.Layers.Add("Horizontal gradient square");
            // Create a horizontal gradient brush
            PDFHorizontalGradientBrush hgb = new PDFHorizontalGradientBrush();
            hgb.StartColor = new PDFRgbColor(Color.YellowGreen);
            hgb.EndColor = new PDFRgbColor(Color.Violet);
            horizontalGradientLayer.Canvas.DrawRectangle(redPen, hgb, 100, 350, 200, 200);

            // 4. Solid layer
            PDFLayer solidLayer = squareLayer.Canvas.Layers.Add("Solid square");
            // Create a solid brush
            PDFBrush solidBrush = new PDFBrush(new PDFRgbColor(Color.CornflowerBlue));
            solidLayer.Canvas.DrawRectangle(redPen, solidBrush, 300, 350, 200, 200);

            // create another layer on top of existing ones
            PDFLayer xLayer = page.Canvas.Layers.Add("Green X");
            PDFPen greenPen = new PDFPen(new PDFRgbColor(Color.GreenYellow), 32);
            greenPen.LineCap = PDFLineCap.Round;
            xLayer.Canvas.DrawLine(greenPen, 50, 100, 550, 600);
            xLayer.Canvas.DrawLine(greenPen, 550, 100, 50, 600);

            // Save the document to disk
            doc.Save("Sample_Layers.pdf");
        }
    }
}


Layers.vb

PDF4NET Send comments on this topic.
Layers.vb
PDF4NET On-line Help > Samples > Layers > Layers.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.Layers
    ''' <summary>
    ''' The sample shows how to use layers in a PDF file.
    ''' The PDF4NET library supports unlimited levels of nested layers.
    ''' Each layers can be hidden or shown independently. Hidding a parent layer
    ''' will hide all its child layers. Layers' content is always drawn on top of page content
    ''' and they are drawn on top of each other in the order they have been added to the Layers collection.
    ''' Page main content can not be hidden, it is always visible.
    ''' </summary>
    Class Layers
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim doc As New PDFDocument()

            ' Create one page
            Dim page As PDFPage = doc.AddPage()

            Dim redPen As New PDFPen(New PDFRgbColor(192, 0, 0), 1)
            Dim blueBrush As New PDFBrush(New PDFRgbColor(0, 0, 255))
            Dim darkBlueBrush As New PDFBrush(New PDFRgbColor(0, 0, 128))

            ' Draw "Hello world" in the center of the page
            ' this text is always visible.
            page.Canvas.DrawText("Hello world !", New PDFFont(PDFFontFace.Helvetica, 100), redPen, blueBrush, page.Width / 2, page.Height / 2, _
                0, PDFTextAlign.MiddleCenter)

            ' Create a parent layer
            Dim squareLayer As PDFLayer = page.Canvas.Layers.Add("Empty square")
            ' Create a poly polygon and draw it on the layer
            Dim polygons As PDFPoint()() = New PDFPoint(1)() {}
            polygons(0) = New PDFPoint() {New PDFPoint(50, 100), New PDFPoint(550, 100), New PDFPoint(550, 600), New PDFPoint(50, 600)}
            polygons(1) = New PDFPoint() {New PDFPoint(100, 150), New PDFPoint(500, 150), New PDFPoint(500, 550), New PDFPoint(100, 550)}
            squareLayer.Canvas.DrawPolyPolygon(redPen, darkBlueBrush, polygons, PDFFillMode.EvenOdd)

            ' create 4 sublayers
            ' 1. Hatched layer
            Dim hatchedLayer As PDFLayer = squareLayer.Canvas.Layers.Add("Hatched square")
            ' Create a hatch brush
            Dim hb As New PDFHatchBrush(PDFHatchType.DiagonalCross)
            hb.HatchForeColor = New PDFRgbColor(Color.Aquamarine)
            hb.HatchBackColor = New PDFRgbColor(Color.Azure)
            hatchedLayer.Canvas.DrawRectangle(redPen, hb, 100, 150, 200, 200)

            ' 2. Vertical gradient layer
            Dim verticalGradientLayer As PDFLayer = squareLayer.Canvas.Layers.Add("Vertical gradient square")
            ' Create a vertical gradien brush
            Dim vgb As New PDFVerticalGradientBrush()
            vgb.StartColor = New PDFRgbColor(Color.Aquamarine)
            vgb.EndColor = New PDFRgbColor(Color.Purple)
            verticalGradientLayer.Canvas.DrawRectangle(redPen, vgb, 300, 150, 200, 200)

            ' 3. Horizontal gradient layer
            Dim horizontalGradientLayer As PDFLayer = squareLayer.Canvas.Layers.Add("Horizontal gradient square")
            ' Create a horizontal gradient brush
            Dim hgb As New PDFHorizontalGradientBrush()
            hgb.StartColor = New PDFRgbColor(Color.YellowGreen)
            hgb.EndColor = New PDFRgbColor(Color.Violet)
            horizontalGradientLayer.Canvas.DrawRectangle(redPen, hgb, 100, 350, 200, 200)

            ' 4. Solid layer
            Dim solidLayer As PDFLayer = squareLayer.Canvas.Layers.Add("Solid square")
            ' Create a solid brush
            Dim solidBrush As New PDFBrush(New PDFRgbColor(Color.CornflowerBlue))
            solidLayer.Canvas.DrawRectangle(redPen, solidBrush, 300, 350, 200, 200)

            ' create another layer on top of existing ones
            Dim xLayer As PDFLayer = page.Canvas.Layers.Add("Green X")
            Dim greenPen As New PDFPen(New PDFRgbColor(Color.GreenYellow), 32)
            greenPen.LineCap = PDFLineCap.Round
            xLayer.Canvas.DrawLine(greenPen, 50, 100, 550, 600)
            xLayer.Canvas.DrawLine(greenPen, 550, 100, 50, 600)

            ' Save the document to disk
            doc.Save("Sample_Layers.pdf")
        End Sub
    End Class
End Namespace


Samples: Lines

PDF4NET Send comments on this topic.
Samples: Lines
PDF4NET On-line Help > Samples > Samples: Lines

Glossary Item Box

This sample shows the lines drawing capabilities. On the first page it draws random positioned lines, the second page demonstrates the LineCap and LineJoin properties, and on the third page it draws a spiral using an array of consecutive line segments.

C# Source code | VB.NET Source code | PDF file


Lines.cs

PDF4NET Send comments on this topic.
Lines.cs
PDF4NET On-line Help > Samples > Lines > Lines.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.Lines
{
    /// <summary>
    /// This sample will show various types of lines.
    /// </summary>
    class Lines
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            DrawFirstPage(pdfDoc);
            DrawSecondPage(pdfDoc);
            DrawThirdPage(pdfDoc);

            // Save the document to disk
            pdfDoc.Save("Sample_Lines.pdf");
        }

        private static void DrawFirstPage(PDFDocument pdfDoc)
        {
            // Create first page
            PDFPage pdfPage = pdfDoc.AddPage();

            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());

            Random rnd = new Random();
            for (int i = 0; i < 50; i++)
            {
                // Create random colors for drawing the spline
                PDFRgbColor penColor = new PDFRgbColor((byte)rnd.Next(256),
                    (byte)rnd.Next(256), (byte)rnd.Next(256));

                // Create the pen to draw the border
                PDFPen randomPen = new PDFPen(penColor, 1);

                // Generate random control points
                double x1 = rnd.Next((int)pdfPage.Width);
                double y1 = rnd.Next((int)pdfPage.Height);
                double x2 = rnd.Next((int)pdfPage.Width);
                double y2 = rnd.Next((int)pdfPage.Height);

                // Draw the line
                pdfPage.Canvas.DrawLine(randomPen, x1, y1, x2, y2);
            }

            // Draw a label
            pdfPage.Canvas.DrawText("Random lines",
                fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft);
        }

        private static void DrawSecondPage(PDFDocument pdfDoc)
        {
            // Create first page
            PDFPage pdfPage = pdfDoc.AddPage();

            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 16);
            fontText.Bold = true;
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());
            PDFPen thinPen = new PDFPen(new PDFRgbColor(), 1);

            // Draw the line caps
            // Flat line cap
            PDFPen thickFlatPen = new PDFPen(new PDFRgbColor(Color.Orange), 15);
            thickFlatPen.LineCap = PDFLineCap.Flat;
            pdfPage.Canvas.DrawText("Line cap: Flat",
                fontText, null, blackBrush, 20, 25, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawLine(thickFlatPen, 200, 30, 400, 30);
            pdfPage.Canvas.DrawLine(thinPen, 200, 30, 400, 30);

            // Round line cap
            PDFPen thickRoundPen = new PDFPen(new PDFRgbColor(Color.Orange), 15);
            thickRoundPen.LineCap = PDFLineCap.Round;
            pdfPage.Canvas.DrawText("Line cap: Round",
                fontText, null, blackBrush, 20, 55, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawLine(thickRoundPen, 200, 60, 400, 60);
            pdfPage.Canvas.DrawLine(thinPen, 200, 60, 400, 60);

            // Square line cap
            PDFPen thickSquarePen = new PDFPen(new PDFRgbColor(Color.Orange), 15);
            thickSquarePen.LineCap = PDFLineCap.Square;
            pdfPage.Canvas.DrawText("Line cap: Square",
                fontText, null, blackBrush, 20, 85, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawLine(thickSquarePen, 200, 90, 400, 90);
            pdfPage.Canvas.DrawLine(thinPen, 200, 90, 400, 90);

            // Draw the line joins
            // Miter join
            PDFPoint[] pointsMiter = { new PDFPoint(200, 250), new PDFPoint(300, 150), new PDFPoint(400, 250) };
            thickRoundPen.LineJoin = PDFLineJoin.Miter;
            pdfPage.Canvas.DrawText("Line join: Miter", fontText, null, blackBrush, 20, 200, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawLines(thickRoundPen, pointsMiter);

            // Bevel join
            PDFPoint[] pointsBevel = { new PDFPoint(200, 350), new PDFPoint(300, 250), new PDFPoint(400, 350) };
            PDFPen thickRoundBevelPen = new PDFPen(new PDFRgbColor(Color.Orange), 15);
            thickRoundBevelPen.LineCap = PDFLineCap.Round;
            thickRoundBevelPen.LineJoin = PDFLineJoin.Bevel;
            pdfPage.Canvas.DrawText("Line join: Bevel", fontText, null, blackBrush, 20, 300, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawLines(thickRoundBevelPen, pointsBevel);

            // Round join
            PDFPoint[] pointsRound = { new PDFPoint(200, 450), new PDFPoint(300, 350), new PDFPoint(400, 450) };
            PDFPen thickFlatRoundPen = new PDFPen(new PDFRgbColor(Color.Orange), 15);
            thickFlatRoundPen.LineCap = PDFLineCap.Round;
            thickFlatRoundPen.LineJoin = PDFLineJoin.Round;
            pdfPage.Canvas.DrawText("Line join: Round", fontText, null, blackBrush, 20, 400, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawLines(thickFlatRoundPen, pointsRound);

            // Draw dash styles
            // Dash line style
            PDFPen dashPen = new PDFPen(new PDFRgbColor(Color.Orange), 1);
            dashPen.DashStyle = PDFDashStyle.Dash;
            pdfPage.Canvas.DrawText("Dash style: Dash",
                fontText, null, blackBrush, 20, 500, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawLine(dashPen, 200, 505, 400, 505);

            // Dash dot line style
            PDFPen dashDotPen = new PDFPen(new PDFRgbColor(Color.Orange), 1);
            dashDotPen.DashStyle = PDFDashStyle.DashDot;
            pdfPage.Canvas.DrawText("Dash style: DashDot",
                fontText, null, blackBrush, 20, 530, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawLine(dashDotPen, 200, 535, 400, 535);

            // Dash dot dot line style
            PDFPen dashDotDotPen = new PDFPen(new PDFRgbColor(Color.Orange), 1);
            dashDotDotPen.DashStyle = PDFDashStyle.DashDotDot;
            pdfPage.Canvas.DrawText("Dash style: DashDotDot",
                fontText, null, blackBrush, 20, 560, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawLine(dashDotDotPen, 200, 565, 400, 565);

            // Dot line style
            PDFPen dotPen = new PDFPen(new PDFRgbColor(Color.Orange), 1);
            dotPen.DashStyle = PDFDashStyle.Dot;
            pdfPage.Canvas.DrawText("Dash style: Dot",
                fontText, null, blackBrush, 20, 590, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawLine(dotPen, 200, 595, 400, 595);

            // Custom line style
            double[] dashPattern = { 20, 5, 10, 5, 5, 5 };
            PDFPen customPen = new PDFPen(new PDFRgbColor(Color.Orange), 1);
            customPen.DashStyle = PDFDashStyle.Custom;
            customPen.DashPattern = dashPattern;
            pdfPage.Canvas.DrawText("Dash style: Custom",
                fontText, null, blackBrush, 20, 620, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawLine(customPen, 200, 625, 400, 625);
        }

        private static void DrawThirdPage(PDFDocument pdfDoc)
        {
            // Create first page
            PDFPage pdfPage = pdfDoc.AddPage();

            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());

            // Draw a label
            pdfPage.Canvas.DrawText("Spiral lines",
                fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft);

            PDFPoint[] spiral = { new PDFPoint( 30, 30 ), new PDFPoint( 600, 30 ), new PDFPoint( 600, 700 ), new PDFPoint( 30, 700 ),
                                    new PDFPoint( 30, 60 ), new PDFPoint( 570, 60 ), new PDFPoint( 570, 670 ), new PDFPoint( 60, 670 ),
                                    new PDFPoint( 60, 90 ), new PDFPoint( 540, 90 ), new PDFPoint( 540, 640 ), new PDFPoint( 90, 640 ),
                                    new PDFPoint( 90, 120 ), new PDFPoint( 510, 120 ), new PDFPoint( 510, 610 ), new PDFPoint( 120, 610 ),
                                    new PDFPoint( 120, 150 ), new PDFPoint( 480, 150 ), new PDFPoint( 480, 580 ), new PDFPoint( 150, 580 ),
                                    new PDFPoint( 150, 180 ), new PDFPoint( 450, 180 ), new PDFPoint( 450, 550 ), new PDFPoint( 180, 550 ),
                                    new PDFPoint( 180, 210 ), new PDFPoint( 420, 210 ), new PDFPoint( 420, 520 ), new PDFPoint( 210, 520 ),
                                    new PDFPoint( 210, 240 ), new PDFPoint( 390, 240 ), new PDFPoint( 390, 490 ), new PDFPoint( 240, 490 ),
                                    new PDFPoint( 240, 270 ), new PDFPoint( 360, 270 ), new PDFPoint( 360, 460 ), new PDFPoint( 270, 460 ),
                                    new PDFPoint( 270, 300 ), new PDFPoint( 330, 300 ), new PDFPoint( 330, 430 ), new PDFPoint( 300, 430 ),
                                    new PDFPoint( 300, 330 ) };
            Random rnd = new Random();
            // Create random color for drawing the line
            PDFRgbColor penColor2 = new PDFRgbColor((byte)rnd.Next(256),
                (byte)rnd.Next(256), (byte)rnd.Next(256));
            // Create the pen to draw the line
            PDFPen randomPen2 = new PDFPen(penColor2, 1);

            pdfPage.Canvas.DrawLines(randomPen2, spiral);
        }
    }
}


Lines.vb

PDF4NET Send comments on this topic.
Lines.vb
PDF4NET On-line Help > Samples > Lines > Lines.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.Lines
    ''' <summary>
    ''' This sample will show various types of lines.
    ''' </summary>
    Class Lines
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            DrawFirstPage(pdfDoc)
            DrawSecondPage(pdfDoc)
            DrawThirdPage(pdfDoc)

            ' Save the document to disk
            pdfDoc.Save("Sample_Lines.pdf")
        End Sub

        Private Shared Sub DrawFirstPage(pdfDoc As PDFDocument)
            ' Create first page
            Dim pdfPage As PDFPage = pdfDoc.AddPage()

            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())

            Dim rnd As New Random()
            Dim i As Integer = 0
            While i < 50
                ' Create random colors for drawing the spline
                Dim penColor As New PDFRgbColor(rnd.Next(256), rnd.Next(256), rnd.Next(256))

                ' Create the pen to draw the border
                Dim randomPen As New PDFPen(penColor, 1)

                ' Generate random control points
                Dim x1 As Double = rnd.NextDouble() * pdfPage.Width
                Dim y1 As Double = rnd.NextDouble() * pdfPage.Height
                Dim x2 As Double = rnd.NextDouble() * pdfPage.Width
                Dim y2 As Double = rnd.NextDouble() * pdfPage.Height

                ' Draw the line
                pdfPage.Canvas.DrawLine(randomPen, x1, y1, x2, y2)
                i = i + 1
            End While

            ' Draw a label
            pdfPage.Canvas.DrawText("Random lines", fontText, Nothing, blackBrush, 20, 20, _
                0, PDFTextAlign.TopLeft)
        End Sub

        Private Shared Sub DrawSecondPage(pdfDoc As PDFDocument)
            ' Create first page
            Dim pdfPage As PDFPage = pdfDoc.AddPage()

            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 16)
            fontText.Bold = True
            Dim blackBrush As New PDFBrush(New PDFRgbColor())
            Dim thinPen As New PDFPen(New PDFRgbColor(), 1)

            ' Draw the line caps
            ' Flat line cap
            Dim thickFlatPen As New PDFPen(New PDFRgbColor(Color.Orange), 15)
            thickFlatPen.LineCap = PDFLineCap.Flat
            pdfPage.Canvas.DrawText("Line cap: Flat", fontText, Nothing, blackBrush, 20, 25, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawLine(thickFlatPen, 200, 30, 400, 30)
            pdfPage.Canvas.DrawLine(thinPen, 200, 30, 400, 30)

            ' Round line cap
            Dim thickRoundPen As New PDFPen(New PDFRgbColor(Color.Orange), 15)
            thickRoundPen.LineCap = PDFLineCap.Round
            pdfPage.Canvas.DrawText("Line cap: Round", fontText, Nothing, blackBrush, 20, 55, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawLine(thickRoundPen, 200, 60, 400, 60)
            pdfPage.Canvas.DrawLine(thinPen, 200, 60, 400, 60)

            ' Square line cap
            Dim thickSquarePen As New PDFPen(New PDFRgbColor(Color.Orange), 15)
            thickSquarePen.LineCap = PDFLineCap.Square
            pdfPage.Canvas.DrawText("Line cap: Square", fontText, Nothing, blackBrush, 20, 85, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawLine(thickSquarePen, 200, 90, 400, 90)
            pdfPage.Canvas.DrawLine(thinPen, 200, 90, 400, 90)

            ' Draw the line joins
            ' Miter join
            Dim pointsMiter As PDFPoint() = {New PDFPoint(200, 250), New PDFPoint(300, 150), New PDFPoint(400, 250)}
            thickRoundPen.LineJoin = PDFLineJoin.Miter
            pdfPage.Canvas.DrawText("Line join: Miter", fontText, Nothing, blackBrush, 20, 200, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawLines(thickRoundPen, pointsMiter)

            ' Bevel join
            Dim pointsBevel As PDFPoint() = {New PDFPoint(200, 350), New PDFPoint(300, 250), New PDFPoint(400, 350)}
            Dim thickRoundBevelPen As New PDFPen(New PDFRgbColor(Color.Orange), 15)
            thickRoundBevelPen.LineCap = PDFLineCap.Round
            thickRoundBevelPen.LineJoin = PDFLineJoin.Bevel
            pdfPage.Canvas.DrawText("Line join: Bevel", fontText, Nothing, blackBrush, 20, 300, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawLines(thickRoundBevelPen, pointsBevel)

            ' Round join
            Dim pointsRound As PDFPoint() = {New PDFPoint(200, 450), New PDFPoint(300, 350), New PDFPoint(400, 450)}
            Dim thickFlatRoundPen As New PDFPen(New PDFRgbColor(Color.Orange), 15)
            thickFlatRoundPen.LineCap = PDFLineCap.Round
            thickFlatRoundPen.LineJoin = PDFLineJoin.Round
            pdfPage.Canvas.DrawText("Line join: Round", fontText, Nothing, blackBrush, 20, 400, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawLines(thickFlatRoundPen, pointsRound)

            ' Draw dash styles
            ' Dash line style
            Dim dashPen As New PDFPen(New PDFRgbColor(Color.Orange), 1)
            dashPen.DashStyle = PDFDashStyle.Dash
            pdfPage.Canvas.DrawText("Dash style: Dash", fontText, Nothing, blackBrush, 20, 500, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawLine(dashPen, 200, 505, 400, 505)

            ' Dash dot line style
            Dim dashDotPen As New PDFPen(New PDFRgbColor(Color.Orange), 1)
            dashDotPen.DashStyle = PDFDashStyle.DashDot
            pdfPage.Canvas.DrawText("Dash style: DashDot", fontText, Nothing, blackBrush, 20, 530, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawLine(dashDotPen, 200, 535, 400, 535)

            ' Dash dot dot line style
            Dim dashDotDotPen As New PDFPen(New PDFRgbColor(Color.Orange), 1)
            dashDotDotPen.DashStyle = PDFDashStyle.DashDotDot
            pdfPage.Canvas.DrawText("Dash style: DashDot", fontText, Nothing, blackBrush, 20, 560, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawLine(dashDotDotPen, 200, 565, 400, 565)

            ' Dot line style
            Dim dotPen As New PDFPen(New PDFRgbColor(Color.Orange), 1)
            dotPen.DashStyle = PDFDashStyle.Dot
            pdfPage.Canvas.DrawText("Dash style: Dot", fontText, Nothing, blackBrush, 20, 590, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawLine(dotPen, 200, 595, 400, 595)

            ' Custom line style
            Dim dashPattern As Double() = {20, 5, 10, 5, 5, 5}
            Dim customPen As New PDFPen(New PDFRgbColor(Color.Orange), 1)
            customPen.DashStyle = PDFDashStyle.[Custom]
            customPen.DashPattern = dashPattern
            pdfPage.Canvas.DrawText("Dash style: Custom", fontText, Nothing, blackBrush, 20, 620, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawLine(customPen, 200, 625, 400, 625)
        End Sub

        Private Shared Sub DrawThirdPage(pdfDoc As PDFDocument)
            ' Create first page
            Dim pdfPage As PDFPage = pdfDoc.AddPage()

            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())

            ' Draw a label
            pdfPage.Canvas.DrawText("Spiral lines", fontText, Nothing, blackBrush, 20, 20, _
                0, PDFTextAlign.TopLeft)

            Dim spiral As PDFPoint() = {New PDFPoint(30, 30), New PDFPoint(600, 30), New PDFPoint(600, 700), New PDFPoint(30, 700), New PDFPoint(30, 60), New PDFPoint(570, 60), _
                New PDFPoint(570, 670), New PDFPoint(60, 670), New PDFPoint(60, 90), New PDFPoint(540, 90), New PDFPoint(540, 640), New PDFPoint(90, 640), _
                New PDFPoint(90, 120), New PDFPoint(510, 120), New PDFPoint(510, 610), New PDFPoint(120, 610), New PDFPoint(120, 150), New PDFPoint(480, 150), _
                New PDFPoint(480, 580), New PDFPoint(150, 580), New PDFPoint(150, 180), New PDFPoint(450, 180), New PDFPoint(450, 550), New PDFPoint(180, 550), _
                New PDFPoint(180, 210), New PDFPoint(420, 210), New PDFPoint(420, 520), New PDFPoint(210, 520), New PDFPoint(210, 240), New PDFPoint(390, 240), _
                New PDFPoint(390, 490), New PDFPoint(240, 490), New PDFPoint(240, 270), New PDFPoint(360, 270), New PDFPoint(360, 460), New PDFPoint(270, 460), _
                New PDFPoint(270, 300), New PDFPoint(330, 300), New PDFPoint(330, 430), New PDFPoint(300, 430), New PDFPoint(300, 330)}
            Dim rnd As New Random()
            ' Create random color for drawing the line
            Dim penColor2 As New PDFRgbColor(rnd.Next(256), rnd.Next(256), rnd.Next(256))
            ' Create the pen to draw the line
            Dim randomPen2 As New PDFPen(penColor2, 1)

            pdfPage.Canvas.DrawLines(randomPen2, spiral)
        End Sub
    End Class
End Namespace


Samples: Links

PDF4NET Send comments on this topic.
Samples: Links
PDF4NET On-line Help > Samples > Samples: Links

Glossary Item Box

This sample shows how to create links in a page that point to other content. It shows all 4 types of links: internal links, external document links, file links and web links. For each type of link, an area link and a text link are created.

C# Source code | VB.NET Source code | PDF file


Links.cs

PDF4NET Send comments on this topic.
Links.cs
PDF4NET On-line Help > Samples > Links > Links.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Actions;
using O2S.Components.PDF4NET.Annotations;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.Links
{
    /// <summary>
    /// This sample will show how to create links to internal
    /// and external elements.
    /// </summary>
    class Links
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // The default page size is letter
            const int width = 612;
            const int height = 792;

            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFFont fontTitle = new PDFFont(PDFFontFace.Helvetica, 72);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());
            PDFPen blackPen = new PDFPen(new PDFRgbColor(), 1);

            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            // Add 2 pages to the document
            PDFPage pdfPage1 = pdfDoc.AddPage();
            PDFPage pdfPage2 = pdfDoc.AddPage();

            // Create content for page1
            pdfPage1.Canvas.DrawText("Rectangular area links", fontText,
                null, blackBrush, width / 4, 20, 0, PDFTextAlign.TopCenter);
            pdfPage1.Canvas.DrawText("Text links", fontText,
                null, blackBrush, 3 * width / 4, 20, 0, PDFTextAlign.TopCenter);
            pdfPage1.Canvas.DrawLine(blackPen, width / 2, 20, width / 2, height - 20);

            // Draw the rectangular links
            // Web link
            DrawAreaWebLink(pdfPage1, "http://www.o2sol.com/", 10, 30,
                width / 2 - 30, 150, new PDFRgbColor(0, 0, 255), 1);
            pdfPage1.Canvas.DrawText("web link", fontText, null, blackBrush, 15, 35, 0, PDFTextAlign.TopLeft);
            // File link
            DrawAreaFileLink(pdfPage1, "links.exe", 10, 200,
                width / 2 - 30, 150, new PDFRgbColor(255, 0, 0), 1);
            pdfPage1.Canvas.DrawText("file link", fontText, null, blackBrush, 15, 205, 0, PDFTextAlign.TopLeft);
            // External pdf document link
            DrawAreaRemoteDocLink(pdfPage1, "Sample_HelloPDFWorld.pdf", 10, 400,
                width / 2 - 30, 150, new PDFRgbColor(0, 255, 0), 1);
            pdfPage1.Canvas.DrawText("external pdf file link", fontText, null, blackBrush, 15, 405, 0, PDFTextAlign.TopLeft);
            // In document link
            DrawAreaDocLink(pdfPage1, pdfPage2, 10, 600,
                width / 2 - 30, 150, new PDFRgbColor(), 1);
            pdfPage1.Canvas.DrawText("in document link (click to go to next page)",
                fontText, null, blackBrush, 15, 605, 0, PDFTextAlign.TopLeft);

            // Draw the text links
            // Web link
            DrawTextWebLink(pdfPage1, "http://www.o2sol.com/", "Text web link",
                fontText, blackBrush, width / 2 + 30, 35, new PDFRgbColor(), 0);
            // File link
            DrawTextFileLink(pdfPage1, "links.exe", "Text file link",
                fontText, blackBrush, width / 2 + 30, 205, new PDFRgbColor(), 0);
            // External pdf document link
            DrawTextRemoteDocLink(pdfPage1, "Sample_HelloPDFWorld.pdf", "Text external pdf document link",
                fontText, blackBrush, width / 2 + 30, 405, new PDFRgbColor(), 0);
            // In document link
            DrawTextDocLink(pdfPage1, pdfPage2, "Text in document link (click to go to next page)",
                fontText, blackBrush, width / 2 + 30, 605, new PDFRgbColor(), 0);

            pdfPage2.Canvas.DrawText("This is page 2.",
                fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft);

            // Save the document to disk
            pdfDoc.Save("Sample_Links.pdf");
        }

        private static PDFLinkAnnotation CreateLinkAnnotation(PDFPage page,
            double left, double top, double width, double height, PDFDeviceColor borderColor, double borderWidth)
        {
            PDFLinkAnnotation linkAnnotation = new PDFLinkAnnotation();
            linkAnnotation.DisplayRectangle = new DisplayRectangle(left, top, width, height);
            linkAnnotation.Border = new PDFAnnotationBorder(borderWidth, PDFBorderStyle.Solid);
            linkAnnotation.Color = borderColor;

            page.Annotations.Add(linkAnnotation);

            return linkAnnotation;
        }

        private static void DrawAreaWebLink(PDFPage page, string url, double left, double top,
            double width, double height, PDFDeviceColor borderColor, double borderWidth)
        {
            PDFURIAction uriAction = new PDFURIAction();
            uriAction.URI = url;

            PDFLinkAnnotation linkAnnotation = CreateLinkAnnotation(page, left, top, width, height, borderColor, borderWidth);
            linkAnnotation.Action = uriAction;
        }

        private static void DrawAreaFileLink(PDFPage page, string fileName, double left, double top,
            double width, double height, PDFDeviceColor borderColor, double borderWidth)
        {
            PDFLaunchAction launchAction = new PDFLaunchAction();
            launchAction.FileName = fileName;

            PDFLinkAnnotation linkAnnotation = CreateLinkAnnotation(page, left, top, width, height, borderColor, borderWidth);
            linkAnnotation.Action = launchAction;
        }

        private static void DrawAreaRemoteDocLink(PDFPage page, string pdfFileName, double left, double top,
            double width, double height, PDFDeviceColor borderColor, double borderWidth)
        {
            PDFRemotePageDestination rpd = new PDFRemotePageDestination();
            rpd.PageNumber = 0;
            PDFRemoteGoToAction remoteGoToAction = new PDFRemoteGoToAction();
            remoteGoToAction.FileName = pdfFileName;
            remoteGoToAction.Destination = rpd;

            PDFLinkAnnotation linkAnnotation = CreateLinkAnnotation(page, left, top, width, height, borderColor, borderWidth);
            linkAnnotation.Action = remoteGoToAction;
        }

        private static void DrawAreaDocLink(PDFPage page, PDFPage destinationPage, double left, double top,
            double width, double height, PDFDeviceColor borderColor, double borderWidth)
        {
            PDFPageDestination pd = new PDFPageDestination();
            pd.Page = destinationPage;
            pd.MagnificationMode = PDFMagnificationMode.Fit;

            PDFGoToAction goToAction = new PDFGoToAction();
            goToAction.Destination = pd;

            PDFLinkAnnotation linkAnnotation = CreateLinkAnnotation(page, left, top, width, height, borderColor, borderWidth);
            linkAnnotation.Action = goToAction;
        }

        private static void DrawTextWebLink(PDFPage page, string url, string linkText,
            PDFFontBase font, PDFBrush brush, double left, double top,
            PDFDeviceColor borderColor, double borderWidth)
        {
            double width = font.MeasureString(linkText);
            double height = font.Size;

            page.Canvas.DrawText(linkText, font, brush, left, top);

            DrawAreaWebLink(page, url, left, top, width, height, borderColor, borderWidth);
        }

        private static void DrawTextFileLink(PDFPage page, string fileName, string linkText,
            PDFFontBase font, PDFBrush brush, double left, double top,
            PDFDeviceColor borderColor, double borderWidth)
        {
            double width = font.MeasureString(linkText);
            double height = font.Size;

            page.Canvas.DrawText(linkText, font, brush, left, top);

            DrawAreaFileLink(page, fileName, left, top, width, height, borderColor, borderWidth);
        }

        private static void DrawTextRemoteDocLink(
            PDFPage page, string pdfFileName, string linkText,
            PDFFontBase font, PDFBrush brush, double left, double top,
            PDFDeviceColor borderColor, double borderWidth)
        {
            double width = font.MeasureString(linkText);
            double height = font.Size;

            page.Canvas.DrawText(linkText, font, brush, left, top);

            DrawAreaRemoteDocLink(page, pdfFileName, left, top, width, height, borderColor, borderWidth);
        }

        private static void DrawTextDocLink(
            PDFPage page, PDFPage destinationPage, string linkText,
            PDFFontBase font, PDFBrush brush, double left, double top,
            PDFDeviceColor borderColor, double borderWidth)
        {
            double width = font.MeasureString(linkText);
            double height = font.Size;

            page.Canvas.DrawText(linkText, font, brush, left, top);

            DrawAreaDocLink(page, destinationPage, left, top, width, height, borderColor, borderWidth);
        }
    }
}


Links.vb

PDF4NET Send comments on this topic.
Links.vb
PDF4NET On-line Help > Samples > Links > Links.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Actions
Imports O2S.Components.PDF4NET.Annotations
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.Links
    ''' <summary>
    ''' This sample will show how to create links to internal
    ''' and external elements.
    ''' </summary>
    Class Links
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' The default page size is letter
            Const  width As Integer = 612
            Const  height As Integer = 792

            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim fontTitle As New PDFFont(PDFFontFace.Helvetica, 72)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())
            Dim blackPen As New PDFPen(New PDFRgbColor(), 1)

            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            ' Add 2 pages to the document
            Dim pdfPage1 As PDFPage = pdfDoc.AddPage()
            Dim pdfPage2 As PDFPage = pdfDoc.AddPage()

            ' Create content for page1
            pdfPage1.Canvas.DrawText("Rectangular area links", fontText, Nothing, blackBrush, width / 4, 20, _
                0, PDFTextAlign.TopCenter)
            pdfPage1.Canvas.DrawText("Text links", fontText, Nothing, blackBrush, 3 * width / 4, 20, _
                0, PDFTextAlign.TopCenter)
            pdfPage1.Canvas.DrawLine(blackPen, width / 2, 20, width / 2, height - 20)

            ' Draw the rectangular links
            ' Web link
            DrawAreaWebLink(pdfPage1, "http://www.o2sol.com/", 10, 30, width / 2 - 30, 150, _
                New PDFRgbColor(0, 0, 255), 1)
            pdfPage1.Canvas.DrawText("web link", fontText, Nothing, blackBrush, 15, 35, _
                0, PDFTextAlign.TopLeft)
            ' File link
            DrawAreaFileLink(pdfPage1, "links.exe", 10, 200, width / 2 - 30, 150, _
                New PDFRgbColor(255, 0, 0), 1)
            pdfPage1.Canvas.DrawText("file link", fontText, Nothing, blackBrush, 15, 205, _
                0, PDFTextAlign.TopLeft)
            ' External pdf document link
            DrawAreaRemoteDocLink(pdfPage1, "Sample_HelloPDFWorld.pdf", 10, 400, width / 2 - 30, 150, _
                New PDFRgbColor(0, 255, 0), 1)
            pdfPage1.Canvas.DrawText("external pdf file link", fontText, Nothing, blackBrush, 15, 405, _
                0, PDFTextAlign.TopLeft)
            ' In document link
            DrawAreaDocLink(pdfPage1, pdfPage2, 10, 600, width / 2 - 30, 150, _
                New PDFRgbColor(), 1)
            pdfPage1.Canvas.DrawText("in document link (click to go to next page)", fontText, Nothing, blackBrush, 15, 605, _
                0, PDFTextAlign.TopLeft)

            ' Draw the text links
            ' Web link
            DrawTextWebLink(pdfPage1, "http://www.o2sol.com/", "Text web link", fontText, blackBrush, width / 2 + 30, _
                35, New PDFRgbColor(), 0)
            ' File link
            DrawTextFileLink(pdfPage1, "links.exe", "Text file link", fontText, blackBrush, width / 2 + 30, _
                205, New PDFRgbColor(), 0)
            ' External pdf document link
            DrawTextRemoteDocLink(pdfPage1, "Sample_HelloPDFWorld.pdf", "Text external pdf document link", fontText, blackBrush, width / 2 + 30, _
                405, New PDFRgbColor(), 0)
            ' In document link
            DrawTextDocLink(pdfPage1, pdfPage2, "Text in document link (click to go to next page)", fontText, blackBrush, width / 2 + 30, _
                605, New PDFRgbColor(), 0)

            pdfPage2.Canvas.DrawText("This is page 2.", fontText, Nothing, blackBrush, 20, 20, _
                0, PDFTextAlign.TopLeft)

            ' Save the document to disk
            pdfDoc.Save("Sample_Links.pdf")
        End Sub

        Private Shared Function CreateLinkAnnotation(page As PDFPage, left As Double, top As Double, width As Double, height As Double, borderColor As PDFDeviceColor, _
            borderWidth As Double) As PDFLinkAnnotation
            Dim linkAnnotation As New PDFLinkAnnotation()
            linkAnnotation.DisplayRectangle = New DisplayRectangle(left, top, width, height)
            linkAnnotation.Border = New PDFAnnotationBorder(borderWidth, PDFBorderStyle.Solid)
            linkAnnotation.Color = borderColor

            page.Annotations.Add(linkAnnotation)

            Return linkAnnotation
        End Function

        Private Shared Sub DrawAreaWebLink(page As PDFPage, url As String, left As Double, top As Double, width As Double, height As Double, _
            borderColor As PDFDeviceColor, borderWidth As Double)
            Dim uriAction As New PDFURIAction()
            uriAction.URI = url

            Dim linkAnnotation As PDFLinkAnnotation = CreateLinkAnnotation(page, left, top, width, height, borderColor, _
                borderWidth)
            linkAnnotation.Action = uriAction
        End Sub

        Private Shared Sub DrawAreaFileLink(page As PDFPage, fileName As String, left As Double, top As Double, width As Double, height As Double, _
            borderColor As PDFDeviceColor, borderWidth As Double)
            Dim launchAction As New PDFLaunchAction()
            launchAction.FileName = fileName

            Dim linkAnnotation As PDFLinkAnnotation = CreateLinkAnnotation(page, left, top, width, height, borderColor, _
                borderWidth)
            linkAnnotation.Action = launchAction
        End Sub

        Private Shared Sub DrawAreaRemoteDocLink(page As PDFPage, pdfFileName As String, left As Double, top As Double, width As Double, height As Double, _
            borderColor As PDFDeviceColor, borderWidth As Double)
            Dim rpd As New PDFRemotePageDestination()
            rpd.PageNumber = 0
            Dim remoteGoToAction As New PDFRemoteGoToAction()
            remoteGoToAction.FileName = pdfFileName
            remoteGoToAction.Destination = rpd

            Dim linkAnnotation As PDFLinkAnnotation = CreateLinkAnnotation(page, left, top, width, height, borderColor, _
                borderWidth)
            linkAnnotation.Action = remoteGoToAction
        End Sub

        Private Shared Sub DrawAreaDocLink(page As PDFPage, destinationPage As PDFPage, left As Double, top As Double, width As Double, height As Double, _
            borderColor As PDFDeviceColor, borderWidth As Double)
            Dim pd As New PDFPageDestination()
            pd.Page = destinationPage
            pd.MagnificationMode = PDFMagnificationMode.Fit

            Dim goToAction As New PDFGoToAction()
            goToAction.Destination = pd

            Dim linkAnnotation As PDFLinkAnnotation = CreateLinkAnnotation(page, left, top, width, height, borderColor, _
                borderWidth)
            linkAnnotation.Action = goToAction
        End Sub

        Private Shared Sub DrawTextWebLink(page As PDFPage, url As String, linkText As String, font As PDFFontBase, brush As PDFBrush, left As Double, _
            top As Double, borderColor As PDFDeviceColor, borderWidth As Double)
            Dim width As Double = font.MeasureString(linkText)
            Dim height As Double = font.Size

            page.Canvas.DrawText(linkText, font, brush, left, top)

            DrawAreaWebLink(page, url, left, top, width, height, _
                borderColor, borderWidth)
        End Sub

        Private Shared Sub DrawTextFileLink(page As PDFPage, fileName As String, linkText As String, font As PDFFontBase, brush As PDFBrush, left As Double, _
            top As Double, borderColor As PDFDeviceColor, borderWidth As Double)
            Dim width As Double = font.MeasureString(linkText)
            Dim height As Double = font.Size

            page.Canvas.DrawText(linkText, font, brush, left, top)

            DrawAreaFileLink(page, fileName, left, top, width, height, _
                borderColor, borderWidth)
        End Sub

        Private Shared Sub DrawTextRemoteDocLink(page As PDFPage, pdfFileName As String, linkText As String, font As PDFFontBase, brush As PDFBrush, left As Double, _
            top As Double, borderColor As PDFDeviceColor, borderWidth As Double)
            Dim width As Double = font.MeasureString(linkText)
            Dim height As Double = font.Size

            page.Canvas.DrawText(linkText, font, brush, left, top)

            DrawAreaRemoteDocLink(page, pdfFileName, left, top, width, height, _
                borderColor, borderWidth)
        End Sub

        Private Shared Sub DrawTextDocLink(page As PDFPage, destinationPage As PDFPage, linkText As String, font As PDFFontBase, brush As PDFBrush, left As Double, _
            top As Double, borderColor As PDFDeviceColor, borderWidth As Double)
            Dim width As Double = font.MeasureString(linkText)
            Dim height As Double = font.Size

            page.Canvas.DrawText(linkText, font, brush, left, top)

            DrawAreaDocLink(page, destinationPage, left, top, width, height, _
                borderColor, borderWidth)
        End Sub
    End Class
End Namespace


Samples: Metafiles

PDF4NET Send comments on this topic.
Samples: Metafiles
PDF4NET On-line Help > Samples > Samples: Metafiles

Glossary Item Box

This sample demonstrates the metafiles support implemented in PDF4NET library. Enhanced Windows Metafiles are converted to native PDF vector data when using PDFMetafile class. Metafiles can be scaled or rotated without losing their graphic quality.
Metafiles are stored as form XObjects to reduce the file size, and allowing the viewer to cache their graphic representation when the metafile is displayed multiple times in the same file.

C# Source code | VB.NET Source code | PDF file


Metafiles.cs

PDF4NET Send comments on this topic.
Metafiles.cs
PDF4NET On-line Help > Samples > Metafiles > Metafiles.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;

namespace O2S.Samples.PDF4NET.Metafiles
{
    /// <summary>
    /// This sample shows how to use metafiles in a PDF file.
    /// When using metafiles in this way, they are converted to PDF vector data
    /// thus keeping the graphic details, no matter the drawing size. If metafiles
    /// are used with DrawImage methods, they are converted to raster data thus resulting
    /// the stairs effect when zooming the PDF file.<br>
    /// The metafile data is stored only once in the PDF file
    /// and can be drawn multiple times.
    /// </summary>
    class Metafiles
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument doc = new PDFDocument();

            // Create first page
            PDFPage page = doc.AddPage();

            // Create a metafile object
            PDFMetafile mf = new PDFMetafile("..\\SupportFiles\\sample.emf");

            page.Orientation = PDFPageOrientation.Landscape;
            page.Canvas.DrawFormXObject(mf, 10, 10, page.Width - 20, page.Height - 20);

            // Create second page
            page = doc.AddPage();

            page.Orientation = PDFPageOrientation.Landscape;
            page.Canvas.DrawFormXObject(mf, 10, 10, page.Width / 2 - 20, page.Height / 2 - 20);
            page.Canvas.DrawFormXObject(mf, page.Width / 2 + 10, 10, page.Width / 2 - 20, page.Height / 2 - 20);
            page.Canvas.DrawFormXObject(mf, 10, page.Height / 2 + 10, page.Width / 2 - 20, page.Height / 2 - 20);
            page.Canvas.DrawFormXObject(mf, page.Width / 2 + 10, page.Height / 2 + 10, page.Width / 2 - 20, page.Height / 2 - 20);

            // Save the document to disk
            doc.Save("Sample_Metafiles.pdf");
        }
    }
}


Metafiles.vb

PDF4NET Send comments on this topic.
Metafiles.vb
PDF4NET On-line Help > Samples > Metafiles > Metafiles.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes

Namespace O2S.Samples.PDF4NET.Metafiles
    ''' <summary>
    ''' This sample shows how to use metafiles in a PDF file.
    ''' When using metafiles in this way, they are converted to PDF vector data
    ''' thus keeping the graphic details, no matter the drawing size. If metafiles
    ''' are used with DrawImage methods, they are converted to raster data thus resulting
    ''' the stairs effect when zooming the PDF file.<br>
    ''' The metafile data is stored only once in the PDF file
    ''' and can be drawn multiple times.
    ''' </summary>
    Class Metafiles
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim doc As New PDFDocument()

            ' Create first page
            Dim page As PDFPage = doc.AddPage()

            ' Create a metafile object
            Dim mf As New PDFMetafile("..\SupportFiles\sample.emf")

            page.Orientation = PDFPageOrientation.Landscape
            page.Canvas.DrawFormXObject(mf, 10, 10, page.Width - 20, page.Height - 20)

            ' Create second page
            page = doc.AddPage()

            page.Orientation = PDFPageOrientation.Landscape
            page.Canvas.DrawFormXObject(mf, 10, 10, page.Width / 2 - 20, page.Height / 2 - 20)
            page.Canvas.DrawFormXObject(mf, page.Width / 2 + 10, 10, page.Width / 2 - 20, page.Height / 2 - 20)
            page.Canvas.DrawFormXObject(mf, 10, page.Height / 2 + 10, page.Width / 2 - 20, page.Height / 2 - 20)
            page.Canvas.DrawFormXObject(mf, page.Width / 2 + 10, page.Height / 2 + 10, page.Width / 2 - 20, page.Height / 2 - 20)

            ' Save the document to disk
            doc.Save("Sample_Metafiles.pdf")
        End Sub
    End Class
End Namespace


Samples: Multicolumn Text and Images

PDF4NET Send comments on this topic.
Samples: Multicolumn Text and Images
PDF4NET On-line Help > Samples > Samples: Multicolumn Text and Images

Glossary Item Box

This sample shows how to draw columnar text that flows over multiple pages. It also demonstrates HTML formatting capabilities of PDF4NET library.

C# Source code | VB.NET Source code | PDF file


MultiColumnTextAndImages.cs

PDF4NET Send comments on this topic.
MultiColumnTextAndImages.cs
PDF4NET On-line Help > Samples > MulticolumnTextAndImages > MultiColumnTextAndImages.cs

Glossary Item Box

using System;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.MultiColumnTextAndImages
{
    /// <summary>
    /// Summary description for Class1.
    /// </summary>
    class MultiColumnTextAndImages
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            double leftMargin = 30;
            double topMargin = 30;
            double rightMargin = 30;
            double bottomMargin = 30;
            double columnSpace = 30;
            double columnCount = 2;
            double columnWidth = (612 - leftMargin - rightMargin - columnSpace) / 2;//612 - width of Letter size in points
            double columnHeight = 792 - topMargin - bottomMargin;//792 - height of Letter size in points
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor(0, 0, 0));
            PDFFont font = new PDFFont(PDFFontFace.Helvetica, 12);

            string longText = "<font color='#0000F8'><b>PDF4NET</b></font> is a <u><i>.NET</i></u> " +
                "library for embedding pdf " +
                "documents creation in any <u><i>.NET</i></u> application. " +
                "The pdf files structure is " +
                "hidden behind a simple object model that allows the creation of " +
                "<u>complex pdf documents with a few lines of code</u>. The library uses " +
                "a grid-based approach for placing content on document's pages. " +
                "It allows random access to each page of the document, allowing " +
                "the developer to set the size and the orientation for each page. " +
                "The object model provides support for basic drawing primitives, " +
                "like lines, circles, rectangles, images, etc. " +
                "It also provides extensive support for drawing text, giving the " +
                "developer a large freedom in formatting and placing text on page. " +
                "<font face='TimesRoman'>The library also offers more advanced features, like: automatic page " +
                "numbering; page templates; creation of bookmarks tree; " +
                "creation of hyperlinks; transition effects between pages; support " +
                "for viewer preferences; support for document metadata, like author, " +
                "title, etc, allowing the document to be searched and indexed; custom " +
                "document properties; enhanced color support (RGB, CMYK, Grayscale); " +
                "Adobe XMP metadata storage; user defined logical units; user defined " +
                "coordinate system.</font><br/>" +
                "The resulting pdf documents can be saved to disk or HTTP streams. " +
                "The library compresses document's content, thus resulting smaller pdf files. " +
                "The <font color='#0000F8'><b>PDF4NET</b></font> library can be used both from windows and <i>ASP.NET</i> applications. " +
                "The library is 100% managed, being written in C#. " +
                "The <font color='#0000F8'><b>PDF4NET</b></font> library is <u>licensed " +
                "per developer</u> and can be " +
                "distributed <font color='#F80000'>royalty free</font>.<br/><br/>";

            longText = longText + longText + longText + longText + longText + longText +
                longText + longText + longText + longText + longText + longText;

            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            PDFTextFormatOptions tfo = new PDFTextFormatOptions();
            tfo.Align = PDFTextAlign.TopJustified;
            tfo.ClipText = PDFClipText.ClipWords;

            // length of text that fits in the column
            int columnTextLength;

            bool endOfText = false;
            int startIndex = 0;
            // start drawing text
            while (!endOfText)
            {
                // where to start to print the column
                double leftOffset = leftMargin;

                // Create a new page in the document
                PDFPage page = pdfDoc.AddPage();

                int i = 0;
                // draw each column
                // each column will contain one random positioned image
                Random rnd = new Random();
                while (i < columnCount)
                {
                    #region Random Image Placement

                    // index of the image to be displayed
                    int imageIndex = 1 + rnd.Next(5);

                    // set columnHeight for height, because we'll set KeepAspectRatio to
                    // KeepWidth and the height will be automatically computed.
                    PDFImage img = new PDFImage("..\\SupportFiles\\auto" + imageIndex.ToString() + ".jpg");
                    double imageHeight = img.Height * columnWidth / img.Width;
                    // compute a random top position for the image so it fits full
                    // in the column
                    double imageTop = 30 +
                        (columnHeight - topMargin - bottomMargin - imageHeight) * rnd.NextDouble();

                    // draw the image
                    page.Canvas.DrawImage(img, leftOffset, imageTop, columnWidth, imageHeight);

                    #endregion Random Image Placement

                    #region Above Image Text

                    // see how much text fits above the image
                    // imageTop - topMargin = the height available above the image
                    columnTextLength = page.Canvas.FitHtmlText(longText, startIndex, font, columnWidth, imageTop - topMargin);

                    // draw text above image
                    page.Canvas.DrawHTMLTextBox(longText, font, null, blackBrush,
                        leftOffset, topMargin, columnWidth, imageTop - topMargin, tfo, startIndex);

                    // move the index to the next fragment
                    startIndex = startIndex + columnTextLength;
                    if (startIndex >= longText.Length)
                    {
                        endOfText = true;
                        break;
                    }

                    #endregion Above Image Text

                    #region Below Image Text

                    // see how much text fits below the image
                    // columnHeight - ( topText - topMargin ) = available space below image
                    double topText = Math.Ceiling((imageTop + imageHeight) / font.Size) * font.Size;
                    columnTextLength = page.Canvas.FitHtmlText(longText, startIndex, font, columnWidth, columnHeight - (topText - topMargin));

                    // draw text below image
                    page.Canvas.DrawHTMLTextBox(longText, font, null, blackBrush,
                        leftOffset, topText, columnWidth,
                        columnHeight - (topText - topMargin),
                        tfo, startIndex);

                    // move the index to the next fragment
                    startIndex = startIndex + columnTextLength;
                    if (startIndex >= longText.Length)
                    {
                        endOfText = true;
                        break;
                    }

                    #endregion Below Image Text

                    // compute the offset of the next column
                    leftOffset = leftOffset + columnWidth + columnSpace;

                    i++;
                }
            }

            // Save the document to disk
            pdfDoc.Save("Sample_MultiColumnTextAndImages.pdf");
        }
    }
}


MultiColumnTextAndImages.vb

PDF4NET Send comments on this topic.
MultiColumnTextAndImages.vb
PDF4NET On-line Help > Samples > MulticolumnTextAndImages > MultiColumnTextAndImages.vb

Glossary Item Box

Imports System
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.MultiColumnTextAndImages
    ''' <summary>
    ''' Summary description for Class1.
    ''' </summary>
    Class MultiColumnTextAndImages
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            Dim leftMargin As Double = 30
            Dim topMargin As Double = 30
            Dim rightMargin As Double = 30
            Dim bottomMargin As Double = 30
            Dim columnSpace As Double = 30
            Dim columnCount As Double = 2
            Dim columnWidth As Double = (612 - leftMargin - rightMargin - columnSpace) / 2
            '612 - width of Letter size in points
            Dim columnHeight As Double = 792 - topMargin - bottomMargin
            '792 - height of Letter size in points
            Dim blackBrush As New PDFBrush(New PDFRgbColor(0, 0, 0))
            Dim font As New PDFFont(PDFFontFace.Helvetica, 12)

            Dim longText As String = "<font color='#0000F8'><b>PDF4NET</b></font> is a <u><i>.NET</i></u> " + _
                "library for embedding pdf documents creation in any <u><i>.NET</i></u> application. " + _
                "The pdf files structure is " + "hidden behind a simple object model that allows the creation of " + _
                "<u>complex pdf documents with a few lines of code</u>. The library uses " + _
                "a grid-based approach for placing content on document's pages. " + _
                "It allows random access to each page of the document, allowing " + _
                "the developer to set the size and the orientation for each page. " + _
                "The object model provides support for basic drawing primitives, " + _
                "like lines, circles, rectangles, images, etc. " + _
                "It also provides extensive support for drawing text, giving the " + _
                "developer a large freedom in formatting and placing text on page. " + _
                "<font face='TimesRoman'>The library also offers more advanced features, like: automatic page " + _
                "numbering; page templates; creation of bookmarks tree; " + _
                "creation of hyperlinks; transition effects between pages; support " + _
                "for viewer preferences; support for document metadata, like author, " + _
                "title, etc, allowing the document to be searched and indexed; custom " + _
                "document properties; enhanced color support (RGB, CMYK, Grayscale); " + _
                "Adobe XMP metadata storage; user defined logical units; user defined " + _
                "coordinate system.</font><br/>" + _
                "The resulting pdf documents can be saved to disk or HTTP streams. " + _
                "The library compresses document's content, thus resulting smaller pdf files. " + _
                "The <font color='#0000F8'><b>PDF4NET</b></font> library can be used both from windows and <i>ASP.NET</i> applications. " + _
                "The library is 100% managed, being written in C#. " + _
                "The <font color='#0000F8'><b>PDF4NET</b></font> library is <u>licensed " + +
                "per developer</u> and can be " + "distributed <font color='#F80000'>royalty free</font>.<br/><br/>"

            longText = longText + longText + longText + longText + longText + longText + longText + longText + longText + longText + longText + longText

            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            Dim tfo As New PDFTextFormatOptions()
            tfo.Align = PDFTextAlign.TopJustified
            tfo.ClipText = PDFClipText.ClipWords

            ' length of text that fits in the column
            Dim columnTextLength As Integer

            Dim endOfText As Boolean = False
            Dim startIndex As Integer = 0
            ' start drawing text
            While Not endOfText
                ' where to start to print the column
                Dim leftOffset As Double = leftMargin

                ' Create a new page in the document
                Dim page As PDFPage = pdfDoc.AddPage()

                Dim i As Integer = 0
                ' draw each column
                ' each column will contain one random positioned image
                Dim rnd As New Random()
                While i < columnCount
                    ' index of the image to be displayed
                    Dim imageIndex As Integer = 1 + rnd.[Next](5)

                    ' set columnHeight for height, because we'll set KeepAspectRatio to
                    ' KeepWidth and the height will be automatically computed.
                    Dim img As New PDFImage("..\SupportFiles\auto" + imageIndex.ToString() + ".jpg")
                    Dim imageHeight As Double = img.Height * columnWidth / img.Width
                    ' compute a random top position for the image so it fits full
                    ' in the column
                    Dim imageTop As Double = 30 + (columnHeight - topMargin - bottomMargin - imageHeight) * rnd.NextDouble()

                    ' draw the image
                    page.Canvas.DrawImage(img, leftOffset, imageTop, columnWidth, imageHeight)

                    ' see how much text fits above the image
                    ' imageTop - topMargin = the height available above the image
                    columnTextLength = page.Canvas.FitHtmlText(longText, startIndex, font, columnWidth, imageTop - topMargin)

                    ' draw text above image
                    page.Canvas.DrawHTMLTextBox(longText, font, Nothing, blackBrush, leftOffset, topMargin, _
                        columnWidth, imageTop - topMargin, tfo, startIndex)

                    ' move the index to the next fragment
                    startIndex = startIndex + columnTextLength
                    If startIndex >= longText.Length Then
                        endOfText = True
                        Exit While
                    End If

                    ' see how much text fits below the image
                    ' columnHeight - ( topText - topMargin ) = available space below image
                    Dim topText As Double = Math.Ceiling((imageTop + imageHeight) / font.Size) * font.Size
                    columnTextLength = page.Canvas.FitHtmlText(longText, startIndex, font, columnWidth, columnHeight - (topText - topMargin))

                    ' draw text below image
                    page.Canvas.DrawHTMLTextBox(longText, font, Nothing, blackBrush, leftOffset, topText, _
                        columnWidth, columnHeight - (topText - topMargin), tfo, startIndex)

                    ' move the index to the next fragment
                    startIndex = startIndex + columnTextLength
                    If startIndex >= longText.Length Then
                        endOfText = True
                        Exit While
                    End If

                    ' compute the offset of the next column
                    leftOffset = leftOffset + columnWidth + columnSpace

                    i = i + 1
                End While
            End While

            ' Save the document to disk
            pdfDoc.Save("Sample_MultiColumnTextAndImages.pdf")
        End Sub
    End Class
End Namespace


Samples: PageOrientations

PDF4NET Send comments on this topic.
Samples: PageOrientations
PDF4NET On-line Help > Samples > Samples: PageOrientations

Glossary Item Box

This sample shows how the PDF4NET library allows to create documents with different orientations of their pages. It creates a document with 2 pages. The first page has Portrait orientation, while the second one has Landscape orientation.

C# Source code | VB.NET Source code | PDF file


PageOrientations.cs

PDF4NET Send comments on this topic.
PageOrientations.cs
PDF4NET On-line Help > Samples > PageOrientations > PageOrientations.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.PageOrientations
{
    /// <summary>
    /// This sample will show how to create a document with
    /// different pages orientations
    /// </summary>
    class PageOrientations
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 20);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());

            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            // Create first page
            PDFPage pdfPage1 = pdfDoc.AddPage();
            // No need to do this because Portrait is the default orientation
            pdfPage1.Orientation = PDFPageOrientation.Portrait;

            // Draw a label on first page
            pdfPage1.Canvas.DrawText("This page uses Portrait orientation.",
                fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft);

            // Create second page
            PDFPage pdfPage2 = pdfDoc.AddPage();
            // Set page's orientation to Landscape
            pdfPage2.Orientation = PDFPageOrientation.Landscape;

            // Draw a label on first page
            pdfPage2.Canvas.DrawText("This page uses Landscape orientation.",
                fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft);

            // Save the document to disk
            pdfDoc.Save("Sample_PageOrientations.pdf");
        }
    }
}


PageOrientations.vb

PDF4NET Send comments on this topic.
PageOrientations.vb
PDF4NET On-line Help > Samples > PageOrientations > PageOrientations.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.PageOrientations
    ''' <summary>
    ''' This sample will show how to create a document with
    ''' different pages orientations
    ''' </summary>
    Class PageOrientations
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 20)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())

            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            ' Create first page
            Dim pdfPage1 As PDFPage = pdfDoc.AddPage()
            ' No need to do this because Portrait is the default orientation
            pdfPage1.Orientation = PDFPageOrientation.Portrait

            ' Draw a label on first page
            pdfPage1.Canvas.DrawText("This page uses Portrait orientation.", fontText, Nothing, blackBrush, 20, 20, _
                0, PDFTextAlign.TopLeft)

            ' Create second page
            Dim pdfPage2 As PDFPage = pdfDoc.AddPage()
            ' Set page's orientation to Landscape
            pdfPage2.Orientation = PDFPageOrientation.Landscape

            ' Draw a label on first page
            pdfPage2.Canvas.DrawText("This page uses Landscape orientation.", fontText, Nothing, blackBrush, 20, 20, _
                0, PDFTextAlign.TopLeft)

            ' Save the document to disk
            pdfDoc.Save("Sample_PageOrientations.pdf")
        End Sub
    End Class
End Namespace


Samples: PageSizes

PDF4NET Send comments on this topic.
Samples: PageSizes
PDF4NET On-line Help > Samples > Samples: PageSizes

Glossary Item Box

This sample shows how the PDF4NET library allows to create documents with pages of different sizes. It creates a document with 14 pages, each page has a different size.

C# Source code | VB.NET Source code | PDF file


PageSizes.cs

PDF4NET Send comments on this topic.
PageSizes.cs
PDF4NET On-line Help > Samples > PageSizes > PageSizes.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.PageSizes
{
    /// <summary>
    /// This sample will show how to create a document with different page sizes
    /// </summary>
    class PageSizes
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            PDFPageSize[] pageSizes = { PDFPageSize.A3, PDFPageSize.A4, PDFPageSize.A5, PDFPageSize.B4,
                                       PDFPageSize.B5, PDFPageSize.Executive, PDFPageSize.Folio,
                                       PDFPageSize.Ledger, PDFPageSize.Legal, PDFPageSize.Letter,
                                       PDFPageSize.Quarto, PDFPageSize.Size10x14,
                                       PDFPageSize.Statement, PDFPageSize.Tabloid };

            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 20);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());

            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            // Create the pages of the document, each one having a different size
            for (int i = 0; i < pageSizes.Length; i++)
            {
                // Create the page
                PDFPage pdfPage = pdfDoc.AddPage();
                // Set its size
                pdfPage.Size = pageSizes[i];
                // Draw a label on it
                pdfPage.Canvas.DrawText("This page has the following size: " + pageSizes[i].ToString(),
                    fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft);
            }

            // Save the document to disk
            pdfDoc.Save("Sample_PageSizes.pdf");
        }
    }
}


PageSizes.vb

PDF4NET Send comments on this topic.
PageSizes.vb
PDF4NET On-line Help > Samples > PageSizes > PageSizes.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.PageSizes
    ''' <summary>
    ''' This sample will show how to create a document with different page sizes
    ''' </summary>
    Class PageSizes
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            Dim pageSizes As PDFPageSize() = {PDFPageSize.A3, PDFPageSize.A4, PDFPageSize.A5, PDFPageSize.B4, PDFPageSize.B5, PDFPageSize.Executive, _
                PDFPageSize.Folio, PDFPageSize.Ledger, PDFPageSize.Legal, PDFPageSize.Letter, PDFPageSize.Quarto, PDFPageSize.Size10x14, _
                PDFPageSize.Statement, PDFPageSize.Tabloid}

            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 20)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())

            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            ' Create the pages of the document, each one having a different size
            Dim i As Integer = 0
            While i < pageSizes.Length
                ' Create the page
                Dim pdfPage As PDFPage = pdfDoc.AddPage()
                ' Set its size
                pdfPage.Size = pageSizes(i)
                ' Draw a label on it
                pdfPage.Canvas.DrawText("This page has the following size: " + pageSizes(i).ToString(), fontText, Nothing, blackBrush, 20, 20, _
                    0, PDFTextAlign.TopLeft)
                i = i + 1
            End While

            ' Save the document to disk
            pdfDoc.Save("Sample_PageSizes.pdf")
        End Sub
    End Class
End Namespace


Samples: Pantone colors

PDF4NET Send comments on this topic.
Samples: Pantone colors
PDF4NET On-line Help > Samples > Samples: Pantone colors

Glossary Item Box

This sample shows how to work with Pantone colors. These colors are specific instances of separation colors.

C# Source code | VB.NET Source code | PDF file


PantoneColors.cs

PDF4NET Send comments on this topic.
PantoneColors.cs
PDF4NET On-line Help > Samples > PantoneColors > PantoneColors.cs

Glossary Item Box

using System;
using System.IO;
using System.Text;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Functions;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.ColorSpaces;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET
{
    /// <summary>
    /// This sample shows how to work with various PANTONE colors when creating a PDF document.
    /// </summary>
    class PantoneColors
    {
        [STAThread]
        static void Main(string[] args)
        {
            PDFDocument doc = new PDFDocument();

            PDFPage page = doc.AddPage();
            DrawPantoneColors(page);

            doc.Save("Sample_PantoneColors.pdf");
            doc.Dispose();
        }

        /// <summary>
        /// Draws content on a page using PANTONE colors.
        /// </summary>
        /// <param name="page">The page to draw to.</param>
        private static void DrawPantoneColors(PDFPage page)
        {
            PDFRgbColor black = new PDFRgbColor(0, 0, 0);
            PDFBrush blackBrush = new PDFBrush(black);
            PDFFont font = new PDFFont(PDFFontFace.Helvetica, 16);

            page.Canvas.DrawText("Pantone colors", font, null, blackBrush, 50, 50);

            PDFPantoneColor orange = PDFPantoneColor.Orange021;
            orange.Tint = 0.9;
            PDFPantoneColor warmRed = PDFPantoneColor.WarmRed;
            warmRed.Tint = 0.4;

            PDFBrush orangeBrush = new PDFBrush(orange);
            PDFPen warmRedPen = new PDFPen(warmRed, 5);
            page.Canvas.DrawRoundRectangle(warmRedPen, orangeBrush, 50, 100, 400, 150, 20, 20);
        }
    }
}


PantoneColors.vb

PDF4NET Send comments on this topic.
PantoneColors.vb
PDF4NET On-line Help > Samples > PantoneColors > PantoneColors.vb

Glossary Item Box

Imports System
Imports System.IO
Imports System.Text
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Functions
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.ColorSpaces
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET
    ''' <summary>
    ''' This sample shows how to work with various PANTONE colors when creating a PDF document.
    ''' </summary>
    Class PantoneColors
        <STAThread> _
        Shared Sub Main(args As String())
            Dim doc As New PDFDocument()

            Dim page As PDFPage = doc.AddPage()
            DrawPantoneColors(page)

            doc.Save("Sample_PantoneColors.pdf")
            doc.Dispose()
        End Sub

        ''' <summary>
        ''' Draws content on a page using PANTONE colors.
        ''' </summary>
        ''' <param name="page">The page to draw to.</param>
        Private Shared Sub DrawPantoneColors(page As PDFPage)
            Dim black As New PDFRgbColor(0, 0, 0)
            Dim blackBrush As New PDFBrush(black)
            Dim font As New PDFFont(PDFFontFace.Helvetica, 16)

            page.Canvas.DrawText("Pantone colors", font, Nothing, blackBrush, 50, 50)

            Dim orange As PDFPantoneColor = PDFPantoneColor.Orange021
            orange.Tint = 0.9
            Dim warmRed As PDFPantoneColor = PDFPantoneColor.WarmRed
            warmRed.Tint = 0.4

            Dim orangeBrush As New PDFBrush(orange)
            Dim warmRedPen As New PDFPen(warmRed, 5)
            page.Canvas.DrawRoundRectangle(warmRedPen, orangeBrush, 50, 100, 400, 150, _
                20, 20)
        End Sub
    End Class
End Namespace


Samples: Paths

PDF4NET Send comments on this topic.
Samples: Paths
PDF4NET On-line Help > Samples > Samples: Paths

Glossary Item Box

This sample demonstrates the support for free form paths implemented in PDF4NET library. A path can be constructed from several drawing primitives and it can be stroked and/or filled.

C# Source code | VB.NET Source code | PDF file


Paths.cs

PDF4NET Send comments on this topic.
Paths.cs
PDF4NET On-line Help > Samples > Paths > Paths.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;

namespace O2S.Samples.PDF4NET.Paths
{
    /// <summary>
    /// This sample shows how to use free form graphics paths with PDF4NET.
    /// </summary>
    class Paths
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument doc = new PDFDocument();

            // Create one page
            PDFPage page = doc.AddPage();

            PDFPen redPen = new PDFPen(new PDFRgbColor(255, 0, 0), 1);
            PDFBrush darkBlueBrush = new PDFBrush(new PDFRgbColor(0, 0, 128));
            // a star
            PDFPoint[] points = new PDFPoint[]{ new PDFPoint( 50, 200 ), new PDFPoint( 500, 200 ),
                new PDFPoint( 200, 400 ), new PDFPoint( 275, 50 ), new PDFPoint( 350, 400 ) };

            // create a graphic path
            PDFPath path = new PDFPath();
            path.MoveTo(50, 200);
            path.Polygon(points);

            path.MoveTo(50, 450);
            path.LineTo(600, 450);
            path.BezierTo(600, 500, 500, 500, 500, 600);
            path.BezierTo(400, 600, 300, 550, 600, 500);
            path.CloseSubpath();

            // draw the path on the page
            page.Canvas.DrawPath(redPen, darkBlueBrush, path, PDFFillMode.EvenOdd);

            // Save the document to disk
            doc.Save("Sample_Paths.pdf");
        }
    }
}


Paths.vb

PDF4NET Send comments on this topic.
Paths.vb
PDF4NET On-line Help > Samples > Paths > Paths.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes

Namespace O2S.Samples.PDF4NET.Paths
    ''' <summary>
    ''' This sample shows how to use free form graphics paths with PDF4NET.
    ''' </summary>
    Class Paths
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim doc As New PDFDocument()

            ' Create one page
            Dim page As PDFPage = doc.AddPage()

            Dim redPen As New PDFPen(New PDFRgbColor(255, 0, 0), 1)
            Dim darkBlueBrush As New PDFBrush(New PDFRgbColor(0, 0, 128))
            ' a star
            Dim points As PDFPoint() = New PDFPoint() {New PDFPoint(50, 200), New PDFPoint(500, 200), New PDFPoint(200, 400), New PDFPoint(275, 50), New PDFPoint(350, 400)}

            ' create a graphic path
            Dim path As New PDFPath()
            path.MoveTo(50, 200)
            path.Polygon(points)

            path.MoveTo(50, 450)
            path.LineTo(600, 450)
            path.BezierTo(600, 500, 500, 500, 500, 600)
            path.BezierTo(400, 600, 300, 550, 600, 500)
            path.CloseSubpath()

            ' draw the path on the page
            page.Canvas.DrawPath(redPen, darkBlueBrush, path, PDFFillMode.EvenOdd)

            ' Save the document to disk
            doc.Save("Sample_Paths.pdf")
        End Sub
    End Class
End Namespace


Samples: Polygons

PDF4NET Send comments on this topic.
Samples: Polygons
PDF4NET On-line Help > Samples > Samples: Polygons

Glossary Item Box

This sample shows the polygons drawing capabilities. On the first page it draws a few geometric figures. Second page demonstrates poly-polygon drawing capabilities. For poly-polygons the filling mode can be set.

C# Source code | VB.NET Source code | PDF file


Polygons.cs

PDF4NET Send comments on this topic.
Polygons.cs
PDF4NET On-line Help > Samples > Polygons > Polygons.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.Polygons
{
    /// <summary>
    /// This sample will show how to draw various polygons and polypolygons on the page.
    /// </summary>
    class Polygons
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            // Create first page
            PDFPage pdfPage1 = pdfDoc.AddPage();

            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());
            PDFBrush orangeBrush = new PDFBrush(new PDFRgbColor(Color.Orange));
            PDFPen pen = new PDFPen(new PDFRgbColor(Color.GreenYellow), 1);

            // Draw a pentagon
            PDFPoint[] pentagon = { new PDFPoint( 150, 35 ), new PDFPoint( 250, 125 ), new PDFPoint( 200, 215 ),
                                      new PDFPoint( 100, 215 ), new PDFPoint( 50, 125 ) };
            pdfPage1.Canvas.DrawText("This is a pentagon",
                fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft);
            pdfPage1.Canvas.DrawPolygon(pen, orangeBrush, pentagon);

            // Draw a hexagon
            PDFPoint[] hexagon = { new PDFPoint( 450, 35 ), new PDFPoint( 550, 135 ), new PDFPoint( 550, 235 ),
                                     new PDFPoint( 450, 335 ), new PDFPoint( 350, 235 ), new PDFPoint( 350, 135 ) };
            pdfPage1.Canvas.DrawText("This is a hexagon",
                fontText, null, blackBrush, 300, 20, 0, PDFTextAlign.TopLeft);
            pdfPage1.Canvas.DrawPolygon(pen, orangeBrush, hexagon);

            // Draw an arrow
            PDFPoint[] arrow = { new PDFPoint( 20, 350 ), new PDFPoint( 220, 350 ), new PDFPoint( 220, 300 ),
                                   new PDFPoint( 320, 400 ), new PDFPoint( 220, 500 ), new PDFPoint( 220, 450 ),
                                   new PDFPoint( 20, 450 ) };
            pdfPage1.Canvas.DrawText("This is an arrow",
                fontText, null, blackBrush, 20, 300, 0, PDFTextAlign.TopLeft);
            pdfPage1.Canvas.DrawPolygon(pen, null, arrow);

            // Draw a rectangular callout
            PDFPoint[] callout = { new PDFPoint( 350, 350 ), new PDFPoint( 550, 350 ), new PDFPoint( 550, 450 ),
                                     new PDFPoint( 480, 450 ), new PDFPoint( 350, 550 ), new PDFPoint( 420, 450 ),
                                     new PDFPoint( 350, 450 ) };
            pdfPage1.Canvas.DrawText("This is a rectangular callout",
                fontText, null, blackBrush, 370, 400, 0, PDFTextAlign.TopLeft);
            pdfPage1.Canvas.DrawPolygon(pen, null, callout);

            // Create second page
            PDFPage pdfPage2 = pdfDoc.AddPage();

            // a star
            PDFPoint[] points = new PDFPoint[]{ new PDFPoint( 50, 200 ), new PDFPoint( 500, 200 ),
                                                  new PDFPoint( 150, 500 ), new PDFPoint( 275, 50 ), new PDFPoint( 400, 500 ) };
            pdfPage2.Canvas.DrawPolygon(pen, orangeBrush, points, PDFFillMode.EvenOdd);

            // Create third page
            PDFPage pdfPage3 = pdfDoc.AddPage();

            // a polypolygon
            PDFPoint[][] polygons = new PDFPoint[4][];
            polygons[0] = new PDFPoint[]{ new PDFPoint( 50, 100 ), new PDFPoint( 550, 100 ),
                                            new PDFPoint( 550, 600 ), new PDFPoint( 50, 600 ) };
            polygons[1] = new PDFPoint[]{ new PDFPoint( 100, 150 ), new PDFPoint( 500, 150 ),
                                            new PDFPoint( 500, 550 ), new PDFPoint( 100, 550 ) };
            polygons[2] = new PDFPoint[]{ new PDFPoint( 150, 200 ), new PDFPoint( 450, 200 ),
                                            new PDFPoint( 450, 500 ), new PDFPoint( 150, 500 ) };
            polygons[3] = new PDFPoint[]{ new PDFPoint( 200, 250 ), new PDFPoint( 400, 250 ),
                                            new PDFPoint( 400, 450 ), new PDFPoint( 200, 450 ) };
            pdfPage3.Canvas.DrawPolyPolygon(pen, orangeBrush, polygons, PDFFillMode.EvenOdd);

            // Save the document to disk
            pdfDoc.Save("Sample_Polygons.pdf");
        }
    }
}


Polygons.vb

PDF4NET Send comments on this topic.
Polygons.vb
PDF4NET On-line Help > Samples > Polygons > Polygons.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.Polygons
    ''' <summary>
    ''' This sample will show how to draw various polygons and polypolygons on the page.
    ''' </summary>
    Class Polygons
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            ' Create first page
            Dim pdfPage1 As PDFPage = pdfDoc.AddPage()

            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())
            Dim orangeBrush As New PDFBrush(New PDFRgbColor(Color.Orange))
            Dim pen As New PDFPen(New PDFRgbColor(Color.GreenYellow), 1)

            ' Draw a pentagon
            Dim pentagon As PDFPoint() = {New PDFPoint(150, 35), New PDFPoint(250, 125), New PDFPoint(200, 215), New PDFPoint(100, 215), New PDFPoint(50, 125)}
            pdfPage1.Canvas.DrawText("This is a pentagon", fontText, Nothing, blackBrush, 20, 20, _
                0, PDFTextAlign.TopLeft)
            pdfPage1.Canvas.DrawPolygon(pen, orangeBrush, pentagon)

            ' Draw a hexagon
            Dim hexagon As PDFPoint() = {New PDFPoint(450, 35), New PDFPoint(550, 135), New PDFPoint(550, 235), New PDFPoint(450, 335), New PDFPoint(350, 235), New PDFPoint(350, 135)}
            pdfPage1.Canvas.DrawText("This is a hexagon", fontText, Nothing, blackBrush, 300, 20, _
                0, PDFTextAlign.TopLeft)
            pdfPage1.Canvas.DrawPolygon(pen, orangeBrush, hexagon)

            ' Draw an arrow
            Dim arrow As PDFPoint() = {New PDFPoint(20, 350), New PDFPoint(220, 350), New PDFPoint(220, 300), New PDFPoint(320, 400), New PDFPoint(220, 500), New PDFPoint(220, 450), _
                New PDFPoint(20, 450)}
            pdfPage1.Canvas.DrawText("This is an arrow", fontText, Nothing, blackBrush, 20, 300, _
                0, PDFTextAlign.TopLeft)
            pdfPage1.Canvas.DrawPolygon(pen, Nothing, arrow)

            ' Draw a rectangular callout
            Dim callout As PDFPoint() = {New PDFPoint(350, 350), New PDFPoint(550, 350), New PDFPoint(550, 450), New PDFPoint(480, 450), New PDFPoint(350, 550), New PDFPoint(420, 450), _
                New PDFPoint(350, 450)}
            pdfPage1.Canvas.DrawText("This is a rectangular callout", fontText, Nothing, blackBrush, 370, 400, _
                0, PDFTextAlign.TopLeft)
            pdfPage1.Canvas.DrawPolygon(pen, Nothing, callout)

            ' Create second page
            Dim pdfPage2 As PDFPage = pdfDoc.AddPage()

            ' a star
            Dim points As PDFPoint() = New PDFPoint() {New PDFPoint(50, 200), New PDFPoint(500, 200), New PDFPoint(150, 500), New PDFPoint(275, 50), New PDFPoint(400, 500)}
            pdfPage2.Canvas.DrawPolygon(pen, orangeBrush, points, PDFFillMode.EvenOdd)

            ' Create third page
            Dim pdfPage3 As PDFPage = pdfDoc.AddPage()

            ' a polypolygon
            Dim polygons As PDFPoint()() = New PDFPoint(3)() {}
            polygons(0) = New PDFPoint() {New PDFPoint(50, 100), New PDFPoint(550, 100), New PDFPoint(550, 600), New PDFPoint(50, 600)}
            polygons(1) = New PDFPoint() {New PDFPoint(100, 150), New PDFPoint(500, 150), New PDFPoint(500, 550), New PDFPoint(100, 550)}
            polygons(2) = New PDFPoint() {New PDFPoint(150, 200), New PDFPoint(450, 200), New PDFPoint(450, 500), New PDFPoint(150, 500)}
            polygons(3) = New PDFPoint() {New PDFPoint(200, 250), New PDFPoint(400, 250), New PDFPoint(400, 450), New PDFPoint(200, 450)}
            pdfPage3.Canvas.DrawPolyPolygon(pen, orangeBrush, polygons, PDFFillMode.EvenOdd)

            ' Save the document to disk
            pdfDoc.Save("Sample_Polygons.pdf")
        End Sub
    End Class
End Namespace


Samples: Rectangles

PDF4NET Send comments on this topic.
Samples: Rectangles
PDF4NET On-line Help > Samples > Samples: Rectangles

Glossary Item Box

This samples shows the rectangles drawing capabilities of the PDF4NET library. On the first page, it draws a rectangle by painting its border, a rectangle by filling its interior, and a rectangle by painting its border and filling its interior. It also show how to draw a rotated rectangle. On the second page it draws 50 rectangles at random locations on the page. The color of the rectangles is generated randomly.

C# Source code | VB.NET Source code | PDF file


Rectangles.cs

PDF4NET Send comments on this topic.
Rectangles.cs
PDF4NET On-line Help > Samples > Rectangles > Rectangles.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.Rectangles
{
    /// <summary>
    /// This sample will show how to draw various rectangles
    /// on the page.
    /// </summary>
    class Rectangles
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            // Create first page
            PDFPage pdfPage1 = pdfDoc.AddPage();

            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());
            PDFBrush redBrush = new PDFBrush(new PDFRgbColor(255, 0, 0));
            PDFPen pen = new PDFPen(new PDFRgbColor(0, 0, 255), 1);

            // Draw a rectangle that has a border
            pdfPage1.Canvas.DrawText("This rectangle is drawn by drawing its border",
                fontText, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft);
            pdfPage1.Canvas.DrawRectangle(pen, null, 20, 35, 200, 100, 0);

            // Draw a rectangle that has no border and its interior is filled
            pdfPage1.Canvas.DrawText("This rectangle is drawn by filling its interior",
                fontText, null, blackBrush, 300, 20, 0, PDFTextAlign.TopLeft);
            pdfPage1.Canvas.DrawRectangle(null, redBrush, 300, 35, 300, 150, 0);

            // Draw a rectangle that has a border and its interior is filled
            pdfPage1.Canvas.DrawText("This rectangle has a border and a filled interior",
                fontText, null, blackBrush, 20, 200, 0, PDFTextAlign.TopLeft);
            pdfPage1.Canvas.DrawRectangle(pen, redBrush, 20, 215, 200, 150, 0);

            // Draw a rotated rectangle
            pdfPage1.Canvas.DrawText("This rectangle is rotated with 30 degrees around the top left corner",
                fontText, null, blackBrush, 20, 400, 0, PDFTextAlign.TopLeft);
            pdfPage1.Canvas.DrawRectangle(pen, redBrush, 20, 550, 200, 150, 30);
            pdfPage1.Canvas.DrawRectangle(pen, redBrush, 20, 550, 200, 150, 0);

            // Create the second page
            PDFPage pdfPage2 = pdfDoc.AddPage();

            Random rnd = new Random();
            for (int i = 0; i < 50; i++)
            {
                // Create random colors for the border and the interior
                PDFColor brushColor = new PDFRgbColor((byte)rnd.Next(256),
                    (byte)rnd.Next(256), (byte)rnd.Next(256));
                PDFColor penColor = new PDFRgbColor((byte)rnd.Next(256),
                    (byte)rnd.Next(256), (byte)rnd.Next(256));

                // Create the brush to fill the interior
                PDFBrush randomBrush = new PDFBrush(brushColor);
                // Create the pen to draw the border
                PDFPen randomPen = new PDFPen(penColor, 1);

                // Generate random positions
                float left = rnd.Next((int)pdfPage2.Width);
                float top = rnd.Next((int)pdfPage2.Height);

                // Generate random sizes
                float width = rnd.Next((int)(pdfPage2.Width - left)); // try to keep the rectangle
                float height = rnd.Next((int)(pdfPage2.Height - top));   // within the page

                // Generate random orientation
                float orientation = rnd.Next(360);

                // Draw the rectangle
                pdfPage2.Canvas.DrawRectangle(randomPen, randomBrush,
                    left, top, width, height, orientation);
            }

            // Draw a label
            pdfPage2.Canvas.DrawText("Random rectangles",
                fontText, null, blackBrush, 20, 350, 0, PDFTextAlign.TopLeft);

            // Save the document to disk
            pdfDoc.Save("Sample_Rectangles.pdf");
        }
    }
}


Rectangles.vb

PDF4NET Send comments on this topic.
Rectangles.vb
PDF4NET On-line Help > Samples > Rectangles > Rectangles.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.Rectangles
    ''' <summary>
    ''' This sample will show how to draw various rectangles
    ''' on the page.
    ''' </summary>
    Class Rectangles
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            ' Create first page
            Dim pdfPage1 As PDFPage = pdfDoc.AddPage()

            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())
            Dim redBrush As New PDFBrush(New PDFRgbColor(255, 0, 0))
            Dim pen As New PDFPen(New PDFRgbColor(0, 0, 255), 1)

            ' Draw a rectangle that has a border
            pdfPage1.Canvas.DrawText("This rectangle is drawn by drawing its border", fontText, Nothing, blackBrush, 20, 20, _
                0, PDFTextAlign.TopLeft)
            pdfPage1.Canvas.DrawRectangle(pen, Nothing, 20, 35, 200, 100, _
                0)

            ' Draw a rectangle that has no border and its interior is filled
            pdfPage1.Canvas.DrawText("This rectangle is drawn by filling its interior", fontText, Nothing, blackBrush, 300, 20, _
                0, PDFTextAlign.TopLeft)
            pdfPage1.Canvas.DrawRectangle(Nothing, redBrush, 300, 35, 300, 150, _
                0)

            ' Draw a rectangle that has a border and its interior is filled
            pdfPage1.Canvas.DrawText("This rectangle has a border and a filled interior", fontText, Nothing, blackBrush, 20, 200, _
                0, PDFTextAlign.TopLeft)
            pdfPage1.Canvas.DrawRectangle(pen, redBrush, 20, 215, 200, 150, _
                0)

            ' Draw a rotated rectangle
            pdfPage1.Canvas.DrawText("This rectangle is rotated with 30 degrees around the top left corner", fontText, Nothing, blackBrush, 20, 400, _
                0, PDFTextAlign.TopLeft)
            pdfPage1.Canvas.DrawRectangle(pen, redBrush, 20, 550, 200, 150, _
                30)
            pdfPage1.Canvas.DrawRectangle(pen, redBrush, 20, 550, 200, 150, _
                0)

            ' Create the second page
            Dim pdfPage2 As PDFPage = pdfDoc.AddPage()

            Dim rnd As New Random()
            Dim i As Integer = 0
            While i < 50
                ' Create random colors for the border and the interior
                Dim brushColor As PDFColor = New PDFRgbColor(rnd.Next(256), rnd.Next(256), rnd.Next(256))
                Dim penColor As PDFColor = New PDFRgbColor(rnd.Next(256), rnd.Next(256), rnd.Next(256))

                ' Create the brush to fill the interior
                Dim randomBrush As New PDFBrush(brushColor)
                ' Create the pen to draw the border
                Dim randomPen As New PDFPen(penColor, 1)

                ' Generate random positions
                Dim left As Double = rnd.NextDouble() * pdfPage2.Width
                Dim top As Double = rnd.NextDouble() * pdfPage2.Height

                ' Generate random sizes
                Dim width As Double = rnd.NextDouble() * (pdfPage2.Width - left)
                ' try to keep the rectangle
                Dim height As Double = rnd.NextDouble() * (pdfPage2.Height - top)
                ' within the page
                ' Generate random orientation
                Dim orientation As Double = rnd.Next(360)

                ' Draw the rectangle
                pdfPage2.Canvas.DrawRectangle(randomPen, randomBrush, left, top, width, height, _
                    orientation)
                i = i + 1
            End While

            ' Draw a label
            pdfPage2.Canvas.DrawText("Random rectangles", fontText, Nothing, blackBrush, 20, 350, _
                0, PDFTextAlign.TopLeft)

            ' Save the document to disk
            pdfDoc.Save("Sample_Rectangles.pdf")
        End Sub
    End Class
End Namespace


Samples: SimpleGrid

PDF4NET Send comments on this topic.
Samples: SimpleGrid
PDF4NET On-line Help > Samples > Samples: SimpleGrid

Glossary Item Box

This samples shows how to draw a simple report. The content of the report is loaded from an XML file.
This sample uses authors.xml file found in \supportfiles folder.

C# Source code | VB.NET Source code | PDF file


SimpleGrid.cs

PDF4NET Send comments on this topic.
SimpleGrid.cs
PDF4NET On-line Help > Samples > SimpleGrid > SimpleGrid.cs

Glossary Item Box

using System;
using System.Drawing;
using System.Data;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.SimpleGrid
{
    /// <summary>
    /// This sample will show how to draw a simple report
    /// using content from a database/xml file.
    /// </summary>
    class SimpleGrid
    {
        private static float leftMargin = 15;
        private static float rightMargin = 15;
        private static float topMargin = 20;
        private static float minBottomMargin = 20;
        private static float rowHeight = 30;
        private static float headerHeight = 30;
        private static float firstPageTopOffset = 50;
        private static float[] columnsWidth = { 80, 100, 100, 90, 212, 90, 40, 50 };
        private static string[] columnsHeader = { "Author ID", "First name", "Last name", "Phone",
                                                    "Address", "City", "State", "ZIP" };

        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the graphic objects
            PDFFont fontTitle = new PDFFont(PDFFontFace.Helvetica, 20);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());

            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();
            // Set the document to be Landscape oriented
            pdfDoc.PageOrientation = PDFPageOrientation.Landscape;

            // Create first page of the report
            PDFPage page = pdfDoc.AddPage();

            // Draw the title of the report
            page.Canvas.DrawText("Authors", fontTitle, null, blackBrush,
                page.Width / 2, 15, 0, PDFTextAlign.TopCenter);

            // Draw report header
            DrawReportHeader(page, firstPageTopOffset);

            // Create the dataset
            DataSet ds = new DataSet();

            // Load the dataset
            ds.ReadXml("..\\SupportFiles\\authors.xml", XmlReadMode.ReadSchema);

            // Get the table from the dataset
            DataTable authors = ds.Tables[0];

            // rowOffset - specifies the vertical position where a row
            // should begin to be printed
            float rowOffset = firstPageTopOffset + headerHeight;
            for (int i = 0; i < authors.Rows.Count; i++)
            {
                if (rowOffset + rowHeight > page.Height - minBottomMargin)
                { // not enough space to draw a new row, then create a new page,
                    // draw the header, then draw the rows.
                    page = pdfDoc.AddPage();
                    DrawReportHeader(page, topMargin);
                    rowOffset = topMargin + headerHeight;
                }
                DrawReportRow(page, rowOffset, authors.Rows[i]);
                rowOffset = rowOffset + rowHeight;
            }

            // Save the document to disk
            pdfDoc.Save("Sample_SimpleGrid.pdf");
        }

        private static void DrawReportHeader(PDFPage pdfPage, float topOffset)
        {
            // Create the graphic objects
            PDFFont fontHeader = new PDFFont(PDFFontFace.Helvetica, 12);
            fontHeader.Bold = true;
            PDFPen borderColor = new PDFPen(new PDFRgbColor(), 1);
            PDFBrush textColor = new PDFBrush(new PDFRgbColor());
            PDFBrush headerFill = new PDFBrush(new PDFRgbColor(192, 192, 192));

            // Draw the header
            pdfPage.Canvas.DrawRectangle(borderColor, headerFill, leftMargin, topOffset,
                pdfPage.Width - leftMargin - rightMargin, headerHeight);

            int i;
            float xOffset = leftMargin;
            // Draw the columns separators
            for (i = 0; i < columnsWidth.Length - 1; i++)
            {
                xOffset = xOffset + columnsWidth[i];
                pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset,
                    xOffset, topOffset + headerHeight);
            }

            xOffset = leftMargin;
            // Draw the columns header
            for (i = 0; i < columnsWidth.Length; i++)
            {
                pdfPage.Canvas.DrawText(columnsHeader[i], fontHeader, null, textColor,
                    xOffset + columnsWidth[i] / 2, topOffset + headerHeight / 2, 0, PDFTextAlign.MiddleCenter);
                xOffset = xOffset + columnsWidth[i];
            }
        }

        private static void DrawReportRow(PDFPage pdfPage, float topOffset, DataRow row)
        {
            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFPen borderColor = new PDFPen(new PDFRgbColor(), 1);
            PDFBrush textColor = new PDFBrush(new PDFRgbColor());
            PDFBrush headerFill = new PDFBrush(new PDFRgbColor(192, 192, 192));

            // Draw rows borders
            PDFPoint[] points = { new PDFPoint( leftMargin, topOffset ),
                                  new PDFPoint( leftMargin, topOffset + rowHeight),
                                  new PDFPoint( pdfPage.Width - rightMargin, topOffset + rowHeight ),
                                  new PDFPoint( pdfPage.Width - rightMargin, topOffset )};
            pdfPage.Canvas.DrawLines(borderColor, points);

            int i;
            float xOffset = leftMargin;
            // Draw the columns separators
            for (i = 0; i < columnsWidth.Length - 1; i++)
            {
                xOffset = xOffset + columnsWidth[i];
                pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset,
                    xOffset, topOffset + rowHeight);
            }

            xOffset = leftMargin;
            // Draw the columns header
            for (i = 0; i < columnsWidth.Length; i++)
            {
                pdfPage.Canvas.DrawText((string)row[i], fontText, null, textColor,
                    xOffset + 2, topOffset + rowHeight / 2, 0, PDFTextAlign.MiddleLeft);
                xOffset = xOffset + columnsWidth[i];
            }

        }
    }
}


SimpleGrid.vb

PDF4NET Send comments on this topic.
SimpleGrid.vb
PDF4NET On-line Help > Samples > SimpleGrid > SimpleGrid.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports System.Data
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.SimpleGrid
    ''' <summary>
    ''' This sample will show how to draw a simple report
    ''' using content from a database/xml file.
    ''' </summary>
    Class SimpleGrid
        Private Shared leftMargin As Single = 15
        Private Shared rightMargin As Single = 15
        Private Shared topMargin As Single = 20
        Private Shared minBottomMargin As Single = 20
        Private Shared rowHeight As Single = 30
        Private Shared headerHeight As Single = 30
        Private Shared firstPageTopOffset As Single = 50
        Private Shared columnsWidth As Single() = {80, 100, 100, 90, 212, 90, _
            40, 50}
        Private Shared columnsHeader As String() = {"Author ID", "First name", "Last name", "Phone", "Address", "City", _
            "State", "ZIP"}

        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the graphic objects
            Dim fontTitle As New PDFFont(PDFFontFace.Helvetica, 20)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())

            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()
            ' Set the document to be Landscape oriented
            pdfDoc.PageOrientation = PDFPageOrientation.Landscape

            ' Create first page of the report
            Dim page As PDFPage = pdfDoc.AddPage()

            ' Draw the title of the report
            page.Canvas.DrawText("Authors", fontTitle, Nothing, blackBrush, page.Width / 2, 15, _
                0, PDFTextAlign.TopCenter)

            ' Draw report header
            DrawReportHeader(page, firstPageTopOffset)

            ' Create the dataset
            Dim ds As New DataSet()

            ' Load the dataset
            ds.ReadXml("..\SupportFiles\authors.xml", XmlReadMode.ReadSchema)

            ' Get the table from the dataset
            Dim authors As DataTable = ds.Tables(0)

            ' rowOffset - specifies the vertical position where a row
            ' should begin to be printed
            Dim rowOffset As Single = firstPageTopOffset + headerHeight
            Dim i As Integer = 0
            While i < authors.Rows.Count
                If rowOffset + rowHeight > page.Height - minBottomMargin Then
                    ' not enough space to draw a new row, then create a new page,
                    ' draw the header, then draw the rows.
                    page = pdfDoc.AddPage()
                    DrawReportHeader(page, topMargin)
                    rowOffset = topMargin + headerHeight
                End If
                DrawReportRow(page, rowOffset, authors.Rows(i))
                rowOffset = rowOffset + rowHeight
                i = i + 1
            End While

            ' Save the document to disk
            pdfDoc.Save("Sample_SimpleGrid.pdf")
        End Sub

        Private Shared Sub DrawReportHeader(pdfPage As PDFPage, topOffset As Single)
            ' Create the graphic objects
            Dim fontHeader As New PDFFont(PDFFontFace.Helvetica, 12)
            fontHeader.Bold = True
            Dim borderColor As New PDFPen(New PDFRgbColor(), 1)
            Dim textColor As New PDFBrush(New PDFRgbColor())
            Dim headerFill As New PDFBrush(New PDFRgbColor(192, 192, 192))

            ' Draw the header
            pdfPage.Canvas.DrawRectangle(borderColor, headerFill, leftMargin, topOffset, pdfPage.Width - leftMargin - rightMargin, headerHeight)

            Dim i As Integer
            Dim xOffset As Single = leftMargin
            ' Draw the columns separators
            i = 0
            While i < columnsWidth.Length - 1
                xOffset = xOffset + columnsWidth(i)
                pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset, xOffset, topOffset + headerHeight)
                i = i + 1
            End While

            xOffset = leftMargin
            ' Draw the columns header
            i = 0
            While i < columnsWidth.Length
                pdfPage.Canvas.DrawText(columnsHeader(i), fontHeader, Nothing, textColor, xOffset + columnsWidth(i) / 2, topOffset + headerHeight / 2, _
                    0, PDFTextAlign.MiddleCenter)
                xOffset = xOffset + columnsWidth(i)
                i = i + 1
            End While
        End Sub

        Private Shared Sub DrawReportRow(pdfPage As PDFPage, topOffset As Single, row As DataRow)
            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim borderColor As New PDFPen(New PDFRgbColor(), 1)
            Dim textColor As New PDFBrush(New PDFRgbColor())
            Dim headerFill As New PDFBrush(New PDFRgbColor(192, 192, 192))

            ' Draw rows borders
            Dim points As PDFPoint() = {New PDFPoint(leftMargin, topOffset), New PDFPoint(leftMargin, topOffset + rowHeight), New PDFPoint(pdfPage.Width - rightMargin, topOffset + rowHeight), New PDFPoint(pdfPage.Width - rightMargin, topOffset)}
            pdfPage.Canvas.DrawLines(borderColor, points)

            Dim i As Integer
            Dim xOffset As Single = leftMargin
            ' Draw the columns separators
            i = 0
            While i < columnsWidth.Length - 1
                xOffset = xOffset + columnsWidth(i)
                pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset, xOffset, topOffset + rowHeight)
                i = i + 1
            End While

            xOffset = leftMargin
            ' Draw the columns header
            i = 0
            While i < columnsWidth.Length
                pdfPage.Canvas.DrawText(DirectCast(row(i), String), fontText, Nothing, textColor, xOffset + 2, topOffset + rowHeight / 2, _
                    0, PDFTextAlign.MiddleLeft)
                xOffset = xOffset + columnsWidth(i)
                i = i + 1
            End While

        End Sub
    End Class
End Namespace


Samples: Sin(x) Graph

PDF4NET Send comments on this topic.
Samples: Sin(x) Graph
PDF4NET On-line Help > Samples > Samples: Sin(x) Graph

Glossary Item Box

This sample shows how to use user defined logical units, define them and change the current logical unit during the drawing process. It will also show how to move the coordinate system in order to better fit the drawing needs. The sample will draw the graph of Sin(x) function, using 3 different user defined logical units. These 3 units will be equal on X axis, but they will be different on Y axis.

C# Source code | VB.NET Source code | PDF file


Sinus.cs

PDF4NET Send comments on this topic.
Sinus.cs
PDF4NET On-line Help > Samples > Sin(x) Graph > Sinus.cs

Glossary Item Box

using System;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.Sinus
{
    /// <summary>
    /// This sample shows how to use user defined logical units,
    /// define them and change the current logical unit
    /// during the drawing process. It will also show how to move
    /// the coordinate system in order to better fit the drawing needs.
    /// The sample will draw the graph of Sin(x) function, using 3
    /// different user defined logical units. These 3 units will be
    /// equal on X axis, but they will be different on Y axis.
    /// </summary>
    class Sinus
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            PDFPen redPen = new PDFPen(new PDFRgbColor(255, 0, 0), 1);
            PDFPen bluePen = new PDFPen(new PDFRgbColor(0, 0, 192), 1);
            PDFPen greenPen = new PDFPen(new PDFRgbColor(0, 192, 0), 1);

            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            // Create first page of the document
            PDFPage page = pdfDoc.AddPage();

            // Setup Graph (draw axes, draw labels)
            SetupGraph(page);

            // Create a new logical unit
            CustomUnit1 un1 = new CustomUnit1();

            DrawGraph(page, un1, redPen);

            // Create a new logical unit
            CustomUnit2 un2 = new CustomUnit2();

            DrawGraph(page, un2, bluePen);

            // Create an inch logical unit
            PDFInchLogicalUnit inch = new PDFInchLogicalUnit();

            DrawGraph(page, inch, greenPen);

            // Save the document to disk
            pdfDoc.Save("Sample_Sinus.pdf");
        }

        public static void SetupGraph(PDFPage page)
        {
            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 10);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());
            PDFPen blackPen = new PDFPen(new PDFRgbColor(), 1);

            page.Canvas.DrawText("Sin(x) graph", fontText, null, blackBrush, 50, 50);
            PDFTextFormatOptions tfo = new PDFTextFormatOptions();
            tfo.LineSpacing = 2;
            tfo.ClipText = PDFClipText.ClipNone;
            page.Canvas.DrawTextBox("All 3 graphs are drawn at the same logical " +
                "position on the page. The difference between them is the logical " +
                "unit that has been used for drawing each graph. Each logical unit " +
                "performed a different mapping between the logical position and the " +
                "physical position on the page.", fontText, null, blackBrush, 50, 70, 250, 0, tfo);

            // Move the origin of the coordinate system to the
            // center of the page
            page.Canvas.SetOrigin(page.Width / 2, page.Height / 2);

            // Draw the axes of the coordinate system
            // Draw the Y axis. Adjust 50 pixels to have
            // some space between the end of the axis and
            // the page margin.
            page.Canvas.DrawLine(blackPen, 0, -(page.Height / 2 - 50), 0, page.Height / 2 - 50);
            // Draw the X axis.
            page.Canvas.DrawLine(blackPen, -(page.Width / 2 - 50), 0, page.Width / 2 - 50, 0);

            page.Canvas.DrawText("0", fontText, null, blackBrush, 1, 1);
            page.Canvas.DrawText("x", fontText, null, blackBrush, page.Width / 2 - 55, 1);
            page.Canvas.DrawText("y", fontText, null, blackBrush, 1, -page.Height / 2 + 50);

            // Set the direction of Y axis to BottomToTop
            // and leave the X axis unchanged
            page.Canvas.SetAxesDirection(PDFXAxisDirection.LeftToRight,
                PDFYAxisDirection.BottomToTop);
        }

        /// <summary>
        /// Draws the Sin(x) graph on the given page using the specified logical unit.
        /// </summary>
        /// <param name="page">The page to draw to.</param>
        /// <param name="lu">The logical unit used to position the graph.</param>
        /// <param name="pen">The pen used to draw the graph.</param>
        public static void DrawGraph(PDFPage page, PDFLogicalUnitBase lu, PDFPen pen)
        {
            double x, y;

            // Set the unit for the page
            page.Canvas.SetLogicalUnit(lu);
            pen.Width = pen.Width / lu.ToPDFUnitY(1);

            // i goes from -180 degrees to 180 degrees (=Math.PI)
            PDFPoint[] points = new PDFPoint[361];
            for (int i = -180; i <= 180; i++)
            {
                x = (float)(i * Math.PI / 180);
                y = (float)Math.Sin(x);
                points[i + 180] = new PDFPoint(x, y);
            }

            page.Canvas.DrawLines(pen, points);
        }
    }

    /// <summary>
    /// Defines a custom unit that specifies different mappings for X
    /// and Y axis. The unit on Y axis equals to 3 inch (3*72 points),
    /// and the unit on X axis equals 1 inch.
    /// </summary>
    class CustomUnit1 : PDFLogicalUnitBase
    {
        public CustomUnit1()
        {
        }

        public override double ToPDFUnitX(double unit)
        {
            return unit * 72;
        }

        public override double ToPDFUnitY(double unit)
        {
            return unit * 72 * 3;
        }
    }

    /// <summary>
    /// Defines a custom unit that specifies different mappings for X
    /// and Y axis. The unit on Y axis equals to 2 inch (2*72 points),
    /// and the unit on X axis equals 1 inch.
    /// </summary>
    class CustomUnit2 : PDFLogicalUnitBase
    {
        public CustomUnit2()
        {
        }

        public override double ToPDFUnitX(double unit)
        {
            return unit * 72;
        }

        public override double ToPDFUnitY(double unit)
        {
            return unit * 72 * 2;
        }
    }
}


Sinus.vb

PDF4NET Send comments on this topic.
Sinus.vb
PDF4NET On-line Help > Samples > Sin(x) Graph > Sinus.vb

Glossary Item Box

Imports System
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.Sinus
    ''' <summary>
    ''' This sample shows how to use user defined logical units,
    ''' define them and change the current logical unit
    ''' during the drawing process. It will also show how to move
    ''' the coordinate system in order to better fit the drawing needs.
    ''' The sample will draw the graph of Sin(x) function, using 3
    ''' different user defined logical units. These 3 units will be
    ''' equal on X axis, but they will be different on Y axis.
    ''' </summary>
    Class Sinus
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            Dim redPen As New PDFPen(New PDFRgbColor(255, 0, 0), 1)
            Dim bluePen As New PDFPen(New PDFRgbColor(0, 0, 192), 1)
            Dim greenPen As New PDFPen(New PDFRgbColor(0, 192, 0), 1)

            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            ' Create first page of the document
            Dim page As PDFPage = pdfDoc.AddPage()

            ' Setup Graph (draw axes, draw labels)
            SetupGraph(page)

            ' Create a new logical unit
            Dim un1 As New CustomUnit1()

            DrawGraph(page, un1, redPen)

            ' Create a new logical unit
            Dim un2 As New CustomUnit2()

            DrawGraph(page, un2, bluePen)

            ' Create an inch logical unit
            Dim inch As New PDFInchLogicalUnit()

            DrawGraph(page, inch, greenPen)

            ' Save the document to disk
            pdfDoc.Save("Sample_Sinus.pdf")
        End Sub

        Public Shared Sub SetupGraph(page As PDFPage)
            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 10)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())
            Dim blackPen As New PDFPen(New PDFRgbColor(), 1)

            page.Canvas.DrawText("Sin(x) graph", fontText, Nothing, blackBrush, 50, 50)
            Dim tfo As New PDFTextFormatOptions()
            tfo.LineSpacing = 2
            tfo.ClipText = PDFClipText.ClipNone
            page.Canvas.DrawTextBox("All 3 graphs are drawn at the same logical " + "position on the page. The difference between them is the logical " + "unit that has been used for drawing each graph. Each logical unit " + "performed a different mapping between the logical position and the " + "physical position on the page.", fontText, Nothing, blackBrush, 50, 70, _
                250, 0, tfo)

            ' Move the origin of the coordinate system to the
            ' center of the page
            page.Canvas.SetOrigin(page.Width / 2, page.Height / 2)

            ' Draw the axes of the coordinate system
            ' Draw the Y axis. Adjust 50 pixels to have
            ' some space between the end of the axis and
            ' the page margin.
            page.Canvas.DrawLine(blackPen, 0, -(page.Height / 2 - 50), 0, page.Height / 2 - 50)
            ' Draw the X axis.
            page.Canvas.DrawLine(blackPen, -(page.Width / 2 - 50), 0, page.Width / 2 - 50, 0)

            page.Canvas.DrawText("0", fontText, Nothing, blackBrush, 1, 1)
            page.Canvas.DrawText("x", fontText, Nothing, blackBrush, page.Width / 2 - 55, 1)
            page.Canvas.DrawText("y", fontText, Nothing, blackBrush, 1, -page.Height / 2 + 50)

            ' Set the direction of Y axis to BottomToTop
            ' and leave the X axis unchanged
            page.Canvas.SetAxesDirection(PDFXAxisDirection.LeftToRight, PDFYAxisDirection.BottomToTop)
        End Sub

        ''' <summary>
        ''' Draws the Sin(x) graph on the given page using the specified logical unit.
        ''' </summary>
        ''' <param name="page">The page to draw to.</param>
        ''' <param name="lu">The logical unit used to position the graph.</param>
        ''' <param name="pen">The pen used to draw the graph.</param>
        Public Shared Sub DrawGraph(page As PDFPage, lu As PDFLogicalUnitBase, pen As PDFPen)
            Dim x As Double, y As Double

            ' Set the unit for the page
            page.Canvas.SetLogicalUnit(lu)
            pen.Width = pen.Width / lu.ToPDFUnitY(1)

            ' i goes from -180 degrees to 180 degrees (=Math.PI)
            Dim points As PDFPoint() = New PDFPoint(360) {}
            Dim i As Integer = -180
            While i <= 180
                x = i * Math.PI / 180
                y = Math.Sin(x)
                points(i + 180) = New PDFPoint(x, y)
                i = i + 1
            End While

            page.Canvas.DrawLines(pen, points)
        End Sub
    End Class

    ''' <summary>
    ''' Defines a custom unit that specifies different mappings for X
    ''' and Y axis. The unit on Y axis equals to 3 inch (3*72 points),
    ''' and the unit on X axis equals 1 inch.
    ''' </summary>
    Class CustomUnit1
        Inherits PDFLogicalUnitBase
        Public Sub New()
        End Sub

        Public Overloads Overrides Function ToPDFUnitX(unit As Double) As Double
            Return unit * 72
        End Function

        Public Overloads Overrides Function ToPDFUnitY(unit As Double) As Double
            Return unit * 72 * 3
        End Function
    End Class

    ''' <summary>
    ''' Defines a custom unit that specifies different mappings for X
    ''' and Y axis. The unit on Y axis equals to 2 inch (2*72 points),
    ''' and the unit on X axis equals 1 inch.
    ''' </summary>
    Class CustomUnit2
        Inherits PDFLogicalUnitBase
        Public Sub New()
        End Sub

        Public Overloads Overrides Function ToPDFUnitX(unit As Double) As Double
            Return unit * 72
        End Function

        Public Overloads Overrides Function ToPDFUnitY(unit As Double) As Double
            Return unit * 72 * 2
        End Function
    End Class
End Namespace


Samples: Stamp PDF

PDF4NET Send comments on this topic.
Samples: Stamp PDF
PDF4NET On-line Help > Samples > Samples: Stamp PDF

Glossary Item Box

This sample shows how to stamp a PDF file. A PDF file can be stamped with any combination of text, graphics, images and annotations. The stamps can be opaque or transparent. First page in the sample is stamped with a rubber stamp annotation, second page is stamped with regular text and third page is stamped with a transparent image.

C# Source code | VB.NET Source code | PDF file


StampPDF.cs

PDF4NET Send comments on this topic.
StampPDF.cs
PDF4NET On-line Help > Samples > Stamp PDF > StampPDF.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Annotations;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.StampPDF
{
    /// <summary>
    /// This sample shows how to stamp existing PDF files with stamp annotations, text or images.
    /// </summary>
    class StampPDF
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Import the pdf document
            PDFDocument doc = new PDFDocument("..\\SupportFiles\\sample.pdf");

            // stamp first page with a rubber stamp annotation.
            PDFRubberStampAnnotation rsa = new PDFRubberStampAnnotation("Approved", "This document has been approved.");
            rsa.Icon = PDFRubberStampAnnotationIcon.Approved;
            rsa.DisplayRectangle = new DisplayRectangle(50, 50, 500, 100);
            // make the stamp transparent, so the text behind it is visible
            rsa.Opacity = 50;
            doc.Pages[0].Annotations.Add(rsa);

            // stamp second page with regular text.
            PDFFont font = new PDFFont(PDFFontFace.Helvetica, 96);
            font.Bold = true;
            PDFBrush greenBrush = new PDFBrush(new PDFRgbColor(Color.Green));
            // make the stamp transparent
            doc.Pages[1].Canvas.SetTransparency(50);
            doc.Pages[1].Canvas.DrawText("Approved", font, null, greenBrush,
                doc.Pages[1].Width / 2, 120, 20, PDFTextAlign.MiddleCenter);
            doc.Pages[1].Canvas.SetTransparency(0);

            // stamp third page with an image.
            // make the stamp transparent
            doc.Pages[2].Canvas.SetTransparency(50);
            doc.Pages[2].Canvas.DrawImage("..\\SupportFiles\\auto1.jpg", 200, 500, 300, 1, 20, PDFKeepAspectRatio.KeepWidth);
            doc.Pages[2].Canvas.SetTransparency(0);

            // Save the document to disk
            doc.Save("Sample_StampPDF.pdf");
        }
    }
}


StampPDF.vb

PDF4NET Send comments on this topic.
StampPDF.vb
PDF4NET On-line Help > Samples > Stamp PDF > StampPDF.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Annotations
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.StampPDF
    ''' <summary>
    ''' This sample shows how to stamp existing PDF files with stamp annotations, text or images.
    ''' </summary>
    Class StampPDF
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Import the pdf document
            Dim doc As New PDFDocument("..\SupportFiles\sample.pdf")

            ' stamp first page with a rubber stamp annotation.
            Dim rsa As New PDFRubberStampAnnotation("Approved", "This document has been approved.")
            rsa.Icon = PDFRubberStampAnnotationIcon.Approved
            rsa.DisplayRectangle = New DisplayRectangle(50, 50, 500, 100)
            ' make the stamp transparent, so the text behind it is visible
            rsa.Opacity = 50
            doc.Pages(0).Annotations.Add(rsa)

            ' stamp second page with regular text.
            Dim font As New PDFFont(PDFFontFace.Helvetica, 96)
            font.Bold = True
            Dim greenBrush As New PDFBrush(New PDFRgbColor(Color.Green))
            ' make the stamp transparent
            doc.Pages(1).Canvas.SetTransparency(50)
            doc.Pages(1).Canvas.DrawText("Approved", font, Nothing, greenBrush, doc.Pages(1).Width / 2, 120, _
                20, PDFTextAlign.MiddleCenter)
            doc.Pages(1).Canvas.SetTransparency(0)

            ' stamp third page with an image.
            ' make the stamp transparent
            doc.Pages(2).Canvas.SetTransparency(50)
            doc.Pages(2).Canvas.DrawImage("..\SupportFiles\auto1.jpg", 200, 500, 300, 1, 20, _
             PDFKeepAspectRatio.KeepWidth)
            doc.Pages(2).Canvas.SetTransparency(0)

            ' Save the document to disk
            doc.Save("Sample_StampPDF.pdf")
        End Sub
    End Class
End Namespace


Samples: TextBoxes

PDF4NET Send comments on this topic.
Samples: TextBoxes
PDF4NET On-line Help > Samples > Samples: TextBoxes

Glossary Item Box

This samples shows the columnar text drawing capabilities of the PDF4NET library. On the first page, it shows all the possible alignments of the text inside a box. On the second page is shows how to draw rotated text boxes or how the constrain the text to stay inside the box. It also shows how the text can be let to flow out of the box if it does not fit inside it. The text uses Verdana font for display.

C# Source code | VB.NET Source code | PDF file


TextBoxes.cs

PDF4NET Send comments on this topic.
TextBoxes.cs
PDF4NET On-line Help > Samples > Textboxes > TextBoxes.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.TextBoxes
{
    /// <summary>
    /// This sample will show the available possibilities
    /// for columnar text formatting.
    /// </summary>
    class TextBoxes
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();
            TrueTypeFont ttf = new TrueTypeFont("..\\SupportFiles\\verdana.ttf", 12, true);

            DrawFirstPage(pdfDoc, ttf);
            DrawSecondPage(pdfDoc, ttf);

            // Save the document to disk
            pdfDoc.Save("Sample_TextBoxes.pdf");
        }

        //private static void DrawFirstPage( PDFDocument pdfDoc, TrueTypeFont fnt )
        private static void DrawFirstPage(PDFDocument pdfDoc, PDFFontBase fnt)
        {
            // Create first page
            PDFPage pdfPage = pdfDoc.AddPage();

            // Create the graphic objects
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());
            PDFPen redPen = new PDFPen(new PDFRgbColor(255, 0, 0), 1);

            // Draw the bounding boxes
            pdfPage.Canvas.DrawRectangle(redPen, null, 20, 20, 150, 150, 0);
            pdfPage.Canvas.DrawRectangle(redPen, null, 190, 20, 150, 150, 0);
            pdfPage.Canvas.DrawRectangle(redPen, null, 360, 20, 150, 150, 0);
            pdfPage.Canvas.DrawRectangle(redPen, null, 20, 190, 150, 150, 0);
            pdfPage.Canvas.DrawRectangle(redPen, null, 190, 190, 150, 150, 0);
            pdfPage.Canvas.DrawRectangle(redPen, null, 360, 190, 150, 150, 0);
            pdfPage.Canvas.DrawRectangle(redPen, null, 20, 360, 150, 150, 0);
            pdfPage.Canvas.DrawRectangle(redPen, null, 190, 360, 150, 150, 0);
            pdfPage.Canvas.DrawRectangle(redPen, null, 360, 360, 150, 150, 0);
            pdfPage.Canvas.DrawRectangle(redPen, null, 20, 530, 150, 150, 0);
            pdfPage.Canvas.DrawRectangle(redPen, null, 190, 530, 150, 150, 0);
            pdfPage.Canvas.DrawRectangle(redPen, null, 360, 530, 150, 150, 0);

            // Draw the text
            // Top align
            PDFTextFormatOptions tfo = new PDFTextFormatOptions();
            tfo.Align = PDFTextAlign.TopLeft;
            tfo.ClipText = PDFClipText.ClipNone;
            pdfPage.Canvas.DrawTextBox("These lines of text are top left aligned. These lines of text are top left aligned.",
                fnt, null, blackBrush, 20, 20, 150, 150, tfo);
            tfo = new PDFTextFormatOptions();
            tfo.Align = PDFTextAlign.TopCenter;
            pdfPage.Canvas.DrawTextBox("These lines of text are top center aligned. These lines of text are top center aligned.",
                fnt, null, blackBrush, 190, 20, 150, 150, tfo);
            tfo = new PDFTextFormatOptions();
            tfo.Align = PDFTextAlign.TopRight;
            pdfPage.Canvas.DrawTextBox("These lines of text are top right aligned. These lines of text are top right aligned.",
                fnt, null, blackBrush, 360, 20, 150, 150, tfo);
            // Middle align
            tfo = new PDFTextFormatOptions();
            tfo.Align = PDFTextAlign.MiddleLeft;
            pdfPage.Canvas.DrawTextBox("These lines of text are middle left aligned. These lines of text are middle left aligned.",
                fnt, null, blackBrush, 20, 190, 150, 150, tfo);
            tfo = new PDFTextFormatOptions();
            tfo.Align = PDFTextAlign.MiddleCenter;
            pdfPage.Canvas.DrawTextBox("These lines of text are middle center aligned. These lines of text are middle center aligned.",
                fnt, null, blackBrush, 190, 190, 150, 150, tfo);
            tfo = new PDFTextFormatOptions();
            tfo.Align = PDFTextAlign.MiddleRight;
            pdfPage.Canvas.DrawTextBox("These lines of text are middle right aligned. These lines of text are middle right aligned.",
                fnt, null, blackBrush, 360, 190, 150, 150, tfo);
            // Bottom align
            tfo = new PDFTextFormatOptions();
            tfo.Align = PDFTextAlign.BottomLeft;
            pdfPage.Canvas.DrawTextBox("These lines of text are bottom left aligned. These lines of text are bottom left aligned.",
                fnt, null, blackBrush, 20, 360, 150, 150, tfo);
            tfo = new PDFTextFormatOptions();
            tfo.Align = PDFTextAlign.BottomCenter;
            pdfPage.Canvas.DrawTextBox("These lines of text are bottom center aligned. These lines of text are bottom center aligned.",
                fnt, null, blackBrush, 190, 360, 150, 150, tfo);
            tfo = new PDFTextFormatOptions();
            tfo.Align = PDFTextAlign.BottomRight;
            pdfPage.Canvas.DrawTextBox("These lines of text are bottom right aligned. These lines of text are bottom right aligned.",
                fnt, null, blackBrush, 360, 360, 150, 150, tfo);
            // Justification
            tfo = new PDFTextFormatOptions();
            tfo.Align = PDFTextAlign.TopJustified;
            pdfPage.Canvas.DrawTextBox("These lines of text are top justify aligned. These lines of text are top justify aligned.",
                fnt, null, blackBrush, 20, 530, 150, 150, tfo);
            tfo = new PDFTextFormatOptions();
            tfo.Align = PDFTextAlign.MiddleJustified;
            pdfPage.Canvas.DrawTextBox("These lines of text are middle justify aligned. These lines of text are middle justify aligned.",
                fnt, null, blackBrush, 190, 530, 150, 150, tfo);
            tfo = new PDFTextFormatOptions();
            tfo.Align = PDFTextAlign.BottomJustified;
            pdfPage.Canvas.DrawTextBox("These lines of text are bottom justify aligned. These lines of text are bottom justify justify aligned.",
                fnt, null, blackBrush, 360, 530, 150, 150, tfo);
        }

        //private static void DrawSecondPage( PDFDocument pdfDoc, TrueTypeFont fnt )
        private static void DrawSecondPage(PDFDocument pdfDoc, PDFFontBase fnt)
        {
            // Create first page
            PDFPage pdfPage = pdfDoc.AddPage();

            // Create the graphic objects
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());
            PDFPen redPen = new PDFPen(new PDFRgbColor(255, 0, 0), 1);

            // Draw a label
            pdfPage.Canvas.DrawText("Rotated text box",
                fnt, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft);

            // Draw the bounding boxes
            pdfPage.Canvas.DrawRectangle(redPen, null, 190, 100, 150, 150, 30);

            // Draw the text
            PDFTextFormatOptions tfo = new PDFTextFormatOptions();
            tfo.Align = PDFTextAlign.TopLeft;
            tfo.Orientation = 30;
            pdfPage.Canvas.DrawTextBox("This text box is rotated with 30 degrees around " +
                "the top left corner. The red border does not belong to the text box. It has " +
                "been drawn using DrawRectangle( ) method.",
                fnt, null, blackBrush, 190, 100, 150, 150, tfo);

            // Draw a label
            pdfPage.Canvas.DrawText("Clipped text",
                fnt, null, blackBrush, 20, 300, 0, PDFTextAlign.TopLeft);

            // Draw the bounding boxes
            pdfPage.Canvas.DrawRectangle(redPen, null, 20, 315, 150, 53, 0);

            // Draw the text
            tfo = new PDFTextFormatOptions();
            tfo.Align = PDFTextAlign.TopLeft;
            pdfPage.Canvas.DrawTextBox("This text is not allowed to get out of the box. " +
                "This is the default behavior of the text box. The last line will be clipped.",
                fnt, null, blackBrush, 20, 315, 150, 53, tfo);

            // Draw a label
            pdfPage.Canvas.DrawText("Flow out text",
                fnt, null, blackBrush, 300, 300, 0, PDFTextAlign.TopLeft);

            // Draw the bounding boxes
            pdfPage.Canvas.DrawRectangle(redPen, null, 300, 315, 150, 53, 0);

            // Draw the text
            tfo = new PDFTextFormatOptions();
            tfo.Align = PDFTextAlign.TopLeft;
            tfo.ClipText = PDFClipText.ClipNone;
            tfo.LineSpacing = 5;
            pdfPage.Canvas.DrawTextBox("This text is allowed to get out of the box. " +
                "This behavior can be enforced by setting the clipText parameter to true." +
                "As it can be seen, the text can flow out of the box. " +
                "Also, for this sample, the line spacing has been increased with 5 points.",
                fnt, null, blackBrush, 300, 315, 150, 53, tfo);
        }
    }
}


TextBoxes.vb

PDF4NET Send comments on this topic.
TextBoxes.vb
PDF4NET On-line Help > Samples > Textboxes > TextBoxes.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.TextBoxes
    ''' <summary>
    ''' This sample will show the available possibilities
    ''' for columnar text formatting.
    ''' </summary>
    Class TextBoxes
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()
            Dim ttf As New TrueTypeFont("..\SupportFiles\verdana.ttf", 12, True)

            DrawFirstPage(pdfDoc, ttf)
            DrawSecondPage(pdfDoc, ttf)

            ' Save the document to disk
            pdfDoc.Save("Sample_TextBoxes.pdf")
        End Sub

        'private static void DrawFirstPage( PDFDocument pdfDoc, TrueTypeFont fnt )
        Private Shared Sub DrawFirstPage(pdfDoc As PDFDocument, fnt As PDFFontBase)
            ' Create first page
            Dim pdfPage As PDFPage = pdfDoc.AddPage()

            ' Create the graphic objects
            Dim blackBrush As New PDFBrush(New PDFRgbColor())
            Dim redPen As New PDFPen(New PDFRgbColor(255, 0, 0), 1)

            ' Draw the bounding boxes
            pdfPage.Canvas.DrawRectangle(redPen, Nothing, 20, 20, 150, 150, _
                0)
            pdfPage.Canvas.DrawRectangle(redPen, Nothing, 190, 20, 150, 150, _
                0)
            pdfPage.Canvas.DrawRectangle(redPen, Nothing, 360, 20, 150, 150, _
                0)
            pdfPage.Canvas.DrawRectangle(redPen, Nothing, 20, 190, 150, 150, _
                0)
            pdfPage.Canvas.DrawRectangle(redPen, Nothing, 190, 190, 150, 150, _
                0)
            pdfPage.Canvas.DrawRectangle(redPen, Nothing, 360, 190, 150, 150, _
                0)
            pdfPage.Canvas.DrawRectangle(redPen, Nothing, 20, 360, 150, 150, _
                0)
            pdfPage.Canvas.DrawRectangle(redPen, Nothing, 190, 360, 150, 150, _
                0)
            pdfPage.Canvas.DrawRectangle(redPen, Nothing, 360, 360, 150, 150, _
                0)
            pdfPage.Canvas.DrawRectangle(redPen, Nothing, 20, 530, 150, 150, _
                0)
            pdfPage.Canvas.DrawRectangle(redPen, Nothing, 190, 530, 150, 150, _
                0)
            pdfPage.Canvas.DrawRectangle(redPen, Nothing, 360, 530, 150, 150, _
                0)

            ' Draw the text
            ' Top align
            Dim tfo As New PDFTextFormatOptions()
            tfo.Align = PDFTextAlign.TopLeft
            tfo.ClipText = PDFClipText.ClipNone
            pdfPage.Canvas.DrawTextBox("These lines of text are top left aligned. These lines of text are top left aligned.", fnt, Nothing, blackBrush, 20, 20, _
                150, 150, tfo)
            tfo = New PDFTextFormatOptions()
            tfo.Align = PDFTextAlign.TopCenter
            pdfPage.Canvas.DrawTextBox("These lines of text are top center aligned. These lines of text are top center aligned.", fnt, Nothing, blackBrush, 190, 20, _
                150, 150, tfo)
            tfo = New PDFTextFormatOptions()
            tfo.Align = PDFTextAlign.TopRight
            pdfPage.Canvas.DrawTextBox("These lines of text are top right aligned. These lines of text are top right aligned.", fnt, Nothing, blackBrush, 360, 20, _
                150, 150, tfo)
            ' Middle align
            tfo = New PDFTextFormatOptions()
            tfo.Align = PDFTextAlign.MiddleLeft
            pdfPage.Canvas.DrawTextBox("These lines of text are middle left aligned. These lines of text are middle left aligned.", fnt, Nothing, blackBrush, 20, 190, _
                150, 150, tfo)
            tfo = New PDFTextFormatOptions()
            tfo.Align = PDFTextAlign.MiddleCenter
            pdfPage.Canvas.DrawTextBox("These lines of text are middle center aligned. These lines of text are middle center aligned.", fnt, Nothing, blackBrush, 190, 190, _
                150, 150, tfo)
            tfo = New PDFTextFormatOptions()
            tfo.Align = PDFTextAlign.MiddleRight
            pdfPage.Canvas.DrawTextBox("These lines of text are middle right aligned. These lines of text are middle right aligned.", fnt, Nothing, blackBrush, 360, 190, _
                150, 150, tfo)
            ' Bottom align
            tfo = New PDFTextFormatOptions()
            tfo.Align = PDFTextAlign.BottomLeft
            pdfPage.Canvas.DrawTextBox("These lines of text are bottom left aligned. These lines of text are bottom left aligned.", fnt, Nothing, blackBrush, 20, 360, _
                150, 150, tfo)
            tfo = New PDFTextFormatOptions()
            tfo.Align = PDFTextAlign.BottomCenter
            pdfPage.Canvas.DrawTextBox("These lines of text are bottom center aligned. These lines of text are bottom center aligned.", fnt, Nothing, blackBrush, 190, 360, _
                150, 150, tfo)
            tfo = New PDFTextFormatOptions()
            tfo.Align = PDFTextAlign.BottomRight
            pdfPage.Canvas.DrawTextBox("These lines of text are bottom right aligned. These lines of text are bottom right aligned.", fnt, Nothing, blackBrush, 360, 360, _
                150, 150, tfo)
            ' Justification
            tfo = New PDFTextFormatOptions()
            tfo.Align = PDFTextAlign.TopJustified
            pdfPage.Canvas.DrawTextBox("These lines of text are top justify aligned. These lines of text are top justify aligned.", fnt, Nothing, blackBrush, 20, 530, _
                150, 150, tfo)
            tfo = New PDFTextFormatOptions()
            tfo.Align = PDFTextAlign.MiddleJustified
            pdfPage.Canvas.DrawTextBox("These lines of text are middle justify aligned. These lines of text are middle justify aligned.", fnt, Nothing, blackBrush, 190, 530, _
                150, 150, tfo)
            tfo = New PDFTextFormatOptions()
            tfo.Align = PDFTextAlign.BottomJustified
            pdfPage.Canvas.DrawTextBox("These lines of text are bottom justify aligned. These lines of text are bottom justify justify aligned.", fnt, Nothing, blackBrush, 360, 530, _
                150, 150, tfo)
        End Sub

        'private static void DrawSecondPage( PDFDocument pdfDoc, TrueTypeFont fnt )
        Private Shared Sub DrawSecondPage(pdfDoc As PDFDocument, fnt As PDFFontBase)
            ' Create first page
            Dim pdfPage As PDFPage = pdfDoc.AddPage()

            ' Create the graphic objects
            Dim blackBrush As New PDFBrush(New PDFRgbColor())
            Dim redPen As New PDFPen(New PDFRgbColor(255, 0, 0), 1)

            ' Draw a label
            pdfPage.Canvas.DrawText("Rotated text box", fnt, Nothing, blackBrush, 20, 20, _
                0, PDFTextAlign.TopLeft)

            ' Draw the bounding boxes
            pdfPage.Canvas.DrawRectangle(redPen, Nothing, 190, 100, 150, 150, _
                30)

            ' Draw the text
            Dim tfo As New PDFTextFormatOptions()
            tfo.Align = PDFTextAlign.TopLeft
            tfo.Orientation = 30
            pdfPage.Canvas.DrawTextBox("This text box is rotated with 30 degrees around " + "the top left corner. The red border does not belong to the text box. It has " + "been drawn using DrawRectangle( ) method.", fnt, Nothing, blackBrush, 190, 100, _
                150, 150, tfo)

            ' Draw a label
            pdfPage.Canvas.DrawText("Clipped text", fnt, Nothing, blackBrush, 20, 300, _
                0, PDFTextAlign.TopLeft)

            ' Draw the bounding boxes
            pdfPage.Canvas.DrawRectangle(redPen, Nothing, 20, 315, 150, 53, _
                0)

            ' Draw the text
            tfo = New PDFTextFormatOptions()
            tfo.Align = PDFTextAlign.TopLeft
            pdfPage.Canvas.DrawTextBox("This text is not allowed to get out of the box. " + "This is the default behavior of the text box. The last line will be clipped.", fnt, Nothing, blackBrush, 20, 315, _
                150, 53, tfo)

            ' Draw a label
            pdfPage.Canvas.DrawText("Flow out text", fnt, Nothing, blackBrush, 300, 300, _
                0, PDFTextAlign.TopLeft)

            ' Draw the bounding boxes
            pdfPage.Canvas.DrawRectangle(redPen, Nothing, 300, 315, 150, 53, _
                0)

            ' Draw the text
            tfo = New PDFTextFormatOptions()
            tfo.Align = PDFTextAlign.TopLeft
            tfo.ClipText = PDFClipText.ClipNone
            tfo.LineSpacing = 5
            pdfPage.Canvas.DrawTextBox("This text is allowed to get out of the box. " + "This behavior can be enforced by setting the clipText parameter to true." + "As it can be seen, the text can flow out of the box. " + "Also, for this sample, the line spacing has been increased with 5 points.", fnt, Nothing, blackBrush, 300, 315, _
                150, 53, tfo)
        End Sub
    End Class
End Namespace


Samples: TextExtract

PDF4NET Send comments on this topic.
Samples: TextExtract
PDF4NET On-line Help > Samples > Samples: TextExtract

Glossary Item Box

This sample shows how to extract the text from a PDF page.

C# Source code | VB.NET Source code


TextExtract.cs

PDF4NET Send comments on this topic.
TextExtract.cs
PDF4NET On-line Help > Samples > TextExtract > TextExtract.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.PDFFile;

namespace O2S.Samples.PDF4NET.TextExtract
{
    /// <summary>
    /// This sample shows how to extract text from an existing pdf file.
    /// </summary>
    class TextExtract
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument("..\\SupportFiles\\Sample.pdf");

            for (int i = 0; i < pdfDoc.Pages.Count; i++)
            {
                PDFImportedPage ip = pdfDoc.Pages[i] as PDFImportedPage;

                Console.WriteLine("Page {0}:", i + 1);
                string text = ip.ExtractText();
                Console.WriteLine(text);
            }

            pdfDoc.Dispose();
        }
    }
}


TextExtract.vb

PDF4NET Send comments on this topic.
TextExtract.vb
PDF4NET On-line Help > Samples > TextExtract > TextExtract.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.PDFFile

Namespace O2S.Samples.PDF4NET.TextExtract
    ''' <summary>
    ''' This sample shows how to extract text from an existing pdf file.
    ''' </summary>
    Class TextExtract
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread()> _
        Shared Sub Main(ByVal args As String())
            ' Load the pdf document
            Dim pdfDoc As New PDFDocument("..\SupportFiles\Sample.pdf")

            Dim i As Integer = 0
            While i < pdfDoc.Pages.Count
                Dim ip As PDFImportedPage = pdfDoc.Pages(i)
                Console.WriteLine("Page {0}:", i + 1)
                Dim text As String = ip.ExtractText()
                Console.WriteLine(text)

                i = i + 1
            End While

            pdfDoc.Dispose()
        End Sub
    End Class
End Namespace


Samples: TextLines

PDF4NET Send comments on this topic.
Samples: TextLines
PDF4NET On-line Help > Samples > Samples: TextLines

Glossary Item Box

This samples shows the single line text drawing capabilities of the PDF4NET library. On the first page, it shows all the supported fonts. On the second page, it shows how to draw rotated text at random positions and of random size. On the third page it shows all the possible alignments for text lines.

C# Source code | VB.NET Source code | PDF file


TextLines.cs

PDF4NET Send comments on this topic.
TextLines.cs
PDF4NET On-line Help > Samples > TextLines > TextLines.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.TextLines
{
    struct PrintFont
    {
        public PrintFont(PDFFontFace fontFace, bool bold, bool italic)
        {
            PDFFontFace = fontFace;
            Bold = bold;
            Italic = italic;
        }

        public override string ToString()
        {
            string s = PDFFontFace.ToString();
            if (Bold)
            {
                s = s + "Bold";
            }
            if (Italic)
            {
                s = s + "Italic";
            }
            return s;
        }

        public PDFFontFace PDFFontFace;
        public bool Bold;
        public bool Italic;
    }

    /// <summary>
    /// This sample will show various possibilities to draw text on page
    /// </summary>
    class TextLines
    {
        static PrintFont[] fonts =
            { new PrintFont( PDFFontFace.Helvetica, false, false ),
                new PrintFont( PDFFontFace.Helvetica, true, false ),
                new PrintFont( PDFFontFace.Helvetica, false, true ),
                new PrintFont( PDFFontFace.Helvetica, true, true ),
                new PrintFont( PDFFontFace.Courier, false, false ),
                new PrintFont( PDFFontFace.Courier, true, false ),
                new PrintFont( PDFFontFace.Courier, false, true ),
                new PrintFont( PDFFontFace.Courier, true, true ),
                new PrintFont( PDFFontFace.TimesRoman, false, false ),
                new PrintFont( PDFFontFace.TimesRoman, true, false ),
                new PrintFont( PDFFontFace.TimesRoman, false, true ),
                new PrintFont( PDFFontFace.TimesRoman, true, true ) };
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument();

            DrawFirstPage(pdfDoc);
            DrawSecondPage(pdfDoc);
            DrawThirdPage(pdfDoc);

            // Save the document to disk
            pdfDoc.Save("Sample_TextLines.pdf");
        }

        private static void DrawFirstPage(PDFDocument pdfDoc)
        {
            // Create first page
            PDFPage pdfPage = pdfDoc.AddPage();

            // Create the graphic objects
            PDFFont fontText = new PDFFont(PDFFontFace.Helvetica, 12);
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());

            for (int i = 0; i < fonts.Length; i++)
            {
                PDFFont font = new PDFFont(fonts[i].PDFFontFace, 12);
                font.Bold = fonts[i].Bold;
                font.Italic = fonts[i].Italic;

                pdfPage.Canvas.DrawText("This font is " + fonts[i].ToString() + " size 12",
                    font, null, blackBrush, 20, (i + 1) * 20, 0, PDFTextAlign.TopLeft);
            }

            for (int i = 0; i < fonts.Length; i++)
            {
                PDFFont font = new PDFFont(fonts[i].PDFFontFace, 16);
                font.Bold = fonts[i].Bold;
                font.Italic = fonts[i].Italic;

                pdfPage.Canvas.DrawText("This font is " + fonts[i].ToString() + " size 16",
                    font, null, blackBrush, 20, 300 + (i + 1) * 20, 0, PDFTextAlign.TopLeft);
            }
        }

        private static void DrawSecondPage(PDFDocument pdfDoc)
        {
            // Create first page
            PDFPage pdfPage = pdfDoc.AddPage();

            // Create the graphic objects
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());

            Random rnd = new Random();
            for (int i = 0; i < 50; i++)
            {
                // Random position
                int x = rnd.Next((int)pdfPage.Width);
                int y = rnd.Next((int)pdfPage.Height);

                // Random text size
                int fontSize = rnd.Next(16);

                // Random orientation
                int orientation = rnd.Next(360);

                // Random font face
                int fontFaceIndex = rnd.Next(fonts.Length);

                // Create random colors for drawing the text
                PDFColor brushColor = new PDFRgbColor((byte)rnd.Next(256),
                    (byte)rnd.Next(256), (byte)rnd.Next(256));

                // Create the brush to draw the text
                PDFBrush brush = new PDFBrush(brushColor);

                PDFFont font = new PDFFont(fonts[fontFaceIndex].PDFFontFace, fontSize);
                font.Italic = fonts[fontFaceIndex].Italic;
                font.Bold = fonts[fontFaceIndex].Bold;

                pdfPage.Canvas.DrawText("Font: " + fonts[fontFaceIndex].ToString() +
                    ", size: " + fontSize.ToString() + ", orientation: " + orientation.ToString() + " degrees.",
                    font, null, brush, x, y, orientation, PDFTextAlign.TopLeft);
            }
        }

        private static void DrawThirdPage(PDFDocument pdfDoc)
        {
            // Create first page
            PDFPage pdfPage = pdfDoc.AddPage();

            // Create the graphic objects
            PDFBrush orangeBrush = new PDFBrush(new PDFRgbColor(Color.Orange));
            PDFPen pen = new PDFPen(new PDFRgbColor(), 1);
            PDFFont font2 = new PDFFont(PDFFontFace.Helvetica, 18);

            // Draw the drid
            pdfPage.Canvas.DrawLine(pen, 10, 100, 600, 100);
            pdfPage.Canvas.DrawLine(pen, 10, 300, 600, 300);
            pdfPage.Canvas.DrawLine(pen, 10, 500, 600, 500);
            pdfPage.Canvas.DrawLine(pen, 10, 100, 10, 500);
            pdfPage.Canvas.DrawLine(pen, 300, 100, 300, 500);
            pdfPage.Canvas.DrawLine(pen, 600, 100, 600, 500);

            // Draw the labels
            // Top Align
            pdfPage.Canvas.DrawText("Top left align",
                font2, null, orangeBrush, 10, 100, 0, PDFTextAlign.TopLeft);
            pdfPage.Canvas.DrawText("Top center align",
                font2, null, orangeBrush, 300, 100, 0, PDFTextAlign.TopCenter);
            pdfPage.Canvas.DrawText("Top right align",
                font2, null, orangeBrush, 600, 100, 0, PDFTextAlign.TopRight);
            // Middle align
            pdfPage.Canvas.DrawText("Middle left align",
                font2, null, orangeBrush, 10, 300, 0, PDFTextAlign.MiddleLeft);
            pdfPage.Canvas.DrawText("Middle center align",
                font2, null, orangeBrush, 300, 300, 0, PDFTextAlign.MiddleCenter);
            pdfPage.Canvas.DrawText("Middle right align",
                font2, null, orangeBrush, 600, 300, 0, PDFTextAlign.MiddleRight);
            // Right align
            pdfPage.Canvas.DrawText("Bottom left align",
                font2, null, orangeBrush, 10, 500, 0, PDFTextAlign.BottomLeft);
            pdfPage.Canvas.DrawText("Bottom center align",
                font2, null, orangeBrush, 300, 500, 0, PDFTextAlign.BottomCenter);
            pdfPage.Canvas.DrawText("Bottom right align",
                font2, null, orangeBrush, 600, 500, 0, PDFTextAlign.BottomRight);
        }
    }
}


TextLines.vb

PDF4NET Send comments on this topic.
TextLines.vb
PDF4NET On-line Help > Samples > TextLines > TextLines.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.TextLines
    Structure PrintFont
        Public Sub New(fontFace As PDFFontFace, bold As Boolean, italic As Boolean)
            PDFFontFace = fontFace
            Bold = bold
            Italic = italic
        End Sub

        Public Overloads Overrides Function ToString() As String
            Dim s As String = PDFFontFace.ToString()
            If Bold Then
                s = s + "Bold"
            End If
            If Italic Then
                s = s + "Italic"
            End If
            Return s
        End Function

        Public PDFFontFace As PDFFontFace
        Public Bold As Boolean
        Public Italic As Boolean
    End Structure

    ''' <summary>
    ''' This sample will show various possibilities to draw text on page
    ''' </summary>
    Class TextLines
        Shared fonts As PrintFont() = {New PrintFont(PDFFontFace.Helvetica, False, False), New PrintFont(PDFFontFace.Helvetica, True, False), New PrintFont(PDFFontFace.Helvetica, False, True), New PrintFont(PDFFontFace.Helvetica, True, True), New PrintFont(PDFFontFace.Courier, False, False), New PrintFont(PDFFontFace.Courier, True, False), _
            New PrintFont(PDFFontFace.Courier, False, True), New PrintFont(PDFFontFace.Courier, True, True), New PrintFont(PDFFontFace.TimesRoman, False, False), New PrintFont(PDFFontFace.TimesRoman, True, False), New PrintFont(PDFFontFace.TimesRoman, False, True), New PrintFont(PDFFontFace.TimesRoman, True, True)}
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim pdfDoc As New PDFDocument()

            DrawFirstPage(pdfDoc)
            DrawSecondPage(pdfDoc)
            DrawThirdPage(pdfDoc)

            ' Save the document to disk
            pdfDoc.Save("Sample_TextLines.pdf")
        End Sub

        Private Shared Sub DrawFirstPage(pdfDoc As PDFDocument)
            ' Create first page
            Dim pdfPage As PDFPage = pdfDoc.AddPage()

            ' Create the graphic objects
            Dim fontText As New PDFFont(PDFFontFace.Helvetica, 12)
            Dim blackBrush As New PDFBrush(New PDFRgbColor())

            Dim i As Integer = 0
            While i < fonts.Length
                Dim font As New PDFFont(fonts(i).PDFFontFace, 12)
                font.Bold = fonts(i).Bold
                font.Italic = fonts(i).Italic

                pdfPage.Canvas.DrawText("This font is " + fonts(i).ToString() + " size 12", font, Nothing, blackBrush, 20, (i + 1) * 20, _
                    0, PDFTextAlign.TopLeft)
                i = i + 1
            End While

            i = 0
            While i < fonts.Length
                Dim font As New PDFFont(fonts(i).PDFFontFace, 16)
                font.Bold = fonts(i).Bold
                font.Italic = fonts(i).Italic

                pdfPage.Canvas.DrawText("This font is " + fonts(i).ToString() + " size 16", font, Nothing, blackBrush, 20, 300 + (i + 1) * 20, _
                    0, PDFTextAlign.TopLeft)
                i = i + 1
            End While
        End Sub

        Private Shared Sub DrawSecondPage(pdfDoc As PDFDocument)
            ' Create first page
            Dim pdfPage As PDFPage = pdfDoc.AddPage()

            ' Create the graphic objects
            Dim blackBrush As New PDFBrush(New PDFRgbColor())

            Dim rnd As New Random()
            Dim i As Integer = 0
            While i < 50
                ' Random position
                Dim x As Double = rnd.NextDouble() * pdfPage.Width
                Dim y As Double = rnd.NextDouble() * pdfPage.Height

                ' Random text size
                Dim fontSize As Integer = rnd.Next(16)

                ' Random orientation
                Dim orientation As Integer = rnd.Next(360)

                ' Random font face
                Dim fontFaceIndex As Integer = rnd.Next(fonts.Length)

                ' Create random colors for drawing the text
                Dim brushColor As PDFColor = New PDFRgbColor(rnd.Next(256), rnd.Next(256), rnd.Next(256))

                ' Create the brush to draw the text
                Dim brush As New PDFBrush(brushColor)

                Dim font As New PDFFont(fonts(fontFaceIndex).PDFFontFace, fontSize)
                font.Italic = fonts(fontFaceIndex).Italic
                font.Bold = fonts(fontFaceIndex).Bold

                pdfPage.Canvas.DrawText("Font: " + fonts(fontFaceIndex).ToString() + ", size: " + fontSize.ToString() + ", orientation: " + orientation.ToString() + " degrees.", font, Nothing, brush, x, y, _
                    orientation, PDFTextAlign.TopLeft)
                i = i + 1
            End While
        End Sub

        Private Shared Sub DrawThirdPage(pdfDoc As PDFDocument)
            ' Create first page
            Dim pdfPage As PDFPage = pdfDoc.AddPage()

            ' Create the graphic objects
            Dim orangeBrush As New PDFBrush(New PDFRgbColor(Color.Orange))
            Dim pen As New PDFPen(New PDFRgbColor(), 1)
            Dim font2 As New PDFFont(PDFFontFace.Helvetica, 18)

            ' Draw the drid
            pdfPage.Canvas.DrawLine(pen, 10, 100, 600, 100)
            pdfPage.Canvas.DrawLine(pen, 10, 300, 600, 300)
            pdfPage.Canvas.DrawLine(pen, 10, 500, 600, 500)
            pdfPage.Canvas.DrawLine(pen, 10, 100, 10, 500)
            pdfPage.Canvas.DrawLine(pen, 300, 100, 300, 500)
            pdfPage.Canvas.DrawLine(pen, 600, 100, 600, 500)

            ' Draw the labels
            ' Top Align
            pdfPage.Canvas.DrawText("Top left align", font2, Nothing, orangeBrush, 10, 100, _
                0, PDFTextAlign.TopLeft)
            pdfPage.Canvas.DrawText("Top center align", font2, Nothing, orangeBrush, 300, 100, _
                0, PDFTextAlign.TopCenter)
            pdfPage.Canvas.DrawText("Top right align", font2, Nothing, orangeBrush, 600, 100, _
                0, PDFTextAlign.TopRight)
            ' Middle align
            pdfPage.Canvas.DrawText("Middle left align", font2, Nothing, orangeBrush, 10, 300, _
                0, PDFTextAlign.MiddleLeft)
            pdfPage.Canvas.DrawText("Middle center align", font2, Nothing, orangeBrush, 300, 300, _
                0, PDFTextAlign.MiddleCenter)
            pdfPage.Canvas.DrawText("Middle right align", font2, Nothing, orangeBrush, 600, 300, _
                0, PDFTextAlign.MiddleRight)
            ' Right align
            pdfPage.Canvas.DrawText("Bottom left align", font2, Nothing, orangeBrush, 10, 500, _
                0, PDFTextAlign.BottomLeft)
            pdfPage.Canvas.DrawText("Bottom center align", font2, Nothing, orangeBrush, 300, 500, _
                0, PDFTextAlign.BottomCenter)
            pdfPage.Canvas.DrawText("Bottom right align", font2, Nothing, orangeBrush, 600, 500, _
                0, PDFTextAlign.BottomRight)
        End Sub
    End Class
End Namespace


Samples: Tiff2PDF

PDF4NET Send comments on this topic.
Samples: Tiff2PDF
PDF4NET On-line Help > Samples > Samples: Tiff2PDF

Glossary Item Box

This sample demonstrates how to convert a multipage tiff file to PDF.

C# Source code | VB.NET Source code


Tiff2PDF.cs

PDF4NET Send comments on this topic.
Tiff2PDF.cs
PDF4NET On-line Help > Samples > Tiff2PDF > Tiff2PDF.cs

Glossary Item Box

using System;
using System.Drawing;
using System.Drawing.Imaging;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Converters;

namespace O2S.Samples.PDF4NET.Tiff2PDF
{
    /// <summary>
    /// This sample shows how to convert a multi page tiff file to pdf
    /// </summary>
    class Tiff2PDF
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            PageByPageConversion();

            BulkConversion();
        }

        private static void BulkConversion()
        {
            PDFConverter.ConvertTiffToPDF("..\\SupportFiles\\Sample.tif", "Sample_Tiff2PDF_Bulk.pdf");
        }

        private static void PageByPageConversion()
        {
            // Create the pdf document
            PDFDocument doc = new PDFDocument();

            // Load TIFF file
            Bitmap bitmap = new Bitmap("..\\SupportFiles\\sample.tif");

            // Calculate number of pages/images used in TIFF file
            FrameDimension frameDimension = new FrameDimension(bitmap.FrameDimensionsList[0]);
            int framesCount = bitmap.GetFrameCount(frameDimension);

            for (int i = 0; i < framesCount; i++)
            {
                // Create a new page
                PDFPage page = doc.AddPage();

                // draw the current tiff frame on the page
                PDFImage image = new PDFImage(bitmap, i);
                page.Canvas.DrawImage(image, 0, 0, page.Width, page.Height, 0, PDFKeepAspectRatio.KeepNone);
            }

            doc.Save("Sample_Tiff2PDF_PageByPage.pdf");
        }
    }
}


Tiff2PDF.vb

PDF4NET Send comments on this topic.
Tiff2PDF.vb
PDF4NET On-line Help > Samples > Tiff2PDF > Tiff2PDF.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports System.Drawing.Imaging
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Converters

Namespace O2S.Samples.PDF4NET.Tiff2PDF
    ''' <summary>
    ''' This sample shows how to convert a multi page tiff file to pdf
    ''' </summary>
    Class Tiff2PDF
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread()> _
        Shared Sub Main(ByVal args As String())
            PageByPageConversion()

            BulkConversion()
        End Sub

        Private Shared Sub BulkConversion()
            PDFConverter.ConvertTiffToPDF("..\SupportFiles\Sample.tif", "Sample_Tiff2PDF_Bulk.pdf")
        End Sub

        Private Shared Sub PageByPageConversion()
            ' Create the pdf document
            Dim doc As New PDFDocument()

            ' Load TIFF file
            Dim bitmap As New Bitmap("..\SupportFiles\sample.tif")

            ' Calculate number of pages/images used in TIFF file
            Dim frameDimension As New FrameDimension(bitmap.FrameDimensionsList(0))
            Dim framesCount As Integer = bitmap.GetFrameCount(frameDimension)

            Dim i As Integer = 0
            While i < framesCount
                ' Create a new page
                Dim page As PDFPage = doc.AddPage()

                ' draw the current tiff frame on the page
                Dim image As New PDFImage(bitmap, i)
                page.Canvas.DrawImage(image, 0, 0, page.Width, page.Height, 0, PDFKeepAspectRatio.KeepNone)
                i = i + 1
            End While

            doc.Save("Sample_Tiff2PDF_PageByPage.pdf")
        End Sub
    End Class
End Namespace


Samples: Unicode

PDF4NET Send comments on this topic.
Samples: Unicode
PDF4NET On-line Help > Samples > Samples: Unicode

Glossary Item Box

This samples shows the Unicode capabilities of PDF4NET library. The same text is printed on several pages but translated in various languages. Some of the translations were done automatically, we apologize for any mistakes.

C# Source code | PDF file


Unicode.cs

PDF4NET Send comments on this topic.
Unicode.cs
PDF4NET On-line Help > Samples > Unicode > Unicode.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;
using O2S.Components.PDF4NET.Actions;

namespace O2S.Samples.PDF4NET.Unicode
{
    public class PageData
    {
        public PageData(PDFFontBase font, string language, string text)
        {
            Font = font;
            Language = language;
            Text = text;
        }

        public PDFFontBase Font;
        public string Language;
        public string Text;
    }

    /// <summary>
    /// This sample will show the Unicode display capabilities of PDF4NET library.
    /// </summary>
    class Unicode
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the fonts to write the text
            TrueTypeFont ttf = new TrueTypeFont("..\\SupportFiles\\tahoma.ttf", 12, true, true);
            TrueTypeFont titleFont = new TrueTypeFont(ttf, 16);
            CJKFont csFont = new CJKFont(CJKFontFace.SinoTypeSongLight, 12);
            CJKFont ctFont = new CJKFont(CJKFontFace.MonotypeHeiMedium, 12);
            CJKFont krFont = new CJKFont(CJKFontFace.HanyangSystemsGothicMedium, 12);
            CJKFont jpFont = new CJKFont(CJKFontFace.HeiseiKakuGothicW5, 12);

            PageData[] pagesInfo =
            {
                new PageData( ttf, "English", "PDF4NET is a .NET library for generating pdf documents " +
                    "on the fly from any .NET application. The library does not rely on any Adobe " +
                    "products for creating pdf files. It hides the complex structure of pdf files " +
                    "behind a simple object model that allows creation of complex pdf files with a few " +
                    "lines of code. The PDF4NET library follows the GDI+ model, thus reducing the " +
                    "learning time and increasing productivity.\n" +
                    "It uses a grid based layout approach allowing precise positioning of content on " +
                    "document's pages. The final pdf file is compressed, making the library apropriate " +
                    "for web applications. The library can be used both from WinForms and WebForms " +
                    "(ASP.NET) applications without any restrictions. The library is written entirely " +
                    "in C#, being 100% managed. The PDF4NET library is licensed per developer and can " +
                    "be distributed ROYALTY FREE, reducing project costs.\n" ),
                new PageData( csFont, "Chinese Simplified", "PDF4NET 是一个NET 图书馆为正在进行中生成" +
                    "pdf 文件从任一个NET 申请。 图书馆不依靠任何Adobe 产品为创建pdf 文件。 它隐藏pdf " +
                    "文件复杂结构在允许复杂pdf 文件创建以几个代码行的一个简单对象模型之后。 PDF4NET " +
                    "图书馆跟随GDI+ 设计, 如此减少学习时间和增加生产力。它使用网格基于的格式途径允许精" +
                    "确安置目录在文件的页。 最终pdf 文件是压缩的, 使图书馆适当为万维网申请。 图书馆可能" +
                    "被使用从WinForms 和WebForms (ASP.NET) 申请没有任何限制。 图书馆整个地被写在C#, " +
                    "是100% 管理。 PDF4NET 图书馆被准许每开发员, 可能任意是被分配的皇族, 减少项目费用。" ),
                new PageData( ctFont, "Chinese Traditional", "PDF4NET 是一個NET 圖書館為正在進行中生成" +
                    "pdf 文件從任一個NET 申請。 圖書館不依靠任何Adobe 產品為創建pdf 文件。 它隱藏pdf 文" +
                    "件複雜結構在承認複雜pdf 文件創建以幾個代碼行的一個簡單對象模型之後。 PDF4NET 圖書館" +
                    "跟隨GDI+ 設計, 如此減少學習時間和增加生產力。它使用網格基於的格式途徑允許精確安置目" +
                    "錄在文件的頁。 最終pdf 文件是壓縮的, 使圖書館適當為萬維網申請。 圖書館可能被使用從" +
                    "WinForms 和WebForms (ASP.NET) 申請沒有任何限制。 圖書館整個地被寫在C#, 是100% " +
                    "管理。 PDF4NET 圖書館被准許每開發員, 可能任意是被分配的皇族, 減少項目費用。" ),
                new PageData( ttf, "Dutch", "PDF4NET is a. NETTO bibliotheek voor het produceren van " +
                    "pdf documenten op de vlieg van om het even welke. NETTO toepassing. De bibliotheek " +
                    "zich baseert niet op enige producten van de Adobe voor het creëren van pdf dossiers. " +
                    "Het verbergt de complexe structuur van pdfdossiers achter een eenvoudig objecten " +
                    "model dat verwezenlijking van complexe pdfdossiers met een paar lijnen van code " +
                    "toestaat. De bibliotheek PDF4NET volgt GDI + model, waarbij de het leren tijd wordt " +
                    "verminderd en het verhogen van productiviteit. Het gebruikt een net gebaseerde " +
                    "lay-outbenadering die het nauwkeurige plaatsen van inhoud op de pagina's van het " +
                    "document toestaat. Het definitieve pdfdossier wordt samengeperst, makend de " +
                    "bibliotheek voor Webtoepassingen aangewezen. De bibliotheek kan zowel van " +
                    "(NETTO ASP.) toepassingen WinForms als WebForms zonder enige beperkingen worden " +
                    "gebruikt. De bibliotheek wordt geschreven volledig in C#, zijnd geleide 100%. " +
                    "De bibliotheek PDF4NET is vergunning gegeven per ontwikkelaar en kan verdeelde " +
                    "VRIJ ROYALTY zijn die, projectkosten drukt.\n" ),
                new PageData( ttf, "French", "PDF4NET est une bibliothèque de NET pour produire des " +
                    "documents de pdf en marche de n'importe quelle application de NET. La bibliothèque " +
                    "ne se fonde sur aucun produit d'adobe pour créer des fichiers de pdf. Elle cache " +
                    "la structure complexe des fichiers de pdf derrière un modèle simple d'objet qui " +
                    "permet la création des fichiers complexes de pdf avec quelques lignes de code. " +
                    "La bibliothèque de PDF4NET suit le modèle de GDI+, de ce fait réduisant le temps " +
                    "d'étude et augmentant la productivité. Elle utilise une approche de disposition " +
                    "basée par grille permettant le positionnement précis du contenu sur les pages du " +
                    "document. Le fichier final de pdf est comprimé, rendant la bibliothèque appropriée " +
                    "pour des applications de Web. La bibliothèque peut être utilisée des applications " +
                    "de WinForms et de WebForms (ASP.NET) sans aucune restriction. La bibliothèque est " +
                    "écrite entièrement dans C#, étant 100% contrôlé. La bibliothèque de PDF4NET est " +
                    "autorisée par réalisateur et peut être REDEVANCE distribuée LIBREMENT, réduisant " +
                    "des coûts de projet.\n" ),
                new PageData( ttf, "German", "PDF4NET ist eine NET Bibliothek für pdf Dokumente schnell " +
                    "festlegen von jeder möglicher NET Anwendung. Die Bibliothek beruht nicht auf " +
                    "irgendwelchen Ziegelsteinprodukten für das Herstellen der pdf Dateien. Sie versteckt " +
                    "die komplizierte Struktur der pdf Dateien hinter einem einfachen Nachricht Modell, " +
                    "das Kreation der komplizierten pdf Dateien mit einigen Zeilen des Codes erlaubt. " +
                    "Die PDF4NET Bibliothek folgt dem GDI+ Modell, so verringert die erlernenzeit und " +
                    "erhöht Produktivität. Sie verwendet eine Rasterfeld gegründete Planannäherung, " +
                    "die exakte Positionierung des Inhalts auf Seiten des Dokumentes erlaubend. Die " +
                    "abschließende pdf Datei wird komprimiert und bildet die Bibliothek passend für " +
                    "Web-Anwendungen. Die Bibliothek kann WinForms und WebForms (ASP.NET) von den " +
                    "Anwendungen ohne irgendwelche Beschränkungen benutzt werden. Die Bibliothek wird " +
                    "völlig in C# geschrieben und ist gehandhabtes 100%. Die PDF4NET Bibliothek wird pro " +
                    "Entwickler genehmigt und kann verteilte ABGABE FREI sein und verringert Projektkosten.\n" ),
                new PageData( ttf, "Greek", "PDF4NET είναι βιβλιοθήκη δικτύου α. για την παραγωγή pdf των " +
                    "εγγράφων σχετικά με τη μύγα από οποιαδήποτε. εφαρμογή δικτύου. Η βιβλιοθήκη δεν " +
                    "στηρίζεται σε οποιαδήποτε προϊόντα πλίθας για τη δημιουργία pdf των αρχείων. Κρύβει " +
                    "τη σύνθετη δομή των αρχείων pdf πίσω από ένα απλό μοντέλο αντικειμένου που επιτρέπει " +
                    "τη δημιουργία των σύνθετων αρχείων pdf με μερικές γραμμές κώδικα. Η βιβλιοθήκη " +
                    "PDF4NET ακολουθεί GDI + το μοντέλο, μειώνοντας κατά συνέπεια το χρόνο εκμάθησης και " +
                    "αύξηση της παραγωγικότητας. Χρησιμοποιεί μια βασισμένη στο πλέγμα προσέγγιση " +
                    "σχεδιαγράμματος που επιτρέπει τον ακριβή προσδιορισμό θέσης του περιεχομένου στις " +
                    "σελίδες του εγγράφου. Το τελικό αρχείο pdf συμπιέζεται, καθιστώντας τη βιβλιοθήκη " +
                    "αρμόδια για τις εφαρμογές Ιστού. Η βιβλιοθήκη μπορεί να χρησιμοποιηθεί και από " +
                    "(ASP. δίκτυο) τις εφαρμογές WinForms και WebForms χωρίς οποιουσδήποτε περιορισμούς. " +
                    "Η βιβλιοθήκη γράφεται εξ ολοκλήρου C#, όντας 100% διοικούμενο. Η βιβλιοθήκη " +
                    "PDF4NET είναι χορηγημένη άδεια ανά υπεύθυνο για την ανάπτυξη και μπορεί να είναι " +
                    "διανεμημένο ΔΙΚΑΊΩΜΑ ΕΛΕΎΘΕΡΟ, που μειώνει τις δαπάνες προγράμματος.\n" ),
                new PageData( ttf, "Italian", "PDF4NET proviene una libreria del NET per la generazione " +
                    "dei documenti del pdf in moto da tutta l'applicazione del NET. La libreria non " +
                    "conta su alcuni prodotti dell'adobe per la creazione degli archivi del pdf. " +
                    "Nasconde la struttura complessa degli archivi del pdf dietro un modello semplice " +
                    "dell'oggetto che permette la creazione degli archivi complessi del pdf con alcune " +
                    "righe del codice. La libreria di PDF4NET segue il modello di GDI+, così riducendo " +
                    "il tempo imparante ed aumentando il rendimento. Usa un metodo della disposizione " +
                    "basato griglia permettendo posizionare preciso del soddisfare alle pagine del " +
                    "documento. L'archivio finale del pdf è compresso, rendente la libreria adatta per " +
                    "le applicazioni di Web. La libreria può essere usata sia dalle applicazioni di " +
                    "WebForms che di WinForms (ASP.NET) senza alcune limitazioni. La libreria è " +
                    "scritta interamente in C#, essendo 100% gestito. La libreria di PDF4NET è " +
                    "autorizzata per sviluppatore e può essere la SOVRANITÀ distribuita LIBERAMENTE, " +
                    "riducendo i costi di progetto.\n" ),
                new PageData( jpFont, "Japanese", "PDF4NET はあらゆるNET のアプリケーションからPDF " +
                    "文書をオンザフライ式で生成する為のNET ライブラリである。 ライブラリはPDF ファイ" +
                    "ルを作成する為のAdobe あらゆるプロダクトに頼らない。 それは少数のコード行が付い" +
                    "ている複雑なPDF ファイルの作成を可能にする簡単なオブジェクトモデルの後ろのPDF フ" +
                    "ァイルの複雑な構造を隠す。 従ってPDF4NET ライブラリはGDI+ モデルに続き、学習時間" +
                    "を減らし、生産性を高める。それは格子によって基づかせているレイアウトのアプローチ" +
                    "を使用し文書のページの内容の精密な位置を許可する。 最終的なPDF ファイルは圧縮され" +
                    "て、ライブラリを網アプリケーションのために適切にさせる。 ライブラリは制限のない" +
                    "WinForms 及びWebForms (ASP.NET) アプリケーションから両方使用することができる。 " +
                    "ライブラリはでC# 完全に書かれ、管理される100% である。 PDF4NET ライブラリは1 開" +
                    "発者につき認可され、分散特許権使用料自由にである場合もありプロジェクトのコストを" +
                    "削減する。" ),
                new PageData( krFont, "Korean", "PDF4NET은 어떤NET응용에서pdf문서를 몰래 생성하기를 " +
                    "위해NET도서관 이다. 도서관은pdf파일을 만들기를 위해Adobe어떤 제품에 의지하지 않는" +
                    "다. 그것은 약간 코드 행에 복잡한pdf파일의 창조를 허용하는 간단한 객체 모형뒤에pdf" +
                    "파일의 복잡한 구조를 숨긴다. PDF4NET도서관은 GDI+모형을 따라, 따라서 학습 시간을 " +
                    "감소하고 생산력을 증가한. 그것은 격자에 의하여 기초를 두는 배치 접근을 사용해 문" +
                    "서 페이지에 내용의 정확한 두기 허용한. 마지막pdf파일은 압축 이어, 도서관을 웹 응" +
                    "용을 위해 적당한 시킨. 도서관은 어떤 금지없이 WinForms과 WebForms(22#ASP.NET) 응" +
                    "용에서 모두 이용할 수 있는다. 도서관은 전체로안에C#써, 처리되는 100% 이. PDF4NET" +
                    "도서관은 개발자당 허용하 배부된 특허권 사용료 자유롭게 이을 수 있어, 계획사업 비" +
                    "용을 감소한." ),
                new PageData( ttf, "Portuguese", "PDF4NET é uma biblioteca do NET para gerar originais " +
                    "do pdf na mosca de toda a aplicação do NET. A biblioteca não confia em nenhuns " +
                    "produtos do adôbe para criar limas do pdf. Esconde a estrutura complexa de limas " +
                    "do pdf atrás de um modelo simples do objeto que permita a criação de limas " +
                    "complexas do pdf com algumas linhas do código. A biblioteca de PDF4NET segue o " +
                    "modelo de GDI+, assim reduzindo o tempo de aprendizagem e aumentando a produtividade. " +
                    "Usa uma aproximação baseada grade da disposição permitindo posicionar preciso do " +
                    "índice em páginas do original. A lima final do pdf é comprimida, fazendo a " +
                    "biblioteca apropriada para aplicações do Web. A biblioteca pode ser usada das " +
                    "aplicações de WinForms e de WebForms (ASP.NET) sem nenhumas limitações. A " +
                    "biblioteca é escrita inteiramente em C#, sendo 100% controlado. A biblioteca de " +
                    "PDF4NET é licenciada por o colaborador e pode ser ROYALTY distribuído LIVRE, " +
                    "reduzindo custos do projeto.\n" ),
                new PageData( ttf, "Romanian", "PDF4NET este o librărie .NET destinată generării de " +
                    "documente pdf din orice aplicaţie .NET. Librăria nu se bazează pe nici un product " +
                    "Adobe pentru generarea fişierelor pdf. Ea ascunde structura complexă a fişierelor " +
                    "pdf în spatele unui model obiect simplu ce permite crearea de fişiere pdf complexe " +
                    "cu doar câteva linii de cod. Librăria PDF4NET urmează modelul GDI+, reducând astfel " +
                    "timpul de învăţare şi crescând productivitatea.\n" +
                    "Librăria utilizeaza o abordare de poziţionare a conţinutului bazată pe grid, " +
                    "permiţând poziţionarea precisă a continuţului în paginile documentului. Fisierul " +
                    "pdf final este comprimat, făcând librăria potrivită pentru aplicaţiile web. " +
                    "Librăria poate fi utilizată atât din aplicaţii desktop WinForms cât şi din " +
                    "aplicaţii web WebForms (ASP.NET) fără nici o restricţie. Librăria a fost dezvoltată " +
                    "în întregime în C#, fiind 100% managed. Librăria PDF4NET este licenţiată per " +
                    "programator şi poate fi distribuită fără taxe suplimentare, reducând astfel " +
                    "costurile proiectului în care este folosită.\n" ),
                new PageData( ttf, "Russian", "PDF4NET будет архивом NET для производить документы pdf " +
                    "на мухе от любого применения NET. Архив не полагается на всех продуктах самана для " +
                    "создавать архивы pdf. Он прячет сложную структуру архивов pdf за просто моделью " +
                    "предмета позволяет творение сложных архивов pdf с немного линий Кодего. Архив " +
                    "PDF4NET следует за моделью GDI+, таким образом уменьшающ учя время и увеличивающ " +
                    "урожайность. Он использует основанный решеткой подход к плана позволяющ точный " +
                    "располагать содержания на страницы документа. Обжат окончательный архив pdf, делая " +
                    "архив соотвествующим для применений стержня. Архив можно использовать и от " +
                    "применений WinForms и WebForms (ASP.NET) без всех ограничений. Архив написан вс в C#, " +
                    "был управляемым 100%. Архив PDF4NET лицензирован в проявитель и может быть " +
                    "распределенной КОРОЛЕВСКОЙ ВЛАСТЬЮ СВОБОДНО, уменьшающ цены проекта.\n" ),
                new PageData( ttf, "Spanish", "PDF4NET es una biblioteca del NET para generar documentos " +
                    "del pdf en marcha de cualquier aplicación del NET. La biblioteca no confía en " +
                    "ninguna productos del adobe para crear ficheros del pdf. Oculta la estructura " +
                    "compleja de los ficheros del pdf detrás de un modelo simple del objeto que permita " +
                    "la creación de los ficheros complejos del pdf con algunas líneas del código. " +
                    "La biblioteca de PDF4NET sigue el modelo de GDI+, así reduciendo el tiempo que " +
                    "aprende y aumentando productividad. Utiliza un acercamiento basado rejilla de la " +
                    "disposición permitiendo la colocación exacta del contenido en las paginaciones del " +
                    "documento. El fichero final del pdf se comprime, haciendo la biblioteca apropiada " +
                    "para las aplicaciones del Web. La biblioteca se puede utilizar de las aplicaciones " +
                    "de WinForms y de WebForms (ASP.NET) sin ningunas restricciones. La biblioteca se " +
                    "escribe enteramente en C#, siendo el 100% manejado. La biblioteca de PDF4NET se " +
                    "licencia por el revelador y puede ser DERECHOS distribuidos LIBREMENTE, reduciendo " +
                    "costes del proyecto.\n" ),
                new PageData( ttf, "Swedish", "PDF4NET är ett .NET-bibliotek för att generera " +
                    "pdf-dokument i farten i en .NET-applikation. Biblioteket är inte beroende av någon " +
                    "produkt från Adobe för att skapa pdf-filer. Det döljer pdf-filernas komplexa " +
                    "struktur bakom en enkel objektsmodell, som tillåter skapandet av komplexa " +
                    "pdf-filer med några få rader kod. PDF4NET-biblioteket följer modellen GDI+, och " +
                    "förkortar därigenom inlärningstiden och ökar produktiviteten.\n" +
                    "Det använder en layoutmetod, baserad på rutnät, vilket möjliggör absolut " +
                    "positionering av innehållet i dokumentet. Den slutgiltiga pdf-filen är komprimerad, " +
                    "vilket gör biblioteket lämpligt för webapplikationer. Biblioteket kan användas både " +
                    "från WinForms- och WebForms- (ASP.NET) applikationer utan några begränsningar. " +
                    "Biblioteket är helt och hållet skrivet i C#, och är till 100% s.k. \"Managed Code\". " +
                    "PDF4NET-biblioteket licensieras per utvecklare och kan distribueras royaltyfritt, " +
                    "vilket minskar projektkostnader.\n" )
            };

            // Create the pdf document
            PDFDocument doc = new PDFDocument();
            doc.DisplayMode = PDFDisplayMode.UseOutlines;

            // Create the graphic objects
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());

            // Create the root bookmark
            PDFBookmark root = new PDFBookmark();
            root.DisplayStyle = PDFBookmarkDisplayStyle.Bold;
            root.Title = "Unicode";
            doc.Bookmarks.Add(root);

            PDFTextFormatOptions tfo = new PDFTextFormatOptions();
            tfo.Align = PDFTextAlign.TopJustified;

            for (int i = 0; i < pagesInfo.Length; i++)
            {
                PDFPage page = doc.AddPage();

                // draw the page title
                page.Canvas.DrawText(pagesInfo[i].Language, titleFont, null, blackBrush, 20, 40);

                // draw the page content
                page.Canvas.DrawTextBox(pagesInfo[i].Text, pagesInfo[i].Font, null, blackBrush,
                    20, 60, page.Width - 40, page.Height - 80, tfo);

                // add a bookmark to point to this page
                PDFPageDestination pageDestination = new PDFPageDestination();
                pageDestination.Page = page;
                pageDestination.MagnificationMode = PDFMagnificationMode.XYZ;
                pageDestination.Zoom = 100;
                pageDestination.Top = page.Height;
                PDFGoToAction gta = new PDFGoToAction();
                gta.Destination = pageDestination;
                PDFBookmark pageBookmark = new PDFBookmark();
                pageBookmark.Title = pagesInfo[i].Language;
                pageBookmark.Action = gta;
                root.Bookmarks.Add(pageBookmark);
            }

            // Save the document to disk
            doc.Save("Sample_Unicode.pdf");
        }
    }
}


Samples: Update PDF

PDF4NET Send comments on this topic.
Samples: Update PDF
PDF4NET On-line Help > Samples > Samples: Update PDF

Glossary Item Box

This samples shows the import and update capabilities of PDF4NET library. It loads an external pdf file, draws content on the first page of the document, then it creates a new page at the beginning of the document.

C# Source code | VB.NET Source code | PDF file


UpdatePDF.cs

PDF4NET Send comments on this topic.
UpdatePDF.cs
PDF4NET On-line Help > Samples > Update PDF > UpdatePDF.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.UpdatePDF
{
    /// <summary>
    /// This sample shows how to add content to an existing pdf file.
    /// </summary>
    class UpdatePDF
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Create the pdf document
            PDFDocument pdfDoc = new PDFDocument("..\\SupportFiles\\HelloPDFWorld.pdf");
            // Create the graphic objects
            PDFBrush blackBrush = new PDFBrush(new PDFRgbColor());
            PDFBrush greenBrush = new PDFBrush(new PDFRgbColor(0, 128, 0));
            PDFPen redPen = new PDFPen(new PDFRgbColor(255, 0, 0), 2);
            PDFFont fnt = new PDFFont(PDFFontFace.Helvetica, 12);

            // Draw on the first page of the imported document
            pdfDoc.Pages[0].Canvas.DrawRectangle(redPen, greenBrush, 15, 15, 500, 200, 0);
            pdfDoc.Pages[0].Canvas.DrawText("This is new content added to an imported page.",
                fnt, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft);

            // Create a page and insert it at the beginning
            // of the document
            PDFPage firstPage = new PDFPage();
            pdfDoc.Pages.Insert(0, firstPage);
            firstPage.Canvas.DrawText("This is a new page added to the old document",
                fnt, null, blackBrush, 20, 20, 0, PDFTextAlign.TopLeft);

            // Save the document to disk
            pdfDoc.Save("Sample_UpdatePDF.pdf");
        }
    }
}


UpdatePDF.vb

PDF4NET Send comments on this topic.
UpdatePDF.vb
PDF4NET On-line Help > Samples > Update PDF > UpdatePDF.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.UpdatePDF
    ''' <summary>
    ''' This sample shows how to add content to an existing pdf file.
    ''' </summary>
    Class UpdatePDF
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Create the pdf document
            Dim pdfDoc As New PDFDocument("..\SupportFiles\HelloPDFWorld.pdf")
            ' Create the graphic objects
            Dim blackBrush As New PDFBrush(New PDFRgbColor())
            Dim greenBrush As New PDFBrush(New PDFRgbColor(0, 128, 0))
            Dim redPen As New PDFPen(New PDFRgbColor(255, 0, 0), 2)
            Dim fnt As New PDFFont(PDFFontFace.Helvetica, 12)

            ' Draw on the first page of the imported document
            pdfDoc.Pages(0).Canvas.DrawRectangle(redPen, greenBrush, 15, 15, 500, 200, _
                0)
            pdfDoc.Pages(0).Canvas.DrawText("This is new content added to an imported page.", fnt, Nothing, blackBrush, 20, 20, _
                0, PDFTextAlign.TopLeft)

            ' Create a page and insert it at the beginning
            ' of the document
            Dim firstPage As New PDFPage()
            pdfDoc.Pages.Insert(0, firstPage)
            firstPage.Canvas.DrawText("This is a new page added to the old document", fnt, Nothing, blackBrush, 20, 20, _
                0, PDFTextAlign.TopLeft)

            ' Save the document to disk
            pdfDoc.Save("Sample_UpdatePDF.pdf")
        End Sub
    End Class
End Namespace


Samples: Watermarks

PDF4NET Send comments on this topic.
Samples: Watermarks
PDF4NET On-line Help > Samples > Samples: Watermarks

Glossary Item Box

This sample demonstrates how to a watermark to a PDF file. The sample draws a simple text watermark on each page of a PDF document. Any type of text, graphics and image can be used as watermarks.

C# Source code | VB.NET Source code | PDF file


Watermarks.cs

PDF4NET Send comments on this topic.
Watermarks.cs
PDF4NET On-line Help > Samples > Watermarks > Watermarks.cs

Glossary Item Box

using System;
using System.Drawing;
using O2S.Components.PDF4NET;
using O2S.Components.PDF4NET.PDFFile;
using O2S.Components.PDF4NET.Annotations;
using O2S.Components.PDF4NET.Graphics;
using O2S.Components.PDF4NET.Graphics.Shapes;
using O2S.Components.PDF4NET.Graphics.Fonts;

namespace O2S.Samples.PDF4NET.Watermarks
{
    /// <summary>
    /// This sample shows how to draw a text watermark on existing PDF files behind actual page content.
    /// </summary>
    class Watermarks
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            // Import the pdf document
            PDFDocument doc = new PDFDocument("..\\SupportFiles\\sample.pdf");

            // stamp second page with regular text.
            PDFFont font = new PDFFont(PDFFontFace.Helvetica, 96);
            font.Bold = true;
            PDFBrush greenBrush = new PDFBrush(new PDFRgbColor(Color.Green));

            for (int i = 0; i < doc.Pages.Count; i++)
            {
                PDFImportedPage ip = (PDFImportedPage)doc.Pages[i];

                // Use the UnderCanvas property to draw under existing page content
                ip.UnderCanvas.DrawText("Approved", font, null, greenBrush,
                    ip.Width / 2, ip.Height / 2, 20, PDFTextAlign.MiddleCenter);
            }

            // Save the document to disk
            doc.Save("Sample_Watermarks.pdf");
        }
    }
}


Watermarks.vb

PDF4NET Send comments on this topic.
Watermarks.vb
PDF4NET On-line Help > Samples > Watermarks > Watermarks.vb

Glossary Item Box

Imports System
Imports System.Drawing
Imports O2S.Components.PDF4NET
Imports O2S.Components.PDF4NET.PDFFile
Imports O2S.Components.PDF4NET.Annotations
Imports O2S.Components.PDF4NET.Graphics
Imports O2S.Components.PDF4NET.Graphics.Shapes
Imports O2S.Components.PDF4NET.Graphics.Fonts

Namespace O2S.Samples.PDF4NET.Watermarks
    ''' <summary>
    ''' This sample shows how to draw a text watermark on existing PDF files behind actual page content.
    ''' </summary>
    Class Watermarks
        ''' <summary>
        ''' The main entry point for the application.
        ''' </summary>
        <STAThread> _
        Shared Sub Main(args As String())
            ' Import the pdf document
            Dim doc As New PDFDocument("..\SupportFiles\sample.pdf")

            ' stamp second page with regular text.
            Dim font As New PDFFont(PDFFontFace.Helvetica, 96)
            font.Bold = True
            Dim greenBrush As New PDFBrush(New PDFRgbColor(Color.Green))

            Dim i As Integer = 0
            While i < doc.Pages.Count
                Dim ip As PDFImportedPage = DirectCast(doc.Pages(i), PDFImportedPage)

                ' Use the UnderCanvas property to draw under existing page content
                ip.UnderCanvas.DrawText("Approved", font, Nothing, greenBrush, ip.Width / 2, ip.Height / 2, _
                    20, PDFTextAlign.MiddleCenter)
                i = i + 1
            End While

            ' Save the document to disk
            doc.Save("Sample_Watermarks.pdf")
        End Sub
    End Class
End Namespace


Assembly Overview

O2S.Components.PDF4NET Send comments on this topic.
O2S.Components.PDF4NET Assembly

Namespaces

Namespace | Description
O2S.Components.PDF4NET |
O2S.Components.PDF4NET.Actions |
O2S.Components.PDF4NET.Annotations |
O2S.Components.PDF4NET.Converters |
O2S.Components.PDF4NET.Cos |
O2S.Components.PDF4NET.Forms |
O2S.Components.PDF4NET.Forms.XFA |
O2S.Components.PDF4NET.Functions |
O2S.Components.PDF4NET.Graphics |
O2S.Components.PDF4NET.Graphics.Barcodes |
O2S.Components.PDF4NET.Graphics.ColorSpaces |
O2S.Components.PDF4NET.Graphics.Fonts |
O2S.Components.PDF4NET.Graphics.Shapes |
O2S.Components.PDF4NET.Graphics.Shapes.Transparency |
O2S.Components.PDF4NET.PDFFile |
O2S.Components.PDF4NET.Security |
O2S.Components.PDF4NET.Text |


Getting Started - O2S.Components.PDF4NET

Getting Started


Introduction - O2S.Components.PDF4NET

Introduction


O2S.Components.PDF4NET Namespace

O2S.Components.PDF4NET Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
DisplayRectangle | Defines a rectangle in display coordinates, relative to top left corner of the page.
PDFBookmark | Defines a bookmark in a PDF file.
PDFBookmarkCollection | Defines a collection of bookmarks.
Generic PDFCollection | Defines a collection that fires notifications when it changes or when an item in the collection changes its properties.
PDFCustomProperties | Defines the custom properties that can be added to document.
PDFDestination | Defines the base class for PDF destinations.
PDFDirectDestination | Defines the base class direct PDF destinations.
PDFDocument | Represents a PDF document.
PDFDocumentAttachment | Defines a file embedded in a PDF document.
PDFDocumentAttachmentCollection | Defines a collection of annotations.
PDFDocumentInformation | Provides access to document metadata.
PDFDocumentLoadOptions | Provides several options for loading a PDF file.
PDFDocumentSaveOptions | Provides several options for loading a PDF file.
PDFException | Defines a generic PDF exception.
PDFGraphicsContainer | Defines an abstract object that can store graphic content.
PDFInvalidPasswordException | The exception that is thrown when the password supplied for opening the file is invalid.
PDFJavaScript | Defines a fragment of JavaScript code.
PDFJavaScriptCollection | Defines a collection of annotations.
PDFMetadataSchema | Defines a schema within the document's metadata
PDFMetadataSchemaCollection | Defines a collection of bookmarks.
PDFPage | Defines a page within the pdf document.
PDFPageBackground | Defines a background for a PDF page.
PDFPageCollection | Defines a collection of PDF pages.
PDFPageDestination | Defines a destination to a page within the current document.
PDFPageNumber | Defines the visual aspect of the page number when it is drawn on the page
PDFPageNumberingRange | Defines a series of consecutive pages within the PDF document using the same numbering system
PDFPageNumberingRangeCollection | Defines a collection of bookmarks.
PDFPoint | Represents a pair of floating point x- and y-coordinates that defines a point in a two-dimensional plane.
PDFRectangle | Defines a rectangle in PDF default coordinates, where the origin of the coordinate system is located in the bottom left corner of the page.
PDFRemotePageDestination | Defines a destination to a page in another PDF document.
PDFSeparationInfo | Defines the separation information for a PDF page.
PDFViewerPreferences | Defines the way the PDF document is displayed on the screen.
PDFXMPMetadata | Defines the XMP metadata for a PDF document.

Enumerations

Enumeration | Description
PDFBookmarkDisplayStyle | Specifies the available modes for displaying a bookmark in a viewer application.
PDFDisplayMode | Specifies the possible modes to be display the document when it is opened.
PDFMagnificationMode | Specifies the available zoom modes that can be applied when the PDF page specified in the destination is displayed.
PDFNumberingStyle | Specifies the available styles when setting up a page numbering range.
PDFPageLayout | Specifies the possible page layouts to be used when the document is opened.
PDFPageOrientation | Specifies the possible orientations for a page.
PDFPageSize | Specifies the predefined page sizes.
PDFPrintScaling | Specifies the available print scaling options.
PDFRotationMode | Specifies the available rotation modes for a PDF object.
PDFVersion | Specifies the available PDF versions to save a PDF document.

See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET Namespace Inheritance Hierarchy

O2S.Components.PDF4NET Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.DisplayRectangle
O2S.Components.PDF4NET.PDFBookmark
O2S.Components.PDF4NET.PDFCustomProperties
O2S.Components.PDF4NET.PDFDestination
O2S.Components.PDF4NET.PDFDirectDestination
O2S.Components.PDF4NET.PDFPageDestination
O2S.Components.PDF4NET.PDFRemotePageDestination
O2S.Components.PDF4NET.PDFDocument
O2S.Components.PDF4NET.PDFDocumentAttachment
O2S.Components.PDF4NET.PDFDocumentInformation
O2S.Components.PDF4NET.PDFDocumentLoadOptions
O2S.Components.PDF4NET.PDFDocumentSaveOptions
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.PDFPageBackground
O2S.Components.PDF4NET.PDFPage
O2S.Components.PDF4NET.PDFJavaScript
O2S.Components.PDF4NET.PDFMetadataSchema
O2S.Components.PDF4NET.PDFPageNumber
O2S.Components.PDF4NET.PDFPageNumberingRange
O2S.Components.PDF4NET.PDFPoint
O2S.Components.PDF4NET.PDFRectangle
O2S.Components.PDF4NET.PDFSeparationInfo
O2S.Components.PDF4NET.PDFViewerPreferences
O2S.Components.PDF4NET.PDFXMPMetadata
System.Collections.ObjectModel.Collection<PDFBookmark>
O2S.Components.PDF4NET.PDFCollection<PDFBookmark, PDFBookmark>
O2S.Components.PDF4NET.PDFBookmarkCollection
System.Collections.ObjectModel.Collection<PDFDocumentAttachment>
O2S.Components.PDF4NET.PDFCollection<PDFDocumentAttachment, PDFDocument>
O2S.Components.PDF4NET.PDFDocumentAttachmentCollection
System.Collections.ObjectModel.Collection<PDFJavaScript>
O2S.Components.PDF4NET.PDFCollection<PDFJavaScript, PDFDocument>
O2S.Components.PDF4NET.PDFJavaScriptCollection
System.Collections.ObjectModel.Collection<PDFMetadataSchema>
O2S.Components.PDF4NET.PDFCollection<PDFMetadataSchema, PDFDocument>
O2S.Components.PDF4NET.PDFMetadataSchemaCollection
System.Collections.ObjectModel.Collection<PDFPage>
O2S.Components.PDF4NET.PDFCollection<PDFPage, PDFDocument>
O2S.Components.PDF4NET.PDFPageCollection
System.Collections.ObjectModel.Collection<PDFPageNumberingRange>
O2S.Components.PDF4NET.PDFCollection<PDFPageNumberingRange, PDFDocument>
O2S.Components.PDF4NET.PDFPageNumberingRangeCollection
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection<T, K>
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFException
O2S.Components.PDF4NET.PDFInvalidPasswordException

See Also

Reference

O2S.Components.PDF4NET Assembly


DisplayRectangle Class

DisplayRectangle Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : DisplayRectangle Class

Defines a rectangle in display coordinates, relative to top left corner of the page.

Syntax

Visual Basic (Declaration)
Public Class DisplayRectangle
Visual Basic (Usage) Copy Code
Dim instance As DisplayRectangle
C#
public class DisplayRectangle
Managed Extensions for C++
public __gc class DisplayRectangle
C++/CLI
public ref class DisplayRectangle

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.DisplayRectangle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DisplayRectangle Members
O2S.Components.PDF4NET Namespace


DisplayRectangle Class Members

DisplayRectangle Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : DisplayRectangle Class

The following tables list the members exposed by DisplayRectangle.

Public Constructors

 | Name | Description
Public Constructor | DisplayRectangle Constructor | Overloaded. Initializes a new DisplayRectangle object.
Top

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the rectangle's height.
Public Property | Left | Gets or sets X coordinate of the top left corner.
Public Property | Top | Gets or sets Y coordinate of the top left corner.
Public Property | Width | Gets or sets the rectangle's width.
Top

Public Methods

 | Name | Description
Public Method | Intersects | Verifies if the given rectangle intersects this rectangle.
Public Method | ToString | Overridden. Converts the rectangle to string representation.
Top

See Also

Reference

DisplayRectangle Class
O2S.Components.PDF4NET Namespace


DisplayRectangle Constructor

DisplayRectangle Constructor
[image]
O2S.Components.PDF4NET Namespace > DisplayRectangle Class : DisplayRectangle Constructor

Initializes a new DisplayRectangle object.

Overload List

Overload | Description
DisplayRectangle Constructor() | Initializes a new DisplayRectangle object.
DisplayRectangle Constructor(Double,Double,Double,Double) | Initializes a new PDFRectangle object.
DisplayRectangle Constructor(RectangleF) | Initializes a new PDFRectangle object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


DisplayRectangle Constructor()

DisplayRectangle Constructor()
See Also
[image]
O2S.Components.PDF4NET Namespace > DisplayRectangle Class > DisplayRectangle Constructor : DisplayRectangle Constructor()

Initializes a new DisplayRectangle object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DisplayRectangle()
C#
public DisplayRectangle()
Managed Extensions for C++
public: DisplayRectangle();
C++/CLI
public:
DisplayRectangle();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members
Overload List


DisplayRectangle Constructor(Double,Double,Double,Double)

DisplayRectangle Constructor(Double,Double,Double,Double)
See Also
[image]
O2S.Components.PDF4NET Namespace > DisplayRectangle Class > DisplayRectangle Constructor : DisplayRectangle Constructor(Double,Double,Double,Double)

left
The x coordinate of the top left corner of the rectangle.
top
The y coordinate of the top left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
Initializes a new PDFRectangle object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

Dim instance As DisplayRectangle(left, top, width, height)
C#
public DisplayRectangle(
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: DisplayRectangle(
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
DisplayRectangle(
   double left,
   double top,
   double width,
   double height
)

Parameters

left
The x coordinate of the top left corner of the rectangle.
top
The y coordinate of the top left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members
Overload List


DisplayRectangle Constructor(RectangleF)

DisplayRectangle Constructor(RectangleF)
See Also
[image]
O2S.Components.PDF4NET Namespace > DisplayRectangle Class > DisplayRectangle Constructor : DisplayRectangle Constructor(RectangleF)

rectangle
Source rectangle.
Initializes a new PDFRectangle object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rectangle As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim rectangle As RectangleF

Dim instance As DisplayRectangle(rectangle)
C#
public DisplayRectangle(
   RectangleF rectangle
)
Managed Extensions for C++
public: DisplayRectangle(
   RectangleF rectangle
)
C++/CLI
public:
DisplayRectangle(
   RectangleF rectangle
)

Parameters

rectangle
Source rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members
Overload List


DisplayRectangle Class Methods

DisplayRectangle Class Methods
[image]
O2S.Components.PDF4NET Namespace : DisplayRectangle Class

For a list of all members of this type, see DisplayRectangle members.

Public Methods

 | Name | Description
Public Method | Intersects | Verifies if the given rectangle intersects this rectangle.
Public Method | ToString | Overridden. Converts the rectangle to string representation.
Top

See Also

Reference

DisplayRectangle Class
O2S.Components.PDF4NET Namespace


Intersects Method

Intersects Method
[image]
O2S.Components.PDF4NET Namespace > DisplayRectangle Class : Intersects Method

displayRect
The rectangle to intersect.
Verifies if the given rectangle intersects this rectangle.

Syntax

Visual Basic (Declaration)
Public Function Intersects( _
   ByVal displayRect As DisplayRectangle _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DisplayRectangle
Dim displayRect As DisplayRectangle
Dim value As Boolean

value = instance.Intersects(displayRect)
C#
public bool Intersects(
   DisplayRectangle displayRect
)
Managed Extensions for C++
public: bool Intersects(
   DisplayRectangle* displayRect
)
C++/CLI
public:
bool Intersects(
   DisplayRectangle^ displayRect
)

Parameters

displayRect
The rectangle to intersect.

Return Value

True if the rectangles intersect, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET Namespace > DisplayRectangle Class : ToString Method

Converts the rectangle to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DisplayRectangle
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


DisplayRectangle Class Properties

DisplayRectangle Class Properties
[image]
O2S.Components.PDF4NET Namespace : DisplayRectangle Class

For a list of all members of this type, see DisplayRectangle members.

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the rectangle's height.
Public Property | Left | Gets or sets X coordinate of the top left corner.
Public Property | Top | Gets or sets Y coordinate of the top left corner.
Public Property | Width | Gets or sets the rectangle's width.
Top

See Also

Reference

DisplayRectangle Class
O2S.Components.PDF4NET Namespace


Height Property

Height Property
[image]
O2S.Components.PDF4NET Namespace > DisplayRectangle Class : Height Property

Gets or sets the rectangle's height.

Syntax

Visual Basic (Declaration)
Public Property Height As Double
Visual Basic (Usage) Copy Code
Dim instance As DisplayRectangle
Dim value As Double

instance.Height = value

value = instance.Height
C#
public double Height {get; set;}
Managed Extensions for C++
public: __property double get_Height();
public: __property void set_Height(
   double value
);
C++/CLI
public:
property double Height {
   double get();
   void set (double value);
}

Return Value

The height of the rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


Left Property

Left Property
[image]
O2S.Components.PDF4NET Namespace > DisplayRectangle Class : Left Property

Gets or sets X coordinate of the top left corner.

Syntax

Visual Basic (Declaration)
Public Property Left As Double
Visual Basic (Usage) Copy Code
Dim instance As DisplayRectangle
Dim value As Double

instance.Left = value

value = instance.Left
C#
public double Left {get; set;}
Managed Extensions for C++
public: __property double get_Left();
public: __property void set_Left(
   double value
);
C++/CLI
public:
property double Left {
   double get();
   void set (double value);
}

Return Value

The X coordinate of the top left corner of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


Top Property

Top Property
[image]
O2S.Components.PDF4NET Namespace > DisplayRectangle Class : Top Property

Gets or sets Y coordinate of the top left corner.

Syntax

Visual Basic (Declaration)
Public Property Top As Double
Visual Basic (Usage) Copy Code
Dim instance As DisplayRectangle
Dim value As Double

instance.Top = value

value = instance.Top
C#
public double Top {get; set;}
Managed Extensions for C++
public: __property double get_Top();
public: __property void set_Top(
   double value
);
C++/CLI
public:
property double Top {
   double get();
   void set (double value);
}

Return Value

The Y coordinate of the top left corner of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


Width Property

Width Property
[image]
O2S.Components.PDF4NET Namespace > DisplayRectangle Class : Width Property

Gets or sets the rectangle's width.

Syntax

Visual Basic (Declaration)
Public Property Width As Double
Visual Basic (Usage) Copy Code
Dim instance As DisplayRectangle
Dim value As Double

instance.Width = value

value = instance.Width
C#
public double Width {get; set;}
Managed Extensions for C++
public: __property double get_Width();
public: __property void set_Width(
   double value
);
C++/CLI
public:
property double Width {
   double get();
   void set (double value);
}

Return Value

The width of the rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DisplayRectangle Class
DisplayRectangle Members


PDFBookmark Class

PDFBookmark Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFBookmark Class

Defines a bookmark in a PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFBookmark
Visual Basic (Usage) Copy Code
Dim instance As PDFBookmark
C#
public class PDFBookmark
Managed Extensions for C++
public __gc class PDFBookmark
C++/CLI
public ref class PDFBookmark

Remarks

The bookmarks have a tree structure that allows an easier navigation into the document. The bookmarks tree serves as a table of contents for the document.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFBookmark

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBookmark Members
O2S.Components.PDF4NET Namespace


PDFBookmark Class Members

PDFBookmark Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFBookmark Class

The following tables list the members exposed by PDFBookmark.

Public Constructors

 | Name | Description
Public Constructor | PDFBookmark Constructor | Initializes a new PDFBookmark object.
Top

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the action to be executed when the bookmark is clicked.
Public Property | Bookmarks | Gets the collection of child bookmarks.
Public Property | Color | Gets or sets the bookmark color.
Public Property | Dictionary | Gets the bookmark dictionary.
Public Property | DisplayStyle | Gets or sets the display style of this bookmark.
Public Property | Expanded | Gets or sets a value indicating whether the bookmark should be displayed in collapsed or expanded state.
Public Property | Parent | Gets the parent of this PDFBookmark object.
Public Property | Title | Gets or sets the title of this bookmark.
Top

See Also

Reference

PDFBookmark Class
O2S.Components.PDF4NET Namespace


PDFBookmark Constructor

PDFBookmark Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFBookmark Class : PDFBookmark Constructor

Initializes a new PDFBookmark object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFBookmark()
C#
public PDFBookmark()
Managed Extensions for C++
public: PDFBookmark();
C++/CLI
public:
PDFBookmark();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBookmark Class
PDFBookmark Members


PDFBookmark Class Properties

PDFBookmark Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFBookmark Class

For a list of all members of this type, see PDFBookmark members.

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the action to be executed when the bookmark is clicked.
Public Property | Bookmarks | Gets the collection of child bookmarks.
Public Property | Color | Gets or sets the bookmark color.
Public Property | Dictionary | Gets the bookmark dictionary.
Public Property | DisplayStyle | Gets or sets the display style of this bookmark.
Public Property | Expanded | Gets or sets a value indicating whether the bookmark should be displayed in collapsed or expanded state.
Public Property | Parent | Gets the parent of this PDFBookmark object.
Public Property | Title | Gets or sets the title of this bookmark.
Top

See Also

Reference

PDFBookmark Class
O2S.Components.PDF4NET Namespace


Action Property

Action Property
[image]
O2S.Components.PDF4NET Namespace > PDFBookmark Class : Action Property

Gets or sets the action to be executed when the bookmark is clicked.

Syntax

Visual Basic (Declaration)
Public Property Action As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFBookmark
Dim value As PDFAction

instance.Action = value

value = instance.Action
C#
public PDFAction Action {get; set;}
Managed Extensions for C++
public: __property PDFAction* get_Action();
public: __property void set_Action(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ Action {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

The action to execute when the bookmark is selected by the user.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBookmark Class
PDFBookmark Members


Bookmarks Property

Bookmarks Property
[image]
O2S.Components.PDF4NET Namespace > PDFBookmark Class : Bookmarks Property

Gets the collection of child bookmarks.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bookmarks As PDFBookmarkCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFBookmark
Dim value As PDFBookmarkCollection

value = instance.Bookmarks
C#
public PDFBookmarkCollection Bookmarks {get;}
Managed Extensions for C++
public: __property PDFBookmarkCollection* get_Bookmarks();
C++/CLI
public:
property PDFBookmarkCollection^ Bookmarks {
   PDFBookmarkCollection^ get();
}

Return Value

A PDFBookmarkCollection object with the list of child bookmarks.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBookmark Class
PDFBookmark Members


Color Property

Color Property
[image]
O2S.Components.PDF4NET Namespace > PDFBookmark Class : Color Property

Gets or sets the bookmark color.

Syntax

Visual Basic (Declaration)
Public Property Color As PDFRgbColor
Visual Basic (Usage) Copy Code
Dim instance As PDFBookmark
Dim value As PDFRgbColor

instance.Color = value

value = instance.Color
C#
public PDFRgbColor Color {get; set;}
Managed Extensions for C++
public: __property PDFRgbColor* get_Color();
public: __property void set_Color(
   PDFRgbColor* value
);
C++/CLI
public:
property PDFRgbColor^ Color {
   PDFRgbColor^ get();
   void set (PDFRgbColor^ value);
}

Return Value

The color of the bookmark.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBookmark Class
PDFBookmark Members


Dictionary Property

Dictionary Property
[image]
O2S.Components.PDF4NET Namespace > PDFBookmark Class : Dictionary Property

Gets the bookmark dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dictionary As PDFDictionary
Visual Basic (Usage) Copy Code
Dim instance As PDFBookmark
Dim value As PDFDictionary

value = instance.Dictionary
C#
public PDFDictionary Dictionary {get;}
Managed Extensions for C++
public: __property PDFDictionary* get_Dictionary();
C++/CLI
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Return Value

The raw bookmark dictionary.

Remarks

This property gives you direct access to bookmark dictionary and its associated resources. Note: Modifying directly the bookmark dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBookmark Class
PDFBookmark Members


DisplayStyle Property

DisplayStyle Property
[image]
O2S.Components.PDF4NET Namespace > PDFBookmark Class : DisplayStyle Property

Gets or sets the display style of this bookmark.

Syntax

Visual Basic (Declaration)
Public Property DisplayStyle As PDFBookmarkDisplayStyle
Visual Basic (Usage) Copy Code
Dim instance As PDFBookmark
Dim value As PDFBookmarkDisplayStyle

instance.DisplayStyle = value

value = instance.DisplayStyle
C#
public PDFBookmarkDisplayStyle DisplayStyle {get; set;}
Managed Extensions for C++
public: __property PDFBookmarkDisplayStyle get_DisplayStyle();
public: __property void set_DisplayStyle(
   PDFBookmarkDisplayStyle value
);
C++/CLI
public:
property PDFBookmarkDisplayStyle DisplayStyle {
   PDFBookmarkDisplayStyle get();
   void set (PDFBookmarkDisplayStyle value);
}

Return Value

The bookmark's display style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBookmark Class
PDFBookmark Members


Expanded Property

Expanded Property
[image]
O2S.Components.PDF4NET Namespace > PDFBookmark Class : Expanded Property

Gets or sets a value indicating whether the bookmark should be displayed in collapsed or expanded state.

Syntax

Visual Basic (Declaration)
Public Property Expanded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFBookmark
Dim value As Boolean

instance.Expanded = value

value = instance.Expanded
C#
public bool Expanded {get; set;}
Managed Extensions for C++
public: __property bool get_Expanded();
public: __property void set_Expanded(
   bool value
);
C++/CLI
public:
property bool Expanded {
   bool get();
   void set (bool value);
}

Return Value

True if the bookmark should be displayed in expanded state, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBookmark Class
PDFBookmark Members


Parent Property

Parent Property
[image]
O2S.Components.PDF4NET Namespace > PDFBookmark Class : Parent Property

Gets the parent of this PDFBookmark object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As PDFBookmark
Visual Basic (Usage) Copy Code
Dim instance As PDFBookmark
Dim value As PDFBookmark

value = instance.Parent
C#
public PDFBookmark Parent {get;}
Managed Extensions for C++
public: __property PDFBookmark* get_Parent();
C++/CLI
public:
property PDFBookmark^ Parent {
   PDFBookmark^ get();
}

Return Value

The parent bookmark.

Remarks

If the parent bookmark is null, the bookmark is a top level bookmark.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBookmark Class
PDFBookmark Members


Title Property

Title Property
[image]
O2S.Components.PDF4NET Namespace > PDFBookmark Class : Title Property

Gets or sets the title of this bookmark.

Syntax

Visual Basic (Declaration)
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As PDFBookmark
Dim value As String

instance.Title = value

value = instance.Title
C#
public string Title {get; set;}
Managed Extensions for C++
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
C++/CLI
public:
property String^ Title {
   String^ get();
   void set (String^ value);
}

Return Value

The bookmark title.

Remarks

The title is displayed by the viewer application in the bookmarks tree.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBookmark Class
PDFBookmark Members


PDFBookmarkCollection Class

PDFBookmarkCollection Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFBookmarkCollection Class

Defines a collection of bookmarks.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFBookmarkCollection
   Inherits PDFCollection(Of PDFBookmark, PDFBookmark)
Visual Basic (Usage) Copy Code
Dim instance As PDFBookmarkCollection
C#
public class PDFBookmarkCollection : PDFCollection<PDFBookmark, PDFBookmark>
Managed Extensions for C++
public __gc class PDFBookmarkCollection : public PDFCollection<PDFBookmark, PDFBookmark>
C++/CLI
public ref class PDFBookmarkCollection : public PDFCollection<PDFBookmark, PDFBookmark>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<PDFBookmark>
O2S.Components.PDF4NET.PDFCollection<PDFBookmark, PDFBookmark>
O2S.Components.PDF4NET.PDFBookmarkCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBookmarkCollection Members
O2S.Components.PDF4NET Namespace


PDFBookmarkCollection Class Members

PDFBookmarkCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFBookmarkCollection Class

The following tables list the members exposed by PDFBookmarkCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Creates a new bookmark and adds it at the end of the collection.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Top

See Also

Reference

PDFBookmarkCollection Class
O2S.Components.PDF4NET Namespace


PDFBookmarkCollection Class Methods

PDFBookmarkCollection Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFBookmarkCollection Class

For a list of all members of this type, see PDFBookmarkCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Creates a new bookmark and adds it at the end of the collection.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Top

See Also

Reference

PDFBookmarkCollection Class
O2S.Components.PDF4NET Namespace


Add Method

Add Method
[image]
O2S.Components.PDF4NET Namespace > PDFBookmarkCollection Class : Add Method

Creates a new bookmark and adds it at the end of the collection.

Overload List

Overload | Description
Add(String,PDFRgbColor,Boolean,PDFBookmarkDisplayStyle,PDFPage,Double) | Creates a new bookmark and adds it at the end of the collection.
Add(PDFBookmark) | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBookmarkCollection Class
PDFBookmarkCollection Members


Add(String,PDFRgbColor,Boolean,PDFBookmarkDisplayStyle,PDFPage,Double) Method

Add(String,PDFRgbColor,Boolean,PDFBookmarkDisplayStyle,PDFPage,Double) Method
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFBookmarkCollection Class > Add Method : Add(String,PDFRgbColor,Boolean,PDFBookmarkDisplayStyle,PDFPage,Double) Method

title
the title of the bookmark
bookmarkColor
a PDFRgbColor object specifying the color used to draw the bookmark in the bookmark tree.
expanded
specifies whether the bookmark should be displayed expanded or collapsed the tree when the document is open.
displayStyle
a combination of PDFBookmarkDisplayStyle enumeration members, specifying the font style used to draw the bookmark title.
destinationPage
a PDFPage object representing the destination of the bookmark.
topDestination
the vertical position of the destination page when it is displayed as the result of using the bookmark.
Creates a new bookmark and adds it at the end of the collection.

Syntax

Visual Basic (Declaration)
Overloads Public Function Add( _
   ByVal title As String, _
   ByVal bookmarkColor As PDFRgbColor, _
   ByVal expanded As Boolean, _
   ByVal displayStyle As PDFBookmarkDisplayStyle, _
   ByVal destinationPage As PDFPage, _
   ByVal topDestination As Double _
) As PDFBookmark
Visual Basic (Usage) Copy Code
Dim instance As PDFBookmarkCollection
Dim title As String
Dim bookmarkColor As PDFRgbColor
Dim expanded As Boolean
Dim displayStyle As PDFBookmarkDisplayStyle
Dim destinationPage As PDFPage
Dim topDestination As Double
Dim value As PDFBookmark

value = instance.Add(title, bookmarkColor, expanded, displayStyle, destinationPage, topDestination)
C#
public PDFBookmark Add(
   string title,
   PDFRgbColor bookmarkColor,
   bool expanded,
   PDFBookmarkDisplayStyle displayStyle,
   PDFPage destinationPage,
   double topDestination
)
Managed Extensions for C++
public: PDFBookmark* Add(
   string* title,
   PDFRgbColor* bookmarkColor,
   bool expanded,
   PDFBookmarkDisplayStyle displayStyle,
   PDFPage* destinationPage,
   double topDestination
)
C++/CLI
public:
PDFBookmark^ Add(
   String^ title,
   PDFRgbColor^ bookmarkColor,
   bool expanded,
   PDFBookmarkDisplayStyle displayStyle,
   PDFPage^ destinationPage,
   double topDestination
)

Parameters

title
the title of the bookmark
bookmarkColor
a PDFRgbColor object specifying the color used to draw the bookmark in the bookmark tree.
expanded
specifies whether the bookmark should be displayed expanded or collapsed the tree when the document is open.
displayStyle
a combination of PDFBookmarkDisplayStyle enumeration members, specifying the font style used to draw the bookmark title.
destinationPage
a PDFPage object representing the destination of the bookmark.
topDestination
the vertical position of the destination page when it is displayed as the result of using the bookmark.

Return Value

a PDFBookmark object representing the newly created bookmark.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBookmarkCollection Class
PDFBookmarkCollection Members
Overload List


Generic PDFCollection Class

T
The type of the collection items.
K
The type of the collection parent.
O2S.Components.PDF4NET Send comments on this topic.
Generic PDFCollection Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : Generic PDFCollection Class

Defines a collection that fires notifications when it changes or when an item in the collection changes its properties.

Syntax

Visual Basic (Declaration)
Public Class PDFCollection
     (Of T,K)
   Inherits Collection(Of T)
Visual Basic (Usage) Copy Code
Dim instance As PDFCollection(Of T,K)
C#
public class PDFCollection<T,K> : Collection<T>
Managed Extensions for C++
public __gc class PDFCollection<T,K> : public Collection<T>
C++/CLI
generic<typename T>
generic<typename K>
public ref class PDFCollection : public Collection<T>

Type Parameters

T
The type of the collection items.
K
The type of the collection parent.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
O2S.Components.PDF4NET.PDFCollection
O2S.Components.PDF4NET.PDFPageNumberingRangeCollection
O2S.Components.PDF4NET.PDFPageCollection
O2S.Components.PDF4NET.PDFMetadataSchemaCollection
O2S.Components.PDF4NET.PDFJavaScriptCollection
O2S.Components.PDF4NET.PDFDocumentAttachmentCollection
O2S.Components.PDF4NET.PDFBookmarkCollection
O2S.Components.PDF4NET.Graphics.PDFLayerCollection
O2S.Components.PDF4NET.Forms.XFDFFieldCollection
O2S.Components.PDF4NET.Forms.XFA.XFAListItemCollection
O2S.Components.PDF4NET.Forms.PDFListItemCollection
O2S.Components.PDF4NET.Forms.PDFFieldWidgetCollection
O2S.Components.PDF4NET.Forms.PDFFieldCollection
O2S.Components.PDF4NET.Forms.FDFFieldCollection
O2S.Components.PDF4NET.Annotations.PDFPointsCollection
O2S.Components.PDF4NET.Annotations.PDFAnnotationCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic PDFCollection Members
O2S.Components.PDF4NET Namespace


Generic PDFCollection Class Members

Generic PDFCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : Generic PDFCollection Class

The following tables list the members exposed by Generic PDFCollection.

Public Constructors

 | Name | Description
Public Constructor | PDFCollection Constructor | Initializes a new PDFCollection object.
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<T>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<T>)
Top

See Also

Reference

Generic PDFCollection Class
O2S.Components.PDF4NET Namespace


PDFCollection Constructor

PDFCollection Constructor
[image]
O2S.Components.PDF4NET Namespace > Generic PDFCollection Class : PDFCollection Constructor

parent
The object that owns the collection.
Initializes a new PDFCollection object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parent As K _
)
Visual Basic (Usage) Copy Code
Dim parent As K

Dim instance As PDFCollection(Of T,K)(parent)
C#
public Generic PDFCollection(
   K parent
)
Managed Extensions for C++
public: Generic PDFCollection(
   K parent
)
C++/CLI
public:
Generic PDFCollection(
   K parent
)

Parameters

parent
The object that owns the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic PDFCollection Class
Generic PDFCollection Members


PDFCustomProperties Class

PDFCustomProperties Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFCustomProperties Class

Defines the custom properties that can be added to document.

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PDFCustomProperties
Visual Basic (Usage) Copy Code
Dim instance As PDFCustomProperties
C#
[DefaultMemberAttribute("Item")]
public class PDFCustomProperties
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class PDFCustomProperties
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFCustomProperties

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFCustomProperties

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCustomProperties Members
O2S.Components.PDF4NET Namespace


PDFCustomProperties Class Members

PDFCustomProperties Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFCustomProperties Class

The following tables list the members exposed by PDFCustomProperties.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of custom properties.
Public Property | Item |
Public Property | Properties | Gets the list of custom properties.
Top

See Also

Reference

PDFCustomProperties Class
O2S.Components.PDF4NET Namespace


PDFCustomProperties Class Properties

PDFCustomProperties Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFCustomProperties Class

For a list of all members of this type, see PDFCustomProperties members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of custom properties.
Public Property | Item |
Public Property | Properties | Gets the list of custom properties.
Top

See Also

Reference

PDFCustomProperties Class
O2S.Components.PDF4NET Namespace


Count Property

Count Property
[image]
O2S.Components.PDF4NET Namespace > PDFCustomProperties Class : Count Property

Gets the number of custom properties.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFCustomProperties
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Return Value

The number of the custom properties.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCustomProperties Class
PDFCustomProperties Members


Item Property

Item Property
[image]
O2S.Components.PDF4NET Namespace > PDFCustomProperties Class : Item Property

propertyName

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal propertyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PDFCustomProperties
Dim propertyName As String
Dim value As String

instance.Item(propertyName) = value

value = instance.Item(propertyName)
C#
public string this[
   string propertyName
]; {get; set;}
Managed Extensions for C++
public: __property string* get_Item(
   string* propertyName
);
public: __property void set_Item(
   string* propertyName,
   string* value
);
C++/CLI
public:
property String^ default [String^] {
   String^ get(String^ propertyName);
   void set (String^ propertyName, String^ value);
}

Parameters

propertyName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCustomProperties Class
PDFCustomProperties Members


Properties Property

Properties Property
[image]
O2S.Components.PDF4NET Namespace > PDFCustomProperties Class : Properties Property

Gets the list of custom properties.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Properties As String()
Visual Basic (Usage) Copy Code
Dim instance As PDFCustomProperties
Dim value() As String

value = instance.Properties
C#
public string[] Properties {get;}
Managed Extensions for C++
public: __property string*[]* get_Properties();
C++/CLI
public:
property array<String^>^ Properties {
   array<String^>^ get();
}

Return Value

An array of strings representing the names of the custom properties.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCustomProperties Class
PDFCustomProperties Members


PDFDestination Class

PDFDestination Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFDestination Class

Defines the base class for PDF destinations.

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFDestination
Visual Basic (Usage) Copy Code
Dim instance As PDFDestination
C#
public abstract class PDFDestination
Managed Extensions for C++
public __gc abstract class PDFDestination
C++/CLI
public ref class PDFDestination abstract

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDestination
O2S.Components.PDF4NET.PDFDirectDestination

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDestination Members
O2S.Components.PDF4NET Namespace


PDFDestination Class Members

PDFDestination Class Members
[image]
O2S.Components.PDF4NET Namespace : PDFDestination Class

The following tables list the members exposed by PDFDestination.

Public Constructors

 | Name | Description
Public Constructor | PDFDestination Constructor | Initializes a new PDFDestination object.
Top

See Also

Reference

PDFDestination Class
O2S.Components.PDF4NET Namespace


PDFDestination Constructor

PDFDestination Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFDestination Class : PDFDestination Constructor

Initializes a new PDFDestination object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDestination()
C#
public PDFDestination()
Managed Extensions for C++
public: PDFDestination();
C++/CLI
public:
PDFDestination();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDestination Class
PDFDestination Members


PDFDirectDestination Class

PDFDirectDestination Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFDirectDestination Class

Defines the base class direct PDF destinations.

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFDirectDestination
   Inherits PDFDestination
Visual Basic (Usage) Copy Code
Dim instance As PDFDirectDestination
C#
public abstract class PDFDirectDestination : PDFDestination
Managed Extensions for C++
public __gc abstract class PDFDirectDestination : public PDFDestination
C++/CLI
public ref class PDFDirectDestination abstract : public PDFDestination

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDestination
O2S.Components.PDF4NET.PDFDirectDestination
O2S.Components.PDF4NET.PDFRemotePageDestination
O2S.Components.PDF4NET.PDFPageDestination

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDirectDestination Members
O2S.Components.PDF4NET Namespace


PDFDirectDestination Class Members

PDFDirectDestination Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDirectDestination Class

The following tables list the members exposed by PDFDirectDestination.

Public Constructors

 | Name | Description
Public Constructor | PDFDirectDestination Constructor | Initializes a new PDFDirectDestination object.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate in the page where the viewer should display the page.
Public Property | Left | Gets or sets the left coordinate in the page where the viewer should display the page.
Public Property | MagnificationMode | Gets or sets the magnification mode.
Public Property | Right | Gets or sets the right coordinate in the page where the viewer should display the page.
Public Property | Top | Gets or sets the top coordinate in the page where the viewer should display the page.
Public Property | Zoom | Gets or sets the zoom factor to be used when the page is displayed.
Top

See Also

Reference

PDFDirectDestination Class
O2S.Components.PDF4NET Namespace


PDFDirectDestination Constructor

PDFDirectDestination Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFDirectDestination Class : PDFDirectDestination Constructor

Initializes a new PDFDirectDestination object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDirectDestination()
C#
public PDFDirectDestination()
Managed Extensions for C++
public: PDFDirectDestination();
C++/CLI
public:
PDFDirectDestination();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDirectDestination Class
PDFDirectDestination Members


PDFDirectDestination Class Properties

PDFDirectDestination Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDirectDestination Class

For a list of all members of this type, see PDFDirectDestination members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate in the page where the viewer should display the page.
Public Property | Left | Gets or sets the left coordinate in the page where the viewer should display the page.
Public Property | MagnificationMode | Gets or sets the magnification mode.
Public Property | Right | Gets or sets the right coordinate in the page where the viewer should display the page.
Public Property | Top | Gets or sets the top coordinate in the page where the viewer should display the page.
Public Property | Zoom | Gets or sets the zoom factor to be used when the page is displayed.
Top

See Also

Reference

PDFDirectDestination Class
O2S.Components.PDF4NET Namespace


Bottom Property

Bottom Property
[image]
O2S.Components.PDF4NET Namespace > PDFDirectDestination Class : Bottom Property

Gets or sets the bottom coordinate in the page where the viewer should display the page.

Syntax

Visual Basic (Declaration)
Public Property Bottom As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFDirectDestination
Dim value As Double

instance.Bottom = value

value = instance.Bottom
C#
public double Bottom {get; set;}
Managed Extensions for C++
public: __property double get_Bottom();
public: __property void set_Bottom(
   double value
);
C++/CLI
public:
property double Bottom {
   double get();
   void set (double value);
}

Return Value

A double value specifying the bottom coordinate in the page where the viewer should display the page.

Remarks

When the destination page of this action is displayed, the viewer will try to display the page at the given coordinate. It is relative to the top of the page.
This value is used by the following magnification modes: FitR

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDirectDestination Class
PDFDirectDestination Members


Left Property

Left Property
[image]
O2S.Components.PDF4NET Namespace > PDFDirectDestination Class : Left Property

Gets or sets the left coordinate in the page where the viewer should display the page.

Syntax

Visual Basic (Declaration)
Public Property Left As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFDirectDestination
Dim value As Double

instance.Left = value

value = instance.Left
C#
public double Left {get; set;}
Managed Extensions for C++
public: __property double get_Left();
public: __property void set_Left(
   double value
);
C++/CLI
public:
property double Left {
   double get();
   void set (double value);
}

Return Value

A double value specifying the left coordinate in the page where the viewer should display the page.

Remarks

When the destination page is displayed, the viewer will try to display the page at the given coordinate. This value is relative to the left margin of the page, 0 value meaning that the page will be displayed starting from its left margin.
A -1 value for this property means that the current left coordinate used by the viewer will not be changed when dispaying the page.
This value is used by the following magnification modes: XYZ, FitV, FitR, FitBV

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDirectDestination Class
PDFDirectDestination Members


MagnificationMode Property

MagnificationMode Property
[image]
O2S.Components.PDF4NET Namespace > PDFDirectDestination Class : MagnificationMode Property

Gets or sets the magnification mode.

Syntax

Visual Basic (Declaration)
Public Property MagnificationMode As PDFMagnificationMode
Visual Basic (Usage) Copy Code
Dim instance As PDFDirectDestination
Dim value As PDFMagnificationMode

instance.MagnificationMode = value

value = instance.MagnificationMode
C#
public PDFMagnificationMode MagnificationMode {get; set;}
Managed Extensions for C++
public: __property PDFMagnificationMode get_MagnificationMode();
public: __property void set_MagnificationMode(
   PDFMagnificationMode value
);
C++/CLI
public:
property PDFMagnificationMode MagnificationMode {
   PDFMagnificationMode get();
   void set (PDFMagnificationMode value);
}

Return Value

The zoom mode to be applied when the destination is displayed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDirectDestination Class
PDFDirectDestination Members


Right Property

Right Property
[image]
O2S.Components.PDF4NET Namespace > PDFDirectDestination Class : Right Property

Gets or sets the right coordinate in the page where the viewer should display the page.

Syntax

Visual Basic (Declaration)
Public Property Right As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFDirectDestination
Dim value As Double

instance.Right = value

value = instance.Right
C#
public double Right {get; set;}
Managed Extensions for C++
public: __property double get_Right();
public: __property void set_Right(
   double value
);
C++/CLI
public:
property double Right {
   double get();
   void set (double value);
}

Return Value

A double value specifying the right coordinate in the page where the viewer should display the page.

Remarks

When the destination page of this action is displayed, the viewer will try to display the page at the given coordinate.
This value is used by the following magnification modes: FitR

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDirectDestination Class
PDFDirectDestination Members


Top Property

Top Property
[image]
O2S.Components.PDF4NET Namespace > PDFDirectDestination Class : Top Property

Gets or sets the top coordinate in the page where the viewer should display the page.

Syntax

Visual Basic (Declaration)
Public Property Top As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFDirectDestination
Dim value As Double

instance.Top = value

value = instance.Top
C#
public double Top {get; set;}
Managed Extensions for C++
public: __property double get_Top();
public: __property void set_Top(
   double value
);
C++/CLI
public:
property double Top {
   double get();
   void set (double value);
}

Return Value

A double value specifying the top coordinate in the page where the viewer should display the page.

Remarks

When the destination page is displayed, the viewer will try to display the page at the given coordinate. This value is relative to the top of the page, 0 value meaning that the top of the page will be displayed.
A -1 value for this property means that the current top coordinate used by the viewer will not be changed when dispaying the page.
This value is used by the following magnification modes: XYZ, FitH, FitR, FitBH

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDirectDestination Class
PDFDirectDestination Members


Zoom Property

Zoom Property
[image]
O2S.Components.PDF4NET Namespace > PDFDirectDestination Class : Zoom Property

Gets or sets the zoom factor to be used when the page is displayed.

Syntax

Visual Basic (Declaration)
Public Property Zoom As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFDirectDestination
Dim value As Double

instance.Zoom = value

value = instance.Zoom
C#
public double Zoom {get; set;}
Managed Extensions for C++
public: __property double get_Zoom();
public: __property void set_Zoom(
   double value
);
C++/CLI
public:
property double Zoom {
   double get();
   void set (double value);
}

Return Value

A double value specifying the zoom factor to be used when the page is displayed.

Remarks

When the destination page is displayed, it will be magnified using the zoom factor specified by this property. This value is used only in conjunction with PDFMagnificationMode.XYZ magnification mode ( see PDFMagnificationMode enumeration) and it is given as percents (100 means 100% zoom).
A 0 value for this property means that the current zoom factor used by the viewer will not be changed when displaying the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDirectDestination Class
PDFDirectDestination Members


PDFDocument Class

PDFDocument Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFDocument Class

Represents a PDF document.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFDocument
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
C#
public class PDFDocument
Managed Extensions for C++
public __gc class PDFDocument
C++/CLI
public ref class PDFDocument

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDocument

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Members
O2S.Components.PDF4NET Namespace


PDFDocument Class Members

PDFDocument Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFDocument Class

The following tables list the members exposed by PDFDocument.

Public Constructors

 | Name | Description
Public Constructor | PDFDocument Constructor | Overloaded. Initializes a new PDFDocument object. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | AfterPrintAction | Gets or sets the javascript action to execute after the document is printed.
Public Property | AfterSaveAction | Gets or sets the javascript action to execute after the document is saved.
Public Property | Attachments | Gets the list of file attachments embedded in this document.
Public Property | BeforeCloseAction | Gets or sets the javascript action to execute before the document is closed.
Public Property | BeforePrintAction | Gets or sets the javascript action to execute before the document is printed.
Public Property | BeforeSaveAction | Gets or sets the javascript action to execute before the document is saved.
Public Property | Bookmarks | Gets the list of bookmarks in the PDF document.
Public Property | Dictionary | Gets the document catalog dictionary.
Public Property | DisplayMode | Gets or sets how the document should be displayed when opened in the viewer.
Public Property | DocumentInformation | Gets or sets the document information.
Public Property | Form | Gets the PDF form included in the document.
Public Property | ID | Gets the document ID.
Public Property | JavaScripts | Gets the list of global JavaScript actions associated with this document.
Public Property | Metadata | Gets the XMP metadata for this PDFDocument object.
Public Property | OpenAction | Gets or sets the action to execute when the document is opened.
Public Property | PageHeight | Gets or sets the default page height.
Public Property | PageLayout | Gets or sets the document's page layout specifying how the pages should be displayed when opened.
Public Property | PageNumber | Gets or sets the default page number visual aspect for this PDFDocument object.
Public Property | PageNumberingRanges | Gets the list of page numbering ranges in the PDF document.
Public Property | PageOrientation | Gets or sets the default page orientation.
Public Property | Pages | Gets the document's collection of pages.
Public Property | PageSize | Gets or sets the default page size.
Public Property | PageWidth | Gets or sets the default page width.
Public Property | PDFVersion | Gets or sets the PDF version of this PDFDocument object.
Public Property | SecurityManager | Gets or sets the security manager for this pdf document.
Public Property | SerialNumber | Sets the serial number and unlocks the component.
Public Property | ViewerPreferences | Gets or sets the document's viewer preferences.
Public Property | XFAForm | Gets the XFA form associated with this document.
Top

Public Methods

 | Name | Description
Public Method | AddPage | Creates a new page and adds it as the last page of the document
Public Method | BeginSave | Begins to save the document.
Public Method | Dispose | Disposes the internal resources.
Public Method | EndSave | Finishes a partial save operation.
Public Method | GetPDFAsByteArray | Gets the pdf file as a byte array.
Public Method | Save | Overloaded. Saves the PDF document to a file.
Public Method | SavePage | Saves the specified page.
Public Method | SavePageContent | Saves the content of the specified page.
Top

See Also

Reference

PDFDocument Class
O2S.Components.PDF4NET Namespace


PDFDocument Constructor

PDFDocument Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PDFDocument Constructor

Initializes a new PDFDocument object.

Supported by Compact .NET Edition.

Overload List

Overload | Description
PDFDocument Constructor() | Initializes a new PDFDocument object. Supported by Compact .NET Edition.
PDFDocument Constructor(Stream) | Initializes a new PDFDocument object based on an existing pdf document.
PDFDocument Constructor(Stream,Byte[]) | Initializes a new PDFDocument object based on an existing pdf document.
PDFDocument Constructor(Stream,PDFDocumentLoadOptions) | Initializes a new PDFDocument object based on an existing pdf document.
PDFDocument Constructor(String) | Initializes a new PDFDocument object based on an existing pdf document.
PDFDocument Constructor(String,Byte[]) | Initializes a new PDFDocument object based on an existing pdf document.
PDFDocument Constructor(String,PDFDocumentLoadOptions) | Initializes a new PDFDocument object based on an existing pdf document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


PDFDocument Constructor()

PDFDocument Constructor()
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor()

Initializes a new PDFDocument object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument()
C#
public PDFDocument()
Managed Extensions for C++
public: PDFDocument();
C++/CLI
public:
PDFDocument();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


PDFDocument Constructor(Stream)

PDFDocument Constructor(Stream)
See Also Example
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor(Stream)

stream
a Stream descendant storing the pdf file used as source for creating this PDFDocument object.
Initializes a new PDFDocument object based on an existing pdf document.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As PDFDocument(stream)
C#
public PDFDocument(
   Stream stream
)
Managed Extensions for C++
public: PDFDocument(
   Stream* stream
)
C++/CLI
public:
PDFDocument(
   Stream^ stream
)

Parameters

stream
a Stream descendant storing the pdf file used as source for creating this PDFDocument object.

Exceptions

Exception | Description
PDFParserException | thrown when the input pdf document can not be parsed for import.

Example

The following sample code shows how to add new content to an existing pdf file. It draws a line on top of the first page of the imported document.
C# Copy Code
MemoryStream pdfStream = new MemoryStream( );
// load the pdf file into the stream
...
PDFDocument doc = new PDFDocument( pdfStream );
PDFPen pen = new PDFPen( );
doc.Pages[0].Canvas.DrawLine( pen, 0, 0, doc.Pages[0].Width, doc.Pages[0].Height );
doc.SaveToFile( "new.pdf" );
...

Remarks

This constructor imports an existing pdf file into the document object. It automatically populates the Pages collection with the pages of the given document. After the document object has been created, it can be used as any regular document object. New content can be added to imported pages (the new content is drawn on top of existing content) or to new pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


PDFDocument Constructor(Stream,Byte[])

PDFDocument Constructor(Stream,Byte[])
See Also Example
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor(Stream,Byte[])

stream
a Stream descendant storing the pdf file used as source for creating this PDFDocument object.
password
the user or owner password used to decrypt the PDF file.
Initializes a new PDFDocument object based on an existing pdf document.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal password() As Byte _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim password() As Byte

Dim instance As PDFDocument(stream, password)
C#
public PDFDocument(
   Stream stream,
   byte[] password
)
Managed Extensions for C++
public: PDFDocument(
   Stream* stream,
   byte[]* password
)
C++/CLI
public:
PDFDocument(
   Stream^ stream,
   array<byte>^ password
)

Parameters

stream
a Stream descendant storing the pdf file used as source for creating this PDFDocument object.
password
the user or owner password used to decrypt the PDF file.

Exceptions

Exception | Description
PDFParserException | thrown when the input pdf document can not be parsed for import or the given password is invalid.

Example

The following sample code shows how to add new content to an existing pdf file. It draws a line on top of the first page of the imported document.
C# Copy Code
MemoryStream pdfStream = new MemoryStream( );
// load the pdf file into the stream
...
PDFDocument doc = new PDFDocument( pdfStream );
PDFPen pen = new PDFPen( );
doc.Pages[0].Canvas.DrawLine( pen, 0, 0, doc.Pages[0].Width, doc.Pages[0].Height );
doc.SaveToFile( "new.pdf" );
...

Remarks

This constructor imports an existing pdf file into the document object. It automatically populates the Pages collection with the pages of the given document. After the document object has been created, it can be used as any regular document object. New content can be added to imported pages (the new content is drawn on top of existing content) or to new pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


PDFDocument Constructor(Stream,PDFDocumentLoadOptions)

PDFDocument Constructor(Stream,PDFDocumentLoadOptions)
See Also Example
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor(Stream,PDFDocumentLoadOptions)

stream
a Stream descendant storing the pdf file used as source for creating this PDFDocument object.
loadOptions
options for loading the PDF file.
Initializes a new PDFDocument object based on an existing pdf document.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal loadOptions As PDFDocumentLoadOptions _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim loadOptions As PDFDocumentLoadOptions

Dim instance As PDFDocument(stream, loadOptions)
C#
public PDFDocument(
   Stream stream,
   PDFDocumentLoadOptions loadOptions
)
Managed Extensions for C++
public: PDFDocument(
   Stream* stream,
   PDFDocumentLoadOptions* loadOptions
)
C++/CLI
public:
PDFDocument(
   Stream^ stream,
   PDFDocumentLoadOptions^ loadOptions
)

Parameters

stream
a Stream descendant storing the pdf file used as source for creating this PDFDocument object.
loadOptions
options for loading the PDF file.

Exceptions

Exception | Description
PDFParserException | thrown when the input pdf document can not be parsed for import or the given password is invalid.

Example

The following sample code shows how to add new content to an existing pdf file. It draws a line on top of the first page of the imported document.
C# Copy Code
MemoryStream pdfStream = new MemoryStream( );
// load the pdf file into the stream
...
PDFDocument doc = new PDFDocument( pdfStream );
PDFPen pen = new PDFPen( );
doc.Pages[0].Canvas.DrawLine( pen, 0, 0, doc.Pages[0].Width, doc.Pages[0].Height );
doc.SaveToFile( "new.pdf" );
...

Remarks

This constructor imports an existing pdf file into the document object. It automatically populates the Pages collection with the pages of the given document. After the document object has been created, it can be used as any regular document object. New content can be added to imported pages (the new content is drawn on top of existing content) or to new pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


PDFDocument Constructor(String)

PDFDocument Constructor(String)
See Also Example
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor(String)

pdfFile
path to pdf file used as source for creating this PDFDocument object.
Initializes a new PDFDocument object based on an existing pdf document.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pdfFile As String _
)
Visual Basic (Usage) Copy Code
Dim pdfFile As String

Dim instance As PDFDocument(pdfFile)
C#
public PDFDocument(
   string pdfFile
)
Managed Extensions for C++
public: PDFDocument(
   string* pdfFile
)
C++/CLI
public:
PDFDocument(
   String^ pdfFile
)

Parameters

pdfFile
path to pdf file used as source for creating this PDFDocument object.

Exceptions

Exception | Description
PDFParserException | thrown when the input file can not be parsed for import.

Example

The following sample code shows how to add new content to an existing pdf file. It draws a line on top of the first page of the imported document.
C# Copy Code
...
PDFDocument doc = new PDFDocument( "helloworld.pdf" );
PDFPen pen = new PDFPen( );
doc.Pages[0].Canvas.DrawLine( pen, 0, 0, doc.Pages[0].Width, doc.Pages[0].Height );
doc.SaveToFile( "new.pdf" );
...

Remarks

This constructor imports an existing pdf file into the document object. It automatically populates the Pages collection with the pages of the given document. After the document object has been created, it can be used as any regular document object. New content can be added to imported pages (the new content is drawn on top of existing content) or to new pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


PDFDocument Constructor(String,Byte[])

PDFDocument Constructor(String,Byte[])
See Also Example
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor(String,Byte[])

pdfFile
path to pdf file used as source for creating this PDFDocument object.
password
the user or owner password used to decrypt the PDF file.
Initializes a new PDFDocument object based on an existing pdf document.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pdfFile As String, _
   ByVal password() As Byte _
)
Visual Basic (Usage) Copy Code
Dim pdfFile As String
Dim password() As Byte

Dim instance As PDFDocument(pdfFile, password)
C#
public PDFDocument(
   string pdfFile,
   byte[] password
)
Managed Extensions for C++
public: PDFDocument(
   string* pdfFile,
   byte[]* password
)
C++/CLI
public:
PDFDocument(
   String^ pdfFile,
   array<byte>^ password
)

Parameters

pdfFile
path to pdf file used as source for creating this PDFDocument object.
password
the user or owner password used to decrypt the PDF file.

Exceptions

Exception | Description
PDFParserException | thrown when the input file can not be parsed for import or the given password is invalid.

Example

The following sample code shows how to add new content to an existing pdf file. It draws a line on top of the first page of the imported document.
C# Copy Code
...
PDFDocument doc = new PDFDocument( "helloworld.pdf" );
PDFPen pen = new PDFPen( );
doc.Pages[0].Canvas.DrawLine( pen, 0, 0, doc.Pages[0].Width, doc.Pages[0].Height );
doc.SaveToFile( "new.pdf" );
...

Remarks

This constructor imports an existing pdf file into the document object. It automatically populates the Pages collection with the pages of the given document. After the document object has been created, it can be used as any regular document object. New content can be added to imported pages (the new content is drawn on top of existing content) or to new pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


PDFDocument Constructor(String,PDFDocumentLoadOptions)

PDFDocument Constructor(String,PDFDocumentLoadOptions)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > PDFDocument Constructor : PDFDocument Constructor(String,PDFDocumentLoadOptions)

pdfFile
path to pdf file used as source for creating this PDFDocument object.
loadOptions
options for loading the PDF file.
Initializes a new PDFDocument object based on an existing pdf document.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pdfFile As String, _
   ByVal loadOptions As PDFDocumentLoadOptions _
)
Visual Basic (Usage) Copy Code
Dim pdfFile As String
Dim loadOptions As PDFDocumentLoadOptions

Dim instance As PDFDocument(pdfFile, loadOptions)
C#
public PDFDocument(
   string pdfFile,
   PDFDocumentLoadOptions loadOptions
)
Managed Extensions for C++
public: PDFDocument(
   string* pdfFile,
   PDFDocumentLoadOptions* loadOptions
)
C++/CLI
public:
PDFDocument(
   String^ pdfFile,
   PDFDocumentLoadOptions^ loadOptions
)

Parameters

pdfFile
path to pdf file used as source for creating this PDFDocument object.
loadOptions
options for loading the PDF file.

Exceptions

Exception | Description
PDFParserException | thrown when the input file can not be parsed for import or the given password is invalid.

Remarks

This constructor imports an existing pdf file into the document object. It automatically populates the Pages collection with the pages of the given document. After the document object has been created, it can be used as any regular document object. New content can be added to imported pages (the new content is drawn on top of existing content) or to new pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


PDFDocument Class Methods

PDFDocument Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFDocument Class

For a list of all members of this type, see PDFDocument members.

Public Methods

 | Name | Description
Public Method | AddPage | Creates a new page and adds it as the last page of the document
Public Method | BeginSave | Begins to save the document.
Public Method | Dispose | Disposes the internal resources.
Public Method | EndSave | Finishes a partial save operation.
Public Method | GetPDFAsByteArray | Gets the pdf file as a byte array.
Public Method | Save | Overloaded. Saves the PDF document to a file.
Public Method | SavePage | Saves the specified page.
Public Method | SavePageContent | Saves the content of the specified page.
Top

See Also

Reference

PDFDocument Class
O2S.Components.PDF4NET Namespace


AddPage Method

AddPage Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : AddPage Method

Creates a new page and adds it as the last page of the document

Syntax

Visual Basic (Declaration)
Public Function AddPage() As PDFPage
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFPage

value = instance.AddPage()
C#
public PDFPage AddPage()
Managed Extensions for C++
public: PDFPage* AddPage();
C++/CLI
public:
PDFPage^ AddPage();

Return Value

a PDFPage object representing the newly added page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


BeginSave Method

BeginSave Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : BeginSave Method

stream
Destination stream for saving the document.
Begins to save the document.

Syntax

Visual Basic (Declaration)
Public Sub BeginSave( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim stream As Stream

instance.BeginSave(stream)
C#
public void BeginSave(
   Stream stream
)
Managed Extensions for C++
public: void BeginSave(
   Stream* stream
)
C++/CLI
public:
void BeginSave(
   Stream^ stream
)

Parameters

stream
Destination stream for saving the document.

Remarks

This method, together with SavePage and EndSave, allows to save a PDF document page by page thus reducing the memory consumption. Once a page has been saved, it can no longer be used, its properties and invalid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


Dispose Method

Dispose Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : Dispose Method

Disposes the internal resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


EndSave Method

EndSave Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : EndSave Method

Finishes a partial save operation.

Syntax

Visual Basic (Declaration)
Public Sub EndSave()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument

instance.EndSave()
C#
public void EndSave()
Managed Extensions for C++
public: void EndSave();
C++/CLI
public:
void EndSave();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


GetPDFAsByteArray Method

GetPDFAsByteArray Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : GetPDFAsByteArray Method

Gets the pdf file as a byte array.

Syntax

Visual Basic (Declaration)
Public Function GetPDFAsByteArray() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value() As Byte

value = instance.GetPDFAsByteArray()
C#
public byte[] GetPDFAsByteArray()
Managed Extensions for C++
public: byte[]* GetPDFAsByteArray();
C++/CLI
public:
array<byte>^ GetPDFAsByteArray();

Return Value

a byte array storing the pdf file.

Remarks

This method retrives the pdf file as an array of bytes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


Save Method

Save Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : Save Method

Saves the PDF document to a file.

Overload List

Overload | Description
Save(String) | Saves the PDF document to a file.
Save(String,Boolean) | Saves the PDF document to a file.
Save(String,PDFDocumentSaveOptions) | Saves the PDF document to a file.
Save(Stream) | Saves the PDF document to a stream.
Save(Stream,Boolean) | Saves the PDF document to a stream.
Save(Stream,PDFDocumentSaveOptions) | Saves the PDF document to a stream.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


Save(String) Method

Save(String) Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > Save Method : Save(String) Method

fileName
The path to the file where the PDF document will be saved.
Saves the PDF document to a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim fileName As String

instance.Save(fileName)
C#
public void Save(
   string fileName
)
Managed Extensions for C++
public: void Save(
   string* fileName
)
C++/CLI
public:
void Save(
   String^ fileName
)

Parameters

fileName
The path to the file where the PDF document will be saved.

Remarks

If the file already exists, it will be overwritten.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


Save(String,Boolean) Method

Save(String,Boolean) Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > Save Method : Save(String,Boolean) Method

fileName
The path to the file where the PDF document will be saved.
saveForFastWebView
True if the file should be saved in fast web view format (linearized).
Saves the PDF document to a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal fileName As String, _
   ByVal saveForFastWebView As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim fileName As String
Dim saveForFastWebView As Boolean

instance.Save(fileName, saveForFastWebView)
C#
public void Save(
   string fileName,
   bool saveForFastWebView
)
Managed Extensions for C++
public: void Save(
   string* fileName,
   bool saveForFastWebView
)
C++/CLI
public:
void Save(
   String^ fileName,
   bool saveForFastWebView
)

Parameters

fileName
The path to the file where the PDF document will be saved.
saveForFastWebView
True if the file should be saved in fast web view format (linearized).

Remarks

If the file already exists, it will be overwritten.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


Save(String,PDFDocumentSaveOptions) Method

Save(String,PDFDocumentSaveOptions) Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > Save Method : Save(String,PDFDocumentSaveOptions) Method

fileName
The path to the file where the PDF document will be saved.
saveOptions
Options for saving the PDF document.
Saves the PDF document to a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal fileName As String, _
   ByVal saveOptions As PDFDocumentSaveOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim fileName As String
Dim saveOptions As PDFDocumentSaveOptions

instance.Save(fileName, saveOptions)
C#
public void Save(
   string fileName,
   PDFDocumentSaveOptions saveOptions
)
Managed Extensions for C++
public: void Save(
   string* fileName,
   PDFDocumentSaveOptions* saveOptions
)
C++/CLI
public:
void Save(
   String^ fileName,
   PDFDocumentSaveOptions^ saveOptions
)

Parameters

fileName
The path to the file where the PDF document will be saved.
saveOptions
Options for saving the PDF document.

Remarks

If the file already exists, it will be overwritten.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


Save(Stream) Method

Save(Stream) Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > Save Method : Save(Stream) Method

stream
The stream object where PDF document will be saved.
Saves the PDF document to a stream.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim stream As Stream

instance.Save(stream)
C#
public void Save(
   Stream stream
)
Managed Extensions for C++
public: void Save(
   Stream* stream
)
C++/CLI
public:
void Save(
   Stream^ stream
)

Parameters

stream
The stream object where PDF document will be saved.

Remarks

The stream needs to be created prior saving the PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


Save(Stream,Boolean) Method

Save(Stream,Boolean) Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > Save Method : Save(Stream,Boolean) Method

stream
The stream object where PDF document will be saved.
saveForFastWebView
True if the file should be saved in fast web view format (linearized).
Saves the PDF document to a stream.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream, _
   ByVal saveForFastWebView As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim stream As Stream
Dim saveForFastWebView As Boolean

instance.Save(stream, saveForFastWebView)
C#
public void Save(
   Stream stream,
   bool saveForFastWebView
)
Managed Extensions for C++
public: void Save(
   Stream* stream,
   bool saveForFastWebView
)
C++/CLI
public:
void Save(
   Stream^ stream,
   bool saveForFastWebView
)

Parameters

stream
The stream object where PDF document will be saved.
saveForFastWebView
True if the file should be saved in fast web view format (linearized).

Remarks

The stream needs to be created prior saving the PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


Save(Stream,PDFDocumentSaveOptions) Method

Save(Stream,PDFDocumentSaveOptions) Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class > Save Method : Save(Stream,PDFDocumentSaveOptions) Method

stream
The stream object where PDF document will be saved.
saveOptions
Options for saving the PDF file.
Saves the PDF document to a stream.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream, _
   ByVal saveOptions As PDFDocumentSaveOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim stream As Stream
Dim saveOptions As PDFDocumentSaveOptions

instance.Save(stream, saveOptions)
C#
public void Save(
   Stream stream,
   PDFDocumentSaveOptions saveOptions
)
Managed Extensions for C++
public: void Save(
   Stream* stream,
   PDFDocumentSaveOptions* saveOptions
)
C++/CLI
public:
void Save(
   Stream^ stream,
   PDFDocumentSaveOptions^ saveOptions
)

Parameters

stream
The stream object where PDF document will be saved.
saveOptions
Options for saving the PDF file.

Remarks

The stream needs to be created prior saving the PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members
Overload List


SavePage Method

SavePage Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : SavePage Method

pageNumber
The number of the page to save.
Saves the specified page.

Syntax

Visual Basic (Declaration)
Public Sub SavePage( _
   ByVal pageNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim pageNumber As Integer

instance.SavePage(pageNumber)
C#
public void SavePage(
   int pageNumber
)
Managed Extensions for C++
public: void SavePage(
   int pageNumber
)
C++/CLI
public:
void SavePage(
   int pageNumber
)

Parameters

pageNumber
The number of the page to save.

Remarks

This method, together with BeginSave and EndSave, allows to save a PDF document page by page thus reducing the memory consumption. Once a page has been saved, it can no longer be used, its properties and invalid.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


SavePageContent Method

SavePageContent Method
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : SavePageContent Method

pageNumber
The number of the page to save.
Saves the content of the specified page.

Syntax

Visual Basic (Declaration)
Public Sub SavePageContent( _
   ByVal pageNumber As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim pageNumber As Integer

instance.SavePageContent(pageNumber)
C#
public void SavePageContent(
   int pageNumber
)
Managed Extensions for C++
public: void SavePageContent(
   int pageNumber
)
C++/CLI
public:
void SavePageContent(
   int pageNumber
)

Parameters

pageNumber
The number of the page to save.

Remarks

This method, together with BeginSave, SavePage and EndSave, allows to save a PDF document page by page and page content by page content thus reducing the memory consumption. This method lets you save pieces of the page content while making possible to add new content to the page after the save. In this way, if the page content is very large, if can be saved piece by piece by calling this method multiple times. After the page is completed a call to SavePage is required.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


PDFDocument Class Properties

PDFDocument Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDocument Class

For a list of all members of this type, see PDFDocument members.

Public Properties

 | Name | Description
Public Property | AfterPrintAction | Gets or sets the javascript action to execute after the document is printed.
Public Property | AfterSaveAction | Gets or sets the javascript action to execute after the document is saved.
Public Property | Attachments | Gets the list of file attachments embedded in this document.
Public Property | BeforeCloseAction | Gets or sets the javascript action to execute before the document is closed.
Public Property | BeforePrintAction | Gets or sets the javascript action to execute before the document is printed.
Public Property | BeforeSaveAction | Gets or sets the javascript action to execute before the document is saved.
Public Property | Bookmarks | Gets the list of bookmarks in the PDF document.
Public Property | Dictionary | Gets the document catalog dictionary.
Public Property | DisplayMode | Gets or sets how the document should be displayed when opened in the viewer.
Public Property | DocumentInformation | Gets or sets the document information.
Public Property | Form | Gets the PDF form included in the document.
Public Property | ID | Gets the document ID.
Public Property | JavaScripts | Gets the list of global JavaScript actions associated with this document.
Public Property | Metadata | Gets the XMP metadata for this PDFDocument object.
Public Property | OpenAction | Gets or sets the action to execute when the document is opened.
Public Property | PageHeight | Gets or sets the default page height.
Public Property | PageLayout | Gets or sets the document's page layout specifying how the pages should be displayed when opened.
Public Property | PageNumber | Gets or sets the default page number visual aspect for this PDFDocument object.
Public Property | PageNumberingRanges | Gets the list of page numbering ranges in the PDF document.
Public Property | PageOrientation | Gets or sets the default page orientation.
Public Property | Pages | Gets the document's collection of pages.
Public Property | PageSize | Gets or sets the default page size.
Public Property | PageWidth | Gets or sets the default page width.
Public Property | PDFVersion | Gets or sets the PDF version of this PDFDocument object.
Public Property | SecurityManager | Gets or sets the security manager for this pdf document.
Public Property | SerialNumber | Sets the serial number and unlocks the component.
Public Property | ViewerPreferences | Gets or sets the document's viewer preferences.
Public Property | XFAForm | Gets the XFA form associated with this document.
Top

See Also

Reference

PDFDocument Class
O2S.Components.PDF4NET Namespace


AfterPrintAction Property

AfterPrintAction Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : AfterPrintAction Property

Gets or sets the javascript action to execute after the document is printed.

Syntax

Visual Basic (Declaration)
Public Property AfterPrintAction As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFJavaScriptAction

instance.AfterPrintAction = value

value = instance.AfterPrintAction
C#
public PDFJavaScriptAction AfterPrintAction {get; set;}
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_AfterPrintAction();
public: __property void set_AfterPrintAction(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ AfterPrintAction {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed after the document is printed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


AfterSaveAction Property

AfterSaveAction Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : AfterSaveAction Property

Gets or sets the javascript action to execute after the document is saved.

Syntax

Visual Basic (Declaration)
Public Property AfterSaveAction As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFJavaScriptAction

instance.AfterSaveAction = value

value = instance.AfterSaveAction
C#
public PDFJavaScriptAction AfterSaveAction {get; set;}
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_AfterSaveAction();
public: __property void set_AfterSaveAction(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ AfterSaveAction {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed after the document is saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


Attachments Property

Attachments Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : Attachments Property

Gets the list of file attachments embedded in this document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Attachments As PDFDocumentAttachmentCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFDocumentAttachmentCollection

value = instance.Attachments
C#
public PDFDocumentAttachmentCollection Attachments {get;}
Managed Extensions for C++
public: __property PDFDocumentAttachmentCollection* get_Attachments();
C++/CLI
public:
property PDFDocumentAttachmentCollection^ Attachments {
   PDFDocumentAttachmentCollection^ get();
}

Return Value

PDFDocumentAttachmentCollection object specifying the list of document attachments.

Remarks

When a PDF file is imported into a PDFDocument object, this collection is populated automatically with the attachments in the file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


BeforeCloseAction Property

BeforeCloseAction Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : BeforeCloseAction Property

Gets or sets the javascript action to execute before the document is closed.

Syntax

Visual Basic (Declaration)
Public Property BeforeCloseAction As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFJavaScriptAction

instance.BeforeCloseAction = value

value = instance.BeforeCloseAction
C#
public PDFJavaScriptAction BeforeCloseAction {get; set;}
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_BeforeCloseAction();
public: __property void set_BeforeCloseAction(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ BeforeCloseAction {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed before the document is closed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


BeforePrintAction Property

BeforePrintAction Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : BeforePrintAction Property

Gets or sets the javascript action to execute before the document is printed.

Syntax

Visual Basic (Declaration)
Public Property BeforePrintAction As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFJavaScriptAction

instance.BeforePrintAction = value

value = instance.BeforePrintAction
C#
public PDFJavaScriptAction BeforePrintAction {get; set;}
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_BeforePrintAction();
public: __property void set_BeforePrintAction(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ BeforePrintAction {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed before the document is printed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


BeforeSaveAction Property

BeforeSaveAction Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : BeforeSaveAction Property

Gets or sets the javascript action to execute before the document is saved.

Syntax

Visual Basic (Declaration)
Public Property BeforeSaveAction As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFJavaScriptAction

instance.BeforeSaveAction = value

value = instance.BeforeSaveAction
C#
public PDFJavaScriptAction BeforeSaveAction {get; set;}
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_BeforeSaveAction();
public: __property void set_BeforeSaveAction(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ BeforeSaveAction {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed before the document is saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


Bookmarks Property

Bookmarks Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : Bookmarks Property

Gets the list of bookmarks in the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bookmarks As PDFBookmarkCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFBookmarkCollection

value = instance.Bookmarks
C#
public PDFBookmarkCollection Bookmarks {get;}
Managed Extensions for C++
public: __property PDFBookmarkCollection* get_Bookmarks();
C++/CLI
public:
property PDFBookmarkCollection^ Bookmarks {
   PDFBookmarkCollection^ get();
}

Return Value

The list of top level bookmarks in the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


Dictionary Property

Dictionary Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : Dictionary Property

Gets the document catalog dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dictionary As PDFDictionary
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFDictionary

value = instance.Dictionary
C#
public PDFDictionary Dictionary {get;}
Managed Extensions for C++
public: __property PDFDictionary* get_Dictionary();
C++/CLI
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Return Value

The raw document catalog dictionary.

Remarks

This property gives you direct access to document catalog dictionary and the entire PDF tree. Starting with the document catalog dictionary every bit of information stored in the PDF file can be accessed using the low level COS objects even if it is not avialable through PDF4NET public API.
Note: Modifying directly the document catalog dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


DisplayMode Property

DisplayMode Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : DisplayMode Property

Gets or sets how the document should be displayed when opened in the viewer.

Syntax

Visual Basic (Declaration)
Public Property DisplayMode As PDFDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFDisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
public PDFDisplayMode DisplayMode {get; set;}
Managed Extensions for C++
public: __property PDFDisplayMode get_DisplayMode();
public: __property void set_DisplayMode(
   PDFDisplayMode value
);
C++/CLI
public:
property PDFDisplayMode DisplayMode {
   PDFDisplayMode get();
   void set (PDFDisplayMode value);
}

Return Value

A PDFDisplayMode enumeration member specifying how the viewer should display the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


DocumentInformation Property

DocumentInformation Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : DocumentInformation Property

Gets or sets the document information.

Syntax

Visual Basic (Declaration)
Public Property DocumentInformation As PDFDocumentInformation
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFDocumentInformation

instance.DocumentInformation = value

value = instance.DocumentInformation
C#
public PDFDocumentInformation DocumentInformation {get; set;}
Managed Extensions for C++
public: __property PDFDocumentInformation* get_DocumentInformation();
public: __property void set_DocumentInformation(
   PDFDocumentInformation* value
);
C++/CLI
public:
property PDFDocumentInformation^ DocumentInformation {
   PDFDocumentInformation^ get();
   void set (PDFDocumentInformation^ value);
}

Return Value

The document's metadata.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


Form Property

Form Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : Form Property

Gets the PDF form included in the document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Form As PDFForm
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFForm

value = instance.Form
C#
public PDFForm Form {get;}
Managed Extensions for C++
public: __property PDFForm* get_Form();
C++/CLI
public:
property PDFForm^ Form {
   PDFForm^ get();
}

Return Value

A PDFForm object representing the PDF form included in the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


ID Property

ID Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : ID Property

Gets the document ID.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As String

value = instance.ID
C#
public string ID {get;}
Managed Extensions for C++
public: __property string* get_ID();
C++/CLI
public:
property String^ ID {
   String^ get();
}

Return Value

The PDF identifier of this document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


JavaScripts Property

JavaScripts Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : JavaScripts Property

Gets the list of global JavaScript actions associated with this document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property JavaScripts As PDFJavaScriptCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFJavaScriptCollection

value = instance.JavaScripts
C#
public PDFJavaScriptCollection JavaScripts {get;}
Managed Extensions for C++
public: __property PDFJavaScriptCollection* get_JavaScripts();
C++/CLI
public:
property PDFJavaScriptCollection^ JavaScripts {
   PDFJavaScriptCollection^ get();
}

Return Value

PDFJavaScriptCollection object specifying the list of global JavaScript actions.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


Metadata Property

Metadata Property
See Also Example
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : Metadata Property

Gets the XMP metadata for this PDFDocument object.

Syntax

Visual Basic (Declaration)
Public Property Metadata As PDFXMPMetadata
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFXMPMetadata

instance.Metadata = value

value = instance.Metadata
C#
public PDFXMPMetadata Metadata {get; set;}
Managed Extensions for C++
public: __property PDFXMPMetadata* get_Metadata();
public: __property void set_Metadata(
   PDFXMPMetadata* value
);
C++/CLI
public:
property PDFXMPMetadata^ Metadata {
   PDFXMPMetadata^ get();
   void set (PDFXMPMetadata^ value);
}

Return Value

A PDFXMPMetadata object specifying the collection of metadata schemas.

Example

The following example shows how to set several custom properties for a document:
C# Copy Code
...
PDFDocument doc = new PDFDocument();

PDFMetadataSchema schema = new PDFMetadataSchema();
schema.Name = "http://ns.o2sol.com/schema/pdf/1.4/";
schema.NamespacePrefix = "o2sol";

// set Company attribute
schema["Company"] = "O2 Solutions";
// set Website attribute
schema["Website"] = "http://www.o2sol.com/";

// Add schema to the document
doc.Metadata.MetadataSchemas.Add(schema);
...

Remarks

Metadata schemas are used to define custom properties for a document. Related properties can be grouped into a schema and several schemas can be attached to a document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


OpenAction Property

OpenAction Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : OpenAction Property

Gets or sets the action to execute when the document is opened.

Syntax

Visual Basic (Declaration)
Public Property OpenAction As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFAction

instance.OpenAction = value

value = instance.OpenAction
C#
public PDFAction OpenAction {get; set;}
Managed Extensions for C++
public: __property PDFAction* get_OpenAction();
public: __property void set_OpenAction(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ OpenAction {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

A PDFAction object specifying the action to be executed when documents opens in the viewer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


PageHeight Property

PageHeight Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PageHeight Property

Gets or sets the default page height.

Syntax

Visual Basic (Declaration)
Public Property PageHeight As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As Double

instance.PageHeight = value

value = instance.PageHeight
C#
public double PageHeight {get; set;}
Managed Extensions for C++
public: __property double get_PageHeight();
public: __property void set_PageHeight(
   double value
);
C++/CLI
public:
property double PageHeight {
   double get();
   void set (double value);
}

Return Value

Default height for newly created document pages.

Remarks

This value is used by the AddPage method when adding a new page to the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


PageLayout Property

PageLayout Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PageLayout Property

Gets or sets the document's page layout specifying how the pages should be displayed when opened.

Syntax

Visual Basic (Declaration)
Public Property PageLayout As PDFPageLayout
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFPageLayout

instance.PageLayout = value

value = instance.PageLayout
C#
public PDFPageLayout PageLayout {get; set;}
Managed Extensions for C++
public: __property PDFPageLayout get_PageLayout();
public: __property void set_PageLayout(
   PDFPageLayout value
);
C++/CLI
public:
property PDFPageLayout PageLayout {
   PDFPageLayout get();
   void set (PDFPageLayout value);
}

Return Value

The document's page layout.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


PageNumber Property

PageNumber Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PageNumber Property

Gets or sets the default page number visual aspect for this PDFDocument object.

Syntax

Visual Basic (Declaration)
Public Property PageNumber As PDFPageNumber
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFPageNumber

instance.PageNumber = value

value = instance.PageNumber
C#
public PDFPageNumber PageNumber {get; set;}
Managed Extensions for C++
public: __property PDFPageNumber* get_PageNumber();
public: __property void set_PageNumber(
   PDFPageNumber* value
);
C++/CLI
public:
property PDFPageNumber^ PageNumber {
   PDFPageNumber^ get();
   void set (PDFPageNumber^ value);
}

Return Value

A PDFPageNumber object specifying the default visual appearance of the printed page numbers.

Remarks

This value is used by the AddPage method when adding a new page to the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


PageNumberingRanges Property

PageNumberingRanges Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PageNumberingRanges Property

Gets the list of page numbering ranges in the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNumberingRanges As PDFPageNumberingRangeCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFPageNumberingRangeCollection

value = instance.PageNumberingRanges
C#
public PDFPageNumberingRangeCollection PageNumberingRanges {get;}
Managed Extensions for C++
public: __property PDFPageNumberingRangeCollection* get_PageNumberingRanges();
C++/CLI
public:
property PDFPageNumberingRangeCollection^ PageNumberingRanges {
   PDFPageNumberingRangeCollection^ get();
}

Return Value

The list of page numbering ranges in the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


PageOrientation Property

PageOrientation Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PageOrientation Property

Gets or sets the default page orientation.

Syntax

Visual Basic (Declaration)
Public Property PageOrientation As PDFPageOrientation
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFPageOrientation

instance.PageOrientation = value

value = instance.PageOrientation
C#
public PDFPageOrientation PageOrientation {get; set;}
Managed Extensions for C++
public: __property PDFPageOrientation get_PageOrientation();
public: __property void set_PageOrientation(
   PDFPageOrientation value
);
C++/CLI
public:
property PDFPageOrientation PageOrientation {
   PDFPageOrientation get();
   void set (PDFPageOrientation value);
}

Return Value

A PageOrientation enumeration member specifying the default orientation for newly created document pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


Pages Property

Pages Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : Pages Property

Gets the document's collection of pages.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pages As PDFPageCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFPageCollection

value = instance.Pages
C#
public PDFPageCollection Pages {get;}
Managed Extensions for C++
public: __property PDFPageCollection* get_Pages();
C++/CLI
public:
property PDFPageCollection^ Pages {
   PDFPageCollection^ get();
}

Return Value

A PDFPageCollection object containing the list of document's pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


PageSize Property

PageSize Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PageSize Property

Gets or sets the default page size.

Syntax

Visual Basic (Declaration)
Public Property PageSize As PDFPageSize
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFPageSize

instance.PageSize = value

value = instance.PageSize
C#
public PDFPageSize PageSize {get; set;}
Managed Extensions for C++
public: __property PDFPageSize get_PageSize();
public: __property void set_PageSize(
   PDFPageSize value
);
C++/CLI
public:
property PDFPageSize PageSize {
   PDFPageSize get();
   void set (PDFPageSize value);
}

Return Value

A PDFPageSize enumeration member specifying the default size for newly created document pages.

Remarks

This value is used by the AddPage method when adding a new page to the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


PageWidth Property

PageWidth Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PageWidth Property

Gets or sets the default page width.

Syntax

Visual Basic (Declaration)
Public Property PageWidth As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As Double

instance.PageWidth = value

value = instance.PageWidth
C#
public double PageWidth {get; set;}
Managed Extensions for C++
public: __property double get_PageWidth();
public: __property void set_PageWidth(
   double value
);
C++/CLI
public:
property double PageWidth {
   double get();
   void set (double value);
}

Return Value

Default width for newly created document pages.

Remarks

This value is used by the AddPage method when adding a new page to the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


PDFVersion Property

PDFVersion Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : PDFVersion Property

Gets or sets the PDF version of this PDFDocument object.

Syntax

Visual Basic (Declaration)
Public Property PDFVersion As PDFVersion
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFVersion

instance.PDFVersion = value

value = instance.PDFVersion
C#
public PDFVersion PDFVersion {get; set;}
Managed Extensions for C++
public: __property PDFVersion get_PDFVersion();
public: __property void set_PDFVersion(
   PDFVersion value
);
C++/CLI
public:
property PDFVersion PDFVersion {
   PDFVersion get();
   void set (PDFVersion value);
}

Return Value

A PDFVersion enumeration member specifying the PDF version of this PDFDocument object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


SecurityManager Property

SecurityManager Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : SecurityManager Property

Gets or sets the security manager for this pdf document.

Syntax

Visual Basic (Declaration)
Public Property SecurityManager As PDFSecurityManager
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFSecurityManager

instance.SecurityManager = value

value = instance.SecurityManager
C#
public PDFSecurityManager SecurityManager {get; set;}
Managed Extensions for C++
public: __property PDFSecurityManager* get_SecurityManager();
public: __property void set_SecurityManager(
   PDFSecurityManager* value
);
C++/CLI
public:
property PDFSecurityManager^ SecurityManager {
   PDFSecurityManager^ get();
   void set (PDFSecurityManager^ value);
}

Return Value

A PDFSecurityManager object specifying the security manager for this pdf document.

Remarks

Set this property to a valid security manager object to enforce security settings (document encryption, passwords, access rights), on the pdf document. When this property is null, no security is applied on the resulted pdf document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


SerialNumber Property

SerialNumber Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : SerialNumber Property

Sets the serial number and unlocks the component.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property SerialNumber
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As

instance.SerialNumber = value
C#
public void SerialNumber {set;}
Managed Extensions for C++
public: __property void set_SerialNumber(
   void value
);
C++/CLI
public:
property void SerialNumber {
   void set (void value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


ViewerPreferences Property

ViewerPreferences Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : ViewerPreferences Property

Gets or sets the document's viewer preferences.

Syntax

Visual Basic (Declaration)
Public Property ViewerPreferences As PDFViewerPreferences
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As PDFViewerPreferences

instance.ViewerPreferences = value

value = instance.ViewerPreferences
C#
public PDFViewerPreferences ViewerPreferences {get; set;}
Managed Extensions for C++
public: __property PDFViewerPreferences* get_ViewerPreferences();
public: __property void set_ViewerPreferences(
   PDFViewerPreferences* value
);
C++/CLI
public:
property PDFViewerPreferences^ ViewerPreferences {
   PDFViewerPreferences^ get();
   void set (PDFViewerPreferences^ value);
}

Return Value

The viewer preferences for displaying the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


XFAForm Property

XFAForm Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocument Class : XFAForm Property

Gets the XFA form associated with this document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property XFAForm As XFAForm
Visual Basic (Usage) Copy Code
Dim instance As PDFDocument
Dim value As XFAForm

value = instance.XFAForm
C#
public XFAForm XFAForm {get;}
Managed Extensions for C++
public: __property XFAForm* get_XFAForm();
C++/CLI
public:
property XFAForm^ XFAForm {
   XFAForm^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocument Class
PDFDocument Members


PDFDocumentAttachment Class

PDFDocumentAttachment Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentAttachment Class

Defines a file embedded in a PDF document.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFDocumentAttachment
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachment
C#
public class PDFDocumentAttachment
Managed Extensions for C++
public __gc class PDFDocumentAttachment
C++/CLI
public ref class PDFDocumentAttachment

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDocumentAttachment

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Members
O2S.Components.PDF4NET Namespace


PDFDocumentAttachment Class Members

PDFDocumentAttachment Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentAttachment Class

The following tables list the members exposed by PDFDocumentAttachment.

Public Constructors

 | Name | Description
Public Constructor | PDFDocumentAttachment Constructor | Overloaded. Initializes a new PDFDocumentAttachment object.
Top

Public Properties

 | Name | Description
Public Property | CreationDate | Gets or sets the creation date and time of the attachment.
Public Property | Description | Gets or sets the attachment description.
Public Property | Dictionary | Gets the attachment dictionary.
Public Property | FileData | Gets or sets the file data for this embedded file.
Public Property | FileName | Gets or sets the name of file to embed.
Public Property | MimeType | Gets or sets the MIME type of the file to embed.
Public Property | ModifyDate | Gets or sets the modify date and time of the attachment.
Top

See Also

Reference

PDFDocumentAttachment Class
O2S.Components.PDF4NET Namespace


PDFDocumentAttachment Constructor

PDFDocumentAttachment Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : PDFDocumentAttachment Constructor

Initializes a new PDFDocumentAttachment object.

Overload List

Overload | Description
PDFDocumentAttachment Constructor() | Initializes a new PDFDocumentAttachment object.
PDFDocumentAttachment Constructor(Byte[]) | Initializes a new PDFDocumentAttachment object with the given content.
PDFDocumentAttachment Constructor(String) | Initializes a new PDFDocumentAttachment object with the given file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


PDFDocumentAttachment Constructor()

PDFDocumentAttachment Constructor()
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class > PDFDocumentAttachment Constructor : PDFDocumentAttachment Constructor()

Initializes a new PDFDocumentAttachment object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachment()
C#
public PDFDocumentAttachment()
Managed Extensions for C++
public: PDFDocumentAttachment();
C++/CLI
public:
PDFDocumentAttachment();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members
Overload List


PDFDocumentAttachment Constructor(Byte[])

PDFDocumentAttachment Constructor(Byte[])
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class > PDFDocumentAttachment Constructor : PDFDocumentAttachment Constructor(Byte[])

fileData
The binary content to embed in the PDF file.
Initializes a new PDFDocumentAttachment object with the given content.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileData() As Byte _
)
Visual Basic (Usage) Copy Code
Dim fileData() As Byte

Dim instance As PDFDocumentAttachment(fileData)
C#
public PDFDocumentAttachment(
   byte[] fileData
)
Managed Extensions for C++
public: PDFDocumentAttachment(
   byte[]* fileData
)
C++/CLI
public:
PDFDocumentAttachment(
   array<byte>^ fileData
)

Parameters

fileData
The binary content to embed in the PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members
Overload List


PDFDocumentAttachment Constructor(String)

PDFDocumentAttachment Constructor(String)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class > PDFDocumentAttachment Constructor : PDFDocumentAttachment Constructor(String)

fileName
The name of the file to embed.
Initializes a new PDFDocumentAttachment object with the given file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As PDFDocumentAttachment(fileName)
C#
public PDFDocumentAttachment(
   string fileName
)
Managed Extensions for C++
public: PDFDocumentAttachment(
   string* fileName
)
C++/CLI
public:
PDFDocumentAttachment(
   String^ fileName
)

Parameters

fileName
The name of the file to embed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members
Overload List


PDFDocumentAttachment Class Properties

PDFDocumentAttachment Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentAttachment Class

For a list of all members of this type, see PDFDocumentAttachment members.

Public Properties

 | Name | Description
Public Property | CreationDate | Gets or sets the creation date and time of the attachment.
Public Property | Description | Gets or sets the attachment description.
Public Property | Dictionary | Gets the attachment dictionary.
Public Property | FileData | Gets or sets the file data for this embedded file.
Public Property | FileName | Gets or sets the name of file to embed.
Public Property | MimeType | Gets or sets the MIME type of the file to embed.
Public Property | ModifyDate | Gets or sets the modify date and time of the attachment.
Top

See Also

Reference

PDFDocumentAttachment Class
O2S.Components.PDF4NET Namespace


CreationDate Property

CreationDate Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : CreationDate Property

Gets or sets the creation date and time of the attachment.

Syntax

Visual Basic (Declaration)
Public Property CreationDate As Date
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachment
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
C#
public DateTime CreationDate {get; set;}
Managed Extensions for C++
public: __property DateTime get_CreationDate();
public: __property void set_CreationDate(
   DateTime value
);
C++/CLI
public:
property DateTime CreationDate {
   DateTime get();
   void set (DateTime value);
}

Return Value

A DateTime value specifying the date and time when the attachment was created.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


Description Property

Description Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : Description Property

Gets or sets the attachment description.

Syntax

Visual Basic (Declaration)
Public Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachment
Dim value As String

instance.Description = value

value = instance.Description
C#
public string Description {get; set;}
Managed Extensions for C++
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
C++/CLI
public:
property String^ Description {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying an optional description associated with this attachment.

Remarks

The description is used to provide the user with more information about the embedded attachment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


Dictionary Property

Dictionary Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : Dictionary Property

Gets the attachment dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dictionary As PDFDictionary
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachment
Dim value As PDFDictionary

value = instance.Dictionary
C#
public PDFDictionary Dictionary {get;}
Managed Extensions for C++
public: __property PDFDictionary* get_Dictionary();
C++/CLI
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Return Value

The raw attachment dictionary.

Remarks

This property gives you direct access to attachment dictionary and its associated resources. Note: Modifying directly the attachment dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


FileData Property

FileData Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : FileData Property

Gets or sets the file data for this embedded file.

Syntax

Visual Basic (Declaration)
Public Property FileData As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachment
Dim value() As Byte

instance.FileData = value

value = instance.FileData
C#
public byte[] FileData {get; set;}
Managed Extensions for C++
public: __property byte[]* get_FileData();
public: __property void set_FileData(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ FileData {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array specifying the content to embed.

Remarks

If both FileName and FileData are set, FileData will be used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


FileName Property

FileName Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : FileName Property

Gets or sets the name of file to embed.

Syntax

Visual Basic (Declaration)
Public Property FileName As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachment
Dim value As String

instance.FileName = value

value = instance.FileName
C#
public string FileName {get; set;}
Managed Extensions for C++
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
C++/CLI
public:
property String^ FileName {
   String^ get();
   void set (String^ value);
}

Return Value

A string specifying the file to embed.

Remarks

If both FileName and FileData are set, FileData will be used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


MimeType Property

MimeType Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : MimeType Property

Gets or sets the MIME type of the file to embed.

Syntax

Visual Basic (Declaration)
Public Property MimeType As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachment
Dim value As String

instance.MimeType = value

value = instance.MimeType
C#
public string MimeType {get; set;}
Managed Extensions for C++
public: __property string* get_MimeType();
public: __property void set_MimeType(
   string* value
);
C++/CLI
public:
property String^ MimeType {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the MIME type of the file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


ModifyDate Property

ModifyDate Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentAttachment Class : ModifyDate Property

Gets or sets the modify date and time of the attachment.

Syntax

Visual Basic (Declaration)
Public Property ModifyDate As Date
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachment
Dim value As Date

instance.ModifyDate = value

value = instance.ModifyDate
C#
public DateTime ModifyDate {get; set;}
Managed Extensions for C++
public: __property DateTime get_ModifyDate();
public: __property void set_ModifyDate(
   DateTime value
);
C++/CLI
public:
property DateTime ModifyDate {
   DateTime get();
   void set (DateTime value);
}

Return Value

A DateTime value specifying the date and time when the attachment was modified.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachment Class
PDFDocumentAttachment Members


PDFDocumentAttachmentCollection Class

PDFDocumentAttachmentCollection Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentAttachmentCollection Class

Defines a collection of annotations.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFDocumentAttachmentCollection
   Inherits PDFCollection(Of PDFDocumentAttachment, PDFDocument)
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentAttachmentCollection
C#
public class PDFDocumentAttachmentCollection : PDFCollection<PDFDocumentAttachment, PDFDocument>
Managed Extensions for C++
public __gc class PDFDocumentAttachmentCollection : public PDFCollection<PDFDocumentAttachment, PDFDocument>
C++/CLI
public ref class PDFDocumentAttachmentCollection : public PDFCollection<PDFDocumentAttachment, PDFDocument>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<PDFDocumentAttachment>
O2S.Components.PDF4NET.PDFCollection<PDFDocumentAttachment, PDFDocument>
O2S.Components.PDF4NET.PDFDocumentAttachmentCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentAttachmentCollection Members
O2S.Components.PDF4NET Namespace


PDFDocumentAttachmentCollection Class Members

PDFDocumentAttachmentCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentAttachmentCollection Class

The following tables list the members exposed by PDFDocumentAttachmentCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Top

See Also

Reference

PDFDocumentAttachmentCollection Class
O2S.Components.PDF4NET Namespace


PDFDocumentInformation Class

PDFDocumentInformation Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentInformation Class

Provides access to document metadata.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFDocumentInformation
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
C#
public class PDFDocumentInformation
Managed Extensions for C++
public __gc class PDFDocumentInformation
C++/CLI
public ref class PDFDocumentInformation

Remarks

This class stores document general information, such as document's title, author and other information.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDocumentInformation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Members
O2S.Components.PDF4NET Namespace


PDFDocumentInformation Class Members

PDFDocumentInformation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentInformation Class

The following tables list the members exposed by PDFDocumentInformation.

Public Constructors

 | Name | Description
Public Constructor | PDFDocumentInformation Constructor | Initializes a new PDFDocumentInformation object.
Top

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the document.
Public Property | CreationDate | Gets or sets the date when the document was created.
Public Property | Creator | Gets or sets the application that created the document.
Public Property | CustomProperties | Gets the collection of custom properties of the document.
Public Property | Dictionary | Gets the document information dictionary.
Public Property | Keywords | Gets or sets the keywords of the document.
Public Property | ModDate | Gets or sets the date when the document was modified.
Public Property | Producer | Gets or sets the PDF engine that produced the document.
Public Property | Subject | Gets or sets the subject of the document.
Public Property | Title | Gets or sets the title of the document.
Top

See Also

Reference

PDFDocumentInformation Class
O2S.Components.PDF4NET Namespace


PDFDocumentInformation Constructor

PDFDocumentInformation Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : PDFDocumentInformation Constructor

Initializes a new PDFDocumentInformation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation()
C#
public PDFDocumentInformation()
Managed Extensions for C++
public: PDFDocumentInformation();
C++/CLI
public:
PDFDocumentInformation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


PDFDocumentInformation Class Properties

PDFDocumentInformation Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentInformation Class

For a list of all members of this type, see PDFDocumentInformation members.

Public Properties

 | Name | Description
Public Property | Author | Gets or sets the author of the document.
Public Property | CreationDate | Gets or sets the date when the document was created.
Public Property | Creator | Gets or sets the application that created the document.
Public Property | CustomProperties | Gets the collection of custom properties of the document.
Public Property | Dictionary | Gets the document information dictionary.
Public Property | Keywords | Gets or sets the keywords of the document.
Public Property | ModDate | Gets or sets the date when the document was modified.
Public Property | Producer | Gets or sets the PDF engine that produced the document.
Public Property | Subject | Gets or sets the subject of the document.
Public Property | Title | Gets or sets the title of the document.
Top

See Also

Reference

PDFDocumentInformation Class
O2S.Components.PDF4NET Namespace


Author Property

Author Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Author Property

Gets or sets the author of the document.

Syntax

Visual Basic (Declaration)
Public Property Author As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As String

instance.Author = value

value = instance.Author
C#
public string Author {get; set;}
Managed Extensions for C++
public: __property string* get_Author();
public: __property void set_Author(
   string* value
);
C++/CLI
public:
property String^ Author {
   String^ get();
   void set (String^ value);
}

Return Value

The document author.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


CreationDate Property

CreationDate Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : CreationDate Property

Gets or sets the date when the document was created.

Syntax

Visual Basic (Declaration)
Public Property CreationDate As Date
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
C#
public DateTime CreationDate {get; set;}
Managed Extensions for C++
public: __property DateTime get_CreationDate();
public: __property void set_CreationDate(
   DateTime value
);
C++/CLI
public:
property DateTime CreationDate {
   DateTime get();
   void set (DateTime value);
}

Return Value

The document creation date.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


Creator Property

Creator Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Creator Property

Gets or sets the application that created the document.

Syntax

Visual Basic (Declaration)
Public Property Creator As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As String

instance.Creator = value

value = instance.Creator
C#
public string Creator {get; set;}
Managed Extensions for C++
public: __property string* get_Creator();
public: __property void set_Creator(
   string* value
);
C++/CLI
public:
property String^ Creator {
   String^ get();
   void set (String^ value);
}

Return Value

The document creator.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


CustomProperties Property

CustomProperties Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : CustomProperties Property

Gets the collection of custom properties of the document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CustomProperties As PDFCustomProperties
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As PDFCustomProperties

value = instance.CustomProperties
C#
public PDFCustomProperties CustomProperties {get;}
Managed Extensions for C++
public: __property PDFCustomProperties* get_CustomProperties();
C++/CLI
public:
property PDFCustomProperties^ CustomProperties {
   PDFCustomProperties^ get();
}

Return Value

a PDFCustomProperties object storing the document's custom properties.

Remarks

The properties in this collection are stored in the DocumentInformation dictionary as custom keys.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


Dictionary Property

Dictionary Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Dictionary Property

Gets the document information dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dictionary As PDFDictionary
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As PDFDictionary

value = instance.Dictionary
C#
public PDFDictionary Dictionary {get;}
Managed Extensions for C++
public: __property PDFDictionary* get_Dictionary();
C++/CLI
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Return Value

The raw document information dictionary.

Remarks

This property gives you direct access to document information dictionary and its associated resources. Note: Modifying directly the document information dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


Keywords Property

Keywords Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Keywords Property

Gets or sets the keywords of the document.

Syntax

Visual Basic (Declaration)
Public Property Keywords As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As String

instance.Keywords = value

value = instance.Keywords
C#
public string Keywords {get; set;}
Managed Extensions for C++
public: __property string* get_Keywords();
public: __property void set_Keywords(
   string* value
);
C++/CLI
public:
property String^ Keywords {
   String^ get();
   void set (String^ value);
}

Return Value

The document keywords.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


ModDate Property

ModDate Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : ModDate Property

Gets or sets the date when the document was modified.

Syntax

Visual Basic (Declaration)
Public Property ModDate As Date
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As Date

instance.ModDate = value

value = instance.ModDate
C#
public DateTime ModDate {get; set;}
Managed Extensions for C++
public: __property DateTime get_ModDate();
public: __property void set_ModDate(
   DateTime value
);
C++/CLI
public:
property DateTime ModDate {
   DateTime get();
   void set (DateTime value);
}

Return Value

The document modifiy date.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


Producer Property

Producer Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Producer Property

Gets or sets the PDF engine that produced the document.

Syntax

Visual Basic (Declaration)
Public Property Producer As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As String

instance.Producer = value

value = instance.Producer
C#
public string Producer {get; set;}
Managed Extensions for C++
public: __property string* get_Producer();
public: __property void set_Producer(
   string* value
);
C++/CLI
public:
property String^ Producer {
   String^ get();
   void set (String^ value);
}

Return Value

The document producer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


Subject Property

Subject Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Subject Property

Gets or sets the subject of the document.

Syntax

Visual Basic (Declaration)
Public Property Subject As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As String

instance.Subject = value

value = instance.Subject
C#
public string Subject {get; set;}
Managed Extensions for C++
public: __property string* get_Subject();
public: __property void set_Subject(
   string* value
);
C++/CLI
public:
property String^ Subject {
   String^ get();
   void set (String^ value);
}

Return Value

The document subject.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


Title Property

Title Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentInformation Class : Title Property

Gets or sets the title of the document.

Syntax

Visual Basic (Declaration)
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentInformation
Dim value As String

instance.Title = value

value = instance.Title
C#
public string Title {get; set;}
Managed Extensions for C++
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
C++/CLI
public:
property String^ Title {
   String^ get();
   void set (String^ value);
}

Return Value

The document title.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentInformation Class
PDFDocumentInformation Members


PDFDocumentLoadOptions Class

PDFDocumentLoadOptions Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentLoadOptions Class

Provides several options for loading a PDF file.

Syntax

Visual Basic (Declaration)
Public Class PDFDocumentLoadOptions
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentLoadOptions
C#
public class PDFDocumentLoadOptions
Managed Extensions for C++
public __gc class PDFDocumentLoadOptions
C++/CLI
public ref class PDFDocumentLoadOptions

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDocumentLoadOptions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentLoadOptions Members
O2S.Components.PDF4NET Namespace


PDFDocumentLoadOptions Class Members

PDFDocumentLoadOptions Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentLoadOptions Class

The following tables list the members exposed by PDFDocumentLoadOptions.

Public Constructors

 | Name | Description
Public Constructor | PDFDocumentLoadOptions Constructor | Overloaded. Initializes a new PDFDocumentLoadOptions
Top

Public Properties

 | Name | Description
Public Property | CreatePageCanvas | Gets or sets a value indicating whether the page canvas should be created or not.
Public Property | LoadBookmarks | Gets or sets a value indicating whether the document bookmarks should be loaded or not.
Public Property | LoadDestinations | Gets or sets a value indicating whether the document destinations should be loaded or not.
Public Property | LoadDocumentAttachments | Gets or sets a value indicating whether the document attachments should be loaded or not.
Public Property | LoadJavaScript | Gets or sets a value indicating whether the document level JavaScript should be loaded or not.
Public Property | LoadPageContent | Gets or sets a value indicating whether complete page content should be loaded or not.
Public Property | LoadStructureTree | Gets or sets a value indicating whether the document structure tree should be loaded or not.
Public Property | LoadThreads | Gets or sets a value indicating whether the document threads should be loaded or not.
Public Property | Password | Gets or sets the password for opening the PDF file.
Top

See Also

Reference

PDFDocumentLoadOptions Class
O2S.Components.PDF4NET Namespace


PDFDocumentLoadOptions Constructor

PDFDocumentLoadOptions Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : PDFDocumentLoadOptions Constructor

Initializes a new PDFDocumentLoadOptions

Overload List

Overload | Description
PDFDocumentLoadOptions Constructor() | Initializes a new PDFDocumentLoadOptions
PDFDocumentLoadOptions Constructor(Boolean) | Initializes a new PDFDocumentLoadOptions
PDFDocumentLoadOptions Constructor(Byte[]) | Initializes a new PDFDocumentLoadOptions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


PDFDocumentLoadOptions Constructor()

PDFDocumentLoadOptions Constructor()
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class > PDFDocumentLoadOptions Constructor : PDFDocumentLoadOptions Constructor()

Initializes a new PDFDocumentLoadOptions

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentLoadOptions()
C#
public PDFDocumentLoadOptions()
Managed Extensions for C++
public: PDFDocumentLoadOptions();
C++/CLI
public:
PDFDocumentLoadOptions();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members
Overload List


PDFDocumentLoadOptions Constructor(Boolean)

PDFDocumentLoadOptions Constructor(Boolean)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class > PDFDocumentLoadOptions Constructor : PDFDocumentLoadOptions Constructor(Boolean)

load
True if all the load options should be set to true, false otherwise.
Initializes a new PDFDocumentLoadOptions

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal load As Boolean _
)
Visual Basic (Usage) Copy Code
Dim load As Boolean

Dim instance As PDFDocumentLoadOptions(load)
C#
public PDFDocumentLoadOptions(
   bool load
)
Managed Extensions for C++
public: PDFDocumentLoadOptions(
   bool load
)
C++/CLI
public:
PDFDocumentLoadOptions(
   bool load
)

Parameters

load
True if all the load options should be set to true, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members
Overload List


PDFDocumentLoadOptions Constructor(Byte[])

PDFDocumentLoadOptions Constructor(Byte[])
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class > PDFDocumentLoadOptions Constructor : PDFDocumentLoadOptions Constructor(Byte[])

password
The password for opening the PDF file.
Initializes a new PDFDocumentLoadOptions

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal password() As Byte _
)
Visual Basic (Usage) Copy Code
Dim password() As Byte

Dim instance As PDFDocumentLoadOptions(password)
C#
public PDFDocumentLoadOptions(
   byte[] password
)
Managed Extensions for C++
public: PDFDocumentLoadOptions(
   byte[]* password
)
C++/CLI
public:
PDFDocumentLoadOptions(
   array<byte>^ password
)

Parameters

password
The password for opening the PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members
Overload List


PDFDocumentLoadOptions Class Properties

PDFDocumentLoadOptions Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentLoadOptions Class

For a list of all members of this type, see PDFDocumentLoadOptions members.

Public Properties

 | Name | Description
Public Property | CreatePageCanvas | Gets or sets a value indicating whether the page canvas should be created or not.
Public Property | LoadBookmarks | Gets or sets a value indicating whether the document bookmarks should be loaded or not.
Public Property | LoadDestinations | Gets or sets a value indicating whether the document destinations should be loaded or not.
Public Property | LoadDocumentAttachments | Gets or sets a value indicating whether the document attachments should be loaded or not.
Public Property | LoadJavaScript | Gets or sets a value indicating whether the document level JavaScript should be loaded or not.
Public Property | LoadPageContent | Gets or sets a value indicating whether complete page content should be loaded or not.
Public Property | LoadStructureTree | Gets or sets a value indicating whether the document structure tree should be loaded or not.
Public Property | LoadThreads | Gets or sets a value indicating whether the document threads should be loaded or not.
Public Property | Password | Gets or sets the password for opening the PDF file.
Top

See Also

Reference

PDFDocumentLoadOptions Class
O2S.Components.PDF4NET Namespace


CreatePageCanvas Property

CreatePageCanvas Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : CreatePageCanvas Property

Gets or sets a value indicating whether the page canvas should be created or not.

Syntax

Visual Basic (Declaration)
Public Property CreatePageCanvas As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.CreatePageCanvas = value

value = instance.CreatePageCanvas
C#
public bool CreatePageCanvas {get; set;}
Managed Extensions for C++
public: __property bool get_CreatePageCanvas();
public: __property void set_CreatePageCanvas(
   bool value
);
C++/CLI
public:
property bool CreatePageCanvas {
   bool get();
   void set (bool value);
}

Return Value

True if the page canvas should be created, false otherwise. Default is true.

Remarks

This property should be set to false only when signing a PDF file that already contains a valid signature. Creating page canvases in such scenario causes the initial signature to be invalidated because the pages has been modified when the canvases have been created.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


LoadBookmarks Property

LoadBookmarks Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : LoadBookmarks Property

Gets or sets a value indicating whether the document bookmarks should be loaded or not.

Syntax

Visual Basic (Declaration)
Public Property LoadBookmarks As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.LoadBookmarks = value

value = instance.LoadBookmarks
C#
public bool LoadBookmarks {get; set;}
Managed Extensions for C++
public: __property bool get_LoadBookmarks();
public: __property void set_LoadBookmarks(
   bool value
);
C++/CLI
public:
property bool LoadBookmarks {
   bool get();
   void set (bool value);
}

Return Value

True if the bookmarks should be loaded, false otherwise. Default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


LoadDestinations Property

LoadDestinations Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : LoadDestinations Property

Gets or sets a value indicating whether the document destinations should be loaded or not.

Syntax

Visual Basic (Declaration)
Public Property LoadDestinations As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.LoadDestinations = value

value = instance.LoadDestinations
C#
public bool LoadDestinations {get; set;}
Managed Extensions for C++
public: __property bool get_LoadDestinations();
public: __property void set_LoadDestinations(
   bool value
);
C++/CLI
public:
property bool LoadDestinations {
   bool get();
   void set (bool value);
}

Return Value

True if the destinations should be loaded, false otherwise. Default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


LoadDocumentAttachments Property

LoadDocumentAttachments Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : LoadDocumentAttachments Property

Gets or sets a value indicating whether the document attachments should be loaded or not.

Syntax

Visual Basic (Declaration)
Public Property LoadDocumentAttachments As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.LoadDocumentAttachments = value

value = instance.LoadDocumentAttachments
C#
public bool LoadDocumentAttachments {get; set;}
Managed Extensions for C++
public: __property bool get_LoadDocumentAttachments();
public: __property void set_LoadDocumentAttachments(
   bool value
);
C++/CLI
public:
property bool LoadDocumentAttachments {
   bool get();
   void set (bool value);
}

Return Value

True if the document attachments should be loaded, false otherwise. Default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


LoadJavaScript Property

LoadJavaScript Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : LoadJavaScript Property

Gets or sets a value indicating whether the document level JavaScript should be loaded or not.

Syntax

Visual Basic (Declaration)
Public Property LoadJavaScript As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.LoadJavaScript = value

value = instance.LoadJavaScript
C#
public bool LoadJavaScript {get; set;}
Managed Extensions for C++
public: __property bool get_LoadJavaScript();
public: __property void set_LoadJavaScript(
   bool value
);
C++/CLI
public:
property bool LoadJavaScript {
   bool get();
   void set (bool value);
}

Return Value

True if the document level JavaScript should be loaded, false otherwise. Default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


LoadPageContent Property

LoadPageContent Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : LoadPageContent Property

Gets or sets a value indicating whether complete page content should be loaded or not.

Syntax

Visual Basic (Declaration)
Public Property LoadPageContent As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.LoadPageContent = value

value = instance.LoadPageContent
C#
public bool LoadPageContent {get; set;}
Managed Extensions for C++
public: __property bool get_LoadPageContent();
public: __property void set_LoadPageContent(
   bool value
);
C++/CLI
public:
property bool LoadPageContent {
   bool get();
   void set (bool value);
}

Return Value

True if complete page content needs to be loaded, false otherwise. Default is true.

Remarks

Setting this property to true causes the complete page content to load, otherwise only the page header is loaded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


LoadStructureTree Property

LoadStructureTree Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : LoadStructureTree Property

Gets or sets a value indicating whether the document structure tree should be loaded or not.

Syntax

Visual Basic (Declaration)
Public Property LoadStructureTree As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.LoadStructureTree = value

value = instance.LoadStructureTree
C#
public bool LoadStructureTree {get; set;}
Managed Extensions for C++
public: __property bool get_LoadStructureTree();
public: __property void set_LoadStructureTree(
   bool value
);
C++/CLI
public:
property bool LoadStructureTree {
   bool get();
   void set (bool value);
}

Return Value

True if the document structure tree should be loaded, false otherwise. Default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


LoadThreads Property

LoadThreads Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : LoadThreads Property

Gets or sets a value indicating whether the document threads should be loaded or not.

Syntax

Visual Basic (Declaration)
Public Property LoadThreads As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentLoadOptions
Dim value As Boolean

instance.LoadThreads = value

value = instance.LoadThreads
C#
public bool LoadThreads {get; set;}
Managed Extensions for C++
public: __property bool get_LoadThreads();
public: __property void set_LoadThreads(
   bool value
);
C++/CLI
public:
property bool LoadThreads {
   bool get();
   void set (bool value);
}

Return Value

True if the threads should be loaded, false otherwise. Default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


Password Property

Password Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentLoadOptions Class : Password Property

Gets or sets the password for opening the PDF file.

Syntax

Visual Basic (Declaration)
Public Property Password As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentLoadOptions
Dim value() As Byte

instance.Password = value

value = instance.Password
C#
public byte[] Password {get; set;}
Managed Extensions for C++
public: __property byte[]* get_Password();
public: __property void set_Password(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ Password {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

The user or owner password required for opening the PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentLoadOptions Class
PDFDocumentLoadOptions Members


PDFDocumentSaveOptions Class

PDFDocumentSaveOptions Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentSaveOptions Class

Provides several options for loading a PDF file.

Syntax

Visual Basic (Declaration)
Public Class PDFDocumentSaveOptions
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentSaveOptions
C#
public class PDFDocumentSaveOptions
Managed Extensions for C++
public __gc class PDFDocumentSaveOptions
C++/CLI
public ref class PDFDocumentSaveOptions

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDocumentSaveOptions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentSaveOptions Members
O2S.Components.PDF4NET Namespace


PDFDocumentSaveOptions Class Members

PDFDocumentSaveOptions Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentSaveOptions Class

The following tables list the members exposed by PDFDocumentSaveOptions.

Public Constructors

 | Name | Description
Public Constructor | PDFDocumentSaveOptions Constructor | Initializes a new PDFDocumentSaveOptions
Top

Public Properties

 | Name | Description
Public Property | FastWebView | Gets or sets a value indicating whether the document should be saved in fast web view mode or not.
Public Property | IncrementalUpdate | Gets or sets a value indicating whether incremental update should be used of document save or not.
Top

See Also

Reference

PDFDocumentSaveOptions Class
O2S.Components.PDF4NET Namespace


PDFDocumentSaveOptions Constructor

PDFDocumentSaveOptions Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentSaveOptions Class : PDFDocumentSaveOptions Constructor

Initializes a new PDFDocumentSaveOptions

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentSaveOptions()
C#
public PDFDocumentSaveOptions()
Managed Extensions for C++
public: PDFDocumentSaveOptions();
C++/CLI
public:
PDFDocumentSaveOptions();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentSaveOptions Class
PDFDocumentSaveOptions Members


PDFDocumentSaveOptions Class Properties

PDFDocumentSaveOptions Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentSaveOptions Class

For a list of all members of this type, see PDFDocumentSaveOptions members.

Public Properties

 | Name | Description
Public Property | FastWebView | Gets or sets a value indicating whether the document should be saved in fast web view mode or not.
Public Property | IncrementalUpdate | Gets or sets a value indicating whether incremental update should be used of document save or not.
Top

See Also

Reference

PDFDocumentSaveOptions Class
O2S.Components.PDF4NET Namespace


FastWebView Property

FastWebView Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentSaveOptions Class : FastWebView Property

Gets or sets a value indicating whether the document should be saved in fast web view mode or not.

Syntax

Visual Basic (Declaration)
Public Property FastWebView As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentSaveOptions
Dim value As Boolean

instance.FastWebView = value

value = instance.FastWebView
C#
public bool FastWebView {get; set;}
Managed Extensions for C++
public: __property bool get_FastWebView();
public: __property void set_FastWebView(
   bool value
);
C++/CLI
public:
property bool FastWebView {
   bool get();
   void set (bool value);
}

Return Value

True if the document should be saved in fast web view mode, false otherwise. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentSaveOptions Class
PDFDocumentSaveOptions Members


IncrementalUpdate Property

IncrementalUpdate Property
[image]
O2S.Components.PDF4NET Namespace > PDFDocumentSaveOptions Class : IncrementalUpdate Property

Gets or sets a value indicating whether incremental update should be used of document save or not.

Syntax

Visual Basic (Declaration)
Public Property IncrementalUpdate As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDocumentSaveOptions
Dim value As Boolean

instance.IncrementalUpdate = value

value = instance.IncrementalUpdate
C#
public bool IncrementalUpdate {get; set;}
Managed Extensions for C++
public: __property bool get_IncrementalUpdate();
public: __property void set_IncrementalUpdate(
   bool value
);
C++/CLI
public:
property bool IncrementalUpdate {
   bool get();
   void set (bool value);
}

Return Value

True if incremental update should be used, false otherwise. Default is false.

Remarks

Incremental update should be used when the document has been partially loaded (any of the properties of the PDFDocumentLoadOptions object have been set to false). Incremental updates allow faster saves of the PDF document because only the modified objects are appended at the end of the source file. Incremental updates work only when the source document is loaded from disk and not from a stream.
If the document has been partially loaded but this property is false, the remaining parts of the document will be loaded in memory before saving the file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDocumentSaveOptions Class
PDFDocumentSaveOptions Members


PDFException Class

PDFException Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFException Class

Defines a generic PDF exception.

Syntax

Visual Basic (Declaration)
Public Class PDFException
   Inherits ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As PDFException
C#
public class PDFException : ApplicationException
Managed Extensions for C++
public __gc class PDFException : public ApplicationException
C++/CLI
public ref class PDFException : public ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFException
O2S.Components.PDF4NET.PDFInvalidPasswordException
O2S.Components.PDF4NET.Cos.InvalidPDFValueException
O2S.Components.PDF4NET.Cos.InvalidPasswordException
O2S.Components.PDF4NET.Cos.IncompatiblePDFObjectException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFException Members
O2S.Components.PDF4NET Namespace


PDFException Class Members

PDFException Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFException Class

The following tables list the members exposed by PDFException.

Public Constructors

 | Name | Description
Public Constructor | PDFException Constructor | Overloaded. Initializes a new PDFException object.
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

PDFException Class
O2S.Components.PDF4NET Namespace


PDFException Constructor

PDFException Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFException Class : PDFException Constructor

Initializes a new PDFException object.

Overload List

Overload | Description
PDFException Constructor(String) | Initializes a new PDFException object.
PDFException Constructor(String,Exception) | Initializes a new PDFException object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFException Class
PDFException Members


PDFException Constructor(String)

PDFException Constructor(String)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFException Class > PDFException Constructor : PDFException Constructor(String)

message
The message that describes the exception.
Initializes a new PDFException object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As PDFException(message)
C#
public PDFException(
   string message
)
Managed Extensions for C++
public: PDFException(
   string* message
)
C++/CLI
public:
PDFException(
   String^ message
)

Parameters

message
The message that describes the exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFException Class
PDFException Members
Overload List


PDFException Constructor(String,Exception)

PDFException Constructor(String,Exception)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFException Class > PDFException Constructor : PDFException Constructor(String,Exception)

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.
Initializes a new PDFException object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As PDFException(message, innerException)
C#
public PDFException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: PDFException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
PDFException(
   String^ message,
   Exception^ innerException
)

Parameters

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFException Class
PDFException Members
Overload List


PDFGraphicsContainer Class

PDFGraphicsContainer Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFGraphicsContainer Class

Defines an abstract object that can store graphic content.

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFGraphicsContainer
Visual Basic (Usage) Copy Code
Dim instance As PDFGraphicsContainer
C#
public abstract class PDFGraphicsContainer
Managed Extensions for C++
public __gc abstract class PDFGraphicsContainer
C++/CLI
public ref class PDFGraphicsContainer abstract

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.PDFPage
O2S.Components.PDF4NET.PDFFile.PDFImportedContent
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.Graphics.PDFPattern

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGraphicsContainer Members
O2S.Components.PDF4NET Namespace


PDFGraphicsContainer Class Members

PDFGraphicsContainer Class Members
[image]
O2S.Components.PDF4NET Namespace : PDFGraphicsContainer Class

The following tables list the members exposed by PDFGraphicsContainer.

See Also

Reference

PDFGraphicsContainer Class
O2S.Components.PDF4NET Namespace


PDFInvalidPasswordException Class

PDFInvalidPasswordException Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFInvalidPasswordException Class

The exception that is thrown when the password supplied for opening the file is invalid.

Syntax

Visual Basic (Declaration)
Public Class PDFInvalidPasswordException
   Inherits PDFException
Visual Basic (Usage) Copy Code
Dim instance As PDFInvalidPasswordException
C#
public class PDFInvalidPasswordException : PDFException
Managed Extensions for C++
public __gc class PDFInvalidPasswordException : public PDFException
C++/CLI
public ref class PDFInvalidPasswordException : public PDFException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFException
O2S.Components.PDF4NET.PDFInvalidPasswordException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFInvalidPasswordException Members
O2S.Components.PDF4NET Namespace


PDFInvalidPasswordException Class Members

PDFInvalidPasswordException Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFInvalidPasswordException Class

The following tables list the members exposed by PDFInvalidPasswordException.

Public Constructors

 | Name | Description
Public Constructor | PDFInvalidPasswordException Constructor | Overloaded. Initializes a new InvalidPasswordException object.
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

PDFInvalidPasswordException Class
O2S.Components.PDF4NET Namespace


PDFInvalidPasswordException Constructor

PDFInvalidPasswordException Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFInvalidPasswordException Class : PDFInvalidPasswordException Constructor

Initializes a new InvalidPasswordException object.

Overload List

Overload | Description
PDFInvalidPasswordException Constructor(String) | Initializes a new InvalidPasswordException object.
PDFInvalidPasswordException Constructor(String,Exception) | Initializes a new InvalidPasswordException object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFInvalidPasswordException Class
PDFInvalidPasswordException Members


PDFInvalidPasswordException Constructor(String)

PDFInvalidPasswordException Constructor(String)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFInvalidPasswordException Class > PDFInvalidPasswordException Constructor : PDFInvalidPasswordException Constructor(String)

message
The message that describes the exception.
Initializes a new InvalidPasswordException object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As PDFInvalidPasswordException(message)
C#
public PDFInvalidPasswordException(
   string message
)
Managed Extensions for C++
public: PDFInvalidPasswordException(
   string* message
)
C++/CLI
public:
PDFInvalidPasswordException(
   String^ message
)

Parameters

message
The message that describes the exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFInvalidPasswordException Class
PDFInvalidPasswordException Members
Overload List


PDFInvalidPasswordException Constructor(String,Exception)

PDFInvalidPasswordException Constructor(String,Exception)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFInvalidPasswordException Class > PDFInvalidPasswordException Constructor : PDFInvalidPasswordException Constructor(String,Exception)

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.
Initializes a new InvalidPasswordException object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As PDFInvalidPasswordException(message, innerException)
C#
public PDFInvalidPasswordException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: PDFInvalidPasswordException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
PDFInvalidPasswordException(
   String^ message,
   Exception^ innerException
)

Parameters

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFInvalidPasswordException Class
PDFInvalidPasswordException Members
Overload List


PDFJavaScript Class

PDFJavaScript Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFJavaScript Class

Defines a fragment of JavaScript code.

Syntax

Visual Basic (Declaration)
Public Class PDFJavaScript
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScript
C#
public class PDFJavaScript
Managed Extensions for C++
public __gc class PDFJavaScript
C++/CLI
public ref class PDFJavaScript

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFJavaScript

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScript Members
O2S.Components.PDF4NET Namespace


PDFJavaScript Class Members

PDFJavaScript Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFJavaScript Class

The following tables list the members exposed by PDFJavaScript.

Public Constructors

 | Name | Description
Public Constructor | PDFJavaScript Constructor | Overloaded. Initializes a new PDFJavaScript object.
Top

Public Properties

 | Name | Description
Public Property | Script | Gets or sets the javascript code to be included in the block.
Top

See Also

Reference

PDFJavaScript Class
O2S.Components.PDF4NET Namespace


PDFJavaScript Constructor

PDFJavaScript Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScript Class : PDFJavaScript Constructor

Initializes a new PDFJavaScript object.

Overload List

Overload | Description
PDFJavaScript Constructor() | Initializes a new PDFJavaScript object.
PDFJavaScript Constructor(String) | Initializes a new PDFJavaScript object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScript Class
PDFJavaScript Members


PDFJavaScript Constructor()

PDFJavaScript Constructor()
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScript Class > PDFJavaScript Constructor : PDFJavaScript Constructor()

Initializes a new PDFJavaScript object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScript()
C#
public PDFJavaScript()
Managed Extensions for C++
public: PDFJavaScript();
C++/CLI
public:
PDFJavaScript();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScript Class
PDFJavaScript Members
Overload List


PDFJavaScript Constructor(String)

PDFJavaScript Constructor(String)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScript Class > PDFJavaScript Constructor : PDFJavaScript Constructor(String)

javaScript
The JavaScript code to be included in the fragment.
Initializes a new PDFJavaScript object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal javaScript As String _
)
Visual Basic (Usage) Copy Code
Dim javaScript As String

Dim instance As PDFJavaScript(javaScript)
C#
public PDFJavaScript(
   string javaScript
)
Managed Extensions for C++
public: PDFJavaScript(
   string* javaScript
)
C++/CLI
public:
PDFJavaScript(
   String^ javaScript
)

Parameters

javaScript
The JavaScript code to be included in the fragment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScript Class
PDFJavaScript Members
Overload List


PDFJavaScript Class Properties

PDFJavaScript Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFJavaScript Class

For a list of all members of this type, see PDFJavaScript members.

Public Properties

 | Name | Description
Public Property | Script | Gets or sets the javascript code to be included in the block.
Top

See Also

Reference

PDFJavaScript Class
O2S.Components.PDF4NET Namespace


Script Property

Script Property
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScript Class : Script Property

Gets or sets the javascript code to be included in the block.

Syntax

Visual Basic (Declaration)
Public Property Script As String
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScript
Dim value As String

instance.Script = value

value = instance.Script
C#
public string Script {get; set;}
Managed Extensions for C++
public: __property string* get_Script();
public: __property void set_Script(
   string* value
);
C++/CLI
public:
property String^ Script {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing valid javascript code.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScript Class
PDFJavaScript Members


PDFJavaScriptCollection Class

PDFJavaScriptCollection Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFJavaScriptCollection Class

Defines a collection of annotations.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFJavaScriptCollection
   Inherits PDFCollection(Of PDFJavaScript, PDFDocument)
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptCollection
C#
public class PDFJavaScriptCollection : PDFCollection<PDFJavaScript, PDFDocument>
Managed Extensions for C++
public __gc class PDFJavaScriptCollection : public PDFCollection<PDFJavaScript, PDFDocument>
C++/CLI
public ref class PDFJavaScriptCollection : public PDFCollection<PDFJavaScript, PDFDocument>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<PDFJavaScript>
O2S.Components.PDF4NET.PDFCollection<PDFJavaScript, PDFDocument>
O2S.Components.PDF4NET.PDFJavaScriptCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Members
O2S.Components.PDF4NET Namespace


PDFJavaScriptCollection Class Members

PDFJavaScriptCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFJavaScriptCollection Class

The following tables list the members exposed by PDFJavaScriptCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new JavaScript action to the collection.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Top

See Also

Reference

PDFJavaScriptCollection Class
O2S.Components.PDF4NET Namespace


PDFJavaScriptCollection Class Methods

PDFJavaScriptCollection Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFJavaScriptCollection Class

For a list of all members of this type, see PDFJavaScriptCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new JavaScript action to the collection.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Top

See Also

Reference

PDFJavaScriptCollection Class
O2S.Components.PDF4NET Namespace


Add Method

Add Method
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class : Add Method

Adds a new JavaScript action to the collection.

Overload List

Overload | Description
Add(String) | Adds a new JavaScript action to the collection.
Add(PDFJavaScript) | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members


Add(String) Method

Add(String) Method
[image]
O2S.Components.PDF4NET Namespace > PDFJavaScriptCollection Class > Add Method : Add(String) Method

javaScript
The JavaScript code.
Adds a new JavaScript action to the collection.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Add( _
   ByVal javaScript As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptCollection
Dim javaScript As String

instance.Add(javaScript)
C#
public void Add(
   string javaScript
)
Managed Extensions for C++
public: void Add(
   string* javaScript
)
C++/CLI
public:
void Add(
   String^ javaScript
)

Parameters

javaScript
The JavaScript code.

Remarks

This method adds a JavaScript code fragment in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptCollection Class
PDFJavaScriptCollection Members
Overload List


PDFMetadataSchema Class

PDFMetadataSchema Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFMetadataSchema Class

Defines a schema within the document's metadata

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PDFMetadataSchema
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchema
C#
[DefaultMemberAttribute("Item")]
public class PDFMetadataSchema
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class PDFMetadataSchema
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFMetadataSchema

Remarks

A document's metadata consists of several schemas. A schema groups several properties. Each schema has a name and a namespace prefix.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFMetadataSchema

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchema Members
O2S.Components.PDF4NET Namespace


PDFMetadataSchema Class Members

PDFMetadataSchema Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFMetadataSchema Class

The following tables list the members exposed by PDFMetadataSchema.

Public Constructors

 | Name | Description
Public Constructor | PDFMetadataSchema Constructor | Initializes a new PDFMetadataSchema object.
Top

Public Properties

 | Name | Description
Public Property | Item | Gets or sets the value of a property.
Public Property | Name | Gets or sets schema's name.
Public Property | NamespacePrefix | Gets or sets schema's namespace prefix.
Public Property | Properties | Gets the hashtable storing the properties in this schema.
Public Property | StoreSchemaInDocInfo | Gets or sets whether the properties in this schema are stored also in Document Information dictionary or not.
Top

See Also

Reference

PDFMetadataSchema Class
O2S.Components.PDF4NET Namespace


PDFMetadataSchema Constructor

PDFMetadataSchema Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : PDFMetadataSchema Constructor

Initializes a new PDFMetadataSchema object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchema()
C#
public PDFMetadataSchema()
Managed Extensions for C++
public: PDFMetadataSchema();
C++/CLI
public:
PDFMetadataSchema();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


PDFMetadataSchema Class Properties

PDFMetadataSchema Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFMetadataSchema Class

For a list of all members of this type, see PDFMetadataSchema members.

Public Properties

 | Name | Description
Public Property | Item | Gets or sets the value of a property.
Public Property | Name | Gets or sets schema's name.
Public Property | NamespacePrefix | Gets or sets schema's namespace prefix.
Public Property | Properties | Gets the hashtable storing the properties in this schema.
Public Property | StoreSchemaInDocInfo | Gets or sets whether the properties in this schema are stored also in Document Information dictionary or not.
Top

See Also

Reference

PDFMetadataSchema Class
O2S.Components.PDF4NET Namespace


Item Property

Item Property
See Also Example
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : Item Property

propertyName
Gets or sets the value of a property.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal propertyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchema
Dim propertyName As String
Dim value As String

instance.Item(propertyName) = value

value = instance.Item(propertyName)
C#
public string this[
   string propertyName
]; {get; set;}
Managed Extensions for C++
public: __property string* get_Item(
   string* propertyName
);
public: __property void set_Item(
   string* propertyName,
   string* value
);
C++/CLI
public:
property String^ default [String^] {
   String^ get(String^ propertyName);
   void set (String^ propertyName, String^ value);
}

Parameters

propertyName

Return Value

A string value representing the value of the property. The name of the property is used to set or get its value.

Example

The following example set the "Company" property to the value "O2 Solutions" (in the sample below, schema is considered to be an instance of PDFMetadataSchema class):
C# Copy Code
...
schema["Company"] = "O2 Solutions";
...

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


Name Property

Name Property
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : Name Property

Gets or sets schema's name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchema
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Return Value

A unique string value representing the name of the schema. Usually, this name looks like an URL, but it is a simple identifier. It serves to uniquely identify the schema.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


NamespacePrefix Property

NamespacePrefix Property
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : NamespacePrefix Property

Gets or sets schema's namespace prefix.

Syntax

Visual Basic (Declaration)
Public Property NamespacePrefix As String
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchema
Dim value As String

instance.NamespacePrefix = value

value = instance.NamespacePrefix
C#
public string NamespacePrefix {get; set;}
Managed Extensions for C++
public: __property string* get_NamespacePrefix();
public: __property void set_NamespacePrefix(
   string* value
);
C++/CLI
public:
property String^ NamespacePrefix {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing the namespace prefix for this PDFMetadataSchema object. It is a short abbreviation for the full schema name. It follows the rules of XML namespaces. This namespace prefix has the local scope of the xmlns attribute that declares it (in the XML representation of the schema).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


Properties Property

Properties Property
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : Properties Property

Gets the hashtable storing the properties in this schema.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Properties As Dictionary(Of String, String)
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchema
Dim value As Dictionary(Of String, String)

value = instance.Properties
C#
public Dictionary<string, string> Properties {get;}
Managed Extensions for C++
public: __property Dictionary<string, string>* get_Properties();
C++/CLI
public:
property Dictionary<String, String>^ Properties {
   Dictionary<String, String>^ get();
}

Return Value

A Hashtable object storing the schema's properties.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


StoreSchemaInDocInfo Property

StoreSchemaInDocInfo Property
[image]
O2S.Components.PDF4NET Namespace > PDFMetadataSchema Class : StoreSchemaInDocInfo Property

Gets or sets whether the properties in this schema are stored also in Document Information dictionary or not.

Syntax

Visual Basic (Declaration)
Public Property StoreSchemaInDocInfo As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchema
Dim value As Boolean

instance.StoreSchemaInDocInfo = value

value = instance.StoreSchemaInDocInfo
C#
public bool StoreSchemaInDocInfo {get; set;}
Managed Extensions for C++
public: __property bool get_StoreSchemaInDocInfo();
public: __property void set_StoreSchemaInDocInfo(
   bool value
);
C++/CLI
public:
property bool StoreSchemaInDocInfo {
   bool get();
   void set (bool value);
}

Return Value

If true, the properties in this schema are stored also in Document Information dictionary. Default: false

Remarks

When schema's properties are stored in the Document Information dictionary, the property name is the key and its value is stored as a string value in the PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchema Class
PDFMetadataSchema Members


PDFMetadataSchemaCollection Class

PDFMetadataSchemaCollection Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFMetadataSchemaCollection Class

Defines a collection of bookmarks.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFMetadataSchemaCollection
   Inherits PDFCollection(Of PDFMetadataSchema, PDFDocument)
Visual Basic (Usage) Copy Code
Dim instance As PDFMetadataSchemaCollection
C#
public class PDFMetadataSchemaCollection : PDFCollection<PDFMetadataSchema, PDFDocument>
Managed Extensions for C++
public __gc class PDFMetadataSchemaCollection : public PDFCollection<PDFMetadataSchema, PDFDocument>
C++/CLI
public ref class PDFMetadataSchemaCollection : public PDFCollection<PDFMetadataSchema, PDFDocument>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<PDFMetadataSchema>
O2S.Components.PDF4NET.PDFCollection<PDFMetadataSchema, PDFDocument>
O2S.Components.PDF4NET.PDFMetadataSchemaCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetadataSchemaCollection Members
O2S.Components.PDF4NET Namespace


PDFMetadataSchemaCollection Class Members

PDFMetadataSchemaCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFMetadataSchemaCollection Class

The following tables list the members exposed by PDFMetadataSchemaCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Top

See Also

Reference

PDFMetadataSchemaCollection Class
O2S.Components.PDF4NET Namespace


PDFPage Class

PDFPage Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFPage Class

Defines a page within the pdf document.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPage
   Inherits PDFGraphicsContainer
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
C#
public class PDFPage : PDFGraphicsContainer
Managed Extensions for C++
public __gc class PDFPage : public PDFGraphicsContainer
C++/CLI
public ref class PDFPage : public PDFGraphicsContainer

Remarks

This class is used to create new pages in a pdf document. The pages can be created in any order. The position of the page in the PDFDocument.Pages collection gives the position of the page within the final pdf file. The content of the page is mainly created using the Canvas property of the page.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.PDFPage
O2S.Components.PDF4NET.PDFFile.PDFImportedPage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Members
O2S.Components.PDF4NET Namespace


PDFPage Class Members

PDFPage Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPage Class

The following tables list the members exposed by PDFPage.

Public Constructors

 | Name | Description
Public Constructor | PDFPage Constructor | Initializes a new PDFPage object.
Top

Public Properties

 | Name | Description
Public Property | Annotations | Gets the list of page annotations.
Public Property | ArtBox | Gets or sets the page art box.
Public Property | Background | Gets or sets the background of the page.
Public Property | BleedBox | Gets or sets the page bleed box.
Public Property | Canvas | Gets the page canvas.
Public Property | CloseAction | Gets or sets the action to be performed when the page is closed.
Public Property | CropBox | Gets or sets the page crop box.
Public Property | Dictionary | Gets the page dictionary.
Public Property | Fields | Gets the list of fields defined on this page.
Public Property | Height | Gets or sets the page height.
Public Property | MediaBox | Gets or sets the page media box.
Public Property | Number | Gets or sets the page number visual aspect for this PDFPage object.
Public Property | OpenAction | Gets or sets the action to be performed when the page is opened.
Public Property | Orientation | Gets or sets the page orientation.
Public Property | Rotation | Gets or sets the page rotation angle.
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | Size | Gets or sets the page size.
Public Property | TrimBox | Gets or sets the page trim box.
Public Property | Width | Gets or sets the page width.
Top

See Also

Reference

PDFPage Class
O2S.Components.PDF4NET Namespace


PDFPage Constructor

PDFPage Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : PDFPage Constructor

Initializes a new PDFPage object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPage()
C#
public PDFPage()
Managed Extensions for C++
public: PDFPage();
C++/CLI
public:
PDFPage();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


PDFPage Class Properties

PDFPage Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPage Class

For a list of all members of this type, see PDFPage members.

Public Properties

 | Name | Description
Public Property | Annotations | Gets the list of page annotations.
Public Property | ArtBox | Gets or sets the page art box.
Public Property | Background | Gets or sets the background of the page.
Public Property | BleedBox | Gets or sets the page bleed box.
Public Property | Canvas | Gets the page canvas.
Public Property | CloseAction | Gets or sets the action to be performed when the page is closed.
Public Property | CropBox | Gets or sets the page crop box.
Public Property | Dictionary | Gets the page dictionary.
Public Property | Fields | Gets the list of fields defined on this page.
Public Property | Height | Gets or sets the page height.
Public Property | MediaBox | Gets or sets the page media box.
Public Property | Number | Gets or sets the page number visual aspect for this PDFPage object.
Public Property | OpenAction | Gets or sets the action to be performed when the page is opened.
Public Property | Orientation | Gets or sets the page orientation.
Public Property | Rotation | Gets or sets the page rotation angle.
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | Size | Gets or sets the page size.
Public Property | TrimBox | Gets or sets the page trim box.
Public Property | Width | Gets or sets the page width.
Top

See Also

Reference

PDFPage Class
O2S.Components.PDF4NET Namespace


Annotations Property

Annotations Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Annotations Property

Gets the list of page annotations.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Annotations As PDFAnnotationCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFAnnotationCollection

value = instance.Annotations
C#
public PDFAnnotationCollection Annotations {get;}
Managed Extensions for C++
public: __property PDFAnnotationCollection* get_Annotations();
C++/CLI
public:
property PDFAnnotationCollection^ Annotations {
   PDFAnnotationCollection^ get();
}

Return Value

The list of all annotations included on the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


ArtBox Property

ArtBox Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : ArtBox Property

Gets or sets the page art box.

Syntax

Visual Basic (Declaration)
Public Property ArtBox As PDFRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFRectangle

instance.ArtBox = value

value = instance.ArtBox
C#
public PDFRectangle ArtBox {get; set;}
Managed Extensions for C++
public: __property PDFRectangle* get_ArtBox();
public: __property void set_ArtBox(
   PDFRectangle* value
);
C++/CLI
public:
property PDFRectangle^ ArtBox {
   PDFRectangle^ get();
   void set (PDFRectangle^ value);
}

Return Value

A rectangle that defines the page art box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


Background Property

Background Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Background Property

Gets or sets the background of the page.

Syntax

Visual Basic (Declaration)
Public Property Background As PDFPageBackground
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFPageBackground

instance.Background = value

value = instance.Background
C#
public PDFPageBackground Background {get; set;}
Managed Extensions for C++
public: __property PDFPageBackground* get_Background();
public: __property void set_Background(
   PDFPageBackground* value
);
C++/CLI
public:
property PDFPageBackground^ Background {
   PDFPageBackground^ get();
   void set (PDFPageBackground^ value);
}

Return Value

A PDFPageBackground object specifying the background of the page.

Remarks

The background is drawn always first on the page and the rest of page content appears on top of it.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


BleedBox Property

BleedBox Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : BleedBox Property

Gets or sets the page bleed box.

Syntax

Visual Basic (Declaration)
Public Property BleedBox As PDFRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFRectangle

instance.BleedBox = value

value = instance.BleedBox
C#
public PDFRectangle BleedBox {get; set;}
Managed Extensions for C++
public: __property PDFRectangle* get_BleedBox();
public: __property void set_BleedBox(
   PDFRectangle* value
);
C++/CLI
public:
property PDFRectangle^ BleedBox {
   PDFRectangle^ get();
   void set (PDFRectangle^ value);
}

Return Value

A rectangle that defines the page bleed box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


Canvas Property

Canvas Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Canvas Property

Gets the page canvas.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Canvas As PDFCanvas
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFCanvas

value = instance.Canvas
C#
public PDFCanvas Canvas {get;}
Managed Extensions for C++
public: __property PDFCanvas* get_Canvas();
C++/CLI
public:
property PDFCanvas^ Canvas {
   PDFCanvas^ get();
}

Return Value

The drawing surface of the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


CloseAction Property

CloseAction Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : CloseAction Property

Gets or sets the action to be performed when the page is closed.

Syntax

Visual Basic (Declaration)
Public Property CloseAction As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFAction

instance.CloseAction = value

value = instance.CloseAction
C#
public PDFAction CloseAction {get; set;}
Managed Extensions for C++
public: __property PDFAction* get_CloseAction();
public: __property void set_CloseAction(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ CloseAction {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

The action to be performed when the page is closed.

Remarks

This action applies to the page being closed and is executed before any other page is opened.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


CropBox Property

CropBox Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : CropBox Property

Gets or sets the page crop box.

Syntax

Visual Basic (Declaration)
Public Property CropBox As PDFRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFRectangle

instance.CropBox = value

value = instance.CropBox
C#
public PDFRectangle CropBox {get; set;}
Managed Extensions for C++
public: __property PDFRectangle* get_CropBox();
public: __property void set_CropBox(
   PDFRectangle* value
);
C++/CLI
public:
property PDFRectangle^ CropBox {
   PDFRectangle^ get();
   void set (PDFRectangle^ value);
}

Return Value

A rectangle that defines the page crop box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


Dictionary Property

Dictionary Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Dictionary Property

Gets the page dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dictionary As PDFDictionary
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFDictionary

value = instance.Dictionary
C#
public PDFDictionary Dictionary {get;}
Managed Extensions for C++
public: __property PDFDictionary* get_Dictionary();
C++/CLI
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Return Value

The raw page dictionary.

Remarks

This property gives you direct access to page dictionary and its associated resources. Note: Modifying directly the page dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


Fields Property

Fields Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Fields Property

Gets the list of fields defined on this page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As PDFFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFFieldCollection

value = instance.Fields
C#
public PDFFieldCollection Fields {get;}
Managed Extensions for C++
public: __property PDFFieldCollection* get_Fields();
C++/CLI
public:
property PDFFieldCollection^ Fields {
   PDFFieldCollection^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


Height Property

Height Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Height Property

Gets or sets the page height.

Syntax

Visual Basic (Declaration)
Public Property Height As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As Double

instance.Height = value

value = instance.Height
C#
public double Height {get; set;}
Managed Extensions for C++
public: __property double get_Height();
public: __property void set_Height(
   double value
);
C++/CLI
public:
property double Height {
   double get();
   void set (double value);
}

Return Value

The height of the page. The default value of this property is inherited from the document.

Remarks

In a pdf document, each page can have its own height by setting this property to the desired value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


MediaBox Property

MediaBox Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : MediaBox Property

Gets or sets the page media box.

Syntax

Visual Basic (Declaration)
Public Property MediaBox As PDFRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFRectangle

instance.MediaBox = value

value = instance.MediaBox
C#
public PDFRectangle MediaBox {get; set;}
Managed Extensions for C++
public: __property PDFRectangle* get_MediaBox();
public: __property void set_MediaBox(
   PDFRectangle* value
);
C++/CLI
public:
property PDFRectangle^ MediaBox {
   PDFRectangle^ get();
   void set (PDFRectangle^ value);
}

Return Value

A rectangle that defines the page media box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


Number Property

Number Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Number Property

Gets or sets the page number visual aspect for this PDFPage object.

Syntax

Visual Basic (Declaration)
Public Property Number As PDFPageNumber
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFPageNumber

instance.Number = value

value = instance.Number
C#
public PDFPageNumber Number {get; set;}
Managed Extensions for C++
public: __property PDFPageNumber* get_Number();
public: __property void set_Number(
   PDFPageNumber* value
);
C++/CLI
public:
property PDFPageNumber^ Number {
   PDFPageNumber^ get();
   void set (PDFPageNumber^ value);
}

Remarks

Each page can specify its own appearance for the page number by setting this property to the desired page number object. The default value for this property is the one defined for the whole document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


OpenAction Property

OpenAction Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : OpenAction Property

Gets or sets the action to be performed when the page is opened.

Syntax

Visual Basic (Declaration)
Public Property OpenAction As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFAction

instance.OpenAction = value

value = instance.OpenAction
C#
public PDFAction OpenAction {get; set;}
Managed Extensions for C++
public: __property PDFAction* get_OpenAction();
public: __property void set_OpenAction(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ OpenAction {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

The action to be performed when the page is opened.

Remarks

This action is executed after the document's Open action has been executed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


Orientation Property

Orientation Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Orientation Property

Gets or sets the page orientation.

Syntax

Visual Basic (Declaration)
Public Property Orientation As PDFPageOrientation
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFPageOrientation

instance.Orientation = value

value = instance.Orientation
C#
public PDFPageOrientation Orientation {get; set;}
Managed Extensions for C++
public: __property PDFPageOrientation get_Orientation();
public: __property void set_Orientation(
   PDFPageOrientation value
);
C++/CLI
public:
property PDFPageOrientation Orientation {
   PDFPageOrientation get();
   void set (PDFPageOrientation value);
}

Return Value

A PDFPageOrientation enumeration member specifying the orientation of the page, portrait or landscape.

Remarks

In a pdf document each page can have its own orientation, by setting this property to the desired value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


Rotation Property

Rotation Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Rotation Property

Gets or sets the page rotation angle.

Syntax

Visual Basic (Declaration)
Public Property Rotation As PDFRotationMode
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFRotationMode

instance.Rotation = value

value = instance.Rotation
C#
public PDFRotationMode Rotation {get; set;}
Managed Extensions for C++
public: __property PDFRotationMode get_Rotation();
public: __property void set_Rotation(
   PDFRotationMode value
);
C++/CLI
public:
property PDFRotationMode Rotation {
   PDFRotationMode get();
   void set (PDFRotationMode value);
}

Return Value

The rotation angle of the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


SeparationInfo Property

SeparationInfo Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : SeparationInfo Property

Gets the separation information associated with the page.

Syntax

Visual Basic (Declaration)
Public Property SeparationInfo As PDFSeparationInfo
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFSeparationInfo

instance.SeparationInfo = value

value = instance.SeparationInfo
C#
public PDFSeparationInfo SeparationInfo {get; set;}
Managed Extensions for C++
public: __property PDFSeparationInfo* get_SeparationInfo();
public: __property void set_SeparationInfo(
   PDFSeparationInfo* value
);
C++/CLI
public:
property PDFSeparationInfo^ SeparationInfo {
   PDFSeparationInfo^ get();
   void set (PDFSeparationInfo^ value);
}

Return Value

A PDFSeparationInfo object specifying the separation information for the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


Size Property

Size Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Size Property

Gets or sets the page size.

Syntax

Visual Basic (Declaration)
Public Property Size As PDFPageSize
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFPageSize

instance.Size = value

value = instance.Size
C#
public PDFPageSize Size {get; set;}
Managed Extensions for C++
public: __property PDFPageSize get_Size();
public: __property void set_Size(
   PDFPageSize value
);
C++/CLI
public:
property PDFPageSize Size {
   PDFPageSize get();
   void set (PDFPageSize value);
}

Return Value

A PageSize enumeration member specifying the page dimensions.

Remarks

Setting this property, the Width and Height properties are automatically set to the right value. But, setting the Width or the Height does not set this property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


TrimBox Property

TrimBox Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : TrimBox Property

Gets or sets the page trim box.

Syntax

Visual Basic (Declaration)
Public Property TrimBox As PDFRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As PDFRectangle

instance.TrimBox = value

value = instance.TrimBox
C#
public PDFRectangle TrimBox {get; set;}
Managed Extensions for C++
public: __property PDFRectangle* get_TrimBox();
public: __property void set_TrimBox(
   PDFRectangle* value
);
C++/CLI
public:
property PDFRectangle^ TrimBox {
   PDFRectangle^ get();
   void set (PDFRectangle^ value);
}

Return Value

A rectangle that defines the page trim box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


Width Property

Width Property
[image]
O2S.Components.PDF4NET Namespace > PDFPage Class : Width Property

Gets or sets the page width.

Syntax

Visual Basic (Declaration)
Public Property Width As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFPage
Dim value As Double

instance.Width = value

value = instance.Width
C#
public double Width {get; set;}
Managed Extensions for C++
public: __property double get_Width();
public: __property void set_Width(
   double value
);
C++/CLI
public:
property double Width {
   double get();
   void set (double value);
}

Return Value

The width of the page. The default value of this property is inherited from the document.

Remarks

In a pdf document, each page can have its own width by setting this property to the desired value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPage Class
PDFPage Members


PDFPageBackground Class

PDFPageBackground Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFPageBackground Class

Defines a background for a PDF page.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPageBackground
   Inherits PDFFormXObject
Visual Basic (Usage) Copy Code
Dim instance As PDFPageBackground
C#
public class PDFPageBackground : PDFFormXObject
Managed Extensions for C++
public __gc class PDFPageBackground : public PDFFormXObject
C++/CLI
public ref class PDFPageBackground : public PDFFormXObject

Remarks

The page background is displayed under actual page content.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.PDFPageBackground

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Members
O2S.Components.PDF4NET Namespace


PDFPageBackground Class Members

PDFPageBackground Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPageBackground Class

The following tables list the members exposed by PDFPageBackground.

Public Constructors

 | Name | Description
Public Constructor | PDFPageBackground Constructor | Overloaded. Initializes a new PDFPageBackground object.
Top

Public Properties

 | Name | Description
Public Property | Canvas | Gets the form XObject canvas. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Display | Gets or sets a value indicating whether the page background is displayed on the screen.
Public Property | Height | Gets or sets the height of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Location | Gets or sets the location on the page where the background is drawn.
Public Property | Opacity | Gets or sets the opacity of the page background.
Public Property | Orientation | Gets or sets the rotation angle of the page background.
Public Property | Print | Gets or sets a value indicating whether the page background is printed when the document is printed.
Public Property | Width | Gets or sets the width of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Top

See Also

Reference

PDFPageBackground Class
O2S.Components.PDF4NET Namespace


PDFPageBackground Constructor

PDFPageBackground Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class : PDFPageBackground Constructor

Initializes a new PDFPageBackground object.

Overload List

Overload | Description
PDFPageBackground Constructor() | Initializes a new PDFPageBackground object.
PDFPageBackground Constructor(PDFImportedContent) | Initializes a new PDFPageBackground object with the content of an existing PDF page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


PDFPageBackground Constructor()

PDFPageBackground Constructor()
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class > PDFPageBackground Constructor : PDFPageBackground Constructor()

Initializes a new PDFPageBackground object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPageBackground()
C#
public PDFPageBackground()
Managed Extensions for C++
public: PDFPageBackground();
C++/CLI
public:
PDFPageBackground();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members
Overload List


PDFPageBackground Constructor(PDFImportedContent)

PDFPageBackground Constructor(PDFImportedContent)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class > PDFPageBackground Constructor : PDFPageBackground Constructor(PDFImportedContent)

importedContent
The content of an existing PDF page
Initializes a new PDFPageBackground object with the content of an existing PDF page.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal importedContent As PDFImportedContent _
)
Visual Basic (Usage) Copy Code
Dim importedContent As PDFImportedContent

Dim instance As PDFPageBackground(importedContent)
C#
public PDFPageBackground(
   PDFImportedContent importedContent
)
Managed Extensions for C++
public: PDFPageBackground(
   PDFImportedContent* importedContent
)
C++/CLI
public:
PDFPageBackground(
   PDFImportedContent^ importedContent
)

Parameters

importedContent
The content of an existing PDF page

Remarks

This constructor initializes the page background with the content of another PDF page. All the new content that is added to the background is drawn on top of imported content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members
Overload List


PDFPageBackground Class Properties

PDFPageBackground Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPageBackground Class

For a list of all members of this type, see PDFPageBackground members.

Public Properties

 | Name | Description
Public Property | Canvas | Gets the form XObject canvas. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Display | Gets or sets a value indicating whether the page background is displayed on the screen.
Public Property | Height | Gets or sets the height of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Location | Gets or sets the location on the page where the background is drawn.
Public Property | Opacity | Gets or sets the opacity of the page background.
Public Property | Orientation | Gets or sets the rotation angle of the page background.
Public Property | Print | Gets or sets a value indicating whether the page background is printed when the document is printed.
Public Property | Width | Gets or sets the width of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Top

See Also

Reference

PDFPageBackground Class
O2S.Components.PDF4NET Namespace


Display Property

Display Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Display Property

Gets or sets a value indicating whether the page background is displayed on the screen.

Syntax

Visual Basic (Declaration)
Public Property Display As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFPageBackground
Dim value As Boolean

instance.Display = value

value = instance.Display
C#
public bool Display {get; set;}
Managed Extensions for C++
public: __property bool get_Display();
public: __property void set_Display(
   bool value
);
C++/CLI
public:
property bool Display {
   bool get();
   void set (bool value);
}

Return Value

True if the page background is displayed on the screen, false otherwise. Default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


Location Property

Location Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Location Property

Gets or sets the location on the page where the background is drawn.

Syntax

Visual Basic (Declaration)
Public Property Location As DisplayRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFPageBackground
Dim value As DisplayRectangle

instance.Location = value

value = instance.Location
C#
public DisplayRectangle Location {get; set;}
Managed Extensions for C++
public: __property DisplayRectangle* get_Location();
public: __property void set_Location(
   DisplayRectangle* value
);
C++/CLI
public:
property DisplayRectangle^ Location {
   DisplayRectangle^ get();
   void set (DisplayRectangle^ value);
}

Return Value

A DisplayRectangle object specifying the location on the page where the background is drawn.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


Opacity Property

Opacity Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Opacity Property

Gets or sets the opacity of the page background.

Syntax

Visual Basic (Declaration)
Public Property Opacity As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFPageBackground
Dim value As Double

instance.Opacity = value

value = instance.Opacity
C#
public double Opacity {get; set;}
Managed Extensions for C++
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
C++/CLI
public:
property double Opacity {
   double get();
   void set (double value);
}

Return Value

The opacity of the page background.

Remarks

This property controls the transparency level of the page background. 0 means full transparency, 100 means full opacity.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


Orientation Property

Orientation Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Orientation Property

Gets or sets the rotation angle of the page background.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFPageBackground
Dim value As Double

instance.Orientation = value

value = instance.Orientation
C#
public double Orientation {get; set;}
Managed Extensions for C++
public: __property double get_Orientation();
public: __property void set_Orientation(
   double value
);
C++/CLI
public:
property double Orientation {
   double get();
   void set (double value);
}

Return Value

A float value specifying the rotation angle of the page background.

Remarks

The page background is rotated around the top left corner of the Location rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


Print Property

Print Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageBackground Class : Print Property

Gets or sets a value indicating whether the page background is printed when the document is printed.

Syntax

Visual Basic (Declaration)
Public Property Print As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFPageBackground
Dim value As Boolean

instance.Print = value

value = instance.Print
C#
public bool Print {get; set;}
Managed Extensions for C++
public: __property bool get_Print();
public: __property void set_Print(
   bool value
);
C++/CLI
public:
property bool Print {
   bool get();
   void set (bool value);
}

Return Value

True if the page background is printed when the document is printed, false otherwise. Default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageBackground Class
PDFPageBackground Members


PDFPageCollection Class

PDFPageCollection Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFPageCollection Class

Defines a collection of PDF pages.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPageCollection
   Inherits PDFCollection(Of PDFPage, PDFDocument)
Visual Basic (Usage) Copy Code
Dim instance As PDFPageCollection
C#
public class PDFPageCollection : PDFCollection<PDFPage, PDFDocument>
Managed Extensions for C++
public __gc class PDFPageCollection : public PDFCollection<PDFPage, PDFDocument>
C++/CLI
public ref class PDFPageCollection : public PDFCollection<PDFPage, PDFDocument>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<PDFPage>
O2S.Components.PDF4NET.PDFCollection<PDFPage, PDFDocument>
O2S.Components.PDF4NET.PDFPageCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageCollection Members
O2S.Components.PDF4NET Namespace


PDFPageCollection Class Members

PDFPageCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFPageCollection Class

The following tables list the members exposed by PDFPageCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Top

See Also

Reference

PDFPageCollection Class
O2S.Components.PDF4NET Namespace


PDFPageDestination Class

PDFPageDestination Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFPageDestination Class

Defines a destination to a page within the current document.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPageDestination
   Inherits PDFDirectDestination
Visual Basic (Usage) Copy Code
Dim instance As PDFPageDestination
C#
public class PDFPageDestination : PDFDirectDestination
Managed Extensions for C++
public __gc class PDFPageDestination : public PDFDirectDestination
C++/CLI
public ref class PDFPageDestination : public PDFDirectDestination

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDestination
O2S.Components.PDF4NET.PDFDirectDestination
O2S.Components.PDF4NET.PDFPageDestination

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageDestination Members
O2S.Components.PDF4NET Namespace


PDFPageDestination Class Members

PDFPageDestination Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPageDestination Class

The following tables list the members exposed by PDFPageDestination.

Public Constructors

 | Name | Description
Public Constructor | PDFPageDestination Constructor | Initializes a new PDFPageDestination object.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate in the page where the viewer should display the page. (Inherited from PDFDirectDestination)
Public Property | Left | Gets or sets the left coordinate in the page where the viewer should display the page. (Inherited from PDFDirectDestination)
Public Property | MagnificationMode | Gets or sets the magnification mode. (Inherited from PDFDirectDestination)
Public Property | Page | Gets or sets the destination page.
Public Property | Right | Gets or sets the right coordinate in the page where the viewer should display the page. (Inherited from PDFDirectDestination)
Public Property | Top | Gets or sets the top coordinate in the page where the viewer should display the page. (Inherited from PDFDirectDestination)
Public Property | Zoom | Gets or sets the zoom factor to be used when the page is displayed. (Inherited from PDFDirectDestination)
Top

See Also

Reference

PDFPageDestination Class
O2S.Components.PDF4NET Namespace


PDFPageDestination Constructor

PDFPageDestination Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFPageDestination Class : PDFPageDestination Constructor

Initializes a new PDFPageDestination object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPageDestination()
C#
public PDFPageDestination()
Managed Extensions for C++
public: PDFPageDestination();
C++/CLI
public:
PDFPageDestination();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageDestination Class
PDFPageDestination Members


PDFPageDestination Class Properties

PDFPageDestination Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPageDestination Class

For a list of all members of this type, see PDFPageDestination members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate in the page where the viewer should display the page. (Inherited from PDFDirectDestination)
Public Property | Left | Gets or sets the left coordinate in the page where the viewer should display the page. (Inherited from PDFDirectDestination)
Public Property | MagnificationMode | Gets or sets the magnification mode. (Inherited from PDFDirectDestination)
Public Property | Page | Gets or sets the destination page.
Public Property | Right | Gets or sets the right coordinate in the page where the viewer should display the page. (Inherited from PDFDirectDestination)
Public Property | Top | Gets or sets the top coordinate in the page where the viewer should display the page. (Inherited from PDFDirectDestination)
Public Property | Zoom | Gets or sets the zoom factor to be used when the page is displayed. (Inherited from PDFDirectDestination)
Top

See Also

Reference

PDFPageDestination Class
O2S.Components.PDF4NET Namespace


Page Property

Page Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageDestination Class : Page Property

Gets or sets the destination page.

Syntax

Visual Basic (Declaration)
Public Property Page As PDFPage
Visual Basic (Usage) Copy Code
Dim instance As PDFPageDestination
Dim value As PDFPage

instance.Page = value

value = instance.Page
C#
public PDFPage Page {get; set;}
Managed Extensions for C++
public: __property PDFPage* get_Page();
public: __property void set_Page(
   PDFPage* value
);
C++/CLI
public:
property PDFPage^ Page {
   PDFPage^ get();
   void set (PDFPage^ value);
}

Return Value

The target page of the destination.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageDestination Class
PDFPageDestination Members


PDFPageNumber Class

PDFPageNumber Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFPageNumber Class

Defines the visual aspect of the page number when it is drawn on the page

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPageNumber
Visual Basic (Usage) Copy Code
Dim instance As PDFPageNumber
C#
public class PDFPageNumber
Managed Extensions for C++
public __gc class PDFPageNumber
C++/CLI
public ref class PDFPageNumber

Remarks

This class works in conjunction with PDFPageNumberingRange class. In order to have the page number automatically drawn on the page, at least one numberig range must be defined for the document and the page must be included in the interval defined by the numbering range.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFPageNumber

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageNumber Members
O2S.Components.PDF4NET Namespace


PDFPageNumber Class Members

PDFPageNumber Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPageNumber Class

The following tables list the members exposed by PDFPageNumber.

Public Constructors

 | Name | Description
Public Constructor | PDFPageNumber Constructor | Initializes a new PageNumber object. Supported by Compact .NET Edition.
Top

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the alignment of text used to draw the page number.
Public Property | Brush | Gets or sets the brush used to draw the page number.
Public Property | Font | Gets or sets the font used to draw the page number.
Public Property | HorizontalOffset | Gets or sets the horizontal offset used to position the page number.
Public Property | Pen | Gets or sets the pen used to draw the page number.
Public Property | VerticalOffset | Gets or sets the vertical offset used to position the page number.
Top

See Also

Reference

PDFPageNumber Class
O2S.Components.PDF4NET Namespace


PDFPageNumber Constructor

PDFPageNumber Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFPageNumber Class : PDFPageNumber Constructor

Initializes a new PageNumber object.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPageNumber()
C#
public PDFPageNumber()
Managed Extensions for C++
public: PDFPageNumber();
C++/CLI
public:
PDFPageNumber();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageNumber Class
PDFPageNumber Members


PDFPageNumber Class Properties

PDFPageNumber Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPageNumber Class

For a list of all members of this type, see PDFPageNumber members.

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the alignment of text used to draw the page number.
Public Property | Brush | Gets or sets the brush used to draw the page number.
Public Property | Font | Gets or sets the font used to draw the page number.
Public Property | HorizontalOffset | Gets or sets the horizontal offset used to position the page number.
Public Property | Pen | Gets or sets the pen used to draw the page number.
Public Property | VerticalOffset | Gets or sets the vertical offset used to position the page number.
Top

See Also

Reference

PDFPageNumber Class
O2S.Components.PDF4NET Namespace


Align Property

Align Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageNumber Class : Align Property

Gets or sets the alignment of text used to draw the page number.

Syntax

Visual Basic (Declaration)
Public Property Align As PDFTextAlign
Visual Basic (Usage) Copy Code
Dim instance As PDFPageNumber
Dim value As PDFTextAlign

instance.Align = value

value = instance.Align
C#
public PDFTextAlign Align {get; set;}
Managed Extensions for C++
public: __property PDFTextAlign get_Align();
public: __property void set_Align(
   PDFTextAlign value
);
C++/CLI
public:
property PDFTextAlign Align {
   PDFTextAlign get();
   void set (PDFTextAlign value);
}

Return Value

A TextAlign enumeration member used to position the page number within the page.

Remarks

This property is used to position the page number within the page. Top and bottom alignments use VerticalOffset property to position the page number. Left and right alignments use HorizontalOffset property to position the page number. Middle and center alignments center the page number on vertical, respectivelly on horizontal.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageNumber Class
PDFPageNumber Members


Brush Property

Brush Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageNumber Class : Brush Property

Gets or sets the brush used to draw the page number.

Syntax

Visual Basic (Declaration)
Public Property Brush As PDFBrush
Visual Basic (Usage) Copy Code
Dim instance As PDFPageNumber
Dim value As PDFBrush

instance.Brush = value

value = instance.Brush
C#
public PDFBrush Brush {get; set;}
Managed Extensions for C++
public: __property PDFBrush* get_Brush();
public: __property void set_Brush(
   PDFBrush* value
);
C++/CLI
public:
property PDFBrush^ Brush {
   PDFBrush^ get();
   void set (PDFBrush^ value);
}

Return Value

a PDFBrush object used to draw the page number.

Remarks

This PDFBrush object is used to fill the interior of the text representing the page number. If this is null, then the text will be drawn unfilled. The default value of this property is a brush of black color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageNumber Class
PDFPageNumber Members


Font Property

Font Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageNumber Class : Font Property

Gets or sets the font used to draw the page number.

Syntax

Visual Basic (Declaration)
Public Property Font As PDFFontBase
Visual Basic (Usage) Copy Code
Dim instance As PDFPageNumber
Dim value As PDFFontBase

instance.Font = value

value = instance.Font
C#
public PDFFontBase Font {get; set;}
Managed Extensions for C++
public: __property PDFFontBase* get_Font();
public: __property void set_Font(
   PDFFontBase* value
);
C++/CLI
public:
property PDFFontBase^ Font {
   PDFFontBase^ get();
   void set (PDFFontBase^ value);
}

Return Value

a PDFFontBase object used to draw the page number

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageNumber Class
PDFPageNumber Members


HorizontalOffset Property

HorizontalOffset Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageNumber Class : HorizontalOffset Property

Gets or sets the horizontal offset used to position the page number.

Syntax

Visual Basic (Declaration)
Public Property HorizontalOffset As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFPageNumber
Dim value As Double

instance.HorizontalOffset = value

value = instance.HorizontalOffset
C#
public double HorizontalOffset {get; set;}
Managed Extensions for C++
public: __property double get_HorizontalOffset();
public: __property void set_HorizontalOffset(
   double value
);
C++/CLI
public:
property double HorizontalOffset {
   double get();
   void set (double value);
}

Return Value

a double value specifying the horizontal offset

Remarks

The horizontal offset is used when the page number is left or right aligned.

When the page number is left aligned, the horizontal offset represents the distance between the left margin of the page and the left corner of the rectangle bounding the page number.

When the page number is right aligned, the horizontal offset represents the distance between the right margin of the page and the right corner of the rectangle bounding the page number.

When the page number is center aligned on the horizontal, the horizontal offset is not used. The horizontal center of the bounding rectangle is positioned at half of page width.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageNumber Class
PDFPageNumber Members


Pen Property

Pen Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageNumber Class : Pen Property

Gets or sets the pen used to draw the page number.

Syntax

Visual Basic (Declaration)
Public Property Pen As PDFPen
Visual Basic (Usage) Copy Code
Dim instance As PDFPageNumber
Dim value As PDFPen

instance.Pen = value

value = instance.Pen
C#
public PDFPen Pen {get; set;}
Managed Extensions for C++
public: __property PDFPen* get_Pen();
public: __property void set_Pen(
   PDFPen* value
);
C++/CLI
public:
property PDFPen^ Pen {
   PDFPen^ get();
   void set (PDFPen^ value);
}

Return Value

a PDFPen object used to draw the page number.

Remarks

This PDFPen object is used to draw the border of the text representing the page number. If this is null, then the text will be drawn without border. The default value of this property is null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageNumber Class
PDFPageNumber Members


VerticalOffset Property

VerticalOffset Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageNumber Class : VerticalOffset Property

Gets or sets the vertical offset used to position the page number.

Syntax

Visual Basic (Declaration)
Public Property VerticalOffset As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFPageNumber
Dim value As Double

instance.VerticalOffset = value

value = instance.VerticalOffset
C#
public double VerticalOffset {get; set;}
Managed Extensions for C++
public: __property double get_VerticalOffset();
public: __property void set_VerticalOffset(
   double value
);
C++/CLI
public:
property double VerticalOffset {
   double get();
   void set (double value);
}

Return Value

a double value specifying the vertical offset

Remarks

The vertical offset is used when the page number is top or bottom aligned.

When the page number is top aligned, the vertical offset represents the distance between the top margin of the page and the top corner of the rectangle bounding the page number.

When the page number is bottom aligned, the vertical offset represents the distance between the bottom margin of the page and the bottom corner of the rectangle bounding the page number.

When the page number is middle aligned on the vertical, the vertical offset is not used. The vertical middle of the bounding rectangle is positioned at half of page height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageNumber Class
PDFPageNumber Members


PDFPageNumberingRange Class

PDFPageNumberingRange Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFPageNumberingRange Class

Defines a series of consecutive pages within the PDF document using the same numbering system

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PDFPageNumberingRange
Visual Basic (Usage) Copy Code
Dim instance As PDFPageNumberingRange
C#
public sealed class PDFPageNumberingRange
Managed Extensions for C++
public __gc __sealed class PDFPageNumberingRange
C++/CLI
public ref class PDFPageNumberingRange sealed

Remarks

A numbering range defines a set of consecutive pages that use the same numbering system. The range is considered to start from the page specified by StartPageIndex property and ends at the last page of the document. If multiple numbering ranges are defined, then a numbering range ends where the next numbering range starts. The numbering ranges of a document are ordered ascending by StartPageIndex property.

For example, a document has an introduction on first 3 pages, then it starts first chapter from the 4th page. A numbering range starting at index zero can be defined for the introduction using roman numerals, then a new numbering range can be defined starting at index 3 using arabic numerals. For this new range, the start page number can be set to 1, this being the first logical page, although it is the 4th physical page in the document.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFPageNumberingRange

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageNumberingRange Members
O2S.Components.PDF4NET Namespace


PDFPageNumberingRange Class Members

PDFPageNumberingRange Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPageNumberingRange Class

The following tables list the members exposed by PDFPageNumberingRange.

Public Constructors

 | Name | Description
Public Constructor | PDFPageNumberingRange Constructor | Initializes a new PDFPageNumberingRange object.
Top

Public Properties

 | Name | Description
Public Property | NumberingStyle | Gets or sets the visual style of the page numbers for this PageNumberingRange object.
Public Property | PageNumberPrefix | Gets or sets the prefix that will be appended in front of the page number.
Public Property | PageNumberSuffix | Gets or sets the suffix that will be appended at the end of the page number.
Public Property | StartPageIndex | Gets or sets the start page where the numbering range starts.
Public Property | StartPageNumber | Gets or sets the page number the numbering of the pages starts for this range.
Top

See Also

Reference

PDFPageNumberingRange Class
O2S.Components.PDF4NET Namespace


PDFPageNumberingRange Constructor

PDFPageNumberingRange Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFPageNumberingRange Class : PDFPageNumberingRange Constructor

Initializes a new PDFPageNumberingRange object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPageNumberingRange()
C#
public PDFPageNumberingRange()
Managed Extensions for C++
public: PDFPageNumberingRange();
C++/CLI
public:
PDFPageNumberingRange();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageNumberingRange Class
PDFPageNumberingRange Members


PDFPageNumberingRange Class Properties

PDFPageNumberingRange Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPageNumberingRange Class

For a list of all members of this type, see PDFPageNumberingRange members.

Public Properties

 | Name | Description
Public Property | NumberingStyle | Gets or sets the visual style of the page numbers for this PageNumberingRange object.
Public Property | PageNumberPrefix | Gets or sets the prefix that will be appended in front of the page number.
Public Property | PageNumberSuffix | Gets or sets the suffix that will be appended at the end of the page number.
Public Property | StartPageIndex | Gets or sets the start page where the numbering range starts.
Public Property | StartPageNumber | Gets or sets the page number the numbering of the pages starts for this range.
Top

See Also

Reference

PDFPageNumberingRange Class
O2S.Components.PDF4NET Namespace


NumberingStyle Property

NumberingStyle Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageNumberingRange Class : NumberingStyle Property

Gets or sets the visual style of the page numbers for this PageNumberingRange object.

Syntax

Visual Basic (Declaration)
Public Property NumberingStyle As PDFNumberingStyle
Visual Basic (Usage) Copy Code
Dim instance As PDFPageNumberingRange
Dim value As PDFNumberingStyle

instance.NumberingStyle = value

value = instance.NumberingStyle
C#
public PDFNumberingStyle NumberingStyle {get; set;}
Managed Extensions for C++
public: __property PDFNumberingStyle get_NumberingStyle();
public: __property void set_NumberingStyle(
   PDFNumberingStyle value
);
C++/CLI
public:
property PDFNumberingStyle NumberingStyle {
   PDFNumberingStyle get();
   void set (PDFNumberingStyle value);
}

Return Value

a NumberingStyle enumeration member specifying the numbering style for this PageNumberingRange object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageNumberingRange Class
PDFPageNumberingRange Members


PageNumberPrefix Property

PageNumberPrefix Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageNumberingRange Class : PageNumberPrefix Property

Gets or sets the prefix that will be appended in front of the page number.

Syntax

Visual Basic (Declaration)
Public Property PageNumberPrefix As String
Visual Basic (Usage) Copy Code
Dim instance As PDFPageNumberingRange
Dim value As String

instance.PageNumberPrefix = value

value = instance.PageNumberPrefix
C#
public string PageNumberPrefix {get; set;}
Managed Extensions for C++
public: __property string* get_PageNumberPrefix();
public: __property void set_PageNumberPrefix(
   string* value
);
C++/CLI
public:
property String^ PageNumberPrefix {
   String^ get();
   void set (String^ value);
}

Return Value

a String value representing a prefix that is appended to all the page numbers in this range.

Remarks

This prefix is printed on the pages in the range before the page number. All pages in a range share the same prefix. This prefix is also visible in the Print dialog box of the PDF viewer, when specifing a range of pages to print.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageNumberingRange Class
PDFPageNumberingRange Members


PageNumberSuffix Property

PageNumberSuffix Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageNumberingRange Class : PageNumberSuffix Property

Gets or sets the suffix that will be appended at the end of the page number.

Syntax

Visual Basic (Declaration)
Public Property PageNumberSuffix As String
Visual Basic (Usage) Copy Code
Dim instance As PDFPageNumberingRange
Dim value As String

instance.PageNumberSuffix = value

value = instance.PageNumberSuffix
C#
public string PageNumberSuffix {get; set;}
Managed Extensions for C++
public: __property string* get_PageNumberSuffix();
public: __property void set_PageNumberSuffix(
   string* value
);
C++/CLI
public:
property String^ PageNumberSuffix {
   String^ get();
   void set (String^ value);
}

Return Value

a String value representing a suffix that is appended to all the page numbers in this range.

Remarks

This prefix is printed on the pages in the range after the page number. All pages in a range share the same suffix.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageNumberingRange Class
PDFPageNumberingRange Members


StartPageIndex Property

StartPageIndex Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageNumberingRange Class : StartPageIndex Property

Gets or sets the start page where the numbering range starts.

Syntax

Visual Basic (Declaration)
Public Property StartPageIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFPageNumberingRange
Dim value As Integer

instance.StartPageIndex = value

value = instance.StartPageIndex
C#
public int StartPageIndex {get; set;}
Managed Extensions for C++
public: __property int get_StartPageIndex();
public: __property void set_StartPageIndex(
   int value
);
C++/CLI
public:
property int StartPageIndex {
   int get();
   void set (int value);
}

Return Value

an integer value specifying the zero based index of the page where the numbering range starts. The index is considered within the pages collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageNumberingRange Class
PDFPageNumberingRange Members


StartPageNumber Property

StartPageNumber Property
[image]
O2S.Components.PDF4NET Namespace > PDFPageNumberingRange Class : StartPageNumber Property

Gets or sets the page number the numbering of the pages starts for this range.

Syntax

Visual Basic (Declaration)
Public Property StartPageNumber As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFPageNumberingRange
Dim value As Integer

instance.StartPageNumber = value

value = instance.StartPageNumber
C#
public int StartPageNumber {get; set;}
Managed Extensions for C++
public: __property int get_StartPageNumber();
public: __property void set_StartPageNumber(
   int value
);
C++/CLI
public:
property int StartPageNumber {
   int get();
   void set (int value);
}

Return Value

an integer value specifying the start page number for this PageNumberingRange object.

Remarks

This property specifies the page number that will be printed on the first page in this range. The other pages will be numbered consecutively, starting from this value. It represents a logical page number and it is related to the specific content of the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageNumberingRange Class
PDFPageNumberingRange Members


PDFPageNumberingRangeCollection Class

PDFPageNumberingRangeCollection Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFPageNumberingRangeCollection Class

Defines a collection of bookmarks.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPageNumberingRangeCollection
   Inherits PDFCollection(Of PDFPageNumberingRange, PDFDocument)
Visual Basic (Usage) Copy Code
Dim instance As PDFPageNumberingRangeCollection
C#
public class PDFPageNumberingRangeCollection : PDFCollection<PDFPageNumberingRange, PDFDocument>
Managed Extensions for C++
public __gc class PDFPageNumberingRangeCollection : public PDFCollection<PDFPageNumberingRange, PDFDocument>
C++/CLI
public ref class PDFPageNumberingRangeCollection : public PDFCollection<PDFPageNumberingRange, PDFDocument>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<PDFPageNumberingRange>
O2S.Components.PDF4NET.PDFCollection<PDFPageNumberingRange, PDFDocument>
O2S.Components.PDF4NET.PDFPageNumberingRangeCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPageNumberingRangeCollection Members
O2S.Components.PDF4NET Namespace


PDFPageNumberingRangeCollection Class Members

PDFPageNumberingRangeCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFPageNumberingRangeCollection Class

The following tables list the members exposed by PDFPageNumberingRangeCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Top

See Also

Reference

PDFPageNumberingRangeCollection Class
O2S.Components.PDF4NET Namespace


PDFPoint Class

PDFPoint Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFPoint Class

Represents a pair of floating point x- and y-coordinates that defines a point in a two-dimensional plane.

Syntax

Visual Basic (Declaration)
Public Class PDFPoint
Visual Basic (Usage) Copy Code
Dim instance As PDFPoint
C#
public class PDFPoint
Managed Extensions for C++
public __gc class PDFPoint
C++/CLI
public ref class PDFPoint

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFPoint

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPoint Members
O2S.Components.PDF4NET Namespace


PDFPoint Class Members

PDFPoint Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPoint Class

The following tables list the members exposed by PDFPoint.

Public Constructors

 | Name | Description
Public Constructor | PDFPoint Constructor | Overloaded. Initializes a new PDFPoint object.
Top

Public Properties

 | Name | Description
Public Property | X | Gets or set the x coordinate of this point.
Public Property | Y | Gets or set the y coordinate of this point.
Top

See Also

Reference

PDFPoint Class
O2S.Components.PDF4NET Namespace


PDFPoint Constructor

PDFPoint Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFPoint Class : PDFPoint Constructor

Initializes a new PDFPoint object.

Overload List

Overload | Description
PDFPoint Constructor() | Initializes a new PDFPoint object.
PDFPoint Constructor(Double,Double) | Initializes a new PDFPoint object based on the given coordinates.
PDFPoint Constructor(Point) | Initializes a new PDFPoint object based on a Point structure.
PDFPoint Constructor(PointF) | Initializes a new PDFPoint object based on a PointF structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPoint Class
PDFPoint Members


PDFPoint Constructor()

PDFPoint Constructor()
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFPoint Class > PDFPoint Constructor : PDFPoint Constructor()

Initializes a new PDFPoint object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPoint()
C#
public PDFPoint()
Managed Extensions for C++
public: PDFPoint();
C++/CLI
public:
PDFPoint();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPoint Class
PDFPoint Members
Overload List


PDFPoint Constructor(Double,Double)

PDFPoint Constructor(Double,Double)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFPoint Class > PDFPoint Constructor : PDFPoint Constructor(Double,Double)

x
the x coordinate of the point
y
the y coordinate of the point
Initializes a new PDFPoint object based on the given coordinates.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Double, _
   ByVal y As Double _
)
Visual Basic (Usage) Copy Code
Dim x As Double
Dim y As Double

Dim instance As PDFPoint(x, y)
C#
public PDFPoint(
   double x,
   double y
)
Managed Extensions for C++
public: PDFPoint(
   double x,
   double y
)
C++/CLI
public:
PDFPoint(
   double x,
   double y
)

Parameters

x
the x coordinate of the point
y
the y coordinate of the point

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPoint Class
PDFPoint Members
Overload List


PDFPoint Constructor(Point)

PDFPoint Constructor(Point)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFPoint Class > PDFPoint Constructor : PDFPoint Constructor(Point)

point
a Point structure to initialize this PDFPoint object.
Initializes a new PDFPoint object based on a Point structure.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal point As Point _
)
Visual Basic (Usage) Copy Code
Dim point As Point

Dim instance As PDFPoint(point)
C#
public PDFPoint(
   Point point
)
Managed Extensions for C++
public: PDFPoint(
   Point point
)
C++/CLI
public:
PDFPoint(
   Point point
)

Parameters

point
a Point structure to initialize this PDFPoint object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPoint Class
PDFPoint Members
Overload List


PDFPoint Constructor(PointF)

PDFPoint Constructor(PointF)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFPoint Class > PDFPoint Constructor : PDFPoint Constructor(PointF)

point
a PointF structure to initialize this PDFPoint object.
Initializes a new PDFPoint object based on a PointF structure.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal point As PointF _
)
Visual Basic (Usage) Copy Code
Dim point As PointF

Dim instance As PDFPoint(point)
C#
public PDFPoint(
   PointF point
)
Managed Extensions for C++
public: PDFPoint(
   PointF point
)
C++/CLI
public:
PDFPoint(
   PointF point
)

Parameters

point
a PointF structure to initialize this PDFPoint object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPoint Class
PDFPoint Members
Overload List


PDFPoint Class Properties

PDFPoint Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPoint Class

For a list of all members of this type, see PDFPoint members.

Public Properties

 | Name | Description
Public Property | X | Gets or set the x coordinate of this point.
Public Property | Y | Gets or set the y coordinate of this point.
Top

See Also

Reference

PDFPoint Class
O2S.Components.PDF4NET Namespace


X Property

X Property
[image]
O2S.Components.PDF4NET Namespace > PDFPoint Class : X Property

Gets or set the x coordinate of this point.

Syntax

Visual Basic (Declaration)
Public Property X As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFPoint
Dim value As Double

instance.X = value

value = instance.X
C#
public double X {get; set;}
Managed Extensions for C++
public: __property double get_X();
public: __property void set_X(
   double value
);
C++/CLI
public:
property double X {
   double get();
   void set (double value);
}

Return Value

A float value representing the x coordinate of this point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPoint Class
PDFPoint Members


Y Property

Y Property
[image]
O2S.Components.PDF4NET Namespace > PDFPoint Class : Y Property

Gets or set the y coordinate of this point.

Syntax

Visual Basic (Declaration)
Public Property Y As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFPoint
Dim value As Double

instance.Y = value

value = instance.Y
C#
public double Y {get; set;}
Managed Extensions for C++
public: __property double get_Y();
public: __property void set_Y(
   double value
);
C++/CLI
public:
property double Y {
   double get();
   void set (double value);
}

Return Value

A float value representing the y coordinate of this point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPoint Class
PDFPoint Members


PDFRectangle Class

PDFRectangle Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFRectangle Class

Defines a rectangle in PDF default coordinates, where the origin of the coordinate system is located in the bottom left corner of the page.

Syntax

Visual Basic (Declaration)
Public Class PDFRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangle
C#
public class PDFRectangle
Managed Extensions for C++
public __gc class PDFRectangle
C++/CLI
public ref class PDFRectangle

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFRectangle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangle Members
O2S.Components.PDF4NET Namespace


PDFRectangle Class Members

PDFRectangle Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET Namespace : PDFRectangle Class

The following tables list the members exposed by PDFRectangle.

Public Constructors

 | Name | Description
Public Constructor | PDFRectangle Constructor | Overloaded. Initializes a new PDFRectangle object.
Top

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the rectangle's height.
Public Property | LLX | Gets or sets X coordinate of the lower left corner.
Public Property | LLY | Gets or sets Y coordinate of the lower left corner.
Public Property | URX | Gets or sets X coordinate of the upper right corner.
Public Property | URY | Gets or sets Y coordinate of the upper right corner.
Public Property | Width | Gets or sets the rectangle's width.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the rectangle to string representation.
Top

See Also

Reference

PDFRectangle Class
O2S.Components.PDF4NET Namespace


PDFRectangle Constructor

PDFRectangle Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFRectangle Class : PDFRectangle Constructor

Initializes a new PDFRectangle object.

Overload List

Overload | Description
PDFRectangle Constructor() | Initializes a new PDFRectangle object.
PDFRectangle Constructor(Double,Double,Double,Double) | Initializes a new PDFRectangle object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangle Class
PDFRectangle Members


PDFRectangle Constructor()

PDFRectangle Constructor()
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFRectangle Class > PDFRectangle Constructor : PDFRectangle Constructor()

Initializes a new PDFRectangle object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangle()
C#
public PDFRectangle()
Managed Extensions for C++
public: PDFRectangle();
C++/CLI
public:
PDFRectangle();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangle Class
PDFRectangle Members
Overload List


PDFRectangle Constructor(Double,Double,Double,Double)

PDFRectangle Constructor(Double,Double,Double,Double)
See Also
[image]
O2S.Components.PDF4NET Namespace > PDFRectangle Class > PDFRectangle Constructor : PDFRectangle Constructor(Double,Double,Double,Double)

llx
The x coordinate of the lower left corner of the rectangle.
lly
The y coordinate of the lower left corner of the rectangle.
urx
The x coordinate of the upper right corner of the rectangle.
ury
The y coordinate of the upper right corner of the rectangle.
Initializes a new PDFRectangle object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal llx As Double, _
   ByVal lly As Double, _
   ByVal urx As Double, _
   ByVal ury As Double _
)
Visual Basic (Usage) Copy Code
Dim llx As Double
Dim lly As Double
Dim urx As Double
Dim ury As Double

Dim instance As PDFRectangle(llx, lly, urx, ury)
C#
public PDFRectangle(
   double llx,
   double lly,
   double urx,
   double ury
)
Managed Extensions for C++
public: PDFRectangle(
   double llx,
   double lly,
   double urx,
   double ury
)
C++/CLI
public:
PDFRectangle(
   double llx,
   double lly,
   double urx,
   double ury
)

Parameters

llx
The x coordinate of the lower left corner of the rectangle.
lly
The y coordinate of the lower left corner of the rectangle.
urx
The x coordinate of the upper right corner of the rectangle.
ury
The y coordinate of the upper right corner of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangle Class
PDFRectangle Members
Overload List


PDFRectangle Class Methods

PDFRectangle Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFRectangle Class

For a list of all members of this type, see PDFRectangle members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the rectangle to string representation.
Top

See Also

Reference

PDFRectangle Class
O2S.Components.PDF4NET Namespace


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET Namespace > PDFRectangle Class : ToString Method

Converts the rectangle to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangle
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangle Class
PDFRectangle Members


PDFRectangle Class Properties

PDFRectangle Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFRectangle Class

For a list of all members of this type, see PDFRectangle members.

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the rectangle's height.
Public Property | LLX | Gets or sets X coordinate of the lower left corner.
Public Property | LLY | Gets or sets Y coordinate of the lower left corner.
Public Property | URX | Gets or sets X coordinate of the upper right corner.
Public Property | URY | Gets or sets Y coordinate of the upper right corner.
Public Property | Width | Gets or sets the rectangle's width.
Top

See Also

Reference

PDFRectangle Class
O2S.Components.PDF4NET Namespace


Height Property

Height Property
[image]
O2S.Components.PDF4NET Namespace > PDFRectangle Class : Height Property

Gets or sets the rectangle's height.

Syntax

Visual Basic (Declaration)
Public Property Height As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangle
Dim value As Double

instance.Height = value

value = instance.Height
C#
public double Height {get; set;}
Managed Extensions for C++
public: __property double get_Height();
public: __property void set_Height(
   double value
);
C++/CLI
public:
property double Height {
   double get();
   void set (double value);
}

Return Value

The height of the rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangle Class
PDFRectangle Members


LLX Property

LLX Property
[image]
O2S.Components.PDF4NET Namespace > PDFRectangle Class : LLX Property

Gets or sets X coordinate of the lower left corner.

Syntax

Visual Basic (Declaration)
Public Property LLX As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangle
Dim value As Double

instance.LLX = value

value = instance.LLX
C#
public double LLX {get; set;}
Managed Extensions for C++
public: __property double get_LLX();
public: __property void set_LLX(
   double value
);
C++/CLI
public:
property double LLX {
   double get();
   void set (double value);
}

Return Value

The X coordinate of the lower left corner of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangle Class
PDFRectangle Members


LLY Property

LLY Property
[image]
O2S.Components.PDF4NET Namespace > PDFRectangle Class : LLY Property

Gets or sets Y coordinate of the lower left corner.

Syntax

Visual Basic (Declaration)
Public Property LLY As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangle
Dim value As Double

instance.LLY = value

value = instance.LLY
C#
public double LLY {get; set;}
Managed Extensions for C++
public: __property double get_LLY();
public: __property void set_LLY(
   double value
);
C++/CLI
public:
property double LLY {
   double get();
   void set (double value);
}

Return Value

The Y coordinate of the lower left corner of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangle Class
PDFRectangle Members


URX Property

URX Property
[image]
O2S.Components.PDF4NET Namespace > PDFRectangle Class : URX Property

Gets or sets X coordinate of the upper right corner.

Syntax

Visual Basic (Declaration)
Public Property URX As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangle
Dim value As Double

instance.URX = value

value = instance.URX
C#
public double URX {get; set;}
Managed Extensions for C++
public: __property double get_URX();
public: __property void set_URX(
   double value
);
C++/CLI
public:
property double URX {
   double get();
   void set (double value);
}

Return Value

The X coordinate of the upper right corner of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangle Class
PDFRectangle Members


URY Property

URY Property
[image]
O2S.Components.PDF4NET Namespace > PDFRectangle Class : URY Property

Gets or sets Y coordinate of the upper right corner.

Syntax

Visual Basic (Declaration)
Public Property URY As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangle
Dim value As Double

instance.URY = value

value = instance.URY
C#
public double URY {get; set;}
Managed Extensions for C++
public: __property double get_URY();
public: __property void set_URY(
   double value
);
C++/CLI
public:
property double URY {
   double get();
   void set (double value);
}

Return Value

The Y coordinate of the upper right corner of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangle Class
PDFRectangle Members


Width Property

Width Property
[image]
O2S.Components.PDF4NET Namespace > PDFRectangle Class : Width Property

Gets or sets the rectangle's width.

Syntax

Visual Basic (Declaration)
Public Property Width As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangle
Dim value As Double

instance.Width = value

value = instance.Width
C#
public double Width {get; set;}
Managed Extensions for C++
public: __property double get_Width();
public: __property void set_Width(
   double value
);
C++/CLI
public:
property double Width {
   double get();
   void set (double value);
}

Return Value

The width of the rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than zero.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangle Class
PDFRectangle Members


PDFRemotePageDestination Class

PDFRemotePageDestination Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFRemotePageDestination Class

Defines a destination to a page in another PDF document.

Syntax

Visual Basic (Declaration)
Public Class PDFRemotePageDestination
   Inherits PDFDirectDestination
Visual Basic (Usage) Copy Code
Dim instance As PDFRemotePageDestination
C#
public class PDFRemotePageDestination : PDFDirectDestination
Managed Extensions for C++
public __gc class PDFRemotePageDestination : public PDFDirectDestination
C++/CLI
public ref class PDFRemotePageDestination : public PDFDirectDestination

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFDestination
O2S.Components.PDF4NET.PDFDirectDestination
O2S.Components.PDF4NET.PDFRemotePageDestination

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemotePageDestination Members
O2S.Components.PDF4NET Namespace


PDFRemotePageDestination Class Members

PDFRemotePageDestination Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFRemotePageDestination Class

The following tables list the members exposed by PDFRemotePageDestination.

Public Constructors

 | Name | Description
Public Constructor | PDFRemotePageDestination Constructor | Initializes a new PDFRemotePageDestination object.
Top

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate in the page where the viewer should display the page. (Inherited from PDFDirectDestination)
Public Property | Left | Gets or sets the left coordinate in the page where the viewer should display the page. (Inherited from PDFDirectDestination)
Public Property | MagnificationMode | Gets or sets the magnification mode. (Inherited from PDFDirectDestination)
Public Property | PageNumber | Gets or sets the destination page number.
Public Property | Right | Gets or sets the right coordinate in the page where the viewer should display the page. (Inherited from PDFDirectDestination)
Public Property | Top | Gets or sets the top coordinate in the page where the viewer should display the page. (Inherited from PDFDirectDestination)
Public Property | Zoom | Gets or sets the zoom factor to be used when the page is displayed. (Inherited from PDFDirectDestination)
Top

See Also

Reference

PDFRemotePageDestination Class
O2S.Components.PDF4NET Namespace


PDFRemotePageDestination Constructor

PDFRemotePageDestination Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFRemotePageDestination Class : PDFRemotePageDestination Constructor

Initializes a new PDFRemotePageDestination object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFRemotePageDestination()
C#
public PDFRemotePageDestination()
Managed Extensions for C++
public: PDFRemotePageDestination();
C++/CLI
public:
PDFRemotePageDestination();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemotePageDestination Class
PDFRemotePageDestination Members


PDFRemotePageDestination Class Properties

PDFRemotePageDestination Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFRemotePageDestination Class

For a list of all members of this type, see PDFRemotePageDestination members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets or sets the bottom coordinate in the page where the viewer should display the page. (Inherited from PDFDirectDestination)
Public Property | Left | Gets or sets the left coordinate in the page where the viewer should display the page. (Inherited from PDFDirectDestination)
Public Property | MagnificationMode | Gets or sets the magnification mode. (Inherited from PDFDirectDestination)
Public Property | PageNumber | Gets or sets the destination page number.
Public Property | Right | Gets or sets the right coordinate in the page where the viewer should display the page. (Inherited from PDFDirectDestination)
Public Property | Top | Gets or sets the top coordinate in the page where the viewer should display the page. (Inherited from PDFDirectDestination)
Public Property | Zoom | Gets or sets the zoom factor to be used when the page is displayed. (Inherited from PDFDirectDestination)
Top

See Also

Reference

PDFRemotePageDestination Class
O2S.Components.PDF4NET Namespace


PageNumber Property

PageNumber Property
[image]
O2S.Components.PDF4NET Namespace > PDFRemotePageDestination Class : PageNumber Property

Gets or sets the destination page number.

Syntax

Visual Basic (Declaration)
Public Property PageNumber As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFRemotePageDestination
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
C#
public int PageNumber {get; set;}
Managed Extensions for C++
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
C++/CLI
public:
property int PageNumber {
   int get();
   void set (int value);
}

Return Value

The number of the page in the remote PDF document.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 0.

Remarks

The page number if 0 based.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemotePageDestination Class
PDFRemotePageDestination Members


PDFSeparationInfo Class

PDFSeparationInfo Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFSeparationInfo Class

Defines the separation information for a PDF page.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSeparationInfo
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationInfo
C#
public class PDFSeparationInfo
Managed Extensions for C++
public __gc class PDFSeparationInfo
C++/CLI
public ref class PDFSeparationInfo

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFSeparationInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationInfo Members
O2S.Components.PDF4NET Namespace


PDFSeparationInfo Class Members

PDFSeparationInfo Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFSeparationInfo Class

The following tables list the members exposed by PDFSeparationInfo.

Public Constructors

 | Name | Description
Public Constructor | PDFSeparationInfo Constructor | Initializes a new PDFSeparationInfo object.
Top

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets or sets the base colorspace for this separation object.
Public Property | DeviceColorant | Gets the name of the device colorant used in rendering this separation.
Public Property | Pages | Gets or sets the list of pages included in the same separation group.
Top

See Also

Reference

PDFSeparationInfo Class
O2S.Components.PDF4NET Namespace


PDFSeparationInfo Constructor

PDFSeparationInfo Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFSeparationInfo Class : PDFSeparationInfo Constructor

Initializes a new PDFSeparationInfo object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationInfo()
C#
public PDFSeparationInfo()
Managed Extensions for C++
public: PDFSeparationInfo();
C++/CLI
public:
PDFSeparationInfo();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationInfo Class
PDFSeparationInfo Members


PDFSeparationInfo Class Properties

PDFSeparationInfo Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFSeparationInfo Class

For a list of all members of this type, see PDFSeparationInfo members.

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets or sets the base colorspace for this separation object.
Public Property | DeviceColorant | Gets the name of the device colorant used in rendering this separation.
Public Property | Pages | Gets or sets the list of pages included in the same separation group.
Top

See Also

Reference

PDFSeparationInfo Class
O2S.Components.PDF4NET Namespace


ColorSpace Property

ColorSpace Property
[image]
O2S.Components.PDF4NET Namespace > PDFSeparationInfo Class : ColorSpace Property

Gets or sets the base colorspace for this separation object.

Syntax

Visual Basic (Declaration)
Public Property ColorSpace As PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationInfo
Dim value As PDFColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
C#
public PDFColorSpace ColorSpace {get; set;}
Managed Extensions for C++
public: __property PDFColorSpace* get_ColorSpace();
public: __property void set_ColorSpace(
   PDFColorSpace* value
);
C++/CLI
public:
property PDFColorSpace^ ColorSpace {
   PDFColorSpace^ get();
   void set (PDFColorSpace^ value);
}

Return Value

A PDFColorSpace object specifying the colorspace used by this separation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationInfo Class
PDFSeparationInfo Members


DeviceColorant Property

DeviceColorant Property
[image]
O2S.Components.PDF4NET Namespace > PDFSeparationInfo Class : DeviceColorant Property

Gets the name of the device colorant used in rendering this separation.

Syntax

Visual Basic (Declaration)
Public Property DeviceColorant As String
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationInfo
Dim value As String

instance.DeviceColorant = value

value = instance.DeviceColorant
C#
public string DeviceColorant {get; set;}
Managed Extensions for C++
public: __property string* get_DeviceColorant();
public: __property void set_DeviceColorant(
   string* value
);
C++/CLI
public:
property String^ DeviceColorant {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing the name of the device colorant used in rendering this separation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationInfo Class
PDFSeparationInfo Members


Pages Property

Pages Property
[image]
O2S.Components.PDF4NET Namespace > PDFSeparationInfo Class : Pages Property

Gets or sets the list of pages included in the same separation group.

Syntax

Visual Basic (Declaration)
Public Property Pages As Integer()
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationInfo
Dim value() As Integer

instance.Pages = value

value = instance.Pages
C#
public int[] Pages {get; set;}
Managed Extensions for C++
public: __property int[]* get_Pages();
public: __property void set_Pages(
   int[]* value
);
C++/CLI
public:
property array<int>^ Pages {
   array<int>^ get();
   void set (intarray<value>^ value);
}

Return Value

An array of integer values representing the numbers of the pages included in the separation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationInfo Class
PDFSeparationInfo Members


PDFViewerPreferences Class

PDFViewerPreferences Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFViewerPreferences Class

Defines the way the PDF document is displayed on the screen.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFViewerPreferences
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
C#
public class PDFViewerPreferences
Managed Extensions for C++
public __gc class PDFViewerPreferences
C++/CLI
public ref class PDFViewerPreferences

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFViewerPreferences

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Members
O2S.Components.PDF4NET Namespace


PDFViewerPreferences Class Members

PDFViewerPreferences Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFViewerPreferences Class

The following tables list the members exposed by PDFViewerPreferences.

Public Constructors

 | Name | Description
Public Constructor | PDFViewerPreferences Constructor | Initializes a new PDFViewerPreferences object.
Top

Public Properties

 | Name | Description
Public Property | CenterWindow | Gets or sets a value indicating whether the document's window should be centered on the screen.
Public Property | Dictionary | Gets the viewer preferences dictionary dictionary.
Public Property | DisplayDocTitle | Gets or sets a value indicating whether the window's title bar should display the document's title loaded from document information metadata.
Public Property | FitWindow | Gets or sets a value indicating whether the document's window should be resized to match the size of the first displayed page.
Public Property | HideMenubar | Gets or sets a value indicating whether the viewer's menubar should be hidden when the document is active.
Public Property | HideToolbar | Gets or sets a value indicating whether the viewer's toolbar should be hidden when the document is active.
Public Property | HideWindowUI | Gets or sets a value indicating whether the viewer's UI should be hidden when the document is active.
Public Property | NonFullScreenPageMode | Gets or sets the document's page mode specifying how to display the document on exiting the full-screen mode.
Public Property | PrintScaling | Gets or sets how the print scaling for this document.
Top

See Also

Reference

PDFViewerPreferences Class
O2S.Components.PDF4NET Namespace


PDFViewerPreferences Constructor

PDFViewerPreferences Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : PDFViewerPreferences Constructor

Initializes a new PDFViewerPreferences object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences()
C#
public PDFViewerPreferences()
Managed Extensions for C++
public: PDFViewerPreferences();
C++/CLI
public:
PDFViewerPreferences();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


PDFViewerPreferences Class Properties

PDFViewerPreferences Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFViewerPreferences Class

For a list of all members of this type, see PDFViewerPreferences members.

Public Properties

 | Name | Description
Public Property | CenterWindow | Gets or sets a value indicating whether the document's window should be centered on the screen.
Public Property | Dictionary | Gets the viewer preferences dictionary dictionary.
Public Property | DisplayDocTitle | Gets or sets a value indicating whether the window's title bar should display the document's title loaded from document information metadata.
Public Property | FitWindow | Gets or sets a value indicating whether the document's window should be resized to match the size of the first displayed page.
Public Property | HideMenubar | Gets or sets a value indicating whether the viewer's menubar should be hidden when the document is active.
Public Property | HideToolbar | Gets or sets a value indicating whether the viewer's toolbar should be hidden when the document is active.
Public Property | HideWindowUI | Gets or sets a value indicating whether the viewer's UI should be hidden when the document is active.
Public Property | NonFullScreenPageMode | Gets or sets the document's page mode specifying how to display the document on exiting the full-screen mode.
Public Property | PrintScaling | Gets or sets how the print scaling for this document.
Top

See Also

Reference

PDFViewerPreferences Class
O2S.Components.PDF4NET Namespace


CenterWindow Property

CenterWindow Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : CenterWindow Property

Gets or sets a value indicating whether the document's window should be centered on the screen.

Syntax

Visual Basic (Declaration)
Public Property CenterWindow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.CenterWindow = value

value = instance.CenterWindow
C#
public bool CenterWindow {get; set;}
Managed Extensions for C++
public: __property bool get_CenterWindow();
public: __property void set_CenterWindow(
   bool value
);
C++/CLI
public:
property bool CenterWindow {
   bool get();
   void set (bool value);
}

Return Value

True if the document's window should be centered on the screen. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


Dictionary Property

Dictionary Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : Dictionary Property

Gets the viewer preferences dictionary dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dictionary As PDFDictionary
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As PDFDictionary

value = instance.Dictionary
C#
public PDFDictionary Dictionary {get;}
Managed Extensions for C++
public: __property PDFDictionary* get_Dictionary();
C++/CLI
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Return Value

The raw viewer preferences dictionary.

Remarks

This property gives you direct access to viewer preferences dictionary and its associated resources. Note: Modifying directly the viewer preferences dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


DisplayDocTitle Property

DisplayDocTitle Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : DisplayDocTitle Property

Gets or sets a value indicating whether the window's title bar should display the document's title loaded from document information metadata.

Syntax

Visual Basic (Declaration)
Public Property DisplayDocTitle As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.DisplayDocTitle = value

value = instance.DisplayDocTitle
C#
public bool DisplayDocTitle {get; set;}
Managed Extensions for C++
public: __property bool get_DisplayDocTitle();
public: __property void set_DisplayDocTitle(
   bool value
);
C++/CLI
public:
property bool DisplayDocTitle {
   bool get();
   void set (bool value);
}

Return Value

True if the window's title bar should display the document's title. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


FitWindow Property

FitWindow Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : FitWindow Property

Gets or sets a value indicating whether the document's window should be resized to match the size of the first displayed page.

Syntax

Visual Basic (Declaration)
Public Property FitWindow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.FitWindow = value

value = instance.FitWindow
C#
public bool FitWindow {get; set;}
Managed Extensions for C++
public: __property bool get_FitWindow();
public: __property void set_FitWindow(
   bool value
);
C++/CLI
public:
property bool FitWindow {
   bool get();
   void set (bool value);
}

Return Value

True if the document's window should be resized. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


HideMenubar Property

HideMenubar Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : HideMenubar Property

Gets or sets a value indicating whether the viewer's menubar should be hidden when the document is active.

Syntax

Visual Basic (Declaration)
Public Property HideMenubar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.HideMenubar = value

value = instance.HideMenubar
C#
public bool HideMenubar {get; set;}
Managed Extensions for C++
public: __property bool get_HideMenubar();
public: __property void set_HideMenubar(
   bool value
);
C++/CLI
public:
property bool HideMenubar {
   bool get();
   void set (bool value);
}

Return Value

True if the menubar should be hidden. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


HideToolbar Property

HideToolbar Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : HideToolbar Property

Gets or sets a value indicating whether the viewer's toolbar should be hidden when the document is active.

Syntax

Visual Basic (Declaration)
Public Property HideToolbar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.HideToolbar = value

value = instance.HideToolbar
C#
public bool HideToolbar {get; set;}
Managed Extensions for C++
public: __property bool get_HideToolbar();
public: __property void set_HideToolbar(
   bool value
);
C++/CLI
public:
property bool HideToolbar {
   bool get();
   void set (bool value);
}

Return Value

True if the toolbar should be hidden. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


HideWindowUI Property

HideWindowUI Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : HideWindowUI Property

Gets or sets a value indicating whether the viewer's UI should be hidden when the document is active.

Syntax

Visual Basic (Declaration)
Public Property HideWindowUI As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As Boolean

instance.HideWindowUI = value

value = instance.HideWindowUI
C#
public bool HideWindowUI {get; set;}
Managed Extensions for C++
public: __property bool get_HideWindowUI();
public: __property void set_HideWindowUI(
   bool value
);
C++/CLI
public:
property bool HideWindowUI {
   bool get();
   void set (bool value);
}

Return Value

True if the UI should be hidden. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


NonFullScreenPageMode Property

NonFullScreenPageMode Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : NonFullScreenPageMode Property

Gets or sets the document's page mode specifying how to display the document on exiting the full-screen mode.

Syntax

Visual Basic (Declaration)
Public Property NonFullScreenPageMode As PDFDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As PDFDisplayMode

instance.NonFullScreenPageMode = value

value = instance.NonFullScreenPageMode
C#
public PDFDisplayMode NonFullScreenPageMode {get; set;}
Managed Extensions for C++
public: __property PDFDisplayMode get_NonFullScreenPageMode();
public: __property void set_NonFullScreenPageMode(
   PDFDisplayMode value
);
C++/CLI
public:
property PDFDisplayMode NonFullScreenPageMode {
   PDFDisplayMode get();
   void set (PDFDisplayMode value);
}

Return Value

The document's page mode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown if the value to be set is not one of the supported values.

Remarks

Only the following page modes are supported: PDFDisplayMode.UseNone, PDFDisplayMode.UseOutlines, PDFDisplayMode.UseThumbs and PDFDisplayMode.UseOC.
This property is meaningful only if the PDFDocument.DisplayMode property is PDFDisplayMode.FullScreen.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


PrintScaling Property

PrintScaling Property
[image]
O2S.Components.PDF4NET Namespace > PDFViewerPreferences Class : PrintScaling Property

Gets or sets how the print scaling for this document.

Syntax

Visual Basic (Declaration)
Public Property PrintScaling As PDFPrintScaling
Visual Basic (Usage) Copy Code
Dim instance As PDFViewerPreferences
Dim value As PDFPrintScaling

instance.PrintScaling = value

value = instance.PrintScaling
C#
public PDFPrintScaling PrintScaling {get; set;}
Managed Extensions for C++
public: __property PDFPrintScaling get_PrintScaling();
public: __property void set_PrintScaling(
   PDFPrintScaling value
);
C++/CLI
public:
property PDFPrintScaling PrintScaling {
   PDFPrintScaling get();
   void set (PDFPrintScaling value);
}

Return Value

The page scaling option to be selected when a print dialog is displayed for this document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFViewerPreferences Class
PDFViewerPreferences Members


PDFXMPMetadata Class

PDFXMPMetadata Class
See Also Members
[image]
O2S.Components.PDF4NET Namespace : PDFXMPMetadata Class

Defines the XMP metadata for a PDF document.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFXMPMetadata
Visual Basic (Usage) Copy Code
Dim instance As PDFXMPMetadata
C#
public class PDFXMPMetadata
Managed Extensions for C++
public __gc class PDFXMPMetadata
C++/CLI
public ref class PDFXMPMetadata

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFXMPMetadata

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFXMPMetadata Members
O2S.Components.PDF4NET Namespace


PDFXMPMetadata Class Members

PDFXMPMetadata Class Members
See Also Properties
[image]
O2S.Components.PDF4NET Namespace : PDFXMPMetadata Class

The following tables list the members exposed by PDFXMPMetadata.

Public Constructors

 | Name | Description
Public Constructor | PDFXMPMetadata Constructor | Initializes a new PDFXMPMetadata object.
Top

Public Properties

 | Name | Description
Public Property | MetadataSchemas | Gets the metadata schema collection.
Public Property | XMPMetadata | Gets the raw XMP metadata as an XML string.
Top

See Also

Reference

PDFXMPMetadata Class
O2S.Components.PDF4NET Namespace


PDFXMPMetadata Constructor

PDFXMPMetadata Constructor
[image]
O2S.Components.PDF4NET Namespace > PDFXMPMetadata Class : PDFXMPMetadata Constructor

Initializes a new PDFXMPMetadata object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFXMPMetadata()
C#
public PDFXMPMetadata()
Managed Extensions for C++
public: PDFXMPMetadata();
C++/CLI
public:
PDFXMPMetadata();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFXMPMetadata Class
PDFXMPMetadata Members


PDFXMPMetadata Class Properties

PDFXMPMetadata Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFXMPMetadata Class

For a list of all members of this type, see PDFXMPMetadata members.

Public Properties

 | Name | Description
Public Property | MetadataSchemas | Gets the metadata schema collection.
Public Property | XMPMetadata | Gets the raw XMP metadata as an XML string.
Top

See Also

Reference

PDFXMPMetadata Class
O2S.Components.PDF4NET Namespace


MetadataSchemas Property

MetadataSchemas Property
[image]
O2S.Components.PDF4NET Namespace > PDFXMPMetadata Class : MetadataSchemas Property

Gets the metadata schema collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetadataSchemas As PDFMetadataSchemaCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFXMPMetadata
Dim value As PDFMetadataSchemaCollection

value = instance.MetadataSchemas
C#
public PDFMetadataSchemaCollection MetadataSchemas {get;}
Managed Extensions for C++
public: __property PDFMetadataSchemaCollection* get_MetadataSchemas();
C++/CLI
public:
property PDFMetadataSchemaCollection^ MetadataSchemas {
   PDFMetadataSchemaCollection^ get();
}

Return Value

A collection of metadata schema objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFXMPMetadata Class
PDFXMPMetadata Members


XMPMetadata Property

XMPMetadata Property
[image]
O2S.Components.PDF4NET Namespace > PDFXMPMetadata Class : XMPMetadata Property

Gets the raw XMP metadata as an XML string.

Syntax

Visual Basic (Declaration)
Public Property XMPMetadata As String
Visual Basic (Usage) Copy Code
Dim instance As PDFXMPMetadata
Dim value As String

instance.XMPMetadata = value

value = instance.XMPMetadata
C#
public string XMPMetadata {get; set;}
Managed Extensions for C++
public: __property string* get_XMPMetadata();
public: __property void set_XMPMetadata(
   string* value
);
C++/CLI
public:
property String^ XMPMetadata {
   String^ get();
   void set (String^ value);
}

Return Value

The raw XMP metadata stored in the PDF file.

Remarks

If the PDFDocument object has been created from a source PDF file, this property returns the XMP metadata included in the file, otherwise it returns an empty string.
If this property is set from user code, the new value is appended as it is to the XMP metadata generated by PDF4NET.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFXMPMetadata Class
PDFXMPMetadata Members


PDFBookmarkDisplayStyle Enumeration

PDFBookmarkDisplayStyle Enumeration
[image]
O2S.Components.PDF4NET Namespace : PDFBookmarkDisplayStyle Enumeration

Specifies the available modes for displaying a bookmark in a viewer application.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum PDFBookmarkDisplayStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFBookmarkDisplayStyle
C#
[FlagsAttribute()]
public enum PDFBookmarkDisplayStyle : Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum PDFBookmarkDisplayStyle : public Enum
C++/CLI
[FlagsAttribute()]
public enum class PDFBookmarkDisplayStyle : public Enum

Members

Member | Description
Regular | The bookmark is displayed using regular font.
Italic | The bookmark is displayed using italic font.
Bold | The bookmark is displayed using bold font.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFBookmarkDisplayStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


PDFDisplayMode Enumeration

PDFDisplayMode Enumeration
[image]
O2S.Components.PDF4NET Namespace : PDFDisplayMode Enumeration

Specifies the possible modes to be display the document when it is opened.

Syntax

Visual Basic (Declaration)
Public Enum PDFDisplayMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFDisplayMode
C#
public enum PDFDisplayMode : Enum
Managed Extensions for C++
__value public enum PDFDisplayMode : public Enum
C++/CLI
public enum class PDFDisplayMode : public Enum

Members

Member | Description
UseNone | Neither document outline nor thumbnail images visible.
UseOutlines | Document outline visible.
UseThumbs | Thumbnail images visible.
FullScreen | Full screen mode, with no menu bar, window controls, or any other window visible.
UseOC | Optional content panel visible.
UseAttachments | Attachments panel visible.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFDisplayMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


PDFMagnificationMode Enumeration

PDFMagnificationMode Enumeration
[image]
O2S.Components.PDF4NET Namespace : PDFMagnificationMode Enumeration

Specifies the available zoom modes that can be applied when the PDF page specified in the destination is displayed.

Syntax

Visual Basic (Declaration)
Public Enum PDFMagnificationMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFMagnificationMode
C#
public enum PDFMagnificationMode : Enum
Managed Extensions for C++
__value public enum PDFMagnificationMode : public Enum
C++/CLI
public enum class PDFMagnificationMode : public Enum

Members

Member | Description
XYZ | Display the destination page at the specified position and zoom.
Fit | Display the destination page, with its contents magnified just enough to fit the entire page within the window both horizontally and vertically.
FitH | Display the destination page at the specified top position and the contents of the page magnified just enough to fit the entire width of the page within the window.
FitV | Display the destination page at the specified left position and the contents of the page magnified just enough to fit the entire height of the page within the window.
FitR | Display the destination page, with its contents magnified just enough to fit the rectangle specified by the coordinates left, bottom, right, and top entirely within the window both horizontally and vertically.
FitB | Display the destination page, with its contents magnified just enough to fit its bounding box entirely within the window both horizontally and vertically.
FitBH | Display the destination page at the specified top position and the contents of the page magnified just enough to fit the entire width of its bounding box within the window.
FitBV | Display the destination page at the specified left position and the contents of the page magnified just enough to fit the entire height of its bounding box within the window.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFMagnificationMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


PDFNumberingStyle Enumeration

PDFNumberingStyle Enumeration
[image]
O2S.Components.PDF4NET Namespace : PDFNumberingStyle Enumeration

Specifies the available styles when setting up a page numbering range.

Syntax

Visual Basic (Declaration)
Public Enum PDFNumberingStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFNumberingStyle
C#
public enum PDFNumberingStyle : Enum
Managed Extensions for C++
__value public enum PDFNumberingStyle : public Enum
C++/CLI
public enum class PDFNumberingStyle : public Enum

Members

Member | Description
UpperCaseRoman | The numbering style uses uppercase roman numerals
LowerCaseRoman | The numbering style uses lowercase roman numerals
UpperCaseLetter | Upper case letters are used for page numbers.
LowerCaseLetter | Lower case letters are used for page numbers.
Arabic | The numbering style uses arabic numerals
None | No numbering Style.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFNumberingStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


PDFPageLayout Enumeration

PDFPageLayout Enumeration
[image]
O2S.Components.PDF4NET Namespace : PDFPageLayout Enumeration

Specifies the possible page layouts to be used when the document is opened.

Syntax

Visual Basic (Declaration)
Public Enum PDFPageLayout
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFPageLayout
C#
public enum PDFPageLayout : Enum
Managed Extensions for C++
__value public enum PDFPageLayout : public Enum
C++/CLI
public enum class PDFPageLayout : public Enum

Members

Member | Description
SinglePage | Display one page at a time.
OneColumn | Display the pages in one column.
TwoColumnLeft | Display the pages in two columns, with odd-numbered pages on the left.
TwoColumnRight | Display the pages in two columns, with odd-numbered pages on the right.
TwoPageLeft | Display the pages two at a time, with odd-numbered pages on the left.
TwoPageRight | Display the pages two at a time, with odd-numbered pages on the right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFPageLayout

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


PDFPageOrientation Enumeration

PDFPageOrientation Enumeration
[image]
O2S.Components.PDF4NET Namespace : PDFPageOrientation Enumeration

Specifies the possible orientations for a page.

Syntax

Visual Basic (Declaration)
Public Enum PDFPageOrientation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFPageOrientation
C#
public enum PDFPageOrientation : Enum
Managed Extensions for C++
__value public enum PDFPageOrientation : public Enum
C++/CLI
public enum class PDFPageOrientation : public Enum

Members

Member | Description
Portrait | Portrait orientation.
Landscape | Landscape orientation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFPageOrientation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


PDFPageSize Enumeration

PDFPageSize Enumeration
[image]
O2S.Components.PDF4NET Namespace : PDFPageSize Enumeration

Specifies the predefined page sizes.

Syntax

Visual Basic (Declaration)
Public Enum PDFPageSize
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFPageSize
C#
public enum PDFPageSize : Enum
Managed Extensions for C++
__value public enum PDFPageSize : public Enum
C++/CLI
public enum class PDFPageSize : public Enum

Members

Member | Description
A0 | A0 page size (2380 points x 3368 points).
A1 | A1 page size (1684 points x 2380 points).
A2 | A2 page size (1190 points x 1684 points).
A3 | A3 page size (842 points x 1190 points).
A4 | A4 page size (595 points x 842 points).
A5 | A5 page size (420 points x 595 points).
B4 | B4 page size (729 points x 1032 points).
B5 | B4 page size (516 points x 729 points).
Letter | Letter page size (612 points x 792 points).
Legal | Legal page size (612 points x 1008 points).
Tabloid | Tabloid page size (792 points x 1024 points).
Ledger | Ledger page size (1224 points x 792 points).
Statement | Statement page size (396 points x 612 points).
Executive | Executive page size (540 points x 720 points).
Folio | Folio page size (612 points x 936 points).
Quarto | Quarto page size (610 points x 780 points).
Size10x14 | 10x14 page size (720 points x 1008 points).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFPageSize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


PDFPrintScaling Enumeration

PDFPrintScaling Enumeration
[image]
O2S.Components.PDF4NET Namespace : PDFPrintScaling Enumeration

Specifies the available print scaling options.

Syntax

Visual Basic (Declaration)
Public Enum PDFPrintScaling
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFPrintScaling
C#
public enum PDFPrintScaling : Enum
Managed Extensions for C++
__value public enum PDFPrintScaling : public Enum
C++/CLI
public enum class PDFPrintScaling : public Enum

Members

Member | Description
None | No print scaling.
AppDefault | Application default page scaling.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFPrintScaling

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


PDFRotationMode Enumeration

PDFRotationMode Enumeration
[image]
O2S.Components.PDF4NET Namespace : PDFRotationMode Enumeration

Specifies the available rotation modes for a PDF object.

Syntax

Visual Basic (Declaration)
Public Enum PDFRotationMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFRotationMode
C#
public enum PDFRotationMode : Enum
Managed Extensions for C++
__value public enum PDFRotationMode : public Enum
C++/CLI
public enum class PDFRotationMode : public Enum

Members

Member | Description
Rotate0Degrees | 0 degrees rotation.
Rotate90Degrees | 90 degrees rotation.
Rotate180Degrees | 180 degrees rotation.
Rotate270Degrees | 270 degrees rotation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFRotationMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


PDFVersion Enumeration

PDFVersion Enumeration
[image]
O2S.Components.PDF4NET Namespace : PDFVersion Enumeration

Specifies the available PDF versions to save a PDF document.

Syntax

Visual Basic (Declaration)
Public Enum PDFVersion
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFVersion
C#
public enum PDFVersion : Enum
Managed Extensions for C++
__value public enum PDFVersion : public Enum
C++/CLI
public enum class PDFVersion : public Enum

Members

Member | Description
Unknown | Unknown document version.
Version10 | PDF 1.0 - Adobe Acrobat 1
Version11 | PDF 1.1 - Adobe Acrobat 2
Version12 | PDF 1.2 - Adobe Acrobat 3
Version13 | PDF 1.3 - Adobe Acrobat 4
Version14 | PDF 1.4 - Adobe Acrobat 5
Version15 | PDF 1.5 - Adobe Acrobat 6
Version16 | PDF 1.6 - Adobe Acrobat 7
Version17 | PDF 1.7 - Adobe Acrobat 8

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.PDFVersion

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET Namespace


O2S.Components.PDF4NET.Actions Namespace

O2S.Components.PDF4NET.Actions Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFAction | This is the base class for all PDF actions
PDFActionCollection | Defines a collection of PDF actions.
PDFGoToAction | This class represents a PDF Go-To action.
PDFHideAction | Defines a PDF hide action.
PDFJavaScriptAction | This class represents a PDF Javascript action.
PDFLaunchAction | This class represents a PDF Launch action.
PDFNamedAction | This class represents a PDF Named action.
PDFRemoteGoToAction | This class represents a PDF Remote Go-To action.
PDFResetFormAction | Defines a SubmitForm action.
PDFSubmitFormAction | Defines a SubmitForm action.
PDFURIAction | This class represents a PDF URI action.

Enumerations

Enumeration | Description
NamedAction | Specifies the available named actions supported by the viewer.
SubmitDataFormat | Specifies the available data formats for submitting the form data.

See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET.Actions Namespace Inheritance Hierarchy

O2S.Components.PDF4NET.Actions Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFGoToAction
O2S.Components.PDF4NET.Actions.PDFHideAction
O2S.Components.PDF4NET.Actions.PDFJavaScriptAction
O2S.Components.PDF4NET.Actions.PDFLaunchAction
O2S.Components.PDF4NET.Actions.PDFNamedAction
O2S.Components.PDF4NET.Actions.PDFRemoteGoToAction
O2S.Components.PDF4NET.Actions.PDFResetFormAction
O2S.Components.PDF4NET.Actions.PDFSubmitFormAction
O2S.Components.PDF4NET.Actions.PDFURIAction
System.Collections.ObjectModel.Collection<PDFAction>
O2S.Components.PDF4NET.Actions.PDFActionCollection

See Also

Reference

O2S.Components.PDF4NET Assembly


PDFAction Class

PDFAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFAction Class

This is the base class for all PDF actions

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFAction
C#
public abstract class PDFAction
Managed Extensions for C++
public __gc abstract class PDFAction
C++/CLI
public ref class PDFAction abstract

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFURIAction
O2S.Components.PDF4NET.Actions.PDFSubmitFormAction
O2S.Components.PDF4NET.Actions.PDFResetFormAction
O2S.Components.PDF4NET.Actions.PDFRemoteGoToAction
O2S.Components.PDF4NET.Actions.PDFNamedAction
O2S.Components.PDF4NET.Actions.PDFLaunchAction
O2S.Components.PDF4NET.Actions.PDFJavaScriptAction
O2S.Components.PDF4NET.Actions.PDFHideAction
O2S.Components.PDF4NET.Actions.PDFGoToAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAction Members
O2S.Components.PDF4NET.Actions Namespace


PDFAction Class Members

PDFAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFAction Class

The following tables list the members exposed by PDFAction.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one.
Public Property | Dictionary | Gets the action dictionary.
Top

See Also

Reference

PDFAction Class
O2S.Components.PDF4NET.Actions Namespace


PDFAction Class Properties

PDFAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFAction Class

For a list of all members of this type, see PDFAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one.
Public Property | Dictionary | Gets the action dictionary.
Top

See Also

Reference

PDFAction Class
O2S.Components.PDF4NET.Actions Namespace


Actions Property

Actions Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFAction Class : Actions Property

Gets the list of actions to be performed after this one.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Actions As PDFActionCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFAction
Dim value As PDFActionCollection

value = instance.Actions
C#
public PDFActionCollection Actions {get;}
Managed Extensions for C++
public: __property PDFActionCollection* get_Actions();
C++/CLI
public:
property PDFActionCollection^ Actions {
   PDFActionCollection^ get();
}

Return Value

An PDFActionCollection object storing the actions to be performed after current action (this one) has been executed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAction Class
PDFAction Members


Dictionary Property

Dictionary Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFAction Class : Dictionary Property

Gets the action dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dictionary As PDFDictionary
Visual Basic (Usage) Copy Code
Dim instance As PDFAction
Dim value As PDFDictionary

value = instance.Dictionary
C#
public PDFDictionary Dictionary {get;}
Managed Extensions for C++
public: __property PDFDictionary* get_Dictionary();
C++/CLI
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Return Value

The raw action dictionary.

Remarks

This property gives you direct access to action dictionary and its associated resources. Note: Modifying directly the action dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAction Class
PDFAction Members


PDFActionCollection Class

PDFActionCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFActionCollection Class

Defines a collection of PDF actions.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFActionCollection
   Inherits Collection(Of PDFAction)
Visual Basic (Usage) Copy Code
Dim instance As PDFActionCollection
C#
public class PDFActionCollection : Collection<PDFAction>
Managed Extensions for C++
public __gc class PDFActionCollection : public Collection<PDFAction>
C++/CLI
public ref class PDFActionCollection : public Collection<PDFAction>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<PDFAction>
O2S.Components.PDF4NET.Actions.PDFActionCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFActionCollection Members
O2S.Components.PDF4NET.Actions Namespace


PDFActionCollection Class Members

PDFActionCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFActionCollection Class

The following tables list the members exposed by PDFActionCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Top

See Also

Reference

PDFActionCollection Class
O2S.Components.PDF4NET.Actions Namespace


PDFGoToAction Class

PDFGoToAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFGoToAction Class

This class represents a PDF Go-To action.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFGoToAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFGoToAction
C#
public class PDFGoToAction : PDFAction
Managed Extensions for C++
public __gc class PDFGoToAction : public PDFAction
C++/CLI
public ref class PDFGoToAction : public PDFAction

Remarks

This type of action allows a user to navigate to a specific page in the current document. It allows to specify the page to open when this action is executed, the location in the page where the viewer should display the page and a magnification factor to be used when displaying the destination page.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFGoToAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGoToAction Members
O2S.Components.PDF4NET.Actions Namespace


PDFGoToAction Class Members

PDFGoToAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFGoToAction Class

The following tables list the members exposed by PDFGoToAction.

Public Constructors

 | Name | Description
Public Constructor | PDFGoToAction Constructor | Initializes a new PDFGoToAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Destination | Gets or sets the destination of the GoTo action.
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Top

See Also

Reference

PDFGoToAction Class
O2S.Components.PDF4NET.Actions Namespace


PDFGoToAction Constructor

PDFGoToAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFGoToAction Class : PDFGoToAction Constructor

Initializes a new PDFGoToAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFGoToAction()
C#
public PDFGoToAction()
Managed Extensions for C++
public: PDFGoToAction();
C++/CLI
public:
PDFGoToAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGoToAction Class
PDFGoToAction Members


PDFGoToAction Class Properties

PDFGoToAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFGoToAction Class

For a list of all members of this type, see PDFGoToAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Destination | Gets or sets the destination of the GoTo action.
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Top

See Also

Reference

PDFGoToAction Class
O2S.Components.PDF4NET.Actions Namespace


Destination Property

Destination Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFGoToAction Class : Destination Property

Gets or sets the destination of the GoTo action.

Syntax

Visual Basic (Declaration)
Public Property Destination As PDFPageDestination
Visual Basic (Usage) Copy Code
Dim instance As PDFGoToAction
Dim value As PDFPageDestination

instance.Destination = value

value = instance.Destination
C#
public PDFPageDestination Destination {get; set;}
Managed Extensions for C++
public: __property PDFPageDestination* get_Destination();
public: __property void set_Destination(
   PDFPageDestination* value
);
C++/CLI
public:
property PDFPageDestination^ Destination {
   PDFPageDestination^ get();
   void set (PDFPageDestination^ value);
}

Return Value

The location in the document that will be displayed as a result of executing this action.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGoToAction Class
PDFGoToAction Members


PDFHideAction Class

PDFHideAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFHideAction Class

Defines a PDF hide action.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFHideAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFHideAction
C#
public class PDFHideAction : PDFAction
Managed Extensions for C++
public __gc class PDFHideAction : public PDFAction
C++/CLI
public ref class PDFHideAction : public PDFAction

Remarks

This action allows a user to hide or show a form field.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFHideAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHideAction Members
O2S.Components.PDF4NET.Actions Namespace


PDFHideAction Class Members

PDFHideAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFHideAction Class

The following tables list the members exposed by PDFHideAction.

Public Constructors

 | Name | Description
Public Constructor | PDFHideAction Constructor | Initializes a new PDFHideAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Public Property | FieldName | Gets or sets the name of the field that is affected by this action.
Public Property | Hide | Gets or sets a value indicating whether the specified form field should be hidden or shown.
Top

See Also

Reference

PDFHideAction Class
O2S.Components.PDF4NET.Actions Namespace


PDFHideAction Constructor

PDFHideAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFHideAction Class : PDFHideAction Constructor

Initializes a new PDFHideAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFHideAction()
C#
public PDFHideAction()
Managed Extensions for C++
public: PDFHideAction();
C++/CLI
public:
PDFHideAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHideAction Class
PDFHideAction Members


PDFHideAction Class Properties

PDFHideAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFHideAction Class

For a list of all members of this type, see PDFHideAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Public Property | FieldName | Gets or sets the name of the field that is affected by this action.
Public Property | Hide | Gets or sets a value indicating whether the specified form field should be hidden or shown.
Top

See Also

Reference

PDFHideAction Class
O2S.Components.PDF4NET.Actions Namespace


FieldName Property

FieldName Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFHideAction Class : FieldName Property

Gets or sets the name of the field that is affected by this action.

Syntax

Visual Basic (Declaration)
Public Property FieldName As String
Visual Basic (Usage) Copy Code
Dim instance As PDFHideAction
Dim value As String

instance.FieldName = value

value = instance.FieldName
C#
public string FieldName {get; set;}
Managed Extensions for C++
public: __property string* get_FieldName();
public: __property void set_FieldName(
   string* value
);
C++/CLI
public:
property String^ FieldName {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the name of the field that is affected by this action.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHideAction Class
PDFHideAction Members


Hide Property

Hide Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFHideAction Class : Hide Property

Gets or sets a value indicating whether the specified form field should be hidden or shown.

Syntax

Visual Basic (Declaration)
Public Property Hide As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFHideAction
Dim value As Boolean

instance.Hide = value

value = instance.Hide
C#
public bool Hide {get; set;}
Managed Extensions for C++
public: __property bool get_Hide();
public: __property void set_Hide(
   bool value
);
C++/CLI
public:
property bool Hide {
   bool get();
   void set (bool value);
}

Return Value

True if the form field should be hidden, false if the form field should be shown.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHideAction Class
PDFHideAction Members


PDFJavaScriptAction Class

PDFJavaScriptAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFJavaScriptAction Class

This class represents a PDF Javascript action.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFJavaScriptAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptAction
C#
public class PDFJavaScriptAction : PDFAction
Managed Extensions for C++
public __gc class PDFJavaScriptAction : public PDFAction
C++/CLI
public ref class PDFJavaScriptAction : public PDFAction

Remarks

This type of action allows a user to execute Javascript code within the viewer.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFJavaScriptAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptAction Members
O2S.Components.PDF4NET.Actions Namespace


PDFJavaScriptAction Class Members

PDFJavaScriptAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFJavaScriptAction Class

The following tables list the members exposed by PDFJavaScriptAction.

Public Constructors

 | Name | Description
Public Constructor | PDFJavaScriptAction Constructor | Initializes a new PDFJavaScriptAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Public Property | Script | Gets or sets the javascript code to be executed when this action is executed.
Top

See Also

Reference

PDFJavaScriptAction Class
O2S.Components.PDF4NET.Actions Namespace


PDFJavaScriptAction Constructor

PDFJavaScriptAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFJavaScriptAction Class : PDFJavaScriptAction Constructor

Initializes a new PDFJavaScriptAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptAction()
C#
public PDFJavaScriptAction()
Managed Extensions for C++
public: PDFJavaScriptAction();
C++/CLI
public:
PDFJavaScriptAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptAction Class
PDFJavaScriptAction Members


PDFJavaScriptAction Class Properties

PDFJavaScriptAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFJavaScriptAction Class

For a list of all members of this type, see PDFJavaScriptAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Public Property | Script | Gets or sets the javascript code to be executed when this action is executed.
Top

See Also

Reference

PDFJavaScriptAction Class
O2S.Components.PDF4NET.Actions Namespace


Script Property

Script Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFJavaScriptAction Class : Script Property

Gets or sets the javascript code to be executed when this action is executed.

Syntax

Visual Basic (Declaration)
Public Property Script As String
Visual Basic (Usage) Copy Code
Dim instance As PDFJavaScriptAction
Dim value As String

instance.Script = value

value = instance.Script
C#
public string Script {get; set;}
Managed Extensions for C++
public: __property string* get_Script();
public: __property void set_Script(
   string* value
);
C++/CLI
public:
property String^ Script {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing valid javascript code to be executed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJavaScriptAction Class
PDFJavaScriptAction Members


PDFLaunchAction Class

PDFLaunchAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFLaunchAction Class

This class represents a PDF Launch action.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFLaunchAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFLaunchAction
C#
public class PDFLaunchAction : PDFAction
Managed Extensions for C++
public __gc class PDFLaunchAction : public PDFAction
C++/CLI
public ref class PDFLaunchAction : public PDFAction

Remarks

This type of action allows a user to launch an application or to open a document.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFLaunchAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLaunchAction Members
O2S.Components.PDF4NET.Actions Namespace


PDFLaunchAction Class Members

PDFLaunchAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFLaunchAction Class

The following tables list the members exposed by PDFLaunchAction.

Public Constructors

 | Name | Description
Public Constructor | PDFLaunchAction Constructor | Initializes a new PDFLaunchAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Public Property | FileName | Gets or sets the name of the file to be launched by this action.
Public Property | NewWindow | Gets or sets whether the remote document opens in current window or in a new window.
Public Property | Parameters | Gets or sets a parameter string to be passed to the launched application.
Top

See Also

Reference

PDFLaunchAction Class
O2S.Components.PDF4NET.Actions Namespace


PDFLaunchAction Constructor

PDFLaunchAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFLaunchAction Class : PDFLaunchAction Constructor

Initializes a new PDFLaunchAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFLaunchAction()
C#
public PDFLaunchAction()
Managed Extensions for C++
public: PDFLaunchAction();
C++/CLI
public:
PDFLaunchAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


PDFLaunchAction Class Properties

PDFLaunchAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFLaunchAction Class

For a list of all members of this type, see PDFLaunchAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Public Property | FileName | Gets or sets the name of the file to be launched by this action.
Public Property | NewWindow | Gets or sets whether the remote document opens in current window or in a new window.
Public Property | Parameters | Gets or sets a parameter string to be passed to the launched application.
Top

See Also

Reference

PDFLaunchAction Class
O2S.Components.PDF4NET.Actions Namespace


FileName Property

FileName Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFLaunchAction Class : FileName Property

Gets or sets the name of the file to be launched by this action.

Syntax

Visual Basic (Declaration)
Public Property FileName As String
Visual Basic (Usage) Copy Code
Dim instance As PDFLaunchAction
Dim value As String

instance.FileName = value

value = instance.FileName
C#
public string FileName {get; set;}
Managed Extensions for C++
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
C++/CLI
public:
property String^ FileName {
   String^ get();
   void set (String^ value);
}

Return Value

An string value specifying the full path to the file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


NewWindow Property

NewWindow Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFLaunchAction Class : NewWindow Property

Gets or sets whether the remote document opens in current window or in a new window.

Syntax

Visual Basic (Declaration)
Public Property NewWindow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFLaunchAction
Dim value As Boolean

instance.NewWindow = value

value = instance.NewWindow
C#
public bool NewWindow {get; set;}
Managed Extensions for C++
public: __property bool get_NewWindow();
public: __property void set_NewWindow(
   bool value
);
C++/CLI
public:
property bool NewWindow {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the remote document opens in current window or in a new window. If the remote document opens in the current window, the current pdf file is replaced with the remote document.

Remarks

If the file is not a pdf document, this property is ignored.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


Parameters Property

Parameters Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFLaunchAction Class : Parameters Property

Gets or sets a parameter string to be passed to the launched application.

Syntax

Visual Basic (Declaration)
Public Property Parameters As String
Visual Basic (Usage) Copy Code
Dim instance As PDFLaunchAction
Dim value As String

instance.Parameters = value

value = instance.Parameters
C#
public string Parameters {get; set;}
Managed Extensions for C++
public: __property string* get_Parameters();
public: __property void set_Parameters(
   string* value
);
C++/CLI
public:
property String^ Parameters {
   String^ get();
   void set (String^ value);
}

Return Value

An string value specifying the the list of parameters to be passed to the launched application

Remarks

This property matches the string of parameters as if they were passed to the application in the command line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLaunchAction Class
PDFLaunchAction Members


PDFNamedAction Class

PDFNamedAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFNamedAction Class

This class represents a PDF Named action.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFNamedAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFNamedAction
C#
public class PDFNamedAction : PDFAction
Managed Extensions for C++
public __gc class PDFNamedAction : public PDFAction
C++/CLI
public ref class PDFNamedAction : public PDFAction

Remarks

This type of action allows a user to navigate to specific pages in the document or to print the document.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFNamedAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFNamedAction Members
O2S.Components.PDF4NET.Actions Namespace


PDFNamedAction Class Members

PDFNamedAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFNamedAction Class

The following tables list the members exposed by PDFNamedAction.

Public Constructors

 | Name | Description
Public Constructor | PDFNamedAction Constructor | Initializes a new PDFNamedAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Public Property | NamedAction | Gets or sets the named action to be executed when this action is executed.
Top

See Also

Reference

PDFNamedAction Class
O2S.Components.PDF4NET.Actions Namespace


PDFNamedAction Constructor

PDFNamedAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFNamedAction Class : PDFNamedAction Constructor

Initializes a new PDFNamedAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFNamedAction()
C#
public PDFNamedAction()
Managed Extensions for C++
public: PDFNamedAction();
C++/CLI
public:
PDFNamedAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFNamedAction Class
PDFNamedAction Members


PDFNamedAction Class Properties

PDFNamedAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFNamedAction Class

For a list of all members of this type, see PDFNamedAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Public Property | NamedAction | Gets or sets the named action to be executed when this action is executed.
Top

See Also

Reference

PDFNamedAction Class
O2S.Components.PDF4NET.Actions Namespace


NamedAction Property

NamedAction Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFNamedAction Class : NamedAction Property

Gets or sets the named action to be executed when this action is executed.

Syntax

Visual Basic (Declaration)
Public Property NamedAction As NamedAction
Visual Basic (Usage) Copy Code
Dim instance As PDFNamedAction
Dim value As NamedAction

instance.NamedAction = value

value = instance.NamedAction
C#
public NamedAction NamedAction {get; set;}
Managed Extensions for C++
public: __property NamedAction get_NamedAction();
public: __property void set_NamedAction(
   NamedAction value
);
C++/CLI
public:
property NamedAction NamedAction {
   NamedAction get();
   void set (NamedAction value);
}

Return Value

An NamedAction enumeration member specifying the action to be executed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFNamedAction Class
PDFNamedAction Members


PDFRemoteGoToAction Class

PDFRemoteGoToAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFRemoteGoToAction Class

This class represents a PDF Remote Go-To action.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFRemoteGoToAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFRemoteGoToAction
C#
public class PDFRemoteGoToAction : PDFAction
Managed Extensions for C++
public __gc class PDFRemoteGoToAction : public PDFAction
C++/CLI
public ref class PDFRemoteGoToAction : public PDFAction

Remarks

This type of action allows a user to navigate to a specific page in an external pdf document. It allows to specify the page to open when this action is executed, the location in the page where the viewer should display the page and a magnification factor to be used when displaying the destination page.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFRemoteGoToAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemoteGoToAction Members
O2S.Components.PDF4NET.Actions Namespace


PDFRemoteGoToAction Class Members

PDFRemoteGoToAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFRemoteGoToAction Class

The following tables list the members exposed by PDFRemoteGoToAction.

Public Constructors

 | Name | Description
Public Constructor | PDFRemoteGoToAction Constructor | Initializes a new PDFRemoteGoToAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Destination | Gets or sets the destination of this action.
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Public Property | FileName | Gets or sets the target file name.
Public Property | NewWindow | Gets or sets whether the remote document opens in current window or in a new window.
Top

See Also

Reference

PDFRemoteGoToAction Class
O2S.Components.PDF4NET.Actions Namespace


PDFRemoteGoToAction Constructor

PDFRemoteGoToAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : PDFRemoteGoToAction Constructor

Initializes a new PDFRemoteGoToAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFRemoteGoToAction()
C#
public PDFRemoteGoToAction()
Managed Extensions for C++
public: PDFRemoteGoToAction();
C++/CLI
public:
PDFRemoteGoToAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


PDFRemoteGoToAction Class Properties

PDFRemoteGoToAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFRemoteGoToAction Class

For a list of all members of this type, see PDFRemoteGoToAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Destination | Gets or sets the destination of this action.
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Public Property | FileName | Gets or sets the target file name.
Public Property | NewWindow | Gets or sets whether the remote document opens in current window or in a new window.
Top

See Also

Reference

PDFRemoteGoToAction Class
O2S.Components.PDF4NET.Actions Namespace


Destination Property

Destination Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : Destination Property

Gets or sets the destination of this action.

Syntax

Visual Basic (Declaration)
Public Property Destination As PDFRemotePageDestination
Visual Basic (Usage) Copy Code
Dim instance As PDFRemoteGoToAction
Dim value As PDFRemotePageDestination

instance.Destination = value

value = instance.Destination
C#
public PDFRemotePageDestination Destination {get; set;}
Managed Extensions for C++
public: __property PDFRemotePageDestination* get_Destination();
public: __property void set_Destination(
   PDFRemotePageDestination* value
);
C++/CLI
public:
property PDFRemotePageDestination^ Destination {
   PDFRemotePageDestination^ get();
   void set (PDFRemotePageDestination^ value);
}

Return Value

The location in the remote document that will be displayed as a result of executing this action.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


FileName Property

FileName Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : FileName Property

Gets or sets the target file name.

Syntax

Visual Basic (Declaration)
Public Property FileName As String
Visual Basic (Usage) Copy Code
Dim instance As PDFRemoteGoToAction
Dim value As String

instance.FileName = value

value = instance.FileName
C#
public string FileName {get; set;}
Managed Extensions for C++
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
C++/CLI
public:
property String^ FileName {
   String^ get();
   void set (String^ value);
}

Return Value

The name of the file that represents the target of this action.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


NewWindow Property

NewWindow Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFRemoteGoToAction Class : NewWindow Property

Gets or sets whether the remote document opens in current window or in a new window.

Syntax

Visual Basic (Declaration)
Public Property NewWindow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFRemoteGoToAction
Dim value As Boolean

instance.NewWindow = value

value = instance.NewWindow
C#
public bool NewWindow {get; set;}
Managed Extensions for C++
public: __property bool get_NewWindow();
public: __property void set_NewWindow(
   bool value
);
C++/CLI
public:
property bool NewWindow {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the remote document opens in current window or in a new window. If the remote document opens in the current window, the current pdf file is replaced with the remote document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRemoteGoToAction Class
PDFRemoteGoToAction Members


PDFResetFormAction Class

PDFResetFormAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFResetFormAction Class

Defines a SubmitForm action.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFResetFormAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFResetFormAction
C#
public class PDFResetFormAction : PDFAction
Managed Extensions for C++
public __gc class PDFResetFormAction : public PDFAction
C++/CLI
public ref class PDFResetFormAction : public PDFAction

Remarks

This action allows a user to reset the form fields to their default values.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFResetFormAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFResetFormAction Members
O2S.Components.PDF4NET.Actions Namespace


PDFResetFormAction Class Members

PDFResetFormAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFResetFormAction Class

The following tables list the members exposed by PDFResetFormAction.

Public Constructors

 | Name | Description
Public Constructor | PDFResetFormAction Constructor | Initializes a new PDFResetFormAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Public Property | Fields | Gets or sets the list of fields affected by this action.
Public Property | ResetFields | Gets or sets a value indicating whether the fields in Fields collection should be reset or not.
Top

See Also

Reference

PDFResetFormAction Class
O2S.Components.PDF4NET.Actions Namespace


PDFResetFormAction Constructor

PDFResetFormAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFResetFormAction Class : PDFResetFormAction Constructor

Initializes a new PDFResetFormAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFResetFormAction()
C#
public PDFResetFormAction()
Managed Extensions for C++
public: PDFResetFormAction();
C++/CLI
public:
PDFResetFormAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFResetFormAction Class
PDFResetFormAction Members


PDFResetFormAction Class Properties

PDFResetFormAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFResetFormAction Class

For a list of all members of this type, see PDFResetFormAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Public Property | Fields | Gets or sets the list of fields affected by this action.
Public Property | ResetFields | Gets or sets a value indicating whether the fields in Fields collection should be reset or not.
Top

See Also

Reference

PDFResetFormAction Class
O2S.Components.PDF4NET.Actions Namespace


Fields Property

Fields Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFResetFormAction Class : Fields Property

Gets or sets the list of fields affected by this action.

Syntax

Visual Basic (Declaration)
Public Property Fields As StringCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFResetFormAction
Dim value As StringCollection

instance.Fields = value

value = instance.Fields
C#
public StringCollection Fields {get; set;}
Managed Extensions for C++
public: __property StringCollection get_Fields();
public: __property void set_Fields(
   StringCollection value
);
C++/CLI
public:
property StringCollection Fields {
   StringCollection get();
   void set (StringCollection value);
}

Return Value

A StringCollection object specifying the list of fields affected by this action.

Remarks

The ResetFields property controls how the fields in this collection are reset.
If ResetFields property is true, only the fields in this collection will be reset.
If ResetFields property is false, the fields in this collection are not reset and only the remaining form fields are reset.
If the collection is null or empty, then all the form fields are reset and the ResetFields property is ignored.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFResetFormAction Class
PDFResetFormAction Members


ResetFields Property

ResetFields Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFResetFormAction Class : ResetFields Property

Gets or sets a value indicating whether the fields in Fields collection should be reset or not.

Syntax

Visual Basic (Declaration)
Public Property ResetFields As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFResetFormAction
Dim value As Boolean

instance.ResetFields = value

value = instance.ResetFields
C#
public bool ResetFields {get; set;}
Managed Extensions for C++
public: __property bool get_ResetFields();
public: __property void set_ResetFields(
   bool value
);
C++/CLI
public:
property bool ResetFields {
   bool get();
   void set (bool value);
}

Return Value

True if the fields in Fields collection should be reset, false otherwise. Default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFResetFormAction Class
PDFResetFormAction Members


PDFSubmitFormAction Class

PDFSubmitFormAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFSubmitFormAction Class

Defines a SubmitForm action.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSubmitFormAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
C#
public class PDFSubmitFormAction : PDFAction
Managed Extensions for C++
public __gc class PDFSubmitFormAction : public PDFAction
C++/CLI
public ref class PDFSubmitFormAction : public PDFAction

Remarks

This action allows a user to submit the form data to a specified URL.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFSubmitFormAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Members
O2S.Components.PDF4NET.Actions Namespace


PDFSubmitFormAction Class Members

PDFSubmitFormAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFSubmitFormAction Class

The following tables list the members exposed by PDFSubmitFormAction.

Public Constructors

 | Name | Description
Public Constructor | PDFSubmitFormAction Constructor | Initializes a new PDFSubmitFormAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | DataFormat | Gets or sets the format of the data being submitted.
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Public Property | EmbedForm | Gets or sets a value indicating whether the PDF document is embedded in the submitted FDF file.
Public Property | ExcludeNonUserAnnotations | Gets or sets a value indicating whether only the annotations whose author is the current user should be submitted.
Public Property | Fields | Gets or sets the list of fields affected by this action.
Public Property | IncludeAnnotations | Gets or sets a value indicating whether the markup annotations in the underlying PDF document are included in the submitted FDF file.
Public Property | IncludeAppendSaves | Gets or sets a value indicating whether the incremental updates to the underlying PDF document are included in the submitted FDF file.
Public Property | IncludeNoValueFields | Gets or sets a value indicating whether the fields with no value should be submitted.
Public Property | SubmitCoordinates | Gets or sets a value indicating whether the coordinates of the mouse click that caused the submit form action are transmitted as part of form data.
Public Property | SubmitFields | Gets or sets a value indicating whether the fields in Fields collection should be submitted or not.
Public Property | Url | Gets or sets the URL for submitting the form data.
Public Property | UseCanonicalDateTimeFormat | Gets or sets a value indicating whether the field values representing dates should be submitted using PDF date/time format.
Public Property | UseHttpGet | Gets or sets a value indicating whether the field names and values should be submitted using HTTP GET method.
Top

See Also

Reference

PDFSubmitFormAction Class
O2S.Components.PDF4NET.Actions Namespace


PDFSubmitFormAction Constructor

PDFSubmitFormAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : PDFSubmitFormAction Constructor

Initializes a new PDFSubmitFormAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction()
C#
public PDFSubmitFormAction()
Managed Extensions for C++
public: PDFSubmitFormAction();
C++/CLI
public:
PDFSubmitFormAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


PDFSubmitFormAction Class Properties

PDFSubmitFormAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFSubmitFormAction Class

For a list of all members of this type, see PDFSubmitFormAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | DataFormat | Gets or sets the format of the data being submitted.
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Public Property | EmbedForm | Gets or sets a value indicating whether the PDF document is embedded in the submitted FDF file.
Public Property | ExcludeNonUserAnnotations | Gets or sets a value indicating whether only the annotations whose author is the current user should be submitted.
Public Property | Fields | Gets or sets the list of fields affected by this action.
Public Property | IncludeAnnotations | Gets or sets a value indicating whether the markup annotations in the underlying PDF document are included in the submitted FDF file.
Public Property | IncludeAppendSaves | Gets or sets a value indicating whether the incremental updates to the underlying PDF document are included in the submitted FDF file.
Public Property | IncludeNoValueFields | Gets or sets a value indicating whether the fields with no value should be submitted.
Public Property | SubmitCoordinates | Gets or sets a value indicating whether the coordinates of the mouse click that caused the submit form action are transmitted as part of form data.
Public Property | SubmitFields | Gets or sets a value indicating whether the fields in Fields collection should be submitted or not.
Public Property | Url | Gets or sets the URL for submitting the form data.
Public Property | UseCanonicalDateTimeFormat | Gets or sets a value indicating whether the field values representing dates should be submitted using PDF date/time format.
Public Property | UseHttpGet | Gets or sets a value indicating whether the field names and values should be submitted using HTTP GET method.
Top

See Also

Reference

PDFSubmitFormAction Class
O2S.Components.PDF4NET.Actions Namespace


DataFormat Property

DataFormat Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : DataFormat Property

Gets or sets the format of the data being submitted.

Syntax

Visual Basic (Declaration)
Public Property DataFormat As SubmitDataFormat
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As SubmitDataFormat

instance.DataFormat = value

value = instance.DataFormat
C#
public SubmitDataFormat DataFormat {get; set;}
Managed Extensions for C++
public: __property SubmitDataFormat get_DataFormat();
public: __property void set_DataFormat(
   SubmitDataFormat value
);
C++/CLI
public:
property SubmitDataFormat DataFormat {
   SubmitDataFormat get();
   void set (SubmitDataFormat value);
}

Return Value

A SubmitDataFormat enumeration member specifying the format of the data being submitted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


EmbedForm Property

EmbedForm Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : EmbedForm Property

Gets or sets a value indicating whether the PDF document is embedded in the submitted FDF file.

Syntax

Visual Basic (Declaration)
Public Property EmbedForm As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.EmbedForm = value

value = instance.EmbedForm
C#
public bool EmbedForm {get; set;}
Managed Extensions for C++
public: __property bool get_EmbedForm();
public: __property void set_EmbedForm(
   bool value
);
C++/CLI
public:
property bool EmbedForm {
   bool get();
   void set (bool value);
}

Return Value

True if the PDF document is embedded in the submitted FDF file, false otherwise. Default is false.

Remarks

This property has meaning only if DataFormat property is FDF.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


ExcludeNonUserAnnotations Property

ExcludeNonUserAnnotations Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : ExcludeNonUserAnnotations Property

Gets or sets a value indicating whether only the annotations whose author is the current user should be submitted.

Syntax

Visual Basic (Declaration)
Public Property ExcludeNonUserAnnotations As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.ExcludeNonUserAnnotations = value

value = instance.ExcludeNonUserAnnotations
C#
public bool ExcludeNonUserAnnotations {get; set;}
Managed Extensions for C++
public: __property bool get_ExcludeNonUserAnnotations();
public: __property void set_ExcludeNonUserAnnotations(
   bool value
);
C++/CLI
public:
property bool ExcludeNonUserAnnotations {
   bool get();
   void set (bool value);
}

Return Value

True if only the annotations whose author is the current user should be submitted, false otherwise. Default is false.

Remarks

This property has meaning only if DataFormat property is FDF and IncludeAnnotations property is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


Fields Property

Fields Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : Fields Property

Gets or sets the list of fields affected by this action.

Syntax

Visual Basic (Declaration)
Public Property Fields As StringCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As StringCollection

instance.Fields = value

value = instance.Fields
C#
public StringCollection Fields {get; set;}
Managed Extensions for C++
public: __property StringCollection get_Fields();
public: __property void set_Fields(
   StringCollection value
);
C++/CLI
public:
property StringCollection Fields {
   StringCollection get();
   void set (StringCollection value);
}

Return Value

A StringCollection object specifying the list of fields affected by this action.

Remarks

The SubmitFields property controls how the fields in this collection are submitted to the specified URL.
If SubmitFields property is true, only the fields in this collection will be submitted.
If SubmitFields property is false, the fields in this collection will not be submitted and only the remaining form fields will be submitted.
If the collection is null or empty, then all the form fields are submitted and the SubmitFields property is ignored.
In any of the situations above, the fields with NoExport property set to true will not be submitted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


IncludeAnnotations Property

IncludeAnnotations Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : IncludeAnnotations Property

Gets or sets a value indicating whether the markup annotations in the underlying PDF document are included in the submitted FDF file.

Syntax

Visual Basic (Declaration)
Public Property IncludeAnnotations As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.IncludeAnnotations = value

value = instance.IncludeAnnotations
C#
public bool IncludeAnnotations {get; set;}
Managed Extensions for C++
public: __property bool get_IncludeAnnotations();
public: __property void set_IncludeAnnotations(
   bool value
);
C++/CLI
public:
property bool IncludeAnnotations {
   bool get();
   void set (bool value);
}

Return Value

True if the incremental updates to the underlying PDF document should be included in the submitted FDF file, false otherwise. Default is false.

Remarks

This property has meaning only if DataFormat property is FDF.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


IncludeAppendSaves Property

IncludeAppendSaves Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : IncludeAppendSaves Property

Gets or sets a value indicating whether the incremental updates to the underlying PDF document are included in the submitted FDF file.

Syntax

Visual Basic (Declaration)
Public Property IncludeAppendSaves As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.IncludeAppendSaves = value

value = instance.IncludeAppendSaves
C#
public bool IncludeAppendSaves {get; set;}
Managed Extensions for C++
public: __property bool get_IncludeAppendSaves();
public: __property void set_IncludeAppendSaves(
   bool value
);
C++/CLI
public:
property bool IncludeAppendSaves {
   bool get();
   void set (bool value);
}

Return Value

True if the incremental updates to the underlying PDF document should be included in the submitted FDF file, false otherwise. Default is false.

Remarks

This property has meaning only if DataFormat property is FDF.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


IncludeNoValueFields Property

IncludeNoValueFields Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : IncludeNoValueFields Property

Gets or sets a value indicating whether the fields with no value should be submitted.

Syntax

Visual Basic (Declaration)
Public Property IncludeNoValueFields As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.IncludeNoValueFields = value

value = instance.IncludeNoValueFields
C#
public bool IncludeNoValueFields {get; set;}
Managed Extensions for C++
public: __property bool get_IncludeNoValueFields();
public: __property void set_IncludeNoValueFields(
   bool value
);
C++/CLI
public:
property bool IncludeNoValueFields {
   bool get();
   void set (bool value);
}

Return Value

True if the fields with no value should be submitted, false otherwise. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


SubmitCoordinates Property

SubmitCoordinates Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : SubmitCoordinates Property

Gets or sets a value indicating whether the coordinates of the mouse click that caused the submit form action are transmitted as part of form data.

Syntax

Visual Basic (Declaration)
Public Property SubmitCoordinates As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.SubmitCoordinates = value

value = instance.SubmitCoordinates
C#
public bool SubmitCoordinates {get; set;}
Managed Extensions for C++
public: __property bool get_SubmitCoordinates();
public: __property void set_SubmitCoordinates(
   bool value
);
C++/CLI
public:
property bool SubmitCoordinates {
   bool get();
   void set (bool value);
}

Return Value

True if the coordinates of the mouse click that caused the submit form action should be transmitted as part of form data, otherwise false. Default is false.

Remarks

This property has meaning only if DataFormat property is HTML.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


SubmitFields Property

SubmitFields Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : SubmitFields Property

Gets or sets a value indicating whether the fields in Fields collection should be submitted or not.

Syntax

Visual Basic (Declaration)
Public Property SubmitFields As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.SubmitFields = value

value = instance.SubmitFields
C#
public bool SubmitFields {get; set;}
Managed Extensions for C++
public: __property bool get_SubmitFields();
public: __property void set_SubmitFields(
   bool value
);
C++/CLI
public:
property bool SubmitFields {
   bool get();
   void set (bool value);
}

Return Value

True if the fields in Fields collection should be submitted, false otherwise. Default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


Url Property

Url Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : Url Property

Gets or sets the URL for submitting the form data.

Syntax

Visual Basic (Declaration)
Public Property Url As String
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As String

instance.Url = value

value = instance.Url
C#
public string Url {get; set;}
Managed Extensions for C++
public: __property string* get_Url();
public: __property void set_Url(
   string* value
);
C++/CLI
public:
property String^ Url {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the URL where the form data should be submitted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


UseCanonicalDateTimeFormat Property

UseCanonicalDateTimeFormat Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : UseCanonicalDateTimeFormat Property

Gets or sets a value indicating whether the field values representing dates should be submitted using PDF date/time format.

Syntax

Visual Basic (Declaration)
Public Property UseCanonicalDateTimeFormat As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.UseCanonicalDateTimeFormat = value

value = instance.UseCanonicalDateTimeFormat
C#
public bool UseCanonicalDateTimeFormat {get; set;}
Managed Extensions for C++
public: __property bool get_UseCanonicalDateTimeFormat();
public: __property void set_UseCanonicalDateTimeFormat(
   bool value
);
C++/CLI
public:
property bool UseCanonicalDateTimeFormat {
   bool get();
   void set (bool value);
}

Return Value

True if the the field values representing dates should be submitted using PDF date/time format. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


UseHttpGet Property

UseHttpGet Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFSubmitFormAction Class : UseHttpGet Property

Gets or sets a value indicating whether the field names and values should be submitted using HTTP GET method.

Syntax

Visual Basic (Declaration)
Public Property UseHttpGet As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSubmitFormAction
Dim value As Boolean

instance.UseHttpGet = value

value = instance.UseHttpGet
C#
public bool UseHttpGet {get; set;}
Managed Extensions for C++
public: __property bool get_UseHttpGet();
public: __property void set_UseHttpGet(
   bool value
);
C++/CLI
public:
property bool UseHttpGet {
   bool get();
   void set (bool value);
}

Return Value

True if the field names and values should be submitted using HTTP GET method. If false, the field names and values are submitted using HTTP POST method. Default is false.

Remarks

This property has meaning only if DataFormat property is HTML or PDF.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSubmitFormAction Class
PDFSubmitFormAction Members


PDFURIAction Class

PDFURIAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFURIAction Class

This class represents a PDF URI action.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFURIAction
   Inherits PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFURIAction
C#
public class PDFURIAction : PDFAction
Managed Extensions for C++
public __gc class PDFURIAction : public PDFAction
C++/CLI
public ref class PDFURIAction : public PDFAction

Remarks

This type of action allows a user to go to a resource on the Internet, tipically a hypertext link.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Actions.PDFAction
O2S.Components.PDF4NET.Actions.PDFURIAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFURIAction Members
O2S.Components.PDF4NET.Actions Namespace


PDFURIAction Class Members

PDFURIAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFURIAction Class

The following tables list the members exposed by PDFURIAction.

Public Constructors

 | Name | Description
Public Constructor | PDFURIAction Constructor | Initializes a new PDFURIAction object.
Top

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Public Property | URI | Gets or sets the uri to be resolved when this action is executed.
Top

See Also

Reference

PDFURIAction Class
O2S.Components.PDF4NET.Actions Namespace


PDFURIAction Constructor

PDFURIAction Constructor
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFURIAction Class : PDFURIAction Constructor

Initializes a new PDFURIAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFURIAction()
C#
public PDFURIAction()
Managed Extensions for C++
public: PDFURIAction();
C++/CLI
public:
PDFURIAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFURIAction Class
PDFURIAction Members


PDFURIAction Class Properties

PDFURIAction Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFURIAction Class

For a list of all members of this type, see PDFURIAction members.

Public Properties

 | Name | Description
Public Property | Actions | Gets the list of actions to be performed after this one. (Inherited from PDFAction)
Public Property | Dictionary | Gets the action dictionary. (Inherited from PDFAction)
Public Property | URI | Gets or sets the uri to be resolved when this action is executed.
Top

See Also

Reference

PDFURIAction Class
O2S.Components.PDF4NET.Actions Namespace


URI Property

URI Property
[image]
O2S.Components.PDF4NET.Actions Namespace > PDFURIAction Class : URI Property

Gets or sets the uri to be resolved when this action is executed.

Syntax

Visual Basic (Declaration)
Public Property URI As String
Visual Basic (Usage) Copy Code
Dim instance As PDFURIAction
Dim value As String

instance.URI = value

value = instance.URI
C#
public string URI {get; set;}
Managed Extensions for C++
public: __property string* get_URI();
public: __property void set_URI(
   string* value
);
C++/CLI
public:
property String^ URI {
   String^ get();
   void set (String^ value);
}

Return Value

An string value specifying the full URI for the internet resource.

Remarks

The value of this property is usually a HTTP url, like below:

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFURIAction Class
PDFURIAction Members


NamedAction Enumeration

NamedAction Enumeration
[image]
O2S.Components.PDF4NET.Actions Namespace : NamedAction Enumeration

Specifies the available named actions supported by the viewer.

Syntax

Visual Basic (Declaration)
Public Enum NamedAction
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As NamedAction
C#
public enum NamedAction : Enum
Managed Extensions for C++
__value public enum NamedAction : public Enum
C++/CLI
public enum class NamedAction : public Enum

Members

Member | Description
NextPage | Go to next page in the document.
PrevPage | Go to previous page in the document.
FirstPage | Go to first page in the document.
LastPage | Go to last page in the document.
Print | Print the document.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Actions.NamedAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Actions Namespace


SubmitDataFormat Enumeration

SubmitDataFormat Enumeration
[image]
O2S.Components.PDF4NET.Actions Namespace : SubmitDataFormat Enumeration

Specifies the available data formats for submitting the form data.

Syntax

Visual Basic (Declaration)
Public Enum SubmitDataFormat
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As SubmitDataFormat
C#
public enum SubmitDataFormat : Enum
Managed Extensions for C++
__value public enum SubmitDataFormat : public Enum
C++/CLI
public enum class SubmitDataFormat : public Enum

Members

Member | Description
HTML | The field names and values are submitted in HTML Form format.
FDF | The field names and values are submitted in FDF format.
XFDF | The field names and values are submitted in XFDF format.
PDF | The entire PDF file is submitted.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Actions.SubmitDataFormat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Actions Namespace


O2S.Components.PDF4NET.Annotations Namespace

O2S.Components.PDF4NET.Annotations Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDF3DActivation | Defines how the annotation is activated and deactivated.
PDF3DAnimation | Defines the lighting to apply to 3D artwork.
PDF3DAnnotation | Defines a 3D annotation.
PDF3DBackground | Defines the background appearance for 3D artwork.
PDF3DCrossSection | Defines how a portion of the 3D artwork is clipped for the purpose of showing artwork cross sections.
PDF3DCrossSectionCollection | Defines a collection of PDF actions.
PDF3DEntity | Defines the base class for all 3D related classes.
PDF3DLightingScheme | Defines the lighting to apply to 3D artwork.
PDF3DNode | Defines particular areas of 3D artwork and the opacity and visibility with which individual nodes are displayed.
PDF3DNodeCollection | Defines a collection of PDF actions.
PDF3DProjection | Defines the mapping of 3D camera coordinates onto the target coordinate system of the annotation.
PDF3DRenderMode | Defines the style in which the 3D artwork is rendered.
PDF3DStream | Defines the stream that contains the 3D artwork.
PDF3DView | Defines the parameters to be applied to the virtual camera associated with a 3D annotation.
PDF3DViewCollection | Defines a collection of PDF actions.
PDFAnnotation | Defines the base class for all annotations available in a PDF file.
PDFAnnotationAppearance | Defines the base class for all annotation appearances.
PDFAnnotationBorder | Defines the border of an annotation.
PDFAnnotationCollection | Defines a collection of annotations.
PDFBaseMarkupAnnotation | Defines the base class for all markup type annotations.
PDFEllipseAnnotation | Defines an ellipse (Circle) annotation.
PDFFileAttachmentAnnotation | Defines a file attachment annotation.
PDFFreeTextAnnotation | Defines a free text annotations.
PDFHighlightAnnotation | Defines a highlight annotation.
PDFImageAppearance | Defines an annotation appearance that consists of an image.
PDFInkAnnotation | Defines an ink annotation.
PDFLineAnnotation | Defines a line annotation.
PDFLinkAnnotation | Defines a link annotations.
PDFMarkupAnnotation | Defines the base class for all markup type annotations.
PDFMovieAnnotation | Defines a movie annotation in a PDF file.
PDFPointsCollection | Defines a collection of array the store points on the page.
PDFRectangleAnnotation | Defines a rectangle (Square) annotation.
PDFRubberStampAnnotation | Defines a rubber stamp annotation.
PDFSCAnnotation | Defines the base class for rectangle (Square) and ellipse (Circle) annotations.
PDFSquigglyAnnotation | Defines a squiggly annotation.
PDFStrikeOutAnnotation | Defines a strike out annotation.
PDFTextAnnotation | Defines a text annotation.
PDFTextMarkupAnnotation | Defines a text markup annotation.
PDFUnderlineAnnotation | Defines an underline annotation.

Enumerations

Enumeration | Description
PDF3DActivationMode | Specifies the available modes for activating a 3D annotation.
PDF3DActivationState | Specifies the available states upon activation of the 3D annotation.
PDF3DAnimationType | Specifies the available styles for applying light to 3D artwork.
PDF3DDeactivationMode | Specifies the available modes for activating a 3D annotation.
PDF3DDeactivationState | Specifies the available states upon deactivation of the 3D annotation.
PDF3DLightingStyle | Specifies the available styles for applying light to 3D artwork.
PDF3DProjectionClipStyle | Specifies the available styles for the projection clipping.
PDF3DProjectionOrthoScaleMode | Specifies the available scaling modes for orthographic projections.
PDF3DProjectionType | Specifies the available types for the projection of 3D artwork.
PDF3DRenderStyle | Specifies the available styles for rendering the 3D artwork.
PDFAnnotationFlags | Specifies the available flags for an annotation.
PDFAnnotationType | Specifies the available types of annotations.
PDFBorderStyle | Specifies the available styles for an annotation's border.
PDFFileAttachmentAnnotationIcon | Specifies the available icons for a file attachment annotation.
PDFLineDirection | Specifies the available directions for a line annotation.
PDFLineEndingStyle | Specifies the available line ending styles to be used when drawing a line annotation.
PDFLinkHighlightMode | Specifies the available highlighting modes for a link annotation.
PDFMovieType | Specifies the available movie types to be included in a PDF document.
PDFRubberStampAnnotationIcon | Specifies the available icons for a stmap annotation.
PDFTextAnnotationIcon | Specifies the available icons for a text annotation.
PDFTextAnnotationState | Specifies the available states for a text annotation.
PDFTextMarkupType | Specifies the available markup types for a text markup annotation.

See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET.Annotations Namespace Inheritance Hierarchy

O2S.Components.PDF4NET.Annotations Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DActivation
O2S.Components.PDF4NET.Annotations.PDF3DAnimation
O2S.Components.PDF4NET.Annotations.PDF3DBackground
O2S.Components.PDF4NET.Annotations.PDF3DCrossSection
O2S.Components.PDF4NET.Annotations.PDF3DNode
O2S.Components.PDF4NET.Annotations.PDF3DProjection
O2S.Components.PDF4NET.Annotations.PDF3DRenderMode
O2S.Components.PDF4NET.Annotations.PDF3DStream
O2S.Components.PDF4NET.Annotations.PDF3DView
O2S.Components.PDF4NET.Annotations.PDF3DLightingScheme
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDF3DAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFFileAttachmentAnnotation
O2S.Components.PDF4NET.Annotations.PDFInkAnnotation
O2S.Components.PDF4NET.Annotations.PDFLineAnnotation
O2S.Components.PDF4NET.Annotations.PDFRubberStampAnnotation
O2S.Components.PDF4NET.Annotations.PDFSCAnnotation
O2S.Components.PDF4NET.Annotations.PDFEllipseAnnotation
O2S.Components.PDF4NET.Annotations.PDFRectangleAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFHighlightAnnotation
O2S.Components.PDF4NET.Annotations.PDFSquigglyAnnotation
O2S.Components.PDF4NET.Annotations.PDFStrikeOutAnnotation
O2S.Components.PDF4NET.Annotations.PDFUnderlineAnnotation
O2S.Components.PDF4NET.Annotations.PDFFreeTextAnnotation
O2S.Components.PDF4NET.Annotations.PDFLinkAnnotation
O2S.Components.PDF4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFMovieAnnotation
O2S.Components.PDF4NET.Annotations.PDFAnnotationBorder
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.Annotations.PDFAnnotationAppearance
O2S.Components.PDF4NET.Annotations.PDFImageAppearance
System.Collections.ObjectModel.Collection<PDF3DCrossSection>
O2S.Components.PDF4NET.Annotations.PDF3DCrossSectionCollection
System.Collections.ObjectModel.Collection<PDF3DNode>
O2S.Components.PDF4NET.Annotations.PDF3DNodeCollection
System.Collections.ObjectModel.Collection<PDF3DView>
O2S.Components.PDF4NET.Annotations.PDF3DViewCollection
System.Collections.ObjectModel.Collection<PDFAnnotation>
O2S.Components.PDF4NET.PDFCollection<PDFAnnotation, PDFPage>
O2S.Components.PDF4NET.Annotations.PDFAnnotationCollection
System.Collections.ObjectModel.Collection<Double>
O2S.Components.PDF4NET.PDFCollection<Double, PDFAnnotation>
O2S.Components.PDF4NET.Annotations.PDFPointsCollection

See Also

Reference

O2S.Components.PDF4NET Assembly


PDF3DActivation Class

PDF3DActivation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DActivation Class

Defines how the annotation is activated and deactivated.

Syntax

Visual Basic (Declaration)
Public Class PDF3DActivation
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivation
C#
public class PDF3DActivation : PDF3DEntity
Managed Extensions for C++
public __gc class PDF3DActivation : public PDF3DEntity
C++/CLI
public ref class PDF3DActivation : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DActivation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DActivation Members
O2S.Components.PDF4NET.Annotations Namespace


PDF3DActivation Class Members

PDF3DActivation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DActivation Class

The following tables list the members exposed by PDF3DActivation.

Public Constructors

 | Name | Description
Public Constructor | PDF3DActivation Constructor | Initializes a new PDF3DActivation object.
Top

Public Properties

 | Name | Description
Public Property | ActivationMode | Gets or sets the activation mode for the annotation.
Public Property | ActivationState | Gets or sets the activation state for the annotation.
Public Property | DeactivationMode | Gets or sets the deactivation mode for the annotation.
Public Property | DeactivationState | Gets or sets the deactivation state for the annotation.
Public Property | ShowToolbar | Gets or sets a value indicating whether the toolbar should be displayed when the annotation is activated.
Public Property | ShowUI | Gets or sets a value indicating whether the UI for managing the 3D artwork should be displayed when the annotation is activated.
Top

See Also

Reference

PDF3DActivation Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DActivation Constructor

PDF3DActivation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : PDF3DActivation Constructor

Initializes a new PDF3DActivation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivation()
C#
public PDF3DActivation()
Managed Extensions for C++
public: PDF3DActivation();
C++/CLI
public:
PDF3DActivation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


PDF3DActivation Class Properties

PDF3DActivation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DActivation Class

For a list of all members of this type, see PDF3DActivation members.

Public Properties

 | Name | Description
Public Property | ActivationMode | Gets or sets the activation mode for the annotation.
Public Property | ActivationState | Gets or sets the activation state for the annotation.
Public Property | DeactivationMode | Gets or sets the deactivation mode for the annotation.
Public Property | DeactivationState | Gets or sets the deactivation state for the annotation.
Public Property | ShowToolbar | Gets or sets a value indicating whether the toolbar should be displayed when the annotation is activated.
Public Property | ShowUI | Gets or sets a value indicating whether the UI for managing the 3D artwork should be displayed when the annotation is activated.
Top

See Also

Reference

PDF3DActivation Class
O2S.Components.PDF4NET.Annotations Namespace


ActivationMode Property

ActivationMode Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : ActivationMode Property

Gets or sets the activation mode for the annotation.

Syntax

Visual Basic (Declaration)
Public Property ActivationMode As PDF3DActivationMode
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivation
Dim value As PDF3DActivationMode

instance.ActivationMode = value

value = instance.ActivationMode
C#
public PDF3DActivationMode ActivationMode {get; set;}
Managed Extensions for C++
public: __property PDF3DActivationMode get_ActivationMode();
public: __property void set_ActivationMode(
   PDF3DActivationMode value
);
C++/CLI
public:
property PDF3DActivationMode ActivationMode {
   PDF3DActivationMode get();
   void set (PDF3DActivationMode value);
}

Return Value

A PDF3DActivationMode enumeration member specifying the circumstances under which the annotation should be activated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


ActivationState Property

ActivationState Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : ActivationState Property

Gets or sets the activation state for the annotation.

Syntax

Visual Basic (Declaration)
Public Property ActivationState As PDF3DActivationState
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivation
Dim value As PDF3DActivationState

instance.ActivationState = value

value = instance.ActivationState
C#
public PDF3DActivationState ActivationState {get; set;}
Managed Extensions for C++
public: __property PDF3DActivationState get_ActivationState();
public: __property void set_ActivationState(
   PDF3DActivationState value
);
C++/CLI
public:
property PDF3DActivationState ActivationState {
   PDF3DActivationState get();
   void set (PDF3DActivationState value);
}

Return Value

A PDF3DActivationState enumeration member specifying the state of the artwork instance upon activation of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


DeactivationMode Property

DeactivationMode Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : DeactivationMode Property

Gets or sets the deactivation mode for the annotation.

Syntax

Visual Basic (Declaration)
Public Property DeactivationMode As PDF3DDeactivationMode
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivation
Dim value As PDF3DDeactivationMode

instance.DeactivationMode = value

value = instance.DeactivationMode
C#
public PDF3DDeactivationMode DeactivationMode {get; set;}
Managed Extensions for C++
public: __property PDF3DDeactivationMode get_DeactivationMode();
public: __property void set_DeactivationMode(
   PDF3DDeactivationMode value
);
C++/CLI
public:
property PDF3DDeactivationMode DeactivationMode {
   PDF3DDeactivationMode get();
   void set (PDF3DDeactivationMode value);
}

Return Value

A PDF3DDeactivationMode enumeration member specifying the circumstances under which the annotation should be deactivated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


DeactivationState Property

DeactivationState Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : DeactivationState Property

Gets or sets the deactivation state for the annotation.

Syntax

Visual Basic (Declaration)
Public Property DeactivationState As PDF3DDeactivationState
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivation
Dim value As PDF3DDeactivationState

instance.DeactivationState = value

value = instance.DeactivationState
C#
public PDF3DDeactivationState DeactivationState {get; set;}
Managed Extensions for C++
public: __property PDF3DDeactivationState get_DeactivationState();
public: __property void set_DeactivationState(
   PDF3DDeactivationState value
);
C++/CLI
public:
property PDF3DDeactivationState DeactivationState {
   PDF3DDeactivationState get();
   void set (PDF3DDeactivationState value);
}

Return Value

A PDF3DDeactivationState enumeration member specifying the state of the artwork instance upon deactivation of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


ShowToolbar Property

ShowToolbar Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : ShowToolbar Property

Gets or sets a value indicating whether the toolbar should be displayed when the annotation is activated.

Syntax

Visual Basic (Declaration)
Public Property ShowToolbar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivation
Dim value As Boolean

instance.ShowToolbar = value

value = instance.ShowToolbar
C#
public bool ShowToolbar {get; set;}
Managed Extensions for C++
public: __property bool get_ShowToolbar();
public: __property void set_ShowToolbar(
   bool value
);
C++/CLI
public:
property bool ShowToolbar {
   bool get();
   void set (bool value);
}

Return Value

If true, a toolbar should be displayed by default when the annotation is activated and given focus. If false, a toolbar should not be displayed by default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


ShowUI Property

ShowUI Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DActivation Class : ShowUI Property

Gets or sets a value indicating whether the UI for managing the 3D artwork should be displayed when the annotation is activated.

Syntax

Visual Basic (Declaration)
Public Property ShowUI As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivation
Dim value As Boolean

instance.ShowUI = value

value = instance.ShowUI
C#
public bool ShowUI {get; set;}
Managed Extensions for C++
public: __property bool get_ShowUI();
public: __property void set_ShowUI(
   bool value
);
C++/CLI
public:
property bool ShowUI {
   bool get();
   void set (bool value);
}

Return Value

If true, the user interface should be made visible when the annotation is activated. If false, the user interface should not be made visible by default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DActivation Class
PDF3DActivation Members


PDF3DAnimation Class

PDF3DAnimation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnimation Class

Defines the lighting to apply to 3D artwork.

Syntax

Visual Basic (Declaration)
Public Class PDF3DAnimation
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnimation
C#
public class PDF3DAnimation : PDF3DEntity
Managed Extensions for C++
public __gc class PDF3DAnimation : public PDF3DEntity
C++/CLI
public ref class PDF3DAnimation : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DAnimation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnimation Members
O2S.Components.PDF4NET.Annotations Namespace


PDF3DAnimation Class Members

PDF3DAnimation Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnimation Class

The following tables list the members exposed by PDF3DAnimation.

Public Constructors

 | Name | Description
Public Constructor | PDF3DAnimation Constructor | Overloaded. Initializes a new PDF3DAnimation object.
Top

Public Properties

 | Name | Description
Public Property | PlayCount | Gets or sets the play count.
Public Property | TimeMultiplier | Gets or sets the time multiplier for the animation.
Public Property | Type | Gets or sets the animation type.
Top

See Also

Reference

PDF3DAnimation Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DAnimation Constructor

PDF3DAnimation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class : PDF3DAnimation Constructor

Initializes a new PDF3DAnimation object.

Overload List

Overload | Description
PDF3DAnimation Constructor() | Initializes a new PDF3DAnimation object.
PDF3DAnimation Constructor(PDF3DAnimationType) | Initializes a new PDF3DAnimation object with a new type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members


PDF3DAnimation Constructor()

PDF3DAnimation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class > PDF3DAnimation Constructor : PDF3DAnimation Constructor()

Initializes a new PDF3DAnimation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnimation()
C#
public PDF3DAnimation()
Managed Extensions for C++
public: PDF3DAnimation();
C++/CLI
public:
PDF3DAnimation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members
Overload List


PDF3DAnimation Constructor(PDF3DAnimationType)

PDF3DAnimation Constructor(PDF3DAnimationType)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class > PDF3DAnimation Constructor : PDF3DAnimation Constructor(PDF3DAnimationType)

type
Initializes a new PDF3DAnimation object with a new type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As PDF3DAnimationType _
)
Visual Basic (Usage) Copy Code
Dim type As PDF3DAnimationType

Dim instance As PDF3DAnimation(type)
C#
public PDF3DAnimation(
   PDF3DAnimationType type
)
Managed Extensions for C++
public: PDF3DAnimation(
   PDF3DAnimationType type
)
C++/CLI
public:
PDF3DAnimation(
   PDF3DAnimationType type
)

Parameters

type

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members
Overload List


PDF3DAnimation Class Properties

PDF3DAnimation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnimation Class

For a list of all members of this type, see PDF3DAnimation members.

Public Properties

 | Name | Description
Public Property | PlayCount | Gets or sets the play count.
Public Property | TimeMultiplier | Gets or sets the time multiplier for the animation.
Public Property | Type | Gets or sets the animation type.
Top

See Also

Reference

PDF3DAnimation Class
O2S.Components.PDF4NET.Annotations Namespace


PlayCount Property

PlayCount Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class : PlayCount Property

Gets or sets the play count.

Syntax

Visual Basic (Declaration)
Public Property PlayCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnimation
Dim value As Integer

instance.PlayCount = value

value = instance.PlayCount
C#
public int PlayCount {get; set;}
Managed Extensions for C++
public: __property int get_PlayCount();
public: __property void set_PlayCount(
   int value
);
C++/CLI
public:
property int PlayCount {
   int get();
   void set (int value);
}

Return Value

An integer specifying the play count for this animation.

Remarks

A non-negative integer represents the number of times the animation is played. A negative integer indicates that the animation is infinitely repeated. This value is ignored for animation types of PDF3DAnimationType.None.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members


TimeMultiplier Property

TimeMultiplier Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class : TimeMultiplier Property

Gets or sets the time multiplier for the animation.

Syntax

Visual Basic (Declaration)
Public Property TimeMultiplier As Double
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnimation
Dim value As Double

instance.TimeMultiplier = value

value = instance.TimeMultiplier
C#
public double TimeMultiplier {get; set;}
Managed Extensions for C++
public: __property double get_TimeMultiplier();
public: __property void set_TimeMultiplier(
   double value
);
C++/CLI
public:
property double TimeMultiplier {
   double get();
   void set (double value);
}

Return Value

A positive number specifying the time multiplier to be used when running the animation.

Remarks

A value greater than one shortens the time it takes to play the animation, or effectively speeds up the animation. This value is ignored for animation types of PDF3DAnimationType.None.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members


Type Property

Type Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnimation Class : Type Property

Gets or sets the animation type.

Syntax

Visual Basic (Declaration)
Public Property Type As PDF3DAnimationType
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnimation
Dim value As PDF3DAnimationType

instance.Type = value

value = instance.Type
C#
public PDF3DAnimationType Type {get; set;}
Managed Extensions for C++
public: __property PDF3DAnimationType get_Type();
public: __property void set_Type(
   PDF3DAnimationType value
);
C++/CLI
public:
property PDF3DAnimationType Type {
   PDF3DAnimationType get();
   void set (PDF3DAnimationType value);
}

Return Value

A PDF3DAnimationType enumeration member specifying the animation type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnimation Class
PDF3DAnimation Members


PDF3DAnnotation Class

PDF3DAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnnotation Class

Defines a 3D annotation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDF3DAnnotation
   Inherits PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnnotation
C#
public class PDF3DAnnotation : PDFAnnotation
Managed Extensions for C++
public __gc class PDF3DAnnotation : public PDFAnnotation
C++/CLI
public ref class PDF3DAnnotation : public PDFAnnotation

Remarks

3D annotations allow to include 3D artwork in PDF files.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDF3DAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDF3DAnnotation Class Members

PDF3DAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnnotation Class

The following tables list the members exposed by PDF3DAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDF3DAnnotation Constructor | Initializes a new PDF3DAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Activation | Gets or sets the activation options for the annotation.
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Stream | Gets or sets the 3D stream associated with the annotation.
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDF3DAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DAnnotation Constructor

PDF3DAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnnotation Class : PDF3DAnnotation Constructor

Initializes a new PDF3DAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnnotation()
C#
public PDF3DAnnotation()
Managed Extensions for C++
public: PDF3DAnnotation();
C++/CLI
public:
PDF3DAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnnotation Class
PDF3DAnnotation Members


PDF3DAnnotation Class Properties

PDF3DAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnnotation Class

For a list of all members of this type, see PDF3DAnnotation members.

Public Properties

 | Name | Description
Public Property | Activation | Gets or sets the activation options for the annotation.
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Stream | Gets or sets the 3D stream associated with the annotation.
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDF3DAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Activation Property

Activation Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnnotation Class : Activation Property

Gets or sets the activation options for the annotation.

Syntax

Visual Basic (Declaration)
Public Property Activation As PDF3DActivation
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnnotation
Dim value As PDF3DActivation

instance.Activation = value

value = instance.Activation
C#
public PDF3DActivation Activation {get; set;}
Managed Extensions for C++
public: __property PDF3DActivation* get_Activation();
public: __property void set_Activation(
   PDF3DActivation* value
);
C++/CLI
public:
property PDF3DActivation^ Activation {
   PDF3DActivation^ get();
   void set (PDF3DActivation^ value);
}

Return Value

A PDF3DActivation object specifying the activation options for the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnnotation Class
PDF3DAnnotation Members


Appearance Property

Appearance Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnnotation Class : Appearance Property

Gets or sets the annotation appearance.

Syntax

Visual Basic (Declaration)
Overrides Public Property Appearance As PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
C#
public override PDFAnnotationAppearance Appearance {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationAppearance* get_Appearance()override ;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
)override ;
C++/CLI
public:
property PDFAnnotationAppearance^ Appearance override {
   PDFAnnotationAppearance^ get();
   void set (PDFAnnotationAppearance^ value);
}

Return Value

The appearance of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnnotation Class
PDF3DAnnotation Members


Stream Property

Stream Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DAnnotation Class : Stream Property

Gets or sets the 3D stream associated with the annotation.

Syntax

Visual Basic (Declaration)
Public Property Stream As PDF3DStream
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnnotation
Dim value As PDF3DStream

instance.Stream = value

value = instance.Stream
C#
public PDF3DStream Stream {get; set;}
Managed Extensions for C++
public: __property PDF3DStream* get_Stream();
public: __property void set_Stream(
   PDF3DStream* value
);
C++/CLI
public:
property PDF3DStream^ Stream {
   PDF3DStream^ get();
   void set (PDF3DStream^ value);
}

Return Value

A PDF3DStream object specifying the stream containing the 3D artwork.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DAnnotation Class
PDF3DAnnotation Members


PDF3DBackground Class

PDF3DBackground Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DBackground Class

Defines the background appearance for 3D artwork.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDF3DBackground
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DBackground
C#
public class PDF3DBackground : PDF3DEntity
Managed Extensions for C++
public __gc class PDF3DBackground : public PDF3DEntity
C++/CLI
public ref class PDF3DBackground : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DBackground

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DBackground Members
O2S.Components.PDF4NET.Annotations Namespace


PDF3DBackground Class Members

PDF3DBackground Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DBackground Class

The following tables list the members exposed by PDF3DBackground.

Public Constructors

 | Name | Description
Public Constructor | PDF3DBackground Constructor | Overloaded. Initializes a new PDF3DBackground object.
Top

Public Properties

 | Name | Description
Public Property | ApplyToEntireAnnotation | Gets or sets a value indicating how the background is applied.
Public Property | Color | Gets or sets the background color.
Top

See Also

Reference

PDF3DBackground Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DBackground Constructor

PDF3DBackground Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DBackground Class : PDF3DBackground Constructor

Initializes a new PDF3DBackground object.

Overload List

Overload | Description
PDF3DBackground Constructor() | Initializes a new PDF3DBackground object.
PDF3DBackground Constructor(PDFRgbColor) | Initializes a new PDF3DBackground object with a new color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DBackground Class
PDF3DBackground Members


PDF3DBackground Constructor()

PDF3DBackground Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DBackground Class > PDF3DBackground Constructor : PDF3DBackground Constructor()

Initializes a new PDF3DBackground object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DBackground()
C#
public PDF3DBackground()
Managed Extensions for C++
public: PDF3DBackground();
C++/CLI
public:
PDF3DBackground();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DBackground Class
PDF3DBackground Members
Overload List


PDF3DBackground Constructor(PDFRgbColor)

PDF3DBackground Constructor(PDFRgbColor)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DBackground Class > PDF3DBackground Constructor : PDF3DBackground Constructor(PDFRgbColor)

color
The background color.
Initializes a new PDF3DBackground object with a new color.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As PDFRgbColor _
)
Visual Basic (Usage) Copy Code
Dim color As PDFRgbColor

Dim instance As PDF3DBackground(color)
C#
public PDF3DBackground(
   PDFRgbColor color
)
Managed Extensions for C++
public: PDF3DBackground(
   PDFRgbColor* color
)
C++/CLI
public:
PDF3DBackground(
   PDFRgbColor^ color
)

Parameters

color
The background color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DBackground Class
PDF3DBackground Members
Overload List


PDF3DBackground Class Properties

PDF3DBackground Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DBackground Class

For a list of all members of this type, see PDF3DBackground members.

Public Properties

 | Name | Description
Public Property | ApplyToEntireAnnotation | Gets or sets a value indicating how the background is applied.
Public Property | Color | Gets or sets the background color.
Top

See Also

Reference

PDF3DBackground Class
O2S.Components.PDF4NET.Annotations Namespace


ApplyToEntireAnnotation Property

ApplyToEntireAnnotation Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DBackground Class : ApplyToEntireAnnotation Property

Gets or sets a value indicating how the background is applied.

Syntax

Visual Basic (Declaration)
Public Property ApplyToEntireAnnotation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDF3DBackground
Dim value As Boolean

instance.ApplyToEntireAnnotation = value

value = instance.ApplyToEntireAnnotation
C#
public bool ApplyToEntireAnnotation {get; set;}
Managed Extensions for C++
public: __property bool get_ApplyToEntireAnnotation();
public: __property void set_ApplyToEntireAnnotation(
   bool value
);
C++/CLI
public:
property bool ApplyToEntireAnnotation {
   bool get();
   void set (bool value);
}

Return Value

True if the background is applied to entire annotation, false if the background is applied to annotation's 3D view box only.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DBackground Class
PDF3DBackground Members


Color Property

Color Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DBackground Class : Color Property

Gets or sets the background color.

Syntax

Visual Basic (Declaration)
Public Property Color As PDFRgbColor
Visual Basic (Usage) Copy Code
Dim instance As PDF3DBackground
Dim value As PDFRgbColor

instance.Color = value

value = instance.Color
C#
public PDFRgbColor Color {get; set;}
Managed Extensions for C++
public: __property PDFRgbColor* get_Color();
public: __property void set_Color(
   PDFRgbColor* value
);
C++/CLI
public:
property PDFRgbColor^ Color {
   PDFRgbColor^ get();
   void set (PDFRgbColor^ value);
}

Return Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the background color for the 3D artwork.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DBackground Class
PDF3DBackground Members


PDF3DCrossSection Class

PDF3DCrossSection Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSection Class

Defines how a portion of the 3D artwork is clipped for the purpose of showing artwork cross sections.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDF3DCrossSection
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSection
C#
public class PDF3DCrossSection : PDF3DEntity
Managed Extensions for C++
public __gc class PDF3DCrossSection : public PDF3DEntity
C++/CLI
public ref class PDF3DCrossSection : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DCrossSection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSection Members
O2S.Components.PDF4NET.Annotations Namespace


PDF3DCrossSection Class Members

PDF3DCrossSection Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSection Class

The following tables list the members exposed by PDF3DCrossSection.

Public Constructors

 | Name | Description
Public Constructor | PDF3DCrossSection Constructor | Initializes a new PDF3DCrossSection object.
Top

Public Properties

 | Name | Description
Public Property | Center | Gets or sets the center of the cutting plane.
Public Property | Color | Gets or sets the cutting plane color.
Public Property | IntersectionColor | Gets or sets the intersection color.
Public Property | IntersectionIsVisible | Gets or sets a value indicating whether the intersection of cutting plane with 3D artwork is visible.
Public Property | Opacity | Gets or sets the cutting plane opacity.
Public Property | Orientation | Gets or sets the orientation of the cutting plane.
Top

See Also

Reference

PDF3DCrossSection Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DCrossSection Constructor

PDF3DCrossSection Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : PDF3DCrossSection Constructor

Initializes a new PDF3DCrossSection object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSection()
C#
public PDF3DCrossSection()
Managed Extensions for C++
public: PDF3DCrossSection();
C++/CLI
public:
PDF3DCrossSection();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


PDF3DCrossSection Class Properties

PDF3DCrossSection Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSection Class

For a list of all members of this type, see PDF3DCrossSection members.

Public Properties

 | Name | Description
Public Property | Center | Gets or sets the center of the cutting plane.
Public Property | Color | Gets or sets the cutting plane color.
Public Property | IntersectionColor | Gets or sets the intersection color.
Public Property | IntersectionIsVisible | Gets or sets a value indicating whether the intersection of cutting plane with 3D artwork is visible.
Public Property | Opacity | Gets or sets the cutting plane opacity.
Public Property | Orientation | Gets or sets the orientation of the cutting plane.
Top

See Also

Reference

PDF3DCrossSection Class
O2S.Components.PDF4NET.Annotations Namespace


Center Property

Center Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : Center Property

Gets or sets the center of the cutting plane.

Syntax

Visual Basic (Declaration)
Public Property Center As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSection
Dim value() As Double

instance.Center = value

value = instance.Center
C#
public double[] Center {get; set;}
Managed Extensions for C++
public: __property double[]* get_Center();
public: __property void set_Center(
   double[]* value
);
C++/CLI
public:
property array<double>^ Center {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

A three element array specifying the center of rotation on the cutting plane in world space coordinates.

Remarks

If the array has more than 3 elements, only the first 3 will be considered.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


Color Property

Color Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : Color Property

Gets or sets the cutting plane color.

Syntax

Visual Basic (Declaration)
Public Property Color As PDFRgbColor
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSection
Dim value As PDFRgbColor

instance.Color = value

value = instance.Color
C#
public PDFRgbColor Color {get; set;}
Managed Extensions for C++
public: __property PDFRgbColor* get_Color();
public: __property void set_Color(
   PDFRgbColor* value
);
C++/CLI
public:
property PDFRgbColor^ Color {
   PDFRgbColor^ get();
   void set (PDFRgbColor^ value);
}

Return Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the color of the cutting plane.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


IntersectionColor Property

IntersectionColor Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : IntersectionColor Property

Gets or sets the intersection color.

Syntax

Visual Basic (Declaration)
Public Property IntersectionColor As PDFRgbColor
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSection
Dim value As PDFRgbColor

instance.IntersectionColor = value

value = instance.IntersectionColor
C#
public PDFRgbColor IntersectionColor {get; set;}
Managed Extensions for C++
public: __property PDFRgbColor* get_IntersectionColor();
public: __property void set_IntersectionColor(
   PDFRgbColor* value
);
C++/CLI
public:
property PDFRgbColor^ IntersectionColor {
   PDFRgbColor^ get();
   void set (PDFRgbColor^ value);
}

Return Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the color of the the intersection of cutting plane with 3D artwork.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


IntersectionIsVisible Property

IntersectionIsVisible Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : IntersectionIsVisible Property

Gets or sets a value indicating whether the intersection of cutting plane with 3D artwork is visible.

Syntax

Visual Basic (Declaration)
Public Property IntersectionIsVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSection
Dim value As Boolean

instance.IntersectionIsVisible = value

value = instance.IntersectionIsVisible
C#
public bool IntersectionIsVisible {get; set;}
Managed Extensions for C++
public: __property bool get_IntersectionIsVisible();
public: __property void set_IntersectionIsVisible(
   bool value
);
C++/CLI
public:
property bool IntersectionIsVisible {
   bool get();
   void set (bool value);
}

Return Value

True if the intersection of cutting plane with 3D artwork is visible.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


Opacity Property

Opacity Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : Opacity Property

Gets or sets the cutting plane opacity.

Syntax

Visual Basic (Declaration)
Public Property Opacity As Double
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSection
Dim value As Double

instance.Opacity = value

value = instance.Opacity
C#
public double Opacity {get; set;}
Managed Extensions for C++
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
C++/CLI
public:
property double Opacity {
   double get();
   void set (double value);
}

Return Value

A number indicating the opacity of the cutting plane using a standard additive blend mode.

Remarks

The opacity is given in percents, 100 is full opacity, 0 is no opacity.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


Orientation Property

Orientation Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DCrossSection Class : Orientation Property

Gets or sets the orientation of the cutting plane.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Object()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSection
Dim value() As Object

instance.Orientation = value

value = instance.Orientation
C#
public object[] Orientation {get; set;}
Managed Extensions for C++
public: __property Object*[]* get_Orientation();
public: __property void set_Orientation(
   Object*[]* value
);
C++/CLI
public:
property array<Object^>^ Orientation {
   array<Object^>^ get();
   void set (Object^array<value>^ value);
}

Return Value

A three-element array specifying the orientation of the cutting plane in world space, where each value represents the orientation in relation to the X, Y, and Z axes, respectively.

Remarks

If the array has more than 3 elements, only the first 3 will be considered.
Exactly one of the values must be null, indicating an initial state of the cutting plane that is perpendicular to the corresponding axis and clipping all geometry on the positive side of that axis. The other two values must be numbers indicating the rotation of the plane, in degrees, around their corresponding axes. The order in which these rotations are applied should match the order in which the values appear in the array.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSection Class
PDF3DCrossSection Members


PDF3DCrossSectionCollection Class

PDF3DCrossSectionCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSectionCollection Class

Defines a collection of PDF actions.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDF3DCrossSectionCollection
   Inherits Collection(Of PDF3DCrossSection)
Visual Basic (Usage) Copy Code
Dim instance As PDF3DCrossSectionCollection
C#
public class PDF3DCrossSectionCollection : Collection<PDF3DCrossSection>
Managed Extensions for C++
public __gc class PDF3DCrossSectionCollection : public Collection<PDF3DCrossSection>
C++/CLI
public ref class PDF3DCrossSectionCollection : public Collection<PDF3DCrossSection>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<PDF3DCrossSection>
O2S.Components.PDF4NET.Annotations.PDF3DCrossSectionCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DCrossSectionCollection Members
O2S.Components.PDF4NET.Annotations Namespace


PDF3DCrossSectionCollection Class Members

PDF3DCrossSectionCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSectionCollection Class

The following tables list the members exposed by PDF3DCrossSectionCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Top

See Also

Reference

PDF3DCrossSectionCollection Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DEntity Class

PDF3DEntity Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DEntity Class

Defines the base class for all 3D related classes.

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DEntity
C#
public abstract class PDF3DEntity
Managed Extensions for C++
public __gc abstract class PDF3DEntity
C++/CLI
public ref class PDF3DEntity abstract

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DView
O2S.Components.PDF4NET.Annotations.PDF3DStream
O2S.Components.PDF4NET.Annotations.PDF3DRenderMode
O2S.Components.PDF4NET.Annotations.PDF3DProjection
O2S.Components.PDF4NET.Annotations.PDF3DNode
O2S.Components.PDF4NET.Annotations.PDF3DCrossSection
O2S.Components.PDF4NET.Annotations.PDF3DBackground
O2S.Components.PDF4NET.Annotations.PDF3DAnimation
O2S.Components.PDF4NET.Annotations.PDF3DActivation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DEntity Members
O2S.Components.PDF4NET.Annotations Namespace


PDF3DEntity Class Members

PDF3DEntity Class Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DEntity Class

The following tables list the members exposed by PDF3DEntity.

Public Constructors

 | Name | Description
Public Constructor | PDF3DEntity Constructor | Initializes a new PDF3DEntity object.
Top

See Also

Reference

PDF3DEntity Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DEntity Constructor

PDF3DEntity Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DEntity Class : PDF3DEntity Constructor

Initializes a new PDF3DEntity object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DEntity()
C#
public PDF3DEntity()
Managed Extensions for C++
public: PDF3DEntity();
C++/CLI
public:
PDF3DEntity();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DEntity Class
PDF3DEntity Members


PDF3DLightingScheme Class

PDF3DLightingScheme Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DLightingScheme Class

Defines the lighting to apply to 3D artwork.

Syntax

Visual Basic (Declaration)
Public Class PDF3DLightingScheme
Visual Basic (Usage) Copy Code
Dim instance As PDF3DLightingScheme
C#
public class PDF3DLightingScheme
Managed Extensions for C++
public __gc class PDF3DLightingScheme
C++/CLI
public ref class PDF3DLightingScheme

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DLightingScheme

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DLightingScheme Members
O2S.Components.PDF4NET.Annotations Namespace


PDF3DLightingScheme Class Members

PDF3DLightingScheme Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DLightingScheme Class

The following tables list the members exposed by PDF3DLightingScheme.

Public Constructors

 | Name | Description
Public Constructor | PDF3DLightingScheme Constructor | Overloaded. Initializes a new PDF3DLightingScheme object.
Top

Public Properties

 | Name | Description
Public Property | Style | Gets or sets the style for applying light to 3D artwork.
Top

See Also

Reference

PDF3DLightingScheme Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DLightingScheme Constructor

PDF3DLightingScheme Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DLightingScheme Class : PDF3DLightingScheme Constructor

Initializes a new PDF3DLightingScheme object.

Overload List

Overload | Description
PDF3DLightingScheme Constructor() | Initializes a new PDF3DLightingScheme object.
PDF3DLightingScheme Constructor(PDF3DLightingStyle) | Initializes a new PDF3DLightingScheme object with a new lighting style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DLightingScheme Class
PDF3DLightingScheme Members


PDF3DLightingScheme Constructor()

PDF3DLightingScheme Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DLightingScheme Class > PDF3DLightingScheme Constructor : PDF3DLightingScheme Constructor()

Initializes a new PDF3DLightingScheme object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DLightingScheme()
C#
public PDF3DLightingScheme()
Managed Extensions for C++
public: PDF3DLightingScheme();
C++/CLI
public:
PDF3DLightingScheme();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DLightingScheme Class
PDF3DLightingScheme Members
Overload List


PDF3DLightingScheme Constructor(PDF3DLightingStyle)

PDF3DLightingScheme Constructor(PDF3DLightingStyle)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DLightingScheme Class > PDF3DLightingScheme Constructor : PDF3DLightingScheme Constructor(PDF3DLightingStyle)

style
The lighting style.
Initializes a new PDF3DLightingScheme object with a new lighting style.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As PDF3DLightingStyle _
)
Visual Basic (Usage) Copy Code
Dim style As PDF3DLightingStyle

Dim instance As PDF3DLightingScheme(style)
C#
public PDF3DLightingScheme(
   PDF3DLightingStyle style
)
Managed Extensions for C++
public: PDF3DLightingScheme(
   PDF3DLightingStyle style
)
C++/CLI
public:
PDF3DLightingScheme(
   PDF3DLightingStyle style
)

Parameters

style
The lighting style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DLightingScheme Class
PDF3DLightingScheme Members
Overload List


PDF3DLightingScheme Class Properties

PDF3DLightingScheme Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DLightingScheme Class

For a list of all members of this type, see PDF3DLightingScheme members.

Public Properties

 | Name | Description
Public Property | Style | Gets or sets the style for applying light to 3D artwork.
Top

See Also

Reference

PDF3DLightingScheme Class
O2S.Components.PDF4NET.Annotations Namespace


Style Property

Style Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DLightingScheme Class : Style Property

Gets or sets the style for applying light to 3D artwork.

Syntax

Visual Basic (Declaration)
Public Property Style As PDF3DLightingStyle
Visual Basic (Usage) Copy Code
Dim instance As PDF3DLightingScheme
Dim value As PDF3DLightingStyle

instance.Style = value

value = instance.Style
C#
public PDF3DLightingStyle Style {get; set;}
Managed Extensions for C++
public: __property PDF3DLightingStyle get_Style();
public: __property void set_Style(
   PDF3DLightingStyle value
);
C++/CLI
public:
property PDF3DLightingStyle Style {
   PDF3DLightingStyle get();
   void set (PDF3DLightingStyle value);
}

Return Value

A PDF3DLightingStyle enumeration member specifying the style for applying light to 3D artwork.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DLightingScheme Class
PDF3DLightingScheme Members


PDF3DNode Class

PDF3DNode Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DNode Class

Defines particular areas of 3D artwork and the opacity and visibility with which individual nodes are displayed.

Syntax

Visual Basic (Declaration)
Public Class PDF3DNode
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNode
C#
public class PDF3DNode : PDF3DEntity
Managed Extensions for C++
public __gc class PDF3DNode : public PDF3DEntity
C++/CLI
public ref class PDF3DNode : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DNode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNode Members
O2S.Components.PDF4NET.Annotations Namespace


PDF3DNode Class Members

PDF3DNode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DNode Class

The following tables list the members exposed by PDF3DNode.

Public Constructors

 | Name | Description
Public Constructor | PDF3DNode Constructor | Initializes a new PDF3DNode object.
Top

Public Properties

 | Name | Description
Public Property | Matrix | Gets or sets the 3D transformation matrix.
Public Property | Name | Gets or sets the node name.
Public Property | Opacity | Gets or sets the cutting plane opacity.
Public Property | Visible | Gets or sets a value indicating whether the node is visible or not.
Top

See Also

Reference

PDF3DNode Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DNode Constructor

PDF3DNode Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DNode Class : PDF3DNode Constructor

Initializes a new PDF3DNode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNode()
C#
public PDF3DNode()
Managed Extensions for C++
public: PDF3DNode();
C++/CLI
public:
PDF3DNode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNode Class
PDF3DNode Members


PDF3DNode Class Properties

PDF3DNode Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DNode Class

For a list of all members of this type, see PDF3DNode members.

Public Properties

 | Name | Description
Public Property | Matrix | Gets or sets the 3D transformation matrix.
Public Property | Name | Gets or sets the node name.
Public Property | Opacity | Gets or sets the cutting plane opacity.
Public Property | Visible | Gets or sets a value indicating whether the node is visible or not.
Top

See Also

Reference

PDF3DNode Class
O2S.Components.PDF4NET.Annotations Namespace


Matrix Property

Matrix Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DNode Class : Matrix Property

Gets or sets the 3D transformation matrix.

Syntax

Visual Basic (Declaration)
Public Property Matrix As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNode
Dim value() As Double

instance.Matrix = value

value = instance.Matrix
C#
public double[] Matrix {get; set;}
Managed Extensions for C++
public: __property double[]* get_Matrix();
public: __property void set_Matrix(
   double[]* value
);
C++/CLI
public:
property array<double>^ Matrix {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

A 12-element 3D transformation matrix that specifies the position and orientation of this node, relative to its parent, in world coordinates.

Remarks

If the array has more than 12 elements, only the first 12 will be considered.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNode Class
PDF3DNode Members


Name Property

Name Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DNode Class : Name Property

Gets or sets the node name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNode
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Return Value

The name of the 3D node (in the 3D content stream) being described by this object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNode Class
PDF3DNode Members


Opacity Property

Opacity Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DNode Class : Opacity Property

Gets or sets the cutting plane opacity.

Syntax

Visual Basic (Declaration)
Public Property Opacity As Double
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNode
Dim value As Double

instance.Opacity = value

value = instance.Opacity
C#
public double Opacity {get; set;}
Managed Extensions for C++
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
C++/CLI
public:
property double Opacity {
   double get();
   void set (double value);
}

Return Value

A number indicating the opacity of the cutting plane using a standard additive blend mode.

Remarks

The opacity is given in percents, 100 is full opacity, 0 is no opacity.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNode Class
PDF3DNode Members


Visible Property

Visible Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DNode Class : Visible Property

Gets or sets a value indicating whether the node is visible or not.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNode
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}
Managed Extensions for C++
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
C++/CLI
public:
property bool Visible {
   bool get();
   void set (bool value);
}

Return Value

True if the node is visible.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNode Class
PDF3DNode Members


PDF3DNodeCollection Class

PDF3DNodeCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DNodeCollection Class

Defines a collection of PDF actions.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDF3DNodeCollection
   Inherits Collection(Of PDF3DNode)
Visual Basic (Usage) Copy Code
Dim instance As PDF3DNodeCollection
C#
public class PDF3DNodeCollection : Collection<PDF3DNode>
Managed Extensions for C++
public __gc class PDF3DNodeCollection : public Collection<PDF3DNode>
C++/CLI
public ref class PDF3DNodeCollection : public Collection<PDF3DNode>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<PDF3DNode>
O2S.Components.PDF4NET.Annotations.PDF3DNodeCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DNodeCollection Members
O2S.Components.PDF4NET.Annotations Namespace


PDF3DNodeCollection Class Members

PDF3DNodeCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DNodeCollection Class

The following tables list the members exposed by PDF3DNodeCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Top

See Also

Reference

PDF3DNodeCollection Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DProjection Class

PDF3DProjection Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjection Class

Defines the mapping of 3D camera coordinates onto the target coordinate system of the annotation.

Syntax

Visual Basic (Declaration)
Public Class PDF3DProjection
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection
C#
public class PDF3DProjection : PDF3DEntity
Managed Extensions for C++
public __gc class PDF3DProjection : public PDF3DEntity
C++/CLI
public ref class PDF3DProjection : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DProjection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Members
O2S.Components.PDF4NET.Annotations Namespace


PDF3DProjection Class Members

PDF3DProjection Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjection Class

The following tables list the members exposed by PDF3DProjection.

Public Constructors

 | Name | Description
Public Constructor | PDF3DProjection Constructor | Overloaded. Initializes a new PDF3DProjection object.
Top

Public Properties

 | Name | Description
Public Property | ClipStyle | Gets or sets the clipping style for the projection.
Public Property | FarClipDistance | Gets or sets the far clipping distance.
Public Property | FieldOfView | Gets or sets the field of view.
Public Property | NearClipDistance | Gets or sets the near clipping distance.
Public Property | OrthoScaleMode | Gets or sets the scale mode for orthographic projections.
Public Property | Scaling | Gets or sets the projection scaling.
Public Property | Type | Gets or sets the type of the projection.
Top

See Also

Reference

PDF3DProjection Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DProjection Constructor

PDF3DProjection Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : PDF3DProjection Constructor

Initializes a new PDF3DProjection object.

Overload List

Overload | Description
PDF3DProjection Constructor() | Initializes a new PDF3DProjection object.
PDF3DProjection Constructor(PDF3DProjectionType) | Initializes a new PDF3DProjection object with the specified projection type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


PDF3DProjection Constructor()

PDF3DProjection Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class > PDF3DProjection Constructor : PDF3DProjection Constructor()

Initializes a new PDF3DProjection object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection()
C#
public PDF3DProjection()
Managed Extensions for C++
public: PDF3DProjection();
C++/CLI
public:
PDF3DProjection();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members
Overload List


PDF3DProjection Constructor(PDF3DProjectionType)

PDF3DProjection Constructor(PDF3DProjectionType)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class > PDF3DProjection Constructor : PDF3DProjection Constructor(PDF3DProjectionType)

type
The projection with
Initializes a new PDF3DProjection object with the specified projection type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As PDF3DProjectionType _
)
Visual Basic (Usage) Copy Code
Dim type As PDF3DProjectionType

Dim instance As PDF3DProjection(type)
C#
public PDF3DProjection(
   PDF3DProjectionType type
)
Managed Extensions for C++
public: PDF3DProjection(
   PDF3DProjectionType type
)
C++/CLI
public:
PDF3DProjection(
   PDF3DProjectionType type
)

Parameters

type
The projection with

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members
Overload List


PDF3DProjection Class Properties

PDF3DProjection Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjection Class

For a list of all members of this type, see PDF3DProjection members.

Public Properties

 | Name | Description
Public Property | ClipStyle | Gets or sets the clipping style for the projection.
Public Property | FarClipDistance | Gets or sets the far clipping distance.
Public Property | FieldOfView | Gets or sets the field of view.
Public Property | NearClipDistance | Gets or sets the near clipping distance.
Public Property | OrthoScaleMode | Gets or sets the scale mode for orthographic projections.
Public Property | Scaling | Gets or sets the projection scaling.
Public Property | Type | Gets or sets the type of the projection.
Top

See Also

Reference

PDF3DProjection Class
O2S.Components.PDF4NET.Annotations Namespace


ClipStyle Property

ClipStyle Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : ClipStyle Property

Gets or sets the clipping style for the projection.

Syntax

Visual Basic (Declaration)
Public Property ClipStyle As PDF3DProjectionClipStyle
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection
Dim value As PDF3DProjectionClipStyle

instance.ClipStyle = value

value = instance.ClipStyle
C#
public PDF3DProjectionClipStyle ClipStyle {get; set;}
Managed Extensions for C++
public: __property PDF3DProjectionClipStyle get_ClipStyle();
public: __property void set_ClipStyle(
   PDF3DProjectionClipStyle value
);
C++/CLI
public:
property PDF3DProjectionClipStyle ClipStyle {
   PDF3DProjectionClipStyle get();
   void set (PDF3DProjectionClipStyle value);
}

Return Value

A PDF3DProjectionClipStyle enumeration member specifying the clipping style for the projection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


FarClipDistance Property

FarClipDistance Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : FarClipDistance Property

Gets or sets the far clipping distance.

Syntax

Visual Basic (Declaration)
Public Property FarClipDistance As Double
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection
Dim value As Double

instance.FarClipDistance = value

value = instance.FarClipDistance
C#
public double FarClipDistance {get; set;}
Managed Extensions for C++
public: __property double get_FarClipDistance();
public: __property void set_FarClipDistance(
   double value
);
C++/CLI
public:
property double FarClipDistance {
   double get();
   void set (double value);
}

Return Value

The far clipping distance, expressed in the camera coordinate system.

Remarks

This property has meaning only if ClipStyle property is PDF3DProjectionClipStyle.ExplicitNearFar.
A negative value for this property disables the far clipping.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


FieldOfView Property

FieldOfView Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : FieldOfView Property

Gets or sets the field of view.

Syntax

Visual Basic (Declaration)
Public Property FieldOfView As Double
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection
Dim value As Double

instance.FieldOfView = value

value = instance.FieldOfView
C#
public double FieldOfView {get; set;}
Managed Extensions for C++
public: __property double get_FieldOfView();
public: __property void set_FieldOfView(
   double value
);
C++/CLI
public:
property double FieldOfView {
   double get();
   void set (double value);
}

Return Value

A number between 0 and 180, inclusive, specifying the field of view of the virtual camera, in degrees.

Remarks

This property has meaning only if Type is PDF3DProjectionType.Perspective.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


NearClipDistance Property

NearClipDistance Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : NearClipDistance Property

Gets or sets the near clipping distance.

Syntax

Visual Basic (Declaration)
Public Property NearClipDistance As Double
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection
Dim value As Double

instance.NearClipDistance = value

value = instance.NearClipDistance
C#
public double NearClipDistance {get; set;}
Managed Extensions for C++
public: __property double get_NearClipDistance();
public: __property void set_NearClipDistance(
   double value
);
C++/CLI
public:
property double NearClipDistance {
   double get();
   void set (double value);
}

Return Value

The near clipping distance, expressed in the camera coordinate system.

Remarks

This property has meaning only if ClipStyle property is PDF3DProjectionClipStyle.ExplicitNearFar or if Type is PDF3DProjectionType.Perspective.
This property must be non-negative for orthographic projections and greater than 0 for perspective projections.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


OrthoScaleMode Property

OrthoScaleMode Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : OrthoScaleMode Property

Gets or sets the scale mode for orthographic projections.

Syntax

Visual Basic (Declaration)
Public Property OrthoScaleMode As PDF3DProjectionOrthoScaleMode
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection
Dim value As PDF3DProjectionOrthoScaleMode

instance.OrthoScaleMode = value

value = instance.OrthoScaleMode
C#
public PDF3DProjectionOrthoScaleMode OrthoScaleMode {get; set;}
Managed Extensions for C++
public: __property PDF3DProjectionOrthoScaleMode get_OrthoScaleMode();
public: __property void set_OrthoScaleMode(
   PDF3DProjectionOrthoScaleMode value
);
C++/CLI
public:
property PDF3DProjectionOrthoScaleMode OrthoScaleMode {
   PDF3DProjectionOrthoScaleMode get();
   void set (PDF3DProjectionOrthoScaleMode value);
}

Return Value

A PDF3DProjectionOrthoScaleMode enumeration member specifying a strategy for scaling to fit the near plane’s x and y coordinates onto the annotation’s target coordinate system.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


Scaling Property

Scaling Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : Scaling Property

Gets or sets the projection scaling.

Syntax

Visual Basic (Declaration)
Public Property Scaling As Double
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection
Dim value As Double

instance.Scaling = value

value = instance.Scaling
C#
public double Scaling {get; set;}
Managed Extensions for C++
public: __property double get_Scaling();
public: __property void set_Scaling(
   double value
);
C++/CLI
public:
property double Scaling {
   double get();
   void set (double value);
}

Return Value

A positive number that specifies the scaling used when projecting the 3D artwork onto the annotation’s target coordinate system.

Remarks

This property has meaning only if Type is PDF3DProjectionType.Perspective.
A negative value for this property specifies default scaling for the projection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


Type Property

Type Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DProjection Class : Type Property

Gets or sets the type of the projection.

Syntax

Visual Basic (Declaration)
Public Property Type As PDF3DProjectionType
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjection
Dim value As PDF3DProjectionType

instance.Type = value

value = instance.Type
C#
public PDF3DProjectionType Type {get; set;}
Managed Extensions for C++
public: __property PDF3DProjectionType get_Type();
public: __property void set_Type(
   PDF3DProjectionType value
);
C++/CLI
public:
property PDF3DProjectionType Type {
   PDF3DProjectionType get();
   void set (PDF3DProjectionType value);
}

Return Value

A PDF3DProjectionType enumeration member specifying the projection type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DProjection Class
PDF3DProjection Members


PDF3DRenderMode Class

PDF3DRenderMode Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DRenderMode Class

Defines the style in which the 3D artwork is rendered.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDF3DRenderMode
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DRenderMode
C#
public class PDF3DRenderMode : PDF3DEntity
Managed Extensions for C++
public __gc class PDF3DRenderMode : public PDF3DEntity
C++/CLI
public ref class PDF3DRenderMode : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DRenderMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Members
O2S.Components.PDF4NET.Annotations Namespace


PDF3DRenderMode Class Members

PDF3DRenderMode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DRenderMode Class

The following tables list the members exposed by PDF3DRenderMode.

Public Constructors

 | Name | Description
Public Constructor | PDF3DRenderMode Constructor | Overloaded. Initializes a new PDF3DRenderMode object.
Top

Public Properties

 | Name | Description
Public Property | AuxiliaryColor | Gets or sets the auxiliary color.
Public Property | CreaseValue | Gets or sets the crease value.
Public Property | FaceColor | Gets or sets the face color.
Public Property | Opacity | Gets or sets the rendering opacity.
Public Property | Style | Gets or sets the style for rendering the 3D artwork.
Top

See Also

Reference

PDF3DRenderMode Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DRenderMode Constructor

PDF3DRenderMode Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : PDF3DRenderMode Constructor

Initializes a new PDF3DRenderMode object.

Overload List

Overload | Description
PDF3DRenderMode Constructor() | Initializes a new PDF3DRenderMode object.
PDF3DRenderMode Constructor(PDF3DRenderStyle) | Initializes a new PDF3DRenderMode object with a new render style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


PDF3DRenderMode Constructor()

PDF3DRenderMode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class > PDF3DRenderMode Constructor : PDF3DRenderMode Constructor()

Initializes a new PDF3DRenderMode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DRenderMode()
C#
public PDF3DRenderMode()
Managed Extensions for C++
public: PDF3DRenderMode();
C++/CLI
public:
PDF3DRenderMode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members
Overload List


PDF3DRenderMode Constructor(PDF3DRenderStyle)

PDF3DRenderMode Constructor(PDF3DRenderStyle)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class > PDF3DRenderMode Constructor : PDF3DRenderMode Constructor(PDF3DRenderStyle)

style
The rendering style.
Initializes a new PDF3DRenderMode object with a new render style.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal style As PDF3DRenderStyle _
)
Visual Basic (Usage) Copy Code
Dim style As PDF3DRenderStyle

Dim instance As PDF3DRenderMode(style)
C#
public PDF3DRenderMode(
   PDF3DRenderStyle style
)
Managed Extensions for C++
public: PDF3DRenderMode(
   PDF3DRenderStyle style
)
C++/CLI
public:
PDF3DRenderMode(
   PDF3DRenderStyle style
)

Parameters

style
The rendering style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members
Overload List


PDF3DRenderMode Class Properties

PDF3DRenderMode Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DRenderMode Class

For a list of all members of this type, see PDF3DRenderMode members.

Public Properties

 | Name | Description
Public Property | AuxiliaryColor | Gets or sets the auxiliary color.
Public Property | CreaseValue | Gets or sets the crease value.
Public Property | FaceColor | Gets or sets the face color.
Public Property | Opacity | Gets or sets the rendering opacity.
Public Property | Style | Gets or sets the style for rendering the 3D artwork.
Top

See Also

Reference

PDF3DRenderMode Class
O2S.Components.PDF4NET.Annotations Namespace


AuxiliaryColor Property

AuxiliaryColor Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : AuxiliaryColor Property

Gets or sets the auxiliary color.

Syntax

Visual Basic (Declaration)
Public Property AuxiliaryColor As PDFRgbColor
Visual Basic (Usage) Copy Code
Dim instance As PDF3DRenderMode
Dim value As PDFRgbColor

instance.AuxiliaryColor = value

value = instance.AuxiliaryColor
C#
public PDFRgbColor AuxiliaryColor {get; set;}
Managed Extensions for C++
public: __property PDFRgbColor* get_AuxiliaryColor();
public: __property void set_AuxiliaryColor(
   PDFRgbColor* value
);
C++/CLI
public:
property PDFRgbColor^ AuxiliaryColor {
   PDFRgbColor^ get();
   void set (PDFRgbColor^ value);
}

Return Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the auxiliary color to be used when rendering the 3D image.

Remarks

Auxiliary color is used by some of the 3D render styles.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


CreaseValue Property

CreaseValue Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : CreaseValue Property

Gets or sets the crease value.

Syntax

Visual Basic (Declaration)
Public Property CreaseValue As Double
Visual Basic (Usage) Copy Code
Dim instance As PDF3DRenderMode
Dim value As Double

instance.CreaseValue = value

value = instance.CreaseValue
C#
public double CreaseValue {get; set;}
Managed Extensions for C++
public: __property double get_CreaseValue();
public: __property void set_CreaseValue(
   double value
);
C++/CLI
public:
property double CreaseValue {
   double get();
   void set (double value);
}

Return Value

A number specifying the angle to be used as the crease value to be used when determining silhouette edges.

Remarks

The crease value is specified in degrees, from 0 to 360.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


FaceColor Property

FaceColor Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : FaceColor Property

Gets or sets the face color.

Syntax

Visual Basic (Declaration)
Public Property FaceColor As PDFRgbColor
Visual Basic (Usage) Copy Code
Dim instance As PDF3DRenderMode
Dim value As PDFRgbColor

instance.FaceColor = value

value = instance.FaceColor
C#
public PDFRgbColor FaceColor {get; set;}
Managed Extensions for C++
public: __property PDFRgbColor* get_FaceColor();
public: __property void set_FaceColor(
   PDFRgbColor* value
);
C++/CLI
public:
property PDFRgbColor^ FaceColor {
   PDFRgbColor^ get();
   void set (PDFRgbColor^ value);
}

Return Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the face color to be used when rendering the 3D image.

Remarks

Face color is used only by Illustration render style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


Opacity Property

Opacity Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : Opacity Property

Gets or sets the rendering opacity.

Syntax

Visual Basic (Declaration)
Public Property Opacity As Double
Visual Basic (Usage) Copy Code
Dim instance As PDF3DRenderMode
Dim value As Double

instance.Opacity = value

value = instance.Opacity
C#
public double Opacity {get; set;}
Managed Extensions for C++
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
C++/CLI
public:
property double Opacity {
   double get();
   void set (double value);
}

Return Value

A number specifying the opacity of the added transparency applied by some render modes.

Remarks

The opacity is given in percents, 100 is full opacity, 0 is no opacity.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


Style Property

Style Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DRenderMode Class : Style Property

Gets or sets the style for rendering the 3D artwork.

Syntax

Visual Basic (Declaration)
Public Property Style As PDF3DRenderStyle
Visual Basic (Usage) Copy Code
Dim instance As PDF3DRenderMode
Dim value As PDF3DRenderStyle

instance.Style = value

value = instance.Style
C#
public PDF3DRenderStyle Style {get; set;}
Managed Extensions for C++
public: __property PDF3DRenderStyle get_Style();
public: __property void set_Style(
   PDF3DRenderStyle value
);
C++/CLI
public:
property PDF3DRenderStyle Style {
   PDF3DRenderStyle get();
   void set (PDF3DRenderStyle value);
}

Return Value

A PDF3DRenderStyle enumeration member specifying the style for rendering the 3D artwork.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DRenderMode Class
PDF3DRenderMode Members


PDF3DStream Class

PDF3DStream Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DStream Class

Defines the stream that contains the 3D artwork.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDF3DStream
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DStream
C#
public class PDF3DStream : PDF3DEntity
Managed Extensions for C++
public __gc class PDF3DStream : public PDF3DEntity
C++/CLI
public ref class PDF3DStream : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DStream

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DStream Members
O2S.Components.PDF4NET.Annotations Namespace


PDF3DStream Class Members

PDF3DStream Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DStream Class

The following tables list the members exposed by PDF3DStream.

Public Constructors

 | Name | Description
Public Constructor | PDF3DStream Constructor | Initializes a new PDF3DStream object.
Top

Public Properties

 | Name | Description
Public Property | Animation | Gets or sets the animation for this 3D artwork.
Public Property | Content | Gets or sets content of this stream.
Public Property | DefaultView | Gets or sets the default view.
Public Property | OnInstantiate | Gets or sets the code to execute when the 3D artwork is instantiated.
Public Property | Views | Gets the list of views for this 3D artwork.
Top

See Also

Reference

PDF3DStream Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DStream Constructor

PDF3DStream Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : PDF3DStream Constructor

Initializes a new PDF3DStream object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DStream()
C#
public PDF3DStream()
Managed Extensions for C++
public: PDF3DStream();
C++/CLI
public:
PDF3DStream();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DStream Class
PDF3DStream Members


PDF3DStream Class Properties

PDF3DStream Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DStream Class

For a list of all members of this type, see PDF3DStream members.

Public Properties

 | Name | Description
Public Property | Animation | Gets or sets the animation for this 3D artwork.
Public Property | Content | Gets or sets content of this stream.
Public Property | DefaultView | Gets or sets the default view.
Public Property | OnInstantiate | Gets or sets the code to execute when the 3D artwork is instantiated.
Public Property | Views | Gets the list of views for this 3D artwork.
Top

See Also

Reference

PDF3DStream Class
O2S.Components.PDF4NET.Annotations Namespace


Animation Property

Animation Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : Animation Property

Gets or sets the animation for this 3D artwork.

Syntax

Visual Basic (Declaration)
Public Property Animation As PDF3DAnimation
Visual Basic (Usage) Copy Code
Dim instance As PDF3DStream
Dim value As PDF3DAnimation

instance.Animation = value

value = instance.Animation
C#
public PDF3DAnimation Animation {get; set;}
Managed Extensions for C++
public: __property PDF3DAnimation* get_Animation();
public: __property void set_Animation(
   PDF3DAnimation* value
);
C++/CLI
public:
property PDF3DAnimation^ Animation {
   PDF3DAnimation^ get();
   void set (PDF3DAnimation^ value);
}

Return Value

A PDF3DAnimation object that defines the preferred method that viewer applications should use to drive keyframe animations present in this artwork.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DStream Class
PDF3DStream Members


Content Property

Content Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : Content Property

Gets or sets content of this stream.

Syntax

Visual Basic (Declaration)
Public Property Content As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DStream
Dim value() As Byte

instance.Content = value

value = instance.Content
C#
public byte[] Content {get; set;}
Managed Extensions for C++
public: __property byte[]* get_Content();
public: __property void set_Content(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ Content {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array that contains the 3D artwork in U3D format.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DStream Class
PDF3DStream Members


DefaultView Property

DefaultView Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : DefaultView Property

Gets or sets the default view.

Syntax

Visual Basic (Declaration)
Public Property DefaultView As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF3DStream
Dim value As Integer

instance.DefaultView = value

value = instance.DefaultView
C#
public int DefaultView {get; set;}
Managed Extensions for C++
public: __property int get_DefaultView();
public: __property void set_DefaultView(
   int value
);
C++/CLI
public:
property int DefaultView {
   int get();
   void set (int value);
}

Return Value

Index in Views collection.

Remarks

If there are no views, this value is ignored. If the value is outside of the valid range, the first view is considered to be default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DStream Class
PDF3DStream Members


OnInstantiate Property

OnInstantiate Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : OnInstantiate Property

Gets or sets the code to execute when the 3D artwork is instantiated.

Syntax

Visual Basic (Declaration)
Public Property OnInstantiate As PDFJavaScript
Visual Basic (Usage) Copy Code
Dim instance As PDF3DStream
Dim value As PDFJavaScript

instance.OnInstantiate = value

value = instance.OnInstantiate
C#
public PDFJavaScript OnInstantiate {get; set;}
Managed Extensions for C++
public: __property PDFJavaScript* get_OnInstantiate();
public: __property void set_OnInstantiate(
   PDFJavaScript* value
);
C++/CLI
public:
property PDFJavaScript^ OnInstantiate {
   PDFJavaScript^ get();
   void set (PDFJavaScript^ value);
}

Return Value

Javascript code to be executed when the 3D artwork is instantiated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DStream Class
PDF3DStream Members


Views Property

Views Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DStream Class : Views Property

Gets the list of views for this 3D artwork.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Views As PDF3DViewCollection
Visual Basic (Usage) Copy Code
Dim instance As PDF3DStream
Dim value As PDF3DViewCollection

value = instance.Views
C#
public PDF3DViewCollection Views {get;}
Managed Extensions for C++
public: __property PDF3DViewCollection* get_Views();
C++/CLI
public:
property PDF3DViewCollection^ Views {
   PDF3DViewCollection^ get();
}

Return Value

A list of PDF3DViews objects available for this 3D artwork.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DStream Class
PDF3DStream Members


PDF3DView Class

PDF3DView Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DView Class

Defines the parameters to be applied to the virtual camera associated with a 3D annotation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDF3DView
   Inherits PDF3DEntity
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
C#
public class PDF3DView : PDF3DEntity
Managed Extensions for C++
public __gc class PDF3DView : public PDF3DEntity
C++/CLI
public ref class PDF3DView : public PDF3DEntity

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDF3DEntity
O2S.Components.PDF4NET.Annotations.PDF3DView

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Members
O2S.Components.PDF4NET.Annotations Namespace


PDF3DView Class Members

PDF3DView Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DView Class

The following tables list the members exposed by PDF3DView.

Public Constructors

 | Name | Description
Public Constructor | PDF3DView Constructor | Initializes a new PDF3DView object.
Top

Public Properties

 | Name | Description
Public Property | Background | Gets or sets the background for this view.
Public Property | CameraToWorldMatrix | Gets or sets the 3D transformation matrix.
Public Property | CenterOfOrbit | Gets or sets the center of orbit for 3D artwork.
Public Property | CrossSections | Gets the list of cross sections for this view.
Public Property | ExternalName | Gets or sets the view's external name.
Public Property | InternalName | Gets or sets the view's internal name.
Public Property | LightingScheme | Gets or sets the rendering mode for this view.
Public Property | Nodes | Gets the list of 3D nodes for this view.
Public Property | Projection | Gets or sets the projection for this view.
Public Property | RenderMode | Gets or sets the rendering mode for this view.
Public Property | ResetNodesState | Gets or sets a value indicating whether nodes specified in the Nodes collection are returned to their original states (as specified in the 3D artwork) before applying transformation matrices and opacity settings specified in the node dictionaries.
Public Property | ViewNodeName | Gets or sets the name of the view node.
Top

See Also

Reference

PDF3DView Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DView Constructor

PDF3DView Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : PDF3DView Constructor

Initializes a new PDF3DView object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView()
C#
public PDF3DView()
Managed Extensions for C++
public: PDF3DView();
C++/CLI
public:
PDF3DView();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


PDF3DView Class Properties

PDF3DView Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DView Class

For a list of all members of this type, see PDF3DView members.

Public Properties

 | Name | Description
Public Property | Background | Gets or sets the background for this view.
Public Property | CameraToWorldMatrix | Gets or sets the 3D transformation matrix.
Public Property | CenterOfOrbit | Gets or sets the center of orbit for 3D artwork.
Public Property | CrossSections | Gets the list of cross sections for this view.
Public Property | ExternalName | Gets or sets the view's external name.
Public Property | InternalName | Gets or sets the view's internal name.
Public Property | LightingScheme | Gets or sets the rendering mode for this view.
Public Property | Nodes | Gets the list of 3D nodes for this view.
Public Property | Projection | Gets or sets the projection for this view.
Public Property | RenderMode | Gets or sets the rendering mode for this view.
Public Property | ResetNodesState | Gets or sets a value indicating whether nodes specified in the Nodes collection are returned to their original states (as specified in the 3D artwork) before applying transformation matrices and opacity settings specified in the node dictionaries.
Public Property | ViewNodeName | Gets or sets the name of the view node.
Top

See Also

Reference

PDF3DView Class
O2S.Components.PDF4NET.Annotations Namespace


Background Property

Background Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : Background Property

Gets or sets the background for this view.

Syntax

Visual Basic (Declaration)
Public Property Background As PDF3DBackground
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As PDF3DBackground

instance.Background = value

value = instance.Background
C#
public PDF3DBackground Background {get; set;}
Managed Extensions for C++
public: __property PDF3DBackground* get_Background();
public: __property void set_Background(
   PDF3DBackground* value
);
C++/CLI
public:
property PDF3DBackground^ Background {
   PDF3DBackground^ get();
   void set (PDF3DBackground^ value);
}

Return Value

A PDF3DBackground object that defines the background over which the 3D artwork is to be drawn.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


CameraToWorldMatrix Property

CameraToWorldMatrix Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : CameraToWorldMatrix Property

Gets or sets the 3D transformation matrix.

Syntax

Visual Basic (Declaration)
Public Property CameraToWorldMatrix As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value() As Double

instance.CameraToWorldMatrix = value

value = instance.CameraToWorldMatrix
C#
public double[] CameraToWorldMatrix {get; set;}
Managed Extensions for C++
public: __property double[]* get_CameraToWorldMatrix();
public: __property void set_CameraToWorldMatrix(
   double[]* value
);
C++/CLI
public:
property array<double>^ CameraToWorldMatrix {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

A 12-element 3D transformation matrix that specifies a position and orientation of the camera in world coordinates.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


CenterOfOrbit Property

CenterOfOrbit Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : CenterOfOrbit Property

Gets or sets the center of orbit for 3D artwork.

Syntax

Visual Basic (Declaration)
Public Property CenterOfOrbit As Double
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As Double

instance.CenterOfOrbit = value

value = instance.CenterOfOrbit
C#
public double CenterOfOrbit {get; set;}
Managed Extensions for C++
public: __property double get_CenterOfOrbit();
public: __property void set_CenterOfOrbit(
   double value
);
C++/CLI
public:
property double CenterOfOrbit {
   double get();
   void set (double value);
}

Return Value

A non-negative number indicating a distance in the camera coordinate system along the z axis to the center of orbit for this view.

Remarks

If this value is negative, the viewer application must determine the center of orbit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


CrossSections Property

CrossSections Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : CrossSections Property

Gets the list of cross sections for this view.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CrossSections As PDF3DCrossSectionCollection
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As PDF3DCrossSectionCollection

value = instance.CrossSections
C#
public PDF3DCrossSectionCollection CrossSections {get;}
Managed Extensions for C++
public: __property PDF3DCrossSectionCollection* get_CrossSections();
C++/CLI
public:
property PDF3DCrossSectionCollection^ CrossSections {
   PDF3DCrossSectionCollection^ get();
}

Return Value

A list of PDF3DCrossSection objects available for this view.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


ExternalName Property

ExternalName Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : ExternalName Property

Gets or sets the view's external name.

Syntax

Visual Basic (Declaration)
Public Property ExternalName As String
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As String

instance.ExternalName = value

value = instance.ExternalName
C#
public string ExternalName {get; set;}
Managed Extensions for C++
public: __property string* get_ExternalName();
public: __property void set_ExternalName(
   string* value
);
C++/CLI
public:
property String^ ExternalName {
   String^ get();
   void set (String^ value);
}

Return Value

The external name of the view, suitable for presentation in a user interface.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


InternalName Property

InternalName Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : InternalName Property

Gets or sets the view's internal name.

Syntax

Visual Basic (Declaration)
Public Property InternalName As String
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As String

instance.InternalName = value

value = instance.InternalName
C#
public string InternalName {get; set;}
Managed Extensions for C++
public: __property string* get_InternalName();
public: __property void set_InternalName(
   string* value
);
C++/CLI
public:
property String^ InternalName {
   String^ get();
   void set (String^ value);
}

Return Value

The internal name of the view, used to refer to the view from other objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


LightingScheme Property

LightingScheme Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : LightingScheme Property

Gets or sets the rendering mode for this view.

Syntax

Visual Basic (Declaration)
Public Property LightingScheme As PDF3DLightingScheme
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As PDF3DLightingScheme

instance.LightingScheme = value

value = instance.LightingScheme
C#
public PDF3DLightingScheme LightingScheme {get; set;}
Managed Extensions for C++
public: __property PDF3DLightingScheme* get_LightingScheme();
public: __property void set_LightingScheme(
   PDF3DLightingScheme* value
);
C++/CLI
public:
property PDF3DLightingScheme^ LightingScheme {
   PDF3DLightingScheme^ get();
   void set (PDF3DLightingScheme^ value);
}

Return Value

A PDF3DLightingScheme object that specifies the lighting scheme to be used when rendering 3D artwork with this view.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


Nodes Property

Nodes Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : Nodes Property

Gets the list of 3D nodes for this view.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Nodes As PDF3DNodeCollection
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As PDF3DNodeCollection

value = instance.Nodes
C#
public PDF3DNodeCollection Nodes {get;}
Managed Extensions for C++
public: __property PDF3DNodeCollection* get_Nodes();
C++/CLI
public:
property PDF3DNodeCollection^ Nodes {
   PDF3DNodeCollection^ get();
}

Return Value

A list of PDF3DNode objects available for this view.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


Projection Property

Projection Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : Projection Property

Gets or sets the projection for this view.

Syntax

Visual Basic (Declaration)
Public Property Projection As PDF3DProjection
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As PDF3DProjection

instance.Projection = value

value = instance.Projection
C#
public PDF3DProjection Projection {get; set;}
Managed Extensions for C++
public: __property PDF3DProjection* get_Projection();
public: __property void set_Projection(
   PDF3DProjection* value
);
C++/CLI
public:
property PDF3DProjection^ Projection {
   PDF3DProjection^ get();
   void set (PDF3DProjection^ value);
}

Return Value

A PDF3DProjection object that defines the projection of coordinates in the 3D artwork (already transformed into camera coordinates) onto the target coordinate system of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


RenderMode Property

RenderMode Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : RenderMode Property

Gets or sets the rendering mode for this view.

Syntax

Visual Basic (Declaration)
Public Property RenderMode As PDF3DRenderMode
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As PDF3DRenderMode

instance.RenderMode = value

value = instance.RenderMode
C#
public PDF3DRenderMode RenderMode {get; set;}
Managed Extensions for C++
public: __property PDF3DRenderMode* get_RenderMode();
public: __property void set_RenderMode(
   PDF3DRenderMode* value
);
C++/CLI
public:
property PDF3DRenderMode^ RenderMode {
   PDF3DRenderMode^ get();
   void set (PDF3DRenderMode^ value);
}

Return Value

A PDF3DRenderMode object that specifies the render mode to use when rendering 3D artwork with this view.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


ResetNodesState Property

ResetNodesState Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : ResetNodesState Property

Gets or sets a value indicating whether nodes specified in the Nodes collection are returned to their original states (as specified in the 3D artwork) before applying transformation matrices and opacity settings specified in the node dictionaries.

Syntax

Visual Basic (Declaration)
Public Property ResetNodesState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As Boolean

instance.ResetNodesState = value

value = instance.ResetNodesState
C#
public bool ResetNodesState {get; set;}
Managed Extensions for C++
public: __property bool get_ResetNodesState();
public: __property void set_ResetNodesState(
   bool value
);
C++/CLI
public:
property bool ResetNodesState {
   bool get();
   void set (bool value);
}

Return Value

True if the artwork’s 3D node parameters are restored to their original states and then the dictionaries specified by the Nodes collection are applied.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


ViewNodeName Property

ViewNodeName Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDF3DView Class : ViewNodeName Property

Gets or sets the name of the view node.

Syntax

Visual Basic (Declaration)
Public Property ViewNodeName As String
Visual Basic (Usage) Copy Code
Dim instance As PDF3DView
Dim value As String

instance.ViewNodeName = value

value = instance.ViewNodeName
C#
public string ViewNodeName {get; set;}
Managed Extensions for C++
public: __property string* get_ViewNodeName();
public: __property void set_ViewNodeName(
   string* value
);
C++/CLI
public:
property String^ ViewNodeName {
   String^ get();
   void set (String^ value);
}

Return Value

The name of a view node in the 3D content stream.

Remarks

The view node in the content stream defines all the properties for viewing the 3D artwork. If both ViewNodeName and CameraToWorldMatrix are specified, then ViewNodeName takes precedence.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DView Class
PDF3DView Members


PDF3DViewCollection Class

PDF3DViewCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DViewCollection Class

Defines a collection of PDF actions.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDF3DViewCollection
   Inherits Collection(Of PDF3DView)
Visual Basic (Usage) Copy Code
Dim instance As PDF3DViewCollection
C#
public class PDF3DViewCollection : Collection<PDF3DView>
Managed Extensions for C++
public __gc class PDF3DViewCollection : public Collection<PDF3DView>
C++/CLI
public ref class PDF3DViewCollection : public Collection<PDF3DView>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<PDF3DView>
O2S.Components.PDF4NET.Annotations.PDF3DViewCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF3DViewCollection Members
O2S.Components.PDF4NET.Annotations Namespace


PDF3DViewCollection Class Members

PDF3DViewCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DViewCollection Class

The following tables list the members exposed by PDF3DViewCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Top

See Also

Reference

PDF3DViewCollection Class
O2S.Components.PDF4NET.Annotations Namespace


PDFAnnotation Class

PDFAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotation Class

Defines the base class for all annotations available in a PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
C#
public class PDFAnnotation
Managed Extensions for C++
public __gc class PDFAnnotation
C++/CLI
public ref class PDFAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Annotations.PDFMovieAnnotation
O2S.Components.PDF4NET.Annotations.PDFMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFLinkAnnotation
O2S.Components.PDF4NET.Annotations.PDFFreeTextAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDF3DAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFAnnotation Class Members

PDFAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotation Class

The following tables list the members exposed by PDFAnnotation.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance.
Public Property | Color | Gets or sets the annotation color.
Public Property | Contents | Gets or sets the annotation contents.
Public Property | CreationDate | Gets or sets the annotation creation date.
Public Property | Dictionary | Gets the annotation dictionary.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object.
Public Property | Flags | Gets or sets the annotation flags.
Public Property | ModifiedDate | Gets or sets the annotation modified date.
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle.
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle.
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle.
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle.
Public Property | Page | Gets the page that includes this annotation.
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed.
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee.
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened.
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface.
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object.
Public Property | Rotation | Gets or sets the annotation rotation angle.
Public Property | Type | Gets the annotation type.
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation.
Top

See Also

Reference

PDFAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFAnnotation Class Methods

PDFAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotation Class

For a list of all members of this type, see PDFAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation.
Top

See Also

Reference

PDFAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Flatten Method

Flatten Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Flatten Method

Flattens the annotation.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Flatten()
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation

instance.Flatten()
C#
public virtual void Flatten()
Managed Extensions for C++
public: virtual void Flatten();
C++/CLI
public:
virtual void Flatten();

Remarks

This operation writes the annotation appearance to the content and destroys the annotation. Its effects are irreversible. After calling this method the PDFAnnotation object is invalid and should no longer be used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


PDFAnnotation Class Properties

PDFAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotation Class

For a list of all members of this type, see PDFAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance.
Public Property | Color | Gets or sets the annotation color.
Public Property | Contents | Gets or sets the annotation contents.
Public Property | CreationDate | Gets or sets the annotation creation date.
Public Property | Dictionary | Gets the annotation dictionary.
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object.
Public Property | Flags | Gets or sets the annotation flags.
Public Property | ModifiedDate | Gets or sets the annotation modified date.
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle.
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle.
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle.
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle.
Public Property | Page | Gets the page that includes this annotation.
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed.
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee.
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened.
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface.
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object.
Public Property | Rotation | Gets or sets the annotation rotation angle.
Public Property | Type | Gets the annotation type.
Top

See Also

Reference

PDFAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Appearance Property

Appearance Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Appearance Property

Gets or sets the annotation appearance.

Syntax

Visual Basic (Declaration)
Public Overridable Property Appearance As PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
C#
public virtual PDFAnnotationAppearance Appearance {get; set;}
Managed Extensions for C++
public: __property virtual PDFAnnotationAppearance* get_Appearance();
public: __property virtual void set_Appearance(
   PDFAnnotationAppearance* value
);
C++/CLI
public:
virtual property PDFAnnotationAppearance^ Appearance {
   PDFAnnotationAppearance^ get();
   void set (PDFAnnotationAppearance^ value);
}

Return Value

The appearance of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


Color Property

Color Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Color Property

Gets or sets the annotation color.

Syntax

Visual Basic (Declaration)
Public Property Color As PDFDeviceColor
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFDeviceColor

instance.Color = value

value = instance.Color
C#
public PDFDeviceColor Color {get; set;}
Managed Extensions for C++
public: __property PDFDeviceColor* get_Color();
public: __property void set_Color(
   PDFDeviceColor* value
);
C++/CLI
public:
property PDFDeviceColor^ Color {
   PDFDeviceColor^ get();
   void set (PDFDeviceColor^ value);
}

Return Value

The annotation color.

Remarks

The actual usage of this color depends on the annotation type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


Contents Property

Contents Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Contents Property

Gets or sets the annotation contents.

Syntax

Visual Basic (Declaration)
Public Overridable Property Contents As String
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As String

instance.Contents = value

value = instance.Contents
C#
public virtual string Contents {get; set;}
Managed Extensions for C++
public: __property virtual string* get_Contents();
public: __property virtual void set_Contents(
   string* value
);
C++/CLI
public:
virtual property String^ Contents {
   String^ get();
   void set (String^ value);
}

Return Value

The text to be displayed for the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


CreationDate Property

CreationDate Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : CreationDate Property

Gets or sets the annotation creation date.

Syntax

Visual Basic (Declaration)
Public Property CreationDate As Date
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As Date

instance.CreationDate = value

value = instance.CreationDate
C#
public DateTime CreationDate {get; set;}
Managed Extensions for C++
public: __property DateTime get_CreationDate();
public: __property void set_CreationDate(
   DateTime value
);
C++/CLI
public:
property DateTime CreationDate {
   DateTime get();
   void set (DateTime value);
}

Return Value

The date when the annotation was created.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


Dictionary Property

Dictionary Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Dictionary Property

Gets the annotation dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dictionary As PDFDictionary
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFDictionary

value = instance.Dictionary
C#
public PDFDictionary Dictionary {get;}
Managed Extensions for C++
public: __property PDFDictionary* get_Dictionary();
C++/CLI
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Return Value

The raw annotation dictionary.

Remarks

This property gives you direct access to annotation dictionary and its associated resources. Note: Modifying directly the annotation dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


DisplayRectangle Property

DisplayRectangle Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : DisplayRectangle Property

Gets or sets the display rectangle of this annotation object.

Syntax

Visual Basic (Declaration)
Public Property DisplayRectangle As DisplayRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As DisplayRectangle

instance.DisplayRectangle = value

value = instance.DisplayRectangle
C#
public DisplayRectangle DisplayRectangle {get; set;}
Managed Extensions for C++
public: __property DisplayRectangle* get_DisplayRectangle();
public: __property void set_DisplayRectangle(
   DisplayRectangle* value
);
C++/CLI
public:
property DisplayRectangle^ DisplayRectangle {
   DisplayRectangle^ get();
   void set (DisplayRectangle^ value);
}

Return Value

A RectangleF object specifying the position and size of the annotation.

Remarks

The display rectangle is relative to the top left corner of the page, as opposed to PDFRectangle which is relative to bottom left corner of the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


Flags Property

Flags Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Flags Property

Gets or sets the annotation flags.

Syntax

Visual Basic (Declaration)
Public Property Flags As PDFAnnotationFlags
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFAnnotationFlags

instance.Flags = value

value = instance.Flags
C#
public PDFAnnotationFlags Flags {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationFlags get_Flags();
public: __property void set_Flags(
   PDFAnnotationFlags value
);
C++/CLI
public:
property PDFAnnotationFlags Flags {
   PDFAnnotationFlags get();
   void set (PDFAnnotationFlags value);
}

Return Value

Flags the control the annotation behavior.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


ModifiedDate Property

ModifiedDate Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : ModifiedDate Property

Gets or sets the annotation modified date.

Syntax

Visual Basic (Declaration)
Public Property ModifiedDate As Date
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As Date

instance.ModifiedDate = value

value = instance.ModifiedDate
C#
public DateTime ModifiedDate {get; set;}
Managed Extensions for C++
public: __property DateTime get_ModifiedDate();
public: __property void set_ModifiedDate(
   DateTime value
);
C++/CLI
public:
property DateTime ModifiedDate {
   DateTime get();
   void set (DateTime value);
}

Return Value

The most recent date when the annotation was modified.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


MouseDown Property

MouseDown Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : MouseDown Property

Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle.

Syntax

Visual Basic (Declaration)
Public Property MouseDown As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFAction

instance.MouseDown = value

value = instance.MouseDown
C#
public PDFAction MouseDown {get; set;}
Managed Extensions for C++
public: __property PDFAction* get_MouseDown();
public: __property void set_MouseDown(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ MouseDown {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

The action to be executed when the mouse is pressed in the annotation rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


MouseEnter Property

MouseEnter Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : MouseEnter Property

Gets or sets the action that is executed when the mouse enters the annotation rectangle.

Syntax

Visual Basic (Declaration)
Public Property MouseEnter As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFAction

instance.MouseEnter = value

value = instance.MouseEnter
C#
public PDFAction MouseEnter {get; set;}
Managed Extensions for C++
public: __property PDFAction* get_MouseEnter();
public: __property void set_MouseEnter(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ MouseEnter {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

The action to be executed when the mouse enters the annotation rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


MouseLeave Property

MouseLeave Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : MouseLeave Property

Gets or sets the action that is executed when the mouse leaves the annotation rectangle.

Syntax

Visual Basic (Declaration)
Public Property MouseLeave As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFAction

instance.MouseLeave = value

value = instance.MouseLeave
C#
public PDFAction MouseLeave {get; set;}
Managed Extensions for C++
public: __property PDFAction* get_MouseLeave();
public: __property void set_MouseLeave(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ MouseLeave {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

The action to be executed when the mouse leaves the annotation rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


MouseUp Property

MouseUp Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : MouseUp Property

Gets or sets the action that is executed when the mouse is released in the annotation rectangle.

Syntax

Visual Basic (Declaration)
Public Property MouseUp As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFAction

instance.MouseUp = value

value = instance.MouseUp
C#
public PDFAction MouseUp {get; set;}
Managed Extensions for C++
public: __property PDFAction* get_MouseUp();
public: __property void set_MouseUp(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ MouseUp {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

The action to be executed when the mouse is released in the annotation rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


Page Property

Page Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Page Property

Gets the page that includes this annotation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Page As PDFPage
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFPage

value = instance.Page
C#
public PDFPage Page {get;}
Managed Extensions for C++
public: __property PDFPage* get_Page();
C++/CLI
public:
property PDFPage^ Page {
   PDFPage^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


PageClose Property

PageClose Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : PageClose Property

Gets or sets the action to be performed when the page containing the annotation is closed.

Syntax

Visual Basic (Declaration)
Public Property PageClose As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFAction

instance.PageClose = value

value = instance.PageClose
C#
public PDFAction PageClose {get; set;}
Managed Extensions for C++
public: __property PDFAction* get_PageClose();
public: __property void set_PageClose(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ PageClose {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

The action to be performed when the page containing the annotation is closed.

Remarks

This action is executed before the page's Close action has been executed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


PageHide Property

PageHide Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : PageHide Property

Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee.

Syntax

Visual Basic (Declaration)
Public Property PageHide As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFAction

instance.PageHide = value

value = instance.PageHide
C#
public PDFAction PageHide {get; set;}
Managed Extensions for C++
public: __property PDFAction* get_PageHide();
public: __property void set_PageHide(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ PageHide {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

The action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interface.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


PageOpen Property

PageOpen Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : PageOpen Property

Gets or sets the action to be performed when the page containing the annotation is opened.

Syntax

Visual Basic (Declaration)
Public Property PageOpen As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFAction

instance.PageOpen = value

value = instance.PageOpen
C#
public PDFAction PageOpen {get; set;}
Managed Extensions for C++
public: __property PDFAction* get_PageOpen();
public: __property void set_PageOpen(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ PageOpen {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

The action to be performed when the page containing the annotation is opened.

Remarks

This action is executed after the page's Open action has been executed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


PageShow Property

PageShow Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : PageShow Property

Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface.

Syntax

Visual Basic (Declaration)
Public Property PageShow As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFAction

instance.PageShow = value

value = instance.PageShow
C#
public PDFAction PageShow {get; set;}
Managed Extensions for C++
public: __property PDFAction* get_PageShow();
public: __property void set_PageShow(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ PageShow {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

The action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


PDFRectangle Property

PDFRectangle Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : PDFRectangle Property

Gets or sets the annotation rectangle in PDF coordinates.

Syntax

Visual Basic (Declaration)
Public Overridable Property PDFRectangle As PDFRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFRectangle

instance.PDFRectangle = value

value = instance.PDFRectangle
C#
public virtual PDFRectangle PDFRectangle {get; set;}
Managed Extensions for C++
public: __property virtual PDFRectangle* get_PDFRectangle();
public: __property virtual void set_PDFRectangle(
   PDFRectangle* value
);
C++/CLI
public:
virtual property PDFRectangle^ PDFRectangle {
   PDFRectangle^ get();
   void set (PDFRectangle^ value);
}

Return Value

The annotation rectangle specified in the default PDF coordinate system, as opposed to Rectangle which specifies the annotation rectangle relative to top left corner of the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


Rectangle Property

Rectangle Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Rectangle Property

Gets or sets the display rectangle of this annotation object.

Syntax

Visual Basic (Declaration)
Public Property Rectangle As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As RectangleF

instance.Rectangle = value

value = instance.Rectangle
C#
public RectangleF Rectangle {get; set;}
Managed Extensions for C++
public: __property RectangleF get_Rectangle();
public: __property void set_Rectangle(
   RectangleF value
);
C++/CLI
public:
property RectangleF Rectangle {
   RectangleF get();
   void set (RectangleF value);
}

Return Value

A RectangleF object specifying the position and size of the annotation.

Remarks

The display rectangle is relative to the top left corner of the page, as opposed to PDFRectangle which is relative to bottom left corner of the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


Rotation Property

Rotation Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Rotation Property

Gets or sets the annotation rotation angle.

Syntax

Visual Basic (Declaration)
Public Overridable Property Rotation As PDFRotationMode
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFRotationMode

instance.Rotation = value

value = instance.Rotation
C#
public virtual PDFRotationMode Rotation {get; set;}
Managed Extensions for C++
public: __property virtual PDFRotationMode get_Rotation();
public: __property virtual void set_Rotation(
   PDFRotationMode value
);
C++/CLI
public:
virtual property PDFRotationMode Rotation {
   PDFRotationMode get();
   void set (PDFRotationMode value);
}

Return Value

The rotation angle of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


Type Property

Type Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotation Class : Type Property

Gets the annotation type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As PDFAnnotationType
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotation
Dim value As PDFAnnotationType

value = instance.Type
C#
public PDFAnnotationType Type {get;}
Managed Extensions for C++
public: __property PDFAnnotationType get_Type();
C++/CLI
public:
property PDFAnnotationType Type {
   PDFAnnotationType get();
}

Return Value

The annotation type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotation Class
PDFAnnotation Members


PDFAnnotationAppearance Class

PDFAnnotationAppearance Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationAppearance Class

Defines the base class for all annotation appearances.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFAnnotationAppearance
   Inherits PDFFormXObject
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotationAppearance
C#
public class PDFAnnotationAppearance : PDFFormXObject
Managed Extensions for C++
public __gc class PDFAnnotationAppearance : public PDFFormXObject
C++/CLI
public ref class PDFAnnotationAppearance : public PDFFormXObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.Annotations.PDFAnnotationAppearance
O2S.Components.PDF4NET.Annotations.PDFImageAppearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotationAppearance Members
O2S.Components.PDF4NET.Annotations Namespace


PDFAnnotationAppearance Class Members

PDFAnnotationAppearance Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationAppearance Class

The following tables list the members exposed by PDFAnnotationAppearance.

Public Constructors

 | Name | Description
Public Constructor | PDFAnnotationAppearance Constructor | Initializes a new PDFAnnotationAppearance object.
Top

Public Properties

 | Name | Description
Public Property | Canvas | Gets the form XObject canvas. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Height | Gets or sets the height of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Width | Gets or sets the width of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Top

See Also

Reference

PDFAnnotationAppearance Class
O2S.Components.PDF4NET.Annotations Namespace


PDFAnnotationAppearance Constructor

PDFAnnotationAppearance Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationAppearance Class : PDFAnnotationAppearance Constructor

Initializes a new PDFAnnotationAppearance object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotationAppearance()
C#
public PDFAnnotationAppearance()
Managed Extensions for C++
public: PDFAnnotationAppearance();
C++/CLI
public:
PDFAnnotationAppearance();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotationAppearance Class
PDFAnnotationAppearance Members


PDFAnnotationBorder Class

PDFAnnotationBorder Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationBorder Class

Defines the border of an annotation.

Syntax

Visual Basic (Declaration)
Public Class PDFAnnotationBorder
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotationBorder
C#
public class PDFAnnotationBorder
Managed Extensions for C++
public __gc class PDFAnnotationBorder
C++/CLI
public ref class PDFAnnotationBorder

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotationBorder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotationBorder Members
O2S.Components.PDF4NET.Annotations Namespace


PDFAnnotationBorder Class Members

PDFAnnotationBorder Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationBorder Class

The following tables list the members exposed by PDFAnnotationBorder.

Public Constructors

 | Name | Description
Public Constructor | PDFAnnotationBorder Constructor | Overloaded. Initializes a new PDFAnnotationBorder object.
Top

Public Properties

 | Name | Description
Public Property | BorderStyle | Gets or sets the style of annotation's border.
Public Property | Width | Gets or sets the border width.
Top

See Also

Reference

PDFAnnotationBorder Class
O2S.Components.PDF4NET.Annotations Namespace


PDFAnnotationBorder Constructor

PDFAnnotationBorder Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationBorder Class : PDFAnnotationBorder Constructor

Initializes a new PDFAnnotationBorder object.

Overload List

Overload | Description
PDFAnnotationBorder Constructor() | Initializes a new PDFAnnotationBorder object.
PDFAnnotationBorder Constructor(Double,PDFBorderStyle) | Initializes a new PDFAnnotationBorder object with the given width and style.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members


PDFAnnotationBorder Constructor()

PDFAnnotationBorder Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationBorder Class > PDFAnnotationBorder Constructor : PDFAnnotationBorder Constructor()

Initializes a new PDFAnnotationBorder object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotationBorder()
C#
public PDFAnnotationBorder()
Managed Extensions for C++
public: PDFAnnotationBorder();
C++/CLI
public:
PDFAnnotationBorder();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members
Overload List


PDFAnnotationBorder Constructor(Double,PDFBorderStyle)

PDFAnnotationBorder Constructor(Double,PDFBorderStyle)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationBorder Class > PDFAnnotationBorder Constructor : PDFAnnotationBorder Constructor(Double,PDFBorderStyle)

width
the width of annotation's border.
style
the style of annotation's border.
Initializes a new PDFAnnotationBorder object with the given width and style.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Double, _
   ByVal style As PDFBorderStyle _
)
Visual Basic (Usage) Copy Code
Dim width As Double
Dim style As PDFBorderStyle

Dim instance As PDFAnnotationBorder(width, style)
C#
public PDFAnnotationBorder(
   double width,
   PDFBorderStyle style
)
Managed Extensions for C++
public: PDFAnnotationBorder(
   double width,
   PDFBorderStyle style
)
C++/CLI
public:
PDFAnnotationBorder(
   double width,
   PDFBorderStyle style
)

Parameters

width
the width of annotation's border.
style
the style of annotation's border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members
Overload List


PDFAnnotationBorder Class Properties

PDFAnnotationBorder Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationBorder Class

For a list of all members of this type, see PDFAnnotationBorder members.

Public Properties

 | Name | Description
Public Property | BorderStyle | Gets or sets the style of annotation's border.
Public Property | Width | Gets or sets the border width.
Top

See Also

Reference

PDFAnnotationBorder Class
O2S.Components.PDF4NET.Annotations Namespace


BorderStyle Property

BorderStyle Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationBorder Class : BorderStyle Property

Gets or sets the style of annotation's border.

Syntax

Visual Basic (Declaration)
Public Property BorderStyle As PDFBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotationBorder
Dim value As PDFBorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public PDFBorderStyle BorderStyle {get; set;}
Managed Extensions for C++
public: __property PDFBorderStyle get_BorderStyle();
public: __property void set_BorderStyle(
   PDFBorderStyle value
);
C++/CLI
public:
property PDFBorderStyle BorderStyle {
   PDFBorderStyle get();
   void set (PDFBorderStyle value);
}

Return Value

A BorderStyle enumeration member specifying the style of the annotation's border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members


Width Property

Width Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFAnnotationBorder Class : Width Property

Gets or sets the border width.

Syntax

Visual Basic (Declaration)
Public Property Width As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotationBorder
Dim value As Double

instance.Width = value

value = instance.Width
C#
public double Width {get; set;}
Managed Extensions for C++
public: __property double get_Width();
public: __property void set_Width(
   double value
);
C++/CLI
public:
property double Width {
   double get();
   void set (double value);
}

Return Value

The width of the border.

Remarks

0 means no border is displayed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotationBorder Class
PDFAnnotationBorder Members


PDFAnnotationCollection Class

PDFAnnotationCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationCollection Class

Defines a collection of annotations.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFAnnotationCollection
   Inherits PDFCollection(Of PDFAnnotation, PDFPage)
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotationCollection
C#
public class PDFAnnotationCollection : PDFCollection<PDFAnnotation, PDFPage>
Managed Extensions for C++
public __gc class PDFAnnotationCollection : public PDFCollection<PDFAnnotation, PDFPage>
C++/CLI
public ref class PDFAnnotationCollection : public PDFCollection<PDFAnnotation, PDFPage>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<PDFAnnotation>
O2S.Components.PDF4NET.PDFCollection<PDFAnnotation, PDFPage>
O2S.Components.PDF4NET.Annotations.PDFAnnotationCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAnnotationCollection Members
O2S.Components.PDF4NET.Annotations Namespace


PDFAnnotationCollection Class Members

PDFAnnotationCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationCollection Class

The following tables list the members exposed by PDFAnnotationCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Top

See Also

Reference

PDFAnnotationCollection Class
O2S.Components.PDF4NET.Annotations Namespace


PDFBaseMarkupAnnotation Class

PDFBaseMarkupAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFBaseMarkupAnnotation Class

Defines the base class for all markup type annotations.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFBaseMarkupAnnotation
   Inherits PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseMarkupAnnotation
C#
public class PDFBaseMarkupAnnotation : PDFAnnotation
Managed Extensions for C++
public __gc class PDFBaseMarkupAnnotation : public PDFAnnotation
C++/CLI
public ref class PDFBaseMarkupAnnotation : public PDFAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextAnnotation
O2S.Components.PDF4NET.Annotations.PDFSCAnnotation
O2S.Components.PDF4NET.Annotations.PDFRubberStampAnnotation
O2S.Components.PDF4NET.Annotations.PDFLineAnnotation
O2S.Components.PDF4NET.Annotations.PDFInkAnnotation
O2S.Components.PDF4NET.Annotations.PDFFileAttachmentAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseMarkupAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFBaseMarkupAnnotation Class Members

PDFBaseMarkupAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFBaseMarkupAnnotation Class

The following tables list the members exposed by PDFBaseMarkupAnnotation.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author.
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to".
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity.
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject.
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFBaseMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFBaseMarkupAnnotation Class Properties

PDFBaseMarkupAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFBaseMarkupAnnotation Class

For a list of all members of this type, see PDFBaseMarkupAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author.
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to".
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity.
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject.
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFBaseMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Author Property

Author Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFBaseMarkupAnnotation Class : Author Property

Gets or sets the annotation author.

Syntax

Visual Basic (Declaration)
Public Property Author As String
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseMarkupAnnotation
Dim value As String

instance.Author = value

value = instance.Author
C#
public string Author {get; set;}
Managed Extensions for C++
public: __property string* get_Author();
public: __property void set_Author(
   string* value
);
C++/CLI
public:
property String^ Author {
   String^ get();
   void set (String^ value);
}

Return Value

The name of the person who created the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseMarkupAnnotation Class
PDFBaseMarkupAnnotation Members


InReplyTo Property

InReplyTo Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFBaseMarkupAnnotation Class : InReplyTo Property

Gets or sets the annotation that this annotation is "in reply to".

Syntax

Visual Basic (Declaration)
Public Property InReplyTo As PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseMarkupAnnotation
Dim value As PDFAnnotation

instance.InReplyTo = value

value = instance.InReplyTo
C#
public PDFAnnotation InReplyTo {get; set;}
Managed Extensions for C++
public: __property PDFAnnotation* get_InReplyTo();
public: __property void set_InReplyTo(
   PDFAnnotation* value
);
C++/CLI
public:
property PDFAnnotation^ InReplyTo {
   PDFAnnotation^ get();
   void set (PDFAnnotation^ value);
}

Return Value

The parent annotation that this annotation is "in reply to".

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseMarkupAnnotation Class
PDFBaseMarkupAnnotation Members


Opacity Property

Opacity Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFBaseMarkupAnnotation Class : Opacity Property

Gets or sets the annotation opacity.

Syntax

Visual Basic (Declaration)
Public Overridable Property Opacity As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseMarkupAnnotation
Dim value As Double

instance.Opacity = value

value = instance.Opacity
C#
public virtual double Opacity {get; set;}
Managed Extensions for C++
public: __property virtual double get_Opacity();
public: __property virtual void set_Opacity(
   double value
);
C++/CLI
public:
virtual property double Opacity {
   double get();
   void set (double value);
}

Return Value

The opacity of the annotation in percents.

Remarks

100 means total opacity, 0 means fully transparent.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseMarkupAnnotation Class
PDFBaseMarkupAnnotation Members


Subject Property

Subject Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFBaseMarkupAnnotation Class : Subject Property

Gets or sets the annotation subject.

Syntax

Visual Basic (Declaration)
Public Property Subject As String
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseMarkupAnnotation
Dim value As String

instance.Subject = value

value = instance.Subject
C#
public string Subject {get; set;}
Managed Extensions for C++
public: __property string* get_Subject();
public: __property void set_Subject(
   string* value
);
C++/CLI
public:
property String^ Subject {
   String^ get();
   void set (String^ value);
}

Return Value

The subject of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseMarkupAnnotation Class
PDFBaseMarkupAnnotation Members


PDFEllipseAnnotation Class

PDFEllipseAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFEllipseAnnotation Class

Defines an ellipse (Circle) annotation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFEllipseAnnotation
   Inherits PDFSCAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFEllipseAnnotation
C#
public class PDFEllipseAnnotation : PDFSCAnnotation
Managed Extensions for C++
public __gc class PDFEllipseAnnotation : public PDFSCAnnotation
C++/CLI
public ref class PDFEllipseAnnotation : public PDFSCAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFSCAnnotation
O2S.Components.PDF4NET.Annotations.PDFEllipseAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEllipseAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFEllipseAnnotation Class Members

PDFEllipseAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFEllipseAnnotation Class

The following tables list the members exposed by PDFEllipseAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFEllipseAnnotation Constructor | Overloaded. Initializes a new PDFEllipseAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border. (Inherited from PDFSCAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color. (Inherited from PDFSCAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFEllipseAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFEllipseAnnotation Constructor

PDFEllipseAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFEllipseAnnotation Class : PDFEllipseAnnotation Constructor

Initializes a new PDFEllipseAnnotation object.

Overload List

Overload | Description
PDFEllipseAnnotation Constructor() | Initializes a new PDFEllipseAnnotation object.
PDFEllipseAnnotation Constructor(String,String) | Initializes a new PDFEllipseAnnotation object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEllipseAnnotation Class
PDFEllipseAnnotation Members


PDFEllipseAnnotation Constructor()

PDFEllipseAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFEllipseAnnotation Class > PDFEllipseAnnotation Constructor : PDFEllipseAnnotation Constructor()

Initializes a new PDFEllipseAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFEllipseAnnotation()
C#
public PDFEllipseAnnotation()
Managed Extensions for C++
public: PDFEllipseAnnotation();
C++/CLI
public:
PDFEllipseAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEllipseAnnotation Class
PDFEllipseAnnotation Members
Overload List


PDFEllipseAnnotation Constructor(String,String)

PDFEllipseAnnotation Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFEllipseAnnotation Class > PDFEllipseAnnotation Constructor : PDFEllipseAnnotation Constructor(String,String)

author
The author of the annotation.
contents
The content of the annotation.
Initializes a new PDFEllipseAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim author As String
Dim contents As String

Dim instance As PDFEllipseAnnotation(author, contents)
C#
public PDFEllipseAnnotation(
   string author,
   string contents
)
Managed Extensions for C++
public: PDFEllipseAnnotation(
   string* author,
   string* contents
)
C++/CLI
public:
PDFEllipseAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEllipseAnnotation Class
PDFEllipseAnnotation Members
Overload List


PDFFileAttachmentAnnotation Class

PDFFileAttachmentAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFFileAttachmentAnnotation Class

Defines a file attachment annotation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFileAttachmentAnnotation
   Inherits PDFBaseMarkupAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation
C#
public class PDFFileAttachmentAnnotation : PDFBaseMarkupAnnotation
Managed Extensions for C++
public __gc class PDFFileAttachmentAnnotation : public PDFBaseMarkupAnnotation
C++/CLI
public ref class PDFFileAttachmentAnnotation : public PDFBaseMarkupAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFFileAttachmentAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFFileAttachmentAnnotation Class Members

PDFFileAttachmentAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFFileAttachmentAnnotation Class

The following tables list the members exposed by PDFFileAttachmentAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFFileAttachmentAnnotation Constructor | Overloaded. Initializes a new PDFFileAttachmentAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Data | Gets or sets the data stored in the file attachment annotation.
Public Property | Description | Gets or sets the file description.
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | FileName | Gets or sets the file name.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | Icon | Gets or sets the annotation icon.
Public Property | IconName | Gets or sets the icon name.
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Size | Gets the file size.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Public Method | Save | Overloaded. Saves the content of the embedded file to the specified file.
Top

See Also

Reference

PDFFileAttachmentAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFFileAttachmentAnnotation Constructor

PDFFileAttachmentAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : PDFFileAttachmentAnnotation Constructor

Initializes a new PDFFileAttachmentAnnotation object.

Overload List

Overload | Description
PDFFileAttachmentAnnotation Constructor() | Initializes a new PDFFileAttachmentAnnotation object.
PDFFileAttachmentAnnotation Constructor(String,String) | Initializes a new PDFFileAttachmentAnnotation object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


PDFFileAttachmentAnnotation Constructor()

PDFFileAttachmentAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class > PDFFileAttachmentAnnotation Constructor : PDFFileAttachmentAnnotation Constructor()

Initializes a new PDFFileAttachmentAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation()
C#
public PDFFileAttachmentAnnotation()
Managed Extensions for C++
public: PDFFileAttachmentAnnotation();
C++/CLI
public:
PDFFileAttachmentAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members
Overload List


PDFFileAttachmentAnnotation Constructor(String,String)

PDFFileAttachmentAnnotation Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class > PDFFileAttachmentAnnotation Constructor : PDFFileAttachmentAnnotation Constructor(String,String)

author
The author of the annotation.
contents
The content of the annotation.
Initializes a new PDFFileAttachmentAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim author As String
Dim contents As String

Dim instance As PDFFileAttachmentAnnotation(author, contents)
C#
public PDFFileAttachmentAnnotation(
   string author,
   string contents
)
Managed Extensions for C++
public: PDFFileAttachmentAnnotation(
   string* author,
   string* contents
)
C++/CLI
public:
PDFFileAttachmentAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members
Overload List


PDFFileAttachmentAnnotation Class Methods

PDFFileAttachmentAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFFileAttachmentAnnotation Class

For a list of all members of this type, see PDFFileAttachmentAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Public Method | Save | Overloaded. Saves the content of the embedded file to the specified file.
Top

See Also

Reference

PDFFileAttachmentAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Save Method

Save Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Save Method

Saves the content of the embedded file to the specified file.

Overload List

Overload | Description
Save(String) | Saves the content of the embedded file to the specified file.
Save(Stream) | Saves the content of the embedded file to the specified stream.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


Save(String) Method

Save(String) Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class > Save Method : Save(String) Method

fileName
Physical path where the embedded file should be saved.
Saves the content of the embedded file to the specified file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation
Dim fileName As String

instance.Save(fileName)
C#
public void Save(
   string fileName
)
Managed Extensions for C++
public: void Save(
   string* fileName
)
C++/CLI
public:
void Save(
   String^ fileName
)

Parameters

fileName
Physical path where the embedded file should be saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members
Overload List


Save(Stream) Method

Save(Stream) Method
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class > Save Method : Save(Stream) Method

stream
Stream where the embedded file should be saved.
Saves the content of the embedded file to the specified stream.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Save( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation
Dim stream As Stream

instance.Save(stream)
C#
public void Save(
   Stream stream
)
Managed Extensions for C++
public: void Save(
   Stream* stream
)
C++/CLI
public:
void Save(
   Stream^ stream
)

Parameters

stream
Stream where the embedded file should be saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members
Overload List


PDFFileAttachmentAnnotation Class Properties

PDFFileAttachmentAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFFileAttachmentAnnotation Class

For a list of all members of this type, see PDFFileAttachmentAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Data | Gets or sets the data stored in the file attachment annotation.
Public Property | Description | Gets or sets the file description.
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | FileName | Gets or sets the file name.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | Icon | Gets or sets the annotation icon.
Public Property | IconName | Gets or sets the icon name.
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Size | Gets the file size.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFFileAttachmentAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Appearance Property

Appearance Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Appearance Property

Gets or sets the annotation appearance.

Syntax

Visual Basic (Declaration)
Overrides Public Property Appearance As PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
C#
public override PDFAnnotationAppearance Appearance {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationAppearance* get_Appearance()override ;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
)override ;
C++/CLI
public:
property PDFAnnotationAppearance^ Appearance override {
   PDFAnnotationAppearance^ get();
   void set (PDFAnnotationAppearance^ value);
}

Return Value

The appearance of the text annotation icon.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


Data Property

Data Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Data Property

Gets or sets the data stored in the file attachment annotation.

Syntax

Visual Basic (Declaration)
Public Property Data As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation
Dim value() As Byte

instance.Data = value

value = instance.Data
C#
public byte[] Data {get; set;}
Managed Extensions for C++
public: __property byte[]* get_Data();
public: __property void set_Data(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ Data {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

The content of the file attachment annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


Description Property

Description Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Description Property

Gets or sets the file description.

Syntax

Visual Basic (Declaration)
Public Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation
Dim value As String

instance.Description = value

value = instance.Description
C#
public string Description {get; set;}
Managed Extensions for C++
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
C++/CLI
public:
property String^ Description {
   String^ get();
   void set (String^ value);
}

Return Value

The description of the file stored in the attachment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


FileName Property

FileName Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : FileName Property

Gets or sets the file name.

Syntax

Visual Basic (Declaration)
Public Property FileName As String
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation
Dim value As String

instance.FileName = value

value = instance.FileName
C#
public string FileName {get; set;}
Managed Extensions for C++
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
C++/CLI
public:
property String^ FileName {
   String^ get();
   void set (String^ value);
}

Return Value

The name of the file whose content is stored in Data property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


Icon Property

Icon Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Icon Property

Gets or sets the annotation icon.

Syntax

Visual Basic (Declaration)
Public Property Icon As PDFFileAttachmentAnnotationIcon
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation
Dim value As PDFFileAttachmentAnnotationIcon

instance.Icon = value

value = instance.Icon
C#
public PDFFileAttachmentAnnotationIcon Icon {get; set;}
Managed Extensions for C++
public: __property PDFFileAttachmentAnnotationIcon get_Icon();
public: __property void set_Icon(
   PDFFileAttachmentAnnotationIcon value
);
C++/CLI
public:
property PDFFileAttachmentAnnotationIcon Icon {
   PDFFileAttachmentAnnotationIcon get();
   void set (PDFFileAttachmentAnnotationIcon value);
}

Return Value

The icon to be displayed for the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


IconName Property

IconName Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : IconName Property

Gets or sets the icon name.

Syntax

Visual Basic (Declaration)
Public Property IconName As String
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation
Dim value As String

instance.IconName = value

value = instance.IconName
C#
public string IconName {get; set;}
Managed Extensions for C++
public: __property string* get_IconName();
public: __property void set_IconName(
   string* value
);
C++/CLI
public:
property String^ IconName {
   String^ get();
   void set (String^ value);
}

Return Value

The name of the file attachment's icon.

Exceptions

Exception | Description
ArgumentNullException | Thrown when the property value is null or empty.

Remarks

This property lets you set a custom name for your user defined appearances.
If the Icon property to any of the PDFFileAttachmentAnnotationIcon enum values, the IconName property will be set automatically to the corresponding string value. If the IconName property to a predefined icon name (names available in PDFFileAttachmentAnnotationIcon enumeration), the Icon property will be set accordingly, otherwise the Icon property will be set to PDFFileAttachmentAnnotationIcon.Custom

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


Size Property

Size Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFileAttachmentAnnotation Class : Size Property

Gets the file size.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotation
Dim value As Integer

value = instance.Size
C#
public int Size {get;}
Managed Extensions for C++
public: __property int get_Size();
C++/CLI
public:
property int Size {
   int get();
}

Return Value

The size of the file stored in Data property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFileAttachmentAnnotation Class
PDFFileAttachmentAnnotation Members


PDFFreeTextAnnotation Class

PDFFreeTextAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFFreeTextAnnotation Class

Defines a free text annotations.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFreeTextAnnotation
   Inherits PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFFreeTextAnnotation
C#
public class PDFFreeTextAnnotation : PDFAnnotation
Managed Extensions for C++
public __gc class PDFFreeTextAnnotation : public PDFAnnotation
C++/CLI
public ref class PDFFreeTextAnnotation : public PDFAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFFreeTextAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFreeTextAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFFreeTextAnnotation Class Members

PDFFreeTextAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFFreeTextAnnotation Class

The following tables list the members exposed by PDFFreeTextAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFFreeTextAnnotation Constructor | Initializes a new PDFFreeTextAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author.
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Overridden. Gets or sets the annotation contents.
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject.
Public Property | TextColor | Gets or sets the text color.
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFFreeTextAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFFreeTextAnnotation Constructor

PDFFreeTextAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : PDFFreeTextAnnotation Constructor

Initializes a new PDFFreeTextAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFFreeTextAnnotation()
C#
public PDFFreeTextAnnotation()
Managed Extensions for C++
public: PDFFreeTextAnnotation();
C++/CLI
public:
PDFFreeTextAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


PDFFreeTextAnnotation Class Properties

PDFFreeTextAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFFreeTextAnnotation Class

For a list of all members of this type, see PDFFreeTextAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author.
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Overridden. Gets or sets the annotation contents.
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject.
Public Property | TextColor | Gets or sets the text color.
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFFreeTextAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Author Property

Author Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : Author Property

Gets or sets the annotation author.

Syntax

Visual Basic (Declaration)
Public Property Author As String
Visual Basic (Usage) Copy Code
Dim instance As PDFFreeTextAnnotation
Dim value As String

instance.Author = value

value = instance.Author
C#
public string Author {get; set;}
Managed Extensions for C++
public: __property string* get_Author();
public: __property void set_Author(
   string* value
);
C++/CLI
public:
property String^ Author {
   String^ get();
   void set (String^ value);
}

Return Value

The name of the person who created the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


Contents Property

Contents Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : Contents Property

Gets or sets the annotation contents.

Syntax

Visual Basic (Declaration)
Overrides Public Property Contents As String
Visual Basic (Usage) Copy Code
Dim instance As PDFFreeTextAnnotation
Dim value As String

instance.Contents = value

value = instance.Contents
C#
public override string Contents {get; set;}
Managed Extensions for C++
public: __property string* get_Contents()override ;
public: __property void set_Contents(
   string* value
)override ;
C++/CLI
public:
property String^ Contents override {
   String^ get();
   void set (String^ value);
}

Return Value

The text to be displayed for the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


Subject Property

Subject Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : Subject Property

Gets or sets the annotation subject.

Syntax

Visual Basic (Declaration)
Public Property Subject As String
Visual Basic (Usage) Copy Code
Dim instance As PDFFreeTextAnnotation
Dim value As String

instance.Subject = value

value = instance.Subject
C#
public string Subject {get; set;}
Managed Extensions for C++
public: __property string* get_Subject();
public: __property void set_Subject(
   string* value
);
C++/CLI
public:
property String^ Subject {
   String^ get();
   void set (String^ value);
}

Return Value

The subject of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


TextColor Property

TextColor Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFFreeTextAnnotation Class : TextColor Property

Gets or sets the text color.

Syntax

Visual Basic (Declaration)
Public Property TextColor As PDFRgbColor
Visual Basic (Usage) Copy Code
Dim instance As PDFFreeTextAnnotation
Dim value As PDFRgbColor

instance.TextColor = value

value = instance.TextColor
C#
public PDFRgbColor TextColor {get; set;}
Managed Extensions for C++
public: __property PDFRgbColor* get_TextColor();
public: __property void set_TextColor(
   PDFRgbColor* value
);
C++/CLI
public:
property PDFRgbColor^ TextColor {
   PDFRgbColor^ get();
   void set (PDFRgbColor^ value);
}

Return Value

The color of the annotation's text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFreeTextAnnotation Class
PDFFreeTextAnnotation Members


PDFHighlightAnnotation Class

PDFHighlightAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFHighlightAnnotation Class

Defines a highlight annotation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFHighlightAnnotation
   Inherits PDFTextMarkupAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFHighlightAnnotation
C#
public class PDFHighlightAnnotation : PDFTextMarkupAnnotation
Managed Extensions for C++
public __gc class PDFHighlightAnnotation : public PDFTextMarkupAnnotation
C++/CLI
public ref class PDFHighlightAnnotation : public PDFTextMarkupAnnotation

Remarks

This annotation is used to highlight text in a document.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFHighlightAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHighlightAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFHighlightAnnotation Class Members

PDFHighlightAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFHighlightAnnotation Class

The following tables list the members exposed by PDFHighlightAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFHighlightAnnotation Constructor | Overloaded. Initializes a new PDFHighlightAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from PDFTextMarkupAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFHighlightAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFHighlightAnnotation Constructor

PDFHighlightAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFHighlightAnnotation Class : PDFHighlightAnnotation Constructor

Initializes a new PDFHighlightAnnotation object.

Overload List

Overload | Description
PDFHighlightAnnotation Constructor() | Initializes a new PDFHighlightAnnotation object.
PDFHighlightAnnotation Constructor(String,String) | Initializes a new PDFHighlightAnnotation object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHighlightAnnotation Class
PDFHighlightAnnotation Members


PDFHighlightAnnotation Constructor()

PDFHighlightAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFHighlightAnnotation Class > PDFHighlightAnnotation Constructor : PDFHighlightAnnotation Constructor()

Initializes a new PDFHighlightAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFHighlightAnnotation()
C#
public PDFHighlightAnnotation()
Managed Extensions for C++
public: PDFHighlightAnnotation();
C++/CLI
public:
PDFHighlightAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHighlightAnnotation Class
PDFHighlightAnnotation Members
Overload List


PDFHighlightAnnotation Constructor(String,String)

PDFHighlightAnnotation Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFHighlightAnnotation Class > PDFHighlightAnnotation Constructor : PDFHighlightAnnotation Constructor(String,String)

author
The author of the annotation.
contents
The content of the annotation.
Initializes a new PDFHighlightAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim author As String
Dim contents As String

Dim instance As PDFHighlightAnnotation(author, contents)
C#
public PDFHighlightAnnotation(
   string author,
   string contents
)
Managed Extensions for C++
public: PDFHighlightAnnotation(
   string* author,
   string* contents
)
C++/CLI
public:
PDFHighlightAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHighlightAnnotation Class
PDFHighlightAnnotation Members
Overload List


PDFImageAppearance Class

PDFImageAppearance Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFImageAppearance Class

Defines an annotation appearance that consists of an image.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFImageAppearance
   Inherits PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFImageAppearance
C#
public class PDFImageAppearance : PDFAnnotationAppearance
Managed Extensions for C++
public __gc class PDFImageAppearance : public PDFAnnotationAppearance
C++/CLI
public ref class PDFImageAppearance : public PDFAnnotationAppearance

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.Annotations.PDFAnnotationAppearance
O2S.Components.PDF4NET.Annotations.PDFImageAppearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImageAppearance Members
O2S.Components.PDF4NET.Annotations Namespace


PDFImageAppearance Class Members

PDFImageAppearance Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFImageAppearance Class

The following tables list the members exposed by PDFImageAppearance.

Public Constructors

 | Name | Description
Public Constructor | PDFImageAppearance Constructor | Initializes a new PDFImageAppearance object.
Top

Public Properties

 | Name | Description
Public Property | Canvas | Gets the form XObject canvas. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Height | Gets or sets the height of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Width | Gets or sets the width of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Top

See Also

Reference

PDFImageAppearance Class
O2S.Components.PDF4NET.Annotations Namespace


PDFImageAppearance Constructor

PDFImageAppearance Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFImageAppearance Class : PDFImageAppearance Constructor

image
The image used for creating the appearance.
Initializes a new PDFImageAppearance object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal image As Bitmap _
)
Visual Basic (Usage) Copy Code
Dim image As Bitmap

Dim instance As PDFImageAppearance(image)
C#
public PDFImageAppearance(
   Bitmap image
)
Managed Extensions for C++
public: PDFImageAppearance(
   Bitmap image
)
C++/CLI
public:
PDFImageAppearance(
   Bitmap image
)

Parameters

image
The image used for creating the appearance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImageAppearance Class
PDFImageAppearance Members


PDFInkAnnotation Class

PDFInkAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFInkAnnotation Class

Defines an ink annotation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFInkAnnotation
   Inherits PDFBaseMarkupAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFInkAnnotation
C#
public class PDFInkAnnotation : PDFBaseMarkupAnnotation
Managed Extensions for C++
public __gc class PDFInkAnnotation : public PDFBaseMarkupAnnotation
C++/CLI
public ref class PDFInkAnnotation : public PDFBaseMarkupAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFInkAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFInkAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFInkAnnotation Class Members

PDFInkAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFInkAnnotation Class

The following tables list the members exposed by PDFInkAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFInkAnnotation Constructor | Initializes a new PDFInkAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Points | Gets the annotation points.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFInkAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFInkAnnotation Constructor

PDFInkAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFInkAnnotation Class : PDFInkAnnotation Constructor

Initializes a new PDFInkAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFInkAnnotation()
C#
public PDFInkAnnotation()
Managed Extensions for C++
public: PDFInkAnnotation();
C++/CLI
public:
PDFInkAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFInkAnnotation Class
PDFInkAnnotation Members


PDFInkAnnotation Class Properties

PDFInkAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFInkAnnotation Class

For a list of all members of this type, see PDFInkAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Points | Gets the annotation points.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFInkAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Border Property

Border Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFInkAnnotation Class : Border Property

Gets or sets the annotation border.

Syntax

Visual Basic (Declaration)
Public Property Border As PDFAnnotationBorder
Visual Basic (Usage) Copy Code
Dim instance As PDFInkAnnotation
Dim value As PDFAnnotationBorder

instance.Border = value

value = instance.Border
C#
public PDFAnnotationBorder Border {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationBorder* get_Border();
public: __property void set_Border(
   PDFAnnotationBorder* value
);
C++/CLI
public:
property PDFAnnotationBorder^ Border {
   PDFAnnotationBorder^ get();
   void set (PDFAnnotationBorder^ value);
}

Return Value

The annotation border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFInkAnnotation Class
PDFInkAnnotation Members


Points Property

Points Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFInkAnnotation Class : Points Property

Gets the annotation points.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Points As PDFPointsCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFInkAnnotation
Dim value As PDFPointsCollection

value = instance.Points
C#
public PDFPointsCollection Points {get;}
Managed Extensions for C++
public: __property PDFPointsCollection* get_Points();
C++/CLI
public:
property PDFPointsCollection^ Points {
   PDFPointsCollection^ get();
}

Return Value

The list of points that create this annotation.

Remarks

The collection consists of at least one points array. Each points array includes 2*n values representing the coordinates of n points in the page coordinate space

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFInkAnnotation Class
PDFInkAnnotation Members


PDFLineAnnotation Class

PDFLineAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFLineAnnotation Class

Defines a line annotation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFLineAnnotation
   Inherits PDFBaseMarkupAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFLineAnnotation
C#
public class PDFLineAnnotation : PDFBaseMarkupAnnotation
Managed Extensions for C++
public __gc class PDFLineAnnotation : public PDFBaseMarkupAnnotation
C++/CLI
public ref class PDFLineAnnotation : public PDFBaseMarkupAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFLineAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLineAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFLineAnnotation Class Members

PDFLineAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFLineAnnotation Class

The following tables list the members exposed by PDFLineAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFLineAnnotation Constructor | Overloaded. Initializes a new PDFLineAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | BeginLineStyle | Gets or sets the style used for the beginning of the line.
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | EndLineStyle | Gets or sets the style used for the end of the line.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color.
Public Property | LineDirection | Gets or sets the direction of the line annotation.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFLineAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFLineAnnotation Constructor

PDFLineAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : PDFLineAnnotation Constructor

Initializes a new PDFLineAnnotation object.

Overload List

Overload | Description
PDFLineAnnotation Constructor() | Initializes a new PDFLineAnnotation object.
PDFLineAnnotation Constructor(String,String) | Initializes a new PDFLineAnnotation object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


PDFLineAnnotation Constructor()

PDFLineAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class > PDFLineAnnotation Constructor : PDFLineAnnotation Constructor()

Initializes a new PDFLineAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFLineAnnotation()
C#
public PDFLineAnnotation()
Managed Extensions for C++
public: PDFLineAnnotation();
C++/CLI
public:
PDFLineAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members
Overload List


PDFLineAnnotation Constructor(String,String)

PDFLineAnnotation Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class > PDFLineAnnotation Constructor : PDFLineAnnotation Constructor(String,String)

author
The author of the annotation.
contents
The content of the annotation.
Initializes a new PDFLineAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim author As String
Dim contents As String

Dim instance As PDFLineAnnotation(author, contents)
C#
public PDFLineAnnotation(
   string author,
   string contents
)
Managed Extensions for C++
public: PDFLineAnnotation(
   string* author,
   string* contents
)
C++/CLI
public:
PDFLineAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members
Overload List


PDFLineAnnotation Class Properties

PDFLineAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFLineAnnotation Class

For a list of all members of this type, see PDFLineAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | BeginLineStyle | Gets or sets the style used for the beginning of the line.
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | EndLineStyle | Gets or sets the style used for the end of the line.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color.
Public Property | LineDirection | Gets or sets the direction of the line annotation.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFLineAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Appearance Property

Appearance Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : Appearance Property

Gets or sets the annotation appearance.

Syntax

Visual Basic (Declaration)
Overrides Public Property Appearance As PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFLineAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
C#
public override PDFAnnotationAppearance Appearance {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationAppearance* get_Appearance()override ;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
)override ;
C++/CLI
public:
property PDFAnnotationAppearance^ Appearance override {
   PDFAnnotationAppearance^ get();
   void set (PDFAnnotationAppearance^ value);
}

Return Value

The appearance of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


BeginLineStyle Property

BeginLineStyle Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : BeginLineStyle Property

Gets or sets the style used for the beginning of the line.

Syntax

Visual Basic (Declaration)
Public Property BeginLineStyle As PDFLineEndingStyle
Visual Basic (Usage) Copy Code
Dim instance As PDFLineAnnotation
Dim value As PDFLineEndingStyle

instance.BeginLineStyle = value

value = instance.BeginLineStyle
C#
public PDFLineEndingStyle BeginLineStyle {get; set;}
Managed Extensions for C++
public: __property PDFLineEndingStyle get_BeginLineStyle();
public: __property void set_BeginLineStyle(
   PDFLineEndingStyle value
);
C++/CLI
public:
property PDFLineEndingStyle BeginLineStyle {
   PDFLineEndingStyle get();
   void set (PDFLineEndingStyle value);
}

Return Value

A PDFLineEndingStyle enumeration member specifying the style for the beginning of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


Border Property

Border Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : Border Property

Gets or sets the annotation border.

Syntax

Visual Basic (Declaration)
Public Property Border As PDFAnnotationBorder
Visual Basic (Usage) Copy Code
Dim instance As PDFLineAnnotation
Dim value As PDFAnnotationBorder

instance.Border = value

value = instance.Border
C#
public PDFAnnotationBorder Border {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationBorder* get_Border();
public: __property void set_Border(
   PDFAnnotationBorder* value
);
C++/CLI
public:
property PDFAnnotationBorder^ Border {
   PDFAnnotationBorder^ get();
   void set (PDFAnnotationBorder^ value);
}

Return Value

The annotation border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


EndLineStyle Property

EndLineStyle Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : EndLineStyle Property

Gets or sets the style used for the end of the line.

Syntax

Visual Basic (Declaration)
Public Property EndLineStyle As PDFLineEndingStyle
Visual Basic (Usage) Copy Code
Dim instance As PDFLineAnnotation
Dim value As PDFLineEndingStyle

instance.EndLineStyle = value

value = instance.EndLineStyle
C#
public PDFLineEndingStyle EndLineStyle {get; set;}
Managed Extensions for C++
public: __property PDFLineEndingStyle get_EndLineStyle();
public: __property void set_EndLineStyle(
   PDFLineEndingStyle value
);
C++/CLI
public:
property PDFLineEndingStyle EndLineStyle {
   PDFLineEndingStyle get();
   void set (PDFLineEndingStyle value);
}

Return Value

A PDFLineEndingStyle enumeration member specifying the style for the end of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


InteriorColor Property

InteriorColor Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : InteriorColor Property

Gets or sets the annotation's interior color.

Syntax

Visual Basic (Declaration)
Public Property InteriorColor As PDFDeviceColor
Visual Basic (Usage) Copy Code
Dim instance As PDFLineAnnotation
Dim value As PDFDeviceColor

instance.InteriorColor = value

value = instance.InteriorColor
C#
public PDFDeviceColor InteriorColor {get; set;}
Managed Extensions for C++
public: __property PDFDeviceColor* get_InteriorColor();
public: __property void set_InteriorColor(
   PDFDeviceColor* value
);
C++/CLI
public:
property PDFDeviceColor^ InteriorColor {
   PDFDeviceColor^ get();
   void set (PDFDeviceColor^ value);
}

Return Value

The annotation interior color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


LineDirection Property

LineDirection Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLineAnnotation Class : LineDirection Property

Gets or sets the direction of the line annotation.

Syntax

Visual Basic (Declaration)
Public Property LineDirection As PDFLineDirection
Visual Basic (Usage) Copy Code
Dim instance As PDFLineAnnotation
Dim value As PDFLineDirection

instance.LineDirection = value

value = instance.LineDirection
C#
public PDFLineDirection LineDirection {get; set;}
Managed Extensions for C++
public: __property PDFLineDirection get_LineDirection();
public: __property void set_LineDirection(
   PDFLineDirection value
);
C++/CLI
public:
property PDFLineDirection LineDirection {
   PDFLineDirection get();
   void set (PDFLineDirection value);
}

Return Value

A PDFLineDirection enumeration member specifying the direction of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLineAnnotation Class
PDFLineAnnotation Members


PDFLinkAnnotation Class

PDFLinkAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFLinkAnnotation Class

Defines a link annotations.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFLinkAnnotation
   Inherits PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFLinkAnnotation
C#
public class PDFLinkAnnotation : PDFAnnotation
Managed Extensions for C++
public __gc class PDFLinkAnnotation : public PDFAnnotation
C++/CLI
public ref class PDFLinkAnnotation : public PDFAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFLinkAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinkAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFLinkAnnotation Class Members

PDFLinkAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFLinkAnnotation Class

The following tables list the members exposed by PDFLinkAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFLinkAnnotation Constructor | Initializes a new PDFLinkAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the action to be executed when the link is clicked.
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author.
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | HighlightMode | Gets or sets the highlighting mode of the link.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFLinkAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFLinkAnnotation Constructor

PDFLinkAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLinkAnnotation Class : PDFLinkAnnotation Constructor

Initializes a new PDFLinkAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFLinkAnnotation()
C#
public PDFLinkAnnotation()
Managed Extensions for C++
public: PDFLinkAnnotation();
C++/CLI
public:
PDFLinkAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


PDFLinkAnnotation Class Properties

PDFLinkAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFLinkAnnotation Class

For a list of all members of this type, see PDFLinkAnnotation members.

Public Properties

 | Name | Description
Public Property | Action | Gets or sets the action to be executed when the link is clicked.
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author.
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | HighlightMode | Gets or sets the highlighting mode of the link.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFLinkAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Action Property

Action Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLinkAnnotation Class : Action Property

Gets or sets the action to be executed when the link is clicked.

Syntax

Visual Basic (Declaration)
Public Property Action As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFLinkAnnotation
Dim value As PDFAction

instance.Action = value

value = instance.Action
C#
public PDFAction Action {get; set;}
Managed Extensions for C++
public: __property PDFAction* get_Action();
public: __property void set_Action(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ Action {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

Action to execute.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


Appearance Property

Appearance Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLinkAnnotation Class : Appearance Property

Gets or sets the annotation appearance.

Syntax

Visual Basic (Declaration)
Overrides Public Property Appearance As PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFLinkAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
C#
public override PDFAnnotationAppearance Appearance {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationAppearance* get_Appearance()override ;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
)override ;
C++/CLI
public:
property PDFAnnotationAppearance^ Appearance override {
   PDFAnnotationAppearance^ get();
   void set (PDFAnnotationAppearance^ value);
}

Return Value

The appearance of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


Author Property

Author Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLinkAnnotation Class : Author Property

Gets or sets the annotation author.

Syntax

Visual Basic (Declaration)
Public Property Author As String
Visual Basic (Usage) Copy Code
Dim instance As PDFLinkAnnotation
Dim value As String

instance.Author = value

value = instance.Author
C#
public string Author {get; set;}
Managed Extensions for C++
public: __property string* get_Author();
public: __property void set_Author(
   string* value
);
C++/CLI
public:
property String^ Author {
   String^ get();
   void set (String^ value);
}

Return Value

The name of the person who created the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


Border Property

Border Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLinkAnnotation Class : Border Property

Gets or sets the annotation border.

Syntax

Visual Basic (Declaration)
Public Property Border As PDFAnnotationBorder
Visual Basic (Usage) Copy Code
Dim instance As PDFLinkAnnotation
Dim value As PDFAnnotationBorder

instance.Border = value

value = instance.Border
C#
public PDFAnnotationBorder Border {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationBorder* get_Border();
public: __property void set_Border(
   PDFAnnotationBorder* value
);
C++/CLI
public:
property PDFAnnotationBorder^ Border {
   PDFAnnotationBorder^ get();
   void set (PDFAnnotationBorder^ value);
}

Return Value

The annotation border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


HighlightMode Property

HighlightMode Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFLinkAnnotation Class : HighlightMode Property

Gets or sets the highlighting mode of the link.

Syntax

Visual Basic (Declaration)
Public Property HighlightMode As PDFLinkHighlightMode
Visual Basic (Usage) Copy Code
Dim instance As PDFLinkAnnotation
Dim value As PDFLinkHighlightMode

instance.HighlightMode = value

value = instance.HighlightMode
C#
public PDFLinkHighlightMode HighlightMode {get; set;}
Managed Extensions for C++
public: __property PDFLinkHighlightMode get_HighlightMode();
public: __property void set_HighlightMode(
   PDFLinkHighlightMode value
);
C++/CLI
public:
property PDFLinkHighlightMode HighlightMode {
   PDFLinkHighlightMode get();
   void set (PDFLinkHighlightMode value);
}

Return Value

A PDFLinkHighlightMode enumeration member specifying the highlighting mode for the link.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinkAnnotation Class
PDFLinkAnnotation Members


PDFMarkupAnnotation Class

PDFMarkupAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFMarkupAnnotation Class

Defines the base class for all markup type annotations.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFMarkupAnnotation
   Inherits PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFMarkupAnnotation
C#
public class PDFMarkupAnnotation : PDFAnnotation
Managed Extensions for C++
public __gc class PDFMarkupAnnotation : public PDFAnnotation
C++/CLI
public ref class PDFMarkupAnnotation : public PDFAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFMarkupAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMarkupAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFMarkupAnnotation Class Members

PDFMarkupAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFMarkupAnnotation Class

The following tables list the members exposed by PDFMarkupAnnotation.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author.
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to".
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity.
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject.
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFMarkupAnnotation Class Properties

PDFMarkupAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFMarkupAnnotation Class

For a list of all members of this type, see PDFMarkupAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author.
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to".
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity.
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject.
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Author Property

Author Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMarkupAnnotation Class : Author Property

Gets or sets the annotation author.

Syntax

Visual Basic (Declaration)
Public Property Author As String
Visual Basic (Usage) Copy Code
Dim instance As PDFMarkupAnnotation
Dim value As String

instance.Author = value

value = instance.Author
C#
public string Author {get; set;}
Managed Extensions for C++
public: __property string* get_Author();
public: __property void set_Author(
   string* value
);
C++/CLI
public:
property String^ Author {
   String^ get();
   void set (String^ value);
}

Return Value

The name of the person who created the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMarkupAnnotation Class
PDFMarkupAnnotation Members


InReplyTo Property

InReplyTo Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMarkupAnnotation Class : InReplyTo Property

Gets or sets the annotation that this annotation is "in reply to".

Syntax

Visual Basic (Declaration)
Public Property InReplyTo As PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFMarkupAnnotation
Dim value As PDFAnnotation

instance.InReplyTo = value

value = instance.InReplyTo
C#
public PDFAnnotation InReplyTo {get; set;}
Managed Extensions for C++
public: __property PDFAnnotation* get_InReplyTo();
public: __property void set_InReplyTo(
   PDFAnnotation* value
);
C++/CLI
public:
property PDFAnnotation^ InReplyTo {
   PDFAnnotation^ get();
   void set (PDFAnnotation^ value);
}

Return Value

The parent annotation that this annotation is "in reply to".

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMarkupAnnotation Class
PDFMarkupAnnotation Members


Opacity Property

Opacity Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMarkupAnnotation Class : Opacity Property

Gets or sets the annotation opacity.

Syntax

Visual Basic (Declaration)
Public Overridable Property Opacity As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFMarkupAnnotation
Dim value As Double

instance.Opacity = value

value = instance.Opacity
C#
public virtual double Opacity {get; set;}
Managed Extensions for C++
public: __property virtual double get_Opacity();
public: __property virtual void set_Opacity(
   double value
);
C++/CLI
public:
virtual property double Opacity {
   double get();
   void set (double value);
}

Return Value

The opacity of the annotation in percents.

Remarks

100 means total opacity, 0 means fully transparent.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMarkupAnnotation Class
PDFMarkupAnnotation Members


Subject Property

Subject Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMarkupAnnotation Class : Subject Property

Gets or sets the annotation subject.

Syntax

Visual Basic (Declaration)
Public Property Subject As String
Visual Basic (Usage) Copy Code
Dim instance As PDFMarkupAnnotation
Dim value As String

instance.Subject = value

value = instance.Subject
C#
public string Subject {get; set;}
Managed Extensions for C++
public: __property string* get_Subject();
public: __property void set_Subject(
   string* value
);
C++/CLI
public:
property String^ Subject {
   String^ get();
   void set (String^ value);
}

Return Value

The subject of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMarkupAnnotation Class
PDFMarkupAnnotation Members


PDFMovieAnnotation Class

PDFMovieAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFMovieAnnotation Class

Defines a movie annotation in a PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFMovieAnnotation
   Inherits PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieAnnotation
C#
public class PDFMovieAnnotation : PDFAnnotation
Managed Extensions for C++
public __gc class PDFMovieAnnotation : public PDFAnnotation
C++/CLI
public ref class PDFMovieAnnotation : public PDFAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFMovieAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFMovieAnnotation Class Members

PDFMovieAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFMovieAnnotation Class

The following tables list the members exposed by PDFMovieAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFMovieAnnotation Constructor | Overloaded. Initializes a new PDFMovieAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Duration | Gets or sets the duration of the movie clip.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MovieData | Gets or sets the movie content associated with this annotation.
Public Property | MovieFile | Gets or sets the movie file associated with this annotation.
Public Property | MovieType | Gets or sets the MIME type of the movie file.
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Poster | Gets or sets the movie poster to be displayed on the page when the movie is not playing.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | ShowPlayerControls | Gets or sets whether player control interface should be displayed while playing the movie.
Public Property | Title | Gets or sets the annotation title.
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFMovieAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFMovieAnnotation Constructor

PDFMovieAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : PDFMovieAnnotation Constructor

Initializes a new PDFMovieAnnotation object.

Overload List

Overload | Description
PDFMovieAnnotation Constructor() | Initializes a new PDFMovieAnnotation object.
PDFMovieAnnotation Constructor(String,PDFMovieType,PDFFormXObject) | Initializes a new PDFMovieAnnotation object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


PDFMovieAnnotation Constructor()

PDFMovieAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class > PDFMovieAnnotation Constructor : PDFMovieAnnotation Constructor()

Initializes a new PDFMovieAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieAnnotation()
C#
public PDFMovieAnnotation()
Managed Extensions for C++
public: PDFMovieAnnotation();
C++/CLI
public:
PDFMovieAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members
Overload List


PDFMovieAnnotation Constructor(String,PDFMovieType,PDFFormXObject)

PDFMovieAnnotation Constructor(String,PDFMovieType,PDFFormXObject)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class > PDFMovieAnnotation Constructor : PDFMovieAnnotation Constructor(String,PDFMovieType,PDFFormXObject)

movieFile
movieType
the type of the movie file.
poster
a static image to represent the annotation when the movie is not playing.
Initializes a new PDFMovieAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal movieFile As String, _
   ByVal movieType As PDFMovieType, _
   ByVal poster As PDFFormXObject _
)
Visual Basic (Usage) Copy Code
Dim movieFile As String
Dim movieType As PDFMovieType
Dim poster As PDFFormXObject

Dim instance As PDFMovieAnnotation(movieFile, movieType, poster)
C#
public PDFMovieAnnotation(
   string movieFile,
   PDFMovieType movieType,
   PDFFormXObject poster
)
Managed Extensions for C++
public: PDFMovieAnnotation(
   string* movieFile,
   PDFMovieType movieType,
   PDFFormXObject* poster
)
C++/CLI
public:
PDFMovieAnnotation(
   String^ movieFile,
   PDFMovieType movieType,
   PDFFormXObject^ poster
)

Parameters

movieFile
movieType
the type of the movie file.
poster
a static image to represent the annotation when the movie is not playing.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members
Overload List


PDFMovieAnnotation Class Properties

PDFMovieAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFMovieAnnotation Class

For a list of all members of this type, see PDFMovieAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Duration | Gets or sets the duration of the movie clip.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MovieData | Gets or sets the movie content associated with this annotation.
Public Property | MovieFile | Gets or sets the movie file associated with this annotation.
Public Property | MovieType | Gets or sets the MIME type of the movie file.
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Poster | Gets or sets the movie poster to be displayed on the page when the movie is not playing.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | ShowPlayerControls | Gets or sets whether player control interface should be displayed while playing the movie.
Public Property | Title | Gets or sets the annotation title.
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFMovieAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Duration Property

Duration Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : Duration Property

Gets or sets the duration of the movie clip.

Syntax

Visual Basic (Declaration)
Public Property Duration As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieAnnotation
Dim value As Double

instance.Duration = value

value = instance.Duration
C#
public double Duration {get; set;}
Managed Extensions for C++
public: __property double get_Duration();
public: __property void set_Duration(
   double value
);
C++/CLI
public:
property double Duration {
   double get();
   void set (double value);
}

Return Value

A float value specifying the duration of the movie clip.

Remarks

If this property is -1, the actual movie duration is used for playing the movie. If this property is 0, the duration is infinity.
If the duration is greater than actual movie duration, when the movie ends, the player displays the last frame till the specified duration elapses. If the duration is lower than actual movie duration, the movie ends when the duration elapses.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


MovieData Property

MovieData Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : MovieData Property

Gets or sets the movie content associated with this annotation.

Syntax

Visual Basic (Declaration)
Public Property MovieData As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieAnnotation
Dim value() As Byte

instance.MovieData = value

value = instance.MovieData
C#
public byte[] MovieData {get; set;}
Managed Extensions for C++
public: __property byte[]* get_MovieData();
public: __property void set_MovieData(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ MovieData {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array value specifying the movie content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


MovieFile Property

MovieFile Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : MovieFile Property

Gets or sets the movie file associated with this annotation.

Syntax

Visual Basic (Declaration)
Public Property MovieFile As String
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieAnnotation
Dim value As String

instance.MovieFile = value

value = instance.MovieFile
C#
public string MovieFile {get; set;}
Managed Extensions for C++
public: __property string* get_MovieFile();
public: __property void set_MovieFile(
   string* value
);
C++/CLI
public:
property String^ MovieFile {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the full path to the movie file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


MovieType Property

MovieType Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : MovieType Property

Gets or sets the MIME type of the movie file.

Syntax

Visual Basic (Declaration)
Public Property MovieType As PDFMovieType
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieAnnotation
Dim value As PDFMovieType

instance.MovieType = value

value = instance.MovieType
C#
public PDFMovieType MovieType {get; set;}
Managed Extensions for C++
public: __property PDFMovieType get_MovieType();
public: __property void set_MovieType(
   PDFMovieType value
);
C++/CLI
public:
property PDFMovieType MovieType {
   PDFMovieType get();
   void set (PDFMovieType value);
}

Return Value

A MovieType enumeration member specifying the MIME type of the movie file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


Poster Property

Poster Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : Poster Property

Gets or sets the movie poster to be displayed on the page when the movie is not playing.

Syntax

Visual Basic (Declaration)
Public Property Poster As PDFFormXObject
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieAnnotation
Dim value As PDFFormXObject

instance.Poster = value

value = instance.Poster
C#
public PDFFormXObject Poster {get; set;}
Managed Extensions for C++
public: __property PDFFormXObject* get_Poster();
public: __property void set_Poster(
   PDFFormXObject* value
);
C++/CLI
public:
property PDFFormXObject^ Poster {
   PDFFormXObject^ get();
   void set (PDFFormXObject^ value);
}

Return Value

A string value specifying the movie poster to be displayed on the page when the movie is not playing.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


ShowPlayerControls Property

ShowPlayerControls Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : ShowPlayerControls Property

Gets or sets whether player control interface should be displayed while playing the movie.

Syntax

Visual Basic (Declaration)
Public Property ShowPlayerControls As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieAnnotation
Dim value As Boolean

instance.ShowPlayerControls = value

value = instance.ShowPlayerControls
C#
public bool ShowPlayerControls {get; set;}
Managed Extensions for C++
public: __property bool get_ShowPlayerControls();
public: __property void set_ShowPlayerControls(
   bool value
);
C++/CLI
public:
property bool ShowPlayerControls {
   bool get();
   void set (bool value);
}

Return Value

True if the player control interface should be displayed, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


Title Property

Title Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFMovieAnnotation Class : Title Property

Gets or sets the annotation title.

Syntax

Visual Basic (Declaration)
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieAnnotation
Dim value As String

instance.Title = value

value = instance.Title
C#
public string Title {get; set;}
Managed Extensions for C++
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
C++/CLI
public:
property String^ Title {
   String^ get();
   void set (String^ value);
}

Return Value

The title of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMovieAnnotation Class
PDFMovieAnnotation Members


PDFPointsCollection Class

PDFPointsCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFPointsCollection Class

Defines a collection of array the store points on the page.

Syntax

Visual Basic (Declaration)
Public Class PDFPointsCollection
   Inherits PDFCollection(Of Double, PDFAnnotation)
Visual Basic (Usage) Copy Code
Dim instance As PDFPointsCollection
C#
public class PDFPointsCollection : PDFCollection<double, PDFAnnotation>
Managed Extensions for C++
public __gc class PDFPointsCollection : public PDFCollection<double, PDFAnnotation>
C++/CLI
public ref class PDFPointsCollection : public PDFCollection<double, PDFAnnotation>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<Double>
O2S.Components.PDF4NET.PDFCollection<Double, PDFAnnotation>
O2S.Components.PDF4NET.Annotations.PDFPointsCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPointsCollection Members
O2S.Components.PDF4NET.Annotations Namespace


PDFPointsCollection Class Members

PDFPointsCollection Class Members
See Also Properties Methods Events
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFPointsCollection Class

The following tables list the members exposed by PDFPointsCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Top

Public Events

 | Name | Description
Public Event | CollectionChanged | Occurs when the collection changes.
Top

See Also

Reference

PDFPointsCollection Class
O2S.Components.PDF4NET.Annotations Namespace


PDFPointsCollection Class Events

PDFPointsCollection Class Events
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFPointsCollection Class

For a list of all members of this type, see PDFPointsCollection members.

Public Events

 | Name | Description
Public Event | CollectionChanged | Occurs when the collection changes.
Top

See Also

Reference

PDFPointsCollection Class
O2S.Components.PDF4NET.Annotations Namespace


CollectionChanged Event

CollectionChanged Event
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFPointsCollection Class : CollectionChanged Event

Occurs when the collection changes.

Syntax

Visual Basic (Declaration)
Public Event CollectionChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As PDFPointsCollection
Dim handler As EventHandler

AddHandler instance.CollectionChanged, handler
C#
public event EventHandler CollectionChanged()
Managed Extensions for C++
public: __event EventHandler* CollectionChanged();
C++/CLI
public:
event EventHandler^ CollectionChanged();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPointsCollection Class
PDFPointsCollection Members


PDFRectangleAnnotation Class

PDFRectangleAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFRectangleAnnotation Class

Defines a rectangle (Square) annotation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFRectangleAnnotation
   Inherits PDFSCAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangleAnnotation
C#
public class PDFRectangleAnnotation : PDFSCAnnotation
Managed Extensions for C++
public __gc class PDFRectangleAnnotation : public PDFSCAnnotation
C++/CLI
public ref class PDFRectangleAnnotation : public PDFSCAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFSCAnnotation
O2S.Components.PDF4NET.Annotations.PDFRectangleAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangleAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFRectangleAnnotation Class Members

PDFRectangleAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFRectangleAnnotation Class

The following tables list the members exposed by PDFRectangleAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFRectangleAnnotation Constructor | Overloaded. Initializes a new PDFRectangleAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border. (Inherited from PDFSCAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color. (Inherited from PDFSCAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFRectangleAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFRectangleAnnotation Constructor

PDFRectangleAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFRectangleAnnotation Class : PDFRectangleAnnotation Constructor

Initializes a new PDFRectangleAnnotation object.

Overload List

Overload | Description
PDFRectangleAnnotation Constructor() | Initializes a new PDFRectangleAnnotation object.
PDFRectangleAnnotation Constructor(String,String) | Initializes a new PDFRectangleAnnotation object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangleAnnotation Class
PDFRectangleAnnotation Members


PDFRectangleAnnotation Constructor()

PDFRectangleAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFRectangleAnnotation Class > PDFRectangleAnnotation Constructor : PDFRectangleAnnotation Constructor()

Initializes a new PDFRectangleAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFRectangleAnnotation()
C#
public PDFRectangleAnnotation()
Managed Extensions for C++
public: PDFRectangleAnnotation();
C++/CLI
public:
PDFRectangleAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangleAnnotation Class
PDFRectangleAnnotation Members
Overload List


PDFRectangleAnnotation Constructor(String,String)

PDFRectangleAnnotation Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFRectangleAnnotation Class > PDFRectangleAnnotation Constructor : PDFRectangleAnnotation Constructor(String,String)

author
The author of the annotation.
contents
The content of the annotation.
Initializes a new PDFRectangleAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim author As String
Dim contents As String

Dim instance As PDFRectangleAnnotation(author, contents)
C#
public PDFRectangleAnnotation(
   string author,
   string contents
)
Managed Extensions for C++
public: PDFRectangleAnnotation(
   string* author,
   string* contents
)
C++/CLI
public:
PDFRectangleAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRectangleAnnotation Class
PDFRectangleAnnotation Members
Overload List


PDFRubberStampAnnotation Class

PDFRubberStampAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFRubberStampAnnotation Class

Defines a rubber stamp annotation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFRubberStampAnnotation
   Inherits PDFBaseMarkupAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFRubberStampAnnotation
C#
public class PDFRubberStampAnnotation : PDFBaseMarkupAnnotation
Managed Extensions for C++
public __gc class PDFRubberStampAnnotation : public PDFBaseMarkupAnnotation
C++/CLI
public ref class PDFRubberStampAnnotation : public PDFBaseMarkupAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFRubberStampAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRubberStampAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFRubberStampAnnotation Class Members

PDFRubberStampAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFRubberStampAnnotation Class

The following tables list the members exposed by PDFRubberStampAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFRubberStampAnnotation Constructor | Overloaded. Initializes a new PDFRubberStampAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | Icon |
Public Property | IconName | Gets or sets the icon name.
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFRubberStampAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFRubberStampAnnotation Constructor

PDFRubberStampAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFRubberStampAnnotation Class : PDFRubberStampAnnotation Constructor

Initializes a new PDFRubberStampAnnotation object.

Overload List

Overload | Description
PDFRubberStampAnnotation Constructor() | Initializes a new PDFRubberStampAnnotation object.
PDFRubberStampAnnotation Constructor(String,String) | Initializes a new PDFRubberStampAnnotation object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRubberStampAnnotation Class
PDFRubberStampAnnotation Members


PDFRubberStampAnnotation Constructor()

PDFRubberStampAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFRubberStampAnnotation Class > PDFRubberStampAnnotation Constructor : PDFRubberStampAnnotation Constructor()

Initializes a new PDFRubberStampAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFRubberStampAnnotation()
C#
public PDFRubberStampAnnotation()
Managed Extensions for C++
public: PDFRubberStampAnnotation();
C++/CLI
public:
PDFRubberStampAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRubberStampAnnotation Class
PDFRubberStampAnnotation Members
Overload List


PDFRubberStampAnnotation Constructor(String,String)

PDFRubberStampAnnotation Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFRubberStampAnnotation Class > PDFRubberStampAnnotation Constructor : PDFRubberStampAnnotation Constructor(String,String)

author
The author of the annotation.
contents
The content of the annotation.
Initializes a new PDFRubberStampAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim author As String
Dim contents As String

Dim instance As PDFRubberStampAnnotation(author, contents)
C#
public PDFRubberStampAnnotation(
   string author,
   string contents
)
Managed Extensions for C++
public: PDFRubberStampAnnotation(
   string* author,
   string* contents
)
C++/CLI
public:
PDFRubberStampAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRubberStampAnnotation Class
PDFRubberStampAnnotation Members
Overload List


PDFRubberStampAnnotation Class Properties

PDFRubberStampAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFRubberStampAnnotation Class

For a list of all members of this type, see PDFRubberStampAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | Icon |
Public Property | IconName | Gets or sets the icon name.
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFRubberStampAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Appearance Property

Appearance Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFRubberStampAnnotation Class : Appearance Property

Gets or sets the annotation appearance.

Syntax

Visual Basic (Declaration)
Overrides Public Property Appearance As PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFRubberStampAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
C#
public override PDFAnnotationAppearance Appearance {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationAppearance* get_Appearance()override ;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
)override ;
C++/CLI
public:
property PDFAnnotationAppearance^ Appearance override {
   PDFAnnotationAppearance^ get();
   void set (PDFAnnotationAppearance^ value);
}

Return Value

The appearance of the stamp.

Remarks

When this property is set to a valid appearance, the Icon is set to PDFRubberStampAnnotationIcon.Custom and the IconName is set to "Custom". If you want to use your custom icon name, make sure you set the IconName property after this property is set.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRubberStampAnnotation Class
PDFRubberStampAnnotation Members


Icon Property

Icon Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFRubberStampAnnotation Class : Icon Property

Syntax

Visual Basic (Declaration)
Public Property Icon As PDFRubberStampAnnotationIcon
Visual Basic (Usage) Copy Code
Dim instance As PDFRubberStampAnnotation
Dim value As PDFRubberStampAnnotationIcon

instance.Icon = value

value = instance.Icon
C#
public PDFRubberStampAnnotationIcon Icon {get; set;}
Managed Extensions for C++
public: __property PDFRubberStampAnnotationIcon get_Icon();
public: __property void set_Icon(
   PDFRubberStampAnnotationIcon value
);
C++/CLI
public:
property PDFRubberStampAnnotationIcon Icon {
   PDFRubberStampAnnotationIcon get();
   void set (PDFRubberStampAnnotationIcon value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRubberStampAnnotation Class
PDFRubberStampAnnotation Members


IconName Property

IconName Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFRubberStampAnnotation Class : IconName Property

Gets or sets the icon name.

Syntax

Visual Basic (Declaration)
Public Property IconName As String
Visual Basic (Usage) Copy Code
Dim instance As PDFRubberStampAnnotation
Dim value As String

instance.IconName = value

value = instance.IconName
C#
public string IconName {get; set;}
Managed Extensions for C++
public: __property string* get_IconName();
public: __property void set_IconName(
   string* value
);
C++/CLI
public:
property String^ IconName {
   String^ get();
   void set (String^ value);
}

Return Value

The name of the stamp's icon.

Exceptions

Exception | Description
ArgumentNullException | Thrown when the property value is null or empty.

Remarks

This property lets you set a custom name for your user defined stamp appearances.
If the Icon property to any of the PDFStampAnnotationIcon enum values, the IconName property will be set automatically to the corresponding string value. If the IconName property to a predefined icon name (names available in PDFRubberStampAnnotationIcon enumeration), the Icon property will be set accordingly, otherwise the Icon property will be set to PDFRubberStampAnnotationIcon.Custom

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRubberStampAnnotation Class
PDFRubberStampAnnotation Members


PDFSCAnnotation Class

PDFSCAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFSCAnnotation Class

Defines the base class for rectangle (Square) and ellipse (Circle) annotations.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSCAnnotation
   Inherits PDFBaseMarkupAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFSCAnnotation
C#
public class PDFSCAnnotation : PDFBaseMarkupAnnotation
Managed Extensions for C++
public __gc class PDFSCAnnotation : public PDFBaseMarkupAnnotation
C++/CLI
public ref class PDFSCAnnotation : public PDFBaseMarkupAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFSCAnnotation
O2S.Components.PDF4NET.Annotations.PDFRectangleAnnotation
O2S.Components.PDF4NET.Annotations.PDFEllipseAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSCAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFSCAnnotation Class Members

PDFSCAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFSCAnnotation Class

The following tables list the members exposed by PDFSCAnnotation.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFSCAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFSCAnnotation Class Properties

PDFSCAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFSCAnnotation Class

For a list of all members of this type, see PDFSCAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border.
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFSCAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Border Property

Border Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFSCAnnotation Class : Border Property

Gets or sets the annotation border.

Syntax

Visual Basic (Declaration)
Public Property Border As PDFAnnotationBorder
Visual Basic (Usage) Copy Code
Dim instance As PDFSCAnnotation
Dim value As PDFAnnotationBorder

instance.Border = value

value = instance.Border
C#
public PDFAnnotationBorder Border {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationBorder* get_Border();
public: __property void set_Border(
   PDFAnnotationBorder* value
);
C++/CLI
public:
property PDFAnnotationBorder^ Border {
   PDFAnnotationBorder^ get();
   void set (PDFAnnotationBorder^ value);
}

Return Value

The annotation border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSCAnnotation Class
PDFSCAnnotation Members


InteriorColor Property

InteriorColor Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFSCAnnotation Class : InteriorColor Property

Gets or sets the annotation's interior color.

Syntax

Visual Basic (Declaration)
Public Property InteriorColor As PDFDeviceColor
Visual Basic (Usage) Copy Code
Dim instance As PDFSCAnnotation
Dim value As PDFDeviceColor

instance.InteriorColor = value

value = instance.InteriorColor
C#
public PDFDeviceColor InteriorColor {get; set;}
Managed Extensions for C++
public: __property PDFDeviceColor* get_InteriorColor();
public: __property void set_InteriorColor(
   PDFDeviceColor* value
);
C++/CLI
public:
property PDFDeviceColor^ InteriorColor {
   PDFDeviceColor^ get();
   void set (PDFDeviceColor^ value);
}

Return Value

The annotation interior color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSCAnnotation Class
PDFSCAnnotation Members


PDFSquigglyAnnotation Class

PDFSquigglyAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFSquigglyAnnotation Class

Defines a squiggly annotation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSquigglyAnnotation
   Inherits PDFTextMarkupAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFSquigglyAnnotation
C#
public class PDFSquigglyAnnotation : PDFTextMarkupAnnotation
Managed Extensions for C++
public __gc class PDFSquigglyAnnotation : public PDFTextMarkupAnnotation
C++/CLI
public ref class PDFSquigglyAnnotation : public PDFTextMarkupAnnotation

Remarks

This annotation is used to underline text in a document with a jagged line.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFSquigglyAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSquigglyAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFSquigglyAnnotation Class Members

PDFSquigglyAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFSquigglyAnnotation Class

The following tables list the members exposed by PDFSquigglyAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFSquigglyAnnotation Constructor | Overloaded. Initializes a new PDFSquigglyAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from PDFTextMarkupAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFSquigglyAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFSquigglyAnnotation Constructor

PDFSquigglyAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFSquigglyAnnotation Class : PDFSquigglyAnnotation Constructor

Initializes a new PDFSquigglyAnnotation object.

Overload List

Overload | Description
PDFSquigglyAnnotation Constructor() | Initializes a new PDFSquigglyAnnotation object.
PDFSquigglyAnnotation Constructor(String,String) | Initializes a new PDFSquigglyAnnotation object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSquigglyAnnotation Class
PDFSquigglyAnnotation Members


PDFSquigglyAnnotation Constructor()

PDFSquigglyAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFSquigglyAnnotation Class > PDFSquigglyAnnotation Constructor : PDFSquigglyAnnotation Constructor()

Initializes a new PDFSquigglyAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSquigglyAnnotation()
C#
public PDFSquigglyAnnotation()
Managed Extensions for C++
public: PDFSquigglyAnnotation();
C++/CLI
public:
PDFSquigglyAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSquigglyAnnotation Class
PDFSquigglyAnnotation Members
Overload List


PDFSquigglyAnnotation Constructor(String,String)

PDFSquigglyAnnotation Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFSquigglyAnnotation Class > PDFSquigglyAnnotation Constructor : PDFSquigglyAnnotation Constructor(String,String)

author
The author of the annotation.
contents
The content of the annotation.
Initializes a new PDFSquigglyAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim author As String
Dim contents As String

Dim instance As PDFSquigglyAnnotation(author, contents)
C#
public PDFSquigglyAnnotation(
   string author,
   string contents
)
Managed Extensions for C++
public: PDFSquigglyAnnotation(
   string* author,
   string* contents
)
C++/CLI
public:
PDFSquigglyAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSquigglyAnnotation Class
PDFSquigglyAnnotation Members
Overload List


PDFStrikeOutAnnotation Class

PDFStrikeOutAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFStrikeOutAnnotation Class

Defines a strike out annotation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFStrikeOutAnnotation
   Inherits PDFTextMarkupAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFStrikeOutAnnotation
C#
public class PDFStrikeOutAnnotation : PDFTextMarkupAnnotation
Managed Extensions for C++
public __gc class PDFStrikeOutAnnotation : public PDFTextMarkupAnnotation
C++/CLI
public ref class PDFStrikeOutAnnotation : public PDFTextMarkupAnnotation

Remarks

This annotation is used to strike out text in a document.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFStrikeOutAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFStrikeOutAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFStrikeOutAnnotation Class Members

PDFStrikeOutAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFStrikeOutAnnotation Class

The following tables list the members exposed by PDFStrikeOutAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFStrikeOutAnnotation Constructor | Overloaded. Initializes a new PDFStrikeOutAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from PDFTextMarkupAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFStrikeOutAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFStrikeOutAnnotation Constructor

PDFStrikeOutAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFStrikeOutAnnotation Class : PDFStrikeOutAnnotation Constructor

Initializes a new PDFStrikeOutAnnotation object.

Overload List

Overload | Description
PDFStrikeOutAnnotation Constructor() | Initializes a new PDFStrikeOutAnnotation object.
PDFStrikeOutAnnotation Constructor(String,String) | Initializes a new PDFStrikeOutAnnotation object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFStrikeOutAnnotation Class
PDFStrikeOutAnnotation Members


PDFStrikeOutAnnotation Constructor()

PDFStrikeOutAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFStrikeOutAnnotation Class > PDFStrikeOutAnnotation Constructor : PDFStrikeOutAnnotation Constructor()

Initializes a new PDFStrikeOutAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFStrikeOutAnnotation()
C#
public PDFStrikeOutAnnotation()
Managed Extensions for C++
public: PDFStrikeOutAnnotation();
C++/CLI
public:
PDFStrikeOutAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFStrikeOutAnnotation Class
PDFStrikeOutAnnotation Members
Overload List


PDFStrikeOutAnnotation Constructor(String,String)

PDFStrikeOutAnnotation Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFStrikeOutAnnotation Class > PDFStrikeOutAnnotation Constructor : PDFStrikeOutAnnotation Constructor(String,String)

author
The author of the annotation.
contents
The content of the annotation.
Initializes a new PDFStrikeOutAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim author As String
Dim contents As String

Dim instance As PDFStrikeOutAnnotation(author, contents)
C#
public PDFStrikeOutAnnotation(
   string author,
   string contents
)
Managed Extensions for C++
public: PDFStrikeOutAnnotation(
   string* author,
   string* contents
)
C++/CLI
public:
PDFStrikeOutAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFStrikeOutAnnotation Class
PDFStrikeOutAnnotation Members
Overload List


PDFTextAnnotation Class

PDFTextAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFTextAnnotation Class

Defines a text annotation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFTextAnnotation
   Inherits PDFBaseMarkupAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFTextAnnotation
C#
public class PDFTextAnnotation : PDFBaseMarkupAnnotation
Managed Extensions for C++
public __gc class PDFTextAnnotation : public PDFBaseMarkupAnnotation
C++/CLI
public ref class PDFTextAnnotation : public PDFBaseMarkupAnnotation

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFTextAnnotation Class Members

PDFTextAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFTextAnnotation Class

The following tables list the members exposed by PDFTextAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFTextAnnotation Constructor | Overloaded. Initializes a new PDFTextAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | Icon | Gets or sets the annotation icon.
Public Property | IconName | Gets or sets the icon name.
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Open | Gets or sets whether the annotation should initially be displayed open.
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | State | Gets or sets the annotation state.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFTextAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFTextAnnotation Constructor

PDFTextAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class : PDFTextAnnotation Constructor

Initializes a new PDFTextAnnotation object.

Overload List

Overload | Description
PDFTextAnnotation Constructor() | Initializes a new PDFTextAnnotation object.
PDFTextAnnotation Constructor(String,String) | Initializes a new PDFTextAnnotation object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


PDFTextAnnotation Constructor()

PDFTextAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class > PDFTextAnnotation Constructor : PDFTextAnnotation Constructor()

Initializes a new PDFTextAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFTextAnnotation()
C#
public PDFTextAnnotation()
Managed Extensions for C++
public: PDFTextAnnotation();
C++/CLI
public:
PDFTextAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members
Overload List


PDFTextAnnotation Constructor(String,String)

PDFTextAnnotation Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class > PDFTextAnnotation Constructor : PDFTextAnnotation Constructor(String,String)

author
The author of the annotation.
contents
The content of the annotation.
Initializes a new PDFTextAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim author As String
Dim contents As String

Dim instance As PDFTextAnnotation(author, contents)
C#
public PDFTextAnnotation(
   string author,
   string contents
)
Managed Extensions for C++
public: PDFTextAnnotation(
   string* author,
   string* contents
)
C++/CLI
public:
PDFTextAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members
Overload List


PDFTextAnnotation Class Properties

PDFTextAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFTextAnnotation Class

For a list of all members of this type, see PDFTextAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the annotation appearance.
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | Icon | Gets or sets the annotation icon.
Public Property | IconName | Gets or sets the icon name.
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Open | Gets or sets whether the annotation should initially be displayed open.
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | State | Gets or sets the annotation state.
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFTextAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


Appearance Property

Appearance Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class : Appearance Property

Gets or sets the annotation appearance.

Syntax

Visual Basic (Declaration)
Overrides Public Property Appearance As PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFTextAnnotation
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
C#
public override PDFAnnotationAppearance Appearance {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationAppearance* get_Appearance()override ;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
)override ;
C++/CLI
public:
property PDFAnnotationAppearance^ Appearance override {
   PDFAnnotationAppearance^ get();
   void set (PDFAnnotationAppearance^ value);
}

Return Value

The appearance of the text annotation icon.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


Icon Property

Icon Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class : Icon Property

Gets or sets the annotation icon.

Syntax

Visual Basic (Declaration)
Public Property Icon As PDFTextAnnotationIcon
Visual Basic (Usage) Copy Code
Dim instance As PDFTextAnnotation
Dim value As PDFTextAnnotationIcon

instance.Icon = value

value = instance.Icon
C#
public PDFTextAnnotationIcon Icon {get; set;}
Managed Extensions for C++
public: __property PDFTextAnnotationIcon get_Icon();
public: __property void set_Icon(
   PDFTextAnnotationIcon value
);
C++/CLI
public:
property PDFTextAnnotationIcon Icon {
   PDFTextAnnotationIcon get();
   void set (PDFTextAnnotationIcon value);
}

Return Value

The icon to be displayed for the annotation.

Remarks

If the Icon property to any of the PDFTextAnnotationIcon enum values, the IconName property will be set automatically to the corresponding string value. If the IconName property to a predefined icon name (names available in PDFTextAnnotationIcon enumeration), the Icon property will be set accordingly, otherwise the Icon property will be set to PDFTextAnnotationIcon.Custom

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


IconName Property

IconName Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class : IconName Property

Gets or sets the icon name.

Syntax

Visual Basic (Declaration)
Public Property IconName As String
Visual Basic (Usage) Copy Code
Dim instance As PDFTextAnnotation
Dim value As String

instance.IconName = value

value = instance.IconName
C#
public string IconName {get; set;}
Managed Extensions for C++
public: __property string* get_IconName();
public: __property void set_IconName(
   string* value
);
C++/CLI
public:
property String^ IconName {
   String^ get();
   void set (String^ value);
}

Return Value

The name of the stamp's icon.

Exceptions

Exception | Description
ArgumentNullException | Thrown when the property value is null or empty.

Remarks

This property lets you set a custom name for your user defined stamp appearances.
If the Icon property to any of the PDFTextAnnotationIcon enum values, the IconName property will be set automatically to the corresponding string value. If the IconName property to a predefined icon name (names available in PDFTextAnnotationIcon enumeration), the Icon property will be set accordingly, otherwise the Icon property will be set to PDFTextAnnotationIcon.Custom

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


Open Property

Open Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class : Open Property

Gets or sets whether the annotation should initially be displayed open.

Syntax

Visual Basic (Declaration)
Public Property Open As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextAnnotation
Dim value As Boolean

instance.Open = value

value = instance.Open
C#
public bool Open {get; set;}
Managed Extensions for C++
public: __property bool get_Open();
public: __property void set_Open(
   bool value
);
C++/CLI
public:
property bool Open {
   bool get();
   void set (bool value);
}

Return Value

True if the annotation should initially be displayed open. Default: false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


State Property

State Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFTextAnnotation Class : State Property

Gets or sets the annotation state.

Syntax

Visual Basic (Declaration)
Public Property State As PDFTextAnnotationState
Visual Basic (Usage) Copy Code
Dim instance As PDFTextAnnotation
Dim value As PDFTextAnnotationState

instance.State = value

value = instance.State
C#
public PDFTextAnnotationState State {get; set;}
Managed Extensions for C++
public: __property PDFTextAnnotationState get_State();
public: __property void set_State(
   PDFTextAnnotationState value
);
C++/CLI
public:
property PDFTextAnnotationState State {
   PDFTextAnnotationState get();
   void set (PDFTextAnnotationState value);
}

Return Value

The state of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextAnnotation Class
PDFTextAnnotation Members


PDFTextMarkupAnnotation Class

PDFTextMarkupAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFTextMarkupAnnotation Class

Defines a text markup annotation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFTextMarkupAnnotation
   Inherits PDFBaseMarkupAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFTextMarkupAnnotation
C#
public class PDFTextMarkupAnnotation : PDFBaseMarkupAnnotation
Managed Extensions for C++
public __gc class PDFTextMarkupAnnotation : public PDFBaseMarkupAnnotation
C++/CLI
public ref class PDFTextMarkupAnnotation : public PDFBaseMarkupAnnotation

Remarks

Text markup annotations appear as highlights, underlines, strikeouts or jagged (squiggly) underlines in the text of a document.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFUnderlineAnnotation
O2S.Components.PDF4NET.Annotations.PDFStrikeOutAnnotation
O2S.Components.PDF4NET.Annotations.PDFSquigglyAnnotation
O2S.Components.PDF4NET.Annotations.PDFHighlightAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextMarkupAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFTextMarkupAnnotation Class Members

PDFTextMarkupAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFTextMarkupAnnotation Class

The following tables list the members exposed by PDFTextMarkupAnnotation.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | QuadPoints | Gets or sets the points that define the markup area.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFTextMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFTextMarkupAnnotation Class Properties

PDFTextMarkupAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFTextMarkupAnnotation Class

For a list of all members of this type, see PDFTextMarkupAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Overridden. Gets or sets the annotation rectangle in PDF coordinates.
Public Property | QuadPoints | Gets or sets the points that define the markup area.
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFTextMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


MarkupType Property

MarkupType Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFTextMarkupAnnotation Class : MarkupType Property

Gets or sets the type of the annotation markup.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property MarkupType As PDFTextMarkupType
Visual Basic (Usage) Copy Code
Dim instance As PDFTextMarkupAnnotation
Dim value As PDFTextMarkupType

value = instance.MarkupType
C#
public virtual PDFTextMarkupType MarkupType {get;}
Managed Extensions for C++
public: __property virtual PDFTextMarkupType get_MarkupType();
C++/CLI
public:
virtual property PDFTextMarkupType MarkupType {
   PDFTextMarkupType get();
}

Return Value

The type of the text markup.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextMarkupAnnotation Class
PDFTextMarkupAnnotation Members


PDFRectangle Property

PDFRectangle Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFTextMarkupAnnotation Class : PDFRectangle Property

Gets or sets the annotation rectangle in PDF coordinates.

Syntax

Visual Basic (Declaration)
Overrides Public Property PDFRectangle As PDFRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFTextMarkupAnnotation
Dim value As PDFRectangle

instance.PDFRectangle = value

value = instance.PDFRectangle
C#
public override PDFRectangle PDFRectangle {get; set;}
Managed Extensions for C++
public: __property PDFRectangle* get_PDFRectangle()override ;
public: __property void set_PDFRectangle(
   PDFRectangle* value
)override ;
C++/CLI
public:
property PDFRectangle^ PDFRectangle override {
   PDFRectangle^ get();
   void set (PDFRectangle^ value);
}

Return Value

The annotation rectangle specified in the default PDF coordinate system.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextMarkupAnnotation Class
PDFTextMarkupAnnotation Members


QuadPoints Property

QuadPoints Property
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFTextMarkupAnnotation Class : QuadPoints Property

Gets or sets the points that define the markup area.

Syntax

Visual Basic (Declaration)
Public Property QuadPoints As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFTextMarkupAnnotation
Dim value() As Double

instance.QuadPoints = value

value = instance.QuadPoints
C#
public double[] QuadPoints {get; set;}
Managed Extensions for C++
public: __property double[]* get_QuadPoints();
public: __property void set_QuadPoints(
   double[]* value
);
C++/CLI
public:
property array<double>^ QuadPoints {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of points the define the location of the markup within the annotation.

Remarks

The array must include 8*n values representing the coordinates (x, y)of n quadrilaters. The coordinates for each quadrilateral are given in the order x1 y1 x2 y2 x3 y3 x4 y4 specifying the quadrilater's 4 vertices in counterclockwise order.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextMarkupAnnotation Class
PDFTextMarkupAnnotation Members


PDFUnderlineAnnotation Class

PDFUnderlineAnnotation Class
See Also Members
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFUnderlineAnnotation Class

Defines an underline annotation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFUnderlineAnnotation
   Inherits PDFTextMarkupAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFUnderlineAnnotation
C#
public class PDFUnderlineAnnotation : PDFTextMarkupAnnotation
Managed Extensions for C++
public __gc class PDFUnderlineAnnotation : public PDFTextMarkupAnnotation
C++/CLI
public ref class PDFUnderlineAnnotation : public PDFTextMarkupAnnotation

Remarks

This annotation is used to underline text in a document.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Annotations.PDFBaseMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFTextMarkupAnnotation
O2S.Components.PDF4NET.Annotations.PDFUnderlineAnnotation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnderlineAnnotation Members
O2S.Components.PDF4NET.Annotations Namespace


PDFUnderlineAnnotation Class Members

PDFUnderlineAnnotation Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFUnderlineAnnotation Class

The following tables list the members exposed by PDFUnderlineAnnotation.

Public Constructors

 | Name | Description
Public Constructor | PDFUnderlineAnnotation Constructor | Overloaded. Initializes a new PDFUnderlineAnnotation object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from PDFTextMarkupAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFUnderlineAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFUnderlineAnnotation Constructor

PDFUnderlineAnnotation Constructor
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFUnderlineAnnotation Class : PDFUnderlineAnnotation Constructor

Initializes a new PDFUnderlineAnnotation object.

Overload List

Overload | Description
PDFUnderlineAnnotation Constructor() | Initializes a new PDFUnderlineAnnotation object.
PDFUnderlineAnnotation Constructor(String,String) | Initializes a new PDFUnderlineAnnotation object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnderlineAnnotation Class
PDFUnderlineAnnotation Members


PDFUnderlineAnnotation Constructor()

PDFUnderlineAnnotation Constructor()
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFUnderlineAnnotation Class > PDFUnderlineAnnotation Constructor : PDFUnderlineAnnotation Constructor()

Initializes a new PDFUnderlineAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFUnderlineAnnotation()
C#
public PDFUnderlineAnnotation()
Managed Extensions for C++
public: PDFUnderlineAnnotation();
C++/CLI
public:
PDFUnderlineAnnotation();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnderlineAnnotation Class
PDFUnderlineAnnotation Members
Overload List


PDFUnderlineAnnotation Constructor(String,String)

PDFUnderlineAnnotation Constructor(String,String)
See Also
[image]
O2S.Components.PDF4NET.Annotations Namespace > PDFUnderlineAnnotation Class > PDFUnderlineAnnotation Constructor : PDFUnderlineAnnotation Constructor(String,String)

author
The author of the annotation.
contents
The content of the annotation.
Initializes a new PDFUnderlineAnnotation object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal author As String, _
   ByVal contents As String _
)
Visual Basic (Usage) Copy Code
Dim author As String
Dim contents As String

Dim instance As PDFUnderlineAnnotation(author, contents)
C#
public PDFUnderlineAnnotation(
   string author,
   string contents
)
Managed Extensions for C++
public: PDFUnderlineAnnotation(
   string* author,
   string* contents
)
C++/CLI
public:
PDFUnderlineAnnotation(
   String^ author,
   String^ contents
)

Parameters

author
The author of the annotation.
contents
The content of the annotation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnderlineAnnotation Class
PDFUnderlineAnnotation Members
Overload List


PDF3DActivationMode Enumeration

PDF3DActivationMode Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DActivationMode Enumeration

Specifies the available modes for activating a 3D annotation.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DActivationMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivationMode
C#
public enum PDF3DActivationMode : Enum
Managed Extensions for C++
__value public enum PDF3DActivationMode : public Enum
C++/CLI
public enum class PDF3DActivationMode : public Enum

Members

Member | Description
PageOpen | The annotation should be activated as soon as the page containing the annotation is opened.
PageVisible | The annotation should be activated as soon as any part of the page containing the annotation becomes visible.
ExplicitActivation | The annotation should remain inactive until explicitly activated by a script or user action.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DActivationMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDF3DActivationState Enumeration

PDF3DActivationState Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DActivationState Enumeration

Specifies the available states upon activation of the 3D annotation.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DActivationState
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DActivationState
C#
public enum PDF3DActivationState : Enum
Managed Extensions for C++
__value public enum PDF3DActivationState : public Enum
C++/CLI
public enum class PDF3DActivationState : public Enum

Members

Member | Description
Instantiated | The artwork is instantiated, but real-time script-driven animations are disabled.
Live | Real-time script-driven animations are enabled if present; if not, the artwork is instantiated.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DActivationState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDF3DAnimationType Enumeration

PDF3DAnimationType Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnimationType Enumeration

Specifies the available styles for applying light to 3D artwork.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DAnimationType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DAnimationType
C#
public enum PDF3DAnimationType : Enum
Managed Extensions for C++
__value public enum PDF3DAnimationType : public Enum
C++/CLI
public enum class PDF3DAnimationType : public Enum

Members

Member | Description
None | Animations are driven through alternate means, such as JavaScript.
Linear | Keyframe animations are driven linearly from beginning to end.
Oscillating | Keyframe animations should oscillate along their time range.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DAnimationType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDF3DDeactivationMode Enumeration

PDF3DDeactivationMode Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DDeactivationMode Enumeration

Specifies the available modes for activating a 3D annotation.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DDeactivationMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DDeactivationMode
C#
public enum PDF3DDeactivationMode : Enum
Managed Extensions for C++
__value public enum PDF3DDeactivationMode : public Enum
C++/CLI
public enum class PDF3DDeactivationMode : public Enum

Members

Member | Description
PageClose | The annotation should be deactivated as soon as the page is closed.
PageInvisible | The annotation should be deactivated as soon as the page containing the annotation becomes invisible.
ExplicitDeactivation | The annotation should remain active until explicitly deactivated by a script or user action.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DDeactivationMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDF3DDeactivationState Enumeration

PDF3DDeactivationState Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DDeactivationState Enumeration

Specifies the available states upon deactivation of the 3D annotation.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DDeactivationState
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DDeactivationState
C#
public enum PDF3DDeactivationState : Enum
Managed Extensions for C++
__value public enum PDF3DDeactivationState : public Enum
C++/CLI
public enum class PDF3DDeactivationState : public Enum

Members

Member | Description
Uninstantiated | The artwork is uninstantiated.
Instantiated | The artwork remains instantiated.
Live | The artwork remains live.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DDeactivationState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDF3DLightingStyle Enumeration

PDF3DLightingStyle Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DLightingStyle Enumeration

Specifies the available styles for applying light to 3D artwork.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DLightingStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DLightingStyle
C#
public enum PDF3DLightingStyle : Enum
Managed Extensions for C++
__value public enum PDF3DLightingStyle : public Enum
C++/CLI
public enum class PDF3DLightingStyle : public Enum

Members

Member | Description
Artwork | Lights as specified in the 3D artwork.
None | No lights are used.
White | Three blue-grey infinite lights, no ambient term.
Day | Three light-grey infinite lights, no ambient term.
Night | One yellow, one aqua, and one blue infinite light, no ambient term.
Hard | Three grey infinite lights, moderate ambient term.
Primary | One red, one green, and one blue infinite light, no ambient term.
Blue | Three blue infinite lights, no ambient term.
Red | Three red infinite lights, no ambient term.
Cube | Six grey infinite lights aligned with the major axes, no ambient term.
CAD | Three grey infinite lights and one light attached to the camera, no ambient term.
Headlamp | Single infinite light attached to the camera, low ambient term.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DLightingStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDF3DProjectionClipStyle Enumeration

PDF3DProjectionClipStyle Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjectionClipStyle Enumeration

Specifies the available styles for the projection clipping.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DProjectionClipStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjectionClipStyle
C#
public enum PDF3DProjectionClipStyle : Enum
Managed Extensions for C++
__value public enum PDF3DProjectionClipStyle : public Enum
C++/CLI
public enum class PDF3DProjectionClipStyle : public Enum

Members

Member | Description
ExplicitNearFar | Explicit near/far.
AutomaticNearFar | Automatic near/far.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DProjectionClipStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDF3DProjectionOrthoScaleMode Enumeration

PDF3DProjectionOrthoScaleMode Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjectionOrthoScaleMode Enumeration

Specifies the available scaling modes for orthographic projections.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DProjectionOrthoScaleMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjectionOrthoScaleMode
C#
public enum PDF3DProjectionOrthoScaleMode : Enum
Managed Extensions for C++
__value public enum PDF3DProjectionOrthoScaleMode : public Enum
C++/CLI
public enum class PDF3DProjectionOrthoScaleMode : public Enum

Members

Member | Description
Width | Fit width.
Height | Fit height.
Min | Fit min between width and height.
Max | Fit max between width and height.
Absolute | No scaling.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DProjectionOrthoScaleMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDF3DProjectionType Enumeration

PDF3DProjectionType Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DProjectionType Enumeration

Specifies the available types for the projection of 3D artwork.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DProjectionType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DProjectionType
C#
public enum PDF3DProjectionType : Enum
Managed Extensions for C++
__value public enum PDF3DProjectionType : public Enum
C++/CLI
public enum class PDF3DProjectionType : public Enum

Members

Member | Description
Orthographic | Orthographic projection.
Perspective | Perspective projection.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DProjectionType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDF3DRenderStyle Enumeration

PDF3DRenderStyle Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DRenderStyle Enumeration

Specifies the available styles for rendering the 3D artwork.

Syntax

Visual Basic (Declaration)
Public Enum PDF3DRenderStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF3DRenderStyle
C#
public enum PDF3DRenderStyle : Enum
Managed Extensions for C++
__value public enum PDF3DRenderStyle : public Enum
C++/CLI
public enum class PDF3DRenderStyle : public Enum

Members

Member | Description
Solid | Displays textured and lit geometric shapes. The auxiliary color is ignored.
SolidWireframe | Displays textured and lit geometric shapes (triangles) with single color edges on top of them. The color of these edges is determined by the auxiliary color.
Transparent | Displays textured and lit geometric shapes (triangles) with an added level of transparency. The auxiliary color is ignored.
TransparentWireframe | Displays textured and lit geometric shapes (triangles) with an added level of transparency, with single color opaque edges on top of it. The color of these edges is determined by the auxiliary color.
BoundingBox | Displays the bounding box edges of each node. The color of the bounding box edges is determined by the auxiliary color.
TransparentBoundingBox | Displays bounding boxes faces of each node with an added level of transparency. The color of the bounding box faces is determined by the face color.
TransparentBoundingBoxOutline | Displays bounding boxes edges and faces of each node with an added level of transparency. The color of the bounding box edges is determined by the auxiliary color. The color of the bounding boxes faces is determined by the face color.
Wireframe | Displays only edges in a single color. The color of these edges is determined by the auxiliary color.
ShadedWireframe | Displays only edges and applies lighting. The auxiliary color is ignored.
HiddenWireframe | Displays edges in a single color, though removes back-facing and obscured edges. The color of these edges is determined by the auxiliary color.
Vertices | Displays only vertices in a single color. The color of these points is determined by the auxiliary color.
ShadedVertices | Displays only vertices, though uses their vertex color and applies lighting. The auxiliary color is ignored.
Illustration | Displays silhouette edges with surfaces, removes obscured lines. The color of these edges is determined by the auxiliary color, and the color of the surfaces is determined by the face color.
SolidOutline | Displays silhouette edges with lit and textured surfaces, removes obscured lines. The color of these edges is determined by the auxiliary color.
ShadedIllustration | Displays silhouette edges with lit and textured surfaces and an additional emissive term to remove poorly lit areas of the artwork. The color of these edges is determined by the auxiliary color.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDF3DRenderStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDFAnnotationFlags Enumeration

PDFAnnotationFlags Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationFlags Enumeration

Specifies the available flags for an annotation.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum PDFAnnotationFlags
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotationFlags
C#
[FlagsAttribute()]
public enum PDFAnnotationFlags : Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum PDFAnnotationFlags : public Enum
C++/CLI
[FlagsAttribute()]
public enum class PDFAnnotationFlags : public Enum

Members

Member | Description
Invisible | If set, do not display the annotation if it does not belong to one of the standard annotation types.
Hidden | If set, do not display or print the annotation or allow it to interact with the user.
Print | If set, print the annotation when the page is printed. If clear, never print the annotation, regardless of whether it is displayed on the screen.
NoZoom | If set, do not scale the annotation's appearance to match the magnification of the page.
NoRotate | If set, do not rotate the annotation's appearance to match the rotation of the page.
NoView | If set, do not display the annotation on the screen or allow it to interact with the user. The annotation may be printed (depending on the Print flag), but should be considered hidden for the purposes of onscreen display and user interaction.
ReadOnly | If set, do not allow the annotation to interact with the user.
Locked | If set, do not allow the annotation to be deleted or its properties (including position and size) to be modified by the user. However, this flag does not restrict changes to the annotation’s contents, such as the value of a form field.
ToggleNoView | If set, invert the interpretation of the NoView flag for certain events.
LockedContents | If set, do not allow the contents of the annotation to be modified by the user. This flag does not restrict deletion of the annotation or changes to other annotation properties, such as position and size.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFAnnotationFlags

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDFAnnotationType Enumeration

PDFAnnotationType Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationType Enumeration

Specifies the available types of annotations.

Syntax

Visual Basic (Declaration)
Public Enum PDFAnnotationType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFAnnotationType
C#
public enum PDFAnnotationType : Enum
Managed Extensions for C++
__value public enum PDFAnnotationType : public Enum
C++/CLI
public enum class PDFAnnotationType : public Enum

Members

Member | Description
Unknown | Unknown annotation.
Text | Text annotation.
FreeText | Free text annotation.
Stamp | Stamp annotation.
FileAttachment | File attachment annotation.
Rectangle | Rectangle (Square) annotation.
Ellipse | Ellipse (Circle) annotation.
Line | Line annotation.
Link | Link annotation.
Ink | Ink annotation.
Highlight | Highlight annotation.
Underline | Underline annotation.
StrikeOut | StrikeOut annotation.
Squiggly | Squiggly annotation.
Widget | Field widget annotation.
_3D | 3D annotation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFAnnotationType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDFBorderStyle Enumeration

PDFBorderStyle Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFBorderStyle Enumeration

Specifies the available styles for an annotation's border.

Syntax

Visual Basic (Declaration)
Public Enum PDFBorderStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFBorderStyle
C#
public enum PDFBorderStyle : Enum
Managed Extensions for C++
__value public enum PDFBorderStyle : public Enum
C++/CLI
public enum class PDFBorderStyle : public Enum

Members

Member | Description
Solid | A solid rectangle surrounding the annotation.
Dashed | A dashed rectangle surrounding the annotation.
Beveled | A simulated embossed rectangle that appears to be raised above the surface of the page.
Inset | A simulated engraved rectangle that appears to be recessed below the surface of the page.
Underline | A single line along the bottom of the annotation rectangle.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFBorderStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDFFileAttachmentAnnotationIcon Enumeration

PDFFileAttachmentAnnotationIcon Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFFileAttachmentAnnotationIcon Enumeration

Specifies the available icons for a file attachment annotation.

Syntax

Visual Basic (Declaration)
Public Enum PDFFileAttachmentAnnotationIcon
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFFileAttachmentAnnotationIcon
C#
public enum PDFFileAttachmentAnnotationIcon : Enum
Managed Extensions for C++
__value public enum PDFFileAttachmentAnnotationIcon : public Enum
C++/CLI
public enum class PDFFileAttachmentAnnotationIcon : public Enum

Members

Member | Description
Graph | Graph icon.
Paperclip | Paperclip icon.
PushPin | Push pin icon.
Tag | Tag icon.
Custom | Custom appearance.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFFileAttachmentAnnotationIcon

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDFLineDirection Enumeration

PDFLineDirection Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFLineDirection Enumeration

Specifies the available directions for a line annotation.

Syntax

Visual Basic (Declaration)
Public Enum PDFLineDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFLineDirection
C#
public enum PDFLineDirection : Enum
Managed Extensions for C++
__value public enum PDFLineDirection : public Enum
C++/CLI
public enum class PDFLineDirection : public Enum

Members

Member | Description
TopLeftToBottomRight | Line starts at top left corner and ends at bottom right corner.
BottomLeftToTopRight | Line starts at bottom left corner and ends at top right corner.
TopRightToBottomLeft | Line starts at top right corner and ends at bottom left corner.
BottomRightToTopLeft | Line starts at bottom right corner and ends at top left corner.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFLineDirection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDFLineEndingStyle Enumeration

PDFLineEndingStyle Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFLineEndingStyle Enumeration

Specifies the available line ending styles to be used when drawing a line annotation.

Syntax

Visual Basic (Declaration)
Public Enum PDFLineEndingStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFLineEndingStyle
C#
public enum PDFLineEndingStyle : Enum
Managed Extensions for C++
__value public enum PDFLineEndingStyle : public Enum
C++/CLI
public enum class PDFLineEndingStyle : public Enum

Members

Member | Description
Square | A square filled with annotation's interior color, if any.
Circle | A circle filled with annotation's interior color, if any.
Diamond | A diamond filled with annotation's interior color, if any.
OpenArrow | Two short lines meeting in an acute angle, forming a open arrow head.
ClosedArrow | Two short lines meeting in an acute angle as in the OpenArrow style, connected by a third line to form a triangular closed arrowhead filled with annotation's interior color, if any.
None | No line ending.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFLineEndingStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDFLinkHighlightMode Enumeration

PDFLinkHighlightMode Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFLinkHighlightMode Enumeration

Specifies the available highlighting modes for a link annotation.

Syntax

Visual Basic (Declaration)
Public Enum PDFLinkHighlightMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFLinkHighlightMode
C#
public enum PDFLinkHighlightMode : Enum
Managed Extensions for C++
__value public enum PDFLinkHighlightMode : public Enum
C++/CLI
public enum class PDFLinkHighlightMode : public Enum

Members

Member | Description
None | No highlighting, the link's appearance does not change when the link is activated.
Invert | Inverts the content of link's normal appearance.
Outline | Inverts the link's border.
Push | Displays the link's down appearance.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFLinkHighlightMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDFMovieType Enumeration

PDFMovieType Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFMovieType Enumeration

Specifies the available movie types to be included in a PDF document.

Syntax

Visual Basic (Declaration)
Public Enum PDFMovieType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFMovieType
C#
public enum PDFMovieType : Enum
Managed Extensions for C++
__value public enum PDFMovieType : public Enum
C++/CLI
public enum class PDFMovieType : public Enum

Members

Member | Description
Video_Avi | A video file with video/avi MIME type.
Video_Flc | A video file with video/flc MIME type.
Video_Mp4 | A video file with video/mp4 MIME type.
Video_Mpg | A video file with video/mpg MIME type.
Video_Mpeg | A video file with video/mpeg MIME type.
Video_MsVideo | A video file with video/msvideo MIME type.
Video_QuickTime | A video file with video/quicktime MIME type.
Video_X_Dv | A video file with video/x-dv MIME type.
Video_X_Ivf | A video file with video/x-ivf MIME type.
Video_X_Mpeg | A video file with video/x-mpeg MIME type.
Video_X_Mpg | A video file with video/x-mpg MIME type.
Video_X_Ms_Asf | A video file with video/x-ms-asf MIME type.
Video_X_Ms_Asx | A video file with video/x-ms-asx MIME type.
Video_X_Ms_Wm | A video file with video/x-ms-wm MIME type.
Video_X_Ms_Wmp | A video file with video/x-ms-wmp MIME type.
Video_X_Ms_Wmv | A video file with video/x-ms-wmv MIME type.
Video_X_Ms_Wmx | A video file with video/x-ms-wmx MIME type.
Video_X_Ms_Wvx | A video file with video/x-ms-wvx MIME type.
Video_X_MsVideo | A video file with video/x-msvideo MIME type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFMovieType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDFRubberStampAnnotationIcon Enumeration

PDFRubberStampAnnotationIcon Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFRubberStampAnnotationIcon Enumeration

Specifies the available icons for a stmap annotation.

Syntax

Visual Basic (Declaration)
Public Enum PDFRubberStampAnnotationIcon
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFRubberStampAnnotationIcon
C#
public enum PDFRubberStampAnnotationIcon : Enum
Managed Extensions for C++
__value public enum PDFRubberStampAnnotationIcon : public Enum
C++/CLI
public enum class PDFRubberStampAnnotationIcon : public Enum

Members

Member | Description
Approved | Approved icon.
AsIs | As Is icon.
Confidential | Confidential icon.
Departmental | Departmental icon.
Draft | Draft icon.
Experimental | Experimental icon.
Expired | Expired icon.
Final | Final icon.
ForComment | for comment icon.
ForPublicRelease | For public release icon.
NotApproved | Not approved icon.
NotForPublicRelease | Not for public release icon.
Sold | Sold icon.
TopSecret | Top secret icon.
Custom | User defined custom icon.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFRubberStampAnnotationIcon

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDFTextAnnotationIcon Enumeration

PDFTextAnnotationIcon Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFTextAnnotationIcon Enumeration

Specifies the available icons for a text annotation.

Syntax

Visual Basic (Declaration)
Public Enum PDFTextAnnotationIcon
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFTextAnnotationIcon
C#
public enum PDFTextAnnotationIcon : Enum
Managed Extensions for C++
__value public enum PDFTextAnnotationIcon : public Enum
C++/CLI
public enum class PDFTextAnnotationIcon : public Enum

Members

Member | Description
Comment | Comment icon.
Check | Check mark icon.
Circle | Circle icon.
Cross | Cross icon.
Help | Help icon.
Insert | Insert icon.
Key | Key icon.
NewParagraph | New paragraph icon.
Note | Note icon.
Paragraph | Paragraph icon.
RightArrow | Right arrow icon.
RightPointer | Right pointer icon.
Star | Star arrow icon.
UpArrow | Up arrow icon.
UpLeftArrow | Up left arrow icon.
Custom | User defined custom icon.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFTextAnnotationIcon

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDFTextAnnotationState Enumeration

PDFTextAnnotationState Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFTextAnnotationState Enumeration

Specifies the available states for a text annotation.

Syntax

Visual Basic (Declaration)
Public Enum PDFTextAnnotationState
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFTextAnnotationState
C#
public enum PDFTextAnnotationState : Enum
Managed Extensions for C++
__value public enum PDFTextAnnotationState : public Enum
C++/CLI
public enum class PDFTextAnnotationState : public Enum

Members

Member | Description
NoState | No state has been associated with the annotation.
Marked | The annotation has been marked by the user.
Unmarked | The annotation has not been marked by the user.
Accepted | The user agrees with the change.
Rejected | The user disagrees with the change.
Cancelled | The change has been cancelled.
Completed | The change has been completed.
None | The user has indicated nothing about the change.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFTextAnnotationState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


PDFTextMarkupType Enumeration

PDFTextMarkupType Enumeration
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFTextMarkupType Enumeration

Specifies the available markup types for a text markup annotation.

Syntax

Visual Basic (Declaration)
Public Enum PDFTextMarkupType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFTextMarkupType
C#
public enum PDFTextMarkupType : Enum
Managed Extensions for C++
__value public enum PDFTextMarkupType : public Enum
C++/CLI
public enum class PDFTextMarkupType : public Enum

Members

Member | Description
Highlight | Highlight.
Underline | Underline.
Squiggly | Jagged underline.
StrikeOut | Strike out.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Annotations.PDFTextMarkupType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Annotations Namespace


O2S.Components.PDF4NET.Converters Namespace

O2S.Components.PDF4NET.Converters Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFConverter | Provides conversion services from different file formats to PDF.
PDFConvertOptions | Provides several parameters for converting files to PDF.

See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET.Converters Namespace Inheritance Hierarchy

O2S.Components.PDF4NET.Converters Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Converters.PDFConverter
O2S.Components.PDF4NET.Converters.PDFConvertOptions

See Also

Reference

O2S.Components.PDF4NET Assembly


PDFConverter Class

PDFConverter Class
See Also Members
[image]
O2S.Components.PDF4NET.Converters Namespace : PDFConverter Class

Provides conversion services from different file formats to PDF.

Syntax

Visual Basic (Declaration)
Public Class PDFConverter
Visual Basic (Usage) Copy Code
Dim instance As PDFConverter
C#
public class PDFConverter
Managed Extensions for C++
public __gc class PDFConverter
C++/CLI
public ref class PDFConverter

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Converters.PDFConverter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFConverter Members
O2S.Components.PDF4NET.Converters Namespace


PDFConverter Class Members

PDFConverter Class Members
See Also Methods
[image]
O2S.Components.PDF4NET.Converters Namespace : PDFConverter Class

The following tables list the members exposed by PDFConverter.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConvertTiffToPDF | Overloaded. Converts a multipage TIFF image to PDF.
Top

See Also

Reference

PDFConverter Class
O2S.Components.PDF4NET.Converters Namespace


PDFConverter Class Methods

PDFConverter Class Methods
[image]
O2S.Components.PDF4NET.Converters Namespace : PDFConverter Class

For a list of all members of this type, see PDFConverter members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConvertTiffToPDF | Overloaded. Converts a multipage TIFF image to PDF.
Top

See Also

Reference

PDFConverter Class
O2S.Components.PDF4NET.Converters Namespace


ConvertTiffToPDF Method

ConvertTiffToPDF Method
[image]
O2S.Components.PDF4NET.Converters Namespace > PDFConverter Class : ConvertTiffToPDF Method

Converts a multipage TIFF image to PDF.

Overload List

Overload | Description
ConvertTiffToPDF(String,String) | Converts a multipage TIFF image to PDF.
ConvertTiffToPDF(String,String,PDFConvertOptions) | Converts a multipage TIFF image to PDF.
ConvertTiffToPDF(Stream,Stream) | Converts a multipage TIFF image to PDF.
ConvertTiffToPDF(Stream,Stream,PDFConvertOptions) | Converts a multipage TIFF image to PDF.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFConverter Class
PDFConverter Members


ConvertTiffToPDF(String,String) Method

ConvertTiffToPDF(String,String) Method
[image]
O2S.Components.PDF4NET.Converters Namespace > PDFConverter Class > ConvertTiffToPDF Method : ConvertTiffToPDF(String,String) Method

sourceTiffFile
Source TIFF image to convert.
destinationPdfFile
Destination PDF file.
Converts a multipage TIFF image to PDF.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Sub ConvertTiffToPDF( _
   ByVal sourceTiffFile As String, _
   ByVal destinationPdfFile As String _
)
Visual Basic (Usage) Copy Code
Dim sourceTiffFile As String
Dim destinationPdfFile As String

PDFConverter.ConvertTiffToPDF(sourceTiffFile, destinationPdfFile)
C#
public static void ConvertTiffToPDF(
   string sourceTiffFile,
   string destinationPdfFile
)
Managed Extensions for C++
public: static void ConvertTiffToPDF(
   string* sourceTiffFile,
   string* destinationPdfFile
)
C++/CLI
public:
static void ConvertTiffToPDF(
   String^ sourceTiffFile,
   String^ destinationPdfFile
)

Parameters

sourceTiffFile
Source TIFF image to convert.
destinationPdfFile
Destination PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFConverter Class
PDFConverter Members
Overload List


ConvertTiffToPDF(String,String,PDFConvertOptions) Method

ConvertTiffToPDF(String,String,PDFConvertOptions) Method
[image]
O2S.Components.PDF4NET.Converters Namespace > PDFConverter Class > ConvertTiffToPDF Method : ConvertTiffToPDF(String,String,PDFConvertOptions) Method

sourceTiffFile
Source TIFF image to convert.
destinationPdfFile
Destination PDF file.
options
Options for converting the TIFF image to PDF.
Converts a multipage TIFF image to PDF.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Sub ConvertTiffToPDF( _
   ByVal sourceTiffFile As String, _
   ByVal destinationPdfFile As String, _
   ByVal options As PDFConvertOptions _
)
Visual Basic (Usage) Copy Code
Dim sourceTiffFile As String
Dim destinationPdfFile As String
Dim options As PDFConvertOptions

PDFConverter.ConvertTiffToPDF(sourceTiffFile, destinationPdfFile, options)
C#
public static void ConvertTiffToPDF(
   string sourceTiffFile,
   string destinationPdfFile,
   PDFConvertOptions options
)
Managed Extensions for C++
public: static void ConvertTiffToPDF(
   string* sourceTiffFile,
   string* destinationPdfFile,
   PDFConvertOptions* options
)
C++/CLI
public:
static void ConvertTiffToPDF(
   String^ sourceTiffFile,
   String^ destinationPdfFile,
   PDFConvertOptions^ options
)

Parameters

sourceTiffFile
Source TIFF image to convert.
destinationPdfFile
Destination PDF file.
options
Options for converting the TIFF image to PDF.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFConverter Class
PDFConverter Members
Overload List


ConvertTiffToPDF(Stream,Stream) Method

ConvertTiffToPDF(Stream,Stream) Method
[image]
O2S.Components.PDF4NET.Converters Namespace > PDFConverter Class > ConvertTiffToPDF Method : ConvertTiffToPDF(Stream,Stream) Method

sourceTiffStream
Source TIFF image to convert.
destinationPdfStream
Destination PDF file.
Converts a multipage TIFF image to PDF.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Sub ConvertTiffToPDF( _
   ByVal sourceTiffStream As Stream, _
   ByVal destinationPdfStream As Stream _
)
Visual Basic (Usage) Copy Code
Dim sourceTiffStream As Stream
Dim destinationPdfStream As Stream

PDFConverter.ConvertTiffToPDF(sourceTiffStream, destinationPdfStream)
C#
public static void ConvertTiffToPDF(
   Stream sourceTiffStream,
   Stream destinationPdfStream
)
Managed Extensions for C++
public: static void ConvertTiffToPDF(
   Stream* sourceTiffStream,
   Stream* destinationPdfStream
)
C++/CLI
public:
static void ConvertTiffToPDF(
   Stream^ sourceTiffStream,
   Stream^ destinationPdfStream
)

Parameters

sourceTiffStream
Source TIFF image to convert.
destinationPdfStream
Destination PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFConverter Class
PDFConverter Members
Overload List


ConvertTiffToPDF(Stream,Stream,PDFConvertOptions) Method

ConvertTiffToPDF(Stream,Stream,PDFConvertOptions) Method
[image]
O2S.Components.PDF4NET.Converters Namespace > PDFConverter Class > ConvertTiffToPDF Method : ConvertTiffToPDF(Stream,Stream,PDFConvertOptions) Method

sourceTiffStream
Source TIFF image to convert.
destinationPdfStream
Destination PDF file.
options
Options for converting the TIFF image to PDF.
Converts a multipage TIFF image to PDF.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Sub ConvertTiffToPDF( _
   ByVal sourceTiffStream As Stream, _
   ByVal destinationPdfStream As Stream, _
   ByVal options As PDFConvertOptions _
)
Visual Basic (Usage) Copy Code
Dim sourceTiffStream As Stream
Dim destinationPdfStream As Stream
Dim options As PDFConvertOptions

PDFConverter.ConvertTiffToPDF(sourceTiffStream, destinationPdfStream, options)
C#
public static void ConvertTiffToPDF(
   Stream sourceTiffStream,
   Stream destinationPdfStream,
   PDFConvertOptions options
)
Managed Extensions for C++
public: static void ConvertTiffToPDF(
   Stream* sourceTiffStream,
   Stream* destinationPdfStream,
   PDFConvertOptions* options
)
C++/CLI
public:
static void ConvertTiffToPDF(
   Stream^ sourceTiffStream,
   Stream^ destinationPdfStream,
   PDFConvertOptions^ options
)

Parameters

sourceTiffStream
Source TIFF image to convert.
destinationPdfStream
Destination PDF file.
options
Options for converting the TIFF image to PDF.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFConverter Class
PDFConverter Members
Overload List


PDFConvertOptions Class

PDFConvertOptions Class
See Also Members
[image]
O2S.Components.PDF4NET.Converters Namespace : PDFConvertOptions Class

Provides several parameters for converting files to PDF.

Syntax

Visual Basic (Declaration)
Public Class PDFConvertOptions
Visual Basic (Usage) Copy Code
Dim instance As PDFConvertOptions
C#
public class PDFConvertOptions
Managed Extensions for C++
public __gc class PDFConvertOptions
C++/CLI
public ref class PDFConvertOptions

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Converters.PDFConvertOptions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFConvertOptions Members
O2S.Components.PDF4NET.Converters Namespace


PDFConvertOptions Class Members

PDFConvertOptions Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Converters Namespace : PDFConvertOptions Class

The following tables list the members exposed by PDFConvertOptions.

Public Constructors

 | Name | Description
Public Constructor | PDFConvertOptions Constructor | Initializes a new PDFConvertOptions object.
Top

Public Properties

 | Name | Description
Public Property | PageHeight | Gets or sets the height of the page in the destination PDF file.
Public Property | PageWidth | Gets or sets the width of the pages in the destination PDF file.
Top

See Also

Reference

PDFConvertOptions Class
O2S.Components.PDF4NET.Converters Namespace


PDFConvertOptions Constructor

PDFConvertOptions Constructor
[image]
O2S.Components.PDF4NET.Converters Namespace > PDFConvertOptions Class : PDFConvertOptions Constructor

Initializes a new PDFConvertOptions object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFConvertOptions()
C#
public PDFConvertOptions()
Managed Extensions for C++
public: PDFConvertOptions();
C++/CLI
public:
PDFConvertOptions();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFConvertOptions Class
PDFConvertOptions Members


PDFConvertOptions Class Properties

PDFConvertOptions Class Properties
[image]
O2S.Components.PDF4NET.Converters Namespace : PDFConvertOptions Class

For a list of all members of this type, see PDFConvertOptions members.

Public Properties

 | Name | Description
Public Property | PageHeight | Gets or sets the height of the page in the destination PDF file.
Public Property | PageWidth | Gets or sets the width of the pages in the destination PDF file.
Top

See Also

Reference

PDFConvertOptions Class
O2S.Components.PDF4NET.Converters Namespace


PageHeight Property

PageHeight Property
[image]
O2S.Components.PDF4NET.Converters Namespace > PDFConvertOptions Class : PageHeight Property

Gets or sets the height of the page in the destination PDF file.

Syntax

Visual Basic (Declaration)
Public Property PageHeight As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFConvertOptions
Dim value As Double

instance.PageHeight = value

value = instance.PageHeight
C#
public double PageHeight {get; set;}
Managed Extensions for C++
public: __property double get_PageHeight();
public: __property void set_PageHeight(
   double value
);
C++/CLI
public:
property double PageHeight {
   double get();
   void set (double value);
}

Return Value

The height of the pages in the destination PDF file

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFConvertOptions Class
PDFConvertOptions Members


PageWidth Property

PageWidth Property
[image]
O2S.Components.PDF4NET.Converters Namespace > PDFConvertOptions Class : PageWidth Property

Gets or sets the width of the pages in the destination PDF file.

Syntax

Visual Basic (Declaration)
Public Property PageWidth As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFConvertOptions
Dim value As Double

instance.PageWidth = value

value = instance.PageWidth
C#
public double PageWidth {get; set;}
Managed Extensions for C++
public: __property double get_PageWidth();
public: __property void set_PageWidth(
   double value
);
C++/CLI
public:
property double PageWidth {
   double get();
   void set (double value);
}

Return Value

The width of the pages in the destination PDF file

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFConvertOptions Class
PDFConvertOptions Members


O2S.Components.PDF4NET.Cos Namespace

O2S.Components.PDF4NET.Cos Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
IncompatiblePDFObjectException | The exception that is thrown when a PDF object cannot be converted to requested type.
InvalidPasswordException | The exception that is thrown when the password supplied for opening the file is invalid.
InvalidPDFValueException | The exception that is thrown when the value for a PDF object is invalid.
PDFArray | Defines a PDF object that represents an array.
PDFBoolean | Defines a PDF object that represents a boolean value.
PDFCosObject | Defines a PDF COS object in the PDF file.
PDFDictionary | Defines a PDF object that represents a dictionary.
PDFName | Defines a PDF object that represents a name value.
PDFNull | Defines a PDF object that represents the null PDF value.
PDFNumber | Defines a PDF object that represents a number.
PDFObject | Base class for all PDF objects.
PDFString | Defines a PDF object that represents a string.

See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET.Cos Namespace Inheritance Hierarchy

O2S.Components.PDF4NET.Cos Namespace Inheritance Hierarchy

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFArray
O2S.Components.PDF4NET.Cos.PDFBoolean
O2S.Components.PDF4NET.Cos.PDFCosObject
O2S.Components.PDF4NET.Cos.PDFDictionary
O2S.Components.PDF4NET.Cos.PDFName
O2S.Components.PDF4NET.Cos.PDFNull
O2S.Components.PDF4NET.Cos.PDFNumber
O2S.Components.PDF4NET.Cos.PDFString
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFException
O2S.Components.PDF4NET.Cos.IncompatiblePDFObjectException
O2S.Components.PDF4NET.Cos.InvalidPasswordException
O2S.Components.PDF4NET.Cos.InvalidPDFValueException

See Also

Reference

O2S.Components.PDF4NET Assembly


IncompatiblePDFObjectException Class

IncompatiblePDFObjectException Class
See Also Members
[image]
O2S.Components.PDF4NET.Cos Namespace : IncompatiblePDFObjectException Class

The exception that is thrown when a PDF object cannot be converted to requested type.

Syntax

Visual Basic (Declaration)
Public Class IncompatiblePDFObjectException
   Inherits PDFException
Visual Basic (Usage) Copy Code
Dim instance As IncompatiblePDFObjectException
C#
public class IncompatiblePDFObjectException : PDFException
Managed Extensions for C++
public __gc class IncompatiblePDFObjectException : public PDFException
C++/CLI
public ref class IncompatiblePDFObjectException : public PDFException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFException
O2S.Components.PDF4NET.Cos.IncompatiblePDFObjectException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IncompatiblePDFObjectException Members
O2S.Components.PDF4NET.Cos Namespace


IncompatiblePDFObjectException Class Members

IncompatiblePDFObjectException Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : IncompatiblePDFObjectException Class

The following tables list the members exposed by IncompatiblePDFObjectException.

Public Constructors

 | Name | Description
Public Constructor | IncompatiblePDFObjectException Constructor | Overloaded. Initializes a new IncompatiblePDFObjectException object.
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

IncompatiblePDFObjectException Class
O2S.Components.PDF4NET.Cos Namespace


IncompatiblePDFObjectException Constructor

IncompatiblePDFObjectException Constructor
[image]
O2S.Components.PDF4NET.Cos Namespace > IncompatiblePDFObjectException Class : IncompatiblePDFObjectException Constructor

Initializes a new IncompatiblePDFObjectException object.

Overload List

Overload | Description
IncompatiblePDFObjectException Constructor(String) | Initializes a new IncompatiblePDFObjectException object.
IncompatiblePDFObjectException Constructor(String,Exception) | Initializes a new IncompatiblePDFObjectException object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IncompatiblePDFObjectException Class
IncompatiblePDFObjectException Members


IncompatiblePDFObjectException Constructor(String)

IncompatiblePDFObjectException Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Cos Namespace > IncompatiblePDFObjectException Class > IncompatiblePDFObjectException Constructor : IncompatiblePDFObjectException Constructor(String)

message
The message that describes the exception.
Initializes a new IncompatiblePDFObjectException object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As IncompatiblePDFObjectException(message)
C#
public IncompatiblePDFObjectException(
   string message
)
Managed Extensions for C++
public: IncompatiblePDFObjectException(
   string* message
)
C++/CLI
public:
IncompatiblePDFObjectException(
   String^ message
)

Parameters

message
The message that describes the exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IncompatiblePDFObjectException Class
IncompatiblePDFObjectException Members
Overload List


IncompatiblePDFObjectException Constructor(String,Exception)

IncompatiblePDFObjectException Constructor(String,Exception)
See Also
[image]
O2S.Components.PDF4NET.Cos Namespace > IncompatiblePDFObjectException Class > IncompatiblePDFObjectException Constructor : IncompatiblePDFObjectException Constructor(String,Exception)

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.
Initializes a new IncompatiblePDFObjectException object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As IncompatiblePDFObjectException(message, innerException)
C#
public IncompatiblePDFObjectException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: IncompatiblePDFObjectException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
IncompatiblePDFObjectException(
   String^ message,
   Exception^ innerException
)

Parameters

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

IncompatiblePDFObjectException Class
IncompatiblePDFObjectException Members
Overload List


InvalidPasswordException Class

InvalidPasswordException Class
See Also Members
[image]
O2S.Components.PDF4NET.Cos Namespace : InvalidPasswordException Class

The exception that is thrown when the password supplied for opening the file is invalid.

Syntax

Visual Basic (Declaration)
Public Class InvalidPasswordException
   Inherits PDFException
Visual Basic (Usage) Copy Code
Dim instance As InvalidPasswordException
C#
public class InvalidPasswordException : PDFException
Managed Extensions for C++
public __gc class InvalidPasswordException : public PDFException
C++/CLI
public ref class InvalidPasswordException : public PDFException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFException
O2S.Components.PDF4NET.Cos.InvalidPasswordException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

InvalidPasswordException Members
O2S.Components.PDF4NET.Cos Namespace


InvalidPasswordException Class Members

InvalidPasswordException Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : InvalidPasswordException Class

The following tables list the members exposed by InvalidPasswordException.

Public Constructors

 | Name | Description
Public Constructor | InvalidPasswordException Constructor | Overloaded. Initializes a new InvalidPasswordException object.
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

InvalidPasswordException Class
O2S.Components.PDF4NET.Cos Namespace


InvalidPasswordException Constructor

InvalidPasswordException Constructor
[image]
O2S.Components.PDF4NET.Cos Namespace > InvalidPasswordException Class : InvalidPasswordException Constructor

Initializes a new InvalidPasswordException object.

Overload List

Overload | Description
InvalidPasswordException Constructor(String) | Initializes a new InvalidPasswordException object.
InvalidPasswordException Constructor(String,Exception) | Initializes a new InvalidPasswordException object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


InvalidPasswordException Constructor(String)

InvalidPasswordException Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Cos Namespace > InvalidPasswordException Class > InvalidPasswordException Constructor : InvalidPasswordException Constructor(String)

message
The message that describes the exception.
Initializes a new InvalidPasswordException object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As InvalidPasswordException(message)
C#
public InvalidPasswordException(
   string message
)
Managed Extensions for C++
public: InvalidPasswordException(
   string* message
)
C++/CLI
public:
InvalidPasswordException(
   String^ message
)

Parameters

message
The message that describes the exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members
Overload List


InvalidPasswordException Constructor(String,Exception)

InvalidPasswordException Constructor(String,Exception)
See Also
[image]
O2S.Components.PDF4NET.Cos Namespace > InvalidPasswordException Class > InvalidPasswordException Constructor : InvalidPasswordException Constructor(String,Exception)

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.
Initializes a new InvalidPasswordException object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As InvalidPasswordException(message, innerException)
C#
public InvalidPasswordException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: InvalidPasswordException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
InvalidPasswordException(
   String^ message,
   Exception^ innerException
)

Parameters

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members
Overload List


InvalidPDFValueException Class

InvalidPDFValueException Class
See Also Members
[image]
O2S.Components.PDF4NET.Cos Namespace : InvalidPDFValueException Class

The exception that is thrown when the value for a PDF object is invalid.

Syntax

Visual Basic (Declaration)
Public Class InvalidPDFValueException
   Inherits PDFException
Visual Basic (Usage) Copy Code
Dim instance As InvalidPDFValueException
C#
public class InvalidPDFValueException : PDFException
Managed Extensions for C++
public __gc class InvalidPDFValueException : public PDFException
C++/CLI
public ref class InvalidPDFValueException : public PDFException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.PDFException
O2S.Components.PDF4NET.Cos.InvalidPDFValueException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

InvalidPDFValueException Members
O2S.Components.PDF4NET.Cos Namespace


InvalidPDFValueException Class Members

InvalidPDFValueException Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : InvalidPDFValueException Class

The following tables list the members exposed by InvalidPDFValueException.

Public Constructors

 | Name | Description
Public Constructor | InvalidPDFValueException Constructor | Overloaded. Initializes a new InvalidPDFValueException object.
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

InvalidPDFValueException Class
O2S.Components.PDF4NET.Cos Namespace


InvalidPDFValueException Constructor

InvalidPDFValueException Constructor
[image]
O2S.Components.PDF4NET.Cos Namespace > InvalidPDFValueException Class : InvalidPDFValueException Constructor

Initializes a new InvalidPDFValueException object.

Overload List

Overload | Description
InvalidPDFValueException Constructor(String) | Initializes a new InvalidPDFValueException object.
InvalidPDFValueException Constructor(String,Exception) | Initializes a new InvalidPDFValueException object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

InvalidPDFValueException Class
InvalidPDFValueException Members


InvalidPDFValueException Constructor(String)

InvalidPDFValueException Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Cos Namespace > InvalidPDFValueException Class > InvalidPDFValueException Constructor : InvalidPDFValueException Constructor(String)

message
The message that describes the exception.
Initializes a new InvalidPDFValueException object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As InvalidPDFValueException(message)
C#
public InvalidPDFValueException(
   string message
)
Managed Extensions for C++
public: InvalidPDFValueException(
   string* message
)
C++/CLI
public:
InvalidPDFValueException(
   String^ message
)

Parameters

message
The message that describes the exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

InvalidPDFValueException Class
InvalidPDFValueException Members
Overload List


InvalidPDFValueException Constructor(String,Exception)

InvalidPDFValueException Constructor(String,Exception)
See Also
[image]
O2S.Components.PDF4NET.Cos Namespace > InvalidPDFValueException Class > InvalidPDFValueException Constructor : InvalidPDFValueException Constructor(String,Exception)

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.
Initializes a new InvalidPDFValueException object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As InvalidPDFValueException(message, innerException)
C#
public InvalidPDFValueException(
   string message,
   Exception innerException
)
Managed Extensions for C++
public: InvalidPDFValueException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
InvalidPDFValueException(
   String^ message,
   Exception^ innerException
)

Parameters

message
the message that describes the exception.
innerException
The exception that is the cause of the current exception.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

InvalidPDFValueException Class
InvalidPDFValueException Members
Overload List


PDFArray Class

PDFArray Class
See Also Members
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFArray Class

Defines a PDF object that represents an array.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PDFArray
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFArray
C#
[DefaultMemberAttribute("Item")]
public class PDFArray : PDFObject
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class PDFArray : public PDFObject
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFArray : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFArray

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArray Members
O2S.Components.PDF4NET.Cos Namespace


PDFArray Class Members

PDFArray Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFArray Class

The following tables list the members exposed by PDFArray.

Public Constructors

 | Name | Description
Public Constructor | PDFArray Constructor | Initializes a new PDFArray object.
Top

Public Properties

 | Name | Description
Public Property | Item | Gets the item at the specified index.
Public Property | Length | Gets the number of items in the array.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a new element at the end of the array.
Public Method | Clear | Removes all the elements from the array.
Public Method | IndexOf | Searches the array for the specified object and returns its position in the array.
Public Method | Insert | Inserts a new element in the array at the specified position.
Public Method | Remove | Removes the specified PDF object from the array.
Public Method | RemoveAt | Removes the array item at the specified position.
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFArray Class
O2S.Components.PDF4NET.Cos Namespace


PDFArray Constructor

PDFArray Constructor
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : PDFArray Constructor

Initializes a new PDFArray object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFArray()
C#
public PDFArray()
Managed Extensions for C++
public: PDFArray();
C++/CLI
public:
PDFArray();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArray Class
PDFArray Members


PDFArray Class Methods

PDFArray Class Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFArray Class

For a list of all members of this type, see PDFArray members.

Public Methods

 | Name | Description
Public Method | Add | Adds a new element at the end of the array.
Public Method | Clear | Removes all the elements from the array.
Public Method | IndexOf | Searches the array for the specified object and returns its position in the array.
Public Method | Insert | Inserts a new element in the array at the specified position.
Public Method | Remove | Removes the specified PDF object from the array.
Public Method | RemoveAt | Removes the array item at the specified position.
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFArray Class
O2S.Components.PDF4NET.Cos Namespace


Add Method

Add Method
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : Add Method

item
Item to add the end of the array.
Adds a new element at the end of the array.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As PDFObject _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFArray
Dim item As PDFObject

instance.Add(item)
C#
public void Add(
   PDFObject item
)
Managed Extensions for C++
public: void Add(
   PDFObject* item
)
C++/CLI
public:
void Add(
   PDFObject^ item
)

Parameters

item
Item to add the end of the array.

Exceptions

Exception | Description
ArgumentNullException | Thrown when the item is null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArray Class
PDFArray Members


Clear Method

Clear Method
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : Clear Method

Removes all the elements from the array.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As PDFArray

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArray Class
PDFArray Members


IndexOf Method

IndexOf Method
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : IndexOf Method

obj
Object to search.
Searches the array for the specified object and returns its position in the array.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal obj As PDFObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFArray
Dim obj As PDFObject
Dim value As Integer

value = instance.IndexOf(obj)
C#
public int IndexOf(
   PDFObject obj
)
Managed Extensions for C++
public: int IndexOf(
   PDFObject* obj
)
C++/CLI
public:
int IndexOf(
   PDFObject^ obj
)

Parameters

obj
Object to search.

Return Value

Position of object if it exists in the array, -1 otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArray Class
PDFArray Members


Insert Method

Insert Method
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : Insert Method

index
Position where to insert the new element.
item
New element to insert in the array.
Inserts a new element in the array at the specified position.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As PDFObject _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFArray
Dim index As Integer
Dim item As PDFObject

instance.Insert(index, item)
C#
public void Insert(
   int index,
   PDFObject item
)
Managed Extensions for C++
public: void Insert(
   int index,
   PDFObject* item
)
C++/CLI
public:
void Insert(
   int index,
   PDFObject^ item
)

Parameters

index
Position where to insert the new element.
item
New element to insert in the array.

Exceptions

Exception | Description
ArgumentNullException | Thrown when the item is null.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArray Class
PDFArray Members


Remove Method

Remove Method
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : Remove Method

obj
Object to remove.
Removes the specified PDF object from the array.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal obj As PDFObject _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFArray
Dim obj As PDFObject

instance.Remove(obj)
C#
public void Remove(
   PDFObject obj
)
Managed Extensions for C++
public: void Remove(
   PDFObject* obj
)
C++/CLI
public:
void Remove(
   PDFObject^ obj
)

Parameters

obj
Object to remove.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArray Class
PDFArray Members


RemoveAt Method

RemoveAt Method
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : RemoveAt Method

index
Position of the item to remove.
Removes the array item at the specified position.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFArray
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
Position of the item to remove.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the index is out of range.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArray Class
PDFArray Members


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : ToString Method

Converts the object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFArray
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The string representation of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArray Class
PDFArray Members


PDFArray Class Properties

PDFArray Class Properties
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFArray Class

For a list of all members of this type, see PDFArray members.

Public Properties

 | Name | Description
Public Property | Item | Gets the item at the specified index.
Public Property | Length | Gets the number of items in the array.
Top

See Also

Reference

PDFArray Class
O2S.Components.PDF4NET.Cos Namespace


Item Property

Item Property
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : Item Property

index
Index of item to return.
Gets the item at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFArray
Dim index As Integer
Dim value As PDFObject

instance.Item(index) = value

value = instance.Item(index)
C#
public PDFObject this[
   int index
]; {get; set;}
Managed Extensions for C++
public: __property PDFObject* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   PDFObject* value
);
C++/CLI
public:
property PDFObject^ default [int] {
   PDFObject^ get(int index);
   void set (int index, PDFObject^ value);
}

Parameters

index
Index of item to return.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the index value is invalid

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArray Class
PDFArray Members


Length Property

Length Property
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFArray Class : Length Property

Gets the number of items in the array.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFArray
Dim value As Integer

value = instance.Length
C#
public int Length {get;}
Managed Extensions for C++
public: __property int get_Length();
C++/CLI
public:
property int Length {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFArray Class
PDFArray Members


PDFBoolean Class

PDFBoolean Class
See Also Members
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFBoolean Class

Defines a PDF object that represents a boolean value.

Syntax

Visual Basic (Declaration)
Public Class PDFBoolean
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFBoolean
C#
public class PDFBoolean : PDFObject
Managed Extensions for C++
public __gc class PDFBoolean : public PDFObject
C++/CLI
public ref class PDFBoolean : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFBoolean

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBoolean Members
O2S.Components.PDF4NET.Cos Namespace


PDFBoolean Class Members

PDFBoolean Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFBoolean Class

The following tables list the members exposed by PDFBoolean.

Public Constructors

 | Name | Description
Public Constructor | PDFBoolean Constructor | Overloaded. Initializes a new PDFBoolean object.
Top

Public Properties

 | Name | Description
Public Property | Value | Gets or sets the object value.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFBoolean Class
O2S.Components.PDF4NET.Cos Namespace


PDFBoolean Constructor

PDFBoolean Constructor
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFBoolean Class : PDFBoolean Constructor

Initializes a new PDFBoolean object.

Overload List

Overload | Description
PDFBoolean Constructor() | Initializes a new PDFBoolean object.
PDFBoolean Constructor(Boolean) | Initializes a new PDFBoolean object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBoolean Class
PDFBoolean Members


PDFBoolean Constructor()

PDFBoolean Constructor()
See Also
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFBoolean Class > PDFBoolean Constructor : PDFBoolean Constructor()

Initializes a new PDFBoolean object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFBoolean()
C#
public PDFBoolean()
Managed Extensions for C++
public: PDFBoolean();
C++/CLI
public:
PDFBoolean();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBoolean Class
PDFBoolean Members
Overload List


PDFBoolean Constructor(Boolean)

PDFBoolean Constructor(Boolean)
See Also
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFBoolean Class > PDFBoolean Constructor : PDFBoolean Constructor(Boolean)

value
Initial object value.
Initializes a new PDFBoolean object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim value As Boolean

Dim instance As PDFBoolean(value)
C#
public PDFBoolean(
   bool value
)
Managed Extensions for C++
public: PDFBoolean(
   bool value
)
C++/CLI
public:
PDFBoolean(
   bool value
)

Parameters

value
Initial object value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBoolean Class
PDFBoolean Members
Overload List


PDFBoolean Class Methods

PDFBoolean Class Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFBoolean Class

For a list of all members of this type, see PDFBoolean members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFBoolean Class
O2S.Components.PDF4NET.Cos Namespace


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFBoolean Class : ToString Method

Converts the object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFBoolean
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The string representation of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBoolean Class
PDFBoolean Members


PDFBoolean Class Properties

PDFBoolean Class Properties
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFBoolean Class

For a list of all members of this type, see PDFBoolean members.

Public Properties

 | Name | Description
Public Property | Value | Gets or sets the object value.
Top

See Also

Reference

PDFBoolean Class
O2S.Components.PDF4NET.Cos Namespace


Value Property

Value Property
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFBoolean Class : Value Property

Gets or sets the object value.

Syntax

Visual Basic (Declaration)
Public Property Value As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFBoolean
Dim value As Boolean

instance.Value = value

value = instance.Value
C#
public bool Value {get; set;}
Managed Extensions for C++
public: __property bool get_Value();
public: __property void set_Value(
   bool value
);
C++/CLI
public:
property bool Value {
   bool get();
   void set (bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBoolean Class
PDFBoolean Members


PDFCosObject Class

PDFCosObject Class
See Also Members
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFCosObject Class

Defines a PDF COS object in the PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCosObject
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFCosObject
C#
public class PDFCosObject : PDFObject
Managed Extensions for C++
public __gc class PDFCosObject : public PDFObject
C++/CLI
public ref class PDFCosObject : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFCosObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCosObject Members
O2S.Components.PDF4NET.Cos Namespace


PDFCosObject Class Members

PDFCosObject Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFCosObject Class

The following tables list the members exposed by PDFCosObject.

Public Constructors

 | Name | Description
Public Constructor | PDFCosObject Constructor | Overloaded. Initializes a new PDFCosObject object.
Top

Public Properties

 | Name | Description
Public Property | DecodedStream | Gets the object's decoded stream.
Public Property | Dictionary | Gets or sets the object's dictionary.
Public Property | ObjectID | Gets the object id.
Public Property | Stream | Gets or sets the object' stream.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFCosObject Class
O2S.Components.PDF4NET.Cos Namespace


PDFCosObject Constructor

PDFCosObject Constructor
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFCosObject Class : PDFCosObject Constructor

Initializes a new PDFCosObject object.

Overload List

Overload | Description
PDFCosObject Constructor() | Initializes a new PDFCosObject object.
PDFCosObject Constructor(PDFDictionary) | Initializes a new PDFCosObject object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCosObject Class
PDFCosObject Members


PDFCosObject Constructor()

PDFCosObject Constructor()
See Also
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFCosObject Class > PDFCosObject Constructor : PDFCosObject Constructor()

Initializes a new PDFCosObject object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCosObject()
C#
public PDFCosObject()
Managed Extensions for C++
public: PDFCosObject();
C++/CLI
public:
PDFCosObject();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCosObject Class
PDFCosObject Members
Overload List


PDFCosObject Constructor(PDFDictionary)

PDFCosObject Constructor(PDFDictionary)
See Also
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFCosObject Class > PDFCosObject Constructor : PDFCosObject Constructor(PDFDictionary)

dictionary
Initial object value.
Initializes a new PDFCosObject object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dictionary As PDFDictionary _
)
Visual Basic (Usage) Copy Code
Dim dictionary As PDFDictionary

Dim instance As PDFCosObject(dictionary)
C#
public PDFCosObject(
   PDFDictionary dictionary
)
Managed Extensions for C++
public: PDFCosObject(
   PDFDictionary* dictionary
)
C++/CLI
public:
PDFCosObject(
   PDFDictionary^ dictionary
)

Parameters

dictionary
Initial object value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCosObject Class
PDFCosObject Members
Overload List


PDFCosObject Class Methods

PDFCosObject Class Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFCosObject Class

For a list of all members of this type, see PDFCosObject members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFCosObject Class
O2S.Components.PDF4NET.Cos Namespace


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFCosObject Class : ToString Method

Converts the object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFCosObject
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The string representation of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCosObject Class
PDFCosObject Members


PDFCosObject Class Properties

PDFCosObject Class Properties
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFCosObject Class

For a list of all members of this type, see PDFCosObject members.

Public Properties

 | Name | Description
Public Property | DecodedStream | Gets the object's decoded stream.
Public Property | Dictionary | Gets or sets the object's dictionary.
Public Property | ObjectID | Gets the object id.
Public Property | Stream | Gets or sets the object' stream.
Top

See Also

Reference

PDFCosObject Class
O2S.Components.PDF4NET.Cos Namespace


DecodedStream Property

DecodedStream Property
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFCosObject Class : DecodedStream Property

Gets the object's decoded stream.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DecodedStream As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFCosObject
Dim value() As Byte

value = instance.DecodedStream
C#
public byte[] DecodedStream {get;}
Managed Extensions for C++
public: __property byte[]* get_DecodedStream();
C++/CLI
public:
property array<byte>^ DecodedStream {
   array<byte>^ get();
}

Return Value

The object' decoded stream.

Remarks

This property returns the object stream after it has been decompressed and unfiltered

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCosObject Class
PDFCosObject Members


Dictionary Property

Dictionary Property
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFCosObject Class : Dictionary Property

Gets or sets the object's dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dictionary As PDFDictionary
Visual Basic (Usage) Copy Code
Dim instance As PDFCosObject
Dim value As PDFDictionary

value = instance.Dictionary
C#
public PDFDictionary Dictionary {get;}
Managed Extensions for C++
public: __property PDFDictionary* get_Dictionary();
C++/CLI
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Return Value

The inner dictionary of this COS object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCosObject Class
PDFCosObject Members


ObjectID Property

ObjectID Property
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFCosObject Class : ObjectID Property

Gets the object id.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectID As Long
Visual Basic (Usage) Copy Code
Dim instance As PDFCosObject
Dim value As Long

value = instance.ObjectID
C#
public long ObjectID {get;}
Managed Extensions for C++
public: __property long get_ObjectID();
C++/CLI
public:
property long ObjectID {
   long get();
}

Remarks

The object ID is used when the object is saved.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCosObject Class
PDFCosObject Members


Stream Property

Stream Property
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFCosObject Class : Stream Property

Gets or sets the object' stream.

Syntax

Visual Basic (Declaration)
Public Property Stream As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFCosObject
Dim value() As Byte

instance.Stream = value

value = instance.Stream
C#
public byte[] Stream {get; set;}
Managed Extensions for C++
public: __property byte[]* get_Stream();
public: __property void set_Stream(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ Stream {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

The object' stream.

Remarks

Object' stream is optional. This property returns the object' stream as it appears in the PDF file, possibly compressed and with other filters applied to it. If you need to plain stream data, use the DecodedStream property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCosObject Class
PDFCosObject Members


PDFDictionary Class

PDFDictionary Class
See Also Members
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFDictionary Class

Defines a PDF object that represents a dictionary.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PDFDictionary
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFDictionary
C#
[DefaultMemberAttribute("Item")]
public class PDFDictionary : PDFObject
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class PDFDictionary : public PDFObject
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFDictionary : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFDictionary

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDictionary Members
O2S.Components.PDF4NET.Cos Namespace


PDFDictionary Class Members

PDFDictionary Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFDictionary Class

The following tables list the members exposed by PDFDictionary.

Public Constructors

 | Name | Description
Public Constructor | PDFDictionary Constructor | Initializes a new PDFDictionary object.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the dictionary.
Public Property | Item | Gets or sets the value associated with the specified key.
Public Property | Keys | Gets the list of keys in the dictionary.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFDictionary Class
O2S.Components.PDF4NET.Cos Namespace


PDFDictionary Constructor

PDFDictionary Constructor
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFDictionary Class : PDFDictionary Constructor

Initializes a new PDFDictionary object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDictionary()
C#
public PDFDictionary()
Managed Extensions for C++
public: PDFDictionary();
C++/CLI
public:
PDFDictionary();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDictionary Class
PDFDictionary Members


PDFDictionary Class Methods

PDFDictionary Class Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFDictionary Class

For a list of all members of this type, see PDFDictionary members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFDictionary Class
O2S.Components.PDF4NET.Cos Namespace


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFDictionary Class : ToString Method

Converts the object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDictionary
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The object as string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDictionary Class
PDFDictionary Members


PDFDictionary Class Properties

PDFDictionary Class Properties
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFDictionary Class

For a list of all members of this type, see PDFDictionary members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the dictionary.
Public Property | Item | Gets or sets the value associated with the specified key.
Public Property | Keys | Gets the list of keys in the dictionary.
Top

See Also

Reference

PDFDictionary Class
O2S.Components.PDF4NET.Cos Namespace


Count Property

Count Property
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFDictionary Class : Count Property

Gets the number of items in the dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFDictionary
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDictionary Class
PDFDictionary Members


Item Property

Item Property
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFDictionary Class : Item Property

key
The key of the value to get or set.
Gets or sets the value associated with the specified key.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal key As String _
) As PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFDictionary
Dim key As String
Dim value As PDFObject

instance.Item(key) = value

value = instance.Item(key)
C#
public PDFObject this[
   string key
]; {get; set;}
Managed Extensions for C++
public: __property PDFObject* get_Item(
   string* key
);
public: __property void set_Item(
   string* key,
   PDFObject* value
);
C++/CLI
public:
property PDFObject^ default [String^] {
   PDFObject^ get(String^ key);
   void set (String^ key, PDFObject^ value);
}

Parameters

key
The key of the value to get or set.

Remarks

If the key already exists in the dictionary, the set operation overwrites it.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDictionary Class
PDFDictionary Members


Keys Property

Keys Property
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFDictionary Class : Keys Property

Gets the list of keys in the dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Keys As String()
Visual Basic (Usage) Copy Code
Dim instance As PDFDictionary
Dim value() As String

value = instance.Keys
C#
public string[] Keys {get;}
Managed Extensions for C++
public: __property string*[]* get_Keys();
C++/CLI
public:
property array<String^>^ Keys {
   array<String^>^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDictionary Class
PDFDictionary Members


PDFName Class

PDFName Class
See Also Members
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFName Class

Defines a PDF object that represents a name value.

Syntax

Visual Basic (Declaration)
Public Class PDFName
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFName
C#
public class PDFName : PDFObject
Managed Extensions for C++
public __gc class PDFName : public PDFObject
C++/CLI
public ref class PDFName : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFName Members
O2S.Components.PDF4NET.Cos Namespace


PDFName Class Members

PDFName Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFName Class

The following tables list the members exposed by PDFName.

Public Constructors

 | Name | Description
Public Constructor | PDFName Constructor | Overloaded. Initializes a new PDFName object.
Top

Public Properties

 | Name | Description
Public Property | Value | Gets or sets the object value.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFName Class
O2S.Components.PDF4NET.Cos Namespace


PDFName Constructor

PDFName Constructor
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFName Class : PDFName Constructor

Initializes a new PDFName object.

Overload List

Overload | Description
PDFName Constructor() | Initializes a new PDFName object.
PDFName Constructor(String) | Initializes a new PDFName object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFName Class
PDFName Members


PDFName Constructor()

PDFName Constructor()
See Also
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFName Class > PDFName Constructor : PDFName Constructor()

Initializes a new PDFName object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFName()
C#
public PDFName()
Managed Extensions for C++
public: PDFName();
C++/CLI
public:
PDFName();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFName Class
PDFName Members
Overload List


PDFName Constructor(String)

PDFName Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFName Class > PDFName Constructor : PDFName Constructor(String)

value
Initial object value.
Initializes a new PDFName object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As PDFName(value)
C#
public PDFName(
   string value
)
Managed Extensions for C++
public: PDFName(
   string* value
)
C++/CLI
public:
PDFName(
   String^ value
)

Parameters

value
Initial object value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFName Class
PDFName Members
Overload List


PDFName Class Methods

PDFName Class Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFName Class

For a list of all members of this type, see PDFName members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFName Class
O2S.Components.PDF4NET.Cos Namespace


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFName Class : ToString Method

Converts the object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFName
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The string representation of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFName Class
PDFName Members


PDFName Class Properties

PDFName Class Properties
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFName Class

For a list of all members of this type, see PDFName members.

Public Properties

 | Name | Description
Public Property | Value | Gets or sets the object value.
Top

See Also

Reference

PDFName Class
O2S.Components.PDF4NET.Cos Namespace


Value Property

Value Property
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFName Class : Value Property

Gets or sets the object value.

Syntax

Visual Basic (Declaration)
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As PDFName
Dim value As String

instance.Value = value

value = instance.Value
C#
public string Value {get; set;}
Managed Extensions for C++
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
C++/CLI
public:
property String^ Value {
   String^ get();
   void set (String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFName Class
PDFName Members


PDFNull Class

PDFNull Class
See Also Members
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFNull Class

Defines a PDF object that represents the null PDF value.

Syntax

Visual Basic (Declaration)
Public Class PDFNull
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFNull
C#
public class PDFNull : PDFObject
Managed Extensions for C++
public __gc class PDFNull : public PDFObject
C++/CLI
public ref class PDFNull : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFNull

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFNull Members
O2S.Components.PDF4NET.Cos Namespace


PDFNull Class Members

PDFNull Class Members
See Also Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFNull Class

The following tables list the members exposed by PDFNull.

Public Constructors

 | Name | Description
Public Constructor | PDFNull Constructor | Initializes a new PDFNull object.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFNull Class
O2S.Components.PDF4NET.Cos Namespace


PDFNull Constructor

PDFNull Constructor
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFNull Class : PDFNull Constructor

Initializes a new PDFNull object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFNull()
C#
public PDFNull()
Managed Extensions for C++
public: PDFNull();
C++/CLI
public:
PDFNull();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFNull Class
PDFNull Members


PDFNull Class Methods

PDFNull Class Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFNull Class

For a list of all members of this type, see PDFNull members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFNull Class
O2S.Components.PDF4NET.Cos Namespace


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFNull Class : ToString Method

Converts the object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFNull
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The string representation of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFNull Class
PDFNull Members


PDFNumber Class

PDFNumber Class
See Also Members
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFNumber Class

Defines a PDF object that represents a number.

Syntax

Visual Basic (Declaration)
Public Class PDFNumber
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFNumber
C#
public class PDFNumber : PDFObject
Managed Extensions for C++
public __gc class PDFNumber : public PDFObject
C++/CLI
public ref class PDFNumber : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFNumber

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFNumber Members
O2S.Components.PDF4NET.Cos Namespace


PDFNumber Class Members

PDFNumber Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFNumber Class

The following tables list the members exposed by PDFNumber.

Public Constructors

 | Name | Description
Public Constructor | PDFNumber Constructor | Overloaded. Initializes a new PDFNumber object.
Top

Public Properties

 | Name | Description
Public Property | Value | Gets or sets the object value.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFNumber Class
O2S.Components.PDF4NET.Cos Namespace


PDFNumber Constructor

PDFNumber Constructor
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFNumber Class : PDFNumber Constructor

Initializes a new PDFNumber object.

Overload List

Overload | Description
PDFNumber Constructor() | Initializes a new PDFNumber object.
PDFNumber Constructor(Double) | Initializes a new PDFNumber object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFNumber Class
PDFNumber Members


PDFNumber Constructor()

PDFNumber Constructor()
See Also
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFNumber Class > PDFNumber Constructor : PDFNumber Constructor()

Initializes a new PDFNumber object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFNumber()
C#
public PDFNumber()
Managed Extensions for C++
public: PDFNumber();
C++/CLI
public:
PDFNumber();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFNumber Class
PDFNumber Members
Overload List


PDFNumber Constructor(Double)

PDFNumber Constructor(Double)
See Also
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFNumber Class > PDFNumber Constructor : PDFNumber Constructor(Double)

_value
Initial object value.
Initializes a new PDFNumber object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal _value As Double _
)
Visual Basic (Usage) Copy Code
Dim _value As Double

Dim instance As PDFNumber(_value)
C#
public PDFNumber(
   double _value
)
Managed Extensions for C++
public: PDFNumber(
   double _value
)
C++/CLI
public:
PDFNumber(
   double _value
)

Parameters

_value
Initial object value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFNumber Class
PDFNumber Members
Overload List


PDFNumber Class Methods

PDFNumber Class Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFNumber Class

For a list of all members of this type, see PDFNumber members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFNumber Class
O2S.Components.PDF4NET.Cos Namespace


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFNumber Class : ToString Method

Converts the object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFNumber
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The string representation of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFNumber Class
PDFNumber Members


PDFNumber Class Properties

PDFNumber Class Properties
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFNumber Class

For a list of all members of this type, see PDFNumber members.

Public Properties

 | Name | Description
Public Property | Value | Gets or sets the object value.
Top

See Also

Reference

PDFNumber Class
O2S.Components.PDF4NET.Cos Namespace


Value Property

Value Property
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFNumber Class : Value Property

Gets or sets the object value.

Syntax

Visual Basic (Declaration)
Public Property Value As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFNumber
Dim value As Double

instance.Value = value

value = instance.Value
C#
public double Value {get; set;}
Managed Extensions for C++
public: __property double get_Value();
public: __property void set_Value(
   double value
);
C++/CLI
public:
property double Value {
   double get();
   void set (double value);
}

Return Value

The number that represents this object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFNumber Class
PDFNumber Members


PDFObject Class

PDFObject Class
See Also Members
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFObject Class

Base class for all PDF objects.

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFObject
C#
public abstract class PDFObject
Managed Extensions for C++
public __gc abstract class PDFObject
C++/CLI
public ref class PDFObject abstract

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Security.PDFDigitalSignature
O2S.Components.PDF4NET.Cos.PDFString
O2S.Components.PDF4NET.Cos.PDFNumber
O2S.Components.PDF4NET.Cos.PDFNull
O2S.Components.PDF4NET.Cos.PDFName
O2S.Components.PDF4NET.Cos.PDFDictionary
O2S.Components.PDF4NET.Cos.PDFCosObject
O2S.Components.PDF4NET.Cos.PDFBoolean
O2S.Components.PDF4NET.Cos.PDFArray

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFObject Members
O2S.Components.PDF4NET.Cos Namespace


PDFObject Class Members

PDFObject Class Members
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFObject Class

The following tables list the members exposed by PDFObject.

Public Constructors

 | Name | Description
Public Constructor | PDFObject Constructor | Initializes a new PDFObject object.
Top

See Also

Reference

PDFObject Class
O2S.Components.PDF4NET.Cos Namespace


PDFObject Constructor

PDFObject Constructor
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFObject Class : PDFObject Constructor

Initializes a new PDFObject object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFObject()
C#
public PDFObject()
Managed Extensions for C++
public: PDFObject();
C++/CLI
public:
PDFObject();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFObject Class
PDFObject Members


PDFString Class

PDFString Class
See Also Members
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFString Class

Defines a PDF object that represents a string.

Syntax

Visual Basic (Declaration)
Public Class PDFString
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFString
C#
public class PDFString : PDFObject
Managed Extensions for C++
public __gc class PDFString : public PDFObject
C++/CLI
public ref class PDFString : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Cos.PDFString

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFString Members
O2S.Components.PDF4NET.Cos Namespace


PDFString Class Members

PDFString Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFString Class

The following tables list the members exposed by PDFString.

Public Constructors

 | Name | Description
Public Constructor | PDFString Constructor | Overloaded. Initializes a new PDFString object.
Top

Public Properties

 | Name | Description
Public Property | Value | Gets or sets the object value.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFString Class
O2S.Components.PDF4NET.Cos Namespace


PDFString Constructor

PDFString Constructor
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFString Class : PDFString Constructor

Initializes a new PDFString object.

Overload List

Overload | Description
PDFString Constructor() | Initializes a new PDFString object.
PDFString Constructor(String) | Initializes a new PDFString object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFString Class
PDFString Members


PDFString Constructor()

PDFString Constructor()
See Also
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFString Class > PDFString Constructor : PDFString Constructor()

Initializes a new PDFString object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFString()
C#
public PDFString()
Managed Extensions for C++
public: PDFString();
C++/CLI
public:
PDFString();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFString Class
PDFString Members
Overload List


PDFString Constructor(String)

PDFString Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFString Class > PDFString Constructor : PDFString Constructor(String)

value
Initial object value.
Initializes a new PDFString object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As PDFString(value)
C#
public PDFString(
   string value
)
Managed Extensions for C++
public: PDFString(
   string* value
)
C++/CLI
public:
PDFString(
   String^ value
)

Parameters

value
Initial object value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFString Class
PDFString Members
Overload List


PDFString Class Methods

PDFString Class Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFString Class

For a list of all members of this type, see PDFString members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to string representation.
Top

See Also

Reference

PDFString Class
O2S.Components.PDF4NET.Cos Namespace


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFString Class : ToString Method

Converts the object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFString
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The string representation of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFString Class
PDFString Members


PDFString Class Properties

PDFString Class Properties
[image]
O2S.Components.PDF4NET.Cos Namespace : PDFString Class

For a list of all members of this type, see PDFString members.

Public Properties

 | Name | Description
Public Property | Value | Gets or sets the object value.
Top

See Also

Reference

PDFString Class
O2S.Components.PDF4NET.Cos Namespace


Value Property

Value Property
[image]
O2S.Components.PDF4NET.Cos Namespace > PDFString Class : Value Property

Gets or sets the object value.

Syntax

Visual Basic (Declaration)
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As PDFString
Dim value As String

instance.Value = value

value = instance.Value
C#
public string Value {get; set;}
Managed Extensions for C++
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
C++/CLI
public:
property String^ Value {
   String^ get();
   void set (String^ value);
}

Return Value

The string that represents this object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFString Class
PDFString Members


O2S.Components.PDF4NET.Forms Namespace

O2S.Components.PDF4NET.Forms Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
FDFField | Defines a field in a FDF document.
FDFFieldCollection | Defines a collection of fields in a FDF document.
FDFFile | Represents a FDF file on disk.
PDFCheckBoxField | Defines a checkbox in a PDF form.
PDFCheckBoxWidget | Defines the widget for a check box field.
PDFCheckWidget | Defines a widget that can be checked.
PDFDropDownListField | Defines a drop down list field for user input in the PDF file.
PDFDropDownListWidget | Defines the widget for a textbox field.
PDFField | Defines the base class for form fields in a PDF form.
PDFFieldCollection | Defines a collection of form fields.
PDFFieldImportError | Represents an error that happened during the import of a FDF/XFDF/XML file.
PDFFieldWidget | Defines the widget for a form field.
PDFFieldWidgetCollection | Defines a collection of form fields.
PDFForm | Defines a form in a PDF document.
PDFListBoxField | Defines a scrollable list box field for user input in the PDF file.
PDFListBoxWidget | Defines the widget for a listbox field.
PDFListField | Base class for all list type fields.
PDFListItem | Defines an item in a list.
PDFListItemCollection | Defines a collection of list items.
PDFPushButtonField | Defines a pushbutton in a PDF form.
PDFPushButtonWidget | Defines the widget for a pushbutton field.
PDFRadioButtonItem | Defines the widget for a radio button.
PDFRadioButtonListField | Defines a list of radio buttons in a PDF form.
PDFSignatureField | Defines a signature field in a PDF form.
PDFSignatureLockFieldAction | Defines the field lock action to be executed when a signature field is signed.
PDFSignatureWidget | Defines the widget for a signature field.
PDFTextBoxField | Defines a text box in a PDF form.
PDFTextBoxWidget | Defines the widget for a textbox field.
XFDFField | Defines a field in a XFDF document.
XFDFFieldCollection | Defines a collection of fields in a XFDF document.
XFDFFile | Represents a XFDF file on disk.

Enumerations

Enumeration | Description
PDFCheckSymbolStyle | Specifies the available style for a check box and radio button items.
PDFExportDataOptions | Specifies the available export options for PDF forms.
PDFFieldTextAlign | Specifies the available alignments for text in a field.
PDFFieldType | Specifies the available field types.
PDFFieldWidgetVisibilityStatus | Specifies the available visibility states for a field widget.
PDFFormDataFormat | Specifies the available formats for data import/export for AcroForms.
PDFPushButtonHighlightMode | Specifies the available highlighting modes for a button.
PDFSignatureLockFieldMode | Specifies the available lock modes for form fields when a signature lock is applied.

See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET.Forms Namespace Inheritance Hierarchy

O2S.Components.PDF4NET.Forms Namespace Inheritance Hierarchy

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFCheckWidget
O2S.Components.PDF4NET.Forms.PDFCheckBoxWidget
O2S.Components.PDF4NET.Forms.PDFRadioButtonItem
O2S.Components.PDF4NET.Forms.PDFDropDownListWidget
O2S.Components.PDF4NET.Forms.PDFListBoxWidget
O2S.Components.PDF4NET.Forms.PDFPushButtonWidget
O2S.Components.PDF4NET.Forms.PDFSignatureWidget
O2S.Components.PDF4NET.Forms.PDFTextBoxWidget
O2S.Components.PDF4NET.Forms.FDFField
O2S.Components.PDF4NET.Forms.FDFFile
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFCheckBoxField
O2S.Components.PDF4NET.Forms.PDFListField
O2S.Components.PDF4NET.Forms.PDFDropDownListField
O2S.Components.PDF4NET.Forms.PDFListBoxField
O2S.Components.PDF4NET.Forms.PDFPushButtonField
O2S.Components.PDF4NET.Forms.PDFRadioButtonListField
O2S.Components.PDF4NET.Forms.PDFSignatureField
O2S.Components.PDF4NET.Forms.PDFTextBoxField
O2S.Components.PDF4NET.Forms.PDFFieldImportError
O2S.Components.PDF4NET.Forms.PDFForm
O2S.Components.PDF4NET.Forms.PDFListItem
O2S.Components.PDF4NET.Forms.PDFSignatureLockFieldAction
O2S.Components.PDF4NET.Forms.XFDFField
O2S.Components.PDF4NET.Forms.XFDFFile
System.Collections.ObjectModel.Collection<FDFField>
O2S.Components.PDF4NET.PDFCollection<FDFField, FDFFile>
O2S.Components.PDF4NET.Forms.FDFFieldCollection
System.Collections.ObjectModel.Collection<PDFField>
O2S.Components.PDF4NET.PDFCollection<PDFField, PDFForm>
O2S.Components.PDF4NET.Forms.PDFFieldCollection
System.Collections.ObjectModel.Collection<PDFFieldWidget>
O2S.Components.PDF4NET.PDFCollection<PDFFieldWidget, PDFField>
O2S.Components.PDF4NET.Forms.PDFFieldWidgetCollection
System.Collections.ObjectModel.Collection<PDFListItem>
O2S.Components.PDF4NET.PDFCollection<PDFListItem, PDFListField>
O2S.Components.PDF4NET.Forms.PDFListItemCollection
System.Collections.ObjectModel.Collection<XFDFField>
O2S.Components.PDF4NET.PDFCollection<XFDFField, XFDFFile>
O2S.Components.PDF4NET.Forms.XFDFFieldCollection

See Also

Reference

O2S.Components.PDF4NET Assembly


FDFField Class

FDFField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFField Class

Defines a field in a FDF document.

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FDFField
Visual Basic (Usage) Copy Code
Dim instance As FDFField
C#
public sealed class FDFField
Managed Extensions for C++
public __gc __sealed class FDFField
C++/CLI
public ref class FDFField sealed

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.FDFField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFField Members
O2S.Components.PDF4NET.Forms Namespace


FDFField Class Members

FDFField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFField Class

The following tables list the members exposed by FDFField.

Public Properties

 | Name | Description
Public Property | Name | Gets the field name.
Public Property | Value | Gets the field value.
Top

See Also

Reference

FDFField Class
O2S.Components.PDF4NET.Forms Namespace


FDFField Class Properties

FDFField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFField Class

For a list of all members of this type, see FDFField members.

Public Properties

 | Name | Description
Public Property | Name | Gets the field name.
Public Property | Value | Gets the field value.
Top

See Also

Reference

FDFField Class
O2S.Components.PDF4NET.Forms Namespace


Name Property

Name Property
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFField Class : Name Property

Gets the field name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As FDFField
Dim value As String

value = instance.Name
C#
public string Name {get;}
Managed Extensions for C++
public: __property string* get_Name();
C++/CLI
public:
property String^ Name {
   String^ get();
}

Return Value

A string value specifying the name of the FDF field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFField Class
FDFField Members


Value Property

Value Property
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFField Class : Value Property

Gets the field value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As FDFField
Dim value As String

value = instance.Value
C#
public string Value {get;}
Managed Extensions for C++
public: __property string* get_Value();
C++/CLI
public:
property String^ Value {
   String^ get();
}

Return Value

A string value specifying the value of the FDF field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFField Class
FDFField Members


FDFFieldCollection Class

FDFFieldCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFFieldCollection Class

Defines a collection of fields in a FDF document.

Object Model

Syntax

Visual Basic (Declaration)
Public Class FDFFieldCollection
   Inherits PDFCollection(Of FDFField, FDFFile)
Visual Basic (Usage) Copy Code
Dim instance As FDFFieldCollection
C#
public class FDFFieldCollection : PDFCollection<FDFField, FDFFile>
Managed Extensions for C++
public __gc class FDFFieldCollection : public PDFCollection<FDFField, FDFFile>
C++/CLI
public ref class FDFFieldCollection : public PDFCollection<FDFField, FDFFile>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<FDFField>
O2S.Components.PDF4NET.PDFCollection<FDFField, FDFFile>
O2S.Components.PDF4NET.Forms.FDFFieldCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFieldCollection Members
O2S.Components.PDF4NET.Forms Namespace


FDFFieldCollection Class Members

FDFFieldCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFFieldCollection Class

The following tables list the members exposed by FDFFieldCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Top

See Also

Reference

FDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


FDFFile Class

FDFFile Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFFile Class

Represents a FDF file on disk.

Object Model

Syntax

Visual Basic (Declaration)
Public Class FDFFile
Visual Basic (Usage) Copy Code
Dim instance As FDFFile
C#
public class FDFFile
Managed Extensions for C++
public __gc class FDFFile
C++/CLI
public ref class FDFFile

Remarks

This class defines an existing FDF file. Its methods allows to import/export data from/to FDF files.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.FDFFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFile Members
O2S.Components.PDF4NET.Forms Namespace


FDFFile Class Members

FDFFile Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFFile Class

The following tables list the members exposed by FDFFile.

Public Properties

 | Name | Description
Public Property | Fields | Gets the list of fields in the FDF file.
Public Property | PDFFileName | Gets the name of the PDF file the FDF file was exported from.
Top

Public Methods

 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | FromFile | Creates a FDFFile object from the given FDF file.
static (Shared in Visual Basic) | FromStream | Creates a FDFFile object from the given stream object.
Top

See Also

Reference

FDFFile Class
O2S.Components.PDF4NET.Forms Namespace


FDFFile Class Methods

FDFFile Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFFile Class

For a list of all members of this type, see FDFFile members.

Public Methods

 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | FromFile | Creates a FDFFile object from the given FDF file.
static (Shared in Visual Basic) | FromStream | Creates a FDFFile object from the given stream object.
Top

See Also

Reference

FDFFile Class
O2S.Components.PDF4NET.Forms Namespace


Close Method

Close Method
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFile Class : Close Method

Closes the underlying pdf file and frees all resources.

Syntax

Visual Basic (Declaration)
Public Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As FDFFile

instance.Close()
C#
public void Close()
Managed Extensions for C++
public: void Close();
C++/CLI
public:
void Close();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFile Class
FDFFile Members


FromFile Method

FromFile Method
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFile Class : FromFile Method

fileName
the full path to a FDF file used as source for this FDFFile object.
Creates a FDFFile object from the given FDF file.

Syntax

Visual Basic (Declaration)
Public Shared Function FromFile( _
   ByVal fileName As String _
) As FDFFile
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim value As FDFFile

value = FDFFile.FromFile(fileName)
C#
public static FDFFile FromFile(
   string fileName
)
Managed Extensions for C++
public: static FDFFile* FromFile(
   string* fileName
)
C++/CLI
public:
static FDFFile^ FromFile(
   String^ fileName
)

Parameters

fileName
the full path to a FDF file used as source for this FDFFile object.

Return Value

A FDFFile object created based on the given FDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFile Class
FDFFile Members


FromStream Method

FromStream Method
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFile Class : FromStream Method

stream
the stream object used as source for this FDFFile object.
Creates a FDFFile object from the given stream object.

Syntax

Visual Basic (Declaration)
Public Shared Function FromStream( _
   ByVal stream As Stream _
) As FDFFile
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim value As FDFFile

value = FDFFile.FromStream(stream)
C#
public static FDFFile FromStream(
   Stream stream
)
Managed Extensions for C++
public: static FDFFile* FromStream(
   Stream* stream
)
C++/CLI
public:
static FDFFile^ FromStream(
   Stream^ stream
)

Parameters

stream
the stream object used as source for this FDFFile object.

Return Value

A FDFFile object created based on the given stream object.

Remarks

The stream must contain a valid FDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFile Class
FDFFile Members


FDFFile Class Properties

FDFFile Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFFile Class

For a list of all members of this type, see FDFFile members.

Public Properties

 | Name | Description
Public Property | Fields | Gets the list of fields in the FDF file.
Public Property | PDFFileName | Gets the name of the PDF file the FDF file was exported from.
Top

See Also

Reference

FDFFile Class
O2S.Components.PDF4NET.Forms Namespace


Fields Property

Fields Property
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFile Class : Fields Property

Gets the list of fields in the FDF file.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As FDFFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As FDFFile
Dim value As FDFFieldCollection

value = instance.Fields
C#
public FDFFieldCollection Fields {get;}
Managed Extensions for C++
public: __property FDFFieldCollection* get_Fields();
C++/CLI
public:
property FDFFieldCollection^ Fields {
   FDFFieldCollection^ get();
}

Return Value

A FDFFieldCollection object specifying the list of fields in the FDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFile Class
FDFFile Members


PDFFileName Property

PDFFileName Property
[image]
O2S.Components.PDF4NET.Forms Namespace > FDFFile Class : PDFFileName Property

Gets the name of the PDF file the FDF file was exported from.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PDFFileName As String
Visual Basic (Usage) Copy Code
Dim instance As FDFFile
Dim value As String

value = instance.PDFFileName
C#
public string PDFFileName {get;}
Managed Extensions for C++
public: __property string* get_PDFFileName();
C++/CLI
public:
property String^ PDFFileName {
   String^ get();
}

Return Value

A string value specifying the the name of the PDF file the FDF file was exported from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

FDFFile Class
FDFFile Members


PDFCheckBoxField Class

PDFCheckBoxField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxField Class

Defines a checkbox in a PDF form.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCheckBoxField
   Inherits PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckBoxField
C#
public class PDFCheckBoxField : PDFField
Managed Extensions for C++
public __gc class PDFCheckBoxField : public PDFField
C++/CLI
public ref class PDFCheckBoxField : public PDFField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFCheckBoxField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxField Members
O2S.Components.PDF4NET.Forms Namespace


PDFCheckBoxField Class Members

PDFCheckBoxField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxField Class

The following tables list the members exposed by PDFCheckBoxField.

Public Constructors

 | Name | Description
Public Constructor | PDFCheckBoxField Constructor | Initializes a new PDFCheckBoxField object.
Top

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from PDFField)
Public Property | Checked | Gets or sets a value indicating whether the checkbox is checked or not.
Public Property | Dictionary | Gets the field dictionary. (Inherited from PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from PDFField)
Public Property | Type | Gets the field type. (Inherited from PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from PDFField)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from PDFField)
Top

See Also

Reference

PDFCheckBoxField Class
O2S.Components.PDF4NET.Forms Namespace


PDFCheckBoxField Constructor

PDFCheckBoxField Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxField Class : PDFCheckBoxField Constructor

name
The name of the field.
Initializes a new PDFCheckBoxField object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As PDFCheckBoxField(name)
C#
public PDFCheckBoxField(
   string name
)
Managed Extensions for C++
public: PDFCheckBoxField(
   string* name
)
C++/CLI
public:
PDFCheckBoxField(
   String^ name
)

Parameters

name
The name of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


PDFCheckBoxField Class Properties

PDFCheckBoxField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxField Class

For a list of all members of this type, see PDFCheckBoxField members.

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from PDFField)
Public Property | Checked | Gets or sets a value indicating whether the checkbox is checked or not.
Public Property | Dictionary | Gets the field dictionary. (Inherited from PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from PDFField)
Public Property | Type | Gets the field type. (Inherited from PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from PDFField)
Top

See Also

Reference

PDFCheckBoxField Class
O2S.Components.PDF4NET.Forms Namespace


Checked Property

Checked Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxField Class : Checked Property

Gets or sets a value indicating whether the checkbox is checked or not.

Syntax

Visual Basic (Declaration)
Public Property Checked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckBoxField
Dim value As Boolean

instance.Checked = value

value = instance.Checked
C#
public bool Checked {get; set;}
Managed Extensions for C++
public: __property bool get_Checked();
public: __property void set_Checked(
   bool value
);
C++/CLI
public:
property bool Checked {
   bool get();
   void set (bool value);
}

Return Value

True if at least one checkbox widget is checked, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxField Class
PDFCheckBoxField Members


PDFCheckBoxWidget Class

PDFCheckBoxWidget Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxWidget Class

Defines the widget for a check box field.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCheckBoxWidget
   Inherits PDFCheckWidget
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckBoxWidget
C#
public class PDFCheckBoxWidget : PDFCheckWidget
Managed Extensions for C++
public __gc class PDFCheckBoxWidget : public PDFCheckWidget
C++/CLI
public ref class PDFCheckBoxWidget : public PDFCheckWidget

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFCheckWidget
O2S.Components.PDF4NET.Forms.PDFCheckBoxWidget

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxWidget Members
O2S.Components.PDF4NET.Forms Namespace


PDFCheckBoxWidget Class Members

PDFCheckBoxWidget Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxWidget Class

The following tables list the members exposed by PDFCheckBoxWidget.

Public Constructors

 | Name | Description
Public Constructor | PDFCheckBoxWidget Constructor | Initializes a new PDFCheckBoxWidget object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from PDFCheckWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not. (Inherited from PDFCheckWidget)
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance. (Inherited from PDFCheckWidget)
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance. (Inherited from PDFCheckWidget)
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance. (Inherited from PDFCheckWidget)
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark. (Inherited from PDFCheckWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget. (Inherited from PDFCheckWidget)
Public Property | Field | Gets the form field that owns this widget. (Inherited from PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from PDFFieldWidget)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance. (Inherited from PDFCheckWidget)
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance. (Inherited from PDFCheckWidget)
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance. (Inherited from PDFCheckWidget)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from PDFFieldWidget)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFCheckBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFCheckBoxWidget Constructor

PDFCheckBoxWidget Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckBoxWidget Class : PDFCheckBoxWidget Constructor

Initializes a new PDFCheckBoxWidget object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckBoxWidget()
C#
public PDFCheckBoxWidget()
Managed Extensions for C++
public: PDFCheckBoxWidget();
C++/CLI
public:
PDFCheckBoxWidget();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckBoxWidget Class
PDFCheckBoxWidget Members


PDFCheckWidget Class

PDFCheckWidget Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckWidget Class

Defines a widget that can be checked.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCheckWidget
   Inherits PDFFieldWidget
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckWidget
C#
public class PDFCheckWidget : PDFFieldWidget
Managed Extensions for C++
public __gc class PDFCheckWidget : public PDFFieldWidget
C++/CLI
public ref class PDFCheckWidget : public PDFFieldWidget

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFCheckWidget
O2S.Components.PDF4NET.Forms.PDFRadioButtonItem
O2S.Components.PDF4NET.Forms.PDFCheckBoxWidget

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckWidget Members
O2S.Components.PDF4NET.Forms Namespace


PDFCheckWidget Class Members

PDFCheckWidget Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckWidget Class

The following tables list the members exposed by PDFCheckWidget.

Public Constructors

 | Name | Description
Public Constructor | PDFCheckWidget Constructor | Initializes a new PDFCheckWidget object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the widget appearance.
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not.
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance.
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance.
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance.
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget.
Public Property | Field | Gets the form field that owns this widget. (Inherited from PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from PDFFieldWidget)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance.
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance.
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance.
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from PDFFieldWidget)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFCheckWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFCheckWidget Constructor

PDFCheckWidget Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : PDFCheckWidget Constructor

Initializes a new PDFCheckWidget object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckWidget()
C#
public PDFCheckWidget()
Managed Extensions for C++
public: PDFCheckWidget();
C++/CLI
public:
PDFCheckWidget();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


PDFCheckWidget Class Properties

PDFCheckWidget Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckWidget Class

For a list of all members of this type, see PDFCheckWidget members.

Public Properties

 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the widget appearance.
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not.
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance.
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance.
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance.
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget.
Public Property | Field | Gets the form field that owns this widget. (Inherited from PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from PDFFieldWidget)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance.
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance.
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance.
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFCheckWidget Class
O2S.Components.PDF4NET.Forms Namespace


Appearance Property

Appearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : Appearance Property

Gets or sets the widget appearance.

Syntax

Visual Basic (Declaration)
Overrides Public Property Appearance As PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
C#
public override PDFAnnotationAppearance Appearance {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationAppearance* get_Appearance()override ;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
)override ;
C++/CLI
public:
property PDFAnnotationAppearance^ Appearance override {
   PDFAnnotationAppearance^ get();
   void set (PDFAnnotationAppearance^ value);
}

Return Value

The normal appearance of the field widget.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


Checked Property

Checked Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : Checked Property

Gets or sets a value indicating whether this widget is checked or not.

Syntax

Visual Basic (Declaration)
Public Property Checked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckWidget
Dim value As Boolean

instance.Checked = value

value = instance.Checked
C#
public bool Checked {get; set;}
Managed Extensions for C++
public: __property bool get_Checked();
public: __property void set_Checked(
   bool value
);
C++/CLI
public:
property bool Checked {
   bool get();
   void set (bool value);
}

Return Value

True if the widget is checked, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


CheckedDownAppearance Property

CheckedDownAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : CheckedDownAppearance Property

Gets or sets the checked down widget appearance.

Syntax

Visual Basic (Declaration)
Public Property CheckedDownAppearance As PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.CheckedDownAppearance = value

value = instance.CheckedDownAppearance
C#
public PDFAnnotationAppearance CheckedDownAppearance {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationAppearance* get_CheckedDownAppearance();
public: __property void set_CheckedDownAppearance(
   PDFAnnotationAppearance* value
);
C++/CLI
public:
property PDFAnnotationAppearance^ CheckedDownAppearance {
   PDFAnnotationAppearance^ get();
   void set (PDFAnnotationAppearance^ value);
}

Return Value

The down appearance of the field widget in checked state.

Remarks

This appearance is displayed when the mouse is clicked on the widget.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


CheckedNormalAppearance Property

CheckedNormalAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : CheckedNormalAppearance Property

Gets or sets the checked rollover widget appearance.

Syntax

Visual Basic (Declaration)
Public Property CheckedNormalAppearance As PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.CheckedNormalAppearance = value

value = instance.CheckedNormalAppearance
C#
public PDFAnnotationAppearance CheckedNormalAppearance {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationAppearance* get_CheckedNormalAppearance();
public: __property void set_CheckedNormalAppearance(
   PDFAnnotationAppearance* value
);
C++/CLI
public:
property PDFAnnotationAppearance^ CheckedNormalAppearance {
   PDFAnnotationAppearance^ get();
   void set (PDFAnnotationAppearance^ value);
}

Return Value

The rollover appearance of the field widget in checked state.

Remarks

This appearance is displayed when the mouse is over the widget.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


CheckedRolloverAppearance Property

CheckedRolloverAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : CheckedRolloverAppearance Property

Gets or sets the checked rollover widget appearance.

Syntax

Visual Basic (Declaration)
Public Property CheckedRolloverAppearance As PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.CheckedRolloverAppearance = value

value = instance.CheckedRolloverAppearance
C#
public PDFAnnotationAppearance CheckedRolloverAppearance {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationAppearance* get_CheckedRolloverAppearance();
public: __property void set_CheckedRolloverAppearance(
   PDFAnnotationAppearance* value
);
C++/CLI
public:
property PDFAnnotationAppearance^ CheckedRolloverAppearance {
   PDFAnnotationAppearance^ get();
   void set (PDFAnnotationAppearance^ value);
}

Return Value

The rollover appearance of the field widget in checked state.

Remarks

This appearance is displayed when the mouse is over the widget.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


CheckSymbolStyle Property

CheckSymbolStyle Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : CheckSymbolStyle Property

Gets or sets the symbol used as checkmark.

Syntax

Visual Basic (Declaration)
Public Property CheckSymbolStyle As PDFCheckSymbolStyle
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckWidget
Dim value As PDFCheckSymbolStyle

instance.CheckSymbolStyle = value

value = instance.CheckSymbolStyle
C#
public PDFCheckSymbolStyle CheckSymbolStyle {get; set;}
Managed Extensions for C++
public: __property PDFCheckSymbolStyle get_CheckSymbolStyle();
public: __property void set_CheckSymbolStyle(
   PDFCheckSymbolStyle value
);
C++/CLI
public:
property PDFCheckSymbolStyle CheckSymbolStyle {
   PDFCheckSymbolStyle get();
   void set (PDFCheckSymbolStyle value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


ExportValue Property

ExportValue Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : ExportValue Property

Gets or sets the export value for this check box widget.

Syntax

Visual Basic (Declaration)
Public Property ExportValue As String
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckWidget
Dim value As String

instance.ExportValue = value

value = instance.ExportValue
C#
public string ExportValue {get; set;}
Managed Extensions for C++
public: __property string* get_ExportValue();
public: __property void set_ExportValue(
   string* value
);
C++/CLI
public:
property String^ ExportValue {
   String^ get();
   void set (String^ value);
}

Return Value

The value that is exported from the form if the widget is checked.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


UncheckedDownAppearance Property

UncheckedDownAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : UncheckedDownAppearance Property

Gets or sets the unchecked down widget appearance.

Syntax

Visual Basic (Declaration)
Public Property UncheckedDownAppearance As PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.UncheckedDownAppearance = value

value = instance.UncheckedDownAppearance
C#
public PDFAnnotationAppearance UncheckedDownAppearance {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationAppearance* get_UncheckedDownAppearance();
public: __property void set_UncheckedDownAppearance(
   PDFAnnotationAppearance* value
);
C++/CLI
public:
property PDFAnnotationAppearance^ UncheckedDownAppearance {
   PDFAnnotationAppearance^ get();
   void set (PDFAnnotationAppearance^ value);
}

Return Value

The down appearance of the field widget in unchecked state.

Remarks

This appearance is displayed when the mouse is clicked on the widget.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


UncheckedNormalAppearance Property

UncheckedNormalAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : UncheckedNormalAppearance Property

Gets or sets the unchecked normal widget appearance.

Syntax

Visual Basic (Declaration)
Public Property UncheckedNormalAppearance As PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.UncheckedNormalAppearance = value

value = instance.UncheckedNormalAppearance
C#
public PDFAnnotationAppearance UncheckedNormalAppearance {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationAppearance* get_UncheckedNormalAppearance();
public: __property void set_UncheckedNormalAppearance(
   PDFAnnotationAppearance* value
);
C++/CLI
public:
property PDFAnnotationAppearance^ UncheckedNormalAppearance {
   PDFAnnotationAppearance^ get();
   void set (PDFAnnotationAppearance^ value);
}

Return Value

The normal appearance of the field widget in unchecked state.

Remarks

This appearance is displayed when the mouse is over the widget.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


UncheckedRolloverAppearance Property

UncheckedRolloverAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFCheckWidget Class : UncheckedRolloverAppearance Property

Gets or sets the unchecked rollover widget appearance.

Syntax

Visual Basic (Declaration)
Public Property UncheckedRolloverAppearance As PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckWidget
Dim value As PDFAnnotationAppearance

instance.UncheckedRolloverAppearance = value

value = instance.UncheckedRolloverAppearance
C#
public PDFAnnotationAppearance UncheckedRolloverAppearance {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationAppearance* get_UncheckedRolloverAppearance();
public: __property void set_UncheckedRolloverAppearance(
   PDFAnnotationAppearance* value
);
C++/CLI
public:
property PDFAnnotationAppearance^ UncheckedRolloverAppearance {
   PDFAnnotationAppearance^ get();
   void set (PDFAnnotationAppearance^ value);
}

Return Value

The rollover appearance of the field widget in unchecked state.

Remarks

This appearance is displayed when the mouse is over the widget.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCheckWidget Class
PDFCheckWidget Members


PDFDropDownListField Class

PDFDropDownListField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListField Class

Defines a drop down list field for user input in the PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFDropDownListField
   Inherits PDFListField
Visual Basic (Usage) Copy Code
Dim instance As PDFDropDownListField
C#
public class PDFDropDownListField : PDFListField
Managed Extensions for C++
public __gc class PDFDropDownListField : public PDFListField
C++/CLI
public ref class PDFDropDownListField : public PDFListField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFListField
O2S.Components.PDF4NET.Forms.PDFDropDownListField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDropDownListField Members
O2S.Components.PDF4NET.Forms Namespace


PDFDropDownListField Class Members

PDFDropDownListField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListField Class

The following tables list the members exposed by PDFDropDownListField.

Public Constructors

 | Name | Description
Public Constructor | PDFDropDownListField Constructor | Initializes a new PDFDropDownListField object.
Top

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from PDFField)
Public Property | CheckSpelling | Gets or sets whether the field content should be checked for spelling erorrs.
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made. (Inherited from PDFListField)
Public Property | Dictionary | Gets the field dictionary. (Inherited from PDFField)
Public Property | Edit | Gets or sets whether the user can enter text in the drop down list or not.
Public Property | Form | Gets the form that contains this field. (Inherited from PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from PDFField)
Public Property | Items | Gets the collection of items in the list. (Inherited from PDFListField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from PDFListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from PDFListField)
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list. (Inherited from PDFListField)
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not. (Inherited from PDFListField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from PDFField)
Public Property | Type | Gets the field type. (Inherited from PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from PDFField)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from PDFField)
Top

See Also

Reference

PDFDropDownListField Class
O2S.Components.PDF4NET.Forms Namespace


PDFDropDownListField Constructor

PDFDropDownListField Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFDropDownListField Class : PDFDropDownListField Constructor

name
The name of this drop down list field object.
Initializes a new PDFDropDownListField object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As PDFDropDownListField(name)
C#
public PDFDropDownListField(
   string name
)
Managed Extensions for C++
public: PDFDropDownListField(
   string* name
)
C++/CLI
public:
PDFDropDownListField(
   String^ name
)

Parameters

name
The name of this drop down list field object.

Remarks

The field name must be unique across the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDropDownListField Class
PDFDropDownListField Members


PDFDropDownListField Class Properties

PDFDropDownListField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListField Class

For a list of all members of this type, see PDFDropDownListField members.

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from PDFField)
Public Property | CheckSpelling | Gets or sets whether the field content should be checked for spelling erorrs.
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made. (Inherited from PDFListField)
Public Property | Dictionary | Gets the field dictionary. (Inherited from PDFField)
Public Property | Edit | Gets or sets whether the user can enter text in the drop down list or not.
Public Property | Form | Gets the form that contains this field. (Inherited from PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from PDFField)
Public Property | Items | Gets the collection of items in the list. (Inherited from PDFListField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from PDFListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from PDFListField)
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list. (Inherited from PDFListField)
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not. (Inherited from PDFListField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from PDFField)
Public Property | Type | Gets the field type. (Inherited from PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from PDFField)
Top

See Also

Reference

PDFDropDownListField Class
O2S.Components.PDF4NET.Forms Namespace


CheckSpelling Property

CheckSpelling Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFDropDownListField Class : CheckSpelling Property

Gets or sets whether the field content should be checked for spelling erorrs.

Syntax

Visual Basic (Declaration)
Public Property CheckSpelling As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDropDownListField
Dim value As Boolean

instance.CheckSpelling = value

value = instance.CheckSpelling
C#
public bool CheckSpelling {get; set;}
Managed Extensions for C++
public: __property bool get_CheckSpelling();
public: __property void set_CheckSpelling(
   bool value
);
C++/CLI
public:
property bool CheckSpelling {
   bool get();
   void set (bool value);
}

Return Value

True if the field content should be checked for spelling erorrs, false otherwise. Default is true.

Remarks

The field content is checked for spelling errors only when the PDF file is opened in the viewer (if the PDF viewer support this feature) and it is not spell checked when its value is set from code. This flag has meaning only if Edit is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDropDownListField Class
PDFDropDownListField Members


Edit Property

Edit Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFDropDownListField Class : Edit Property

Gets or sets whether the user can enter text in the drop down list or not.

Syntax

Visual Basic (Declaration)
Public Property Edit As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDropDownListField
Dim value As Boolean

instance.Edit = value

value = instance.Edit
C#
public bool Edit {get; set;}
Managed Extensions for C++
public: __property bool get_Edit();
public: __property void set_Edit(
   bool value
);
C++/CLI
public:
property bool Edit {
   bool get();
   void set (bool value);
}

Return Value

True if the drop down list is editable, false otherwise. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDropDownListField Class
PDFDropDownListField Members


PDFDropDownListWidget Class

PDFDropDownListWidget Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListWidget Class

Defines the widget for a textbox field.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFDropDownListWidget
   Inherits PDFFieldWidget
Visual Basic (Usage) Copy Code
Dim instance As PDFDropDownListWidget
C#
public class PDFDropDownListWidget : PDFFieldWidget
Managed Extensions for C++
public __gc class PDFDropDownListWidget : public PDFFieldWidget
C++/CLI
public ref class PDFDropDownListWidget : public PDFFieldWidget

Remarks

The field widget is the field's visual representation on a PDF page. A textbox field can have multiple widgets on the same page or on different pages. All the field widgets display the same field value.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFDropDownListWidget

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDropDownListWidget Members
O2S.Components.PDF4NET.Forms Namespace


PDFDropDownListWidget Class Members

PDFDropDownListWidget Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListWidget Class

The following tables list the members exposed by PDFDropDownListWidget.

Public Constructors

 | Name | Description
Public Constructor | PDFDropDownListWidget Constructor | Initializes a new PDFDropDownListWidget object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from PDFFieldWidget)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from PDFFieldWidget)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFDropDownListWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFDropDownListWidget Constructor

PDFDropDownListWidget Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFDropDownListWidget Class : PDFDropDownListWidget Constructor

Initializes a new PDFDropDownListWidget object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDropDownListWidget()
C#
public PDFDropDownListWidget()
Managed Extensions for C++
public: PDFDropDownListWidget();
C++/CLI
public:
PDFDropDownListWidget();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDropDownListWidget Class
PDFDropDownListWidget Members


PDFField Class

PDFField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFField Class

Defines the base class for form fields in a PDF form.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFField
C#
public class PDFField
Managed Extensions for C++
public __gc class PDFField
C++/CLI
public ref class PDFField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFTextBoxField
O2S.Components.PDF4NET.Forms.PDFSignatureField
O2S.Components.PDF4NET.Forms.PDFRadioButtonListField
O2S.Components.PDF4NET.Forms.PDFPushButtonField
O2S.Components.PDF4NET.Forms.PDFListField
O2S.Components.PDF4NET.Forms.PDFCheckBoxField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Members
O2S.Components.PDF4NET.Forms Namespace


PDFField Class Members

PDFField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFField Class

The following tables list the members exposed by PDFField.

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value.
Public Property | Dictionary | Gets the field dictionary.
Public Property | Form | Gets the form that contains this field.
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value.
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke.
Public Property | MappingName | Gets or sets the mapping name of the field.
Public Property | Name | Gets or sets the field name.
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only.
Public Property | Required | Gets or sets a value indicating whether the field is required.
Public Property | Tooltip | Gets or sets the field tooltip.
Public Property | Type | Gets the field type.
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value.
Public Property | Value | Gets or sets the field value.
Public Property | Widgets | Gets the list of widgets associated with this field.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources.
Top

See Also

Reference

PDFField Class
O2S.Components.PDF4NET.Forms Namespace


PDFField Class Methods

PDFField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFField Class

For a list of all members of this type, see PDFField members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources.
Top

See Also

Reference

PDFField Class
O2S.Components.PDF4NET.Forms Namespace


Dispose Method

Dispose Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Dispose Method

Disposes the internal resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As PDFField

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


PDFField Class Properties

PDFField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFField Class

For a list of all members of this type, see PDFField members.

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value.
Public Property | Dictionary | Gets the field dictionary.
Public Property | Form | Gets the form that contains this field.
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value.
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke.
Public Property | MappingName | Gets or sets the mapping name of the field.
Public Property | Name | Gets or sets the field name.
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only.
Public Property | Required | Gets or sets a value indicating whether the field is required.
Public Property | Tooltip | Gets or sets the field tooltip.
Public Property | Type | Gets the field type.
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value.
Public Property | Value | Gets or sets the field value.
Public Property | Widgets | Gets the list of widgets associated with this field.
Top

See Also

Reference

PDFField Class
O2S.Components.PDF4NET.Forms Namespace


CalculateAction Property

CalculateAction Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : CalculateAction Property

Gets or sets the JavaScript action to be executed for calculating the field value.

Syntax

Visual Basic (Declaration)
Public Property CalculateAction As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As PDFJavaScriptAction

instance.CalculateAction = value

value = instance.CalculateAction
C#
public PDFJavaScriptAction CalculateAction {get; set;}
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_CalculateAction();
public: __property void set_CalculateAction(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ CalculateAction {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed for calculating the field value.

Remarks

This property specifies a JavaScript action to be performed to recalculate the value of this field when that of another field changes.
This action has no meaning for PDFPushButtonField, PDFCheckBoxField, PDFRadioButtonListField and PDFListBoxField fields.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


Dictionary Property

Dictionary Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Dictionary Property

Gets the field dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dictionary As PDFDictionary
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As PDFDictionary

value = instance.Dictionary
C#
public PDFDictionary Dictionary {get;}
Managed Extensions for C++
public: __property PDFDictionary* get_Dictionary();
C++/CLI
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Return Value

The raw field dictionary.

Remarks

This property gives you direct access to field dictionary and its associated resources. Note: Modifying directly the field dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


Form Property

Form Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Form Property

Gets the form that contains this field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Form As PDFForm
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As PDFForm

value = instance.Form
C#
public PDFForm Form {get;}
Managed Extensions for C++
public: __property PDFForm* get_Form();
C++/CLI
public:
property PDFForm^ Form {
   PDFForm^ get();
}

Return Value

The form that owns the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


FormatAction Property

FormatAction Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : FormatAction Property

Gets or sets the JavaScript action to be executed for formating the field value.

Syntax

Visual Basic (Declaration)
Public Property FormatAction As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As PDFJavaScriptAction

instance.FormatAction = value

value = instance.FormatAction
C#
public PDFJavaScriptAction FormatAction {get; set;}
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_FormatAction();
public: __property void set_FormatAction(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ FormatAction {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed for formating the field value.

Remarks

This property specifies a JavaScript action to be performed before the field is formatted to display its current value. This action can modify the field’s value before formatting.
This action has no meaning for PDFPushButtonField, PDFCheckBoxField, PDFRadioButtonListField and PDFListBoxField fields.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


KeyPressAction Property

KeyPressAction Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : KeyPressAction Property

Gets or sets the JavaScript action to be executed when the user types a keystroke.

Syntax

Visual Basic (Declaration)
Public Property KeyPressAction As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As PDFJavaScriptAction

instance.KeyPressAction = value

value = instance.KeyPressAction
C#
public PDFJavaScriptAction KeyPressAction {get; set;}
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_KeyPressAction();
public: __property void set_KeyPressAction(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ KeyPressAction {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed when the user types a keystroke.

Remarks

This property specifies a JavaScript action to be performed when the user types a keystroke into a text field or combo box or modifies the selection in a scrollable list box. This action can check the keystroke for validity and reject or modify it.
This action has no meaning for PDFPushButtonField, PDFCheckBoxField and PDFRadioButtonListField fields.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


MappingName Property

MappingName Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : MappingName Property

Gets or sets the mapping name of the field.

Syntax

Visual Basic (Declaration)
Public Property MappingName As String
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As String

instance.MappingName = value

value = instance.MappingName
C#
public string MappingName {get; set;}
Managed Extensions for C++
public: __property string* get_MappingName();
public: __property void set_MappingName(
   string* value
);
C++/CLI
public:
property String^ MappingName {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the mapping name of the field.

Remarks

The field's mapping name is used when exporting interactive form field data from the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


Name Property

Name Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Name Property

Gets or sets the field name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Return Value

The fully qualified field name.

Exceptions

Exception | Description
ArgumentException | Thrown when the name is null or empty or not a valid PDF field name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


NoExport Property

NoExport Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : NoExport Property

Gets or sets a value indicating whether the field can be exported or not.

Syntax

Visual Basic (Declaration)
Public Property NoExport As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As Boolean

instance.NoExport = value

value = instance.NoExport
C#
public bool NoExport {get; set;}
Managed Extensions for C++
public: __property bool get_NoExport();
public: __property void set_NoExport(
   bool value
);
C++/CLI
public:
property bool NoExport {
   bool get();
   void set (bool value);
}

Return Value

True if the field can not be exported, false otherwise. Default is false.

Remarks

If true, the field must not be exported by a submit-form action.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


ReadOnly Property

ReadOnly Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : ReadOnly Property

Gets or sets a value indicating whether the field is read-only.

Syntax

Visual Basic (Declaration)
Public Property ReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
public bool ReadOnly {get; set;}
Managed Extensions for C++
public: __property bool get_ReadOnly();
public: __property void set_ReadOnly(
   bool value
);
C++/CLI
public:
property bool ReadOnly {
   bool get();
   void set (bool value);
}

Return Value

True if the field is read-only, false otherwise. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


Required Property

Required Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Required Property

Gets or sets a value indicating whether the field is required.

Syntax

Visual Basic (Declaration)
Public Property Required As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As Boolean

instance.Required = value

value = instance.Required
C#
public bool Required {get; set;}
Managed Extensions for C++
public: __property bool get_Required();
public: __property void set_Required(
   bool value
);
C++/CLI
public:
property bool Required {
   bool get();
   void set (bool value);
}

Return Value

True if the field is required, false otherwise. Default is false.

Remarks

If true, the field must have a value when it is exported by a submit-form action.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


Tooltip Property

Tooltip Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Tooltip Property

Gets or sets the field tooltip.

Syntax

Visual Basic (Declaration)
Public Overridable Property Tooltip As String
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As String

instance.Tooltip = value

value = instance.Tooltip
C#
public virtual string Tooltip {get; set;}
Managed Extensions for C++
public: __property virtual string* get_Tooltip();
public: __property virtual void set_Tooltip(
   string* value
);
C++/CLI
public:
virtual property String^ Tooltip {
   String^ get();
   void set (String^ value);
}

Return Value

The field's tooltip.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


Type Property

Type Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Type Property

Gets the field type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As PDFFieldType
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As PDFFieldType

value = instance.Type
C#
public PDFFieldType Type {get;}
Managed Extensions for C++
public: __property PDFFieldType get_Type();
C++/CLI
public:
property PDFFieldType Type {
   PDFFieldType get();
}

Return Value

The type of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


ValidateAction Property

ValidateAction Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : ValidateAction Property

Gets or sets the JavaScript action to be executed for validating the field value.

Syntax

Visual Basic (Declaration)
Public Property ValidateAction As PDFJavaScriptAction
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As PDFJavaScriptAction

instance.ValidateAction = value

value = instance.ValidateAction
C#
public PDFJavaScriptAction ValidateAction {get; set;}
Managed Extensions for C++
public: __property PDFJavaScriptAction* get_ValidateAction();
public: __property void set_ValidateAction(
   PDFJavaScriptAction* value
);
C++/CLI
public:
property PDFJavaScriptAction^ ValidateAction {
   PDFJavaScriptAction^ get();
   void set (PDFJavaScriptAction^ value);
}

Return Value

A PDFJavaScriptAction object specifying the action to be executed for validating the field value.

Remarks

This property specifies a JavaScript action to be performed when the field’s value is changed. This action can check the new value for validity.
This action has no meaning for PDFPushButtonField, PDFCheckBoxField, PDFRadioButtonListField and PDFListBoxField fields.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


Value Property

Value Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Value Property

Gets or sets the field value.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As Object

instance.Value = value

value = instance.Value
C#
public object Value {get; set;}
Managed Extensions for C++
public: __property Object* get_Value();
public: __property void set_Value(
   Object* value
);
C++/CLI
public:
property Object^ Value {
   Object^ get();
   void set (Object^ value);
}

Return Value

The field value.

Remarks

The value type depends on the actual field. Check box fields accept string and boolean values while other fields work only with strings. If other type is provided, it will be converted to string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


Widgets Property

Widgets Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFField Class : Widgets Property

Gets the list of widgets associated with this field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Widgets As PDFFieldWidgetCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFField
Dim value As PDFFieldWidgetCollection

value = instance.Widgets
C#
public PDFFieldWidgetCollection Widgets {get;}
Managed Extensions for C++
public: __property PDFFieldWidgetCollection* get_Widgets();
C++/CLI
public:
property PDFFieldWidgetCollection^ Widgets {
   PDFFieldWidgetCollection^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFField Class
PDFField Members


PDFFieldCollection Class

PDFFieldCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldCollection Class

Defines a collection of form fields.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PDFFieldCollection
   Inherits PDFCollection(Of PDFField, PDFForm)
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldCollection
C#
[DefaultMemberAttribute("Item")]
public class PDFFieldCollection : PDFCollection<PDFField, PDFForm>
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class PDFFieldCollection : public PDFCollection<PDFField, PDFForm>
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class PDFFieldCollection : public PDFCollection<PDFField, PDFForm>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<PDFField>
O2S.Components.PDF4NET.PDFCollection<PDFField, PDFForm>
O2S.Components.PDF4NET.Forms.PDFFieldCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldCollection Members
O2S.Components.PDF4NET.Forms Namespace


PDFFieldCollection Class Members

PDFFieldCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldCollection Class

The following tables list the members exposed by PDFFieldCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Property | Item | Overloaded. Gets the field with the specified name.
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Dispose | Disposes the internal objects and resources.
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Remove | Overloaded. Removes the field with the specified name from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Top

See Also

Reference

PDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


PDFFieldCollection Class Methods

PDFFieldCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldCollection Class

For a list of all members of this type, see PDFFieldCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Dispose | Disposes the internal objects and resources.
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Method | Remove | Overloaded. Removes the field with the specified name from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Top

See Also

Reference

PDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


Dispose Method

Dispose Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldCollection Class : Dispose Method

Disposes the internal objects and resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldCollection

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Remarks

This method also calls Dispose on the objects in the collection. If you want to remove the items from the collection then call the Clear method.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldCollection Class
PDFFieldCollection Members


Remove Method

Remove Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldCollection Class : Remove Method

Removes the field with the specified name from the collection.

Overload List

Overload | Description
Remove(String) | Removes the field with the specified name from the collection.
Remove(PDFField) | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldCollection Class
PDFFieldCollection Members


Remove(String) Method

Remove(String) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldCollection Class > Remove Method : Remove(String) Method

name
The name of the field to remove.
Removes the field with the specified name from the collection.

Syntax

Visual Basic (Declaration)
Overloads Public Sub Remove( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldCollection
Dim name As String

instance.Remove(name)
C#
public void Remove(
   string name
)
Managed Extensions for C++
public: void Remove(
   string* name
)
C++/CLI
public:
void Remove(
   String^ name
)

Parameters

name
The name of the field to remove.

Remarks

If the field with the specified name does not exist in the collection nothing happens.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldCollection Class
PDFFieldCollection Members
Overload List


PDFFieldCollection Class Properties

PDFFieldCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldCollection Class

For a list of all members of this type, see PDFFieldCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)
Public Property | Item | Overloaded. Gets the field with the specified name.
Top

See Also

Reference

PDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


Item Property

Item Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldCollection Class : Item Property

Gets the field with the specified name.

Overload List

Overload | Description
Item(String) | Gets the field with the specified name.
Item(Int32) | (Inherited from System.Collections.ObjectModel.Collection<PDFField>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldCollection Class
PDFFieldCollection Members


Item(String) Property

Item(String) Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldCollection Class > Item Property : Item(String) Property

name
The name of the field to lookup in the collection.
Gets the field with the specified name.

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldCollection
Dim name As String
Dim value As PDFField

value = instance.Item(name)
C#
public PDFField Item(
   string name
) {get;}
Managed Extensions for C++
public: __property PDFField* get_Item(
   string* name
);
C++/CLI
public:
property PDFField^ Item {
   PDFField^ get(String^ name);
}

Parameters

name
The name of the field to lookup in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldCollection Class
PDFFieldCollection Members
Overload List


PDFFieldImportError Class

PDFFieldImportError Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldImportError Class

Represents an error that happened during the import of a FDF/XFDF/XML file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFieldImportError
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldImportError
C#
public class PDFFieldImportError
Managed Extensions for C++
public __gc class PDFFieldImportError
C++/CLI
public ref class PDFFieldImportError

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFFieldImportError

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldImportError Members
O2S.Components.PDF4NET.Forms Namespace


PDFFieldImportError Class Members

PDFFieldImportError Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldImportError Class

The following tables list the members exposed by PDFFieldImportError.

Public Properties

 | Name | Description
Public Property | Exception | Gets the exception thrown by the field during the import.
Public Property | Field | Gets the field that generated the import error.
Top

See Also

Reference

PDFFieldImportError Class
O2S.Components.PDF4NET.Forms Namespace


PDFFieldImportError Class Properties

PDFFieldImportError Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldImportError Class

For a list of all members of this type, see PDFFieldImportError members.

Public Properties

 | Name | Description
Public Property | Exception | Gets the exception thrown by the field during the import.
Public Property | Field | Gets the field that generated the import error.
Top

See Also

Reference

PDFFieldImportError Class
O2S.Components.PDF4NET.Forms Namespace


Exception Property

Exception Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldImportError Class : Exception Property

Gets the exception thrown by the field during the import.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldImportError
Dim value As Exception

value = instance.Exception
C#
public Exception Exception {get;}
Managed Extensions for C++
public: __property Exception* get_Exception();
C++/CLI
public:
property Exception^ Exception {
   Exception^ get();
}

Return Value

A Exception object with the details about the import error.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldImportError Class
PDFFieldImportError Members


Field Property

Field Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldImportError Class : Field Property

Gets the field that generated the import error.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Field As PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldImportError
Dim value As PDFField

value = instance.Field
C#
public PDFField Field {get;}
Managed Extensions for C++
public: __property PDFField* get_Field();
C++/CLI
public:
property PDFField^ Field {
   PDFField^ get();
}

Return Value

A PDFField object representing the field that generated the error.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldImportError Class
PDFFieldImportError Members


PDFFieldWidget Class

PDFFieldWidget Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidget Class

Defines the widget for a form field.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFieldWidget
   Inherits PDFAnnotation
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldWidget
C#
public class PDFFieldWidget : PDFAnnotation
Managed Extensions for C++
public __gc class PDFFieldWidget : public PDFAnnotation
C++/CLI
public ref class PDFFieldWidget : public PDFAnnotation

Remarks

The field widget is the field's visual representation on a PDF page. A form field can have multiple widgets on the same page or on different pages. All the field widgets display the same field value.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFTextBoxWidget
O2S.Components.PDF4NET.Forms.PDFSignatureWidget
O2S.Components.PDF4NET.Forms.PDFPushButtonWidget
O2S.Components.PDF4NET.Forms.PDFListBoxWidget
O2S.Components.PDF4NET.Forms.PDFDropDownListWidget
O2S.Components.PDF4NET.Forms.PDFCheckWidget

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldWidget Members
O2S.Components.PDF4NET.Forms Namespace


PDFFieldWidget Class Members

PDFFieldWidget Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidget Class

The following tables list the members exposed by PDFFieldWidget.

Public Constructors

 | Name | Description
Public Constructor | PDFFieldWidget Constructor | Initializes a new PDFFieldWidget object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the widget appearance.
Public Property | BackColor | Gets or sets the widget's background color.
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus.
Public Property | BorderColor | Gets or sets the widget's border color.
Public Property | BorderStyle | Gets or sets the widget's border style.
Public Property | BorderWidth | Gets or sets the widget's border width.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus.
Public Property | Font | Gets or sets the font used to display the widget text.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the widget rotation angle.
Public Property | TextColor | Gets or sets the widget's text color.
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget.
Top

Public Methods

 | Name | Description
Public Method | Flatten | Overridden. Flattens the field widget.
Top

See Also

Reference

PDFFieldWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFFieldWidget Constructor

PDFFieldWidget Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : PDFFieldWidget Constructor

Initializes a new PDFFieldWidget object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldWidget()
C#
public PDFFieldWidget()
Managed Extensions for C++
public: PDFFieldWidget();
C++/CLI
public:
PDFFieldWidget();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


PDFFieldWidget Class Methods

PDFFieldWidget Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidget Class

For a list of all members of this type, see PDFFieldWidget members.

Public Methods

 | Name | Description
Public Method | Flatten | Overridden. Flattens the field widget.
Top

See Also

Reference

PDFFieldWidget Class
O2S.Components.PDF4NET.Forms Namespace


Flatten Method

Flatten Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : Flatten Method

Flattens the field widget.

Syntax

Visual Basic (Declaration)
Overrides Public Sub Flatten()
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldWidget

instance.Flatten()
C#
public override void Flatten()
Managed Extensions for C++
public: void Flatten(); override
C++/CLI
public:
void Flatten(); override

Remarks

This operation writes the field appearance to the page content and destroys the widget. Its effects are irreversible. After calling this method the PDFFieldWidget object is invalid and should no longer be used.
If this is the only widget of the field, the field object will also be removed from the document and destroyed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


PDFFieldWidget Class Properties

PDFFieldWidget Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidget Class

For a list of all members of this type, see PDFFieldWidget members.

Public Properties

 | Name | Description
Public Property | Appearance | Overridden. Gets or sets the widget appearance.
Public Property | BackColor | Gets or sets the widget's background color.
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus.
Public Property | BorderColor | Gets or sets the widget's border color.
Public Property | BorderStyle | Gets or sets the widget's border style.
Public Property | BorderWidth | Gets or sets the widget's border width.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget.
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus.
Public Property | Font | Gets or sets the font used to display the widget text.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Overridden. Gets or sets the widget rotation angle.
Public Property | TextColor | Gets or sets the widget's text color.
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget.
Top

See Also

Reference

PDFFieldWidget Class
O2S.Components.PDF4NET.Forms Namespace


Appearance Property

Appearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : Appearance Property

Gets or sets the widget appearance.

Syntax

Visual Basic (Declaration)
Overrides Public Property Appearance As PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldWidget
Dim value As PDFAnnotationAppearance

instance.Appearance = value

value = instance.Appearance
C#
public override PDFAnnotationAppearance Appearance {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationAppearance* get_Appearance()override ;
public: __property void set_Appearance(
   PDFAnnotationAppearance* value
)override ;
C++/CLI
public:
property PDFAnnotationAppearance^ Appearance override {
   PDFAnnotationAppearance^ get();
   void set (PDFAnnotationAppearance^ value);
}

Return Value

The normal appearance of the field widget.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


BackColor Property

BackColor Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : BackColor Property

Gets or sets the widget's background color.

Syntax

Visual Basic (Declaration)
Public Property BackColor As PDFDeviceColor
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldWidget
Dim value As PDFDeviceColor

instance.BackColor = value

value = instance.BackColor
C#
public PDFDeviceColor BackColor {get; set;}
Managed Extensions for C++
public: __property PDFDeviceColor* get_BackColor();
public: __property void set_BackColor(
   PDFDeviceColor* value
);
C++/CLI
public:
property PDFDeviceColor^ BackColor {
   PDFDeviceColor^ get();
   void set (PDFDeviceColor^ value);
}

Return Value

The color of widget's background.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


Blur Property

Blur Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : Blur Property

Gets or sets the action that is executed when the field widget loses focus.

Syntax

Visual Basic (Declaration)
Public Property Blur As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldWidget
Dim value As PDFAction

instance.Blur = value

value = instance.Blur
C#
public PDFAction Blur {get; set;}
Managed Extensions for C++
public: __property PDFAction* get_Blur();
public: __property void set_Blur(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ Blur {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

The action to be executed when the field widget loses focus.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


BorderColor Property

BorderColor Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : BorderColor Property

Gets or sets the widget's border color.

Syntax

Visual Basic (Declaration)
Public Property BorderColor As PDFDeviceColor
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldWidget
Dim value As PDFDeviceColor

instance.BorderColor = value

value = instance.BorderColor
C#
public PDFDeviceColor BorderColor {get; set;}
Managed Extensions for C++
public: __property PDFDeviceColor* get_BorderColor();
public: __property void set_BorderColor(
   PDFDeviceColor* value
);
C++/CLI
public:
property PDFDeviceColor^ BorderColor {
   PDFDeviceColor^ get();
   void set (PDFDeviceColor^ value);
}

Return Value

The color of widget's border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


BorderStyle Property

BorderStyle Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : BorderStyle Property

Gets or sets the widget's border style.

Syntax

Visual Basic (Declaration)
Public Property BorderStyle As PDFBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldWidget
Dim value As PDFBorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public PDFBorderStyle BorderStyle {get; set;}
Managed Extensions for C++
public: __property PDFBorderStyle get_BorderStyle();
public: __property void set_BorderStyle(
   PDFBorderStyle value
);
C++/CLI
public:
property PDFBorderStyle BorderStyle {
   PDFBorderStyle get();
   void set (PDFBorderStyle value);
}

Return Value

The style of widget's border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


BorderWidth Property

BorderWidth Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : BorderWidth Property

Gets or sets the widget's border width.

Syntax

Visual Basic (Declaration)
Public Property BorderWidth As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldWidget
Dim value As Double

instance.BorderWidth = value

value = instance.BorderWidth
C#
public double BorderWidth {get; set;}
Managed Extensions for C++
public: __property double get_BorderWidth();
public: __property void set_BorderWidth(
   double value
);
C++/CLI
public:
property double BorderWidth {
   double get();
   void set (double value);
}

Return Value

The width of widget's border.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


Field Property

Field Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : Field Property

Gets the form field that owns this widget.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Field As PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldWidget
Dim value As PDFField

value = instance.Field
C#
public PDFField Field {get;}
Managed Extensions for C++
public: __property PDFField* get_Field();
C++/CLI
public:
property PDFField^ Field {
   PDFField^ get();
}

Return Value

The form field that owns this widget.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


Focus Property

Focus Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : Focus Property

Gets or sets the action that is executed when the field widget receives focus.

Syntax

Visual Basic (Declaration)
Public Property Focus As PDFAction
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldWidget
Dim value As PDFAction

instance.Focus = value

value = instance.Focus
C#
public PDFAction Focus {get; set;}
Managed Extensions for C++
public: __property PDFAction* get_Focus();
public: __property void set_Focus(
   PDFAction* value
);
C++/CLI
public:
property PDFAction^ Focus {
   PDFAction^ get();
   void set (PDFAction^ value);
}

Return Value

The action to be executed when the field widget receives focus.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


Font Property

Font Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : Font Property

Gets or sets the font used to display the widget text.

Syntax

Visual Basic (Declaration)
Public Property Font As PDFFontBase
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldWidget
Dim value As PDFFontBase

instance.Font = value

value = instance.Font
C#
public PDFFontBase Font {get; set;}
Managed Extensions for C++
public: __property PDFFontBase* get_Font();
public: __property void set_Font(
   PDFFontBase* value
);
C++/CLI
public:
property PDFFontBase^ Font {
   PDFFontBase^ get();
   void set (PDFFontBase^ value);
}

Return Value

The font used for displaying the widget content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


Rotation Property

Rotation Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : Rotation Property

Gets or sets the widget rotation angle.

Syntax

Visual Basic (Declaration)
Overrides Public Property Rotation As PDFRotationMode
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldWidget
Dim value As PDFRotationMode

instance.Rotation = value

value = instance.Rotation
C#
public override PDFRotationMode Rotation {get; set;}
Managed Extensions for C++
public: __property PDFRotationMode get_Rotation()override ;
public: __property void set_Rotation(
   PDFRotationMode value
)override ;
C++/CLI
public:
property PDFRotationMode Rotation override {
   PDFRotationMode get();
   void set (PDFRotationMode value);
}

Return Value

The rotation angle of the widget.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


TextColor Property

TextColor Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : TextColor Property

Gets or sets the widget's text color.

Syntax

Visual Basic (Declaration)
Public Property TextColor As PDFDeviceColor
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldWidget
Dim value As PDFDeviceColor

instance.TextColor = value

value = instance.TextColor
C#
public PDFDeviceColor TextColor {get; set;}
Managed Extensions for C++
public: __property PDFDeviceColor* get_TextColor();
public: __property void set_TextColor(
   PDFDeviceColor* value
);
C++/CLI
public:
property PDFDeviceColor^ TextColor {
   PDFDeviceColor^ get();
   void set (PDFDeviceColor^ value);
}

Return Value

The color of widget's text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


VisibilityStatus Property

VisibilityStatus Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFFieldWidget Class : VisibilityStatus Property

Gets or sets the visibility status of the field widget.

Syntax

Visual Basic (Declaration)
Public Property VisibilityStatus As PDFFieldWidgetVisibilityStatus
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldWidget
Dim value As PDFFieldWidgetVisibilityStatus

instance.VisibilityStatus = value

value = instance.VisibilityStatus
C#
public PDFFieldWidgetVisibilityStatus VisibilityStatus {get; set;}
Managed Extensions for C++
public: __property PDFFieldWidgetVisibilityStatus get_VisibilityStatus();
public: __property void set_VisibilityStatus(
   PDFFieldWidgetVisibilityStatus value
);
C++/CLI
public:
property PDFFieldWidgetVisibilityStatus VisibilityStatus {
   PDFFieldWidgetVisibilityStatus get();
   void set (PDFFieldWidgetVisibilityStatus value);
}

Return Value

A PDFFieldWidgetVisibilityStatus enumeration member specifying the visibility status of the field widget.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldWidget Class
PDFFieldWidget Members


PDFFieldWidgetCollection Class

PDFFieldWidgetCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidgetCollection Class

Defines a collection of form fields.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFieldWidgetCollection
   Inherits PDFCollection(Of PDFFieldWidget, PDFField)
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldWidgetCollection
C#
public class PDFFieldWidgetCollection : PDFCollection<PDFFieldWidget, PDFField>
Managed Extensions for C++
public __gc class PDFFieldWidgetCollection : public PDFCollection<PDFFieldWidget, PDFField>
C++/CLI
public ref class PDFFieldWidgetCollection : public PDFCollection<PDFFieldWidget, PDFField>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<PDFFieldWidget>
O2S.Components.PDF4NET.PDFCollection<PDFFieldWidget, PDFField>
O2S.Components.PDF4NET.Forms.PDFFieldWidgetCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFieldWidgetCollection Members
O2S.Components.PDF4NET.Forms Namespace


PDFFieldWidgetCollection Class Members

PDFFieldWidgetCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidgetCollection Class

The following tables list the members exposed by PDFFieldWidgetCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Top

See Also

Reference

PDFFieldWidgetCollection Class
O2S.Components.PDF4NET.Forms Namespace


PDFForm Class

PDFForm Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFForm Class

Defines a form in a PDF document.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFForm
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
C#
public class PDFForm
Managed Extensions for C++
public __gc class PDFForm
C++/CLI
public ref class PDFForm

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFForm

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Members
O2S.Components.PDF4NET.Forms Namespace


PDFForm Class Members

PDFForm Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFForm Class

The following tables list the members exposed by PDFForm.

Public Properties

 | Name | Description
Public Property | Document | Gets the document that includes this form.
Public Property | Fields | Gets the list of fields included in the form.
Top

Public Methods

 | Name | Description
Public Method | ExportData | Overloaded. Exports the form data to a file.
Public Method | FlattenFormField | Flattens the specified form field, making the field uneditable.
Public Method | FlattenFormFields | Flattens all the fields in the PDF form, making the PDF file uneditable.
Public Method | ImportData | Overloaded. Imports form data from an external file.
Top

See Also

Reference

PDFForm Class
O2S.Components.PDF4NET.Forms Namespace


PDFForm Class Methods

PDFForm Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFForm Class

For a list of all members of this type, see PDFForm members.

Public Methods

 | Name | Description
Public Method | ExportData | Overloaded. Exports the form data to a file.
Public Method | FlattenFormField | Flattens the specified form field, making the field uneditable.
Public Method | FlattenFormFields | Flattens all the fields in the PDF form, making the PDF file uneditable.
Public Method | ImportData | Overloaded. Imports form data from an external file.
Top

See Also

Reference

PDFForm Class
O2S.Components.PDF4NET.Forms Namespace


ExportData Method

ExportData Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : ExportData Method

Exports the form data to a file.

Overload List

Overload | Description
ExportData(String,PDFFormDataFormat,PDFExportDataOptions,String) | Exports the form data to a file.
ExportData(Stream,PDFFormDataFormat,PDFExportDataOptions,String) | Exports the form data to a stream.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members


ExportData(String,PDFFormDataFormat,PDFExportDataOptions,String) Method

ExportData(String,PDFFormDataFormat,PDFExportDataOptions,String) Method
See Also
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ExportData Method : ExportData(String,PDFFormDataFormat,PDFExportDataOptions,String) Method

fileName
The full path to the file where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
pdfFileName
The name of the PDF file the data is exported from.
Exports the form data to a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ExportData( _
   ByVal fileName As String, _
   ByVal format As PDFFormDataFormat, _
   ByVal options As PDFExportDataOptions, _
   ByVal pdfFileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim fileName As String
Dim format As PDFFormDataFormat
Dim options As PDFExportDataOptions
Dim pdfFileName As String

instance.ExportData(fileName, format, options, pdfFileName)
C#
public void ExportData(
   string fileName,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   string pdfFileName
)
Managed Extensions for C++
public: void ExportData(
   string* fileName,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   string* pdfFileName
)
C++/CLI
public:
void ExportData(
   String^ fileName,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   String^ pdfFileName
)

Parameters

fileName
The full path to the file where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
pdfFileName
The name of the PDF file the data is exported from.

Remarks

The name of the source PDF file is required because the data files (both FDF and XFDF) need a reference to the PDF file from which they were exported. This file name does not need to match the actual file name used for saving the PDF document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


ExportData(Stream,PDFFormDataFormat,PDFExportDataOptions,String) Method

ExportData(Stream,PDFFormDataFormat,PDFExportDataOptions,String) Method
See Also
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ExportData Method : ExportData(Stream,PDFFormDataFormat,PDFExportDataOptions,String) Method

stream
The stream where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
pdfFilename
The name of the PDF file the data is exported from.
Exports the form data to a stream.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ExportData( _
   ByVal stream As Stream, _
   ByVal format As PDFFormDataFormat, _
   ByVal options As PDFExportDataOptions, _
   ByVal pdfFilename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim stream As Stream
Dim format As PDFFormDataFormat
Dim options As PDFExportDataOptions
Dim pdfFilename As String

instance.ExportData(stream, format, options, pdfFilename)
C#
public void ExportData(
   Stream stream,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   string pdfFilename
)
Managed Extensions for C++
public: void ExportData(
   Stream* stream,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   string* pdfFilename
)
C++/CLI
public:
void ExportData(
   Stream^ stream,
   PDFFormDataFormat format,
   PDFExportDataOptions options,
   String^ pdfFilename
)

Parameters

stream
The stream where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
pdfFilename
The name of the PDF file the data is exported from.

Remarks

The name of the source PDF file is required because the data files (both FDF and XFDF) need a reference to the PDF file from which they were exported. This file name does not need to match the actual file name used for saving the PDF document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


FlattenFormField Method

FlattenFormField Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : FlattenFormField Method

field
Flattens the specified form field, making the field uneditable.

Syntax

Visual Basic (Declaration)
Public Sub FlattenFormField( _
   ByVal field As PDFField _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim field As PDFField

instance.FlattenFormField(field)
C#
public void FlattenFormField(
   PDFField field
)
Managed Extensions for C++
public: void FlattenFormField(
   PDFField* field
)
C++/CLI
public:
void FlattenFormField(
   PDFField^ field
)

Parameters

field

Remarks

This action is ireversible. Once the form field has been flattened, it can no longer be edited.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members


FlattenFormFields Method

FlattenFormFields Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : FlattenFormFields Method

Flattens all the fields in the PDF form, making the PDF file uneditable.

Syntax

Visual Basic (Declaration)
Public Sub FlattenFormFields()
Visual Basic (Usage) Copy Code
Dim instance As PDFForm

instance.FlattenFormFields()
C#
public void FlattenFormFields()
Managed Extensions for C++
public: void FlattenFormFields();
C++/CLI
public:
void FlattenFormFields();

Remarks

This action is ireversible. Once the form fields have been flattened, they can no longer be edited.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members


ImportData Method

ImportData Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : ImportData Method

Imports form data from an external file.

Overload List

Overload | Description
ImportData(String,PDFFormDataFormat) | Imports form data from an external file.
ImportData(String,PDFFormDataFormat,Boolean) | Imports form data from an external file.
ImportData(Stream,PDFFormDataFormat) | Imports form data from an external file.
ImportData(Stream,PDFFormDataFormat,Boolean) | Imports form data from an external file.
ImportData(FDFFile) | Imports form data from a FDF file.
ImportData(FDFFile,Boolean) | Imports form data from a FDF file.
ImportData(XFDFFile) | Imports form data from a XFDF file.
ImportData(XFDFFile,Boolean) | Imports form data from a XFDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members


ImportData(String,PDFFormDataFormat) Method

ImportData(String,PDFFormDataFormat) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(String,PDFFormDataFormat) Method

fileName
The file from which to import form data.
dataFormat
The format of input file.
Imports form data from an external file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ImportData( _
   ByVal fileName As String, _
   ByVal dataFormat As PDFFormDataFormat _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim fileName As String
Dim dataFormat As PDFFormDataFormat

instance.ImportData(fileName, dataFormat)
C#
public void ImportData(
   string fileName,
   PDFFormDataFormat dataFormat
)
Managed Extensions for C++
public: void ImportData(
   string* fileName,
   PDFFormDataFormat dataFormat
)
C++/CLI
public:
void ImportData(
   String^ fileName,
   PDFFormDataFormat dataFormat
)

Parameters

fileName
The file from which to import form data.
dataFormat
The format of input file.

Exceptions

Exception | Description
PDFException | thrown when the input file can not be open or read.
PDFParserException | thrown when the input file can not be parsed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


ImportData(String,PDFFormDataFormat,Boolean) Method

ImportData(String,PDFFormDataFormat,Boolean) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(String,PDFFormDataFormat,Boolean) Method

fileName
The file from which to import form data.
dataFormat
The format of input file.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.
Imports form data from an external file.

Syntax

Visual Basic (Declaration)
Overloads Public Function ImportData( _
   ByVal fileName As String, _
   ByVal dataFormat As PDFFormDataFormat, _
   ByVal continueImportOnError As Boolean _
) As PDFFieldImportError()
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim fileName As String
Dim dataFormat As PDFFormDataFormat
Dim continueImportOnError As Boolean
Dim value() As PDFFieldImportError

value = instance.ImportData(fileName, dataFormat, continueImportOnError)
C#
public PDFFieldImportError[] ImportData(
   string fileName,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)
Managed Extensions for C++
public: PDFFieldImportError*[]* ImportData(
   string* fileName,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)
C++/CLI
public:
array<PDFFieldImportError^>^ ImportData(
   String^ fileName,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)

Parameters

fileName
The file from which to import form data.
dataFormat
The format of input file.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.

Return Value

An array with the errors occured during the import.

Exceptions

Exception | Description
PDFException | thrown when the input file can not be open or read.
PDFParserException | thrown when the input file can not be parsed.

Remarks

If no errors occured during the import, the returned array is null (Nothing in VB.NET).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


ImportData(Stream,PDFFormDataFormat) Method

ImportData(Stream,PDFFormDataFormat) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(Stream,PDFFormDataFormat) Method

stream
The stream from which to import form data.
dataFormat
The format of input stream.
Imports form data from an external file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ImportData( _
   ByVal stream As Stream, _
   ByVal dataFormat As PDFFormDataFormat _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim stream As Stream
Dim dataFormat As PDFFormDataFormat

instance.ImportData(stream, dataFormat)
C#
public void ImportData(
   Stream stream,
   PDFFormDataFormat dataFormat
)
Managed Extensions for C++
public: void ImportData(
   Stream* stream,
   PDFFormDataFormat dataFormat
)
C++/CLI
public:
void ImportData(
   Stream^ stream,
   PDFFormDataFormat dataFormat
)

Parameters

stream
The stream from which to import form data.
dataFormat
The format of input stream.

Exceptions

Exception | Description
PDFException | Thrown when the input stream can not be read.
PDFParserException | Thrown when the input stream can not be parsed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


ImportData(Stream,PDFFormDataFormat,Boolean) Method

ImportData(Stream,PDFFormDataFormat,Boolean) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(Stream,PDFFormDataFormat,Boolean) Method

stream
The stream from which to import form data.
dataFormat
The format of input stream.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.
Imports form data from an external file.

Syntax

Visual Basic (Declaration)
Overloads Public Function ImportData( _
   ByVal stream As Stream, _
   ByVal dataFormat As PDFFormDataFormat, _
   ByVal continueImportOnError As Boolean _
) As PDFFieldImportError()
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim stream As Stream
Dim dataFormat As PDFFormDataFormat
Dim continueImportOnError As Boolean
Dim value() As PDFFieldImportError

value = instance.ImportData(stream, dataFormat, continueImportOnError)
C#
public PDFFieldImportError[] ImportData(
   Stream stream,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)
Managed Extensions for C++
public: PDFFieldImportError*[]* ImportData(
   Stream* stream,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)
C++/CLI
public:
array<PDFFieldImportError^>^ ImportData(
   Stream^ stream,
   PDFFormDataFormat dataFormat,
   bool continueImportOnError
)

Parameters

stream
The stream from which to import form data.
dataFormat
The format of input stream.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.

Return Value

An array with the errors occured during the import.

Exceptions

Exception | Description
PDFException | Thrown when the input stream can not be read.
PDFParserException | Thrown when the input stream can not be parsed.

Remarks

If no errors occured during the import, the returned array is null (Nothing in VB.NET).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


ImportData(FDFFile) Method

ImportData(FDFFile) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(FDFFile) Method

fdfFile
A FDFFile object that stores the form data.
Imports form data from a FDF file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ImportData( _
   ByVal fdfFile As FDFFile _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim fdfFile As FDFFile

instance.ImportData(fdfFile)
C#
public void ImportData(
   FDFFile fdfFile
)
Managed Extensions for C++
public: void ImportData(
   FDFFile* fdfFile
)
C++/CLI
public:
void ImportData(
   FDFFile^ fdfFile
)

Parameters

fdfFile
A FDFFile object that stores the form data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


ImportData(FDFFile,Boolean) Method

ImportData(FDFFile,Boolean) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(FDFFile,Boolean) Method

fdfFile
A FDFFile object that stores the form data.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.
Imports form data from a FDF file.

Syntax

Visual Basic (Declaration)
Overloads Public Function ImportData( _
   ByVal fdfFile As FDFFile, _
   ByVal continueImportOnError As Boolean _
) As PDFFieldImportError()
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim fdfFile As FDFFile
Dim continueImportOnError As Boolean
Dim value() As PDFFieldImportError

value = instance.ImportData(fdfFile, continueImportOnError)
C#
public PDFFieldImportError[] ImportData(
   FDFFile fdfFile,
   bool continueImportOnError
)
Managed Extensions for C++
public: PDFFieldImportError*[]* ImportData(
   FDFFile* fdfFile,
   bool continueImportOnError
)
C++/CLI
public:
array<PDFFieldImportError^>^ ImportData(
   FDFFile^ fdfFile,
   bool continueImportOnError
)

Parameters

fdfFile
A FDFFile object that stores the form data.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.

Return Value

An array with the errors occured during the import.

Remarks

If no errors occured during the import, the returned array is null (Nothing in VB.NET).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


ImportData(XFDFFile) Method

ImportData(XFDFFile) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(XFDFFile) Method

xfdfFile
A XFDFFile object that stores the form data.
Imports form data from a XFDF file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ImportData( _
   ByVal xfdfFile As XFDFFile _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim xfdfFile As XFDFFile

instance.ImportData(xfdfFile)
C#
public void ImportData(
   XFDFFile xfdfFile
)
Managed Extensions for C++
public: void ImportData(
   XFDFFile* xfdfFile
)
C++/CLI
public:
void ImportData(
   XFDFFile^ xfdfFile
)

Parameters

xfdfFile
A XFDFFile object that stores the form data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


ImportData(XFDFFile,Boolean) Method

ImportData(XFDFFile,Boolean) Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class > ImportData Method : ImportData(XFDFFile,Boolean) Method

xfdfFile
A XFDFFile object that stores the form data.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.
Imports form data from a XFDF file.

Syntax

Visual Basic (Declaration)
Overloads Public Function ImportData( _
   ByVal xfdfFile As XFDFFile, _
   ByVal continueImportOnError As Boolean _
) As PDFFieldImportError()
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim xfdfFile As XFDFFile
Dim continueImportOnError As Boolean
Dim value() As PDFFieldImportError

value = instance.ImportData(xfdfFile, continueImportOnError)
C#
public PDFFieldImportError[] ImportData(
   XFDFFile xfdfFile,
   bool continueImportOnError
)
Managed Extensions for C++
public: PDFFieldImportError*[]* ImportData(
   XFDFFile* xfdfFile,
   bool continueImportOnError
)
C++/CLI
public:
array<PDFFieldImportError^>^ ImportData(
   XFDFFile^ xfdfFile,
   bool continueImportOnError
)

Parameters

xfdfFile
A XFDFFile object that stores the form data.
continueImportOnError
False if the import should stop on the first field that generates an error, or true if the import should ignore the error and continue with the next field.

Return Value

An array with the errors occured during the import.

Remarks

If no errors occured during the import, the returned array is null (Nothing in VB.NET).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members
Overload List


PDFForm Class Properties

PDFForm Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFForm Class

For a list of all members of this type, see PDFForm members.

Public Properties

 | Name | Description
Public Property | Document | Gets the document that includes this form.
Public Property | Fields | Gets the list of fields included in the form.
Top

See Also

Reference

PDFForm Class
O2S.Components.PDF4NET.Forms Namespace


Document Property

Document Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : Document Property

Gets the document that includes this form.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Document As PDFDocument
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim value As PDFDocument

value = instance.Document
C#
public PDFDocument Document {get;}
Managed Extensions for C++
public: __property PDFDocument* get_Document();
C++/CLI
public:
property PDFDocument^ Document {
   PDFDocument^ get();
}

Return Value

The document that owns the form.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members


Fields Property

Fields Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFForm Class : Fields Property

Gets the list of fields included in the form.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As PDFFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFForm
Dim value As PDFFieldCollection

value = instance.Fields
C#
public PDFFieldCollection Fields {get;}
Managed Extensions for C++
public: __property PDFFieldCollection* get_Fields();
C++/CLI
public:
property PDFFieldCollection^ Fields {
   PDFFieldCollection^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFForm Class
PDFForm Members


PDFListBoxField Class

PDFListBoxField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListBoxField Class

Defines a scrollable list box field for user input in the PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFListBoxField
   Inherits PDFListField
Visual Basic (Usage) Copy Code
Dim instance As PDFListBoxField
C#
public class PDFListBoxField : PDFListField
Managed Extensions for C++
public __gc class PDFListBoxField : public PDFListField
C++/CLI
public ref class PDFListBoxField : public PDFListField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFListField
O2S.Components.PDF4NET.Forms.PDFListBoxField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListBoxField Members
O2S.Components.PDF4NET.Forms Namespace


PDFListBoxField Class Members

PDFListBoxField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListBoxField Class

The following tables list the members exposed by PDFListBoxField.

Public Constructors

 | Name | Description
Public Constructor | PDFListBoxField Constructor | Initializes a new PDFListBoxField object.
Top

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from PDFField)
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made. (Inherited from PDFListField)
Public Property | Dictionary | Gets the field dictionary. (Inherited from PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from PDFField)
Public Property | Items | Gets the collection of items in the list. (Inherited from PDFListField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from PDFListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from PDFListField)
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list. (Inherited from PDFListField)
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not. (Inherited from PDFListField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from PDFField)
Public Property | Type | Gets the field type. (Inherited from PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from PDFField)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from PDFField)
Top

See Also

Reference

PDFListBoxField Class
O2S.Components.PDF4NET.Forms Namespace


PDFListBoxField Constructor

PDFListBoxField Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListBoxField Class : PDFListBoxField Constructor

name
The name of this field object.
Initializes a new PDFListBoxField object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As PDFListBoxField(name)
C#
public PDFListBoxField(
   string name
)
Managed Extensions for C++
public: PDFListBoxField(
   string* name
)
C++/CLI
public:
PDFListBoxField(
   String^ name
)

Parameters

name
The name of this field object.

Remarks

The field name must be unique across the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListBoxField Class
PDFListBoxField Members


PDFListBoxWidget Class

PDFListBoxWidget Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListBoxWidget Class

Defines the widget for a listbox field.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFListBoxWidget
   Inherits PDFFieldWidget
Visual Basic (Usage) Copy Code
Dim instance As PDFListBoxWidget
C#
public class PDFListBoxWidget : PDFFieldWidget
Managed Extensions for C++
public __gc class PDFListBoxWidget : public PDFFieldWidget
C++/CLI
public ref class PDFListBoxWidget : public PDFFieldWidget

Remarks

The field widget is the field's visual representation on a PDF page. A textbox field can have multiple widgets on the same page or on different pages. All the field widgets display the same field value.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFListBoxWidget

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListBoxWidget Members
O2S.Components.PDF4NET.Forms Namespace


PDFListBoxWidget Class Members

PDFListBoxWidget Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListBoxWidget Class

The following tables list the members exposed by PDFListBoxWidget.

Public Constructors

 | Name | Description
Public Constructor | PDFListBoxWidget Constructor | Initializes a new PDFListBoxWidget object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from PDFFieldWidget)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from PDFFieldWidget)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFListBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFListBoxWidget Constructor

PDFListBoxWidget Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListBoxWidget Class : PDFListBoxWidget Constructor

Initializes a new PDFListBoxWidget object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFListBoxWidget()
C#
public PDFListBoxWidget()
Managed Extensions for C++
public: PDFListBoxWidget();
C++/CLI
public:
PDFListBoxWidget();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListBoxWidget Class
PDFListBoxWidget Members


PDFListField Class

PDFListField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListField Class

Base class for all list type fields.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFListField
   Inherits PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFListField
C#
public abstract class PDFListField : PDFField
Managed Extensions for C++
public __gc abstract class PDFListField : public PDFField
C++/CLI
public ref class PDFListField abstract : public PDFField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFListField
O2S.Components.PDF4NET.Forms.PDFListBoxField
O2S.Components.PDF4NET.Forms.PDFDropDownListField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListField Members
O2S.Components.PDF4NET.Forms Namespace


PDFListField Class Members

PDFListField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListField Class

The following tables list the members exposed by PDFListField.

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from PDFField)
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made.
Public Property | Dictionary | Gets the field dictionary. (Inherited from PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from PDFField)
Public Property | Items | Gets the collection of items in the list.
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list.
Public Property | SelectedItem | Gets or sets the first selected item in the list.
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list.
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from PDFField)
Public Property | Type | Gets the field type. (Inherited from PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from PDFField)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from PDFField)
Top

See Also

Reference

PDFListField Class
O2S.Components.PDF4NET.Forms Namespace


PDFListField Class Properties

PDFListField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListField Class

For a list of all members of this type, see PDFListField members.

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from PDFField)
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made.
Public Property | Dictionary | Gets the field dictionary. (Inherited from PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from PDFField)
Public Property | Items | Gets the collection of items in the list.
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list.
Public Property | SelectedItem | Gets or sets the first selected item in the list.
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list.
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from PDFField)
Public Property | Type | Gets the field type. (Inherited from PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from PDFField)
Top

See Also

Reference

PDFListField Class
O2S.Components.PDF4NET.Forms Namespace


CommitOnSelChange Property

CommitOnSelChange Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListField Class : CommitOnSelChange Property

Gets or sets whether the selected item is commited as soon as the selection is made.

Syntax

Visual Basic (Declaration)
Public Property CommitOnSelChange As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFListField
Dim value As Boolean

instance.CommitOnSelChange = value

value = instance.CommitOnSelChange
C#
public bool CommitOnSelChange {get; set;}
Managed Extensions for C++
public: __property bool get_CommitOnSelChange();
public: __property void set_CommitOnSelChange(
   bool value
);
C++/CLI
public:
property bool CommitOnSelChange {
   bool get();
   void set (bool value);
}

Return Value

True if the selected item is commited as soon as the selection is made, false otherwise. Default is false.

Remarks

If set, the new value is committed as soon as a selection is made with the pointing device. This option enables applications to perform an action once a selection is made, without requiring the user to exit the field. If clear, the new value is not committed until the user exits the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListField Class
PDFListField Members


Items Property

Items Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListField Class : Items Property

Gets the collection of items in the list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As PDFListItemCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFListField
Dim value As PDFListItemCollection

value = instance.Items
C#
public PDFListItemCollection Items {get;}
Managed Extensions for C++
public: __property PDFListItemCollection* get_Items();
C++/CLI
public:
property PDFListItemCollection^ Items {
   PDFListItemCollection^ get();
}

Return Value

A PDFListItemCollection that represents the items within the list.

Remarks

Use this property to get the properties of items in the list.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListField Class
PDFListField Members


SelectedIndex Property

SelectedIndex Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListField Class : SelectedIndex Property

Gets or sets the lowest ordinal index of the selected items in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFListField
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
public int SelectedIndex {get; set;}
Managed Extensions for C++
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
C++/CLI
public:
property int SelectedIndex {
   int get();
   void set (int value);
}

Return Value

The lowest ordinal index of the selected items in the list. The default is -1, which indicates that nothing is selected.

Remarks

Use this property to determine the index of the currently selected item in the list if the list control allows only one selection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListField Class
PDFListField Members


SelectedItem Property

SelectedItem Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListField Class : SelectedItem Property

Gets or sets the first selected item in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedItem As PDFListItem
Visual Basic (Usage) Copy Code
Dim instance As PDFListField
Dim value As PDFListItem

instance.SelectedItem = value

value = instance.SelectedItem
C#
public PDFListItem SelectedItem {get; set;}
Managed Extensions for C++
public: __property PDFListItem* get_SelectedItem();
public: __property void set_SelectedItem(
   PDFListItem* value
);
C++/CLI
public:
property PDFListItem^ SelectedItem {
   PDFListItem^ get();
   void set (PDFListItem^ value);
}

Return Value

A PDFListItem object specifying the first selected item.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The item does not exist in the list.

Remarks

null (Nothing in VB.NET) means that no item is selected.
If the item does not exist in the list, an exception is thrown.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListField Class
PDFListField Members


SelectedValue Property

SelectedValue Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListField Class : SelectedValue Property

Gets or sets the value of the first selected item in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedValue As String
Visual Basic (Usage) Copy Code
Dim instance As PDFListField
Dim value As String

instance.SelectedValue = value

value = instance.SelectedValue
C#
public string SelectedValue {get; set;}
Managed Extensions for C++
public: __property string* get_SelectedValue();
public: __property void set_SelectedValue(
   string* value
);
C++/CLI
public:
property String^ SelectedValue {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the value of the first selected item, null (Nothing in VB.NET) if there is no selected item.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value does not exist in field's set of values.

Remarks

When setting the selected value, if the value does not exist in the list, an exception is thrown.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListField Class
PDFListField Members


Sort Property

Sort Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListField Class : Sort Property

Gets or sets whether the items in the drop down list should be sorted alphabetically or not.

Syntax

Visual Basic (Declaration)
Public Property Sort As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFListField
Dim value As Boolean

instance.Sort = value

value = instance.Sort
C#
public bool Sort {get; set;}
Managed Extensions for C++
public: __property bool get_Sort();
public: __property void set_Sort(
   bool value
);
C++/CLI
public:
property bool Sort {
   bool get();
   void set (bool value);
}

Return Value

True if the items are sorted, false otherwise. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListField Class
PDFListField Members


PDFListItem Class

PDFListItem Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListItem Class

Defines an item in a list.

Syntax

Visual Basic (Declaration)
Public Class PDFListItem
Visual Basic (Usage) Copy Code
Dim instance As PDFListItem
C#
public class PDFListItem
Managed Extensions for C++
public __gc class PDFListItem
C++/CLI
public ref class PDFListItem

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFListItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItem Members
O2S.Components.PDF4NET.Forms Namespace


PDFListItem Class Members

PDFListItem Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListItem Class

The following tables list the members exposed by PDFListItem.

Public Constructors

 | Name | Description
Public Constructor | PDFListItem Constructor | Initialzies a new PDFListItem object.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the item.
Public Property | Value | Gets or sets the value of the item.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Creates a new PDFListItem object.
Top

See Also

Reference

PDFListItem Class
O2S.Components.PDF4NET.Forms Namespace


PDFListItem Constructor

PDFListItem Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItem Class : PDFListItem Constructor

name
The item name, it is displayed in the list.
value
The item value, it is exported when form content is exported.
Initialzies a new PDFListItem object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim value As String

Dim instance As PDFListItem(name, value)
C#
public PDFListItem(
   string name,
   string value
)
Managed Extensions for C++
public: PDFListItem(
   string* name,
   string* value
)
C++/CLI
public:
PDFListItem(
   String^ name,
   String^ value
)

Parameters

name
The item name, it is displayed in the list.
value
The item value, it is exported when form content is exported.

Exceptions

Exception | Description
ArgumentNullException | Thrown when the item value is null or empty.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItem Class
PDFListItem Members


PDFListItem Class Methods

PDFListItem Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListItem Class

For a list of all members of this type, see PDFListItem members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Creates a new PDFListItem object.
Top

See Also

Reference

PDFListItem Class
O2S.Components.PDF4NET.Forms Namespace


Create Method

Create Method
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItem Class : Create Method

name
The item name, it is displayed in the list.
value
The item value, it is exported when form content is exported.
Creates a new PDFListItem object.

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal name As String, _
   ByVal value As String _
) As PDFListItem
Visual Basic (Usage) Copy Code
Dim name As String
Dim value As String
Dim value As PDFListItem

value = PDFListItem.Create(name, value)
C#
public static PDFListItem Create(
   string name,
   string value
)
Managed Extensions for C++
public: static PDFListItem* Create(
   string* name,
   string* value
)
C++/CLI
public:
static PDFListItem^ Create(
   String^ name,
   String^ value
)

Parameters

name
The item name, it is displayed in the list.
value
The item value, it is exported when form content is exported.

Return Value

A PDFListItem object

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItem Class
PDFListItem Members


PDFListItem Class Properties

PDFListItem Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListItem Class

For a list of all members of this type, see PDFListItem members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the item.
Public Property | Value | Gets or sets the value of the item.
Top

See Also

Reference

PDFListItem Class
O2S.Components.PDF4NET.Forms Namespace


Name Property

Name Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItem Class : Name Property

Gets or sets the name of the item.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PDFListItem
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing the name of the item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItem Class
PDFListItem Members


Value Property

Value Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFListItem Class : Value Property

Gets or sets the value of the item.

Syntax

Visual Basic (Declaration)
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As PDFListItem
Dim value As String

instance.Value = value

value = instance.Value
C#
public string Value {get; set;}
Managed Extensions for C++
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
C++/CLI
public:
property String^ Value {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing the value of the item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItem Class
PDFListItem Members


PDFListItemCollection Class

PDFListItemCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListItemCollection Class

Defines a collection of list items.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFListItemCollection
   Inherits PDFCollection(Of PDFListItem, PDFListField)
Visual Basic (Usage) Copy Code
Dim instance As PDFListItemCollection
C#
public class PDFListItemCollection : PDFCollection<PDFListItem, PDFListField>
Managed Extensions for C++
public __gc class PDFListItemCollection : public PDFCollection<PDFListItem, PDFListField>
C++/CLI
public ref class PDFListItemCollection : public PDFCollection<PDFListItem, PDFListField>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<PDFListItem>
O2S.Components.PDF4NET.PDFCollection<PDFListItem, PDFListField>
O2S.Components.PDF4NET.Forms.PDFListItemCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFListItemCollection Members
O2S.Components.PDF4NET.Forms Namespace


PDFListItemCollection Class Members

PDFListItemCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListItemCollection Class

The following tables list the members exposed by PDFListItemCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Top

See Also

Reference

PDFListItemCollection Class
O2S.Components.PDF4NET.Forms Namespace


PDFPushButtonField Class

PDFPushButtonField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonField Class

Defines a pushbutton in a PDF form.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPushButtonField
   Inherits PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFPushButtonField
C#
public class PDFPushButtonField : PDFField
Managed Extensions for C++
public __gc class PDFPushButtonField : public PDFField
C++/CLI
public ref class PDFPushButtonField : public PDFField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFPushButtonField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushButtonField Members
O2S.Components.PDF4NET.Forms Namespace


PDFPushButtonField Class Members

PDFPushButtonField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonField Class

The following tables list the members exposed by PDFPushButtonField.

Public Constructors

 | Name | Description
Public Constructor | PDFPushButtonField Constructor | Initializes a new PDFPushButtonField object.
Top

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from PDFField)
Public Property | Caption | Gets the button caption.
Public Property | Dictionary | Gets the field dictionary. (Inherited from PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | Tooltip | Overridden. Gets or sets the field tooltip.
Public Property | Type | Gets the field type. (Inherited from PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from PDFField)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from PDFField)
Top

See Also

Reference

PDFPushButtonField Class
O2S.Components.PDF4NET.Forms Namespace


PDFPushButtonField Constructor

PDFPushButtonField Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonField Class : PDFPushButtonField Constructor

name
The name of the pushbutton field
Initializes a new PDFPushButtonField object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As PDFPushButtonField(name)
C#
public PDFPushButtonField(
   string name
)
Managed Extensions for C++
public: PDFPushButtonField(
   string* name
)
C++/CLI
public:
PDFPushButtonField(
   String^ name
)

Parameters

name
The name of the pushbutton field

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushButtonField Class
PDFPushButtonField Members


PDFPushButtonField Class Properties

PDFPushButtonField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonField Class

For a list of all members of this type, see PDFPushButtonField members.

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from PDFField)
Public Property | Caption | Gets the button caption.
Public Property | Dictionary | Gets the field dictionary. (Inherited from PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | Tooltip | Overridden. Gets or sets the field tooltip.
Public Property | Type | Gets the field type. (Inherited from PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from PDFField)
Top

See Also

Reference

PDFPushButtonField Class
O2S.Components.PDF4NET.Forms Namespace


Caption Property

Caption Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonField Class : Caption Property

Gets the button caption.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Caption As String
Visual Basic (Usage) Copy Code
Dim instance As PDFPushButtonField
Dim value As String

value = instance.Caption
C#
public string Caption {get;}
Managed Extensions for C++
public: __property string* get_Caption();
C++/CLI
public:
property String^ Caption {
   String^ get();
}

Return Value

The text displayed on the button.

Remarks

If the button has multiple widgets, this property returns the caption defined on the first widget.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushButtonField Class
PDFPushButtonField Members


Tooltip Property

Tooltip Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonField Class : Tooltip Property

Gets or sets the field tooltip.

Syntax

Visual Basic (Declaration)
Overrides Public Property Tooltip As String
Visual Basic (Usage) Copy Code
Dim instance As PDFPushButtonField
Dim value As String

instance.Tooltip = value

value = instance.Tooltip
C#
public override string Tooltip {get; set;}
Managed Extensions for C++
public: __property string* get_Tooltip()override ;
public: __property void set_Tooltip(
   string* value
)override ;
C++/CLI
public:
property String^ Tooltip override {
   String^ get();
   void set (String^ value);
}

Return Value

The field's tooltip.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushButtonField Class
PDFPushButtonField Members


PDFPushButtonWidget Class

PDFPushButtonWidget Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonWidget Class

Defines the widget for a pushbutton field.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPushButtonWidget
   Inherits PDFFieldWidget
Visual Basic (Usage) Copy Code
Dim instance As PDFPushButtonWidget
C#
public class PDFPushButtonWidget : PDFFieldWidget
Managed Extensions for C++
public __gc class PDFPushButtonWidget : public PDFFieldWidget
C++/CLI
public ref class PDFPushButtonWidget : public PDFFieldWidget

Remarks

The field widget is the field's visual representation on a PDF page. A pushbutton field can have multiple widgets on the same page or on different pages. All the field widgets display the same field value.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFPushButtonWidget

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushButtonWidget Members
O2S.Components.PDF4NET.Forms Namespace


PDFPushButtonWidget Class Members

PDFPushButtonWidget Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonWidget Class

The following tables list the members exposed by PDFPushButtonWidget.

Public Constructors

 | Name | Description
Public Constructor | PDFPushButtonWidget Constructor | Initializes a new PDFPushButtonWidget object.
Top

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the caption alignment on the button.
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from PDFFieldWidget)
Public Property | Caption | Gets or sets the widget's caption.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DownAppearance | Gets or sets the down widget appearance.
Public Property | Field | Gets the form field that owns this widget. (Inherited from PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from PDFFieldWidget)
Public Property | HighlightMode | Gets or sets the highlighting mode of the button widget.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | RolloverAppearance | Gets or sets the rollover widget appearance.
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from PDFFieldWidget)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFPushButtonWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFPushButtonWidget Constructor

PDFPushButtonWidget Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonWidget Class : PDFPushButtonWidget Constructor

Initializes a new PDFPushButtonWidget object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPushButtonWidget()
C#
public PDFPushButtonWidget()
Managed Extensions for C++
public: PDFPushButtonWidget();
C++/CLI
public:
PDFPushButtonWidget();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


PDFPushButtonWidget Class Properties

PDFPushButtonWidget Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonWidget Class

For a list of all members of this type, see PDFPushButtonWidget members.

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the caption alignment on the button.
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from PDFFieldWidget)
Public Property | Caption | Gets or sets the widget's caption.
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DownAppearance | Gets or sets the down widget appearance.
Public Property | Field | Gets the form field that owns this widget. (Inherited from PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from PDFFieldWidget)
Public Property | HighlightMode | Gets or sets the highlighting mode of the button widget.
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | RolloverAppearance | Gets or sets the rollover widget appearance.
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFPushButtonWidget Class
O2S.Components.PDF4NET.Forms Namespace


Align Property

Align Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonWidget Class : Align Property

Gets or sets the caption alignment on the button.

Syntax

Visual Basic (Declaration)
Public Property Align As PDFFieldTextAlign
Visual Basic (Usage) Copy Code
Dim instance As PDFPushButtonWidget
Dim value As PDFFieldTextAlign

instance.Align = value

value = instance.Align
C#
public PDFFieldTextAlign Align {get; set;}
Managed Extensions for C++
public: __property PDFFieldTextAlign get_Align();
public: __property void set_Align(
   PDFFieldTextAlign value
);
C++/CLI
public:
property PDFFieldTextAlign Align {
   PDFFieldTextAlign get();
   void set (PDFFieldTextAlign value);
}

Return Value

A PDFFieldTextAlign enumeration member specifying the caption alignment on the button.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


Caption Property

Caption Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonWidget Class : Caption Property

Gets or sets the widget's caption.

Syntax

Visual Basic (Declaration)
Public Property Caption As String
Visual Basic (Usage) Copy Code
Dim instance As PDFPushButtonWidget
Dim value As String

instance.Caption = value

value = instance.Caption
C#
public string Caption {get; set;}
Managed Extensions for C++
public: __property string* get_Caption();
public: __property void set_Caption(
   string* value
);
C++/CLI
public:
property String^ Caption {
   String^ get();
   void set (String^ value);
}

Return Value

The caption of pushbutton's widget.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


DownAppearance Property

DownAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonWidget Class : DownAppearance Property

Gets or sets the down widget appearance.

Syntax

Visual Basic (Declaration)
Public Property DownAppearance As PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFPushButtonWidget
Dim value As PDFAnnotationAppearance

instance.DownAppearance = value

value = instance.DownAppearance
C#
public PDFAnnotationAppearance DownAppearance {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationAppearance* get_DownAppearance();
public: __property void set_DownAppearance(
   PDFAnnotationAppearance* value
);
C++/CLI
public:
property PDFAnnotationAppearance^ DownAppearance {
   PDFAnnotationAppearance^ get();
   void set (PDFAnnotationAppearance^ value);
}

Return Value

The down appearance of the field widget.

Remarks

This appearance is displayed when the mouse is clicked on the widget.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


HighlightMode Property

HighlightMode Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonWidget Class : HighlightMode Property

Gets or sets the highlighting mode of the button widget.

Syntax

Visual Basic (Declaration)
Public Property HighlightMode As PDFPushButtonHighlightMode
Visual Basic (Usage) Copy Code
Dim instance As PDFPushButtonWidget
Dim value As PDFPushButtonHighlightMode

instance.HighlightMode = value

value = instance.HighlightMode
C#
public PDFPushButtonHighlightMode HighlightMode {get; set;}
Managed Extensions for C++
public: __property PDFPushButtonHighlightMode get_HighlightMode();
public: __property void set_HighlightMode(
   PDFPushButtonHighlightMode value
);
C++/CLI
public:
property PDFPushButtonHighlightMode HighlightMode {
   PDFPushButtonHighlightMode get();
   void set (PDFPushButtonHighlightMode value);
}

Return Value

A PDFPushButtonHighlightMode enumeration member specifying the highlighting mode for the button widget.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


RolloverAppearance Property

RolloverAppearance Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFPushButtonWidget Class : RolloverAppearance Property

Gets or sets the rollover widget appearance.

Syntax

Visual Basic (Declaration)
Public Property RolloverAppearance As PDFAnnotationAppearance
Visual Basic (Usage) Copy Code
Dim instance As PDFPushButtonWidget
Dim value As PDFAnnotationAppearance

instance.RolloverAppearance = value

value = instance.RolloverAppearance
C#
public PDFAnnotationAppearance RolloverAppearance {get; set;}
Managed Extensions for C++
public: __property PDFAnnotationAppearance* get_RolloverAppearance();
public: __property void set_RolloverAppearance(
   PDFAnnotationAppearance* value
);
C++/CLI
public:
property PDFAnnotationAppearance^ RolloverAppearance {
   PDFAnnotationAppearance^ get();
   void set (PDFAnnotationAppearance^ value);
}

Return Value

The rollover appearance of the field widget.

Remarks

This appearance is displayed when the mouse is over the widget.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPushButtonWidget Class
PDFPushButtonWidget Members


PDFRadioButtonItem Class

PDFRadioButtonItem Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonItem Class

Defines the widget for a radio button.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFRadioButtonItem
   Inherits PDFCheckWidget
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItem
C#
public class PDFRadioButtonItem : PDFCheckWidget
Managed Extensions for C++
public __gc class PDFRadioButtonItem : public PDFCheckWidget
C++/CLI
public ref class PDFRadioButtonItem : public PDFCheckWidget

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFCheckWidget
O2S.Components.PDF4NET.Forms.PDFRadioButtonItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItem Members
O2S.Components.PDF4NET.Forms Namespace


PDFRadioButtonItem Class Members

PDFRadioButtonItem Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonItem Class

The following tables list the members exposed by PDFRadioButtonItem.

Public Constructors

 | Name | Description
Public Constructor | PDFRadioButtonItem Constructor | Initializes a new PDFRadioButtonItem object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from PDFCheckWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not. (Inherited from PDFCheckWidget)
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance. (Inherited from PDFCheckWidget)
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance. (Inherited from PDFCheckWidget)
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance. (Inherited from PDFCheckWidget)
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark. (Inherited from PDFCheckWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget. (Inherited from PDFCheckWidget)
Public Property | Field | Gets the form field that owns this widget. (Inherited from PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from PDFFieldWidget)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance. (Inherited from PDFCheckWidget)
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance. (Inherited from PDFCheckWidget)
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance. (Inherited from PDFCheckWidget)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from PDFFieldWidget)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFRadioButtonItem Class
O2S.Components.PDF4NET.Forms Namespace


PDFRadioButtonItem Constructor

PDFRadioButtonItem Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonItem Class : PDFRadioButtonItem Constructor

Initializes a new PDFRadioButtonItem object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonItem()
C#
public PDFRadioButtonItem()
Managed Extensions for C++
public: PDFRadioButtonItem();
C++/CLI
public:
PDFRadioButtonItem();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonItem Class
PDFRadioButtonItem Members


PDFRadioButtonListField Class

PDFRadioButtonListField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonListField Class

Defines a list of radio buttons in a PDF form.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFRadioButtonListField
   Inherits PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonListField
C#
public class PDFRadioButtonListField : PDFField
Managed Extensions for C++
public __gc class PDFRadioButtonListField : public PDFField
C++/CLI
public ref class PDFRadioButtonListField : public PDFField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFRadioButtonListField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonListField Members
O2S.Components.PDF4NET.Forms Namespace


PDFRadioButtonListField Class Members

PDFRadioButtonListField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonListField Class

The following tables list the members exposed by PDFRadioButtonListField.

Public Constructors

 | Name | Description
Public Constructor | PDFRadioButtonListField Constructor | Initializes a new PDFRadioButtonListField object.
Top

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from PDFField)
Public Property | Checked | Gets or sets a value indicating whether the radio button list is checked or not.
Public Property | Dictionary | Gets the field dictionary. (Inherited from PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | NoToggleToOff | Gets or sets a value indicating whether a radiobutton should be selected all the time.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | SelectedIndex | Gets or sets the selected radio button item.
Public Property | SelectedValue | Gets or sets the value of the selected radio button item .
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from PDFField)
Public Property | Type | Gets the field type. (Inherited from PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from PDFField)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from PDFField)
Top

See Also

Reference

PDFRadioButtonListField Class
O2S.Components.PDF4NET.Forms Namespace


PDFRadioButtonListField Constructor

PDFRadioButtonListField Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : PDFRadioButtonListField Constructor

name
The name of the field.
Initializes a new PDFRadioButtonListField object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As PDFRadioButtonListField(name)
C#
public PDFRadioButtonListField(
   string name
)
Managed Extensions for C++
public: PDFRadioButtonListField(
   string* name
)
C++/CLI
public:
PDFRadioButtonListField(
   String^ name
)

Parameters

name
The name of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


PDFRadioButtonListField Class Properties

PDFRadioButtonListField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonListField Class

For a list of all members of this type, see PDFRadioButtonListField members.

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from PDFField)
Public Property | Checked | Gets or sets a value indicating whether the radio button list is checked or not.
Public Property | Dictionary | Gets the field dictionary. (Inherited from PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | NoToggleToOff | Gets or sets a value indicating whether a radiobutton should be selected all the time.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | SelectedIndex | Gets or sets the selected radio button item.
Public Property | SelectedValue | Gets or sets the value of the selected radio button item .
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from PDFField)
Public Property | Type | Gets the field type. (Inherited from PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from PDFField)
Top

See Also

Reference

PDFRadioButtonListField Class
O2S.Components.PDF4NET.Forms Namespace


Checked Property

Checked Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : Checked Property

Gets or sets a value indicating whether the radio button list is checked or not.

Syntax

Visual Basic (Declaration)
Public Property Checked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonListField
Dim value As Boolean

instance.Checked = value

value = instance.Checked
C#
public bool Checked {get; set;}
Managed Extensions for C++
public: __property bool get_Checked();
public: __property void set_Checked(
   bool value
);
C++/CLI
public:
property bool Checked {
   bool get();
   void set (bool value);
}

Return Value

True if at least one radio button widget is checked, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


NoToggleToOff Property

NoToggleToOff Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : NoToggleToOff Property

Gets or sets a value indicating whether a radiobutton should be selected all the time.

Syntax

Visual Basic (Declaration)
Public Property NoToggleToOff As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonListField
Dim value As Boolean

instance.NoToggleToOff = value

value = instance.NoToggleToOff
C#
public bool NoToggleToOff {get; set;}
Managed Extensions for C++
public: __property bool get_NoToggleToOff();
public: __property void set_NoToggleToOff(
   bool value
);
C++/CLI
public:
property bool NoToggleToOff {
   bool get();
   void set (bool value);
}

Return Value

True if a radiobutton should be selected all the time, otherwise false. Default is true.

Remarks

If this property is true, clicking on currently selected radiobutton has no effect. If this property is false, clicking on currently selected radiobutton deselects it, leaving no radiobutton selected.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


SelectedIndex Property

SelectedIndex Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : SelectedIndex Property

Gets or sets the selected radio button item.

Syntax

Visual Basic (Declaration)
Public Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonListField
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
public int SelectedIndex {get; set;}
Managed Extensions for C++
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
C++/CLI
public:
property int SelectedIndex {
   int get();
   void set (int value);
}

Return Value

The index of the selected radio button item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


SelectedValue Property

SelectedValue Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFRadioButtonListField Class : SelectedValue Property

Gets or sets the value of the selected radio button item .

Syntax

Visual Basic (Declaration)
Public Property SelectedValue As String
Visual Basic (Usage) Copy Code
Dim instance As PDFRadioButtonListField
Dim value As String

instance.SelectedValue = value

value = instance.SelectedValue
C#
public string SelectedValue {get; set;}
Managed Extensions for C++
public: __property string* get_SelectedValue();
public: __property void set_SelectedValue(
   string* value
);
C++/CLI
public:
property String^ SelectedValue {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the value of the selected item.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value does not exist in field's set of values.

Remarks

null (Nothing in VB.NET) or "Off" means that no radio button item is selected.
When setting the selected value, if the value does not exist in the list, an exception is thrown.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRadioButtonListField Class
PDFRadioButtonListField Members


PDFSignatureField Class

PDFSignatureField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureField Class

Defines a signature field in a PDF form.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSignatureField
   Inherits PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFSignatureField
C#
public class PDFSignatureField : PDFField
Managed Extensions for C++
public __gc class PDFSignatureField : public PDFField
C++/CLI
public ref class PDFSignatureField : public PDFField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFSignatureField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSignatureField Members
O2S.Components.PDF4NET.Forms Namespace


PDFSignatureField Class Members

PDFSignatureField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureField Class

The following tables list the members exposed by PDFSignatureField.

Public Constructors

 | Name | Description
Public Constructor | PDFSignatureField Constructor | Initializes a new PDFSignatureField object.
Top

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from PDFField)
Public Property | Dictionary | Gets the field dictionary. (Inherited from PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from PDFField)
Public Property | LockFieldAction | Gets or sets the lock field action.
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | Signature | Gets or sets the digital signature for signing the the field.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from PDFField)
Public Property | Type | Gets the field type. (Inherited from PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from PDFField)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from PDFField)
Top

See Also

Reference

PDFSignatureField Class
O2S.Components.PDF4NET.Forms Namespace


PDFSignatureField Constructor

PDFSignatureField Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFSignatureField Class : PDFSignatureField Constructor

name
The name of the field.
Initializes a new PDFSignatureField object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As PDFSignatureField(name)
C#
public PDFSignatureField(
   string name
)
Managed Extensions for C++
public: PDFSignatureField(
   string* name
)
C++/CLI
public:
PDFSignatureField(
   String^ name
)

Parameters

name
The name of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSignatureField Class
PDFSignatureField Members


PDFSignatureField Class Properties

PDFSignatureField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureField Class

For a list of all members of this type, see PDFSignatureField members.

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from PDFField)
Public Property | Dictionary | Gets the field dictionary. (Inherited from PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from PDFField)
Public Property | LockFieldAction | Gets or sets the lock field action.
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | Signature | Gets or sets the digital signature for signing the the field.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from PDFField)
Public Property | Type | Gets the field type. (Inherited from PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from PDFField)
Top

See Also

Reference

PDFSignatureField Class
O2S.Components.PDF4NET.Forms Namespace


LockFieldAction Property

LockFieldAction Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFSignatureField Class : LockFieldAction Property

Gets or sets the lock field action.

Syntax

Visual Basic (Declaration)
Public Property LockFieldAction As PDFSignatureLockFieldAction
Visual Basic (Usage) Copy Code
Dim instance As PDFSignatureField
Dim value As PDFSignatureLockFieldAction

instance.LockFieldAction = value

value = instance.LockFieldAction
C#
public PDFSignatureLockFieldAction LockFieldAction {get; set;}
Managed Extensions for C++
public: __property PDFSignatureLockFieldAction* get_LockFieldAction();
public: __property void set_LockFieldAction(
   PDFSignatureLockFieldAction* value
);
C++/CLI
public:
property PDFSignatureLockFieldAction^ LockFieldAction {
   PDFSignatureLockFieldAction^ get();
   void set (PDFSignatureLockFieldAction^ value);
}

Return Value

The lock field action to be executed when the signature field is signed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSignatureField Class
PDFSignatureField Members


Signature Property

Signature Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFSignatureField Class : Signature Property

Gets or sets the digital signature for signing the the field.

Syntax

Visual Basic (Declaration)
Public Property Signature As PDFDigitalSignature
Visual Basic (Usage) Copy Code
Dim instance As PDFSignatureField
Dim value As PDFDigitalSignature

instance.Signature = value

value = instance.Signature
C#
public PDFDigitalSignature Signature {get; set;}
Managed Extensions for C++
public: __property PDFDigitalSignature* get_Signature();
public: __property void set_Signature(
   PDFDigitalSignature* value
);
C++/CLI
public:
property PDFDigitalSignature^ Signature {
   PDFDigitalSignature^ get();
   void set (PDFDigitalSignature^ value);
}

Return Value

A O2S.Components.PDF4NET.Security.PDFDigitalSignature object specifying the digital signature for signing the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSignatureField Class
PDFSignatureField Members


PDFSignatureLockFieldAction Class

PDFSignatureLockFieldAction Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureLockFieldAction Class

Defines the field lock action to be executed when a signature field is signed.

Syntax

Visual Basic (Declaration)
Public Class PDFSignatureLockFieldAction
Visual Basic (Usage) Copy Code
Dim instance As PDFSignatureLockFieldAction
C#
public class PDFSignatureLockFieldAction
Managed Extensions for C++
public __gc class PDFSignatureLockFieldAction
C++/CLI
public ref class PDFSignatureLockFieldAction

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFSignatureLockFieldAction

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSignatureLockFieldAction Members
O2S.Components.PDF4NET.Forms Namespace


PDFSignatureLockFieldAction Class Members

PDFSignatureLockFieldAction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureLockFieldAction Class

The following tables list the members exposed by PDFSignatureLockFieldAction.

Public Constructors

 | Name | Description
Public Constructor | PDFSignatureLockFieldAction Constructor | Initializes a new PDFSignatureLockFieldAction object.
Top

Public Properties

 | Name | Description
Public Property | Fields | Gets or sets the fields to be locked.
Public Property | SignatureLockFieldMode | Gets or sets the mode for applying the field lock.
Top

See Also

Reference

PDFSignatureLockFieldAction Class
O2S.Components.PDF4NET.Forms Namespace


PDFSignatureLockFieldAction Constructor

PDFSignatureLockFieldAction Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFSignatureLockFieldAction Class : PDFSignatureLockFieldAction Constructor

Initializes a new PDFSignatureLockFieldAction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSignatureLockFieldAction()
C#
public PDFSignatureLockFieldAction()
Managed Extensions for C++
public: PDFSignatureLockFieldAction();
C++/CLI
public:
PDFSignatureLockFieldAction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSignatureLockFieldAction Class
PDFSignatureLockFieldAction Members


PDFSignatureLockFieldAction Class Properties

PDFSignatureLockFieldAction Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureLockFieldAction Class

For a list of all members of this type, see PDFSignatureLockFieldAction members.

Public Properties

 | Name | Description
Public Property | Fields | Gets or sets the fields to be locked.
Public Property | SignatureLockFieldMode | Gets or sets the mode for applying the field lock.
Top

See Also

Reference

PDFSignatureLockFieldAction Class
O2S.Components.PDF4NET.Forms Namespace


Fields Property

Fields Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFSignatureLockFieldAction Class : Fields Property

Gets or sets the fields to be locked.

Syntax

Visual Basic (Declaration)
Public Property Fields As String()
Visual Basic (Usage) Copy Code
Dim instance As PDFSignatureLockFieldAction
Dim value() As String

instance.Fields = value

value = instance.Fields
C#
public string[] Fields {get; set;}
Managed Extensions for C++
public: __property string*[]* get_Fields();
public: __property void set_Fields(
   string*[]* value
);
C++/CLI
public:
property array<String^>^ Fields {
   array<String^>^ get();
   void set (String^array<value>^ value);
}

Return Value

The list of fields to be locked when the signature lock is applied.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSignatureLockFieldAction Class
PDFSignatureLockFieldAction Members


SignatureLockFieldMode Property

SignatureLockFieldMode Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFSignatureLockFieldAction Class : SignatureLockFieldMode Property

Gets or sets the mode for applying the field lock.

Syntax

Visual Basic (Declaration)
Public Property SignatureLockFieldMode As PDFSignatureLockFieldMode
Visual Basic (Usage) Copy Code
Dim instance As PDFSignatureLockFieldAction
Dim value As PDFSignatureLockFieldMode

instance.SignatureLockFieldMode = value

value = instance.SignatureLockFieldMode
C#
public PDFSignatureLockFieldMode SignatureLockFieldMode {get; set;}
Managed Extensions for C++
public: __property PDFSignatureLockFieldMode get_SignatureLockFieldMode();
public: __property void set_SignatureLockFieldMode(
   PDFSignatureLockFieldMode value
);
C++/CLI
public:
property PDFSignatureLockFieldMode SignatureLockFieldMode {
   PDFSignatureLockFieldMode get();
   void set (PDFSignatureLockFieldMode value);
}

Return Value

A value which, in conjunction with Fields, indicates the set of fields that should be locked.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSignatureLockFieldAction Class
PDFSignatureLockFieldAction Members


PDFSignatureWidget Class

PDFSignatureWidget Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureWidget Class

Defines the widget for a signature field.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSignatureWidget
   Inherits PDFFieldWidget
Visual Basic (Usage) Copy Code
Dim instance As PDFSignatureWidget
C#
public class PDFSignatureWidget : PDFFieldWidget
Managed Extensions for C++
public __gc class PDFSignatureWidget : public PDFFieldWidget
C++/CLI
public ref class PDFSignatureWidget : public PDFFieldWidget

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFSignatureWidget

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSignatureWidget Members
O2S.Components.PDF4NET.Forms Namespace


PDFSignatureWidget Class Members

PDFSignatureWidget Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureWidget Class

The following tables list the members exposed by PDFSignatureWidget.

Public Constructors

 | Name | Description
Public Constructor | PDFSignatureWidget Constructor | Initializes a new PDFSignatureWidget object.
Top

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from PDFFieldWidget)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from PDFFieldWidget)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFSignatureWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFSignatureWidget Constructor

PDFSignatureWidget Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFSignatureWidget Class : PDFSignatureWidget Constructor

Initializes a new PDFSignatureWidget object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSignatureWidget()
C#
public PDFSignatureWidget()
Managed Extensions for C++
public: PDFSignatureWidget();
C++/CLI
public:
PDFSignatureWidget();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSignatureWidget Class
PDFSignatureWidget Members


PDFTextBoxField Class

PDFTextBoxField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxField Class

Defines a text box in a PDF form.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFTextBoxField
   Inherits PDFField
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
C#
public class PDFTextBoxField : PDFField
Managed Extensions for C++
public __gc class PDFTextBoxField : public PDFField
C++/CLI
public ref class PDFTextBoxField : public PDFField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.PDFField
O2S.Components.PDF4NET.Forms.PDFTextBoxField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Members
O2S.Components.PDF4NET.Forms Namespace


PDFTextBoxField Class Members

PDFTextBoxField Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxField Class

The following tables list the members exposed by PDFTextBoxField.

Public Constructors

 | Name | Description
Public Constructor | PDFTextBoxField Constructor | Initializes a new PDFTextBoxField object.
Top

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from PDFField)
Public Property | CheckSpelling | Gets or sets a value indicating whether the field content should be checked for spelling erorrs.
Public Property | Comb | Gets or sets a value indicating whether the field acts like a comb or not.
Public Property | Dictionary | Gets the field dictionary. (Inherited from PDFField)
Public Property | FileSelect | Gets or sets a value indicating whether the field can be used for selecting a file from disk.
Public Property | Form | Gets the form that contains this field. (Inherited from PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | MaxLength | Gets or sets the max length of the text that can be inserted in the field.
Public Property | Multiline | Gets or sets a value indicating whether the field is multiline.
Public Property | Name | Gets or sets the field name. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | Password | Gets or sets a value indicating whether the field is used for entering passwords.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | ScrollLongText | Gets or sets a value indicating whether the field content can be scrolled if larger than visible area.
Public Property | Text | Gets or sets the field text.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from PDFField)
Public Property | Type | Gets the field type. (Inherited from PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from PDFField)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from PDFField)
Top

See Also

Reference

PDFTextBoxField Class
O2S.Components.PDF4NET.Forms Namespace


PDFTextBoxField Constructor

PDFTextBoxField Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : PDFTextBoxField Constructor

name
The name of the field.
Initializes a new PDFTextBoxField object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim name As String

Dim instance As PDFTextBoxField(name)
C#
public PDFTextBoxField(
   string name
)
Managed Extensions for C++
public: PDFTextBoxField(
   string* name
)
C++/CLI
public:
PDFTextBoxField(
   String^ name
)

Parameters

name
The name of the field.

Exceptions

Exception | Description
ArgumentException | Thrown when the name is null or empty or not a valid PDF field name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


PDFTextBoxField Class Properties

PDFTextBoxField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxField Class

For a list of all members of this type, see PDFTextBoxField members.

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from PDFField)
Public Property | CheckSpelling | Gets or sets a value indicating whether the field content should be checked for spelling erorrs.
Public Property | Comb | Gets or sets a value indicating whether the field acts like a comb or not.
Public Property | Dictionary | Gets the field dictionary. (Inherited from PDFField)
Public Property | FileSelect | Gets or sets a value indicating whether the field can be used for selecting a file from disk.
Public Property | Form | Gets the form that contains this field. (Inherited from PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from PDFField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | MaxLength | Gets or sets the max length of the text that can be inserted in the field.
Public Property | Multiline | Gets or sets a value indicating whether the field is multiline.
Public Property | Name | Gets or sets the field name. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | Password | Gets or sets a value indicating whether the field is used for entering passwords.
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | ScrollLongText | Gets or sets a value indicating whether the field content can be scrolled if larger than visible area.
Public Property | Text | Gets or sets the field text.
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from PDFField)
Public Property | Type | Gets the field type. (Inherited from PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from PDFField)
Top

See Also

Reference

PDFTextBoxField Class
O2S.Components.PDF4NET.Forms Namespace


CheckSpelling Property

CheckSpelling Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : CheckSpelling Property

Gets or sets a value indicating whether the field content should be checked for spelling erorrs.

Syntax

Visual Basic (Declaration)
Public Property CheckSpelling As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As Boolean

instance.CheckSpelling = value

value = instance.CheckSpelling
C#
public bool CheckSpelling {get; set;}
Managed Extensions for C++
public: __property bool get_CheckSpelling();
public: __property void set_CheckSpelling(
   bool value
);
C++/CLI
public:
property bool CheckSpelling {
   bool get();
   void set (bool value);
}

Return Value

True if the field content should be checked for spelling erorrs, false otherwise. Default is true.

Remarks

The field content is checked for spelling errors only when the PDF file is opened in the viewer (if the PDF viewer support this feature) and it is not spell checked when its value is set from code.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


Comb Property

Comb Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : Comb Property

Gets or sets a value indicating whether the field acts like a comb or not.

Syntax

Visual Basic (Declaration)
Public Property Comb As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As Boolean

instance.Comb = value

value = instance.Comb
C#
public bool Comb {get; set;}
Managed Extensions for C++
public: __property bool get_Comb();
public: __property void set_Comb(
   bool value
);
C++/CLI
public:
property bool Comb {
   bool get();
   void set (bool value);
}

Return Value

True if the field acts like a comb, otherwise false. Default is false.

Remarks

If this property is true, the field is automatically divided into as many equally spaced positions, or combs, as the value of MaxLen property and the text is laid out into those combs.
When this property is set to true, the Multiline and Password properties are automatically set to false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


FileSelect Property

FileSelect Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : FileSelect Property

Gets or sets a value indicating whether the field can be used for selecting a file from disk.

Syntax

Visual Basic (Declaration)
Public Property FileSelect As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As Boolean

instance.FileSelect = value

value = instance.FileSelect
C#
public bool FileSelect {get; set;}
Managed Extensions for C++
public: __property bool get_FileSelect();
public: __property void set_FileSelect(
   bool value
);
C++/CLI
public:
property bool FileSelect {
   bool get();
   void set (bool value);
}

Return Value

True if the text entered in the field represents the pathname of a file whose contents are to be submitted as the value of the field. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


MaxLength Property

MaxLength Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : MaxLength Property

Gets or sets the max length of the text that can be inserted in the field.

Syntax

Visual Basic (Declaration)
Public Property MaxLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As Integer

instance.MaxLength = value

value = instance.MaxLength
C#
public int MaxLength {get; set;}
Managed Extensions for C++
public: __property int get_MaxLength();
public: __property void set_MaxLength(
   int value
);
C++/CLI
public:
property int MaxLength {
   int get();
   void set (int value);
}

Return Value

Maximum amount of text that can be inserted in the text.

Remarks

If this property is 0, then the text length is unlimited.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


Multiline Property

Multiline Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : Multiline Property

Gets or sets a value indicating whether the field is multiline.

Syntax

Visual Basic (Declaration)
Public Property Multiline As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As Boolean

instance.Multiline = value

value = instance.Multiline
C#
public bool Multiline {get; set;}
Managed Extensions for C++
public: __property bool get_Multiline();
public: __property void set_Multiline(
   bool value
);
C++/CLI
public:
property bool Multiline {
   bool get();
   void set (bool value);
}

Return Value

True if the field is multiline, false otherwise. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


Password Property

Password Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : Password Property

Gets or sets a value indicating whether the field is used for entering passwords.

Syntax

Visual Basic (Declaration)
Public Property Password As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As Boolean

instance.Password = value

value = instance.Password
C#
public bool Password {get; set;}
Managed Extensions for C++
public: __property bool get_Password();
public: __property void set_Password(
   bool value
);
C++/CLI
public:
property bool Password {
   bool get();
   void set (bool value);
}

Return Value

True if the field is a password field, false otherwise. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


ScrollLongText Property

ScrollLongText Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : ScrollLongText Property

Gets or sets a value indicating whether the field content can be scrolled if larger than visible area.

Syntax

Visual Basic (Declaration)
Public Property ScrollLongText As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As Boolean

instance.ScrollLongText = value

value = instance.ScrollLongText
C#
public bool ScrollLongText {get; set;}
Managed Extensions for C++
public: __property bool get_ScrollLongText();
public: __property void set_ScrollLongText(
   bool value
);
C++/CLI
public:
property bool ScrollLongText {
   bool get();
   void set (bool value);
}

Return Value

True if the field content can be scrolled, false otherwise. Default is true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


Text Property

Text Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxField Class : Text Property

Gets or sets the field text.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxField
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Return Value

The text content of the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxField Class
PDFTextBoxField Members


PDFTextBoxWidget Class

PDFTextBoxWidget Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxWidget Class

Defines the widget for a textbox field.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFTextBoxWidget
   Inherits PDFFieldWidget
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxWidget
C#
public class PDFTextBoxWidget : PDFFieldWidget
Managed Extensions for C++
public __gc class PDFTextBoxWidget : public PDFFieldWidget
C++/CLI
public ref class PDFTextBoxWidget : public PDFFieldWidget

Remarks

The field widget is the field's visual representation on a PDF page. A textbox field can have multiple widgets on the same page or on different pages. All the field widgets display the same field value.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Annotations.PDFAnnotation
O2S.Components.PDF4NET.Forms.PDFFieldWidget
O2S.Components.PDF4NET.Forms.PDFTextBoxWidget

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxWidget Members
O2S.Components.PDF4NET.Forms Namespace


PDFTextBoxWidget Class Members

PDFTextBoxWidget Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxWidget Class

The following tables list the members exposed by PDFTextBoxWidget.

Public Constructors

 | Name | Description
Public Constructor | PDFTextBoxWidget Constructor | Initializes a new PDFTextBoxWidget object.
Top

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the text alignment in a field.
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from PDFFieldWidget)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from PDFFieldWidget)
Top

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFTextBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFTextBoxWidget Constructor

PDFTextBoxWidget Constructor
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxWidget Class : PDFTextBoxWidget Constructor

Initializes a new PDFTextBoxWidget object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxWidget()
C#
public PDFTextBoxWidget()
Managed Extensions for C++
public: PDFTextBoxWidget();
C++/CLI
public:
PDFTextBoxWidget();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxWidget Class
PDFTextBoxWidget Members


PDFTextBoxWidget Class Properties

PDFTextBoxWidget Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxWidget Class

For a list of all members of this type, see PDFTextBoxWidget members.

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the text alignment in a field.
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from PDFFieldWidget)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFTextBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


Align Property

Align Property
[image]
O2S.Components.PDF4NET.Forms Namespace > PDFTextBoxWidget Class : Align Property

Gets or sets the text alignment in a field.

Syntax

Visual Basic (Declaration)
Public Property Align As PDFFieldTextAlign
Visual Basic (Usage) Copy Code
Dim instance As PDFTextBoxWidget
Dim value As PDFFieldTextAlign

instance.Align = value

value = instance.Align
C#
public PDFFieldTextAlign Align {get; set;}
Managed Extensions for C++
public: __property PDFFieldTextAlign get_Align();
public: __property void set_Align(
   PDFFieldTextAlign value
);
C++/CLI
public:
property PDFFieldTextAlign Align {
   PDFFieldTextAlign get();
   void set (PDFFieldTextAlign value);
}

Return Value

A PDFFieldTextAlign enumeration member specifying the text alignment in a field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextBoxWidget Class
PDFTextBoxWidget Members


XFDFField Class

XFDFField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFField Class

Defines a field in a XFDF document.

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XFDFField
Visual Basic (Usage) Copy Code
Dim instance As XFDFField
C#
public sealed class XFDFField
Managed Extensions for C++
public __gc __sealed class XFDFField
C++/CLI
public ref class XFDFField sealed

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFDFField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFField Members
O2S.Components.PDF4NET.Forms Namespace


XFDFField Class Members

XFDFField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFField Class

The following tables list the members exposed by XFDFField.

Public Properties

 | Name | Description
Public Property | Name | Gets the field name.
Public Property | Value | Gets the field value.
Top

See Also

Reference

XFDFField Class
O2S.Components.PDF4NET.Forms Namespace


XFDFField Class Properties

XFDFField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFField Class

For a list of all members of this type, see XFDFField members.

Public Properties

 | Name | Description
Public Property | Name | Gets the field name.
Public Property | Value | Gets the field value.
Top

See Also

Reference

XFDFField Class
O2S.Components.PDF4NET.Forms Namespace


Name Property

Name Property
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFField Class : Name Property

Gets the field name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As XFDFField
Dim value As String

value = instance.Name
C#
public string Name {get;}
Managed Extensions for C++
public: __property string* get_Name();
C++/CLI
public:
property String^ Name {
   String^ get();
}

Return Value

A string value specifying the name of the XFDF field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFField Class
XFDFField Members


Value Property

Value Property
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFField Class : Value Property

Gets the field value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As XFDFField
Dim value As String

value = instance.Value
C#
public string Value {get;}
Managed Extensions for C++
public: __property string* get_Value();
C++/CLI
public:
property String^ Value {
   String^ get();
}

Return Value

A string value specifying the value of the XFDF field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFField Class
XFDFField Members


XFDFFieldCollection Class

XFDFFieldCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFFieldCollection Class

Defines a collection of fields in a XFDF document.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XFDFFieldCollection
   Inherits PDFCollection(Of XFDFField, XFDFFile)
Visual Basic (Usage) Copy Code
Dim instance As XFDFFieldCollection
C#
public sealed class XFDFFieldCollection : PDFCollection<XFDFField, XFDFFile>
Managed Extensions for C++
public __gc __sealed class XFDFFieldCollection : public PDFCollection<XFDFField, XFDFFile>
C++/CLI
public ref class XFDFFieldCollection sealed : public PDFCollection<XFDFField, XFDFFile>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<XFDFField>
O2S.Components.PDF4NET.PDFCollection<XFDFField, XFDFFile>
O2S.Components.PDF4NET.Forms.XFDFFieldCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFieldCollection Members
O2S.Components.PDF4NET.Forms Namespace


XFDFFieldCollection Class Members

XFDFFieldCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFFieldCollection Class

The following tables list the members exposed by XFDFFieldCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Top

See Also

Reference

XFDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


XFDFFile Class

XFDFFile Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFFile Class

Represents a XFDF file on disk.

Object Model

Syntax

Visual Basic (Declaration)
Public Class XFDFFile
Visual Basic (Usage) Copy Code
Dim instance As XFDFFile
C#
public class XFDFFile
Managed Extensions for C++
public __gc class XFDFFile
C++/CLI
public ref class XFDFFile

Remarks

This class defines an existing XFDF file.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFDFFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFile Members
O2S.Components.PDF4NET.Forms Namespace


XFDFFile Class Members

XFDFFile Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFFile Class

The following tables list the members exposed by XFDFFile.

Public Properties

 | Name | Description
Public Property | Fields | Gets the list of fields in the XFDF file.
Public Property | PDFFileName | Gets the name of the PDF file the XFDF file was exported from.
Top

Public Methods

 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | FromFile | Creates a XFDFFile object from the given XFDF file.
static (Shared in Visual Basic) | FromStream | Creates a XFDFFile object from the given stream object.
Top

See Also

Reference

XFDFFile Class
O2S.Components.PDF4NET.Forms Namespace


XFDFFile Class Methods

XFDFFile Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFFile Class

For a list of all members of this type, see XFDFFile members.

Public Methods

 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | FromFile | Creates a XFDFFile object from the given XFDF file.
static (Shared in Visual Basic) | FromStream | Creates a XFDFFile object from the given stream object.
Top

See Also

Reference

XFDFFile Class
O2S.Components.PDF4NET.Forms Namespace


Close Method

Close Method
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFile Class : Close Method

Closes the underlying pdf file and frees all resources.

Syntax

Visual Basic (Declaration)
Public Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As XFDFFile

instance.Close()
C#
public void Close()
Managed Extensions for C++
public: void Close();
C++/CLI
public:
void Close();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFile Class
XFDFFile Members


FromFile Method

FromFile Method
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFile Class : FromFile Method

fileName
the full path to a XFDF file used as source for this XFDFFile object.
Creates a XFDFFile object from the given XFDF file.

Syntax

Visual Basic (Declaration)
Public Shared Function FromFile( _
   ByVal fileName As String _
) As XFDFFile
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim value As XFDFFile

value = XFDFFile.FromFile(fileName)
C#
public static XFDFFile FromFile(
   string fileName
)
Managed Extensions for C++
public: static XFDFFile* FromFile(
   string* fileName
)
C++/CLI
public:
static XFDFFile^ FromFile(
   String^ fileName
)

Parameters

fileName
the full path to a XFDF file used as source for this XFDFFile object.

Return Value

A XFDFFile object created based on the given XFDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFile Class
XFDFFile Members


FromStream Method

FromStream Method
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFile Class : FromStream Method

stream
the stream object used as source for this XFDFFile object.
Creates a XFDFFile object from the given stream object.

Syntax

Visual Basic (Declaration)
Public Shared Function FromStream( _
   ByVal stream As Stream _
) As XFDFFile
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim value As XFDFFile

value = XFDFFile.FromStream(stream)
C#
public static XFDFFile FromStream(
   Stream stream
)
Managed Extensions for C++
public: static XFDFFile* FromStream(
   Stream* stream
)
C++/CLI
public:
static XFDFFile^ FromStream(
   Stream^ stream
)

Parameters

stream
the stream object used as source for this XFDFFile object.

Return Value

A XFDFFile object created based on the given stream object.

Remarks

The stream must contain a valid XFDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFile Class
XFDFFile Members


XFDFFile Class Properties

XFDFFile Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFFile Class

For a list of all members of this type, see XFDFFile members.

Public Properties

 | Name | Description
Public Property | Fields | Gets the list of fields in the XFDF file.
Public Property | PDFFileName | Gets the name of the PDF file the XFDF file was exported from.
Top

See Also

Reference

XFDFFile Class
O2S.Components.PDF4NET.Forms Namespace


Fields Property

Fields Property
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFile Class : Fields Property

Gets the list of fields in the XFDF file.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As XFDFFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As XFDFFile
Dim value As XFDFFieldCollection

value = instance.Fields
C#
public XFDFFieldCollection Fields {get;}
Managed Extensions for C++
public: __property XFDFFieldCollection* get_Fields();
C++/CLI
public:
property XFDFFieldCollection^ Fields {
   XFDFFieldCollection^ get();
}

Return Value

A XFDFFieldCollection object specifying the list of fields in the XFDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFile Class
XFDFFile Members


PDFFileName Property

PDFFileName Property
[image]
O2S.Components.PDF4NET.Forms Namespace > XFDFFile Class : PDFFileName Property

Gets the name of the PDF file the XFDF file was exported from.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PDFFileName As String
Visual Basic (Usage) Copy Code
Dim instance As XFDFFile
Dim value As String

value = instance.PDFFileName
C#
public string PDFFileName {get;}
Managed Extensions for C++
public: __property string* get_PDFFileName();
C++/CLI
public:
property String^ PDFFileName {
   String^ get();
}

Return Value

A string value specifying the the name of the PDF file the XFDF file was exported from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFDFFile Class
XFDFFile Members


PDFCheckSymbolStyle Enumeration

PDFCheckSymbolStyle Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckSymbolStyle Enumeration

Specifies the available style for a check box and radio button items.

Syntax

Visual Basic (Declaration)
Public Enum PDFCheckSymbolStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFCheckSymbolStyle
C#
public enum PDFCheckSymbolStyle : Enum
Managed Extensions for C++
__value public enum PDFCheckSymbolStyle : public Enum
C++/CLI
public enum class PDFCheckSymbolStyle : public Enum

Members

Member | Description
Custom | The appearance of the check box is created from code.
Check | A check mark is used for the checked state.
Circle | A circle is used for the checked state.
Cross | A cross is used for the checked state.
Cross2 | A cross is used for the checked state.
Cross3 | A cross is used for the checked state.
Diamond | A diamond symbol is used for the checked state.
Square | A square is used for the checked state.
Star | A star is used for the checked state.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.PDFCheckSymbolStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


PDFExportDataOptions Enumeration

PDFExportDataOptions Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFExportDataOptions Enumeration

Specifies the available export options for PDF forms.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum PDFExportDataOptions
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFExportDataOptions
C#
[FlagsAttribute()]
public enum PDFExportDataOptions : Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum PDFExportDataOptions : public Enum
C++/CLI
[FlagsAttribute()]
public enum class PDFExportDataOptions : public Enum

Members

Member | Description
FormData | Form data is exported from the PDF document.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.PDFExportDataOptions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


PDFFieldTextAlign Enumeration

PDFFieldTextAlign Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldTextAlign Enumeration

Specifies the available alignments for text in a field.

Syntax

Visual Basic (Declaration)
Public Enum PDFFieldTextAlign
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldTextAlign
C#
public enum PDFFieldTextAlign : Enum
Managed Extensions for C++
__value public enum PDFFieldTextAlign : public Enum
C++/CLI
public enum class PDFFieldTextAlign : public Enum

Members

Member | Description
Left | The text is left aligned
Center | The text is center aligned
Right | The text is right aligned

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.PDFFieldTextAlign

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


PDFFieldType Enumeration

PDFFieldType Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldType Enumeration

Specifies the available field types.

Syntax

Visual Basic (Declaration)
Public Enum PDFFieldType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldType
C#
public enum PDFFieldType : Enum
Managed Extensions for C++
__value public enum PDFFieldType : public Enum
C++/CLI
public enum class PDFFieldType : public Enum

Members

Member | Description
TextBox | Text box.
PushButton | Push button.
CheckBox | Check box.
RadioButton | Radio button list.
DropDownList | Combobox.
ListBox | List box.
Signature | Signature field.
Unknown | Unknown.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.PDFFieldType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


PDFFieldWidgetVisibilityStatus Enumeration

PDFFieldWidgetVisibilityStatus Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidgetVisibilityStatus Enumeration

Specifies the available visibility states for a field widget.

Syntax

Visual Basic (Declaration)
Public Enum PDFFieldWidgetVisibilityStatus
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFFieldWidgetVisibilityStatus
C#
public enum PDFFieldWidgetVisibilityStatus : Enum
Managed Extensions for C++
__value public enum PDFFieldWidgetVisibilityStatus : public Enum
C++/CLI
public enum class PDFFieldWidgetVisibilityStatus : public Enum

Members

Member | Description
Visible | The field widget is visible on the page.
Hidden | The field widget is not visible on the page.
VisibleNonPrintable | The field widget is visible on the page but it does not print.
HiddenPrintable | The field widget is not visible on the page but it prints.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.PDFFieldWidgetVisibilityStatus

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


PDFFormDataFormat Enumeration

PDFFormDataFormat Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFormDataFormat Enumeration

Specifies the available formats for data import/export for AcroForms.

Syntax

Visual Basic (Declaration)
Public Enum PDFFormDataFormat
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFFormDataFormat
C#
public enum PDFFormDataFormat : Enum
Managed Extensions for C++
__value public enum PDFFormDataFormat : public Enum
C++/CLI
public enum class PDFFormDataFormat : public Enum

Members

Member | Description
FDF | Form data is imported or exported in FDF format.
XFDF | Form data is imported or exported in XFDF format.
XML | Form data is imported or exported in XML format.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.PDFFormDataFormat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


PDFPushButtonHighlightMode Enumeration

PDFPushButtonHighlightMode Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonHighlightMode Enumeration

Specifies the available highlighting modes for a button.

Syntax

Visual Basic (Declaration)
Public Enum PDFPushButtonHighlightMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFPushButtonHighlightMode
C#
public enum PDFPushButtonHighlightMode : Enum
Managed Extensions for C++
__value public enum PDFPushButtonHighlightMode : public Enum
C++/CLI
public enum class PDFPushButtonHighlightMode : public Enum

Members

Member | Description
None | No highlighting, the button's appearance does not change when the button is pressed. Rollover and down button appearances are ignored.
Invert | Inverts the content of button's normal appearance. Rollover and down button appearances are ignored.
Outline | Inverts the button's border. Rollover and down button appearances are ignored.
Push | Displays the button's down appearance. Rollover appearance has also effect on this mode. When this mode is used, both rollover and down appearances must be constructed from code.

Remarks

The highlight mode defines how the button's down appearance is created when the button is pressed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.PDFPushButtonHighlightMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


PDFSignatureLockFieldMode Enumeration

PDFSignatureLockFieldMode Enumeration
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureLockFieldMode Enumeration

Specifies the available lock modes for form fields when a signature lock is applied.

Syntax

Visual Basic (Declaration)
Public Enum PDFSignatureLockFieldMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFSignatureLockFieldMode
C#
public enum PDFSignatureLockFieldMode : Enum
Managed Extensions for C++
__value public enum PDFSignatureLockFieldMode : public Enum
C++/CLI
public enum class PDFSignatureLockFieldMode : public Enum

Members

Member | Description
All | All fields in the form are locked.
Include | Only the specified fields are locked.
Exclude | All the form fields are locked excepting the specified fields.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.PDFSignatureLockFieldMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms Namespace


O2S.Components.PDF4NET.Forms.XFA Namespace

O2S.Components.PDF4NET.Forms.XFA Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
XFAArea | Defines a XFA area.
XFAAreaCollection | Defines a collection of XFA areas.
XFABarcodeField | Defines a XFA barcode field.
XFABasicContainer | Defines a basic XFA container.
XFAButtonField | Defines a XFA button field.
XFACheckButtonField | Defines a XFA check button field.
XFAChoiceListField | Defines a XFA choice list field.
XFADateTimeEditField | Defines a XFA date/time edit field.
XFAElement | Defines the base class for all elements in a XFA form.
XFAExtendedContainer | Defines an extended XFA container.
XFAField | Defines a XFA field.
XFAFieldCollection | Defines a collection of XFA fields.
XFAFieldImportError | Represents an error that happened during the import of a XML file.
XFAForm | Defines a document level XFA form.
XFAHttpSubmitButtonField | Defines a XFA button field that submits the form data to a server using HTTP protocol.
XFAImageEditField | Defines a XFA image edit field.
XFAListItem | Defines an item in a choice list.
XFAListItemCollection | Defines a collection of fields in a FDF document.
XFANumericEditField | Defines a XFA numeric edit field.
XFAPageArea | Defines a XFA page area.
XFAPageAreaCollection | Defines a collection of XFA page areas.
XFAPageSet | Defines a XFA page set.
XFAPageSetCollection | Defines a collection of XFA page sets.
XFAPasswordEditField | Defines a XFA password edit field.
XFARadioButtonField | Defines a XFA radio button field.
XFARadioButtonFieldCollection | Defines a collection of exclusive radio buttons.
XFARadioButtonListField | Defines a XFA radio buttons list field.
XFASubform | Defines a XFA subform.
XFASubformCollection | Defines a collection of XFA subforms.
XFATextEditField | Defines a XFA text edit field.

Enumerations

Enumeration | Description
XFABarcodeType | Specifies the available barcode types for displaying field content.
XFACheckButtonState | Specifies the available states for a checkbutton and radiobutton.
XFAChoiceListDisplayMode | Specifies the modes for presenting the drop down choice list in interactive applications.
XFAContentAccess | Specifies the access modes to the content of a container.
XFAContentType | Specifies the available types of content accepted by a XFA value.
XFAContentVisibility | Specifies the visibility of the content of a container.
XFADataFormat | Specifies the available formats for data import/export for XFA Forms.
XFAImageAspect | Specifies the available modes for scaling the image when it is displayed in the image edit field.
XFAImageStorageMode | Specifies the available modes for storing image content in an image edit field.

See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET.Forms.XFA Namespace Inheritance Hierarchy

O2S.Components.PDF4NET.Forms.XFA Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAAreaCollection
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer
O2S.Components.PDF4NET.Forms.XFA.XFAArea
O2S.Components.PDF4NET.Forms.XFA.XFAPageArea
O2S.Components.PDF4NET.Forms.XFA.XFASubform
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFABarcodeField
O2S.Components.PDF4NET.Forms.XFA.XFAButtonField
O2S.Components.PDF4NET.Forms.XFA.XFAHttpSubmitButtonField
O2S.Components.PDF4NET.Forms.XFA.XFAChoiceListField
O2S.Components.PDF4NET.Forms.XFA.XFADateTimeEditField
O2S.Components.PDF4NET.Forms.XFA.XFAImageEditField
O2S.Components.PDF4NET.Forms.XFA.XFANumericEditField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonField
O2S.Components.PDF4NET.Forms.XFA.XFACheckButtonField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonListField
O2S.Components.PDF4NET.Forms.XFA.XFATextEditField
O2S.Components.PDF4NET.Forms.XFA.XFAPasswordEditField
O2S.Components.PDF4NET.Forms.XFA.XFAPageSet
O2S.Components.PDF4NET.Forms.XFA.XFAForm
O2S.Components.PDF4NET.Forms.XFA.XFAFieldCollection
O2S.Components.PDF4NET.Forms.XFA.XFAFieldImportError
O2S.Components.PDF4NET.Forms.XFA.XFAListItem
O2S.Components.PDF4NET.Forms.XFA.XFAPageAreaCollection
O2S.Components.PDF4NET.Forms.XFA.XFAPageSetCollection
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonFieldCollection
O2S.Components.PDF4NET.Forms.XFA.XFASubformCollection
System.Collections.ObjectModel.Collection<XFAListItem>
O2S.Components.PDF4NET.PDFCollection<XFAListItem, XFAChoiceListField>
O2S.Components.PDF4NET.Forms.XFA.XFAListItemCollection

See Also

Reference

O2S.Components.PDF4NET Assembly


XFAArea Class

XFAArea Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAArea Class

Defines a XFA area.

Syntax

Visual Basic (Declaration)
Public Class XFAArea
   Inherits XFAExtendedContainer
Visual Basic (Usage) Copy Code
Dim instance As XFAArea
C#
public class XFAArea : XFAExtendedContainer
Managed Extensions for C++
public __gc class XFAArea : public XFAExtendedContainer
C++/CLI
public ref class XFAArea : public XFAExtendedContainer

Remarks

A XFA area is a container representing a geographical grouping of other containers.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer
O2S.Components.PDF4NET.Forms.XFA.XFAArea

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAArea Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAArea Class Members

XFAArea Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAArea Class

The following tables list the members exposed by XFAArea.

Public Properties

 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from XFAExtendedContainer)
Top

See Also

Reference

XFAArea Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAAreaCollection Class

XFAAreaCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAAreaCollection Class

Defines a collection of XFA areas.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class XFAAreaCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAAreaCollection
C#
[DefaultMemberAttribute("Item")]
public class XFAAreaCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class XFAAreaCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class XFAAreaCollection

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAAreaCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAAreaCollection Class Members

XFAAreaCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAAreaCollection Class

The following tables list the members exposed by XFAAreaCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the area at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAAreaCollection Class Methods

XFAAreaCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAAreaCollection Class

For a list of all members of this type, see XFAAreaCollection members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


GetEnumerator Method

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As XFAAreaCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


MoveNext Method

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFAAreaCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


Reset Method

Reset Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As XFAAreaCollection

instance.Reset()
C#
public void Reset()
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


XFAAreaCollection Class Properties

XFAAreaCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAAreaCollection Class

For a list of all members of this type, see XFAAreaCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the area at the specified index (zero based index).
Top

See Also

Reference

XFAAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Count Property

Count Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : Count Property

Returns the number of items in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFAAreaCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


Current Property

Current Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As XFAAreaCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


Item Property

Item Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class : Item Property

Gets the area at the specified index (zero based index).

Overload List

Overload | Description
Item(Int32) | Gets the area at the specified index (zero based index).
Item(String) | Gets the area with the given name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members


Item(Int32) Property

Item(Int32) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class > Item Property : Item(Int32) Property

index
Gets the area at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As XFAArea
Visual Basic (Usage) Copy Code
Dim instance As XFAAreaCollection
Dim index As Integer
Dim value As XFAArea

value = instance.Item(index)
C#
public XFAArea Item(
   int index
) {get;}
Managed Extensions for C++
public: __property XFAArea* get_Item(
   int index
);
C++/CLI
public:
property XFAArea^ Item {
   XFAArea^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members
Overload List


Item(String) Property

Item(String) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAAreaCollection Class > Item Property : Item(String) Property

name
Gets the area with the given name.

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As XFAArea
Visual Basic (Usage) Copy Code
Dim instance As XFAAreaCollection
Dim name As String
Dim value As XFAArea

value = instance.Item(name)
C#
public XFAArea Item(
   string name
) {get;}
Managed Extensions for C++
public: __property XFAArea* get_Item(
   string* name
);
C++/CLI
public:
property XFAArea^ Item {
   XFAArea^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAAreaCollection Class
XFAAreaCollection Members
Overload List


XFABarcodeField Class

XFABarcodeField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFABarcodeField Class

Defines a XFA barcode field.

Syntax

Visual Basic (Declaration)
Public Class XFABarcodeField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFABarcodeField
C#
public class XFABarcodeField : XFAField
Managed Extensions for C++
public __gc class XFABarcodeField : public XFAField
C++/CLI
public ref class XFABarcodeField : public XFAField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFABarcodeField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFABarcodeField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFABarcodeField Class Members

XFABarcodeField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFABarcodeField Class

The following tables list the members exposed by XFABarcodeField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | Data | Gets or sets the barcode data.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Type | Gets the type of the barcode used by this field.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFABarcodeField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFABarcodeField Class Properties

XFABarcodeField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFABarcodeField Class

For a list of all members of this type, see XFABarcodeField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | Data | Gets or sets the barcode data.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Type | Gets the type of the barcode used by this field.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFABarcodeField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Data Property

Data Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFABarcodeField Class : Data Property

Gets or sets the barcode data.

Syntax

Visual Basic (Declaration)
Public Property Data As String
Visual Basic (Usage) Copy Code
Dim instance As XFABarcodeField
Dim value As String

instance.Data = value

value = instance.Data
C#
public string Data {get; set;}
Managed Extensions for C++
public: __property string* get_Data();
public: __property void set_Data(
   string* value
);
C++/CLI
public:
property String^ Data {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the text to be displayed as barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFABarcodeField Class
XFABarcodeField Members


Type Property

Type Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFABarcodeField Class : Type Property

Gets the type of the barcode used by this field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As XFABarcodeType
Visual Basic (Usage) Copy Code
Dim instance As XFABarcodeField
Dim value As XFABarcodeType

value = instance.Type
C#
public XFABarcodeType Type {get;}
Managed Extensions for C++
public: __property XFABarcodeType get_Type();
C++/CLI
public:
property XFABarcodeType Type {
   XFABarcodeType get();
}

Return Value

A XFABarcodeType enumeration member specifying the type of the barcode used to represent the content of this field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFABarcodeField Class
XFABarcodeField Members


XFABasicContainer Class

XFABasicContainer Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFABasicContainer Class

Defines a basic XFA container.

Syntax

Visual Basic (Declaration)
Public MustInherit Class XFABasicContainer
   Inherits XFAElement
Visual Basic (Usage) Copy Code
Dim instance As XFABasicContainer
C#
public abstract class XFABasicContainer : XFAElement
Managed Extensions for C++
public __gc abstract class XFABasicContainer : public XFAElement
C++/CLI
public ref class XFABasicContainer abstract : public XFAElement

Remarks

A basic XFA container is an element that can include only other basic containers.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAPageSet
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFABasicContainer Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFABasicContainer Class Members

XFABasicContainer Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFABasicContainer Class

The following tables list the members exposed by XFABasicContainer.

Public Properties

 | Name | Description
Public Property | ID | Gets the id of this container.
Public Property | Name | Gets the name of this container.
Top

See Also

Reference

XFABasicContainer Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFABasicContainer Class Properties

XFABasicContainer Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFABasicContainer Class

For a list of all members of this type, see XFABasicContainer members.

Public Properties

 | Name | Description
Public Property | ID | Gets the id of this container.
Public Property | Name | Gets the name of this container.
Top

See Also

Reference

XFABasicContainer Class
O2S.Components.PDF4NET.Forms.XFA Namespace


ID Property

ID Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFABasicContainer Class : ID Property

Gets the id of this container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As XFABasicContainer
Dim value As String

value = instance.ID
C#
public string ID {get;}
Managed Extensions for C++
public: __property string* get_ID();
C++/CLI
public:
property String^ ID {
   String^ get();
}

Return Value

A string value specifying the the container identifier.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFABasicContainer Class
XFABasicContainer Members


Name Property

Name Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFABasicContainer Class : Name Property

Gets the name of this container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As XFABasicContainer
Dim value As String

value = instance.Name
C#
public string Name {get;}
Managed Extensions for C++
public: __property string* get_Name();
C++/CLI
public:
property String^ Name {
   String^ get();
}

Return Value

A string value specifying the the container name.

Remarks

The name is used to locate the container inside the form hierarchy and it is relative to parent container.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFABasicContainer Class
XFABasicContainer Members


XFAButtonField Class

XFAButtonField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAButtonField Class

Defines a XFA button field.

Syntax

Visual Basic (Declaration)
Public Class XFAButtonField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFAButtonField
C#
public class XFAButtonField : XFAField
Managed Extensions for C++
public __gc class XFAButtonField : public XFAField
C++/CLI
public ref class XFAButtonField : public XFAField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFAButtonField
O2S.Components.PDF4NET.Forms.XFA.XFAHttpSubmitButtonField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAButtonField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAButtonField Class Members

XFAButtonField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAButtonField Class

The following tables list the members exposed by XFAButtonField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFACheckButtonField Class

XFACheckButtonField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFACheckButtonField Class

Defines a XFA check button field.

Syntax

Visual Basic (Declaration)
Public Class XFACheckButtonField
   Inherits XFARadioButtonField
Visual Basic (Usage) Copy Code
Dim instance As XFACheckButtonField
C#
public class XFACheckButtonField : XFARadioButtonField
Managed Extensions for C++
public __gc class XFACheckButtonField : public XFARadioButtonField
C++/CLI
public ref class XFACheckButtonField : public XFARadioButtonField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonField
O2S.Components.PDF4NET.Forms.XFA.XFACheckButtonField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFACheckButtonField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFACheckButtonField Class Members

XFACheckButtonField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFACheckButtonField Class

The following tables list the members exposed by XFACheckButtonField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | AllowNeutral | Gets a value indicating whether the check button allows neutral state.
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | CheckedState | Gets or sets the checked state of the field. (Inherited from XFARadioButtonField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFACheckButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFACheckButtonField Class Properties

XFACheckButtonField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFACheckButtonField Class

For a list of all members of this type, see XFACheckButtonField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | AllowNeutral | Gets a value indicating whether the check button allows neutral state.
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | CheckedState | Gets or sets the checked state of the field. (Inherited from XFARadioButtonField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFACheckButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


AllowNeutral Property

AllowNeutral Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFACheckButtonField Class : AllowNeutral Property

Gets a value indicating whether the check button allows neutral state.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AllowNeutral As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFACheckButtonField
Dim value As Boolean

value = instance.AllowNeutral
C#
public bool AllowNeutral {get;}
Managed Extensions for C++
public: __property bool get_AllowNeutral();
C++/CLI
public:
property bool AllowNeutral {
   bool get();
}

Return Value

True if the check button allows neutral state, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFACheckButtonField Class
XFACheckButtonField Members


XFAChoiceListField Class

XFAChoiceListField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAChoiceListField Class

Defines a XFA choice list field.

Object Model

Syntax

Visual Basic (Declaration)
Public Class XFAChoiceListField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFAChoiceListField
C#
public class XFAChoiceListField : XFAField
Managed Extensions for C++
public __gc class XFAChoiceListField : public XFAField
C++/CLI
public ref class XFAChoiceListField : public XFAField

Remarks

The field can be either a drop down list or a list box, depending on the DisplayMode property.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFAChoiceListField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAChoiceListField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAChoiceListField Class Members

XFAChoiceListField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAChoiceListField Class

The following tables list the members exposed by XFAChoiceListField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | DisplayMode | Gets the display mode of the drop down choice list.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Items | Gets the collection of items in the choice list.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list.
Public Property | SelectedItem | Gets or sets the first selected item in the list.
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAChoiceListField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAChoiceListField Class Properties

XFAChoiceListField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAChoiceListField Class

For a list of all members of this type, see XFAChoiceListField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | DisplayMode | Gets the display mode of the drop down choice list.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Items | Gets the collection of items in the choice list.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list.
Public Property | SelectedItem | Gets or sets the first selected item in the list.
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAChoiceListField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


DisplayMode Property

DisplayMode Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAChoiceListField Class : DisplayMode Property

Gets the display mode of the drop down choice list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisplayMode As XFAChoiceListDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As XFAChoiceListField
Dim value As XFAChoiceListDisplayMode

value = instance.DisplayMode
C#
public XFAChoiceListDisplayMode DisplayMode {get;}
Managed Extensions for C++
public: __property XFAChoiceListDisplayMode get_DisplayMode();
C++/CLI
public:
property XFAChoiceListDisplayMode DisplayMode {
   XFAChoiceListDisplayMode get();
}

Return Value

A XFAChoiceListDisplayMode enumeration member specifying the display mode of the drop down choice list.

Remarks

If the value of this property is XFAChoiceListDisplayMode.Always or XFAChoiceListDisplayMode.Multiselect, then the choice list is presented as a list box in user interactive applications, otherwise it is presented as a drop down list.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAChoiceListField Class
XFAChoiceListField Members


Items Property

Items Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAChoiceListField Class : Items Property

Gets the collection of items in the choice list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As XFAListItemCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAChoiceListField
Dim value As XFAListItemCollection

value = instance.Items
C#
public XFAListItemCollection Items {get;}
Managed Extensions for C++
public: __property XFAListItemCollection* get_Items();
C++/CLI
public:
property XFAListItemCollection^ Items {
   XFAListItemCollection^ get();
}

Return Value

A XFAListItemCollection that represents the items in the choice list.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAChoiceListField Class
XFAChoiceListField Members


SelectedIndex Property

SelectedIndex Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAChoiceListField Class : SelectedIndex Property

Gets or sets the lowest ordinal index of the selected items in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFAChoiceListField
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
public int SelectedIndex {get; set;}
Managed Extensions for C++
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
C++/CLI
public:
property int SelectedIndex {
   int get();
   void set (int value);
}

Return Value

The lowest ordinal index of the selected items in the list. The default is -1, which indicates that nothing is selected.

Remarks

Use this property to determine the index of the currently selected item in the list if the list control allows only one selection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAChoiceListField Class
XFAChoiceListField Members


SelectedItem Property

SelectedItem Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAChoiceListField Class : SelectedItem Property

Gets or sets the first selected item in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedItem As XFAListItem
Visual Basic (Usage) Copy Code
Dim instance As XFAChoiceListField
Dim value As XFAListItem

instance.SelectedItem = value

value = instance.SelectedItem
C#
public XFAListItem SelectedItem {get; set;}
Managed Extensions for C++
public: __property XFAListItem* get_SelectedItem();
public: __property void set_SelectedItem(
   XFAListItem* value
);
C++/CLI
public:
property XFAListItem^ SelectedItem {
   XFAListItem^ get();
   void set (XFAListItem^ value);
}

Return Value

A XFAListItem object specifying the first selected item.

Remarks

If the item to select does not exist in the list, current selection is not changed.
If the item to select is null, then the selection is reset and SelectedIndex property becomes -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAChoiceListField Class
XFAChoiceListField Members


SelectedValue Property

SelectedValue Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAChoiceListField Class : SelectedValue Property

Gets or sets the value of the first selected item in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedValue As String
Visual Basic (Usage) Copy Code
Dim instance As XFAChoiceListField
Dim value As String

instance.SelectedValue = value

value = instance.SelectedValue
C#
public string SelectedValue {get; set;}
Managed Extensions for C++
public: __property string* get_SelectedValue();
public: __property void set_SelectedValue(
   string* value
);
C++/CLI
public:
property String^ SelectedValue {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the value of the first selected item, null (Nothing in VB.NET) if there is no selected item.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value does not exist in field's set of values.

Remarks

When setting the selected value, if the value does not exist in the list, an exception is thrown.
If the value to select is null (Nothing in VB.NET), then the selection is reset and SelectedIndex property becomes -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAChoiceListField Class
XFAChoiceListField Members


XFADateTimeEditField Class

XFADateTimeEditField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFADateTimeEditField Class

Defines a XFA date/time edit field.

Syntax

Visual Basic (Declaration)
Public Class XFADateTimeEditField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFADateTimeEditField
C#
public class XFADateTimeEditField : XFAField
Managed Extensions for C++
public __gc class XFADateTimeEditField : public XFAField
C++/CLI
public ref class XFADateTimeEditField : public XFAField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFADateTimeEditField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFADateTimeEditField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFADateTimeEditField Class Members

XFADateTimeEditField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFADateTimeEditField Class

The following tables list the members exposed by XFADateTimeEditField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | DateTimeValue | Gets or sets the date and time.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFADateTimeEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFADateTimeEditField Class Properties

XFADateTimeEditField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFADateTimeEditField Class

For a list of all members of this type, see XFADateTimeEditField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | DateTimeValue | Gets or sets the date and time.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFADateTimeEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


DateTimeValue Property

DateTimeValue Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFADateTimeEditField Class : DateTimeValue Property

Gets or sets the date and time.

Syntax

Visual Basic (Declaration)
Public Property DateTimeValue As Date
Visual Basic (Usage) Copy Code
Dim instance As XFADateTimeEditField
Dim value As Date

instance.DateTimeValue = value

value = instance.DateTimeValue
C#
public DateTime DateTimeValue {get; set;}
Managed Extensions for C++
public: __property DateTime get_DateTimeValue();
public: __property void set_DateTimeValue(
   DateTime value
);
C++/CLI
public:
property DateTime DateTimeValue {
   DateTime get();
   void set (DateTime value);
}

Return Value

A DateTime value specifying the value of the field.

Remarks

The value of this property is controlled by ValueType property.
When ValueType property is XFAContentType.Date, only the date part of the DateTime value is stored and the time part is set to 12:00:00 AM.
When ValueType property is XFAContentType.DateTime, the complete DateTime value is stored.
When ValueType property is XFAContentType.Time, only the time part of the DateTime value is stored and the date part is set to 01 January 0001.
This property returns 01 January 0001 even if the field does not contain any value. In order to find out if the field is empty compare the XFAField.Value property to null (Nothing in VB.NET).
Set the XFAField.Value property to null (Nothing in VB.NET) in order to clear the field value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFADateTimeEditField Class
XFADateTimeEditField Members


XFAElement Class

XFAElement Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAElement Class

Defines the base class for all elements in a XFA form.

Syntax

Visual Basic (Declaration)
Public MustInherit Class XFAElement
Visual Basic (Usage) Copy Code
Dim instance As XFAElement
C#
public abstract class XFAElement
Managed Extensions for C++
public __gc abstract class XFAElement
C++/CLI
public ref class XFAElement abstract

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFAForm
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAElement Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAElement Class Members

XFAElement Class Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAElement Class

The following tables list the members exposed by XFAElement.

See Also

Reference

XFAElement Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAExtendedContainer Class

XFAExtendedContainer Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAExtendedContainer Class

Defines an extended XFA container.

Syntax

Visual Basic (Declaration)
Public MustInherit Class XFAExtendedContainer
   Inherits XFABasicContainer
Visual Basic (Usage) Copy Code
Dim instance As XFAExtendedContainer
C#
public abstract class XFAExtendedContainer : XFABasicContainer
Managed Extensions for C++
public __gc abstract class XFAExtendedContainer : public XFABasicContainer
C++/CLI
public ref class XFAExtendedContainer abstract : public XFABasicContainer

Remarks

An extended XFA container is an element that can include other containers, both basic and extended, such as subforms, areas and fields.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer
O2S.Components.PDF4NET.Forms.XFA.XFASubform
O2S.Components.PDF4NET.Forms.XFA.XFAPageArea
O2S.Components.PDF4NET.Forms.XFA.XFAArea

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAExtendedContainer Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAExtendedContainer Class Members

XFAExtendedContainer Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAExtendedContainer Class

The following tables list the members exposed by XFAExtendedContainer.

Public Properties

 | Name | Description
Public Property | Areas | Gets the list of areas included in this container.
Public Property | Fields | Gets the list of fields included in this container.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container.
Top

See Also

Reference

XFAExtendedContainer Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAExtendedContainer Class Properties

XFAExtendedContainer Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAExtendedContainer Class

For a list of all members of this type, see XFAExtendedContainer members.

Public Properties

 | Name | Description
Public Property | Areas | Gets the list of areas included in this container.
Public Property | Fields | Gets the list of fields included in this container.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container.
Top

See Also

Reference

XFAExtendedContainer Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Areas Property

Areas Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAExtendedContainer Class : Areas Property

Gets the list of areas included in this container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Areas As XFAAreaCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAExtendedContainer
Dim value As XFAAreaCollection

value = instance.Areas
C#
public XFAAreaCollection Areas {get;}
Managed Extensions for C++
public: __property XFAAreaCollection* get_Areas();
C++/CLI
public:
property XFAAreaCollection^ Areas {
   XFAAreaCollection^ get();
}

Return Value

A XFAAreaCollection object specifying the list of areas included in this container.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAExtendedContainer Class
XFAExtendedContainer Members


Fields Property

Fields Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAExtendedContainer Class : Fields Property

Gets the list of fields included in this container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fields As XFAFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAExtendedContainer
Dim value As XFAFieldCollection

value = instance.Fields
C#
public XFAFieldCollection Fields {get;}
Managed Extensions for C++
public: __property XFAFieldCollection* get_Fields();
C++/CLI
public:
property XFAFieldCollection^ Fields {
   XFAFieldCollection^ get();
}

Return Value

A XFAFieldCollection object specifying the list of fields included in this container.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAExtendedContainer Class
XFAExtendedContainer Members


Subforms Property

Subforms Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAExtendedContainer Class : Subforms Property

Gets the list of subforms included in this container.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Subforms As XFASubformCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAExtendedContainer
Dim value As XFASubformCollection

value = instance.Subforms
C#
public XFASubformCollection Subforms {get;}
Managed Extensions for C++
public: __property XFASubformCollection* get_Subforms();
C++/CLI
public:
property XFASubformCollection^ Subforms {
   XFASubformCollection^ get();
}

Return Value

A XFASubformCollection object specifying the list of subforms included in this container.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAExtendedContainer Class
XFAExtendedContainer Members


XFAField Class

XFAField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAField Class

Defines a XFA field.

Syntax

Visual Basic (Declaration)
Public Class XFAField
   Inherits XFABasicContainer
Visual Basic (Usage) Copy Code
Dim instance As XFAField
C#
public class XFAField : XFABasicContainer
Managed Extensions for C++
public __gc class XFAField : public XFABasicContainer
C++/CLI
public ref class XFAField : public XFABasicContainer

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFATextEditField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonListField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonField
O2S.Components.PDF4NET.Forms.XFA.XFANumericEditField
O2S.Components.PDF4NET.Forms.XFA.XFAImageEditField
O2S.Components.PDF4NET.Forms.XFA.XFADateTimeEditField
O2S.Components.PDF4NET.Forms.XFA.XFAChoiceListField
O2S.Components.PDF4NET.Forms.XFA.XFAButtonField
O2S.Components.PDF4NET.Forms.XFA.XFABarcodeField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAField Class Members

XFAField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAField Class

The following tables list the members exposed by XFAField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content.
Public Property | BindRef | Gets the explicit data binding string.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field.
Public Property | ValueType | Gets the type of value stored in this field.
Public Property | Visibility | Gets the visibility of the field content.
Top

See Also

Reference

XFAField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAField Class Properties

XFAField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAField Class

For a list of all members of this type, see XFAField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content.
Public Property | BindRef | Gets the explicit data binding string.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field.
Public Property | ValueType | Gets the type of value stored in this field.
Public Property | Visibility | Gets the visibility of the field content.
Top

See Also

Reference

XFAField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Access Property

Access Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAField Class : Access Property

Gets or sets the access mode to field content.

Syntax

Visual Basic (Declaration)
Public Property Access As XFAContentAccess
Visual Basic (Usage) Copy Code
Dim instance As XFAField
Dim value As XFAContentAccess

instance.Access = value

value = instance.Access
C#
public XFAContentAccess Access {get; set;}
Managed Extensions for C++
public: __property XFAContentAccess get_Access();
public: __property void set_Access(
   XFAContentAccess value
);
C++/CLI
public:
property XFAContentAccess Access {
   XFAContentAccess get();
   void set (XFAContentAccess value);
}

Return Value

A XFAContentAccess enumeration member specifying the allowed access mode for field content.

Remarks

If this property is XFAContentAccess.Protected or XFAContentAccess.ReadOnly, the field value can not be changed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAField Class
XFAField Members


BindRef Property

BindRef Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAField Class : BindRef Property

Gets the explicit data binding string.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BindRef As String
Visual Basic (Usage) Copy Code
Dim instance As XFAField
Dim value As String

value = instance.BindRef
C#
public string BindRef {get;}
Managed Extensions for C++
public: __property string* get_BindRef();
C++/CLI
public:
property String^ BindRef {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAField Class
XFAField Members


Value Property

Value Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAField Class : Value Property

Gets or sets the value stored in this field.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As XFAField
Dim value As Object

instance.Value = value

value = instance.Value
C#
public object Value {get; set;}
Managed Extensions for C++
public: __property Object* get_Value();
public: __property void set_Value(
   Object* value
);
C++/CLI
public:
property Object^ Value {
   Object^ get();
   void set (Object^ value);
}

Return Value

An object that boxes actual value.

Exceptions

Exception | Description
ArgumentException | Thrown when the provided value is not supported by the actual field type.
ArgumentOutOfRangeException | The value does not exist in field's specific set of values.

Remarks

The values accepted by this property depend on the actual field type. If the actual field does not support the provided value, an exception is raised.
If the field Access is Protected or ReadOnly, the Value can not be changed.
Fields with a fixed range of values (checkboxes, radiobutton lists and choice fields) will throw an exception if the value does not exist in their set of values.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAField Class
XFAField Members


ValueType Property

ValueType Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAField Class : ValueType Property

Gets the type of value stored in this field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValueType As XFAContentType
Visual Basic (Usage) Copy Code
Dim instance As XFAField
Dim value As XFAContentType

value = instance.ValueType
C#
public XFAContentType ValueType {get;}
Managed Extensions for C++
public: __property XFAContentType get_ValueType();
C++/CLI
public:
property XFAContentType ValueType {
   XFAContentType get();
}

Return Value

A XFAContentType enumeration member specifying the type of the value stored in this field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAField Class
XFAField Members


Visibility Property

Visibility Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAField Class : Visibility Property

Gets the visibility of the field content.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visibility As XFAContentVisibility
Visual Basic (Usage) Copy Code
Dim instance As XFAField
Dim value As XFAContentVisibility

value = instance.Visibility
C#
public XFAContentVisibility Visibility {get;}
Managed Extensions for C++
public: __property XFAContentVisibility get_Visibility();
C++/CLI
public:
property XFAContentVisibility Visibility {
   XFAContentVisibility get();
}

Return Value

A XFAContentVisibility enumeration member specifying the visibility for field content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAField Class
XFAField Members


XFAFieldCollection Class

XFAFieldCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldCollection Class

Defines a collection of XFA fields.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class XFAFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldCollection
C#
[DefaultMemberAttribute("Item")]
public class XFAFieldCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class XFAFieldCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class XFAFieldCollection

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAFieldCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAFieldCollection Class Members

XFAFieldCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldCollection Class

The following tables list the members exposed by XFAFieldCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the field at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAFieldCollection Class Methods

XFAFieldCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldCollection Class

For a list of all members of this type, see XFAFieldCollection members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


GetEnumerator Method

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


MoveNext Method

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


Reset Method

Reset Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldCollection

instance.Reset()
C#
public void Reset()
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


XFAFieldCollection Class Properties

XFAFieldCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldCollection Class

For a list of all members of this type, see XFAFieldCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the field at the specified index (zero based index).
Top

See Also

Reference

XFAFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Count Property

Count Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : Count Property

Returns the number of items in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


Current Property

Current Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


Item Property

Item Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class : Item Property

Gets the field at the specified index (zero based index).

Overload List

Overload | Description
Item(Int32) | Gets the field at the specified index (zero based index).
Item(String) | Gets the field with the given name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members


Item(Int32) Property

Item(Int32) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class > Item Property : Item(Int32) Property

index
Gets the field at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldCollection
Dim index As Integer
Dim value As XFAField

value = instance.Item(index)
C#
public XFAField Item(
   int index
) {get;}
Managed Extensions for C++
public: __property XFAField* get_Item(
   int index
);
C++/CLI
public:
property XFAField^ Item {
   XFAField^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members
Overload List


Item(String) Property

Item(String) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldCollection Class > Item Property : Item(String) Property

name
Gets the field with the given name.

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldCollection
Dim name As String
Dim value As XFAField

value = instance.Item(name)
C#
public XFAField Item(
   string name
) {get;}
Managed Extensions for C++
public: __property XFAField* get_Item(
   string* name
);
C++/CLI
public:
property XFAField^ Item {
   XFAField^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldCollection Class
XFAFieldCollection Members
Overload List


XFAFieldImportError Class

XFAFieldImportError Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldImportError Class

Represents an error that happened during the import of a XML file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class XFAFieldImportError
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldImportError
C#
public class XFAFieldImportError
Managed Extensions for C++
public __gc class XFAFieldImportError
C++/CLI
public ref class XFAFieldImportError

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAFieldImportError

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldImportError Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAFieldImportError Class Members

XFAFieldImportError Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldImportError Class

The following tables list the members exposed by XFAFieldImportError.

Public Properties

 | Name | Description
Public Property | Exception | Gets the exception thrown by the field during the import.
Public Property | Field | Gets the field that generated the import error.
Top

See Also

Reference

XFAFieldImportError Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAFieldImportError Class Properties

XFAFieldImportError Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAFieldImportError Class

For a list of all members of this type, see XFAFieldImportError members.

Public Properties

 | Name | Description
Public Property | Exception | Gets the exception thrown by the field during the import.
Public Property | Field | Gets the field that generated the import error.
Top

See Also

Reference

XFAFieldImportError Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Exception Property

Exception Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldImportError Class : Exception Property

Gets the exception thrown by the field during the import.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldImportError
Dim value As Exception

value = instance.Exception
C#
public Exception Exception {get;}
Managed Extensions for C++
public: __property Exception* get_Exception();
C++/CLI
public:
property Exception^ Exception {
   Exception^ get();
}

Return Value

A Exception object with the details about the import error.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldImportError Class
XFAFieldImportError Members


Field Property

Field Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAFieldImportError Class : Field Property

Gets the field that generated the import error.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Field As XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFAFieldImportError
Dim value As XFAField

value = instance.Field
C#
public XFAField Field {get;}
Managed Extensions for C++
public: __property XFAField* get_Field();
C++/CLI
public:
property XFAField^ Field {
   XFAField^ get();
}

Return Value

A XFAField object representing the field that generated the error.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAFieldImportError Class
XFAFieldImportError Members


XFAForm Class

XFAForm Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAForm Class

Defines a document level XFA form.

Syntax

Visual Basic (Declaration)
Public Class XFAForm
   Inherits XFAElement
Visual Basic (Usage) Copy Code
Dim instance As XFAForm
C#
public class XFAForm : XFAElement
Managed Extensions for C++
public __gc class XFAForm : public XFAElement
C++/CLI
public ref class XFAForm : public XFAElement

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFAForm

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAForm Class Members

XFAForm Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAForm Class

The following tables list the members exposed by XFAForm.

Public Properties

 | Name | Description
Public Property | ForceRendering | Gets or sets a value indicating whether the XFA form should be regenerated when it is open for the first time.
Public Property | Subforms | Gets the list of subforms included in the form.
Top

Public Methods

 | Name | Description
Public Method | ExportData | Overloaded. Exports the form data to a file.
Public Method | ImportData | Overloaded. Imports form data from an external file.
Top

See Also

Reference

XFAForm Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAForm Class Methods

XFAForm Class Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAForm Class

For a list of all members of this type, see XFAForm members.

Public Methods

 | Name | Description
Public Method | ExportData | Overloaded. Exports the form data to a file.
Public Method | ImportData | Overloaded. Imports form data from an external file.
Top

See Also

Reference

XFAForm Class
O2S.Components.PDF4NET.Forms.XFA Namespace


ExportData Method

ExportData Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class : ExportData Method

Exports the form data to a file.

Overload List

Overload | Description
ExportData(String,XFADataFormat,PDFExportDataOptions) | Exports the form data to a file.
ExportData(Stream,XFADataFormat,PDFExportDataOptions) | Exports the form data to a stream.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Class
XFAForm Members


ExportData(String,XFADataFormat,PDFExportDataOptions) Method

ExportData(String,XFADataFormat,PDFExportDataOptions) Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class > ExportData Method : ExportData(String,XFADataFormat,PDFExportDataOptions) Method

fileName
The full path to the file where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
Exports the form data to a file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ExportData( _
   ByVal fileName As String, _
   ByVal format As XFADataFormat, _
   ByVal options As PDFExportDataOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As XFAForm
Dim fileName As String
Dim format As XFADataFormat
Dim options As PDFExportDataOptions

instance.ExportData(fileName, format, options)
C#
public void ExportData(
   string fileName,
   XFADataFormat format,
   PDFExportDataOptions options
)
Managed Extensions for C++
public: void ExportData(
   string* fileName,
   XFADataFormat format,
   PDFExportDataOptions options
)
C++/CLI
public:
void ExportData(
   String^ fileName,
   XFADataFormat format,
   PDFExportDataOptions options
)

Parameters

fileName
The full path to the file where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Class
XFAForm Members
Overload List


ExportData(Stream,XFADataFormat,PDFExportDataOptions) Method

ExportData(Stream,XFADataFormat,PDFExportDataOptions) Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class > ExportData Method : ExportData(Stream,XFADataFormat,PDFExportDataOptions) Method

stream
The stream where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.
Exports the form data to a stream.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ExportData( _
   ByVal stream As Stream, _
   ByVal format As XFADataFormat, _
   ByVal options As PDFExportDataOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As XFAForm
Dim stream As Stream
Dim format As XFADataFormat
Dim options As PDFExportDataOptions

instance.ExportData(stream, format, options)
C#
public void ExportData(
   Stream stream,
   XFADataFormat format,
   PDFExportDataOptions options
)
Managed Extensions for C++
public: void ExportData(
   Stream* stream,
   XFADataFormat format,
   PDFExportDataOptions options
)
C++/CLI
public:
void ExportData(
   Stream^ stream,
   XFADataFormat format,
   PDFExportDataOptions options
)

Parameters

stream
The stream where form data will be exported.
format
The format of exported data.
options
Options for specifying the type of data to be exported.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Class
XFAForm Members
Overload List


ImportData Method

ImportData Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class : ImportData Method

Imports form data from an external file.

Overload List

Overload | Description
ImportData(String,XFADataFormat) | Imports form data from an external file.
ImportData(Stream,XFADataFormat) | Imports form data from an external file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Class
XFAForm Members


ImportData(String,XFADataFormat) Method

ImportData(String,XFADataFormat) Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class > ImportData Method : ImportData(String,XFADataFormat) Method

fileName
The file from which to import form data.
dataFormat
The format of input file.
Imports form data from an external file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ImportData( _
   ByVal fileName As String, _
   ByVal dataFormat As XFADataFormat _
)
Visual Basic (Usage) Copy Code
Dim instance As XFAForm
Dim fileName As String
Dim dataFormat As XFADataFormat

instance.ImportData(fileName, dataFormat)
C#
public void ImportData(
   string fileName,
   XFADataFormat dataFormat
)
Managed Extensions for C++
public: void ImportData(
   string* fileName,
   XFADataFormat dataFormat
)
C++/CLI
public:
void ImportData(
   String^ fileName,
   XFADataFormat dataFormat
)

Parameters

fileName
The file from which to import form data.
dataFormat
The format of input file.

Exceptions

Exception | Description
PDFException | thrown when the input file can not be open or read.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Class
XFAForm Members
Overload List


ImportData(Stream,XFADataFormat) Method

ImportData(Stream,XFADataFormat) Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class > ImportData Method : ImportData(Stream,XFADataFormat) Method

stream
The stream from which to import form data.
dataFormat
The format of input stream.
Imports form data from an external file.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ImportData( _
   ByVal stream As Stream, _
   ByVal dataFormat As XFADataFormat _
)
Visual Basic (Usage) Copy Code
Dim instance As XFAForm
Dim stream As Stream
Dim dataFormat As XFADataFormat

instance.ImportData(stream, dataFormat)
C#
public void ImportData(
   Stream stream,
   XFADataFormat dataFormat
)
Managed Extensions for C++
public: void ImportData(
   Stream* stream,
   XFADataFormat dataFormat
)
C++/CLI
public:
void ImportData(
   Stream^ stream,
   XFADataFormat dataFormat
)

Parameters

stream
The stream from which to import form data.
dataFormat
The format of input stream.

Exceptions

Exception | Description
PDFException | Thrown when the input stream can not be read.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Class
XFAForm Members
Overload List


XFAForm Class Properties

XFAForm Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAForm Class

For a list of all members of this type, see XFAForm members.

Public Properties

 | Name | Description
Public Property | ForceRendering | Gets or sets a value indicating whether the XFA form should be regenerated when it is open for the first time.
Public Property | Subforms | Gets the list of subforms included in the form.
Top

See Also

Reference

XFAForm Class
O2S.Components.PDF4NET.Forms.XFA Namespace


ForceRendering Property

ForceRendering Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class : ForceRendering Property

Gets or sets a value indicating whether the XFA form should be regenerated when it is open for the first time.

Syntax

Visual Basic (Declaration)
Public Property ForceRendering As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFAForm
Dim value As Boolean

instance.ForceRendering = value

value = instance.ForceRendering
C#
public bool ForceRendering {get; set;}
Managed Extensions for C++
public: __property bool get_ForceRendering();
public: __property void set_ForceRendering(
   bool value
);
C++/CLI
public:
property bool ForceRendering {
   bool get();
   void set (bool value);
}

Return Value

True if the XFA form should be regenerated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Class
XFAForm Members


Subforms Property

Subforms Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAForm Class : Subforms Property

Gets the list of subforms included in the form.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Subforms As XFASubformCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAForm
Dim value As XFASubformCollection

value = instance.Subforms
C#
public XFASubformCollection Subforms {get;}
Managed Extensions for C++
public: __property XFASubformCollection* get_Subforms();
C++/CLI
public:
property XFASubformCollection^ Subforms {
   XFASubformCollection^ get();
}

Return Value

A XFASubformCollection object specifying the list of subforms included in this form.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAForm Class
XFAForm Members


XFAHttpSubmitButtonField Class

XFAHttpSubmitButtonField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAHttpSubmitButtonField Class

Defines a XFA button field that submits the form data to a server using HTTP protocol.

Syntax

Visual Basic (Declaration)
Public Class XFAHttpSubmitButtonField
   Inherits XFAButtonField
Visual Basic (Usage) Copy Code
Dim instance As XFAHttpSubmitButtonField
C#
public class XFAHttpSubmitButtonField : XFAButtonField
Managed Extensions for C++
public __gc class XFAHttpSubmitButtonField : public XFAButtonField
C++/CLI
public ref class XFAHttpSubmitButtonField : public XFAButtonField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFAButtonField
O2S.Components.PDF4NET.Forms.XFA.XFAHttpSubmitButtonField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAHttpSubmitButtonField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAHttpSubmitButtonField Class Members

XFAHttpSubmitButtonField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAHttpSubmitButtonField Class

The following tables list the members exposed by XFAHttpSubmitButtonField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Url | Gets or sets the Url where the form data is submitted.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAHttpSubmitButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAHttpSubmitButtonField Class Properties

XFAHttpSubmitButtonField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAHttpSubmitButtonField Class

For a list of all members of this type, see XFAHttpSubmitButtonField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Url | Gets or sets the Url where the form data is submitted.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAHttpSubmitButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Url Property

Url Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAHttpSubmitButtonField Class : Url Property

Gets or sets the Url where the form data is submitted.

Syntax

Visual Basic (Declaration)
Public Property Url As String
Visual Basic (Usage) Copy Code
Dim instance As XFAHttpSubmitButtonField
Dim value As String

instance.Url = value

value = instance.Url
C#
public string Url {get; set;}
Managed Extensions for C++
public: __property string* get_Url();
public: __property void set_Url(
   string* value
);
C++/CLI
public:
property String^ Url {
   String^ get();
   void set (String^ value);
}

Remarks

A string value specifying the HTTP Url where the form data is submitted when the button is clicked.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAHttpSubmitButtonField Class
XFAHttpSubmitButtonField Members


XFAImageEditField Class

XFAImageEditField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAImageEditField Class

Defines a XFA image edit field.

Syntax

Visual Basic (Declaration)
Public Class XFAImageEditField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFAImageEditField
C#
public class XFAImageEditField : XFAField
Managed Extensions for C++
public __gc class XFAImageEditField : public XFAField
C++/CLI
public ref class XFAImageEditField : public XFAField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFAImageEditField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAImageEditField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAImageEditField Class Members

XFAImageEditField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAImageEditField Class

The following tables list the members exposed by XFAImageEditField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ContentType | Gets or sets the image content type.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | ImageAspect | Gets the scaling mode for the image.
Public Property | ImageData | Gets or sets the image data to be loaded in this field.
Public Property | ImagePath | Gets or sets the path to the image to be loaded in this field.
Public Property | ImageStorageMode | Gets the mode the image is stored in this field.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAImageEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAImageEditField Class Properties

XFAImageEditField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAImageEditField Class

For a list of all members of this type, see XFAImageEditField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ContentType | Gets or sets the image content type.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | ImageAspect | Gets the scaling mode for the image.
Public Property | ImageData | Gets or sets the image data to be loaded in this field.
Public Property | ImagePath | Gets or sets the path to the image to be loaded in this field.
Public Property | ImageStorageMode | Gets the mode the image is stored in this field.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAImageEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


ContentType Property

ContentType Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAImageEditField Class : ContentType Property

Gets or sets the image content type.

Syntax

Visual Basic (Declaration)
Public Property ContentType As String
Visual Basic (Usage) Copy Code
Dim instance As XFAImageEditField
Dim value As String

instance.ContentType = value

value = instance.ContentType
C#
public string ContentType {get; set;}
Managed Extensions for C++
public: __property string* get_ContentType();
public: __property void set_ContentType(
   string* value
);
C++/CLI
public:
property String^ ContentType {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the image content type.

Remarks

This property is the MIME-type of the image stored in the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAImageEditField Class
XFAImageEditField Members


ImageAspect Property

ImageAspect Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAImageEditField Class : ImageAspect Property

Gets the scaling mode for the image.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ImageAspect As XFAImageAspect
Visual Basic (Usage) Copy Code
Dim instance As XFAImageEditField
Dim value As XFAImageAspect

value = instance.ImageAspect
C#
public XFAImageAspect ImageAspect {get;}
Managed Extensions for C++
public: __property XFAImageAspect get_ImageAspect();
C++/CLI
public:
property XFAImageAspect ImageAspect {
   XFAImageAspect get();
}

Return Value

A XFAImageAspect enumeration member specifying how the image is scaled when it is displayed in the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAImageEditField Class
XFAImageEditField Members


ImageData Property

ImageData Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAImageEditField Class : ImageData Property

Gets or sets the image data to be loaded in this field.

Syntax

Visual Basic (Declaration)
Public Property ImageData As Byte()
Visual Basic (Usage) Copy Code
Dim instance As XFAImageEditField
Dim value() As Byte

instance.ImageData = value

value = instance.ImageData
C#
public byte[] ImageData {get; set;}
Managed Extensions for C++
public: __property byte[]* get_ImageData();
public: __property void set_ImageData(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ ImageData {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array specifying the image data to be loaded in this field.

Remarks

Only one of ImagePath or ImageData properties can be set. If this property is set, then ImagePath property is set to null (Nothing in VB.NET).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAImageEditField Class
XFAImageEditField Members


ImagePath Property

ImagePath Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAImageEditField Class : ImagePath Property

Gets or sets the path to the image to be loaded in this field.

Syntax

Visual Basic (Declaration)
Public Property ImagePath As String
Visual Basic (Usage) Copy Code
Dim instance As XFAImageEditField
Dim value As String

instance.ImagePath = value

value = instance.ImagePath
C#
public string ImagePath {get; set;}
Managed Extensions for C++
public: __property string* get_ImagePath();
public: __property void set_ImagePath(
   string* value
);
C++/CLI
public:
property String^ ImagePath {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the path to the image to be loaded in this field.

Remarks

Only one of ImagePath or ImageData properties can be set. If this property is set, then ImageData property is set to null (Nothing in VB.NET).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAImageEditField Class
XFAImageEditField Members


ImageStorageMode Property

ImageStorageMode Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAImageEditField Class : ImageStorageMode Property

Gets the mode the image is stored in this field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ImageStorageMode As XFAImageStorageMode
Visual Basic (Usage) Copy Code
Dim instance As XFAImageEditField
Dim value As XFAImageStorageMode

value = instance.ImageStorageMode
C#
public XFAImageStorageMode ImageStorageMode {get;}
Managed Extensions for C++
public: __property XFAImageStorageMode get_ImageStorageMode();
C++/CLI
public:
property XFAImageStorageMode ImageStorageMode {
   XFAImageStorageMode get();
}

Return Value

A ImageStorageMode enumeration member specifying the mode the image is stored in this field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAImageEditField Class
XFAImageEditField Members


XFAListItem Class

XFAListItem Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItem Class

Defines an item in a choice list.

Syntax

Visual Basic (Declaration)
Public Class XFAListItem
Visual Basic (Usage) Copy Code
Dim instance As XFAListItem
C#
public class XFAListItem
Managed Extensions for C++
public __gc class XFAListItem
C++/CLI
public ref class XFAListItem

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAListItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItem Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAListItem Class Members

XFAListItem Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItem Class

The following tables list the members exposed by XFAListItem.

Public Constructors

 | Name | Description
Public Constructor | XFAListItem Constructor | Initializes a new XFAListItem object.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the list item.
Public Property | Value | Gets or sets the value of the list item.
Top

See Also

Reference

XFAListItem Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAListItem Constructor

XFAListItem Constructor
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItem Class : XFAListItem Constructor

itemName
The item name, it is displayed in the list.
itemValue
The item value, it is exported when form content is exported.
Initializes a new XFAListItem object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal itemName As String, _
   ByVal itemValue As String _
)
Visual Basic (Usage) Copy Code
Dim itemName As String
Dim itemValue As String

Dim instance As XFAListItem(itemName, itemValue)
C#
public XFAListItem(
   string itemName,
   string itemValue
)
Managed Extensions for C++
public: XFAListItem(
   string* itemName,
   string* itemValue
)
C++/CLI
public:
XFAListItem(
   String^ itemName,
   String^ itemValue
)

Parameters

itemName
The item name, it is displayed in the list.
itemValue
The item value, it is exported when form content is exported.

Exceptions

Exception | Description
ArgumentNullException | Thrown when the item value is null or empty.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItem Class
XFAListItem Members


XFAListItem Class Properties

XFAListItem Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItem Class

For a list of all members of this type, see XFAListItem members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the list item.
Public Property | Value | Gets or sets the value of the list item.
Top

See Also

Reference

XFAListItem Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Name Property

Name Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItem Class : Name Property

Gets or sets the name of the list item.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As XFAListItem
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing the name of the list item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItem Class
XFAListItem Members


Value Property

Value Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAListItem Class : Value Property

Gets or sets the value of the list item.

Syntax

Visual Basic (Declaration)
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As XFAListItem
Dim value As String

instance.Value = value

value = instance.Value
C#
public string Value {get; set;}
Managed Extensions for C++
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
C++/CLI
public:
property String^ Value {
   String^ get();
   void set (String^ value);
}

Return Value

A string value representing the value of the list item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItem Class
XFAListItem Members


XFAListItemCollection Class

XFAListItemCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItemCollection Class

Defines a collection of fields in a FDF document.

Object Model

Syntax

Visual Basic (Declaration)
Public Class XFAListItemCollection
   Inherits PDFCollection(Of XFAListItem, XFAChoiceListField)
Visual Basic (Usage) Copy Code
Dim instance As XFAListItemCollection
C#
public class XFAListItemCollection : PDFCollection<XFAListItem, XFAChoiceListField>
Managed Extensions for C++
public __gc class XFAListItemCollection : public PDFCollection<XFAListItem, XFAChoiceListField>
C++/CLI
public ref class XFAListItemCollection : public PDFCollection<XFAListItem, XFAChoiceListField>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<XFAListItem>
O2S.Components.PDF4NET.PDFCollection<XFAListItem, XFAChoiceListField>
O2S.Components.PDF4NET.Forms.XFA.XFAListItemCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAListItemCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAListItemCollection Class Members

XFAListItemCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItemCollection Class

The following tables list the members exposed by XFAListItemCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Top

See Also

Reference

XFAListItemCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFANumericEditField Class

XFANumericEditField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFANumericEditField Class

Defines a XFA numeric edit field.

Syntax

Visual Basic (Declaration)
Public Class XFANumericEditField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFANumericEditField
C#
public class XFANumericEditField : XFAField
Managed Extensions for C++
public __gc class XFANumericEditField : public XFAField
C++/CLI
public ref class XFANumericEditField : public XFAField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFANumericEditField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFANumericEditField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFANumericEditField Class Members

XFANumericEditField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFANumericEditField Class

The following tables list the members exposed by XFANumericEditField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | DecimalValue | Gets or sets the decimal number in this numeric edit field.
Public Property | FloatValue | Gets or sets the float number in this numeric edit field.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | IntValue | Gets or sets the integer number in this numeric edit field.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFANumericEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFANumericEditField Class Properties

XFANumericEditField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFANumericEditField Class

For a list of all members of this type, see XFANumericEditField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | DecimalValue | Gets or sets the decimal number in this numeric edit field.
Public Property | FloatValue | Gets or sets the float number in this numeric edit field.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | IntValue | Gets or sets the integer number in this numeric edit field.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFANumericEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


DecimalValue Property

DecimalValue Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFANumericEditField Class : DecimalValue Property

Gets or sets the decimal number in this numeric edit field.

Syntax

Visual Basic (Declaration)
Public Property DecimalValue As Decimal
Visual Basic (Usage) Copy Code
Dim instance As XFANumericEditField
Dim value As Decimal

instance.DecimalValue = value

value = instance.DecimalValue
C#
public decimal DecimalValue {get; set;}
Managed Extensions for C++
public: __property decimal get_DecimalValue();
public: __property void set_DecimalValue(
   decimal value
);
C++/CLI
public:
property decimal DecimalValue {
   decimal get();
   void set (decimal value);
}

Return Value

A decimal value specifying the number displayed in the numeric edit field.

Remarks

This property returns 0 even if the field does not contain any value. In order to find out if the field is empty compare the XFAField.Value property to null (Nothing in VB.NET).
Set the XFAField.Value property to null (Nothing in VB.NET) in order to clear the field value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFANumericEditField Class
XFANumericEditField Members


FloatValue Property

FloatValue Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFANumericEditField Class : FloatValue Property

Gets or sets the float number in this numeric edit field.

Syntax

Visual Basic (Declaration)
Public Property FloatValue As Double
Visual Basic (Usage) Copy Code
Dim instance As XFANumericEditField
Dim value As Double

instance.FloatValue = value

value = instance.FloatValue
C#
public double FloatValue {get; set;}
Managed Extensions for C++
public: __property double get_FloatValue();
public: __property void set_FloatValue(
   double value
);
C++/CLI
public:
property double FloatValue {
   double get();
   void set (double value);
}

Return Value

A double value specifying the number displayed in the numeric edit field.

Remarks

This property returns 0 even if the field does not contain any value. In order to find out if the field is empty compare the XFAField.Value property to null (Nothing in VB.NET).
Set the XFAField.Value property to null (Nothing in VB.NET) in order to clear the field value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFANumericEditField Class
XFANumericEditField Members


IntValue Property

IntValue Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFANumericEditField Class : IntValue Property

Gets or sets the integer number in this numeric edit field.

Syntax

Visual Basic (Declaration)
Public Property IntValue As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFANumericEditField
Dim value As Integer

instance.IntValue = value

value = instance.IntValue
C#
public int IntValue {get; set;}
Managed Extensions for C++
public: __property int get_IntValue();
public: __property void set_IntValue(
   int value
);
C++/CLI
public:
property int IntValue {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number displayed in the numeric edit field.

Remarks

This property returns 0 even if the field does not contain any value. In order to find out if the field is empty compare the XFAField.Value property to null (Nothing in VB.NET).
Set the XFAField.Value property to null (Nothing in VB.NET) in order to clear the field value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFANumericEditField Class
XFANumericEditField Members


XFAPageArea Class

XFAPageArea Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageArea Class

Defines a XFA page area.

Syntax

Visual Basic (Declaration)
Public Class XFAPageArea
   Inherits XFAExtendedContainer
Visual Basic (Usage) Copy Code
Dim instance As XFAPageArea
C#
public class XFAPageArea : XFAExtendedContainer
Managed Extensions for C++
public __gc class XFAPageArea : public XFAExtendedContainer
C++/CLI
public ref class XFAPageArea : public XFAExtendedContainer

Remarks

A XFA page area is an element that describes a rendering surface.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer
O2S.Components.PDF4NET.Forms.XFA.XFAPageArea

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageArea Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAPageArea Class Members

XFAPageArea Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageArea Class

The following tables list the members exposed by XFAPageArea.

Public Properties

 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from XFAExtendedContainer)
Top

See Also

Reference

XFAPageArea Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAPageAreaCollection Class

XFAPageAreaCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageAreaCollection Class

Defines a collection of XFA page areas.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class XFAPageAreaCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAPageAreaCollection
C#
[DefaultMemberAttribute("Item")]
public class XFAPageAreaCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class XFAPageAreaCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class XFAPageAreaCollection

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAPageAreaCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAPageAreaCollection Class Members

XFAPageAreaCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageAreaCollection Class

The following tables list the members exposed by XFAPageAreaCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the page area at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAPageAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAPageAreaCollection Class Methods

XFAPageAreaCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageAreaCollection Class

For a list of all members of this type, see XFAPageAreaCollection members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAPageAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


GetEnumerator Method

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As XFAPageAreaCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


MoveNext Method

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFAPageAreaCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


Reset Method

Reset Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As XFAPageAreaCollection

instance.Reset()
C#
public void Reset()
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


XFAPageAreaCollection Class Properties

XFAPageAreaCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageAreaCollection Class

For a list of all members of this type, see XFAPageAreaCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the page area at the specified index (zero based index).
Top

See Also

Reference

XFAPageAreaCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Count Property

Count Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : Count Property

Returns the number of items in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFAPageAreaCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


Current Property

Current Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As XFAPageAreaCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


Item Property

Item Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class : Item Property

Gets the page area at the specified index (zero based index).

Overload List

Overload | Description
Item(Int32) | Gets the page area at the specified index (zero based index).
Item(String) | Gets the page area with the given name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members


Item(Int32) Property

Item(Int32) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class > Item Property : Item(Int32) Property

index
Gets the page area at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As XFAPageArea
Visual Basic (Usage) Copy Code
Dim instance As XFAPageAreaCollection
Dim index As Integer
Dim value As XFAPageArea

value = instance.Item(index)
C#
public XFAPageArea Item(
   int index
) {get;}
Managed Extensions for C++
public: __property XFAPageArea* get_Item(
   int index
);
C++/CLI
public:
property XFAPageArea^ Item {
   XFAPageArea^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members
Overload List


Item(String) Property

Item(String) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageAreaCollection Class > Item Property : Item(String) Property

name
Gets the page area with the given name.

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As XFAPageArea
Visual Basic (Usage) Copy Code
Dim instance As XFAPageAreaCollection
Dim name As String
Dim value As XFAPageArea

value = instance.Item(name)
C#
public XFAPageArea Item(
   string name
) {get;}
Managed Extensions for C++
public: __property XFAPageArea* get_Item(
   string* name
);
C++/CLI
public:
property XFAPageArea^ Item {
   XFAPageArea^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageAreaCollection Class
XFAPageAreaCollection Members
Overload List


XFAPageSet Class

XFAPageSet Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSet Class

Defines a XFA page set.

Syntax

Visual Basic (Declaration)
Public Class XFAPageSet
   Inherits XFABasicContainer
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSet
C#
public class XFAPageSet : XFABasicContainer
Managed Extensions for C++
public __gc class XFAPageSet : public XFABasicContainer
C++/CLI
public ref class XFAPageSet : public XFABasicContainer

Remarks

A page set describes a set of related page areas.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAPageSet

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSet Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAPageSet Class Members

XFAPageSet Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSet Class

The following tables list the members exposed by XFAPageSet.

Public Properties

 | Name | Description
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | PageAreas | Gets the list of page areas included in this page set.
Public Property | PageSets | Gets the list of page sets included in this page set.
Top

See Also

Reference

XFAPageSet Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAPageSet Class Properties

XFAPageSet Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSet Class

For a list of all members of this type, see XFAPageSet members.

Public Properties

 | Name | Description
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | PageAreas | Gets the list of page areas included in this page set.
Public Property | PageSets | Gets the list of page sets included in this page set.
Top

See Also

Reference

XFAPageSet Class
O2S.Components.PDF4NET.Forms.XFA Namespace


PageAreas Property

PageAreas Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSet Class : PageAreas Property

Gets the list of page areas included in this page set.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageAreas As XFAPageAreaCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSet
Dim value As XFAPageAreaCollection

value = instance.PageAreas
C#
public XFAPageAreaCollection PageAreas {get;}
Managed Extensions for C++
public: __property XFAPageAreaCollection* get_PageAreas();
C++/CLI
public:
property XFAPageAreaCollection^ PageAreas {
   XFAPageAreaCollection^ get();
}

Return Value

A XFAPageAreaCollection object specifying the list of areas included in this container.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSet Class
XFAPageSet Members


PageSets Property

PageSets Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSet Class : PageSets Property

Gets the list of page sets included in this page set.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageSets As XFAPageSetCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSet
Dim value As XFAPageSetCollection

value = instance.PageSets
C#
public XFAPageSetCollection PageSets {get;}
Managed Extensions for C++
public: __property XFAPageSetCollection* get_PageSets();
C++/CLI
public:
property XFAPageSetCollection^ PageSets {
   XFAPageSetCollection^ get();
}

Return Value

A XFAPageSetCollection object specifying the list of page sets included in this page set.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSet Class
XFAPageSet Members


XFAPageSetCollection Class

XFAPageSetCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSetCollection Class

Defines a collection of XFA page sets.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class XFAPageSetCollection
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSetCollection
C#
[DefaultMemberAttribute("Item")]
public class XFAPageSetCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class XFAPageSetCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class XFAPageSetCollection

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAPageSetCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAPageSetCollection Class Members

XFAPageSetCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSetCollection Class

The following tables list the members exposed by XFAPageSetCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the page set at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAPageSetCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAPageSetCollection Class Methods

XFAPageSetCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSetCollection Class

For a list of all members of this type, see XFAPageSetCollection members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFAPageSetCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


GetEnumerator Method

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSetCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


MoveNext Method

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSetCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


Reset Method

Reset Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSetCollection

instance.Reset()
C#
public void Reset()
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


XFAPageSetCollection Class Properties

XFAPageSetCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageSetCollection Class

For a list of all members of this type, see XFAPageSetCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the page set at the specified index (zero based index).
Top

See Also

Reference

XFAPageSetCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Count Property

Count Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : Count Property

Returns the number of items in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSetCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


Current Property

Current Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSetCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


Item Property

Item Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class : Item Property

Gets the page set at the specified index (zero based index).

Overload List

Overload | Description
Item(Int32) | Gets the page set at the specified index (zero based index).
Item(String) | Gets the page set with the given name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members


Item(Int32) Property

Item(Int32) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class > Item Property : Item(Int32) Property

index
Gets the page set at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As XFAPageSet
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSetCollection
Dim index As Integer
Dim value As XFAPageSet

value = instance.Item(index)
C#
public XFAPageSet Item(
   int index
) {get;}
Managed Extensions for C++
public: __property XFAPageSet* get_Item(
   int index
);
C++/CLI
public:
property XFAPageSet^ Item {
   XFAPageSet^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members
Overload List


Item(String) Property

Item(String) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPageSetCollection Class > Item Property : Item(String) Property

name
Gets the page set with the given name.

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As XFAPageSet
Visual Basic (Usage) Copy Code
Dim instance As XFAPageSetCollection
Dim name As String
Dim value As XFAPageSet

value = instance.Item(name)
C#
public XFAPageSet Item(
   string name
) {get;}
Managed Extensions for C++
public: __property XFAPageSet* get_Item(
   string* name
);
C++/CLI
public:
property XFAPageSet^ Item {
   XFAPageSet^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPageSetCollection Class
XFAPageSetCollection Members
Overload List


XFAPasswordEditField Class

XFAPasswordEditField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPasswordEditField Class

Defines a XFA password edit field.

Syntax

Visual Basic (Declaration)
Public Class XFAPasswordEditField
   Inherits XFATextEditField
Visual Basic (Usage) Copy Code
Dim instance As XFAPasswordEditField
C#
public class XFAPasswordEditField : XFATextEditField
Managed Extensions for C++
public __gc class XFAPasswordEditField : public XFATextEditField
C++/CLI
public ref class XFAPasswordEditField : public XFATextEditField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFATextEditField
O2S.Components.PDF4NET.Forms.XFA.XFAPasswordEditField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPasswordEditField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAPasswordEditField Class Members

XFAPasswordEditField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPasswordEditField Class

The following tables list the members exposed by XFAPasswordEditField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | MaxLen | Gets or sets the maximum number of characters that can be entered in the text edit field. (Inherited from XFATextEditField)
Public Property | Multiline | Gets a value indicating whether the field is multiline. (Inherited from XFATextEditField)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | PasswordChar | Gets the character used to mask the user input that is entered in the field.
Public Property | Text | Gets or sets the text in this text edit field. (Inherited from XFATextEditField)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAPasswordEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAPasswordEditField Class Properties

XFAPasswordEditField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPasswordEditField Class

For a list of all members of this type, see XFAPasswordEditField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | MaxLen | Gets or sets the maximum number of characters that can be entered in the text edit field. (Inherited from XFATextEditField)
Public Property | Multiline | Gets a value indicating whether the field is multiline. (Inherited from XFATextEditField)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | PasswordChar | Gets the character used to mask the user input that is entered in the field.
Public Property | Text | Gets or sets the text in this text edit field. (Inherited from XFATextEditField)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAPasswordEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


PasswordChar Property

PasswordChar Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFAPasswordEditField Class : PasswordChar Property

Gets the character used to mask the user input that is entered in the field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PasswordChar As Char
Visual Basic (Usage) Copy Code
Dim instance As XFAPasswordEditField
Dim value As Char

value = instance.PasswordChar
C#
public char PasswordChar {get;}
Managed Extensions for C++
public: __property char get_PasswordChar();
C++/CLI
public:
property char PasswordChar {
   char get();
}

Return Value

A char value specifying the character used to mask the user input that is entered in the field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFAPasswordEditField Class
XFAPasswordEditField Members


XFARadioButtonField Class

XFARadioButtonField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonField Class

Defines a XFA radio button field.

Syntax

Visual Basic (Declaration)
Public Class XFARadioButtonField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonField
C#
public class XFARadioButtonField : XFAField
Managed Extensions for C++
public __gc class XFARadioButtonField : public XFAField
C++/CLI
public ref class XFARadioButtonField : public XFAField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonField
O2S.Components.PDF4NET.Forms.XFA.XFACheckButtonField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFARadioButtonField Class Members

XFARadioButtonField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonField Class

The following tables list the members exposed by XFARadioButtonField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | CheckedState | Gets or sets the checked state of the field.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFARadioButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFARadioButtonField Class Properties

XFARadioButtonField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonField Class

For a list of all members of this type, see XFARadioButtonField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | CheckedState | Gets or sets the checked state of the field.
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFARadioButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


CheckedState Property

CheckedState Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonField Class : CheckedState Property

Gets or sets the checked state of the field.

Syntax

Visual Basic (Declaration)
Public Property CheckedState As XFACheckButtonState
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonField
Dim value As XFACheckButtonState

instance.CheckedState = value

value = instance.CheckedState
C#
public XFACheckButtonState CheckedState {get; set;}
Managed Extensions for C++
public: __property XFACheckButtonState get_CheckedState();
public: __property void set_CheckedState(
   XFACheckButtonState value
);
C++/CLI
public:
property XFACheckButtonState CheckedState {
   XFACheckButtonState get();
   void set (XFACheckButtonState value);
}

Return Value

A XFACheckButtonState enumeration member specifying the checked state of the field.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when trying to set Neutral state on a radio button or on a check button that does not support it.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonField Class
XFARadioButtonField Members


XFARadioButtonFieldCollection Class

XFARadioButtonFieldCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonFieldCollection Class

Defines a collection of exclusive radio buttons.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class XFARadioButtonFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonFieldCollection
C#
[DefaultMemberAttribute("Item")]
public class XFARadioButtonFieldCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class XFARadioButtonFieldCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class XFARadioButtonFieldCollection

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonFieldCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonFieldCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFARadioButtonFieldCollection Class Members

XFARadioButtonFieldCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonFieldCollection Class

The following tables list the members exposed by XFARadioButtonFieldCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the radio button at the specified index.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFARadioButtonFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFARadioButtonFieldCollection Class Methods

XFARadioButtonFieldCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonFieldCollection Class

For a list of all members of this type, see XFARadioButtonFieldCollection members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFARadioButtonFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


GetEnumerator Method

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonFieldCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


MoveNext Method

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonFieldCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


Reset Method

Reset Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonFieldCollection

instance.Reset()
C#
public void Reset()
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


XFARadioButtonFieldCollection Class Properties

XFARadioButtonFieldCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonFieldCollection Class

For a list of all members of this type, see XFARadioButtonFieldCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Gets the radio button at the specified index.
Top

See Also

Reference

XFARadioButtonFieldCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Count Property

Count Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : Count Property

Returns the number of items in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonFieldCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


Current Property

Current Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonFieldCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


Item Property

Item Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonFieldCollection Class : Item Property

index
Gets the radio button at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As XFARadioButtonField
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonFieldCollection
Dim index As Integer
Dim value As XFARadioButtonField

value = instance.Item(index)
C#
public XFARadioButtonField this[
   int index
]; {get;}
Managed Extensions for C++
public: __property XFARadioButtonField* get_Item(
   int index
);
C++/CLI
public:
property XFARadioButtonField^ default [int] {
   XFARadioButtonField^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is lower than 0 or greater than or equal to Count.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonFieldCollection Class
XFARadioButtonFieldCollection Members


XFARadioButtonListField Class

XFARadioButtonListField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonListField Class

Defines a XFA radio buttons list field.

Object Model

Syntax

Visual Basic (Declaration)
Public Class XFARadioButtonListField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonListField
C#
public class XFARadioButtonListField : XFAField
Managed Extensions for C++
public __gc class XFARadioButtonListField : public XFAField
C++/CLI
public ref class XFARadioButtonListField : public XFAField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFARadioButtonListField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonListField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFARadioButtonListField Class Members

XFARadioButtonListField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonListField Class

The following tables list the members exposed by XFARadioButtonListField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Items | Gets the list of radio buttons included in this list.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | SelectedIndex | Gets or sets the index of the checked radio button in the list.
Public Property | SelectedItem | Gets or sets the selected radio button in the list.
Public Property | SelectedValue | Gets or sets the selected radio button based on radio button's value.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFARadioButtonListField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFARadioButtonListField Class Properties

XFARadioButtonListField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFARadioButtonListField Class

For a list of all members of this type, see XFARadioButtonListField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Items | Gets the list of radio buttons included in this list.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | SelectedIndex | Gets or sets the index of the checked radio button in the list.
Public Property | SelectedItem | Gets or sets the selected radio button in the list.
Public Property | SelectedValue | Gets or sets the selected radio button based on radio button's value.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFARadioButtonListField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Items Property

Items Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonListField Class : Items Property

Gets the list of radio buttons included in this list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As XFARadioButtonFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonListField
Dim value As XFARadioButtonFieldCollection

value = instance.Items
C#
public XFARadioButtonFieldCollection Items {get;}
Managed Extensions for C++
public: __property XFARadioButtonFieldCollection* get_Items();
C++/CLI
public:
property XFARadioButtonFieldCollection^ Items {
   XFARadioButtonFieldCollection^ get();
}

Return Value

A XFARadioButtonFieldCollection object specifying the list of radio buttons in this list.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonListField Class
XFARadioButtonListField Members


SelectedIndex Property

SelectedIndex Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonListField Class : SelectedIndex Property

Gets or sets the index of the checked radio button in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonListField
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
public int SelectedIndex {get; set;}
Managed Extensions for C++
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
C++/CLI
public:
property int SelectedIndex {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the checked radio button in the list.

Remarks

-1 means that no radio button is checked.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonListField Class
XFARadioButtonListField Members


SelectedItem Property

SelectedItem Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonListField Class : SelectedItem Property

Gets or sets the selected radio button in the list.

Syntax

Visual Basic (Declaration)
Public Property SelectedItem As XFARadioButtonField
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonListField
Dim value As XFARadioButtonField

instance.SelectedItem = value

value = instance.SelectedItem
C#
public XFARadioButtonField SelectedItem {get; set;}
Managed Extensions for C++
public: __property XFARadioButtonField* get_SelectedItem();
public: __property void set_SelectedItem(
   XFARadioButtonField* value
);
C++/CLI
public:
property XFARadioButtonField^ SelectedItem {
   XFARadioButtonField^ get();
   void set (XFARadioButtonField^ value);
}

Return Value

A XFARadioButtonField object specifying the selected radio button.

Remarks

null (Nothing in VB.NET) means that no radio button is selected.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonListField Class
XFARadioButtonListField Members


SelectedValue Property

SelectedValue Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFARadioButtonListField Class : SelectedValue Property

Gets or sets the selected radio button based on radio button's value.

Syntax

Visual Basic (Declaration)
Public Property SelectedValue As String
Visual Basic (Usage) Copy Code
Dim instance As XFARadioButtonListField
Dim value As String

instance.SelectedValue = value

value = instance.SelectedValue
C#
public string SelectedValue {get; set;}
Managed Extensions for C++
public: __property string* get_SelectedValue();
public: __property void set_SelectedValue(
   string* value
);
C++/CLI
public:
property String^ SelectedValue {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the value of the selected item.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value does not exist in field's set of values.

Remarks

When setting the selected value, if the value does not exist in the list, an exception is thrown.
If the value to select is null (Nothing in VB.NET), then the selection is reset and SelectedIndex property becomes -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFARadioButtonListField Class
XFARadioButtonListField Members


XFASubform Class

XFASubform Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubform Class

Defines a XFA subform.

Syntax

Visual Basic (Declaration)
Public Class XFASubform
   Inherits XFAExtendedContainer
Visual Basic (Usage) Copy Code
Dim instance As XFASubform
C#
public class XFASubform : XFAExtendedContainer
Managed Extensions for C++
public __gc class XFASubform : public XFAExtendedContainer
C++/CLI
public ref class XFASubform : public XFAExtendedContainer

Remarks

A XFA subform is used to group in a logical manner the elements in a XFA form. A XFA subform can be included in another subform and also it ca include other subforms.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAExtendedContainer
O2S.Components.PDF4NET.Forms.XFA.XFASubform

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubform Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFASubform Class Members

XFASubform Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubform Class

The following tables list the members exposed by XFASubform.

Public Properties

 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | PageSets | Gets the list of page sets included in this subform.
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from XFAExtendedContainer)
Public Property | Visibility | Gets the visibility of the subform content.
Top

See Also

Reference

XFASubform Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFASubform Class Properties

XFASubform Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubform Class

For a list of all members of this type, see XFASubform members.

Public Properties

 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | PageSets | Gets the list of page sets included in this subform.
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from XFAExtendedContainer)
Public Property | Visibility | Gets the visibility of the subform content.
Top

See Also

Reference

XFASubform Class
O2S.Components.PDF4NET.Forms.XFA Namespace


PageSets Property

PageSets Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubform Class : PageSets Property

Gets the list of page sets included in this subform.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageSets As XFAPageSetCollection
Visual Basic (Usage) Copy Code
Dim instance As XFASubform
Dim value As XFAPageSetCollection

value = instance.PageSets
C#
public XFAPageSetCollection PageSets {get;}
Managed Extensions for C++
public: __property XFAPageSetCollection* get_PageSets();
C++/CLI
public:
property XFAPageSetCollection^ PageSets {
   XFAPageSetCollection^ get();
}

Return Value

A XFAPageSetCollection object specifying the list of page sets included in this subform.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubform Class
XFASubform Members


Visibility Property

Visibility Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubform Class : Visibility Property

Gets the visibility of the subform content.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visibility As XFAContentVisibility
Visual Basic (Usage) Copy Code
Dim instance As XFASubform
Dim value As XFAContentVisibility

value = instance.Visibility
C#
public XFAContentVisibility Visibility {get;}
Managed Extensions for C++
public: __property XFAContentVisibility get_Visibility();
C++/CLI
public:
property XFAContentVisibility Visibility {
   XFAContentVisibility get();
}

Return Value

A XFAContentVisibility enumeration member specifying the visibility for subform content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubform Class
XFASubform Members


XFASubformCollection Class

XFASubformCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubformCollection Class

Defines a collection of XFA subforms.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class XFASubformCollection
Visual Basic (Usage) Copy Code
Dim instance As XFASubformCollection
C#
[DefaultMemberAttribute("Item")]
public class XFASubformCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class XFASubformCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class XFASubformCollection

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFASubformCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFASubformCollection Class Members

XFASubformCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubformCollection Class

The following tables list the members exposed by XFASubformCollection.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the subform at the specified index (zero based index).
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFASubformCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFASubformCollection Class Methods

XFASubformCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubformCollection Class

For a list of all members of this type, see XFASubformCollection members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that can iterate through a collection.
Public Method | MoveNext | Advances the enumerator to the next element of the collection.
Public Method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top

See Also

Reference

XFASubformCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


GetEnumerator Method

GetEnumerator Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As XFASubformCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


MoveNext Method

MoveNext Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : MoveNext Method

Advances the enumerator to the next element of the collection.

Syntax

Visual Basic (Declaration)
Public Function MoveNext() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFASubformCollection
Dim value As Boolean

value = instance.MoveNext()
C#
public bool MoveNext()
Managed Extensions for C++
public: bool MoveNext();
C++/CLI
public:
bool MoveNext();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


Reset Method

Reset Method
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As XFASubformCollection

instance.Reset()
C#
public void Reset()
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


XFASubformCollection Class Properties

XFASubformCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFASubformCollection Class

For a list of all members of this type, see XFASubformCollection members.

Public Properties

 | Name | Description
Public Property | Count | Returns the number of items in the collection
Public Property | Current | Gets the current element in the collection.
Public Property | Item | Overloaded. Gets the subform at the specified index (zero based index).
Top

See Also

Reference

XFASubformCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


Count Property

Count Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : Count Property

Returns the number of items in the collection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFASubformCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


Current Property

Current Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : Current Property

Gets the current element in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As XFASubformCollection
Dim value As Object

value = instance.Current
C#
public object Current {get;}
Managed Extensions for C++
public: __property Object* get_Current();
C++/CLI
public:
property Object^ Current {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


Item Property

Item Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class : Item Property

Gets the subform at the specified index (zero based index).

Overload List

Overload | Description
Item(Int32) | Gets the subform at the specified index (zero based index).
Item(String) | Gets the subform with the given name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members


Item(Int32) Property

Item(Int32) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class > Item Property : Item(Int32) Property

index
Gets the subform at the specified index (zero based index).

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal index As Integer _
) As XFASubform
Visual Basic (Usage) Copy Code
Dim instance As XFASubformCollection
Dim index As Integer
Dim value As XFASubform

value = instance.Item(index)
C#
public XFASubform Item(
   int index
) {get;}
Managed Extensions for C++
public: __property XFASubform* get_Item(
   int index
);
C++/CLI
public:
property XFASubform^ Item {
   XFASubform^ get(int index);
}

Parameters

index

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when index is less than 0 or greater than number of items in the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members
Overload List


Item(String) Property

Item(String) Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFASubformCollection Class > Item Property : Item(String) Property

name
Gets the subform with the given name.

Syntax

Visual Basic (Declaration)
Overloads Public ReadOnly Property Item( _
   ByVal name As String _
) As XFASubform
Visual Basic (Usage) Copy Code
Dim instance As XFASubformCollection
Dim name As String
Dim value As XFASubform

value = instance.Item(name)
C#
public XFASubform Item(
   string name
) {get;}
Managed Extensions for C++
public: __property XFASubform* get_Item(
   string* name
);
C++/CLI
public:
property XFASubform^ Item {
   XFASubform^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFASubformCollection Class
XFASubformCollection Members
Overload List


XFATextEditField Class

XFATextEditField Class
See Also Members
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFATextEditField Class

Defines a XFA text edit field.

Syntax

Visual Basic (Declaration)
Public Class XFATextEditField
   Inherits XFAField
Visual Basic (Usage) Copy Code
Dim instance As XFATextEditField
C#
public class XFATextEditField : XFAField
Managed Extensions for C++
public __gc class XFATextEditField : public XFAField
C++/CLI
public ref class XFATextEditField : public XFAField

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Forms.XFA.XFAElement
O2S.Components.PDF4NET.Forms.XFA.XFABasicContainer
O2S.Components.PDF4NET.Forms.XFA.XFAField
O2S.Components.PDF4NET.Forms.XFA.XFATextEditField
O2S.Components.PDF4NET.Forms.XFA.XFAPasswordEditField

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFATextEditField Members
O2S.Components.PDF4NET.Forms.XFA Namespace


XFATextEditField Class Members

XFATextEditField Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFATextEditField Class

The following tables list the members exposed by XFATextEditField.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | MaxLen | Gets or sets the maximum number of characters that can be entered in the text edit field.
Public Property | Multiline | Gets a value indicating whether the field is multiline.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Text | Gets or sets the text in this text edit field.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFATextEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFATextEditField Class Properties

XFATextEditField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFATextEditField Class

For a list of all members of this type, see XFATextEditField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | MaxLen | Gets or sets the maximum number of characters that can be entered in the text edit field.
Public Property | Multiline | Gets a value indicating whether the field is multiline.
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Text | Gets or sets the text in this text edit field.
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFATextEditField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


MaxLen Property

MaxLen Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFATextEditField Class : MaxLen Property

Gets or sets the maximum number of characters that can be entered in the text edit field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MaxLen As Integer
Visual Basic (Usage) Copy Code
Dim instance As XFATextEditField
Dim value As Integer

value = instance.MaxLen
C#
public int MaxLen {get;}
Managed Extensions for C++
public: __property int get_MaxLen();
C++/CLI
public:
property int MaxLen {
   int get();
}

Return Value

An non-negative integer value specifying the maximum number of characters that can be entered in the text edit field.

Remarks

If the value of this property is 0, then the length of this field is unlimited.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFATextEditField Class
XFATextEditField Members


Multiline Property

Multiline Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFATextEditField Class : Multiline Property

Gets a value indicating whether the field is multiline.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Multiline As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XFATextEditField
Dim value As Boolean

value = instance.Multiline
C#
public bool Multiline {get;}
Managed Extensions for C++
public: __property bool get_Multiline();
C++/CLI
public:
property bool Multiline {
   bool get();
}

Return Value

True if the field is multiline, false otherwise.

Remarks

For password edit fields this property is always false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFATextEditField Class
XFATextEditField Members


Text Property

Text Property
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace > XFATextEditField Class : Text Property

Gets or sets the text in this text edit field.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As XFATextEditField
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the text displayed in the text edit field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

XFATextEditField Class
XFATextEditField Members


XFABarcodeType Enumeration

XFABarcodeType Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFABarcodeType Enumeration

Specifies the available barcode types for displaying field content.

Syntax

Visual Basic (Declaration)
Public Enum XFABarcodeType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFABarcodeType
C#
public enum XFABarcodeType : Enum
Managed Extensions for C++
__value public enum XFABarcodeType : public Enum
C++/CLI
public enum class XFABarcodeType : public Enum

Members

Member | Description
Codabar | Codabar, as defined in ANSI/AIM BC3-1995, USS Codabar.
Code2Of5Industrial | Code 2 of 5 Industrial; no official standard.
Code2Of5Interleaved | Code 2 of 5 Interleaved, as defined in ANSI/AIM BC2-1995.
Code2Of5Matrix | Code 2 of 5 Matrix; no official standard.
Code2Of5Standard | Code 2 of 5 Standard; no official standard.
Code3Of9 | Code 39 (also known as code 3 of 9), as defined in ANSI/AIM BC1-1995.
Code3Of9Extended | Code 39 extended; no official standard.
Code11 | Code 11 (USD-8); no official standard.
Code49 | Code 49, as defined in ANSI/AIM BC6-1995.
Code93 | Code 93, as defined in ANSI/AIM BC5-1995.
Code128 | Code 128, as defined in ANSI/AIM BC4-1995.
Code128A | Code 128 A, as defined in ANSI/AIM BC4-1995.
Code128B | Code 128 B, as defined in ANSI/AIM BC4-1995.
Code128C | Code 128 C, as defined in ANSI/AIM BC4-1995.
Code128SSCC | Code 128 serial shipping container code, as defined in ANSI/AIM BC4-1995.
Ean8 | EAN-8, as defined in ISO/EEC 15420.
Ean8Add2 | EAN-8 with 2-digit Addendum, as defined in ISO/EEC 15420.
Ean8Add5 | EAN-8 with 5-digit Addendum, as defined in ISO/EEC 15420.
Ean13 | EAN-13, as defined in ISO/EEC 15420.
Ean13Pwcd | EAN-13 with Price/Weight customer data, as defined in ISO/EEC 15420.
Ean13Add2 | EAN-13 with 2-digit Addendum, as defined in ISO/EEC 15420.
Ean13Add5 | EAN-13 with 5-digit Addendum, as defined in ISO/EEC 15420.
Fim | United States Postal Service FIM (Facing Identification Mark), as described in First-Class Mail.
Logmars | Logmars (Logistics Applications of Automated Marking and Reading Symbols) as defined by U.S. Military Standard MIL-STD-1189B
Maxicode | UPS Maxicode, as defined in ANSI/AIM BC10-ISS Maxicode.
Msi | MSI (modified Plessey).
Pdf417 | PDF417, as defined in USS PDF417.
Pdf417Macro | PDF417, but allowing the data to span multiple PDF417 bar codes.
Plessey | Plessey; no official standard.
PostAUSCust2 | Australian Postal Customer 2, as defined in Customer Barcoding Technical Specifications.
PostAUSCust3 | Australian Postal Customer 3, as defined in Customer Barcoding Technical Specifications.
PostAUSReplyPaid | Australian Postal Reply Paid, as defined in Customer Barcoding Technical Specifications.
PostAUSStandard | Australian Postal Standard, as defined in Customer Barcoding Technical Specifications.
PostUKRM4SCC | United Kingdom RM4SCC (Royal Mail 4-State Customer Code), as defined in the How to Use Mailsort Guide.
PostUSDPBC | United States Postal Service Delivery Point Bar Code, as defined in DMM C840 Barcoding Standards for Letters and Flats.
PostUSStandard | United States Postal Service POSTNET bar code (Zip+4), as defined in DMM C840 Barcoding Standards for Letters and Flats.
PostUSZip | United States Postal Service POSTNET bar code (5 digit Zip), as defined in DMM C840 Barcoding Standards for Letters and Flats.
QR | QR Code, as defined in ISS - QR Code.
Telepen | Telepen, as defined in USS Telepen.
Ucc128 | UCC/EAN 128, as defined in International Symbology Specification - Code 128.
Ucc128Random | UCC/EAN 128 Random Weight, as defined in International Symbology Specification - Code 128.
Ucc128SSCC | UCC/EAN 128 serial shipping container code (SSCC), as defined in International Symbology Specification - Code 128.
UpcA | UPC-A, as defined in ISO/EEC 15420.
UpcAAdd2 | UPC-A with 2-digit Addendum, as defined in ISO/EEC 15420.
UpcAAdd5 | UPC-A with 5-digit Addendum, as defined in ISO/EEC 15420.
UpcAPwcd | UPC-A with Price/Weight customer data, as defined in ISO/EEC 15420.
UpcE | UPC-E, as defined in ISO/EEC 15420.
UpcEAdd2 | UPC-E with 2-digit Addendum, as defined in ISO/EEC 15420.
UpcEAdd5 | UPC-E with 5-digit Addendum, as defined in ISO/EEC 15420.
UpcEan2 | UPC/EAN with 2-digit Addendum, as defined in ISO/EEC 15420.
UpcEan5 | UPC/EAN with 5-digit Addendum, as defined in ISO/EEC 15420.
Unknown | Unknown barcode type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFABarcodeType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


XFACheckButtonState Enumeration

XFACheckButtonState Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFACheckButtonState Enumeration

Specifies the available states for a checkbutton and radiobutton.

Syntax

Visual Basic (Declaration)
Public Enum XFACheckButtonState
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFACheckButtonState
C#
public enum XFACheckButtonState : Enum
Managed Extensions for C++
__value public enum XFACheckButtonState : public Enum
C++/CLI
public enum class XFACheckButtonState : public Enum

Members

Member | Description
Checked | Checked state.
Unchecked | Unchecked state.
Neutral | Neutral state, not available for radiobuttons.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFACheckButtonState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


XFAChoiceListDisplayMode Enumeration

XFAChoiceListDisplayMode Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAChoiceListDisplayMode Enumeration

Specifies the modes for presenting the drop down choice list in interactive applications.

Syntax

Visual Basic (Declaration)
Public Enum XFAChoiceListDisplayMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFAChoiceListDisplayMode
C#
public enum XFAChoiceListDisplayMode : Enum
Managed Extensions for C++
__value public enum XFAChoiceListDisplayMode : public Enum
C++/CLI
public enum class XFAChoiceListDisplayMode : public Enum

Members

Member | Description
UserControl | The drop down list is displayed when the user clicks on the field or on the arrow button.
OnEntry | The drop down list is displayed when the field gets the focus.
Always | The drop down list is always displayed (the field is a list box).
Multiselect | The drop down list is always displayed and allows selection of multiple items (the field is a list box).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAChoiceListDisplayMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


XFAContentAccess Enumeration

XFAContentAccess Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAContentAccess Enumeration

Specifies the access modes to the content of a container.

Syntax

Visual Basic (Declaration)
Public Enum XFAContentAccess
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFAContentAccess
C#
public enum XFAContentAccess : Enum
Managed Extensions for C++
__value public enum XFAContentAccess : public Enum
C++/CLI
public enum class XFAContentAccess : public Enum

Members

Member | Description
NonInteractive | Allows the content to be loaded from the data document, but not updated interactively.
Open | Allow update without restriction.
Protected | The processing application must prevent the user from making any direct changes to the container's content. Indirect changes (e.g., via calculations) may occur. A protected container will not generate any events.
ReadOnly | The processing application must not allow the user to make direct changes to the container's content. Indirect changes (e.g., via calculations) may occur. A protected container will not generate a subset of regular events (those that are not related to direct modification of the content).

Remarks

Fields with Protected or ReadOnly access can not be updated from code.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAContentAccess

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


XFAContentType Enumeration

XFAContentType Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAContentType Enumeration

Specifies the available types of content accepted by a XFA value.

Syntax

Visual Basic (Declaration)
Public Enum XFAContentType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFAContentType
C#
public enum XFAContentType : Enum
Managed Extensions for C++
__value public enum XFAContentType : public Enum
C++/CLI
public enum class XFAContentType : public Enum

Members

Member | Description
Arc | Arc data type
Boolean | Boolean data type.
Date | Date data type.
DateTime | DateTime data type.
Decimal | Decimal data type.
Float | Float data type.
Image | Image data type.
Integer | Integer data type.
Line | Line data type.
Null | No data.
Rectangle | Rectangle data type.
Text | String data type.
Time | Time data type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAContentType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


XFAContentVisibility Enumeration

XFAContentVisibility Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAContentVisibility Enumeration

Specifies the visibility of the content of a container.

Syntax

Visual Basic (Declaration)
Public Enum XFAContentVisibility
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFAContentVisibility
C#
public enum XFAContentVisibility : Enum
Managed Extensions for C++
__value public enum XFAContentVisibility : public Enum
C++/CLI
public enum class XFAContentVisibility : public Enum

Members

Member | Description
Visible | The container content is visible.
Invisible | The container content is not visible, but it still takes up space.
Hidden | The container content is not visible and it does not take up space.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAContentVisibility

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


XFADataFormat Enumeration

XFADataFormat Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFADataFormat Enumeration

Specifies the available formats for data import/export for XFA Forms.

Syntax

Visual Basic (Declaration)
Public Enum XFADataFormat
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFADataFormat
C#
public enum XFADataFormat : Enum
Managed Extensions for C++
__value public enum XFADataFormat : public Enum
C++/CLI
public enum class XFADataFormat : public Enum

Members

Member | Description
XML | Form data is imported or exported in XML format.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFADataFormat

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


XFAImageAspect Enumeration

XFAImageAspect Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAImageAspect Enumeration

Specifies the available modes for scaling the image when it is displayed in the image edit field.

Syntax

Visual Basic (Declaration)
Public Enum XFAImageAspect
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFAImageAspect
C#
public enum XFAImageAspect : Enum
Managed Extensions for C++
__value public enum XFAImageAspect : public Enum
C++/CLI
public enum class XFAImageAspect : public Enum

Members

Member | Description
Fit | The image is scaled to maximum possible size while keeping the original aspect ratio.
None | The image is scaled to occupy the entire field area.
Actual | The image is not scaled, its original size is used.
Width | The image is scaled proportionally such that its width matches the field width and the original aspect ratio is kept.
Height | The image is scaled proportionally such that its height matches the field height and the original aspect ratio is kept.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAImageAspect

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


XFAImageStorageMode Enumeration

XFAImageStorageMode Enumeration
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAImageStorageMode Enumeration

Specifies the available modes for storing image content in an image edit field.

Syntax

Visual Basic (Declaration)
Public Enum XFAImageStorageMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XFAImageStorageMode
C#
public enum XFAImageStorageMode : Enum
Managed Extensions for C++
__value public enum XFAImageStorageMode : public Enum
C++/CLI
public enum class XFAImageStorageMode : public Enum

Members

Member | Description
Embed | The image data is stored in the field.
Link | The path to the image file is stored in the field.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Forms.XFA.XFAImageStorageMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Forms.XFA Namespace


O2S.Components.PDF4NET.Functions Namespace

O2S.Components.PDF4NET.Functions Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFFunction | Defines the base class for PDF functions.
PDFFunctionCollection | Defines a collection of PDF actions.
PDFType0Function | Defines a type 0 function.
PDFType2Function | Defines a type 2 function.
PDFType3Function | Defines a type 3 function.
PDFType4Function | Defines a type 4 function.

Enumerations

Enumeration | Description
InterpolationMode | Specifies the available interpolation modes for a type 0 function values.

See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET.Functions Namespace Inheritance Hierarchy

O2S.Components.PDF4NET.Functions Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType0Function
O2S.Components.PDF4NET.Functions.PDFType2Function
O2S.Components.PDF4NET.Functions.PDFType3Function
O2S.Components.PDF4NET.Functions.PDFType4Function
System.Collections.ObjectModel.Collection<PDFFunction>
O2S.Components.PDF4NET.Functions.PDFFunctionCollection

See Also

Reference

O2S.Components.PDF4NET Assembly


PDFFunction Class

PDFFunction Class
See Also Members
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFFunction Class

Defines the base class for PDF functions.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFFunction
Visual Basic (Usage) Copy Code
Dim instance As PDFFunction
C#
public abstract class PDFFunction
Managed Extensions for C++
public __gc abstract class PDFFunction
C++/CLI
public ref class PDFFunction abstract

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType4Function
O2S.Components.PDF4NET.Functions.PDFType3Function
O2S.Components.PDF4NET.Functions.PDFType2Function
O2S.Components.PDF4NET.Functions.PDFType0Function

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunction Members
O2S.Components.PDF4NET.Functions Namespace


PDFFunction Class Members

PDFFunction Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFFunction Class

The following tables list the members exposed by PDFFunction.

Public Constructors

 | Name | Description
Public Constructor | PDFFunction Constructor | Initilizes a new PDFFunction object.
Top

Public Properties

 | Name | Description
Public Property | Dictionary | Gets the function dictionary.
Public Property | Domain | Gets or sets the domain function domain.
Public Property | Range | Gets or sets the function range.
Top

See Also

Reference

PDFFunction Class
O2S.Components.PDF4NET.Functions Namespace


PDFFunction Constructor

PDFFunction Constructor
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunction Class : PDFFunction Constructor

Initilizes a new PDFFunction object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFFunction()
C#
public PDFFunction()
Managed Extensions for C++
public: PDFFunction();
C++/CLI
public:
PDFFunction();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunction Class
PDFFunction Members


PDFFunction Class Properties

PDFFunction Class Properties
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFFunction Class

For a list of all members of this type, see PDFFunction members.

Public Properties

 | Name | Description
Public Property | Dictionary | Gets the function dictionary.
Public Property | Domain | Gets or sets the domain function domain.
Public Property | Range | Gets or sets the function range.
Top

See Also

Reference

PDFFunction Class
O2S.Components.PDF4NET.Functions Namespace


Dictionary Property

Dictionary Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunction Class : Dictionary Property

Gets the function dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dictionary As PDFDictionary
Visual Basic (Usage) Copy Code
Dim instance As PDFFunction
Dim value As PDFDictionary

value = instance.Dictionary
C#
public PDFDictionary Dictionary {get;}
Managed Extensions for C++
public: __property PDFDictionary* get_Dictionary();
C++/CLI
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Return Value

The raw function dictionary.

Remarks

This property gives you direct access to function dictionary and its associated resources. Note: Modifying directly the function dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunction Class
PDFFunction Members


Domain Property

Domain Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunction Class : Domain Property

Gets or sets the domain function domain.

Syntax

Visual Basic (Declaration)
Public Property Domain As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFFunction
Dim value() As Double

instance.Domain = value

value = instance.Domain
C#
public double[] Domain {get; set;}
Managed Extensions for C++
public: __property double[]* get_Domain();
public: __property void set_Domain(
   double[]* value
);
C++/CLI
public:
property array<double>^ Domain {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

A double array specifying the function domain.

Remarks

The domain is an array of 2 × m numbers, where m is the number of input values.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunction Class
PDFFunction Members


Range Property

Range Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFFunction Class : Range Property

Gets or sets the function range.

Syntax

Visual Basic (Declaration)
Public Property Range As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFFunction
Dim value() As Double

instance.Range = value

value = instance.Range
C#
public double[] Range {get; set;}
Managed Extensions for C++
public: __property double[]* get_Range();
public: __property void set_Range(
   double[]* value
);
C++/CLI
public:
property array<double>^ Range {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

A double array specifying the function range.

Remarks

The rangle is an array of 2 × n numbers, where n is the number of output values.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunction Class
PDFFunction Members


PDFFunctionCollection Class

PDFFunctionCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFFunctionCollection Class

Defines a collection of PDF actions.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFunctionCollection
   Inherits Collection(Of PDFFunction)
Visual Basic (Usage) Copy Code
Dim instance As PDFFunctionCollection
C#
public class PDFFunctionCollection : Collection<PDFFunction>
Managed Extensions for C++
public __gc class PDFFunctionCollection : public Collection<PDFFunction>
C++/CLI
public ref class PDFFunctionCollection : public Collection<PDFFunction>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<PDFFunction>
O2S.Components.PDF4NET.Functions.PDFFunctionCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFunctionCollection Members
O2S.Components.PDF4NET.Functions Namespace


PDFFunctionCollection Class Members

PDFFunctionCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFFunctionCollection Class

The following tables list the members exposed by PDFFunctionCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Top

See Also

Reference

PDFFunctionCollection Class
O2S.Components.PDF4NET.Functions Namespace


PDFType0Function Class

PDFType0Function Class
See Also Members
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType0Function Class

Defines a type 0 function.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFType0Function
   Inherits PDFFunction
Visual Basic (Usage) Copy Code
Dim instance As PDFType0Function
C#
public class PDFType0Function : PDFFunction
Managed Extensions for C++
public __gc class PDFType0Function : public PDFFunction
C++/CLI
public ref class PDFType0Function : public PDFFunction

Remarks

Type 0 functions use a sequence of sample values (contained in a stream) to provide an approximation for functions whose domains and ranges are bounded. The samples are organized as an m-dimensional table in which each entry has n components.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType0Function

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Members
O2S.Components.PDF4NET.Functions Namespace


PDFType0Function Class Members

PDFType0Function Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType0Function Class

The following tables list the members exposed by PDFType0Function.

Public Constructors

 | Name | Description
Public Constructor | PDFType0Function Constructor | Overloaded. Initilizes a new PDFType0Function object.
Top

Public Properties

 | Name | Description
Public Property | BitsPerSample | Gets or sets the function's bits per sample.
Public Property | Decode | Gets or sets the function's decoding array.
Public Property | Dictionary | Gets the function dictionary. (Inherited from PDFFunction)
Public Property | Domain | Gets or sets the domain function domain. (Inherited from PDFFunction)
Public Property | Encode | Gets or sets the function's encoding array.
Public Property | InterpolationMode | Gets or sets the function's interpolation mode.
Public Property | Range | Gets or sets the function range. (Inherited from PDFFunction)
Public Property | Samples | Get or sets the stream that stores the sample values.
Public Property | Size | Gets or sets the number of samples.
Top

See Also

Reference

PDFType0Function Class
O2S.Components.PDF4NET.Functions Namespace


PDFType0Function Constructor

PDFType0Function Constructor
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : PDFType0Function Constructor

Initilizes a new PDFType0Function object.

Overload List

Overload | Description
PDFType0Function Constructor() | Initilizes a new PDFType0Function object.
PDFType0Function Constructor(Int32[],Int32,InterpolationMode,Double[],Double[],Byte[]) | Initializes new PDFType0Function object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members


PDFType0Function Constructor()

PDFType0Function Constructor()
See Also
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class > PDFType0Function Constructor : PDFType0Function Constructor()

Initilizes a new PDFType0Function object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFType0Function()
C#
public PDFType0Function()
Managed Extensions for C++
public: PDFType0Function();
C++/CLI
public:
PDFType0Function();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members
Overload List


PDFType0Function Constructor(Int32[],Int32,InterpolationMode,Double[],Double[],Byte[])

PDFType0Function Constructor(Int32[],Int32,InterpolationMode,Double[],Double[],Byte[])
See Also
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class > PDFType0Function Constructor : PDFType0Function Constructor(Int32[],Int32,InterpolationMode,Double[],Double[],Byte[])

size
An array of m positive integers specifying the number of samples in each input dimension of the sample table.
bitsPerSample
The number of bits used to represent each sample.
interpolationMode
The interpolation mode between samples.
encode
An array of 2*m numbers specifying the linear mapping of input values into the domain of the function's sample table.
decode
An array of 2*n numbers specifying the linear mapping of sample values into the range appropriate for the function's output values.
samples
Sample function data.
Initializes new PDFType0Function object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal size() As Integer, _
   ByVal bitsPerSample As Integer, _
   ByVal interpolationMode As InterpolationMode, _
   ByVal encode() As Double, _
   ByVal decode() As Double, _
   ByVal samples() As Byte _
)
Visual Basic (Usage) Copy Code
Dim size() As Integer
Dim bitsPerSample As Integer
Dim interpolationMode As InterpolationMode
Dim encode() As Double
Dim decode() As Double
Dim samples() As Byte

Dim instance As PDFType0Function(size, bitsPerSample, interpolationMode, encode, decode, samples)
C#
public PDFType0Function(
   int[] size,
   int bitsPerSample,
   InterpolationMode interpolationMode,
   double[] encode,
   double[] decode,
   byte[] samples
)
Managed Extensions for C++
public: PDFType0Function(
   int[]* size,
   int bitsPerSample,
   InterpolationMode interpolationMode,
   double[]* encode,
   double[]* decode,
   byte[]* samples
)
C++/CLI
public:
PDFType0Function(
   array<int>^ size,
   int bitsPerSample,
   InterpolationMode interpolationMode,
   array<double>^ encode,
   array<double>^ decode,
   array<byte>^ samples
)

Parameters

size
An array of m positive integers specifying the number of samples in each input dimension of the sample table.
bitsPerSample
The number of bits used to represent each sample.
interpolationMode
The interpolation mode between samples.
encode
An array of 2*m numbers specifying the linear mapping of input values into the domain of the function's sample table.
decode
An array of 2*n numbers specifying the linear mapping of sample values into the range appropriate for the function's output values.
samples
Sample function data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members
Overload List


PDFType0Function Class Properties

PDFType0Function Class Properties
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType0Function Class

For a list of all members of this type, see PDFType0Function members.

Public Properties

 | Name | Description
Public Property | BitsPerSample | Gets or sets the function's bits per sample.
Public Property | Decode | Gets or sets the function's decoding array.
Public Property | Dictionary | Gets the function dictionary. (Inherited from PDFFunction)
Public Property | Domain | Gets or sets the domain function domain. (Inherited from PDFFunction)
Public Property | Encode | Gets or sets the function's encoding array.
Public Property | InterpolationMode | Gets or sets the function's interpolation mode.
Public Property | Range | Gets or sets the function range. (Inherited from PDFFunction)
Public Property | Samples | Get or sets the stream that stores the sample values.
Public Property | Size | Gets or sets the number of samples.
Top

See Also

Reference

PDFType0Function Class
O2S.Components.PDF4NET.Functions Namespace


BitsPerSample Property

BitsPerSample Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : BitsPerSample Property

Gets or sets the function's bits per sample.

Syntax

Visual Basic (Declaration)
Public Property BitsPerSample As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFType0Function
Dim value As Integer

instance.BitsPerSample = value

value = instance.BitsPerSample
C#
public int BitsPerSample {get; set;}
Managed Extensions for C++
public: __property int get_BitsPerSample();
public: __property void set_BitsPerSample(
   int value
);
C++/CLI
public:
property int BitsPerSample {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the function's bits per sample.

Remarks

This property is the number of bits used to represent each sample. (If the function has multiple output values, each one occupies BitsPerSample bits.) Valid values are 1, 2, 4, 8, 12, 16, 24, and 32.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members


Decode Property

Decode Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : Decode Property

Gets or sets the function's decoding array.

Syntax

Visual Basic (Declaration)
Public Property Decode As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFType0Function
Dim value() As Double

instance.Decode = value

value = instance.Decode
C#
public double[] Decode {get; set;}
Managed Extensions for C++
public: __property double[]* get_Decode();
public: __property void set_Decode(
   double[]* value
);
C++/CLI
public:
property array<double>^ Decode {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

A float array specifying the function's decoding array.

Remarks

The decode is an array of 2*n numbers specifying the linear mapping of sample values into the range appropriate for the function's output values.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members


Encode Property

Encode Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : Encode Property

Gets or sets the function's encoding array.

Syntax

Visual Basic (Declaration)
Public Property Encode As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFType0Function
Dim value() As Double

instance.Encode = value

value = instance.Encode
C#
public double[] Encode {get; set;}
Managed Extensions for C++
public: __property double[]* get_Encode();
public: __property void set_Encode(
   double[]* value
);
C++/CLI
public:
property array<double>^ Encode {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

A float array specifying the function's encoding array.

Remarks

The encode is an array of 2*m numbers specifying the linear mapping of input values into the domain of the function’s sample table.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members


InterpolationMode Property

InterpolationMode Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : InterpolationMode Property

Gets or sets the function's interpolation mode.

Syntax

Visual Basic (Declaration)
Public Property InterpolationMode As InterpolationMode
Visual Basic (Usage) Copy Code
Dim instance As PDFType0Function
Dim value As InterpolationMode

instance.InterpolationMode = value

value = instance.InterpolationMode
C#
public InterpolationMode InterpolationMode {get; set;}
Managed Extensions for C++
public: __property InterpolationMode get_InterpolationMode();
public: __property void set_InterpolationMode(
   InterpolationMode value
);
C++/CLI
public:
property InterpolationMode InterpolationMode {
   InterpolationMode get();
   void set (InterpolationMode value);
}

Return Value

A InterpolationMode enumeration member specifying the function's interpolation mode.

Remarks

This property specifies how the sample values are interpolated.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members


Samples Property

Samples Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : Samples Property

Get or sets the stream that stores the sample values.

Syntax

Visual Basic (Declaration)
Public Property Samples As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFType0Function
Dim value() As Byte

instance.Samples = value

value = instance.Samples
C#
public byte[] Samples {get; set;}
Managed Extensions for C++
public: __property byte[]* get_Samples();
public: __property void set_Samples(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ Samples {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array that stores the sample values.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members


Size Property

Size Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType0Function Class : Size Property

Gets or sets the number of samples.

Syntax

Visual Basic (Declaration)
Public Property Size As Integer()
Visual Basic (Usage) Copy Code
Dim instance As PDFType0Function
Dim value() As Integer

instance.Size = value

value = instance.Size
C#
public int[] Size {get; set;}
Managed Extensions for C++
public: __property int[]* get_Size();
public: __property void set_Size(
   int[]* value
);
C++/CLI
public:
property array<int>^ Size {
   array<int>^ get();
   void set (intarray<value>^ value);
}

Return Value

An int array specifying the number of samples.

Remarks

An array of m positive integers specifying the number of samples in each input dimension of the sample table.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType0Function Class
PDFType0Function Members


PDFType2Function Class

PDFType2Function Class
See Also Members
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType2Function Class

Defines a type 2 function.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFType2Function
   Inherits PDFFunction
Visual Basic (Usage) Copy Code
Dim instance As PDFType2Function
C#
public class PDFType2Function : PDFFunction
Managed Extensions for C++
public __gc class PDFType2Function : public PDFFunction
C++/CLI
public ref class PDFType2Function : public PDFFunction

Remarks

Type 2 functions define an exponential interpolation of one input value and n output values.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType2Function

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType2Function Members
O2S.Components.PDF4NET.Functions Namespace


PDFType2Function Class Members

PDFType2Function Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType2Function Class

The following tables list the members exposed by PDFType2Function.

Public Constructors

 | Name | Description
Public Constructor | PDFType2Function Constructor | Overloaded. Initilizes a new PDFType2Function object.
Top

Public Properties

 | Name | Description
Public Property | C0 | Gets or sets the function result when input value is 0.
Public Property | C1 | Gets or sets the function result when input value is 1.
Public Property | Dictionary | Gets the function dictionary. (Inherited from PDFFunction)
Public Property | Domain | Gets or sets the domain function domain. (Inherited from PDFFunction)
Public Property | Exponent | Gets or sets the interpolation exponent.
Public Property | Range | Gets or sets the function range. (Inherited from PDFFunction)
Top

See Also

Reference

PDFType2Function Class
O2S.Components.PDF4NET.Functions Namespace


PDFType2Function Constructor

PDFType2Function Constructor
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class : PDFType2Function Constructor

Initilizes a new PDFType2Function object.

Overload List

Overload | Description
PDFType2Function Constructor() | Initilizes a new PDFType2Function object.
PDFType2Function Constructor(Double[],Double[],Int32) | Initializes new PDFType2Function object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType2Function Class
PDFType2Function Members


PDFType2Function Constructor()

PDFType2Function Constructor()
See Also
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class > PDFType2Function Constructor : PDFType2Function Constructor()

Initilizes a new PDFType2Function object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFType2Function()
C#
public PDFType2Function()
Managed Extensions for C++
public: PDFType2Function();
C++/CLI
public:
PDFType2Function();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType2Function Class
PDFType2Function Members
Overload List


PDFType2Function Constructor(Double[],Double[],Int32)

PDFType2Function Constructor(Double[],Double[],Int32)
See Also
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class > PDFType2Function Constructor : PDFType2Function Constructor(Double[],Double[],Int32)

c0
An array of N numbers defining the function result when x = 0.0.
c1
An array of N numbers defining the function result when x = 1.0.
exponent
Initializes new PDFType2Function object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal c0() As Double, _
   ByVal c1() As Double, _
   ByVal exponent As Integer _
)
Visual Basic (Usage) Copy Code
Dim c0() As Double
Dim c1() As Double
Dim exponent As Integer

Dim instance As PDFType2Function(c0, c1, exponent)
C#
public PDFType2Function(
   double[] c0,
   double[] c1,
   int exponent
)
Managed Extensions for C++
public: PDFType2Function(
   double[]* c0,
   double[]* c1,
   int exponent
)
C++/CLI
public:
PDFType2Function(
   array<double>^ c0,
   array<double>^ c1,
   int exponent
)

Parameters

c0
An array of N numbers defining the function result when x = 0.0.
c1
An array of N numbers defining the function result when x = 1.0.
exponent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType2Function Class
PDFType2Function Members
Overload List


PDFType2Function Class Properties

PDFType2Function Class Properties
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType2Function Class

For a list of all members of this type, see PDFType2Function members.

Public Properties

 | Name | Description
Public Property | C0 | Gets or sets the function result when input value is 0.
Public Property | C1 | Gets or sets the function result when input value is 1.
Public Property | Dictionary | Gets the function dictionary. (Inherited from PDFFunction)
Public Property | Domain | Gets or sets the domain function domain. (Inherited from PDFFunction)
Public Property | Exponent | Gets or sets the interpolation exponent.
Public Property | Range | Gets or sets the function range. (Inherited from PDFFunction)
Top

See Also

Reference

PDFType2Function Class
O2S.Components.PDF4NET.Functions Namespace


C0 Property

C0 Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class : C0 Property

Gets or sets the function result when input value is 0.

Syntax

Visual Basic (Declaration)
Public Property C0 As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFType2Function
Dim value() As Double

instance.C0 = value

value = instance.C0
C#
public double[] C0 {get; set;}
Managed Extensions for C++
public: __property double[]* get_C0();
public: __property void set_C0(
   double[]* value
);
C++/CLI
public:
property array<double>^ C0 {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

A double array specifying the function result when input value is 0.

Remarks

This property is an array of n numbers defining the function result when the input value is 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType2Function Class
PDFType2Function Members


C1 Property

C1 Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class : C1 Property

Gets or sets the function result when input value is 1.

Syntax

Visual Basic (Declaration)
Public Property C1 As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFType2Function
Dim value() As Double

instance.C1 = value

value = instance.C1
C#
public double[] C1 {get; set;}
Managed Extensions for C++
public: __property double[]* get_C1();
public: __property void set_C1(
   double[]* value
);
C++/CLI
public:
property array<double>^ C1 {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

A double array specifying the function result when input value is 1.

Remarks

This property is an array of n numbers defining the function result when the input value is 1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType2Function Class
PDFType2Function Members


Exponent Property

Exponent Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType2Function Class : Exponent Property

Gets or sets the interpolation exponent.

Syntax

Visual Basic (Declaration)
Public Property Exponent As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFType2Function
Dim value As Double

instance.Exponent = value

value = instance.Exponent
C#
public double Exponent {get; set;}
Managed Extensions for C++
public: __property double get_Exponent();
public: __property void set_Exponent(
   double value
);
C++/CLI
public:
property double Exponent {
   double get();
   void set (double value);
}

Return Value

A double value specifying the function's interpolation exponent.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType2Function Class
PDFType2Function Members


PDFType3Function Class

PDFType3Function Class
See Also Members
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType3Function Class

Defines a type 3 function.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFType3Function
   Inherits PDFFunction
Visual Basic (Usage) Copy Code
Dim instance As PDFType3Function
C#
public class PDFType3Function : PDFFunction
Managed Extensions for C++
public __gc class PDFType3Function : public PDFFunction
C++/CLI
public ref class PDFType3Function : public PDFFunction

Remarks

Type 3 functions define a stitching of the subdomains of several 1-input functions to produce a single new 1-input function.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType3Function

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType3Function Members
O2S.Components.PDF4NET.Functions Namespace


PDFType3Function Class Members

PDFType3Function Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType3Function Class

The following tables list the members exposed by PDFType3Function.

Public Constructors

 | Name | Description
Public Constructor | PDFType3Function Constructor | Initilizes a new PDFType3Function object.
Top

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the intervals to which the functions apply.
Public Property | Dictionary | Gets the function dictionary. (Inherited from PDFFunction)
Public Property | Domain | Gets or sets the domain function domain. (Inherited from PDFFunction)
Public Property | Encode | Gets or sets the function's encoding array.
Public Property | Functions | Gets the list of functions that make up this function.
Public Property | Range | Gets or sets the function range. (Inherited from PDFFunction)
Top

See Also

Reference

PDFType3Function Class
O2S.Components.PDF4NET.Functions Namespace


PDFType3Function Constructor

PDFType3Function Constructor
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType3Function Class : PDFType3Function Constructor

Initilizes a new PDFType3Function object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFType3Function()
C#
public PDFType3Function()
Managed Extensions for C++
public: PDFType3Function();
C++/CLI
public:
PDFType3Function();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType3Function Class
PDFType3Function Members


PDFType3Function Class Properties

PDFType3Function Class Properties
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType3Function Class

For a list of all members of this type, see PDFType3Function members.

Public Properties

 | Name | Description
Public Property | Bounds | Gets or sets the intervals to which the functions apply.
Public Property | Dictionary | Gets the function dictionary. (Inherited from PDFFunction)
Public Property | Domain | Gets or sets the domain function domain. (Inherited from PDFFunction)
Public Property | Encode | Gets or sets the function's encoding array.
Public Property | Functions | Gets the list of functions that make up this function.
Public Property | Range | Gets or sets the function range. (Inherited from PDFFunction)
Top

See Also

Reference

PDFType3Function Class
O2S.Components.PDF4NET.Functions Namespace


Bounds Property

Bounds Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType3Function Class : Bounds Property

Gets or sets the intervals to which the functions apply.

Syntax

Visual Basic (Declaration)
Public Property Bounds As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFType3Function
Dim value() As Double

instance.Bounds = value

value = instance.Bounds
C#
public double[] Bounds {get; set;}
Managed Extensions for C++
public: __property double[]* get_Bounds();
public: __property void set_Bounds(
   double[]* value
);
C++/CLI
public:
property array<double>^ Bounds {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

A float array specifying the intervals to which the functions apply.

Remarks

This property is an An array of k - 1 numbers that, in combination with PDFFunction.Domain, define the intervals to which each function from the Functions list applies. Bounds elements must be in order of increasing value, and each value must be within the domain defined by PDFFunction.Domain.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType3Function Class
PDFType3Function Members


Encode Property

Encode Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType3Function Class : Encode Property

Gets or sets the function's encoding array.

Syntax

Visual Basic (Declaration)
Public Property Encode As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFType3Function
Dim value() As Double

instance.Encode = value

value = instance.Encode
C#
public double[] Encode {get; set;}
Managed Extensions for C++
public: __property double[]* get_Encode();
public: __property void set_Encode(
   double[]* value
);
C++/CLI
public:
property array<double>^ Encode {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

A float array specifying the function's encoding array.

Remarks

The encode is an array of 2*k numbers that, taken in pairs, map each subset of the domain defined by PDFFunction.Domain and the Bounds array to the domain of the corresponding function.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType3Function Class
PDFType3Function Members


Functions Property

Functions Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType3Function Class : Functions Property

Gets the list of functions that make up this function.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Functions As PDFFunctionCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFType3Function
Dim value As PDFFunctionCollection

value = instance.Functions
C#
public PDFFunctionCollection Functions {get;}
Managed Extensions for C++
public: __property PDFFunctionCollection* get_Functions();
C++/CLI
public:
property PDFFunctionCollection^ Functions {
   PDFFunctionCollection^ get();
}

Return Value

The list of functions that make up this function.

Remarks

An array of k 1-input functions making up the stitching function. The output dimensionality of all functions must be the same, and compatible with the value of PDFFunction.Range if PDFFunction.Range is present.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType3Function Class
PDFType3Function Members


PDFType4Function Class

PDFType4Function Class
See Also Members
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType4Function Class

Defines a type 4 function.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFType4Function
   Inherits PDFFunction
Visual Basic (Usage) Copy Code
Dim instance As PDFType4Function
C#
public class PDFType4Function : PDFFunction
Managed Extensions for C++
public __gc class PDFType4Function : public PDFFunction
C++/CLI
public ref class PDFType4Function : public PDFFunction

Remarks

A type 4 function, also called a PostScript calculator function, is represented as a stream containing code written in a small subset of the PostScript language.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Functions.PDFFunction
O2S.Components.PDF4NET.Functions.PDFType4Function

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType4Function Members
O2S.Components.PDF4NET.Functions Namespace


PDFType4Function Class Members

PDFType4Function Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType4Function Class

The following tables list the members exposed by PDFType4Function.

Public Constructors

 | Name | Description
Public Constructor | PDFType4Function Constructor | Overloaded. Initilizes a new PDFType4Function object.
Top

Public Properties

 | Name | Description
Public Property | Dictionary | Gets the function dictionary. (Inherited from PDFFunction)
Public Property | Domain | Gets or sets the domain function domain. (Inherited from PDFFunction)
Public Property | Range | Gets or sets the function range. (Inherited from PDFFunction)
Public Property | Stream | Get or sets the stream that represents the function's code.
Top

See Also

Reference

PDFType4Function Class
O2S.Components.PDF4NET.Functions Namespace


PDFType4Function Constructor

PDFType4Function Constructor
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType4Function Class : PDFType4Function Constructor

Initilizes a new PDFType4Function object.

Overload List

Overload | Description
PDFType4Function Constructor() | Initilizes a new PDFType4Function object.
PDFType4Function Constructor(Byte[]) | Initializes new PDFType4Function object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType4Function Class
PDFType4Function Members


PDFType4Function Constructor()

PDFType4Function Constructor()
See Also
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType4Function Class > PDFType4Function Constructor : PDFType4Function Constructor()

Initilizes a new PDFType4Function object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFType4Function()
C#
public PDFType4Function()
Managed Extensions for C++
public: PDFType4Function();
C++/CLI
public:
PDFType4Function();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType4Function Class
PDFType4Function Members
Overload List


PDFType4Function Constructor(Byte[])

PDFType4Function Constructor(Byte[])
See Also
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType4Function Class > PDFType4Function Constructor : PDFType4Function Constructor(Byte[])

code
Postscript code for the function.
Initializes new PDFType4Function object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code() As Byte _
)
Visual Basic (Usage) Copy Code
Dim code() As Byte

Dim instance As PDFType4Function(code)
C#
public PDFType4Function(
   byte[] code
)
Managed Extensions for C++
public: PDFType4Function(
   byte[]* code
)
C++/CLI
public:
PDFType4Function(
   array<byte>^ code
)

Parameters

code
Postscript code for the function.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType4Function Class
PDFType4Function Members
Overload List


PDFType4Function Class Properties

PDFType4Function Class Properties
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFType4Function Class

For a list of all members of this type, see PDFType4Function members.

Public Properties

 | Name | Description
Public Property | Dictionary | Gets the function dictionary. (Inherited from PDFFunction)
Public Property | Domain | Gets or sets the domain function domain. (Inherited from PDFFunction)
Public Property | Range | Gets or sets the function range. (Inherited from PDFFunction)
Public Property | Stream | Get or sets the stream that represents the function's code.
Top

See Also

Reference

PDFType4Function Class
O2S.Components.PDF4NET.Functions Namespace


Stream Property

Stream Property
[image]
O2S.Components.PDF4NET.Functions Namespace > PDFType4Function Class : Stream Property

Get or sets the stream that represents the function's code.

Syntax

Visual Basic (Declaration)
Public Property Stream As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFType4Function
Dim value() As Byte

instance.Stream = value

value = instance.Stream
C#
public byte[] Stream {get; set;}
Managed Extensions for C++
public: __property byte[]* get_Stream();
public: __property void set_Stream(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ Stream {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array that represents the function's code.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFType4Function Class
PDFType4Function Members


InterpolationMode Enumeration

InterpolationMode Enumeration
[image]
O2S.Components.PDF4NET.Functions Namespace : InterpolationMode Enumeration

Specifies the available interpolation modes for a type 0 function values.

Syntax

Visual Basic (Declaration)
Public Enum InterpolationMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As InterpolationMode
C#
public enum InterpolationMode : Enum
Managed Extensions for C++
__value public enum InterpolationMode : public Enum
C++/CLI
public enum class InterpolationMode : public Enum

Members

Member | Description
Linear | Linear intepolation.
CubicSpline | Cubic spline interpolation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Functions.InterpolationMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Functions Namespace


O2S.Components.PDF4NET.Graphics Namespace

O2S.Components.PDF4NET.Graphics Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFAxialShadingPattern | Defines a PDF shading pattern.
PDFBasicCanvas | Encapsulates a drawing surface.
PDFBrush | Defines an object used to fill a closed shape with a single color.
PDFCalGrayColor | Defines a calibrated gray color, based on a CalGray colorspace.
PDFCalRgbColor | Defines a calibrated RGB color, based on a CalRGB colorspace.
PDFCanvas | Encapsulates a page's drawing surface. Supported by Compact .NET Edition.
PDFCMLogicalUnit | Defines the centimeter as a logical unit.
PDFCmykColor | Defines a CMYK color, a color based on a CMYK device colorspace.
PDFColor | Defines the base class for all PDF colors.
PDFDeviceColor | Defines a device based color.
PDFDeviceNColor | Defines a DeviceN color, based on a DeviceN colorspace.
PDFExtendedGraphicState | Defines the current graphic state in a PDF content stream.
PDFGrayColor | Defines a Gray color, a color based on a Gray device colorspace.
PDFHatchBrush | Defines a hatch brush for filling closed shapes.
PDFHatchPattern | Defines a PDF hatch pattern.
PDFHorizontalGradientBrush | Defines a horizontal gradient brush for filling closed shapes.
PDFICCColor | Defines an ICC color, based on an ICC colorspace.
PDFInchLogicalUnit | Defines the inch as a logical unit.
PDFIndexedColor | Defines an indexed color, based on an indexed colorspace.
PDFLabColor | Defines a calibrated Lab color, based on a Lab colorspace.
PDFLayer | Defines a layer on a page's canvas.
PDFLayerCollection | Defines a collection of PDF layers.
PDFLinearGradientBrush | Defines a hatch brush for filling closed shapes.
PDFLinearGradientPattern | Defines a pattern that represents a linear gradient.
PDFLogicalUnitBase | Base class for all the classes that implement custom logical units.
PDFMMLogicalUnit | Defines the millimeter as a logical unit.
PDFPattern | Defines the base class for all PDF patterns.
PDFPen | Defines an object used to draw lines and curves. This class cannot be inherited. Supported by Compact .NET Edition.
PDFPointLogicalUnit | Defines the point (pdf unit) as a logical unit.
PDFRgbColor | Defines a RGB color, a color based on a RGB device colorspace.
PDFSeparationColor | Defines an separation color, based on a separation colorspace.
PDFShadingPattern | Defines a PDF shading pattern.
PDFShadingPatternColor | Defines a special color based on a shading pattern.
PDFTilingPattern | Defines a PDF tiling pattern.
PDFTilingPatternColor | Defines a special color based on a tiling pattern.
PDFVerticalGradientBrush | Defines a vertical gradient brush for filling closed shapes.

Enumerations

Enumeration | Description
PDFBlendMode | Specifies the available blend modes.
PDFContentMirroring | Specifies the available mirroring options when drawing graphic content.
PDFDashStyle | Specifies the style of dashed lines drawn with a PDFPen object.
PDFFillMode | Specifies the available fill modes for a complex shape.
PDFHatchType | Specifies the available types for hatch brushes.
PDFLineCap | Specifies the available cap styles with which a Pen object can begin or end a line.
PDFLineJoin | Specifies how to join consecutive line or curve segments
PDFTextAlign | Specifies the available alignments for text lines.
PDFXAxisDirection | Specifies the available directions for the X axis of the page canvas.
PDFYAxisDirection | Specifies the available directions for the Y axis of the page canvas.

See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET.Graphics Namespace Inheritance Hierarchy

O2S.Components.PDF4NET.Graphics Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBasicCanvas
O2S.Components.PDF4NET.Graphics.PDFCanvas
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFHatchBrush
O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush
O2S.Components.PDF4NET.Graphics.PDFHorizontalGradientBrush
O2S.Components.PDF4NET.Graphics.PDFVerticalGradientBrush
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFCalGrayColor
O2S.Components.PDF4NET.Graphics.PDFCalRgbColor
O2S.Components.PDF4NET.Graphics.PDFDeviceColor
O2S.Components.PDF4NET.Graphics.PDFCmykColor
O2S.Components.PDF4NET.Graphics.PDFGrayColor
O2S.Components.PDF4NET.Graphics.PDFRgbColor
O2S.Components.PDF4NET.Graphics.PDFDeviceNColor
O2S.Components.PDF4NET.Graphics.PDFICCColor
O2S.Components.PDF4NET.Graphics.PDFIndexedColor
O2S.Components.PDF4NET.Graphics.PDFLabColor
O2S.Components.PDF4NET.Graphics.PDFSeparationColor
O2S.Components.PDF4NET.Graphics.PDFShadingPatternColor
O2S.Components.PDF4NET.Graphics.PDFTilingPatternColor
O2S.Components.PDF4NET.Graphics.PDFExtendedGraphicState
O2S.Components.PDF4NET.Graphics.PDFLayer
O2S.Components.PDF4NET.Graphics.PDFLogicalUnitBase
O2S.Components.PDF4NET.Graphics.PDFCMLogicalUnit
O2S.Components.PDF4NET.Graphics.PDFInchLogicalUnit
O2S.Components.PDF4NET.Graphics.PDFMMLogicalUnit
O2S.Components.PDF4NET.Graphics.PDFPointLogicalUnit
O2S.Components.PDF4NET.Graphics.PDFPen
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.PDFPattern
O2S.Components.PDF4NET.Graphics.PDFShadingPattern
O2S.Components.PDF4NET.Graphics.PDFAxialShadingPattern
O2S.Components.PDF4NET.Graphics.PDFLinearGradientPattern
O2S.Components.PDF4NET.Graphics.PDFTilingPattern
O2S.Components.PDF4NET.Graphics.PDFHatchPattern
System.Collections.ObjectModel.Collection<PDFLayer>
O2S.Components.PDF4NET.PDFCollection<PDFLayer, PDFPage>
O2S.Components.PDF4NET.Graphics.PDFLayerCollection

See Also

Reference

O2S.Components.PDF4NET Assembly


PDFAxialShadingPattern Class

PDFAxialShadingPattern Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFAxialShadingPattern Class

Defines a PDF shading pattern.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFAxialShadingPattern
   Inherits PDFShadingPattern
Visual Basic (Usage) Copy Code
Dim instance As PDFAxialShadingPattern
C#
public class PDFAxialShadingPattern : PDFShadingPattern
Managed Extensions for C++
public __gc class PDFAxialShadingPattern : public PDFShadingPattern
C++/CLI
public ref class PDFAxialShadingPattern : public PDFShadingPattern

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.PDFPattern
O2S.Components.PDF4NET.Graphics.PDFShadingPattern
O2S.Components.PDF4NET.Graphics.PDFAxialShadingPattern
O2S.Components.PDF4NET.Graphics.PDFLinearGradientPattern

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAxialShadingPattern Members
O2S.Components.PDF4NET.Graphics Namespace


PDFAxialShadingPattern Class Members

PDFAxialShadingPattern Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFAxialShadingPattern Class

The following tables list the members exposed by PDFAxialShadingPattern.

Public Constructors

 | Name | Description
Public Constructor | PDFAxialShadingPattern Constructor | Initializes a new PDFAxialShadingPattern object.
Top

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets or sets the shading's colorspace.
Public Property | Coordinates | Gets or sets the shading coordinates.
Public Property | Function | Gets or sets the function that defines the axial shading.
Top

See Also

Reference

PDFAxialShadingPattern Class
O2S.Components.PDF4NET.Graphics Namespace


PDFAxialShadingPattern Constructor

PDFAxialShadingPattern Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFAxialShadingPattern Class : PDFAxialShadingPattern Constructor

Initializes a new PDFAxialShadingPattern object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFAxialShadingPattern()
C#
public PDFAxialShadingPattern()
Managed Extensions for C++
public: PDFAxialShadingPattern();
C++/CLI
public:
PDFAxialShadingPattern();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAxialShadingPattern Class
PDFAxialShadingPattern Members


PDFAxialShadingPattern Class Properties

PDFAxialShadingPattern Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFAxialShadingPattern Class

For a list of all members of this type, see PDFAxialShadingPattern members.

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets or sets the shading's colorspace.
Public Property | Coordinates | Gets or sets the shading coordinates.
Public Property | Function | Gets or sets the function that defines the axial shading.
Top

See Also

Reference

PDFAxialShadingPattern Class
O2S.Components.PDF4NET.Graphics Namespace


ColorSpace Property

ColorSpace Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFAxialShadingPattern Class : ColorSpace Property

Gets or sets the shading's colorspace.

Syntax

Visual Basic (Declaration)
Public Property ColorSpace As PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFAxialShadingPattern
Dim value As PDFColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
C#
public PDFColorSpace ColorSpace {get; set;}
Managed Extensions for C++
public: __property PDFColorSpace* get_ColorSpace();
public: __property void set_ColorSpace(
   PDFColorSpace* value
);
C++/CLI
public:
property PDFColorSpace^ ColorSpace {
   PDFColorSpace^ get();
   void set (PDFColorSpace^ value);
}

Return Value

The color space in which color values are expressed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAxialShadingPattern Class
PDFAxialShadingPattern Members


Coordinates Property

Coordinates Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFAxialShadingPattern Class : Coordinates Property

Gets or sets the shading coordinates.

Syntax

Visual Basic (Declaration)
Public Property Coordinates As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFAxialShadingPattern
Dim value() As Double

instance.Coordinates = value

value = instance.Coordinates
C#
public double[] Coordinates {get; set;}
Managed Extensions for C++
public: __property double[]* get_Coordinates();
public: __property void set_Coordinates(
   double[]* value
);
C++/CLI
public:
property array<double>^ Coordinates {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of four numbers [ x0 y0 x1 y1 ] specifying the starting and ending coordinates of the axis, expressed in the shading's target coordinate space.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAxialShadingPattern Class
PDFAxialShadingPattern Members


Function Property

Function Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFAxialShadingPattern Class : Function Property

Gets or sets the function that defines the axial shading.

Syntax

Visual Basic (Declaration)
Public Property Function As PDFFunction
Visual Basic (Usage) Copy Code
Dim instance As PDFAxialShadingPattern
Dim value As PDFFunction

instance.Function = value

value = instance.Function
C#
public PDFFunction Function {get; set;}
Managed Extensions for C++
public: __property PDFFunction* get_Function();
public: __property void set_Function(
   PDFFunction* value
);
C++/CLI
public:
property PDFFunction^ Function {
   PDFFunction^ get();
   void set (PDFFunction^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAxialShadingPattern Class
PDFAxialShadingPattern Members


PDFBasicCanvas Class

PDFBasicCanvas Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFBasicCanvas Class

Encapsulates a drawing surface.

Syntax

Visual Basic (Declaration)
Public Class PDFBasicCanvas
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
C#
public class PDFBasicCanvas
Managed Extensions for C++
public __gc class PDFBasicCanvas
C++/CLI
public ref class PDFBasicCanvas

Remarks

This class is used to create the content of a standalone drawing.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBasicCanvas
O2S.Components.PDF4NET.Graphics.PDFCanvas

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Members
O2S.Components.PDF4NET.Graphics Namespace


PDFBasicCanvas Class Members

PDFBasicCanvas Class Members
See Also Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFBasicCanvas Class

The following tables list the members exposed by PDFBasicCanvas.

Public Methods

 | Name | Description
Public Method | Clear | Clears the canvas content.
Public Method | DrawArc | Draws an arc representing a portion of an circle specified by a pair of coordinates and a width.
Public Method | DrawBarcode | Overloaded. Draws the barcode on the canvas.
Public Method | DrawBezier | Overloaded. Draws a Bezier spline specified by four pairs of coordinates. Supported by Compact .NET Edition.
Public Method | DrawChord | Overloaded. Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Public Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Public Method | DrawFormXObject | Overloaded. Draws a form XObject specified by a pair of coordinates, a width and a height.
Public Method | DrawHTMLText | Overloaded. Draws a line of text specified by a string and a pair of coordinates.
Public Method | DrawHTMLTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height.
Public Method | DrawImage | Overloaded. Draws an image specified by a file name, a pair of coordinates, a width and a height.
Public Method | DrawImportedContent | Overloaded. Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
Public Method | DrawLine | Overloaded. Draws a line connecting two points specified by coordinate pairs using the specified pen. Supported by Compact .NET Edition.
Public Method | DrawLines | Overloaded. Draws a series of line segments that connect an array of PointF structures.
Public Method | DrawPath | Overloaded. Draws a PDFPath object with the specified pen.
Public Method | DrawPie | Overloaded. Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
Public Method | DrawPolyBezier | Overloaded. Draws a series of connected curves defined by an array of PointF structures.
Public Method | DrawPolygon | Overloaded. Draws a polygon defined by an array of PDFPoint objects.
Public Method | DrawPolyPolygon | Overloaded. Draws a series of closed polygons, each one defined by an array of PDFPoint objects.
Public Method | DrawRectangle | Overloaded. Draws a rectangle specified by a pair of coordinates, a width and a height.
Public Method | DrawRoundRectangle | Overloaded. Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
Public Method | DrawText | Overloaded. Draws a line of text specified by a string and a pair of coordinates.
Public Method | DrawTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height.
Public Method | FitHtmlText | Overloaded. Calculates how much of the text really fits in the box.
Public Method | FitText | Overloaded. Calculates how much of the given text fits in the given area.
Public Method | GetHtmlTextBoxHeight | Overloaded. Gets the height of the wrapped HTML text.
Public Method | GetHtmlTextBoxLastLineWidth | Overloaded. Gets the width of the last line in the HTML text box.
Public Method | GetTextBoxHeight | Overloaded. Gets the height of the wrapped text.
Public Method | GetTextBoxLastLineWidth | Gets the width of the last line in the text box.
Public Method | ResetClipRegion | Resets the current clipping region to whole page.
Public Method | RestoreGraphicState | Restores the current graphic state in the PDF content stream.
Public Method | SaveGraphicState | Saves the current graphic state in the PDF content stream.
Public Method | SetAxesDirection | Sets the new directions for the axes of the coordinate system.
Public Method | SetBlendMode | Sets the blending mode for the subsequent drawing operations.
Public Method | SetClipRegion | Sets a clipping region on page's canvas.
Public Method | SetExtendedGraphicState | Sets the current graphic state in the content stream.
Public Method | SetLogicalUnit | Sets the logical unit for the drawing operations.
Public Method | SetOrigin | Sets the new point of origin for the coordinate system.
Public Method | SetOverprint | Sets the overprint for the subsequent drawing (stroke and fill) operations.
Public Method | SetTransparency | Sets the transparency level for the subsequent drawing operations.
Public Method | ToString | Overridden. Gets the string representation of this object.
Top

See Also

Reference

PDFBasicCanvas Class
O2S.Components.PDF4NET.Graphics Namespace


PDFBasicCanvas Class Methods

PDFBasicCanvas Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFBasicCanvas Class

For a list of all members of this type, see PDFBasicCanvas members.

Public Methods

 | Name | Description
Public Method | Clear | Clears the canvas content.
Public Method | DrawArc | Draws an arc representing a portion of an circle specified by a pair of coordinates and a width.
Public Method | DrawBarcode | Overloaded. Draws the barcode on the canvas.
Public Method | DrawBezier | Overloaded. Draws a Bezier spline specified by four pairs of coordinates. Supported by Compact .NET Edition.
Public Method | DrawChord | Overloaded. Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
Public Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Public Method | DrawFormXObject | Overloaded. Draws a form XObject specified by a pair of coordinates, a width and a height.
Public Method | DrawHTMLText | Overloaded. Draws a line of text specified by a string and a pair of coordinates.
Public Method | DrawHTMLTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height.
Public Method | DrawImage | Overloaded. Draws an image specified by a file name, a pair of coordinates, a width and a height.
Public Method | DrawImportedContent | Overloaded. Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
Public Method | DrawLine | Overloaded. Draws a line connecting two points specified by coordinate pairs using the specified pen. Supported by Compact .NET Edition.
Public Method | DrawLines | Overloaded. Draws a series of line segments that connect an array of PointF structures.
Public Method | DrawPath | Overloaded. Draws a PDFPath object with the specified pen.
Public Method | DrawPie | Overloaded. Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
Public Method | DrawPolyBezier | Overloaded. Draws a series of connected curves defined by an array of PointF structures.
Public Method | DrawPolygon | Overloaded. Draws a polygon defined by an array of PDFPoint objects.
Public Method | DrawPolyPolygon | Overloaded. Draws a series of closed polygons, each one defined by an array of PDFPoint objects.
Public Method | DrawRectangle | Overloaded. Draws a rectangle specified by a pair of coordinates, a width and a height.
Public Method | DrawRoundRectangle | Overloaded. Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
Public Method | DrawText | Overloaded. Draws a line of text specified by a string and a pair of coordinates.
Public Method | DrawTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height.
Public Method | FitHtmlText | Overloaded. Calculates how much of the text really fits in the box.
Public Method | FitText | Overloaded. Calculates how much of the given text fits in the given area.
Public Method | GetHtmlTextBoxHeight | Overloaded. Gets the height of the wrapped HTML text.
Public Method | GetHtmlTextBoxLastLineWidth | Overloaded. Gets the width of the last line in the HTML text box.
Public Method | GetTextBoxHeight | Overloaded. Gets the height of the wrapped text.
Public Method | GetTextBoxLastLineWidth | Gets the width of the last line in the text box.
Public Method | ResetClipRegion | Resets the current clipping region to whole page.
Public Method | RestoreGraphicState | Restores the current graphic state in the PDF content stream.
Public Method | SaveGraphicState | Saves the current graphic state in the PDF content stream.
Public Method | SetAxesDirection | Sets the new directions for the axes of the coordinate system.
Public Method | SetBlendMode | Sets the blending mode for the subsequent drawing operations.
Public Method | SetClipRegion | Sets a clipping region on page's canvas.
Public Method | SetExtendedGraphicState | Sets the current graphic state in the content stream.
Public Method | SetLogicalUnit | Sets the logical unit for the drawing operations.
Public Method | SetOrigin | Sets the new point of origin for the coordinate system.
Public Method | SetOverprint | Sets the overprint for the subsequent drawing (stroke and fill) operations.
Public Method | SetTransparency | Sets the transparency level for the subsequent drawing operations.
Public Method | ToString | Overridden. Gets the string representation of this object.
Top

See Also

Reference

PDFBasicCanvas Class
O2S.Components.PDF4NET.Graphics Namespace


Clear Method

Clear Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : Clear Method

Clears the canvas content.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawArc Method

DrawArc Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawArc Method

pen
a PDFPen object used to draw the border of the arc.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.
Draws an arc representing a portion of an circle specified by a pair of coordinates and a width.

Syntax

Visual Basic (Declaration)
Public Sub DrawArc( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawArc(pen, left, top, width, height, startAngle, sweepAngle)
C#
public void DrawArc(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
Managed Extensions for C++
public: void DrawArc(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
C++/CLI
public:
void DrawArc(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the arc.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the arc.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the arc.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawBarcode Method

DrawBarcode Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawBarcode Method

Draws the barcode on the canvas.

Overload List

Overload | Description
DrawBarcode(PDFBarcode) | Draws the barcode on the canvas.
DrawBarcode(PDFBarcode,Double,Double) | Draws the barcode on the canvas at the specified position.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawBarcode(PDFBarcode) Method

DrawBarcode(PDFBarcode) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawBarcode Method : DrawBarcode(PDFBarcode) Method

barcode
A PDFBarcode descendant object.
Draws the barcode on the canvas.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawBarcode( _
   ByVal barcode As PDFBarcode _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim barcode As PDFBarcode

instance.DrawBarcode(barcode)
C#
public void DrawBarcode(
   PDFBarcode barcode
)
Managed Extensions for C++
public: void DrawBarcode(
   PDFBarcode* barcode
)
C++/CLI
public:
void DrawBarcode(
   PDFBarcode^ barcode
)

Parameters

barcode
A PDFBarcode descendant object.

Remarks

This method draws the given barcode on the canvas. The position of the barcode is given by the barcode's properties PDFBarcode.Left, PDFBarcode.Top, PDFBarcode.Width and PDFBarcode.Height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawBarcode(PDFBarcode,Double,Double) Method

DrawBarcode(PDFBarcode,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawBarcode Method : DrawBarcode(PDFBarcode,Double,Double) Method

barcode
A PDFBarcode descendant object.
left
The X coordinate of the top left corner of barcode's bounding rectangle.
top
The Y coordinate of the top left corner of barcode's bounding rectangle.
Draws the barcode on the canvas at the specified position.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawBarcode( _
   ByVal barcode As PDFBarcode, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim barcode As PDFBarcode
Dim left As Double
Dim top As Double

instance.DrawBarcode(barcode, left, top)
C#
public void DrawBarcode(
   PDFBarcode barcode,
   double left,
   double top
)
Managed Extensions for C++
public: void DrawBarcode(
   PDFBarcode* barcode,
   double left,
   double top
)
C++/CLI
public:
void DrawBarcode(
   PDFBarcode^ barcode,
   double left,
   double top
)

Parameters

barcode
A PDFBarcode descendant object.
left
The X coordinate of the top left corner of barcode's bounding rectangle.
top
The Y coordinate of the top left corner of barcode's bounding rectangle.

Remarks

This method draws the given barcode on the canvas. The barcode's properties PDFBarcode.Left, PDFBarcode.Top, PDFBarcode.Width and PDFBarcode.Height are ignored.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawBezier Method

DrawBezier Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawBezier Method

Draws a Bezier spline specified by four pairs of coordinates.

Supported by Compact .NET Edition.

Overload List

Overload | Description
DrawBezier(PDFPen,Double,Double,Double,Double,Double,Double,Double,Double) | Draws a Bezier spline specified by four pairs of coordinates. Supported by Compact .NET Edition.
DrawBezier(PDFPen,PointF,PointF,PointF,PointF) | Draws a Bezier spline specified by four PointF structures.
DrawBezier(PDFPen,PDFPoint,PDFPoint,PDFPoint,PDFPoint) | Draws a Bezier spline specified by four PDFPoint objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawBezier(PDFPen,Double,Double,Double,Double,Double,Double,Double,Double) Method

DrawBezier(PDFPen,Double,Double,Double,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawBezier Method : DrawBezier(PDFPen,Double,Double,Double,Double,Double,Double,Double,Double) Method

pen
a PDFPen object used to draw the Bezier spline.
x1
the x coordinate of the first control point.
y1
the y coordinate of the first control point.
x2
the x coordinate of the second control point.
y2
the y coordinate of the second control point.
x3
the x coordinate of the third control point.
y3
the y coordinate of the third control point.
x4
the x coordinate of the fourth control point.
y4
the y coordinate of the fourth control point.
Draws a Bezier spline specified by four pairs of coordinates.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawBezier( _
   ByVal pen As PDFPen, _
   ByVal x1 As Double, _
   ByVal y1 As Double, _
   ByVal x2 As Double, _
   ByVal y2 As Double, _
   ByVal x3 As Double, _
   ByVal y3 As Double, _
   ByVal x4 As Double, _
   ByVal y4 As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim x1 As Double
Dim y1 As Double
Dim x2 As Double
Dim y2 As Double
Dim x3 As Double
Dim y3 As Double
Dim x4 As Double
Dim y4 As Double

instance.DrawBezier(pen, x1, y1, x2, y2, x3, y3, x4, y4)
C#
public void DrawBezier(
   PDFPen pen,
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3,
   double x4,
   double y4
)
Managed Extensions for C++
public: void DrawBezier(
   PDFPen* pen,
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3,
   double x4,
   double y4
)
C++/CLI
public:
void DrawBezier(
   PDFPen^ pen,
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3,
   double x4,
   double y4
)

Parameters

pen
a PDFPen object used to draw the Bezier spline.
x1
the x coordinate of the first control point.
y1
the y coordinate of the first control point.
x2
the x coordinate of the second control point.
y2
the y coordinate of the second control point.
x3
the x coordinate of the third control point.
y3
the y coordinate of the third control point.
x4
the x coordinate of the fourth control point.
y4
the y coordinate of the fourth control point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawBezier(PDFPen,PointF,PointF,PointF,PointF) Method

DrawBezier(PDFPen,PointF,PointF,PointF,PointF) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawBezier Method : DrawBezier(PDFPen,PointF,PointF,PointF,PointF) Method

pen
a PDFPen object used to draw the Bezier spline.
pt1
the first control point
pt2
the second control point
pt3
the third control point
pt4
the fourth control point
Draws a Bezier spline specified by four PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawBezier( _
   ByVal pen As PDFPen, _
   ByVal pt1 As PointF, _
   ByVal pt2 As PointF, _
   ByVal pt3 As PointF, _
   ByVal pt4 As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim pt1 As PointF
Dim pt2 As PointF
Dim pt3 As PointF
Dim pt4 As PointF

instance.DrawBezier(pen, pt1, pt2, pt3, pt4)
C#
public void DrawBezier(
   PDFPen pen,
   PointF pt1,
   PointF pt2,
   PointF pt3,
   PointF pt4
)
Managed Extensions for C++
public: void DrawBezier(
   PDFPen* pen,
   PointF pt1,
   PointF pt2,
   PointF pt3,
   PointF pt4
)
C++/CLI
public:
void DrawBezier(
   PDFPen^ pen,
   PointF pt1,
   PointF pt2,
   PointF pt3,
   PointF pt4
)

Parameters

pen
a PDFPen object used to draw the Bezier spline.
pt1
the first control point
pt2
the second control point
pt3
the third control point
pt4
the fourth control point

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawBezier(PDFPen,PDFPoint,PDFPoint,PDFPoint,PDFPoint) Method

DrawBezier(PDFPen,PDFPoint,PDFPoint,PDFPoint,PDFPoint) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawBezier Method : DrawBezier(PDFPen,PDFPoint,PDFPoint,PDFPoint,PDFPoint) Method

pen
a PDFPen object used to draw the Bezier spline.
pt1
the first control point
pt2
the second control point
pt3
the third control point
pt4
the fourth control point
Draws a Bezier spline specified by four PDFPoint objects.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawBezier( _
   ByVal pen As PDFPen, _
   ByVal pt1 As PDFPoint, _
   ByVal pt2 As PDFPoint, _
   ByVal pt3 As PDFPoint, _
   ByVal pt4 As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim pt1 As PDFPoint
Dim pt2 As PDFPoint
Dim pt3 As PDFPoint
Dim pt4 As PDFPoint

instance.DrawBezier(pen, pt1, pt2, pt3, pt4)
C#
public void DrawBezier(
   PDFPen pen,
   PDFPoint pt1,
   PDFPoint pt2,
   PDFPoint pt3,
   PDFPoint pt4
)
Managed Extensions for C++
public: void DrawBezier(
   PDFPen* pen,
   PDFPoint* pt1,
   PDFPoint* pt2,
   PDFPoint* pt3,
   PDFPoint* pt4
)
C++/CLI
public:
void DrawBezier(
   PDFPen^ pen,
   PDFPoint^ pt1,
   PDFPoint^ pt2,
   PDFPoint^ pt3,
   PDFPoint^ pt4
)

Parameters

pen
a PDFPen object used to draw the Bezier spline.
pt1
the first control point
pt2
the second control point
pt3
the third control point
pt4
the fourth control point

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawChord Method

DrawChord Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawChord Method

Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.

Overload List

Overload | Description
DrawChord(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
DrawChord(PDFPen,Double,Double,Double,Double,Double,Double) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
DrawChord(PDFPen,RectangleF,Double,Double) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a RectangleF structure.
DrawChord(PDFBrush,Double,Double,Double,Double,Double,Double) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.
DrawChord(PDFBrush,RectangleF,Double,Double) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a RectangleF structure.
DrawChord(PDFPen,PDFBrush,RectangleF,Double,Double) | Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a RectangleF structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawChord(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) Method

DrawChord(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) Method

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawChord( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawChord(pen, brush, left, top, width, height, startAngle, sweepAngle)
C#
public void DrawChord(
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
Managed Extensions for C++
public: void DrawChord(
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
C++/CLI
public:
void DrawChord(
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawChord(PDFPen,Double,Double,Double,Double,Double,Double) Method

DrawChord(PDFPen,Double,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFPen,Double,Double,Double,Double,Double,Double) Method

pen
a PDFPen object used to draw the border of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawChord( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawChord(pen, left, top, width, height, startAngle, sweepAngle)
C#
public void DrawChord(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
Managed Extensions for C++
public: void DrawChord(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
C++/CLI
public:
void DrawChord(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawChord(PDFPen,RectangleF,Double,Double) Method

DrawChord(PDFPen,RectangleF,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFPen,RectangleF,Double,Double) Method

pen
a PDFPen object used to draw the border of the chord.
rect
a RectangleF structure specifying the bounding rectangle of the chord.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawChord( _
   ByVal pen As PDFPen, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim rect As RectangleF
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawChord(pen, rect, startAngle, sweepAngle)
C#
public void DrawChord(
   PDFPen pen,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
Managed Extensions for C++
public: void DrawChord(
   PDFPen* pen,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
C++/CLI
public:
void DrawChord(
   PDFPen^ pen,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the chord.
rect
a RectangleF structure specifying the bounding rectangle of the chord.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawChord(PDFBrush,Double,Double,Double,Double,Double,Double) Method

DrawChord(PDFBrush,Double,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFBrush,Double,Double,Double,Double,Double,Double) Method

brush
a PDFBrush object used to fill the interior of the chord.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawChord( _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawChord(brush, left, top, width, height, startAngle, sweepAngle)
C#
public void DrawChord(
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
Managed Extensions for C++
public: void DrawChord(
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
C++/CLI
public:
void DrawChord(
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

brush
a PDFBrush object used to fill the interior of the chord.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawChord(PDFBrush,RectangleF,Double,Double) Method

DrawChord(PDFBrush,RectangleF,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFBrush,RectangleF,Double,Double) Method

brush
a PDFBrush object used to fill the interior of the chord.
rect
a RectangleF structure specifying the bounding rectangle of the chord.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawChord( _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim rect As RectangleF
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawChord(brush, rect, startAngle, sweepAngle)
C#
public void DrawChord(
   PDFBrush brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
Managed Extensions for C++
public: void DrawChord(
   PDFBrush* brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
C++/CLI
public:
void DrawChord(
   PDFBrush^ brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)

Parameters

brush
a PDFBrush object used to fill the interior of the chord.
rect
a RectangleF structure specifying the bounding rectangle of the chord.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawChord(PDFPen,PDFBrush,RectangleF,Double,Double) Method

DrawChord(PDFPen,PDFBrush,RectangleF,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawChord Method : DrawChord(PDFPen,PDFBrush,RectangleF,Double,Double) Method

pen
a PDFPen object used to draw the border of the chord.
brush
a PDFBrush object used to fill the interior of the chord.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.
Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawChord( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawChord(pen, brush, rect, startAngle, sweepAngle)
C#
public void DrawChord(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
Managed Extensions for C++
public: void DrawChord(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
C++/CLI
public:
void DrawChord(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the chord.
brush
a PDFBrush object used to fill the interior of the chord.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the chord.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the chord.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse Method

DrawEllipse Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawEllipse Method

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Overload List

Overload | Description
DrawEllipse(PDFPen,PDFBrush,Double,Double,Double,Double) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawEllipse(PDFPen,PDFBrush,Double,Double,Double,Double,Double) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawEllipse(PDFPen,Double,Double,Double,Double) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawEllipse(PDFPen,Double,Double,Double,Double,Double) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawEllipse(PDFPen,RectangleF) | Draws an ellipse defined by a bounding rectangle specified by a RectangleF structure.
DrawEllipse(PDFBrush,Double,Double,Double,Double) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawEllipse(PDFBrush,Double,Double,Double,Double,Double) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawEllipse(PDFBrush,RectangleF) | Draws an ellipse defined by a bounding rectangle specified by a RectangleF structure.
DrawEllipse(PDFPen,PDFBrush,RectangleF) | Draws an ellipse defined by a bounding rectangle specified by a RectangleF structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawEllipse(PDFPen,PDFBrush,Double,Double,Double,Double) Method

DrawEllipse(PDFPen,PDFBrush,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFPen,PDFBrush,Double,Double,Double,Double) Method

pen
a PDFPen object used to draw the border of the ellipse.
brush
a PDFBrush object used to fill the interior of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawEllipse(pen, brush, left, top, width, height)
C#
public void DrawEllipse(
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: void DrawEllipse(
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
void DrawEllipse(
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
brush
a PDFBrush object used to fill the interior of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse(PDFPen,PDFBrush,Double,Double,Double,Double,Double) Method

DrawEllipse(PDFPen,PDFBrush,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFPen,PDFBrush,Double,Double,Double,Double,Double) Method

pen
a PDFPen object used to draw the border of the ellipse.
brush
a PDFBrush object used to fill the interior of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
rotation angle of the ellipse.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawEllipse(pen, brush, left, top, width, height, orientation)
C#
public void DrawEllipse(
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
Managed Extensions for C++
public: void DrawEllipse(
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
C++/CLI
public:
void DrawEllipse(
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
brush
a PDFBrush object used to fill the interior of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
rotation angle of the ellipse.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse(PDFPen,Double,Double,Double,Double) Method

DrawEllipse(PDFPen,Double,Double,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFPen,Double,Double,Double,Double) Method

pen
a PDFPen object used to draw the border of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawEllipse(pen, left, top, width, height)
C#
public void DrawEllipse(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: void DrawEllipse(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
void DrawEllipse(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse(PDFPen,Double,Double,Double,Double,Double) Method

DrawEllipse(PDFPen,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFPen,Double,Double,Double,Double,Double) Method

pen
a PDFPen object used to draw the border of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
rotation angle of the ellipse.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawEllipse(pen, left, top, width, height, orientation)
C#
public void DrawEllipse(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
Managed Extensions for C++
public: void DrawEllipse(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
C++/CLI
public:
void DrawEllipse(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
rotation angle of the ellipse.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse(PDFPen,RectangleF) Method

DrawEllipse(PDFPen,RectangleF) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFPen,RectangleF) Method

pen
a PDFPen object used to draw the border of the ellipse.
rect
a RectangleF structure specifying the bounding rectangle of the ellipse.
Draws an ellipse defined by a bounding rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse( _
   ByVal pen As PDFPen, _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim rect As RectangleF

instance.DrawEllipse(pen, rect)
C#
public void DrawEllipse(
   PDFPen pen,
   RectangleF rect
)
Managed Extensions for C++
public: void DrawEllipse(
   PDFPen* pen,
   RectangleF rect
)
C++/CLI
public:
void DrawEllipse(
   PDFPen^ pen,
   RectangleF rect
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
rect
a RectangleF structure specifying the bounding rectangle of the ellipse.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse(PDFBrush,Double,Double,Double,Double) Method

DrawEllipse(PDFBrush,Double,Double,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFBrush,Double,Double,Double,Double) Method

brush
a PDFBrush object used to fill the interior of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse( _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawEllipse(brush, left, top, width, height)
C#
public void DrawEllipse(
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: void DrawEllipse(
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
void DrawEllipse(
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height
)

Parameters

brush
a PDFBrush object used to fill the interior of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse(PDFBrush,Double,Double,Double,Double,Double) Method

DrawEllipse(PDFBrush,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFBrush,Double,Double,Double,Double,Double) Method

brush
a PDFBrush object used to fill the interior of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
rotation angle of the ellipse.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse( _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawEllipse(brush, left, top, width, height, orientation)
C#
public void DrawEllipse(
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
Managed Extensions for C++
public: void DrawEllipse(
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
C++/CLI
public:
void DrawEllipse(
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

brush
a PDFBrush object used to fill the interior of the ellipse.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
rotation angle of the ellipse.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse(PDFBrush,RectangleF) Method

DrawEllipse(PDFBrush,RectangleF) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFBrush,RectangleF) Method

brush
a PDFBrush object used to fill the interior of the ellipse.
rect
a RectangleF structure specifying the bounding rectangle of the ellipse.
Draws an ellipse defined by a bounding rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse( _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim rect As RectangleF

instance.DrawEllipse(brush, rect)
C#
public void DrawEllipse(
   PDFBrush brush,
   RectangleF rect
)
Managed Extensions for C++
public: void DrawEllipse(
   PDFBrush* brush,
   RectangleF rect
)
C++/CLI
public:
void DrawEllipse(
   PDFBrush^ brush,
   RectangleF rect
)

Parameters

brush
a PDFBrush object used to fill the interior of the ellipse.
rect
a RectangleF structure specifying the bounding rectangle of the ellipse.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawEllipse(PDFPen,PDFBrush,RectangleF) Method

DrawEllipse(PDFPen,PDFBrush,RectangleF) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawEllipse Method : DrawEllipse(PDFPen,PDFBrush,RectangleF) Method

pen
a PDFPen object used to draw the border of the ellipse.
brush
a PDFBrush object used to fill the interior of the ellipse.
rect
a RectangleF structure specifying the bounding rectangle of the ellipse.
Draws an ellipse defined by a bounding rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawEllipse( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF

instance.DrawEllipse(pen, brush, rect)
C#
public void DrawEllipse(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect
)
Managed Extensions for C++
public: void DrawEllipse(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect
)
C++/CLI
public:
void DrawEllipse(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect
)

Parameters

pen
a PDFPen object used to draw the border of the ellipse.
brush
a PDFBrush object used to fill the interior of the ellipse.
rect
a RectangleF structure specifying the bounding rectangle of the ellipse.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawFormXObject Method

DrawFormXObject Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawFormXObject Method

Draws a form XObject specified by a pair of coordinates, a width and a height.

Overload List

Overload | Description
DrawFormXObject(PDFFormXObject,Double,Double,Double,Double) | Draws a form XObject specified by a pair of coordinates, a width and a height.
DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,Double) | Draws a form XObject specified by a pair of coordinates, a width and a height and an orientation.
DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,PDFContentMirroring) | Draws a form XObject specified by a pair of coordinates, a width and a height and a mirroring mode.
DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,Double,PDFContentMirroring) | Draws a form XObject specified by a pair of coordinates, a width and a height and an orientation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawFormXObject(PDFFormXObject,Double,Double,Double,Double) Method

DrawFormXObject(PDFFormXObject,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawFormXObject Method : DrawFormXObject(PDFFormXObject,Double,Double,Double,Double) Method

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
Draws a form XObject specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawFormXObject( _
   ByVal formXObject As PDFFormXObject, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim formXObject As PDFFormXObject
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawFormXObject(formXObject, left, top, width, height)
C#
public void DrawFormXObject(
   PDFFormXObject formXObject,
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: void DrawFormXObject(
   PDFFormXObject* formXObject,
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
void DrawFormXObject(
   PDFFormXObject^ formXObject,
   double left,
   double top,
   double width,
   double height
)

Parameters

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.

Remarks

This function is used to draw a graphic block on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn graphic block are set by the corresponding parameters.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,Double) Method

DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawFormXObject Method : DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,Double) Method

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
orientation
the orientation of the graphic block when it is placed on the page.
Draws a form XObject specified by a pair of coordinates, a width and a height and an orientation.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawFormXObject( _
   ByVal formXObject As PDFFormXObject, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim formXObject As PDFFormXObject
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawFormXObject(formXObject, left, top, width, height, orientation)
C#
public void DrawFormXObject(
   PDFFormXObject formXObject,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
Managed Extensions for C++
public: void DrawFormXObject(
   PDFFormXObject* formXObject,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
C++/CLI
public:
void DrawFormXObject(
   PDFFormXObject^ formXObject,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
orientation
the orientation of the graphic block when it is placed on the page.

Remarks

This function is used to draw a graphic block on the canvas. The top left corner of the graphic block is placed at left,top coordinates. The graphic block content is scaled to fit the given width and height. The graphic block is rotated around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,PDFContentMirroring) Method

DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,PDFContentMirroring) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawFormXObject Method : DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,PDFContentMirroring) Method

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
contentMirroring
The mirroring mode of the form XObject content.
Draws a form XObject specified by a pair of coordinates, a width and a height and a mirroring mode.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawFormXObject( _
   ByVal formXObject As PDFFormXObject, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal contentMirroring As PDFContentMirroring _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim formXObject As PDFFormXObject
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim contentMirroring As PDFContentMirroring

instance.DrawFormXObject(formXObject, left, top, width, height, contentMirroring)
C#
public void DrawFormXObject(
   PDFFormXObject formXObject,
   double left,
   double top,
   double width,
   double height,
   PDFContentMirroring contentMirroring
)
Managed Extensions for C++
public: void DrawFormXObject(
   PDFFormXObject* formXObject,
   double left,
   double top,
   double width,
   double height,
   PDFContentMirroring contentMirroring
)
C++/CLI
public:
void DrawFormXObject(
   PDFFormXObject^ formXObject,
   double left,
   double top,
   double width,
   double height,
   PDFContentMirroring contentMirroring
)

Parameters

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
contentMirroring
The mirroring mode of the form XObject content.

Remarks

This function is used to draw a graphic block on the canvas. The top left corner of the graphic block is placed at left,top coordinates. The graphic block content is scaled to fit the given width and height. The content is mirrored according to contentMirroring parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,Double,PDFContentMirroring) Method

DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,Double,PDFContentMirroring) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawFormXObject Method : DrawFormXObject(PDFFormXObject,Double,Double,Double,Double,Double,PDFContentMirroring) Method

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
orientation
the orientation of the graphic block when it is placed on the page.
contentMirroring
The mirroring mode of the form XObject content.
Draws a form XObject specified by a pair of coordinates, a width and a height and an orientation.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawFormXObject( _
   ByVal formXObject As PDFFormXObject, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal contentMirroring As PDFContentMirroring _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim formXObject As PDFFormXObject
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim contentMirroring As PDFContentMirroring

instance.DrawFormXObject(formXObject, left, top, width, height, orientation, contentMirroring)
C#
public void DrawFormXObject(
   PDFFormXObject formXObject,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFContentMirroring contentMirroring
)
Managed Extensions for C++
public: void DrawFormXObject(
   PDFFormXObject* formXObject,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFContentMirroring contentMirroring
)
C++/CLI
public:
void DrawFormXObject(
   PDFFormXObject^ formXObject,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFContentMirroring contentMirroring
)

Parameters

formXObject
the form XObject.
left
the x coordinate of the top left corner of the graphic block when it is placed on the page.
top
the y coordinate of the top left corner of the graphic block when it is placed on the page.
width
the width of the graphic block when it is placed on the page.
height
the height of the graphic block when it is placed on the page.
orientation
the orientation of the graphic block when it is placed on the page.
contentMirroring
The mirroring mode of the form XObject content.

Remarks

This function is used to draw a graphic block on the canvas. The top left corner of the graphic block is placed at left,top coordinates. The graphic block content is scaled to fit the given width and height. The graphic block is rotated around the top left corner with a number of degrees specified by the orientation parameter. The content is mirrored according to contentMirroring parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLText Method

DrawHTMLText Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawHTMLText Method

Draws a line of text specified by a string and a pair of coordinates.

Overload List

Overload | Description
DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double) | Draws a line of text specified by a string and a pair of coordinates.
DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double) | Draws a line of text specified by a string and a pair of coordinates.
DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double,Double) | Draws a line of text specified by a string and a pair of coordinates.
DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double) | Draws a line of text specified by a string and a pair of coordinates.
DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double,Double,PDFTextAlign) | Draws a line of text specified by a string and a pair of coordinates.
DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,PDFTextAlign) | Draws a line of text specified by a string and a pair of coordinates.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double) Method

DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLText Method : DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim x As Double
Dim y As Double

instance.DrawHTMLText(text, font, brush, x, y)
C#
public void DrawHTMLText(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double x,
   double y
)
Managed Extensions for C++
public: void DrawHTMLText(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double x,
   double y
)
C++/CLI
public:
void DrawHTMLText(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double x,
   double y
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.

Remarks

The text may contain HTML tags for formatting.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double) Method

DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLText Method : DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Double
Dim y As Double

instance.DrawHTMLText(text, font, pen, brush, x, y)
C#
public void DrawHTMLText(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double x,
   double y
)
Managed Extensions for C++
public: void DrawHTMLText(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double x,
   double y
)
C++/CLI
public:
void DrawHTMLText(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double x,
   double y
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.

Remarks

The text may contain HTML tags for formatting.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double,Double) Method

DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLText Method : DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double,Double) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim x As Double
Dim y As Double
Dim orientation As Double

instance.DrawHTMLText(text, font, brush, x, y, orientation)
C#
public void DrawHTMLText(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double x,
   double y,
   double orientation
)
Managed Extensions for C++
public: void DrawHTMLText(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double x,
   double y,
   double orientation
)
C++/CLI
public:
void DrawHTMLText(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double x,
   double y,
   double orientation
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.

Remarks

The text is drawn rotated around the printing point with a number of degrees specified by the orientation parameter. The text may contain HTML tags for formatting.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double) Method

DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLText Method : DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Double
Dim y As Double
Dim orientation As Double

instance.DrawHTMLText(text, font, pen, brush, x, y, orientation)
C#
public void DrawHTMLText(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double x,
   double y,
   double orientation
)
Managed Extensions for C++
public: void DrawHTMLText(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double x,
   double y,
   double orientation
)
C++/CLI
public:
void DrawHTMLText(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double x,
   double y,
   double orientation
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.

Remarks

The text is drawn rotated around the printing point with a number of degrees specified by the orientation parameter. The text may contain HTML tags for formatting.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double,Double,PDFTextAlign) Method

DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double,Double,PDFTextAlign) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLText Method : DrawHTMLText(String,PDFFontBase,PDFBrush,Double,Double,Double,PDFTextAlign) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a PDFTextAlign enumeration member specifying the aligment of the text.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal orientation As Double, _
   ByVal align As PDFTextAlign _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim x As Double
Dim y As Double
Dim orientation As Double
Dim align As PDFTextAlign

instance.DrawHTMLText(text, font, brush, x, y, orientation, align)
C#
public void DrawHTMLText(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
Managed Extensions for C++
public: void DrawHTMLText(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
C++/CLI
public:
void DrawHTMLText(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a PDFTextAlign enumeration member specifying the aligment of the text.

Remarks

The text is drawn rotated around the printing point with a number of degrees specified by the orientation parameter. Also, the text is drawn aligned relative to the printing point. The text may contain HTML tags for formatting.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,PDFTextAlign) Method

DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,PDFTextAlign) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLText Method : DrawHTMLText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,PDFTextAlign) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a PDFTextAlign enumeration member specifying the aligment of the text.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal orientation As Double, _
   ByVal align As PDFTextAlign _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Double
Dim y As Double
Dim orientation As Double
Dim align As PDFTextAlign

instance.DrawHTMLText(text, font, pen, brush, x, y, orientation, align)
C#
public void DrawHTMLText(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
Managed Extensions for C++
public: void DrawHTMLText(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
C++/CLI
public:
void DrawHTMLText(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a PDFTextAlign enumeration member specifying the aligment of the text.

Remarks

The text is drawn rotated around the printing point with a number of degrees specified by the orientation parameter. Also, the text is drawn aligned relative to the printing point. The text may contain HTML tags for formatting.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLTextBox Method

DrawHTMLTextBox Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawHTMLTextBox Method

Draws a text specified by a string, a pair of coordinates, a width and a height.

Overload List

Overload | Description
DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions,Int32) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions,Int32) | Draws a text specified by a string, a pair of coordinates, a width and a height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double) Method

DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLTextBox Method : DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawHTMLTextBox(text, font, brush, left, top, width, height)
C#
public void DrawHTMLTextBox(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: void DrawHTMLTextBox(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
void DrawHTMLTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.

Remarks

The text is automatically wrapped to fit the width of the text box. The text supports HTML formatting tags.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double) Method

DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLTextBox Method : DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawHTMLTextBox(text, font, pen, brush, left, top, width, height)
C#
public void DrawHTMLTextBox(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: void DrawHTMLTextBox(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
void DrawHTMLTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.

Remarks

The text is automatically wrapped to fit the width of the text box. The text supports HTML formatting tags.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method

DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLTextBox Method : DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim textFormatOptions As PDFTextFormatOptions

instance.DrawHTMLTextBox(text, font, brush, left, top, width, height, textFormatOptions)
C#
public void DrawHTMLTextBox(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions textFormatOptions
)
Managed Extensions for C++
public: void DrawHTMLTextBox(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions* textFormatOptions
)
C++/CLI
public:
void DrawHTMLTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.

Remarks

The text is automatically wrapped to fit the width of the text box. The display of the text is controlled by the textFormatOptions parameter. The text supports HTML formatting tags.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method

DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLTextBox Method : DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim textFormatOptions As PDFTextFormatOptions

instance.DrawHTMLTextBox(text, font, pen, brush, left, top, width, height, textFormatOptions)
C#
public void DrawHTMLTextBox(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions textFormatOptions
)
Managed Extensions for C++
public: void DrawHTMLTextBox(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions* textFormatOptions
)
C++/CLI
public:
void DrawHTMLTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.

Remarks

The text is automatically wrapped to fit the width of the text box. The display of the text is controlled by the textFormatOptions parameter. The text supports HTML formatting tags.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions,Int32) Method

DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions,Int32) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLTextBox Method : DrawHTMLTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions,Int32) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions, _
   ByVal startDisplayFrom As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim textFormatOptions As PDFTextFormatOptions
Dim startDisplayFrom As Integer

instance.DrawHTMLTextBox(text, font, brush, left, top, width, height, textFormatOptions, startDisplayFrom)
C#
public void DrawHTMLTextBox(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions textFormatOptions,
   int startDisplayFrom
)
Managed Extensions for C++
public: void DrawHTMLTextBox(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions* textFormatOptions,
   int startDisplayFrom
)
C++/CLI
public:
void DrawHTMLTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions^ textFormatOptions,
   int startDisplayFrom
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.

Remarks

The text is automatically wrapped to fit the width of the text box. The display of the text is controlled by the textFormatOptions parameter. The text supports HTML formatting tags.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions,Int32) Method

DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions,Int32) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawHTMLTextBox Method : DrawHTMLTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions,Int32) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawHTMLTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions, _
   ByVal startDisplayFrom As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim textFormatOptions As PDFTextFormatOptions
Dim startDisplayFrom As Integer

instance.DrawHTMLTextBox(text, font, pen, brush, left, top, width, height, textFormatOptions, startDisplayFrom)
C#
public void DrawHTMLTextBox(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions textFormatOptions,
   int startDisplayFrom
)
Managed Extensions for C++
public: void DrawHTMLTextBox(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions* textFormatOptions,
   int startDisplayFrom
)
C++/CLI
public:
void DrawHTMLTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions^ textFormatOptions,
   int startDisplayFrom
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.
startDisplayFrom
An integer value representing the index within the text where the text to be displayed starts.

Remarks

The text is automatically wrapped to fit the width of the text box. The display of the text is controlled by the textFormatOptions parameter. The text supports HTML formatting tags.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage Method

DrawImage Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawImage Method

Draws an image specified by a file name, a pair of coordinates, a width and a height.

Overload List

Overload | Description
DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) | Draws an image specified by a file name, a pair of coordinates, a width and a height.
DrawImage(Stream,Double,Double,Double,Double) | Draws an image specified by a stream, a pair of coordinates, a width and a height.
DrawImage(Stream,Double,Double,Double,Double,Double) | Draws an image specified by a stream, a pair of coordinates, a width and a height.
DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio) | Draws an image specified by a stream, a pair of coordinates, a width and a height.
DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) | Draws an image specified by a stream, a pair of coordinates, a width and a height.
DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) | Draws an image specified by a stream, a pair of coordinates, a width and a height.
DrawImage(Bitmap,Double,Double,Double,Double) | Draws an image specified by a Bitmap object, a pair of coordinates, a width and a height.
DrawImage(Bitmap,Double,Double,Double,Double,Double) | Draws an image specified by a Bitmap object, a pair of coordinates, a width and a height.
DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio) | Draws an image specified by a Bitmap object, a pair of coordinates, a width and a height.
DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) | Draws an image specified by a Bitmap object, a pair of coordinates, a width and a height.
DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) | Draws an image specified by a Bitmap object, a pair of coordinates, a width and a height.
DrawImage(PDFImage,Double,Double,Double,Double) | Draws an image specified by an PDFImage object, a pair of coordinates, a width and a height.
DrawImage(PDFImage,Double,Double,Double,Double,Double) | Draws an image specified by an PDFImage object, a pair of coordinates, a width and a height.
DrawImage(PDFImage,Double,Double,Double,Double,Double,PDFKeepAspectRatio) | Draws an image specified by an PDFImage object, a pair of coordinates, a width and a height.
DrawImage(PDFImage,Double,Double,Double,Double,Double,PDFKeepAspectRatio,PDFContentMirroring) | Draws an image specified by an PDFImage object, a pair of coordinates, a width and a height.
DrawImage(String,Double,Double,Double,Double) | Draws an image specified by a file name, a pair of coordinates, a width and a height.
DrawImage(String,Double,Double,Double,Double,Double) | Draws an image specified by a file name, a pair of coordinates, a width and a height.
DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio) | Draws an image specified by a file name, a pair of coordinates, a width and a height.
DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) | Draws an image specified by a file name, a pair of coordinates, a width and a height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) Method

DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) Method

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.
compression
the compression method used to store image data in the PDF file.
Draws an image specified by a file name, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal fileName As String, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio, _
   ByVal activeFrame As Integer, _
   ByVal compression As PDFImageCompression _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim fileName As String
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim activeFrame As Integer
Dim compression As PDFImageCompression
Dim value As Double

value = instance.DrawImage(fileName, left, top, width, height, orientation, keepAspectRatio, activeFrame, compression)
C#
public double DrawImage(
   string fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)
Managed Extensions for C++
public: double DrawImage(
   string* fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)
C++/CLI
public:
double DrawImage(
   String^ fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)

Parameters

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.
compression
the compression method used to store image data in the PDF file.

Return Value

A double value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Stream,Double,Double,Double,Double) Method

DrawImage(Stream,Double,Double,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Stream,Double,Double,Double,Double) Method

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
Draws an image specified by a stream, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImage( _
   ByVal imageStream As Stream, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim imageStream As Stream
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawImage(imageStream, left, top, width, height)
C#
public void DrawImage(
   Stream imageStream,
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: void DrawImage(
   Stream* imageStream,
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
void DrawImage(
   Stream^ imageStream,
   double left,
   double top,
   double width,
   double height
)

Parameters

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Stream,Double,Double,Double,Double,Double) Method

DrawImage(Stream,Double,Double,Double,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Stream,Double,Double,Double,Double,Double) Method

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
Draws an image specified by a stream, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImage( _
   ByVal imageStream As Stream, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim imageStream As Stream
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawImage(imageStream, left, top, width, height, orientation)
C#
public void DrawImage(
   Stream imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
Managed Extensions for C++
public: void DrawImage(
   Stream* imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
C++/CLI
public:
void DrawImage(
   Stream^ imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method

DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
Draws an image specified by a stream, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal imageStream As Stream, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim imageStream As Stream
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim value As Double

value = instance.DrawImage(imageStream, left, top, width, height, orientation, keepAspectRatio)
C#
public double DrawImage(
   Stream imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)
Managed Extensions for C++
public: double DrawImage(
   Stream* imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)
C++/CLI
public:
double DrawImage(
   Stream^ imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)

Parameters

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) Method

DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) Method

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.
Draws an image specified by a stream, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal imageStream As Stream, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio, _
   ByVal activeFrame As Integer _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim imageStream As Stream
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim activeFrame As Integer
Dim value As Double

value = instance.DrawImage(imageStream, left, top, width, height, orientation, keepAspectRatio, activeFrame)
C#
public double DrawImage(
   Stream imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)
Managed Extensions for C++
public: double DrawImage(
   Stream* imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)
C++/CLI
public:
double DrawImage(
   Stream^ imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)

Parameters

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) Method

DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Stream,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) Method

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.
compression
the compression method used to store image data in the PDF file.
Draws an image specified by a stream, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal imageStream As Stream, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio, _
   ByVal activeFrame As Integer, _
   ByVal compression As PDFImageCompression _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim imageStream As Stream
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim activeFrame As Integer
Dim compression As PDFImageCompression
Dim value As Double

value = instance.DrawImage(imageStream, left, top, width, height, orientation, keepAspectRatio, activeFrame, compression)
C#
public double DrawImage(
   Stream imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)
Managed Extensions for C++
public: double DrawImage(
   Stream* imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)
C++/CLI
public:
double DrawImage(
   Stream^ imageStream,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)

Parameters

imageStream
a Stream object storing image data.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.
compression
the compression method used to store image data in the PDF file.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Bitmap,Double,Double,Double,Double) Method

DrawImage(Bitmap,Double,Double,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Bitmap,Double,Double,Double,Double) Method

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
Draws an image specified by a Bitmap object, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImage( _
   ByVal image As Bitmap, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim image As Bitmap
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawImage(image, left, top, width, height)
C#
public void DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: void DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
void DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height
)

Parameters

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Bitmap,Double,Double,Double,Double,Double) Method

DrawImage(Bitmap,Double,Double,Double,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Bitmap,Double,Double,Double,Double,Double) Method

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
Draws an image specified by a Bitmap object, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImage( _
   ByVal image As Bitmap, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim image As Bitmap
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawImage(image, left, top, width, height, orientation)
C#
public void DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
Managed Extensions for C++
public: void DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
C++/CLI
public:
void DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method

DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
Draws an image specified by a Bitmap object, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal image As Bitmap, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim image As Bitmap
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim value As Double

value = instance.DrawImage(image, left, top, width, height, orientation, keepAspectRatio)
C#
public double DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)
Managed Extensions for C++
public: double DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)
C++/CLI
public:
double DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)

Parameters

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) Method

DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) Method

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.
Draws an image specified by a Bitmap object, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal image As Bitmap, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio, _
   ByVal activeFrame As Integer _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim image As Bitmap
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim activeFrame As Integer
Dim value As Double

value = instance.DrawImage(image, left, top, width, height, orientation, keepAspectRatio, activeFrame)
C#
public double DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)
Managed Extensions for C++
public: double DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)
C++/CLI
public:
double DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)

Parameters

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) Method

DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(Bitmap,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32,PDFImageCompression) Method

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.
compression
the compression method used to store image data in the PDF file.
Draws an image specified by a Bitmap object, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal image As Bitmap, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio, _
   ByVal activeFrame As Integer, _
   ByVal compression As PDFImageCompression _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim image As Bitmap
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim activeFrame As Integer
Dim compression As PDFImageCompression
Dim value As Double

value = instance.DrawImage(image, left, top, width, height, orientation, keepAspectRatio, activeFrame, compression)
C#
public double DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)
Managed Extensions for C++
public: double DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)
C++/CLI
public:
double DrawImage(
   Bitmap image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame,
   PDFImageCompression compression
)

Parameters

image
a Image object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.
compression
the compression method used to store image data in the PDF file.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(PDFImage,Double,Double,Double,Double) Method

DrawImage(PDFImage,Double,Double,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(PDFImage,Double,Double,Double,Double) Method

image
a PDFImage object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
Draws an image specified by an PDFImage object, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImage( _
   ByVal image As PDFImage, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim image As PDFImage
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawImage(image, left, top, width, height)
C#
public void DrawImage(
   PDFImage image,
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: void DrawImage(
   PDFImage* image,
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
void DrawImage(
   PDFImage^ image,
   double left,
   double top,
   double width,
   double height
)

Parameters

image
a PDFImage object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(PDFImage,Double,Double,Double,Double,Double) Method

DrawImage(PDFImage,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(PDFImage,Double,Double,Double,Double,Double) Method

image
a PDFImage object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the rotation angle of the image.
Draws an image specified by an PDFImage object, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImage( _
   ByVal image As PDFImage, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim image As PDFImage
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawImage(image, left, top, width, height, orientation)
C#
public void DrawImage(
   PDFImage image,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
Managed Extensions for C++
public: void DrawImage(
   PDFImage* image,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
C++/CLI
public:
void DrawImage(
   PDFImage^ image,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

image
a PDFImage object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the rotation angle of the image.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(PDFImage,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method

DrawImage(PDFImage,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(PDFImage,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method

image
a PDFImage object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the rotation angle of the image.
keepAspectRatio
requested aspect ratio for the image.
Draws an image specified by an PDFImage object, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal image As PDFImage, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim image As PDFImage
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim value As Double

value = instance.DrawImage(image, left, top, width, height, orientation, keepAspectRatio)
C#
public double DrawImage(
   PDFImage image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)
Managed Extensions for C++
public: double DrawImage(
   PDFImage* image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)
C++/CLI
public:
double DrawImage(
   PDFImage^ image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)

Parameters

image
a PDFImage object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the rotation angle of the image.
keepAspectRatio
requested aspect ratio for the image.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio, or -1 if KeepNone or KeepBoth aspect ratio modes have been specified on the image.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.

Based on the KeepAspectRatio parameter the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(PDFImage,Double,Double,Double,Double,Double,PDFKeepAspectRatio,PDFContentMirroring) Method

DrawImage(PDFImage,Double,Double,Double,Double,Double,PDFKeepAspectRatio,PDFContentMirroring) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(PDFImage,Double,Double,Double,Double,Double,PDFKeepAspectRatio,PDFContentMirroring) Method

image
a PDFImage object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the rotation angle of the image.
keepAspectRatio
requested aspect ratio for the image.
contentMirroring
The mirroring mode of the image.
Draws an image specified by an PDFImage object, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal image As PDFImage, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio, _
   ByVal contentMirroring As PDFContentMirroring _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim image As PDFImage
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim contentMirroring As PDFContentMirroring
Dim value As Double

value = instance.DrawImage(image, left, top, width, height, orientation, keepAspectRatio, contentMirroring)
C#
public double DrawImage(
   PDFImage image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   PDFContentMirroring contentMirroring
)
Managed Extensions for C++
public: double DrawImage(
   PDFImage* image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   PDFContentMirroring contentMirroring
)
C++/CLI
public:
double DrawImage(
   PDFImage^ image,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   PDFContentMirroring contentMirroring
)

Parameters

image
a PDFImage object storing the image.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the rotation angle of the image.
keepAspectRatio
requested aspect ratio for the image.
contentMirroring
The mirroring mode of the image.

Return Value

A float value specifying the calculated image dimension, based on the requested aspect ratio, or -1 if KeepNone or KeepBoth aspect ratio modes have been specified on the image.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.

Based on the KeepAspectRatio parameter the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(String,Double,Double,Double,Double) Method

DrawImage(String,Double,Double,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(String,Double,Double,Double,Double) Method

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
Draws an image specified by a file name, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImage( _
   ByVal fileName As String, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim fileName As String
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawImage(fileName, left, top, width, height)
C#
public void DrawImage(
   string fileName,
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: void DrawImage(
   string* fileName,
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
void DrawImage(
   String^ fileName,
   double left,
   double top,
   double width,
   double height
)

Parameters

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(String,Double,Double,Double,Double,Double) Method

DrawImage(String,Double,Double,Double,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(String,Double,Double,Double,Double,Double) Method

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
Draws an image specified by a file name, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImage( _
   ByVal fileName As String, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim fileName As String
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawImage(fileName, left, top, width, height, orientation)
C#
public void DrawImage(
   string fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
Managed Extensions for C++
public: void DrawImage(
   string* fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
C++/CLI
public:
void DrawImage(
   String^ fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method

DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio) Method

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
Draws an image specified by a file name, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal fileName As String, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim fileName As String
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim value As Double

value = instance.DrawImage(fileName, left, top, width, height, orientation, keepAspectRatio)
C#
public double DrawImage(
   string fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)
Managed Extensions for C++
public: double DrawImage(
   string* fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)
C++/CLI
public:
double DrawImage(
   String^ fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio
)

Parameters

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.

Return Value

A double value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) Method

DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImage Method : DrawImage(String,Double,Double,Double,Double,Double,PDFKeepAspectRatio,Int32) Method

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.
Draws an image specified by a file name, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Function DrawImage( _
   ByVal fileName As String, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal keepAspectRatio As PDFKeepAspectRatio, _
   ByVal activeFrame As Integer _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim fileName As String
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim keepAspectRatio As PDFKeepAspectRatio
Dim activeFrame As Integer
Dim value As Double

value = instance.DrawImage(fileName, left, top, width, height, orientation, keepAspectRatio, activeFrame)
C#
public double DrawImage(
   string fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)
Managed Extensions for C++
public: double DrawImage(
   string* fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)
C++/CLI
public:
double DrawImage(
   String^ fileName,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFKeepAspectRatio keepAspectRatio,
   int activeFrame
)

Parameters

fileName
a full path to the image file.
left
the x coordinate of the top left corner of the image.
top
the y coordinate of the top left corner of the image.
width
the width of the image.
height
the height of the image.
orientation
the orientation of the image.
keepAspectRatio
a KeepAspectRatio enumeration member specifying how the original aspect ratio of the image should be handled.
activeFrame
the index of the frame within the image to be drawn on the page.

Return Value

A double value specifying the calculated image dimension, based on the requested aspect ratio.

Remarks

This function is used to draw an image on the canvas. The top left corner of the image is placed at left,top coordinates. The width and the height of the drawn images are set by the corresponding parameters. The image is rotated around the top left corner with a number of degrees specified by the orientation parameter. Depending on the keepAspectRatio parameter, the width or the height can be computed automatically.

Based on the keepAspectRatio parameter, the width or the height can be computed automatically. If KeepWidth is used, then the height is adjusted to obtain the original image ratio. The return of the function is the calculated height. If KeepHeight is used, then the width is adjusted to obtain the original image ratio. The return of the function is the calculated width. If KeepNone or KeepBoth are used, then the given width and height parameters are used. The return of the function is -1.

The following image formats are supported: jpeg, gif, bmp, png, emf.

The activeFrame parameter specifies the frame index within a multiframe image. When a multiframe image is requested to be drawn on the page, this index selects the frame within the image that will be drawn on the page. This property is used by images that include multiple images within the same file, like gif or tiff. The other supported image formats ignore this property. This index is zero based. If the frame does not exist in the image, then the first frame will be considered for display.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImportedContent Method

DrawImportedContent Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawImportedContent Method

Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.

Overload List

Overload | Description
DrawImportedContent(PDFImportedContent,Double,Double,Double,Double) | Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,Double) | Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,PDFContentMirroring) | Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.
DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,Double,PDFContentMirroring) | Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawImportedContent(PDFImportedContent,Double,Double,Double,Double) Method

DrawImportedContent(PDFImportedContent,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImportedContent Method : DrawImportedContent(PDFImportedContent,Double,Double,Double,Double) Method

importedContent
the imported content object.
left
the x coordinate of the top left corner of the imported content when it is placed on the page.
top
the y coordinate of the top left corner of the imported content when it is placed on the page.
width
the width of the imported content when it is placed on the page.
height
the height of the imported content when it is placed on the page.
Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImportedContent( _
   ByVal importedContent As PDFImportedContent, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim importedContent As PDFImportedContent
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawImportedContent(importedContent, left, top, width, height)
C#
public void DrawImportedContent(
   PDFImportedContent importedContent,
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: void DrawImportedContent(
   PDFImportedContent* importedContent,
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
void DrawImportedContent(
   PDFImportedContent^ importedContent,
   double left,
   double top,
   double width,
   double height
)

Parameters

importedContent
the imported content object.
left
the x coordinate of the top left corner of the imported content when it is placed on the page.
top
the y coordinate of the top left corner of the imported content when it is placed on the page.
width
the width of the imported content when it is placed on the page.
height
the height of the imported content when it is placed on the page.

Remarks

This function is used to draw the content of an imported page on current canvas. The content is scaled to fit the given width and height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,Double) Method

DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImportedContent Method : DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,Double) Method

importedContent
the imported content object.
left
the x coordinate of the top left corner of the imported content when it is placed on the page.
top
the y coordinate of the top left corner of the imported content when it is placed on the page.
width
the width of the imported content when it is placed on the page.
height
the height of the imported content when it is placed on the page.
orientation
The orientation angle of the imported content.
Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImportedContent( _
   ByVal importedContent As PDFImportedContent, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim importedContent As PDFImportedContent
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawImportedContent(importedContent, left, top, width, height, orientation)
C#
public void DrawImportedContent(
   PDFImportedContent importedContent,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
Managed Extensions for C++
public: void DrawImportedContent(
   PDFImportedContent* importedContent,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
C++/CLI
public:
void DrawImportedContent(
   PDFImportedContent^ importedContent,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

importedContent
the imported content object.
left
the x coordinate of the top left corner of the imported content when it is placed on the page.
top
the y coordinate of the top left corner of the imported content when it is placed on the page.
width
the width of the imported content when it is placed on the page.
height
the height of the imported content when it is placed on the page.
orientation
The orientation angle of the imported content.

Remarks

This function is used to draw the content of an imported page on current canvas. The content is scaled to fit the given width and height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,PDFContentMirroring) Method

DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,PDFContentMirroring) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImportedContent Method : DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,PDFContentMirroring) Method

importedContent
the imported content object.
left
the x coordinate of the top left corner of the imported content when it is placed on the page.
top
the y coordinate of the top left corner of the imported content when it is placed on the page.
width
the width of the imported content when it is placed on the page.
height
the height of the imported content when it is placed on the page.
contentMirroring
The mirroring mode of the imported content.
Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImportedContent( _
   ByVal importedContent As PDFImportedContent, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal contentMirroring As PDFContentMirroring _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim importedContent As PDFImportedContent
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim contentMirroring As PDFContentMirroring

instance.DrawImportedContent(importedContent, left, top, width, height, contentMirroring)
C#
public void DrawImportedContent(
   PDFImportedContent importedContent,
   double left,
   double top,
   double width,
   double height,
   PDFContentMirroring contentMirroring
)
Managed Extensions for C++
public: void DrawImportedContent(
   PDFImportedContent* importedContent,
   double left,
   double top,
   double width,
   double height,
   PDFContentMirroring contentMirroring
)
C++/CLI
public:
void DrawImportedContent(
   PDFImportedContent^ importedContent,
   double left,
   double top,
   double width,
   double height,
   PDFContentMirroring contentMirroring
)

Parameters

importedContent
the imported content object.
left
the x coordinate of the top left corner of the imported content when it is placed on the page.
top
the y coordinate of the top left corner of the imported content when it is placed on the page.
width
the width of the imported content when it is placed on the page.
height
the height of the imported content when it is placed on the page.
contentMirroring
The mirroring mode of the imported content.

Remarks

This function is used to draw the content of an imported page on current canvas. The content is scaled to fit the given width and height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,Double,PDFContentMirroring) Method

DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,Double,PDFContentMirroring) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawImportedContent Method : DrawImportedContent(PDFImportedContent,Double,Double,Double,Double,Double,PDFContentMirroring) Method

importedContent
the imported content object.
left
the x coordinate of the top left corner of the imported content when it is placed on the page.
top
the y coordinate of the top left corner of the imported content when it is placed on the page.
width
the width of the imported content when it is placed on the page.
height
the height of the imported content when it is placed on the page.
orientation
The orientation angle of the imported content.
contentMirroring
The mirroring mode of the imported content.
Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawImportedContent( _
   ByVal importedContent As PDFImportedContent, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal contentMirroring As PDFContentMirroring _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim importedContent As PDFImportedContent
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim contentMirroring As PDFContentMirroring

instance.DrawImportedContent(importedContent, left, top, width, height, orientation, contentMirroring)
C#
public void DrawImportedContent(
   PDFImportedContent importedContent,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFContentMirroring contentMirroring
)
Managed Extensions for C++
public: void DrawImportedContent(
   PDFImportedContent* importedContent,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFContentMirroring contentMirroring
)
C++/CLI
public:
void DrawImportedContent(
   PDFImportedContent^ importedContent,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFContentMirroring contentMirroring
)

Parameters

importedContent
the imported content object.
left
the x coordinate of the top left corner of the imported content when it is placed on the page.
top
the y coordinate of the top left corner of the imported content when it is placed on the page.
width
the width of the imported content when it is placed on the page.
height
the height of the imported content when it is placed on the page.
orientation
The orientation angle of the imported content.
contentMirroring
The mirroring mode of the imported content.

Remarks

This function is used to draw the content of an imported page on current canvas. The content is scaled to fit the given width and height and it is rotated around the top left corner with a number of degrees specified by the orientation parameter. The content is mirrored according to contentMirroring parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawLine Method

DrawLine Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawLine Method

Draws a line connecting two points specified by coordinate pairs using the specified pen.

Supported by Compact .NET Edition.

Overload List

Overload | Description
DrawLine(PDFPen,Double,Double,Double,Double) | Draws a line connecting two points specified by coordinate pairs using the specified pen. Supported by Compact .NET Edition.
DrawLine(PDFPen,PointF,PointF) | Draws a line connecting two points specified by PointF structures using the specified pen.
DrawLine(PDFPen,PDFPoint,PDFPoint) | Draws a line connecting two points specified by Point structures using the specified pen.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawLine(PDFPen,Double,Double,Double,Double) Method

DrawLine(PDFPen,Double,Double,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawLine Method : DrawLine(PDFPen,Double,Double,Double,Double) Method

pen
a PDFPen object used to draw the line.
x1
x coordinate of the beginning of the line.
y1
y coordinate of the beginning of the line.
x2
x coordinate of the end of the line.
y2
y coordinate of the end of the line.
Draws a line connecting two points specified by coordinate pairs using the specified pen.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawLine( _
   ByVal pen As PDFPen, _
   ByVal x1 As Double, _
   ByVal y1 As Double, _
   ByVal x2 As Double, _
   ByVal y2 As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim x1 As Double
Dim y1 As Double
Dim x2 As Double
Dim y2 As Double

instance.DrawLine(pen, x1, y1, x2, y2)
C#
public void DrawLine(
   PDFPen pen,
   double x1,
   double y1,
   double x2,
   double y2
)
Managed Extensions for C++
public: void DrawLine(
   PDFPen* pen,
   double x1,
   double y1,
   double x2,
   double y2
)
C++/CLI
public:
void DrawLine(
   PDFPen^ pen,
   double x1,
   double y1,
   double x2,
   double y2
)

Parameters

pen
a PDFPen object used to draw the line.
x1
x coordinate of the beginning of the line.
y1
y coordinate of the beginning of the line.
x2
x coordinate of the end of the line.
y2
y coordinate of the end of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawLine(PDFPen,PointF,PointF) Method

DrawLine(PDFPen,PointF,PointF) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawLine Method : DrawLine(PDFPen,PointF,PointF) Method

pen
a PDFPen object used to draw the line.
pt1
a PointF structure specifying the beginning of the line.
pt2
a PointF structure specifying the end of the line.
Draws a line connecting two points specified by PointF structures using the specified pen.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawLine( _
   ByVal pen As PDFPen, _
   ByVal pt1 As PointF, _
   ByVal pt2 As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim pt1 As PointF
Dim pt2 As PointF

instance.DrawLine(pen, pt1, pt2)
C#
public void DrawLine(
   PDFPen pen,
   PointF pt1,
   PointF pt2
)
Managed Extensions for C++
public: void DrawLine(
   PDFPen* pen,
   PointF pt1,
   PointF pt2
)
C++/CLI
public:
void DrawLine(
   PDFPen^ pen,
   PointF pt1,
   PointF pt2
)

Parameters

pen
a PDFPen object used to draw the line.
pt1
a PointF structure specifying the beginning of the line.
pt2
a PointF structure specifying the end of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawLine(PDFPen,PDFPoint,PDFPoint) Method

DrawLine(PDFPen,PDFPoint,PDFPoint) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawLine Method : DrawLine(PDFPen,PDFPoint,PDFPoint) Method

pen
a PDFPen object used to draw the line.
pt1
a PDFPoint structure specifying the beginning of the line.
pt2
a PDFPoint structure specifying the end of the line.
Draws a line connecting two points specified by Point structures using the specified pen.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawLine( _
   ByVal pen As PDFPen, _
   ByVal pt1 As PDFPoint, _
   ByVal pt2 As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim pt1 As PDFPoint
Dim pt2 As PDFPoint

instance.DrawLine(pen, pt1, pt2)
C#
public void DrawLine(
   PDFPen pen,
   PDFPoint pt1,
   PDFPoint pt2
)
Managed Extensions for C++
public: void DrawLine(
   PDFPen* pen,
   PDFPoint* pt1,
   PDFPoint* pt2
)
C++/CLI
public:
void DrawLine(
   PDFPen^ pen,
   PDFPoint^ pt1,
   PDFPoint^ pt2
)

Parameters

pen
a PDFPen object used to draw the line.
pt1
a PDFPoint structure specifying the beginning of the line.
pt2
a PDFPoint structure specifying the end of the line.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawLines Method

DrawLines Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawLines Method

Draws a series of line segments that connect an array of PointF structures.

Overload List

Overload | Description
DrawLines(PDFPen,PointF[]) | Draws a series of line segments that connect an array of PointF structures.
DrawLines(PDFPen,PDFPoint[]) | Draws a series of line segments that connect an array of PDFPoint objects. Supported by Compact .NET Edition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawLines(PDFPen,PointF[]) Method

DrawLines(PDFPen,PointF[]) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawLines Method : DrawLines(PDFPen,PointF[]) Method

pen
a PDFPen object used to draw the lines.
points
an array of PointF structures specifying the coordinates of the lines.
Draws a series of line segments that connect an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawLines( _
   ByVal pen As PDFPen, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PointF

instance.DrawLines(pen, points)
C#
public void DrawLines(
   PDFPen pen,
   PointF[] points
)
Managed Extensions for C++
public: void DrawLines(
   PDFPen* pen,
   PointF[]* points
)
C++/CLI
public:
void DrawLines(
   PDFPen^ pen,
   array<PointF>^ points
)

Parameters

pen
a PDFPen object used to draw the lines.
points
an array of PointF structures specifying the coordinates of the lines.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawLines(PDFPen,PDFPoint[]) Method

DrawLines(PDFPen,PDFPoint[]) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawLines Method : DrawLines(PDFPen,PDFPoint[]) Method

pen
a PDFPen object used to draw the lines.
points
an array of PDFPoint objects specifying the coordinates of the lines.
Draws a series of line segments that connect an array of PDFPoint objects.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawLines( _
   ByVal pen As PDFPen, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PDFPoint

instance.DrawLines(pen, points)
C#
public void DrawLines(
   PDFPen pen,
   PDFPoint[] points
)
Managed Extensions for C++
public: void DrawLines(
   PDFPen* pen,
   PDFPoint*[]* points
)
C++/CLI
public:
void DrawLines(
   PDFPen^ pen,
   array<PDFPoint^>^ points
)

Parameters

pen
a PDFPen object used to draw the lines.
points
an array of PDFPoint objects specifying the coordinates of the lines.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPath Method

DrawPath Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawPath Method

Draws a PDFPath object with the specified pen.

Overload List

Overload | Description
DrawPath(PDFPen,PDFPath) | Draws a PDFPath object with the specified pen.
DrawPath(PDFBrush,PDFPath) | Draws a PDFPath object with the specified brush.
DrawPath(PDFBrush,PDFPath,PDFFillMode) | Draws a PDFPath object with the specified brush.
DrawPath(PDFPen,PDFBrush,PDFPath) | Draws a PDFPath object with the specified pen and brush.
DrawPath(PDFPen,PDFBrush,PDFPath,PDFFillMode) | Draws a PDFPath object with the specified pen and brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawPath(PDFPen,PDFPath) Method

DrawPath(PDFPen,PDFPath) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPath Method : DrawPath(PDFPen,PDFPath) Method

pen
A PDFPen object used to stroke the path.
path
A PDFPath object to be drawn on the canvas.
Draws a PDFPath object with the specified pen.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPath( _
   ByVal pen As PDFPen, _
   ByVal path As PDFPath _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim path As PDFPath

instance.DrawPath(pen, path)
C#
public void DrawPath(
   PDFPen pen,
   PDFPath path
)
Managed Extensions for C++
public: void DrawPath(
   PDFPen* pen,
   PDFPath* path
)
C++/CLI
public:
void DrawPath(
   PDFPen^ pen,
   PDFPath^ path
)

Parameters

pen
A PDFPen object used to stroke the path.
path
A PDFPath object to be drawn on the canvas.

Remarks

This function strokes a user defined path.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPath(PDFBrush,PDFPath) Method

DrawPath(PDFBrush,PDFPath) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPath Method : DrawPath(PDFBrush,PDFPath) Method

brush
A PDFBrush object used to fill the interior of the path.
path
A PDFPath object to be drawn on the canvas.
Draws a PDFPath object with the specified brush.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPath( _
   ByVal brush As PDFBrush, _
   ByVal path As PDFPath _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim path As PDFPath

instance.DrawPath(brush, path)
C#
public void DrawPath(
   PDFBrush brush,
   PDFPath path
)
Managed Extensions for C++
public: void DrawPath(
   PDFBrush* brush,
   PDFPath* path
)
C++/CLI
public:
void DrawPath(
   PDFBrush^ brush,
   PDFPath^ path
)

Parameters

brush
A PDFBrush object used to fill the interior of the path.
path
A PDFPath object to be drawn on the canvas.

Remarks

This function strokes and fill a user defined path.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPath(PDFBrush,PDFPath,PDFFillMode) Method

DrawPath(PDFBrush,PDFPath,PDFFillMode) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPath Method : DrawPath(PDFBrush,PDFPath,PDFFillMode) Method

brush
A PDFBrush object used to fill the interior of the path.
path
A PDFPath object to be drawn on the canvas.
fillMode
The fill mode of the path.
Draws a PDFPath object with the specified brush.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPath( _
   ByVal brush As PDFBrush, _
   ByVal path As PDFPath, _
   ByVal fillMode As PDFFillMode _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim path As PDFPath
Dim fillMode As PDFFillMode

instance.DrawPath(brush, path, fillMode)
C#
public void DrawPath(
   PDFBrush brush,
   PDFPath path,
   PDFFillMode fillMode
)
Managed Extensions for C++
public: void DrawPath(
   PDFBrush* brush,
   PDFPath* path,
   PDFFillMode fillMode
)
C++/CLI
public:
void DrawPath(
   PDFBrush^ brush,
   PDFPath^ path,
   PDFFillMode fillMode
)

Parameters

brush
A PDFBrush object used to fill the interior of the path.
path
A PDFPath object to be drawn on the canvas.
fillMode
The fill mode of the path.

Remarks

This function strokes and fill a user defined path.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPath(PDFPen,PDFBrush,PDFPath) Method

DrawPath(PDFPen,PDFBrush,PDFPath) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPath Method : DrawPath(PDFPen,PDFBrush,PDFPath) Method

pen
A PDFPen object used to stroke the path.
brush
A PDFBrush object used to fill the interior of the path.
path
A PDFPath object to be drawn on the canvas.
Draws a PDFPath object with the specified pen and brush.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPath( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal path As PDFPath _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim path As PDFPath

instance.DrawPath(pen, brush, path)
C#
public void DrawPath(
   PDFPen pen,
   PDFBrush brush,
   PDFPath path
)
Managed Extensions for C++
public: void DrawPath(
   PDFPen* pen,
   PDFBrush* brush,
   PDFPath* path
)
C++/CLI
public:
void DrawPath(
   PDFPen^ pen,
   PDFBrush^ brush,
   PDFPath^ path
)

Parameters

pen
A PDFPen object used to stroke the path.
brush
A PDFBrush object used to fill the interior of the path.
path
A PDFPath object to be drawn on the canvas.

Remarks

This function strokes and fill a user defined path.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPath(PDFPen,PDFBrush,PDFPath,PDFFillMode) Method

DrawPath(PDFPen,PDFBrush,PDFPath,PDFFillMode) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPath Method : DrawPath(PDFPen,PDFBrush,PDFPath,PDFFillMode) Method

pen
A PDFPen object used to stroke the path.
brush
A PDFBrush object used to fill the interior of the path.
path
A PDFPath object to be drawn on the canvas.
fillMode
The fill mode of the path.
Draws a PDFPath object with the specified pen and brush.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPath( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal path As PDFPath, _
   ByVal fillMode As PDFFillMode _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim path As PDFPath
Dim fillMode As PDFFillMode

instance.DrawPath(pen, brush, path, fillMode)
C#
public void DrawPath(
   PDFPen pen,
   PDFBrush brush,
   PDFPath path,
   PDFFillMode fillMode
)
Managed Extensions for C++
public: void DrawPath(
   PDFPen* pen,
   PDFBrush* brush,
   PDFPath* path,
   PDFFillMode fillMode
)
C++/CLI
public:
void DrawPath(
   PDFPen^ pen,
   PDFBrush^ brush,
   PDFPath^ path,
   PDFFillMode fillMode
)

Parameters

pen
A PDFPen object used to stroke the path.
brush
A PDFBrush object used to fill the interior of the path.
path
A PDFPath object to be drawn on the canvas.
fillMode
The fill mode of the path.

Remarks

This function strokes and fill a user defined path.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPie Method

DrawPie Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawPie Method

Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.

Overload List

Overload | Description
DrawPie(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) | Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
DrawPie(PDFBrush,Double,Double,Double,Double,Double,Double) | Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
DrawPie(PDFPen,Double,Double,Double,Double,Double,Double) | Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.
DrawPie(PDFPen,RectangleF,Double,Double) | Draws a pie representing a closed portion of an circle specified by a RectangleF structure.
DrawPie(PDFBrush,RectangleF,Double,Double) | Draws a pie representing a closed portion of an circle specified by a RectangleF structure.
DrawPie(PDFPen,PDFBrush,RectangleF,Double,Double) | Draws a pie representing a closed portion of an circle specified by a RectangleF structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawPie(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) Method

DrawPie(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) Method

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPie( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawPie(pen, brush, left, top, width, height, startAngle, sweepAngle)
C#
public void DrawPie(
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
Managed Extensions for C++
public: void DrawPie(
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
C++/CLI
public:
void DrawPie(
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
the height of the rectangle
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPie(PDFBrush,Double,Double,Double,Double,Double,Double) Method

DrawPie(PDFBrush,Double,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFBrush,Double,Double,Double,Double,Double,Double) Method

brush
a PDFBrush object used to fill the interior of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPie( _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawPie(brush, left, top, width, height, startAngle, sweepAngle)
C#
public void DrawPie(
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
Managed Extensions for C++
public: void DrawPie(
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
C++/CLI
public:
void DrawPie(
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

brush
a PDFBrush object used to fill the interior of the pie.
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPie(PDFPen,Double,Double,Double,Double,Double,Double) Method

DrawPie(PDFPen,Double,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFPen,Double,Double,Double,Double,Double,Double) Method

pen
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPie( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawPie(pen, left, top, width, height, startAngle, sweepAngle)
C#
public void DrawPie(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
Managed Extensions for C++
public: void DrawPie(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)
C++/CLI
public:
void DrawPie(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height,
   double startAngle,
   double sweepAngle
)

Parameters

pen
left
the x coordinate of the top left corner of the bounding rectangle.
top
the y coordinate of the top left corner of the bounding rectangle.
width
the width of the rectangle.
height
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPie(PDFPen,RectangleF,Double,Double) Method

DrawPie(PDFPen,RectangleF,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFPen,RectangleF,Double,Double) Method

pen
a PDFPen object used to draw the border of the pie.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPie( _
   ByVal pen As PDFPen, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim rect As RectangleF
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawPie(pen, rect, startAngle, sweepAngle)
C#
public void DrawPie(
   PDFPen pen,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
Managed Extensions for C++
public: void DrawPie(
   PDFPen* pen,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
C++/CLI
public:
void DrawPie(
   PDFPen^ pen,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle. Although, a different width and height can be specified in the RectangleF structure, internally, these two values are made equal.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPie(PDFBrush,RectangleF,Double,Double) Method

DrawPie(PDFBrush,RectangleF,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFBrush,RectangleF,Double,Double) Method

brush
a PDFBrush object used to fill the interior of the pie.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPie( _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim rect As RectangleF
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawPie(brush, rect, startAngle, sweepAngle)
C#
public void DrawPie(
   PDFBrush brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
Managed Extensions for C++
public: void DrawPie(
   PDFBrush* brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
C++/CLI
public:
void DrawPie(
   PDFBrush^ brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)

Parameters

brush
a PDFBrush object used to fill the interior of the pie.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle. Although, a different width and height can be specified in the RectangleF structure, internally, these two values are made equal.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPie(PDFPen,PDFBrush,RectangleF,Double,Double) Method

DrawPie(PDFPen,PDFBrush,RectangleF,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPie Method : DrawPie(PDFPen,PDFBrush,RectangleF,Double,Double) Method

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.
Draws a pie representing a closed portion of an circle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPie( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal startAngle As Double, _
   ByVal sweepAngle As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF
Dim startAngle As Double
Dim sweepAngle As Double

instance.DrawPie(pen, brush, rect, startAngle, sweepAngle)
C#
public void DrawPie(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
Managed Extensions for C++
public: void DrawPie(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)
C++/CLI
public:
void DrawPie(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect,
   double startAngle,
   double sweepAngle
)

Parameters

pen
a PDFPen object used to draw the border of the pie.
brush
a PDFBrush object used to fill the interior of the pie.
rect
a RectangleF structure specifying the bounding rectangle of the circle.
startAngle
angle in degrees measured counterclockwise from the x-axis to the starting point of the pie.
sweepAngle
angle in degrees measured counterclockwise from the startAngle parameter to ending point of the pie.

Remarks

The height of the bounding rectangle is always equal to the width of the rectangle. Although, a different width and height can be specified in the RectangleF structure, internally, these two values are made equal.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyBezier Method

DrawPolyBezier Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawPolyBezier Method

Draws a series of connected curves defined by an array of PointF structures.

Overload List

Overload | Description
DrawPolyBezier(PDFPen,PointF[]) | Draws a series of connected curves defined by an array of PointF structures.
DrawPolyBezier(PDFPen,PDFPoint[]) | Draws a series of connected curves defined by an array of PDFPoint objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawPolyBezier(PDFPen,PointF[]) Method

DrawPolyBezier(PDFPen,PointF[]) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyBezier Method : DrawPolyBezier(PDFPen,PointF[]) Method

pen
A PDFPen object used to draw the curves.
points
An array of PointF structures specifying the coordinates of the control points.
Draws a series of connected curves defined by an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyBezier( _
   ByVal pen As PDFPen, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PointF

instance.DrawPolyBezier(pen, points)
C#
public void DrawPolyBezier(
   PDFPen pen,
   PointF[] points
)
Managed Extensions for C++
public: void DrawPolyBezier(
   PDFPen* pen,
   PointF[]* points
)
C++/CLI
public:
void DrawPolyBezier(
   PDFPen^ pen,
   array<PointF>^ points
)

Parameters

pen
A PDFPen object used to draw the curves.
points
An array of PointF structures specifying the coordinates of the control points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyBezier(PDFPen,PDFPoint[]) Method

DrawPolyBezier(PDFPen,PDFPoint[]) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyBezier Method : DrawPolyBezier(PDFPen,PDFPoint[]) Method

pen
A PDFPen object used to draw the curves.
points
An array of PDFPoint structures specifying the coordinates of the control points.
Draws a series of connected curves defined by an array of PDFPoint objects.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyBezier( _
   ByVal pen As PDFPen, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PDFPoint

instance.DrawPolyBezier(pen, points)
C#
public void DrawPolyBezier(
   PDFPen pen,
   PDFPoint[] points
)
Managed Extensions for C++
public: void DrawPolyBezier(
   PDFPen* pen,
   PDFPoint*[]* points
)
C++/CLI
public:
void DrawPolyBezier(
   PDFPen^ pen,
   array<PDFPoint^>^ points
)

Parameters

pen
A PDFPen object used to draw the curves.
points
An array of PDFPoint structures specifying the coordinates of the control points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon Method

DrawPolygon Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawPolygon Method

Draws a polygon defined by an array of PDFPoint objects.

Overload List

Overload | Description
DrawPolygon(PDFPen,PDFBrush,PDFPoint[],PDFFillMode) | Draws a polygon defined by an array of PDFPoint objects.
DrawPolygon(PDFPen,PDFBrush,PDFPoint[]) | Draws a polygon defined by an array of PDFPoint objects.
DrawPolygon(PDFPen,PDFPoint[]) | Draws a polygon defined by an array of PDFPoint objects.
DrawPolygon(PDFBrush,PDFPoint[]) | Draws a polygon defined by an array of PDFPoint objects.
DrawPolygon(PDFBrush,PDFPoint[],PDFFillMode) | Draws a polygon defined by an array of PDFPoint objects.
DrawPolygon(PDFPen,PointF[]) | Draws a polygon defined by an array of PointF structures.
DrawPolygon(PDFBrush,PointF[]) | Draws a polygon defined by an array of PointF structures.
DrawPolygon(PDFBrush,PointF[],PDFFillMode) | Draws a polygon defined by an array of PointF structures.
DrawPolygon(PDFPen,PDFBrush,PointF[]) | Draws a polygon defined by an array of PointF structures.
DrawPolygon(PDFPen,PDFBrush,PointF[],PDFFillMode) | Draws a polygon defined by an array of PointF structures.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawPolygon(PDFPen,PDFBrush,PDFPoint[],PDFFillMode) Method

DrawPolygon(PDFPen,PDFBrush,PDFPoint[],PDFFillMode) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFPen,PDFBrush,PDFPoint[],PDFFillMode) Method

pen
a PDFPen object used to draw the border of the polygon.
brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PDFPoint objects specifying the coordinates of polygon's corners.
fillMode
The fill mode for the polygon.
Draws a polygon defined by an array of PDFPoint objects.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint, _
   ByVal fillMode As PDFFillMode _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PDFPoint
Dim fillMode As PDFFillMode

instance.DrawPolygon(pen, brush, points, fillMode)
C#
public void DrawPolygon(
   PDFPen pen,
   PDFBrush brush,
   PDFPoint[] points,
   PDFFillMode fillMode
)
Managed Extensions for C++
public: void DrawPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PDFPoint*[]* points,
   PDFFillMode fillMode
)
C++/CLI
public:
void DrawPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PDFPoint^>^ points,
   PDFFillMode fillMode
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PDFPoint objects specifying the coordinates of polygon's corners.
fillMode
The fill mode for the polygon.

Remarks

This function draws a polygon defined by an array of PDFPoint objects. The border of the polygon is drawn using the pen, and the interior is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFPen,PDFBrush,PDFPoint[]) Method

DrawPolygon(PDFPen,PDFBrush,PDFPoint[]) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFPen,PDFBrush,PDFPoint[]) Method

pen
a PDFPen object used to draw the border of the polygon.
brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PDFPoint objects specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PDFPoint objects.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PDFPoint

instance.DrawPolygon(pen, brush, points)
C#
public void DrawPolygon(
   PDFPen pen,
   PDFBrush brush,
   PDFPoint[] points
)
Managed Extensions for C++
public: void DrawPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PDFPoint*[]* points
)
C++/CLI
public:
void DrawPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PDFPoint^>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PDFPoint objects specifying the coordinates of polygon's corners.

Remarks

This function draws a polygon defined by an array of PDFPoint objects. The border of the polygon is drawn using the pen, and the interior is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFPen,PDFPoint[]) Method

DrawPolygon(PDFPen,PDFPoint[]) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFPen,PDFPoint[]) Method

pen
a PDFPen object used to draw the border of the polygon.
points
an array of PDFPoint objects specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PDFPoint objects.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolygon( _
   ByVal pen As PDFPen, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PDFPoint

instance.DrawPolygon(pen, points)
C#
public void DrawPolygon(
   PDFPen pen,
   PDFPoint[] points
)
Managed Extensions for C++
public: void DrawPolygon(
   PDFPen* pen,
   PDFPoint*[]* points
)
C++/CLI
public:
void DrawPolygon(
   PDFPen^ pen,
   array<PDFPoint^>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
points
an array of PDFPoint objects specifying the coordinates of polygon's corners.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFBrush,PDFPoint[]) Method

DrawPolygon(PDFBrush,PDFPoint[]) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFBrush,PDFPoint[]) Method

brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PDFPoint objects specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PDFPoint objects.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PDFPoint

instance.DrawPolygon(brush, points)
C#
public void DrawPolygon(
   PDFBrush brush,
   PDFPoint[] points
)
Managed Extensions for C++
public: void DrawPolygon(
   PDFBrush* brush,
   PDFPoint*[]* points
)
C++/CLI
public:
void DrawPolygon(
   PDFBrush^ brush,
   array<PDFPoint^>^ points
)

Parameters

brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PDFPoint objects specifying the coordinates of polygon's corners.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFBrush,PDFPoint[],PDFFillMode) Method

DrawPolygon(PDFBrush,PDFPoint[],PDFFillMode) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFBrush,PDFPoint[],PDFFillMode) Method

brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PDFPoint objects specifying the coordinates of polygon's corners.
fillMode
The fill mode of the polygon.
Draws a polygon defined by an array of PDFPoint objects.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint, _
   ByVal fillMode As PDFFillMode _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PDFPoint
Dim fillMode As PDFFillMode

instance.DrawPolygon(brush, points, fillMode)
C#
public void DrawPolygon(
   PDFBrush brush,
   PDFPoint[] points,
   PDFFillMode fillMode
)
Managed Extensions for C++
public: void DrawPolygon(
   PDFBrush* brush,
   PDFPoint*[]* points,
   PDFFillMode fillMode
)
C++/CLI
public:
void DrawPolygon(
   PDFBrush^ brush,
   array<PDFPoint^>^ points,
   PDFFillMode fillMode
)

Parameters

brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PDFPoint objects specifying the coordinates of polygon's corners.
fillMode
The fill mode of the polygon.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFPen,PointF[]) Method

DrawPolygon(PDFPen,PointF[]) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFPen,PointF[]) Method

pen
a PDFPen object used to draw the border of the polygon.
points
an array of PointF structures specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolygon( _
   ByVal pen As PDFPen, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PointF

instance.DrawPolygon(pen, points)
C#
public void DrawPolygon(
   PDFPen pen,
   PointF[] points
)
Managed Extensions for C++
public: void DrawPolygon(
   PDFPen* pen,
   PointF[]* points
)
C++/CLI
public:
void DrawPolygon(
   PDFPen^ pen,
   array<PointF>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
points
an array of PointF structures specifying the coordinates of polygon's corners.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFBrush,PointF[]) Method

DrawPolygon(PDFBrush,PointF[]) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFBrush,PointF[]) Method

brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PointF structures specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PointF

instance.DrawPolygon(brush, points)
C#
public void DrawPolygon(
   PDFBrush brush,
   PointF[] points
)
Managed Extensions for C++
public: void DrawPolygon(
   PDFBrush* brush,
   PointF[]* points
)
C++/CLI
public:
void DrawPolygon(
   PDFBrush^ brush,
   array<PointF>^ points
)

Parameters

brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PointF structures specifying the coordinates of polygon's corners.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFBrush,PointF[],PDFFillMode) Method

DrawPolygon(PDFBrush,PointF[],PDFFillMode) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFBrush,PointF[],PDFFillMode) Method

brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PointF structures specifying the coordinates of polygon's corners.
fillMode
The fill mode of the polygon.
Draws a polygon defined by an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF, _
   ByVal fillMode As PDFFillMode _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PointF
Dim fillMode As PDFFillMode

instance.DrawPolygon(brush, points, fillMode)
C#
public void DrawPolygon(
   PDFBrush brush,
   PointF[] points,
   PDFFillMode fillMode
)
Managed Extensions for C++
public: void DrawPolygon(
   PDFBrush* brush,
   PointF[]* points,
   PDFFillMode fillMode
)
C++/CLI
public:
void DrawPolygon(
   PDFBrush^ brush,
   array<PointF>^ points,
   PDFFillMode fillMode
)

Parameters

brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PointF structures specifying the coordinates of polygon's corners.
fillMode
The fill mode of the polygon.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFPen,PDFBrush,PointF[]) Method

DrawPolygon(PDFPen,PDFBrush,PointF[]) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFPen,PDFBrush,PointF[]) Method

pen
a PDFPen object used to draw the border of the polygon.
brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PointF structures specifying the coordinates of polygon's corners.
Draws a polygon defined by an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PointF

instance.DrawPolygon(pen, brush, points)
C#
public void DrawPolygon(
   PDFPen pen,
   PDFBrush brush,
   PointF[] points
)
Managed Extensions for C++
public: void DrawPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PointF[]* points
)
C++/CLI
public:
void DrawPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PointF>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PointF structures specifying the coordinates of polygon's corners.

Remarks

This function draws a polygon defined by an array of PointF structures. The border of the polygon is drawn using the pen, and the interior is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolygon(PDFPen,PDFBrush,PointF[],PDFFillMode) Method

DrawPolygon(PDFPen,PDFBrush,PointF[],PDFFillMode) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolygon Method : DrawPolygon(PDFPen,PDFBrush,PointF[],PDFFillMode) Method

pen
a PDFPen object used to draw the border of the polygon.
brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PointF structures specifying the coordinates of polygon's corners.
fillMode
The fill mode of the polygon.
Draws a polygon defined by an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF, _
   ByVal fillMode As PDFFillMode _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PointF
Dim fillMode As PDFFillMode

instance.DrawPolygon(pen, brush, points, fillMode)
C#
public void DrawPolygon(
   PDFPen pen,
   PDFBrush brush,
   PointF[] points,
   PDFFillMode fillMode
)
Managed Extensions for C++
public: void DrawPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PointF[]* points,
   PDFFillMode fillMode
)
C++/CLI
public:
void DrawPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PointF>^ points,
   PDFFillMode fillMode
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
brush
a PDFBrush object used to fill the interior of the polygon.
points
an array of PointF structures specifying the coordinates of polygon's corners.
fillMode
The fill mode of the polygon.

Remarks

This function draws a polygon defined by an array of PointF structures. The border of the polygon is drawn using the pen, and the interior is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon Method

DrawPolyPolygon Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawPolyPolygon Method

Draws a series of closed polygons, each one defined by an array of PDFPoint objects.

Overload List

Overload | Description
DrawPolyPolygon(PDFPen,PDFBrush,PDFPoint[][]) | Draws a series of closed polygons, each one defined by an array of PDFPoint objects.
DrawPolyPolygon(PDFPen,PDFBrush,PDFPoint[][],PDFFillMode) | Draws a series of closed polygons, each one defined by an array of PDFPoint objects.
DrawPolyPolygon(PDFPen,PDFPoint[][]) | Draws a series of closed polygons, each one defined by an array of PDFPoint arrays.
DrawPolyPolygon(PDFBrush,PDFPoint[][]) | Draws a series of closed polygons, each one defined by an array of PDFPoint arrays.
DrawPolyPolygon(PDFBrush,PDFPoint[][],PDFFillMode) | Draws a series of closed polygons, each one defined by an array of PDFPoint arrays.
DrawPolyPolygon(PDFPen,PointF[][]) | Draws a series of closed polygons, each one defined by an array of PointF objects.
DrawPolyPolygon(PDFBrush,PointF[][]) | Draws a series of closed polygons, each one defined by an array of PointF structures.
DrawPolyPolygon(PDFBrush,PointF[][],PDFFillMode) | Draws a series of closed polygons, each one defined by an array of PointF structures.
DrawPolyPolygon(PDFPen,PDFBrush,PointF[][]) | Draws a series of closed polygons defined by an array of PointF structures.
DrawPolyPolygon(PDFPen,PDFBrush,PointF[][],PDFFillMode) | Draws a series of closed polygons defined by an array of PointF structures.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawPolyPolygon(PDFPen,PDFBrush,PDFPoint[][]) Method

DrawPolyPolygon(PDFPen,PDFBrush,PDFPoint[][]) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFPen,PDFBrush,PDFPoint[][]) Method

pen
a PDFPen object used to draw the border of the polygons.
brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PDFPoint arrays specifying the coordinates of each polygon's corners.
Draws a series of closed polygons, each one defined by an array of PDFPoint objects.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PDFPoint

instance.DrawPolyPolygon(pen, brush, points)
C#
public void DrawPolyPolygon(
   PDFPen pen,
   PDFBrush brush,
   PDFPoint[] points
)
Managed Extensions for C++
public: void DrawPolyPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PDFPoint*[]* points
)
C++/CLI
public:
void DrawPolyPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PDFPoint^>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygons.
brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PDFPoint arrays specifying the coordinates of each polygon's corners.

Remarks

This function draws a series of closed polygons, each one defined by an array of PDFPoint objects. The border of the polygon is drawn using the pen, and the interior is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFPen,PDFBrush,PDFPoint[][],PDFFillMode) Method

DrawPolyPolygon(PDFPen,PDFBrush,PDFPoint[][],PDFFillMode) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFPen,PDFBrush,PDFPoint[][],PDFFillMode) Method

pen
a PDFPen object used to draw the border of the polygons.
brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PDFPoint arrays specifying the coordinates of each polygon's corners.
fillMode
The fill mode of the polygons.
Draws a series of closed polygons, each one defined by an array of PDFPoint objects.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint, _
   ByVal fillMode As PDFFillMode _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PDFPoint
Dim fillMode As PDFFillMode

instance.DrawPolyPolygon(pen, brush, points, fillMode)
C#
public void DrawPolyPolygon(
   PDFPen pen,
   PDFBrush brush,
   PDFPoint[] points,
   PDFFillMode fillMode
)
Managed Extensions for C++
public: void DrawPolyPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PDFPoint*[]* points,
   PDFFillMode fillMode
)
C++/CLI
public:
void DrawPolyPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PDFPoint^>^ points,
   PDFFillMode fillMode
)

Parameters

pen
a PDFPen object used to draw the border of the polygons.
brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PDFPoint arrays specifying the coordinates of each polygon's corners.
fillMode
The fill mode of the polygons.

Remarks

This function draws a series of closed polygons, each one defined by an array of PDFPoint objects. The border of the polygon is drawn using the pen, and the interior is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFPen,PDFPoint[][]) Method

DrawPolyPolygon(PDFPen,PDFPoint[][]) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFPen,PDFPoint[][]) Method

pen
a PDFPen object used to draw the border of the polygon.
points
an array of PDFPoint objects specifying the coordinates of each polygon's corners.
Draws a series of closed polygons, each one defined by an array of PDFPoint arrays.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyPolygon( _
   ByVal pen As PDFPen, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PDFPoint

instance.DrawPolyPolygon(pen, points)
C#
public void DrawPolyPolygon(
   PDFPen pen,
   PDFPoint[] points
)
Managed Extensions for C++
public: void DrawPolyPolygon(
   PDFPen* pen,
   PDFPoint*[]* points
)
C++/CLI
public:
void DrawPolyPolygon(
   PDFPen^ pen,
   array<PDFPoint^>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygon.
points
an array of PDFPoint objects specifying the coordinates of each polygon's corners.

Remarks

This function draws a series of closed polygons, each one defined by an array of PDFPoint objects. The border of the polygon is drawn using the pen.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFBrush,PDFPoint[][]) Method

DrawPolyPolygon(PDFBrush,PDFPoint[][]) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFBrush,PDFPoint[][]) Method

brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PDFPoint objects specifying the coordinates of each polygon's corners.
Draws a series of closed polygons, each one defined by an array of PDFPoint arrays.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PDFPoint

instance.DrawPolyPolygon(brush, points)
C#
public void DrawPolyPolygon(
   PDFBrush brush,
   PDFPoint[] points
)
Managed Extensions for C++
public: void DrawPolyPolygon(
   PDFBrush* brush,
   PDFPoint*[]* points
)
C++/CLI
public:
void DrawPolyPolygon(
   PDFBrush^ brush,
   array<PDFPoint^>^ points
)

Parameters

brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PDFPoint objects specifying the coordinates of each polygon's corners.

Remarks

This function draws a series of closed polygons, each one defined by an array of PointF objects. The polygons' interior is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFBrush,PDFPoint[][],PDFFillMode) Method

DrawPolyPolygon(PDFBrush,PDFPoint[][],PDFFillMode) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFBrush,PDFPoint[][],PDFFillMode) Method

brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PDFPoint objects specifying the coordinates of each polygon's corners.
fillMode
The fill mode of the polygons.
Draws a series of closed polygons, each one defined by an array of PDFPoint arrays.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PDFPoint, _
   ByVal fillMode As PDFFillMode _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PDFPoint
Dim fillMode As PDFFillMode

instance.DrawPolyPolygon(brush, points, fillMode)
C#
public void DrawPolyPolygon(
   PDFBrush brush,
   PDFPoint[] points,
   PDFFillMode fillMode
)
Managed Extensions for C++
public: void DrawPolyPolygon(
   PDFBrush* brush,
   PDFPoint*[]* points,
   PDFFillMode fillMode
)
C++/CLI
public:
void DrawPolyPolygon(
   PDFBrush^ brush,
   array<PDFPoint^>^ points,
   PDFFillMode fillMode
)

Parameters

brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PDFPoint objects specifying the coordinates of each polygon's corners.
fillMode
The fill mode of the polygons.

Remarks

This function draws a series of closed polygons, each one defined by an array of PointF objects. The polygons' interior is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFPen,PointF[][]) Method

DrawPolyPolygon(PDFPen,PointF[][]) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFPen,PointF[][]) Method

pen
a PDFPen object used to draw the border of the polygons.
points
an array of PointF array specifying the coordinates of each polygon's corners.
Draws a series of closed polygons, each one defined by an array of PointF objects.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyPolygon( _
   ByVal pen As PDFPen, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim points() As PointF

instance.DrawPolyPolygon(pen, points)
C#
public void DrawPolyPolygon(
   PDFPen pen,
   PointF[] points
)
Managed Extensions for C++
public: void DrawPolyPolygon(
   PDFPen* pen,
   PointF[]* points
)
C++/CLI
public:
void DrawPolyPolygon(
   PDFPen^ pen,
   array<PointF>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygons.
points
an array of PointF array specifying the coordinates of each polygon's corners.

Remarks

This function draws a series of closed polygons, each one defined by an array of PDFPoint objects. The border of the polygon is drawn using the pen.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFBrush,PointF[][]) Method

DrawPolyPolygon(PDFBrush,PointF[][]) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFBrush,PointF[][]) Method

brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PointF structures specifying the coordinates of each polygon's corners.
Draws a series of closed polygons, each one defined by an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PointF

instance.DrawPolyPolygon(brush, points)
C#
public void DrawPolyPolygon(
   PDFBrush brush,
   PointF[] points
)
Managed Extensions for C++
public: void DrawPolyPolygon(
   PDFBrush* brush,
   PointF[]* points
)
C++/CLI
public:
void DrawPolyPolygon(
   PDFBrush^ brush,
   array<PointF>^ points
)

Parameters

brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PointF structures specifying the coordinates of each polygon's corners.

Remarks

This function draws a series of closed polygons, each one defined by an array of PointF objects. The interior of the polygons is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFBrush,PointF[][],PDFFillMode) Method

DrawPolyPolygon(PDFBrush,PointF[][],PDFFillMode) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFBrush,PointF[][],PDFFillMode) Method

brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PointF structures specifying the coordinates of each polygon's corners.
fillMode
The fill mode of the polygons.
Draws a series of closed polygons, each one defined by an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyPolygon( _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF, _
   ByVal fillMode As PDFFillMode _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim points() As PointF
Dim fillMode As PDFFillMode

instance.DrawPolyPolygon(brush, points, fillMode)
C#
public void DrawPolyPolygon(
   PDFBrush brush,
   PointF[] points,
   PDFFillMode fillMode
)
Managed Extensions for C++
public: void DrawPolyPolygon(
   PDFBrush* brush,
   PointF[]* points,
   PDFFillMode fillMode
)
C++/CLI
public:
void DrawPolyPolygon(
   PDFBrush^ brush,
   array<PointF>^ points,
   PDFFillMode fillMode
)

Parameters

brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PointF structures specifying the coordinates of each polygon's corners.
fillMode
The fill mode of the polygons.

Remarks

This function draws a series of closed polygons, each one defined by an array of PointF objects. The interior of the polygons is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFPen,PDFBrush,PointF[][]) Method

DrawPolyPolygon(PDFPen,PDFBrush,PointF[][]) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFPen,PDFBrush,PointF[][]) Method

pen
a PDFPen object used to draw the border of the polygons.
brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PointF structures specifying the coordinates of each polygon's corners.
Draws a series of closed polygons defined by an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PointF

instance.DrawPolyPolygon(pen, brush, points)
C#
public void DrawPolyPolygon(
   PDFPen pen,
   PDFBrush brush,
   PointF[] points
)
Managed Extensions for C++
public: void DrawPolyPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PointF[]* points
)
C++/CLI
public:
void DrawPolyPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PointF>^ points
)

Parameters

pen
a PDFPen object used to draw the border of the polygons.
brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PointF structures specifying the coordinates of each polygon's corners.

Remarks

This function draws a series of closed polygons, each one defined by an array of PointF objects. The border of the polygon is drawn using the pen, and the interior is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawPolyPolygon(PDFPen,PDFBrush,PointF[][],PDFFillMode) Method

DrawPolyPolygon(PDFPen,PDFBrush,PointF[][],PDFFillMode) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawPolyPolygon Method : DrawPolyPolygon(PDFPen,PDFBrush,PointF[][],PDFFillMode) Method

pen
a PDFPen object used to draw the border of the polygons.
brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PointF structures specifying the coordinates of each polygon's corners.
fillMode
The polygons fill mode.
Draws a series of closed polygons defined by an array of PointF structures.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawPolyPolygon( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal points() As PointF, _
   ByVal fillMode As PDFFillMode _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim points() As PointF
Dim fillMode As PDFFillMode

instance.DrawPolyPolygon(pen, brush, points, fillMode)
C#
public void DrawPolyPolygon(
   PDFPen pen,
   PDFBrush brush,
   PointF[] points,
   PDFFillMode fillMode
)
Managed Extensions for C++
public: void DrawPolyPolygon(
   PDFPen* pen,
   PDFBrush* brush,
   PointF[]* points,
   PDFFillMode fillMode
)
C++/CLI
public:
void DrawPolyPolygon(
   PDFPen^ pen,
   PDFBrush^ brush,
   array<PointF>^ points,
   PDFFillMode fillMode
)

Parameters

pen
a PDFPen object used to draw the border of the polygons.
brush
a PDFBrush object used to fill the interior of the polygons.
points
an array of PointF structures specifying the coordinates of each polygon's corners.
fillMode
The polygons fill mode.

Remarks

This function draws a series of closed polygons, each one defined by an array of PointF objects. The border of the polygon is drawn using the pen, and the interior is filled with the brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle Method

DrawRectangle Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawRectangle Method

Draws a rectangle specified by a pair of coordinates, a width and a height.

Overload List

Overload | Description
DrawRectangle(PDFPen,Double,Double,Double,Double) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle(PDFPen,Double,Double,Double,Double,Double) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle(PDFPen,RectangleF) | Draws a rectangle specified by a RectangleF structure.
DrawRectangle(PDFPen,RectangleF,Double) | Draws a rectangle specified by a RectangleF structure.
DrawRectangle(PDFBrush,Double,Double,Double,Double) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle(PDFBrush,Double,Double,Double,Double,Double) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle(PDFBrush,RectangleF) | Draws a rectangle specified by a RectangleF structure.
DrawRectangle(PDFBrush,RectangleF,Double) | Draws a rectangle specified by a RectangleF structure.
DrawRectangle(PDFPen,PDFBrush,Double,Double,Double,Double) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double) | Draws a rectangle specified by a pair of coordinates, a width and a height.
DrawRectangle(PDFPen,PDFBrush,RectangleF) | Draws a rectangle specified by a RectangleF structure.
DrawRectangle(PDFPen,PDFBrush,RectangleF,Double) | Draws a rectangle specified by a RectangleF structure.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawRectangle(PDFPen,Double,Double,Double,Double) Method

DrawRectangle(PDFPen,Double,Double,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,Double,Double,Double,Double) Method

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawRectangle(pen, left, top, width, height)
C#
public void DrawRectangle(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: void DrawRectangle(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
void DrawRectangle(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFPen,Double,Double,Double,Double,Double) Method

DrawRectangle(PDFPen,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,Double,Double,Double,Double,Double) Method

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawRectangle(pen, left, top, width, height, orientation)
C#
public void DrawRectangle(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
Managed Extensions for C++
public: void DrawRectangle(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
C++/CLI
public:
void DrawRectangle(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.

Remarks

This function is used to draw a rectangle specified by a pair of coordinates, a width and a height. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFPen,RectangleF) Method

DrawRectangle(PDFPen,RectangleF) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,RectangleF) Method

pen
a PDFPen object used to draw the border of the rectangle.
rect
a RectangleF structure specifying the rectangle.
Draws a rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim rect As RectangleF

instance.DrawRectangle(pen, rect)
C#
public void DrawRectangle(
   PDFPen pen,
   RectangleF rect
)
Managed Extensions for C++
public: void DrawRectangle(
   PDFPen* pen,
   RectangleF rect
)
C++/CLI
public:
void DrawRectangle(
   PDFPen^ pen,
   RectangleF rect
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
rect
a RectangleF structure specifying the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFPen,RectangleF,Double) Method

DrawRectangle(PDFPen,RectangleF,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,RectangleF,Double) Method

pen
a PDFPen object used to draw the border of the rectangle.
rect
a RectangleF structure specifying the rectangle.
orientation
the orientation of the rectangle.
Draws a rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal rect As RectangleF, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim rect As RectangleF
Dim orientation As Double

instance.DrawRectangle(pen, rect, orientation)
C#
public void DrawRectangle(
   PDFPen pen,
   RectangleF rect,
   double orientation
)
Managed Extensions for C++
public: void DrawRectangle(
   PDFPen* pen,
   RectangleF rect,
   double orientation
)
C++/CLI
public:
void DrawRectangle(
   PDFPen^ pen,
   RectangleF rect,
   double orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
rect
a RectangleF structure specifying the rectangle.
orientation
the orientation of the rectangle.

Remarks

This function is used to draw a rectangle specified by a RectangleF structure. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFBrush,Double,Double,Double,Double) Method

DrawRectangle(PDFBrush,Double,Double,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFBrush,Double,Double,Double,Double) Method

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawRectangle(brush, left, top, width, height)
C#
public void DrawRectangle(
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: void DrawRectangle(
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
void DrawRectangle(
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFBrush,Double,Double,Double,Double,Double) Method

DrawRectangle(PDFBrush,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFBrush,Double,Double,Double,Double,Double) Method

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawRectangle(brush, left, top, width, height, orientation)
C#
public void DrawRectangle(
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
Managed Extensions for C++
public: void DrawRectangle(
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
C++/CLI
public:
void DrawRectangle(
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.

Remarks

This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFBrush,RectangleF) Method

DrawRectangle(PDFBrush,RectangleF) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFBrush,RectangleF) Method

brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a RectangleF structure specifying the rectangle.
Draws a rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim rect As RectangleF

instance.DrawRectangle(brush, rect)
C#
public void DrawRectangle(
   PDFBrush brush,
   RectangleF rect
)
Managed Extensions for C++
public: void DrawRectangle(
   PDFBrush* brush,
   RectangleF rect
)
C++/CLI
public:
void DrawRectangle(
   PDFBrush^ brush,
   RectangleF rect
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a RectangleF structure specifying the rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFBrush,RectangleF,Double) Method

DrawRectangle(PDFBrush,RectangleF,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFBrush,RectangleF,Double) Method

brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a RectangleF structure specifying the rectangle.
orientation
the orientation of the rectangle.
Draws a rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim rect As RectangleF
Dim orientation As Double

instance.DrawRectangle(brush, rect, orientation)
C#
public void DrawRectangle(
   PDFBrush brush,
   RectangleF rect,
   double orientation
)
Managed Extensions for C++
public: void DrawRectangle(
   PDFBrush* brush,
   RectangleF rect,
   double orientation
)
C++/CLI
public:
void DrawRectangle(
   PDFBrush^ brush,
   RectangleF rect,
   double orientation
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a RectangleF structure specifying the rectangle.
orientation
the orientation of the rectangle.

Remarks

This function is used to draw a filled rectangle specified by a RectangleF structure. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFPen,PDFBrush,Double,Double,Double,Double) Method

DrawRectangle(PDFPen,PDFBrush,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,PDFBrush,Double,Double,Double,Double) Method

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawRectangle(pen, brush, left, top, width, height)
C#
public void DrawRectangle(
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: void DrawRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
void DrawRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.

Remarks

This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double) Method

DrawRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double) Method

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.
Draws a rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawRectangle(pen, brush, left, top, width, height, orientation)
C#
public void DrawRectangle(
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
Managed Extensions for C++
public: void DrawRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
C++/CLI
public:
void DrawRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
orientation
the orientation of the rectangle.

Remarks

This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFPen,PDFBrush,RectangleF) Method

DrawRectangle(PDFPen,PDFBrush,RectangleF) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,PDFBrush,RectangleF) Method

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a RectangleF structure specifying the rectangle.
Draws a rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF

instance.DrawRectangle(pen, brush, rect)
C#
public void DrawRectangle(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect
)
Managed Extensions for C++
public: void DrawRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect
)
C++/CLI
public:
void DrawRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a RectangleF structure specifying the rectangle.

Remarks

This function is used to draw a filled rectangle specified by a RectangleF structure. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRectangle(PDFPen,PDFBrush,RectangleF,Double) Method

DrawRectangle(PDFPen,PDFBrush,RectangleF,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRectangle Method : DrawRectangle(PDFPen,PDFBrush,RectangleF,Double) Method

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a RectangleF structure specifying the rectangle.
orientation
the orientation of the rectangle.
Draws a rectangle specified by a RectangleF structure.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal rect As RectangleF, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim rect As RectangleF
Dim orientation As Double

instance.DrawRectangle(pen, brush, rect, orientation)
C#
public void DrawRectangle(
   PDFPen pen,
   PDFBrush brush,
   RectangleF rect,
   double orientation
)
Managed Extensions for C++
public: void DrawRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   RectangleF rect,
   double orientation
)
C++/CLI
public:
void DrawRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   RectangleF rect,
   double orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
rect
a RectangleF structure specifying the rectangle.
orientation
the orientation of the rectangle.

Remarks

This function is used to draw a filled rectangle specified by a RectangleF structure. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object. The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRoundRectangle Method

DrawRoundRectangle Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawRoundRectangle Method

Draws a rounded rectangle specified by a pair of coordinates, a width and a height.

Overload List

Overload | Description
DrawRoundRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
DrawRoundRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double,Double) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
DrawRoundRectangle(PDFPen,Double,Double,Double,Double,Double,Double) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height.
DrawRoundRectangle(PDFPen,Double,Double,Double,Double,Double,Double,Double) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.
DrawRoundRectangle(PDFBrush,Double,Double,Double,Double,Double,Double) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.
DrawRoundRectangle(PDFBrush,Double,Double,Double,Double,Double,Double,Double) | Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawRoundRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) Method

DrawRoundRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double) Method

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRoundRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double

instance.DrawRoundRectangle(pen, brush, left, top, width, height, ellipseWidth, ellipseHeight)
C#
public void DrawRoundRectangle(
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
Managed Extensions for C++
public: void DrawRoundRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
C++/CLI
public:
void DrawRoundRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.

Remarks

This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRoundRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double,Double) Method

DrawRoundRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFPen,PDFBrush,Double,Double,Double,Double,Double,Double,Double) Method

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
the orientation of the rectangle.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRoundRectangle( _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double
Dim orientation As Double

instance.DrawRoundRectangle(pen, brush, left, top, width, height, ellipseWidth, ellipseHeight, orientation)
C#
public void DrawRoundRectangle(
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)
Managed Extensions for C++
public: void DrawRoundRectangle(
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)
C++/CLI
public:
void DrawRoundRectangle(
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
the orientation of the rectangle.

Remarks

This function is used to draw a filled rectangle specified by a pair of coordinates, a width and a height. The border of the rectangle is drawn using the PDFPen object and the rectangle is filled using the PDFBrush object.
The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRoundRectangle(PDFPen,Double,Double,Double,Double,Double,Double) Method

DrawRoundRectangle(PDFPen,Double,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFPen,Double,Double,Double,Double,Double,Double) Method

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRoundRectangle( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double

instance.DrawRoundRectangle(pen, left, top, width, height, ellipseWidth, ellipseHeight)
C#
public void DrawRoundRectangle(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
Managed Extensions for C++
public: void DrawRoundRectangle(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
C++/CLI
public:
void DrawRoundRectangle(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.

Remarks

This function strokes the rectangle with the given PDFPen object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRoundRectangle(PDFPen,Double,Double,Double,Double,Double,Double,Double) Method

DrawRoundRectangle(PDFPen,Double,Double,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFPen,Double,Double,Double,Double,Double,Double,Double) Method

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
the orientation of the rectangle.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRoundRectangle( _
   ByVal pen As PDFPen, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim pen As PDFPen
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double
Dim orientation As Double

instance.DrawRoundRectangle(pen, left, top, width, height, ellipseWidth, ellipseHeight, orientation)
C#
public void DrawRoundRectangle(
   PDFPen pen,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)
Managed Extensions for C++
public: void DrawRoundRectangle(
   PDFPen* pen,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)
C++/CLI
public:
void DrawRoundRectangle(
   PDFPen^ pen,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)

Parameters

pen
a PDFPen object used to draw the border of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
the orientation of the rectangle.

Remarks

This function strokes the rectangle with the given PDFPen object.
The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRoundRectangle(PDFBrush,Double,Double,Double,Double,Double,Double) Method

DrawRoundRectangle(PDFBrush,Double,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFBrush,Double,Double,Double,Double,Double,Double) Method

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRoundRectangle( _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double

instance.DrawRoundRectangle(brush, left, top, width, height, ellipseWidth, ellipseHeight)
C#
public void DrawRoundRectangle(
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
Managed Extensions for C++
public: void DrawRoundRectangle(
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
C++/CLI
public:
void DrawRoundRectangle(
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.

Remarks

This function fill the interior of the rectangle with the given PDFBrush object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawRoundRectangle(PDFBrush,Double,Double,Double,Double,Double,Double,Double) Method

DrawRoundRectangle(PDFBrush,Double,Double,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawRoundRectangle Method : DrawRoundRectangle(PDFBrush,Double,Double,Double,Double,Double,Double,Double) Method

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
the orientation of the rectangle.
Draws a rounded rectangle specified by a pair of coordinates, a width and a height and an orientation.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawRoundRectangle( _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double
Dim orientation As Double

instance.DrawRoundRectangle(brush, left, top, width, height, ellipseWidth, ellipseHeight, orientation)
C#
public void DrawRoundRectangle(
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)
Managed Extensions for C++
public: void DrawRoundRectangle(
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)
C++/CLI
public:
void DrawRoundRectangle(
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight,
   double orientation
)

Parameters

brush
a PDFBrush object used to fill the interior of the rectangle.
left
the x coordinate of the top left corner of the rectangle.
top
the y coordinate of the top left corner of the rectangle.
width
the width of the rectangle.
height
the height of the rectangle.
ellipseWidth
the width of the ellipse used to draw the rounded corners.
ellipseHeight
the height of the ellipse used to draw the rounded corners.
orientation
the orientation of the rectangle.

Remarks

This function fill the interior of the rectangle with the given PDFBrush object.
The rectangle is rotated counterclockwise from the x axis around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawText Method

DrawText Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawText Method

Draws a line of text specified by a string and a pair of coordinates.

Overload List

Overload | Description
DrawText(String,PDFFontBase,PDFBrush,Double,Double) | Draws a line of text specified by a string and a pair of coordinates.
DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double) | Draws a line of text specified by a string and a pair of coordinates.
DrawText(String,PDFFontBase,PDFBrush,Double,Double,Double) | Draws a line of text specified by a string and a pair of coordinates.
DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double) | Draws a line of text specified by a string and a pair of coordinates.
DrawText(String,PDFFontBase,PDFBrush,Double,Double,Double,PDFTextAlign) | Draws a line of text specified by a string and a pair of coordinates.
DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,PDFTextAlign) | Draws a line of text specified by a string and a pair of coordinates.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawText(String,PDFFontBase,PDFBrush,Double,Double) Method

DrawText(String,PDFFontBase,PDFBrush,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawText Method : DrawText(String,PDFFontBase,PDFBrush,Double,Double) Method

text
the string to be drawn.
font
a PDFFontBase object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the top left corner of the drawn text.
y
the y coordinate of the top left corner of the drawn text.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim x As Double
Dim y As Double

instance.DrawText(text, font, brush, x, y)
C#
public void DrawText(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double x,
   double y
)
Managed Extensions for C++
public: void DrawText(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double x,
   double y
)
C++/CLI
public:
void DrawText(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double x,
   double y
)

Parameters

text
the string to be drawn.
font
a PDFFontBase object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the top left corner of the drawn text.
y
the y coordinate of the top left corner of the drawn text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double) Method

DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawText Method : DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double) Method

text
the string to be drawn.
font
a PDFFontBase object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the top left corner of the drawn text.
y
the y coordinate of the top left corner of the drawn text.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Double
Dim y As Double

instance.DrawText(text, font, pen, brush, x, y)
C#
public void DrawText(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double x,
   double y
)
Managed Extensions for C++
public: void DrawText(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double x,
   double y
)
C++/CLI
public:
void DrawText(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double x,
   double y
)

Parameters

text
the string to be drawn.
font
a PDFFontBase object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the top left corner of the drawn text.
y
the y coordinate of the top left corner of the drawn text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawText(String,PDFFontBase,PDFBrush,Double,Double,Double) Method

DrawText(String,PDFFontBase,PDFBrush,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawText Method : DrawText(String,PDFFontBase,PDFBrush,Double,Double,Double) Method

text
the string to be drawn.
font
a PDFFontBase descendant object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the top left corner of the drawn text.
y
the y coordinate of the top left corner of the drawn text.
orientation
the orientation of the text.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim x As Double
Dim y As Double
Dim orientation As Double

instance.DrawText(text, font, brush, x, y, orientation)
C#
public void DrawText(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double x,
   double y,
   double orientation
)
Managed Extensions for C++
public: void DrawText(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double x,
   double y,
   double orientation
)
C++/CLI
public:
void DrawText(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double x,
   double y,
   double orientation
)

Parameters

text
the string to be drawn.
font
a PDFFontBase descendant object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the top left corner of the drawn text.
y
the y coordinate of the top left corner of the drawn text.
orientation
the orientation of the text.

Remarks

The text is drawn rotated around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double) Method

DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawText Method : DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double) Method

text
the string to be drawn.
font
a PDFFontBase descendant object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the top left corner of the drawn text.
y
the y coordinate of the top left corner of the drawn text.
orientation
the orientation of the text.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Double
Dim y As Double
Dim orientation As Double

instance.DrawText(text, font, pen, brush, x, y, orientation)
C#
public void DrawText(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double x,
   double y,
   double orientation
)
Managed Extensions for C++
public: void DrawText(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double x,
   double y,
   double orientation
)
C++/CLI
public:
void DrawText(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double x,
   double y,
   double orientation
)

Parameters

text
the string to be drawn.
font
a PDFFontBase descendant object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the top left corner of the drawn text.
y
the y coordinate of the top left corner of the drawn text.
orientation
the orientation of the text.

Remarks

The text is drawn rotated around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawText(String,PDFFontBase,PDFBrush,Double,Double,Double,PDFTextAlign) Method

DrawText(String,PDFFontBase,PDFBrush,Double,Double,Double,PDFTextAlign) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawText Method : DrawText(String,PDFFontBase,PDFBrush,Double,Double,Double,PDFTextAlign) Method

text
the string to be drawn.
font
a PDFFontBase descendant object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a TextAlign enumeration member specifying the aligment of the text.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal orientation As Double, _
   ByVal align As PDFTextAlign _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim x As Double
Dim y As Double
Dim orientation As Double
Dim align As PDFTextAlign

instance.DrawText(text, font, brush, x, y, orientation, align)
C#
public void DrawText(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
Managed Extensions for C++
public: void DrawText(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
C++/CLI
public:
void DrawText(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)

Parameters

text
the string to be drawn.
font
a PDFFontBase descendant object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a TextAlign enumeration member specifying the aligment of the text.

Remarks

The text is drawn rotated around the printing point with a number of degrees specified by the orientation parameter. Also, the text is drawn aligned relative to the printing point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,PDFTextAlign) Method

DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,PDFTextAlign) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawText Method : DrawText(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,PDFTextAlign) Method

text
the string to be drawn.
font
a PDFFontBase descendant object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a TextAlign enumeration member specifying the aligment of the text.
Draws a line of text specified by a string and a pair of coordinates.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal x As Double, _
   ByVal y As Double, _
   ByVal orientation As Double, _
   ByVal align As PDFTextAlign _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim x As Double
Dim y As Double
Dim orientation As Double
Dim align As PDFTextAlign

instance.DrawText(text, font, pen, brush, x, y, orientation, align)
C#
public void DrawText(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
Managed Extensions for C++
public: void DrawText(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)
C++/CLI
public:
void DrawText(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double x,
   double y,
   double orientation,
   PDFTextAlign align
)

Parameters

text
the string to be drawn.
font
a PDFFontBase descendant object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
x
the x coordinate of the printing point.
y
the y coordinate of the printing point.
orientation
the orientation of the text.
align
a TextAlign enumeration member specifying the aligment of the text.

Remarks

The text is drawn rotated around the printing point with a number of degrees specified by the orientation parameter. Also, the text is drawn aligned relative to the printing point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawTextBox Method

DrawTextBox Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : DrawTextBox Method

Draws a text specified by a string, a pair of coordinates, a width and a height.

Overload List

Overload | Description
DrawTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double,Double) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign,Boolean) | Draws a text specified by a string, a pair of coordinates, a width and a height.
DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign,Boolean,Double) | Draws a text specified by a string, a pair of coordinates, a width and a height.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


DrawTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method

DrawTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFontBase,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim textFormatOptions As PDFTextFormatOptions

instance.DrawTextBox(text, font, brush, left, top, width, height, textFormatOptions)
C#
public void DrawTextBox(
   string text,
   PDFFontBase font,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions textFormatOptions
)
Managed Extensions for C++
public: void DrawTextBox(
   string* text,
   PDFFontBase* font,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions* textFormatOptions
)
C++/CLI
public:
void DrawTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.

Remarks

The text is automatically wrapped to fit the width of the text box. The formatting of the text is controlled by the textFormatOptions parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method

DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFontBase,PDFPen,PDFBrush,Double,Double,Double,Double,PDFTextFormatOptions) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim textFormatOptions As PDFTextFormatOptions

instance.DrawTextBox(text, font, pen, brush, left, top, width, height, textFormatOptions)
C#
public void DrawTextBox(
   string text,
   PDFFontBase font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions textFormatOptions
)
Managed Extensions for C++
public: void DrawTextBox(
   string* text,
   PDFFontBase* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions* textFormatOptions
)
C++/CLI
public:
void DrawTextBox(
   String^ text,
   PDFFontBase^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
textFormatOptions
A PDFTextFormatOptions object specifying how the text within the text box should be formatted.

Remarks

The text is automatically wrapped to fit the width of the text box. The formatting of the text is controlled by the textFormatOptions parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double) Method

DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.DrawTextBox(text, font, pen, brush, left, top, width, height)
C#
public void DrawTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: void DrawTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
void DrawTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.

Remarks

The text is automatically wrapped to fit the width of the text box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double,Double) Method

DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double,Double) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double

instance.DrawTextBox(text, font, pen, brush, left, top, width, height, orientation)
C#
public void DrawTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
Managed Extensions for C++
public: void DrawTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)
C++/CLI
public:
void DrawTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double orientation
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.

Remarks

The text is automatically wrapped to fit the width of the text box. The text box is rotated around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign) Method

DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
align
a TextAlign enumeration member specifying how the text is aligned inside the text box.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal align As PDFTextAlign _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim align As PDFTextAlign

instance.DrawTextBox(text, font, pen, brush, left, top, width, height, orientation, align)
C#
public void DrawTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align
)
Managed Extensions for C++
public: void DrawTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align
)
C++/CLI
public:
void DrawTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
align
a TextAlign enumeration member specifying how the text is aligned inside the text box.

Remarks

The text is automatically wrapped to fit the width of the text box. The text box is rotated around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign,Boolean) Method

DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign,Boolean) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign,Boolean) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
align
a PDFTextAlign enumeration member specifying how the text is aligned inside the text box.
clipText
a boolean value specifying whether to clip or no the text that does not fit inside the text box.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal align As PDFTextAlign, _
   ByVal clipText As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim align As PDFTextAlign
Dim clipText As Boolean

instance.DrawTextBox(text, font, pen, brush, left, top, width, height, orientation, align, clipText)
C#
public void DrawTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align,
   bool clipText
)
Managed Extensions for C++
public: void DrawTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align,
   bool clipText
)
C++/CLI
public:
void DrawTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align,
   bool clipText
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
align
a PDFTextAlign enumeration member specifying how the text is aligned inside the text box.
clipText
a boolean value specifying whether to clip or no the text that does not fit inside the text box.

Remarks

The text is automatically wrapped to fit the width of the text box. The text box is rotated around the top left corner with a number of degrees specified by the orientation parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign,Boolean,Double) Method

DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign,Boolean,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > DrawTextBox Method : DrawTextBox(String,PDFFont,PDFPen,PDFBrush,Double,Double,Double,Double,Double,PDFTextAlign,Boolean,Double) Method

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
align
a TextAlign enumeration member specifying how the text is aligned inside the text box.
clipText
a boolean value specifying whether to clip or no the text that does not fit inside the text box.
lineSpacing
a float value specifying additional space between wrapped lines of text.
Draws a text specified by a string, a pair of coordinates, a width and a height.

Syntax

Visual Basic (Declaration)
Overloads Public Sub DrawTextBox( _
   ByVal text As String, _
   ByVal font As PDFFont, _
   ByVal pen As PDFPen, _
   ByVal brush As PDFBrush, _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal orientation As Double, _
   ByVal align As PDFTextAlign, _
   ByVal clipText As Boolean, _
   ByVal lineSpacing As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFont
Dim pen As PDFPen
Dim brush As PDFBrush
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim orientation As Double
Dim align As PDFTextAlign
Dim clipText As Boolean
Dim lineSpacing As Double

instance.DrawTextBox(text, font, pen, brush, left, top, width, height, orientation, align, clipText, lineSpacing)
C#
public void DrawTextBox(
   string text,
   PDFFont font,
   PDFPen pen,
   PDFBrush brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align,
   bool clipText,
   double lineSpacing
)
Managed Extensions for C++
public: void DrawTextBox(
   string* text,
   PDFFont* font,
   PDFPen* pen,
   PDFBrush* brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align,
   bool clipText,
   double lineSpacing
)
C++/CLI
public:
void DrawTextBox(
   String^ text,
   PDFFont^ font,
   PDFPen^ pen,
   PDFBrush^ brush,
   double left,
   double top,
   double width,
   double height,
   double orientation,
   PDFTextAlign align,
   bool clipText,
   double lineSpacing
)

Parameters

text
the string to be drawn.
font
a PDFFont object used to represent the string.
pen
a PDFPen object used to draw the border of the string.
brush
a PDFBrush object used to fill the interior of the string.
left
the x coordinate of the top left corner of the text box.
top
the y coordinate of the top left corner of the text box.
width
the width of the text box.
height
the height of the text box.
orientation
the orientation of the text box.
align
a TextAlign enumeration member specifying how the text is aligned inside the text box.
clipText
a boolean value specifying whether to clip or no the text that does not fit inside the text box.
lineSpacing
a float value specifying additional space between wrapped lines of text.

Remarks

The text is automatically wrapped to fit the width of the text box. The text box is rotated around the top left corner with a number of degrees specified by the orientation parameter. The space between lines of text is increased with the value specified by the lineSpacing parameter. If this value is negative, then the lines pf text are drawn closer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


FitHtmlText Method

FitHtmlText Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : FitHtmlText Method

Calculates how much of the text really fits in the box.

Overload List

Overload | Description
FitHtmlText(String,Int32,PDFFontBase,Double,Double) | Calculates how much of the text really fits in the box.
FitHtmlText(String,Int32,PDFFontBase,Double,Double,PDFTextFormatOptions) | Calculates how much of the text really fits in the box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


FitHtmlText(String,Int32,PDFFontBase,Double,Double) Method

FitHtmlText(String,Int32,PDFFontBase,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > FitHtmlText Method : FitHtmlText(String,Int32,PDFFontBase,Double,Double) Method

text
the text to fit in the given area.
startDisplayFrom
Position within the text where to start calculating.
font
the font used to display the text.
width
the width of the area.
height
the height of the area.
Calculates how much of the text really fits in the box.

Syntax

Visual Basic (Declaration)
Overloads Public Function FitHtmlText( _
   ByVal text As String, _
   ByVal startDisplayFrom As Integer, _
   ByVal font As PDFFontBase, _
   ByVal width As Double, _
   ByVal height As Double _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim startDisplayFrom As Integer
Dim font As PDFFontBase
Dim width As Double
Dim height As Double
Dim value As Integer

value = instance.FitHtmlText(text, startDisplayFrom, font, width, height)
C#
public int FitHtmlText(
   string text,
   int startDisplayFrom,
   PDFFontBase font,
   double width,
   double height
)
Managed Extensions for C++
public: int FitHtmlText(
   string* text,
   int startDisplayFrom,
   PDFFontBase* font,
   double width,
   double height
)
C++/CLI
public:
int FitHtmlText(
   String^ text,
   int startDisplayFrom,
   PDFFontBase^ font,
   double width,
   double height
)

Parameters

text
the text to fit in the given area.
startDisplayFrom
Position within the text where to start calculating.
font
the font used to display the text.
width
the width of the area.
height
the height of the area.

Return Value

an integer value representing the length of the text that fits in the area.

Remarks

The width and height of the area are considered always given in points. The text that fits in the area is always calculated to end with a whole word, not a fragment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


FitHtmlText(String,Int32,PDFFontBase,Double,Double,PDFTextFormatOptions) Method

FitHtmlText(String,Int32,PDFFontBase,Double,Double,PDFTextFormatOptions) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > FitHtmlText Method : FitHtmlText(String,Int32,PDFFontBase,Double,Double,PDFTextFormatOptions) Method

text
the text to fit in the given area.
startDisplayFrom
Position within the text where to start calculating.
font
the font used to display the text.
width
the width of the area.
height
the height of the area.
textFormatOptions
Options for text formatting.
Calculates how much of the text really fits in the box.

Syntax

Visual Basic (Declaration)
Overloads Public Function FitHtmlText( _
   ByVal text As String, _
   ByVal startDisplayFrom As Integer, _
   ByVal font As PDFFontBase, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim startDisplayFrom As Integer
Dim font As PDFFontBase
Dim width As Double
Dim height As Double
Dim textFormatOptions As PDFTextFormatOptions
Dim value As Integer

value = instance.FitHtmlText(text, startDisplayFrom, font, width, height, textFormatOptions)
C#
public int FitHtmlText(
   string text,
   int startDisplayFrom,
   PDFFontBase font,
   double width,
   double height,
   PDFTextFormatOptions textFormatOptions
)
Managed Extensions for C++
public: int FitHtmlText(
   string* text,
   int startDisplayFrom,
   PDFFontBase* font,
   double width,
   double height,
   PDFTextFormatOptions* textFormatOptions
)
C++/CLI
public:
int FitHtmlText(
   String^ text,
   int startDisplayFrom,
   PDFFontBase^ font,
   double width,
   double height,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the text to fit in the given area.
startDisplayFrom
Position within the text where to start calculating.
font
the font used to display the text.
width
the width of the area.
height
the height of the area.
textFormatOptions
Options for text formatting.

Return Value

an integer value representing the length of the text that fits in the area.

Remarks

The width and height of the area are considered always given in points. The text that fits in the area is always calculated to end with a whole word, not a fragment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


FitText Method

FitText Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : FitText Method

Calculates how much of the given text fits in the given area.

Overload List

Overload | Description
FitText(String,PDFFontBase,Double,Double) | Calculates how much of the given text fits in the given area.
FitText(String,PDFFontBase,Double,Double,PDFTextFormatOptions) | Calculates how much of the given text fits in the given area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


FitText(String,PDFFontBase,Double,Double) Method

FitText(String,PDFFontBase,Double,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > FitText Method : FitText(String,PDFFontBase,Double,Double) Method

text
the text to fit in the given area.
font
the font used to display the text.
width
the width of the area.
height
the height of the area.
Calculates how much of the given text fits in the given area.

Syntax

Visual Basic (Declaration)
Overloads Public Function FitText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal width As Double, _
   ByVal height As Double _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim width As Double
Dim height As Double
Dim value As Integer

value = instance.FitText(text, font, width, height)
C#
public int FitText(
   string text,
   PDFFontBase font,
   double width,
   double height
)
Managed Extensions for C++
public: int FitText(
   string* text,
   PDFFontBase* font,
   double width,
   double height
)
C++/CLI
public:
int FitText(
   String^ text,
   PDFFontBase^ font,
   double width,
   double height
)

Parameters

text
the text to fit in the given area.
font
the font used to display the text.
width
the width of the area.
height
the height of the area.

Return Value

an integer value representing the length of the text that fits in the area.

Remarks

The width and height of the area are always given in points. The text that fits in the area is always calculated to end with a whole word, not a fragment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


FitText(String,PDFFontBase,Double,Double,PDFTextFormatOptions) Method

FitText(String,PDFFontBase,Double,Double,PDFTextFormatOptions) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > FitText Method : FitText(String,PDFFontBase,Double,Double,PDFTextFormatOptions) Method

text
the text to fit in the given area.
font
the font used to display the text.
width
the width of the area.
height
the height of the area.
textFormatOptions
Options for text formatting.
Calculates how much of the given text fits in the given area.

Syntax

Visual Basic (Declaration)
Overloads Public Function FitText( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim width As Double
Dim height As Double
Dim textFormatOptions As PDFTextFormatOptions
Dim value As Integer

value = instance.FitText(text, font, width, height, textFormatOptions)
C#
public int FitText(
   string text,
   PDFFontBase font,
   double width,
   double height,
   PDFTextFormatOptions textFormatOptions
)
Managed Extensions for C++
public: int FitText(
   string* text,
   PDFFontBase* font,
   double width,
   double height,
   PDFTextFormatOptions* textFormatOptions
)
C++/CLI
public:
int FitText(
   String^ text,
   PDFFontBase^ font,
   double width,
   double height,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the text to fit in the given area.
font
the font used to display the text.
width
the width of the area.
height
the height of the area.
textFormatOptions
Options for text formatting.

Return Value

an integer value representing the length of the text that fits in the area.

Remarks

The width and height of the area are always given in points. The text that fits in the area is always calculated to end with a whole word, not a fragment.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


GetHtmlTextBoxHeight Method

GetHtmlTextBoxHeight Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : GetHtmlTextBoxHeight Method

Gets the height of the wrapped HTML text.

Overload List

Overload | Description
GetHtmlTextBoxHeight(String,Int32,PDFFontBase,Double) | Gets the height of the wrapped HTML text.
GetHtmlTextBoxHeight(String,Int32,PDFFontBase,Double,PDFTextFormatOptions) | Gets the height of the wrapped HTML text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


GetHtmlTextBoxHeight(String,Int32,PDFFontBase,Double) Method

GetHtmlTextBoxHeight(String,Int32,PDFFontBase,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > GetHtmlTextBoxHeight Method : GetHtmlTextBoxHeight(String,Int32,PDFFontBase,Double) Method

text
the text to wrap in the given area.
startDisplayFrom
position within the text where to start wrapping.
font
the font used to display the text.
width
the width of the area.
Gets the height of the wrapped HTML text.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetHtmlTextBoxHeight( _
   ByVal text As String, _
   ByVal startDisplayFrom As Integer, _
   ByVal font As PDFFontBase, _
   ByVal width As Double _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim startDisplayFrom As Integer
Dim font As PDFFontBase
Dim width As Double
Dim value As Double

value = instance.GetHtmlTextBoxHeight(text, startDisplayFrom, font, width)
C#
public double GetHtmlTextBoxHeight(
   string text,
   int startDisplayFrom,
   PDFFontBase font,
   double width
)
Managed Extensions for C++
public: double GetHtmlTextBoxHeight(
   string* text,
   int startDisplayFrom,
   PDFFontBase* font,
   double width
)
C++/CLI
public:
double GetHtmlTextBoxHeight(
   String^ text,
   int startDisplayFrom,
   PDFFontBase^ font,
   double width
)

Parameters

text
the text to wrap in the given area.
startDisplayFrom
position within the text where to start wrapping.
font
the font used to display the text.
width
the width of the area.

Return Value

The height of the wrapped text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


GetHtmlTextBoxHeight(String,Int32,PDFFontBase,Double,PDFTextFormatOptions) Method

GetHtmlTextBoxHeight(String,Int32,PDFFontBase,Double,PDFTextFormatOptions) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > GetHtmlTextBoxHeight Method : GetHtmlTextBoxHeight(String,Int32,PDFFontBase,Double,PDFTextFormatOptions) Method

text
the text to wrap in the given area.
startDisplayFrom
position within the text where to start wrapping.
font
the font used to display the text.
width
the width of the area.
textFormatOptions
Options for text formatting.
Gets the height of the wrapped HTML text.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetHtmlTextBoxHeight( _
   ByVal text As String, _
   ByVal startDisplayFrom As Integer, _
   ByVal font As PDFFontBase, _
   ByVal width As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim startDisplayFrom As Integer
Dim font As PDFFontBase
Dim width As Double
Dim textFormatOptions As PDFTextFormatOptions
Dim value As Double

value = instance.GetHtmlTextBoxHeight(text, startDisplayFrom, font, width, textFormatOptions)
C#
public double GetHtmlTextBoxHeight(
   string text,
   int startDisplayFrom,
   PDFFontBase font,
   double width,
   PDFTextFormatOptions textFormatOptions
)
Managed Extensions for C++
public: double GetHtmlTextBoxHeight(
   string* text,
   int startDisplayFrom,
   PDFFontBase* font,
   double width,
   PDFTextFormatOptions* textFormatOptions
)
C++/CLI
public:
double GetHtmlTextBoxHeight(
   String^ text,
   int startDisplayFrom,
   PDFFontBase^ font,
   double width,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the text to wrap in the given area.
startDisplayFrom
position within the text where to start wrapping.
font
the font used to display the text.
width
the width of the area.
textFormatOptions
Options for text formatting.

Return Value

The height of the wrapped text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


GetHtmlTextBoxLastLineWidth Method

GetHtmlTextBoxLastLineWidth Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : GetHtmlTextBoxLastLineWidth Method

Gets the width of the last line in the HTML text box.

Overload List

Overload | Description
GetHtmlTextBoxLastLineWidth(String,Int32,PDFFontBase,Double) | Gets the width of the last line in the HTML text box.
GetHtmlTextBoxLastLineWidth(String,Int32,PDFFontBase,Double,PDFTextFormatOptions) | Gets the width of the last line in the HTML text box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


GetHtmlTextBoxLastLineWidth(String,Int32,PDFFontBase,Double) Method

GetHtmlTextBoxLastLineWidth(String,Int32,PDFFontBase,Double) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > GetHtmlTextBoxLastLineWidth Method : GetHtmlTextBoxLastLineWidth(String,Int32,PDFFontBase,Double) Method

text
the text to wrap in the given area.
startDisplayFrom
position in text where to start wrapping.
font
the font used to display the text.
width
the width of the area.
Gets the width of the last line in the HTML text box.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetHtmlTextBoxLastLineWidth( _
   ByVal text As String, _
   ByVal startDisplayFrom As Integer, _
   ByVal font As PDFFontBase, _
   ByVal width As Double _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim startDisplayFrom As Integer
Dim font As PDFFontBase
Dim width As Double
Dim value As Double

value = instance.GetHtmlTextBoxLastLineWidth(text, startDisplayFrom, font, width)
C#
public double GetHtmlTextBoxLastLineWidth(
   string text,
   int startDisplayFrom,
   PDFFontBase font,
   double width
)
Managed Extensions for C++
public: double GetHtmlTextBoxLastLineWidth(
   string* text,
   int startDisplayFrom,
   PDFFontBase* font,
   double width
)
C++/CLI
public:
double GetHtmlTextBoxLastLineWidth(
   String^ text,
   int startDisplayFrom,
   PDFFontBase^ font,
   double width
)

Parameters

text
the text to wrap in the given area.
startDisplayFrom
position in text where to start wrapping.
font
the font used to display the text.
width
the width of the area.

Return Value

The width of the last wrapped line in the textbox.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


GetHtmlTextBoxLastLineWidth(String,Int32,PDFFontBase,Double,PDFTextFormatOptions) Method

GetHtmlTextBoxLastLineWidth(String,Int32,PDFFontBase,Double,PDFTextFormatOptions) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > GetHtmlTextBoxLastLineWidth Method : GetHtmlTextBoxLastLineWidth(String,Int32,PDFFontBase,Double,PDFTextFormatOptions) Method

text
the text to wrap in the given area.
startDisplayFrom
position in text where to start wrapping.
font
the font used to display the text.
width
the width of the area.
textFormatOptions
Options for text formatting.
Gets the width of the last line in the HTML text box.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetHtmlTextBoxLastLineWidth( _
   ByVal text As String, _
   ByVal startDisplayFrom As Integer, _
   ByVal font As PDFFontBase, _
   ByVal width As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim startDisplayFrom As Integer
Dim font As PDFFontBase
Dim width As Double
Dim textFormatOptions As PDFTextFormatOptions
Dim value As Double

value = instance.GetHtmlTextBoxLastLineWidth(text, startDisplayFrom, font, width, textFormatOptions)
C#
public double GetHtmlTextBoxLastLineWidth(
   string text,
   int startDisplayFrom,
   PDFFontBase font,
   double width,
   PDFTextFormatOptions textFormatOptions
)
Managed Extensions for C++
public: double GetHtmlTextBoxLastLineWidth(
   string* text,
   int startDisplayFrom,
   PDFFontBase* font,
   double width,
   PDFTextFormatOptions* textFormatOptions
)
C++/CLI
public:
double GetHtmlTextBoxLastLineWidth(
   String^ text,
   int startDisplayFrom,
   PDFFontBase^ font,
   double width,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the text to wrap in the given area.
startDisplayFrom
position in text where to start wrapping.
font
the font used to display the text.
width
the width of the area.
textFormatOptions
Options for text formatting.

Return Value

The width of the last wrapped line in the textbox.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


GetTextBoxHeight Method

GetTextBoxHeight Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : GetTextBoxHeight Method

Gets the height of the wrapped text.

Overload List

Overload | Description
GetTextBoxHeight(String,PDFFontBase,Double) | Gets the height of the wrapped text.
GetTextBoxHeight(String,PDFFontBase,Double,PDFTextFormatOptions) | Gets the height of the wrapped text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


GetTextBoxHeight(String,PDFFontBase,Double) Method

GetTextBoxHeight(String,PDFFontBase,Double) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > GetTextBoxHeight Method : GetTextBoxHeight(String,PDFFontBase,Double) Method

text
the text to wrap in the given area.
font
the font used to display the text.
width
the width of the area.
Gets the height of the wrapped text.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetTextBoxHeight( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal width As Double _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim width As Double
Dim value As Double

value = instance.GetTextBoxHeight(text, font, width)
C#
public double GetTextBoxHeight(
   string text,
   PDFFontBase font,
   double width
)
Managed Extensions for C++
public: double GetTextBoxHeight(
   string* text,
   PDFFontBase* font,
   double width
)
C++/CLI
public:
double GetTextBoxHeight(
   String^ text,
   PDFFontBase^ font,
   double width
)

Parameters

text
the text to wrap in the given area.
font
the font used to display the text.
width
the width of the area.

Return Value

The height of the wrapped text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


GetTextBoxHeight(String,PDFFontBase,Double,PDFTextFormatOptions) Method

GetTextBoxHeight(String,PDFFontBase,Double,PDFTextFormatOptions) Method
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class > GetTextBoxHeight Method : GetTextBoxHeight(String,PDFFontBase,Double,PDFTextFormatOptions) Method

text
the text to wrap in the given area.
font
the font used to display the text.
width
the width of the area.
textFormatOptions
Options for text formatting.
Gets the height of the wrapped text.

Syntax

Visual Basic (Declaration)
Overloads Public Function GetTextBoxHeight( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal width As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim width As Double
Dim textFormatOptions As PDFTextFormatOptions
Dim value As Double

value = instance.GetTextBoxHeight(text, font, width, textFormatOptions)
C#
public double GetTextBoxHeight(
   string text,
   PDFFontBase font,
   double width,
   PDFTextFormatOptions textFormatOptions
)
Managed Extensions for C++
public: double GetTextBoxHeight(
   string* text,
   PDFFontBase* font,
   double width,
   PDFTextFormatOptions* textFormatOptions
)
C++/CLI
public:
double GetTextBoxHeight(
   String^ text,
   PDFFontBase^ font,
   double width,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the text to wrap in the given area.
font
the font used to display the text.
width
the width of the area.
textFormatOptions
Options for text formatting.

Return Value

The height of the wrapped text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members
Overload List


GetTextBoxLastLineWidth Method

GetTextBoxLastLineWidth Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : GetTextBoxLastLineWidth Method

text
the text to wrap in the given area.
font
the font used to display the text.
width
the width of the area.
textFormatOptions
Options for text formatting.
Gets the width of the last line in the text box.

Syntax

Visual Basic (Declaration)
Public Function GetTextBoxLastLineWidth( _
   ByVal text As String, _
   ByVal font As PDFFontBase, _
   ByVal width As Double, _
   ByVal textFormatOptions As PDFTextFormatOptions _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim text As String
Dim font As PDFFontBase
Dim width As Double
Dim textFormatOptions As PDFTextFormatOptions
Dim value As Double

value = instance.GetTextBoxLastLineWidth(text, font, width, textFormatOptions)
C#
public double GetTextBoxLastLineWidth(
   string text,
   PDFFontBase font,
   double width,
   PDFTextFormatOptions textFormatOptions
)
Managed Extensions for C++
public: double GetTextBoxLastLineWidth(
   string* text,
   PDFFontBase* font,
   double width,
   PDFTextFormatOptions* textFormatOptions
)
C++/CLI
public:
double GetTextBoxLastLineWidth(
   String^ text,
   PDFFontBase^ font,
   double width,
   PDFTextFormatOptions^ textFormatOptions
)

Parameters

text
the text to wrap in the given area.
font
the font used to display the text.
width
the width of the area.
textFormatOptions
Options for text formatting.

Return Value

The width of the last wrapped line in the textbox.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


ResetClipRegion Method

ResetClipRegion Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : ResetClipRegion Method

Resets the current clipping region to whole page.

Syntax

Visual Basic (Declaration)
Public Sub ResetClipRegion()
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas

instance.ResetClipRegion()
C#
public void ResetClipRegion()
Managed Extensions for C++
public: void ResetClipRegion();
C++/CLI
public:
void ResetClipRegion();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


RestoreGraphicState Method

RestoreGraphicState Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : RestoreGraphicState Method

Restores the current graphic state in the PDF content stream.

Syntax

Visual Basic (Declaration)
Public Sub RestoreGraphicState()
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas

instance.RestoreGraphicState()
C#
public void RestoreGraphicState()
Managed Extensions for C++
public: void RestoreGraphicState();
C++/CLI
public:
void RestoreGraphicState();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SaveGraphicState Method

SaveGraphicState Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SaveGraphicState Method

Saves the current graphic state in the PDF content stream.

Syntax

Visual Basic (Declaration)
Public Sub SaveGraphicState()
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas

instance.SaveGraphicState()
C#
public void SaveGraphicState()
Managed Extensions for C++
public: void SaveGraphicState();
C++/CLI
public:
void SaveGraphicState();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetAxesDirection Method

SetAxesDirection Method
See Also Example
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetAxesDirection Method

xAxisDirection
A xAxisDirection enumeration member specifying the new direction of the X axis.
yAxisDirection
A yAxisDirection enumeration member specifying the new direction of the Y axis.
Sets the new directions for the axes of the coordinate system.

Syntax

Visual Basic (Declaration)
Public Sub SetAxesDirection( _
   ByVal xAxisDirection As PDFXAxisDirection, _
   ByVal yAxisDirection As PDFYAxisDirection _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim xAxisDirection As PDFXAxisDirection
Dim yAxisDirection As PDFYAxisDirection

instance.SetAxesDirection(xAxisDirection, yAxisDirection)
C#
public void SetAxesDirection(
   PDFXAxisDirection xAxisDirection,
   PDFYAxisDirection yAxisDirection
)
Managed Extensions for C++
public: void SetAxesDirection(
   PDFXAxisDirection xAxisDirection,
   PDFYAxisDirection yAxisDirection
)
C++/CLI
public:
void SetAxesDirection(
   PDFXAxisDirection xAxisDirection,
   PDFYAxisDirection yAxisDirection
)

Parameters

xAxisDirection
A xAxisDirection enumeration member specifying the new direction of the X axis.
yAxisDirection
A yAxisDirection enumeration member specifying the new direction of the Y axis.

Example

The following example sets the direction of the Y axis to be from bottom to top. It also sets the origin of the coordinate system to bottom left corner of the page (this is the default coordinate system used by pdf files). The sample assumes the current origin of the coordinate system is at top left corner of the page.
C# Copy Code
...
page.Canvas.SetOrigin( 0, page.Height );
page.Canvas.SetAxesDirection( XAxisDirection.LeftToRight, YAxisDirection.BottomToTop );
// the default pdf coordinate system is now in place
...

Remarks

This method changes the direction of the axes of the coordinate system. The default directions are: top to bottom for the Y axis and left to right for the X axis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetBlendMode Method

SetBlendMode Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetBlendMode Method

blendMode
A PDFBlendMode enumeration member specifying how colors are combined.
Sets the blending mode for the subsequent drawing operations.

Syntax

Visual Basic (Declaration)
Public Sub SetBlendMode( _
   ByVal blendMode As PDFBlendMode _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim blendMode As PDFBlendMode

instance.SetBlendMode(blendMode)
C#
public void SetBlendMode(
   PDFBlendMode blendMode
)
Managed Extensions for C++
public: void SetBlendMode(
   PDFBlendMode blendMode
)
C++/CLI
public:
void SetBlendMode(
   PDFBlendMode blendMode
)

Parameters

blendMode
A PDFBlendMode enumeration member specifying how colors are combined.

Remarks

A blend mode specifies how backdrop color combine with source color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetClipRegion Method

SetClipRegion Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetClipRegion Method

clipPath
Sets a clipping region on page's canvas.

Syntax

Visual Basic (Declaration)
Public Sub SetClipRegion( _
   ByVal clipPath As PDFPath _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim clipPath As PDFPath

instance.SetClipRegion(clipPath)
C#
public void SetClipRegion(
   PDFPath clipPath
)
Managed Extensions for C++
public: void SetClipRegion(
   PDFPath* clipPath
)
C++/CLI
public:
void SetClipRegion(
   PDFPath^ clipPath
)

Parameters

clipPath

Remarks

The path that defines the clipping region must be a closed path.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetExtendedGraphicState Method

SetExtendedGraphicState Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetExtendedGraphicState Method

extendedGraphicState
The new graphic state.
Sets the current graphic state in the content stream.

Syntax

Visual Basic (Declaration)
Public Sub SetExtendedGraphicState( _
   ByVal extendedGraphicState As PDFExtendedGraphicState _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim extendedGraphicState As PDFExtendedGraphicState

instance.SetExtendedGraphicState(extendedGraphicState)
C#
public void SetExtendedGraphicState(
   PDFExtendedGraphicState extendedGraphicState
)
Managed Extensions for C++
public: void SetExtendedGraphicState(
   PDFExtendedGraphicState* extendedGraphicState
)
C++/CLI
public:
void SetExtendedGraphicState(
   PDFExtendedGraphicState^ extendedGraphicState
)

Parameters

extendedGraphicState
The new graphic state.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetLogicalUnit Method

SetLogicalUnit Method
See Also Example
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetLogicalUnit Method

logicalUnit
The new measure unit for subsequent drawing operations.
Sets the logical unit for the drawing operations.

Syntax

Visual Basic (Declaration)
Public Sub SetLogicalUnit( _
   ByVal logicalUnit As PDFLogicalUnitBase _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim logicalUnit As PDFLogicalUnitBase

instance.SetLogicalUnit(logicalUnit)
C#
public void SetLogicalUnit(
   PDFLogicalUnitBase logicalUnit
)
Managed Extensions for C++
public: void SetLogicalUnit(
   PDFLogicalUnitBase* logicalUnit
)
C++/CLI
public:
void SetLogicalUnit(
   PDFLogicalUnitBase^ logicalUnit
)

Parameters

logicalUnit
The new measure unit for subsequent drawing operations.

Example

The following example show how to draw different objects on the page using different logical units to position them.
C# Copy Code
...
PDFPen pen = new PDFPen(new PDFColor(255, 0, 0), 1);
PDFDocument doc = new PDFDocument();
PDFPage page = doc.AddPage();
page.Canvas.SetLogicalUnit(new PDFMMLogicalUnit());
// the following drawing operation uses the millimeter
// as a logical unit to draw the line. The milimeter
// was defined as default logical unit for the page.
page.Canvas.DrawLine(pen, 10, 10, 100, 100);

page.Canvas.SetLogicalUnit(new PDFPointLogicalUnit());
// the following drawing operation uses the point, as requested above,
// to draw the line.
page.Canvas.DrawLine(pen, 20, 10, 110, 100);
...

Remarks

The default logical unit used to position graphic objects on the page is the PDF point (1/72 inches). During the drawing operations, the logical unit can be changed in order to achieve desired functionality. In this way, some objects can be positioned on the page using one logical unit, while other objects can be positioned using another logical unit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetOrigin Method

SetOrigin Method
See Also Example
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetOrigin Method

newXAxisOrigin
The X coordinate of the origin.
newYAxisOrigin
The Y coordinate of the origin.
Sets the new point of origin for the coordinate system.

Syntax

Visual Basic (Declaration)
Public Sub SetOrigin( _
   ByVal newXAxisOrigin As Double, _
   ByVal newYAxisOrigin As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim newXAxisOrigin As Double
Dim newYAxisOrigin As Double

instance.SetOrigin(newXAxisOrigin, newYAxisOrigin)
C#
public void SetOrigin(
   double newXAxisOrigin,
   double newYAxisOrigin
)
Managed Extensions for C++
public: void SetOrigin(
   double newXAxisOrigin,
   double newYAxisOrigin
)
C++/CLI
public:
void SetOrigin(
   double newXAxisOrigin,
   double newYAxisOrigin
)

Parameters

newXAxisOrigin
The X coordinate of the origin.
newYAxisOrigin
The Y coordinate of the origin.

Example

The following example sets the origin of the coordinate system at 100mm from the left margin of the page and at 100mm from the top margin of the page. The example assumes the current origin is set at the top left corner of the page. The direction of the axes is left untouched, from top to bottom and from left to right.
C# Copy Code
...
page.Canvas.SetLogicalUnit(new PDFMMLogicalUnit());
page.Canvas.SetOrigin(100, 100);
...

Remarks

This method moves the origin of the coordinate system to the new position. The new position is always given relative to the current origin. The values specifying the new origin are given in logical units.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetOverprint Method

SetOverprint Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetOverprint Method

strokeOverprint
a value indicating whether overprint is enabled or not for stroke operations.
fillOverprint
a value indicating whether overprint is enabled or not for fill operations.
Sets the overprint for the subsequent drawing (stroke and fill) operations.

Syntax

Visual Basic (Declaration)
Public Sub SetOverprint( _
   ByVal strokeOverprint As Boolean, _
   ByVal fillOverprint As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim strokeOverprint As Boolean
Dim fillOverprint As Boolean

instance.SetOverprint(strokeOverprint, fillOverprint)
C#
public void SetOverprint(
   bool strokeOverprint,
   bool fillOverprint
)
Managed Extensions for C++
public: void SetOverprint(
   bool strokeOverprint,
   bool fillOverprint
)
C++/CLI
public:
void SetOverprint(
   bool strokeOverprint,
   bool fillOverprint
)

Parameters

strokeOverprint
a value indicating whether overprint is enabled or not for stroke operations.
fillOverprint
a value indicating whether overprint is enabled or not for fill operations.

Remarks

If true, the overprint is enabled for subsequent drawing (stroke and/or fill) operations.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


SetTransparency Method

SetTransparency Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : SetTransparency Method

transparency
a double value specifying the transparency level.
Sets the transparency level for the subsequent drawing operations.

Syntax

Visual Basic (Declaration)
Public Sub SetTransparency( _
   ByVal transparency As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim transparency As Double

instance.SetTransparency(transparency)
C#
public void SetTransparency(
   double transparency
)
Managed Extensions for C++
public: void SetTransparency(
   double transparency
)
C++/CLI
public:
void SetTransparency(
   double transparency
)

Parameters

transparency
a double value specifying the transparency level.

Remarks

The transparency level can take any value between 0 and 100. 100 means full transparency (100), 0 means opaque transparency).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBasicCanvas Class : ToString Method

Gets the string representation of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFBasicCanvas
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The canvas content as a string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasicCanvas Class
PDFBasicCanvas Members


PDFBrush Class

PDFBrush Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFBrush Class

Defines an object used to fill a closed shape with a single color.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFBrush
Visual Basic (Usage) Copy Code
Dim instance As PDFBrush
C#
public class PDFBrush
Managed Extensions for C++
public __gc class PDFBrush
C++/CLI
public ref class PDFBrush

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush
O2S.Components.PDF4NET.Graphics.PDFHatchBrush

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBrush Members
O2S.Components.PDF4NET.Graphics Namespace


PDFBrush Class Members

PDFBrush Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFBrush Class

The following tables list the members exposed by PDFBrush.

Public Constructors

 | Name | Description
Public Constructor | PDFBrush Constructor | Overloaded. Initializes a new PDFBrush object of White color.
Top

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object.
Top

See Also

Reference

PDFBrush Class
O2S.Components.PDF4NET.Graphics Namespace


PDFBrush Constructor

PDFBrush Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBrush Class : PDFBrush Constructor

Initializes a new PDFBrush object of White color.

Overload List

Overload | Description
PDFBrush Constructor() | Initializes a new PDFBrush object of White color.
PDFBrush Constructor(PDFBrush) | Initializes a new PDFBrush object based on the given brush.
PDFBrush Constructor(PDFColor) | Initializes a new PDFBrush object of the specified color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBrush Class
PDFBrush Members


PDFBrush Constructor()

PDFBrush Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBrush Class > PDFBrush Constructor : PDFBrush Constructor()

Initializes a new PDFBrush object of White color.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFBrush()
C#
public PDFBrush()
Managed Extensions for C++
public: PDFBrush();
C++/CLI
public:
PDFBrush();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBrush Class
PDFBrush Members
Overload List


PDFBrush Constructor(PDFBrush)

PDFBrush Constructor(PDFBrush)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBrush Class > PDFBrush Constructor : PDFBrush Constructor(PDFBrush)

brush
Initializes a new PDFBrush object based on the given brush.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal brush As PDFBrush _
)
Visual Basic (Usage) Copy Code
Dim brush As PDFBrush

Dim instance As PDFBrush(brush)
C#
public PDFBrush(
   PDFBrush brush
)
Managed Extensions for C++
public: PDFBrush(
   PDFBrush* brush
)
C++/CLI
public:
PDFBrush(
   PDFBrush^ brush
)

Parameters

brush

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBrush Class
PDFBrush Members
Overload List


PDFBrush Constructor(PDFColor)

PDFBrush Constructor(PDFColor)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBrush Class > PDFBrush Constructor : PDFBrush Constructor(PDFColor)

color
a O2S.Components.PDF4NET.Graphics.PDFColor object that represents the color of this brush
Initializes a new PDFBrush object of the specified color.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As PDFColor _
)
Visual Basic (Usage) Copy Code
Dim color As PDFColor

Dim instance As PDFBrush(color)
C#
public PDFBrush(
   PDFColor color
)
Managed Extensions for C++
public: PDFBrush(
   PDFColor* color
)
C++/CLI
public:
PDFBrush(
   PDFColor^ color
)

Parameters

color
a O2S.Components.PDF4NET.Graphics.PDFColor object that represents the color of this brush

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBrush Class
PDFBrush Members
Overload List


PDFBrush Class Properties

PDFBrush Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFBrush Class

For a list of all members of this type, see PDFBrush members.

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object.
Top

See Also

Reference

PDFBrush Class
O2S.Components.PDF4NET.Graphics Namespace


Color Property

Color Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFBrush Class : Color Property

Gets or sets the color of this Brush object.

Syntax

Visual Basic (Declaration)
Public Overridable Property Color As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFBrush
Dim value As PDFColor

instance.Color = value

value = instance.Color
C#
public virtual PDFColor Color {get; set;}
Managed Extensions for C++
public: __property virtual PDFColor* get_Color();
public: __property virtual void set_Color(
   PDFColor* value
);
C++/CLI
public:
virtual property PDFColor^ Color {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

The color of this brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBrush Class
PDFBrush Members


PDFCalGrayColor Class

PDFCalGrayColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCalGrayColor Class

Defines a calibrated gray color, based on a CalGray colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCalGrayColor
   Inherits PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColor
C#
public class PDFCalGrayColor : PDFColor
Managed Extensions for C++
public __gc class PDFCalGrayColor : public PDFColor
C++/CLI
public ref class PDFCalGrayColor : public PDFColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFCalGrayColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColor Members
O2S.Components.PDF4NET.Graphics Namespace


PDFCalGrayColor Class Members

PDFCalGrayColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCalGrayColor Class

The following tables list the members exposed by PDFCalGrayColor.

Public Constructors

 | Name | Description
Public Constructor | PDFCalGrayColor Constructor | Initializes a new PDFCalGrayColor object.
Top

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | Gray | Gets or sets the gray level for this color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFCalGrayColor Class
O2S.Components.PDF4NET.Graphics Namespace


PDFCalGrayColor Constructor

PDFCalGrayColor Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCalGrayColor Class : PDFCalGrayColor Constructor

colorSpace
a PDFCalGrayColorSpace object the color is based on.
Initializes a new PDFCalGrayColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorSpace As PDFCalGrayColorSpace _
)
Visual Basic (Usage) Copy Code
Dim colorSpace As PDFCalGrayColorSpace

Dim instance As PDFCalGrayColor(colorSpace)
C#
public PDFCalGrayColor(
   PDFCalGrayColorSpace colorSpace
)
Managed Extensions for C++
public: PDFCalGrayColor(
   PDFCalGrayColorSpace* colorSpace
)
C++/CLI
public:
PDFCalGrayColor(
   PDFCalGrayColorSpace^ colorSpace
)

Parameters

colorSpace
a PDFCalGrayColorSpace object the color is based on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColor Class
PDFCalGrayColor Members


PDFCalGrayColor Class Methods

PDFCalGrayColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCalGrayColor Class

For a list of all members of this type, see PDFCalGrayColor members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFCalGrayColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method

Clone Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCalGrayColor Class : Clone Method

Clones this color object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColor
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

A copy of this color object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColor Class
PDFCalGrayColor Members


Equals Method

Equals Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCalGrayColor Class : Equals Method

obj
Object to verify.
Verifies if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColor Class
PDFCalGrayColor Members


GetHashCode Method

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCalGrayColor Class : GetHashCode Method

Gets the hash code of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColor
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hashcode of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColor Class
PDFCalGrayColor Members


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCalGrayColor Class : ToString Method

Converts the color object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The color representation in PDF format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColor Class
PDFCalGrayColor Members


PDFCalGrayColor Class Properties

PDFCalGrayColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCalGrayColor Class

For a list of all members of this type, see PDFCalGrayColor members.

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | Gray | Gets or sets the gray level for this color.
Top

See Also

Reference

PDFCalGrayColor Class
O2S.Components.PDF4NET.Graphics Namespace


Gray Property

Gray Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCalGrayColor Class : Gray Property

Gets or sets the gray level for this color.

Syntax

Visual Basic (Declaration)
Public Property Gray As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColor
Dim value As Double

instance.Gray = value

value = instance.Gray
C#
public double Gray {get; set;}
Managed Extensions for C++
public: __property double get_Gray();
public: __property void set_Gray(
   double value
);
C++/CLI
public:
property double Gray {
   double get();
   void set (double value);
}

Return Value

The gray level of this color.

Remarks

The acceptable range for this value is [0.0 1.0].
0.0 means the darkest color that can be achieved, and 1.0 means the lightest color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColor Class
PDFCalGrayColor Members


PDFCalRgbColor Class

PDFCalRgbColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCalRgbColor Class

Defines a calibrated RGB color, based on a CalRGB colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCalRgbColor
   Inherits PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColor
C#
public class PDFCalRgbColor : PDFColor
Managed Extensions for C++
public __gc class PDFCalRgbColor : public PDFColor
C++/CLI
public ref class PDFCalRgbColor : public PDFColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFCalRgbColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColor Members
O2S.Components.PDF4NET.Graphics Namespace


PDFCalRgbColor Class Members

PDFCalRgbColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCalRgbColor Class

The following tables list the members exposed by PDFCalRgbColor.

Public Constructors

 | Name | Description
Public Constructor | PDFCalRgbColor Constructor | Initializes a new PDFCalRgbColor object.
Top

Public Properties

 | Name | Description
Public Property | Blue | Gets or sets the blue level for this color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | Green | Gets or sets the green level for this color.
Public Property | Red | Gets or sets the red level for this color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFCalRgbColor Class
O2S.Components.PDF4NET.Graphics Namespace


PDFCalRgbColor Constructor

PDFCalRgbColor Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCalRgbColor Class : PDFCalRgbColor Constructor

colorSpace
a PDFCalRgbColorSpace object the color is based on.
Initializes a new PDFCalRgbColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorSpace As PDFCalRgbColorSpace _
)
Visual Basic (Usage) Copy Code
Dim colorSpace As PDFCalRgbColorSpace

Dim instance As PDFCalRgbColor(colorSpace)
C#
public PDFCalRgbColor(
   PDFCalRgbColorSpace colorSpace
)
Managed Extensions for C++
public: PDFCalRgbColor(
   PDFCalRgbColorSpace* colorSpace
)
C++/CLI
public:
PDFCalRgbColor(
   PDFCalRgbColorSpace^ colorSpace
)

Parameters

colorSpace
a PDFCalRgbColorSpace object the color is based on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


PDFCalRgbColor Class Methods

PDFCalRgbColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCalRgbColor Class

For a list of all members of this type, see PDFCalRgbColor members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFCalRgbColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method

Clone Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCalRgbColor Class : Clone Method

Clones this color object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColor
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

A copy of this color object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


Equals Method

Equals Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCalRgbColor Class : Equals Method

obj
Object to verify.
Verifies if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


GetHashCode Method

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCalRgbColor Class : GetHashCode Method

Gets the hash code of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColor
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hashcode of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCalRgbColor Class : ToString Method

Converts the color object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The color representation in PDF format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


PDFCalRgbColor Class Properties

PDFCalRgbColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCalRgbColor Class

For a list of all members of this type, see PDFCalRgbColor members.

Public Properties

 | Name | Description
Public Property | Blue | Gets or sets the blue level for this color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | Green | Gets or sets the green level for this color.
Public Property | Red | Gets or sets the red level for this color.
Top

See Also

Reference

PDFCalRgbColor Class
O2S.Components.PDF4NET.Graphics Namespace


Blue Property

Blue Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCalRgbColor Class : Blue Property

Gets or sets the blue level for this color.

Syntax

Visual Basic (Declaration)
Public Property Blue As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColor
Dim value As Double

instance.Blue = value

value = instance.Blue
C#
public double Blue {get; set;}
Managed Extensions for C++
public: __property double get_Blue();
public: __property void set_Blue(
   double value
);
C++/CLI
public:
property double Blue {
   double get();
   void set (double value);
}

Return Value

The blue level of this color.

Remarks

The acceptable range for this value is [0.0 1.0].
0.0 means the darkest color that can be achieved, and 1.0 means the lightest color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


Green Property

Green Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCalRgbColor Class : Green Property

Gets or sets the green level for this color.

Syntax

Visual Basic (Declaration)
Public Property Green As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColor
Dim value As Double

instance.Green = value

value = instance.Green
C#
public double Green {get; set;}
Managed Extensions for C++
public: __property double get_Green();
public: __property void set_Green(
   double value
);
C++/CLI
public:
property double Green {
   double get();
   void set (double value);
}

Return Value

The green level of this color.

Remarks

The acceptable range for this value is [0.0 1.0].
0.0 means the darkest color that can be achieved, and 1.0 means the lightest color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


Red Property

Red Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCalRgbColor Class : Red Property

Gets or sets the red level for this color.

Syntax

Visual Basic (Declaration)
Public Property Red As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColor
Dim value As Double

instance.Red = value

value = instance.Red
C#
public double Red {get; set;}
Managed Extensions for C++
public: __property double get_Red();
public: __property void set_Red(
   double value
);
C++/CLI
public:
property double Red {
   double get();
   void set (double value);
}

Return Value

The red level of this color.

Remarks

The acceptable range for this value is [0.0 1.0].
0.0 means the darkest color that can be achieved, and 1.0 means the lightest color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColor Class
PDFCalRgbColor Members


PDFCanvas Class

PDFCanvas Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCanvas Class

Encapsulates a page's drawing surface.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PDFCanvas
   Inherits PDFBasicCanvas
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
C#
public sealed class PDFCanvas : PDFBasicCanvas
Managed Extensions for C++
public __gc __sealed class PDFCanvas : public PDFBasicCanvas
C++/CLI
public ref class PDFCanvas sealed : public PDFBasicCanvas

Remarks

This class is mainly used for creating the content of the document. All the drawing functions are exposed by this class. It can not be created directly, it is accessible through the Canvas property of PDFPage object.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBasicCanvas
O2S.Components.PDF4NET.Graphics.PDFCanvas

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Members
O2S.Components.PDF4NET.Graphics Namespace


PDFCanvas Class Members

PDFCanvas Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCanvas Class

The following tables list the members exposed by PDFCanvas.

Public Properties

 | Name | Description
Public Property | Layers | Gets the collection of layers available for this canvas.
Top

Public Methods

 | Name | Description
Public Method | Clear | Clears the canvas content. (Inherited from PDFBasicCanvas)
Public Method | DrawArc | Draws an arc representing a portion of an circle specified by a pair of coordinates and a width. (Inherited from PDFBasicCanvas)
Public Method | DrawBarcode | Overloaded. Draws the barcode on the canvas. (Inherited from PDFBasicCanvas)
Public Method | DrawBezier | Overloaded. Draws a Bezier spline specified by four pairs of coordinates. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawChord | Overloaded. Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width. (Inherited from PDFBasicCanvas)
Public Method | DrawFormXObject | Overloaded. Draws a form XObject specified by a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawHTMLText | Overloaded. Draws a line of text specified by a string and a pair of coordinates. (Inherited from PDFBasicCanvas)
Public Method | DrawHTMLTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawImage | Overloaded. Draws an image specified by a file name, a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawImportedContent | Overloaded. Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawLine | Overloaded. Draws a line connecting two points specified by coordinate pairs using the specified pen. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawLines | Overloaded. Draws a series of line segments that connect an array of PointF structures. (Inherited from PDFBasicCanvas)
Public Method | DrawPath | Overloaded. Draws a PDFPath object with the specified pen. (Inherited from PDFBasicCanvas)
Public Method | DrawPie | Overloaded. Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width. (Inherited from PDFBasicCanvas)
Public Method | DrawPolyBezier | Overloaded. Draws a series of connected curves defined by an array of PointF structures. (Inherited from PDFBasicCanvas)
Public Method | DrawPolygon | Overloaded. Draws a polygon defined by an array of PDFPoint objects. (Inherited from PDFBasicCanvas)
Public Method | DrawPolyPolygon | Overloaded. Draws a series of closed polygons, each one defined by an array of PDFPoint objects. (Inherited from PDFBasicCanvas)
Public Method | DrawRectangle | Overloaded. Draws a rectangle specified by a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawRoundRectangle | Overloaded. Draws a rounded rectangle specified by a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawText | Overloaded. Draws a line of text specified by a string and a pair of coordinates. (Inherited from PDFBasicCanvas)
Public Method | DrawTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | FitHtmlText | Overloaded. Calculates how much of the text really fits in the box. (Inherited from PDFBasicCanvas)
Public Method | FitText | Overloaded. Calculates how much of the given text fits in the given area. (Inherited from PDFBasicCanvas)
Public Method | GetHtmlTextBoxHeight | Overloaded. Gets the height of the wrapped HTML text. (Inherited from PDFBasicCanvas)
Public Method | GetHtmlTextBoxLastLineWidth | Overloaded. Gets the width of the last line in the HTML text box. (Inherited from PDFBasicCanvas)
Public Method | GetTextBoxHeight | Overloaded. Gets the height of the wrapped text. (Inherited from PDFBasicCanvas)
Public Method | GetTextBoxLastLineWidth | Gets the width of the last line in the text box. (Inherited from PDFBasicCanvas)
Public Method | ResetClipRegion | Resets the current clipping region to whole page. (Inherited from PDFBasicCanvas)
Public Method | RestoreGraphicState | Restores the current graphic state in the PDF content stream. (Inherited from PDFBasicCanvas)
Public Method | SaveGraphicState | Saves the current graphic state in the PDF content stream. (Inherited from PDFBasicCanvas)
Public Method | SetAxesDirection | Sets the new directions for the axes of the coordinate system. (Inherited from PDFBasicCanvas)
Public Method | SetBlendMode | Sets the blending mode for the subsequent drawing operations. (Inherited from PDFBasicCanvas)
Public Method | SetClipRegion | Sets a clipping region on page's canvas. (Inherited from PDFBasicCanvas)
Public Method | SetExtendedGraphicState | Sets the current graphic state in the content stream. (Inherited from PDFBasicCanvas)
Public Method | SetLogicalUnit | Sets the logical unit for the drawing operations. (Inherited from PDFBasicCanvas)
Public Method | SetOrigin | Sets the new point of origin for the coordinate system. (Inherited from PDFBasicCanvas)
Public Method | SetOverprint | Sets the overprint for the subsequent drawing (stroke and fill) operations. (Inherited from PDFBasicCanvas)
Public Method | SetTransparency | Sets the transparency level for the subsequent drawing operations. (Inherited from PDFBasicCanvas)
Public Method | ToString | Gets the string representation of this object. (Inherited from PDFBasicCanvas)
Top

See Also

Reference

PDFCanvas Class
O2S.Components.PDF4NET.Graphics Namespace


PDFCanvas Class Properties

PDFCanvas Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCanvas Class

For a list of all members of this type, see PDFCanvas members.

Public Properties

 | Name | Description
Public Property | Layers | Gets the collection of layers available for this canvas.
Top

See Also

Reference

PDFCanvas Class
O2S.Components.PDF4NET.Graphics Namespace


Layers Property

Layers Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCanvas Class : Layers Property

Gets the collection of layers available for this canvas.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Layers As PDFLayerCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFCanvas
Dim value As PDFLayerCollection

value = instance.Layers
C#
public PDFLayerCollection Layers {get;}
Managed Extensions for C++
public: __property PDFLayerCollection* get_Layers();
C++/CLI
public:
property PDFLayerCollection^ Layers {
   PDFLayerCollection^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCanvas Class
PDFCanvas Members


PDFCMLogicalUnit Class

PDFCMLogicalUnit Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCMLogicalUnit Class

Defines the centimeter as a logical unit.

Syntax

Visual Basic (Declaration)
Public Class PDFCMLogicalUnit
   Inherits PDFLogicalUnitBase
Visual Basic (Usage) Copy Code
Dim instance As PDFCMLogicalUnit
C#
public class PDFCMLogicalUnit : PDFLogicalUnitBase
Managed Extensions for C++
public __gc class PDFCMLogicalUnit : public PDFLogicalUnitBase
C++/CLI
public ref class PDFCMLogicalUnit : public PDFLogicalUnitBase

Remarks

This class defines the centimeter as a logical unit. The mapping between logical unit and pdf unit is 28.34646-to-1, one logical unit equals to 28.34646 pdf units. The mapping functions return the value given as parameter multiplied by 28.34646.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFLogicalUnitBase
O2S.Components.PDF4NET.Graphics.PDFCMLogicalUnit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCMLogicalUnit Members
O2S.Components.PDF4NET.Graphics Namespace


PDFCMLogicalUnit Class Members

PDFCMLogicalUnit Class Members
See Also Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCMLogicalUnit Class

The following tables list the members exposed by PDFCMLogicalUnit.

Public Constructors

 | Name | Description
Public Constructor | PDFCMLogicalUnit Constructor | Initializes a new PDFCMLogicalUnit object.
Top

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Overridden. Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Overridden. Defines the mapping between the logical unit and the pdf unit for the Y axis
Top

See Also

Reference

PDFCMLogicalUnit Class
O2S.Components.PDF4NET.Graphics Namespace


PDFCMLogicalUnit Constructor

PDFCMLogicalUnit Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCMLogicalUnit Class : PDFCMLogicalUnit Constructor

Initializes a new PDFCMLogicalUnit object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCMLogicalUnit()
C#
public PDFCMLogicalUnit()
Managed Extensions for C++
public: PDFCMLogicalUnit();
C++/CLI
public:
PDFCMLogicalUnit();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCMLogicalUnit Class
PDFCMLogicalUnit Members


PDFCMLogicalUnit Class Methods

PDFCMLogicalUnit Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCMLogicalUnit Class

For a list of all members of this type, see PDFCMLogicalUnit members.

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Overridden. Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Overridden. Defines the mapping between the logical unit and the pdf unit for the Y axis
Top

See Also

Reference

PDFCMLogicalUnit Class
O2S.Components.PDF4NET.Graphics Namespace


ToPDFUnitX Method

ToPDFUnitX Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCMLogicalUnit Class : ToPDFUnitX Method

unit
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the X axis

Syntax

Visual Basic (Declaration)
Overrides Public Function ToPDFUnitX( _
   ByVal unit As Double _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCMLogicalUnit
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitX(unit)
C#
public override double ToPDFUnitX(
   double unit
)
Managed Extensions for C++
public: double ToPDFUnitX(
   double unit
) override
C++/CLI
public:
double ToPDFUnitX(
   double unit
) override

Parameters

unit
the number of logical units to be converted to pdf units.

Remarks

This method is used to convert the X coordinates, which are always expressed in logical units, of a graphic object to pdf units on X axis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCMLogicalUnit Class
PDFCMLogicalUnit Members


ToPDFUnitY Method

ToPDFUnitY Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCMLogicalUnit Class : ToPDFUnitY Method

unit
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the Y axis

Syntax

Visual Basic (Declaration)
Overrides Public Function ToPDFUnitY( _
   ByVal unit As Double _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCMLogicalUnit
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitY(unit)
C#
public override double ToPDFUnitY(
   double unit
)
Managed Extensions for C++
public: double ToPDFUnitY(
   double unit
) override
C++/CLI
public:
double ToPDFUnitY(
   double unit
) override

Parameters

unit
the number of logical units to be converted to pdf units.

Remarks

This method is used to convert the Y coordinates, which are always expressed in logical units, of a graphic object to pdf units on Y axis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCMLogicalUnit Class
PDFCMLogicalUnit Members


PDFCmykColor Class

PDFCmykColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCmykColor Class

Defines a CMYK color, a color based on a CMYK device colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCmykColor
   Inherits PDFDeviceColor
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor
C#
public class PDFCmykColor : PDFDeviceColor
Managed Extensions for C++
public __gc class PDFCmykColor : public PDFDeviceColor
C++/CLI
public ref class PDFCmykColor : public PDFDeviceColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFDeviceColor
O2S.Components.PDF4NET.Graphics.PDFCmykColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Members
O2S.Components.PDF4NET.Graphics Namespace


PDFCmykColor Class Members

PDFCmykColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCmykColor Class

The following tables list the members exposed by PDFCmykColor.

Public Constructors

 | Name | Description
Public Constructor | PDFCmykColor Constructor | Overloaded. Initializes a new PDFRgbColor object.
Top

Public Properties

 | Name | Description
Public Property | C | Gets or sets the cyan component of the color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | K | Gets or sets the black component of the color.
Public Property | M | Gets or sets the magenta component of the color.
Public Property | Y | Gets or sets the yellow component of the color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFCmykColor Class
O2S.Components.PDF4NET.Graphics Namespace


PDFCmykColor Constructor

PDFCmykColor Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : PDFCmykColor Constructor

Initializes a new PDFRgbColor object.

Overload List

Overload | Description
PDFCmykColor Constructor() | Initializes a new PDFRgbColor object.
PDFCmykColor Constructor(Double,Double,Double,Double) | Initializes a new PDFCmykColor object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


PDFCmykColor Constructor()

PDFCmykColor Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class > PDFCmykColor Constructor : PDFCmykColor Constructor()

Initializes a new PDFRgbColor object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor()
C#
public PDFCmykColor()
Managed Extensions for C++
public: PDFCmykColor();
C++/CLI
public:
PDFCmykColor();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members
Overload List


PDFCmykColor Constructor(Double,Double,Double,Double)

PDFCmykColor Constructor(Double,Double,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class > PDFCmykColor Constructor : PDFCmykColor Constructor(Double,Double,Double,Double)

c
Cyan component of the color.
m
Magenta component of the color.
y
Yellow component of the color.
k
Black component of the color.
Initializes a new PDFCmykColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal c As Double, _
   ByVal m As Double, _
   ByVal y As Double, _
   ByVal k As Double _
)
Visual Basic (Usage) Copy Code
Dim c As Double
Dim m As Double
Dim y As Double
Dim k As Double

Dim instance As PDFCmykColor(c, m, y, k)
C#
public PDFCmykColor(
   double c,
   double m,
   double y,
   double k
)
Managed Extensions for C++
public: PDFCmykColor(
   double c,
   double m,
   double y,
   double k
)
C++/CLI
public:
PDFCmykColor(
   double c,
   double m,
   double y,
   double k
)

Parameters

c
Cyan component of the color.
m
Magenta component of the color.
y
Yellow component of the color.
k
Black component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members
Overload List


PDFCmykColor Class Methods

PDFCmykColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCmykColor Class

For a list of all members of this type, see PDFCmykColor members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFCmykColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method

Clone Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : Clone Method

Clones this color object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

A copy of this color object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


Equals Method

Equals Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : Equals Method

obj
Object to verify.
Verifies if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


GetHashCode Method

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : GetHashCode Method

Gets the hash code of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hashcode of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : ToString Method

Converts the color object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The color representation in PDF format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


PDFCmykColor Class Properties

PDFCmykColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCmykColor Class

For a list of all members of this type, see PDFCmykColor members.

Public Properties

 | Name | Description
Public Property | C | Gets or sets the cyan component of the color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | K | Gets or sets the black component of the color.
Public Property | M | Gets or sets the magenta component of the color.
Public Property | Y | Gets or sets the yellow component of the color.
Top

See Also

Reference

PDFCmykColor Class
O2S.Components.PDF4NET.Graphics Namespace


C Property

C Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : C Property

Gets or sets the cyan component of the color.

Syntax

Visual Basic (Declaration)
Public Property C As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor
Dim value As Double

instance.C = value

value = instance.C
C#
public double C {get; set;}
Managed Extensions for C++
public: __property double get_C();
public: __property void set_C(
   double value
);
C++/CLI
public:
property double C {
   double get();
   void set (double value);
}

Return Value

Cyan component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


K Property

K Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : K Property

Gets or sets the black component of the color.

Syntax

Visual Basic (Declaration)
Public Property K As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor
Dim value As Double

instance.K = value

value = instance.K
C#
public double K {get; set;}
Managed Extensions for C++
public: __property double get_K();
public: __property void set_K(
   double value
);
C++/CLI
public:
property double K {
   double get();
   void set (double value);
}

Return Value

Black component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


M Property

M Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : M Property

Gets or sets the magenta component of the color.

Syntax

Visual Basic (Declaration)
Public Property M As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor
Dim value As Double

instance.M = value

value = instance.M
C#
public double M {get; set;}
Managed Extensions for C++
public: __property double get_M();
public: __property void set_M(
   double value
);
C++/CLI
public:
property double M {
   double get();
   void set (double value);
}

Return Value

Magenta component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


Y Property

Y Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFCmykColor Class : Y Property

Gets or sets the yellow component of the color.

Syntax

Visual Basic (Declaration)
Public Property Y As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCmykColor
Dim value As Double

instance.Y = value

value = instance.Y
C#
public double Y {get; set;}
Managed Extensions for C++
public: __property double get_Y();
public: __property void set_Y(
   double value
);
C++/CLI
public:
property double Y {
   double get();
   void set (double value);
}

Return Value

Yellow component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCmykColor Class
PDFCmykColor Members


PDFColor Class

PDFColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFColor Class

Defines the base class for all PDF colors.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
C#
public abstract class PDFColor
Managed Extensions for C++
public __gc abstract class PDFColor
C++/CLI
public ref class PDFColor abstract

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFTilingPatternColor
O2S.Components.PDF4NET.Graphics.PDFShadingPatternColor
O2S.Components.PDF4NET.Graphics.PDFSeparationColor
O2S.Components.PDF4NET.Graphics.PDFLabColor
O2S.Components.PDF4NET.Graphics.PDFIndexedColor
O2S.Components.PDF4NET.Graphics.PDFICCColor
O2S.Components.PDF4NET.Graphics.PDFDeviceNColor
O2S.Components.PDF4NET.Graphics.PDFDeviceColor
O2S.Components.PDF4NET.Graphics.PDFCalRgbColor
O2S.Components.PDF4NET.Graphics.PDFCalGrayColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Members
O2S.Components.PDF4NET.Graphics Namespace


PDFColor Class Members

PDFColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFColor Class

The following tables list the members exposed by PDFColor.

Public Constructors

 | Name | Description
Public Constructor | PDFColor Constructor | Initializes a new O2S.Components.PDF4NET.Graphics.PDFColor object.
Top

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on.
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFColor Class
O2S.Components.PDF4NET.Graphics Namespace


PDFColor Constructor

PDFColor Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : PDFColor Constructor

colorSpace
a PDFColorSpace object the color is based on.
Initializes a new O2S.Components.PDF4NET.Graphics.PDFColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorSpace As PDFColorSpace _
)
Visual Basic (Usage) Copy Code
Dim colorSpace As PDFColorSpace

Dim instance As PDFColor(colorSpace)
C#
public PDFColor(
   PDFColorSpace colorSpace
)
Managed Extensions for C++
public: PDFColor(
   PDFColorSpace* colorSpace
)
C++/CLI
public:
PDFColor(
   PDFColorSpace^ colorSpace
)

Parameters

colorSpace
a PDFColorSpace object the color is based on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


PDFColor Class Methods

PDFColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFColor Class

For a list of all members of this type, see PDFColor members.

Public Methods

 | Name | Description
Public Method | Clone | Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method

Clone Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : Clone Method

Clones this color object.

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()
Managed Extensions for C++
public: virtual Object* Clone();
C++/CLI
public:
virtual Object^ Clone();

Return Value

A copy of this color object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


Equals Method

Equals Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : Equals Method

obj
Object to verify.
Verifies if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


GetHashCode Method

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : GetHashCode Method

Gets the hash code of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hashcode of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : ToString Method

Converts the color object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The color representation in PDF format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


PDFColor Class Properties

PDFColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFColor Class

For a list of all members of this type, see PDFColor members.

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on.
Top

See Also

Reference

PDFColor Class
O2S.Components.PDF4NET.Graphics Namespace


ColorSpace Property

ColorSpace Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFColor Class : ColorSpace Property

Gets the colorspace this color is based on.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColorSpace As PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFColor
Dim value As PDFColorSpace

value = instance.ColorSpace
C#
public PDFColorSpace ColorSpace {get;}
Managed Extensions for C++
public: __property PDFColorSpace* get_ColorSpace();
C++/CLI
public:
property PDFColorSpace^ ColorSpace {
   PDFColorSpace^ get();
}

Return Value

A colorspace object specifying the colorspace this color was created from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColor Class
PDFColor Members


PDFDeviceColor Class

PDFDeviceColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFDeviceColor Class

Defines a device based color.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFDeviceColor
   Inherits PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceColor
C#
public class PDFDeviceColor : PDFColor
Managed Extensions for C++
public __gc class PDFDeviceColor : public PDFColor
C++/CLI
public ref class PDFDeviceColor : public PDFColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFDeviceColor
O2S.Components.PDF4NET.Graphics.PDFRgbColor
O2S.Components.PDF4NET.Graphics.PDFGrayColor
O2S.Components.PDF4NET.Graphics.PDFCmykColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceColor Members
O2S.Components.PDF4NET.Graphics Namespace


PDFDeviceColor Class Members

PDFDeviceColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFDeviceColor Class

The following tables list the members exposed by PDFDeviceColor.

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones this color object. (Inherited from PDFColor)
Public Method | Equals | Verifies if the given object is equal to this object. (Inherited from PDFColor)
Public Method | GetHashCode | Gets the hash code of this object. (Inherited from PDFColor)
Public Method | ToString | Converts the color object to string representation. (Inherited from PDFColor)
Top

See Also

Reference

PDFDeviceColor Class
O2S.Components.PDF4NET.Graphics Namespace


PDFDeviceNColor Class

PDFDeviceNColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFDeviceNColor Class

Defines a DeviceN color, based on a DeviceN colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFDeviceNColor
   Inherits PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColor
C#
public class PDFDeviceNColor : PDFColor
Managed Extensions for C++
public __gc class PDFDeviceNColor : public PDFColor
C++/CLI
public ref class PDFDeviceNColor : public PDFColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFDeviceNColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColor Members
O2S.Components.PDF4NET.Graphics Namespace


PDFDeviceNColor Class Members

PDFDeviceNColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFDeviceNColor Class

The following tables list the members exposed by PDFDeviceNColor.

Public Constructors

 | Name | Description
Public Constructor | PDFDeviceNColor Constructor | Initializes a new PDFDeviceNColor object.
Top

Public Properties

 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFDeviceNColor Class
O2S.Components.PDF4NET.Graphics Namespace


PDFDeviceNColor Constructor

PDFDeviceNColor Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFDeviceNColor Class : PDFDeviceNColor Constructor

colorSpace
a PDFDeviceNColorSpace object the color is based on.
Initializes a new PDFDeviceNColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorSpace As PDFDeviceNColorSpace _
)
Visual Basic (Usage) Copy Code
Dim colorSpace As PDFDeviceNColorSpace

Dim instance As PDFDeviceNColor(colorSpace)
C#
public PDFDeviceNColor(
   PDFDeviceNColorSpace colorSpace
)
Managed Extensions for C++
public: PDFDeviceNColor(
   PDFDeviceNColorSpace* colorSpace
)
C++/CLI
public:
PDFDeviceNColor(
   PDFDeviceNColorSpace^ colorSpace
)

Parameters

colorSpace
a PDFDeviceNColorSpace object the color is based on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColor Class
PDFDeviceNColor Members


PDFDeviceNColor Class Methods

PDFDeviceNColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFDeviceNColor Class

For a list of all members of this type, see PDFDeviceNColor members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFDeviceNColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method

Clone Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFDeviceNColor Class : Clone Method

Clones this color object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColor
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

A copy of this color object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColor Class
PDFDeviceNColor Members


Equals Method

Equals Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFDeviceNColor Class : Equals Method

obj
Object to verify.
Verifies if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColor Class
PDFDeviceNColor Members


GetHashCode Method

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFDeviceNColor Class : GetHashCode Method

Gets the hash code of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColor
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hashcode of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColor Class
PDFDeviceNColor Members


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFDeviceNColor Class : ToString Method

Converts the color object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The color representation in PDF format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColor Class
PDFDeviceNColor Members


PDFDeviceNColor Class Properties

PDFDeviceNColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFDeviceNColor Class

For a list of all members of this type, see PDFDeviceNColor members.

Public Properties

 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Top

See Also

Reference

PDFDeviceNColor Class
O2S.Components.PDF4NET.Graphics Namespace


ColorComponents Property

ColorComponents Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFDeviceNColor Class : ColorComponents Property

Gets or sets the color components.

Syntax

Visual Basic (Declaration)
Public Property ColorComponents As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColor
Dim value() As Double

instance.ColorComponents = value

value = instance.ColorComponents
C#
public double[] ColorComponents {get; set;}
Managed Extensions for C++
public: __property double[]* get_ColorComponents();
public: __property void set_ColorComponents(
   double[]* value
);
C++/CLI
public:
property array<double>^ ColorComponents {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of values that describe the color in the DeviceN colorspace.

Remarks

The length of this array must match the number of PDFDeviceNColorSpace.ColorantNames in the underlying DeviceN colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColor Class
PDFDeviceNColor Members


PDFExtendedGraphicState Class

PDFExtendedGraphicState Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFExtendedGraphicState Class

Defines the current graphic state in a PDF content stream.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFExtendedGraphicState
Visual Basic (Usage) Copy Code
Dim instance As PDFExtendedGraphicState
C#
public class PDFExtendedGraphicState
Managed Extensions for C++
public __gc class PDFExtendedGraphicState
C++/CLI
public ref class PDFExtendedGraphicState

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFExtendedGraphicState

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFExtendedGraphicState Members
O2S.Components.PDF4NET.Graphics Namespace


PDFExtendedGraphicState Class Members

PDFExtendedGraphicState Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFExtendedGraphicState Class

The following tables list the members exposed by PDFExtendedGraphicState.

Public Constructors

 | Name | Description
Public Constructor | PDFExtendedGraphicState Constructor | Initializes a new PDFGraphicState object.
Top

Public Properties

 | Name | Description
Public Property | BlendMode | Gets or sets the blend mode.
Public Property | Dictionary | Gets the extended graphic state dictionary.
Public Property | FillAlpha | Gets or sets the value for the alpha channel for fill operations.
Public Property | FillOverprint | Gets or sets the value for the overprint flag for fill operations.
Public Property | StrokeAlpha | Gets or sets the value for the alpha channel for stroke operations.
Public Property | StrokeOverprint | Gets or sets the value for the overprint flag for stroke operations.
Top

See Also

Reference

PDFExtendedGraphicState Class
O2S.Components.PDF4NET.Graphics Namespace


PDFExtendedGraphicState Constructor

PDFExtendedGraphicState Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFExtendedGraphicState Class : PDFExtendedGraphicState Constructor

Initializes a new PDFGraphicState object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFExtendedGraphicState()
C#
public PDFExtendedGraphicState()
Managed Extensions for C++
public: PDFExtendedGraphicState();
C++/CLI
public:
PDFExtendedGraphicState();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFExtendedGraphicState Class
PDFExtendedGraphicState Members


PDFExtendedGraphicState Class Properties

PDFExtendedGraphicState Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFExtendedGraphicState Class

For a list of all members of this type, see PDFExtendedGraphicState members.

Public Properties

 | Name | Description
Public Property | BlendMode | Gets or sets the blend mode.
Public Property | Dictionary | Gets the extended graphic state dictionary.
Public Property | FillAlpha | Gets or sets the value for the alpha channel for fill operations.
Public Property | FillOverprint | Gets or sets the value for the overprint flag for fill operations.
Public Property | StrokeAlpha | Gets or sets the value for the alpha channel for stroke operations.
Public Property | StrokeOverprint | Gets or sets the value for the overprint flag for stroke operations.
Top

See Also

Reference

PDFExtendedGraphicState Class
O2S.Components.PDF4NET.Graphics Namespace


BlendMode Property

BlendMode Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFExtendedGraphicState Class : BlendMode Property

Gets or sets the blend mode.

Syntax

Visual Basic (Declaration)
Public Property BlendMode As PDFBlendMode
Visual Basic (Usage) Copy Code
Dim instance As PDFExtendedGraphicState
Dim value As PDFBlendMode

instance.BlendMode = value

value = instance.BlendMode
C#
public PDFBlendMode BlendMode {get; set;}
Managed Extensions for C++
public: __property PDFBlendMode get_BlendMode();
public: __property void set_BlendMode(
   PDFBlendMode value
);
C++/CLI
public:
property PDFBlendMode BlendMode {
   PDFBlendMode get();
   void set (PDFBlendMode value);
}

Return Value

The blend mode for the drawing operations.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFExtendedGraphicState Class
PDFExtendedGraphicState Members


Dictionary Property

Dictionary Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFExtendedGraphicState Class : Dictionary Property

Gets the extended graphic state dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dictionary As PDFDictionary
Visual Basic (Usage) Copy Code
Dim instance As PDFExtendedGraphicState
Dim value As PDFDictionary

value = instance.Dictionary
C#
public PDFDictionary Dictionary {get;}
Managed Extensions for C++
public: __property PDFDictionary* get_Dictionary();
C++/CLI
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Return Value

The raw extended graphic state dictionary.

Remarks

This property gives you direct access to extended graphic state dictionary and its associated resources. Note: Modifying directly the extended graphic state dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFExtendedGraphicState Class
PDFExtendedGraphicState Members


FillAlpha Property

FillAlpha Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFExtendedGraphicState Class : FillAlpha Property

Gets or sets the value for the alpha channel for fill operations.

Syntax

Visual Basic (Declaration)
Public Property FillAlpha As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFExtendedGraphicState
Dim value As Double

instance.FillAlpha = value

value = instance.FillAlpha
C#
public double FillAlpha {get; set;}
Managed Extensions for C++
public: __property double get_FillAlpha();
public: __property void set_FillAlpha(
   double value
);
C++/CLI
public:
property double FillAlpha {
   double get();
   void set (double value);
}

Return Value

A value between 0 and 100 specifying the value for the alpha channel for fill operations.

Remarks

0 means full transparency, 100 means full opacity.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFExtendedGraphicState Class
PDFExtendedGraphicState Members


FillOverprint Property

FillOverprint Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFExtendedGraphicState Class : FillOverprint Property

Gets or sets the value for the overprint flag for fill operations.

Syntax

Visual Basic (Declaration)
Public Property FillOverprint As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFExtendedGraphicState
Dim value As Boolean

instance.FillOverprint = value

value = instance.FillOverprint
C#
public bool FillOverprint {get; set;}
Managed Extensions for C++
public: __property bool get_FillOverprint();
public: __property void set_FillOverprint(
   bool value
);
C++/CLI
public:
property bool FillOverprint {
   bool get();
   void set (bool value);
}

Return Value

True if overprinting should be enabled for fill operations, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFExtendedGraphicState Class
PDFExtendedGraphicState Members


StrokeAlpha Property

StrokeAlpha Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFExtendedGraphicState Class : StrokeAlpha Property

Gets or sets the value for the alpha channel for stroke operations.

Syntax

Visual Basic (Declaration)
Public Property StrokeAlpha As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFExtendedGraphicState
Dim value As Double

instance.StrokeAlpha = value

value = instance.StrokeAlpha
C#
public double StrokeAlpha {get; set;}
Managed Extensions for C++
public: __property double get_StrokeAlpha();
public: __property void set_StrokeAlpha(
   double value
);
C++/CLI
public:
property double StrokeAlpha {
   double get();
   void set (double value);
}

Return Value

A value between 0 and 100 specifying the value for the alpha channel for stroking operations.

Remarks

0 means full transparency, 100 means full opacity.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFExtendedGraphicState Class
PDFExtendedGraphicState Members


StrokeOverprint Property

StrokeOverprint Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFExtendedGraphicState Class : StrokeOverprint Property

Gets or sets the value for the overprint flag for stroke operations.

Syntax

Visual Basic (Declaration)
Public Property StrokeOverprint As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFExtendedGraphicState
Dim value As Boolean

instance.StrokeOverprint = value

value = instance.StrokeOverprint
C#
public bool StrokeOverprint {get; set;}
Managed Extensions for C++
public: __property bool get_StrokeOverprint();
public: __property void set_StrokeOverprint(
   bool value
);
C++/CLI
public:
property bool StrokeOverprint {
   bool get();
   void set (bool value);
}

Return Value

True if overprinting should be enabled for stroke operations, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFExtendedGraphicState Class
PDFExtendedGraphicState Members


PDFGrayColor Class

PDFGrayColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFGrayColor Class

Defines a Gray color, a color based on a Gray device colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFGrayColor
   Inherits PDFDeviceColor
Visual Basic (Usage) Copy Code
Dim instance As PDFGrayColor
C#
public class PDFGrayColor : PDFDeviceColor
Managed Extensions for C++
public __gc class PDFGrayColor : public PDFDeviceColor
C++/CLI
public ref class PDFGrayColor : public PDFDeviceColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFDeviceColor
O2S.Components.PDF4NET.Graphics.PDFGrayColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGrayColor Members
O2S.Components.PDF4NET.Graphics Namespace


PDFGrayColor Class Members

PDFGrayColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFGrayColor Class

The following tables list the members exposed by PDFGrayColor.

Public Constructors

 | Name | Description
Public Constructor | PDFGrayColor Constructor | Overloaded. Initializes a new PDFGrayColor object.
Top

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | G | Gets or sets the gray level of the color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFGrayColor Class
O2S.Components.PDF4NET.Graphics Namespace


PDFGrayColor Constructor

PDFGrayColor Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFGrayColor Class : PDFGrayColor Constructor

Initializes a new PDFGrayColor object.

Overload List

Overload | Description
PDFGrayColor Constructor() | Initializes a new PDFGrayColor object.
PDFGrayColor Constructor(Double) | Initializes a new PDFGrayColor object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


PDFGrayColor Constructor()

PDFGrayColor Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFGrayColor Class > PDFGrayColor Constructor : PDFGrayColor Constructor()

Initializes a new PDFGrayColor object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFGrayColor()
C#
public PDFGrayColor()
Managed Extensions for C++
public: PDFGrayColor();
C++/CLI
public:
PDFGrayColor();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members
Overload List


PDFGrayColor Constructor(Double)

PDFGrayColor Constructor(Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFGrayColor Class > PDFGrayColor Constructor : PDFGrayColor Constructor(Double)

g
Gray level of the color.
Initializes a new PDFGrayColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal g As Double _
)
Visual Basic (Usage) Copy Code
Dim g As Double

Dim instance As PDFGrayColor(g)
C#
public PDFGrayColor(
   double g
)
Managed Extensions for C++
public: PDFGrayColor(
   double g
)
C++/CLI
public:
PDFGrayColor(
   double g
)

Parameters

g
Gray level of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members
Overload List


PDFGrayColor Class Methods

PDFGrayColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFGrayColor Class

For a list of all members of this type, see PDFGrayColor members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFGrayColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method

Clone Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFGrayColor Class : Clone Method

Clones this color object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFGrayColor
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

A copy of this color object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


Equals Method

Equals Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFGrayColor Class : Equals Method

obj
Object to verify.
Verifies if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFGrayColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


GetHashCode Method

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFGrayColor Class : GetHashCode Method

Gets the hash code of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFGrayColor
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hashcode of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFGrayColor Class : ToString Method

Converts the color object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFGrayColor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The color representation in PDF format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


PDFGrayColor Class Properties

PDFGrayColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFGrayColor Class

For a list of all members of this type, see PDFGrayColor members.

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | G | Gets or sets the gray level of the color.
Top

See Also

Reference

PDFGrayColor Class
O2S.Components.PDF4NET.Graphics Namespace


G Property

G Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFGrayColor Class : G Property

Gets or sets the gray level of the color.

Syntax

Visual Basic (Declaration)
Public Property G As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFGrayColor
Dim value As Double

instance.G = value

value = instance.G
C#
public double G {get; set;}
Managed Extensions for C++
public: __property double get_G();
public: __property void set_G(
   double value
);
C++/CLI
public:
property double G {
   double get();
   void set (double value);
}

Return Value

Gray level of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGrayColor Class
PDFGrayColor Members


PDFHatchBrush Class

PDFHatchBrush Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFHatchBrush Class

Defines a hatch brush for filling closed shapes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFHatchBrush
   Inherits PDFBrush
Visual Basic (Usage) Copy Code
Dim instance As PDFHatchBrush
C#
public class PDFHatchBrush : PDFBrush
Managed Extensions for C++
public __gc class PDFHatchBrush : public PDFBrush
C++/CLI
public ref class PDFHatchBrush : public PDFBrush

Remarks

The type of the hatch brush is defined by the PDFHatchType enumeration.
A hatch brush uses a hatch cell as its basic drawing unit. The hatch cells are drawn repeatedly from left to right, and top to bottom till the closed shaped is filled.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFHatchBrush

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchBrush Members
O2S.Components.PDF4NET.Graphics Namespace


PDFHatchBrush Class Members

PDFHatchBrush Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFHatchBrush Class

The following tables list the members exposed by PDFHatchBrush.

Public Constructors

 | Name | Description
Public Constructor | PDFHatchBrush Constructor | Initializes a new PDFHatchBrush object.
Top

Public Properties

 | Name | Description
Public Property | Color | Overridden. Gets or sets the color of this Brush object.
Public Property | HatchBackColor | Gets or sets the hatch background color.
Public Property | HatchForeColor | Gets or sets the hatch foreground color.
Public Property | HatchHorizontalSize | Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.
Public Property | HatchType | Gets or sets the hatch type for this PDFHatchBrush object.
Public Property | HatchVerticalSize | Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.
Top

See Also

Reference

PDFHatchBrush Class
O2S.Components.PDF4NET.Graphics Namespace


PDFHatchBrush Constructor

PDFHatchBrush Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : PDFHatchBrush Constructor

hatchType
Initializes a new PDFHatchBrush object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal hatchType As PDFHatchType _
)
Visual Basic (Usage) Copy Code
Dim hatchType As PDFHatchType

Dim instance As PDFHatchBrush(hatchType)
C#
public PDFHatchBrush(
   PDFHatchType hatchType
)
Managed Extensions for C++
public: PDFHatchBrush(
   PDFHatchType hatchType
)
C++/CLI
public:
PDFHatchBrush(
   PDFHatchType hatchType
)

Parameters

hatchType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


PDFHatchBrush Class Properties

PDFHatchBrush Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFHatchBrush Class

For a list of all members of this type, see PDFHatchBrush members.

Public Properties

 | Name | Description
Public Property | Color | Overridden. Gets or sets the color of this Brush object.
Public Property | HatchBackColor | Gets or sets the hatch background color.
Public Property | HatchForeColor | Gets or sets the hatch foreground color.
Public Property | HatchHorizontalSize | Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.
Public Property | HatchType | Gets or sets the hatch type for this PDFHatchBrush object.
Public Property | HatchVerticalSize | Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.
Top

See Also

Reference

PDFHatchBrush Class
O2S.Components.PDF4NET.Graphics Namespace


Color Property

Color Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : Color Property

Gets or sets the color of this Brush object.

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFHatchBrush
Dim value As PDFColor

instance.Color = value

value = instance.Color
C#
public override PDFColor Color {get; set;}
Managed Extensions for C++
public: __property PDFColor* get_Color()override ;
public: __property void set_Color(
   PDFColor* value
)override ;
C++/CLI
public:
property PDFColor^ Color override {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

The color of this brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


HatchBackColor Property

HatchBackColor Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : HatchBackColor Property

Gets or sets the hatch background color.

Syntax

Visual Basic (Declaration)
Public Property HatchBackColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFHatchBrush
Dim value As PDFColor

instance.HatchBackColor = value

value = instance.HatchBackColor
C#
public PDFColor HatchBackColor {get; set;}
Managed Extensions for C++
public: __property PDFColor* get_HatchBackColor();
public: __property void set_HatchBackColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ HatchBackColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the background color of the hatch.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


HatchForeColor Property

HatchForeColor Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : HatchForeColor Property

Gets or sets the hatch foreground color.

Syntax

Visual Basic (Declaration)
Public Property HatchForeColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFHatchBrush
Dim value As PDFColor

instance.HatchForeColor = value

value = instance.HatchForeColor
C#
public PDFColor HatchForeColor {get; set;}
Managed Extensions for C++
public: __property PDFColor* get_HatchForeColor();
public: __property void set_HatchForeColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ HatchForeColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the foreground color of the hatch.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


HatchHorizontalSize Property

HatchHorizontalSize Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : HatchHorizontalSize Property

Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.

Syntax

Visual Basic (Declaration)
Public Property HatchHorizontalSize As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFHatchBrush
Dim value As Double

instance.HatchHorizontalSize = value

value = instance.HatchHorizontalSize
C#
public double HatchHorizontalSize {get; set;}
Managed Extensions for C++
public: __property double get_HatchHorizontalSize();
public: __property void set_HatchHorizontalSize(
   double value
);
C++/CLI
public:
property double HatchHorizontalSize {
   double get();
   void set (double value);
}

Return Value

A float value specfying the size of horizontal of the hatch cell for this brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


HatchType Property

HatchType Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : HatchType Property

Gets or sets the hatch type for this PDFHatchBrush object.

Syntax

Visual Basic (Declaration)
Public Property HatchType As PDFHatchType
Visual Basic (Usage) Copy Code
Dim instance As PDFHatchBrush
Dim value As PDFHatchType

instance.HatchType = value

value = instance.HatchType
C#
public PDFHatchType HatchType {get; set;}
Managed Extensions for C++
public: __property PDFHatchType get_HatchType();
public: __property void set_HatchType(
   PDFHatchType value
);
C++/CLI
public:
property PDFHatchType HatchType {
   PDFHatchType get();
   void set (PDFHatchType value);
}

Return Value

A HatchType enumeration member specfying the hatch type for this brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


HatchVerticalSize Property

HatchVerticalSize Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHatchBrush Class : HatchVerticalSize Property

Gets or sets the size on horizontal of the hatch cell for this PDFHatchBrush object.

Syntax

Visual Basic (Declaration)
Public Property HatchVerticalSize As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFHatchBrush
Dim value As Double

instance.HatchVerticalSize = value

value = instance.HatchVerticalSize
C#
public double HatchVerticalSize {get; set;}
Managed Extensions for C++
public: __property double get_HatchVerticalSize();
public: __property void set_HatchVerticalSize(
   double value
);
C++/CLI
public:
property double HatchVerticalSize {
   double get();
   void set (double value);
}

Return Value

A float value specfying the size of horizontal of the hatch cell for this brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchBrush Class
PDFHatchBrush Members


PDFHatchPattern Class

PDFHatchPattern Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFHatchPattern Class

Defines a PDF hatch pattern.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFHatchPattern
   Inherits PDFTilingPattern
Visual Basic (Usage) Copy Code
Dim instance As PDFHatchPattern
C#
public class PDFHatchPattern : PDFTilingPattern
Managed Extensions for C++
public __gc class PDFHatchPattern : public PDFTilingPattern
C++/CLI
public ref class PDFHatchPattern : public PDFTilingPattern

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.PDFPattern
O2S.Components.PDF4NET.Graphics.PDFTilingPattern
O2S.Components.PDF4NET.Graphics.PDFHatchPattern

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchPattern Members
O2S.Components.PDF4NET.Graphics Namespace


PDFHatchPattern Class Members

PDFHatchPattern Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFHatchPattern Class

The following tables list the members exposed by PDFHatchPattern.

Public Constructors

 | Name | Description
Public Constructor | PDFHatchPattern Constructor | Initializes a new PDFHatchPattern object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the hatch.
Public Property | Canvas | Gets the pattern canvas. (Inherited from PDFTilingPattern)
Public Property | ForeColor | Gets or sets the foreground color of the hatch.
Public Property | HatchType | Gets or sets the hatch type for this PDFHatchPattern object.
Public Property | Height | Gets or sets the height of the pattern cell. (Inherited from PDFTilingPattern)
Public Property | Width | Gets or sets the width of the pattern cell. (Inherited from PDFTilingPattern)
Public Property | XStep | Gets or sets the horizontal spacing between pattern cells. (Inherited from PDFTilingPattern)
Public Property | YStep | Gets or sets the vertical spacing between pattern cells. (Inherited from PDFTilingPattern)
Top

See Also

Reference

PDFHatchPattern Class
O2S.Components.PDF4NET.Graphics Namespace


PDFHatchPattern Constructor

PDFHatchPattern Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHatchPattern Class : PDFHatchPattern Constructor

hatchType
The type of the hatch for the pattern.
Initializes a new PDFHatchPattern object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal hatchType As PDFHatchType _
)
Visual Basic (Usage) Copy Code
Dim hatchType As PDFHatchType

Dim instance As PDFHatchPattern(hatchType)
C#
public PDFHatchPattern(
   PDFHatchType hatchType
)
Managed Extensions for C++
public: PDFHatchPattern(
   PDFHatchType hatchType
)
C++/CLI
public:
PDFHatchPattern(
   PDFHatchType hatchType
)

Parameters

hatchType
The type of the hatch for the pattern.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchPattern Class
PDFHatchPattern Members


PDFHatchPattern Class Properties

PDFHatchPattern Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFHatchPattern Class

For a list of all members of this type, see PDFHatchPattern members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the hatch.
Public Property | Canvas | Gets the pattern canvas. (Inherited from PDFTilingPattern)
Public Property | ForeColor | Gets or sets the foreground color of the hatch.
Public Property | HatchType | Gets or sets the hatch type for this PDFHatchPattern object.
Public Property | Height | Gets or sets the height of the pattern cell. (Inherited from PDFTilingPattern)
Public Property | Width | Gets or sets the width of the pattern cell. (Inherited from PDFTilingPattern)
Public Property | XStep | Gets or sets the horizontal spacing between pattern cells. (Inherited from PDFTilingPattern)
Public Property | YStep | Gets or sets the vertical spacing between pattern cells. (Inherited from PDFTilingPattern)
Top

See Also

Reference

PDFHatchPattern Class
O2S.Components.PDF4NET.Graphics Namespace


BackColor Property

BackColor Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHatchPattern Class : BackColor Property

Gets or sets the background color of the hatch.

Syntax

Visual Basic (Declaration)
Public Property BackColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFHatchPattern
Dim value As PDFColor

instance.BackColor = value

value = instance.BackColor
C#
public PDFColor BackColor {get; set;}
Managed Extensions for C++
public: __property PDFColor* get_BackColor();
public: __property void set_BackColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ BackColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the background color for this pattern object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchPattern Class
PDFHatchPattern Members


ForeColor Property

ForeColor Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHatchPattern Class : ForeColor Property

Gets or sets the foreground color of the hatch.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFHatchPattern
Dim value As PDFColor

instance.ForeColor = value

value = instance.ForeColor
C#
public PDFColor ForeColor {get; set;}
Managed Extensions for C++
public: __property PDFColor* get_ForeColor();
public: __property void set_ForeColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ ForeColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the foreground color for this pattern object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchPattern Class
PDFHatchPattern Members


HatchType Property

HatchType Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHatchPattern Class : HatchType Property

Gets or sets the hatch type for this PDFHatchPattern object.

Syntax

Visual Basic (Declaration)
Public Property HatchType As PDFHatchType
Visual Basic (Usage) Copy Code
Dim instance As PDFHatchPattern
Dim value As PDFHatchType

instance.HatchType = value

value = instance.HatchType
C#
public PDFHatchType HatchType {get; set;}
Managed Extensions for C++
public: __property PDFHatchType get_HatchType();
public: __property void set_HatchType(
   PDFHatchType value
);
C++/CLI
public:
property PDFHatchType HatchType {
   PDFHatchType get();
   void set (PDFHatchType value);
}

Return Value

A PDFHatchType enumeration member specifying the type of hatch for this pattern.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHatchPattern Class
PDFHatchPattern Members


PDFHorizontalGradientBrush Class

PDFHorizontalGradientBrush Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFHorizontalGradientBrush Class

Defines a horizontal gradient brush for filling closed shapes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFHorizontalGradientBrush
   Inherits PDFLinearGradientBrush
Visual Basic (Usage) Copy Code
Dim instance As PDFHorizontalGradientBrush
C#
public class PDFHorizontalGradientBrush : PDFLinearGradientBrush
Managed Extensions for C++
public __gc class PDFHorizontalGradientBrush : public PDFLinearGradientBrush
C++/CLI
public ref class PDFHorizontalGradientBrush : public PDFLinearGradientBrush

Remarks

A horizontal gradient starts on the left and ends on the right of the filled shape.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush
O2S.Components.PDF4NET.Graphics.PDFHorizontalGradientBrush

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHorizontalGradientBrush Members
O2S.Components.PDF4NET.Graphics Namespace


PDFHorizontalGradientBrush Class Members

PDFHorizontalGradientBrush Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFHorizontalGradientBrush Class

The following tables list the members exposed by PDFHorizontalGradientBrush.

Public Constructors

 | Name | Description
Public Constructor | PDFHorizontalGradientBrush Constructor | Initializes a new PDFHorizontalGradientBrush object.
Top

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. (Inherited from PDFLinearGradientBrush)
Public Property | EndColor | (Inherited from PDFLinearGradientBrush)
Public Property | StartColor | Gets or sets the start color of the gradient. (Inherited from PDFLinearGradientBrush)
Top

See Also

Reference

PDFHorizontalGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


PDFHorizontalGradientBrush Constructor

PDFHorizontalGradientBrush Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFHorizontalGradientBrush Class : PDFHorizontalGradientBrush Constructor

Initializes a new PDFHorizontalGradientBrush object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFHorizontalGradientBrush()
C#
public PDFHorizontalGradientBrush()
Managed Extensions for C++
public: PDFHorizontalGradientBrush();
C++/CLI
public:
PDFHorizontalGradientBrush();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHorizontalGradientBrush Class
PDFHorizontalGradientBrush Members


PDFICCColor Class

PDFICCColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFICCColor Class

Defines an ICC color, based on an ICC colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFICCColor
   Inherits PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColor
C#
public class PDFICCColor : PDFColor
Managed Extensions for C++
public __gc class PDFICCColor : public PDFColor
C++/CLI
public ref class PDFICCColor : public PDFColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFICCColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColor Members
O2S.Components.PDF4NET.Graphics Namespace


PDFICCColor Class Members

PDFICCColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFICCColor Class

The following tables list the members exposed by PDFICCColor.

Public Constructors

 | Name | Description
Public Constructor | PDFICCColor Constructor | Initializes a new PDFICCColor object.
Top

Public Properties

 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFICCColor Class
O2S.Components.PDF4NET.Graphics Namespace


PDFICCColor Constructor

PDFICCColor Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFICCColor Class : PDFICCColor Constructor

colorSpace
a PDFICCColorSpace object the color is based on.
Initializes a new PDFICCColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorSpace As PDFICCColorSpace _
)
Visual Basic (Usage) Copy Code
Dim colorSpace As PDFICCColorSpace

Dim instance As PDFICCColor(colorSpace)
C#
public PDFICCColor(
   PDFICCColorSpace colorSpace
)
Managed Extensions for C++
public: PDFICCColor(
   PDFICCColorSpace* colorSpace
)
C++/CLI
public:
PDFICCColor(
   PDFICCColorSpace^ colorSpace
)

Parameters

colorSpace
a PDFICCColorSpace object the color is based on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColor Class
PDFICCColor Members


PDFICCColor Class Methods

PDFICCColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFICCColor Class

For a list of all members of this type, see PDFICCColor members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFICCColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method

Clone Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFICCColor Class : Clone Method

Clones this color object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColor
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

A copy of this color object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColor Class
PDFICCColor Members


Equals Method

Equals Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFICCColor Class : Equals Method

obj
Object to verify.
Verifies if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColor Class
PDFICCColor Members


GetHashCode Method

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFICCColor Class : GetHashCode Method

Gets the hash code of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColor
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hashcode of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColor Class
PDFICCColor Members


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFICCColor Class : ToString Method

Converts the color object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The color representation in PDF format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColor Class
PDFICCColor Members


PDFICCColor Class Properties

PDFICCColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFICCColor Class

For a list of all members of this type, see PDFICCColor members.

Public Properties

 | Name | Description
Public Property | ColorComponents | Gets or sets the color components.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Top

See Also

Reference

PDFICCColor Class
O2S.Components.PDF4NET.Graphics Namespace


ColorComponents Property

ColorComponents Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFICCColor Class : ColorComponents Property

Gets or sets the color components.

Syntax

Visual Basic (Declaration)
Public Property ColorComponents As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColor
Dim value() As Double

instance.ColorComponents = value

value = instance.ColorComponents
C#
public double[] ColorComponents {get; set;}
Managed Extensions for C++
public: __property double[]* get_ColorComponents();
public: __property void set_ColorComponents(
   double[]* value
);
C++/CLI
public:
property array<double>^ ColorComponents {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of values that describe the color in the ICC colorspace.

Remarks

The length of this array must match the value of PDFICCColorSpace.ColorComponents property on the underlying ICC colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColor Class
PDFICCColor Members


PDFInchLogicalUnit Class

PDFInchLogicalUnit Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFInchLogicalUnit Class

Defines the inch as a logical unit.

Syntax

Visual Basic (Declaration)
Public Class PDFInchLogicalUnit
   Inherits PDFLogicalUnitBase
Visual Basic (Usage) Copy Code
Dim instance As PDFInchLogicalUnit
C#
public class PDFInchLogicalUnit : PDFLogicalUnitBase
Managed Extensions for C++
public __gc class PDFInchLogicalUnit : public PDFLogicalUnitBase
C++/CLI
public ref class PDFInchLogicalUnit : public PDFLogicalUnitBase

Remarks

This class defines the inch as a logical unit. The mapping between logical unit and pdf unit is 72-to-1, one logical unit equals to 72 pdf units. The mapping functions return the value given as parameter multiplied by 72.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFLogicalUnitBase
O2S.Components.PDF4NET.Graphics.PDFInchLogicalUnit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFInchLogicalUnit Members
O2S.Components.PDF4NET.Graphics Namespace


PDFInchLogicalUnit Class Members

PDFInchLogicalUnit Class Members
See Also Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFInchLogicalUnit Class

The following tables list the members exposed by PDFInchLogicalUnit.

Public Constructors

 | Name | Description
Public Constructor | PDFInchLogicalUnit Constructor | Initializes a new PDFInchLogicalUnit object.
Top

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Overridden. Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Overridden. Defines the mapping between the logical unit and the pdf unit for the Y axis
Top

See Also

Reference

PDFInchLogicalUnit Class
O2S.Components.PDF4NET.Graphics Namespace


PDFInchLogicalUnit Constructor

PDFInchLogicalUnit Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFInchLogicalUnit Class : PDFInchLogicalUnit Constructor

Initializes a new PDFInchLogicalUnit object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFInchLogicalUnit()
C#
public PDFInchLogicalUnit()
Managed Extensions for C++
public: PDFInchLogicalUnit();
C++/CLI
public:
PDFInchLogicalUnit();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFInchLogicalUnit Class
PDFInchLogicalUnit Members


PDFInchLogicalUnit Class Methods

PDFInchLogicalUnit Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFInchLogicalUnit Class

For a list of all members of this type, see PDFInchLogicalUnit members.

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Overridden. Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Overridden. Defines the mapping between the logical unit and the pdf unit for the Y axis
Top

See Also

Reference

PDFInchLogicalUnit Class
O2S.Components.PDF4NET.Graphics Namespace


ToPDFUnitX Method

ToPDFUnitX Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFInchLogicalUnit Class : ToPDFUnitX Method

unit
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the X axis

Syntax

Visual Basic (Declaration)
Overrides Public Function ToPDFUnitX( _
   ByVal unit As Double _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFInchLogicalUnit
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitX(unit)
C#
public override double ToPDFUnitX(
   double unit
)
Managed Extensions for C++
public: double ToPDFUnitX(
   double unit
) override
C++/CLI
public:
double ToPDFUnitX(
   double unit
) override

Parameters

unit
the number of logical units to be converted to pdf units.

Remarks

This method is used to convert the X coordinates, which are always expressed in logical units, of a graphic object to pdf units on X axis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFInchLogicalUnit Class
PDFInchLogicalUnit Members


ToPDFUnitY Method

ToPDFUnitY Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFInchLogicalUnit Class : ToPDFUnitY Method

unit
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the Y axis

Syntax

Visual Basic (Declaration)
Overrides Public Function ToPDFUnitY( _
   ByVal unit As Double _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFInchLogicalUnit
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitY(unit)
C#
public override double ToPDFUnitY(
   double unit
)
Managed Extensions for C++
public: double ToPDFUnitY(
   double unit
) override
C++/CLI
public:
double ToPDFUnitY(
   double unit
) override

Parameters

unit
the number of logical units to be converted to pdf units.

Remarks

This method is used to convert the Y coordinates, which are always expressed in logical units, of a graphic object to pdf units on Y axis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFInchLogicalUnit Class
PDFInchLogicalUnit Members


PDFIndexedColor Class

PDFIndexedColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFIndexedColor Class

Defines an indexed color, based on an indexed colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFIndexedColor
   Inherits PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColor
C#
public class PDFIndexedColor : PDFColor
Managed Extensions for C++
public __gc class PDFIndexedColor : public PDFColor
C++/CLI
public ref class PDFIndexedColor : public PDFColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFIndexedColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColor Members
O2S.Components.PDF4NET.Graphics Namespace


PDFIndexedColor Class Members

PDFIndexedColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFIndexedColor Class

The following tables list the members exposed by PDFIndexedColor.

Public Constructors

 | Name | Description
Public Constructor | PDFIndexedColor Constructor | Initializes a new PDFIndexedColor object.
Top

Public Properties

 | Name | Description
Public Property | ColorIndex | Gets or sets the color index.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFIndexedColor Class
O2S.Components.PDF4NET.Graphics Namespace


PDFIndexedColor Constructor

PDFIndexedColor Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFIndexedColor Class : PDFIndexedColor Constructor

colorSpace
a PDFIndexedColorSpace object the color is based on.
Initializes a new PDFIndexedColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorSpace As PDFIndexedColorSpace _
)
Visual Basic (Usage) Copy Code
Dim colorSpace As PDFIndexedColorSpace

Dim instance As PDFIndexedColor(colorSpace)
C#
public PDFIndexedColor(
   PDFIndexedColorSpace colorSpace
)
Managed Extensions for C++
public: PDFIndexedColor(
   PDFIndexedColorSpace* colorSpace
)
C++/CLI
public:
PDFIndexedColor(
   PDFIndexedColorSpace^ colorSpace
)

Parameters

colorSpace
a PDFIndexedColorSpace object the color is based on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColor Class
PDFIndexedColor Members


PDFIndexedColor Class Methods

PDFIndexedColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFIndexedColor Class

For a list of all members of this type, see PDFIndexedColor members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFIndexedColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method

Clone Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFIndexedColor Class : Clone Method

Clones this color object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColor
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

A copy of this color object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColor Class
PDFIndexedColor Members


Equals Method

Equals Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFIndexedColor Class : Equals Method

obj
Object to verify.
Verifies if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColor Class
PDFIndexedColor Members


GetHashCode Method

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFIndexedColor Class : GetHashCode Method

Gets the hash code of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColor
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hashcode of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColor Class
PDFIndexedColor Members


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFIndexedColor Class : ToString Method

Converts the color object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The color representation in PDF format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColor Class
PDFIndexedColor Members


PDFIndexedColor Class Properties

PDFIndexedColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFIndexedColor Class

For a list of all members of this type, see PDFIndexedColor members.

Public Properties

 | Name | Description
Public Property | ColorIndex | Gets or sets the color index.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Top

See Also

Reference

PDFIndexedColor Class
O2S.Components.PDF4NET.Graphics Namespace


ColorIndex Property

ColorIndex Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFIndexedColor Class : ColorIndex Property

Gets or sets the color index.

Syntax

Visual Basic (Declaration)
Public Property ColorIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColor
Dim value As Integer

instance.ColorIndex = value

value = instance.ColorIndex
C#
public int ColorIndex {get; set;}
Managed Extensions for C++
public: __property int get_ColorIndex();
public: __property void set_ColorIndex(
   int value
);
C++/CLI
public:
property int ColorIndex {
   int get();
   void set (int value);
}

Return Value

The index of this color.

Remarks

The acceptable range for this value is 0 - PDFIndexedColorSpace.MaxIndex.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColor Class
PDFIndexedColor Members


PDFLabColor Class

PDFLabColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLabColor Class

Defines a calibrated Lab color, based on a Lab colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFLabColor
   Inherits PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColor
C#
public class PDFLabColor : PDFColor
Managed Extensions for C++
public __gc class PDFLabColor : public PDFColor
C++/CLI
public ref class PDFLabColor : public PDFColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFLabColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColor Members
O2S.Components.PDF4NET.Graphics Namespace


PDFLabColor Class Members

PDFLabColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLabColor Class

The following tables list the members exposed by PDFLabColor.

Public Constructors

 | Name | Description
Public Constructor | PDFLabColor Constructor | Initializes a new PDFLabColor object.
Top

Public Properties

 | Name | Description
Public Property | A | Gets or sets the a* component for this color.
Public Property | B | Gets or sets the b* component for this color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | L | Gets or sets the l component for this color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFLabColor Class
O2S.Components.PDF4NET.Graphics Namespace


PDFLabColor Constructor

PDFLabColor Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLabColor Class : PDFLabColor Constructor

colorSpace
a PDFLabColorSpace object the color is based on.
Initializes a new PDFLabColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorSpace As PDFLabColorSpace _
)
Visual Basic (Usage) Copy Code
Dim colorSpace As PDFLabColorSpace

Dim instance As PDFLabColor(colorSpace)
C#
public PDFLabColor(
   PDFLabColorSpace colorSpace
)
Managed Extensions for C++
public: PDFLabColor(
   PDFLabColorSpace* colorSpace
)
C++/CLI
public:
PDFLabColor(
   PDFLabColorSpace^ colorSpace
)

Parameters

colorSpace
a PDFLabColorSpace object the color is based on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColor Class
PDFLabColor Members


PDFLabColor Class Methods

PDFLabColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLabColor Class

For a list of all members of this type, see PDFLabColor members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFLabColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method

Clone Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLabColor Class : Clone Method

Clones this color object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColor
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

A copy of this color object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColor Class
PDFLabColor Members


Equals Method

Equals Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLabColor Class : Equals Method

obj
Object to verify.
Verifies if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColor Class
PDFLabColor Members


GetHashCode Method

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLabColor Class : GetHashCode Method

Gets the hash code of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColor
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hashcode of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColor Class
PDFLabColor Members


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLabColor Class : ToString Method

Converts the color object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The color representation in PDF format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColor Class
PDFLabColor Members


PDFLabColor Class Properties

PDFLabColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLabColor Class

For a list of all members of this type, see PDFLabColor members.

Public Properties

 | Name | Description
Public Property | A | Gets or sets the a* component for this color.
Public Property | B | Gets or sets the b* component for this color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | L | Gets or sets the l component for this color.
Top

See Also

Reference

PDFLabColor Class
O2S.Components.PDF4NET.Graphics Namespace


A Property

A Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLabColor Class : A Property

Gets or sets the a* component for this color.

Syntax

Visual Basic (Declaration)
Public Property A As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColor
Dim value As Double

instance.A = value

value = instance.A
C#
public double A {get; set;}
Managed Extensions for C++
public: __property double get_A();
public: __property void set_A(
   double value
);
C++/CLI
public:
property double A {
   double get();
   void set (double value);
}

Return Value

The a* component of this color.

Remarks

The range for this value is defined by the PDFLabColorSpace.Range property of the underlying Lab colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColor Class
PDFLabColor Members


B Property

B Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLabColor Class : B Property

Gets or sets the b* component for this color.

Syntax

Visual Basic (Declaration)
Public Property B As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColor
Dim value As Double

instance.B = value

value = instance.B
C#
public double B {get; set;}
Managed Extensions for C++
public: __property double get_B();
public: __property void set_B(
   double value
);
C++/CLI
public:
property double B {
   double get();
   void set (double value);
}

Return Value

The b* component of this color.

Remarks

The range for this value is defined by the PDFLabColorSpace.Range property of the underlying Lab colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColor Class
PDFLabColor Members


L Property

L Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLabColor Class : L Property

Gets or sets the l component for this color.

Syntax

Visual Basic (Declaration)
Public Property L As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColor
Dim value As Double

instance.L = value

value = instance.L
C#
public double L {get; set;}
Managed Extensions for C++
public: __property double get_L();
public: __property void set_L(
   double value
);
C++/CLI
public:
property double L {
   double get();
   void set (double value);
}

Return Value

The l component of this color.

Remarks

The acceptable range for this value is [0.0 100.0].
0.0 means the darkest color that can be achieved, and 100.0 means the lightest color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColor Class
PDFLabColor Members


PDFLayer Class

PDFLayer Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLayer Class

Defines a layer on a page's canvas.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFLayer
Visual Basic (Usage) Copy Code
Dim instance As PDFLayer
C#
public class PDFLayer
Managed Extensions for C++
public __gc class PDFLayer
C++/CLI
public ref class PDFLayer

Remarks

A layer allows to define sections of a content of a PDF document that can be selectively viewed or hidden by PDF consumers (PDF viewer aplications for example).
Regular page content, created through page's canvas, is not included in any layer and it is always visible.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFLayer

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayer Members
O2S.Components.PDF4NET.Graphics Namespace


PDFLayer Class Members

PDFLayer Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLayer Class

The following tables list the members exposed by PDFLayer.

Public Properties

 | Name | Description
Public Property | Canvas | Gets the canvas of the layer.
Public Property | Name | Gets or sets the name of this layer.
Public Property | Visible | Gets or sets whether this layer is visible when the document is opened.
Top

See Also

Reference

PDFLayer Class
O2S.Components.PDF4NET.Graphics Namespace


PDFLayer Class Properties

PDFLayer Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLayer Class

For a list of all members of this type, see PDFLayer members.

Public Properties

 | Name | Description
Public Property | Canvas | Gets the canvas of the layer.
Public Property | Name | Gets or sets the name of this layer.
Public Property | Visible | Gets or sets whether this layer is visible when the document is opened.
Top

See Also

Reference

PDFLayer Class
O2S.Components.PDF4NET.Graphics Namespace


Canvas Property

Canvas Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayer Class : Canvas Property

Gets the canvas of the layer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Canvas As PDFCanvas
Visual Basic (Usage) Copy Code
Dim instance As PDFLayer
Dim value As PDFCanvas

value = instance.Canvas
C#
public PDFCanvas Canvas {get;}
Managed Extensions for C++
public: __property PDFCanvas* get_Canvas();
C++/CLI
public:
property PDFCanvas^ Canvas {
   PDFCanvas^ get();
}

Return Value

A PDFCanvas object specifying the drawing surface of the layer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayer Class
PDFLayer Members


Name Property

Name Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayer Class : Name Property

Gets or sets the name of this layer.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PDFLayer
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the name of this layer.

Remarks

This name is displayed in the user interface of the viewer application, allowing the user to show/hide the layer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayer Class
PDFLayer Members


Visible Property

Visible Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayer Class : Visible Property

Gets or sets whether this layer is visible when the document is opened.

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFLayer
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}
Managed Extensions for C++
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
C++/CLI
public:
property bool Visible {
   bool get();
   void set (bool value);
}

Return Value

True if this layer is visible when the document is opened, otherwise false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayer Class
PDFLayer Members


PDFLayerCollection Class

PDFLayerCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLayerCollection Class

Defines a collection of PDF layers.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFLayerCollection
   Inherits PDFCollection(Of PDFLayer, PDFPage)
Visual Basic (Usage) Copy Code
Dim instance As PDFLayerCollection
C#
public class PDFLayerCollection : PDFCollection<PDFLayer, PDFPage>
Managed Extensions for C++
public __gc class PDFLayerCollection : public PDFCollection<PDFLayer, PDFPage>
C++/CLI
public ref class PDFLayerCollection : public PDFCollection<PDFLayer, PDFPage>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<PDFLayer>
O2S.Components.PDF4NET.PDFCollection<PDFLayer, PDFPage>
O2S.Components.PDF4NET.Graphics.PDFLayerCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayerCollection Members
O2S.Components.PDF4NET.Graphics Namespace


PDFLayerCollection Class Members

PDFLayerCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLayerCollection Class

The following tables list the members exposed by PDFLayerCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Creates a new layer with the given name and adds it at the end of the collection.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | Insert | Overloaded. Creates a new layer with the given name and inserts it at the specified index.
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Top

See Also

Reference

PDFLayerCollection Class
O2S.Components.PDF4NET.Graphics Namespace


PDFLayerCollection Class Methods

PDFLayerCollection Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLayerCollection Class

For a list of all members of this type, see PDFLayerCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Creates a new layer with the given name and adds it at the end of the collection.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | Insert | Overloaded. Creates a new layer with the given name and inserts it at the specified index.
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Top

See Also

Reference

PDFLayerCollection Class
O2S.Components.PDF4NET.Graphics Namespace


Add Method

Add Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayerCollection Class : Add Method

Creates a new layer with the given name and adds it at the end of the collection.

Overload List

Overload | Description
Add(String) | Creates a new layer with the given name and adds it at the end of the collection.
Add(PDFLayer) | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayerCollection Class
PDFLayerCollection Members


Add(String) Method

Add(String) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayerCollection Class > Add Method : Add(String) Method

name
the name of the new layer.
Creates a new layer with the given name and adds it at the end of the collection.

Syntax

Visual Basic (Declaration)
Overloads Public Function Add( _
   ByVal name As String _
) As PDFLayer
Visual Basic (Usage) Copy Code
Dim instance As PDFLayerCollection
Dim name As String
Dim value As PDFLayer

value = instance.Add(name)
C#
public PDFLayer Add(
   string name
)
Managed Extensions for C++
public: PDFLayer* Add(
   string* name
)
C++/CLI
public:
PDFLayer^ Add(
   String^ name
)

Parameters

name
the name of the new layer.

Return Value

a PDFLayer object representing the new layer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayerCollection Class
PDFLayerCollection Members
Overload List


Insert Method

Insert Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayerCollection Class : Insert Method

Creates a new layer with the given name and inserts it at the specified index.

Overload List

Overload | Description
Insert(Int32,String) | Creates a new layer with the given name and inserts it at the specified index.
Insert(Int32,PDFLayer) | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayerCollection Class
PDFLayerCollection Members


Insert(Int32,String) Method

Insert(Int32,String) Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLayerCollection Class > Insert Method : Insert(Int32,String) Method

index
The zero-based index at which the new layer should be inserted.
name
The name of the new layer.
Creates a new layer with the given name and inserts it at the specified index.

Syntax

Visual Basic (Declaration)
Overloads Public Function Insert( _
   ByVal index As Integer, _
   ByVal name As String _
) As PDFLayer
Visual Basic (Usage) Copy Code
Dim instance As PDFLayerCollection
Dim index As Integer
Dim name As String
Dim value As PDFLayer

value = instance.Insert(index, name)
C#
public PDFLayer Insert(
   int index,
   string name
)
Managed Extensions for C++
public: PDFLayer* Insert(
   int index,
   string* name
)
C++/CLI
public:
PDFLayer^ Insert(
   int index,
   String^ name
)

Parameters

index
The zero-based index at which the new layer should be inserted.
name
The name of the new layer.

Return Value

a PDFLayer object representing the new layer.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less then zero or index is equal to or greater than Count

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLayerCollection Class
PDFLayerCollection Members
Overload List


PDFLinearGradientBrush Class

PDFLinearGradientBrush Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLinearGradientBrush Class

Defines a hatch brush for filling closed shapes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFLinearGradientBrush
   Inherits PDFBrush
Visual Basic (Usage) Copy Code
Dim instance As PDFLinearGradientBrush
C#
public class PDFLinearGradientBrush : PDFBrush
Managed Extensions for C++
public __gc class PDFLinearGradientBrush : public PDFBrush
C++/CLI
public ref class PDFLinearGradientBrush : public PDFBrush

Remarks

The type of the hatch brush is defined by the PDFHatchType enumeration.
A hatch brush uses a hatch cell as its basic drawing unit. The hatch cells are drawn repeatedly from left to right, and top to bottom till the closed shaped is filled.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush
O2S.Components.PDF4NET.Graphics.PDFVerticalGradientBrush
O2S.Components.PDF4NET.Graphics.PDFHorizontalGradientBrush

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinearGradientBrush Members
O2S.Components.PDF4NET.Graphics Namespace


PDFLinearGradientBrush Class Members

PDFLinearGradientBrush Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLinearGradientBrush Class

The following tables list the members exposed by PDFLinearGradientBrush.

Public Constructors

 | Name | Description
Public Constructor | PDFLinearGradientBrush Constructor | Initializes a new PDFHatchBrush object.
Top

Public Properties

 | Name | Description
Public Property | Color | Overridden. Gets or sets the color of this Brush object.
Public Property | EndColor |
Public Property | StartColor | Gets or sets the start color of the gradient.
Top

See Also

Reference

PDFLinearGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


PDFLinearGradientBrush Constructor

PDFLinearGradientBrush Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLinearGradientBrush Class : PDFLinearGradientBrush Constructor

Initializes a new PDFHatchBrush object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFLinearGradientBrush()
C#
public PDFLinearGradientBrush()
Managed Extensions for C++
public: PDFLinearGradientBrush();
C++/CLI
public:
PDFLinearGradientBrush();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinearGradientBrush Class
PDFLinearGradientBrush Members


PDFLinearGradientBrush Class Properties

PDFLinearGradientBrush Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLinearGradientBrush Class

For a list of all members of this type, see PDFLinearGradientBrush members.

Public Properties

 | Name | Description
Public Property | Color | Overridden. Gets or sets the color of this Brush object.
Public Property | EndColor |
Public Property | StartColor | Gets or sets the start color of the gradient.
Top

See Also

Reference

PDFLinearGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


Color Property

Color Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLinearGradientBrush Class : Color Property

Gets or sets the color of this Brush object.

Syntax

Visual Basic (Declaration)
Overrides Public Property Color As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFLinearGradientBrush
Dim value As PDFColor

instance.Color = value

value = instance.Color
C#
public override PDFColor Color {get; set;}
Managed Extensions for C++
public: __property PDFColor* get_Color()override ;
public: __property void set_Color(
   PDFColor* value
)override ;
C++/CLI
public:
property PDFColor^ Color override {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

The color of this brush.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinearGradientBrush Class
PDFLinearGradientBrush Members


EndColor Property

EndColor Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLinearGradientBrush Class : EndColor Property

Syntax

Visual Basic (Declaration)
Public Property EndColor As PDFRgbColor
Visual Basic (Usage) Copy Code
Dim instance As PDFLinearGradientBrush
Dim value As PDFRgbColor

instance.EndColor = value

value = instance.EndColor
C#
public PDFRgbColor EndColor {get; set;}
Managed Extensions for C++
public: __property PDFRgbColor* get_EndColor();
public: __property void set_EndColor(
   PDFRgbColor* value
);
C++/CLI
public:
property PDFRgbColor^ EndColor {
   PDFRgbColor^ get();
   void set (PDFRgbColor^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinearGradientBrush Class
PDFLinearGradientBrush Members


StartColor Property

StartColor Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLinearGradientBrush Class : StartColor Property

Gets or sets the start color of the gradient.

Syntax

Visual Basic (Declaration)
Public Property StartColor As PDFRgbColor
Visual Basic (Usage) Copy Code
Dim instance As PDFLinearGradientBrush
Dim value As PDFRgbColor

instance.StartColor = value

value = instance.StartColor
C#
public PDFRgbColor StartColor {get; set;}
Managed Extensions for C++
public: __property PDFRgbColor* get_StartColor();
public: __property void set_StartColor(
   PDFRgbColor* value
);
C++/CLI
public:
property PDFRgbColor^ StartColor {
   PDFRgbColor^ get();
   void set (PDFRgbColor^ value);
}

Return Value

A RGB color specifying the start color of the gradient.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinearGradientBrush Class
PDFLinearGradientBrush Members


PDFLinearGradientPattern Class

PDFLinearGradientPattern Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLinearGradientPattern Class

Defines a pattern that represents a linear gradient.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFLinearGradientPattern
   Inherits PDFAxialShadingPattern
Visual Basic (Usage) Copy Code
Dim instance As PDFLinearGradientPattern
C#
public class PDFLinearGradientPattern : PDFAxialShadingPattern
Managed Extensions for C++
public __gc class PDFLinearGradientPattern : public PDFAxialShadingPattern
C++/CLI
public ref class PDFLinearGradientPattern : public PDFAxialShadingPattern

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.PDFPattern
O2S.Components.PDF4NET.Graphics.PDFShadingPattern
O2S.Components.PDF4NET.Graphics.PDFAxialShadingPattern
O2S.Components.PDF4NET.Graphics.PDFLinearGradientPattern

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinearGradientPattern Members
O2S.Components.PDF4NET.Graphics Namespace


PDFLinearGradientPattern Class Members

PDFLinearGradientPattern Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLinearGradientPattern Class

The following tables list the members exposed by PDFLinearGradientPattern.

Public Constructors

 | Name | Description
Public Constructor | PDFLinearGradientPattern Constructor | Initializes a new PDFLinearGradientPattern object.
Top

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets or sets the shading's colorspace. (Inherited from PDFAxialShadingPattern)
Public Property | Coordinates | Gets or sets the shading coordinates. (Inherited from PDFAxialShadingPattern)
Public Property | EndColor | Gets or sets the color at the end of the gradient.
Public Property | Function | Gets or sets the function that defines the axial shading. (Inherited from PDFAxialShadingPattern)
Public Property | StartColor | Gets or sets the color at the start of the gradient.
Top

See Also

Reference

PDFLinearGradientPattern Class
O2S.Components.PDF4NET.Graphics Namespace


PDFLinearGradientPattern Constructor

PDFLinearGradientPattern Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLinearGradientPattern Class : PDFLinearGradientPattern Constructor

Initializes a new PDFLinearGradientPattern object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFLinearGradientPattern()
C#
public PDFLinearGradientPattern()
Managed Extensions for C++
public: PDFLinearGradientPattern();
C++/CLI
public:
PDFLinearGradientPattern();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinearGradientPattern Class
PDFLinearGradientPattern Members


PDFLinearGradientPattern Class Properties

PDFLinearGradientPattern Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLinearGradientPattern Class

For a list of all members of this type, see PDFLinearGradientPattern members.

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets or sets the shading's colorspace. (Inherited from PDFAxialShadingPattern)
Public Property | Coordinates | Gets or sets the shading coordinates. (Inherited from PDFAxialShadingPattern)
Public Property | EndColor | Gets or sets the color at the end of the gradient.
Public Property | Function | Gets or sets the function that defines the axial shading. (Inherited from PDFAxialShadingPattern)
Public Property | StartColor | Gets or sets the color at the start of the gradient.
Top

See Also

Reference

PDFLinearGradientPattern Class
O2S.Components.PDF4NET.Graphics Namespace


EndColor Property

EndColor Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLinearGradientPattern Class : EndColor Property

Gets or sets the color at the end of the gradient.

Syntax

Visual Basic (Declaration)
Public Property EndColor As PDFRgbColor
Visual Basic (Usage) Copy Code
Dim instance As PDFLinearGradientPattern
Dim value As PDFRgbColor

instance.EndColor = value

value = instance.EndColor
C#
public PDFRgbColor EndColor {get; set;}
Managed Extensions for C++
public: __property PDFRgbColor* get_EndColor();
public: __property void set_EndColor(
   PDFRgbColor* value
);
C++/CLI
public:
property PDFRgbColor^ EndColor {
   PDFRgbColor^ get();
   void set (PDFRgbColor^ value);
}

Return Value

End color of the gradient.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinearGradientPattern Class
PDFLinearGradientPattern Members


StartColor Property

StartColor Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLinearGradientPattern Class : StartColor Property

Gets or sets the color at the start of the gradient.

Syntax

Visual Basic (Declaration)
Public Property StartColor As PDFRgbColor
Visual Basic (Usage) Copy Code
Dim instance As PDFLinearGradientPattern
Dim value As PDFRgbColor

instance.StartColor = value

value = instance.StartColor
C#
public PDFRgbColor StartColor {get; set;}
Managed Extensions for C++
public: __property PDFRgbColor* get_StartColor();
public: __property void set_StartColor(
   PDFRgbColor* value
);
C++/CLI
public:
property PDFRgbColor^ StartColor {
   PDFRgbColor^ get();
   void set (PDFRgbColor^ value);
}

Return Value

Start color of the gradient.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLinearGradientPattern Class
PDFLinearGradientPattern Members


PDFLogicalUnitBase Class

PDFLogicalUnitBase Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLogicalUnitBase Class

Base class for all the classes that implement custom logical units.

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFLogicalUnitBase
Visual Basic (Usage) Copy Code
Dim instance As PDFLogicalUnitBase
C#
public abstract class PDFLogicalUnitBase
Managed Extensions for C++
public __gc abstract class PDFLogicalUnitBase
C++/CLI
public ref class PDFLogicalUnitBase abstract

Remarks

This class is the base class for implementing user defined logical units. All classes that represent a custom defined logical unit must implement two methods: ToPDFUnitX( float unit ) and ToPDFUnitY( float unit ). These 2 methods need to define the mapping between the logical unit and measure unit used by pdf files, which is the point (1/72 inches). These 2 methods allow to define custom mappings between logical unit and pdf unit (point) for each axis. The mapping between the logical unit and the pdf unit shows how many pdf units correspond to a logical unit.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFLogicalUnitBase
O2S.Components.PDF4NET.Graphics.PDFPointLogicalUnit
O2S.Components.PDF4NET.Graphics.PDFMMLogicalUnit
O2S.Components.PDF4NET.Graphics.PDFInchLogicalUnit
O2S.Components.PDF4NET.Graphics.PDFCMLogicalUnit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLogicalUnitBase Members
O2S.Components.PDF4NET.Graphics Namespace


PDFLogicalUnitBase Class Members

PDFLogicalUnitBase Class Members
See Also Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLogicalUnitBase Class

The following tables list the members exposed by PDFLogicalUnitBase.

Public Constructors

 | Name | Description
Public Constructor | PDFLogicalUnitBase Constructor | Initializes a new PDFLogicalUnitBase object.
Top

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Defines the mapping between the logical unit and the pdf unit for the Y axis
Top

See Also

Reference

PDFLogicalUnitBase Class
O2S.Components.PDF4NET.Graphics Namespace


PDFLogicalUnitBase Constructor

PDFLogicalUnitBase Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLogicalUnitBase Class : PDFLogicalUnitBase Constructor

Initializes a new PDFLogicalUnitBase object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFLogicalUnitBase()
C#
public PDFLogicalUnitBase()
Managed Extensions for C++
public: PDFLogicalUnitBase();
C++/CLI
public:
PDFLogicalUnitBase();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLogicalUnitBase Class
PDFLogicalUnitBase Members


PDFLogicalUnitBase Class Methods

PDFLogicalUnitBase Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLogicalUnitBase Class

For a list of all members of this type, see PDFLogicalUnitBase members.

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Defines the mapping between the logical unit and the pdf unit for the Y axis
Top

See Also

Reference

PDFLogicalUnitBase Class
O2S.Components.PDF4NET.Graphics Namespace


ToPDFUnitX Method

ToPDFUnitX Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLogicalUnitBase Class : ToPDFUnitX Method

unit
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the X axis

Syntax

Visual Basic (Declaration)
Public Overridable Function ToPDFUnitX( _
   ByVal unit As Double _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFLogicalUnitBase
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitX(unit)
C#
public virtual double ToPDFUnitX(
   double unit
)
Managed Extensions for C++
public: virtual double ToPDFUnitX(
   double unit
)
C++/CLI
public:
virtual double ToPDFUnitX(
   double unit
)

Parameters

unit
the number of logical units to be converted to pdf units.

Remarks

This method is used to convert the X coordinates, which are always expressed in logical units, of a graphic object to pdf units on X axis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLogicalUnitBase Class
PDFLogicalUnitBase Members


ToPDFUnitY Method

ToPDFUnitY Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFLogicalUnitBase Class : ToPDFUnitY Method

unit
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the Y axis

Syntax

Visual Basic (Declaration)
Public Overridable Function ToPDFUnitY( _
   ByVal unit As Double _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFLogicalUnitBase
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitY(unit)
C#
public virtual double ToPDFUnitY(
   double unit
)
Managed Extensions for C++
public: virtual double ToPDFUnitY(
   double unit
)
C++/CLI
public:
virtual double ToPDFUnitY(
   double unit
)

Parameters

unit
the number of logical units to be converted to pdf units.

Remarks

This method is used to convert the Y coordinates, which are always expressed in logical units, of a graphic object to pdf units on Y axis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLogicalUnitBase Class
PDFLogicalUnitBase Members


PDFMMLogicalUnit Class

PDFMMLogicalUnit Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFMMLogicalUnit Class

Defines the millimeter as a logical unit.

Syntax

Visual Basic (Declaration)
Public Class PDFMMLogicalUnit
   Inherits PDFLogicalUnitBase
Visual Basic (Usage) Copy Code
Dim instance As PDFMMLogicalUnit
C#
public class PDFMMLogicalUnit : PDFLogicalUnitBase
Managed Extensions for C++
public __gc class PDFMMLogicalUnit : public PDFLogicalUnitBase
C++/CLI
public ref class PDFMMLogicalUnit : public PDFLogicalUnitBase

Remarks

This class defines the millimeter as a logical unit. The mapping between logical unit and pdf unit is 2.834646-to-1, one logical unit equals to 2.834646 pdf units. The mapping functions return the value given as parameter multiplied by 2.834646.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFLogicalUnitBase
O2S.Components.PDF4NET.Graphics.PDFMMLogicalUnit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMMLogicalUnit Members
O2S.Components.PDF4NET.Graphics Namespace


PDFMMLogicalUnit Class Members

PDFMMLogicalUnit Class Members
See Also Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFMMLogicalUnit Class

The following tables list the members exposed by PDFMMLogicalUnit.

Public Constructors

 | Name | Description
Public Constructor | PDFMMLogicalUnit Constructor | Initializes a new PDFMMLogicalUnit object.
Top

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Overridden. Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Overridden. Defines the mapping between the logical unit and the pdf unit for the Y axis
Top

See Also

Reference

PDFMMLogicalUnit Class
O2S.Components.PDF4NET.Graphics Namespace


PDFMMLogicalUnit Constructor

PDFMMLogicalUnit Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFMMLogicalUnit Class : PDFMMLogicalUnit Constructor

Initializes a new PDFMMLogicalUnit object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFMMLogicalUnit()
C#
public PDFMMLogicalUnit()
Managed Extensions for C++
public: PDFMMLogicalUnit();
C++/CLI
public:
PDFMMLogicalUnit();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMMLogicalUnit Class
PDFMMLogicalUnit Members


PDFMMLogicalUnit Class Methods

PDFMMLogicalUnit Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFMMLogicalUnit Class

For a list of all members of this type, see PDFMMLogicalUnit members.

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Overridden. Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Overridden. Defines the mapping between the logical unit and the pdf unit for the Y axis
Top

See Also

Reference

PDFMMLogicalUnit Class
O2S.Components.PDF4NET.Graphics Namespace


ToPDFUnitX Method

ToPDFUnitX Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFMMLogicalUnit Class : ToPDFUnitX Method

unit
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the X axis

Syntax

Visual Basic (Declaration)
Overrides Public Function ToPDFUnitX( _
   ByVal unit As Double _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFMMLogicalUnit
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitX(unit)
C#
public override double ToPDFUnitX(
   double unit
)
Managed Extensions for C++
public: double ToPDFUnitX(
   double unit
) override
C++/CLI
public:
double ToPDFUnitX(
   double unit
) override

Parameters

unit
the number of logical units to be converted to pdf units.

Remarks

This method is used to convert the X coordinates, which are always expressed in logical units, of a graphic object to pdf units on X axis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMMLogicalUnit Class
PDFMMLogicalUnit Members


ToPDFUnitY Method

ToPDFUnitY Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFMMLogicalUnit Class : ToPDFUnitY Method

unit
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the Y axis

Syntax

Visual Basic (Declaration)
Overrides Public Function ToPDFUnitY( _
   ByVal unit As Double _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFMMLogicalUnit
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitY(unit)
C#
public override double ToPDFUnitY(
   double unit
)
Managed Extensions for C++
public: double ToPDFUnitY(
   double unit
) override
C++/CLI
public:
double ToPDFUnitY(
   double unit
) override

Parameters

unit
the number of logical units to be converted to pdf units.

Remarks

This method is used to convert the Y coordinates, which are always expressed in logical units, of a graphic object to pdf units on Y axis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMMLogicalUnit Class
PDFMMLogicalUnit Members


PDFPattern Class

PDFPattern Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFPattern Class

Defines the base class for all PDF patterns.

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFPattern
   Inherits PDFGraphicsContainer
Visual Basic (Usage) Copy Code
Dim instance As PDFPattern
C#
public abstract class PDFPattern : PDFGraphicsContainer
Managed Extensions for C++
public __gc abstract class PDFPattern : public PDFGraphicsContainer
C++/CLI
public ref class PDFPattern abstract : public PDFGraphicsContainer

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.PDFPattern
O2S.Components.PDF4NET.Graphics.PDFTilingPattern
O2S.Components.PDF4NET.Graphics.PDFShadingPattern

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPattern Members
O2S.Components.PDF4NET.Graphics Namespace


PDFPattern Class Members

PDFPattern Class Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFPattern Class

The following tables list the members exposed by PDFPattern.

Public Constructors

 | Name | Description
Public Constructor | PDFPattern Constructor | Initializes a new PDFPattern object.
Top

See Also

Reference

PDFPattern Class
O2S.Components.PDF4NET.Graphics Namespace


PDFPattern Constructor

PDFPattern Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPattern Class : PDFPattern Constructor

Initializes a new PDFPattern object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPattern()
C#
public PDFPattern()
Managed Extensions for C++
public: PDFPattern();
C++/CLI
public:
PDFPattern();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPattern Class
PDFPattern Members


PDFPen Class

PDFPen Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFPen Class

Defines an object used to draw lines and curves. This class cannot be inherited.

Supported by Compact .NET Edition.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PDFPen
Visual Basic (Usage) Copy Code
Dim instance As PDFPen
C#
public sealed class PDFPen
Managed Extensions for C++
public __gc __sealed class PDFPen
C++/CLI
public ref class PDFPen sealed

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFPen

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Members
O2S.Components.PDF4NET.Graphics Namespace


PDFPen Class Members

PDFPen Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFPen Class

The following tables list the members exposed by PDFPen.

Public Constructors

 | Name | Description
Public Constructor | PDFPen Constructor | Overloaded. Initializes a new PDFPen object of the specified color and width.
Top

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this PDFPen object.
Public Property | DashOffset | Gets or sets the distance from the start of a line to the beginning of a dash pattern.
Public Property | DashPattern | Gets or sets an array of custom dashes and spaces.
Public Property | DashStyle | Gets or sets the style used for dashed lines drawn with this Pen object.
Public Property | LineCap | Gets or sets the cap style used at the beginning and the end of lines drawn with this Pen object.
Public Property | LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this Pen object.
Public Property | Width | Gets or sets the width of this PDFPen object.
Top

See Also

Reference

PDFPen Class
O2S.Components.PDF4NET.Graphics Namespace


PDFPen Constructor

PDFPen Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : PDFPen Constructor

Initializes a new PDFPen object of the specified color and width.

Overload List

Overload | Description
PDFPen Constructor() | Initializes a new PDFPen object.
PDFPen Constructor(PDFColor) | Initializes a new PDFPen object of the specified color.
PDFPen Constructor(PDFColor,Double) | Initializes a new PDFPen object of the specified color and width.
PDFPen Constructor(PDFPen) | Initializes a new PDFPen object based on the given pen.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members


PDFPen Constructor()

PDFPen Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class > PDFPen Constructor : PDFPen Constructor()

Initializes a new PDFPen object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPen()
C#
public PDFPen()
Managed Extensions for C++
public: PDFPen();
C++/CLI
public:
PDFPen();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members
Overload List


PDFPen Constructor(PDFColor)

PDFPen Constructor(PDFColor)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class > PDFPen Constructor : PDFPen Constructor(PDFColor)

color
the color of the pen.
Initializes a new PDFPen object of the specified color.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As PDFColor _
)
Visual Basic (Usage) Copy Code
Dim color As PDFColor

Dim instance As PDFPen(color)
C#
public PDFPen(
   PDFColor color
)
Managed Extensions for C++
public: PDFPen(
   PDFColor* color
)
C++/CLI
public:
PDFPen(
   PDFColor^ color
)

Parameters

color
the color of the pen.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members
Overload List


PDFPen Constructor(PDFColor,Double)

PDFPen Constructor(PDFColor,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class > PDFPen Constructor : PDFPen Constructor(PDFColor,Double)

color
the color of the pen.
width
the width of the pen.
Initializes a new PDFPen object of the specified color and width.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As PDFColor, _
   ByVal width As Double _
)
Visual Basic (Usage) Copy Code
Dim color As PDFColor
Dim width As Double

Dim instance As PDFPen(color, width)
C#
public PDFPen(
   PDFColor color,
   double width
)
Managed Extensions for C++
public: PDFPen(
   PDFColor* color,
   double width
)
C++/CLI
public:
PDFPen(
   PDFColor^ color,
   double width
)

Parameters

color
the color of the pen.
width
the width of the pen.

Remarks

The width of the pen is always set in points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members
Overload List


PDFPen Constructor(PDFPen)

PDFPen Constructor(PDFPen)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class > PDFPen Constructor : PDFPen Constructor(PDFPen)

pen
the pen to copy.
Initializes a new PDFPen object based on the given pen.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pen As PDFPen _
)
Visual Basic (Usage) Copy Code
Dim pen As PDFPen

Dim instance As PDFPen(pen)
C#
public PDFPen(
   PDFPen pen
)
Managed Extensions for C++
public: PDFPen(
   PDFPen* pen
)
C++/CLI
public:
PDFPen(
   PDFPen^ pen
)

Parameters

pen
the pen to copy.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members
Overload List


PDFPen Class Properties

PDFPen Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFPen Class

For a list of all members of this type, see PDFPen members.

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this PDFPen object.
Public Property | DashOffset | Gets or sets the distance from the start of a line to the beginning of a dash pattern.
Public Property | DashPattern | Gets or sets an array of custom dashes and spaces.
Public Property | DashStyle | Gets or sets the style used for dashed lines drawn with this Pen object.
Public Property | LineCap | Gets or sets the cap style used at the beginning and the end of lines drawn with this Pen object.
Public Property | LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this Pen object.
Public Property | Width | Gets or sets the width of this PDFPen object.
Top

See Also

Reference

PDFPen Class
O2S.Components.PDF4NET.Graphics Namespace


Color Property

Color Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : Color Property

Gets or sets the color of this PDFPen object.

Syntax

Visual Basic (Declaration)
Public Property Color As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFPen
Dim value As PDFColor

instance.Color = value

value = instance.Color
C#
public PDFColor Color {get; set;}
Managed Extensions for C++
public: __property PDFColor* get_Color();
public: __property void set_Color(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ Color {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

The color of the pen.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members


DashOffset Property

DashOffset Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : DashOffset Property

Gets or sets the distance from the start of a line to the beginning of a dash pattern.

Syntax

Visual Basic (Declaration)
Public Property DashOffset As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFPen
Dim value As Double

instance.DashOffset = value

value = instance.DashOffset
C#
public double DashOffset {get; set;}
Managed Extensions for C++
public: __property double get_DashOffset();
public: __property void set_DashOffset(
   double value
);
C++/CLI
public:
property double DashOffset {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members


DashPattern Property

DashPattern Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : DashPattern Property

Gets or sets an array of custom dashes and spaces.

Syntax

Visual Basic (Declaration)
Public Property DashPattern As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFPen
Dim value() As Double

instance.DashPattern = value

value = instance.DashPattern
C#
public double[] DashPattern {get; set;}
Managed Extensions for C++
public: __property double[]* get_DashPattern();
public: __property void set_DashPattern(
   double[]* value
);
C++/CLI
public:
property array<double>^ DashPattern {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of float values specifying custom dashes and spaces.

Remarks

A custom dashed line is drawn using a dash pattern specified as an array of float values. The odd values represent the length of the dashes in the pattern, and the even values represent the length of the spaces in the pattern. The pattern is repeated until the whole line is drawn.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members


DashStyle Property

DashStyle Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : DashStyle Property

Gets or sets the style used for dashed lines drawn with this Pen object.

Syntax

Visual Basic (Declaration)
Public Property DashStyle As PDFDashStyle
Visual Basic (Usage) Copy Code
Dim instance As PDFPen
Dim value As PDFDashStyle

instance.DashStyle = value

value = instance.DashStyle
C#
public PDFDashStyle DashStyle {get; set;}
Managed Extensions for C++
public: __property PDFDashStyle get_DashStyle();
public: __property void set_DashStyle(
   PDFDashStyle value
);
C++/CLI
public:
property PDFDashStyle DashStyle {
   PDFDashStyle get();
   void set (PDFDashStyle value);
}

Return Value

A DashStyle enumeration member specifying how dashed lines are drawn.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members


LineCap Property

LineCap Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : LineCap Property

Gets or sets the cap style used at the beginning and the end of lines drawn with this Pen object.

Syntax

Visual Basic (Declaration)
Public Property LineCap As PDFLineCap
Visual Basic (Usage) Copy Code
Dim instance As PDFPen
Dim value As PDFLineCap

instance.LineCap = value

value = instance.LineCap
C#
public PDFLineCap LineCap {get; set;}
Managed Extensions for C++
public: __property PDFLineCap get_LineCap();
public: __property void set_LineCap(
   PDFLineCap value
);
C++/CLI
public:
property PDFLineCap LineCap {
   PDFLineCap get();
   void set (PDFLineCap value);
}

Return Value

a LineCap enumeration member specifying how the lines end.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members


LineJoin Property

LineJoin Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : LineJoin Property

Gets or sets the join style for the ends of two consecutive lines drawn with this Pen object.

Syntax

Visual Basic (Declaration)
Public Property LineJoin As PDFLineJoin
Visual Basic (Usage) Copy Code
Dim instance As PDFPen
Dim value As PDFLineJoin

instance.LineJoin = value

value = instance.LineJoin
C#
public PDFLineJoin LineJoin {get; set;}
Managed Extensions for C++
public: __property PDFLineJoin get_LineJoin();
public: __property void set_LineJoin(
   PDFLineJoin value
);
C++/CLI
public:
property PDFLineJoin LineJoin {
   PDFLineJoin get();
   void set (PDFLineJoin value);
}

Return Value

a LineJoin enumeration member specifying the join style for consecutive lines.

Remarks

This join style is used by lines, polygon and rectangle objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members


Width Property

Width Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPen Class : Width Property

Gets or sets the width of this PDFPen object.

Syntax

Visual Basic (Declaration)
Public Property Width As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFPen
Dim value As Double

instance.Width = value

value = instance.Width
C#
public double Width {get; set;}
Managed Extensions for C++
public: __property double get_Width();
public: __property void set_Width(
   double value
);
C++/CLI
public:
property double Width {
   double get();
   void set (double value);
}

Return Value

a float value specifying the width of this PDFPen object in points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPen Class
PDFPen Members


PDFPointLogicalUnit Class

PDFPointLogicalUnit Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFPointLogicalUnit Class

Defines the point (pdf unit) as a logical unit.

Syntax

Visual Basic (Declaration)
Public Class PDFPointLogicalUnit
   Inherits PDFLogicalUnitBase
Visual Basic (Usage) Copy Code
Dim instance As PDFPointLogicalUnit
C#
public class PDFPointLogicalUnit : PDFLogicalUnitBase
Managed Extensions for C++
public __gc class PDFPointLogicalUnit : public PDFLogicalUnitBase
C++/CLI
public ref class PDFPointLogicalUnit : public PDFLogicalUnitBase

Remarks

This class defines the point as a logical unit. The mapping between logical unit and pdf unit is one-to-one, one logical unit equals to one pdf unit. The mapping functions simply return the value given as parameter.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFLogicalUnitBase
O2S.Components.PDF4NET.Graphics.PDFPointLogicalUnit

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPointLogicalUnit Members
O2S.Components.PDF4NET.Graphics Namespace


PDFPointLogicalUnit Class Members

PDFPointLogicalUnit Class Members
See Also Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFPointLogicalUnit Class

The following tables list the members exposed by PDFPointLogicalUnit.

Public Constructors

 | Name | Description
Public Constructor | PDFPointLogicalUnit Constructor | Initializes a new PDFPointLogicalUnit object.
Top

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Overridden. Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Overridden. Defines the mapping between the logical unit and the pdf unit for the Y axis
Top

See Also

Reference

PDFPointLogicalUnit Class
O2S.Components.PDF4NET.Graphics Namespace


PDFPointLogicalUnit Constructor

PDFPointLogicalUnit Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPointLogicalUnit Class : PDFPointLogicalUnit Constructor

Initializes a new PDFPointLogicalUnit object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPointLogicalUnit()
C#
public PDFPointLogicalUnit()
Managed Extensions for C++
public: PDFPointLogicalUnit();
C++/CLI
public:
PDFPointLogicalUnit();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPointLogicalUnit Class
PDFPointLogicalUnit Members


PDFPointLogicalUnit Class Methods

PDFPointLogicalUnit Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFPointLogicalUnit Class

For a list of all members of this type, see PDFPointLogicalUnit members.

Public Methods

 | Name | Description
Public Method | ToPDFUnitX | Overridden. Defines the mapping between the logical unit and the pdf unit for the X axis
Public Method | ToPDFUnitY | Overridden. Defines the mapping between the logical unit and the pdf unit for the Y axis
Top

See Also

Reference

PDFPointLogicalUnit Class
O2S.Components.PDF4NET.Graphics Namespace


ToPDFUnitX Method

ToPDFUnitX Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPointLogicalUnit Class : ToPDFUnitX Method

unit
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the X axis

Syntax

Visual Basic (Declaration)
Overrides Public Function ToPDFUnitX( _
   ByVal unit As Double _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFPointLogicalUnit
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitX(unit)
C#
public override double ToPDFUnitX(
   double unit
)
Managed Extensions for C++
public: double ToPDFUnitX(
   double unit
) override
C++/CLI
public:
double ToPDFUnitX(
   double unit
) override

Parameters

unit
the number of logical units to be converted to pdf units.

Remarks

This method is used to convert the X coordinates, which are always expressed in logical units, of a graphic object to pdf units on X axis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPointLogicalUnit Class
PDFPointLogicalUnit Members


ToPDFUnitY Method

ToPDFUnitY Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFPointLogicalUnit Class : ToPDFUnitY Method

unit
the number of logical units to be converted to pdf units.
Defines the mapping between the logical unit and the pdf unit for the Y axis

Syntax

Visual Basic (Declaration)
Overrides Public Function ToPDFUnitY( _
   ByVal unit As Double _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFPointLogicalUnit
Dim unit As Double
Dim value As Double

value = instance.ToPDFUnitY(unit)
C#
public override double ToPDFUnitY(
   double unit
)
Managed Extensions for C++
public: double ToPDFUnitY(
   double unit
) override
C++/CLI
public:
double ToPDFUnitY(
   double unit
) override

Parameters

unit
the number of logical units to be converted to pdf units.

Remarks

This method is used to convert the Y coordinates, which are always expressed in logical units, of a graphic object to pdf units on Y axis.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPointLogicalUnit Class
PDFPointLogicalUnit Members


PDFRgbColor Class

PDFRgbColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFRgbColor Class

Defines a RGB color, a color based on a RGB device colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFRgbColor
   Inherits PDFDeviceColor
Visual Basic (Usage) Copy Code
Dim instance As PDFRgbColor
C#
public class PDFRgbColor : PDFDeviceColor
Managed Extensions for C++
public __gc class PDFRgbColor : public PDFDeviceColor
C++/CLI
public ref class PDFRgbColor : public PDFDeviceColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFDeviceColor
O2S.Components.PDF4NET.Graphics.PDFRgbColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Members
O2S.Components.PDF4NET.Graphics Namespace


PDFRgbColor Class Members

PDFRgbColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFRgbColor Class

The following tables list the members exposed by PDFRgbColor.

Public Constructors

 | Name | Description
Public Constructor | PDFRgbColor Constructor | Overloaded. Initializes a new PDFRgbColor object.
Top

Public Properties

 | Name | Description
Public Property | B | Gets or sets the blue component of the color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | G | Gets or sets the green component of the color.
Public Property | R | Gets or sets the red component of the color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFRgbColor Class
O2S.Components.PDF4NET.Graphics Namespace


PDFRgbColor Constructor

PDFRgbColor Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class : PDFRgbColor Constructor

Initializes a new PDFRgbColor object.

Overload List

Overload | Description
PDFRgbColor Constructor() | Initializes a new PDFRgbColor object.
PDFRgbColor Constructor(Byte,Byte,Byte) | Initializes a new PDFRgbColor object.
PDFRgbColor Constructor(Color) | Initializes a new PDFRgbColor object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


PDFRgbColor Constructor()

PDFRgbColor Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class > PDFRgbColor Constructor : PDFRgbColor Constructor()

Initializes a new PDFRgbColor object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFRgbColor()
C#
public PDFRgbColor()
Managed Extensions for C++
public: PDFRgbColor();
C++/CLI
public:
PDFRgbColor();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members
Overload List


PDFRgbColor Constructor(Byte,Byte,Byte)

PDFRgbColor Constructor(Byte,Byte,Byte)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class > PDFRgbColor Constructor : PDFRgbColor Constructor(Byte,Byte,Byte)

r
Red component of the color.
g
Green component of the color.
b
Blue component of the color.
Initializes a new PDFRgbColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal r As Byte, _
   ByVal g As Byte, _
   ByVal b As Byte _
)
Visual Basic (Usage) Copy Code
Dim r As Byte
Dim g As Byte
Dim b As Byte

Dim instance As PDFRgbColor(r, g, b)
C#
public PDFRgbColor(
   byte r,
   byte g,
   byte b
)
Managed Extensions for C++
public: PDFRgbColor(
   byte r,
   byte g,
   byte b
)
C++/CLI
public:
PDFRgbColor(
   byte r,
   byte g,
   byte b
)

Parameters

r
Red component of the color.
g
Green component of the color.
b
Blue component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members
Overload List


PDFRgbColor Constructor(Color)

PDFRgbColor Constructor(Color)
See Also
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class > PDFRgbColor Constructor : PDFRgbColor Constructor(Color)

color
Source color.
Initializes a new PDFRgbColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal color As Color _
)
Visual Basic (Usage) Copy Code
Dim color As Color

Dim instance As PDFRgbColor(color)
C#
public PDFRgbColor(
   Color color
)
Managed Extensions for C++
public: PDFRgbColor(
   Color color
)
C++/CLI
public:
PDFRgbColor(
   Color color
)

Parameters

color
Source color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members
Overload List


PDFRgbColor Class Methods

PDFRgbColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFRgbColor Class

For a list of all members of this type, see PDFRgbColor members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFRgbColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method

Clone Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class : Clone Method

Clones this color object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFRgbColor
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

A copy of this color object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


Equals Method

Equals Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class : Equals Method

obj
Object to verify.
Verifies if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFRgbColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


GetHashCode Method

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class : GetHashCode Method

Gets the hash code of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFRgbColor
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hashcode of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class : ToString Method

Converts the color object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFRgbColor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The color representation in PDF format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


PDFRgbColor Class Properties

PDFRgbColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFRgbColor Class

For a list of all members of this type, see PDFRgbColor members.

Public Properties

 | Name | Description
Public Property | B | Gets or sets the blue component of the color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | G | Gets or sets the green component of the color.
Public Property | R | Gets or sets the red component of the color.
Top

See Also

Reference

PDFRgbColor Class
O2S.Components.PDF4NET.Graphics Namespace


B Property

B Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class : B Property

Gets or sets the blue component of the color.

Syntax

Visual Basic (Declaration)
Public Property B As Byte
Visual Basic (Usage) Copy Code
Dim instance As PDFRgbColor
Dim value As Byte

instance.B = value

value = instance.B
C#
public byte B {get; set;}
Managed Extensions for C++
public: __property byte get_B();
public: __property void set_B(
   byte value
);
C++/CLI
public:
property byte B {
   byte get();
   void set (byte value);
}

Return Value

Blue component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


G Property

G Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class : G Property

Gets or sets the green component of the color.

Syntax

Visual Basic (Declaration)
Public Property G As Byte
Visual Basic (Usage) Copy Code
Dim instance As PDFRgbColor
Dim value As Byte

instance.G = value

value = instance.G
C#
public byte G {get; set;}
Managed Extensions for C++
public: __property byte get_G();
public: __property void set_G(
   byte value
);
C++/CLI
public:
property byte G {
   byte get();
   void set (byte value);
}

Return Value

Green component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


R Property

R Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFRgbColor Class : R Property

Gets or sets the red component of the color.

Syntax

Visual Basic (Declaration)
Public Property R As Byte
Visual Basic (Usage) Copy Code
Dim instance As PDFRgbColor
Dim value As Byte

instance.R = value

value = instance.R
C#
public byte R {get; set;}
Managed Extensions for C++
public: __property byte get_R();
public: __property void set_R(
   byte value
);
C++/CLI
public:
property byte R {
   byte get();
   void set (byte value);
}

Return Value

Red component of the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRgbColor Class
PDFRgbColor Members


PDFSeparationColor Class

PDFSeparationColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFSeparationColor Class

Defines an separation color, based on a separation colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSeparationColor
   Inherits PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColor
C#
public class PDFSeparationColor : PDFColor
Managed Extensions for C++
public __gc class PDFSeparationColor : public PDFColor
C++/CLI
public ref class PDFSeparationColor : public PDFColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFSeparationColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFPantoneColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColor Members
O2S.Components.PDF4NET.Graphics Namespace


PDFSeparationColor Class Members

PDFSeparationColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFSeparationColor Class

The following tables list the members exposed by PDFSeparationColor.

Public Constructors

 | Name | Description
Public Constructor | PDFSeparationColor Constructor | Initializes a new PDFSeparationColor object.
Top

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | Tint | Gets or sets the tint for this color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFSeparationColor Class
O2S.Components.PDF4NET.Graphics Namespace


PDFSeparationColor Constructor

PDFSeparationColor Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFSeparationColor Class : PDFSeparationColor Constructor

colorSpace
a PDFSeparationColorSpace object the color is based on.
Initializes a new PDFSeparationColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorSpace As PDFSeparationColorSpace _
)
Visual Basic (Usage) Copy Code
Dim colorSpace As PDFSeparationColorSpace

Dim instance As PDFSeparationColor(colorSpace)
C#
public PDFSeparationColor(
   PDFSeparationColorSpace colorSpace
)
Managed Extensions for C++
public: PDFSeparationColor(
   PDFSeparationColorSpace* colorSpace
)
C++/CLI
public:
PDFSeparationColor(
   PDFSeparationColorSpace^ colorSpace
)

Parameters

colorSpace
a PDFSeparationColorSpace object the color is based on.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColor Class
PDFSeparationColor Members


PDFSeparationColor Class Methods

PDFSeparationColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFSeparationColor Class

For a list of all members of this type, see PDFSeparationColor members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFSeparationColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method

Clone Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFSeparationColor Class : Clone Method

Clones this color object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColor
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

A copy of this color object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColor Class
PDFSeparationColor Members


Equals Method

Equals Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFSeparationColor Class : Equals Method

obj
Object to verify.
Verifies if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColor Class
PDFSeparationColor Members


GetHashCode Method

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFSeparationColor Class : GetHashCode Method

Gets the hash code of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColor
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hashcode of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColor Class
PDFSeparationColor Members


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFSeparationColor Class : ToString Method

Converts the color object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The color representation in PDF format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColor Class
PDFSeparationColor Members


PDFSeparationColor Class Properties

PDFSeparationColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFSeparationColor Class

For a list of all members of this type, see PDFSeparationColor members.

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | Tint | Gets or sets the tint for this color.
Top

See Also

Reference

PDFSeparationColor Class
O2S.Components.PDF4NET.Graphics Namespace


Tint Property

Tint Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFSeparationColor Class : Tint Property

Gets or sets the tint for this color.

Syntax

Visual Basic (Declaration)
Public Property Tint As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColor
Dim value As Double

instance.Tint = value

value = instance.Tint
C#
public double Tint {get; set;}
Managed Extensions for C++
public: __property double get_Tint();
public: __property void set_Tint(
   double value
);
C++/CLI
public:
property double Tint {
   double get();
   void set (double value);
}

Return Value

A float value specifying the tint of this color.

Remarks

The acceptable range for this value is [0.0 1.0].
0.0 means the lightest color that can be achieved, and 1.0 means the darkest color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColor Class
PDFSeparationColor Members


PDFShadingPattern Class

PDFShadingPattern Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFShadingPattern Class

Defines a PDF shading pattern.

Syntax

Visual Basic (Declaration)
Public Class PDFShadingPattern
   Inherits PDFPattern
Visual Basic (Usage) Copy Code
Dim instance As PDFShadingPattern
C#
public class PDFShadingPattern : PDFPattern
Managed Extensions for C++
public __gc class PDFShadingPattern : public PDFPattern
C++/CLI
public ref class PDFShadingPattern : public PDFPattern

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.PDFPattern
O2S.Components.PDF4NET.Graphics.PDFShadingPattern
O2S.Components.PDF4NET.Graphics.PDFAxialShadingPattern

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFShadingPattern Members
O2S.Components.PDF4NET.Graphics Namespace


PDFShadingPattern Class Members

PDFShadingPattern Class Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFShadingPattern Class

The following tables list the members exposed by PDFShadingPattern.

Public Constructors

 | Name | Description
Public Constructor | PDFShadingPattern Constructor | Initializes a new PDFShadingPattern object.
Top

See Also

Reference

PDFShadingPattern Class
O2S.Components.PDF4NET.Graphics Namespace


PDFShadingPattern Constructor

PDFShadingPattern Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFShadingPattern Class : PDFShadingPattern Constructor

Initializes a new PDFShadingPattern object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFShadingPattern()
C#
public PDFShadingPattern()
Managed Extensions for C++
public: PDFShadingPattern();
C++/CLI
public:
PDFShadingPattern();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFShadingPattern Class
PDFShadingPattern Members


PDFShadingPatternColor Class

PDFShadingPatternColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFShadingPatternColor Class

Defines a special color based on a shading pattern.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFShadingPatternColor
   Inherits PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFShadingPatternColor
C#
public class PDFShadingPatternColor : PDFColor
Managed Extensions for C++
public __gc class PDFShadingPatternColor : public PDFColor
C++/CLI
public ref class PDFShadingPatternColor : public PDFColor

Remarks

This is not an actual color, the pattern is used for stroking and filling shapes.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFShadingPatternColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFShadingPatternColor Members
O2S.Components.PDF4NET.Graphics Namespace


PDFShadingPatternColor Class Members

PDFShadingPatternColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFShadingPatternColor Class

The following tables list the members exposed by PDFShadingPatternColor.

Public Constructors

 | Name | Description
Public Constructor | PDFShadingPatternColor Constructor | Initializes a new PDFShadingPatternColor object.
Top

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | Pattern | Gets the pattern that defines the color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFShadingPatternColor Class
O2S.Components.PDF4NET.Graphics Namespace


PDFShadingPatternColor Constructor

PDFShadingPatternColor Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFShadingPatternColor Class : PDFShadingPatternColor Constructor

shadingPattern
The tiling pattern that represents the color.
Initializes a new PDFShadingPatternColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal shadingPattern As PDFShadingPattern _
)
Visual Basic (Usage) Copy Code
Dim shadingPattern As PDFShadingPattern

Dim instance As PDFShadingPatternColor(shadingPattern)
C#
public PDFShadingPatternColor(
   PDFShadingPattern shadingPattern
)
Managed Extensions for C++
public: PDFShadingPatternColor(
   PDFShadingPattern* shadingPattern
)
C++/CLI
public:
PDFShadingPatternColor(
   PDFShadingPattern^ shadingPattern
)

Parameters

shadingPattern
The tiling pattern that represents the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFShadingPatternColor Class
PDFShadingPatternColor Members


PDFShadingPatternColor Class Methods

PDFShadingPatternColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFShadingPatternColor Class

For a list of all members of this type, see PDFShadingPatternColor members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFShadingPatternColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method

Clone Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFShadingPatternColor Class : Clone Method

Clones this color object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFShadingPatternColor
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

A copy of this color object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFShadingPatternColor Class
PDFShadingPatternColor Members


Equals Method

Equals Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFShadingPatternColor Class : Equals Method

obj
Object to verify.
Verifies if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFShadingPatternColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFShadingPatternColor Class
PDFShadingPatternColor Members


GetHashCode Method

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFShadingPatternColor Class : GetHashCode Method

Gets the hash code of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFShadingPatternColor
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hashcode of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFShadingPatternColor Class
PDFShadingPatternColor Members


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFShadingPatternColor Class : ToString Method

Converts the color object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFShadingPatternColor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The color representation in PDF format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFShadingPatternColor Class
PDFShadingPatternColor Members


PDFShadingPatternColor Class Properties

PDFShadingPatternColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFShadingPatternColor Class

For a list of all members of this type, see PDFShadingPatternColor members.

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | Pattern | Gets the pattern that defines the color.
Top

See Also

Reference

PDFShadingPatternColor Class
O2S.Components.PDF4NET.Graphics Namespace


Pattern Property

Pattern Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFShadingPatternColor Class : Pattern Property

Gets the pattern that defines the color.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pattern As PDFShadingPattern
Visual Basic (Usage) Copy Code
Dim instance As PDFShadingPatternColor
Dim value As PDFShadingPattern

value = instance.Pattern
C#
public PDFShadingPattern Pattern {get;}
Managed Extensions for C++
public: __property PDFShadingPattern* get_Pattern();
C++/CLI
public:
property PDFShadingPattern^ Pattern {
   PDFShadingPattern^ get();
}

Return Value

The pattern used for painting.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFShadingPatternColor Class
PDFShadingPatternColor Members


PDFTilingPattern Class

PDFTilingPattern Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFTilingPattern Class

Defines a PDF tiling pattern.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFTilingPattern
   Inherits PDFPattern
Visual Basic (Usage) Copy Code
Dim instance As PDFTilingPattern
C#
public class PDFTilingPattern : PDFPattern
Managed Extensions for C++
public __gc class PDFTilingPattern : public PDFPattern
C++/CLI
public ref class PDFTilingPattern : public PDFPattern

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.PDFPattern
O2S.Components.PDF4NET.Graphics.PDFTilingPattern
O2S.Components.PDF4NET.Graphics.PDFHatchPattern

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTilingPattern Members
O2S.Components.PDF4NET.Graphics Namespace


PDFTilingPattern Class Members

PDFTilingPattern Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFTilingPattern Class

The following tables list the members exposed by PDFTilingPattern.

Public Constructors

 | Name | Description
Public Constructor | PDFTilingPattern Constructor | Initializes a new PDFTilingPattern object.
Top

Public Properties

 | Name | Description
Public Property | Canvas | Gets the pattern canvas.
Public Property | Height | Gets or sets the height of the pattern cell.
Public Property | Width | Gets or sets the width of the pattern cell.
Public Property | XStep | Gets or sets the horizontal spacing between pattern cells.
Public Property | YStep | Gets or sets the vertical spacing between pattern cells.
Top

See Also

Reference

PDFTilingPattern Class
O2S.Components.PDF4NET.Graphics Namespace


PDFTilingPattern Constructor

PDFTilingPattern Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPattern Class : PDFTilingPattern Constructor

Initializes a new PDFTilingPattern object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFTilingPattern()
C#
public PDFTilingPattern()
Managed Extensions for C++
public: PDFTilingPattern();
C++/CLI
public:
PDFTilingPattern();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTilingPattern Class
PDFTilingPattern Members


PDFTilingPattern Class Properties

PDFTilingPattern Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFTilingPattern Class

For a list of all members of this type, see PDFTilingPattern members.

Public Properties

 | Name | Description
Public Property | Canvas | Gets the pattern canvas.
Public Property | Height | Gets or sets the height of the pattern cell.
Public Property | Width | Gets or sets the width of the pattern cell.
Public Property | XStep | Gets or sets the horizontal spacing between pattern cells.
Public Property | YStep | Gets or sets the vertical spacing between pattern cells.
Top

See Also

Reference

PDFTilingPattern Class
O2S.Components.PDF4NET.Graphics Namespace


Canvas Property

Canvas Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPattern Class : Canvas Property

Gets the pattern canvas.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Canvas As PDFBasicCanvas
Visual Basic (Usage) Copy Code
Dim instance As PDFTilingPattern
Dim value As PDFBasicCanvas

value = instance.Canvas
C#
public PDFBasicCanvas Canvas {get;}
Managed Extensions for C++
public: __property PDFBasicCanvas* get_Canvas();
C++/CLI
public:
property PDFBasicCanvas^ Canvas {
   PDFBasicCanvas^ get();
}

Return Value

The drawing surface of the pattern.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTilingPattern Class
PDFTilingPattern Members


Height Property

Height Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPattern Class : Height Property

Gets or sets the height of the pattern cell.

Syntax

Visual Basic (Declaration)
Public Property Height As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFTilingPattern
Dim value As Double

instance.Height = value

value = instance.Height
C#
public double Height {get; set;}
Managed Extensions for C++
public: __property double get_Height();
public: __property void set_Height(
   double value
);
C++/CLI
public:
property double Height {
   double get();
   void set (double value);
}

Return Value

The height of the pattern cell.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTilingPattern Class
PDFTilingPattern Members


Width Property

Width Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPattern Class : Width Property

Gets or sets the width of the pattern cell.

Syntax

Visual Basic (Declaration)
Public Property Width As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFTilingPattern
Dim value As Double

instance.Width = value

value = instance.Width
C#
public double Width {get; set;}
Managed Extensions for C++
public: __property double get_Width();
public: __property void set_Width(
   double value
);
C++/CLI
public:
property double Width {
   double get();
   void set (double value);
}

Return Value

The width of the pattern cell.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTilingPattern Class
PDFTilingPattern Members


XStep Property

XStep Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPattern Class : XStep Property

Gets or sets the horizontal spacing between pattern cells.

Syntax

Visual Basic (Declaration)
Public Property XStep As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFTilingPattern
Dim value As Double

instance.XStep = value

value = instance.XStep
C#
public double XStep {get; set;}
Managed Extensions for C++
public: __property double get_XStep();
public: __property void set_XStep(
   double value
);
C++/CLI
public:
property double XStep {
   double get();
   void set (double value);
}

Return Value

The horizontal space between pattern cells.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTilingPattern Class
PDFTilingPattern Members


YStep Property

YStep Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPattern Class : YStep Property

Gets or sets the vertical spacing between pattern cells.

Syntax

Visual Basic (Declaration)
Public Property YStep As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFTilingPattern
Dim value As Double

instance.YStep = value

value = instance.YStep
C#
public double YStep {get; set;}
Managed Extensions for C++
public: __property double get_YStep();
public: __property void set_YStep(
   double value
);
C++/CLI
public:
property double YStep {
   double get();
   void set (double value);
}

Return Value

The vertical space between pattern cells.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTilingPattern Class
PDFTilingPattern Members


PDFTilingPatternColor Class

PDFTilingPatternColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFTilingPatternColor Class

Defines a special color based on a tiling pattern.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFTilingPatternColor
   Inherits PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFTilingPatternColor
C#
public class PDFTilingPatternColor : PDFColor
Managed Extensions for C++
public __gc class PDFTilingPatternColor : public PDFColor
C++/CLI
public ref class PDFTilingPatternColor : public PDFColor

Remarks

This is not an actual color, the pattern is used for stroking and filling shapes.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFTilingPatternColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTilingPatternColor Members
O2S.Components.PDF4NET.Graphics Namespace


PDFTilingPatternColor Class Members

PDFTilingPatternColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFTilingPatternColor Class

The following tables list the members exposed by PDFTilingPatternColor.

Public Constructors

 | Name | Description
Public Constructor | PDFTilingPatternColor Constructor | Initializes a new PDFTilingPatternColor object.
Top

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | Pattern | Gets the pattern that defines the color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFTilingPatternColor Class
O2S.Components.PDF4NET.Graphics Namespace


PDFTilingPatternColor Constructor

PDFTilingPatternColor Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPatternColor Class : PDFTilingPatternColor Constructor

tillingPattern
The tiling pattern that represents the color.
Initializes a new PDFTilingPatternColor object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal tillingPattern As PDFTilingPattern _
)
Visual Basic (Usage) Copy Code
Dim tillingPattern As PDFTilingPattern

Dim instance As PDFTilingPatternColor(tillingPattern)
C#
public PDFTilingPatternColor(
   PDFTilingPattern tillingPattern
)
Managed Extensions for C++
public: PDFTilingPatternColor(
   PDFTilingPattern* tillingPattern
)
C++/CLI
public:
PDFTilingPatternColor(
   PDFTilingPattern^ tillingPattern
)

Parameters

tillingPattern
The tiling pattern that represents the color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTilingPatternColor Class
PDFTilingPatternColor Members


PDFTilingPatternColor Class Methods

PDFTilingPatternColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFTilingPatternColor Class

For a list of all members of this type, see PDFTilingPatternColor members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Clones this color object.
Public Method | Equals | Overridden. Verifies if the given object is equal to this object.
Public Method | GetHashCode | Overridden. Gets the hash code of this object.
Public Method | ToString | Overridden. Converts the color object to string representation.
Top

See Also

Reference

PDFTilingPatternColor Class
O2S.Components.PDF4NET.Graphics Namespace


Clone Method

Clone Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPatternColor Class : Clone Method

Clones this color object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As PDFTilingPatternColor
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

A copy of this color object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTilingPatternColor Class
PDFTilingPatternColor Members


Equals Method

Equals Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPatternColor Class : Equals Method

obj
Object to verify.
Verifies if the given object is equal to this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTilingPatternColor
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
Object to verify.

Return Value

True if the objects are equal, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTilingPatternColor Class
PDFTilingPatternColor Members


GetHashCode Method

GetHashCode Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPatternColor Class : GetHashCode Method

Gets the hash code of this object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFTilingPatternColor
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hashcode of the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTilingPatternColor Class
PDFTilingPatternColor Members


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPatternColor Class : ToString Method

Converts the color object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFTilingPatternColor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The color representation in PDF format

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTilingPatternColor Class
PDFTilingPatternColor Members


PDFTilingPatternColor Class Properties

PDFTilingPatternColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFTilingPatternColor Class

For a list of all members of this type, see PDFTilingPatternColor members.

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Public Property | Pattern | Gets the pattern that defines the color.
Top

See Also

Reference

PDFTilingPatternColor Class
O2S.Components.PDF4NET.Graphics Namespace


Pattern Property

Pattern Property
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFTilingPatternColor Class : Pattern Property

Gets the pattern that defines the color.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pattern As PDFTilingPattern
Visual Basic (Usage) Copy Code
Dim instance As PDFTilingPatternColor
Dim value As PDFTilingPattern

value = instance.Pattern
C#
public PDFTilingPattern Pattern {get;}
Managed Extensions for C++
public: __property PDFTilingPattern* get_Pattern();
C++/CLI
public:
property PDFTilingPattern^ Pattern {
   PDFTilingPattern^ get();
}

Return Value

The pattern used for painting.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTilingPatternColor Class
PDFTilingPatternColor Members


PDFVerticalGradientBrush Class

PDFVerticalGradientBrush Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFVerticalGradientBrush Class

Defines a vertical gradient brush for filling closed shapes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFVerticalGradientBrush
   Inherits PDFLinearGradientBrush
Visual Basic (Usage) Copy Code
Dim instance As PDFVerticalGradientBrush
C#
public class PDFVerticalGradientBrush : PDFLinearGradientBrush
Managed Extensions for C++
public __gc class PDFVerticalGradientBrush : public PDFLinearGradientBrush
C++/CLI
public ref class PDFVerticalGradientBrush : public PDFLinearGradientBrush

Remarks

A vertical gradient starts at top and ends at the bottom of the filled shape.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFBrush
O2S.Components.PDF4NET.Graphics.PDFLinearGradientBrush
O2S.Components.PDF4NET.Graphics.PDFVerticalGradientBrush

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFVerticalGradientBrush Members
O2S.Components.PDF4NET.Graphics Namespace


PDFVerticalGradientBrush Class Members

PDFVerticalGradientBrush Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFVerticalGradientBrush Class

The following tables list the members exposed by PDFVerticalGradientBrush.

Public Constructors

 | Name | Description
Public Constructor | PDFVerticalGradientBrush Constructor | Initializes a new PDFVerticalGradientBrush object.
Top

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. (Inherited from PDFLinearGradientBrush)
Public Property | EndColor | (Inherited from PDFLinearGradientBrush)
Public Property | StartColor | Gets or sets the start color of the gradient. (Inherited from PDFLinearGradientBrush)
Top

See Also

Reference

PDFVerticalGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


PDFVerticalGradientBrush Constructor

PDFVerticalGradientBrush Constructor
[image]
O2S.Components.PDF4NET.Graphics Namespace > PDFVerticalGradientBrush Class : PDFVerticalGradientBrush Constructor

Initializes a new PDFVerticalGradientBrush object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFVerticalGradientBrush()
C#
public PDFVerticalGradientBrush()
Managed Extensions for C++
public: PDFVerticalGradientBrush();
C++/CLI
public:
PDFVerticalGradientBrush();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFVerticalGradientBrush Class
PDFVerticalGradientBrush Members


PDFBlendMode Enumeration

PDFBlendMode Enumeration
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFBlendMode Enumeration

Specifies the available blend modes.

Syntax

Visual Basic (Declaration)
Public Enum PDFBlendMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFBlendMode
C#
public enum PDFBlendMode : Enum
Managed Extensions for C++
__value public enum PDFBlendMode : public Enum
C++/CLI
public enum class PDFBlendMode : public Enum

Members

Member | Description
None | Same as Normal, but for internal library use.
Normal | Selects the source color.
Multiply | Multiplies the backdrop and source color.
Screen | Multiplies the complements of backdrop and source color values, and then complements the result.
Overlay | Multiplies or screens the colors depending on the backdrop color.
Darken | Selects the darker of the backdrop and source colors.
Lighten | Selects the lighter of the backdrop and source colors.
ColorDodge | Brightens the backdrop color to reflect the source color.
ColorBurn | Darkens the backdrop color to reflect the source color.
HardLight | Multiplies or screens the colors depending on the source color.
SoftLight | Darkens or lightens the colors depending on the source color.
Difference | Subtracts the darker of the two constituents colors from the lighter.
Exclusion | Same as Difference, but lower in contrast.
Hue | Creates a color with the hue of the source color and the saturation and luminance of the backdrop color.
Saturation | Creates a color with the saturation of the source color and the hue and luminance of the backdrop color.
Color | Creates a color with the saturation and hue of the source color and the luminance of the backdrop color.
Luminosity | Creates a color with the luminance of the source color and the saturation and hue of the backdrop color.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFBlendMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


PDFContentMirroring Enumeration

PDFContentMirroring Enumeration
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFContentMirroring Enumeration

Specifies the available mirroring options when drawing graphic content.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum PDFContentMirroring
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFContentMirroring
C#
[FlagsAttribute()]
public enum PDFContentMirroring : Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum PDFContentMirroring : public Enum
C++/CLI
[FlagsAttribute()]
public enum class PDFContentMirroring : public Enum

Members

Member | Description
NoMirroring | The content is drawn as it is.
XAxisMirroring | The content is mirrored about X axis.
YAxisMirroring | The content is mirrored about Y axis.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFContentMirroring

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


PDFDashStyle Enumeration

PDFDashStyle Enumeration
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFDashStyle Enumeration

Specifies the style of dashed lines drawn with a PDFPen object.

Syntax

Visual Basic (Declaration)
Public Enum PDFDashStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFDashStyle
C#
public enum PDFDashStyle : Enum
Managed Extensions for C++
__value public enum PDFDashStyle : public Enum
C++/CLI
public enum class PDFDashStyle : public Enum

Members

Member | Description
Custom | Specifies a custom dash style. The DashPattern property of the PDFPen object is used to specify the dashes and spaces pattern.
Dash | Specifies a line consisting of dashes.
DashDot | Specifies a line consisting of a repeating pattern of dash-dot.
DashDotDot | Specifies a line consisting of a repeating pattern of dash-dot-dot.
Dot | Specifies a line consisting of dots.
Solid | Specifies a solid line.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFDashStyle

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


PDFFillMode Enumeration

PDFFillMode Enumeration
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFFillMode Enumeration

Specifies the available fill modes for a complex shape.

Syntax

Visual Basic (Declaration)
Public Enum PDFFillMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFFillMode
C#
public enum PDFFillMode : Enum
Managed Extensions for C++
__value public enum PDFFillMode : public Enum
C++/CLI
public enum class PDFFillMode : public Enum

Members

Member | Description
NonZeroWinding | Non zero winding rule for filling the polygons.
EvenOdd | Even-odd rule for filling the polygons.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFFillMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


PDFHatchType Enumeration

PDFHatchType Enumeration
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFHatchType Enumeration

Specifies the available types for hatch brushes.

Syntax

Visual Basic (Declaration)
Public Enum PDFHatchType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFHatchType
C#
public enum PDFHatchType : Enum
Managed Extensions for C++
__value public enum PDFHatchType : public Enum
C++/CLI
public enum class PDFHatchType : public Enum

Members

Member | Description
BackwardDiagonal | A pattern of lines on a diagonal from upper right to lower left.
ForwardDiagonal | A pattern of lines on a diagonal from upper left to lower right.
Cross | Specifies horizontal and vertical lines that cross.
DiagonalCross | Specifies forward diagonal and backward diagonal lines that cross
Horizontal | A pattern of horizontal lines.
Vertical | A pattern of vertical lines.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFHatchType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


PDFLineCap Enumeration

PDFLineCap Enumeration
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLineCap Enumeration

Specifies the available cap styles with which a Pen object can begin or end a line.

Syntax

Visual Basic (Declaration)
Public Enum PDFLineCap
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFLineCap
C#
public enum PDFLineCap : Enum
Managed Extensions for C++
__value public enum PDFLineCap : public Enum
C++/CLI
public enum class PDFLineCap : public Enum

Members

Member | Description
Flat | Specifies a flat line cap.
Round | Specifies a round line cap.
Square | Specifies a square line cap.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFLineCap

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


PDFLineJoin Enumeration

PDFLineJoin Enumeration
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLineJoin Enumeration

Specifies how to join consecutive line or curve segments

Syntax

Visual Basic (Declaration)
Public Enum PDFLineJoin
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFLineJoin
C#
public enum PDFLineJoin : Enum
Managed Extensions for C++
__value public enum PDFLineJoin : public Enum
C++/CLI
public enum class PDFLineJoin : public Enum

Members

Member | Description
Miter | Specifies a mitered join. This produces a sharp corner.
Round | Specifies a round join. This produces a smooth, circular arc between the lines.
Bevel | Specifies a beveled join. This produces a diagonal corner.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFLineJoin

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


PDFTextAlign Enumeration

PDFTextAlign Enumeration
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFTextAlign Enumeration

Specifies the available alignments for text lines.

Syntax

Visual Basic (Declaration)
Public Enum PDFTextAlign
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFTextAlign
C#
public enum PDFTextAlign : Enum
Managed Extensions for C++
__value public enum PDFTextAlign : public Enum
C++/CLI
public enum class PDFTextAlign : public Enum

Members

Member | Description
TopLeft | The text is top left aligned
TopCenter | The text is top center aligned
TopRight | The text is top right aligned
MiddleLeft | The text is middle left aligned
MiddleCenter | The text is middle center aligned
MiddleRight | The text is middle right aligned
BottomLeft | The text is bottom left aligned
BottomCenter | The text is bottom center aligned
BottomRight | The text is bottom right aligned
TopJustified | The text is top justified aligned. This alignment is used only by text boxes.
MiddleJustified | The text is middle justified aligned. This alignment is used only by text boxes.
BottomJustified | The text is bottom justified aligned. This alignment is used only by text boxes.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFTextAlign

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


PDFXAxisDirection Enumeration

PDFXAxisDirection Enumeration
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFXAxisDirection Enumeration

Specifies the available directions for the X axis of the page canvas.

Syntax

Visual Basic (Declaration)
Public Enum PDFXAxisDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFXAxisDirection
C#
public enum PDFXAxisDirection : Enum
Managed Extensions for C++
__value public enum PDFXAxisDirection : public Enum
C++/CLI
public enum class PDFXAxisDirection : public Enum

Members

Member | Description
LeftToRight | The X axis is oriented from left to right. The values on X axis grow from left to right. This is the default direction used by PDF4NET library.
RightToLeft | The X axis is oriented from right to left. The values on X axis grow from right to left.

Remarks

The X axis directions are used when positioning the graphic objects in the page canvas' coordinate system. The RightToLeft direction has no connection with RightToLeft reading and text writting used by some languages.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFXAxisDirection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


PDFYAxisDirection Enumeration

PDFYAxisDirection Enumeration
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFYAxisDirection Enumeration

Specifies the available directions for the Y axis of the page canvas.

Syntax

Visual Basic (Declaration)
Public Enum PDFYAxisDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFYAxisDirection
C#
public enum PDFYAxisDirection : Enum
Managed Extensions for C++
__value public enum PDFYAxisDirection : public Enum
C++/CLI
public enum class PDFYAxisDirection : public Enum

Members

Member | Description
TopToBottom | The Y axis is oriented from top to bottom. The values on Y axis grow from top to bottom. This is the default direction used by PDF4NET library.
BottomToTop | The Y axis is oriented from bottom to top. The values on Y axis grow from bottom to top.

Remarks

The Y axis directions are used when positioning the graphic objects in the page canvas' coordinate system.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.PDFYAxisDirection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics Namespace


O2S.Components.PDF4NET.Graphics.Barcodes Namespace

O2S.Components.PDF4NET.Graphics.Barcodes Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
BarcodeEncodingException | Defines an exception that is thrown when the barcode data can not be encoded according to barcode's rules.
PDF417Barcode | Defines a PDF 417 barcode.
PDFBarcode | Defines the base class for all barcode types.
PDFBasePDF417Barcode | Defines the base class for all PDF 417 barcodes.
PDFBidimensionalBarcode | Defines the base class for all bidimensional barcodes.
PDFCodabarBarcode | Defines a Code 39 barcode.
PDFCodablockFBarcode | Defines a CODABLOCK F barcode.
PDFCode11Barcode | Defines a Code 11 barcode.
PDFCode128ABarcode | Defines a Code 128 barcode.
PDFCode128Barcode | Defines the base class for all Code 128 barcodes.
PDFCode128BBarcode | Defines a Code 128 barcode.
PDFCode128CBarcode | Defines a Code 128 barcode.
PDFCode16KBarcode | Defines a Code 16K barcode.
PDFCode25Barcode | Defines a Code 2 of 5 barcode.
PDFCode25InterleavedBarcode | Defines a Code 2 of 5 barcode.
PDFCode32Barcode | Defines a Code 32 barcode.
PDFCode39Barcode | Defines a Code 39 barcode.
PDFCode39ExtendedBarcode | Defines an extended Code 39 barcode.
PDFCode93Barcode | Defines a Code 93 barcode.
PDFCode93ExtendedBarcode | Defines an extended Code 93 barcode.
PDFCOOP25Barcode | Defines a COOP 2 of 5 barcode.
PDFDataMatrixBarcode | Defines a DataMatrix barcode.
PDFEAN128Barcode | Defines a EAN 128 barcode.
PDFEAN13Barcode | Defines the class for EAN-13 barcodes.
PDFEAN8Barcode | Defines the class for EAN-8 barcodes.
PDFEANBarcode | Defines the base class for EAN based barcodes.
PDFFedExGround96Barcode | Defines a FedEx Ground 96 barcode.
PDFHeightModulatedBarcode | Defines the base class for all height modulated barcodes.
PDFIATA25Barcode | Defines a IATA 2 of 5 barcode.
PDFIdentcodeBarcode | Defines an Identcode barcode.
PDFISBNBarcode | Defines the class for ISBN barcodes.
PDFISMNBarcode | Defines the class for ISMN barcodes.
PDFISSNBarcode | Defines the class for ISSN barcodes.
PDFJAN13Barcode | Defines the class for JAN13 barcodes.
PDFKixBarcode | Defines a Kix barcode.
PDFLeitcodeBarcode | Defines a Leitcode barcode.
PDFMatrix25Barcode | Defines a Matrix 2 of 5 barcode.
PDFMicroPDF417Barcode | Defines a Micro PDF 417 barcode.
PDFMSIPlesseyBarcode | Defines a MSI/Plessey barcode.
PDFPharmacodeBarcode | Defines a Pharmacode barcode.
PDFPlanetBarcode | Defines a Planet barcode.
PDFPostNetBarcode | Defines a PostNet barcode.
PDFPZNBarcode | Defines a PZN barcode.
PDFRM4SCCBarcode | Defines a RM4SCC barcode.
PDFSCC14Barcode | Defines a SCC-14 barcode.
PDFSingaporePostBarcode | Defines a Singapore Post barcode.
PDFSSCC18Barcode | Defines a SSCC-18 barcode.
PDFUnidimensionalBarcode | Defines the base class for 1D barcodes.
PDFUPCABarcode | Defines the class for UPC-A barcodes.
PDFUPCEBarcode | Defines the class for UPC-E barcodes.
PDFUSPSFIMBarcode | Defines a USPS FIM barcode.
PDFUSPSHorizontalBarcode | Defines a horizontal bars barcode.
PDFUSPSPICBarcode | Defines a USPS Package Identification Code barcode.

Enumerations

Enumeration | Description
BarcodeTextLocation | Specifies the available locations for displaying text on a linear barcode.
DataMatrixEncoding | Specifies the available encoding modes for a DataMatrix barcode.
DataMatrixSymbolSize | Specifies the available sizes for a DataMatrix symbol.
MicroPDF417SymbolSize | Specifies the available sizes for a Micro PDF417 symbol.
PDF417DataCompactionMode | Specifies the available data compaction modes for a PDF417 barcode.
PDF417ErrorCorrectionLevel | Specifies the available error correction levels for a PDF417 barcode.

See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET.Graphics.Barcodes Namespace Inheritance Hierarchy

O2S.Components.PDF4NET.Graphics.Barcodes Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMicroPDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodablockFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode16KBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFDataMatrixBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodabarBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode11Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128ABarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128BBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFFedExGround96Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSCC14Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSSCC18Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSPICBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIdentcodeBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFLeitcodeBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCOOP25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIATA25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMatrix25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode32Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39ExtendedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPZNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93ExtendedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN13Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN8Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISBNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISMNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISSNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFJAN13Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCABarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCEBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPlanetBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPostNetBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFKixBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSingaporePostBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMSIPlesseyBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPharmacodeBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSFIMBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSHorizontalBarcode
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.Graphics.Barcodes.BarcodeEncodingException

See Also

Reference

O2S.Components.PDF4NET Assembly


BarcodeEncodingException Class

BarcodeEncodingException Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : BarcodeEncodingException Class

Defines an exception that is thrown when the barcode data can not be encoded according to barcode's rules.

Syntax

Visual Basic (Declaration)
Public Class BarcodeEncodingException
   Inherits ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As BarcodeEncodingException
C#
public class BarcodeEncodingException : ApplicationException
Managed Extensions for C++
public __gc class BarcodeEncodingException : public ApplicationException
C++/CLI
public ref class BarcodeEncodingException : public ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
O2S.Components.PDF4NET.Graphics.Barcodes.BarcodeEncodingException

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeEncodingException Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


BarcodeEncodingException Class Members

BarcodeEncodingException Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : BarcodeEncodingException Class

The following tables list the members exposed by BarcodeEncodingException.

Public Constructors

 | Name | Description
Public Constructor | BarcodeEncodingException Constructor | Initializes a new BarcodeEncodingException object with the specified message.
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

BarcodeEncodingException Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


BarcodeEncodingException Constructor

BarcodeEncodingException Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > BarcodeEncodingException Class : BarcodeEncodingException Constructor

message
The exception message.
Initializes a new BarcodeEncodingException object with the specified message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As BarcodeEncodingException(message)
C#
public BarcodeEncodingException(
   string message
)
Managed Extensions for C++
public: BarcodeEncodingException(
   string* message
)
C++/CLI
public:
BarcodeEncodingException(
   String^ message
)

Parameters

message
The exception message.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

BarcodeEncodingException Class
BarcodeEncodingException Members


PDF417Barcode Class

PDF417Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417Barcode Class

Defines a PDF 417 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDF417Barcode
   Inherits PDFBasePDF417Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
C#
public class PDF417Barcode : PDFBasePDF417Barcode
Managed Extensions for C++
public __gc class PDF417Barcode : public PDFBasePDF417Barcode
C++/CLI
public ref class PDF417Barcode : public PDFBasePDF417Barcode

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDF417Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDF417Barcode Class Members

PDF417Barcode Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417Barcode Class

The following tables list the members exposed by PDF417Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDF417Barcode Constructor | Initializes a new PDF417Barcode object.
Top

Public Properties

 | Name | Description
Public Property | ActualColumns | Returns the actual number of columns used by this barcode.
Public Property | ActualRows | Returns the actual number of rows used by this barcode.
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from PDFBasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | ErrorCorrectionLevel | Gets or sets the level of error correction used by this barcode.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from PDFBasePDF417Barcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

Public Methods

 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from PDFBasePDF417Barcode)
Top

See Also

Reference

PDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDF417Barcode Constructor

PDF417Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : PDF417Barcode Constructor

Initializes a new PDF417Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode()
C#
public PDF417Barcode()
Managed Extensions for C++
public: PDF417Barcode();
C++/CLI
public:
PDF417Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


PDF417Barcode Class Properties

PDF417Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417Barcode Class

For a list of all members of this type, see PDF417Barcode members.

Public Properties

 | Name | Description
Public Property | ActualColumns | Returns the actual number of columns used by this barcode.
Public Property | ActualRows | Returns the actual number of rows used by this barcode.
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from PDFBasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | ErrorCorrectionLevel | Gets or sets the level of error correction used by this barcode.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from PDFBasePDF417Barcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


ActualColumns Property

ActualColumns Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : ActualColumns Property

Returns the actual number of columns used by this barcode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActualColumns As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As Integer

value = instance.ActualColumns
C#
public int ActualColumns {get;}
Managed Extensions for C++
public: __property int get_ActualColumns();
C++/CLI
public:
property int ActualColumns {
   int get();
}

Return Value

An integer value specifying the actual number of columns used by this barcode.

Remarks

This value is computed automatically by the library when Columns property is 0. When Columns property is not 0, this property matches the Columns property.
This property returns -1 if a valid number of columns can not be computed for the following combination: barcode data, rows and error correction level.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


ActualRows Property

ActualRows Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : ActualRows Property

Returns the actual number of rows used by this barcode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActualRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As Integer

value = instance.ActualRows
C#
public int ActualRows {get;}
Managed Extensions for C++
public: __property int get_ActualRows();
C++/CLI
public:
property int ActualRows {
   int get();
}

Return Value

An integer value specifying the actual number of rows used by this barcode.

Remarks

This value is computed automatically by the library when Rows property is 0. When Rows property is not 0, this property matches the Rows property.
This property returns -1 if a valid number of rows can not be computed for the following combination: barcode data, columns and error correction level.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


Columns Property

Columns Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : Columns Property

Gets or sets the number of columns in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As Integer

instance.Columns = value

value = instance.Columns
C#
public int Columns {get; set;}
Managed Extensions for C++
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
C++/CLI
public:
property int Columns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 0 or greater than 30 - OR - Throws when value is 0 and Rows is also 0.

Remarks

The minimum number of columns in a PDF 417 barcode is 1 and the maximum number of columns is 30. If this property is 0, the library will compute automatically the number of required columns to encode the barcode data. When this property is 0, the Rows property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


ErrorCorrectionLevel Property

ErrorCorrectionLevel Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : ErrorCorrectionLevel Property

Gets or sets the level of error correction used by this barcode.

Syntax

Visual Basic (Declaration)
Public Property ErrorCorrectionLevel As PDF417ErrorCorrectionLevel
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As PDF417ErrorCorrectionLevel

instance.ErrorCorrectionLevel = value

value = instance.ErrorCorrectionLevel
C#
public PDF417ErrorCorrectionLevel ErrorCorrectionLevel {get; set;}
Managed Extensions for C++
public: __property PDF417ErrorCorrectionLevel get_ErrorCorrectionLevel();
public: __property void set_ErrorCorrectionLevel(
   PDF417ErrorCorrectionLevel value
);
C++/CLI
public:
property PDF417ErrorCorrectionLevel ErrorCorrectionLevel {
   PDF417ErrorCorrectionLevel get();
   void set (PDF417ErrorCorrectionLevel value);
}

Return Value

An PDF417ErrorCorrectionLevel enumeration member specifying the level of error correction used by this barcode.

Remarks

The lowest error correction level is 0 and the greatest error correction level is 8. Each level generates a specific number of error correction codewords.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


Rows Property

Rows Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDF417Barcode Class : Rows Property

Gets or sets the number of rows in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDF417Barcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
public int Rows {get; set;}
Managed Extensions for C++
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
C++/CLI
public:
property int Rows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 3, but not 0, or greater than 90 - OR - Throws when value is 0 and Columns is also 0.

Remarks

The minimum number of rows in a PDF 417 barcode is 3 and the maximum number of rows is 90. If this property is 0, the library will compute automatically the number of required rows to encode the barcode data. When this property is 0, the Columns property must not be 0.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDF417Barcode Class
PDF417Barcode Members


PDFBarcode Class

PDFBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBarcode Class

Defines the base class for all barcode types.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
C#
public abstract class PDFBarcode
Managed Extensions for C++
public __gc abstract class PDFBarcode
C++/CLI
public ref class PDFBarcode abstract

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFBarcode Class Members

PDFBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBarcode Class

The following tables list the members exposed by PDFBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFBarcode Constructor | Initializes a new PDFBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode.
Public Property | BarColor | Gets or sets the bars color.
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode.
Public Property | Height | Gets the height in points of the barcode rectangle.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle.
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode.
Public Property | Position | Gets or sets the position of this barcode object.
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object.
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode.
Public Property | Size | Gets or sets the size of this barcode object.
Public Property | TextColor | Gets or sets the color of the barcode text.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle.
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode.
Public Property | Width | Gets the width in points of the barcode rectangle.
Public Property | XDimension | Gets or sets the width in points of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

See Also

Reference

PDFBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFBarcode Constructor

PDFBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : PDFBarcode Constructor

Initializes a new PDFBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode()
C#
public PDFBarcode()
Managed Extensions for C++
public: PDFBarcode();
C++/CLI
public:
PDFBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


PDFBarcode Class Properties

PDFBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBarcode Class

For a list of all members of this type, see PDFBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode.
Public Property | BarColor | Gets or sets the bars color.
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode.
Public Property | Height | Gets the height in points of the barcode rectangle.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle.
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode.
Public Property | Position | Gets or sets the position of this barcode object.
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object.
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode.
Public Property | Size | Gets or sets the size of this barcode object.
Public Property | TextColor | Gets or sets the color of the barcode text.
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle.
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode.
Public Property | Width | Gets the width in points of the barcode rectangle.
Public Property | XDimension | Gets or sets the width in points of a narrow bar.
Public Property | YDimension | Gets or sets the height of a bar.
Top

See Also

Reference

PDFBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


BackColor Property

BackColor Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : BackColor Property

Gets or sets the background color of the barcode.

Syntax

Visual Basic (Declaration)
Public Property BackColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As PDFColor

instance.BackColor = value

value = instance.BackColor
C#
public PDFColor BackColor {get; set;}
Managed Extensions for C++
public: __property PDFColor* get_BackColor();
public: __property void set_BackColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ BackColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the background color of barcode.

Remarks

If this property is null (Nothing in VB.NET), then the barcode's background will be transparent. Default barcode background color is white.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


BarColor Property

BarColor Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : BarColor Property

Gets or sets the bars color.

Syntax

Visual Basic (Declaration)
Public Property BarColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As PDFColor

instance.BarColor = value

value = instance.BarColor
C#
public PDFColor BarColor {get; set;}
Managed Extensions for C++
public: __property PDFColor* get_BarColor();
public: __property void set_BarColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ BarColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the bars color.

Remarks

If this property is null (Nothing in VB.NET), then no bars are shown. Default bars color is black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


BottomQuietZone Property

BottomQuietZone Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : BottomQuietZone Property

Gets or sets the height of the bottom quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property BottomQuietZone As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Double

instance.BottomQuietZone = value

value = instance.BottomQuietZone
C#
public double BottomQuietZone {get; set;}
Managed Extensions for C++
public: __property double get_BottomQuietZone();
public: __property void set_BottomQuietZone(
   double value
);
C++/CLI
public:
property double BottomQuietZone {
   double get();
   void set (double value);
}

Return Value

A double value specifying the height of the bottom quiet zone.

Remarks

The bottom quiet zone is measured in multiples of XDimension.
The quiet zone is a blank area around the barcode that clearly delimitates the barcode symbol, so the barcode reader does not consider external elements as part of the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


Data Property

Data Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Data Property

Gets or sets the string to be encoded as barcode.

Syntax

Visual Basic (Declaration)
Public Property Data As String
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As String

instance.Data = value

value = instance.Data
C#
public string Data {get; set;}
Managed Extensions for C++
public: __property string* get_Data();
public: __property void set_Data(
   string* value
);
C++/CLI
public:
property String^ Data {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the value to be encoded as barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length (applies to some barcodes only).

Remarks

The characters allowed to be encoded are defined by each barcode type.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


Height Property

Height Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Height Property

Gets the height in points of the barcode rectangle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Double

value = instance.Height
C#
public double Height {get;}
Managed Extensions for C++
public: __property double get_Height();
C++/CLI
public:
property double Height {
   double get();
}

Return Value

A double value specifying the height of the barcode rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


Left Property

Left Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Left Property

Gets or sets the X coordinate of the top left corner of the barcode's rectangle.

Syntax

Visual Basic (Declaration)
Public Property Left As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Double

instance.Left = value

value = instance.Left
C#
public double Left {get; set;}
Managed Extensions for C++
public: __property double get_Left();
public: __property void set_Left(
   double value
);
C++/CLI
public:
property double Left {
   double get();
   void set (double value);
}

Return Value

a double value representing the X coordinate of the top left corner of the barcode's rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


LeftQuietZone Property

LeftQuietZone Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : LeftQuietZone Property

Gets or sets the width of the left quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property LeftQuietZone As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Double

instance.LeftQuietZone = value

value = instance.LeftQuietZone
C#
public double LeftQuietZone {get; set;}
Managed Extensions for C++
public: __property double get_LeftQuietZone();
public: __property void set_LeftQuietZone(
   double value
);
C++/CLI
public:
property double LeftQuietZone {
   double get();
   void set (double value);
}

Return Value

A double value specifying the width of the left quiet zone.

Remarks

The left quiet zone is measured in multiples of XDimension.
The quiet zone is a blank area around the barcode that clearly delimitates the barcode symbol, so the barcode reader does not consider external elements as part of the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


Position Property

Position Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Position Property

Gets or sets the position of this barcode object.

Syntax

Visual Basic (Declaration)
Public Property Position As PointF
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As PointF

instance.Position = value

value = instance.Position
C#
public PointF Position {get; set;}
Managed Extensions for C++
public: __property PointF get_Position();
public: __property void set_Position(
   PointF value
);
C++/CLI
public:
property PointF Position {
   PointF get();
   void set (PointF value);
}

Return Value

A PointF object specifying the position of the barcode.

Remarks

This position is relative to the top left corner of the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


Rectangle Property

Rectangle Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Rectangle Property

Gets or sets the bounding rectangle of this barcode object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rectangle As RectangleF
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As RectangleF

value = instance.Rectangle
C#
public RectangleF Rectangle {get;}
Managed Extensions for C++
public: __property RectangleF get_Rectangle();
C++/CLI
public:
property RectangleF Rectangle {
   RectangleF get();
}

Return Value

A RectangleF object specifying the position and size of the barcode.

Remarks

The bounding rectangle is relative to the top left corner of the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


RightQuietZone Property

RightQuietZone Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : RightQuietZone Property

Gets or sets the width of the right quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property RightQuietZone As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Double

instance.RightQuietZone = value

value = instance.RightQuietZone
C#
public double RightQuietZone {get; set;}
Managed Extensions for C++
public: __property double get_RightQuietZone();
public: __property void set_RightQuietZone(
   double value
);
C++/CLI
public:
property double RightQuietZone {
   double get();
   void set (double value);
}

Return Value

A double value specifying the width of the right quiet zone.

Remarks

The right quiet zone is measured in multiples of XDimension.
The quiet zone is a blank area around the barcode that clearly delimitates the barcode symbol, so the barcode reader does not consider external elements as part of the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


Size Property

Size Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Size Property

Gets or sets the size of this barcode object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As SizeF
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As SizeF

value = instance.Size
C#
public SizeF Size {get;}
Managed Extensions for C++
public: __property SizeF get_Size();
C++/CLI
public:
property SizeF Size {
   SizeF get();
}

Return Value

A SizeF object specifying the size of the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


TextColor Property

TextColor Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : TextColor Property

Gets or sets the color of the barcode text.

Syntax

Visual Basic (Declaration)
Public Property TextColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As PDFColor

instance.TextColor = value

value = instance.TextColor
C#
public PDFColor TextColor {get; set;}
Managed Extensions for C++
public: __property PDFColor* get_TextColor();
public: __property void set_TextColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ TextColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the text color.

Remarks

If this property is null (Nothing in VB.NET), then no text is shown. Default text color is black.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


Top Property

Top Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Top Property

Gets or sets the Y coordinate of the top left corner of the barcode's rectangle.

Syntax

Visual Basic (Declaration)
Public Property Top As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Double

instance.Top = value

value = instance.Top
C#
public double Top {get; set;}
Managed Extensions for C++
public: __property double get_Top();
public: __property void set_Top(
   double value
);
C++/CLI
public:
property double Top {
   double get();
   void set (double value);
}

Return Value

a double value representing the Y coordinate of the top left corner of the barcode's rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


TopQuietZone Property

TopQuietZone Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : TopQuietZone Property

Gets or sets the height of the top quiet zone of the barcode.

Syntax

Visual Basic (Declaration)
Public Property TopQuietZone As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Double

instance.TopQuietZone = value

value = instance.TopQuietZone
C#
public double TopQuietZone {get; set;}
Managed Extensions for C++
public: __property double get_TopQuietZone();
public: __property void set_TopQuietZone(
   double value
);
C++/CLI
public:
property double TopQuietZone {
   double get();
   void set (double value);
}

Return Value

A double value specifying the height of the top quiet zone.

Remarks

The top quiet zone is measured in multiples of XDimension.
The quiet zone is a blank area around the barcode that clearly delimitates the barcode symbol, so the barcode reader does not consider external elements as part of the barcode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


Width Property

Width Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : Width Property

Gets the width in points of the barcode rectangle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Double

value = instance.Width
C#
public double Width {get;}
Managed Extensions for C++
public: __property double get_Width();
C++/CLI
public:
property double Width {
   double get();
}

Return Value

A double value specifying the width of the barcode rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


XDimension Property

XDimension Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : XDimension Property

Gets or sets the width in points of a narrow bar.

Syntax

Visual Basic (Declaration)
Public Property XDimension As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Double

instance.XDimension = value

value = instance.XDimension
C#
public double XDimension {get; set;}
Managed Extensions for C++
public: __property double get_XDimension();
public: __property void set_XDimension(
   double value
);
C++/CLI
public:
property double XDimension {
   double get();
   void set (double value);
}

Return Value

A double value specifying the width of a narrow bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Remarks

The recommended width of a narrow bar is 0.864 points, which is 12 mils (1 mil = 0.001inches). Depending on the barcode printer resolution and quality of barcode scanner, the XDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower XDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


YDimension Property

YDimension Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBarcode Class : YDimension Property

Gets or sets the height of a bar.

Syntax

Visual Basic (Declaration)
Public Overridable Property YDimension As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFBarcode
Dim value As Double

instance.YDimension = value

value = instance.YDimension
C#
public virtual double YDimension {get; set;}
Managed Extensions for C++
public: __property virtual double get_YDimension();
public: __property virtual void set_YDimension(
   double value
);
C++/CLI
public:
virtual property double YDimension {
   double get();
   void set (double value);
}

Return Value

A double value specifying the height of a bar.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBarcode Class
PDFBarcode Members


PDFBasePDF417Barcode Class

PDFBasePDF417Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBasePDF417Barcode Class

Defines the base class for all PDF 417 barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFBasePDF417Barcode
   Inherits PDFBidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFBasePDF417Barcode
C#
public abstract class PDFBasePDF417Barcode : PDFBidimensionalBarcode
Managed Extensions for C++
public __gc abstract class PDFBasePDF417Barcode : public PDFBidimensionalBarcode
C++/CLI
public ref class PDFBasePDF417Barcode abstract : public PDFBidimensionalBarcode

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMicroPDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDF417Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasePDF417Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFBasePDF417Barcode Class Members

PDFBasePDF417Barcode Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBasePDF417Barcode Class

The following tables list the members exposed by PDFBasePDF417Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFBasePDF417Barcode Constructor | Initializes a new PDF417Barcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

Public Methods

 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode.
Top

See Also

Reference

PDFBasePDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFBasePDF417Barcode Constructor

PDFBasePDF417Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBasePDF417Barcode Class : PDFBasePDF417Barcode Constructor

Initializes a new PDF417Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFBasePDF417Barcode()
C#
public PDFBasePDF417Barcode()
Managed Extensions for C++
public: PDFBasePDF417Barcode();
C++/CLI
public:
PDFBasePDF417Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasePDF417Barcode Class
PDFBasePDF417Barcode Members


PDFBasePDF417Barcode Class Methods

PDFBasePDF417Barcode Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBasePDF417Barcode Class

For a list of all members of this type, see PDFBasePDF417Barcode members.

Public Methods

 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode.
Top

See Also

Reference

PDFBasePDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


GetMaxDataLength Method

GetMaxDataLength Method
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBasePDF417Barcode Class : GetMaxDataLength Method

Calculates the length of the maximum data section that can be encoded in the barcode.

Syntax

Visual Basic (Declaration)
Public Function GetMaxDataLength() As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFBasePDF417Barcode
Dim value As Integer

value = instance.GetMaxDataLength()
C#
public int GetMaxDataLength()
Managed Extensions for C++
public: int GetMaxDataLength();
C++/CLI
public:
int GetMaxDataLength();

Return Value

The maximum length of encoded data.

Remarks

This method calculates how much of the barcode data can be actually encoded in the barcode. The encoded data is considered to start at the beginning of barcode data. The maximum length is calculated based on barcode data, error correction level and barcode rows and columns.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasePDF417Barcode Class
PDFBasePDF417Barcode Members


PDFBasePDF417Barcode Class Properties

PDFBasePDF417Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBasePDF417Barcode Class

For a list of all members of this type, see PDFBasePDF417Barcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built.
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFBasePDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


CompactionMode Property

CompactionMode Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBasePDF417Barcode Class : CompactionMode Property

Gets or sets the data compaction mode for this barcode.

Syntax

Visual Basic (Declaration)
Public Property CompactionMode As PDF417DataCompactionMode
Visual Basic (Usage) Copy Code
Dim instance As PDFBasePDF417Barcode
Dim value As PDF417DataCompactionMode

instance.CompactionMode = value

value = instance.CompactionMode
C#
public PDF417DataCompactionMode CompactionMode {get; set;}
Managed Extensions for C++
public: __property PDF417DataCompactionMode get_CompactionMode();
public: __property void set_CompactionMode(
   PDF417DataCompactionMode value
);
C++/CLI
public:
property PDF417DataCompactionMode CompactionMode {
   PDF417DataCompactionMode get();
   void set (PDF417DataCompactionMode value);
}

Return Value

A PDF417DataCompactionMode enumeration member specifying the data compaction mode used in this barcode.

Remarks

The Text compaction mode provides a 2:1 compaction ratio when using only ASCII characters from 0x20 to 0x7F. The Numeric compaction mode provides a 2.93:1 compaction ratio when using only digits (0x30 to 0x39). Byte compaction mode provides a 1.2:1 compaction ratio when using any 8bit character.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasePDF417Barcode Class
PDFBasePDF417Barcode Members


IsValid Property

IsValid Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBasePDF417Barcode Class : IsValid Property

Gets a value indicating whether a valid barcode can be built.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsValid As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFBasePDF417Barcode
Dim value As Boolean

value = instance.IsValid
C#
public bool IsValid {get;}
Managed Extensions for C++
public: __property bool get_IsValid();
C++/CLI
public:
property bool IsValid {
   bool get();
}

Return Value

True if the barcode can be built, false otherwise.

Remarks

The following items are considered when building the barcode: barcode data, rows, columns and error correction level.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBasePDF417Barcode Class
PDFBasePDF417Barcode Members


PDFBidimensionalBarcode Class

PDFBidimensionalBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBidimensionalBarcode Class

Defines the base class for all bidimensional barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFBidimensionalBarcode
   Inherits PDFBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFBidimensionalBarcode
C#
public abstract class PDFBidimensionalBarcode : PDFBarcode
Managed Extensions for C++
public __gc abstract class PDFBidimensionalBarcode : public PDFBarcode
C++/CLI
public ref class PDFBidimensionalBarcode abstract : public PDFBarcode

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFDataMatrixBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode16KBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodablockFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBidimensionalBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFBidimensionalBarcode Class Members

PDFBidimensionalBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBidimensionalBarcode Class

The following tables list the members exposed by PDFBidimensionalBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFBidimensionalBarcode Constructor | Initializes a new PDFBidimensionalBarcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFBidimensionalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFBidimensionalBarcode Constructor

PDFBidimensionalBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBidimensionalBarcode Class : PDFBidimensionalBarcode Constructor

Initializes a new PDFBidimensionalBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFBidimensionalBarcode()
C#
public PDFBidimensionalBarcode()
Managed Extensions for C++
public: PDFBidimensionalBarcode();
C++/CLI
public:
PDFBidimensionalBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBidimensionalBarcode Class
PDFBidimensionalBarcode Members


PDFBidimensionalBarcode Class Properties

PDFBidimensionalBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFBidimensionalBarcode Class

For a list of all members of this type, see PDFBidimensionalBarcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFBidimensionalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


AlternateData Property

AlternateData Property
See Also Example
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFBidimensionalBarcode Class : AlternateData Property

Gets or sets the alternate data to encode as a barcode.

Syntax

Visual Basic (Declaration)
Public Property AlternateData As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFBidimensionalBarcode
Dim value() As Byte

instance.AlternateData = value

value = instance.AlternateData
C#
public byte[] AlternateData {get; set;}
Managed Extensions for C++
public: __property byte[]* get_AlternateData();
public: __property void set_AlternateData(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ AlternateData {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array specifying the data to be encoded as a barcode.

Example

The following line of code shows how to encode a Unicode string:
C# Copy Code
...<br/>
barcode.AlternateData = Encoding.Unicode.GetBytes("my unicode string");
...<br/>

Remarks

Barcodes were designed to work with 8bit characters. Because .NET strings are Unicode, when they are converted to 8bit characters (using Windows 1252 encoding) the Unicode characters are removed. This property allows you to specify directly the byte array to encode.
If both PDFBarcode.Data and AlternateData properties are specified, the AlternateData property is used.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBidimensionalBarcode Class
PDFBidimensionalBarcode Members


PDFCodabarBarcode Class

PDFCodabarBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodabarBarcode Class

Defines a Code 39 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCodabarBarcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCodabarBarcode
C#
public class PDFCodabarBarcode : PDFUnidimensionalBarcode
Managed Extensions for C++
public __gc class PDFCodabarBarcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFCodabarBarcode : public PDFUnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Codabar barcode: 0 1 2 3 4 5 6 7 8 9 - $ : / . +

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodabarBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodabarBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCodabarBarcode Class Members

PDFCodabarBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodabarBarcode Class

The following tables list the members exposed by PDFCodabarBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCodabarBarcode Constructor | Overloaded. Initializes a new PDFCodabarBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCodabarBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCodabarBarcode Constructor

PDFCodabarBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodabarBarcode Class : PDFCodabarBarcode Constructor

Initializes a new PDFCodabarBarcode object.

Overload List

Overload | Description
PDFCodabarBarcode Constructor() | Initializes a new PDFCodabarBarcode object.
PDFCodabarBarcode Constructor(String) | Initializes a new PDFCodabarBarcode object.
PDFCodabarBarcode Constructor(String,Double,Double) | Initializes a new PDFCodabarBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodabarBarcode Class
PDFCodabarBarcode Members


PDFCodabarBarcode Constructor()

PDFCodabarBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodabarBarcode Class > PDFCodabarBarcode Constructor : PDFCodabarBarcode Constructor()

Initializes a new PDFCodabarBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCodabarBarcode()
C#
public PDFCodabarBarcode()
Managed Extensions for C++
public: PDFCodabarBarcode();
C++/CLI
public:
PDFCodabarBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodabarBarcode Class
PDFCodabarBarcode Members
Overload List


PDFCodabarBarcode Constructor(String)

PDFCodabarBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodabarBarcode Class > PDFCodabarBarcode Constructor : PDFCodabarBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCodabarBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCodabarBarcode(data)
C#
public PDFCodabarBarcode(
   string data
)
Managed Extensions for C++
public: PDFCodabarBarcode(
   string* data
)
C++/CLI
public:
PDFCodabarBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodabarBarcode Class
PDFCodabarBarcode Members
Overload List


PDFCodabarBarcode Constructor(String,Double,Double)

PDFCodabarBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodabarBarcode Class > PDFCodabarBarcode Constructor : PDFCodabarBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCodabarBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFCodabarBarcode(data, left, top)
C#
public PDFCodabarBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFCodabarBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFCodabarBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodabarBarcode Class
PDFCodabarBarcode Members
Overload List


PDFCodablockFBarcode Class

PDFCodablockFBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodablockFBarcode Class

Defines a CODABLOCK F barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCodablockFBarcode
   Inherits PDFBidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCodablockFBarcode
C#
public class PDFCodablockFBarcode : PDFBidimensionalBarcode
Managed Extensions for C++
public __gc class PDFCodablockFBarcode : public PDFBidimensionalBarcode
C++/CLI
public ref class PDFCodablockFBarcode : public PDFBidimensionalBarcode

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodablockFBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodablockFBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCodablockFBarcode Class Members

PDFCodablockFBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodablockFBarcode Class

The following tables list the members exposed by PDFCodablockFBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCodablockFBarcode Constructor | Initializes a new PDFCodablockFBarcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a barcode row.
Top

See Also

Reference

PDFCodablockFBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCodablockFBarcode Constructor

PDFCodablockFBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodablockFBarcode Class : PDFCodablockFBarcode Constructor

Initializes a new PDFCodablockFBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCodablockFBarcode()
C#
public PDFCodablockFBarcode()
Managed Extensions for C++
public: PDFCodablockFBarcode();
C++/CLI
public:
PDFCodablockFBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodablockFBarcode Class
PDFCodablockFBarcode Members


PDFCodablockFBarcode Class Properties

PDFCodablockFBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodablockFBarcode Class

For a list of all members of this type, see PDFCodablockFBarcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Columns | Gets or sets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a barcode row.
Top

See Also

Reference

PDFCodablockFBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


Columns Property

Columns Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodablockFBarcode Class : Columns Property

Gets or sets the number of columns in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFCodablockFBarcode
Dim value As Integer

instance.Columns = value

value = instance.Columns
C#
public int Columns {get; set;}
Managed Extensions for C++
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
C++/CLI
public:
property int Columns {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of columns used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 7 or greater than 65.

Remarks

The minimum number of columns in a CODABLOCK F barcode is 7 and the maximum number of columns is 65. This property includes the character subset selector, row indicator and row check columns.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodablockFBarcode Class
PDFCodablockFBarcode Members


Rows Property

Rows Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodablockFBarcode Class : Rows Property

Gets or sets the number of rows in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFCodablockFBarcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
public int Rows {get; set;}
Managed Extensions for C++
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
C++/CLI
public:
property int Rows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2, or greater than 44.

Remarks

The minimum number of rows in a CODABLOCK F barcode is 2 and the maximum number of rows is 44.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodablockFBarcode Class
PDFCodablockFBarcode Members


YDimension Property

YDimension Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCodablockFBarcode Class : YDimension Property

Gets or sets the height of a barcode row.

Syntax

Visual Basic (Declaration)
Public Property YDimension As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCodablockFBarcode
Dim value As Double

instance.YDimension = value

value = instance.YDimension
C#
public double YDimension {get; set;}
Managed Extensions for C++
public: __property double get_YDimension();
public: __property void set_YDimension(
   double value
);
C++/CLI
public:
property double YDimension {
   double get();
   void set (double value);
}

Return Value

A double value specifying the height of a barcode row.

Remarks

The minimum YDimension should be either 8*XDimension or 0.55*Columns+3, whichever is greater. If this property is 0, the row height will be computed automatically.
Depending on the barcode printer resolution and quality of barcode scanner, the YDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower YDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCodablockFBarcode Class
PDFCodablockFBarcode Members


PDFCode11Barcode Class

PDFCode11Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode11Barcode Class

Defines a Code 11 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode11Barcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode11Barcode
C#
public class PDFCode11Barcode : PDFUnidimensionalBarcode
Managed Extensions for C++
public __gc class PDFCode11Barcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFCode11Barcode : public PDFUnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Code 11 barcode: 0 1 2 3 4 5 6 7 8 9 -

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode11Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode11Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode11Barcode Class Members

PDFCode11Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode11Barcode Class

The following tables list the members exposed by PDFCode11Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode11Barcode Constructor | Overloaded. Initializes a new PDFCode11Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode11Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode11Barcode Constructor

PDFCode11Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode11Barcode Class : PDFCode11Barcode Constructor

Initializes a new PDFCode11Barcode object.

Overload List

Overload | Description
PDFCode11Barcode Constructor() | Initializes a new PDFCode11Barcode object.
PDFCode11Barcode Constructor(String) | Initializes a new PDFCode11Barcode object.
PDFCode11Barcode Constructor(String,Double,Double) | Initializes a new PDFCode11Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode11Barcode Class
PDFCode11Barcode Members


PDFCode11Barcode Constructor()

PDFCode11Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode11Barcode Class > PDFCode11Barcode Constructor : PDFCode11Barcode Constructor()

Initializes a new PDFCode11Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode11Barcode()
C#
public PDFCode11Barcode()
Managed Extensions for C++
public: PDFCode11Barcode();
C++/CLI
public:
PDFCode11Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode11Barcode Class
PDFCode11Barcode Members
Overload List


PDFCode11Barcode Constructor(String)

PDFCode11Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode11Barcode Class > PDFCode11Barcode Constructor : PDFCode11Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode11Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode11Barcode(data)
C#
public PDFCode11Barcode(
   string data
)
Managed Extensions for C++
public: PDFCode11Barcode(
   string* data
)
C++/CLI
public:
PDFCode11Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode11Barcode Class
PDFCode11Barcode Members
Overload List


PDFCode11Barcode Constructor(String,Double,Double)

PDFCode11Barcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode11Barcode Class > PDFCode11Barcode Constructor : PDFCode11Barcode Constructor(String,Double,Double)

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode11Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFCode11Barcode(data, left, top)
C#
public PDFCode11Barcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFCode11Barcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFCode11Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode11Barcode Class
PDFCode11Barcode Members
Overload List


PDFCode128ABarcode Class

PDFCode128ABarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128ABarcode Class

Defines a Code 128 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode128ABarcode
   Inherits PDFCode128Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode128ABarcode
C#
public class PDFCode128ABarcode : PDFCode128Barcode
Managed Extensions for C++
public __gc class PDFCode128ABarcode : public PDFCode128Barcode
C++/CLI
public ref class PDFCode128ABarcode : public PDFCode128Barcode

Remarks

This class defines a Code 128 barcode using the A character set. Only the following symbols are allowed in a Code 128 A barcode: NUL (\x00) SOH (\x01) STX (\x02) ETX (\x03) EOT (\x04) ENQ (\x05) ACK (\x06) BEL (\x07) BS (\x08) HT (\x09) LF (\x0A) VT (\x0B) FF (\x0C) CR (\x0D) SO (\x0E) SI (\x0F) DLE (\x10) DC1 (\x11) DC2 (\x12) DC3 (\x13) DC4 (\x14) NAK (\x15) SYN (\x16) ETB (\x17) CAN (\x18) EM (\x19) SUB (\x1A) ESC (\x1B) FS (\x1C) GS (\x1D) RS (\x1E) US (\x1F) SPACE ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _ FNC1 (\xF0) FNC2 (\xF1) FNC3 (\xF2) FNC4 (\xF3) SHIFT (\xF4).

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128ABarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128ABarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode128ABarcode Class Members

PDFCode128ABarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128ABarcode Class

The following tables list the members exposed by PDFCode128ABarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode128ABarcode Constructor | Overloaded. Initializes a new PDFCode128ABarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode128ABarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode128ABarcode Constructor

PDFCode128ABarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128ABarcode Class : PDFCode128ABarcode Constructor

Initializes a new PDFCode128ABarcode object.

Overload List

Overload | Description
PDFCode128ABarcode Constructor() | Initializes a new PDFCode128ABarcode object.
PDFCode128ABarcode Constructor(String) | Initializes a new PDFCode128ABarcode object.
PDFCode128ABarcode Constructor(String,Double,Double) | Initializes a new PDFCode128ABarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128ABarcode Class
PDFCode128ABarcode Members


PDFCode128ABarcode Constructor()

PDFCode128ABarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128ABarcode Class > PDFCode128ABarcode Constructor : PDFCode128ABarcode Constructor()

Initializes a new PDFCode128ABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode128ABarcode()
C#
public PDFCode128ABarcode()
Managed Extensions for C++
public: PDFCode128ABarcode();
C++/CLI
public:
PDFCode128ABarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128ABarcode Class
PDFCode128ABarcode Members
Overload List


PDFCode128ABarcode Constructor(String)

PDFCode128ABarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128ABarcode Class > PDFCode128ABarcode Constructor : PDFCode128ABarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode128ABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode128ABarcode(data)
C#
public PDFCode128ABarcode(
   string data
)
Managed Extensions for C++
public: PDFCode128ABarcode(
   string* data
)
C++/CLI
public:
PDFCode128ABarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128ABarcode Class
PDFCode128ABarcode Members
Overload List


PDFCode128ABarcode Constructor(String,Double,Double)

PDFCode128ABarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128ABarcode Class > PDFCode128ABarcode Constructor : PDFCode128ABarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode128ABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFCode128ABarcode(data, left, top)
C#
public PDFCode128ABarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFCode128ABarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFCode128ABarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128ABarcode Class
PDFCode128ABarcode Members
Overload List


PDFCode128Barcode Class

PDFCode128Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128Barcode Class

Defines the base class for all Code 128 barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode128Barcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode128Barcode
C#
public class PDFCode128Barcode : PDFUnidimensionalBarcode
Managed Extensions for C++
public __gc class PDFCode128Barcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFCode128Barcode : public PDFUnidimensionalBarcode

Remarks

Code 128 allows to encode 102 symbols, grouped in 3 sets of symbols, A, B and C. Each symbol set is represented by its own barcode class: PDFCode128ABarcode, PDFCode128BBarcode and PDFCode128CBarcode.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128BBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128ABarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode128Barcode Class Members

PDFCode128Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128Barcode Class

The following tables list the members exposed by PDFCode128Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode128Barcode Constructor | Overloaded. Initializes a new PDFCode128Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode128Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode128Barcode Constructor

PDFCode128Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128Barcode Class : PDFCode128Barcode Constructor

Initializes a new PDFCode128Barcode object.

Overload List

Overload | Description
PDFCode128Barcode Constructor() | Initializes a new PDFCode128Barcode object.
PDFCode128Barcode Constructor(String) | Initializes a new PDFCode128Barcode object.
PDFCode128Barcode Constructor(String,Double,Double) | Initializes a new PDFCode128Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128Barcode Class
PDFCode128Barcode Members


PDFCode128Barcode Constructor()

PDFCode128Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128Barcode Class > PDFCode128Barcode Constructor : PDFCode128Barcode Constructor()

Initializes a new PDFCode128Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode128Barcode()
C#
public PDFCode128Barcode()
Managed Extensions for C++
public: PDFCode128Barcode();
C++/CLI
public:
PDFCode128Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128Barcode Class
PDFCode128Barcode Members
Overload List


PDFCode128Barcode Constructor(String)

PDFCode128Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128Barcode Class > PDFCode128Barcode Constructor : PDFCode128Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode128Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode128Barcode(data)
C#
public PDFCode128Barcode(
   string data
)
Managed Extensions for C++
public: PDFCode128Barcode(
   string* data
)
C++/CLI
public:
PDFCode128Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128Barcode Class
PDFCode128Barcode Members
Overload List


PDFCode128Barcode Constructor(String,Double,Double)

PDFCode128Barcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128Barcode Class > PDFCode128Barcode Constructor : PDFCode128Barcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode128Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFCode128Barcode(data, left, top)
C#
public PDFCode128Barcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFCode128Barcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFCode128Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128Barcode Class
PDFCode128Barcode Members
Overload List


PDFCode128BBarcode Class

PDFCode128BBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128BBarcode Class

Defines a Code 128 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode128BBarcode
   Inherits PDFCode128Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode128BBarcode
C#
public class PDFCode128BBarcode : PDFCode128Barcode
Managed Extensions for C++
public __gc class PDFCode128BBarcode : public PDFCode128Barcode
C++/CLI
public ref class PDFCode128BBarcode : public PDFCode128Barcode

Remarks

This class defines a Code 128 barcode using the B character set. Only the following symbols are allowed in a Code 128 B barcode: SPACE ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z [ \ ]^ _ ` a b c d e f g h i j k l m n o p q r s t u v w x y z { | } ~ DEL (\x7F) FNC1 (\xF0) FNC2 (\xF1) FNC3 (\xF2) FNC4 (\xF3) SHIFT (\xF4).

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128BBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128BBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode128BBarcode Class Members

PDFCode128BBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128BBarcode Class

The following tables list the members exposed by PDFCode128BBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode128BBarcode Constructor | Overloaded. Initializes a new PDFCode128BBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode128BBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode128BBarcode Constructor

PDFCode128BBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128BBarcode Class : PDFCode128BBarcode Constructor

Initializes a new PDFCode128BBarcode object.

Overload List

Overload | Description
PDFCode128BBarcode Constructor() | Initializes a new PDFCode128BBarcode object.
PDFCode128BBarcode Constructor(String) | Initializes a new PDFCode128BBarcode object.
PDFCode128BBarcode Constructor(String,Double,Double) | Initializes a new PDFCode128BBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128BBarcode Class
PDFCode128BBarcode Members


PDFCode128BBarcode Constructor()

PDFCode128BBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128BBarcode Class > PDFCode128BBarcode Constructor : PDFCode128BBarcode Constructor()

Initializes a new PDFCode128BBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode128BBarcode()
C#
public PDFCode128BBarcode()
Managed Extensions for C++
public: PDFCode128BBarcode();
C++/CLI
public:
PDFCode128BBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128BBarcode Class
PDFCode128BBarcode Members
Overload List


PDFCode128BBarcode Constructor(String)

PDFCode128BBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128BBarcode Class > PDFCode128BBarcode Constructor : PDFCode128BBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode128BBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode128BBarcode(data)
C#
public PDFCode128BBarcode(
   string data
)
Managed Extensions for C++
public: PDFCode128BBarcode(
   string* data
)
C++/CLI
public:
PDFCode128BBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128BBarcode Class
PDFCode128BBarcode Members
Overload List


PDFCode128BBarcode Constructor(String,Double,Double)

PDFCode128BBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128BBarcode Class > PDFCode128BBarcode Constructor : PDFCode128BBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode128BBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFCode128BBarcode(data, left, top)
C#
public PDFCode128BBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFCode128BBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFCode128BBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128BBarcode Class
PDFCode128BBarcode Members
Overload List


PDFCode128CBarcode Class

PDFCode128CBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128CBarcode Class

Defines a Code 128 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode128CBarcode
   Inherits PDFCode128Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode128CBarcode
C#
public class PDFCode128CBarcode : PDFCode128Barcode
Managed Extensions for C++
public __gc class PDFCode128CBarcode : public PDFCode128Barcode
C++/CLI
public ref class PDFCode128CBarcode : public PDFCode128Barcode

Remarks

This class defines a Code 128 barcode using the C character set. Only the following symbols are allowed in a Code 128 C barcode: 0 1 2 3 4 5 6 7 8 9 FNC1 (\xF0).
Code 128 C encodes only numeric symbols at double density, each pair of digits is encoded using a single symbol.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSPICBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSSCC18Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSCC14Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFFedExGround96Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128CBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode128CBarcode Class Members

PDFCode128CBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128CBarcode Class

The following tables list the members exposed by PDFCode128CBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode128CBarcode Constructor | Overloaded. Initializes a new PDFCode128CBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode128CBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode128CBarcode Constructor

PDFCode128CBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128CBarcode Class : PDFCode128CBarcode Constructor

Initializes a new PDFCode128CBarcode object.

Overload List

Overload | Description
PDFCode128CBarcode Constructor() | Initializes a new PDFCode128CBarcode object.
PDFCode128CBarcode Constructor(String) | Initializes a new PDFCode128CBarcode object.
PDFCode128CBarcode Constructor(String,Double,Double) | Initializes a new PDFCode128CBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128CBarcode Class
PDFCode128CBarcode Members


PDFCode128CBarcode Constructor()

PDFCode128CBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128CBarcode Class > PDFCode128CBarcode Constructor : PDFCode128CBarcode Constructor()

Initializes a new PDFCode128CBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode128CBarcode()
C#
public PDFCode128CBarcode()
Managed Extensions for C++
public: PDFCode128CBarcode();
C++/CLI
public:
PDFCode128CBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128CBarcode Class
PDFCode128CBarcode Members
Overload List


PDFCode128CBarcode Constructor(String)

PDFCode128CBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128CBarcode Class > PDFCode128CBarcode Constructor : PDFCode128CBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode128CBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode128CBarcode(data)
C#
public PDFCode128CBarcode(
   string data
)
Managed Extensions for C++
public: PDFCode128CBarcode(
   string* data
)
C++/CLI
public:
PDFCode128CBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128CBarcode Class
PDFCode128CBarcode Members
Overload List


PDFCode128CBarcode Constructor(String,Double,Double)

PDFCode128CBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode128CBarcode Class > PDFCode128CBarcode Constructor : PDFCode128CBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode128CBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFCode128CBarcode(data, left, top)
C#
public PDFCode128CBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFCode128CBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFCode128CBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode128CBarcode Class
PDFCode128CBarcode Members
Overload List


PDFCode16KBarcode Class

PDFCode16KBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode16KBarcode Class

Defines a Code 16K barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode16KBarcode
   Inherits PDFBidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode16KBarcode
C#
public class PDFCode16KBarcode : PDFBidimensionalBarcode
Managed Extensions for C++
public __gc class PDFCode16KBarcode : public PDFBidimensionalBarcode
C++/CLI
public ref class PDFCode16KBarcode : public PDFBidimensionalBarcode

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode16KBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode16KBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode16KBarcode Class Members

PDFCode16KBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode16KBarcode Class

The following tables list the members exposed by PDFCode16KBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode16KBarcode Constructor | Initializes a new PDFCode16KBarcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Columns | Gets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a barcode row.
Top

See Also

Reference

PDFCode16KBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode16KBarcode Constructor

PDFCode16KBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode16KBarcode Class : PDFCode16KBarcode Constructor

Initializes a new PDFCode16KBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode16KBarcode()
C#
public PDFCode16KBarcode()
Managed Extensions for C++
public: PDFCode16KBarcode();
C++/CLI
public:
PDFCode16KBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode16KBarcode Class
PDFCode16KBarcode Members


PDFCode16KBarcode Class Properties

PDFCode16KBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode16KBarcode Class

For a list of all members of this type, see PDFCode16KBarcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Columns | Gets the number of columns in this barcode.
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Rows | Gets or sets the number of rows in this barcode.
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a barcode row.
Top

See Also

Reference

PDFCode16KBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


Columns Property

Columns Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode16KBarcode Class : Columns Property

Gets the number of columns in this barcode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFCode16KBarcode
Dim value As Integer

value = instance.Columns
C#
public int Columns {get;}
Managed Extensions for C++
public: __property int get_Columns();
C++/CLI
public:
property int Columns {
   int get();
}

Return Value

An integer value specifying the number of columns used by this barcode.

Remarks

A Code 16K barcode has always 5 columns.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode16KBarcode Class
PDFCode16KBarcode Members


Rows Property

Rows Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode16KBarcode Class : Rows Property

Gets or sets the number of rows in this barcode.

Syntax

Visual Basic (Declaration)
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFCode16KBarcode
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
public int Rows {get; set;}
Managed Extensions for C++
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
C++/CLI
public:
property int Rows {
   int get();
   void set (int value);
}

Return Value

An integer value specifying the number of rows used by this barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the value is less than 2 but not 0, or greater than 16.

Remarks

The minimum number of rows in a Code 16K barcode is 2 and the maximum number of rows is 16. If this property is 0, the number of rows is calculated automatically to accomodate the barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode16KBarcode Class
PDFCode16KBarcode Members


YDimension Property

YDimension Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode16KBarcode Class : YDimension Property

Gets or sets the height of a barcode row.

Syntax

Visual Basic (Declaration)
Public Property YDimension As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCode16KBarcode
Dim value As Double

instance.YDimension = value

value = instance.YDimension
C#
public double YDimension {get; set;}
Managed Extensions for C++
public: __property double get_YDimension();
public: __property void set_YDimension(
   double value
);
C++/CLI
public:
property double YDimension {
   double get();
   void set (double value);
}

Return Value

A double value specifying the height of a barcode row.

Remarks

A minimum YDimension of 8*XDimension is recommended for ease of scanning. If this property is 0, the row height will be computed automatically.
Depending on the barcode printer resolution and quality of barcode scanner, the YDimension can be increased or decreased to make sure the barcode is scanned correctly. A lower YDimension results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode16KBarcode Class
PDFCode16KBarcode Members


PDFCode25Barcode Class

PDFCode25Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25Barcode Class

Defines a Code 2 of 5 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode25Barcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode25Barcode
C#
public class PDFCode25Barcode : PDFUnidimensionalBarcode
Managed Extensions for C++
public __gc class PDFCode25Barcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFCode25Barcode : public PDFUnidimensionalBarcode

Remarks

Code 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Code 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMatrix25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIATA25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCOOP25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode25Barcode Class Members

PDFCode25Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25Barcode Class

The following tables list the members exposed by PDFCode25Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode25Barcode Constructor | Overloaded. Initializes a new PDFCode25Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode25Barcode Constructor

PDFCode25Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class : PDFCode25Barcode Constructor

Initializes a new PDFCode25Barcode object.

Overload List

Overload | Description
PDFCode25Barcode Constructor() | Initializes a new PDFCode25Barcode object.
PDFCode25Barcode Constructor(String) | Initializes a new PDFCode25Barcode object.
PDFCode25Barcode Constructor(String,Double,Double) | Initializes a new PDFCode25Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members


PDFCode25Barcode Constructor()

PDFCode25Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class > PDFCode25Barcode Constructor : PDFCode25Barcode Constructor()

Initializes a new PDFCode25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode25Barcode()
C#
public PDFCode25Barcode()
Managed Extensions for C++
public: PDFCode25Barcode();
C++/CLI
public:
PDFCode25Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members
Overload List


PDFCode25Barcode Constructor(String)

PDFCode25Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class > PDFCode25Barcode Constructor : PDFCode25Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode25Barcode(data)
C#
public PDFCode25Barcode(
   string data
)
Managed Extensions for C++
public: PDFCode25Barcode(
   string* data
)
C++/CLI
public:
PDFCode25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members
Overload List


PDFCode25Barcode Constructor(String,Double,Double)

PDFCode25Barcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class > PDFCode25Barcode Constructor : PDFCode25Barcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFCode25Barcode(data, left, top)
C#
public PDFCode25Barcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFCode25Barcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFCode25Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members
Overload List


PDFCode25Barcode Class Properties

PDFCode25Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25Barcode Class

For a list of all members of this type, see PDFCode25Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


WideToNarrowRatio Property

WideToNarrowRatio Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25Barcode Class : WideToNarrowRatio Property

Gets or sets the ratio between wide bars and narrow bars.

Syntax

Visual Basic (Declaration)
Public Property WideToNarrowRatio As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCode25Barcode
Dim value As Double

instance.WideToNarrowRatio = value

value = instance.WideToNarrowRatio
C#
public double WideToNarrowRatio {get; set;}
Managed Extensions for C++
public: __property double get_WideToNarrowRatio();
public: __property void set_WideToNarrowRatio(
   double value
);
C++/CLI
public:
property double WideToNarrowRatio {
   double get();
   void set (double value);
}

Return Value

A double value specifying the ratio between wide bars and narrow bars.

Remarks

The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25Barcode Class
PDFCode25Barcode Members


PDFCode25InterleavedBarcode Class

PDFCode25InterleavedBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25InterleavedBarcode Class

Defines a Code 2 of 5 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode25InterleavedBarcode
   Inherits PDFCode25Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode25InterleavedBarcode
C#
public class PDFCode25InterleavedBarcode : PDFCode25Barcode
Managed Extensions for C++
public __gc class PDFCode25InterleavedBarcode : public PDFCode25Barcode
C++/CLI
public ref class PDFCode25InterleavedBarcode : public PDFCode25Barcode

Remarks

Code 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Code 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFLeitcodeBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIdentcodeBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25InterleavedBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode25InterleavedBarcode Class Members

PDFCode25InterleavedBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25InterleavedBarcode Class

The following tables list the members exposed by PDFCode25InterleavedBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode25InterleavedBarcode Constructor | Overloaded. Initializes a new PDFCode25InterleavedBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode25InterleavedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode25InterleavedBarcode Constructor

PDFCode25InterleavedBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25InterleavedBarcode Class : PDFCode25InterleavedBarcode Constructor

Initializes a new PDFCode25InterleavedBarcode object.

Overload List

Overload | Description
PDFCode25InterleavedBarcode Constructor() | Initializes a new PDFCode25InterleavedBarcode object.
PDFCode25InterleavedBarcode Constructor(String) | Initializes a new PDFCode25InterleavedBarcode object.
PDFCode25InterleavedBarcode Constructor(String,Double,Double) | Initializes a new PDFCode25InterleavedBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25InterleavedBarcode Class
PDFCode25InterleavedBarcode Members


PDFCode25InterleavedBarcode Constructor()

PDFCode25InterleavedBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25InterleavedBarcode Class > PDFCode25InterleavedBarcode Constructor : PDFCode25InterleavedBarcode Constructor()

Initializes a new PDFCode25InterleavedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode25InterleavedBarcode()
C#
public PDFCode25InterleavedBarcode()
Managed Extensions for C++
public: PDFCode25InterleavedBarcode();
C++/CLI
public:
PDFCode25InterleavedBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25InterleavedBarcode Class
PDFCode25InterleavedBarcode Members
Overload List


PDFCode25InterleavedBarcode Constructor(String)

PDFCode25InterleavedBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25InterleavedBarcode Class > PDFCode25InterleavedBarcode Constructor : PDFCode25InterleavedBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode25InterleavedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode25InterleavedBarcode(data)
C#
public PDFCode25InterleavedBarcode(
   string data
)
Managed Extensions for C++
public: PDFCode25InterleavedBarcode(
   string* data
)
C++/CLI
public:
PDFCode25InterleavedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25InterleavedBarcode Class
PDFCode25InterleavedBarcode Members
Overload List


PDFCode25InterleavedBarcode Constructor(String,Double,Double)

PDFCode25InterleavedBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode25InterleavedBarcode Class > PDFCode25InterleavedBarcode Constructor : PDFCode25InterleavedBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode25InterleavedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFCode25InterleavedBarcode(data, left, top)
C#
public PDFCode25InterleavedBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFCode25InterleavedBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFCode25InterleavedBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode25InterleavedBarcode Class
PDFCode25InterleavedBarcode Members
Overload List


PDFCode32Barcode Class

PDFCode32Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode32Barcode Class

Defines a Code 32 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode32Barcode
   Inherits PDFCode39Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode32Barcode
C#
public class PDFCode32Barcode : PDFCode39Barcode
Managed Extensions for C++
public __gc class PDFCode32Barcode : public PDFCode39Barcode
C++/CLI
public ref class PDFCode32Barcode : public PDFCode39Barcode

Remarks

Only the following symbols are allowed in a Code 32 barcode: 1 2 3 4 5 6 7 8 9 0. The barcode length is 9 digits (8 user defined digits + 1 check digit).
Code 32 barcodes are also known as Italian Pharmacode barcodes.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode32Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode32Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode32Barcode Class Members

PDFCode32Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode32Barcode Class

The following tables list the members exposed by PDFCode32Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode32Barcode Constructor | Overloaded. Initializes a new PDFCode32Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode32Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode32Barcode Constructor

PDFCode32Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode32Barcode Class : PDFCode32Barcode Constructor

Initializes a new PDFCode32Barcode object.

Overload List

Overload | Description
PDFCode32Barcode Constructor() | Initializes a new PDFCode32Barcode object.
PDFCode32Barcode Constructor(String) | Initializes a new PDFCode32Barcode object.
PDFCode32Barcode Constructor(String,Double,Double) | Initializes a new PDFCode32Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode32Barcode Class
PDFCode32Barcode Members


PDFCode32Barcode Constructor()

PDFCode32Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode32Barcode Class > PDFCode32Barcode Constructor : PDFCode32Barcode Constructor()

Initializes a new PDFCode32Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode32Barcode()
C#
public PDFCode32Barcode()
Managed Extensions for C++
public: PDFCode32Barcode();
C++/CLI
public:
PDFCode32Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode32Barcode Class
PDFCode32Barcode Members
Overload List


PDFCode32Barcode Constructor(String)

PDFCode32Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode32Barcode Class > PDFCode32Barcode Constructor : PDFCode32Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode32Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode32Barcode(data)
C#
public PDFCode32Barcode(
   string data
)
Managed Extensions for C++
public: PDFCode32Barcode(
   string* data
)
C++/CLI
public:
PDFCode32Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode32Barcode Class
PDFCode32Barcode Members
Overload List


PDFCode32Barcode Constructor(String,Double,Double)

PDFCode32Barcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode32Barcode Class > PDFCode32Barcode Constructor : PDFCode32Barcode Constructor(String,Double,Double)

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode32Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFCode32Barcode(data, left, top)
C#
public PDFCode32Barcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFCode32Barcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFCode32Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode32Barcode Class
PDFCode32Barcode Members
Overload List


PDFCode39Barcode Class

PDFCode39Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39Barcode Class

Defines a Code 39 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode39Barcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode39Barcode
C#
public class PDFCode39Barcode : PDFUnidimensionalBarcode
Managed Extensions for C++
public __gc class PDFCode39Barcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFCode39Barcode : public PDFUnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Code 39 barcode: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
All alphabetic characters are uppercase. If lowercase characters are required, then a Code 39 Extended barcode must be used.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPZNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39ExtendedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode32Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode39Barcode Class Members

PDFCode39Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39Barcode Class

The following tables list the members exposed by PDFCode39Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode39Barcode Constructor | Overloaded. Initializes a new PDFCode39Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode39Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode39Barcode Constructor

PDFCode39Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class : PDFCode39Barcode Constructor

Initializes a new PDFCode39Barcode object.

Overload List

Overload | Description
PDFCode39Barcode Constructor() | Initializes a new PDFCode39Barcode object.
PDFCode39Barcode Constructor(String) | Initializes a new PDFCode39Barcode object.
PDFCode39Barcode Constructor(String,Double,Double) | Initializes a new PDFCode39Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members


PDFCode39Barcode Constructor()

PDFCode39Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class > PDFCode39Barcode Constructor : PDFCode39Barcode Constructor()

Initializes a new PDFCode39Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode39Barcode()
C#
public PDFCode39Barcode()
Managed Extensions for C++
public: PDFCode39Barcode();
C++/CLI
public:
PDFCode39Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members
Overload List


PDFCode39Barcode Constructor(String)

PDFCode39Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class > PDFCode39Barcode Constructor : PDFCode39Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode39Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode39Barcode(data)
C#
public PDFCode39Barcode(
   string data
)
Managed Extensions for C++
public: PDFCode39Barcode(
   string* data
)
C++/CLI
public:
PDFCode39Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members
Overload List


PDFCode39Barcode Constructor(String,Double,Double)

PDFCode39Barcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class > PDFCode39Barcode Constructor : PDFCode39Barcode Constructor(String,Double,Double)

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode39Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFCode39Barcode(data, left, top)
C#
public PDFCode39Barcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFCode39Barcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFCode39Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members
Overload List


PDFCode39Barcode Class Properties

PDFCode39Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39Barcode Class

For a list of all members of this type, see PDFCode39Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode39Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


WideToNarrowRatio Property

WideToNarrowRatio Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39Barcode Class : WideToNarrowRatio Property

Gets or sets the ratio between wide bars and narrow bars.

Syntax

Visual Basic (Declaration)
Public Property WideToNarrowRatio As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCode39Barcode
Dim value As Double

instance.WideToNarrowRatio = value

value = instance.WideToNarrowRatio
C#
public double WideToNarrowRatio {get; set;}
Managed Extensions for C++
public: __property double get_WideToNarrowRatio();
public: __property void set_WideToNarrowRatio(
   double value
);
C++/CLI
public:
property double WideToNarrowRatio {
   double get();
   void set (double value);
}

Return Value

A double value specifying the ratio between wide bars and narrow bars.

Remarks

The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39Barcode Class
PDFCode39Barcode Members


PDFCode39ExtendedBarcode Class

PDFCode39ExtendedBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39ExtendedBarcode Class

Defines an extended Code 39 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode39ExtendedBarcode
   Inherits PDFCode39Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode39ExtendedBarcode
C#
public class PDFCode39ExtendedBarcode : PDFCode39Barcode
Managed Extensions for C++
public __gc class PDFCode39ExtendedBarcode : public PDFCode39Barcode
C++/CLI
public ref class PDFCode39ExtendedBarcode : public PDFCode39Barcode

Remarks

All 128 ASCII characters can be encoded in an extended Code 39 barcode.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39ExtendedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39ExtendedBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode39ExtendedBarcode Class Members

PDFCode39ExtendedBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39ExtendedBarcode Class

The following tables list the members exposed by PDFCode39ExtendedBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode39ExtendedBarcode Constructor | Overloaded. Initializes a new PDFCode39ExtendedBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode39ExtendedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode39ExtendedBarcode Constructor

PDFCode39ExtendedBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39ExtendedBarcode Class : PDFCode39ExtendedBarcode Constructor

Initializes a new PDFCode39ExtendedBarcode object.

Overload List

Overload | Description
PDFCode39ExtendedBarcode Constructor() | Initializes a new PDFCode39ExtendedBarcode object.
PDFCode39ExtendedBarcode Constructor(String) | Initializes a new PDFCode39ExtendedBarcode object.
PDFCode39ExtendedBarcode Constructor(String,Double,Double) | Initializes a new PDFCode39ExtendedBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39ExtendedBarcode Class
PDFCode39ExtendedBarcode Members


PDFCode39ExtendedBarcode Constructor()

PDFCode39ExtendedBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39ExtendedBarcode Class > PDFCode39ExtendedBarcode Constructor : PDFCode39ExtendedBarcode Constructor()

Initializes a new PDFCode39ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode39ExtendedBarcode()
C#
public PDFCode39ExtendedBarcode()
Managed Extensions for C++
public: PDFCode39ExtendedBarcode();
C++/CLI
public:
PDFCode39ExtendedBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39ExtendedBarcode Class
PDFCode39ExtendedBarcode Members
Overload List


PDFCode39ExtendedBarcode Constructor(String)

PDFCode39ExtendedBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39ExtendedBarcode Class > PDFCode39ExtendedBarcode Constructor : PDFCode39ExtendedBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode39ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode39ExtendedBarcode(data)
C#
public PDFCode39ExtendedBarcode(
   string data
)
Managed Extensions for C++
public: PDFCode39ExtendedBarcode(
   string* data
)
C++/CLI
public:
PDFCode39ExtendedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39ExtendedBarcode Class
PDFCode39ExtendedBarcode Members
Overload List


PDFCode39ExtendedBarcode Constructor(String,Double,Double)

PDFCode39ExtendedBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode39ExtendedBarcode Class > PDFCode39ExtendedBarcode Constructor : PDFCode39ExtendedBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode39ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFCode39ExtendedBarcode(data, left, top)
C#
public PDFCode39ExtendedBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFCode39ExtendedBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFCode39ExtendedBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode39ExtendedBarcode Class
PDFCode39ExtendedBarcode Members
Overload List


PDFCode93Barcode Class

PDFCode93Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93Barcode Class

Defines a Code 93 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode93Barcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode93Barcode
C#
public class PDFCode93Barcode : PDFUnidimensionalBarcode
Managed Extensions for C++
public __gc class PDFCode93Barcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFCode93Barcode : public PDFUnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Code 93 barcode: 1 2 3 4 5 6 7 8 9 0 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z - . $ / + % SPACE.
All alphabetic characters are uppercase. If lowercase characters are required, then a Code 93 Extended barcode must be used.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93ExtendedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode93Barcode Class Members

PDFCode93Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93Barcode Class

The following tables list the members exposed by PDFCode93Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode93Barcode Constructor | Overloaded. Initializes a new PDFCode93Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode93Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode93Barcode Constructor

PDFCode93Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93Barcode Class : PDFCode93Barcode Constructor

Initializes a new PDFCode93Barcode object.

Overload List

Overload | Description
PDFCode93Barcode Constructor() | Initializes a new PDFCode93Barcode object.
PDFCode93Barcode Constructor(String) | Initializes a new PDFCode93Barcode object.
PDFCode93Barcode Constructor(String,Double,Double) | Initializes a new PDFCode93Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93Barcode Class
PDFCode93Barcode Members


PDFCode93Barcode Constructor()

PDFCode93Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93Barcode Class > PDFCode93Barcode Constructor : PDFCode93Barcode Constructor()

Initializes a new PDFCode93Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode93Barcode()
C#
public PDFCode93Barcode()
Managed Extensions for C++
public: PDFCode93Barcode();
C++/CLI
public:
PDFCode93Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93Barcode Class
PDFCode93Barcode Members
Overload List


PDFCode93Barcode Constructor(String)

PDFCode93Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93Barcode Class > PDFCode93Barcode Constructor : PDFCode93Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode93Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode93Barcode(data)
C#
public PDFCode93Barcode(
   string data
)
Managed Extensions for C++
public: PDFCode93Barcode(
   string* data
)
C++/CLI
public:
PDFCode93Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93Barcode Class
PDFCode93Barcode Members
Overload List


PDFCode93Barcode Constructor(String,Double,Double)

PDFCode93Barcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93Barcode Class > PDFCode93Barcode Constructor : PDFCode93Barcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode93Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFCode93Barcode(data, left, top)
C#
public PDFCode93Barcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFCode93Barcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFCode93Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93Barcode Class
PDFCode93Barcode Members
Overload List


PDFCode93ExtendedBarcode Class

PDFCode93ExtendedBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93ExtendedBarcode Class

Defines an extended Code 93 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCode93ExtendedBarcode
   Inherits PDFCode93Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCode93ExtendedBarcode
C#
public class PDFCode93ExtendedBarcode : PDFCode93Barcode
Managed Extensions for C++
public __gc class PDFCode93ExtendedBarcode : public PDFCode93Barcode
C++/CLI
public ref class PDFCode93ExtendedBarcode : public PDFCode93Barcode

Remarks

All 128 ASCII characters can be encoded in an extended Code 93 barcode.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93ExtendedBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93ExtendedBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode93ExtendedBarcode Class Members

PDFCode93ExtendedBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93ExtendedBarcode Class

The following tables list the members exposed by PDFCode93ExtendedBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCode93ExtendedBarcode Constructor | Overloaded. Initializes a new PDFCode93ExtendedBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode93ExtendedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode93ExtendedBarcode Constructor

PDFCode93ExtendedBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93ExtendedBarcode Class : PDFCode93ExtendedBarcode Constructor

Initializes a new PDFCode93ExtendedBarcode object.

Overload List

Overload | Description
PDFCode93ExtendedBarcode Constructor() | Initializes a new PDFCode93ExtendedBarcode object.
PDFCode93ExtendedBarcode Constructor(String) | Initializes a new PDFCode93ExtendedBarcode object.
PDFCode93ExtendedBarcode Constructor(String,Double,Double) | Initializes a new PDFCode93ExtendedBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93ExtendedBarcode Class
PDFCode93ExtendedBarcode Members


PDFCode93ExtendedBarcode Constructor()

PDFCode93ExtendedBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93ExtendedBarcode Class > PDFCode93ExtendedBarcode Constructor : PDFCode93ExtendedBarcode Constructor()

Initializes a new PDFCode93ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCode93ExtendedBarcode()
C#
public PDFCode93ExtendedBarcode()
Managed Extensions for C++
public: PDFCode93ExtendedBarcode();
C++/CLI
public:
PDFCode93ExtendedBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93ExtendedBarcode Class
PDFCode93ExtendedBarcode Members
Overload List


PDFCode93ExtendedBarcode Constructor(String)

PDFCode93ExtendedBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93ExtendedBarcode Class > PDFCode93ExtendedBarcode Constructor : PDFCode93ExtendedBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCode93ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCode93ExtendedBarcode(data)
C#
public PDFCode93ExtendedBarcode(
   string data
)
Managed Extensions for C++
public: PDFCode93ExtendedBarcode(
   string* data
)
C++/CLI
public:
PDFCode93ExtendedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93ExtendedBarcode Class
PDFCode93ExtendedBarcode Members
Overload List


PDFCode93ExtendedBarcode Constructor(String,Double,Double)

PDFCode93ExtendedBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCode93ExtendedBarcode Class > PDFCode93ExtendedBarcode Constructor : PDFCode93ExtendedBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCode93ExtendedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFCode93ExtendedBarcode(data, left, top)
C#
public PDFCode93ExtendedBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFCode93ExtendedBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFCode93ExtendedBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCode93ExtendedBarcode Class
PDFCode93ExtendedBarcode Members
Overload List


PDFCOOP25Barcode Class

PDFCOOP25Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCOOP25Barcode Class

Defines a COOP 2 of 5 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCOOP25Barcode
   Inherits PDFCode25Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFCOOP25Barcode
C#
public class PDFCOOP25Barcode : PDFCode25Barcode
Managed Extensions for C++
public __gc class PDFCOOP25Barcode : public PDFCode25Barcode
C++/CLI
public ref class PDFCOOP25Barcode : public PDFCode25Barcode

Remarks

COOP 2 of 5 is a numeric symbology. Only the following symbols are allowed in a COOP 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCOOP25Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCOOP25Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCOOP25Barcode Class Members

PDFCOOP25Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCOOP25Barcode Class

The following tables list the members exposed by PDFCOOP25Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFCOOP25Barcode Constructor | Overloaded. Initializes a new PDFCOOP25Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCOOP25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCOOP25Barcode Constructor

PDFCOOP25Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCOOP25Barcode Class : PDFCOOP25Barcode Constructor

Initializes a new PDFCOOP25Barcode object.

Overload List

Overload | Description
PDFCOOP25Barcode Constructor() | Initializes a new PDFCOOP25Barcode object.
PDFCOOP25Barcode Constructor(String) | Initializes a new PDFCOOP25Barcode object.
PDFCOOP25Barcode Constructor(String,Double,Double) | Initializes a new PDFCOOP25Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCOOP25Barcode Class
PDFCOOP25Barcode Members


PDFCOOP25Barcode Constructor()

PDFCOOP25Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCOOP25Barcode Class > PDFCOOP25Barcode Constructor : PDFCOOP25Barcode Constructor()

Initializes a new PDFCOOP25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCOOP25Barcode()
C#
public PDFCOOP25Barcode()
Managed Extensions for C++
public: PDFCOOP25Barcode();
C++/CLI
public:
PDFCOOP25Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCOOP25Barcode Class
PDFCOOP25Barcode Members
Overload List


PDFCOOP25Barcode Constructor(String)

PDFCOOP25Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCOOP25Barcode Class > PDFCOOP25Barcode Constructor : PDFCOOP25Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFCOOP25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFCOOP25Barcode(data)
C#
public PDFCOOP25Barcode(
   string data
)
Managed Extensions for C++
public: PDFCOOP25Barcode(
   string* data
)
C++/CLI
public:
PDFCOOP25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCOOP25Barcode Class
PDFCOOP25Barcode Members
Overload List


PDFCOOP25Barcode Constructor(String,Double,Double)

PDFCOOP25Barcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFCOOP25Barcode Class > PDFCOOP25Barcode Constructor : PDFCOOP25Barcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFCOOP25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFCOOP25Barcode(data, left, top)
C#
public PDFCOOP25Barcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFCOOP25Barcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFCOOP25Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCOOP25Barcode Class
PDFCOOP25Barcode Members
Overload List


PDFDataMatrixBarcode Class

PDFDataMatrixBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFDataMatrixBarcode Class

Defines a DataMatrix barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFDataMatrixBarcode
   Inherits PDFBidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFDataMatrixBarcode
C#
public class PDFDataMatrixBarcode : PDFBidimensionalBarcode
Managed Extensions for C++
public __gc class PDFDataMatrixBarcode : public PDFBidimensionalBarcode
C++/CLI
public ref class PDFDataMatrixBarcode : public PDFBidimensionalBarcode

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFDataMatrixBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDataMatrixBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFDataMatrixBarcode Class Members

PDFDataMatrixBarcode Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFDataMatrixBarcode Class

The following tables list the members exposed by PDFDataMatrixBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFDataMatrixBarcode Constructor | Initializes a new PDFDataMatrixBarcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Encoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | SymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

Public Methods

 | Name | Description
Public Method | Randomize253State | Applies the 253-state randomizing algorithm on padding values.
Top

See Also

Reference

PDFDataMatrixBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFDataMatrixBarcode Constructor

PDFDataMatrixBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFDataMatrixBarcode Class : PDFDataMatrixBarcode Constructor

Initializes a new PDFDataMatrixBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDataMatrixBarcode()
C#
public PDFDataMatrixBarcode()
Managed Extensions for C++
public: PDFDataMatrixBarcode();
C++/CLI
public:
PDFDataMatrixBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDataMatrixBarcode Class
PDFDataMatrixBarcode Members


PDFDataMatrixBarcode Class Methods

PDFDataMatrixBarcode Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFDataMatrixBarcode Class

For a list of all members of this type, see PDFDataMatrixBarcode members.

Public Methods

 | Name | Description
Public Method | Randomize253State | Applies the 253-state randomizing algorithm on padding values.
Top

See Also

Reference

PDFDataMatrixBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


Randomize253State Method

Randomize253State Method
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFDataMatrixBarcode Class : Randomize253State Method

padCodeword
The padding codeword, usually 129.
position
The position of the padding codeword (0 based index).
Applies the 253-state randomizing algorithm on padding values.

Syntax

Visual Basic (Declaration)
Public Function Randomize253State( _
   ByVal padCodeword As Integer, _
   ByVal position As Integer _
) As Byte
Visual Basic (Usage) Copy Code
Dim instance As PDFDataMatrixBarcode
Dim padCodeword As Integer
Dim position As Integer
Dim value As Byte

value = instance.Randomize253State(padCodeword, position)
C#
public byte Randomize253State(
   int padCodeword,
   int position
)
Managed Extensions for C++
public: byte Randomize253State(
   int padCodeword,
   int position
)
C++/CLI
public:
byte Randomize253State(
   int padCodeword,
   int position
)

Parameters

padCodeword
The padding codeword, usually 129.
position
The position of the padding codeword (0 based index).

Return Value

The randomized value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDataMatrixBarcode Class
PDFDataMatrixBarcode Members


PDFDataMatrixBarcode Class Properties

PDFDataMatrixBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFDataMatrixBarcode Class

For a list of all members of this type, see PDFDataMatrixBarcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Encoding | Gets or sets the encoding of this DataMatrix barcode.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | SymbolSize | Gets or sets the symbol size of this DataMatrix barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFDataMatrixBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


Encoding Property

Encoding Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFDataMatrixBarcode Class : Encoding Property

Gets or sets the encoding of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property Encoding As DataMatrixEncoding
Visual Basic (Usage) Copy Code
Dim instance As PDFDataMatrixBarcode
Dim value As DataMatrixEncoding

instance.Encoding = value

value = instance.Encoding
C#
public DataMatrixEncoding Encoding {get; set;}
Managed Extensions for C++
public: __property DataMatrixEncoding get_Encoding();
public: __property void set_Encoding(
   DataMatrixEncoding value
);
C++/CLI
public:
property DataMatrixEncoding Encoding {
   DataMatrixEncoding get();
   void set (DataMatrixEncoding value);
}

Return Value

A DataMatrixEncoding enumeration member specifying the data encoding for this DataMatrix barcode.

Remarks

If the data to encode contains only numbers (ASCII characters from 0x30 to 0x39), then DataMatrixEncoding.Numeric provides the best encoding. If the data to encode contains only base ASCII characters (0x00 to 0x7F), then both DataMatrixEncoding.ASCII and DataMatrixEncoding.Base256 encoding provide the same performance, but if the data to encode contains more than 3 extended ASCII characters (0x80 to 0xFF) then the DataMatrixEncoding.Base256 encoding is the best option.
If the selected encoding is DataMatrixEncoding.Auto, then the library will select the encoding that will generate the smallest encoded data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDataMatrixBarcode Class
PDFDataMatrixBarcode Members


SymbolSize Property

SymbolSize Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFDataMatrixBarcode Class : SymbolSize Property

Gets or sets the symbol size of this DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Property SymbolSize As DataMatrixSymbolSize
Visual Basic (Usage) Copy Code
Dim instance As PDFDataMatrixBarcode
Dim value As DataMatrixSymbolSize

instance.SymbolSize = value

value = instance.SymbolSize
C#
public DataMatrixSymbolSize SymbolSize {get; set;}
Managed Extensions for C++
public: __property DataMatrixSymbolSize get_SymbolSize();
public: __property void set_SymbolSize(
   DataMatrixSymbolSize value
);
C++/CLI
public:
property DataMatrixSymbolSize SymbolSize {
   DataMatrixSymbolSize get();
   void set (DataMatrixSymbolSize value);
}

Return Value

A DataMatrixSymbolSize enumeration member specifying the size of symbol used to represent this DataMatrix barcode.

Remarks

If the SymbolSize is DataMatrixSymbolSize.Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDataMatrixBarcode Class
PDFDataMatrixBarcode Members


PDFEAN128Barcode Class

PDFEAN128Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN128Barcode Class

Defines a EAN 128 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFEAN128Barcode
   Inherits PDFCode128Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFEAN128Barcode
C#
public class PDFEAN128Barcode : PDFCode128Barcode
Managed Extensions for C++
public __gc class PDFEAN128Barcode : public PDFCode128Barcode
C++/CLI
public ref class PDFEAN128Barcode : public PDFCode128Barcode

Remarks

An EAN-128 barcode is a Code 128 barcode that has specific rules for interpreting the encoded data, based on an application identifier.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN128Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN128Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFEAN128Barcode Class Members

PDFEAN128Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN128Barcode Class

The following tables list the members exposed by PDFEAN128Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFEAN128Barcode Constructor | Overloaded. Initializes a new PDFEAN128Barcode object.
Top

Public Properties

 | Name | Description
Public Property | ApplicationIdentifier | Gets or sets the application identifier.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFEAN128Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFEAN128Barcode Constructor

PDFEAN128Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class : PDFEAN128Barcode Constructor

Initializes a new PDFEAN128Barcode object.

Overload List

Overload | Description
PDFEAN128Barcode Constructor() | Initializes a new PDFEAN128Barcode object.
PDFEAN128Barcode Constructor(String) | Initializes a new PDFEAN128Barcode object.
PDFEAN128Barcode Constructor(String,Double,Double) | Initializes a new PDFEAN128Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members


PDFEAN128Barcode Constructor()

PDFEAN128Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class > PDFEAN128Barcode Constructor : PDFEAN128Barcode Constructor()

Initializes a new PDFEAN128Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFEAN128Barcode()
C#
public PDFEAN128Barcode()
Managed Extensions for C++
public: PDFEAN128Barcode();
C++/CLI
public:
PDFEAN128Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members
Overload List


PDFEAN128Barcode Constructor(String)

PDFEAN128Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class > PDFEAN128Barcode Constructor : PDFEAN128Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFEAN128Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFEAN128Barcode(data)
C#
public PDFEAN128Barcode(
   string data
)
Managed Extensions for C++
public: PDFEAN128Barcode(
   string* data
)
C++/CLI
public:
PDFEAN128Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members
Overload List


PDFEAN128Barcode Constructor(String,Double,Double)

PDFEAN128Barcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class > PDFEAN128Barcode Constructor : PDFEAN128Barcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFEAN128Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFEAN128Barcode(data, left, top)
C#
public PDFEAN128Barcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFEAN128Barcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFEAN128Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members
Overload List


PDFEAN128Barcode Class Properties

PDFEAN128Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN128Barcode Class

For a list of all members of this type, see PDFEAN128Barcode members.

Public Properties

 | Name | Description
Public Property | ApplicationIdentifier | Gets or sets the application identifier.
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFEAN128Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


ApplicationIdentifier Property

ApplicationIdentifier Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN128Barcode Class : ApplicationIdentifier Property

Gets or sets the application identifier.

Syntax

Visual Basic (Declaration)
Public Property ApplicationIdentifier As String
Visual Basic (Usage) Copy Code
Dim instance As PDFEAN128Barcode
Dim value As String

instance.ApplicationIdentifier = value

value = instance.ApplicationIdentifier
C#
public string ApplicationIdentifier {get; set;}
Managed Extensions for C++
public: __property string* get_ApplicationIdentifier();
public: __property void set_ApplicationIdentifier(
   string* value
);
C++/CLI
public:
property String^ ApplicationIdentifier {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the application identifier.

Remarks

The application identifier defines how the barcode data should be interpreted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN128Barcode Class
PDFEAN128Barcode Members


PDFEAN13Barcode Class

PDFEAN13Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN13Barcode Class

Defines the class for EAN-13 barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFEAN13Barcode
   Inherits PDFEANBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFEAN13Barcode
C#
public class PDFEAN13Barcode : PDFEANBarcode
Managed Extensions for C++
public __gc class PDFEAN13Barcode : public PDFEANBarcode
C++/CLI
public ref class PDFEAN13Barcode : public PDFEANBarcode

Remarks

EAN-13 symbology is a numeric symbology. Only the following symbols are allowed in an EAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-13 barcode must always have 12 characters length. The 13th character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN13Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN13Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFEAN13Barcode Class Members

PDFEAN13Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN13Barcode Class

The following tables list the members exposed by PDFEAN13Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFEAN13Barcode Constructor | Overloaded. Initializes a new PDFEAN13Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFEAN13Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFEAN13Barcode Constructor

PDFEAN13Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN13Barcode Class : PDFEAN13Barcode Constructor

Initializes a new PDFEAN13Barcode object.

Overload List

Overload | Description
PDFEAN13Barcode Constructor() | Initializes a new PDFEAN13Barcode object.
PDFEAN13Barcode Constructor(String) | Initializes a new PDFEAN13Barcode object.
PDFEAN13Barcode Constructor(String,Double,Double) | Initializes a new PDFEAN13Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN13Barcode Class
PDFEAN13Barcode Members


PDFEAN13Barcode Constructor()

PDFEAN13Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN13Barcode Class > PDFEAN13Barcode Constructor : PDFEAN13Barcode Constructor()

Initializes a new PDFEAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFEAN13Barcode()
C#
public PDFEAN13Barcode()
Managed Extensions for C++
public: PDFEAN13Barcode();
C++/CLI
public:
PDFEAN13Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN13Barcode Class
PDFEAN13Barcode Members
Overload List


PDFEAN13Barcode Constructor(String)

PDFEAN13Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN13Barcode Class > PDFEAN13Barcode Constructor : PDFEAN13Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFEAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFEAN13Barcode(data)
C#
public PDFEAN13Barcode(
   string data
)
Managed Extensions for C++
public: PDFEAN13Barcode(
   string* data
)
C++/CLI
public:
PDFEAN13Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN13Barcode Class
PDFEAN13Barcode Members
Overload List


PDFEAN13Barcode Constructor(String,Double,Double)

PDFEAN13Barcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN13Barcode Class > PDFEAN13Barcode Constructor : PDFEAN13Barcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFEAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFEAN13Barcode(data, left, top)
C#
public PDFEAN13Barcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFEAN13Barcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFEAN13Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN13Barcode Class
PDFEAN13Barcode Members
Overload List


PDFEAN8Barcode Class

PDFEAN8Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN8Barcode Class

Defines the class for EAN-8 barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFEAN8Barcode
   Inherits PDFEANBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFEAN8Barcode
C#
public class PDFEAN8Barcode : PDFEANBarcode
Managed Extensions for C++
public __gc class PDFEAN8Barcode : public PDFEANBarcode
C++/CLI
public ref class PDFEAN8Barcode : public PDFEANBarcode

Remarks

EAN-8 symbology is a numeric symbology. Only the following symbols are allowed in an EAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-8 barcode must always have 7 characters length. The 8th character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN8Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN8Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFEAN8Barcode Class Members

PDFEAN8Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN8Barcode Class

The following tables list the members exposed by PDFEAN8Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFEAN8Barcode Constructor | Overloaded. Initializes a new PDFEAN8Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFEAN8Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFEAN8Barcode Constructor

PDFEAN8Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN8Barcode Class : PDFEAN8Barcode Constructor

Initializes a new PDFEAN8Barcode object.

Overload List

Overload | Description
PDFEAN8Barcode Constructor() | Initializes a new PDFEAN8Barcode object.
PDFEAN8Barcode Constructor(String) | Initializes a new PDFEAN8Barcode object.
PDFEAN8Barcode Constructor(String,Double,Double) | Initializes a new PDFEAN8Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN8Barcode Class
PDFEAN8Barcode Members


PDFEAN8Barcode Constructor()

PDFEAN8Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN8Barcode Class > PDFEAN8Barcode Constructor : PDFEAN8Barcode Constructor()

Initializes a new PDFEAN8Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFEAN8Barcode()
C#
public PDFEAN8Barcode()
Managed Extensions for C++
public: PDFEAN8Barcode();
C++/CLI
public:
PDFEAN8Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN8Barcode Class
PDFEAN8Barcode Members
Overload List


PDFEAN8Barcode Constructor(String)

PDFEAN8Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN8Barcode Class > PDFEAN8Barcode Constructor : PDFEAN8Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFEAN8Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFEAN8Barcode(data)
C#
public PDFEAN8Barcode(
   string data
)
Managed Extensions for C++
public: PDFEAN8Barcode(
   string* data
)
C++/CLI
public:
PDFEAN8Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN8Barcode Class
PDFEAN8Barcode Members
Overload List


PDFEAN8Barcode Constructor(String,Double,Double)

PDFEAN8Barcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEAN8Barcode Class > PDFEAN8Barcode Constructor : PDFEAN8Barcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFEAN8Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFEAN8Barcode(data, left, top)
C#
public PDFEAN8Barcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFEAN8Barcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFEAN8Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEAN8Barcode Class
PDFEAN8Barcode Members
Overload List


PDFEANBarcode Class

PDFEANBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEANBarcode Class

Defines the base class for EAN based barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFEANBarcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFEANBarcode
C#
public abstract class PDFEANBarcode : PDFUnidimensionalBarcode
Managed Extensions for C++
public __gc abstract class PDFEANBarcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFEANBarcode abstract : public PDFUnidimensionalBarcode

Remarks

An EAN based symbology is a numeric symbology. Only the following symbols are allowed in an EAN based barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an EAN-13 barcode must always has 12 characters length. The 13th character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCEBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCABarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFJAN13Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISSNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISMNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISBNBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN8Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEAN13Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEANBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFEANBarcode Class Members

PDFEANBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEANBarcode Class

The following tables list the members exposed by PDFEANBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFEANBarcode Constructor | Overloaded. Initializes a new PDFEANBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data.
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text.
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFEANBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFEANBarcode Constructor

PDFEANBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class : PDFEANBarcode Constructor

Initializes a new PDFEANBarcode object.

Overload List

Overload | Description
PDFEANBarcode Constructor() | Initializes a new PDFEANBarcode object.
PDFEANBarcode Constructor(String) | Initializes a new PDFEANBarcode object.
PDFEANBarcode Constructor(String,Double,Double) | Initializes a new PDFEANBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members


PDFEANBarcode Constructor()

PDFEANBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class > PDFEANBarcode Constructor : PDFEANBarcode Constructor()

Initializes a new PDFEANBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFEANBarcode()
C#
public PDFEANBarcode()
Managed Extensions for C++
public: PDFEANBarcode();
C++/CLI
public:
PDFEANBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members
Overload List


PDFEANBarcode Constructor(String)

PDFEANBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class > PDFEANBarcode Constructor : PDFEANBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFEANBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFEANBarcode(data)
C#
public PDFEANBarcode(
   string data
)
Managed Extensions for C++
public: PDFEANBarcode(
   string* data
)
C++/CLI
public:
PDFEANBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members
Overload List


PDFEANBarcode Constructor(String,Double,Double)

PDFEANBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class > PDFEANBarcode Constructor : PDFEANBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFEANBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFEANBarcode(data, left, top)
C#
public PDFEANBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFEANBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFEANBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members
Overload List


PDFEANBarcode Class Properties

PDFEANBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEANBarcode Class

For a list of all members of this type, see PDFEANBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data.
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text.
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFEANBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


Supplement Property

Supplement Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class : Supplement Property

Gets or sets the supplement for barcode data.

Syntax

Visual Basic (Declaration)
Public Property Supplement As String
Visual Basic (Usage) Copy Code
Dim instance As PDFEANBarcode
Dim value As String

instance.Supplement = value

value = instance.Supplement
C#
public string Supplement {get; set;}
Managed Extensions for C++
public: __property string* get_Supplement();
public: __property void set_Supplement(
   string* value
);
C++/CLI
public:
property String^ Supplement {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying a 2 or 5 digit supplemental barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in supplement data or the supplement does not have the required length (2 or 5 digits).

Remarks

This supplement is optional. If it exists, it can be only 2 or 5 digits.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members


SupplementDisplayLocation Property

SupplementDisplayLocation Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class : SupplementDisplayLocation Property

Gets or sets the location of the supplement text.

Syntax

Visual Basic (Declaration)
Public Property SupplementDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As PDFEANBarcode
Dim value As BarcodeTextLocation

instance.SupplementDisplayLocation = value

value = instance.SupplementDisplayLocation
C#
public BarcodeTextLocation SupplementDisplayLocation {get; set;}
Managed Extensions for C++
public: __property BarcodeTextLocation get_SupplementDisplayLocation();
public: __property void set_SupplementDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation SupplementDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location where the supplement text is displayed.

Remarks

The embedding options are ignored for supplement text. BarcodeTextLocation.AboveEmbedded has the same effect like BarcodeTextLocation.Above, and BarcodeTextLocation.BelowEmbedded has the same effect like BarcodeTextLocation.Below.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members


SupplementYDimension Property

SupplementYDimension Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFEANBarcode Class : SupplementYDimension Property

Gets or sets the height of a bar in the supplement barcode.

Syntax

Visual Basic (Declaration)
Public Property SupplementYDimension As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFEANBarcode
Dim value As Double

instance.SupplementYDimension = value

value = instance.SupplementYDimension
C#
public double SupplementYDimension {get; set;}
Managed Extensions for C++
public: __property double get_SupplementYDimension();
public: __property void set_SupplementYDimension(
   double value
);
C++/CLI
public:
property double SupplementYDimension {
   double get();
   void set (double value);
}

Return Value

A double value specifying the height of a bar in the supplement barcode.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when value is less than or equal to zero.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFEANBarcode Class
PDFEANBarcode Members


PDFFedExGround96Barcode Class

PDFFedExGround96Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFFedExGround96Barcode Class

Defines a FedEx Ground 96 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFedExGround96Barcode
   Inherits PDFCode128CBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFFedExGround96Barcode
C#
public class PDFFedExGround96Barcode : PDFCode128CBarcode
Managed Extensions for C++
public __gc class PDFFedExGround96Barcode : public PDFCode128CBarcode
C++/CLI
public ref class PDFFedExGround96Barcode : public PDFCode128CBarcode

Remarks

This class defines a FedEx Ground 96 barcode. Only the following symbols are allowed in the barcode: 0 1 2 3 4 5 6 7 8 9. The required data length is 21 digits and the first 2 digits are always 96.
The structure of a FedEx Ground 96 barcode is as follows:
1-2 - Application Identifier (96)
3-4 - Two digit “Serial Container Numeric Code” - “11,12,13” identifies the carrier as “FedEx Ground”.
5-7 - Class of Service - Three-digit number used to identify the FedEx Ground class of service.
8-14 - FedEx Ground Shipper ID - Seven-digit unique shipper identification number.
15-21 - Package Number - Seven-digit package serial number.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFFedExGround96Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFedExGround96Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFFedExGround96Barcode Class Members

PDFFedExGround96Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFFedExGround96Barcode Class

The following tables list the members exposed by PDFFedExGround96Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFFedExGround96Barcode Constructor | Overloaded. Initializes a new PDFFedExGround96Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFFedExGround96Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFFedExGround96Barcode Constructor

PDFFedExGround96Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFFedExGround96Barcode Class : PDFFedExGround96Barcode Constructor

Initializes a new PDFFedExGround96Barcode object.

Overload List

Overload | Description
PDFFedExGround96Barcode Constructor() | Initializes a new PDFFedExGround96Barcode object.
PDFFedExGround96Barcode Constructor(String) | Initializes a new PDFFedExGround96Barcode object.
PDFFedExGround96Barcode Constructor(String,Double,Double) | Initializes a new PDFFedExGround96Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFedExGround96Barcode Class
PDFFedExGround96Barcode Members


PDFFedExGround96Barcode Constructor()

PDFFedExGround96Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFFedExGround96Barcode Class > PDFFedExGround96Barcode Constructor : PDFFedExGround96Barcode Constructor()

Initializes a new PDFFedExGround96Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFFedExGround96Barcode()
C#
public PDFFedExGround96Barcode()
Managed Extensions for C++
public: PDFFedExGround96Barcode();
C++/CLI
public:
PDFFedExGround96Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFedExGround96Barcode Class
PDFFedExGround96Barcode Members
Overload List


PDFFedExGround96Barcode Constructor(String)

PDFFedExGround96Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFFedExGround96Barcode Class > PDFFedExGround96Barcode Constructor : PDFFedExGround96Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFFedExGround96Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFFedExGround96Barcode(data)
C#
public PDFFedExGround96Barcode(
   string data
)
Managed Extensions for C++
public: PDFFedExGround96Barcode(
   string* data
)
C++/CLI
public:
PDFFedExGround96Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFedExGround96Barcode Class
PDFFedExGround96Barcode Members
Overload List


PDFFedExGround96Barcode Constructor(String,Double,Double)

PDFFedExGround96Barcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFFedExGround96Barcode Class > PDFFedExGround96Barcode Constructor : PDFFedExGround96Barcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFFedExGround96Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFFedExGround96Barcode(data, left, top)
C#
public PDFFedExGround96Barcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFFedExGround96Barcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFFedExGround96Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFedExGround96Barcode Class
PDFFedExGround96Barcode Members
Overload List


PDFHeightModulatedBarcode Class

PDFHeightModulatedBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFHeightModulatedBarcode Class

Defines the base class for all height modulated barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFHeightModulatedBarcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFHeightModulatedBarcode
C#
public abstract class PDFHeightModulatedBarcode : PDFUnidimensionalBarcode
Managed Extensions for C++
public __gc abstract class PDFHeightModulatedBarcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFHeightModulatedBarcode abstract : public PDFUnidimensionalBarcode

Remarks

Height modulated barcodes encode the information in the height of the bars, not and in the width of the bars and spaces.
Usually height modulated barcodes are used for encoding postal information, such as ZIP/Postal codes or delivery points.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPostNetBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPlanetBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHeightModulatedBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFHeightModulatedBarcode Class Members

PDFHeightModulatedBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFHeightModulatedBarcode Class

The following tables list the members exposed by PDFHeightModulatedBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFHeightModulatedBarcode Constructor | Overloaded. Initializes a new PDFHeightModulatedBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFHeightModulatedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFHeightModulatedBarcode Constructor

PDFHeightModulatedBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFHeightModulatedBarcode Class : PDFHeightModulatedBarcode Constructor

Initializes a new PDFHeightModulatedBarcode object.

Overload List

Overload | Description
PDFHeightModulatedBarcode Constructor() | Initializes a new PDFHeightModulatedBarcode object.
PDFHeightModulatedBarcode Constructor(String) | Initializes a new PDFHeightModulatedBarcode object.
PDFHeightModulatedBarcode Constructor(String,Double,Double) | Initializes a new PDFHeightModulatedBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHeightModulatedBarcode Class
PDFHeightModulatedBarcode Members


PDFHeightModulatedBarcode Constructor()

PDFHeightModulatedBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFHeightModulatedBarcode Class > PDFHeightModulatedBarcode Constructor : PDFHeightModulatedBarcode Constructor()

Initializes a new PDFHeightModulatedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFHeightModulatedBarcode()
C#
public PDFHeightModulatedBarcode()
Managed Extensions for C++
public: PDFHeightModulatedBarcode();
C++/CLI
public:
PDFHeightModulatedBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHeightModulatedBarcode Class
PDFHeightModulatedBarcode Members
Overload List


PDFHeightModulatedBarcode Constructor(String)

PDFHeightModulatedBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFHeightModulatedBarcode Class > PDFHeightModulatedBarcode Constructor : PDFHeightModulatedBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFHeightModulatedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFHeightModulatedBarcode(data)
C#
public PDFHeightModulatedBarcode(
   string data
)
Managed Extensions for C++
public: PDFHeightModulatedBarcode(
   string* data
)
C++/CLI
public:
PDFHeightModulatedBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHeightModulatedBarcode Class
PDFHeightModulatedBarcode Members
Overload List


PDFHeightModulatedBarcode Constructor(String,Double,Double)

PDFHeightModulatedBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFHeightModulatedBarcode Class > PDFHeightModulatedBarcode Constructor : PDFHeightModulatedBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFHeightModulatedBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFHeightModulatedBarcode(data, left, top)
C#
public PDFHeightModulatedBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFHeightModulatedBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFHeightModulatedBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFHeightModulatedBarcode Class
PDFHeightModulatedBarcode Members
Overload List


PDFIATA25Barcode Class

PDFIATA25Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIATA25Barcode Class

Defines a IATA 2 of 5 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFIATA25Barcode
   Inherits PDFCode25Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFIATA25Barcode
C#
public class PDFIATA25Barcode : PDFCode25Barcode
Managed Extensions for C++
public __gc class PDFIATA25Barcode : public PDFCode25Barcode
C++/CLI
public ref class PDFIATA25Barcode : public PDFCode25Barcode

Remarks

IATA 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Matrix 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9
IATA (International Air Transport Assosiation) uses this for the management of air cargo.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIATA25Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIATA25Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFIATA25Barcode Class Members

PDFIATA25Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIATA25Barcode Class

The following tables list the members exposed by PDFIATA25Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFIATA25Barcode Constructor | Overloaded. Initializes a new PDFIATA25Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFIATA25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFIATA25Barcode Constructor

PDFIATA25Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIATA25Barcode Class : PDFIATA25Barcode Constructor

Initializes a new PDFIATA25Barcode object.

Overload List

Overload | Description
PDFIATA25Barcode Constructor() | Initializes a new PDFIATA25Barcode object.
PDFIATA25Barcode Constructor(String) | Initializes a new PDFIATA25Barcode object.
PDFIATA25Barcode Constructor(String,Double,Double) | Initializes a new PDFIATA25Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIATA25Barcode Class
PDFIATA25Barcode Members


PDFIATA25Barcode Constructor()

PDFIATA25Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIATA25Barcode Class > PDFIATA25Barcode Constructor : PDFIATA25Barcode Constructor()

Initializes a new PDFIATA25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFIATA25Barcode()
C#
public PDFIATA25Barcode()
Managed Extensions for C++
public: PDFIATA25Barcode();
C++/CLI
public:
PDFIATA25Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIATA25Barcode Class
PDFIATA25Barcode Members
Overload List


PDFIATA25Barcode Constructor(String)

PDFIATA25Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIATA25Barcode Class > PDFIATA25Barcode Constructor : PDFIATA25Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFIATA25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFIATA25Barcode(data)
C#
public PDFIATA25Barcode(
   string data
)
Managed Extensions for C++
public: PDFIATA25Barcode(
   string* data
)
C++/CLI
public:
PDFIATA25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIATA25Barcode Class
PDFIATA25Barcode Members
Overload List


PDFIATA25Barcode Constructor(String,Double,Double)

PDFIATA25Barcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIATA25Barcode Class > PDFIATA25Barcode Constructor : PDFIATA25Barcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFIATA25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFIATA25Barcode(data, left, top)
C#
public PDFIATA25Barcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFIATA25Barcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFIATA25Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIATA25Barcode Class
PDFIATA25Barcode Members
Overload List


PDFIdentcodeBarcode Class

PDFIdentcodeBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIdentcodeBarcode Class

Defines an Identcode barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFIdentcodeBarcode
   Inherits PDFCode25InterleavedBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFIdentcodeBarcode
C#
public class PDFIdentcodeBarcode : PDFCode25InterleavedBarcode
Managed Extensions for C++
public __gc class PDFIdentcodeBarcode : public PDFCode25InterleavedBarcode
C++/CLI
public ref class PDFIdentcodeBarcode : public PDFCode25InterleavedBarcode

Remarks

The Identcode is a numeric barcode using the digits from 0 to 9 and is used by the Deutsche Post AG (DHL). It has a fixed length of 12 digits (11 user defined digits + 1 check digit).
The structure of Identcode barcode is:
1..2 - Mail center (outgoing)
3..5 - Customer code
6..11 - Delivery number
12 - Check digit (computed automatically)

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFIdentcodeBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIdentcodeBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFIdentcodeBarcode Class Members

PDFIdentcodeBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIdentcodeBarcode Class

The following tables list the members exposed by PDFIdentcodeBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFIdentcodeBarcode Constructor | Overloaded. Initializes a new PDFIdentcodeBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFIdentcodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFIdentcodeBarcode Constructor

PDFIdentcodeBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIdentcodeBarcode Class : PDFIdentcodeBarcode Constructor

Initializes a new PDFIdentcodeBarcode object.

Overload List

Overload | Description
PDFIdentcodeBarcode Constructor() | Initializes a new PDFIdentcodeBarcode object.
PDFIdentcodeBarcode Constructor(String) | Initializes a new PDFIdentcodeBarcode object.
PDFIdentcodeBarcode Constructor(String,Double,Double) | Initializes a new PDFIdentcodeBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIdentcodeBarcode Class
PDFIdentcodeBarcode Members


PDFIdentcodeBarcode Constructor()

PDFIdentcodeBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIdentcodeBarcode Class > PDFIdentcodeBarcode Constructor : PDFIdentcodeBarcode Constructor()

Initializes a new PDFIdentcodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFIdentcodeBarcode()
C#
public PDFIdentcodeBarcode()
Managed Extensions for C++
public: PDFIdentcodeBarcode();
C++/CLI
public:
PDFIdentcodeBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIdentcodeBarcode Class
PDFIdentcodeBarcode Members
Overload List


PDFIdentcodeBarcode Constructor(String)

PDFIdentcodeBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIdentcodeBarcode Class > PDFIdentcodeBarcode Constructor : PDFIdentcodeBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFIdentcodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFIdentcodeBarcode(data)
C#
public PDFIdentcodeBarcode(
   string data
)
Managed Extensions for C++
public: PDFIdentcodeBarcode(
   string* data
)
C++/CLI
public:
PDFIdentcodeBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIdentcodeBarcode Class
PDFIdentcodeBarcode Members
Overload List


PDFIdentcodeBarcode Constructor(String,Double,Double)

PDFIdentcodeBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFIdentcodeBarcode Class > PDFIdentcodeBarcode Constructor : PDFIdentcodeBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFIdentcodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFIdentcodeBarcode(data, left, top)
C#
public PDFIdentcodeBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFIdentcodeBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFIdentcodeBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIdentcodeBarcode Class
PDFIdentcodeBarcode Members
Overload List


PDFISBNBarcode Class

PDFISBNBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISBNBarcode Class

Defines the class for ISBN barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFISBNBarcode
   Inherits PDFEANBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFISBNBarcode
C#
public class PDFISBNBarcode : PDFEANBarcode
Managed Extensions for C++
public __gc class PDFISBNBarcode : public PDFEANBarcode
C++/CLI
public ref class PDFISBNBarcode : public PDFEANBarcode

Remarks

ISBN symbology is a numeric symbology. Only the following symbols are allowed in an ISBN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISBN barcode (International Standard Book Numbering) is in fact an EAN-13 barcode having the 978 number system. The data for an ISBN barcode must always have 9 characters length. The number system is always 978 and the last character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISBNBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISBNBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFISBNBarcode Class Members

PDFISBNBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISBNBarcode Class

The following tables list the members exposed by PDFISBNBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFISBNBarcode Constructor | Overloaded. Initializes a new PDFISBNBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFISBNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFISBNBarcode Constructor

PDFISBNBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISBNBarcode Class : PDFISBNBarcode Constructor

Initializes a new PDFISBNBarcode object.

Overload List

Overload | Description
PDFISBNBarcode Constructor() | Initializes a new PDFISBNBarcode object.
PDFISBNBarcode Constructor(String) | Initializes a new PDFISBNBarcode object.
PDFISBNBarcode Constructor(String,Double,Double) | Initializes a new PDFISBNBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISBNBarcode Class
PDFISBNBarcode Members


PDFISBNBarcode Constructor()

PDFISBNBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISBNBarcode Class > PDFISBNBarcode Constructor : PDFISBNBarcode Constructor()

Initializes a new PDFISBNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFISBNBarcode()
C#
public PDFISBNBarcode()
Managed Extensions for C++
public: PDFISBNBarcode();
C++/CLI
public:
PDFISBNBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISBNBarcode Class
PDFISBNBarcode Members
Overload List


PDFISBNBarcode Constructor(String)

PDFISBNBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISBNBarcode Class > PDFISBNBarcode Constructor : PDFISBNBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFISBNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFISBNBarcode(data)
C#
public PDFISBNBarcode(
   string data
)
Managed Extensions for C++
public: PDFISBNBarcode(
   string* data
)
C++/CLI
public:
PDFISBNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISBNBarcode Class
PDFISBNBarcode Members
Overload List


PDFISBNBarcode Constructor(String,Double,Double)

PDFISBNBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISBNBarcode Class > PDFISBNBarcode Constructor : PDFISBNBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFISBNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFISBNBarcode(data, left, top)
C#
public PDFISBNBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFISBNBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFISBNBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISBNBarcode Class
PDFISBNBarcode Members
Overload List


PDFISMNBarcode Class

PDFISMNBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISMNBarcode Class

Defines the class for ISMN barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFISMNBarcode
   Inherits PDFEANBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFISMNBarcode
C#
public class PDFISMNBarcode : PDFEANBarcode
Managed Extensions for C++
public __gc class PDFISMNBarcode : public PDFEANBarcode
C++/CLI
public ref class PDFISMNBarcode : public PDFEANBarcode

Remarks

ISMN symbology is a numeric symbology. Only the following symbols are allowed in an ISMN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISMN barcode (International Standard Music Number) is in fact an EAN-13 barcode having the 979 number system. The data for an ISMN barcode must always have 9 characters length. The number system is always 979 and the last character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISMNBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISMNBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFISMNBarcode Class Members

PDFISMNBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISMNBarcode Class

The following tables list the members exposed by PDFISMNBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFISMNBarcode Constructor | Overloaded. Initializes a new PDFISMNBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFISMNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFISMNBarcode Constructor

PDFISMNBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISMNBarcode Class : PDFISMNBarcode Constructor

Initializes a new PDFISMNBarcode object.

Overload List

Overload | Description
PDFISMNBarcode Constructor() | Initializes a new PDFISMNBarcode object.
PDFISMNBarcode Constructor(String) | Initializes a new PDFISMNBarcode object.
PDFISMNBarcode Constructor(String,Double,Double) | Initializes a new PDFISMNBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISMNBarcode Class
PDFISMNBarcode Members


PDFISMNBarcode Constructor()

PDFISMNBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISMNBarcode Class > PDFISMNBarcode Constructor : PDFISMNBarcode Constructor()

Initializes a new PDFISMNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFISMNBarcode()
C#
public PDFISMNBarcode()
Managed Extensions for C++
public: PDFISMNBarcode();
C++/CLI
public:
PDFISMNBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISMNBarcode Class
PDFISMNBarcode Members
Overload List


PDFISMNBarcode Constructor(String)

PDFISMNBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISMNBarcode Class > PDFISMNBarcode Constructor : PDFISMNBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFISMNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFISMNBarcode(data)
C#
public PDFISMNBarcode(
   string data
)
Managed Extensions for C++
public: PDFISMNBarcode(
   string* data
)
C++/CLI
public:
PDFISMNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISMNBarcode Class
PDFISMNBarcode Members
Overload List


PDFISMNBarcode Constructor(String,Double,Double)

PDFISMNBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISMNBarcode Class > PDFISMNBarcode Constructor : PDFISMNBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFISMNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFISMNBarcode(data, left, top)
C#
public PDFISMNBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFISMNBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFISMNBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISMNBarcode Class
PDFISMNBarcode Members
Overload List


PDFISSNBarcode Class

PDFISSNBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISSNBarcode Class

Defines the class for ISSN barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFISSNBarcode
   Inherits PDFEANBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFISSNBarcode
C#
public class PDFISSNBarcode : PDFEANBarcode
Managed Extensions for C++
public __gc class PDFISSNBarcode : public PDFEANBarcode
C++/CLI
public ref class PDFISSNBarcode : public PDFEANBarcode

Remarks

ISSN symbology is a numeric symbology. Only the following symbols are allowed in an ISSN barcode: 0 1 2 3 4 5 6 7 8 9
. An ISSN barcode (International Standard Serial Number for Periodicals) is in fact an EAN-13 barcode having the 977 number system. The data for an ISSN barcode must always have 9 characters length. The number system is always 977 and the last character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFISSNBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISSNBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFISSNBarcode Class Members

PDFISSNBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISSNBarcode Class

The following tables list the members exposed by PDFISSNBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFISSNBarcode Constructor | Overloaded. Initializes a new PDFISSNBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFISSNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFISSNBarcode Constructor

PDFISSNBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISSNBarcode Class : PDFISSNBarcode Constructor

Initializes a new PDFISSNBarcode object.

Overload List

Overload | Description
PDFISSNBarcode Constructor() | Initializes a new PDFISSNBarcode object.
PDFISSNBarcode Constructor(String) | Initializes a new PDFISSNBarcode object.
PDFISSNBarcode Constructor(String,Double,Double) | Initializes a new PDFISSNBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISSNBarcode Class
PDFISSNBarcode Members


PDFISSNBarcode Constructor()

PDFISSNBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISSNBarcode Class > PDFISSNBarcode Constructor : PDFISSNBarcode Constructor()

Initializes a new PDFISSNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFISSNBarcode()
C#
public PDFISSNBarcode()
Managed Extensions for C++
public: PDFISSNBarcode();
C++/CLI
public:
PDFISSNBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISSNBarcode Class
PDFISSNBarcode Members
Overload List


PDFISSNBarcode Constructor(String)

PDFISSNBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISSNBarcode Class > PDFISSNBarcode Constructor : PDFISSNBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFISSNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFISSNBarcode(data)
C#
public PDFISSNBarcode(
   string data
)
Managed Extensions for C++
public: PDFISSNBarcode(
   string* data
)
C++/CLI
public:
PDFISSNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISSNBarcode Class
PDFISSNBarcode Members
Overload List


PDFISSNBarcode Constructor(String,Double,Double)

PDFISSNBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFISSNBarcode Class > PDFISSNBarcode Constructor : PDFISSNBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFISSNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFISSNBarcode(data, left, top)
C#
public PDFISSNBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFISSNBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFISSNBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFISSNBarcode Class
PDFISSNBarcode Members
Overload List


PDFJAN13Barcode Class

PDFJAN13Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFJAN13Barcode Class

Defines the class for JAN13 barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFJAN13Barcode
   Inherits PDFEANBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFJAN13Barcode
C#
public class PDFJAN13Barcode : PDFEANBarcode
Managed Extensions for C++
public __gc class PDFJAN13Barcode : public PDFEANBarcode
C++/CLI
public ref class PDFJAN13Barcode : public PDFEANBarcode

Remarks

JAN-13 symbology is a numeric symbology. Only the following symbols are allowed in an JAN-13 barcode: 0 1 2 3 4 5 6 7 8 9
. An JAN-13 barcode (Japanese Article Numbering) is in fact an EAN-13 barcode having the 49 number system. The data for an JAN-13 barcode must always have 10 characters length. The number system is always 49 and the last character is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFJAN13Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJAN13Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFJAN13Barcode Class Members

PDFJAN13Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFJAN13Barcode Class

The following tables list the members exposed by PDFJAN13Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFJAN13Barcode Constructor | Overloaded. Initializes a new PDFJAN13Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFJAN13Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFJAN13Barcode Constructor

PDFJAN13Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFJAN13Barcode Class : PDFJAN13Barcode Constructor

Initializes a new PDFJAN13Barcode object.

Overload List

Overload | Description
PDFJAN13Barcode Constructor() | Initializes a new PDFJAN13Barcode object.
PDFJAN13Barcode Constructor(String) | Initializes a new PDFJAN13Barcode object.
PDFJAN13Barcode Constructor(String,Double,Double) | Initializes a new PDFJAN13Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJAN13Barcode Class
PDFJAN13Barcode Members


PDFJAN13Barcode Constructor()

PDFJAN13Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFJAN13Barcode Class > PDFJAN13Barcode Constructor : PDFJAN13Barcode Constructor()

Initializes a new PDFJAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFJAN13Barcode()
C#
public PDFJAN13Barcode()
Managed Extensions for C++
public: PDFJAN13Barcode();
C++/CLI
public:
PDFJAN13Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJAN13Barcode Class
PDFJAN13Barcode Members
Overload List


PDFJAN13Barcode Constructor(String)

PDFJAN13Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFJAN13Barcode Class > PDFJAN13Barcode Constructor : PDFJAN13Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFJAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFJAN13Barcode(data)
C#
public PDFJAN13Barcode(
   string data
)
Managed Extensions for C++
public: PDFJAN13Barcode(
   string* data
)
C++/CLI
public:
PDFJAN13Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJAN13Barcode Class
PDFJAN13Barcode Members
Overload List


PDFJAN13Barcode Constructor(String,Double,Double)

PDFJAN13Barcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFJAN13Barcode Class > PDFJAN13Barcode Constructor : PDFJAN13Barcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFJAN13Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFJAN13Barcode(data, left, top)
C#
public PDFJAN13Barcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFJAN13Barcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFJAN13Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJAN13Barcode Class
PDFJAN13Barcode Members
Overload List


PDFKixBarcode Class

PDFKixBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFKixBarcode Class

Defines a Kix barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFKixBarcode
   Inherits PDFRM4SCCBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFKixBarcode
C#
public class PDFKixBarcode : PDFRM4SCCBarcode
Managed Extensions for C++
public __gc class PDFKixBarcode : public PDFRM4SCCBarcode
C++/CLI
public ref class PDFKixBarcode : public PDFRM4SCCBarcode

Remarks

The Kix barcode, a height-modulated barcode symbology, is used by Royal Dutch Post in automated mail sortation process.
Only the following symbols are allowed in a Kix barcode: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z.
The information is encoded in the height of the barcodes, not in their width.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFKixBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFKixBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFKixBarcode Class Members

PDFKixBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFKixBarcode Class

The following tables list the members exposed by PDFKixBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFKixBarcode Constructor | Overloaded. Initializes a new PDFKixBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFKixBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFKixBarcode Constructor

PDFKixBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFKixBarcode Class : PDFKixBarcode Constructor

Initializes a new PDFKixBarcode object.

Overload List

Overload | Description
PDFKixBarcode Constructor() | Initializes a new PDFKixBarcode object.
PDFKixBarcode Constructor(String) | Initializes a new PDFKixBarcode object.
PDFKixBarcode Constructor(String,Double,Double) | Initializes a new PDFKixBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFKixBarcode Class
PDFKixBarcode Members


PDFKixBarcode Constructor()

PDFKixBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFKixBarcode Class > PDFKixBarcode Constructor : PDFKixBarcode Constructor()

Initializes a new PDFKixBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFKixBarcode()
C#
public PDFKixBarcode()
Managed Extensions for C++
public: PDFKixBarcode();
C++/CLI
public:
PDFKixBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFKixBarcode Class
PDFKixBarcode Members
Overload List


PDFKixBarcode Constructor(String)

PDFKixBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFKixBarcode Class > PDFKixBarcode Constructor : PDFKixBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFKixBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFKixBarcode(data)
C#
public PDFKixBarcode(
   string data
)
Managed Extensions for C++
public: PDFKixBarcode(
   string* data
)
C++/CLI
public:
PDFKixBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFKixBarcode Class
PDFKixBarcode Members
Overload List


PDFKixBarcode Constructor(String,Double,Double)

PDFKixBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFKixBarcode Class > PDFKixBarcode Constructor : PDFKixBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFKixBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFKixBarcode(data, left, top)
C#
public PDFKixBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFKixBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFKixBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFKixBarcode Class
PDFKixBarcode Members
Overload List


PDFLeitcodeBarcode Class

PDFLeitcodeBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFLeitcodeBarcode Class

Defines a Leitcode barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFLeitcodeBarcode
   Inherits PDFCode25InterleavedBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFLeitcodeBarcode
C#
public class PDFLeitcodeBarcode : PDFCode25InterleavedBarcode
Managed Extensions for C++
public __gc class PDFLeitcodeBarcode : public PDFCode25InterleavedBarcode
C++/CLI
public ref class PDFLeitcodeBarcode : public PDFCode25InterleavedBarcode

Remarks

The Leitcode is a numeric barcode using the digits from 0 to 9 and is used by the Deutsche Post AG (DHL). It has a fixed length of 14 digits (13 user defined digits + 1 check digit).
The structure of Leitcode barcode is:
1..5 - ZIP code
6..8 - Street's code number
9..11 - House number
12..13 - Product code
14 - Check Digit

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25InterleavedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFLeitcodeBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLeitcodeBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFLeitcodeBarcode Class Members

PDFLeitcodeBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFLeitcodeBarcode Class

The following tables list the members exposed by PDFLeitcodeBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFLeitcodeBarcode Constructor | Overloaded. Initializes a new PDFLeitcodeBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFLeitcodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFLeitcodeBarcode Constructor

PDFLeitcodeBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFLeitcodeBarcode Class : PDFLeitcodeBarcode Constructor

Initializes a new PDFLeitcodeBarcode object.

Overload List

Overload | Description
PDFLeitcodeBarcode Constructor() | Initializes a new PDFLeitcodeBarcode object.
PDFLeitcodeBarcode Constructor(String) | Initializes a new PDFLeitcodeBarcode object.
PDFLeitcodeBarcode Constructor(String,Double,Double) | Initializes a new PDFLeitcodeBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLeitcodeBarcode Class
PDFLeitcodeBarcode Members


PDFLeitcodeBarcode Constructor()

PDFLeitcodeBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFLeitcodeBarcode Class > PDFLeitcodeBarcode Constructor : PDFLeitcodeBarcode Constructor()

Initializes a new PDFLeitcodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFLeitcodeBarcode()
C#
public PDFLeitcodeBarcode()
Managed Extensions for C++
public: PDFLeitcodeBarcode();
C++/CLI
public:
PDFLeitcodeBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLeitcodeBarcode Class
PDFLeitcodeBarcode Members
Overload List


PDFLeitcodeBarcode Constructor(String)

PDFLeitcodeBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFLeitcodeBarcode Class > PDFLeitcodeBarcode Constructor : PDFLeitcodeBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFLeitcodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFLeitcodeBarcode(data)
C#
public PDFLeitcodeBarcode(
   string data
)
Managed Extensions for C++
public: PDFLeitcodeBarcode(
   string* data
)
C++/CLI
public:
PDFLeitcodeBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLeitcodeBarcode Class
PDFLeitcodeBarcode Members
Overload List


PDFLeitcodeBarcode Constructor(String,Double,Double)

PDFLeitcodeBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFLeitcodeBarcode Class > PDFLeitcodeBarcode Constructor : PDFLeitcodeBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFLeitcodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFLeitcodeBarcode(data, left, top)
C#
public PDFLeitcodeBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFLeitcodeBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFLeitcodeBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLeitcodeBarcode Class
PDFLeitcodeBarcode Members
Overload List


PDFMatrix25Barcode Class

PDFMatrix25Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMatrix25Barcode Class

Defines a Matrix 2 of 5 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFMatrix25Barcode
   Inherits PDFCode25Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFMatrix25Barcode
C#
public class PDFMatrix25Barcode : PDFCode25Barcode
Managed Extensions for C++
public __gc class PDFMatrix25Barcode : public PDFCode25Barcode
C++/CLI
public ref class PDFMatrix25Barcode : public PDFCode25Barcode

Remarks

Matrix 2 of 5 is a numeric symbology. Only the following symbols are allowed in a Matrix 2 of 5 barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMatrix25Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMatrix25Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFMatrix25Barcode Class Members

PDFMatrix25Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMatrix25Barcode Class

The following tables list the members exposed by PDFMatrix25Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFMatrix25Barcode Constructor | Overloaded. Initializes a new PDFMatrix25Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFMatrix25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFMatrix25Barcode Constructor

PDFMatrix25Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMatrix25Barcode Class : PDFMatrix25Barcode Constructor

Initializes a new PDFMatrix25Barcode object.

Overload List

Overload | Description
PDFMatrix25Barcode Constructor() | Initializes a new PDFMatrix25Barcode object.
PDFMatrix25Barcode Constructor(String) | Initializes a new PDFMatrix25Barcode object.
PDFMatrix25Barcode Constructor(String,Double,Double) | Initializes a new PDFMatrix25Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMatrix25Barcode Class
PDFMatrix25Barcode Members


PDFMatrix25Barcode Constructor()

PDFMatrix25Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMatrix25Barcode Class > PDFMatrix25Barcode Constructor : PDFMatrix25Barcode Constructor()

Initializes a new PDFMatrix25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFMatrix25Barcode()
C#
public PDFMatrix25Barcode()
Managed Extensions for C++
public: PDFMatrix25Barcode();
C++/CLI
public:
PDFMatrix25Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMatrix25Barcode Class
PDFMatrix25Barcode Members
Overload List


PDFMatrix25Barcode Constructor(String)

PDFMatrix25Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMatrix25Barcode Class > PDFMatrix25Barcode Constructor : PDFMatrix25Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFMatrix25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFMatrix25Barcode(data)
C#
public PDFMatrix25Barcode(
   string data
)
Managed Extensions for C++
public: PDFMatrix25Barcode(
   string* data
)
C++/CLI
public:
PDFMatrix25Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMatrix25Barcode Class
PDFMatrix25Barcode Members
Overload List


PDFMatrix25Barcode Constructor(String,Double,Double)

PDFMatrix25Barcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMatrix25Barcode Class > PDFMatrix25Barcode Constructor : PDFMatrix25Barcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFMatrix25Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFMatrix25Barcode(data, left, top)
C#
public PDFMatrix25Barcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFMatrix25Barcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFMatrix25Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMatrix25Barcode Class
PDFMatrix25Barcode Members
Overload List


PDFMicroPDF417Barcode Class

PDFMicroPDF417Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMicroPDF417Barcode Class

Defines a Micro PDF 417 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFMicroPDF417Barcode
   Inherits PDFBasePDF417Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFMicroPDF417Barcode
C#
public class PDFMicroPDF417Barcode : PDFBasePDF417Barcode
Managed Extensions for C++
public __gc class PDFMicroPDF417Barcode : public PDFBasePDF417Barcode
C++/CLI
public ref class PDFMicroPDF417Barcode : public PDFBasePDF417Barcode

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBasePDF417Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMicroPDF417Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMicroPDF417Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFMicroPDF417Barcode Class Members

PDFMicroPDF417Barcode Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMicroPDF417Barcode Class

The following tables list the members exposed by PDFMicroPDF417Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFMicroPDF417Barcode Constructor | Initializes a new PDFMicroPDF417Barcode object.
Top

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from PDFBasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from PDFBasePDF417Barcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

Public Methods

 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from PDFBasePDF417Barcode)
Top

See Also

Reference

PDFMicroPDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFMicroPDF417Barcode Constructor

PDFMicroPDF417Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMicroPDF417Barcode Class : PDFMicroPDF417Barcode Constructor

Initializes a new PDFMicroPDF417Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFMicroPDF417Barcode()
C#
public PDFMicroPDF417Barcode()
Managed Extensions for C++
public: PDFMicroPDF417Barcode();
C++/CLI
public:
PDFMicroPDF417Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMicroPDF417Barcode Class
PDFMicroPDF417Barcode Members


PDFMicroPDF417Barcode Class Properties

PDFMicroPDF417Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMicroPDF417Barcode Class

For a list of all members of this type, see PDFMicroPDF417Barcode members.

Public Properties

 | Name | Description
Public Property | AlternateData | Gets or sets the alternate data to encode as a barcode. (Inherited from PDFBidimensionalBarcode)
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | CompactionMode | Gets or sets the data compaction mode for this barcode. (Inherited from PDFBasePDF417Barcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | IsValid | Gets a value indicating whether a valid barcode can be built. (Inherited from PDFBasePDF417Barcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | SymbolSize | Gets or sets the symbol size of this Micro PDF 417 barcode.
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFMicroPDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


SymbolSize Property

SymbolSize Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMicroPDF417Barcode Class : SymbolSize Property

Gets or sets the symbol size of this Micro PDF 417 barcode.

Syntax

Visual Basic (Declaration)
Public Property SymbolSize As MicroPDF417SymbolSize
Visual Basic (Usage) Copy Code
Dim instance As PDFMicroPDF417Barcode
Dim value As MicroPDF417SymbolSize

instance.SymbolSize = value

value = instance.SymbolSize
C#
public MicroPDF417SymbolSize SymbolSize {get; set;}
Managed Extensions for C++
public: __property MicroPDF417SymbolSize get_SymbolSize();
public: __property void set_SymbolSize(
   MicroPDF417SymbolSize value
);
C++/CLI
public:
property MicroPDF417SymbolSize SymbolSize {
   MicroPDF417SymbolSize get();
   void set (MicroPDF417SymbolSize value);
}

Return Value

A MicroPDF417SymbolSize enumeration member specifying the size of symbol used to represent this Micro PDF 417 barcode.

Remarks

If the SymbolSize is MicroPDF417SymbolSize.Auto, then the library will calculate automatically the smallest symbol size that can accomodate the data to encode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMicroPDF417Barcode Class
PDFMicroPDF417Barcode Members


PDFMSIPlesseyBarcode Class

PDFMSIPlesseyBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMSIPlesseyBarcode Class

Defines a MSI/Plessey barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFMSIPlesseyBarcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFMSIPlesseyBarcode
C#
public class PDFMSIPlesseyBarcode : PDFUnidimensionalBarcode
Managed Extensions for C++
public __gc class PDFMSIPlesseyBarcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFMSIPlesseyBarcode : public PDFUnidimensionalBarcode

Remarks

MSI/Plessey is a numeric symbology. Only the following symbols are allowed in a MSI/Plessey barcode: 0 1 2 3 4 5 6 7 8 9

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMSIPlesseyBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMSIPlesseyBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFMSIPlesseyBarcode Class Members

PDFMSIPlesseyBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMSIPlesseyBarcode Class

The following tables list the members exposed by PDFMSIPlesseyBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFMSIPlesseyBarcode Constructor | Overloaded. Initializes a new PDFMSIPlesseyBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFMSIPlesseyBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFMSIPlesseyBarcode Constructor

PDFMSIPlesseyBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMSIPlesseyBarcode Class : PDFMSIPlesseyBarcode Constructor

Initializes a new PDFMSIPlesseyBarcode object.

Overload List

Overload | Description
PDFMSIPlesseyBarcode Constructor() | Initializes a new PDFMSIPlesseyBarcode object.
PDFMSIPlesseyBarcode Constructor(String) | Initializes a new PDFMSIPlesseyBarcode object.
PDFMSIPlesseyBarcode Constructor(String,Double,Double) | Initializes a new PDFMSIPlesseyBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMSIPlesseyBarcode Class
PDFMSIPlesseyBarcode Members


PDFMSIPlesseyBarcode Constructor()

PDFMSIPlesseyBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMSIPlesseyBarcode Class > PDFMSIPlesseyBarcode Constructor : PDFMSIPlesseyBarcode Constructor()

Initializes a new PDFMSIPlesseyBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFMSIPlesseyBarcode()
C#
public PDFMSIPlesseyBarcode()
Managed Extensions for C++
public: PDFMSIPlesseyBarcode();
C++/CLI
public:
PDFMSIPlesseyBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMSIPlesseyBarcode Class
PDFMSIPlesseyBarcode Members
Overload List


PDFMSIPlesseyBarcode Constructor(String)

PDFMSIPlesseyBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMSIPlesseyBarcode Class > PDFMSIPlesseyBarcode Constructor : PDFMSIPlesseyBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFMSIPlesseyBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFMSIPlesseyBarcode(data)
C#
public PDFMSIPlesseyBarcode(
   string data
)
Managed Extensions for C++
public: PDFMSIPlesseyBarcode(
   string* data
)
C++/CLI
public:
PDFMSIPlesseyBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMSIPlesseyBarcode Class
PDFMSIPlesseyBarcode Members
Overload List


PDFMSIPlesseyBarcode Constructor(String,Double,Double)

PDFMSIPlesseyBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFMSIPlesseyBarcode Class > PDFMSIPlesseyBarcode Constructor : PDFMSIPlesseyBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFMSIPlesseyBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFMSIPlesseyBarcode(data, left, top)
C#
public PDFMSIPlesseyBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFMSIPlesseyBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFMSIPlesseyBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMSIPlesseyBarcode Class
PDFMSIPlesseyBarcode Members
Overload List


PDFPharmacodeBarcode Class

PDFPharmacodeBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPharmacodeBarcode Class

Defines a Pharmacode barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPharmacodeBarcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFPharmacodeBarcode
C#
public class PDFPharmacodeBarcode : PDFUnidimensionalBarcode
Managed Extensions for C++
public __gc class PDFPharmacodeBarcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFPharmacodeBarcode : public PDFUnidimensionalBarcode

Remarks

Only the following symbols are allowed in a Pharmacode barcode: 1 2 3 4 5 6 7 8 9 0 and the PDFBarcode.Data property must represent a number between 3 and 131070.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPharmacodeBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPharmacodeBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFPharmacodeBarcode Class Members

PDFPharmacodeBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPharmacodeBarcode Class

The following tables list the members exposed by PDFPharmacodeBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFPharmacodeBarcode Constructor | Overloaded. Initializes a new PDFPharmacodeBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BarSpacing | Gets or sets the space between bars.
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFPharmacodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFPharmacodeBarcode Constructor

PDFPharmacodeBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class : PDFPharmacodeBarcode Constructor

Initializes a new PDFPharmacodeBarcode object.

Overload List

Overload | Description
PDFPharmacodeBarcode Constructor() | Initializes a new PDFPharmacodeBarcode object.
PDFPharmacodeBarcode Constructor(String) | Initializes a new PDFPharmacodeBarcode object.
PDFPharmacodeBarcode Constructor(String,Double,Double) | Initializes a new PDFPharmacodeBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members


PDFPharmacodeBarcode Constructor()

PDFPharmacodeBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class > PDFPharmacodeBarcode Constructor : PDFPharmacodeBarcode Constructor()

Initializes a new PDFPharmacodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPharmacodeBarcode()
C#
public PDFPharmacodeBarcode()
Managed Extensions for C++
public: PDFPharmacodeBarcode();
C++/CLI
public:
PDFPharmacodeBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members
Overload List


PDFPharmacodeBarcode Constructor(String)

PDFPharmacodeBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class > PDFPharmacodeBarcode Constructor : PDFPharmacodeBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFPharmacodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFPharmacodeBarcode(data)
C#
public PDFPharmacodeBarcode(
   string data
)
Managed Extensions for C++
public: PDFPharmacodeBarcode(
   string* data
)
C++/CLI
public:
PDFPharmacodeBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members
Overload List


PDFPharmacodeBarcode Constructor(String,Double,Double)

PDFPharmacodeBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class > PDFPharmacodeBarcode Constructor : PDFPharmacodeBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFPharmacodeBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFPharmacodeBarcode(data, left, top)
C#
public PDFPharmacodeBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFPharmacodeBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFPharmacodeBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members
Overload List


PDFPharmacodeBarcode Class Properties

PDFPharmacodeBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPharmacodeBarcode Class

For a list of all members of this type, see PDFPharmacodeBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BarSpacing | Gets or sets the space between bars.
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars.
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFPharmacodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


BarSpacing Property

BarSpacing Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class : BarSpacing Property

Gets or sets the space between bars.

Syntax

Visual Basic (Declaration)
Public Property BarSpacing As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFPharmacodeBarcode
Dim value As Double

instance.BarSpacing = value

value = instance.BarSpacing
C#
public double BarSpacing {get; set;}
Managed Extensions for C++
public: __property double get_BarSpacing();
public: __property void set_BarSpacing(
   double value
);
C++/CLI
public:
property double BarSpacing {
   double get();
   void set (double value);
}

Return Value

The distance between the bars.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members


WideToNarrowRatio Property

WideToNarrowRatio Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPharmacodeBarcode Class : WideToNarrowRatio Property

Gets or sets the ratio between wide bars and narrow bars.

Syntax

Visual Basic (Declaration)
Public Property WideToNarrowRatio As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFPharmacodeBarcode
Dim value As Double

instance.WideToNarrowRatio = value

value = instance.WideToNarrowRatio
C#
public double WideToNarrowRatio {get; set;}
Managed Extensions for C++
public: __property double get_WideToNarrowRatio();
public: __property void set_WideToNarrowRatio(
   double value
);
C++/CLI
public:
property double WideToNarrowRatio {
   double get();
   void set (double value);
}

Return Value

A double value specifying the ratio between wide bars and narrow bars.

Remarks

The recommended ratio varies between 2.2:1 and 3:1. Depending on the barcode printer resolution and quality of barcode scanner, this ratio can be increased or decreased to make sure the barcode is scanned correctly. A lower ratio results in a higher barcode density and less occupied space, but it requires high resolution printers (laser printer quality) and precise scanners in order to read the barcodes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPharmacodeBarcode Class
PDFPharmacodeBarcode Members


PDFPlanetBarcode Class

PDFPlanetBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPlanetBarcode Class

Defines a Planet barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPlanetBarcode
   Inherits PDFHeightModulatedBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFPlanetBarcode
C#
public class PDFPlanetBarcode : PDFHeightModulatedBarcode
Managed Extensions for C++
public __gc class PDFPlanetBarcode : public PDFHeightModulatedBarcode
C++/CLI
public ref class PDFPlanetBarcode : public PDFHeightModulatedBarcode

Remarks

The Planet barcode was developed by the United States Postal Service (USPS).
Only the following symbols are allowed in a Planet barcode: 0 1 2 3 4 5 6 7 8 9
The information is encoded in the height of the barcodes, not in their width.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPlanetBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPlanetBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFPlanetBarcode Class Members

PDFPlanetBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPlanetBarcode Class

The following tables list the members exposed by PDFPlanetBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFPlanetBarcode Constructor | Overloaded. Initializes a new PDFPlanetBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFPlanetBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFPlanetBarcode Constructor

PDFPlanetBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPlanetBarcode Class : PDFPlanetBarcode Constructor

Initializes a new PDFPlanetBarcode object.

Overload List

Overload | Description
PDFPlanetBarcode Constructor() | Initializes a new PDFPlanetBarcode object.
PDFPlanetBarcode Constructor(String) | Initializes a new PDFPlanetBarcode object.
PDFPlanetBarcode Constructor(String,Double,Double) | Initializes a new PDFPlanetBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPlanetBarcode Class
PDFPlanetBarcode Members


PDFPlanetBarcode Constructor()

PDFPlanetBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPlanetBarcode Class > PDFPlanetBarcode Constructor : PDFPlanetBarcode Constructor()

Initializes a new PDFPlanetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPlanetBarcode()
C#
public PDFPlanetBarcode()
Managed Extensions for C++
public: PDFPlanetBarcode();
C++/CLI
public:
PDFPlanetBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPlanetBarcode Class
PDFPlanetBarcode Members
Overload List


PDFPlanetBarcode Constructor(String)

PDFPlanetBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPlanetBarcode Class > PDFPlanetBarcode Constructor : PDFPlanetBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFPlanetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFPlanetBarcode(data)
C#
public PDFPlanetBarcode(
   string data
)
Managed Extensions for C++
public: PDFPlanetBarcode(
   string* data
)
C++/CLI
public:
PDFPlanetBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPlanetBarcode Class
PDFPlanetBarcode Members
Overload List


PDFPlanetBarcode Constructor(String,Double,Double)

PDFPlanetBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPlanetBarcode Class > PDFPlanetBarcode Constructor : PDFPlanetBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFPlanetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFPlanetBarcode(data, left, top)
C#
public PDFPlanetBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFPlanetBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFPlanetBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPlanetBarcode Class
PDFPlanetBarcode Members
Overload List


PDFPostNetBarcode Class

PDFPostNetBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPostNetBarcode Class

Defines a PostNet barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPostNetBarcode
   Inherits PDFHeightModulatedBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFPostNetBarcode
C#
public class PDFPostNetBarcode : PDFHeightModulatedBarcode
Managed Extensions for C++
public __gc class PDFPostNetBarcode : public PDFHeightModulatedBarcode
C++/CLI
public ref class PDFPostNetBarcode : public PDFHeightModulatedBarcode

Remarks

PostNet was developed by the United States Postal Service (USPS) to allow faster sorting and routing of mail.
Only the following symbols are allowed in a Planet barcode: 0 1 2 3 4 5 6 7 8 9
The information is encoded in the height of the barcodes, not in their width.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPostNetBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPostNetBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFPostNetBarcode Class Members

PDFPostNetBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPostNetBarcode Class

The following tables list the members exposed by PDFPostNetBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFPostNetBarcode Constructor | Overloaded. Initializes a new PDFPostNetBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFPostNetBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFPostNetBarcode Constructor

PDFPostNetBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPostNetBarcode Class : PDFPostNetBarcode Constructor

Initializes a new PDFPostNetBarcode object.

Overload List

Overload | Description
PDFPostNetBarcode Constructor() | Initializes a new PDFPostNetBarcode object.
PDFPostNetBarcode Constructor(String) | Initializes a new PDFPostNetBarcode object.
PDFPostNetBarcode Constructor(String,Double,Double) | Initializes a new PDFPostNetBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPostNetBarcode Class
PDFPostNetBarcode Members


PDFPostNetBarcode Constructor()

PDFPostNetBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPostNetBarcode Class > PDFPostNetBarcode Constructor : PDFPostNetBarcode Constructor()

Initializes a new PDFPostNetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPostNetBarcode()
C#
public PDFPostNetBarcode()
Managed Extensions for C++
public: PDFPostNetBarcode();
C++/CLI
public:
PDFPostNetBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPostNetBarcode Class
PDFPostNetBarcode Members
Overload List


PDFPostNetBarcode Constructor(String)

PDFPostNetBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPostNetBarcode Class > PDFPostNetBarcode Constructor : PDFPostNetBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFPostNetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFPostNetBarcode(data)
C#
public PDFPostNetBarcode(
   string data
)
Managed Extensions for C++
public: PDFPostNetBarcode(
   string* data
)
C++/CLI
public:
PDFPostNetBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPostNetBarcode Class
PDFPostNetBarcode Members
Overload List


PDFPostNetBarcode Constructor(String,Double,Double)

PDFPostNetBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPostNetBarcode Class > PDFPostNetBarcode Constructor : PDFPostNetBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFPostNetBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFPostNetBarcode(data, left, top)
C#
public PDFPostNetBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFPostNetBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFPostNetBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPostNetBarcode Class
PDFPostNetBarcode Members
Overload List


PDFPZNBarcode Class

PDFPZNBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPZNBarcode Class

Defines a PZN barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPZNBarcode
   Inherits PDFCode39Barcode
Visual Basic (Usage) Copy Code
Dim instance As PDFPZNBarcode
C#
public class PDFPZNBarcode : PDFCode39Barcode
Managed Extensions for C++
public __gc class PDFPZNBarcode : public PDFCode39Barcode
C++/CLI
public ref class PDFPZNBarcode : public PDFCode39Barcode

Remarks

The PZN barcode has a fixed length, 6 digits and only the following symbols are allowed: 1 2 3 4 5 6 7 8 9 0.
PZN (Pharma-Zentral-Nummer) barcodes are used in pharmaceutical industry in Germany.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPZNBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPZNBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFPZNBarcode Class Members

PDFPZNBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPZNBarcode Class

The following tables list the members exposed by PDFPZNBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFPZNBarcode Constructor | Overloaded. Initializes a new PDFPZNBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFPZNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFPZNBarcode Constructor

PDFPZNBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPZNBarcode Class : PDFPZNBarcode Constructor

Initializes a new PDFPZNBarcode object.

Overload List

Overload | Description
PDFPZNBarcode Constructor() | Initializes a new PDFPZNBarcode object.
PDFPZNBarcode Constructor(String) | Initializes a new PDFPZNBarcode object.
PDFPZNBarcode Constructor(String,Double,Double) | Initializes a new PDFPZNBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPZNBarcode Class
PDFPZNBarcode Members


PDFPZNBarcode Constructor()

PDFPZNBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPZNBarcode Class > PDFPZNBarcode Constructor : PDFPZNBarcode Constructor()

Initializes a new PDFPZNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPZNBarcode()
C#
public PDFPZNBarcode()
Managed Extensions for C++
public: PDFPZNBarcode();
C++/CLI
public:
PDFPZNBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPZNBarcode Class
PDFPZNBarcode Members
Overload List


PDFPZNBarcode Constructor(String)

PDFPZNBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPZNBarcode Class > PDFPZNBarcode Constructor : PDFPZNBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFPZNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFPZNBarcode(data)
C#
public PDFPZNBarcode(
   string data
)
Managed Extensions for C++
public: PDFPZNBarcode(
   string* data
)
C++/CLI
public:
PDFPZNBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPZNBarcode Class
PDFPZNBarcode Members
Overload List


PDFPZNBarcode Constructor(String,Double,Double)

PDFPZNBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFPZNBarcode Class > PDFPZNBarcode Constructor : PDFPZNBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFPZNBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFPZNBarcode(data, left, top)
C#
public PDFPZNBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFPZNBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFPZNBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
The X coordinate of the top left corner of the barcode rectangle.
top
The Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPZNBarcode Class
PDFPZNBarcode Members
Overload List


PDFRM4SCCBarcode Class

PDFRM4SCCBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFRM4SCCBarcode Class

Defines a RM4SCC barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFRM4SCCBarcode
   Inherits PDFHeightModulatedBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFRM4SCCBarcode
C#
public class PDFRM4SCCBarcode : PDFHeightModulatedBarcode
Managed Extensions for C++
public __gc class PDFRM4SCCBarcode : public PDFHeightModulatedBarcode
C++/CLI
public ref class PDFRM4SCCBarcode : public PDFHeightModulatedBarcode

Remarks

The Royal Mail 4-state Customer Code (RM4SCC) is a height-modulated barcode symbology for use in automated mail sortation process.
Only the following symbols are allowed in a RM4SCC barcode: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z.
The information is encoded in the height of the barcodes, not in their width.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSingaporePostBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFKixBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRM4SCCBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFRM4SCCBarcode Class Members

PDFRM4SCCBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFRM4SCCBarcode Class

The following tables list the members exposed by PDFRM4SCCBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFRM4SCCBarcode Constructor | Overloaded. Initializes a new PDFRM4SCCBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFRM4SCCBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFRM4SCCBarcode Constructor

PDFRM4SCCBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFRM4SCCBarcode Class : PDFRM4SCCBarcode Constructor

Initializes a new PDFRM4SCCBarcode object.

Overload List

Overload | Description
PDFRM4SCCBarcode Constructor() | Initializes a new PDFRM4SCCBarcode object.
PDFRM4SCCBarcode Constructor(String) | Initializes a new PDFRM4SCCBarcode object.
PDFRM4SCCBarcode Constructor(String,Double,Double) | Initializes a new PDFRM4SCCBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRM4SCCBarcode Class
PDFRM4SCCBarcode Members


PDFRM4SCCBarcode Constructor()

PDFRM4SCCBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFRM4SCCBarcode Class > PDFRM4SCCBarcode Constructor : PDFRM4SCCBarcode Constructor()

Initializes a new PDFRM4SCCBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFRM4SCCBarcode()
C#
public PDFRM4SCCBarcode()
Managed Extensions for C++
public: PDFRM4SCCBarcode();
C++/CLI
public:
PDFRM4SCCBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRM4SCCBarcode Class
PDFRM4SCCBarcode Members
Overload List


PDFRM4SCCBarcode Constructor(String)

PDFRM4SCCBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFRM4SCCBarcode Class > PDFRM4SCCBarcode Constructor : PDFRM4SCCBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFRM4SCCBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFRM4SCCBarcode(data)
C#
public PDFRM4SCCBarcode(
   string data
)
Managed Extensions for C++
public: PDFRM4SCCBarcode(
   string* data
)
C++/CLI
public:
PDFRM4SCCBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRM4SCCBarcode Class
PDFRM4SCCBarcode Members
Overload List


PDFRM4SCCBarcode Constructor(String,Double,Double)

PDFRM4SCCBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFRM4SCCBarcode Class > PDFRM4SCCBarcode Constructor : PDFRM4SCCBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFRM4SCCBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFRM4SCCBarcode(data, left, top)
C#
public PDFRM4SCCBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFRM4SCCBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFRM4SCCBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRM4SCCBarcode Class
PDFRM4SCCBarcode Members
Overload List


PDFSCC14Barcode Class

PDFSCC14Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSCC14Barcode Class

Defines a SCC-14 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSCC14Barcode
   Inherits PDFCode128CBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFSCC14Barcode
C#
public class PDFSCC14Barcode : PDFCode128CBarcode
Managed Extensions for C++
public __gc class PDFSCC14Barcode : public PDFCode128CBarcode
C++/CLI
public ref class PDFSCC14Barcode : public PDFCode128CBarcode

Remarks

This class defines a SCC-14 (Shipping Container Code) barcode. Only the following symbols are allowed in a SCC-14 barcode: 0 1 2 3 4 5 6 7 8 9.
A SCC-14 barcode is a special Code 128C barcode using a predefined format with a fixed length. The barcode length is 14 digits. 13 digits are provided by the user, the 14th digit is the check digit and it is calculated automatically by the library.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSCC14Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSCC14Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFSCC14Barcode Class Members

PDFSCC14Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSCC14Barcode Class

The following tables list the members exposed by PDFSCC14Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFSCC14Barcode Constructor | Overloaded. Initializes a new PDFSCC14Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFSCC14Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFSCC14Barcode Constructor

PDFSCC14Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSCC14Barcode Class : PDFSCC14Barcode Constructor

Initializes a new PDFSCC14Barcode object.

Overload List

Overload | Description
PDFSCC14Barcode Constructor() | Initializes a new PDFSCC14Barcode object.
PDFSCC14Barcode Constructor(String) | Initializes a new PDFSCC14Barcode object.
PDFSCC14Barcode Constructor(String,Double,Double) | Initializes a new PDFSCC14Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSCC14Barcode Class
PDFSCC14Barcode Members


PDFSCC14Barcode Constructor()

PDFSCC14Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSCC14Barcode Class > PDFSCC14Barcode Constructor : PDFSCC14Barcode Constructor()

Initializes a new PDFSCC14Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSCC14Barcode()
C#
public PDFSCC14Barcode()
Managed Extensions for C++
public: PDFSCC14Barcode();
C++/CLI
public:
PDFSCC14Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSCC14Barcode Class
PDFSCC14Barcode Members
Overload List


PDFSCC14Barcode Constructor(String)

PDFSCC14Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSCC14Barcode Class > PDFSCC14Barcode Constructor : PDFSCC14Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFSCC14Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFSCC14Barcode(data)
C#
public PDFSCC14Barcode(
   string data
)
Managed Extensions for C++
public: PDFSCC14Barcode(
   string* data
)
C++/CLI
public:
PDFSCC14Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSCC14Barcode Class
PDFSCC14Barcode Members
Overload List


PDFSCC14Barcode Constructor(String,Double,Double)

PDFSCC14Barcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSCC14Barcode Class > PDFSCC14Barcode Constructor : PDFSCC14Barcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFSCC14Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFSCC14Barcode(data, left, top)
C#
public PDFSCC14Barcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFSCC14Barcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFSCC14Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSCC14Barcode Class
PDFSCC14Barcode Members
Overload List


PDFSingaporePostBarcode Class

PDFSingaporePostBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSingaporePostBarcode Class

Defines a Singapore Post barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSingaporePostBarcode
   Inherits PDFRM4SCCBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFSingaporePostBarcode
C#
public class PDFSingaporePostBarcode : PDFRM4SCCBarcode
Managed Extensions for C++
public __gc class PDFSingaporePostBarcode : public PDFRM4SCCBarcode
C++/CLI
public ref class PDFSingaporePostBarcode : public PDFRM4SCCBarcode

Remarks

The Singapore Post barcode is a height-modulated barcode symbology for use in automated mail sortation process.
Only the following symbols are allowed in a Singapore Post barcode: 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z.
The information is encoded in the height of the barcodes, not in their width.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFRM4SCCBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSingaporePostBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSingaporePostBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFSingaporePostBarcode Class Members

PDFSingaporePostBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSingaporePostBarcode Class

The following tables list the members exposed by PDFSingaporePostBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFSingaporePostBarcode Constructor | Overloaded. Initializes a new PDFSingaporePostBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFSingaporePostBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFSingaporePostBarcode Constructor

PDFSingaporePostBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSingaporePostBarcode Class : PDFSingaporePostBarcode Constructor

Initializes a new PDFSingaporePostBarcode object.

Overload List

Overload | Description
PDFSingaporePostBarcode Constructor() | Initializes a new PDFSingaporePostBarcode object.
PDFSingaporePostBarcode Constructor(String) | Initializes a new PDFSingaporePostBarcode object.
PDFSingaporePostBarcode Constructor(String,Double,Double) | Initializes a new PDFSingaporePostBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSingaporePostBarcode Class
PDFSingaporePostBarcode Members


PDFSingaporePostBarcode Constructor()

PDFSingaporePostBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSingaporePostBarcode Class > PDFSingaporePostBarcode Constructor : PDFSingaporePostBarcode Constructor()

Initializes a new PDFSingaporePostBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSingaporePostBarcode()
C#
public PDFSingaporePostBarcode()
Managed Extensions for C++
public: PDFSingaporePostBarcode();
C++/CLI
public:
PDFSingaporePostBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSingaporePostBarcode Class
PDFSingaporePostBarcode Members
Overload List


PDFSingaporePostBarcode Constructor(String)

PDFSingaporePostBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSingaporePostBarcode Class > PDFSingaporePostBarcode Constructor : PDFSingaporePostBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFSingaporePostBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFSingaporePostBarcode(data)
C#
public PDFSingaporePostBarcode(
   string data
)
Managed Extensions for C++
public: PDFSingaporePostBarcode(
   string* data
)
C++/CLI
public:
PDFSingaporePostBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSingaporePostBarcode Class
PDFSingaporePostBarcode Members
Overload List


PDFSingaporePostBarcode Constructor(String,Double,Double)

PDFSingaporePostBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSingaporePostBarcode Class > PDFSingaporePostBarcode Constructor : PDFSingaporePostBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFSingaporePostBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFSingaporePostBarcode(data, left, top)
C#
public PDFSingaporePostBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFSingaporePostBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFSingaporePostBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSingaporePostBarcode Class
PDFSingaporePostBarcode Members
Overload List


PDFSSCC18Barcode Class

PDFSSCC18Barcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSSCC18Barcode Class

Defines a SSCC-18 barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSSCC18Barcode
   Inherits PDFCode128CBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFSSCC18Barcode
C#
public class PDFSSCC18Barcode : PDFCode128CBarcode
Managed Extensions for C++
public __gc class PDFSSCC18Barcode : public PDFCode128CBarcode
C++/CLI
public ref class PDFSSCC18Barcode : public PDFCode128CBarcode

Remarks

This class defines a SSCC-18 (Serial Shipping Container Code) barcode. Only the following symbols are allowed in a SSCC-18 barcode: 0 1 2 3 4 5 6 7 8 9.
A SSCC-18 barcode is a special Code 128C barcode using a predefined format with a fixed length. The barcode length is 18 digits. 17 digits are provided by the user, the 18th digit is the check digit and it is calculated automatically by the library.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFSSCC18Barcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSSCC18Barcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFSSCC18Barcode Class Members

PDFSSCC18Barcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSSCC18Barcode Class

The following tables list the members exposed by PDFSSCC18Barcode.

Public Constructors

 | Name | Description
Public Constructor | PDFSSCC18Barcode Constructor | Overloaded. Initializes a new PDFSSCC18Barcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFSSCC18Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFSSCC18Barcode Constructor

PDFSSCC18Barcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSSCC18Barcode Class : PDFSSCC18Barcode Constructor

Initializes a new PDFSSCC18Barcode object.

Overload List

Overload | Description
PDFSSCC18Barcode Constructor() | Initializes a new PDFSSCC18Barcode object.
PDFSSCC18Barcode Constructor(String) | Initializes a new PDFSSCC18Barcode object.
PDFSSCC18Barcode Constructor(String,Double,Double) | Initializes a new PDFSSCC18Barcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSSCC18Barcode Class
PDFSSCC18Barcode Members


PDFSSCC18Barcode Constructor()

PDFSSCC18Barcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSSCC18Barcode Class > PDFSSCC18Barcode Constructor : PDFSSCC18Barcode Constructor()

Initializes a new PDFSSCC18Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSSCC18Barcode()
C#
public PDFSSCC18Barcode()
Managed Extensions for C++
public: PDFSSCC18Barcode();
C++/CLI
public:
PDFSSCC18Barcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSSCC18Barcode Class
PDFSSCC18Barcode Members
Overload List


PDFSSCC18Barcode Constructor(String)

PDFSSCC18Barcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSSCC18Barcode Class > PDFSSCC18Barcode Constructor : PDFSSCC18Barcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFSSCC18Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFSSCC18Barcode(data)
C#
public PDFSSCC18Barcode(
   string data
)
Managed Extensions for C++
public: PDFSSCC18Barcode(
   string* data
)
C++/CLI
public:
PDFSSCC18Barcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSSCC18Barcode Class
PDFSSCC18Barcode Members
Overload List


PDFSSCC18Barcode Constructor(String,Double,Double)

PDFSSCC18Barcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFSSCC18Barcode Class > PDFSSCC18Barcode Constructor : PDFSSCC18Barcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFSSCC18Barcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFSSCC18Barcode(data, left, top)
C#
public PDFSSCC18Barcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFSSCC18Barcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFSSCC18Barcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSSCC18Barcode Class
PDFSSCC18Barcode Members
Overload List


PDFUnidimensionalBarcode Class

PDFUnidimensionalBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUnidimensionalBarcode Class

Defines the base class for 1D barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFUnidimensionalBarcode
   Inherits PDFBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFUnidimensionalBarcode
C#
public abstract class PDFUnidimensionalBarcode : PDFBarcode
Managed Extensions for C++
public __gc abstract class PDFUnidimensionalBarcode : public PDFBarcode
C++/CLI
public ref class PDFUnidimensionalBarcode abstract : public PDFBarcode

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSHorizontalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSFIMBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFPharmacodeBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFMSIPlesseyBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFHeightModulatedBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode93Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode39Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode25Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode11Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCodabarBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFUnidimensionalBarcode Class Members

PDFUnidimensionalBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUnidimensionalBarcode Class

The following tables list the members exposed by PDFUnidimensionalBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFUnidimensionalBarcode Constructor | Overloaded. Initializes a new PDFUnidimensionalBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form.
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.
Public Property | Font | Gets or sets the font used to display the barcode text.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUnidimensionalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFUnidimensionalBarcode Constructor

PDFUnidimensionalBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : PDFUnidimensionalBarcode Constructor

Initializes a new PDFUnidimensionalBarcode object.

Overload List

Overload | Description
PDFUnidimensionalBarcode Constructor() | Initializes a new PDFUnidimensionalBarcode object.
PDFUnidimensionalBarcode Constructor(String,Double,Double) | Initializes a new PDFBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


PDFUnidimensionalBarcode Constructor()

PDFUnidimensionalBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class > PDFUnidimensionalBarcode Constructor : PDFUnidimensionalBarcode Constructor()

Initializes a new PDFUnidimensionalBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFUnidimensionalBarcode()
C#
public PDFUnidimensionalBarcode()
Managed Extensions for C++
public: PDFUnidimensionalBarcode();
C++/CLI
public:
PDFUnidimensionalBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members
Overload List


PDFUnidimensionalBarcode Constructor(String,Double,Double)

PDFUnidimensionalBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class > PDFUnidimensionalBarcode Constructor : PDFUnidimensionalBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFUnidimensionalBarcode(data, left, top)
C#
public PDFUnidimensionalBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFUnidimensionalBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFUnidimensionalBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length (applies to some barcodes only).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members
Overload List


PDFUnidimensionalBarcode Class Properties

PDFUnidimensionalBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUnidimensionalBarcode Class

For a list of all members of this type, see PDFUnidimensionalBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data.
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form.
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed.
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.
Public Property | Font | Gets or sets the font used to display the barcode text.
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUnidimensionalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


DataDisplayLocation Property

DataDisplayLocation Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : DataDisplayLocation Property

Gets or sets the location of the barcode data.

Syntax

Visual Basic (Declaration)
Public Property DataDisplayLocation As BarcodeTextLocation
Visual Basic (Usage) Copy Code
Dim instance As PDFUnidimensionalBarcode
Dim value As BarcodeTextLocation

instance.DataDisplayLocation = value

value = instance.DataDisplayLocation
C#
public BarcodeTextLocation DataDisplayLocation {get; set;}
Managed Extensions for C++
public: __property BarcodeTextLocation get_DataDisplayLocation();
public: __property void set_DataDisplayLocation(
   BarcodeTextLocation value
);
C++/CLI
public:
property BarcodeTextLocation DataDisplayLocation {
   BarcodeTextLocation get();
   void set (BarcodeTextLocation value);
}

Return Value

A BarcodeTextLocation enumeration member specifying the location where the barcode data is displayed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


DisplayCheckSum Property

DisplayCheckSum Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : DisplayCheckSum Property

Gets or sets whether the check characters should be displayed in human readable form.

Syntax

Visual Basic (Declaration)
Public Property DisplayCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFUnidimensionalBarcode
Dim value As Boolean

instance.DisplayCheckSum = value

value = instance.DisplayCheckSum
C#
public bool DisplayCheckSum {get; set;}
Managed Extensions for C++
public: __property bool get_DisplayCheckSum();
public: __property void set_DisplayCheckSum(
   bool value
);
C++/CLI
public:
property bool DisplayCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if the check characters should be displayed. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


DisplayStartStopSymbols Property

DisplayStartStopSymbols Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : DisplayStartStopSymbols Property

Gets or sets a value indicating whether the start/stop symbols should be displayed.

Syntax

Visual Basic (Declaration)
Public Property DisplayStartStopSymbols As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFUnidimensionalBarcode
Dim value As Boolean

instance.DisplayStartStopSymbols = value

value = instance.DisplayStartStopSymbols
C#
public bool DisplayStartStopSymbols {get; set;}
Managed Extensions for C++
public: __property bool get_DisplayStartStopSymbols();
public: __property void set_DisplayStartStopSymbols(
   bool value
);
C++/CLI
public:
property bool DisplayStartStopSymbols {
   bool get();
   void set (bool value);
}

Return Value

True if the start/stop symbol should be displayed. Default is true.

Remarks

Hiding the start/stop symbols can generate unreadable barcodes in some situations, unless you have specialized barcode readers that are aware of missing start/stop symbols.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


EnableCheckSum Property

EnableCheckSum Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : EnableCheckSum Property

Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode.

Syntax

Visual Basic (Declaration)
Public Property EnableCheckSum As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFUnidimensionalBarcode
Dim value As Boolean

instance.EnableCheckSum = value

value = instance.EnableCheckSum
C#
public bool EnableCheckSum {get; set;}
Managed Extensions for C++
public: __property bool get_EnableCheckSum();
public: __property void set_EnableCheckSum(
   bool value
);
C++/CLI
public:
property bool EnableCheckSum {
   bool get();
   void set (bool value);
}

Return Value

True if a checksum symbol should be appended automatically to the barcode, false otherwise.

Remarks

Not all barcodes support checksum symbols. This property is ignored for those that do not support them.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


Font Property

Font Property
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUnidimensionalBarcode Class : Font Property

Gets or sets the font used to display the barcode text.

Syntax

Visual Basic (Declaration)
Public Property Font As PDFFontBase
Visual Basic (Usage) Copy Code
Dim instance As PDFUnidimensionalBarcode
Dim value As PDFFontBase

instance.Font = value

value = instance.Font
C#
public PDFFontBase Font {get; set;}
Managed Extensions for C++
public: __property PDFFontBase* get_Font();
public: __property void set_Font(
   PDFFontBase* value
);
C++/CLI
public:
property PDFFontBase^ Font {
   PDFFontBase^ get();
   void set (PDFFontBase^ value);
}

Return Value

A PDFFont object used to display the barcode text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUnidimensionalBarcode Class
PDFUnidimensionalBarcode Members


PDFUPCABarcode Class

PDFUPCABarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCABarcode Class

Defines the class for UPC-A barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFUPCABarcode
   Inherits PDFEANBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFUPCABarcode
C#
public class PDFUPCABarcode : PDFEANBarcode
Managed Extensions for C++
public __gc class PDFUPCABarcode : public PDFEANBarcode
C++/CLI
public ref class PDFUPCABarcode : public PDFEANBarcode

Remarks

UPC-A symbology is a numeric symbology. Only the following symbols are allowed in an UPC-A barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an UPC-A barcode must always have 11 characters length. The first digit is the number system, usually 0, and the last digit is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCABarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCABarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFUPCABarcode Class Members

PDFUPCABarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCABarcode Class

The following tables list the members exposed by PDFUPCABarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFUPCABarcode Constructor | Overloaded. Initializes a new PDFUPCABarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUPCABarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFUPCABarcode Constructor

PDFUPCABarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCABarcode Class : PDFUPCABarcode Constructor

Initializes a new PDFUPCABarcode object.

Overload List

Overload | Description
PDFUPCABarcode Constructor() | Initializes a new PDFUPCABarcode object.
PDFUPCABarcode Constructor(String) | Initializes a new PDFUPCABarcode object.
PDFUPCABarcode Constructor(String,Double,Double) | Initializes a new PDFUPCABarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCABarcode Class
PDFUPCABarcode Members


PDFUPCABarcode Constructor()

PDFUPCABarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCABarcode Class > PDFUPCABarcode Constructor : PDFUPCABarcode Constructor()

Initializes a new PDFUPCABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFUPCABarcode()
C#
public PDFUPCABarcode()
Managed Extensions for C++
public: PDFUPCABarcode();
C++/CLI
public:
PDFUPCABarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCABarcode Class
PDFUPCABarcode Members
Overload List


PDFUPCABarcode Constructor(String)

PDFUPCABarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCABarcode Class > PDFUPCABarcode Constructor : PDFUPCABarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFUPCABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFUPCABarcode(data)
C#
public PDFUPCABarcode(
   string data
)
Managed Extensions for C++
public: PDFUPCABarcode(
   string* data
)
C++/CLI
public:
PDFUPCABarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCABarcode Class
PDFUPCABarcode Members
Overload List


PDFUPCABarcode Constructor(String,Double,Double)

PDFUPCABarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCABarcode Class > PDFUPCABarcode Constructor : PDFUPCABarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUPCABarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFUPCABarcode(data, left, top)
C#
public PDFUPCABarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFUPCABarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFUPCABarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCABarcode Class
PDFUPCABarcode Members
Overload List


PDFUPCEBarcode Class

PDFUPCEBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCEBarcode Class

Defines the class for UPC-E barcodes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFUPCEBarcode
   Inherits PDFEANBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFUPCEBarcode
C#
public class PDFUPCEBarcode : PDFEANBarcode
Managed Extensions for C++
public __gc class PDFUPCEBarcode : public PDFEANBarcode
C++/CLI
public ref class PDFUPCEBarcode : public PDFEANBarcode

Remarks

UPC-E symbology is a numeric symbology. Only the following symbols are allowed in an UPC-E barcode: 0 1 2 3 4 5 6 7 8 9
. The data for an UPC-E barcode must always have 7 characters length. The first digit is the number system, usually 0, and the last digit is the check digit and it is computed automatically.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFEANBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUPCEBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCEBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFUPCEBarcode Class Members

PDFUPCEBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCEBarcode Class

The following tables list the members exposed by PDFUPCEBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFUPCEBarcode Constructor | Overloaded. Initializes a new PDFUPCEBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUPCEBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFUPCEBarcode Constructor

PDFUPCEBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCEBarcode Class : PDFUPCEBarcode Constructor

Initializes a new PDFUPCEBarcode object.

Overload List

Overload | Description
PDFUPCEBarcode Constructor() | Initializes a new PDFUPCEBarcode object.
PDFUPCEBarcode Constructor(String) | Initializes a new PDFUPCEBarcode object.
PDFUPCEBarcode Constructor(String,Double,Double) | Initializes a new PDFUPCEBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCEBarcode Class
PDFUPCEBarcode Members


PDFUPCEBarcode Constructor()

PDFUPCEBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCEBarcode Class > PDFUPCEBarcode Constructor : PDFUPCEBarcode Constructor()

Initializes a new PDFUPCEBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFUPCEBarcode()
C#
public PDFUPCEBarcode()
Managed Extensions for C++
public: PDFUPCEBarcode();
C++/CLI
public:
PDFUPCEBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCEBarcode Class
PDFUPCEBarcode Members
Overload List


PDFUPCEBarcode Constructor(String)

PDFUPCEBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCEBarcode Class > PDFUPCEBarcode Constructor : PDFUPCEBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFUPCEBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFUPCEBarcode(data)
C#
public PDFUPCEBarcode(
   string data
)
Managed Extensions for C++
public: PDFUPCEBarcode(
   string* data
)
C++/CLI
public:
PDFUPCEBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCEBarcode Class
PDFUPCEBarcode Members
Overload List


PDFUPCEBarcode Constructor(String,Double,Double)

PDFUPCEBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUPCEBarcode Class > PDFUPCEBarcode Constructor : PDFUPCEBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUPCEBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFUPCEBarcode(data, left, top)
C#
public PDFUPCEBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFUPCEBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFUPCEBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data or the data does not have the required length.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUPCEBarcode Class
PDFUPCEBarcode Members
Overload List


PDFUSPSFIMBarcode Class

PDFUSPSFIMBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSFIMBarcode Class

Defines a USPS FIM barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFUSPSFIMBarcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFUSPSFIMBarcode
C#
public class PDFUSPSFIMBarcode : PDFUnidimensionalBarcode
Managed Extensions for C++
public __gc class PDFUSPSFIMBarcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFUSPSFIMBarcode : public PDFUnidimensionalBarcode

Remarks

The Facing Identification Mark, or FIM, is a bar code designed by the United States Postal Service to assist in the automated processing of mail. The FIM is a set of vertical bars printed on the envelope or postcard near the upper edge, just to the left of the postage area (the area where the postage stamp or its equivalent is placed). The FIM is intended for use primarily on preprinted envelopes and postcards and is applied by the company printing the envelopes or postcards, not by the USPS.
FIM barcodes support only 4 data strings: "A", "B", "C", and "D", one string for each FIM barcode.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSFIMBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSFIMBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFUSPSFIMBarcode Class Members

PDFUSPSFIMBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSFIMBarcode Class

The following tables list the members exposed by PDFUSPSFIMBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFUSPSFIMBarcode Constructor | Overloaded. Initializes a new PDFUSPSFIMBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUSPSFIMBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFUSPSFIMBarcode Constructor

PDFUSPSFIMBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSFIMBarcode Class : PDFUSPSFIMBarcode Constructor

Initializes a new PDFUSPSFIMBarcode object.

Overload List

Overload | Description
PDFUSPSFIMBarcode Constructor() | Initializes a new PDFUSPSFIMBarcode object.
PDFUSPSFIMBarcode Constructor(String) | Initializes a new PDFUSPSFIMBarcode object.
PDFUSPSFIMBarcode Constructor(String,Double,Double) | Initializes a new PDFUSPSFIMBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSFIMBarcode Class
PDFUSPSFIMBarcode Members


PDFUSPSFIMBarcode Constructor()

PDFUSPSFIMBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSFIMBarcode Class > PDFUSPSFIMBarcode Constructor : PDFUSPSFIMBarcode Constructor()

Initializes a new PDFUSPSFIMBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFUSPSFIMBarcode()
C#
public PDFUSPSFIMBarcode()
Managed Extensions for C++
public: PDFUSPSFIMBarcode();
C++/CLI
public:
PDFUSPSFIMBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSFIMBarcode Class
PDFUSPSFIMBarcode Members
Overload List


PDFUSPSFIMBarcode Constructor(String)

PDFUSPSFIMBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSFIMBarcode Class > PDFUSPSFIMBarcode Constructor : PDFUSPSFIMBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFUSPSFIMBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFUSPSFIMBarcode(data)
C#
public PDFUSPSFIMBarcode(
   string data
)
Managed Extensions for C++
public: PDFUSPSFIMBarcode(
   string* data
)
C++/CLI
public:
PDFUSPSFIMBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSFIMBarcode Class
PDFUSPSFIMBarcode Members
Overload List


PDFUSPSFIMBarcode Constructor(String,Double,Double)

PDFUSPSFIMBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSFIMBarcode Class > PDFUSPSFIMBarcode Constructor : PDFUSPSFIMBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUSPSFIMBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFUSPSFIMBarcode(data, left, top)
C#
public PDFUSPSFIMBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFUSPSFIMBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFUSPSFIMBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSFIMBarcode Class
PDFUSPSFIMBarcode Members
Overload List


PDFUSPSHorizontalBarcode Class

PDFUSPSHorizontalBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSHorizontalBarcode Class

Defines a horizontal bars barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFUSPSHorizontalBarcode
   Inherits PDFUnidimensionalBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFUSPSHorizontalBarcode
C#
public class PDFUSPSHorizontalBarcode : PDFUnidimensionalBarcode
Managed Extensions for C++
public __gc class PDFUSPSHorizontalBarcode : public PDFUnidimensionalBarcode
C++/CLI
public ref class PDFUSPSHorizontalBarcode : public PDFUnidimensionalBarcode

Remarks

This type of barcode is used by USPS to identify mailings as business reply mail. The PDFBarcode.Data property is a string of "1", each digit corresponding to a bar.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSHorizontalBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSHorizontalBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFUSPSHorizontalBarcode Class Members

PDFUSPSHorizontalBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSHorizontalBarcode Class

The following tables list the members exposed by PDFUSPSHorizontalBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFUSPSHorizontalBarcode Constructor | Overloaded. Initializes a new PDFUSPSHorizontalBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUSPSHorizontalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFUSPSHorizontalBarcode Constructor

PDFUSPSHorizontalBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSHorizontalBarcode Class : PDFUSPSHorizontalBarcode Constructor

Initializes a new PDFUSPSHorizontalBarcode object.

Overload List

Overload | Description
PDFUSPSHorizontalBarcode Constructor() | Initializes a new PDFUSPSHorizontalBarcode object.
PDFUSPSHorizontalBarcode Constructor(String) | Initializes a new PDFUSPSHorizontalBarcode object.
PDFUSPSHorizontalBarcode Constructor(String,Double,Double) | Initializes a new PDFUSPSHorizontalBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSHorizontalBarcode Class
PDFUSPSHorizontalBarcode Members


PDFUSPSHorizontalBarcode Constructor()

PDFUSPSHorizontalBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSHorizontalBarcode Class > PDFUSPSHorizontalBarcode Constructor : PDFUSPSHorizontalBarcode Constructor()

Initializes a new PDFUSPSHorizontalBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFUSPSHorizontalBarcode()
C#
public PDFUSPSHorizontalBarcode()
Managed Extensions for C++
public: PDFUSPSHorizontalBarcode();
C++/CLI
public:
PDFUSPSHorizontalBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSHorizontalBarcode Class
PDFUSPSHorizontalBarcode Members
Overload List


PDFUSPSHorizontalBarcode Constructor(String)

PDFUSPSHorizontalBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSHorizontalBarcode Class > PDFUSPSHorizontalBarcode Constructor : PDFUSPSHorizontalBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFUSPSHorizontalBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFUSPSHorizontalBarcode(data)
C#
public PDFUSPSHorizontalBarcode(
   string data
)
Managed Extensions for C++
public: PDFUSPSHorizontalBarcode(
   string* data
)
C++/CLI
public:
PDFUSPSHorizontalBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSHorizontalBarcode Class
PDFUSPSHorizontalBarcode Members
Overload List


PDFUSPSHorizontalBarcode Constructor(String,Double,Double)

PDFUSPSHorizontalBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSHorizontalBarcode Class > PDFUSPSHorizontalBarcode Constructor : PDFUSPSHorizontalBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUSPSHorizontalBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFUSPSHorizontalBarcode(data, left, top)
C#
public PDFUSPSHorizontalBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFUSPSHorizontalBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFUSPSHorizontalBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSHorizontalBarcode Class
PDFUSPSHorizontalBarcode Members
Overload List


PDFUSPSPICBarcode Class

PDFUSPSPICBarcode Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSPICBarcode Class

Defines a USPS Package Identification Code barcode.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFUSPSPICBarcode
   Inherits PDFCode128CBarcode
Visual Basic (Usage) Copy Code
Dim instance As PDFUSPSPICBarcode
C#
public class PDFUSPSPICBarcode : PDFCode128CBarcode
Managed Extensions for C++
public __gc class PDFUSPSPICBarcode : public PDFCode128CBarcode
C++/CLI
public ref class PDFUSPSPICBarcode : public PDFCode128CBarcode

Remarks

Only the following symbols are allowed in the barcode: 0 1 2 3 4 5 6 7 8 9. The required data length is 21 digits for standard barcode (the first 2 digits are always 91) or 29 digits for concatenated barcode (the first 3 digits are always 420).
The structure of a USPS PIC standard barcode is as follows:
1 - 2 - Application Identifier (91)
3 - 4 - Service Type Code (STC)
5 - 13 - Customer ID: DUNS number that uniquely identifies the customer
14 - 21 - Package Sequence Number (PSN)
The structure of a USPS PIC concatenated barcode is as follows:
1 - 3 - Routing Application Identifier (420)
4 - 8 - 5-digit ZIP code
9 - 10 - Application Identifier (91)
11 - 12 - Service Type Code (STC)
13 - 21 - Customer ID: DUNS number that uniquely identifies the customer
22 - 29 - Package Sequence Number (PSN)

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Barcodes.PDFBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUnidimensionalBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128Barcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFCode128CBarcode
O2S.Components.PDF4NET.Graphics.Barcodes.PDFUSPSPICBarcode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSPICBarcode Members
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFUSPSPICBarcode Class Members

PDFUSPSPICBarcode Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSPICBarcode Class

The following tables list the members exposed by PDFUSPSPICBarcode.

Public Constructors

 | Name | Description
Public Constructor | PDFUSPSPICBarcode Constructor | Overloaded. Initializes a new PDFUSPSPICBarcode object.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUSPSPICBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFUSPSPICBarcode Constructor

PDFUSPSPICBarcode Constructor
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSPICBarcode Class : PDFUSPSPICBarcode Constructor

Initializes a new PDFUSPSPICBarcode object.

Overload List

Overload | Description
PDFUSPSPICBarcode Constructor() | Initializes a new PDFUSPSPICBarcode object.
PDFUSPSPICBarcode Constructor(String) | Initializes a new PDFUSPSPICBarcode object.
PDFUSPSPICBarcode Constructor(String,Double,Double) | Initializes a new PDFUSPSPICBarcode object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSPICBarcode Class
PDFUSPSPICBarcode Members


PDFUSPSPICBarcode Constructor()

PDFUSPSPICBarcode Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSPICBarcode Class > PDFUSPSPICBarcode Constructor : PDFUSPSPICBarcode Constructor()

Initializes a new PDFUSPSPICBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFUSPSPICBarcode()
C#
public PDFUSPSPICBarcode()
Managed Extensions for C++
public: PDFUSPSPICBarcode();
C++/CLI
public:
PDFUSPSPICBarcode();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSPICBarcode Class
PDFUSPSPICBarcode Members
Overload List


PDFUSPSPICBarcode Constructor(String)

PDFUSPSPICBarcode Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSPICBarcode Class > PDFUSPSPICBarcode Constructor : PDFUSPSPICBarcode Constructor(String)

data
The data to be encoded.
Initializes a new PDFUSPSPICBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim data As String

Dim instance As PDFUSPSPICBarcode(data)
C#
public PDFUSPSPICBarcode(
   string data
)
Managed Extensions for C++
public: PDFUSPSPICBarcode(
   string* data
)
C++/CLI
public:
PDFUSPSPICBarcode(
   String^ data
)

Parameters

data
The data to be encoded.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSPICBarcode Class
PDFUSPSPICBarcode Members
Overload List


PDFUSPSPICBarcode Constructor(String,Double,Double)

PDFUSPSPICBarcode Constructor(String,Double,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace > PDFUSPSPICBarcode Class > PDFUSPSPICBarcode Constructor : PDFUSPSPICBarcode Constructor(String,Double,Double)

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.
Initializes a new PDFUSPSPICBarcode object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As String, _
   ByVal left As Double, _
   ByVal top As Double _
)
Visual Basic (Usage) Copy Code
Dim data As String
Dim left As Double
Dim top As Double

Dim instance As PDFUSPSPICBarcode(data, left, top)
C#
public PDFUSPSPICBarcode(
   string data,
   double left,
   double top
)
Managed Extensions for C++
public: PDFUSPSPICBarcode(
   string* data,
   double left,
   double top
)
C++/CLI
public:
PDFUSPSPICBarcode(
   String^ data,
   double left,
   double top
)

Parameters

data
The data to be encoded.
left
the X coordinate of the top left corner of the barcode rectangle.
top
the Y coordinate of the top left corner of the barcode rectangle.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when invalid symbols exist in barcode data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFUSPSPICBarcode Class
PDFUSPSPICBarcode Members
Overload List


BarcodeTextLocation Enumeration

BarcodeTextLocation Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : BarcodeTextLocation Enumeration

Specifies the available locations for displaying text on a linear barcode.

Syntax

Visual Basic (Declaration)
Public Enum BarcodeTextLocation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BarcodeTextLocation
C#
public enum BarcodeTextLocation : Enum
Managed Extensions for C++
__value public enum BarcodeTextLocation : public Enum
C++/CLI
public enum class BarcodeTextLocation : public Enum

Members

Member | Description
None | Barcode text is not displayed.
Above | Barcode text is placed above the bar code.
AboveEmbedded | Barcode text is partially embedded at the top of the bar code. The top of the text is aligned with the top of the bars.
Below | Barcode text is placed below the bar code.
BelowEmbedded | Barcode text is partially embedded in the bottom of the bar code. The baseline of the text is aligned with the bottom of the bars.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.BarcodeTextLocation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


DataMatrixEncoding Enumeration

DataMatrixEncoding Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : DataMatrixEncoding Enumeration

Specifies the available encoding modes for a DataMatrix barcode.

Syntax

Visual Basic (Declaration)
Public Enum DataMatrixEncoding
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixEncoding
C#
public enum DataMatrixEncoding : Enum
Managed Extensions for C++
__value public enum DataMatrixEncoding : public Enum
C++/CLI
public enum class DataMatrixEncoding : public Enum

Members

Member | Description
Auto | The encoding is determined automatically based on the data to encode.
ASCII | The data to encode contains ASCII characters only (0x00 - 0x7F). Extended ASCII characters (0x80 - 0xFF) are also supported.
Base256 | The data to encode is a binary stream.
Numeric | The data to encode contains only numbers (ASCII characters 0x30 - 0x39)

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.DataMatrixEncoding

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


DataMatrixSymbolSize Enumeration

DataMatrixSymbolSize Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : DataMatrixSymbolSize Enumeration

Specifies the available sizes for a DataMatrix symbol.

Syntax

Visual Basic (Declaration)
Public Enum DataMatrixSymbolSize
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataMatrixSymbolSize
C#
public enum DataMatrixSymbolSize : Enum
Managed Extensions for C++
__value public enum DataMatrixSymbolSize : public Enum
C++/CLI
public enum class DataMatrixSymbolSize : public Enum

Members

Member | Description
Auto | The smallest symbol size is calculated based on available data.
Size10x10 | Square DataMatrix symbol with 10 rows and 10 columns.
Size12x12 | Square DataMatrix symbol with 12 rows and 12 columns.
Size14x14 | Square DataMatrix symbol with 14 rows and 14 columns.
Size16x16 | Square DataMatrix symbol with 16 rows and 16 columns.
Size18x18 | Square DataMatrix symbol with 18 rows and 18 columns.
Size20x20 | Square DataMatrix symbol with 20 rows and 20 columns.
Size22x22 | Square DataMatrix symbol with 22 rows and 22 columns.
Size24x24 | Square DataMatrix symbol with 24 rows and 24 columns.
Size26x26 | Square DataMatrix symbol with 26 rows and 26 columns.
Size32x32 | Square DataMatrix symbol with 32 rows and 32 columns.
Size36x36 | Square DataMatrix symbol with 36 rows and 36 columns.
Size40x40 | Square DataMatrix symbol with 40 rows and 40 columns.
Size44x44 | Square DataMatrix symbol with 44 rows and 44 columns.
Size48x48 | Square DataMatrix symbol with 48 rows and 48 columns.
Size52x52 | Square DataMatrix symbol with 52 rows and 52 columns.
Size64x64 | Square DataMatrix symbol with 64 rows and 64 columns.
Size72x72 | Square DataMatrix symbol with 72 rows and 72 columns.
Size80x80 | Square DataMatrix symbol with 80 rows and 80 columns.
Size88x88 | Square DataMatrix symbol with 88 rows and 88 columns.
Size96x96 | Square DataMatrix symbol with 96 rows and 96 columns.
Size104x104 | Square DataMatrix symbol with 104 rows and 104 columns.
Size120x120 | Square DataMatrix symbol with 120 rows and 120 columns.
Size132x132 | Square DataMatrix symbol with 132 rows and 132 columns.
Size144x144 | Square DataMatrix symbol with 144 rows and 144 columns.
Size8x18 | Rectangular DataMatrix symbol with 8 rows and 18 columns.
Size8x32 | Rectangular DataMatrix symbol with 8 rows and 32 columns.
Size12x26 | Rectangular DataMatrix symbol with 12 rows and 26 columns.
Size12x36 | Rectangular DataMatrix symbol with 12 rows and 36 columns.
Size16x36 | Rectangular DataMatrix symbol with 16 rows and 36 columns.
Size16x48 | Rectangular DataMatrix symbol with 16 rows and 48 columns.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.DataMatrixSymbolSize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


MicroPDF417SymbolSize Enumeration

MicroPDF417SymbolSize Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : MicroPDF417SymbolSize Enumeration

Specifies the available sizes for a Micro PDF417 symbol.

Syntax

Visual Basic (Declaration)
Public Enum MicroPDF417SymbolSize
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MicroPDF417SymbolSize
C#
public enum MicroPDF417SymbolSize : Enum
Managed Extensions for C++
__value public enum MicroPDF417SymbolSize : public Enum
C++/CLI
public enum class MicroPDF417SymbolSize : public Enum

Members

Member | Description
Auto | The smallest symbol size is calculated based on available data.
Size11x1 | Micro PDF417 symbol with 11 rows and 1 column.
Size14x1 | Micro PDF417 symbol with 14 rows and 1 column.
Size17x1 | Micro PDF417 symbol with 17 rows and 1 column.
Size20x1 | Micro PDF417 symbol with 20 rows and 1 column.
Size24x1 | Micro PDF417 symbol with 24 rows and 1 column.
Size28x1 | Micro PDF417 symbol with 28 rows and 1 column.
Size8x2 | Micro PDF417 symbol with 8 rows and 2 columns.
Size11x2 | Micro PDF417 symbol with 11 rows and 2 columns.
Size14x2 | Micro PDF417 symbol with 14 rows and 2 columns.
Size17x2 | Micro PDF417 symbol with 17 rows and 2 columns.
Size20x2 | Micro PDF417 symbol with 20 rows and 2 columns.
Size23x2 | Micro PDF417 symbol with 23 rows and 2 columns.
Size26x2 | Micro PDF417 symbol with 26 rows and 2 columns.
Size6x3 | Micro PDF417 symbol with 6 rows and 3 columns.
Size8x3 | Micro PDF417 symbol with 8 rows and 3 columns.
Size10x3 | Micro PDF417 symbol with 10 rows and 3 columns.
Size12x3 | Micro PDF417 symbol with 12 rows and 3 columns.
Size15x3 | Micro PDF417 symbol with 15 rows and 3 columns.
Size20x3 | Micro PDF417 symbol with 20 rows and 3 columns.
Size26x3 | Micro PDF417 symbol with 26 rows and 3 columns.
Size32x3 | Micro PDF417 symbol with 32 rows and 3 columns.
Size38x3 | Micro PDF417 symbol with 38 rows and 3 columns.
Size44x3 | Micro PDF417 symbol with 44 rows and 3 columns.
Size4x4 | Micro PDF417 symbol with 4 rows and 4 columns.
Size6x4 | Micro PDF417 symbol with 6 rows and 4 columns.
Size8x4 | Micro PDF417 symbol with 8 rows and 4 columns.
Size10x4 | Micro PDF417 symbol with 10 rows and 4 columns.
Size12x4 | Micro PDF417 symbol with 12 rows and 4 columns.
Size15x4 | Micro PDF417 symbol with 15 rows and 4 columns.
Size20x4 | Micro PDF417 symbol with 20 rows and 4 columns.
Size26x4 | Micro PDF417 symbol with 26 rows and 4 columns.
Size32x4 | Micro PDF417 symbol with 32 rows and 4 columns.
Size38x4 | Micro PDF417 symbol with 38 rows and 4 columns.
Size44x4 | Micro PDF417 symbol with 44 rows and 4 columns.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.MicroPDF417SymbolSize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDF417DataCompactionMode Enumeration

PDF417DataCompactionMode Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417DataCompactionMode Enumeration

Specifies the available data compaction modes for a PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Enum PDF417DataCompactionMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF417DataCompactionMode
C#
public enum PDF417DataCompactionMode : Enum
Managed Extensions for C++
__value public enum PDF417DataCompactionMode : public Enum
C++/CLI
public enum class PDF417DataCompactionMode : public Enum

Members

Member | Description
Text | Text compaction mode.
Numeric | Numeric compaction mode.
Byte | Binary compaction mode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.PDF417DataCompactionMode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDF417ErrorCorrectionLevel Enumeration

PDF417ErrorCorrectionLevel Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417ErrorCorrectionLevel Enumeration

Specifies the available error correction levels for a PDF417 barcode.

Syntax

Visual Basic (Declaration)
Public Enum PDF417ErrorCorrectionLevel
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDF417ErrorCorrectionLevel
C#
public enum PDF417ErrorCorrectionLevel : Enum
Managed Extensions for C++
__value public enum PDF417ErrorCorrectionLevel : public Enum
C++/CLI
public enum class PDF417ErrorCorrectionLevel : public Enum

Members

Member | Description
Level0 | Level 0 - 2 error correction codewords.
Level1 | Level 1 - 4 error correction codewords.
Level2 | Level 2 - 8 error correction codewords.
Level3 | Level 3 - 16 error correction codewords.
Level4 | Level 4 - 32 error correction codewords.
Level5 | Level 5 - 64 error correction codewords.
Level6 | Level 6 - 128 error correction codewords.
Level7 | Level 7 - 256 error correction codewords.
Level8 | Level 8 - 512 error correction codewords.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Barcodes.PDF417ErrorCorrectionLevel

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Barcodes Namespace


O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFCalGrayColorSpace | Defines a CalGray colorspace.
PDFCalRgbColorSpace | Defines a CalRGB colorspace.
PDFColorSpace | Defines the base class for all colorspaces.
PDFColorSpaceCollection | Defines a collection of colorspaces.
PDFDeviceColorSpace | Defines a device colorspace.
PDFDeviceNAttributes | Defines the attributes for the DeviceN colorspace.
PDFDeviceNColorants |
PDFDeviceNColorNameCollection | Defines a collection of PDF actions.
PDFDeviceNColorSpace | Defines a DeviceN colorspace.
PDFICCColorSpace | Defines an ICC based colorspace.
PDFIndexedColorSpace | Defines an indexed colorspace.
PDFLabColorSpace | Defines a Lab colorspace.
PDFPantoneColor | Defines a PANTONE color.
PDFPatternColorSpace | Defines a pattern colorspace.
PDFSeparationColorSpace | Defines a separation colorspace.

Enumerations

Enumeration | Description
PDFColorSpaceType | Defines the available colorspace types.
PDFDeviceColorSpaceType | Defines the available device colorspace types.

See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace Inheritance Hierarchy

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalGrayColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalRgbColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFICCColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFIndexedColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFLabColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFPatternColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNAttributes
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorants
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFSeparationColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFPantoneColor
System.Collections.ObjectModel.Collection<String>
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorNameCollection
System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpaceCollection

See Also

Reference

O2S.Components.PDF4NET Assembly


PDFCalGrayColorSpace Class

PDFCalGrayColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalGrayColorSpace Class

Defines a CalGray colorspace.

Syntax

Visual Basic (Declaration)
Public Class PDFCalGrayColorSpace
   Inherits PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColorSpace
C#
public class PDFCalGrayColorSpace : PDFColorSpace
Managed Extensions for C++
public __gc class PDFCalGrayColorSpace : public PDFColorSpace
C++/CLI
public ref class PDFCalGrayColorSpace : public PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalGrayColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFCalGrayColorSpace Class Members

PDFCalGrayColorSpace Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalGrayColorSpace Class

The following tables list the members exposed by PDFCalGrayColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFCalGrayColorSpace Constructor | Initializes a new PDFCalGrayColorSpace object.
Top

Public Properties

 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Gamma | Gets or sets the gamma.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top

See Also

Reference

PDFCalGrayColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFCalGrayColorSpace Constructor

PDFCalGrayColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalGrayColorSpace Class : PDFCalGrayColorSpace Constructor

Initializes a new PDFCalGrayColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColorSpace()
C#
public PDFCalGrayColorSpace()
Managed Extensions for C++
public: PDFCalGrayColorSpace();
C++/CLI
public:
PDFCalGrayColorSpace();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColorSpace Class
PDFCalGrayColorSpace Members


PDFCalGrayColorSpace Class Properties

PDFCalGrayColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalGrayColorSpace Class

For a list of all members of this type, see PDFCalGrayColorSpace members.

Public Properties

 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Gamma | Gets or sets the gamma.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top

See Also

Reference

PDFCalGrayColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


BlackPoint Property

BlackPoint Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalGrayColorSpace Class : BlackPoint Property

Gets or sets the black point.

Syntax

Visual Basic (Declaration)
Public Property BlackPoint As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColorSpace
Dim value() As Double

instance.BlackPoint = value

value = instance.BlackPoint
C#
public double[] BlackPoint {get; set;}
Managed Extensions for C++
public: __property double[]* get_BlackPoint();
public: __property void set_BlackPoint(
   double[]* value
);
C++/CLI
public:
property array<double>^ BlackPoint {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of three numbers [XB YB ZB] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse black point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColorSpace Class
PDFCalGrayColorSpace Members


Gamma Property

Gamma Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalGrayColorSpace Class : Gamma Property

Gets or sets the gamma.

Syntax

Visual Basic (Declaration)
Public Property Gamma As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColorSpace
Dim value As Double

instance.Gamma = value

value = instance.Gamma
C#
public double Gamma {get; set;}
Managed Extensions for C++
public: __property double get_Gamma();
public: __property void set_Gamma(
   double value
);
C++/CLI
public:
property double Gamma {
   double get();
   void set (double value);
}

Return Value

The gamma value for the gray component.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColorSpace Class
PDFCalGrayColorSpace Members


WhitePoint Property

WhitePoint Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalGrayColorSpace Class : WhitePoint Property

Gets or sets the white point.

Syntax

Visual Basic (Declaration)
Public Property WhitePoint As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFCalGrayColorSpace
Dim value() As Double

instance.WhitePoint = value

value = instance.WhitePoint
C#
public double[] WhitePoint {get; set;}
Managed Extensions for C++
public: __property double[]* get_WhitePoint();
public: __property void set_WhitePoint(
   double[]* value
);
C++/CLI
public:
property array<double>^ WhitePoint {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of three numbers [XW YW ZW] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse white point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalGrayColorSpace Class
PDFCalGrayColorSpace Members


PDFCalRgbColorSpace Class

PDFCalRgbColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalRgbColorSpace Class

Defines a CalRGB colorspace.

Syntax

Visual Basic (Declaration)
Public Class PDFCalRgbColorSpace
   Inherits PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColorSpace
C#
public class PDFCalRgbColorSpace : PDFColorSpace
Managed Extensions for C++
public __gc class PDFCalRgbColorSpace : public PDFColorSpace
C++/CLI
public ref class PDFCalRgbColorSpace : public PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalRgbColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFCalRgbColorSpace Class Members

PDFCalRgbColorSpace Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalRgbColorSpace Class

The following tables list the members exposed by PDFCalRgbColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFCalRgbColorSpace Constructor | Initializes a new PDFCalRgbColorSpace object.
Top

Public Properties

 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Gamma | Gets or sets the gamma.
Public Property | Matrix | Gets or sets the colorspace transformation matrix.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top

See Also

Reference

PDFCalRgbColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFCalRgbColorSpace Constructor

PDFCalRgbColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : PDFCalRgbColorSpace Constructor

Initializes a new PDFCalRgbColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColorSpace()
C#
public PDFCalRgbColorSpace()
Managed Extensions for C++
public: PDFCalRgbColorSpace();
C++/CLI
public:
PDFCalRgbColorSpace();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


PDFCalRgbColorSpace Class Properties

PDFCalRgbColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFCalRgbColorSpace Class

For a list of all members of this type, see PDFCalRgbColorSpace members.

Public Properties

 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Gamma | Gets or sets the gamma.
Public Property | Matrix | Gets or sets the colorspace transformation matrix.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top

See Also

Reference

PDFCalRgbColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


BlackPoint Property

BlackPoint Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : BlackPoint Property

Gets or sets the black point.

Syntax

Visual Basic (Declaration)
Public Property BlackPoint As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColorSpace
Dim value() As Double

instance.BlackPoint = value

value = instance.BlackPoint
C#
public double[] BlackPoint {get; set;}
Managed Extensions for C++
public: __property double[]* get_BlackPoint();
public: __property void set_BlackPoint(
   double[]* value
);
C++/CLI
public:
property array<double>^ BlackPoint {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of three numbers [XB YB ZB] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse black point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


Gamma Property

Gamma Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : Gamma Property

Gets or sets the gamma.

Syntax

Visual Basic (Declaration)
Public Property Gamma As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColorSpace
Dim value() As Double

instance.Gamma = value

value = instance.Gamma
C#
public double[] Gamma {get; set;}
Managed Extensions for C++
public: __property double[]* get_Gamma();
public: __property void set_Gamma(
   double[]* value
);
C++/CLI
public:
property array<double>^ Gamma {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of three numbers [GR GG GB] specifying the gamma for the red, green, and blue components of the color space.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


Matrix Property

Matrix Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : Matrix Property

Gets or sets the colorspace transformation matrix.

Syntax

Visual Basic (Declaration)
Public Property Matrix As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColorSpace
Dim value() As Double

instance.Matrix = value

value = instance.Matrix
C#
public double[] Matrix {get; set;}
Managed Extensions for C++
public: __property double[]* get_Matrix();
public: __property void set_Matrix(
   double[]* value
);
C++/CLI
public:
property array<double>^ Matrix {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of nine numbers [XA YA ZA XB YB ZB XC YC ZC] specifying the linear interpretation of the decoded A, B, and C components of the color space with respect to the final XYZ representation..

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


WhitePoint Property

WhitePoint Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFCalRgbColorSpace Class : WhitePoint Property

Gets or sets the white point.

Syntax

Visual Basic (Declaration)
Public Property WhitePoint As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFCalRgbColorSpace
Dim value() As Double

instance.WhitePoint = value

value = instance.WhitePoint
C#
public double[] WhitePoint {get; set;}
Managed Extensions for C++
public: __property double[]* get_WhitePoint();
public: __property void set_WhitePoint(
   double[]* value
);
C++/CLI
public:
property array<double>^ WhitePoint {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of three numbers [XW YW ZW] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse white point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCalRgbColorSpace Class
PDFCalRgbColorSpace Members


PDFColorSpace Class

PDFColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpace Class

Defines the base class for all colorspaces.

Syntax

Visual Basic (Declaration)
Public Class PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFColorSpace
C#
public class PDFColorSpace
Managed Extensions for C++
public __gc class PDFColorSpace
C++/CLI
public ref class PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFPatternColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFLabColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFIndexedColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFICCColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalRgbColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFCalGrayColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFColorSpace Class Members

PDFColorSpace Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpace Class

The following tables list the members exposed by PDFColorSpace.

Public Properties

 | Name | Description
Public Property | Type | Gets the type of this colorspace.
Top

See Also

Reference

PDFColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFColorSpace Class Properties

PDFColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpace Class

For a list of all members of this type, see PDFColorSpace members.

Public Properties

 | Name | Description
Public Property | Type | Gets the type of this colorspace.
Top

See Also

Reference

PDFColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


Type Property

Type Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFColorSpace Class : Type Property

Gets the type of this colorspace.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As PDFColorSpaceType
Visual Basic (Usage) Copy Code
Dim instance As PDFColorSpace
Dim value As PDFColorSpaceType

value = instance.Type
C#
public PDFColorSpaceType Type {get;}
Managed Extensions for C++
public: __property PDFColorSpaceType get_Type();
C++/CLI
public:
property PDFColorSpaceType Type {
   PDFColorSpaceType get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColorSpace Class
PDFColorSpace Members


PDFColorSpaceCollection Class

PDFColorSpaceCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpaceCollection Class

Defines a collection of colorspaces.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFColorSpaceCollection
   Inherits ReadOnlyCollection(Of PDFColorSpace)
Visual Basic (Usage) Copy Code
Dim instance As PDFColorSpaceCollection
C#
public class PDFColorSpaceCollection : ReadOnlyCollection<PDFColorSpace>
Managed Extensions for C++
public __gc class PDFColorSpaceCollection : public ReadOnlyCollection<PDFColorSpace>
C++/CLI
public ref class PDFColorSpaceCollection : public ReadOnlyCollection<PDFColorSpace>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpaceCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColorSpaceCollection Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFColorSpaceCollection Class Members

PDFColorSpaceCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpaceCollection Class

The following tables list the members exposed by PDFColorSpaceCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Top

Public Methods

 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Top

See Also

Reference

PDFColorSpaceCollection Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFDeviceColorSpace Class

PDFDeviceColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceColorSpace Class

Defines a device colorspace.

Syntax

Visual Basic (Declaration)
Public Class PDFDeviceColorSpace
   Inherits PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceColorSpace
C#
public class PDFDeviceColorSpace : PDFColorSpace
Managed Extensions for C++
public __gc class PDFDeviceColorSpace : public PDFColorSpace
C++/CLI
public ref class PDFDeviceColorSpace : public PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFDeviceColorSpace Class Members

PDFDeviceColorSpace Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceColorSpace Class

The following tables list the members exposed by PDFDeviceColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFDeviceColorSpace Constructor | Initializes a new PDFDeviceColorSpace object.
Top

Public Properties

 | Name | Description
Public Property | DeviceType | Gets the type of this device colorspace.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if this colorspace equals another colorspace.
Top

See Also

Reference

PDFDeviceColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFDeviceColorSpace Constructor

PDFDeviceColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceColorSpace Class : PDFDeviceColorSpace Constructor

deviceType
The type of the newly created device colorspace.
Initializes a new PDFDeviceColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal deviceType As PDFDeviceColorSpaceType _
)
Visual Basic (Usage) Copy Code
Dim deviceType As PDFDeviceColorSpaceType

Dim instance As PDFDeviceColorSpace(deviceType)
C#
public PDFDeviceColorSpace(
   PDFDeviceColorSpaceType deviceType
)
Managed Extensions for C++
public: PDFDeviceColorSpace(
   PDFDeviceColorSpaceType deviceType
)
C++/CLI
public:
PDFDeviceColorSpace(
   PDFDeviceColorSpaceType deviceType
)

Parameters

deviceType
The type of the newly created device colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceColorSpace Class
PDFDeviceColorSpace Members


PDFDeviceColorSpace Class Methods

PDFDeviceColorSpace Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceColorSpace Class

For a list of all members of this type, see PDFDeviceColorSpace members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Tests if this colorspace equals another colorspace.
Top

See Also

Reference

PDFDeviceColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


Equals Method

Equals Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceColorSpace Class : Equals Method

obj
Tests if this colorspace equals another colorspace.

Syntax

Visual Basic (Declaration)
Overrides Public Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceColorSpace
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceColorSpace Class
PDFDeviceColorSpace Members


PDFDeviceColorSpace Class Properties

PDFDeviceColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceColorSpace Class

For a list of all members of this type, see PDFDeviceColorSpace members.

Public Properties

 | Name | Description
Public Property | DeviceType | Gets the type of this device colorspace.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Top

See Also

Reference

PDFDeviceColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


DeviceType Property

DeviceType Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceColorSpace Class : DeviceType Property

Gets the type of this device colorspace.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeviceType As PDFDeviceColorSpaceType
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceColorSpace
Dim value As PDFDeviceColorSpaceType

value = instance.DeviceType
C#
public PDFDeviceColorSpaceType DeviceType {get;}
Managed Extensions for C++
public: __property PDFDeviceColorSpaceType get_DeviceType();
C++/CLI
public:
property PDFDeviceColorSpaceType DeviceType {
   PDFDeviceColorSpaceType get();
}

Return Value

The type of the device colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceColorSpace Class
PDFDeviceColorSpace Members


PDFDeviceNAttributes Class

PDFDeviceNAttributes Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNAttributes Class

Defines the attributes for the DeviceN colorspace.

Syntax

Visual Basic (Declaration)
Public Class PDFDeviceNAttributes
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNAttributes
C#
public class PDFDeviceNAttributes
Managed Extensions for C++
public __gc class PDFDeviceNAttributes
C++/CLI
public ref class PDFDeviceNAttributes

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNAttributes

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNAttributes Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFDeviceNAttributes Class Members

PDFDeviceNAttributes Class Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNAttributes Class

The following tables list the members exposed by PDFDeviceNAttributes.

Public Constructors

 | Name | Description
Public Constructor | PDFDeviceNAttributes Constructor | Initilizes a new PDFDeviceNAttributes object.
Top

See Also

Reference

PDFDeviceNAttributes Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFDeviceNAttributes Constructor

PDFDeviceNAttributes Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNAttributes Class : PDFDeviceNAttributes Constructor

Initilizes a new PDFDeviceNAttributes object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNAttributes()
C#
public PDFDeviceNAttributes()
Managed Extensions for C++
public: PDFDeviceNAttributes();
C++/CLI
public:
PDFDeviceNAttributes();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNAttributes Class
PDFDeviceNAttributes Members


PDFDeviceNColorants Class

PDFDeviceNColorants Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorants Class

Syntax

Visual Basic (Declaration)
Public Class PDFDeviceNColorants
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorants
C#
public class PDFDeviceNColorants
Managed Extensions for C++
public __gc class PDFDeviceNColorants
C++/CLI
public ref class PDFDeviceNColorants

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorants

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorants Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFDeviceNColorants Class Members

PDFDeviceNColorants Class Members
See Also Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorants Class

The following tables list the members exposed by PDFDeviceNColorants.

Public Constructors

 | Name | Description
Public Constructor | PDFDeviceNColorants Constructor | Initilizes a new PDFDeviceNColorants object.
Top

Public Methods

 | Name | Description
Public Method | AddColorant | Adds a colorant to the DeviceN colorspace.
Public Method | GetColorant | Gets the colorant with the specified name.
Public Method | GetColorantNames | Gets the names of the colorants included in the DeviceN colorspace.
Public Method | RemoveColorant | Removes the colorant with the specified name from the colorspace.
Top

See Also

Reference

PDFDeviceNColorants Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFDeviceNColorants Constructor

PDFDeviceNColorants Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorants Class : PDFDeviceNColorants Constructor

Initilizes a new PDFDeviceNColorants object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorants()
C#
public PDFDeviceNColorants()
Managed Extensions for C++
public: PDFDeviceNColorants();
C++/CLI
public:
PDFDeviceNColorants();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorants Class
PDFDeviceNColorants Members


PDFDeviceNColorants Class Methods

PDFDeviceNColorants Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorants Class

For a list of all members of this type, see PDFDeviceNColorants members.

Public Methods

 | Name | Description
Public Method | AddColorant | Adds a colorant to the DeviceN colorspace.
Public Method | GetColorant | Gets the colorant with the specified name.
Public Method | GetColorantNames | Gets the names of the colorants included in the DeviceN colorspace.
Public Method | RemoveColorant | Removes the colorant with the specified name from the colorspace.
Top

See Also

Reference

PDFDeviceNColorants Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


AddColorant Method

AddColorant Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorants Class : AddColorant Method

colorant
The colorant to be addded to the colorspace.
Adds a colorant to the DeviceN colorspace.

Syntax

Visual Basic (Declaration)
Public Sub AddColorant( _
   ByVal colorant As PDFSeparationColorSpace _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorants
Dim colorant As PDFSeparationColorSpace

instance.AddColorant(colorant)
C#
public void AddColorant(
   PDFSeparationColorSpace colorant
)
Managed Extensions for C++
public: void AddColorant(
   PDFSeparationColorSpace* colorant
)
C++/CLI
public:
void AddColorant(
   PDFSeparationColorSpace^ colorant
)

Parameters

colorant
The colorant to be addded to the colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorants Class
PDFDeviceNColorants Members


GetColorant Method

GetColorant Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorants Class : GetColorant Method

colorantName
The name of the colorant to get.
Gets the colorant with the specified name.

Syntax

Visual Basic (Declaration)
Public Function GetColorant( _
   ByVal colorantName As String _
) As PDFSeparationColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorants
Dim colorantName As String
Dim value As PDFSeparationColorSpace

value = instance.GetColorant(colorantName)
C#
public PDFSeparationColorSpace GetColorant(
   string colorantName
)
Managed Extensions for C++
public: PDFSeparationColorSpace* GetColorant(
   string* colorantName
)
C++/CLI
public:
PDFSeparationColorSpace^ GetColorant(
   String^ colorantName
)

Parameters

colorantName
The name of the colorant to get.

Return Value

The colorant as a separation colorspace if it exists, null otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorants Class
PDFDeviceNColorants Members


GetColorantNames Method

GetColorantNames Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorants Class : GetColorantNames Method

Gets the names of the colorants included in the DeviceN colorspace.

Syntax

Visual Basic (Declaration)
Public Function GetColorantNames() As String()
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorants
Dim value() As String

value = instance.GetColorantNames()
C#
public string[] GetColorantNames()
Managed Extensions for C++
public: string*[]* GetColorantNames();
C++/CLI
public:
array<String^>^ GetColorantNames();

Return Value

List of colorant names.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorants Class
PDFDeviceNColorants Members


RemoveColorant Method

RemoveColorant Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorants Class : RemoveColorant Method

colorantName
The name of the colorant to be removed.
Removes the colorant with the specified name from the colorspace.

Syntax

Visual Basic (Declaration)
Public Sub RemoveColorant( _
   ByVal colorantName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorants
Dim colorantName As String

instance.RemoveColorant(colorantName)
C#
public void RemoveColorant(
   string colorantName
)
Managed Extensions for C++
public: void RemoveColorant(
   string* colorantName
)
C++/CLI
public:
void RemoveColorant(
   String^ colorantName
)

Parameters

colorantName
The name of the colorant to be removed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorants Class
PDFDeviceNColorants Members


PDFDeviceNColorNameCollection Class

PDFDeviceNColorNameCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorNameCollection Class

Defines a collection of PDF actions.

Syntax

Visual Basic (Declaration)
Public Class PDFDeviceNColorNameCollection
   Inherits Collection(Of String)
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorNameCollection
C#
public class PDFDeviceNColorNameCollection : Collection<string>
Managed Extensions for C++
public __gc class PDFDeviceNColorNameCollection : public Collection<string>
C++/CLI
public ref class PDFDeviceNColorNameCollection : public Collection<String>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<String>
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorNameCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorNameCollection Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFDeviceNColorNameCollection Class Members

PDFDeviceNColorNameCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorNameCollection Class

The following tables list the members exposed by PDFDeviceNColorNameCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<String>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<String>)
Top

See Also

Reference

PDFDeviceNColorNameCollection Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFDeviceNColorSpace Class

PDFDeviceNColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorSpace Class

Defines a DeviceN colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFDeviceNColorSpace
   Inherits PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorSpace
C#
public class PDFDeviceNColorSpace : PDFColorSpace
Managed Extensions for C++
public __gc class PDFDeviceNColorSpace : public PDFColorSpace
C++/CLI
public ref class PDFDeviceNColorSpace : public PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceNColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFDeviceNColorSpace Class Members

PDFDeviceNColorSpace Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorSpace Class

The following tables list the members exposed by PDFDeviceNColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFDeviceNColorSpace Constructor | Overloaded. Initializes a new PDFDeviceNColorSpace object.
Top

Public Properties

 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | Attributes | Gets the attributes associated with this colorsspace.
Public Property | ColorantNames | Gets the collection of colorant names included in this DeviceN colorspace.
Public Property | TintTransform | Gets or sets the tint transform function for the this colorspace.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Top

See Also

Reference

PDFDeviceNColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFDeviceNColorSpace Constructor

PDFDeviceNColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class : PDFDeviceNColorSpace Constructor

Initializes a new PDFDeviceNColorSpace object.

Overload List

Overload | Description
PDFDeviceNColorSpace Constructor() | Initializes a new PDFDeviceNColorSpace object.
PDFDeviceNColorSpace Constructor(PDFArray) | Initializes a new PDFDeviceNColorSpace object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members


PDFDeviceNColorSpace Constructor()

PDFDeviceNColorSpace Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class > PDFDeviceNColorSpace Constructor : PDFDeviceNColorSpace Constructor()

Initializes a new PDFDeviceNColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorSpace()
C#
public PDFDeviceNColorSpace()
Managed Extensions for C++
public: PDFDeviceNColorSpace();
C++/CLI
public:
PDFDeviceNColorSpace();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members
Overload List


PDFDeviceNColorSpace Constructor(PDFArray)

PDFDeviceNColorSpace Constructor(PDFArray)
See Also
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class > PDFDeviceNColorSpace Constructor : PDFDeviceNColorSpace Constructor(PDFArray)

rawColorSpace
Initializes a new PDFDeviceNColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rawColorSpace As PDFArray _
)
Visual Basic (Usage) Copy Code
Dim rawColorSpace As PDFArray

Dim instance As PDFDeviceNColorSpace(rawColorSpace)
C#
public PDFDeviceNColorSpace(
   PDFArray rawColorSpace
)
Managed Extensions for C++
public: PDFDeviceNColorSpace(
   PDFArray* rawColorSpace
)
C++/CLI
public:
PDFDeviceNColorSpace(
   PDFArray^ rawColorSpace
)

Parameters

rawColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members
Overload List


PDFDeviceNColorSpace Class Properties

PDFDeviceNColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorSpace Class

For a list of all members of this type, see PDFDeviceNColorSpace members.

Public Properties

 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | Attributes | Gets the attributes associated with this colorsspace.
Public Property | ColorantNames | Gets the collection of colorant names included in this DeviceN colorspace.
Public Property | TintTransform | Gets or sets the tint transform function for the this colorspace.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Top

See Also

Reference

PDFDeviceNColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


AlternateColorSpace Property

AlternateColorSpace Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class : AlternateColorSpace Property

Gets or sets the alternate colorspace.

Syntax

Visual Basic (Declaration)
Public Property AlternateColorSpace As PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorSpace
Dim value As PDFColorSpace

instance.AlternateColorSpace = value

value = instance.AlternateColorSpace
C#
public PDFColorSpace AlternateColorSpace {get; set;}
Managed Extensions for C++
public: __property PDFColorSpace* get_AlternateColorSpace();
public: __property void set_AlternateColorSpace(
   PDFColorSpace* value
);
C++/CLI
public:
property PDFColorSpace^ AlternateColorSpace {
   PDFColorSpace^ get();
   void set (PDFColorSpace^ value);
}

Return Value

The alternate color space to be used when the destination device does not support DeviceN colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members


Attributes Property

Attributes Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class : Attributes Property

Gets the attributes associated with this colorsspace.

Syntax

Visual Basic (Declaration)
Public Property Attributes As PDFDeviceNAttributes
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorSpace
Dim value As PDFDeviceNAttributes

instance.Attributes = value

value = instance.Attributes
C#
public PDFDeviceNAttributes Attributes {get; set;}
Managed Extensions for C++
public: __property PDFDeviceNAttributes* get_Attributes();
public: __property void set_Attributes(
   PDFDeviceNAttributes* value
);
C++/CLI
public:
property PDFDeviceNAttributes^ Attributes {
   PDFDeviceNAttributes^ get();
   void set (PDFDeviceNAttributes^ value);
}

Return Value

The attributes of the colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members


ColorantNames Property

ColorantNames Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class : ColorantNames Property

Gets the collection of colorant names included in this DeviceN colorspace.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColorantNames As PDFDeviceNColorNameCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorSpace
Dim value As PDFDeviceNColorNameCollection

value = instance.ColorantNames
C#
public PDFDeviceNColorNameCollection ColorantNames {get;}
Managed Extensions for C++
public: __property PDFDeviceNColorNameCollection* get_ColorantNames();
C++/CLI
public:
property PDFDeviceNColorNameCollection^ ColorantNames {
   PDFDeviceNColorNameCollection^ get();
}

Return Value

The list of colorant names.

Remarks

If this list is empty, the library will build it automatically from the names of the separation colorspaces included in this colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members


TintTransform Property

TintTransform Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFDeviceNColorSpace Class : TintTransform Property

Gets or sets the tint transform function for the this colorspace.

Syntax

Visual Basic (Declaration)
Public Property TintTransform As PDFFunction
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceNColorSpace
Dim value As PDFFunction

instance.TintTransform = value

value = instance.TintTransform
C#
public PDFFunction TintTransform {get; set;}
Managed Extensions for C++
public: __property PDFFunction* get_TintTransform();
public: __property void set_TintTransform(
   PDFFunction* value
);
C++/CLI
public:
property PDFFunction^ TintTransform {
   PDFFunction^ get();
   void set (PDFFunction^ value);
}

Return Value

Tint transform function for the colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDeviceNColorSpace Class
PDFDeviceNColorSpace Members


PDFICCColorSpace Class

PDFICCColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFICCColorSpace Class

Defines an ICC based colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFICCColorSpace
   Inherits PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColorSpace
C#
public class PDFICCColorSpace : PDFColorSpace
Managed Extensions for C++
public __gc class PDFICCColorSpace : public PDFColorSpace
C++/CLI
public ref class PDFICCColorSpace : public PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFICCColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFICCColorSpace Class Members

PDFICCColorSpace Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFICCColorSpace Class

The following tables list the members exposed by PDFICCColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFICCColorSpace Constructor | Initializes a new PDFICCColorSpace object.
Top

Public Properties

 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | ColorComponents | Gets or sets the number of color components in the ICC colorspace.
Public Property | ProfileData | Gets or sets the profile data.
Public Property | Range | Gets or sets the range for color components.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Top

See Also

Reference

PDFICCColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFICCColorSpace Constructor

PDFICCColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : PDFICCColorSpace Constructor

Initializes a new PDFICCColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColorSpace()
C#
public PDFICCColorSpace()
Managed Extensions for C++
public: PDFICCColorSpace();
C++/CLI
public:
PDFICCColorSpace();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


PDFICCColorSpace Class Properties

PDFICCColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFICCColorSpace Class

For a list of all members of this type, see PDFICCColorSpace members.

Public Properties

 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | ColorComponents | Gets or sets the number of color components in the ICC colorspace.
Public Property | ProfileData | Gets or sets the profile data.
Public Property | Range | Gets or sets the range for color components.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Top

See Also

Reference

PDFICCColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


AlternateColorSpace Property

AlternateColorSpace Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : AlternateColorSpace Property

Gets or sets the alternate colorspace.

Syntax

Visual Basic (Declaration)
Public Property AlternateColorSpace As PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColorSpace
Dim value As PDFColorSpace

instance.AlternateColorSpace = value

value = instance.AlternateColorSpace
C#
public PDFColorSpace AlternateColorSpace {get; set;}
Managed Extensions for C++
public: __property PDFColorSpace* get_AlternateColorSpace();
public: __property void set_AlternateColorSpace(
   PDFColorSpace* value
);
C++/CLI
public:
property PDFColorSpace^ AlternateColorSpace {
   PDFColorSpace^ get();
   void set (PDFColorSpace^ value);
}

Return Value

The alternate color space to be used in case the one specified in the stream data is not supported

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


ColorComponents Property

ColorComponents Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : ColorComponents Property

Gets or sets the number of color components in the ICC colorspace.

Syntax

Visual Basic (Declaration)
Public Property ColorComponents As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColorSpace
Dim value As Integer

instance.ColorComponents = value

value = instance.ColorComponents
C#
public int ColorComponents {get; set;}
Managed Extensions for C++
public: __property int get_ColorComponents();
public: __property void set_ColorComponents(
   int value
);
C++/CLI
public:
property int ColorComponents {
   int get();
   void set (int value);
}

Return Value

The number of color components in the color space described by the ICC profile data.

Remarks

This number must match the number of components actually in the ICC profile. As of PDF 1.4, this value must be 1, 3 or 4.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


ProfileData Property

ProfileData Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : ProfileData Property

Gets or sets the profile data.

Syntax

Visual Basic (Declaration)
Public Property ProfileData As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColorSpace
Dim value() As Byte

instance.ProfileData = value

value = instance.ProfileData
C#
public byte[] ProfileData {get; set;}
Managed Extensions for C++
public: __property byte[]* get_ProfileData();
public: __property void set_ProfileData(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ ProfileData {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

The ICC profile data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


Range Property

Range Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFICCColorSpace Class : Range Property

Gets or sets the range for color components.

Syntax

Visual Basic (Declaration)
Public Property Range As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFICCColorSpace
Dim value() As Double

instance.Range = value

value = instance.Range
C#
public double[] Range {get; set;}
Managed Extensions for C++
public: __property double[]* get_Range();
public: __property void set_Range(
   double[]* value
);
C++/CLI
public:
property array<double>^ Range {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of 2 * PDFICCColorSpace.ColorComponents numbers [ min0 max0 min1 max1 ... ] specifying the minimum and maximum valid values of the corresponding color components. These values must match the information in the ICC profile.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFICCColorSpace Class
PDFICCColorSpace Members


PDFIndexedColorSpace Class

PDFIndexedColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFIndexedColorSpace Class

Defines an indexed colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFIndexedColorSpace
   Inherits PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColorSpace
C#
public class PDFIndexedColorSpace : PDFColorSpace
Managed Extensions for C++
public __gc class PDFIndexedColorSpace : public PDFColorSpace
C++/CLI
public ref class PDFIndexedColorSpace : public PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFIndexedColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFIndexedColorSpace Class Members

PDFIndexedColorSpace Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFIndexedColorSpace Class

The following tables list the members exposed by PDFIndexedColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFIndexedColorSpace Constructor | Overloaded. Initializes a new PDFIndexedColorSpace object.
Top

Public Properties

 | Name | Description
Public Property | BaseColorSpace | Gets or sets the base colorspace.
Public Property | ColorTable | Gets or sets the color table.
Public Property | MaxIndex | Gets or sets the maximum index for the colors in the color table.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Top

See Also

Reference

PDFIndexedColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFIndexedColorSpace Constructor

PDFIndexedColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class : PDFIndexedColorSpace Constructor

Initializes a new PDFIndexedColorSpace object.

Overload List

Overload | Description
PDFIndexedColorSpace Constructor() | Initializes a new PDFIndexedColorSpace object.
PDFIndexedColorSpace Constructor(PDFArray) | Initializes a new PDFIndexedColorSpace object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members


PDFIndexedColorSpace Constructor()

PDFIndexedColorSpace Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class > PDFIndexedColorSpace Constructor : PDFIndexedColorSpace Constructor()

Initializes a new PDFIndexedColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColorSpace()
C#
public PDFIndexedColorSpace()
Managed Extensions for C++
public: PDFIndexedColorSpace();
C++/CLI
public:
PDFIndexedColorSpace();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members
Overload List


PDFIndexedColorSpace Constructor(PDFArray)

PDFIndexedColorSpace Constructor(PDFArray)
See Also
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class > PDFIndexedColorSpace Constructor : PDFIndexedColorSpace Constructor(PDFArray)

rawColorSpace
Initializes a new PDFIndexedColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rawColorSpace As PDFArray _
)
Visual Basic (Usage) Copy Code
Dim rawColorSpace As PDFArray

Dim instance As PDFIndexedColorSpace(rawColorSpace)
C#
public PDFIndexedColorSpace(
   PDFArray rawColorSpace
)
Managed Extensions for C++
public: PDFIndexedColorSpace(
   PDFArray* rawColorSpace
)
C++/CLI
public:
PDFIndexedColorSpace(
   PDFArray^ rawColorSpace
)

Parameters

rawColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members
Overload List


PDFIndexedColorSpace Class Properties

PDFIndexedColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFIndexedColorSpace Class

For a list of all members of this type, see PDFIndexedColorSpace members.

Public Properties

 | Name | Description
Public Property | BaseColorSpace | Gets or sets the base colorspace.
Public Property | ColorTable | Gets or sets the color table.
Public Property | MaxIndex | Gets or sets the maximum index for the colors in the color table.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Top

See Also

Reference

PDFIndexedColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


BaseColorSpace Property

BaseColorSpace Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class : BaseColorSpace Property

Gets or sets the base colorspace.

Syntax

Visual Basic (Declaration)
Public Property BaseColorSpace As PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColorSpace
Dim value As PDFColorSpace

instance.BaseColorSpace = value

value = instance.BaseColorSpace
C#
public PDFColorSpace BaseColorSpace {get; set;}
Managed Extensions for C++
public: __property PDFColorSpace* get_BaseColorSpace();
public: __property void set_BaseColorSpace(
   PDFColorSpace* value
);
C++/CLI
public:
property PDFColorSpace^ BaseColorSpace {
   PDFColorSpace^ get();
   void set (PDFColorSpace^ value);
}

Return Value

The color space in which the values in the color table are to be interpreted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members


ColorTable Property

ColorTable Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class : ColorTable Property

Gets or sets the color table.

Syntax

Visual Basic (Declaration)
Public Property ColorTable As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColorSpace
Dim value() As Byte

instance.ColorTable = value

value = instance.ColorTable
C#
public byte[] ColorTable {get; set;}
Managed Extensions for C++
public: __property byte[]* get_ColorTable();
public: __property void set_ColorTable(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ ColorTable {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

The table of color components.

Remarks

The color table data must be m * (maxIndex + 1) bytes long, where m is the number of color components in the base color space. Each byte is an unsigned integer in the range 0 to 255 that is scaled to the range of the corresponding color component in the base color space; that is, 0 corresponds to the minimum value in the range for that component, and 255 corresponds to the maximum.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members


MaxIndex Property

MaxIndex Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFIndexedColorSpace Class : MaxIndex Property

Gets or sets the maximum index for the colors in the color table.

Syntax

Visual Basic (Declaration)
Public Property MaxIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFIndexedColorSpace
Dim value As Integer

instance.MaxIndex = value

value = instance.MaxIndex
C#
public int MaxIndex {get; set;}
Managed Extensions for C++
public: __property int get_MaxIndex();
public: __property void set_MaxIndex(
   int value
);
C++/CLI
public:
property int MaxIndex {
   int get();
   void set (int value);
}

Return Value

The maximum index that can be used to access the values in the color table.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFIndexedColorSpace Class
PDFIndexedColorSpace Members


PDFLabColorSpace Class

PDFLabColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFLabColorSpace Class

Defines a Lab colorspace.

Syntax

Visual Basic (Declaration)
Public Class PDFLabColorSpace
   Inherits PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColorSpace
C#
public class PDFLabColorSpace : PDFColorSpace
Managed Extensions for C++
public __gc class PDFLabColorSpace : public PDFColorSpace
C++/CLI
public ref class PDFLabColorSpace : public PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFLabColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFLabColorSpace Class Members

PDFLabColorSpace Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFLabColorSpace Class

The following tables list the members exposed by PDFLabColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFLabColorSpace Constructor | Initializes a new PDFLabColorSpace object.
Top

Public Properties

 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Range | Gets or sets the range.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top

See Also

Reference

PDFLabColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFLabColorSpace Constructor

PDFLabColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColorSpace Class : PDFLabColorSpace Constructor

Initializes a new PDFLabColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColorSpace()
C#
public PDFLabColorSpace()
Managed Extensions for C++
public: PDFLabColorSpace();
C++/CLI
public:
PDFLabColorSpace();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColorSpace Class
PDFLabColorSpace Members


PDFLabColorSpace Class Properties

PDFLabColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFLabColorSpace Class

For a list of all members of this type, see PDFLabColorSpace members.

Public Properties

 | Name | Description
Public Property | BlackPoint | Gets or sets the black point.
Public Property | Range | Gets or sets the range.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Public Property | WhitePoint | Gets or sets the white point.
Top

See Also

Reference

PDFLabColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


BlackPoint Property

BlackPoint Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColorSpace Class : BlackPoint Property

Gets or sets the black point.

Syntax

Visual Basic (Declaration)
Public Property BlackPoint As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColorSpace
Dim value() As Double

instance.BlackPoint = value

value = instance.BlackPoint
C#
public double[] BlackPoint {get; set;}
Managed Extensions for C++
public: __property double[]* get_BlackPoint();
public: __property void set_BlackPoint(
   double[]* value
);
C++/CLI
public:
property array<double>^ BlackPoint {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of three numbers [XB YB ZB] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse black point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColorSpace Class
PDFLabColorSpace Members


Range Property

Range Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColorSpace Class : Range Property

Gets or sets the range.

Syntax

Visual Basic (Declaration)
Public Property Range As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColorSpace
Dim value() As Double

instance.Range = value

value = instance.Range
C#
public double[] Range {get; set;}
Managed Extensions for C++
public: __property double[]* get_Range();
public: __property void set_Range(
   double[]* value
);
C++/CLI
public:
property array<double>^ Range {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of four numbers [amin amax bmin bmax] specifying the range of valid values for the a* and b* (B and C) components of the color space.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColorSpace Class
PDFLabColorSpace Members


WhitePoint Property

WhitePoint Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFLabColorSpace Class : WhitePoint Property

Gets or sets the white point.

Syntax

Visual Basic (Declaration)
Public Property WhitePoint As Double()
Visual Basic (Usage) Copy Code
Dim instance As PDFLabColorSpace
Dim value() As Double

instance.WhitePoint = value

value = instance.WhitePoint
C#
public double[] WhitePoint {get; set;}
Managed Extensions for C++
public: __property double[]* get_WhitePoint();
public: __property void set_WhitePoint(
   double[]* value
);
C++/CLI
public:
property array<double>^ WhitePoint {
   array<double>^ get();
   void set (doublearray<value>^ value);
}

Return Value

An array of three numbers [XW YW ZW] specifying the tristimulus value, in the CIE 1931 XYZ space, of the diffuse white point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFLabColorSpace Class
PDFLabColorSpace Members


PDFPantoneColor Class

PDFPantoneColor Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPantoneColor Class

Defines a PANTONE color.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPantoneColor
   Inherits PDFSeparationColor
Visual Basic (Usage) Copy Code
Dim instance As PDFPantoneColor
C#
public class PDFPantoneColor : PDFSeparationColor
Managed Extensions for C++
public __gc class PDFPantoneColor : public PDFSeparationColor
C++/CLI
public ref class PDFPantoneColor : public PDFSeparationColor

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.PDFColor
O2S.Components.PDF4NET.Graphics.PDFSeparationColor
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFPantoneColor

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFPantoneColor Class Members

PDFPantoneColor Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPantoneColor Class

The following tables list the members exposed by PDFPantoneColor.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Black | Gets the PANTONE Black color.
static (Shared in Visual Basic) | Black2 | Gets the PANTONE Black 2 color.
static (Shared in Visual Basic) | Black3 | Gets the PANTONE Black 3 color.
static (Shared in Visual Basic) | Black4 | Gets the PANTONE Black 4 color.
static (Shared in Visual Basic) | Black5 | Gets the PANTONE Black 5 color.
static (Shared in Visual Basic) | Black6 | Gets the PANTONE Black 6 color.
static (Shared in Visual Basic) | Black7 | Gets the PANTONE Black 7 color.
static (Shared in Visual Basic) | Blue072 | Gets the PANTONE Blue 072 color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
static (Shared in Visual Basic) | CoolGray1 | Gets the PANTONE Cool Gray 1 color.
static (Shared in Visual Basic) | CoolGray10 | Gets the PANTONE Cool Gray 10 color.
static (Shared in Visual Basic) | CoolGray11 | Gets the PANTONE Cool Gray 11 color.
static (Shared in Visual Basic) | CoolGray2 | Gets the PANTONE Cool Gray 2 color.
static (Shared in Visual Basic) | CoolGray3 | Gets the PANTONE Cool Gray 3 color.
static (Shared in Visual Basic) | CoolGray4 | Gets the PANTONE Cool Gray 4 color.
static (Shared in Visual Basic) | CoolGray5 | Gets the PANTONE Cool Gray 5 color.
static (Shared in Visual Basic) | CoolGray6 | Gets the PANTONE Cool Gray 6 color.
static (Shared in Visual Basic) | CoolGray7 | Gets the PANTONE Cool Gray 7 color.
static (Shared in Visual Basic) | CoolGray8 | Gets the PANTONE Cool Gray 8 color.
static (Shared in Visual Basic) | CoolGray9 | Gets the PANTONE Cool Gray 9 color.
static (Shared in Visual Basic) | Green | Gets the PANTONE Green color.
static (Shared in Visual Basic) | HexachromeBlack | Gets the PANTONE Hexachrome Black color.
static (Shared in Visual Basic) | HexachromeCyan | Gets the PANTONE Hexachrome Cyan color.
static (Shared in Visual Basic) | HexachromeGreen | Gets the PANTONE Hexachrome Green color.
static (Shared in Visual Basic) | HexachromeMagenta | Gets the PANTONE Hexachrome Magenta color.
static (Shared in Visual Basic) | HexachromeOrange | Gets the PANTONE Hexachrome Orange color.
static (Shared in Visual Basic) | HexachromeYellow | Gets the PANTONE Hexachrome Yellow color.
static (Shared in Visual Basic) | Orange021 | Gets the PANTONE Orange 021 color.
static (Shared in Visual Basic) | PANTONE100 | Gets the PANTONE 100 color.
static (Shared in Visual Basic) | PANTONE101 | Gets the PANTONE 101 color.
static (Shared in Visual Basic) | PANTONE102 | Gets the PANTONE 102 color.
static (Shared in Visual Basic) | PANTONE103 | Gets the PANTONE 103 color.
static (Shared in Visual Basic) | PANTONE104 | Gets the PANTONE 104 color.
static (Shared in Visual Basic) | PANTONE105 | Gets the PANTONE 105 color.
static (Shared in Visual Basic) | PANTONE106 | Gets the PANTONE 106 color.
static (Shared in Visual Basic) | PANTONE107 | Gets the PANTONE 107 color.
static (Shared in Visual Basic) | PANTONE108 | Gets the PANTONE 108 color.
static (Shared in Visual Basic) | PANTONE109 | Gets the PANTONE 109 color.
static (Shared in Visual Basic) | PANTONE110 | Gets the PANTONE 110 color.
static (Shared in Visual Basic) | PANTONE111 | Gets the PANTONE 111 color.
static (Shared in Visual Basic) | PANTONE112 | Gets the PANTONE 112 color.
static (Shared in Visual Basic) | PANTONE113 | Gets the PANTONE 113 color.
static (Shared in Visual Basic) | PANTONE114 | Gets the PANTONE 114 color.
static (Shared in Visual Basic) | PANTONE115 | Gets the PANTONE 115 color.
static (Shared in Visual Basic) | PANTONE116 | Gets the PANTONE 116 color.
static (Shared in Visual Basic) | PANTONE117 | Gets the PANTONE 117 color.
static (Shared in Visual Basic) | PANTONE118 | Gets the PANTONE 118 color.
static (Shared in Visual Basic) | PANTONE119 | Gets the PANTONE 119 color.
static (Shared in Visual Basic) | PANTONE120 | Gets the PANTONE 120 color.
static (Shared in Visual Basic) | PANTONE1205 | Gets the PANTONE 1205 color.
static (Shared in Visual Basic) | PANTONE121 | Gets the PANTONE 121 color.
static (Shared in Visual Basic) | PANTONE1215 | Gets the PANTONE 1215 color.
static (Shared in Visual Basic) | PANTONE122 | Gets the PANTONE 122 color.
static (Shared in Visual Basic) | PANTONE1225 | Gets the PANTONE 1225 color.
static (Shared in Visual Basic) | PANTONE123 | Gets the PANTONE 123 color.
static (Shared in Visual Basic) | PANTONE1235 | Gets the PANTONE 1235 color.
static (Shared in Visual Basic) | PANTONE124 | Gets the PANTONE 124 color.
static (Shared in Visual Basic) | PANTONE1245 | Gets the PANTONE 1245 color.
static (Shared in Visual Basic) | PANTONE125 | Gets the PANTONE 125 color.
static (Shared in Visual Basic) | PANTONE1255 | Gets the PANTONE 1255 color.
static (Shared in Visual Basic) | PANTONE126 | Gets the PANTONE 126 color.
static (Shared in Visual Basic) | PANTONE1265 | Gets the PANTONE 1265 color.
static (Shared in Visual Basic) | PANTONE127 | Gets the PANTONE 127 color.
static (Shared in Visual Basic) | PANTONE128 | Gets the PANTONE 128 color.
static (Shared in Visual Basic) | PANTONE129 | Gets the PANTONE 129 color.
static (Shared in Visual Basic) | PANTONE130 | Gets the PANTONE 130 color.
static (Shared in Visual Basic) | PANTONE131 | Gets the PANTONE 131 color.
static (Shared in Visual Basic) | PANTONE132 | Gets the PANTONE 132 color.
static (Shared in Visual Basic) | PANTONE133 | Gets the PANTONE 133 color.
static (Shared in Visual Basic) | PANTONE134 | Gets the PANTONE 134 color.
static (Shared in Visual Basic) | PANTONE1345 | Gets the PANTONE 1345 color.
static (Shared in Visual Basic) | PANTONE135 | Gets the PANTONE 135 color.
static (Shared in Visual Basic) | PANTONE1355 | Gets the PANTONE 1355 color.
static (Shared in Visual Basic) | PANTONE136 | Gets the PANTONE 136 color.
static (Shared in Visual Basic) | PANTONE1365 | Gets the PANTONE 1365 color.
static (Shared in Visual Basic) | PANTONE137 | Gets the PANTONE 137 color.
static (Shared in Visual Basic) | PANTONE1375 | Gets the PANTONE 1375 color.
static (Shared in Visual Basic) | PANTONE138 | Gets the PANTONE 138 color.
static (Shared in Visual Basic) | PANTONE1385 | Gets the PANTONE 1385 color.
static (Shared in Visual Basic) | PANTONE139 | Gets the PANTONE 139 color.
static (Shared in Visual Basic) | PANTONE1395 | Gets the PANTONE 1395 color.
static (Shared in Visual Basic) | PANTONE140 | Gets the PANTONE 140 color.
static (Shared in Visual Basic) | PANTONE1405 | Gets the PANTONE 1405 color.
static (Shared in Visual Basic) | PANTONE141 | Gets the PANTONE 141 color.
static (Shared in Visual Basic) | PANTONE142 | Gets the PANTONE 142 color.
static (Shared in Visual Basic) | PANTONE143 | Gets the PANTONE 143 color.
static (Shared in Visual Basic) | PANTONE144 | Gets the PANTONE 144 color.
static (Shared in Visual Basic) | PANTONE145 | Gets the PANTONE 145 color.
static (Shared in Visual Basic) | PANTONE146 | Gets the PANTONE 146 color.
static (Shared in Visual Basic) | PANTONE147 | Gets the PANTONE 147 color.
static (Shared in Visual Basic) | PANTONE148 | Gets the PANTONE 148 color.
static (Shared in Visual Basic) | PANTONE1485 | Gets the PANTONE 1485 color.
static (Shared in Visual Basic) | PANTONE149 | Gets the PANTONE 149 color.
static (Shared in Visual Basic) | PANTONE1495 | Gets the PANTONE 1495 color.
static (Shared in Visual Basic) | PANTONE150 | Gets the PANTONE 150 color.
static (Shared in Visual Basic) | PANTONE1505 | Gets the PANTONE 1505 color.
static (Shared in Visual Basic) | PANTONE151 | Gets the PANTONE 151 color.
static (Shared in Visual Basic) | PANTONE152 | Gets the PANTONE 152 color.
static (Shared in Visual Basic) | PANTONE1525 | Gets the PANTONE 1525 color.
static (Shared in Visual Basic) | PANTONE153 | Gets the PANTONE 153 color.
static (Shared in Visual Basic) | PANTONE1535 | Gets the PANTONE 1535 color.
static (Shared in Visual Basic) | PANTONE154 | Gets the PANTONE 154 color.
static (Shared in Visual Basic) | PANTONE1545 | Gets the PANTONE 1545 color.
static (Shared in Visual Basic) | PANTONE155 | Gets the PANTONE 155 color.
static (Shared in Visual Basic) | PANTONE1555 | Gets the PANTONE 1555 color.
static (Shared in Visual Basic) | PANTONE156 | Gets the PANTONE 156 color.
static (Shared in Visual Basic) | PANTONE1565 | Gets the PANTONE 1565 color.
static (Shared in Visual Basic) | PANTONE157 | Gets the PANTONE 157 color.
static (Shared in Visual Basic) | PANTONE1575 | Gets the PANTONE 1575 color.
static (Shared in Visual Basic) | PANTONE158 | Gets the PANTONE 158 color.
static (Shared in Visual Basic) | PANTONE1585 | Gets the PANTONE 1585 color.
static (Shared in Visual Basic) | PANTONE159 | Gets the PANTONE 159 color.
static (Shared in Visual Basic) | PANTONE1595 | Gets the PANTONE 1595 color.
static (Shared in Visual Basic) | PANTONE160 | Gets the PANTONE 160 color.
static (Shared in Visual Basic) | PANTONE1605 | Gets the PANTONE 1605 color.
static (Shared in Visual Basic) | PANTONE161 | Gets the PANTONE 161 color.
static (Shared in Visual Basic) | PANTONE1615 | Gets the PANTONE 1615 color.
static (Shared in Visual Basic) | PANTONE162 | Gets the PANTONE 162 color.
static (Shared in Visual Basic) | PANTONE1625 | Gets the PANTONE 1625 color.
static (Shared in Visual Basic) | PANTONE163 | Gets the PANTONE 163 color.
static (Shared in Visual Basic) | PANTONE1635 | Gets the PANTONE 1635 color.
static (Shared in Visual Basic) | PANTONE164 | Gets the PANTONE 164 color.
static (Shared in Visual Basic) | PANTONE1645 | Gets the PANTONE 1645 color.
static (Shared in Visual Basic) | PANTONE165 | Gets the PANTONE 165 color.
static (Shared in Visual Basic) | PANTONE1655 | Gets the PANTONE 1655 color.
static (Shared in Visual Basic) | PANTONE166 | Gets the PANTONE 166 color.
static (Shared in Visual Basic) | PANTONE1665 | Gets the PANTONE 1665 color.
static (Shared in Visual Basic) | PANTONE167 | Gets the PANTONE 167 color.
static (Shared in Visual Basic) | PANTONE1675 | Gets the PANTONE 1675 color.
static (Shared in Visual Basic) | PANTONE168 | Gets the PANTONE 168 color.
static (Shared in Visual Basic) | PANTONE1685 | Gets the PANTONE 1685 color.
static (Shared in Visual Basic) | PANTONE169 | Gets the PANTONE 169 color.
static (Shared in Visual Basic) | PANTONE170 | Gets the PANTONE 170 color.
static (Shared in Visual Basic) | PANTONE171 | Gets the PANTONE 171 color.
static (Shared in Visual Basic) | PANTONE172 | Gets the PANTONE 172 color.
static (Shared in Visual Basic) | PANTONE173 | Gets the PANTONE 173 color.
static (Shared in Visual Basic) | PANTONE174 | Gets the PANTONE 174 color.
static (Shared in Visual Basic) | PANTONE175 | Gets the PANTONE 175 color.
static (Shared in Visual Basic) | PANTONE176 | Gets the PANTONE 176 color.
static (Shared in Visual Basic) | PANTONE1765 | Gets the PANTONE 1765 color.
static (Shared in Visual Basic) | PANTONE1767 | Gets the PANTONE 1767 color.
static (Shared in Visual Basic) | PANTONE177 | Gets the PANTONE 177 color.
static (Shared in Visual Basic) | PANTONE1775 | Gets the PANTONE 1775 color.
static (Shared in Visual Basic) | PANTONE1777 | Gets the PANTONE 1777 color.
static (Shared in Visual Basic) | PANTONE178 | Gets the PANTONE 178 color.
static (Shared in Visual Basic) | PANTONE1785 | Gets the PANTONE 1785 color.
static (Shared in Visual Basic) | PANTONE1787 | Gets the PANTONE 1787 color.
static (Shared in Visual Basic) | PANTONE1788 | Gets the PANTONE 1788 color.
static (Shared in Visual Basic) | PANTONE179 | Gets the PANTONE 179 color.
static (Shared in Visual Basic) | PANTONE1795 | Gets the PANTONE 1795 color.
static (Shared in Visual Basic) | PANTONE1797 | Gets the PANTONE 1797 color.
static (Shared in Visual Basic) | PANTONE180 | Gets the PANTONE 180 color.
static (Shared in Visual Basic) | PANTONE1805 | Gets the PANTONE 1805 color.
static (Shared in Visual Basic) | PANTONE1807 | Gets the PANTONE 1807 color.
static (Shared in Visual Basic) | PANTONE181 | Gets the PANTONE 181 color.
static (Shared in Visual Basic) | PANTONE1815 | Gets the PANTONE 1815 color.
static (Shared in Visual Basic) | PANTONE1817 | Gets the PANTONE 1817 color.
static (Shared in Visual Basic) | PANTONE182 | Gets the PANTONE 182 color.
static (Shared in Visual Basic) | PANTONE183 | Gets the PANTONE 183 color.
static (Shared in Visual Basic) | PANTONE184 | Gets the PANTONE 184 color.
static (Shared in Visual Basic) | PANTONE185 | Gets the PANTONE 185 color.
static (Shared in Visual Basic) | PANTONE186 | Gets the PANTONE 186 color.
static (Shared in Visual Basic) | PANTONE187 | Gets the PANTONE 187 color.
static (Shared in Visual Basic) | PANTONE188 | Gets the PANTONE 188 color.
static (Shared in Visual Basic) | PANTONE189 | Gets the PANTONE 189 color.
static (Shared in Visual Basic) | PANTONE1895 | Gets the PANTONE 1895 color.
static (Shared in Visual Basic) | PANTONE190 | Gets the PANTONE 190 color.
static (Shared in Visual Basic) | PANTONE1905 | Gets the PANTONE 1905 color.
static (Shared in Visual Basic) | PANTONE191 | Gets the PANTONE 191 color.
static (Shared in Visual Basic) | PANTONE1915 | Gets the PANTONE 1915 color.
static (Shared in Visual Basic) | PANTONE192 | Gets the PANTONE 192 color.
static (Shared in Visual Basic) | PANTONE1925 | Gets the PANTONE 1925 color.
static (Shared in Visual Basic) | PANTONE193 | Gets the PANTONE 193 color.
static (Shared in Visual Basic) | PANTONE1935 | Gets the PANTONE 1935 color.
static (Shared in Visual Basic) | PANTONE194 | Gets the PANTONE 194 color.
static (Shared in Visual Basic) | PANTONE1945 | Gets the PANTONE 1945 color.
static (Shared in Visual Basic) | PANTONE195 | Gets the PANTONE 195 color.
static (Shared in Visual Basic) | PANTONE1955 | Gets the PANTONE 1955 color.
static (Shared in Visual Basic) | PANTONE196 | Gets the PANTONE 196 color.
static (Shared in Visual Basic) | PANTONE197 | Gets the PANTONE 197 color.
static (Shared in Visual Basic) | PANTONE198 | Gets the PANTONE 198 color.
static (Shared in Visual Basic) | PANTONE199 | Gets the PANTONE 199 color.
static (Shared in Visual Basic) | PANTONE200 | Gets the PANTONE 200 color.
static (Shared in Visual Basic) | PANTONE201 | Gets the PANTONE 201 color.
static (Shared in Visual Basic) | PANTONE202 | Gets the PANTONE 202 color.
static (Shared in Visual Basic) | PANTONE203 | Gets the PANTONE 203 color.
static (Shared in Visual Basic) | PANTONE204 | Gets the PANTONE 204 color.
static (Shared in Visual Basic) | PANTONE205 | Gets the PANTONE 205 color.
static (Shared in Visual Basic) | PANTONE206 | Gets the PANTONE 206 color.
static (Shared in Visual Basic) | PANTONE207 | Gets the PANTONE 207 color.
static (Shared in Visual Basic) | PANTONE208 | Gets the PANTONE 208 color.
static (Shared in Visual Basic) | PANTONE209 | Gets the PANTONE 209 color.
static (Shared in Visual Basic) | PANTONE210 | Gets the PANTONE 210 color.
static (Shared in Visual Basic) | PANTONE211 | Gets the PANTONE 211 color.
static (Shared in Visual Basic) | PANTONE212 | Gets the PANTONE 212 color.
static (Shared in Visual Basic) | PANTONE213 | Gets the PANTONE 213 color.
static (Shared in Visual Basic) | PANTONE214 | Gets the PANTONE 214 color.
static (Shared in Visual Basic) | PANTONE215 | Gets the PANTONE 215 color.
static (Shared in Visual Basic) | PANTONE216 | Gets the PANTONE 216 color.
static (Shared in Visual Basic) | PANTONE217 | Gets the PANTONE 217 color.
static (Shared in Visual Basic) | PANTONE218 | Gets the PANTONE 218 color.
static (Shared in Visual Basic) | PANTONE219 | Gets the PANTONE 219 color.
static (Shared in Visual Basic) | PANTONE220 | Gets the PANTONE 220 color.
static (Shared in Visual Basic) | PANTONE221 | Gets the PANTONE 221 color.
static (Shared in Visual Basic) | PANTONE222 | Gets the PANTONE 222 color.
static (Shared in Visual Basic) | PANTONE223 | Gets the PANTONE 223 color.
static (Shared in Visual Basic) | PANTONE224 | Gets the PANTONE 224 color.
static (Shared in Visual Basic) | PANTONE225 | Gets the PANTONE 225 color.
static (Shared in Visual Basic) | PANTONE226 | Gets the PANTONE 226 color.
static (Shared in Visual Basic) | PANTONE227 | Gets the PANTONE 227 color.
static (Shared in Visual Basic) | PANTONE228 | Gets the PANTONE 228 color.
static (Shared in Visual Basic) | PANTONE229 | Gets the PANTONE 229 color.
static (Shared in Visual Basic) | PANTONE230 | Gets the PANTONE 230 color.
static (Shared in Visual Basic) | PANTONE231 | Gets the PANTONE 231 color.
static (Shared in Visual Basic) | PANTONE232 | Gets the PANTONE 232 color.
static (Shared in Visual Basic) | PANTONE233 | Gets the PANTONE 233 color.
static (Shared in Visual Basic) | PANTONE234 | Gets the PANTONE 234 color.
static (Shared in Visual Basic) | PANTONE235 | Gets the PANTONE 235 color.
static (Shared in Visual Basic) | PANTONE236 | Gets the PANTONE 236 color.
static (Shared in Visual Basic) | PANTONE2365 | Gets the PANTONE 2365 color.
static (Shared in Visual Basic) | PANTONE237 | Gets the PANTONE 237 color.
static (Shared in Visual Basic) | PANTONE2375 | Gets the PANTONE 2375 color.
static (Shared in Visual Basic) | PANTONE238 | Gets the PANTONE 238 color.
static (Shared in Visual Basic) | PANTONE2385 | Gets the PANTONE 2385 color.
static (Shared in Visual Basic) | PANTONE239 | Gets the PANTONE 239 color.
static (Shared in Visual Basic) | PANTONE2395 | Gets the PANTONE 2395 color.
static (Shared in Visual Basic) | PANTONE240 | Gets the PANTONE 240 color.
static (Shared in Visual Basic) | PANTONE2405 | Gets the PANTONE 2405 color.
static (Shared in Visual Basic) | PANTONE241 | Gets the PANTONE 241 color.
static (Shared in Visual Basic) | PANTONE2415 | Gets the PANTONE 2415 color.
static (Shared in Visual Basic) | PANTONE242 | Gets the PANTONE 242 color.
static (Shared in Visual Basic) | PANTONE2425 | Gets the PANTONE 2425 color.
static (Shared in Visual Basic) | PANTONE243 | Gets the PANTONE 243 color.
static (Shared in Visual Basic) | PANTONE244 | Gets the PANTONE 244 color.
static (Shared in Visual Basic) | PANTONE245 | Gets the PANTONE 245 color.
static (Shared in Visual Basic) | PANTONE246 | Gets the PANTONE 246 color.
static (Shared in Visual Basic) | PANTONE247 | Gets the PANTONE 247 color.
static (Shared in Visual Basic) | PANTONE248 | Gets the PANTONE 248 color.
static (Shared in Visual Basic) | PANTONE249 | Gets the PANTONE 249 color.
static (Shared in Visual Basic) | PANTONE250 | Gets the PANTONE 250 color.
static (Shared in Visual Basic) | PANTONE251 | Gets the PANTONE 251 color.
static (Shared in Visual Basic) | PANTONE252 | Gets the PANTONE 252 color.
static (Shared in Visual Basic) | PANTONE253 | Gets the PANTONE 253 color.
static (Shared in Visual Basic) | PANTONE254 | Gets the PANTONE 254 color.
static (Shared in Visual Basic) | PANTONE255 | Gets the PANTONE 255 color.
static (Shared in Visual Basic) | PANTONE256 | Gets the PANTONE 256 color.
static (Shared in Visual Basic) | PANTONE2562 | Gets the PANTONE 2562 color.
static (Shared in Visual Basic) | PANTONE2563 | Gets the PANTONE 2563 color.
static (Shared in Visual Basic) | PANTONE2567 | Gets the PANTONE 2567 color.
static (Shared in Visual Basic) | PANTONE257 | Gets the PANTONE 257 color.
static (Shared in Visual Basic) | PANTONE2572 | Gets the PANTONE 2572 color.
static (Shared in Visual Basic) | PANTONE2573 | Gets the PANTONE 2573 color.
static (Shared in Visual Basic) | PANTONE2577 | Gets the PANTONE 2577 color.
static (Shared in Visual Basic) | PANTONE258 | Gets the PANTONE 258 color.
static (Shared in Visual Basic) | PANTONE2582 | Gets the PANTONE 2582 color.
static (Shared in Visual Basic) | PANTONE2583 | Gets the PANTONE 2583 color.
static (Shared in Visual Basic) | PANTONE2587 | Gets the PANTONE 2587 color.
static (Shared in Visual Basic) | PANTONE259 | Gets the PANTONE 259 color.
static (Shared in Visual Basic) | PANTONE2592 | Gets the PANTONE 2592 color.
static (Shared in Visual Basic) | PANTONE2593 | Gets the PANTONE 2593 color.
static (Shared in Visual Basic) | PANTONE2597 | Gets the PANTONE 2597 color.
static (Shared in Visual Basic) | PANTONE260 | Gets the PANTONE 260 color.
static (Shared in Visual Basic) | PANTONE2602 | Gets the PANTONE 2602 color.
static (Shared in Visual Basic) | PANTONE2603 | Gets the PANTONE 2603 color.
static (Shared in Visual Basic) | PANTONE2607 | Gets the PANTONE 2607 color.
static (Shared in Visual Basic) | PANTONE261 | Gets the PANTONE 261 color.
static (Shared in Visual Basic) | PANTONE2612 | Gets the PANTONE 2612 color.
static (Shared in Visual Basic) | PANTONE2613 | Gets the PANTONE 2613 color.
static (Shared in Visual Basic) | PANTONE2617 | Gets the PANTONE 2617 color.
static (Shared in Visual Basic) | PANTONE262 | Gets the PANTONE 262 color.
static (Shared in Visual Basic) | PANTONE2622 | Gets the PANTONE 2622 color.
static (Shared in Visual Basic) | PANTONE2623 | Gets the PANTONE 2623 color.
static (Shared in Visual Basic) | PANTONE2627 | Gets the PANTONE 2627 color.
static (Shared in Visual Basic) | PANTONE263 | Gets the PANTONE 263 color.
static (Shared in Visual Basic) | PANTONE2635 | Gets the PANTONE 2635 color.
static (Shared in Visual Basic) | PANTONE264 | Gets the PANTONE 264 color.
static (Shared in Visual Basic) | PANTONE2645 | Gets the PANTONE 2645 color.
static (Shared in Visual Basic) | PANTONE265 | Gets the PANTONE 265 color.
static (Shared in Visual Basic) | PANTONE2655 | Gets the PANTONE 2655 color.
static (Shared in Visual Basic) | PANTONE266 | Gets the PANTONE 266 color.
static (Shared in Visual Basic) | PANTONE2665 | Gets the PANTONE 2665 color.
static (Shared in Visual Basic) | PANTONE267 | Gets the PANTONE 267 color.
static (Shared in Visual Basic) | PANTONE268 | Gets the PANTONE 268 color.
static (Shared in Visual Basic) | PANTONE2685 | Gets the PANTONE 2685 color.
static (Shared in Visual Basic) | PANTONE269 | Gets the PANTONE 269 color.
static (Shared in Visual Basic) | PANTONE2695 | Gets the PANTONE 2695 color.
static (Shared in Visual Basic) | PANTONE270 | Gets the PANTONE 270 color.
static (Shared in Visual Basic) | PANTONE2705 | Gets the PANTONE 2705 color.
static (Shared in Visual Basic) | PANTONE2706 | Gets the PANTONE 2706 color.
static (Shared in Visual Basic) | PANTONE2707 | Gets the PANTONE 2707 color.
static (Shared in Visual Basic) | PANTONE2708 | Gets the PANTONE 2708 color.
static (Shared in Visual Basic) | PANTONE271 | Gets the PANTONE 271 color.
static (Shared in Visual Basic) | PANTONE2715 | Gets the PANTONE 2715 color.
static (Shared in Visual Basic) | PANTONE2716 | Gets the PANTONE 2716 color.
static (Shared in Visual Basic) | PANTONE2717 | Gets the PANTONE 2717 color.
static (Shared in Visual Basic) | PANTONE2718 | Gets the PANTONE 2718 color.
static (Shared in Visual Basic) | PANTONE272 | Gets the PANTONE 272 color.
static (Shared in Visual Basic) | PANTONE2725 | Gets the PANTONE 2725 color.
static (Shared in Visual Basic) | PANTONE2726 | Gets the PANTONE 2726 color.
static (Shared in Visual Basic) | PANTONE2727 | Gets the PANTONE 2727 color.
static (Shared in Visual Basic) | PANTONE2728 | Gets the PANTONE 2728 color.
static (Shared in Visual Basic) | PANTONE273 | Gets the PANTONE 273 color.
static (Shared in Visual Basic) | PANTONE2735 | Gets the PANTONE 2735 color.
static (Shared in Visual Basic) | PANTONE2736 | Gets the PANTONE 2736 color.
static (Shared in Visual Basic) | PANTONE2738 | Gets the PANTONE 2738 color.
static (Shared in Visual Basic) | PANTONE274 | Gets the PANTONE 274 color.
static (Shared in Visual Basic) | PANTONE2745 | Gets the PANTONE 2745 color.
static (Shared in Visual Basic) | PANTONE2746 | Gets the PANTONE 2746 color.
static (Shared in Visual Basic) | PANTONE2747 | Gets the PANTONE 2747 color.
static (Shared in Visual Basic) | PANTONE2748 | Gets the PANTONE 2748 color.
static (Shared in Visual Basic) | PANTONE275 | Gets the PANTONE 275 color.
static (Shared in Visual Basic) | PANTONE2755 | Gets the PANTONE 2755 color.
static (Shared in Visual Basic) | PANTONE2756 | Gets the PANTONE 2756 color.
static (Shared in Visual Basic) | PANTONE2757 | Gets the PANTONE 2757 color.
static (Shared in Visual Basic) | PANTONE2758 | Gets the PANTONE 2758 color.
static (Shared in Visual Basic) | PANTONE276 | Gets the PANTONE 276 color.
static (Shared in Visual Basic) | PANTONE2765 | Gets the PANTONE 2765 color.
static (Shared in Visual Basic) | PANTONE2766 | Gets the PANTONE 2766 color.
static (Shared in Visual Basic) | PANTONE2767 | Gets the PANTONE 2767 color.
static (Shared in Visual Basic) | PANTONE2768 | Gets the PANTONE 2768 color.
static (Shared in Visual Basic) | PANTONE277 | Gets the PANTONE 277 color.
static (Shared in Visual Basic) | PANTONE278 | Gets the PANTONE 278 color.
static (Shared in Visual Basic) | PANTONE279 | Gets the PANTONE 279 color.
static (Shared in Visual Basic) | PANTONE280 | Gets the PANTONE 280 color.
static (Shared in Visual Basic) | PANTONE281 | Gets the PANTONE 281 color.
static (Shared in Visual Basic) | PANTONE282 | Gets the PANTONE 282 color.
static (Shared in Visual Basic) | PANTONE283 | Gets the PANTONE 283 color.
static (Shared in Visual Basic) | PANTONE284 | Gets the PANTONE 284 color.
static (Shared in Visual Basic) | PANTONE285 | Gets the PANTONE 285 color.
static (Shared in Visual Basic) | PANTONE286 | Gets the PANTONE 286 color.
static (Shared in Visual Basic) | PANTONE287 | Gets the PANTONE 287 color.
static (Shared in Visual Basic) | PANTONE288 | Gets the PANTONE 288 color.
static (Shared in Visual Basic) | PANTONE289 | Gets the PANTONE 289 color.
static (Shared in Visual Basic) | PANTONE290 | Gets the PANTONE 290 color.
static (Shared in Visual Basic) | PANTONE2905 | Gets the PANTONE 2905 color.
static (Shared in Visual Basic) | PANTONE291 | Gets the PANTONE 291 color.
static (Shared in Visual Basic) | PANTONE2915 | Gets the PANTONE 2915 color.
static (Shared in Visual Basic) | PANTONE292 | Gets the PANTONE 292 color.
static (Shared in Visual Basic) | PANTONE2925 | Gets the PANTONE 2925 color.
static (Shared in Visual Basic) | PANTONE293 | Gets the PANTONE 293 color.
static (Shared in Visual Basic) | PANTONE2935 | Gets the PANTONE 2935 color.
static (Shared in Visual Basic) | PANTONE294 | Gets the PANTONE 294 color.
static (Shared in Visual Basic) | PANTONE2945 | Gets the PANTONE 2945 color.
static (Shared in Visual Basic) | PANTONE295 | Gets the PANTONE 295 color.
static (Shared in Visual Basic) | PANTONE2955 | Gets the PANTONE 2955 color.
static (Shared in Visual Basic) | PANTONE296 | Gets the PANTONE 296 color.
static (Shared in Visual Basic) | PANTONE2965 | Gets the PANTONE 2965 color.
static (Shared in Visual Basic) | PANTONE297 | Gets the PANTONE 297 color.
static (Shared in Visual Basic) | PANTONE2975 | Gets the PANTONE 2975 color.
static (Shared in Visual Basic) | PANTONE298 | Gets the PANTONE 298 color.
static (Shared in Visual Basic) | PANTONE2985 | Gets the PANTONE 2985 color.
static (Shared in Visual Basic) | PANTONE299 | Gets the PANTONE 299 color.
static (Shared in Visual Basic) | PANTONE2995 | Gets the PANTONE 2995 color.
static (Shared in Visual Basic) | PANTONE300 | Gets the PANTONE 300 color.
static (Shared in Visual Basic) | PANTONE3005 | Gets the PANTONE 3005 color.
static (Shared in Visual Basic) | PANTONE301 | Gets the PANTONE 301 color.
static (Shared in Visual Basic) | PANTONE3015 | Gets the PANTONE 3015 color.
static (Shared in Visual Basic) | PANTONE302 | Gets the PANTONE 302 color.
static (Shared in Visual Basic) | PANTONE3025 | Gets the PANTONE 3025 color.
static (Shared in Visual Basic) | PANTONE303 | Gets the PANTONE 303 color.
static (Shared in Visual Basic) | PANTONE3035 | Gets the PANTONE 3035 color.
static (Shared in Visual Basic) | PANTONE304 | Gets the PANTONE 304 color.
static (Shared in Visual Basic) | PANTONE305 | Gets the PANTONE 305 color.
static (Shared in Visual Basic) | PANTONE306 | Gets the PANTONE 306 color.
static (Shared in Visual Basic) | PANTONE307 | Gets the PANTONE 307 color.
static (Shared in Visual Basic) | PANTONE308 | Gets the PANTONE 308 color.
static (Shared in Visual Basic) | PANTONE309 | Gets the PANTONE 309 color.
static (Shared in Visual Basic) | PANTONE310 | Gets the PANTONE 310 color.
static (Shared in Visual Basic) | PANTONE3105 | Gets the PANTONE 3105 color.
static (Shared in Visual Basic) | PANTONE311 | Gets the PANTONE 311 color.
static (Shared in Visual Basic) | PANTONE3115 | Gets the PANTONE 3115 color.
static (Shared in Visual Basic) | PANTONE312 | Gets the PANTONE 312 color.
static (Shared in Visual Basic) | PANTONE3125 | Gets the PANTONE 3125 color.
static (Shared in Visual Basic) | PANTONE313 | Gets the PANTONE 313 color.
static (Shared in Visual Basic) | PANTONE3135 | Gets the PANTONE 3135 color.
static (Shared in Visual Basic) | PANTONE314 | Gets the PANTONE 314 color.
static (Shared in Visual Basic) | PANTONE3145 | Gets the PANTONE 3145 color.
static (Shared in Visual Basic) | PANTONE315 | Gets the PANTONE 315 color.
static (Shared in Visual Basic) | PANTONE3155 | Gets the PANTONE 3155 color.
static (Shared in Visual Basic) | PANTONE316 | Gets the PANTONE 316 color.
static (Shared in Visual Basic) | PANTONE3165 | Gets the PANTONE 3165 color.
static (Shared in Visual Basic) | PANTONE317 | Gets the PANTONE 317 color.
static (Shared in Visual Basic) | PANTONE318 | Gets the PANTONE 318 color.
static (Shared in Visual Basic) | PANTONE319 | Gets the PANTONE 319 color.
static (Shared in Visual Basic) | PANTONE320 | Gets the PANTONE 320 color.
static (Shared in Visual Basic) | PANTONE321 | Gets the PANTONE 321 color.
static (Shared in Visual Basic) | PANTONE322 | Gets the PANTONE 322 color.
static (Shared in Visual Basic) | PANTONE323 | Gets the PANTONE 323 color.
static (Shared in Visual Basic) | PANTONE324 | Gets the PANTONE 324 color.
static (Shared in Visual Basic) | PANTONE3242 | Gets the PANTONE 3242 color.
static (Shared in Visual Basic) | PANTONE3245 | Gets the PANTONE 3245 color.
static (Shared in Visual Basic) | PANTONE3248 | Gets the PANTONE 3248 color.
static (Shared in Visual Basic) | PANTONE325 | Gets the PANTONE 325 color.
static (Shared in Visual Basic) | PANTONE3252 | Gets the PANTONE 3252 color.
static (Shared in Visual Basic) | PANTONE3255 | Gets the PANTONE 3255 color.
static (Shared in Visual Basic) | PANTONE3258 | Gets the PANTONE 3258 color.
static (Shared in Visual Basic) | PANTONE326 | Gets the PANTONE 326 color.
static (Shared in Visual Basic) | PANTONE3262 | Gets the PANTONE 3262 color.
static (Shared in Visual Basic) | PANTONE3265 | Gets the PANTONE 3265 color.
static (Shared in Visual Basic) | PANTONE3268 | Gets the PANTONE 3268 color.
static (Shared in Visual Basic) | PANTONE327 | Gets the PANTONE 327 color.
static (Shared in Visual Basic) | PANTONE3272 | Gets the PANTONE 3272 color.
static (Shared in Visual Basic) | PANTONE3275 | Gets the PANTONE 3275 color.
static (Shared in Visual Basic) | PANTONE3278 | Gets the PANTONE 3278 color.
static (Shared in Visual Basic) | PANTONE328 | Gets the PANTONE 328 color.
static (Shared in Visual Basic) | PANTONE3282 | Gets the PANTONE 3282 color.
static (Shared in Visual Basic) | PANTONE3285 | Gets the PANTONE 3285 color.
static (Shared in Visual Basic) | PANTONE3288 | Gets the PANTONE 3288 color.
static (Shared in Visual Basic) | PANTONE329 | Gets the PANTONE 329 color.
static (Shared in Visual Basic) | PANTONE3292 | Gets the PANTONE 3292 color.
static (Shared in Visual Basic) | PANTONE3295 | Gets the PANTONE 3295 color.
static (Shared in Visual Basic) | PANTONE3298 | Gets the PANTONE 3298 color.
static (Shared in Visual Basic) | PANTONE330 | Gets the PANTONE 330 color.
static (Shared in Visual Basic) | PANTONE3302 | Gets the PANTONE 3302 color.
static (Shared in Visual Basic) | PANTONE3305 | Gets the PANTONE 3305 color.
static (Shared in Visual Basic) | PANTONE3308 | Gets the PANTONE 3308 color.
static (Shared in Visual Basic) | PANTONE331 | Gets the PANTONE 331 color.
static (Shared in Visual Basic) | PANTONE332 | Gets the PANTONE 332 color.
static (Shared in Visual Basic) | PANTONE333 | Gets the PANTONE 333 color.
static (Shared in Visual Basic) | PANTONE334 | Gets the PANTONE 334 color.
static (Shared in Visual Basic) | PANTONE335 | Gets the PANTONE 335 color.
static (Shared in Visual Basic) | PANTONE336 | Gets the PANTONE 336 color.
static (Shared in Visual Basic) | PANTONE337 | Gets the PANTONE 337 color.
static (Shared in Visual Basic) | PANTONE3375 | Gets the PANTONE 3375 color.
static (Shared in Visual Basic) | PANTONE338 | Gets the PANTONE 338 color.
static (Shared in Visual Basic) | PANTONE3385 | Gets the PANTONE 3385 color.
static (Shared in Visual Basic) | PANTONE339 | Gets the PANTONE 339 color.
static (Shared in Visual Basic) | PANTONE3395 | Gets the PANTONE 3395 color.
static (Shared in Visual Basic) | PANTONE340 | Gets the PANTONE 340 color.
static (Shared in Visual Basic) | PANTONE3405 | Gets the PANTONE 3405 color.
static (Shared in Visual Basic) | PANTONE341 | Gets the PANTONE 341 color.
static (Shared in Visual Basic) | PANTONE3415 | Gets the PANTONE 3415 color.
static (Shared in Visual Basic) | PANTONE342 | Gets the PANTONE 342 color.
static (Shared in Visual Basic) | PANTONE3425 | Gets the PANTONE 3425 color.
static (Shared in Visual Basic) | PANTONE343 | Gets the PANTONE 343 color.
static (Shared in Visual Basic) | PANTONE3435 | Gets the PANTONE 3435 color.
static (Shared in Visual Basic) | PANTONE344 | Gets the PANTONE 344 color.
static (Shared in Visual Basic) | PANTONE345 | Gets the PANTONE 345 color.
static (Shared in Visual Basic) | PANTONE346 | Gets the PANTONE 346 color.
static (Shared in Visual Basic) | PANTONE347 | Gets the PANTONE 347 color.
static (Shared in Visual Basic) | PANTONE348 | Gets the PANTONE 348 color.
static (Shared in Visual Basic) | PANTONE349 | Gets the PANTONE 349 color.
static (Shared in Visual Basic) | PANTONE350 | Gets the PANTONE 350 color.
static (Shared in Visual Basic) | PANTONE351 | Gets the PANTONE 351 color.
static (Shared in Visual Basic) | PANTONE352 | Gets the PANTONE 352 color.
static (Shared in Visual Basic) | PANTONE353 | Gets the PANTONE 353 color.
static (Shared in Visual Basic) | PANTONE354 | Gets the PANTONE 354 color.
static (Shared in Visual Basic) | PANTONE355 | Gets the PANTONE 355 color.
static (Shared in Visual Basic) | PANTONE356 | Gets the PANTONE 356 color.
static (Shared in Visual Basic) | PANTONE357 | Gets the PANTONE 357 color.
static (Shared in Visual Basic) | PANTONE358 | Gets the PANTONE 358 color.
static (Shared in Visual Basic) | PANTONE359 | Gets the PANTONE 359 color.
static (Shared in Visual Basic) | PANTONE360 | Gets the PANTONE 360 color.
static (Shared in Visual Basic) | PANTONE361 | Gets the PANTONE 361 color.
static (Shared in Visual Basic) | PANTONE362 | Gets the PANTONE 362 color.
static (Shared in Visual Basic) | PANTONE363 | Gets the PANTONE 363 color.
static (Shared in Visual Basic) | PANTONE364 | Gets the PANTONE 364 color.
static (Shared in Visual Basic) | PANTONE365 | Gets the PANTONE 365 color.
static (Shared in Visual Basic) | PANTONE366 | Gets the PANTONE 366 color.
static (Shared in Visual Basic) | PANTONE367 | Gets the PANTONE 367 color.
static (Shared in Visual Basic) | PANTONE368 | Gets the PANTONE 368 color.
static (Shared in Visual Basic) | PANTONE369 | Gets the PANTONE 369 color.
static (Shared in Visual Basic) | PANTONE370 | Gets the PANTONE 370 color.
static (Shared in Visual Basic) | PANTONE371 | Gets the PANTONE 371 color.
static (Shared in Visual Basic) | PANTONE372 | Gets the PANTONE 372 color.
static (Shared in Visual Basic) | PANTONE373 | Gets the PANTONE 373 color.
static (Shared in Visual Basic) | PANTONE374 | Gets the PANTONE 374 color.
static (Shared in Visual Basic) | PANTONE375 | Gets the PANTONE 375 color.
static (Shared in Visual Basic) | PANTONE376 | Gets the PANTONE 376 color.
static (Shared in Visual Basic) | PANTONE377 | Gets the PANTONE 377 color.
static (Shared in Visual Basic) | PANTONE378 | Gets the PANTONE 378 color.
static (Shared in Visual Basic) | PANTONE379 | Gets the PANTONE 379 color.
static (Shared in Visual Basic) | PANTONE380 | Gets the PANTONE 380 color.
static (Shared in Visual Basic) | PANTONE381 | Gets the PANTONE 381 color.
static (Shared in Visual Basic) | PANTONE382 | Gets the PANTONE 382 color.
static (Shared in Visual Basic) | PANTONE383 | Gets the PANTONE 383 color.
static (Shared in Visual Basic) | PANTONE384 | Gets the PANTONE 384 color.
static (Shared in Visual Basic) | PANTONE385 | Gets the PANTONE 385 color.
static (Shared in Visual Basic) | PANTONE386 | Gets the PANTONE 386 color.
static (Shared in Visual Basic) | PANTONE387 | Gets the PANTONE 387 color.
static (Shared in Visual Basic) | PANTONE388 | Gets the PANTONE 388 color.
static (Shared in Visual Basic) | PANTONE389 | Gets the PANTONE 389 color.
static (Shared in Visual Basic) | PANTONE390 | Gets the PANTONE 390 color.
static (Shared in Visual Basic) | PANTONE391 | Gets the PANTONE 391 color.
static (Shared in Visual Basic) | PANTONE392 | Gets the PANTONE 392 color.
static (Shared in Visual Basic) | PANTONE393 | Gets the PANTONE 393 color.
static (Shared in Visual Basic) | PANTONE3935 | Gets the PANTONE 3935 color.
static (Shared in Visual Basic) | PANTONE394 | Gets the PANTONE 394 color.
static (Shared in Visual Basic) | PANTONE3945 | Gets the PANTONE 3945 color.
static (Shared in Visual Basic) | PANTONE395 | Gets the PANTONE 395 color.
static (Shared in Visual Basic) | PANTONE3955 | Gets the PANTONE 3955 color.
static (Shared in Visual Basic) | PANTONE396 | Gets the PANTONE 396 color.
static (Shared in Visual Basic) | PANTONE3965 | Gets the PANTONE 3965 color.
static (Shared in Visual Basic) | PANTONE397 | Gets the PANTONE 397 color.
static (Shared in Visual Basic) | PANTONE3975 | Gets the PANTONE 3975 color.
static (Shared in Visual Basic) | PANTONE398 | Gets the PANTONE 398 color.
static (Shared in Visual Basic) | PANTONE3985 | Gets the PANTONE 3985 color.
static (Shared in Visual Basic) | PANTONE399 | Gets the PANTONE 399 color.
static (Shared in Visual Basic) | PANTONE3995 | Gets the PANTONE 3995 color.
static (Shared in Visual Basic) | PANTONE400 | Gets the PANTONE 400 color.
static (Shared in Visual Basic) | PANTONE401 | Gets the PANTONE 401 color.
static (Shared in Visual Basic) | PANTONE402 | Gets the PANTONE 402 color.
static (Shared in Visual Basic) | PANTONE403 | Gets the PANTONE 403 color.
static (Shared in Visual Basic) | PANTONE404 | Gets the PANTONE 404 color.
static (Shared in Visual Basic) | PANTONE405 | Gets the PANTONE 405 color.
static (Shared in Visual Basic) | PANTONE406 | Gets the PANTONE 406 color.
static (Shared in Visual Basic) | PANTONE407 | Gets the PANTONE 407 color.
static (Shared in Visual Basic) | PANTONE408 | Gets the PANTONE 408 color.
static (Shared in Visual Basic) | PANTONE409 | Gets the PANTONE 409 color.
static (Shared in Visual Basic) | PANTONE410 | Gets the PANTONE 410 color.
static (Shared in Visual Basic) | PANTONE411 | Gets the PANTONE 411 color.
static (Shared in Visual Basic) | PANTONE412 | Gets the PANTONE 412 color.
static (Shared in Visual Basic) | PANTONE413 | Gets the PANTONE 413 color.
static (Shared in Visual Basic) | PANTONE414 | Gets the PANTONE 414 color.
static (Shared in Visual Basic) | PANTONE415 | Gets the PANTONE 415 color.
static (Shared in Visual Basic) | PANTONE416 | Gets the PANTONE 416 color.
static (Shared in Visual Basic) | PANTONE417 | Gets the PANTONE 417 color.
static (Shared in Visual Basic) | PANTONE418 | Gets the PANTONE 418 color.
static (Shared in Visual Basic) | PANTONE419 | Gets the PANTONE 419 color.
static (Shared in Visual Basic) | PANTONE420 | Gets the PANTONE 420 color.
static (Shared in Visual Basic) | PANTONE421 | Gets the PANTONE 421 color.
static (Shared in Visual Basic) | PANTONE422 | Gets the PANTONE 422 color.
static (Shared in Visual Basic) | PANTONE423 | Gets the PANTONE 423 color.
static (Shared in Visual Basic) | PANTONE424 | Gets the PANTONE 424 color.
static (Shared in Visual Basic) | PANTONE425 | Gets the PANTONE 425 color.
static (Shared in Visual Basic) | PANTONE426 | Gets the PANTONE 426 color.
static (Shared in Visual Basic) | PANTONE427 | Gets the PANTONE 427 color.
static (Shared in Visual Basic) | PANTONE428 | Gets the PANTONE 428 color.
static (Shared in Visual Basic) | PANTONE429 | Gets the PANTONE 429 color.
static (Shared in Visual Basic) | PANTONE430 | Gets the PANTONE 430 color.
static (Shared in Visual Basic) | PANTONE431 | Gets the PANTONE 431 color.
static (Shared in Visual Basic) | PANTONE432 | Gets the PANTONE 432 color.
static (Shared in Visual Basic) | PANTONE433 | Gets the PANTONE 433 color.
static (Shared in Visual Basic) | PANTONE434 | Gets the PANTONE 434 color.
static (Shared in Visual Basic) | PANTONE435 | Gets the PANTONE 435 color.
static (Shared in Visual Basic) | PANTONE436 | Gets the PANTONE 436 color.
static (Shared in Visual Basic) | PANTONE437 | Gets the PANTONE 437 color.
static (Shared in Visual Basic) | PANTONE438 | Gets the PANTONE 438 color.
static (Shared in Visual Basic) | PANTONE439 | Gets the PANTONE 439 color.
static (Shared in Visual Basic) | PANTONE440 | Gets the PANTONE 440 color.
static (Shared in Visual Basic) | PANTONE441 | Gets the PANTONE 441 color.
static (Shared in Visual Basic) | PANTONE442 | Gets the PANTONE 442 color.
static (Shared in Visual Basic) | PANTONE443 | Gets the PANTONE 443 color.
static (Shared in Visual Basic) | PANTONE444 | Gets the PANTONE 444 color.
static (Shared in Visual Basic) | PANTONE445 | Gets the PANTONE 445 color.
static (Shared in Visual Basic) | PANTONE446 | Gets the PANTONE 446 color.
static (Shared in Visual Basic) | PANTONE447 | Gets the PANTONE 447 color.
static (Shared in Visual Basic) | PANTONE448 | Gets the PANTONE 448 color.
static (Shared in Visual Basic) | PANTONE4485 | Gets the PANTONE 4485 color.
static (Shared in Visual Basic) | PANTONE449 | Gets the PANTONE 449 color.
static (Shared in Visual Basic) | PANTONE4495 | Gets the PANTONE 4495 color.
static (Shared in Visual Basic) | PANTONE450 | Gets the PANTONE 450 color.
static (Shared in Visual Basic) | PANTONE4505 | Gets the PANTONE 4505 color.
static (Shared in Visual Basic) | PANTONE451 | Gets the PANTONE 451 color.
static (Shared in Visual Basic) | PANTONE4515 | Gets the PANTONE 4515 color.
static (Shared in Visual Basic) | PANTONE452 | Gets the PANTONE 452 color.
static (Shared in Visual Basic) | PANTONE4525 | Gets the PANTONE 4525 color.
static (Shared in Visual Basic) | PANTONE453 | Gets the PANTONE 453 color.
static (Shared in Visual Basic) | PANTONE4535 | Gets the PANTONE 4535 color.
static (Shared in Visual Basic) | PANTONE454 | Gets the PANTONE 454 color.
static (Shared in Visual Basic) | PANTONE4545 | Gets the PANTONE 4545 color.
static (Shared in Visual Basic) | PANTONE455 | Gets the PANTONE 455 color.
static (Shared in Visual Basic) | PANTONE456 | Gets the PANTONE 456 color.
static (Shared in Visual Basic) | PANTONE457 | Gets the PANTONE 457 color.
static (Shared in Visual Basic) | PANTONE458 | Gets the PANTONE 458 color.
static (Shared in Visual Basic) | PANTONE459 | Gets the PANTONE 459 color.
static (Shared in Visual Basic) | PANTONE460 | Gets the PANTONE 460 color.
static (Shared in Visual Basic) | PANTONE461 | Gets the PANTONE 461 color.
static (Shared in Visual Basic) | PANTONE462 | Gets the PANTONE 462 color.
static (Shared in Visual Basic) | PANTONE4625 | Gets the PANTONE 4625 color.
static (Shared in Visual Basic) | PANTONE463 | Gets the PANTONE 463 color.
static (Shared in Visual Basic) | PANTONE4635 | Gets the PANTONE 4635 color.
static (Shared in Visual Basic) | PANTONE464 | Gets the PANTONE 464 color.
static (Shared in Visual Basic) | PANTONE4645 | Gets the PANTONE 4645 color.
static (Shared in Visual Basic) | PANTONE465 | Gets the PANTONE 465 color.
static (Shared in Visual Basic) | PANTONE4655 | Gets the PANTONE 4655 color.
static (Shared in Visual Basic) | PANTONE466 | Gets the PANTONE 466 color.
static (Shared in Visual Basic) | PANTONE4665 | Gets the PANTONE 4665 color.
static (Shared in Visual Basic) | PANTONE467 | Gets the PANTONE 467 color.
static (Shared in Visual Basic) | PANTONE4675 | Gets the PANTONE 4675 color.
static (Shared in Visual Basic) | PANTONE468 | Gets the PANTONE 468 color.
static (Shared in Visual Basic) | PANTONE4685 | Gets the PANTONE 4685 color.
static (Shared in Visual Basic) | PANTONE469 | Gets the PANTONE 469 color.
static (Shared in Visual Basic) | PANTONE4695 | Gets the PANTONE 4695 color.
static (Shared in Visual Basic) | PANTONE470 | Gets the PANTONE 470 color.
static (Shared in Visual Basic) | PANTONE4705 | Gets the PANTONE 4705 color.
static (Shared in Visual Basic) | PANTONE471 | Gets the PANTONE 471 color.
static (Shared in Visual Basic) | PANTONE4715 | Gets the PANTONE 4715 color.
static (Shared in Visual Basic) | PANTONE472 | Gets the PANTONE 472 color.
static (Shared in Visual Basic) | PANTONE4725 | Gets the PANTONE 4725 color.
static (Shared in Visual Basic) | PANTONE473 | Gets the PANTONE 473 color.
static (Shared in Visual Basic) | PANTONE4735 | Gets the PANTONE 4735 color.
static (Shared in Visual Basic) | PANTONE474 | Gets the PANTONE 474 color.
static (Shared in Visual Basic) | PANTONE4745 | Gets the PANTONE 4745 color.
static (Shared in Visual Basic) | PANTONE475 | Gets the PANTONE 475 color.
static (Shared in Visual Basic) | PANTONE4755 | Gets the PANTONE 4755 color.
static (Shared in Visual Basic) | PANTONE476 | Gets the PANTONE 476 color.
static (Shared in Visual Basic) | PANTONE477 | Gets the PANTONE 477 color.
static (Shared in Visual Basic) | PANTONE478 | Gets the PANTONE 478 color.
static (Shared in Visual Basic) | PANTONE479 | Gets the PANTONE 479 color.
static (Shared in Visual Basic) | PANTONE480 | Gets the PANTONE 480 color.
static (Shared in Visual Basic) | PANTONE481 | Gets the PANTONE 481 color.
static (Shared in Visual Basic) | PANTONE482 | Gets the PANTONE 482 color.
static (Shared in Visual Basic) | PANTONE483 | Gets the PANTONE 483 color.
static (Shared in Visual Basic) | PANTONE484 | Gets the PANTONE 484 color.
static (Shared in Visual Basic) | PANTONE485 | Gets the PANTONE 485 color.
static (Shared in Visual Basic) | PANTONE486 | Gets the PANTONE 486 color.
static (Shared in Visual Basic) | PANTONE487 | Gets the PANTONE 487 color.
static (Shared in Visual Basic) | PANTONE488 | Gets the PANTONE 488 color.
static (Shared in Visual Basic) | PANTONE489 | Gets the PANTONE 489 color.
static (Shared in Visual Basic) | PANTONE490 | Gets the PANTONE 490 color.
static (Shared in Visual Basic) | PANTONE491 | Gets the PANTONE 491 color.
static (Shared in Visual Basic) | PANTONE492 | Gets the PANTONE 492 color.
static (Shared in Visual Basic) | PANTONE493 | Gets the PANTONE 493 color.
static (Shared in Visual Basic) | PANTONE494 | Gets the PANTONE 494 color.
static (Shared in Visual Basic) | PANTONE495 | Gets the PANTONE 495 color.
static (Shared in Visual Basic) | PANTONE496 | Gets the PANTONE 496 color.
static (Shared in Visual Basic) | PANTONE497 | Gets the PANTONE 497 color.
static (Shared in Visual Basic) | PANTONE4975 | Gets the PANTONE 4975 color.
static (Shared in Visual Basic) | PANTONE498 | Gets the PANTONE 498 color.
static (Shared in Visual Basic) | PANTONE4985 | Gets the PANTONE 4985 color.
static (Shared in Visual Basic) | PANTONE499 | Gets the PANTONE 499 color.
static (Shared in Visual Basic) | PANTONE4995 | Gets the PANTONE 4995 color.
static (Shared in Visual Basic) | PANTONE500 | Gets the PANTONE 500 color.
static (Shared in Visual Basic) | PANTONE5005 | Gets the PANTONE 5005 color.
static (Shared in Visual Basic) | PANTONE501 | Gets the PANTONE 501 color.
static (Shared in Visual Basic) | PANTONE5015 | Gets the PANTONE 5015 color.
static (Shared in Visual Basic) | PANTONE502 | Gets the PANTONE 502 color.
static (Shared in Visual Basic) | PANTONE5025 | Gets the PANTONE 5025 color.
static (Shared in Visual Basic) | PANTONE503 | Gets the PANTONE 503 color.
static (Shared in Visual Basic) | PANTONE5035 | Gets the PANTONE 5035 color.
static (Shared in Visual Basic) | PANTONE504 | Gets the PANTONE 504 color.
static (Shared in Visual Basic) | PANTONE505 | Gets the PANTONE 505 color.
static (Shared in Visual Basic) | PANTONE506 | Gets the PANTONE 506 color.
static (Shared in Visual Basic) | PANTONE507 | Gets the PANTONE 507 color.
static (Shared in Visual Basic) | PANTONE508 | Gets the PANTONE 508 color.
static (Shared in Visual Basic) | PANTONE509 | Gets the PANTONE 509 color.
static (Shared in Visual Basic) | PANTONE510 | Gets the PANTONE 510 color.
static (Shared in Visual Basic) | PANTONE511 | Gets the PANTONE 511 color.
static (Shared in Visual Basic) | PANTONE5115 | Gets the PANTONE 5115 color.
static (Shared in Visual Basic) | PANTONE512 | Gets the PANTONE 512 color.
static (Shared in Visual Basic) | PANTONE5125 | Gets the PANTONE 5125 color.
static (Shared in Visual Basic) | PANTONE513 | Gets the PANTONE 513 color.
static (Shared in Visual Basic) | PANTONE5135 | Gets the PANTONE 5135 color.
static (Shared in Visual Basic) | PANTONE514 | Gets the PANTONE 514 color.
static (Shared in Visual Basic) | PANTONE5145 | Gets the PANTONE 5145 color.
static (Shared in Visual Basic) | PANTONE515 | Gets the PANTONE 515 color.
static (Shared in Visual Basic) | PANTONE5155 | Gets the PANTONE 5155 color.
static (Shared in Visual Basic) | PANTONE516 | Gets the PANTONE 516 color.
static (Shared in Visual Basic) | PANTONE5165 | Gets the PANTONE 5165 color.
static (Shared in Visual Basic) | PANTONE517 | Gets the PANTONE 517 color.
static (Shared in Visual Basic) | PANTONE5175 | Gets the PANTONE 5175 color.
static (Shared in Visual Basic) | PANTONE518 | Gets the PANTONE 518 color.
static (Shared in Visual Basic) | PANTONE5185 | Gets the PANTONE 5185 color.
static (Shared in Visual Basic) | PANTONE519 | Gets the PANTONE 519 color.
static (Shared in Visual Basic) | PANTONE5195 | Gets the PANTONE 5195 color.
static (Shared in Visual Basic) | PANTONE520 | Gets the PANTONE 520 color.
static (Shared in Visual Basic) | PANTONE5205 | Gets the PANTONE 5205 color.
static (Shared in Visual Basic) | PANTONE521 | Gets the PANTONE 521 color.
static (Shared in Visual Basic) | PANTONE5215 | Gets the PANTONE 5215 color.
static (Shared in Visual Basic) | PANTONE522 | Gets the PANTONE 522 color.
static (Shared in Visual Basic) | PANTONE5225 | Gets the PANTONE 5225 color.
static (Shared in Visual Basic) | PANTONE523 | Gets the PANTONE 523 color.
static (Shared in Visual Basic) | PANTONE5235 | Gets the PANTONE 5235 color.
static (Shared in Visual Basic) | PANTONE524 | Gets the PANTONE 524 color.
static (Shared in Visual Basic) | PANTONE5245 | Gets the PANTONE 5245 color.
static (Shared in Visual Basic) | PANTONE525 | Gets the PANTONE 525 color.
static (Shared in Visual Basic) | PANTONE5255 | Gets the PANTONE 5255 color.
static (Shared in Visual Basic) | PANTONE526 | Gets the PANTONE 526 color.
static (Shared in Visual Basic) | PANTONE5265 | Gets the PANTONE 5265 color.
static (Shared in Visual Basic) | PANTONE527 | Gets the PANTONE 527 color.
static (Shared in Visual Basic) | PANTONE5275 | Gets the PANTONE 5275 color.
static (Shared in Visual Basic) | PANTONE528 | Gets the PANTONE 528 color.
static (Shared in Visual Basic) | PANTONE5285 | Gets the PANTONE 5285 color.
static (Shared in Visual Basic) | PANTONE529 | Gets the PANTONE 529 color.
static (Shared in Visual Basic) | PANTONE5295 | Gets the PANTONE 5295 color.
static (Shared in Visual Basic) | PANTONE530 | Gets the PANTONE 530 color.
static (Shared in Visual Basic) | PANTONE5305 | Gets the PANTONE 5305 color.
static (Shared in Visual Basic) | PANTONE531 | Gets the PANTONE 531 color.
static (Shared in Visual Basic) | PANTONE5315 | Gets the PANTONE 5315 color.
static (Shared in Visual Basic) | PANTONE532 | Gets the PANTONE 532 color.
static (Shared in Visual Basic) | PANTONE533 | Gets the PANTONE 533 color.
static (Shared in Visual Basic) | PANTONE534 | Gets the PANTONE 534 color.
static (Shared in Visual Basic) | PANTONE535 | Gets the PANTONE 535 color.
static (Shared in Visual Basic) | PANTONE536 | Gets the PANTONE 536 color.
static (Shared in Visual Basic) | PANTONE537 | Gets the PANTONE 537 color.
static (Shared in Visual Basic) | PANTONE538 | Gets the PANTONE 538 color.
static (Shared in Visual Basic) | PANTONE539 | Gets the PANTONE 539 color.
static (Shared in Visual Basic) | PANTONE5395 | Gets the PANTONE 5395 color.
static (Shared in Visual Basic) | PANTONE540 | Gets the PANTONE 540 color.
static (Shared in Visual Basic) | PANTONE5405 | Gets the PANTONE 5405 color.
static (Shared in Visual Basic) | PANTONE541 | Gets the PANTONE 541 color.
static (Shared in Visual Basic) | PANTONE5415 | Gets the PANTONE 5415 color.
static (Shared in Visual Basic) | PANTONE542 | Gets the PANTONE 542 color.
static (Shared in Visual Basic) | PANTONE5425 | Gets the PANTONE 5425 color.
static (Shared in Visual Basic) | PANTONE543 | Gets the PANTONE 543 color.
static (Shared in Visual Basic) | PANTONE5435 | Gets the PANTONE 5435 color.
static (Shared in Visual Basic) | PANTONE544 | Gets the PANTONE 544 color.
static (Shared in Visual Basic) | PANTONE5445 | Gets the PANTONE 5445 color.
static (Shared in Visual Basic) | PANTONE545 | Gets the PANTONE 545 color.
static (Shared in Visual Basic) | PANTONE5455 | Gets the PANTONE 5455 color.
static (Shared in Visual Basic) | PANTONE546 | Gets the PANTONE 546 color.
static (Shared in Visual Basic) | PANTONE5463 | Gets the PANTONE 5463 color.
static (Shared in Visual Basic) | PANTONE5467 | Gets the PANTONE 5467 color.
static (Shared in Visual Basic) | PANTONE547 | Gets the PANTONE 547 color.
static (Shared in Visual Basic) | PANTONE5473 | Gets the PANTONE 5473 color.
static (Shared in Visual Basic) | PANTONE5477 | Gets the PANTONE 5477 color.
static (Shared in Visual Basic) | PANTONE548 | Gets the PANTONE 548 color.
static (Shared in Visual Basic) | PANTONE5483 | Gets the PANTONE 5483 color.
static (Shared in Visual Basic) | PANTONE5487 | Gets the PANTONE 5487 color.
static (Shared in Visual Basic) | PANTONE549 | Gets the PANTONE 549 color.
static (Shared in Visual Basic) | PANTONE5493 | Gets the PANTONE 5493 color.
static (Shared in Visual Basic) | PANTONE5497 | Gets the PANTONE 5497 color.
static (Shared in Visual Basic) | PANTONE550 | Gets the PANTONE 550 color.
static (Shared in Visual Basic) | PANTONE5503 | Gets the PANTONE 5503 color.
static (Shared in Visual Basic) | PANTONE5507 | Gets the PANTONE 5507 color.
static (Shared in Visual Basic) | PANTONE551 | Gets the PANTONE 551 color.
static (Shared in Visual Basic) | PANTONE5513 | Gets the PANTONE 5513 color.
static (Shared in Visual Basic) | PANTONE5517 | Gets the PANTONE 5517 color.
static (Shared in Visual Basic) | PANTONE552 | Gets the PANTONE 552 color.
static (Shared in Visual Basic) | PANTONE5523 | Gets the PANTONE 5523 color.
static (Shared in Visual Basic) | PANTONE5527 | Gets the PANTONE 5527 color.
static (Shared in Visual Basic) | PANTONE553 | Gets the PANTONE 553 color.
static (Shared in Visual Basic) | PANTONE5535 | Gets the PANTONE 5535 color.
static (Shared in Visual Basic) | PANTONE554 | Gets the PANTONE 554 color.
static (Shared in Visual Basic) | PANTONE5545 | Gets the PANTONE 5545 color.
static (Shared in Visual Basic) | PANTONE555 | Gets the PANTONE 555 color.
static (Shared in Visual Basic) | PANTONE5555 | Gets the PANTONE 5555 color.
static (Shared in Visual Basic) | PANTONE556 | Gets the PANTONE 556 color.
static (Shared in Visual Basic) | PANTONE5565 | Gets the PANTONE 5565 color.
static (Shared in Visual Basic) | PANTONE557 | Gets the PANTONE 557 color.
static (Shared in Visual Basic) | PANTONE5575 | Gets the PANTONE 5575 color.
static (Shared in Visual Basic) | PANTONE558 | Gets the PANTONE 558 color.
static (Shared in Visual Basic) | PANTONE5585 | Gets the PANTONE 5585 color.
static (Shared in Visual Basic) | PANTONE559 | Gets the PANTONE 559 color.
static (Shared in Visual Basic) | PANTONE5595 | Gets the PANTONE 5595 color.
static (Shared in Visual Basic) | PANTONE560 | Gets the PANTONE 560 color.
static (Shared in Visual Basic) | PANTONE5605 | Gets the PANTONE 5605 color.
static (Shared in Visual Basic) | PANTONE561 | Gets the PANTONE 561 color.
static (Shared in Visual Basic) | PANTONE5615 | Gets the PANTONE 5615 color.
static (Shared in Visual Basic) | PANTONE562 | Gets the PANTONE 562 color.
static (Shared in Visual Basic) | PANTONE5625 | Gets the PANTONE 5625 color.
static (Shared in Visual Basic) | PANTONE563 | Gets the PANTONE 563 color.
static (Shared in Visual Basic) | PANTONE5635 | Gets the PANTONE 5635 color.
static (Shared in Visual Basic) | PANTONE564 | Gets the PANTONE 564 color.
static (Shared in Visual Basic) | PANTONE5645 | Gets the PANTONE 5645 color.
static (Shared in Visual Basic) | PANTONE565 | Gets the PANTONE 565 color.
static (Shared in Visual Basic) | PANTONE5655 | Gets the PANTONE 5655 color.
static (Shared in Visual Basic) | PANTONE566 | Gets the PANTONE 566 color.
static (Shared in Visual Basic) | PANTONE5665 | Gets the PANTONE 5665 color.
static (Shared in Visual Basic) | PANTONE567 | Gets the PANTONE 567 color.
static (Shared in Visual Basic) | PANTONE568 | Gets the PANTONE 568 color.
static (Shared in Visual Basic) | PANTONE569 | Gets the PANTONE 569 color.
static (Shared in Visual Basic) | PANTONE570 | Gets the PANTONE 570 color.
static (Shared in Visual Basic) | PANTONE571 | Gets the PANTONE 571 color.
static (Shared in Visual Basic) | PANTONE572 | Gets the PANTONE 572 color.
static (Shared in Visual Basic) | PANTONE573 | Gets the PANTONE 573 color.
static (Shared in Visual Basic) | PANTONE574 | Gets the PANTONE 574 color.
static (Shared in Visual Basic) | PANTONE5743 | Gets the PANTONE 5743 color.
static (Shared in Visual Basic) | PANTONE5747 | Gets the PANTONE 5747 color.
static (Shared in Visual Basic) | PANTONE575 | Gets the PANTONE 575 color.
static (Shared in Visual Basic) | PANTONE5753 | Gets the PANTONE 5753 color.
static (Shared in Visual Basic) | PANTONE5757 | Gets the PANTONE 5757 color.
static (Shared in Visual Basic) | PANTONE576 | Gets the PANTONE 576 color.
static (Shared in Visual Basic) | PANTONE5763 | Gets the PANTONE 5763 color.
static (Shared in Visual Basic) | PANTONE5767 | Gets the PANTONE 5767 color.
static (Shared in Visual Basic) | PANTONE577 | Gets the PANTONE 577 color.
static (Shared in Visual Basic) | PANTONE5773 | Gets the PANTONE 5773 color.
static (Shared in Visual Basic) | PANTONE5777 | Gets the PANTONE 5777 color.
static (Shared in Visual Basic) | PANTONE578 | Gets the PANTONE 578 color.
static (Shared in Visual Basic) | PANTONE5783 | Gets the PANTONE 5783 color.
static (Shared in Visual Basic) | PANTONE5787 | Gets the PANTONE 5787 color.
static (Shared in Visual Basic) | PANTONE579 | Gets the PANTONE 579 color.
static (Shared in Visual Basic) | PANTONE5793 | Gets the PANTONE 5793 color.
static (Shared in Visual Basic) | PANTONE5797 | Gets the PANTONE 5797 color.
static (Shared in Visual Basic) | PANTONE580 | Gets the PANTONE 580 color.
static (Shared in Visual Basic) | PANTONE5803 | Gets the PANTONE 5803 color.
static (Shared in Visual Basic) | PANTONE5807 | Gets the PANTONE 5807 color.
static (Shared in Visual Basic) | PANTONE581 | Gets the PANTONE 581 color.
static (Shared in Visual Basic) | PANTONE5815 | Gets the PANTONE 5815 color.
static (Shared in Visual Basic) | PANTONE582 | Gets the PANTONE 582 color.
static (Shared in Visual Basic) | PANTONE5825 | Gets the PANTONE 5825 color.
static (Shared in Visual Basic) | PANTONE583 | Gets the PANTONE 583 color.
static (Shared in Visual Basic) | PANTONE5835 | Gets the PANTONE 5835 color.
static (Shared in Visual Basic) | PANTONE584 | Gets the PANTONE 584 color.
static (Shared in Visual Basic) | PANTONE5845 | Gets the PANTONE 5845 color.
static (Shared in Visual Basic) | PANTONE585 | Gets the PANTONE 585 color.
static (Shared in Visual Basic) | PANTONE5855 | Gets the PANTONE 5855 color.
static (Shared in Visual Basic) | PANTONE586 | Gets the PANTONE 586 color.
static (Shared in Visual Basic) | PANTONE5865 | Gets the PANTONE 5865 color.
static (Shared in Visual Basic) | PANTONE587 | Gets the PANTONE 587 color.
static (Shared in Visual Basic) | PANTONE5875 | Gets the PANTONE 5875 color.
static (Shared in Visual Basic) | PANTONE600 | Gets the PANTONE 600 color.
static (Shared in Visual Basic) | PANTONE601 | Gets the PANTONE 601 color.
static (Shared in Visual Basic) | PANTONE602 | Gets the PANTONE 602 color.
static (Shared in Visual Basic) | PANTONE603 | Gets the PANTONE 603 color.
static (Shared in Visual Basic) | PANTONE604 | Gets the PANTONE 604 color.
static (Shared in Visual Basic) | PANTONE605 | Gets the PANTONE 605 color.
static (Shared in Visual Basic) | PANTONE606 | Gets the PANTONE 606 color.
static (Shared in Visual Basic) | PANTONE607 | Gets the PANTONE 607 color.
static (Shared in Visual Basic) | PANTONE608 | Gets the PANTONE 608 color.
static (Shared in Visual Basic) | PANTONE609 | Gets the PANTONE 609 color.
static (Shared in Visual Basic) | PANTONE610 | Gets the PANTONE 610 color.
static (Shared in Visual Basic) | PANTONE611 | Gets the PANTONE 611 color.
static (Shared in Visual Basic) | PANTONE612 | Gets the PANTONE 612 color.
static (Shared in Visual Basic) | PANTONE613 | Gets the PANTONE 613 color.
static (Shared in Visual Basic) | PANTONE614 | Gets the PANTONE 614 color.
static (Shared in Visual Basic) | PANTONE615 | Gets the PANTONE 615 color.
static (Shared in Visual Basic) | PANTONE616 | Gets the PANTONE 616 color.
static (Shared in Visual Basic) | PANTONE617 | Gets the PANTONE 617 color.
static (Shared in Visual Basic) | PANTONE618 | Gets the PANTONE 618 color.
static (Shared in Visual Basic) | PANTONE619 | Gets the PANTONE 619 color.
static (Shared in Visual Basic) | PANTONE620 | Gets the PANTONE 620 color.
static (Shared in Visual Basic) | PANTONE621 | Gets the PANTONE 621 color.
static (Shared in Visual Basic) | PANTONE622 | Gets the PANTONE 622 color.
static (Shared in Visual Basic) | PANTONE623 | Gets the PANTONE 623 color.
static (Shared in Visual Basic) | PANTONE624 | Gets the PANTONE 624 color.
static (Shared in Visual Basic) | PANTONE625 | Gets the PANTONE 625 color.
static (Shared in Visual Basic) | PANTONE626 | Gets the PANTONE 626 color.
static (Shared in Visual Basic) | PANTONE627 | Gets the PANTONE 627 color.
static (Shared in Visual Basic) | PANTONE628 | Gets the PANTONE 628 color.
static (Shared in Visual Basic) | PANTONE629 | Gets the PANTONE 629 color.
static (Shared in Visual Basic) | PANTONE630 | Gets the PANTONE 630 color.
static (Shared in Visual Basic) | PANTONE631 | Gets the PANTONE 631 color.
static (Shared in Visual Basic) | PANTONE632 | Gets the PANTONE 632 color.
static (Shared in Visual Basic) | PANTONE633 | Gets the PANTONE 633 color.
static (Shared in Visual Basic) | PANTONE634 | Gets the PANTONE 634 color.
static (Shared in Visual Basic) | PANTONE635 | Gets the PANTONE 635 color.
static (Shared in Visual Basic) | PANTONE636 | Gets the PANTONE 636 color.
static (Shared in Visual Basic) | PANTONE637 | Gets the PANTONE 637 color.
static (Shared in Visual Basic) | PANTONE638 | Gets the PANTONE 638 color.
static (Shared in Visual Basic) | PANTONE639 | Gets the PANTONE 639 color.
static (Shared in Visual Basic) | PANTONE640 | Gets the PANTONE 640 color.
static (Shared in Visual Basic) | PANTONE641 | Gets the PANTONE 641 color.
static (Shared in Visual Basic) | PANTONE642 | Gets the PANTONE 642 color.
static (Shared in Visual Basic) | PANTONE643 | Gets the PANTONE 643 color.
static (Shared in Visual Basic) | PANTONE644 | Gets the PANTONE 644 color.
static (Shared in Visual Basic) | PANTONE645 | Gets the PANTONE 645 color.
static (Shared in Visual Basic) | PANTONE646 | Gets the PANTONE 646 color.
static (Shared in Visual Basic) | PANTONE647 | Gets the PANTONE 647 color.
static (Shared in Visual Basic) | PANTONE648 | Gets the PANTONE 648 color.
static (Shared in Visual Basic) | PANTONE649 | Gets the PANTONE 649 color.
static (Shared in Visual Basic) | PANTONE650 | Gets the PANTONE 650 color.
static (Shared in Visual Basic) | PANTONE651 | Gets the PANTONE 651 color.
static (Shared in Visual Basic) | PANTONE652 | Gets the PANTONE 652 color.
static (Shared in Visual Basic) | PANTONE653 | Gets the PANTONE 653 color.
static (Shared in Visual Basic) | PANTONE654 | Gets the PANTONE 654 color.
static (Shared in Visual Basic) | PANTONE655 | Gets the PANTONE 655 color.
static (Shared in Visual Basic) | PANTONE656 | Gets the PANTONE 656 color.
static (Shared in Visual Basic) | PANTONE657 | Gets the PANTONE 657 color.
static (Shared in Visual Basic) | PANTONE658 | Gets the PANTONE 658 color.
static (Shared in Visual Basic) | PANTONE659 | Gets the PANTONE 659 color.
static (Shared in Visual Basic) | PANTONE660 | Gets the PANTONE 660 color.
static (Shared in Visual Basic) | PANTONE661 | Gets the PANTONE 661 color.
static (Shared in Visual Basic) | PANTONE662 | Gets the PANTONE 662 color.
static (Shared in Visual Basic) | PANTONE663 | Gets the PANTONE 663 color.
static (Shared in Visual Basic) | PANTONE664 | Gets the PANTONE 664 color.
static (Shared in Visual Basic) | PANTONE665 | Gets the PANTONE 665 color.
static (Shared in Visual Basic) | PANTONE666 | Gets the PANTONE 666 color.
static (Shared in Visual Basic) | PANTONE667 | Gets the PANTONE 667 color.
static (Shared in Visual Basic) | PANTONE668 | Gets the PANTONE 668 color.
static (Shared in Visual Basic) | PANTONE669 | Gets the PANTONE 669 color.
static (Shared in Visual Basic) | PANTONE670 | Gets the PANTONE 670 color.
static (Shared in Visual Basic) | PANTONE671 | Gets the PANTONE 671 color.
static (Shared in Visual Basic) | PANTONE672 | Gets the PANTONE 672 color.
static (Shared in Visual Basic) | PANTONE673 | Gets the PANTONE 673 color.
static (Shared in Visual Basic) | PANTONE674 | Gets the PANTONE 674 color.
static (Shared in Visual Basic) | PANTONE675 | Gets the PANTONE 675 color.
static (Shared in Visual Basic) | PANTONE676 | Gets the PANTONE 676 color.
static (Shared in Visual Basic) | PANTONE677 | Gets the PANTONE 677 color.
static (Shared in Visual Basic) | PANTONE678 | Gets the PANTONE 678 color.
static (Shared in Visual Basic) | PANTONE679 | Gets the PANTONE 679 color.
static (Shared in Visual Basic) | PANTONE680 | Gets the PANTONE 680 color.
static (Shared in Visual Basic) | PANTONE681 | Gets the PANTONE 681 color.
static (Shared in Visual Basic) | PANTONE682 | Gets the PANTONE 682 color.
static (Shared in Visual Basic) | PANTONE683 | Gets the PANTONE 683 color.
static (Shared in Visual Basic) | PANTONE684 | Gets the PANTONE 684 color.
static (Shared in Visual Basic) | PANTONE685 | Gets the PANTONE 685 color.
static (Shared in Visual Basic) | PANTONE686 | Gets the PANTONE 686 color.
static (Shared in Visual Basic) | PANTONE687 | Gets the PANTONE 687 color.
static (Shared in Visual Basic) | PANTONE688 | Gets the PANTONE 688 color.
static (Shared in Visual Basic) | PANTONE689 | Gets the PANTONE 689 color.
static (Shared in Visual Basic) | PANTONE690 | Gets the PANTONE 690 color.
static (Shared in Visual Basic) | PANTONE691 | Gets the PANTONE 691 color.
static (Shared in Visual Basic) | PANTONE692 | Gets the PANTONE 692 color.
static (Shared in Visual Basic) | PANTONE693 | Gets the PANTONE 693 color.
static (Shared in Visual Basic) | PANTONE694 | Gets the PANTONE 694 color.
static (Shared in Visual Basic) | PANTONE695 | Gets the PANTONE 695 color.
static (Shared in Visual Basic) | PANTONE696 | Gets the PANTONE 696 color.
static (Shared in Visual Basic) | PANTONE697 | Gets the PANTONE 697 color.
static (Shared in Visual Basic) | PANTONE698 | Gets the PANTONE 698 color.
static (Shared in Visual Basic) | PANTONE699 | Gets the PANTONE 699 color.
static (Shared in Visual Basic) | PANTONE700 | Gets the PANTONE 700 color.
static (Shared in Visual Basic) | PANTONE701 | Gets the PANTONE 701 color.
static (Shared in Visual Basic) | PANTONE702 | Gets the PANTONE 702 color.
static (Shared in Visual Basic) | PANTONE703 | Gets the PANTONE 703 color.
static (Shared in Visual Basic) | PANTONE704 | Gets the PANTONE 704 color.
static (Shared in Visual Basic) | PANTONE705 | Gets the PANTONE 705 color.
static (Shared in Visual Basic) | PANTONE706 | Gets the PANTONE 706 color.
static (Shared in Visual Basic) | PANTONE707 | Gets the PANTONE 707 color.
static (Shared in Visual Basic) | PANTONE708 | Gets the PANTONE 708 color.
static (Shared in Visual Basic) | PANTONE709 | Gets the PANTONE 709 color.
static (Shared in Visual Basic) | PANTONE710 | Gets the PANTONE 710 color.
static (Shared in Visual Basic) | PANTONE711 | Gets the PANTONE 711 color.
static (Shared in Visual Basic) | PANTONE712 | Gets the PANTONE 712 color.
static (Shared in Visual Basic) | PANTONE713 | Gets the PANTONE 713 color.
static (Shared in Visual Basic) | PANTONE714 | Gets the PANTONE 714 color.
static (Shared in Visual Basic) | PANTONE715 | Gets the PANTONE 715 color.
static (Shared in Visual Basic) | PANTONE716 | Gets the PANTONE 716 color.
static (Shared in Visual Basic) | PANTONE717 | Gets the PANTONE 717 color.
static (Shared in Visual Basic) | PANTONE718 | Gets the PANTONE 718 color.
static (Shared in Visual Basic) | PANTONE719 | Gets the PANTONE 719 color.
static (Shared in Visual Basic) | PANTONE720 | Gets the PANTONE 720 color.
static (Shared in Visual Basic) | PANTONE721 | Gets the PANTONE 721 color.
static (Shared in Visual Basic) | PANTONE722 | Gets the PANTONE 722 color.
static (Shared in Visual Basic) | PANTONE723 | Gets the PANTONE 723 color.
static (Shared in Visual Basic) | PANTONE724 | Gets the PANTONE 724 color.
static (Shared in Visual Basic) | PANTONE725 | Gets the PANTONE 725 color.
static (Shared in Visual Basic) | PANTONE726 | Gets the PANTONE 726 color.
static (Shared in Visual Basic) | PANTONE727 | Gets the PANTONE 727 color.
static (Shared in Visual Basic) | PANTONE728 | Gets the PANTONE 728 color.
static (Shared in Visual Basic) | PANTONE729 | Gets the PANTONE 729 color.
static (Shared in Visual Basic) | PANTONE730 | Gets the PANTONE 730 color.
static (Shared in Visual Basic) | PANTONE731 | Gets the PANTONE 731 color.
static (Shared in Visual Basic) | PANTONE732 | Gets the PANTONE 732 color.
static (Shared in Visual Basic) | PANTONE7401 | Gets the PANTONE 7401 color.
static (Shared in Visual Basic) | PANTONE7402 | Gets the PANTONE 7402 color.
static (Shared in Visual Basic) | PANTONE7403 | Gets the PANTONE 7403 color.
static (Shared in Visual Basic) | PANTONE7404 | Gets the PANTONE 7404 color.
static (Shared in Visual Basic) | PANTONE7405 | Gets the PANTONE 7405 color.
static (Shared in Visual Basic) | PANTONE7406 | Gets the PANTONE 7406 color.
static (Shared in Visual Basic) | PANTONE7407 | Gets the PANTONE 7407 color.
static (Shared in Visual Basic) | PANTONE7408 | Gets the PANTONE 7408 color.
static (Shared in Visual Basic) | PANTONE7409 | Gets the PANTONE 7409 color.
static (Shared in Visual Basic) | PANTONE7410 | Gets the PANTONE 7410 color.
static (Shared in Visual Basic) | PANTONE7411 | Gets the PANTONE 7411 color.
static (Shared in Visual Basic) | PANTONE7412 | Gets the PANTONE 7412 color.
static (Shared in Visual Basic) | PANTONE7413 | Gets the PANTONE 7413 color.
static (Shared in Visual Basic) | PANTONE7414 | Gets the PANTONE 7414 color.
static (Shared in Visual Basic) | PANTONE7415 | Gets the PANTONE 7415 color.
static (Shared in Visual Basic) | PANTONE7416 | Gets the PANTONE 7416 color.
static (Shared in Visual Basic) | PANTONE7417 | Gets the PANTONE 7417 color.
static (Shared in Visual Basic) | PANTONE7418 | Gets the PANTONE 7418 color.
static (Shared in Visual Basic) | PANTONE7419 | Gets the PANTONE 7419 color.
static (Shared in Visual Basic) | PANTONE7420 | Gets the PANTONE 7420 color.
static (Shared in Visual Basic) | PANTONE7421 | Gets the PANTONE 7421 color.
static (Shared in Visual Basic) | PANTONE7422 | Gets the PANTONE 7422 color.
static (Shared in Visual Basic) | PANTONE7423 | Gets the PANTONE 7423 color.
static (Shared in Visual Basic) | PANTONE7424 | Gets the PANTONE 7424 color.
static (Shared in Visual Basic) | PANTONE7425 | Gets the PANTONE 7425 color.
static (Shared in Visual Basic) | PANTONE7426 | Gets the PANTONE 7426 color.
static (Shared in Visual Basic) | PANTONE7427 | Gets the PANTONE 7427 color.
static (Shared in Visual Basic) | PANTONE7428 | Gets the PANTONE 7428 color.
static (Shared in Visual Basic) | PANTONE7429 | Gets the PANTONE 7429 color.
static (Shared in Visual Basic) | PANTONE7430 | Gets the PANTONE 7430 color.
static (Shared in Visual Basic) | PANTONE7431 | Gets the PANTONE 7431 color.
static (Shared in Visual Basic) | PANTONE7432 | Gets the PANTONE 7432 color.
static (Shared in Visual Basic) | PANTONE7433 | Gets the PANTONE 7433 color.
static (Shared in Visual Basic) | PANTONE7434 | Gets the PANTONE 7434 color.
static (Shared in Visual Basic) | PANTONE7435 | Gets the PANTONE 7435 color.
static (Shared in Visual Basic) | PANTONE7436 | Gets the PANTONE 7436 color.
static (Shared in Visual Basic) | PANTONE7437 | Gets the PANTONE 7437 color.
static (Shared in Visual Basic) | PANTONE7438 | Gets the PANTONE 7438 color.
static (Shared in Visual Basic) | PANTONE7439 | Gets the PANTONE 7439 color.
static (Shared in Visual Basic) | PANTONE7440 | Gets the PANTONE 7440 color.
static (Shared in Visual Basic) | PANTONE7441 | Gets the PANTONE 7441 color.
static (Shared in Visual Basic) | PANTONE7442 | Gets the PANTONE 7442 color.
static (Shared in Visual Basic) | PANTONE7443 | Gets the PANTONE 7443 color.
static (Shared in Visual Basic) | PANTONE7444 | Gets the PANTONE 7444 color.
static (Shared in Visual Basic) | PANTONE7445 | Gets the PANTONE 7445 color.
static (Shared in Visual Basic) | PANTONE7446 | Gets the PANTONE 7446 color.
static (Shared in Visual Basic) | PANTONE7447 | Gets the PANTONE 7447 color.
static (Shared in Visual Basic) | PANTONE7448 | Gets the PANTONE 7448 color.
static (Shared in Visual Basic) | PANTONE7449 | Gets the PANTONE 7449 color.
static (Shared in Visual Basic) | PANTONE7450 | Gets the PANTONE 7450 color.
static (Shared in Visual Basic) | PANTONE7451 | Gets the PANTONE 7451 color.
static (Shared in Visual Basic) | PANTONE7452 | Gets the PANTONE 7452 color.
static (Shared in Visual Basic) | PANTONE7453 | Gets the PANTONE 7453 color.
static (Shared in Visual Basic) | PANTONE7454 | Gets the PANTONE 7454 color.
static (Shared in Visual Basic) | PANTONE7455 | Gets the PANTONE 7455 color.
static (Shared in Visual Basic) | PANTONE7456 | Gets the PANTONE 7456 color.
static (Shared in Visual Basic) | PANTONE7457 | Gets the PANTONE 7457 color.
static (Shared in Visual Basic) | PANTONE7458 | Gets the PANTONE 7458 color.
static (Shared in Visual Basic) | PANTONE7459 | Gets the PANTONE 7459 color.
static (Shared in Visual Basic) | PANTONE7460 | Gets the PANTONE 7460 color.
static (Shared in Visual Basic) | PANTONE7461 | Gets the PANTONE 7461 color.
static (Shared in Visual Basic) | PANTONE7462 | Gets the PANTONE 7462 color.
static (Shared in Visual Basic) | PANTONE7463 | Gets the PANTONE 7463 color.
static (Shared in Visual Basic) | PANTONE7464 | Gets the PANTONE 7464 color.
static (Shared in Visual Basic) | PANTONE7465 | Gets the PANTONE 7465 color.
static (Shared in Visual Basic) | PANTONE7466 | Gets the PANTONE 7466 color.
static (Shared in Visual Basic) | PANTONE7467 | Gets the PANTONE 7467 color.
static (Shared in Visual Basic) | PANTONE7468 | Gets the PANTONE 7468 color.
static (Shared in Visual Basic) | PANTONE7469 | Gets the PANTONE 7469 color.
static (Shared in Visual Basic) | PANTONE7470 | Gets the PANTONE 7470 color.
static (Shared in Visual Basic) | PANTONE7471 | Gets the PANTONE 7471 color.
static (Shared in Visual Basic) | PANTONE7472 | Gets the PANTONE 7472 color.
static (Shared in Visual Basic) | PANTONE7473 | Gets the PANTONE 7473 color.
static (Shared in Visual Basic) | PANTONE7474 | Gets the PANTONE 7474 color.
static (Shared in Visual Basic) | PANTONE7475 | Gets the PANTONE 7475 color.
static (Shared in Visual Basic) | PANTONE7476 | Gets the PANTONE 7476 color.
static (Shared in Visual Basic) | PANTONE7477 | Gets the PANTONE 7477 color.
static (Shared in Visual Basic) | PANTONE7478 | Gets the PANTONE 7478 color.
static (Shared in Visual Basic) | PANTONE7479 | Gets the PANTONE 7479 color.
static (Shared in Visual Basic) | PANTONE7480 | Gets the PANTONE 7480 color.
static (Shared in Visual Basic) | PANTONE7481 | Gets the PANTONE 7481 color.
static (Shared in Visual Basic) | PANTONE7482 | Gets the PANTONE 7482 color.
static (Shared in Visual Basic) | PANTONE7483 | Gets the PANTONE 7483 color.
static (Shared in Visual Basic) | PANTONE7484 | Gets the PANTONE 7484 color.
static (Shared in Visual Basic) | PANTONE7485 | Gets the PANTONE 7485 color.
static (Shared in Visual Basic) | PANTONE7486 | Gets the PANTONE 7486 color.
static (Shared in Visual Basic) | PANTONE7487 | Gets the PANTONE 7487 color.
static (Shared in Visual Basic) | PANTONE7488 | Gets the PANTONE 7488 color.
static (Shared in Visual Basic) | PANTONE7489 | Gets the PANTONE 7489 color.
static (Shared in Visual Basic) | PANTONE7490 | Gets the PANTONE 7490 color.
static (Shared in Visual Basic) | PANTONE7491 | Gets the PANTONE 7491 color.
static (Shared in Visual Basic) | PANTONE7492 | Gets the PANTONE 7492 color.
static (Shared in Visual Basic) | PANTONE7493 | Gets the PANTONE 7493 color.
static (Shared in Visual Basic) | PANTONE7494 | Gets the PANTONE 7494 color.
static (Shared in Visual Basic) | PANTONE7495 | Gets the PANTONE 7495 color.
static (Shared in Visual Basic) | PANTONE7496 | Gets the PANTONE 7496 color.
static (Shared in Visual Basic) | PANTONE7497 | Gets the PANTONE 7497 color.
static (Shared in Visual Basic) | PANTONE7498 | Gets the PANTONE 7498 color.
static (Shared in Visual Basic) | PANTONE7499 | Gets the PANTONE 7499 color.
static (Shared in Visual Basic) | PANTONE7500 | Gets the PANTONE 7500 color.
static (Shared in Visual Basic) | PANTONE7501 | Gets the PANTONE 7501 color.
static (Shared in Visual Basic) | PANTONE7502 | Gets the PANTONE 7502 color.
static (Shared in Visual Basic) | PANTONE7503 | Gets the PANTONE 7503 color.
static (Shared in Visual Basic) | PANTONE7504 | Gets the PANTONE 7504 color.
static (Shared in Visual Basic) | PANTONE7505 | Gets the PANTONE 7505 color.
static (Shared in Visual Basic) | PANTONE7506 | Gets the PANTONE 7506 color.
static (Shared in Visual Basic) | PANTONE7507 | Gets the PANTONE 7507 color.
static (Shared in Visual Basic) | PANTONE7508 | Gets the PANTONE 7508 color.
static (Shared in Visual Basic) | PANTONE7509 | Gets the PANTONE 7509 color.
static (Shared in Visual Basic) | PANTONE7510 | Gets the PANTONE 7510 color.
static (Shared in Visual Basic) | PANTONE7511 | Gets the PANTONE 7511 color.
static (Shared in Visual Basic) | PANTONE7512 | Gets the PANTONE 7512 color.
static (Shared in Visual Basic) | PANTONE7513 | Gets the PANTONE 7513 color.
static (Shared in Visual Basic) | PANTONE7514 | Gets the PANTONE 7514 color.
static (Shared in Visual Basic) | PANTONE7515 | Gets the PANTONE 7515 color.
static (Shared in Visual Basic) | PANTONE7516 | Gets the PANTONE 7516 color.
static (Shared in Visual Basic) | PANTONE7517 | Gets the PANTONE 7517 color.
static (Shared in Visual Basic) | PANTONE7518 | Gets the PANTONE 7518 color.
static (Shared in Visual Basic) | PANTONE7519 | Gets the PANTONE 7519 color.
static (Shared in Visual Basic) | PANTONE7520 | Gets the PANTONE 7520 color.
static (Shared in Visual Basic) | PANTONE7521 | Gets the PANTONE 7521 color.
static (Shared in Visual Basic) | PANTONE7522 | Gets the PANTONE 7522 color.
static (Shared in Visual Basic) | PANTONE7523 | Gets the PANTONE 7523 color.
static (Shared in Visual Basic) | PANTONE7524 | Gets the PANTONE 7524 color.
static (Shared in Visual Basic) | PANTONE7525 | Gets the PANTONE 7525 color.
static (Shared in Visual Basic) | PANTONE7526 | Gets the PANTONE 7526 color.
static (Shared in Visual Basic) | PANTONE7527 | Gets the PANTONE 7527 color.
static (Shared in Visual Basic) | PANTONE7528 | Gets the PANTONE 7528 color.
static (Shared in Visual Basic) | PANTONE7529 | Gets the PANTONE 7529 color.
static (Shared in Visual Basic) | PANTONE7530 | Gets the PANTONE 7530 color.
static (Shared in Visual Basic) | PANTONE7531 | Gets the PANTONE 7531 color.
static (Shared in Visual Basic) | PANTONE7532 | Gets the PANTONE 7532 color.
static (Shared in Visual Basic) | PANTONE7533 | Gets the PANTONE 7533 color.
static (Shared in Visual Basic) | PANTONE7534 | Gets the PANTONE 7534 color.
static (Shared in Visual Basic) | PANTONE7535 | Gets the PANTONE 7535 color.
static (Shared in Visual Basic) | PANTONE7536 | Gets the PANTONE 7536 color.
static (Shared in Visual Basic) | PANTONE7537 | Gets the PANTONE 7537 color.
static (Shared in Visual Basic) | PANTONE7538 | Gets the PANTONE 7538 color.
static (Shared in Visual Basic) | PANTONE7539 | Gets the PANTONE 7539 color.
static (Shared in Visual Basic) | PANTONE7540 | Gets the PANTONE 7540 color.
static (Shared in Visual Basic) | PANTONE7541 | Gets the PANTONE 7541 color.
static (Shared in Visual Basic) | PANTONE7542 | Gets the PANTONE 7542 color.
static (Shared in Visual Basic) | PANTONE7543 | Gets the PANTONE 7543 color.
static (Shared in Visual Basic) | PANTONE7544 | Gets the PANTONE 7544 color.
static (Shared in Visual Basic) | PANTONE7545 | Gets the PANTONE 7545 color.
static (Shared in Visual Basic) | PANTONE7546 | Gets the PANTONE 7546 color.
static (Shared in Visual Basic) | PANTONE7547 | Gets the PANTONE 7547 color.
static (Shared in Visual Basic) | PANTONE8003 | Gets the PANTONE 8003 color.
static (Shared in Visual Basic) | PANTONE801 | Gets the PANTONE 801 color.
static (Shared in Visual Basic) | PANTONE802 | Gets the PANTONE 802 color.
static (Shared in Visual Basic) | PANTONE8021 | Gets the PANTONE 8021 color.
static (Shared in Visual Basic) | PANTONE803 | Gets the PANTONE 803 color.
static (Shared in Visual Basic) | PANTONE804 | Gets the PANTONE 804 color.
static (Shared in Visual Basic) | PANTONE805 | Gets the PANTONE 805 color.
static (Shared in Visual Basic) | PANTONE806 | Gets the PANTONE 806 color.
static (Shared in Visual Basic) | PANTONE8062 | Gets the PANTONE 8062 color.
static (Shared in Visual Basic) | PANTONE807 | Gets the PANTONE 807 color.
static (Shared in Visual Basic) | PANTONE808 | Gets the PANTONE 808 color.
static (Shared in Visual Basic) | PANTONE809 | Gets the PANTONE 809 color.
static (Shared in Visual Basic) | PANTONE810 | Gets the PANTONE 810 color.
static (Shared in Visual Basic) | PANTONE8100 | Gets the PANTONE 8100 color.
static (Shared in Visual Basic) | PANTONE811 | Gets the PANTONE 811 color.
static (Shared in Visual Basic) | PANTONE812 | Gets the PANTONE 812 color.
static (Shared in Visual Basic) | PANTONE813 | Gets the PANTONE 813 color.
static (Shared in Visual Basic) | PANTONE814 | Gets the PANTONE 814 color.
static (Shared in Visual Basic) | PANTONE8201 | Gets the PANTONE 8201 color.
static (Shared in Visual Basic) | PANTONE8281 | Gets the PANTONE 8281 color.
static (Shared in Visual Basic) | PANTONE8321 | Gets the PANTONE 8321 color.
static (Shared in Visual Basic) | PANTONE871 | Gets the PANTONE 871 color.
static (Shared in Visual Basic) | PANTONE872 | Gets the PANTONE 872 color.
static (Shared in Visual Basic) | PANTONE873 | Gets the PANTONE 873 color.
static (Shared in Visual Basic) | PANTONE874 | Gets the PANTONE 874 color.
static (Shared in Visual Basic) | PANTONE875 | Gets the PANTONE 875 color.
static (Shared in Visual Basic) | PANTONE876 | Gets the PANTONE 876 color.
static (Shared in Visual Basic) | PANTONE877 | Gets the PANTONE 877 color.
static (Shared in Visual Basic) | ProcessBlack | Gets the PANTONE Process Black color.
static (Shared in Visual Basic) | ProcessBlue | Gets the PANTONE Process Blue color.
static (Shared in Visual Basic) | ProcessCyan | Gets the PANTONE Process Cyan color.
static (Shared in Visual Basic) | ProcessMagenta | Gets the PANTONE Process Magenta color.
static (Shared in Visual Basic) | ProcessYellow | Gets the PANTONE Process Yellow color.
static (Shared in Visual Basic) | Purple | Gets the PANTONE Purple color.
static (Shared in Visual Basic) | Red032 | Gets the PANTONE Red 032 color.
static (Shared in Visual Basic) | ReflexBlue | Gets the PANTONE Reflex Blue color.
static (Shared in Visual Basic) | RhodamineRed | Gets the PANTONE Rhodamine Red color.
static (Shared in Visual Basic) | RubineRed | Gets the PANTONE Rubine Red color.
Public Property | Tint | Gets or sets the tint for this color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
static (Shared in Visual Basic) | Violet | Gets the PANTONE Violet color.
static (Shared in Visual Basic) | WarmGray1 | Gets the PANTONE Warm Gray 1 color.
static (Shared in Visual Basic) | WarmGray10 | Gets the PANTONE Warm Gray 10 color.
static (Shared in Visual Basic) | WarmGray11 | Gets the PANTONE Warm Gray 11 color.
static (Shared in Visual Basic) | WarmGray2 | Gets the PANTONE Warm Gray 2 color.
static (Shared in Visual Basic) | WarmGray3 | Gets the PANTONE Warm Gray 3 color.
static (Shared in Visual Basic) | WarmGray4 | Gets the PANTONE Warm Gray 4 color.
static (Shared in Visual Basic) | WarmGray5 | Gets the PANTONE Warm Gray 5 color.
static (Shared in Visual Basic) | WarmGray6 | Gets the PANTONE Warm Gray 6 color.
static (Shared in Visual Basic) | WarmGray7 | Gets the PANTONE Warm Gray 7 color.
static (Shared in Visual Basic) | WarmGray8 | Gets the PANTONE Warm Gray 8 color.
static (Shared in Visual Basic) | WarmGray9 | Gets the PANTONE Warm Gray 9 color.
static (Shared in Visual Basic) | WarmRed | Gets the PANTONE Warm Red color.
static (Shared in Visual Basic) | Yellow | Gets the PANTONE Yellow color.
static (Shared in Visual Basic) | Yellow012 | Gets the PANTONE Yellow 012 color.
Top

Public Methods

 | Name | Description
Public Method | Clone | Clones this color object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
Public Method | Equals | Verifies if the given object is equal to this object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
static (Shared in Visual Basic) | FromName | Creates a Pantone color from a known pantone name.
Public Method | GetHashCode | Gets the hash code of this object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
Public Method | ToString | Converts the color object to string representation. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
Top

See Also

Reference

PDFPantoneColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFPantoneColor Class Methods

PDFPantoneColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPantoneColor Class

For a list of all members of this type, see PDFPantoneColor members.

Public Methods

 | Name | Description
Public Method | Clone | Clones this color object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
Public Method | Equals | Verifies if the given object is equal to this object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
static (Shared in Visual Basic) | FromName | Creates a Pantone color from a known pantone name.
Public Method | GetHashCode | Gets the hash code of this object. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
Public Method | ToString | Converts the color object to string representation. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
Top

See Also

Reference

PDFPantoneColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


FromName Method

FromName Method
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : FromName Method

pantoneName
Name of pantone color.
Creates a Pantone color from a known pantone name.

Syntax

Visual Basic (Declaration)
Public Shared Function FromName( _
   ByVal pantoneName As String _
) As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim pantoneName As String
Dim value As PDFPantoneColor

value = PDFPantoneColor.FromName(pantoneName)
C#
public static PDFPantoneColor FromName(
   string pantoneName
)
Managed Extensions for C++
public: static PDFPantoneColor* FromName(
   string* pantoneName
)
C++/CLI
public:
static PDFPantoneColor^ FromName(
   String^ pantoneName
)

Parameters

pantoneName
Name of pantone color.

Return Value

The pantone color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PDFPantoneColor Class Properties

PDFPantoneColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPantoneColor Class

For a list of all members of this type, see PDFPantoneColor members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Black | Gets the PANTONE Black color.
static (Shared in Visual Basic) | Black2 | Gets the PANTONE Black 2 color.
static (Shared in Visual Basic) | Black3 | Gets the PANTONE Black 3 color.
static (Shared in Visual Basic) | Black4 | Gets the PANTONE Black 4 color.
static (Shared in Visual Basic) | Black5 | Gets the PANTONE Black 5 color.
static (Shared in Visual Basic) | Black6 | Gets the PANTONE Black 6 color.
static (Shared in Visual Basic) | Black7 | Gets the PANTONE Black 7 color.
static (Shared in Visual Basic) | Blue072 | Gets the PANTONE Blue 072 color.
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from O2S.Components.PDF4NET.Graphics.PDFColor)
static (Shared in Visual Basic) | CoolGray1 | Gets the PANTONE Cool Gray 1 color.
static (Shared in Visual Basic) | CoolGray10 | Gets the PANTONE Cool Gray 10 color.
static (Shared in Visual Basic) | CoolGray11 | Gets the PANTONE Cool Gray 11 color.
static (Shared in Visual Basic) | CoolGray2 | Gets the PANTONE Cool Gray 2 color.
static (Shared in Visual Basic) | CoolGray3 | Gets the PANTONE Cool Gray 3 color.
static (Shared in Visual Basic) | CoolGray4 | Gets the PANTONE Cool Gray 4 color.
static (Shared in Visual Basic) | CoolGray5 | Gets the PANTONE Cool Gray 5 color.
static (Shared in Visual Basic) | CoolGray6 | Gets the PANTONE Cool Gray 6 color.
static (Shared in Visual Basic) | CoolGray7 | Gets the PANTONE Cool Gray 7 color.
static (Shared in Visual Basic) | CoolGray8 | Gets the PANTONE Cool Gray 8 color.
static (Shared in Visual Basic) | CoolGray9 | Gets the PANTONE Cool Gray 9 color.
static (Shared in Visual Basic) | Green | Gets the PANTONE Green color.
static (Shared in Visual Basic) | HexachromeBlack | Gets the PANTONE Hexachrome Black color.
static (Shared in Visual Basic) | HexachromeCyan | Gets the PANTONE Hexachrome Cyan color.
static (Shared in Visual Basic) | HexachromeGreen | Gets the PANTONE Hexachrome Green color.
static (Shared in Visual Basic) | HexachromeMagenta | Gets the PANTONE Hexachrome Magenta color.
static (Shared in Visual Basic) | HexachromeOrange | Gets the PANTONE Hexachrome Orange color.
static (Shared in Visual Basic) | HexachromeYellow | Gets the PANTONE Hexachrome Yellow color.
static (Shared in Visual Basic) | Orange021 | Gets the PANTONE Orange 021 color.
static (Shared in Visual Basic) | PANTONE100 | Gets the PANTONE 100 color.
static (Shared in Visual Basic) | PANTONE101 | Gets the PANTONE 101 color.
static (Shared in Visual Basic) | PANTONE102 | Gets the PANTONE 102 color.
static (Shared in Visual Basic) | PANTONE103 | Gets the PANTONE 103 color.
static (Shared in Visual Basic) | PANTONE104 | Gets the PANTONE 104 color.
static (Shared in Visual Basic) | PANTONE105 | Gets the PANTONE 105 color.
static (Shared in Visual Basic) | PANTONE106 | Gets the PANTONE 106 color.
static (Shared in Visual Basic) | PANTONE107 | Gets the PANTONE 107 color.
static (Shared in Visual Basic) | PANTONE108 | Gets the PANTONE 108 color.
static (Shared in Visual Basic) | PANTONE109 | Gets the PANTONE 109 color.
static (Shared in Visual Basic) | PANTONE110 | Gets the PANTONE 110 color.
static (Shared in Visual Basic) | PANTONE111 | Gets the PANTONE 111 color.
static (Shared in Visual Basic) | PANTONE112 | Gets the PANTONE 112 color.
static (Shared in Visual Basic) | PANTONE113 | Gets the PANTONE 113 color.
static (Shared in Visual Basic) | PANTONE114 | Gets the PANTONE 114 color.
static (Shared in Visual Basic) | PANTONE115 | Gets the PANTONE 115 color.
static (Shared in Visual Basic) | PANTONE116 | Gets the PANTONE 116 color.
static (Shared in Visual Basic) | PANTONE117 | Gets the PANTONE 117 color.
static (Shared in Visual Basic) | PANTONE118 | Gets the PANTONE 118 color.
static (Shared in Visual Basic) | PANTONE119 | Gets the PANTONE 119 color.
static (Shared in Visual Basic) | PANTONE120 | Gets the PANTONE 120 color.
static (Shared in Visual Basic) | PANTONE1205 | Gets the PANTONE 1205 color.
static (Shared in Visual Basic) | PANTONE121 | Gets the PANTONE 121 color.
static (Shared in Visual Basic) | PANTONE1215 | Gets the PANTONE 1215 color.
static (Shared in Visual Basic) | PANTONE122 | Gets the PANTONE 122 color.
static (Shared in Visual Basic) | PANTONE1225 | Gets the PANTONE 1225 color.
static (Shared in Visual Basic) | PANTONE123 | Gets the PANTONE 123 color.
static (Shared in Visual Basic) | PANTONE1235 | Gets the PANTONE 1235 color.
static (Shared in Visual Basic) | PANTONE124 | Gets the PANTONE 124 color.
static (Shared in Visual Basic) | PANTONE1245 | Gets the PANTONE 1245 color.
static (Shared in Visual Basic) | PANTONE125 | Gets the PANTONE 125 color.
static (Shared in Visual Basic) | PANTONE1255 | Gets the PANTONE 1255 color.
static (Shared in Visual Basic) | PANTONE126 | Gets the PANTONE 126 color.
static (Shared in Visual Basic) | PANTONE1265 | Gets the PANTONE 1265 color.
static (Shared in Visual Basic) | PANTONE127 | Gets the PANTONE 127 color.
static (Shared in Visual Basic) | PANTONE128 | Gets the PANTONE 128 color.
static (Shared in Visual Basic) | PANTONE129 | Gets the PANTONE 129 color.
static (Shared in Visual Basic) | PANTONE130 | Gets the PANTONE 130 color.
static (Shared in Visual Basic) | PANTONE131 | Gets the PANTONE 131 color.
static (Shared in Visual Basic) | PANTONE132 | Gets the PANTONE 132 color.
static (Shared in Visual Basic) | PANTONE133 | Gets the PANTONE 133 color.
static (Shared in Visual Basic) | PANTONE134 | Gets the PANTONE 134 color.
static (Shared in Visual Basic) | PANTONE1345 | Gets the PANTONE 1345 color.
static (Shared in Visual Basic) | PANTONE135 | Gets the PANTONE 135 color.
static (Shared in Visual Basic) | PANTONE1355 | Gets the PANTONE 1355 color.
static (Shared in Visual Basic) | PANTONE136 | Gets the PANTONE 136 color.
static (Shared in Visual Basic) | PANTONE1365 | Gets the PANTONE 1365 color.
static (Shared in Visual Basic) | PANTONE137 | Gets the PANTONE 137 color.
static (Shared in Visual Basic) | PANTONE1375 | Gets the PANTONE 1375 color.
static (Shared in Visual Basic) | PANTONE138 | Gets the PANTONE 138 color.
static (Shared in Visual Basic) | PANTONE1385 | Gets the PANTONE 1385 color.
static (Shared in Visual Basic) | PANTONE139 | Gets the PANTONE 139 color.
static (Shared in Visual Basic) | PANTONE1395 | Gets the PANTONE 1395 color.
static (Shared in Visual Basic) | PANTONE140 | Gets the PANTONE 140 color.
static (Shared in Visual Basic) | PANTONE1405 | Gets the PANTONE 1405 color.
static (Shared in Visual Basic) | PANTONE141 | Gets the PANTONE 141 color.
static (Shared in Visual Basic) | PANTONE142 | Gets the PANTONE 142 color.
static (Shared in Visual Basic) | PANTONE143 | Gets the PANTONE 143 color.
static (Shared in Visual Basic) | PANTONE144 | Gets the PANTONE 144 color.
static (Shared in Visual Basic) | PANTONE145 | Gets the PANTONE 145 color.
static (Shared in Visual Basic) | PANTONE146 | Gets the PANTONE 146 color.
static (Shared in Visual Basic) | PANTONE147 | Gets the PANTONE 147 color.
static (Shared in Visual Basic) | PANTONE148 | Gets the PANTONE 148 color.
static (Shared in Visual Basic) | PANTONE1485 | Gets the PANTONE 1485 color.
static (Shared in Visual Basic) | PANTONE149 | Gets the PANTONE 149 color.
static (Shared in Visual Basic) | PANTONE1495 | Gets the PANTONE 1495 color.
static (Shared in Visual Basic) | PANTONE150 | Gets the PANTONE 150 color.
static (Shared in Visual Basic) | PANTONE1505 | Gets the PANTONE 1505 color.
static (Shared in Visual Basic) | PANTONE151 | Gets the PANTONE 151 color.
static (Shared in Visual Basic) | PANTONE152 | Gets the PANTONE 152 color.
static (Shared in Visual Basic) | PANTONE1525 | Gets the PANTONE 1525 color.
static (Shared in Visual Basic) | PANTONE153 | Gets the PANTONE 153 color.
static (Shared in Visual Basic) | PANTONE1535 | Gets the PANTONE 1535 color.
static (Shared in Visual Basic) | PANTONE154 | Gets the PANTONE 154 color.
static (Shared in Visual Basic) | PANTONE1545 | Gets the PANTONE 1545 color.
static (Shared in Visual Basic) | PANTONE155 | Gets the PANTONE 155 color.
static (Shared in Visual Basic) | PANTONE1555 | Gets the PANTONE 1555 color.
static (Shared in Visual Basic) | PANTONE156 | Gets the PANTONE 156 color.
static (Shared in Visual Basic) | PANTONE1565 | Gets the PANTONE 1565 color.
static (Shared in Visual Basic) | PANTONE157 | Gets the PANTONE 157 color.
static (Shared in Visual Basic) | PANTONE1575 | Gets the PANTONE 1575 color.
static (Shared in Visual Basic) | PANTONE158 | Gets the PANTONE 158 color.
static (Shared in Visual Basic) | PANTONE1585 | Gets the PANTONE 1585 color.
static (Shared in Visual Basic) | PANTONE159 | Gets the PANTONE 159 color.
static (Shared in Visual Basic) | PANTONE1595 | Gets the PANTONE 1595 color.
static (Shared in Visual Basic) | PANTONE160 | Gets the PANTONE 160 color.
static (Shared in Visual Basic) | PANTONE1605 | Gets the PANTONE 1605 color.
static (Shared in Visual Basic) | PANTONE161 | Gets the PANTONE 161 color.
static (Shared in Visual Basic) | PANTONE1615 | Gets the PANTONE 1615 color.
static (Shared in Visual Basic) | PANTONE162 | Gets the PANTONE 162 color.
static (Shared in Visual Basic) | PANTONE1625 | Gets the PANTONE 1625 color.
static (Shared in Visual Basic) | PANTONE163 | Gets the PANTONE 163 color.
static (Shared in Visual Basic) | PANTONE1635 | Gets the PANTONE 1635 color.
static (Shared in Visual Basic) | PANTONE164 | Gets the PANTONE 164 color.
static (Shared in Visual Basic) | PANTONE1645 | Gets the PANTONE 1645 color.
static (Shared in Visual Basic) | PANTONE165 | Gets the PANTONE 165 color.
static (Shared in Visual Basic) | PANTONE1655 | Gets the PANTONE 1655 color.
static (Shared in Visual Basic) | PANTONE166 | Gets the PANTONE 166 color.
static (Shared in Visual Basic) | PANTONE1665 | Gets the PANTONE 1665 color.
static (Shared in Visual Basic) | PANTONE167 | Gets the PANTONE 167 color.
static (Shared in Visual Basic) | PANTONE1675 | Gets the PANTONE 1675 color.
static (Shared in Visual Basic) | PANTONE168 | Gets the PANTONE 168 color.
static (Shared in Visual Basic) | PANTONE1685 | Gets the PANTONE 1685 color.
static (Shared in Visual Basic) | PANTONE169 | Gets the PANTONE 169 color.
static (Shared in Visual Basic) | PANTONE170 | Gets the PANTONE 170 color.
static (Shared in Visual Basic) | PANTONE171 | Gets the PANTONE 171 color.
static (Shared in Visual Basic) | PANTONE172 | Gets the PANTONE 172 color.
static (Shared in Visual Basic) | PANTONE173 | Gets the PANTONE 173 color.
static (Shared in Visual Basic) | PANTONE174 | Gets the PANTONE 174 color.
static (Shared in Visual Basic) | PANTONE175 | Gets the PANTONE 175 color.
static (Shared in Visual Basic) | PANTONE176 | Gets the PANTONE 176 color.
static (Shared in Visual Basic) | PANTONE1765 | Gets the PANTONE 1765 color.
static (Shared in Visual Basic) | PANTONE1767 | Gets the PANTONE 1767 color.
static (Shared in Visual Basic) | PANTONE177 | Gets the PANTONE 177 color.
static (Shared in Visual Basic) | PANTONE1775 | Gets the PANTONE 1775 color.
static (Shared in Visual Basic) | PANTONE1777 | Gets the PANTONE 1777 color.
static (Shared in Visual Basic) | PANTONE178 | Gets the PANTONE 178 color.
static (Shared in Visual Basic) | PANTONE1785 | Gets the PANTONE 1785 color.
static (Shared in Visual Basic) | PANTONE1787 | Gets the PANTONE 1787 color.
static (Shared in Visual Basic) | PANTONE1788 | Gets the PANTONE 1788 color.
static (Shared in Visual Basic) | PANTONE179 | Gets the PANTONE 179 color.
static (Shared in Visual Basic) | PANTONE1795 | Gets the PANTONE 1795 color.
static (Shared in Visual Basic) | PANTONE1797 | Gets the PANTONE 1797 color.
static (Shared in Visual Basic) | PANTONE180 | Gets the PANTONE 180 color.
static (Shared in Visual Basic) | PANTONE1805 | Gets the PANTONE 1805 color.
static (Shared in Visual Basic) | PANTONE1807 | Gets the PANTONE 1807 color.
static (Shared in Visual Basic) | PANTONE181 | Gets the PANTONE 181 color.
static (Shared in Visual Basic) | PANTONE1815 | Gets the PANTONE 1815 color.
static (Shared in Visual Basic) | PANTONE1817 | Gets the PANTONE 1817 color.
static (Shared in Visual Basic) | PANTONE182 | Gets the PANTONE 182 color.
static (Shared in Visual Basic) | PANTONE183 | Gets the PANTONE 183 color.
static (Shared in Visual Basic) | PANTONE184 | Gets the PANTONE 184 color.
static (Shared in Visual Basic) | PANTONE185 | Gets the PANTONE 185 color.
static (Shared in Visual Basic) | PANTONE186 | Gets the PANTONE 186 color.
static (Shared in Visual Basic) | PANTONE187 | Gets the PANTONE 187 color.
static (Shared in Visual Basic) | PANTONE188 | Gets the PANTONE 188 color.
static (Shared in Visual Basic) | PANTONE189 | Gets the PANTONE 189 color.
static (Shared in Visual Basic) | PANTONE1895 | Gets the PANTONE 1895 color.
static (Shared in Visual Basic) | PANTONE190 | Gets the PANTONE 190 color.
static (Shared in Visual Basic) | PANTONE1905 | Gets the PANTONE 1905 color.
static (Shared in Visual Basic) | PANTONE191 | Gets the PANTONE 191 color.
static (Shared in Visual Basic) | PANTONE1915 | Gets the PANTONE 1915 color.
static (Shared in Visual Basic) | PANTONE192 | Gets the PANTONE 192 color.
static (Shared in Visual Basic) | PANTONE1925 | Gets the PANTONE 1925 color.
static (Shared in Visual Basic) | PANTONE193 | Gets the PANTONE 193 color.
static (Shared in Visual Basic) | PANTONE1935 | Gets the PANTONE 1935 color.
static (Shared in Visual Basic) | PANTONE194 | Gets the PANTONE 194 color.
static (Shared in Visual Basic) | PANTONE1945 | Gets the PANTONE 1945 color.
static (Shared in Visual Basic) | PANTONE195 | Gets the PANTONE 195 color.
static (Shared in Visual Basic) | PANTONE1955 | Gets the PANTONE 1955 color.
static (Shared in Visual Basic) | PANTONE196 | Gets the PANTONE 196 color.
static (Shared in Visual Basic) | PANTONE197 | Gets the PANTONE 197 color.
static (Shared in Visual Basic) | PANTONE198 | Gets the PANTONE 198 color.
static (Shared in Visual Basic) | PANTONE199 | Gets the PANTONE 199 color.
static (Shared in Visual Basic) | PANTONE200 | Gets the PANTONE 200 color.
static (Shared in Visual Basic) | PANTONE201 | Gets the PANTONE 201 color.
static (Shared in Visual Basic) | PANTONE202 | Gets the PANTONE 202 color.
static (Shared in Visual Basic) | PANTONE203 | Gets the PANTONE 203 color.
static (Shared in Visual Basic) | PANTONE204 | Gets the PANTONE 204 color.
static (Shared in Visual Basic) | PANTONE205 | Gets the PANTONE 205 color.
static (Shared in Visual Basic) | PANTONE206 | Gets the PANTONE 206 color.
static (Shared in Visual Basic) | PANTONE207 | Gets the PANTONE 207 color.
static (Shared in Visual Basic) | PANTONE208 | Gets the PANTONE 208 color.
static (Shared in Visual Basic) | PANTONE209 | Gets the PANTONE 209 color.
static (Shared in Visual Basic) | PANTONE210 | Gets the PANTONE 210 color.
static (Shared in Visual Basic) | PANTONE211 | Gets the PANTONE 211 color.
static (Shared in Visual Basic) | PANTONE212 | Gets the PANTONE 212 color.
static (Shared in Visual Basic) | PANTONE213 | Gets the PANTONE 213 color.
static (Shared in Visual Basic) | PANTONE214 | Gets the PANTONE 214 color.
static (Shared in Visual Basic) | PANTONE215 | Gets the PANTONE 215 color.
static (Shared in Visual Basic) | PANTONE216 | Gets the PANTONE 216 color.
static (Shared in Visual Basic) | PANTONE217 | Gets the PANTONE 217 color.
static (Shared in Visual Basic) | PANTONE218 | Gets the PANTONE 218 color.
static (Shared in Visual Basic) | PANTONE219 | Gets the PANTONE 219 color.
static (Shared in Visual Basic) | PANTONE220 | Gets the PANTONE 220 color.
static (Shared in Visual Basic) | PANTONE221 | Gets the PANTONE 221 color.
static (Shared in Visual Basic) | PANTONE222 | Gets the PANTONE 222 color.
static (Shared in Visual Basic) | PANTONE223 | Gets the PANTONE 223 color.
static (Shared in Visual Basic) | PANTONE224 | Gets the PANTONE 224 color.
static (Shared in Visual Basic) | PANTONE225 | Gets the PANTONE 225 color.
static (Shared in Visual Basic) | PANTONE226 | Gets the PANTONE 226 color.
static (Shared in Visual Basic) | PANTONE227 | Gets the PANTONE 227 color.
static (Shared in Visual Basic) | PANTONE228 | Gets the PANTONE 228 color.
static (Shared in Visual Basic) | PANTONE229 | Gets the PANTONE 229 color.
static (Shared in Visual Basic) | PANTONE230 | Gets the PANTONE 230 color.
static (Shared in Visual Basic) | PANTONE231 | Gets the PANTONE 231 color.
static (Shared in Visual Basic) | PANTONE232 | Gets the PANTONE 232 color.
static (Shared in Visual Basic) | PANTONE233 | Gets the PANTONE 233 color.
static (Shared in Visual Basic) | PANTONE234 | Gets the PANTONE 234 color.
static (Shared in Visual Basic) | PANTONE235 | Gets the PANTONE 235 color.
static (Shared in Visual Basic) | PANTONE236 | Gets the PANTONE 236 color.
static (Shared in Visual Basic) | PANTONE2365 | Gets the PANTONE 2365 color.
static (Shared in Visual Basic) | PANTONE237 | Gets the PANTONE 237 color.
static (Shared in Visual Basic) | PANTONE2375 | Gets the PANTONE 2375 color.
static (Shared in Visual Basic) | PANTONE238 | Gets the PANTONE 238 color.
static (Shared in Visual Basic) | PANTONE2385 | Gets the PANTONE 2385 color.
static (Shared in Visual Basic) | PANTONE239 | Gets the PANTONE 239 color.
static (Shared in Visual Basic) | PANTONE2395 | Gets the PANTONE 2395 color.
static (Shared in Visual Basic) | PANTONE240 | Gets the PANTONE 240 color.
static (Shared in Visual Basic) | PANTONE2405 | Gets the PANTONE 2405 color.
static (Shared in Visual Basic) | PANTONE241 | Gets the PANTONE 241 color.
static (Shared in Visual Basic) | PANTONE2415 | Gets the PANTONE 2415 color.
static (Shared in Visual Basic) | PANTONE242 | Gets the PANTONE 242 color.
static (Shared in Visual Basic) | PANTONE2425 | Gets the PANTONE 2425 color.
static (Shared in Visual Basic) | PANTONE243 | Gets the PANTONE 243 color.
static (Shared in Visual Basic) | PANTONE244 | Gets the PANTONE 244 color.
static (Shared in Visual Basic) | PANTONE245 | Gets the PANTONE 245 color.
static (Shared in Visual Basic) | PANTONE246 | Gets the PANTONE 246 color.
static (Shared in Visual Basic) | PANTONE247 | Gets the PANTONE 247 color.
static (Shared in Visual Basic) | PANTONE248 | Gets the PANTONE 248 color.
static (Shared in Visual Basic) | PANTONE249 | Gets the PANTONE 249 color.
static (Shared in Visual Basic) | PANTONE250 | Gets the PANTONE 250 color.
static (Shared in Visual Basic) | PANTONE251 | Gets the PANTONE 251 color.
static (Shared in Visual Basic) | PANTONE252 | Gets the PANTONE 252 color.
static (Shared in Visual Basic) | PANTONE253 | Gets the PANTONE 253 color.
static (Shared in Visual Basic) | PANTONE254 | Gets the PANTONE 254 color.
static (Shared in Visual Basic) | PANTONE255 | Gets the PANTONE 255 color.
static (Shared in Visual Basic) | PANTONE256 | Gets the PANTONE 256 color.
static (Shared in Visual Basic) | PANTONE2562 | Gets the PANTONE 2562 color.
static (Shared in Visual Basic) | PANTONE2563 | Gets the PANTONE 2563 color.
static (Shared in Visual Basic) | PANTONE2567 | Gets the PANTONE 2567 color.
static (Shared in Visual Basic) | PANTONE257 | Gets the PANTONE 257 color.
static (Shared in Visual Basic) | PANTONE2572 | Gets the PANTONE 2572 color.
static (Shared in Visual Basic) | PANTONE2573 | Gets the PANTONE 2573 color.
static (Shared in Visual Basic) | PANTONE2577 | Gets the PANTONE 2577 color.
static (Shared in Visual Basic) | PANTONE258 | Gets the PANTONE 258 color.
static (Shared in Visual Basic) | PANTONE2582 | Gets the PANTONE 2582 color.
static (Shared in Visual Basic) | PANTONE2583 | Gets the PANTONE 2583 color.
static (Shared in Visual Basic) | PANTONE2587 | Gets the PANTONE 2587 color.
static (Shared in Visual Basic) | PANTONE259 | Gets the PANTONE 259 color.
static (Shared in Visual Basic) | PANTONE2592 | Gets the PANTONE 2592 color.
static (Shared in Visual Basic) | PANTONE2593 | Gets the PANTONE 2593 color.
static (Shared in Visual Basic) | PANTONE2597 | Gets the PANTONE 2597 color.
static (Shared in Visual Basic) | PANTONE260 | Gets the PANTONE 260 color.
static (Shared in Visual Basic) | PANTONE2602 | Gets the PANTONE 2602 color.
static (Shared in Visual Basic) | PANTONE2603 | Gets the PANTONE 2603 color.
static (Shared in Visual Basic) | PANTONE2607 | Gets the PANTONE 2607 color.
static (Shared in Visual Basic) | PANTONE261 | Gets the PANTONE 261 color.
static (Shared in Visual Basic) | PANTONE2612 | Gets the PANTONE 2612 color.
static (Shared in Visual Basic) | PANTONE2613 | Gets the PANTONE 2613 color.
static (Shared in Visual Basic) | PANTONE2617 | Gets the PANTONE 2617 color.
static (Shared in Visual Basic) | PANTONE262 | Gets the PANTONE 262 color.
static (Shared in Visual Basic) | PANTONE2622 | Gets the PANTONE 2622 color.
static (Shared in Visual Basic) | PANTONE2623 | Gets the PANTONE 2623 color.
static (Shared in Visual Basic) | PANTONE2627 | Gets the PANTONE 2627 color.
static (Shared in Visual Basic) | PANTONE263 | Gets the PANTONE 263 color.
static (Shared in Visual Basic) | PANTONE2635 | Gets the PANTONE 2635 color.
static (Shared in Visual Basic) | PANTONE264 | Gets the PANTONE 264 color.
static (Shared in Visual Basic) | PANTONE2645 | Gets the PANTONE 2645 color.
static (Shared in Visual Basic) | PANTONE265 | Gets the PANTONE 265 color.
static (Shared in Visual Basic) | PANTONE2655 | Gets the PANTONE 2655 color.
static (Shared in Visual Basic) | PANTONE266 | Gets the PANTONE 266 color.
static (Shared in Visual Basic) | PANTONE2665 | Gets the PANTONE 2665 color.
static (Shared in Visual Basic) | PANTONE267 | Gets the PANTONE 267 color.
static (Shared in Visual Basic) | PANTONE268 | Gets the PANTONE 268 color.
static (Shared in Visual Basic) | PANTONE2685 | Gets the PANTONE 2685 color.
static (Shared in Visual Basic) | PANTONE269 | Gets the PANTONE 269 color.
static (Shared in Visual Basic) | PANTONE2695 | Gets the PANTONE 2695 color.
static (Shared in Visual Basic) | PANTONE270 | Gets the PANTONE 270 color.
static (Shared in Visual Basic) | PANTONE2705 | Gets the PANTONE 2705 color.
static (Shared in Visual Basic) | PANTONE2706 | Gets the PANTONE 2706 color.
static (Shared in Visual Basic) | PANTONE2707 | Gets the PANTONE 2707 color.
static (Shared in Visual Basic) | PANTONE2708 | Gets the PANTONE 2708 color.
static (Shared in Visual Basic) | PANTONE271 | Gets the PANTONE 271 color.
static (Shared in Visual Basic) | PANTONE2715 | Gets the PANTONE 2715 color.
static (Shared in Visual Basic) | PANTONE2716 | Gets the PANTONE 2716 color.
static (Shared in Visual Basic) | PANTONE2717 | Gets the PANTONE 2717 color.
static (Shared in Visual Basic) | PANTONE2718 | Gets the PANTONE 2718 color.
static (Shared in Visual Basic) | PANTONE272 | Gets the PANTONE 272 color.
static (Shared in Visual Basic) | PANTONE2725 | Gets the PANTONE 2725 color.
static (Shared in Visual Basic) | PANTONE2726 | Gets the PANTONE 2726 color.
static (Shared in Visual Basic) | PANTONE2727 | Gets the PANTONE 2727 color.
static (Shared in Visual Basic) | PANTONE2728 | Gets the PANTONE 2728 color.
static (Shared in Visual Basic) | PANTONE273 | Gets the PANTONE 273 color.
static (Shared in Visual Basic) | PANTONE2735 | Gets the PANTONE 2735 color.
static (Shared in Visual Basic) | PANTONE2736 | Gets the PANTONE 2736 color.
static (Shared in Visual Basic) | PANTONE2738 | Gets the PANTONE 2738 color.
static (Shared in Visual Basic) | PANTONE274 | Gets the PANTONE 274 color.
static (Shared in Visual Basic) | PANTONE2745 | Gets the PANTONE 2745 color.
static (Shared in Visual Basic) | PANTONE2746 | Gets the PANTONE 2746 color.
static (Shared in Visual Basic) | PANTONE2747 | Gets the PANTONE 2747 color.
static (Shared in Visual Basic) | PANTONE2748 | Gets the PANTONE 2748 color.
static (Shared in Visual Basic) | PANTONE275 | Gets the PANTONE 275 color.
static (Shared in Visual Basic) | PANTONE2755 | Gets the PANTONE 2755 color.
static (Shared in Visual Basic) | PANTONE2756 | Gets the PANTONE 2756 color.
static (Shared in Visual Basic) | PANTONE2757 | Gets the PANTONE 2757 color.
static (Shared in Visual Basic) | PANTONE2758 | Gets the PANTONE 2758 color.
static (Shared in Visual Basic) | PANTONE276 | Gets the PANTONE 276 color.
static (Shared in Visual Basic) | PANTONE2765 | Gets the PANTONE 2765 color.
static (Shared in Visual Basic) | PANTONE2766 | Gets the PANTONE 2766 color.
static (Shared in Visual Basic) | PANTONE2767 | Gets the PANTONE 2767 color.
static (Shared in Visual Basic) | PANTONE2768 | Gets the PANTONE 2768 color.
static (Shared in Visual Basic) | PANTONE277 | Gets the PANTONE 277 color.
static (Shared in Visual Basic) | PANTONE278 | Gets the PANTONE 278 color.
static (Shared in Visual Basic) | PANTONE279 | Gets the PANTONE 279 color.
static (Shared in Visual Basic) | PANTONE280 | Gets the PANTONE 280 color.
static (Shared in Visual Basic) | PANTONE281 | Gets the PANTONE 281 color.
static (Shared in Visual Basic) | PANTONE282 | Gets the PANTONE 282 color.
static (Shared in Visual Basic) | PANTONE283 | Gets the PANTONE 283 color.
static (Shared in Visual Basic) | PANTONE284 | Gets the PANTONE 284 color.
static (Shared in Visual Basic) | PANTONE285 | Gets the PANTONE 285 color.
static (Shared in Visual Basic) | PANTONE286 | Gets the PANTONE 286 color.
static (Shared in Visual Basic) | PANTONE287 | Gets the PANTONE 287 color.
static (Shared in Visual Basic) | PANTONE288 | Gets the PANTONE 288 color.
static (Shared in Visual Basic) | PANTONE289 | Gets the PANTONE 289 color.
static (Shared in Visual Basic) | PANTONE290 | Gets the PANTONE 290 color.
static (Shared in Visual Basic) | PANTONE2905 | Gets the PANTONE 2905 color.
static (Shared in Visual Basic) | PANTONE291 | Gets the PANTONE 291 color.
static (Shared in Visual Basic) | PANTONE2915 | Gets the PANTONE 2915 color.
static (Shared in Visual Basic) | PANTONE292 | Gets the PANTONE 292 color.
static (Shared in Visual Basic) | PANTONE2925 | Gets the PANTONE 2925 color.
static (Shared in Visual Basic) | PANTONE293 | Gets the PANTONE 293 color.
static (Shared in Visual Basic) | PANTONE2935 | Gets the PANTONE 2935 color.
static (Shared in Visual Basic) | PANTONE294 | Gets the PANTONE 294 color.
static (Shared in Visual Basic) | PANTONE2945 | Gets the PANTONE 2945 color.
static (Shared in Visual Basic) | PANTONE295 | Gets the PANTONE 295 color.
static (Shared in Visual Basic) | PANTONE2955 | Gets the PANTONE 2955 color.
static (Shared in Visual Basic) | PANTONE296 | Gets the PANTONE 296 color.
static (Shared in Visual Basic) | PANTONE2965 | Gets the PANTONE 2965 color.
static (Shared in Visual Basic) | PANTONE297 | Gets the PANTONE 297 color.
static (Shared in Visual Basic) | PANTONE2975 | Gets the PANTONE 2975 color.
static (Shared in Visual Basic) | PANTONE298 | Gets the PANTONE 298 color.
static (Shared in Visual Basic) | PANTONE2985 | Gets the PANTONE 2985 color.
static (Shared in Visual Basic) | PANTONE299 | Gets the PANTONE 299 color.
static (Shared in Visual Basic) | PANTONE2995 | Gets the PANTONE 2995 color.
static (Shared in Visual Basic) | PANTONE300 | Gets the PANTONE 300 color.
static (Shared in Visual Basic) | PANTONE3005 | Gets the PANTONE 3005 color.
static (Shared in Visual Basic) | PANTONE301 | Gets the PANTONE 301 color.
static (Shared in Visual Basic) | PANTONE3015 | Gets the PANTONE 3015 color.
static (Shared in Visual Basic) | PANTONE302 | Gets the PANTONE 302 color.
static (Shared in Visual Basic) | PANTONE3025 | Gets the PANTONE 3025 color.
static (Shared in Visual Basic) | PANTONE303 | Gets the PANTONE 303 color.
static (Shared in Visual Basic) | PANTONE3035 | Gets the PANTONE 3035 color.
static (Shared in Visual Basic) | PANTONE304 | Gets the PANTONE 304 color.
static (Shared in Visual Basic) | PANTONE305 | Gets the PANTONE 305 color.
static (Shared in Visual Basic) | PANTONE306 | Gets the PANTONE 306 color.
static (Shared in Visual Basic) | PANTONE307 | Gets the PANTONE 307 color.
static (Shared in Visual Basic) | PANTONE308 | Gets the PANTONE 308 color.
static (Shared in Visual Basic) | PANTONE309 | Gets the PANTONE 309 color.
static (Shared in Visual Basic) | PANTONE310 | Gets the PANTONE 310 color.
static (Shared in Visual Basic) | PANTONE3105 | Gets the PANTONE 3105 color.
static (Shared in Visual Basic) | PANTONE311 | Gets the PANTONE 311 color.
static (Shared in Visual Basic) | PANTONE3115 | Gets the PANTONE 3115 color.
static (Shared in Visual Basic) | PANTONE312 | Gets the PANTONE 312 color.
static (Shared in Visual Basic) | PANTONE3125 | Gets the PANTONE 3125 color.
static (Shared in Visual Basic) | PANTONE313 | Gets the PANTONE 313 color.
static (Shared in Visual Basic) | PANTONE3135 | Gets the PANTONE 3135 color.
static (Shared in Visual Basic) | PANTONE314 | Gets the PANTONE 314 color.
static (Shared in Visual Basic) | PANTONE3145 | Gets the PANTONE 3145 color.
static (Shared in Visual Basic) | PANTONE315 | Gets the PANTONE 315 color.
static (Shared in Visual Basic) | PANTONE3155 | Gets the PANTONE 3155 color.
static (Shared in Visual Basic) | PANTONE316 | Gets the PANTONE 316 color.
static (Shared in Visual Basic) | PANTONE3165 | Gets the PANTONE 3165 color.
static (Shared in Visual Basic) | PANTONE317 | Gets the PANTONE 317 color.
static (Shared in Visual Basic) | PANTONE318 | Gets the PANTONE 318 color.
static (Shared in Visual Basic) | PANTONE319 | Gets the PANTONE 319 color.
static (Shared in Visual Basic) | PANTONE320 | Gets the PANTONE 320 color.
static (Shared in Visual Basic) | PANTONE321 | Gets the PANTONE 321 color.
static (Shared in Visual Basic) | PANTONE322 | Gets the PANTONE 322 color.
static (Shared in Visual Basic) | PANTONE323 | Gets the PANTONE 323 color.
static (Shared in Visual Basic) | PANTONE324 | Gets the PANTONE 324 color.
static (Shared in Visual Basic) | PANTONE3242 | Gets the PANTONE 3242 color.
static (Shared in Visual Basic) | PANTONE3245 | Gets the PANTONE 3245 color.
static (Shared in Visual Basic) | PANTONE3248 | Gets the PANTONE 3248 color.
static (Shared in Visual Basic) | PANTONE325 | Gets the PANTONE 325 color.
static (Shared in Visual Basic) | PANTONE3252 | Gets the PANTONE 3252 color.
static (Shared in Visual Basic) | PANTONE3255 | Gets the PANTONE 3255 color.
static (Shared in Visual Basic) | PANTONE3258 | Gets the PANTONE 3258 color.
static (Shared in Visual Basic) | PANTONE326 | Gets the PANTONE 326 color.
static (Shared in Visual Basic) | PANTONE3262 | Gets the PANTONE 3262 color.
static (Shared in Visual Basic) | PANTONE3265 | Gets the PANTONE 3265 color.
static (Shared in Visual Basic) | PANTONE3268 | Gets the PANTONE 3268 color.
static (Shared in Visual Basic) | PANTONE327 | Gets the PANTONE 327 color.
static (Shared in Visual Basic) | PANTONE3272 | Gets the PANTONE 3272 color.
static (Shared in Visual Basic) | PANTONE3275 | Gets the PANTONE 3275 color.
static (Shared in Visual Basic) | PANTONE3278 | Gets the PANTONE 3278 color.
static (Shared in Visual Basic) | PANTONE328 | Gets the PANTONE 328 color.
static (Shared in Visual Basic) | PANTONE3282 | Gets the PANTONE 3282 color.
static (Shared in Visual Basic) | PANTONE3285 | Gets the PANTONE 3285 color.
static (Shared in Visual Basic) | PANTONE3288 | Gets the PANTONE 3288 color.
static (Shared in Visual Basic) | PANTONE329 | Gets the PANTONE 329 color.
static (Shared in Visual Basic) | PANTONE3292 | Gets the PANTONE 3292 color.
static (Shared in Visual Basic) | PANTONE3295 | Gets the PANTONE 3295 color.
static (Shared in Visual Basic) | PANTONE3298 | Gets the PANTONE 3298 color.
static (Shared in Visual Basic) | PANTONE330 | Gets the PANTONE 330 color.
static (Shared in Visual Basic) | PANTONE3302 | Gets the PANTONE 3302 color.
static (Shared in Visual Basic) | PANTONE3305 | Gets the PANTONE 3305 color.
static (Shared in Visual Basic) | PANTONE3308 | Gets the PANTONE 3308 color.
static (Shared in Visual Basic) | PANTONE331 | Gets the PANTONE 331 color.
static (Shared in Visual Basic) | PANTONE332 | Gets the PANTONE 332 color.
static (Shared in Visual Basic) | PANTONE333 | Gets the PANTONE 333 color.
static (Shared in Visual Basic) | PANTONE334 | Gets the PANTONE 334 color.
static (Shared in Visual Basic) | PANTONE335 | Gets the PANTONE 335 color.
static (Shared in Visual Basic) | PANTONE336 | Gets the PANTONE 336 color.
static (Shared in Visual Basic) | PANTONE337 | Gets the PANTONE 337 color.
static (Shared in Visual Basic) | PANTONE3375 | Gets the PANTONE 3375 color.
static (Shared in Visual Basic) | PANTONE338 | Gets the PANTONE 338 color.
static (Shared in Visual Basic) | PANTONE3385 | Gets the PANTONE 3385 color.
static (Shared in Visual Basic) | PANTONE339 | Gets the PANTONE 339 color.
static (Shared in Visual Basic) | PANTONE3395 | Gets the PANTONE 3395 color.
static (Shared in Visual Basic) | PANTONE340 | Gets the PANTONE 340 color.
static (Shared in Visual Basic) | PANTONE3405 | Gets the PANTONE 3405 color.
static (Shared in Visual Basic) | PANTONE341 | Gets the PANTONE 341 color.
static (Shared in Visual Basic) | PANTONE3415 | Gets the PANTONE 3415 color.
static (Shared in Visual Basic) | PANTONE342 | Gets the PANTONE 342 color.
static (Shared in Visual Basic) | PANTONE3425 | Gets the PANTONE 3425 color.
static (Shared in Visual Basic) | PANTONE343 | Gets the PANTONE 343 color.
static (Shared in Visual Basic) | PANTONE3435 | Gets the PANTONE 3435 color.
static (Shared in Visual Basic) | PANTONE344 | Gets the PANTONE 344 color.
static (Shared in Visual Basic) | PANTONE345 | Gets the PANTONE 345 color.
static (Shared in Visual Basic) | PANTONE346 | Gets the PANTONE 346 color.
static (Shared in Visual Basic) | PANTONE347 | Gets the PANTONE 347 color.
static (Shared in Visual Basic) | PANTONE348 | Gets the PANTONE 348 color.
static (Shared in Visual Basic) | PANTONE349 | Gets the PANTONE 349 color.
static (Shared in Visual Basic) | PANTONE350 | Gets the PANTONE 350 color.
static (Shared in Visual Basic) | PANTONE351 | Gets the PANTONE 351 color.
static (Shared in Visual Basic) | PANTONE352 | Gets the PANTONE 352 color.
static (Shared in Visual Basic) | PANTONE353 | Gets the PANTONE 353 color.
static (Shared in Visual Basic) | PANTONE354 | Gets the PANTONE 354 color.
static (Shared in Visual Basic) | PANTONE355 | Gets the PANTONE 355 color.
static (Shared in Visual Basic) | PANTONE356 | Gets the PANTONE 356 color.
static (Shared in Visual Basic) | PANTONE357 | Gets the PANTONE 357 color.
static (Shared in Visual Basic) | PANTONE358 | Gets the PANTONE 358 color.
static (Shared in Visual Basic) | PANTONE359 | Gets the PANTONE 359 color.
static (Shared in Visual Basic) | PANTONE360 | Gets the PANTONE 360 color.
static (Shared in Visual Basic) | PANTONE361 | Gets the PANTONE 361 color.
static (Shared in Visual Basic) | PANTONE362 | Gets the PANTONE 362 color.
static (Shared in Visual Basic) | PANTONE363 | Gets the PANTONE 363 color.
static (Shared in Visual Basic) | PANTONE364 | Gets the PANTONE 364 color.
static (Shared in Visual Basic) | PANTONE365 | Gets the PANTONE 365 color.
static (Shared in Visual Basic) | PANTONE366 | Gets the PANTONE 366 color.
static (Shared in Visual Basic) | PANTONE367 | Gets the PANTONE 367 color.
static (Shared in Visual Basic) | PANTONE368 | Gets the PANTONE 368 color.
static (Shared in Visual Basic) | PANTONE369 | Gets the PANTONE 369 color.
static (Shared in Visual Basic) | PANTONE370 | Gets the PANTONE 370 color.
static (Shared in Visual Basic) | PANTONE371 | Gets the PANTONE 371 color.
static (Shared in Visual Basic) | PANTONE372 | Gets the PANTONE 372 color.
static (Shared in Visual Basic) | PANTONE373 | Gets the PANTONE 373 color.
static (Shared in Visual Basic) | PANTONE374 | Gets the PANTONE 374 color.
static (Shared in Visual Basic) | PANTONE375 | Gets the PANTONE 375 color.
static (Shared in Visual Basic) | PANTONE376 | Gets the PANTONE 376 color.
static (Shared in Visual Basic) | PANTONE377 | Gets the PANTONE 377 color.
static (Shared in Visual Basic) | PANTONE378 | Gets the PANTONE 378 color.
static (Shared in Visual Basic) | PANTONE379 | Gets the PANTONE 379 color.
static (Shared in Visual Basic) | PANTONE380 | Gets the PANTONE 380 color.
static (Shared in Visual Basic) | PANTONE381 | Gets the PANTONE 381 color.
static (Shared in Visual Basic) | PANTONE382 | Gets the PANTONE 382 color.
static (Shared in Visual Basic) | PANTONE383 | Gets the PANTONE 383 color.
static (Shared in Visual Basic) | PANTONE384 | Gets the PANTONE 384 color.
static (Shared in Visual Basic) | PANTONE385 | Gets the PANTONE 385 color.
static (Shared in Visual Basic) | PANTONE386 | Gets the PANTONE 386 color.
static (Shared in Visual Basic) | PANTONE387 | Gets the PANTONE 387 color.
static (Shared in Visual Basic) | PANTONE388 | Gets the PANTONE 388 color.
static (Shared in Visual Basic) | PANTONE389 | Gets the PANTONE 389 color.
static (Shared in Visual Basic) | PANTONE390 | Gets the PANTONE 390 color.
static (Shared in Visual Basic) | PANTONE391 | Gets the PANTONE 391 color.
static (Shared in Visual Basic) | PANTONE392 | Gets the PANTONE 392 color.
static (Shared in Visual Basic) | PANTONE393 | Gets the PANTONE 393 color.
static (Shared in Visual Basic) | PANTONE3935 | Gets the PANTONE 3935 color.
static (Shared in Visual Basic) | PANTONE394 | Gets the PANTONE 394 color.
static (Shared in Visual Basic) | PANTONE3945 | Gets the PANTONE 3945 color.
static (Shared in Visual Basic) | PANTONE395 | Gets the PANTONE 395 color.
static (Shared in Visual Basic) | PANTONE3955 | Gets the PANTONE 3955 color.
static (Shared in Visual Basic) | PANTONE396 | Gets the PANTONE 396 color.
static (Shared in Visual Basic) | PANTONE3965 | Gets the PANTONE 3965 color.
static (Shared in Visual Basic) | PANTONE397 | Gets the PANTONE 397 color.
static (Shared in Visual Basic) | PANTONE3975 | Gets the PANTONE 3975 color.
static (Shared in Visual Basic) | PANTONE398 | Gets the PANTONE 398 color.
static (Shared in Visual Basic) | PANTONE3985 | Gets the PANTONE 3985 color.
static (Shared in Visual Basic) | PANTONE399 | Gets the PANTONE 399 color.
static (Shared in Visual Basic) | PANTONE3995 | Gets the PANTONE 3995 color.
static (Shared in Visual Basic) | PANTONE400 | Gets the PANTONE 400 color.
static (Shared in Visual Basic) | PANTONE401 | Gets the PANTONE 401 color.
static (Shared in Visual Basic) | PANTONE402 | Gets the PANTONE 402 color.
static (Shared in Visual Basic) | PANTONE403 | Gets the PANTONE 403 color.
static (Shared in Visual Basic) | PANTONE404 | Gets the PANTONE 404 color.
static (Shared in Visual Basic) | PANTONE405 | Gets the PANTONE 405 color.
static (Shared in Visual Basic) | PANTONE406 | Gets the PANTONE 406 color.
static (Shared in Visual Basic) | PANTONE407 | Gets the PANTONE 407 color.
static (Shared in Visual Basic) | PANTONE408 | Gets the PANTONE 408 color.
static (Shared in Visual Basic) | PANTONE409 | Gets the PANTONE 409 color.
static (Shared in Visual Basic) | PANTONE410 | Gets the PANTONE 410 color.
static (Shared in Visual Basic) | PANTONE411 | Gets the PANTONE 411 color.
static (Shared in Visual Basic) | PANTONE412 | Gets the PANTONE 412 color.
static (Shared in Visual Basic) | PANTONE413 | Gets the PANTONE 413 color.
static (Shared in Visual Basic) | PANTONE414 | Gets the PANTONE 414 color.
static (Shared in Visual Basic) | PANTONE415 | Gets the PANTONE 415 color.
static (Shared in Visual Basic) | PANTONE416 | Gets the PANTONE 416 color.
static (Shared in Visual Basic) | PANTONE417 | Gets the PANTONE 417 color.
static (Shared in Visual Basic) | PANTONE418 | Gets the PANTONE 418 color.
static (Shared in Visual Basic) | PANTONE419 | Gets the PANTONE 419 color.
static (Shared in Visual Basic) | PANTONE420 | Gets the PANTONE 420 color.
static (Shared in Visual Basic) | PANTONE421 | Gets the PANTONE 421 color.
static (Shared in Visual Basic) | PANTONE422 | Gets the PANTONE 422 color.
static (Shared in Visual Basic) | PANTONE423 | Gets the PANTONE 423 color.
static (Shared in Visual Basic) | PANTONE424 | Gets the PANTONE 424 color.
static (Shared in Visual Basic) | PANTONE425 | Gets the PANTONE 425 color.
static (Shared in Visual Basic) | PANTONE426 | Gets the PANTONE 426 color.
static (Shared in Visual Basic) | PANTONE427 | Gets the PANTONE 427 color.
static (Shared in Visual Basic) | PANTONE428 | Gets the PANTONE 428 color.
static (Shared in Visual Basic) | PANTONE429 | Gets the PANTONE 429 color.
static (Shared in Visual Basic) | PANTONE430 | Gets the PANTONE 430 color.
static (Shared in Visual Basic) | PANTONE431 | Gets the PANTONE 431 color.
static (Shared in Visual Basic) | PANTONE432 | Gets the PANTONE 432 color.
static (Shared in Visual Basic) | PANTONE433 | Gets the PANTONE 433 color.
static (Shared in Visual Basic) | PANTONE434 | Gets the PANTONE 434 color.
static (Shared in Visual Basic) | PANTONE435 | Gets the PANTONE 435 color.
static (Shared in Visual Basic) | PANTONE436 | Gets the PANTONE 436 color.
static (Shared in Visual Basic) | PANTONE437 | Gets the PANTONE 437 color.
static (Shared in Visual Basic) | PANTONE438 | Gets the PANTONE 438 color.
static (Shared in Visual Basic) | PANTONE439 | Gets the PANTONE 439 color.
static (Shared in Visual Basic) | PANTONE440 | Gets the PANTONE 440 color.
static (Shared in Visual Basic) | PANTONE441 | Gets the PANTONE 441 color.
static (Shared in Visual Basic) | PANTONE442 | Gets the PANTONE 442 color.
static (Shared in Visual Basic) | PANTONE443 | Gets the PANTONE 443 color.
static (Shared in Visual Basic) | PANTONE444 | Gets the PANTONE 444 color.
static (Shared in Visual Basic) | PANTONE445 | Gets the PANTONE 445 color.
static (Shared in Visual Basic) | PANTONE446 | Gets the PANTONE 446 color.
static (Shared in Visual Basic) | PANTONE447 | Gets the PANTONE 447 color.
static (Shared in Visual Basic) | PANTONE448 | Gets the PANTONE 448 color.
static (Shared in Visual Basic) | PANTONE4485 | Gets the PANTONE 4485 color.
static (Shared in Visual Basic) | PANTONE449 | Gets the PANTONE 449 color.
static (Shared in Visual Basic) | PANTONE4495 | Gets the PANTONE 4495 color.
static (Shared in Visual Basic) | PANTONE450 | Gets the PANTONE 450 color.
static (Shared in Visual Basic) | PANTONE4505 | Gets the PANTONE 4505 color.
static (Shared in Visual Basic) | PANTONE451 | Gets the PANTONE 451 color.
static (Shared in Visual Basic) | PANTONE4515 | Gets the PANTONE 4515 color.
static (Shared in Visual Basic) | PANTONE452 | Gets the PANTONE 452 color.
static (Shared in Visual Basic) | PANTONE4525 | Gets the PANTONE 4525 color.
static (Shared in Visual Basic) | PANTONE453 | Gets the PANTONE 453 color.
static (Shared in Visual Basic) | PANTONE4535 | Gets the PANTONE 4535 color.
static (Shared in Visual Basic) | PANTONE454 | Gets the PANTONE 454 color.
static (Shared in Visual Basic) | PANTONE4545 | Gets the PANTONE 4545 color.
static (Shared in Visual Basic) | PANTONE455 | Gets the PANTONE 455 color.
static (Shared in Visual Basic) | PANTONE456 | Gets the PANTONE 456 color.
static (Shared in Visual Basic) | PANTONE457 | Gets the PANTONE 457 color.
static (Shared in Visual Basic) | PANTONE458 | Gets the PANTONE 458 color.
static (Shared in Visual Basic) | PANTONE459 | Gets the PANTONE 459 color.
static (Shared in Visual Basic) | PANTONE460 | Gets the PANTONE 460 color.
static (Shared in Visual Basic) | PANTONE461 | Gets the PANTONE 461 color.
static (Shared in Visual Basic) | PANTONE462 | Gets the PANTONE 462 color.
static (Shared in Visual Basic) | PANTONE4625 | Gets the PANTONE 4625 color.
static (Shared in Visual Basic) | PANTONE463 | Gets the PANTONE 463 color.
static (Shared in Visual Basic) | PANTONE4635 | Gets the PANTONE 4635 color.
static (Shared in Visual Basic) | PANTONE464 | Gets the PANTONE 464 color.
static (Shared in Visual Basic) | PANTONE4645 | Gets the PANTONE 4645 color.
static (Shared in Visual Basic) | PANTONE465 | Gets the PANTONE 465 color.
static (Shared in Visual Basic) | PANTONE4655 | Gets the PANTONE 4655 color.
static (Shared in Visual Basic) | PANTONE466 | Gets the PANTONE 466 color.
static (Shared in Visual Basic) | PANTONE4665 | Gets the PANTONE 4665 color.
static (Shared in Visual Basic) | PANTONE467 | Gets the PANTONE 467 color.
static (Shared in Visual Basic) | PANTONE4675 | Gets the PANTONE 4675 color.
static (Shared in Visual Basic) | PANTONE468 | Gets the PANTONE 468 color.
static (Shared in Visual Basic) | PANTONE4685 | Gets the PANTONE 4685 color.
static (Shared in Visual Basic) | PANTONE469 | Gets the PANTONE 469 color.
static (Shared in Visual Basic) | PANTONE4695 | Gets the PANTONE 4695 color.
static (Shared in Visual Basic) | PANTONE470 | Gets the PANTONE 470 color.
static (Shared in Visual Basic) | PANTONE4705 | Gets the PANTONE 4705 color.
static (Shared in Visual Basic) | PANTONE471 | Gets the PANTONE 471 color.
static (Shared in Visual Basic) | PANTONE4715 | Gets the PANTONE 4715 color.
static (Shared in Visual Basic) | PANTONE472 | Gets the PANTONE 472 color.
static (Shared in Visual Basic) | PANTONE4725 | Gets the PANTONE 4725 color.
static (Shared in Visual Basic) | PANTONE473 | Gets the PANTONE 473 color.
static (Shared in Visual Basic) | PANTONE4735 | Gets the PANTONE 4735 color.
static (Shared in Visual Basic) | PANTONE474 | Gets the PANTONE 474 color.
static (Shared in Visual Basic) | PANTONE4745 | Gets the PANTONE 4745 color.
static (Shared in Visual Basic) | PANTONE475 | Gets the PANTONE 475 color.
static (Shared in Visual Basic) | PANTONE4755 | Gets the PANTONE 4755 color.
static (Shared in Visual Basic) | PANTONE476 | Gets the PANTONE 476 color.
static (Shared in Visual Basic) | PANTONE477 | Gets the PANTONE 477 color.
static (Shared in Visual Basic) | PANTONE478 | Gets the PANTONE 478 color.
static (Shared in Visual Basic) | PANTONE479 | Gets the PANTONE 479 color.
static (Shared in Visual Basic) | PANTONE480 | Gets the PANTONE 480 color.
static (Shared in Visual Basic) | PANTONE481 | Gets the PANTONE 481 color.
static (Shared in Visual Basic) | PANTONE482 | Gets the PANTONE 482 color.
static (Shared in Visual Basic) | PANTONE483 | Gets the PANTONE 483 color.
static (Shared in Visual Basic) | PANTONE484 | Gets the PANTONE 484 color.
static (Shared in Visual Basic) | PANTONE485 | Gets the PANTONE 485 color.
static (Shared in Visual Basic) | PANTONE486 | Gets the PANTONE 486 color.
static (Shared in Visual Basic) | PANTONE487 | Gets the PANTONE 487 color.
static (Shared in Visual Basic) | PANTONE488 | Gets the PANTONE 488 color.
static (Shared in Visual Basic) | PANTONE489 | Gets the PANTONE 489 color.
static (Shared in Visual Basic) | PANTONE490 | Gets the PANTONE 490 color.
static (Shared in Visual Basic) | PANTONE491 | Gets the PANTONE 491 color.
static (Shared in Visual Basic) | PANTONE492 | Gets the PANTONE 492 color.
static (Shared in Visual Basic) | PANTONE493 | Gets the PANTONE 493 color.
static (Shared in Visual Basic) | PANTONE494 | Gets the PANTONE 494 color.
static (Shared in Visual Basic) | PANTONE495 | Gets the PANTONE 495 color.
static (Shared in Visual Basic) | PANTONE496 | Gets the PANTONE 496 color.
static (Shared in Visual Basic) | PANTONE497 | Gets the PANTONE 497 color.
static (Shared in Visual Basic) | PANTONE4975 | Gets the PANTONE 4975 color.
static (Shared in Visual Basic) | PANTONE498 | Gets the PANTONE 498 color.
static (Shared in Visual Basic) | PANTONE4985 | Gets the PANTONE 4985 color.
static (Shared in Visual Basic) | PANTONE499 | Gets the PANTONE 499 color.
static (Shared in Visual Basic) | PANTONE4995 | Gets the PANTONE 4995 color.
static (Shared in Visual Basic) | PANTONE500 | Gets the PANTONE 500 color.
static (Shared in Visual Basic) | PANTONE5005 | Gets the PANTONE 5005 color.
static (Shared in Visual Basic) | PANTONE501 | Gets the PANTONE 501 color.
static (Shared in Visual Basic) | PANTONE5015 | Gets the PANTONE 5015 color.
static (Shared in Visual Basic) | PANTONE502 | Gets the PANTONE 502 color.
static (Shared in Visual Basic) | PANTONE5025 | Gets the PANTONE 5025 color.
static (Shared in Visual Basic) | PANTONE503 | Gets the PANTONE 503 color.
static (Shared in Visual Basic) | PANTONE5035 | Gets the PANTONE 5035 color.
static (Shared in Visual Basic) | PANTONE504 | Gets the PANTONE 504 color.
static (Shared in Visual Basic) | PANTONE505 | Gets the PANTONE 505 color.
static (Shared in Visual Basic) | PANTONE506 | Gets the PANTONE 506 color.
static (Shared in Visual Basic) | PANTONE507 | Gets the PANTONE 507 color.
static (Shared in Visual Basic) | PANTONE508 | Gets the PANTONE 508 color.
static (Shared in Visual Basic) | PANTONE509 | Gets the PANTONE 509 color.
static (Shared in Visual Basic) | PANTONE510 | Gets the PANTONE 510 color.
static (Shared in Visual Basic) | PANTONE511 | Gets the PANTONE 511 color.
static (Shared in Visual Basic) | PANTONE5115 | Gets the PANTONE 5115 color.
static (Shared in Visual Basic) | PANTONE512 | Gets the PANTONE 512 color.
static (Shared in Visual Basic) | PANTONE5125 | Gets the PANTONE 5125 color.
static (Shared in Visual Basic) | PANTONE513 | Gets the PANTONE 513 color.
static (Shared in Visual Basic) | PANTONE5135 | Gets the PANTONE 5135 color.
static (Shared in Visual Basic) | PANTONE514 | Gets the PANTONE 514 color.
static (Shared in Visual Basic) | PANTONE5145 | Gets the PANTONE 5145 color.
static (Shared in Visual Basic) | PANTONE515 | Gets the PANTONE 515 color.
static (Shared in Visual Basic) | PANTONE5155 | Gets the PANTONE 5155 color.
static (Shared in Visual Basic) | PANTONE516 | Gets the PANTONE 516 color.
static (Shared in Visual Basic) | PANTONE5165 | Gets the PANTONE 5165 color.
static (Shared in Visual Basic) | PANTONE517 | Gets the PANTONE 517 color.
static (Shared in Visual Basic) | PANTONE5175 | Gets the PANTONE 5175 color.
static (Shared in Visual Basic) | PANTONE518 | Gets the PANTONE 518 color.
static (Shared in Visual Basic) | PANTONE5185 | Gets the PANTONE 5185 color.
static (Shared in Visual Basic) | PANTONE519 | Gets the PANTONE 519 color.
static (Shared in Visual Basic) | PANTONE5195 | Gets the PANTONE 5195 color.
static (Shared in Visual Basic) | PANTONE520 | Gets the PANTONE 520 color.
static (Shared in Visual Basic) | PANTONE5205 | Gets the PANTONE 5205 color.
static (Shared in Visual Basic) | PANTONE521 | Gets the PANTONE 521 color.
static (Shared in Visual Basic) | PANTONE5215 | Gets the PANTONE 5215 color.
static (Shared in Visual Basic) | PANTONE522 | Gets the PANTONE 522 color.
static (Shared in Visual Basic) | PANTONE5225 | Gets the PANTONE 5225 color.
static (Shared in Visual Basic) | PANTONE523 | Gets the PANTONE 523 color.
static (Shared in Visual Basic) | PANTONE5235 | Gets the PANTONE 5235 color.
static (Shared in Visual Basic) | PANTONE524 | Gets the PANTONE 524 color.
static (Shared in Visual Basic) | PANTONE5245 | Gets the PANTONE 5245 color.
static (Shared in Visual Basic) | PANTONE525 | Gets the PANTONE 525 color.
static (Shared in Visual Basic) | PANTONE5255 | Gets the PANTONE 5255 color.
static (Shared in Visual Basic) | PANTONE526 | Gets the PANTONE 526 color.
static (Shared in Visual Basic) | PANTONE5265 | Gets the PANTONE 5265 color.
static (Shared in Visual Basic) | PANTONE527 | Gets the PANTONE 527 color.
static (Shared in Visual Basic) | PANTONE5275 | Gets the PANTONE 5275 color.
static (Shared in Visual Basic) | PANTONE528 | Gets the PANTONE 528 color.
static (Shared in Visual Basic) | PANTONE5285 | Gets the PANTONE 5285 color.
static (Shared in Visual Basic) | PANTONE529 | Gets the PANTONE 529 color.
static (Shared in Visual Basic) | PANTONE5295 | Gets the PANTONE 5295 color.
static (Shared in Visual Basic) | PANTONE530 | Gets the PANTONE 530 color.
static (Shared in Visual Basic) | PANTONE5305 | Gets the PANTONE 5305 color.
static (Shared in Visual Basic) | PANTONE531 | Gets the PANTONE 531 color.
static (Shared in Visual Basic) | PANTONE5315 | Gets the PANTONE 5315 color.
static (Shared in Visual Basic) | PANTONE532 | Gets the PANTONE 532 color.
static (Shared in Visual Basic) | PANTONE533 | Gets the PANTONE 533 color.
static (Shared in Visual Basic) | PANTONE534 | Gets the PANTONE 534 color.
static (Shared in Visual Basic) | PANTONE535 | Gets the PANTONE 535 color.
static (Shared in Visual Basic) | PANTONE536 | Gets the PANTONE 536 color.
static (Shared in Visual Basic) | PANTONE537 | Gets the PANTONE 537 color.
static (Shared in Visual Basic) | PANTONE538 | Gets the PANTONE 538 color.
static (Shared in Visual Basic) | PANTONE539 | Gets the PANTONE 539 color.
static (Shared in Visual Basic) | PANTONE5395 | Gets the PANTONE 5395 color.
static (Shared in Visual Basic) | PANTONE540 | Gets the PANTONE 540 color.
static (Shared in Visual Basic) | PANTONE5405 | Gets the PANTONE 5405 color.
static (Shared in Visual Basic) | PANTONE541 | Gets the PANTONE 541 color.
static (Shared in Visual Basic) | PANTONE5415 | Gets the PANTONE 5415 color.
static (Shared in Visual Basic) | PANTONE542 | Gets the PANTONE 542 color.
static (Shared in Visual Basic) | PANTONE5425 | Gets the PANTONE 5425 color.
static (Shared in Visual Basic) | PANTONE543 | Gets the PANTONE 543 color.
static (Shared in Visual Basic) | PANTONE5435 | Gets the PANTONE 5435 color.
static (Shared in Visual Basic) | PANTONE544 | Gets the PANTONE 544 color.
static (Shared in Visual Basic) | PANTONE5445 | Gets the PANTONE 5445 color.
static (Shared in Visual Basic) | PANTONE545 | Gets the PANTONE 545 color.
static (Shared in Visual Basic) | PANTONE5455 | Gets the PANTONE 5455 color.
static (Shared in Visual Basic) | PANTONE546 | Gets the PANTONE 546 color.
static (Shared in Visual Basic) | PANTONE5463 | Gets the PANTONE 5463 color.
static (Shared in Visual Basic) | PANTONE5467 | Gets the PANTONE 5467 color.
static (Shared in Visual Basic) | PANTONE547 | Gets the PANTONE 547 color.
static (Shared in Visual Basic) | PANTONE5473 | Gets the PANTONE 5473 color.
static (Shared in Visual Basic) | PANTONE5477 | Gets the PANTONE 5477 color.
static (Shared in Visual Basic) | PANTONE548 | Gets the PANTONE 548 color.
static (Shared in Visual Basic) | PANTONE5483 | Gets the PANTONE 5483 color.
static (Shared in Visual Basic) | PANTONE5487 | Gets the PANTONE 5487 color.
static (Shared in Visual Basic) | PANTONE549 | Gets the PANTONE 549 color.
static (Shared in Visual Basic) | PANTONE5493 | Gets the PANTONE 5493 color.
static (Shared in Visual Basic) | PANTONE5497 | Gets the PANTONE 5497 color.
static (Shared in Visual Basic) | PANTONE550 | Gets the PANTONE 550 color.
static (Shared in Visual Basic) | PANTONE5503 | Gets the PANTONE 5503 color.
static (Shared in Visual Basic) | PANTONE5507 | Gets the PANTONE 5507 color.
static (Shared in Visual Basic) | PANTONE551 | Gets the PANTONE 551 color.
static (Shared in Visual Basic) | PANTONE5513 | Gets the PANTONE 5513 color.
static (Shared in Visual Basic) | PANTONE5517 | Gets the PANTONE 5517 color.
static (Shared in Visual Basic) | PANTONE552 | Gets the PANTONE 552 color.
static (Shared in Visual Basic) | PANTONE5523 | Gets the PANTONE 5523 color.
static (Shared in Visual Basic) | PANTONE5527 | Gets the PANTONE 5527 color.
static (Shared in Visual Basic) | PANTONE553 | Gets the PANTONE 553 color.
static (Shared in Visual Basic) | PANTONE5535 | Gets the PANTONE 5535 color.
static (Shared in Visual Basic) | PANTONE554 | Gets the PANTONE 554 color.
static (Shared in Visual Basic) | PANTONE5545 | Gets the PANTONE 5545 color.
static (Shared in Visual Basic) | PANTONE555 | Gets the PANTONE 555 color.
static (Shared in Visual Basic) | PANTONE5555 | Gets the PANTONE 5555 color.
static (Shared in Visual Basic) | PANTONE556 | Gets the PANTONE 556 color.
static (Shared in Visual Basic) | PANTONE5565 | Gets the PANTONE 5565 color.
static (Shared in Visual Basic) | PANTONE557 | Gets the PANTONE 557 color.
static (Shared in Visual Basic) | PANTONE5575 | Gets the PANTONE 5575 color.
static (Shared in Visual Basic) | PANTONE558 | Gets the PANTONE 558 color.
static (Shared in Visual Basic) | PANTONE5585 | Gets the PANTONE 5585 color.
static (Shared in Visual Basic) | PANTONE559 | Gets the PANTONE 559 color.
static (Shared in Visual Basic) | PANTONE5595 | Gets the PANTONE 5595 color.
static (Shared in Visual Basic) | PANTONE560 | Gets the PANTONE 560 color.
static (Shared in Visual Basic) | PANTONE5605 | Gets the PANTONE 5605 color.
static (Shared in Visual Basic) | PANTONE561 | Gets the PANTONE 561 color.
static (Shared in Visual Basic) | PANTONE5615 | Gets the PANTONE 5615 color.
static (Shared in Visual Basic) | PANTONE562 | Gets the PANTONE 562 color.
static (Shared in Visual Basic) | PANTONE5625 | Gets the PANTONE 5625 color.
static (Shared in Visual Basic) | PANTONE563 | Gets the PANTONE 563 color.
static (Shared in Visual Basic) | PANTONE5635 | Gets the PANTONE 5635 color.
static (Shared in Visual Basic) | PANTONE564 | Gets the PANTONE 564 color.
static (Shared in Visual Basic) | PANTONE5645 | Gets the PANTONE 5645 color.
static (Shared in Visual Basic) | PANTONE565 | Gets the PANTONE 565 color.
static (Shared in Visual Basic) | PANTONE5655 | Gets the PANTONE 5655 color.
static (Shared in Visual Basic) | PANTONE566 | Gets the PANTONE 566 color.
static (Shared in Visual Basic) | PANTONE5665 | Gets the PANTONE 5665 color.
static (Shared in Visual Basic) | PANTONE567 | Gets the PANTONE 567 color.
static (Shared in Visual Basic) | PANTONE568 | Gets the PANTONE 568 color.
static (Shared in Visual Basic) | PANTONE569 | Gets the PANTONE 569 color.
static (Shared in Visual Basic) | PANTONE570 | Gets the PANTONE 570 color.
static (Shared in Visual Basic) | PANTONE571 | Gets the PANTONE 571 color.
static (Shared in Visual Basic) | PANTONE572 | Gets the PANTONE 572 color.
static (Shared in Visual Basic) | PANTONE573 | Gets the PANTONE 573 color.
static (Shared in Visual Basic) | PANTONE574 | Gets the PANTONE 574 color.
static (Shared in Visual Basic) | PANTONE5743 | Gets the PANTONE 5743 color.
static (Shared in Visual Basic) | PANTONE5747 | Gets the PANTONE 5747 color.
static (Shared in Visual Basic) | PANTONE575 | Gets the PANTONE 575 color.
static (Shared in Visual Basic) | PANTONE5753 | Gets the PANTONE 5753 color.
static (Shared in Visual Basic) | PANTONE5757 | Gets the PANTONE 5757 color.
static (Shared in Visual Basic) | PANTONE576 | Gets the PANTONE 576 color.
static (Shared in Visual Basic) | PANTONE5763 | Gets the PANTONE 5763 color.
static (Shared in Visual Basic) | PANTONE5767 | Gets the PANTONE 5767 color.
static (Shared in Visual Basic) | PANTONE577 | Gets the PANTONE 577 color.
static (Shared in Visual Basic) | PANTONE5773 | Gets the PANTONE 5773 color.
static (Shared in Visual Basic) | PANTONE5777 | Gets the PANTONE 5777 color.
static (Shared in Visual Basic) | PANTONE578 | Gets the PANTONE 578 color.
static (Shared in Visual Basic) | PANTONE5783 | Gets the PANTONE 5783 color.
static (Shared in Visual Basic) | PANTONE5787 | Gets the PANTONE 5787 color.
static (Shared in Visual Basic) | PANTONE579 | Gets the PANTONE 579 color.
static (Shared in Visual Basic) | PANTONE5793 | Gets the PANTONE 5793 color.
static (Shared in Visual Basic) | PANTONE5797 | Gets the PANTONE 5797 color.
static (Shared in Visual Basic) | PANTONE580 | Gets the PANTONE 580 color.
static (Shared in Visual Basic) | PANTONE5803 | Gets the PANTONE 5803 color.
static (Shared in Visual Basic) | PANTONE5807 | Gets the PANTONE 5807 color.
static (Shared in Visual Basic) | PANTONE581 | Gets the PANTONE 581 color.
static (Shared in Visual Basic) | PANTONE5815 | Gets the PANTONE 5815 color.
static (Shared in Visual Basic) | PANTONE582 | Gets the PANTONE 582 color.
static (Shared in Visual Basic) | PANTONE5825 | Gets the PANTONE 5825 color.
static (Shared in Visual Basic) | PANTONE583 | Gets the PANTONE 583 color.
static (Shared in Visual Basic) | PANTONE5835 | Gets the PANTONE 5835 color.
static (Shared in Visual Basic) | PANTONE584 | Gets the PANTONE 584 color.
static (Shared in Visual Basic) | PANTONE5845 | Gets the PANTONE 5845 color.
static (Shared in Visual Basic) | PANTONE585 | Gets the PANTONE 585 color.
static (Shared in Visual Basic) | PANTONE5855 | Gets the PANTONE 5855 color.
static (Shared in Visual Basic) | PANTONE586 | Gets the PANTONE 586 color.
static (Shared in Visual Basic) | PANTONE5865 | Gets the PANTONE 5865 color.
static (Shared in Visual Basic) | PANTONE587 | Gets the PANTONE 587 color.
static (Shared in Visual Basic) | PANTONE5875 | Gets the PANTONE 5875 color.
static (Shared in Visual Basic) | PANTONE600 | Gets the PANTONE 600 color.
static (Shared in Visual Basic) | PANTONE601 | Gets the PANTONE 601 color.
static (Shared in Visual Basic) | PANTONE602 | Gets the PANTONE 602 color.
static (Shared in Visual Basic) | PANTONE603 | Gets the PANTONE 603 color.
static (Shared in Visual Basic) | PANTONE604 | Gets the PANTONE 604 color.
static (Shared in Visual Basic) | PANTONE605 | Gets the PANTONE 605 color.
static (Shared in Visual Basic) | PANTONE606 | Gets the PANTONE 606 color.
static (Shared in Visual Basic) | PANTONE607 | Gets the PANTONE 607 color.
static (Shared in Visual Basic) | PANTONE608 | Gets the PANTONE 608 color.
static (Shared in Visual Basic) | PANTONE609 | Gets the PANTONE 609 color.
static (Shared in Visual Basic) | PANTONE610 | Gets the PANTONE 610 color.
static (Shared in Visual Basic) | PANTONE611 | Gets the PANTONE 611 color.
static (Shared in Visual Basic) | PANTONE612 | Gets the PANTONE 612 color.
static (Shared in Visual Basic) | PANTONE613 | Gets the PANTONE 613 color.
static (Shared in Visual Basic) | PANTONE614 | Gets the PANTONE 614 color.
static (Shared in Visual Basic) | PANTONE615 | Gets the PANTONE 615 color.
static (Shared in Visual Basic) | PANTONE616 | Gets the PANTONE 616 color.
static (Shared in Visual Basic) | PANTONE617 | Gets the PANTONE 617 color.
static (Shared in Visual Basic) | PANTONE618 | Gets the PANTONE 618 color.
static (Shared in Visual Basic) | PANTONE619 | Gets the PANTONE 619 color.
static (Shared in Visual Basic) | PANTONE620 | Gets the PANTONE 620 color.
static (Shared in Visual Basic) | PANTONE621 | Gets the PANTONE 621 color.
static (Shared in Visual Basic) | PANTONE622 | Gets the PANTONE 622 color.
static (Shared in Visual Basic) | PANTONE623 | Gets the PANTONE 623 color.
static (Shared in Visual Basic) | PANTONE624 | Gets the PANTONE 624 color.
static (Shared in Visual Basic) | PANTONE625 | Gets the PANTONE 625 color.
static (Shared in Visual Basic) | PANTONE626 | Gets the PANTONE 626 color.
static (Shared in Visual Basic) | PANTONE627 | Gets the PANTONE 627 color.
static (Shared in Visual Basic) | PANTONE628 | Gets the PANTONE 628 color.
static (Shared in Visual Basic) | PANTONE629 | Gets the PANTONE 629 color.
static (Shared in Visual Basic) | PANTONE630 | Gets the PANTONE 630 color.
static (Shared in Visual Basic) | PANTONE631 | Gets the PANTONE 631 color.
static (Shared in Visual Basic) | PANTONE632 | Gets the PANTONE 632 color.
static (Shared in Visual Basic) | PANTONE633 | Gets the PANTONE 633 color.
static (Shared in Visual Basic) | PANTONE634 | Gets the PANTONE 634 color.
static (Shared in Visual Basic) | PANTONE635 | Gets the PANTONE 635 color.
static (Shared in Visual Basic) | PANTONE636 | Gets the PANTONE 636 color.
static (Shared in Visual Basic) | PANTONE637 | Gets the PANTONE 637 color.
static (Shared in Visual Basic) | PANTONE638 | Gets the PANTONE 638 color.
static (Shared in Visual Basic) | PANTONE639 | Gets the PANTONE 639 color.
static (Shared in Visual Basic) | PANTONE640 | Gets the PANTONE 640 color.
static (Shared in Visual Basic) | PANTONE641 | Gets the PANTONE 641 color.
static (Shared in Visual Basic) | PANTONE642 | Gets the PANTONE 642 color.
static (Shared in Visual Basic) | PANTONE643 | Gets the PANTONE 643 color.
static (Shared in Visual Basic) | PANTONE644 | Gets the PANTONE 644 color.
static (Shared in Visual Basic) | PANTONE645 | Gets the PANTONE 645 color.
static (Shared in Visual Basic) | PANTONE646 | Gets the PANTONE 646 color.
static (Shared in Visual Basic) | PANTONE647 | Gets the PANTONE 647 color.
static (Shared in Visual Basic) | PANTONE648 | Gets the PANTONE 648 color.
static (Shared in Visual Basic) | PANTONE649 | Gets the PANTONE 649 color.
static (Shared in Visual Basic) | PANTONE650 | Gets the PANTONE 650 color.
static (Shared in Visual Basic) | PANTONE651 | Gets the PANTONE 651 color.
static (Shared in Visual Basic) | PANTONE652 | Gets the PANTONE 652 color.
static (Shared in Visual Basic) | PANTONE653 | Gets the PANTONE 653 color.
static (Shared in Visual Basic) | PANTONE654 | Gets the PANTONE 654 color.
static (Shared in Visual Basic) | PANTONE655 | Gets the PANTONE 655 color.
static (Shared in Visual Basic) | PANTONE656 | Gets the PANTONE 656 color.
static (Shared in Visual Basic) | PANTONE657 | Gets the PANTONE 657 color.
static (Shared in Visual Basic) | PANTONE658 | Gets the PANTONE 658 color.
static (Shared in Visual Basic) | PANTONE659 | Gets the PANTONE 659 color.
static (Shared in Visual Basic) | PANTONE660 | Gets the PANTONE 660 color.
static (Shared in Visual Basic) | PANTONE661 | Gets the PANTONE 661 color.
static (Shared in Visual Basic) | PANTONE662 | Gets the PANTONE 662 color.
static (Shared in Visual Basic) | PANTONE663 | Gets the PANTONE 663 color.
static (Shared in Visual Basic) | PANTONE664 | Gets the PANTONE 664 color.
static (Shared in Visual Basic) | PANTONE665 | Gets the PANTONE 665 color.
static (Shared in Visual Basic) | PANTONE666 | Gets the PANTONE 666 color.
static (Shared in Visual Basic) | PANTONE667 | Gets the PANTONE 667 color.
static (Shared in Visual Basic) | PANTONE668 | Gets the PANTONE 668 color.
static (Shared in Visual Basic) | PANTONE669 | Gets the PANTONE 669 color.
static (Shared in Visual Basic) | PANTONE670 | Gets the PANTONE 670 color.
static (Shared in Visual Basic) | PANTONE671 | Gets the PANTONE 671 color.
static (Shared in Visual Basic) | PANTONE672 | Gets the PANTONE 672 color.
static (Shared in Visual Basic) | PANTONE673 | Gets the PANTONE 673 color.
static (Shared in Visual Basic) | PANTONE674 | Gets the PANTONE 674 color.
static (Shared in Visual Basic) | PANTONE675 | Gets the PANTONE 675 color.
static (Shared in Visual Basic) | PANTONE676 | Gets the PANTONE 676 color.
static (Shared in Visual Basic) | PANTONE677 | Gets the PANTONE 677 color.
static (Shared in Visual Basic) | PANTONE678 | Gets the PANTONE 678 color.
static (Shared in Visual Basic) | PANTONE679 | Gets the PANTONE 679 color.
static (Shared in Visual Basic) | PANTONE680 | Gets the PANTONE 680 color.
static (Shared in Visual Basic) | PANTONE681 | Gets the PANTONE 681 color.
static (Shared in Visual Basic) | PANTONE682 | Gets the PANTONE 682 color.
static (Shared in Visual Basic) | PANTONE683 | Gets the PANTONE 683 color.
static (Shared in Visual Basic) | PANTONE684 | Gets the PANTONE 684 color.
static (Shared in Visual Basic) | PANTONE685 | Gets the PANTONE 685 color.
static (Shared in Visual Basic) | PANTONE686 | Gets the PANTONE 686 color.
static (Shared in Visual Basic) | PANTONE687 | Gets the PANTONE 687 color.
static (Shared in Visual Basic) | PANTONE688 | Gets the PANTONE 688 color.
static (Shared in Visual Basic) | PANTONE689 | Gets the PANTONE 689 color.
static (Shared in Visual Basic) | PANTONE690 | Gets the PANTONE 690 color.
static (Shared in Visual Basic) | PANTONE691 | Gets the PANTONE 691 color.
static (Shared in Visual Basic) | PANTONE692 | Gets the PANTONE 692 color.
static (Shared in Visual Basic) | PANTONE693 | Gets the PANTONE 693 color.
static (Shared in Visual Basic) | PANTONE694 | Gets the PANTONE 694 color.
static (Shared in Visual Basic) | PANTONE695 | Gets the PANTONE 695 color.
static (Shared in Visual Basic) | PANTONE696 | Gets the PANTONE 696 color.
static (Shared in Visual Basic) | PANTONE697 | Gets the PANTONE 697 color.
static (Shared in Visual Basic) | PANTONE698 | Gets the PANTONE 698 color.
static (Shared in Visual Basic) | PANTONE699 | Gets the PANTONE 699 color.
static (Shared in Visual Basic) | PANTONE700 | Gets the PANTONE 700 color.
static (Shared in Visual Basic) | PANTONE701 | Gets the PANTONE 701 color.
static (Shared in Visual Basic) | PANTONE702 | Gets the PANTONE 702 color.
static (Shared in Visual Basic) | PANTONE703 | Gets the PANTONE 703 color.
static (Shared in Visual Basic) | PANTONE704 | Gets the PANTONE 704 color.
static (Shared in Visual Basic) | PANTONE705 | Gets the PANTONE 705 color.
static (Shared in Visual Basic) | PANTONE706 | Gets the PANTONE 706 color.
static (Shared in Visual Basic) | PANTONE707 | Gets the PANTONE 707 color.
static (Shared in Visual Basic) | PANTONE708 | Gets the PANTONE 708 color.
static (Shared in Visual Basic) | PANTONE709 | Gets the PANTONE 709 color.
static (Shared in Visual Basic) | PANTONE710 | Gets the PANTONE 710 color.
static (Shared in Visual Basic) | PANTONE711 | Gets the PANTONE 711 color.
static (Shared in Visual Basic) | PANTONE712 | Gets the PANTONE 712 color.
static (Shared in Visual Basic) | PANTONE713 | Gets the PANTONE 713 color.
static (Shared in Visual Basic) | PANTONE714 | Gets the PANTONE 714 color.
static (Shared in Visual Basic) | PANTONE715 | Gets the PANTONE 715 color.
static (Shared in Visual Basic) | PANTONE716 | Gets the PANTONE 716 color.
static (Shared in Visual Basic) | PANTONE717 | Gets the PANTONE 717 color.
static (Shared in Visual Basic) | PANTONE718 | Gets the PANTONE 718 color.
static (Shared in Visual Basic) | PANTONE719 | Gets the PANTONE 719 color.
static (Shared in Visual Basic) | PANTONE720 | Gets the PANTONE 720 color.
static (Shared in Visual Basic) | PANTONE721 | Gets the PANTONE 721 color.
static (Shared in Visual Basic) | PANTONE722 | Gets the PANTONE 722 color.
static (Shared in Visual Basic) | PANTONE723 | Gets the PANTONE 723 color.
static (Shared in Visual Basic) | PANTONE724 | Gets the PANTONE 724 color.
static (Shared in Visual Basic) | PANTONE725 | Gets the PANTONE 725 color.
static (Shared in Visual Basic) | PANTONE726 | Gets the PANTONE 726 color.
static (Shared in Visual Basic) | PANTONE727 | Gets the PANTONE 727 color.
static (Shared in Visual Basic) | PANTONE728 | Gets the PANTONE 728 color.
static (Shared in Visual Basic) | PANTONE729 | Gets the PANTONE 729 color.
static (Shared in Visual Basic) | PANTONE730 | Gets the PANTONE 730 color.
static (Shared in Visual Basic) | PANTONE731 | Gets the PANTONE 731 color.
static (Shared in Visual Basic) | PANTONE732 | Gets the PANTONE 732 color.
static (Shared in Visual Basic) | PANTONE7401 | Gets the PANTONE 7401 color.
static (Shared in Visual Basic) | PANTONE7402 | Gets the PANTONE 7402 color.
static (Shared in Visual Basic) | PANTONE7403 | Gets the PANTONE 7403 color.
static (Shared in Visual Basic) | PANTONE7404 | Gets the PANTONE 7404 color.
static (Shared in Visual Basic) | PANTONE7405 | Gets the PANTONE 7405 color.
static (Shared in Visual Basic) | PANTONE7406 | Gets the PANTONE 7406 color.
static (Shared in Visual Basic) | PANTONE7407 | Gets the PANTONE 7407 color.
static (Shared in Visual Basic) | PANTONE7408 | Gets the PANTONE 7408 color.
static (Shared in Visual Basic) | PANTONE7409 | Gets the PANTONE 7409 color.
static (Shared in Visual Basic) | PANTONE7410 | Gets the PANTONE 7410 color.
static (Shared in Visual Basic) | PANTONE7411 | Gets the PANTONE 7411 color.
static (Shared in Visual Basic) | PANTONE7412 | Gets the PANTONE 7412 color.
static (Shared in Visual Basic) | PANTONE7413 | Gets the PANTONE 7413 color.
static (Shared in Visual Basic) | PANTONE7414 | Gets the PANTONE 7414 color.
static (Shared in Visual Basic) | PANTONE7415 | Gets the PANTONE 7415 color.
static (Shared in Visual Basic) | PANTONE7416 | Gets the PANTONE 7416 color.
static (Shared in Visual Basic) | PANTONE7417 | Gets the PANTONE 7417 color.
static (Shared in Visual Basic) | PANTONE7418 | Gets the PANTONE 7418 color.
static (Shared in Visual Basic) | PANTONE7419 | Gets the PANTONE 7419 color.
static (Shared in Visual Basic) | PANTONE7420 | Gets the PANTONE 7420 color.
static (Shared in Visual Basic) | PANTONE7421 | Gets the PANTONE 7421 color.
static (Shared in Visual Basic) | PANTONE7422 | Gets the PANTONE 7422 color.
static (Shared in Visual Basic) | PANTONE7423 | Gets the PANTONE 7423 color.
static (Shared in Visual Basic) | PANTONE7424 | Gets the PANTONE 7424 color.
static (Shared in Visual Basic) | PANTONE7425 | Gets the PANTONE 7425 color.
static (Shared in Visual Basic) | PANTONE7426 | Gets the PANTONE 7426 color.
static (Shared in Visual Basic) | PANTONE7427 | Gets the PANTONE 7427 color.
static (Shared in Visual Basic) | PANTONE7428 | Gets the PANTONE 7428 color.
static (Shared in Visual Basic) | PANTONE7429 | Gets the PANTONE 7429 color.
static (Shared in Visual Basic) | PANTONE7430 | Gets the PANTONE 7430 color.
static (Shared in Visual Basic) | PANTONE7431 | Gets the PANTONE 7431 color.
static (Shared in Visual Basic) | PANTONE7432 | Gets the PANTONE 7432 color.
static (Shared in Visual Basic) | PANTONE7433 | Gets the PANTONE 7433 color.
static (Shared in Visual Basic) | PANTONE7434 | Gets the PANTONE 7434 color.
static (Shared in Visual Basic) | PANTONE7435 | Gets the PANTONE 7435 color.
static (Shared in Visual Basic) | PANTONE7436 | Gets the PANTONE 7436 color.
static (Shared in Visual Basic) | PANTONE7437 | Gets the PANTONE 7437 color.
static (Shared in Visual Basic) | PANTONE7438 | Gets the PANTONE 7438 color.
static (Shared in Visual Basic) | PANTONE7439 | Gets the PANTONE 7439 color.
static (Shared in Visual Basic) | PANTONE7440 | Gets the PANTONE 7440 color.
static (Shared in Visual Basic) | PANTONE7441 | Gets the PANTONE 7441 color.
static (Shared in Visual Basic) | PANTONE7442 | Gets the PANTONE 7442 color.
static (Shared in Visual Basic) | PANTONE7443 | Gets the PANTONE 7443 color.
static (Shared in Visual Basic) | PANTONE7444 | Gets the PANTONE 7444 color.
static (Shared in Visual Basic) | PANTONE7445 | Gets the PANTONE 7445 color.
static (Shared in Visual Basic) | PANTONE7446 | Gets the PANTONE 7446 color.
static (Shared in Visual Basic) | PANTONE7447 | Gets the PANTONE 7447 color.
static (Shared in Visual Basic) | PANTONE7448 | Gets the PANTONE 7448 color.
static (Shared in Visual Basic) | PANTONE7449 | Gets the PANTONE 7449 color.
static (Shared in Visual Basic) | PANTONE7450 | Gets the PANTONE 7450 color.
static (Shared in Visual Basic) | PANTONE7451 | Gets the PANTONE 7451 color.
static (Shared in Visual Basic) | PANTONE7452 | Gets the PANTONE 7452 color.
static (Shared in Visual Basic) | PANTONE7453 | Gets the PANTONE 7453 color.
static (Shared in Visual Basic) | PANTONE7454 | Gets the PANTONE 7454 color.
static (Shared in Visual Basic) | PANTONE7455 | Gets the PANTONE 7455 color.
static (Shared in Visual Basic) | PANTONE7456 | Gets the PANTONE 7456 color.
static (Shared in Visual Basic) | PANTONE7457 | Gets the PANTONE 7457 color.
static (Shared in Visual Basic) | PANTONE7458 | Gets the PANTONE 7458 color.
static (Shared in Visual Basic) | PANTONE7459 | Gets the PANTONE 7459 color.
static (Shared in Visual Basic) | PANTONE7460 | Gets the PANTONE 7460 color.
static (Shared in Visual Basic) | PANTONE7461 | Gets the PANTONE 7461 color.
static (Shared in Visual Basic) | PANTONE7462 | Gets the PANTONE 7462 color.
static (Shared in Visual Basic) | PANTONE7463 | Gets the PANTONE 7463 color.
static (Shared in Visual Basic) | PANTONE7464 | Gets the PANTONE 7464 color.
static (Shared in Visual Basic) | PANTONE7465 | Gets the PANTONE 7465 color.
static (Shared in Visual Basic) | PANTONE7466 | Gets the PANTONE 7466 color.
static (Shared in Visual Basic) | PANTONE7467 | Gets the PANTONE 7467 color.
static (Shared in Visual Basic) | PANTONE7468 | Gets the PANTONE 7468 color.
static (Shared in Visual Basic) | PANTONE7469 | Gets the PANTONE 7469 color.
static (Shared in Visual Basic) | PANTONE7470 | Gets the PANTONE 7470 color.
static (Shared in Visual Basic) | PANTONE7471 | Gets the PANTONE 7471 color.
static (Shared in Visual Basic) | PANTONE7472 | Gets the PANTONE 7472 color.
static (Shared in Visual Basic) | PANTONE7473 | Gets the PANTONE 7473 color.
static (Shared in Visual Basic) | PANTONE7474 | Gets the PANTONE 7474 color.
static (Shared in Visual Basic) | PANTONE7475 | Gets the PANTONE 7475 color.
static (Shared in Visual Basic) | PANTONE7476 | Gets the PANTONE 7476 color.
static (Shared in Visual Basic) | PANTONE7477 | Gets the PANTONE 7477 color.
static (Shared in Visual Basic) | PANTONE7478 | Gets the PANTONE 7478 color.
static (Shared in Visual Basic) | PANTONE7479 | Gets the PANTONE 7479 color.
static (Shared in Visual Basic) | PANTONE7480 | Gets the PANTONE 7480 color.
static (Shared in Visual Basic) | PANTONE7481 | Gets the PANTONE 7481 color.
static (Shared in Visual Basic) | PANTONE7482 | Gets the PANTONE 7482 color.
static (Shared in Visual Basic) | PANTONE7483 | Gets the PANTONE 7483 color.
static (Shared in Visual Basic) | PANTONE7484 | Gets the PANTONE 7484 color.
static (Shared in Visual Basic) | PANTONE7485 | Gets the PANTONE 7485 color.
static (Shared in Visual Basic) | PANTONE7486 | Gets the PANTONE 7486 color.
static (Shared in Visual Basic) | PANTONE7487 | Gets the PANTONE 7487 color.
static (Shared in Visual Basic) | PANTONE7488 | Gets the PANTONE 7488 color.
static (Shared in Visual Basic) | PANTONE7489 | Gets the PANTONE 7489 color.
static (Shared in Visual Basic) | PANTONE7490 | Gets the PANTONE 7490 color.
static (Shared in Visual Basic) | PANTONE7491 | Gets the PANTONE 7491 color.
static (Shared in Visual Basic) | PANTONE7492 | Gets the PANTONE 7492 color.
static (Shared in Visual Basic) | PANTONE7493 | Gets the PANTONE 7493 color.
static (Shared in Visual Basic) | PANTONE7494 | Gets the PANTONE 7494 color.
static (Shared in Visual Basic) | PANTONE7495 | Gets the PANTONE 7495 color.
static (Shared in Visual Basic) | PANTONE7496 | Gets the PANTONE 7496 color.
static (Shared in Visual Basic) | PANTONE7497 | Gets the PANTONE 7497 color.
static (Shared in Visual Basic) | PANTONE7498 | Gets the PANTONE 7498 color.
static (Shared in Visual Basic) | PANTONE7499 | Gets the PANTONE 7499 color.
static (Shared in Visual Basic) | PANTONE7500 | Gets the PANTONE 7500 color.
static (Shared in Visual Basic) | PANTONE7501 | Gets the PANTONE 7501 color.
static (Shared in Visual Basic) | PANTONE7502 | Gets the PANTONE 7502 color.
static (Shared in Visual Basic) | PANTONE7503 | Gets the PANTONE 7503 color.
static (Shared in Visual Basic) | PANTONE7504 | Gets the PANTONE 7504 color.
static (Shared in Visual Basic) | PANTONE7505 | Gets the PANTONE 7505 color.
static (Shared in Visual Basic) | PANTONE7506 | Gets the PANTONE 7506 color.
static (Shared in Visual Basic) | PANTONE7507 | Gets the PANTONE 7507 color.
static (Shared in Visual Basic) | PANTONE7508 | Gets the PANTONE 7508 color.
static (Shared in Visual Basic) | PANTONE7509 | Gets the PANTONE 7509 color.
static (Shared in Visual Basic) | PANTONE7510 | Gets the PANTONE 7510 color.
static (Shared in Visual Basic) | PANTONE7511 | Gets the PANTONE 7511 color.
static (Shared in Visual Basic) | PANTONE7512 | Gets the PANTONE 7512 color.
static (Shared in Visual Basic) | PANTONE7513 | Gets the PANTONE 7513 color.
static (Shared in Visual Basic) | PANTONE7514 | Gets the PANTONE 7514 color.
static (Shared in Visual Basic) | PANTONE7515 | Gets the PANTONE 7515 color.
static (Shared in Visual Basic) | PANTONE7516 | Gets the PANTONE 7516 color.
static (Shared in Visual Basic) | PANTONE7517 | Gets the PANTONE 7517 color.
static (Shared in Visual Basic) | PANTONE7518 | Gets the PANTONE 7518 color.
static (Shared in Visual Basic) | PANTONE7519 | Gets the PANTONE 7519 color.
static (Shared in Visual Basic) | PANTONE7520 | Gets the PANTONE 7520 color.
static (Shared in Visual Basic) | PANTONE7521 | Gets the PANTONE 7521 color.
static (Shared in Visual Basic) | PANTONE7522 | Gets the PANTONE 7522 color.
static (Shared in Visual Basic) | PANTONE7523 | Gets the PANTONE 7523 color.
static (Shared in Visual Basic) | PANTONE7524 | Gets the PANTONE 7524 color.
static (Shared in Visual Basic) | PANTONE7525 | Gets the PANTONE 7525 color.
static (Shared in Visual Basic) | PANTONE7526 | Gets the PANTONE 7526 color.
static (Shared in Visual Basic) | PANTONE7527 | Gets the PANTONE 7527 color.
static (Shared in Visual Basic) | PANTONE7528 | Gets the PANTONE 7528 color.
static (Shared in Visual Basic) | PANTONE7529 | Gets the PANTONE 7529 color.
static (Shared in Visual Basic) | PANTONE7530 | Gets the PANTONE 7530 color.
static (Shared in Visual Basic) | PANTONE7531 | Gets the PANTONE 7531 color.
static (Shared in Visual Basic) | PANTONE7532 | Gets the PANTONE 7532 color.
static (Shared in Visual Basic) | PANTONE7533 | Gets the PANTONE 7533 color.
static (Shared in Visual Basic) | PANTONE7534 | Gets the PANTONE 7534 color.
static (Shared in Visual Basic) | PANTONE7535 | Gets the PANTONE 7535 color.
static (Shared in Visual Basic) | PANTONE7536 | Gets the PANTONE 7536 color.
static (Shared in Visual Basic) | PANTONE7537 | Gets the PANTONE 7537 color.
static (Shared in Visual Basic) | PANTONE7538 | Gets the PANTONE 7538 color.
static (Shared in Visual Basic) | PANTONE7539 | Gets the PANTONE 7539 color.
static (Shared in Visual Basic) | PANTONE7540 | Gets the PANTONE 7540 color.
static (Shared in Visual Basic) | PANTONE7541 | Gets the PANTONE 7541 color.
static (Shared in Visual Basic) | PANTONE7542 | Gets the PANTONE 7542 color.
static (Shared in Visual Basic) | PANTONE7543 | Gets the PANTONE 7543 color.
static (Shared in Visual Basic) | PANTONE7544 | Gets the PANTONE 7544 color.
static (Shared in Visual Basic) | PANTONE7545 | Gets the PANTONE 7545 color.
static (Shared in Visual Basic) | PANTONE7546 | Gets the PANTONE 7546 color.
static (Shared in Visual Basic) | PANTONE7547 | Gets the PANTONE 7547 color.
static (Shared in Visual Basic) | PANTONE8003 | Gets the PANTONE 8003 color.
static (Shared in Visual Basic) | PANTONE801 | Gets the PANTONE 801 color.
static (Shared in Visual Basic) | PANTONE802 | Gets the PANTONE 802 color.
static (Shared in Visual Basic) | PANTONE8021 | Gets the PANTONE 8021 color.
static (Shared in Visual Basic) | PANTONE803 | Gets the PANTONE 803 color.
static (Shared in Visual Basic) | PANTONE804 | Gets the PANTONE 804 color.
static (Shared in Visual Basic) | PANTONE805 | Gets the PANTONE 805 color.
static (Shared in Visual Basic) | PANTONE806 | Gets the PANTONE 806 color.
static (Shared in Visual Basic) | PANTONE8062 | Gets the PANTONE 8062 color.
static (Shared in Visual Basic) | PANTONE807 | Gets the PANTONE 807 color.
static (Shared in Visual Basic) | PANTONE808 | Gets the PANTONE 808 color.
static (Shared in Visual Basic) | PANTONE809 | Gets the PANTONE 809 color.
static (Shared in Visual Basic) | PANTONE810 | Gets the PANTONE 810 color.
static (Shared in Visual Basic) | PANTONE8100 | Gets the PANTONE 8100 color.
static (Shared in Visual Basic) | PANTONE811 | Gets the PANTONE 811 color.
static (Shared in Visual Basic) | PANTONE812 | Gets the PANTONE 812 color.
static (Shared in Visual Basic) | PANTONE813 | Gets the PANTONE 813 color.
static (Shared in Visual Basic) | PANTONE814 | Gets the PANTONE 814 color.
static (Shared in Visual Basic) | PANTONE8201 | Gets the PANTONE 8201 color.
static (Shared in Visual Basic) | PANTONE8281 | Gets the PANTONE 8281 color.
static (Shared in Visual Basic) | PANTONE8321 | Gets the PANTONE 8321 color.
static (Shared in Visual Basic) | PANTONE871 | Gets the PANTONE 871 color.
static (Shared in Visual Basic) | PANTONE872 | Gets the PANTONE 872 color.
static (Shared in Visual Basic) | PANTONE873 | Gets the PANTONE 873 color.
static (Shared in Visual Basic) | PANTONE874 | Gets the PANTONE 874 color.
static (Shared in Visual Basic) | PANTONE875 | Gets the PANTONE 875 color.
static (Shared in Visual Basic) | PANTONE876 | Gets the PANTONE 876 color.
static (Shared in Visual Basic) | PANTONE877 | Gets the PANTONE 877 color.
static (Shared in Visual Basic) | ProcessBlack | Gets the PANTONE Process Black color.
static (Shared in Visual Basic) | ProcessBlue | Gets the PANTONE Process Blue color.
static (Shared in Visual Basic) | ProcessCyan | Gets the PANTONE Process Cyan color.
static (Shared in Visual Basic) | ProcessMagenta | Gets the PANTONE Process Magenta color.
static (Shared in Visual Basic) | ProcessYellow | Gets the PANTONE Process Yellow color.
static (Shared in Visual Basic) | Purple | Gets the PANTONE Purple color.
static (Shared in Visual Basic) | Red032 | Gets the PANTONE Red 032 color.
static (Shared in Visual Basic) | ReflexBlue | Gets the PANTONE Reflex Blue color.
static (Shared in Visual Basic) | RhodamineRed | Gets the PANTONE Rhodamine Red color.
static (Shared in Visual Basic) | RubineRed | Gets the PANTONE Rubine Red color.
Public Property | Tint | Gets or sets the tint for this color. (Inherited from O2S.Components.PDF4NET.Graphics.PDFSeparationColor)
static (Shared in Visual Basic) | Violet | Gets the PANTONE Violet color.
static (Shared in Visual Basic) | WarmGray1 | Gets the PANTONE Warm Gray 1 color.
static (Shared in Visual Basic) | WarmGray10 | Gets the PANTONE Warm Gray 10 color.
static (Shared in Visual Basic) | WarmGray11 | Gets the PANTONE Warm Gray 11 color.
static (Shared in Visual Basic) | WarmGray2 | Gets the PANTONE Warm Gray 2 color.
static (Shared in Visual Basic) | WarmGray3 | Gets the PANTONE Warm Gray 3 color.
static (Shared in Visual Basic) | WarmGray4 | Gets the PANTONE Warm Gray 4 color.
static (Shared in Visual Basic) | WarmGray5 | Gets the PANTONE Warm Gray 5 color.
static (Shared in Visual Basic) | WarmGray6 | Gets the PANTONE Warm Gray 6 color.
static (Shared in Visual Basic) | WarmGray7 | Gets the PANTONE Warm Gray 7 color.
static (Shared in Visual Basic) | WarmGray8 | Gets the PANTONE Warm Gray 8 color.
static (Shared in Visual Basic) | WarmGray9 | Gets the PANTONE Warm Gray 9 color.
static (Shared in Visual Basic) | WarmRed | Gets the PANTONE Warm Red color.
static (Shared in Visual Basic) | Yellow | Gets the PANTONE Yellow color.
static (Shared in Visual Basic) | Yellow012 | Gets the PANTONE Yellow 012 color.
Top

See Also

Reference

PDFPantoneColor Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


Black Property

Black Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black Property

Gets the PANTONE Black color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Black As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Black
C#
public static PDFPantoneColor Black {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Black();
C++/CLI
public:
static property PDFPantoneColor^ Black {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Black color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Black2 Property

Black2 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black2 Property

Gets the PANTONE Black 2 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Black2 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Black2
C#
public static PDFPantoneColor Black2 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Black2();
C++/CLI
public:
static property PDFPantoneColor^ Black2 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Black 2 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Black3 Property

Black3 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black3 Property

Gets the PANTONE Black 3 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Black3 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Black3
C#
public static PDFPantoneColor Black3 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Black3();
C++/CLI
public:
static property PDFPantoneColor^ Black3 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Black 3 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Black4 Property

Black4 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black4 Property

Gets the PANTONE Black 4 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Black4 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Black4
C#
public static PDFPantoneColor Black4 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Black4();
C++/CLI
public:
static property PDFPantoneColor^ Black4 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Black 4 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Black5 Property

Black5 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black5 Property

Gets the PANTONE Black 5 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Black5 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Black5
C#
public static PDFPantoneColor Black5 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Black5();
C++/CLI
public:
static property PDFPantoneColor^ Black5 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Black 5 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Black6 Property

Black6 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black6 Property

Gets the PANTONE Black 6 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Black6 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Black6
C#
public static PDFPantoneColor Black6 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Black6();
C++/CLI
public:
static property PDFPantoneColor^ Black6 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Black 6 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Black7 Property

Black7 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Black7 Property

Gets the PANTONE Black 7 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Black7 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Black7
C#
public static PDFPantoneColor Black7 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Black7();
C++/CLI
public:
static property PDFPantoneColor^ Black7 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Black 7 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Blue072 Property

Blue072 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Blue072 Property

Gets the PANTONE Blue 072 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Blue072 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Blue072
C#
public static PDFPantoneColor Blue072 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Blue072();
C++/CLI
public:
static property PDFPantoneColor^ Blue072 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Blue 072 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray1 Property

CoolGray1 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray1 Property

Gets the PANTONE Cool Gray 1 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray1 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray1
C#
public static PDFPantoneColor CoolGray1 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray1();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray1 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 1 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray10 Property

CoolGray10 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray10 Property

Gets the PANTONE Cool Gray 10 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray10 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray10
C#
public static PDFPantoneColor CoolGray10 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray10();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray10 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 10 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray11 Property

CoolGray11 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray11 Property

Gets the PANTONE Cool Gray 11 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray11 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray11
C#
public static PDFPantoneColor CoolGray11 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray11();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray11 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 11 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray2 Property

CoolGray2 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray2 Property

Gets the PANTONE Cool Gray 2 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray2 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray2
C#
public static PDFPantoneColor CoolGray2 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray2();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray2 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 2 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray3 Property

CoolGray3 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray3 Property

Gets the PANTONE Cool Gray 3 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray3 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray3
C#
public static PDFPantoneColor CoolGray3 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray3();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray3 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 3 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray4 Property

CoolGray4 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray4 Property

Gets the PANTONE Cool Gray 4 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray4 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray4
C#
public static PDFPantoneColor CoolGray4 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray4();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray4 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 4 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray5 Property

CoolGray5 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray5 Property

Gets the PANTONE Cool Gray 5 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray5 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray5
C#
public static PDFPantoneColor CoolGray5 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray5();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray5 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 5 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray6 Property

CoolGray6 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray6 Property

Gets the PANTONE Cool Gray 6 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray6 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray6
C#
public static PDFPantoneColor CoolGray6 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray6();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray6 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 6 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray7 Property

CoolGray7 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray7 Property

Gets the PANTONE Cool Gray 7 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray7 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray7
C#
public static PDFPantoneColor CoolGray7 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray7();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray7 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 7 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray8 Property

CoolGray8 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray8 Property

Gets the PANTONE Cool Gray 8 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray8 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray8
C#
public static PDFPantoneColor CoolGray8 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray8();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray8 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 8 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


CoolGray9 Property

CoolGray9 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : CoolGray9 Property

Gets the PANTONE Cool Gray 9 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CoolGray9 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.CoolGray9
C#
public static PDFPantoneColor CoolGray9 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_CoolGray9();
C++/CLI
public:
static property PDFPantoneColor^ CoolGray9 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Cool Gray 9 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Green Property

Green Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Green Property

Gets the PANTONE Green color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Green As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Green
C#
public static PDFPantoneColor Green {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Green();
C++/CLI
public:
static property PDFPantoneColor^ Green {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Green color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


HexachromeBlack Property

HexachromeBlack Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeBlack Property

Gets the PANTONE Hexachrome Black color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property HexachromeBlack As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeBlack
C#
public static PDFPantoneColor HexachromeBlack {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_HexachromeBlack();
C++/CLI
public:
static property PDFPantoneColor^ HexachromeBlack {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Black color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


HexachromeCyan Property

HexachromeCyan Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeCyan Property

Gets the PANTONE Hexachrome Cyan color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property HexachromeCyan As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeCyan
C#
public static PDFPantoneColor HexachromeCyan {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_HexachromeCyan();
C++/CLI
public:
static property PDFPantoneColor^ HexachromeCyan {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Cyan color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


HexachromeGreen Property

HexachromeGreen Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeGreen Property

Gets the PANTONE Hexachrome Green color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property HexachromeGreen As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeGreen
C#
public static PDFPantoneColor HexachromeGreen {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_HexachromeGreen();
C++/CLI
public:
static property PDFPantoneColor^ HexachromeGreen {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Green color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


HexachromeMagenta Property

HexachromeMagenta Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeMagenta Property

Gets the PANTONE Hexachrome Magenta color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property HexachromeMagenta As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeMagenta
C#
public static PDFPantoneColor HexachromeMagenta {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_HexachromeMagenta();
C++/CLI
public:
static property PDFPantoneColor^ HexachromeMagenta {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Magenta color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


HexachromeOrange Property

HexachromeOrange Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeOrange Property

Gets the PANTONE Hexachrome Orange color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property HexachromeOrange As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeOrange
C#
public static PDFPantoneColor HexachromeOrange {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_HexachromeOrange();
C++/CLI
public:
static property PDFPantoneColor^ HexachromeOrange {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Orange color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


HexachromeYellow Property

HexachromeYellow Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : HexachromeYellow Property

Gets the PANTONE Hexachrome Yellow color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property HexachromeYellow As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.HexachromeYellow
C#
public static PDFPantoneColor HexachromeYellow {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_HexachromeYellow();
C++/CLI
public:
static property PDFPantoneColor^ HexachromeYellow {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Hexachrome Yellow color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Orange021 Property

Orange021 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Orange021 Property

Gets the PANTONE Orange 021 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Orange021 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Orange021
C#
public static PDFPantoneColor Orange021 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Orange021();
C++/CLI
public:
static property PDFPantoneColor^ Orange021 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Orange 021 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE100 Property

PANTONE100 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE100 Property

Gets the PANTONE 100 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE100 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE100
C#
public static PDFPantoneColor PANTONE100 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE100();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE100 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 100 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE101 Property

PANTONE101 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE101 Property

Gets the PANTONE 101 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE101 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE101
C#
public static PDFPantoneColor PANTONE101 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE101();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE101 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 101 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE102 Property

PANTONE102 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE102 Property

Gets the PANTONE 102 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE102 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE102
C#
public static PDFPantoneColor PANTONE102 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE102();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE102 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 102 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE103 Property

PANTONE103 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE103 Property

Gets the PANTONE 103 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE103 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE103
C#
public static PDFPantoneColor PANTONE103 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE103();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE103 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 103 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE104 Property

PANTONE104 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE104 Property

Gets the PANTONE 104 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE104 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE104
C#
public static PDFPantoneColor PANTONE104 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE104();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE104 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 104 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE105 Property

PANTONE105 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE105 Property

Gets the PANTONE 105 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE105 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE105
C#
public static PDFPantoneColor PANTONE105 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE105();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE105 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 105 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE106 Property

PANTONE106 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE106 Property

Gets the PANTONE 106 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE106 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE106
C#
public static PDFPantoneColor PANTONE106 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE106();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE106 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 106 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE107 Property

PANTONE107 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE107 Property

Gets the PANTONE 107 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE107 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE107
C#
public static PDFPantoneColor PANTONE107 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE107();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE107 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 107 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE108 Property

PANTONE108 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE108 Property

Gets the PANTONE 108 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE108 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE108
C#
public static PDFPantoneColor PANTONE108 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE108();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE108 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 108 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE109 Property

PANTONE109 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE109 Property

Gets the PANTONE 109 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE109 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE109
C#
public static PDFPantoneColor PANTONE109 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE109();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE109 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 109 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE110 Property

PANTONE110 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE110 Property

Gets the PANTONE 110 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE110 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE110
C#
public static PDFPantoneColor PANTONE110 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE110();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE110 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 110 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE111 Property

PANTONE111 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE111 Property

Gets the PANTONE 111 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE111 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE111
C#
public static PDFPantoneColor PANTONE111 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE111();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE111 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 111 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE112 Property

PANTONE112 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE112 Property

Gets the PANTONE 112 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE112 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE112
C#
public static PDFPantoneColor PANTONE112 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE112();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE112 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 112 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE113 Property

PANTONE113 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE113 Property

Gets the PANTONE 113 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE113 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE113
C#
public static PDFPantoneColor PANTONE113 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE113();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE113 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 113 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE114 Property

PANTONE114 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE114 Property

Gets the PANTONE 114 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE114 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE114
C#
public static PDFPantoneColor PANTONE114 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE114();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE114 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 114 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE115 Property

PANTONE115 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE115 Property

Gets the PANTONE 115 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE115 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE115
C#
public static PDFPantoneColor PANTONE115 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE115();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE115 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 115 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE116 Property

PANTONE116 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE116 Property

Gets the PANTONE 116 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE116 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE116
C#
public static PDFPantoneColor PANTONE116 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE116();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE116 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 116 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE117 Property

PANTONE117 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE117 Property

Gets the PANTONE 117 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE117 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE117
C#
public static PDFPantoneColor PANTONE117 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE117();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE117 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 117 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE118 Property

PANTONE118 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE118 Property

Gets the PANTONE 118 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE118 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE118
C#
public static PDFPantoneColor PANTONE118 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE118();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE118 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 118 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE119 Property

PANTONE119 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE119 Property

Gets the PANTONE 119 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE119 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE119
C#
public static PDFPantoneColor PANTONE119 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE119();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE119 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 119 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE120 Property

PANTONE120 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE120 Property

Gets the PANTONE 120 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE120 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE120
C#
public static PDFPantoneColor PANTONE120 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE120();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE120 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 120 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1205 Property

PANTONE1205 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1205 Property

Gets the PANTONE 1205 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1205 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1205
C#
public static PDFPantoneColor PANTONE1205 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1205();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1205 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1205 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE121 Property

PANTONE121 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE121 Property

Gets the PANTONE 121 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE121 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE121
C#
public static PDFPantoneColor PANTONE121 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE121();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE121 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 121 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1215 Property

PANTONE1215 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1215 Property

Gets the PANTONE 1215 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1215 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1215
C#
public static PDFPantoneColor PANTONE1215 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1215();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1215 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1215 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE122 Property

PANTONE122 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE122 Property

Gets the PANTONE 122 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE122 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE122
C#
public static PDFPantoneColor PANTONE122 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE122();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE122 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 122 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1225 Property

PANTONE1225 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1225 Property

Gets the PANTONE 1225 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1225 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1225
C#
public static PDFPantoneColor PANTONE1225 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1225();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1225 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1225 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE123 Property

PANTONE123 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE123 Property

Gets the PANTONE 123 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE123 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE123
C#
public static PDFPantoneColor PANTONE123 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE123();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE123 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 123 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1235 Property

PANTONE1235 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1235 Property

Gets the PANTONE 1235 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1235 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1235
C#
public static PDFPantoneColor PANTONE1235 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1235();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1235 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1235 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE124 Property

PANTONE124 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE124 Property

Gets the PANTONE 124 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE124 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE124
C#
public static PDFPantoneColor PANTONE124 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE124();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE124 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 124 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1245 Property

PANTONE1245 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1245 Property

Gets the PANTONE 1245 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1245 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1245
C#
public static PDFPantoneColor PANTONE1245 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1245();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1245 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1245 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE125 Property

PANTONE125 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE125 Property

Gets the PANTONE 125 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE125 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE125
C#
public static PDFPantoneColor PANTONE125 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE125();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE125 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 125 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1255 Property

PANTONE1255 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1255 Property

Gets the PANTONE 1255 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1255 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1255
C#
public static PDFPantoneColor PANTONE1255 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1255();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1255 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1255 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE126 Property

PANTONE126 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE126 Property

Gets the PANTONE 126 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE126 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE126
C#
public static PDFPantoneColor PANTONE126 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE126();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE126 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 126 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1265 Property

PANTONE1265 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1265 Property

Gets the PANTONE 1265 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1265 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1265
C#
public static PDFPantoneColor PANTONE1265 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1265();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1265 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1265 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE127 Property

PANTONE127 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE127 Property

Gets the PANTONE 127 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE127 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE127
C#
public static PDFPantoneColor PANTONE127 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE127();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE127 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 127 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE128 Property

PANTONE128 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE128 Property

Gets the PANTONE 128 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE128 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE128
C#
public static PDFPantoneColor PANTONE128 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE128();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE128 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 128 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE129 Property

PANTONE129 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE129 Property

Gets the PANTONE 129 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE129 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE129
C#
public static PDFPantoneColor PANTONE129 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE129();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE129 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 129 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE130 Property

PANTONE130 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE130 Property

Gets the PANTONE 130 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE130 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE130
C#
public static PDFPantoneColor PANTONE130 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE130();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE130 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 130 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE131 Property

PANTONE131 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE131 Property

Gets the PANTONE 131 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE131 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE131
C#
public static PDFPantoneColor PANTONE131 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE131();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE131 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 131 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE132 Property

PANTONE132 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE132 Property

Gets the PANTONE 132 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE132 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE132
C#
public static PDFPantoneColor PANTONE132 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE132();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE132 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 132 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE133 Property

PANTONE133 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE133 Property

Gets the PANTONE 133 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE133 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE133
C#
public static PDFPantoneColor PANTONE133 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE133();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE133 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 133 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE134 Property

PANTONE134 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE134 Property

Gets the PANTONE 134 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE134 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE134
C#
public static PDFPantoneColor PANTONE134 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE134();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE134 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 134 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1345 Property

PANTONE1345 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1345 Property

Gets the PANTONE 1345 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1345 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1345
C#
public static PDFPantoneColor PANTONE1345 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1345();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1345 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1345 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE135 Property

PANTONE135 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE135 Property

Gets the PANTONE 135 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE135 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE135
C#
public static PDFPantoneColor PANTONE135 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE135();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE135 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 135 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1355 Property

PANTONE1355 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1355 Property

Gets the PANTONE 1355 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1355 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1355
C#
public static PDFPantoneColor PANTONE1355 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1355();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1355 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1355 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE136 Property

PANTONE136 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE136 Property

Gets the PANTONE 136 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE136 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE136
C#
public static PDFPantoneColor PANTONE136 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE136();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE136 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 136 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1365 Property

PANTONE1365 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1365 Property

Gets the PANTONE 1365 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1365 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1365
C#
public static PDFPantoneColor PANTONE1365 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1365();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1365 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1365 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE137 Property

PANTONE137 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE137 Property

Gets the PANTONE 137 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE137 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE137
C#
public static PDFPantoneColor PANTONE137 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE137();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE137 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 137 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1375 Property

PANTONE1375 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1375 Property

Gets the PANTONE 1375 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1375 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1375
C#
public static PDFPantoneColor PANTONE1375 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1375();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1375 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1375 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE138 Property

PANTONE138 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE138 Property

Gets the PANTONE 138 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE138 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE138
C#
public static PDFPantoneColor PANTONE138 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE138();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE138 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 138 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1385 Property

PANTONE1385 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1385 Property

Gets the PANTONE 1385 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1385 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1385
C#
public static PDFPantoneColor PANTONE1385 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1385();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1385 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1385 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE139 Property

PANTONE139 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE139 Property

Gets the PANTONE 139 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE139 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE139
C#
public static PDFPantoneColor PANTONE139 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE139();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE139 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 139 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1395 Property

PANTONE1395 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1395 Property

Gets the PANTONE 1395 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1395 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1395
C#
public static PDFPantoneColor PANTONE1395 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1395();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1395 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1395 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE140 Property

PANTONE140 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE140 Property

Gets the PANTONE 140 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE140 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE140
C#
public static PDFPantoneColor PANTONE140 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE140();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE140 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 140 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1405 Property

PANTONE1405 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1405 Property

Gets the PANTONE 1405 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1405 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1405
C#
public static PDFPantoneColor PANTONE1405 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1405();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1405 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1405 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE141 Property

PANTONE141 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE141 Property

Gets the PANTONE 141 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE141 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE141
C#
public static PDFPantoneColor PANTONE141 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE141();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE141 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 141 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE142 Property

PANTONE142 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE142 Property

Gets the PANTONE 142 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE142 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE142
C#
public static PDFPantoneColor PANTONE142 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE142();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE142 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 142 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE143 Property

PANTONE143 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE143 Property

Gets the PANTONE 143 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE143 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE143
C#
public static PDFPantoneColor PANTONE143 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE143();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE143 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 143 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE144 Property

PANTONE144 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE144 Property

Gets the PANTONE 144 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE144 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE144
C#
public static PDFPantoneColor PANTONE144 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE144();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE144 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 144 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE145 Property

PANTONE145 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE145 Property

Gets the PANTONE 145 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE145 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE145
C#
public static PDFPantoneColor PANTONE145 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE145();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE145 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 145 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE146 Property

PANTONE146 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE146 Property

Gets the PANTONE 146 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE146 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE146
C#
public static PDFPantoneColor PANTONE146 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE146();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE146 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 146 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE147 Property

PANTONE147 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE147 Property

Gets the PANTONE 147 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE147 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE147
C#
public static PDFPantoneColor PANTONE147 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE147();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE147 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 147 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE148 Property

PANTONE148 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE148 Property

Gets the PANTONE 148 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE148 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE148
C#
public static PDFPantoneColor PANTONE148 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE148();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE148 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 148 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1485 Property

PANTONE1485 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1485 Property

Gets the PANTONE 1485 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1485 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1485
C#
public static PDFPantoneColor PANTONE1485 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1485();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1485 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1485 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE149 Property

PANTONE149 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE149 Property

Gets the PANTONE 149 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE149 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE149
C#
public static PDFPantoneColor PANTONE149 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE149();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE149 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 149 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1495 Property

PANTONE1495 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1495 Property

Gets the PANTONE 1495 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1495 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1495
C#
public static PDFPantoneColor PANTONE1495 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1495();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1495 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1495 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE150 Property

PANTONE150 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE150 Property

Gets the PANTONE 150 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE150 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE150
C#
public static PDFPantoneColor PANTONE150 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE150();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE150 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 150 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1505 Property

PANTONE1505 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1505 Property

Gets the PANTONE 1505 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1505 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1505
C#
public static PDFPantoneColor PANTONE1505 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1505();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1505 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1505 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE151 Property

PANTONE151 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE151 Property

Gets the PANTONE 151 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE151 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE151
C#
public static PDFPantoneColor PANTONE151 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE151();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE151 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 151 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE152 Property

PANTONE152 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE152 Property

Gets the PANTONE 152 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE152 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE152
C#
public static PDFPantoneColor PANTONE152 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE152();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE152 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 152 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1525 Property

PANTONE1525 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1525 Property

Gets the PANTONE 1525 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1525 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1525
C#
public static PDFPantoneColor PANTONE1525 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1525();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1525 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1525 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE153 Property

PANTONE153 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE153 Property

Gets the PANTONE 153 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE153 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE153
C#
public static PDFPantoneColor PANTONE153 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE153();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE153 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 153 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1535 Property

PANTONE1535 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1535 Property

Gets the PANTONE 1535 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1535 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1535
C#
public static PDFPantoneColor PANTONE1535 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1535();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1535 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1535 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE154 Property

PANTONE154 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE154 Property

Gets the PANTONE 154 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE154 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE154
C#
public static PDFPantoneColor PANTONE154 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE154();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE154 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 154 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1545 Property

PANTONE1545 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1545 Property

Gets the PANTONE 1545 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1545 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1545
C#
public static PDFPantoneColor PANTONE1545 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1545();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1545 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1545 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE155 Property

PANTONE155 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE155 Property

Gets the PANTONE 155 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE155 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE155
C#
public static PDFPantoneColor PANTONE155 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE155();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE155 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 155 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1555 Property

PANTONE1555 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1555 Property

Gets the PANTONE 1555 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1555 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1555
C#
public static PDFPantoneColor PANTONE1555 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1555();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1555 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1555 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE156 Property

PANTONE156 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE156 Property

Gets the PANTONE 156 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE156 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE156
C#
public static PDFPantoneColor PANTONE156 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE156();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE156 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 156 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1565 Property

PANTONE1565 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1565 Property

Gets the PANTONE 1565 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1565 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1565
C#
public static PDFPantoneColor PANTONE1565 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1565();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1565 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1565 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE157 Property

PANTONE157 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE157 Property

Gets the PANTONE 157 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE157 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE157
C#
public static PDFPantoneColor PANTONE157 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE157();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE157 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 157 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1575 Property

PANTONE1575 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1575 Property

Gets the PANTONE 1575 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1575 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1575
C#
public static PDFPantoneColor PANTONE1575 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1575();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1575 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1575 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE158 Property

PANTONE158 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE158 Property

Gets the PANTONE 158 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE158 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE158
C#
public static PDFPantoneColor PANTONE158 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE158();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE158 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 158 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1585 Property

PANTONE1585 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1585 Property

Gets the PANTONE 1585 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1585 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1585
C#
public static PDFPantoneColor PANTONE1585 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1585();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1585 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1585 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE159 Property

PANTONE159 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE159 Property

Gets the PANTONE 159 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE159 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE159
C#
public static PDFPantoneColor PANTONE159 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE159();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE159 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 159 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1595 Property

PANTONE1595 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1595 Property

Gets the PANTONE 1595 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1595 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1595
C#
public static PDFPantoneColor PANTONE1595 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1595();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1595 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1595 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE160 Property

PANTONE160 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE160 Property

Gets the PANTONE 160 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE160 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE160
C#
public static PDFPantoneColor PANTONE160 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE160();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE160 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 160 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1605 Property

PANTONE1605 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1605 Property

Gets the PANTONE 1605 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1605 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1605
C#
public static PDFPantoneColor PANTONE1605 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1605();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1605 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1605 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE161 Property

PANTONE161 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE161 Property

Gets the PANTONE 161 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE161 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE161
C#
public static PDFPantoneColor PANTONE161 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE161();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE161 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 161 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1615 Property

PANTONE1615 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1615 Property

Gets the PANTONE 1615 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1615 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1615
C#
public static PDFPantoneColor PANTONE1615 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1615();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1615 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1615 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE162 Property

PANTONE162 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE162 Property

Gets the PANTONE 162 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE162 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE162
C#
public static PDFPantoneColor PANTONE162 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE162();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE162 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 162 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1625 Property

PANTONE1625 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1625 Property

Gets the PANTONE 1625 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1625 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1625
C#
public static PDFPantoneColor PANTONE1625 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1625();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1625 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1625 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE163 Property

PANTONE163 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE163 Property

Gets the PANTONE 163 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE163 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE163
C#
public static PDFPantoneColor PANTONE163 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE163();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE163 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 163 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1635 Property

PANTONE1635 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1635 Property

Gets the PANTONE 1635 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1635 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1635
C#
public static PDFPantoneColor PANTONE1635 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1635();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1635 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1635 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE164 Property

PANTONE164 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE164 Property

Gets the PANTONE 164 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE164 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE164
C#
public static PDFPantoneColor PANTONE164 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE164();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE164 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 164 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1645 Property

PANTONE1645 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1645 Property

Gets the PANTONE 1645 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1645 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1645
C#
public static PDFPantoneColor PANTONE1645 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1645();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1645 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1645 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE165 Property

PANTONE165 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE165 Property

Gets the PANTONE 165 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE165 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE165
C#
public static PDFPantoneColor PANTONE165 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE165();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE165 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 165 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1655 Property

PANTONE1655 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1655 Property

Gets the PANTONE 1655 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1655 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1655
C#
public static PDFPantoneColor PANTONE1655 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1655();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1655 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1655 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE166 Property

PANTONE166 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE166 Property

Gets the PANTONE 166 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE166 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE166
C#
public static PDFPantoneColor PANTONE166 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE166();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE166 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 166 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1665 Property

PANTONE1665 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1665 Property

Gets the PANTONE 1665 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1665 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1665
C#
public static PDFPantoneColor PANTONE1665 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1665();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1665 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1665 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE167 Property

PANTONE167 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE167 Property

Gets the PANTONE 167 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE167 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE167
C#
public static PDFPantoneColor PANTONE167 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE167();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE167 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 167 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1675 Property

PANTONE1675 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1675 Property

Gets the PANTONE 1675 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1675 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1675
C#
public static PDFPantoneColor PANTONE1675 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1675();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1675 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1675 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE168 Property

PANTONE168 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE168 Property

Gets the PANTONE 168 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE168 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE168
C#
public static PDFPantoneColor PANTONE168 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE168();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE168 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 168 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1685 Property

PANTONE1685 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1685 Property

Gets the PANTONE 1685 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1685 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1685
C#
public static PDFPantoneColor PANTONE1685 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1685();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1685 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1685 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE169 Property

PANTONE169 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE169 Property

Gets the PANTONE 169 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE169 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE169
C#
public static PDFPantoneColor PANTONE169 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE169();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE169 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 169 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE170 Property

PANTONE170 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE170 Property

Gets the PANTONE 170 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE170 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE170
C#
public static PDFPantoneColor PANTONE170 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE170();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE170 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 170 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE171 Property

PANTONE171 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE171 Property

Gets the PANTONE 171 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE171 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE171
C#
public static PDFPantoneColor PANTONE171 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE171();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE171 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 171 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE172 Property

PANTONE172 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE172 Property

Gets the PANTONE 172 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE172 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE172
C#
public static PDFPantoneColor PANTONE172 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE172();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE172 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 172 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE173 Property

PANTONE173 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE173 Property

Gets the PANTONE 173 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE173 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE173
C#
public static PDFPantoneColor PANTONE173 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE173();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE173 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 173 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE174 Property

PANTONE174 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE174 Property

Gets the PANTONE 174 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE174 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE174
C#
public static PDFPantoneColor PANTONE174 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE174();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE174 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 174 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE175 Property

PANTONE175 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE175 Property

Gets the PANTONE 175 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE175 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE175
C#
public static PDFPantoneColor PANTONE175 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE175();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE175 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 175 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE176 Property

PANTONE176 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE176 Property

Gets the PANTONE 176 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE176 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE176
C#
public static PDFPantoneColor PANTONE176 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE176();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE176 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 176 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1765 Property

PANTONE1765 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1765 Property

Gets the PANTONE 1765 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1765 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1765
C#
public static PDFPantoneColor PANTONE1765 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1765();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1765 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1765 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1767 Property

PANTONE1767 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1767 Property

Gets the PANTONE 1767 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1767 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1767
C#
public static PDFPantoneColor PANTONE1767 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1767();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1767 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1767 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE177 Property

PANTONE177 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE177 Property

Gets the PANTONE 177 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE177 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE177
C#
public static PDFPantoneColor PANTONE177 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE177();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE177 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 177 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1775 Property

PANTONE1775 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1775 Property

Gets the PANTONE 1775 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1775 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1775
C#
public static PDFPantoneColor PANTONE1775 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1775();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1775 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1775 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1777 Property

PANTONE1777 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1777 Property

Gets the PANTONE 1777 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1777 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1777
C#
public static PDFPantoneColor PANTONE1777 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1777();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1777 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1777 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE178 Property

PANTONE178 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE178 Property

Gets the PANTONE 178 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE178 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE178
C#
public static PDFPantoneColor PANTONE178 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE178();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE178 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 178 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1785 Property

PANTONE1785 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1785 Property

Gets the PANTONE 1785 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1785 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1785
C#
public static PDFPantoneColor PANTONE1785 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1785();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1785 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1785 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1787 Property

PANTONE1787 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1787 Property

Gets the PANTONE 1787 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1787 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1787
C#
public static PDFPantoneColor PANTONE1787 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1787();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1787 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1787 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1788 Property

PANTONE1788 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1788 Property

Gets the PANTONE 1788 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1788 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1788
C#
public static PDFPantoneColor PANTONE1788 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1788();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1788 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1788 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE179 Property

PANTONE179 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE179 Property

Gets the PANTONE 179 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE179 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE179
C#
public static PDFPantoneColor PANTONE179 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE179();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE179 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 179 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1795 Property

PANTONE1795 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1795 Property

Gets the PANTONE 1795 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1795 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1795
C#
public static PDFPantoneColor PANTONE1795 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1795();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1795 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1795 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1797 Property

PANTONE1797 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1797 Property

Gets the PANTONE 1797 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1797 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1797
C#
public static PDFPantoneColor PANTONE1797 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1797();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1797 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1797 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE180 Property

PANTONE180 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE180 Property

Gets the PANTONE 180 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE180 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE180
C#
public static PDFPantoneColor PANTONE180 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE180();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE180 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 180 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1805 Property

PANTONE1805 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1805 Property

Gets the PANTONE 1805 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1805 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1805
C#
public static PDFPantoneColor PANTONE1805 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1805();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1805 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1805 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1807 Property

PANTONE1807 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1807 Property

Gets the PANTONE 1807 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1807 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1807
C#
public static PDFPantoneColor PANTONE1807 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1807();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1807 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1807 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE181 Property

PANTONE181 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE181 Property

Gets the PANTONE 181 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE181 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE181
C#
public static PDFPantoneColor PANTONE181 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE181();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE181 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 181 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1815 Property

PANTONE1815 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1815 Property

Gets the PANTONE 1815 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1815 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1815
C#
public static PDFPantoneColor PANTONE1815 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1815();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1815 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1815 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1817 Property

PANTONE1817 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1817 Property

Gets the PANTONE 1817 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1817 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1817
C#
public static PDFPantoneColor PANTONE1817 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1817();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1817 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1817 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE182 Property

PANTONE182 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE182 Property

Gets the PANTONE 182 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE182 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE182
C#
public static PDFPantoneColor PANTONE182 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE182();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE182 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 182 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE183 Property

PANTONE183 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE183 Property

Gets the PANTONE 183 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE183 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE183
C#
public static PDFPantoneColor PANTONE183 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE183();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE183 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 183 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE184 Property

PANTONE184 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE184 Property

Gets the PANTONE 184 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE184 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE184
C#
public static PDFPantoneColor PANTONE184 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE184();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE184 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 184 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE185 Property

PANTONE185 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE185 Property

Gets the PANTONE 185 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE185 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE185
C#
public static PDFPantoneColor PANTONE185 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE185();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE185 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 185 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE186 Property

PANTONE186 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE186 Property

Gets the PANTONE 186 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE186 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE186
C#
public static PDFPantoneColor PANTONE186 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE186();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE186 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 186 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE187 Property

PANTONE187 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE187 Property

Gets the PANTONE 187 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE187 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE187
C#
public static PDFPantoneColor PANTONE187 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE187();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE187 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 187 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE188 Property

PANTONE188 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE188 Property

Gets the PANTONE 188 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE188 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE188
C#
public static PDFPantoneColor PANTONE188 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE188();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE188 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 188 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE189 Property

PANTONE189 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE189 Property

Gets the PANTONE 189 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE189 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE189
C#
public static PDFPantoneColor PANTONE189 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE189();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE189 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 189 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1895 Property

PANTONE1895 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1895 Property

Gets the PANTONE 1895 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1895 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1895
C#
public static PDFPantoneColor PANTONE1895 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1895();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1895 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1895 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE190 Property

PANTONE190 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE190 Property

Gets the PANTONE 190 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE190 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE190
C#
public static PDFPantoneColor PANTONE190 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE190();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE190 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 190 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1905 Property

PANTONE1905 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1905 Property

Gets the PANTONE 1905 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1905 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1905
C#
public static PDFPantoneColor PANTONE1905 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1905();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1905 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1905 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE191 Property

PANTONE191 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE191 Property

Gets the PANTONE 191 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE191 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE191
C#
public static PDFPantoneColor PANTONE191 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE191();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE191 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 191 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1915 Property

PANTONE1915 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1915 Property

Gets the PANTONE 1915 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1915 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1915
C#
public static PDFPantoneColor PANTONE1915 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1915();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1915 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1915 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE192 Property

PANTONE192 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE192 Property

Gets the PANTONE 192 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE192 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE192
C#
public static PDFPantoneColor PANTONE192 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE192();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE192 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 192 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1925 Property

PANTONE1925 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1925 Property

Gets the PANTONE 1925 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1925 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1925
C#
public static PDFPantoneColor PANTONE1925 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1925();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1925 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1925 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE193 Property

PANTONE193 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE193 Property

Gets the PANTONE 193 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE193 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE193
C#
public static PDFPantoneColor PANTONE193 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE193();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE193 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 193 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1935 Property

PANTONE1935 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1935 Property

Gets the PANTONE 1935 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1935 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1935
C#
public static PDFPantoneColor PANTONE1935 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1935();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1935 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1935 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE194 Property

PANTONE194 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE194 Property

Gets the PANTONE 194 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE194 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE194
C#
public static PDFPantoneColor PANTONE194 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE194();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE194 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 194 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1945 Property

PANTONE1945 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1945 Property

Gets the PANTONE 1945 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1945 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1945
C#
public static PDFPantoneColor PANTONE1945 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1945();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1945 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1945 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE195 Property

PANTONE195 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE195 Property

Gets the PANTONE 195 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE195 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE195
C#
public static PDFPantoneColor PANTONE195 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE195();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE195 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 195 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE1955 Property

PANTONE1955 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE1955 Property

Gets the PANTONE 1955 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE1955 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE1955
C#
public static PDFPantoneColor PANTONE1955 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE1955();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE1955 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 1955 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE196 Property

PANTONE196 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE196 Property

Gets the PANTONE 196 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE196 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE196
C#
public static PDFPantoneColor PANTONE196 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE196();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE196 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 196 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE197 Property

PANTONE197 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE197 Property

Gets the PANTONE 197 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE197 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE197
C#
public static PDFPantoneColor PANTONE197 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE197();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE197 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 197 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE198 Property

PANTONE198 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE198 Property

Gets the PANTONE 198 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE198 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE198
C#
public static PDFPantoneColor PANTONE198 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE198();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE198 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 198 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE199 Property

PANTONE199 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE199 Property

Gets the PANTONE 199 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE199 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE199
C#
public static PDFPantoneColor PANTONE199 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE199();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE199 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 199 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE200 Property

PANTONE200 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE200 Property

Gets the PANTONE 200 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE200 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE200
C#
public static PDFPantoneColor PANTONE200 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE200();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE200 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 200 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE201 Property

PANTONE201 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE201 Property

Gets the PANTONE 201 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE201 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE201
C#
public static PDFPantoneColor PANTONE201 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE201();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE201 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 201 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE202 Property

PANTONE202 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE202 Property

Gets the PANTONE 202 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE202 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE202
C#
public static PDFPantoneColor PANTONE202 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE202();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE202 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 202 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE203 Property

PANTONE203 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE203 Property

Gets the PANTONE 203 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE203 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE203
C#
public static PDFPantoneColor PANTONE203 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE203();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE203 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 203 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE204 Property

PANTONE204 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE204 Property

Gets the PANTONE 204 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE204 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE204
C#
public static PDFPantoneColor PANTONE204 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE204();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE204 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 204 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE205 Property

PANTONE205 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE205 Property

Gets the PANTONE 205 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE205 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE205
C#
public static PDFPantoneColor PANTONE205 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE205();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE205 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 205 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE206 Property

PANTONE206 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE206 Property

Gets the PANTONE 206 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE206 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE206
C#
public static PDFPantoneColor PANTONE206 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE206();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE206 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 206 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE207 Property

PANTONE207 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE207 Property

Gets the PANTONE 207 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE207 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE207
C#
public static PDFPantoneColor PANTONE207 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE207();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE207 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 207 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE208 Property

PANTONE208 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE208 Property

Gets the PANTONE 208 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE208 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE208
C#
public static PDFPantoneColor PANTONE208 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE208();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE208 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 208 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE209 Property

PANTONE209 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE209 Property

Gets the PANTONE 209 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE209 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE209
C#
public static PDFPantoneColor PANTONE209 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE209();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE209 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 209 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE210 Property

PANTONE210 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE210 Property

Gets the PANTONE 210 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE210 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE210
C#
public static PDFPantoneColor PANTONE210 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE210();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE210 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 210 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE211 Property

PANTONE211 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE211 Property

Gets the PANTONE 211 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE211 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE211
C#
public static PDFPantoneColor PANTONE211 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE211();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE211 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 211 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE212 Property

PANTONE212 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE212 Property

Gets the PANTONE 212 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE212 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE212
C#
public static PDFPantoneColor PANTONE212 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE212();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE212 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 212 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE213 Property

PANTONE213 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE213 Property

Gets the PANTONE 213 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE213 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE213
C#
public static PDFPantoneColor PANTONE213 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE213();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE213 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 213 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE214 Property

PANTONE214 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE214 Property

Gets the PANTONE 214 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE214 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE214
C#
public static PDFPantoneColor PANTONE214 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE214();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE214 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 214 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE215 Property

PANTONE215 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE215 Property

Gets the PANTONE 215 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE215 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE215
C#
public static PDFPantoneColor PANTONE215 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE215();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE215 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 215 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE216 Property

PANTONE216 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE216 Property

Gets the PANTONE 216 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE216 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE216
C#
public static PDFPantoneColor PANTONE216 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE216();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE216 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 216 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE217 Property

PANTONE217 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE217 Property

Gets the PANTONE 217 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE217 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE217
C#
public static PDFPantoneColor PANTONE217 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE217();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE217 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 217 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE218 Property

PANTONE218 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE218 Property

Gets the PANTONE 218 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE218 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE218
C#
public static PDFPantoneColor PANTONE218 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE218();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE218 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 218 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE219 Property

PANTONE219 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE219 Property

Gets the PANTONE 219 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE219 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE219
C#
public static PDFPantoneColor PANTONE219 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE219();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE219 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 219 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE220 Property

PANTONE220 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE220 Property

Gets the PANTONE 220 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE220 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE220
C#
public static PDFPantoneColor PANTONE220 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE220();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE220 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 220 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE221 Property

PANTONE221 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE221 Property

Gets the PANTONE 221 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE221 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE221
C#
public static PDFPantoneColor PANTONE221 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE221();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE221 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 221 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE222 Property

PANTONE222 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE222 Property

Gets the PANTONE 222 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE222 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE222
C#
public static PDFPantoneColor PANTONE222 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE222();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE222 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 222 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE223 Property

PANTONE223 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE223 Property

Gets the PANTONE 223 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE223 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE223
C#
public static PDFPantoneColor PANTONE223 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE223();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE223 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 223 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE224 Property

PANTONE224 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE224 Property

Gets the PANTONE 224 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE224 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE224
C#
public static PDFPantoneColor PANTONE224 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE224();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE224 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 224 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE225 Property

PANTONE225 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE225 Property

Gets the PANTONE 225 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE225 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE225
C#
public static PDFPantoneColor PANTONE225 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE225();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE225 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 225 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE226 Property

PANTONE226 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE226 Property

Gets the PANTONE 226 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE226 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE226
C#
public static PDFPantoneColor PANTONE226 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE226();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE226 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 226 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE227 Property

PANTONE227 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE227 Property

Gets the PANTONE 227 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE227 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE227
C#
public static PDFPantoneColor PANTONE227 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE227();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE227 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 227 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE228 Property

PANTONE228 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE228 Property

Gets the PANTONE 228 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE228 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE228
C#
public static PDFPantoneColor PANTONE228 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE228();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE228 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 228 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE229 Property

PANTONE229 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE229 Property

Gets the PANTONE 229 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE229 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE229
C#
public static PDFPantoneColor PANTONE229 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE229();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE229 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 229 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE230 Property

PANTONE230 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE230 Property

Gets the PANTONE 230 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE230 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE230
C#
public static PDFPantoneColor PANTONE230 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE230();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE230 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 230 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE231 Property

PANTONE231 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE231 Property

Gets the PANTONE 231 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE231 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE231
C#
public static PDFPantoneColor PANTONE231 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE231();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE231 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 231 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE232 Property

PANTONE232 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE232 Property

Gets the PANTONE 232 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE232 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE232
C#
public static PDFPantoneColor PANTONE232 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE232();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE232 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 232 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE233 Property

PANTONE233 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE233 Property

Gets the PANTONE 233 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE233 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE233
C#
public static PDFPantoneColor PANTONE233 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE233();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE233 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 233 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE234 Property

PANTONE234 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE234 Property

Gets the PANTONE 234 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE234 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE234
C#
public static PDFPantoneColor PANTONE234 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE234();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE234 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 234 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE235 Property

PANTONE235 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE235 Property

Gets the PANTONE 235 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE235 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE235
C#
public static PDFPantoneColor PANTONE235 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE235();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE235 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 235 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE236 Property

PANTONE236 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE236 Property

Gets the PANTONE 236 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE236 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE236
C#
public static PDFPantoneColor PANTONE236 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE236();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE236 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 236 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2365 Property

PANTONE2365 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2365 Property

Gets the PANTONE 2365 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2365 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2365
C#
public static PDFPantoneColor PANTONE2365 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2365();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2365 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2365 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE237 Property

PANTONE237 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE237 Property

Gets the PANTONE 237 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE237 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE237
C#
public static PDFPantoneColor PANTONE237 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE237();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE237 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 237 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2375 Property

PANTONE2375 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2375 Property

Gets the PANTONE 2375 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2375 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2375
C#
public static PDFPantoneColor PANTONE2375 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2375();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2375 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2375 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE238 Property

PANTONE238 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE238 Property

Gets the PANTONE 238 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE238 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE238
C#
public static PDFPantoneColor PANTONE238 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE238();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE238 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 238 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2385 Property

PANTONE2385 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2385 Property

Gets the PANTONE 2385 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2385 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2385
C#
public static PDFPantoneColor PANTONE2385 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2385();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2385 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2385 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE239 Property

PANTONE239 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE239 Property

Gets the PANTONE 239 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE239 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE239
C#
public static PDFPantoneColor PANTONE239 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE239();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE239 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 239 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2395 Property

PANTONE2395 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2395 Property

Gets the PANTONE 2395 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2395 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2395
C#
public static PDFPantoneColor PANTONE2395 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2395();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2395 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2395 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE240 Property

PANTONE240 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE240 Property

Gets the PANTONE 240 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE240 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE240
C#
public static PDFPantoneColor PANTONE240 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE240();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE240 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 240 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2405 Property

PANTONE2405 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2405 Property

Gets the PANTONE 2405 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2405 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2405
C#
public static PDFPantoneColor PANTONE2405 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2405();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2405 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2405 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE241 Property

PANTONE241 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE241 Property

Gets the PANTONE 241 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE241 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE241
C#
public static PDFPantoneColor PANTONE241 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE241();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE241 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 241 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2415 Property

PANTONE2415 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2415 Property

Gets the PANTONE 2415 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2415 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2415
C#
public static PDFPantoneColor PANTONE2415 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2415();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2415 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2415 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE242 Property

PANTONE242 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE242 Property

Gets the PANTONE 242 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE242 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE242
C#
public static PDFPantoneColor PANTONE242 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE242();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE242 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 242 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2425 Property

PANTONE2425 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2425 Property

Gets the PANTONE 2425 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2425 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2425
C#
public static PDFPantoneColor PANTONE2425 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2425();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2425 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2425 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE243 Property

PANTONE243 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE243 Property

Gets the PANTONE 243 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE243 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE243
C#
public static PDFPantoneColor PANTONE243 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE243();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE243 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 243 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE244 Property

PANTONE244 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE244 Property

Gets the PANTONE 244 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE244 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE244
C#
public static PDFPantoneColor PANTONE244 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE244();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE244 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 244 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE245 Property

PANTONE245 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE245 Property

Gets the PANTONE 245 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE245 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE245
C#
public static PDFPantoneColor PANTONE245 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE245();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE245 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 245 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE246 Property

PANTONE246 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE246 Property

Gets the PANTONE 246 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE246 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE246
C#
public static PDFPantoneColor PANTONE246 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE246();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE246 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 246 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE247 Property

PANTONE247 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE247 Property

Gets the PANTONE 247 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE247 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE247
C#
public static PDFPantoneColor PANTONE247 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE247();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE247 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 247 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE248 Property

PANTONE248 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE248 Property

Gets the PANTONE 248 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE248 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE248
C#
public static PDFPantoneColor PANTONE248 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE248();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE248 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 248 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE249 Property

PANTONE249 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE249 Property

Gets the PANTONE 249 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE249 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE249
C#
public static PDFPantoneColor PANTONE249 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE249();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE249 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 249 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE250 Property

PANTONE250 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE250 Property

Gets the PANTONE 250 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE250 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE250
C#
public static PDFPantoneColor PANTONE250 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE250();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE250 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 250 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE251 Property

PANTONE251 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE251 Property

Gets the PANTONE 251 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE251 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE251
C#
public static PDFPantoneColor PANTONE251 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE251();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE251 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 251 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE252 Property

PANTONE252 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE252 Property

Gets the PANTONE 252 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE252 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE252
C#
public static PDFPantoneColor PANTONE252 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE252();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE252 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 252 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE253 Property

PANTONE253 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE253 Property

Gets the PANTONE 253 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE253 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE253
C#
public static PDFPantoneColor PANTONE253 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE253();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE253 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 253 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE254 Property

PANTONE254 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE254 Property

Gets the PANTONE 254 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE254 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE254
C#
public static PDFPantoneColor PANTONE254 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE254();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE254 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 254 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE255 Property

PANTONE255 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE255 Property

Gets the PANTONE 255 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE255 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE255
C#
public static PDFPantoneColor PANTONE255 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE255();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE255 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 255 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE256 Property

PANTONE256 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE256 Property

Gets the PANTONE 256 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE256 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE256
C#
public static PDFPantoneColor PANTONE256 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE256();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE256 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 256 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2562 Property

PANTONE2562 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2562 Property

Gets the PANTONE 2562 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2562 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2562
C#
public static PDFPantoneColor PANTONE2562 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2562();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2562 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2562 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2563 Property

PANTONE2563 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2563 Property

Gets the PANTONE 2563 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2563 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2563
C#
public static PDFPantoneColor PANTONE2563 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2563();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2563 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2563 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2567 Property

PANTONE2567 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2567 Property

Gets the PANTONE 2567 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2567 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2567
C#
public static PDFPantoneColor PANTONE2567 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2567();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2567 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2567 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE257 Property

PANTONE257 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE257 Property

Gets the PANTONE 257 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE257 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE257
C#
public static PDFPantoneColor PANTONE257 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE257();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE257 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 257 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2572 Property

PANTONE2572 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2572 Property

Gets the PANTONE 2572 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2572 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2572
C#
public static PDFPantoneColor PANTONE2572 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2572();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2572 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2572 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2573 Property

PANTONE2573 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2573 Property

Gets the PANTONE 2573 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2573 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2573
C#
public static PDFPantoneColor PANTONE2573 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2573();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2573 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2573 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2577 Property

PANTONE2577 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2577 Property

Gets the PANTONE 2577 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2577 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2577
C#
public static PDFPantoneColor PANTONE2577 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2577();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2577 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2577 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE258 Property

PANTONE258 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE258 Property

Gets the PANTONE 258 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE258 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE258
C#
public static PDFPantoneColor PANTONE258 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE258();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE258 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 258 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2582 Property

PANTONE2582 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2582 Property

Gets the PANTONE 2582 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2582 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2582
C#
public static PDFPantoneColor PANTONE2582 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2582();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2582 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2582 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2583 Property

PANTONE2583 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2583 Property

Gets the PANTONE 2583 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2583 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2583
C#
public static PDFPantoneColor PANTONE2583 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2583();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2583 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2583 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2587 Property

PANTONE2587 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2587 Property

Gets the PANTONE 2587 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2587 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2587
C#
public static PDFPantoneColor PANTONE2587 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2587();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2587 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2587 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE259 Property

PANTONE259 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE259 Property

Gets the PANTONE 259 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE259 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE259
C#
public static PDFPantoneColor PANTONE259 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE259();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE259 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 259 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2592 Property

PANTONE2592 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2592 Property

Gets the PANTONE 2592 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2592 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2592
C#
public static PDFPantoneColor PANTONE2592 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2592();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2592 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2592 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2593 Property

PANTONE2593 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2593 Property

Gets the PANTONE 2593 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2593 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2593
C#
public static PDFPantoneColor PANTONE2593 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2593();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2593 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2593 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2597 Property

PANTONE2597 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2597 Property

Gets the PANTONE 2597 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2597 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2597
C#
public static PDFPantoneColor PANTONE2597 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2597();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2597 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2597 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE260 Property

PANTONE260 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE260 Property

Gets the PANTONE 260 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE260 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE260
C#
public static PDFPantoneColor PANTONE260 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE260();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE260 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 260 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2602 Property

PANTONE2602 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2602 Property

Gets the PANTONE 2602 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2602 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2602
C#
public static PDFPantoneColor PANTONE2602 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2602();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2602 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2602 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2603 Property

PANTONE2603 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2603 Property

Gets the PANTONE 2603 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2603 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2603
C#
public static PDFPantoneColor PANTONE2603 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2603();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2603 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2603 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2607 Property

PANTONE2607 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2607 Property

Gets the PANTONE 2607 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2607 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2607
C#
public static PDFPantoneColor PANTONE2607 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2607();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2607 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2607 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE261 Property

PANTONE261 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE261 Property

Gets the PANTONE 261 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE261 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE261
C#
public static PDFPantoneColor PANTONE261 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE261();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE261 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 261 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2612 Property

PANTONE2612 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2612 Property

Gets the PANTONE 2612 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2612 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2612
C#
public static PDFPantoneColor PANTONE2612 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2612();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2612 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2612 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2613 Property

PANTONE2613 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2613 Property

Gets the PANTONE 2613 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2613 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2613
C#
public static PDFPantoneColor PANTONE2613 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2613();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2613 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2613 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2617 Property

PANTONE2617 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2617 Property

Gets the PANTONE 2617 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2617 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2617
C#
public static PDFPantoneColor PANTONE2617 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2617();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2617 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2617 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE262 Property

PANTONE262 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE262 Property

Gets the PANTONE 262 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE262 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE262
C#
public static PDFPantoneColor PANTONE262 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE262();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE262 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 262 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2622 Property

PANTONE2622 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2622 Property

Gets the PANTONE 2622 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2622 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2622
C#
public static PDFPantoneColor PANTONE2622 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2622();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2622 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2622 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2623 Property

PANTONE2623 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2623 Property

Gets the PANTONE 2623 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2623 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2623
C#
public static PDFPantoneColor PANTONE2623 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2623();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2623 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2623 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2627 Property

PANTONE2627 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2627 Property

Gets the PANTONE 2627 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2627 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2627
C#
public static PDFPantoneColor PANTONE2627 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2627();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2627 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2627 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE263 Property

PANTONE263 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE263 Property

Gets the PANTONE 263 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE263 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE263
C#
public static PDFPantoneColor PANTONE263 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE263();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE263 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 263 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2635 Property

PANTONE2635 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2635 Property

Gets the PANTONE 2635 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2635 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2635
C#
public static PDFPantoneColor PANTONE2635 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2635();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2635 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2635 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE264 Property

PANTONE264 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE264 Property

Gets the PANTONE 264 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE264 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE264
C#
public static PDFPantoneColor PANTONE264 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE264();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE264 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 264 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2645 Property

PANTONE2645 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2645 Property

Gets the PANTONE 2645 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2645 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2645
C#
public static PDFPantoneColor PANTONE2645 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2645();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2645 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2645 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE265 Property

PANTONE265 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE265 Property

Gets the PANTONE 265 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE265 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE265
C#
public static PDFPantoneColor PANTONE265 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE265();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE265 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 265 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2655 Property

PANTONE2655 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2655 Property

Gets the PANTONE 2655 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2655 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2655
C#
public static PDFPantoneColor PANTONE2655 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2655();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2655 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2655 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE266 Property

PANTONE266 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE266 Property

Gets the PANTONE 266 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE266 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE266
C#
public static PDFPantoneColor PANTONE266 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE266();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE266 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 266 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2665 Property

PANTONE2665 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2665 Property

Gets the PANTONE 2665 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2665 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2665
C#
public static PDFPantoneColor PANTONE2665 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2665();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2665 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2665 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE267 Property

PANTONE267 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE267 Property

Gets the PANTONE 267 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE267 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE267
C#
public static PDFPantoneColor PANTONE267 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE267();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE267 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 267 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE268 Property

PANTONE268 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE268 Property

Gets the PANTONE 268 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE268 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE268
C#
public static PDFPantoneColor PANTONE268 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE268();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE268 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 268 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2685 Property

PANTONE2685 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2685 Property

Gets the PANTONE 2685 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2685 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2685
C#
public static PDFPantoneColor PANTONE2685 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2685();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2685 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2685 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE269 Property

PANTONE269 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE269 Property

Gets the PANTONE 269 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE269 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE269
C#
public static PDFPantoneColor PANTONE269 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE269();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE269 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 269 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2695 Property

PANTONE2695 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2695 Property

Gets the PANTONE 2695 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2695 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2695
C#
public static PDFPantoneColor PANTONE2695 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2695();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2695 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2695 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE270 Property

PANTONE270 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE270 Property

Gets the PANTONE 270 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE270 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE270
C#
public static PDFPantoneColor PANTONE270 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE270();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE270 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 270 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2705 Property

PANTONE2705 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2705 Property

Gets the PANTONE 2705 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2705 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2705
C#
public static PDFPantoneColor PANTONE2705 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2705();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2705 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2705 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2706 Property

PANTONE2706 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2706 Property

Gets the PANTONE 2706 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2706 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2706
C#
public static PDFPantoneColor PANTONE2706 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2706();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2706 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2706 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2707 Property

PANTONE2707 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2707 Property

Gets the PANTONE 2707 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2707 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2707
C#
public static PDFPantoneColor PANTONE2707 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2707();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2707 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2707 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2708 Property

PANTONE2708 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2708 Property

Gets the PANTONE 2708 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2708 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2708
C#
public static PDFPantoneColor PANTONE2708 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2708();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2708 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2708 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE271 Property

PANTONE271 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE271 Property

Gets the PANTONE 271 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE271 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE271
C#
public static PDFPantoneColor PANTONE271 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE271();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE271 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 271 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2715 Property

PANTONE2715 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2715 Property

Gets the PANTONE 2715 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2715 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2715
C#
public static PDFPantoneColor PANTONE2715 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2715();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2715 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2715 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2716 Property

PANTONE2716 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2716 Property

Gets the PANTONE 2716 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2716 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2716
C#
public static PDFPantoneColor PANTONE2716 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2716();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2716 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2716 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2717 Property

PANTONE2717 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2717 Property

Gets the PANTONE 2717 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2717 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2717
C#
public static PDFPantoneColor PANTONE2717 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2717();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2717 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2717 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2718 Property

PANTONE2718 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2718 Property

Gets the PANTONE 2718 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2718 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2718
C#
public static PDFPantoneColor PANTONE2718 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2718();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2718 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2718 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE272 Property

PANTONE272 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE272 Property

Gets the PANTONE 272 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE272 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE272
C#
public static PDFPantoneColor PANTONE272 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE272();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE272 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 272 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2725 Property

PANTONE2725 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2725 Property

Gets the PANTONE 2725 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2725 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2725
C#
public static PDFPantoneColor PANTONE2725 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2725();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2725 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2725 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2726 Property

PANTONE2726 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2726 Property

Gets the PANTONE 2726 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2726 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2726
C#
public static PDFPantoneColor PANTONE2726 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2726();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2726 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2726 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2727 Property

PANTONE2727 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2727 Property

Gets the PANTONE 2727 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2727 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2727
C#
public static PDFPantoneColor PANTONE2727 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2727();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2727 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2727 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2728 Property

PANTONE2728 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2728 Property

Gets the PANTONE 2728 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2728 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2728
C#
public static PDFPantoneColor PANTONE2728 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2728();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2728 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2728 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE273 Property

PANTONE273 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE273 Property

Gets the PANTONE 273 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE273 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE273
C#
public static PDFPantoneColor PANTONE273 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE273();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE273 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 273 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2735 Property

PANTONE2735 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2735 Property

Gets the PANTONE 2735 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2735 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2735
C#
public static PDFPantoneColor PANTONE2735 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2735();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2735 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2735 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2736 Property

PANTONE2736 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2736 Property

Gets the PANTONE 2736 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2736 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2736
C#
public static PDFPantoneColor PANTONE2736 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2736();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2736 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2736 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2738 Property

PANTONE2738 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2738 Property

Gets the PANTONE 2738 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2738 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2738
C#
public static PDFPantoneColor PANTONE2738 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2738();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2738 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2738 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE274 Property

PANTONE274 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE274 Property

Gets the PANTONE 274 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE274 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE274
C#
public static PDFPantoneColor PANTONE274 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE274();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE274 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 274 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2745 Property

PANTONE2745 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2745 Property

Gets the PANTONE 2745 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2745 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2745
C#
public static PDFPantoneColor PANTONE2745 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2745();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2745 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2745 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2746 Property

PANTONE2746 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2746 Property

Gets the PANTONE 2746 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2746 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2746
C#
public static PDFPantoneColor PANTONE2746 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2746();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2746 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2746 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2747 Property

PANTONE2747 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2747 Property

Gets the PANTONE 2747 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2747 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2747
C#
public static PDFPantoneColor PANTONE2747 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2747();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2747 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2747 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2748 Property

PANTONE2748 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2748 Property

Gets the PANTONE 2748 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2748 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2748
C#
public static PDFPantoneColor PANTONE2748 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2748();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2748 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2748 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE275 Property

PANTONE275 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE275 Property

Gets the PANTONE 275 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE275 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE275
C#
public static PDFPantoneColor PANTONE275 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE275();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE275 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 275 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2755 Property

PANTONE2755 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2755 Property

Gets the PANTONE 2755 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2755 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2755
C#
public static PDFPantoneColor PANTONE2755 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2755();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2755 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2755 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2756 Property

PANTONE2756 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2756 Property

Gets the PANTONE 2756 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2756 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2756
C#
public static PDFPantoneColor PANTONE2756 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2756();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2756 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2756 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2757 Property

PANTONE2757 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2757 Property

Gets the PANTONE 2757 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2757 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2757
C#
public static PDFPantoneColor PANTONE2757 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2757();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2757 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2757 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2758 Property

PANTONE2758 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2758 Property

Gets the PANTONE 2758 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2758 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2758
C#
public static PDFPantoneColor PANTONE2758 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2758();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2758 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2758 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE276 Property

PANTONE276 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE276 Property

Gets the PANTONE 276 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE276 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE276
C#
public static PDFPantoneColor PANTONE276 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE276();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE276 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 276 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2765 Property

PANTONE2765 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2765 Property

Gets the PANTONE 2765 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2765 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2765
C#
public static PDFPantoneColor PANTONE2765 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2765();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2765 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2765 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2766 Property

PANTONE2766 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2766 Property

Gets the PANTONE 2766 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2766 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2766
C#
public static PDFPantoneColor PANTONE2766 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2766();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2766 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2766 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2767 Property

PANTONE2767 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2767 Property

Gets the PANTONE 2767 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2767 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2767
C#
public static PDFPantoneColor PANTONE2767 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2767();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2767 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2767 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2768 Property

PANTONE2768 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2768 Property

Gets the PANTONE 2768 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2768 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2768
C#
public static PDFPantoneColor PANTONE2768 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2768();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2768 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2768 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE277 Property

PANTONE277 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE277 Property

Gets the PANTONE 277 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE277 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE277
C#
public static PDFPantoneColor PANTONE277 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE277();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE277 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 277 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE278 Property

PANTONE278 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE278 Property

Gets the PANTONE 278 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE278 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE278
C#
public static PDFPantoneColor PANTONE278 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE278();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE278 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 278 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE279 Property

PANTONE279 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE279 Property

Gets the PANTONE 279 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE279 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE279
C#
public static PDFPantoneColor PANTONE279 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE279();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE279 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 279 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE280 Property

PANTONE280 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE280 Property

Gets the PANTONE 280 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE280 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE280
C#
public static PDFPantoneColor PANTONE280 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE280();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE280 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 280 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE281 Property

PANTONE281 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE281 Property

Gets the PANTONE 281 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE281 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE281
C#
public static PDFPantoneColor PANTONE281 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE281();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE281 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 281 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE282 Property

PANTONE282 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE282 Property

Gets the PANTONE 282 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE282 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE282
C#
public static PDFPantoneColor PANTONE282 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE282();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE282 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 282 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE283 Property

PANTONE283 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE283 Property

Gets the PANTONE 283 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE283 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE283
C#
public static PDFPantoneColor PANTONE283 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE283();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE283 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 283 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE284 Property

PANTONE284 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE284 Property

Gets the PANTONE 284 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE284 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE284
C#
public static PDFPantoneColor PANTONE284 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE284();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE284 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 284 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE285 Property

PANTONE285 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE285 Property

Gets the PANTONE 285 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE285 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE285
C#
public static PDFPantoneColor PANTONE285 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE285();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE285 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 285 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE286 Property

PANTONE286 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE286 Property

Gets the PANTONE 286 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE286 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE286
C#
public static PDFPantoneColor PANTONE286 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE286();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE286 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 286 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE287 Property

PANTONE287 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE287 Property

Gets the PANTONE 287 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE287 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE287
C#
public static PDFPantoneColor PANTONE287 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE287();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE287 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 287 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE288 Property

PANTONE288 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE288 Property

Gets the PANTONE 288 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE288 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE288
C#
public static PDFPantoneColor PANTONE288 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE288();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE288 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 288 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE289 Property

PANTONE289 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE289 Property

Gets the PANTONE 289 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE289 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE289
C#
public static PDFPantoneColor PANTONE289 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE289();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE289 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 289 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE290 Property

PANTONE290 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE290 Property

Gets the PANTONE 290 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE290 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE290
C#
public static PDFPantoneColor PANTONE290 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE290();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE290 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 290 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2905 Property

PANTONE2905 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2905 Property

Gets the PANTONE 2905 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2905 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2905
C#
public static PDFPantoneColor PANTONE2905 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2905();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2905 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2905 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE291 Property

PANTONE291 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE291 Property

Gets the PANTONE 291 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE291 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE291
C#
public static PDFPantoneColor PANTONE291 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE291();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE291 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 291 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2915 Property

PANTONE2915 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2915 Property

Gets the PANTONE 2915 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2915 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2915
C#
public static PDFPantoneColor PANTONE2915 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2915();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2915 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2915 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE292 Property

PANTONE292 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE292 Property

Gets the PANTONE 292 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE292 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE292
C#
public static PDFPantoneColor PANTONE292 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE292();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE292 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 292 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2925 Property

PANTONE2925 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2925 Property

Gets the PANTONE 2925 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2925 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2925
C#
public static PDFPantoneColor PANTONE2925 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2925();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2925 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2925 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE293 Property

PANTONE293 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE293 Property

Gets the PANTONE 293 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE293 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE293
C#
public static PDFPantoneColor PANTONE293 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE293();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE293 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 293 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2935 Property

PANTONE2935 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2935 Property

Gets the PANTONE 2935 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2935 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2935
C#
public static PDFPantoneColor PANTONE2935 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2935();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2935 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2935 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE294 Property

PANTONE294 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE294 Property

Gets the PANTONE 294 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE294 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE294
C#
public static PDFPantoneColor PANTONE294 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE294();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE294 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 294 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2945 Property

PANTONE2945 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2945 Property

Gets the PANTONE 2945 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2945 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2945
C#
public static PDFPantoneColor PANTONE2945 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2945();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2945 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2945 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE295 Property

PANTONE295 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE295 Property

Gets the PANTONE 295 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE295 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE295
C#
public static PDFPantoneColor PANTONE295 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE295();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE295 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 295 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2955 Property

PANTONE2955 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2955 Property

Gets the PANTONE 2955 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2955 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2955
C#
public static PDFPantoneColor PANTONE2955 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2955();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2955 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2955 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE296 Property

PANTONE296 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE296 Property

Gets the PANTONE 296 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE296 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE296
C#
public static PDFPantoneColor PANTONE296 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE296();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE296 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 296 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2965 Property

PANTONE2965 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2965 Property

Gets the PANTONE 2965 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2965 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2965
C#
public static PDFPantoneColor PANTONE2965 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2965();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2965 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2965 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE297 Property

PANTONE297 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE297 Property

Gets the PANTONE 297 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE297 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE297
C#
public static PDFPantoneColor PANTONE297 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE297();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE297 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 297 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2975 Property

PANTONE2975 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2975 Property

Gets the PANTONE 2975 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2975 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2975
C#
public static PDFPantoneColor PANTONE2975 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2975();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2975 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2975 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE298 Property

PANTONE298 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE298 Property

Gets the PANTONE 298 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE298 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE298
C#
public static PDFPantoneColor PANTONE298 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE298();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE298 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 298 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2985 Property

PANTONE2985 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2985 Property

Gets the PANTONE 2985 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2985 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2985
C#
public static PDFPantoneColor PANTONE2985 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2985();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2985 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2985 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE299 Property

PANTONE299 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE299 Property

Gets the PANTONE 299 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE299 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE299
C#
public static PDFPantoneColor PANTONE299 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE299();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE299 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 299 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE2995 Property

PANTONE2995 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE2995 Property

Gets the PANTONE 2995 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE2995 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE2995
C#
public static PDFPantoneColor PANTONE2995 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE2995();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE2995 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 2995 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE300 Property

PANTONE300 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE300 Property

Gets the PANTONE 300 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE300 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE300
C#
public static PDFPantoneColor PANTONE300 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE300();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE300 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 300 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3005 Property

PANTONE3005 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3005 Property

Gets the PANTONE 3005 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3005 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3005
C#
public static PDFPantoneColor PANTONE3005 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3005();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3005 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3005 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE301 Property

PANTONE301 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE301 Property

Gets the PANTONE 301 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE301 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE301
C#
public static PDFPantoneColor PANTONE301 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE301();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE301 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 301 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3015 Property

PANTONE3015 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3015 Property

Gets the PANTONE 3015 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3015 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3015
C#
public static PDFPantoneColor PANTONE3015 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3015();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3015 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3015 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE302 Property

PANTONE302 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE302 Property

Gets the PANTONE 302 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE302 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE302
C#
public static PDFPantoneColor PANTONE302 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE302();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE302 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 302 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3025 Property

PANTONE3025 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3025 Property

Gets the PANTONE 3025 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3025 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3025
C#
public static PDFPantoneColor PANTONE3025 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3025();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3025 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3025 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE303 Property

PANTONE303 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE303 Property

Gets the PANTONE 303 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE303 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE303
C#
public static PDFPantoneColor PANTONE303 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE303();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE303 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 303 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3035 Property

PANTONE3035 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3035 Property

Gets the PANTONE 3035 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3035 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3035
C#
public static PDFPantoneColor PANTONE3035 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3035();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3035 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3035 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE304 Property

PANTONE304 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE304 Property

Gets the PANTONE 304 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE304 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE304
C#
public static PDFPantoneColor PANTONE304 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE304();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE304 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 304 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE305 Property

PANTONE305 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE305 Property

Gets the PANTONE 305 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE305 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE305
C#
public static PDFPantoneColor PANTONE305 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE305();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE305 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 305 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE306 Property

PANTONE306 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE306 Property

Gets the PANTONE 306 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE306 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE306
C#
public static PDFPantoneColor PANTONE306 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE306();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE306 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 306 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE307 Property

PANTONE307 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE307 Property

Gets the PANTONE 307 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE307 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE307
C#
public static PDFPantoneColor PANTONE307 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE307();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE307 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 307 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE308 Property

PANTONE308 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE308 Property

Gets the PANTONE 308 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE308 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE308
C#
public static PDFPantoneColor PANTONE308 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE308();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE308 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 308 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE309 Property

PANTONE309 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE309 Property

Gets the PANTONE 309 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE309 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE309
C#
public static PDFPantoneColor PANTONE309 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE309();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE309 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 309 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE310 Property

PANTONE310 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE310 Property

Gets the PANTONE 310 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE310 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE310
C#
public static PDFPantoneColor PANTONE310 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE310();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE310 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 310 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3105 Property

PANTONE3105 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3105 Property

Gets the PANTONE 3105 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3105 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3105
C#
public static PDFPantoneColor PANTONE3105 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3105();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3105 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3105 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE311 Property

PANTONE311 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE311 Property

Gets the PANTONE 311 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE311 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE311
C#
public static PDFPantoneColor PANTONE311 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE311();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE311 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 311 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3115 Property

PANTONE3115 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3115 Property

Gets the PANTONE 3115 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3115 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3115
C#
public static PDFPantoneColor PANTONE3115 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3115();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3115 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3115 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE312 Property

PANTONE312 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE312 Property

Gets the PANTONE 312 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE312 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE312
C#
public static PDFPantoneColor PANTONE312 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE312();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE312 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 312 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3125 Property

PANTONE3125 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3125 Property

Gets the PANTONE 3125 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3125 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3125
C#
public static PDFPantoneColor PANTONE3125 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3125();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3125 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3125 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE313 Property

PANTONE313 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE313 Property

Gets the PANTONE 313 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE313 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE313
C#
public static PDFPantoneColor PANTONE313 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE313();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE313 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 313 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3135 Property

PANTONE3135 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3135 Property

Gets the PANTONE 3135 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3135 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3135
C#
public static PDFPantoneColor PANTONE3135 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3135();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3135 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3135 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE314 Property

PANTONE314 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE314 Property

Gets the PANTONE 314 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE314 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE314
C#
public static PDFPantoneColor PANTONE314 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE314();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE314 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 314 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3145 Property

PANTONE3145 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3145 Property

Gets the PANTONE 3145 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3145 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3145
C#
public static PDFPantoneColor PANTONE3145 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3145();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3145 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3145 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE315 Property

PANTONE315 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE315 Property

Gets the PANTONE 315 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE315 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE315
C#
public static PDFPantoneColor PANTONE315 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE315();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE315 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 315 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3155 Property

PANTONE3155 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3155 Property

Gets the PANTONE 3155 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3155 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3155
C#
public static PDFPantoneColor PANTONE3155 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3155();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3155 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3155 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE316 Property

PANTONE316 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE316 Property

Gets the PANTONE 316 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE316 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE316
C#
public static PDFPantoneColor PANTONE316 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE316();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE316 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 316 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3165 Property

PANTONE3165 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3165 Property

Gets the PANTONE 3165 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3165 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3165
C#
public static PDFPantoneColor PANTONE3165 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3165();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3165 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3165 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE317 Property

PANTONE317 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE317 Property

Gets the PANTONE 317 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE317 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE317
C#
public static PDFPantoneColor PANTONE317 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE317();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE317 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 317 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE318 Property

PANTONE318 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE318 Property

Gets the PANTONE 318 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE318 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE318
C#
public static PDFPantoneColor PANTONE318 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE318();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE318 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 318 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE319 Property

PANTONE319 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE319 Property

Gets the PANTONE 319 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE319 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE319
C#
public static PDFPantoneColor PANTONE319 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE319();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE319 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 319 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE320 Property

PANTONE320 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE320 Property

Gets the PANTONE 320 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE320 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE320
C#
public static PDFPantoneColor PANTONE320 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE320();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE320 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 320 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE321 Property

PANTONE321 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE321 Property

Gets the PANTONE 321 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE321 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE321
C#
public static PDFPantoneColor PANTONE321 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE321();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE321 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 321 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE322 Property

PANTONE322 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE322 Property

Gets the PANTONE 322 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE322 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE322
C#
public static PDFPantoneColor PANTONE322 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE322();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE322 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 322 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE323 Property

PANTONE323 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE323 Property

Gets the PANTONE 323 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE323 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE323
C#
public static PDFPantoneColor PANTONE323 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE323();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE323 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 323 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE324 Property

PANTONE324 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE324 Property

Gets the PANTONE 324 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE324 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE324
C#
public static PDFPantoneColor PANTONE324 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE324();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE324 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 324 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3242 Property

PANTONE3242 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3242 Property

Gets the PANTONE 3242 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3242 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3242
C#
public static PDFPantoneColor PANTONE3242 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3242();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3242 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3242 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3245 Property

PANTONE3245 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3245 Property

Gets the PANTONE 3245 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3245 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3245
C#
public static PDFPantoneColor PANTONE3245 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3245();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3245 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3245 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3248 Property

PANTONE3248 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3248 Property

Gets the PANTONE 3248 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3248 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3248
C#
public static PDFPantoneColor PANTONE3248 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3248();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3248 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3248 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE325 Property

PANTONE325 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE325 Property

Gets the PANTONE 325 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE325 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE325
C#
public static PDFPantoneColor PANTONE325 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE325();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE325 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 325 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3252 Property

PANTONE3252 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3252 Property

Gets the PANTONE 3252 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3252 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3252
C#
public static PDFPantoneColor PANTONE3252 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3252();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3252 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3252 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3255 Property

PANTONE3255 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3255 Property

Gets the PANTONE 3255 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3255 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3255
C#
public static PDFPantoneColor PANTONE3255 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3255();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3255 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3255 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3258 Property

PANTONE3258 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3258 Property

Gets the PANTONE 3258 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3258 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3258
C#
public static PDFPantoneColor PANTONE3258 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3258();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3258 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3258 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE326 Property

PANTONE326 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE326 Property

Gets the PANTONE 326 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE326 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE326
C#
public static PDFPantoneColor PANTONE326 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE326();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE326 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 326 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3262 Property

PANTONE3262 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3262 Property

Gets the PANTONE 3262 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3262 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3262
C#
public static PDFPantoneColor PANTONE3262 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3262();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3262 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3262 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3265 Property

PANTONE3265 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3265 Property

Gets the PANTONE 3265 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3265 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3265
C#
public static PDFPantoneColor PANTONE3265 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3265();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3265 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3265 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3268 Property

PANTONE3268 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3268 Property

Gets the PANTONE 3268 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3268 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3268
C#
public static PDFPantoneColor PANTONE3268 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3268();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3268 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3268 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE327 Property

PANTONE327 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE327 Property

Gets the PANTONE 327 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE327 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE327
C#
public static PDFPantoneColor PANTONE327 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE327();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE327 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 327 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3272 Property

PANTONE3272 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3272 Property

Gets the PANTONE 3272 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3272 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3272
C#
public static PDFPantoneColor PANTONE3272 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3272();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3272 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3272 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3275 Property

PANTONE3275 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3275 Property

Gets the PANTONE 3275 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3275 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3275
C#
public static PDFPantoneColor PANTONE3275 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3275();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3275 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3275 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3278 Property

PANTONE3278 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3278 Property

Gets the PANTONE 3278 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3278 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3278
C#
public static PDFPantoneColor PANTONE3278 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3278();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3278 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3278 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE328 Property

PANTONE328 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE328 Property

Gets the PANTONE 328 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE328 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE328
C#
public static PDFPantoneColor PANTONE328 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE328();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE328 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 328 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3282 Property

PANTONE3282 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3282 Property

Gets the PANTONE 3282 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3282 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3282
C#
public static PDFPantoneColor PANTONE3282 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3282();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3282 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3282 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3285 Property

PANTONE3285 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3285 Property

Gets the PANTONE 3285 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3285 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3285
C#
public static PDFPantoneColor PANTONE3285 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3285();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3285 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3285 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3288 Property

PANTONE3288 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3288 Property

Gets the PANTONE 3288 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3288 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3288
C#
public static PDFPantoneColor PANTONE3288 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3288();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3288 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3288 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE329 Property

PANTONE329 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE329 Property

Gets the PANTONE 329 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE329 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE329
C#
public static PDFPantoneColor PANTONE329 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE329();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE329 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 329 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3292 Property

PANTONE3292 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3292 Property

Gets the PANTONE 3292 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3292 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3292
C#
public static PDFPantoneColor PANTONE3292 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3292();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3292 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3292 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3295 Property

PANTONE3295 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3295 Property

Gets the PANTONE 3295 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3295 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3295
C#
public static PDFPantoneColor PANTONE3295 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3295();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3295 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3295 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3298 Property

PANTONE3298 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3298 Property

Gets the PANTONE 3298 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3298 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3298
C#
public static PDFPantoneColor PANTONE3298 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3298();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3298 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3298 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE330 Property

PANTONE330 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE330 Property

Gets the PANTONE 330 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE330 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE330
C#
public static PDFPantoneColor PANTONE330 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE330();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE330 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 330 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3302 Property

PANTONE3302 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3302 Property

Gets the PANTONE 3302 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3302 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3302
C#
public static PDFPantoneColor PANTONE3302 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3302();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3302 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3302 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3305 Property

PANTONE3305 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3305 Property

Gets the PANTONE 3305 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3305 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3305
C#
public static PDFPantoneColor PANTONE3305 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3305();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3305 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3305 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3308 Property

PANTONE3308 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3308 Property

Gets the PANTONE 3308 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3308 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3308
C#
public static PDFPantoneColor PANTONE3308 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3308();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3308 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3308 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE331 Property

PANTONE331 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE331 Property

Gets the PANTONE 331 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE331 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE331
C#
public static PDFPantoneColor PANTONE331 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE331();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE331 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 331 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE332 Property

PANTONE332 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE332 Property

Gets the PANTONE 332 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE332 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE332
C#
public static PDFPantoneColor PANTONE332 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE332();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE332 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 332 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE333 Property

PANTONE333 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE333 Property

Gets the PANTONE 333 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE333 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE333
C#
public static PDFPantoneColor PANTONE333 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE333();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE333 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 333 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE334 Property

PANTONE334 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE334 Property

Gets the PANTONE 334 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE334 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE334
C#
public static PDFPantoneColor PANTONE334 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE334();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE334 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 334 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE335 Property

PANTONE335 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE335 Property

Gets the PANTONE 335 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE335 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE335
C#
public static PDFPantoneColor PANTONE335 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE335();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE335 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 335 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE336 Property

PANTONE336 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE336 Property

Gets the PANTONE 336 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE336 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE336
C#
public static PDFPantoneColor PANTONE336 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE336();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE336 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 336 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE337 Property

PANTONE337 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE337 Property

Gets the PANTONE 337 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE337 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE337
C#
public static PDFPantoneColor PANTONE337 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE337();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE337 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 337 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3375 Property

PANTONE3375 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3375 Property

Gets the PANTONE 3375 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3375 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3375
C#
public static PDFPantoneColor PANTONE3375 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3375();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3375 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3375 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE338 Property

PANTONE338 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE338 Property

Gets the PANTONE 338 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE338 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE338
C#
public static PDFPantoneColor PANTONE338 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE338();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE338 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 338 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3385 Property

PANTONE3385 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3385 Property

Gets the PANTONE 3385 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3385 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3385
C#
public static PDFPantoneColor PANTONE3385 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3385();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3385 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3385 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE339 Property

PANTONE339 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE339 Property

Gets the PANTONE 339 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE339 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE339
C#
public static PDFPantoneColor PANTONE339 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE339();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE339 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 339 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3395 Property

PANTONE3395 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3395 Property

Gets the PANTONE 3395 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3395 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3395
C#
public static PDFPantoneColor PANTONE3395 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3395();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3395 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3395 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE340 Property

PANTONE340 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE340 Property

Gets the PANTONE 340 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE340 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE340
C#
public static PDFPantoneColor PANTONE340 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE340();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE340 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 340 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3405 Property

PANTONE3405 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3405 Property

Gets the PANTONE 3405 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3405 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3405
C#
public static PDFPantoneColor PANTONE3405 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3405();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3405 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3405 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE341 Property

PANTONE341 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE341 Property

Gets the PANTONE 341 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE341 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE341
C#
public static PDFPantoneColor PANTONE341 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE341();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE341 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 341 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3415 Property

PANTONE3415 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3415 Property

Gets the PANTONE 3415 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3415 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3415
C#
public static PDFPantoneColor PANTONE3415 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3415();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3415 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3415 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE342 Property

PANTONE342 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE342 Property

Gets the PANTONE 342 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE342 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE342
C#
public static PDFPantoneColor PANTONE342 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE342();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE342 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 342 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3425 Property

PANTONE3425 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3425 Property

Gets the PANTONE 3425 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3425 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3425
C#
public static PDFPantoneColor PANTONE3425 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3425();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3425 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3425 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE343 Property

PANTONE343 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE343 Property

Gets the PANTONE 343 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE343 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE343
C#
public static PDFPantoneColor PANTONE343 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE343();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE343 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 343 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3435 Property

PANTONE3435 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3435 Property

Gets the PANTONE 3435 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3435 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3435
C#
public static PDFPantoneColor PANTONE3435 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3435();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3435 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3435 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE344 Property

PANTONE344 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE344 Property

Gets the PANTONE 344 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE344 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE344
C#
public static PDFPantoneColor PANTONE344 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE344();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE344 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 344 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE345 Property

PANTONE345 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE345 Property

Gets the PANTONE 345 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE345 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE345
C#
public static PDFPantoneColor PANTONE345 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE345();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE345 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 345 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE346 Property

PANTONE346 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE346 Property

Gets the PANTONE 346 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE346 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE346
C#
public static PDFPantoneColor PANTONE346 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE346();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE346 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 346 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE347 Property

PANTONE347 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE347 Property

Gets the PANTONE 347 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE347 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE347
C#
public static PDFPantoneColor PANTONE347 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE347();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE347 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 347 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE348 Property

PANTONE348 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE348 Property

Gets the PANTONE 348 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE348 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE348
C#
public static PDFPantoneColor PANTONE348 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE348();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE348 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 348 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE349 Property

PANTONE349 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE349 Property

Gets the PANTONE 349 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE349 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE349
C#
public static PDFPantoneColor PANTONE349 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE349();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE349 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 349 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE350 Property

PANTONE350 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE350 Property

Gets the PANTONE 350 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE350 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE350
C#
public static PDFPantoneColor PANTONE350 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE350();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE350 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 350 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE351 Property

PANTONE351 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE351 Property

Gets the PANTONE 351 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE351 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE351
C#
public static PDFPantoneColor PANTONE351 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE351();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE351 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 351 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE352 Property

PANTONE352 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE352 Property

Gets the PANTONE 352 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE352 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE352
C#
public static PDFPantoneColor PANTONE352 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE352();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE352 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 352 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE353 Property

PANTONE353 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE353 Property

Gets the PANTONE 353 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE353 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE353
C#
public static PDFPantoneColor PANTONE353 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE353();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE353 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 353 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE354 Property

PANTONE354 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE354 Property

Gets the PANTONE 354 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE354 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE354
C#
public static PDFPantoneColor PANTONE354 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE354();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE354 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 354 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE355 Property

PANTONE355 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE355 Property

Gets the PANTONE 355 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE355 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE355
C#
public static PDFPantoneColor PANTONE355 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE355();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE355 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 355 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE356 Property

PANTONE356 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE356 Property

Gets the PANTONE 356 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE356 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE356
C#
public static PDFPantoneColor PANTONE356 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE356();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE356 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 356 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE357 Property

PANTONE357 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE357 Property

Gets the PANTONE 357 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE357 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE357
C#
public static PDFPantoneColor PANTONE357 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE357();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE357 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 357 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE358 Property

PANTONE358 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE358 Property

Gets the PANTONE 358 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE358 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE358
C#
public static PDFPantoneColor PANTONE358 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE358();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE358 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 358 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE359 Property

PANTONE359 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE359 Property

Gets the PANTONE 359 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE359 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE359
C#
public static PDFPantoneColor PANTONE359 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE359();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE359 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 359 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE360 Property

PANTONE360 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE360 Property

Gets the PANTONE 360 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE360 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE360
C#
public static PDFPantoneColor PANTONE360 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE360();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE360 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 360 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE361 Property

PANTONE361 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE361 Property

Gets the PANTONE 361 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE361 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE361
C#
public static PDFPantoneColor PANTONE361 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE361();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE361 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 361 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE362 Property

PANTONE362 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE362 Property

Gets the PANTONE 362 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE362 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE362
C#
public static PDFPantoneColor PANTONE362 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE362();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE362 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 362 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE363 Property

PANTONE363 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE363 Property

Gets the PANTONE 363 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE363 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE363
C#
public static PDFPantoneColor PANTONE363 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE363();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE363 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 363 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE364 Property

PANTONE364 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE364 Property

Gets the PANTONE 364 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE364 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE364
C#
public static PDFPantoneColor PANTONE364 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE364();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE364 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 364 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE365 Property

PANTONE365 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE365 Property

Gets the PANTONE 365 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE365 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE365
C#
public static PDFPantoneColor PANTONE365 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE365();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE365 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 365 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE366 Property

PANTONE366 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE366 Property

Gets the PANTONE 366 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE366 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE366
C#
public static PDFPantoneColor PANTONE366 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE366();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE366 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 366 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE367 Property

PANTONE367 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE367 Property

Gets the PANTONE 367 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE367 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE367
C#
public static PDFPantoneColor PANTONE367 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE367();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE367 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 367 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE368 Property

PANTONE368 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE368 Property

Gets the PANTONE 368 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE368 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE368
C#
public static PDFPantoneColor PANTONE368 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE368();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE368 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 368 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE369 Property

PANTONE369 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE369 Property

Gets the PANTONE 369 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE369 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE369
C#
public static PDFPantoneColor PANTONE369 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE369();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE369 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 369 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE370 Property

PANTONE370 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE370 Property

Gets the PANTONE 370 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE370 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE370
C#
public static PDFPantoneColor PANTONE370 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE370();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE370 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 370 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE371 Property

PANTONE371 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE371 Property

Gets the PANTONE 371 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE371 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE371
C#
public static PDFPantoneColor PANTONE371 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE371();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE371 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 371 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE372 Property

PANTONE372 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE372 Property

Gets the PANTONE 372 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE372 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE372
C#
public static PDFPantoneColor PANTONE372 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE372();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE372 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 372 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE373 Property

PANTONE373 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE373 Property

Gets the PANTONE 373 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE373 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE373
C#
public static PDFPantoneColor PANTONE373 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE373();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE373 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 373 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE374 Property

PANTONE374 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE374 Property

Gets the PANTONE 374 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE374 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE374
C#
public static PDFPantoneColor PANTONE374 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE374();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE374 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 374 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE375 Property

PANTONE375 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE375 Property

Gets the PANTONE 375 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE375 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE375
C#
public static PDFPantoneColor PANTONE375 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE375();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE375 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 375 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE376 Property

PANTONE376 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE376 Property

Gets the PANTONE 376 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE376 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE376
C#
public static PDFPantoneColor PANTONE376 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE376();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE376 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 376 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE377 Property

PANTONE377 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE377 Property

Gets the PANTONE 377 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE377 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE377
C#
public static PDFPantoneColor PANTONE377 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE377();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE377 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 377 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE378 Property

PANTONE378 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE378 Property

Gets the PANTONE 378 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE378 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE378
C#
public static PDFPantoneColor PANTONE378 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE378();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE378 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 378 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE379 Property

PANTONE379 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE379 Property

Gets the PANTONE 379 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE379 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE379
C#
public static PDFPantoneColor PANTONE379 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE379();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE379 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 379 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE380 Property

PANTONE380 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE380 Property

Gets the PANTONE 380 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE380 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE380
C#
public static PDFPantoneColor PANTONE380 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE380();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE380 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 380 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE381 Property

PANTONE381 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE381 Property

Gets the PANTONE 381 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE381 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE381
C#
public static PDFPantoneColor PANTONE381 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE381();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE381 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 381 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE382 Property

PANTONE382 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE382 Property

Gets the PANTONE 382 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE382 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE382
C#
public static PDFPantoneColor PANTONE382 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE382();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE382 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 382 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE383 Property

PANTONE383 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE383 Property

Gets the PANTONE 383 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE383 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE383
C#
public static PDFPantoneColor PANTONE383 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE383();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE383 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 383 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE384 Property

PANTONE384 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE384 Property

Gets the PANTONE 384 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE384 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE384
C#
public static PDFPantoneColor PANTONE384 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE384();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE384 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 384 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE385 Property

PANTONE385 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE385 Property

Gets the PANTONE 385 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE385 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE385
C#
public static PDFPantoneColor PANTONE385 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE385();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE385 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 385 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE386 Property

PANTONE386 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE386 Property

Gets the PANTONE 386 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE386 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE386
C#
public static PDFPantoneColor PANTONE386 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE386();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE386 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 386 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE387 Property

PANTONE387 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE387 Property

Gets the PANTONE 387 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE387 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE387
C#
public static PDFPantoneColor PANTONE387 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE387();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE387 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 387 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE388 Property

PANTONE388 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE388 Property

Gets the PANTONE 388 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE388 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE388
C#
public static PDFPantoneColor PANTONE388 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE388();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE388 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 388 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE389 Property

PANTONE389 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE389 Property

Gets the PANTONE 389 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE389 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE389
C#
public static PDFPantoneColor PANTONE389 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE389();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE389 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 389 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE390 Property

PANTONE390 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE390 Property

Gets the PANTONE 390 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE390 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE390
C#
public static PDFPantoneColor PANTONE390 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE390();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE390 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 390 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE391 Property

PANTONE391 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE391 Property

Gets the PANTONE 391 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE391 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE391
C#
public static PDFPantoneColor PANTONE391 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE391();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE391 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 391 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE392 Property

PANTONE392 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE392 Property

Gets the PANTONE 392 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE392 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE392
C#
public static PDFPantoneColor PANTONE392 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE392();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE392 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 392 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE393 Property

PANTONE393 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE393 Property

Gets the PANTONE 393 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE393 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE393
C#
public static PDFPantoneColor PANTONE393 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE393();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE393 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 393 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3935 Property

PANTONE3935 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3935 Property

Gets the PANTONE 3935 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3935 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3935
C#
public static PDFPantoneColor PANTONE3935 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3935();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3935 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3935 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE394 Property

PANTONE394 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE394 Property

Gets the PANTONE 394 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE394 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE394
C#
public static PDFPantoneColor PANTONE394 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE394();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE394 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 394 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3945 Property

PANTONE3945 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3945 Property

Gets the PANTONE 3945 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3945 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3945
C#
public static PDFPantoneColor PANTONE3945 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3945();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3945 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3945 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE395 Property

PANTONE395 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE395 Property

Gets the PANTONE 395 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE395 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE395
C#
public static PDFPantoneColor PANTONE395 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE395();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE395 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 395 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3955 Property

PANTONE3955 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3955 Property

Gets the PANTONE 3955 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3955 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3955
C#
public static PDFPantoneColor PANTONE3955 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3955();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3955 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3955 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE396 Property

PANTONE396 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE396 Property

Gets the PANTONE 396 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE396 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE396
C#
public static PDFPantoneColor PANTONE396 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE396();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE396 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 396 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3965 Property

PANTONE3965 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3965 Property

Gets the PANTONE 3965 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3965 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3965
C#
public static PDFPantoneColor PANTONE3965 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3965();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3965 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3965 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE397 Property

PANTONE397 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE397 Property

Gets the PANTONE 397 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE397 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE397
C#
public static PDFPantoneColor PANTONE397 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE397();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE397 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 397 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3975 Property

PANTONE3975 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3975 Property

Gets the PANTONE 3975 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3975 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3975
C#
public static PDFPantoneColor PANTONE3975 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3975();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3975 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3975 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE398 Property

PANTONE398 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE398 Property

Gets the PANTONE 398 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE398 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE398
C#
public static PDFPantoneColor PANTONE398 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE398();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE398 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 398 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3985 Property

PANTONE3985 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3985 Property

Gets the PANTONE 3985 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3985 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3985
C#
public static PDFPantoneColor PANTONE3985 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3985();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3985 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3985 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE399 Property

PANTONE399 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE399 Property

Gets the PANTONE 399 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE399 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE399
C#
public static PDFPantoneColor PANTONE399 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE399();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE399 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 399 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE3995 Property

PANTONE3995 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE3995 Property

Gets the PANTONE 3995 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE3995 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE3995
C#
public static PDFPantoneColor PANTONE3995 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE3995();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE3995 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 3995 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE400 Property

PANTONE400 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE400 Property

Gets the PANTONE 400 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE400 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE400
C#
public static PDFPantoneColor PANTONE400 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE400();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE400 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 400 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE401 Property

PANTONE401 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE401 Property

Gets the PANTONE 401 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE401 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE401
C#
public static PDFPantoneColor PANTONE401 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE401();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE401 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 401 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE402 Property

PANTONE402 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE402 Property

Gets the PANTONE 402 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE402 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE402
C#
public static PDFPantoneColor PANTONE402 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE402();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE402 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 402 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE403 Property

PANTONE403 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE403 Property

Gets the PANTONE 403 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE403 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE403
C#
public static PDFPantoneColor PANTONE403 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE403();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE403 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 403 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE404 Property

PANTONE404 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE404 Property

Gets the PANTONE 404 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE404 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE404
C#
public static PDFPantoneColor PANTONE404 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE404();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE404 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 404 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE405 Property

PANTONE405 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE405 Property

Gets the PANTONE 405 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE405 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE405
C#
public static PDFPantoneColor PANTONE405 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE405();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE405 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 405 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE406 Property

PANTONE406 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE406 Property

Gets the PANTONE 406 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE406 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE406
C#
public static PDFPantoneColor PANTONE406 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE406();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE406 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 406 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE407 Property

PANTONE407 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE407 Property

Gets the PANTONE 407 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE407 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE407
C#
public static PDFPantoneColor PANTONE407 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE407();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE407 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 407 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE408 Property

PANTONE408 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE408 Property

Gets the PANTONE 408 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE408 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE408
C#
public static PDFPantoneColor PANTONE408 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE408();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE408 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 408 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE409 Property

PANTONE409 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE409 Property

Gets the PANTONE 409 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE409 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE409
C#
public static PDFPantoneColor PANTONE409 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE409();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE409 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 409 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE410 Property

PANTONE410 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE410 Property

Gets the PANTONE 410 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE410 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE410
C#
public static PDFPantoneColor PANTONE410 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE410();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE410 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 410 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE411 Property

PANTONE411 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE411 Property

Gets the PANTONE 411 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE411 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE411
C#
public static PDFPantoneColor PANTONE411 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE411();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE411 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 411 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE412 Property

PANTONE412 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE412 Property

Gets the PANTONE 412 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE412 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE412
C#
public static PDFPantoneColor PANTONE412 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE412();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE412 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 412 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE413 Property

PANTONE413 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE413 Property

Gets the PANTONE 413 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE413 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE413
C#
public static PDFPantoneColor PANTONE413 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE413();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE413 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 413 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE414 Property

PANTONE414 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE414 Property

Gets the PANTONE 414 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE414 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE414
C#
public static PDFPantoneColor PANTONE414 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE414();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE414 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 414 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE415 Property

PANTONE415 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE415 Property

Gets the PANTONE 415 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE415 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE415
C#
public static PDFPantoneColor PANTONE415 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE415();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE415 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 415 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE416 Property

PANTONE416 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE416 Property

Gets the PANTONE 416 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE416 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE416
C#
public static PDFPantoneColor PANTONE416 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE416();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE416 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 416 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE417 Property

PANTONE417 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE417 Property

Gets the PANTONE 417 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE417 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE417
C#
public static PDFPantoneColor PANTONE417 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE417();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE417 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 417 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE418 Property

PANTONE418 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE418 Property

Gets the PANTONE 418 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE418 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE418
C#
public static PDFPantoneColor PANTONE418 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE418();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE418 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 418 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE419 Property

PANTONE419 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE419 Property

Gets the PANTONE 419 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE419 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE419
C#
public static PDFPantoneColor PANTONE419 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE419();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE419 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 419 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE420 Property

PANTONE420 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE420 Property

Gets the PANTONE 420 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE420 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE420
C#
public static PDFPantoneColor PANTONE420 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE420();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE420 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 420 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE421 Property

PANTONE421 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE421 Property

Gets the PANTONE 421 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE421 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE421
C#
public static PDFPantoneColor PANTONE421 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE421();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE421 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 421 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE422 Property

PANTONE422 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE422 Property

Gets the PANTONE 422 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE422 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE422
C#
public static PDFPantoneColor PANTONE422 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE422();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE422 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 422 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE423 Property

PANTONE423 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE423 Property

Gets the PANTONE 423 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE423 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE423
C#
public static PDFPantoneColor PANTONE423 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE423();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE423 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 423 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE424 Property

PANTONE424 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE424 Property

Gets the PANTONE 424 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE424 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE424
C#
public static PDFPantoneColor PANTONE424 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE424();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE424 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 424 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE425 Property

PANTONE425 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE425 Property

Gets the PANTONE 425 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE425 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE425
C#
public static PDFPantoneColor PANTONE425 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE425();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE425 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 425 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE426 Property

PANTONE426 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE426 Property

Gets the PANTONE 426 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE426 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE426
C#
public static PDFPantoneColor PANTONE426 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE426();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE426 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 426 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE427 Property

PANTONE427 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE427 Property

Gets the PANTONE 427 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE427 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE427
C#
public static PDFPantoneColor PANTONE427 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE427();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE427 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 427 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE428 Property

PANTONE428 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE428 Property

Gets the PANTONE 428 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE428 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE428
C#
public static PDFPantoneColor PANTONE428 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE428();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE428 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 428 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE429 Property

PANTONE429 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE429 Property

Gets the PANTONE 429 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE429 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE429
C#
public static PDFPantoneColor PANTONE429 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE429();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE429 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 429 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE430 Property

PANTONE430 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE430 Property

Gets the PANTONE 430 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE430 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE430
C#
public static PDFPantoneColor PANTONE430 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE430();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE430 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 430 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE431 Property

PANTONE431 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE431 Property

Gets the PANTONE 431 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE431 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE431
C#
public static PDFPantoneColor PANTONE431 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE431();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE431 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 431 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE432 Property

PANTONE432 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE432 Property

Gets the PANTONE 432 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE432 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE432
C#
public static PDFPantoneColor PANTONE432 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE432();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE432 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 432 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE433 Property

PANTONE433 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE433 Property

Gets the PANTONE 433 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE433 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE433
C#
public static PDFPantoneColor PANTONE433 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE433();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE433 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 433 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE434 Property

PANTONE434 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE434 Property

Gets the PANTONE 434 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE434 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE434
C#
public static PDFPantoneColor PANTONE434 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE434();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE434 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 434 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE435 Property

PANTONE435 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE435 Property

Gets the PANTONE 435 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE435 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE435
C#
public static PDFPantoneColor PANTONE435 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE435();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE435 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 435 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE436 Property

PANTONE436 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE436 Property

Gets the PANTONE 436 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE436 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE436
C#
public static PDFPantoneColor PANTONE436 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE436();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE436 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 436 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE437 Property

PANTONE437 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE437 Property

Gets the PANTONE 437 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE437 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE437
C#
public static PDFPantoneColor PANTONE437 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE437();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE437 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 437 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE438 Property

PANTONE438 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE438 Property

Gets the PANTONE 438 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE438 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE438
C#
public static PDFPantoneColor PANTONE438 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE438();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE438 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 438 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE439 Property

PANTONE439 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE439 Property

Gets the PANTONE 439 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE439 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE439
C#
public static PDFPantoneColor PANTONE439 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE439();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE439 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 439 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE440 Property

PANTONE440 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE440 Property

Gets the PANTONE 440 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE440 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE440
C#
public static PDFPantoneColor PANTONE440 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE440();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE440 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 440 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE441 Property

PANTONE441 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE441 Property

Gets the PANTONE 441 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE441 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE441
C#
public static PDFPantoneColor PANTONE441 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE441();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE441 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 441 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE442 Property

PANTONE442 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE442 Property

Gets the PANTONE 442 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE442 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE442
C#
public static PDFPantoneColor PANTONE442 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE442();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE442 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 442 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE443 Property

PANTONE443 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE443 Property

Gets the PANTONE 443 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE443 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE443
C#
public static PDFPantoneColor PANTONE443 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE443();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE443 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 443 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE444 Property

PANTONE444 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE444 Property

Gets the PANTONE 444 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE444 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE444
C#
public static PDFPantoneColor PANTONE444 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE444();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE444 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 444 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE445 Property

PANTONE445 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE445 Property

Gets the PANTONE 445 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE445 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE445
C#
public static PDFPantoneColor PANTONE445 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE445();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE445 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 445 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE446 Property

PANTONE446 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE446 Property

Gets the PANTONE 446 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE446 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE446
C#
public static PDFPantoneColor PANTONE446 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE446();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE446 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 446 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE447 Property

PANTONE447 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE447 Property

Gets the PANTONE 447 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE447 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE447
C#
public static PDFPantoneColor PANTONE447 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE447();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE447 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 447 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE448 Property

PANTONE448 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE448 Property

Gets the PANTONE 448 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE448 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE448
C#
public static PDFPantoneColor PANTONE448 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE448();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE448 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 448 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4485 Property

PANTONE4485 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4485 Property

Gets the PANTONE 4485 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4485 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4485
C#
public static PDFPantoneColor PANTONE4485 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4485();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4485 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4485 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE449 Property

PANTONE449 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE449 Property

Gets the PANTONE 449 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE449 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE449
C#
public static PDFPantoneColor PANTONE449 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE449();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE449 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 449 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4495 Property

PANTONE4495 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4495 Property

Gets the PANTONE 4495 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4495 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4495
C#
public static PDFPantoneColor PANTONE4495 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4495();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4495 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4495 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE450 Property

PANTONE450 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE450 Property

Gets the PANTONE 450 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE450 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE450
C#
public static PDFPantoneColor PANTONE450 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE450();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE450 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 450 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4505 Property

PANTONE4505 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4505 Property

Gets the PANTONE 4505 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4505 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4505
C#
public static PDFPantoneColor PANTONE4505 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4505();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4505 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4505 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE451 Property

PANTONE451 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE451 Property

Gets the PANTONE 451 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE451 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE451
C#
public static PDFPantoneColor PANTONE451 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE451();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE451 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 451 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4515 Property

PANTONE4515 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4515 Property

Gets the PANTONE 4515 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4515 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4515
C#
public static PDFPantoneColor PANTONE4515 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4515();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4515 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4515 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE452 Property

PANTONE452 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE452 Property

Gets the PANTONE 452 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE452 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE452
C#
public static PDFPantoneColor PANTONE452 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE452();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE452 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 452 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4525 Property

PANTONE4525 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4525 Property

Gets the PANTONE 4525 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4525 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4525
C#
public static PDFPantoneColor PANTONE4525 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4525();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4525 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4525 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE453 Property

PANTONE453 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE453 Property

Gets the PANTONE 453 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE453 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE453
C#
public static PDFPantoneColor PANTONE453 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE453();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE453 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 453 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4535 Property

PANTONE4535 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4535 Property

Gets the PANTONE 4535 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4535 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4535
C#
public static PDFPantoneColor PANTONE4535 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4535();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4535 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4535 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE454 Property

PANTONE454 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE454 Property

Gets the PANTONE 454 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE454 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE454
C#
public static PDFPantoneColor PANTONE454 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE454();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE454 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 454 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4545 Property

PANTONE4545 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4545 Property

Gets the PANTONE 4545 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4545 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4545
C#
public static PDFPantoneColor PANTONE4545 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4545();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4545 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4545 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE455 Property

PANTONE455 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE455 Property

Gets the PANTONE 455 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE455 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE455
C#
public static PDFPantoneColor PANTONE455 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE455();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE455 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 455 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE456 Property

PANTONE456 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE456 Property

Gets the PANTONE 456 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE456 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE456
C#
public static PDFPantoneColor PANTONE456 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE456();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE456 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 456 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE457 Property

PANTONE457 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE457 Property

Gets the PANTONE 457 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE457 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE457
C#
public static PDFPantoneColor PANTONE457 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE457();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE457 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 457 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE458 Property

PANTONE458 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE458 Property

Gets the PANTONE 458 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE458 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE458
C#
public static PDFPantoneColor PANTONE458 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE458();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE458 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 458 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE459 Property

PANTONE459 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE459 Property

Gets the PANTONE 459 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE459 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE459
C#
public static PDFPantoneColor PANTONE459 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE459();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE459 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 459 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE460 Property

PANTONE460 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE460 Property

Gets the PANTONE 460 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE460 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE460
C#
public static PDFPantoneColor PANTONE460 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE460();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE460 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 460 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE461 Property

PANTONE461 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE461 Property

Gets the PANTONE 461 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE461 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE461
C#
public static PDFPantoneColor PANTONE461 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE461();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE461 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 461 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE462 Property

PANTONE462 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE462 Property

Gets the PANTONE 462 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE462 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE462
C#
public static PDFPantoneColor PANTONE462 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE462();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE462 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 462 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4625 Property

PANTONE4625 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4625 Property

Gets the PANTONE 4625 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4625 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4625
C#
public static PDFPantoneColor PANTONE4625 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4625();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4625 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4625 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE463 Property

PANTONE463 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE463 Property

Gets the PANTONE 463 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE463 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE463
C#
public static PDFPantoneColor PANTONE463 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE463();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE463 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 463 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4635 Property

PANTONE4635 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4635 Property

Gets the PANTONE 4635 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4635 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4635
C#
public static PDFPantoneColor PANTONE4635 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4635();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4635 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4635 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE464 Property

PANTONE464 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE464 Property

Gets the PANTONE 464 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE464 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE464
C#
public static PDFPantoneColor PANTONE464 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE464();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE464 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 464 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4645 Property

PANTONE4645 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4645 Property

Gets the PANTONE 4645 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4645 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4645
C#
public static PDFPantoneColor PANTONE4645 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4645();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4645 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4645 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE465 Property

PANTONE465 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE465 Property

Gets the PANTONE 465 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE465 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE465
C#
public static PDFPantoneColor PANTONE465 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE465();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE465 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 465 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4655 Property

PANTONE4655 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4655 Property

Gets the PANTONE 4655 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4655 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4655
C#
public static PDFPantoneColor PANTONE4655 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4655();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4655 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4655 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE466 Property

PANTONE466 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE466 Property

Gets the PANTONE 466 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE466 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE466
C#
public static PDFPantoneColor PANTONE466 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE466();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE466 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 466 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4665 Property

PANTONE4665 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4665 Property

Gets the PANTONE 4665 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4665 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4665
C#
public static PDFPantoneColor PANTONE4665 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4665();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4665 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4665 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE467 Property

PANTONE467 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE467 Property

Gets the PANTONE 467 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE467 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE467
C#
public static PDFPantoneColor PANTONE467 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE467();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE467 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 467 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4675 Property

PANTONE4675 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4675 Property

Gets the PANTONE 4675 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4675 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4675
C#
public static PDFPantoneColor PANTONE4675 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4675();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4675 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4675 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE468 Property

PANTONE468 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE468 Property

Gets the PANTONE 468 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE468 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE468
C#
public static PDFPantoneColor PANTONE468 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE468();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE468 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 468 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4685 Property

PANTONE4685 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4685 Property

Gets the PANTONE 4685 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4685 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4685
C#
public static PDFPantoneColor PANTONE4685 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4685();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4685 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4685 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE469 Property

PANTONE469 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE469 Property

Gets the PANTONE 469 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE469 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE469
C#
public static PDFPantoneColor PANTONE469 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE469();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE469 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 469 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4695 Property

PANTONE4695 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4695 Property

Gets the PANTONE 4695 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4695 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4695
C#
public static PDFPantoneColor PANTONE4695 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4695();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4695 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4695 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE470 Property

PANTONE470 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE470 Property

Gets the PANTONE 470 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE470 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE470
C#
public static PDFPantoneColor PANTONE470 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE470();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE470 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 470 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4705 Property

PANTONE4705 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4705 Property

Gets the PANTONE 4705 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4705 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4705
C#
public static PDFPantoneColor PANTONE4705 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4705();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4705 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4705 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE471 Property

PANTONE471 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE471 Property

Gets the PANTONE 471 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE471 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE471
C#
public static PDFPantoneColor PANTONE471 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE471();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE471 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 471 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4715 Property

PANTONE4715 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4715 Property

Gets the PANTONE 4715 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4715 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4715
C#
public static PDFPantoneColor PANTONE4715 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4715();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4715 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4715 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE472 Property

PANTONE472 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE472 Property

Gets the PANTONE 472 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE472 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE472
C#
public static PDFPantoneColor PANTONE472 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE472();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE472 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 472 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4725 Property

PANTONE4725 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4725 Property

Gets the PANTONE 4725 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4725 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4725
C#
public static PDFPantoneColor PANTONE4725 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4725();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4725 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4725 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE473 Property

PANTONE473 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE473 Property

Gets the PANTONE 473 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE473 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE473
C#
public static PDFPantoneColor PANTONE473 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE473();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE473 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 473 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4735 Property

PANTONE4735 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4735 Property

Gets the PANTONE 4735 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4735 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4735
C#
public static PDFPantoneColor PANTONE4735 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4735();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4735 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4735 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE474 Property

PANTONE474 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE474 Property

Gets the PANTONE 474 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE474 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE474
C#
public static PDFPantoneColor PANTONE474 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE474();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE474 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 474 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4745 Property

PANTONE4745 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4745 Property

Gets the PANTONE 4745 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4745 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4745
C#
public static PDFPantoneColor PANTONE4745 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4745();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4745 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4745 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE475 Property

PANTONE475 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE475 Property

Gets the PANTONE 475 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE475 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE475
C#
public static PDFPantoneColor PANTONE475 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE475();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE475 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 475 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4755 Property

PANTONE4755 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4755 Property

Gets the PANTONE 4755 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4755 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4755
C#
public static PDFPantoneColor PANTONE4755 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4755();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4755 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4755 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE476 Property

PANTONE476 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE476 Property

Gets the PANTONE 476 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE476 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE476
C#
public static PDFPantoneColor PANTONE476 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE476();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE476 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 476 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE477 Property

PANTONE477 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE477 Property

Gets the PANTONE 477 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE477 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE477
C#
public static PDFPantoneColor PANTONE477 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE477();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE477 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 477 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE478 Property

PANTONE478 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE478 Property

Gets the PANTONE 478 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE478 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE478
C#
public static PDFPantoneColor PANTONE478 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE478();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE478 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 478 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE479 Property

PANTONE479 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE479 Property

Gets the PANTONE 479 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE479 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE479
C#
public static PDFPantoneColor PANTONE479 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE479();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE479 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 479 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE480 Property

PANTONE480 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE480 Property

Gets the PANTONE 480 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE480 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE480
C#
public static PDFPantoneColor PANTONE480 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE480();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE480 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 480 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE481 Property

PANTONE481 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE481 Property

Gets the PANTONE 481 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE481 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE481
C#
public static PDFPantoneColor PANTONE481 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE481();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE481 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 481 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE482 Property

PANTONE482 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE482 Property

Gets the PANTONE 482 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE482 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE482
C#
public static PDFPantoneColor PANTONE482 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE482();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE482 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 482 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE483 Property

PANTONE483 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE483 Property

Gets the PANTONE 483 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE483 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE483
C#
public static PDFPantoneColor PANTONE483 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE483();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE483 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 483 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE484 Property

PANTONE484 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE484 Property

Gets the PANTONE 484 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE484 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE484
C#
public static PDFPantoneColor PANTONE484 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE484();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE484 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 484 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE485 Property

PANTONE485 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE485 Property

Gets the PANTONE 485 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE485 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE485
C#
public static PDFPantoneColor PANTONE485 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE485();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE485 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 485 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE486 Property

PANTONE486 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE486 Property

Gets the PANTONE 486 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE486 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE486
C#
public static PDFPantoneColor PANTONE486 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE486();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE486 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 486 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE487 Property

PANTONE487 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE487 Property

Gets the PANTONE 487 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE487 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE487
C#
public static PDFPantoneColor PANTONE487 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE487();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE487 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 487 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE488 Property

PANTONE488 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE488 Property

Gets the PANTONE 488 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE488 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE488
C#
public static PDFPantoneColor PANTONE488 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE488();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE488 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 488 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE489 Property

PANTONE489 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE489 Property

Gets the PANTONE 489 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE489 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE489
C#
public static PDFPantoneColor PANTONE489 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE489();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE489 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 489 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE490 Property

PANTONE490 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE490 Property

Gets the PANTONE 490 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE490 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE490
C#
public static PDFPantoneColor PANTONE490 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE490();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE490 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 490 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE491 Property

PANTONE491 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE491 Property

Gets the PANTONE 491 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE491 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE491
C#
public static PDFPantoneColor PANTONE491 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE491();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE491 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 491 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE492 Property

PANTONE492 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE492 Property

Gets the PANTONE 492 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE492 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE492
C#
public static PDFPantoneColor PANTONE492 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE492();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE492 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 492 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE493 Property

PANTONE493 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE493 Property

Gets the PANTONE 493 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE493 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE493
C#
public static PDFPantoneColor PANTONE493 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE493();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE493 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 493 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE494 Property

PANTONE494 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE494 Property

Gets the PANTONE 494 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE494 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE494
C#
public static PDFPantoneColor PANTONE494 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE494();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE494 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 494 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE495 Property

PANTONE495 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE495 Property

Gets the PANTONE 495 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE495 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE495
C#
public static PDFPantoneColor PANTONE495 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE495();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE495 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 495 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE496 Property

PANTONE496 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE496 Property

Gets the PANTONE 496 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE496 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE496
C#
public static PDFPantoneColor PANTONE496 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE496();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE496 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 496 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE497 Property

PANTONE497 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE497 Property

Gets the PANTONE 497 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE497 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE497
C#
public static PDFPantoneColor PANTONE497 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE497();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE497 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 497 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4975 Property

PANTONE4975 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4975 Property

Gets the PANTONE 4975 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4975 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4975
C#
public static PDFPantoneColor PANTONE4975 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4975();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4975 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4975 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE498 Property

PANTONE498 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE498 Property

Gets the PANTONE 498 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE498 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE498
C#
public static PDFPantoneColor PANTONE498 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE498();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE498 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 498 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4985 Property

PANTONE4985 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4985 Property

Gets the PANTONE 4985 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4985 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4985
C#
public static PDFPantoneColor PANTONE4985 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4985();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4985 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4985 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE499 Property

PANTONE499 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE499 Property

Gets the PANTONE 499 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE499 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE499
C#
public static PDFPantoneColor PANTONE499 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE499();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE499 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 499 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE4995 Property

PANTONE4995 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE4995 Property

Gets the PANTONE 4995 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE4995 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE4995
C#
public static PDFPantoneColor PANTONE4995 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE4995();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE4995 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 4995 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE500 Property

PANTONE500 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE500 Property

Gets the PANTONE 500 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE500 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE500
C#
public static PDFPantoneColor PANTONE500 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE500();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE500 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 500 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5005 Property

PANTONE5005 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5005 Property

Gets the PANTONE 5005 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5005 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5005
C#
public static PDFPantoneColor PANTONE5005 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5005();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5005 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5005 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE501 Property

PANTONE501 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE501 Property

Gets the PANTONE 501 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE501 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE501
C#
public static PDFPantoneColor PANTONE501 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE501();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE501 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 501 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5015 Property

PANTONE5015 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5015 Property

Gets the PANTONE 5015 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5015 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5015
C#
public static PDFPantoneColor PANTONE5015 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5015();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5015 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5015 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE502 Property

PANTONE502 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE502 Property

Gets the PANTONE 502 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE502 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE502
C#
public static PDFPantoneColor PANTONE502 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE502();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE502 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 502 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5025 Property

PANTONE5025 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5025 Property

Gets the PANTONE 5025 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5025 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5025
C#
public static PDFPantoneColor PANTONE5025 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5025();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5025 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5025 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE503 Property

PANTONE503 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE503 Property

Gets the PANTONE 503 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE503 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE503
C#
public static PDFPantoneColor PANTONE503 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE503();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE503 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 503 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5035 Property

PANTONE5035 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5035 Property

Gets the PANTONE 5035 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5035 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5035
C#
public static PDFPantoneColor PANTONE5035 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5035();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5035 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5035 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE504 Property

PANTONE504 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE504 Property

Gets the PANTONE 504 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE504 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE504
C#
public static PDFPantoneColor PANTONE504 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE504();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE504 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 504 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE505 Property

PANTONE505 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE505 Property

Gets the PANTONE 505 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE505 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE505
C#
public static PDFPantoneColor PANTONE505 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE505();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE505 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 505 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE506 Property

PANTONE506 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE506 Property

Gets the PANTONE 506 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE506 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE506
C#
public static PDFPantoneColor PANTONE506 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE506();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE506 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 506 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE507 Property

PANTONE507 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE507 Property

Gets the PANTONE 507 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE507 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE507
C#
public static PDFPantoneColor PANTONE507 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE507();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE507 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 507 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE508 Property

PANTONE508 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE508 Property

Gets the PANTONE 508 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE508 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE508
C#
public static PDFPantoneColor PANTONE508 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE508();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE508 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 508 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE509 Property

PANTONE509 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE509 Property

Gets the PANTONE 509 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE509 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE509
C#
public static PDFPantoneColor PANTONE509 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE509();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE509 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 509 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE510 Property

PANTONE510 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE510 Property

Gets the PANTONE 510 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE510 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE510
C#
public static PDFPantoneColor PANTONE510 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE510();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE510 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 510 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE511 Property

PANTONE511 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE511 Property

Gets the PANTONE 511 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE511 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE511
C#
public static PDFPantoneColor PANTONE511 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE511();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE511 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 511 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5115 Property

PANTONE5115 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5115 Property

Gets the PANTONE 5115 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5115 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5115
C#
public static PDFPantoneColor PANTONE5115 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5115();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5115 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5115 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE512 Property

PANTONE512 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE512 Property

Gets the PANTONE 512 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE512 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE512
C#
public static PDFPantoneColor PANTONE512 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE512();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE512 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 512 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5125 Property

PANTONE5125 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5125 Property

Gets the PANTONE 5125 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5125 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5125
C#
public static PDFPantoneColor PANTONE5125 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5125();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5125 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5125 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE513 Property

PANTONE513 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE513 Property

Gets the PANTONE 513 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE513 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE513
C#
public static PDFPantoneColor PANTONE513 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE513();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE513 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 513 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5135 Property

PANTONE5135 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5135 Property

Gets the PANTONE 5135 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5135 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5135
C#
public static PDFPantoneColor PANTONE5135 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5135();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5135 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5135 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE514 Property

PANTONE514 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE514 Property

Gets the PANTONE 514 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE514 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE514
C#
public static PDFPantoneColor PANTONE514 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE514();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE514 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 514 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5145 Property

PANTONE5145 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5145 Property

Gets the PANTONE 5145 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5145 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5145
C#
public static PDFPantoneColor PANTONE5145 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5145();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5145 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5145 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE515 Property

PANTONE515 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE515 Property

Gets the PANTONE 515 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE515 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE515
C#
public static PDFPantoneColor PANTONE515 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE515();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE515 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 515 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5155 Property

PANTONE5155 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5155 Property

Gets the PANTONE 5155 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5155 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5155
C#
public static PDFPantoneColor PANTONE5155 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5155();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5155 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5155 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE516 Property

PANTONE516 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE516 Property

Gets the PANTONE 516 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE516 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE516
C#
public static PDFPantoneColor PANTONE516 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE516();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE516 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 516 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5165 Property

PANTONE5165 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5165 Property

Gets the PANTONE 5165 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5165 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5165
C#
public static PDFPantoneColor PANTONE5165 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5165();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5165 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5165 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE517 Property

PANTONE517 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE517 Property

Gets the PANTONE 517 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE517 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE517
C#
public static PDFPantoneColor PANTONE517 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE517();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE517 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 517 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5175 Property

PANTONE5175 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5175 Property

Gets the PANTONE 5175 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5175 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5175
C#
public static PDFPantoneColor PANTONE5175 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5175();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5175 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5175 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE518 Property

PANTONE518 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE518 Property

Gets the PANTONE 518 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE518 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE518
C#
public static PDFPantoneColor PANTONE518 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE518();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE518 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 518 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5185 Property

PANTONE5185 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5185 Property

Gets the PANTONE 5185 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5185 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5185
C#
public static PDFPantoneColor PANTONE5185 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5185();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5185 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5185 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE519 Property

PANTONE519 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE519 Property

Gets the PANTONE 519 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE519 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE519
C#
public static PDFPantoneColor PANTONE519 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE519();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE519 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 519 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5195 Property

PANTONE5195 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5195 Property

Gets the PANTONE 5195 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5195 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5195
C#
public static PDFPantoneColor PANTONE5195 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5195();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5195 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5195 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE520 Property

PANTONE520 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE520 Property

Gets the PANTONE 520 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE520 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE520
C#
public static PDFPantoneColor PANTONE520 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE520();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE520 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 520 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5205 Property

PANTONE5205 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5205 Property

Gets the PANTONE 5205 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5205 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5205
C#
public static PDFPantoneColor PANTONE5205 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5205();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5205 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5205 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE521 Property

PANTONE521 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE521 Property

Gets the PANTONE 521 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE521 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE521
C#
public static PDFPantoneColor PANTONE521 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE521();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE521 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 521 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5215 Property

PANTONE5215 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5215 Property

Gets the PANTONE 5215 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5215 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5215
C#
public static PDFPantoneColor PANTONE5215 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5215();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5215 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5215 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE522 Property

PANTONE522 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE522 Property

Gets the PANTONE 522 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE522 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE522
C#
public static PDFPantoneColor PANTONE522 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE522();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE522 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 522 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5225 Property

PANTONE5225 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5225 Property

Gets the PANTONE 5225 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5225 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5225
C#
public static PDFPantoneColor PANTONE5225 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5225();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5225 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5225 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE523 Property

PANTONE523 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE523 Property

Gets the PANTONE 523 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE523 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE523
C#
public static PDFPantoneColor PANTONE523 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE523();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE523 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 523 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5235 Property

PANTONE5235 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5235 Property

Gets the PANTONE 5235 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5235 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5235
C#
public static PDFPantoneColor PANTONE5235 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5235();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5235 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5235 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE524 Property

PANTONE524 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE524 Property

Gets the PANTONE 524 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE524 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE524
C#
public static PDFPantoneColor PANTONE524 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE524();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE524 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 524 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5245 Property

PANTONE5245 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5245 Property

Gets the PANTONE 5245 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5245 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5245
C#
public static PDFPantoneColor PANTONE5245 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5245();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5245 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5245 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE525 Property

PANTONE525 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE525 Property

Gets the PANTONE 525 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE525 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE525
C#
public static PDFPantoneColor PANTONE525 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE525();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE525 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 525 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5255 Property

PANTONE5255 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5255 Property

Gets the PANTONE 5255 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5255 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5255
C#
public static PDFPantoneColor PANTONE5255 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5255();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5255 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5255 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE526 Property

PANTONE526 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE526 Property

Gets the PANTONE 526 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE526 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE526
C#
public static PDFPantoneColor PANTONE526 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE526();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE526 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 526 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5265 Property

PANTONE5265 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5265 Property

Gets the PANTONE 5265 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5265 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5265
C#
public static PDFPantoneColor PANTONE5265 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5265();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5265 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5265 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE527 Property

PANTONE527 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE527 Property

Gets the PANTONE 527 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE527 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE527
C#
public static PDFPantoneColor PANTONE527 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE527();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE527 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 527 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5275 Property

PANTONE5275 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5275 Property

Gets the PANTONE 5275 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5275 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5275
C#
public static PDFPantoneColor PANTONE5275 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5275();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5275 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5275 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE528 Property

PANTONE528 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE528 Property

Gets the PANTONE 528 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE528 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE528
C#
public static PDFPantoneColor PANTONE528 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE528();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE528 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 528 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5285 Property

PANTONE5285 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5285 Property

Gets the PANTONE 5285 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5285 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5285
C#
public static PDFPantoneColor PANTONE5285 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5285();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5285 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5285 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE529 Property

PANTONE529 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE529 Property

Gets the PANTONE 529 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE529 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE529
C#
public static PDFPantoneColor PANTONE529 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE529();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE529 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 529 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5295 Property

PANTONE5295 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5295 Property

Gets the PANTONE 5295 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5295 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5295
C#
public static PDFPantoneColor PANTONE5295 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5295();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5295 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5295 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE530 Property

PANTONE530 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE530 Property

Gets the PANTONE 530 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE530 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE530
C#
public static PDFPantoneColor PANTONE530 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE530();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE530 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 530 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5305 Property

PANTONE5305 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5305 Property

Gets the PANTONE 5305 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5305 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5305
C#
public static PDFPantoneColor PANTONE5305 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5305();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5305 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5305 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE531 Property

PANTONE531 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE531 Property

Gets the PANTONE 531 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE531 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE531
C#
public static PDFPantoneColor PANTONE531 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE531();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE531 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 531 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5315 Property

PANTONE5315 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5315 Property

Gets the PANTONE 5315 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5315 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5315
C#
public static PDFPantoneColor PANTONE5315 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5315();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5315 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5315 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE532 Property

PANTONE532 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE532 Property

Gets the PANTONE 532 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE532 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE532
C#
public static PDFPantoneColor PANTONE532 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE532();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE532 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 532 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE533 Property

PANTONE533 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE533 Property

Gets the PANTONE 533 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE533 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE533
C#
public static PDFPantoneColor PANTONE533 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE533();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE533 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 533 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE534 Property

PANTONE534 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE534 Property

Gets the PANTONE 534 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE534 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE534
C#
public static PDFPantoneColor PANTONE534 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE534();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE534 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 534 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE535 Property

PANTONE535 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE535 Property

Gets the PANTONE 535 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE535 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE535
C#
public static PDFPantoneColor PANTONE535 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE535();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE535 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 535 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE536 Property

PANTONE536 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE536 Property

Gets the PANTONE 536 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE536 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE536
C#
public static PDFPantoneColor PANTONE536 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE536();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE536 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 536 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE537 Property

PANTONE537 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE537 Property

Gets the PANTONE 537 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE537 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE537
C#
public static PDFPantoneColor PANTONE537 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE537();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE537 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 537 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE538 Property

PANTONE538 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE538 Property

Gets the PANTONE 538 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE538 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE538
C#
public static PDFPantoneColor PANTONE538 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE538();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE538 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 538 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE539 Property

PANTONE539 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE539 Property

Gets the PANTONE 539 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE539 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE539
C#
public static PDFPantoneColor PANTONE539 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE539();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE539 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 539 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5395 Property

PANTONE5395 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5395 Property

Gets the PANTONE 5395 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5395 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5395
C#
public static PDFPantoneColor PANTONE5395 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5395();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5395 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5395 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE540 Property

PANTONE540 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE540 Property

Gets the PANTONE 540 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE540 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE540
C#
public static PDFPantoneColor PANTONE540 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE540();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE540 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 540 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5405 Property

PANTONE5405 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5405 Property

Gets the PANTONE 5405 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5405 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5405
C#
public static PDFPantoneColor PANTONE5405 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5405();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5405 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5405 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE541 Property

PANTONE541 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE541 Property

Gets the PANTONE 541 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE541 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE541
C#
public static PDFPantoneColor PANTONE541 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE541();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE541 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 541 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5415 Property

PANTONE5415 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5415 Property

Gets the PANTONE 5415 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5415 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5415
C#
public static PDFPantoneColor PANTONE5415 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5415();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5415 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5415 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE542 Property

PANTONE542 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE542 Property

Gets the PANTONE 542 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE542 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE542
C#
public static PDFPantoneColor PANTONE542 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE542();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE542 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 542 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5425 Property

PANTONE5425 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5425 Property

Gets the PANTONE 5425 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5425 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5425
C#
public static PDFPantoneColor PANTONE5425 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5425();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5425 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5425 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE543 Property

PANTONE543 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE543 Property

Gets the PANTONE 543 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE543 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE543
C#
public static PDFPantoneColor PANTONE543 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE543();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE543 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 543 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5435 Property

PANTONE5435 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5435 Property

Gets the PANTONE 5435 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5435 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5435
C#
public static PDFPantoneColor PANTONE5435 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5435();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5435 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5435 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE544 Property

PANTONE544 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE544 Property

Gets the PANTONE 544 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE544 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE544
C#
public static PDFPantoneColor PANTONE544 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE544();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE544 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 544 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5445 Property

PANTONE5445 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5445 Property

Gets the PANTONE 5445 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5445 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5445
C#
public static PDFPantoneColor PANTONE5445 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5445();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5445 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5445 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE545 Property

PANTONE545 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE545 Property

Gets the PANTONE 545 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE545 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE545
C#
public static PDFPantoneColor PANTONE545 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE545();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE545 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 545 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5455 Property

PANTONE5455 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5455 Property

Gets the PANTONE 5455 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5455 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5455
C#
public static PDFPantoneColor PANTONE5455 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5455();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5455 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5455 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE546 Property

PANTONE546 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE546 Property

Gets the PANTONE 546 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE546 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE546
C#
public static PDFPantoneColor PANTONE546 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE546();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE546 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 546 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5463 Property

PANTONE5463 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5463 Property

Gets the PANTONE 5463 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5463 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5463
C#
public static PDFPantoneColor PANTONE5463 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5463();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5463 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5463 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5467 Property

PANTONE5467 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5467 Property

Gets the PANTONE 5467 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5467 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5467
C#
public static PDFPantoneColor PANTONE5467 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5467();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5467 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5467 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE547 Property

PANTONE547 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE547 Property

Gets the PANTONE 547 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE547 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE547
C#
public static PDFPantoneColor PANTONE547 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE547();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE547 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 547 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5473 Property

PANTONE5473 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5473 Property

Gets the PANTONE 5473 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5473 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5473
C#
public static PDFPantoneColor PANTONE5473 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5473();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5473 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5473 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5477 Property

PANTONE5477 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5477 Property

Gets the PANTONE 5477 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5477 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5477
C#
public static PDFPantoneColor PANTONE5477 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5477();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5477 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5477 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE548 Property

PANTONE548 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE548 Property

Gets the PANTONE 548 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE548 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE548
C#
public static PDFPantoneColor PANTONE548 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE548();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE548 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 548 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5483 Property

PANTONE5483 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5483 Property

Gets the PANTONE 5483 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5483 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5483
C#
public static PDFPantoneColor PANTONE5483 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5483();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5483 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5483 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5487 Property

PANTONE5487 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5487 Property

Gets the PANTONE 5487 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5487 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5487
C#
public static PDFPantoneColor PANTONE5487 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5487();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5487 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5487 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE549 Property

PANTONE549 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE549 Property

Gets the PANTONE 549 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE549 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE549
C#
public static PDFPantoneColor PANTONE549 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE549();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE549 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 549 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5493 Property

PANTONE5493 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5493 Property

Gets the PANTONE 5493 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5493 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5493
C#
public static PDFPantoneColor PANTONE5493 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5493();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5493 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5493 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5497 Property

PANTONE5497 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5497 Property

Gets the PANTONE 5497 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5497 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5497
C#
public static PDFPantoneColor PANTONE5497 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5497();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5497 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5497 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE550 Property

PANTONE550 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE550 Property

Gets the PANTONE 550 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE550 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE550
C#
public static PDFPantoneColor PANTONE550 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE550();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE550 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 550 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5503 Property

PANTONE5503 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5503 Property

Gets the PANTONE 5503 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5503 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5503
C#
public static PDFPantoneColor PANTONE5503 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5503();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5503 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5503 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5507 Property

PANTONE5507 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5507 Property

Gets the PANTONE 5507 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5507 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5507
C#
public static PDFPantoneColor PANTONE5507 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5507();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5507 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5507 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE551 Property

PANTONE551 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE551 Property

Gets the PANTONE 551 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE551 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE551
C#
public static PDFPantoneColor PANTONE551 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE551();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE551 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 551 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5513 Property

PANTONE5513 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5513 Property

Gets the PANTONE 5513 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5513 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5513
C#
public static PDFPantoneColor PANTONE5513 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5513();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5513 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5513 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5517 Property

PANTONE5517 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5517 Property

Gets the PANTONE 5517 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5517 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5517
C#
public static PDFPantoneColor PANTONE5517 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5517();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5517 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5517 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE552 Property

PANTONE552 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE552 Property

Gets the PANTONE 552 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE552 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE552
C#
public static PDFPantoneColor PANTONE552 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE552();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE552 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 552 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5523 Property

PANTONE5523 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5523 Property

Gets the PANTONE 5523 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5523 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5523
C#
public static PDFPantoneColor PANTONE5523 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5523();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5523 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5523 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5527 Property

PANTONE5527 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5527 Property

Gets the PANTONE 5527 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5527 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5527
C#
public static PDFPantoneColor PANTONE5527 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5527();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5527 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5527 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE553 Property

PANTONE553 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE553 Property

Gets the PANTONE 553 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE553 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE553
C#
public static PDFPantoneColor PANTONE553 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE553();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE553 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 553 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5535 Property

PANTONE5535 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5535 Property

Gets the PANTONE 5535 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5535 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5535
C#
public static PDFPantoneColor PANTONE5535 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5535();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5535 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5535 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE554 Property

PANTONE554 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE554 Property

Gets the PANTONE 554 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE554 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE554
C#
public static PDFPantoneColor PANTONE554 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE554();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE554 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 554 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5545 Property

PANTONE5545 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5545 Property

Gets the PANTONE 5545 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5545 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5545
C#
public static PDFPantoneColor PANTONE5545 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5545();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5545 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5545 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE555 Property

PANTONE555 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE555 Property

Gets the PANTONE 555 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE555 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE555
C#
public static PDFPantoneColor PANTONE555 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE555();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE555 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 555 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5555 Property

PANTONE5555 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5555 Property

Gets the PANTONE 5555 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5555 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5555
C#
public static PDFPantoneColor PANTONE5555 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5555();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5555 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5555 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE556 Property

PANTONE556 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE556 Property

Gets the PANTONE 556 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE556 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE556
C#
public static PDFPantoneColor PANTONE556 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE556();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE556 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 556 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5565 Property

PANTONE5565 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5565 Property

Gets the PANTONE 5565 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5565 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5565
C#
public static PDFPantoneColor PANTONE5565 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5565();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5565 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5565 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE557 Property

PANTONE557 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE557 Property

Gets the PANTONE 557 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE557 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE557
C#
public static PDFPantoneColor PANTONE557 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE557();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE557 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 557 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5575 Property

PANTONE5575 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5575 Property

Gets the PANTONE 5575 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5575 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5575
C#
public static PDFPantoneColor PANTONE5575 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5575();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5575 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5575 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE558 Property

PANTONE558 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE558 Property

Gets the PANTONE 558 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE558 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE558
C#
public static PDFPantoneColor PANTONE558 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE558();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE558 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 558 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5585 Property

PANTONE5585 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5585 Property

Gets the PANTONE 5585 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5585 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5585
C#
public static PDFPantoneColor PANTONE5585 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5585();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5585 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5585 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE559 Property

PANTONE559 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE559 Property

Gets the PANTONE 559 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE559 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE559
C#
public static PDFPantoneColor PANTONE559 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE559();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE559 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 559 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5595 Property

PANTONE5595 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5595 Property

Gets the PANTONE 5595 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5595 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5595
C#
public static PDFPantoneColor PANTONE5595 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5595();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5595 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5595 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE560 Property

PANTONE560 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE560 Property

Gets the PANTONE 560 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE560 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE560
C#
public static PDFPantoneColor PANTONE560 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE560();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE560 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 560 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5605 Property

PANTONE5605 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5605 Property

Gets the PANTONE 5605 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5605 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5605
C#
public static PDFPantoneColor PANTONE5605 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5605();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5605 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5605 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE561 Property

PANTONE561 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE561 Property

Gets the PANTONE 561 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE561 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE561
C#
public static PDFPantoneColor PANTONE561 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE561();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE561 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 561 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5615 Property

PANTONE5615 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5615 Property

Gets the PANTONE 5615 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5615 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5615
C#
public static PDFPantoneColor PANTONE5615 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5615();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5615 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5615 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE562 Property

PANTONE562 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE562 Property

Gets the PANTONE 562 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE562 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE562
C#
public static PDFPantoneColor PANTONE562 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE562();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE562 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 562 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5625 Property

PANTONE5625 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5625 Property

Gets the PANTONE 5625 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5625 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5625
C#
public static PDFPantoneColor PANTONE5625 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5625();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5625 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5625 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE563 Property

PANTONE563 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE563 Property

Gets the PANTONE 563 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE563 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE563
C#
public static PDFPantoneColor PANTONE563 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE563();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE563 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 563 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5635 Property

PANTONE5635 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5635 Property

Gets the PANTONE 5635 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5635 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5635
C#
public static PDFPantoneColor PANTONE5635 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5635();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5635 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5635 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE564 Property

PANTONE564 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE564 Property

Gets the PANTONE 564 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE564 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE564
C#
public static PDFPantoneColor PANTONE564 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE564();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE564 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 564 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5645 Property

PANTONE5645 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5645 Property

Gets the PANTONE 5645 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5645 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5645
C#
public static PDFPantoneColor PANTONE5645 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5645();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5645 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5645 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE565 Property

PANTONE565 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE565 Property

Gets the PANTONE 565 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE565 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE565
C#
public static PDFPantoneColor PANTONE565 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE565();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE565 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 565 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5655 Property

PANTONE5655 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5655 Property

Gets the PANTONE 5655 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5655 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5655
C#
public static PDFPantoneColor PANTONE5655 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5655();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5655 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5655 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE566 Property

PANTONE566 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE566 Property

Gets the PANTONE 566 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE566 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE566
C#
public static PDFPantoneColor PANTONE566 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE566();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE566 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 566 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5665 Property

PANTONE5665 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5665 Property

Gets the PANTONE 5665 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5665 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5665
C#
public static PDFPantoneColor PANTONE5665 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5665();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5665 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5665 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE567 Property

PANTONE567 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE567 Property

Gets the PANTONE 567 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE567 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE567
C#
public static PDFPantoneColor PANTONE567 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE567();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE567 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 567 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE568 Property

PANTONE568 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE568 Property

Gets the PANTONE 568 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE568 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE568
C#
public static PDFPantoneColor PANTONE568 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE568();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE568 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 568 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE569 Property

PANTONE569 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE569 Property

Gets the PANTONE 569 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE569 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE569
C#
public static PDFPantoneColor PANTONE569 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE569();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE569 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 569 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE570 Property

PANTONE570 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE570 Property

Gets the PANTONE 570 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE570 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE570
C#
public static PDFPantoneColor PANTONE570 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE570();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE570 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 570 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE571 Property

PANTONE571 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE571 Property

Gets the PANTONE 571 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE571 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE571
C#
public static PDFPantoneColor PANTONE571 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE571();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE571 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 571 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE572 Property

PANTONE572 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE572 Property

Gets the PANTONE 572 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE572 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE572
C#
public static PDFPantoneColor PANTONE572 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE572();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE572 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 572 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE573 Property

PANTONE573 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE573 Property

Gets the PANTONE 573 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE573 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE573
C#
public static PDFPantoneColor PANTONE573 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE573();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE573 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 573 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE574 Property

PANTONE574 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE574 Property

Gets the PANTONE 574 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE574 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE574
C#
public static PDFPantoneColor PANTONE574 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE574();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE574 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 574 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5743 Property

PANTONE5743 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5743 Property

Gets the PANTONE 5743 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5743 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5743
C#
public static PDFPantoneColor PANTONE5743 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5743();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5743 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5743 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5747 Property

PANTONE5747 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5747 Property

Gets the PANTONE 5747 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5747 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5747
C#
public static PDFPantoneColor PANTONE5747 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5747();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5747 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5747 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE575 Property

PANTONE575 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE575 Property

Gets the PANTONE 575 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE575 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE575
C#
public static PDFPantoneColor PANTONE575 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE575();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE575 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 575 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5753 Property

PANTONE5753 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5753 Property

Gets the PANTONE 5753 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5753 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5753
C#
public static PDFPantoneColor PANTONE5753 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5753();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5753 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5753 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5757 Property

PANTONE5757 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5757 Property

Gets the PANTONE 5757 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5757 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5757
C#
public static PDFPantoneColor PANTONE5757 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5757();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5757 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5757 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE576 Property

PANTONE576 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE576 Property

Gets the PANTONE 576 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE576 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE576
C#
public static PDFPantoneColor PANTONE576 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE576();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE576 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 576 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5763 Property

PANTONE5763 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5763 Property

Gets the PANTONE 5763 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5763 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5763
C#
public static PDFPantoneColor PANTONE5763 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5763();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5763 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5763 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5767 Property

PANTONE5767 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5767 Property

Gets the PANTONE 5767 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5767 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5767
C#
public static PDFPantoneColor PANTONE5767 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5767();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5767 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5767 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE577 Property

PANTONE577 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE577 Property

Gets the PANTONE 577 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE577 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE577
C#
public static PDFPantoneColor PANTONE577 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE577();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE577 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 577 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5773 Property

PANTONE5773 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5773 Property

Gets the PANTONE 5773 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5773 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5773
C#
public static PDFPantoneColor PANTONE5773 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5773();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5773 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5773 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5777 Property

PANTONE5777 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5777 Property

Gets the PANTONE 5777 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5777 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5777
C#
public static PDFPantoneColor PANTONE5777 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5777();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5777 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5777 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE578 Property

PANTONE578 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE578 Property

Gets the PANTONE 578 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE578 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE578
C#
public static PDFPantoneColor PANTONE578 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE578();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE578 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 578 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5783 Property

PANTONE5783 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5783 Property

Gets the PANTONE 5783 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5783 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5783
C#
public static PDFPantoneColor PANTONE5783 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5783();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5783 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5783 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5787 Property

PANTONE5787 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5787 Property

Gets the PANTONE 5787 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5787 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5787
C#
public static PDFPantoneColor PANTONE5787 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5787();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5787 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5787 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE579 Property

PANTONE579 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE579 Property

Gets the PANTONE 579 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE579 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE579
C#
public static PDFPantoneColor PANTONE579 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE579();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE579 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 579 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5793 Property

PANTONE5793 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5793 Property

Gets the PANTONE 5793 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5793 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5793
C#
public static PDFPantoneColor PANTONE5793 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5793();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5793 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5793 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5797 Property

PANTONE5797 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5797 Property

Gets the PANTONE 5797 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5797 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5797
C#
public static PDFPantoneColor PANTONE5797 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5797();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5797 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5797 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE580 Property

PANTONE580 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE580 Property

Gets the PANTONE 580 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE580 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE580
C#
public static PDFPantoneColor PANTONE580 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE580();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE580 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 580 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5803 Property

PANTONE5803 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5803 Property

Gets the PANTONE 5803 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5803 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5803
C#
public static PDFPantoneColor PANTONE5803 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5803();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5803 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5803 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5807 Property

PANTONE5807 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5807 Property

Gets the PANTONE 5807 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5807 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5807
C#
public static PDFPantoneColor PANTONE5807 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5807();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5807 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5807 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE581 Property

PANTONE581 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE581 Property

Gets the PANTONE 581 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE581 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE581
C#
public static PDFPantoneColor PANTONE581 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE581();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE581 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 581 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5815 Property

PANTONE5815 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5815 Property

Gets the PANTONE 5815 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5815 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5815
C#
public static PDFPantoneColor PANTONE5815 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5815();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5815 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5815 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE582 Property

PANTONE582 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE582 Property

Gets the PANTONE 582 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE582 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE582
C#
public static PDFPantoneColor PANTONE582 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE582();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE582 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 582 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5825 Property

PANTONE5825 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5825 Property

Gets the PANTONE 5825 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5825 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5825
C#
public static PDFPantoneColor PANTONE5825 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5825();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5825 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5825 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE583 Property

PANTONE583 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE583 Property

Gets the PANTONE 583 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE583 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE583
C#
public static PDFPantoneColor PANTONE583 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE583();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE583 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 583 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5835 Property

PANTONE5835 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5835 Property

Gets the PANTONE 5835 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5835 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5835
C#
public static PDFPantoneColor PANTONE5835 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5835();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5835 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5835 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE584 Property

PANTONE584 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE584 Property

Gets the PANTONE 584 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE584 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE584
C#
public static PDFPantoneColor PANTONE584 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE584();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE584 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 584 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5845 Property

PANTONE5845 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5845 Property

Gets the PANTONE 5845 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5845 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5845
C#
public static PDFPantoneColor PANTONE5845 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5845();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5845 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5845 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE585 Property

PANTONE585 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE585 Property

Gets the PANTONE 585 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE585 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE585
C#
public static PDFPantoneColor PANTONE585 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE585();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE585 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 585 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5855 Property

PANTONE5855 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5855 Property

Gets the PANTONE 5855 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5855 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5855
C#
public static PDFPantoneColor PANTONE5855 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5855();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5855 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5855 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE586 Property

PANTONE586 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE586 Property

Gets the PANTONE 586 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE586 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE586
C#
public static PDFPantoneColor PANTONE586 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE586();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE586 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 586 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5865 Property

PANTONE5865 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5865 Property

Gets the PANTONE 5865 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5865 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5865
C#
public static PDFPantoneColor PANTONE5865 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5865();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5865 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5865 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE587 Property

PANTONE587 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE587 Property

Gets the PANTONE 587 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE587 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE587
C#
public static PDFPantoneColor PANTONE587 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE587();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE587 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 587 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE5875 Property

PANTONE5875 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE5875 Property

Gets the PANTONE 5875 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE5875 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE5875
C#
public static PDFPantoneColor PANTONE5875 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE5875();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE5875 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 5875 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE600 Property

PANTONE600 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE600 Property

Gets the PANTONE 600 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE600 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE600
C#
public static PDFPantoneColor PANTONE600 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE600();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE600 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 600 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE601 Property

PANTONE601 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE601 Property

Gets the PANTONE 601 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE601 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE601
C#
public static PDFPantoneColor PANTONE601 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE601();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE601 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 601 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE602 Property

PANTONE602 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE602 Property

Gets the PANTONE 602 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE602 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE602
C#
public static PDFPantoneColor PANTONE602 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE602();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE602 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 602 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE603 Property

PANTONE603 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE603 Property

Gets the PANTONE 603 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE603 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE603
C#
public static PDFPantoneColor PANTONE603 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE603();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE603 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 603 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE604 Property

PANTONE604 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE604 Property

Gets the PANTONE 604 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE604 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE604
C#
public static PDFPantoneColor PANTONE604 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE604();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE604 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 604 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE605 Property

PANTONE605 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE605 Property

Gets the PANTONE 605 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE605 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE605
C#
public static PDFPantoneColor PANTONE605 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE605();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE605 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 605 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE606 Property

PANTONE606 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE606 Property

Gets the PANTONE 606 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE606 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE606
C#
public static PDFPantoneColor PANTONE606 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE606();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE606 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 606 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE607 Property

PANTONE607 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE607 Property

Gets the PANTONE 607 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE607 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE607
C#
public static PDFPantoneColor PANTONE607 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE607();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE607 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 607 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE608 Property

PANTONE608 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE608 Property

Gets the PANTONE 608 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE608 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE608
C#
public static PDFPantoneColor PANTONE608 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE608();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE608 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 608 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE609 Property

PANTONE609 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE609 Property

Gets the PANTONE 609 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE609 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE609
C#
public static PDFPantoneColor PANTONE609 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE609();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE609 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 609 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE610 Property

PANTONE610 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE610 Property

Gets the PANTONE 610 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE610 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE610
C#
public static PDFPantoneColor PANTONE610 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE610();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE610 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 610 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE611 Property

PANTONE611 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE611 Property

Gets the PANTONE 611 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE611 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE611
C#
public static PDFPantoneColor PANTONE611 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE611();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE611 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 611 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE612 Property

PANTONE612 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE612 Property

Gets the PANTONE 612 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE612 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE612
C#
public static PDFPantoneColor PANTONE612 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE612();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE612 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 612 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE613 Property

PANTONE613 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE613 Property

Gets the PANTONE 613 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE613 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE613
C#
public static PDFPantoneColor PANTONE613 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE613();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE613 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 613 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE614 Property

PANTONE614 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE614 Property

Gets the PANTONE 614 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE614 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE614
C#
public static PDFPantoneColor PANTONE614 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE614();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE614 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 614 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE615 Property

PANTONE615 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE615 Property

Gets the PANTONE 615 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE615 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE615
C#
public static PDFPantoneColor PANTONE615 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE615();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE615 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 615 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE616 Property

PANTONE616 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE616 Property

Gets the PANTONE 616 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE616 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE616
C#
public static PDFPantoneColor PANTONE616 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE616();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE616 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 616 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE617 Property

PANTONE617 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE617 Property

Gets the PANTONE 617 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE617 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE617
C#
public static PDFPantoneColor PANTONE617 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE617();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE617 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 617 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE618 Property

PANTONE618 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE618 Property

Gets the PANTONE 618 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE618 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE618
C#
public static PDFPantoneColor PANTONE618 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE618();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE618 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 618 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE619 Property

PANTONE619 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE619 Property

Gets the PANTONE 619 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE619 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE619
C#
public static PDFPantoneColor PANTONE619 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE619();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE619 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 619 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE620 Property

PANTONE620 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE620 Property

Gets the PANTONE 620 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE620 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE620
C#
public static PDFPantoneColor PANTONE620 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE620();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE620 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 620 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE621 Property

PANTONE621 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE621 Property

Gets the PANTONE 621 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE621 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE621
C#
public static PDFPantoneColor PANTONE621 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE621();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE621 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 621 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE622 Property

PANTONE622 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE622 Property

Gets the PANTONE 622 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE622 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE622
C#
public static PDFPantoneColor PANTONE622 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE622();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE622 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 622 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE623 Property

PANTONE623 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE623 Property

Gets the PANTONE 623 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE623 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE623
C#
public static PDFPantoneColor PANTONE623 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE623();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE623 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 623 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE624 Property

PANTONE624 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE624 Property

Gets the PANTONE 624 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE624 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE624
C#
public static PDFPantoneColor PANTONE624 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE624();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE624 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 624 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE625 Property

PANTONE625 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE625 Property

Gets the PANTONE 625 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE625 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE625
C#
public static PDFPantoneColor PANTONE625 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE625();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE625 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 625 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE626 Property

PANTONE626 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE626 Property

Gets the PANTONE 626 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE626 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE626
C#
public static PDFPantoneColor PANTONE626 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE626();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE626 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 626 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE627 Property

PANTONE627 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE627 Property

Gets the PANTONE 627 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE627 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE627
C#
public static PDFPantoneColor PANTONE627 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE627();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE627 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 627 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE628 Property

PANTONE628 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE628 Property

Gets the PANTONE 628 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE628 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE628
C#
public static PDFPantoneColor PANTONE628 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE628();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE628 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 628 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE629 Property

PANTONE629 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE629 Property

Gets the PANTONE 629 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE629 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE629
C#
public static PDFPantoneColor PANTONE629 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE629();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE629 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 629 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE630 Property

PANTONE630 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE630 Property

Gets the PANTONE 630 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE630 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE630
C#
public static PDFPantoneColor PANTONE630 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE630();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE630 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 630 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE631 Property

PANTONE631 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE631 Property

Gets the PANTONE 631 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE631 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE631
C#
public static PDFPantoneColor PANTONE631 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE631();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE631 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 631 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE632 Property

PANTONE632 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE632 Property

Gets the PANTONE 632 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE632 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE632
C#
public static PDFPantoneColor PANTONE632 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE632();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE632 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 632 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE633 Property

PANTONE633 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE633 Property

Gets the PANTONE 633 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE633 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE633
C#
public static PDFPantoneColor PANTONE633 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE633();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE633 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 633 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE634 Property

PANTONE634 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE634 Property

Gets the PANTONE 634 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE634 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE634
C#
public static PDFPantoneColor PANTONE634 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE634();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE634 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 634 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE635 Property

PANTONE635 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE635 Property

Gets the PANTONE 635 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE635 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE635
C#
public static PDFPantoneColor PANTONE635 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE635();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE635 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 635 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE636 Property

PANTONE636 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE636 Property

Gets the PANTONE 636 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE636 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE636
C#
public static PDFPantoneColor PANTONE636 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE636();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE636 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 636 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE637 Property

PANTONE637 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE637 Property

Gets the PANTONE 637 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE637 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE637
C#
public static PDFPantoneColor PANTONE637 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE637();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE637 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 637 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE638 Property

PANTONE638 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE638 Property

Gets the PANTONE 638 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE638 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE638
C#
public static PDFPantoneColor PANTONE638 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE638();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE638 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 638 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE639 Property

PANTONE639 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE639 Property

Gets the PANTONE 639 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE639 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE639
C#
public static PDFPantoneColor PANTONE639 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE639();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE639 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 639 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE640 Property

PANTONE640 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE640 Property

Gets the PANTONE 640 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE640 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE640
C#
public static PDFPantoneColor PANTONE640 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE640();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE640 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 640 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE641 Property

PANTONE641 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE641 Property

Gets the PANTONE 641 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE641 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE641
C#
public static PDFPantoneColor PANTONE641 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE641();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE641 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 641 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE642 Property

PANTONE642 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE642 Property

Gets the PANTONE 642 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE642 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE642
C#
public static PDFPantoneColor PANTONE642 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE642();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE642 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 642 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE643 Property

PANTONE643 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE643 Property

Gets the PANTONE 643 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE643 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE643
C#
public static PDFPantoneColor PANTONE643 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE643();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE643 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 643 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE644 Property

PANTONE644 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE644 Property

Gets the PANTONE 644 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE644 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE644
C#
public static PDFPantoneColor PANTONE644 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE644();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE644 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 644 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE645 Property

PANTONE645 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE645 Property

Gets the PANTONE 645 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE645 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE645
C#
public static PDFPantoneColor PANTONE645 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE645();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE645 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 645 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE646 Property

PANTONE646 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE646 Property

Gets the PANTONE 646 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE646 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE646
C#
public static PDFPantoneColor PANTONE646 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE646();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE646 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 646 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE647 Property

PANTONE647 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE647 Property

Gets the PANTONE 647 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE647 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE647
C#
public static PDFPantoneColor PANTONE647 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE647();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE647 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 647 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE648 Property

PANTONE648 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE648 Property

Gets the PANTONE 648 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE648 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE648
C#
public static PDFPantoneColor PANTONE648 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE648();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE648 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 648 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE649 Property

PANTONE649 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE649 Property

Gets the PANTONE 649 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE649 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE649
C#
public static PDFPantoneColor PANTONE649 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE649();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE649 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 649 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE650 Property

PANTONE650 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE650 Property

Gets the PANTONE 650 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE650 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE650
C#
public static PDFPantoneColor PANTONE650 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE650();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE650 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 650 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE651 Property

PANTONE651 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE651 Property

Gets the PANTONE 651 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE651 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE651
C#
public static PDFPantoneColor PANTONE651 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE651();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE651 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 651 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE652 Property

PANTONE652 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE652 Property

Gets the PANTONE 652 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE652 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE652
C#
public static PDFPantoneColor PANTONE652 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE652();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE652 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 652 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE653 Property

PANTONE653 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE653 Property

Gets the PANTONE 653 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE653 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE653
C#
public static PDFPantoneColor PANTONE653 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE653();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE653 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 653 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE654 Property

PANTONE654 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE654 Property

Gets the PANTONE 654 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE654 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE654
C#
public static PDFPantoneColor PANTONE654 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE654();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE654 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 654 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE655 Property

PANTONE655 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE655 Property

Gets the PANTONE 655 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE655 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE655
C#
public static PDFPantoneColor PANTONE655 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE655();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE655 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 655 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE656 Property

PANTONE656 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE656 Property

Gets the PANTONE 656 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE656 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE656
C#
public static PDFPantoneColor PANTONE656 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE656();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE656 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 656 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE657 Property

PANTONE657 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE657 Property

Gets the PANTONE 657 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE657 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE657
C#
public static PDFPantoneColor PANTONE657 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE657();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE657 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 657 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE658 Property

PANTONE658 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE658 Property

Gets the PANTONE 658 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE658 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE658
C#
public static PDFPantoneColor PANTONE658 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE658();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE658 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 658 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE659 Property

PANTONE659 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE659 Property

Gets the PANTONE 659 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE659 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE659
C#
public static PDFPantoneColor PANTONE659 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE659();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE659 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 659 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE660 Property

PANTONE660 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE660 Property

Gets the PANTONE 660 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE660 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE660
C#
public static PDFPantoneColor PANTONE660 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE660();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE660 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 660 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE661 Property

PANTONE661 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE661 Property

Gets the PANTONE 661 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE661 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE661
C#
public static PDFPantoneColor PANTONE661 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE661();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE661 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 661 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE662 Property

PANTONE662 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE662 Property

Gets the PANTONE 662 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE662 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE662
C#
public static PDFPantoneColor PANTONE662 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE662();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE662 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 662 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE663 Property

PANTONE663 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE663 Property

Gets the PANTONE 663 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE663 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE663
C#
public static PDFPantoneColor PANTONE663 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE663();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE663 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 663 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE664 Property

PANTONE664 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE664 Property

Gets the PANTONE 664 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE664 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE664
C#
public static PDFPantoneColor PANTONE664 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE664();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE664 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 664 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE665 Property

PANTONE665 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE665 Property

Gets the PANTONE 665 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE665 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE665
C#
public static PDFPantoneColor PANTONE665 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE665();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE665 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 665 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE666 Property

PANTONE666 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE666 Property

Gets the PANTONE 666 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE666 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE666
C#
public static PDFPantoneColor PANTONE666 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE666();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE666 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 666 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE667 Property

PANTONE667 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE667 Property

Gets the PANTONE 667 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE667 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE667
C#
public static PDFPantoneColor PANTONE667 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE667();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE667 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 667 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE668 Property

PANTONE668 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE668 Property

Gets the PANTONE 668 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE668 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE668
C#
public static PDFPantoneColor PANTONE668 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE668();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE668 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 668 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE669 Property

PANTONE669 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE669 Property

Gets the PANTONE 669 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE669 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE669
C#
public static PDFPantoneColor PANTONE669 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE669();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE669 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 669 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE670 Property

PANTONE670 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE670 Property

Gets the PANTONE 670 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE670 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE670
C#
public static PDFPantoneColor PANTONE670 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE670();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE670 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 670 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE671 Property

PANTONE671 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE671 Property

Gets the PANTONE 671 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE671 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE671
C#
public static PDFPantoneColor PANTONE671 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE671();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE671 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 671 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE672 Property

PANTONE672 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE672 Property

Gets the PANTONE 672 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE672 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE672
C#
public static PDFPantoneColor PANTONE672 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE672();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE672 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 672 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE673 Property

PANTONE673 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE673 Property

Gets the PANTONE 673 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE673 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE673
C#
public static PDFPantoneColor PANTONE673 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE673();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE673 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 673 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE674 Property

PANTONE674 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE674 Property

Gets the PANTONE 674 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE674 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE674
C#
public static PDFPantoneColor PANTONE674 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE674();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE674 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 674 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE675 Property

PANTONE675 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE675 Property

Gets the PANTONE 675 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE675 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE675
C#
public static PDFPantoneColor PANTONE675 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE675();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE675 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 675 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE676 Property

PANTONE676 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE676 Property

Gets the PANTONE 676 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE676 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE676
C#
public static PDFPantoneColor PANTONE676 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE676();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE676 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 676 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE677 Property

PANTONE677 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE677 Property

Gets the PANTONE 677 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE677 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE677
C#
public static PDFPantoneColor PANTONE677 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE677();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE677 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 677 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE678 Property

PANTONE678 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE678 Property

Gets the PANTONE 678 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE678 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE678
C#
public static PDFPantoneColor PANTONE678 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE678();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE678 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 678 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE679 Property

PANTONE679 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE679 Property

Gets the PANTONE 679 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE679 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE679
C#
public static PDFPantoneColor PANTONE679 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE679();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE679 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 679 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE680 Property

PANTONE680 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE680 Property

Gets the PANTONE 680 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE680 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE680
C#
public static PDFPantoneColor PANTONE680 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE680();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE680 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 680 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE681 Property

PANTONE681 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE681 Property

Gets the PANTONE 681 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE681 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE681
C#
public static PDFPantoneColor PANTONE681 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE681();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE681 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 681 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE682 Property

PANTONE682 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE682 Property

Gets the PANTONE 682 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE682 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE682
C#
public static PDFPantoneColor PANTONE682 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE682();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE682 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 682 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE683 Property

PANTONE683 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE683 Property

Gets the PANTONE 683 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE683 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE683
C#
public static PDFPantoneColor PANTONE683 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE683();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE683 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 683 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE684 Property

PANTONE684 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE684 Property

Gets the PANTONE 684 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE684 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE684
C#
public static PDFPantoneColor PANTONE684 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE684();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE684 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 684 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE685 Property

PANTONE685 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE685 Property

Gets the PANTONE 685 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE685 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE685
C#
public static PDFPantoneColor PANTONE685 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE685();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE685 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 685 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE686 Property

PANTONE686 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE686 Property

Gets the PANTONE 686 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE686 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE686
C#
public static PDFPantoneColor PANTONE686 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE686();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE686 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 686 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE687 Property

PANTONE687 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE687 Property

Gets the PANTONE 687 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE687 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE687
C#
public static PDFPantoneColor PANTONE687 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE687();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE687 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 687 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE688 Property

PANTONE688 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE688 Property

Gets the PANTONE 688 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE688 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE688
C#
public static PDFPantoneColor PANTONE688 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE688();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE688 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 688 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE689 Property

PANTONE689 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE689 Property

Gets the PANTONE 689 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE689 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE689
C#
public static PDFPantoneColor PANTONE689 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE689();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE689 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 689 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE690 Property

PANTONE690 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE690 Property

Gets the PANTONE 690 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE690 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE690
C#
public static PDFPantoneColor PANTONE690 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE690();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE690 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 690 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE691 Property

PANTONE691 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE691 Property

Gets the PANTONE 691 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE691 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE691
C#
public static PDFPantoneColor PANTONE691 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE691();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE691 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 691 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE692 Property

PANTONE692 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE692 Property

Gets the PANTONE 692 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE692 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE692
C#
public static PDFPantoneColor PANTONE692 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE692();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE692 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 692 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE693 Property

PANTONE693 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE693 Property

Gets the PANTONE 693 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE693 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE693
C#
public static PDFPantoneColor PANTONE693 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE693();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE693 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 693 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE694 Property

PANTONE694 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE694 Property

Gets the PANTONE 694 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE694 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE694
C#
public static PDFPantoneColor PANTONE694 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE694();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE694 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 694 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE695 Property

PANTONE695 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE695 Property

Gets the PANTONE 695 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE695 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE695
C#
public static PDFPantoneColor PANTONE695 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE695();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE695 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 695 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE696 Property

PANTONE696 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE696 Property

Gets the PANTONE 696 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE696 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE696
C#
public static PDFPantoneColor PANTONE696 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE696();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE696 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 696 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE697 Property

PANTONE697 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE697 Property

Gets the PANTONE 697 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE697 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE697
C#
public static PDFPantoneColor PANTONE697 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE697();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE697 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 697 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE698 Property

PANTONE698 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE698 Property

Gets the PANTONE 698 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE698 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE698
C#
public static PDFPantoneColor PANTONE698 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE698();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE698 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 698 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE699 Property

PANTONE699 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE699 Property

Gets the PANTONE 699 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE699 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE699
C#
public static PDFPantoneColor PANTONE699 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE699();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE699 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 699 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE700 Property

PANTONE700 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE700 Property

Gets the PANTONE 700 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE700 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE700
C#
public static PDFPantoneColor PANTONE700 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE700();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE700 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 700 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE701 Property

PANTONE701 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE701 Property

Gets the PANTONE 701 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE701 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE701
C#
public static PDFPantoneColor PANTONE701 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE701();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE701 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 701 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE702 Property

PANTONE702 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE702 Property

Gets the PANTONE 702 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE702 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE702
C#
public static PDFPantoneColor PANTONE702 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE702();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE702 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 702 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE703 Property

PANTONE703 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE703 Property

Gets the PANTONE 703 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE703 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE703
C#
public static PDFPantoneColor PANTONE703 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE703();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE703 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 703 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE704 Property

PANTONE704 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE704 Property

Gets the PANTONE 704 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE704 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE704
C#
public static PDFPantoneColor PANTONE704 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE704();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE704 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 704 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE705 Property

PANTONE705 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE705 Property

Gets the PANTONE 705 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE705 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE705
C#
public static PDFPantoneColor PANTONE705 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE705();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE705 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 705 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE706 Property

PANTONE706 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE706 Property

Gets the PANTONE 706 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE706 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE706
C#
public static PDFPantoneColor PANTONE706 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE706();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE706 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 706 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE707 Property

PANTONE707 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE707 Property

Gets the PANTONE 707 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE707 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE707
C#
public static PDFPantoneColor PANTONE707 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE707();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE707 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 707 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE708 Property

PANTONE708 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE708 Property

Gets the PANTONE 708 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE708 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE708
C#
public static PDFPantoneColor PANTONE708 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE708();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE708 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 708 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE709 Property

PANTONE709 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE709 Property

Gets the PANTONE 709 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE709 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE709
C#
public static PDFPantoneColor PANTONE709 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE709();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE709 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 709 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE710 Property

PANTONE710 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE710 Property

Gets the PANTONE 710 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE710 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE710
C#
public static PDFPantoneColor PANTONE710 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE710();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE710 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 710 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE711 Property

PANTONE711 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE711 Property

Gets the PANTONE 711 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE711 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE711
C#
public static PDFPantoneColor PANTONE711 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE711();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE711 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 711 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE712 Property

PANTONE712 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE712 Property

Gets the PANTONE 712 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE712 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE712
C#
public static PDFPantoneColor PANTONE712 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE712();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE712 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 712 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE713 Property

PANTONE713 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE713 Property

Gets the PANTONE 713 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE713 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE713
C#
public static PDFPantoneColor PANTONE713 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE713();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE713 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 713 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE714 Property

PANTONE714 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE714 Property

Gets the PANTONE 714 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE714 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE714
C#
public static PDFPantoneColor PANTONE714 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE714();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE714 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 714 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE715 Property

PANTONE715 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE715 Property

Gets the PANTONE 715 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE715 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE715
C#
public static PDFPantoneColor PANTONE715 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE715();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE715 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 715 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE716 Property

PANTONE716 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE716 Property

Gets the PANTONE 716 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE716 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE716
C#
public static PDFPantoneColor PANTONE716 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE716();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE716 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 716 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE717 Property

PANTONE717 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE717 Property

Gets the PANTONE 717 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE717 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE717
C#
public static PDFPantoneColor PANTONE717 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE717();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE717 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 717 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE718 Property

PANTONE718 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE718 Property

Gets the PANTONE 718 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE718 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE718
C#
public static PDFPantoneColor PANTONE718 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE718();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE718 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 718 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE719 Property

PANTONE719 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE719 Property

Gets the PANTONE 719 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE719 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE719
C#
public static PDFPantoneColor PANTONE719 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE719();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE719 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 719 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE720 Property

PANTONE720 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE720 Property

Gets the PANTONE 720 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE720 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE720
C#
public static PDFPantoneColor PANTONE720 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE720();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE720 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 720 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE721 Property

PANTONE721 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE721 Property

Gets the PANTONE 721 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE721 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE721
C#
public static PDFPantoneColor PANTONE721 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE721();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE721 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 721 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE722 Property

PANTONE722 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE722 Property

Gets the PANTONE 722 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE722 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE722
C#
public static PDFPantoneColor PANTONE722 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE722();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE722 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 722 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE723 Property

PANTONE723 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE723 Property

Gets the PANTONE 723 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE723 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE723
C#
public static PDFPantoneColor PANTONE723 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE723();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE723 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 723 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE724 Property

PANTONE724 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE724 Property

Gets the PANTONE 724 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE724 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE724
C#
public static PDFPantoneColor PANTONE724 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE724();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE724 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 724 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE725 Property

PANTONE725 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE725 Property

Gets the PANTONE 725 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE725 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE725
C#
public static PDFPantoneColor PANTONE725 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE725();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE725 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 725 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE726 Property

PANTONE726 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE726 Property

Gets the PANTONE 726 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE726 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE726
C#
public static PDFPantoneColor PANTONE726 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE726();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE726 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 726 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE727 Property

PANTONE727 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE727 Property

Gets the PANTONE 727 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE727 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE727
C#
public static PDFPantoneColor PANTONE727 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE727();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE727 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 727 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE728 Property

PANTONE728 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE728 Property

Gets the PANTONE 728 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE728 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE728
C#
public static PDFPantoneColor PANTONE728 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE728();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE728 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 728 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE729 Property

PANTONE729 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE729 Property

Gets the PANTONE 729 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE729 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE729
C#
public static PDFPantoneColor PANTONE729 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE729();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE729 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 729 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE730 Property

PANTONE730 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE730 Property

Gets the PANTONE 730 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE730 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE730
C#
public static PDFPantoneColor PANTONE730 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE730();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE730 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 730 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE731 Property

PANTONE731 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE731 Property

Gets the PANTONE 731 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE731 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE731
C#
public static PDFPantoneColor PANTONE731 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE731();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE731 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 731 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE732 Property

PANTONE732 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE732 Property

Gets the PANTONE 732 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE732 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE732
C#
public static PDFPantoneColor PANTONE732 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE732();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE732 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 732 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7401 Property

PANTONE7401 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7401 Property

Gets the PANTONE 7401 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7401 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7401
C#
public static PDFPantoneColor PANTONE7401 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7401();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7401 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7401 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7402 Property

PANTONE7402 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7402 Property

Gets the PANTONE 7402 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7402 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7402
C#
public static PDFPantoneColor PANTONE7402 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7402();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7402 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7402 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7403 Property

PANTONE7403 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7403 Property

Gets the PANTONE 7403 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7403 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7403
C#
public static PDFPantoneColor PANTONE7403 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7403();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7403 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7403 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7404 Property

PANTONE7404 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7404 Property

Gets the PANTONE 7404 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7404 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7404
C#
public static PDFPantoneColor PANTONE7404 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7404();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7404 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7404 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7405 Property

PANTONE7405 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7405 Property

Gets the PANTONE 7405 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7405 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7405
C#
public static PDFPantoneColor PANTONE7405 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7405();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7405 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7405 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7406 Property

PANTONE7406 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7406 Property

Gets the PANTONE 7406 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7406 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7406
C#
public static PDFPantoneColor PANTONE7406 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7406();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7406 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7406 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7407 Property

PANTONE7407 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7407 Property

Gets the PANTONE 7407 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7407 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7407
C#
public static PDFPantoneColor PANTONE7407 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7407();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7407 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7407 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7408 Property

PANTONE7408 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7408 Property

Gets the PANTONE 7408 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7408 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7408
C#
public static PDFPantoneColor PANTONE7408 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7408();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7408 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7408 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7409 Property

PANTONE7409 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7409 Property

Gets the PANTONE 7409 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7409 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7409
C#
public static PDFPantoneColor PANTONE7409 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7409();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7409 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7409 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7410 Property

PANTONE7410 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7410 Property

Gets the PANTONE 7410 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7410 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7410
C#
public static PDFPantoneColor PANTONE7410 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7410();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7410 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7410 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7411 Property

PANTONE7411 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7411 Property

Gets the PANTONE 7411 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7411 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7411
C#
public static PDFPantoneColor PANTONE7411 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7411();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7411 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7411 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7412 Property

PANTONE7412 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7412 Property

Gets the PANTONE 7412 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7412 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7412
C#
public static PDFPantoneColor PANTONE7412 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7412();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7412 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7412 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7413 Property

PANTONE7413 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7413 Property

Gets the PANTONE 7413 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7413 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7413
C#
public static PDFPantoneColor PANTONE7413 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7413();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7413 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7413 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7414 Property

PANTONE7414 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7414 Property

Gets the PANTONE 7414 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7414 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7414
C#
public static PDFPantoneColor PANTONE7414 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7414();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7414 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7414 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7415 Property

PANTONE7415 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7415 Property

Gets the PANTONE 7415 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7415 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7415
C#
public static PDFPantoneColor PANTONE7415 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7415();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7415 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7415 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7416 Property

PANTONE7416 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7416 Property

Gets the PANTONE 7416 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7416 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7416
C#
public static PDFPantoneColor PANTONE7416 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7416();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7416 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7416 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7417 Property

PANTONE7417 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7417 Property

Gets the PANTONE 7417 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7417 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7417
C#
public static PDFPantoneColor PANTONE7417 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7417();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7417 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7417 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7418 Property

PANTONE7418 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7418 Property

Gets the PANTONE 7418 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7418 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7418
C#
public static PDFPantoneColor PANTONE7418 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7418();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7418 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7418 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7419 Property

PANTONE7419 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7419 Property

Gets the PANTONE 7419 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7419 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7419
C#
public static PDFPantoneColor PANTONE7419 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7419();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7419 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7419 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7420 Property

PANTONE7420 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7420 Property

Gets the PANTONE 7420 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7420 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7420
C#
public static PDFPantoneColor PANTONE7420 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7420();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7420 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7420 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7421 Property

PANTONE7421 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7421 Property

Gets the PANTONE 7421 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7421 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7421
C#
public static PDFPantoneColor PANTONE7421 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7421();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7421 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7421 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7422 Property

PANTONE7422 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7422 Property

Gets the PANTONE 7422 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7422 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7422
C#
public static PDFPantoneColor PANTONE7422 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7422();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7422 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7422 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7423 Property

PANTONE7423 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7423 Property

Gets the PANTONE 7423 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7423 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7423
C#
public static PDFPantoneColor PANTONE7423 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7423();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7423 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7423 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7424 Property

PANTONE7424 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7424 Property

Gets the PANTONE 7424 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7424 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7424
C#
public static PDFPantoneColor PANTONE7424 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7424();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7424 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7424 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7425 Property

PANTONE7425 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7425 Property

Gets the PANTONE 7425 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7425 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7425
C#
public static PDFPantoneColor PANTONE7425 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7425();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7425 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7425 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7426 Property

PANTONE7426 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7426 Property

Gets the PANTONE 7426 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7426 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7426
C#
public static PDFPantoneColor PANTONE7426 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7426();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7426 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7426 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7427 Property

PANTONE7427 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7427 Property

Gets the PANTONE 7427 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7427 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7427
C#
public static PDFPantoneColor PANTONE7427 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7427();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7427 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7427 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7428 Property

PANTONE7428 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7428 Property

Gets the PANTONE 7428 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7428 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7428
C#
public static PDFPantoneColor PANTONE7428 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7428();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7428 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7428 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7429 Property

PANTONE7429 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7429 Property

Gets the PANTONE 7429 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7429 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7429
C#
public static PDFPantoneColor PANTONE7429 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7429();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7429 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7429 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7430 Property

PANTONE7430 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7430 Property

Gets the PANTONE 7430 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7430 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7430
C#
public static PDFPantoneColor PANTONE7430 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7430();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7430 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7430 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7431 Property

PANTONE7431 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7431 Property

Gets the PANTONE 7431 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7431 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7431
C#
public static PDFPantoneColor PANTONE7431 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7431();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7431 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7431 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7432 Property

PANTONE7432 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7432 Property

Gets the PANTONE 7432 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7432 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7432
C#
public static PDFPantoneColor PANTONE7432 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7432();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7432 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7432 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7433 Property

PANTONE7433 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7433 Property

Gets the PANTONE 7433 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7433 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7433
C#
public static PDFPantoneColor PANTONE7433 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7433();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7433 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7433 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7434 Property

PANTONE7434 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7434 Property

Gets the PANTONE 7434 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7434 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7434
C#
public static PDFPantoneColor PANTONE7434 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7434();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7434 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7434 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7435 Property

PANTONE7435 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7435 Property

Gets the PANTONE 7435 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7435 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7435
C#
public static PDFPantoneColor PANTONE7435 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7435();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7435 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7435 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7436 Property

PANTONE7436 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7436 Property

Gets the PANTONE 7436 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7436 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7436
C#
public static PDFPantoneColor PANTONE7436 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7436();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7436 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7436 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7437 Property

PANTONE7437 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7437 Property

Gets the PANTONE 7437 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7437 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7437
C#
public static PDFPantoneColor PANTONE7437 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7437();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7437 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7437 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7438 Property

PANTONE7438 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7438 Property

Gets the PANTONE 7438 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7438 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7438
C#
public static PDFPantoneColor PANTONE7438 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7438();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7438 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7438 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7439 Property

PANTONE7439 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7439 Property

Gets the PANTONE 7439 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7439 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7439
C#
public static PDFPantoneColor PANTONE7439 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7439();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7439 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7439 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7440 Property

PANTONE7440 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7440 Property

Gets the PANTONE 7440 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7440 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7440
C#
public static PDFPantoneColor PANTONE7440 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7440();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7440 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7440 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7441 Property

PANTONE7441 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7441 Property

Gets the PANTONE 7441 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7441 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7441
C#
public static PDFPantoneColor PANTONE7441 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7441();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7441 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7441 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7442 Property

PANTONE7442 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7442 Property

Gets the PANTONE 7442 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7442 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7442
C#
public static PDFPantoneColor PANTONE7442 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7442();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7442 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7442 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7443 Property

PANTONE7443 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7443 Property

Gets the PANTONE 7443 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7443 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7443
C#
public static PDFPantoneColor PANTONE7443 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7443();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7443 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7443 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7444 Property

PANTONE7444 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7444 Property

Gets the PANTONE 7444 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7444 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7444
C#
public static PDFPantoneColor PANTONE7444 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7444();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7444 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7444 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7445 Property

PANTONE7445 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7445 Property

Gets the PANTONE 7445 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7445 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7445
C#
public static PDFPantoneColor PANTONE7445 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7445();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7445 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7445 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7446 Property

PANTONE7446 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7446 Property

Gets the PANTONE 7446 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7446 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7446
C#
public static PDFPantoneColor PANTONE7446 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7446();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7446 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7446 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7447 Property

PANTONE7447 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7447 Property

Gets the PANTONE 7447 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7447 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7447
C#
public static PDFPantoneColor PANTONE7447 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7447();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7447 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7447 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7448 Property

PANTONE7448 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7448 Property

Gets the PANTONE 7448 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7448 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7448
C#
public static PDFPantoneColor PANTONE7448 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7448();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7448 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7448 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7449 Property

PANTONE7449 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7449 Property

Gets the PANTONE 7449 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7449 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7449
C#
public static PDFPantoneColor PANTONE7449 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7449();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7449 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7449 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7450 Property

PANTONE7450 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7450 Property

Gets the PANTONE 7450 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7450 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7450
C#
public static PDFPantoneColor PANTONE7450 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7450();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7450 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7450 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7451 Property

PANTONE7451 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7451 Property

Gets the PANTONE 7451 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7451 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7451
C#
public static PDFPantoneColor PANTONE7451 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7451();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7451 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7451 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7452 Property

PANTONE7452 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7452 Property

Gets the PANTONE 7452 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7452 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7452
C#
public static PDFPantoneColor PANTONE7452 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7452();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7452 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7452 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7453 Property

PANTONE7453 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7453 Property

Gets the PANTONE 7453 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7453 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7453
C#
public static PDFPantoneColor PANTONE7453 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7453();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7453 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7453 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7454 Property

PANTONE7454 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7454 Property

Gets the PANTONE 7454 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7454 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7454
C#
public static PDFPantoneColor PANTONE7454 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7454();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7454 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7454 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7455 Property

PANTONE7455 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7455 Property

Gets the PANTONE 7455 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7455 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7455
C#
public static PDFPantoneColor PANTONE7455 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7455();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7455 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7455 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7456 Property

PANTONE7456 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7456 Property

Gets the PANTONE 7456 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7456 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7456
C#
public static PDFPantoneColor PANTONE7456 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7456();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7456 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7456 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7457 Property

PANTONE7457 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7457 Property

Gets the PANTONE 7457 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7457 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7457
C#
public static PDFPantoneColor PANTONE7457 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7457();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7457 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7457 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7458 Property

PANTONE7458 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7458 Property

Gets the PANTONE 7458 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7458 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7458
C#
public static PDFPantoneColor PANTONE7458 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7458();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7458 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7458 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7459 Property

PANTONE7459 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7459 Property

Gets the PANTONE 7459 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7459 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7459
C#
public static PDFPantoneColor PANTONE7459 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7459();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7459 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7459 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7460 Property

PANTONE7460 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7460 Property

Gets the PANTONE 7460 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7460 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7460
C#
public static PDFPantoneColor PANTONE7460 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7460();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7460 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7460 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7461 Property

PANTONE7461 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7461 Property

Gets the PANTONE 7461 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7461 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7461
C#
public static PDFPantoneColor PANTONE7461 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7461();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7461 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7461 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7462 Property

PANTONE7462 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7462 Property

Gets the PANTONE 7462 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7462 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7462
C#
public static PDFPantoneColor PANTONE7462 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7462();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7462 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7462 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7463 Property

PANTONE7463 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7463 Property

Gets the PANTONE 7463 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7463 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7463
C#
public static PDFPantoneColor PANTONE7463 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7463();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7463 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7463 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7464 Property

PANTONE7464 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7464 Property

Gets the PANTONE 7464 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7464 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7464
C#
public static PDFPantoneColor PANTONE7464 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7464();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7464 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7464 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7465 Property

PANTONE7465 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7465 Property

Gets the PANTONE 7465 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7465 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7465
C#
public static PDFPantoneColor PANTONE7465 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7465();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7465 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7465 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7466 Property

PANTONE7466 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7466 Property

Gets the PANTONE 7466 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7466 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7466
C#
public static PDFPantoneColor PANTONE7466 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7466();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7466 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7466 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7467 Property

PANTONE7467 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7467 Property

Gets the PANTONE 7467 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7467 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7467
C#
public static PDFPantoneColor PANTONE7467 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7467();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7467 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7467 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7468 Property

PANTONE7468 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7468 Property

Gets the PANTONE 7468 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7468 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7468
C#
public static PDFPantoneColor PANTONE7468 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7468();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7468 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7468 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7469 Property

PANTONE7469 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7469 Property

Gets the PANTONE 7469 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7469 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7469
C#
public static PDFPantoneColor PANTONE7469 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7469();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7469 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7469 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7470 Property

PANTONE7470 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7470 Property

Gets the PANTONE 7470 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7470 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7470
C#
public static PDFPantoneColor PANTONE7470 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7470();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7470 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7470 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7471 Property

PANTONE7471 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7471 Property

Gets the PANTONE 7471 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7471 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7471
C#
public static PDFPantoneColor PANTONE7471 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7471();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7471 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7471 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7472 Property

PANTONE7472 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7472 Property

Gets the PANTONE 7472 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7472 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7472
C#
public static PDFPantoneColor PANTONE7472 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7472();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7472 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7472 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7473 Property

PANTONE7473 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7473 Property

Gets the PANTONE 7473 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7473 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7473
C#
public static PDFPantoneColor PANTONE7473 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7473();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7473 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7473 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7474 Property

PANTONE7474 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7474 Property

Gets the PANTONE 7474 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7474 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7474
C#
public static PDFPantoneColor PANTONE7474 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7474();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7474 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7474 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7475 Property

PANTONE7475 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7475 Property

Gets the PANTONE 7475 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7475 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7475
C#
public static PDFPantoneColor PANTONE7475 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7475();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7475 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7475 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7476 Property

PANTONE7476 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7476 Property

Gets the PANTONE 7476 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7476 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7476
C#
public static PDFPantoneColor PANTONE7476 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7476();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7476 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7476 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7477 Property

PANTONE7477 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7477 Property

Gets the PANTONE 7477 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7477 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7477
C#
public static PDFPantoneColor PANTONE7477 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7477();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7477 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7477 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7478 Property

PANTONE7478 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7478 Property

Gets the PANTONE 7478 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7478 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7478
C#
public static PDFPantoneColor PANTONE7478 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7478();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7478 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7478 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7479 Property

PANTONE7479 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7479 Property

Gets the PANTONE 7479 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7479 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7479
C#
public static PDFPantoneColor PANTONE7479 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7479();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7479 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7479 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7480 Property

PANTONE7480 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7480 Property

Gets the PANTONE 7480 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7480 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7480
C#
public static PDFPantoneColor PANTONE7480 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7480();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7480 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7480 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7481 Property

PANTONE7481 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7481 Property

Gets the PANTONE 7481 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7481 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7481
C#
public static PDFPantoneColor PANTONE7481 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7481();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7481 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7481 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7482 Property

PANTONE7482 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7482 Property

Gets the PANTONE 7482 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7482 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7482
C#
public static PDFPantoneColor PANTONE7482 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7482();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7482 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7482 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7483 Property

PANTONE7483 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7483 Property

Gets the PANTONE 7483 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7483 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7483
C#
public static PDFPantoneColor PANTONE7483 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7483();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7483 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7483 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7484 Property

PANTONE7484 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7484 Property

Gets the PANTONE 7484 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7484 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7484
C#
public static PDFPantoneColor PANTONE7484 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7484();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7484 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7484 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7485 Property

PANTONE7485 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7485 Property

Gets the PANTONE 7485 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7485 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7485
C#
public static PDFPantoneColor PANTONE7485 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7485();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7485 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7485 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7486 Property

PANTONE7486 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7486 Property

Gets the PANTONE 7486 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7486 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7486
C#
public static PDFPantoneColor PANTONE7486 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7486();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7486 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7486 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7487 Property

PANTONE7487 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7487 Property

Gets the PANTONE 7487 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7487 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7487
C#
public static PDFPantoneColor PANTONE7487 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7487();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7487 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7487 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7488 Property

PANTONE7488 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7488 Property

Gets the PANTONE 7488 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7488 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7488
C#
public static PDFPantoneColor PANTONE7488 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7488();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7488 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7488 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7489 Property

PANTONE7489 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7489 Property

Gets the PANTONE 7489 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7489 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7489
C#
public static PDFPantoneColor PANTONE7489 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7489();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7489 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7489 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7490 Property

PANTONE7490 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7490 Property

Gets the PANTONE 7490 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7490 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7490
C#
public static PDFPantoneColor PANTONE7490 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7490();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7490 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7490 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7491 Property

PANTONE7491 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7491 Property

Gets the PANTONE 7491 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7491 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7491
C#
public static PDFPantoneColor PANTONE7491 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7491();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7491 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7491 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7492 Property

PANTONE7492 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7492 Property

Gets the PANTONE 7492 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7492 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7492
C#
public static PDFPantoneColor PANTONE7492 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7492();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7492 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7492 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7493 Property

PANTONE7493 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7493 Property

Gets the PANTONE 7493 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7493 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7493
C#
public static PDFPantoneColor PANTONE7493 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7493();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7493 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7493 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7494 Property

PANTONE7494 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7494 Property

Gets the PANTONE 7494 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7494 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7494
C#
public static PDFPantoneColor PANTONE7494 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7494();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7494 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7494 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7495 Property

PANTONE7495 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7495 Property

Gets the PANTONE 7495 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7495 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7495
C#
public static PDFPantoneColor PANTONE7495 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7495();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7495 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7495 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7496 Property

PANTONE7496 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7496 Property

Gets the PANTONE 7496 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7496 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7496
C#
public static PDFPantoneColor PANTONE7496 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7496();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7496 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7496 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7497 Property

PANTONE7497 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7497 Property

Gets the PANTONE 7497 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7497 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7497
C#
public static PDFPantoneColor PANTONE7497 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7497();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7497 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7497 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7498 Property

PANTONE7498 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7498 Property

Gets the PANTONE 7498 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7498 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7498
C#
public static PDFPantoneColor PANTONE7498 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7498();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7498 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7498 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7499 Property

PANTONE7499 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7499 Property

Gets the PANTONE 7499 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7499 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7499
C#
public static PDFPantoneColor PANTONE7499 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7499();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7499 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7499 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7500 Property

PANTONE7500 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7500 Property

Gets the PANTONE 7500 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7500 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7500
C#
public static PDFPantoneColor PANTONE7500 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7500();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7500 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7500 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7501 Property

PANTONE7501 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7501 Property

Gets the PANTONE 7501 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7501 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7501
C#
public static PDFPantoneColor PANTONE7501 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7501();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7501 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7501 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7502 Property

PANTONE7502 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7502 Property

Gets the PANTONE 7502 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7502 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7502
C#
public static PDFPantoneColor PANTONE7502 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7502();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7502 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7502 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7503 Property

PANTONE7503 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7503 Property

Gets the PANTONE 7503 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7503 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7503
C#
public static PDFPantoneColor PANTONE7503 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7503();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7503 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7503 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7504 Property

PANTONE7504 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7504 Property

Gets the PANTONE 7504 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7504 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7504
C#
public static PDFPantoneColor PANTONE7504 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7504();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7504 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7504 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7505 Property

PANTONE7505 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7505 Property

Gets the PANTONE 7505 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7505 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7505
C#
public static PDFPantoneColor PANTONE7505 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7505();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7505 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7505 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7506 Property

PANTONE7506 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7506 Property

Gets the PANTONE 7506 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7506 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7506
C#
public static PDFPantoneColor PANTONE7506 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7506();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7506 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7506 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7507 Property

PANTONE7507 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7507 Property

Gets the PANTONE 7507 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7507 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7507
C#
public static PDFPantoneColor PANTONE7507 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7507();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7507 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7507 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7508 Property

PANTONE7508 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7508 Property

Gets the PANTONE 7508 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7508 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7508
C#
public static PDFPantoneColor PANTONE7508 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7508();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7508 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7508 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7509 Property

PANTONE7509 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7509 Property

Gets the PANTONE 7509 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7509 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7509
C#
public static PDFPantoneColor PANTONE7509 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7509();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7509 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7509 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7510 Property

PANTONE7510 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7510 Property

Gets the PANTONE 7510 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7510 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7510
C#
public static PDFPantoneColor PANTONE7510 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7510();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7510 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7510 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7511 Property

PANTONE7511 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7511 Property

Gets the PANTONE 7511 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7511 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7511
C#
public static PDFPantoneColor PANTONE7511 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7511();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7511 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7511 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7512 Property

PANTONE7512 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7512 Property

Gets the PANTONE 7512 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7512 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7512
C#
public static PDFPantoneColor PANTONE7512 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7512();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7512 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7512 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7513 Property

PANTONE7513 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7513 Property

Gets the PANTONE 7513 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7513 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7513
C#
public static PDFPantoneColor PANTONE7513 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7513();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7513 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7513 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7514 Property

PANTONE7514 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7514 Property

Gets the PANTONE 7514 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7514 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7514
C#
public static PDFPantoneColor PANTONE7514 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7514();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7514 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7514 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7515 Property

PANTONE7515 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7515 Property

Gets the PANTONE 7515 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7515 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7515
C#
public static PDFPantoneColor PANTONE7515 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7515();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7515 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7515 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7516 Property

PANTONE7516 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7516 Property

Gets the PANTONE 7516 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7516 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7516
C#
public static PDFPantoneColor PANTONE7516 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7516();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7516 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7516 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7517 Property

PANTONE7517 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7517 Property

Gets the PANTONE 7517 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7517 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7517
C#
public static PDFPantoneColor PANTONE7517 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7517();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7517 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7517 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7518 Property

PANTONE7518 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7518 Property

Gets the PANTONE 7518 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7518 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7518
C#
public static PDFPantoneColor PANTONE7518 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7518();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7518 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7518 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7519 Property

PANTONE7519 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7519 Property

Gets the PANTONE 7519 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7519 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7519
C#
public static PDFPantoneColor PANTONE7519 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7519();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7519 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7519 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7520 Property

PANTONE7520 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7520 Property

Gets the PANTONE 7520 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7520 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7520
C#
public static PDFPantoneColor PANTONE7520 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7520();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7520 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7520 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7521 Property

PANTONE7521 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7521 Property

Gets the PANTONE 7521 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7521 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7521
C#
public static PDFPantoneColor PANTONE7521 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7521();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7521 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7521 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7522 Property

PANTONE7522 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7522 Property

Gets the PANTONE 7522 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7522 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7522
C#
public static PDFPantoneColor PANTONE7522 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7522();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7522 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7522 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7523 Property

PANTONE7523 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7523 Property

Gets the PANTONE 7523 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7523 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7523
C#
public static PDFPantoneColor PANTONE7523 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7523();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7523 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7523 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7524 Property

PANTONE7524 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7524 Property

Gets the PANTONE 7524 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7524 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7524
C#
public static PDFPantoneColor PANTONE7524 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7524();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7524 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7524 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7525 Property

PANTONE7525 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7525 Property

Gets the PANTONE 7525 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7525 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7525
C#
public static PDFPantoneColor PANTONE7525 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7525();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7525 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7525 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7526 Property

PANTONE7526 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7526 Property

Gets the PANTONE 7526 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7526 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7526
C#
public static PDFPantoneColor PANTONE7526 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7526();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7526 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7526 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7527 Property

PANTONE7527 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7527 Property

Gets the PANTONE 7527 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7527 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7527
C#
public static PDFPantoneColor PANTONE7527 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7527();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7527 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7527 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7528 Property

PANTONE7528 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7528 Property

Gets the PANTONE 7528 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7528 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7528
C#
public static PDFPantoneColor PANTONE7528 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7528();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7528 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7528 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7529 Property

PANTONE7529 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7529 Property

Gets the PANTONE 7529 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7529 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7529
C#
public static PDFPantoneColor PANTONE7529 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7529();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7529 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7529 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7530 Property

PANTONE7530 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7530 Property

Gets the PANTONE 7530 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7530 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7530
C#
public static PDFPantoneColor PANTONE7530 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7530();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7530 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7530 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7531 Property

PANTONE7531 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7531 Property

Gets the PANTONE 7531 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7531 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7531
C#
public static PDFPantoneColor PANTONE7531 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7531();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7531 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7531 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7532 Property

PANTONE7532 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7532 Property

Gets the PANTONE 7532 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7532 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7532
C#
public static PDFPantoneColor PANTONE7532 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7532();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7532 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7532 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7533 Property

PANTONE7533 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7533 Property

Gets the PANTONE 7533 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7533 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7533
C#
public static PDFPantoneColor PANTONE7533 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7533();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7533 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7533 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7534 Property

PANTONE7534 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7534 Property

Gets the PANTONE 7534 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7534 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7534
C#
public static PDFPantoneColor PANTONE7534 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7534();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7534 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7534 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7535 Property

PANTONE7535 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7535 Property

Gets the PANTONE 7535 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7535 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7535
C#
public static PDFPantoneColor PANTONE7535 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7535();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7535 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7535 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7536 Property

PANTONE7536 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7536 Property

Gets the PANTONE 7536 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7536 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7536
C#
public static PDFPantoneColor PANTONE7536 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7536();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7536 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7536 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7537 Property

PANTONE7537 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7537 Property

Gets the PANTONE 7537 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7537 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7537
C#
public static PDFPantoneColor PANTONE7537 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7537();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7537 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7537 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7538 Property

PANTONE7538 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7538 Property

Gets the PANTONE 7538 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7538 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7538
C#
public static PDFPantoneColor PANTONE7538 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7538();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7538 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7538 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7539 Property

PANTONE7539 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7539 Property

Gets the PANTONE 7539 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7539 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7539
C#
public static PDFPantoneColor PANTONE7539 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7539();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7539 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7539 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7540 Property

PANTONE7540 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7540 Property

Gets the PANTONE 7540 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7540 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7540
C#
public static PDFPantoneColor PANTONE7540 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7540();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7540 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7540 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7541 Property

PANTONE7541 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7541 Property

Gets the PANTONE 7541 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7541 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7541
C#
public static PDFPantoneColor PANTONE7541 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7541();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7541 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7541 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7542 Property

PANTONE7542 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7542 Property

Gets the PANTONE 7542 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7542 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7542
C#
public static PDFPantoneColor PANTONE7542 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7542();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7542 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7542 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7543 Property

PANTONE7543 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7543 Property

Gets the PANTONE 7543 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7543 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7543
C#
public static PDFPantoneColor PANTONE7543 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7543();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7543 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7543 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7544 Property

PANTONE7544 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7544 Property

Gets the PANTONE 7544 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7544 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7544
C#
public static PDFPantoneColor PANTONE7544 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7544();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7544 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7544 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7545 Property

PANTONE7545 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7545 Property

Gets the PANTONE 7545 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7545 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7545
C#
public static PDFPantoneColor PANTONE7545 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7545();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7545 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7545 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7546 Property

PANTONE7546 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7546 Property

Gets the PANTONE 7546 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7546 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7546
C#
public static PDFPantoneColor PANTONE7546 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7546();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7546 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7546 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE7547 Property

PANTONE7547 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE7547 Property

Gets the PANTONE 7547 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE7547 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE7547
C#
public static PDFPantoneColor PANTONE7547 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE7547();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE7547 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 7547 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE8003 Property

PANTONE8003 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8003 Property

Gets the PANTONE 8003 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE8003 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8003
C#
public static PDFPantoneColor PANTONE8003 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE8003();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE8003 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 8003 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE801 Property

PANTONE801 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE801 Property

Gets the PANTONE 801 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE801 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE801
C#
public static PDFPantoneColor PANTONE801 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE801();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE801 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 801 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE802 Property

PANTONE802 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE802 Property

Gets the PANTONE 802 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE802 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE802
C#
public static PDFPantoneColor PANTONE802 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE802();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE802 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 802 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE8021 Property

PANTONE8021 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8021 Property

Gets the PANTONE 8021 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE8021 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8021
C#
public static PDFPantoneColor PANTONE8021 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE8021();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE8021 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 8021 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE803 Property

PANTONE803 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE803 Property

Gets the PANTONE 803 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE803 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE803
C#
public static PDFPantoneColor PANTONE803 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE803();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE803 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 803 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE804 Property

PANTONE804 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE804 Property

Gets the PANTONE 804 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE804 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE804
C#
public static PDFPantoneColor PANTONE804 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE804();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE804 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 804 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE805 Property

PANTONE805 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE805 Property

Gets the PANTONE 805 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE805 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE805
C#
public static PDFPantoneColor PANTONE805 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE805();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE805 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 805 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE806 Property

PANTONE806 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE806 Property

Gets the PANTONE 806 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE806 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE806
C#
public static PDFPantoneColor PANTONE806 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE806();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE806 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 806 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE8062 Property

PANTONE8062 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8062 Property

Gets the PANTONE 8062 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE8062 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8062
C#
public static PDFPantoneColor PANTONE8062 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE8062();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE8062 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 8062 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE807 Property

PANTONE807 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE807 Property

Gets the PANTONE 807 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE807 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE807
C#
public static PDFPantoneColor PANTONE807 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE807();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE807 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 807 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE808 Property

PANTONE808 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE808 Property

Gets the PANTONE 808 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE808 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE808
C#
public static PDFPantoneColor PANTONE808 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE808();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE808 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 808 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE809 Property

PANTONE809 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE809 Property

Gets the PANTONE 809 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE809 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE809
C#
public static PDFPantoneColor PANTONE809 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE809();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE809 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 809 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE810 Property

PANTONE810 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE810 Property

Gets the PANTONE 810 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE810 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE810
C#
public static PDFPantoneColor PANTONE810 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE810();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE810 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 810 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE8100 Property

PANTONE8100 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8100 Property

Gets the PANTONE 8100 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE8100 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8100
C#
public static PDFPantoneColor PANTONE8100 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE8100();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE8100 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 8100 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE811 Property

PANTONE811 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE811 Property

Gets the PANTONE 811 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE811 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE811
C#
public static PDFPantoneColor PANTONE811 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE811();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE811 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 811 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE812 Property

PANTONE812 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE812 Property

Gets the PANTONE 812 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE812 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE812
C#
public static PDFPantoneColor PANTONE812 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE812();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE812 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 812 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE813 Property

PANTONE813 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE813 Property

Gets the PANTONE 813 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE813 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE813
C#
public static PDFPantoneColor PANTONE813 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE813();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE813 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 813 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE814 Property

PANTONE814 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE814 Property

Gets the PANTONE 814 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE814 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE814
C#
public static PDFPantoneColor PANTONE814 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE814();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE814 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 814 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE8201 Property

PANTONE8201 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8201 Property

Gets the PANTONE 8201 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE8201 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8201
C#
public static PDFPantoneColor PANTONE8201 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE8201();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE8201 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 8201 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE8281 Property

PANTONE8281 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8281 Property

Gets the PANTONE 8281 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE8281 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8281
C#
public static PDFPantoneColor PANTONE8281 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE8281();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE8281 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 8281 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE8321 Property

PANTONE8321 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE8321 Property

Gets the PANTONE 8321 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE8321 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE8321
C#
public static PDFPantoneColor PANTONE8321 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE8321();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE8321 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 8321 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE871 Property

PANTONE871 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE871 Property

Gets the PANTONE 871 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE871 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE871
C#
public static PDFPantoneColor PANTONE871 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE871();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE871 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 871 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE872 Property

PANTONE872 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE872 Property

Gets the PANTONE 872 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE872 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE872
C#
public static PDFPantoneColor PANTONE872 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE872();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE872 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 872 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE873 Property

PANTONE873 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE873 Property

Gets the PANTONE 873 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE873 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE873
C#
public static PDFPantoneColor PANTONE873 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE873();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE873 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 873 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE874 Property

PANTONE874 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE874 Property

Gets the PANTONE 874 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE874 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE874
C#
public static PDFPantoneColor PANTONE874 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE874();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE874 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 874 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE875 Property

PANTONE875 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE875 Property

Gets the PANTONE 875 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE875 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE875
C#
public static PDFPantoneColor PANTONE875 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE875();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE875 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 875 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE876 Property

PANTONE876 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE876 Property

Gets the PANTONE 876 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE876 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE876
C#
public static PDFPantoneColor PANTONE876 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE876();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE876 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 876 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PANTONE877 Property

PANTONE877 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : PANTONE877 Property

Gets the PANTONE 877 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PANTONE877 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.PANTONE877
C#
public static PDFPantoneColor PANTONE877 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_PANTONE877();
C++/CLI
public:
static property PDFPantoneColor^ PANTONE877 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE 877 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


ProcessBlack Property

ProcessBlack Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ProcessBlack Property

Gets the PANTONE Process Black color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ProcessBlack As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.ProcessBlack
C#
public static PDFPantoneColor ProcessBlack {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_ProcessBlack();
C++/CLI
public:
static property PDFPantoneColor^ ProcessBlack {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Process Black color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


ProcessBlue Property

ProcessBlue Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ProcessBlue Property

Gets the PANTONE Process Blue color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ProcessBlue As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.ProcessBlue
C#
public static PDFPantoneColor ProcessBlue {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_ProcessBlue();
C++/CLI
public:
static property PDFPantoneColor^ ProcessBlue {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Process Blue color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


ProcessCyan Property

ProcessCyan Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ProcessCyan Property

Gets the PANTONE Process Cyan color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ProcessCyan As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.ProcessCyan
C#
public static PDFPantoneColor ProcessCyan {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_ProcessCyan();
C++/CLI
public:
static property PDFPantoneColor^ ProcessCyan {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Process Cyan color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


ProcessMagenta Property

ProcessMagenta Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ProcessMagenta Property

Gets the PANTONE Process Magenta color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ProcessMagenta As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.ProcessMagenta
C#
public static PDFPantoneColor ProcessMagenta {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_ProcessMagenta();
C++/CLI
public:
static property PDFPantoneColor^ ProcessMagenta {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Process Magenta color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


ProcessYellow Property

ProcessYellow Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ProcessYellow Property

Gets the PANTONE Process Yellow color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ProcessYellow As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.ProcessYellow
C#
public static PDFPantoneColor ProcessYellow {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_ProcessYellow();
C++/CLI
public:
static property PDFPantoneColor^ ProcessYellow {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Process Yellow color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Purple Property

Purple Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Purple Property

Gets the PANTONE Purple color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Purple As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Purple
C#
public static PDFPantoneColor Purple {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Purple();
C++/CLI
public:
static property PDFPantoneColor^ Purple {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Purple color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Red032 Property

Red032 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Red032 Property

Gets the PANTONE Red 032 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Red032 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Red032
C#
public static PDFPantoneColor Red032 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Red032();
C++/CLI
public:
static property PDFPantoneColor^ Red032 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Red 032 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


ReflexBlue Property

ReflexBlue Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : ReflexBlue Property

Gets the PANTONE Reflex Blue color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ReflexBlue As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.ReflexBlue
C#
public static PDFPantoneColor ReflexBlue {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_ReflexBlue();
C++/CLI
public:
static property PDFPantoneColor^ ReflexBlue {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Reflex Blue color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


RhodamineRed Property

RhodamineRed Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : RhodamineRed Property

Gets the PANTONE Rhodamine Red color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property RhodamineRed As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.RhodamineRed
C#
public static PDFPantoneColor RhodamineRed {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_RhodamineRed();
C++/CLI
public:
static property PDFPantoneColor^ RhodamineRed {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Rhodamine Red color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


RubineRed Property

RubineRed Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : RubineRed Property

Gets the PANTONE Rubine Red color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property RubineRed As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.RubineRed
C#
public static PDFPantoneColor RubineRed {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_RubineRed();
C++/CLI
public:
static property PDFPantoneColor^ RubineRed {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Rubine Red color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Violet Property

Violet Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Violet Property

Gets the PANTONE Violet color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Violet As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Violet
C#
public static PDFPantoneColor Violet {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Violet();
C++/CLI
public:
static property PDFPantoneColor^ Violet {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Violet color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray1 Property

WarmGray1 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray1 Property

Gets the PANTONE Warm Gray 1 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray1 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray1
C#
public static PDFPantoneColor WarmGray1 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray1();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray1 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 1 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray10 Property

WarmGray10 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray10 Property

Gets the PANTONE Warm Gray 10 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray10 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray10
C#
public static PDFPantoneColor WarmGray10 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray10();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray10 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 10 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray11 Property

WarmGray11 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray11 Property

Gets the PANTONE Warm Gray 11 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray11 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray11
C#
public static PDFPantoneColor WarmGray11 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray11();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray11 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 11 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray2 Property

WarmGray2 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray2 Property

Gets the PANTONE Warm Gray 2 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray2 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray2
C#
public static PDFPantoneColor WarmGray2 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray2();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray2 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 2 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray3 Property

WarmGray3 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray3 Property

Gets the PANTONE Warm Gray 3 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray3 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray3
C#
public static PDFPantoneColor WarmGray3 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray3();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray3 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 3 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray4 Property

WarmGray4 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray4 Property

Gets the PANTONE Warm Gray 4 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray4 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray4
C#
public static PDFPantoneColor WarmGray4 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray4();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray4 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 4 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray5 Property

WarmGray5 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray5 Property

Gets the PANTONE Warm Gray 5 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray5 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray5
C#
public static PDFPantoneColor WarmGray5 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray5();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray5 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 5 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray6 Property

WarmGray6 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray6 Property

Gets the PANTONE Warm Gray 6 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray6 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray6
C#
public static PDFPantoneColor WarmGray6 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray6();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray6 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 6 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray7 Property

WarmGray7 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray7 Property

Gets the PANTONE Warm Gray 7 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray7 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray7
C#
public static PDFPantoneColor WarmGray7 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray7();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray7 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 7 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray8 Property

WarmGray8 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray8 Property

Gets the PANTONE Warm Gray 8 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray8 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray8
C#
public static PDFPantoneColor WarmGray8 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray8();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray8 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 8 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmGray9 Property

WarmGray9 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmGray9 Property

Gets the PANTONE Warm Gray 9 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmGray9 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmGray9
C#
public static PDFPantoneColor WarmGray9 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmGray9();
C++/CLI
public:
static property PDFPantoneColor^ WarmGray9 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Gray 9 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


WarmRed Property

WarmRed Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : WarmRed Property

Gets the PANTONE Warm Red color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WarmRed As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.WarmRed
C#
public static PDFPantoneColor WarmRed {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_WarmRed();
C++/CLI
public:
static property PDFPantoneColor^ WarmRed {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Warm Red color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Yellow Property

Yellow Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Yellow Property

Gets the PANTONE Yellow color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Yellow As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Yellow
C#
public static PDFPantoneColor Yellow {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Yellow();
C++/CLI
public:
static property PDFPantoneColor^ Yellow {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Yellow color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


Yellow012 Property

Yellow012 Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPantoneColor Class : Yellow012 Property

Gets the PANTONE Yellow 012 color.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Yellow012 As PDFPantoneColor
Visual Basic (Usage) Copy Code
Dim value As PDFPantoneColor

value = PDFPantoneColor.Yellow012
C#
public static PDFPantoneColor Yellow012 {get;}
Managed Extensions for C++
public: __property static PDFPantoneColor* get_Yellow012();
C++/CLI
public:
static property PDFPantoneColor^ Yellow012 {
   PDFPantoneColor^ get();
}

Return Value

A PDFPantoneColor object specifying the PANTONE Yellow 012 color.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPantoneColor Class
PDFPantoneColor Members


PDFPatternColorSpace Class

PDFPatternColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPatternColorSpace Class

Defines a pattern colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFPatternColorSpace
   Inherits PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFPatternColorSpace
C#
public class PDFPatternColorSpace : PDFColorSpace
Managed Extensions for C++
public __gc class PDFPatternColorSpace : public PDFColorSpace
C++/CLI
public ref class PDFPatternColorSpace : public PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFPatternColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPatternColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFPatternColorSpace Class Members

PDFPatternColorSpace Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPatternColorSpace Class

The following tables list the members exposed by PDFPatternColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFPatternColorSpace Constructor | Initializes a new PDFDeviceColorSpace object.
Top

Public Properties

 | Name | Description
Public Property | Pattern | Gets the pattern represented by this colorspace.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Top

See Also

Reference

PDFPatternColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFPatternColorSpace Constructor

PDFPatternColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPatternColorSpace Class : PDFPatternColorSpace Constructor

pattern
Initializes a new PDFDeviceColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pattern As PDFPattern _
)
Visual Basic (Usage) Copy Code
Dim pattern As PDFPattern

Dim instance As PDFPatternColorSpace(pattern)
C#
public PDFPatternColorSpace(
   PDFPattern pattern
)
Managed Extensions for C++
public: PDFPatternColorSpace(
   PDFPattern* pattern
)
C++/CLI
public:
PDFPatternColorSpace(
   PDFPattern^ pattern
)

Parameters

pattern

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPatternColorSpace Class
PDFPatternColorSpace Members


PDFPatternColorSpace Class Properties

PDFPatternColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFPatternColorSpace Class

For a list of all members of this type, see PDFPatternColorSpace members.

Public Properties

 | Name | Description
Public Property | Pattern | Gets the pattern represented by this colorspace.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Top

See Also

Reference

PDFPatternColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


Pattern Property

Pattern Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFPatternColorSpace Class : Pattern Property

Gets the pattern represented by this colorspace.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pattern As PDFPattern
Visual Basic (Usage) Copy Code
Dim instance As PDFPatternColorSpace
Dim value As PDFPattern

value = instance.Pattern
C#
public PDFPattern Pattern {get;}
Managed Extensions for C++
public: __property PDFPattern* get_Pattern();
C++/CLI
public:
property PDFPattern^ Pattern {
   PDFPattern^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPatternColorSpace Class
PDFPatternColorSpace Members


PDFSeparationColorSpace Class

PDFSeparationColorSpace Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColorSpace Class

Defines a separation colorspace.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSeparationColorSpace
   Inherits PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpace
C#
public class PDFSeparationColorSpace : PDFColorSpace
Managed Extensions for C++
public __gc class PDFSeparationColorSpace : public PDFColorSpace
C++/CLI
public ref class PDFSeparationColorSpace : public PDFColorSpace

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpace
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFSeparationColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpace Members
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFSeparationColorSpace Class Members

PDFSeparationColorSpace Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColorSpace Class

The following tables list the members exposed by PDFSeparationColorSpace.

Public Constructors

 | Name | Description
Public Constructor | PDFSeparationColorSpace Constructor | Overloaded. Initializes a new PDFSeparationColorSpace object.
Top

Public Properties

 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | Colorant | Gets or sets the colorant represented by this separation colorspace.
Public Property | TintTransform | Gets or sets the tint transform function for the this colorspace.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Top

See Also

Reference

PDFSeparationColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFSeparationColorSpace Constructor

PDFSeparationColorSpace Constructor
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class : PDFSeparationColorSpace Constructor

Initializes a new PDFSeparationColorSpace object.

Overload List

Overload | Description
PDFSeparationColorSpace Constructor() | Initializes a new PDFSeparationColorSpace object.
PDFSeparationColorSpace Constructor(PDFArray) | Initializes a new PDFSeparationColorSpace object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members


PDFSeparationColorSpace Constructor()

PDFSeparationColorSpace Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class > PDFSeparationColorSpace Constructor : PDFSeparationColorSpace Constructor()

Initializes a new PDFSeparationColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpace()
C#
public PDFSeparationColorSpace()
Managed Extensions for C++
public: PDFSeparationColorSpace();
C++/CLI
public:
PDFSeparationColorSpace();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members
Overload List


PDFSeparationColorSpace Constructor(PDFArray)

PDFSeparationColorSpace Constructor(PDFArray)
See Also
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class > PDFSeparationColorSpace Constructor : PDFSeparationColorSpace Constructor(PDFArray)

rawColorSpace
Initializes a new PDFSeparationColorSpace object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rawColorSpace As PDFArray _
)
Visual Basic (Usage) Copy Code
Dim rawColorSpace As PDFArray

Dim instance As PDFSeparationColorSpace(rawColorSpace)
C#
public PDFSeparationColorSpace(
   PDFArray rawColorSpace
)
Managed Extensions for C++
public: PDFSeparationColorSpace(
   PDFArray* rawColorSpace
)
C++/CLI
public:
PDFSeparationColorSpace(
   PDFArray^ rawColorSpace
)

Parameters

rawColorSpace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members
Overload List


PDFSeparationColorSpace Class Properties

PDFSeparationColorSpace Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFSeparationColorSpace Class

For a list of all members of this type, see PDFSeparationColorSpace members.

Public Properties

 | Name | Description
Public Property | AlternateColorSpace | Gets or sets the alternate colorspace.
Public Property | Colorant | Gets or sets the colorant represented by this separation colorspace.
Public Property | TintTransform | Gets or sets the tint transform function for the this colorspace.
Public Property | Type | Gets the type of this colorspace. (Inherited from PDFColorSpace)
Top

See Also

Reference

PDFSeparationColorSpace Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


AlternateColorSpace Property

AlternateColorSpace Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class : AlternateColorSpace Property

Gets or sets the alternate colorspace.

Syntax

Visual Basic (Declaration)
Public Property AlternateColorSpace As PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpace
Dim value As PDFColorSpace

instance.AlternateColorSpace = value

value = instance.AlternateColorSpace
C#
public PDFColorSpace AlternateColorSpace {get; set;}
Managed Extensions for C++
public: __property PDFColorSpace* get_AlternateColorSpace();
public: __property void set_AlternateColorSpace(
   PDFColorSpace* value
);
C++/CLI
public:
property PDFColorSpace^ AlternateColorSpace {
   PDFColorSpace^ get();
   void set (PDFColorSpace^ value);
}

Return Value

The alternate color space to be used when the destination device does not support separation colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members


Colorant Property

Colorant Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class : Colorant Property

Gets or sets the colorant represented by this separation colorspace.

Syntax

Visual Basic (Declaration)
Public Property Colorant As String
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpace
Dim value As String

instance.Colorant = value

value = instance.Colorant
C#
public string Colorant {get; set;}
Managed Extensions for C++
public: __property string* get_Colorant();
public: __property void set_Colorant(
   string* value
);
C++/CLI
public:
property String^ Colorant {
   String^ get();
   void set (String^ value);
}

Return Value

The name of the colorant.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members


TintTransform Property

TintTransform Property
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace > PDFSeparationColorSpace Class : TintTransform Property

Gets or sets the tint transform function for the this colorspace.

Syntax

Visual Basic (Declaration)
Public Property TintTransform As PDFFunction
Visual Basic (Usage) Copy Code
Dim instance As PDFSeparationColorSpace
Dim value As PDFFunction

instance.TintTransform = value

value = instance.TintTransform
C#
public PDFFunction TintTransform {get; set;}
Managed Extensions for C++
public: __property PDFFunction* get_TintTransform();
public: __property void set_TintTransform(
   PDFFunction* value
);
C++/CLI
public:
property PDFFunction^ TintTransform {
   PDFFunction^ get();
   void set (PDFFunction^ value);
}

Return Value

Tint transform function for the colorspace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSeparationColorSpace Class
PDFSeparationColorSpace Members


PDFColorSpaceType Enumeration

PDFColorSpaceType Enumeration
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpaceType Enumeration

Defines the available colorspace types.

Syntax

Visual Basic (Declaration)
Public Enum PDFColorSpaceType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFColorSpaceType
C#
public enum PDFColorSpaceType : Enum
Managed Extensions for C++
__value public enum PDFColorSpaceType : public Enum
C++/CLI
public enum class PDFColorSpaceType : public Enum

Members

Member | Description
Unknown | Unknown colorspace.
DeviceRGB | RGB device colorspace.
DeviceCMYK | CMYK device colorspace.
DeviceGray | Gray device colorspace.
CalGray | Calibrated gray colorspace.
CalRGB | Calibrated RGB colorspace.
Lab | Lab colorspace.
ICCBased | ICC based colorspace.
Indexed | Indexed colorspace.
Separation | Separation colorspace.
DeviceN | DeviceN colorspace.
Pattern | Pattern colorspace.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFColorSpaceType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFDeviceColorSpaceType Enumeration

PDFDeviceColorSpaceType Enumeration
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceColorSpaceType Enumeration

Defines the available device colorspace types.

Syntax

Visual Basic (Declaration)
Public Enum PDFDeviceColorSpaceType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFDeviceColorSpaceType
C#
public enum PDFDeviceColorSpaceType : Enum
Managed Extensions for C++
__value public enum PDFDeviceColorSpaceType : public Enum
C++/CLI
public enum class PDFDeviceColorSpaceType : public Enum

Members

Member | Description
DeviceRGB | RGB device colorspace.
DeviceCMYK | CMYK device colorspace.
DeviceGray | Gray device colorspace.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.ColorSpaces.PDFDeviceColorSpaceType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


O2S.Components.PDF4NET.Graphics.Fonts Namespace

O2S.Components.PDF4NET.Graphics.Fonts Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
CJKFont | Defines a font for east asian languages (chinese, japanese and korean).
PDFFont | Defines a particular format for text, including font face and size.
PDFFontBase | Base class for all PDF fonts.
PDFFontMetrics | Defines the metrics for a font object used in the pdf file.
PostScriptFont | Defines a particular format for text, including font face and size.
TrueTypeFont | Defines a TrueType font that can be used in a PDF file.
Type0Font | Defines a generic Type0 font that can be used in a PDF file.

Enumerations

Enumeration | Description
CJKFontFace | Defines the available CJK fonts faces.
PDFFontFace | Specifies the available PDF fonts for drawing text on a page

See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET.Graphics.Fonts Namespace Inheritance Hierarchy

O2S.Components.PDF4NET.Graphics.Fonts Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDF4NET.Graphics.Fonts.CJKFont
O2S.Components.PDF4NET.Graphics.Fonts.PDFFont
O2S.Components.PDF4NET.Graphics.Fonts.PostScriptFont
O2S.Components.PDF4NET.Graphics.Fonts.TrueTypeFont
O2S.Components.PDF4NET.Graphics.Fonts.Type0Font
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontMetrics

See Also

Reference

O2S.Components.PDF4NET Assembly


CJKFont Class

CJKFont Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : CJKFont Class

Defines a font for east asian languages (chinese, japanese and korean).

Object Model

Syntax

Visual Basic (Declaration)
Public Class CJKFont
   Inherits PDFFontBase
Visual Basic (Usage) Copy Code
Dim instance As CJKFont
C#
public class CJKFont : PDFFontBase
Managed Extensions for C++
public __gc class CJKFont : public PDFFontBase
C++/CLI
public ref class CJKFont : public PDFFontBase

Remarks

The fonts defined by this class are based on Asian Language Pack for Adobe Acrobat and Adobe Acrobat Reader products.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDF4NET.Graphics.Fonts.CJKFont

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CJKFont Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


CJKFont Class Members

CJKFont Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : CJKFont Class

The following tables list the members exposed by CJKFont.

Public Constructors

 | Name | Description
Public Constructor | CJKFont Constructor | Overloaded. Initializes a new CJKFont object with the specified CJKFontFace and size.
Top

Public Properties

 | Name | Description
Public Property | Bold | Overridden. Gets or sets whether the font object is bold or not.
Public Property | CJKFontFace | Gets of sets the cjk font face.
Public Property | Italic | Overridden. Gets or sets whether the font object is italic or not.
Public Property | Metrics | Gets the metrics of this font object. (Inherited from PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from PDFFontBase)
Top

Public Methods

 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from PDFFontBase)
Top

See Also

Reference

CJKFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


CJKFont Constructor

CJKFont Constructor
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class : CJKFont Constructor

Initializes a new CJKFont object with the specified CJKFontFace and size.

Overload List

Overload | Description
CJKFont Constructor(CJKFont) | Initializes a new CJKFont object based on an existing font.
CJKFont Constructor(CJKFontFace,Single) | Initializes a new CJKFont object with the specified CJKFontFace and size.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CJKFont Class
CJKFont Members


CJKFont Constructor(CJKFont)

CJKFont Constructor(CJKFont)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class > CJKFont Constructor : CJKFont Constructor(CJKFont)

font
a CJKFont object to be copied in the new font.
Initializes a new CJKFont object based on an existing font.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal font As CJKFont _
)
Visual Basic (Usage) Copy Code
Dim font As CJKFont

Dim instance As CJKFont(font)
C#
public CJKFont(
   CJKFont font
)
Managed Extensions for C++
public: CJKFont(
   CJKFont* font
)
C++/CLI
public:
CJKFont(
   CJKFont^ font
)

Parameters

font
a CJKFont object to be copied in the new font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CJKFont Class
CJKFont Members
Overload List


CJKFont Constructor(CJKFontFace,Single)

CJKFont Constructor(CJKFontFace,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class > CJKFont Constructor : CJKFont Constructor(CJKFontFace,Single)

cjkFontFace
a CJKFontFace enumeration member specifying the font face
size
a float value specifying the size of the font in points
Initializes a new CJKFont object with the specified CJKFontFace and size.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cjkFontFace As CJKFontFace, _
   ByVal size As Single _
)
Visual Basic (Usage) Copy Code
Dim cjkFontFace As CJKFontFace
Dim size As Single

Dim instance As CJKFont(cjkFontFace, size)
C#
public CJKFont(
   CJKFontFace cjkFontFace,
   float size
)
Managed Extensions for C++
public: CJKFont(
   CJKFontFace cjkFontFace,
   float size
)
C++/CLI
public:
CJKFont(
   CJKFontFace cjkFontFace,
   float size
)

Parameters

cjkFontFace
a CJKFontFace enumeration member specifying the font face
size
a float value specifying the size of the font in points

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CJKFont Class
CJKFont Members
Overload List


CJKFont Class Methods

CJKFont Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : CJKFont Class

For a list of all members of this type, see CJKFont members.

Public Methods

 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from PDFFontBase)
Top

See Also

Reference

CJKFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


GetCharWidth Method

GetCharWidth Method
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class : GetCharWidth Method

charCode
the char to get its width
Gets the width of the given character when drawn with this font object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As CJKFont
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
C#
public override double GetCharWidth(
   char charCode
)
Managed Extensions for C++
public: double GetCharWidth(
   char charCode
) override
C++/CLI
public:
double GetCharWidth(
   char charCode
) override

Parameters

charCode
the char to get its width

Return Value

This method returns a float value that represents the width, in unscaled glyph units, of the given character.

Remarks

To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CJKFont Class
CJKFont Members


CJKFont Class Properties

CJKFont Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : CJKFont Class

For a list of all members of this type, see CJKFont members.

Public Properties

 | Name | Description
Public Property | Bold | Overridden. Gets or sets whether the font object is bold or not.
Public Property | CJKFontFace | Gets of sets the cjk font face.
Public Property | Italic | Overridden. Gets or sets whether the font object is italic or not.
Public Property | Metrics | Gets the metrics of this font object. (Inherited from PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from PDFFontBase)
Top

See Also

Reference

CJKFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


Bold Property

Bold Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class : Bold Property

Gets or sets whether the font object is bold or not.

Syntax

Visual Basic (Declaration)
Overrides Public Property Bold As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CJKFont
Dim value As Boolean

instance.Bold = value

value = instance.Bold
C#
public override bool Bold {get; set;}
Managed Extensions for C++
public: __property bool get_Bold()override ;
public: __property void set_Bold(
   bool value
)override ;
C++/CLI
public:
property bool Bold override {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this font object is bold; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CJKFont Class
CJKFont Members


CJKFontFace Property

CJKFontFace Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class : CJKFontFace Property

Gets of sets the cjk font face.

Syntax

Visual Basic (Declaration)
Public Property CJKFontFace As CJKFontFace
Visual Basic (Usage) Copy Code
Dim instance As CJKFont
Dim value As CJKFontFace

instance.CJKFontFace = value

value = instance.CJKFontFace
C#
public CJKFontFace CJKFontFace {get; set;}
Managed Extensions for C++
public: __property CJKFontFace get_CJKFontFace();
public: __property void set_CJKFontFace(
   CJKFontFace value
);
C++/CLI
public:
property CJKFontFace CJKFontFace {
   CJKFontFace get();
   void set (CJKFontFace value);
}

Return Value

a CJKFontFace enumeration member specifying the cjk font face.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CJKFont Class
CJKFont Members


Italic Property

Italic Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > CJKFont Class : Italic Property

Gets or sets whether the font object is italic or not.

Syntax

Visual Basic (Declaration)
Overrides Public Property Italic As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CJKFont
Dim value As Boolean

instance.Italic = value

value = instance.Italic
C#
public override bool Italic {get; set;}
Managed Extensions for C++
public: __property bool get_Italic()override ;
public: __property void set_Italic(
   bool value
)override ;
C++/CLI
public:
property bool Italic override {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this font object is italic; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

CJKFont Class
CJKFont Members


PDFFont Class

PDFFont Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFont Class

Defines a particular format for text, including font face and size.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFont
   Inherits PDFFontBase
Visual Basic (Usage) Copy Code
Dim instance As PDFFont
C#
public class PDFFont : PDFFontBase
Managed Extensions for C++
public __gc class PDFFont : public PDFFontBase
C++/CLI
public ref class PDFFont : public PDFFontBase

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDF4NET.Graphics.Fonts.PDFFont

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


PDFFont Class Members

PDFFont Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFont Class

The following tables list the members exposed by PDFFont.

Public Constructors

 | Name | Description
Public Constructor | PDFFont Constructor | Overloaded. Initializes a new PDFFont object
Top

Public Properties

 | Name | Description
Public Property | Bold | Overridden. Gets or sets whether the font object is bold or not.
Public Property | FontFace | Gets or sets the font face
Public Property | Italic | Overridden. Gets or sets whether the font object is italic or not.
Public Property | Metrics | Gets the metrics of this font object. (Inherited from PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from PDFFontBase)
Top

Public Methods

 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from PDFFontBase)
Top

See Also

Reference

PDFFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


PDFFont Constructor

PDFFont Constructor
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFont Class : PDFFont Constructor

Initializes a new PDFFont object

Overload List

Overload | Description
PDFFont Constructor() | Initializes a new PDFFont object
PDFFont Constructor(PDFFont) | Initializes a new PDFFont object based on an existing font.
PDFFont Constructor(PDFFontFace,Single) | Initializes a new PDFFont object of specified FontFace and size.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members


PDFFont Constructor()

PDFFont Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFont Class > PDFFont Constructor : PDFFont Constructor()

Initializes a new PDFFont object

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFFont()
C#
public PDFFont()
Managed Extensions for C++
public: PDFFont();
C++/CLI
public:
PDFFont();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members
Overload List


PDFFont Constructor(PDFFont)

PDFFont Constructor(PDFFont)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFont Class > PDFFont Constructor : PDFFont Constructor(PDFFont)

font
a PDFFont object to be copied in the new font.
Initializes a new PDFFont object based on an existing font.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal font As PDFFont _
)
Visual Basic (Usage) Copy Code
Dim font As PDFFont

Dim instance As PDFFont(font)
C#
public PDFFont(
   PDFFont font
)
Managed Extensions for C++
public: PDFFont(
   PDFFont* font
)
C++/CLI
public:
PDFFont(
   PDFFont^ font
)

Parameters

font
a PDFFont object to be copied in the new font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members
Overload List


PDFFont Constructor(PDFFontFace,Single)

PDFFont Constructor(PDFFontFace,Single)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFont Class > PDFFont Constructor : PDFFont Constructor(PDFFontFace,Single)

fontFace
a FontFace enumeration member specifying the font face
size
a float value specifying the size of the font in points
Initializes a new PDFFont object of specified FontFace and size.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fontFace As PDFFontFace, _
   ByVal size As Single _
)
Visual Basic (Usage) Copy Code
Dim fontFace As PDFFontFace
Dim size As Single

Dim instance As PDFFont(fontFace, size)
C#
public PDFFont(
   PDFFontFace fontFace,
   float size
)
Managed Extensions for C++
public: PDFFont(
   PDFFontFace fontFace,
   float size
)
C++/CLI
public:
PDFFont(
   PDFFontFace fontFace,
   float size
)

Parameters

fontFace
a FontFace enumeration member specifying the font face
size
a float value specifying the size of the font in points

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members
Overload List


PDFFont Class Methods

PDFFont Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFont Class

For a list of all members of this type, see PDFFont members.

Public Methods

 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from PDFFontBase)
Top

See Also

Reference

PDFFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


GetCharWidth Method

GetCharWidth Method
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFont Class : GetCharWidth Method

charCode
the char to get its width
Gets the width of the given character when drawn with this font object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFFont
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
C#
public override double GetCharWidth(
   char charCode
)
Managed Extensions for C++
public: double GetCharWidth(
   char charCode
) override
C++/CLI
public:
double GetCharWidth(
   char charCode
) override

Parameters

charCode
the char to get its width

Return Value

This method returns a float value that represents the width, in unscaled glyph units, of the given character.

Remarks

To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members


PDFFont Class Properties

PDFFont Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFont Class

For a list of all members of this type, see PDFFont members.

Public Properties

 | Name | Description
Public Property | Bold | Overridden. Gets or sets whether the font object is bold or not.
Public Property | FontFace | Gets or sets the font face
Public Property | Italic | Overridden. Gets or sets whether the font object is italic or not.
Public Property | Metrics | Gets the metrics of this font object. (Inherited from PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from PDFFontBase)
Top

See Also

Reference

PDFFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


Bold Property

Bold Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFont Class : Bold Property

Gets or sets whether the font object is bold or not.

Syntax

Visual Basic (Declaration)
Overrides Public Property Bold As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFont
Dim value As Boolean

instance.Bold = value

value = instance.Bold
C#
public override bool Bold {get; set;}
Managed Extensions for C++
public: __property bool get_Bold()override ;
public: __property void set_Bold(
   bool value
)override ;
C++/CLI
public:
property bool Bold override {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this font object is bold; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members


FontFace Property

FontFace Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFont Class : FontFace Property

Gets or sets the font face

Syntax

Visual Basic (Declaration)
Public Property FontFace As PDFFontFace
Visual Basic (Usage) Copy Code
Dim instance As PDFFont
Dim value As PDFFontFace

instance.FontFace = value

value = instance.FontFace
C#
public PDFFontFace FontFace {get; set;}
Managed Extensions for C++
public: __property PDFFontFace get_FontFace();
public: __property void set_FontFace(
   PDFFontFace value
);
C++/CLI
public:
property PDFFontFace FontFace {
   PDFFontFace get();
   void set (PDFFontFace value);
}

Return Value

a FontFace enumeration member specifying the font face

Remarks

When creating a PDFFont object using the default constructor, the default value of this property is set to Helvetica

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members


Italic Property

Italic Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFont Class : Italic Property

Gets or sets whether the font object is italic or not.

Syntax

Visual Basic (Declaration)
Overrides Public Property Italic As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFont
Dim value As Boolean

instance.Italic = value

value = instance.Italic
C#
public override bool Italic {get; set;}
Managed Extensions for C++
public: __property bool get_Italic()override ;
public: __property void set_Italic(
   bool value
)override ;
C++/CLI
public:
property bool Italic override {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this font object is italic; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFont Class
PDFFont Members


PDFFontBase Class

PDFFontBase Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontBase Class

Base class for all PDF fonts.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFFontBase
Visual Basic (Usage) Copy Code
Dim instance As PDFFontBase
C#
public abstract class PDFFontBase
Managed Extensions for C++
public __gc abstract class PDFFontBase
C++/CLI
public ref class PDFFontBase abstract

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDF4NET.Graphics.Fonts.Type0Font
O2S.Components.PDF4NET.Graphics.Fonts.TrueTypeFont
O2S.Components.PDF4NET.Graphics.Fonts.PostScriptFont
O2S.Components.PDF4NET.Graphics.Fonts.PDFFont
O2S.Components.PDF4NET.Graphics.Fonts.CJKFont

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontBase Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


PDFFontBase Class Members

PDFFontBase Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontBase Class

The following tables list the members exposed by PDFFontBase.

Public Properties

 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not.
Public Property | Italic | Gets or sets whether the font object is italic or not.
Public Property | Metrics | Gets the metrics of this font object.
Public Property | Overline | Gets or sets whether the font object is overline or not.
Public Property | Size | Gets or sets the font size.
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not.
Public Property | Underline | Gets or sets whether the font object is underline or not.
Top

Public Methods

 | Name | Description
Public Method | GetCharWidth | Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object.
Top

See Also

Reference

PDFFontBase Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


PDFFontBase Class Methods

PDFFontBase Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontBase Class

For a list of all members of this type, see PDFFontBase members.

Public Methods

 | Name | Description
Public Method | GetCharWidth | Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object.
Top

See Also

Reference

PDFFontBase Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


GetCharWidth Method

GetCharWidth Method
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : GetCharWidth Method

charCode
the char to get its width
Gets the width of the given character when drawn with this font object.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFFontBase
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
C#
public virtual double GetCharWidth(
   char charCode
)
Managed Extensions for C++
public: virtual double GetCharWidth(
   char charCode
)
C++/CLI
public:
virtual double GetCharWidth(
   char charCode
)

Parameters

charCode
the char to get its width

Return Value

This method returns a float value that represents the width, in unscaled glyph units, of the given character.

Remarks

To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontBase Class
PDFFontBase Members


MeasureString Method

MeasureString Method
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : MeasureString Method

text
The string to measure
Measures the specified string when drawn with this font object.

Syntax

Visual Basic (Declaration)
Public Overridable Function MeasureString( _
   ByVal text As String _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFFontBase
Dim text As String
Dim value As Double

value = instance.MeasureString(text)
C#
public virtual double MeasureString(
   string text
)
Managed Extensions for C++
public: virtual double MeasureString(
   string* text
)
C++/CLI
public:
virtual double MeasureString(
   String^ text
)

Parameters

text
The string to measure

Return Value

This method returns a float value that represents the size, in points, of the string specified by the text parameter as drawn with this font object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontBase Class
PDFFontBase Members


PDFFontBase Class Properties

PDFFontBase Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontBase Class

For a list of all members of this type, see PDFFontBase members.

Public Properties

 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not.
Public Property | Italic | Gets or sets whether the font object is italic or not.
Public Property | Metrics | Gets the metrics of this font object.
Public Property | Overline | Gets or sets whether the font object is overline or not.
Public Property | Size | Gets or sets the font size.
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not.
Public Property | Underline | Gets or sets whether the font object is underline or not.
Top

See Also

Reference

PDFFontBase Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


Bold Property

Bold Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : Bold Property

Gets or sets whether the font object is bold or not.

Syntax

Visual Basic (Declaration)
Public Overridable Property Bold As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFontBase
Dim value As Boolean

instance.Bold = value

value = instance.Bold
C#
public virtual bool Bold {get; set;}
Managed Extensions for C++
public: __property virtual bool get_Bold();
public: __property virtual void set_Bold(
   bool value
);
C++/CLI
public:
virtual property bool Bold {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this font object is bold; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontBase Class
PDFFontBase Members


Italic Property

Italic Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : Italic Property

Gets or sets whether the font object is italic or not.

Syntax

Visual Basic (Declaration)
Public Overridable Property Italic As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFontBase
Dim value As Boolean

instance.Italic = value

value = instance.Italic
C#
public virtual bool Italic {get; set;}
Managed Extensions for C++
public: __property virtual bool get_Italic();
public: __property virtual void set_Italic(
   bool value
);
C++/CLI
public:
virtual property bool Italic {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this font object is italic; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontBase Class
PDFFontBase Members


Metrics Property

Metrics Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : Metrics Property

Gets the metrics of this font object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Metrics As PDFFontMetrics
Visual Basic (Usage) Copy Code
Dim instance As PDFFontBase
Dim value As PDFFontMetrics

value = instance.Metrics
C#
public PDFFontMetrics Metrics {get;}
Managed Extensions for C++
public: __property PDFFontMetrics* get_Metrics();
C++/CLI
public:
property PDFFontMetrics^ Metrics {
   PDFFontMetrics^ get();
}

Return Value

A PDFFontMetrics object specifying the metrics of this font object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontBase Class
PDFFontBase Members


Overline Property

Overline Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : Overline Property

Gets or sets whether the font object is overline or not.

Syntax

Visual Basic (Declaration)
Public Property Overline As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFontBase
Dim value As Boolean

instance.Overline = value

value = instance.Overline
C#
public bool Overline {get; set;}
Managed Extensions for C++
public: __property bool get_Overline();
public: __property void set_Overline(
   bool value
);
C++/CLI
public:
property bool Overline {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this PDFFont object is overline; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontBase Class
PDFFontBase Members


Size Property

Size Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : Size Property

Gets or sets the font size.

Syntax

Visual Basic (Declaration)
Public Property Size As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFFontBase
Dim value As Double

instance.Size = value

value = instance.Size
C#
public double Size {get; set;}
Managed Extensions for C++
public: __property double get_Size();
public: __property void set_Size(
   double value
);
C++/CLI
public:
property double Size {
   double get();
   void set (double value);
}

Return Value

a float value specifyig the size of the font in points (1/72 inches)

Remarks

The size of a font is always given in points, it does not matter the logical unit used for positioning the text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontBase Class
PDFFontBase Members


Strikethrough Property

Strikethrough Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : Strikethrough Property

Gets or sets whether the font object is strikethrough or not.

Syntax

Visual Basic (Declaration)
Public Property Strikethrough As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFontBase
Dim value As Boolean

instance.Strikethrough = value

value = instance.Strikethrough
C#
public bool Strikethrough {get; set;}
Managed Extensions for C++
public: __property bool get_Strikethrough();
public: __property void set_Strikethrough(
   bool value
);
C++/CLI
public:
property bool Strikethrough {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this font object is strikethrough; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontBase Class
PDFFontBase Members


Underline Property

Underline Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontBase Class : Underline Property

Gets or sets whether the font object is underline or not.

Syntax

Visual Basic (Declaration)
Public Property Underline As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFFontBase
Dim value As Boolean

instance.Underline = value

value = instance.Underline
C#
public bool Underline {get; set;}
Managed Extensions for C++
public: __property bool get_Underline();
public: __property void set_Underline(
   bool value
);
C++/CLI
public:
property bool Underline {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this font object is underline; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontBase Class
PDFFontBase Members


PDFFontMetrics Class

PDFFontMetrics Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontMetrics Class

Defines the metrics for a font object used in the pdf file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFontMetrics
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
C#
public class PDFFontMetrics
Managed Extensions for C++
public __gc class PDFFontMetrics
C++/CLI
public ref class PDFFontMetrics

Remarks

The values of the properties of this class are given in unscaled glyph units. To convert the values to points, divide by 1000 then multiply by font size (points).

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontMetrics

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


PDFFontMetrics Class Members

PDFFontMetrics Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontMetrics Class

The following tables list the members exposed by PDFFontMetrics.

Public Properties

 | Name | Description
Public Property | Ascent | Gets the ascent of the font.
Public Property | AverageWidth | Gets the average width of glyphs in the font.
Public Property | BoundingBox | Gets the font's bounding box.
Public Property | CapHeight | Gets the capHeight of the font.
Public Property | Descent | Gets the descent of the font.
Public Property | Leading | Gets the leading of the font.
Public Property | MaxWidth | Gets the maximum width of glyphs in the font.
Public Property | Name | Gets the Postscript name of the font.
Public Property | StemH | Gets the horizontal stem of the font.
Public Property | StemV | Gets the vertical stem of the font.
Public Property | XHeight | Gets the x height of the font.
Top

See Also

Reference

PDFFontMetrics Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


PDFFontMetrics Class Properties

PDFFontMetrics Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontMetrics Class

For a list of all members of this type, see PDFFontMetrics members.

Public Properties

 | Name | Description
Public Property | Ascent | Gets the ascent of the font.
Public Property | AverageWidth | Gets the average width of glyphs in the font.
Public Property | BoundingBox | Gets the font's bounding box.
Public Property | CapHeight | Gets the capHeight of the font.
Public Property | Descent | Gets the descent of the font.
Public Property | Leading | Gets the leading of the font.
Public Property | MaxWidth | Gets the maximum width of glyphs in the font.
Public Property | Name | Gets the Postscript name of the font.
Public Property | StemH | Gets the horizontal stem of the font.
Public Property | StemV | Gets the vertical stem of the font.
Public Property | XHeight | Gets the x height of the font.
Top

See Also

Reference

PDFFontMetrics Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


Ascent Property

Ascent Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : Ascent Property

Gets the ascent of the font.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Ascent As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Double

value = instance.Ascent
C#
public double Ascent {get;}
Managed Extensions for C++
public: __property double get_Ascent();
C++/CLI
public:
property double Ascent {
   double get();
}

Return Value

A double value specifying the maximum height above the baseline reached by glyphs in this font, excluding the height of glyphs for accented characters.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


AverageWidth Property

AverageWidth Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : AverageWidth Property

Gets the average width of glyphs in the font.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AverageWidth As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Double

value = instance.AverageWidth
C#
public double AverageWidth {get;}
Managed Extensions for C++
public: __property double get_AverageWidth();
C++/CLI
public:
property double AverageWidth {
   double get();
}

Return Value

A double value specifying the average width of glyphs in the font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


BoundingBox Property

BoundingBox Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : BoundingBox Property

Gets the font's bounding box.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BoundingBox As PDFRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As PDFRectangle

value = instance.BoundingBox
C#
public PDFRectangle BoundingBox {get;}
Managed Extensions for C++
public: __property PDFRectangle* get_BoundingBox();
C++/CLI
public:
property PDFRectangle^ BoundingBox {
   PDFRectangle^ get();
}

Return Value

A PDFRectangle object specifying the font's bounding box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


CapHeight Property

CapHeight Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : CapHeight Property

Gets the capHeight of the font.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CapHeight As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Double

value = instance.CapHeight
C#
public double CapHeight {get;}
Managed Extensions for C++
public: __property double get_CapHeight();
C++/CLI
public:
property double CapHeight {
   double get();
}

Return Value

A double value specifying the vertical coordinate of the top of flat capital letters, measured from the baseline.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


Descent Property

Descent Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : Descent Property

Gets the descent of the font.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Descent As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Double

value = instance.Descent
C#
public double Descent {get;}
Managed Extensions for C++
public: __property double get_Descent();
C++/CLI
public:
property double Descent {
   double get();
}

Return Value

A double value specifying the maximum depth below the baseline reached by glyphs in this font. This value is a negative number.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


Leading Property

Leading Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : Leading Property

Gets the leading of the font.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Leading As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Double

value = instance.Leading
C#
public double Leading {get;}
Managed Extensions for C++
public: __property double get_Leading();
C++/CLI
public:
property double Leading {
   double get();
}

Return Value

A double value specifying the desired spacing between baselines of consecutives lines of text.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


MaxWidth Property

MaxWidth Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : MaxWidth Property

Gets the maximum width of glyphs in the font.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MaxWidth As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Double

value = instance.MaxWidth
C#
public double MaxWidth {get;}
Managed Extensions for C++
public: __property double get_MaxWidth();
C++/CLI
public:
property double MaxWidth {
   double get();
}

Return Value

A double value specifying the maximum width of glyphs in the font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


Name Property

Name Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : Name Property

Gets the Postscript name of the font.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As String

value = instance.Name
C#
public string Name {get;}
Managed Extensions for C++
public: __property string* get_Name();
C++/CLI
public:
property String^ Name {
   String^ get();
}

Return Value

The name of the font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


StemH Property

StemH Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : StemH Property

Gets the horizontal stem of the font.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StemH As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Double

value = instance.StemH
C#
public double StemH {get;}
Managed Extensions for C++
public: __property double get_StemH();
C++/CLI
public:
property double StemH {
   double get();
}

Return Value

A double value specifying the thickness, measured invertically, of the dominant horizontal stems of glyphs in the font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


StemV Property

StemV Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : StemV Property

Gets the vertical stem of the font.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StemV As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Double

value = instance.StemV
C#
public double StemV {get;}
Managed Extensions for C++
public: __property double get_StemV();
C++/CLI
public:
property double StemV {
   double get();
}

Return Value

A double value specifying the thickness, measure horizontally, of the dominant vertical stems of glyphs in the font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


XHeight Property

XHeight Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PDFFontMetrics Class : XHeight Property

Gets the x height of the font.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property XHeight As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFFontMetrics
Dim value As Double

value = instance.XHeight
C#
public double XHeight {get;}
Managed Extensions for C++
public: __property double get_XHeight();
C++/CLI
public:
property double XHeight {
   double get();
}

Return Value

A double value specifying the vertical coordinate of the top of flat non-ascending lowercase letters (like letter x), measured from the baseline.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFontMetrics Class
PDFFontMetrics Members


PostScriptFont Class

PostScriptFont Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PostScriptFont Class

Defines a particular format for text, including font face and size.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PostScriptFont
   Inherits PDFFontBase
Visual Basic (Usage) Copy Code
Dim instance As PostScriptFont
C#
public sealed class PostScriptFont : PDFFontBase
Managed Extensions for C++
public __gc __sealed class PostScriptFont : public PDFFontBase
C++/CLI
public ref class PostScriptFont sealed : public PDFFontBase

Remarks

A PostScript font is always loaded from disk. The metrics of the font are specified in an .afm file (Adobe Font Metrics) and the binary representation of the font is specified in a .pfb file (Printer Font Binary).

The font can be embedded or not in the pdf file. When the font is embedded in the pdf file, the most accurate results are obtained when the file is viewed and printed. The viewer will synthesize the correct appearance of the font based on the embedded data, and the bold and italic modifiers do not have any effect.

If the font is not embedded in the pdf file, the pdf viewer will load the font from the local machine and will use it for display. If the font is not installed on the local machine, then the pdf viewer will use a local font that will match closely the metrics of the font used in the pdf file.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDF4NET.Graphics.Fonts.PostScriptFont

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostScriptFont Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


PostScriptFont Class Members

PostScriptFont Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PostScriptFont Class

The following tables list the members exposed by PostScriptFont.

Public Constructors

 | Name | Description
Public Constructor | PostScriptFont Constructor | Overloaded. Initializes a new PostScriptFont object based on the given metrics and font data files.
Top

Public Properties

 | Name | Description
Public Property | Bold | Overridden. Gets of sets whether the font object is bold or not.
Public Property | Italic | Overridden. Gets of sets whether the font object is italic or not
Public Property | Metrics | Gets the metrics of this font object. (Inherited from PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from PDFFontBase)
Top

Public Methods

 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from PDFFontBase)
Top

See Also

Reference

PostScriptFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


PostScriptFont Constructor

PostScriptFont Constructor
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PostScriptFont Class : PostScriptFont Constructor

Initializes a new PostScriptFont object based on the given metrics and font data files.

Overload List

Overload | Description
PostScriptFont Constructor(PostScriptFont,Double) | Initializes a new PostScriptFont object based on an existing font object.
PostScriptFont Constructor(String,String,Single,Boolean) | Initializes a new PostScriptFont object based on the given metrics and font data files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostScriptFont Class
PostScriptFont Members


PostScriptFont Constructor(PostScriptFont,Double)

PostScriptFont Constructor(PostScriptFont,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PostScriptFont Class > PostScriptFont Constructor : PostScriptFont Constructor(PostScriptFont,Double)

font
the original PostScriptFont object
size
the size of the new font
Initializes a new PostScriptFont object based on an existing font object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal font As PostScriptFont, _
   ByVal size As Double _
)
Visual Basic (Usage) Copy Code
Dim font As PostScriptFont
Dim size As Double

Dim instance As PostScriptFont(font, size)
C#
public PostScriptFont(
   PostScriptFont font,
   double size
)
Managed Extensions for C++
public: PostScriptFont(
   PostScriptFont* font,
   double size
)
C++/CLI
public:
PostScriptFont(
   PostScriptFont^ font,
   double size
)

Parameters

font
the original PostScriptFont object
size
the size of the new font

Remarks

Use this constructor when the same font (the same face)) is used multiple time but at different sizes. This will avoid reparsing the font file. Because the some of the internal structures are shared by the new and the original font object, changing the bold and italic modifiers for one font object, will also update the other font object. This is because the values of this modifiers are built in the font data. All the other properties of the font (underline, overline, strikethrough, size) can be changed without side effects. The embedding can not be changed for the new font, if the original font is embedded, this new font will use the same embedded data, in order to avoid redundancy.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostScriptFont Class
PostScriptFont Members
Overload List


PostScriptFont Constructor(String,String,Single,Boolean)

PostScriptFont Constructor(String,String,Single,Boolean)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PostScriptFont Class > PostScriptFont Constructor : PostScriptFont Constructor(String,String,Single,Boolean)

metricsFile
the full path to file containing the metrics for this PostScript font.
fontDataFile
the full path to file containing the binary representation of this PostScript font.
size
the size of the font, in points.
embed
a flag specifying whether the font should be embedded in the pdf file or not.
Initializes a new PostScriptFont object based on the given metrics and font data files.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal metricsFile As String, _
   ByVal fontDataFile As String, _
   ByVal size As Single, _
   ByVal embed As Boolean _
)
Visual Basic (Usage) Copy Code
Dim metricsFile As String
Dim fontDataFile As String
Dim size As Single
Dim embed As Boolean

Dim instance As PostScriptFont(metricsFile, fontDataFile, size, embed)
C#
public PostScriptFont(
   string metricsFile,
   string fontDataFile,
   float size,
   bool embed
)
Managed Extensions for C++
public: PostScriptFont(
   string* metricsFile,
   string* fontDataFile,
   float size,
   bool embed
)
C++/CLI
public:
PostScriptFont(
   String^ metricsFile,
   String^ fontDataFile,
   float size,
   bool embed
)

Parameters

metricsFile
the full path to file containing the metrics for this PostScript font.
fontDataFile
the full path to file containing the binary representation of this PostScript font.
size
the size of the font, in points.
embed
a flag specifying whether the font should be embedded in the pdf file or not.

Remarks

A PostScript font is always loaded from disk. The metrics of the font are specified using an .afm file (Adobe Font Metrics) or a .pfm file (Printer Font Metrics). The binary representation of the font is specified using a .pfb file (Printer Font Binary).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostScriptFont Class
PostScriptFont Members
Overload List


PostScriptFont Class Methods

PostScriptFont Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PostScriptFont Class

For a list of all members of this type, see PostScriptFont members.

Public Methods

 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from PDFFontBase)
Top

See Also

Reference

PostScriptFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


GetCharWidth Method

GetCharWidth Method
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PostScriptFont Class : GetCharWidth Method

charCode
the char to get its width
Gets the width of the given character when drawn with this font object.

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As PostScriptFont
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
C#
public override double GetCharWidth(
   char charCode
)
Managed Extensions for C++
public: double GetCharWidth(
   char charCode
) override
C++/CLI
public:
double GetCharWidth(
   char charCode
) override

Parameters

charCode
the char to get its width

Return Value

This method returns a float value that represents the width, in unscaled glyph units, of the given character.

Remarks

To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostScriptFont Class
PostScriptFont Members


PostScriptFont Class Properties

PostScriptFont Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PostScriptFont Class

For a list of all members of this type, see PostScriptFont members.

Public Properties

 | Name | Description
Public Property | Bold | Overridden. Gets of sets whether the font object is bold or not.
Public Property | Italic | Overridden. Gets of sets whether the font object is italic or not
Public Property | Metrics | Gets the metrics of this font object. (Inherited from PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from PDFFontBase)
Top

See Also

Reference

PostScriptFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


Bold Property

Bold Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PostScriptFont Class : Bold Property

Gets of sets whether the font object is bold or not.

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Property Bold As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PostScriptFont
Dim value As Boolean

instance.Bold = value

value = instance.Bold
C#
public override bool Bold {get; set;}
Managed Extensions for C++
public: __property bool get_Bold()override ;
public: __property void set_Bold(
   bool value
)override ;
C++/CLI
public:
property bool Bold override {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this Font object is bold; otherwise, false.

Remarks

When the Type1 font is embedded in the pdf file, the value of this property is ignored because the pdf viewer always renders the appropriate weight (bold or not) based on the embedded font. Embedding a regular font and setting this property to true will have no effect, when the font is embedded in the pdf file.

When the font is not embedded in the pdf file, this property is used to give a hint to the pdf viewer, in order for it to render the correct weight (assuming the font is installed on the local computer). It the bold face of the font is not installed on the local machine, and only the regular face is installed, the pdf viewer will synthesize the bold appearance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostScriptFont Class
PostScriptFont Members


Italic Property

Italic Property
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > PostScriptFont Class : Italic Property

Gets of sets whether the font object is italic or not

Syntax

Visual Basic (Declaration)
Overrides Public NotOverridable Property Italic As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PostScriptFont
Dim value As Boolean

instance.Italic = value

value = instance.Italic
C#
public override bool Italic {get; set;}
Managed Extensions for C++
public: __property bool get_Italic()override ;
public: __property void set_Italic(
   bool value
)override ;
C++/CLI
public:
property bool Italic override {
   bool get();
   void set (bool value);
}

Return Value

This property returns true if this Font object is italic; otherwise, false.

Remarks

When the Type1 font is embedded in the pdf file, the value of this property is ignored because the pdf viewer always renders the appropriate face (italic or not) based on the embedded font. Embedding a regular font and setting this property to true will have no effect, when the font is embedded in the pdf file.

When the font is not embedded in the pdf file, this property is used to give a hint to the pdf viewer, in order for it to render the correct face (assuming the font is installed on the local computer).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PostScriptFont Class
PostScriptFont Members


TrueTypeFont Class

TrueTypeFont Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : TrueTypeFont Class

Defines a TrueType font that can be used in a PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class TrueTypeFont
   Inherits PDFFontBase
Visual Basic (Usage) Copy Code
Dim instance As TrueTypeFont
C#
public class TrueTypeFont : PDFFontBase
Managed Extensions for C++
public __gc class TrueTypeFont : public PDFFontBase
C++/CLI
public ref class TrueTypeFont : public PDFFontBase

Remarks

The font can be embedded or not in the pdf file. When the font is embedded in the pdf file, the most accurate results are obtained when the file is viewed and printed. The viewer will synthesize the correct appearance of the font based on the embedded data, and the bold and italic modifiers do not have any effect.

If the font is not embedded in the pdf file, the pdf viewer will load the font from the local machine and will use it for display. If the font is not installed on the local machine, then the pdf viewer will use a local font that will match closely the metrics of the font used in the pdf file.

When the font is not emdedded in the pdf file, the bold and italic modifiers have the following effect: assuming that the font used for displaying text has only a regular face, these modifiers force the pdf viewer to synthesize the bold or italic appearance of the font. But the regular version of the font must be installed on the machine where the pdf file is viewed.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDF4NET.Graphics.Fonts.TrueTypeFont

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


TrueTypeFont Class Members

TrueTypeFont Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : TrueTypeFont Class

The following tables list the members exposed by TrueTypeFont.

Public Constructors

 | Name | Description
Public Constructor | TrueTypeFont Constructor | Overloaded. Initializes a new TrueTypeFont object based on the given font file and size.
Top

Public Properties

 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not. (Inherited from PDFFontBase)
Public Property | Italic | Gets or sets whether the font object is italic or not. (Inherited from PDFFontBase)
Public Property | Metrics | Gets the metrics of this font object. (Inherited from PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from PDFFontBase)
Top

Public Methods

 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from PDFFontBase)
Top

See Also

Reference

TrueTypeFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


TrueTypeFont Constructor

TrueTypeFont Constructor
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class : TrueTypeFont Constructor

Initializes a new TrueTypeFont object based on the given font file and size.

Overload List

Overload | Description
TrueTypeFont Constructor(Font,Boolean) | Initializes a new TrueTypeFont object based on a Font object.
TrueTypeFont Constructor(Font,Boolean,Boolean) | Initializes a new TrueTypeFont object based on a Font object.
TrueTypeFont Constructor(Stream,Single,Boolean) | Initializes a new TrueTypeFont object based on the given font stream and size.
TrueTypeFont Constructor(Stream,Single,Boolean,Boolean) | Initializes a new TrueTypeFont object based on the given font stream and size.
TrueTypeFont Constructor(String,Single,Boolean) | Initializes a new TrueTypeFont object based on the given font file and size.
TrueTypeFont Constructor(String,Single,Boolean,Boolean) | Initializes a new TrueTypeFont object based on the given font file and size.
TrueTypeFont Constructor(TrueTypeFont,Double) | Initializes a new TrueTypeFont object based on an existing font object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members


TrueTypeFont Constructor(Font,Boolean)

TrueTypeFont Constructor(Font,Boolean)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(Font,Boolean)

font
the System.Drawing.Font object.
embed
true, if the font file should be embedded in the pdf file.
Initializes a new TrueTypeFont object based on a Font object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal font As Font, _
   ByVal embed As Boolean _
)
Visual Basic (Usage) Copy Code
Dim font As Font
Dim embed As Boolean

Dim instance As TrueTypeFont(font, embed)
C#
public TrueTypeFont(
   Font font,
   bool embed
)
Managed Extensions for C++
public: TrueTypeFont(
   Font font,
   bool embed
)
C++/CLI
public:
TrueTypeFont(
   Font font,
   bool embed
)

Parameters

font
the System.Drawing.Font object.
embed
true, if the font file should be embedded in the pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


TrueTypeFont Constructor(Font,Boolean,Boolean)

TrueTypeFont Constructor(Font,Boolean,Boolean)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(Font,Boolean,Boolean)

font
the System.Drawing.Font object.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings
Initializes a new TrueTypeFont object based on a Font object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal font As Font, _
   ByVal embed As Boolean, _
   ByVal unicode As Boolean _
)
Visual Basic (Usage) Copy Code
Dim font As Font
Dim embed As Boolean
Dim unicode As Boolean

Dim instance As TrueTypeFont(font, embed, unicode)
C#
public TrueTypeFont(
   Font font,
   bool embed,
   bool unicode
)
Managed Extensions for C++
public: TrueTypeFont(
   Font font,
   bool embed,
   bool unicode
)
C++/CLI
public:
TrueTypeFont(
   Font font,
   bool embed,
   bool unicode
)

Parameters

font
the System.Drawing.Font object.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


TrueTypeFont Constructor(Stream,Single,Boolean)

TrueTypeFont Constructor(Stream,Single,Boolean)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(Stream,Single,Boolean)

trueTypeFontStream
a stream object with font data.
size
the size of the font, in points.
embed
true if the font file should be embedded in the pdf file.
Initializes a new TrueTypeFont object based on the given font stream and size.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal trueTypeFontStream As Stream, _
   ByVal size As Single, _
   ByVal embed As Boolean _
)
Visual Basic (Usage) Copy Code
Dim trueTypeFontStream As Stream
Dim size As Single
Dim embed As Boolean

Dim instance As TrueTypeFont(trueTypeFontStream, size, embed)
C#
public TrueTypeFont(
   Stream trueTypeFontStream,
   float size,
   bool embed
)
Managed Extensions for C++
public: TrueTypeFont(
   Stream* trueTypeFontStream,
   float size,
   bool embed
)
C++/CLI
public:
TrueTypeFont(
   Stream^ trueTypeFontStream,
   float size,
   bool embed
)

Parameters

trueTypeFontStream
a stream object with font data.
size
the size of the font, in points.
embed
true if the font file should be embedded in the pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


TrueTypeFont Constructor(Stream,Single,Boolean,Boolean)

TrueTypeFont Constructor(Stream,Single,Boolean,Boolean)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(Stream,Single,Boolean,Boolean)

trueTypeFontStream
a stream object with font data.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings
Initializes a new TrueTypeFont object based on the given font stream and size.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal trueTypeFontStream As Stream, _
   ByVal size As Single, _
   ByVal embed As Boolean, _
   ByVal unicode As Boolean _
)
Visual Basic (Usage) Copy Code
Dim trueTypeFontStream As Stream
Dim size As Single
Dim embed As Boolean
Dim unicode As Boolean

Dim instance As TrueTypeFont(trueTypeFontStream, size, embed, unicode)
C#
public TrueTypeFont(
   Stream trueTypeFontStream,
   float size,
   bool embed,
   bool unicode
)
Managed Extensions for C++
public: TrueTypeFont(
   Stream* trueTypeFontStream,
   float size,
   bool embed,
   bool unicode
)
C++/CLI
public:
TrueTypeFont(
   Stream^ trueTypeFontStream,
   float size,
   bool embed,
   bool unicode
)

Parameters

trueTypeFontStream
a stream object with font data.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings

Remarks

The font is always loaded from disk.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


TrueTypeFont Constructor(String,Single,Boolean)

TrueTypeFont Constructor(String,Single,Boolean)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(String,Single,Boolean)

trueTypeFontFile
the full path to the font file.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
Initializes a new TrueTypeFont object based on the given font file and size.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal trueTypeFontFile As String, _
   ByVal size As Single, _
   ByVal embed As Boolean _
)
Visual Basic (Usage) Copy Code
Dim trueTypeFontFile As String
Dim size As Single
Dim embed As Boolean

Dim instance As TrueTypeFont(trueTypeFontFile, size, embed)
C#
public TrueTypeFont(
   string trueTypeFontFile,
   float size,
   bool embed
)
Managed Extensions for C++
public: TrueTypeFont(
   string* trueTypeFontFile,
   float size,
   bool embed
)
C++/CLI
public:
TrueTypeFont(
   String^ trueTypeFontFile,
   float size,
   bool embed
)

Parameters

trueTypeFontFile
the full path to the font file.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


TrueTypeFont Constructor(String,Single,Boolean,Boolean)

TrueTypeFont Constructor(String,Single,Boolean,Boolean)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(String,Single,Boolean,Boolean)

trueTypeFontFile
the full path to the font file.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings
Initializes a new TrueTypeFont object based on the given font file and size.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal trueTypeFontFile As String, _
   ByVal size As Single, _
   ByVal embed As Boolean, _
   ByVal unicode As Boolean _
)
Visual Basic (Usage) Copy Code
Dim trueTypeFontFile As String
Dim size As Single
Dim embed As Boolean
Dim unicode As Boolean

Dim instance As TrueTypeFont(trueTypeFontFile, size, embed, unicode)
C#
public TrueTypeFont(
   string trueTypeFontFile,
   float size,
   bool embed,
   bool unicode
)
Managed Extensions for C++
public: TrueTypeFont(
   string* trueTypeFontFile,
   float size,
   bool embed,
   bool unicode
)
C++/CLI
public:
TrueTypeFont(
   String^ trueTypeFontFile,
   float size,
   bool embed,
   bool unicode
)

Parameters

trueTypeFontFile
the full path to the font file.
size
the size of the font, in points.
embed
true, if the font file should be embedded in the pdf file.
unicode
true, if the font is used to display Unicode strings

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


TrueTypeFont Constructor(TrueTypeFont,Double)

TrueTypeFont Constructor(TrueTypeFont,Double)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class > TrueTypeFont Constructor : TrueTypeFont Constructor(TrueTypeFont,Double)

font
the original TrueTypeFont object
size
the size of the new font
Initializes a new TrueTypeFont object based on an existing font object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal font As TrueTypeFont, _
   ByVal size As Double _
)
Visual Basic (Usage) Copy Code
Dim font As TrueTypeFont
Dim size As Double

Dim instance As TrueTypeFont(font, size)
C#
public TrueTypeFont(
   TrueTypeFont font,
   double size
)
Managed Extensions for C++
public: TrueTypeFont(
   TrueTypeFont* font,
   double size
)
C++/CLI
public:
TrueTypeFont(
   TrueTypeFont^ font,
   double size
)

Parameters

font
the original TrueTypeFont object
size
the size of the new font

Remarks

Use this constructor when the same font (the same face)) is used multiple time but at different sizes. This will avoid reparsing the font file. Because the some of the internal structures are shared by the new and the original font object, changing the bold and italic modifiers for one font object, will also update the other font object. This is because the values of this modifiers are built in the font data. All the other properties of the font (underline, overline, strikethrough, size) can be changed without side effects. The embedding can not be changed for the new font, if the original font is embedded, this new font will use the same embedded data, in order to avoid redundancy.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members
Overload List


TrueTypeFont Class Methods

TrueTypeFont Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : TrueTypeFont Class

For a list of all members of this type, see TrueTypeFont members.

Public Methods

 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from PDFFontBase)
Top

See Also

Reference

TrueTypeFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


GetCharWidth Method

GetCharWidth Method
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > TrueTypeFont Class : GetCharWidth Method

charCode
the char to get its width
Gets the width of the given character when drawn with this font object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As TrueTypeFont
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
C#
public override double GetCharWidth(
   char charCode
)
Managed Extensions for C++
public: double GetCharWidth(
   char charCode
) override
C++/CLI
public:
double GetCharWidth(
   char charCode
) override

Parameters

charCode
the char to get its width

Return Value

This method returns a float value that represents the width, in unscaled glyph units, of the given character.

Remarks

To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

TrueTypeFont Class
TrueTypeFont Members


Type0Font Class

Type0Font Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type0Font Class

Defines a generic Type0 font that can be used in a PDF file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class Type0Font
   Inherits PDFFontBase
Visual Basic (Usage) Copy Code
Dim instance As Type0Font
C#
public class Type0Font : PDFFontBase
Managed Extensions for C++
public __gc class Type0Font : public PDFFontBase
C++/CLI
public ref class Type0Font : public PDFFontBase

Remarks

This class is for internal library use.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontBase
O2S.Components.PDF4NET.Graphics.Fonts.Type0Font

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Type0Font Members
O2S.Components.PDF4NET.Graphics.Fonts Namespace


Type0Font Class Members

Type0Font Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type0Font Class

The following tables list the members exposed by Type0Font.

Public Properties

 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not. (Inherited from PDFFontBase)
Public Property | Italic | Gets or sets whether the font object is italic or not. (Inherited from PDFFontBase)
Public Property | Metrics | Gets the metrics of this font object. (Inherited from PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from PDFFontBase)
Top

Public Methods

 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from PDFFontBase)
Top

See Also

Reference

Type0Font Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


Type0Font Class Methods

Type0Font Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type0Font Class

For a list of all members of this type, see Type0Font members.

Public Methods

 | Name | Description
Public Method | GetCharWidth | Overridden. Gets the width of the given character when drawn with this font object.
Public Method | MeasureString | Measures the specified string when drawn with this font object. (Inherited from PDFFontBase)
Top

See Also

Reference

Type0Font Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


GetCharWidth Method

GetCharWidth Method
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace > Type0Font Class : GetCharWidth Method

charCode
the char to get its width
Gets the width of the given character when drawn with this font object.

Syntax

Visual Basic (Declaration)
Overrides Public Function GetCharWidth( _
   ByVal charCode As Char _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As Type0Font
Dim charCode As Char
Dim value As Double

value = instance.GetCharWidth(charCode)
C#
public override double GetCharWidth(
   char charCode
)
Managed Extensions for C++
public: double GetCharWidth(
   char charCode
) override
C++/CLI
public:
double GetCharWidth(
   char charCode
) override

Parameters

charCode
the char to get its width

Return Value

This method returns a float value that represents the width, in unscaled glyph units, of the given character.

Remarks

To scale this value to font's current size, divide it by 1000 and multiply it by font size. For example, if font size is 20pt, then the width, in points, of a character for this font is 20 * GetCharWidth( charCode ) / 1000.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Type0Font Class
Type0Font Members


CJKFontFace Enumeration

CJKFontFace Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : CJKFontFace Enumeration

Defines the available CJK fonts faces.

Syntax

Visual Basic (Declaration)
Public Enum CJKFontFace
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As CJKFontFace
C#
public enum CJKFontFace : Enum
Managed Extensions for C++
__value public enum CJKFontFace : public Enum
C++/CLI
public enum class CJKFontFace : public Enum

Members

Member | Description
HeiseiKakuGothicW5 | The Heisei Kaku Gothic W5 japanese font face.
HeiseiMinchoW3 | The Heisei Mincho W3 japanese font face.
KozMinProVIRegular | KozMinProVI-Regular japanese font face.
HanyangSystemsGothicMedium | The Hanyang Systems Gothic Medium korean font face.
HanyangSystemsShinMyeongJoMedium | The Hanyang Systems Shin MyeongJo Medium korean font face.
MonotypeHeiMedium | The Monotype Hei Medium chinese traditional font face.
MonotypeSungLight | The Monotype Sung Light chinese traditional font face.
SinoTypeSongLight | The SinoType Song Light chinese simplified font face.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Fonts.CJKFontFace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Fonts Namespace


PDFFontFace Enumeration

PDFFontFace Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : PDFFontFace Enumeration

Specifies the available PDF fonts for drawing text on a page

Syntax

Visual Basic (Declaration)
Public Enum PDFFontFace
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFFontFace
C#
public enum PDFFontFace : Enum
Managed Extensions for C++
__value public enum PDFFontFace : public Enum
C++/CLI
public enum class PDFFontFace : public Enum

Members

Member | Description
Helvetica | The Helvetica font
TimesRoman | The Times Roman font
Courier | The Courier font
Symbol | The Symbol font
ZapfDingbats | The ZapfDingbats font

Remarks

These fonts and their variations (bold, italic) are recongized and implemented by any PDF viewer.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Fonts.PDFFontFace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Fonts Namespace


O2S.Components.PDF4NET.Graphics.Shapes Namespace

O2S.Components.PDF4NET.Graphics.Shapes Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFCcittImage | Defines a PDF image in CCITT Fax format.
PDFFormXObject | Defines a PDF form XObject.
PDFImage | Defines an image specified by a pair of coordinates, a width, and a height.
PDFJpeg2000Image | Defines a PDF image in JPEG2000 format.
PDFMetafile | Defines a Windows metafile object.
PDFPath | Represents a series of connected lines and curves.
PDFRawImage | Defines a PDF image in RAW format.
PDFTextFormatOptions | Defines the available formatting options for a text box

Enumerations

Enumeration | Description
PDFCcittFaxCompression | Specifies the available CCITT fax compression modes.
PDFClipText | Specifies the available cliping modes when displaying a text box
PDFImageCompression | Specifies the available compression methods for storing an image in the PDF file.
PDFKeepAspectRatio | Specifies the available modes to resize an image when it is drawn on the page.

See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET.Graphics.Shapes Namespace Inheritance Hierarchy

O2S.Components.PDF4NET.Graphics.Shapes Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFCcittImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFJpeg2000Image
O2S.Components.PDF4NET.Graphics.Shapes.PDFRawImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFPath
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFMetafile

See Also

Reference

O2S.Components.PDF4NET Assembly


PDFCcittImage Class

PDFCcittImage Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFCcittImage Class

Defines a PDF image in CCITT Fax format.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFCcittImage
   Inherits PDFImage
Visual Basic (Usage) Copy Code
Dim instance As PDFCcittImage
C#
public class PDFCcittImage : PDFImage
Managed Extensions for C++
public __gc class PDFCcittImage : public PDFImage
C++/CLI
public ref class PDFCcittImage : public PDFImage

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFCcittImage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCcittImage Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFCcittImage Class Members

PDFCcittImage Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFCcittImage Class

The following tables list the members exposed by PDFCcittImage.

Public Constructors

 | Name | Description
Public Constructor | PDFCcittImage Constructor | Initializes a new PDFCcittImage object.
Top

Public Properties

 | Name | Description
Public Property | BlackIs1 | Gets or sets a value indicating how the image data should be interpreted.
Public Property | Compression | Gets or sets the compression method used by the image data.
Public Property | Dictionary | Gets the image dictionary. (Inherited from PDFImage)
Public Property | Height | Overridden. Gets or sets the height of this image object.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in. (Inherited from PDFImage)
Public Property | Mask | Gets or sets the mask for this image. (Inherited from PDFImage)
Public Property | Width | Overridden. Gets or sets the width of this image object.
Top

See Also

Reference

PDFCcittImage Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFCcittImage Constructor

PDFCcittImage Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFCcittImage Class : PDFCcittImage Constructor

imageData
Image data using CCITT Fax compression.
Initializes a new PDFCcittImage object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal imageData() As Byte _
)
Visual Basic (Usage) Copy Code
Dim imageData() As Byte

Dim instance As PDFCcittImage(imageData)
C#
public PDFCcittImage(
   byte[] imageData
)
Managed Extensions for C++
public: PDFCcittImage(
   byte[]* imageData
)
C++/CLI
public:
PDFCcittImage(
   array<byte>^ imageData
)

Parameters

imageData
Image data using CCITT Fax compression.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCcittImage Class
PDFCcittImage Members


PDFCcittImage Class Properties

PDFCcittImage Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFCcittImage Class

For a list of all members of this type, see PDFCcittImage members.

Public Properties

 | Name | Description
Public Property | BlackIs1 | Gets or sets a value indicating how the image data should be interpreted.
Public Property | Compression | Gets or sets the compression method used by the image data.
Public Property | Dictionary | Gets the image dictionary. (Inherited from PDFImage)
Public Property | Height | Overridden. Gets or sets the height of this image object.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in. (Inherited from PDFImage)
Public Property | Mask | Gets or sets the mask for this image. (Inherited from PDFImage)
Public Property | Width | Overridden. Gets or sets the width of this image object.
Top

See Also

Reference

PDFCcittImage Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


BlackIs1 Property

BlackIs1 Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFCcittImage Class : BlackIs1 Property

Gets or sets a value indicating how the image data should be interpreted.

Syntax

Visual Basic (Declaration)
Public Property BlackIs1 As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFCcittImage
Dim value As Boolean

instance.BlackIs1 = value

value = instance.BlackIs1
C#
public bool BlackIs1 {get; set;}
Managed Extensions for C++
public: __property bool get_BlackIs1();
public: __property void set_BlackIs1(
   bool value
);
C++/CLI
public:
property bool BlackIs1 {
   bool get();
   void set (bool value);
}

Return Value

True if the 1 bits are considered black, false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCcittImage Class
PDFCcittImage Members


Compression Property

Compression Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFCcittImage Class : Compression Property

Gets or sets the compression method used by the image data.

Syntax

Visual Basic (Declaration)
Public Property Compression As PDFCcittFaxCompression
Visual Basic (Usage) Copy Code
Dim instance As PDFCcittImage
Dim value As PDFCcittFaxCompression

instance.Compression = value

value = instance.Compression
C#
public PDFCcittFaxCompression Compression {get; set;}
Managed Extensions for C++
public: __property PDFCcittFaxCompression get_Compression();
public: __property void set_Compression(
   PDFCcittFaxCompression value
);
C++/CLI
public:
property PDFCcittFaxCompression Compression {
   PDFCcittFaxCompression get();
   void set (PDFCcittFaxCompression value);
}

Return Value

The compression method of the image.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCcittImage Class
PDFCcittImage Members


Height Property

Height Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFCcittImage Class : Height Property

Gets or sets the height of this image object.

Syntax

Visual Basic (Declaration)
Overrides Public Property Height As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFCcittImage
Dim value As Integer

instance.Height = value

value = instance.Height
C#
public override int Height {get; set;}
Managed Extensions for C++
public: __property int get_Height()override ;
public: __property void set_Height(
   int value
)override ;
C++/CLI
public:
property int Height override {
   int get();
   void set (int value);
}

Return Value

The height of the image in pixels.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCcittImage Class
PDFCcittImage Members


Width Property

Width Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFCcittImage Class : Width Property

Gets or sets the width of this image object.

Syntax

Visual Basic (Declaration)
Overrides Public Property Width As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFCcittImage
Dim value As Integer

instance.Width = value

value = instance.Width
C#
public override int Width {get; set;}
Managed Extensions for C++
public: __property int get_Width()override ;
public: __property void set_Width(
   int value
)override ;
C++/CLI
public:
property int Width override {
   int get();
   void set (int value);
}

Return Value

The width of the image in pixels.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFCcittImage Class
PDFCcittImage Members


PDFFormXObject Class

PDFFormXObject Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFFormXObject Class

Defines a PDF form XObject.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFFormXObject
   Inherits PDFGraphicsContainer
Visual Basic (Usage) Copy Code
Dim instance As PDFFormXObject
C#
public class PDFFormXObject : PDFGraphicsContainer
Managed Extensions for C++
public __gc class PDFFormXObject : public PDFGraphicsContainer
C++/CLI
public ref class PDFFormXObject : public PDFGraphicsContainer

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.PDFPageBackground
O2S.Components.PDF4NET.Graphics.Shapes.PDFMetafile
O2S.Components.PDF4NET.Annotations.PDFAnnotationAppearance

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFFormXObject Class Members

PDFFormXObject Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFFormXObject Class

The following tables list the members exposed by PDFFormXObject.

Public Constructors

 | Name | Description
Public Constructor | PDFFormXObject Constructor | Overloaded. Initializes a new PDFFormXObject object.
Top

Public Properties

 | Name | Description
Public Property | Canvas | Gets the form XObject canvas.
Public Property | Height | Gets or sets the height of this form XObject.
Public Property | Width | Gets or sets the width of this form XObject.
Top

See Also

Reference

PDFFormXObject Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFFormXObject Constructor

PDFFormXObject Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class : PDFFormXObject Constructor

Initializes a new PDFFormXObject object.

Overload List

Overload | Description
PDFFormXObject Constructor() | Initializes a new PDFFormXObject object.
PDFFormXObject Constructor(PDFImportedContent) | Initializes a new PDFFormXObject object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members


PDFFormXObject Constructor()

PDFFormXObject Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class > PDFFormXObject Constructor : PDFFormXObject Constructor()

Initializes a new PDFFormXObject object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFFormXObject()
C#
public PDFFormXObject()
Managed Extensions for C++
public: PDFFormXObject();
C++/CLI
public:
PDFFormXObject();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members
Overload List


PDFFormXObject Constructor(PDFImportedContent)

PDFFormXObject Constructor(PDFImportedContent)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class > PDFFormXObject Constructor : PDFFormXObject Constructor(PDFImportedContent)

importedContent
Imported content that represents the content of the form XObject.
Initializes a new PDFFormXObject object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal importedContent As PDFImportedContent _
)
Visual Basic (Usage) Copy Code
Dim importedContent As PDFImportedContent

Dim instance As PDFFormXObject(importedContent)
C#
public PDFFormXObject(
   PDFImportedContent importedContent
)
Managed Extensions for C++
public: PDFFormXObject(
   PDFImportedContent* importedContent
)
C++/CLI
public:
PDFFormXObject(
   PDFImportedContent^ importedContent
)

Parameters

importedContent
Imported content that represents the content of the form XObject.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members
Overload List


PDFFormXObject Class Properties

PDFFormXObject Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFFormXObject Class

For a list of all members of this type, see PDFFormXObject members.

Public Properties

 | Name | Description
Public Property | Canvas | Gets the form XObject canvas.
Public Property | Height | Gets or sets the height of this form XObject.
Public Property | Width | Gets or sets the width of this form XObject.
Top

See Also

Reference

PDFFormXObject Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


Canvas Property

Canvas Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class : Canvas Property

Gets the form XObject canvas.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Canvas As PDFBasicCanvas
Visual Basic (Usage) Copy Code
Dim instance As PDFFormXObject
Dim value As PDFBasicCanvas

value = instance.Canvas
C#
public PDFBasicCanvas Canvas {get;}
Managed Extensions for C++
public: __property PDFBasicCanvas* get_Canvas();
C++/CLI
public:
property PDFBasicCanvas^ Canvas {
   PDFBasicCanvas^ get();
}

Return Value

The drawing surface of the form XObject.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members


Height Property

Height Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class : Height Property

Gets or sets the height of this form XObject.

Syntax

Visual Basic (Declaration)
Public Property Height As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFFormXObject
Dim value As Double

instance.Height = value

value = instance.Height
C#
public double Height {get; set;}
Managed Extensions for C++
public: __property double get_Height();
public: __property void set_Height(
   double value
);
C++/CLI
public:
property double Height {
   double get();
   void set (double value);
}

Return Value

The height of the form XObject in points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members


Width Property

Width Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFFormXObject Class : Width Property

Gets or sets the width of this form XObject.

Syntax

Visual Basic (Declaration)
Public Property Width As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFFormXObject
Dim value As Double

instance.Width = value

value = instance.Width
C#
public double Width {get; set;}
Managed Extensions for C++
public: __property double get_Width();
public: __property void set_Width(
   double value
);
C++/CLI
public:
property double Width {
   double get();
   void set (double value);
}

Return Value

The width of the form XObject in points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFormXObject Class
PDFFormXObject Members


PDFImage Class

PDFImage Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFImage Class

Defines an image specified by a pair of coordinates, a width, and a height.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFImage
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
C#
public class PDFImage
Managed Extensions for C++
public __gc class PDFImage
C++/CLI
public ref class PDFImage

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFRawImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFJpeg2000Image
O2S.Components.PDF4NET.Graphics.Shapes.PDFCcittImage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFImage Class Members

PDFImage Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFImage Class

The following tables list the members exposed by PDFImage.

Public Constructors

 | Name | Description
Public Constructor | PDFImage Constructor | Overloaded. Initializes a new PDFImage object.
Top

Public Properties

 | Name | Description
Public Property | Dictionary | Gets the image dictionary.
Public Property | Height | Gets the height of this image object.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in.
Public Property | Mask | Gets or sets the mask for this image.
Public Property | Width | Gets the width of this image object.
Top

See Also

Reference

PDFImage Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFImage Constructor

PDFImage Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : PDFImage Constructor

Initializes a new PDFImage object.

Overload List

Overload | Description
PDFImage Constructor(Bitmap) | Initializes a new PDFImage object from a Image.
PDFImage Constructor(Bitmap,Int32) | Initializes a new PDFImage object from a Image and an active frame.
PDFImage Constructor(Bitmap,Int32,PDFImageCompression) | Initializes a new PDFImage object from a Image and an active frame.
PDFImage Constructor(Stream) | Initializes a new PDFImage object specifying a stream.
PDFImage Constructor(Stream,Int32) | Initializes a new PDFImage object specifying a stream and an active frame.
PDFImage Constructor(Stream,Int32,PDFImageCompression) | Initializes a new PDFImage object specifying a stream and an active frame.
PDFImage Constructor(String) | Initializes a new PDFImage object specifying a file name.
PDFImage Constructor(String,Int32) | Initializes a new PDFImage object specifying a file name and an active frame.
PDFImage Constructor(String,Int32,PDFImageCompression) | Initializes a new PDFImage object specifying a file name and an active frame.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


PDFImage Constructor(Bitmap)

PDFImage Constructor(Bitmap)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Bitmap)

image
a Bitmap object where to copy the image from.
Initializes a new PDFImage object from a Image.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal image As Bitmap _
)
Visual Basic (Usage) Copy Code
Dim image As Bitmap

Dim instance As PDFImage(image)
C#
public PDFImage(
   Bitmap image
)
Managed Extensions for C++
public: PDFImage(
   Bitmap image
)
C++/CLI
public:
PDFImage(
   Bitmap image
)

Parameters

image
a Bitmap object where to copy the image from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


PDFImage Constructor(Bitmap,Int32)

PDFImage Constructor(Bitmap,Int32)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Bitmap,Int32)

image
a Bitmap object where to copy the image from.
activeFrame
the frame in the image that should be used.
Initializes a new PDFImage object from a Image and an active frame.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal image As Bitmap, _
   ByVal activeFrame As Integer _
)
Visual Basic (Usage) Copy Code
Dim image As Bitmap
Dim activeFrame As Integer

Dim instance As PDFImage(image, activeFrame)
C#
public PDFImage(
   Bitmap image,
   int activeFrame
)
Managed Extensions for C++
public: PDFImage(
   Bitmap image,
   int activeFrame
)
C++/CLI
public:
PDFImage(
   Bitmap image,
   int activeFrame
)

Parameters

image
a Bitmap object where to copy the image from.
activeFrame
the frame in the image that should be used.

Remarks

If the image does not support multiple frames in the same file, the activeFrame parameter is ignored.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


PDFImage Constructor(Bitmap,Int32,PDFImageCompression)

PDFImage Constructor(Bitmap,Int32,PDFImageCompression)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Bitmap,Int32,PDFImageCompression)

image
a Bitmap object where to copy the image from.
activeFrame
the frame in the image that should be used.
imageCompression
Compression method for storing the image data in the PDF file.
Initializes a new PDFImage object from a Image and an active frame.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal image As Bitmap, _
   ByVal activeFrame As Integer, _
   ByVal imageCompression As PDFImageCompression _
)
Visual Basic (Usage) Copy Code
Dim image As Bitmap
Dim activeFrame As Integer
Dim imageCompression As PDFImageCompression

Dim instance As PDFImage(image, activeFrame, imageCompression)
C#
public PDFImage(
   Bitmap image,
   int activeFrame,
   PDFImageCompression imageCompression
)
Managed Extensions for C++
public: PDFImage(
   Bitmap image,
   int activeFrame,
   PDFImageCompression imageCompression
)
C++/CLI
public:
PDFImage(
   Bitmap image,
   int activeFrame,
   PDFImageCompression imageCompression
)

Parameters

image
a Bitmap object where to copy the image from.
activeFrame
the frame in the image that should be used.
imageCompression
Compression method for storing the image data in the PDF file.

Remarks

If the image does not support multiple frames in the same file, the activeFrame parameter is ignored.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


PDFImage Constructor(Stream)

PDFImage Constructor(Stream)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Stream)

stream
a Stream object where to load the image from.
Initializes a new PDFImage object specifying a stream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As PDFImage(stream)
C#
public PDFImage(
   Stream stream
)
Managed Extensions for C++
public: PDFImage(
   Stream* stream
)
C++/CLI
public:
PDFImage(
   Stream^ stream
)

Parameters

stream
a Stream object where to load the image from.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


PDFImage Constructor(Stream,Int32)

PDFImage Constructor(Stream,Int32)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Stream,Int32)

stream
a Stream object where to load the image from.
activeFrame
the frame in the image that should be used.
Initializes a new PDFImage object specifying a stream and an active frame.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal activeFrame As Integer _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim activeFrame As Integer

Dim instance As PDFImage(stream, activeFrame)
C#
public PDFImage(
   Stream stream,
   int activeFrame
)
Managed Extensions for C++
public: PDFImage(
   Stream* stream,
   int activeFrame
)
C++/CLI
public:
PDFImage(
   Stream^ stream,
   int activeFrame
)

Parameters

stream
a Stream object where to load the image from.
activeFrame
the frame in the image that should be used.

Remarks

If the image does not support multiple frames in the same file, the activeFrame parameter is ignored.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


PDFImage Constructor(Stream,Int32,PDFImageCompression)

PDFImage Constructor(Stream,Int32,PDFImageCompression)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(Stream,Int32,PDFImageCompression)

stream
a Stream object where to load the image from.
activeFrame
the frame in the image that should be used.
imageCompression
Compression method for storing the image data in the PDF file.
Initializes a new PDFImage object specifying a stream and an active frame.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal activeFrame As Integer, _
   ByVal imageCompression As PDFImageCompression _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim activeFrame As Integer
Dim imageCompression As PDFImageCompression

Dim instance As PDFImage(stream, activeFrame, imageCompression)
C#
public PDFImage(
   Stream stream,
   int activeFrame,
   PDFImageCompression imageCompression
)
Managed Extensions for C++
public: PDFImage(
   Stream* stream,
   int activeFrame,
   PDFImageCompression imageCompression
)
C++/CLI
public:
PDFImage(
   Stream^ stream,
   int activeFrame,
   PDFImageCompression imageCompression
)

Parameters

stream
a Stream object where to load the image from.
activeFrame
the frame in the image that should be used.
imageCompression
Compression method for storing the image data in the PDF file.

Remarks

If the image does not support multiple frames in the same file, the activeFrame parameter is ignored.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


PDFImage Constructor(String)

PDFImage Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(String)

fileName
a string value representing a path to the image file.
Initializes a new PDFImage object specifying a file name.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As PDFImage(fileName)
C#
public PDFImage(
   string fileName
)
Managed Extensions for C++
public: PDFImage(
   string* fileName
)
C++/CLI
public:
PDFImage(
   String^ fileName
)

Parameters

fileName
a string value representing a path to the image file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


PDFImage Constructor(String,Int32)

PDFImage Constructor(String,Int32)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(String,Int32)

fileName
a string value representing a path to the image file.
activeFrame
the frame in the image that should be used.
Initializes a new PDFImage object specifying a file name and an active frame.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal activeFrame As Integer _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim activeFrame As Integer

Dim instance As PDFImage(fileName, activeFrame)
C#
public PDFImage(
   string fileName,
   int activeFrame
)
Managed Extensions for C++
public: PDFImage(
   string* fileName,
   int activeFrame
)
C++/CLI
public:
PDFImage(
   String^ fileName,
   int activeFrame
)

Parameters

fileName
a string value representing a path to the image file.
activeFrame
the frame in the image that should be used.

Remarks

If the image does not support multiple frames in the same file, the activeFrame parameter is ignored.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


PDFImage Constructor(String,Int32,PDFImageCompression)

PDFImage Constructor(String,Int32,PDFImageCompression)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class > PDFImage Constructor : PDFImage Constructor(String,Int32,PDFImageCompression)

fileName
a string value representing a path to the image file.
activeFrame
the frame in the image that should be used.
imageCompression
Compression method for storing the image data in the PDF file.
Initializes a new PDFImage object specifying a file name and an active frame.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal activeFrame As Integer, _
   ByVal imageCompression As PDFImageCompression _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim activeFrame As Integer
Dim imageCompression As PDFImageCompression

Dim instance As PDFImage(fileName, activeFrame, imageCompression)
C#
public PDFImage(
   string fileName,
   int activeFrame,
   PDFImageCompression imageCompression
)
Managed Extensions for C++
public: PDFImage(
   string* fileName,
   int activeFrame,
   PDFImageCompression imageCompression
)
C++/CLI
public:
PDFImage(
   String^ fileName,
   int activeFrame,
   PDFImageCompression imageCompression
)

Parameters

fileName
a string value representing a path to the image file.
activeFrame
the frame in the image that should be used.
imageCompression
Compression method for storing the image data in the PDF file.

Remarks

If the image does not support multiple frames in the same file, the activeFrame parameter is ignored.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members
Overload List


PDFImage Class Properties

PDFImage Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFImage Class

For a list of all members of this type, see PDFImage members.

Public Properties

 | Name | Description
Public Property | Dictionary | Gets the image dictionary.
Public Property | Height | Gets the height of this image object.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in.
Public Property | Mask | Gets or sets the mask for this image.
Public Property | Width | Gets the width of this image object.
Top

See Also

Reference

PDFImage Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


Dictionary Property

Dictionary Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : Dictionary Property

Gets the image dictionary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dictionary As PDFDictionary
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As PDFDictionary

value = instance.Dictionary
C#
public PDFDictionary Dictionary {get;}
Managed Extensions for C++
public: __property PDFDictionary* get_Dictionary();
C++/CLI
public:
property PDFDictionary^ Dictionary {
   PDFDictionary^ get();
}

Return Value

The raw image dictionary.

Remarks

This property gives you direct access to image dictionary and its associated resources. Note: Modifying directly the page dictionary without good knowledge of the PDF specification can lead to unexpected results, such as invalid PDF files.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


Height Property

Height Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : Height Property

Gets the height of this image object.

Syntax

Visual Basic (Declaration)
Public Overridable Property Height As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As Integer

instance.Height = value

value = instance.Height
C#
public virtual int Height {get; set;}
Managed Extensions for C++
public: __property virtual int get_Height();
public: __property virtual void set_Height(
   int value
);
C++/CLI
public:
virtual property int Height {
   int get();
   void set (int value);
}

Return Value

The height of the image in pixels.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


Interpolate Property

Interpolate Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : Interpolate Property

Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in.

Syntax

Visual Basic (Declaration)
Public Property Interpolate As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As Boolean

instance.Interpolate = value

value = instance.Interpolate
C#
public bool Interpolate {get; set;}
Managed Extensions for C++
public: __property bool get_Interpolate();
public: __property void set_Interpolate(
   bool value
);
C++/CLI
public:
property bool Interpolate {
   bool get();
   void set (bool value);
}

Return Value

True if the image should be interpolated when the PDF viewer zooms in, false otherwise. Default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


Mask Property

Mask Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : Mask Property

Gets or sets the mask for this image.

Syntax

Visual Basic (Declaration)
Public Property Mask As PDFBaseImageMask
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As PDFBaseImageMask

instance.Mask = value

value = instance.Mask
C#
public PDFBaseImageMask Mask {get; set;}
Managed Extensions for C++
public: __property PDFBaseImageMask* get_Mask();
public: __property void set_Mask(
   PDFBaseImageMask* value
);
C++/CLI
public:
property PDFBaseImageMask^ Mask {
   PDFBaseImageMask^ get();
   void set (PDFBaseImageMask^ value);
}

Return Value

A PDFBaseImageMask descendant specifying the mask for this image.

Remarks

The mask allows to define areas of an image to be treated as transparent when the image is painted on the page. Note: An image mask should not be used with jpeg images because they use a lossy image compression and unwanted effects might appear.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


Width Property

Width Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFImage Class : Width Property

Gets the width of this image object.

Syntax

Visual Basic (Declaration)
Public Overridable Property Width As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFImage
Dim value As Integer

instance.Width = value

value = instance.Width
C#
public virtual int Width {get; set;}
Managed Extensions for C++
public: __property virtual int get_Width();
public: __property virtual void set_Width(
   int value
);
C++/CLI
public:
virtual property int Width {
   int get();
   void set (int value);
}

Return Value

The width of the image in pixels.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImage Class
PDFImage Members


PDFJpeg2000Image Class

PDFJpeg2000Image Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFJpeg2000Image Class

Defines a PDF image in JPEG2000 format.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFJpeg2000Image
   Inherits PDFImage
Visual Basic (Usage) Copy Code
Dim instance As PDFJpeg2000Image
C#
public class PDFJpeg2000Image : PDFImage
Managed Extensions for C++
public __gc class PDFJpeg2000Image : public PDFImage
C++/CLI
public ref class PDFJpeg2000Image : public PDFImage

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFJpeg2000Image

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJpeg2000Image Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFJpeg2000Image Class Members

PDFJpeg2000Image Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFJpeg2000Image Class

The following tables list the members exposed by PDFJpeg2000Image.

Public Constructors

 | Name | Description
Public Constructor | PDFJpeg2000Image Constructor | Initializes a new PDFJpeg2000Image object.
Top

Public Properties

 | Name | Description
Public Property | BitsPerComponent | Gets or sets the bits per components.
Public Property | ColorSpace | Gets or sets the image colorspace.
Public Property | Dictionary | Gets the image dictionary. (Inherited from PDFImage)
Public Property | Height | Overridden. Gets or sets the height of this image object.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in. (Inherited from PDFImage)
Public Property | Mask | Gets or sets the mask for this image. (Inherited from PDFImage)
Public Property | Width | Overridden. Gets or sets the width of this image object.
Top

See Also

Reference

PDFJpeg2000Image Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFJpeg2000Image Constructor

PDFJpeg2000Image Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpeg2000Image Class : PDFJpeg2000Image Constructor

imageData
JPEG2000 image data.
Initializes a new PDFJpeg2000Image object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal imageData() As Byte _
)
Visual Basic (Usage) Copy Code
Dim imageData() As Byte

Dim instance As PDFJpeg2000Image(imageData)
C#
public PDFJpeg2000Image(
   byte[] imageData
)
Managed Extensions for C++
public: PDFJpeg2000Image(
   byte[]* imageData
)
C++/CLI
public:
PDFJpeg2000Image(
   array<byte>^ imageData
)

Parameters

imageData
JPEG2000 image data.

Remarks

The imageData parameter must contain the image in JPEG2000 format, the data is stored as it is in the PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJpeg2000Image Class
PDFJpeg2000Image Members


PDFJpeg2000Image Class Properties

PDFJpeg2000Image Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFJpeg2000Image Class

For a list of all members of this type, see PDFJpeg2000Image members.

Public Properties

 | Name | Description
Public Property | BitsPerComponent | Gets or sets the bits per components.
Public Property | ColorSpace | Gets or sets the image colorspace.
Public Property | Dictionary | Gets the image dictionary. (Inherited from PDFImage)
Public Property | Height | Overridden. Gets or sets the height of this image object.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in. (Inherited from PDFImage)
Public Property | Mask | Gets or sets the mask for this image. (Inherited from PDFImage)
Public Property | Width | Overridden. Gets or sets the width of this image object.
Top

See Also

Reference

PDFJpeg2000Image Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


BitsPerComponent Property

BitsPerComponent Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpeg2000Image Class : BitsPerComponent Property

Gets or sets the bits per components.

Syntax

Visual Basic (Declaration)
Public Property BitsPerComponent As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFJpeg2000Image
Dim value As Integer

instance.BitsPerComponent = value

value = instance.BitsPerComponent
C#
public int BitsPerComponent {get; set;}
Managed Extensions for C++
public: __property int get_BitsPerComponent();
public: __property void set_BitsPerComponent(
   int value
);
C++/CLI
public:
property int BitsPerComponent {
   int get();
   void set (int value);
}

Return Value

The number of bits used to represent a color component in this image.

Remarks

Valid values are 1, 2, 4, 8, and (in PDF 1.5) 16

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJpeg2000Image Class
PDFJpeg2000Image Members


ColorSpace Property

ColorSpace Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpeg2000Image Class : ColorSpace Property

Gets or sets the image colorspace.

Syntax

Visual Basic (Declaration)
Public Property ColorSpace As PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFJpeg2000Image
Dim value As PDFColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
C#
public PDFColorSpace ColorSpace {get; set;}
Managed Extensions for C++
public: __property PDFColorSpace* get_ColorSpace();
public: __property void set_ColorSpace(
   PDFColorSpace* value
);
C++/CLI
public:
property PDFColorSpace^ ColorSpace {
   PDFColorSpace^ get();
   void set (PDFColorSpace^ value);
}

Return Value

The image colorspace used to interpret the image data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJpeg2000Image Class
PDFJpeg2000Image Members


Height Property

Height Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpeg2000Image Class : Height Property

Gets or sets the height of this image object.

Syntax

Visual Basic (Declaration)
Overrides Public Property Height As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFJpeg2000Image
Dim value As Integer

instance.Height = value

value = instance.Height
C#
public override int Height {get; set;}
Managed Extensions for C++
public: __property int get_Height()override ;
public: __property void set_Height(
   int value
)override ;
C++/CLI
public:
property int Height override {
   int get();
   void set (int value);
}

Return Value

The height of the image in pixels.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJpeg2000Image Class
PDFJpeg2000Image Members


Width Property

Width Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFJpeg2000Image Class : Width Property

Gets or sets the width of this image object.

Syntax

Visual Basic (Declaration)
Overrides Public Property Width As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFJpeg2000Image
Dim value As Integer

instance.Width = value

value = instance.Width
C#
public override int Width {get; set;}
Managed Extensions for C++
public: __property int get_Width()override ;
public: __property void set_Width(
   int value
)override ;
C++/CLI
public:
property int Width override {
   int get();
   void set (int value);
}

Return Value

The width of the image in pixels.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFJpeg2000Image Class
PDFJpeg2000Image Members


PDFMetafile Class

PDFMetafile Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFMetafile Class

Defines a Windows metafile object.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFMetafile
   Inherits PDFFormXObject
Visual Basic (Usage) Copy Code
Dim instance As PDFMetafile
C#
public class PDFMetafile : PDFFormXObject
Managed Extensions for C++
public __gc class PDFMetafile : public PDFFormXObject
C++/CLI
public ref class PDFMetafile : public PDFFormXObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject
O2S.Components.PDF4NET.Graphics.Shapes.PDFMetafile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetafile Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFMetafile Class Members

PDFMetafile Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFMetafile Class

The following tables list the members exposed by PDFMetafile.

Public Constructors

 | Name | Description
Public Constructor | PDFMetafile Constructor | Overloaded. Initializes a new PDFMetafile object with the specified metafile file.
Top

Public Properties

 | Name | Description
Public Property | Canvas | Gets the form XObject canvas. (Inherited from PDFFormXObject)
Public Property | Height | Gets or sets the height of this form XObject. (Inherited from PDFFormXObject)
Public Property | Width | Gets or sets the width of this form XObject. (Inherited from PDFFormXObject)
Top

See Also

Reference

PDFMetafile Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFMetafile Constructor

PDFMetafile Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class : PDFMetafile Constructor

Initializes a new PDFMetafile object with the specified metafile file.

Overload List

Overload | Description
PDFMetafile Constructor(Stream) | Initializes a new PDFMetafile object with the specified metafile stream.
PDFMetafile Constructor(Stream,Boolean) | Initializes a new PDFMetafile object with the specified metafile stream.
PDFMetafile Constructor(String) | Initializes a new PDFMetafile object with the specified metafile file.
PDFMetafile Constructor(String,Boolean) | Initializes a new PDFMetafile object with the specified metafile file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetafile Class
PDFMetafile Members


PDFMetafile Constructor(Stream)

PDFMetafile Constructor(Stream)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(Stream)

stream
the stream with metafile content.
Initializes a new PDFMetafile object with the specified metafile stream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As PDFMetafile(stream)
C#
public PDFMetafile(
   Stream stream
)
Managed Extensions for C++
public: PDFMetafile(
   Stream* stream
)
C++/CLI
public:
PDFMetafile(
   Stream^ stream
)

Parameters

stream
the stream with metafile content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


PDFMetafile Constructor(Stream,Boolean)

PDFMetafile Constructor(Stream,Boolean)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(Stream,Boolean)

stream
the stream with metafile content.
useUnicodeFonts
True if the fonts in the metafile should be created with Unicode support.
Initializes a new PDFMetafile object with the specified metafile stream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal useUnicodeFonts As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim useUnicodeFonts As Boolean

Dim instance As PDFMetafile(stream, useUnicodeFonts)
C#
public PDFMetafile(
   Stream stream,
   bool useUnicodeFonts
)
Managed Extensions for C++
public: PDFMetafile(
   Stream* stream,
   bool useUnicodeFonts
)
C++/CLI
public:
PDFMetafile(
   Stream^ stream,
   bool useUnicodeFonts
)

Parameters

stream
the stream with metafile content.
useUnicodeFonts
True if the fonts in the metafile should be created with Unicode support.

Remarks

When using non-Unicode fonts to draw the text in the metafile the size of the rendered EMF file is much smaller because some of the TrueType fonts are substituted with native PDF fonts. The drawback is that non-Unicode fonts can not draw Unicode characters. If the rendered EMF files usually contain Unicode characters, then 'useUnicodeFonts' parameter should be true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


PDFMetafile Constructor(String)

PDFMetafile Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(String)

fileName
the full path to the metafile on disk.
Initializes a new PDFMetafile object with the specified metafile file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As PDFMetafile(fileName)
C#
public PDFMetafile(
   string fileName
)
Managed Extensions for C++
public: PDFMetafile(
   string* fileName
)
C++/CLI
public:
PDFMetafile(
   String^ fileName
)

Parameters

fileName
the full path to the metafile on disk.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


PDFMetafile Constructor(String,Boolean)

PDFMetafile Constructor(String,Boolean)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFMetafile Class > PDFMetafile Constructor : PDFMetafile Constructor(String,Boolean)

fileName
the full path to the metafile on disk.
useUnicodeFonts
True if the fonts in the metafile should be created with Unicode support.
Initializes a new PDFMetafile object with the specified metafile file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal useUnicodeFonts As Boolean _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim useUnicodeFonts As Boolean

Dim instance As PDFMetafile(fileName, useUnicodeFonts)
C#
public PDFMetafile(
   string fileName,
   bool useUnicodeFonts
)
Managed Extensions for C++
public: PDFMetafile(
   string* fileName,
   bool useUnicodeFonts
)
C++/CLI
public:
PDFMetafile(
   String^ fileName,
   bool useUnicodeFonts
)

Parameters

fileName
the full path to the metafile on disk.
useUnicodeFonts
True if the fonts in the metafile should be created with Unicode support.

Remarks

When using non-Unicode fonts to draw the text in the metafile the size of the rendered EMF file is much smaller because some of the TrueType fonts are substituted with native PDF fonts. The drawback is that non-Unicode fonts can not draw Unicode characters. If the rendered EMF files usually contain Unicode characters, then 'useUnicodeFonts' parameter should be true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFMetafile Class
PDFMetafile Members
Overload List


PDFPath Class

PDFPath Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPath Class

Represents a series of connected lines and curves.

Syntax

Visual Basic (Declaration)
Public Class PDFPath
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
C#
public class PDFPath
Managed Extensions for C++
public __gc class PDFPath
C++/CLI
public ref class PDFPath

Remarks

A path can be used to create complex geometric shapes that are not available in PDF4NET library as basic drawing primitives.
A path consists of one or more subpaths that can be connected or not. All the points of a subpath are connected through lines and/or curves. A subpath can be open or it can be explicitly closed.
When the path is filled, its subpaths, that are not explicitly closed, are automatically closed.
Each drawing primitive in a subpath updates the current drawing point. If the current drawing point is explicitly moved using MoveTo, the current subpath is ended and a new subpath is started.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFPath

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFPath Class Members

PDFPath Class Members
See Also Methods
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPath Class

The following tables list the members exposed by PDFPath.

Public Constructors

 | Name | Description
Public Constructor | PDFPath Constructor | Initializes a new PDFPath object.
Top

Public Methods

 | Name | Description
Public Method | BezierTo | Appends a Berzier curve to the end of the current subpath.
Public Method | CloseSubpath | Closes the current subpath.
Public Method | Ellipse | Add an ellipse to this path object.
Public Method | LineTo | Appends a line segment to the end of the current subpath.
Public Method | MoveTo | Moves the current point in the path to a new position.
Public Method | PolyBezierTo | Appends a series of connected Bezier curves to the end of the current subpath.
Public Method | Polygon | Add a polygon to this path object.
Public Method | PolyLineTo | Appends a series of connected line segments to the end of the current subpath.
Public Method | Rectangle | Add a rectangle to this path object.
Public Method | RoundRectangle | Add a rounded rectangle to this path object.
Top

See Also

Reference

PDFPath Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFPath Constructor

PDFPath Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : PDFPath Constructor

Initializes a new PDFPath object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFPath()
C#
public PDFPath()
Managed Extensions for C++
public: PDFPath();
C++/CLI
public:
PDFPath();

Remarks

The starting point of the path is (0,0).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


PDFPath Class Methods

PDFPath Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFPath Class

For a list of all members of this type, see PDFPath members.

Public Methods

 | Name | Description
Public Method | BezierTo | Appends a Berzier curve to the end of the current subpath.
Public Method | CloseSubpath | Closes the current subpath.
Public Method | Ellipse | Add an ellipse to this path object.
Public Method | LineTo | Appends a line segment to the end of the current subpath.
Public Method | MoveTo | Moves the current point in the path to a new position.
Public Method | PolyBezierTo | Appends a series of connected Bezier curves to the end of the current subpath.
Public Method | Polygon | Add a polygon to this path object.
Public Method | PolyLineTo | Appends a series of connected line segments to the end of the current subpath.
Public Method | Rectangle | Add a rectangle to this path object.
Public Method | RoundRectangle | Add a rounded rectangle to this path object.
Top

See Also

Reference

PDFPath Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


BezierTo Method

BezierTo Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : BezierTo Method

x1
The x coordinate of the first control point.
y1
The y coordinate of the first control point.
x2
The x coordinate of the second control point.
y2
The y coordinate of the second control point.
x3
The x coordinate of the third control point.
y3
The y coordinate of the third control point.
Appends a Berzier curve to the end of the current subpath.

Syntax

Visual Basic (Declaration)
Public Sub BezierTo( _
   ByVal x1 As Double, _
   ByVal y1 As Double, _
   ByVal x2 As Double, _
   ByVal y2 As Double, _
   ByVal x3 As Double, _
   ByVal y3 As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim x1 As Double
Dim y1 As Double
Dim x2 As Double
Dim y2 As Double
Dim x3 As Double
Dim y3 As Double

instance.BezierTo(x1, y1, x2, y2, x3, y3)
C#
public void BezierTo(
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3
)
Managed Extensions for C++
public: void BezierTo(
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3
)
C++/CLI
public:
void BezierTo(
   double x1,
   double y1,
   double x2,
   double y2,
   double x3,
   double y3
)

Parameters

x1
The x coordinate of the first control point.
y1
The y coordinate of the first control point.
x2
The x coordinate of the second control point.
y2
The y coordinate of the second control point.
x3
The x coordinate of the third control point.
y3
The y coordinate of the third control point.

Remarks

The new point (x3,y3) becomes the path current point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


CloseSubpath Method

CloseSubpath Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : CloseSubpath Method

Closes the current subpath.

Syntax

Visual Basic (Declaration)
Public Sub CloseSubpath()
Visual Basic (Usage) Copy Code
Dim instance As PDFPath

instance.CloseSubpath()
C#
public void CloseSubpath()
Managed Extensions for C++
public: void CloseSubpath();
C++/CLI
public:
void CloseSubpath();

Remarks

Current subpath is closed. A new subpath is automatically started and the new current point is (0,0).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


Ellipse Method

Ellipse Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : Ellipse Method

left
The x coordinate of the top left corner of the bounding rectangle.
top
The y coordinate of the top left corner of the bounding rectangle.
width
The width of the bounding rectangle.
height
The height of the bounding rectangle.
Add an ellipse to this path object.

Syntax

Visual Basic (Declaration)
Public Sub Ellipse( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.Ellipse(left, top, width, height)
C#
public void Ellipse(
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: void Ellipse(
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
void Ellipse(
   double left,
   double top,
   double width,
   double height
)

Parameters

left
The x coordinate of the top left corner of the bounding rectangle.
top
The y coordinate of the top left corner of the bounding rectangle.
width
The width of the bounding rectangle.
height
The height of the bounding rectangle.

Remarks

The ellipse defines a closed subpath within the path. A new subpath is automatically started and the new current point is (left,top).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


LineTo Method

LineTo Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : LineTo Method

x
The x coordinate of the line ending point.
y
The y coordinate of the line ending point.
Appends a line segment to the end of the current subpath.

Syntax

Visual Basic (Declaration)
Public Sub LineTo( _
   ByVal x As Double, _
   ByVal y As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim x As Double
Dim y As Double

instance.LineTo(x, y)
C#
public void LineTo(
   double x,
   double y
)
Managed Extensions for C++
public: void LineTo(
   double x,
   double y
)
C++/CLI
public:
void LineTo(
   double x,
   double y
)

Parameters

x
The x coordinate of the line ending point.
y
The y coordinate of the line ending point.

Remarks

The new point (x,y) becomes the path current point.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


MoveTo Method

MoveTo Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : MoveTo Method

x
The x coordinate of the new current point.
y
The y coordinate of the new current point.
Moves the current point in the path to a new position.

Syntax

Visual Basic (Declaration)
Public Sub MoveTo( _
   ByVal x As Double, _
   ByVal y As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim x As Double
Dim y As Double

instance.MoveTo(x, y)
C#
public void MoveTo(
   double x,
   double y
)
Managed Extensions for C++
public: void MoveTo(
   double x,
   double y
)
C++/CLI
public:
void MoveTo(
   double x,
   double y
)

Parameters

x
The x coordinate of the new current point.
y
The y coordinate of the new current point.

Remarks

The previous path, if exists, is ended and a new subpath is automatically started.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


PolyBezierTo Method

PolyBezierTo Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : PolyBezierTo Method

points
An array of PDFPoint objects that represents the control points that define the Bezier curves to add.
Appends a series of connected Bezier curves to the end of the current subpath.

Syntax

Visual Basic (Declaration)
Public Sub PolyBezierTo( _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim points() As PDFPoint

instance.PolyBezierTo(points)
C#
public void PolyBezierTo(
   PDFPoint[] points
)
Managed Extensions for C++
public: void PolyBezierTo(
   PDFPoint*[]* points
)
C++/CLI
public:
void PolyBezierTo(
   array<PDFPoint^>^ points
)

Parameters

points
An array of PDFPoint objects that represents the control points that define the Bezier curves to add.

Exceptions

Exception | Description
ArgumentNullException | Thrown when points parameter is null.
ArgumentException | Thrown when the last Bezier curve in the array is incomplete.

Remarks

Each Bezier curve is defined by 4 points. The first curve uses the current point as its first control point and each following curve uses the last point of the previous curve as its first control point.
The last point in the array becomes the new current point in the path.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


Polygon Method

Polygon Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : Polygon Method

points
An array of PDFPoint objects that represents the points that define the polygon to add.
Add a polygon to this path object.

Syntax

Visual Basic (Declaration)
Public Sub Polygon( _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim points() As PDFPoint

instance.Polygon(points)
C#
public void Polygon(
   PDFPoint[] points
)
Managed Extensions for C++
public: void Polygon(
   PDFPoint*[]* points
)
C++/CLI
public:
void Polygon(
   array<PDFPoint^>^ points
)

Parameters

points
An array of PDFPoint objects that represents the points that define the polygon to add.

Exceptions

Exception | Description
ArgumentNullException | Thrown when points parameter is null.

Remarks

The polygon defines a closed subpath within the path. The first point in the array is considered as the starting point for the polygon. A new subpath is automatically started and the new current point is the first point of the polygon.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


PolyLineTo Method

PolyLineTo Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : PolyLineTo Method

points
An array of PDFPoint objects that represents the points that define the line segments to add.
Appends a series of connected line segments to the end of the current subpath.

Syntax

Visual Basic (Declaration)
Public Sub PolyLineTo( _
   ByVal points() As PDFPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim points() As PDFPoint

instance.PolyLineTo(points)
C#
public void PolyLineTo(
   PDFPoint[] points
)
Managed Extensions for C++
public: void PolyLineTo(
   PDFPoint*[]* points
)
C++/CLI
public:
void PolyLineTo(
   array<PDFPoint^>^ points
)

Parameters

points
An array of PDFPoint objects that represents the points that define the line segments to add.

Exceptions

Exception | Description
ArgumentNullException | Thrown when points parameter is null.

Remarks

The last point in the array becomes the new current point in the path.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


Rectangle Method

Rectangle Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : Rectangle Method

left
The x coordinate of the top left corner of the rectangle.
top
The y coordinate of the top left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
Add a rectangle to this path object.

Syntax

Visual Basic (Declaration)
Public Sub Rectangle( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double

instance.Rectangle(left, top, width, height)
C#
public void Rectangle(
   double left,
   double top,
   double width,
   double height
)
Managed Extensions for C++
public: void Rectangle(
   double left,
   double top,
   double width,
   double height
)
C++/CLI
public:
void Rectangle(
   double left,
   double top,
   double width,
   double height
)

Parameters

left
The x coordinate of the top left corner of the rectangle.
top
The y coordinate of the top left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.

Remarks

The rectangle defines a closed subpath within the path. A new subpath is automatically started and the new current point is (left,top).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


RoundRectangle Method

RoundRectangle Method
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFPath Class : RoundRectangle Method

left
The x coordinate of the top left corner of the rectangle.
top
The y coordinate of the top left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
ellipseWidth
The width of the ellipse used to draw the rounded corners.
ellipseHeight
The height of the ellipse used to draw the rounded corners.
Add a rounded rectangle to this path object.

Syntax

Visual Basic (Declaration)
Public Sub RoundRectangle( _
   ByVal left As Double, _
   ByVal top As Double, _
   ByVal width As Double, _
   ByVal height As Double, _
   ByVal ellipseWidth As Double, _
   ByVal ellipseHeight As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFPath
Dim left As Double
Dim top As Double
Dim width As Double
Dim height As Double
Dim ellipseWidth As Double
Dim ellipseHeight As Double

instance.RoundRectangle(left, top, width, height, ellipseWidth, ellipseHeight)
C#
public void RoundRectangle(
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
Managed Extensions for C++
public: void RoundRectangle(
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)
C++/CLI
public:
void RoundRectangle(
   double left,
   double top,
   double width,
   double height,
   double ellipseWidth,
   double ellipseHeight
)

Parameters

left
The x coordinate of the top left corner of the rectangle.
top
The y coordinate of the top left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
ellipseWidth
The width of the ellipse used to draw the rounded corners.
ellipseHeight
The height of the ellipse used to draw the rounded corners.

Remarks

The rounded rectangle defines a closed subpath within the path. A new subpath is automatically started and the new current point is (left,top).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFPath Class
PDFPath Members


PDFRawImage Class

PDFRawImage Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRawImage Class

Defines a PDF image in RAW format.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFRawImage
   Inherits PDFImage
Visual Basic (Usage) Copy Code
Dim instance As PDFRawImage
C#
public class PDFRawImage : PDFImage
Managed Extensions for C++
public __gc class PDFRawImage : public PDFImage
C++/CLI
public ref class PDFRawImage : public PDFImage

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFImage
O2S.Components.PDF4NET.Graphics.Shapes.PDFRawImage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRawImage Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFRawImage Class Members

PDFRawImage Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRawImage Class

The following tables list the members exposed by PDFRawImage.

Public Constructors

 | Name | Description
Public Constructor | PDFRawImage Constructor | Initializes a new PDFRawImage object.
Top

Public Properties

 | Name | Description
Public Property | BitsPerComponent | Gets or sets the bits per components.
Public Property | ColorSpace | Gets or sets the image colorspace.
Public Property | Dictionary | Gets the image dictionary. (Inherited from PDFImage)
Public Property | Height | Overridden. Gets or sets the height of this image object.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in. (Inherited from PDFImage)
Public Property | Mask | Gets or sets the mask for this image. (Inherited from PDFImage)
Public Property | Width | Overridden. Gets or sets the width of this image object.
Top

See Also

Reference

PDFRawImage Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFRawImage Constructor

PDFRawImage Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRawImage Class : PDFRawImage Constructor

imageData
Raw image data, its size depends on the BitsPerComponent and ColorSpace.
Initializes a new PDFRawImage object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal imageData() As Byte _
)
Visual Basic (Usage) Copy Code
Dim imageData() As Byte

Dim instance As PDFRawImage(imageData)
C#
public PDFRawImage(
   byte[] imageData
)
Managed Extensions for C++
public: PDFRawImage(
   byte[]* imageData
)
C++/CLI
public:
PDFRawImage(
   array<byte>^ imageData
)

Parameters

imageData
Raw image data, its size depends on the BitsPerComponent and ColorSpace.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRawImage Class
PDFRawImage Members


PDFRawImage Class Properties

PDFRawImage Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFRawImage Class

For a list of all members of this type, see PDFRawImage members.

Public Properties

 | Name | Description
Public Property | BitsPerComponent | Gets or sets the bits per components.
Public Property | ColorSpace | Gets or sets the image colorspace.
Public Property | Dictionary | Gets the image dictionary. (Inherited from PDFImage)
Public Property | Height | Overridden. Gets or sets the height of this image object.
Public Property | Interpolate | Gets or sets a value indicating whether the PDF viewer should interpolate the image when zooming in. (Inherited from PDFImage)
Public Property | Mask | Gets or sets the mask for this image. (Inherited from PDFImage)
Public Property | Width | Overridden. Gets or sets the width of this image object.
Top

See Also

Reference

PDFRawImage Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


BitsPerComponent Property

BitsPerComponent Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRawImage Class : BitsPerComponent Property

Gets or sets the bits per components.

Syntax

Visual Basic (Declaration)
Public Property BitsPerComponent As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFRawImage
Dim value As Integer

instance.BitsPerComponent = value

value = instance.BitsPerComponent
C#
public int BitsPerComponent {get; set;}
Managed Extensions for C++
public: __property int get_BitsPerComponent();
public: __property void set_BitsPerComponent(
   int value
);
C++/CLI
public:
property int BitsPerComponent {
   int get();
   void set (int value);
}

Return Value

The number of bits used to represent a color component in this image.

Remarks

Valid values are 1, 2, 4, 8, and (in PDF 1.5) 16

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRawImage Class
PDFRawImage Members


ColorSpace Property

ColorSpace Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRawImage Class : ColorSpace Property

Gets or sets the image colorspace.

Syntax

Visual Basic (Declaration)
Public Property ColorSpace As PDFColorSpace
Visual Basic (Usage) Copy Code
Dim instance As PDFRawImage
Dim value As PDFColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
C#
public PDFColorSpace ColorSpace {get; set;}
Managed Extensions for C++
public: __property PDFColorSpace* get_ColorSpace();
public: __property void set_ColorSpace(
   PDFColorSpace* value
);
C++/CLI
public:
property PDFColorSpace^ ColorSpace {
   PDFColorSpace^ get();
   void set (PDFColorSpace^ value);
}

Return Value

The image colorspace used to interpret the image data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRawImage Class
PDFRawImage Members


Height Property

Height Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRawImage Class : Height Property

Gets or sets the height of this image object.

Syntax

Visual Basic (Declaration)
Overrides Public Property Height As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFRawImage
Dim value As Integer

instance.Height = value

value = instance.Height
C#
public override int Height {get; set;}
Managed Extensions for C++
public: __property int get_Height()override ;
public: __property void set_Height(
   int value
)override ;
C++/CLI
public:
property int Height override {
   int get();
   void set (int value);
}

Return Value

The height of the image in pixels.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRawImage Class
PDFRawImage Members


Width Property

Width Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFRawImage Class : Width Property

Gets or sets the width of this image object.

Syntax

Visual Basic (Declaration)
Overrides Public Property Width As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFRawImage
Dim value As Integer

instance.Width = value

value = instance.Width
C#
public override int Width {get; set;}
Managed Extensions for C++
public: __property int get_Width()override ;
public: __property void set_Width(
   int value
)override ;
C++/CLI
public:
property int Width override {
   int get();
   void set (int value);
}

Return Value

The width of the image in pixels.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFRawImage Class
PDFRawImage Members


PDFTextFormatOptions Class

PDFTextFormatOptions Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextFormatOptions Class

Defines the available formatting options for a text box

Syntax

Visual Basic (Declaration)
Public Class PDFTextFormatOptions
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions
C#
public class PDFTextFormatOptions
Managed Extensions for C++
public __gc class PDFTextFormatOptions
C++/CLI
public ref class PDFTextFormatOptions

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.PDFTextFormatOptions

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Members
O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFTextFormatOptions Class Members

PDFTextFormatOptions Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextFormatOptions Class

The following tables list the members exposed by PDFTextFormatOptions.

Public Constructors

 | Name | Description
Public Constructor | PDFTextFormatOptions Constructor | Initializes a new PDFTextFormatOptions object.
Top

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the text alignment within the text box.
Public Property | BreakLongWords | Gets or sets whether to break no spaced text at character level.
Public Property | ClipText | Gets or sets the text clipping mode for the text box
Public Property | FirstLineIndent | Gets or sets the first line indentation.
Public Property | KeepWhiteSpaces | Gets or sets whether the white spaces are kept within the text.
Public Property | LineSpacing | Gets or sets the line spacing.
Public Property | Orientation | Gets or sets the text box orientation.
Top

See Also

Reference

PDFTextFormatOptions Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFTextFormatOptions Constructor

PDFTextFormatOptions Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : PDFTextFormatOptions Constructor

Initializes a new PDFTextFormatOptions object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions()
C#
public PDFTextFormatOptions()
Managed Extensions for C++
public: PDFTextFormatOptions();
C++/CLI
public:
PDFTextFormatOptions();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


PDFTextFormatOptions Class Properties

PDFTextFormatOptions Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFTextFormatOptions Class

For a list of all members of this type, see PDFTextFormatOptions members.

Public Properties

 | Name | Description
Public Property | Align | Gets or sets the text alignment within the text box.
Public Property | BreakLongWords | Gets or sets whether to break no spaced text at character level.
Public Property | ClipText | Gets or sets the text clipping mode for the text box
Public Property | FirstLineIndent | Gets or sets the first line indentation.
Public Property | KeepWhiteSpaces | Gets or sets whether the white spaces are kept within the text.
Public Property | LineSpacing | Gets or sets the line spacing.
Public Property | Orientation | Gets or sets the text box orientation.
Top

See Also

Reference

PDFTextFormatOptions Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


Align Property

Align Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : Align Property

Gets or sets the text alignment within the text box.

Syntax

Visual Basic (Declaration)
Public Property Align As PDFTextAlign
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions
Dim value As PDFTextAlign

instance.Align = value

value = instance.Align
C#
public PDFTextAlign Align {get; set;}
Managed Extensions for C++
public: __property PDFTextAlign get_Align();
public: __property void set_Align(
   PDFTextAlign value
);
C++/CLI
public:
property PDFTextAlign Align {
   PDFTextAlign get();
   void set (PDFTextAlign value);
}

Return Value

a TextAlign enumeration member specifying the alignment of the text within the text box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


BreakLongWords Property

BreakLongWords Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : BreakLongWords Property

Gets or sets whether to break no spaced text at character level.

Syntax

Visual Basic (Declaration)
Public Property BreakLongWords As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions
Dim value As Boolean

instance.BreakLongWords = value

value = instance.BreakLongWords
C#
public bool BreakLongWords {get; set;}
Managed Extensions for C++
public: __property bool get_BreakLongWords();
public: __property void set_BreakLongWords(
   bool value
);
C++/CLI
public:
property bool BreakLongWords {
   bool get();
   void set (bool value);
}

Return Value

A boolean value specifying whether to break no spaced text at character level.

Remarks

This property allows to perform text wrapping at character level, not only at word level. It applies only if the first word in a line is longer than the available width.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


ClipText Property

ClipText Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : ClipText Property

Gets or sets the text clipping mode for the text box

Syntax

Visual Basic (Declaration)
Public Property ClipText As PDFClipText
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions
Dim value As PDFClipText

instance.ClipText = value

value = instance.ClipText
C#
public PDFClipText ClipText {get; set;}
Managed Extensions for C++
public: __property PDFClipText get_ClipText();
public: __property void set_ClipText(
   PDFClipText value
);
C++/CLI
public:
property PDFClipText ClipText {
   PDFClipText get();
   void set (PDFClipText value);
}

Return Value

a ClipText enumeration member specifying how the text within the text box should be clipped at box boundary.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


FirstLineIndent Property

FirstLineIndent Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : FirstLineIndent Property

Gets or sets the first line indentation.

Syntax

Visual Basic (Declaration)
Public Property FirstLineIndent As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions
Dim value As Double

instance.FirstLineIndent = value

value = instance.FirstLineIndent
C#
public double FirstLineIndent {get; set;}
Managed Extensions for C++
public: __property double get_FirstLineIndent();
public: __property void set_FirstLineIndent(
   double value
);
C++/CLI
public:
property double FirstLineIndent {
   double get();
   void set (double value);
}

Return Value

a float value specifying the indentation of the first line.

Remarks

This value allows the indent the first line of a text box. Also, this value is used to indent the next line when a new line has been requested by the \n character, or <br/> tag in a HTML text box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


KeepWhiteSpaces Property

KeepWhiteSpaces Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : KeepWhiteSpaces Property

Gets or sets whether the white spaces are kept within the text.

Syntax

Visual Basic (Declaration)
Public Property KeepWhiteSpaces As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions
Dim value As Boolean

instance.KeepWhiteSpaces = value

value = instance.KeepWhiteSpaces
C#
public bool KeepWhiteSpaces {get; set;}
Managed Extensions for C++
public: __property bool get_KeepWhiteSpaces();
public: __property void set_KeepWhiteSpaces(
   bool value
);
C++/CLI
public:
property bool KeepWhiteSpaces {
   bool get();
   void set (bool value);
}

Return Value

a bool value specifying whether the white spaces are kept within the text.

Remarks

This property allows to align text using whitespaces (blanks or tabs). It is useful when using a monospaced font like Courier.

This property has effect only on regular text boxes when using left, center or right alignments. Justified text ignores the value of this property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


LineSpacing Property

LineSpacing Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : LineSpacing Property

Gets or sets the line spacing.

Syntax

Visual Basic (Declaration)
Public Property LineSpacing As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions
Dim value As Double

instance.LineSpacing = value

value = instance.LineSpacing
C#
public double LineSpacing {get; set;}
Managed Extensions for C++
public: __property double get_LineSpacing();
public: __property void set_LineSpacing(
   double value
);
C++/CLI
public:
property double LineSpacing {
   double get();
   void set (double value);
}

Return Value

a float value specifying the additional space to be added between lines of text.

Remarks

If this value is negative, then the lines of text will be drawn closer. The value of this property is given in points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


Orientation Property

Orientation Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace > PDFTextFormatOptions Class : Orientation Property

Gets or sets the text box orientation.

Syntax

Visual Basic (Declaration)
Public Property Orientation As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFTextFormatOptions
Dim value As Double

instance.Orientation = value

value = instance.Orientation
C#
public double Orientation {get; set;}
Managed Extensions for C++
public: __property double get_Orientation();
public: __property void set_Orientation(
   double value
);
C++/CLI
public:
property double Orientation {
   double get();
   void set (double value);
}

Return Value

a float value specifying the rotation angle of the text box.

Remarks

The text boxes are always rotated around the top left corner.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextFormatOptions Class
PDFTextFormatOptions Members


PDFCcittFaxCompression Enumeration

PDFCcittFaxCompression Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFCcittFaxCompression Enumeration

Specifies the available CCITT fax compression modes.

Syntax

Visual Basic (Declaration)
Public Enum PDFCcittFaxCompression
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFCcittFaxCompression
C#
public enum PDFCcittFaxCompression : Enum
Managed Extensions for C++
__value public enum PDFCcittFaxCompression : public Enum
C++/CLI
public enum class PDFCcittFaxCompression : public Enum

Members

Member | Description
CcittFaxG31D | 1D CCITT Fax Group 3
CcittFaxG32D | 2D CCITT Fax Group 3
CcittFaxG4 | CCITT Fax Group 4

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Shapes.PDFCcittFaxCompression

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFClipText Enumeration

PDFClipText Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFClipText Enumeration

Specifies the available cliping modes when displaying a text box

Syntax

Visual Basic (Declaration)
Public Enum PDFClipText
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFClipText
C#
public enum PDFClipText : Enum
Managed Extensions for C++
__value public enum PDFClipText : public Enum
C++/CLI
public enum class PDFClipText : public Enum

Members

Member | Description
ClipNone | The text is not clipped, it can flow outside the text box when text lines height is greater than text box height.
ClipGlyphs | The text is clipped at text box boundary allowing partial text lines to be displayed within the text box.
ClipWords | The text is logically clipped at word level, only the fully visible lines of text are displayed within the text box.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Shapes.PDFClipText

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFImageCompression Enumeration

PDFImageCompression Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFImageCompression Enumeration

Specifies the available compression methods for storing an image in the PDF file.

Syntax

Visual Basic (Declaration)
Public Enum PDFImageCompression
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFImageCompression
C#
public enum PDFImageCompression : Enum
Managed Extensions for C++
__value public enum PDFImageCompression : public Enum
C++/CLI
public enum class PDFImageCompression : public Enum

Members

Member | Description
Default | The library decides what compression method will be used.
Deflate | The image data is compressed using DEFLATE method.
JPEG | The image data is compressed using JPEG (DCT) method.
CCITTG4 | Image data is compressed using CCITT G4 method. Valid only for 1bpp images.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Shapes.PDFImageCompression

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFKeepAspectRatio Enumeration

PDFKeepAspectRatio Enumeration
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFKeepAspectRatio Enumeration

Specifies the available modes to resize an image when it is drawn on the page.

Syntax

Visual Basic (Declaration)
Public Enum PDFKeepAspectRatio
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PDFKeepAspectRatio
C#
public enum PDFKeepAspectRatio : Enum
Managed Extensions for C++
__value public enum PDFKeepAspectRatio : public Enum
C++/CLI
public enum class PDFKeepAspectRatio : public Enum

Members

Member | Description
KeepNone | The image is drawn on the page using the specified Width and Height values.
KeepWidth | The image is drawn on the page using the specified Width. The Height is automatically computed in order to keep the original aspect ratio of the image.
KeepHeight | The image is drawn on the page using the specified Height. The Width is automatically computed in order to keep the original aspect ratio of the image.
KeepBoth | The image is drawn inside the given rectangle while keeping the original aspect ratio.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Graphics.Shapes.PDFKeepAspectRatio

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Graphics.Shapes Namespace


O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFAlphaChannelMask | Defines an image based mask for an image.
PDFBaseImageMask | Defines a base class for all image masks.
PDFColorImageMask | Defines a color-key mask for an image.
PDFImageMask | Defines an image based mask for an image.

See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace Inheritance Hierarchy

O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFBaseImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFColorImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFAlphaChannelMask

See Also

Reference

O2S.Components.PDF4NET Assembly


PDFAlphaChannelMask Class

PDFAlphaChannelMask Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFAlphaChannelMask Class

Defines an image based mask for an image.

Syntax

Visual Basic (Declaration)
Public Class PDFAlphaChannelMask
   Inherits PDFImageMask
Visual Basic (Usage) Copy Code
Dim instance As PDFAlphaChannelMask
C#
public class PDFAlphaChannelMask : PDFImageMask
Managed Extensions for C++
public __gc class PDFAlphaChannelMask : public PDFImageMask
C++/CLI
public ref class PDFAlphaChannelMask : public PDFImageMask

Remarks

An alpha channel mask allows to specify a grayscale bitmap that defines the alpha channel values for the image. Only grayscale images are supported as alpha channel masks.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFBaseImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFAlphaChannelMask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAlphaChannelMask Members
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


PDFAlphaChannelMask Class Members

PDFAlphaChannelMask Class Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFAlphaChannelMask Class

The following tables list the members exposed by PDFAlphaChannelMask.

Public Constructors

 | Name | Description
Public Constructor | PDFAlphaChannelMask Constructor | Overloaded. Initializes a new PDFImageMask object based on a file.
Top

See Also

Reference

PDFAlphaChannelMask Class
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


PDFAlphaChannelMask Constructor

PDFAlphaChannelMask Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFAlphaChannelMask Class : PDFAlphaChannelMask Constructor

Initializes a new PDFImageMask object based on a file.

Overload List

Overload | Description
PDFAlphaChannelMask Constructor(Bitmap) | Initializes a new PDFImageMask object based on a Image object.
PDFAlphaChannelMask Constructor(Stream) | Initializes a new PDFImageMask object based on a stream.
PDFAlphaChannelMask Constructor(String) | Initializes a new PDFImageMask object based on a file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAlphaChannelMask Class
PDFAlphaChannelMask Members


PDFAlphaChannelMask Constructor(Bitmap)

PDFAlphaChannelMask Constructor(Bitmap)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFAlphaChannelMask Class > PDFAlphaChannelMask Constructor : PDFAlphaChannelMask Constructor(Bitmap)

image
the image representing the mask
Initializes a new PDFImageMask object based on a Image object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal image As Bitmap _
)
Visual Basic (Usage) Copy Code
Dim image As Bitmap

Dim instance As PDFAlphaChannelMask(image)
C#
public PDFAlphaChannelMask(
   Bitmap image
)
Managed Extensions for C++
public: PDFAlphaChannelMask(
   Bitmap image
)
C++/CLI
public:
PDFAlphaChannelMask(
   Bitmap image
)

Parameters

image
the image representing the mask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAlphaChannelMask Class
PDFAlphaChannelMask Members
Overload List


PDFAlphaChannelMask Constructor(Stream)

PDFAlphaChannelMask Constructor(Stream)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFAlphaChannelMask Class > PDFAlphaChannelMask Constructor : PDFAlphaChannelMask Constructor(Stream)

stream
the stream representing the mask
Initializes a new PDFImageMask object based on a stream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As PDFAlphaChannelMask(stream)
C#
public PDFAlphaChannelMask(
   Stream stream
)
Managed Extensions for C++
public: PDFAlphaChannelMask(
   Stream* stream
)
C++/CLI
public:
PDFAlphaChannelMask(
   Stream^ stream
)

Parameters

stream
the stream representing the mask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAlphaChannelMask Class
PDFAlphaChannelMask Members
Overload List


PDFAlphaChannelMask Constructor(String)

PDFAlphaChannelMask Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFAlphaChannelMask Class > PDFAlphaChannelMask Constructor : PDFAlphaChannelMask Constructor(String)

fileName
the file representing the mask
Initializes a new PDFImageMask object based on a file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As PDFAlphaChannelMask(fileName)
C#
public PDFAlphaChannelMask(
   string fileName
)
Managed Extensions for C++
public: PDFAlphaChannelMask(
   string* fileName
)
C++/CLI
public:
PDFAlphaChannelMask(
   String^ fileName
)

Parameters

fileName
the file representing the mask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFAlphaChannelMask Class
PDFAlphaChannelMask Members
Overload List


PDFBaseImageMask Class

PDFBaseImageMask Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFBaseImageMask Class

Defines a base class for all image masks.

Syntax

Visual Basic (Declaration)
Public MustInherit Class PDFBaseImageMask
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseImageMask
C#
public abstract class PDFBaseImageMask
Managed Extensions for C++
public __gc abstract class PDFBaseImageMask
C++/CLI
public ref class PDFBaseImageMask abstract

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFBaseImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFColorImageMask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseImageMask Members
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


PDFBaseImageMask Class Members

PDFBaseImageMask Class Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFBaseImageMask Class

The following tables list the members exposed by PDFBaseImageMask.

Public Constructors

 | Name | Description
Public Constructor | PDFBaseImageMask Constructor | Initializes a new PDFBaseImageMask object.
Top

See Also

Reference

PDFBaseImageMask Class
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


PDFBaseImageMask Constructor

PDFBaseImageMask Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFBaseImageMask Class : PDFBaseImageMask Constructor

Initializes a new PDFBaseImageMask object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFBaseImageMask()
C#
public PDFBaseImageMask()
Managed Extensions for C++
public: PDFBaseImageMask();
C++/CLI
public:
PDFBaseImageMask();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFBaseImageMask Class
PDFBaseImageMask Members


PDFColorImageMask Class

PDFColorImageMask Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFColorImageMask Class

Defines a color-key mask for an image.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PDFColorImageMask
   Inherits PDFBaseImageMask
Visual Basic (Usage) Copy Code
Dim instance As PDFColorImageMask
C#
public sealed class PDFColorImageMask : PDFBaseImageMask
Managed Extensions for C++
public __gc __sealed class PDFColorImageMask : public PDFBaseImageMask
C++/CLI
public ref class PDFColorImageMask sealed : public PDFBaseImageMask

Remarks

A color-key mask allows to specify a range of colors within an image to be treated as transparent when the image is painted on the page. All the colors between startColor and endColor will be treated as transparent.
A color is considered higher than startColor and lower than endColor when all its components meet this considition individually. For example, in RGB colorspace, being given the color C with its components (Cr, Cg, Cb), then startColor (SC) <= C <= endColor (EC) when:
SCr <= Cr <= ECr AND SCg <= Cg <= ECg AND SCb <= Cb <= ECb.
Note: A color image mask should not be used with jpeg images because they use a lossy image compression and unwanted effects might appear.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFBaseImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFColorImageMask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColorImageMask Members
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


PDFColorImageMask Class Members

PDFColorImageMask Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFColorImageMask Class

The following tables list the members exposed by PDFColorImageMask.

Public Constructors

 | Name | Description
Public Constructor | PDFColorImageMask Constructor | Overloaded. Initializes a new PDFColorImageMask object considering white as transparent color.
Top

Public Properties

 | Name | Description
Public Property | EndColor | Gets or sets the end color for image mask.
Public Property | StartColor | Gets or sets the start color for image mask.
Top

See Also

Reference

PDFColorImageMask Class
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


PDFColorImageMask Constructor

PDFColorImageMask Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFColorImageMask Class : PDFColorImageMask Constructor

Initializes a new PDFColorImageMask object considering white as transparent color.

Overload List

Overload | Description
PDFColorImageMask Constructor() | Initializes a new PDFColorImageMask object considering white as transparent color.
PDFColorImageMask Constructor(PDFColor,PDFColor) | Initializes a new PDFColorImageMask object specifying a start and an end color for the image mask.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColorImageMask Class
PDFColorImageMask Members


PDFColorImageMask Constructor()

PDFColorImageMask Constructor()
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFColorImageMask Class > PDFColorImageMask Constructor : PDFColorImageMask Constructor()

Initializes a new PDFColorImageMask object considering white as transparent color.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFColorImageMask()
C#
public PDFColorImageMask()
Managed Extensions for C++
public: PDFColorImageMask();
C++/CLI
public:
PDFColorImageMask();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColorImageMask Class
PDFColorImageMask Members
Overload List


PDFColorImageMask Constructor(PDFColor,PDFColor)

PDFColorImageMask Constructor(PDFColor,PDFColor)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFColorImageMask Class > PDFColorImageMask Constructor : PDFColorImageMask Constructor(PDFColor,PDFColor)

startColor
the start color for the image mask.
endColor
the end color for the image mask.
Initializes a new PDFColorImageMask object specifying a start and an end color for the image mask.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal startColor As PDFColor, _
   ByVal endColor As PDFColor _
)
Visual Basic (Usage) Copy Code
Dim startColor As PDFColor
Dim endColor As PDFColor

Dim instance As PDFColorImageMask(startColor, endColor)
C#
public PDFColorImageMask(
   PDFColor startColor,
   PDFColor endColor
)
Managed Extensions for C++
public: PDFColorImageMask(
   PDFColor* startColor,
   PDFColor* endColor
)
C++/CLI
public:
PDFColorImageMask(
   PDFColor^ startColor,
   PDFColor^ endColor
)

Parameters

startColor
the start color for the image mask.
endColor
the end color for the image mask.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColorImageMask Class
PDFColorImageMask Members
Overload List


PDFColorImageMask Class Properties

PDFColorImageMask Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFColorImageMask Class

For a list of all members of this type, see PDFColorImageMask members.

Public Properties

 | Name | Description
Public Property | EndColor | Gets or sets the end color for image mask.
Public Property | StartColor | Gets or sets the start color for image mask.
Top

See Also

Reference

PDFColorImageMask Class
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


EndColor Property

EndColor Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFColorImageMask Class : EndColor Property

Gets or sets the end color for image mask.

Syntax

Visual Basic (Declaration)
Public Property EndColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFColorImageMask
Dim value As PDFColor

instance.EndColor = value

value = instance.EndColor
C#
public PDFColor EndColor {get; set;}
Managed Extensions for C++
public: __property PDFColor* get_EndColor();
public: __property void set_EndColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ EndColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the end color for the image mask.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColorImageMask Class
PDFColorImageMask Members


StartColor Property

StartColor Property
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFColorImageMask Class : StartColor Property

Gets or sets the start color for image mask.

Syntax

Visual Basic (Declaration)
Public Property StartColor As PDFColor
Visual Basic (Usage) Copy Code
Dim instance As PDFColorImageMask
Dim value As PDFColor

instance.StartColor = value

value = instance.StartColor
C#
public PDFColor StartColor {get; set;}
Managed Extensions for C++
public: __property PDFColor* get_StartColor();
public: __property void set_StartColor(
   PDFColor* value
);
C++/CLI
public:
property PDFColor^ StartColor {
   PDFColor^ get();
   void set (PDFColor^ value);
}

Return Value

A O2S.Components.PDF4NET.Graphics.PDFColor object specifying the start color for the image mask.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFColorImageMask Class
PDFColorImageMask Members


PDFImageMask Class

PDFImageMask Class
See Also Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFImageMask Class

Defines an image based mask for an image.

Syntax

Visual Basic (Declaration)
Public Class PDFImageMask
   Inherits PDFBaseImageMask
Visual Basic (Usage) Copy Code
Dim instance As PDFImageMask
C#
public class PDFImageMask : PDFBaseImageMask
Managed Extensions for C++
public __gc class PDFImageMask : public PDFBaseImageMask
C++/CLI
public ref class PDFImageMask : public PDFBaseImageMask

Remarks

An image based mask allows to specify a monochrome bitmap that defines what regions of the base image will be painted or not on the page.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFBaseImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFImageMask
O2S.Components.PDF4NET.Graphics.Shapes.Transparency.PDFAlphaChannelMask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImageMask Members
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


PDFImageMask Class Members

PDFImageMask Class Members
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace : PDFImageMask Class

The following tables list the members exposed by PDFImageMask.

Public Constructors

 | Name | Description
Public Constructor | PDFImageMask Constructor | Overloaded. Initializes a new PDFImageMask object based on a file.
Top

See Also

Reference

PDFImageMask Class
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace


PDFImageMask Constructor

PDFImageMask Constructor
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFImageMask Class : PDFImageMask Constructor

Initializes a new PDFImageMask object based on a file.

Overload List

Overload | Description
PDFImageMask Constructor(Bitmap) | Initializes a new PDFImageMask object based on a Image object.
PDFImageMask Constructor(Stream) | Initializes a new PDFImageMask object based on a stream.
PDFImageMask Constructor(String) | Initializes a new PDFImageMask object based on a file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImageMask Class
PDFImageMask Members


PDFImageMask Constructor(Bitmap)

PDFImageMask Constructor(Bitmap)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFImageMask Class > PDFImageMask Constructor : PDFImageMask Constructor(Bitmap)

image
the image representing the mask
Initializes a new PDFImageMask object based on a Image object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal image As Bitmap _
)
Visual Basic (Usage) Copy Code
Dim image As Bitmap

Dim instance As PDFImageMask(image)
C#
public PDFImageMask(
   Bitmap image
)
Managed Extensions for C++
public: PDFImageMask(
   Bitmap image
)
C++/CLI
public:
PDFImageMask(
   Bitmap image
)

Parameters

image
the image representing the mask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImageMask Class
PDFImageMask Members
Overload List


PDFImageMask Constructor(Stream)

PDFImageMask Constructor(Stream)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFImageMask Class > PDFImageMask Constructor : PDFImageMask Constructor(Stream)

stream
the stream representing the mask
Initializes a new PDFImageMask object based on a stream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As PDFImageMask(stream)
C#
public PDFImageMask(
   Stream stream
)
Managed Extensions for C++
public: PDFImageMask(
   Stream* stream
)
C++/CLI
public:
PDFImageMask(
   Stream^ stream
)

Parameters

stream
the stream representing the mask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImageMask Class
PDFImageMask Members
Overload List


PDFImageMask Constructor(String)

PDFImageMask Constructor(String)
See Also
[image]
O2S.Components.PDF4NET.Graphics.Shapes.Transparency Namespace > PDFImageMask Class > PDFImageMask Constructor : PDFImageMask Constructor(String)

fileName
the file representing the mask
Initializes a new PDFImageMask object based on a file.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As PDFImageMask(fileName)
C#
public PDFImageMask(
   string fileName
)
Managed Extensions for C++
public: PDFImageMask(
   string* fileName
)
C++/CLI
public:
PDFImageMask(
   String^ fileName
)

Parameters

fileName
the file representing the mask

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImageMask Class
PDFImageMask Members
Overload List


O2S.Components.PDF4NET.PDFFile Namespace

O2S.Components.PDF4NET.PDFFile Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFFile | Represents a pdf file on disk.
PDFImportedContent | Represents the binary content of a page in a pdf file.
PDFImportedPage | Represents a page in a pdf file.
PDFImportedPageInfo | Defines the properties of an imported page but without actual page content.

See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET.PDFFile Namespace Inheritance Hierarchy

O2S.Components.PDF4NET.PDFFile Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFFile.PDFFile
O2S.Components.PDF4NET.PDFFile.PDFImportedPageInfo
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.PDFFile.PDFImportedContent
O2S.Components.PDF4NET.PDFPage
O2S.Components.PDF4NET.PDFFile.PDFImportedPage

See Also

Reference

O2S.Components.PDF4NET Assembly


PDFFile Class

PDFFile Class
See Also Members
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFFile Class

Represents a pdf file on disk.

Syntax

Visual Basic (Declaration)
Public Class PDFFile
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
C#
public class PDFFile
Managed Extensions for C++
public __gc class PDFFile
C++/CLI
public ref class PDFFile

Remarks

This class defines an existing pdf file. Its methods allows to perform various operations on pdf files. It allows to merge multiple pdf files, split pdf files to individual pages, apply security to existing pdf files, extract full pages or their content from pdf files.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFFile.PDFFile

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Members
O2S.Components.PDF4NET.PDFFile Namespace


PDFFile Class Members

PDFFile Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFFile Class

The following tables list the members exposed by PDFFile.

Public Properties

 | Name | Description
Public Property | PagesCount | Gets the number of pages in the PDF file.
Public Property | SerialNumber | Sets the serial number and unlocks the component.
Top

Public Methods

 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
Public Method | Dispose | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | EncryptFile | Overloaded. Encrypts the given pdf file with the security settings specified by securityManager parameter.
Public Method | ExtractPage | Extracts the specified page from the current file.
Public Method | ExtractPageContent | Gets the binary content of the specified page.
Public Method | ExtractPageInfo | Extracts the specified page information from the current file.
Public Method | ExtractPages | Overloaded. Gets an array of imported page objects representing the pages given as parameter.
Public Method | ExtractPagesContent | Overloaded. Gets an array of imported content objects representing the binary content of the pages given as parameter.
Public Method | ExtractPagesInfo | Gets an array of imported page info objects representing the pages given as parameter.
static (Shared in Visual Basic) | FromFile | Overloaded. Creates a PDFFile object from the given pdf file.
static (Shared in Visual Basic) | FromStream | Overloaded. Creates a PDFFile object from the given stream object.
Public Method | GetJavaScripts | Gets the JavaScript code fragments embedded in the PDF file.
Public Method | GetPageNumberingRanges | Gets the page numbering ranges included in the PDF file.
static (Shared in Visual Basic) | MergeFiles | Overloaded. Merges multiple pdf files into a single pdf file.
static (Shared in Visual Basic) | SplitFile | Splits the given pdf file to individual pages.
Top

See Also

Reference

PDFFile Class
O2S.Components.PDF4NET.PDFFile Namespace


PDFFile Class Methods

PDFFile Class Methods
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFFile Class

For a list of all members of this type, see PDFFile members.

Public Methods

 | Name | Description
Public Method | Close | Closes the underlying pdf file and frees all resources.
Public Method | Dispose | Closes the underlying pdf file and frees all resources.
static (Shared in Visual Basic) | EncryptFile | Overloaded. Encrypts the given pdf file with the security settings specified by securityManager parameter.
Public Method | ExtractPage | Extracts the specified page from the current file.
Public Method | ExtractPageContent | Gets the binary content of the specified page.
Public Method | ExtractPageInfo | Extracts the specified page information from the current file.
Public Method | ExtractPages | Overloaded. Gets an array of imported page objects representing the pages given as parameter.
Public Method | ExtractPagesContent | Overloaded. Gets an array of imported content objects representing the binary content of the pages given as parameter.
Public Method | ExtractPagesInfo | Gets an array of imported page info objects representing the pages given as parameter.
static (Shared in Visual Basic) | FromFile | Overloaded. Creates a PDFFile object from the given pdf file.
static (Shared in Visual Basic) | FromStream | Overloaded. Creates a PDFFile object from the given stream object.
Public Method | GetJavaScripts | Gets the JavaScript code fragments embedded in the PDF file.
Public Method | GetPageNumberingRanges | Gets the page numbering ranges included in the PDF file.
static (Shared in Visual Basic) | MergeFiles | Overloaded. Merges multiple pdf files into a single pdf file.
static (Shared in Visual Basic) | SplitFile | Splits the given pdf file to individual pages.
Top

See Also

Reference

PDFFile Class
O2S.Components.PDF4NET.PDFFile Namespace


Close Method

Close Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : Close Method

Closes the underlying pdf file and frees all resources.

Syntax

Visual Basic (Declaration)
Public Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As PDFFile

instance.Close()
C#
public void Close()
Managed Extensions for C++
public: void Close();
C++/CLI
public:
void Close();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


Dispose Method

Dispose Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : Dispose Method

Closes the underlying pdf file and frees all resources.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As PDFFile

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


EncryptFile Method

EncryptFile Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : EncryptFile Method

Encrypts the given pdf file with the security settings specified by securityManager parameter.

Overload List

Overload | Description
EncryptFile(PDFSecurityManager,String,String) | Encrypts the given pdf file with the security settings specified by securityManager parameter.
EncryptFile(PDFSecurityManager,String) | Encrypts the given pdf file with the security settings specified by securityManager parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


EncryptFile(PDFSecurityManager,String,String) Method

EncryptFile(PDFSecurityManager,String,String) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > EncryptFile Method : EncryptFile(PDFSecurityManager,String,String) Method

securityManager
a PDFSecurityManager object specifying the security settings for the destination pdf file.
srcFileName
the source pdf file that will be encrypted.
destFileName
the destination pdf file where the encrypted docment will be saved.
Encrypts the given pdf file with the security settings specified by securityManager parameter.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Sub EncryptFile( _
   ByVal securityManager As PDFSecurityManager, _
   ByVal srcFileName As String, _
   ByVal destFileName As String _
)
Visual Basic (Usage) Copy Code
Dim securityManager As PDFSecurityManager
Dim srcFileName As String
Dim destFileName As String

PDFFile.EncryptFile(securityManager, srcFileName, destFileName)
C#
public static void EncryptFile(
   PDFSecurityManager securityManager,
   string srcFileName,
   string destFileName
)
Managed Extensions for C++
public: static void EncryptFile(
   PDFSecurityManager* securityManager,
   string* srcFileName,
   string* destFileName
)
C++/CLI
public:
static void EncryptFile(
   PDFSecurityManager^ securityManager,
   String^ srcFileName,
   String^ destFileName
)

Parameters

securityManager
a PDFSecurityManager object specifying the security settings for the destination pdf file.
srcFileName
the source pdf file that will be encrypted.
destFileName
the destination pdf file where the encrypted docment will be saved.

Exceptions

Exception | Description
PDFParserException | thrown when input pdf files can not be parsed.

Remarks

This method encrypts an existing pdf file specified by srcFileName and saves the encrypted file to the location specified by destFileName parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


EncryptFile(PDFSecurityManager,String) Method

EncryptFile(PDFSecurityManager,String) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > EncryptFile Method : EncryptFile(PDFSecurityManager,String) Method

securityManager
a PDFSecurityManager object specifying the security settings for the destination pdf file.
srcFileName
the source pdf file that will be encrypted.
Encrypts the given pdf file with the security settings specified by securityManager parameter.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function EncryptFile( _
   ByVal securityManager As PDFSecurityManager, _
   ByVal srcFileName As String _
) As PDFDocument
Visual Basic (Usage) Copy Code
Dim securityManager As PDFSecurityManager
Dim srcFileName As String
Dim value As PDFDocument

value = PDFFile.EncryptFile(securityManager, srcFileName)
C#
public static PDFDocument EncryptFile(
   PDFSecurityManager securityManager,
   string srcFileName
)
Managed Extensions for C++
public: static PDFDocument* EncryptFile(
   PDFSecurityManager* securityManager,
   string* srcFileName
)
C++/CLI
public:
static PDFDocument^ EncryptFile(
   PDFSecurityManager^ securityManager,
   String^ srcFileName
)

Parameters

securityManager
a PDFSecurityManager object specifying the security settings for the destination pdf file.
srcFileName
the source pdf file that will be encrypted.

Return Value

a PDFDocument object representing the encrypted source pdf file

Exceptions

Exception | Description
PDFParserException | thrown when input pdf files can not be parsed.

Remarks

This method encrypts an existing pdf file specified by srcFileName and saves the encrypted file to the location specified by destFileName parameter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPage Method

ExtractPage Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPage Method

pageNumber
the number of the page tha will be extracted.
Extracts the specified page from the current file.

Syntax

Visual Basic (Declaration)
Public Function ExtractPage( _
   ByVal pageNumber As Integer _
) As PDFImportedPage
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim pageNumber As Integer
Dim value As PDFImportedPage

value = instance.ExtractPage(pageNumber)
C#
public PDFImportedPage ExtractPage(
   int pageNumber
)
Managed Extensions for C++
public: PDFImportedPage* ExtractPage(
   int pageNumber
)
C++/CLI
public:
PDFImportedPage^ ExtractPage(
   int pageNumber
)

Parameters

pageNumber
the number of the page tha will be extracted.

Return Value

a PDFImportedPage object representing the extracted page.

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when pageNumber is less than zero or greater than or equal to number of pages in the current pdf file.

Remarks

This method extracts a full page from the current pdf file. This page can be later inserted in any new document keeping all the attributes it had in the old document. Use AddPage method to insert the extracted page into a new document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


ExtractPageContent Method

ExtractPageContent Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPageContent Method

pageNumber
the number of the page whose binary content should be retrieved.
Gets the binary content of the specified page.

Syntax

Visual Basic (Declaration)
Public Function ExtractPageContent( _
   ByVal pageNumber As Integer _
) As PDFImportedContent
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim pageNumber As Integer
Dim value As PDFImportedContent

value = instance.ExtractPageContent(pageNumber)
C#
public PDFImportedContent ExtractPageContent(
   int pageNumber
)
Managed Extensions for C++
public: PDFImportedContent* ExtractPageContent(
   int pageNumber
)
C++/CLI
public:
PDFImportedContent^ ExtractPageContent(
   int pageNumber
)

Parameters

pageNumber
the number of the page whose binary content should be retrieved.

Return Value

a PDFImportedContent object representing the binary representation of the page.

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when pageNumber is less than zero or greater than or equal to number of pages in the current pdf file.

Remarks

This method extracts the binary content of the given page. This content can be later painted on any page canvas. It also can be scaled or rotated and can be painted multiple times. When the binary content of a page is extracted, its width and height are initially equal to the width and height of the original page. Use O2S.Components.PDF4NET.Graphics.PDFBasicCanvas.DrawImportedContent(PDFImportedContent,Double,Double,Double,Double) method to draw the imported content on a new page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


ExtractPageInfo Method

ExtractPageInfo Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPageInfo Method

pageNumber
the number of the page for which information will be extracted.
Extracts the specified page information from the current file.

Syntax

Visual Basic (Declaration)
Public Function ExtractPageInfo( _
   ByVal pageNumber As Integer _
) As PDFImportedPageInfo
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim pageNumber As Integer
Dim value As PDFImportedPageInfo

value = instance.ExtractPageInfo(pageNumber)
C#
public PDFImportedPageInfo ExtractPageInfo(
   int pageNumber
)
Managed Extensions for C++
public: PDFImportedPageInfo* ExtractPageInfo(
   int pageNumber
)
C++/CLI
public:
PDFImportedPageInfo^ ExtractPageInfo(
   int pageNumber
)

Parameters

pageNumber
the number of the page for which information will be extracted.

Return Value

A PDFImportedPageInfo object representing the page information.

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when pageNumber is less than zero or greater than or equal to number of pages in the current pdf file.

Remarks

This method extracts a only the page information from the current pdf file, no page content is extracted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


ExtractPages Method

ExtractPages Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPages Method

Gets an array of imported page objects representing the pages given as parameter.

Overload List

Overload | Description
ExtractPages(String) | Gets an array of imported page objects representing the pages given as parameter.
ExtractPages() | Gets an array of imported page objects representing all the pages in the file.
ExtractPages(String,Int32,Int32) | Gets an array of imported page objects representing the pages in the range specified by startPage and endPage parameters.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


ExtractPages(String) Method

ExtractPages(String) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPages Method : ExtractPages(String) Method

pageNumbers
a set of page numbers, separated by comma or dash, specifying the pages that should be extracted.
Gets an array of imported page objects representing the pages given as parameter.

Syntax

Visual Basic (Declaration)
Overloads Public Function ExtractPages( _
   ByVal pageNumbers As String _
) As PDFImportedPage()
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim pageNumbers As String
Dim value() As PDFImportedPage

value = instance.ExtractPages(pageNumbers)
C#
public PDFImportedPage[] ExtractPages(
   string pageNumbers
)
Managed Extensions for C++
public: PDFImportedPage*[]* ExtractPages(
   string* pageNumbers
)
C++/CLI
public:
array<PDFImportedPage^>^ ExtractPages(
   String^ pageNumbers
)

Parameters

pageNumbers
a set of page numbers, separated by comma or dash, specifying the pages that should be extracted.

Return Value

an array of PDFImportedPage objects representing the pages given as paramter.

Exceptions

Exception | Description
PDFParserException | thrown when any of the page numbers is less than zero or greater than or equal to number of pages in the current pdf file.

Remarks

This method extracts the given set of pages. These pages can be inserted in any new document. Use Add method to add imported page to current document.
The page numbers are specified using a comma or dash separated list. Page numbers separated by comma represent single pages, while dash separated page numbers represent page ranges. "1,2,3" represents pages 2, 3 and 4 (remember the page number as parameter is zero based), while "2-5" represents pages 3, 4, 5 and 6. A pages list can contain both comma and dashes, ex: "1, 3, 5-7, 10" meaning that pages 2, 4, 6, 7, 8 and 11 will be extracted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPages() Method

ExtractPages() Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPages Method : ExtractPages() Method

Gets an array of imported page objects representing all the pages in the file.

Syntax

Visual Basic (Declaration)
Overloads Public Function ExtractPages() As PDFImportedPage()
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim value() As PDFImportedPage

value = instance.ExtractPages()
C#
public PDFImportedPage[] ExtractPages()
Managed Extensions for C++
public: PDFImportedPage*[]* ExtractPages();
C++/CLI
public:
array<PDFImportedPage^>^ ExtractPages();

Return Value

an array of PDFImportedPage objects representing all the pages in the file.

Exceptions

Exception | Description
PDFParserException | Thrown when page content can not be extracted due to a PDF parsing error.

Remarks

This method extracts all the pages in the file. These pages can be inserted in any new document. Use AddPage method to add imported page to current document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPages(String,Int32,Int32) Method

ExtractPages(String,Int32,Int32) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPages Method : ExtractPages(String,Int32,Int32) Method

fileName
the PDF file from which the pages are extracted.
startPage
the zero based index of the first page in the range.
endPage
the zero based index of the last page in the range.
Gets an array of imported page objects representing the pages in the range specified by startPage and endPage parameters.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function ExtractPages( _
   ByVal fileName As String, _
   ByVal startPage As Integer, _
   ByVal endPage As Integer _
) As PDFImportedPage()
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim startPage As Integer
Dim endPage As Integer
Dim value() As PDFImportedPage

value = PDFFile.ExtractPages(fileName, startPage, endPage)
C#
public static PDFImportedPage[] ExtractPages(
   string fileName,
   int startPage,
   int endPage
)
Managed Extensions for C++
public: static PDFImportedPage*[]* ExtractPages(
   string* fileName,
   int startPage,
   int endPage
)
C++/CLI
public:
static array<PDFImportedPage^>^ ExtractPages(
   String^ fileName,
   int startPage,
   int endPage
)

Parameters

fileName
the PDF file from which the pages are extracted.
startPage
the zero based index of the first page in the range.
endPage
the zero based index of the last page in the range.

Return Value

an array of PDFImportedPage objects representing the requested range of consecutive pages.

Exceptions

Exception | Description
PDFParserException | thrown when any of the page numbers is less than zero or greater than or equal to number of pages in the given pdf file.

Remarks

This method extracts a consecutive range of pages from the given PDF file. These pages can be inserted in any new document. Use AddPage method to add imported page to current document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPagesContent Method

ExtractPagesContent Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPagesContent Method

Gets an array of imported content objects representing the binary content of the pages given as parameter.

Overload List

Overload | Description
ExtractPagesContent(String) | Gets an array of imported content objects representing the binary content of the pages given as parameter.
ExtractPagesContent() | Gets an array of imported content objects representing the binary content of all the pages in the file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


ExtractPagesContent(String) Method

ExtractPagesContent(String) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPagesContent Method : ExtractPagesContent(String) Method

pageNumbers
a set of page numbers, separated by comma or dash, specifying the page numbers whose content should be extracted.
Gets an array of imported content objects representing the binary content of the pages given as parameter.

Syntax

Visual Basic (Declaration)
Overloads Public Function ExtractPagesContent( _
   ByVal pageNumbers As String _
) As PDFImportedContent()
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim pageNumbers As String
Dim value() As PDFImportedContent

value = instance.ExtractPagesContent(pageNumbers)
C#
public PDFImportedContent[] ExtractPagesContent(
   string pageNumbers
)
Managed Extensions for C++
public: PDFImportedContent*[]* ExtractPagesContent(
   string* pageNumbers
)
C++/CLI
public:
array<PDFImportedContent^>^ ExtractPagesContent(
   String^ pageNumbers
)

Parameters

pageNumbers
a set of page numbers, separated by comma or dash, specifying the page numbers whose content should be extracted.

Return Value

an array of PDFImportedContent objects representing the binary content of the pages given as parameter.

Exceptions

Exception | Description
PDFParserException | thrown when any of the page numbers is less than zero or greater than or equal to number of pages in the current pdf file.

Remarks

This method extracts the binary content of the given set of pages. This content can be later painted on any page canvas. It also can be scaled or rotated and can be painted multiple times. When the binary content of a page is extracted, its width and height are initially equal to the width and height of the original page. Use O2S.Components.PDF4NET.Graphics.PDFBasicCanvas.DrawImportedContent(PDFImportedContent,Double,Double,Double,Double) method to draw the imported content on a new page.
The page numbers are specified using a comma or dash separated list. Page numbers separated by comma represent single pages, while dash separated page numbers represent page ranges. "1,2,3" represents pages 2, 3 and 4 (remember the page number as parameter is zero based), while "2-5" represents pages 3, 4, 5 and 6. A pages list can contain both comma and dashes, ex: "1, 3, 5-7, 10" meaning that pages 2, 4, 6, 7, 8 and 11 will be extracted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPagesContent() Method

ExtractPagesContent() Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > ExtractPagesContent Method : ExtractPagesContent() Method

Gets an array of imported content objects representing the binary content of all the pages in the file.

Syntax

Visual Basic (Declaration)
Overloads Public Function ExtractPagesContent() As PDFImportedContent()
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim value() As PDFImportedContent

value = instance.ExtractPagesContent()
C#
public PDFImportedContent[] ExtractPagesContent()
Managed Extensions for C++
public: PDFImportedContent*[]* ExtractPagesContent();
C++/CLI
public:
array<PDFImportedContent^>^ ExtractPagesContent();

Return Value

an array of PDFImportedContent objects representing the binary content of all the pages in the file.

Exceptions

Exception | Description
PDFParserException | Thrown when page content can not be extracted due to a PDF parsing error.

Remarks

This method extracts the binary content of all the pages in the file. This content can be later painted on any page canvas. It also can be scaled or rotated and can be painted multiple times. When the binary content of a page is extracted, its width and height are initially equal to the width and height of the original page. Use DrawImportedContent method to draw the imported content on a new page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


ExtractPagesInfo Method

ExtractPagesInfo Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : ExtractPagesInfo Method

pageNumbers
a set of page numbers, separated by comma or dash, specifying the pages whose information should be extracted.
Gets an array of imported page info objects representing the pages given as parameter.

Syntax

Visual Basic (Declaration)
Public Function ExtractPagesInfo( _
   ByVal pageNumbers As String _
) As PDFImportedPageInfo()
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim pageNumbers As String
Dim value() As PDFImportedPageInfo

value = instance.ExtractPagesInfo(pageNumbers)
C#
public PDFImportedPageInfo[] ExtractPagesInfo(
   string pageNumbers
)
Managed Extensions for C++
public: PDFImportedPageInfo*[]* ExtractPagesInfo(
   string* pageNumbers
)
C++/CLI
public:
array<PDFImportedPageInfo^>^ ExtractPagesInfo(
   String^ pageNumbers
)

Parameters

pageNumbers
a set of page numbers, separated by comma or dash, specifying the pages whose information should be extracted.

Return Value

an array of PDFImportedPageInfo objects representing the pages given as paramter.

Exceptions

Exception | Description
ArgumentOutOfRangeException | thrown when any of the page numbers is less than zero or greater than or equal to number of pages in the current pdf file.

Remarks

This method extracts the information for the given set of pages without extracting the whole page content.
The page numbers are specified using a comma or dash separated list. Page numbers separated by comma represent single pages, while dash separated page numbers represent page ranges. "1,2,3" represents pages 2, 3 and 4 (remember the page number as parameter is zero based), while "2-5" represents pages 3, 4, 5 and 6. A pages list can contain both comma and dashes, ex: "1, 3, 5-7, 10" meaning that pages 2, 4, 6, 7, 8 and 11 will be extracted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


FromFile Method

FromFile Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : FromFile Method

Creates a PDFFile object from the given pdf file.

Overload List

Overload | Description
FromFile(String) | Creates a PDFFile object from the given pdf file.
FromFile(String,Byte[]) | Creates a PDFFile object from the given pdf file.
FromFile(String,PDFDocumentLoadOptions) | Creates a PDFFile object from the given pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


FromFile(String) Method

FromFile(String) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromFile Method : FromFile(String) Method

fileName
the full path to a pdf file used as source for this PDFFile object.
Creates a PDFFile object from the given pdf file.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromFile( _
   ByVal fileName As String _
) As PDFFile
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim value As PDFFile

value = PDFFile.FromFile(fileName)
C#
public static PDFFile FromFile(
   string fileName
)
Managed Extensions for C++
public: static PDFFile* FromFile(
   string* fileName
)
C++/CLI
public:
static PDFFile^ FromFile(
   String^ fileName
)

Parameters

fileName
the full path to a pdf file used as source for this PDFFile object.

Return Value

A PDFFile object created based on the given pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


FromFile(String,Byte[]) Method

FromFile(String,Byte[]) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromFile Method : FromFile(String,Byte[]) Method

fileName
the full path to a pdf file used as source for this PDFFile object.
userPassword
the user password used to decrypt the PDF file.
Creates a PDFFile object from the given pdf file.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromFile( _
   ByVal fileName As String, _
   ByVal userPassword() As Byte _
) As PDFFile
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim userPassword() As Byte
Dim value As PDFFile

value = PDFFile.FromFile(fileName, userPassword)
C#
public static PDFFile FromFile(
   string fileName,
   byte[] userPassword
)
Managed Extensions for C++
public: static PDFFile* FromFile(
   string* fileName,
   byte[]* userPassword
)
C++/CLI
public:
static PDFFile^ FromFile(
   String^ fileName,
   array<byte>^ userPassword
)

Parameters

fileName
the full path to a pdf file used as source for this PDFFile object.
userPassword
the user password used to decrypt the PDF file.

Return Value

A PDFFile object created based on the given pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


FromFile(String,PDFDocumentLoadOptions) Method

FromFile(String,PDFDocumentLoadOptions) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromFile Method : FromFile(String,PDFDocumentLoadOptions) Method

fileName
the full path to a pdf file used as source for this PDFFile object.
loadOptions
options specifying what parts of the PDF file should be loaded.
Creates a PDFFile object from the given pdf file.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromFile( _
   ByVal fileName As String, _
   ByVal loadOptions As PDFDocumentLoadOptions _
) As PDFFile
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim loadOptions As PDFDocumentLoadOptions
Dim value As PDFFile

value = PDFFile.FromFile(fileName, loadOptions)
C#
public static PDFFile FromFile(
   string fileName,
   PDFDocumentLoadOptions loadOptions
)
Managed Extensions for C++
public: static PDFFile* FromFile(
   string* fileName,
   PDFDocumentLoadOptions* loadOptions
)
C++/CLI
public:
static PDFFile^ FromFile(
   String^ fileName,
   PDFDocumentLoadOptions^ loadOptions
)

Parameters

fileName
the full path to a pdf file used as source for this PDFFile object.
loadOptions
options specifying what parts of the PDF file should be loaded.

Return Value

A PDFFile object created based on the given pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


FromStream Method

FromStream Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : FromStream Method

Creates a PDFFile object from the given stream object.

Overload List

Overload | Description
FromStream(Stream) | Creates a PDFFile object from the given stream object.
FromStream(Stream,Byte[]) | Creates a PDFFile object from the given stream object.
FromStream(Stream,PDFDocumentLoadOptions) | Creates a PDFFile object from the given stream object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


FromStream(Stream) Method

FromStream(Stream) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromStream Method : FromStream(Stream) Method

stream
the stream object used as source for this PDFFile object.
Creates a PDFFile object from the given stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromStream( _
   ByVal stream As Stream _
) As PDFFile
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim value As PDFFile

value = PDFFile.FromStream(stream)
C#
public static PDFFile FromStream(
   Stream stream
)
Managed Extensions for C++
public: static PDFFile* FromStream(
   Stream* stream
)
C++/CLI
public:
static PDFFile^ FromStream(
   Stream^ stream
)

Parameters

stream
the stream object used as source for this PDFFile object.

Return Value

A PDFFile object created based on the given stream object.

Remarks

The stream must contain a valid pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


FromStream(Stream,Byte[]) Method

FromStream(Stream,Byte[]) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromStream Method : FromStream(Stream,Byte[]) Method

stream
the stream object used as source for this PDFFile object.
userPassword
the user password used to decrypt the PDF file.
Creates a PDFFile object from the given stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromStream( _
   ByVal stream As Stream, _
   ByVal userPassword() As Byte _
) As PDFFile
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim userPassword() As Byte
Dim value As PDFFile

value = PDFFile.FromStream(stream, userPassword)
C#
public static PDFFile FromStream(
   Stream stream,
   byte[] userPassword
)
Managed Extensions for C++
public: static PDFFile* FromStream(
   Stream* stream,
   byte[]* userPassword
)
C++/CLI
public:
static PDFFile^ FromStream(
   Stream^ stream,
   array<byte>^ userPassword
)

Parameters

stream
the stream object used as source for this PDFFile object.
userPassword
the user password used to decrypt the PDF file.

Return Value

A PDFFile object created based on the given stream object.

Remarks

The stream must contain a valid pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


FromStream(Stream,PDFDocumentLoadOptions) Method

FromStream(Stream,PDFDocumentLoadOptions) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > FromStream Method : FromStream(Stream,PDFDocumentLoadOptions) Method

stream
the stream object used as source for this PDFFile object.
loadOptions
options specifying what parts of the PDF file should be loaded.
Creates a PDFFile object from the given stream object.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function FromStream( _
   ByVal stream As Stream, _
   ByVal loadOptions As PDFDocumentLoadOptions _
) As PDFFile
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim loadOptions As PDFDocumentLoadOptions
Dim value As PDFFile

value = PDFFile.FromStream(stream, loadOptions)
C#
public static PDFFile FromStream(
   Stream stream,
   PDFDocumentLoadOptions loadOptions
)
Managed Extensions for C++
public: static PDFFile* FromStream(
   Stream* stream,
   PDFDocumentLoadOptions* loadOptions
)
C++/CLI
public:
static PDFFile^ FromStream(
   Stream^ stream,
   PDFDocumentLoadOptions^ loadOptions
)

Parameters

stream
the stream object used as source for this PDFFile object.
loadOptions
options specifying what parts of the PDF file should be loaded.

Return Value

A PDFFile object created based on the given stream object.

Remarks

The stream must contain a valid pdf file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


GetJavaScripts Method

GetJavaScripts Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : GetJavaScripts Method

Gets the JavaScript code fragments embedded in the PDF file.

Syntax

Visual Basic (Declaration)
Public Function GetJavaScripts() As PDFJavaScriptCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim value As PDFJavaScriptCollection

value = instance.GetJavaScripts()
C#
public PDFJavaScriptCollection GetJavaScripts()
Managed Extensions for C++
public: PDFJavaScriptCollection* GetJavaScripts();
C++/CLI
public:
PDFJavaScriptCollection^ GetJavaScripts();

Return Value

A collection of PDFJavaScript objects representing the JavaScript code fragments included in the PDF file.

Remarks

The PDF file must be open with the load options specifying that LoadJavaScripts property is true in order for the method below to return the existing JavaScripts.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


GetPageNumberingRanges Method

GetPageNumberingRanges Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : GetPageNumberingRanges Method

Gets the page numbering ranges included in the PDF file.

Syntax

Visual Basic (Declaration)
Public Function GetPageNumberingRanges() As PDFPageNumberingRangeCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim value As PDFPageNumberingRangeCollection

value = instance.GetPageNumberingRanges()
C#
public PDFPageNumberingRangeCollection GetPageNumberingRanges()
Managed Extensions for C++
public: PDFPageNumberingRangeCollection* GetPageNumberingRanges();
C++/CLI
public:
PDFPageNumberingRangeCollection^ GetPageNumberingRanges();

Return Value

A collection of PDFPageNumberingRange objects representing the page numbering ranges included in the PDF file.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


MergeFiles Method

MergeFiles Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : MergeFiles Method

Merges multiple pdf files into a single pdf file.

Overload List

Overload | Description
MergeFiles(String,String[]) | Merges multiple pdf files into a single pdf file.
MergeFiles(String,String[],Boolean) | Merges multiple pdf files into a single pdf file.
MergeFiles(String[]) | Merges multiple pdf files into a single PDFDocument object.
MergeFiles(Stream,Stream[]) | Merges multiple pdf files into a single pdf file.
MergeFiles(Stream,Stream[],Boolean) | Merges multiple pdf files into a single pdf file.
MergeFiles(Stream[]) | Merges multiple pdf files into a single PDFDocument object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


MergeFiles(String,String[]) Method

MergeFiles(String,String[]) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(String,String[]) Method

destFileName
the fully qualified name of the destination file
srcFileNames
an array of pdf files that will be merged
Merges multiple pdf files into a single pdf file.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Sub MergeFiles( _
   ByVal destFileName As String, _
   ByVal srcFileNames() As String _
)
Visual Basic (Usage) Copy Code
Dim destFileName As String
Dim srcFileNames() As String

PDFFile.MergeFiles(destFileName, srcFileNames)
C#
public static void MergeFiles(
   string destFileName,
   string[] srcFileNames
)
Managed Extensions for C++
public: static void MergeFiles(
   string* destFileName,
   string*[]* srcFileNames
)
C++/CLI
public:
static void MergeFiles(
   String^ destFileName,
   array<String^>^ srcFileNames
)

Parameters

destFileName
the fully qualified name of the destination file
srcFileNames
an array of pdf files that will be merged

Exceptions

Exception | Description
ArgumentException | thrown when less than 2 source pdf files as given as parameter.
PDFParserException | thrown when input pdf files can not be parsed.

Remarks

This method merges several pdf files into a single one and saves the final pdf file to the location specified by destFileName parameter. The method accepts a string array of pdf files, so multiple pdf files can be appended at once. The files will be merged in the order they appear in the array.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


MergeFiles(String,String[],Boolean) Method

MergeFiles(String,String[],Boolean) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(String,String[],Boolean) Method

destFileName
the fully qualified name of the destination file
srcFileNames
an array of pdf files that will be merged
enableFastWebView
True if the merged PDF file must be saved in fast web view format.
Merges multiple pdf files into a single pdf file.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Sub MergeFiles( _
   ByVal destFileName As String, _
   ByVal srcFileNames() As String, _
   ByVal enableFastWebView As Boolean _
)
Visual Basic (Usage) Copy Code
Dim destFileName As String
Dim srcFileNames() As String
Dim enableFastWebView As Boolean

PDFFile.MergeFiles(destFileName, srcFileNames, enableFastWebView)
C#
public static void MergeFiles(
   string destFileName,
   string[] srcFileNames,
   bool enableFastWebView
)
Managed Extensions for C++
public: static void MergeFiles(
   string* destFileName,
   string*[]* srcFileNames,
   bool enableFastWebView
)
C++/CLI
public:
static void MergeFiles(
   String^ destFileName,
   array<String^>^ srcFileNames,
   bool enableFastWebView
)

Parameters

destFileName
the fully qualified name of the destination file
srcFileNames
an array of pdf files that will be merged
enableFastWebView
True if the merged PDF file must be saved in fast web view format.

Exceptions

Exception | Description
ArgumentException | thrown when less than 2 source pdf files as given as parameter.
PDFParserException | thrown when input pdf files can not be parsed.

Remarks

This method merges several pdf files into a single one and saves the final pdf file to the location specified by destFileName parameter. The method accepts a string array of pdf files, so multiple pdf files can be appended at once. The files will be merged in the order they appear in the array.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


MergeFiles(String[]) Method

MergeFiles(String[]) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(String[]) Method

srcFileNames
an array of pdf files that will be merged
Merges multiple pdf files into a single PDFDocument object.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function MergeFiles( _
   ByVal srcFileNames() As String _
) As PDFDocument
Visual Basic (Usage) Copy Code
Dim srcFileNames() As String
Dim value As PDFDocument

value = PDFFile.MergeFiles(srcFileNames)
C#
public static PDFDocument MergeFiles(
   string[] srcFileNames
)
Managed Extensions for C++
public: static PDFDocument* MergeFiles(
   string*[]* srcFileNames
)
C++/CLI
public:
static PDFDocument^ MergeFiles(
   array<String^>^ srcFileNames
)

Parameters

srcFileNames
an array of pdf files that will be merged

Exceptions

Exception | Description
ArgumentException | thrown when less than 2 source pdf files as given as parameter.
PDFParserException | thrown when input pdf files can not be parsed.

Remarks

This method merges several pdf files into a single one and returns the new PDFDocument object, so new content and new pages can be added. The method accepts a string array of pdf files, so multiple pdf files can be appended at once. The files will be merged in the order they appear in the array.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


MergeFiles(Stream,Stream[]) Method

MergeFiles(Stream,Stream[]) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(Stream,Stream[]) Method

destFile
a stream to hold the merged pdf file
srcFiles
an array of pdf streams that will be merged
Merges multiple pdf files into a single pdf file.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Sub MergeFiles( _
   ByVal destFile As Stream, _
   ByVal srcFiles() As Stream _
)
Visual Basic (Usage) Copy Code
Dim destFile As Stream
Dim srcFiles() As Stream

PDFFile.MergeFiles(destFile, srcFiles)
C#
public static void MergeFiles(
   Stream destFile,
   Stream[] srcFiles
)
Managed Extensions for C++
public: static void MergeFiles(
   Stream* destFile,
   Stream*[]* srcFiles
)
C++/CLI
public:
static void MergeFiles(
   Stream^ destFile,
   array<Stream^>^ srcFiles
)

Parameters

destFile
a stream to hold the merged pdf file
srcFiles
an array of pdf streams that will be merged

Exceptions

Exception | Description
ArgumentException | thrown when less than 2 source pdf files are given as parameter.
PDFParserException | thrown when input pdf files can not be parsed.

Remarks

This method merges several pdf streams into a single one and saves the final pdf file to a stream specified by destFile parameter. The method accepts an array of pdf streams, so multiple pdf files can be appended at once in memory. The files will be merged in the order they appear in the array.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


MergeFiles(Stream,Stream[],Boolean) Method

MergeFiles(Stream,Stream[],Boolean) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(Stream,Stream[],Boolean) Method

destFile
a stream to hold the merged pdf file
srcFiles
an array of pdf streams that will be merged
enableFastWebView
True if the merged PDF file must be saved in fast web view format.
Merges multiple pdf files into a single pdf file.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Sub MergeFiles( _
   ByVal destFile As Stream, _
   ByVal srcFiles() As Stream, _
   ByVal enableFastWebView As Boolean _
)
Visual Basic (Usage) Copy Code
Dim destFile As Stream
Dim srcFiles() As Stream
Dim enableFastWebView As Boolean

PDFFile.MergeFiles(destFile, srcFiles, enableFastWebView)
C#
public static void MergeFiles(
   Stream destFile,
   Stream[] srcFiles,
   bool enableFastWebView
)
Managed Extensions for C++
public: static void MergeFiles(
   Stream* destFile,
   Stream*[]* srcFiles,
   bool enableFastWebView
)
C++/CLI
public:
static void MergeFiles(
   Stream^ destFile,
   array<Stream^>^ srcFiles,
   bool enableFastWebView
)

Parameters

destFile
a stream to hold the merged pdf file
srcFiles
an array of pdf streams that will be merged
enableFastWebView
True if the merged PDF file must be saved in fast web view format.

Exceptions

Exception | Description
ArgumentException | thrown when less than 2 source pdf files are given as parameter.
PDFParserException | thrown when input pdf files can not be parsed.

Remarks

This method merges several pdf streams into a single one and saves the final pdf file to a stream specified by destFile parameter. The method accepts an array of pdf streams, so multiple pdf files can be appended at once in memory. The files will be merged in the order they appear in the array.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


MergeFiles(Stream[]) Method

MergeFiles(Stream[]) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class > MergeFiles Method : MergeFiles(Stream[]) Method

srcFiles
an array of pdf file streams that will be merged
Merges multiple pdf files into a single PDFDocument object.

Syntax

Visual Basic (Declaration)
Overloads Public Shared Function MergeFiles( _
   ByVal srcFiles() As Stream _
) As PDFDocument
Visual Basic (Usage) Copy Code
Dim srcFiles() As Stream
Dim value As PDFDocument

value = PDFFile.MergeFiles(srcFiles)
C#
public static PDFDocument MergeFiles(
   Stream[] srcFiles
)
Managed Extensions for C++
public: static PDFDocument* MergeFiles(
   Stream*[]* srcFiles
)
C++/CLI
public:
static PDFDocument^ MergeFiles(
   array<Stream^>^ srcFiles
)

Parameters

srcFiles
an array of pdf file streams that will be merged

Exceptions

Exception | Description
ArgumentException | thrown when less than 2 source pdf streams as given as parameter.
PDFParserException | thrown when input pdf streams can not be parsed.

Remarks

This method merges several pdf streams into a single one and returns the new PDFDocument object, to allow new content and new pages to be added. The method accepts an array of pdf streams, so multiple pdf streams can be appended at once. The streams will be merged in the order they appear in the array.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members
Overload List


SplitFile Method

SplitFile Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : SplitFile Method

srcFileName
the full path of the pdf file to split.
destFileName
the name of destiantion individual pages file.
Splits the given pdf file to individual pages.

Syntax

Visual Basic (Declaration)
Public Shared Sub SplitFile( _
   ByVal srcFileName As String, _
   ByVal destFileName As String _
)
Visual Basic (Usage) Copy Code
Dim srcFileName As String
Dim destFileName As String

PDFFile.SplitFile(srcFileName, destFileName)
C#
public static void SplitFile(
   string srcFileName,
   string destFileName
)
Managed Extensions for C++
public: static void SplitFile(
   string* srcFileName,
   string* destFileName
)
C++/CLI
public:
static void SplitFile(
   String^ srcFileName,
   String^ destFileName
)

Parameters

srcFileName
the full path of the pdf file to split.
destFileName
the name of destiantion individual pages file.

Remarks

This method splits a pdf file to individual pages. Each page is named using destFileName parameter after which a numeric index is appended, eg: destfileName001.pdf, destfileName002.pdf, destfileName003.pdf, etc.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


PDFFile Class Properties

PDFFile Class Properties
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFFile Class

For a list of all members of this type, see PDFFile members.

Public Properties

 | Name | Description
Public Property | PagesCount | Gets the number of pages in the PDF file.
Public Property | SerialNumber | Sets the serial number and unlocks the component.
Top

See Also

Reference

PDFFile Class
O2S.Components.PDF4NET.PDFFile Namespace


PagesCount Property

PagesCount Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : PagesCount Property

Gets the number of pages in the PDF file.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PagesCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim value As Integer

value = instance.PagesCount
C#
public int PagesCount {get;}
Managed Extensions for C++
public: __property int get_PagesCount();
C++/CLI
public:
property int PagesCount {
   int get();
}

Return Value

An integer value specifying the number of pages of the PDF document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


SerialNumber Property

SerialNumber Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFFile Class : SerialNumber Property

Sets the serial number and unlocks the component.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property SerialNumber
Visual Basic (Usage) Copy Code
Dim instance As PDFFile
Dim value As

instance.SerialNumber = value
C#
public void SerialNumber {set;}
Managed Extensions for C++
public: __property void set_SerialNumber(
   void value
);
C++/CLI
public:
property void SerialNumber {
   void set (void value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFFile Class
PDFFile Members


PDFImportedContent Class

PDFImportedContent Class
See Also Members
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedContent Class

Represents the binary content of a page in a pdf file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFImportedContent
   Inherits PDFGraphicsContainer
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
C#
public class PDFImportedContent : PDFGraphicsContainer
Managed Extensions for C++
public __gc class PDFImportedContent : public PDFGraphicsContainer
C++/CLI
public ref class PDFImportedContent : public PDFGraphicsContainer

Remarks

This class represents the binary content of a page in a pdf file. This binary content creates the visual appearance of the page. It contains instructions for drawing text, images, etc. This binary content can be extracted and drawn on a new page. When it is drawn, it can be rotated. The content is automatically scaled to fit the given destination rectangle. To draw only a section of the imported content to the destination rectangle, set the ClipLeft, ClipTop, ClipWidth and ClipHeight properties to desired values. These values define the clipping rectangle, only the content inside the clipping rectangle will be displayed in the destination rectangle.
Links, form fields and annotations are not part of page content, so when the content is extracted, these items are not included.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.PDFFile.PDFImportedContent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Members
O2S.Components.PDF4NET.PDFFile Namespace


PDFImportedContent Class Members

PDFImportedContent Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedContent Class

The following tables list the members exposed by PDFImportedContent.

Public Properties

 | Name | Description
Public Property | ClipHeight | Gets or sets the visible height of the imported page content.
Public Property | ClipLeft | Gets or sets the left coordinate of the visible part of the imported page content.
Public Property | ClipTop | Gets or sets the top coordinate of the visible part of the imported page content.
Public Property | ClipWidth | Gets or sets the visible width of the imported page content.
Public Property | Height | Gets the original height of the imported contet.
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | Width | Gets the original width of the imported content.
Top

See Also

Reference

PDFImportedContent Class
O2S.Components.PDF4NET.PDFFile Namespace


PDFImportedContent Class Properties

PDFImportedContent Class Properties
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedContent Class

For a list of all members of this type, see PDFImportedContent members.

Public Properties

 | Name | Description
Public Property | ClipHeight | Gets or sets the visible height of the imported page content.
Public Property | ClipLeft | Gets or sets the left coordinate of the visible part of the imported page content.
Public Property | ClipTop | Gets or sets the top coordinate of the visible part of the imported page content.
Public Property | ClipWidth | Gets or sets the visible width of the imported page content.
Public Property | Height | Gets the original height of the imported contet.
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | Width | Gets the original width of the imported content.
Top

See Also

Reference

PDFImportedContent Class
O2S.Components.PDF4NET.PDFFile Namespace


ClipHeight Property

ClipHeight Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : ClipHeight Property

Gets or sets the visible height of the imported page content.

Syntax

Visual Basic (Declaration)
Public Property ClipHeight As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As Double

instance.ClipHeight = value

value = instance.ClipHeight
C#
public double ClipHeight {get; set;}
Managed Extensions for C++
public: __property double get_ClipHeight();
public: __property void set_ClipHeight(
   double value
);
C++/CLI
public:
property double ClipHeight {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


ClipLeft Property

ClipLeft Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : ClipLeft Property

Gets or sets the left coordinate of the visible part of the imported page content.

Syntax

Visual Basic (Declaration)
Public Property ClipLeft As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As Double

instance.ClipLeft = value

value = instance.ClipLeft
C#
public double ClipLeft {get; set;}
Managed Extensions for C++
public: __property double get_ClipLeft();
public: __property void set_ClipLeft(
   double value
);
C++/CLI
public:
property double ClipLeft {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


ClipTop Property

ClipTop Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : ClipTop Property

Gets or sets the top coordinate of the visible part of the imported page content.

Syntax

Visual Basic (Declaration)
Public Property ClipTop As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As Double

instance.ClipTop = value

value = instance.ClipTop
C#
public double ClipTop {get; set;}
Managed Extensions for C++
public: __property double get_ClipTop();
public: __property void set_ClipTop(
   double value
);
C++/CLI
public:
property double ClipTop {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


ClipWidth Property

ClipWidth Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : ClipWidth Property

Gets or sets the visible width of the imported page content.

Syntax

Visual Basic (Declaration)
Public Property ClipWidth As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As Double

instance.ClipWidth = value

value = instance.ClipWidth
C#
public double ClipWidth {get; set;}
Managed Extensions for C++
public: __property double get_ClipWidth();
public: __property void set_ClipWidth(
   double value
);
C++/CLI
public:
property double ClipWidth {
   double get();
   void set (double value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


Height Property

Height Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : Height Property

Gets the original height of the imported contet.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As Double

value = instance.Height
C#
public double Height {get;}
Managed Extensions for C++
public: __property double get_Height();
C++/CLI
public:
property double Height {
   double get();
}

Return Value

The original height of the imported content in points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


SeparationInfo Property

SeparationInfo Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : SeparationInfo Property

Gets the separation information associated with the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SeparationInfo As PDFSeparationInfo
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As PDFSeparationInfo

value = instance.SeparationInfo
C#
public PDFSeparationInfo SeparationInfo {get;}
Managed Extensions for C++
public: __property PDFSeparationInfo* get_SeparationInfo();
C++/CLI
public:
property PDFSeparationInfo^ SeparationInfo {
   PDFSeparationInfo^ get();
}

Return Value

A PDFSeparationInfo object specifying the separation information for the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


Width Property

Width Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedContent Class : Width Property

Gets the original width of the imported content.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedContent
Dim value As Double

value = instance.Width
C#
public double Width {get;}
Managed Extensions for C++
public: __property double get_Width();
C++/CLI
public:
property double Width {
   double get();
}

Return Value

The original width of the imported content in points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedContent Class
PDFImportedContent Members


PDFImportedPage Class

PDFImportedPage Class
See Also Members
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPage Class

Represents a page in a pdf file.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFImportedPage
   Inherits PDFPage
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
C#
public class PDFImportedPage : PDFPage
Managed Extensions for C++
public __gc class PDFImportedPage : public PDFPage
C++/CLI
public ref class PDFImportedPage : public PDFPage

Remarks

This class represents a single page in a pdf file. A page can be extracted from a pdf document and included anywhere in a new one.
Links, form fields and annotations are part of the page, so when the page is extracted, these items are extracted too.

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFGraphicsContainer
O2S.Components.PDF4NET.PDFPage
O2S.Components.PDF4NET.PDFFile.PDFImportedPage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Members
O2S.Components.PDF4NET.PDFFile Namespace


PDFImportedPage Class Members

PDFImportedPage Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPage Class

The following tables list the members exposed by PDFImportedPage.

Public Properties

 | Name | Description
Public Property | Annotations | Gets the list of page annotations. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | ArtBox | Gets or sets the page art box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Background | Gets or sets the background of the page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | BleedBox | Gets or sets the page bleed box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Canvas | Gets the page canvas. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | CloseAction | Gets or sets the action to be performed when the page is closed. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | ContentStream | Gets the page's content stream.
Public Property | CropBox | Gets or sets the page crop box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Dictionary | Gets the page dictionary. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Fields | Gets the list of fields defined on this page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Height | Gets or sets the page height. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | MediaBox | Gets or sets the page media box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Number | Gets or sets the page number visual aspect for this PDFPage object. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | OpenAction | Gets or sets the action to be performed when the page is opened. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Orientation | Gets or sets the page orientation. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Rotation | Gets or sets the page rotation angle. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | SeparationInfo | Gets the separation information associated with the page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Size | Gets or sets the page size. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | TrimBox | Gets or sets the page trim box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | UnderCanvas | Gets the canvas of the page.
Public Property | VisibleHeight | Gets the height of the top left corner of the visible page area.
Public Property | VisibleLeft | Gets the X coordinate of the top left corner of the visible page area.
Public Property | VisibleTop | Gets the Y coordinate of the top left corner of the visible page area.
Public Property | VisibleWidth | Gets the width of the top left corner of the visible page area.
Public Property | Width | Gets or sets the page width. (Inherited from O2S.Components.PDF4NET.PDFPage)
Top

Public Methods

 | Name | Description
Public Method | ExtractColorSpaces | Extracts the colorspaces that exist in the page resources.
Public Method | ExtractImages | Gets the lists on images on the page as bitmap objects.
Public Method | ExtractText | Extracts the text from the PDF page.
Public Method | ExtractTextRuns | Extracts the text runs from the PDF page.
Public Method | ReplaceImage | Overloaded. Replaces an existing image with a new image.
Public Method | SearchText | Searches the page for the given text.
Top

See Also

Reference

PDFImportedPage Class
O2S.Components.PDF4NET.PDFFile Namespace


PDFImportedPage Class Methods

PDFImportedPage Class Methods
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPage Class

For a list of all members of this type, see PDFImportedPage members.

Public Methods

 | Name | Description
Public Method | ExtractColorSpaces | Extracts the colorspaces that exist in the page resources.
Public Method | ExtractImages | Gets the lists on images on the page as bitmap objects.
Public Method | ExtractText | Extracts the text from the PDF page.
Public Method | ExtractTextRuns | Extracts the text runs from the PDF page.
Public Method | ReplaceImage | Overloaded. Replaces an existing image with a new image.
Public Method | SearchText | Searches the page for the given text.
Top

See Also

Reference

PDFImportedPage Class
O2S.Components.PDF4NET.PDFFile Namespace


ExtractColorSpaces Method

ExtractColorSpaces Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : ExtractColorSpaces Method

Extracts the colorspaces that exist in the page resources.

Syntax

Visual Basic (Declaration)
Public Function ExtractColorSpaces() As PDFColorSpaceCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value As PDFColorSpaceCollection

value = instance.ExtractColorSpaces()
C#
public PDFColorSpaceCollection ExtractColorSpaces()
Managed Extensions for C++
public: PDFColorSpaceCollection* ExtractColorSpaces();
C++/CLI
public:
PDFColorSpaceCollection^ ExtractColorSpaces();

Return Value

List of colorspaces defined in page resources.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


ExtractImages Method

ExtractImages Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : ExtractImages Method

Gets the lists on images on the page as bitmap objects.

Syntax

Visual Basic (Declaration)
Public Function ExtractImages() As Bitmap()
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value() As Bitmap

value = instance.ExtractImages()
C#
public Bitmap[] ExtractImages()
Managed Extensions for C++
public: Bitmap[]* ExtractImages();
C++/CLI
public:
array<Bitmap>^ ExtractImages();

Return Value

An array of Bitmap objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


ExtractText Method

ExtractText Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : ExtractText Method

Extracts the text from the PDF page.

Syntax

Visual Basic (Declaration)
Public Function ExtractText() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value As String

value = instance.ExtractText()
C#
public string ExtractText()
Managed Extensions for C++
public: string* ExtractText();
C++/CLI
public:
String^ ExtractText();

Return Value

The text content of the page.

Remarks

The text returned by this method appears in the order it is defined in the page content stream, not in the visual order as it appears in the viewer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


ExtractTextRuns Method

ExtractTextRuns Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : ExtractTextRuns Method

Extracts the text runs from the PDF page.

Syntax

Visual Basic (Declaration)
Public Function ExtractTextRuns() As PDFTextRunCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value As PDFTextRunCollection

value = instance.ExtractTextRuns()
C#
public PDFTextRunCollection ExtractTextRuns()
Managed Extensions for C++
public: PDFTextRunCollection* ExtractTextRuns();
C++/CLI
public:
PDFTextRunCollection^ ExtractTextRuns();

Return Value

The collection of text runs included in the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


ReplaceImage Method

ReplaceImage Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : ReplaceImage Method

Replaces an existing image with a new image.

Overload List

Overload | Description
ReplaceImage(String,PDFImage) | Replaces an existing image with a new image.
ReplaceImage(Int32,PDFImage) | Replaces an existing image with a new image.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


ReplaceImage(String,PDFImage) Method

ReplaceImage(String,PDFImage) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class > ReplaceImage Method : ReplaceImage(String,PDFImage) Method

imageID
The image ID that identifies the image in the resources dictionary.
newImage
The new image to be embedded in the PDF file.
Replaces an existing image with a new image.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ReplaceImage( _
   ByVal imageID As String, _
   ByVal newImage As PDFImage _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim imageID As String
Dim newImage As PDFImage

instance.ReplaceImage(imageID, newImage)
C#
public void ReplaceImage(
   string imageID,
   PDFImage newImage
)
Managed Extensions for C++
public: void ReplaceImage(
   string* imageID,
   PDFImage* newImage
)
C++/CLI
public:
void ReplaceImage(
   String^ imageID,
   PDFImage^ newImage
)

Parameters

imageID
The image ID that identifies the image in the resources dictionary.
newImage
The new image to be embedded in the PDF file.

Exceptions

Exception | Description
ArgumentNullException | Thrown when the image ID is invalid and the specified image does not exist in the resources dictionary.

Remarks

This method just replaces the image data, it does not change the position or size of the image on the page. If the image is shared between several pages, the new image will appear on all pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members
Overload List


ReplaceImage(Int32,PDFImage) Method

ReplaceImage(Int32,PDFImage) Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class > ReplaceImage Method : ReplaceImage(Int32,PDFImage) Method

imageIndex
The image index in the resources dictionary.
newImage
The new image to be embedded in the PDF file.
Replaces an existing image with a new image.

Syntax

Visual Basic (Declaration)
Overloads Public Sub ReplaceImage( _
   ByVal imageIndex As Integer, _
   ByVal newImage As PDFImage _
)
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim imageIndex As Integer
Dim newImage As PDFImage

instance.ReplaceImage(imageIndex, newImage)
C#
public void ReplaceImage(
   int imageIndex,
   PDFImage newImage
)
Managed Extensions for C++
public: void ReplaceImage(
   int imageIndex,
   PDFImage* newImage
)
C++/CLI
public:
void ReplaceImage(
   int imageIndex,
   PDFImage^ newImage
)

Parameters

imageIndex
The image index in the resources dictionary.
newImage
The new image to be embedded in the PDF file.

Exceptions

Exception | Description
ArgumentOutOfRangeException | Thrown when the image index is lower than 0 or greater than number of images on the page.

Remarks

This method just replaces the image data, it does not change the position or size of the image on the page. If the image is shared between several pages, the new image will appear on all pages.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members
Overload List


SearchText Method

SearchText Method
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : SearchText Method

text
Text to search.
Searches the page for the given text.

Syntax

Visual Basic (Declaration)
Public Function SearchText( _
   ByVal text As String _
) As PDFSearchTextResultCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim text As String
Dim value As PDFSearchTextResultCollection

value = instance.SearchText(text)
C#
public PDFSearchTextResultCollection SearchText(
   string text
)
Managed Extensions for C++
public: PDFSearchTextResultCollection* SearchText(
   string* text
)
C++/CLI
public:
PDFSearchTextResultCollection^ SearchText(
   String^ text
)

Parameters

text
Text to search.

Return Value

List of search results.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


PDFImportedPage Class Properties

PDFImportedPage Class Properties
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPage Class

For a list of all members of this type, see PDFImportedPage members.

Public Properties

 | Name | Description
Public Property | Annotations | Gets the list of page annotations. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | ArtBox | Gets or sets the page art box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Background | Gets or sets the background of the page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | BleedBox | Gets or sets the page bleed box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Canvas | Gets the page canvas. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | CloseAction | Gets or sets the action to be performed when the page is closed. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | ContentStream | Gets the page's content stream.
Public Property | CropBox | Gets or sets the page crop box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Dictionary | Gets the page dictionary. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Fields | Gets the list of fields defined on this page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Height | Gets or sets the page height. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | MediaBox | Gets or sets the page media box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Number | Gets or sets the page number visual aspect for this PDFPage object. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | OpenAction | Gets or sets the action to be performed when the page is opened. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Orientation | Gets or sets the page orientation. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Rotation | Gets or sets the page rotation angle. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | SeparationInfo | Gets the separation information associated with the page. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | Size | Gets or sets the page size. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | TrimBox | Gets or sets the page trim box. (Inherited from O2S.Components.PDF4NET.PDFPage)
Public Property | UnderCanvas | Gets the canvas of the page.
Public Property | VisibleHeight | Gets the height of the top left corner of the visible page area.
Public Property | VisibleLeft | Gets the X coordinate of the top left corner of the visible page area.
Public Property | VisibleTop | Gets the Y coordinate of the top left corner of the visible page area.
Public Property | VisibleWidth | Gets the width of the top left corner of the visible page area.
Public Property | Width | Gets or sets the page width. (Inherited from O2S.Components.PDF4NET.PDFPage)
Top

See Also

Reference

PDFImportedPage Class
O2S.Components.PDF4NET.PDFFile Namespace


ContentStream Property

ContentStream Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : ContentStream Property

Gets the page's content stream.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContentStream As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value() As Byte

value = instance.ContentStream
C#
public byte[] ContentStream {get;}
Managed Extensions for C++
public: __property byte[]* get_ContentStream();
C++/CLI
public:
property array<byte>^ ContentStream {
   array<byte>^ get();
}

Return Value

A byte array representing the page's content stream.

Remarks

This property returns the page's content stream after it has decrpyted and decompressed. It contains the stream of raw PDF instructions used to create the page visual appearance.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


UnderCanvas Property

UnderCanvas Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : UnderCanvas Property

Gets the canvas of the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UnderCanvas As PDFBasicCanvas
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value As PDFBasicCanvas

value = instance.UnderCanvas
C#
public PDFBasicCanvas UnderCanvas {get;}
Managed Extensions for C++
public: __property PDFBasicCanvas* get_UnderCanvas();
C++/CLI
public:
property PDFBasicCanvas^ UnderCanvas {
   PDFBasicCanvas^ get();
}

Return Value

A O2S.Components.PDF4NET.Graphics.PDFBasicCanvas object specifying the drawing surface located under actual page content.

Remarks

The under canvas allows to draw directly under existing page content. The regular Canvas draws on top of existing content.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


VisibleHeight Property

VisibleHeight Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : VisibleHeight Property

Gets the height of the top left corner of the visible page area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleHeight As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value As Double

value = instance.VisibleHeight
C#
public double VisibleHeight {get;}
Managed Extensions for C++
public: __property double get_VisibleHeight();
C++/CLI
public:
property double VisibleHeight {
   double get();
}

Return Value

The height of the visible page area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


VisibleLeft Property

VisibleLeft Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : VisibleLeft Property

Gets the X coordinate of the top left corner of the visible page area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleLeft As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value As Double

value = instance.VisibleLeft
C#
public double VisibleLeft {get;}
Managed Extensions for C++
public: __property double get_VisibleLeft();
C++/CLI
public:
property double VisibleLeft {
   double get();
}

Return Value

The X coordinate of the visible page area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


VisibleTop Property

VisibleTop Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : VisibleTop Property

Gets the Y coordinate of the top left corner of the visible page area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleTop As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value As Double

value = instance.VisibleTop
C#
public double VisibleTop {get;}
Managed Extensions for C++
public: __property double get_VisibleTop();
C++/CLI
public:
property double VisibleTop {
   double get();
}

Return Value

The Y coordinate of the visible page area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


VisibleWidth Property

VisibleWidth Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPage Class : VisibleWidth Property

Gets the width of the top left corner of the visible page area.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleWidth As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPage
Dim value As Double

value = instance.VisibleWidth
C#
public double VisibleWidth {get;}
Managed Extensions for C++
public: __property double get_VisibleWidth();
C++/CLI
public:
property double VisibleWidth {
   double get();
}

Return Value

The width of the visible page area.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPage Class
PDFImportedPage Members


PDFImportedPageInfo Class

PDFImportedPageInfo Class
See Also Members
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPageInfo Class

Defines the properties of an imported page but without actual page content.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFImportedPageInfo
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPageInfo
C#
public class PDFImportedPageInfo
Managed Extensions for C++
public __gc class PDFImportedPageInfo
C++/CLI
public ref class PDFImportedPageInfo

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.PDFFile.PDFImportedPageInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPageInfo Members
O2S.Components.PDF4NET.PDFFile Namespace


PDFImportedPageInfo Class Members

PDFImportedPageInfo Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPageInfo Class

The following tables list the members exposed by PDFImportedPageInfo.

Public Properties

 | Name | Description
Public Property | ArtBox | Gets the dimensions of the page's art box.
Public Property | BleedBox | Gets the dimensions of the page's bleed box.
Public Property | CropBox | Gets the dimensions of the page's crop box.
Public Property | MediaBox | Gets the dimensions of the page's media box.
Public Property | Rotation | Gets the rotation angle of the page.
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | TrimBox | Gets the dimensions of the page's trim box.
Top

See Also

Reference

PDFImportedPageInfo Class
O2S.Components.PDF4NET.PDFFile Namespace


PDFImportedPageInfo Class Properties

PDFImportedPageInfo Class Properties
[image]
O2S.Components.PDF4NET.PDFFile Namespace : PDFImportedPageInfo Class

For a list of all members of this type, see PDFImportedPageInfo members.

Public Properties

 | Name | Description
Public Property | ArtBox | Gets the dimensions of the page's art box.
Public Property | BleedBox | Gets the dimensions of the page's bleed box.
Public Property | CropBox | Gets the dimensions of the page's crop box.
Public Property | MediaBox | Gets the dimensions of the page's media box.
Public Property | Rotation | Gets the rotation angle of the page.
Public Property | SeparationInfo | Gets the separation information associated with the page.
Public Property | TrimBox | Gets the dimensions of the page's trim box.
Top

See Also

Reference

PDFImportedPageInfo Class
O2S.Components.PDF4NET.PDFFile Namespace


ArtBox Property

ArtBox Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : ArtBox Property

Gets the dimensions of the page's art box.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ArtBox As PDFRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPageInfo
Dim value As PDFRectangle

value = instance.ArtBox
C#
public PDFRectangle ArtBox {get;}
Managed Extensions for C++
public: __property PDFRectangle* get_ArtBox();
C++/CLI
public:
property PDFRectangle^ ArtBox {
   PDFRectangle^ get();
}

Return Value

A PDFRectangle object representing the page's art box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


BleedBox Property

BleedBox Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : BleedBox Property

Gets the dimensions of the page's bleed box.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BleedBox As PDFRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPageInfo
Dim value As PDFRectangle

value = instance.BleedBox
C#
public PDFRectangle BleedBox {get;}
Managed Extensions for C++
public: __property PDFRectangle* get_BleedBox();
C++/CLI
public:
property PDFRectangle^ BleedBox {
   PDFRectangle^ get();
}

Return Value

A PDFRectangle object representing the page's bleed box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


CropBox Property

CropBox Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : CropBox Property

Gets the dimensions of the page's crop box.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CropBox As PDFRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPageInfo
Dim value As PDFRectangle

value = instance.CropBox
C#
public PDFRectangle CropBox {get;}
Managed Extensions for C++
public: __property PDFRectangle* get_CropBox();
C++/CLI
public:
property PDFRectangle^ CropBox {
   PDFRectangle^ get();
}

Return Value

A PDFRectangle object representing the page's crop box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


MediaBox Property

MediaBox Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : MediaBox Property

Gets the dimensions of the page's media box.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MediaBox As PDFRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPageInfo
Dim value As PDFRectangle

value = instance.MediaBox
C#
public PDFRectangle MediaBox {get;}
Managed Extensions for C++
public: __property PDFRectangle* get_MediaBox();
C++/CLI
public:
property PDFRectangle^ MediaBox {
   PDFRectangle^ get();
}

Return Value

A PDFRectangle object representing the page's media box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


Rotation Property

Rotation Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : Rotation Property

Gets the rotation angle of the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rotation As PDFRotationMode
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPageInfo
Dim value As PDFRotationMode

value = instance.Rotation
C#
public PDFRotationMode Rotation {get;}
Managed Extensions for C++
public: __property PDFRotationMode get_Rotation();
C++/CLI
public:
property PDFRotationMode Rotation {
   PDFRotationMode get();
}

Return Value

The rotation angle of the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


SeparationInfo Property

SeparationInfo Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : SeparationInfo Property

Gets the separation information associated with the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SeparationInfo As PDFSeparationInfo
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPageInfo
Dim value As PDFSeparationInfo

value = instance.SeparationInfo
C#
public PDFSeparationInfo SeparationInfo {get;}
Managed Extensions for C++
public: __property PDFSeparationInfo* get_SeparationInfo();
C++/CLI
public:
property PDFSeparationInfo^ SeparationInfo {
   PDFSeparationInfo^ get();
}

Return Value

A PDFSeparationInfo object specifying the separation information for the page.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


TrimBox Property

TrimBox Property
[image]
O2S.Components.PDF4NET.PDFFile Namespace > PDFImportedPageInfo Class : TrimBox Property

Gets the dimensions of the page's trim box.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TrimBox As PDFRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFImportedPageInfo
Dim value As PDFRectangle

value = instance.TrimBox
C#
public PDFRectangle TrimBox {get;}
Managed Extensions for C++
public: __property PDFRectangle* get_TrimBox();
C++/CLI
public:
property PDFRectangle^ TrimBox {
   PDFRectangle^ get();
}

Return Value

A PDFRectangle object representing the page's trim box.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFImportedPageInfo Class
PDFImportedPageInfo Members


O2S.Components.PDF4NET.Security Namespace

O2S.Components.PDF4NET.Security Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFDigitalSignature | Defines a digital signature used for signing a PDF file.
PDFSecurityManager | Manages the security settings for a pdf document.

Enumerations

Enumeration | Description
EncryptionAlgorithm | Specifies the available encryption algorithms.
EncryptionKeySize | Specifies the available key sizes when encrypting a pdf document. Supported by Compact .NET Edition.

See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET.Security Namespace Inheritance Hierarchy

O2S.Components.PDF4NET.Security Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Security.PDFDigitalSignature
O2S.Components.PDF4NET.Security.PDFSecurityManager

See Also

Reference

O2S.Components.PDF4NET Assembly


PDFDigitalSignature Class

PDFDigitalSignature Class
See Also Members
[image]
O2S.Components.PDF4NET.Security Namespace : PDFDigitalSignature Class

Defines a digital signature used for signing a PDF file.

Syntax

Visual Basic (Declaration)
Public Class PDFDigitalSignature
   Inherits PDFObject
Visual Basic (Usage) Copy Code
Dim instance As PDFDigitalSignature
C#
public class PDFDigitalSignature : PDFObject
Managed Extensions for C++
public __gc class PDFDigitalSignature : public PDFObject
C++/CLI
public ref class PDFDigitalSignature : public PDFObject

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Cos.PDFObject
O2S.Components.PDF4NET.Security.PDFDigitalSignature

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDigitalSignature Members
O2S.Components.PDF4NET.Security Namespace


PDFDigitalSignature Class Members

PDFDigitalSignature Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Security Namespace : PDFDigitalSignature Class

The following tables list the members exposed by PDFDigitalSignature.

Public Constructors

 | Name | Description
Public Constructor | PDFDigitalSignature Constructor | Initializes a new O2S.Components.PDF4NET.Security.PDFDigitalSignature object.
Top

Public Properties

 | Name | Description
Public Property | Certificate | Gets or sets the certificate for signing the PDF document.
Public Property | ContactInfo | Gets or sets the signer's contact information.
Public Property | Location | Gets or sets the location of the signer.
Public Property | Name | Gets or sets the name of the signer.
Public Property | Reason | Gets or sets the reason for signing the document.
Top

See Also

Reference

PDFDigitalSignature Class
O2S.Components.PDF4NET.Security Namespace


PDFDigitalSignature Constructor

PDFDigitalSignature Constructor
[image]
O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : PDFDigitalSignature Constructor

Initializes a new O2S.Components.PDF4NET.Security.PDFDigitalSignature object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFDigitalSignature()
C#
public PDFDigitalSignature()
Managed Extensions for C++
public: PDFDigitalSignature();
C++/CLI
public:
PDFDigitalSignature();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


PDFDigitalSignature Class Properties

PDFDigitalSignature Class Properties
[image]
O2S.Components.PDF4NET.Security Namespace : PDFDigitalSignature Class

For a list of all members of this type, see PDFDigitalSignature members.

Public Properties

 | Name | Description
Public Property | Certificate | Gets or sets the certificate for signing the PDF document.
Public Property | ContactInfo | Gets or sets the signer's contact information.
Public Property | Location | Gets or sets the location of the signer.
Public Property | Name | Gets or sets the name of the signer.
Public Property | Reason | Gets or sets the reason for signing the document.
Top

See Also

Reference

PDFDigitalSignature Class
O2S.Components.PDF4NET.Security Namespace


Certificate Property

Certificate Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : Certificate Property

Gets or sets the certificate for signing the PDF document.

Syntax

Visual Basic (Declaration)
Public Property Certificate As X509Certificate2
Visual Basic (Usage) Copy Code
Dim instance As PDFDigitalSignature
Dim value As X509Certificate2

instance.Certificate = value

value = instance.Certificate
C#
public X509Certificate2 Certificate {get; set;}
Managed Extensions for C++
public: __property X509Certificate2 get_Certificate();
public: __property void set_Certificate(
   X509Certificate2 value
);
C++/CLI
public:
property X509Certificate2 Certificate {
   X509Certificate2 get();
   void set (X509Certificate2 value);
}

Return Value

A X509Certificate2 object specifying the certificate for signing.

Remarks

This property also sets the Name property to the name in the certificate.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


ContactInfo Property

ContactInfo Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : ContactInfo Property

Gets or sets the signer's contact information.

Syntax

Visual Basic (Declaration)
Public Property ContactInfo As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDigitalSignature
Dim value As String

instance.ContactInfo = value

value = instance.ContactInfo
C#
public string ContactInfo {get; set;}
Managed Extensions for C++
public: __property string* get_ContactInfo();
public: __property void set_ContactInfo(
   string* value
);
C++/CLI
public:
property String^ ContactInfo {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the signer's contact information.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


Location Property

Location Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : Location Property

Gets or sets the location of the signer.

Syntax

Visual Basic (Declaration)
Public Property Location As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDigitalSignature
Dim value As String

instance.Location = value

value = instance.Location
C#
public string Location {get; set;}
Managed Extensions for C++
public: __property string* get_Location();
public: __property void set_Location(
   string* value
);
C++/CLI
public:
property String^ Location {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the location of the signer.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


Name Property

Name Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : Name Property

Gets or sets the name of the signer.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDigitalSignature
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the name of the signer.

Remarks

The Certificate property overwrites the value of this property with the name stored in the certificate. If you want to set the Name to another value, set this property after the Certificate property has been set.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


Reason Property

Reason Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFDigitalSignature Class : Reason Property

Gets or sets the reason for signing the document.

Syntax

Visual Basic (Declaration)
Public Property Reason As String
Visual Basic (Usage) Copy Code
Dim instance As PDFDigitalSignature
Dim value As String

instance.Reason = value

value = instance.Reason
C#
public string Reason {get; set;}
Managed Extensions for C++
public: __property string* get_Reason();
public: __property void set_Reason(
   string* value
);
C++/CLI
public:
property String^ Reason {
   String^ get();
   void set (String^ value);
}

Return Value

A string value specifying the reason for signing the document.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFDigitalSignature Class
PDFDigitalSignature Members


PDFSecurityManager Class

PDFSecurityManager Class
See Also Members
[image]
O2S.Components.PDF4NET.Security Namespace : PDFSecurityManager Class

Manages the security settings for a pdf document.

Syntax

Visual Basic (Declaration)
Public Class PDFSecurityManager
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
C#
public class PDFSecurityManager
Managed Extensions for C++
public __gc class PDFSecurityManager
C++/CLI
public ref class PDFSecurityManager

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Security.PDFSecurityManager

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Members
O2S.Components.PDF4NET.Security Namespace


PDFSecurityManager Class Members

PDFSecurityManager Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Security Namespace : PDFSecurityManager Class

The following tables list the members exposed by PDFSecurityManager.

Public Constructors

 | Name | Description
Public Constructor | PDFSecurityManager Constructor | Initializes a new PDFSecurityManager object.
Top

Public Properties

 | Name | Description
Public Property | AllowAccessibilityExtractContent | Gets or sets whether the user is allowed to extract the content of the document in support of accessibility. Supported by Compact .NET Edition.
Public Property | AllowAssembleDocument | Gets or sets whether the user is allowed to assemble the pdf document. Supported by Compact .NET Edition.
Public Property | AllowExtractContent | Gets or sets whether the user is allowed to extract the content of the document. Supported by Compact .NET Edition.
Public Property | AllowFormsFill | Gets or sets whether the user is allowed to fill the form fields in the pdf document. Supported by Compact .NET Edition.
Public Property | AllowInteractiveEdit | Gets or sets whether the user is allowed to perform interactive edit operations on the document. Supported by Compact .NET Edition.
Public Property | AllowModifyDocument | Gets or sets whether the user is allowed to modify the document. Supported by Compact .NET Edition.
Public Property | AllowPrint | Gets or sets whether the user is allowed to print the document. Supported by Compact .NET Edition.
Public Property | EncryptionAlgorithm | Gets or sets the encryption algorithm used to encrypt the PDF file.
Public Property | EncryptMetadata | Gets or sets a value indicatig whether document level metadata should be encrypted.
Public Property | FullQualityPrint | Gets or sets the quality of the document printing. Supported by Compact .NET Edition.
Public Property | KeySize | Gets or sets the length of the encryption key. Supported by Compact .NET Edition.
Public Property | OwnerPassword | Gets or sets the owner password for the pdf document this security manager object is attached to. Supported by Compact .NET Edition.
Public Property | UserPassword | Gets or sets the user password for the pdf document this security manager object is attached to. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFSecurityManager Class
O2S.Components.PDF4NET.Security Namespace


PDFSecurityManager Constructor

PDFSecurityManager Constructor
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : PDFSecurityManager Constructor

Initializes a new PDFSecurityManager object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager()
C#
public PDFSecurityManager()
Managed Extensions for C++
public: PDFSecurityManager();
C++/CLI
public:
PDFSecurityManager();

Remarks

When a PDFSecurityManager object is created, all the public properties are set to true, the user and owner passwords are null, and the encryption strength is set to 128 bit.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


PDFSecurityManager Class Properties

PDFSecurityManager Class Properties
[image]
O2S.Components.PDF4NET.Security Namespace : PDFSecurityManager Class

For a list of all members of this type, see PDFSecurityManager members.

Public Properties

 | Name | Description
Public Property | AllowAccessibilityExtractContent | Gets or sets whether the user is allowed to extract the content of the document in support of accessibility. Supported by Compact .NET Edition.
Public Property | AllowAssembleDocument | Gets or sets whether the user is allowed to assemble the pdf document. Supported by Compact .NET Edition.
Public Property | AllowExtractContent | Gets or sets whether the user is allowed to extract the content of the document. Supported by Compact .NET Edition.
Public Property | AllowFormsFill | Gets or sets whether the user is allowed to fill the form fields in the pdf document. Supported by Compact .NET Edition.
Public Property | AllowInteractiveEdit | Gets or sets whether the user is allowed to perform interactive edit operations on the document. Supported by Compact .NET Edition.
Public Property | AllowModifyDocument | Gets or sets whether the user is allowed to modify the document. Supported by Compact .NET Edition.
Public Property | AllowPrint | Gets or sets whether the user is allowed to print the document. Supported by Compact .NET Edition.
Public Property | EncryptionAlgorithm | Gets or sets the encryption algorithm used to encrypt the PDF file.
Public Property | EncryptMetadata | Gets or sets a value indicatig whether document level metadata should be encrypted.
Public Property | FullQualityPrint | Gets or sets the quality of the document printing. Supported by Compact .NET Edition.
Public Property | KeySize | Gets or sets the length of the encryption key. Supported by Compact .NET Edition.
Public Property | OwnerPassword | Gets or sets the owner password for the pdf document this security manager object is attached to. Supported by Compact .NET Edition.
Public Property | UserPassword | Gets or sets the user password for the pdf document this security manager object is attached to. Supported by Compact .NET Edition.
Top

See Also

Reference

PDFSecurityManager Class
O2S.Components.PDF4NET.Security Namespace


AllowAccessibilityExtractContent Property

AllowAccessibilityExtractContent Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowAccessibilityExtractContent Property

Gets or sets whether the user is allowed to extract the content of the document in support of accessibility.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property AllowAccessibilityExtractContent As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowAccessibilityExtractContent = value

value = instance.AllowAccessibilityExtractContent
C#
public bool AllowAccessibilityExtractContent {get; set;}
Managed Extensions for C++
public: __property bool get_AllowAccessibilityExtractContent();
public: __property void set_AllowAccessibilityExtractContent(
   bool value
);
C++/CLI
public:
property bool AllowAccessibilityExtractContent {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the user is allowed to extract the content of the document in support of accessibility.

Remarks

This property has effect only when using 128 bit encryption (KeySize property is set to EncryptionKeySize.Use128BitKey). This property, if true, allows a user to copy or otherwise extract text and graphics from the document in support of accessibility to disabled users or for other purposes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


AllowAssembleDocument Property

AllowAssembleDocument Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowAssembleDocument Property

Gets or sets whether the user is allowed to assemble the pdf document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property AllowAssembleDocument As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowAssembleDocument = value

value = instance.AllowAssembleDocument
C#
public bool AllowAssembleDocument {get; set;}
Managed Extensions for C++
public: __property bool get_AllowAssembleDocument();
public: __property void set_AllowAssembleDocument(
   bool value
);
C++/CLI
public:
property bool AllowAssembleDocument {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the user is allowed to assemble the pdf document or not.

Remarks

This property has effect only when using 128 bit encryption (KeySize property is set to EncryptionKeySize.Use128BitKey). This property, if true, allows a user to assemble the document (insert, rotate, or delete pages and create bookmarks or thumbnail images), event property AllowModifyDocument is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


AllowExtractContent Property

AllowExtractContent Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowExtractContent Property

Gets or sets whether the user is allowed to extract the content of the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property AllowExtractContent As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowExtractContent = value

value = instance.AllowExtractContent
C#
public bool AllowExtractContent {get; set;}
Managed Extensions for C++
public: __property bool get_AllowExtractContent();
public: __property void set_AllowExtractContent(
   bool value
);
C++/CLI
public:
property bool AllowExtractContent {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the user is allowed to extract the content of the document.

Remarks

When using 128 bit encryption (KeySize property is set to EncryptionKeySize.Use128BitKey), this property, if true, allows a user to copy or otherwise extract text and graphics from the document by operations other than those controlled by property AllowAccessibilityExtractContent. When using 40 bit encryption (KeySize property is set to EncryptionKeySize.Use40BitKey), then this property also controls extraction of text and graphics in support of accessibility to disabled users or other purposes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


AllowFormsFill Property

AllowFormsFill Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowFormsFill Property

Gets or sets whether the user is allowed to fill the form fields in the pdf document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property AllowFormsFill As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowFormsFill = value

value = instance.AllowFormsFill
C#
public bool AllowFormsFill {get; set;}
Managed Extensions for C++
public: __property bool get_AllowFormsFill();
public: __property void set_AllowFormsFill(
   bool value
);
C++/CLI
public:
property bool AllowFormsFill {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the user is allowed to fill the form fields in the pdf document.

Remarks

This property has effect only when using 128 bit encryption. (KeySize property is set to EncryptionKeySize.Use128BitKey). This property, if true, allows a user to fill in existing interactive form fields (including signature fields), event property AllowInteractiveEdit is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


AllowInteractiveEdit Property

AllowInteractiveEdit Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowInteractiveEdit Property

Gets or sets whether the user is allowed to perform interactive edit operations on the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property AllowInteractiveEdit As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowInteractiveEdit = value

value = instance.AllowInteractiveEdit
C#
public bool AllowInteractiveEdit {get; set;}
Managed Extensions for C++
public: __property bool get_AllowInteractiveEdit();
public: __property void set_AllowInteractiveEdit(
   bool value
);
C++/CLI
public:
property bool AllowInteractiveEdit {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the user is allowed to perform interactive edit operations on the document.

Remarks

This property, if true, allows a user to add or modify text annotations, fill in interactive forms fields, and, if property AllowModifyDocument is true, create or modify interactive form fields (including signature fields).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


AllowModifyDocument Property

AllowModifyDocument Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowModifyDocument Property

Gets or sets whether the user is allowed to modify the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property AllowModifyDocument As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowModifyDocument = value

value = instance.AllowModifyDocument
C#
public bool AllowModifyDocument {get; set;}
Managed Extensions for C++
public: __property bool get_AllowModifyDocument();
public: __property void set_AllowModifyDocument(
   bool value
);
C++/CLI
public:
property bool AllowModifyDocument {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the user is allowed to modify the document or not.

Remarks

This property, if true, allows a user to modify the content of pdf document by operations other than those controlled by the following properties: AllowInteractiveEdit, AllowFormsFill, AllowAssembleDocument.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


AllowPrint Property

AllowPrint Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : AllowPrint Property

Gets or sets whether the user is allowed to print the document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property AllowPrint As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.AllowPrint = value

value = instance.AllowPrint
C#
public bool AllowPrint {get; set;}
Managed Extensions for C++
public: __property bool get_AllowPrint();
public: __property void set_AllowPrint(
   bool value
);
C++/CLI
public:
property bool AllowPrint {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the user is allowed or not to print the document.

Remarks

This property, together with FullQualityPrint and KeySize properties, controls the printing of the document. If this property is false, then the user is not allowed to print the document. If this property is true, then the user is allowed to print the document, depending on the value of FullQualityPrint and KeySize properties. If KeySize is EncryptionKeySize.Use40BitKey then FullQualityPrint property is ignored. If KeySize is EncryptionKeySize.Use128BitKey then if FullQualityPrint is true, then the document is printed at full quality, otherwise printing of the document is limited to a low-level representation of the document, of degraded quality. This degraded quality printing is viewer implementation dependent.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


EncryptionAlgorithm Property

EncryptionAlgorithm Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : EncryptionAlgorithm Property

Gets or sets the encryption algorithm used to encrypt the PDF file.

Syntax

Visual Basic (Declaration)
Public Property EncryptionAlgorithm As EncryptionAlgorithm
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As EncryptionAlgorithm

instance.EncryptionAlgorithm = value

value = instance.EncryptionAlgorithm
C#
public EncryptionAlgorithm EncryptionAlgorithm {get; set;}
Managed Extensions for C++
public: __property EncryptionAlgorithm get_EncryptionAlgorithm();
public: __property void set_EncryptionAlgorithm(
   EncryptionAlgorithm value
);
C++/CLI
public:
property EncryptionAlgorithm EncryptionAlgorithm {
   EncryptionAlgorithm get();
   void set (EncryptionAlgorithm value);
}

Remarks

When using AES encrpytion the key size is always 128 bit and the KeySize property is set automatically to 128 bit and it can not be changed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


EncryptMetadata Property

EncryptMetadata Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : EncryptMetadata Property

Gets or sets a value indicatig whether document level metadata should be encrypted.

Syntax

Visual Basic (Declaration)
Public Property EncryptMetadata As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.EncryptMetadata = value

value = instance.EncryptMetadata
C#
public bool EncryptMetadata {get; set;}
Managed Extensions for C++
public: __property bool get_EncryptMetadata();
public: __property void set_EncryptMetadata(
   bool value
);
C++/CLI
public:
property bool EncryptMetadata {
   bool get();
   void set (bool value);
}

Return Value

True if the document metadata is encrypted (default), false otherwise.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


FullQualityPrint Property

FullQualityPrint Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : FullQualityPrint Property

Gets or sets the quality of the document printing.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property FullQualityPrint As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As Boolean

instance.FullQualityPrint = value

value = instance.FullQualityPrint
C#
public bool FullQualityPrint {get; set;}
Managed Extensions for C++
public: __property bool get_FullQualityPrint();
public: __property void set_FullQualityPrint(
   bool value
);
C++/CLI
public:
property bool FullQualityPrint {
   bool get();
   void set (bool value);
}

Return Value

A bool value specifying whether the document is printed in full quality or not.

Remarks

This property has effect only when AllowPrint property is true and KeySize property is set to EncryptionKeySize.Use128BitKey. If this property is true, then the document is printed at full quality, otherwise printing of the document is limited to a low-level representation of the document, of degraded quality. This degraded quality printing is viewer implementation dependent.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


KeySize Property

KeySize Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : KeySize Property

Gets or sets the length of the encryption key.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property KeySize As EncryptionKeySize
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value As EncryptionKeySize

instance.KeySize = value

value = instance.KeySize
C#
public EncryptionKeySize KeySize {get; set;}
Managed Extensions for C++
public: __property EncryptionKeySize get_KeySize();
public: __property void set_KeySize(
   EncryptionKeySize value
);
C++/CLI
public:
property EncryptionKeySize KeySize {
   EncryptionKeySize get();
   void set (EncryptionKeySize value);
}

Return Value

A EncryptionKeySize enumeration member specifying the length of the encryption key. If the EncryptionAlgorithm property is EncryptionAlgorithm.Aes, then this property is EncryptionKeySize.Use128BitKey and it can not be changed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


OwnerPassword Property

OwnerPassword Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : OwnerPassword Property

Gets or sets the owner password for the pdf document this security manager object is attached to.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property OwnerPassword As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value() As Byte

instance.OwnerPassword = value

value = instance.OwnerPassword
C#
public byte[] OwnerPassword {get; set;}
Managed Extensions for C++
public: __property byte[]* get_OwnerPassword();
public: __property void set_OwnerPassword(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ OwnerPassword {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array specifying the owner password for the pdf file.

Remarks

An owner password allows the user to get full control over the pdf document. If a pdf file is password protected, entering an owner password when opening the file, allows the user to get full access to the document without any restrictions.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


UserPassword Property

UserPassword Property
[image]
O2S.Components.PDF4NET.Security Namespace > PDFSecurityManager Class : UserPassword Property

Gets or sets the user password for the pdf document this security manager object is attached to.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Property UserPassword As Byte()
Visual Basic (Usage) Copy Code
Dim instance As PDFSecurityManager
Dim value() As Byte

instance.UserPassword = value

value = instance.UserPassword
C#
public byte[] UserPassword {get; set;}
Managed Extensions for C++
public: __property byte[]* get_UserPassword();
public: __property void set_UserPassword(
   byte[]* value
);
C++/CLI
public:
property array<byte>^ UserPassword {
   array<byte>^ get();
   void set (bytearray<value>^ value);
}

Return Value

A byte array specifying the user password for the pdf file.

Remarks

A user password restricts access to a pdf document. When the pdf document is opened, the viewer requests the user to enter a password, if a user password has been set on the document. If the user password has not been set (this property is set to null), then the viewer opens the document without requesting a password. When the pdf document is open with a user password (or without one), the access to the document is restricted by the access rights associated with the document (allow print, etc).

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSecurityManager Class
PDFSecurityManager Members


EncryptionAlgorithm Enumeration

EncryptionAlgorithm Enumeration
[image]
O2S.Components.PDF4NET.Security Namespace : EncryptionAlgorithm Enumeration

Specifies the available encryption algorithms.

Syntax

Visual Basic (Declaration)
Public Enum EncryptionAlgorithm
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As EncryptionAlgorithm
C#
public enum EncryptionAlgorithm : Enum
Managed Extensions for C++
__value public enum EncryptionAlgorithm : public Enum
C++/CLI
public enum class EncryptionAlgorithm : public Enum

Members

Member | Description
Aes | 128 bit AES encryption. Supported in PDF 1.6 or higher.
RC4 | 40 bit or 128 bit RC4 encryption.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Security.EncryptionAlgorithm

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Security Namespace


EncryptionKeySize Enumeration

EncryptionKeySize Enumeration
[image]
O2S.Components.PDF4NET.Security Namespace : EncryptionKeySize Enumeration

Specifies the available key sizes when encrypting a pdf document.

Supported by Compact .NET Edition.

Syntax

Visual Basic (Declaration)
Public Enum EncryptionKeySize
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As EncryptionKeySize
C#
public enum EncryptionKeySize : Enum
Managed Extensions for C++
__value public enum EncryptionKeySize : public Enum
C++/CLI
public enum class EncryptionKeySize : public Enum

Members

Member | Description
Use40BitKey | A 40 bit encryption key will be used to encrypt the pdf document. Supported by Compact .NET Edition.
Use128BitKey | A 128 bit encryption key will be used to encrypt the pdf document. Supported by Compact .NET Edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
O2S.Components.PDF4NET.Security.EncryptionKeySize

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

O2S.Components.PDF4NET.Security Namespace


O2S.Components.PDF4NET.Text Namespace

O2S.Components.PDF4NET.Text Namespace
See Also Inheritance Hierarchy

Classes

Class | Description
PDFGlyph | Defines a glyph in a PDF text run.
PDFGlyphCollection | Defines a read only collection of PDFGlyph objects.
PDFSearchTextResult | Defines the results of a text search operation.
PDFSearchTextResultCollection | Defines a read only collection of PDFSearchTextResult objects.
PDFTextRun | Defines a sequence of characters that share the same visual attributes.
PDFTextRunCollection | Defines a read only collection of PDFTextRun objects.

See Also

Reference

O2S.Components.PDF4NET Assembly


O2S.Components.PDF4NET.Text Namespace Inheritance Hierarchy

O2S.Components.PDF4NET.Text Namespace Inheritance Hierarchy

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Text.PDFGlyph
O2S.Components.PDF4NET.Text.PDFSearchTextResult
O2S.Components.PDF4NET.Text.PDFTextRun
System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>
O2S.Components.PDF4NET.Text.PDFGlyphCollection
System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>
O2S.Components.PDF4NET.Text.PDFSearchTextResultCollection
System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>
O2S.Components.PDF4NET.Text.PDFTextRunCollection

See Also

Reference

O2S.Components.PDF4NET Assembly


PDFGlyph Class

PDFGlyph Class
See Also Members
[image]
O2S.Components.PDF4NET.Text Namespace : PDFGlyph Class

Defines a glyph in a PDF text run.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFGlyph
Visual Basic (Usage) Copy Code
Dim instance As PDFGlyph
C#
public class PDFGlyph
Managed Extensions for C++
public __gc class PDFGlyph
C++/CLI
public ref class PDFGlyph

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Text.PDFGlyph

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGlyph Members
O2S.Components.PDF4NET.Text Namespace


PDFGlyph Class Members

PDFGlyph Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Text Namespace : PDFGlyph Class

The following tables list the members exposed by PDFGlyph.

Public Properties

 | Name | Description
Public Property | DisplayBounds | Gets the bounds of the glyph in display coordinate system.
Public Property | PDFBounds | Gets the bounds of the glyph.
Public Property | Text | Gets the text represents by this glyph.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to its string representation.
Top

See Also

Reference

PDFGlyph Class
O2S.Components.PDF4NET.Text Namespace


PDFGlyph Class Methods

PDFGlyph Class Methods
[image]
O2S.Components.PDF4NET.Text Namespace : PDFGlyph Class

For a list of all members of this type, see PDFGlyph members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts the object to its string representation.
Top

See Also

Reference

PDFGlyph Class
O2S.Components.PDF4NET.Text Namespace


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Text Namespace > PDFGlyph Class : ToString Method

Converts the object to its string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFGlyph
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The object represented as string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGlyph Class
PDFGlyph Members


PDFGlyph Class Properties

PDFGlyph Class Properties
[image]
O2S.Components.PDF4NET.Text Namespace : PDFGlyph Class

For a list of all members of this type, see PDFGlyph members.

Public Properties

 | Name | Description
Public Property | DisplayBounds | Gets the bounds of the glyph in display coordinate system.
Public Property | PDFBounds | Gets the bounds of the glyph.
Public Property | Text | Gets the text represents by this glyph.
Top

See Also

Reference

PDFGlyph Class
O2S.Components.PDF4NET.Text Namespace


DisplayBounds Property

DisplayBounds Property
[image]
O2S.Components.PDF4NET.Text Namespace > PDFGlyph Class : DisplayBounds Property

Gets the bounds of the glyph in display coordinate system.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisplayBounds As DisplayRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFGlyph
Dim value As DisplayRectangle

value = instance.DisplayBounds
C#
public DisplayRectangle DisplayBounds {get;}
Managed Extensions for C++
public: __property DisplayRectangle* get_DisplayBounds();
C++/CLI
public:
property DisplayRectangle^ DisplayBounds {
   DisplayRectangle^ get();
}

Return Value

A DisplayRectangle specifying the bounding rectangle for the glyph in display coordinate system.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGlyph Class
PDFGlyph Members


PDFBounds Property

PDFBounds Property
[image]
O2S.Components.PDF4NET.Text Namespace > PDFGlyph Class : PDFBounds Property

Gets the bounds of the glyph.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PDFBounds As PDFRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFGlyph
Dim value As PDFRectangle

value = instance.PDFBounds
C#
public PDFRectangle PDFBounds {get;}
Managed Extensions for C++
public: __property PDFRectangle* get_PDFBounds();
C++/CLI
public:
property PDFRectangle^ PDFBounds {
   PDFRectangle^ get();
}

Return Value

A PDFRectangle specifying the bounding rectangle for the glyph, in PDF coordinates.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGlyph Class
PDFGlyph Members


Text Property

Text Property
[image]
O2S.Components.PDF4NET.Text Namespace > PDFGlyph Class : Text Property

Gets the text represents by this glyph.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As PDFGlyph
Dim value As String

value = instance.Text
C#
public string Text {get;}
Managed Extensions for C++
public: __property string* get_Text();
C++/CLI
public:
property String^ Text {
   String^ get();
}

Return Value

The character this glyph corresponds to.

Remarks

Usually a glyph corresponds to a single character, but when ligatures are used a single glyph can correspond to 2 or 3 characters.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGlyph Class
PDFGlyph Members


PDFGlyphCollection Class

PDFGlyphCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Text Namespace : PDFGlyphCollection Class

Defines a read only collection of PDFGlyph objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFGlyphCollection
   Inherits ReadOnlyCollection(Of PDFGlyph)
Visual Basic (Usage) Copy Code
Dim instance As PDFGlyphCollection
C#
public class PDFGlyphCollection : ReadOnlyCollection<PDFGlyph>
Managed Extensions for C++
public __gc class PDFGlyphCollection : public ReadOnlyCollection<PDFGlyph>
C++/CLI
public ref class PDFGlyphCollection : public ReadOnlyCollection<PDFGlyph>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>
O2S.Components.PDF4NET.Text.PDFGlyphCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFGlyphCollection Members
O2S.Components.PDF4NET.Text Namespace


PDFGlyphCollection Class Members

PDFGlyphCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Text Namespace : PDFGlyphCollection Class

The following tables list the members exposed by PDFGlyphCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Top

Public Methods

 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Top

See Also

Reference

PDFGlyphCollection Class
O2S.Components.PDF4NET.Text Namespace


PDFSearchTextResult Class

PDFSearchTextResult Class
See Also Members
[image]
O2S.Components.PDF4NET.Text Namespace : PDFSearchTextResult Class

Defines the results of a text search operation.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSearchTextResult
Visual Basic (Usage) Copy Code
Dim instance As PDFSearchTextResult
C#
public class PDFSearchTextResult
Managed Extensions for C++
public __gc class PDFSearchTextResult
C++/CLI
public ref class PDFSearchTextResult

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Text.PDFSearchTextResult

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSearchTextResult Members
O2S.Components.PDF4NET.Text Namespace


PDFSearchTextResult Class Members

PDFSearchTextResult Class Members
See Also Properties
[image]
O2S.Components.PDF4NET.Text Namespace : PDFSearchTextResult Class

The following tables list the members exposed by PDFSearchTextResult.

Public Properties

 | Name | Description
Public Property | TextRuns | Gets the list of actual text runs that compose the search result.
Top

See Also

Reference

PDFSearchTextResult Class
O2S.Components.PDF4NET.Text Namespace


PDFSearchTextResult Class Properties

PDFSearchTextResult Class Properties
[image]
O2S.Components.PDF4NET.Text Namespace : PDFSearchTextResult Class

For a list of all members of this type, see PDFSearchTextResult members.

Public Properties

 | Name | Description
Public Property | TextRuns | Gets the list of actual text runs that compose the search result.
Top

See Also

Reference

PDFSearchTextResult Class
O2S.Components.PDF4NET.Text Namespace


TextRuns Property

TextRuns Property
[image]
O2S.Components.PDF4NET.Text Namespace > PDFSearchTextResult Class : TextRuns Property

Gets the list of actual text runs that compose the search result.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TextRuns As PDFTextRunCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFSearchTextResult
Dim value As PDFTextRunCollection

value = instance.TextRuns
C#
public PDFTextRunCollection TextRuns {get;}
Managed Extensions for C++
public: __property PDFTextRunCollection* get_TextRuns();
C++/CLI
public:
property PDFTextRunCollection^ TextRuns {
   PDFTextRunCollection^ get();
}

Return Value

List of text runs that compose the search result.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSearchTextResult Class
PDFSearchTextResult Members


PDFSearchTextResultCollection Class

PDFSearchTextResultCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Text Namespace : PDFSearchTextResultCollection Class

Defines a read only collection of PDFSearchTextResult objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFSearchTextResultCollection
   Inherits ReadOnlyCollection(Of PDFSearchTextResult)
Visual Basic (Usage) Copy Code
Dim instance As PDFSearchTextResultCollection
C#
public class PDFSearchTextResultCollection : ReadOnlyCollection<PDFSearchTextResult>
Managed Extensions for C++
public __gc class PDFSearchTextResultCollection : public ReadOnlyCollection<PDFSearchTextResult>
C++/CLI
public ref class PDFSearchTextResultCollection : public ReadOnlyCollection<PDFSearchTextResult>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>
O2S.Components.PDF4NET.Text.PDFSearchTextResultCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFSearchTextResultCollection Members
O2S.Components.PDF4NET.Text Namespace


PDFSearchTextResultCollection Class Members

PDFSearchTextResultCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Text Namespace : PDFSearchTextResultCollection Class

The following tables list the members exposed by PDFSearchTextResultCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Top

Public Methods

 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Top

See Also

Reference

PDFSearchTextResultCollection Class
O2S.Components.PDF4NET.Text Namespace


PDFTextRun Class

PDFTextRun Class
See Also Members
[image]
O2S.Components.PDF4NET.Text Namespace : PDFTextRun Class

Defines a sequence of characters that share the same visual attributes.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFTextRun
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRun
C#
public class PDFTextRun
Managed Extensions for C++
public __gc class PDFTextRun
C++/CLI
public ref class PDFTextRun

Inheritance Hierarchy

System.Object
O2S.Components.PDF4NET.Text.PDFTextRun

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRun Members
O2S.Components.PDF4NET.Text Namespace


PDFTextRun Class Members

PDFTextRun Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Text Namespace : PDFTextRun Class

The following tables list the members exposed by PDFTextRun.

Public Properties

 | Name | Description
Public Property | DisplayBounds | Gets the bounds of this text run in display coordinate system.
Public Property | FontName | Gets the name of the font used to display the text run.
Public Property | FontSize | Gets the size of the font used to display the text run.
Public Property | Glyphs | Gets or sets the list of glyphs included in this text run.
Public Property | PDFBounds | Gets the bounds of this text run.
Public Property | ScaledFontSize | Gets the scaled size of the font used to display the text run.
Public Property | Text | Gets the text in this object.
Public Property | TextMatrix | Gets the active text matrix.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts this object to string representation.
Top

See Also

Reference

PDFTextRun Class
O2S.Components.PDF4NET.Text Namespace


PDFTextRun Class Methods

PDFTextRun Class Methods
[image]
O2S.Components.PDF4NET.Text Namespace : PDFTextRun Class

For a list of all members of this type, see PDFTextRun members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Converts this object to string representation.
Top

See Also

Reference

PDFTextRun Class
O2S.Components.PDF4NET.Text Namespace


ToString Method

ToString Method
[image]
O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : ToString Method

Converts this object to string representation.

Syntax

Visual Basic (Declaration)
Overrides Public Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRun
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The object as string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRun Class
PDFTextRun Members


PDFTextRun Class Properties

PDFTextRun Class Properties
[image]
O2S.Components.PDF4NET.Text Namespace : PDFTextRun Class

For a list of all members of this type, see PDFTextRun members.

Public Properties

 | Name | Description
Public Property | DisplayBounds | Gets the bounds of this text run in display coordinate system.
Public Property | FontName | Gets the name of the font used to display the text run.
Public Property | FontSize | Gets the size of the font used to display the text run.
Public Property | Glyphs | Gets or sets the list of glyphs included in this text run.
Public Property | PDFBounds | Gets the bounds of this text run.
Public Property | ScaledFontSize | Gets the scaled size of the font used to display the text run.
Public Property | Text | Gets the text in this object.
Public Property | TextMatrix | Gets the active text matrix.
Top

See Also

Reference

PDFTextRun Class
O2S.Components.PDF4NET.Text Namespace


DisplayBounds Property

DisplayBounds Property
[image]
O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : DisplayBounds Property

Gets the bounds of this text run in display coordinate system.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisplayBounds As DisplayRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRun
Dim value As DisplayRectangle

value = instance.DisplayBounds
C#
public DisplayRectangle DisplayBounds {get;}
Managed Extensions for C++
public: __property DisplayRectangle* get_DisplayBounds();
C++/CLI
public:
property DisplayRectangle^ DisplayBounds {
   DisplayRectangle^ get();
}

Return Value

The bounding rectangle of the text run in display coordinate system.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRun Class
PDFTextRun Members


FontName Property

FontName Property
[image]
O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : FontName Property

Gets the name of the font used to display the text run.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FontName As String
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRun
Dim value As String

value = instance.FontName
C#
public string FontName {get;}
Managed Extensions for C++
public: __property string* get_FontName();
C++/CLI
public:
property String^ FontName {
   String^ get();
}

Return Value

The name of the font.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRun Class
PDFTextRun Members


FontSize Property

FontSize Property
[image]
O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : FontSize Property

Gets the size of the font used to display the text run.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FontSize As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRun
Dim value As Double

value = instance.FontSize
C#
public double FontSize {get;}
Managed Extensions for C++
public: __property double get_FontSize();
C++/CLI
public:
property double FontSize {
   double get();
}

Return Value

The size of the font in points.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRun Class
PDFTextRun Members


Glyphs Property

Glyphs Property
[image]
O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : Glyphs Property

Gets or sets the list of glyphs included in this text run.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Glyphs As PDFGlyphCollection
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRun
Dim value As PDFGlyphCollection

value = instance.Glyphs
C#
public PDFGlyphCollection Glyphs {get;}
Managed Extensions for C++
public: __property PDFGlyphCollection* get_Glyphs();
C++/CLI
public:
property PDFGlyphCollection^ Glyphs {
   PDFGlyphCollection^ get();
}

Return Value

The collection of glyphs that compose the text run.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRun Class
PDFTextRun Members


PDFBounds Property

PDFBounds Property
[image]
O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : PDFBounds Property

Gets the bounds of this text run.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PDFBounds As PDFRectangle
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRun
Dim value As PDFRectangle

value = instance.PDFBounds
C#
public PDFRectangle PDFBounds {get;}
Managed Extensions for C++
public: __property PDFRectangle* get_PDFBounds();
C++/CLI
public:
property PDFRectangle^ PDFBounds {
   PDFRectangle^ get();
}

Return Value

The bounding rectangle of the text run in PDF coordinates.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRun Class
PDFTextRun Members


ScaledFontSize Property

ScaledFontSize Property
[image]
O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : ScaledFontSize Property

Gets the scaled size of the font used to display the text run.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ScaledFontSize As Double
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRun
Dim value As Double

value = instance.ScaledFontSize
C#
public double ScaledFontSize {get;}
Managed Extensions for C++
public: __property double get_ScaledFontSize();
C++/CLI
public:
property double ScaledFontSize {
   double get();
}

Return Value

The scaled size of the font in points, based on current text matrix.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRun Class
PDFTextRun Members


Text Property

Text Property
[image]
O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : Text Property

Gets the text in this object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRun
Dim value As String

value = instance.Text
C#
public string Text {get;}
Managed Extensions for C++
public: __property string* get_Text();
C++/CLI
public:
property String^ Text {
   String^ get();
}

Return Value

The text content represented by this object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRun Class
PDFTextRun Members


TextMatrix Property

TextMatrix Property
[image]
O2S.Components.PDF4NET.Text Namespace > PDFTextRun Class : TextMatrix Property

Gets the active text matrix.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TextMatrix As Matrix
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRun
Dim value As Matrix

value = instance.TextMatrix
C#
public Matrix TextMatrix {get;}
Managed Extensions for C++
public: __property Matrix get_TextMatrix();
C++/CLI
public:
property Matrix TextMatrix {
   Matrix get();
}

Return Value

The transformation matrix being in place when the text is displayed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRun Class
PDFTextRun Members


PDFTextRunCollection Class

PDFTextRunCollection Class
See Also Members
[image]
O2S.Components.PDF4NET.Text Namespace : PDFTextRunCollection Class

Defines a read only collection of PDFTextRun objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PDFTextRunCollection
   Inherits ReadOnlyCollection(Of PDFTextRun)
Visual Basic (Usage) Copy Code
Dim instance As PDFTextRunCollection
C#
public class PDFTextRunCollection : ReadOnlyCollection<PDFTextRun>
Managed Extensions for C++
public __gc class PDFTextRunCollection : public ReadOnlyCollection<PDFTextRun>
C++/CLI
public ref class PDFTextRunCollection : public ReadOnlyCollection<PDFTextRun>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>
O2S.Components.PDF4NET.Text.PDFTextRunCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

PDFTextRunCollection Members
O2S.Components.PDF4NET.Text Namespace


PDFTextRunCollection Class Members

PDFTextRunCollection Class Members
See Also Properties Methods
[image]
O2S.Components.PDF4NET.Text Namespace : PDFTextRunCollection Class

The following tables list the members exposed by PDFTextRunCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Top

Public Methods

 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Top

See Also

Reference

PDFTextRunCollection Class
O2S.Components.PDF4NET.Text Namespace


Empty Index Entry

Glossary Item Box

Empty Index Entry

The index entry you selected has no target topics associated with it.

If you have chosen a parent entry, please select a child entry.


Topic Not Found

Glossary Item Box

Topic Not Found

The link you just clicked was not able to connect to the target page.

Some possible reasons and remedies are as follows:

Reason | Remedy
Destination topic is not part of the area you specified in the Filtered by field. | Either select another filter or select (no filter).
The URL of the destination topic is incorrect or has changed. | Use the index or the search function instead.
Problems with the help installation. | Rerun Setup for the product this help is related to and select the 'Repair' option.

Additional help is available for filters, search, and the index.

Click Back to return to the page you were on.

The target parameters are:

Keyword:
Index Moniker:
URL:


RandomAccess.cs

PDF4NET Send comments on this topic.
RandomAccess.cs

Glossary Item Box

///<fileName>///File name: RandomAccess.cs///</fileName>
usingSystem;usingSystem.Drawing;usingSystem.Threading;usingO2S.Components.PDF4NET;usingO2S.Components.PDF4NET.Graphics;usingO2S.Components.PDF4NET.Graphics.Shapes;namespaceO2S.Samples.PDF4NET.RandomAccess{ ///<summary>///This sample will show the possibility to ///access in a random way any page of the document. ///On each page the access time will be written. ///</summary>classRandomAccess { ///<summary>///The main entry point for the application. ///</summary>[STAThread] staticvoidMain(string[] args) { //Create the array that will hold the page access indexesint[] pageIndexes ={4, 7, 9, 2, 6, 1, 0, 3, 8, 5}; inti; //Create the pdf documentPDFDocument pdfDoc =newPDFDocument( ); //Create all the pages of the documentfor( i =0; i <pageIndexes.Length; i++) { pdfDoc.AddPage( ); } //Create the graphic objects PDFFont fontText =newPDFFont( FontFace.Helvetica, 12); PDFBrush brush =newPDFBrush( newPDFColor( ) ); //Access each page of the document. The access order //is given by the content of pageIndexes arrayfor( i =0; i <pageIndexes.Length; i++) { pdfDoc.Pages[pageIndexes[i]].Canvas.DrawText( "Write time: "+DateTime.Now.ToString( "yyyy/MM/dd HH:mm:ss"), fontText, null, brush, 20, 50); //Sleep for 2 secondsThread.Sleep( 2000); } //Save the document to diskpdfDoc.SaveToFile( "randomaccess.pdf"); } }}


SlideShow.cs

PDF4NET Send comments on this topic.
SlideShow.cs

Glossary Item Box

///<fileName>///File name: SlideShow.cs///</fileName>
usingSystem;usingSystem.Data;usingSystem.Drawing;usingO2S.Components.PDF4NET;usingO2S.Components.PDF4NET.Graphics;usingO2S.Components.PDF4NET.Graphics.Shapes;namespaceO2S.Samples.PDF4NET.SlideShow{ ///<summary>///This sample will show the presentation capabilities ///of the pdf document. The report in SimpleGrid sample ///uses now transitions to automatically advance from ///one page to the next. ///</summary>classSlideShow { privatestaticfloatleftMargin =15; privatestaticfloatrightMargin =15; privatestaticfloattopMargin =20; privatestaticfloatminBottomMargin =20; privatestaticfloatrowHeight =30; privatestaticfloatheaderHeight =30; privatestaticfloatfirstPageTopOffset =50; privatestaticfloat[] columnsWidth ={ 80, 100, 100, 90, 212, 90, 40, 50}; privatestaticstring[] columnsHeader ={ "Author ID", "First name", "Last name", "Phone", "Address", "City", "State", "ZIP"}; ///<summary>///The main entry point for the application. ///</summary>[STAThread] staticvoidMain(string[] args) { //Create the graphic objectsPDFFont fontTitle =newPDFFont( FontFace.Helvetica, 20); PDFBrush blackBrush =newPDFBrush( newPDFColor( ) ); //Create the pdf documentPDFDocument pdfDoc =newPDFDocument( ); //Set the document to be Landscape orientedpdfDoc.PageOrientation =PageOrientation.Landscape; //Create the transition objectPDFPageTransition trans =newPDFPageTransition( ); trans.Effect =PageTransitionEffect.Box; trans.PageDuration =2; trans.TransitionDuration =2; trans.TransitionMotionDirection =TransitionMotionDirection.Outward; //Create first page of the reportPDFPage page =pdfDoc.AddPage( ); //Add the transition to the pagepage.Transition =trans; //Draw the title of the reportpage.Canvas.DrawText( "Authors - with transition effects", fontTitle, null, blackBrush, page.Width/2, 15, 0, TextAlign.TopCenter ); //Draw report headerDrawReportHeader( page, firstPageTopOffset ); //Create the datasetDataSet ds =newDataSet( ); //Load the datasetds.ReadXml( "authors.xml", XmlReadMode.ReadSchema ); //Get the table from the datasetDataTable authors =ds.Tables[0]; //rowOffset - specifies the vertical position where a row //should begin to be printedfloatrowOffset =firstPageTopOffset +headerHeight; for( inti =0; i <authors.Rows.Count; i++) { if( rowOffset +rowHeight >page.Height -minBottomMargin ) { //not enough space to draw a new row, then create a new page, //draw the header, then draw the rows.page =pdfDoc.AddPage( ); //set the transition effect for the pagepage.Transition =trans; DrawReportHeader( page, topMargin ); rowOffset =topMargin +headerHeight; } DrawReportRow( page, rowOffset, authors.Rows[i] ); rowOffset =rowOffset +rowHeight; } //Save the document to diskpdfDoc.SaveToFile( "slideshow.pdf"); } privatestaticvoidDrawReportHeader( PDFPage pdfPage, floattopOffset ) { //Create the graphic objectsPDFFont fontHeader =newPDFFont( FontFace.Helvetica, 12); fontHeader.Bold =true; PDFPen borderColor =newPDFPen( newPDFColor( ), 1); PDFBrush textColor =newPDFBrush( newPDFColor( ) ); PDFBrush headerFill =newPDFBrush( newPDFColor( 192, 192, 192) ); //Draw the headerpdfPage.Canvas.DrawRectangle( borderColor, headerFill, topOffset, leftMargin, pdfPage.Width -leftMargin -rightMargin, headerHeight ); inti; floatxOffset =leftMargin; //Draw the columns separatorsfor( i =0; i <columnsWidth.Length -1; i++) { xOffset =xOffset +columnsWidth[i]; pdfPage.Canvas.DrawLine( borderColor, xOffset, topOffset, xOffset, topOffset +headerHeight ); } xOffset =leftMargin; //Draw the columns headerfor( i =0; i <columnsWidth.Length; i++) { pdfPage.Canvas.DrawText( columnsHeader[i], fontHeader, null, textColor, xOffset +columnsWidth[i]/2, topOffset +headerHeight/2, 0, TextAlign.MiddleCenter ); xOffset =xOffset +columnsWidth[i]; } } privatestaticvoidDrawReportRow( PDFPage pdfPage, floattopOffset, DataRow row ) { //Create the graphic objectsPDFFont fontText =newPDFFont( FontFace.Helvetica, 12); PDFPen borderColor =newPDFPen( newPDFColor( ), 1); PDFBrush textColor =newPDFBrush( newPDFColor( ) ); PDFBrush headerFill =newPDFBrush( newPDFColor( 192, 192, 192) ); //Draw rows bordersPointF[] points ={ newPointF( leftMargin, topOffset ), newPointF( leftMargin, topOffset +rowHeight), newPointF( pdfPage.Width -rightMargin, topOffset +rowHeight ), newPointF( pdfPage.Width -rightMargin, topOffset )}; pdfPage.Canvas.DrawLines( borderColor, points ); inti; floatxOffset =leftMargin; //Draw the columns separatorsfor( i =0; i <columnsWidth.Length -1; i++) { xOffset =xOffset +columnsWidth[i]; pdfPage.Canvas.DrawLine( borderColor, xOffset, topOffset, xOffset, topOffset +rowHeight ); } xOffset =leftMargin; //Draw the columns headerfor( i =0; i <columnsWidth.Length; i++) { pdfPage.Canvas.DrawText( ( string)row[i], fontText, null, textColor, xOffset +2, topOffset +rowHeight/2, 0, TextAlign.MiddleLeft ); xOffset =xOffset +columnsWidth[i]; } } }}


Templates.cs

PDF4NET Send comments on this topic.
Templates.cs

Glossary Item Box

///<fileName>///File name: Templates.cs///</fileName>
usingSystem;usingSystem.Drawing;usingO2S.Components.PDF4NET;usingO2S.Components.PDF4NET.Graphics;usingO2S.Components.PDF4NET.Graphics.Shapes;namespaceO2S.Samples.PDF4NET.Templates{ ///<summary>///This sample will show how to use common content ///on multiple pages using templates. ///</summary>classTemplates { ///<summary>///The main entry point for the application. ///</summary>[STAThread] staticvoidMain(string[] args) { //The default page size is letterconstintwidth =612; constintheight =792; //Create the graphic objects PDFFont fontText =newPDFFont( FontFace.Helvetica, 12); PDFFont fontTitle =newPDFFont( FontFace.Helvetica, 72); PDFBrush blackBrush =newPDFBrush( newPDFColor( ) ); PDFPen blackPen =newPDFPen( newPDFColor( ), 1); //Import a sample pdf documentPDFDocument pdfDoc =newPDFDocument( "sample.pdf"); //Create the template from a PDF file and attach it to the documentPDFPageTemplate tmpl =newPDFPageTemplate( "one-page-template.pdf", 0, 0, 0, width, height ); pdfDoc.PageTemplate =tmpl; //Create 10 additional pagesfor( inti =0; i <10; i++) { PDFPage pdfPage =pdfDoc.AddPage( ); if( i >0) { pdfPage.Canvas.DrawText( "Page "+i.ToString( ), fontTitle, null, blackBrush, pdfPage.Width/2, pdfPage.Height/2, 0, TextAlign.MiddleCenter ); } } //Do not apply the template on 6th pagepdfDoc.Pages[5].ApplyTemplate =false; //Draw the title on the 6th page (the first of the newly 10 added pages)pdfDoc.Pages[5].Canvas.DrawText( "Templates", fontTitle, null, blackBrush, pdfDoc.Pages[0].Width/2, pdfDoc.Pages[0].Height/2, 0, TextAlign.MiddleCenter ); //Save the document to diskpdfDoc.SaveToFile( "templates.pdf"); } }}


Glossary

PDF4NET Send comments on this topic.
Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z


Linearized PDF

PDF4NET Send comments on this topic.
Linearized PDF

Glossary Item Box

PDF4NET library can create linearized PDF files (fast web view PDF files) with no additional effort from the developer. The new Save method added to PDFDocument class has a second boolean parameter that allows to specify whether the resulting PDF file should be created in linearized or regular format.
PDFDocument doc = new PDFDocument();
// Create the PDF file content.
// ...
// Save the linearized PDF file (set second parameter to true).
doc.Save("file.pdf", true);

Linearized PDF files require 2 passes over the PDF file and the save operation will require more time than saving the file in regular format.


PDFActionCollection Class Methods

PDFActionCollection Class Methods
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFActionCollection Class

For a list of all members of this type, see PDFActionCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Top

See Also

Reference

PDFActionCollection Class
O2S.Components.PDF4NET.Actions Namespace


PDFActionCollection Class Properties

PDFActionCollection Class Properties
[image]
O2S.Components.PDF4NET.Actions Namespace : PDFActionCollection Class

For a list of all members of this type, see PDFActionCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFAction>)
Top

See Also

Reference

PDFActionCollection Class
O2S.Components.PDF4NET.Actions Namespace


PDF3DAnnotation Class Methods

PDF3DAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DAnnotation Class

For a list of all members of this type, see PDF3DAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDF3DAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DCrossSectionCollection Class Methods

PDF3DCrossSectionCollection Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSectionCollection Class

For a list of all members of this type, see PDF3DCrossSectionCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Top

See Also

Reference

PDF3DCrossSectionCollection Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DCrossSectionCollection Class Properties

PDF3DCrossSectionCollection Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DCrossSectionCollection Class

For a list of all members of this type, see PDF3DCrossSectionCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDF3DCrossSection>)
Top

See Also

Reference

PDF3DCrossSectionCollection Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DNodeCollection Class Methods

PDF3DNodeCollection Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DNodeCollection Class

For a list of all members of this type, see PDF3DNodeCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Top

See Also

Reference

PDF3DNodeCollection Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DNodeCollection Class Properties

PDF3DNodeCollection Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DNodeCollection Class

For a list of all members of this type, see PDF3DNodeCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDF3DNode>)
Top

See Also

Reference

PDF3DNodeCollection Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DViewCollection Class Methods

PDF3DViewCollection Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DViewCollection Class

For a list of all members of this type, see PDF3DViewCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Top

See Also

Reference

PDF3DViewCollection Class
O2S.Components.PDF4NET.Annotations Namespace


PDF3DViewCollection Class Properties

PDF3DViewCollection Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDF3DViewCollection Class

For a list of all members of this type, see PDF3DViewCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDF3DView>)
Top

See Also

Reference

PDF3DViewCollection Class
O2S.Components.PDF4NET.Annotations Namespace


PDFAnnotationAppearance Class Properties

PDFAnnotationAppearance Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationAppearance Class

For a list of all members of this type, see PDFAnnotationAppearance members.

Public Properties

 | Name | Description
Public Property | Canvas | Gets the form XObject canvas. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Height | Gets or sets the height of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Width | Gets or sets the width of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Top

See Also

Reference

PDFAnnotationAppearance Class
O2S.Components.PDF4NET.Annotations Namespace


PDFAnnotationCollection Class Methods

PDFAnnotationCollection Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationCollection Class

For a list of all members of this type, see PDFAnnotationCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Top

See Also

Reference

PDFAnnotationCollection Class
O2S.Components.PDF4NET.Annotations Namespace


PDFAnnotationCollection Class Properties

PDFAnnotationCollection Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFAnnotationCollection Class

For a list of all members of this type, see PDFAnnotationCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFAnnotation>)
Top

See Also

Reference

PDFAnnotationCollection Class
O2S.Components.PDF4NET.Annotations Namespace


PDFBaseMarkupAnnotation Class Methods

PDFBaseMarkupAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFBaseMarkupAnnotation Class

For a list of all members of this type, see PDFBaseMarkupAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFBaseMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFEllipseAnnotation Class Methods

PDFEllipseAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFEllipseAnnotation Class

For a list of all members of this type, see PDFEllipseAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFEllipseAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFEllipseAnnotation Class Properties

PDFEllipseAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFEllipseAnnotation Class

For a list of all members of this type, see PDFEllipseAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border. (Inherited from PDFSCAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color. (Inherited from PDFSCAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFEllipseAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFFreeTextAnnotation Class Methods

PDFFreeTextAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFFreeTextAnnotation Class

For a list of all members of this type, see PDFFreeTextAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFFreeTextAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFHighlightAnnotation Class Methods

PDFHighlightAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFHighlightAnnotation Class

For a list of all members of this type, see PDFHighlightAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFHighlightAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFHighlightAnnotation Class Properties

PDFHighlightAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFHighlightAnnotation Class

For a list of all members of this type, see PDFHighlightAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from PDFTextMarkupAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFHighlightAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFImageAppearance Class Properties

PDFImageAppearance Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFImageAppearance Class

For a list of all members of this type, see PDFImageAppearance members.

Public Properties

 | Name | Description
Public Property | Canvas | Gets the form XObject canvas. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Height | Gets or sets the height of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Public Property | Width | Gets or sets the width of this form XObject. (Inherited from O2S.Components.PDF4NET.Graphics.Shapes.PDFFormXObject)
Top

See Also

Reference

PDFImageAppearance Class
O2S.Components.PDF4NET.Annotations Namespace


PDFInkAnnotation Class Methods

PDFInkAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFInkAnnotation Class

For a list of all members of this type, see PDFInkAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFInkAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFLineAnnotation Class Methods

PDFLineAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFLineAnnotation Class

For a list of all members of this type, see PDFLineAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFLineAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFLinkAnnotation Class Methods

PDFLinkAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFLinkAnnotation Class

For a list of all members of this type, see PDFLinkAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFLinkAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFMarkupAnnotation Class Methods

PDFMarkupAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFMarkupAnnotation Class

For a list of all members of this type, see PDFMarkupAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFMovieAnnotation Class Methods

PDFMovieAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFMovieAnnotation Class

For a list of all members of this type, see PDFMovieAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFMovieAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFPointsCollection Class Methods

PDFPointsCollection Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFPointsCollection Class

For a list of all members of this type, see PDFPointsCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Top

See Also

Reference

PDFPointsCollection Class
O2S.Components.PDF4NET.Annotations Namespace


PDFPointsCollection Class Properties

PDFPointsCollection Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFPointsCollection Class

For a list of all members of this type, see PDFPointsCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<Double>)
Top

See Also

Reference

PDFPointsCollection Class
O2S.Components.PDF4NET.Annotations Namespace


PDFRectangleAnnotation Class Methods

PDFRectangleAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFRectangleAnnotation Class

For a list of all members of this type, see PDFRectangleAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFRectangleAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFRectangleAnnotation Class Properties

PDFRectangleAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFRectangleAnnotation Class

For a list of all members of this type, see PDFRectangleAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Border | Gets or sets the annotation border. (Inherited from PDFSCAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | InteriorColor | Gets or sets the annotation's interior color. (Inherited from PDFSCAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFRectangleAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFRubberStampAnnotation Class Methods

PDFRubberStampAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFRubberStampAnnotation Class

For a list of all members of this type, see PDFRubberStampAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFRubberStampAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFSCAnnotation Class Methods

PDFSCAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFSCAnnotation Class

For a list of all members of this type, see PDFSCAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFSCAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFSquigglyAnnotation Class Methods

PDFSquigglyAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFSquigglyAnnotation Class

For a list of all members of this type, see PDFSquigglyAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFSquigglyAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFSquigglyAnnotation Class Properties

PDFSquigglyAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFSquigglyAnnotation Class

For a list of all members of this type, see PDFSquigglyAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from PDFTextMarkupAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFSquigglyAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFStrikeOutAnnotation Class Methods

PDFStrikeOutAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFStrikeOutAnnotation Class

For a list of all members of this type, see PDFStrikeOutAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFStrikeOutAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFStrikeOutAnnotation Class Properties

PDFStrikeOutAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFStrikeOutAnnotation Class

For a list of all members of this type, see PDFStrikeOutAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from PDFTextMarkupAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFStrikeOutAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFTextAnnotation Class Methods

PDFTextAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFTextAnnotation Class

For a list of all members of this type, see PDFTextAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFTextAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFTextMarkupAnnotation Class Methods

PDFTextMarkupAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFTextMarkupAnnotation Class

For a list of all members of this type, see PDFTextMarkupAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFTextMarkupAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFUnderlineAnnotation Class Methods

PDFUnderlineAnnotation Class Methods
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFUnderlineAnnotation Class

For a list of all members of this type, see PDFUnderlineAnnotation members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the annotation. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFUnderlineAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


PDFUnderlineAnnotation Class Properties

PDFUnderlineAnnotation Class Properties
[image]
O2S.Components.PDF4NET.Annotations Namespace : PDFUnderlineAnnotation Class

For a list of all members of this type, see PDFUnderlineAnnotation members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the annotation appearance. (Inherited from PDFAnnotation)
Public Property | Author | Gets or sets the annotation author. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Color | Gets or sets the annotation color. (Inherited from PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from PDFAnnotation)
Public Property | InReplyTo | Gets or sets the annotation that this annotation is "in reply to". (Inherited from PDFBaseMarkupAnnotation)
Public Property | MarkupType | Gets or sets the type of the annotation markup. (Inherited from PDFTextMarkupAnnotation)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from PDFAnnotation)
Public Property | Opacity | Gets or sets the annotation opacity. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from PDFTextMarkupAnnotation)
Public Property | QuadPoints | Gets or sets the points that define the markup area. (Inherited from PDFTextMarkupAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from PDFAnnotation)
Public Property | Rotation | Gets or sets the annotation rotation angle. (Inherited from PDFAnnotation)
Public Property | Subject | Gets or sets the annotation subject. (Inherited from PDFBaseMarkupAnnotation)
Public Property | Type | Gets the annotation type. (Inherited from PDFAnnotation)
Top

See Also

Reference

PDFUnderlineAnnotation Class
O2S.Components.PDF4NET.Annotations Namespace


IncompatiblePDFObjectException Class Methods

IncompatiblePDFObjectException Class Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : IncompatiblePDFObjectException Class

For a list of all members of this type, see IncompatiblePDFObjectException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

IncompatiblePDFObjectException Class
O2S.Components.PDF4NET.Cos Namespace


IncompatiblePDFObjectException Class Properties

IncompatiblePDFObjectException Class Properties
[image]
O2S.Components.PDF4NET.Cos Namespace : IncompatiblePDFObjectException Class

For a list of all members of this type, see IncompatiblePDFObjectException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

See Also

Reference

IncompatiblePDFObjectException Class
O2S.Components.PDF4NET.Cos Namespace


InvalidPasswordException Class Methods

InvalidPasswordException Class Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : InvalidPasswordException Class

For a list of all members of this type, see InvalidPasswordException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

InvalidPasswordException Class
O2S.Components.PDF4NET.Cos Namespace


InvalidPasswordException Class Properties

InvalidPasswordException Class Properties
[image]
O2S.Components.PDF4NET.Cos Namespace : InvalidPasswordException Class

For a list of all members of this type, see InvalidPasswordException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

See Also

Reference

InvalidPasswordException Class
O2S.Components.PDF4NET.Cos Namespace


InvalidPDFValueException Class Methods

InvalidPDFValueException Class Methods
[image]
O2S.Components.PDF4NET.Cos Namespace : InvalidPDFValueException Class

For a list of all members of this type, see InvalidPDFValueException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

InvalidPDFValueException Class
O2S.Components.PDF4NET.Cos Namespace


InvalidPDFValueException Class Properties

InvalidPDFValueException Class Properties
[image]
O2S.Components.PDF4NET.Cos Namespace : InvalidPDFValueException Class

For a list of all members of this type, see InvalidPDFValueException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

See Also

Reference

InvalidPDFValueException Class
O2S.Components.PDF4NET.Cos Namespace


FDFFieldCollection Class Methods

FDFFieldCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFFieldCollection Class

For a list of all members of this type, see FDFFieldCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Top

See Also

Reference

FDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


FDFFieldCollection Class Properties

FDFFieldCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : FDFFieldCollection Class

For a list of all members of this type, see FDFFieldCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<FDFField>)
Top

See Also

Reference

FDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


PDFCheckBoxField Class Methods

PDFCheckBoxField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxField Class

For a list of all members of this type, see PDFCheckBoxField members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from PDFField)
Top

See Also

Reference

PDFCheckBoxField Class
O2S.Components.PDF4NET.Forms Namespace


PDFCheckBoxWidget Class Methods

PDFCheckBoxWidget Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxWidget Class

For a list of all members of this type, see PDFCheckBoxWidget members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFCheckBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFCheckBoxWidget Class Properties

PDFCheckBoxWidget Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckBoxWidget Class

For a list of all members of this type, see PDFCheckBoxWidget members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from PDFCheckWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not. (Inherited from PDFCheckWidget)
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance. (Inherited from PDFCheckWidget)
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance. (Inherited from PDFCheckWidget)
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance. (Inherited from PDFCheckWidget)
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark. (Inherited from PDFCheckWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget. (Inherited from PDFCheckWidget)
Public Property | Field | Gets the form field that owns this widget. (Inherited from PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from PDFFieldWidget)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance. (Inherited from PDFCheckWidget)
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance. (Inherited from PDFCheckWidget)
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance. (Inherited from PDFCheckWidget)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFCheckBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFCheckWidget Class Methods

PDFCheckWidget Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFCheckWidget Class

For a list of all members of this type, see PDFCheckWidget members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFCheckWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFDropDownListField Class Methods

PDFDropDownListField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListField Class

For a list of all members of this type, see PDFDropDownListField members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from PDFField)
Top

See Also

Reference

PDFDropDownListField Class
O2S.Components.PDF4NET.Forms Namespace


PDFDropDownListWidget Class Methods

PDFDropDownListWidget Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListWidget Class

For a list of all members of this type, see PDFDropDownListWidget members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFDropDownListWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFDropDownListWidget Class Properties

PDFDropDownListWidget Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFDropDownListWidget Class

For a list of all members of this type, see PDFDropDownListWidget members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from PDFFieldWidget)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFDropDownListWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFFieldWidgetCollection Class Methods

PDFFieldWidgetCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidgetCollection Class

For a list of all members of this type, see PDFFieldWidgetCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Top

See Also

Reference

PDFFieldWidgetCollection Class
O2S.Components.PDF4NET.Forms Namespace


PDFFieldWidgetCollection Class Properties

PDFFieldWidgetCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFFieldWidgetCollection Class

For a list of all members of this type, see PDFFieldWidgetCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFFieldWidget>)
Top

See Also

Reference

PDFFieldWidgetCollection Class
O2S.Components.PDF4NET.Forms Namespace


PDFListBoxField Class Methods

PDFListBoxField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListBoxField Class

For a list of all members of this type, see PDFListBoxField members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from PDFField)
Top

See Also

Reference

PDFListBoxField Class
O2S.Components.PDF4NET.Forms Namespace


PDFListBoxField Class Properties

PDFListBoxField Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListBoxField Class

For a list of all members of this type, see PDFListBoxField members.

Public Properties

 | Name | Description
Public Property | CalculateAction | Gets or sets the JavaScript action to be executed for calculating the field value. (Inherited from PDFField)
Public Property | CommitOnSelChange | Gets or sets whether the selected item is commited as soon as the selection is made. (Inherited from PDFListField)
Public Property | Dictionary | Gets the field dictionary. (Inherited from PDFField)
Public Property | Form | Gets the form that contains this field. (Inherited from PDFField)
Public Property | FormatAction | Gets or sets the JavaScript action to be executed for formating the field value. (Inherited from PDFField)
Public Property | Items | Gets the collection of items in the list. (Inherited from PDFListField)
Public Property | KeyPressAction | Gets or sets the JavaScript action to be executed when the user types a keystroke. (Inherited from PDFField)
Public Property | MappingName | Gets or sets the mapping name of the field. (Inherited from PDFField)
Public Property | Name | Gets or sets the field name. (Inherited from PDFField)
Public Property | NoExport | Gets or sets a value indicating whether the field can be exported or not. (Inherited from PDFField)
Public Property | ReadOnly | Gets or sets a value indicating whether the field is read-only. (Inherited from PDFField)
Public Property | Required | Gets or sets a value indicating whether the field is required. (Inherited from PDFField)
Public Property | SelectedIndex | Gets or sets the lowest ordinal index of the selected items in the list. (Inherited from PDFListField)
Public Property | SelectedItem | Gets or sets the first selected item in the list. (Inherited from PDFListField)
Public Property | SelectedValue | Gets or sets the value of the first selected item in the list. (Inherited from PDFListField)
Public Property | Sort | Gets or sets whether the items in the drop down list should be sorted alphabetically or not. (Inherited from PDFListField)
Public Property | Tooltip | Gets or sets the field tooltip. (Inherited from PDFField)
Public Property | Type | Gets the field type. (Inherited from PDFField)
Public Property | ValidateAction | Gets or sets the JavaScript action to be executed for validating the field value. (Inherited from PDFField)
Public Property | Value | Gets or sets the field value. (Inherited from PDFField)
Public Property | Widgets | Gets the list of widgets associated with this field. (Inherited from PDFField)
Top

See Also

Reference

PDFListBoxField Class
O2S.Components.PDF4NET.Forms Namespace


PDFListBoxWidget Class Methods

PDFListBoxWidget Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListBoxWidget Class

For a list of all members of this type, see PDFListBoxWidget members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFListBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFListBoxWidget Class Properties

PDFListBoxWidget Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListBoxWidget Class

For a list of all members of this type, see PDFListBoxWidget members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from PDFFieldWidget)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFListBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFListField Class Methods

PDFListField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListField Class

For a list of all members of this type, see PDFListField members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from PDFField)
Top

See Also

Reference

PDFListField Class
O2S.Components.PDF4NET.Forms Namespace


PDFListItemCollection Class Methods

PDFListItemCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListItemCollection Class

For a list of all members of this type, see PDFListItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Top

See Also

Reference

PDFListItemCollection Class
O2S.Components.PDF4NET.Forms Namespace


PDFListItemCollection Class Properties

PDFListItemCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFListItemCollection Class

For a list of all members of this type, see PDFListItemCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFListItem>)
Top

See Also

Reference

PDFListItemCollection Class
O2S.Components.PDF4NET.Forms Namespace


PDFPushButtonField Class Methods

PDFPushButtonField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonField Class

For a list of all members of this type, see PDFPushButtonField members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from PDFField)
Top

See Also

Reference

PDFPushButtonField Class
O2S.Components.PDF4NET.Forms Namespace


PDFPushButtonWidget Class Methods

PDFPushButtonWidget Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFPushButtonWidget Class

For a list of all members of this type, see PDFPushButtonWidget members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFPushButtonWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFRadioButtonItem Class Methods

PDFRadioButtonItem Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonItem Class

For a list of all members of this type, see PDFRadioButtonItem members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFRadioButtonItem Class
O2S.Components.PDF4NET.Forms Namespace


PDFRadioButtonItem Class Properties

PDFRadioButtonItem Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonItem Class

For a list of all members of this type, see PDFRadioButtonItem members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from PDFCheckWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from PDFFieldWidget)
Public Property | Checked | Gets or sets a value indicating whether this widget is checked or not. (Inherited from PDFCheckWidget)
Public Property | CheckedDownAppearance | Gets or sets the checked down widget appearance. (Inherited from PDFCheckWidget)
Public Property | CheckedNormalAppearance | Gets or sets the checked rollover widget appearance. (Inherited from PDFCheckWidget)
Public Property | CheckedRolloverAppearance | Gets or sets the checked rollover widget appearance. (Inherited from PDFCheckWidget)
Public Property | CheckSymbolStyle | Gets or sets the symbol used as checkmark. (Inherited from PDFCheckWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | ExportValue | Gets or sets the export value for this check box widget. (Inherited from PDFCheckWidget)
Public Property | Field | Gets the form field that owns this widget. (Inherited from PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from PDFFieldWidget)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | UncheckedDownAppearance | Gets or sets the unchecked down widget appearance. (Inherited from PDFCheckWidget)
Public Property | UncheckedNormalAppearance | Gets or sets the unchecked normal widget appearance. (Inherited from PDFCheckWidget)
Public Property | UncheckedRolloverAppearance | Gets or sets the unchecked rollover widget appearance. (Inherited from PDFCheckWidget)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFRadioButtonItem Class
O2S.Components.PDF4NET.Forms Namespace


PDFRadioButtonListField Class Methods

PDFRadioButtonListField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFRadioButtonListField Class

For a list of all members of this type, see PDFRadioButtonListField members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from PDFField)
Top

See Also

Reference

PDFRadioButtonListField Class
O2S.Components.PDF4NET.Forms Namespace


PDFSignatureField Class Methods

PDFSignatureField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureField Class

For a list of all members of this type, see PDFSignatureField members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from PDFField)
Top

See Also

Reference

PDFSignatureField Class
O2S.Components.PDF4NET.Forms Namespace


PDFSignatureWidget Class Methods

PDFSignatureWidget Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureWidget Class

For a list of all members of this type, see PDFSignatureWidget members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFSignatureWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFSignatureWidget Class Properties

PDFSignatureWidget Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFSignatureWidget Class

For a list of all members of this type, see PDFSignatureWidget members.

Public Properties

 | Name | Description
Public Property | Appearance | Gets or sets the widget appearance. (Inherited from PDFFieldWidget)
Public Property | BackColor | Gets or sets the widget's background color. (Inherited from PDFFieldWidget)
Public Property | Blur | Gets or sets the action that is executed when the field widget loses focus. (Inherited from PDFFieldWidget)
Public Property | BorderColor | Gets or sets the widget's border color. (Inherited from PDFFieldWidget)
Public Property | BorderStyle | Gets or sets the widget's border style. (Inherited from PDFFieldWidget)
Public Property | BorderWidth | Gets or sets the widget's border width. (Inherited from PDFFieldWidget)
Public Property | Color | Gets or sets the annotation color. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Contents | Gets or sets the annotation contents. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | CreationDate | Gets or sets the annotation creation date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Dictionary | Gets the annotation dictionary. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | DisplayRectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Field | Gets the form field that owns this widget. (Inherited from PDFFieldWidget)
Public Property | Flags | Gets or sets the annotation flags. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Focus | Gets or sets the action that is executed when the field widget receives focus. (Inherited from PDFFieldWidget)
Public Property | Font | Gets or sets the font used to display the widget text. (Inherited from PDFFieldWidget)
Public Property | ModifiedDate | Gets or sets the annotation modified date. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseDown | Gets or sets the action that is executed when the mouse is pressed in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseEnter | Gets or sets the action that is executed when the mouse enters the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseLeave | Gets or sets the action that is executed when the mouse leaves the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | MouseUp | Gets or sets the action that is executed when the mouse is released in the annotation rectangle. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Page | Gets the page that includes this annotation. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageClose | Gets or sets the action to be performed when the page containing the annotation is closed. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageHide | Gets or sets the action to be performed when the page containing the annotation is no longer visible in the viewer application’s user interfacee. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageOpen | Gets or sets the action to be performed when the page containing the annotation is opened. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PageShow | Gets or sets the action to be performed when the page containing the annotation becomes visible in the viewer application’s user interface. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | PDFRectangle | Gets or sets the annotation rectangle in PDF coordinates. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rectangle | Gets or sets the display rectangle of this annotation object. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | Rotation | Gets or sets the widget rotation angle. (Inherited from PDFFieldWidget)
Public Property | TextColor | Gets or sets the widget's text color. (Inherited from PDFFieldWidget)
Public Property | Type | Gets the annotation type. (Inherited from O2S.Components.PDF4NET.Annotations.PDFAnnotation)
Public Property | VisibilityStatus | Gets or sets the visibility status of the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFSignatureWidget Class
O2S.Components.PDF4NET.Forms Namespace


PDFTextBoxField Class Methods

PDFTextBoxField Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxField Class

For a list of all members of this type, see PDFTextBoxField members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the internal resources. (Inherited from PDFField)
Top

See Also

Reference

PDFTextBoxField Class
O2S.Components.PDF4NET.Forms Namespace


PDFTextBoxWidget Class Methods

PDFTextBoxWidget Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : PDFTextBoxWidget Class

For a list of all members of this type, see PDFTextBoxWidget members.

Public Methods

 | Name | Description
Public Method | Flatten | Flattens the field widget. (Inherited from PDFFieldWidget)
Top

See Also

Reference

PDFTextBoxWidget Class
O2S.Components.PDF4NET.Forms Namespace


XFAArea Class Properties

XFAArea Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAArea Class

For a list of all members of this type, see XFAArea members.

Public Properties

 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from XFAExtendedContainer)
Top

See Also

Reference

XFAArea Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAButtonField Class Properties

XFAButtonField Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAButtonField Class

For a list of all members of this type, see XFAButtonField members.

Public Properties

 | Name | Description
Public Property | Access | Gets or sets the access mode to field content. (Inherited from XFAField)
Public Property | BindRef | Gets the explicit data binding string. (Inherited from XFAField)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Value | Gets or sets the value stored in this field. (Inherited from XFAField)
Public Property | ValueType | Gets the type of value stored in this field. (Inherited from XFAField)
Public Property | Visibility | Gets the visibility of the field content. (Inherited from XFAField)
Top

See Also

Reference

XFAButtonField Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAListItemCollection Class Methods

XFAListItemCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItemCollection Class

For a list of all members of this type, see XFAListItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Top

See Also

Reference

XFAListItemCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAListItemCollection Class Properties

XFAListItemCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAListItemCollection Class

For a list of all members of this type, see XFAListItemCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<XFAListItem>)
Top

See Also

Reference

XFAListItemCollection Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFAPageArea Class Properties

XFAPageArea Class Properties
[image]
O2S.Components.PDF4NET.Forms.XFA Namespace : XFAPageArea Class

For a list of all members of this type, see XFAPageArea members.

Public Properties

 | Name | Description
Public Property | Areas | Gets the list of areas included in this container. (Inherited from XFAExtendedContainer)
Public Property | Fields | Gets the list of fields included in this container. (Inherited from XFAExtendedContainer)
Public Property | ID | Gets the id of this container. (Inherited from XFABasicContainer)
Public Property | Name | Gets the name of this container. (Inherited from XFABasicContainer)
Public Property | Subforms | Gets the list of subforms included in this container. (Inherited from XFAExtendedContainer)
Top

See Also

Reference

XFAPageArea Class
O2S.Components.PDF4NET.Forms.XFA Namespace


XFDFFieldCollection Class Methods

XFDFFieldCollection Class Methods
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFFieldCollection Class

For a list of all members of this type, see XFDFFieldCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Top

See Also

Reference

XFDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


XFDFFieldCollection Class Properties

XFDFFieldCollection Class Properties
[image]
O2S.Components.PDF4NET.Forms Namespace : XFDFFieldCollection Class

For a list of all members of this type, see XFDFFieldCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<XFDFField>)
Top

See Also

Reference

XFDFFieldCollection Class
O2S.Components.PDF4NET.Forms Namespace


PDFFunctionCollection Class Methods

PDFFunctionCollection Class Methods
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFFunctionCollection Class

For a list of all members of this type, see PDFFunctionCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Top

See Also

Reference

PDFFunctionCollection Class
O2S.Components.PDF4NET.Functions Namespace


PDFFunctionCollection Class Properties

PDFFunctionCollection Class Properties
[image]
O2S.Components.PDF4NET.Functions Namespace : PDFFunctionCollection Class

For a list of all members of this type, see PDFFunctionCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFFunction>)
Top

See Also

Reference

PDFFunctionCollection Class
O2S.Components.PDF4NET.Functions Namespace


BarcodeEncodingException Class Methods

BarcodeEncodingException Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : BarcodeEncodingException Class

For a list of all members of this type, see BarcodeEncodingException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

BarcodeEncodingException Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


BarcodeEncodingException Class Properties

BarcodeEncodingException Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : BarcodeEncodingException Class

For a list of all members of this type, see BarcodeEncodingException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

See Also

Reference

BarcodeEncodingException Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDF417Barcode Class Methods

PDF417Barcode Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDF417Barcode Class

For a list of all members of this type, see PDF417Barcode members.

Public Methods

 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from PDFBasePDF417Barcode)
Top

See Also

Reference

PDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCodabarBarcode Class Properties

PDFCodabarBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCodabarBarcode Class

For a list of all members of this type, see PDFCodabarBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCodabarBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode11Barcode Class Properties

PDFCode11Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode11Barcode Class

For a list of all members of this type, see PDFCode11Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode11Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode25InterleavedBarcode Class Properties

PDFCode25InterleavedBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode25InterleavedBarcode Class

For a list of all members of this type, see PDFCode25InterleavedBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode25InterleavedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode32Barcode Class Properties

PDFCode32Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode32Barcode Class

For a list of all members of this type, see PDFCode32Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode32Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode39ExtendedBarcode Class Properties

PDFCode39ExtendedBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode39ExtendedBarcode Class

For a list of all members of this type, see PDFCode39ExtendedBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode39ExtendedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode93Barcode Class Properties

PDFCode93Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93Barcode Class

For a list of all members of this type, see PDFCode93Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode93Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode93ExtendedBarcode Class Properties

PDFCode93ExtendedBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode93ExtendedBarcode Class

For a list of all members of this type, see PDFCode93ExtendedBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode93ExtendedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode128ABarcode Class Properties

PDFCode128ABarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128ABarcode Class

For a list of all members of this type, see PDFCode128ABarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode128ABarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode128Barcode Class Properties

PDFCode128Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128Barcode Class

For a list of all members of this type, see PDFCode128Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode128Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode128BBarcode Class Properties

PDFCode128BBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128BBarcode Class

For a list of all members of this type, see PDFCode128BBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode128BBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCode128CBarcode Class Properties

PDFCode128CBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCode128CBarcode Class

For a list of all members of this type, see PDFCode128CBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCode128CBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFCOOP25Barcode Class Properties

PDFCOOP25Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFCOOP25Barcode Class

For a list of all members of this type, see PDFCOOP25Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFCOOP25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFEAN8Barcode Class Properties

PDFEAN8Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN8Barcode Class

For a list of all members of this type, see PDFEAN8Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFEAN8Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFEAN13Barcode Class Properties

PDFEAN13Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFEAN13Barcode Class

For a list of all members of this type, see PDFEAN13Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFEAN13Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFFedExGround96Barcode Class Properties

PDFFedExGround96Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFFedExGround96Barcode Class

For a list of all members of this type, see PDFFedExGround96Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFFedExGround96Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFHeightModulatedBarcode Class Properties

PDFHeightModulatedBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFHeightModulatedBarcode Class

For a list of all members of this type, see PDFHeightModulatedBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFHeightModulatedBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFIATA25Barcode Class Properties

PDFIATA25Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIATA25Barcode Class

For a list of all members of this type, see PDFIATA25Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFIATA25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFIdentcodeBarcode Class Properties

PDFIdentcodeBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFIdentcodeBarcode Class

For a list of all members of this type, see PDFIdentcodeBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFIdentcodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFISBNBarcode Class Properties

PDFISBNBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISBNBarcode Class

For a list of all members of this type, see PDFISBNBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFISBNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFISMNBarcode Class Properties

PDFISMNBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISMNBarcode Class

For a list of all members of this type, see PDFISMNBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFISMNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFISSNBarcode Class Properties

PDFISSNBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFISSNBarcode Class

For a list of all members of this type, see PDFISSNBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFISSNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFJAN13Barcode Class Properties

PDFJAN13Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFJAN13Barcode Class

For a list of all members of this type, see PDFJAN13Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFJAN13Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFKixBarcode Class Properties

PDFKixBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFKixBarcode Class

For a list of all members of this type, see PDFKixBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFKixBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFLeitcodeBarcode Class Properties

PDFLeitcodeBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFLeitcodeBarcode Class

For a list of all members of this type, see PDFLeitcodeBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFLeitcodeBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFMatrix25Barcode Class Properties

PDFMatrix25Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMatrix25Barcode Class

For a list of all members of this type, see PDFMatrix25Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode25Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFMatrix25Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFMicroPDF417Barcode Class Methods

PDFMicroPDF417Barcode Class Methods
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMicroPDF417Barcode Class

For a list of all members of this type, see PDFMicroPDF417Barcode members.

Public Methods

 | Name | Description
Public Method | GetMaxDataLength | Calculates the length of the maximum data section that can be encoded in the barcode. (Inherited from PDFBasePDF417Barcode)
Top

See Also

Reference

PDFMicroPDF417Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFMSIPlesseyBarcode Class Properties

PDFMSIPlesseyBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFMSIPlesseyBarcode Class

For a list of all members of this type, see PDFMSIPlesseyBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFMSIPlesseyBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFPlanetBarcode Class Properties

PDFPlanetBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPlanetBarcode Class

For a list of all members of this type, see PDFPlanetBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFPlanetBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFPostNetBarcode Class Properties

PDFPostNetBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPostNetBarcode Class

For a list of all members of this type, see PDFPostNetBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFPostNetBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFPZNBarcode Class Properties

PDFPZNBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFPZNBarcode Class

For a list of all members of this type, see PDFPZNBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | WideToNarrowRatio | Gets or sets the ratio between wide bars and narrow bars. (Inherited from PDFCode39Barcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFPZNBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFRM4SCCBarcode Class Properties

PDFRM4SCCBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFRM4SCCBarcode Class

For a list of all members of this type, see PDFRM4SCCBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFRM4SCCBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFSCC14Barcode Class Properties

PDFSCC14Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSCC14Barcode Class

For a list of all members of this type, see PDFSCC14Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFSCC14Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFSingaporePostBarcode Class Properties

PDFSingaporePostBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSingaporePostBarcode Class

For a list of all members of this type, see PDFSingaporePostBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFSingaporePostBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFSSCC18Barcode Class Properties

PDFSSCC18Barcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFSSCC18Barcode Class

For a list of all members of this type, see PDFSSCC18Barcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFSSCC18Barcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFUPCABarcode Class Properties

PDFUPCABarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCABarcode Class

For a list of all members of this type, see PDFUPCABarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUPCABarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFUPCEBarcode Class Properties

PDFUPCEBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUPCEBarcode Class

For a list of all members of this type, see PDFUPCEBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | Supplement | Gets or sets the supplement for barcode data. (Inherited from PDFEANBarcode)
Public Property | SupplementDisplayLocation | Gets or sets the location of the supplement text. (Inherited from PDFEANBarcode)
Public Property | SupplementYDimension | Gets or sets the height of a bar in the supplement barcode. (Inherited from PDFEANBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUPCEBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFUSPSFIMBarcode Class Properties

PDFUSPSFIMBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSFIMBarcode Class

For a list of all members of this type, see PDFUSPSFIMBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUSPSFIMBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFUSPSHorizontalBarcode Class Properties

PDFUSPSHorizontalBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSHorizontalBarcode Class

For a list of all members of this type, see PDFUSPSHorizontalBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUSPSHorizontalBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFUSPSPICBarcode Class Properties

PDFUSPSPICBarcode Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Barcodes Namespace : PDFUSPSPICBarcode Class

For a list of all members of this type, see PDFUSPSPICBarcode members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the background color of the barcode. (Inherited from PDFBarcode)
Public Property | BarColor | Gets or sets the bars color. (Inherited from PDFBarcode)
Public Property | BottomQuietZone | Gets or sets the height of the bottom quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Data | Gets or sets the string to be encoded as barcode. (Inherited from PDFBarcode)
Public Property | DataDisplayLocation | Gets or sets the location of the barcode data. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayCheckSum | Gets or sets whether the check characters should be displayed in human readable form. (Inherited from PDFUnidimensionalBarcode)
Public Property | DisplayStartStopSymbols | Gets or sets a value indicating whether the start/stop symbols should be displayed. (Inherited from PDFUnidimensionalBarcode)
Public Property | EnableCheckSum | Gets or sets a value indicating whether a checksum symbol should be appended automatically to the barcode. (Inherited from PDFUnidimensionalBarcode)
Public Property | Font | Gets or sets the font used to display the barcode text. (Inherited from PDFUnidimensionalBarcode)
Public Property | Height | Gets the height in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | Left | Gets or sets the X coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | LeftQuietZone | Gets or sets the width of the left quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Position | Gets or sets the position of this barcode object. (Inherited from PDFBarcode)
Public Property | Rectangle | Gets or sets the bounding rectangle of this barcode object. (Inherited from PDFBarcode)
Public Property | RightQuietZone | Gets or sets the width of the right quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Size | Gets or sets the size of this barcode object. (Inherited from PDFBarcode)
Public Property | TextColor | Gets or sets the color of the barcode text. (Inherited from PDFBarcode)
Public Property | Top | Gets or sets the Y coordinate of the top left corner of the barcode's rectangle. (Inherited from PDFBarcode)
Public Property | TopQuietZone | Gets or sets the height of the top quiet zone of the barcode. (Inherited from PDFBarcode)
Public Property | Width | Gets the width in points of the barcode rectangle. (Inherited from PDFBarcode)
Public Property | XDimension | Gets or sets the width in points of a narrow bar. (Inherited from PDFBarcode)
Public Property | YDimension | Gets or sets the height of a bar. (Inherited from PDFBarcode)
Top

See Also

Reference

PDFUSPSPICBarcode Class
O2S.Components.PDF4NET.Graphics.Barcodes Namespace


PDFColorSpaceCollection Class Methods

PDFColorSpaceCollection Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpaceCollection Class

For a list of all members of this type, see PDFColorSpaceCollection members.

Public Methods

 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Top

See Also

Reference

PDFColorSpaceCollection Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFColorSpaceCollection Class Properties

PDFColorSpaceCollection Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFColorSpaceCollection Class

For a list of all members of this type, see PDFColorSpaceCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFColorSpace>)
Top

See Also

Reference

PDFColorSpaceCollection Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFDeviceNColorNameCollection Class Methods

PDFDeviceNColorNameCollection Class Methods
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorNameCollection Class

For a list of all members of this type, see PDFDeviceNColorNameCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<String>)
Top

See Also

Reference

PDFDeviceNColorNameCollection Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


PDFDeviceNColorNameCollection Class Properties

PDFDeviceNColorNameCollection Class Properties
[image]
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace : PDFDeviceNColorNameCollection Class

For a list of all members of this type, see PDFDeviceNColorNameCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<String>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<String>)
Top

See Also

Reference

PDFDeviceNColorNameCollection Class
O2S.Components.PDF4NET.Graphics.ColorSpaces Namespace


TrueTypeFont Class Properties

TrueTypeFont Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : TrueTypeFont Class

For a list of all members of this type, see TrueTypeFont members.

Public Properties

 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not. (Inherited from PDFFontBase)
Public Property | Italic | Gets or sets whether the font object is italic or not. (Inherited from PDFFontBase)
Public Property | Metrics | Gets the metrics of this font object. (Inherited from PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from PDFFontBase)
Top

See Also

Reference

TrueTypeFont Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


Type0Font Class Properties

Type0Font Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Fonts Namespace : Type0Font Class

For a list of all members of this type, see Type0Font members.

Public Properties

 | Name | Description
Public Property | Bold | Gets or sets whether the font object is bold or not. (Inherited from PDFFontBase)
Public Property | Italic | Gets or sets whether the font object is italic or not. (Inherited from PDFFontBase)
Public Property | Metrics | Gets the metrics of this font object. (Inherited from PDFFontBase)
Public Property | Overline | Gets or sets whether the font object is overline or not. (Inherited from PDFFontBase)
Public Property | Size | Gets or sets the font size. (Inherited from PDFFontBase)
Public Property | Strikethrough | Gets or sets whether the font object is strikethrough or not. (Inherited from PDFFontBase)
Public Property | Underline | Gets or sets whether the font object is underline or not. (Inherited from PDFFontBase)
Top

See Also

Reference

Type0Font Class
O2S.Components.PDF4NET.Graphics.Fonts Namespace


PDFCanvas Class Methods

PDFCanvas Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFCanvas Class

For a list of all members of this type, see PDFCanvas members.

Public Methods

 | Name | Description
Public Method | Clear | Clears the canvas content. (Inherited from PDFBasicCanvas)
Public Method | DrawArc | Draws an arc representing a portion of an circle specified by a pair of coordinates and a width. (Inherited from PDFBasicCanvas)
Public Method | DrawBarcode | Overloaded. Draws the barcode on the canvas. (Inherited from PDFBasicCanvas)
Public Method | DrawBezier | Overloaded. Draws a Bezier spline specified by four pairs of coordinates. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawChord | Overloaded. Draws a chord representing a region bounded by the intersection of an ellipse and a line segment, called a secant, specified by a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width. (Inherited from PDFBasicCanvas)
Public Method | DrawFormXObject | Overloaded. Draws a form XObject specified by a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawHTMLText | Overloaded. Draws a line of text specified by a string and a pair of coordinates. (Inherited from PDFBasicCanvas)
Public Method | DrawHTMLTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawImage | Overloaded. Draws an image specified by a file name, a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawImportedContent | Overloaded. Draws the imported content of an external page at a location specified by a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawLine | Overloaded. Draws a line connecting two points specified by coordinate pairs using the specified pen. Supported by Compact .NET Edition. (Inherited from PDFBasicCanvas)
Public Method | DrawLines | Overloaded. Draws a series of line segments that connect an array of PointF structures. (Inherited from PDFBasicCanvas)
Public Method | DrawPath | Overloaded. Draws a PDFPath object with the specified pen. (Inherited from PDFBasicCanvas)
Public Method | DrawPie | Overloaded. Draws a pie representing a closed portion of an circle specified by a pair of coordinates and a width. (Inherited from PDFBasicCanvas)
Public Method | DrawPolyBezier | Overloaded. Draws a series of connected curves defined by an array of PointF structures. (Inherited from PDFBasicCanvas)
Public Method | DrawPolygon | Overloaded. Draws a polygon defined by an array of PDFPoint objects. (Inherited from PDFBasicCanvas)
Public Method | DrawPolyPolygon | Overloaded. Draws a series of closed polygons, each one defined by an array of PDFPoint objects. (Inherited from PDFBasicCanvas)
Public Method | DrawRectangle | Overloaded. Draws a rectangle specified by a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawRoundRectangle | Overloaded. Draws a rounded rectangle specified by a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | DrawText | Overloaded. Draws a line of text specified by a string and a pair of coordinates. (Inherited from PDFBasicCanvas)
Public Method | DrawTextBox | Overloaded. Draws a text specified by a string, a pair of coordinates, a width and a height. (Inherited from PDFBasicCanvas)
Public Method | FitHtmlText | Overloaded. Calculates how much of the text really fits in the box. (Inherited from PDFBasicCanvas)
Public Method | FitText | Overloaded. Calculates how much of the given text fits in the given area. (Inherited from PDFBasicCanvas)
Public Method | GetHtmlTextBoxHeight | Overloaded. Gets the height of the wrapped HTML text. (Inherited from PDFBasicCanvas)
Public Method | GetHtmlTextBoxLastLineWidth | Overloaded. Gets the width of the last line in the HTML text box. (Inherited from PDFBasicCanvas)
Public Method | GetTextBoxHeight | Overloaded. Gets the height of the wrapped text. (Inherited from PDFBasicCanvas)
Public Method | GetTextBoxLastLineWidth | Gets the width of the last line in the text box. (Inherited from PDFBasicCanvas)
Public Method | ResetClipRegion | Resets the current clipping region to whole page. (Inherited from PDFBasicCanvas)
Public Method | RestoreGraphicState | Restores the current graphic state in the PDF content stream. (Inherited from PDFBasicCanvas)
Public Method | SaveGraphicState | Saves the current graphic state in the PDF content stream. (Inherited from PDFBasicCanvas)
Public Method | SetAxesDirection | Sets the new directions for the axes of the coordinate system. (Inherited from PDFBasicCanvas)
Public Method | SetBlendMode | Sets the blending mode for the subsequent drawing operations. (Inherited from PDFBasicCanvas)
Public Method | SetClipRegion | Sets a clipping region on page's canvas. (Inherited from PDFBasicCanvas)
Public Method | SetExtendedGraphicState | Sets the current graphic state in the content stream. (Inherited from PDFBasicCanvas)
Public Method | SetLogicalUnit | Sets the logical unit for the drawing operations. (Inherited from PDFBasicCanvas)
Public Method | SetOrigin | Sets the new point of origin for the coordinate system. (Inherited from PDFBasicCanvas)
Public Method | SetOverprint | Sets the overprint for the subsequent drawing (stroke and fill) operations. (Inherited from PDFBasicCanvas)
Public Method | SetTransparency | Sets the transparency level for the subsequent drawing operations. (Inherited from PDFBasicCanvas)
Public Method | ToString | Gets the string representation of this object. (Inherited from PDFBasicCanvas)
Top

See Also

Reference

PDFCanvas Class
O2S.Components.PDF4NET.Graphics Namespace


PDFDeviceColor Class Methods

PDFDeviceColor Class Methods
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFDeviceColor Class

For a list of all members of this type, see PDFDeviceColor members.

Public Methods

 | Name | Description
Public Method | Clone | Clones this color object. (Inherited from PDFColor)
Public Method | Equals | Verifies if the given object is equal to this object. (Inherited from PDFColor)
Public Method | GetHashCode | Gets the hash code of this object. (Inherited from PDFColor)
Public Method | ToString | Converts the color object to string representation. (Inherited from PDFColor)
Top

See Also

Reference

PDFDeviceColor Class
O2S.Components.PDF4NET.Graphics Namespace


PDFDeviceColor Class Properties

PDFDeviceColor Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFDeviceColor Class

For a list of all members of this type, see PDFDeviceColor members.

Public Properties

 | Name | Description
Public Property | ColorSpace | Gets the colorspace this color is based on. (Inherited from PDFColor)
Top

See Also

Reference

PDFDeviceColor Class
O2S.Components.PDF4NET.Graphics Namespace


PDFHorizontalGradientBrush Class Properties

PDFHorizontalGradientBrush Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFHorizontalGradientBrush Class

For a list of all members of this type, see PDFHorizontalGradientBrush members.

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. (Inherited from PDFLinearGradientBrush)
Public Property | EndColor | (Inherited from PDFLinearGradientBrush)
Public Property | StartColor | Gets or sets the start color of the gradient. (Inherited from PDFLinearGradientBrush)
Top

See Also

Reference

PDFHorizontalGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


PDFLayerCollection Class Properties

PDFLayerCollection Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFLayerCollection Class

For a list of all members of this type, see PDFLayerCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFLayer>)
Top

See Also

Reference

PDFLayerCollection Class
O2S.Components.PDF4NET.Graphics Namespace


PDFVerticalGradientBrush Class Properties

PDFVerticalGradientBrush Class Properties
[image]
O2S.Components.PDF4NET.Graphics Namespace : PDFVerticalGradientBrush Class

For a list of all members of this type, see PDFVerticalGradientBrush members.

Public Properties

 | Name | Description
Public Property | Color | Gets or sets the color of this Brush object. (Inherited from PDFLinearGradientBrush)
Public Property | EndColor | (Inherited from PDFLinearGradientBrush)
Public Property | StartColor | Gets or sets the start color of the gradient. (Inherited from PDFLinearGradientBrush)
Top

See Also

Reference

PDFVerticalGradientBrush Class
O2S.Components.PDF4NET.Graphics Namespace


PDFMetafile Class Properties

PDFMetafile Class Properties
[image]
O2S.Components.PDF4NET.Graphics.Shapes Namespace : PDFMetafile Class

For a list of all members of this type, see PDFMetafile members.

Public Properties

 | Name | Description
Public Property | Canvas | Gets the form XObject canvas. (Inherited from PDFFormXObject)
Public Property | Height | Gets or sets the height of this form XObject. (Inherited from PDFFormXObject)
Public Property | Width | Gets or sets the width of this form XObject. (Inherited from PDFFormXObject)
Top

See Also

Reference

PDFMetafile Class
O2S.Components.PDF4NET.Graphics.Shapes Namespace


PDFBookmarkCollection Class Properties

PDFBookmarkCollection Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFBookmarkCollection Class

For a list of all members of this type, see PDFBookmarkCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFBookmark>)
Top

See Also

Reference

PDFBookmarkCollection Class
O2S.Components.PDF4NET Namespace


Generic PDFCollection Class Methods

Generic PDFCollection Class Methods
[image]
O2S.Components.PDF4NET Namespace : Generic PDFCollection Class

For a list of all members of this type, see Generic PDFCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<T>)
Top

See Also

Reference

Generic PDFCollection Class
O2S.Components.PDF4NET Namespace


Generic PDFCollection Class Properties

Generic PDFCollection Class Properties
[image]
O2S.Components.PDF4NET Namespace : Generic PDFCollection Class

For a list of all members of this type, see Generic PDFCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<T>)
Top

See Also

Reference

Generic PDFCollection Class
O2S.Components.PDF4NET Namespace


PDFDocumentAttachmentCollection Class Methods

PDFDocumentAttachmentCollection Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentAttachmentCollection Class

For a list of all members of this type, see PDFDocumentAttachmentCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Top

See Also

Reference

PDFDocumentAttachmentCollection Class
O2S.Components.PDF4NET Namespace


PDFDocumentAttachmentCollection Class Properties

PDFDocumentAttachmentCollection Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFDocumentAttachmentCollection Class

For a list of all members of this type, see PDFDocumentAttachmentCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFDocumentAttachment>)
Top

See Also

Reference

PDFDocumentAttachmentCollection Class
O2S.Components.PDF4NET Namespace


PDFException Class Methods

PDFException Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFException Class

For a list of all members of this type, see PDFException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

PDFException Class
O2S.Components.PDF4NET Namespace


PDFException Class Properties

PDFException Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFException Class

For a list of all members of this type, see PDFException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

See Also

Reference

PDFException Class
O2S.Components.PDF4NET Namespace


PDFInvalidPasswordException Class Methods

PDFInvalidPasswordException Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFInvalidPasswordException Class

For a list of all members of this type, see PDFInvalidPasswordException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

PDFInvalidPasswordException Class
O2S.Components.PDF4NET Namespace


PDFInvalidPasswordException Class Properties

PDFInvalidPasswordException Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFInvalidPasswordException Class

For a list of all members of this type, see PDFInvalidPasswordException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

See Also

Reference

PDFInvalidPasswordException Class
O2S.Components.PDF4NET Namespace


PDFJavaScriptCollection Class Properties

PDFJavaScriptCollection Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFJavaScriptCollection Class

For a list of all members of this type, see PDFJavaScriptCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFJavaScript>)
Top

See Also

Reference

PDFJavaScriptCollection Class
O2S.Components.PDF4NET Namespace


PDFMetadataSchemaCollection Class Methods

PDFMetadataSchemaCollection Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFMetadataSchemaCollection Class

For a list of all members of this type, see PDFMetadataSchemaCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Top

See Also

Reference

PDFMetadataSchemaCollection Class
O2S.Components.PDF4NET Namespace


PDFMetadataSchemaCollection Class Properties

PDFMetadataSchemaCollection Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFMetadataSchemaCollection Class

For a list of all members of this type, see PDFMetadataSchemaCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFMetadataSchema>)
Top

See Also

Reference

PDFMetadataSchemaCollection Class
O2S.Components.PDF4NET Namespace


PDFPageCollection Class Methods

PDFPageCollection Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFPageCollection Class

For a list of all members of this type, see PDFPageCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Top

See Also

Reference

PDFPageCollection Class
O2S.Components.PDF4NET Namespace


PDFPageCollection Class Properties

PDFPageCollection Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPageCollection Class

For a list of all members of this type, see PDFPageCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFPage>)
Top

See Also

Reference

PDFPageCollection Class
O2S.Components.PDF4NET Namespace


PDFPageNumberingRangeCollection Class Methods

PDFPageNumberingRangeCollection Class Methods
[image]
O2S.Components.PDF4NET Namespace : PDFPageNumberingRangeCollection Class

For a list of all members of this type, see PDFPageNumberingRangeCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Top

See Also

Reference

PDFPageNumberingRangeCollection Class
O2S.Components.PDF4NET Namespace


PDFPageNumberingRangeCollection Class Properties

PDFPageNumberingRangeCollection Class Properties
[image]
O2S.Components.PDF4NET Namespace : PDFPageNumberingRangeCollection Class

For a list of all members of this type, see PDFPageNumberingRangeCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<PDFPageNumberingRange>)
Top

See Also

Reference

PDFPageNumberingRangeCollection Class
O2S.Components.PDF4NET Namespace


PDFGlyphCollection Class Methods

PDFGlyphCollection Class Methods
[image]
O2S.Components.PDF4NET.Text Namespace : PDFGlyphCollection Class

For a list of all members of this type, see PDFGlyphCollection members.

Public Methods

 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Top

See Also

Reference

PDFGlyphCollection Class
O2S.Components.PDF4NET.Text Namespace


PDFGlyphCollection Class Properties

PDFGlyphCollection Class Properties
[image]
O2S.Components.PDF4NET.Text Namespace : PDFGlyphCollection Class

For a list of all members of this type, see PDFGlyphCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFGlyph>)
Top

See Also

Reference

PDFGlyphCollection Class
O2S.Components.PDF4NET.Text Namespace


PDFSearchTextResultCollection Class Methods

PDFSearchTextResultCollection Class Methods
[image]
O2S.Components.PDF4NET.Text Namespace : PDFSearchTextResultCollection Class

For a list of all members of this type, see PDFSearchTextResultCollection members.

Public Methods

 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Top

See Also

Reference

PDFSearchTextResultCollection Class
O2S.Components.PDF4NET.Text Namespace


PDFSearchTextResultCollection Class Properties

PDFSearchTextResultCollection Class Properties
[image]
O2S.Components.PDF4NET.Text Namespace : PDFSearchTextResultCollection Class

For a list of all members of this type, see PDFSearchTextResultCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFSearchTextResult>)
Top

See Also

Reference

PDFSearchTextResultCollection Class
O2S.Components.PDF4NET.Text Namespace


PDFTextRunCollection Class Methods

PDFTextRunCollection Class Methods
[image]
O2S.Components.PDF4NET.Text Namespace : PDFTextRunCollection Class

For a list of all members of this type, see PDFTextRunCollection members.

Public Methods

 | Name | Description
Public Method | Contains | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Top

See Also

Reference

PDFTextRunCollection Class
O2S.Components.PDF4NET.Text Namespace


PDFTextRunCollection Class Properties

PDFTextRunCollection Class Properties
[image]
O2S.Components.PDF4NET.Text Namespace : PDFTextRunCollection Class

For a list of all members of this type, see PDFTextRunCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.ReadOnlyCollection<PDFTextRun>)
Top

See Also

Reference

PDFTextRunCollection Class
O2S.Components.PDF4NET.Text Namespace


PDF file

PDF4NET Send comments on this topic.
PDF file

Glossary Item Box


PDF support for presentations

PDF4NET Send comments on this topic.
PDF support for presentations

Glossary Item Box

PDF files may include basic presentation features, such as automatic advance to the next page and transition effects when advancing from one page to the next one. In this way, the document can be displayed in the form of a slide show.

The presentation features are controlled by the PDFPageTransition class. This class specifies the type of transition effect between page, the display duration of a page and the transition duration to the next page.

In order to enable the presentation features, each page of the document must have attached a PDFPageTransition object, using the Transition property of the page. The display duration of a page is controlled by the PageDuration property, and the transition duration is controlled by the TransitionDuration property. Both properties are specified in seconds. The TransitionDuration for a page controls the transition between the previous page and that page. This rule also applies to the transition effect.

The PageDuration controls the display duration of a page. If it is zero or the page does not have a transition object, then the viewer does not automatically advance to the next page. Also, the next page must have attached a transition object to specify the transition effect and the transition duration between the first page and the next page, in order to have automatic advance.

Note: The presentation features are optional and may not be implemented by all viewers.


Samples: RandomAccess

PDF4NET Send comments on this topic.
Samples: RandomAccess

Glossary Item Box

Samples

RandomAccess

This sample shows the possibilities of random accessing each page of the document. It creates a document with 10 pages, then the pages are access in a random order. On each page it is written the time of access. To better observe the random access, between page writes, there is a few seconds delay.

C# Source code | PDF file

© 2003 - 2007 O2 Solutions. All rights reserved.


Samples: SlideShow

PDF4NET Send comments on this topic.
Samples: SlideShow

Glossary Item Box

Samples

SlideShow

This samples shows the transition effects available in pdf files. This sample is identical with SimpleGrid sample, but it uses transition effects when passing from one page to another.
This sample uses authors.xml file found in \bin folder.

C# Source code | VB.NET Source code | PDF file

� 2003 - 2007 O2 Solutions. All rights reserved.


Samples: Templates

PDF4NET Send comments on this topic.
Samples: Templates

Glossary Item Box

Samples

Templates

This samples shows template capabilites of the PDF4NET library. A template is created from an existing PDF page. Then it imports a PDF document, adds 10 additional pages and attached the template to the document. The template is drawn under existing page content.

C# Source code | VB.NET Source code | PDF file

© 2003 - 2007 O2 Solutions. All rights reserved.


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you


SlideShow.vb

PDF4NET Send comments on this topic.
SlideShow.vb

Glossary Item Box

''File name: SlideShow.vb'
ImportsSystemImportsSystem.DataImportsSystem.DrawingImportsO2S.Components.PDF4NETImportsO2S.Components.PDF4NET.GraphicsImportsO2S.Components.PDF4NET.Graphics.ShapesNamespaceO2S.Samples.PDF4NET.SlideShow '/ <summary>'/ This sample will show the presentation capabilities'/ of the pdf document. The report in SimpleGrid sample'/ uses now transitions to automatically advance from'/ one page to the next.'/ </summary>ClassSlideShow PrivateSharedleftMargin AsSingle=15PrivateSharedrightMargin AsSingle=15PrivateSharedtopMargin AsSingle=20PrivateSharedminBottomMargin AsSingle=20PrivateSharedrowHeight AsSingle=30PrivateSharedheaderHeight AsSingle=30PrivateSharedfirstPageTopOffset AsSingle=50PrivateSharedcolumnsWidth AsSingle() ={80, 100, 100, 90, 212, 90, 40, 50} PrivateSharedcolumnsHeader AsString() ={"Author ID", "First name", "Last name", "Phone", "Address", "City", "State", "ZIP"} SharedSubMain() 'Create the graphic objectsDimfontTitle AsNewPDFFont(FontFace.Helvetica, 20) DimblackBrush AsNewPDFBrush(NewPDFColor()) 'Create the pdf documentDimpdfDoc AsNewPDFDocument() 'Set the document to be Landscape orientedpdfDoc.PageOrientation =PageOrientation.Landscape 'Create the transition objectDimtrans AsNewPDFPageTransition() trans.Effect =PageTransitionEffect.Box trans.PageDuration =2trans.TransitionDuration =2trans.TransitionMotionDirection =TransitionMotionDirection.Outward 'Create first page of the reportDimpage AsPDFPage =pdfDoc.AddPage() 'Add the transition to the pagepage.Transition =trans 'Draw the title of the reportpage.Canvas.DrawText("Authors - with transition effects", fontTitle, Nothing, blackBrush, page.Width /2, 15, 0, TextAlign.TopCenter) 'Draw report headerDrawReportHeader(page, firstPageTopOffset) 'Create the datasetDimds AsNewDataSet() 'Load the datasetds.ReadXml("authors.xml", XmlReadMode.ReadSchema) 'Get the table from the datasetDimauthors AsDataTable =ds.Tables(0) 'rowOffset - specifies the vertical position where a row'should begin to be printedDimrowOffset AsSingle=firstPageTopOffset +headerHeight Dimi AsIntegerFori =0Toauthors.Rows.Count -1IfrowOffset +rowHeight >page.Height -minBottomMargin Then'not enough space to draw a new row, then create a new page, 'draw the header, then draw the rows.page =pdfDoc.AddPage() 'set the transition effect for the pagepage.Transition =trans DrawReportHeader(page, topMargin) rowOffset =topMargin +headerHeight EndIfDrawReportRow(page, rowOffset, authors.Rows(i)) rowOffset =rowOffset +rowHeight Nexti 'Save the document to diskpdfDoc.SaveToFile("slideshow.pdf") End Sub'MainPrivateSharedSubDrawReportHeader(ByValpdfPage AsPDFPage, ByValtopOffset AsSingle) 'Create the graphic objectsDimfontHeader AsNewPDFFont(FontFace.Helvetica, 12) fontHeader.Bold =TrueDimborderColor AsNewPDFPen(NewPDFColor(), 1) DimtextColor AsNewPDFBrush(NewPDFColor()) DimheaderFill AsNewPDFBrush(NewPDFColor(192, 192, 192)) 'Draw the headerpdfPage.Canvas.DrawRectangle(borderColor, headerFill, topOffset, leftMargin, pdfPage.Width -leftMargin -rightMargin, headerHeight) Dimi AsIntegerDimxOffset AsSingle=leftMargin 'Draw the columns separatorsFori =0To(columnsWidth.Length -1) -1xOffset =xOffset +columnsWidth(i) pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset, xOffset, topOffset +headerHeight) Nexti xOffset =leftMargin 'Draw the columns headerFori =0TocolumnsWidth.Length -1pdfPage.Canvas.DrawText(columnsHeader(i), fontHeader, Nothing, textColor, xOffset +columnsWidth(i) /2, topOffset +headerHeight /2, 0, TextAlign.MiddleCenter) xOffset =xOffset +columnsWidth(i) Nexti End Sub'DrawReportHeaderPrivateSharedSubDrawReportRow(ByValpdfPage AsPDFPage, ByValtopOffset AsSingle, ByValrow AsDataRow) 'Create the graphic objectsDimfontText AsNewPDFFont(FontFace.Helvetica, 12) DimborderColor AsNewPDFPen(NewPDFColor(), 1) DimtextColor AsNewPDFBrush(NewPDFColor()) DimheaderFill AsNewPDFBrush(NewPDFColor(192, 192, 192)) 'Draw rows bordersDimpoints AsPointF() ={NewPointF(leftMargin, topOffset), NewPointF(leftMargin, topOffset +rowHeight), NewPointF(pdfPage.Width -rightMargin, topOffset +rowHeight), NewPointF(pdfPage.Width -rightMargin, topOffset)} pdfPage.Canvas.DrawLines(borderColor, points) Dimi AsIntegerDimxOffset AsSingle=leftMargin 'Draw the columns separatorsFori =0To(columnsWidth.Length -1) -1xOffset =xOffset +columnsWidth(i) pdfPage.Canvas.DrawLine(borderColor, xOffset, topOffset, xOffset, topOffset +rowHeight) Nexti xOffset =leftMargin 'Draw the columns headerFori =0TocolumnsWidth.Length -1pdfPage.Canvas.DrawText(CStr(row(i)), fontText, Nothing, textColor, xOffset +2, topOffset +rowHeight /2, 0, TextAlign.MiddleLeft) xOffset =xOffset +columnsWidth(i) Nexti End Sub'DrawReportRow End Class'SlideShowEnd Namespace'O2S.Samples.PDF4NET.SlideShow


Templates.vb

PDF4NET Send comments on this topic.
Templates.vb

Glossary Item Box

''File name: Templates.vb'
ImportsSystemImportsSystem.DrawingImportsO2S.Components.PDF4NETImportsO2S.Components.PDF4NET.GraphicsImportsO2S.Components.PDF4NET.Graphics.Shapes'/ <summary>'/ This sample will show how to use common content'/ on multiple pages using templates. '/ </summary>ClassTemplates <STAThread()>_ SharedSubMain(ByValargs() AsString) 'The default page size is letterConstwidth AsInteger=612Constheight AsInteger=792'Create the graphic objects DimfontText AsNewPDFFont(FontFace.Helvetica, 12) DimfontTitle AsNewPDFFont(FontFace.Helvetica, 72) DimblackBrush AsNewPDFBrush(NewPDFColor) DimblackPen AsNewPDFPen(NewPDFColor, 1) 'Import a sample pdf documentDimpdfDoc AsNewPDFDocument("sample.pdf") 'Create the template from a PDF file and attach it to the documentDimtmpl AsNewPDFPageTemplate("one-page-template.pdf", 0, 0, 0, width, height) pdfDoc.PageTemplate =tmpl 'Create 10 additional pagesDimi AsIntegerFori =0To9DimpdfPage AsPDFPage =pdfDoc.AddPage() Ifi >0ThenpdfPage.Canvas.DrawText("Page "+i.ToString(), fontTitle, Nothing, blackBrush, pdfPage.Width /2, pdfPage.Height /2, 0, TextAlign.MiddleCenter) EndIfNexti 'Do not apply the template on 6th pagepdfDoc.Pages(5).ApplyTemplate =False'Draw the title on the 6th page (the first of the newly 10 added pages)pdfDoc.Pages(5).Canvas.DrawText("Templates", fontTitle, Nothing, blackBrush, pdfDoc.Pages(0).Width /2, pdfDoc.Pages(0).Height /2, 0, TextAlign.MiddleCenter) 'Save the document to diskpdfDoc.SaveToFile("templates.pdf") End Sub'MainEnd Class'Templates